Borland.StarTeam

Borland StarTeam SDK for .NET

Borland.StarTeam Namespace

Namespace hierarchy

Classes

Class | Description
AccessCheckSecLogID | For Access Check events.
AccessRightsManager

Provides utilities for manipulating access rights.

Access rights information is fetched from the server as necessary, and cached to improve performance of subsequent access tests.
AccessTestResults

Represents the results of an access test.

Indicates whether or not access is granted, and provides an explanation in terms of the EffectiveACEs that were relevant for each tested permission.
ACE | An Access Control List entry. An AclEntry specifies a set of permissions that are either granted or denied to a particular user or group. A collection of such entries makes an ACL or Access Control List.
ACL | A strongly-typed collection of ACEs.
AddResult | The class holds return information specific to the file add operation.
Audit | Represents a StarTeam Audit record
BLSLicenseInfo | A license managed by the Borland License Server.
BLSLicenseInfoCollection | A strongly-typed collection of BLSLicenseInfos.
BuildNumber | A simple class that provides access to version information for the StarTeam SDK. The current version is "StarTeam SDK 11.0, Build 35".
CacheAgent | Describes the features of a Cache Agent, including the type of content it caches, the projects supported, and whether or not it caches file content.
CacheAgentEventArgs
CacheAgentEventSource
CacheController | For each repository accessed via some Server object, we maintain a local cache that holds data fetched from the repository. Normally, when a given cache is no longer referened by any Server object, the cache is discarded, freeing up memory used by the cached data objects. However, "server-oriented" applications, which open and close many Server connections on behalf of various clients, may benefit from keeping these local caches around even after they are no longer referenced by any Server object. This is especially true when MPX is enabled. CacheController allows an application to adjust the behavior of the SDK caching mechanisms as appropriate.
CacheRef | For internal use only.
Catalog | The Catalog class provides "global" access to certain properties of objects from different classes. The catalog provides information about Property values for the primary and secondary descriptors of objects.
ChangeRequest | Represents a StarTeam ChangeRequest item.
ChangeRequestCollection | A strongly-typed collection of ChangeRequests.
CharacterSet | The Character Set of a text file on disk.
CharacterSetCollection | A strongly-typed collection of CharacterSets.
CheckinEventArgs
CheckinEventSource
CheckinManager | Provides a way to check out multiple files, applying a consistent set of options across all files.
CheckinOptions | Maintains the checkout options used by CheckinManager.
CheckinPhase | Information on the phase of a checkin progress of the checkin operation from CheckinManager.
CheckinProgress | Information on the progress of a checkin operation from CheckinManager. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use CheckinManager.getProgress().
CheckInResult | The class holds return information specific to the file checkin operation.
CheckoutEventArgs
CheckoutEventSource
CheckoutManager | Provides a way to check out multiple files, applying a consistent set of options across all files.
CheckoutOptions | Maintains the checkout options used by CheckoutManager.
CheckoutProgress | Information on the progress of a checkout operation from CheckoutManager. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use CheckoutManager.getProgress().
CheckOutResult | The class holds return information specific to the file checkout operation.
ClientApplication | Manages information about the client application. This information is reported to the StarTeam Server for diagnostic purposes. Diagnostic information is used by StarTeam Server versions 6.0 and later.
ClientContext | The ClientContext class contains the nescessary information in order to run the SDK on one machine for a client running on a different machine. This is useful, for example, when running an SDK application within a Web server for a remote browser based client. The information in the ClientContext includes a unique client GUID identitfier, the hostname of the client machine, the client's end-of-line convention, whether or not the client treats file names as case sensitive or not and the string used to delimit directory names within an absolute file path. The Platform class has methods for returning those values on the host running the SDK.
ColumnInfo
ColumnInfoCollection | A strongly-typed collection of ColumnInfos.
CommandAbortedException
CommandException
ConfigFiles | All client stored config file locations for StarTeam can be found using this class.
ConnectionException
ContainerACLSecLogID | For Container-level security log events.
ContentFilterAdapter
CultureInfoCollection | A strongly-typed collection of CultureInfos.
DirectoryOverrides | A class that can parse a StarTeam.ini file and work with the view and folder overrides it specifies.
DisembodiedItemException
DuplicateServerListEntryException
EffectiveACE

An Access Control Entry (ACE) in an Effective Access Control List (ACL).

An EffectiveACE may be an ACE that is explicitly listed in the ACL for an object or for its parent container, or may be implied by group permissions that have been defined, or by object ownership rules, or by the StarTeam access test algorithm itself.

Each EffectiveACE provides information about its origin, including a description in human-readable form.

EffectiveACEs are important with respect to explaining the results of an access test.
EffectiveACL | A strongly-typed collection of EffectiveACEs.
EmailAttachment | This class embodies an email attachment.
EmailAttachmentCollection | A strongly-typed collection of EmailAttachments.
EncryptionAlgorithm | This class provides a convenient place to refer to the different encryption algorithms that can be used for secure StarTeam connections. This class is used by various encryption methods on the connection and server objects. There is also some support for mapping the algorithm to an enum code used by the server. These methods should not be needed by the general user of security.
EnumeratedValue | A simple integer/String pair object to be used for adding new custom enumerated fields (Property) and modifying existing enumerated fields (Property).
EnumeratedValueCollection | A strongly-typed collection of EnumeratedValues.
EOLFormat | The EOL format of a text file on disk.
EOLFormatCollection | A strongly-typed collection of EOLFormats.
EventHandlerInfo | The EventHandlerInfo class describes a registered event handler, such as the one for the StarTeam MPX Server.
EventHandlerProfile | The EventHandlerProfile class contains the information of one of profiles of an EventHandlerInfo.
File | Represents a StarTeam File item.
FileBasedStatusManager | Manages File Status information on the local client workstation.
FileCollection | A strongly-typed collection of Files.
FileDigestAdapter
FileResult | The class holds return information common to the file operations of add, checkin and checkout.
FileStream | Provides utility function for manipulating File streams.
FileSyncInfoAdapter
Filter | The Filter class is used to define criteria for which items (files, change requests) should be displayed to a user. It includes information on which items should be displayed, which properties should be displayed, and how the items should be sorted or grouped. The StarTeam GUI uses filters to determine what items in a folder to display.
FilterCollection | A strongly-typed collection of Filters.
FilterEventArgs
FilterEventSource
Folder | Represents a StarTeam Folder.
FolderCollection | A strongly-typed collection of Folders.
FolderEventArgs
FolderEventSource
FolderListManager | Manages a collection of folders created by including and excluding selected folders and their subfolders. Currently, all folders in the list must belong to the same view. Remembers the set of operations used to create the collection, so that the collection can be refreshed using the latest information from the StarTeam repository.
FolderTreeEventArgs
FolderTreeEventSource
FolderUpdateEventArgs
FolderUpdateEventSource
ForeignPasswordException
ForeignRefreshResult | The class holds return information specific to the "foreign" refresh operation.
Group | Represents a StarTeam Group. Only a limited subset of the whole group information is available. The GroupAccount class has the full group information but it is only accessible to user's with the appropriate permissions.
GroupAccount | This class represents a full StarTeam Group account. New groups can be added to a StarTeam Server and existing groups can be modified through this class. Whereas the Group class only provides access to a group's name and ID, the GroupAccount supports access to all information about a group. All users can obtain Group information but only users with the appropriate permissions can access GroupAccount information.
GroupAccountCollection | A strongly-typed collection of GroupAccounts.
GroupCollection | A strongly-typed collection of Groups.
GroupNode | Describes a group of objects that may be a subgroup of a larger, indexable group. Maintains a range mapping into the underlying ordered collection. Each Node may be in an expanded or collapsed state. Note that it is the client's responsibility to ensure valid index ranges relative to the underlying collection.
GroupNodeCollection | A strongly-typed collection of GroupNodes.
GroupSortInfo
GroupSortInfoCollection | A strongly-typed collection of GroupSortInfos.
HistoryKeyword
HistoryLine | A class containing information specific to a single version entry for expansion of the $History$ keyword.
HiveInfo | Describes a vault hive on the server.
HiveInfo.HiveType
HiveInfoCollection | A strongly-typed collection of HiveInfos.
HiveManager | Manages vault hives on the server.
IOExceptionCollection | A strongly-typed collection of IOExceptions.
IPRange | This class represents a range of TCP/IP addresses and the required level of encryption for clients to connect to the StarTeam server.
IPRangeCollection | A strongly-typed collection of IPRanges.
ISecurableAdapter
ISecurableContainerAdapter
ISecurableObjectAdapter
Item | Contextual reference to an object in a StarTeam repository. Items provide transparent access to the underlying entity (e.g., modifying the description of an item by calling Item.put("Description", "some text") actually modifies the Desription property of the underlying entity the Item references. An Item consists of the underlying entity and its context within a view. Therefore, an Item has direct knowledge of the items to which it is related. Items also maintain state information to determine if the underlying object is is new or modified relative to instances of the object stored in the repository. An Item also has a temporal aspect in that it represents a single development path (linear history) of the underlying object as of a moment in time.
Item.LockType
ItemBehavior | A class that represents the behavior of an Item.
ItemCollection
ItemEventArgs
ItemEventSource
ItemIDEventArgs
ItemIDEventSource
ItemListAdapter
ItemListEventArgs
ItemListEventSource
ItemListManager | Generates and manages a list of Items. All Items in the item list have a given type. Items are generated from a list of folders determined by a FolderListManager. The item list can be filtered, sorted, refreshed, queried, and so on. Items are retrieved via getItems() or getItemsArray(), which are optimized to do as little work as possible. For example, if only the sort order has changed since the last time the item list was retrieved, then the existing items in the list are resorted only.
ItemNotFoundException
ItemReference
ItemReferenceCollection | A strongly-typed collection of ItemReferences.
ItemRevision | A ItemRevision represents a View member level revision of an item. Such revisions are created when one modifies the view level properties of a particular share of the item. These would be operations like: 1. changing the item branch behavior 2. changing the item configuration 3. branching the item 4. moving the item
ItemRevisionCollection | A strongly-typed collection of ItemRevisions.
ItemsAdapter
ItemUpdateEventArgs
ItemUpdateEventSource
KeywordAdapter
KeywordCollection | A strongly-typed collection of Keywords.
KeywordReader
Label | Represents a named configuration of Items. Labels may be applied to an entire View or to individual item versions.
LabelCollection | A strongly-typed collection of Labels.
LabelEventArgs
LabelEventSource
LicenseUsage | This class is a simple container for StarTeam license usage information.
Link | Represents an instance of an association between two items.
LinkCache | Caches links for a given set of items. One LinkCache may be populated with links from multiple view configurations on multiple servers.
LinkCollection | A strongly-typed collection of Links.
LinkEndpoint | Represents a link reference to an item.
LinkFactory | Supports bulk link creation, on servers that support it.
LinkUpdateEventArgs
LinkUpdateEventSource
LogKeyword | An implementation of the StarTeam $Log$ keyword.
LogLine | A class containing information specific to a single version entry for expansion of the $Log$ keyword.
LogLineCollection | A strongly-typed collection of LogLines.
LogonException
MatchedACE

Used when explaining the results of an access test.

Each MatchedACE provides a subset of the permissions that were tested, as well as the corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.
MatchedACECollection | A strongly-typed collection of MatchedACEs.
MergePoint | This class provides information about how two item revisions are related with respect to merging. Suppose the file "foo.txt" branches at revision 1.3 to create a new revision 1.3.1.0. A checkin on the main branch will create revision 1.4 and a subsequent checkin on the alternate branch will create revision 1.3.1.1. If the user then merges the changes between 1.3 to 1.4 in to a new branch revision 1.3.1.2 a MergePoint can be used to record the sources used to create this new revision. In this case the MergePoint would have a source RevisionID corresponding to the 1.4 revision of "foo.txt" and a target RevisionID corresponding to the 1.3.1.2 revision of "foo.txt".
MergePointCollection | A strongly-typed collection of MergePoints.
MPXException
MPXStatusEventArgs
MPXStatusEventSource
MyUserAccount | This class represents the user account information that every user can specify/modify about themselves. The basic proceedure is to call the Server.getMyUserAccount, then modify the appropriate fields then call update() on the object to save the changes on the server.
NetMonitor | Displays information about the commands that are being sent to the StarTeam Server. This may be useful in diagnosing performance problems.
NoKeywords | A special Keyword implementation that halts keyword expansion for the rest of a file when encountered. The keyword is $NoKeywords$
NoSuchPropertyException
NotificationEventArgs
NotificationEventSource
NotificationItem | This class bundles together information about new "notification" items of a particular type in a particular view that the user may be interested in knowing about.
NotificationItemCollection | A strongly-typed collection of NotificationItems.
ObjectACLSecLogID | For Object ACL events.
PasswordExpiredException
Permission | This interface contains fields defining all the different permission settings used by StarTeam.
ProcessItem | A process item in the context of a given target view.
ProcessItemUsage | Indicates the type of operation that created a given process task and its associated process links.
ProductCodes | This class defines constant values for the various StarTeam product codes.
Project | Represents a StarTeam project which is essentially just a collection of Views.
ProjectCollection | A strongly-typed collection of Projects.
ProjectEventArgs
ProjectEventSource
PromotionModel | This class represents the Promotion model for a view. Each view has a single promotion model. The PromotionModel class primarily acts as the owner of an ordered list of PromotionStates.
PromotionState | This class represents a promotion state associated with a promotion model. This class has no update() method so to save new or modified promotion states you must use PromotionModel.update()
PromotionStateCollection | A strongly-typed collection of PromotionStates.
Property | Each different Type supported by a StarTeam Server (e.g. File, Change Request, Topic...) has an associated set of properties. The Property class provides information about a Type's property.
Property.Types
PropertyCollection | A strongly-typed collection of Propertys.
PropertyEnums | This class provides a conventient place to get the values of various built-in StarTeam enumerated item properties. The member variables here should be used instead of hard-coded numeric values. This does lead to a bit of indirection but is the safest way of being sure you are using the right enumerated value. This class also insulates you from any enumerated value changes that could occur from one release of StarTeam to the next.
PropertyNames | This class provides a conventient place to get the names of various built-in StarTeam Item (and some non-item) property names. The member variables here should always be used instead of hard-coded String values. For example, on a File Item you should not call get("Name") to get the name property but rather file.get(file.getPropertyNames().FILE_NAME); This does lead to a bit of indirection but is the safest way of being sure you are using the right property name. This class also insulates you from any property name changes that could occur from one release of StarTeam to the next.
PropertyNotWritableException
PurgeControl | Provides control over the Online Purge service. The service may be configured to start automatically when the server starts up. If configured to do so, it will run a purge in the background while the server is running. This eliminates the requirement for costly down time just to purge the starteam repository. The online purge will not affect any resources deleted during the current active server session. Access the purge log by issuing a writeLogFile command with a logType value of 1.
PurgeStatus | Describes the current state of the purge service
PurgeStatusCollection | A strongly-typed collection of PurgeStatuss.
Query | The QueryInfo class implements a query condition to be applied to items of a certain type. QueryInfo objects are used in conjunction with Filter objects for describing what items to display to the user and how to display them.
QueryCollection | A strongly-typed collection of Querys.
QueryEventArgs
QueryEventSource
QueryNode | A QueryNode represents a boolean expression. The expression is applied to an item to determine if the query is true of the item or not.
QueryNodeCollection | A strongly-typed collection of QueryNodes.
QueryPart | A QueryPart object represents a boolean expression on the value of a particular property of an item. For example, it could be used to define query to match file objects whose name starts with a specific string.
QueryPartCollection | A strongly-typed collection of QueryParts.
RecycleBin
RevisionID | A simple class representing a unique revision of an Item in the repository. For items of the same type revisions can be uniquely int a repository byte the item's objectID and revision number.
RevisionIdentifierAdapter
SDKRuntimeException
SDKWrapper
SecurableContainerAdapter | An implementation of ISecurableContainer that can be used as a wrapper for the object returned by getParentContainer(), for classes whose wrapped getParentContainer() method does not return an instance of a public class; for instance Filter and QueryInfo.
SecurityLogEntry
SecurityLogEntry.SecurityEventType
SecurityLogEntryCollection | A strongly-typed collection of SecurityLogEntrys.
Server | The Server class provides network access to a remote StarTeam Server. It only supports access through TCP/IP sockets and has the ability to encrypt and compress all communication between the client server.
ServerAdministration | The ServerAdministration class provides a convenient interface to perform various server level administration commands. The current set of operations are for field customization. Ultimately these methods should hang off of the core Type and Property objects but the refresh issues are too complex to deal with at this time. After calling any of the customization methods one should do a FULL refresh by discarding everything including the Server object itself and start over.
ServerCommandEventArgs
ServerCommandEventSource
ServerConfiguration
ServerControlEventArgs
ServerControlEventSource
ServerException
ServerInfo
ServerInfoCollection | A strongly-typed collection of ServerInfos.
ServerLicenseInfo | Information about the licenses registered on a StarTeam Server.
ServerList | This class is used to manage a list of ServerInfo objects. Methods to read and write the server list to a file are supported. The server list file is also used by the StarTeam GUI.
ServerSessionAdapter
ServerUnavailableException
SimpleKeyword | A Keyword object that encapsulates information about a File keyword. When checking a file is added, checked-in or checked-out of the repository keyword expansion may be applied to the contents of the file. For example, an occurance of $Author$ in a file might be be replaced with $Author: Fred$ upon checkout.
SimpleTypedResource | A simple implementation of the TypedResource class.
StarTeamClientOptions
StarTeamFinder | A utility class for easily obtaining a connection to a StarTeam server and finding various objects like projects, views, folders and files.
StarTeamURL

StarTeamURL uses a URL-like syntax to reference a StarTeam Server, Project, View or Folder. Used in conjunction with StarTeamFinder, it provides a convenient way to locate important StarTeam objects.

StarTeamURL supports the following syntax:

starteam://username:password@hostname:port/Project/View/FolderA/FolderB/...

The "starteam://" prefix is optional.

Alternatively, the following syntax is also supported:

starteam://username:password@server/Project/View/FolderA/FolderB/...

Thus, if no ":port" is specified, the hostname is interpreted as a server description. The description is looked up in the server list, and, if found, the connection information from the server list (host address, port, encryption and compression settings, and MPX profile name) are used to establish the server connection.
Status | Represents the status of a working file relative to its corresponding file in the repository.
StatusMethod

This class provides information about how file status is managed for the client. Prior to StarTeam 5.2 all file status information was stored on the StarTeam Server. In 5.2 this staus information moved to the client. There are two ways in which that status information can be stored. These are refered to as "Per folder" and "Central"

"Per folder" status information is stored as close to the source file as possible. Assuming a file under revision control is stored in C:/project/foo.txt then the status information for that file will be stored in C:/project/.sbas/SyncDB. In fact, the status information for all files under C:/project will be stored in the file. There are a number of advantages of storing it in this location. For example, whole local folder structures may be moved or copied to new locations and all the status information will go along with it. The downside to this scheme is that in some cases users will not want the .sbas folders mixed in with the source files they are managing with StarTeam.

"Central" status information is all stored under a single user specified directory on the client's machine. This keeps the status information away from the user's source files. The downside to this approach is that you cannot easily move or copy source directories and have status information go along with it.

Users may specify which of these two methods to use by default along with the location of the central status information. Additionaly, users may override this on a per-View basis.
SupportedFeatures | The SupportedFeatures class contains a number of methods that report whether or not a particular feature is available for a StarTeam server.
SystemPolicy
SystemRevisionNumbers
Task | Represents a StarTeam Task item.
TaskDependency | This is a class representing a dependency between two tasks.
TaskDependencyCollection | A strongly-typed collection of TaskDependencys.
Topic | Represents a StarTeam Topic.
Translations | The Translations class defines the possible localized translations of a particular resource. There is the notion of a default translation which should be used when no translation exists for a particular language. In addition to the default there may be any number of specific localizations defined on a per-locale basis.
TreeItem | A type of item with children.
Type | Information describing certain StarTeam object types.
TypeCollection | A strongly-typed collection of Types.
TypedResource | This is a parent interface for many instances of StarTeam types (e.g. File, ChangeRequest). The interface describes objects that have property/value pairs. Each TypedResource is associated with the properties from a Type object. A TypedResource has a constraint that only valid Type properties may be used for set/get and that type checking for set will be enforced.
TypeEventArgs
TypeEventSource
TypeNames | TypeNames is a class defining pseudo-constants for the names of various types in StarTeam.
TypeNotFoundException
User | Represents a StarTeam user. Only a limited subset of the whole user information is available. The UserAccount class has the full user information but it is only accessible to user's with the appropriate permissions.
UserAccount | Represents a StarTeam user account. That is, an active user account on a StarTeam Server. This is not to be confused with a User object which simply represents a user that does participate or has participated in operations on the items in the repository.
UserAccountCollection | A strongly-typed collection of UserAccounts.
UserCollection | A strongly-typed collection of Users.
UserEventArgs
UserEventSource
UserGroupSecLogID | For User-based security log events.
View | Represents a StarTeam View.
ViewCollection | A strongly-typed collection of Views.
ViewConfiguration | A class that represents the possible configuration states for a View. A StarTeam View can be in one of four different configurations: Current: all items in the view are the most recent or "tip" versions, Label: all items reference the version with the specified label attached, Time: all items reference the version that was tip as of some time, Promotion: like a label-based view but with respect to some promotion state.
ViewConfigurationDiffer

Used to compare two configurations of a given view, triggering FolderUpdateEvents and ItemUpdateEvents describing the changes detected between the two.

Events are triggered only for differences detectable by comparing the two view configurations. For example, if an item was added sometime after the time represented by the first configuration, and then removed sometime before the time represented by the second configuration, then no events would be triggered for that item.

Events are triggered in an order that reflects the times the change actually occurred, when possible. For some older server versions, and for some types of view configurations, it is not currently possible to determine when a move has occurred. It is also not currently possible to determine when a folder or item was removed. Such events are triggered last.
ViewEventArgs
ViewEventSource
ViewPollingAgent

Used to periodically poll a given view for recent changes, triggering FolderUpdateEvents and ItemUpdateEvents describing the changes detected since the last poll.

Events are triggered only for differences detectable across the polling interval. For example, if an item is added then removed without an intervening refresh, then no events would be triggered for that item.

Events are triggered in an order that reflects the times the change actually occurred, when possible. For some older server versions, it is not possible to determine when a move has occurred. It is also not currently possible to determine when a folder or item was removed. Such events are triggered last.

There are two basic ways to use a ViewPollingAgent. The first way is to create one and keep it around for a long time, periodically calling refresh() to trigger events. This is generally faster than creating a new ViewPollingAgent for each refresh(). However, the ViewPollingAgent consumes memory while it is in use.

The second way is to create a new ViewPollingAgent at each polling interval, call refresh() once to trigger events, and save the time returned by refresh() to use later when creating a ViewPollingAgent for the next poll. This is slower, but uses less memory between polls.
WorkRecord | Record of a period of work expended for a task.
WorkRecordCollection | A strongly-typed collection of WorkRecords.
Workstation

Interfaces

Interface | Description
ContentFilter | Allows an application to hook into the checkout process at a low level. getOutputStream() is called for each file as it is checked out. OutputStream is the stream where content is written; the application may wrap this stream to transform content as it sees fit.
FileDigest | The FileDigest interface specifies the nescessary information to determine if a file on disk has changed from some checkpoint. There are three pieces of information that can be used to determine this: the file's lastModified time, the file size, and a checksum of the file's contents.
FileSyncInfo | The FileSyncInfo interface specifies the pairing of the two important pieces of information needed to know what is on a user's local disk: RevisionIdentifier and FileDigest. This information is needed to compute a File's status.
ISecurable | An object that can be secured in the repository.
ISecurableContainer | A container in the repository that can hold secured objects of a given type.
ISecurableObject | An object that can be secured in the repository.
Keyword | A Keyword object that encapsulates information about a File keyword. When a file is added, checked-in or checked-out of the repository keyword expansion may be applied to the contents of the file. For example, an occurance of $Author$ in a file might be be replaced with $Author: Fred$ upon checkout.
RevisionIdentifier | The RevisionIdentifier interface globally and uniquely identifies a specific revision of a StarTeam object.
ServerSession | Represents a user's session with the server. Note: Though this class is public, it is for internal use only.

Delegates

Delegate | Description
CacheAgentEventSource.Handler |
CheckinEventSource.Handler |
CheckoutEventSource.Handler |
FilterEventSource.Handler |
FolderEventSource.Handler |
FolderTreeEventSource.Handler |
FolderUpdateEventSource.Handler |
ItemEventSource.Handler |
ItemIDEventSource.Handler |
ItemListEventSource.Handler |
ItemUpdateEventSource.Handler |
LabelEventSource.Handler |
LinkUpdateEventSource.Handler |
MPXStatusEventSource.Handler |
NotificationEventSource.Handler |
ProjectEventSource.Handler |
QueryEventSource.Handler |
ServerCommandEventSource.Handler |
ServerControlEventSource.Handler |
TypeEventSource.Handler |
UserEventSource.Handler |
ViewEventSource.Handler |

Copyright 2004, Borland Corp.


AccessCheckSecLogID Class

For Access Check events.

For a list of all members of this type, see AccessCheckSecLogID Members.

System.Object
AccessCheckSecLogID

public class AccessCheckSecLogID : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

AccessCheckSecLogID Members | Borland.StarTeam Namespace

Generated from assembly Borland.StarTeam [11.0.0.35]


AccessCheckSecLogID Members

AccessCheckSecLogID overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.AccessCheckSecLogID.

Public Static Type Conversions

Implicit AccessCheckSecLogID to AccessCheckSecLogID Conversion Implicitly convert AccessCheckSecLogID to com.starbase.starteam.AccessCheckSecLogID.

Public Instance Constructors

AccessCheckSecLogID Constructor Construct AccessCheckSecLogID from com.starbase.starteam.AccessCheckSecLogID.

Public Instance Properties

ClassID | [read] The class id.
ObjectID | [read] The object id.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.AccessCheckSecLogID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.AccessCheckSecLogID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.AccessCheckSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


AccessCheckSecLogID Constructor

Construct AccessCheckSecLogID from com.starbase.starteam.AccessCheckSecLogID.

public AccessCheckSecLogID(
AccessCheckSecLogID impl
);

Parameters

impl
The com.starbase.starteam.AccessCheckSecLogID to be wrapped.

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


AccessCheckSecLogID Properties

The properties of the AccessCheckSecLogID class are listed below. For a complete list of AccessCheckSecLogID class members, see the AccessCheckSecLogID Members topic.

Public Instance Properties

ClassID | [read] The class id.
ObjectID | [read] The object id.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


ClassID Property

Borland StarTeam SDK for .NET

AccessCheckSecLogID.ClassID Property

[read] The class id.

public virtual Int32 ClassID {get;}

Property Value

The class id.

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

AccessCheckSecLogID.ObjectID Property

[read] The object id.

public virtual Int32 ObjectID {get;}

Property Value

The object id.

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


AccessCheckSecLogID Methods

The methods of the AccessCheckSecLogID class are listed below. For a complete list of AccessCheckSecLogID class members, see the AccessCheckSecLogID Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.AccessCheckSecLogID.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.AccessCheckSecLogID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.AccessCheckSecLogID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.AccessCheckSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


AccessCheckSecLogID.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.AccessCheckSecLogID

Implements

IWrapper.Unwrap

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


AccessCheckSecLogID.Equals Method

Delegate Equals() to com.starbase.starteam.AccessCheckSecLogID.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.AccessCheckSecLogID.Equals(obj).

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


AccessCheckSecLogID.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.AccessCheckSecLogID.

public override int GetHashCode();

Return Value

com.starbase.starteam.AccessCheckSecLogID.GetHashCode().

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


AccessCheckSecLogID.ToString Method

Delegate ToString() to com.starbase.starteam.AccessCheckSecLogID.

public override string ToString();

Return Value

com.starbase.starteam.AccessCheckSecLogID.ToString()

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


AccessCheckSecLogID.Wrap Method

Dynamically wraps com.starbase.starteam.AccessCheckSecLogID.

public static AccessCheckSecLogID Wrap(
AccessCheckSecLogID impl
);

Parameters

impl
com.starbase.starteam.AccessCheckSecLogID to be wrapped.

Return Value

AccessCheckSecLogID

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


AccessCheckSecLogID Type Conversions

The type conversions of the AccessCheckSecLogID class are listed below. For a complete list of AccessCheckSecLogID class members, see the AccessCheckSecLogID Members topic.

Public Static Type Conversions

Implicit AccessCheckSecLogID to AccessCheckSecLogID Conversion Implicitly convert AccessCheckSecLogID to com.starbase.starteam.AccessCheckSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AccessCheckSecLogID Class | AccessCheckSecLogID Members | Borland.StarTeam Namespace


AccessCheckSecLogID Implicit AccessCheckSecLogID to AccessCheckSecLogID Conversion

Implicitly convert AccessCheckSecLogID to com.starbase.starteam.AccessCheckSecLogID.

public static implicit operator AccessCheckSecLogID(
AccessCheckSecLogID arg
);

Parameters

arg
AccessCheckSecLogID to convert.

Return Value

com.starbase.starteam.AccessCheckSecLogID

See Also

AccessCheckSecLogID Class | Borland.StarTeam Namespace


AccessRightsManager Class

Provides utilities for manipulating access rights.

Access rights information is fetched from the server as necessary, and cached to improve performance of subsequent access tests.

For a list of all members of this type, see AccessRightsManager Members.

System.Object
AccessRightsManager

public class AccessRightsManager : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

AccessRightsManager Members | Borland.StarTeam Namespace


AccessRightsManager Members

AccessRightsManager overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.AccessRightsManager.

Public Static Type Conversions

Implicit AccessRightsManager to AccessRightsManager Conversion Implicitly convert AccessRightsManager to com.starbase.starteam.AccessRightsManager.

Public Instance Constructors

AccessRightsManager Overloaded. Initializes a new instance of the AccessRightsManager class.

Public Instance Methods

AccessTest | Overloaded. Performs an access test against the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.
Discard | Discards cached access rights information. Access rights information will be fetched from the server as needed.
Equals | Delegate Equals() to com.starbase.starteam.AccessRightsManager.
GetEffectiveACL | Gets the effective access control list for the given securable object. The effective access control list completely encompasses all information used by the server to perform an access test for the given object. This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.
GetEffectiveContainerACL | Gets the effective access control list for objects of a given type in a given securable container. The effective access control list completely encompasses all information used by the server to perform an access test for the given object. This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.AccessRightsManager.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAccessGranted | Overloaded. Determines whether or not the given user is granted the given permissions to the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.
Refresh | Refreshes cached access rights information to reflect recent changes to the server.
ToString | Delegate ToString() to com.starbase.starteam.AccessRightsManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AccessRightsManager Class | Borland.StarTeam Namespace


AccessRightsManager Constructor

Construct AccessRightsManager from com.starbase.starteam.AccessRightsManager.

Overload List

Creates a new access rights manager for the given server.

public AccessRightsManager(Server);

Construct AccessRightsManager from com.starbase.starteam.AccessRightsManager.

public AccessRightsManager(AccessRightsManager);

See Also

AccessRightsManager Class | Borland.StarTeam Namespace


AccessRightsManager Constructor (AccessRightsManager)

Construct AccessRightsManager from com.starbase.starteam.AccessRightsManager.

public AccessRightsManager(
AccessRightsManager impl
);

Parameters

impl
The com.starbase.starteam.AccessRightsManager to be wrapped.

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | AccessRightsManager Constructor Overload List


AccessRightsManager Constructor (Server)

Creates a new access rights manager for the given server.

public AccessRightsManager(
Server s
);

Parameters

s
The server whose access rights are to be managed.

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | AccessRightsManager Constructor Overload List


AccessRightsManager Methods

The methods of the AccessRightsManager class are listed below. For a complete list of AccessRightsManager class members, see the AccessRightsManager Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.AccessRightsManager.

Public Instance Methods

AccessTest | Overloaded. Performs an access test against the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.
Discard | Discards cached access rights information. Access rights information will be fetched from the server as needed.
Equals | Delegate Equals() to com.starbase.starteam.AccessRightsManager.
GetEffectiveACL | Gets the effective access control list for the given securable object. The effective access control list completely encompasses all information used by the server to perform an access test for the given object. This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.
GetEffectiveContainerACL | Gets the effective access control list for objects of a given type in a given securable container. The effective access control list completely encompasses all information used by the server to perform an access test for the given object. This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.AccessRightsManager.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAccessGranted | Overloaded. Determines whether or not the given user is granted the given permissions to the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.
Refresh | Refreshes cached access rights information to reflect recent changes to the server.
ToString | Delegate ToString() to com.starbase.starteam.AccessRightsManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AccessRightsManager Class | Borland.StarTeam Namespace


AccessTest Method

Borland StarTeam SDK for .NET

AccessRightsManager.AccessTest Method

Determines whether or not the given user is granted the given permissions to a securable object with the given access control list.

Overload List

Determines whether or not the given user is granted the given permissions to a securable object with the given access control list.

public virtual AccessTestResults AccessTest(Int32,Int32,EffectiveACL);

Performs an access test against the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.

public virtual AccessTestResults AccessTest(Int32,Int32,ISecurable);

Performs an access test against the given securable container. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.

public virtual AccessTestResults AccessTest(Int32,Int32,ISecurableContainer,Type);

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | EffectiveACE | AccessTestResults | getEffectiveACL


AccessRightsManager.AccessTest Method (Int32, Int32, EffectiveACL)

Determines whether or not the given user is granted the given permissions to a securable object with the given access control list.

public virtual AccessTestResults AccessTest(
Int32 userID,
Int32 permissions,
EffectiveACL acl
);

Parameters

userID
The userID of the user for which the access test is performed.
permissions
The set of permission flags to be tested.
acl
The access control list against which the test is performed.

Return Value

A detailed explanation of the results of the access test.

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | AccessRightsManager.AccessTest Overload List | EffectiveACE | AccessTestResults | getEffectiveACL


AccessRightsManager.AccessTest Method (Int32, Int32, ISecurable)

Performs an access test against the given securable object.

Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.

public virtual AccessTestResults AccessTest(
Int32 userID,
Int32 permissions,
ISecurable obj
);

Parameters

userID
The userID of the user for which the access test is performed.
permissions
The set of permission flags to be tested.
obj
The securable object against which the test is performed.

Return Value

A detailed explanation of the results of the access test.

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | AccessRightsManager.AccessTest Overload List | ISecurable | AccessTestResults | getEffectiveACL | accessTest


AccessRightsManager.AccessTest Method (Int32, Int32, ISecurableContainer, Type)

Performs an access test against the given securable container.

Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.

public virtual AccessTestResults AccessTest(
Int32 userID,
Int32 permissions,
ISecurableContainer container,
Type type
);

Parameters

userID
The userID of the user for which the access test is performed.
permissions
The set of permission flags to be tested.
container
The securable container against which the test is performed.
type
The type of object for which the test is performed.

Return Value

A detailed explanation of the results of the access test.

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | AccessRightsManager.AccessTest Overload List | ISecurable | AccessTestResults | getEffectiveContainerACL | accessTest


AccessRightsManager.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.AccessRightsManager

Implements

IWrapper.Unwrap

See Also

AccessRightsManager Class | Borland.StarTeam Namespace


AccessRightsManager.Discard Method

Discards cached access rights information. Access rights information will be fetched from the server as needed.

public virtual void Discard();

See Also

AccessRightsManager Class | Borland.StarTeam Namespace


AccessRightsManager.Equals Method

Delegate Equals() to com.starbase.starteam.AccessRightsManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.AccessRightsManager.Equals(obj).

See Also

AccessRightsManager Class | Borland.StarTeam Namespace


AccessRightsManager.GetEffectiveACL Method

Gets the effective access control list for the given securable object.

The effective access control list completely encompasses all information used by the server to perform an access test for the given object.

This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.

public virtual EffectiveACL GetEffectiveACL(
ISecurable obj
);

Parameters

obj
A securable object.

Return Value

The effective access control list for the given securable object.

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | ISecurable | EffectiveACE | isAccessGranted | accessTest


AccessRightsManager.GetEffectiveContainerACL Method

Gets the effective access control list for objects of a given type in a given securable container.

The effective access control list completely encompasses all information used by the server to perform an access test for the given object.

This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.

public virtual EffectiveACL GetEffectiveContainerACL(
ISecurableContainer container,
Type type
);

Parameters

container
A securable container.
type
The object type.

Return Value

The effective access control list for the given securable object.

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | ISecurableContainer | EffectiveACE | isAccessGranted | accessTest


AccessRightsManager.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.AccessRightsManager.

public override int GetHashCode();

Return Value

com.starbase.starteam.AccessRightsManager.GetHashCode().

See Also

AccessRightsManager Class | Borland.StarTeam Namespace


IsAccessGranted Method

Borland StarTeam SDK for .NET

AccessRightsManager.IsAccessGranted Method

Determines whether or not the given user is granted the given permissions to a securable object with the given access control list.

Overload List

Determines whether or not the given user is granted the given permissions to a securable object with the given access control list.

public virtual bool IsAccessGranted(Int32,Int32,EffectiveACL);

Determines whether or not the given user is granted the given permissions to the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.

public virtual bool IsAccessGranted(Int32,Int32,ISecurable);

Determines whether or not the given user is granted the given permissions to the given securable container. Determining the effective access control list for a securable container is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.

public virtual bool IsAccessGranted(Int32,Int32,ISecurableContainer,Type);

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | EffectiveACE | getEffectiveACL


AccessRightsManager.IsAccessGranted Method (Int32, Int32, EffectiveACL)

Determines whether or not the given user is granted the given permissions to a securable object with the given access control list.

public virtual bool IsAccessGranted(
Int32 userID,
Int32 permissions,
EffectiveACL acl
);

Parameters

userID
The userID of the user for which the access test is performed.
permissions
The set of permission flags to be tested.
acl
The access control list against which the test is performed.

Return Value

true if the user is granted all the requested permissions; false if at least one of the requested permissions is denied.

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | AccessRightsManager.IsAccessGranted Overload List | EffectiveACE | getEffectiveACL


AccessRightsManager.IsAccessGranted Method (Int32, Int32, ISecurable)

Determines whether or not the given user is granted the given permissions to the given securable object.

Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.

public virtual bool IsAccessGranted(
Int32 userID,
Int32 permissions,
ISecurable obj
);

Parameters

userID
The userID of the user for which the access test is performed.
permissions
The set of permission flags to be tested.
obj
The securable object against which the test is performed.

Return Value

true if the user is granted all the requested permissions; false if at least one of the requested permissions is denied.

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | AccessRightsManager.IsAccessGranted Overload List | ISecurable | getEffectiveACL | isAccessGranted


AccessRightsManager.IsAccessGranted Method (Int32, Int32, ISecurableContainer, Type)

Determines whether or not the given user is granted the given permissions to the given securable container.

Determining the effective access control list for a securable container is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.

public virtual bool IsAccessGranted(
Int32 userID,
Int32 permissions,
ISecurableContainer container,
Type type
);

Parameters

userID
The userID of the user for which the access test is performed.
permissions
The set of permission flags to be tested.
container
The securable container against which the test is performed.
type
The type of object for which the test is performed.

Return Value

true if the user is granted all the requested permissions; false if at least one of the requested permissions is denied.

See Also

AccessRightsManager Class | Borland.StarTeam Namespace | AccessRightsManager.IsAccessGranted Overload List | ISecurable | getEffectiveContainerACL | isAccessGranted


AccessRightsManager.Refresh Method

Refreshes cached access rights information to reflect recent changes to the server.

public virtual void Refresh();

See Also

AccessRightsManager Class | Borland.StarTeam Namespace


AccessRightsManager.ToString Method

Delegate ToString() to com.starbase.starteam.AccessRightsManager.

public override string ToString();

Return Value

com.starbase.starteam.AccessRightsManager.ToString()

See Also

AccessRightsManager Class | Borland.StarTeam Namespace


AccessRightsManager.Wrap Method

Dynamically wraps com.starbase.starteam.AccessRightsManager.

public static AccessRightsManager Wrap(
AccessRightsManager impl
);

Parameters

impl
com.starbase.starteam.AccessRightsManager to be wrapped.

Return Value

AccessRightsManager

See Also

AccessRightsManager Class | Borland.StarTeam Namespace


AccessRightsManager Type Conversions

The type conversions of the AccessRightsManager class are listed below. For a complete list of AccessRightsManager class members, see the AccessRightsManager Members topic.

Public Static Type Conversions

Implicit AccessRightsManager to AccessRightsManager Conversion Implicitly convert AccessRightsManager to com.starbase.starteam.AccessRightsManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AccessRightsManager Class | AccessRightsManager Members | Borland.StarTeam Namespace


AccessRightsManager Implicit AccessRightsManager to AccessRightsManager Conversion

Implicitly convert AccessRightsManager to com.starbase.starteam.AccessRightsManager.

public static implicit operator AccessRightsManager(
AccessRightsManager arg
);

Parameters

arg
AccessRightsManager to convert.

Return Value

com.starbase.starteam.AccessRightsManager

See Also

AccessRightsManager Class | Borland.StarTeam Namespace


AccessTestResults Class

Represents the results of an access test.

Indicates whether or not access is granted, and provides an explanation in terms of the EffectiveACEs that were relevant for each tested permission.

For a list of all members of this type, see AccessTestResults Members.

System.Object
AccessTestResults

public class AccessTestResults : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

AccessTestResults Members | Borland.StarTeam Namespace


AccessTestResults Members

AccessTestResults overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.AccessTestResults.

Public Static Type Conversions

Implicit AccessTestResults to AccessTestResults Conversion Implicitly convert AccessTestResults to com.starbase.starteam.AccessTestResults.

Public Instance Constructors

AccessTestResults Constructor Construct AccessTestResults from com.starbase.starteam.AccessTestResults.

Public Instance Properties

Explanation | [read] An explanation of why access was granted or denied, in terms of the EffectiveACEs that were relevant for each tested permission. Each tested permission appears in exactly one of the MatchedACEs.
IsGranted | [read] true if access was granted; false if access was denied.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.AccessTestResults.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.AccessTestResults.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.AccessTestResults.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AccessTestResults Class | Borland.StarTeam Namespace


AccessTestResults Constructor

Construct AccessTestResults from com.starbase.starteam.AccessTestResults.

public AccessTestResults(
AccessTestResults impl
);

Parameters

impl
The com.starbase.starteam.AccessTestResults to be wrapped.

See Also

AccessTestResults Class | Borland.StarTeam Namespace


AccessTestResults Properties

The properties of the AccessTestResults class are listed below. For a complete list of AccessTestResults class members, see the AccessTestResults Members topic.

Public Instance Properties

Explanation | [read] An explanation of why access was granted or denied, in terms of the EffectiveACEs that were relevant for each tested permission. Each tested permission appears in exactly one of the MatchedACEs.
IsGranted | [read] true if access was granted; false if access was denied.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AccessTestResults Class | Borland.StarTeam Namespace


Explanation Property

Borland StarTeam SDK for .NET

AccessTestResults.Explanation Property

[read] An explanation of why access was granted or denied, in terms of the EffectiveACEs that were relevant for each tested permission. Each tested permission appears in exactly one of the MatchedACEs.

public virtual MatchedACECollection Explanation {get;}

Property Value

An explanation of why access was granted or denied, in terms of the EffectiveACEs that were relevant for each tested permission. Each tested permission appears in exactly one of the MatchedACEs.

See Also

AccessTestResults Class | Borland.StarTeam Namespace


IsGranted Property

Borland StarTeam SDK for .NET

AccessTestResults.IsGranted Property

[read] true if access was granted; false if access was denied.

public virtual Boolean IsGranted {get;}

Property Value

true if access was granted; false if access was denied.

See Also

AccessTestResults Class | Borland.StarTeam Namespace


AccessTestResults Methods

The methods of the AccessTestResults class are listed below. For a complete list of AccessTestResults class members, see the AccessTestResults Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.AccessTestResults.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.AccessTestResults.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.AccessTestResults.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.AccessTestResults.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AccessTestResults Class | Borland.StarTeam Namespace


AccessTestResults.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.AccessTestResults

Implements

IWrapper.Unwrap

See Also

AccessTestResults Class | Borland.StarTeam Namespace


AccessTestResults.Equals Method

Delegate Equals() to com.starbase.starteam.AccessTestResults.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.AccessTestResults.Equals(obj).

See Also

AccessTestResults Class | Borland.StarTeam Namespace


AccessTestResults.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.AccessTestResults.

public override int GetHashCode();

Return Value

com.starbase.starteam.AccessTestResults.GetHashCode().

See Also

AccessTestResults Class | Borland.StarTeam Namespace


AccessTestResults.ToString Method

Delegate ToString() to com.starbase.starteam.AccessTestResults.

public override string ToString();

Return Value

com.starbase.starteam.AccessTestResults.ToString()

See Also

AccessTestResults Class | Borland.StarTeam Namespace


AccessTestResults.Wrap Method

Dynamically wraps com.starbase.starteam.AccessTestResults.

public static AccessTestResults Wrap(
AccessTestResults impl
);

Parameters

impl
com.starbase.starteam.AccessTestResults to be wrapped.

Return Value

AccessTestResults

See Also

AccessTestResults Class | Borland.StarTeam Namespace


AccessTestResults Type Conversions

The type conversions of the AccessTestResults class are listed below. For a complete list of AccessTestResults class members, see the AccessTestResults Members topic.

Public Static Type Conversions

Implicit AccessTestResults to AccessTestResults Conversion Implicitly convert AccessTestResults to com.starbase.starteam.AccessTestResults.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AccessTestResults Class | AccessTestResults Members | Borland.StarTeam Namespace


AccessTestResults Implicit AccessTestResults to AccessTestResults Conversion

Implicitly convert AccessTestResults to com.starbase.starteam.AccessTestResults.

public static implicit operator AccessTestResults(
AccessTestResults arg
);

Parameters

arg
AccessTestResults to convert.

Return Value

com.starbase.starteam.AccessTestResults

See Also

AccessTestResults Class | Borland.StarTeam Namespace


ACE Class

An Access Control List entry. An AclEntry specifies a set of permissions that are either granted or denied to a particular user or group. A collection of such entries makes an ACL or Access Control List.

For a list of all members of this type, see ACE Members.

System.Object
ACE
EffectiveACE

public class ACE : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ACE Members | Borland.StarTeam Namespace


ACE Members

ACE overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.AclEntry.

Public Static Type Conversions

Implicit ACE to AclEntry Conversion Implicitly convert ACE to com.starbase.starteam.AclEntry.

Public Instance Constructors

ACE Overloaded. Initializes a new instance of the ACE class.

Public Instance Properties

ID | [read] the user or group ID for this entry.
IsGranted | [read/write] true if the permissions are granted and false if denied.
IsGroupID | [read] true if the ID represents a group.
PermissionFlags | [read] the internal "bit set" representation of this entry's permissions.

Public Instance Methods

AddPermission | Adds the specified permission to this entry.
Equals | Delegate Equals() to com.starbase.starteam.AclEntry.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.AclEntry.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Returns true if the specified permission is a part of this entry.
RemovePermission | Removes the specified permission from this entry.
ToString | Delegate ToString() to com.starbase.starteam.AclEntry.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ACE Class | Borland.StarTeam Namespace


ACE Constructor

Construct ACE from com.starbase.starteam.AclEntry.

Overload List

Construct ACE from com.starbase.starteam.AclEntry.

public ACE(AclEntry);

Creates a new Access Control List entry. No permissions are explicitly granted or denied.

public ACE(Int32,Boolean);

Creates a new Access Control List entry.

public ACE(Int32,Int32,Boolean);

See Also

ACE Class | Borland.StarTeam Namespace


ACE Constructor (AclEntry)

Construct ACE from com.starbase.starteam.AclEntry.

public ACE(
AclEntry impl
);

Parameters

impl
The com.starbase.starteam.AclEntry to be wrapped.

See Also

ACE Class | Borland.StarTeam Namespace | ACE Constructor Overload List


ACE Constructor (Int32, Boolean)

Creates a new Access Control List entry. No permissions are explicitly granted or denied.

public ACE(
Int32 id,
Boolean isGranted
);

Parameters

id
The user or group ID for this entry.
isGranted
true if the permissions are to be granted; false if they are to be denied.

See Also

ACE Class | Borland.StarTeam Namespace | ACE Constructor Overload List | addPermission


ACE Constructor (Int32, Int32, Boolean)

Creates a new Access Control List entry.

public ACE(
Int32 id,
Int32 permissions,
Boolean isGranted
);

Parameters

id
The user or group ID for this entry.
permissions
isGranted
true if the permissions are to be granted; false if they are to be denied.

See Also

ACE Class | Borland.StarTeam Namespace | ACE Constructor Overload List


ACE Properties

The properties of the ACE class are listed below. For a complete list of ACE class members, see the ACE Members topic.

Public Instance Properties

ID | [read] the user or group ID for this entry.
IsGranted | [read/write] true if the permissions are granted and false if denied.
IsGroupID | [read] true if the ID represents a group.
PermissionFlags | [read] the internal "bit set" representation of this entry's permissions.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ACE Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ACE.ID Property

[read] the user or group ID for this entry.

public virtual Int32 ID {get;}

Property Value

the user or group ID for this entry.

See Also

ACE Class | Borland.StarTeam Namespace


IsGranted Property

Borland StarTeam SDK for .NET

ACE.IsGranted Property

[read/write] true if the permissions are granted and false if denied.

public virtual Boolean IsGranted {get; set;}

Property Value

true if the permissions are granted and false if denied.

See Also

ACE Class | Borland.StarTeam Namespace


IsGroupID Property

Borland StarTeam SDK for .NET

ACE.IsGroupID Property

[read] true if the ID represents a group.

public virtual Boolean IsGroupID {get;}

Property Value

true if the ID represents a group.

See Also

ACE Class | Borland.StarTeam Namespace


PermissionFlags Property

Borland StarTeam SDK for .NET

ACE.PermissionFlags Property

[read] the internal "bit set" representation of this entry's permissions.

public virtual Int32 PermissionFlags {get;}

Property Value

the internal "bit set" representation of this entry's permissions.

See Also

ACE Class | Borland.StarTeam Namespace


ACE Methods

The methods of the ACE class are listed below. For a complete list of ACE class members, see the ACE Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.AclEntry.

Public Instance Methods

AddPermission | Adds the specified permission to this entry.
Equals | Delegate Equals() to com.starbase.starteam.AclEntry.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.AclEntry.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Returns true if the specified permission is a part of this entry.
RemovePermission | Removes the specified permission from this entry.
ToString | Delegate ToString() to com.starbase.starteam.AclEntry.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ACE Class | Borland.StarTeam Namespace


ACE.AddPermission Method

Adds the specified permission to this entry.

public virtual void AddPermission(
Int32 permission
);

Parameters

permission
the permission code to be added

See Also

ACE Class | Borland.StarTeam Namespace | Permission


ACE.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.AclEntry

Implements

IWrapper.Unwrap

See Also

ACE Class | Borland.StarTeam Namespace


ACE.Equals Method

Delegate Equals() to com.starbase.starteam.AclEntry.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.AclEntry.Equals(obj).

See Also

ACE Class | Borland.StarTeam Namespace


ACE.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.AclEntry.

public override int GetHashCode();

Return Value

com.starbase.starteam.AclEntry.GetHashCode().

See Also

ACE Class | Borland.StarTeam Namespace


ACE.HasPermission Method

Returns true if the specified permission is a part of this entry.

public virtual bool HasPermission(
Int32 permission
);

Parameters

permission
the permission code to be checked

Return Value

true if the specified permission if a part of this entry.

See Also

ACE Class | Borland.StarTeam Namespace | Permission


ACE.RemovePermission Method

Removes the specified permission from this entry.

public virtual void RemovePermission(
Int32 permission
);

Parameters

permission
the permission code to be removed

See Also

ACE Class | Borland.StarTeam Namespace | Permission


ACE.ToString Method

Delegate ToString() to com.starbase.starteam.AclEntry.

public override string ToString();

Return Value

com.starbase.starteam.AclEntry.ToString()

See Also

ACE Class | Borland.StarTeam Namespace


ACE.Wrap Method

Dynamically wraps com.starbase.starteam.AclEntry.

public static ACE Wrap(
AclEntry impl
);

Parameters

impl
com.starbase.starteam.AclEntry to be wrapped.

Return Value

ACE

See Also

ACE Class | Borland.StarTeam Namespace


ACE Type Conversions

The type conversions of the ACE class are listed below. For a complete list of ACE class members, see the ACE Members topic.

Public Static Type Conversions

Implicit ACE to AclEntry Conversion Implicitly convert ACE to com.starbase.starteam.AclEntry.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ACE Class | ACE Members | Borland.StarTeam Namespace


ACE Implicit ACE to AclEntry Conversion

Implicitly convert ACE to com.starbase.starteam.AclEntry.

public static implicit operator AclEntry(
ACE arg
);

Parameters

arg
ACE to convert.

Return Value

com.starbase.starteam.AclEntry

See Also

ACE Class | Borland.StarTeam Namespace


ACL Class

A strongly-typed collection of ACEs.

For a list of all members of this type, see ACL Members.

System.Object
ArrayAdapter
ACL

public class ACL : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ACL Members | Borland.StarTeam Namespace


ACL Members

ACL overview

Public Static Methods

Wrap Creates an ACL to represent the given array of AclEntry (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit ACL to ACE[] Conversion | Converts an ACL to an array of ACEs.
Implicit ACL to AclEntry[] Conversion | Converts an ACL from the Borland.StarTeam namespace to an AclEntry[] in the com.starbase.starteam namespace.

Public Instance Constructors

ACL Overloaded. Initializes a new instance of the ACL class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ACE at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an ACE to end of the collection.
Append | Overloaded. Appends the ACEs of the given ACL to the end of this ACL.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ACE.
CopyTo | Copies all of the ACEs in the ACL to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the ACE with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ACE in the collection.
Insert | Inserts an ACE into the collection at the specified position.
Remove | Removes the first occurrence of a specific ACE from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ACEs in this ACL.
Sort | Sorts the ACEs in this ACL, using the given comparer.
SortByID | Sorts the ACEs in this ACL by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ACL Class | Borland.StarTeam Namespace


ACL Constructor

Initializes an instance of the ACL class.

Overload List

Initializes an instance of the ACL class.

public ACL();

Initializes an instance of the an ACL class, copying the given array.

public ACL(ACE[]);

Initializes an instance of the an ACL class, copying the given collection.

public ACL(ACL);

Initializes an instance of the an ACL class, wrapping the given array of AclEntry (from the com.starbase.starteam namespace).

public ACL(AclEntry[]);

See Also

ACL Class | Borland.StarTeam Namespace


ACL Constructor ()

Initializes an instance of the ACL class.

public ACL();

See Also

ACL Class | Borland.StarTeam Namespace | ACL Constructor Overload List


ACL Constructor (AclEntry[])

Initializes an instance of the an ACL class, wrapping the given array of AclEntry (from the com.starbase.starteam namespace).

public ACL(
AclEntry[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ACL Class | Borland.StarTeam Namespace | ACL Constructor Overload List | Wrap


ACL Constructor (ACL)

Initializes an instance of the an ACL class, copying the given collection.

public ACL(
ACL collection
);

Parameters

collection
The collection to be copied.

Remarks

The member ACE objects of the original collection are shared, not copied.

See Also

ACL Class | Borland.StarTeam Namespace | ACL Constructor Overload List


ACL Constructor (ACE[])

Initializes an instance of the an ACL class, copying the given array.

public ACL(
ACE[] array
);

Parameters

array
The array to be copied.

Remarks

The member ACE objects of the original array are shared, not copied.

See Also

ACL Class | Borland.StarTeam Namespace | ACL Constructor Overload List


ACL Properties

The properties of the ACL class are listed below. For a complete list of ACL class members, see the ACL Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ACE at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ACL Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

ACL.Item Property

Gets or sets the ACE at the specified index.

public ACE this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the ACE to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ACL Class | Borland.StarTeam Namespace


ACL Methods

The methods of the ACL class are listed below. For a complete list of ACL class members, see the ACL Members topic.

Public Static Methods

Wrap Creates an ACL to represent the given array of AclEntry (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds an ACE to end of the collection.
Append | Overloaded. Appends the ACEs of the given ACL to the end of this ACL.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ACE.
CopyTo | Copies all of the ACEs in the ACL to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the ACE with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ACE in the collection.
Insert | Inserts an ACE into the collection at the specified position.
Remove | Removes the first occurrence of a specific ACE from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ACEs in this ACL.
Sort | Sorts the ACEs in this ACL, using the given comparer.
SortByID | Sorts the ACEs in this ACL by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ACL Class | Borland.StarTeam Namespace


ACL.Add Method

Adds an ACE to end of the collection.

public int Add(
ACE value
);

Parameters

value
The ACE to add to the collection.

Return Value

The position into which the new ACE was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ACL Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

ACL.Append Method

Appends the ACEs of the given array to the end of this ACL.

Overload List

Appends the ACEs of the given array to the end of this ACL.

public ACL Append(ACE[]);

Appends the ACEs of the given ACL to the end of this ACL.

public ACL Append(ACL);

See Also

ACL Class | Borland.StarTeam Namespace


ACL.Append Method (ACE[])

Appends the ACEs of the given array to the end of this ACL.

public ACL Append(
ACE[] array
);

Parameters

array
The array whose ACEs are to be appended to this ACL.

Return Value

This ACL, modified to include the new ACEs.

Remarks

The ACL is modified to include the new members. The individual ACE objects are shared, not copied.

See Also

ACL Class | Borland.StarTeam Namespace | ACL.Append Overload List


ACL.Append Method (ACL)

Appends the ACEs of the given ACL to the end of this ACL.

public ACL Append(
ACL collection
);

Parameters

collection
The ACL whose ACEs are to be appended to this ACL.

Return Value

This ACL, modified to include the new ACEs.

Remarks

The ACL is modified to include the new members. The individual ACE objects are shared, not copied.

See Also

ACL Class | Borland.StarTeam Namespace | ACL.Append Overload List


ACL.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.AclEntry[].

Implements

IWrapper.Unwrap

See Also

ACL Class | Borland.StarTeam Namespace


ACL.Contains Method

Determines whether or not the collection contains a specific ACE.

public bool Contains(
ACE value
);

Parameters

value
The ACE to locate in the collection.

Return Value

true if the ACE is found in the collection; otherwise, false.

See Also

ACL Class | Borland.StarTeam Namespace


ACL.CopyTo Method

Copies all of the ACEs in the ACL to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
ACE[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the ACEs copied from the ACL.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of ACEs in the source ACL is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ACL cannot be cast automatically to the type of the destination array.

See Also

ACL Class | Borland.StarTeam Namespace


ACL.FindByID Method

Finds the ACE with the given ID.

public ACE FindByID(
Int32 id
);

Parameters

id
The ID of the ACE to be found.

Return Value

The ACE with the given ID, or null if there is no ACE with that ID in this ACL.

See Also

ACL Class | Borland.StarTeam Namespace


ACL.IndexOf Method

Determines the index of a specific ACE in the collection.

public int IndexOf(
ACE value
);

Parameters

value
The ACE to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ACL Class | Borland.StarTeam Namespace


ACL.Insert Method

Inserts an ACE into the collection at the specified position.

public void Insert(
Int32 index,
ACE value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The ACE to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ACL Class | Borland.StarTeam Namespace


ACL.Remove Method

Removes the first occurrence of a specific ACE from the collection.

public void Remove(
ACE value
);

Parameters

value
The ACE to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ACL Class | Borland.StarTeam Namespace


ACL.Reverse Method

Reverses the order of the ACEs in this ACL.

new public ACL Reverse();

Return Value

This ACL, modified such that the ACEs are reversed.

Remarks

The ACL is modified in place.

See Also

ACL Class | Borland.StarTeam Namespace


ACL.Sort Method

Sorts the ACEs in this ACL, using the given comparer.

new public ACL Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two ACEs.

Return Value

This ACL, modified such that the ACEs are sorted.

Remarks

The ACL is modified in place.

See Also

ACL Class | Borland.StarTeam Namespace


ACL.SortByID Method

Sorts the ACEs in this ACL by ID.

public ACL SortByID();

Return Value

This ACL, modified such that the ACEs are sorted by ID.

Remarks

The ACL is modified in place.

See Also

ACL Class | Borland.StarTeam Namespace


ACL.Wrap Method

Creates an ACL to represent the given array of AclEntry (from the com.starbase.starteam namespace).

public static ACL Wrap(
AclEntry[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ACL, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an AclEntry[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

ACL Class | Borland.StarTeam Namespace


ACL Type Conversions

The type conversions of the ACL class are listed below. For a complete list of ACL class members, see the ACL Members topic.

Public Static Type Conversions

Implicit ACL to ACE[] Conversion | Converts an ACL to an array of ACEs.
Implicit ACL to AclEntry[] Conversion | Converts an ACL from the Borland.StarTeam namespace to an AclEntry[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ACL Class | ACL Members | Borland.StarTeam Namespace


ACL Implicit ACL to ACE[] Conversion

Converts an ACL to an array of ACEs.

public static implicit operator ACE[](
ACL arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new ACE wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one ACE wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ACL Class | Borland.StarTeam Namespace


ACL Implicit ACL to AclEntry[] Conversion

Converts an ACL from the Borland.StarTeam namespace to an AclEntry[] in the com.starbase.starteam namespace.

public static implicit operator AclEntry[](
ACL arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ACL is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ACL Class | Borland.StarTeam Namespace


AddResult Class

The class holds return information specific to the file add operation.

For a list of all members of this type, see AddResult Members.

System.Object
FileResult
AddResult

public class AddResult : FileResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

AddResult Members | Borland.StarTeam Namespace


AddResult Members

AddResult overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.AddResult.

Public Static Type Conversions

Implicit AddResult to AddResult Conversion Implicitly convert AddResult to com.starbase.starteam.AddResult.

Public Instance Constructors

AddResult Constructor Construct AddResult from com.starbase.starteam.AddResult.

Public Instance Properties

Keywords (inherited from FileResult) [read] the keywords used for the file operation.

Public Instance Methods

Equals (inherited from FileResult) | Delegate Equals() to com.starbase.starteam.FileResult.
GetHashCode (inherited from FileResult) | Delegate GetHashCode() to com.starbase.starteam.FileResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from FileResult) | Delegate ToString() to com.starbase.starteam.FileResult.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileResult) Implementation of IWrapper.Unwrap().

See Also

AddResult Class | Borland.StarTeam Namespace


AddResult Constructor

Construct AddResult from com.starbase.starteam.AddResult.

public AddResult(
AddResult impl
);

Parameters

impl
The com.starbase.starteam.AddResult to be wrapped.

See Also

AddResult Class | Borland.StarTeam Namespace


AddResult Methods

The methods of the AddResult class are listed below. For a complete list of AddResult class members, see the AddResult Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.AddResult.

Public Instance Methods

Equals (inherited from FileResult) | Delegate Equals() to com.starbase.starteam.FileResult.
GetHashCode (inherited from FileResult) | Delegate GetHashCode() to com.starbase.starteam.FileResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from FileResult) | Delegate ToString() to com.starbase.starteam.FileResult.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileResult) Implementation of IWrapper.Unwrap().

See Also

AddResult Class | Borland.StarTeam Namespace


AddResult.Wrap Method

Dynamically wraps com.starbase.starteam.AddResult.

public static AddResult Wrap(
AddResult impl
);

Parameters

impl
com.starbase.starteam.AddResult to be wrapped.

Return Value

AddResult

See Also

AddResult Class | Borland.StarTeam Namespace


AddResult Type Conversions

The type conversions of the AddResult class are listed below. For a complete list of AddResult class members, see the AddResult Members topic.

Public Static Type Conversions

Implicit AddResult to AddResult Conversion Implicitly convert AddResult to com.starbase.starteam.AddResult.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileResult) Implementation of IWrapper.Unwrap().

See Also

AddResult Class | AddResult Members | Borland.StarTeam Namespace


AddResult Implicit AddResult to AddResult Conversion

Implicitly convert AddResult to com.starbase.starteam.AddResult.

public static implicit operator AddResult(
AddResult arg
);

Parameters

arg
AddResult to convert.

Return Value

com.starbase.starteam.AddResult

See Also

AddResult Class | Borland.StarTeam Namespace


Audit Class

Represents a StarTeam Audit record

For a list of all members of this type, see Audit Members.

System.Object
TypedResource
SimpleTypedResource
Item
Audit

public class Audit : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Audit Members | Borland.StarTeam Namespace


Audit Members

Audit overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Audit.

Public Static Type Conversions

Implicit Audit to Audit Conversion Implicitly convert Audit to com.starbase.starteam.Audit.

Public Instance Constructors

Audit Constructor Construct Audit from com.starbase.starteam.Audit.

Public Instance Properties

ACL (inherited from Item) |
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemClass2Name | [read] the name of the audited item's type.
ItemClass3Name | [read] the name of the audited item's type.
ItemClassName | [read] the name of the audited item's type.
ItemDescriptor | [read] the primary descriptor for the underlying audited object.
ItemDescriptor2 | [read] the primary descriptor for the second "operand" object
ItemDescriptor3 | [read] the primary descriptor for the second "operand" object
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
NewRevisionComment (inherited from Item) | [read] the empty string.
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.

Public Instance Methods

AcquireOwnership (inherited from Item)
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Audit Class | Borland.StarTeam Namespace


Audit Constructor

Construct Audit from com.starbase.starteam.Audit.

public Audit(
Audit impl
);

Parameters

impl
The com.starbase.starteam.Audit to be wrapped.

See Also

Audit Class | Borland.StarTeam Namespace


Audit Properties

The properties of the Audit class are listed below. For a complete list of Audit class members, see the Audit Members topic.

Public Instance Properties

ACL (inherited from Item) |
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemClass2Name | [read] the name of the audited item's type.
ItemClass3Name | [read] the name of the audited item's type.
ItemClassName | [read] the name of the audited item's type.
ItemDescriptor | [read] the primary descriptor for the underlying audited object.
ItemDescriptor2 | [read] the primary descriptor for the second "operand" object
ItemDescriptor3 | [read] the primary descriptor for the second "operand" object
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
NewRevisionComment (inherited from Item) | [read] the empty string.
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Audit Class | Borland.StarTeam Namespace


ItemClass2Name Property

Borland StarTeam SDK for .NET

Audit.ItemClass2Name Property

[read] the name of the audited item's type.

public virtual String ItemClass2Name {get;}

Property Value

the name of the audited item's type.

See Also

Audit Class | Borland.StarTeam Namespace


ItemClass3Name Property

Borland StarTeam SDK for .NET

Audit.ItemClass3Name Property

[read] the name of the audited item's type.

public virtual String ItemClass3Name {get;}

Property Value

the name of the audited item's type.

See Also

Audit Class | Borland.StarTeam Namespace


ItemClassName Property

Borland StarTeam SDK for .NET

Audit.ItemClassName Property

[read] the name of the audited item's type.

public virtual String ItemClassName {get;}

Property Value

the name of the audited item's type.

See Also

Audit Class | Borland.StarTeam Namespace


ItemDescriptor Property

Borland StarTeam SDK for .NET

Audit.ItemDescriptor Property

[read] the primary descriptor for the underlying audited object.

public virtual String ItemDescriptor {get;}

Property Value

the primary descriptor for the underlying audited object.

See Also

Audit Class | Borland.StarTeam Namespace


ItemDescriptor2 Property

Borland StarTeam SDK for .NET

Audit.ItemDescriptor2 Property

[read] the primary descriptor for the second "operand" object

public virtual String ItemDescriptor2 {get;}

Property Value

the primary descriptor for the second "operand" object

See Also

Audit Class | Borland.StarTeam Namespace


ItemDescriptor3 Property

Borland StarTeam SDK for .NET

Audit.ItemDescriptor3 Property

[read] the primary descriptor for the second "operand" object

public virtual String ItemDescriptor3 {get;}

Property Value

the primary descriptor for the second "operand" object

See Also

Audit Class | Borland.StarTeam Namespace


Audit Methods

The methods of the Audit class are listed below. For a complete list of Audit class members, see the Audit Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Audit.

Public Instance Methods

AcquireOwnership (inherited from Item)
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Audit Class | Borland.StarTeam Namespace


Audit.Wrap Method

Dynamically wraps com.starbase.starteam.Audit.

public static Audit Wrap(
Audit impl
);

Parameters

impl
com.starbase.starteam.Audit to be wrapped.

Return Value

Audit

See Also

Audit Class | Borland.StarTeam Namespace


Audit Type Conversions

The type conversions of the Audit class are listed below. For a complete list of Audit class members, see the Audit Members topic.

Public Static Type Conversions

Implicit Audit to Audit Conversion Implicitly convert Audit to com.starbase.starteam.Audit.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Audit Class | Audit Members | Borland.StarTeam Namespace


Audit Implicit Audit to Audit Conversion

Implicitly convert Audit to com.starbase.starteam.Audit.

public static implicit operator Audit(
Audit arg
);

Parameters

arg
Audit to convert.

Return Value

com.starbase.starteam.Audit

See Also

Audit Class | Borland.StarTeam Namespace


BLSLicenseInfo Class

A license managed by the Borland License Server.

For a list of all members of this type, see BLSLicenseInfo Members.

System.Object
BLSLicenseInfo

public class BLSLicenseInfo : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

BLSLicenseInfo Members | Borland.StarTeam Namespace


BLSLicenseInfo Members

BLSLicenseInfo overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.BLSLicenseInfo.

Public Static Type Conversions

Implicit BLSLicenseInfo to BLSLicenseInfo Conversion Implicitly convert BLSLicenseInfo to com.starbase.starteam.BLSLicenseInfo.

Public Instance Constructors

BLSLicenseInfo Constructor Construct BLSLicenseInfo from com.starbase.starteam.BLSLicenseInfo.

Public Instance Properties

Description | [read] The description of this license.
SlipGuid | [read] The Slip ID assigned by the Borland License Server to identify this license.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.BLSLicenseInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.BLSLicenseInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.BLSLicenseInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


BLSLicenseInfo Constructor

Construct BLSLicenseInfo from com.starbase.starteam.BLSLicenseInfo.

public BLSLicenseInfo(
BLSLicenseInfo impl
);

Parameters

impl
The com.starbase.starteam.BLSLicenseInfo to be wrapped.

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


BLSLicenseInfo Properties

The properties of the BLSLicenseInfo class are listed below. For a complete list of BLSLicenseInfo class members, see the BLSLicenseInfo Members topic.

Public Instance Properties

Description | [read] The description of this license.
SlipGuid | [read] The Slip ID assigned by the Borland License Server to identify this license.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

BLSLicenseInfo.Description Property

[read] The description of this license.

public virtual String Description {get;}

Property Value

The description of this license.

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


SlipGuid Property

Borland StarTeam SDK for .NET

BLSLicenseInfo.SlipGuid Property

[read] The Slip ID assigned by the Borland License Server to identify this license.

public virtual Int32 SlipGuid {get;}

Property Value

The Slip ID assigned by the Borland License Server to identify this license.

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


BLSLicenseInfo Methods

The methods of the BLSLicenseInfo class are listed below. For a complete list of BLSLicenseInfo class members, see the BLSLicenseInfo Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.BLSLicenseInfo.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.BLSLicenseInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.BLSLicenseInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.BLSLicenseInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


BLSLicenseInfo.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.BLSLicenseInfo

Implements

IWrapper.Unwrap

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


BLSLicenseInfo.Equals Method

Delegate Equals() to com.starbase.starteam.BLSLicenseInfo.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.BLSLicenseInfo.Equals(obj).

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


BLSLicenseInfo.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.BLSLicenseInfo.

public override int GetHashCode();

Return Value

com.starbase.starteam.BLSLicenseInfo.GetHashCode().

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


BLSLicenseInfo.ToString Method

Delegate ToString() to com.starbase.starteam.BLSLicenseInfo.

public override string ToString();

Return Value

com.starbase.starteam.BLSLicenseInfo.ToString()

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


BLSLicenseInfo.Wrap Method

Dynamically wraps com.starbase.starteam.BLSLicenseInfo.

public static BLSLicenseInfo Wrap(
BLSLicenseInfo impl
);

Parameters

impl
com.starbase.starteam.BLSLicenseInfo to be wrapped.

Return Value

BLSLicenseInfo

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


BLSLicenseInfo Type Conversions

The type conversions of the BLSLicenseInfo class are listed below. For a complete list of BLSLicenseInfo class members, see the BLSLicenseInfo Members topic.

Public Static Type Conversions

Implicit BLSLicenseInfo to BLSLicenseInfo Conversion Implicitly convert BLSLicenseInfo to com.starbase.starteam.BLSLicenseInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

BLSLicenseInfo Class | BLSLicenseInfo Members | Borland.StarTeam Namespace


BLSLicenseInfo Implicit BLSLicenseInfo to BLSLicenseInfo Conversion

Implicitly convert BLSLicenseInfo to com.starbase.starteam.BLSLicenseInfo.

public static implicit operator BLSLicenseInfo(
BLSLicenseInfo arg
);

Parameters

arg
BLSLicenseInfo to convert.

Return Value

com.starbase.starteam.BLSLicenseInfo

See Also

BLSLicenseInfo Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection Class

A strongly-typed collection of BLSLicenseInfos.

For a list of all members of this type, see BLSLicenseInfoCollection Members.

System.Object
ArrayAdapter
BLSLicenseInfoCollection

public class BLSLicenseInfoCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

BLSLicenseInfoCollection Members | Borland.StarTeam Namespace


BLSLicenseInfoCollection Members

BLSLicenseInfoCollection overview

Public Static Methods

Wrap Creates a BLSLicenseInfoCollection to represent the given array of BLSLicenseInfo (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit BLSLicenseInfoCollection to BLSLicenseInfo[] Conversion | Converts a BLSLicenseInfoCollection to an array of BLSLicenseInfos.
Implicit BLSLicenseInfoCollection to BLSLicenseInfo[] Conversion | Converts a BLSLicenseInfoCollection from the Borland.StarTeam namespace to a BLSLicenseInfo[] in the com.starbase.starteam namespace.

Public Instance Constructors

BLSLicenseInfoCollection Overloaded. Initializes a new instance of the BLSLicenseInfoCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the BLSLicenseInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a BLSLicenseInfo to end of the collection.
Append | Overloaded. Appends the BLSLicenseInfos of the given BLSLicenseInfoCollection to the end of this BLSLicenseInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific BLSLicenseInfo.
CopyTo | Copies all of the BLSLicenseInfos in the BLSLicenseInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific BLSLicenseInfo in the collection.
Insert | Inserts a BLSLicenseInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific BLSLicenseInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the BLSLicenseInfos in this BLSLicenseInfoCollection.
Sort | Sorts the BLSLicenseInfos in this BLSLicenseInfoCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection Constructor

Initializes an instance of the BLSLicenseInfoCollection class.

Overload List

Initializes an instance of the BLSLicenseInfoCollection class.

public BLSLicenseInfoCollection();

Initializes an instance of the a BLSLicenseInfoCollection class, copying the given array.

public BLSLicenseInfoCollection(BLSLicenseInfo[]);

Initializes an instance of the a BLSLicenseInfoCollection class, copying the given collection.

public BLSLicenseInfoCollection(BLSLicenseInfoCollection);

Initializes an instance of the a BLSLicenseInfoCollection class, wrapping the given array of BLSLicenseInfo (from the com.starbase.starteam namespace).

public BLSLicenseInfoCollection(BLSLicenseInfo[]);

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection Constructor ()

Initializes an instance of the BLSLicenseInfoCollection class.

public BLSLicenseInfoCollection();

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace | BLSLicenseInfoCollection Constructor Overload List


BLSLicenseInfoCollection Constructor (BLSLicenseInfo[])

Initializes an instance of the a BLSLicenseInfoCollection class, wrapping the given array of BLSLicenseInfo (from the com.starbase.starteam namespace).

public BLSLicenseInfoCollection(
BLSLicenseInfo[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace | BLSLicenseInfoCollection Constructor Overload List | Wrap


BLSLicenseInfoCollection Constructor (BLSLicenseInfoCollection)

Initializes an instance of the a BLSLicenseInfoCollection class, copying the given collection.

public BLSLicenseInfoCollection(
BLSLicenseInfoCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member BLSLicenseInfo objects of the original collection are shared, not copied.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace | BLSLicenseInfoCollection Constructor Overload List


BLSLicenseInfoCollection Constructor (BLSLicenseInfo[])

Initializes an instance of the a BLSLicenseInfoCollection class, copying the given array.

public BLSLicenseInfoCollection(
BLSLicenseInfo[] array
);

Parameters

array
The array to be copied.

Remarks

The member BLSLicenseInfo objects of the original array are shared, not copied.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace | BLSLicenseInfoCollection Constructor Overload List


BLSLicenseInfoCollection Properties

The properties of the BLSLicenseInfoCollection class are listed below. For a complete list of BLSLicenseInfoCollection class members, see the BLSLicenseInfoCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the BLSLicenseInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

BLSLicenseInfoCollection.Item Property

Gets or sets the BLSLicenseInfo at the specified index.

public BLSLicenseInfo this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the BLSLicenseInfo to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection Methods

The methods of the BLSLicenseInfoCollection class are listed below. For a complete list of BLSLicenseInfoCollection class members, see the BLSLicenseInfoCollection Members topic.

Public Static Methods

Wrap Creates a BLSLicenseInfoCollection to represent the given array of BLSLicenseInfo (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a BLSLicenseInfo to end of the collection.
Append | Overloaded. Appends the BLSLicenseInfos of the given BLSLicenseInfoCollection to the end of this BLSLicenseInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific BLSLicenseInfo.
CopyTo | Copies all of the BLSLicenseInfos in the BLSLicenseInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific BLSLicenseInfo in the collection.
Insert | Inserts a BLSLicenseInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific BLSLicenseInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the BLSLicenseInfos in this BLSLicenseInfoCollection.
Sort | Sorts the BLSLicenseInfos in this BLSLicenseInfoCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection.Add Method

Adds a BLSLicenseInfo to end of the collection.

public int Add(
BLSLicenseInfo value
);

Parameters

value
The BLSLicenseInfo to add to the collection.

Return Value

The position into which the new BLSLicenseInfo was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

BLSLicenseInfoCollection.Append Method

Appends the BLSLicenseInfos of the given array to the end of this BLSLicenseInfoCollection.

Overload List

Appends the BLSLicenseInfos of the given array to the end of this BLSLicenseInfoCollection.

public BLSLicenseInfoCollection Append(BLSLicenseInfo[]);

Appends the BLSLicenseInfos of the given BLSLicenseInfoCollection to the end of this BLSLicenseInfoCollection.

public BLSLicenseInfoCollection Append(BLSLicenseInfoCollection);

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection.Append Method (BLSLicenseInfo[])

Appends the BLSLicenseInfos of the given array to the end of this BLSLicenseInfoCollection.

public BLSLicenseInfoCollection Append(
BLSLicenseInfo[] array
);

Parameters

array
The array whose BLSLicenseInfos are to be appended to this BLSLicenseInfoCollection.

Return Value

This BLSLicenseInfoCollection, modified to include the new BLSLicenseInfos.

Remarks

The BLSLicenseInfoCollection is modified to include the new members. The individual BLSLicenseInfo objects are shared, not copied.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace | BLSLicenseInfoCollection.Append Overload List


BLSLicenseInfoCollection.Append Method (BLSLicenseInfoCollection)

Appends the BLSLicenseInfos of the given BLSLicenseInfoCollection to the end of this BLSLicenseInfoCollection.

public BLSLicenseInfoCollection Append(
BLSLicenseInfoCollection collection
);

Parameters

collection
The BLSLicenseInfoCollection whose BLSLicenseInfos are to be appended to this BLSLicenseInfoCollection.

Return Value

This BLSLicenseInfoCollection, modified to include the new BLSLicenseInfos.

Remarks

The BLSLicenseInfoCollection is modified to include the new members. The individual BLSLicenseInfo objects are shared, not copied.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace | BLSLicenseInfoCollection.Append Overload List


BLSLicenseInfoCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.BLSLicenseInfo[].

Implements

IWrapper.Unwrap

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection.Contains Method

Determines whether or not the collection contains a specific BLSLicenseInfo.

public bool Contains(
BLSLicenseInfo value
);

Parameters

value
The BLSLicenseInfo to locate in the collection.

Return Value

true if the BLSLicenseInfo is found in the collection; otherwise, false.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection.CopyTo Method

Copies all of the BLSLicenseInfos in the BLSLicenseInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
BLSLicenseInfo[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the BLSLicenseInfos copied from the BLSLicenseInfoCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of BLSLicenseInfos in the source BLSLicenseInfoCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source BLSLicenseInfoCollection cannot be cast automatically to the type of the destination array.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection.IndexOf Method

Determines the index of a specific BLSLicenseInfo in the collection.

public int IndexOf(
BLSLicenseInfo value
);

Parameters

value
The BLSLicenseInfo to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection.Insert Method

Inserts a BLSLicenseInfo into the collection at the specified position.

public void Insert(
Int32 index,
BLSLicenseInfo value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The BLSLicenseInfo to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection.Remove Method

Removes the first occurrence of a specific BLSLicenseInfo from the collection.

public void Remove(
BLSLicenseInfo value
);

Parameters

value
The BLSLicenseInfo to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection.Reverse Method

Reverses the order of the BLSLicenseInfos in this BLSLicenseInfoCollection.

new public BLSLicenseInfoCollection Reverse();

Return Value

This BLSLicenseInfoCollection, modified such that the BLSLicenseInfos are reversed.

Remarks

The BLSLicenseInfoCollection is modified in place.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection.Sort Method

Sorts the BLSLicenseInfos in this BLSLicenseInfoCollection, using the given comparer.

new public BLSLicenseInfoCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two BLSLicenseInfos.

Return Value

This BLSLicenseInfoCollection, modified such that the BLSLicenseInfos are sorted.

Remarks

The BLSLicenseInfoCollection is modified in place.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection.Wrap Method

Creates a BLSLicenseInfoCollection to represent the given array of BLSLicenseInfo (from the com.starbase.starteam namespace).

public static BLSLicenseInfoCollection Wrap(
BLSLicenseInfo[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new BLSLicenseInfoCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a BLSLicenseInfo[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection Type Conversions

The type conversions of the BLSLicenseInfoCollection class are listed below. For a complete list of BLSLicenseInfoCollection class members, see the BLSLicenseInfoCollection Members topic.

Public Static Type Conversions

Implicit BLSLicenseInfoCollection to BLSLicenseInfo[] Conversion | Converts a BLSLicenseInfoCollection to an array of BLSLicenseInfos.
Implicit BLSLicenseInfoCollection to BLSLicenseInfo[] Conversion | Converts a BLSLicenseInfoCollection from the Borland.StarTeam namespace to a BLSLicenseInfo[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

BLSLicenseInfoCollection Class | BLSLicenseInfoCollection Members | Borland.StarTeam Namespace


BLSLicenseInfoCollection Implicit BLSLicenseInfoCollection to BLSLicenseInfo[] Conversion

Converts a BLSLicenseInfoCollection to an array of BLSLicenseInfos.

public static implicit operator BLSLicenseInfo[](
BLSLicenseInfoCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new BLSLicenseInfo wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one BLSLicenseInfo wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BLSLicenseInfoCollection Implicit BLSLicenseInfoCollection to BLSLicenseInfo[] Conversion

Converts a BLSLicenseInfoCollection from the Borland.StarTeam namespace to a BLSLicenseInfo[] in the com.starbase.starteam namespace.

public static implicit operator BLSLicenseInfo[](
BLSLicenseInfoCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, BLSLicenseInfoCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

BLSLicenseInfoCollection Class | Borland.StarTeam Namespace


BuildNumber Class

A simple class that provides access to version information for the StarTeam SDK. The current version is "StarTeam SDK 11.0, Build 35".

For a list of all members of this type, see BuildNumber Members.

System.Object
BuildNumber

public class BuildNumber : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

BuildNumber Members | Borland.StarTeam Namespace


BuildNumber Members

BuildNumber overview

Public Static Properties

BranchNumber | [read] The internal development branch number (currently 0).
Build | [read] The product build number (currently 35).
BuildString | [read] The full product version string, showing major version, minor version, internal development branch and build number (currently, "11.0.0.35").
DisplayString | [read] A display string showing the full product name, version and build number (currently "StarTeam SDK 11.0, Build 35").
DotRelease | [read] 0
MajorVersion | [read] The product major version number (currently 11).
MinorVersion | [read] The product minor version number (currently 0).
ProductName | [read] The product name (currently "StarTeam SDK").
VersionString | [read] The product version string, showing major and minor version numbers (currently, "11.0").

Public Static Type Conversions

Implicit BuildNumber to BuildNumber Conversion Implicitly convert BuildNumber to com.starbase.starteam.BuildNumber.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.BuildNumber.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.BuildNumber.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.BuildNumber.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

BuildNumber Class | Borland.StarTeam Namespace


BuildNumber Properties

The properties of the BuildNumber class are listed below. For a complete list of BuildNumber class members, see the BuildNumber Members topic.

Public Static Properties

BranchNumber | [read] The internal development branch number (currently 0).
Build | [read] The product build number (currently 35).
BuildString | [read] The full product version string, showing major version, minor version, internal development branch and build number (currently, "11.0.0.35").
DisplayString | [read] A display string showing the full product name, version and build number (currently "StarTeam SDK 11.0, Build 35").
DotRelease | [read] 0
MajorVersion | [read] The product major version number (currently 11).
MinorVersion | [read] The product minor version number (currently 0).
ProductName | [read] The product name (currently "StarTeam SDK").
VersionString | [read] The product version string, showing major and minor version numbers (currently, "11.0").

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

BuildNumber Class | Borland.StarTeam Namespace


BranchNumber Property

Borland StarTeam SDK for .NET

BuildNumber.BranchNumber Property

[read] The internal development branch number (currently 0).

public static Int32 BranchNumber {get;}

Property Value

The internal development branch number (currently 0).

See Also

BuildNumber Class | Borland.StarTeam Namespace


Build Property

Borland StarTeam SDK for .NET

BuildNumber.Build Property

[read] The product build number (currently 35).

public static Int32 Build {get;}

Property Value

The product build number (currently 35).

See Also

BuildNumber Class | Borland.StarTeam Namespace


BuildString Property

Borland StarTeam SDK for .NET

BuildNumber.BuildString Property

[read] The full product version string, showing major version, minor version, internal development branch and build number (currently, "11.0.0.35").

public static String BuildString {get;}

Property Value

The full product version string, showing major version, minor version, internal development branch and build number (currently, "11.0.0.35").

See Also

BuildNumber Class | Borland.StarTeam Namespace


DisplayString Property

Borland StarTeam SDK for .NET

BuildNumber.DisplayString Property

[read] A display string showing the full product name, version and build number (currently "StarTeam SDK 11.0, Build 35").

public static String DisplayString {get;}

Property Value

A display string showing the full product name, version and build number (currently "StarTeam SDK 11.0, Build 35").

See Also

BuildNumber Class | Borland.StarTeam Namespace


DotRelease Property

Borland StarTeam SDK for .NET

BuildNumber.DotRelease Property

[read] 0

public static Int32 DotRelease {get;}

Property Value

0

See Also

BuildNumber Class | Borland.StarTeam Namespace


MajorVersion Property

Borland StarTeam SDK for .NET

BuildNumber.MajorVersion Property

[read] The product major version number (currently 11).

public static Int32 MajorVersion {get;}

Property Value

The product major version number (currently 11).

See Also

BuildNumber Class | Borland.StarTeam Namespace


MinorVersion Property

Borland StarTeam SDK for .NET

BuildNumber.MinorVersion Property

[read] The product minor version number (currently 0).

public static Int32 MinorVersion {get;}

Property Value

The product minor version number (currently 0).

See Also

BuildNumber Class | Borland.StarTeam Namespace


ProductName Property

Borland StarTeam SDK for .NET

BuildNumber.ProductName Property

[read] The product name (currently "StarTeam SDK").

public static String ProductName {get;}

Property Value

The product name (currently "StarTeam SDK").

See Also

BuildNumber Class | Borland.StarTeam Namespace


VersionString Property

Borland StarTeam SDK for .NET

BuildNumber.VersionString Property

[read] The product version string, showing major and minor version numbers (currently, "11.0").

public static String VersionString {get;}

Property Value

The product version string, showing major and minor version numbers (currently, "11.0").

See Also

BuildNumber Class | Borland.StarTeam Namespace


BuildNumber Methods

The methods of the BuildNumber class are listed below. For a complete list of BuildNumber class members, see the BuildNumber Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.BuildNumber.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.BuildNumber.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.BuildNumber.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

BuildNumber Class | Borland.StarTeam Namespace


BuildNumber.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.BuildNumber

Implements

IWrapper.Unwrap

See Also

BuildNumber Class | Borland.StarTeam Namespace


BuildNumber.Equals Method

Delegate Equals() to com.starbase.starteam.BuildNumber.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.BuildNumber.Equals(obj).

See Also

BuildNumber Class | Borland.StarTeam Namespace


BuildNumber.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.BuildNumber.

public override int GetHashCode();

Return Value

com.starbase.starteam.BuildNumber.GetHashCode().

See Also

BuildNumber Class | Borland.StarTeam Namespace


BuildNumber.ToString Method

Delegate ToString() to com.starbase.starteam.BuildNumber.

public override string ToString();

Return Value

com.starbase.starteam.BuildNumber.ToString()

See Also

BuildNumber Class | Borland.StarTeam Namespace


BuildNumber Type Conversions

The type conversions of the BuildNumber class are listed below. For a complete list of BuildNumber class members, see the BuildNumber Members topic.

Public Static Type Conversions

Implicit BuildNumber to BuildNumber Conversion Implicitly convert BuildNumber to com.starbase.starteam.BuildNumber.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

BuildNumber Class | BuildNumber Members | Borland.StarTeam Namespace


BuildNumber Implicit BuildNumber to BuildNumber Conversion

Implicitly convert BuildNumber to com.starbase.starteam.BuildNumber.

public static implicit operator BuildNumber(
BuildNumber arg
);

Parameters

arg
BuildNumber to convert.

Return Value

com.starbase.starteam.BuildNumber

See Also

BuildNumber Class | Borland.StarTeam Namespace


CacheAgent Class

Describes the features of a Cache Agent, including the type of content it caches, the projects supported, and whether or not it caches file content.

For a list of all members of this type, see CacheAgent Members.

System.Object
CacheAgent

public class CacheAgent : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CacheAgent Members | Borland.StarTeam Namespace


CacheAgent Members

CacheAgent overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CacheAgent.

Public Static Type Conversions

Implicit CacheAgent to CacheAgent Conversion Implicitly convert CacheAgent to com.starbase.starteam.CacheAgent.

Public Instance Constructors

CacheAgent Constructor Construct CacheAgent from com.starbase.starteam.CacheAgent.

Public Instance Properties

HostName | [read] The host address of this cache agent.
IsRoot | [read] boolean true if this a a Root Cache Agent
Port | [read] int the port number at which this cache agent is located
Version | [read] String version information for this Cache Agent

Public Instance Methods

CachesFileContent | returns true if this cache agent caches file content
CachesObjectPropertyContent | returns true if this cache agent caches object property content
CachesProject | Indicate if the Cache Agent is caching content for the given StarTeam server project. The method performs a case-insensitive project name comparison, leveraging the fact that some names cached by the Cache Agent may be patterns with "*" wildcards.
CachesType | Indicate if the object type is cached by the Cache Agent.
Equals | Delegate Equals() to com.starbase.starteam.CacheAgent.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CacheAgent.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CacheAgent.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent Constructor

Construct CacheAgent from com.starbase.starteam.CacheAgent.

public CacheAgent(
CacheAgent impl
);

Parameters

impl
The com.starbase.starteam.CacheAgent to be wrapped.

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent Properties

The properties of the CacheAgent class are listed below. For a complete list of CacheAgent class members, see the CacheAgent Members topic.

Public Instance Properties

HostName | [read] The host address of this cache agent.
IsRoot | [read] boolean true if this a a Root Cache Agent
Port | [read] int the port number at which this cache agent is located
Version | [read] String version information for this Cache Agent

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CacheAgent Class | Borland.StarTeam Namespace


HostName Property

Borland StarTeam SDK for .NET

CacheAgent.HostName Property

[read] The host address of this cache agent.

public virtual String HostName {get;}

Property Value

The host address of this cache agent.

See Also

CacheAgent Class | Borland.StarTeam Namespace


IsRoot Property

Borland StarTeam SDK for .NET

CacheAgent.IsRoot Property

[read] boolean true if this a a Root Cache Agent

public virtual Boolean IsRoot {get;}

Property Value

boolean true if this a a Root Cache Agent

See Also

CacheAgent Class | Borland.StarTeam Namespace


Port Property

Borland StarTeam SDK for .NET

CacheAgent.Port Property

[read] int the port number at which this cache agent is located

public virtual Int32 Port {get;}

Property Value

int the port number at which this cache agent is located

See Also

CacheAgent Class | Borland.StarTeam Namespace


Version Property

Borland StarTeam SDK for .NET

CacheAgent.Version Property

[read] String version information for this Cache Agent

public virtual String Version {get;}

Property Value

String version information for this Cache Agent

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent Methods

The methods of the CacheAgent class are listed below. For a complete list of CacheAgent class members, see the CacheAgent Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CacheAgent.

Public Instance Methods

CachesFileContent | returns true if this cache agent caches file content
CachesObjectPropertyContent | returns true if this cache agent caches object property content
CachesProject | Indicate if the Cache Agent is caching content for the given StarTeam server project. The method performs a case-insensitive project name comparison, leveraging the fact that some names cached by the Cache Agent may be patterns with "*" wildcards.
CachesType | Indicate if the object type is cached by the Cache Agent.
Equals | Delegate Equals() to com.starbase.starteam.CacheAgent.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CacheAgent.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CacheAgent.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.CacheAgent

Implements

IWrapper.Unwrap

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent.CachesFileContent Method

returns true if this cache agent caches file content

public virtual bool CachesFileContent();

Return Value

boolean true if this cache agent caches file content

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent.CachesObjectPropertyContent Method

returns true if this cache agent caches object property content

public virtual bool CachesObjectPropertyContent();

Return Value

boolean true if this cache agent caches object property content

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent.CachesProject Method

Indicate if the Cache Agent is caching content for the given StarTeam server project. The method performs a case-insensitive project name comparison, leveraging the fact that some names cached by the Cache Agent may be patterns with "*" wildcards.

public virtual bool CachesProject(
Project project
);

Parameters

project
A project.

Return Value

boolean

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent.CachesType Method

Indicate if the object type is cached by the Cache Agent.

public virtual bool CachesType(
Type type
);

Parameters

type
Object type (e.g., ChangeRequest).

Return Value

boolean True if the Cache Agent is caching all object types or the specified type.

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent.Equals Method

Delegate Equals() to com.starbase.starteam.CacheAgent.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.CacheAgent.Equals(obj).

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.CacheAgent.

public override int GetHashCode();

Return Value

com.starbase.starteam.CacheAgent.GetHashCode().

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent.ToString Method

Delegate ToString() to com.starbase.starteam.CacheAgent.

public override string ToString();

Return Value

com.starbase.starteam.CacheAgent.ToString()

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent.Wrap Method

Dynamically wraps com.starbase.starteam.CacheAgent.

public static CacheAgent Wrap(
CacheAgent impl
);

Parameters

impl
com.starbase.starteam.CacheAgent to be wrapped.

Return Value

CacheAgent

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgent Type Conversions

The type conversions of the CacheAgent class are listed below. For a complete list of CacheAgent class members, see the CacheAgent Members topic.

Public Static Type Conversions

Implicit CacheAgent to CacheAgent Conversion Implicitly convert CacheAgent to com.starbase.starteam.CacheAgent.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CacheAgent Class | CacheAgent Members | Borland.StarTeam Namespace


CacheAgent Implicit CacheAgent to CacheAgent Conversion

Implicitly convert CacheAgent to com.starbase.starteam.CacheAgent.

public static implicit operator CacheAgent(
CacheAgent arg
);

Parameters

arg
CacheAgent to convert.

Return Value

com.starbase.starteam.CacheAgent

See Also

CacheAgent Class | Borland.StarTeam Namespace


CacheAgentEventArgs Class

For a list of all members of this type, see CacheAgentEventArgs Members.

System.Object
EventArgs
CacheAgentEventArgs

public class CacheAgentEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CacheAgentEventArgs Members | Borland.StarTeam Namespace


CacheAgentEventArgs Members

CacheAgentEventArgs overview

Public Static Type Conversions

Implicit CacheAgentEventArgs to CacheAgentEvent Conversion Implicitly convert CacheAgentEventArgs to com.starbase.starteam.CacheAgentEvent.

Public Instance Properties

BytesReceived | [read] long the number of bytes received from the Cache Agent for this item
DebugString | [read] String a string representation of the event
ExecutionTime | [read] int the time (in msecs) taken to process the content for this item
IsFileContent | [read] boolean true if the content is file specific, false otherwise
IsObjectPropertyContent | [read] boolean true if the content describes properties of cached objects, false otherwise
ItemID | [read] ItemID the item id of the StarTeam item whose content has been received
MissingProperties | [read] Property[] the set of properties that were requested but not received from the Cache Agent
Type | [read] Type the type of the StarTeam item whose content has been received

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


CacheAgentEventArgs Properties

The properties of the CacheAgentEventArgs class are listed below. For a complete list of CacheAgentEventArgs class members, see the CacheAgentEventArgs Members topic.

Public Instance Properties

BytesReceived | [read] long the number of bytes received from the Cache Agent for this item
DebugString | [read] String a string representation of the event
ExecutionTime | [read] int the time (in msecs) taken to process the content for this item
IsFileContent | [read] boolean true if the content is file specific, false otherwise
IsObjectPropertyContent | [read] boolean true if the content describes properties of cached objects, false otherwise
ItemID | [read] ItemID the item id of the StarTeam item whose content has been received
MissingProperties | [read] Property[] the set of properties that were requested but not received from the Cache Agent
Type | [read] Type the type of the StarTeam item whose content has been received

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


BytesReceived Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.BytesReceived Property

[read] long the number of bytes received from the Cache Agent for this item

public virtual Int64 BytesReceived {get;}

Property Value

long the number of bytes received from the Cache Agent for this item

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.DebugString Property

[read] String a string representation of the event

public virtual String DebugString {get;}

Property Value

String a string representation of the event

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


ExecutionTime Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.ExecutionTime Property

[read] int the time (in msecs) taken to process the content for this item

public virtual Int32 ExecutionTime {get;}

Property Value

int the time (in msecs) taken to process the content for this item

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


IsFileContent Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.IsFileContent Property

[read] boolean true if the content is file specific, false otherwise

public virtual Boolean IsFileContent {get;}

Property Value

boolean true if the content is file specific, false otherwise

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


IsObjectPropertyContent Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.IsObjectPropertyContent Property

[read] boolean true if the content describes properties of cached objects, false otherwise

public virtual Boolean IsObjectPropertyContent {get;}

Property Value

boolean true if the content describes properties of cached objects, false otherwise

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


ItemID Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.ItemID Property

[read] ItemID the item id of the StarTeam item whose content has been received

public virtual Int32 ItemID {get;}

Property Value

ItemID the item id of the StarTeam item whose content has been received

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


MissingProperties Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.MissingProperties Property

[read] Property[] the set of properties that were requested but not received from the Cache Agent

public virtual PropertyCollection MissingProperties {get;}

Property Value

Property[] the set of properties that were requested but not received from the Cache Agent

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.Type Property

[read] Type the type of the StarTeam item whose content has been received

public virtual Type Type {get;}

Property Value

Type the type of the StarTeam item whose content has been received

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


CacheAgentEventArgs Methods

The methods of the CacheAgentEventArgs class are listed below. For a complete list of CacheAgentEventArgs class members, see the CacheAgentEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


CacheAgentEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


CacheAgentEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


CacheAgentEventArgs.ToString Method

public override string ToString();

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


CacheAgentEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


CacheAgentEventArgs Type Conversions

The type conversions of the CacheAgentEventArgs class are listed below. For a complete list of CacheAgentEventArgs class members, see the CacheAgentEventArgs Members topic.

Public Static Type Conversions

Implicit CacheAgentEventArgs to CacheAgentEvent Conversion Implicitly convert CacheAgentEventArgs to com.starbase.starteam.CacheAgentEvent.

See Also

CacheAgentEventArgs Class | CacheAgentEventArgs Members | Borland.StarTeam Namespace


CacheAgentEventArgs Implicit CacheAgentEventArgs to CacheAgentEvent Conversion

Implicitly convert CacheAgentEventArgs to com.starbase.starteam.CacheAgentEvent.

public static implicit operator CacheAgentEvent(
CacheAgentEventArgs arg
);

Parameters

arg
CacheAgentEventArgs to convert.

Return Value

com.starbase.starteam.CacheAgentEvent

See Also

CacheAgentEventArgs Class | Borland.StarTeam Namespace


CacheAgentEventSource Class

For a list of all members of this type, see CacheAgentEventSource Members.

System.Object
CacheAgentEventSource

public class CacheAgentEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CacheAgentEventSource Members | Borland.StarTeam Namespace


CacheAgentEventSource Members

CacheAgentEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ItemMissed
ItemReceived
OnItemMissed
OnItemReceived

See Also

CacheAgentEventSource Class | Borland.StarTeam Namespace


CacheAgentEventSource Properties

The properties of the CacheAgentEventSource class are listed below. For a complete list of CacheAgentEventSource class members, see the CacheAgentEventSource Members topic.

Public Instance Properties

Parent

See Also

CacheAgentEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

CacheAgentEventSource.Parent Property

public Object Parent {get;}

See Also

CacheAgentEventSource Class | Borland.StarTeam Namespace


CacheAgentEventSource Events

The events of the CacheAgentEventSource class are listed below. For a complete list of CacheAgentEventSource class members, see the CacheAgentEventSource Members topic.

Public Instance Events

ItemMissed
ItemReceived
OnItemMissed
OnItemReceived

See Also

CacheAgentEventSource Class | Borland.StarTeam Namespace


CacheAgentEventSource.ItemMissed Event

public event CacheAgentEventSource.Handler ItemMissed;

See Also

CacheAgentEventSource Class | Borland.StarTeam Namespace


CacheAgentEventSource.ItemReceived Event

public event CacheAgentEventSource.Handler ItemReceived;

See Also

CacheAgentEventSource Class | Borland.StarTeam Namespace


CacheAgentEventSource.OnItemMissed Event

public event CacheAgentEventSource.Handler OnItemMissed;

See Also

CacheAgentEventSource Class | Borland.StarTeam Namespace


CacheAgentEventSource.OnItemReceived Event

public event CacheAgentEventSource.Handler OnItemReceived;

See Also

CacheAgentEventSource Class | Borland.StarTeam Namespace


CacheAgentEventSource.Handler Delegate

public delegate void CacheAgentEventSource.Handler(
CacheAgentEventSource source,
CacheAgentEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


CacheController Class

For each repository accessed via some Server object, we maintain a local cache that holds data fetched from the repository. Normally, when a given cache is no longer referened by any Server object, the cache is discarded, freeing up memory used by the cached data objects. However, "server-oriented" applications, which open and close many Server connections on behalf of various clients, may benefit from keeping these local caches around even after they are no longer referenced by any Server object. This is especially true when MPX is enabled. CacheController allows an application to adjust the behavior of the SDK caching mechanisms as appropriate.

For a list of all members of this type, see CacheController Members.

System.Object
CacheController

public class CacheController : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CacheController Members | Borland.StarTeam Namespace


CacheController Members

CacheController overview

Public Static Properties

MaxCaches [read/write] The maximum number of server caches that are permitted to remain in memory even after they are no longer referenced by any Server object.

Public Static Type Conversions

Implicit CacheController to CacheController Conversion Implicitly convert CacheController to com.starbase.starteam.CacheController.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CacheController.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CacheController.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CacheController.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CacheController Class | Borland.StarTeam Namespace


CacheController Properties

The properties of the CacheController class are listed below. For a complete list of CacheController class members, see the CacheController Members topic.

Public Static Properties

MaxCaches [read/write] The maximum number of server caches that are permitted to remain in memory even after they are no longer referenced by any Server object.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CacheController Class | Borland.StarTeam Namespace


MaxCaches Property

Borland StarTeam SDK for .NET

CacheController.MaxCaches Property

[read/write] The maximum number of server caches that are permitted to remain in memory even after they are no longer referenced by any Server object.

public static Int32 MaxCaches {get; set;}

Property Value

The maximum number of server caches that are permitted to remain in memory even after they are no longer referenced by any Server object.

See Also

CacheController Class | Borland.StarTeam Namespace


CacheController Methods

The methods of the CacheController class are listed below. For a complete list of CacheController class members, see the CacheController Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CacheController.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CacheController.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CacheController.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CacheController Class | Borland.StarTeam Namespace


CacheController.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.CacheController

Implements

IWrapper.Unwrap

See Also

CacheController Class | Borland.StarTeam Namespace


CacheController.Equals Method

Delegate Equals() to com.starbase.starteam.CacheController.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.CacheController.Equals(obj).

See Also

CacheController Class | Borland.StarTeam Namespace


CacheController.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.CacheController.

public override int GetHashCode();

Return Value

com.starbase.starteam.CacheController.GetHashCode().

See Also

CacheController Class | Borland.StarTeam Namespace


CacheController.ToString Method

Delegate ToString() to com.starbase.starteam.CacheController.

public override string ToString();

Return Value

com.starbase.starteam.CacheController.ToString()

See Also

CacheController Class | Borland.StarTeam Namespace


CacheController Type Conversions

The type conversions of the CacheController class are listed below. For a complete list of CacheController class members, see the CacheController Members topic.

Public Static Type Conversions

Implicit CacheController to CacheController Conversion Implicitly convert CacheController to com.starbase.starteam.CacheController.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CacheController Class | CacheController Members | Borland.StarTeam Namespace


CacheController Implicit CacheController to CacheController Conversion

Implicitly convert CacheController to com.starbase.starteam.CacheController.

public static implicit operator CacheController(
CacheController arg
);

Parameters

arg
CacheController to convert.

Return Value

com.starbase.starteam.CacheController

See Also

CacheController Class | Borland.StarTeam Namespace


CacheRef Class

For internal use only.

For a list of all members of this type, see CacheRef Members.

System.Object
CacheRef
Derived types

public class CacheRef : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CacheRef Members | Borland.StarTeam Namespace


CacheRef Members

CacheRef overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CacheRef.

Public Static Type Conversions

Implicit CacheRef to CacheRef Conversion Implicitly convert CacheRef to com.starbase.starteam.CacheRef.

Public Instance Constructors

CacheRef Constructor Construct CacheRef from com.starbase.starteam.CacheRef.

Public Instance Methods

Clone |
Equals | Delegate Equals() to com.starbase.starteam.CacheRef.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CacheRef.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CacheRef Class | Borland.StarTeam Namespace


CacheRef Constructor

Construct CacheRef from com.starbase.starteam.CacheRef.

public CacheRef(
CacheRef impl
);

Parameters

impl
The com.starbase.starteam.CacheRef to be wrapped.

See Also

CacheRef Class | Borland.StarTeam Namespace


CacheRef Methods

The methods of the CacheRef class are listed below. For a complete list of CacheRef class members, see the CacheRef Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CacheRef.

Public Instance Methods

Clone |
Equals | Delegate Equals() to com.starbase.starteam.CacheRef.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CacheRef.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CacheRef Class | Borland.StarTeam Namespace


CacheRef.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.CacheRef

Implements

IWrapper.Unwrap

See Also

CacheRef Class | Borland.StarTeam Namespace


CacheRef.Clone Method

public virtual object Clone();

See Also

CacheRef Class | Borland.StarTeam Namespace


CacheRef.Equals Method

Delegate Equals() to com.starbase.starteam.CacheRef.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.CacheRef.Equals(obj).

See Also

CacheRef Class | Borland.StarTeam Namespace


CacheRef.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.CacheRef.

public override int GetHashCode();

Return Value

com.starbase.starteam.CacheRef.GetHashCode().

See Also

CacheRef Class | Borland.StarTeam Namespace


CacheRef.ToString Method

Delegate ToString() to com.starbase.starteam.CacheRef.

public override string ToString();

Return Value

com.starbase.starteam.CacheRef.ToString()

See Also

CacheRef Class | Borland.StarTeam Namespace


CacheRef.Wrap Method

Dynamically wraps com.starbase.starteam.CacheRef.

public static CacheRef Wrap(
CacheRef impl
);

Parameters

impl
com.starbase.starteam.CacheRef to be wrapped.

Return Value

CacheRef

See Also

CacheRef Class | Borland.StarTeam Namespace


CacheRef Type Conversions

The type conversions of the CacheRef class are listed below. For a complete list of CacheRef class members, see the CacheRef Members topic.

Public Static Type Conversions

Implicit CacheRef to CacheRef Conversion Implicitly convert CacheRef to com.starbase.starteam.CacheRef.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CacheRef Class | CacheRef Members | Borland.StarTeam Namespace


CacheRef Implicit CacheRef to CacheRef Conversion

Implicitly convert CacheRef to com.starbase.starteam.CacheRef.

public static implicit operator CacheRef(
CacheRef arg
);

Parameters

arg
CacheRef to convert.

Return Value

com.starbase.starteam.CacheRef

See Also

CacheRef Class | Borland.StarTeam Namespace


Catalog Class

The Catalog class provides "global" access to certain properties of objects from different classes. The catalog provides information about Property values for the primary and secondary descriptors of objects.

For a list of all members of this type, see Catalog Members.

System.Object
Catalog

public class Catalog : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Catalog Members | Borland.StarTeam Namespace


Catalog Members

Catalog overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Catalog.

Public Static Type Conversions

Implicit Catalog to Catalog Conversion Implicitly convert Catalog to com.starbase.starteam.Catalog.

Public Instance Constructors

Catalog Constructor Construct Catalog from com.starbase.starteam.Catalog.

Public Instance Properties

AllIDs | [read] A list of the object IDs currently stored in the catalog.
IsRefreshRequired | [read] true if catalog information may be out of date.
PropertyIDs | [read] an array of property IDs for this catalog.

Public Instance Methods

Discard | Discards all cached data for this Catalog. A subsequent get() will re-fetch the data from the server (even when MPX is enabled).
Equals | Delegate Equals() to com.starbase.starteam.Catalog.
Get | Returns the property value for the specified "object" ID and propertyID. Will throw an IllegalArgumentException if the object ID is not in the catalog. If the specified ID is not cached in the catalog this method will go to the server to get the catalog data for that ID alone. If still not found the exception is thrown.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Catalog.
GetPrimaryDescriptor | Returns the property value for the "primary descriptor" property of the given "object" ID.
GetType (inherited from Object) | Gets the Type of the current instance.
HasID | Determines whether or not information for specified ObjectID has been cached in this Catalog.
IsRefreshIDsRequired | Returns true if a refresh() operation might have resulted in the catalog information being updated for any of the given object IDs; returns false if and only if it is known that the catalog information had not been changed since the last refresh. If MPX is not enabled, then isRefreshIDsRequired() returns true.
Populate | Fetch the catalog data if needed. If the data has already been fetched then this is essentially a no-op.
Refresh | Update the contents of the Catalog to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unneccessary server commands.
RefreshIDs | Update the contents of the Catalog for the given Object IDs to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unneccessary server commands.
ToString | Delegate ToString() to com.starbase.starteam.Catalog.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Catalog Class | Borland.StarTeam Namespace


Catalog Constructor

Construct Catalog from com.starbase.starteam.Catalog.

public Catalog(
Catalog impl
);

Parameters

impl
The com.starbase.starteam.Catalog to be wrapped.

See Also

Catalog Class | Borland.StarTeam Namespace


Catalog Properties

The properties of the Catalog class are listed below. For a complete list of Catalog class members, see the Catalog Members topic.

Public Instance Properties

AllIDs | [read] A list of the object IDs currently stored in the catalog.
IsRefreshRequired | [read] true if catalog information may be out of date.
PropertyIDs | [read] an array of property IDs for this catalog.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Catalog Class | Borland.StarTeam Namespace


AllIDs Property

Borland StarTeam SDK for .NET

Catalog.AllIDs Property

[read] A list of the object IDs currently stored in the catalog.

public virtual Int32[] AllIDs {get;}

Property Value

A list of the object IDs currently stored in the catalog.

See Also

Catalog Class | Borland.StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

Catalog.IsRefreshRequired Property

[read] true if catalog information may be out of date.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if catalog information may be out of date.

See Also

Catalog Class | Borland.StarTeam Namespace


PropertyIDs Property

Borland StarTeam SDK for .NET

Catalog.PropertyIDs Property

[read] an array of property IDs for this catalog.

public virtual Int32[] PropertyIDs {get;}

Property Value

an array of property IDs for this catalog.

See Also

Catalog Class | Borland.StarTeam Namespace


Catalog Methods

The methods of the Catalog class are listed below. For a complete list of Catalog class members, see the Catalog Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Catalog.

Public Instance Methods

Discard | Discards all cached data for this Catalog. A subsequent get() will re-fetch the data from the server (even when MPX is enabled).
Equals | Delegate Equals() to com.starbase.starteam.Catalog.
Get | Returns the property value for the specified "object" ID and propertyID. Will throw an IllegalArgumentException if the object ID is not in the catalog. If the specified ID is not cached in the catalog this method will go to the server to get the catalog data for that ID alone. If still not found the exception is thrown.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Catalog.
GetPrimaryDescriptor | Returns the property value for the "primary descriptor" property of the given "object" ID.
GetType (inherited from Object) | Gets the Type of the current instance.
HasID | Determines whether or not information for specified ObjectID has been cached in this Catalog.
IsRefreshIDsRequired | Returns true if a refresh() operation might have resulted in the catalog information being updated for any of the given object IDs; returns false if and only if it is known that the catalog information had not been changed since the last refresh. If MPX is not enabled, then isRefreshIDsRequired() returns true.
Populate | Fetch the catalog data if needed. If the data has already been fetched then this is essentially a no-op.
Refresh | Update the contents of the Catalog to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unneccessary server commands.
RefreshIDs | Update the contents of the Catalog for the given Object IDs to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unneccessary server commands.
ToString | Delegate ToString() to com.starbase.starteam.Catalog.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Catalog Class | Borland.StarTeam Namespace


Catalog.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.Catalog

Implements

IWrapper.Unwrap

See Also

Catalog Class | Borland.StarTeam Namespace


Catalog.Discard Method

Discards all cached data for this Catalog. A subsequent get() will re-fetch the data from the server (even when MPX is enabled).

public virtual void Discard();

See Also

Catalog Class | Borland.StarTeam Namespace | refresh


Catalog.Equals Method

Delegate Equals() to com.starbase.starteam.Catalog.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.Catalog.Equals(obj).

See Also

Catalog Class | Borland.StarTeam Namespace


Catalog.Get Method

Returns the property value for the specified "object" ID and propertyID. Will throw an IllegalArgumentException if the object ID is not in the catalog. If the specified ID is not cached in the catalog this method will go to the server to get the catalog data for that ID alone. If still not found the exception is thrown.

public virtual object Get(
Int32 objectID,
Int32 propertyID
);

Parameters

objectID
the object ID for requested object
propertyID
the propertyID for the requested property value

Return Value

the specified property's value for the given object.

See Also

Catalog Class | Borland.StarTeam Namespace | getPropertyIDs


Catalog.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.Catalog.

public override int GetHashCode();

Return Value

com.starbase.starteam.Catalog.GetHashCode().

See Also

Catalog Class | Borland.StarTeam Namespace


Catalog.GetPrimaryDescriptor Method

Returns the property value for the "primary descriptor" property of the given "object" ID.

public virtual object GetPrimaryDescriptor(
Int32 objectID
);

Parameters

objectID
the object ID for which you want the value.

Return Value

the value of the primary descriptor property

See Also

Catalog Class | Borland.StarTeam Namespace | isPrimaryDescriptor


Catalog.HasID Method

Determines whether or not information for specified ObjectID has been cached in this Catalog.

public virtual bool HasID(
Int32 id
);

Parameters

id
ObjectID to be examined.

Return Value

true if information for specified ID has been cached in this Catalog; false otherwise.

See Also

Catalog Class | Borland.StarTeam Namespace


Catalog.IsRefreshIDsRequired Method

Returns true if a refresh() operation might have resulted in the catalog information being updated for any of the given object IDs; returns false if and only if it is known that the catalog information had not been changed since the last refresh. If MPX is not enabled, then isRefreshIDsRequired() returns true.

public virtual bool IsRefreshIDsRequired(
Int32[] objIDs
);

Parameters

objIDs
List of objectIDs to be tested.

Return Value

true if catalog information may be out of date.

See Also

Catalog Class | Borland.StarTeam Namespace | refreshIDs


Catalog.Populate Method

Fetch the catalog data if needed. If the data has already been fetched then this is essentially a no-op.

public virtual void Populate();

See Also

Catalog Class | Borland.StarTeam Namespace | refresh | discard


Catalog.Refresh Method

Update the contents of the Catalog to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unneccessary server commands.

public virtual void Refresh();

See Also

Catalog Class | Borland.StarTeam Namespace | refreshIDs | populate | discard | enableMPX


Catalog.RefreshIDs Method

Update the contents of the Catalog for the given Object IDs to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unneccessary server commands.

public virtual void RefreshIDs(
Int32[] objectIDs
);

Parameters

objectIDs
List of objectIDs to be refreshed.

See Also

Catalog Class | Borland.StarTeam Namespace | refresh | populate | discard | enableMPX


Catalog.ToString Method

Delegate ToString() to com.starbase.starteam.Catalog.

public override string ToString();

Return Value

com.starbase.starteam.Catalog.ToString()

See Also

Catalog Class | Borland.StarTeam Namespace


Catalog.Wrap Method

Dynamically wraps com.starbase.starteam.Catalog.

public static Catalog Wrap(
Catalog impl
);

Parameters

impl
com.starbase.starteam.Catalog to be wrapped.

Return Value

Catalog

See Also

Catalog Class | Borland.StarTeam Namespace


Catalog Type Conversions

The type conversions of the Catalog class are listed below. For a complete list of Catalog class members, see the Catalog Members topic.

Public Static Type Conversions

Implicit Catalog to Catalog Conversion Implicitly convert Catalog to com.starbase.starteam.Catalog.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Catalog Class | Catalog Members | Borland.StarTeam Namespace


Catalog Implicit Catalog to Catalog Conversion

Implicitly convert Catalog to com.starbase.starteam.Catalog.

public static implicit operator Catalog(
Catalog arg
);

Parameters

arg
Catalog to convert.

Return Value

com.starbase.starteam.Catalog

See Also

Catalog Class | Borland.StarTeam Namespace


ChangeRequest Class

Represents a StarTeam ChangeRequest item.

For a list of all members of this type, see ChangeRequest Members.

System.Object
TypedResource
SimpleTypedResource
Item
ChangeRequest

public class ChangeRequest : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ChangeRequest Members | Borland.StarTeam Namespace


ChangeRequest Members

ChangeRequest overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ChangeRequest.

Public Static Type Conversions

Implicit ChangeRequest to ChangeRequest Conversion Implicitly convert ChangeRequest to com.starbase.starteam.ChangeRequest.

Public Instance Constructors

ChangeRequest Overloaded. Initializes a new instance of the ChangeRequest class.

Public Instance Properties

ACL (inherited from Item) |
AddressedBy | [read/write] the user ID for the user that addressed this request.
AddressedIn | [read/write] the label ID for the build in which this request was addressed
AddressedInView | [read/write] The ID of the view from which this Change Request was addressed.
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
Category | [read/write] the category of this request.
ClosedOn | [read] the date that this request was given a closed status.
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
Component | [read/write] the component this request applies to.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
Description | [read/write] the description of this change request.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
ExternalReference | [read/write] the external reference field for this change request
Fix | [read/write] the fix for this change request.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
LastBuildTested | [read/write] a label ID of the build or named configuration that this request was last tested in.
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
NewRevisionComment (inherited from Item) | [read] the empty string.
Number | [read] this change requests CR#
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
Platform | [read/write] The platform this Change Request applies to.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossiblePlatform | [read] the possible enum values for the platform property.
PossiblePriority | [read] The possible enum values for the priority property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PossibleRequestType | [read] The possible values for the RequestType property.
PossibleSeverity | [read] The possible enum value for the severity property
PossibleStatus | [read] The possible enum values for the Status property.
Priority | [read/write] The relative priority of this Change Request.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
RequestType | [read/write] This change request's type. The type denotes whether this request is a defect report or a feature enhancement.
ResolvedOn | [read] The date that this Change Request was resolved.
Responsibility | [read/write] the user ID that is currently responsible for this request.
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Severity | [read/write] The relative severity of the condition that this Change Request represents.
Status | [read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.
Synopsis | [read/write] the synopsis or brief description of this request.
TestCommand | [read/write] the test command string for this change request.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
VerifiedOn | [read] The date that this Change Request was verified.
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.
WorkAround | [read/write] the workaround for this change request.

Public Instance Methods

AcquireOwnership (inherited from Item)
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPlatformDisplayName | Returns a user-friendly display name for the given Platform value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPriorityDisplayName | Returns a user-friendly display name for the given Priority value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetRequestTypeDisplayName | Returns a user-friendly display name for the given RequestType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetSeverityDisplayName | Returns a user-friendly display name for the given Severity value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetStatusDisplayName | Returns a user-friendly display name for the given Status value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ChangeRequest Class | Borland.StarTeam Namespace


ChangeRequest Constructor

Construct ChangeRequest from com.starbase.starteam.ChangeRequest.

Overload List

Constructs a new ChangeRequest in the specified folder.

public ChangeRequest(Folder);

Construct ChangeRequest from com.starbase.starteam.ChangeRequest.

public ChangeRequest(ChangeRequest);

See Also

ChangeRequest Class | Borland.StarTeam Namespace


ChangeRequest Constructor (ChangeRequest)

Construct ChangeRequest from com.starbase.starteam.ChangeRequest.

public ChangeRequest(
ChangeRequest impl
);

Parameters

impl
The com.starbase.starteam.ChangeRequest to be wrapped.

See Also

ChangeRequest Class | Borland.StarTeam Namespace | ChangeRequest Constructor Overload List


ChangeRequest Constructor (Folder)

Constructs a new ChangeRequest in the specified folder.

public ChangeRequest(
Folder parentFolder
);

Parameters

parentFolder
the folder in which this change request will be stored.

See Also

ChangeRequest Class | Borland.StarTeam Namespace | ChangeRequest Constructor Overload List


ChangeRequest Properties

The properties of the ChangeRequest class are listed below. For a complete list of ChangeRequest class members, see the ChangeRequest Members topic.

Public Instance Properties

ACL (inherited from Item) |
AddressedBy | [read/write] the user ID for the user that addressed this request.
AddressedIn | [read/write] the label ID for the build in which this request was addressed
AddressedInView | [read/write] The ID of the view from which this Change Request was addressed.
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
Category | [read/write] the category of this request.
ClosedOn | [read] the date that this request was given a closed status.
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
Component | [read/write] the component this request applies to.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
Description | [read/write] the description of this change request.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
ExternalReference | [read/write] the external reference field for this change request
Fix | [read/write] the fix for this change request.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
LastBuildTested | [read/write] a label ID of the build or named configuration that this request was last tested in.
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
NewRevisionComment (inherited from Item) | [read] the empty string.
Number | [read] this change requests CR#
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
Platform | [read/write] The platform this Change Request applies to.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossiblePlatform | [read] the possible enum values for the platform property.
PossiblePriority | [read] The possible enum values for the priority property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PossibleRequestType | [read] The possible values for the RequestType property.
PossibleSeverity | [read] The possible enum value for the severity property
PossibleStatus | [read] The possible enum values for the Status property.
Priority | [read/write] The relative priority of this Change Request.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
RequestType | [read/write] This change request's type. The type denotes whether this request is a defect report or a feature enhancement.
ResolvedOn | [read] The date that this Change Request was resolved.
Responsibility | [read/write] the user ID that is currently responsible for this request.
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Severity | [read/write] The relative severity of the condition that this Change Request represents.
Status | [read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.
Synopsis | [read/write] the synopsis or brief description of this request.
TestCommand | [read/write] the test command string for this change request.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
VerifiedOn | [read] The date that this Change Request was verified.
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.
WorkAround | [read/write] the workaround for this change request.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ChangeRequest Class | Borland.StarTeam Namespace


AddressedBy Property

Borland StarTeam SDK for .NET

ChangeRequest.AddressedBy Property

[read/write] the user ID for the user that addressed this request.

public virtual Int32 AddressedBy {get; set;}

Property Value

the user ID for the user that addressed this request.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


AddressedIn Property

Borland StarTeam SDK for .NET

ChangeRequest.AddressedIn Property

[read/write] the label ID for the build in which this request was addressed

public virtual Int32 AddressedIn {get; set;}

Property Value

the label ID for the build in which this request was addressed

See Also

ChangeRequest Class | Borland.StarTeam Namespace


AddressedInView Property

Borland StarTeam SDK for .NET

ChangeRequest.AddressedInView Property

[read/write] The ID of the view from which this Change Request was addressed.

public virtual Int32 AddressedInView {get; set;}

Property Value

The ID of the view from which this Change Request was addressed.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


Category Property

Borland StarTeam SDK for .NET

ChangeRequest.Category Property

[read/write] the category of this request.

public virtual String Category {get; set;}

Property Value

the category of this request.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


ClosedOn Property

Borland StarTeam SDK for .NET

ChangeRequest.ClosedOn Property

[read] the date that this request was given a closed status.

public virtual DateTime ClosedOn {get;}

Property Value

the date that this request was given a closed status.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


Component Property

Borland StarTeam SDK for .NET

ChangeRequest.Component Property

[read/write] the component this request applies to.

public virtual String Component {get; set;}

Property Value

the component this request applies to.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

ChangeRequest.Description Property

[read/write] the description of this change request.

public virtual String Description {get; set;}

Property Value

the description of this change request.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


ExternalReference Property

Borland StarTeam SDK for .NET

ChangeRequest.ExternalReference Property

[read/write] the external reference field for this change request

public virtual String ExternalReference {get; set;}

Property Value

the external reference field for this change request

See Also

ChangeRequest Class | Borland.StarTeam Namespace


Fix Property

Borland StarTeam SDK for .NET

ChangeRequest.Fix Property

[read/write] the fix for this change request.

public virtual String Fix {get; set;}

Property Value

the fix for this change request.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


LastBuildTested Property

Borland StarTeam SDK for .NET

ChangeRequest.LastBuildTested Property

[read/write] a label ID of the build or named configuration that this request was last tested in.

public virtual Int32 LastBuildTested {get; set;}

Property Value

a label ID of the build or named configuration that this request was last tested in.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


Number Property

Borland StarTeam SDK for .NET

ChangeRequest.Number Property

[read] this change requests CR#

public virtual Int32 Number {get;}

Property Value

this change requests CR#

See Also

ChangeRequest Class | Borland.StarTeam Namespace


Platform Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform Property

[read/write] The platform this Change Request applies to.

public virtual Int32 Platform {get; set;}

Property Value

The platform this Change Request applies to.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


PossiblePlatform Property

Borland StarTeam SDK for .NET

ChangeRequest.PossiblePlatform Property

[read] the possible enum values for the platform property.

public virtual Int32[] PossiblePlatform {get;}

Property Value

the possible enum values for the platform property.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


PossiblePriority Property

Borland StarTeam SDK for .NET

ChangeRequest.PossiblePriority Property

[read] The possible enum values for the priority property.

public virtual Int32[] PossiblePriority {get;}

Property Value

The possible enum values for the priority property.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


PossibleRequestType Property

Borland StarTeam SDK for .NET

ChangeRequest.PossibleRequestType Property

[read] The possible values for the RequestType property.

public virtual Int32[] PossibleRequestType {get;}

Property Value

The possible values for the RequestType property.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


PossibleSeverity Property

Borland StarTeam SDK for .NET

ChangeRequest.PossibleSeverity Property

[read] The possible enum value for the severity property

public virtual Int32[] PossibleSeverity {get;}

Property Value

The possible enum value for the severity property

See Also

ChangeRequest Class | Borland.StarTeam Namespace


PossibleStatus Property

Borland StarTeam SDK for .NET

ChangeRequest.PossibleStatus Property

[read] The possible enum values for the Status property.

public virtual Int32[] PossibleStatus {get;}

Property Value

The possible enum values for the Status property.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


Priority Property

Borland StarTeam SDK for .NET

ChangeRequest.Priority Property

[read/write] The relative priority of this Change Request.

public virtual Int32 Priority {get; set;}

Property Value

The relative priority of this Change Request.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


RequestType Property

Borland StarTeam SDK for .NET

ChangeRequest.RequestType Property

[read/write] This change request's type. The type denotes whether this request is a defect report or a feature enhancement.

public virtual Int32 RequestType {get; set;}

Property Value

This change request's type. The type denotes whether this request is a defect report or a feature enhancement.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


ResolvedOn Property

Borland StarTeam SDK for .NET

ChangeRequest.ResolvedOn Property

[read] The date that this Change Request was resolved.

public virtual DateTime ResolvedOn {get;}

Property Value

The date that this Change Request was resolved.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


Responsibility Property

Borland StarTeam SDK for .NET

ChangeRequest.Responsibility Property

[read/write] the user ID that is currently responsible for this request.

public virtual Int32 Responsibility {get; set;}

Property Value

the user ID that is currently responsible for this request.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


Severity Property

Borland StarTeam SDK for .NET

ChangeRequest.Severity Property

[read/write] The relative severity of the condition that this Change Request represents.

public virtual Int32 Severity {get; set;}

Property Value

The relative severity of the condition that this Change Request represents.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


Status Property

Borland StarTeam SDK for .NET

ChangeRequest.Status Property

[read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.

public virtual Int32 Status {get; set;}

Property Value

The status (Open, Fixed, Closed, etc.) of this Change Request.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


Synopsis Property

Borland StarTeam SDK for .NET

ChangeRequest.Synopsis Property

[read/write] the synopsis or brief description of this request.

public virtual String Synopsis {get; set;}

Property Value

the synopsis or brief description of this request.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


TestCommand Property

Borland StarTeam SDK for .NET

ChangeRequest.TestCommand Property

[read/write] the test command string for this change request.

public virtual String TestCommand {get; set;}

Property Value

the test command string for this change request.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


VerifiedOn Property

Borland StarTeam SDK for .NET

ChangeRequest.VerifiedOn Property

[read] The date that this Change Request was verified.

public virtual DateTime VerifiedOn {get;}

Property Value

The date that this Change Request was verified.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


WorkAround Property

Borland StarTeam SDK for .NET

ChangeRequest.WorkAround Property

[read/write] the workaround for this change request.

public virtual String WorkAround {get; set;}

Property Value

the workaround for this change request.

See Also

ChangeRequest Class | Borland.StarTeam Namespace


ChangeRequest Methods

The methods of the ChangeRequest class are listed below. For a complete list of ChangeRequest class members, see the ChangeRequest Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ChangeRequest.

Public Instance Methods

AcquireOwnership (inherited from Item)
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPlatformDisplayName | Returns a user-friendly display name for the given Platform value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPriorityDisplayName | Returns a user-friendly display name for the given Priority value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetRequestTypeDisplayName | Returns a user-friendly display name for the given RequestType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetSeverityDisplayName | Returns a user-friendly display name for the given Severity value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetStatusDisplayName | Returns a user-friendly display name for the given Status value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ChangeRequest Class | Borland.StarTeam Namespace


ChangeRequest.GetPlatformDisplayName Method

Returns a user-friendly display name for the given Platform value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetPlatformDisplayName(
Int32 value
);

Parameters

value
The Platform value to be converted to a display name.

Return Value

A user-friendly display name for the given Platform value.

See Also

ChangeRequest Class | Borland.StarTeam Namespace | getPlatform | getPossiblePlatform | getEnumDisplayName | CR_PLATFORM


ChangeRequest.GetPriorityDisplayName Method

Returns a user-friendly display name for the given Priority value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetPriorityDisplayName(
Int32 value
);

Parameters

value
The Priority value to be converted to a display name.

Return Value

A user-friendly display name for the given Priority value.

See Also

ChangeRequest Class | Borland.StarTeam Namespace | getPriority | getPossiblePriority | getEnumDisplayName | CR_PRIORITY


ChangeRequest.GetRequestTypeDisplayName Method

Returns a user-friendly display name for the given RequestType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetRequestTypeDisplayName(
Int32 value
);

Parameters

value
The RequestType value to be converted to a display name.

Return Value

A user-friendly display name for the given RequestType value.

See Also

ChangeRequest Class | Borland.StarTeam Namespace | getRequestType | getPossibleRequestType | getEnumDisplayName | CR_TYPE


ChangeRequest.GetSeverityDisplayName Method

Returns a user-friendly display name for the given Severity value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetSeverityDisplayName(
Int32 value
);

Parameters

value
The Severity value to be converted to a display name.

Return Value

A user-friendly display name for the given Severity value.

See Also

ChangeRequest Class | Borland.StarTeam Namespace | getSeverity | getPossibleSeverity | getEnumDisplayName | CR_SEVERITY


ChangeRequest.GetStatusDisplayName Method

Returns a user-friendly display name for the given Status value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetStatusDisplayName(
Int32 value
);

Parameters

value
The Status value to be converted to a display name.

Return Value

A user-friendly display name for the given Status value.

See Also

ChangeRequest Class | Borland.StarTeam Namespace | getStatus | getPossibleStatus | getEnumDisplayName | CR_STATUS


ChangeRequest.Wrap Method

Dynamically wraps com.starbase.starteam.ChangeRequest.

public static ChangeRequest Wrap(
ChangeRequest impl
);

Parameters

impl
com.starbase.starteam.ChangeRequest to be wrapped.

Return Value

ChangeRequest

See Also

ChangeRequest Class | Borland.StarTeam Namespace


ChangeRequest Type Conversions

The type conversions of the ChangeRequest class are listed below. For a complete list of ChangeRequest class members, see the ChangeRequest Members topic.

Public Static Type Conversions

Implicit ChangeRequest to ChangeRequest Conversion Implicitly convert ChangeRequest to com.starbase.starteam.ChangeRequest.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ChangeRequest Class | ChangeRequest Members | Borland.StarTeam Namespace


ChangeRequest Implicit ChangeRequest to ChangeRequest Conversion

Implicitly convert ChangeRequest to com.starbase.starteam.ChangeRequest.

public static implicit operator ChangeRequest(
ChangeRequest arg
);

Parameters

arg
ChangeRequest to convert.

Return Value

com.starbase.starteam.ChangeRequest

See Also

ChangeRequest Class | Borland.StarTeam Namespace


ChangeRequestCollection Class

A strongly-typed collection of ChangeRequests.

For a list of all members of this type, see ChangeRequestCollection Members.

System.Object
ArrayAdapter
ChangeRequestCollection

public class ChangeRequestCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ChangeRequestCollection Members | Borland.StarTeam Namespace


ChangeRequestCollection Members

ChangeRequestCollection overview

Public Static Methods

Wrap Creates a ChangeRequestCollection to represent the given array of ChangeRequest (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit ChangeRequestCollection to ChangeRequest[] Conversion | Converts a ChangeRequestCollection to an array of ChangeRequests.
Implicit ChangeRequestCollection to ChangeRequest[] Conversion | Converts a ChangeRequestCollection from the Borland.StarTeam namespace to a ChangeRequest[] in the com.starbase.starteam namespace.

Public Instance Constructors

ChangeRequestCollection Overloaded. Initializes a new instance of the ChangeRequestCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ChangeRequest at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a ChangeRequest to end of the collection.
Append | Overloaded. Appends the ChangeRequests of the given ChangeRequestCollection to the end of this ChangeRequestCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ChangeRequest.
CopyTo | Copies all of the ChangeRequests in the ChangeRequestCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the ChangeRequest with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ChangeRequest in the collection.
Insert | Inserts a ChangeRequest into the collection at the specified position.
Remove | Removes the first occurrence of a specific ChangeRequest from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ChangeRequests in this ChangeRequestCollection.
Sort | Sorts the ChangeRequests in this ChangeRequestCollection, using the given comparer.
SortByID | Sorts the ChangeRequests in this ChangeRequestCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection Constructor

Initializes an instance of the ChangeRequestCollection class.

Overload List

Initializes an instance of the ChangeRequestCollection class.

public ChangeRequestCollection();

Initializes an instance of the a ChangeRequestCollection class, copying the given array.

public ChangeRequestCollection(ChangeRequest[]);

Initializes an instance of the a ChangeRequestCollection class, copying the given collection.

public ChangeRequestCollection(ChangeRequestCollection);

Initializes an instance of the a ChangeRequestCollection class, wrapping the given array of ChangeRequest (from the com.starbase.starteam namespace).

public ChangeRequestCollection(ChangeRequest[]);

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection Constructor ()

Initializes an instance of the ChangeRequestCollection class.

public ChangeRequestCollection();

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace | ChangeRequestCollection Constructor Overload List


ChangeRequestCollection Constructor (ChangeRequest[])

Initializes an instance of the a ChangeRequestCollection class, wrapping the given array of ChangeRequest (from the com.starbase.starteam namespace).

public ChangeRequestCollection(
ChangeRequest[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace | ChangeRequestCollection Constructor Overload List | Wrap


ChangeRequestCollection Constructor (ChangeRequestCollection)

Initializes an instance of the a ChangeRequestCollection class, copying the given collection.

public ChangeRequestCollection(
ChangeRequestCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member ChangeRequest objects of the original collection are shared, not copied.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace | ChangeRequestCollection Constructor Overload List


ChangeRequestCollection Constructor (ChangeRequest[])

Initializes an instance of the a ChangeRequestCollection class, copying the given array.

public ChangeRequestCollection(
ChangeRequest[] array
);

Parameters

array
The array to be copied.

Remarks

The member ChangeRequest objects of the original array are shared, not copied.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace | ChangeRequestCollection Constructor Overload List


ChangeRequestCollection Properties

The properties of the ChangeRequestCollection class are listed below. For a complete list of ChangeRequestCollection class members, see the ChangeRequestCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ChangeRequest at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

ChangeRequestCollection.Item Property

Gets or sets the ChangeRequest at the specified index.

public ChangeRequest this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the ChangeRequest to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection Methods

The methods of the ChangeRequestCollection class are listed below. For a complete list of ChangeRequestCollection class members, see the ChangeRequestCollection Members topic.

Public Static Methods

Wrap Creates a ChangeRequestCollection to represent the given array of ChangeRequest (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a ChangeRequest to end of the collection.
Append | Overloaded. Appends the ChangeRequests of the given ChangeRequestCollection to the end of this ChangeRequestCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ChangeRequest.
CopyTo | Copies all of the ChangeRequests in the ChangeRequestCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the ChangeRequest with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ChangeRequest in the collection.
Insert | Inserts a ChangeRequest into the collection at the specified position.
Remove | Removes the first occurrence of a specific ChangeRequest from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ChangeRequests in this ChangeRequestCollection.
Sort | Sorts the ChangeRequests in this ChangeRequestCollection, using the given comparer.
SortByID | Sorts the ChangeRequests in this ChangeRequestCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.Add Method

Adds a ChangeRequest to end of the collection.

public int Add(
ChangeRequest value
);

Parameters

value
The ChangeRequest to add to the collection.

Return Value

The position into which the new ChangeRequest was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

ChangeRequestCollection.Append Method

Appends the ChangeRequests of the given array to the end of this ChangeRequestCollection.

Overload List

Appends the ChangeRequests of the given array to the end of this ChangeRequestCollection.

public ChangeRequestCollection Append(ChangeRequest[]);

Appends the ChangeRequests of the given ChangeRequestCollection to the end of this ChangeRequestCollection.

public ChangeRequestCollection Append(ChangeRequestCollection);

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.Append Method (ChangeRequest[])

Appends the ChangeRequests of the given array to the end of this ChangeRequestCollection.

public ChangeRequestCollection Append(
ChangeRequest[] array
);

Parameters

array
The array whose ChangeRequests are to be appended to this ChangeRequestCollection.

Return Value

This ChangeRequestCollection, modified to include the new ChangeRequests.

Remarks

The ChangeRequestCollection is modified to include the new members. The individual ChangeRequest objects are shared, not copied.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace | ChangeRequestCollection.Append Overload List


ChangeRequestCollection.Append Method (ChangeRequestCollection)

Appends the ChangeRequests of the given ChangeRequestCollection to the end of this ChangeRequestCollection.

public ChangeRequestCollection Append(
ChangeRequestCollection collection
);

Parameters

collection
The ChangeRequestCollection whose ChangeRequests are to be appended to this ChangeRequestCollection.

Return Value

This ChangeRequestCollection, modified to include the new ChangeRequests.

Remarks

The ChangeRequestCollection is modified to include the new members. The individual ChangeRequest objects are shared, not copied.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace | ChangeRequestCollection.Append Overload List


ChangeRequestCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.ChangeRequest[].

Implements

IWrapper.Unwrap

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.Contains Method

Determines whether or not the collection contains a specific ChangeRequest.

public bool Contains(
ChangeRequest value
);

Parameters

value
The ChangeRequest to locate in the collection.

Return Value

true if the ChangeRequest is found in the collection; otherwise, false.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.CopyTo Method

Copies all of the ChangeRequests in the ChangeRequestCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
ChangeRequest[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the ChangeRequests copied from the ChangeRequestCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of ChangeRequests in the source ChangeRequestCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ChangeRequestCollection cannot be cast automatically to the type of the destination array.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.FindByID Method

Finds the ChangeRequest with the given ID.

public ChangeRequest FindByID(
Int32 id
);

Parameters

id
The ID of the ChangeRequest to be found.

Return Value

The ChangeRequest with the given ID, or null if there is no ChangeRequest with that ID in this ChangeRequestCollection.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.IndexOf Method

Determines the index of a specific ChangeRequest in the collection.

public int IndexOf(
ChangeRequest value
);

Parameters

value
The ChangeRequest to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.Insert Method

Inserts a ChangeRequest into the collection at the specified position.

public void Insert(
Int32 index,
ChangeRequest value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The ChangeRequest to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.Remove Method

Removes the first occurrence of a specific ChangeRequest from the collection.

public void Remove(
ChangeRequest value
);

Parameters

value
The ChangeRequest to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.Reverse Method

Reverses the order of the ChangeRequests in this ChangeRequestCollection.

new public ChangeRequestCollection Reverse();

Return Value

This ChangeRequestCollection, modified such that the ChangeRequests are reversed.

Remarks

The ChangeRequestCollection is modified in place.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.Sort Method

Sorts the ChangeRequests in this ChangeRequestCollection, using the given comparer.

new public ChangeRequestCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two ChangeRequests.

Return Value

This ChangeRequestCollection, modified such that the ChangeRequests are sorted.

Remarks

The ChangeRequestCollection is modified in place.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.SortByID Method

Sorts the ChangeRequests in this ChangeRequestCollection by ID.

public ChangeRequestCollection SortByID();

Return Value

This ChangeRequestCollection, modified such that the ChangeRequests are sorted by ID.

Remarks

The ChangeRequestCollection is modified in place.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection.Wrap Method

Creates a ChangeRequestCollection to represent the given array of ChangeRequest (from the com.starbase.starteam namespace).

public static ChangeRequestCollection Wrap(
ChangeRequest[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ChangeRequestCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a ChangeRequest[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection Type Conversions

The type conversions of the ChangeRequestCollection class are listed below. For a complete list of ChangeRequestCollection class members, see the ChangeRequestCollection Members topic.

Public Static Type Conversions

Implicit ChangeRequestCollection to ChangeRequest[] Conversion | Converts a ChangeRequestCollection to an array of ChangeRequests.
Implicit ChangeRequestCollection to ChangeRequest[] Conversion | Converts a ChangeRequestCollection from the Borland.StarTeam namespace to a ChangeRequest[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ChangeRequestCollection Class | ChangeRequestCollection Members | Borland.StarTeam Namespace


ChangeRequestCollection Implicit ChangeRequestCollection to ChangeRequest[] Conversion

Converts a ChangeRequestCollection to an array of ChangeRequests.

public static implicit operator ChangeRequest[](
ChangeRequestCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new ChangeRequest wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one ChangeRequest wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


ChangeRequestCollection Implicit ChangeRequestCollection to ChangeRequest[] Conversion

Converts a ChangeRequestCollection from the Borland.StarTeam namespace to a ChangeRequest[] in the com.starbase.starteam namespace.

public static implicit operator ChangeRequest[](
ChangeRequestCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ChangeRequestCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ChangeRequestCollection Class | Borland.StarTeam Namespace


CharacterSet Class

The Character Set of a text file on disk.

For a list of all members of this type, see CharacterSet Members.

System.Object
EnumeratedValue
CharacterSet

public class CharacterSet : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CharacterSet Members | Borland.StarTeam Namespace


CharacterSet Members

CharacterSet overview

Public Static Properties

ALL
ASCII
BINARY
UNICODE

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CharacterSet.

Public Static Type Conversions

Implicit CharacterSet to CharacterSet Conversion Implicitly convert CharacterSet to com.starbase.starteam.CharacterSet.

Public Instance Constructors

CharacterSet Constructor Construct CharacterSet from com.starbase.starteam.CharacterSet.

Public Instance Properties

Code (inherited from EnumeratedValue) | [read/write] the enum code for this object.
Description (inherited from EnumeratedValue) | [read/write] the description of this object. This may return null.
DisplayName (inherited from EnumeratedValue) | [read]
Enabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
SortOrder (inherited from EnumeratedValue) | [read] The sort order of this enumerated value.
Translations (inherited from EnumeratedValue) | [read/write]

Public Instance Methods

Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Equals (inherited from EnumeratedValue) | Delegate Equals() to com.starbase.starteam.EnumeratedValue.
GetHashCode (inherited from EnumeratedValue) | Delegate GetHashCode() to com.starbase.starteam.EnumeratedValue.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from EnumeratedValue) | Delegate ToString() to com.starbase.starteam.EnumeratedValue.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

CharacterSet Class | Borland.StarTeam Namespace


CharacterSet Constructor

Construct CharacterSet from com.starbase.starteam.CharacterSet.

public CharacterSet(
CharacterSet impl
);

Parameters

impl
The com.starbase.starteam.CharacterSet to be wrapped.

See Also

CharacterSet Class | Borland.StarTeam Namespace


CharacterSet Properties

The properties of the CharacterSet class are listed below. For a complete list of CharacterSet class members, see the CharacterSet Members topic.

Public Static Properties

ALL
ASCII
BINARY
UNICODE

Public Instance Properties

Code (inherited from EnumeratedValue) | [read/write] the enum code for this object.
Description (inherited from EnumeratedValue) | [read/write] the description of this object. This may return null.
DisplayName (inherited from EnumeratedValue) | [read]
Enabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
SortOrder (inherited from EnumeratedValue) | [read] The sort order of this enumerated value.
Translations (inherited from EnumeratedValue) | [read/write]

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

CharacterSet Class | Borland.StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

CharacterSet.ALL Property

public static CharacterSetCollection ALL {get;}

See Also

CharacterSet Class | Borland.StarTeam Namespace


ASCII Property

Borland StarTeam SDK for .NET

CharacterSet.ASCII Property

public static CharacterSet ASCII {get;}

See Also

CharacterSet Class | Borland.StarTeam Namespace


BINARY Property

Borland StarTeam SDK for .NET

CharacterSet.BINARY Property

public static CharacterSet BINARY {get;}

See Also

CharacterSet Class | Borland.StarTeam Namespace


UNICODE Property

Borland StarTeam SDK for .NET

CharacterSet.UNICODE Property

public static CharacterSet UNICODE {get;}

See Also

CharacterSet Class | Borland.StarTeam Namespace


CharacterSet Methods

The methods of the CharacterSet class are listed below. For a complete list of CharacterSet class members, see the CharacterSet Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CharacterSet.

Public Instance Methods

Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Equals (inherited from EnumeratedValue) | Delegate Equals() to com.starbase.starteam.EnumeratedValue.
GetHashCode (inherited from EnumeratedValue) | Delegate GetHashCode() to com.starbase.starteam.EnumeratedValue.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from EnumeratedValue) | Delegate ToString() to com.starbase.starteam.EnumeratedValue.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

CharacterSet Class | Borland.StarTeam Namespace


CharacterSet.Wrap Method

Dynamically wraps com.starbase.starteam.CharacterSet.

public static CharacterSet Wrap(
CharacterSet impl
);

Parameters

impl
com.starbase.starteam.CharacterSet to be wrapped.

Return Value

CharacterSet

See Also

CharacterSet Class | Borland.StarTeam Namespace


CharacterSet Type Conversions

The type conversions of the CharacterSet class are listed below. For a complete list of CharacterSet class members, see the CharacterSet Members topic.

Public Static Type Conversions

Implicit CharacterSet to CharacterSet Conversion Implicitly convert CharacterSet to com.starbase.starteam.CharacterSet.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

CharacterSet Class | CharacterSet Members | Borland.StarTeam Namespace


CharacterSet Implicit CharacterSet to CharacterSet Conversion

Implicitly convert CharacterSet to com.starbase.starteam.CharacterSet.

public static implicit operator CharacterSet(
CharacterSet arg
);

Parameters

arg
CharacterSet to convert.

Return Value

com.starbase.starteam.CharacterSet

See Also

CharacterSet Class | Borland.StarTeam Namespace


CharacterSetCollection Class

A strongly-typed collection of CharacterSets.

For a list of all members of this type, see CharacterSetCollection Members.

System.Object
ArrayAdapter
CharacterSetCollection

public class CharacterSetCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CharacterSetCollection Members | Borland.StarTeam Namespace


CharacterSetCollection Members

CharacterSetCollection overview

Public Static Methods

Wrap Creates a CharacterSetCollection to represent the given array of CharacterSet (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit CharacterSetCollection to CharacterSet[] Conversion | Converts a CharacterSetCollection to an array of CharacterSets.
Implicit CharacterSetCollection to CharacterSet[] Conversion | Converts a CharacterSetCollection from the Borland.StarTeam namespace to a CharacterSet[] in the com.starbase.starteam namespace.

Public Instance Constructors

CharacterSetCollection Overloaded. Initializes a new instance of the CharacterSetCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the CharacterSet at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a CharacterSet to end of the collection.
Append | Overloaded. Appends the CharacterSets of the given CharacterSetCollection to the end of this CharacterSetCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific CharacterSet.
CopyTo | Copies all of the CharacterSets in the CharacterSetCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific CharacterSet in the collection.
Insert | Inserts a CharacterSet into the collection at the specified position.
Remove | Removes the first occurrence of a specific CharacterSet from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the CharacterSets in this CharacterSetCollection.
Sort | Sorts the CharacterSets in this CharacterSetCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection Constructor

Initializes an instance of the CharacterSetCollection class.

Overload List

Initializes an instance of the CharacterSetCollection class.

public CharacterSetCollection();

Initializes an instance of the a CharacterSetCollection class, copying the given array.

public CharacterSetCollection(CharacterSet[]);

Initializes an instance of the a CharacterSetCollection class, copying the given collection.

public CharacterSetCollection(CharacterSetCollection);

Initializes an instance of the a CharacterSetCollection class, wrapping the given array of CharacterSet (from the com.starbase.starteam namespace).

public CharacterSetCollection(CharacterSet[]);

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection Constructor ()

Initializes an instance of the CharacterSetCollection class.

public CharacterSetCollection();

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace | CharacterSetCollection Constructor Overload List


CharacterSetCollection Constructor (CharacterSet[])

Initializes an instance of the a CharacterSetCollection class, wrapping the given array of CharacterSet (from the com.starbase.starteam namespace).

public CharacterSetCollection(
CharacterSet[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace | CharacterSetCollection Constructor Overload List | Wrap


CharacterSetCollection Constructor (CharacterSetCollection)

Initializes an instance of the a CharacterSetCollection class, copying the given collection.

public CharacterSetCollection(
CharacterSetCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member CharacterSet objects of the original collection are shared, not copied.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace | CharacterSetCollection Constructor Overload List


CharacterSetCollection Constructor (CharacterSet[])

Initializes an instance of the a CharacterSetCollection class, copying the given array.

public CharacterSetCollection(
CharacterSet[] array
);

Parameters

array
The array to be copied.

Remarks

The member CharacterSet objects of the original array are shared, not copied.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace | CharacterSetCollection Constructor Overload List


CharacterSetCollection Properties

The properties of the CharacterSetCollection class are listed below. For a complete list of CharacterSetCollection class members, see the CharacterSetCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the CharacterSet at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

CharacterSetCollection.Item Property

Gets or sets the CharacterSet at the specified index.

public CharacterSet this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the CharacterSet to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection Methods

The methods of the CharacterSetCollection class are listed below. For a complete list of CharacterSetCollection class members, see the CharacterSetCollection Members topic.

Public Static Methods

Wrap Creates a CharacterSetCollection to represent the given array of CharacterSet (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a CharacterSet to end of the collection.
Append | Overloaded. Appends the CharacterSets of the given CharacterSetCollection to the end of this CharacterSetCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific CharacterSet.
CopyTo | Copies all of the CharacterSets in the CharacterSetCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific CharacterSet in the collection.
Insert | Inserts a CharacterSet into the collection at the specified position.
Remove | Removes the first occurrence of a specific CharacterSet from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the CharacterSets in this CharacterSetCollection.
Sort | Sorts the CharacterSets in this CharacterSetCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection.Add Method

Adds a CharacterSet to end of the collection.

public int Add(
CharacterSet value
);

Parameters

value
The CharacterSet to add to the collection.

Return Value

The position into which the new CharacterSet was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

CharacterSetCollection.Append Method

Appends the CharacterSets of the given array to the end of this CharacterSetCollection.

Overload List

Appends the CharacterSets of the given array to the end of this CharacterSetCollection.

public CharacterSetCollection Append(CharacterSet[]);

Appends the CharacterSets of the given CharacterSetCollection to the end of this CharacterSetCollection.

public CharacterSetCollection Append(CharacterSetCollection);

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection.Append Method (CharacterSet[])

Appends the CharacterSets of the given array to the end of this CharacterSetCollection.

public CharacterSetCollection Append(
CharacterSet[] array
);

Parameters

array
The array whose CharacterSets are to be appended to this CharacterSetCollection.

Return Value

This CharacterSetCollection, modified to include the new CharacterSets.

Remarks

The CharacterSetCollection is modified to include the new members. The individual CharacterSet objects are shared, not copied.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace | CharacterSetCollection.Append Overload List


CharacterSetCollection.Append Method (CharacterSetCollection)

Appends the CharacterSets of the given CharacterSetCollection to the end of this CharacterSetCollection.

public CharacterSetCollection Append(
CharacterSetCollection collection
);

Parameters

collection
The CharacterSetCollection whose CharacterSets are to be appended to this CharacterSetCollection.

Return Value

This CharacterSetCollection, modified to include the new CharacterSets.

Remarks

The CharacterSetCollection is modified to include the new members. The individual CharacterSet objects are shared, not copied.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace | CharacterSetCollection.Append Overload List


CharacterSetCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.CharacterSet[].

Implements

IWrapper.Unwrap

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection.Contains Method

Determines whether or not the collection contains a specific CharacterSet.

public bool Contains(
CharacterSet value
);

Parameters

value
The CharacterSet to locate in the collection.

Return Value

true if the CharacterSet is found in the collection; otherwise, false.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection.CopyTo Method

Copies all of the CharacterSets in the CharacterSetCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
CharacterSet[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the CharacterSets copied from the CharacterSetCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of CharacterSets in the source CharacterSetCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source CharacterSetCollection cannot be cast automatically to the type of the destination array.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection.IndexOf Method

Determines the index of a specific CharacterSet in the collection.

public int IndexOf(
CharacterSet value
);

Parameters

value
The CharacterSet to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection.Insert Method

Inserts a CharacterSet into the collection at the specified position.

public void Insert(
Int32 index,
CharacterSet value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The CharacterSet to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection.Remove Method

Removes the first occurrence of a specific CharacterSet from the collection.

public void Remove(
CharacterSet value
);

Parameters

value
The CharacterSet to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection.Reverse Method

Reverses the order of the CharacterSets in this CharacterSetCollection.

new public CharacterSetCollection Reverse();

Return Value

This CharacterSetCollection, modified such that the CharacterSets are reversed.

Remarks

The CharacterSetCollection is modified in place.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection.Sort Method

Sorts the CharacterSets in this CharacterSetCollection, using the given comparer.

new public CharacterSetCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two CharacterSets.

Return Value

This CharacterSetCollection, modified such that the CharacterSets are sorted.

Remarks

The CharacterSetCollection is modified in place.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection.Wrap Method

Creates a CharacterSetCollection to represent the given array of CharacterSet (from the com.starbase.starteam namespace).

public static CharacterSetCollection Wrap(
CharacterSet[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new CharacterSetCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a CharacterSet[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection Type Conversions

The type conversions of the CharacterSetCollection class are listed below. For a complete list of CharacterSetCollection class members, see the CharacterSetCollection Members topic.

Public Static Type Conversions

Implicit CharacterSetCollection to CharacterSet[] Conversion | Converts a CharacterSetCollection to an array of CharacterSets.
Implicit CharacterSetCollection to CharacterSet[] Conversion | Converts a CharacterSetCollection from the Borland.StarTeam namespace to a CharacterSet[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

CharacterSetCollection Class | CharacterSetCollection Members | Borland.StarTeam Namespace


CharacterSetCollection Implicit CharacterSetCollection to CharacterSet[] Conversion

Converts a CharacterSetCollection to an array of CharacterSets.

public static implicit operator CharacterSet[](
CharacterSetCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new CharacterSet wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one CharacterSet wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CharacterSetCollection Implicit CharacterSetCollection to CharacterSet[] Conversion

Converts a CharacterSetCollection from the Borland.StarTeam namespace to a CharacterSet[] in the com.starbase.starteam namespace.

public static implicit operator CharacterSet[](
CharacterSetCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, CharacterSetCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

CharacterSetCollection Class | Borland.StarTeam Namespace


CheckinEventArgs Class

For a list of all members of this type, see CheckinEventArgs Members.

System.Object
EventArgs
CheckinEventArgs

public class CheckinEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckinEventArgs Members | Borland.StarTeam Namespace


CheckinEventArgs Members

CheckinEventArgs overview

Public Static Type Conversions

Implicit CheckinEventArgs to CheckinEvent Conversion Implicitly convert CheckinEventArgs to com.starbase.starteam.CheckinEvent.

Public Instance Properties

CheckinManager | [read] The CheckinManager that triggered this CheckinEvent.
CheckinResult | [read] Details describing the result of this checkin, or null if the checkin of this file is still in progress or finished with an error.
CurrentFile | [read] The StarTeam File being checked in.
CurrentWorkingFile | [read/write] The working file on disk where this file is being checked in from, or null if this file is being checked in from a the default path.
Error |
ErrorMessage | [read] The error message for the error describing the reason for failure of this checkin, if the checkin finished with an error, or empty string otherwise.
IsCanceled | [read] true if the checkin operation has been canceled (for all remaining files), and false otherwise.
IsFinished | [read] true if the checkin operation for this file is finished; false if it is still in progress. Note that the checkin may have finished, but unsuccessfully.
IsSuccessful | [read] true if the checkin operation for this file has finished successfully; false if the checkin is still in progress, or if it finished with an error.
Options | [read] The checkin options that apply to the current file.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CheckinEventArgs Properties

The properties of the CheckinEventArgs class are listed below. For a complete list of CheckinEventArgs class members, see the CheckinEventArgs Members topic.

Public Instance Properties

CheckinManager | [read] The CheckinManager that triggered this CheckinEvent.
CheckinResult | [read] Details describing the result of this checkin, or null if the checkin of this file is still in progress or finished with an error.
CurrentFile | [read] The StarTeam File being checked in.
CurrentWorkingFile | [read/write] The working file on disk where this file is being checked in from, or null if this file is being checked in from a the default path.
Error |
ErrorMessage | [read] The error message for the error describing the reason for failure of this checkin, if the checkin finished with an error, or empty string otherwise.
IsCanceled | [read] true if the checkin operation has been canceled (for all remaining files), and false otherwise.
IsFinished | [read] true if the checkin operation for this file is finished; false if it is still in progress. Note that the checkin may have finished, but unsuccessfully.
IsSuccessful | [read] true if the checkin operation for this file has finished successfully; false if the checkin is still in progress, or if it finished with an error.
Options | [read] The checkin options that apply to the current file.

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CheckinManager Property

Borland StarTeam SDK for .NET

CheckinEventArgs.CheckinManager Property

[read] The CheckinManager that triggered this CheckinEvent.

public virtual CheckinManager CheckinManager {get;}

Property Value

The CheckinManager that triggered this CheckinEvent.

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CheckinResult Property

Borland StarTeam SDK for .NET

CheckinEventArgs.CheckinResult Property

[read] Details describing the result of this checkin, or null if the checkin of this file is still in progress or finished with an error.

public virtual CheckInResult CheckinResult {get;}

Property Value

Details describing the result of this checkin, or null if the checkin of this file is still in progress or finished with an error.

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CurrentFile Property

Borland StarTeam SDK for .NET

CheckinEventArgs.CurrentFile Property

[read] The StarTeam File being checked in.

public virtual File CurrentFile {get;}

Property Value

The StarTeam File being checked in.

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CurrentWorkingFile Property

Borland StarTeam SDK for .NET

CheckinEventArgs.CurrentWorkingFile Property

[read/write] The working file on disk where this file is being checked in from, or null if this file is being checked in from a the default path.

public virtual FileInfo CurrentWorkingFile {get; set;}

Property Value

The working file on disk where this file is being checked in from, or null if this file is being checked in from a the default path.

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


Error Property

Borland StarTeam SDK for .NET

CheckinEventArgs.Error Property

public virtual Exception Error {get;}

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


ErrorMessage Property

Borland StarTeam SDK for .NET

CheckinEventArgs.ErrorMessage Property

[read] The error message for the error describing the reason for failure of this checkin, if the checkin finished with an error, or empty string otherwise.

public virtual String ErrorMessage {get;}

Property Value

The error message for the error describing the reason for failure of this checkin, if the checkin finished with an error, or empty string otherwise.

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

CheckinEventArgs.IsCanceled Property

[read] true if the checkin operation has been canceled (for all remaining files), and false otherwise.

public virtual Boolean IsCanceled {get;}

Property Value

true if the checkin operation has been canceled (for all remaining files), and false otherwise.

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


IsFinished Property

Borland StarTeam SDK for .NET

CheckinEventArgs.IsFinished Property

[read] true if the checkin operation for this file is finished; false if it is still in progress. Note that the checkin may have finished, but unsuccessfully.

public virtual Boolean IsFinished {get;}

Property Value

true if the checkin operation for this file is finished; false if it is still in progress. Note that the checkin may have finished, but unsuccessfully.

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


IsSuccessful Property

Borland StarTeam SDK for .NET

CheckinEventArgs.IsSuccessful Property

[read] true if the checkin operation for this file has finished successfully; false if the checkin is still in progress, or if it finished with an error.

public virtual Boolean IsSuccessful {get;}

Property Value

true if the checkin operation for this file has finished successfully; false if the checkin is still in progress, or if it finished with an error.

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


Options Property

Borland StarTeam SDK for .NET

CheckinEventArgs.Options Property

[read] The checkin options that apply to the current file.

public virtual CheckinOptions Options {get;}

Property Value

The checkin options that apply to the current file.

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CheckinEventArgs Methods

The methods of the CheckinEventArgs class are listed below. For a complete list of CheckinEventArgs class members, see the CheckinEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CheckinEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CheckinEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CheckinEventArgs.ToString Method

public override string ToString();

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CheckinEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CheckinEventArgs Type Conversions

The type conversions of the CheckinEventArgs class are listed below. For a complete list of CheckinEventArgs class members, see the CheckinEventArgs Members topic.

Public Static Type Conversions

Implicit CheckinEventArgs to CheckinEvent Conversion Implicitly convert CheckinEventArgs to com.starbase.starteam.CheckinEvent.

See Also

CheckinEventArgs Class | CheckinEventArgs Members | Borland.StarTeam Namespace


CheckinEventArgs Implicit CheckinEventArgs to CheckinEvent Conversion

Implicitly convert CheckinEventArgs to com.starbase.starteam.CheckinEvent.

public static implicit operator CheckinEvent(
CheckinEventArgs arg
);

Parameters

arg
CheckinEventArgs to convert.

Return Value

com.starbase.starteam.CheckinEvent

See Also

CheckinEventArgs Class | Borland.StarTeam Namespace


CheckinEventSource Class

For a list of all members of this type, see CheckinEventSource Members.

System.Object
CheckinEventSource

public class CheckinEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckinEventSource Members | Borland.StarTeam Namespace


CheckinEventSource Members

CheckinEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnNotifyProgress
OnOnNotifyProgress
OnOnStartFile
OnStartFile

See Also

CheckinEventSource Class | Borland.StarTeam Namespace


CheckinEventSource Properties

The properties of the CheckinEventSource class are listed below. For a complete list of CheckinEventSource class members, see the CheckinEventSource Members topic.

Public Instance Properties

Parent

See Also

CheckinEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

CheckinEventSource.Parent Property

public Object Parent {get;}

See Also

CheckinEventSource Class | Borland.StarTeam Namespace


CheckinEventSource Events

The events of the CheckinEventSource class are listed below. For a complete list of CheckinEventSource class members, see the CheckinEventSource Members topic.

Public Instance Events

OnNotifyProgress
OnOnNotifyProgress
OnOnStartFile
OnStartFile

See Also

CheckinEventSource Class | Borland.StarTeam Namespace


CheckinEventSource.OnNotifyProgress Event

public event CheckinEventSource.Handler OnNotifyProgress;

See Also

CheckinEventSource Class | Borland.StarTeam Namespace


CheckinEventSource.OnOnNotifyProgress Event

public event CheckinEventSource.Handler OnOnNotifyProgress;

See Also

CheckinEventSource Class | Borland.StarTeam Namespace


CheckinEventSource.OnOnStartFile Event

public event CheckinEventSource.Handler OnOnStartFile;

See Also

CheckinEventSource Class | Borland.StarTeam Namespace


CheckinEventSource.OnStartFile Event

public event CheckinEventSource.Handler OnStartFile;

See Also

CheckinEventSource Class | Borland.StarTeam Namespace


CheckinEventSource.Handler Delegate

public delegate void CheckinEventSource.Handler(
CheckinEventSource source,
CheckinEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


CheckinManager Class

Provides a way to check out multiple files, applying a consistent set of options across all files.

For a list of all members of this type, see CheckinManager Members.

System.Object
CheckinManager

public class CheckinManager : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckinManager Members | Borland.StarTeam Namespace


CheckinManager Members

CheckinManager overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckinManager.

Public Static Type Conversions

Implicit CheckinManager to CheckinManager Conversion Implicitly convert CheckinManager to com.starbase.starteam.CheckinManager.

Public Instance Constructors

CheckinManager Overloaded. Initializes a new instance of the CheckinManager class.

Public Instance Properties

IsCanceled | [read] true if pending checkin operations have been canceled, and false otherwise.
IsRunning | [read] true if there is currently a checkin operation in progress, and false otherwise.
Options | [read/write] The checkin options currently in effect.
Progress | [read] A snapshot of the state of the current checkin operation.

Public Instance Methods

Checkin | Overloaded. Checks in a single file from the default location.
CheckinFrom | Overloaded. Checks in a single file from an alternate location.
Equals | Delegate Equals() to com.starbase.starteam.CheckinManager.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckinManager.
GetType (inherited from Object) | Gets the Type of the current instance.
NewCheckinEventSource |
SetCanceled | Cancels any pending checkin operations.
ToString | Delegate ToString() to com.starbase.starteam.CheckinManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinManager Constructor

Construct CheckinManager from com.starbase.starteam.CheckinManager.

Overload List

Constructs a CheckinManager with default options.

public CheckinManager(View);

Constructs a CheckinManager with the same options as the given one.

public CheckinManager(View,CheckinManager);

Constructs a CheckinManager using a specific set of options. Note that individual options can be overridden on a file-by-file basis by registering a CheckinListener, and changing options as necessary in the onStartFile event handler.

public CheckinManager(View,CheckinOptions);

Construct CheckinManager from com.starbase.starteam.CheckinManager.

public CheckinManager(CheckinManager);

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinManager Constructor (CheckinManager)

Construct CheckinManager from com.starbase.starteam.CheckinManager.

public CheckinManager(
CheckinManager impl
);

Parameters

impl
The com.starbase.starteam.CheckinManager to be wrapped.

See Also

CheckinManager Class | Borland.StarTeam Namespace | CheckinManager Constructor Overload List


CheckinManager Constructor (View)

Constructs a CheckinManager with default options.

public CheckinManager(
View view
);

Parameters

view
The View containing the files to be checked in.

See Also

CheckinManager Class | Borland.StarTeam Namespace | CheckinManager Constructor Overload List


CheckinManager Constructor (View, CheckinOptions)

Constructs a CheckinManager using a specific set of options.

Note that individual options can be overridden on a file-by-file basis by registering a CheckinListener, and changing options as necessary in the onStartFile event handler.

public CheckinManager(
View view,
CheckinOptions options
);

Parameters

view
The View containing the files to be checked in.
options
The specific CheckinOtions to be used.

See Also

CheckinManager Class | Borland.StarTeam Namespace | CheckinManager Constructor Overload List | CheckinOptions | addCheckinListener | onStartFile


CheckinManager Constructor (View, CheckinManager)

Constructs a CheckinManager with the same options as the given one.

public CheckinManager(
View view,
CheckinManager checkinManager
);

Parameters

view
The View containing the files to be checked in.
checkinManager
The CheckinManager whose options are to be copied.

See Also

CheckinManager Class | Borland.StarTeam Namespace | CheckinManager Constructor Overload List


CheckinManager Properties

The properties of the CheckinManager class are listed below. For a complete list of CheckinManager class members, see the CheckinManager Members topic.

Public Instance Properties

IsCanceled | [read] true if pending checkin operations have been canceled, and false otherwise.
IsRunning | [read] true if there is currently a checkin operation in progress, and false otherwise.
Options | [read/write] The checkin options currently in effect.
Progress | [read] A snapshot of the state of the current checkin operation.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinManager Class | Borland.StarTeam Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

CheckinManager.IsCanceled Property

[read] true if pending checkin operations have been canceled, and false otherwise.

public virtual Boolean IsCanceled {get;}

Property Value

true if pending checkin operations have been canceled, and false otherwise.

See Also

CheckinManager Class | Borland.StarTeam Namespace


IsRunning Property

Borland StarTeam SDK for .NET

CheckinManager.IsRunning Property

[read] true if there is currently a checkin operation in progress, and false otherwise.

public virtual Boolean IsRunning {get;}

Property Value

true if there is currently a checkin operation in progress, and false otherwise.

See Also

CheckinManager Class | Borland.StarTeam Namespace


Options Property

Borland StarTeam SDK for .NET

CheckinManager.Options Property

[read/write] The checkin options currently in effect.

public virtual CheckinOptions Options {get; set;}

Property Value

The checkin options currently in effect.

See Also

CheckinManager Class | Borland.StarTeam Namespace


Progress Property

Borland StarTeam SDK for .NET

CheckinManager.Progress Property

[read] A snapshot of the state of the current checkin operation.

public virtual CheckinProgress Progress {get;}

Property Value

A snapshot of the state of the current checkin operation.

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinManager Methods

The methods of the CheckinManager class are listed below. For a complete list of CheckinManager class members, see the CheckinManager Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckinManager.

Public Instance Methods

Checkin | Overloaded. Checks in a single file from the default location.
CheckinFrom | Overloaded. Checks in a single file from an alternate location.
Equals | Delegate Equals() to com.starbase.starteam.CheckinManager.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckinManager.
GetType (inherited from Object) | Gets the Type of the current instance.
NewCheckinEventSource |
SetCanceled | Cancels any pending checkin operations.
ToString | Delegate ToString() to com.starbase.starteam.CheckinManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinManager.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.CheckinManager

Implements

IWrapper.Unwrap

See Also

CheckinManager Class | Borland.StarTeam Namespace


Checkin Method

Borland StarTeam SDK for .NET

CheckinManager.Checkin Method

Checks in a single file from the default location.

Overload List

Checks in a single file from the default location.

public virtual void Checkin(File);

Checks in all the files in the given folder.

public virtual void Checkin(Folder);

Checks in all the files in the given folder, and in all subfolders to the given depth.

public virtual void Checkin(Folder,Int32);

Checks in the given set of files.

public virtual void Checkin(ItemCollection);

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinManager.Checkin Method (File)

Checks in a single file from the default location.

public virtual void Checkin(
File file
);

Parameters

file
The file to be checked in.

See Also

CheckinManager Class | Borland.StarTeam Namespace | CheckinManager.Checkin Overload List


CheckinManager.Checkin Method (Folder)

Checks in all the files in the given folder.

public virtual void Checkin(
Folder folder
);

Parameters

folder
The StarTeam folder whose files are to be checked in.

See Also

CheckinManager Class | Borland.StarTeam Namespace | CheckinManager.Checkin Overload List | Folder | checkin


CheckinManager.Checkin Method (Folder, Int32)

Checks in all the files in the given folder, and in all subfolders to the given depth.

public virtual void Checkin(
Folder folder,
Int32 depth
);

Parameters

folder
The StarTeam folder whose files are to be checked in.
depth
Indicates which subfolders also contain files to be checked in. Zero indicates that no subfolders should be included; 1 indicates that this folder and its immediate child folders should be included; -1 indicates that this folder and all child folders at any depth should be included.

See Also

CheckinManager Class | Borland.StarTeam Namespace | CheckinManager.Checkin Overload List


CheckinManager.Checkin Method (ItemCollection)

Checks in the given set of files.

public virtual void Checkin(
ItemCollection files
);

Parameters

files
The files to be checked in.

See Also

CheckinManager Class | Borland.StarTeam Namespace | CheckinManager.Checkin Overload List | getItems


CheckinFrom Method

Borland StarTeam SDK for .NET

CheckinManager.CheckinFrom Method

Checks in a single file from an alternate location.

Overload List

Checks in a single file from an alternate location.

public virtual void CheckinFrom(File,FileInfo);

Checks in a single file from an output stream. No status update is performed in this case.

public virtual void CheckinFrom(File,Stream);

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinManager.CheckinFrom Method (File, FileInfo)

Checks in a single file from an alternate location.

public virtual void CheckinFrom(
File file,
FileInfo workingFile
);

Parameters

file
The file to be checked in.
workingFile
The alternate working file.

See Also

CheckinManager Class | Borland.StarTeam Namespace | CheckinManager.CheckinFrom Overload List


CheckinManager.CheckinFrom Method (File, Stream)

Checks in a single file from an output stream. No status update is performed in this case.

public virtual void CheckinFrom(
File file,
Stream stream
);

Parameters

file
The file to be checked in.
stream
The stream to which the checked in content is written.

See Also

CheckinManager Class | Borland.StarTeam Namespace | CheckinManager.CheckinFrom Overload List


CheckinManager.Equals Method

Delegate Equals() to com.starbase.starteam.CheckinManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.CheckinManager.Equals(obj).

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinManager.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.CheckinManager.

public override int GetHashCode();

Return Value

com.starbase.starteam.CheckinManager.GetHashCode().

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinManager.NewCheckinEventSource Method

public CheckinEventSource NewCheckinEventSource();

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinManager.SetCanceled Method

Cancels any pending checkin operations.

public virtual void SetCanceled();

See Also

CheckinManager Class | Borland.StarTeam Namespace | isCanceled


CheckinManager.ToString Method

Delegate ToString() to com.starbase.starteam.CheckinManager.

public override string ToString();

Return Value

com.starbase.starteam.CheckinManager.ToString()

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinManager.Wrap Method

Dynamically wraps com.starbase.starteam.CheckinManager.

public static CheckinManager Wrap(
CheckinManager impl
);

Parameters

impl
com.starbase.starteam.CheckinManager to be wrapped.

Return Value

CheckinManager

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinManager Type Conversions

The type conversions of the CheckinManager class are listed below. For a complete list of CheckinManager class members, see the CheckinManager Members topic.

Public Static Type Conversions

Implicit CheckinManager to CheckinManager Conversion Implicitly convert CheckinManager to com.starbase.starteam.CheckinManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinManager Class | CheckinManager Members | Borland.StarTeam Namespace


CheckinManager Implicit CheckinManager to CheckinManager Conversion

Implicitly convert CheckinManager to com.starbase.starteam.CheckinManager.

public static implicit operator CheckinManager(
CheckinManager arg
);

Parameters

arg
CheckinManager to convert.

Return Value

com.starbase.starteam.CheckinManager

See Also

CheckinManager Class | Borland.StarTeam Namespace


CheckinOptions Class

Maintains the checkout options used by CheckinManager.

For a list of all members of this type, see CheckinOptions Members.

System.Object
CheckinOptions

public class CheckinOptions : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckinOptions Members | Borland.StarTeam Namespace


CheckinOptions Members

CheckinOptions overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckinOptions.

Public Static Type Conversions

Implicit CheckinOptions to CheckinOptions Conversion Implicitly convert CheckinOptions to com.starbase.starteam.CheckinOptions.

Public Instance Constructors

CheckinOptions Overloaded. Initializes a new instance of the CheckinOptions class.

Public Instance Properties

AtomicCheckInDisabled | [read/write] Returns the "Atomic Checkin Disabled" option value.
AttachNewLabelsOnly | [read/write] true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.
CharacterSet | [read/write] CharacterSet
CheckinReason | [read/write] Returnsthe "Checkin Reason" option value.
CRsToMarkFixed | [read/write] Returns ChangeRequests to mark fixed; null, if none is specified.
DeleteWorkingFile | [read/write] Returns true if "Delete Working File" option is set; false, otherwise.
EOLConversionEnabled | [read/write] Return true if EOL conversion is enabled; false, otherwise.
EOLFormat | [read/write] EOLFormat
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
ForceCheckin | [read/write] Returns true if "Force Checkin" option is set; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking out files or the file associated with this CheckinOptions object.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LockType | [read/write] Return the type of lock to be used when checking out.
MarkProcessItemComplete | [read/write] true if the associated process item is to be marked complete; false, otherwise.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
MoveRevisionLabelIfAssigned | [read/write] true the revision label is to move if file already has one attached.; false, otherwise.
ProcessItem | [read/write] the process item to link and pin.
RestoreFileOnError | [read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.
RevisionLabel | [read/write] the revision label to attach.
UpdateStatus | [read/write] Return true if status information is to be updated after a successful checkout.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CheckinOptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckinOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CheckinOptions.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CheckinOptions Constructor

Construct CheckinOptions from com.starbase.starteam.CheckinOptions.

Overload List

Construct a CheckinOptions object with the same options as the given one.

public CheckinOptions(CheckinOptions);

Construct a CheckinOptions object with the same options as the given one.

public CheckinOptions(StarTeamClientOptions);

Construct a CheckinOptions object with default options from the View.

public CheckinOptions(View);

Construct CheckinOptions from com.starbase.starteam.CheckinOptions.

public CheckinOptions(CheckinOptions);

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CheckinOptions Constructor (CheckinOptions)

Construct CheckinOptions from com.starbase.starteam.CheckinOptions.

public CheckinOptions(
CheckinOptions impl
);

Parameters

impl
The com.starbase.starteam.CheckinOptions to be wrapped.

See Also

CheckinOptions Class | Borland.StarTeam Namespace | CheckinOptions Constructor Overload List


CheckinOptions Constructor (View)

Construct a CheckinOptions object with default options from the View.

public CheckinOptions(
View view
);

Parameters

view
a View object where the values of the options are picked up.

See Also

CheckinOptions Class | Borland.StarTeam Namespace | CheckinOptions Constructor Overload List | getOptions | View


CheckinOptions Constructor (StarTeamClientOptions)

Construct a CheckinOptions object with the same options as the given one.

public CheckinOptions(
StarTeamClientOptions options
);

Parameters

options
a CheckinOptions where the values of the options are picked up.

See Also

CheckinOptions Class | Borland.StarTeam Namespace | CheckinOptions Constructor Overload List | getOptions


CheckinOptions Constructor (CheckinOptions)

Construct a CheckinOptions object with the same options as the given one.

public CheckinOptions(
CheckinOptions options
);

Parameters

options
a CheckinOptions where the values of the options are picked up.

See Also

CheckinOptions Class | Borland.StarTeam Namespace | CheckinOptions Constructor Overload List | getOptions


CheckinOptions Properties

The properties of the CheckinOptions class are listed below. For a complete list of CheckinOptions class members, see the CheckinOptions Members topic.

Public Instance Properties

AtomicCheckInDisabled | [read/write] Returns the "Atomic Checkin Disabled" option value.
AttachNewLabelsOnly | [read/write] true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.
CharacterSet | [read/write] CharacterSet
CheckinReason | [read/write] Returnsthe "Checkin Reason" option value.
CRsToMarkFixed | [read/write] Returns ChangeRequests to mark fixed; null, if none is specified.
DeleteWorkingFile | [read/write] Returns true if "Delete Working File" option is set; false, otherwise.
EOLConversionEnabled | [read/write] Return true if EOL conversion is enabled; false, otherwise.
EOLFormat | [read/write] EOLFormat
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
ForceCheckin | [read/write] Returns true if "Force Checkin" option is set; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking out files or the file associated with this CheckinOptions object.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LockType | [read/write] Return the type of lock to be used when checking out.
MarkProcessItemComplete | [read/write] true if the associated process item is to be marked complete; false, otherwise.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
MoveRevisionLabelIfAssigned | [read/write] true the revision label is to move if file already has one attached.; false, otherwise.
ProcessItem | [read/write] the process item to link and pin.
RestoreFileOnError | [read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.
RevisionLabel | [read/write] the revision label to attach.
UpdateStatus | [read/write] Return true if status information is to be updated after a successful checkout.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinOptions Class | Borland.StarTeam Namespace


AtomicCheckInDisabled Property

Borland StarTeam SDK for .NET

CheckinOptions.AtomicCheckInDisabled Property

[read/write] Returns the "Atomic Checkin Disabled" option value.

public virtual Boolean AtomicCheckInDisabled {get; set;}

Property Value

Returns the "Atomic Checkin Disabled" option value.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


AttachNewLabelsOnly Property

Borland StarTeam SDK for .NET

CheckinOptions.AttachNewLabelsOnly Property

[read/write] true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.

public virtual Boolean AttachNewLabelsOnly {get; set;}

Property Value

true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CharacterSet Property

Borland StarTeam SDK for .NET

CheckinOptions.CharacterSet Property

[read/write] CharacterSet

public virtual CharacterSet CharacterSet {get; set;}

Property Value

CharacterSet

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CheckinReason Property

Borland StarTeam SDK for .NET

CheckinOptions.CheckinReason Property

[read/write] Returnsthe "Checkin Reason" option value.

public virtual String CheckinReason {get; set;}

Property Value

Returnsthe "Checkin Reason" option value.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CRsToMarkFixed Property

Borland StarTeam SDK for .NET

CheckinOptions.CRsToMarkFixed Property

[read/write] Returns ChangeRequests to mark fixed; null, if none is specified.

public virtual ChangeRequestCollection CRsToMarkFixed {get; set;}

Property Value

Returns ChangeRequests to mark fixed; null, if none is specified.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


DeleteWorkingFile Property

Borland StarTeam SDK for .NET

CheckinOptions.DeleteWorkingFile Property

[read/write] Returns true if "Delete Working File" option is set; false, otherwise.

public virtual Boolean DeleteWorkingFile {get; set;}

Property Value

Returns true if "Delete Working File" option is set; false, otherwise.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


EOLConversionEnabled Property

Borland StarTeam SDK for .NET

CheckinOptions.EOLConversionEnabled Property

[read/write] Return true if EOL conversion is enabled; false, otherwise.

public virtual Boolean EOLConversionEnabled {get; set;}

Property Value

Return true if EOL conversion is enabled; false, otherwise.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


EOLFormat Property

Borland StarTeam SDK for .NET

CheckinOptions.EOLFormat Property

[read/write] EOLFormat

public virtual EOLFormat EOLFormat {get; set;}

Property Value

EOLFormat

See Also

CheckinOptions Class | Borland.StarTeam Namespace


FileEncoding Property

Borland StarTeam SDK for .NET

CheckinOptions.FileEncoding Property

[read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

public virtual String FileEncoding {get; set;}

Property Value

the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

See Also

CheckinOptions Class | Borland.StarTeam Namespace


ForceCheckin Property

Borland StarTeam SDK for .NET

CheckinOptions.ForceCheckin Property

[read/write] Returns true if "Force Checkin" option is set; false, otherwise.

public virtual Boolean ForceCheckin {get; set;}

Property Value

Returns true if "Force Checkin" option is set; false, otherwise.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


IsFileSkipped Property

Borland StarTeam SDK for .NET

CheckinOptions.IsFileSkipped Property

[read/write] whether to skip checking out files or the file associated with this CheckinOptions object.

public virtual Boolean IsFileSkipped {get; set;}

Property Value

whether to skip checking out files or the file associated with this CheckinOptions object.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


KeywordExpansionEnabled Property

Borland StarTeam SDK for .NET

CheckinOptions.KeywordExpansionEnabled Property

[read/write] Return true if keyword expansion in text files is enabled; false, otherwise.

public virtual Boolean KeywordExpansionEnabled {get; set;}

Property Value

Return true if keyword expansion in text files is enabled; false, otherwise.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


LockType Property

Borland StarTeam SDK for .NET

CheckinOptions.LockType Property

[read/write] Return the type of lock to be used when checking out.

public virtual Int32 LockType {get; set;}

Property Value

Return the type of lock to be used when checking out.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


MarkProcessItemComplete Property

Borland StarTeam SDK for .NET

CheckinOptions.MarkProcessItemComplete Property

[read/write] true if the associated process item is to be marked complete; false, otherwise.

public virtual Boolean MarkProcessItemComplete {get; set;}

Property Value

true if the associated process item is to be marked complete; false, otherwise.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


MarkUnlockedFilesReadOnly Property

Borland StarTeam SDK for .NET

CheckinOptions.MarkUnlockedFilesReadOnly Property

[read/write] option value. Default if not defined: false

public virtual Boolean MarkUnlockedFilesReadOnly {get; set;}

Property Value

option value. Default if not defined: false

See Also

CheckinOptions Class | Borland.StarTeam Namespace


MoveRevisionLabelIfAssigned Property

Borland StarTeam SDK for .NET

CheckinOptions.MoveRevisionLabelIfAssigned Property

[read/write] true the revision label is to move if file already has one attached.; false, otherwise.

public virtual Boolean MoveRevisionLabelIfAssigned {get; set;}

Property Value

true the revision label is to move if file already has one attached.; false, otherwise.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


ProcessItem Property

Borland StarTeam SDK for .NET

CheckinOptions.ProcessItem Property

[read/write] the process item to link and pin.

public virtual Item ProcessItem {get; set;}

Property Value

the process item to link and pin.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


RestoreFileOnError Property

Borland StarTeam SDK for .NET

CheckinOptions.RestoreFileOnError Property

[read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.

public virtual Boolean RestoreFileOnError {get; set;}

Property Value

Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


RevisionLabel Property

Borland StarTeam SDK for .NET

CheckinOptions.RevisionLabel Property

[read/write] the revision label to attach.

public virtual Label RevisionLabel {get; set;}

Property Value

the revision label to attach.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


UpdateStatus Property

Borland StarTeam SDK for .NET

CheckinOptions.UpdateStatus Property

[read/write] Return true if status information is to be updated after a successful checkout.

public virtual Boolean UpdateStatus {get; set;}

Property Value

Return true if status information is to be updated after a successful checkout.

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CheckinOptions Methods

The methods of the CheckinOptions class are listed below. For a complete list of CheckinOptions class members, see the CheckinOptions Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckinOptions.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CheckinOptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckinOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CheckinOptions.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CheckinOptions.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.CheckinOptions

Implements

IWrapper.Unwrap

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CheckinOptions.Equals Method

Delegate Equals() to com.starbase.starteam.CheckinOptions.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.CheckinOptions.Equals(obj).

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CheckinOptions.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.CheckinOptions.

public override int GetHashCode();

Return Value

com.starbase.starteam.CheckinOptions.GetHashCode().

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CheckinOptions.ToString Method

Delegate ToString() to com.starbase.starteam.CheckinOptions.

public override string ToString();

Return Value

com.starbase.starteam.CheckinOptions.ToString()

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CheckinOptions.Wrap Method

Dynamically wraps com.starbase.starteam.CheckinOptions.

public static CheckinOptions Wrap(
CheckinOptions impl
);

Parameters

impl
com.starbase.starteam.CheckinOptions to be wrapped.

Return Value

CheckinOptions

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CheckinOptions Type Conversions

The type conversions of the CheckinOptions class are listed below. For a complete list of CheckinOptions class members, see the CheckinOptions Members topic.

Public Static Type Conversions

Implicit CheckinOptions to CheckinOptions Conversion Implicitly convert CheckinOptions to com.starbase.starteam.CheckinOptions.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinOptions Class | CheckinOptions Members | Borland.StarTeam Namespace


CheckinOptions Implicit CheckinOptions to CheckinOptions Conversion

Implicitly convert CheckinOptions to com.starbase.starteam.CheckinOptions.

public static implicit operator CheckinOptions(
CheckinOptions arg
);

Parameters

arg
CheckinOptions to convert.

Return Value

com.starbase.starteam.CheckinOptions

See Also

CheckinOptions Class | Borland.StarTeam Namespace


CheckinPhase Class

Information on the phase of a checkin progress of the checkin operation from CheckinManager.

For a list of all members of this type, see CheckinPhase Members.

System.Object
CheckinPhase

public class CheckinPhase : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckinPhase Members | Borland.StarTeam Namespace


CheckinPhase Members

CheckinPhase overview

Public Static Properties

ABORTING_CHANGES
CANCELED
COMMITTING_CHANGES
LINKING
POST_PROCESSING
PRE_PROCESSING
UPLOADING_CONTENT

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckinPhase.

Public Static Type Conversions

Implicit CheckinPhase to CheckinPhase Conversion Implicitly convert CheckinPhase to com.starbase.starteam.CheckinPhase.

Public Instance Constructors

CheckinPhase Constructor Construct CheckinPhase from com.starbase.starteam.CheckinPhase.

Public Instance Properties

Name [read] Return the name of this CheckinPhase.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CheckinPhase.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckinPhase.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CheckinPhase.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinPhase Class | Borland.StarTeam Namespace


CheckinPhase Constructor

Construct CheckinPhase from com.starbase.starteam.CheckinPhase.

public CheckinPhase(
CheckinPhase impl
);

Parameters

impl
The com.starbase.starteam.CheckinPhase to be wrapped.

See Also

CheckinPhase Class | Borland.StarTeam Namespace


CheckinPhase Properties

The properties of the CheckinPhase class are listed below. For a complete list of CheckinPhase class members, see the CheckinPhase Members topic.

Public Static Properties

ABORTING_CHANGES
CANCELED
COMMITTING_CHANGES
LINKING
POST_PROCESSING
PRE_PROCESSING
UPLOADING_CONTENT

Public Instance Properties

Name [read] Return the name of this CheckinPhase.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinPhase Class | Borland.StarTeam Namespace


ABORTING_CHANGES Property

Borland StarTeam SDK for .NET

CheckinPhase.ABORTING_CHANGES Property

public static CheckinPhase ABORTING_CHANGES {get;}

See Also

CheckinPhase Class | Borland.StarTeam Namespace


CANCELED Property

Borland StarTeam SDK for .NET

CheckinPhase.CANCELED Property

public static CheckinPhase CANCELED {get;}

See Also

CheckinPhase Class | Borland.StarTeam Namespace


COMMITTING_CHANGES Property

Borland StarTeam SDK for .NET

CheckinPhase.COMMITTING_CHANGES Property

public static CheckinPhase COMMITTING_CHANGES {get;}

See Also

CheckinPhase Class | Borland.StarTeam Namespace


LINKING Property

Borland StarTeam SDK for .NET

CheckinPhase.LINKING Property

public static CheckinPhase LINKING {get;}

See Also

CheckinPhase Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

CheckinPhase.Name Property

[read] Return the name of this CheckinPhase.

public virtual String Name {get;}

Property Value

Return the name of this CheckinPhase.

See Also

CheckinPhase Class | Borland.StarTeam Namespace


POST_PROCESSING Property

Borland StarTeam SDK for .NET

CheckinPhase.POST_PROCESSING Property

public static CheckinPhase POST_PROCESSING {get;}

See Also

CheckinPhase Class | Borland.StarTeam Namespace


PRE_PROCESSING Property

Borland StarTeam SDK for .NET

CheckinPhase.PRE_PROCESSING Property

public static CheckinPhase PRE_PROCESSING {get;}

See Also

CheckinPhase Class | Borland.StarTeam Namespace


UPLOADING_CONTENT Property

Borland StarTeam SDK for .NET

CheckinPhase.UPLOADING_CONTENT Property

public static CheckinPhase UPLOADING_CONTENT {get;}

See Also

CheckinPhase Class | Borland.StarTeam Namespace


CheckinPhase Methods

The methods of the CheckinPhase class are listed below. For a complete list of CheckinPhase class members, see the CheckinPhase Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckinPhase.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CheckinPhase.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckinPhase.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CheckinPhase.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinPhase Class | Borland.StarTeam Namespace


CheckinPhase.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.CheckinPhase

Implements

IWrapper.Unwrap

See Also

CheckinPhase Class | Borland.StarTeam Namespace


CheckinPhase.Equals Method

Delegate Equals() to com.starbase.starteam.CheckinPhase.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.CheckinPhase.Equals(obj).

See Also

CheckinPhase Class | Borland.StarTeam Namespace


CheckinPhase.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.CheckinPhase.

public override int GetHashCode();

Return Value

com.starbase.starteam.CheckinPhase.GetHashCode().

See Also

CheckinPhase Class | Borland.StarTeam Namespace


CheckinPhase.ToString Method

Delegate ToString() to com.starbase.starteam.CheckinPhase.

public override string ToString();

Return Value

com.starbase.starteam.CheckinPhase.ToString()

See Also

CheckinPhase Class | Borland.StarTeam Namespace


CheckinPhase.Wrap Method

Dynamically wraps com.starbase.starteam.CheckinPhase.

public static CheckinPhase Wrap(
CheckinPhase impl
);

Parameters

impl
com.starbase.starteam.CheckinPhase to be wrapped.

Return Value

CheckinPhase

See Also

CheckinPhase Class | Borland.StarTeam Namespace


CheckinPhase Type Conversions

The type conversions of the CheckinPhase class are listed below. For a complete list of CheckinPhase class members, see the CheckinPhase Members topic.

Public Static Type Conversions

Implicit CheckinPhase to CheckinPhase Conversion Implicitly convert CheckinPhase to com.starbase.starteam.CheckinPhase.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinPhase Class | CheckinPhase Members | Borland.StarTeam Namespace


CheckinPhase Implicit CheckinPhase to CheckinPhase Conversion

Implicitly convert CheckinPhase to com.starbase.starteam.CheckinPhase.

public static implicit operator CheckinPhase(
CheckinPhase arg
);

Parameters

arg
CheckinPhase to convert.

Return Value

com.starbase.starteam.CheckinPhase

See Also

CheckinPhase Class | Borland.StarTeam Namespace


CheckinProgress Class

Information on the progress of a checkin operation from CheckinManager. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use CheckinManager.getProgress().

For a list of all members of this type, see CheckinProgress Members.

System.Object
CheckinProgress

public class CheckinProgress : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckinProgress Members | Borland.StarTeam Namespace


CheckinProgress Members

CheckinProgress overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckinProgress.

Public Static Type Conversions

Implicit CheckinProgress to CheckinProgress Conversion Implicitly convert CheckinProgress to com.starbase.starteam.CheckinProgress.

Public Instance Constructors

CheckinProgress Constructor Construct CheckinProgress from com.starbase.starteam.CheckinProgress.

Public Instance Properties

CheckinPhase | [read] the CheckinPhase associated with this CheckinProgress.
CurrentPhaseEstimatedTimeRemaining | [read] the estimated time remaining in milliseconds.
CurrentPhaseUnitsOfWork | [read] Return the total number of units of work.
CurrentPhaseUnitsOfWorkProcessed | [read] the number of units of work that has been processed in this phase.
CurrentPhaseUnitsOfWorkRemaining | [read] Return the total number of units of work that are yet to be done.
CurrentStarteamItem | [read] Return the current StarTeam Item that's being processed in the current phase.
CurrentWorkingFile | [read] Return the current File object that's being checked in in the specified thread ID.
Description | [read]
LastError |
SnapshotTime | [read] DateTime the snapshot time that is set when the last clone was created.
TotalBytesCheckedIn | [read] Return the total number of bytes that are checked in.
TotalFilesCheckedIn | [read] the number of files that have been checked in.
TotalFilesFailed | [read] Return the total number of files that failed during checkin.
TotalFilesForCheckin | [read] Return the total number of files for checkin.
TotalFilesProcessed | [read] Return the total number of files to be checked in.
TotalFilesRemaining | [read] the number of files left to be checked in.
TotalFilesSkipped | [read] Return the total number of files skipped without being checked in.
TotalTimeSpent | [read] Return the time spent on checking in in milliseconds.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CheckinProgress.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckinProgress.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CheckinProgress.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CheckinProgress Constructor

Construct CheckinProgress from com.starbase.starteam.CheckinProgress.

public CheckinProgress(
CheckinProgress impl
);

Parameters

impl
The com.starbase.starteam.CheckinProgress to be wrapped.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CheckinProgress Properties

The properties of the CheckinProgress class are listed below. For a complete list of CheckinProgress class members, see the CheckinProgress Members topic.

Public Instance Properties

CheckinPhase | [read] the CheckinPhase associated with this CheckinProgress.
CurrentPhaseEstimatedTimeRemaining | [read] the estimated time remaining in milliseconds.
CurrentPhaseUnitsOfWork | [read] Return the total number of units of work.
CurrentPhaseUnitsOfWorkProcessed | [read] the number of units of work that has been processed in this phase.
CurrentPhaseUnitsOfWorkRemaining | [read] Return the total number of units of work that are yet to be done.
CurrentStarteamItem | [read] Return the current StarTeam Item that's being processed in the current phase.
CurrentWorkingFile | [read] Return the current File object that's being checked in in the specified thread ID.
Description | [read]
LastError |
SnapshotTime | [read] DateTime the snapshot time that is set when the last clone was created.
TotalBytesCheckedIn | [read] Return the total number of bytes that are checked in.
TotalFilesCheckedIn | [read] the number of files that have been checked in.
TotalFilesFailed | [read] Return the total number of files that failed during checkin.
TotalFilesForCheckin | [read] Return the total number of files for checkin.
TotalFilesProcessed | [read] Return the total number of files to be checked in.
TotalFilesRemaining | [read] the number of files left to be checked in.
TotalFilesSkipped | [read] Return the total number of files skipped without being checked in.
TotalTimeSpent | [read] Return the time spent on checking in in milliseconds.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CheckinPhase Property

Borland StarTeam SDK for .NET

CheckinProgress.CheckinPhase Property

[read] the CheckinPhase associated with this CheckinProgress.

public virtual CheckinPhase CheckinPhase {get;}

Property Value

the CheckinPhase associated with this CheckinProgress.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CurrentPhaseEstimatedTimeRemaining Property

Borland StarTeam SDK for .NET

CheckinProgress.CurrentPhaseEstimatedTimeRemaining Property

[read] the estimated time remaining in milliseconds.

public virtual Int64 CurrentPhaseEstimatedTimeRemaining {get;}

Property Value

the estimated time remaining in milliseconds.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CurrentPhaseUnitsOfWork Property

Borland StarTeam SDK for .NET

CheckinProgress.CurrentPhaseUnitsOfWork Property

[read] Return the total number of units of work.

public virtual Int64 CurrentPhaseUnitsOfWork {get;}

Property Value

Return the total number of units of work.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CurrentPhaseUnitsOfWorkProcessed Property

Borland StarTeam SDK for .NET

CheckinProgress.CurrentPhaseUnitsOfWorkProcessed Property

[read] the number of units of work that has been processed in this phase.

public virtual Int64 CurrentPhaseUnitsOfWorkProcessed {get;}

Property Value

the number of units of work that has been processed in this phase.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CurrentPhaseUnitsOfWorkRemaining Property

Borland StarTeam SDK for .NET

CheckinProgress.CurrentPhaseUnitsOfWorkRemaining Property

[read] Return the total number of units of work that are yet to be done.

public virtual Int64 CurrentPhaseUnitsOfWorkRemaining {get;}

Property Value

Return the total number of units of work that are yet to be done.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CurrentStarteamItem Property

Borland StarTeam SDK for .NET

CheckinProgress.CurrentStarteamItem Property

[read] Return the current StarTeam Item that's being processed in the current phase.

public virtual Item CurrentStarteamItem {get;}

Property Value

Return the current StarTeam Item that's being processed in the current phase.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CurrentWorkingFile Property

Borland StarTeam SDK for .NET

CheckinProgress.CurrentWorkingFile Property

[read] Return the current File object that's being checked in in the specified thread ID.

public virtual FileInfo CurrentWorkingFile {get;}

Property Value

Return the current File object that's being checked in in the specified thread ID.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

CheckinProgress.Description Property

[read]

public virtual String Description {get;}

See Also

CheckinProgress Class | Borland.StarTeam Namespace


LastError Property

Borland StarTeam SDK for .NET

CheckinProgress.LastError Property

public virtual Exception LastError {get;}

See Also

CheckinProgress Class | Borland.StarTeam Namespace


SnapshotTime Property

Borland StarTeam SDK for .NET

CheckinProgress.SnapshotTime Property

[read] DateTime the snapshot time that is set when the last clone was created.

public virtual DateTime SnapshotTime {get;}

Property Value

DateTime the snapshot time that is set when the last clone was created.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


TotalBytesCheckedIn Property

Borland StarTeam SDK for .NET

CheckinProgress.TotalBytesCheckedIn Property

[read] Return the total number of bytes that are checked in.

public virtual Int64 TotalBytesCheckedIn {get;}

Property Value

Return the total number of bytes that are checked in.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


TotalFilesCheckedIn Property

Borland StarTeam SDK for .NET

CheckinProgress.TotalFilesCheckedIn Property

[read] the number of files that have been checked in.

public virtual Int64 TotalFilesCheckedIn {get;}

Property Value

the number of files that have been checked in.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


TotalFilesFailed Property

Borland StarTeam SDK for .NET

CheckinProgress.TotalFilesFailed Property

[read] Return the total number of files that failed during checkin.

public virtual Int64 TotalFilesFailed {get;}

Property Value

Return the total number of files that failed during checkin.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


TotalFilesForCheckin Property

Borland StarTeam SDK for .NET

CheckinProgress.TotalFilesForCheckin Property

[read] Return the total number of files for checkin.

public virtual Int64 TotalFilesForCheckin {get;}

Property Value

Return the total number of files for checkin.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


TotalFilesProcessed Property

Borland StarTeam SDK for .NET

CheckinProgress.TotalFilesProcessed Property

[read] Return the total number of files to be checked in.

public virtual Int64 TotalFilesProcessed {get;}

Property Value

Return the total number of files to be checked in.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


TotalFilesRemaining Property

Borland StarTeam SDK for .NET

CheckinProgress.TotalFilesRemaining Property

[read] the number of files left to be checked in.

public virtual Int64 TotalFilesRemaining {get;}

Property Value

the number of files left to be checked in.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


TotalFilesSkipped Property

Borland StarTeam SDK for .NET

CheckinProgress.TotalFilesSkipped Property

[read] Return the total number of files skipped without being checked in.

public virtual Int64 TotalFilesSkipped {get;}

Property Value

Return the total number of files skipped without being checked in.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


TotalTimeSpent Property

Borland StarTeam SDK for .NET

CheckinProgress.TotalTimeSpent Property

[read] Return the time spent on checking in in milliseconds.

public virtual Int64 TotalTimeSpent {get;}

Property Value

Return the time spent on checking in in milliseconds.

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CheckinProgress Methods

The methods of the CheckinProgress class are listed below. For a complete list of CheckinProgress class members, see the CheckinProgress Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckinProgress.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CheckinProgress.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckinProgress.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.CheckinProgress.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CheckinProgress.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.CheckinProgress

Implements

IWrapper.Unwrap

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CheckinProgress.Equals Method

Delegate Equals() to com.starbase.starteam.CheckinProgress.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.CheckinProgress.Equals(obj).

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CheckinProgress.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.CheckinProgress.

public override int GetHashCode();

Return Value

com.starbase.starteam.CheckinProgress.GetHashCode().

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CheckinProgress.ToString Method

Delegate ToString() to com.starbase.starteam.CheckinProgress.

public override string ToString();

Return Value

com.starbase.starteam.CheckinProgress.ToString()

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CheckinProgress.Wrap Method

Dynamically wraps com.starbase.starteam.CheckinProgress.

public static CheckinProgress Wrap(
CheckinProgress impl
);

Parameters

impl
com.starbase.starteam.CheckinProgress to be wrapped.

Return Value

CheckinProgress

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CheckinProgress Type Conversions

The type conversions of the CheckinProgress class are listed below. For a complete list of CheckinProgress class members, see the CheckinProgress Members topic.

Public Static Type Conversions

Implicit CheckinProgress to CheckinProgress Conversion Implicitly convert CheckinProgress to com.starbase.starteam.CheckinProgress.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckinProgress Class | CheckinProgress Members | Borland.StarTeam Namespace


CheckinProgress Implicit CheckinProgress to CheckinProgress Conversion

Implicitly convert CheckinProgress to com.starbase.starteam.CheckinProgress.

public static implicit operator CheckinProgress(
CheckinProgress arg
);

Parameters

arg
CheckinProgress to convert.

Return Value

com.starbase.starteam.CheckinProgress

See Also

CheckinProgress Class | Borland.StarTeam Namespace


CheckInResult Class

The class holds return information specific to the file checkin operation.

For a list of all members of this type, see CheckInResult Members.

System.Object
FileResult
CheckInResult

public class CheckInResult : FileResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckInResult Members | Borland.StarTeam Namespace


CheckInResult Members

CheckInResult overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckInResult.

Public Static Type Conversions

Implicit CheckInResult to CheckInResult Conversion Implicitly convert CheckInResult to com.starbase.starteam.CheckInResult.

Public Instance Constructors

CheckInResult Constructor Construct CheckInResult from com.starbase.starteam.CheckInResult.

Public Instance Properties

ExclusiveLockerID | [read] the user ID of the user that has an exclusive lock on the file.
Keywords (inherited from FileResult) | [read] the keywords used for the file operation.
MyLockState | [read] the lock state of the file for the user performing the checkout.

Public Instance Methods

Equals (inherited from FileResult) | Delegate Equals() to com.starbase.starteam.FileResult.
GetHashCode (inherited from FileResult) | Delegate GetHashCode() to com.starbase.starteam.FileResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from FileResult) | Delegate ToString() to com.starbase.starteam.FileResult.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileResult) Implementation of IWrapper.Unwrap().

See Also

CheckInResult Class | Borland.StarTeam Namespace


CheckInResult Constructor

Construct CheckInResult from com.starbase.starteam.CheckInResult.

public CheckInResult(
CheckInResult impl
);

Parameters

impl
The com.starbase.starteam.CheckInResult to be wrapped.

See Also

CheckInResult Class | Borland.StarTeam Namespace


CheckInResult Properties

The properties of the CheckInResult class are listed below. For a complete list of CheckInResult class members, see the CheckInResult Members topic.

Public Instance Properties

ExclusiveLockerID | [read] the user ID of the user that has an exclusive lock on the file.
Keywords (inherited from FileResult) | [read] the keywords used for the file operation.
MyLockState | [read] the lock state of the file for the user performing the checkout.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileResult) Implementation of IWrapper.Unwrap().

See Also

CheckInResult Class | Borland.StarTeam Namespace


ExclusiveLockerID Property

Borland StarTeam SDK for .NET

CheckInResult.ExclusiveLockerID Property

[read] the user ID of the user that has an exclusive lock on the file.

public virtual Int32 ExclusiveLockerID {get;}

Property Value

the user ID of the user that has an exclusive lock on the file.

See Also

CheckInResult Class | Borland.StarTeam Namespace


MyLockState Property

Borland StarTeam SDK for .NET

CheckInResult.MyLockState Property

[read] the lock state of the file for the user performing the checkout.

public virtual Int32 MyLockState {get;}

Property Value

the lock state of the file for the user performing the checkout.

See Also

CheckInResult Class | Borland.StarTeam Namespace


CheckInResult Methods

The methods of the CheckInResult class are listed below. For a complete list of CheckInResult class members, see the CheckInResult Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckInResult.

Public Instance Methods

Equals (inherited from FileResult) | Delegate Equals() to com.starbase.starteam.FileResult.
GetHashCode (inherited from FileResult) | Delegate GetHashCode() to com.starbase.starteam.FileResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from FileResult) | Delegate ToString() to com.starbase.starteam.FileResult.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileResult) Implementation of IWrapper.Unwrap().

See Also

CheckInResult Class | Borland.StarTeam Namespace


CheckInResult.Wrap Method

Dynamically wraps com.starbase.starteam.CheckInResult.

public static CheckInResult Wrap(
CheckInResult impl
);

Parameters

impl
com.starbase.starteam.CheckInResult to be wrapped.

Return Value

CheckInResult

See Also

CheckInResult Class | Borland.StarTeam Namespace


CheckInResult Type Conversions

The type conversions of the CheckInResult class are listed below. For a complete list of CheckInResult class members, see the CheckInResult Members topic.

Public Static Type Conversions

Implicit CheckInResult to CheckInResult Conversion Implicitly convert CheckInResult to com.starbase.starteam.CheckInResult.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileResult) Implementation of IWrapper.Unwrap().

See Also

CheckInResult Class | CheckInResult Members | Borland.StarTeam Namespace


CheckInResult Implicit CheckInResult to CheckInResult Conversion

Implicitly convert CheckInResult to com.starbase.starteam.CheckInResult.

public static implicit operator CheckInResult(
CheckInResult arg
);

Parameters

arg
CheckInResult to convert.

Return Value

com.starbase.starteam.CheckInResult

See Also

CheckInResult Class | Borland.StarTeam Namespace


CheckoutEventArgs Class

For a list of all members of this type, see CheckoutEventArgs Members.

System.Object
EventArgs
CheckoutEventArgs

public class CheckoutEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckoutEventArgs Members | Borland.StarTeam Namespace


CheckoutEventArgs Members

CheckoutEventArgs overview

Public Static Type Conversions

Implicit CheckoutEventArgs to CheckoutEvent Conversion Implicitly convert CheckoutEventArgs to com.starbase.starteam.CheckoutEvent.

Public Instance Properties

CheckoutManager | [read] The CheckoutManager that triggered this CheckoutEvent.
CheckoutResults | [read] Details describing the result of this checkout, or null if the checkout of this file is still in progress or finished with an error.
CheckoutThreadIndex | [read] The index of this thread within the CheckoutManager's running thread list.
CurrentBytesExpected | [read] The total number of bytes expected in this file.
CurrentBytesSoFar | [read] The number of bytes checked out so far for this file.
CurrentFile | [read] The StarTeam File being checked out.
CurrentWorkingFile | [read/write] The working file on disk where this file is being checked out to, or null if this file is being checked out to a stream rather than a file.
Error |
IsCanceled | [read] true if the checkout operation has been canceled (for all remaining files), and false otherwise.
IsFinished | [read] true if the checkout operation for this file is finished; false if it is still in progress. Note that the checkout may have finished, but unsuccessfully.
IsMPXCacheAgentThread | [read] true if this thread is checking out files from the MPX File Cache Agent, and false if this thread is checking out directly from the StarTeam server.
IsSuccessful | [read] true if the checkout operation for this file has finished successfully; false if the checkout is still in progress, or if it finished with an error.
Options | [read] The checkout options that apply to the current file.
Progress | [read] A snapshot of the state of the current checkout operation, as of the time that this event was triggered.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CheckoutEventArgs Properties

The properties of the CheckoutEventArgs class are listed below. For a complete list of CheckoutEventArgs class members, see the CheckoutEventArgs Members topic.

Public Instance Properties

CheckoutManager | [read] The CheckoutManager that triggered this CheckoutEvent.
CheckoutResults | [read] Details describing the result of this checkout, or null if the checkout of this file is still in progress or finished with an error.
CheckoutThreadIndex | [read] The index of this thread within the CheckoutManager's running thread list.
CurrentBytesExpected | [read] The total number of bytes expected in this file.
CurrentBytesSoFar | [read] The number of bytes checked out so far for this file.
CurrentFile | [read] The StarTeam File being checked out.
CurrentWorkingFile | [read/write] The working file on disk where this file is being checked out to, or null if this file is being checked out to a stream rather than a file.
Error |
IsCanceled | [read] true if the checkout operation has been canceled (for all remaining files), and false otherwise.
IsFinished | [read] true if the checkout operation for this file is finished; false if it is still in progress. Note that the checkout may have finished, but unsuccessfully.
IsMPXCacheAgentThread | [read] true if this thread is checking out files from the MPX File Cache Agent, and false if this thread is checking out directly from the StarTeam server.
IsSuccessful | [read] true if the checkout operation for this file has finished successfully; false if the checkout is still in progress, or if it finished with an error.
Options | [read] The checkout options that apply to the current file.
Progress | [read] A snapshot of the state of the current checkout operation, as of the time that this event was triggered.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CheckoutManager Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CheckoutManager Property

[read] The CheckoutManager that triggered this CheckoutEvent.

public virtual CheckoutManager CheckoutManager {get;}

Property Value

The CheckoutManager that triggered this CheckoutEvent.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CheckoutResults Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CheckoutResults Property

[read] Details describing the result of this checkout, or null if the checkout of this file is still in progress or finished with an error.

public virtual CheckOutResult CheckoutResults {get;}

Property Value

Details describing the result of this checkout, or null if the checkout of this file is still in progress or finished with an error.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CheckoutThreadIndex Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CheckoutThreadIndex Property

[read] The index of this thread within the CheckoutManager's running thread list.

public virtual Int32 CheckoutThreadIndex {get;}

Property Value

The index of this thread within the CheckoutManager's running thread list.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CurrentBytesExpected Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CurrentBytesExpected Property

[read] The total number of bytes expected in this file.

public virtual Int64 CurrentBytesExpected {get;}

Property Value

The total number of bytes expected in this file.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CurrentBytesSoFar Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CurrentBytesSoFar Property

[read] The number of bytes checked out so far for this file.

public virtual Int64 CurrentBytesSoFar {get;}

Property Value

The number of bytes checked out so far for this file.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CurrentFile Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CurrentFile Property

[read] The StarTeam File being checked out.

public virtual File CurrentFile {get;}

Property Value

The StarTeam File being checked out.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CurrentWorkingFile Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CurrentWorkingFile Property

[read/write] The working file on disk where this file is being checked out to, or null if this file is being checked out to a stream rather than a file.

public virtual FileInfo CurrentWorkingFile {get; set;}

Property Value

The working file on disk where this file is being checked out to, or null if this file is being checked out to a stream rather than a file.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


Error Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.Error Property

public virtual Exception Error {get;}

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.IsCanceled Property

[read] true if the checkout operation has been canceled (for all remaining files), and false otherwise.

public virtual Boolean IsCanceled {get;}

Property Value

true if the checkout operation has been canceled (for all remaining files), and false otherwise.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


IsFinished Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.IsFinished Property

[read] true if the checkout operation for this file is finished; false if it is still in progress. Note that the checkout may have finished, but unsuccessfully.

public virtual Boolean IsFinished {get;}

Property Value

true if the checkout operation for this file is finished; false if it is still in progress. Note that the checkout may have finished, but unsuccessfully.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


IsMPXCacheAgentThread Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.IsMPXCacheAgentThread Property

[read] true if this thread is checking out files from the MPX File Cache Agent, and false if this thread is checking out directly from the StarTeam server.

public virtual Boolean IsMPXCacheAgentThread {get;}

Property Value

true if this thread is checking out files from the MPX File Cache Agent, and false if this thread is checking out directly from the StarTeam server.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


IsSuccessful Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.IsSuccessful Property

[read] true if the checkout operation for this file has finished successfully; false if the checkout is still in progress, or if it finished with an error.

public virtual Boolean IsSuccessful {get;}

Property Value

true if the checkout operation for this file has finished successfully; false if the checkout is still in progress, or if it finished with an error.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


Options Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.Options Property

[read] The checkout options that apply to the current file.

public virtual CheckoutOptions Options {get;}

Property Value

The checkout options that apply to the current file.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


Progress Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.Progress Property

[read] A snapshot of the state of the current checkout operation, as of the time that this event was triggered.

public virtual CheckoutProgress Progress {get;}

Property Value

A snapshot of the state of the current checkout operation, as of the time that this event was triggered.

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CheckoutEventArgs Methods

The methods of the CheckoutEventArgs class are listed below. For a complete list of CheckoutEventArgs class members, see the CheckoutEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CheckoutEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CheckoutEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CheckoutEventArgs.ToString Method

public override string ToString();

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CheckoutEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CheckoutEventArgs Type Conversions

The type conversions of the CheckoutEventArgs class are listed below. For a complete list of CheckoutEventArgs class members, see the CheckoutEventArgs Members topic.

Public Static Type Conversions

Implicit CheckoutEventArgs to CheckoutEvent Conversion Implicitly convert CheckoutEventArgs to com.starbase.starteam.CheckoutEvent.

See Also

CheckoutEventArgs Class | CheckoutEventArgs Members | Borland.StarTeam Namespace


CheckoutEventArgs Implicit CheckoutEventArgs to CheckoutEvent Conversion

Implicitly convert CheckoutEventArgs to com.starbase.starteam.CheckoutEvent.

public static implicit operator CheckoutEvent(
CheckoutEventArgs arg
);

Parameters

arg
CheckoutEventArgs to convert.

Return Value

com.starbase.starteam.CheckoutEvent

See Also

CheckoutEventArgs Class | Borland.StarTeam Namespace


CheckoutEventSource Class

For a list of all members of this type, see CheckoutEventSource Members.

System.Object
CheckoutEventSource

public class CheckoutEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckoutEventSource Members | Borland.StarTeam Namespace


CheckoutEventSource Members

CheckoutEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnNotifyProgress
OnOnNotifyProgress
OnOnStartFile
OnStartFile

See Also

CheckoutEventSource Class | Borland.StarTeam Namespace


CheckoutEventSource Properties

The properties of the CheckoutEventSource class are listed below. For a complete list of CheckoutEventSource class members, see the CheckoutEventSource Members topic.

Public Instance Properties

Parent

See Also

CheckoutEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

CheckoutEventSource.Parent Property

public Object Parent {get;}

See Also

CheckoutEventSource Class | Borland.StarTeam Namespace


CheckoutEventSource Events

The events of the CheckoutEventSource class are listed below. For a complete list of CheckoutEventSource class members, see the CheckoutEventSource Members topic.

Public Instance Events

OnNotifyProgress
OnOnNotifyProgress
OnOnStartFile
OnStartFile

See Also

CheckoutEventSource Class | Borland.StarTeam Namespace


CheckoutEventSource.OnNotifyProgress Event

public event CheckoutEventSource.Handler OnNotifyProgress;

See Also

CheckoutEventSource Class | Borland.StarTeam Namespace


CheckoutEventSource.OnOnNotifyProgress Event

public event CheckoutEventSource.Handler OnOnNotifyProgress;

See Also

CheckoutEventSource Class | Borland.StarTeam Namespace


CheckoutEventSource.OnOnStartFile Event

public event CheckoutEventSource.Handler OnOnStartFile;

See Also

CheckoutEventSource Class | Borland.StarTeam Namespace


CheckoutEventSource.OnStartFile Event

public event CheckoutEventSource.Handler OnStartFile;

See Also

CheckoutEventSource Class | Borland.StarTeam Namespace


CheckoutEventSource.Handler Delegate

public delegate void CheckoutEventSource.Handler(
CheckoutEventSource source,
CheckoutEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


CheckoutManager Class

Provides a way to check out multiple files, applying a consistent set of options across all files.

For a list of all members of this type, see CheckoutManager Members.

System.Object
CheckoutManager

public class CheckoutManager : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckoutManager Members | Borland.StarTeam Namespace


CheckoutManager Members

CheckoutManager overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckoutManager.

Public Static Type Conversions

Implicit CheckoutManager to CheckoutManager Conversion Implicitly convert CheckoutManager to com.starbase.starteam.CheckoutManager.

Public Instance Constructors

CheckoutManager Overloaded. Initializes a new instance of the CheckoutManager class.

Public Instance Properties

IsCanceled | [read] true if pending checkout operations have been canceled, and false otherwise.
IsRunning | [read] true if there is currently a checkout operation in progress, and false otherwise.
MPXCacheAgentAddress | [read/write] The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.
MPXCacheAgentEnabled | [read/write] True to enable checkouts via the MPX cache agent; false to force all checkouts to use the StarTeam server directly.
MPXCacheAgentPort | [read/write] The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.
MPXCacheAgentThreadCount | [read/write] The number of threads used by the MPX cache agent to fetch file content. The default value is 3.
Options | [read/write] The checkout options currently in effect.
Progress | [read] A snapshot of the state of the current checkout operation.

Public Instance Methods

Checkout | Overloaded. Checks out a single file to the default location.
CheckoutTo | Overloaded. Checks out a single file to an alternate location.
Equals | Delegate Equals() to com.starbase.starteam.CheckoutManager.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckoutManager.
GetType (inherited from Object) | Gets the Type of the current instance.
NewCheckoutEventSource |
SetCanceled | Cancels any pending checkout operations.
ToString | Delegate ToString() to com.starbase.starteam.CheckoutManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutManager Constructor

Construct CheckoutManager from com.starbase.starteam.CheckoutManager.

Overload List

Constructs a CheckoutManager with default options.

public CheckoutManager(View);

Constructs a CheckoutManager with the same options as the given one.

public CheckoutManager(View,CheckoutManager);

Constructs a CheckoutManager using a specific set of options. Note that individual options can be overridden on a file-by-file basis by registering a CheckoutListener, and changing options as necessary in the onStartFile event handler.

public CheckoutManager(View,CheckoutOptions);

Construct CheckoutManager from com.starbase.starteam.CheckoutManager.

public CheckoutManager(CheckoutManager);

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutManager Constructor (CheckoutManager)

Construct CheckoutManager from com.starbase.starteam.CheckoutManager.

public CheckoutManager(
CheckoutManager impl
);

Parameters

impl
The com.starbase.starteam.CheckoutManager to be wrapped.

See Also

CheckoutManager Class | Borland.StarTeam Namespace | CheckoutManager Constructor Overload List


CheckoutManager Constructor (View)

Constructs a CheckoutManager with default options.

public CheckoutManager(
View view
);

Parameters

view
The View containing the files to be checked out.

See Also

CheckoutManager Class | Borland.StarTeam Namespace | CheckoutManager Constructor Overload List


CheckoutManager Constructor (View, CheckoutOptions)

Constructs a CheckoutManager using a specific set of options.

Note that individual options can be overridden on a file-by-file basis by registering a CheckoutListener, and changing options as necessary in the onStartFile event handler.

public CheckoutManager(
View view,
CheckoutOptions options
);

Parameters

view
The View containing the files to be checked out.
options
The specific CheckoutOtions to be used.

See Also

CheckoutManager Class | Borland.StarTeam Namespace | CheckoutManager Constructor Overload List | CheckoutOptions | addCheckoutListener | onStartFile


CheckoutManager Constructor (View, CheckoutManager)

Constructs a CheckoutManager with the same options as the given one.

public CheckoutManager(
View view,
CheckoutManager checkoutManager
);

Parameters

view
The View containing the files to be checked out.
checkoutManager
The CheckoutManager whose options are to be copied.

See Also

CheckoutManager Class | Borland.StarTeam Namespace | CheckoutManager Constructor Overload List


CheckoutManager Properties

The properties of the CheckoutManager class are listed below. For a complete list of CheckoutManager class members, see the CheckoutManager Members topic.

Public Instance Properties

IsCanceled | [read] true if pending checkout operations have been canceled, and false otherwise.
IsRunning | [read] true if there is currently a checkout operation in progress, and false otherwise.
MPXCacheAgentAddress | [read/write] The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.
MPXCacheAgentEnabled | [read/write] True to enable checkouts via the MPX cache agent; false to force all checkouts to use the StarTeam server directly.
MPXCacheAgentPort | [read/write] The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.
MPXCacheAgentThreadCount | [read/write] The number of threads used by the MPX cache agent to fetch file content. The default value is 3.
Options | [read/write] The checkout options currently in effect.
Progress | [read] A snapshot of the state of the current checkout operation.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutManager Class | Borland.StarTeam Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

CheckoutManager.IsCanceled Property

[read] true if pending checkout operations have been canceled, and false otherwise.

public virtual Boolean IsCanceled {get;}

Property Value

true if pending checkout operations have been canceled, and false otherwise.

See Also

CheckoutManager Class | Borland.StarTeam Namespace


IsRunning Property

Borland StarTeam SDK for .NET

CheckoutManager.IsRunning Property

[read] true if there is currently a checkout operation in progress, and false otherwise.

public virtual Boolean IsRunning {get;}

Property Value

true if there is currently a checkout operation in progress, and false otherwise.

See Also

CheckoutManager Class | Borland.StarTeam Namespace


MPXCacheAgentAddress Property

Borland StarTeam SDK for .NET

CheckoutManager.MPXCacheAgentAddress Property

[read/write] The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.

public virtual String MPXCacheAgentAddress {get; set;}

Property Value

The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.

See Also

CheckoutManager Class | Borland.StarTeam Namespace


MPXCacheAgentEnabled Property

Borland StarTeam SDK for .NET

CheckoutManager.MPXCacheAgentEnabled Property

[read/write] True to enable checkouts via the MPX cache agent; false to force all checkouts to use the StarTeam server directly.

public virtual Boolean MPXCacheAgentEnabled {get; set;}

Property Value

True to enable checkouts via the MPX cache agent; false to force all checkouts to use the StarTeam server directly.

See Also

CheckoutManager Class | Borland.StarTeam Namespace


MPXCacheAgentPort Property

Borland StarTeam SDK for .NET

CheckoutManager.MPXCacheAgentPort Property

[read/write] The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.

public virtual Int32 MPXCacheAgentPort {get; set;}

Property Value

The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.

See Also

CheckoutManager Class | Borland.StarTeam Namespace


MPXCacheAgentThreadCount Property

Borland StarTeam SDK for .NET

CheckoutManager.MPXCacheAgentThreadCount Property

[read/write] The number of threads used by the MPX cache agent to fetch file content. The default value is 3.

public virtual Int32 MPXCacheAgentThreadCount {get; set;}

Property Value

The number of threads used by the MPX cache agent to fetch file content. The default value is 3.

See Also

CheckoutManager Class | Borland.StarTeam Namespace


Options Property

Borland StarTeam SDK for .NET

CheckoutManager.Options Property

[read/write] The checkout options currently in effect.

public virtual CheckoutOptions Options {get; set;}

Property Value

The checkout options currently in effect.

See Also

CheckoutManager Class | Borland.StarTeam Namespace


Progress Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress Property

[read] A snapshot of the state of the current checkout operation.

public virtual CheckoutProgress Progress {get;}

Property Value

A snapshot of the state of the current checkout operation.

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutManager Methods

The methods of the CheckoutManager class are listed below. For a complete list of CheckoutManager class members, see the CheckoutManager Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckoutManager.

Public Instance Methods

Checkout | Overloaded. Checks out a single file to the default location.
CheckoutTo | Overloaded. Checks out a single file to an alternate location.
Equals | Delegate Equals() to com.starbase.starteam.CheckoutManager.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckoutManager.
GetType (inherited from Object) | Gets the Type of the current instance.
NewCheckoutEventSource |
SetCanceled | Cancels any pending checkout operations.
ToString | Delegate ToString() to com.starbase.starteam.CheckoutManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutManager.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.CheckoutManager

Implements

IWrapper.Unwrap

See Also

CheckoutManager Class | Borland.StarTeam Namespace


Checkout Method

Borland StarTeam SDK for .NET

CheckoutManager.Checkout Method

Checks out a single file to the default location.

Overload List

Checks out a single file to the default location.

public virtual void Checkout(File);

Checks out all the files in the given folder.

public virtual void Checkout(Folder);

Checks out all the files in the given folder, and in all subfolders to the given depth.

public virtual void Checkout(Folder,Int32);

Checks out the given set of files.

public virtual void Checkout(ItemCollection);

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutManager.Checkout Method (File)

Checks out a single file to the default location.

public virtual void Checkout(
File file
);

Parameters

file
The file to be checked out.

See Also

CheckoutManager Class | Borland.StarTeam Namespace | CheckoutManager.Checkout Overload List


CheckoutManager.Checkout Method (Folder)

Checks out all the files in the given folder.

public virtual void Checkout(
Folder folder
);

Parameters

folder
The StarTeam folder whose files are to be checked out.

See Also

CheckoutManager Class | Borland.StarTeam Namespace | CheckoutManager.Checkout Overload List | Folder | checkout


CheckoutManager.Checkout Method (Folder, Int32)

Checks out all the files in the given folder, and in all subfolders to the given depth.

public virtual void Checkout(
Folder folder,
Int32 depth
);

Parameters

folder
The StarTeam folder whose files are to be checked out.
depth
Indicates which subfolders also contain files to be checked out. Zero indicates that no subfolders should be included; 1 indicates that this folder and its immediate child folders should be included; -1 indicates that this folder and all child folders at any depth should be included.

See Also

CheckoutManager Class | Borland.StarTeam Namespace | CheckoutManager.Checkout Overload List


CheckoutManager.Checkout Method (ItemCollection)

Checks out the given set of files.

public virtual void Checkout(
ItemCollection files
);

Parameters

files
The files to be checked out.

See Also

CheckoutManager Class | Borland.StarTeam Namespace | CheckoutManager.Checkout Overload List | getItems


CheckoutTo Method

Borland StarTeam SDK for .NET

CheckoutManager.CheckoutTo Method

Checks out a single file to an alternate location.

Overload List

Checks out a single file to an alternate location.

public virtual void CheckoutTo(File,FileInfo);

Checks out a single file to an output stream. No status update is performed in this case.

public virtual void CheckoutTo(File,Stream);

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutManager.CheckoutTo Method (File, FileInfo)

Checks out a single file to an alternate location.

public virtual void CheckoutTo(
File file,
FileInfo workingFile
);

Parameters

file
The file to be checked out.
workingFile
The alternate working file.

See Also

CheckoutManager Class | Borland.StarTeam Namespace | CheckoutManager.CheckoutTo Overload List


CheckoutManager.CheckoutTo Method (File, Stream)

Checks out a single file to an output stream. No status update is performed in this case.

public virtual void CheckoutTo(
File file,
Stream stream
);

Parameters

file
The file to be checked out.
stream
The stream to which the checked out content is written.

See Also

CheckoutManager Class | Borland.StarTeam Namespace | CheckoutManager.CheckoutTo Overload List


CheckoutManager.Equals Method

Delegate Equals() to com.starbase.starteam.CheckoutManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.CheckoutManager.Equals(obj).

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutManager.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.CheckoutManager.

public override int GetHashCode();

Return Value

com.starbase.starteam.CheckoutManager.GetHashCode().

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutManager.NewCheckoutEventSource Method

public CheckoutEventSource NewCheckoutEventSource();

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutManager.SetCanceled Method

Cancels any pending checkout operations.

public virtual void SetCanceled();

See Also

CheckoutManager Class | Borland.StarTeam Namespace | isCanceled


CheckoutManager.ToString Method

Delegate ToString() to com.starbase.starteam.CheckoutManager.

public override string ToString();

Return Value

com.starbase.starteam.CheckoutManager.ToString()

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutManager.Wrap Method

Dynamically wraps com.starbase.starteam.CheckoutManager.

public static CheckoutManager Wrap(
CheckoutManager impl
);

Parameters

impl
com.starbase.starteam.CheckoutManager to be wrapped.

Return Value

CheckoutManager

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutManager Type Conversions

The type conversions of the CheckoutManager class are listed below. For a complete list of CheckoutManager class members, see the CheckoutManager Members topic.

Public Static Type Conversions

Implicit CheckoutManager to CheckoutManager Conversion Implicitly convert CheckoutManager to com.starbase.starteam.CheckoutManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutManager Class | CheckoutManager Members | Borland.StarTeam Namespace


CheckoutManager Implicit CheckoutManager to CheckoutManager Conversion

Implicitly convert CheckoutManager to com.starbase.starteam.CheckoutManager.

public static implicit operator CheckoutManager(
CheckoutManager arg
);

Parameters

arg
CheckoutManager to convert.

Return Value

com.starbase.starteam.CheckoutManager

See Also

CheckoutManager Class | Borland.StarTeam Namespace


CheckoutOptions Class

Maintains the checkout options used by CheckoutManager.

For a list of all members of this type, see CheckoutOptions Members.

System.Object
CheckoutOptions

public class CheckoutOptions : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckoutOptions Members | Borland.StarTeam Namespace


CheckoutOptions Members

CheckoutOptions overview

Public Static Properties

EOL_CR
EOL_CRLF
EOL_LF

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckoutOptions.

Public Static Type Conversions

Implicit CheckoutOptions to CheckoutOptions Conversion Implicitly convert CheckoutOptions to com.starbase.starteam.CheckoutOptions.

Public Instance Constructors

CheckoutOptions Overloaded. Initializes a new instance of the CheckoutOptions class.

Public Instance Properties

CheckoutDate | [read/write] Return the OLEDate value to be used for the "checkout by date" option.
CheckoutLabelID | [read/write] Return the Label ID value to be used for the "checkout by Label" option.
ContentFilter | [read/write] Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.
EOLChars | [read/write] Return the contant value that represents the actual end-of-line sequence to be in EOL conversion. One of these values may be returned: EOL_CRLF, EOL_CR, and EOL_LF. The default value is EOL_CRLF when setEOLChars() is not called.
EOLConversionEnabled | [read/write] Return true if EOL conversion is enabled; false, otherwise.
EOLFormat | [read/write] EOLFormat
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
ForceCheckout | [read/write] the "Force Checkout" option value, whose default value is true.
IsByDate | [read] Return true if "checkout by date" option is used; false, otherwise.
IsByLabel | [read] Return true if "checkout by Label" option is used; false, otherwise.
IsByPromotionState | [read] Return true if "checkout by PromotionState" option is used; false, otherwise.
IsByTips | [read] Return true if the tip is used; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking out files or the file associated with this CheckoutOptions object.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LockType | [read/write] Return the type of lock to be used when checking out.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
OptimizeForSlowConnections | [read/write] Return true if it is optimized for slow connections, when possible; false, otherwise.
PromotionStateID | [read/write] Return the PromotionState ID value to be used for the "checkout by PromotionState" option.
RestoreFileOnError | [read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.
TimeStampNow | [read/write] Return true if current time is used as the last modified time; false, otherwise.
UpdateStatus | [read/write] Return true if status information is to be updated after a successful checkout.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CheckoutOptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckoutOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
SetTips | Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
ToString | Delegate ToString() to com.starbase.starteam.CheckoutOptions.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutOptions Constructor

Construct CheckoutOptions from com.starbase.starteam.CheckoutOptions.

Overload List

Construct a CheckoutOptions object with the same options as the given one.

public CheckoutOptions(CheckoutOptions);

Construct a CheckoutOptions object with the same options as the given one.

public CheckoutOptions(StarTeamClientOptions);

Construct a CheckoutOptions object with default options from the View.

public CheckoutOptions(View);

Construct CheckoutOptions from com.starbase.starteam.CheckoutOptions.

public CheckoutOptions(CheckoutOptions);

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutOptions Constructor (CheckoutOptions)

Construct CheckoutOptions from com.starbase.starteam.CheckoutOptions.

public CheckoutOptions(
CheckoutOptions impl
);

Parameters

impl
The com.starbase.starteam.CheckoutOptions to be wrapped.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace | CheckoutOptions Constructor Overload List


CheckoutOptions Constructor (View)

Construct a CheckoutOptions object with default options from the View.

public CheckoutOptions(
View view
);

Parameters

view
a View object where the values of the options are picked up.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace | CheckoutOptions Constructor Overload List | getOptions | View


CheckoutOptions Constructor (StarTeamClientOptions)

Construct a CheckoutOptions object with the same options as the given one.

public CheckoutOptions(
StarTeamClientOptions options
);

Parameters

options
a CheckoutOptions where the values of the options are picked up.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace | CheckoutOptions Constructor Overload List | getOptions


CheckoutOptions Constructor (CheckoutOptions)

Construct a CheckoutOptions object with the same options as the given one.

public CheckoutOptions(
CheckoutOptions options
);

Parameters

options
a CheckoutOptions where the values of the options are picked up.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace | CheckoutOptions Constructor Overload List | getOptions


CheckoutOptions Properties

The properties of the CheckoutOptions class are listed below. For a complete list of CheckoutOptions class members, see the CheckoutOptions Members topic.

Public Static Properties

EOL_CR
EOL_CRLF
EOL_LF

Public Instance Properties

CheckoutDate | [read/write] Return the OLEDate value to be used for the "checkout by date" option.
CheckoutLabelID | [read/write] Return the Label ID value to be used for the "checkout by Label" option.
ContentFilter | [read/write] Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.
EOLChars | [read/write] Return the contant value that represents the actual end-of-line sequence to be in EOL conversion. One of these values may be returned: EOL_CRLF, EOL_CR, and EOL_LF. The default value is EOL_CRLF when setEOLChars() is not called.
EOLConversionEnabled | [read/write] Return true if EOL conversion is enabled; false, otherwise.
EOLFormat | [read/write] EOLFormat
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
ForceCheckout | [read/write] the "Force Checkout" option value, whose default value is true.
IsByDate | [read] Return true if "checkout by date" option is used; false, otherwise.
IsByLabel | [read] Return true if "checkout by Label" option is used; false, otherwise.
IsByPromotionState | [read] Return true if "checkout by PromotionState" option is used; false, otherwise.
IsByTips | [read] Return true if the tip is used; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking out files or the file associated with this CheckoutOptions object.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LockType | [read/write] Return the type of lock to be used when checking out.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
OptimizeForSlowConnections | [read/write] Return true if it is optimized for slow connections, when possible; false, otherwise.
PromotionStateID | [read/write] Return the PromotionState ID value to be used for the "checkout by PromotionState" option.
RestoreFileOnError | [read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.
TimeStampNow | [read/write] Return true if current time is used as the last modified time; false, otherwise.
UpdateStatus | [read/write] Return true if status information is to be updated after a successful checkout.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutDate Property

Borland StarTeam SDK for .NET

CheckoutOptions.CheckoutDate Property

[read/write] Return the OLEDate value to be used for the "checkout by date" option.

public virtual DateTime CheckoutDate {get; set;}

Property Value

Return the OLEDate value to be used for the "checkout by date" option.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutLabelID Property

Borland StarTeam SDK for .NET

CheckoutOptions.CheckoutLabelID Property

[read/write] Return the Label ID value to be used for the "checkout by Label" option.

public virtual Int32 CheckoutLabelID {get; set;}

Property Value

Return the Label ID value to be used for the "checkout by Label" option.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


ContentFilter Property

Borland StarTeam SDK for .NET

CheckoutOptions.ContentFilter Property

[read/write] Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.

public virtual ContentFilter ContentFilter {get; set;}

Property Value

Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


EOL_CR Property

Borland StarTeam SDK for .NET

CheckoutOptions.EOL_CR Property

public static Int32 EOL_CR {get;}

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


EOL_CRLF Property

Borland StarTeam SDK for .NET

CheckoutOptions.EOL_CRLF Property

public static Int32 EOL_CRLF {get;}

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


EOL_LF Property

Borland StarTeam SDK for .NET

CheckoutOptions.EOL_LF Property

public static Int32 EOL_LF {get;}

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


EOLChars Property

Borland StarTeam SDK for .NET

CheckoutOptions.EOLChars Property

[read/write] Return the contant value that represents the actual end-of-line sequence to be in EOL conversion. One of these values may be returned: EOL_CRLF, EOL_CR, and EOL_LF. The default value is EOL_CRLF when setEOLChars() is not called.

public virtual Int32 EOLChars {get; set;}

Property Value

Return the contant value that represents the actual end-of-line sequence to be in EOL conversion. One of these values may be returned: EOL_CRLF, EOL_CR, and EOL_LF. The default value is EOL_CRLF when setEOLChars() is not called.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


EOLConversionEnabled Property

Borland StarTeam SDK for .NET

CheckoutOptions.EOLConversionEnabled Property

[read/write] Return true if EOL conversion is enabled; false, otherwise.

public virtual Boolean EOLConversionEnabled {get; set;}

Property Value

Return true if EOL conversion is enabled; false, otherwise.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


EOLFormat Property

Borland StarTeam SDK for .NET

CheckoutOptions.EOLFormat Property

[read/write] EOLFormat

public virtual EOLFormat EOLFormat {get; set;}

Property Value

EOLFormat

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


FileEncoding Property

Borland StarTeam SDK for .NET

CheckoutOptions.FileEncoding Property

[read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

public virtual String FileEncoding {get; set;}

Property Value

the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


ForceCheckout Property

Borland StarTeam SDK for .NET

CheckoutOptions.ForceCheckout Property

[read/write] the "Force Checkout" option value, whose default value is true.

public virtual Boolean ForceCheckout {get; set;}

Property Value

the "Force Checkout" option value, whose default value is true.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


IsByDate Property

Borland StarTeam SDK for .NET

CheckoutOptions.IsByDate Property

[read] Return true if "checkout by date" option is used; false, otherwise.

public virtual Boolean IsByDate {get;}

Property Value

Return true if "checkout by date" option is used; false, otherwise.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


IsByLabel Property

Borland StarTeam SDK for .NET

CheckoutOptions.IsByLabel Property

[read] Return true if "checkout by Label" option is used; false, otherwise.

public virtual Boolean IsByLabel {get;}

Property Value

Return true if "checkout by Label" option is used; false, otherwise.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


IsByPromotionState Property

Borland StarTeam SDK for .NET

CheckoutOptions.IsByPromotionState Property

[read] Return true if "checkout by PromotionState" option is used; false, otherwise.

public virtual Boolean IsByPromotionState {get;}

Property Value

Return true if "checkout by PromotionState" option is used; false, otherwise.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


IsByTips Property

Borland StarTeam SDK for .NET

CheckoutOptions.IsByTips Property

[read] Return true if the tip is used; false, otherwise.

public virtual Boolean IsByTips {get;}

Property Value

Return true if the tip is used; false, otherwise.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


IsFileSkipped Property

Borland StarTeam SDK for .NET

CheckoutOptions.IsFileSkipped Property

[read/write] whether to skip checking out files or the file associated with this CheckoutOptions object.

public virtual Boolean IsFileSkipped {get; set;}

Property Value

whether to skip checking out files or the file associated with this CheckoutOptions object.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


KeywordExpansionEnabled Property

Borland StarTeam SDK for .NET

CheckoutOptions.KeywordExpansionEnabled Property

[read/write] Return true if keyword expansion in text files is enabled; false, otherwise.

public virtual Boolean KeywordExpansionEnabled {get; set;}

Property Value

Return true if keyword expansion in text files is enabled; false, otherwise.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


LockType Property

Borland StarTeam SDK for .NET

CheckoutOptions.LockType Property

[read/write] Return the type of lock to be used when checking out.

public virtual Int32 LockType {get; set;}

Property Value

Return the type of lock to be used when checking out.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


MarkUnlockedFilesReadOnly Property

Borland StarTeam SDK for .NET

CheckoutOptions.MarkUnlockedFilesReadOnly Property

[read/write] option value. Default if not defined: false

public virtual Boolean MarkUnlockedFilesReadOnly {get; set;}

Property Value

option value. Default if not defined: false

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


OptimizeForSlowConnections Property

Borland StarTeam SDK for .NET

CheckoutOptions.OptimizeForSlowConnections Property

[read/write] Return true if it is optimized for slow connections, when possible; false, otherwise.

public virtual Boolean OptimizeForSlowConnections {get; set;}

Property Value

Return true if it is optimized for slow connections, when possible; false, otherwise.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


PromotionStateID Property

Borland StarTeam SDK for .NET

CheckoutOptions.PromotionStateID Property

[read/write] Return the PromotionState ID value to be used for the "checkout by PromotionState" option.

public virtual Int32 PromotionStateID {get; set;}

Property Value

Return the PromotionState ID value to be used for the "checkout by PromotionState" option.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


RestoreFileOnError Property

Borland StarTeam SDK for .NET

CheckoutOptions.RestoreFileOnError Property

[read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.

public virtual Boolean RestoreFileOnError {get; set;}

Property Value

Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


TimeStampNow Property

Borland StarTeam SDK for .NET

CheckoutOptions.TimeStampNow Property

[read/write] Return true if current time is used as the last modified time; false, otherwise.

public virtual Boolean TimeStampNow {get; set;}

Property Value

Return true if current time is used as the last modified time; false, otherwise.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


UpdateStatus Property

Borland StarTeam SDK for .NET

CheckoutOptions.UpdateStatus Property

[read/write] Return true if status information is to be updated after a successful checkout.

public virtual Boolean UpdateStatus {get; set;}

Property Value

Return true if status information is to be updated after a successful checkout.

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutOptions Methods

The methods of the CheckoutOptions class are listed below. For a complete list of CheckoutOptions class members, see the CheckoutOptions Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckoutOptions.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CheckoutOptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckoutOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
SetTips | Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
ToString | Delegate ToString() to com.starbase.starteam.CheckoutOptions.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutOptions.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.CheckoutOptions

Implements

IWrapper.Unwrap

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutOptions.Equals Method

Delegate Equals() to com.starbase.starteam.CheckoutOptions.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.CheckoutOptions.Equals(obj).

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutOptions.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.CheckoutOptions.

public override int GetHashCode();

Return Value

com.starbase.starteam.CheckoutOptions.GetHashCode().

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutOptions.SetTips Method

Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.

public virtual void SetTips();

See Also

CheckoutOptions Class | Borland.StarTeam Namespace | isByTips | setCheckoutDate | setCheckoutLabelID | setPromotionStateID


CheckoutOptions.ToString Method

Delegate ToString() to com.starbase.starteam.CheckoutOptions.

public override string ToString();

Return Value

com.starbase.starteam.CheckoutOptions.ToString()

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutOptions.Wrap Method

Dynamically wraps com.starbase.starteam.CheckoutOptions.

public static CheckoutOptions Wrap(
CheckoutOptions impl
);

Parameters

impl
com.starbase.starteam.CheckoutOptions to be wrapped.

Return Value

CheckoutOptions

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutOptions Type Conversions

The type conversions of the CheckoutOptions class are listed below. For a complete list of CheckoutOptions class members, see the CheckoutOptions Members topic.

Public Static Type Conversions

Implicit CheckoutOptions to CheckoutOptions Conversion Implicitly convert CheckoutOptions to com.starbase.starteam.CheckoutOptions.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutOptions Class | CheckoutOptions Members | Borland.StarTeam Namespace


CheckoutOptions Implicit CheckoutOptions to CheckoutOptions Conversion

Implicitly convert CheckoutOptions to com.starbase.starteam.CheckoutOptions.

public static implicit operator CheckoutOptions(
CheckoutOptions arg
);

Parameters

arg
CheckoutOptions to convert.

Return Value

com.starbase.starteam.CheckoutOptions

See Also

CheckoutOptions Class | Borland.StarTeam Namespace


CheckoutProgress Class

Information on the progress of a checkout operation from CheckoutManager. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use CheckoutManager.getProgress().

For a list of all members of this type, see CheckoutProgress Members.

System.Object
CheckoutProgress

public class CheckoutProgress : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckoutProgress Members | Borland.StarTeam Namespace


CheckoutProgress Members

CheckoutProgress overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckoutProgress.

Public Static Type Conversions

Implicit CheckoutProgress to CheckoutProgress Conversion Implicitly convert CheckoutProgress to com.starbase.starteam.CheckoutProgress.

Public Instance Constructors

CheckoutProgress Constructor Construct CheckoutProgress from com.starbase.starteam.CheckoutProgress.

Public Instance Properties

LastError |
NumCheckoutThreads | [read] Return the number of threads that contains checkout operations.
TotalBytesCheckedOut | [read] Return the total number of bytes that are checked out.
TotalBytesCheckedOutByMPXCacheAgent | [read] Return the number of bytes checked out through MPX File Cache Agent.
TotalCommandTime | [read] Return the time spent on checking out in milliseconds.
TotalCommandTimeByMPXCacheAgent | [read] Return the time spent on checking out in milliseconds through MPX File Cache Agent.
TotalFilesCheckedOut | [read] Return the total number of files checked out.
TotalFilesCheckedOutByMPXCacheAgent | [read] Return the number of files checked out through MPX File Cache Agent.
TotalFilesFailed | [read] Return the total number of files that failed during checkout.
TotalFilesRemaining | [read] Return the total number of files that are yet to be checked out.
TotalFilesSkipped | [read] Return the total number of files skipped without being checked out.
TotalFilesSkippedByMPXCacheAgent | [read] Return the number of files skipped without being checked out through MPX File Cache Agent.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CheckoutProgress.
GetCurrentBytesExpected | Get the number of bytes to be expected from the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid, and that there is still checkout operation currently. Otherwise, a zero is returned.
GetCurrentBytesSoFar | Get the number of bytes checked out so far for the file that's in the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid, and that there is still checkout operation currently. Otherwise, a zero is returned.
GetCurrentFile | Get the current File object that's being checked out in the specified thread ID. The return value may be the actual File if the thread ID is valid, and that there is still checkout operation currently. Otherwise, a null is returned.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckoutProgress.
GetTotalBytesCheckedOut | Get the number of bytes checked out from the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid. Otherwise, a zero is returned.
GetTotalFilesCheckedOut | Get the number of files checked out that's in the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid. Otherwise, a zero is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
IsMPXCacheAgentThread | Determine if a given number represent the thread ID of a thread that contains checkout operations through MPX File Cache Agent.
ToString | Delegate ToString() to com.starbase.starteam.CheckoutProgress.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress Constructor

Construct CheckoutProgress from com.starbase.starteam.CheckoutProgress.

public CheckoutProgress(
CheckoutProgress impl
);

Parameters

impl
The com.starbase.starteam.CheckoutProgress to be wrapped.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress Properties

The properties of the CheckoutProgress class are listed below. For a complete list of CheckoutProgress class members, see the CheckoutProgress Members topic.

Public Instance Properties

LastError |
NumCheckoutThreads | [read] Return the number of threads that contains checkout operations.
TotalBytesCheckedOut | [read] Return the total number of bytes that are checked out.
TotalBytesCheckedOutByMPXCacheAgent | [read] Return the number of bytes checked out through MPX File Cache Agent.
TotalCommandTime | [read] Return the time spent on checking out in milliseconds.
TotalCommandTimeByMPXCacheAgent | [read] Return the time spent on checking out in milliseconds through MPX File Cache Agent.
TotalFilesCheckedOut | [read] Return the total number of files checked out.
TotalFilesCheckedOutByMPXCacheAgent | [read] Return the number of files checked out through MPX File Cache Agent.
TotalFilesFailed | [read] Return the total number of files that failed during checkout.
TotalFilesRemaining | [read] Return the total number of files that are yet to be checked out.
TotalFilesSkipped | [read] Return the total number of files skipped without being checked out.
TotalFilesSkippedByMPXCacheAgent | [read] Return the number of files skipped without being checked out through MPX File Cache Agent.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


LastError Property

Borland StarTeam SDK for .NET

CheckoutProgress.LastError Property

public virtual Exception LastError {get;}

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


NumCheckoutThreads Property

Borland StarTeam SDK for .NET

CheckoutProgress.NumCheckoutThreads Property

[read] Return the number of threads that contains checkout operations.

public virtual Int32 NumCheckoutThreads {get;}

Property Value

Return the number of threads that contains checkout operations.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


TotalBytesCheckedOut Property

Borland StarTeam SDK for .NET

CheckoutProgress.TotalBytesCheckedOut Property

[read] Return the total number of bytes that are checked out.

public virtual Int64 TotalBytesCheckedOut {get;}

Property Value

Return the total number of bytes that are checked out.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


TotalBytesCheckedOutByMPXCacheAgent Property

Borland StarTeam SDK for .NET

CheckoutProgress.TotalBytesCheckedOutByMPXCacheAgent Property

[read] Return the number of bytes checked out through MPX File Cache Agent.

public virtual Int64 TotalBytesCheckedOutByMPXCacheAgent {get;}

Property Value

Return the number of bytes checked out through MPX File Cache Agent.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


TotalCommandTime Property

Borland StarTeam SDK for .NET

CheckoutProgress.TotalCommandTime Property

[read] Return the time spent on checking out in milliseconds.

public virtual Int64 TotalCommandTime {get;}

Property Value

Return the time spent on checking out in milliseconds.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


TotalCommandTimeByMPXCacheAgent Property

Borland StarTeam SDK for .NET

CheckoutProgress.TotalCommandTimeByMPXCacheAgent Property

[read] Return the time spent on checking out in milliseconds through MPX File Cache Agent.

public virtual Int64 TotalCommandTimeByMPXCacheAgent {get;}

Property Value

Return the time spent on checking out in milliseconds through MPX File Cache Agent.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


TotalFilesCheckedOut Property

Borland StarTeam SDK for .NET

CheckoutProgress.TotalFilesCheckedOut Property

[read] Return the total number of files checked out.

public virtual Int32 TotalFilesCheckedOut {get;}

Property Value

Return the total number of files checked out.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


TotalFilesCheckedOutByMPXCacheAgent Property

Borland StarTeam SDK for .NET

CheckoutProgress.TotalFilesCheckedOutByMPXCacheAgent Property

[read] Return the number of files checked out through MPX File Cache Agent.

public virtual Int32 TotalFilesCheckedOutByMPXCacheAgent {get;}

Property Value

Return the number of files checked out through MPX File Cache Agent.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


TotalFilesFailed Property

Borland StarTeam SDK for .NET

CheckoutProgress.TotalFilesFailed Property

[read] Return the total number of files that failed during checkout.

public virtual Int32 TotalFilesFailed {get;}

Property Value

Return the total number of files that failed during checkout.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


TotalFilesRemaining Property

Borland StarTeam SDK for .NET

CheckoutProgress.TotalFilesRemaining Property

[read] Return the total number of files that are yet to be checked out.

public virtual Int32 TotalFilesRemaining {get;}

Property Value

Return the total number of files that are yet to be checked out.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


TotalFilesSkipped Property

Borland StarTeam SDK for .NET

CheckoutProgress.TotalFilesSkipped Property

[read] Return the total number of files skipped without being checked out.

public virtual Int32 TotalFilesSkipped {get;}

Property Value

Return the total number of files skipped without being checked out.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


TotalFilesSkippedByMPXCacheAgent Property

Borland StarTeam SDK for .NET

CheckoutProgress.TotalFilesSkippedByMPXCacheAgent Property

[read] Return the number of files skipped without being checked out through MPX File Cache Agent.

public virtual Int32 TotalFilesSkippedByMPXCacheAgent {get;}

Property Value

Return the number of files skipped without being checked out through MPX File Cache Agent.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress Methods

The methods of the CheckoutProgress class are listed below. For a complete list of CheckoutProgress class members, see the CheckoutProgress Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckoutProgress.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.CheckoutProgress.
GetCurrentBytesExpected | Get the number of bytes to be expected from the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid, and that there is still checkout operation currently. Otherwise, a zero is returned.
GetCurrentBytesSoFar | Get the number of bytes checked out so far for the file that's in the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid, and that there is still checkout operation currently. Otherwise, a zero is returned.
GetCurrentFile | Get the current File object that's being checked out in the specified thread ID. The return value may be the actual File if the thread ID is valid, and that there is still checkout operation currently. Otherwise, a null is returned.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.CheckoutProgress.
GetTotalBytesCheckedOut | Get the number of bytes checked out from the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid. Otherwise, a zero is returned.
GetTotalFilesCheckedOut | Get the number of files checked out that's in the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid. Otherwise, a zero is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
IsMPXCacheAgentThread | Determine if a given number represent the thread ID of a thread that contains checkout operations through MPX File Cache Agent.
ToString | Delegate ToString() to com.starbase.starteam.CheckoutProgress.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.CheckoutProgress

Implements

IWrapper.Unwrap

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress.Equals Method

Delegate Equals() to com.starbase.starteam.CheckoutProgress.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.CheckoutProgress.Equals(obj).

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress.GetCurrentBytesExpected Method

Get the number of bytes to be expected from the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid, and that there is still checkout operation currently. Otherwise, a zero is returned.

public virtual long GetCurrentBytesExpected(
Int32 threadIndex
);

Parameters

threadIndex
The thread ID of a thread.

Return Value

Return the number of bytes to be expected from the thread represented by the specified thread ID.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress.GetCurrentBytesSoFar Method

Get the number of bytes checked out so far for the file that's in the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid, and that there is still checkout operation currently. Otherwise, a zero is returned.

public virtual long GetCurrentBytesSoFar(
Int32 threadIndex
);

Parameters

threadIndex
The thread ID of a thread.

Return Value

Return the number of bytes checked out so far for the file that's in the thread represented by the specified thread ID.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress.GetCurrentFile Method

Get the current File object that's being checked out in the specified thread ID. The return value may be the actual File if the thread ID is valid, and that there is still checkout operation currently. Otherwise, a null is returned.

public virtual File GetCurrentFile(
Int32 threadIndex
);

Parameters

threadIndex
The thread ID of a thread.

Return Value

Return the current File object that's being checked out in the specified thread ID.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.CheckoutProgress.

public override int GetHashCode();

Return Value

com.starbase.starteam.CheckoutProgress.GetHashCode().

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress.GetTotalBytesCheckedOut Method

Get the number of bytes checked out from the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid. Otherwise, a zero is returned.

public virtual long GetTotalBytesCheckedOut(
Int32 threadIndex
);

Parameters

threadIndex
The thread ID of a thread.

Return Value

Return the number of bytes checked out from the thread represented by the specified thread ID.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress.GetTotalFilesCheckedOut Method

Get the number of files checked out that's in the thread represented by the specified thread ID. The return value may be the actual number if the thread ID is valid. Otherwise, a zero is returned.

public virtual int GetTotalFilesCheckedOut(
Int32 threadIndex
);

Parameters

threadIndex
The thread ID of a thread.

Return Value

Return the number of files checked out that's in the thread represented by the specified thread ID.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress.IsMPXCacheAgentThread Method

Determine if a given number represent the thread ID of a thread that contains checkout operations through MPX File Cache Agent.

public virtual bool IsMPXCacheAgentThread(
Int32 threadIndex
);

Parameters

threadIndex
The number to be determined if it represents the thread ID of a thread that contains checkout operations through MPX File Cache Agent.

Return Value

Return true if the given number represent the thread ID of a thread that contains checkout operations through MPX File Cache Agent.

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress.ToString Method

Delegate ToString() to com.starbase.starteam.CheckoutProgress.

public override string ToString();

Return Value

com.starbase.starteam.CheckoutProgress.ToString()

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress.Wrap Method

Dynamically wraps com.starbase.starteam.CheckoutProgress.

public static CheckoutProgress Wrap(
CheckoutProgress impl
);

Parameters

impl
com.starbase.starteam.CheckoutProgress to be wrapped.

Return Value

CheckoutProgress

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckoutProgress Type Conversions

The type conversions of the CheckoutProgress class are listed below. For a complete list of CheckoutProgress class members, see the CheckoutProgress Members topic.

Public Static Type Conversions

Implicit CheckoutProgress to CheckoutProgress Conversion Implicitly convert CheckoutProgress to com.starbase.starteam.CheckoutProgress.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CheckoutProgress Class | CheckoutProgress Members | Borland.StarTeam Namespace


CheckoutProgress Implicit CheckoutProgress to CheckoutProgress Conversion

Implicitly convert CheckoutProgress to com.starbase.starteam.CheckoutProgress.

public static implicit operator CheckoutProgress(
CheckoutProgress arg
);

Parameters

arg
CheckoutProgress to convert.

Return Value

com.starbase.starteam.CheckoutProgress

See Also

CheckoutProgress Class | Borland.StarTeam Namespace


CheckOutResult Class

The class holds return information specific to the file checkout operation.

For a list of all members of this type, see CheckOutResult Members.

System.Object
FileResult
CheckOutResult

public class CheckOutResult : FileResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CheckOutResult Members | Borland.StarTeam Namespace


CheckOutResult Members

CheckOutResult overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckOutResult.

Public Static Type Conversions

Implicit CheckOutResult to CheckOutResult Conversion Implicitly convert CheckOutResult to com.starbase.starteam.CheckOutResult.

Public Instance Constructors

CheckOutResult Constructor Construct CheckOutResult from com.starbase.starteam.CheckOutResult.

Public Instance Properties

ExclusiveLockerID | [read] the user ID of the user that has an exclusive lock on the file.
Keywords (inherited from FileResult) | [read] the keywords used for the file operation.
MyLockState | [read] the lock state of the file for the user performing the checkout.

Public Instance Methods

Equals (inherited from FileResult) | Delegate Equals() to com.starbase.starteam.FileResult.
GetHashCode (inherited from FileResult) | Delegate GetHashCode() to com.starbase.starteam.FileResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from FileResult) | Delegate ToString() to com.starbase.starteam.FileResult.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileResult) Implementation of IWrapper.Unwrap().

See Also

CheckOutResult Class | Borland.StarTeam Namespace


CheckOutResult Constructor

Construct CheckOutResult from com.starbase.starteam.CheckOutResult.

public CheckOutResult(
CheckOutResult impl
);

Parameters

impl
The com.starbase.starteam.CheckOutResult to be wrapped.

See Also

CheckOutResult Class | Borland.StarTeam Namespace


CheckOutResult Properties

The properties of the CheckOutResult class are listed below. For a complete list of CheckOutResult class members, see the CheckOutResult Members topic.

Public Instance Properties

ExclusiveLockerID | [read] the user ID of the user that has an exclusive lock on the file.
Keywords (inherited from FileResult) | [read] the keywords used for the file operation.
MyLockState | [read] the lock state of the file for the user performing the checkout.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileResult) Implementation of IWrapper.Unwrap().

See Also

CheckOutResult Class | Borland.StarTeam Namespace


ExclusiveLockerID Property

Borland StarTeam SDK for .NET

CheckOutResult.ExclusiveLockerID Property

[read] the user ID of the user that has an exclusive lock on the file.

public virtual Int32 ExclusiveLockerID {get;}

Property Value

the user ID of the user that has an exclusive lock on the file.

See Also

CheckOutResult Class | Borland.StarTeam Namespace


MyLockState Property

Borland StarTeam SDK for .NET

CheckOutResult.MyLockState Property

[read] the lock state of the file for the user performing the checkout.

public virtual Int32 MyLockState {get;}

Property Value

the lock state of the file for the user performing the checkout.

See Also

CheckOutResult Class | Borland.StarTeam Namespace


CheckOutResult Methods

The methods of the CheckOutResult class are listed below. For a complete list of CheckOutResult class members, see the CheckOutResult Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CheckOutResult.

Public Instance Methods

Equals (inherited from FileResult) | Delegate Equals() to com.starbase.starteam.FileResult.
GetHashCode (inherited from FileResult) | Delegate GetHashCode() to com.starbase.starteam.FileResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from FileResult) | Delegate ToString() to com.starbase.starteam.FileResult.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileResult) Implementation of IWrapper.Unwrap().

See Also

CheckOutResult Class | Borland.StarTeam Namespace


CheckOutResult.Wrap Method

Dynamically wraps com.starbase.starteam.CheckOutResult.

public static CheckOutResult Wrap(
CheckOutResult impl
);

Parameters

impl
com.starbase.starteam.CheckOutResult to be wrapped.

Return Value

CheckOutResult

See Also

CheckOutResult Class | Borland.StarTeam Namespace


CheckOutResult Type Conversions

The type conversions of the CheckOutResult class are listed below. For a complete list of CheckOutResult class members, see the CheckOutResult Members topic.

Public Static Type Conversions

Implicit CheckOutResult to CheckOutResult Conversion Implicitly convert CheckOutResult to com.starbase.starteam.CheckOutResult.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileResult) Implementation of IWrapper.Unwrap().

See Also

CheckOutResult Class | CheckOutResult Members | Borland.StarTeam Namespace


CheckOutResult Implicit CheckOutResult to CheckOutResult Conversion

Implicitly convert CheckOutResult to com.starbase.starteam.CheckOutResult.

public static implicit operator CheckOutResult(
CheckOutResult arg
);

Parameters

arg
CheckOutResult to convert.

Return Value

com.starbase.starteam.CheckOutResult

See Also

CheckOutResult Class | Borland.StarTeam Namespace


ClientApplication Class

Manages information about the client application. This information is reported to the StarTeam Server for diagnostic purposes. Diagnostic information is used by StarTeam Server versions 6.0 and later.

For a list of all members of this type, see ClientApplication Members.

System.Object
ClientApplication

public class ClientApplication : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ClientApplication Members | Borland.StarTeam Namespace


ClientApplication Members

ClientApplication overview

Public Static Properties

Description | [read] A verbose description of the client application. This information is communicated to the StarTeam Server at connect time, for diagnostic purposes.
Name | [read/write] The client application name. Default is "<Unknown Application>". To report a specific application name to the StarTeam Server for diagnostic purposes, set the application name prior to connecting.

Public Static Type Conversions

Implicit ClientApplication to ClientApplication Conversion Implicitly convert ClientApplication to com.starbase.starteam.ClientApplication.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ClientApplication.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ClientApplication.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ClientApplication.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ClientApplication Class | Borland.StarTeam Namespace


ClientApplication Properties

The properties of the ClientApplication class are listed below. For a complete list of ClientApplication class members, see the ClientApplication Members topic.

Public Static Properties

Description | [read] A verbose description of the client application. This information is communicated to the StarTeam Server at connect time, for diagnostic purposes.
Name | [read/write] The client application name. Default is "<Unknown Application>". To report a specific application name to the StarTeam Server for diagnostic purposes, set the application name prior to connecting.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ClientApplication Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

ClientApplication.Description Property

[read] A verbose description of the client application. This information is communicated to the StarTeam Server at connect time, for diagnostic purposes.

public static String Description {get;}

Property Value

A verbose description of the client application. This information is communicated to the StarTeam Server at connect time, for diagnostic purposes.

See Also

ClientApplication Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ClientApplication.Name Property

[read/write] The client application name. Default is "<Unknown Application>". To report a specific application name to the StarTeam Server for diagnostic purposes, set the application name prior to connecting.

public static String Name {get; set;}

Property Value

The client application name. Default is "<Unknown Application>". To report a specific application name to the StarTeam Server for diagnostic purposes, set the application name prior to connecting.

See Also

ClientApplication Class | Borland.StarTeam Namespace


ClientApplication Methods

The methods of the ClientApplication class are listed below. For a complete list of ClientApplication class members, see the ClientApplication Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ClientApplication.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ClientApplication.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ClientApplication.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ClientApplication Class | Borland.StarTeam Namespace


ClientApplication.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ClientApplication

Implements

IWrapper.Unwrap

See Also

ClientApplication Class | Borland.StarTeam Namespace


ClientApplication.Equals Method

Delegate Equals() to com.starbase.starteam.ClientApplication.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ClientApplication.Equals(obj).

See Also

ClientApplication Class | Borland.StarTeam Namespace


ClientApplication.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ClientApplication.

public override int GetHashCode();

Return Value

com.starbase.starteam.ClientApplication.GetHashCode().

See Also

ClientApplication Class | Borland.StarTeam Namespace


ClientApplication.ToString Method

Delegate ToString() to com.starbase.starteam.ClientApplication.

public override string ToString();

Return Value

com.starbase.starteam.ClientApplication.ToString()

See Also

ClientApplication Class | Borland.StarTeam Namespace


ClientApplication Type Conversions

The type conversions of the ClientApplication class are listed below. For a complete list of ClientApplication class members, see the ClientApplication Members topic.

Public Static Type Conversions

Implicit ClientApplication to ClientApplication Conversion Implicitly convert ClientApplication to com.starbase.starteam.ClientApplication.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ClientApplication Class | ClientApplication Members | Borland.StarTeam Namespace


ClientApplication Implicit ClientApplication to ClientApplication Conversion

Implicitly convert ClientApplication to com.starbase.starteam.ClientApplication.

public static implicit operator ClientApplication(
ClientApplication arg
);

Parameters

arg
ClientApplication to convert.

Return Value

com.starbase.starteam.ClientApplication

See Also

ClientApplication Class | Borland.StarTeam Namespace


ClientContext Class

The ClientContext class contains the nescessary information in order to run the SDK on one machine for a client running on a different machine. This is useful, for example, when running an SDK application within a Web server for a remote browser based client. The information in the ClientContext includes a unique client GUID identitfier, the hostname of the client machine, the client's end-of-line convention, whether or not the client treats file names as case sensitive or not and the string used to delimit directory names within an absolute file path. The Platform class has methods for returning those values on the host running the SDK.

For a list of all members of this type, see ClientContext Members.

System.Object
ClientContext

public class ClientContext : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ClientContext Members | Borland.StarTeam Namespace


ClientContext Members

ClientContext overview

Public Static Properties

EOL_CR
EOL_CRLF
EOL_LF
EOL_MAC
EOL_UNIX
EOL_WINDOWS

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ClientContext.

Public Static Type Conversions

Implicit ClientContext to ClientContext Conversion Implicitly convert ClientContext to com.starbase.starteam.ClientContext.

Public Instance Constructors

ClientContext Overloaded. Initializes a new instance of the ClientContext class.

Public Instance Properties

CaseSensitiveFileNames | [read/write] true if the client treats file names as case sensitive.
DirectoryOverrides | [read/write] the directory override information for this client context.
EOL | [read/write] the client machine's end-of-line convention.
FilePathDelimiter | [read/write] the string used to delimit directories in a file path.
HostName | [read] the client machine's host name.
WorkStationID | [read] the workstation GUID identifying the client.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ClientContext.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ClientContext.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ClientContext.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ClientContext Class | Borland.StarTeam Namespace


ClientContext Constructor

Construct ClientContext from com.starbase.starteam.ClientContext.

Overload List

Creates a default client context based on propeties of the machine actually running the code.

public ClientContext();

Creates a default client context based on propeties of the machine actually running the code but using the specified workstation ID. Normally the workstation ID is read out of an ini file. Passing in null for the workStationID will read the GUID out of the appropriate ini file.

public ClientContext(GUID);

Creates a new client context based on the specified parameters.

public ClientContext(GUID,String,String,Boolean,String,DirectoryOverrides);

Construct ClientContext from com.starbase.starteam.ClientContext.

public ClientContext(ClientContext);

See Also

ClientContext Class | Borland.StarTeam Namespace


ClientContext Constructor (ClientContext)

Construct ClientContext from com.starbase.starteam.ClientContext.

public ClientContext(
ClientContext impl
);

Parameters

impl
The com.starbase.starteam.ClientContext to be wrapped.

See Also

ClientContext Class | Borland.StarTeam Namespace | ClientContext Constructor Overload List


ClientContext Constructor ()

Creates a default client context based on propeties of the machine actually running the code.

public ClientContext();

See Also

ClientContext Class | Borland.StarTeam Namespace | ClientContext Constructor Overload List


ClientContext Constructor (GUID)

Creates a default client context based on propeties of the machine actually running the code but using the specified workstation ID. Normally the workstation ID is read out of an ini file. Passing in null for the workStationID will read the GUID out of the appropriate ini file.

public ClientContext(
GUID workStationID
);

Parameters

workStationID
the workstation GUID associated with the client, the value may be null

See Also

ClientContext Class | Borland.StarTeam Namespace | ClientContext Constructor Overload List


ClientContext Constructor (GUID, String, String, Boolean, String, DirectoryOverrides)

Creates a new client context based on the specified parameters.

public ClientContext(
GUID workStationID,
String hostname,
String eol,
Boolean caseSensitive,
String filePathDelim,
DirectoryOverrides overrides
);

Parameters

workStationID
the workstation GUID associated with the client, the value may be null
hostname
the hostname of the machine running the client
eol
the end of line convention for the client platform
caseSensitive
true if the client treats file names as case sensitive
filePathDelim
the string used to delimit directory names on a file path. Is "\" on windows and "/" for Unix.
overrides

See Also

ClientContext Class | Borland.StarTeam Namespace | ClientContext Constructor Overload List


ClientContext Properties

The properties of the ClientContext class are listed below. For a complete list of ClientContext class members, see the ClientContext Members topic.

Public Static Properties

EOL_CR
EOL_CRLF
EOL_LF
EOL_MAC
EOL_UNIX
EOL_WINDOWS

Public Instance Properties

CaseSensitiveFileNames | [read/write] true if the client treats file names as case sensitive.
DirectoryOverrides | [read/write] the directory override information for this client context.
EOL | [read/write] the client machine's end-of-line convention.
FilePathDelimiter | [read/write] the string used to delimit directories in a file path.
HostName | [read] the client machine's host name.
WorkStationID | [read] the workstation GUID identifying the client.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ClientContext Class | Borland.StarTeam Namespace


CaseSensitiveFileNames Property

Borland StarTeam SDK for .NET

ClientContext.CaseSensitiveFileNames Property

[read/write] true if the client treats file names as case sensitive.

public virtual Boolean CaseSensitiveFileNames {get; set;}

Property Value

true if the client treats file names as case sensitive.

See Also

ClientContext Class | Borland.StarTeam Namespace


DirectoryOverrides Property

Borland StarTeam SDK for .NET

ClientContext.DirectoryOverrides Property

[read/write] the directory override information for this client context.

public virtual DirectoryOverrides DirectoryOverrides {get; set;}

Property Value

the directory override information for this client context.

See Also

ClientContext Class | Borland.StarTeam Namespace


EOL Property

Borland StarTeam SDK for .NET

ClientContext.EOL Property

[read/write] the client machine's end-of-line convention.

public virtual String EOL {get; set;}

Property Value

the client machine's end-of-line convention.

See Also

ClientContext Class | Borland.StarTeam Namespace


EOL_CR Property

Borland StarTeam SDK for .NET

ClientContext.EOL_CR Property

public static String EOL_CR {get;}

See Also

ClientContext Class | Borland.StarTeam Namespace


EOL_CRLF Property

Borland StarTeam SDK for .NET

ClientContext.EOL_CRLF Property

public static String EOL_CRLF {get;}

See Also

ClientContext Class | Borland.StarTeam Namespace


EOL_LF Property

Borland StarTeam SDK for .NET

ClientContext.EOL_LF Property

public static String EOL_LF {get;}

See Also

ClientContext Class | Borland.StarTeam Namespace


EOL_MAC Property

Borland StarTeam SDK for .NET

ClientContext.EOL_MAC Property

public static String EOL_MAC {get;}

See Also

ClientContext Class | Borland.StarTeam Namespace


EOL_UNIX Property

Borland StarTeam SDK for .NET

ClientContext.EOL_UNIX Property

public static String EOL_UNIX {get;}

See Also

ClientContext Class | Borland.StarTeam Namespace


EOL_WINDOWS Property

Borland StarTeam SDK for .NET

ClientContext.EOL_WINDOWS Property

public static String EOL_WINDOWS {get;}

See Also

ClientContext Class | Borland.StarTeam Namespace


FilePathDelimiter Property

Borland StarTeam SDK for .NET

ClientContext.FilePathDelimiter Property

[read/write] the string used to delimit directories in a file path.

public virtual String FilePathDelimiter {get; set;}

Property Value

the string used to delimit directories in a file path.

See Also

ClientContext Class | Borland.StarTeam Namespace


HostName Property

Borland StarTeam SDK for .NET

ClientContext.HostName Property

[read] the client machine's host name.

public virtual String HostName {get;}

Property Value

the client machine's host name.

See Also

ClientContext Class | Borland.StarTeam Namespace


WorkStationID Property

Borland StarTeam SDK for .NET

ClientContext.WorkStationID Property

[read] the workstation GUID identifying the client.

public virtual GUID WorkStationID {get;}

Property Value

the workstation GUID identifying the client.

See Also

ClientContext Class | Borland.StarTeam Namespace


ClientContext Methods

The methods of the ClientContext class are listed below. For a complete list of ClientContext class members, see the ClientContext Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ClientContext.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ClientContext.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ClientContext.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ClientContext.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ClientContext Class | Borland.StarTeam Namespace


ClientContext.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ClientContext

Implements

IWrapper.Unwrap

See Also

ClientContext Class | Borland.StarTeam Namespace


ClientContext.Equals Method

Delegate Equals() to com.starbase.starteam.ClientContext.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ClientContext.Equals(obj).

See Also

ClientContext Class | Borland.StarTeam Namespace


ClientContext.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ClientContext.

public override int GetHashCode();

Return Value

com.starbase.starteam.ClientContext.GetHashCode().

See Also

ClientContext Class | Borland.StarTeam Namespace


ClientContext.ToString Method

Delegate ToString() to com.starbase.starteam.ClientContext.

public override string ToString();

Return Value

com.starbase.starteam.ClientContext.ToString()

See Also

ClientContext Class | Borland.StarTeam Namespace


ClientContext.Wrap Method

Dynamically wraps com.starbase.starteam.ClientContext.

public static ClientContext Wrap(
ClientContext impl
);

Parameters

impl
com.starbase.starteam.ClientContext to be wrapped.

Return Value

ClientContext

See Also

ClientContext Class | Borland.StarTeam Namespace


ClientContext Type Conversions

The type conversions of the ClientContext class are listed below. For a complete list of ClientContext class members, see the ClientContext Members topic.

Public Static Type Conversions

Implicit ClientContext to ClientContext Conversion Implicitly convert ClientContext to com.starbase.starteam.ClientContext.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ClientContext Class | ClientContext Members | Borland.StarTeam Namespace


ClientContext Implicit ClientContext to ClientContext Conversion

Implicitly convert ClientContext to com.starbase.starteam.ClientContext.

public static implicit operator ClientContext(
ClientContext arg
);

Parameters

arg
ClientContext to convert.

Return Value

com.starbase.starteam.ClientContext

See Also

ClientContext Class | Borland.StarTeam Namespace


ColumnInfo Class

For a list of all members of this type, see ColumnInfo Members.

System.Object
ColumnInfo

public class ColumnInfo : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ColumnInfo Members | Borland.StarTeam Namespace


ColumnInfo Members

ColumnInfo overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ColumnInfo.

Public Static Type Conversions

Implicit ColumnInfo to ColumnInfo Conversion Implicitly convert ColumnInfo to com.starbase.starteam.ColumnInfo.

Public Instance Constructors

ColumnInfo Overloaded. Initializes a new instance of the ColumnInfo class.

Public Instance Properties

DebugString | [read]
PixelWidth | [read/write]
PropertyID | [read/write]

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ColumnInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ColumnInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ColumnInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ColumnInfo Class | Borland.StarTeam Namespace


ColumnInfo Constructor

Construct ColumnInfo from com.starbase.starteam.ColumnInfo.

Overload List

Construct ColumnInfo from com.starbase.starteam.ColumnInfo.

public ColumnInfo(ColumnInfo);

public ColumnInfo(Int32,Int32);

See Also

ColumnInfo Class | Borland.StarTeam Namespace


ColumnInfo Constructor (ColumnInfo)

Construct ColumnInfo from com.starbase.starteam.ColumnInfo.

public ColumnInfo(
ColumnInfo impl
);

Parameters

impl
The com.starbase.starteam.ColumnInfo to be wrapped.

See Also

ColumnInfo Class | Borland.StarTeam Namespace | ColumnInfo Constructor Overload List


ColumnInfo Constructor (Int32, Int32)

public ColumnInfo(
Int32 propertyID,
Int32 pixelWidth
);

Parameters

propertyID
pixelWidth

See Also

ColumnInfo Class | Borland.StarTeam Namespace | ColumnInfo Constructor Overload List


ColumnInfo Properties

The properties of the ColumnInfo class are listed below. For a complete list of ColumnInfo class members, see the ColumnInfo Members topic.

Public Instance Properties

DebugString | [read]
PixelWidth | [read/write]
PropertyID | [read/write]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ColumnInfo Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

ColumnInfo.DebugString Property

[read]

public virtual String DebugString {get;}

See Also

ColumnInfo Class | Borland.StarTeam Namespace


PixelWidth Property

Borland StarTeam SDK for .NET

ColumnInfo.PixelWidth Property

[read/write]

public virtual Int32 PixelWidth {get; set;}

See Also

ColumnInfo Class | Borland.StarTeam Namespace


PropertyID Property

Borland StarTeam SDK for .NET

ColumnInfo.PropertyID Property

[read/write]

public virtual Int32 PropertyID {get; set;}

See Also

ColumnInfo Class | Borland.StarTeam Namespace


ColumnInfo Methods

The methods of the ColumnInfo class are listed below. For a complete list of ColumnInfo class members, see the ColumnInfo Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ColumnInfo.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ColumnInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ColumnInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ColumnInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ColumnInfo Class | Borland.StarTeam Namespace


ColumnInfo.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ColumnInfo

Implements

IWrapper.Unwrap

See Also

ColumnInfo Class | Borland.StarTeam Namespace


ColumnInfo.Equals Method

Delegate Equals() to com.starbase.starteam.ColumnInfo.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ColumnInfo.Equals(obj).

See Also

ColumnInfo Class | Borland.StarTeam Namespace


ColumnInfo.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ColumnInfo.

public override int GetHashCode();

Return Value

com.starbase.starteam.ColumnInfo.GetHashCode().

See Also

ColumnInfo Class | Borland.StarTeam Namespace


ColumnInfo.ToString Method

Delegate ToString() to com.starbase.starteam.ColumnInfo.

public override string ToString();

Return Value

com.starbase.starteam.ColumnInfo.ToString()

See Also

ColumnInfo Class | Borland.StarTeam Namespace


ColumnInfo.Wrap Method

Dynamically wraps com.starbase.starteam.ColumnInfo.

public static ColumnInfo Wrap(
ColumnInfo impl
);

Parameters

impl
com.starbase.starteam.ColumnInfo to be wrapped.

Return Value

ColumnInfo

See Also

ColumnInfo Class | Borland.StarTeam Namespace


ColumnInfo Type Conversions

The type conversions of the ColumnInfo class are listed below. For a complete list of ColumnInfo class members, see the ColumnInfo Members topic.

Public Static Type Conversions

Implicit ColumnInfo to ColumnInfo Conversion Implicitly convert ColumnInfo to com.starbase.starteam.ColumnInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ColumnInfo Class | ColumnInfo Members | Borland.StarTeam Namespace


ColumnInfo Implicit ColumnInfo to ColumnInfo Conversion

Implicitly convert ColumnInfo to com.starbase.starteam.ColumnInfo.

public static implicit operator ColumnInfo(
ColumnInfo arg
);

Parameters

arg
ColumnInfo to convert.

Return Value

com.starbase.starteam.ColumnInfo

See Also

ColumnInfo Class | Borland.StarTeam Namespace


ColumnInfoCollection Class

A strongly-typed collection of ColumnInfos.

For a list of all members of this type, see ColumnInfoCollection Members.

System.Object
ArrayAdapter
ColumnInfoCollection

public class ColumnInfoCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ColumnInfoCollection Members | Borland.StarTeam Namespace


ColumnInfoCollection Members

ColumnInfoCollection overview

Public Static Methods

Wrap Creates a ColumnInfoCollection to represent the given array of ColumnInfo (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit ColumnInfoCollection to ColumnInfo[] Conversion | Converts a ColumnInfoCollection to an array of ColumnInfos.
Implicit ColumnInfoCollection to ColumnInfo[] Conversion | Converts a ColumnInfoCollection from the Borland.StarTeam namespace to a ColumnInfo[] in the com.starbase.starteam namespace.

Public Instance Constructors

ColumnInfoCollection Overloaded. Initializes a new instance of the ColumnInfoCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ColumnInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a ColumnInfo to end of the collection.
Append | Overloaded. Appends the ColumnInfos of the given ColumnInfoCollection to the end of this ColumnInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ColumnInfo.
CopyTo | Copies all of the ColumnInfos in the ColumnInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ColumnInfo in the collection.
Insert | Inserts a ColumnInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific ColumnInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ColumnInfos in this ColumnInfoCollection.
Sort | Sorts the ColumnInfos in this ColumnInfoCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection Constructor

Initializes an instance of the ColumnInfoCollection class.

Overload List

Initializes an instance of the ColumnInfoCollection class.

public ColumnInfoCollection();

Initializes an instance of the a ColumnInfoCollection class, copying the given array.

public ColumnInfoCollection(ColumnInfo[]);

Initializes an instance of the a ColumnInfoCollection class, copying the given collection.

public ColumnInfoCollection(ColumnInfoCollection);

Initializes an instance of the a ColumnInfoCollection class, wrapping the given array of ColumnInfo (from the com.starbase.starteam namespace).

public ColumnInfoCollection(ColumnInfo[]);

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection Constructor ()

Initializes an instance of the ColumnInfoCollection class.

public ColumnInfoCollection();

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace | ColumnInfoCollection Constructor Overload List


ColumnInfoCollection Constructor (ColumnInfo[])

Initializes an instance of the a ColumnInfoCollection class, wrapping the given array of ColumnInfo (from the com.starbase.starteam namespace).

public ColumnInfoCollection(
ColumnInfo[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace | ColumnInfoCollection Constructor Overload List | Wrap


ColumnInfoCollection Constructor (ColumnInfoCollection)

Initializes an instance of the a ColumnInfoCollection class, copying the given collection.

public ColumnInfoCollection(
ColumnInfoCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member ColumnInfo objects of the original collection are shared, not copied.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace | ColumnInfoCollection Constructor Overload List


ColumnInfoCollection Constructor (ColumnInfo[])

Initializes an instance of the a ColumnInfoCollection class, copying the given array.

public ColumnInfoCollection(
ColumnInfo[] array
);

Parameters

array
The array to be copied.

Remarks

The member ColumnInfo objects of the original array are shared, not copied.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace | ColumnInfoCollection Constructor Overload List


ColumnInfoCollection Properties

The properties of the ColumnInfoCollection class are listed below. For a complete list of ColumnInfoCollection class members, see the ColumnInfoCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ColumnInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

ColumnInfoCollection.Item Property

Gets or sets the ColumnInfo at the specified index.

public ColumnInfo this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the ColumnInfo to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection Methods

The methods of the ColumnInfoCollection class are listed below. For a complete list of ColumnInfoCollection class members, see the ColumnInfoCollection Members topic.

Public Static Methods

Wrap Creates a ColumnInfoCollection to represent the given array of ColumnInfo (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a ColumnInfo to end of the collection.
Append | Overloaded. Appends the ColumnInfos of the given ColumnInfoCollection to the end of this ColumnInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ColumnInfo.
CopyTo | Copies all of the ColumnInfos in the ColumnInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ColumnInfo in the collection.
Insert | Inserts a ColumnInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific ColumnInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ColumnInfos in this ColumnInfoCollection.
Sort | Sorts the ColumnInfos in this ColumnInfoCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection.Add Method

Adds a ColumnInfo to end of the collection.

public int Add(
ColumnInfo value
);

Parameters

value
The ColumnInfo to add to the collection.

Return Value

The position into which the new ColumnInfo was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

ColumnInfoCollection.Append Method

Appends the ColumnInfos of the given array to the end of this ColumnInfoCollection.

Overload List

Appends the ColumnInfos of the given array to the end of this ColumnInfoCollection.

public ColumnInfoCollection Append(ColumnInfo[]);

Appends the ColumnInfos of the given ColumnInfoCollection to the end of this ColumnInfoCollection.

public ColumnInfoCollection Append(ColumnInfoCollection);

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection.Append Method (ColumnInfo[])

Appends the ColumnInfos of the given array to the end of this ColumnInfoCollection.

public ColumnInfoCollection Append(
ColumnInfo[] array
);

Parameters

array
The array whose ColumnInfos are to be appended to this ColumnInfoCollection.

Return Value

This ColumnInfoCollection, modified to include the new ColumnInfos.

Remarks

The ColumnInfoCollection is modified to include the new members. The individual ColumnInfo objects are shared, not copied.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace | ColumnInfoCollection.Append Overload List


ColumnInfoCollection.Append Method (ColumnInfoCollection)

Appends the ColumnInfos of the given ColumnInfoCollection to the end of this ColumnInfoCollection.

public ColumnInfoCollection Append(
ColumnInfoCollection collection
);

Parameters

collection
The ColumnInfoCollection whose ColumnInfos are to be appended to this ColumnInfoCollection.

Return Value

This ColumnInfoCollection, modified to include the new ColumnInfos.

Remarks

The ColumnInfoCollection is modified to include the new members. The individual ColumnInfo objects are shared, not copied.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace | ColumnInfoCollection.Append Overload List


ColumnInfoCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.ColumnInfo[].

Implements

IWrapper.Unwrap

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection.Contains Method

Determines whether or not the collection contains a specific ColumnInfo.

public bool Contains(
ColumnInfo value
);

Parameters

value
The ColumnInfo to locate in the collection.

Return Value

true if the ColumnInfo is found in the collection; otherwise, false.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection.CopyTo Method

Copies all of the ColumnInfos in the ColumnInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
ColumnInfo[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the ColumnInfos copied from the ColumnInfoCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of ColumnInfos in the source ColumnInfoCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ColumnInfoCollection cannot be cast automatically to the type of the destination array.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection.IndexOf Method

Determines the index of a specific ColumnInfo in the collection.

public int IndexOf(
ColumnInfo value
);

Parameters

value
The ColumnInfo to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection.Insert Method

Inserts a ColumnInfo into the collection at the specified position.

public void Insert(
Int32 index,
ColumnInfo value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The ColumnInfo to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection.Remove Method

Removes the first occurrence of a specific ColumnInfo from the collection.

public void Remove(
ColumnInfo value
);

Parameters

value
The ColumnInfo to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection.Reverse Method

Reverses the order of the ColumnInfos in this ColumnInfoCollection.

new public ColumnInfoCollection Reverse();

Return Value

This ColumnInfoCollection, modified such that the ColumnInfos are reversed.

Remarks

The ColumnInfoCollection is modified in place.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection.Sort Method

Sorts the ColumnInfos in this ColumnInfoCollection, using the given comparer.

new public ColumnInfoCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two ColumnInfos.

Return Value

This ColumnInfoCollection, modified such that the ColumnInfos are sorted.

Remarks

The ColumnInfoCollection is modified in place.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection.Wrap Method

Creates a ColumnInfoCollection to represent the given array of ColumnInfo (from the com.starbase.starteam namespace).

public static ColumnInfoCollection Wrap(
ColumnInfo[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ColumnInfoCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a ColumnInfo[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection Type Conversions

The type conversions of the ColumnInfoCollection class are listed below. For a complete list of ColumnInfoCollection class members, see the ColumnInfoCollection Members topic.

Public Static Type Conversions

Implicit ColumnInfoCollection to ColumnInfo[] Conversion | Converts a ColumnInfoCollection to an array of ColumnInfos.
Implicit ColumnInfoCollection to ColumnInfo[] Conversion | Converts a ColumnInfoCollection from the Borland.StarTeam namespace to a ColumnInfo[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ColumnInfoCollection Class | ColumnInfoCollection Members | Borland.StarTeam Namespace


ColumnInfoCollection Implicit ColumnInfoCollection to ColumnInfo[] Conversion

Converts a ColumnInfoCollection to an array of ColumnInfos.

public static implicit operator ColumnInfo[](
ColumnInfoCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new ColumnInfo wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one ColumnInfo wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


ColumnInfoCollection Implicit ColumnInfoCollection to ColumnInfo[] Conversion

Converts a ColumnInfoCollection from the Borland.StarTeam namespace to a ColumnInfo[] in the com.starbase.starteam namespace.

public static implicit operator ColumnInfo[](
ColumnInfoCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ColumnInfoCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ColumnInfoCollection Class | Borland.StarTeam Namespace


CommandAbortedException Class

For a list of all members of this type, see CommandAbortedException Members.

System.Object
Exception
ServerException
CommandAbortedException

public class CommandAbortedException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CommandAbortedException Members | Borland.StarTeam Namespace


CommandAbortedException Members

CommandAbortedException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CommandAbortedException.

Public Static Type Conversions

Implicit CommandAbortedException to CommandAbortedException Conversion Implicitly convert CommandAbortedException to com.starbase.starteam.CommandAbortedException.

Public Instance Constructors

CommandAbortedException Overloaded. Initializes a new instance of the CommandAbortedException class.

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

CommandAbortedException Class | Borland.StarTeam Namespace


CommandAbortedException Constructor

Construct CommandAbortedException from com.starbase.starteam.CommandAbortedException.

Overload List

Construct CommandAbortedException from com.starbase.starteam.CommandAbortedException.

public CommandAbortedException(CommandAbortedException);

public CommandAbortedException(String);

See Also

CommandAbortedException Class | Borland.StarTeam Namespace


CommandAbortedException Constructor (CommandAbortedException)

Construct CommandAbortedException from com.starbase.starteam.CommandAbortedException.

public CommandAbortedException(
CommandAbortedException impl
);

Parameters

impl
The com.starbase.starteam.CommandAbortedException to be wrapped.

See Also

CommandAbortedException Class | Borland.StarTeam Namespace | CommandAbortedException Constructor Overload List


CommandAbortedException Constructor (String)

public CommandAbortedException(
String sErrorMessage
);

See Also

CommandAbortedException Class | Borland.StarTeam Namespace | CommandAbortedException Constructor Overload List


CommandAbortedException Methods

The methods of the CommandAbortedException class are listed below. For a complete list of CommandAbortedException class members, see the CommandAbortedException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.CommandAbortedException.

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

CommandAbortedException Class | Borland.StarTeam Namespace


CommandAbortedException.Wrap Method

Dynamically wraps com.starbase.starteam.CommandAbortedException.

public static CommandAbortedException Wrap(
CommandAbortedException impl
);

Parameters

impl
com.starbase.starteam.CommandAbortedException to be wrapped.

Return Value

CommandAbortedException

See Also

CommandAbortedException Class | Borland.StarTeam Namespace


CommandAbortedException Type Conversions

The type conversions of the CommandAbortedException class are listed below. For a complete list of CommandAbortedException class members, see the CommandAbortedException Members topic.

Public Static Type Conversions

Implicit CommandAbortedException to CommandAbortedException Conversion Implicitly convert CommandAbortedException to com.starbase.starteam.CommandAbortedException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

CommandAbortedException Class | CommandAbortedException Members | Borland.StarTeam Namespace


CommandAbortedException Implicit CommandAbortedException to CommandAbortedException Conversion

Implicitly convert CommandAbortedException to com.starbase.starteam.CommandAbortedException.

public static implicit operator CommandAbortedException(
CommandAbortedException arg
);

Parameters

arg
CommandAbortedException to convert.

Return Value

com.starbase.starteam.CommandAbortedException

See Also

CommandAbortedException Class | Borland.StarTeam Namespace


CommandException Class

For a list of all members of this type, see CommandException Members.

System.Object
Exception
CommandException
ConnectionException

public class CommandException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CommandException Members | Borland.StarTeam Namespace


CommandException Members

CommandException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.vts.comm.CommandException.

Public Static Type Conversions

Implicit CommandException to CommandException Conversion Implicitly convert CommandException to com.starbase.starteam.vts.comm.CommandException.

Public Instance Constructors

CommandException Constructor Construct CommandException from com.starbase.starteam.vts.comm.CommandException.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IOException |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.vts.comm.CommandException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.vts.comm.CommandException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.vts.comm.CommandException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CommandException Class | Borland.StarTeam Namespace


CommandException Constructor

Construct CommandException from com.starbase.starteam.vts.comm.CommandException.

public CommandException(
CommandException impl
);

Parameters

impl
The com.starbase.starteam.vts.comm.CommandException to be wrapped.

See Also

CommandException Class | Borland.StarTeam Namespace


CommandException Properties

The properties of the CommandException class are listed below. For a complete list of CommandException class members, see the CommandException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IOException |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CommandException Class | Borland.StarTeam Namespace


IOException Property

Borland StarTeam SDK for .NET

CommandException.IOException Property

public virtual IOException IOException {get;}

See Also

CommandException Class | Borland.StarTeam Namespace


CommandException Methods

The methods of the CommandException class are listed below. For a complete list of CommandException class members, see the CommandException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.vts.comm.CommandException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.vts.comm.CommandException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.vts.comm.CommandException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.vts.comm.CommandException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CommandException Class | Borland.StarTeam Namespace


CommandException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.vts.comm.CommandException

Implements

IWrapper.Unwrap

See Also

CommandException Class | Borland.StarTeam Namespace


CommandException.Equals Method

Delegate Equals() to com.starbase.starteam.vts.comm.CommandException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.vts.comm.CommandException.Equals(obj).

See Also

CommandException Class | Borland.StarTeam Namespace


CommandException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.vts.comm.CommandException.

public override int GetHashCode();

Return Value

com.starbase.starteam.vts.comm.CommandException.GetHashCode().

See Also

CommandException Class | Borland.StarTeam Namespace


CommandException.ToString Method

Delegate ToString() to com.starbase.starteam.vts.comm.CommandException.

public override string ToString();

Return Value

com.starbase.starteam.vts.comm.CommandException.ToString()

See Also

CommandException Class | Borland.StarTeam Namespace


CommandException.Wrap Method

Dynamically wraps com.starbase.starteam.vts.comm.CommandException.

public static CommandException Wrap(
CommandException impl
);

Parameters

impl
com.starbase.starteam.vts.comm.CommandException to be wrapped.

Return Value

CommandException

See Also

CommandException Class | Borland.StarTeam Namespace


CommandException Type Conversions

The type conversions of the CommandException class are listed below. For a complete list of CommandException class members, see the CommandException Members topic.

Public Static Type Conversions

Implicit CommandException to CommandException Conversion Implicitly convert CommandException to com.starbase.starteam.vts.comm.CommandException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

CommandException Class | CommandException Members | Borland.StarTeam Namespace


CommandException Implicit CommandException to CommandException Conversion

Implicitly convert CommandException to com.starbase.starteam.vts.comm.CommandException.

public static implicit operator CommandException(
CommandException arg
);

Parameters

arg
CommandException to convert.

Return Value

com.starbase.starteam.vts.comm.CommandException

See Also

CommandException Class | Borland.StarTeam Namespace


ConfigFiles Class

All client stored config file locations for StarTeam can be found using this class.

For a list of all members of this type, see ConfigFiles Members.

System.Object
ConfigFiles

public class ConfigFiles : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ConfigFiles Members | Borland.StarTeam Namespace


ConfigFiles Members

ConfigFiles overview

Public Static Properties

ConnectionManagerINI | [read] The full path to ConnectionManager.ini, or null on non-Windows platforms.
DefaultCentralStatusDirectory | [read] The default location of the client's centralized status directory
NonWindowsConfig | [read]
ServerList | [read] The default location of the client's "ServerList.st" file.
StarTeamINI | [read] The default location of the client's "StarTeam.ini" file.

Public Static Type Conversions

Implicit ConfigFiles to ConfigFiles Conversion Implicitly convert ConfigFiles to com.starbase.starteam.ConfigFiles.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ConfigFiles.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ConfigFiles.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ConfigFiles.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ConfigFiles Class | Borland.StarTeam Namespace


ConfigFiles Properties

The properties of the ConfigFiles class are listed below. For a complete list of ConfigFiles class members, see the ConfigFiles Members topic.

Public Static Properties

ConnectionManagerINI | [read] The full path to ConnectionManager.ini, or null on non-Windows platforms.
DefaultCentralStatusDirectory | [read] The default location of the client's centralized status directory
NonWindowsConfig | [read]
ServerList | [read] The default location of the client's "ServerList.st" file.
StarTeamINI | [read] The default location of the client's "StarTeam.ini" file.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ConfigFiles Class | Borland.StarTeam Namespace


ConnectionManagerINI Property

Borland StarTeam SDK for .NET

ConfigFiles.ConnectionManagerINI Property

[read] The full path to ConnectionManager.ini, or null on non-Windows platforms.

public static FileInfo ConnectionManagerINI {get;}

Property Value

The full path to ConnectionManager.ini, or null on non-Windows platforms.

See Also

ConfigFiles Class | Borland.StarTeam Namespace


DefaultCentralStatusDirectory Property

Borland StarTeam SDK for .NET

ConfigFiles.DefaultCentralStatusDirectory Property

[read] The default location of the client's centralized status directory

public static FileInfo DefaultCentralStatusDirectory {get;}

Property Value

The default location of the client's centralized status directory

See Also

ConfigFiles Class | Borland.StarTeam Namespace


NonWindowsConfig Property

Borland StarTeam SDK for .NET

ConfigFiles.NonWindowsConfig Property

[read]

public static FileInfo NonWindowsConfig {get;}

See Also

ConfigFiles Class | Borland.StarTeam Namespace


ServerList Property

Borland StarTeam SDK for .NET

ConfigFiles.ServerList Property

[read] The default location of the client's "ServerList.st" file.

public static FileInfo ServerList {get;}

Property Value

The default location of the client's "ServerList.st" file.

See Also

ConfigFiles Class | Borland.StarTeam Namespace


StarTeamINI Property

Borland StarTeam SDK for .NET

ConfigFiles.StarTeamINI Property

[read] The default location of the client's "StarTeam.ini" file.

public static FileInfo StarTeamINI {get;}

Property Value

The default location of the client's "StarTeam.ini" file.

See Also

ConfigFiles Class | Borland.StarTeam Namespace


ConfigFiles Methods

The methods of the ConfigFiles class are listed below. For a complete list of ConfigFiles class members, see the ConfigFiles Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ConfigFiles.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ConfigFiles.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ConfigFiles.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ConfigFiles Class | Borland.StarTeam Namespace


ConfigFiles.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ConfigFiles

Implements

IWrapper.Unwrap

See Also

ConfigFiles Class | Borland.StarTeam Namespace


ConfigFiles.Equals Method

Delegate Equals() to com.starbase.starteam.ConfigFiles.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ConfigFiles.Equals(obj).

See Also

ConfigFiles Class | Borland.StarTeam Namespace


ConfigFiles.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ConfigFiles.

public override int GetHashCode();

Return Value

com.starbase.starteam.ConfigFiles.GetHashCode().

See Also

ConfigFiles Class | Borland.StarTeam Namespace


ConfigFiles.ToString Method

Delegate ToString() to com.starbase.starteam.ConfigFiles.

public override string ToString();

Return Value

com.starbase.starteam.ConfigFiles.ToString()

See Also

ConfigFiles Class | Borland.StarTeam Namespace


ConfigFiles Type Conversions

The type conversions of the ConfigFiles class are listed below. For a complete list of ConfigFiles class members, see the ConfigFiles Members topic.

Public Static Type Conversions

Implicit ConfigFiles to ConfigFiles Conversion Implicitly convert ConfigFiles to com.starbase.starteam.ConfigFiles.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ConfigFiles Class | ConfigFiles Members | Borland.StarTeam Namespace


ConfigFiles Implicit ConfigFiles to ConfigFiles Conversion

Implicitly convert ConfigFiles to com.starbase.starteam.ConfigFiles.

public static implicit operator ConfigFiles(
ConfigFiles arg
);

Parameters

arg
ConfigFiles to convert.

Return Value

com.starbase.starteam.ConfigFiles

See Also

ConfigFiles Class | Borland.StarTeam Namespace


ConnectionException Class

For a list of all members of this type, see ConnectionException Members.

System.Object
Exception
CommandException
ConnectionException

public class ConnectionException : CommandException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ConnectionException Members | Borland.StarTeam Namespace


ConnectionException Members

ConnectionException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.vts.comm.ConnectionException.

Public Static Type Conversions

Implicit ConnectionException to ConnectionException Conversion Implicitly convert ConnectionException to com.starbase.starteam.vts.comm.ConnectionException.

Public Instance Constructors

ConnectionException Constructor Construct ConnectionException from com.starbase.starteam.vts.comm.ConnectionException.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IOException (inherited from CommandException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
ReconnectAttemptCount |
ReconnectExceptions |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from CommandException) | Delegate Equals() to com.starbase.starteam.vts.comm.CommandException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from CommandException) | Delegate GetHashCode() to com.starbase.starteam.vts.comm.CommandException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from CommandException) | Delegate ToString() to com.starbase.starteam.vts.comm.CommandException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CommandException) Implementation of IWrapper.Unwrap().

See Also

ConnectionException Class | Borland.StarTeam Namespace


ConnectionException Constructor

Construct ConnectionException from com.starbase.starteam.vts.comm.ConnectionException.

public ConnectionException(
ConnectionException impl
);

Parameters

impl
The com.starbase.starteam.vts.comm.ConnectionException to be wrapped.

See Also

ConnectionException Class | Borland.StarTeam Namespace


ConnectionException Properties

The properties of the ConnectionException class are listed below. For a complete list of ConnectionException class members, see the ConnectionException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IOException (inherited from CommandException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
ReconnectAttemptCount |
ReconnectExceptions |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CommandException) Implementation of IWrapper.Unwrap().

See Also

ConnectionException Class | Borland.StarTeam Namespace


ReconnectAttemptCount Property

Borland StarTeam SDK for .NET

ConnectionException.ReconnectAttemptCount Property

public virtual Int32 ReconnectAttemptCount {get;}

See Also

ConnectionException Class | Borland.StarTeam Namespace


ReconnectExceptions Property

Borland StarTeam SDK for .NET

ConnectionException.ReconnectExceptions Property

public virtual IOExceptionCollection ReconnectExceptions {get;}

See Also

ConnectionException Class | Borland.StarTeam Namespace


ConnectionException Methods

The methods of the ConnectionException class are listed below. For a complete list of ConnectionException class members, see the ConnectionException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.vts.comm.ConnectionException.

Public Instance Methods

Equals (inherited from CommandException) | Delegate Equals() to com.starbase.starteam.vts.comm.CommandException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from CommandException) | Delegate GetHashCode() to com.starbase.starteam.vts.comm.CommandException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from CommandException) | Delegate ToString() to com.starbase.starteam.vts.comm.CommandException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CommandException) Implementation of IWrapper.Unwrap().

See Also

ConnectionException Class | Borland.StarTeam Namespace


ConnectionException.Wrap Method

Dynamically wraps com.starbase.starteam.vts.comm.ConnectionException.

public static ConnectionException Wrap(
ConnectionException impl
);

Parameters

impl
com.starbase.starteam.vts.comm.ConnectionException to be wrapped.

Return Value

ConnectionException

See Also

ConnectionException Class | Borland.StarTeam Namespace


ConnectionException Type Conversions

The type conversions of the ConnectionException class are listed below. For a complete list of ConnectionException class members, see the ConnectionException Members topic.

Public Static Type Conversions

Implicit ConnectionException to ConnectionException Conversion Implicitly convert ConnectionException to com.starbase.starteam.vts.comm.ConnectionException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CommandException) Implementation of IWrapper.Unwrap().

See Also

ConnectionException Class | ConnectionException Members | Borland.StarTeam Namespace


ConnectionException Implicit ConnectionException to ConnectionException Conversion

Implicitly convert ConnectionException to com.starbase.starteam.vts.comm.ConnectionException.

public static implicit operator ConnectionException(
ConnectionException arg
);

Parameters

arg
ConnectionException to convert.

Return Value

com.starbase.starteam.vts.comm.ConnectionException

See Also

ConnectionException Class | Borland.StarTeam Namespace


ContainerACLSecLogID Class

For Container-level security log events.

For a list of all members of this type, see ContainerACLSecLogID Members.

System.Object
ContainerACLSecLogID

public class ContainerACLSecLogID : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ContainerACLSecLogID Members | Borland.StarTeam Namespace


ContainerACLSecLogID Members

ContainerACLSecLogID overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ContainerACLSecLogID.

Public Static Type Conversions

Implicit ContainerACLSecLogID to ContainerACLSecLogID Conversion Implicitly convert ContainerACLSecLogID to com.starbase.starteam.ContainerACLSecLogID.

Public Instance Constructors

ContainerACLSecLogID Constructor Construct ContainerACLSecLogID from com.starbase.starteam.ContainerACLSecLogID.

Public Instance Properties

ClassID | [read] The class id.
ContainerID | [read] The container id.
ObjectID | [read] The object id.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ContainerACLSecLogID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ContainerACLSecLogID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ContainerACLSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ContainerACLSecLogID Constructor

Construct ContainerACLSecLogID from com.starbase.starteam.ContainerACLSecLogID.

public ContainerACLSecLogID(
ContainerACLSecLogID impl
);

Parameters

impl
The com.starbase.starteam.ContainerACLSecLogID to be wrapped.

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ContainerACLSecLogID Properties

The properties of the ContainerACLSecLogID class are listed below. For a complete list of ContainerACLSecLogID class members, see the ContainerACLSecLogID Members topic.

Public Instance Properties

ClassID | [read] The class id.
ContainerID | [read] The container id.
ObjectID | [read] The object id.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ClassID Property

Borland StarTeam SDK for .NET

ContainerACLSecLogID.ClassID Property

[read] The class id.

public virtual Int32 ClassID {get;}

Property Value

The class id.

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ContainerID Property

Borland StarTeam SDK for .NET

ContainerACLSecLogID.ContainerID Property

[read] The container id.

public virtual Int32 ContainerID {get;}

Property Value

The container id.

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

ContainerACLSecLogID.ObjectID Property

[read] The object id.

public virtual Int32 ObjectID {get;}

Property Value

The object id.

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ContainerACLSecLogID Methods

The methods of the ContainerACLSecLogID class are listed below. For a complete list of ContainerACLSecLogID class members, see the ContainerACLSecLogID Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ContainerACLSecLogID.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ContainerACLSecLogID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ContainerACLSecLogID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ContainerACLSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ContainerACLSecLogID.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ContainerACLSecLogID

Implements

IWrapper.Unwrap

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ContainerACLSecLogID.Equals Method

Delegate Equals() to com.starbase.starteam.ContainerACLSecLogID.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ContainerACLSecLogID.Equals(obj).

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ContainerACLSecLogID.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ContainerACLSecLogID.

public override int GetHashCode();

Return Value

com.starbase.starteam.ContainerACLSecLogID.GetHashCode().

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ContainerACLSecLogID.ToString Method

Delegate ToString() to com.starbase.starteam.ContainerACLSecLogID.

public override string ToString();

Return Value

com.starbase.starteam.ContainerACLSecLogID.ToString()

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ContainerACLSecLogID.Wrap Method

Dynamically wraps com.starbase.starteam.ContainerACLSecLogID.

public static ContainerACLSecLogID Wrap(
ContainerACLSecLogID impl
);

Parameters

impl
com.starbase.starteam.ContainerACLSecLogID to be wrapped.

Return Value

ContainerACLSecLogID

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ContainerACLSecLogID Type Conversions

The type conversions of the ContainerACLSecLogID class are listed below. For a complete list of ContainerACLSecLogID class members, see the ContainerACLSecLogID Members topic.

Public Static Type Conversions

Implicit ContainerACLSecLogID to ContainerACLSecLogID Conversion Implicitly convert ContainerACLSecLogID to com.starbase.starteam.ContainerACLSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ContainerACLSecLogID Class | ContainerACLSecLogID Members | Borland.StarTeam Namespace


ContainerACLSecLogID Implicit ContainerACLSecLogID to ContainerACLSecLogID Conversion

Implicitly convert ContainerACLSecLogID to com.starbase.starteam.ContainerACLSecLogID.

public static implicit operator ContainerACLSecLogID(
ContainerACLSecLogID arg
);

Parameters

arg
ContainerACLSecLogID to convert.

Return Value

com.starbase.starteam.ContainerACLSecLogID

See Also

ContainerACLSecLogID Class | Borland.StarTeam Namespace


ContentFilter Interface

Allows an application to hook into the checkout process at a low level. getOutputStream() is called for each file as it is checked out. OutputStream is the stream where content is written; the application may wrap this stream to transform content as it sees fit.

For a list of all members of this type, see ContentFilter Members.

public interface ContentFilter

Types that implement ContentFilter

Type | Description
ContentFilterAdapter |

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ContentFilter Members | Borland.StarTeam Namespace


ContentFilter Members

ContentFilter overview

Public Instance Methods

GetOutputStream Get the OutputStream object corresponding to the specified File and OutputStream objects.

See Also

ContentFilter Interface | Borland.StarTeam Namespace


ContentFilter Methods

The methods of the ContentFilter interface are listed below. For a complete list of ContentFilter interface members, see the ContentFilter Members topic.

Public Instance Methods

GetOutputStream Get the OutputStream object corresponding to the specified File and OutputStream objects.

See Also

ContentFilter Interface | Borland.StarTeam Namespace


ContentFilter.GetOutputStream Method

Get the OutputStream object corresponding to the specified File and OutputStream objects.

Stream GetOutputStream(
File file,
Stream stream
);

Parameters

file
the File object.
stream
the OutputStream object.

Return Value

Return the corresponding OutputStream object.

See Also

ContentFilter Interface | Borland.StarTeam Namespace


ContentFilterAdapter Class

For a list of all members of this type, see ContentFilterAdapter Members.

System.Object
ContentFilterAdapter

public class ContentFilterAdapter : ContentFilter, ContentFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ContentFilterAdapter Members | Borland.StarTeam Namespace


ContentFilterAdapter Members

ContentFilterAdapter overview

Public Instance Constructors

ContentFilterAdapter Overloaded. Initializes a new instance of the ContentFilterAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ContentFilter.getOutputStream
ContentFilter.GetOutputStream

See Also

ContentFilterAdapter Class | Borland.StarTeam Namespace


ContentFilterAdapter Constructor

Overload List

public ContentFilterAdapter(ContentFilter);

public ContentFilterAdapter(ContentFilter);

See Also

ContentFilterAdapter Class | Borland.StarTeam Namespace


ContentFilterAdapter Constructor (ContentFilter)

public ContentFilterAdapter(
ContentFilter arg
);

See Also

ContentFilterAdapter Class | Borland.StarTeam Namespace | ContentFilterAdapter Constructor Overload List


ContentFilterAdapter Methods

The methods of the ContentFilterAdapter class are listed below. For a complete list of ContentFilterAdapter class members, see the ContentFilterAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ContentFilter.getOutputStream
ContentFilter.GetOutputStream

See Also

ContentFilterAdapter Class | Borland.StarTeam Namespace


ContentFilterAdapter.ContentFilter.GetOutputStream Method

Stream ContentFilter.GetOutputStream(
File file,
Stream stream
);

Implements

ContentFilter.GetOutputStream

See Also

ContentFilterAdapter Class | Borland.StarTeam Namespace


ContentFilterAdapter.ContentFilter.getOutputStream Method

OutputStream ContentFilter.getOutputStream(
File file,
OutputStream stream
);

Implements

ContentFilter.getOutputStream

See Also

ContentFilterAdapter Class | Borland.StarTeam Namespace


CultureInfoCollection Class

A strongly-typed collection of CultureInfos.

For a list of all members of this type, see CultureInfoCollection Members.

System.Object
ArrayAdapter
CultureInfoCollection

public class CultureInfoCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CultureInfoCollection Members | Borland.StarTeam Namespace


CultureInfoCollection Members

CultureInfoCollection overview

Public Static Methods

Wrap Creates a CultureInfoCollection to represent the given array of Locale (from the java.util namespace).

Public Static Type Conversions

Implicit CultureInfoCollection to Locale[] Conversion | Converts a CultureInfoCollection from the Borland.StarTeam namespace to a Locale[] in the java.util namespace.
Implicit CultureInfoCollection to CultureInfo[] Conversion | Converts a CultureInfoCollection to an array of CultureInfos.

Public Instance Constructors

CultureInfoCollection Overloaded. Initializes a new instance of the CultureInfoCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the CultureInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a CultureInfo to end of the collection.
Append | Overloaded. Appends the CultureInfos of the given CultureInfoCollection to the end of this CultureInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific CultureInfo.
CopyTo | Copies all of the CultureInfos in the CultureInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the CultureInfo with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific CultureInfo in the collection.
Insert | Inserts a CultureInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific CultureInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the CultureInfos in this CultureInfoCollection.
Sort | Sorts the CultureInfos in this CultureInfoCollection, using the given comparer.
SortByName | Sorts the CultureInfos in this CultureInfoCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the java.util namespace.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection Constructor

Initializes an instance of the CultureInfoCollection class.

Overload List

Initializes an instance of the CultureInfoCollection class.

public CultureInfoCollection();

Initializes an instance of the a CultureInfoCollection class, copying the given collection.

public CultureInfoCollection(CultureInfoCollection);

Initializes an instance of the a CultureInfoCollection class, wrapping the given array of Locale (from the java.util namespace).

public CultureInfoCollection(Locale[]);

Initializes an instance of the a CultureInfoCollection class, copying the given array.

public CultureInfoCollection(CultureInfo[]);

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection Constructor ()

Initializes an instance of the CultureInfoCollection class.

public CultureInfoCollection();

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace | CultureInfoCollection Constructor Overload List


CultureInfoCollection Constructor (Locale[])

Initializes an instance of the a CultureInfoCollection class, wrapping the given array of Locale (from the java.util namespace).

public CultureInfoCollection(
Locale[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the java.util namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace | CultureInfoCollection Constructor Overload List | Wrap


CultureInfoCollection Constructor (CultureInfoCollection)

Initializes an instance of the a CultureInfoCollection class, copying the given collection.

public CultureInfoCollection(
CultureInfoCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member CultureInfo objects of the original collection are shared, not copied.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace | CultureInfoCollection Constructor Overload List


CultureInfoCollection Constructor (CultureInfo[])

Initializes an instance of the a CultureInfoCollection class, copying the given array.

public CultureInfoCollection(
CultureInfo[] array
);

Parameters

array
The array to be copied.

Remarks

The member CultureInfo objects of the original array are shared, not copied.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace | CultureInfoCollection Constructor Overload List


CultureInfoCollection Properties

The properties of the CultureInfoCollection class are listed below. For a complete list of CultureInfoCollection class members, see the CultureInfoCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the CultureInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the java.util namespace.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

CultureInfoCollection.Item Property

Gets or sets the CultureInfo at the specified index.

Overload List

Gets or sets the CultureInfo at the specified index.

public CultureInfo this[Int32] {get; set;}

Gets the CultureInfo with the given name.

public CultureInfo this[String] {get;}

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

CultureInfoCollection.Item Property (Int32)

Gets or sets the CultureInfo at the specified index.

public CultureInfo this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the CultureInfo to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace | CultureInfoCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

CultureInfoCollection.Item Property (String)

Gets the CultureInfo with the given name.

public CultureInfo this[
String name
] {get;}

Parameters

name
The name of the CultureInfo to get.

Property Value

The CultureInfo with the given name, or null if there is no CultureInfo with that name in this CultureInfoCollection. Comparison is case sensitive.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace | CultureInfoCollection.Item Overload List | FindByName


CultureInfoCollection Methods

The methods of the CultureInfoCollection class are listed below. For a complete list of CultureInfoCollection class members, see the CultureInfoCollection Members topic.

Public Static Methods

Wrap Creates a CultureInfoCollection to represent the given array of Locale (from the java.util namespace).

Public Instance Methods

Add | Adds a CultureInfo to end of the collection.
Append | Overloaded. Appends the CultureInfos of the given CultureInfoCollection to the end of this CultureInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific CultureInfo.
CopyTo | Copies all of the CultureInfos in the CultureInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the CultureInfo with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific CultureInfo in the collection.
Insert | Inserts a CultureInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific CultureInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the CultureInfos in this CultureInfoCollection.
Sort | Sorts the CultureInfos in this CultureInfoCollection, using the given comparer.
SortByName | Sorts the CultureInfos in this CultureInfoCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the java.util namespace.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.Add Method

Adds a CultureInfo to end of the collection.

public int Add(
CultureInfo value
);

Parameters

value
The CultureInfo to add to the collection.

Return Value

The position into which the new CultureInfo was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

CultureInfoCollection.Append Method

Appends the CultureInfos of the given CultureInfoCollection to the end of this CultureInfoCollection.

Overload List

Appends the CultureInfos of the given CultureInfoCollection to the end of this CultureInfoCollection.

public CultureInfoCollection Append(CultureInfoCollection);

Appends the CultureInfos of the given array to the end of this CultureInfoCollection.

public CultureInfoCollection Append(CultureInfo[]);

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.Append Method (CultureInfoCollection)

Appends the CultureInfos of the given CultureInfoCollection to the end of this CultureInfoCollection.

public CultureInfoCollection Append(
CultureInfoCollection collection
);

Parameters

collection
The CultureInfoCollection whose CultureInfos are to be appended to this CultureInfoCollection.

Return Value

This CultureInfoCollection, modified to include the new CultureInfos.

Remarks

The CultureInfoCollection is modified to include the new members. The individual CultureInfo objects are shared, not copied.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace | CultureInfoCollection.Append Overload List


CultureInfoCollection.Append Method (CultureInfo[])

Appends the CultureInfos of the given array to the end of this CultureInfoCollection.

public CultureInfoCollection Append(
CultureInfo[] array
);

Parameters

array
The array whose CultureInfos are to be appended to this CultureInfoCollection.

Return Value

This CultureInfoCollection, modified to include the new CultureInfos.

Remarks

The CultureInfoCollection is modified to include the new members. The individual CultureInfo objects are shared, not copied.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace | CultureInfoCollection.Append Overload List


CultureInfoCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the java.util namespace.

object IWrapper.Unwrap();

Return Value

The underlying java.util.Locale[].

Implements

IWrapper.Unwrap

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.Contains Method

Determines whether or not the collection contains a specific CultureInfo.

public bool Contains(
CultureInfo value
);

Parameters

value
The CultureInfo to locate in the collection.

Return Value

true if the CultureInfo is found in the collection; otherwise, false.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.CopyTo Method

Copies all of the CultureInfos in the CultureInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
CultureInfo[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the CultureInfos copied from the CultureInfoCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of CultureInfos in the source CultureInfoCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source CultureInfoCollection cannot be cast automatically to the type of the destination array.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.FindByName Method

Finds the CultureInfo with the given name.

public CultureInfo FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the CultureInfo to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The CultureInfo with the given name, or null if there is no CultureInfo with that name in this CultureInfoCollection.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.IndexOf Method

Determines the index of a specific CultureInfo in the collection.

public int IndexOf(
CultureInfo value
);

Parameters

value
The CultureInfo to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.Insert Method

Inserts a CultureInfo into the collection at the specified position.

public void Insert(
Int32 index,
CultureInfo value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The CultureInfo to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.Remove Method

Removes the first occurrence of a specific CultureInfo from the collection.

public void Remove(
CultureInfo value
);

Parameters

value
The CultureInfo to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.Reverse Method

Reverses the order of the CultureInfos in this CultureInfoCollection.

new public CultureInfoCollection Reverse();

Return Value

This CultureInfoCollection, modified such that the CultureInfos are reversed.

Remarks

The CultureInfoCollection is modified in place.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.Sort Method

Sorts the CultureInfos in this CultureInfoCollection, using the given comparer.

new public CultureInfoCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two CultureInfos.

Return Value

This CultureInfoCollection, modified such that the CultureInfos are sorted.

Remarks

The CultureInfoCollection is modified in place.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.SortByName Method

Sorts the CultureInfos in this CultureInfoCollection by name.

public CultureInfoCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This CultureInfoCollection, modified such that the CultureInfos are sorted by name.

Remarks

The CultureInfoCollection is modified in place.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection.Wrap Method

Creates a CultureInfoCollection to represent the given array of Locale (from the java.util namespace).

public static CultureInfoCollection Wrap(
Locale[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new CultureInfoCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a Locale[] from the java.util namespace to the Borland.StarTeam namespace.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection Type Conversions

The type conversions of the CultureInfoCollection class are listed below. For a complete list of CultureInfoCollection class members, see the CultureInfoCollection Members topic.

Public Static Type Conversions

Implicit CultureInfoCollection to Locale[] Conversion | Converts a CultureInfoCollection from the Borland.StarTeam namespace to a Locale[] in the java.util namespace.
Implicit CultureInfoCollection to CultureInfo[] Conversion | Converts a CultureInfoCollection to an array of CultureInfos.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the java.util namespace.

See Also

CultureInfoCollection Class | CultureInfoCollection Members | Borland.StarTeam Namespace


CultureInfoCollection Implicit CultureInfoCollection to Locale[] Conversion

Converts a CultureInfoCollection from the Borland.StarTeam namespace to a Locale[] in the java.util namespace.

public static implicit operator Locale[](
CultureInfoCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the java.util namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, CultureInfoCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


CultureInfoCollection Implicit CultureInfoCollection to CultureInfo[] Conversion

Converts a CultureInfoCollection to an array of CultureInfos.

public static implicit operator CultureInfo[](
CultureInfoCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new CultureInfo wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one CultureInfo wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

CultureInfoCollection Class | Borland.StarTeam Namespace


DirectoryOverrides Class

A class that can parse a StarTeam.ini file and work with the view and folder overrides it specifies.

For a list of all members of this type, see DirectoryOverrides Members.

System.Object
DirectoryOverrides

public class DirectoryOverrides : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DirectoryOverrides Members | Borland.StarTeam Namespace


DirectoryOverrides Members

DirectoryOverrides overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.DirectoryOverrides.

Public Static Type Conversions

Implicit DirectoryOverrides to DirectoryOverrides Conversion Implicitly convert DirectoryOverrides to com.starbase.starteam.DirectoryOverrides.

Public Instance Constructors

DirectoryOverrides Overloaded. Initializes a new instance of the DirectoryOverrides class.

Public Instance Properties

SourceFile [read] the source file specifying the override information.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.DirectoryOverrides.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.DirectoryOverrides.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads the specified ini file. The parsing is very loose so no errors will occur if it is not really a StarTeam.ini file.
LoadDefault | Loads the default ini file for the client platform. On Windows this is the value of the "StarTeam" environment variable which is usually "StarTeam.ini".
Reload | Re-loads the ini.
ReloadIfNeeded | Re-loads the ini only if the file's last modified time stamp has changed.
ToString | Delegate ToString() to com.starbase.starteam.DirectoryOverrides.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides Constructor

Construct DirectoryOverrides from com.starbase.starteam.DirectoryOverrides.

Overload List

Create a new instance with no overrides specified.

public DirectoryOverrides();

Construct DirectoryOverrides from com.starbase.starteam.DirectoryOverrides.

public DirectoryOverrides(DirectoryOverrides);

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides Constructor (DirectoryOverrides)

Construct DirectoryOverrides from com.starbase.starteam.DirectoryOverrides.

public DirectoryOverrides(
DirectoryOverrides impl
);

Parameters

impl
The com.starbase.starteam.DirectoryOverrides to be wrapped.

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace | DirectoryOverrides Constructor Overload List


DirectoryOverrides Constructor ()

Create a new instance with no overrides specified.

public DirectoryOverrides();

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace | DirectoryOverrides Constructor Overload List


DirectoryOverrides Properties

The properties of the DirectoryOverrides class are listed below. For a complete list of DirectoryOverrides class members, see the DirectoryOverrides Members topic.

Public Instance Properties

SourceFile [read] the source file specifying the override information.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


SourceFile Property

Borland StarTeam SDK for .NET

DirectoryOverrides.SourceFile Property

[read] the source file specifying the override information.

public virtual FileInfo SourceFile {get;}

Property Value

the source file specifying the override information.

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides Methods

The methods of the DirectoryOverrides class are listed below. For a complete list of DirectoryOverrides class members, see the DirectoryOverrides Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.DirectoryOverrides.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.DirectoryOverrides.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.DirectoryOverrides.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads the specified ini file. The parsing is very loose so no errors will occur if it is not really a StarTeam.ini file.
LoadDefault | Loads the default ini file for the client platform. On Windows this is the value of the "StarTeam" environment variable which is usually "StarTeam.ini".
Reload | Re-loads the ini.
ReloadIfNeeded | Re-loads the ini only if the file's last modified time stamp has changed.
ToString | Delegate ToString() to com.starbase.starteam.DirectoryOverrides.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.DirectoryOverrides

Implements

IWrapper.Unwrap

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides.Equals Method

Delegate Equals() to com.starbase.starteam.DirectoryOverrides.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.DirectoryOverrides.Equals(obj).

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.DirectoryOverrides.

public override int GetHashCode();

Return Value

com.starbase.starteam.DirectoryOverrides.GetHashCode().

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides.Load Method

Loads the specified ini file. The parsing is very loose so no errors will occur if it is not really a StarTeam.ini file.

public virtual void Load(
FileInfo iniFile
);

Parameters

iniFile
the file to load

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides.LoadDefault Method

Loads the default ini file for the client platform. On Windows this is the value of the "StarTeam" environment variable which is usually "StarTeam.ini".

public virtual void LoadDefault();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides.Reload Method

Re-loads the ini.

public virtual void Reload();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides.ReloadIfNeeded Method

Re-loads the ini only if the file's last modified time stamp has changed.

public virtual void ReloadIfNeeded();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides.ToString Method

Delegate ToString() to com.starbase.starteam.DirectoryOverrides.

public override string ToString();

Return Value

com.starbase.starteam.DirectoryOverrides.ToString()

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides.Wrap Method

Dynamically wraps com.starbase.starteam.DirectoryOverrides.

public static DirectoryOverrides Wrap(
DirectoryOverrides impl
);

Parameters

impl
com.starbase.starteam.DirectoryOverrides to be wrapped.

Return Value

DirectoryOverrides

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DirectoryOverrides Type Conversions

The type conversions of the DirectoryOverrides class are listed below. For a complete list of DirectoryOverrides class members, see the DirectoryOverrides Members topic.

Public Static Type Conversions

Implicit DirectoryOverrides to DirectoryOverrides Conversion Implicitly convert DirectoryOverrides to com.starbase.starteam.DirectoryOverrides.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DirectoryOverrides Class | DirectoryOverrides Members | Borland.StarTeam Namespace


DirectoryOverrides Implicit DirectoryOverrides to DirectoryOverrides Conversion

Implicitly convert DirectoryOverrides to com.starbase.starteam.DirectoryOverrides.

public static implicit operator DirectoryOverrides(
DirectoryOverrides arg
);

Parameters

arg
DirectoryOverrides to convert.

Return Value

com.starbase.starteam.DirectoryOverrides

See Also

DirectoryOverrides Class | Borland.StarTeam Namespace


DisembodiedItemException Class

For a list of all members of this type, see DisembodiedItemException Members.

System.Object
Exception
DisembodiedItemException

public class DisembodiedItemException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DisembodiedItemException Members | Borland.StarTeam Namespace


DisembodiedItemException Members

DisembodiedItemException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.DisembodiedItemException.

Public Static Type Conversions

Implicit DisembodiedItemException to DisembodiedItemException Conversion Implicitly convert DisembodiedItemException to com.starbase.starteam.DisembodiedItemException.

Public Instance Constructors

DisembodiedItemException Overloaded. Initializes a new instance of the DisembodiedItemException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Item |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.DisembodiedItemException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.DisembodiedItemException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.DisembodiedItemException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace


DisembodiedItemException Constructor

Construct DisembodiedItemException from com.starbase.starteam.DisembodiedItemException.

Overload List

Initializes a new instance of the DisembodiedItemException class.

public DisembodiedItemException();

Construct DisembodiedItemException from com.starbase.starteam.DisembodiedItemException.

public DisembodiedItemException(DisembodiedItemException);

public DisembodiedItemException(String);

public DisembodiedItemException(String,Item);

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace


DisembodiedItemException Constructor (DisembodiedItemException)

Construct DisembodiedItemException from com.starbase.starteam.DisembodiedItemException.

public DisembodiedItemException(
DisembodiedItemException impl
);

Parameters

impl
The com.starbase.starteam.DisembodiedItemException to be wrapped.

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace | DisembodiedItemException Constructor Overload List


DisembodiedItemException Constructor ()

Initializes a new instance of the DisembodiedItemException class.

public DisembodiedItemException();

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace | DisembodiedItemException Constructor Overload List


DisembodiedItemException Constructor (String)

public DisembodiedItemException(
String message
);

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace | DisembodiedItemException Constructor Overload List


DisembodiedItemException Constructor (String, Item)

public DisembodiedItemException(
String message,
Item disembodiedItem
);

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace | DisembodiedItemException Constructor Overload List


DisembodiedItemException Properties

The properties of the DisembodiedItemException class are listed below. For a complete list of DisembodiedItemException class members, see the DisembodiedItemException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Item |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

DisembodiedItemException.Item Property

public virtual Item Item {get;}

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace


DisembodiedItemException Methods

The methods of the DisembodiedItemException class are listed below. For a complete list of DisembodiedItemException class members, see the DisembodiedItemException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.DisembodiedItemException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.DisembodiedItemException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.DisembodiedItemException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.DisembodiedItemException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace


DisembodiedItemException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.DisembodiedItemException

Implements

IWrapper.Unwrap

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace


DisembodiedItemException.Equals Method

Delegate Equals() to com.starbase.starteam.DisembodiedItemException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.DisembodiedItemException.Equals(obj).

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace


DisembodiedItemException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.DisembodiedItemException.

public override int GetHashCode();

Return Value

com.starbase.starteam.DisembodiedItemException.GetHashCode().

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace


DisembodiedItemException.ToString Method

Delegate ToString() to com.starbase.starteam.DisembodiedItemException.

public override string ToString();

Return Value

com.starbase.starteam.DisembodiedItemException.ToString()

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace


DisembodiedItemException.Wrap Method

Dynamically wraps com.starbase.starteam.DisembodiedItemException.

public static DisembodiedItemException Wrap(
DisembodiedItemException impl
);

Parameters

impl
com.starbase.starteam.DisembodiedItemException to be wrapped.

Return Value

DisembodiedItemException

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace


DisembodiedItemException Type Conversions

The type conversions of the DisembodiedItemException class are listed below. For a complete list of DisembodiedItemException class members, see the DisembodiedItemException Members topic.

Public Static Type Conversions

Implicit DisembodiedItemException to DisembodiedItemException Conversion Implicitly convert DisembodiedItemException to com.starbase.starteam.DisembodiedItemException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DisembodiedItemException Class | DisembodiedItemException Members | Borland.StarTeam Namespace


DisembodiedItemException Implicit DisembodiedItemException to DisembodiedItemException Conversion

Implicitly convert DisembodiedItemException to com.starbase.starteam.DisembodiedItemException.

public static implicit operator DisembodiedItemException(
DisembodiedItemException arg
);

Parameters

arg
DisembodiedItemException to convert.

Return Value

com.starbase.starteam.DisembodiedItemException

See Also

DisembodiedItemException Class | Borland.StarTeam Namespace


DuplicateServerListEntryException Class

For a list of all members of this type, see DuplicateServerListEntryException Members.

System.Object
Exception
DuplicateServerListEntryException

public class DuplicateServerListEntryException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DuplicateServerListEntryException Members | Borland.StarTeam Namespace


DuplicateServerListEntryException Members

DuplicateServerListEntryException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.DuplicateServerListEntryException.

Public Static Type Conversions

Implicit DuplicateServerListEntryException to DuplicateServerListEntryException Conversion Implicitly convert DuplicateServerListEntryException to com.starbase.starteam.DuplicateServerListEntryException.

Public Instance Constructors

DuplicateServerListEntryException Overloaded. Initializes a new instance of the DuplicateServerListEntryException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.DuplicateServerListEntryException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.DuplicateServerListEntryException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.DuplicateServerListEntryException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DuplicateServerListEntryException Class | Borland.StarTeam Namespace


DuplicateServerListEntryException Constructor

Construct DuplicateServerListEntryException from com.starbase.starteam.DuplicateServerListEntryException.

Overload List

Construct DuplicateServerListEntryException from com.starbase.starteam.DuplicateServerListEntryException.

public DuplicateServerListEntryException(DuplicateServerListEntryException);

public DuplicateServerListEntryException(String);

See Also

DuplicateServerListEntryException Class | Borland.StarTeam Namespace


DuplicateServerListEntryException Constructor (DuplicateServerListEntryException)

Construct DuplicateServerListEntryException from com.starbase.starteam.DuplicateServerListEntryException.

public DuplicateServerListEntryException(
DuplicateServerListEntryException impl
);

Parameters

impl
The com.starbase.starteam.DuplicateServerListEntryException to be wrapped.

See Also

DuplicateServerListEntryException Class | Borland.StarTeam Namespace | DuplicateServerListEntryException Constructor Overload List


DuplicateServerListEntryException Constructor (String)

public DuplicateServerListEntryException(
String message
);

See Also

DuplicateServerListEntryException Class | Borland.StarTeam Namespace | DuplicateServerListEntryException Constructor Overload List


DuplicateServerListEntryException Methods

The methods of the DuplicateServerListEntryException class are listed below. For a complete list of DuplicateServerListEntryException class members, see the DuplicateServerListEntryException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.DuplicateServerListEntryException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.DuplicateServerListEntryException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.DuplicateServerListEntryException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.DuplicateServerListEntryException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DuplicateServerListEntryException Class | Borland.StarTeam Namespace


DuplicateServerListEntryException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.DuplicateServerListEntryException

Implements

IWrapper.Unwrap

See Also

DuplicateServerListEntryException Class | Borland.StarTeam Namespace


DuplicateServerListEntryException.Equals Method

Delegate Equals() to com.starbase.starteam.DuplicateServerListEntryException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.DuplicateServerListEntryException.Equals(obj).

See Also

DuplicateServerListEntryException Class | Borland.StarTeam Namespace


DuplicateServerListEntryException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.DuplicateServerListEntryException.

public override int GetHashCode();

Return Value

com.starbase.starteam.DuplicateServerListEntryException.GetHashCode().

See Also

DuplicateServerListEntryException Class | Borland.StarTeam Namespace


DuplicateServerListEntryException.ToString Method

Delegate ToString() to com.starbase.starteam.DuplicateServerListEntryException.

public override string ToString();

Return Value

com.starbase.starteam.DuplicateServerListEntryException.ToString()

See Also

DuplicateServerListEntryException Class | Borland.StarTeam Namespace


DuplicateServerListEntryException.Wrap Method

Dynamically wraps com.starbase.starteam.DuplicateServerListEntryException.

public static DuplicateServerListEntryException Wrap(
DuplicateServerListEntryException impl
);

Parameters

impl
com.starbase.starteam.DuplicateServerListEntryException to be wrapped.

Return Value

DuplicateServerListEntryException

See Also

DuplicateServerListEntryException Class | Borland.StarTeam Namespace


DuplicateServerListEntryException Type Conversions

The type conversions of the DuplicateServerListEntryException class are listed below. For a complete list of DuplicateServerListEntryException class members, see the DuplicateServerListEntryException Members topic.

Public Static Type Conversions

Implicit DuplicateServerListEntryException to DuplicateServerListEntryException Conversion Implicitly convert DuplicateServerListEntryException to com.starbase.starteam.DuplicateServerListEntryException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DuplicateServerListEntryException Class | DuplicateServerListEntryException Members | Borland.StarTeam Namespace


DuplicateServerListEntryException Implicit DuplicateServerListEntryException to DuplicateServerListEntryException Conversion

Implicitly convert DuplicateServerListEntryException to com.starbase.starteam.DuplicateServerListEntryException.

public static implicit operator DuplicateServerListEntryException(
DuplicateServerListEntryException arg
);

Parameters

arg
DuplicateServerListEntryException to convert.

Return Value

com.starbase.starteam.DuplicateServerListEntryException

See Also

DuplicateServerListEntryException Class | Borland.StarTeam Namespace


EffectiveACE Class

An Access Control Entry (ACE) in an Effective Access Control List (ACL).

An EffectiveACE may be an ACE that is explicitly listed in the ACL for an object or for its parent container, or may be implied by group permissions that have been defined, or by object ownership rules, or by the StarTeam access test algorithm itself.

Each EffectiveACE provides information about its origin, including a description in human-readable form.

EffectiveACEs are important with respect to explaining the results of an access test.

For a list of all members of this type, see EffectiveACE Members.

System.Object
ACE
EffectiveACE

public class EffectiveACE : ACE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EffectiveACE Members | Borland.StarTeam Namespace


EffectiveACE Members

EffectiveACE overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.EffectiveACE.

Public Static Type Conversions

Implicit EffectiveACE to EffectiveACE Conversion Implicitly convert EffectiveACE to com.starbase.starteam.EffectiveACE.

Public Instance Constructors

EffectiveACE Constructor Construct EffectiveACE from com.starbase.starteam.EffectiveACE.

Public Instance Properties

Container | [read] The parent container whose ACL defined this ACE, or null if this is not an ACE that was defined in one of the object's parent containers.
Description | [read] A description of this ACE, explaining its origin in human-readable form.
Group | [read] The Group to which this ACE applies, or null if this ACE applies to a specific user instead of a group.
ID (inherited from ACE) | [read] the user or group ID for this entry.
IsExplicitACE | [read] true if this ACE is explicitly represented in an ACL on the object or one of its parent containers.
IsFromContainerACL | [read] true if this is an ACE that is explicitly defined in the Access Control List (ACL) of one of the object's parent containers, and false otherwise.
IsFromGroupPrivileges | [read] true if this is an ACE that is implied by group privileges, and false otherwise.
IsFromMissingACE | [read] true if this ACE is implicit in the StarTeam access control algorithm, which dictates that if a given permission is not explicitly specified in an ACL, then access is denied by default.
IsFromMissingACL | [read] true if this ACE is implicit in the StarTeam access control algorithm, which dictates that if there is no ACL defined on an object or on any parent container, then access is granted by default.
IsFromObjectACL | [read] true if this is an ACE that is explicitly defined in the object's Access Control List (ACL), and false otherwise.
IsFromObjectOwnership | [read] true if this is an ACE that is implied by object ownership rules, and false otherwise.
IsGranted (inherited from ACE) | [read/write] true if the permissions are granted and false if denied.
IsGroupID (inherited from ACE) | [read] true if the ID represents a group.
IsImpliedACE | [read] true if this is an implied ACE that is not explicitly represented in an object or container-level ACL.
Object | [read] The securable object to which this ACE applies, or null if this ACE does not apply to a specific securable object.
ObjectType | [read] The type of securable object to which this ACE applies, or null if this ACE was not defined in a container-level ACL, and does not apply to a specific securable object.
PermissionFlags (inherited from ACE) | [read] the internal "bit set" representation of this entry's permissions.
User | [read] The User to which this ACE applies, or null if this ACE applies to a group instead of a specific user.
UserOrGroupName | [read] The name of the user or group to which this ACE applies.

Public Instance Methods

AddPermission (inherited from ACE) | Adds the specified permission to this entry.
Equals (inherited from ACE) | Delegate Equals() to com.starbase.starteam.AclEntry.
GetHashCode (inherited from ACE) | Delegate GetHashCode() to com.starbase.starteam.AclEntry.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from ACE) | Returns true if the specified permission is a part of this entry.
RemovePermission (inherited from ACE) | Removes the specified permission from this entry.
ToString (inherited from ACE) | Delegate ToString() to com.starbase.starteam.AclEntry.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ACE) Implementation of IWrapper.Unwrap().

See Also

EffectiveACE Class | Borland.StarTeam Namespace


EffectiveACE Constructor

Construct EffectiveACE from com.starbase.starteam.EffectiveACE.

public EffectiveACE(
EffectiveACE impl
);

Parameters

impl
The com.starbase.starteam.EffectiveACE to be wrapped.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


EffectiveACE Properties

The properties of the EffectiveACE class are listed below. For a complete list of EffectiveACE class members, see the EffectiveACE Members topic.

Public Instance Properties

Container | [read] The parent container whose ACL defined this ACE, or null if this is not an ACE that was defined in one of the object's parent containers.
Description | [read] A description of this ACE, explaining its origin in human-readable form.
Group | [read] The Group to which this ACE applies, or null if this ACE applies to a specific user instead of a group.
ID (inherited from ACE) | [read] the user or group ID for this entry.
IsExplicitACE | [read] true if this ACE is explicitly represented in an ACL on the object or one of its parent containers.
IsFromContainerACL | [read] true if this is an ACE that is explicitly defined in the Access Control List (ACL) of one of the object's parent containers, and false otherwise.
IsFromGroupPrivileges | [read] true if this is an ACE that is implied by group privileges, and false otherwise.
IsFromMissingACE | [read] true if this ACE is implicit in the StarTeam access control algorithm, which dictates that if a given permission is not explicitly specified in an ACL, then access is denied by default.
IsFromMissingACL | [read] true if this ACE is implicit in the StarTeam access control algorithm, which dictates that if there is no ACL defined on an object or on any parent container, then access is granted by default.
IsFromObjectACL | [read] true if this is an ACE that is explicitly defined in the object's Access Control List (ACL), and false otherwise.
IsFromObjectOwnership | [read] true if this is an ACE that is implied by object ownership rules, and false otherwise.
IsGranted (inherited from ACE) | [read/write] true if the permissions are granted and false if denied.
IsGroupID (inherited from ACE) | [read] true if the ID represents a group.
IsImpliedACE | [read] true if this is an implied ACE that is not explicitly represented in an object or container-level ACL.
Object | [read] The securable object to which this ACE applies, or null if this ACE does not apply to a specific securable object.
ObjectType | [read] The type of securable object to which this ACE applies, or null if this ACE was not defined in a container-level ACL, and does not apply to a specific securable object.
PermissionFlags (inherited from ACE) | [read] the internal "bit set" representation of this entry's permissions.
User | [read] The User to which this ACE applies, or null if this ACE applies to a group instead of a specific user.
UserOrGroupName | [read] The name of the user or group to which this ACE applies.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ACE) Implementation of IWrapper.Unwrap().

See Also

EffectiveACE Class | Borland.StarTeam Namespace


Container Property

Borland StarTeam SDK for .NET

EffectiveACE.Container Property

[read] The parent container whose ACL defined this ACE, or null if this is not an ACE that was defined in one of the object's parent containers.

public virtual ISecurableContainer Container {get;}

Property Value

The parent container whose ACL defined this ACE, or null if this is not an ACE that was defined in one of the object's parent containers.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

EffectiveACE.Description Property

[read] A description of this ACE, explaining its origin in human-readable form.

public virtual String Description {get;}

Property Value

A description of this ACE, explaining its origin in human-readable form.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


Group Property

Borland StarTeam SDK for .NET

EffectiveACE.Group Property

[read] The Group to which this ACE applies, or null if this ACE applies to a specific user instead of a group.

public virtual Group Group {get;}

Property Value

The Group to which this ACE applies, or null if this ACE applies to a specific user instead of a group.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


IsExplicitACE Property

Borland StarTeam SDK for .NET

EffectiveACE.IsExplicitACE Property

[read] true if this ACE is explicitly represented in an ACL on the object or one of its parent containers.

public virtual Boolean IsExplicitACE {get;}

Property Value

true if this ACE is explicitly represented in an ACL on the object or one of its parent containers.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


IsFromContainerACL Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromContainerACL Property

[read] true if this is an ACE that is explicitly defined in the Access Control List (ACL) of one of the object's parent containers, and false otherwise.

public virtual Boolean IsFromContainerACL {get;}

Property Value

true if this is an ACE that is explicitly defined in the Access Control List (ACL) of one of the object's parent containers, and false otherwise.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


IsFromGroupPrivileges Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromGroupPrivileges Property

[read] true if this is an ACE that is implied by group privileges, and false otherwise.

public virtual Boolean IsFromGroupPrivileges {get;}

Property Value

true if this is an ACE that is implied by group privileges, and false otherwise.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


IsFromMissingACE Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromMissingACE Property

[read] true if this ACE is implicit in the StarTeam access control algorithm, which dictates that if a given permission is not explicitly specified in an ACL, then access is denied by default.

public virtual Boolean IsFromMissingACE {get;}

Property Value

true if this ACE is implicit in the StarTeam access control algorithm, which dictates that if a given permission is not explicitly specified in an ACL, then access is denied by default.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


IsFromMissingACL Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromMissingACL Property

[read] true if this ACE is implicit in the StarTeam access control algorithm, which dictates that if there is no ACL defined on an object or on any parent container, then access is granted by default.

public virtual Boolean IsFromMissingACL {get;}

Property Value

true if this ACE is implicit in the StarTeam access control algorithm, which dictates that if there is no ACL defined on an object or on any parent container, then access is granted by default.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


IsFromObjectACL Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromObjectACL Property

[read] true if this is an ACE that is explicitly defined in the object's Access Control List (ACL), and false otherwise.

public virtual Boolean IsFromObjectACL {get;}

Property Value

true if this is an ACE that is explicitly defined in the object's Access Control List (ACL), and false otherwise.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


IsFromObjectOwnership Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromObjectOwnership Property

[read] true if this is an ACE that is implied by object ownership rules, and false otherwise.

public virtual Boolean IsFromObjectOwnership {get;}

Property Value

true if this is an ACE that is implied by object ownership rules, and false otherwise.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


IsImpliedACE Property

Borland StarTeam SDK for .NET

EffectiveACE.IsImpliedACE Property

[read] true if this is an implied ACE that is not explicitly represented in an object or container-level ACL.

public virtual Boolean IsImpliedACE {get;}

Property Value

true if this is an implied ACE that is not explicitly represented in an object or container-level ACL.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


Object Property

Borland StarTeam SDK for .NET

EffectiveACE.Object Property

[read] The securable object to which this ACE applies, or null if this ACE does not apply to a specific securable object.

public virtual ISecurable Object {get;}

Property Value

The securable object to which this ACE applies, or null if this ACE does not apply to a specific securable object.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


ObjectType Property

Borland StarTeam SDK for .NET

EffectiveACE.ObjectType Property

[read] The type of securable object to which this ACE applies, or null if this ACE was not defined in a container-level ACL, and does not apply to a specific securable object.

public virtual Type ObjectType {get;}

Property Value

The type of securable object to which this ACE applies, or null if this ACE was not defined in a container-level ACL, and does not apply to a specific securable object.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


User Property

Borland StarTeam SDK for .NET

EffectiveACE.User Property

[read] The User to which this ACE applies, or null if this ACE applies to a group instead of a specific user.

public virtual User User {get;}

Property Value

The User to which this ACE applies, or null if this ACE applies to a group instead of a specific user.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


UserOrGroupName Property

Borland StarTeam SDK for .NET

EffectiveACE.UserOrGroupName Property

[read] The name of the user or group to which this ACE applies.

public virtual String UserOrGroupName {get;}

Property Value

The name of the user or group to which this ACE applies.

See Also

EffectiveACE Class | Borland.StarTeam Namespace


EffectiveACE Methods

The methods of the EffectiveACE class are listed below. For a complete list of EffectiveACE class members, see the EffectiveACE Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.EffectiveACE.

Public Instance Methods

AddPermission (inherited from ACE) | Adds the specified permission to this entry.
Equals (inherited from ACE) | Delegate Equals() to com.starbase.starteam.AclEntry.
GetHashCode (inherited from ACE) | Delegate GetHashCode() to com.starbase.starteam.AclEntry.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from ACE) | Returns true if the specified permission is a part of this entry.
RemovePermission (inherited from ACE) | Removes the specified permission from this entry.
ToString (inherited from ACE) | Delegate ToString() to com.starbase.starteam.AclEntry.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ACE) Implementation of IWrapper.Unwrap().

See Also

EffectiveACE Class | Borland.StarTeam Namespace


EffectiveACE.Wrap Method

Dynamically wraps com.starbase.starteam.EffectiveACE.

public static EffectiveACE Wrap(
EffectiveACE impl
);

Parameters

impl
com.starbase.starteam.EffectiveACE to be wrapped.

Return Value

EffectiveACE

See Also

EffectiveACE Class | Borland.StarTeam Namespace


EffectiveACE Type Conversions

The type conversions of the EffectiveACE class are listed below. For a complete list of EffectiveACE class members, see the EffectiveACE Members topic.

Public Static Type Conversions

Implicit EffectiveACE to EffectiveACE Conversion Implicitly convert EffectiveACE to com.starbase.starteam.EffectiveACE.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ACE) Implementation of IWrapper.Unwrap().

See Also

EffectiveACE Class | EffectiveACE Members | Borland.StarTeam Namespace


EffectiveACE Implicit EffectiveACE to EffectiveACE Conversion

Implicitly convert EffectiveACE to com.starbase.starteam.EffectiveACE.

public static implicit operator EffectiveACE(
EffectiveACE arg
);

Parameters

arg
EffectiveACE to convert.

Return Value

com.starbase.starteam.EffectiveACE

See Also

EffectiveACE Class | Borland.StarTeam Namespace


EffectiveACL Class

A strongly-typed collection of EffectiveACEs.

For a list of all members of this type, see EffectiveACL Members.

System.Object
ArrayAdapter
EffectiveACL

public class EffectiveACL : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EffectiveACL Members | Borland.StarTeam Namespace


EffectiveACL Members

EffectiveACL overview

Public Static Methods

Wrap Creates an EffectiveACL to represent the given array of EffectiveACE (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit EffectiveACL to EffectiveACE[] Conversion | Converts an EffectiveACL to an array of EffectiveACEs.
Implicit EffectiveACL to EffectiveACE[] Conversion | Converts an EffectiveACL from the Borland.StarTeam namespace to an EffectiveACE[] in the com.starbase.starteam namespace.

Public Instance Constructors

EffectiveACL Overloaded. Initializes a new instance of the EffectiveACL class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the EffectiveACE at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an EffectiveACE to end of the collection.
Append | Overloaded. Appends the EffectiveACEs of the given EffectiveACL to the end of this EffectiveACL.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific EffectiveACE.
CopyTo | Copies all of the EffectiveACEs in the EffectiveACL to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the EffectiveACE with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific EffectiveACE in the collection.
Insert | Inserts an EffectiveACE into the collection at the specified position.
Remove | Removes the first occurrence of a specific EffectiveACE from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the EffectiveACEs in this EffectiveACL.
Sort | Sorts the EffectiveACEs in this EffectiveACL, using the given comparer.
SortByID | Sorts the EffectiveACEs in this EffectiveACL by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL Constructor

Initializes an instance of the EffectiveACL class.

Overload List

Initializes an instance of the EffectiveACL class.

public EffectiveACL();

Initializes an instance of the an EffectiveACL class, copying the given array.

public EffectiveACL(EffectiveACE[]);

Initializes an instance of the an EffectiveACL class, copying the given collection.

public EffectiveACL(EffectiveACL);

Initializes an instance of the an EffectiveACL class, wrapping the given array of EffectiveACE (from the com.starbase.starteam namespace).

public EffectiveACL(EffectiveACE[]);

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL Constructor ()

Initializes an instance of the EffectiveACL class.

public EffectiveACL();

See Also

EffectiveACL Class | Borland.StarTeam Namespace | EffectiveACL Constructor Overload List


EffectiveACL Constructor (EffectiveACE[])

Initializes an instance of the an EffectiveACL class, wrapping the given array of EffectiveACE (from the com.starbase.starteam namespace).

public EffectiveACL(
EffectiveACE[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

EffectiveACL Class | Borland.StarTeam Namespace | EffectiveACL Constructor Overload List | Wrap


EffectiveACL Constructor (EffectiveACL)

Initializes an instance of the an EffectiveACL class, copying the given collection.

public EffectiveACL(
EffectiveACL collection
);

Parameters

collection
The collection to be copied.

Remarks

The member EffectiveACE objects of the original collection are shared, not copied.

See Also

EffectiveACL Class | Borland.StarTeam Namespace | EffectiveACL Constructor Overload List


EffectiveACL Constructor (EffectiveACE[])

Initializes an instance of the an EffectiveACL class, copying the given array.

public EffectiveACL(
EffectiveACE[] array
);

Parameters

array
The array to be copied.

Remarks

The member EffectiveACE objects of the original array are shared, not copied.

See Also

EffectiveACL Class | Borland.StarTeam Namespace | EffectiveACL Constructor Overload List


EffectiveACL Properties

The properties of the EffectiveACL class are listed below. For a complete list of EffectiveACL class members, see the EffectiveACL Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the EffectiveACE at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

EffectiveACL.Item Property

Gets or sets the EffectiveACE at the specified index.

public EffectiveACE this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the EffectiveACE to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL Methods

The methods of the EffectiveACL class are listed below. For a complete list of EffectiveACL class members, see the EffectiveACL Members topic.

Public Static Methods

Wrap Creates an EffectiveACL to represent the given array of EffectiveACE (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds an EffectiveACE to end of the collection.
Append | Overloaded. Appends the EffectiveACEs of the given EffectiveACL to the end of this EffectiveACL.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific EffectiveACE.
CopyTo | Copies all of the EffectiveACEs in the EffectiveACL to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the EffectiveACE with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific EffectiveACE in the collection.
Insert | Inserts an EffectiveACE into the collection at the specified position.
Remove | Removes the first occurrence of a specific EffectiveACE from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the EffectiveACEs in this EffectiveACL.
Sort | Sorts the EffectiveACEs in this EffectiveACL, using the given comparer.
SortByID | Sorts the EffectiveACEs in this EffectiveACL by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.Add Method

Adds an EffectiveACE to end of the collection.

public int Add(
EffectiveACE value
);

Parameters

value
The EffectiveACE to add to the collection.

Return Value

The position into which the new EffectiveACE was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

EffectiveACL.Append Method

Appends the EffectiveACEs of the given array to the end of this EffectiveACL.

Overload List

Appends the EffectiveACEs of the given array to the end of this EffectiveACL.

public EffectiveACL Append(EffectiveACE[]);

Appends the EffectiveACEs of the given EffectiveACL to the end of this EffectiveACL.

public EffectiveACL Append(EffectiveACL);

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.Append Method (EffectiveACE[])

Appends the EffectiveACEs of the given array to the end of this EffectiveACL.

public EffectiveACL Append(
EffectiveACE[] array
);

Parameters

array
The array whose EffectiveACEs are to be appended to this EffectiveACL.

Return Value

This EffectiveACL, modified to include the new EffectiveACEs.

Remarks

The EffectiveACL is modified to include the new members. The individual EffectiveACE objects are shared, not copied.

See Also

EffectiveACL Class | Borland.StarTeam Namespace | EffectiveACL.Append Overload List


EffectiveACL.Append Method (EffectiveACL)

Appends the EffectiveACEs of the given EffectiveACL to the end of this EffectiveACL.

public EffectiveACL Append(
EffectiveACL collection
);

Parameters

collection
The EffectiveACL whose EffectiveACEs are to be appended to this EffectiveACL.

Return Value

This EffectiveACL, modified to include the new EffectiveACEs.

Remarks

The EffectiveACL is modified to include the new members. The individual EffectiveACE objects are shared, not copied.

See Also

EffectiveACL Class | Borland.StarTeam Namespace | EffectiveACL.Append Overload List


EffectiveACL.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.EffectiveACE[].

Implements

IWrapper.Unwrap

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.Contains Method

Determines whether or not the collection contains a specific EffectiveACE.

public bool Contains(
EffectiveACE value
);

Parameters

value
The EffectiveACE to locate in the collection.

Return Value

true if the EffectiveACE is found in the collection; otherwise, false.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.CopyTo Method

Copies all of the EffectiveACEs in the EffectiveACL to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
EffectiveACE[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the EffectiveACEs copied from the EffectiveACL.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of EffectiveACEs in the source EffectiveACL is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source EffectiveACL cannot be cast automatically to the type of the destination array.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.FindByID Method

Finds the EffectiveACE with the given ID.

public EffectiveACE FindByID(
Int32 id
);

Parameters

id
The ID of the EffectiveACE to be found.

Return Value

The EffectiveACE with the given ID, or null if there is no EffectiveACE with that ID in this EffectiveACL.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.IndexOf Method

Determines the index of a specific EffectiveACE in the collection.

public int IndexOf(
EffectiveACE value
);

Parameters

value
The EffectiveACE to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.Insert Method

Inserts an EffectiveACE into the collection at the specified position.

public void Insert(
Int32 index,
EffectiveACE value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The EffectiveACE to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.Remove Method

Removes the first occurrence of a specific EffectiveACE from the collection.

public void Remove(
EffectiveACE value
);

Parameters

value
The EffectiveACE to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.Reverse Method

Reverses the order of the EffectiveACEs in this EffectiveACL.

new public EffectiveACL Reverse();

Return Value

This EffectiveACL, modified such that the EffectiveACEs are reversed.

Remarks

The EffectiveACL is modified in place.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.Sort Method

Sorts the EffectiveACEs in this EffectiveACL, using the given comparer.

new public EffectiveACL Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two EffectiveACEs.

Return Value

This EffectiveACL, modified such that the EffectiveACEs are sorted.

Remarks

The EffectiveACL is modified in place.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.SortByID Method

Sorts the EffectiveACEs in this EffectiveACL by ID.

public EffectiveACL SortByID();

Return Value

This EffectiveACL, modified such that the EffectiveACEs are sorted by ID.

Remarks

The EffectiveACL is modified in place.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL.Wrap Method

Creates an EffectiveACL to represent the given array of EffectiveACE (from the com.starbase.starteam namespace).

public static EffectiveACL Wrap(
EffectiveACE[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new EffectiveACL, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an EffectiveACE[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL Type Conversions

The type conversions of the EffectiveACL class are listed below. For a complete list of EffectiveACL class members, see the EffectiveACL Members topic.

Public Static Type Conversions

Implicit EffectiveACL to EffectiveACE[] Conversion | Converts an EffectiveACL to an array of EffectiveACEs.
Implicit EffectiveACL to EffectiveACE[] Conversion | Converts an EffectiveACL from the Borland.StarTeam namespace to an EffectiveACE[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EffectiveACL Class | EffectiveACL Members | Borland.StarTeam Namespace


EffectiveACL Implicit EffectiveACL to EffectiveACE[] Conversion

Converts an EffectiveACL to an array of EffectiveACEs.

public static implicit operator EffectiveACE[](
EffectiveACL arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new EffectiveACE wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one EffectiveACE wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EffectiveACL Implicit EffectiveACL to EffectiveACE[] Conversion

Converts an EffectiveACL from the Borland.StarTeam namespace to an EffectiveACE[] in the com.starbase.starteam namespace.

public static implicit operator EffectiveACE[](
EffectiveACL arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, EffectiveACL is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

EffectiveACL Class | Borland.StarTeam Namespace


EmailAttachment Class

This class embodies an email attachment.

For a list of all members of this type, see EmailAttachment Members.

System.Object
EmailAttachment

public class EmailAttachment : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EmailAttachment Members | Borland.StarTeam Namespace


EmailAttachment Members

EmailAttachment overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.EmailAttachment.

Public Static Type Conversions

Implicit EmailAttachment to EmailAttachment Conversion Implicitly convert EmailAttachment to com.starbase.starteam.EmailAttachment.

Public Instance Constructors

EmailAttachment Overloaded. Initializes a new instance of the EmailAttachment class.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.EmailAttachment.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.EmailAttachment.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.EmailAttachment.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EmailAttachment Class | Borland.StarTeam Namespace


EmailAttachment Constructor

Construct EmailAttachment from com.starbase.starteam.EmailAttachment.

Overload List

Construct EmailAttachment from com.starbase.starteam.EmailAttachment.

public EmailAttachment(EmailAttachment);

Creates a new email attachment based on the specified input file. You must also supply a name for the attachment and the MIME content-type. For example, content-type might be "text/html"

public EmailAttachment(FileInfo,String,String);

See Also

EmailAttachment Class | Borland.StarTeam Namespace


EmailAttachment Constructor (EmailAttachment)

Construct EmailAttachment from com.starbase.starteam.EmailAttachment.

public EmailAttachment(
EmailAttachment impl
);

Parameters

impl
The com.starbase.starteam.EmailAttachment to be wrapped.

See Also

EmailAttachment Class | Borland.StarTeam Namespace | EmailAttachment Constructor Overload List


EmailAttachment Constructor (FileInfo, String, String)

Creates a new email attachment based on the specified input file. You must also supply a name for the attachment and the MIME content-type. For example, content-type might be "text/html"

public EmailAttachment(
FileInfo source,
String name,
String contentType
);

Parameters

source
the file to be attached, may not be null
name
the name to call the attachment, may not be null
contentType
the attachment's content type, may not be null

See Also

EmailAttachment Class | Borland.StarTeam Namespace | EmailAttachment Constructor Overload List


EmailAttachment Methods

The methods of the EmailAttachment class are listed below. For a complete list of EmailAttachment class members, see the EmailAttachment Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.EmailAttachment.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.EmailAttachment.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.EmailAttachment.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.EmailAttachment.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EmailAttachment Class | Borland.StarTeam Namespace


EmailAttachment.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.EmailAttachment

Implements

IWrapper.Unwrap

See Also

EmailAttachment Class | Borland.StarTeam Namespace


EmailAttachment.Equals Method

Delegate Equals() to com.starbase.starteam.EmailAttachment.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.EmailAttachment.Equals(obj).

See Also

EmailAttachment Class | Borland.StarTeam Namespace


EmailAttachment.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.EmailAttachment.

public override int GetHashCode();

Return Value

com.starbase.starteam.EmailAttachment.GetHashCode().

See Also

EmailAttachment Class | Borland.StarTeam Namespace


EmailAttachment.ToString Method

Delegate ToString() to com.starbase.starteam.EmailAttachment.

public override string ToString();

Return Value

com.starbase.starteam.EmailAttachment.ToString()

See Also

EmailAttachment Class | Borland.StarTeam Namespace


EmailAttachment.Wrap Method

Dynamically wraps com.starbase.starteam.EmailAttachment.

public static EmailAttachment Wrap(
EmailAttachment impl
);

Parameters

impl
com.starbase.starteam.EmailAttachment to be wrapped.

Return Value

EmailAttachment

See Also

EmailAttachment Class | Borland.StarTeam Namespace


EmailAttachment Type Conversions

The type conversions of the EmailAttachment class are listed below. For a complete list of EmailAttachment class members, see the EmailAttachment Members topic.

Public Static Type Conversions

Implicit EmailAttachment to EmailAttachment Conversion Implicitly convert EmailAttachment to com.starbase.starteam.EmailAttachment.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EmailAttachment Class | EmailAttachment Members | Borland.StarTeam Namespace


EmailAttachment Implicit EmailAttachment to EmailAttachment Conversion

Implicitly convert EmailAttachment to com.starbase.starteam.EmailAttachment.

public static implicit operator EmailAttachment(
EmailAttachment arg
);

Parameters

arg
EmailAttachment to convert.

Return Value

com.starbase.starteam.EmailAttachment

See Also

EmailAttachment Class | Borland.StarTeam Namespace


EmailAttachmentCollection Class

A strongly-typed collection of EmailAttachments.

For a list of all members of this type, see EmailAttachmentCollection Members.

System.Object
ArrayAdapter
EmailAttachmentCollection

public class EmailAttachmentCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EmailAttachmentCollection Members | Borland.StarTeam Namespace


EmailAttachmentCollection Members

EmailAttachmentCollection overview

Public Static Methods

Wrap Creates an EmailAttachmentCollection to represent the given array of EmailAttachment (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit EmailAttachmentCollection to EmailAttachment[] Conversion | Converts an EmailAttachmentCollection to an array of EmailAttachments.
Implicit EmailAttachmentCollection to EmailAttachment[] Conversion | Converts an EmailAttachmentCollection from the Borland.StarTeam namespace to an EmailAttachment[] in the com.starbase.starteam namespace.

Public Instance Constructors

EmailAttachmentCollection Overloaded. Initializes a new instance of the EmailAttachmentCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the EmailAttachment at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an EmailAttachment to end of the collection.
Append | Overloaded. Appends the EmailAttachments of the given EmailAttachmentCollection to the end of this EmailAttachmentCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific EmailAttachment.
CopyTo | Copies all of the EmailAttachments in the EmailAttachmentCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific EmailAttachment in the collection.
Insert | Inserts an EmailAttachment into the collection at the specified position.
Remove | Removes the first occurrence of a specific EmailAttachment from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the EmailAttachments in this EmailAttachmentCollection.
Sort | Sorts the EmailAttachments in this EmailAttachmentCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection Constructor

Initializes an instance of the EmailAttachmentCollection class.

Overload List

Initializes an instance of the EmailAttachmentCollection class.

public EmailAttachmentCollection();

Initializes an instance of the an EmailAttachmentCollection class, copying the given array.

public EmailAttachmentCollection(EmailAttachment[]);

Initializes an instance of the an EmailAttachmentCollection class, copying the given collection.

public EmailAttachmentCollection(EmailAttachmentCollection);

Initializes an instance of the an EmailAttachmentCollection class, wrapping the given array of EmailAttachment (from the com.starbase.starteam namespace).

public EmailAttachmentCollection(EmailAttachment[]);

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection Constructor ()

Initializes an instance of the EmailAttachmentCollection class.

public EmailAttachmentCollection();

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace | EmailAttachmentCollection Constructor Overload List


EmailAttachmentCollection Constructor (EmailAttachment[])

Initializes an instance of the an EmailAttachmentCollection class, wrapping the given array of EmailAttachment (from the com.starbase.starteam namespace).

public EmailAttachmentCollection(
EmailAttachment[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace | EmailAttachmentCollection Constructor Overload List | Wrap


EmailAttachmentCollection Constructor (EmailAttachmentCollection)

Initializes an instance of the an EmailAttachmentCollection class, copying the given collection.

public EmailAttachmentCollection(
EmailAttachmentCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member EmailAttachment objects of the original collection are shared, not copied.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace | EmailAttachmentCollection Constructor Overload List


EmailAttachmentCollection Constructor (EmailAttachment[])

Initializes an instance of the an EmailAttachmentCollection class, copying the given array.

public EmailAttachmentCollection(
EmailAttachment[] array
);

Parameters

array
The array to be copied.

Remarks

The member EmailAttachment objects of the original array are shared, not copied.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace | EmailAttachmentCollection Constructor Overload List


EmailAttachmentCollection Properties

The properties of the EmailAttachmentCollection class are listed below. For a complete list of EmailAttachmentCollection class members, see the EmailAttachmentCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the EmailAttachment at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

EmailAttachmentCollection.Item Property

Gets or sets the EmailAttachment at the specified index.

public EmailAttachment this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the EmailAttachment to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection Methods

The methods of the EmailAttachmentCollection class are listed below. For a complete list of EmailAttachmentCollection class members, see the EmailAttachmentCollection Members topic.

Public Static Methods

Wrap Creates an EmailAttachmentCollection to represent the given array of EmailAttachment (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds an EmailAttachment to end of the collection.
Append | Overloaded. Appends the EmailAttachments of the given EmailAttachmentCollection to the end of this EmailAttachmentCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific EmailAttachment.
CopyTo | Copies all of the EmailAttachments in the EmailAttachmentCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific EmailAttachment in the collection.
Insert | Inserts an EmailAttachment into the collection at the specified position.
Remove | Removes the first occurrence of a specific EmailAttachment from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the EmailAttachments in this EmailAttachmentCollection.
Sort | Sorts the EmailAttachments in this EmailAttachmentCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection.Add Method

Adds an EmailAttachment to end of the collection.

public int Add(
EmailAttachment value
);

Parameters

value
The EmailAttachment to add to the collection.

Return Value

The position into which the new EmailAttachment was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

EmailAttachmentCollection.Append Method

Appends the EmailAttachments of the given array to the end of this EmailAttachmentCollection.

Overload List

Appends the EmailAttachments of the given array to the end of this EmailAttachmentCollection.

public EmailAttachmentCollection Append(EmailAttachment[]);

Appends the EmailAttachments of the given EmailAttachmentCollection to the end of this EmailAttachmentCollection.

public EmailAttachmentCollection Append(EmailAttachmentCollection);

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection.Append Method (EmailAttachment[])

Appends the EmailAttachments of the given array to the end of this EmailAttachmentCollection.

public EmailAttachmentCollection Append(
EmailAttachment[] array
);

Parameters

array
The array whose EmailAttachments are to be appended to this EmailAttachmentCollection.

Return Value

This EmailAttachmentCollection, modified to include the new EmailAttachments.

Remarks

The EmailAttachmentCollection is modified to include the new members. The individual EmailAttachment objects are shared, not copied.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace | EmailAttachmentCollection.Append Overload List


EmailAttachmentCollection.Append Method (EmailAttachmentCollection)

Appends the EmailAttachments of the given EmailAttachmentCollection to the end of this EmailAttachmentCollection.

public EmailAttachmentCollection Append(
EmailAttachmentCollection collection
);

Parameters

collection
The EmailAttachmentCollection whose EmailAttachments are to be appended to this EmailAttachmentCollection.

Return Value

This EmailAttachmentCollection, modified to include the new EmailAttachments.

Remarks

The EmailAttachmentCollection is modified to include the new members. The individual EmailAttachment objects are shared, not copied.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace | EmailAttachmentCollection.Append Overload List


EmailAttachmentCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.EmailAttachment[].

Implements

IWrapper.Unwrap

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection.Contains Method

Determines whether or not the collection contains a specific EmailAttachment.

public bool Contains(
EmailAttachment value
);

Parameters

value
The EmailAttachment to locate in the collection.

Return Value

true if the EmailAttachment is found in the collection; otherwise, false.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection.CopyTo Method

Copies all of the EmailAttachments in the EmailAttachmentCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
EmailAttachment[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the EmailAttachments copied from the EmailAttachmentCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of EmailAttachments in the source EmailAttachmentCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source EmailAttachmentCollection cannot be cast automatically to the type of the destination array.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection.IndexOf Method

Determines the index of a specific EmailAttachment in the collection.

public int IndexOf(
EmailAttachment value
);

Parameters

value
The EmailAttachment to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection.Insert Method

Inserts an EmailAttachment into the collection at the specified position.

public void Insert(
Int32 index,
EmailAttachment value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The EmailAttachment to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection.Remove Method

Removes the first occurrence of a specific EmailAttachment from the collection.

public void Remove(
EmailAttachment value
);

Parameters

value
The EmailAttachment to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection.Reverse Method

Reverses the order of the EmailAttachments in this EmailAttachmentCollection.

new public EmailAttachmentCollection Reverse();

Return Value

This EmailAttachmentCollection, modified such that the EmailAttachments are reversed.

Remarks

The EmailAttachmentCollection is modified in place.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection.Sort Method

Sorts the EmailAttachments in this EmailAttachmentCollection, using the given comparer.

new public EmailAttachmentCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two EmailAttachments.

Return Value

This EmailAttachmentCollection, modified such that the EmailAttachments are sorted.

Remarks

The EmailAttachmentCollection is modified in place.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection.Wrap Method

Creates an EmailAttachmentCollection to represent the given array of EmailAttachment (from the com.starbase.starteam namespace).

public static EmailAttachmentCollection Wrap(
EmailAttachment[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new EmailAttachmentCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an EmailAttachment[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection Type Conversions

The type conversions of the EmailAttachmentCollection class are listed below. For a complete list of EmailAttachmentCollection class members, see the EmailAttachmentCollection Members topic.

Public Static Type Conversions

Implicit EmailAttachmentCollection to EmailAttachment[] Conversion | Converts an EmailAttachmentCollection to an array of EmailAttachments.
Implicit EmailAttachmentCollection to EmailAttachment[] Conversion | Converts an EmailAttachmentCollection from the Borland.StarTeam namespace to an EmailAttachment[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EmailAttachmentCollection Class | EmailAttachmentCollection Members | Borland.StarTeam Namespace


EmailAttachmentCollection Implicit EmailAttachmentCollection to EmailAttachment[] Conversion

Converts an EmailAttachmentCollection to an array of EmailAttachments.

public static implicit operator EmailAttachment[](
EmailAttachmentCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new EmailAttachment wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one EmailAttachment wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EmailAttachmentCollection Implicit EmailAttachmentCollection to EmailAttachment[] Conversion

Converts an EmailAttachmentCollection from the Borland.StarTeam namespace to an EmailAttachment[] in the com.starbase.starteam namespace.

public static implicit operator EmailAttachment[](
EmailAttachmentCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, EmailAttachmentCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

EmailAttachmentCollection Class | Borland.StarTeam Namespace


EncryptionAlgorithm Class

This class provides a convenient place to refer to the different encryption algorithms that can be used for secure StarTeam connections. This class is used by various encryption methods on the connection and server objects. There is also some support for mapping the algorithm to an enum code used by the server. These methods should not be needed by the general user of security.

For a list of all members of this type, see EncryptionAlgorithm Members.

System.Object
EncryptionAlgorithm

public class EncryptionAlgorithm : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EncryptionAlgorithm Members | Borland.StarTeam Namespace


EncryptionAlgorithm Members

EncryptionAlgorithm overview

Public Static Properties

NULL
RC2_CBC
RC2_CFB
RC2_ECB
RC4

Public Static Methods

MaxSecurity | Given two security algorithms return the maximum of the two. Either one may be null and the return value may be null.
Wrap | Dynamically wraps com.starbase.starteam.vts.comm.EncryptionAlgorithm.

Public Static Type Conversions

Implicit EncryptionAlgorithm to EncryptionAlgorithm Conversion Implicitly convert EncryptionAlgorithm to com.starbase.starteam.vts.comm.EncryptionAlgorithm.

Public Instance Constructors

EncryptionAlgorithm Constructor Construct EncryptionAlgorithm from com.starbase.starteam.vts.comm.EncryptionAlgorithm.

Public Instance Properties

DisplayName | [read]
Name | [read]

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.vts.comm.EncryptionAlgorithm.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.vts.comm.EncryptionAlgorithm.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.vts.comm.EncryptionAlgorithm.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


EncryptionAlgorithm Constructor

Construct EncryptionAlgorithm from com.starbase.starteam.vts.comm.EncryptionAlgorithm.

public EncryptionAlgorithm(
EncryptionAlgorithm impl
);

Parameters

impl
The com.starbase.starteam.vts.comm.EncryptionAlgorithm to be wrapped.

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


EncryptionAlgorithm Properties

The properties of the EncryptionAlgorithm class are listed below. For a complete list of EncryptionAlgorithm class members, see the EncryptionAlgorithm Members topic.

Public Static Properties

NULL
RC2_CBC
RC2_CFB
RC2_ECB
RC4

Public Instance Properties

DisplayName | [read]
Name | [read]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

EncryptionAlgorithm.DisplayName Property

[read]

public virtual String DisplayName {get;}

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

EncryptionAlgorithm.Name Property

[read]

public virtual String Name {get;}

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


NULL Property

Borland StarTeam SDK for .NET

EncryptionAlgorithm.NULL Property

public static EncryptionAlgorithm NULL {get;}

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


RC2_CBC Property

Borland StarTeam SDK for .NET

EncryptionAlgorithm.RC2_CBC Property

public static EncryptionAlgorithm RC2_CBC {get;}

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


RC2_CFB Property

Borland StarTeam SDK for .NET

EncryptionAlgorithm.RC2_CFB Property

public static EncryptionAlgorithm RC2_CFB {get;}

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


RC2_ECB Property

Borland StarTeam SDK for .NET

EncryptionAlgorithm.RC2_ECB Property

public static EncryptionAlgorithm RC2_ECB {get;}

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


RC4 Property

Borland StarTeam SDK for .NET

EncryptionAlgorithm.RC4 Property

public static EncryptionAlgorithm RC4 {get;}

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


EncryptionAlgorithm Methods

The methods of the EncryptionAlgorithm class are listed below. For a complete list of EncryptionAlgorithm class members, see the EncryptionAlgorithm Members topic.

Public Static Methods

MaxSecurity | Given two security algorithms return the maximum of the two. Either one may be null and the return value may be null.
Wrap | Dynamically wraps com.starbase.starteam.vts.comm.EncryptionAlgorithm.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.vts.comm.EncryptionAlgorithm.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.vts.comm.EncryptionAlgorithm.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.vts.comm.EncryptionAlgorithm.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


EncryptionAlgorithm.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.vts.comm.EncryptionAlgorithm

Implements

IWrapper.Unwrap

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


EncryptionAlgorithm.Equals Method

Delegate Equals() to com.starbase.starteam.vts.comm.EncryptionAlgorithm.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.vts.comm.EncryptionAlgorithm.Equals(obj).

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


EncryptionAlgorithm.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.vts.comm.EncryptionAlgorithm.

public override int GetHashCode();

Return Value

com.starbase.starteam.vts.comm.EncryptionAlgorithm.GetHashCode().

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


EncryptionAlgorithm.MaxSecurity Method

Given two security algorithms return the maximum of the two. Either one may be null and the return value may be null.

public static EncryptionAlgorithm MaxSecurity(
EncryptionAlgorithm algA,
EncryptionAlgorithm algB
);

Parameters

algA
algB

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


EncryptionAlgorithm.ToString Method

Delegate ToString() to com.starbase.starteam.vts.comm.EncryptionAlgorithm.

public override string ToString();

Return Value

com.starbase.starteam.vts.comm.EncryptionAlgorithm.ToString()

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


EncryptionAlgorithm.Wrap Method

Dynamically wraps com.starbase.starteam.vts.comm.EncryptionAlgorithm.

public static EncryptionAlgorithm Wrap(
EncryptionAlgorithm impl
);

Parameters

impl
com.starbase.starteam.vts.comm.EncryptionAlgorithm to be wrapped.

Return Value

EncryptionAlgorithm

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


EncryptionAlgorithm Type Conversions

The type conversions of the EncryptionAlgorithm class are listed below. For a complete list of EncryptionAlgorithm class members, see the EncryptionAlgorithm Members topic.

Public Static Type Conversions

Implicit EncryptionAlgorithm to EncryptionAlgorithm Conversion Implicitly convert EncryptionAlgorithm to com.starbase.starteam.vts.comm.EncryptionAlgorithm.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EncryptionAlgorithm Class | EncryptionAlgorithm Members | Borland.StarTeam Namespace


EncryptionAlgorithm Implicit EncryptionAlgorithm to EncryptionAlgorithm Conversion

Implicitly convert EncryptionAlgorithm to com.starbase.starteam.vts.comm.EncryptionAlgorithm.

public static implicit operator EncryptionAlgorithm(
EncryptionAlgorithm arg
);

Parameters

arg
EncryptionAlgorithm to convert.

Return Value

com.starbase.starteam.vts.comm.EncryptionAlgorithm

See Also

EncryptionAlgorithm Class | Borland.StarTeam Namespace


EnumeratedValue Class

A simple integer/String pair object to be used for adding new custom enumerated fields (Property) and modifying existing enumerated fields (Property).

For a list of all members of this type, see EnumeratedValue Members.

System.Object
EnumeratedValue
CharacterSet
EOLFormat
ProcessItemUsage

public class EnumeratedValue : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EnumeratedValue Members | Borland.StarTeam Namespace


EnumeratedValue Members

EnumeratedValue overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.EnumeratedValue.

Public Static Type Conversions

Implicit EnumeratedValue to EnumeratedValue Conversion Implicitly convert EnumeratedValue to com.starbase.starteam.EnumeratedValue.

Public Instance Constructors

EnumeratedValue Overloaded. Initializes a new instance of the EnumeratedValue class.

Public Instance Properties

Code | [read/write] the enum code for this object.
Description | [read/write] the description of this object. This may return null.
DisplayName | [read]
Enabled | [read/write] true if this enumerated value is enabled.
SortOrder | [read] The sort order of this enumerated value.
Translations | [read/write]

Public Instance Methods

Copy | Returns a deep copy of this object.
Equals | Delegate Equals() to com.starbase.starteam.EnumeratedValue.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.EnumeratedValue.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.EnumeratedValue.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


EnumeratedValue Constructor

Construct EnumeratedValue from com.starbase.starteam.EnumeratedValue.

Overload List

Construct EnumeratedValue from com.starbase.starteam.EnumeratedValue.

public EnumeratedValue(EnumeratedValue);

Creates a new enumerated value with the specified code and translations for its display name.

public EnumeratedValue(Int32,Translations);

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


EnumeratedValue Constructor (EnumeratedValue)

Construct EnumeratedValue from com.starbase.starteam.EnumeratedValue.

public EnumeratedValue(
EnumeratedValue impl
);

Parameters

impl
The com.starbase.starteam.EnumeratedValue to be wrapped.

See Also

EnumeratedValue Class | Borland.StarTeam Namespace | EnumeratedValue Constructor Overload List


EnumeratedValue Constructor (Int32, Translations)

Creates a new enumerated value with the specified code and translations for its display name.

public EnumeratedValue(
Int32 code,
Translations translations
);

Parameters

code
the enum code value
translations
the display names for this enumerated value. May not be null.

See Also

EnumeratedValue Class | Borland.StarTeam Namespace | EnumeratedValue Constructor Overload List


EnumeratedValue Properties

The properties of the EnumeratedValue class are listed below. For a complete list of EnumeratedValue class members, see the EnumeratedValue Members topic.

Public Instance Properties

Code | [read/write] the enum code for this object.
Description | [read/write] the description of this object. This may return null.
DisplayName | [read]
Enabled | [read/write] true if this enumerated value is enabled.
SortOrder | [read] The sort order of this enumerated value.
Translations | [read/write]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


Code Property

Borland StarTeam SDK for .NET

EnumeratedValue.Code Property

[read/write] the enum code for this object.

public virtual Int32 Code {get; set;}

Property Value

the enum code for this object.

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

EnumeratedValue.Description Property

[read/write] the description of this object. This may return null.

public virtual String Description {get; set;}

Property Value

the description of this object. This may return null.

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

EnumeratedValue.DisplayName Property

[read]

public virtual String DisplayName {get;}

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


Enabled Property

Borland StarTeam SDK for .NET

EnumeratedValue.Enabled Property

[read/write] true if this enumerated value is enabled.

public virtual Boolean Enabled {get; set;}

Property Value

true if this enumerated value is enabled.

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


SortOrder Property

Borland StarTeam SDK for .NET

EnumeratedValue.SortOrder Property

[read] The sort order of this enumerated value.

public virtual Int32 SortOrder {get;}

Property Value

The sort order of this enumerated value.

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


Translations Property

Borland StarTeam SDK for .NET

EnumeratedValue.Translations Property

[read/write]

public virtual Translations Translations {get; set;}

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


EnumeratedValue Methods

The methods of the EnumeratedValue class are listed below. For a complete list of EnumeratedValue class members, see the EnumeratedValue Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.EnumeratedValue.

Public Instance Methods

Copy | Returns a deep copy of this object.
Equals | Delegate Equals() to com.starbase.starteam.EnumeratedValue.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.EnumeratedValue.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.EnumeratedValue.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


EnumeratedValue.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.EnumeratedValue

Implements

IWrapper.Unwrap

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


EnumeratedValue.Copy Method

Returns a deep copy of this object.

public virtual EnumeratedValue Copy();

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


EnumeratedValue.Equals Method

Delegate Equals() to com.starbase.starteam.EnumeratedValue.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.EnumeratedValue.Equals(obj).

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


EnumeratedValue.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.EnumeratedValue.

public override int GetHashCode();

Return Value

com.starbase.starteam.EnumeratedValue.GetHashCode().

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


EnumeratedValue.ToString Method

Delegate ToString() to com.starbase.starteam.EnumeratedValue.

public override string ToString();

Return Value

com.starbase.starteam.EnumeratedValue.ToString()

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


EnumeratedValue.Wrap Method

Dynamically wraps com.starbase.starteam.EnumeratedValue.

public static EnumeratedValue Wrap(
EnumeratedValue impl
);

Parameters

impl
com.starbase.starteam.EnumeratedValue to be wrapped.

Return Value

EnumeratedValue

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


EnumeratedValue Type Conversions

The type conversions of the EnumeratedValue class are listed below. For a complete list of EnumeratedValue class members, see the EnumeratedValue Members topic.

Public Static Type Conversions

Implicit EnumeratedValue to EnumeratedValue Conversion Implicitly convert EnumeratedValue to com.starbase.starteam.EnumeratedValue.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EnumeratedValue Class | EnumeratedValue Members | Borland.StarTeam Namespace


EnumeratedValue Implicit EnumeratedValue to EnumeratedValue Conversion

Implicitly convert EnumeratedValue to com.starbase.starteam.EnumeratedValue.

public static implicit operator EnumeratedValue(
EnumeratedValue arg
);

Parameters

arg
EnumeratedValue to convert.

Return Value

com.starbase.starteam.EnumeratedValue

See Also

EnumeratedValue Class | Borland.StarTeam Namespace


EnumeratedValueCollection Class

A strongly-typed collection of EnumeratedValues.

For a list of all members of this type, see EnumeratedValueCollection Members.

System.Object
ArrayAdapter
EnumeratedValueCollection

public class EnumeratedValueCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EnumeratedValueCollection Members | Borland.StarTeam Namespace


EnumeratedValueCollection Members

EnumeratedValueCollection overview

Public Static Methods

Wrap Creates an EnumeratedValueCollection to represent the given array of EnumeratedValue (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit EnumeratedValueCollection to EnumeratedValue[] Conversion | Converts an EnumeratedValueCollection to an array of EnumeratedValues.
Implicit EnumeratedValueCollection to EnumeratedValue[] Conversion | Converts an EnumeratedValueCollection from the Borland.StarTeam namespace to an EnumeratedValue[] in the com.starbase.starteam namespace.

Public Instance Constructors

EnumeratedValueCollection Overloaded. Initializes a new instance of the EnumeratedValueCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the EnumeratedValue at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an EnumeratedValue to end of the collection.
Append | Overloaded. Appends the EnumeratedValues of the given EnumeratedValueCollection to the end of this EnumeratedValueCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific EnumeratedValue.
CopyTo | Copies all of the EnumeratedValues in the EnumeratedValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific EnumeratedValue in the collection.
Insert | Inserts an EnumeratedValue into the collection at the specified position.
Remove | Removes the first occurrence of a specific EnumeratedValue from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the EnumeratedValues in this EnumeratedValueCollection.
Sort | Sorts the EnumeratedValues in this EnumeratedValueCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection Constructor

Initializes an instance of the EnumeratedValueCollection class.

Overload List

Initializes an instance of the EnumeratedValueCollection class.

public EnumeratedValueCollection();

Initializes an instance of the an EnumeratedValueCollection class, copying the given array.

public EnumeratedValueCollection(EnumeratedValue[]);

Initializes an instance of the an EnumeratedValueCollection class, copying the given collection.

public EnumeratedValueCollection(EnumeratedValueCollection);

Initializes an instance of the an EnumeratedValueCollection class, wrapping the given array of EnumeratedValue (from the com.starbase.starteam namespace).

public EnumeratedValueCollection(EnumeratedValue[]);

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection Constructor ()

Initializes an instance of the EnumeratedValueCollection class.

public EnumeratedValueCollection();

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace | EnumeratedValueCollection Constructor Overload List


EnumeratedValueCollection Constructor (EnumeratedValue[])

Initializes an instance of the an EnumeratedValueCollection class, wrapping the given array of EnumeratedValue (from the com.starbase.starteam namespace).

public EnumeratedValueCollection(
EnumeratedValue[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace | EnumeratedValueCollection Constructor Overload List | Wrap


EnumeratedValueCollection Constructor (EnumeratedValueCollection)

Initializes an instance of the an EnumeratedValueCollection class, copying the given collection.

public EnumeratedValueCollection(
EnumeratedValueCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member EnumeratedValue objects of the original collection are shared, not copied.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace | EnumeratedValueCollection Constructor Overload List


EnumeratedValueCollection Constructor (EnumeratedValue[])

Initializes an instance of the an EnumeratedValueCollection class, copying the given array.

public EnumeratedValueCollection(
EnumeratedValue[] array
);

Parameters

array
The array to be copied.

Remarks

The member EnumeratedValue objects of the original array are shared, not copied.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace | EnumeratedValueCollection Constructor Overload List


EnumeratedValueCollection Properties

The properties of the EnumeratedValueCollection class are listed below. For a complete list of EnumeratedValueCollection class members, see the EnumeratedValueCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the EnumeratedValue at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

EnumeratedValueCollection.Item Property

Gets or sets the EnumeratedValue at the specified index.

public EnumeratedValue this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the EnumeratedValue to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection Methods

The methods of the EnumeratedValueCollection class are listed below. For a complete list of EnumeratedValueCollection class members, see the EnumeratedValueCollection Members topic.

Public Static Methods

Wrap Creates an EnumeratedValueCollection to represent the given array of EnumeratedValue (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds an EnumeratedValue to end of the collection.
Append | Overloaded. Appends the EnumeratedValues of the given EnumeratedValueCollection to the end of this EnumeratedValueCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific EnumeratedValue.
CopyTo | Copies all of the EnumeratedValues in the EnumeratedValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific EnumeratedValue in the collection.
Insert | Inserts an EnumeratedValue into the collection at the specified position.
Remove | Removes the first occurrence of a specific EnumeratedValue from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the EnumeratedValues in this EnumeratedValueCollection.
Sort | Sorts the EnumeratedValues in this EnumeratedValueCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection.Add Method

Adds an EnumeratedValue to end of the collection.

public int Add(
EnumeratedValue value
);

Parameters

value
The EnumeratedValue to add to the collection.

Return Value

The position into which the new EnumeratedValue was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

EnumeratedValueCollection.Append Method

Appends the EnumeratedValues of the given array to the end of this EnumeratedValueCollection.

Overload List

Appends the EnumeratedValues of the given array to the end of this EnumeratedValueCollection.

public EnumeratedValueCollection Append(EnumeratedValue[]);

Appends the EnumeratedValues of the given EnumeratedValueCollection to the end of this EnumeratedValueCollection.

public EnumeratedValueCollection Append(EnumeratedValueCollection);

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection.Append Method (EnumeratedValue[])

Appends the EnumeratedValues of the given array to the end of this EnumeratedValueCollection.

public EnumeratedValueCollection Append(
EnumeratedValue[] array
);

Parameters

array
The array whose EnumeratedValues are to be appended to this EnumeratedValueCollection.

Return Value

This EnumeratedValueCollection, modified to include the new EnumeratedValues.

Remarks

The EnumeratedValueCollection is modified to include the new members. The individual EnumeratedValue objects are shared, not copied.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace | EnumeratedValueCollection.Append Overload List


EnumeratedValueCollection.Append Method (EnumeratedValueCollection)

Appends the EnumeratedValues of the given EnumeratedValueCollection to the end of this EnumeratedValueCollection.

public EnumeratedValueCollection Append(
EnumeratedValueCollection collection
);

Parameters

collection
The EnumeratedValueCollection whose EnumeratedValues are to be appended to this EnumeratedValueCollection.

Return Value

This EnumeratedValueCollection, modified to include the new EnumeratedValues.

Remarks

The EnumeratedValueCollection is modified to include the new members. The individual EnumeratedValue objects are shared, not copied.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace | EnumeratedValueCollection.Append Overload List


EnumeratedValueCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.EnumeratedValue[].

Implements

IWrapper.Unwrap

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection.Contains Method

Determines whether or not the collection contains a specific EnumeratedValue.

public bool Contains(
EnumeratedValue value
);

Parameters

value
The EnumeratedValue to locate in the collection.

Return Value

true if the EnumeratedValue is found in the collection; otherwise, false.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection.CopyTo Method

Copies all of the EnumeratedValues in the EnumeratedValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
EnumeratedValue[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the EnumeratedValues copied from the EnumeratedValueCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of EnumeratedValues in the source EnumeratedValueCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source EnumeratedValueCollection cannot be cast automatically to the type of the destination array.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection.IndexOf Method

Determines the index of a specific EnumeratedValue in the collection.

public int IndexOf(
EnumeratedValue value
);

Parameters

value
The EnumeratedValue to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection.Insert Method

Inserts an EnumeratedValue into the collection at the specified position.

public void Insert(
Int32 index,
EnumeratedValue value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The EnumeratedValue to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection.Remove Method

Removes the first occurrence of a specific EnumeratedValue from the collection.

public void Remove(
EnumeratedValue value
);

Parameters

value
The EnumeratedValue to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection.Reverse Method

Reverses the order of the EnumeratedValues in this EnumeratedValueCollection.

new public EnumeratedValueCollection Reverse();

Return Value

This EnumeratedValueCollection, modified such that the EnumeratedValues are reversed.

Remarks

The EnumeratedValueCollection is modified in place.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection.Sort Method

Sorts the EnumeratedValues in this EnumeratedValueCollection, using the given comparer.

new public EnumeratedValueCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two EnumeratedValues.

Return Value

This EnumeratedValueCollection, modified such that the EnumeratedValues are sorted.

Remarks

The EnumeratedValueCollection is modified in place.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection.Wrap Method

Creates an EnumeratedValueCollection to represent the given array of EnumeratedValue (from the com.starbase.starteam namespace).

public static EnumeratedValueCollection Wrap(
EnumeratedValue[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new EnumeratedValueCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an EnumeratedValue[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection Type Conversions

The type conversions of the EnumeratedValueCollection class are listed below. For a complete list of EnumeratedValueCollection class members, see the EnumeratedValueCollection Members topic.

Public Static Type Conversions

Implicit EnumeratedValueCollection to EnumeratedValue[] Conversion | Converts an EnumeratedValueCollection to an array of EnumeratedValues.
Implicit EnumeratedValueCollection to EnumeratedValue[] Conversion | Converts an EnumeratedValueCollection from the Borland.StarTeam namespace to an EnumeratedValue[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EnumeratedValueCollection Class | EnumeratedValueCollection Members | Borland.StarTeam Namespace


EnumeratedValueCollection Implicit EnumeratedValueCollection to EnumeratedValue[] Conversion

Converts an EnumeratedValueCollection to an array of EnumeratedValues.

public static implicit operator EnumeratedValue[](
EnumeratedValueCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new EnumeratedValue wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one EnumeratedValue wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EnumeratedValueCollection Implicit EnumeratedValueCollection to EnumeratedValue[] Conversion

Converts an EnumeratedValueCollection from the Borland.StarTeam namespace to an EnumeratedValue[] in the com.starbase.starteam namespace.

public static implicit operator EnumeratedValue[](
EnumeratedValueCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, EnumeratedValueCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

EnumeratedValueCollection Class | Borland.StarTeam Namespace


EOLFormat Class

The EOL format of a text file on disk.

For a list of all members of this type, see EOLFormat Members.

System.Object
EnumeratedValue
EOLFormat

public class EOLFormat : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EOLFormat Members | Borland.StarTeam Namespace


EOLFormat Members

EOLFormat overview

Public Static Properties

ALL
CLIENT_DEFINED
FIXED_CR
FIXED_CRLF
FIXED_LF
PLATFORM

Public Static Methods

FromEOL | Determines the EOLFormat whose end-of-line character sequence matches the given one. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.
FromEOLFormatID | Determines the EOLFormat whose end-of-line character sequence matches the given LineReader EOL ID. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.
Wrap | Dynamically wraps com.starbase.starteam.EOLFormat.

Public Static Type Conversions

Implicit EOLFormat to EOLFormat Conversion Implicitly convert EOLFormat to com.starbase.starteam.EOLFormat.

Public Instance Constructors

EOLFormat Constructor Construct EOLFormat from com.starbase.starteam.EOLFormat.

Public Instance Properties

Code (inherited from EnumeratedValue) | [read/write] the enum code for this object.
Description (inherited from EnumeratedValue) | [read/write] the description of this object. This may return null.
DisplayName (inherited from EnumeratedValue) | [read]
Enabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
EOL | [read] String
EOLFormatID | [read] int
IsFixed | [read] boolean
SortOrder (inherited from EnumeratedValue) | [read] The sort order of this enumerated value.
Translations (inherited from EnumeratedValue) | [read/write]

Public Instance Methods

Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Equals (inherited from EnumeratedValue) | Delegate Equals() to com.starbase.starteam.EnumeratedValue.
GetHashCode (inherited from EnumeratedValue) | Delegate GetHashCode() to com.starbase.starteam.EnumeratedValue.
GetType (inherited from Object) | Gets the Type of the current instance.
ToPropertyValue | Gets the EOLFormat used as the default value of the FILE_EOL_CHARACTER property for files whose actual EOLFormat is this one. Returns CLIENT_DEFINED if this EOLFormat matches the PLATFORM EOLFormat; otehrwise, returns this EOLFormat itself.
ToString (inherited from EnumeratedValue) | Delegate ToString() to com.starbase.starteam.EnumeratedValue.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

EOLFormat Class | Borland.StarTeam Namespace


EOLFormat Constructor

Construct EOLFormat from com.starbase.starteam.EOLFormat.

public EOLFormat(
EOLFormat impl
);

Parameters

impl
The com.starbase.starteam.EOLFormat to be wrapped.

See Also

EOLFormat Class | Borland.StarTeam Namespace


EOLFormat Properties

The properties of the EOLFormat class are listed below. For a complete list of EOLFormat class members, see the EOLFormat Members topic.

Public Static Properties

ALL
CLIENT_DEFINED
FIXED_CR
FIXED_CRLF
FIXED_LF
PLATFORM

Public Instance Properties

Code (inherited from EnumeratedValue) | [read/write] the enum code for this object.
Description (inherited from EnumeratedValue) | [read/write] the description of this object. This may return null.
DisplayName (inherited from EnumeratedValue) | [read]
Enabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
EOL | [read] String
EOLFormatID | [read] int
IsFixed | [read] boolean
SortOrder (inherited from EnumeratedValue) | [read] The sort order of this enumerated value.
Translations (inherited from EnumeratedValue) | [read/write]

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

EOLFormat Class | Borland.StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

EOLFormat.ALL Property

public static EOLFormatCollection ALL {get;}

See Also

EOLFormat Class | Borland.StarTeam Namespace


CLIENT_DEFINED Property

Borland StarTeam SDK for .NET

EOLFormat.CLIENT_DEFINED Property

public static EOLFormat CLIENT_DEFINED {get;}

See Also

EOLFormat Class | Borland.StarTeam Namespace


EOL Property

Borland StarTeam SDK for .NET

EOLFormat.EOL Property

[read] String

public virtual String EOL {get;}

Property Value

String

See Also

EOLFormat Class | Borland.StarTeam Namespace


EOLFormatID Property

Borland StarTeam SDK for .NET

EOLFormat.EOLFormatID Property

[read] int

public virtual Int32 EOLFormatID {get;}

Property Value

int

See Also

EOLFormat Class | Borland.StarTeam Namespace


FIXED_CR Property

Borland StarTeam SDK for .NET

EOLFormat.FIXED_CR Property

public static EOLFormat FIXED_CR {get;}

See Also

EOLFormat Class | Borland.StarTeam Namespace


FIXED_CRLF Property

Borland StarTeam SDK for .NET

EOLFormat.FIXED_CRLF Property

public static EOLFormat FIXED_CRLF {get;}

See Also

EOLFormat Class | Borland.StarTeam Namespace


FIXED_LF Property

Borland StarTeam SDK for .NET

EOLFormat.FIXED_LF Property

public static EOLFormat FIXED_LF {get;}

See Also

EOLFormat Class | Borland.StarTeam Namespace


IsFixed Property

Borland StarTeam SDK for .NET

EOLFormat.IsFixed Property

[read] boolean

public virtual Boolean IsFixed {get;}

Property Value

boolean

See Also

EOLFormat Class | Borland.StarTeam Namespace


PLATFORM Property

Borland StarTeam SDK for .NET

EOLFormat.PLATFORM Property

public static EOLFormat PLATFORM {get;}

See Also

EOLFormat Class | Borland.StarTeam Namespace


EOLFormat Methods

The methods of the EOLFormat class are listed below. For a complete list of EOLFormat class members, see the EOLFormat Members topic.

Public Static Methods

FromEOL | Determines the EOLFormat whose end-of-line character sequence matches the given one. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.
FromEOLFormatID | Determines the EOLFormat whose end-of-line character sequence matches the given LineReader EOL ID. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.
Wrap | Dynamically wraps com.starbase.starteam.EOLFormat.

Public Instance Methods

Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Equals (inherited from EnumeratedValue) | Delegate Equals() to com.starbase.starteam.EnumeratedValue.
GetHashCode (inherited from EnumeratedValue) | Delegate GetHashCode() to com.starbase.starteam.EnumeratedValue.
GetType (inherited from Object) | Gets the Type of the current instance.
ToPropertyValue | Gets the EOLFormat used as the default value of the FILE_EOL_CHARACTER property for files whose actual EOLFormat is this one. Returns CLIENT_DEFINED if this EOLFormat matches the PLATFORM EOLFormat; otehrwise, returns this EOLFormat itself.
ToString (inherited from EnumeratedValue) | Delegate ToString() to com.starbase.starteam.EnumeratedValue.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

EOLFormat Class | Borland.StarTeam Namespace


EOLFormat.FromEOL Method

Determines the EOLFormat whose end-of-line character sequence matches the given one. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.

public static EOLFormat FromEOL(
String eol
);

Parameters

eol
String

Return Value

EOLFormat

See Also

EOLFormat Class | Borland.StarTeam Namespace | getEOL


EOLFormat.FromEOLFormatID Method

Determines the EOLFormat whose end-of-line character sequence matches the given LineReader EOL ID. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.

public static EOLFormat FromEOLFormatID(
Int32 id
);

Parameters

id
int

Return Value

EOLFormat

See Also

EOLFormat Class | Borland.StarTeam Namespace | getEOLFormatID


EOLFormat.ToPropertyValue Method

Gets the EOLFormat used as the default value of the FILE_EOL_CHARACTER property for files whose actual EOLFormat is this one.

Returns CLIENT_DEFINED if this EOLFormat matches the PLATFORM EOLFormat; otehrwise, returns this EOLFormat itself.

public virtual EOLFormat ToPropertyValue();

Return Value

EOLFormat

See Also

EOLFormat Class | Borland.StarTeam Namespace


EOLFormat.Wrap Method

Dynamically wraps com.starbase.starteam.EOLFormat.

public static EOLFormat Wrap(
EOLFormat impl
);

Parameters

impl
com.starbase.starteam.EOLFormat to be wrapped.

Return Value

EOLFormat

See Also

EOLFormat Class | Borland.StarTeam Namespace


EOLFormat Type Conversions

The type conversions of the EOLFormat class are listed below. For a complete list of EOLFormat class members, see the EOLFormat Members topic.

Public Static Type Conversions

Implicit EOLFormat to EOLFormat Conversion Implicitly convert EOLFormat to com.starbase.starteam.EOLFormat.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

EOLFormat Class | EOLFormat Members | Borland.StarTeam Namespace


EOLFormat Implicit EOLFormat to EOLFormat Conversion

Implicitly convert EOLFormat to com.starbase.starteam.EOLFormat.

public static implicit operator EOLFormat(
EOLFormat arg
);

Parameters

arg
EOLFormat to convert.

Return Value

com.starbase.starteam.EOLFormat

See Also

EOLFormat Class | Borland.StarTeam Namespace


EOLFormatCollection Class

A strongly-typed collection of EOLFormats.

For a list of all members of this type, see EOLFormatCollection Members.

System.Object
ArrayAdapter
EOLFormatCollection

public class EOLFormatCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EOLFormatCollection Members | Borland.StarTeam Namespace


EOLFormatCollection Members

EOLFormatCollection overview

Public Static Methods

Wrap Creates an EOLFormatCollection to represent the given array of EOLFormat (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit EOLFormatCollection to EOLFormat[] Conversion | Converts an EOLFormatCollection to an array of EOLFormats.
Implicit EOLFormatCollection to EOLFormat[] Conversion | Converts an EOLFormatCollection from the Borland.StarTeam namespace to an EOLFormat[] in the com.starbase.starteam namespace.

Public Instance Constructors

EOLFormatCollection Overloaded. Initializes a new instance of the EOLFormatCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the EOLFormat at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an EOLFormat to end of the collection.
Append | Overloaded. Appends the EOLFormats of the given EOLFormatCollection to the end of this EOLFormatCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific EOLFormat.
CopyTo | Copies all of the EOLFormats in the EOLFormatCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific EOLFormat in the collection.
Insert | Inserts an EOLFormat into the collection at the specified position.
Remove | Removes the first occurrence of a specific EOLFormat from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the EOLFormats in this EOLFormatCollection.
Sort | Sorts the EOLFormats in this EOLFormatCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection Constructor

Initializes an instance of the EOLFormatCollection class.

Overload List

Initializes an instance of the EOLFormatCollection class.

public EOLFormatCollection();

Initializes an instance of the an EOLFormatCollection class, copying the given array.

public EOLFormatCollection(EOLFormat[]);

Initializes an instance of the an EOLFormatCollection class, copying the given collection.

public EOLFormatCollection(EOLFormatCollection);

Initializes an instance of the an EOLFormatCollection class, wrapping the given array of EOLFormat (from the com.starbase.starteam namespace).

public EOLFormatCollection(EOLFormat[]);

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection Constructor ()

Initializes an instance of the EOLFormatCollection class.

public EOLFormatCollection();

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace | EOLFormatCollection Constructor Overload List


EOLFormatCollection Constructor (EOLFormat[])

Initializes an instance of the an EOLFormatCollection class, wrapping the given array of EOLFormat (from the com.starbase.starteam namespace).

public EOLFormatCollection(
EOLFormat[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace | EOLFormatCollection Constructor Overload List | Wrap


EOLFormatCollection Constructor (EOLFormatCollection)

Initializes an instance of the an EOLFormatCollection class, copying the given collection.

public EOLFormatCollection(
EOLFormatCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member EOLFormat objects of the original collection are shared, not copied.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace | EOLFormatCollection Constructor Overload List


EOLFormatCollection Constructor (EOLFormat[])

Initializes an instance of the an EOLFormatCollection class, copying the given array.

public EOLFormatCollection(
EOLFormat[] array
);

Parameters

array
The array to be copied.

Remarks

The member EOLFormat objects of the original array are shared, not copied.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace | EOLFormatCollection Constructor Overload List


EOLFormatCollection Properties

The properties of the EOLFormatCollection class are listed below. For a complete list of EOLFormatCollection class members, see the EOLFormatCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the EOLFormat at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

EOLFormatCollection.Item Property

Gets or sets the EOLFormat at the specified index.

public EOLFormat this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the EOLFormat to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection Methods

The methods of the EOLFormatCollection class are listed below. For a complete list of EOLFormatCollection class members, see the EOLFormatCollection Members topic.

Public Static Methods

Wrap Creates an EOLFormatCollection to represent the given array of EOLFormat (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds an EOLFormat to end of the collection.
Append | Overloaded. Appends the EOLFormats of the given EOLFormatCollection to the end of this EOLFormatCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific EOLFormat.
CopyTo | Copies all of the EOLFormats in the EOLFormatCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific EOLFormat in the collection.
Insert | Inserts an EOLFormat into the collection at the specified position.
Remove | Removes the first occurrence of a specific EOLFormat from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the EOLFormats in this EOLFormatCollection.
Sort | Sorts the EOLFormats in this EOLFormatCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection.Add Method

Adds an EOLFormat to end of the collection.

public int Add(
EOLFormat value
);

Parameters

value
The EOLFormat to add to the collection.

Return Value

The position into which the new EOLFormat was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

EOLFormatCollection.Append Method

Appends the EOLFormats of the given array to the end of this EOLFormatCollection.

Overload List

Appends the EOLFormats of the given array to the end of this EOLFormatCollection.

public EOLFormatCollection Append(EOLFormat[]);

Appends the EOLFormats of the given EOLFormatCollection to the end of this EOLFormatCollection.

public EOLFormatCollection Append(EOLFormatCollection);

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection.Append Method (EOLFormat[])

Appends the EOLFormats of the given array to the end of this EOLFormatCollection.

public EOLFormatCollection Append(
EOLFormat[] array
);

Parameters

array
The array whose EOLFormats are to be appended to this EOLFormatCollection.

Return Value

This EOLFormatCollection, modified to include the new EOLFormats.

Remarks

The EOLFormatCollection is modified to include the new members. The individual EOLFormat objects are shared, not copied.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace | EOLFormatCollection.Append Overload List


EOLFormatCollection.Append Method (EOLFormatCollection)

Appends the EOLFormats of the given EOLFormatCollection to the end of this EOLFormatCollection.

public EOLFormatCollection Append(
EOLFormatCollection collection
);

Parameters

collection
The EOLFormatCollection whose EOLFormats are to be appended to this EOLFormatCollection.

Return Value

This EOLFormatCollection, modified to include the new EOLFormats.

Remarks

The EOLFormatCollection is modified to include the new members. The individual EOLFormat objects are shared, not copied.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace | EOLFormatCollection.Append Overload List


EOLFormatCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.EOLFormat[].

Implements

IWrapper.Unwrap

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection.Contains Method

Determines whether or not the collection contains a specific EOLFormat.

public bool Contains(
EOLFormat value
);

Parameters

value
The EOLFormat to locate in the collection.

Return Value

true if the EOLFormat is found in the collection; otherwise, false.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection.CopyTo Method

Copies all of the EOLFormats in the EOLFormatCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
EOLFormat[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the EOLFormats copied from the EOLFormatCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of EOLFormats in the source EOLFormatCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source EOLFormatCollection cannot be cast automatically to the type of the destination array.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection.IndexOf Method

Determines the index of a specific EOLFormat in the collection.

public int IndexOf(
EOLFormat value
);

Parameters

value
The EOLFormat to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection.Insert Method

Inserts an EOLFormat into the collection at the specified position.

public void Insert(
Int32 index,
EOLFormat value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The EOLFormat to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection.Remove Method

Removes the first occurrence of a specific EOLFormat from the collection.

public void Remove(
EOLFormat value
);

Parameters

value
The EOLFormat to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection.Reverse Method

Reverses the order of the EOLFormats in this EOLFormatCollection.

new public EOLFormatCollection Reverse();

Return Value

This EOLFormatCollection, modified such that the EOLFormats are reversed.

Remarks

The EOLFormatCollection is modified in place.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection.Sort Method

Sorts the EOLFormats in this EOLFormatCollection, using the given comparer.

new public EOLFormatCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two EOLFormats.

Return Value

This EOLFormatCollection, modified such that the EOLFormats are sorted.

Remarks

The EOLFormatCollection is modified in place.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection.Wrap Method

Creates an EOLFormatCollection to represent the given array of EOLFormat (from the com.starbase.starteam namespace).

public static EOLFormatCollection Wrap(
EOLFormat[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new EOLFormatCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an EOLFormat[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection Type Conversions

The type conversions of the EOLFormatCollection class are listed below. For a complete list of EOLFormatCollection class members, see the EOLFormatCollection Members topic.

Public Static Type Conversions

Implicit EOLFormatCollection to EOLFormat[] Conversion | Converts an EOLFormatCollection to an array of EOLFormats.
Implicit EOLFormatCollection to EOLFormat[] Conversion | Converts an EOLFormatCollection from the Borland.StarTeam namespace to an EOLFormat[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

EOLFormatCollection Class | EOLFormatCollection Members | Borland.StarTeam Namespace


EOLFormatCollection Implicit EOLFormatCollection to EOLFormat[] Conversion

Converts an EOLFormatCollection to an array of EOLFormats.

public static implicit operator EOLFormat[](
EOLFormatCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new EOLFormat wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one EOLFormat wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EOLFormatCollection Implicit EOLFormatCollection to EOLFormat[] Conversion

Converts an EOLFormatCollection from the Borland.StarTeam namespace to an EOLFormat[] in the com.starbase.starteam namespace.

public static implicit operator EOLFormat[](
EOLFormatCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, EOLFormatCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

EOLFormatCollection Class | Borland.StarTeam Namespace


EventHandlerInfo Class

The EventHandlerInfo class describes a registered event handler, such as the one for the StarTeam MPX Server.

For a list of all members of this type, see EventHandlerInfo Members.

System.Object
EventHandlerInfo

public class EventHandlerInfo : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EventHandlerInfo Members | Borland.StarTeam Namespace


EventHandlerInfo Members

EventHandlerInfo overview

Public Static Properties

MPX_TRANSMITTER

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.EventHandlerInfo.

Public Static Type Conversions

Implicit EventHandlerInfo to EventHandlerInfo Conversion Implicitly convert EventHandlerInfo to com.starbase.starteam.EventHandlerInfo.

Public Instance Constructors

EventHandlerInfo Constructor Construct EventHandlerInfo from com.starbase.starteam.EventHandlerInfo.

Public Instance Properties

Description | [read/write] The description of this EventHandlerInfo.
Name | [read] The name of this EventHandlerInfo.
ProfileNames | [read] an array containing the names of all existing EventHandlerProfiles of this EventHandlerInfo
PropertyNames | [read] The names of all existing properties of this EventHandlerInfo.

Public Instance Methods

AddProfile | Add an EventHandlerProfile to this EventHandlerInfo object.
DeleteProfile | Remove an EventHandlerProfile from this EventHandlerInfo object.
Equals | Delegate Equals() to com.starbase.starteam.EventHandlerInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.EventHandlerInfo.
GetProfile | Returns the specified EventHandlerProfile object. If no such EventhandlerProfile exist, a null is returned.
GetProperty | Gets the value of a named property.
GetType (inherited from Object) | Gets the Type of the current instance.
PutProperty | Sets the value of the named property.
RemoveProperty | Removes the named property.
ToString | Delegate ToString() to com.starbase.starteam.EventHandlerInfo.
Update | Stores the existing EventHandlerInfo in the server.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo Constructor

Construct EventHandlerInfo from com.starbase.starteam.EventHandlerInfo.

public EventHandlerInfo(
EventHandlerInfo impl
);

Parameters

impl
The com.starbase.starteam.EventHandlerInfo to be wrapped.

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo Properties

The properties of the EventHandlerInfo class are listed below. For a complete list of EventHandlerInfo class members, see the EventHandlerInfo Members topic.

Public Static Properties

MPX_TRANSMITTER

Public Instance Properties

Description | [read/write] The description of this EventHandlerInfo.
Name | [read] The name of this EventHandlerInfo.
ProfileNames | [read] an array containing the names of all existing EventHandlerProfiles of this EventHandlerInfo
PropertyNames | [read] The names of all existing properties of this EventHandlerInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

EventHandlerInfo.Description Property

[read/write] The description of this EventHandlerInfo.

public virtual String Description {get; set;}

Property Value

The description of this EventHandlerInfo.

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


MPX_TRANSMITTER Property

Borland StarTeam SDK for .NET

EventHandlerInfo.MPX_TRANSMITTER Property

public static String MPX_TRANSMITTER {get;}

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

EventHandlerInfo.Name Property

[read] The name of this EventHandlerInfo.

public virtual String Name {get;}

Property Value

The name of this EventHandlerInfo.

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


ProfileNames Property

Borland StarTeam SDK for .NET

EventHandlerInfo.ProfileNames Property

[read] an array containing the names of all existing EventHandlerProfiles of this EventHandlerInfo

public virtual String[] ProfileNames {get;}

Property Value

an array containing the names of all existing EventHandlerProfiles of this EventHandlerInfo

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


PropertyNames Property

Borland StarTeam SDK for .NET

EventHandlerInfo.PropertyNames Property

[read] The names of all existing properties of this EventHandlerInfo.

public virtual String[] PropertyNames {get;}

Property Value

The names of all existing properties of this EventHandlerInfo.

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo Methods

The methods of the EventHandlerInfo class are listed below. For a complete list of EventHandlerInfo class members, see the EventHandlerInfo Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.EventHandlerInfo.

Public Instance Methods

AddProfile | Add an EventHandlerProfile to this EventHandlerInfo object.
DeleteProfile | Remove an EventHandlerProfile from this EventHandlerInfo object.
Equals | Delegate Equals() to com.starbase.starteam.EventHandlerInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.EventHandlerInfo.
GetProfile | Returns the specified EventHandlerProfile object. If no such EventhandlerProfile exist, a null is returned.
GetProperty | Gets the value of a named property.
GetType (inherited from Object) | Gets the Type of the current instance.
PutProperty | Sets the value of the named property.
RemoveProperty | Removes the named property.
ToString | Delegate ToString() to com.starbase.starteam.EventHandlerInfo.
Update | Stores the existing EventHandlerInfo in the server.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo.AddProfile Method

Add an EventHandlerProfile to this EventHandlerInfo object.

public virtual void AddProfile(
EventHandlerProfile profile
);

Parameters

profile
the EventHandlerProfile to be added.

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.EventHandlerInfo

Implements

IWrapper.Unwrap

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo.DeleteProfile Method

Remove an EventHandlerProfile from this EventHandlerInfo object.

public virtual void DeleteProfile(
EventHandlerProfile profile
);

Parameters

profile
the EventHandlerProfile to be removed.

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo.Equals Method

Delegate Equals() to com.starbase.starteam.EventHandlerInfo.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.EventHandlerInfo.Equals(obj).

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.EventHandlerInfo.

public override int GetHashCode();

Return Value

com.starbase.starteam.EventHandlerInfo.GetHashCode().

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo.GetProfile Method

Returns the specified EventHandlerProfile object. If no such EventhandlerProfile exist, a null is returned.

public virtual EventHandlerProfile GetProfile(
String profileName
);

Parameters

profileName
the name of the EventHandlerInfo object to be returned

Return Value

the specified EventHandlerProfile object. If no such EventhandlerProfile exist, a null is returned.

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace | getProfileNames


EventHandlerInfo.GetProperty Method

Gets the value of a named property.

public virtual object GetProperty(
String propertyName
);

Parameters

propertyName
The name of the property.

Return Value

The value of the named property.

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace | getPropertyNames


EventHandlerInfo.PutProperty Method

Sets the value of the named property.

public virtual object PutProperty(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property.
value

Return Value

the old value of the named property.

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace | getPropertyNames


EventHandlerInfo.RemoveProperty Method

Removes the named property.

public virtual object RemoveProperty(
String propertyName
);

Parameters

propertyName
the name of the property.

Return Value

the old value of the named property.

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace | getPropertyNames


EventHandlerInfo.ToString Method

Delegate ToString() to com.starbase.starteam.EventHandlerInfo.

public override string ToString();

Return Value

com.starbase.starteam.EventHandlerInfo.ToString()

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo.Update Method

Stores the existing EventHandlerInfo in the server.

public virtual void Update();

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo.Wrap Method

Dynamically wraps com.starbase.starteam.EventHandlerInfo.

public static EventHandlerInfo Wrap(
EventHandlerInfo impl
);

Parameters

impl
com.starbase.starteam.EventHandlerInfo to be wrapped.

Return Value

EventHandlerInfo

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerInfo Type Conversions

The type conversions of the EventHandlerInfo class are listed below. For a complete list of EventHandlerInfo class members, see the EventHandlerInfo Members topic.

Public Static Type Conversions

Implicit EventHandlerInfo to EventHandlerInfo Conversion Implicitly convert EventHandlerInfo to com.starbase.starteam.EventHandlerInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EventHandlerInfo Class | EventHandlerInfo Members | Borland.StarTeam Namespace


EventHandlerInfo Implicit EventHandlerInfo to EventHandlerInfo Conversion

Implicitly convert EventHandlerInfo to com.starbase.starteam.EventHandlerInfo.

public static implicit operator EventHandlerInfo(
EventHandlerInfo arg
);

Parameters

arg
EventHandlerInfo to convert.

Return Value

com.starbase.starteam.EventHandlerInfo

See Also

EventHandlerInfo Class | Borland.StarTeam Namespace


EventHandlerProfile Class

The EventHandlerProfile class contains the information of one of profiles of an EventHandlerInfo.

For a list of all members of this type, see EventHandlerProfile Members.

System.Object
EventHandlerProfile

public class EventHandlerProfile : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EventHandlerProfile Members | Borland.StarTeam Namespace


EventHandlerProfile Members

EventHandlerProfile overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.EventHandlerProfile.

Public Static Type Conversions

Implicit EventHandlerProfile to EventHandlerProfile Conversion Implicitly convert EventHandlerProfile to com.starbase.starteam.EventHandlerProfile.

Public Instance Constructors

EventHandlerProfile Overloaded. Initializes a new instance of the EventHandlerProfile class.

Public Instance Properties

Description | [read/write] The description of this EventHandlerProfile.
Name | [read] The name of this EventHandlerProfile.
PropertyNames | [read] The names of all existing properties of this EventHandlerProfile.

Public Instance Methods

Copy | Creates a copy of this EventHandlerProfile. Copies the Name, Description, all the individual properties, and their associated values.
Equals | Delegate Equals() to com.starbase.starteam.EventHandlerProfile.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.EventHandlerProfile.
GetProperty | Gets the value of the named property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two EventHandlerProfile objects. Compares the Name, Description, all the individual properties, and their associated values.
PutProperty | Sets the value of the named property.
RemoveProperty | Removes the named property.
ToString | Delegate ToString() to com.starbase.starteam.EventHandlerProfile.
Update | Stores the existing EventHandlerProfile in the server. If the EventHandlerProfile is new, EventHandlerInfo.addProfile() should be called instead.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


EventHandlerProfile Constructor

Construct EventHandlerProfile from com.starbase.starteam.EventHandlerProfile.

Overload List

Construct EventHandlerProfile from com.starbase.starteam.EventHandlerProfile.

public EventHandlerProfile(EventHandlerProfile);

Constructs a new Event Handler Profile object. The object returned needs to be added to an EventHandlerInfo by calling EventHandlerInfo.addProfile() before being stored.

public EventHandlerProfile(String,String);

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


EventHandlerProfile Constructor (EventHandlerProfile)

Construct EventHandlerProfile from com.starbase.starteam.EventHandlerProfile.

public EventHandlerProfile(
EventHandlerProfile impl
);

Parameters

impl
The com.starbase.starteam.EventHandlerProfile to be wrapped.

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace | EventHandlerProfile Constructor Overload List


EventHandlerProfile Constructor (String, String)

Constructs a new Event Handler Profile object. The object returned needs to be added to an EventHandlerInfo by calling EventHandlerInfo.addProfile() before being stored.

public EventHandlerProfile(
String name,
String description
);

Parameters

name
the name of the profile
description
the description of the profile

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace | EventHandlerProfile Constructor Overload List | addProfile


EventHandlerProfile Properties

The properties of the EventHandlerProfile class are listed below. For a complete list of EventHandlerProfile class members, see the EventHandlerProfile Members topic.

Public Instance Properties

Description | [read/write] The description of this EventHandlerProfile.
Name | [read] The name of this EventHandlerProfile.
PropertyNames | [read] The names of all existing properties of this EventHandlerProfile.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

EventHandlerProfile.Description Property

[read/write] The description of this EventHandlerProfile.

public virtual String Description {get; set;}

Property Value

The description of this EventHandlerProfile.

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

EventHandlerProfile.Name Property

[read] The name of this EventHandlerProfile.

public virtual String Name {get;}

Property Value

The name of this EventHandlerProfile.

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


PropertyNames Property

Borland StarTeam SDK for .NET

EventHandlerProfile.PropertyNames Property

[read] The names of all existing properties of this EventHandlerProfile.

public virtual String[] PropertyNames {get;}

Property Value

The names of all existing properties of this EventHandlerProfile.

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


EventHandlerProfile Methods

The methods of the EventHandlerProfile class are listed below. For a complete list of EventHandlerProfile class members, see the EventHandlerProfile Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.EventHandlerProfile.

Public Instance Methods

Copy | Creates a copy of this EventHandlerProfile. Copies the Name, Description, all the individual properties, and their associated values.
Equals | Delegate Equals() to com.starbase.starteam.EventHandlerProfile.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.EventHandlerProfile.
GetProperty | Gets the value of the named property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two EventHandlerProfile objects. Compares the Name, Description, all the individual properties, and their associated values.
PutProperty | Sets the value of the named property.
RemoveProperty | Removes the named property.
ToString | Delegate ToString() to com.starbase.starteam.EventHandlerProfile.
Update | Stores the existing EventHandlerProfile in the server. If the EventHandlerProfile is new, EventHandlerInfo.addProfile() should be called instead.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


EventHandlerProfile.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.EventHandlerProfile

Implements

IWrapper.Unwrap

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


EventHandlerProfile.Copy Method

Creates a copy of this EventHandlerProfile. Copies the Name, Description, all the individual properties, and their associated values.

public virtual EventHandlerProfile Copy();

Return Value

A new copy of this EventHandlerProfile.

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace | isEqualTo


EventHandlerProfile.Equals Method

Delegate Equals() to com.starbase.starteam.EventHandlerProfile.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.EventHandlerProfile.Equals(obj).

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


EventHandlerProfile.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.EventHandlerProfile.

public override int GetHashCode();

Return Value

com.starbase.starteam.EventHandlerProfile.GetHashCode().

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


EventHandlerProfile.GetProperty Method

Gets the value of the named property.

public virtual object GetProperty(
String propertyName
);

Parameters

propertyName
The name of the property.

Return Value

The value of the named property.

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace | getPropertyNames


EventHandlerProfile.IsEqualTo Method

Compares two EventHandlerProfile objects. Compares the Name, Description, all the individual properties, and their associated values.

public virtual bool IsEqualTo(
EventHandlerProfile p
);

Parameters

p
The EventHandlerProfile object to be compared to this one.

Return Value

true if no differences were found.

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace | copy


EventHandlerProfile.PutProperty Method

Sets the value of the named property.

public virtual object PutProperty(
String propertyName,
Object value
);

Parameters

propertyName
The name of the property.
value
The new value of the property.

Return Value

The old value of the named property.

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace | getPropertyNames


EventHandlerProfile.RemoveProperty Method

Removes the named property.

public virtual object RemoveProperty(
String propertyName
);

Parameters

propertyName
The name of the property.

Return Value

The old value of the named property.

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace | getPropertyNames


EventHandlerProfile.ToString Method

Delegate ToString() to com.starbase.starteam.EventHandlerProfile.

public override string ToString();

Return Value

com.starbase.starteam.EventHandlerProfile.ToString()

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


EventHandlerProfile.Update Method

Stores the existing EventHandlerProfile in the server. If the EventHandlerProfile is new, EventHandlerInfo.addProfile() should be called instead.

public virtual void Update();

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace | addProfile


EventHandlerProfile.Wrap Method

Dynamically wraps com.starbase.starteam.EventHandlerProfile.

public static EventHandlerProfile Wrap(
EventHandlerProfile impl
);

Parameters

impl
com.starbase.starteam.EventHandlerProfile to be wrapped.

Return Value

EventHandlerProfile

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


EventHandlerProfile Type Conversions

The type conversions of the EventHandlerProfile class are listed below. For a complete list of EventHandlerProfile class members, see the EventHandlerProfile Members topic.

Public Static Type Conversions

Implicit EventHandlerProfile to EventHandlerProfile Conversion Implicitly convert EventHandlerProfile to com.starbase.starteam.EventHandlerProfile.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EventHandlerProfile Class | EventHandlerProfile Members | Borland.StarTeam Namespace


EventHandlerProfile Implicit EventHandlerProfile to EventHandlerProfile Conversion

Implicitly convert EventHandlerProfile to com.starbase.starteam.EventHandlerProfile.

public static implicit operator EventHandlerProfile(
EventHandlerProfile arg
);

Parameters

arg
EventHandlerProfile to convert.

Return Value

com.starbase.starteam.EventHandlerProfile

See Also

EventHandlerProfile Class | Borland.StarTeam Namespace


File Class

Represents a StarTeam File item.

For a list of all members of this type, see File Members.

System.Object
TypedResource
SimpleTypedResource
Item
File

public class File : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

File Members | Borland.StarTeam Namespace


File Members

File overview

Public Static Methods

IsInSyncByMD5 | Determines whether or not the given file has the MD5 signature indicated in the given FileSyncInfo record.
IsInSyncByTime | Determines whether or not the given file has the size and last modified date indicated in the given FileSyncInfo record.
Wrap | Dynamically wraps com.starbase.starteam.File.

Public Static Type Conversions

Implicit File to File Conversion Implicitly convert File to com.starbase.starteam.File.

Public Instance Constructors

File Overloaded. Initializes a new instance of the File class.

Public Instance Properties

ACL (inherited from Item) |
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
ArchiveFormat | [read] the vault archive format for this file
ArchiveName | [read] the name of the archive for this file
ArchiveType | [read] the vault archive type for this file
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
BlankKeywords | [read] an array of blank StarTeam keywords
CachedProperties (inherited from Item) | [read] Property[]
CharacterSet | [read/write] the Character Encoding that determine this file content or NULL if none has been specified
Charset | [read] The character set enumerated value for this file.
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
Compression | [read/write] The enumerated value for this file's compression level in the repository.
ContentModificationTime | [read/write] the "last modified" timestamp of the working file when this revision was checked in
ContentVersion | [read] the content version number for this file
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
Description | [read/write] the description of this file
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
EOLFormat | [read/write] The end-of-line format, or null if it has not yet been initialized.
Extension | [read] the file name extension.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
FullName | [read] the local file path to this file
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBinary | [read] true if this repository file has been determined to be binary
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
IsUnicode | [read] true if this repository file has been determined to be unicode
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
LastKnownStatus | [read] The status code for this file
LastKnownVersionOnDisk | [read] the view version of the last known version of this file on disk
LocalFileExecutable | [read] true if the local file is executable.
LocalFileExists | [read] true if the local file exists on disk.
LocalName | [read] the local file name, as recognized by the local file system.
LocalPath | [read] the local path, as recognized by the local file system.
LocalSize | [read] the local file's size.
LocalSizeEx | [read] the local file's size.
LocalTimeStamp | [read] the local file's time stamp.
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MD5 | [read] the MD5 has bytes of the repository contents of this file
MergeHistory (inherited from Item) | [read]
MergeVersion | [read] the most recent common ancestor of this file and the last known version of this file on disk.
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
Name | [read/write] the name of this file
NewRevisionComment (inherited from Item) | [read] the empty string.
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
PossibleArchiveFormat | [read] The possible values for the ArchiveFormat property.
PossibleArchiveType | [read] The possible values for the ArchiveType property.
PossibleCharset | [read] The possible values for the Charset property.
PossibleCompression | [read] The possible values for the Compression property.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PossibleStorageFormat | [read] The possible values for the StorageFormat property.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Size | [read] the size of this file in the repository
SizeEx | [read] the size of this file in the repository
SmartStatus | [read] The current status of this file.
Status | [read] The current status of this file.
StatusKnown | [read]
StatusNow | [read] this file's status
StorageFormat | [read/write] The storage format enumerated value for this file.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
UsesKeywords | [read] true if this file uses keyword expansion
VaultVersion | [read] the vault version number for this file
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.

Public Instance Methods

AcquireOwnership (inherited from Item)
Add | Overloaded. Adds this (new) file to the project/view.
AddAndReturn | Overloaded. Adds this (new) file to the project/view.
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddFromStream | Overloaded. Adds a new file to the repository using the provided stream's file contents.
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Checkin | Overloaded. Check in this File using the specified options
CheckinFrom | Overloaded. Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.
CheckinFromAndReturn | Overloaded. Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.
CheckinFromStream | Overloaded. Adds this new version of the file to the repository. The contents of the file revision are obtained from the provided input stream.
Checkout | Overloaded. Check out this File using the specified options.
CheckoutByDate | Check out by date, overriding the default working file location. You can pass null for file and it will check out to the default location.
CheckoutByLabelID | Check out by label, overriding the default working file location. You can pass null for file and it will check out to the default location.
CheckoutByVersion | Check out by view version, overriding the default working file location. You can pass null for file and it will check out to the default location.
CheckoutTo | Check out the tip version, overriding the working file location. You can pass null for file and it will check out to the default location.
CheckoutToAndReturn | Check out the tip version, obyverriding the working file location. You can pass null for file and it will check out to the default location.
CheckoutToStream | Checks out the tip version of this file and write it to the specified stream.
ConvertArchive | This method causes the server to convert all versions stored in the archives associated with the file to the storage parameters specified. This can not be called for a not-in-view file (an exception will be thrown). A new file revision will be created. Note that archive conversion is irreversible in the sense that the archive cannot be restored to its original state if it contained versions using mixed storage options. Note also that the archive conversion may be a fairly long operation depending on the number and size of versions stored in the archive files.
ConvertToNativeIIArchive | Convert this File's archives to Native II format. Available starting with server release 7.0; ignored for earlier releases.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
DeleteLocalFile | Deletes the specified local file and has the side effect of deleting sync information from the server about the file.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
DeleteSyncInfo | Removes sync information from this File object's Server. Once it has been called the Status for file will be unknown. Use with caution.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
FindCommonAnscestor | Returns the most recent common ancestor of this file with the specified file. The common version is taken from this file's history. It may return null if no common version was found.
Get (inherited from TypedResource) | Return the value for the specified property.
GetArchiveFormatDisplayName | Returns a user-friendly display name for the given ArchiveFormat value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetArchiveTypeDisplayName | Returns a user-friendly display name for the given ArchiveType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCharsetDisplayName | Returns a user-friendly display name for the given Charset value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetCompressionDisplayName | Returns a user-friendly display name for the given Compression value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFileSyncInfo | Attempts to determine what version of the file is actually on disk. This method is similar to resyncStatus, except that the status information is returned to the caller, rather than being cached with the Server object. This is useful for server-based applications running on behalf of a remote client, when running against a StarTeam server that supports client-managed status.
GetFileSyncInfoEx | Attempts to determine what version of the file is actually on disk. This method is similar to resyncStatus, except that the status information is returned to the caller, rather than being cached with the Server object. This is useful for server-based applications running on behalf of a remote client, when running against a StarTeam server that supports client-managed status.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetSmartStatus | Gets the status of the given working file relative to the latest version of this file in the repository. Status is determined by comparing the current size and last modified time with that of the last known version on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.
GetStatus | Gets the status of the given working file relative to the latest version of this file in the repository. Status is determined by comparing the current size and last modified time with that of the last known version on disk.
GetStatusByMD5 | Returns the status of the default working file relative to the file in the repository, using the given size MD5 signature of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).
GetStatusByTime | Returns the status of the default working file relative to the file in the repository, using the given size and last modified date of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).
GetStatusByTimeEx | Returns the status of the default working file relative to the file in the repository, using the given size and last modified date of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).
GetStorageFormatDisplayName | Returns a user-friendly display name for the given StorageFormat value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveLocalFile | Moves the local file to the specified folder and has the side effect of moving the status information from the original file to the newly created one Deletes the original file and it's status information at the end of the move
MoveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAndDeleteLocal | Removes the file item from its parent folder. Note that a file may be shared in another folder in the same or different view. This method will merely remove the one instance (or shared copy) that the method is called on. In addition, this method will delete the corresponding working file.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
Rename | Renames this file to a new name along with the side effect of changing the corresponding local file's name as well. This method does the same work as update() but also maintains the status information so that the newly renamed file will have the same status it did prior to the renaming. Simply using setName() and update() will not change the local file name consequently status information would be lost. NOTE: in the case where a file already exists with the new name, but it is not the same file as the old one [e.g., on Unix systems where only the case of the filenames differ], the local file will not be renamed, to avoid loss of data for users.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ResyncStatus | Attempts to update the repository information about what version of the file is actually on disk. This method is similar to updateStatus, except that information about the working file is provided explicitly by the caller. The working file itself is not used, and in fact does not need to be accessible. This is useful, for example, if the actual working file resides on a remote client workstation.
ResyncStatusEx | Attempts to update the repository information about what version of the file is actually on disk. This method is similar to updateStatus, except that information about the working file is provided explicitly by the caller. The working file itself is not used, and in fact does not need to be accessible. This is useful, for example, if the actual working file resides on a remote client workstation.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.
UpdateStatus | Overloaded. Attempts to update the repository information about what version of the file is actually on disk. This method will send either the whole file or its MD5 checksum to the server to see if the contents exactly matche any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged. Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".
UpdateStatusAfterMerge | Updates the server's status information to reflect the fact that the local file's contents were derived from this file's contents. You would most commonly want to call this after merging in changes. This file's status will be "Modified" after a call to this method if this file is the tip version of the file.
UpdateStatusFromMD5 | Updates the server's status information to reflect the fact that the local file's content has the given MD5 signature. The file size and last modified date are assumed to be unknown. Any previously specified values will remain unchanged. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
UpdateStatusFromTime | Updates the server's status information to reflect the fact that the local file's content has the given size and last modified date. The MD5 signature is assumed to be unknown, and any previously specified value will remain unchanged. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
UpdateStatusFromTimeEx | Updates the server's status information to reflect the fact that the local file's content has the given size and last modified date. The MD5 signature is assumed to be unknown, and any previously specified value will remain unchanged. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
UpdateStatusInformation | Updates the server's status information to reflect the fact that the local file's content has the given size, last modified date, and MD5 signature. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
UpdateStatusInformationEx | Updates the server's status information to reflect the fact that the local file's content has the given size, last modified date, and MD5 signature. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
UpgradeSyncInfo | Move status records from an old server to the new client managed status information. Returns true if sync information was found and moved locally and false otherwise. This will return false and do nothing if the file is from a newer server that supports client managed status.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

File Class | Borland.StarTeam Namespace


File Constructor

Construct File from com.starbase.starteam.File.

Overload List

Creates a new file instance.

public File(Folder);

Construct File from com.starbase.starteam.File.

public File(File);

See Also

File Class | Borland.StarTeam Namespace


File Constructor (File)

Construct File from com.starbase.starteam.File.

public File(
File impl
);

Parameters

impl
The com.starbase.starteam.File to be wrapped.

See Also

File Class | Borland.StarTeam Namespace | File Constructor Overload List


File Constructor (Folder)

Creates a new file instance.

public File(
Folder parentFolder
);

Parameters

parentFolder
the folder that will contain this file

See Also

File Class | Borland.StarTeam Namespace | File Constructor Overload List


File Properties

The properties of the File class are listed below. For a complete list of File class members, see the File Members topic.

Public Instance Properties

ACL (inherited from Item) |
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
ArchiveFormat | [read] the vault archive format for this file
ArchiveName | [read] the name of the archive for this file
ArchiveType | [read] the vault archive type for this file
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
BlankKeywords | [read] an array of blank StarTeam keywords
CachedProperties (inherited from Item) | [read] Property[]
CharacterSet | [read/write] the Character Encoding that determine this file content or NULL if none has been specified
Charset | [read] The character set enumerated value for this file.
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
Compression | [read/write] The enumerated value for this file's compression level in the repository.
ContentModificationTime | [read/write] the "last modified" timestamp of the working file when this revision was checked in
ContentVersion | [read] the content version number for this file
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
Description | [read/write] the description of this file
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
EOLFormat | [read/write] The end-of-line format, or null if it has not yet been initialized.
Extension | [read] the file name extension.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
FullName | [read] the local file path to this file
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBinary | [read] true if this repository file has been determined to be binary
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
IsUnicode | [read] true if this repository file has been determined to be unicode
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
LastKnownStatus | [read] The status code for this file
LastKnownVersionOnDisk | [read] the view version of the last known version of this file on disk
LocalFileExecutable | [read] true if the local file is executable.
LocalFileExists | [read] true if the local file exists on disk.
LocalName | [read] the local file name, as recognized by the local file system.
LocalPath | [read] the local path, as recognized by the local file system.
LocalSize | [read] the local file's size.
LocalSizeEx | [read] the local file's size.
LocalTimeStamp | [read] the local file's time stamp.
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MD5 | [read] the MD5 has bytes of the repository contents of this file
MergeHistory (inherited from Item) | [read]
MergeVersion | [read] the most recent common ancestor of this file and the last known version of this file on disk.
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
Name | [read/write] the name of this file
NewRevisionComment (inherited from Item) | [read] the empty string.
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
PossibleArchiveFormat | [read] The possible values for the ArchiveFormat property.
PossibleArchiveType | [read] The possible values for the ArchiveType property.
PossibleCharset | [read] The possible values for the Charset property.
PossibleCompression | [read] The possible values for the Compression property.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PossibleStorageFormat | [read] The possible values for the StorageFormat property.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Size | [read] the size of this file in the repository
SizeEx | [read] the size of this file in the repository
SmartStatus | [read] The current status of this file.
Status | [read] The current status of this file.
StatusKnown | [read]
StatusNow | [read] this file's status
StorageFormat | [read/write] The storage format enumerated value for this file.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
UsesKeywords | [read] true if this file uses keyword expansion
VaultVersion | [read] the vault version number for this file
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

File Class | Borland.StarTeam Namespace


ArchiveFormat Property

Borland StarTeam SDK for .NET

File.ArchiveFormat Property

[read] the vault archive format for this file

public virtual Int32 ArchiveFormat {get;}

Property Value

the vault archive format for this file

See Also

File Class | Borland.StarTeam Namespace


ArchiveName Property

Borland StarTeam SDK for .NET

File.ArchiveName Property

[read] the name of the archive for this file

public virtual String ArchiveName {get;}

Property Value

the name of the archive for this file

See Also

File Class | Borland.StarTeam Namespace


ArchiveType Property

Borland StarTeam SDK for .NET

File.ArchiveType Property

[read] the vault archive type for this file

public virtual Int32 ArchiveType {get;}

Property Value

the vault archive type for this file

See Also

File Class | Borland.StarTeam Namespace


BlankKeywords Property

Borland StarTeam SDK for .NET

File.BlankKeywords Property

[read] an array of blank StarTeam keywords

public virtual KeywordCollection BlankKeywords {get;}

Property Value

an array of blank StarTeam keywords

See Also

File Class | Borland.StarTeam Namespace


CharacterSet Property

Borland StarTeam SDK for .NET

File.CharacterSet Property

[read/write] the Character Encoding that determine this file content or NULL if none has been specified

public virtual CharacterSet CharacterSet {get; set;}

Property Value

the Character Encoding that determine this file content or NULL if none has been specified

See Also

File Class | Borland.StarTeam Namespace


Charset Property

Borland StarTeam SDK for .NET

File.Charset Property

[read] The character set enumerated value for this file.

public virtual Int32 Charset {get;}

Property Value

The character set enumerated value for this file.

See Also

File Class | Borland.StarTeam Namespace


Compression Property

Borland StarTeam SDK for .NET

File.Compression Property

[read/write] The enumerated value for this file's compression level in the repository.

public virtual Int32 Compression {get; set;}

Property Value

The enumerated value for this file's compression level in the repository.

See Also

File Class | Borland.StarTeam Namespace


ContentModificationTime Property

Borland StarTeam SDK for .NET

File.ContentModificationTime Property

[read/write] the "last modified" timestamp of the working file when this revision was checked in

public virtual DateTime ContentModificationTime {get; set;}

Property Value

the "last modified" timestamp of the working file when this revision was checked in

See Also

File Class | Borland.StarTeam Namespace


ContentVersion Property

Borland StarTeam SDK for .NET

File.ContentVersion Property

[read] the content version number for this file

public virtual Int32 ContentVersion {get;}

Property Value

the content version number for this file

See Also

File Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

File.Description Property

[read/write] the description of this file

public virtual String Description {get; set;}

Property Value

the description of this file

See Also

File Class | Borland.StarTeam Namespace


EOLFormat Property

Borland StarTeam SDK for .NET

File.EOLFormat Property

[read/write] The end-of-line format, or null if it has not yet been initialized.

public virtual EOLFormat EOLFormat {get; set;}

Property Value

The end-of-line format, or null if it has not yet been initialized.

See Also

File Class | Borland.StarTeam Namespace


Extension Property

Borland StarTeam SDK for .NET

File.Extension Property

[read] the file name extension.

public virtual String Extension {get;}

Property Value

the file name extension.

See Also

File Class | Borland.StarTeam Namespace


FullName Property

Borland StarTeam SDK for .NET

File.FullName Property

[read] the local file path to this file

public virtual String FullName {get;}

Property Value

the local file path to this file

See Also

File Class | Borland.StarTeam Namespace


IsBinary Property

Borland StarTeam SDK for .NET

File.IsBinary Property

[read] true if this repository file has been determined to be binary

public virtual Boolean IsBinary {get;}

Property Value

true if this repository file has been determined to be binary

See Also

File Class | Borland.StarTeam Namespace


IsUnicode Property

Borland StarTeam SDK for .NET

File.IsUnicode Property

[read] true if this repository file has been determined to be unicode

public virtual Boolean IsUnicode {get;}

Property Value

true if this repository file has been determined to be unicode

See Also

File Class | Borland.StarTeam Namespace


LastKnownStatus Property

Borland StarTeam SDK for .NET

File.LastKnownStatus Property

[read] The status code for this file

public virtual Int32 LastKnownStatus {get;}

Property Value

The status code for this file

See Also

File Class | Borland.StarTeam Namespace


LastKnownVersionOnDisk Property

Borland StarTeam SDK for .NET

File.LastKnownVersionOnDisk Property

[read] the view version of the last known version of this file on disk

public virtual Int32 LastKnownVersionOnDisk {get;}

Property Value

the view version of the last known version of this file on disk

See Also

File Class | Borland.StarTeam Namespace


LocalFileExecutable Property

Borland StarTeam SDK for .NET

File.LocalFileExecutable Property

[read] true if the local file is executable.

public virtual Boolean LocalFileExecutable {get;}

Property Value

true if the local file is executable.

See Also

File Class | Borland.StarTeam Namespace


LocalFileExists Property

Borland StarTeam SDK for .NET

File.LocalFileExists Property

[read] true if the local file exists on disk.

public virtual Boolean LocalFileExists {get;}

Property Value

true if the local file exists on disk.

See Also

File Class | Borland.StarTeam Namespace


LocalName Property

Borland StarTeam SDK for .NET

File.LocalName Property

[read] the local file name, as recognized by the local file system.

public virtual String LocalName {get;}

Property Value

the local file name, as recognized by the local file system.

See Also

File Class | Borland.StarTeam Namespace


LocalPath Property

Borland StarTeam SDK for .NET

File.LocalPath Property

[read] the local path, as recognized by the local file system.

public virtual String LocalPath {get;}

Property Value

the local path, as recognized by the local file system.

See Also

File Class | Borland.StarTeam Namespace


LocalSize Property

Borland StarTeam SDK for .NET

File.LocalSize Property

[read] the local file's size.

public virtual Int32 LocalSize {get;}

Property Value

the local file's size.

See Also

File Class | Borland.StarTeam Namespace


LocalSizeEx Property

Borland StarTeam SDK for .NET

File.LocalSizeEx Property

[read] the local file's size.

public virtual Int64 LocalSizeEx {get;}

Property Value

the local file's size.

See Also

File Class | Borland.StarTeam Namespace


LocalTimeStamp Property

Borland StarTeam SDK for .NET

File.LocalTimeStamp Property

[read] the local file's time stamp.

public virtual DateTime LocalTimeStamp {get;}

Property Value

the local file's time stamp.

See Also

File Class | Borland.StarTeam Namespace


MD5 Property

Borland StarTeam SDK for .NET

File.MD5 Property

[read] the MD5 has bytes of the repository contents of this file

public virtual Byte[] MD5 {get;}

Property Value

the MD5 has bytes of the repository contents of this file

See Also

File Class | Borland.StarTeam Namespace


MergeVersion Property

Borland StarTeam SDK for .NET

File.MergeVersion Property

[read] the most recent common ancestor of this file and the last known version of this file on disk.

public virtual File MergeVersion {get;}

Property Value

the most recent common ancestor of this file and the last known version of this file on disk.

See Also

File Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

File.Name Property

[read/write] the name of this file

public virtual String Name {get; set;}

Property Value

the name of this file

See Also

File Class | Borland.StarTeam Namespace


PossibleArchiveFormat Property

Borland StarTeam SDK for .NET

File.PossibleArchiveFormat Property

[read] The possible values for the ArchiveFormat property.

public virtual Int32[] PossibleArchiveFormat {get;}

Property Value

The possible values for the ArchiveFormat property.

See Also

File Class | Borland.StarTeam Namespace


PossibleArchiveType Property

Borland StarTeam SDK for .NET

File.PossibleArchiveType Property

[read] The possible values for the ArchiveType property.

public virtual Int32[] PossibleArchiveType {get;}

Property Value

The possible values for the ArchiveType property.

See Also

File Class | Borland.StarTeam Namespace


PossibleCharset Property

Borland StarTeam SDK for .NET

File.PossibleCharset Property

[read] The possible values for the Charset property.

public virtual Int32[] PossibleCharset {get;}

Property Value

The possible values for the Charset property.

See Also

File Class | Borland.StarTeam Namespace


PossibleCompression Property

Borland StarTeam SDK for .NET

File.PossibleCompression Property

[read] The possible values for the Compression property.

public virtual Int32[] PossibleCompression {get;}

Property Value

The possible values for the Compression property.

See Also

File Class | Borland.StarTeam Namespace


PossibleStorageFormat Property

Borland StarTeam SDK for .NET

File.PossibleStorageFormat Property

[read] The possible values for the StorageFormat property.

public virtual Int32[] PossibleStorageFormat {get;}

Property Value

The possible values for the StorageFormat property.

See Also

File Class | Borland.StarTeam Namespace


Size Property

Borland StarTeam SDK for .NET

File.Size Property

[read] the size of this file in the repository

public virtual Int32 Size {get;}

Property Value

the size of this file in the repository

See Also

File Class | Borland.StarTeam Namespace


SizeEx Property

Borland StarTeam SDK for .NET

File.SizeEx Property

[read] the size of this file in the repository

public virtual Int64 SizeEx {get;}

Property Value

the size of this file in the repository

See Also

File Class | Borland.StarTeam Namespace


SmartStatus Property

Borland StarTeam SDK for .NET

File.SmartStatus Property

[read] The current status of this file.

public virtual Int32 SmartStatus {get;}

Property Value

The current status of this file.

See Also

File Class | Borland.StarTeam Namespace


Status Property

Borland StarTeam SDK for .NET

File.Status Property

[read] The current status of this file.

public virtual Int32 Status {get;}

Property Value

The current status of this file.

See Also

File Class | Borland.StarTeam Namespace


StatusKnown Property

Borland StarTeam SDK for .NET

File.StatusKnown Property

[read]

public virtual Boolean StatusKnown {get;}

See Also

File Class | Borland.StarTeam Namespace


StatusNow Property

Borland StarTeam SDK for .NET

File.StatusNow Property

[read] this file's status

public virtual Int32 StatusNow {get;}

Property Value

this file's status

See Also

File Class | Borland.StarTeam Namespace


StorageFormat Property

Borland StarTeam SDK for .NET

File.StorageFormat Property

[read/write] The storage format enumerated value for this file.

public virtual Int32 StorageFormat {get; set;}

Property Value

The storage format enumerated value for this file.

See Also

File Class | Borland.StarTeam Namespace


UsesKeywords Property

Borland StarTeam SDK for .NET

File.UsesKeywords Property

[read] true if this file uses keyword expansion

public virtual Boolean UsesKeywords {get;}

Property Value

true if this file uses keyword expansion

See Also

File Class | Borland.StarTeam Namespace


VaultVersion Property

Borland StarTeam SDK for .NET

File.VaultVersion Property

[read] the vault version number for this file

public virtual Int32 VaultVersion {get;}

Property Value

the vault version number for this file

See Also

File Class | Borland.StarTeam Namespace


File Methods

The methods of the File class are listed below. For a complete list of File class members, see the File Members topic.

Public Static Methods

IsInSyncByMD5 | Determines whether or not the given file has the MD5 signature indicated in the given FileSyncInfo record.
IsInSyncByTime | Determines whether or not the given file has the size and last modified date indicated in the given FileSyncInfo record.
Wrap | Dynamically wraps com.starbase.starteam.File.

Public Instance Methods

AcquireOwnership (inherited from Item)
Add | Overloaded. Adds this (new) file to the project/view.
AddAndReturn | Overloaded. Adds this (new) file to the project/view.
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddFromStream | Overloaded. Adds a new file to the repository using the provided stream's file contents.
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Checkin | Overloaded. Check in this File using the specified options
CheckinFrom | Overloaded. Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.
CheckinFromAndReturn | Overloaded. Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.
CheckinFromStream | Overloaded. Adds this new version of the file to the repository. The contents of the file revision are obtained from the provided input stream.
Checkout | Overloaded. Check out this File using the specified options.
CheckoutByDate | Check out by date, overriding the default working file location. You can pass null for file and it will check out to the default location.
CheckoutByLabelID | Check out by label, overriding the default working file location. You can pass null for file and it will check out to the default location.
CheckoutByVersion | Check out by view version, overriding the default working file location. You can pass null for file and it will check out to the default location.
CheckoutTo | Check out the tip version, overriding the working file location. You can pass null for file and it will check out to the default location.
CheckoutToAndReturn | Check out the tip version, obyverriding the working file location. You can pass null for file and it will check out to the default location.
CheckoutToStream | Checks out the tip version of this file and write it to the specified stream.
ConvertArchive | This method causes the server to convert all versions stored in the archives associated with the file to the storage parameters specified. This can not be called for a not-in-view file (an exception will be thrown). A new file revision will be created. Note that archive conversion is irreversible in the sense that the archive cannot be restored to its original state if it contained versions using mixed storage options. Note also that the archive conversion may be a fairly long operation depending on the number and size of versions stored in the archive files.
ConvertToNativeIIArchive | Convert this File's archives to Native II format. Available starting with server release 7.0; ignored for earlier releases.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
DeleteLocalFile | Deletes the specified local file and has the side effect of deleting sync information from the server about the file.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
DeleteSyncInfo | Removes sync information from this File object's Server. Once it has been called the Status for file will be unknown. Use with caution.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
FindCommonAnscestor | Returns the most recent common ancestor of this file with the specified file. The common version is taken from this file's history. It may return null if no common version was found.
Get (inherited from TypedResource) | Return the value for the specified property.
GetArchiveFormatDisplayName | Returns a user-friendly display name for the given ArchiveFormat value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetArchiveTypeDisplayName | Returns a user-friendly display name for the given ArchiveType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCharsetDisplayName | Returns a user-friendly display name for the given Charset value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetCompressionDisplayName | Returns a user-friendly display name for the given Compression value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFileSyncInfo | Attempts to determine what version of the file is actually on disk. This method is similar to resyncStatus, except that the status information is returned to the caller, rather than being cached with the Server object. This is useful for server-based applications running on behalf of a remote client, when running against a StarTeam server that supports client-managed status.
GetFileSyncInfoEx | Attempts to determine what version of the file is actually on disk. This method is similar to resyncStatus, except that the status information is returned to the caller, rather than being cached with the Server object. This is useful for server-based applications running on behalf of a remote client, when running against a StarTeam server that supports client-managed status.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetSmartStatus | Gets the status of the given working file relative to the latest version of this file in the repository. Status is determined by comparing the current size and last modified time with that of the last known version on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.
GetStatus | Gets the status of the given working file relative to the latest version of this file in the repository. Status is determined by comparing the current size and last modified time with that of the last known version on disk.
GetStatusByMD5 | Returns the status of the default working file relative to the file in the repository, using the given size MD5 signature of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).
GetStatusByTime | Returns the status of the default working file relative to the file in the repository, using the given size and last modified date of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).
GetStatusByTimeEx | Returns the status of the default working file relative to the file in the repository, using the given size and last modified date of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).
GetStorageFormatDisplayName | Returns a user-friendly display name for the given StorageFormat value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveLocalFile | Moves the local file to the specified folder and has the side effect of moving the status information from the original file to the newly created one Deletes the original file and it's status information at the end of the move
MoveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAndDeleteLocal | Removes the file item from its parent folder. Note that a file may be shared in another folder in the same or different view. This method will merely remove the one instance (or shared copy) that the method is called on. In addition, this method will delete the corresponding working file.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
Rename | Renames this file to a new name along with the side effect of changing the corresponding local file's name as well. This method does the same work as update() but also maintains the status information so that the newly renamed file will have the same status it did prior to the renaming. Simply using setName() and update() will not change the local file name consequently status information would be lost. NOTE: in the case where a file already exists with the new name, but it is not the same file as the old one [e.g., on Unix systems where only the case of the filenames differ], the local file will not be renamed, to avoid loss of data for users.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ResyncStatus | Attempts to update the repository information about what version of the file is actually on disk. This method is similar to updateStatus, except that information about the working file is provided explicitly by the caller. The working file itself is not used, and in fact does not need to be accessible. This is useful, for example, if the actual working file resides on a remote client workstation.
ResyncStatusEx | Attempts to update the repository information about what version of the file is actually on disk. This method is similar to updateStatus, except that information about the working file is provided explicitly by the caller. The working file itself is not used, and in fact does not need to be accessible. This is useful, for example, if the actual working file resides on a remote client workstation.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.
UpdateStatus | Overloaded. Attempts to update the repository information about what version of the file is actually on disk. This method will send either the whole file or its MD5 checksum to the server to see if the contents exactly matche any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged. Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".
UpdateStatusAfterMerge | Updates the server's status information to reflect the fact that the local file's contents were derived from this file's contents. You would most commonly want to call this after merging in changes. This file's status will be "Modified" after a call to this method if this file is the tip version of the file.
UpdateStatusFromMD5 | Updates the server's status information to reflect the fact that the local file's content has the given MD5 signature. The file size and last modified date are assumed to be unknown. Any previously specified values will remain unchanged. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
UpdateStatusFromTime | Updates the server's status information to reflect the fact that the local file's content has the given size and last modified date. The MD5 signature is assumed to be unknown, and any previously specified value will remain unchanged. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
UpdateStatusFromTimeEx | Updates the server's status information to reflect the fact that the local file's content has the given size and last modified date. The MD5 signature is assumed to be unknown, and any previously specified value will remain unchanged. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
UpdateStatusInformation | Updates the server's status information to reflect the fact that the local file's content has the given size, last modified date, and MD5 signature. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
UpdateStatusInformationEx | Updates the server's status information to reflect the fact that the local file's content has the given size, last modified date, and MD5 signature. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
UpgradeSyncInfo | Move status records from an old server to the new client managed status information. Returns true if sync information was found and moved locally and false otherwise. This will return false and do nothing if the file is from a newer server that supports client managed status.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

File Class | Borland.StarTeam Namespace


Add Method

Borland StarTeam SDK for .NET

File.Add Method

Adds this (new) file to the project/view.

Overload List

Adds this (new) file to the project/view.

public virtual void Add(FileInfo,String,String,String,Int32,Boolean);

Adds this (new) file to the project/view.

public virtual void Add(FileInfo,String,String,String,Int32,Boolean,Boolean);

See Also

File Class | Borland.StarTeam Namespace | isDisembodied


File.Add Method (FileInfo, String, String, String, Int32, Boolean)

Adds this (new) file to the project/view.

public virtual void Add(
FileInfo file,
String name,
String desc,
String reason,
Int32 lockStatus,
Boolean updateStatus
);

Parameters

file
the local file whose contents are to be used for this new file
name
the repository name of the file.
desc
the file's decription
reason
the initial checkin reason
lockStatus
the file's lock status once it has been added
updateStatus
if true will have StarTeam remember what file is on disk

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.Add Overload List | isDisembodied


File.Add Method (FileInfo, String, String, String, Int32, Boolean, Boolean)

Adds this (new) file to the project/view.

public virtual void Add(
FileInfo file,
String name,
String desc,
String reason,
Int32 lockStatus,
Boolean eol,
Boolean updateStatus
);

Parameters

file
the local file whose contents are to be used for this new file
name
the repository name of the file.
desc
the file's decription
reason
the initial checkin reason
lockStatus
the file's lock status once it has been added
eol
This parameter is obsolete and ignored. The end-of-line characters of text files are always converted to a canonical format in the repository. To specify the desired end-of-line sequence for the working file, see {@link File#setEOLFormat setEOLFormat}.
updateStatus
if true will have StarTeam remember what file is on disk

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.Add Overload List | isDisembodied


AddAndReturn Method

Borland StarTeam SDK for .NET

File.AddAndReturn Method

Adds this (new) file to the project/view.

Overload List

Adds this (new) file to the project/view.

public virtual AddResult AddAndReturn(FileInfo,String,String,String,Int32,Boolean);

Adds this (new) file to the project/view.

public virtual AddResult AddAndReturn(FileInfo,String,String,String,Int32,Boolean,Boolean);

See Also

File Class | Borland.StarTeam Namespace | isDisembodied


File.AddAndReturn Method (FileInfo, String, String, String, Int32, Boolean)

Adds this (new) file to the project/view.

public virtual AddResult AddAndReturn(
FileInfo file,
String name,
String desc,
String reason,
Int32 lockStatus,
Boolean updateStatus
);

Parameters

file
the local file whose contents are to be used for this new file
name
the repository name of the file.
desc
the file's decription
reason
the initial checkin reason
lockStatus
the file's lock status once it has been added
updateStatus
if true will have StarTeam remember what file is on disk

Return Value

information specific to the result of the add operation

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.AddAndReturn Overload List | isDisembodied


File.AddAndReturn Method (FileInfo, String, String, String, Int32, Boolean, Boolean)

Adds this (new) file to the project/view.

public virtual AddResult AddAndReturn(
FileInfo file,
String name,
String desc,
String reason,
Int32 lockStatus,
Boolean eol,
Boolean updateStatus
);

Parameters

file
the local file whose contents are to be used for this new file
name
the repository name of the file.
desc
the file's decription
reason
the initial checkin reason
lockStatus
the file's lock status once it has been added
eol
This parameter is obsolete and ignored. The end-of-line characters of text files are always converted to a canonical format in the repository. To specify the desired end-of-line sequence for the working file, see {@link File#setEOLFormat setEOLFormat}.
updateStatus
if true will have StarTeam remember what file is on disk

Return Value

information specific to the result of the add operation

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.AddAndReturn Overload List | isDisembodied


AddFromStream Method

Borland StarTeam SDK for .NET

File.AddFromStream Method

Adds a new file to the repository using the provided stream's file contents.

Overload List

Adds a new file to the repository using the provided stream's file contents.

public virtual void AddFromStream(Stream,String,String,String,Int32);

Adds a new file to the repository using the provided stream's file contents.

public virtual void AddFromStream(Stream,String,String,String,Int32,Boolean);

See Also

File Class | Borland.StarTeam Namespace | isDisembodied


File.AddFromStream Method (Stream, String, String, String, Int32)

Adds a new file to the repository using the provided stream's file contents.

public virtual void AddFromStream(
Stream stream,
String fileName,
String description,
String comment,
Int32 lockStatus
);

Parameters

stream
the stream source whose contents are to be used for this new file
fileName
description
comment
lockStatus
the file's lock status once it has been added

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.AddFromStream Overload List | isDisembodied


File.AddFromStream Method (Stream, String, String, String, Int32, Boolean)

Adds a new file to the repository using the provided stream's file contents.

public virtual void AddFromStream(
Stream stream,
String fileName,
String description,
String comment,
Int32 lockStatus,
Boolean eol
);

Parameters

stream
the stream source whose contents are to be used for this new file
fileName
description
comment
lockStatus
the file's lock status once it has been added
eol
This parameter is obsolete and ignored. The end-of-line characters of text files are always converted to a canonical format in the repository. To specify the desired end-of-line sequence for the working file, see {@link File#setEOLFormat setEOLFormat}.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.AddFromStream Overload List | isDisembodied


Checkin Method

Borland StarTeam SDK for .NET

File.Checkin Method

Check in this File using the specified options

Overload List

Check in this File using the specified options

public virtual void Checkin(CheckinOptions);

Check in a new version of this file.

public virtual void Checkin(String,Int32,Boolean,Boolean);

Check in a new version of this file.

public virtual void Checkin(String,Int32,Boolean,Boolean,Boolean);

See Also

File Class | Borland.StarTeam Namespace


File.Checkin Method (CheckinOptions)

Check in this File using the specified options

public virtual void Checkin(
CheckinOptions options
);

Parameters

options
the options to be used to check out this file.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.Checkin Overload List


File.Checkin Method (String, Int32, Boolean, Boolean)

Check in a new version of this file.

public virtual void Checkin(
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean updateStatus
);

Parameters

reason
the checkin reason or comment for this revision
lockStatus
the new lock status for this file
forceCheckin
false if you want the server to throw an exception if the file's status is anything other than "Modified".
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.Checkin Overload List | isDisembodied | Item.LockType | getStatus


File.Checkin Method (String, Int32, Boolean, Boolean, Boolean)

Check in a new version of this file.

public virtual void Checkin(
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean eol,
Boolean updateStatus
);

Parameters

reason
the checkin reason or comment for this revision
lockStatus
the new lock status for this file
forceCheckin
false if you want the server to throw an exception if the file's status is anything other than "Modified".
eol
This parameter is obsolete and ignored. The end-of-line characters of text files are always converted to a canonical format in the repository. To specify the desired end-of-line sequence for the working file, see {@link File#setEOLFormat setEOLFormat}.
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.Checkin Overload List | isDisembodied | Item.LockType | getStatus


CheckinFrom Method

Borland StarTeam SDK for .NET

File.CheckinFrom Method

Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.

Overload List

Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.

public virtual void CheckinFrom(FileInfo,String,Int32,Boolean,Boolean);

Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.

public virtual void CheckinFrom(FileInfo,String,Int32,Boolean,Boolean,Boolean);

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | Item.LockType | getStatus


File.CheckinFrom Method (FileInfo, String, Int32, Boolean, Boolean)

Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.

public virtual void CheckinFrom(
FileInfo file,
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean updateStatus
);

Parameters

file
the location of the file whose contents are used for the new revision of this file
reason
the checkin reason or comment for this revision
lockStatus
the new lock status for this file
forceCheckin
false if you want the server to throw an exception if the file's status is anything other than "Modified".
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.CheckinFrom Overload List | isDisembodied | Item.LockType | getStatus


File.CheckinFrom Method (FileInfo, String, Int32, Boolean, Boolean, Boolean)

Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.

public virtual void CheckinFrom(
FileInfo file,
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean eol,
Boolean updateStatus
);

Parameters

file
the location of the file whose contents are used for the new revision of this file
reason
the checkin reason or comment for this revision
lockStatus
the new lock status for this file
forceCheckin
false if you want the server to throw an exception if the file's status is anything other than "Modified".
eol
This parameter is obsolete and ignored. The end-of-line characters of text files are always converted to a canonical format in the repository. To specify the desired end-of-line sequence for the working file, see {@link File#setEOLFormat setEOLFormat}.
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.CheckinFrom Overload List | isDisembodied | Item.LockType | getStatus


CheckinFromAndReturn Method

Borland StarTeam SDK for .NET

File.CheckinFromAndReturn Method

Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.

Overload List

Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.

public virtual CheckInResult CheckinFromAndReturn(FileInfo,String,Int32,Boolean,Boolean);

Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.

public virtual CheckInResult CheckinFromAndReturn(FileInfo,String,Int32,Boolean,Boolean,Boolean);

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | Item.LockType | getStatus


File.CheckinFromAndReturn Method (FileInfo, String, Int32, Boolean, Boolean)

Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.

public virtual CheckInResult CheckinFromAndReturn(
FileInfo file,
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean updateStatus
);

Parameters

file
the location of the file whose contents are used for the new revision of this file
reason
the checkin reason or comment for this revision
lockStatus
the new lock status for this file
forceCheckin
false if you want the server to throw an exception if the file's status is anything other than "Modified".
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Return Value

information specific to the checkin operation

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.CheckinFromAndReturn Overload List | isDisembodied | Item.LockType | getStatus


File.CheckinFromAndReturn Method (FileInfo, String, Int32, Boolean, Boolean, Boolean)

Adds this new version of the file to the repository. The location of the file contents is explicitly specified, thereby overriding the default location.

public virtual CheckInResult CheckinFromAndReturn(
FileInfo file,
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean eol,
Boolean updateStatus
);

Parameters

file
the location of the file whose contents are used for the new revision of this file
reason
the checkin reason or comment for this revision
lockStatus
the new lock status for this file
forceCheckin
false if you want the server to throw an exception if the file's status is anything other than "Modified".
eol
This parameter is obsolete and ignored. The end-of-line characters of text files are always converted to a canonical format in the repository. To specify the desired end-of-line sequence for the working file, see {@link File#setEOLFormat setEOLFormat}.
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Return Value

information specific to the checkin operation

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.CheckinFromAndReturn Overload List | isDisembodied | Item.LockType | getStatus


CheckinFromStream Method

Borland StarTeam SDK for .NET

File.CheckinFromStream Method

Adds this new version of the file to the repository. The contents of the file revision are obtained from the provided input stream.

Overload List

Adds this new version of the file to the repository. The contents of the file revision are obtained from the provided input stream.

public virtual void CheckinFromStream(Stream,String,Int32);

Adds this new version of the file to the repository. The contents of the file revision are obtained from the provided input stream.

public virtual void CheckinFromStream(Stream,String,Int32,Boolean);

See Also

File Class | Borland.StarTeam Namespace | Item.LockType


File.CheckinFromStream Method (Stream, String, Int32)

Adds this new version of the file to the repository. The contents of the file revision are obtained from the provided input stream.

public virtual void CheckinFromStream(
Stream source,
String checkinReason,
Int32 lockStatus
);

Parameters

source
the source input stream providing the new contents of this file revision
checkinReason
lockStatus
the new lock status for this file

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.CheckinFromStream Overload List | Item.LockType


File.CheckinFromStream Method (Stream, String, Int32, Boolean)

Adds this new version of the file to the repository. The contents of the file revision are obtained from the provided input stream.

public virtual void CheckinFromStream(
Stream source,
String checkinReason,
Int32 lockStatus,
Boolean eol
);

Parameters

source
the source input stream providing the new contents of this file revision
checkinReason
lockStatus
the new lock status for this file
eol
if true will convert all end-of-lines to CRLF (for non-binary files)

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.CheckinFromStream Overload List | Item.LockType


Checkout Method

Borland StarTeam SDK for .NET

File.Checkout Method

Check out this File using the specified options.

Overload List

Check out this File using the specified options.

public virtual void Checkout(CheckoutOptions);

Checks out the tip version of this file.

public virtual void Checkout(Int32,Boolean,Boolean,Boolean);

See Also

File Class | Borland.StarTeam Namespace


File.Checkout Method (CheckoutOptions)

Check out this File using the specified options.

public virtual void Checkout(
CheckoutOptions options
);

Parameters

options
the options to be used to check out this file.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.Checkout Overload List


File.Checkout Method (Int32, Boolean, Boolean, Boolean)

Checks out the tip version of this file.

public virtual void Checkout(
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

Parameters

lockStatus
the new lock status for this file
timeStampNow
if false the local file will be given the same "last modified" time stamp as this revision has when checked in
eol
if true will convert all end-of-lines to your local platforms's end of line convention
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.Checkout Overload List | isDisembodied | Item.LockType | getContentModificationTime | getStatus


File.CheckoutByDate Method

Check out by date, overriding the default working file location. You can pass null for file and it will check out to the default location.

public virtual bool CheckoutByDate(
FileInfo checkoutTo,
DateTime date,
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

Parameters

checkoutTo
the file on disk where the contents will be placed
date
the date specifying which revision to checkout
lockStatus
the new lock status for this file
timeStampNow
if false the local file will be given the same "last modified" time stamp as this revision has when checked in
eol
if true will convert all end-of-lines to your local platforms's end of line convention
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Return Value

false if the date specified was prior to the creation of the file, true otherwise

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | getFromHistoryByDate | Item.LockType | getContentModificationTime | getStatus


File.CheckoutByLabelID Method

Check out by label, overriding the default working file location. You can pass null for file and it will check out to the default location.

public virtual bool CheckoutByLabelID(
FileInfo checkoutTo,
Int32 labelID,
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

Parameters

checkoutTo
the file on disk where the contents will be placed
labelID
the label ID specifying which revision to checkout
lockStatus
the new lock status for this file
timeStampNow
if false the local file will be given the same "last modified" time stamp as this revision has when checked in
eol
if true will convert all end-of-lines to your local platforms's end of line convention
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Return Value

false if no revision had the specified label attached, true otherwise

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | getFromHistoryByLabelID | Item.LockType | getContentModificationTime | getStatus


File.CheckoutByVersion Method

Check out by view version, overriding the default working file location. You can pass null for file and it will check out to the default location.

public virtual bool CheckoutByVersion(
FileInfo checkoutTo,
Int32 viewVersion,
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

Parameters

checkoutTo
the file on disk where the contents will be placed
viewVersion
the view version of the file to check out
lockStatus
the new lock status for this file
timeStampNow
if false the local file will be given the same "last modified" time stamp as this revision has when checked in
eol
if true will convert all end-of-lines to your local platforms's end of line convention
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Return Value

false if the file does not have the specified version, true otherwise

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | getFromHistoryByVersion | Item.LockType | getContentModificationTime | getStatus


File.CheckoutTo Method

Check out the tip version, overriding the working file location. You can pass null for file and it will check out to the default location.

public virtual void CheckoutTo(
FileInfo checkoutTo,
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

Parameters

checkoutTo
the location of where the contents should be checked out to
lockStatus
the new lock status for this file
timeStampNow
if false the local file will be given the same "last modified" time stamp as this revision has when checked in
eol
if true will convert all end-of-lines to your local platforms's end of line convention
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | Item.LockType | getContentModificationTime | getStatus


File.CheckoutToAndReturn Method

Check out the tip version, obyverriding the working file location. You can pass null for file and it will check out to the default location.

public virtual CheckOutResult CheckoutToAndReturn(
FileInfo checkoutTo,
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

Parameters

checkoutTo
the location of where the contents should be checked out to
lockStatus
the new lock status for this file
timeStampNow
if false the local file will be given the same "last modified" time stamp as this revision has when checked in
eol
if true will convert all end-of-lines to your local platforms's end of line convention
updateStatus
if true will have StarTeam remember what version of this file is on your local disk so getStatus() will return the correct value

Return Value

information specific to the checkin operation

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | Item.LockType | getContentModificationTime | getStatus


File.CheckoutToStream Method

Checks out the tip version of this file and write it to the specified stream.

public virtual void CheckoutToStream(
Stream destination,
Int32 lockStatus,
Boolean eol
);

Parameters

destination
the output stream to which the file will be written
lockStatus
the new lock status for this file
eol
if true will convert all end-of-lines to your local platforms's end of line convention

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | Item.LockType


File.ConvertArchive Method

This method causes the server to convert all versions stored in the archives associated with the file to the storage parameters specified. This can not be called for a not-in-view file (an exception will be thrown). A new file revision will be created. Note that archive conversion is irreversible in the sense that the archive cannot be restored to its original state if it contained versions using mixed storage options. Note also that the archive conversion may be a fairly long operation depending on the number and size of versions stored in the archive files.

public virtual void ConvertArchive(
Boolean useDeltaStorage,
Int32 compressionLevel
);

Parameters

useDeltaStorage
true if the archive should use delta storage
compressionLevel
desired compression level. This value must be one of the possible values for the FILE_COMPRESSION_LEVEL enumerated property.

See Also

File Class | Borland.StarTeam Namespace | FILE_COMPRESSION_LEVEL | FILE_COMPRESSION_LEVEL_NONE | FILE_COMPRESSION_LEVEL_MAXIMIZE_SPEED | FILE_COMPRESSION_LEVEL_DEFAULT | FILE_COMPRESSION_LEVEL_MAXIMIZE_COMPRESSION


File.ConvertToNativeIIArchive Method

Convert this File's archives to Native II format. Available starting with server release 7.0; ignored for earlier releases.

public virtual void ConvertToNativeIIArchive(
Boolean bDeleteOldArchives
);

Parameters

bDeleteOldArchives
True if old archives should be deleted, otherwise false.

See Also

File Class | Borland.StarTeam Namespace


File.DeleteLocalFile Method

Deletes the specified local file and has the side effect of deleting sync information from the server about the file.

public virtual bool DeleteLocalFile(
FileInfo file
);

Parameters

file
the local file to delete

Return Value

true if the file was deleted and false otherwise

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | isDisembodied


File.DeleteSyncInfo Method

Removes sync information from this File object's Server. Once it has been called the Status for file will be unknown. Use with caution.

public virtual void DeleteSyncInfo(
FileInfo file
);

Parameters

file
the local file for which to delete status information

See Also

File Class | Borland.StarTeam Namespace | isDisembodied


File.FindCommonAnscestor Method

Returns the most recent common ancestor of this file with the specified file. The common version is taken from this file's history. It may return null if no common version was found.

public virtual File FindCommonAnscestor(
File other
);

Parameters

other
the file for which a common ancestor of this file is to be found

Return Value

the most recent common ancestor of this file and the specified file.

See Also

File Class | Borland.StarTeam Namespace | getCommonAncestor


File.GetArchiveFormatDisplayName Method

Returns a user-friendly display name for the given ArchiveFormat value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetArchiveFormatDisplayName(
Int32 value
);

Parameters

value
The ArchiveFormat value to be converted to a display name.

Return Value

A user-friendly display name for the given ArchiveFormat value.

See Also

File Class | Borland.StarTeam Namespace | getArchiveFormat | getPossibleArchiveFormat | getEnumDisplayName | FILE_ARCHIVE_FORMAT


File.GetArchiveTypeDisplayName Method

Returns a user-friendly display name for the given ArchiveType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetArchiveTypeDisplayName(
Int32 value
);

Parameters

value
The ArchiveType value to be converted to a display name.

Return Value

A user-friendly display name for the given ArchiveType value.

See Also

File Class | Borland.StarTeam Namespace | getArchiveType | getPossibleArchiveType | getEnumDisplayName | FILE_ARCHIVE_TYPE


File.GetCharsetDisplayName Method

Returns a user-friendly display name for the given Charset value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetCharsetDisplayName(
Int32 value
);

Parameters

value
The Charset value to be converted to a display name.

Return Value

A user-friendly display name for the given Charset value.

See Also

File Class | Borland.StarTeam Namespace | getCharset | getPossibleCharset | getEnumDisplayName | FILE_ENCODING


File.GetCompressionDisplayName Method

Returns a user-friendly display name for the given Compression value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetCompressionDisplayName(
Int32 value
);

Parameters

value
The Compression value to be converted to a display name.

Return Value

A user-friendly display name for the given Compression value.

See Also

File Class | Borland.StarTeam Namespace | getCompression | getPossibleCompression | getEnumDisplayName | FILE_COMPRESSION_LEVEL


File.GetFileSyncInfo Method

Attempts to determine what version of the file is actually on disk.

This method is similar to resyncStatus, except that the status information is returned to the caller, rather than being cached with the Server object. This is useful for server-based applications running on behalf of a remote client, when running against a StarTeam server that supports client-managed status.

public virtual FileSyncInfo GetFileSyncInfo(
MD5 compareMD5,
Int32 compareSize,
MD5 syncMD5,
Int32 syncSize,
DateTime syncTime
);

Parameters

compareMD5
The original MD5 signature of this file, as stored in the StarTeam repository. This is the signature that is compared against the signatures of the various revisions of this file, looking for a match. The compareMD5 signature may be different from the syncMD5 signature as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout. The compareMD5 signature is typically derived using FileStream.computeCompareMD5().
compareSize
The original size of this file, as stored in the StarTeam repository. This may be different from syncSize as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout.
syncMD5
The MD5 signature of the actual working file on disk. Typically derived using FileStream.computeSyncMD5().
syncSize
The size of the actual working file on disk.
syncTime
The last modified date of the actual working file on disk.

Return Value

The file status information describing which version of the file is actually on disk. Returns null if the status information could not be determined.

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | resyncStatus | computeCompareMD5 | computeSyncMD5 | Status | getFileSyncInfoEx


File.GetFileSyncInfoEx Method

Attempts to determine what version of the file is actually on disk.

This method is similar to resyncStatus, except that the status information is returned to the caller, rather than being cached with the Server object. This is useful for server-based applications running on behalf of a remote client, when running against a StarTeam server that supports client-managed status.

public virtual FileSyncInfo GetFileSyncInfoEx(
MD5 compareMD5,
Int64 compareSize,
MD5 syncMD5,
Int64 syncSize,
DateTime syncTime
);

Parameters

compareMD5
The original MD5 signature of this file, as stored in the StarTeam repository. This is the signature that is compared against the signatures of the various revisions of this file, looking for a match. The compareMD5 signature may be different from the syncMD5 signature as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout. The compareMD5 signature is typically derived using FileStream.computeCompareMD5().
compareSize
The original size of this file, as stored in the StarTeam repository. This may be different from syncSize as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout.
syncMD5
The MD5 signature of the actual working file on disk. Typically derived using FileStream.computeSyncMD5().
syncSize
The size of the actual working file on disk.
syncTime
The last modified date of the actual working file on disk.

Return Value

The file status information describing which version of the file is actually on disk. Returns null if the status information could not be determined.

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | resyncStatus | computeCompareMD5 | computeSyncMD5 | Status


File.GetSmartStatus Method

Gets the status of the given working file relative to the latest version of this file in the repository.

Status is determined by comparing the current size and last modified time with that of the last known version on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.

public virtual int GetSmartStatus(
FileInfo file
);

Parameters

file
The working file whose status is to be determined.

Return Value

The current status of this file.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | Status | getStatus


File.GetStatus Method

Gets the status of the given working file relative to the latest version of this file in the repository.

Status is determined by comparing the current size and last modified time with that of the last known version on disk.

public virtual int GetStatus(
FileInfo file
);

Parameters

file
The working file whose status is to be determined.

Return Value

The current status of this file.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | Status | getSmartStatus


File.GetStatusByMD5 Method

Returns the status of the default working file relative to the file in the repository, using the given size MD5 signature of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).

public virtual int GetStatusByMD5(
MD5 md5
);

Parameters

md5
The MD5 signature of the working file, or null if the signature is unknown or unchanged.

Return Value

The status code for this file.

See Also

File Class | Borland.StarTeam Namespace | getStatusByTime | updateStatusFromMD5 | resyncStatus | Status


File.GetStatusByTime Method

Returns the status of the default working file relative to the file in the repository, using the given size and last modified date of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).

public virtual int GetStatusByTime(
Int32 size,
DateTime lastModified
);

Parameters

size
The size of the working file on disk.
lastModified
The last modified date of the working file.

Return Value

The status code for this file.

See Also

File Class | Borland.StarTeam Namespace | getStatusByMD5 | updateStatusFromTime | resyncStatus | Status | getStatusByTimeEx


File.GetStatusByTimeEx Method

Returns the status of the default working file relative to the file in the repository, using the given size and last modified date of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).

public virtual int GetStatusByTimeEx(
Int64 size,
DateTime lastModified
);

Parameters

size
The size of the working file on disk.
lastModified
The last modified date of the working file.

Return Value

The status code for this file.

See Also

File Class | Borland.StarTeam Namespace | getStatusByMD5 | updateStatusFromTime | resyncStatus | Status


File.GetStorageFormatDisplayName Method

Returns a user-friendly display name for the given StorageFormat value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetStorageFormatDisplayName(
Int32 value
);

Parameters

value
The StorageFormat value to be converted to a display name.

Return Value

A user-friendly display name for the given StorageFormat value.

See Also

File Class | Borland.StarTeam Namespace | getStorageFormat | getPossibleStorageFormat | getEnumDisplayName | FILE_STORAGE_TYPE


File.IsInSyncByMD5 Method

Determines whether or not the given file has the MD5 signature indicated in the given FileSyncInfo record.

public static bool IsInSyncByMD5(
FileInfo file,
FileSyncInfo syncInfo
);

Parameters

file
A working file.
syncInfo
File synchronization information.

Return Value

True if the given file is in sync with respect to MD5 signature; false otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace


File.IsInSyncByTime Method

Determines whether or not the given file has the size and last modified date indicated in the given FileSyncInfo record.

public static bool IsInSyncByTime(
FileInfo file,
FileSyncInfo syncInfo
);

Parameters

file
A working file.
syncInfo
File synchronization information.

Return Value

True if the given file is in sync with respect to size and last modified date; false otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace


File.MoveLocalFile Method

Moves the local file to the specified folder and has the side effect of moving the status information from the original file to the newly created one Deletes the original file and it's status information at the end of the move

public virtual FileInfo MoveLocalFile(
FileInfo fromFile,
String toFolderPath
);

Parameters

fromFile
toFolderPath
String the folder to move it to.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace


File.RemoveAndDeleteLocal Method

Removes the file item from its parent folder. Note that a file may be shared in another folder in the same or different view. This method will merely remove the one instance (or shared copy) that the method is called on. In addition, this method will delete the corresponding working file.

public virtual void RemoveAndDeleteLocal();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | isDisembodied


File.Rename Method

Renames this file to a new name along with the side effect of changing the corresponding local file's name as well. This method does the same work as update() but also maintains the status information so that the newly renamed file will have the same status it did prior to the renaming. Simply using setName() and update() will not change the local file name consequently status information would be lost. NOTE: in the case where a file already exists with the new name, but it is not the same file as the old one [e.g., on Unix systems where only the case of the filenames differ], the local file will not be renamed, to avoid loss of data for users.

public virtual void Rename(
String newName
);

Parameters

newName
the file's new name

See Also

File Class | Borland.StarTeam Namespace


File.ResyncStatus Method

Attempts to update the repository information about what version of the file is actually on disk.

This method is similar to updateStatus, except that information about the working file is provided explicitly by the caller. The working file itself is not used, and in fact does not need to be accessible. This is useful, for example, if the actual working file resides on a remote client workstation.

public virtual void ResyncStatus(
MD5 compareMD5,
Int32 compareSize,
MD5 syncMD5,
Int32 syncSize,
DateTime syncTime
);

Parameters

compareMD5
The original MD5 signature of this file, as stored in the StarTeam repository. This is the signature that is compared against the signatures of the various revisions of this file, looking for a match. The compareMD5 signature may be different from the syncMD5 signature as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout. The compareMD5 signature is typically derived using FileStream.computeCompareMD5().
compareSize
The original size of this file, as stored in the StarTeam repository. This may be different from syncSize as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout.
syncMD5
The MD5 signature of the actual working file on disk. Typically derived using FileStream.computeSyncMD5().
syncSize
The size of the actual working file on disk.
syncTime
The last modified date of the actual working file on disk.

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | updateStatus | updateStatusFromMD5 | getStatusByMD5 | computeCompareMD5 | computeSyncMD5 | Status | resyncStatusEx


File.ResyncStatusEx Method

Attempts to update the repository information about what version of the file is actually on disk.

This method is similar to updateStatus, except that information about the working file is provided explicitly by the caller. The working file itself is not used, and in fact does not need to be accessible. This is useful, for example, if the actual working file resides on a remote client workstation.

public virtual void ResyncStatusEx(
MD5 compareMD5,
Int64 compareSize,
MD5 syncMD5,
Int64 syncSize,
DateTime syncTime
);

Parameters

compareMD5
The original MD5 signature of this file, as stored in the StarTeam repository. This is the signature that is compared against the signatures of the various revisions of this file, looking for a match. The compareMD5 signature may be different from the syncMD5 signature as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout. The compareMD5 signature is typically derived using FileStream.computeCompareMD5().
compareSize
The original size of this file, as stored in the StarTeam repository. This may be different from syncSize as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout.
syncMD5
The MD5 signature of the actual working file on disk. Typically derived using FileStream.computeSyncMD5().
syncSize
The size of the actual working file on disk.
syncTime
The last modified date of the actual working file on disk.

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | updateStatus | updateStatusFromMD5 | getStatusByMD5 | computeCompareMD5 | computeSyncMD5 | Status


UpdateStatus Method

Borland StarTeam SDK for .NET

File.UpdateStatus Method

Attempts to update the repository information about what version of the file is actually on disk. This method will send either the whole file or its MD5 checksum to the server to see if the contents exactly matche any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged.

Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".

Overload List

Attempts to update the repository information about what version of the file is actually on disk. This method will send either the whole file or its MD5 checksum to the server to see if the contents exactly matche any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged. Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".

public virtual void UpdateStatus(Boolean);

Attempts to update the repository information about what version of the file is actually on disk. This method will send either the whole file or its MD5 checksum to the server to see if the contents exactly matche any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged. Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".

public virtual void UpdateStatus(Boolean,Boolean);

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | getStatus | Status


File.UpdateStatus Method (Boolean)

Attempts to update the repository information about what version of the file is actually on disk. This method will send either the whole file or its MD5 checksum to the server to see if the contents exactly matche any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged.

Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".

public virtual void UpdateStatus(
Boolean useMD5
);

Parameters

useMD5
true if you want to just send the file's MD5 checksum and false if you wish to send the entire file

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.UpdateStatus Overload List | isDisembodied | getStatus | Status


File.UpdateStatus Method (Boolean, Boolean)

Attempts to update the repository information about what version of the file is actually on disk. This method will send either the whole file or its MD5 checksum to the server to see if the contents exactly matche any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged.

Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".

public virtual void UpdateStatus(
Boolean eolConversion,
Boolean useMD5
);

Parameters

eolConversion
This parameter is obsolete and ignored. The end-of-line characters of text files are always converted to a canonical format in the repository. To specify the desired end-of-line sequence for the working file, see {@link File#setEOLFormat setEOLFormat}.
useMD5
true if you want to just send the file's MD5 checksum and false if you wish to send the entire file

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | File.UpdateStatus Overload List | isDisembodied | getStatus | Status


File.UpdateStatusAfterMerge Method

Updates the server's status information to reflect the fact that the local file's contents were derived from this file's contents. You would most commonly want to call this after merging in changes. This file's status will be "Modified" after a call to this method if this file is the tip version of the file.

public virtual void UpdateStatusAfterMerge();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | isDisembodied


File.UpdateStatusFromMD5 Method

Updates the server's status information to reflect the fact that the local file's content has the given MD5 signature.

The file size and last modified date are assumed to be unknown. Any previously specified values will remain unchanged.

This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void UpdateStatusFromMD5(
MD5 signature
);

Parameters

signature
The MD5 signature of the working file.

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | getStatusByMD5 | updateStatusFromTime | updateStatusInformation | resyncStatus | Status


File.UpdateStatusFromTime Method

Updates the server's status information to reflect the fact that the local file's content has the given size and last modified date.

The MD5 signature is assumed to be unknown, and any previously specified value will remain unchanged.

This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void UpdateStatusFromTime(
Int32 size,
DateTime lastModified
);

Parameters

size
The size of the working file on disk.
lastModified
The last modified date of the working file.

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | getStatusByTime | updateStatusFromMD5 | updateStatusInformation | resyncStatus | Status | updateStatusFromTimeEx


File.UpdateStatusFromTimeEx Method

Updates the server's status information to reflect the fact that the local file's content has the given size and last modified date.

The MD5 signature is assumed to be unknown, and any previously specified value will remain unchanged.

This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void UpdateStatusFromTimeEx(
Int64 size,
DateTime lastModified
);

Parameters

size
The size of the working file on disk.
lastModified
The last modified date of the working file.

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | getStatusByTime | updateStatusFromMD5 | updateStatusInformation | resyncStatus | Status


File.UpdateStatusInformation Method

Updates the server's status information to reflect the fact that the local file's content has the given size, last modified date, and MD5 signature.

This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void UpdateStatusInformation(
Int32 fileSize,
DateTime lastModified,
MD5 signature
);

Parameters

fileSize
The size of the working file on disk. A negative value indicates that the size is unknown.
lastModified
The last modified date of the working file. null indicates that the last modified date is unknown.
signature
The MD5 signature of the working file. null indicates that the signature is unknown.

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | updateStatusFromTime | updateStatusFromMD5 | resyncStatus | Status | updateStatusInformationEx


File.UpdateStatusInformationEx Method

Updates the server's status information to reflect the fact that the local file's content has the given size, last modified date, and MD5 signature.

This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void UpdateStatusInformationEx(
Int64 fileSize,
DateTime lastModified,
MD5 signature
);

Parameters

fileSize
The size of the working file on disk. A negative value indicates that the size is unknown.
lastModified
The last modified date of the working file. null indicates that the last modified date is unknown.
signature
The MD5 signature of the working file. null indicates that the signature is unknown.

See Also

File Class | Borland.StarTeam Namespace | isDisembodied | updateStatusFromTime | updateStatusFromMD5 | resyncStatus | Status


File.UpgradeSyncInfo Method

Move status records from an old server to the new client managed status information. Returns true if sync information was found and moved locally and false otherwise. This will return false and do nothing if the file is from a newer server that supports client managed status.

public virtual bool UpgradeSyncInfo();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | Borland.StarTeam Namespace | isDisembodied


File.Wrap Method

Dynamically wraps com.starbase.starteam.File.

public static File Wrap(
File impl
);

Parameters

impl
com.starbase.starteam.File to be wrapped.

Return Value

File

See Also

File Class | Borland.StarTeam Namespace


File Type Conversions

The type conversions of the File class are listed below. For a complete list of File class members, see the File Members topic.

Public Static Type Conversions

Implicit File to File Conversion Implicitly convert File to com.starbase.starteam.File.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

File Class | File Members | Borland.StarTeam Namespace


File Implicit File to File Conversion

Implicitly convert File to com.starbase.starteam.File.

public static implicit operator File(
File arg
);

Parameters

arg
File to convert.

Return Value

com.starbase.starteam.File

See Also

File Class | Borland.StarTeam Namespace


FileBasedStatusManager Class

Manages File Status information on the local client workstation.

For a list of all members of this type, see FileBasedStatusManager Members.

System.Object
FileBasedStatusManager

public class FileBasedStatusManager : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileBasedStatusManager Members | Borland.StarTeam Namespace


FileBasedStatusManager Members

FileBasedStatusManager overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.FileBasedStatusManager.

Public Static Type Conversions

Implicit FileBasedStatusManager to FileBasedStatusManager Conversion Implicitly convert FileBasedStatusManager to com.starbase.starteam.FileBasedStatusManager.

Public Instance Constructors

FileBasedStatusManager Constructor Construct FileBasedStatusManager from com.starbase.starteam.FileBasedStatusManager.

Public Instance Properties

IsCentral | [read] True if status information is stored in a central location; false if it is managed on a per-folder basis.
IsPerFolder | [read] True if status information is managed on a per-folder basis; false if it is stored in a central location.

Public Instance Methods

DeleteFileSyncInfo | Deletes File Status information for the given working file.
Equals | Delegate Equals() to com.starbase.starteam.FileBasedStatusManager.
GetFileSyncInfo | Gets File Status information for the given working file.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.FileBasedStatusManager.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveFileSyncInfo | Moves File Status Information from the oldFile to the newFile The move will fail if either of the two specified files do not exist.
SetFileSyncInfo | Sets File Status information for the given working file.
ToString | Delegate ToString() to com.starbase.starteam.FileBasedStatusManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


FileBasedStatusManager Constructor

Construct FileBasedStatusManager from com.starbase.starteam.FileBasedStatusManager.

public FileBasedStatusManager(
FileBasedStatusManager impl
);

Parameters

impl
The com.starbase.starteam.FileBasedStatusManager to be wrapped.

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


FileBasedStatusManager Properties

The properties of the FileBasedStatusManager class are listed below. For a complete list of FileBasedStatusManager class members, see the FileBasedStatusManager Members topic.

Public Instance Properties

IsCentral | [read] True if status information is stored in a central location; false if it is managed on a per-folder basis.
IsPerFolder | [read] True if status information is managed on a per-folder basis; false if it is stored in a central location.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


IsCentral Property

Borland StarTeam SDK for .NET

FileBasedStatusManager.IsCentral Property

[read] True if status information is stored in a central location; false if it is managed on a per-folder basis.

public virtual Boolean IsCentral {get;}

Property Value

True if status information is stored in a central location; false if it is managed on a per-folder basis.

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


IsPerFolder Property

Borland StarTeam SDK for .NET

FileBasedStatusManager.IsPerFolder Property

[read] True if status information is managed on a per-folder basis; false if it is stored in a central location.

public virtual Boolean IsPerFolder {get;}

Property Value

True if status information is managed on a per-folder basis; false if it is stored in a central location.

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


FileBasedStatusManager Methods

The methods of the FileBasedStatusManager class are listed below. For a complete list of FileBasedStatusManager class members, see the FileBasedStatusManager Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.FileBasedStatusManager.

Public Instance Methods

DeleteFileSyncInfo | Deletes File Status information for the given working file.
Equals | Delegate Equals() to com.starbase.starteam.FileBasedStatusManager.
GetFileSyncInfo | Gets File Status information for the given working file.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.FileBasedStatusManager.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveFileSyncInfo | Moves File Status Information from the oldFile to the newFile The move will fail if either of the two specified files do not exist.
SetFileSyncInfo | Sets File Status information for the given working file.
ToString | Delegate ToString() to com.starbase.starteam.FileBasedStatusManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


FileBasedStatusManager.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.FileBasedStatusManager

Implements

IWrapper.Unwrap

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


FileBasedStatusManager.DeleteFileSyncInfo Method

Deletes File Status information for the given working file.

public virtual void DeleteFileSyncInfo(
FileInfo file,
Boolean cs
);

Parameters

file
A working file.
cs
True if paths are case sensitive; false otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace | FileSyncInfo | StatusMethod


FileBasedStatusManager.Equals Method

Delegate Equals() to com.starbase.starteam.FileBasedStatusManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.FileBasedStatusManager.Equals(obj).

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


FileBasedStatusManager.GetFileSyncInfo Method

Gets File Status information for the given working file.

public virtual FileSyncInfo GetFileSyncInfo(
FileInfo file,
Boolean cs
);

Parameters

file
A working file.
cs
True if paths are case sensitive; false otherwise.

Return Value

File Status information for the given working file, or null if none is available.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace | FileSyncInfo | StatusMethod


FileBasedStatusManager.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.FileBasedStatusManager.

public override int GetHashCode();

Return Value

com.starbase.starteam.FileBasedStatusManager.GetHashCode().

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


FileBasedStatusManager.MoveFileSyncInfo Method

Moves File Status Information from the oldFile to the newFile The move will fail if either of the two specified files do not exist.

public virtual bool MoveFileSyncInfo(
FileInfo oldFile,
FileInfo newFile,
Boolean caseSensitive
);

Parameters

oldFile
File a file for which status information is recorded; this status will be deleted as a result of the move
newFile
File a file to which the status information is being transferred
caseSensitive
boolean True if paths are case sensitive; false otherwise

Return Value

true if the move succeeded

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace | FileSyncInfo | StatusMethod


FileBasedStatusManager.SetFileSyncInfo Method

Sets File Status information for the given working file.

public virtual void SetFileSyncInfo(
FileInfo file,
FileSyncInfo rec,
Boolean cs
);

Parameters

file
A working file.
rec
New File Status information to be saved.
cs
True if paths are case sensitive; false otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace | FileSyncInfo | StatusMethod


FileBasedStatusManager.ToString Method

Delegate ToString() to com.starbase.starteam.FileBasedStatusManager.

public override string ToString();

Return Value

com.starbase.starteam.FileBasedStatusManager.ToString()

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


FileBasedStatusManager.Wrap Method

Dynamically wraps com.starbase.starteam.FileBasedStatusManager.

public static FileBasedStatusManager Wrap(
FileBasedStatusManager impl
);

Parameters

impl
com.starbase.starteam.FileBasedStatusManager to be wrapped.

Return Value

FileBasedStatusManager

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


FileBasedStatusManager Type Conversions

The type conversions of the FileBasedStatusManager class are listed below. For a complete list of FileBasedStatusManager class members, see the FileBasedStatusManager Members topic.

Public Static Type Conversions

Implicit FileBasedStatusManager to FileBasedStatusManager Conversion Implicitly convert FileBasedStatusManager to com.starbase.starteam.FileBasedStatusManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileBasedStatusManager Class | FileBasedStatusManager Members | Borland.StarTeam Namespace


FileBasedStatusManager Implicit FileBasedStatusManager to FileBasedStatusManager Conversion

Implicitly convert FileBasedStatusManager to com.starbase.starteam.FileBasedStatusManager.

public static implicit operator FileBasedStatusManager(
FileBasedStatusManager arg
);

Parameters

arg
FileBasedStatusManager to convert.

Return Value

com.starbase.starteam.FileBasedStatusManager

See Also

FileBasedStatusManager Class | Borland.StarTeam Namespace


FileCollection Class

A strongly-typed collection of Files.

For a list of all members of this type, see FileCollection Members.

System.Object
ArrayAdapter
FileCollection

public class FileCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileCollection Members | Borland.StarTeam Namespace


FileCollection Members

FileCollection overview

Public Static Methods

Wrap Creates a FileCollection to represent the given array of File (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit FileCollection to File[] Conversion | Converts a FileCollection to an array of Files.
Implicit FileCollection to File[] Conversion | Converts a FileCollection from the Borland.StarTeam namespace to a File[] in the com.starbase.starteam namespace.

Public Instance Constructors

FileCollection Overloaded. Initializes a new instance of the FileCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the File at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a File to end of the collection.
Append | Overloaded. Appends the Files of the given FileCollection to the end of this FileCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific File.
CopyTo | Copies all of the Files in the FileCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the File with the given ID.
FindByName | Finds the File with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific File in the collection.
Insert | Inserts a File into the collection at the specified position.
Remove | Removes the first occurrence of a specific File from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Files in this FileCollection.
Sort | Sorts the Files in this FileCollection, using the given comparer.
SortByID | Sorts the Files in this FileCollection by ID.
SortByName | Sorts the Files in this FileCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection Constructor

Initializes an instance of the FileCollection class.

Overload List

Initializes an instance of the FileCollection class.

public FileCollection();

Initializes an instance of the a FileCollection class, copying the given array.

public FileCollection(File[]);

Initializes an instance of the a FileCollection class, copying the given collection.

public FileCollection(FileCollection);

Initializes an instance of the a FileCollection class, wrapping the given array of File (from the com.starbase.starteam namespace).

public FileCollection(File[]);

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection Constructor ()

Initializes an instance of the FileCollection class.

public FileCollection();

See Also

FileCollection Class | Borland.StarTeam Namespace | FileCollection Constructor Overload List


FileCollection Constructor (File[])

Initializes an instance of the a FileCollection class, wrapping the given array of File (from the com.starbase.starteam namespace).

public FileCollection(
File[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

FileCollection Class | Borland.StarTeam Namespace | FileCollection Constructor Overload List | Wrap


FileCollection Constructor (FileCollection)

Initializes an instance of the a FileCollection class, copying the given collection.

public FileCollection(
FileCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member File objects of the original collection are shared, not copied.

See Also

FileCollection Class | Borland.StarTeam Namespace | FileCollection Constructor Overload List


FileCollection Constructor (File[])

Initializes an instance of the a FileCollection class, copying the given array.

public FileCollection(
File[] array
);

Parameters

array
The array to be copied.

Remarks

The member File objects of the original array are shared, not copied.

See Also

FileCollection Class | Borland.StarTeam Namespace | FileCollection Constructor Overload List


FileCollection Properties

The properties of the FileCollection class are listed below. For a complete list of FileCollection class members, see the FileCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the File at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FileCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

FileCollection.Item Property

Gets or sets the File at the specified index.

Overload List

Gets or sets the File at the specified index.

public File this[Int32] {get; set;}

Gets the File with the given name.

public File this[String] {get;}

See Also

FileCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

FileCollection.Item Property (Int32)

Gets or sets the File at the specified index.

public File this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the File to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

FileCollection Class | Borland.StarTeam Namespace | FileCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

FileCollection.Item Property (String)

Gets the File with the given name.

public File this[
String name
] {get;}

Parameters

name
The name of the File to get.

Property Value

The File with the given name, or null if there is no File with that name in this FileCollection. Comparison is case sensitive.

See Also

FileCollection Class | Borland.StarTeam Namespace | FileCollection.Item Overload List | FindByName


FileCollection Methods

The methods of the FileCollection class are listed below. For a complete list of FileCollection class members, see the FileCollection Members topic.

Public Static Methods

Wrap Creates a FileCollection to represent the given array of File (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a File to end of the collection.
Append | Overloaded. Appends the Files of the given FileCollection to the end of this FileCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific File.
CopyTo | Copies all of the Files in the FileCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the File with the given ID.
FindByName | Finds the File with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific File in the collection.
Insert | Inserts a File into the collection at the specified position.
Remove | Removes the first occurrence of a specific File from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Files in this FileCollection.
Sort | Sorts the Files in this FileCollection, using the given comparer.
SortByID | Sorts the Files in this FileCollection by ID.
SortByName | Sorts the Files in this FileCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.Add Method

Adds a File to end of the collection.

public int Add(
File value
);

Parameters

value
The File to add to the collection.

Return Value

The position into which the new File was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

FileCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

FileCollection.Append Method

Appends the Files of the given array to the end of this FileCollection.

Overload List

Appends the Files of the given array to the end of this FileCollection.

public FileCollection Append(File[]);

Appends the Files of the given FileCollection to the end of this FileCollection.

public FileCollection Append(FileCollection);

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.Append Method (File[])

Appends the Files of the given array to the end of this FileCollection.

public FileCollection Append(
File[] array
);

Parameters

array
The array whose Files are to be appended to this FileCollection.

Return Value

This FileCollection, modified to include the new Files.

Remarks

The FileCollection is modified to include the new members. The individual File objects are shared, not copied.

See Also

FileCollection Class | Borland.StarTeam Namespace | FileCollection.Append Overload List


FileCollection.Append Method (FileCollection)

Appends the Files of the given FileCollection to the end of this FileCollection.

public FileCollection Append(
FileCollection collection
);

Parameters

collection
The FileCollection whose Files are to be appended to this FileCollection.

Return Value

This FileCollection, modified to include the new Files.

Remarks

The FileCollection is modified to include the new members. The individual File objects are shared, not copied.

See Also

FileCollection Class | Borland.StarTeam Namespace | FileCollection.Append Overload List


FileCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.File[].

Implements

IWrapper.Unwrap

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.Contains Method

Determines whether or not the collection contains a specific File.

public bool Contains(
File value
);

Parameters

value
The File to locate in the collection.

Return Value

true if the File is found in the collection; otherwise, false.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.CopyTo Method

Copies all of the Files in the FileCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
File[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Files copied from the FileCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Files in the source FileCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source FileCollection cannot be cast automatically to the type of the destination array.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.FindByID Method

Finds the File with the given ID.

public File FindByID(
Int32 id
);

Parameters

id
The ID of the File to be found.

Return Value

The File with the given ID, or null if there is no File with that ID in this FileCollection.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.FindByName Method

Finds the File with the given name.

public File FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the File to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The File with the given name, or null if there is no File with that name in this FileCollection.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.IndexOf Method

Determines the index of a specific File in the collection.

public int IndexOf(
File value
);

Parameters

value
The File to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.Insert Method

Inserts a File into the collection at the specified position.

public void Insert(
Int32 index,
File value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The File to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.Remove Method

Removes the first occurrence of a specific File from the collection.

public void Remove(
File value
);

Parameters

value
The File to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.Reverse Method

Reverses the order of the Files in this FileCollection.

new public FileCollection Reverse();

Return Value

This FileCollection, modified such that the Files are reversed.

Remarks

The FileCollection is modified in place.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.Sort Method

Sorts the Files in this FileCollection, using the given comparer.

new public FileCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Files.

Return Value

This FileCollection, modified such that the Files are sorted.

Remarks

The FileCollection is modified in place.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.SortByID Method

Sorts the Files in this FileCollection by ID.

public FileCollection SortByID();

Return Value

This FileCollection, modified such that the Files are sorted by ID.

Remarks

The FileCollection is modified in place.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.SortByName Method

Sorts the Files in this FileCollection by name.

public FileCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This FileCollection, modified such that the Files are sorted by name.

Remarks

The FileCollection is modified in place.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection.Wrap Method

Creates a FileCollection to represent the given array of File (from the com.starbase.starteam namespace).

public static FileCollection Wrap(
File[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new FileCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a File[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection Type Conversions

The type conversions of the FileCollection class are listed below. For a complete list of FileCollection class members, see the FileCollection Members topic.

Public Static Type Conversions

Implicit FileCollection to File[] Conversion | Converts a FileCollection to an array of Files.
Implicit FileCollection to File[] Conversion | Converts a FileCollection from the Borland.StarTeam namespace to a File[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FileCollection Class | FileCollection Members | Borland.StarTeam Namespace


FileCollection Implicit FileCollection to File[] Conversion

Converts a FileCollection to an array of Files.

public static implicit operator File[](
FileCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new File wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one File wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileCollection Implicit FileCollection to File[] Conversion

Converts a FileCollection from the Borland.StarTeam namespace to a File[] in the com.starbase.starteam namespace.

public static implicit operator File[](
FileCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, FileCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

FileCollection Class | Borland.StarTeam Namespace


FileDigest Interface

The FileDigest interface specifies the nescessary information to determine if a file on disk has changed from some checkpoint. There are three pieces of information that can be used to determine this: the file's lastModified time, the file size, and a checksum of the file's contents.

For a list of all members of this type, see FileDigest Members.

public interface FileDigest

Types that implement FileDigest

Type | Description
FileDigestAdapter |

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileDigest Members | Borland.StarTeam Namespace


FileDigest Members

FileDigest overview

Public Instance Properties

FileMD5 | [read/write] The MD5 cryptographic hash of the file's content.
FileSize | [read/write] The file's size, in bytes.
FileTime | [read/write] The file's last modified time, as the number days from midnight, 30 December 1899, in UTC.

See Also

FileDigest Interface | Borland.StarTeam Namespace


FileDigest Properties

The properties of the FileDigest interface are listed below. For a complete list of FileDigest interface members, see the FileDigest Members topic.

Public Instance Properties

FileMD5 | [read/write] The MD5 cryptographic hash of the file's content.
FileSize | [read/write] The file's size, in bytes.
FileTime | [read/write] The file's last modified time, as the number days from midnight, 30 December 1899, in UTC.

See Also

FileDigest Interface | Borland.StarTeam Namespace


FileMD5 Property

Borland StarTeam SDK for .NET

FileDigest.FileMD5 Property

[read/write] The MD5 cryptographic hash of the file's content.

MD5 FileMD5 {get; set;}

Property Value

The MD5 cryptographic hash of the file's content.

See Also

FileDigest Interface | Borland.StarTeam Namespace


FileSize Property

Borland StarTeam SDK for .NET

FileDigest.FileSize Property

[read/write] The file's size, in bytes.

Int64 FileSize {get; set;}

Property Value

The file's size, in bytes.

See Also

FileDigest Interface | Borland.StarTeam Namespace


FileTime Property

Borland StarTeam SDK for .NET

FileDigest.FileTime Property

[read/write] The file's last modified time, as the number days from midnight, 30 December 1899, in UTC.

Double FileTime {get; set;}

Property Value

The file's last modified time, as the number days from midnight, 30 December 1899, in UTC.

See Also

FileDigest Interface | Borland.StarTeam Namespace


FileDigestAdapter Class

For a list of all members of this type, see FileDigestAdapter Members.

System.Object
FileDigestAdapter

public class FileDigestAdapter : FileDigest, FileDigest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileDigestAdapter Members | Borland.StarTeam Namespace


FileDigestAdapter Members

FileDigestAdapter overview

Public Instance Constructors

FileDigestAdapter Overloaded. Initializes a new instance of the FileDigestAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

FileDigest.FileMD5
FileDigest.FileSize
FileDigest.FileTime
FileDigest.getFileMD5
FileDigest.getFileSize
FileDigest.getFileTime
FileDigest.setFileMD5
FileDigest.setFileSize
FileDigest.setFileTime

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigestAdapter Constructor

Overload List

public FileDigestAdapter(FileDigest);

public FileDigestAdapter(FileDigest);

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigestAdapter Constructor (FileDigest)

public FileDigestAdapter(
FileDigest arg
);

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace | FileDigestAdapter Constructor Overload List


FileDigestAdapter Properties

The properties of the FileDigestAdapter class are listed below. For a complete list of FileDigestAdapter class members, see the FileDigestAdapter Members topic.

Explicit Interface Implementations

FileDigest.FileMD5
FileDigest.FileSize
FileDigest.FileTime
FileDigest.getFileMD5
FileDigest.getFileSize
FileDigest.getFileTime
FileDigest.setFileMD5
FileDigest.setFileSize
FileDigest.setFileTime

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigest.FileMD5 Property

Borland StarTeam SDK for .NET

FileDigestAdapter.FileDigest.FileMD5 Property

private MD5 FileDigest.FileMD5 {get; set;}

Implements

FileDigest.FileMD5

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigest.FileSize Property

Borland StarTeam SDK for .NET

FileDigestAdapter.FileDigest.FileSize Property

private Int64 FileDigest.FileSize {get; set;}

Implements

FileDigest.FileSize

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigest.FileTime Property

Borland StarTeam SDK for .NET

FileDigestAdapter.FileDigest.FileTime Property

private Double FileDigest.FileTime {get; set;}

Implements

FileDigest.FileTime

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigestAdapter Methods

The methods of the FileDigestAdapter class are listed below. For a complete list of FileDigestAdapter class members, see the FileDigestAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

FileDigest.FileMD5
FileDigest.FileSize
FileDigest.FileTime
FileDigest.getFileMD5
FileDigest.getFileSize
FileDigest.getFileTime
FileDigest.setFileMD5
FileDigest.setFileSize
FileDigest.setFileTime

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigestAdapter.FileDigest.getFileMD5 Method

MD5 FileDigest.getFileMD5();

Implements

FileDigest.getFileMD5

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigestAdapter.FileDigest.getFileSize Method

long FileDigest.getFileSize();

Implements

FileDigest.getFileSize

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigestAdapter.FileDigest.getFileTime Method

double FileDigest.getFileTime();

Implements

FileDigest.getFileTime

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigestAdapter.FileDigest.setFileMD5 Method

void FileDigest.setFileMD5(
MD5 value
);

Implements

FileDigest.setFileMD5

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigestAdapter.FileDigest.setFileSize Method

void FileDigest.setFileSize(
Int64 value
);

Implements

FileDigest.setFileSize

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileDigestAdapter.FileDigest.setFileTime Method

void FileDigest.setFileTime(
Double value
);

Implements

FileDigest.setFileTime

See Also

FileDigestAdapter Class | Borland.StarTeam Namespace


FileResult Class

The class holds return information common to the file operations of add, checkin and checkout.

For a list of all members of this type, see FileResult Members.

System.Object
FileResult
AddResult
CheckInResult
CheckOutResult

public class FileResult : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileResult Members | Borland.StarTeam Namespace


FileResult Members

FileResult overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.FileResult.

Public Static Type Conversions

Implicit FileResult to FileResult Conversion Implicitly convert FileResult to com.starbase.starteam.FileResult.

Public Instance Constructors

FileResult Constructor Construct FileResult from com.starbase.starteam.FileResult.

Public Instance Properties

Keywords [read] the keywords used for the file operation.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.FileResult.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.FileResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.FileResult.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileResult Class | Borland.StarTeam Namespace


FileResult Constructor

Construct FileResult from com.starbase.starteam.FileResult.

public FileResult(
FileResult impl
);

Parameters

impl
The com.starbase.starteam.FileResult to be wrapped.

See Also

FileResult Class | Borland.StarTeam Namespace


FileResult Properties

The properties of the FileResult class are listed below. For a complete list of FileResult class members, see the FileResult Members topic.

Public Instance Properties

Keywords [read] the keywords used for the file operation.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileResult Class | Borland.StarTeam Namespace


Keywords Property

Borland StarTeam SDK for .NET

FileResult.Keywords Property

[read] the keywords used for the file operation.

public virtual KeywordCollection Keywords {get;}

Property Value

the keywords used for the file operation.

See Also

FileResult Class | Borland.StarTeam Namespace


FileResult Methods

The methods of the FileResult class are listed below. For a complete list of FileResult class members, see the FileResult Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.FileResult.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.FileResult.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.FileResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.FileResult.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileResult Class | Borland.StarTeam Namespace


FileResult.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.FileResult

Implements

IWrapper.Unwrap

See Also

FileResult Class | Borland.StarTeam Namespace


FileResult.Equals Method

Delegate Equals() to com.starbase.starteam.FileResult.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.FileResult.Equals(obj).

See Also

FileResult Class | Borland.StarTeam Namespace


FileResult.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.FileResult.

public override int GetHashCode();

Return Value

com.starbase.starteam.FileResult.GetHashCode().

See Also

FileResult Class | Borland.StarTeam Namespace


FileResult.ToString Method

Delegate ToString() to com.starbase.starteam.FileResult.

public override string ToString();

Return Value

com.starbase.starteam.FileResult.ToString()

See Also

FileResult Class | Borland.StarTeam Namespace


FileResult.Wrap Method

Dynamically wraps com.starbase.starteam.FileResult.

public static FileResult Wrap(
FileResult impl
);

Parameters

impl
com.starbase.starteam.FileResult to be wrapped.

Return Value

FileResult

See Also

FileResult Class | Borland.StarTeam Namespace


FileResult Type Conversions

The type conversions of the FileResult class are listed below. For a complete list of FileResult class members, see the FileResult Members topic.

Public Static Type Conversions

Implicit FileResult to FileResult Conversion Implicitly convert FileResult to com.starbase.starteam.FileResult.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileResult Class | FileResult Members | Borland.StarTeam Namespace


FileResult Implicit FileResult to FileResult Conversion

Implicitly convert FileResult to com.starbase.starteam.FileResult.

public static implicit operator FileResult(
FileResult arg
);

Parameters

arg
FileResult to convert.

Return Value

com.starbase.starteam.FileResult

See Also

FileResult Class | Borland.StarTeam Namespace


FileStream Class

Provides utility function for manipulating File streams.

For a list of all members of this type, see FileStream Members.

System.Object
FileStream

public class FileStream : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileStream Members | Borland.StarTeam Namespace


FileStream Members

FileStream overview

Public Static Methods

ComputeCompareMD5 | Derives an MD5 signature representing what the content of the given file would be if stored in the StarTeam repository. Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.
ComputeCompareMD5Ex | Derives an MD5 signature representing what the content of the given file would be if stored in the StarTeam repository. Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.
ComputeSyncMD5 | Derives an MD5 signature representing an actual working file on disk.
ComputeSyncMD5Ex | Derives an MD5 signature representing an actual working file on disk.

Public Static Type Conversions

Implicit FileStream to FileStream Conversion Implicitly convert FileStream to com.starbase.starteam.FileStream.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.FileStream.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.FileStream.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.FileStream.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileStream Class | Borland.StarTeam Namespace


FileStream Methods

The methods of the FileStream class are listed below. For a complete list of FileStream class members, see the FileStream Members topic.

Public Static Methods

ComputeCompareMD5 | Derives an MD5 signature representing what the content of the given file would be if stored in the StarTeam repository. Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.
ComputeCompareMD5Ex | Derives an MD5 signature representing what the content of the given file would be if stored in the StarTeam repository. Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.
ComputeSyncMD5 | Derives an MD5 signature representing an actual working file on disk.
ComputeSyncMD5Ex | Derives an MD5 signature representing an actual working file on disk.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.FileStream.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.FileStream.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.FileStream.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileStream Class | Borland.StarTeam Namespace


FileStream.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.FileStream

Implements

IWrapper.Unwrap

See Also

FileStream Class | Borland.StarTeam Namespace


FileStream.ComputeCompareMD5 Method

Derives an MD5 signature representing what the content of the given file would be if stored in the StarTeam repository.

Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.

public static int ComputeCompareMD5(
FileInfo file,
Boolean bUsesKeywords,
Boolean bConvertEOL,
MD5 md5
);

Parameters

file
The working file on disk. An exception will be thrown if the file does not exist or cannot be read.
bUsesKeywords
A newly initialized MD5 signature. On output, contains the MD5 signature calculated from the file's content, adjusted as determined by bUsesKeywords and bConvertEOL.
bConvertEOL
True if this file uses keywords. If true, then the signature is adjusted to compensate for any keyword expansion that would occur on a checkin. If this is a binary file (that is, if it contains at least one '\0' character), bUsesKeywords is ignored, and no adjustment is made to the signature.
md5
This parameter is obsolete and ignored. The end-of-line characters of text files are always converted to a canonical format in the repository. To specify the desired end-of-line sequence for the working file, see {@link File#setEOLFormat setEOLFormat}.

Return Value

The number of bytes in the as it would be stored in the StarTeam repository.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileStream Class | Borland.StarTeam Namespace | computeSyncMD5 | resyncStatus | Status | computeCompareMD5Ex


FileStream.ComputeCompareMD5Ex Method

Derives an MD5 signature representing what the content of the given file would be if stored in the StarTeam repository.

Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.

public static long ComputeCompareMD5Ex(
FileInfo file,
Boolean bUsesKeywords,
Boolean bConvertEOL,
MD5 md5
);

Parameters

file
The working file on disk. An exception will be thrown if the file does not exist or cannot be read.
bUsesKeywords
A newly initialized MD5 signature. On output, contains the MD5 signature calculated from the file's content, adjusted as determined by bUsesKeywords and bConvertEOL.
bConvertEOL
True if this file uses keywords. If true, then the signature is adjusted to compensate for any keyword expansion that would occur on a checkin. If this is a binary file (that is, if it contains at least one '\0' character), bUsesKeywords is ignored, and no adjustment is made to the signature.
md5
This parameter is obsolete and ignored. The end-of-line characters of text files are always converted to a canonical format in the repository. To specify the desired end-of-line sequence for the working file, see {@link File#setEOLFormat setEOLFormat}.

Return Value

The number of bytes in the as it would be stored in the StarTeam repository.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileStream Class | Borland.StarTeam Namespace | computeSyncMD5 | resyncStatus | Status


FileStream.ComputeSyncMD5 Method

Derives an MD5 signature representing an actual working file on disk.

public static int ComputeSyncMD5(
FileInfo file,
MD5 md5
);

Parameters

file
The working file on disk. An exception will be thrown if the file does not exist or cannot be read.
md5
A newly initialized MD5 signature. On output, contains the MD5 signature calculated from the file's content.

Return Value

The number of bytes in the working file on disk.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileStream Class | Borland.StarTeam Namespace | computeCompareMD5 | resyncStatus | Status | computeSyncMD5Ex


FileStream.ComputeSyncMD5Ex Method

Derives an MD5 signature representing an actual working file on disk.

public static long ComputeSyncMD5Ex(
FileInfo file,
MD5 md5
);

Parameters

file
The working file on disk. An exception will be thrown if the file does not exist or cannot be read.
md5
A newly initialized MD5 signature. On output, contains the MD5 signature calculated from the file's content.

Return Value

The number of bytes in the working file on disk.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileStream Class | Borland.StarTeam Namespace | computeCompareMD5 | resyncStatus | Status


FileStream.Equals Method

Delegate Equals() to com.starbase.starteam.FileStream.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.FileStream.Equals(obj).

See Also

FileStream Class | Borland.StarTeam Namespace


FileStream.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.FileStream.

public override int GetHashCode();

Return Value

com.starbase.starteam.FileStream.GetHashCode().

See Also

FileStream Class | Borland.StarTeam Namespace


FileStream.ToString Method

Delegate ToString() to com.starbase.starteam.FileStream.

public override string ToString();

Return Value

com.starbase.starteam.FileStream.ToString()

See Also

FileStream Class | Borland.StarTeam Namespace


FileStream Type Conversions

The type conversions of the FileStream class are listed below. For a complete list of FileStream class members, see the FileStream Members topic.

Public Static Type Conversions

Implicit FileStream to FileStream Conversion Implicitly convert FileStream to com.starbase.starteam.FileStream.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileStream Class | FileStream Members | Borland.StarTeam Namespace


FileStream Implicit FileStream to FileStream Conversion

Implicitly convert FileStream to com.starbase.starteam.FileStream.

public static implicit operator FileStream(
FileStream arg
);

Parameters

arg
FileStream to convert.

Return Value

com.starbase.starteam.FileStream

See Also

FileStream Class | Borland.StarTeam Namespace


FileSyncInfo Interface

The FileSyncInfo interface specifies the pairing of the two important pieces of information needed to know what is on a user's local disk: RevisionIdentifier and FileDigest. This information is needed to compute a File's status.

For a list of all members of this type, see FileSyncInfo Members.

public interface FileSyncInfo

Types that implement FileSyncInfo

Type | Description
FileSyncInfoAdapter |

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileSyncInfo Members | Borland.StarTeam Namespace


FileSyncInfo Members

FileSyncInfo overview

Public Instance Properties

FileDigest | [read] The FileDigest for the file in question.
RevisionIdentifier | [read] The RevisionIdentifier for the file in question.

See Also

FileSyncInfo Interface | Borland.StarTeam Namespace


FileSyncInfo Properties

The properties of the FileSyncInfo interface are listed below. For a complete list of FileSyncInfo interface members, see the FileSyncInfo Members topic.

Public Instance Properties

FileDigest | [read] The FileDigest for the file in question.
RevisionIdentifier | [read] The RevisionIdentifier for the file in question.

See Also

FileSyncInfo Interface | Borland.StarTeam Namespace


FileDigest Property

Borland StarTeam SDK for .NET

FileSyncInfo.FileDigest Property

[read] The FileDigest for the file in question.

FileDigest FileDigest {get;}

Property Value

The FileDigest for the file in question.

See Also

FileSyncInfo Interface | Borland.StarTeam Namespace


RevisionIdentifier Property

Borland StarTeam SDK for .NET

FileSyncInfo.RevisionIdentifier Property

[read] The RevisionIdentifier for the file in question.

RevisionIdentifier RevisionIdentifier {get;}

Property Value

The RevisionIdentifier for the file in question.

See Also

FileSyncInfo Interface | Borland.StarTeam Namespace


FileSyncInfoAdapter Class

For a list of all members of this type, see FileSyncInfoAdapter Members.

System.Object
FileSyncInfoAdapter

public class FileSyncInfoAdapter : FileSyncInfo, FileSyncInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileSyncInfoAdapter Members | Borland.StarTeam Namespace


FileSyncInfoAdapter Members

FileSyncInfoAdapter overview

Public Instance Constructors

FileSyncInfoAdapter Overloaded. Initializes a new instance of the FileSyncInfoAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

FileSyncInfo.FileDigest
FileSyncInfo.getFileDigest
FileSyncInfo.getRevisionIdentifier
FileSyncInfo.RevisionIdentifier

See Also

FileSyncInfoAdapter Class | Borland.StarTeam Namespace


FileSyncInfoAdapter Constructor

Overload List

public FileSyncInfoAdapter(FileSyncInfo);

public FileSyncInfoAdapter(FileSyncInfo);

See Also

FileSyncInfoAdapter Class | Borland.StarTeam Namespace


FileSyncInfoAdapter Constructor (FileSyncInfo)

public FileSyncInfoAdapter(
FileSyncInfo arg
);

See Also

FileSyncInfoAdapter Class | Borland.StarTeam Namespace | FileSyncInfoAdapter Constructor Overload List


FileSyncInfoAdapter Properties

The properties of the FileSyncInfoAdapter class are listed below. For a complete list of FileSyncInfoAdapter class members, see the FileSyncInfoAdapter Members topic.

Explicit Interface Implementations

FileSyncInfo.FileDigest
FileSyncInfo.getFileDigest
FileSyncInfo.getRevisionIdentifier
FileSyncInfo.RevisionIdentifier

See Also

FileSyncInfoAdapter Class | Borland.StarTeam Namespace


FileSyncInfo.FileDigest Property

Borland StarTeam SDK for .NET

FileSyncInfoAdapter.FileSyncInfo.FileDigest Property

private FileDigest FileSyncInfo.FileDigest {get;}

Implements

FileSyncInfo.FileDigest

See Also

FileSyncInfoAdapter Class | Borland.StarTeam Namespace


FileSyncInfo.RevisionIdentifier Property

Borland StarTeam SDK for .NET

FileSyncInfoAdapter.FileSyncInfo.RevisionIdentifier Property

private RevisionIdentifier FileSyncInfo.RevisionIdentifier {get;}

Implements

FileSyncInfo.RevisionIdentifier

See Also

FileSyncInfoAdapter Class | Borland.StarTeam Namespace


FileSyncInfoAdapter Methods

The methods of the FileSyncInfoAdapter class are listed below. For a complete list of FileSyncInfoAdapter class members, see the FileSyncInfoAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

FileSyncInfo.FileDigest
FileSyncInfo.getFileDigest
FileSyncInfo.getRevisionIdentifier
FileSyncInfo.RevisionIdentifier

See Also

FileSyncInfoAdapter Class | Borland.StarTeam Namespace


FileSyncInfoAdapter.FileSyncInfo.getFileDigest Method

FileDigest FileSyncInfo.getFileDigest();

Implements

FileSyncInfo.getFileDigest

See Also

FileSyncInfoAdapter Class | Borland.StarTeam Namespace


FileSyncInfoAdapter.FileSyncInfo.getRevisionIdentifier Method

RevisionIdentifier FileSyncInfo.getRevisionIdentifier();

Implements

FileSyncInfo.getRevisionIdentifier

See Also

FileSyncInfoAdapter Class | Borland.StarTeam Namespace


Filter Class

The Filter class is used to define criteria for which items (files, change requests) should be displayed to a user. It includes information on which items should be displayed, which properties should be displayed, and how the items should be sorted or grouped. The StarTeam GUI uses filters to determine what items in a folder to display.

For a list of all members of this type, see Filter Members.

System.Object
Filter

public class Filter : ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Filter Members | Borland.StarTeam Namespace


Filter Members

Filter overview

Public Static Properties

CONTEXT_LOCAL
CONTEXT_LOCAL_AND_SERVER
CONTEXT_SERVER

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Filter.

Public Static Type Conversions

Implicit Filter to Filter Conversion Implicitly convert Filter to com.starbase.starteam.Filter.

Public Instance Constructors

Filter Overloaded. Initializes a new instance of the Filter class.

Public Instance Properties

ACL |
ColumnInfo | [read/write]
Context | [read/write]
DebugString | [read]
GroupingDepth | [read] the number of grouping levels specified for the Filter.
GroupSortInfo | [read/write]
ID | [read]
IsDeleted | [read]
IsDirty | [read] true if the filter has unsaved modifications.
IsNew | [read]
IsPublic | [read]
Name | [read/write]
ParentContainer |
Properties | [read] an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.
QueryID | [read/write]
Type |
UserID | [read]

Public Instance Methods

AppendColumn | A convenience method to add a new column at the end of the column list.
AppendGroupSortInfo |
ClearColumns | A convenience method to remove all column display information.
ClearGroupSortInfo | A convenience method to remove all sort and group information.
Copy | Creates a copy of this Filter object. Useful to applications that want to save a snapshot of the filter in a given state, for example, before calling Type.refreshFiltersAndQueries(). The copied filter will have the same parent Type as the original property. The Type object is not copied.
Delete |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission |
IsEqualTo | Compares two Filter objects.
MakePublic |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update |

See Also

Filter Class | Borland.StarTeam Namespace


Filter Constructor

Construct Filter from com.starbase.starteam.Filter.

Overload List

Creates a new Filter. The filter will not be stored in the repository until you call update().

public Filter(Type,String,Int32,Boolean);

Construct Filter from com.starbase.starteam.Filter.

public Filter(Filter);

See Also

Filter Class | Borland.StarTeam Namespace


Filter Constructor (Filter)

Construct Filter from com.starbase.starteam.Filter.

public Filter(
Filter impl
);

Parameters

impl
The com.starbase.starteam.Filter to be wrapped.

See Also

Filter Class | Borland.StarTeam Namespace | Filter Constructor Overload List


Filter Constructor (Type, String, Int32, Boolean)

Creates a new Filter. The filter will not be stored in the repository until you call update().

public Filter(
Type type,
String name,
Int32 context,
Boolean publicFilter
);

Parameters

type
the type of items to be displayed (e.g. files or change requests)
name
the name of the filter
context
specify server, local or both types of items to be displayed
publicFilter
if true the filter will be visible to all users

See Also

Filter Class | Borland.StarTeam Namespace | Filter Constructor Overload List


Filter Properties

The properties of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Static Properties

CONTEXT_LOCAL
CONTEXT_LOCAL_AND_SERVER
CONTEXT_SERVER

Public Instance Properties

ACL |
ColumnInfo | [read/write]
Context | [read/write]
DebugString | [read]
GroupingDepth | [read] the number of grouping levels specified for the Filter.
GroupSortInfo | [read/write]
ID | [read]
IsDeleted | [read]
IsDirty | [read] true if the filter has unsaved modifications.
IsNew | [read]
IsPublic | [read]
Name | [read/write]
ParentContainer |
Properties | [read] an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.
QueryID | [read/write]
Type |
UserID | [read]

See Also

Filter Class | Borland.StarTeam Namespace


ACL Property

Borland StarTeam SDK for .NET

Filter.ACL Property

public virtual ACL ACL {get; set;}

Implements

ISecurable.ACL

See Also

Filter Class | Borland.StarTeam Namespace


ColumnInfo Property

Borland StarTeam SDK for .NET

Filter.ColumnInfo Property

[read/write]

public virtual ColumnInfoCollection ColumnInfo {get; set;}

See Also

Filter Class | Borland.StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Filter.Context Property

[read/write]

public virtual Int32 Context {get; set;}

See Also

Filter Class | Borland.StarTeam Namespace


CONTEXT_LOCAL Property

Borland StarTeam SDK for .NET

Filter.CONTEXT_LOCAL Property

public static Int32 CONTEXT_LOCAL {get;}

See Also

Filter Class | Borland.StarTeam Namespace


CONTEXT_LOCAL_AND_SERVER Property

Borland StarTeam SDK for .NET

Filter.CONTEXT_LOCAL_AND_SERVER Property

public static Int32 CONTEXT_LOCAL_AND_SERVER {get;}

See Also

Filter Class | Borland.StarTeam Namespace


CONTEXT_SERVER Property

Borland StarTeam SDK for .NET

Filter.CONTEXT_SERVER Property

public static Int32 CONTEXT_SERVER {get;}

See Also

Filter Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Filter.DebugString Property

[read]

public virtual String DebugString {get;}

See Also

Filter Class | Borland.StarTeam Namespace


GroupingDepth Property

Borland StarTeam SDK for .NET

Filter.GroupingDepth Property

[read] the number of grouping levels specified for the Filter.

public virtual Int32 GroupingDepth {get;}

Property Value

the number of grouping levels specified for the Filter.

See Also

Filter Class | Borland.StarTeam Namespace


GroupSortInfo Property

Borland StarTeam SDK for .NET

Filter.GroupSortInfo Property

[read/write]

public virtual GroupSortInfoCollection GroupSortInfo {get; set;}

See Also

Filter Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Filter.ID Property

[read]

public virtual Int32 ID {get;}

See Also

Filter Class | Borland.StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Filter.IsDeleted Property

[read]

public virtual Boolean IsDeleted {get;}

See Also

Filter Class | Borland.StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Filter.IsDirty Property

[read] true if the filter has unsaved modifications.

public virtual Boolean IsDirty {get;}

Property Value

true if the filter has unsaved modifications.

See Also

Filter Class | Borland.StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Filter.IsNew Property

[read]

public virtual Boolean IsNew {get;}

See Also

Filter Class | Borland.StarTeam Namespace


IsPublic Property

Borland StarTeam SDK for .NET

Filter.IsPublic Property

[read]

public virtual Boolean IsPublic {get;}

See Also

Filter Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Filter.Name Property

[read/write]

public virtual String Name {get; set;}

See Also

Filter Class | Borland.StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

Filter.ParentContainer Property

public virtual ISecurableContainer ParentContainer {get;}

Implements

ISecurable.ParentContainer

See Also

Filter Class | Borland.StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Filter.Properties Property

[read] an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.

public virtual PropertyCollection Properties {get;}

Property Value

an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.

See Also

Filter Class | Borland.StarTeam Namespace


QueryID Property

Borland StarTeam SDK for .NET

Filter.QueryID Property

[read/write]

public virtual Int32 QueryID {get; set;}

See Also

Filter Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

Filter.Type Property

public virtual Type Type {get;}

Implements

ISecurable.Type

See Also

Filter Class | Borland.StarTeam Namespace


UserID Property

Borland StarTeam SDK for .NET

Filter.UserID Property

[read]

public virtual Int32 UserID {get;}

See Also

Filter Class | Borland.StarTeam Namespace


Filter Methods

The methods of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Filter.

Public Instance Methods

AppendColumn | A convenience method to add a new column at the end of the column list.
AppendGroupSortInfo |
ClearColumns | A convenience method to remove all column display information.
ClearGroupSortInfo | A convenience method to remove all sort and group information.
Copy | Creates a copy of this Filter object. Useful to applications that want to save a snapshot of the filter in a given state, for example, before calling Type.refreshFiltersAndQueries(). The copied filter will have the same parent Type as the original property. The Type object is not copied.
Delete |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission |
IsEqualTo | Compares two Filter objects.
MakePublic |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update |

See Also

Filter Class | Borland.StarTeam Namespace


Filter.AppendColumn Method

A convenience method to add a new column at the end of the column list.

public virtual void AppendColumn(
String propertyName,
Int32 pixelWidth
);

Parameters

propertyName
pixelWidth

See Also

Filter Class | Borland.StarTeam Namespace


Filter.AppendGroupSortInfo Method

public virtual void AppendGroupSortInfo(
Boolean group,
String propertyName,
Boolean ascending
);

Parameters

group
propertyName
ascending

See Also

Filter Class | Borland.StarTeam Namespace


Filter.ClearColumns Method

A convenience method to remove all column display information.

public virtual void ClearColumns();

See Also

Filter Class | Borland.StarTeam Namespace


Filter.ClearGroupSortInfo Method

A convenience method to remove all sort and group information.

public virtual void ClearGroupSortInfo();

See Also

Filter Class | Borland.StarTeam Namespace


Filter.Copy Method

Creates a copy of this Filter object. Useful to applications that want to save a snapshot of the filter in a given state, for example, before calling Type.refreshFiltersAndQueries().

The copied filter will have the same parent Type as the original property. The Type object is not copied.

public virtual Filter Copy();

Return Value

A copy of this Filter object.

See Also

Filter Class | Borland.StarTeam Namespace | isEqualTo


Filter.Delete Method

public virtual void Delete();

See Also

Filter Class | Borland.StarTeam Namespace


Filter.HasPermission Method

public virtual bool HasPermission(
Int32 permissions
);

Implements

ISecurable.HasPermission

See Also

Filter Class | Borland.StarTeam Namespace


Filter.IsEqualTo Method

Compares two Filter objects.

public virtual bool IsEqualTo(
Filter filter
);

Parameters

filter
The Filter to be compared with this one.

Return Value

true if no differences were found.

See Also

Filter Class | Borland.StarTeam Namespace | copy


Filter.MakePublic Method

public virtual void MakePublic();

See Also

Filter Class | Borland.StarTeam Namespace


Filter.Update Method

public virtual void Update();

See Also

Filter Class | Borland.StarTeam Namespace


Filter.Wrap Method

Dynamically wraps com.starbase.starteam.Filter.

public static Filter Wrap(
Filter impl
);

Parameters

impl
com.starbase.starteam.Filter to be wrapped.

Return Value

Filter

See Also

Filter Class | Borland.StarTeam Namespace


Filter Type Conversions

The type conversions of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Static Type Conversions

Implicit Filter to Filter Conversion Implicitly convert Filter to com.starbase.starteam.Filter.

See Also

Filter Class | Filter Members | Borland.StarTeam Namespace


Filter Implicit Filter to Filter Conversion

Implicitly convert Filter to com.starbase.starteam.Filter.

public static implicit operator Filter(
Filter arg
);

Parameters

arg
Filter to convert.

Return Value

com.starbase.starteam.Filter

See Also

Filter Class | Borland.StarTeam Namespace


FilterCollection Class

A strongly-typed collection of Filters.

For a list of all members of this type, see FilterCollection Members.

System.Object
ArrayAdapter
FilterCollection

public class FilterCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FilterCollection Members | Borland.StarTeam Namespace


FilterCollection Members

FilterCollection overview

Public Static Methods

Wrap Creates a FilterCollection to represent the given array of Filter (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit FilterCollection to Filter[] Conversion | Converts a FilterCollection to an array of Filters.
Implicit FilterCollection to Filter[] Conversion | Converts a FilterCollection from the Borland.StarTeam namespace to a Filter[] in the com.starbase.starteam namespace.

Public Instance Constructors

FilterCollection Overloaded. Initializes a new instance of the FilterCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Filter at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Filter to end of the collection.
Append | Overloaded. Appends the Filters of the given FilterCollection to the end of this FilterCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Filter.
CopyTo | Copies all of the Filters in the FilterCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Filter with the given ID.
FindByName | Finds the Filter with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Filter in the collection.
Insert | Inserts a Filter into the collection at the specified position.
Remove | Removes the first occurrence of a specific Filter from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Filters in this FilterCollection.
Sort | Sorts the Filters in this FilterCollection, using the given comparer.
SortByID | Sorts the Filters in this FilterCollection by ID.
SortByName | Sorts the Filters in this FilterCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection Constructor

Initializes an instance of the FilterCollection class.

Overload List

Initializes an instance of the FilterCollection class.

public FilterCollection();

Initializes an instance of the a FilterCollection class, copying the given array.

public FilterCollection(Filter[]);

Initializes an instance of the a FilterCollection class, copying the given collection.

public FilterCollection(FilterCollection);

Initializes an instance of the a FilterCollection class, wrapping the given array of Filter (from the com.starbase.starteam namespace).

public FilterCollection(Filter[]);

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection Constructor ()

Initializes an instance of the FilterCollection class.

public FilterCollection();

See Also

FilterCollection Class | Borland.StarTeam Namespace | FilterCollection Constructor Overload List


FilterCollection Constructor (Filter[])

Initializes an instance of the a FilterCollection class, wrapping the given array of Filter (from the com.starbase.starteam namespace).

public FilterCollection(
Filter[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

FilterCollection Class | Borland.StarTeam Namespace | FilterCollection Constructor Overload List | Wrap


FilterCollection Constructor (FilterCollection)

Initializes an instance of the a FilterCollection class, copying the given collection.

public FilterCollection(
FilterCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Filter objects of the original collection are shared, not copied.

See Also

FilterCollection Class | Borland.StarTeam Namespace | FilterCollection Constructor Overload List


FilterCollection Constructor (Filter[])

Initializes an instance of the a FilterCollection class, copying the given array.

public FilterCollection(
Filter[] array
);

Parameters

array
The array to be copied.

Remarks

The member Filter objects of the original array are shared, not copied.

See Also

FilterCollection Class | Borland.StarTeam Namespace | FilterCollection Constructor Overload List


FilterCollection Properties

The properties of the FilterCollection class are listed below. For a complete list of FilterCollection class members, see the FilterCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Filter at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FilterCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

FilterCollection.Item Property

Gets or sets the Filter at the specified index.

Overload List

Gets or sets the Filter at the specified index.

public Filter this[Int32] {get; set;}

Gets the Filter with the given name.

public Filter this[String] {get;}

See Also

FilterCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

FilterCollection.Item Property (Int32)

Gets or sets the Filter at the specified index.

public Filter this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Filter to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

FilterCollection Class | Borland.StarTeam Namespace | FilterCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

FilterCollection.Item Property (String)

Gets the Filter with the given name.

public Filter this[
String name
] {get;}

Parameters

name
The name of the Filter to get.

Property Value

The Filter with the given name, or null if there is no Filter with that name in this FilterCollection. Comparison is case sensitive.

See Also

FilterCollection Class | Borland.StarTeam Namespace | FilterCollection.Item Overload List | FindByName


FilterCollection Methods

The methods of the FilterCollection class are listed below. For a complete list of FilterCollection class members, see the FilterCollection Members topic.

Public Static Methods

Wrap Creates a FilterCollection to represent the given array of Filter (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a Filter to end of the collection.
Append | Overloaded. Appends the Filters of the given FilterCollection to the end of this FilterCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Filter.
CopyTo | Copies all of the Filters in the FilterCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Filter with the given ID.
FindByName | Finds the Filter with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Filter in the collection.
Insert | Inserts a Filter into the collection at the specified position.
Remove | Removes the first occurrence of a specific Filter from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Filters in this FilterCollection.
Sort | Sorts the Filters in this FilterCollection, using the given comparer.
SortByID | Sorts the Filters in this FilterCollection by ID.
SortByName | Sorts the Filters in this FilterCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.Add Method

Adds a Filter to end of the collection.

public int Add(
Filter value
);

Parameters

value
The Filter to add to the collection.

Return Value

The position into which the new Filter was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

FilterCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

FilterCollection.Append Method

Appends the Filters of the given array to the end of this FilterCollection.

Overload List

Appends the Filters of the given array to the end of this FilterCollection.

public FilterCollection Append(Filter[]);

Appends the Filters of the given FilterCollection to the end of this FilterCollection.

public FilterCollection Append(FilterCollection);

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.Append Method (Filter[])

Appends the Filters of the given array to the end of this FilterCollection.

public FilterCollection Append(
Filter[] array
);

Parameters

array
The array whose Filters are to be appended to this FilterCollection.

Return Value

This FilterCollection, modified to include the new Filters.

Remarks

The FilterCollection is modified to include the new members. The individual Filter objects are shared, not copied.

See Also

FilterCollection Class | Borland.StarTeam Namespace | FilterCollection.Append Overload List


FilterCollection.Append Method (FilterCollection)

Appends the Filters of the given FilterCollection to the end of this FilterCollection.

public FilterCollection Append(
FilterCollection collection
);

Parameters

collection
The FilterCollection whose Filters are to be appended to this FilterCollection.

Return Value

This FilterCollection, modified to include the new Filters.

Remarks

The FilterCollection is modified to include the new members. The individual Filter objects are shared, not copied.

See Also

FilterCollection Class | Borland.StarTeam Namespace | FilterCollection.Append Overload List


FilterCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.Filter[].

Implements

IWrapper.Unwrap

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.Contains Method

Determines whether or not the collection contains a specific Filter.

public bool Contains(
Filter value
);

Parameters

value
The Filter to locate in the collection.

Return Value

true if the Filter is found in the collection; otherwise, false.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.CopyTo Method

Copies all of the Filters in the FilterCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Filter[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Filters copied from the FilterCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Filters in the source FilterCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source FilterCollection cannot be cast automatically to the type of the destination array.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.FindByID Method

Finds the Filter with the given ID.

public Filter FindByID(
Int32 id
);

Parameters

id
The ID of the Filter to be found.

Return Value

The Filter with the given ID, or null if there is no Filter with that ID in this FilterCollection.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.FindByName Method

Finds the Filter with the given name.

public Filter FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the Filter to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The Filter with the given name, or null if there is no Filter with that name in this FilterCollection.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.IndexOf Method

Determines the index of a specific Filter in the collection.

public int IndexOf(
Filter value
);

Parameters

value
The Filter to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.Insert Method

Inserts a Filter into the collection at the specified position.

public void Insert(
Int32 index,
Filter value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Filter to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.Remove Method

Removes the first occurrence of a specific Filter from the collection.

public void Remove(
Filter value
);

Parameters

value
The Filter to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.Reverse Method

Reverses the order of the Filters in this FilterCollection.

new public FilterCollection Reverse();

Return Value

This FilterCollection, modified such that the Filters are reversed.

Remarks

The FilterCollection is modified in place.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.Sort Method

Sorts the Filters in this FilterCollection, using the given comparer.

new public FilterCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Filters.

Return Value

This FilterCollection, modified such that the Filters are sorted.

Remarks

The FilterCollection is modified in place.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.SortByID Method

Sorts the Filters in this FilterCollection by ID.

public FilterCollection SortByID();

Return Value

This FilterCollection, modified such that the Filters are sorted by ID.

Remarks

The FilterCollection is modified in place.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.SortByName Method

Sorts the Filters in this FilterCollection by name.

public FilterCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This FilterCollection, modified such that the Filters are sorted by name.

Remarks

The FilterCollection is modified in place.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection.Wrap Method

Creates a FilterCollection to represent the given array of Filter (from the com.starbase.starteam namespace).

public static FilterCollection Wrap(
Filter[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new FilterCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a Filter[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection Type Conversions

The type conversions of the FilterCollection class are listed below. For a complete list of FilterCollection class members, see the FilterCollection Members topic.

Public Static Type Conversions

Implicit FilterCollection to Filter[] Conversion | Converts a FilterCollection to an array of Filters.
Implicit FilterCollection to Filter[] Conversion | Converts a FilterCollection from the Borland.StarTeam namespace to a Filter[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FilterCollection Class | FilterCollection Members | Borland.StarTeam Namespace


FilterCollection Implicit FilterCollection to Filter[] Conversion

Converts a FilterCollection to an array of Filters.

public static implicit operator Filter[](
FilterCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Filter wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Filter wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterCollection Implicit FilterCollection to Filter[] Conversion

Converts a FilterCollection from the Borland.StarTeam namespace to a Filter[] in the com.starbase.starteam namespace.

public static implicit operator Filter[](
FilterCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, FilterCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

FilterCollection Class | Borland.StarTeam Namespace


FilterEventArgs Class

For a list of all members of this type, see FilterEventArgs Members.

System.Object
EventArgs
FilterEventArgs

public class FilterEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FilterEventArgs Members | Borland.StarTeam Namespace


FilterEventArgs Members

FilterEventArgs overview

Public Static Type Conversions

Implicit FilterEventArgs to FilterEvent Conversion Implicitly convert FilterEventArgs to com.starbase.starteam.FilterEvent.

Public Instance Properties

Filter [read] The Filter that has been added, changed or deleted, in its new state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

FilterEventArgs Class | Borland.StarTeam Namespace


FilterEventArgs Properties

The properties of the FilterEventArgs class are listed below. For a complete list of FilterEventArgs class members, see the FilterEventArgs Members topic.

Public Instance Properties

Filter [read] The Filter that has been added, changed or deleted, in its new state.

See Also

FilterEventArgs Class | Borland.StarTeam Namespace


Filter Property

Borland StarTeam SDK for .NET

FilterEventArgs.Filter Property

[read] The Filter that has been added, changed or deleted, in its new state.

public virtual Filter Filter {get;}

Property Value

The Filter that has been added, changed or deleted, in its new state.

See Also

FilterEventArgs Class | Borland.StarTeam Namespace


FilterEventArgs Methods

The methods of the FilterEventArgs class are listed below. For a complete list of FilterEventArgs class members, see the FilterEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

FilterEventArgs Class | Borland.StarTeam Namespace


FilterEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

FilterEventArgs Class | Borland.StarTeam Namespace


FilterEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

FilterEventArgs Class | Borland.StarTeam Namespace


FilterEventArgs.ToString Method

public override string ToString();

See Also

FilterEventArgs Class | Borland.StarTeam Namespace


FilterEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

FilterEventArgs Class | Borland.StarTeam Namespace


FilterEventArgs Type Conversions

The type conversions of the FilterEventArgs class are listed below. For a complete list of FilterEventArgs class members, see the FilterEventArgs Members topic.

Public Static Type Conversions

Implicit FilterEventArgs to FilterEvent Conversion Implicitly convert FilterEventArgs to com.starbase.starteam.FilterEvent.

See Also

FilterEventArgs Class | FilterEventArgs Members | Borland.StarTeam Namespace


FilterEventArgs Implicit FilterEventArgs to FilterEvent Conversion

Implicitly convert FilterEventArgs to com.starbase.starteam.FilterEvent.

public static implicit operator FilterEvent(
FilterEventArgs arg
);

Parameters

arg
FilterEventArgs to convert.

Return Value

com.starbase.starteam.FilterEvent

See Also

FilterEventArgs Class | Borland.StarTeam Namespace


FilterEventSource Class

For a list of all members of this type, see FilterEventSource Members.

System.Object
FilterEventSource

public class FilterEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FilterEventSource Members | Borland.StarTeam Namespace


FilterEventSource Members

FilterEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

FilterAdded
FilterChanged
FilterDeleted
OnFilterAdded
OnFilterChanged
OnFilterDeleted

See Also

FilterEventSource Class | Borland.StarTeam Namespace


FilterEventSource Properties

The properties of the FilterEventSource class are listed below. For a complete list of FilterEventSource class members, see the FilterEventSource Members topic.

Public Instance Properties

Parent

See Also

FilterEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

FilterEventSource.Parent Property

public Object Parent {get;}

See Also

FilterEventSource Class | Borland.StarTeam Namespace


FilterEventSource Events

The events of the FilterEventSource class are listed below. For a complete list of FilterEventSource class members, see the FilterEventSource Members topic.

Public Instance Events

FilterAdded
FilterChanged
FilterDeleted
OnFilterAdded
OnFilterChanged
OnFilterDeleted

See Also

FilterEventSource Class | Borland.StarTeam Namespace


FilterEventSource.FilterAdded Event

public event FilterEventSource.Handler FilterAdded;

See Also

FilterEventSource Class | Borland.StarTeam Namespace


FilterEventSource.FilterChanged Event

public event FilterEventSource.Handler FilterChanged;

See Also

FilterEventSource Class | Borland.StarTeam Namespace


FilterEventSource.FilterDeleted Event

public event FilterEventSource.Handler FilterDeleted;

See Also

FilterEventSource Class | Borland.StarTeam Namespace


FilterEventSource.OnFilterAdded Event

public event FilterEventSource.Handler OnFilterAdded;

See Also

FilterEventSource Class | Borland.StarTeam Namespace


FilterEventSource.OnFilterChanged Event

public event FilterEventSource.Handler OnFilterChanged;

See Also

FilterEventSource Class | Borland.StarTeam Namespace


FilterEventSource.OnFilterDeleted Event

public event FilterEventSource.Handler OnFilterDeleted;

See Also

FilterEventSource Class | Borland.StarTeam Namespace


FilterEventSource.Handler Delegate

public delegate void FilterEventSource.Handler(
FilterEventSource source,
FilterEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


Folder Class

Represents a StarTeam Folder.

For a list of all members of this type, see Folder Members.

System.Object
TypedResource
SimpleTypedResource
Item
Folder
VCMFolder

public class Folder : Item, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Folder Members | Borland.StarTeam Namespace


Folder Members

Folder overview

Public Static Properties

EOL_CR
EOL_CRLF
EOL_LF
EXCLUDE_INHERIT
EXCLUDE_LOCAL
EXCLUDE_NONE

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Folder.

Public Static Type Conversions

Implicit Folder to Folder Conversion Implicitly convert Folder to com.starbase.starteam.Folder.

Public Instance Constructors

Folder Overloaded. Initializes a new instance of the Folder class.

Public Instance Properties

ACL (inherited from Item) |
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AlternatePathFragment | [read/write] the alternate or overridden working path for this folder.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
CaseSensitiveFileNames | [read] True if the names of files in this folder are case sensitive, and false otherwise.
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DefaultPathFragment | [read/write] this folder's specified working path.
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
Description | [read/write] the description of this folder.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
EffectiveExcludeList | [read] the fully resolved exclude list for this folder.
EffectiveUserVisible | [read]
ExcludeFlags | [read/write] the exclude type being used for this folder's exclude list
ExcludeList | [read/write] the portion of the exclude list that this folder contributes.
FileEOL | [read] The end-of-line character sequence to be used for text files in this folder.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
FolderHierarchy | [read] The fully-qualified name of this folder.
HasParentFolder | [read] true if this folder has a parent folder.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
Name | [read/write] the name of the folder.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotInViewFiles | [read] an array of "not in view" File objects in this Folder, applying exclusions as appropriate.
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
Path | [read] the local working file path being used for this folder.
PathFragment | [read] the path fragment to use for this folder.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
QualifiedName | [read] The fully-qualified name of this folder.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
SubFolderCount | [read] the number of sub folders for this folder.
SubFolders | [read] the subfolders of this folder. Will not return null but may return an empty array if the folder has no subfolders.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
UserVisible | [read/write]
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.

Public Instance Methods

AcquireOwnership (inherited from Item)
Add | Adds the specified item to this folder. The added item will still exist in its original folder as well as in this one.
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CopyFolderTree | Copies a folder tree. Does not populate any properties or copy any cached items.
CountItems | Returns a count of the number of items (of a given type) reachable from this folder to the given depth
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardItems | Discards cached items of the specified type in this folder. Subsequent calls to getItems will re-fetch the items from the server (even when MPX is enabled).
EnumerateItems | Returns an Enumeration of the items of the specified type that exist in this folder.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContainerLevelACL
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFilePath | For a given file name, this method returns the concatenation of the file name and the working directory path of this folder.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFolderTree | Retrieves a copy of this Folder object in the specified context and depth.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetItems | Ensures that the list of items of the specified type for this folder have been retrieved from the server and cached locally. The list of items is retrieved from the server only if it has not already been retrieved. Therefore, the list of items may or may not be up-to-date with respect to the latest information on the server. To ensure that the list is up-to-date, use refresh(). getItems() does not retrieve any item properties. To ensure that a specific set of properties is avaliable, use populateNow().
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Overloaded.
HasPermission (inherited from Item) | Overloaded.
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsExcluded | Determines if the given file name is one that will be excluded (matcthes the exclude list criteria) from operations in the working directory. Most StarTeam clients make use of a folder's exclude list by not allowing excluded files to be added to the repository. Nothing in the StarTeam SDK prevents any file being added to a repository it must be implemented as specific client-side logic. For example, the StarTeam GUI will not display any excluded files whose status is "Not In View" in the list control.
IsPopulated | Determines whether or not this folder's items have been populated.
IsRefreshItemsRequired Determines whether or not the items of the given type need to be refreshed. A refresh is required if the cached items are not known to be up-to-date with respect to the latest information in the repository. Specifically, a refresh is required if:
  • MPX is not enabled, or
  • At least one new item has been added since the last refresh, or
  • At least one item has been deleted since the last refresh, or
  • The value of one or more of the specified properties is not yet known for at least one of the items, or
  • The properties of at least one item have changed since the last refresh.
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
NewFolderEventSource
NewFolderTreeEventSource
NewFolderUpdateEventSource
NewItemEventSource | Overloaded.
NewItemIDEventSource | Overloaded.
NewItemListEventSource | Overloaded.
NewItemUpdateEventSource
NewNotificationEventSource | Overloaded.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
PopulateInBackground | Similar to populateNow(). Items are populated in a background thread.
PopulateNow | Ensures that the items of the specified type have been retrieved from the server and cached locally. Also ensures that the specified properties have been retrieved for each item. populateNow() does not retrieve any items or properties that have already been cached. Therefore, the item and property information may or may not be up-to-date with respect to the latest information on the server. To ensure that the item and property information is up-to-date, use refresh(). When an application attempts to access the value of a given property of an item, and that property has not yet been retrieved from the server, a command is issued to the server to retrieve all the properties of that item and cache them locally. For applications that examine many items, it is much more efficient to populate all the required properties up front, using populateNow(). It is sometimes difficult to determine exactly which item properties are used by a given application. If performance problems cause you to suspect that there is a property that has not been populated correctly, you can use NetMonitor to help diagnose the problem. If accessing a specific item property results in a fetch from the server, NetMonitor will display a message indicating which property caused the fetch.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshForeignFiles | Refresh the foreign files in this folder, and its child folders depending on the specified "depth."
RefreshItems | Ensures that the latest list of items of the specified type for this folder has been retrieved from the server and cached locally. Also ensures that the latest values of the specified properties have been retrieved for each item. refreshItems() is similar to populateNow(). However, refreshItems() ensures that the list of items and the properties of each item are up-to-date with respect to the latest information on the server. refreshItems() re-uses existing Item objects whenever possible, changing cached property values as necessary to bring older Items up-to-date. When MPX is enabled, refreshItems() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo | Overloaded. Reverse shares this folder to a new parent folder. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetContainerLevelACL
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo | Overloaded. Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ShareTo (inherited from Item) | Overloaded. Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateFolderTree | Calls update() on itself, and recursively calls Folder.updateAllFolders() on Folders returned from getSubFolders().
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Folder Class | Borland.StarTeam Namespace


Folder Constructor

Construct Folder from com.starbase.starteam.Folder.

Overload List

Creates a new folder specifying in which folder it is to reside. Note that a valid name is required prior to update.

public Folder(Folder);

Creates a new folder specifying in which folder it is to reside, its name and its working path relative to the working path of its parent folder.

public Folder(Folder,String,String);

Special constructor for the root folder of a view, to be used during the creation of a project. NOTE that this needs to remain public because it's used in the COM API for CreateProjectEx().

public Folder(Server);

Construct Folder from com.starbase.starteam.Folder.

public Folder(Folder);

See Also

Folder Class | Borland.StarTeam Namespace


Folder Constructor (Folder)

Construct Folder from com.starbase.starteam.Folder.

public Folder(
Folder impl
);

Parameters

impl
The com.starbase.starteam.Folder to be wrapped.

See Also

Folder Class | Borland.StarTeam Namespace | Folder Constructor Overload List


Folder Constructor (Server)

Special constructor for the root folder of a view, to be used during the creation of a project. NOTE that this needs to remain public because it's used in the COM API for CreateProjectEx().

public Folder(
Server server
);

Parameters

server

See Also

Folder Class | Borland.StarTeam Namespace | Folder Constructor Overload List


Folder Constructor (Folder)

Creates a new folder specifying in which folder it is to reside. Note that a valid name is required prior to update.

public Folder(
Folder parent
);

Parameters

parent
the parent folder in which this new folder will reside.

See Also

Folder Class | Borland.StarTeam Namespace | Folder Constructor Overload List


Folder Constructor (Folder, String, String)

Creates a new folder specifying in which folder it is to reside, its name and its working path relative to the working path of its parent folder.

public Folder(
Folder parent,
String name,
String workingFolder
);

Parameters

parent
the parent folder in which this new folder will reside.
name
the name of this folder.
workingFolder
the working path for this folder, relative to its parent's working path.

See Also

Folder Class | Borland.StarTeam Namespace | Folder Constructor Overload List


Folder Properties

The properties of the Folder class are listed below. For a complete list of Folder class members, see the Folder Members topic.

Public Static Properties

EOL_CR
EOL_CRLF
EOL_LF
EXCLUDE_INHERIT
EXCLUDE_LOCAL
EXCLUDE_NONE

Public Instance Properties

ACL (inherited from Item) |
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AlternatePathFragment | [read/write] the alternate or overridden working path for this folder.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
CaseSensitiveFileNames | [read] True if the names of files in this folder are case sensitive, and false otherwise.
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DefaultPathFragment | [read/write] this folder's specified working path.
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
Description | [read/write] the description of this folder.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
EffectiveExcludeList | [read] the fully resolved exclude list for this folder.
EffectiveUserVisible | [read]
ExcludeFlags | [read/write] the exclude type being used for this folder's exclude list
ExcludeList | [read/write] the portion of the exclude list that this folder contributes.
FileEOL | [read] The end-of-line character sequence to be used for text files in this folder.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
FolderHierarchy | [read] The fully-qualified name of this folder.
HasParentFolder | [read] true if this folder has a parent folder.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
Name | [read/write] the name of the folder.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotInViewFiles | [read] an array of "not in view" File objects in this Folder, applying exclusions as appropriate.
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
Path | [read] the local working file path being used for this folder.
PathFragment | [read] the path fragment to use for this folder.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
QualifiedName | [read] The fully-qualified name of this folder.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
SubFolderCount | [read] the number of sub folders for this folder.
SubFolders | [read] the subfolders of this folder. Will not return null but may return an empty array if the folder has no subfolders.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
UserVisible | [read/write]
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Folder Class | Borland.StarTeam Namespace


AlternatePathFragment Property

Borland StarTeam SDK for .NET

Folder.AlternatePathFragment Property

[read/write] the alternate or overridden working path for this folder.

public virtual String AlternatePathFragment {get; set;}

Property Value

the alternate or overridden working path for this folder.

See Also

Folder Class | Borland.StarTeam Namespace


CaseSensitiveFileNames Property

Borland StarTeam SDK for .NET

Folder.CaseSensitiveFileNames Property

[read] True if the names of files in this folder are case sensitive, and false otherwise.

public virtual Boolean CaseSensitiveFileNames {get;}

Property Value

True if the names of files in this folder are case sensitive, and false otherwise.

See Also

Folder Class | Borland.StarTeam Namespace


DefaultPathFragment Property

Borland StarTeam SDK for .NET

Folder.DefaultPathFragment Property

[read/write] this folder's specified working path.

public virtual String DefaultPathFragment {get; set;}

Property Value

this folder's specified working path.

See Also

Folder Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Folder.Description Property

[read/write] the description of this folder.

public virtual String Description {get; set;}

Property Value

the description of this folder.

See Also

Folder Class | Borland.StarTeam Namespace


EffectiveExcludeList Property

Borland StarTeam SDK for .NET

Folder.EffectiveExcludeList Property

[read] the fully resolved exclude list for this folder.

public virtual String EffectiveExcludeList {get;}

Property Value

the fully resolved exclude list for this folder.

See Also

Folder Class | Borland.StarTeam Namespace


EffectiveUserVisible Property

Borland StarTeam SDK for .NET

Folder.EffectiveUserVisible Property

[read]

public virtual Boolean EffectiveUserVisible {get;}

See Also

Folder Class | Borland.StarTeam Namespace


EOL_CR Property

Borland StarTeam SDK for .NET

Folder.EOL_CR Property

public static String EOL_CR {get;}

See Also

Folder Class | Borland.StarTeam Namespace


EOL_CRLF Property

Borland StarTeam SDK for .NET

Folder.EOL_CRLF Property

public static String EOL_CRLF {get;}

See Also

Folder Class | Borland.StarTeam Namespace


EOL_LF Property

Borland StarTeam SDK for .NET

Folder.EOL_LF Property

public static String EOL_LF {get;}

See Also

Folder Class | Borland.StarTeam Namespace


EXCLUDE_INHERIT Property

Borland StarTeam SDK for .NET

Folder.EXCLUDE_INHERIT Property

public static Int32 EXCLUDE_INHERIT {get;}

See Also

Folder Class | Borland.StarTeam Namespace


EXCLUDE_LOCAL Property

Borland StarTeam SDK for .NET

Folder.EXCLUDE_LOCAL Property

public static Int32 EXCLUDE_LOCAL {get;}

See Also

Folder Class | Borland.StarTeam Namespace


EXCLUDE_NONE Property

Borland StarTeam SDK for .NET

Folder.EXCLUDE_NONE Property

public static Int32 EXCLUDE_NONE {get;}

See Also

Folder Class | Borland.StarTeam Namespace


ExcludeFlags Property

Borland StarTeam SDK for .NET

Folder.ExcludeFlags Property

[read/write] the exclude type being used for this folder's exclude list

public virtual Int32 ExcludeFlags {get; set;}

Property Value

the exclude type being used for this folder's exclude list

See Also

Folder Class | Borland.StarTeam Namespace


ExcludeList Property

Borland StarTeam SDK for .NET

Folder.ExcludeList Property

[read/write] the portion of the exclude list that this folder contributes.

public virtual String ExcludeList {get; set;}

Property Value

the portion of the exclude list that this folder contributes.

See Also

Folder Class | Borland.StarTeam Namespace


FileEOL Property

Borland StarTeam SDK for .NET

Folder.FileEOL Property

[read] The end-of-line character sequence to be used for text files in this folder.

public virtual String FileEOL {get;}

Property Value

The end-of-line character sequence to be used for text files in this folder.

See Also

Folder Class | Borland.StarTeam Namespace


FolderHierarchy Property

Borland StarTeam SDK for .NET

Folder.FolderHierarchy Property

[read] The fully-qualified name of this folder.

public virtual String FolderHierarchy {get;}

Property Value

The fully-qualified name of this folder.

See Also

Folder Class | Borland.StarTeam Namespace


HasParentFolder Property

Borland StarTeam SDK for .NET

Folder.HasParentFolder Property

[read] true if this folder has a parent folder.

public virtual Boolean HasParentFolder {get;}

Property Value

true if this folder has a parent folder.

See Also

Folder Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Folder.Name Property

[read/write] the name of the folder.

public virtual String Name {get; set;}

Property Value

the name of the folder.

See Also

Folder Class | Borland.StarTeam Namespace


NotInViewFiles Property

Borland StarTeam SDK for .NET

Folder.NotInViewFiles Property

[read] an array of "not in view" File objects in this Folder, applying exclusions as appropriate.

public virtual FileCollection NotInViewFiles {get;}

Property Value

an array of "not in view" File objects in this Folder, applying exclusions as appropriate.

See Also

Folder Class | Borland.StarTeam Namespace


Path Property

Borland StarTeam SDK for .NET

Folder.Path Property

[read] the local working file path being used for this folder.

public virtual String Path {get;}

Property Value

the local working file path being used for this folder.

See Also

Folder Class | Borland.StarTeam Namespace


PathFragment Property

Borland StarTeam SDK for .NET

Folder.PathFragment Property

[read] the path fragment to use for this folder.

public virtual String PathFragment {get;}

Property Value

the path fragment to use for this folder.

See Also

Folder Class | Borland.StarTeam Namespace


QualifiedName Property

Borland StarTeam SDK for .NET

Folder.QualifiedName Property

[read] The fully-qualified name of this folder.

public virtual String QualifiedName {get;}

Property Value

The fully-qualified name of this folder.

See Also

Folder Class | Borland.StarTeam Namespace


SubFolderCount Property

Borland StarTeam SDK for .NET

Folder.SubFolderCount Property

[read] the number of sub folders for this folder.

public virtual Int32 SubFolderCount {get;}

Property Value

the number of sub folders for this folder.

See Also

Folder Class | Borland.StarTeam Namespace


SubFolders Property

Borland StarTeam SDK for .NET

Folder.SubFolders Property

[read] the subfolders of this folder. Will not return null but may return an empty array if the folder has no subfolders.

public virtual FolderCollection SubFolders {get;}

Property Value

the subfolders of this folder. Will not return null but may return an empty array if the folder has no subfolders.

See Also

Folder Class | Borland.StarTeam Namespace


UserVisible Property

Borland StarTeam SDK for .NET

Folder.UserVisible Property

[read/write]

public virtual Boolean UserVisible {get; set;}

See Also

Folder Class | Borland.StarTeam Namespace


Folder Methods

The methods of the Folder class are listed below. For a complete list of Folder class members, see the Folder Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Folder.

Public Instance Methods

AcquireOwnership (inherited from Item)
Add | Adds the specified item to this folder. The added item will still exist in its original folder as well as in this one.
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CopyFolderTree | Copies a folder tree. Does not populate any properties or copy any cached items.
CountItems | Returns a count of the number of items (of a given type) reachable from this folder to the given depth
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardItems | Discards cached items of the specified type in this folder. Subsequent calls to getItems will re-fetch the items from the server (even when MPX is enabled).
EnumerateItems | Returns an Enumeration of the items of the specified type that exist in this folder.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContainerLevelACL
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFilePath | For a given file name, this method returns the concatenation of the file name and the working directory path of this folder.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFolderTree | Retrieves a copy of this Folder object in the specified context and depth.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetItems | Ensures that the list of items of the specified type for this folder have been retrieved from the server and cached locally. The list of items is retrieved from the server only if it has not already been retrieved. Therefore, the list of items may or may not be up-to-date with respect to the latest information on the server. To ensure that the list is up-to-date, use refresh(). getItems() does not retrieve any item properties. To ensure that a specific set of properties is avaliable, use populateNow().
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Overloaded.
HasPermission (inherited from Item) | Overloaded.
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsExcluded | Determines if the given file name is one that will be excluded (matcthes the exclude list criteria) from operations in the working directory. Most StarTeam clients make use of a folder's exclude list by not allowing excluded files to be added to the repository. Nothing in the StarTeam SDK prevents any file being added to a repository it must be implemented as specific client-side logic. For example, the StarTeam GUI will not display any excluded files whose status is "Not In View" in the list control.
IsPopulated | Determines whether or not this folder's items have been populated.
IsRefreshItemsRequired Determines whether or not the items of the given type need to be refreshed. A refresh is required if the cached items are not known to be up-to-date with respect to the latest information in the repository. Specifically, a refresh is required if:
  • MPX is not enabled, or
  • At least one new item has been added since the last refresh, or
  • At least one item has been deleted since the last refresh, or
  • The value of one or more of the specified properties is not yet known for at least one of the items, or
  • The properties of at least one item have changed since the last refresh.
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
NewFolderEventSource
NewFolderTreeEventSource
NewFolderUpdateEventSource
NewItemEventSource | Overloaded.
NewItemIDEventSource | Overloaded.
NewItemListEventSource | Overloaded.
NewItemUpdateEventSource
NewNotificationEventSource | Overloaded.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
PopulateInBackground | Similar to populateNow(). Items are populated in a background thread.
PopulateNow | Ensures that the items of the specified type have been retrieved from the server and cached locally. Also ensures that the specified properties have been retrieved for each item. populateNow() does not retrieve any items or properties that have already been cached. Therefore, the item and property information may or may not be up-to-date with respect to the latest information on the server. To ensure that the item and property information is up-to-date, use refresh(). When an application attempts to access the value of a given property of an item, and that property has not yet been retrieved from the server, a command is issued to the server to retrieve all the properties of that item and cache them locally. For applications that examine many items, it is much more efficient to populate all the required properties up front, using populateNow(). It is sometimes difficult to determine exactly which item properties are used by a given application. If performance problems cause you to suspect that there is a property that has not been populated correctly, you can use NetMonitor to help diagnose the problem. If accessing a specific item property results in a fetch from the server, NetMonitor will display a message indicating which property caused the fetch.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshForeignFiles | Refresh the foreign files in this folder, and its child folders depending on the specified "depth."
RefreshItems | Ensures that the latest list of items of the specified type for this folder has been retrieved from the server and cached locally. Also ensures that the latest values of the specified properties have been retrieved for each item. refreshItems() is similar to populateNow(). However, refreshItems() ensures that the list of items and the properties of each item are up-to-date with respect to the latest information on the server. refreshItems() re-uses existing Item objects whenever possible, changing cached property values as necessary to bring older Items up-to-date. When MPX is enabled, refreshItems() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo | Overloaded. Reverse shares this folder to a new parent folder. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetContainerLevelACL
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo | Overloaded. Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ShareTo (inherited from Item) | Overloaded. Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateFolderTree | Calls update() on itself, and recursively calls Folder.updateAllFolders() on Folders returned from getSubFolders().
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Folder Class | Borland.StarTeam Namespace


Folder.Add Method

Adds the specified item to this folder. The added item will still exist in its original folder as well as in this one.

public virtual Item Add(
Item child
);

Parameters

child
the item to add to this folder

Return Value

the item object representing the newly added item

See Also

Folder Class | Borland.StarTeam Namespace | isDisembodied | shareTo | TreeItem


Folder.CopyFolderTree Method

Copies a folder tree. Does not populate any properties or copy any cached items.

public virtual Folder CopyFolderTree();

Return Value

A copy of this folder and its subfolders.

See Also

Folder Class | Borland.StarTeam Namespace | copy


Folder.CountItems Method

Returns a count of the number of items (of a given type) reachable from this folder to the given depth

public virtual long CountItems(
Type type,
Int32 depth
);

Parameters

type
Type the type of Item for which the count is to be retrieved
depth
int The number of levels deep in the folder tree that child folders should also be populated. A value of 0 causes only this folder to be populated. A positive value n will cause this folder and all subfolders up to n levels deeper to be populated. A negative value causes this folder and all subfolders to be populated.

Return Value

long the number of items reachable from here

See Also

Folder Class | Borland.StarTeam Namespace


Folder.DiscardItems Method

Discards cached items of the specified type in this folder. Subsequent calls to getItems will re-fetch the items from the server (even when MPX is enabled).

public virtual void DiscardItems(
String typeName,
Int32 depth
);

Parameters

typeName
The type of the items to be discarded.
depth
The number of levels deep in the folder tree that items should also be discarded. A value of 0 causes only the items in this folder to be discarded. A positive value n will cause the items in this folder and in all subfolders up to n levels deeper to be discarded. A negative value causes the items in this folder and in all subfolders to be discarded.

See Also

Folder Class | Borland.StarTeam Namespace | TypeNames | populateNow | refreshItems | isDisembodied | enableMPX


Folder.EnumerateItems Method

Returns an Enumeration of the items of the specified type that exist in this folder.

public virtual IEnumerator EnumerateItems(
String typeName
);

Parameters

typeName
the type name of the sub items of this folder.

Return Value

an Enumeration of the specified items in this folder.

See Also

Folder Class | Borland.StarTeam Namespace | isDisembodied | TypeNames


Folder.GetContainerLevelACL Method

public virtual ACL GetContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.GetContainerLevelACL

See Also

Folder Class | Borland.StarTeam Namespace


Folder.GetFilePath Method

For a given file name, this method returns the concatenation of the file name and the working directory path of this folder.

public virtual string GetFilePath(
String fileName
);

Parameters

fileName
the name of the local file.

Return Value

the full local working path to the specified file name

See Also

Folder Class | Borland.StarTeam Namespace


Folder.GetFolderTree Method

Retrieves a copy of this Folder object in the specified context and depth.

public virtual Folder GetFolderTree(
Int32 context,
Int32 depth
);

Parameters

context
one of these values: Filter.CONTEXT_SERVER, Filter.CONTEXT_LOCAL and Filter.CONTEXT_LOCAL_AND_SERVER.
depth
the depth of levels of Folders affected.

Return Value

a copy of this Folder object in the specified context and depth.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Folder Class | Borland.StarTeam Namespace | CONTEXT_SERVER | CONTEXT_LOCAL | CONTEXT_LOCAL_AND_SERVER | getSubFolders


Folder.GetItems Method

Ensures that the list of items of the specified type for this folder have been retrieved from the server and cached locally. The list of items is retrieved from the server only if it has not already been retrieved. Therefore, the list of items may or may not be up-to-date with respect to the latest information on the server. To ensure that the list is up-to-date, use refresh(). getItems() does not retrieve any item properties. To ensure that a specific set of properties is avaliable, use populateNow().

public virtual ItemCollection GetItems(
String typeName
);

Parameters

typeName
The type name of the items to be retrieved.

Return Value

The items of the specified type in this folder.

See Also

Folder Class | Borland.StarTeam Namespace | TypeNames | populateNow | isPopulated | refresh | isDisembodied


HasPermission Method

Borland StarTeam SDK for .NET

Folder.HasPermission Method

Overload List

Inherited from Item.

public virtual bool HasPermission(Int32);

public virtual bool HasPermission(Int32,String);

See Also

Folder Class | Borland.StarTeam Namespace


Folder.HasPermission Method (Int32, String)

public virtual bool HasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.HasPermission

See Also

Folder Class | Borland.StarTeam Namespace | Folder.HasPermission Overload List


Folder.IsExcluded Method

Determines if the given file name is one that will be excluded (matcthes the exclude list criteria) from operations in the working directory. Most StarTeam clients make use of a folder's exclude list by not allowing excluded files to be added to the repository. Nothing in the StarTeam SDK prevents any file being added to a repository it must be implemented as specific client-side logic. For example, the StarTeam GUI will not display any excluded files whose status is "Not In View" in the list control.

public virtual bool IsExcluded(
String filename
);

Parameters

filename
the name of the file to be checked for exclusion

Return Value

true if the specified file name should be considered as excluded from being added to the StarTeam repository/

See Also

Folder Class | Borland.StarTeam Namespace | resolveExcludeList


Folder.IsPopulated Method

Determines whether or not this folder's items have been populated.

public virtual bool IsPopulated(
String typeName
);

Parameters

typeName
The type of the items to be tested.

Return Value

true if the items of the given type have been populated in this folder; false if they have not yet been populated.

See Also

Folder Class | Borland.StarTeam Namespace | getItems


Folder.IsRefreshItemsRequired Method

Determines whether or not the items of the given type need to be refreshed. A refresh is required if the cached items are not known to be up-to-date with respect to the latest information in the repository. Specifically, a refresh is required if:

  • MPX is not enabled, or
  • At least one new item has been added since the last refresh, or
  • At least one item has been deleted since the last refresh, or
  • The value of one or more of the specified properties is not yet known for at least one of the items, or
  • The properties of at least one item have changed since the last refresh.

public virtual bool IsRefreshItemsRequired(
String typeName,
String[] propertyNames,
Int32 depth
);

Parameters

typeName
The type name of the items to be examined.
propertyNames
The names of the properties whose values are to be examined. Specifying null causes all properties to be examined. Specifying a client-calculated property causes all dependent properties to be examined.
depth
The number of levels deep in the folder tree that child folders should also be examined. A value of 0 causes only this folder to be examined. A positive value n will cause this folder and all subfolders up to n levels deeper to be examined. A negative value causes this folder and all subfolders to be examined.

Return Value

true if a refresh is required; false otherwise.

See Also

Folder Class | Borland.StarTeam Namespace | TypeNames | PropertyNames | refreshItems | isDisembodied | enableMPX


Folder.NewFolderEventSource Method

public FolderEventSource NewFolderEventSource(
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace


Folder.NewFolderTreeEventSource Method

public FolderTreeEventSource NewFolderTreeEventSource(
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace


Folder.NewFolderUpdateEventSource Method

public FolderUpdateEventSource NewFolderUpdateEventSource(
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace


NewItemEventSource Method

Borland StarTeam SDK for .NET

Folder.NewItemEventSource Method

Overload List

public ItemEventSource NewItemEventSource(Type,Int32);

public ItemEventSource NewItemEventSource(Type,String[],Int32);

See Also

Folder Class | Borland.StarTeam Namespace


Folder.NewItemEventSource Method (Type, Int32)

public ItemEventSource NewItemEventSource(
Type type,
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace | Folder.NewItemEventSource Overload List


Folder.NewItemEventSource Method (Type, String[], Int32)

public ItemEventSource NewItemEventSource(
Type type,
String[] propertyNames,
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace | Folder.NewItemEventSource Overload List


NewItemIDEventSource Method

Borland StarTeam SDK for .NET

Folder.NewItemIDEventSource Method

Overload List

public ItemIDEventSource NewItemIDEventSource(Type,Int32);

public ItemIDEventSource NewItemIDEventSource(Type,String[],Int32);

See Also

Folder Class | Borland.StarTeam Namespace


Folder.NewItemIDEventSource Method (Type, Int32)

public ItemIDEventSource NewItemIDEventSource(
Type type,
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace | Folder.NewItemIDEventSource Overload List


Folder.NewItemIDEventSource Method (Type, String[], Int32)

public ItemIDEventSource NewItemIDEventSource(
Type type,
String[] propertyNames,
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace | Folder.NewItemIDEventSource Overload List


NewItemListEventSource Method

Borland StarTeam SDK for .NET

Folder.NewItemListEventSource Method

Overload List

public ItemListEventSource NewItemListEventSource(Type,Int32);

public ItemListEventSource NewItemListEventSource(Type,String[],Int32);

See Also

Folder Class | Borland.StarTeam Namespace


Folder.NewItemListEventSource Method (Type, Int32)

public ItemListEventSource NewItemListEventSource(
Type type,
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace | Folder.NewItemListEventSource Overload List


Folder.NewItemListEventSource Method (Type, String[], Int32)

public ItemListEventSource NewItemListEventSource(
Type type,
String[] propertyNames,
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace | Folder.NewItemListEventSource Overload List


Folder.NewItemUpdateEventSource Method

public ItemUpdateEventSource NewItemUpdateEventSource(
Type type,
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace


NewNotificationEventSource Method

Borland StarTeam SDK for .NET

Folder.NewNotificationEventSource Method

Overload List

public NotificationEventSource NewNotificationEventSource(Type,Int32);

public NotificationEventSource NewNotificationEventSource(Type,String[],Int32);

See Also

Folder Class | Borland.StarTeam Namespace


Folder.NewNotificationEventSource Method (Type, Int32)

public NotificationEventSource NewNotificationEventSource(
Type type,
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace | Folder.NewNotificationEventSource Overload List


Folder.NewNotificationEventSource Method (Type, String[], Int32)

public NotificationEventSource NewNotificationEventSource(
Type type,
String[] propertyNames,
Int32 depth
);

See Also

Folder Class | Borland.StarTeam Namespace | Folder.NewNotificationEventSource Overload List


Folder.PopulateInBackground Method

Similar to populateNow(). Items are populated in a background thread.

public virtual void PopulateInBackground(
String typeName,
String[] propertyNames,
Int32 chunkSize
);

Parameters

typeName
The type name of the items to be retrieved.
propertyNames
The names of the properties whose values are to be retrieved. Specifying null causes all properties to be retrieved. Specifying a client-calculated property causes all dependent properties to be included.
chunkSize
Obsolete. chunkSize is ignored.

See Also

Folder Class | Borland.StarTeam Namespace | isDisembodied | TypeNames | PropertyNames | populateNow


Folder.PopulateNow Method

Ensures that the items of the specified type have been retrieved from the server and cached locally. Also ensures that the specified properties have been retrieved for each item.

populateNow() does not retrieve any items or properties that have already been cached. Therefore, the item and property information may or may not be up-to-date with respect to the latest information on the server. To ensure that the item and property information is up-to-date, use refresh().

When an application attempts to access the value of a given property of an item, and that property has not yet been retrieved from the server, a command is issued to the server to retrieve all the properties of that item and cache them locally. For applications that examine many items, it is much more efficient to populate all the required properties up front, using populateNow().

It is sometimes difficult to determine exactly which item properties are used by a given application. If performance problems cause you to suspect that there is a property that has not been populated correctly, you can use NetMonitor to help diagnose the problem. If accessing a specific item property results in a fetch from the server, NetMonitor will display a message indicating which property caused the fetch.

public virtual void PopulateNow(
String typeName,
String[] propertyNames,
Int32 depth
);

Parameters

typeName
The type name of the items to be retrieved.
propertyNames
The names of the properties whose values are to be retrieved. Specifying null causes all properties to be retrieved. Specifying a client-calculated property causes all dependent properties to be included.
depth
The number of levels deep in the folder tree that child folders should also be populated. A value of 0 causes only this folder to be populated. A positive value n will cause this folder and all subfolders up to n levels deeper to be populated. A negative value causes this folder and all subfolders to be populated.

See Also

Folder Class | Borland.StarTeam Namespace | TypeNames | PropertyNames | getItems | refresh | isDisembodied | NetMonitor


Folder.RefreshForeignFiles Method

Refresh the foreign files in this folder, and its child folders depending on the specified "depth."

public virtual ForeignRefreshResult RefreshForeignFiles(
Int32 depth
);

Parameters

depth
The depth of the folders to be refreshed: 0 = this folder only, -1 = full tree.

Return Value

The result from running this method as a ForeignRefreshResult object.

See Also

Folder Class | Borland.StarTeam Namespace | ForeignRefreshResult


Folder.RefreshItems Method

Ensures that the latest list of items of the specified type for this folder has been retrieved from the server and cached locally. Also ensures that the latest values of the specified properties have been retrieved for each item.

refreshItems() is similar to populateNow(). However, refreshItems() ensures that the list of items and the properties of each item are up-to-date with respect to the latest information on the server.

refreshItems() re-uses existing Item objects whenever possible, changing cached property values as necessary to bring older Items up-to-date.

When MPX is enabled, refreshItems() is optimized to avoid unnecessary server commands.

public virtual void RefreshItems(
String typeName,
String[] propertyNames,
Int32 depth
);

Parameters

typeName
The type name of the items to be refreshed.
propertyNames
The names of the properties whose values are to be refreshed. Specifying null causes all properties to be refreshed. Specifying a client-calculated property causes all dependent properties to be refreshed.
depth
The number of levels deep in the folder tree that child folders should also be refreshed. A value of 0 causes only this folder to be refreshed. A positive value n will cause this folder and all subfolders up to n levels deeper to be refreshed. A negative value causes this folder and all subfolders to be refreshed.

See Also

Folder Class | Borland.StarTeam Namespace | TypeNames | PropertyNames | getItems | populateNow | isRefreshItemsRequired | discardItems | isDisembodied | enableMPX


ReverseShareTo Method

Borland StarTeam SDK for .NET

Folder.ReverseShareTo Method

Reverse shares this folder to a new parent folder.

If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

Overload List

Inherited from Item.

public virtual Item ReverseShareTo(Folder);

Reverse shares this folder to a new parent folder. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

public virtual Folder ReverseShareTo(Folder,Boolean);

See Also

Folder Class | Borland.StarTeam Namespace | canShareFolderOnly | reverseShareTo


Folder.ReverseShareTo Method (Folder, Boolean)

Reverse shares this folder to a new parent folder.

If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

public virtual Folder ReverseShareTo(
Folder toFolder,
Boolean bThisFolderOnly
);

Parameters

toFolder
The new parent folder.
bThisFolderOnly
true to share this folder only; false to share this folder, all of its children to any depth, and all of the items contained within those folders.

Return Value

The folder object representing the newly shared folder.

See Also

Folder Class | Borland.StarTeam Namespace | Folder.ReverseShareTo Overload List | canShareFolderOnly | reverseShareTo


Folder.SetContainerLevelACL Method

public virtual void SetContainerLevelACL(
ACL acl,
String typeName
);

Implements

ISecurableContainer.SetContainerLevelACL

See Also

Folder Class | Borland.StarTeam Namespace


ShareTo Method

Borland StarTeam SDK for .NET

Folder.ShareTo Method

Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one.

If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

Overload List

Inherited from Item.

public virtual Item ShareTo(Folder);

Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

public virtual Folder ShareTo(Folder,Boolean);

See Also

Folder Class | Borland.StarTeam Namespace | canShareFolderOnly | shareTo


Folder.ShareTo Method (Folder, Boolean)

Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one.

If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

public virtual Folder ShareTo(
Folder toFolder,
Boolean bThisFolderOnly
);

Parameters

toFolder
The new parent folder.
bThisFolderOnly
true to share this folder only; false to share this folder, all of its children to any depth, and all of the items contained within those folders.

Return Value

The folder object representing the newly shared folder.

See Also

Folder Class | Borland.StarTeam Namespace | Folder.ShareTo Overload List | canShareFolderOnly | shareTo


Folder.UpdateFolderTree Method

Calls update() on itself, and recursively calls Folder.updateAllFolders() on Folders returned from getSubFolders().

public virtual void UpdateFolderTree(
Int32 depth
);

Parameters

depth
the depth of levels of Folders that's affected.

See Also

Folder Class | Borland.StarTeam Namespace | getSubFolders


Folder.Wrap Method

Dynamically wraps com.starbase.starteam.Folder.

public static Folder Wrap(
Folder impl
);

Parameters

impl
com.starbase.starteam.Folder to be wrapped.

Return Value

Folder

See Also

Folder Class | Borland.StarTeam Namespace


Folder Type Conversions

The type conversions of the Folder class are listed below. For a complete list of Folder class members, see the Folder Members topic.

Public Static Type Conversions

Implicit Folder to Folder Conversion Implicitly convert Folder to com.starbase.starteam.Folder.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Folder Class | Folder Members | Borland.StarTeam Namespace


Folder Implicit Folder to Folder Conversion

Implicitly convert Folder to com.starbase.starteam.Folder.

public static implicit operator Folder(
Folder arg
);

Parameters

arg
Folder to convert.

Return Value

com.starbase.starteam.Folder

See Also

Folder Class | Borland.StarTeam Namespace


FolderCollection Class

A strongly-typed collection of Folders.

For a list of all members of this type, see FolderCollection Members.

System.Object
ArrayAdapter
FolderCollection

public class FolderCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FolderCollection Members | Borland.StarTeam Namespace


FolderCollection Members

FolderCollection overview

Public Static Methods

Wrap Creates a FolderCollection to represent the given array of Folder (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit FolderCollection to Folder[] Conversion | Converts a FolderCollection to an array of Folders.
Implicit FolderCollection to Folder[] Conversion | Converts a FolderCollection from the Borland.StarTeam namespace to a Folder[] in the com.starbase.starteam namespace.

Public Instance Constructors

FolderCollection Overloaded. Initializes a new instance of the FolderCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Folder at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Folder to end of the collection.
Append | Overloaded. Appends the Folders of the given FolderCollection to the end of this FolderCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Folder.
CopyTo | Copies all of the Folders in the FolderCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Folder with the given ID.
FindByName | Finds the Folder with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Folder in the collection.
Insert | Inserts a Folder into the collection at the specified position.
Remove | Removes the first occurrence of a specific Folder from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Folders in this FolderCollection.
Sort | Sorts the Folders in this FolderCollection, using the given comparer.
SortByID | Sorts the Folders in this FolderCollection by ID.
SortByName | Sorts the Folders in this FolderCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection Constructor

Initializes an instance of the FolderCollection class.

Overload List

Initializes an instance of the FolderCollection class.

public FolderCollection();

Initializes an instance of the a FolderCollection class, copying the given array.

public FolderCollection(Folder[]);

Initializes an instance of the a FolderCollection class, copying the given collection.

public FolderCollection(FolderCollection);

Initializes an instance of the a FolderCollection class, wrapping the given array of Folder (from the com.starbase.starteam namespace).

public FolderCollection(Folder[]);

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection Constructor ()

Initializes an instance of the FolderCollection class.

public FolderCollection();

See Also

FolderCollection Class | Borland.StarTeam Namespace | FolderCollection Constructor Overload List


FolderCollection Constructor (Folder[])

Initializes an instance of the a FolderCollection class, wrapping the given array of Folder (from the com.starbase.starteam namespace).

public FolderCollection(
Folder[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

FolderCollection Class | Borland.StarTeam Namespace | FolderCollection Constructor Overload List | Wrap


FolderCollection Constructor (FolderCollection)

Initializes an instance of the a FolderCollection class, copying the given collection.

public FolderCollection(
FolderCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Folder objects of the original collection are shared, not copied.

See Also

FolderCollection Class | Borland.StarTeam Namespace | FolderCollection Constructor Overload List


FolderCollection Constructor (Folder[])

Initializes an instance of the a FolderCollection class, copying the given array.

public FolderCollection(
Folder[] array
);

Parameters

array
The array to be copied.

Remarks

The member Folder objects of the original array are shared, not copied.

See Also

FolderCollection Class | Borland.StarTeam Namespace | FolderCollection Constructor Overload List


FolderCollection Properties

The properties of the FolderCollection class are listed below. For a complete list of FolderCollection class members, see the FolderCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Folder at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FolderCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

FolderCollection.Item Property

Gets or sets the Folder at the specified index.

Overload List

Gets or sets the Folder at the specified index.

public Folder this[Int32] {get; set;}

Gets the Folder with the given name.

public Folder this[String] {get;}

See Also

FolderCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

FolderCollection.Item Property (Int32)

Gets or sets the Folder at the specified index.

public Folder this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Folder to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

FolderCollection Class | Borland.StarTeam Namespace | FolderCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

FolderCollection.Item Property (String)

Gets the Folder with the given name.

public Folder this[
String name
] {get;}

Parameters

name
The name of the Folder to get.

Property Value

The Folder with the given name, or null if there is no Folder with that name in this FolderCollection. Comparison is case sensitive.

See Also

FolderCollection Class | Borland.StarTeam Namespace | FolderCollection.Item Overload List | FindByName


FolderCollection Methods

The methods of the FolderCollection class are listed below. For a complete list of FolderCollection class members, see the FolderCollection Members topic.

Public Static Methods

Wrap Creates a FolderCollection to represent the given array of Folder (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a Folder to end of the collection.
Append | Overloaded. Appends the Folders of the given FolderCollection to the end of this FolderCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Folder.
CopyTo | Copies all of the Folders in the FolderCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Folder with the given ID.
FindByName | Finds the Folder with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Folder in the collection.
Insert | Inserts a Folder into the collection at the specified position.
Remove | Removes the first occurrence of a specific Folder from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Folders in this FolderCollection.
Sort | Sorts the Folders in this FolderCollection, using the given comparer.
SortByID | Sorts the Folders in this FolderCollection by ID.
SortByName | Sorts the Folders in this FolderCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.Add Method

Adds a Folder to end of the collection.

public int Add(
Folder value
);

Parameters

value
The Folder to add to the collection.

Return Value

The position into which the new Folder was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

FolderCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

FolderCollection.Append Method

Appends the Folders of the given array to the end of this FolderCollection.

Overload List

Appends the Folders of the given array to the end of this FolderCollection.

public FolderCollection Append(Folder[]);

Appends the Folders of the given FolderCollection to the end of this FolderCollection.

public FolderCollection Append(FolderCollection);

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.Append Method (Folder[])

Appends the Folders of the given array to the end of this FolderCollection.

public FolderCollection Append(
Folder[] array
);

Parameters

array
The array whose Folders are to be appended to this FolderCollection.

Return Value

This FolderCollection, modified to include the new Folders.

Remarks

The FolderCollection is modified to include the new members. The individual Folder objects are shared, not copied.

See Also

FolderCollection Class | Borland.StarTeam Namespace | FolderCollection.Append Overload List


FolderCollection.Append Method (FolderCollection)

Appends the Folders of the given FolderCollection to the end of this FolderCollection.

public FolderCollection Append(
FolderCollection collection
);

Parameters

collection
The FolderCollection whose Folders are to be appended to this FolderCollection.

Return Value

This FolderCollection, modified to include the new Folders.

Remarks

The FolderCollection is modified to include the new members. The individual Folder objects are shared, not copied.

See Also

FolderCollection Class | Borland.StarTeam Namespace | FolderCollection.Append Overload List


FolderCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.Folder[].

Implements

IWrapper.Unwrap

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.Contains Method

Determines whether or not the collection contains a specific Folder.

public bool Contains(
Folder value
);

Parameters

value
The Folder to locate in the collection.

Return Value

true if the Folder is found in the collection; otherwise, false.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.CopyTo Method

Copies all of the Folders in the FolderCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Folder[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Folders copied from the FolderCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Folders in the source FolderCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source FolderCollection cannot be cast automatically to the type of the destination array.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.FindByID Method

Finds the Folder with the given ID.

public Folder FindByID(
Int32 id
);

Parameters

id
The ID of the Folder to be found.

Return Value

The Folder with the given ID, or null if there is no Folder with that ID in this FolderCollection.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.FindByName Method

Finds the Folder with the given name.

public Folder FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the Folder to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The Folder with the given name, or null if there is no Folder with that name in this FolderCollection.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.IndexOf Method

Determines the index of a specific Folder in the collection.

public int IndexOf(
Folder value
);

Parameters

value
The Folder to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.Insert Method

Inserts a Folder into the collection at the specified position.

public void Insert(
Int32 index,
Folder value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Folder to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.Remove Method

Removes the first occurrence of a specific Folder from the collection.

public void Remove(
Folder value
);

Parameters

value
The Folder to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.Reverse Method

Reverses the order of the Folders in this FolderCollection.

new public FolderCollection Reverse();

Return Value

This FolderCollection, modified such that the Folders are reversed.

Remarks

The FolderCollection is modified in place.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.Sort Method

Sorts the Folders in this FolderCollection, using the given comparer.

new public FolderCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Folders.

Return Value

This FolderCollection, modified such that the Folders are sorted.

Remarks

The FolderCollection is modified in place.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.SortByID Method

Sorts the Folders in this FolderCollection by ID.

public FolderCollection SortByID();

Return Value

This FolderCollection, modified such that the Folders are sorted by ID.

Remarks

The FolderCollection is modified in place.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.SortByName Method

Sorts the Folders in this FolderCollection by name.

public FolderCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This FolderCollection, modified such that the Folders are sorted by name.

Remarks

The FolderCollection is modified in place.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection.Wrap Method

Creates a FolderCollection to represent the given array of Folder (from the com.starbase.starteam namespace).

public static FolderCollection Wrap(
Folder[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new FolderCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a Folder[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection Type Conversions

The type conversions of the FolderCollection class are listed below. For a complete list of FolderCollection class members, see the FolderCollection Members topic.

Public Static Type Conversions

Implicit FolderCollection to Folder[] Conversion | Converts a FolderCollection to an array of Folders.
Implicit FolderCollection to Folder[] Conversion | Converts a FolderCollection from the Borland.StarTeam namespace to a Folder[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

FolderCollection Class | FolderCollection Members | Borland.StarTeam Namespace


FolderCollection Implicit FolderCollection to Folder[] Conversion

Converts a FolderCollection to an array of Folders.

public static implicit operator Folder[](
FolderCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Folder wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Folder wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderCollection Implicit FolderCollection to Folder[] Conversion

Converts a FolderCollection from the Borland.StarTeam namespace to a Folder[] in the com.starbase.starteam namespace.

public static implicit operator Folder[](
FolderCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, FolderCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

FolderCollection Class | Borland.StarTeam Namespace


FolderEventArgs Class

For a list of all members of this type, see FolderEventArgs Members.

System.Object
EventArgs
FolderEventArgs

public class FolderEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FolderEventArgs Members | Borland.StarTeam Namespace


FolderEventArgs Members

FolderEventArgs overview

Public Static Type Conversions

Implicit FolderEventArgs to FolderEvent Conversion Implicitly convert FolderEventArgs to com.starbase.starteam.FolderEvent.

Public Instance Properties

NewFolder | [read] The Folder in its new state.
OldFolder | [read] The Folder in its old state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

FolderEventArgs Class | Borland.StarTeam Namespace


FolderEventArgs Properties

The properties of the FolderEventArgs class are listed below. For a complete list of FolderEventArgs class members, see the FolderEventArgs Members topic.

Public Instance Properties

NewFolder | [read] The Folder in its new state.
OldFolder | [read] The Folder in its old state.

See Also

FolderEventArgs Class | Borland.StarTeam Namespace


NewFolder Property

Borland StarTeam SDK for .NET

FolderEventArgs.NewFolder Property

[read] The Folder in its new state.

public virtual Folder NewFolder {get;}

Property Value

The Folder in its new state.

See Also

FolderEventArgs Class | Borland.StarTeam Namespace


OldFolder Property

Borland StarTeam SDK for .NET

FolderEventArgs.OldFolder Property

[read] The Folder in its old state.

public virtual Folder OldFolder {get;}

Property Value

The Folder in its old state.

See Also

FolderEventArgs Class | Borland.StarTeam Namespace


FolderEventArgs Methods

The methods of the FolderEventArgs class are listed below. For a complete list of FolderEventArgs class members, see the FolderEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

FolderEventArgs Class | Borland.StarTeam Namespace


FolderEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

FolderEventArgs Class | Borland.StarTeam Namespace


FolderEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

FolderEventArgs Class | Borland.StarTeam Namespace


FolderEventArgs.ToString Method

public override string ToString();

See Also

FolderEventArgs Class | Borland.StarTeam Namespace


FolderEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

FolderEventArgs Class | Borland.StarTeam Namespace


FolderEventArgs Type Conversions

The type conversions of the FolderEventArgs class are listed below. For a complete list of FolderEventArgs class members, see the FolderEventArgs Members topic.

Public Static Type Conversions

Implicit FolderEventArgs to FolderEvent Conversion Implicitly convert FolderEventArgs to com.starbase.starteam.FolderEvent.

See Also

FolderEventArgs Class | FolderEventArgs Members | Borland.StarTeam Namespace


FolderEventArgs Implicit FolderEventArgs to FolderEvent Conversion

Implicitly convert FolderEventArgs to com.starbase.starteam.FolderEvent.

public static implicit operator FolderEvent(
FolderEventArgs arg
);

Parameters

arg
FolderEventArgs to convert.

Return Value

com.starbase.starteam.FolderEvent

See Also

FolderEventArgs Class | Borland.StarTeam Namespace


FolderEventSource Class

For a list of all members of this type, see FolderEventSource Members.

System.Object
FolderEventSource

public class FolderEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FolderEventSource Members | Borland.StarTeam Namespace


FolderEventSource Members

FolderEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

FolderAdded
FolderChanged
FolderMoved
FolderRemoved
OnFolderAdded
OnFolderChanged
OnFolderMoved
OnFolderRemoved

See Also

FolderEventSource Class | Borland.StarTeam Namespace


FolderEventSource Properties

The properties of the FolderEventSource class are listed below. For a complete list of FolderEventSource class members, see the FolderEventSource Members topic.

Public Instance Properties

Parent

See Also

FolderEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

FolderEventSource.Parent Property

public Object Parent {get;}

See Also

FolderEventSource Class | Borland.StarTeam Namespace


FolderEventSource Events

The events of the FolderEventSource class are listed below. For a complete list of FolderEventSource class members, see the FolderEventSource Members topic.

Public Instance Events

FolderAdded
FolderChanged
FolderMoved
FolderRemoved
OnFolderAdded
OnFolderChanged
OnFolderMoved
OnFolderRemoved

See Also

FolderEventSource Class | Borland.StarTeam Namespace


FolderEventSource.FolderAdded Event

public event FolderEventSource.Handler FolderAdded;

See Also

FolderEventSource Class | Borland.StarTeam Namespace


FolderEventSource.FolderChanged Event

public event FolderEventSource.Handler FolderChanged;

See Also

FolderEventSource Class | Borland.StarTeam Namespace


FolderEventSource.FolderMoved Event

public event FolderEventSource.Handler FolderMoved;

See Also

FolderEventSource Class | Borland.StarTeam Namespace


FolderEventSource.FolderRemoved Event

public event FolderEventSource.Handler FolderRemoved;

See Also

FolderEventSource Class | Borland.StarTeam Namespace


FolderEventSource.OnFolderAdded Event

public event FolderEventSource.Handler OnFolderAdded;

See Also

FolderEventSource Class | Borland.StarTeam Namespace


FolderEventSource.OnFolderChanged Event

public event FolderEventSource.Handler OnFolderChanged;

See Also

FolderEventSource Class | Borland.StarTeam Namespace


FolderEventSource.OnFolderMoved Event

public event FolderEventSource.Handler OnFolderMoved;

See Also

FolderEventSource Class | Borland.StarTeam Namespace


FolderEventSource.OnFolderRemoved Event

public event FolderEventSource.Handler OnFolderRemoved;

See Also

FolderEventSource Class | Borland.StarTeam Namespace


FolderEventSource.Handler Delegate

public delegate void FolderEventSource.Handler(
FolderEventSource source,
FolderEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


FolderListManager Class

Manages a collection of folders created by including and excluding selected folders and their subfolders. Currently, all folders in the list must belong to the same view. Remembers the set of operations used to create the collection, so that the collection can be refreshed using the latest information from the StarTeam repository.

For a list of all members of this type, see FolderListManager Members.

System.Object
FolderListManager

public class FolderListManager : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FolderListManager Members | Borland.StarTeam Namespace


FolderListManager Members

FolderListManager overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.FolderListManager.

Public Static Type Conversions

Implicit FolderListManager to FolderListManager Conversion Implicitly convert FolderListManager to com.starbase.starteam.FolderListManager.

Public Instance Constructors

FolderListManager Overloaded. Initializes a new instance of the FolderListManager class.

Public Instance Properties

Folders | [read] The list of folders in the folder list.
IsRefreshRequired | [read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.
View | [read] the view for this FolderListManager.

Public Instance Methods

Clear | Removes all folders from the folder list.
Discard | Discards cached folder information. It will be re-fetched from the server the next time the folder list is retrieved (even when MPX is enabled).
Equals | Delegate Equals() to com.starbase.starteam.FolderListManager.
ExcludeFolder | Excludes the given folder from the folder list.
ExcludeFolders | Overloaded. Excludes the given folder, and optionally its subfolders, from the folder list.
GetFolderID | Returns the ItemID for a folder; if we're managing not-in-view folders, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view folder object until it's been added to the repository.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.FolderListManager.
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeFolder | Includes the given folder in the folder list.
IncludeFolders | Overloaded. Includes the given folder, and optionally its subfolders, in the folder list.
IsFolderIncluded | Determines whether or not the given folder is included in the folder list.
NewFolderEventSource |
NewFolderTreeEventSource |
NewFolderUpdateEventSource |
Refresh |
ToString | Delegate ToString() to com.starbase.starteam.FolderListManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager Constructor

Construct FolderListManager from com.starbase.starteam.FolderListManager.

Overload List

Creates a new folder list with the same folders as an existing folder list.

public FolderListManager(FolderListManager);

Constructs a new folder list.

public FolderListManager(View);

Construct FolderListManager from com.starbase.starteam.FolderListManager.

public FolderListManager(FolderListManager);

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager Constructor (FolderListManager)

Construct FolderListManager from com.starbase.starteam.FolderListManager.

public FolderListManager(
FolderListManager impl
);

Parameters

impl
The com.starbase.starteam.FolderListManager to be wrapped.

See Also

FolderListManager Class | Borland.StarTeam Namespace | FolderListManager Constructor Overload List


FolderListManager Constructor (View)

Constructs a new folder list.

public FolderListManager(
View view
);

Parameters

view
The view from which the folders will be added.

See Also

FolderListManager Class | Borland.StarTeam Namespace | FolderListManager Constructor Overload List


FolderListManager Constructor (FolderListManager)

Creates a new folder list with the same folders as an existing folder list.

public FolderListManager(
FolderListManager folderList
);

Parameters

folderList
A folder list to be copied.

See Also

FolderListManager Class | Borland.StarTeam Namespace | FolderListManager Constructor Overload List


FolderListManager Properties

The properties of the FolderListManager class are listed below. For a complete list of FolderListManager class members, see the FolderListManager Members topic.

Public Instance Properties

Folders | [read] The list of folders in the folder list.
IsRefreshRequired | [read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.
View | [read] the view for this FolderListManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FolderListManager Class | Borland.StarTeam Namespace


Folders Property

Borland StarTeam SDK for .NET

FolderListManager.Folders Property

[read] The list of folders in the folder list.

public virtual FolderCollection Folders {get;}

Property Value

The list of folders in the folder list.

See Also

FolderListManager Class | Borland.StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

FolderListManager.IsRefreshRequired Property

[read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.

See Also

FolderListManager Class | Borland.StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

FolderListManager.View Property

[read] the view for this FolderListManager.

public virtual View View {get;}

Property Value

the view for this FolderListManager.

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager Methods

The methods of the FolderListManager class are listed below. For a complete list of FolderListManager class members, see the FolderListManager Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.FolderListManager.

Public Instance Methods

Clear | Removes all folders from the folder list.
Discard | Discards cached folder information. It will be re-fetched from the server the next time the folder list is retrieved (even when MPX is enabled).
Equals | Delegate Equals() to com.starbase.starteam.FolderListManager.
ExcludeFolder | Excludes the given folder from the folder list.
ExcludeFolders | Overloaded. Excludes the given folder, and optionally its subfolders, from the folder list.
GetFolderID | Returns the ItemID for a folder; if we're managing not-in-view folders, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view folder object until it's been added to the repository.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.FolderListManager.
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeFolder | Includes the given folder in the folder list.
IncludeFolders | Overloaded. Includes the given folder, and optionally its subfolders, in the folder list.
IsFolderIncluded | Determines whether or not the given folder is included in the folder list.
NewFolderEventSource |
NewFolderTreeEventSource |
NewFolderUpdateEventSource |
Refresh |
ToString | Delegate ToString() to com.starbase.starteam.FolderListManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.FolderListManager

Implements

IWrapper.Unwrap

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager.Clear Method

Removes all folders from the folder list.

public virtual void Clear();

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager.Discard Method

Discards cached folder information. It will be re-fetched from the server the next time the folder list is retrieved (even when MPX is enabled).

public virtual void Discard();

See Also

FolderListManager Class | Borland.StarTeam Namespace | refresh


FolderListManager.Equals Method

Delegate Equals() to com.starbase.starteam.FolderListManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.FolderListManager.Equals(obj).

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager.ExcludeFolder Method

Excludes the given folder from the folder list.

public virtual void ExcludeFolder(
Folder folder
);

Parameters

folder
A folder to be excluded from the folder list.

See Also

FolderListManager Class | Borland.StarTeam Namespace | excludeFolders | includeFolder | getFolders | isFolderIncluded | Folder


ExcludeFolders Method

Borland StarTeam SDK for .NET

FolderListManager.ExcludeFolders Method

Excludes the given folder, and optionally its subfolders, from the folder list.

Overload List

Excludes the given folder, and optionally its subfolders, from the folder list.

public virtual void ExcludeFolders(Folder,Int32);

Excludes the given folder, and optionally its subfolders, from the folder list.

public virtual void ExcludeFolders(Folder,Int32,Int32);

See Also

FolderListManager Class | Borland.StarTeam Namespace | excludeFolder | includeFolder | getFolders | isFolderIncluded | Folder


FolderListManager.ExcludeFolders Method (Folder, Int32)

Excludes the given folder, and optionally its subfolders, from the folder list.

public virtual void ExcludeFolders(
Folder folder,
Int32 depth
);

Parameters

folder
A folder to be excluded from the folder list.
depth
Determines the depth to which subfolders are also excluded. If depth is 0, only the folder itself is excluded. If depth is 1, only the immediate subfolders are excluded; if depth is 2, two levels are excluded; and so on. If depth is -1, all subfolders at any depth are excluded.

See Also

FolderListManager Class | Borland.StarTeam Namespace | FolderListManager.ExcludeFolders Overload List | excludeFolder | includeFolder | getFolders | isFolderIncluded | Folder


FolderListManager.ExcludeFolders Method (Folder, Int32, Int32)

Excludes the given folder, and optionally its subfolders, from the folder list.

public virtual void ExcludeFolders(
Folder folder,
Int32 context,
Int32 depth
);

Parameters

folder
A folder to be excluded from the folder list.
context
one of these values: Filter.CONTEXT_SERVER, Filter.CONTEXT_LOCAL and Filter.CONTEXT_LOCAL_AND_SERVER.
depth
Determines the depth to which subfolders are also excluded. If depth is 0, only the folder itself is excluded. If depth is 1, only the immediate subfolders are excluded; if depth is 2, two levels are excluded; and so on. If depth is -1, all subfolders at any depth are excluded.

See Also

FolderListManager Class | Borland.StarTeam Namespace | FolderListManager.ExcludeFolders Overload List | excludeFolder | includeFolder | getFolders | isFolderIncluded | Folder


FolderListManager.GetFolderID Method

Returns the ItemID for a folder; if we're managing not-in-view folders, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view folder object until it's been added to the repository.

public virtual int GetFolderID(
Folder folder
);

Parameters

folder
The folder whose ItemID is returned.

Return Value

the ItemID for a folder; if we're managing not-in-view folders, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view folder object until it's been added to the repository.

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.FolderListManager.

public override int GetHashCode();

Return Value

com.starbase.starteam.FolderListManager.GetHashCode().

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager.IncludeFolder Method

Includes the given folder in the folder list.

public virtual void IncludeFolder(
Folder folder
);

Parameters

folder
A folder to be included in the folder list.

See Also

FolderListManager Class | Borland.StarTeam Namespace | includeFolders | excludeFolder | getFolders | isFolderIncluded | Folder


IncludeFolders Method

Borland StarTeam SDK for .NET

FolderListManager.IncludeFolders Method

Includes the given folder, and optionally its subfolders, in the folder list.

Overload List

Includes the given folder, and optionally its subfolders, in the folder list.

public virtual void IncludeFolders(Folder,Int32);

Includes the given folder in the folder list in the context and depth specified.

public virtual void IncludeFolders(Folder,Int32,Int32);

See Also

FolderListManager Class | Borland.StarTeam Namespace | includeFolder | excludeFolder | getFolders | isFolderIncluded | Folder


FolderListManager.IncludeFolders Method (Folder, Int32)

Includes the given folder, and optionally its subfolders, in the folder list.

public virtual void IncludeFolders(
Folder folder,
Int32 depth
);

Parameters

folder
A folder to be included in the folder list.
depth
Determines the depth to which subfolders are also included. If depth is 0, only the folder itself is included. If depth is 1, only the immediate subfolders are included; if depth is 2, two levels are included; and so on. If depth is -1, all subfolders at any depth are included.

See Also

FolderListManager Class | Borland.StarTeam Namespace | FolderListManager.IncludeFolders Overload List | includeFolder | excludeFolder | getFolders | isFolderIncluded | Folder


FolderListManager.IncludeFolders Method (Folder, Int32, Int32)

Includes the given folder in the folder list in the context and depth specified.

public virtual void IncludeFolders(
Folder folder,
Int32 context,
Int32 depth
);

Parameters

folder
A folder to be included in the folder list.
context
one of these values: Filter.CONTEXT_SERVER, Filter.CONTEXT_LOCAL and Filter.CONTEXT_LOCAL_AND_SERVER.
depth
Determines the depth to which subfolders are also included. If depth is 0, only the folder itself is included. If depth is 1, only the immediate subfolders are included; if depth is 2, two levels are included; and so on. If depth is -1, all subfolders at any depth are included.

See Also

FolderListManager Class | Borland.StarTeam Namespace | FolderListManager.IncludeFolders Overload List | CONTEXT_SERVER | CONTEXT_LOCAL | CONTEXT_LOCAL_AND_SERVER | includeFolders | excludeFolder | getFolders | isFolderIncluded | Folder


FolderListManager.IsFolderIncluded Method

Determines whether or not the given folder is included in the folder list.

public virtual bool IsFolderIncluded(
Folder folder
);

Parameters

folder
The folder to be tested.

Return Value

true if the folder is included, and false otherwise.

See Also

FolderListManager Class | Borland.StarTeam Namespace | includeFolder | excludeFolder | getFolders | Folder


FolderListManager.NewFolderEventSource Method

public FolderEventSource NewFolderEventSource();

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager.NewFolderTreeEventSource Method

public FolderTreeEventSource NewFolderTreeEventSource();

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager.NewFolderUpdateEventSource Method

public FolderUpdateEventSource NewFolderUpdateEventSource();

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager.Refresh Method

public virtual void Refresh();

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager.ToString Method

Delegate ToString() to com.starbase.starteam.FolderListManager.

public override string ToString();

Return Value

com.starbase.starteam.FolderListManager.ToString()

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager.Wrap Method

Dynamically wraps com.starbase.starteam.FolderListManager.

public static FolderListManager Wrap(
FolderListManager impl
);

Parameters

impl
com.starbase.starteam.FolderListManager to be wrapped.

Return Value

FolderListManager

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderListManager Type Conversions

The type conversions of the FolderListManager class are listed below. For a complete list of FolderListManager class members, see the FolderListManager Members topic.

Public Static Type Conversions

Implicit FolderListManager to FolderListManager Conversion Implicitly convert FolderListManager to com.starbase.starteam.FolderListManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FolderListManager Class | FolderListManager Members | Borland.StarTeam Namespace


FolderListManager Implicit FolderListManager to FolderListManager Conversion

Implicitly convert FolderListManager to com.starbase.starteam.FolderListManager.

public static implicit operator FolderListManager(
FolderListManager arg
);

Parameters

arg
FolderListManager to convert.

Return Value

com.starbase.starteam.FolderListManager

See Also

FolderListManager Class | Borland.StarTeam Namespace


FolderTreeEventArgs Class

For a list of all members of this type, see FolderTreeEventArgs Members.

System.Object
EventArgs
FolderTreeEventArgs

public class FolderTreeEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FolderTreeEventArgs Members | Borland.StarTeam Namespace


FolderTreeEventArgs Members

FolderTreeEventArgs overview

Public Static Type Conversions

Implicit FolderTreeEventArgs to FolderTreeEvent Conversion Implicitly convert FolderTreeEventArgs to com.starbase.starteam.FolderTreeEvent.

Public Instance Properties

Folder [read] The deepest folder that fully encompasses the change to the folder hierarchy.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

FolderTreeEventArgs Class | Borland.StarTeam Namespace


FolderTreeEventArgs Properties

The properties of the FolderTreeEventArgs class are listed below. For a complete list of FolderTreeEventArgs class members, see the FolderTreeEventArgs Members topic.

Public Instance Properties

Folder [read] The deepest folder that fully encompasses the change to the folder hierarchy.

See Also

FolderTreeEventArgs Class | Borland.StarTeam Namespace


Folder Property

Borland StarTeam SDK for .NET

FolderTreeEventArgs.Folder Property

[read] The deepest folder that fully encompasses the change to the folder hierarchy.

public virtual Folder Folder {get;}

Property Value

The deepest folder that fully encompasses the change to the folder hierarchy.

See Also

FolderTreeEventArgs Class | Borland.StarTeam Namespace


FolderTreeEventArgs Methods

The methods of the FolderTreeEventArgs class are listed below. For a complete list of FolderTreeEventArgs class members, see the FolderTreeEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

FolderTreeEventArgs Class | Borland.StarTeam Namespace


FolderTreeEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

FolderTreeEventArgs Class | Borland.StarTeam Namespace


FolderTreeEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

FolderTreeEventArgs Class | Borland.StarTeam Namespace


FolderTreeEventArgs.ToString Method

public override string ToString();

See Also

FolderTreeEventArgs Class | Borland.StarTeam Namespace


FolderTreeEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

FolderTreeEventArgs Class | Borland.StarTeam Namespace


FolderTreeEventArgs Type Conversions

The type conversions of the FolderTreeEventArgs class are listed below. For a complete list of FolderTreeEventArgs class members, see the FolderTreeEventArgs Members topic.

Public Static Type Conversions

Implicit FolderTreeEventArgs to FolderTreeEvent Conversion Implicitly convert FolderTreeEventArgs to com.starbase.starteam.FolderTreeEvent.

See Also

FolderTreeEventArgs Class | FolderTreeEventArgs Members | Borland.StarTeam Namespace


FolderTreeEventArgs Implicit FolderTreeEventArgs to FolderTreeEvent Conversion

Implicitly convert FolderTreeEventArgs to com.starbase.starteam.FolderTreeEvent.

public static implicit operator FolderTreeEvent(
FolderTreeEventArgs arg
);

Parameters

arg
FolderTreeEventArgs to convert.

Return Value

com.starbase.starteam.FolderTreeEvent

See Also

FolderTreeEventArgs Class | Borland.StarTeam Namespace


FolderTreeEventSource Class

For a list of all members of this type, see FolderTreeEventSource Members.

System.Object
FolderTreeEventSource

public class FolderTreeEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FolderTreeEventSource Members | Borland.StarTeam Namespace


FolderTreeEventSource Members

FolderTreeEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

FolderTreeChanged
OnFolderTreeChanged

See Also

FolderTreeEventSource Class | Borland.StarTeam Namespace


FolderTreeEventSource Properties

The properties of the FolderTreeEventSource class are listed below. For a complete list of FolderTreeEventSource class members, see the FolderTreeEventSource Members topic.

Public Instance Properties

Parent

See Also

FolderTreeEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

FolderTreeEventSource.Parent Property

public Object Parent {get;}

See Also

FolderTreeEventSource Class | Borland.StarTeam Namespace


FolderTreeEventSource Events

The events of the FolderTreeEventSource class are listed below. For a complete list of FolderTreeEventSource class members, see the FolderTreeEventSource Members topic.

Public Instance Events

FolderTreeChanged
OnFolderTreeChanged

See Also

FolderTreeEventSource Class | Borland.StarTeam Namespace


FolderTreeEventSource.FolderTreeChanged Event

public event FolderTreeEventSource.Handler FolderTreeChanged;

See Also

FolderTreeEventSource Class | Borland.StarTeam Namespace


FolderTreeEventSource.OnFolderTreeChanged Event

public event FolderTreeEventSource.Handler OnFolderTreeChanged;

See Also

FolderTreeEventSource Class | Borland.StarTeam Namespace


FolderTreeEventSource.Handler Delegate

public delegate void FolderTreeEventSource.Handler(
FolderTreeEventSource source,
FolderTreeEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


FolderUpdateEventArgs Class

For a list of all members of this type, see FolderUpdateEventArgs Members.

System.Object
EventArgs
FolderUpdateEventArgs

public class FolderUpdateEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FolderUpdateEventArgs Members | Borland.StarTeam Namespace


FolderUpdateEventArgs Members

FolderUpdateEventArgs overview

Public Static Type Conversions

Implicit FolderUpdateEventArgs to FolderUpdateEvent Conversion Implicitly convert FolderUpdateEventArgs to com.starbase.starteam.FolderUpdateEvent.

Public Instance Constructors

FolderUpdateEventArgs Constructor

Public Instance Properties

NewFolder | [read] The Folder in its new state.
OldFolder | [read] The Folder in its old state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

FolderUpdateEventArgs Class | Borland.StarTeam Namespace


FolderUpdateEventArgs Constructor

public FolderUpdateEventArgs(
Folder oldFolder,
Folder newFolder
);

Parameters

oldFolder
newFolder

See Also

FolderUpdateEventArgs Class | Borland.StarTeam Namespace


FolderUpdateEventArgs Properties

The properties of the FolderUpdateEventArgs class are listed below. For a complete list of FolderUpdateEventArgs class members, see the FolderUpdateEventArgs Members topic.

Public Instance Properties

NewFolder | [read] The Folder in its new state.
OldFolder | [read] The Folder in its old state.

See Also

FolderUpdateEventArgs Class | Borland.StarTeam Namespace


NewFolder Property

Borland StarTeam SDK for .NET

FolderUpdateEventArgs.NewFolder Property

[read] The Folder in its new state.

public virtual Folder NewFolder {get;}

Property Value

The Folder in its new state.

See Also

FolderUpdateEventArgs Class | Borland.StarTeam Namespace


OldFolder Property

Borland StarTeam SDK for .NET

FolderUpdateEventArgs.OldFolder Property

[read] The Folder in its old state.

public virtual Folder OldFolder {get;}

Property Value

The Folder in its old state.

See Also

FolderUpdateEventArgs Class | Borland.StarTeam Namespace


FolderUpdateEventArgs Methods

The methods of the FolderUpdateEventArgs class are listed below. For a complete list of FolderUpdateEventArgs class members, see the FolderUpdateEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

FolderUpdateEventArgs Class | Borland.StarTeam Namespace


FolderUpdateEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

FolderUpdateEventArgs Class | Borland.StarTeam Namespace


FolderUpdateEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

FolderUpdateEventArgs Class | Borland.StarTeam Namespace


FolderUpdateEventArgs.ToString Method

public override string ToString();

See Also

FolderUpdateEventArgs Class | Borland.StarTeam Namespace


FolderUpdateEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

FolderUpdateEventArgs Class | Borland.StarTeam Namespace


FolderUpdateEventArgs Type Conversions

The type conversions of the FolderUpdateEventArgs class are listed below. For a complete list of FolderUpdateEventArgs class members, see the FolderUpdateEventArgs Members topic.

Public Static Type Conversions

Implicit FolderUpdateEventArgs to FolderUpdateEvent Conversion Implicitly convert FolderUpdateEventArgs to com.starbase.starteam.FolderUpdateEvent.

See Also

FolderUpdateEventArgs Class | FolderUpdateEventArgs Members | Borland.StarTeam Namespace


FolderUpdateEventArgs Implicit FolderUpdateEventArgs to FolderUpdateEvent Conversion

Implicitly convert FolderUpdateEventArgs to com.starbase.starteam.FolderUpdateEvent.

public static implicit operator FolderUpdateEvent(
FolderUpdateEventArgs arg
);

Parameters

arg
FolderUpdateEventArgs to convert.

Return Value

com.starbase.starteam.FolderUpdateEvent

See Also

FolderUpdateEventArgs Class | Borland.StarTeam Namespace


FolderUpdateEventSource Class

For a list of all members of this type, see FolderUpdateEventSource Members.

System.Object
FolderUpdateEventSource

public class FolderUpdateEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FolderUpdateEventSource Members | Borland.StarTeam Namespace


FolderUpdateEventSource Members

FolderUpdateEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

FolderAdded
FolderChanged
FolderMoved
FolderRemoved
OnFolderAdded
OnFolderChanged
OnFolderMoved
OnFolderRemoved

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


FolderUpdateEventSource Properties

The properties of the FolderUpdateEventSource class are listed below. For a complete list of FolderUpdateEventSource class members, see the FolderUpdateEventSource Members topic.

Public Instance Properties

Parent

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

FolderUpdateEventSource.Parent Property

public Object Parent {get;}

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


FolderUpdateEventSource Events

The events of the FolderUpdateEventSource class are listed below. For a complete list of FolderUpdateEventSource class members, see the FolderUpdateEventSource Members topic.

Public Instance Events

FolderAdded
FolderChanged
FolderMoved
FolderRemoved
OnFolderAdded
OnFolderChanged
OnFolderMoved
OnFolderRemoved

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


FolderUpdateEventSource.FolderAdded Event

public event FolderUpdateEventSource.Handler FolderAdded;

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


FolderUpdateEventSource.FolderChanged Event

public event FolderUpdateEventSource.Handler FolderChanged;

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


FolderUpdateEventSource.FolderMoved Event

public event FolderUpdateEventSource.Handler FolderMoved;

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


FolderUpdateEventSource.FolderRemoved Event

public event FolderUpdateEventSource.Handler FolderRemoved;

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


FolderUpdateEventSource.OnFolderAdded Event

public event FolderUpdateEventSource.Handler OnFolderAdded;

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


FolderUpdateEventSource.OnFolderChanged Event

public event FolderUpdateEventSource.Handler OnFolderChanged;

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


FolderUpdateEventSource.OnFolderMoved Event

public event FolderUpdateEventSource.Handler OnFolderMoved;

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


FolderUpdateEventSource.OnFolderRemoved Event

public event FolderUpdateEventSource.Handler OnFolderRemoved;

See Also

FolderUpdateEventSource Class | Borland.StarTeam Namespace


FolderUpdateEventSource.Handler Delegate

public delegate void FolderUpdateEventSource.Handler(
FolderUpdateEventSource source,
FolderUpdateEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


ForeignPasswordException Class

For a list of all members of this type, see ForeignPasswordException Members.

System.Object
Exception
ServerException
ForeignPasswordException

public class ForeignPasswordException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ForeignPasswordException Members | Borland.StarTeam Namespace


ForeignPasswordException Members

ForeignPasswordException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ForeignPasswordException.

Public Static Type Conversions

Implicit ForeignPasswordException to ForeignPasswordException Conversion Implicitly convert ForeignPasswordException to com.starbase.starteam.ForeignPasswordException.

Public Instance Constructors

ForeignPasswordException Constructor Construct ForeignPasswordException from com.starbase.starteam.ForeignPasswordException.

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
ConfigPath |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
IsPVCS |
IsVSS |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
ProjectType |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

ForeignPasswordException Class | Borland.StarTeam Namespace


ForeignPasswordException Constructor

Construct ForeignPasswordException from com.starbase.starteam.ForeignPasswordException.

public ForeignPasswordException(
ForeignPasswordException impl
);

Parameters

impl
The com.starbase.starteam.ForeignPasswordException to be wrapped.

See Also

ForeignPasswordException Class | Borland.StarTeam Namespace


ForeignPasswordException Properties

The properties of the ForeignPasswordException class are listed below. For a complete list of ForeignPasswordException class members, see the ForeignPasswordException Members topic.

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
ConfigPath |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
IsPVCS |
IsVSS |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
ProjectType |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

ForeignPasswordException Class | Borland.StarTeam Namespace


ConfigPath Property

Borland StarTeam SDK for .NET

ForeignPasswordException.ConfigPath Property

public virtual String ConfigPath {get;}

See Also

ForeignPasswordException Class | Borland.StarTeam Namespace


IsPVCS Property

Borland StarTeam SDK for .NET

ForeignPasswordException.IsPVCS Property

public virtual Boolean IsPVCS {get;}

See Also

ForeignPasswordException Class | Borland.StarTeam Namespace


IsVSS Property

Borland StarTeam SDK for .NET

ForeignPasswordException.IsVSS Property

public virtual Boolean IsVSS {get;}

See Also

ForeignPasswordException Class | Borland.StarTeam Namespace


ProjectType Property

Borland StarTeam SDK for .NET

ForeignPasswordException.ProjectType Property

public virtual Int32 ProjectType {get;}

See Also

ForeignPasswordException Class | Borland.StarTeam Namespace


ForeignPasswordException Methods

The methods of the ForeignPasswordException class are listed below. For a complete list of ForeignPasswordException class members, see the ForeignPasswordException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ForeignPasswordException.

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

ForeignPasswordException Class | Borland.StarTeam Namespace


ForeignPasswordException.Wrap Method

Dynamically wraps com.starbase.starteam.ForeignPasswordException.

public static ForeignPasswordException Wrap(
ForeignPasswordException impl
);

Parameters

impl
com.starbase.starteam.ForeignPasswordException to be wrapped.

Return Value

ForeignPasswordException

See Also

ForeignPasswordException Class | Borland.StarTeam Namespace


ForeignPasswordException Type Conversions

The type conversions of the ForeignPasswordException class are listed below. For a complete list of ForeignPasswordException class members, see the ForeignPasswordException Members topic.

Public Static Type Conversions

Implicit ForeignPasswordException to ForeignPasswordException Conversion Implicitly convert ForeignPasswordException to com.starbase.starteam.ForeignPasswordException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

ForeignPasswordException Class | ForeignPasswordException Members | Borland.StarTeam Namespace


ForeignPasswordException Implicit ForeignPasswordException to ForeignPasswordException Conversion

Implicitly convert ForeignPasswordException to com.starbase.starteam.ForeignPasswordException.

public static implicit operator ForeignPasswordException(
ForeignPasswordException arg
);

Parameters

arg
ForeignPasswordException to convert.

Return Value

com.starbase.starteam.ForeignPasswordException

See Also

ForeignPasswordException Class | Borland.StarTeam Namespace


ForeignRefreshResult Class

The class holds return information specific to the "foreign" refresh operation.

For a list of all members of this type, see ForeignRefreshResult Members.

System.Object
ForeignRefreshResult

public class ForeignRefreshResult : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ForeignRefreshResult Members | Borland.StarTeam Namespace


ForeignRefreshResult Members

ForeignRefreshResult overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ForeignRefreshResult.

Public Static Type Conversions

Implicit ForeignRefreshResult to ForeignRefreshResult Conversion Implicitly convert ForeignRefreshResult to com.starbase.starteam.ForeignRefreshResult.

Public Instance Constructors

ForeignRefreshResult Constructor Construct ForeignRefreshResult from com.starbase.starteam.ForeignRefreshResult.

Public Instance Properties

FilesChanged | [read]
FoldersChanged | [read]

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ForeignRefreshResult.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ForeignRefreshResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ForeignRefreshResult.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


ForeignRefreshResult Constructor

Construct ForeignRefreshResult from com.starbase.starteam.ForeignRefreshResult.

public ForeignRefreshResult(
ForeignRefreshResult impl
);

Parameters

impl
The com.starbase.starteam.ForeignRefreshResult to be wrapped.

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


ForeignRefreshResult Properties

The properties of the ForeignRefreshResult class are listed below. For a complete list of ForeignRefreshResult class members, see the ForeignRefreshResult Members topic.

Public Instance Properties

FilesChanged | [read]
FoldersChanged | [read]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


FilesChanged Property

Borland StarTeam SDK for .NET

ForeignRefreshResult.FilesChanged Property

[read]

public virtual Boolean FilesChanged {get;}

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


FoldersChanged Property

Borland StarTeam SDK for .NET

ForeignRefreshResult.FoldersChanged Property

[read]

public virtual Boolean FoldersChanged {get;}

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


ForeignRefreshResult Methods

The methods of the ForeignRefreshResult class are listed below. For a complete list of ForeignRefreshResult class members, see the ForeignRefreshResult Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ForeignRefreshResult.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ForeignRefreshResult.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ForeignRefreshResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ForeignRefreshResult.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


ForeignRefreshResult.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ForeignRefreshResult

Implements

IWrapper.Unwrap

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


ForeignRefreshResult.Equals Method

Delegate Equals() to com.starbase.starteam.ForeignRefreshResult.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ForeignRefreshResult.Equals(obj).

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


ForeignRefreshResult.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ForeignRefreshResult.

public override int GetHashCode();

Return Value

com.starbase.starteam.ForeignRefreshResult.GetHashCode().

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


ForeignRefreshResult.ToString Method

Delegate ToString() to com.starbase.starteam.ForeignRefreshResult.

public override string ToString();

Return Value

com.starbase.starteam.ForeignRefreshResult.ToString()

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


ForeignRefreshResult.Wrap Method

Dynamically wraps com.starbase.starteam.ForeignRefreshResult.

public static ForeignRefreshResult Wrap(
ForeignRefreshResult impl
);

Parameters

impl
com.starbase.starteam.ForeignRefreshResult to be wrapped.

Return Value

ForeignRefreshResult

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


ForeignRefreshResult Type Conversions

The type conversions of the ForeignRefreshResult class are listed below. For a complete list of ForeignRefreshResult class members, see the ForeignRefreshResult Members topic.

Public Static Type Conversions

Implicit ForeignRefreshResult to ForeignRefreshResult Conversion Implicitly convert ForeignRefreshResult to com.starbase.starteam.ForeignRefreshResult.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ForeignRefreshResult Class | ForeignRefreshResult Members | Borland.StarTeam Namespace


ForeignRefreshResult Implicit ForeignRefreshResult to ForeignRefreshResult Conversion

Implicitly convert ForeignRefreshResult to com.starbase.starteam.ForeignRefreshResult.

public static implicit operator ForeignRefreshResult(
ForeignRefreshResult arg
);

Parameters

arg
ForeignRefreshResult to convert.

Return Value

com.starbase.starteam.ForeignRefreshResult

See Also

ForeignRefreshResult Class | Borland.StarTeam Namespace


Group Class

Represents a StarTeam Group. Only a limited subset of the whole group information is available. The GroupAccount class has the full group information but it is only accessible to user's with the appropriate permissions.

For a list of all members of this type, see Group Members.

System.Object
CacheRef
Group

public class Group : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Group Members | Borland.StarTeam Namespace


Group Members

Group overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Group.

Public Static Type Conversions

Implicit Group to Group Conversion Implicitly convert Group to com.starbase.starteam.Group.

Public Instance Constructors

Group Constructor Construct Group from com.starbase.starteam.Group.

Public Instance Properties

ID | [read] the integer idenitifier for this group.
IsDeleted | [read] true if the Group has been deleted.
Name | [read] the group's name.
Server | [read] the Server object to which this group belongs.

Public Instance Methods

Clone (inherited from CacheRef) |
Copy | Creates a copy of this Group object. Useful to applications that want to save a snapshot of the group in a given state, for example, before calling Server.refreshGroups(). The copied group will have the same parent server as the original group. The Server object is not copied.
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
FetchMemberUserIDs | Returns the IDs of all of the users that belong to this group. The information is retrieved directly from the StarTeam Server, and is not cached. Requires admin privileges on 5.2 and earlier servers.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two Group objects, and their member User IDs. Requires admin privileges on 5.2 and earlier servers. The parent Servers are not compared.
IsMember | Return true if the specified user can be considered a member of this Group. A user is defined to be a member of a Group if it is directly a member of the Group or recusively of any sub-Group of this Group. This requires admin privileges on servers older than 5.3.033.
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Group Class | Borland.StarTeam Namespace


Group Constructor

Construct Group from com.starbase.starteam.Group.

public Group(
Group impl
);

Parameters

impl
The com.starbase.starteam.Group to be wrapped.

See Also

Group Class | Borland.StarTeam Namespace


Group Properties

The properties of the Group class are listed below. For a complete list of Group class members, see the Group Members topic.

Public Instance Properties

ID | [read] the integer idenitifier for this group.
IsDeleted | [read] true if the Group has been deleted.
Name | [read] the group's name.
Server | [read] the Server object to which this group belongs.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Group Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Group.ID Property

[read] the integer idenitifier for this group.

public virtual Int32 ID {get;}

Property Value

the integer idenitifier for this group.

See Also

Group Class | Borland.StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Group.IsDeleted Property

[read] true if the Group has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if the Group has been deleted.

See Also

Group Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Group.Name Property

[read] the group's name.

public virtual String Name {get;}

Property Value

the group's name.

See Also

Group Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Group.Server Property

[read] the Server object to which this group belongs.

public virtual Server Server {get;}

Property Value

the Server object to which this group belongs.

See Also

Group Class | Borland.StarTeam Namespace


Group Methods

The methods of the Group class are listed below. For a complete list of Group class members, see the Group Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Group.

Public Instance Methods

Clone (inherited from CacheRef) |
Copy | Creates a copy of this Group object. Useful to applications that want to save a snapshot of the group in a given state, for example, before calling Server.refreshGroups(). The copied group will have the same parent server as the original group. The Server object is not copied.
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
FetchMemberUserIDs | Returns the IDs of all of the users that belong to this group. The information is retrieved directly from the StarTeam Server, and is not cached. Requires admin privileges on 5.2 and earlier servers.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two Group objects, and their member User IDs. Requires admin privileges on 5.2 and earlier servers. The parent Servers are not compared.
IsMember | Return true if the specified user can be considered a member of this Group. A user is defined to be a member of a Group if it is directly a member of the Group or recusively of any sub-Group of this Group. This requires admin privileges on servers older than 5.3.033.
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Group Class | Borland.StarTeam Namespace


Group.Copy Method

Creates a copy of this Group object. Useful to applications that want to save a snapshot of the group in a given state, for example, before calling Server.refreshGroups().

The copied group will have the same parent server as the original group. The Server object is not copied.

public virtual Group Copy();

Return Value

A new copy of this Group object.

See Also

Group Class | Borland.StarTeam Namespace | isEqualTo


Group.FetchMemberUserIDs Method

Returns the IDs of all of the users that belong to this group. The information is retrieved directly from the StarTeam Server, and is not cached. Requires admin privileges on 5.2 and earlier servers.

public virtual int[] FetchMemberUserIDs(
Boolean bDescendants
);

Parameters

bDescendants
true = plus all descendants of group; false = this group only

Return Value

the IDs of all of the users that belong to this group.

See Also

Group Class | Borland.StarTeam Namespace


Group.IsEqualTo Method

Compares two Group objects, and their member User IDs. Requires admin privileges on 5.2 and earlier servers.

The parent Servers are not compared.

public virtual bool IsEqualTo(
Group group
);

Parameters

group
The Group to be compared with this one.

Return Value

true if no differences were found.

See Also

Group Class | Borland.StarTeam Namespace | copy


Group.IsMember Method

Return true if the specified user can be considered a member of this Group. A user is defined to be a member of a Group if it is directly a member of the Group or recusively of any sub-Group of this Group. This requires admin privileges on servers older than 5.3.033.

public virtual bool IsMember(
Int32 userID
);

Parameters

userID
the user ID being checked for group membership

Return Value

true if the specified user ID is a member of this or any sub group

See Also

Group Class | Borland.StarTeam Namespace


Group.Wrap Method

Dynamically wraps com.starbase.starteam.Group.

public static Group Wrap(
Group impl
);

Parameters

impl
com.starbase.starteam.Group to be wrapped.

Return Value

Group

See Also

Group Class | Borland.StarTeam Namespace


Group Type Conversions

The type conversions of the Group class are listed below. For a complete list of Group class members, see the Group Members topic.

Public Static Type Conversions

Implicit Group to Group Conversion Implicitly convert Group to com.starbase.starteam.Group.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Group Class | Group Members | Borland.StarTeam Namespace


Group Implicit Group to Group Conversion

Implicitly convert Group to com.starbase.starteam.Group.

public static implicit operator Group(
Group arg
);

Parameters

arg
Group to convert.

Return Value

com.starbase.starteam.Group

See Also

Group Class | Borland.StarTeam Namespace


GroupAccount Class

This class represents a full StarTeam Group account. New groups can be added to a StarTeam Server and existing groups can be modified through this class. Whereas the Group class only provides access to a group's name and ID, the GroupAccount supports access to all information about a group. All users can obtain Group information but only users with the appropriate permissions can access GroupAccount information.

For a list of all members of this type, see GroupAccount Members.

System.Object
CacheRef
GroupAccount

public class GroupAccount : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

GroupAccount Members | Borland.StarTeam Namespace


GroupAccount Members

GroupAccount overview

Public Static Properties

ID_ALL_USERS

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.GroupAccount.

Public Static Type Conversions

Implicit GroupAccount to GroupAccount Conversion Implicitly convert GroupAccount to com.starbase.starteam.GroupAccount.

Public Instance Constructors

GroupAccount Overloaded. Initializes a new instance of the GroupAccount class.

Public Instance Properties

CanRemove | [read] true if this GroupAccount and all of its descendants can be deleted without leaving any users with no group membership.
Description | [read/write] the group description.
FullName | [read] A qualified name for the group, showing both the group and its parents.
ID | [read] this group's integer indentifier.
IsBuiltin | [read] true if this is a builtin GroupAccount.
IsDeleted | [read] true if the GroupAccount has been deleted.
IsNew | [read] true if this GroupAccount has not yet been created on the Server.
IsRoot | [read] true if this is a top-level group with no parent group.
Name | [read/write] the group name.
Parent | [read/write] the parent GroupAccount for this group.
PermissionsFlags | [read] the permissions flags for this group.
Server | [read] the Server object to which this GroupAccount belongs.
SubGroupAccounts | [read] the sub GroupAccounts of this GroupAccount
UserAccounts | [read] the UserAccount objects directly belonging to this group.

Public Instance Methods

AddPermission | Add this permission to the set of permissions for this GroupAccount.
Clone (inherited from CacheRef) |
Copy | Creates a copy of this GroupAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Returns true if this GroupAccount has the specified permission.
IsEqualTo | Compares two GroupAccount objects.
IsMember | Return true if the specified user can be considered a member of this GroupAccount. A user is defined to be a member of a GroupAccount if it is directly a member of the GroupAccount or recusively of any sub-GroupAccount of this GroupAccount.
Remove | Removes this group from the StarTeam server, plus any direct or indirect subgroups of this group. If the GroupAccount was never saved (isNew() returns true), if it is a builtin account, or if removing this group or any of its descendants would leave one or more users without any group membership, then an exception will be thrown. Note also that any affected UserAccounts will be updated, including any pending changes, as a side effect of this method.
RemovePermission | Removes the specified permission from this GroupAccount.
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.
Update | Persistently saves the changes to this GroupAccount in the server. If the GroupAccount is new it will be added, otherwise it will be modified.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

GroupAccount Class | Borland.StarTeam Namespace


GroupAccount Constructor

Construct GroupAccount from com.starbase.starteam.GroupAccount.

Overload List

Creates a new StarTeam Group object. It is initially not a subgroup of any existing group and one should call setParent to change this. The name is initially the empty string. To create this group in the StarTeam server you must call update.

public GroupAccount(Server);

Construct GroupAccount from com.starbase.starteam.GroupAccount.

public GroupAccount(GroupAccount);

See Also

GroupAccount Class | Borland.StarTeam Namespace


GroupAccount Constructor (GroupAccount)

Construct GroupAccount from com.starbase.starteam.GroupAccount.

public GroupAccount(
GroupAccount impl
);

Parameters

impl
The com.starbase.starteam.GroupAccount to be wrapped.

See Also

GroupAccount Class | Borland.StarTeam Namespace | GroupAccount Constructor Overload List


GroupAccount Constructor (Server)

Creates a new StarTeam Group object. It is initially not a subgroup of any existing group and one should call setParent to change this. The name is initially the empty string. To create this group in the StarTeam server you must call update.

public GroupAccount(
Server server
);

Parameters

server
the StarTeam Server to which this group belongs.

See Also

GroupAccount Class | Borland.StarTeam Namespace | GroupAccount Constructor Overload List


GroupAccount Properties

The properties of the GroupAccount class are listed below. For a complete list of GroupAccount class members, see the GroupAccount Members topic.

Public Static Properties

ID_ALL_USERS

Public Instance Properties

CanRemove | [read] true if this GroupAccount and all of its descendants can be deleted without leaving any users with no group membership.
Description | [read/write] the group description.
FullName | [read] A qualified name for the group, showing both the group and its parents.
ID | [read] this group's integer indentifier.
IsBuiltin | [read] true if this is a builtin GroupAccount.
IsDeleted | [read] true if the GroupAccount has been deleted.
IsNew | [read] true if this GroupAccount has not yet been created on the Server.
IsRoot | [read] true if this is a top-level group with no parent group.
Name | [read/write] the group name.
Parent | [read/write] the parent GroupAccount for this group.
PermissionsFlags | [read] the permissions flags for this group.
Server | [read] the Server object to which this GroupAccount belongs.
SubGroupAccounts | [read] the sub GroupAccounts of this GroupAccount
UserAccounts | [read] the UserAccount objects directly belonging to this group.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

GroupAccount Class | Borland.StarTeam Namespace


CanRemove Property

Borland StarTeam SDK for .NET

GroupAccount.CanRemove Property

[read] true if this GroupAccount and all of its descendants can be deleted without leaving any users with no group membership.

public virtual Boolean CanRemove {get;}

Property Value

true if this GroupAccount and all of its descendants can be deleted without leaving any users with no group membership.

See Also

GroupAccount Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

GroupAccount.Description Property

[read/write] the group description.

public virtual String Description {get; set;}

Property Value

the group description.

See Also

GroupAccount Class | Borland.StarTeam Namespace


FullName Property

Borland StarTeam SDK for .NET

GroupAccount.FullName Property

[read] A qualified name for the group, showing both the group and its parents.

public virtual String FullName {get;}

Property Value

A qualified name for the group, showing both the group and its parents.

See Also

GroupAccount Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

GroupAccount.ID Property

[read] this group's integer indentifier.

public virtual Int32 ID {get;}

Property Value

this group's integer indentifier.

See Also

GroupAccount Class | Borland.StarTeam Namespace


ID_ALL_USERS Property

Borland StarTeam SDK for .NET

GroupAccount.ID_ALL_USERS Property

public static Int32 ID_ALL_USERS {get;}

See Also

GroupAccount Class | Borland.StarTeam Namespace


IsBuiltin Property

Borland StarTeam SDK for .NET

GroupAccount.IsBuiltin Property

[read] true if this is a builtin GroupAccount.

public virtual Boolean IsBuiltin {get;}

Property Value

true if this is a builtin GroupAccount.

See Also

GroupAccount Class | Borland.StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

GroupAccount.IsDeleted Property

[read] true if the GroupAccount has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if the GroupAccount has been deleted.

See Also

GroupAccount Class | Borland.StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

GroupAccount.IsNew Property

[read] true if this GroupAccount has not yet been created on the Server.

public virtual Boolean IsNew {get;}

Property Value

true if this GroupAccount has not yet been created on the Server.

See Also

GroupAccount Class | Borland.StarTeam Namespace


IsRoot Property

Borland StarTeam SDK for .NET

GroupAccount.IsRoot Property

[read] true if this is a top-level group with no parent group.

public virtual Boolean IsRoot {get;}

Property Value

true if this is a top-level group with no parent group.

See Also

GroupAccount Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

GroupAccount.Name Property

[read/write] the group name.

public virtual String Name {get; set;}

Property Value

the group name.

See Also

GroupAccount Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

GroupAccount.Parent Property

[read/write] the parent GroupAccount for this group.

public virtual GroupAccount Parent {get; set;}

Property Value

the parent GroupAccount for this group.

See Also

GroupAccount Class | Borland.StarTeam Namespace


PermissionsFlags Property

Borland StarTeam SDK for .NET

GroupAccount.PermissionsFlags Property

[read] the permissions flags for this group.

public virtual Int32 PermissionsFlags {get;}

Property Value

the permissions flags for this group.

See Also

GroupAccount Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

GroupAccount.Server Property

[read] the Server object to which this GroupAccount belongs.

public virtual Server Server {get;}

Property Value

the Server object to which this GroupAccount belongs.

See Also

GroupAccount Class | Borland.StarTeam Namespace


SubGroupAccounts Property

Borland StarTeam SDK for .NET

GroupAccount.SubGroupAccounts Property

[read] the sub GroupAccounts of this GroupAccount

public virtual GroupAccountCollection SubGroupAccounts {get;}

Property Value

the sub GroupAccounts of this GroupAccount

See Also

GroupAccount Class | Borland.StarTeam Namespace


UserAccounts Property

Borland StarTeam SDK for .NET

GroupAccount.UserAccounts Property

[read] the UserAccount objects directly belonging to this group.

public virtual UserAccountCollection UserAccounts {get;}

Property Value

the UserAccount objects directly belonging to this group.

See Also

GroupAccount Class | Borland.StarTeam Namespace


GroupAccount Methods

The methods of the GroupAccount class are listed below. For a complete list of GroupAccount class members, see the GroupAccount Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.GroupAccount.

Public Instance Methods

AddPermission | Add this permission to the set of permissions for this GroupAccount.
Clone (inherited from CacheRef) |
Copy | Creates a copy of this GroupAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Returns true if this GroupAccount has the specified permission.
IsEqualTo | Compares two GroupAccount objects.
IsMember | Return true if the specified user can be considered a member of this GroupAccount. A user is defined to be a member of a GroupAccount if it is directly a member of the GroupAccount or recusively of any sub-GroupAccount of this GroupAccount.
Remove | Removes this group from the StarTeam server, plus any direct or indirect subgroups of this group. If the GroupAccount was never saved (isNew() returns true), if it is a builtin account, or if removing this group or any of its descendants would leave one or more users without any group membership, then an exception will be thrown. Note also that any affected UserAccounts will be updated, including any pending changes, as a side effect of this method.
RemovePermission | Removes the specified permission from this GroupAccount.
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.
Update | Persistently saves the changes to this GroupAccount in the server. If the GroupAccount is new it will be added, otherwise it will be modified.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

GroupAccount Class | Borland.StarTeam Namespace


GroupAccount.AddPermission Method

Add this permission to the set of permissions for this GroupAccount.

public virtual void AddPermission(
Int32 permission
);

Parameters

permission
the permission to add

See Also

GroupAccount Class | Borland.StarTeam Namespace | Permission


GroupAccount.Copy Method

Creates a copy of this GroupAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().

public virtual GroupAccount Copy();

Return Value

A new copy of this GroupAccount object.

See Also

GroupAccount Class | Borland.StarTeam Namespace | isEqualTo


GroupAccount.HasPermission Method

Returns true if this GroupAccount has the specified permission.

public virtual bool HasPermission(
Int32 permission
);

Parameters

permission
the permission in question

Return Value

true if this GroupAccount has the specified permission.

See Also

GroupAccount Class | Borland.StarTeam Namespace | Permission


GroupAccount.IsEqualTo Method

Compares two GroupAccount objects.

public virtual bool IsEqualTo(
GroupAccount account
);

Parameters

account
The GroupAccount to be compared with this one.

Return Value

true if no differences were found.

See Also

GroupAccount Class | Borland.StarTeam Namespace | copy


GroupAccount.IsMember Method

Return true if the specified user can be considered a member of this GroupAccount. A user is defined to be a member of a GroupAccount if it is directly a member of the GroupAccount or recusively of any sub-GroupAccount of this GroupAccount.

public virtual bool IsMember(
Int32 userID
);

Parameters

userID
the user ID being checked for group membership

Return Value

true if the specified user ID is a member of this or any sub group

See Also

GroupAccount Class | Borland.StarTeam Namespace


GroupAccount.Remove Method

Removes this group from the StarTeam server, plus any direct or indirect subgroups of this group. If the GroupAccount was never saved (isNew() returns true), if it is a builtin account, or if removing this group or any of its descendants would leave one or more users without any group membership, then an exception will be thrown. Note also that any affected UserAccounts will be updated, including any pending changes, as a side effect of this method.

public virtual void Remove();

Exceptions

Exception Type | Condition
 | System.InvalidOperationException

See Also

GroupAccount Class | Borland.StarTeam Namespace | isNew


GroupAccount.RemovePermission Method

Removes the specified permission from this GroupAccount.

public virtual void RemovePermission(
Int32 permission
);

Parameters

permission
the permission to remove

See Also

GroupAccount Class | Borland.StarTeam Namespace | Permission


GroupAccount.Update Method

Persistently saves the changes to this GroupAccount in the server. If the GroupAccount is new it will be added, otherwise it will be modified.

public virtual void Update();

Exceptions

Exception Type | Condition
 | System.InvalidOperationException

See Also

GroupAccount Class | Borland.StarTeam Namespace


GroupAccount.Wrap Method

Dynamically wraps com.starbase.starteam.GroupAccount.

public static GroupAccount Wrap(
GroupAccount impl
);

Parameters

impl
com.starbase.starteam.GroupAccount to be wrapped.

Return Value

GroupAccount

See Also

GroupAccount Class | Borland.StarTeam Namespace


GroupAccount Type Conversions

The type conversions of the GroupAccount class are listed below. For a complete list of GroupAccount class members, see the GroupAccount Members topic.

Public Static Type Conversions

Implicit GroupAccount to GroupAccount Conversion Implicitly convert GroupAccount to com.starbase.starteam.GroupAccount.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

GroupAccount Class | GroupAccount Members | Borland.StarTeam Namespace


GroupAccount Implicit GroupAccount to GroupAccount Conversion

Implicitly convert GroupAccount to com.starbase.starteam.GroupAccount.

public static implicit operator GroupAccount(
GroupAccount arg
);

Parameters

arg
GroupAccount to convert.

Return Value

com.starbase.starteam.GroupAccount

See Also

GroupAccount Class | Borland.StarTeam Namespace


GroupAccountCollection Class

A strongly-typed collection of GroupAccounts.

For a list of all members of this type, see GroupAccountCollection Members.

System.Object
ArrayAdapter
GroupAccountCollection

public class GroupAccountCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

GroupAccountCollection Members | Borland.StarTeam Namespace


GroupAccountCollection Members

GroupAccountCollection overview

Public Static Methods

Wrap Creates a GroupAccountCollection to represent the given array of GroupAccount (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit GroupAccountCollection to GroupAccount[] Conversion | Converts a GroupAccountCollection to an array of GroupAccounts.
Implicit GroupAccountCollection to GroupAccount[] Conversion | Converts a GroupAccountCollection from the Borland.StarTeam namespace to a GroupAccount[] in the com.starbase.starteam namespace.

Public Instance Constructors

GroupAccountCollection Overloaded. Initializes a new instance of the GroupAccountCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the GroupAccount at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a GroupAccount to end of the collection.
Append | Overloaded. Appends the GroupAccounts of the given GroupAccountCollection to the end of this GroupAccountCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific GroupAccount.
CopyTo | Copies all of the GroupAccounts in the GroupAccountCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the GroupAccount with the given ID.
FindByName | Finds the GroupAccount with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific GroupAccount in the collection.
Insert | Inserts a GroupAccount into the collection at the specified position.
Remove | Removes the first occurrence of a specific GroupAccount from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the GroupAccounts in this GroupAccountCollection.
Sort | Sorts the GroupAccounts in this GroupAccountCollection, using the given comparer.
SortByID | Sorts the GroupAccounts in this GroupAccountCollection by ID.
SortByName | Sorts the GroupAccounts in this GroupAccountCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection Constructor

Initializes an instance of the GroupAccountCollection class.

Overload List

Initializes an instance of the GroupAccountCollection class.

public GroupAccountCollection();

Initializes an instance of the a GroupAccountCollection class, copying the given array.

public GroupAccountCollection(GroupAccount[]);

Initializes an instance of the a GroupAccountCollection class, copying the given collection.

public GroupAccountCollection(GroupAccountCollection);

Initializes an instance of the a GroupAccountCollection class, wrapping the given array of GroupAccount (from the com.starbase.starteam namespace).

public GroupAccountCollection(GroupAccount[]);

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection Constructor ()

Initializes an instance of the GroupAccountCollection class.

public GroupAccountCollection();

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace | GroupAccountCollection Constructor Overload List


GroupAccountCollection Constructor (GroupAccount[])

Initializes an instance of the a GroupAccountCollection class, wrapping the given array of GroupAccount (from the com.starbase.starteam namespace).

public GroupAccountCollection(
GroupAccount[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace | GroupAccountCollection Constructor Overload List | Wrap


GroupAccountCollection Constructor (GroupAccountCollection)

Initializes an instance of the a GroupAccountCollection class, copying the given collection.

public GroupAccountCollection(
GroupAccountCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member GroupAccount objects of the original collection are shared, not copied.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace | GroupAccountCollection Constructor Overload List


GroupAccountCollection Constructor (GroupAccount[])

Initializes an instance of the a GroupAccountCollection class, copying the given array.

public GroupAccountCollection(
GroupAccount[] array
);

Parameters

array
The array to be copied.

Remarks

The member GroupAccount objects of the original array are shared, not copied.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace | GroupAccountCollection Constructor Overload List


GroupAccountCollection Properties

The properties of the GroupAccountCollection class are listed below. For a complete list of GroupAccountCollection class members, see the GroupAccountCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the GroupAccount at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

GroupAccountCollection.Item Property

Gets or sets the GroupAccount at the specified index.

Overload List

Gets or sets the GroupAccount at the specified index.

public GroupAccount this[Int32] {get; set;}

Gets the GroupAccount with the given name.

public GroupAccount this[String] {get;}

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

GroupAccountCollection.Item Property (Int32)

Gets or sets the GroupAccount at the specified index.

public GroupAccount this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the GroupAccount to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace | GroupAccountCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

GroupAccountCollection.Item Property (String)

Gets the GroupAccount with the given name.

public GroupAccount this[
String name
] {get;}

Parameters

name
The name of the GroupAccount to get.

Property Value

The GroupAccount with the given name, or null if there is no GroupAccount with that name in this GroupAccountCollection. Comparison is case sensitive.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace | GroupAccountCollection.Item Overload List | FindByName


GroupAccountCollection Methods

The methods of the GroupAccountCollection class are listed below. For a complete list of GroupAccountCollection class members, see the GroupAccountCollection Members topic.

Public Static Methods

Wrap Creates a GroupAccountCollection to represent the given array of GroupAccount (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a GroupAccount to end of the collection.
Append | Overloaded. Appends the GroupAccounts of the given GroupAccountCollection to the end of this GroupAccountCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific GroupAccount.
CopyTo | Copies all of the GroupAccounts in the GroupAccountCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the GroupAccount with the given ID.
FindByName | Finds the GroupAccount with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific GroupAccount in the collection.
Insert | Inserts a GroupAccount into the collection at the specified position.
Remove | Removes the first occurrence of a specific GroupAccount from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the GroupAccounts in this GroupAccountCollection.
Sort | Sorts the GroupAccounts in this GroupAccountCollection, using the given comparer.
SortByID | Sorts the GroupAccounts in this GroupAccountCollection by ID.
SortByName | Sorts the GroupAccounts in this GroupAccountCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.Add Method

Adds a GroupAccount to end of the collection.

public int Add(
GroupAccount value
);

Parameters

value
The GroupAccount to add to the collection.

Return Value

The position into which the new GroupAccount was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

GroupAccountCollection.Append Method

Appends the GroupAccounts of the given array to the end of this GroupAccountCollection.

Overload List

Appends the GroupAccounts of the given array to the end of this GroupAccountCollection.

public GroupAccountCollection Append(GroupAccount[]);

Appends the GroupAccounts of the given GroupAccountCollection to the end of this GroupAccountCollection.

public GroupAccountCollection Append(GroupAccountCollection);

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.Append Method (GroupAccount[])

Appends the GroupAccounts of the given array to the end of this GroupAccountCollection.

public GroupAccountCollection Append(
GroupAccount[] array
);

Parameters

array
The array whose GroupAccounts are to be appended to this GroupAccountCollection.

Return Value

This GroupAccountCollection, modified to include the new GroupAccounts.

Remarks

The GroupAccountCollection is modified to include the new members. The individual GroupAccount objects are shared, not copied.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace | GroupAccountCollection.Append Overload List


GroupAccountCollection.Append Method (GroupAccountCollection)

Appends the GroupAccounts of the given GroupAccountCollection to the end of this GroupAccountCollection.

public GroupAccountCollection Append(
GroupAccountCollection collection
);

Parameters

collection
The GroupAccountCollection whose GroupAccounts are to be appended to this GroupAccountCollection.

Return Value

This GroupAccountCollection, modified to include the new GroupAccounts.

Remarks

The GroupAccountCollection is modified to include the new members. The individual GroupAccount objects are shared, not copied.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace | GroupAccountCollection.Append Overload List


GroupAccountCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.GroupAccount[].

Implements

IWrapper.Unwrap

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.Contains Method

Determines whether or not the collection contains a specific GroupAccount.

public bool Contains(
GroupAccount value
);

Parameters

value
The GroupAccount to locate in the collection.

Return Value

true if the GroupAccount is found in the collection; otherwise, false.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.CopyTo Method

Copies all of the GroupAccounts in the GroupAccountCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
GroupAccount[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the GroupAccounts copied from the GroupAccountCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of GroupAccounts in the source GroupAccountCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source GroupAccountCollection cannot be cast automatically to the type of the destination array.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.FindByID Method

Finds the GroupAccount with the given ID.

public GroupAccount FindByID(
Int32 id
);

Parameters

id
The ID of the GroupAccount to be found.

Return Value

The GroupAccount with the given ID, or null if there is no GroupAccount with that ID in this GroupAccountCollection.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.FindByName Method

Finds the GroupAccount with the given name.

public GroupAccount FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the GroupAccount to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The GroupAccount with the given name, or null if there is no GroupAccount with that name in this GroupAccountCollection.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.IndexOf Method

Determines the index of a specific GroupAccount in the collection.

public int IndexOf(
GroupAccount value
);

Parameters

value
The GroupAccount to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.Insert Method

Inserts a GroupAccount into the collection at the specified position.

public void Insert(
Int32 index,
GroupAccount value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The GroupAccount to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.Remove Method

Removes the first occurrence of a specific GroupAccount from the collection.

public void Remove(
GroupAccount value
);

Parameters

value
The GroupAccount to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.Reverse Method

Reverses the order of the GroupAccounts in this GroupAccountCollection.

new public GroupAccountCollection Reverse();

Return Value

This GroupAccountCollection, modified such that the GroupAccounts are reversed.

Remarks

The GroupAccountCollection is modified in place.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.Sort Method

Sorts the GroupAccounts in this GroupAccountCollection, using the given comparer.

new public GroupAccountCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two GroupAccounts.

Return Value

This GroupAccountCollection, modified such that the GroupAccounts are sorted.

Remarks

The GroupAccountCollection is modified in place.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.SortByID Method

Sorts the GroupAccounts in this GroupAccountCollection by ID.

public GroupAccountCollection SortByID();

Return Value

This GroupAccountCollection, modified such that the GroupAccounts are sorted by ID.

Remarks

The GroupAccountCollection is modified in place.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.SortByName Method

Sorts the GroupAccounts in this GroupAccountCollection by name.

public GroupAccountCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This GroupAccountCollection, modified such that the GroupAccounts are sorted by name.

Remarks

The GroupAccountCollection is modified in place.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection.Wrap Method

Creates a GroupAccountCollection to represent the given array of GroupAccount (from the com.starbase.starteam namespace).

public static GroupAccountCollection Wrap(
GroupAccount[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new GroupAccountCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a GroupAccount[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection Type Conversions

The type conversions of the GroupAccountCollection class are listed below. For a complete list of GroupAccountCollection class members, see the GroupAccountCollection Members topic.

Public Static Type Conversions

Implicit GroupAccountCollection to GroupAccount[] Conversion | Converts a GroupAccountCollection to an array of GroupAccounts.
Implicit GroupAccountCollection to GroupAccount[] Conversion | Converts a GroupAccountCollection from the Borland.StarTeam namespace to a GroupAccount[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupAccountCollection Class | GroupAccountCollection Members | Borland.StarTeam Namespace


GroupAccountCollection Implicit GroupAccountCollection to GroupAccount[] Conversion

Converts a GroupAccountCollection to an array of GroupAccounts.

public static implicit operator GroupAccount[](
GroupAccountCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new GroupAccount wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one GroupAccount wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupAccountCollection Implicit GroupAccountCollection to GroupAccount[] Conversion

Converts a GroupAccountCollection from the Borland.StarTeam namespace to a GroupAccount[] in the com.starbase.starteam namespace.

public static implicit operator GroupAccount[](
GroupAccountCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, GroupAccountCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

GroupAccountCollection Class | Borland.StarTeam Namespace


GroupCollection Class

A strongly-typed collection of Groups.

For a list of all members of this type, see GroupCollection Members.

System.Object
ArrayAdapter
GroupCollection

public class GroupCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

GroupCollection Members | Borland.StarTeam Namespace


GroupCollection Members

GroupCollection overview

Public Static Methods

Wrap Creates a GroupCollection to represent the given array of Group (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit GroupCollection to Group[] Conversion | Converts a GroupCollection to an array of Groups.
Implicit GroupCollection to Group[] Conversion | Converts a GroupCollection from the Borland.StarTeam namespace to a Group[] in the com.starbase.starteam namespace.

Public Instance Constructors

GroupCollection Overloaded. Initializes a new instance of the GroupCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Group at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Group to end of the collection.
Append | Overloaded. Appends the Groups of the given GroupCollection to the end of this GroupCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Group.
CopyTo | Copies all of the Groups in the GroupCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Group with the given ID.
FindByName | Finds the Group with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Group in the collection.
Insert | Inserts a Group into the collection at the specified position.
Remove | Removes the first occurrence of a specific Group from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Groups in this GroupCollection.
Sort | Sorts the Groups in this GroupCollection, using the given comparer.
SortByID | Sorts the Groups in this GroupCollection by ID.
SortByName | Sorts the Groups in this GroupCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection Constructor

Initializes an instance of the GroupCollection class.

Overload List

Initializes an instance of the GroupCollection class.

public GroupCollection();

Initializes an instance of the a GroupCollection class, copying the given array.

public GroupCollection(Group[]);

Initializes an instance of the a GroupCollection class, copying the given collection.

public GroupCollection(GroupCollection);

Initializes an instance of the a GroupCollection class, wrapping the given array of Group (from the com.starbase.starteam namespace).

public GroupCollection(Group[]);

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection Constructor ()

Initializes an instance of the GroupCollection class.

public GroupCollection();

See Also

GroupCollection Class | Borland.StarTeam Namespace | GroupCollection Constructor Overload List


GroupCollection Constructor (Group[])

Initializes an instance of the a GroupCollection class, wrapping the given array of Group (from the com.starbase.starteam namespace).

public GroupCollection(
Group[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

GroupCollection Class | Borland.StarTeam Namespace | GroupCollection Constructor Overload List | Wrap


GroupCollection Constructor (GroupCollection)

Initializes an instance of the a GroupCollection class, copying the given collection.

public GroupCollection(
GroupCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Group objects of the original collection are shared, not copied.

See Also

GroupCollection Class | Borland.StarTeam Namespace | GroupCollection Constructor Overload List


GroupCollection Constructor (Group[])

Initializes an instance of the a GroupCollection class, copying the given array.

public GroupCollection(
Group[] array
);

Parameters

array
The array to be copied.

Remarks

The member Group objects of the original array are shared, not copied.

See Also

GroupCollection Class | Borland.StarTeam Namespace | GroupCollection Constructor Overload List


GroupCollection Properties

The properties of the GroupCollection class are listed below. For a complete list of GroupCollection class members, see the GroupCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Group at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

GroupCollection.Item Property

Gets or sets the Group at the specified index.

Overload List

Gets or sets the Group at the specified index.

public Group this[Int32] {get; set;}

Gets the Group with the given name.

public Group this[String] {get;}

See Also

GroupCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

GroupCollection.Item Property (Int32)

Gets or sets the Group at the specified index.

public Group this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Group to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

GroupCollection Class | Borland.StarTeam Namespace | GroupCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

GroupCollection.Item Property (String)

Gets the Group with the given name.

public Group this[
String name
] {get;}

Parameters

name
The name of the Group to get.

Property Value

The Group with the given name, or null if there is no Group with that name in this GroupCollection. Comparison is case sensitive.

See Also

GroupCollection Class | Borland.StarTeam Namespace | GroupCollection.Item Overload List | FindByName


GroupCollection Methods

The methods of the GroupCollection class are listed below. For a complete list of GroupCollection class members, see the GroupCollection Members topic.

Public Static Methods

Wrap Creates a GroupCollection to represent the given array of Group (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a Group to end of the collection.
Append | Overloaded. Appends the Groups of the given GroupCollection to the end of this GroupCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Group.
CopyTo | Copies all of the Groups in the GroupCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Group with the given ID.
FindByName | Finds the Group with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Group in the collection.
Insert | Inserts a Group into the collection at the specified position.
Remove | Removes the first occurrence of a specific Group from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Groups in this GroupCollection.
Sort | Sorts the Groups in this GroupCollection, using the given comparer.
SortByID | Sorts the Groups in this GroupCollection by ID.
SortByName | Sorts the Groups in this GroupCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.Add Method

Adds a Group to end of the collection.

public int Add(
Group value
);

Parameters

value
The Group to add to the collection.

Return Value

The position into which the new Group was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

GroupCollection.Append Method

Appends the Groups of the given array to the end of this GroupCollection.

Overload List

Appends the Groups of the given array to the end of this GroupCollection.

public GroupCollection Append(Group[]);

Appends the Groups of the given GroupCollection to the end of this GroupCollection.

public GroupCollection Append(GroupCollection);

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.Append Method (Group[])

Appends the Groups of the given array to the end of this GroupCollection.

public GroupCollection Append(
Group[] array
);

Parameters

array
The array whose Groups are to be appended to this GroupCollection.

Return Value

This GroupCollection, modified to include the new Groups.

Remarks

The GroupCollection is modified to include the new members. The individual Group objects are shared, not copied.

See Also

GroupCollection Class | Borland.StarTeam Namespace | GroupCollection.Append Overload List


GroupCollection.Append Method (GroupCollection)

Appends the Groups of the given GroupCollection to the end of this GroupCollection.

public GroupCollection Append(
GroupCollection collection
);

Parameters

collection
The GroupCollection whose Groups are to be appended to this GroupCollection.

Return Value

This GroupCollection, modified to include the new Groups.

Remarks

The GroupCollection is modified to include the new members. The individual Group objects are shared, not copied.

See Also

GroupCollection Class | Borland.StarTeam Namespace | GroupCollection.Append Overload List


GroupCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.Group[].

Implements

IWrapper.Unwrap

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.Contains Method

Determines whether or not the collection contains a specific Group.

public bool Contains(
Group value
);

Parameters

value
The Group to locate in the collection.

Return Value

true if the Group is found in the collection; otherwise, false.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.CopyTo Method

Copies all of the Groups in the GroupCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Group[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Groups copied from the GroupCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Groups in the source GroupCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source GroupCollection cannot be cast automatically to the type of the destination array.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.FindByID Method

Finds the Group with the given ID.

public Group FindByID(
Int32 id
);

Parameters

id
The ID of the Group to be found.

Return Value

The Group with the given ID, or null if there is no Group with that ID in this GroupCollection.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.FindByName Method

Finds the Group with the given name.

public Group FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the Group to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The Group with the given name, or null if there is no Group with that name in this GroupCollection.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.IndexOf Method

Determines the index of a specific Group in the collection.

public int IndexOf(
Group value
);

Parameters

value
The Group to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.Insert Method

Inserts a Group into the collection at the specified position.

public void Insert(
Int32 index,
Group value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Group to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.Remove Method

Removes the first occurrence of a specific Group from the collection.

public void Remove(
Group value
);

Parameters

value
The Group to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.Reverse Method

Reverses the order of the Groups in this GroupCollection.

new public GroupCollection Reverse();

Return Value

This GroupCollection, modified such that the Groups are reversed.

Remarks

The GroupCollection is modified in place.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.Sort Method

Sorts the Groups in this GroupCollection, using the given comparer.

new public GroupCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Groups.

Return Value

This GroupCollection, modified such that the Groups are sorted.

Remarks

The GroupCollection is modified in place.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.SortByID Method

Sorts the Groups in this GroupCollection by ID.

public GroupCollection SortByID();

Return Value

This GroupCollection, modified such that the Groups are sorted by ID.

Remarks

The GroupCollection is modified in place.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.SortByName Method

Sorts the Groups in this GroupCollection by name.

public GroupCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This GroupCollection, modified such that the Groups are sorted by name.

Remarks

The GroupCollection is modified in place.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection.Wrap Method

Creates a GroupCollection to represent the given array of Group (from the com.starbase.starteam namespace).

public static GroupCollection Wrap(
Group[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new GroupCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a Group[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection Type Conversions

The type conversions of the GroupCollection class are listed below. For a complete list of GroupCollection class members, see the GroupCollection Members topic.

Public Static Type Conversions

Implicit GroupCollection to Group[] Conversion | Converts a GroupCollection to an array of Groups.
Implicit GroupCollection to Group[] Conversion | Converts a GroupCollection from the Borland.StarTeam namespace to a Group[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupCollection Class | GroupCollection Members | Borland.StarTeam Namespace


GroupCollection Implicit GroupCollection to Group[] Conversion

Converts a GroupCollection to an array of Groups.

public static implicit operator Group[](
GroupCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Group wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Group wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupCollection Implicit GroupCollection to Group[] Conversion

Converts a GroupCollection from the Borland.StarTeam namespace to a Group[] in the com.starbase.starteam namespace.

public static implicit operator Group[](
GroupCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, GroupCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

GroupCollection Class | Borland.StarTeam Namespace


GroupNode Class

Describes a group of objects that may be a subgroup of a larger, indexable group. Maintains a range mapping into the underlying ordered collection. Each Node may be in an expanded or collapsed state. Note that it is the client's responsibility to ensure valid index ranges relative to the underlying collection.

For a list of all members of this type, see GroupNode Members.

System.Object
GroupNode

public class GroupNode : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

GroupNode Members | Borland.StarTeam Namespace


GroupNode Members

GroupNode overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.GroupNode.

Public Static Type Conversions

Implicit GroupNode to GroupNode Conversion Implicitly convert GroupNode to com.starbase.starteam.GroupNode.

Public Instance Constructors

GroupNode Overloaded. Initializes a new instance of the GroupNode class.

Public Instance Properties

Children | [read] the direct subgroups of this group.
Depth | [read] the zero-based depth of this GroupNode in the grouping hierarchy.
IsExpanded | [read/write] true if this GroupNode is expanded.
IsLeafNode | [read] true if this is a leaf-level GroupNode.
Length | [read] the number of contiguous objects spanned in the underlying indexable collection.
Name | [read] the display name of this group.
NumChildren | [read] the number of direct subgroups of this group.
NumVisibleLines | [read] the number of visible lines represented in this node, based on the current collapsed/expanded state of the hierarchy.
Parent | [read] the parent GroupNode.
Start | [read] the index of the first leaf object of this node in the associated indexable collection.

Public Instance Methods

AddChild | Adds a GroupNode as a child of this GroupNode.
Equals | Delegate Equals() to com.starbase.starteam.GroupNode.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.GroupNode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToDebugString | Prints a String representation of the GroupNode, helpful for debugging.
ToString | Delegate ToString() to com.starbase.starteam.GroupNode.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNode Constructor

Construct GroupNode from com.starbase.starteam.GroupNode.

Overload List

Construct GroupNode from com.starbase.starteam.GroupNode.

public GroupNode(GroupNode);

Creates a GroupNode containing a set of objects in the associated indexable collection.

public GroupNode(String,Int32,Int32);

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNode Constructor (GroupNode)

Construct GroupNode from com.starbase.starteam.GroupNode.

public GroupNode(
GroupNode impl
);

Parameters

impl
The com.starbase.starteam.GroupNode to be wrapped.

See Also

GroupNode Class | Borland.StarTeam Namespace | GroupNode Constructor Overload List


GroupNode Constructor (String, Int32, Int32)

Creates a GroupNode containing a set of objects in the associated indexable collection.

public GroupNode(
String name,
Int32 start,
Int32 length
);

Parameters

name
The display name for the group.
start
The index of the first object that belongs to this group in the associated indexable collection.
length
The number of contiguous objects in the associated collection that belong to this group.

See Also

GroupNode Class | Borland.StarTeam Namespace | GroupNode Constructor Overload List


GroupNode Properties

The properties of the GroupNode class are listed below. For a complete list of GroupNode class members, see the GroupNode Members topic.

Public Instance Properties

Children | [read] the direct subgroups of this group.
Depth | [read] the zero-based depth of this GroupNode in the grouping hierarchy.
IsExpanded | [read/write] true if this GroupNode is expanded.
IsLeafNode | [read] true if this is a leaf-level GroupNode.
Length | [read] the number of contiguous objects spanned in the underlying indexable collection.
Name | [read] the display name of this group.
NumChildren | [read] the number of direct subgroups of this group.
NumVisibleLines | [read] the number of visible lines represented in this node, based on the current collapsed/expanded state of the hierarchy.
Parent | [read] the parent GroupNode.
Start | [read] the index of the first leaf object of this node in the associated indexable collection.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GroupNode Class | Borland.StarTeam Namespace


Children Property

Borland StarTeam SDK for .NET

GroupNode.Children Property

[read] the direct subgroups of this group.

public virtual GroupNodeCollection Children {get;}

Property Value

the direct subgroups of this group.

See Also

GroupNode Class | Borland.StarTeam Namespace


Depth Property

Borland StarTeam SDK for .NET

GroupNode.Depth Property

[read] the zero-based depth of this GroupNode in the grouping hierarchy.

public virtual Int32 Depth {get;}

Property Value

the zero-based depth of this GroupNode in the grouping hierarchy.

See Also

GroupNode Class | Borland.StarTeam Namespace


IsExpanded Property

Borland StarTeam SDK for .NET

GroupNode.IsExpanded Property

[read/write] true if this GroupNode is expanded.

public virtual Boolean IsExpanded {get; set;}

Property Value

true if this GroupNode is expanded.

See Also

GroupNode Class | Borland.StarTeam Namespace


IsLeafNode Property

Borland StarTeam SDK for .NET

GroupNode.IsLeafNode Property

[read] true if this is a leaf-level GroupNode.

public virtual Boolean IsLeafNode {get;}

Property Value

true if this is a leaf-level GroupNode.

See Also

GroupNode Class | Borland.StarTeam Namespace


Length Property

Borland StarTeam SDK for .NET

GroupNode.Length Property

[read] the number of contiguous objects spanned in the underlying indexable collection.

public virtual Int32 Length {get;}

Property Value

the number of contiguous objects spanned in the underlying indexable collection.

See Also

GroupNode Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

GroupNode.Name Property

[read] the display name of this group.

public virtual String Name {get;}

Property Value

the display name of this group.

See Also

GroupNode Class | Borland.StarTeam Namespace


NumChildren Property

Borland StarTeam SDK for .NET

GroupNode.NumChildren Property

[read] the number of direct subgroups of this group.

public virtual Int32 NumChildren {get;}

Property Value

the number of direct subgroups of this group.

See Also

GroupNode Class | Borland.StarTeam Namespace


NumVisibleLines Property

Borland StarTeam SDK for .NET

GroupNode.NumVisibleLines Property

[read] the number of visible lines represented in this node, based on the current collapsed/expanded state of the hierarchy.

public virtual Int32 NumVisibleLines {get;}

Property Value

the number of visible lines represented in this node, based on the current collapsed/expanded state of the hierarchy.

See Also

GroupNode Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

GroupNode.Parent Property

[read] the parent GroupNode.

public virtual GroupNode Parent {get;}

Property Value

the parent GroupNode.

See Also

GroupNode Class | Borland.StarTeam Namespace


Start Property

Borland StarTeam SDK for .NET

GroupNode.Start Property

[read] the index of the first leaf object of this node in the associated indexable collection.

public virtual Int32 Start {get;}

Property Value

the index of the first leaf object of this node in the associated indexable collection.

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNode Methods

The methods of the GroupNode class are listed below. For a complete list of GroupNode class members, see the GroupNode Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.GroupNode.

Public Instance Methods

AddChild | Adds a GroupNode as a child of this GroupNode.
Equals | Delegate Equals() to com.starbase.starteam.GroupNode.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.GroupNode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToDebugString | Prints a String representation of the GroupNode, helpful for debugging.
ToString | Delegate ToString() to com.starbase.starteam.GroupNode.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNode.AddChild Method

Adds a GroupNode as a child of this GroupNode.

public virtual void AddChild(
GroupNode child
);

Parameters

child
The GroupNode to add as a child of this one.

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNode.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.GroupNode

Implements

IWrapper.Unwrap

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNode.Equals Method

Delegate Equals() to com.starbase.starteam.GroupNode.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.GroupNode.Equals(obj).

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNode.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.GroupNode.

public override int GetHashCode();

Return Value

com.starbase.starteam.GroupNode.GetHashCode().

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNode.ToDebugString Method

Prints a String representation of the GroupNode, helpful for debugging.

public virtual void ToDebugString();

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNode.ToString Method

Delegate ToString() to com.starbase.starteam.GroupNode.

public override string ToString();

Return Value

com.starbase.starteam.GroupNode.ToString()

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNode.Wrap Method

Dynamically wraps com.starbase.starteam.GroupNode.

public static GroupNode Wrap(
GroupNode impl
);

Parameters

impl
com.starbase.starteam.GroupNode to be wrapped.

Return Value

GroupNode

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNode Type Conversions

The type conversions of the GroupNode class are listed below. For a complete list of GroupNode class members, see the GroupNode Members topic.

Public Static Type Conversions

Implicit GroupNode to GroupNode Conversion Implicitly convert GroupNode to com.starbase.starteam.GroupNode.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GroupNode Class | GroupNode Members | Borland.StarTeam Namespace


GroupNode Implicit GroupNode to GroupNode Conversion

Implicitly convert GroupNode to com.starbase.starteam.GroupNode.

public static implicit operator GroupNode(
GroupNode arg
);

Parameters

arg
GroupNode to convert.

Return Value

com.starbase.starteam.GroupNode

See Also

GroupNode Class | Borland.StarTeam Namespace


GroupNodeCollection Class

A strongly-typed collection of GroupNodes.

For a list of all members of this type, see GroupNodeCollection Members.

System.Object
ArrayAdapter
GroupNodeCollection

public class GroupNodeCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

GroupNodeCollection Members | Borland.StarTeam Namespace


GroupNodeCollection Members

GroupNodeCollection overview

Public Static Methods

Wrap Creates a GroupNodeCollection to represent the given array of GroupNode (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit GroupNodeCollection to GroupNode[] Conversion | Converts a GroupNodeCollection to an array of GroupNodes.
Implicit GroupNodeCollection to GroupNode[] Conversion | Converts a GroupNodeCollection from the Borland.StarTeam namespace to a GroupNode[] in the com.starbase.starteam namespace.

Public Instance Constructors

GroupNodeCollection Overloaded. Initializes a new instance of the GroupNodeCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the GroupNode at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a GroupNode to end of the collection.
Append | Overloaded. Appends the GroupNodes of the given GroupNodeCollection to the end of this GroupNodeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific GroupNode.
CopyTo | Copies all of the GroupNodes in the GroupNodeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the GroupNode with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific GroupNode in the collection.
Insert | Inserts a GroupNode into the collection at the specified position.
Remove | Removes the first occurrence of a specific GroupNode from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the GroupNodes in this GroupNodeCollection.
Sort | Sorts the GroupNodes in this GroupNodeCollection, using the given comparer.
SortByName | Sorts the GroupNodes in this GroupNodeCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection Constructor

Initializes an instance of the GroupNodeCollection class.

Overload List

Initializes an instance of the GroupNodeCollection class.

public GroupNodeCollection();

Initializes an instance of the a GroupNodeCollection class, copying the given array.

public GroupNodeCollection(GroupNode[]);

Initializes an instance of the a GroupNodeCollection class, copying the given collection.

public GroupNodeCollection(GroupNodeCollection);

Initializes an instance of the a GroupNodeCollection class, wrapping the given array of GroupNode (from the com.starbase.starteam namespace).

public GroupNodeCollection(GroupNode[]);

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection Constructor ()

Initializes an instance of the GroupNodeCollection class.

public GroupNodeCollection();

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace | GroupNodeCollection Constructor Overload List


GroupNodeCollection Constructor (GroupNode[])

Initializes an instance of the a GroupNodeCollection class, wrapping the given array of GroupNode (from the com.starbase.starteam namespace).

public GroupNodeCollection(
GroupNode[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace | GroupNodeCollection Constructor Overload List | Wrap


GroupNodeCollection Constructor (GroupNodeCollection)

Initializes an instance of the a GroupNodeCollection class, copying the given collection.

public GroupNodeCollection(
GroupNodeCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member GroupNode objects of the original collection are shared, not copied.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace | GroupNodeCollection Constructor Overload List


GroupNodeCollection Constructor (GroupNode[])

Initializes an instance of the a GroupNodeCollection class, copying the given array.

public GroupNodeCollection(
GroupNode[] array
);

Parameters

array
The array to be copied.

Remarks

The member GroupNode objects of the original array are shared, not copied.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace | GroupNodeCollection Constructor Overload List


GroupNodeCollection Properties

The properties of the GroupNodeCollection class are listed below. For a complete list of GroupNodeCollection class members, see the GroupNodeCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the GroupNode at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

GroupNodeCollection.Item Property

Gets or sets the GroupNode at the specified index.

Overload List

Gets or sets the GroupNode at the specified index.

public GroupNode this[Int32] {get; set;}

Gets the GroupNode with the given name.

public GroupNode this[String] {get;}

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

GroupNodeCollection.Item Property (Int32)

Gets or sets the GroupNode at the specified index.

public GroupNode this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the GroupNode to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace | GroupNodeCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

GroupNodeCollection.Item Property (String)

Gets the GroupNode with the given name.

public GroupNode this[
String name
] {get;}

Parameters

name
The name of the GroupNode to get.

Property Value

The GroupNode with the given name, or null if there is no GroupNode with that name in this GroupNodeCollection. Comparison is case sensitive.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace | GroupNodeCollection.Item Overload List | FindByName


GroupNodeCollection Methods

The methods of the GroupNodeCollection class are listed below. For a complete list of GroupNodeCollection class members, see the GroupNodeCollection Members topic.

Public Static Methods

Wrap Creates a GroupNodeCollection to represent the given array of GroupNode (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a GroupNode to end of the collection.
Append | Overloaded. Appends the GroupNodes of the given GroupNodeCollection to the end of this GroupNodeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific GroupNode.
CopyTo | Copies all of the GroupNodes in the GroupNodeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the GroupNode with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific GroupNode in the collection.
Insert | Inserts a GroupNode into the collection at the specified position.
Remove | Removes the first occurrence of a specific GroupNode from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the GroupNodes in this GroupNodeCollection.
Sort | Sorts the GroupNodes in this GroupNodeCollection, using the given comparer.
SortByName | Sorts the GroupNodes in this GroupNodeCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.Add Method

Adds a GroupNode to end of the collection.

public int Add(
GroupNode value
);

Parameters

value
The GroupNode to add to the collection.

Return Value

The position into which the new GroupNode was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

GroupNodeCollection.Append Method

Appends the GroupNodes of the given array to the end of this GroupNodeCollection.

Overload List

Appends the GroupNodes of the given array to the end of this GroupNodeCollection.

public GroupNodeCollection Append(GroupNode[]);

Appends the GroupNodes of the given GroupNodeCollection to the end of this GroupNodeCollection.

public GroupNodeCollection Append(GroupNodeCollection);

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.Append Method (GroupNode[])

Appends the GroupNodes of the given array to the end of this GroupNodeCollection.

public GroupNodeCollection Append(
GroupNode[] array
);

Parameters

array
The array whose GroupNodes are to be appended to this GroupNodeCollection.

Return Value

This GroupNodeCollection, modified to include the new GroupNodes.

Remarks

The GroupNodeCollection is modified to include the new members. The individual GroupNode objects are shared, not copied.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace | GroupNodeCollection.Append Overload List


GroupNodeCollection.Append Method (GroupNodeCollection)

Appends the GroupNodes of the given GroupNodeCollection to the end of this GroupNodeCollection.

public GroupNodeCollection Append(
GroupNodeCollection collection
);

Parameters

collection
The GroupNodeCollection whose GroupNodes are to be appended to this GroupNodeCollection.

Return Value

This GroupNodeCollection, modified to include the new GroupNodes.

Remarks

The GroupNodeCollection is modified to include the new members. The individual GroupNode objects are shared, not copied.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace | GroupNodeCollection.Append Overload List


GroupNodeCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.GroupNode[].

Implements

IWrapper.Unwrap

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.Contains Method

Determines whether or not the collection contains a specific GroupNode.

public bool Contains(
GroupNode value
);

Parameters

value
The GroupNode to locate in the collection.

Return Value

true if the GroupNode is found in the collection; otherwise, false.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.CopyTo Method

Copies all of the GroupNodes in the GroupNodeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
GroupNode[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the GroupNodes copied from the GroupNodeCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of GroupNodes in the source GroupNodeCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source GroupNodeCollection cannot be cast automatically to the type of the destination array.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.FindByName Method

Finds the GroupNode with the given name.

public GroupNode FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the GroupNode to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The GroupNode with the given name, or null if there is no GroupNode with that name in this GroupNodeCollection.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.IndexOf Method

Determines the index of a specific GroupNode in the collection.

public int IndexOf(
GroupNode value
);

Parameters

value
The GroupNode to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.Insert Method

Inserts a GroupNode into the collection at the specified position.

public void Insert(
Int32 index,
GroupNode value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The GroupNode to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.Remove Method

Removes the first occurrence of a specific GroupNode from the collection.

public void Remove(
GroupNode value
);

Parameters

value
The GroupNode to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.Reverse Method

Reverses the order of the GroupNodes in this GroupNodeCollection.

new public GroupNodeCollection Reverse();

Return Value

This GroupNodeCollection, modified such that the GroupNodes are reversed.

Remarks

The GroupNodeCollection is modified in place.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.Sort Method

Sorts the GroupNodes in this GroupNodeCollection, using the given comparer.

new public GroupNodeCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two GroupNodes.

Return Value

This GroupNodeCollection, modified such that the GroupNodes are sorted.

Remarks

The GroupNodeCollection is modified in place.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.SortByName Method

Sorts the GroupNodes in this GroupNodeCollection by name.

public GroupNodeCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This GroupNodeCollection, modified such that the GroupNodes are sorted by name.

Remarks

The GroupNodeCollection is modified in place.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection.Wrap Method

Creates a GroupNodeCollection to represent the given array of GroupNode (from the com.starbase.starteam namespace).

public static GroupNodeCollection Wrap(
GroupNode[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new GroupNodeCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a GroupNode[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection Type Conversions

The type conversions of the GroupNodeCollection class are listed below. For a complete list of GroupNodeCollection class members, see the GroupNodeCollection Members topic.

Public Static Type Conversions

Implicit GroupNodeCollection to GroupNode[] Conversion | Converts a GroupNodeCollection to an array of GroupNodes.
Implicit GroupNodeCollection to GroupNode[] Conversion | Converts a GroupNodeCollection from the Borland.StarTeam namespace to a GroupNode[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupNodeCollection Class | GroupNodeCollection Members | Borland.StarTeam Namespace


GroupNodeCollection Implicit GroupNodeCollection to GroupNode[] Conversion

Converts a GroupNodeCollection to an array of GroupNodes.

public static implicit operator GroupNode[](
GroupNodeCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new GroupNode wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one GroupNode wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupNodeCollection Implicit GroupNodeCollection to GroupNode[] Conversion

Converts a GroupNodeCollection from the Borland.StarTeam namespace to a GroupNode[] in the com.starbase.starteam namespace.

public static implicit operator GroupNode[](
GroupNodeCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, GroupNodeCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

GroupNodeCollection Class | Borland.StarTeam Namespace


GroupSortInfo Class

For a list of all members of this type, see GroupSortInfo Members.

System.Object
GroupSortInfo

public class GroupSortInfo : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

GroupSortInfo Members | Borland.StarTeam Namespace


GroupSortInfo Members

GroupSortInfo overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.GroupSortInfo.

Public Static Type Conversions

Implicit GroupSortInfo to GroupSortInfo Conversion Implicitly convert GroupSortInfo to com.starbase.starteam.GroupSortInfo.

Public Instance Constructors

GroupSortInfo Overloaded. Initializes a new instance of the GroupSortInfo class.

Public Instance Properties

DebugString | [read]
IsAscending | [read/write]
IsByDateOnly | [read/write]
IsByTextValue | [read/write]
IsCaseSensitive | [read/write]
IsGroup | [read]
IsSort | [read]
PropertyID | [read/write]

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.GroupSortInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.GroupSortInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.GroupSortInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


GroupSortInfo Constructor

Construct GroupSortInfo from com.starbase.starteam.GroupSortInfo.

Overload List

Construct GroupSortInfo from com.starbase.starteam.GroupSortInfo.

public GroupSortInfo(GroupSortInfo);

public GroupSortInfo(Boolean,Int32,Boolean);

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


GroupSortInfo Constructor (GroupSortInfo)

Construct GroupSortInfo from com.starbase.starteam.GroupSortInfo.

public GroupSortInfo(
GroupSortInfo impl
);

Parameters

impl
The com.starbase.starteam.GroupSortInfo to be wrapped.

See Also

GroupSortInfo Class | Borland.StarTeam Namespace | GroupSortInfo Constructor Overload List


GroupSortInfo Constructor (Boolean, Int32, Boolean)

public GroupSortInfo(
Boolean group,
Int32 propertyID,
Boolean ascending
);

Parameters

group
propertyID
ascending

See Also

GroupSortInfo Class | Borland.StarTeam Namespace | GroupSortInfo Constructor Overload List


GroupSortInfo Properties

The properties of the GroupSortInfo class are listed below. For a complete list of GroupSortInfo class members, see the GroupSortInfo Members topic.

Public Instance Properties

DebugString | [read]
IsAscending | [read/write]
IsByDateOnly | [read/write]
IsByTextValue | [read/write]
IsCaseSensitive | [read/write]
IsGroup | [read]
IsSort | [read]
PropertyID | [read/write]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

GroupSortInfo.DebugString Property

[read]

public virtual String DebugString {get;}

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


IsAscending Property

Borland StarTeam SDK for .NET

GroupSortInfo.IsAscending Property

[read/write]

public virtual Boolean IsAscending {get; set;}

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


IsByDateOnly Property

Borland StarTeam SDK for .NET

GroupSortInfo.IsByDateOnly Property

[read/write]

public virtual Boolean IsByDateOnly {get; set;}

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


IsByTextValue Property

Borland StarTeam SDK for .NET

GroupSortInfo.IsByTextValue Property

[read/write]

public virtual Boolean IsByTextValue {get; set;}

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


IsCaseSensitive Property

Borland StarTeam SDK for .NET

GroupSortInfo.IsCaseSensitive Property

[read/write]

public virtual Boolean IsCaseSensitive {get; set;}

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


IsGroup Property

Borland StarTeam SDK for .NET

GroupSortInfo.IsGroup Property

[read]

public virtual Boolean IsGroup {get;}

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


IsSort Property

Borland StarTeam SDK for .NET

GroupSortInfo.IsSort Property

[read]

public virtual Boolean IsSort {get;}

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


PropertyID Property

Borland StarTeam SDK for .NET

GroupSortInfo.PropertyID Property

[read/write]

public virtual Int32 PropertyID {get; set;}

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


GroupSortInfo Methods

The methods of the GroupSortInfo class are listed below. For a complete list of GroupSortInfo class members, see the GroupSortInfo Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.GroupSortInfo.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.GroupSortInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.GroupSortInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.GroupSortInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


GroupSortInfo.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.GroupSortInfo

Implements

IWrapper.Unwrap

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


GroupSortInfo.Equals Method

Delegate Equals() to com.starbase.starteam.GroupSortInfo.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.GroupSortInfo.Equals(obj).

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


GroupSortInfo.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.GroupSortInfo.

public override int GetHashCode();

Return Value

com.starbase.starteam.GroupSortInfo.GetHashCode().

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


GroupSortInfo.ToString Method

Delegate ToString() to com.starbase.starteam.GroupSortInfo.

public override string ToString();

Return Value

com.starbase.starteam.GroupSortInfo.ToString()

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


GroupSortInfo.Wrap Method

Dynamically wraps com.starbase.starteam.GroupSortInfo.

public static GroupSortInfo Wrap(
GroupSortInfo impl
);

Parameters

impl
com.starbase.starteam.GroupSortInfo to be wrapped.

Return Value

GroupSortInfo

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


GroupSortInfo Type Conversions

The type conversions of the GroupSortInfo class are listed below. For a complete list of GroupSortInfo class members, see the GroupSortInfo Members topic.

Public Static Type Conversions

Implicit GroupSortInfo to GroupSortInfo Conversion Implicitly convert GroupSortInfo to com.starbase.starteam.GroupSortInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GroupSortInfo Class | GroupSortInfo Members | Borland.StarTeam Namespace


GroupSortInfo Implicit GroupSortInfo to GroupSortInfo Conversion

Implicitly convert GroupSortInfo to com.starbase.starteam.GroupSortInfo.

public static implicit operator GroupSortInfo(
GroupSortInfo arg
);

Parameters

arg
GroupSortInfo to convert.

Return Value

com.starbase.starteam.GroupSortInfo

See Also

GroupSortInfo Class | Borland.StarTeam Namespace


GroupSortInfoCollection Class

A strongly-typed collection of GroupSortInfos.

For a list of all members of this type, see GroupSortInfoCollection Members.

System.Object
ArrayAdapter
GroupSortInfoCollection

public class GroupSortInfoCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

GroupSortInfoCollection Members | Borland.StarTeam Namespace


GroupSortInfoCollection Members

GroupSortInfoCollection overview

Public Static Methods

Wrap Creates a GroupSortInfoCollection to represent the given array of GroupSortInfo (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit GroupSortInfoCollection to GroupSortInfo[] Conversion | Converts a GroupSortInfoCollection to an array of GroupSortInfos.
Implicit GroupSortInfoCollection to GroupSortInfo[] Conversion | Converts a GroupSortInfoCollection from the Borland.StarTeam namespace to a GroupSortInfo[] in the com.starbase.starteam namespace.

Public Instance Constructors

GroupSortInfoCollection Overloaded. Initializes a new instance of the GroupSortInfoCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the GroupSortInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a GroupSortInfo to end of the collection.
Append | Overloaded. Appends the GroupSortInfos of the given GroupSortInfoCollection to the end of this GroupSortInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific GroupSortInfo.
CopyTo | Copies all of the GroupSortInfos in the GroupSortInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific GroupSortInfo in the collection.
Insert | Inserts a GroupSortInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific GroupSortInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the GroupSortInfos in this GroupSortInfoCollection.
Sort | Sorts the GroupSortInfos in this GroupSortInfoCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection Constructor

Initializes an instance of the GroupSortInfoCollection class.

Overload List

Initializes an instance of the GroupSortInfoCollection class.

public GroupSortInfoCollection();

Initializes an instance of the a GroupSortInfoCollection class, copying the given array.

public GroupSortInfoCollection(GroupSortInfo[]);

Initializes an instance of the a GroupSortInfoCollection class, copying the given collection.

public GroupSortInfoCollection(GroupSortInfoCollection);

Initializes an instance of the a GroupSortInfoCollection class, wrapping the given array of GroupSortInfo (from the com.starbase.starteam namespace).

public GroupSortInfoCollection(GroupSortInfo[]);

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection Constructor ()

Initializes an instance of the GroupSortInfoCollection class.

public GroupSortInfoCollection();

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace | GroupSortInfoCollection Constructor Overload List


GroupSortInfoCollection Constructor (GroupSortInfo[])

Initializes an instance of the a GroupSortInfoCollection class, wrapping the given array of GroupSortInfo (from the com.starbase.starteam namespace).

public GroupSortInfoCollection(
GroupSortInfo[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace | GroupSortInfoCollection Constructor Overload List | Wrap


GroupSortInfoCollection Constructor (GroupSortInfoCollection)

Initializes an instance of the a GroupSortInfoCollection class, copying the given collection.

public GroupSortInfoCollection(
GroupSortInfoCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member GroupSortInfo objects of the original collection are shared, not copied.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace | GroupSortInfoCollection Constructor Overload List


GroupSortInfoCollection Constructor (GroupSortInfo[])

Initializes an instance of the a GroupSortInfoCollection class, copying the given array.

public GroupSortInfoCollection(
GroupSortInfo[] array
);

Parameters

array
The array to be copied.

Remarks

The member GroupSortInfo objects of the original array are shared, not copied.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace | GroupSortInfoCollection Constructor Overload List


GroupSortInfoCollection Properties

The properties of the GroupSortInfoCollection class are listed below. For a complete list of GroupSortInfoCollection class members, see the GroupSortInfoCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the GroupSortInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

GroupSortInfoCollection.Item Property

Gets or sets the GroupSortInfo at the specified index.

public GroupSortInfo this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the GroupSortInfo to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection Methods

The methods of the GroupSortInfoCollection class are listed below. For a complete list of GroupSortInfoCollection class members, see the GroupSortInfoCollection Members topic.

Public Static Methods

Wrap Creates a GroupSortInfoCollection to represent the given array of GroupSortInfo (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a GroupSortInfo to end of the collection.
Append | Overloaded. Appends the GroupSortInfos of the given GroupSortInfoCollection to the end of this GroupSortInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific GroupSortInfo.
CopyTo | Copies all of the GroupSortInfos in the GroupSortInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific GroupSortInfo in the collection.
Insert | Inserts a GroupSortInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific GroupSortInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the GroupSortInfos in this GroupSortInfoCollection.
Sort | Sorts the GroupSortInfos in this GroupSortInfoCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection.Add Method

Adds a GroupSortInfo to end of the collection.

public int Add(
GroupSortInfo value
);

Parameters

value
The GroupSortInfo to add to the collection.

Return Value

The position into which the new GroupSortInfo was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

GroupSortInfoCollection.Append Method

Appends the GroupSortInfos of the given array to the end of this GroupSortInfoCollection.

Overload List

Appends the GroupSortInfos of the given array to the end of this GroupSortInfoCollection.

public GroupSortInfoCollection Append(GroupSortInfo[]);

Appends the GroupSortInfos of the given GroupSortInfoCollection to the end of this GroupSortInfoCollection.

public GroupSortInfoCollection Append(GroupSortInfoCollection);

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection.Append Method (GroupSortInfo[])

Appends the GroupSortInfos of the given array to the end of this GroupSortInfoCollection.

public GroupSortInfoCollection Append(
GroupSortInfo[] array
);

Parameters

array
The array whose GroupSortInfos are to be appended to this GroupSortInfoCollection.

Return Value

This GroupSortInfoCollection, modified to include the new GroupSortInfos.

Remarks

The GroupSortInfoCollection is modified to include the new members. The individual GroupSortInfo objects are shared, not copied.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace | GroupSortInfoCollection.Append Overload List


GroupSortInfoCollection.Append Method (GroupSortInfoCollection)

Appends the GroupSortInfos of the given GroupSortInfoCollection to the end of this GroupSortInfoCollection.

public GroupSortInfoCollection Append(
GroupSortInfoCollection collection
);

Parameters

collection
The GroupSortInfoCollection whose GroupSortInfos are to be appended to this GroupSortInfoCollection.

Return Value

This GroupSortInfoCollection, modified to include the new GroupSortInfos.

Remarks

The GroupSortInfoCollection is modified to include the new members. The individual GroupSortInfo objects are shared, not copied.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace | GroupSortInfoCollection.Append Overload List


GroupSortInfoCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.GroupSortInfo[].

Implements

IWrapper.Unwrap

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection.Contains Method

Determines whether or not the collection contains a specific GroupSortInfo.

public bool Contains(
GroupSortInfo value
);

Parameters

value
The GroupSortInfo to locate in the collection.

Return Value

true if the GroupSortInfo is found in the collection; otherwise, false.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection.CopyTo Method

Copies all of the GroupSortInfos in the GroupSortInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
GroupSortInfo[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the GroupSortInfos copied from the GroupSortInfoCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of GroupSortInfos in the source GroupSortInfoCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source GroupSortInfoCollection cannot be cast automatically to the type of the destination array.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection.IndexOf Method

Determines the index of a specific GroupSortInfo in the collection.

public int IndexOf(
GroupSortInfo value
);

Parameters

value
The GroupSortInfo to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection.Insert Method

Inserts a GroupSortInfo into the collection at the specified position.

public void Insert(
Int32 index,
GroupSortInfo value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The GroupSortInfo to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection.Remove Method

Removes the first occurrence of a specific GroupSortInfo from the collection.

public void Remove(
GroupSortInfo value
);

Parameters

value
The GroupSortInfo to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection.Reverse Method

Reverses the order of the GroupSortInfos in this GroupSortInfoCollection.

new public GroupSortInfoCollection Reverse();

Return Value

This GroupSortInfoCollection, modified such that the GroupSortInfos are reversed.

Remarks

The GroupSortInfoCollection is modified in place.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection.Sort Method

Sorts the GroupSortInfos in this GroupSortInfoCollection, using the given comparer.

new public GroupSortInfoCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two GroupSortInfos.

Return Value

This GroupSortInfoCollection, modified such that the GroupSortInfos are sorted.

Remarks

The GroupSortInfoCollection is modified in place.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection.Wrap Method

Creates a GroupSortInfoCollection to represent the given array of GroupSortInfo (from the com.starbase.starteam namespace).

public static GroupSortInfoCollection Wrap(
GroupSortInfo[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new GroupSortInfoCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a GroupSortInfo[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection Type Conversions

The type conversions of the GroupSortInfoCollection class are listed below. For a complete list of GroupSortInfoCollection class members, see the GroupSortInfoCollection Members topic.

Public Static Type Conversions

Implicit GroupSortInfoCollection to GroupSortInfo[] Conversion | Converts a GroupSortInfoCollection to an array of GroupSortInfos.
Implicit GroupSortInfoCollection to GroupSortInfo[] Conversion | Converts a GroupSortInfoCollection from the Borland.StarTeam namespace to a GroupSortInfo[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

GroupSortInfoCollection Class | GroupSortInfoCollection Members | Borland.StarTeam Namespace


GroupSortInfoCollection Implicit GroupSortInfoCollection to GroupSortInfo[] Conversion

Converts a GroupSortInfoCollection to an array of GroupSortInfos.

public static implicit operator GroupSortInfo[](
GroupSortInfoCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new GroupSortInfo wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one GroupSortInfo wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


GroupSortInfoCollection Implicit GroupSortInfoCollection to GroupSortInfo[] Conversion

Converts a GroupSortInfoCollection from the Borland.StarTeam namespace to a GroupSortInfo[] in the com.starbase.starteam namespace.

public static implicit operator GroupSortInfo[](
GroupSortInfoCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, GroupSortInfoCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

GroupSortInfoCollection Class | Borland.StarTeam Namespace


HistoryKeyword Class

For a list of all members of this type, see HistoryKeyword Members.

System.Object
SimpleKeyword
HistoryKeyword

public class HistoryKeyword : SimpleKeyword

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

HistoryKeyword Members | Borland.StarTeam Namespace


HistoryKeyword Members

HistoryKeyword overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.HistoryKeyword.

Public Static Type Conversions

Implicit HistoryKeyword to HistoryKeyword Conversion Implicitly convert HistoryKeyword to com.starbase.starteam.HistoryKeyword.

Public Instance Constructors

HistoryKeyword Overloaded. Initializes a new instance of the HistoryKeyword class.

Public Instance Properties

IsMultiLine (inherited from SimpleKeyword)
Name (inherited from SimpleKeyword)
StopExpanding (inherited from SimpleKeyword)
Value (inherited from SimpleKeyword)
XMLString (inherited from SimpleKeyword)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from SimpleKeyword) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches (inherited from SimpleKeyword) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HistoryKeyword Class | Borland.StarTeam Namespace


HistoryKeyword Constructor

Construct HistoryKeyword from com.starbase.starteam.HistoryKeyword.

Overload List

Constructs a $History$ keyword using the specified history entries.

public HistoryKeyword(HistoryLine);

Construct HistoryKeyword from com.starbase.starteam.HistoryKeyword.

public HistoryKeyword(HistoryKeyword);

See Also

HistoryKeyword Class | Borland.StarTeam Namespace


HistoryKeyword Constructor (HistoryKeyword)

Construct HistoryKeyword from com.starbase.starteam.HistoryKeyword.

public HistoryKeyword(
HistoryKeyword impl
);

Parameters

impl
The com.starbase.starteam.HistoryKeyword to be wrapped.

See Also

HistoryKeyword Class | Borland.StarTeam Namespace | HistoryKeyword Constructor Overload List


HistoryKeyword Constructor (HistoryLine)

Constructs a $History$ keyword using the specified history entries.

public HistoryKeyword(
HistoryLine historyLine
);

Parameters

historyLine

See Also

HistoryKeyword Class | Borland.StarTeam Namespace | HistoryKeyword Constructor Overload List


HistoryKeyword Methods

The methods of the HistoryKeyword class are listed below. For a complete list of HistoryKeyword class members, see the HistoryKeyword Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.HistoryKeyword.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from SimpleKeyword) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches (inherited from SimpleKeyword) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HistoryKeyword Class | Borland.StarTeam Namespace


HistoryKeyword.Wrap Method

Dynamically wraps com.starbase.starteam.HistoryKeyword.

public static HistoryKeyword Wrap(
HistoryKeyword impl
);

Parameters

impl
com.starbase.starteam.HistoryKeyword to be wrapped.

Return Value

HistoryKeyword

See Also

HistoryKeyword Class | Borland.StarTeam Namespace


HistoryKeyword Type Conversions

The type conversions of the HistoryKeyword class are listed below. For a complete list of HistoryKeyword class members, see the HistoryKeyword Members topic.

Public Static Type Conversions

Implicit HistoryKeyword to HistoryKeyword Conversion Implicitly convert HistoryKeyword to com.starbase.starteam.HistoryKeyword.

See Also

HistoryKeyword Class | HistoryKeyword Members | Borland.StarTeam Namespace


HistoryKeyword Implicit HistoryKeyword to HistoryKeyword Conversion

Implicitly convert HistoryKeyword to com.starbase.starteam.HistoryKeyword.

public static implicit operator HistoryKeyword(
HistoryKeyword arg
);

Parameters

arg
HistoryKeyword to convert.

Return Value

com.starbase.starteam.HistoryKeyword

See Also

HistoryKeyword Class | Borland.StarTeam Namespace


HistoryLine Class

A class containing information specific to a single version entry for expansion of the $History$ keyword.

For a list of all members of this type, see HistoryLine Members.

System.Object
LogLine
HistoryLine

public class HistoryLine : LogLine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

HistoryLine Members | Borland.StarTeam Namespace


HistoryLine Members

HistoryLine overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.HistoryLine.

Public Static Type Conversions

Implicit HistoryLine to HistoryLine Conversion Implicitly convert HistoryLine to com.starbase.starteam.HistoryLine.

Public Instance Constructors

HistoryLine Overloaded. Initializes a new instance of the HistoryLine class.

Public Instance Properties

XMLString (inherited from LogLine) [read] an XML representation of this log line entry

Public Instance Methods

Equals (inherited from LogLine) | Delegate Equals() to com.starbase.starteam.LogLine.
Format | Format and return a revision history record consisiting of the prefix, view name, dot notation, utc date, author and comment
GetHashCode (inherited from LogLine) | Delegate GetHashCode() to com.starbase.starteam.LogLine.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from LogLine) | Delegate ToString() to com.starbase.starteam.LogLine.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from LogLine) Implementation of IWrapper.Unwrap().

See Also

HistoryLine Class | Borland.StarTeam Namespace


HistoryLine Constructor

Construct HistoryLine from com.starbase.starteam.HistoryLine.

Overload List

Construct HistoryLine from com.starbase.starteam.HistoryLine.

public HistoryLine(HistoryLine);

Creates new information for a single $History keyword entry. Each revision of a file will have its own HistoryLine.

public HistoryLine(Int32,String,String,DateTime,String,String);

See Also

HistoryLine Class | Borland.StarTeam Namespace


HistoryLine Constructor (HistoryLine)

Construct HistoryLine from com.starbase.starteam.HistoryLine.

public HistoryLine(
HistoryLine impl
);

Parameters

impl
The com.starbase.starteam.HistoryLine to be wrapped.

See Also

HistoryLine Class | Borland.StarTeam Namespace | HistoryLine Constructor Overload List


HistoryLine Constructor (Int32, String, String, DateTime, String, String)

Creates new information for a single $History keyword entry. Each revision of a file will have its own HistoryLine.

public HistoryLine(
Int32 version,
String viewName,
String dotNotation,
DateTime date,
String author,
String comment
);

Parameters

version
the version number for the revision
viewName
the name of the view in which the revision was created
dotNotation
the dot notation for the revision (for example "1.2.3.0")
date
the time at which the revision was created, in UTC
author
the name of the author of the revision
comment
the check-in comment for the revision

See Also

HistoryLine Class | Borland.StarTeam Namespace | HistoryLine Constructor Overload List


HistoryLine Methods

The methods of the HistoryLine class are listed below. For a complete list of HistoryLine class members, see the HistoryLine Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.HistoryLine.

Public Instance Methods

Equals (inherited from LogLine) | Delegate Equals() to com.starbase.starteam.LogLine.
Format | Format and return a revision history record consisiting of the prefix, view name, dot notation, utc date, author and comment
GetHashCode (inherited from LogLine) | Delegate GetHashCode() to com.starbase.starteam.LogLine.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from LogLine) | Delegate ToString() to com.starbase.starteam.LogLine.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from LogLine) Implementation of IWrapper.Unwrap().

See Also

HistoryLine Class | Borland.StarTeam Namespace


HistoryLine.Format Method

Format and return a revision history record consisiting of the prefix, view name, dot notation, utc date, author and comment

public virtual string Format(
String prefix,
String eol
);

Parameters

prefix
String the prefix to pre-pend to each history line, for instance '//' to signify a comment
eol
String the platform specific eol character; e.g. 'CR', 'LF' or 'CRLF'

Return Value

String a formatted line that can be written against the local file's history keyword

See Also

HistoryLine Class | Borland.StarTeam Namespace


HistoryLine.Wrap Method

Dynamically wraps com.starbase.starteam.HistoryLine.

public static HistoryLine Wrap(
HistoryLine impl
);

Parameters

impl
com.starbase.starteam.HistoryLine to be wrapped.

Return Value

HistoryLine

See Also

HistoryLine Class | Borland.StarTeam Namespace


HistoryLine Type Conversions

The type conversions of the HistoryLine class are listed below. For a complete list of HistoryLine class members, see the HistoryLine Members topic.

Public Static Type Conversions

Implicit HistoryLine to HistoryLine Conversion Implicitly convert HistoryLine to com.starbase.starteam.HistoryLine.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from LogLine) Implementation of IWrapper.Unwrap().

See Also

HistoryLine Class | HistoryLine Members | Borland.StarTeam Namespace


HistoryLine Implicit HistoryLine to HistoryLine Conversion

Implicitly convert HistoryLine to com.starbase.starteam.HistoryLine.

public static implicit operator HistoryLine(
HistoryLine arg
);

Parameters

arg
HistoryLine to convert.

Return Value

com.starbase.starteam.HistoryLine

See Also

HistoryLine Class | Borland.StarTeam Namespace


HiveInfo Class

Describes a vault hive on the server.

For a list of all members of this type, see HiveInfo Members.

System.Object
HiveInfo

public class HiveInfo : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

HiveInfo Members | Borland.StarTeam Namespace


HiveInfo Members

HiveInfo overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.HiveInfo.

Public Static Type Conversions

Implicit HiveInfo to HiveInfo Conversion Implicitly convert HiveInfo to com.starbase.starteam.HiveInfo.

Public Instance Constructors

HiveInfo Overloaded. Initializes a new instance of the HiveInfo class.

Public Instance Properties

AllowNewArchives | [read/write] Indication of whether new archive files can be added to the hive. The default is TRUE.
ArchiveDirectory | [read/write] The path to the hive's Archive directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Archives.
CacheCleanupInterval | [read/write] The number of seconds between cache cleanup operations. The default value is 600. The range is 60 (1 minute) to 3153600 (1 year).
CacheDirectory | [read/write] The path to the hive's Cache directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Cache.
ID | [read] The number assigned by StarTeam to identify the hive
MaxCacheSize | [read/write] The maximum number of megabytes of hard disk space that the cache can use. -1 is the default and represents 20 percent of the available disk space at the time the option is set. The range is -1 to 9,223,372,036,854,775,807.
Name | [read/write] The name of the hive. Note that on UNIX-based systems the name should not include any spaces.
RootCacheAgentArchiveDirectory | [read/write] The path to the hive's Root Cache Agent Archive directory. This is the same folder path as for ArchiveDirectory but from the perspective of the computer on which the Root Cache Agent is installed. If the Root Cache Agent is installed on the same computer as the StarTeam Server, this can be empty or the same setting as the ArchiveDirectory.
RootDirectory | [read/write] The shortcut to creating path to Cache and Archive directories. When set, CacheDirectory and ArchiveDirectory do not need to be set. The default is [repository_path]\DefaultHive.
StorageLimitThreshold | [read/write] The percentage of total disk space allowed for hive. When this percentage of total disk space has been used, no more archives can be added to the hive. -1 is the default and represents 95 percent of total disk space. The range is -1 to 100.
Type | [read] The number assigned by StarTeam to identify the the type of archive files stored in the hive: 0 for unknown; 1 for PVCS, 2 for VSS, or 3 for Native II.

Public Instance Methods

Copy | return a copy of this HiveInfo instance
Equals | Delegate Equals() to com.starbase.starteam.HiveInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.HiveInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Return true if this HiveInfo is equal to the argument.
ToString | Delegate ToString() to com.starbase.starteam.HiveInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo Constructor

Construct HiveInfo from com.starbase.starteam.HiveInfo.

Overload List

construct a new HiveInfo from the source

public HiveInfo(HiveInfo);

Construct HiveInfo from com.starbase.starteam.HiveInfo.

public HiveInfo(HiveInfo);

construct a new HiveInfo instance

public HiveInfo(Int32);

Creates a new HiveInfo object.

public HiveInfo(Int32,String,String,String,String,String,Boolean,Int32,Int64,Int32);

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo Constructor (HiveInfo)

Construct HiveInfo from com.starbase.starteam.HiveInfo.

public HiveInfo(
HiveInfo impl
);

Parameters

impl
The com.starbase.starteam.HiveInfo to be wrapped.

See Also

HiveInfo Class | Borland.StarTeam Namespace | HiveInfo Constructor Overload List


HiveInfo Constructor (Int32, String, String, String, String, String, Boolean, Int32, Int64, Int32)

Creates a new HiveInfo object.

public HiveInfo(
Int32 hiveType,
String name,
String rootDirectory,
String cacheDirectory,
String archiveDirectory,
String rootCacheAgentArchiveDirectory,
Boolean bAllowNewArchives,
Int32 storageLimitThreshold,
Int64 maxCacheSize,
Int32 cacheCleanupInterval
);

Parameters

hiveType
One of the HiveType values described above.
name
Name of the hive.
rootDirectory
Root directory of the hive.
cacheDirectory
Cache directory of the hive.
archiveDirectory
Archive directory of the hive.
rootCacheAgentArchiveDirectory
Directory for the root cache agent of the hive.
bAllowNewArchives
true = allow new archives, false = do not allow.
storageLimitThreshold
Hive's storage limit threshold.
maxCacheSize
64-bit value specifying the hive's maximum cache size.
cacheCleanupInterval

See Also

HiveInfo Class | Borland.StarTeam Namespace | HiveInfo Constructor Overload List


HiveInfo Constructor (Int32)

construct a new HiveInfo instance

public HiveInfo(
Int32 ID
);

Parameters

ID

See Also

HiveInfo Class | Borland.StarTeam Namespace | HiveInfo Constructor Overload List


HiveInfo Constructor (HiveInfo)

construct a new HiveInfo from the source

public HiveInfo(
HiveInfo source
);

Parameters

source
HiveInfo the HiveInfo to copy

See Also

HiveInfo Class | Borland.StarTeam Namespace | HiveInfo Constructor Overload List


HiveInfo Properties

The properties of the HiveInfo class are listed below. For a complete list of HiveInfo class members, see the HiveInfo Members topic.

Public Instance Properties

AllowNewArchives | [read/write] Indication of whether new archive files can be added to the hive. The default is TRUE.
ArchiveDirectory | [read/write] The path to the hive's Archive directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Archives.
CacheCleanupInterval | [read/write] The number of seconds between cache cleanup operations. The default value is 600. The range is 60 (1 minute) to 3153600 (1 year).
CacheDirectory | [read/write] The path to the hive's Cache directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Cache.
ID | [read] The number assigned by StarTeam to identify the hive
MaxCacheSize | [read/write] The maximum number of megabytes of hard disk space that the cache can use. -1 is the default and represents 20 percent of the available disk space at the time the option is set. The range is -1 to 9,223,372,036,854,775,807.
Name | [read/write] The name of the hive. Note that on UNIX-based systems the name should not include any spaces.
RootCacheAgentArchiveDirectory | [read/write] The path to the hive's Root Cache Agent Archive directory. This is the same folder path as for ArchiveDirectory but from the perspective of the computer on which the Root Cache Agent is installed. If the Root Cache Agent is installed on the same computer as the StarTeam Server, this can be empty or the same setting as the ArchiveDirectory.
RootDirectory | [read/write] The shortcut to creating path to Cache and Archive directories. When set, CacheDirectory and ArchiveDirectory do not need to be set. The default is [repository_path]\DefaultHive.
StorageLimitThreshold | [read/write] The percentage of total disk space allowed for hive. When this percentage of total disk space has been used, no more archives can be added to the hive. -1 is the default and represents 95 percent of total disk space. The range is -1 to 100.
Type | [read] The number assigned by StarTeam to identify the the type of archive files stored in the hive: 0 for unknown; 1 for PVCS, 2 for VSS, or 3 for Native II.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveInfo Class | Borland.StarTeam Namespace


AllowNewArchives Property

Borland StarTeam SDK for .NET

HiveInfo.AllowNewArchives Property

[read/write] Indication of whether new archive files can be added to the hive. The default is TRUE.

public virtual Boolean AllowNewArchives {get; set;}

Property Value

Indication of whether new archive files can be added to the hive. The default is TRUE.

See Also

HiveInfo Class | Borland.StarTeam Namespace


ArchiveDirectory Property

Borland StarTeam SDK for .NET

HiveInfo.ArchiveDirectory Property

[read/write] The path to the hive's Archive directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Archives.

public virtual String ArchiveDirectory {get; set;}

Property Value

The path to the hive's Archive directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Archives.

See Also

HiveInfo Class | Borland.StarTeam Namespace


CacheCleanupInterval Property

Borland StarTeam SDK for .NET

HiveInfo.CacheCleanupInterval Property

[read/write] The number of seconds between cache cleanup operations. The default value is 600. The range is 60 (1 minute) to 3153600 (1 year).

public virtual Int32 CacheCleanupInterval {get; set;}

Property Value

The number of seconds between cache cleanup operations. The default value is 600. The range is 60 (1 minute) to 3153600 (1 year).

See Also

HiveInfo Class | Borland.StarTeam Namespace


CacheDirectory Property

Borland StarTeam SDK for .NET

HiveInfo.CacheDirectory Property

[read/write] The path to the hive's Cache directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Cache.

public virtual String CacheDirectory {get; set;}

Property Value

The path to the hive's Cache directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Cache.

See Also

HiveInfo Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

HiveInfo.ID Property

[read] The number assigned by StarTeam to identify the hive

public virtual Int32 ID {get;}

Property Value

The number assigned by StarTeam to identify the hive

See Also

HiveInfo Class | Borland.StarTeam Namespace


MaxCacheSize Property

Borland StarTeam SDK for .NET

HiveInfo.MaxCacheSize Property

[read/write] The maximum number of megabytes of hard disk space that the cache can use. -1 is the default and represents 20 percent of the available disk space at the time the option is set. The range is -1 to 9,223,372,036,854,775,807.

public virtual Int64 MaxCacheSize {get; set;}

Property Value

The maximum number of megabytes of hard disk space that the cache can use. -1 is the default and represents 20 percent of the available disk space at the time the option is set. The range is -1 to 9,223,372,036,854,775,807.

See Also

HiveInfo Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

HiveInfo.Name Property

[read/write] The name of the hive. Note that on UNIX-based systems the name should not include any spaces.

public virtual String Name {get; set;}

Property Value

The name of the hive. Note that on UNIX-based systems the name should not include any spaces.

See Also

HiveInfo Class | Borland.StarTeam Namespace


RootCacheAgentArchiveDirectory Property

Borland StarTeam SDK for .NET

HiveInfo.RootCacheAgentArchiveDirectory Property

[read/write] The path to the hive's Root Cache Agent Archive directory. This is the same folder path as for ArchiveDirectory but from the perspective of the computer on which the Root Cache Agent is installed. If the Root Cache Agent is installed on the same computer as the StarTeam Server, this can be empty or the same setting as the ArchiveDirectory.

public virtual String RootCacheAgentArchiveDirectory {get; set;}

Property Value

The path to the hive's Root Cache Agent Archive directory. This is the same folder path as for ArchiveDirectory but from the perspective of the computer on which the Root Cache Agent is installed. If the Root Cache Agent is installed on the same computer as the StarTeam Server, this can be empty or the same setting as the ArchiveDirectory.

See Also

HiveInfo Class | Borland.StarTeam Namespace


RootDirectory Property

Borland StarTeam SDK for .NET

HiveInfo.RootDirectory Property

[read/write] The shortcut to creating path to Cache and Archive directories. When set, CacheDirectory and ArchiveDirectory do not need to be set. The default is [repository_path]\DefaultHive.

public virtual String RootDirectory {get; set;}

Property Value

The shortcut to creating path to Cache and Archive directories. When set, CacheDirectory and ArchiveDirectory do not need to be set. The default is [repository_path]\DefaultHive.

See Also

HiveInfo Class | Borland.StarTeam Namespace


StorageLimitThreshold Property

Borland StarTeam SDK for .NET

HiveInfo.StorageLimitThreshold Property

[read/write] The percentage of total disk space allowed for hive. When this percentage of total disk space has been used, no more archives can be added to the hive. -1 is the default and represents 95 percent of total disk space. The range is -1 to 100.

public virtual Int32 StorageLimitThreshold {get; set;}

Property Value

The percentage of total disk space allowed for hive. When this percentage of total disk space has been used, no more archives can be added to the hive. -1 is the default and represents 95 percent of total disk space. The range is -1 to 100.

See Also

HiveInfo Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

HiveInfo.Type Property

[read] The number assigned by StarTeam to identify the the type of archive files stored in the hive: 0 for unknown; 1 for PVCS, 2 for VSS, or 3 for Native II.

public virtual Int32 Type {get;}

Property Value

The number assigned by StarTeam to identify the the type of archive files stored in the hive: 0 for unknown; 1 for PVCS, 2 for VSS, or 3 for Native II.

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo Methods

The methods of the HiveInfo class are listed below. For a complete list of HiveInfo class members, see the HiveInfo Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.HiveInfo.

Public Instance Methods

Copy | return a copy of this HiveInfo instance
Equals | Delegate Equals() to com.starbase.starteam.HiveInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.HiveInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Return true if this HiveInfo is equal to the argument.
ToString | Delegate ToString() to com.starbase.starteam.HiveInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.HiveInfo

Implements

IWrapper.Unwrap

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo.Copy Method

return a copy of this HiveInfo instance

public virtual HiveInfo Copy();

Return Value

HiveInfo a copy of this HiveInfo instance

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo.Equals Method

Delegate Equals() to com.starbase.starteam.HiveInfo.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.HiveInfo.Equals(obj).

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.HiveInfo.

public override int GetHashCode();

Return Value

com.starbase.starteam.HiveInfo.GetHashCode().

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo.IsEqualTo Method

Return true if this HiveInfo is equal to the argument.

public virtual bool IsEqualTo(
HiveInfo other
);

Parameters

other
the HiveInfo to compare with this one.

Return Value

true if the two are equal, otherwise false.

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo.ToString Method

Delegate ToString() to com.starbase.starteam.HiveInfo.

public override string ToString();

Return Value

com.starbase.starteam.HiveInfo.ToString()

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo.Wrap Method

Dynamically wraps com.starbase.starteam.HiveInfo.

public static HiveInfo Wrap(
HiveInfo impl
);

Parameters

impl
com.starbase.starteam.HiveInfo to be wrapped.

Return Value

HiveInfo

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo Type Conversions

The type conversions of the HiveInfo class are listed below. For a complete list of HiveInfo class members, see the HiveInfo Members topic.

Public Static Type Conversions

Implicit HiveInfo to HiveInfo Conversion Implicitly convert HiveInfo to com.starbase.starteam.HiveInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveInfo Class | HiveInfo Members | Borland.StarTeam Namespace


HiveInfo Implicit HiveInfo to HiveInfo Conversion

Implicitly convert HiveInfo to com.starbase.starteam.HiveInfo.

public static implicit operator HiveInfo(
HiveInfo arg
);

Parameters

arg
HiveInfo to convert.

Return Value

com.starbase.starteam.HiveInfo

See Also

HiveInfo Class | Borland.StarTeam Namespace


HiveInfo.HiveType Class

For a list of all members of this type, see HiveInfo.HiveType Members.

System.Object
HiveInfo.HiveType

public class HiveInfo.HiveType : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

HiveInfo.HiveType Members | Borland.StarTeam Namespace


HiveInfo.HiveType Members

HiveInfo.HiveType overview

Public Static Properties

eNativeII
ePVCS
eUNKNOWN
eVSS

Public Static Type Conversions

Implicit HiveInfo.HiveType to HiveInfo.HiveType Conversion

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.HiveInfo.HiveType.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.HiveInfo.HiveType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.HiveInfo.HiveType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


HiveInfo.HiveType Properties

The properties of the HiveInfo.HiveType class are listed below. For a complete list of HiveInfo.HiveType class members, see the HiveInfo.HiveType Members topic.

Public Static Properties

eNativeII
ePVCS
eUNKNOWN
eVSS

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


eNativeII Property

Borland StarTeam SDK for .NET

HiveInfo.HiveType.eNativeII Property

public static Int32 eNativeII {get;}

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


ePVCS Property

Borland StarTeam SDK for .NET

HiveInfo.HiveType.ePVCS Property

public static Int32 ePVCS {get;}

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


eUNKNOWN Property

Borland StarTeam SDK for .NET

HiveInfo.HiveType.eUNKNOWN Property

public static Int32 eUNKNOWN {get;}

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


eVSS Property

Borland StarTeam SDK for .NET

HiveInfo.HiveType.eVSS Property

public static Int32 eVSS {get;}

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


HiveInfo.HiveType Methods

The methods of the HiveInfo.HiveType class are listed below. For a complete list of HiveInfo.HiveType class members, see the HiveInfo.HiveType Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.HiveInfo.HiveType.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.HiveInfo.HiveType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.HiveInfo.HiveType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


HiveInfo.HiveType.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.HiveInfo.HiveType

Implements

IWrapper.Unwrap

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


HiveInfo.HiveType.Equals Method

Delegate Equals() to com.starbase.starteam.HiveInfo.HiveType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.HiveInfo.HiveType.Equals(obj).

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


HiveInfo.HiveType.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.HiveInfo.HiveType.

public override int GetHashCode();

Return Value

com.starbase.starteam.HiveInfo.HiveType.GetHashCode().

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


HiveInfo.HiveType.ToString Method

Delegate ToString() to com.starbase.starteam.HiveInfo.HiveType.

public override string ToString();

Return Value

com.starbase.starteam.HiveInfo.HiveType.ToString()

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


HiveInfo.HiveType Type Conversions

The type conversions of the HiveInfo.HiveType class are listed below. For a complete list of HiveInfo.HiveType class members, see the HiveInfo.HiveType Members topic.

Public Static Type Conversions

Implicit HiveInfo.HiveType to HiveInfo.HiveType Conversion

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveInfo.HiveType Class | HiveInfo.HiveType Members | Borland.StarTeam Namespace


HiveInfo.HiveType Implicit HiveInfo.HiveType to HiveInfo.HiveType Conversion

public static implicit operator HiveType(
HiveInfo.HiveType arg
);

See Also

HiveInfo.HiveType Class | Borland.StarTeam Namespace


HiveInfoCollection Class

A strongly-typed collection of HiveInfos.

For a list of all members of this type, see HiveInfoCollection Members.

System.Object
ArrayAdapter
HiveInfoCollection

public class HiveInfoCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

HiveInfoCollection Members | Borland.StarTeam Namespace


HiveInfoCollection Members

HiveInfoCollection overview

Public Static Methods

Wrap Creates a HiveInfoCollection to represent the given array of HiveInfo (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit HiveInfoCollection to HiveInfo[] Conversion | Converts a HiveInfoCollection to an array of HiveInfos.
Implicit HiveInfoCollection to HiveInfo[] Conversion | Converts a HiveInfoCollection from the Borland.StarTeam namespace to a HiveInfo[] in the com.starbase.starteam namespace.

Public Instance Constructors

HiveInfoCollection Overloaded. Initializes a new instance of the HiveInfoCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the HiveInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a HiveInfo to end of the collection.
Append | Overloaded. Appends the HiveInfos of the given HiveInfoCollection to the end of this HiveInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific HiveInfo.
CopyTo | Copies all of the HiveInfos in the HiveInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the HiveInfo with the given ID.
FindByName | Finds the HiveInfo with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific HiveInfo in the collection.
Insert | Inserts a HiveInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific HiveInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the HiveInfos in this HiveInfoCollection.
Sort | Sorts the HiveInfos in this HiveInfoCollection, using the given comparer.
SortByID | Sorts the HiveInfos in this HiveInfoCollection by ID.
SortByName | Sorts the HiveInfos in this HiveInfoCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection Constructor

Initializes an instance of the HiveInfoCollection class.

Overload List

Initializes an instance of the HiveInfoCollection class.

public HiveInfoCollection();

Initializes an instance of the a HiveInfoCollection class, copying the given array.

public HiveInfoCollection(HiveInfo[]);

Initializes an instance of the a HiveInfoCollection class, copying the given collection.

public HiveInfoCollection(HiveInfoCollection);

Initializes an instance of the a HiveInfoCollection class, wrapping the given array of HiveInfo (from the com.starbase.starteam namespace).

public HiveInfoCollection(HiveInfo[]);

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection Constructor ()

Initializes an instance of the HiveInfoCollection class.

public HiveInfoCollection();

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace | HiveInfoCollection Constructor Overload List


HiveInfoCollection Constructor (HiveInfo[])

Initializes an instance of the a HiveInfoCollection class, wrapping the given array of HiveInfo (from the com.starbase.starteam namespace).

public HiveInfoCollection(
HiveInfo[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace | HiveInfoCollection Constructor Overload List | Wrap


HiveInfoCollection Constructor (HiveInfoCollection)

Initializes an instance of the a HiveInfoCollection class, copying the given collection.

public HiveInfoCollection(
HiveInfoCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member HiveInfo objects of the original collection are shared, not copied.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace | HiveInfoCollection Constructor Overload List


HiveInfoCollection Constructor (HiveInfo[])

Initializes an instance of the a HiveInfoCollection class, copying the given array.

public HiveInfoCollection(
HiveInfo[] array
);

Parameters

array
The array to be copied.

Remarks

The member HiveInfo objects of the original array are shared, not copied.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace | HiveInfoCollection Constructor Overload List


HiveInfoCollection Properties

The properties of the HiveInfoCollection class are listed below. For a complete list of HiveInfoCollection class members, see the HiveInfoCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the HiveInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

HiveInfoCollection.Item Property

Gets or sets the HiveInfo at the specified index.

Overload List

Gets or sets the HiveInfo at the specified index.

public HiveInfo this[Int32] {get; set;}

Gets the HiveInfo with the given name.

public HiveInfo this[String] {get;}

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

HiveInfoCollection.Item Property (Int32)

Gets or sets the HiveInfo at the specified index.

public HiveInfo this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the HiveInfo to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace | HiveInfoCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

HiveInfoCollection.Item Property (String)

Gets the HiveInfo with the given name.

public HiveInfo this[
String name
] {get;}

Parameters

name
The name of the HiveInfo to get.

Property Value

The HiveInfo with the given name, or null if there is no HiveInfo with that name in this HiveInfoCollection. Comparison is case sensitive.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace | HiveInfoCollection.Item Overload List | FindByName


HiveInfoCollection Methods

The methods of the HiveInfoCollection class are listed below. For a complete list of HiveInfoCollection class members, see the HiveInfoCollection Members topic.

Public Static Methods

Wrap Creates a HiveInfoCollection to represent the given array of HiveInfo (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a HiveInfo to end of the collection.
Append | Overloaded. Appends the HiveInfos of the given HiveInfoCollection to the end of this HiveInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific HiveInfo.
CopyTo | Copies all of the HiveInfos in the HiveInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the HiveInfo with the given ID.
FindByName | Finds the HiveInfo with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific HiveInfo in the collection.
Insert | Inserts a HiveInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific HiveInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the HiveInfos in this HiveInfoCollection.
Sort | Sorts the HiveInfos in this HiveInfoCollection, using the given comparer.
SortByID | Sorts the HiveInfos in this HiveInfoCollection by ID.
SortByName | Sorts the HiveInfos in this HiveInfoCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.Add Method

Adds a HiveInfo to end of the collection.

public int Add(
HiveInfo value
);

Parameters

value
The HiveInfo to add to the collection.

Return Value

The position into which the new HiveInfo was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

HiveInfoCollection.Append Method

Appends the HiveInfos of the given array to the end of this HiveInfoCollection.

Overload List

Appends the HiveInfos of the given array to the end of this HiveInfoCollection.

public HiveInfoCollection Append(HiveInfo[]);

Appends the HiveInfos of the given HiveInfoCollection to the end of this HiveInfoCollection.

public HiveInfoCollection Append(HiveInfoCollection);

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.Append Method (HiveInfo[])

Appends the HiveInfos of the given array to the end of this HiveInfoCollection.

public HiveInfoCollection Append(
HiveInfo[] array
);

Parameters

array
The array whose HiveInfos are to be appended to this HiveInfoCollection.

Return Value

This HiveInfoCollection, modified to include the new HiveInfos.

Remarks

The HiveInfoCollection is modified to include the new members. The individual HiveInfo objects are shared, not copied.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace | HiveInfoCollection.Append Overload List


HiveInfoCollection.Append Method (HiveInfoCollection)

Appends the HiveInfos of the given HiveInfoCollection to the end of this HiveInfoCollection.

public HiveInfoCollection Append(
HiveInfoCollection collection
);

Parameters

collection
The HiveInfoCollection whose HiveInfos are to be appended to this HiveInfoCollection.

Return Value

This HiveInfoCollection, modified to include the new HiveInfos.

Remarks

The HiveInfoCollection is modified to include the new members. The individual HiveInfo objects are shared, not copied.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace | HiveInfoCollection.Append Overload List


HiveInfoCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.HiveInfo[].

Implements

IWrapper.Unwrap

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.Contains Method

Determines whether or not the collection contains a specific HiveInfo.

public bool Contains(
HiveInfo value
);

Parameters

value
The HiveInfo to locate in the collection.

Return Value

true if the HiveInfo is found in the collection; otherwise, false.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.CopyTo Method

Copies all of the HiveInfos in the HiveInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
HiveInfo[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the HiveInfos copied from the HiveInfoCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of HiveInfos in the source HiveInfoCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source HiveInfoCollection cannot be cast automatically to the type of the destination array.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.FindByID Method

Finds the HiveInfo with the given ID.

public HiveInfo FindByID(
Int32 id
);

Parameters

id
The ID of the HiveInfo to be found.

Return Value

The HiveInfo with the given ID, or null if there is no HiveInfo with that ID in this HiveInfoCollection.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.FindByName Method

Finds the HiveInfo with the given name.

public HiveInfo FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the HiveInfo to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The HiveInfo with the given name, or null if there is no HiveInfo with that name in this HiveInfoCollection.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.IndexOf Method

Determines the index of a specific HiveInfo in the collection.

public int IndexOf(
HiveInfo value
);

Parameters

value
The HiveInfo to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.Insert Method

Inserts a HiveInfo into the collection at the specified position.

public void Insert(
Int32 index,
HiveInfo value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The HiveInfo to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.Remove Method

Removes the first occurrence of a specific HiveInfo from the collection.

public void Remove(
HiveInfo value
);

Parameters

value
The HiveInfo to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.Reverse Method

Reverses the order of the HiveInfos in this HiveInfoCollection.

new public HiveInfoCollection Reverse();

Return Value

This HiveInfoCollection, modified such that the HiveInfos are reversed.

Remarks

The HiveInfoCollection is modified in place.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.Sort Method

Sorts the HiveInfos in this HiveInfoCollection, using the given comparer.

new public HiveInfoCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two HiveInfos.

Return Value

This HiveInfoCollection, modified such that the HiveInfos are sorted.

Remarks

The HiveInfoCollection is modified in place.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.SortByID Method

Sorts the HiveInfos in this HiveInfoCollection by ID.

public HiveInfoCollection SortByID();

Return Value

This HiveInfoCollection, modified such that the HiveInfos are sorted by ID.

Remarks

The HiveInfoCollection is modified in place.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.SortByName Method

Sorts the HiveInfos in this HiveInfoCollection by name.

public HiveInfoCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This HiveInfoCollection, modified such that the HiveInfos are sorted by name.

Remarks

The HiveInfoCollection is modified in place.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection.Wrap Method

Creates a HiveInfoCollection to represent the given array of HiveInfo (from the com.starbase.starteam namespace).

public static HiveInfoCollection Wrap(
HiveInfo[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new HiveInfoCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a HiveInfo[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection Type Conversions

The type conversions of the HiveInfoCollection class are listed below. For a complete list of HiveInfoCollection class members, see the HiveInfoCollection Members topic.

Public Static Type Conversions

Implicit HiveInfoCollection to HiveInfo[] Conversion | Converts a HiveInfoCollection to an array of HiveInfos.
Implicit HiveInfoCollection to HiveInfo[] Conversion | Converts a HiveInfoCollection from the Borland.StarTeam namespace to a HiveInfo[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

HiveInfoCollection Class | HiveInfoCollection Members | Borland.StarTeam Namespace


HiveInfoCollection Implicit HiveInfoCollection to HiveInfo[] Conversion

Converts a HiveInfoCollection to an array of HiveInfos.

public static implicit operator HiveInfo[](
HiveInfoCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new HiveInfo wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one HiveInfo wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveInfoCollection Implicit HiveInfoCollection to HiveInfo[] Conversion

Converts a HiveInfoCollection from the Borland.StarTeam namespace to a HiveInfo[] in the com.starbase.starteam namespace.

public static implicit operator HiveInfo[](
HiveInfoCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, HiveInfoCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

HiveInfoCollection Class | Borland.StarTeam Namespace


HiveManager Class

Manages vault hives on the server.

For a list of all members of this type, see HiveManager Members.

System.Object
HiveManager

public class HiveManager : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

HiveManager Members | Borland.StarTeam Namespace


HiveManager Members

HiveManager overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.HiveManager.

Public Static Type Conversions

Implicit HiveManager to HiveManager Conversion Implicitly convert HiveManager to com.starbase.starteam.HiveManager.

Public Instance Constructors

HiveManager Overloaded. Initializes a new instance of the HiveManager class.

Public Instance Properties

HiveInfo [read/write] the current set of HiveInfos from the server, or null if new vault format is not supported on this server.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.HiveManager.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.HiveManager.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.HiveManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveManager Class | Borland.StarTeam Namespace


HiveManager Constructor

Construct HiveManager from com.starbase.starteam.HiveManager.

Overload List

Constructor.

public HiveManager(Server);

Construct HiveManager from com.starbase.starteam.HiveManager.

public HiveManager(HiveManager);

See Also

HiveManager Class | Borland.StarTeam Namespace


HiveManager Constructor (HiveManager)

Construct HiveManager from com.starbase.starteam.HiveManager.

public HiveManager(
HiveManager impl
);

Parameters

impl
The com.starbase.starteam.HiveManager to be wrapped.

See Also

HiveManager Class | Borland.StarTeam Namespace | HiveManager Constructor Overload List


HiveManager Constructor (Server)

Constructor.

public HiveManager(
Server server
);

Parameters

server

See Also

HiveManager Class | Borland.StarTeam Namespace | HiveManager Constructor Overload List


HiveManager Properties

The properties of the HiveManager class are listed below. For a complete list of HiveManager class members, see the HiveManager Members topic.

Public Instance Properties

HiveInfo [read/write] the current set of HiveInfos from the server, or null if new vault format is not supported on this server.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveManager Class | Borland.StarTeam Namespace


HiveInfo Property

Borland StarTeam SDK for .NET

HiveManager.HiveInfo Property

[read/write] the current set of HiveInfos from the server, or null if new vault format is not supported on this server.

public virtual HiveInfoCollection HiveInfo {get; set;}

Property Value

the current set of HiveInfos from the server, or null if new vault format is not supported on this server.

See Also

HiveManager Class | Borland.StarTeam Namespace


HiveManager Methods

The methods of the HiveManager class are listed below. For a complete list of HiveManager class members, see the HiveManager Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.HiveManager.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.HiveManager.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.HiveManager.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.HiveManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveManager Class | Borland.StarTeam Namespace


HiveManager.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.HiveManager

Implements

IWrapper.Unwrap

See Also

HiveManager Class | Borland.StarTeam Namespace


HiveManager.Equals Method

Delegate Equals() to com.starbase.starteam.HiveManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.HiveManager.Equals(obj).

See Also

HiveManager Class | Borland.StarTeam Namespace


HiveManager.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.HiveManager.

public override int GetHashCode();

Return Value

com.starbase.starteam.HiveManager.GetHashCode().

See Also

HiveManager Class | Borland.StarTeam Namespace


HiveManager.ToString Method

Delegate ToString() to com.starbase.starteam.HiveManager.

public override string ToString();

Return Value

com.starbase.starteam.HiveManager.ToString()

See Also

HiveManager Class | Borland.StarTeam Namespace


HiveManager.Wrap Method

Dynamically wraps com.starbase.starteam.HiveManager.

public static HiveManager Wrap(
HiveManager impl
);

Parameters

impl
com.starbase.starteam.HiveManager to be wrapped.

Return Value

HiveManager

See Also

HiveManager Class | Borland.StarTeam Namespace


HiveManager Type Conversions

The type conversions of the HiveManager class are listed below. For a complete list of HiveManager class members, see the HiveManager Members topic.

Public Static Type Conversions

Implicit HiveManager to HiveManager Conversion Implicitly convert HiveManager to com.starbase.starteam.HiveManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

HiveManager Class | HiveManager Members | Borland.StarTeam Namespace


HiveManager Implicit HiveManager to HiveManager Conversion

Implicitly convert HiveManager to com.starbase.starteam.HiveManager.

public static implicit operator HiveManager(
HiveManager arg
);

Parameters

arg
HiveManager to convert.

Return Value

com.starbase.starteam.HiveManager

See Also

HiveManager Class | Borland.StarTeam Namespace


IOExceptionCollection Class

A strongly-typed collection of IOExceptions.

For a list of all members of this type, see IOExceptionCollection Members.

System.Object
ArrayAdapter
IOExceptionCollection

public class IOExceptionCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

IOExceptionCollection Members | Borland.StarTeam Namespace


IOExceptionCollection Members

IOExceptionCollection overview

Public Static Methods

Wrap Creates an IOExceptionCollection to represent the given array of IOException (from the java.io namespace).

Public Static Type Conversions

Implicit IOExceptionCollection to IOException[] Conversion | Converts an IOExceptionCollection from the Borland.StarTeam namespace to an IOException[] in the java.io namespace.
Implicit IOExceptionCollection to IOException[] Conversion | Converts an IOExceptionCollection to an array of IOExceptions.

Public Instance Constructors

IOExceptionCollection Overloaded. Initializes a new instance of the IOExceptionCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the IOException at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an IOException to end of the collection.
Append | Overloaded. Appends the IOExceptions of the given IOExceptionCollection to the end of this IOExceptionCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific IOException.
CopyTo | Copies all of the IOExceptions in the IOExceptionCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific IOException in the collection.
Insert | Inserts an IOException into the collection at the specified position.
Remove | Removes the first occurrence of a specific IOException from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the IOExceptions in this IOExceptionCollection.
Sort | Sorts the IOExceptions in this IOExceptionCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the java.io namespace.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection Constructor

Initializes an instance of the IOExceptionCollection class.

Overload List

Initializes an instance of the IOExceptionCollection class.

public IOExceptionCollection();

Initializes an instance of the an IOExceptionCollection class, copying the given collection.

public IOExceptionCollection(IOExceptionCollection);

Initializes an instance of the an IOExceptionCollection class, wrapping the given array of IOException (from the java.io namespace).

public IOExceptionCollection(IOException[]);

Initializes an instance of the an IOExceptionCollection class, copying the given array.

public IOExceptionCollection(IOException[]);

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection Constructor ()

Initializes an instance of the IOExceptionCollection class.

public IOExceptionCollection();

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace | IOExceptionCollection Constructor Overload List


IOExceptionCollection Constructor (IOException[])

Initializes an instance of the an IOExceptionCollection class, wrapping the given array of IOException (from the java.io namespace).

public IOExceptionCollection(
IOException[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the java.io namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace | IOExceptionCollection Constructor Overload List | Wrap


IOExceptionCollection Constructor (IOExceptionCollection)

Initializes an instance of the an IOExceptionCollection class, copying the given collection.

public IOExceptionCollection(
IOExceptionCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member IOException objects of the original collection are shared, not copied.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace | IOExceptionCollection Constructor Overload List


IOExceptionCollection Constructor (IOException[])

Initializes an instance of the an IOExceptionCollection class, copying the given array.

public IOExceptionCollection(
IOException[] array
);

Parameters

array
The array to be copied.

Remarks

The member IOException objects of the original array are shared, not copied.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace | IOExceptionCollection Constructor Overload List


IOExceptionCollection Properties

The properties of the IOExceptionCollection class are listed below. For a complete list of IOExceptionCollection class members, see the IOExceptionCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the IOException at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the java.io namespace.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

IOExceptionCollection.Item Property

Gets or sets the IOException at the specified index.

public IOException this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the IOException to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection Methods

The methods of the IOExceptionCollection class are listed below. For a complete list of IOExceptionCollection class members, see the IOExceptionCollection Members topic.

Public Static Methods

Wrap Creates an IOExceptionCollection to represent the given array of IOException (from the java.io namespace).

Public Instance Methods

Add | Adds an IOException to end of the collection.
Append | Overloaded. Appends the IOExceptions of the given IOExceptionCollection to the end of this IOExceptionCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific IOException.
CopyTo | Copies all of the IOExceptions in the IOExceptionCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific IOException in the collection.
Insert | Inserts an IOException into the collection at the specified position.
Remove | Removes the first occurrence of a specific IOException from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the IOExceptions in this IOExceptionCollection.
Sort | Sorts the IOExceptions in this IOExceptionCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the java.io namespace.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection.Add Method

Adds an IOException to end of the collection.

public int Add(
IOException value
);

Parameters

value
The IOException to add to the collection.

Return Value

The position into which the new IOException was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

IOExceptionCollection.Append Method

Appends the IOExceptions of the given IOExceptionCollection to the end of this IOExceptionCollection.

Overload List

Appends the IOExceptions of the given IOExceptionCollection to the end of this IOExceptionCollection.

public IOExceptionCollection Append(IOExceptionCollection);

Appends the IOExceptions of the given array to the end of this IOExceptionCollection.

public IOExceptionCollection Append(IOException[]);

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection.Append Method (IOExceptionCollection)

Appends the IOExceptions of the given IOExceptionCollection to the end of this IOExceptionCollection.

public IOExceptionCollection Append(
IOExceptionCollection collection
);

Parameters

collection
The IOExceptionCollection whose IOExceptions are to be appended to this IOExceptionCollection.

Return Value

This IOExceptionCollection, modified to include the new IOExceptions.

Remarks

The IOExceptionCollection is modified to include the new members. The individual IOException objects are shared, not copied.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace | IOExceptionCollection.Append Overload List


IOExceptionCollection.Append Method (IOException[])

Appends the IOExceptions of the given array to the end of this IOExceptionCollection.

public IOExceptionCollection Append(
IOException[] array
);

Parameters

array
The array whose IOExceptions are to be appended to this IOExceptionCollection.

Return Value

This IOExceptionCollection, modified to include the new IOExceptions.

Remarks

The IOExceptionCollection is modified to include the new members. The individual IOException objects are shared, not copied.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace | IOExceptionCollection.Append Overload List


IOExceptionCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the java.io namespace.

object IWrapper.Unwrap();

Return Value

The underlying java.io.IOException[].

Implements

IWrapper.Unwrap

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection.Contains Method

Determines whether or not the collection contains a specific IOException.

public bool Contains(
IOException value
);

Parameters

value
The IOException to locate in the collection.

Return Value

true if the IOException is found in the collection; otherwise, false.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection.CopyTo Method

Copies all of the IOExceptions in the IOExceptionCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
IOException[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the IOExceptions copied from the IOExceptionCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of IOExceptions in the source IOExceptionCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source IOExceptionCollection cannot be cast automatically to the type of the destination array.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection.IndexOf Method

Determines the index of a specific IOException in the collection.

public int IndexOf(
IOException value
);

Parameters

value
The IOException to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection.Insert Method

Inserts an IOException into the collection at the specified position.

public void Insert(
Int32 index,
IOException value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The IOException to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection.Remove Method

Removes the first occurrence of a specific IOException from the collection.

public void Remove(
IOException value
);

Parameters

value
The IOException to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection.Reverse Method

Reverses the order of the IOExceptions in this IOExceptionCollection.

new public IOExceptionCollection Reverse();

Return Value

This IOExceptionCollection, modified such that the IOExceptions are reversed.

Remarks

The IOExceptionCollection is modified in place.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection.Sort Method

Sorts the IOExceptions in this IOExceptionCollection, using the given comparer.

new public IOExceptionCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two IOExceptions.

Return Value

This IOExceptionCollection, modified such that the IOExceptions are sorted.

Remarks

The IOExceptionCollection is modified in place.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection.Wrap Method

Creates an IOExceptionCollection to represent the given array of IOException (from the java.io namespace).

public static IOExceptionCollection Wrap(
IOException[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new IOExceptionCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an IOException[] from the java.io namespace to the Borland.StarTeam namespace.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection Type Conversions

The type conversions of the IOExceptionCollection class are listed below. For a complete list of IOExceptionCollection class members, see the IOExceptionCollection Members topic.

Public Static Type Conversions

Implicit IOExceptionCollection to IOException[] Conversion | Converts an IOExceptionCollection from the Borland.StarTeam namespace to an IOException[] in the java.io namespace.
Implicit IOExceptionCollection to IOException[] Conversion | Converts an IOExceptionCollection to an array of IOExceptions.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the java.io namespace.

See Also

IOExceptionCollection Class | IOExceptionCollection Members | Borland.StarTeam Namespace


IOExceptionCollection Implicit IOExceptionCollection to IOException[] Conversion

Converts an IOExceptionCollection from the Borland.StarTeam namespace to an IOException[] in the java.io namespace.

public static implicit operator IOException[](
IOExceptionCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the java.io namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, IOExceptionCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IOExceptionCollection Implicit IOExceptionCollection to IOException[] Conversion

Converts an IOExceptionCollection to an array of IOExceptions.

public static implicit operator IOException[](
IOExceptionCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new IOException wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one IOException wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

IOExceptionCollection Class | Borland.StarTeam Namespace


IPRange Class

This class represents a range of TCP/IP addresses and the required level of encryption for clients to connect to the StarTeam server.

For a list of all members of this type, see IPRange Members.

System.Object
IPRange

public class IPRange : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

IPRange Members | Borland.StarTeam Namespace


IPRange Members

IPRange overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.IPRange.

Public Static Type Conversions

Implicit IPRange to IPRange Conversion Implicitly convert IPRange to com.starbase.starteam.IPRange.

Public Instance Constructors

IPRange Overloaded. Initializes a new instance of the IPRange class.

Public Instance Properties

Algorithm | [read/write] the minimum required level of encryption for this range.
MaxIP | [read/write] the maximum IP address for this range. The form will be "0.0.0.0".
MinIP | [read/write] the minimum IP address for this range. The form will be "0.0.0.0".

Public Instance Methods

Copy | return a copy of this IPRange instance
Equals | Delegate Equals() to com.starbase.starteam.IPRange.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.IPRange.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if this object instance is equal to the source
ToString | Delegate ToString() to com.starbase.starteam.IPRange.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

IPRange Class | Borland.StarTeam Namespace


IPRange Constructor

Construct IPRange from com.starbase.starteam.IPRange.

Overload List

construct a new IPRange from the source

public IPRange(IPRange);

Construct IPRange from com.starbase.starteam.IPRange.

public IPRange(IPRange);

Creates a new IP range/required encryption level. A client whose IP address falls in the specified range will be required to connect with the specified encryption level. The default catch all range is specified with a min and max IP address of "0.0.0.0".

public IPRange(String,String,EncryptionAlgorithm);

See Also

IPRange Class | Borland.StarTeam Namespace


IPRange Constructor (IPRange)

Construct IPRange from com.starbase.starteam.IPRange.

public IPRange(
IPRange impl
);

Parameters

impl
The com.starbase.starteam.IPRange to be wrapped.

See Also

IPRange Class | Borland.StarTeam Namespace | IPRange Constructor Overload List


IPRange Constructor (String, String, EncryptionAlgorithm)

Creates a new IP range/required encryption level. A client whose IP address falls in the specified range will be required to connect with the specified encryption level. The default catch all range is specified with a min and max IP address of "0.0.0.0".

public IPRange(
String min,
String max,
EncryptionAlgorithm required
);

Parameters

min
the start of the IP range in the form "0.0.0.0"
max
the end of the IP range in the form "0.0.0.0"
required
the minimum required encrytpion level for the specified range

See Also

IPRange Class | Borland.StarTeam Namespace | IPRange Constructor Overload List


IPRange Constructor (IPRange)

construct a new IPRange from the source

public IPRange(
IPRange source
);

Parameters

source
IPRange the IPRange to copy

See Also

IPRange Class | Borland.StarTeam Namespace | IPRange Constructor Overload List


IPRange Properties

The properties of the IPRange class are listed below. For a complete list of IPRange class members, see the IPRange Members topic.

Public Instance Properties

Algorithm | [read/write] the minimum required level of encryption for this range.
MaxIP | [read/write] the maximum IP address for this range. The form will be "0.0.0.0".
MinIP | [read/write] the minimum IP address for this range. The form will be "0.0.0.0".

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

IPRange Class | Borland.StarTeam Namespace


Algorithm Property

Borland StarTeam SDK for .NET

IPRange.Algorithm Property

[read/write] the minimum required level of encryption for this range.

public virtual EncryptionAlgorithm Algorithm {get; set;}

Property Value

the minimum required level of encryption for this range.

See Also

IPRange Class | Borland.StarTeam Namespace


MaxIP Property

Borland StarTeam SDK for .NET

IPRange.MaxIP Property

[read/write] the maximum IP address for this range. The form will be "0.0.0.0".

public virtual String MaxIP {get; set;}

Property Value

the maximum IP address for this range. The form will be "0.0.0.0".

See Also

IPRange Class | Borland.StarTeam Namespace


MinIP Property

Borland StarTeam SDK for .NET

IPRange.MinIP Property

[read/write] the minimum IP address for this range. The form will be "0.0.0.0".

public virtual String MinIP {get; set;}

Property Value

the minimum IP address for this range. The form will be "0.0.0.0".

See Also

IPRange Class | Borland.StarTeam Namespace


IPRange Methods

The methods of the IPRange class are listed below. For a complete list of IPRange class members, see the IPRange Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.IPRange.

Public Instance Methods

Copy | return a copy of this IPRange instance
Equals | Delegate Equals() to com.starbase.starteam.IPRange.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.IPRange.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if this object instance is equal to the source
ToString | Delegate ToString() to com.starbase.starteam.IPRange.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

IPRange Class | Borland.StarTeam Namespace


IPRange.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.IPRange

Implements

IWrapper.Unwrap

See Also

IPRange Class | Borland.StarTeam Namespace


IPRange.Copy Method

return a copy of this IPRange instance

public virtual IPRange Copy();

Return Value

IPRange a copy of this IPRange instance

See Also

IPRange Class | Borland.StarTeam Namespace


IPRange.Equals Method

Delegate Equals() to com.starbase.starteam.IPRange.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.IPRange.Equals(obj).

See Also

IPRange Class | Borland.StarTeam Namespace


IPRange.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.IPRange.

public override int GetHashCode();

Return Value

com.starbase.starteam.IPRange.GetHashCode().

See Also

IPRange Class | Borland.StarTeam Namespace


IPRange.IsEqualTo Method

returns true if this object instance is equal to the source

public virtual bool IsEqualTo(
IPRange source
);

Parameters

source
Object the source to comapre with

Return Value

boolean true if this object is equal to the source

See Also

IPRange Class | Borland.StarTeam Namespace


IPRange.ToString Method

Delegate ToString() to com.starbase.starteam.IPRange.

public override string ToString();

Return Value

com.starbase.starteam.IPRange.ToString()

See Also

IPRange Class | Borland.StarTeam Namespace


IPRange.Wrap Method

Dynamically wraps com.starbase.starteam.IPRange.

public static IPRange Wrap(
IPRange impl
);

Parameters

impl
com.starbase.starteam.IPRange to be wrapped.

Return Value

IPRange

See Also

IPRange Class | Borland.StarTeam Namespace


IPRange Type Conversions

The type conversions of the IPRange class are listed below. For a complete list of IPRange class members, see the IPRange Members topic.

Public Static Type Conversions

Implicit IPRange to IPRange Conversion Implicitly convert IPRange to com.starbase.starteam.IPRange.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

IPRange Class | IPRange Members | Borland.StarTeam Namespace


IPRange Implicit IPRange to IPRange Conversion

Implicitly convert IPRange to com.starbase.starteam.IPRange.

public static implicit operator IPRange(
IPRange arg
);

Parameters

arg
IPRange to convert.

Return Value

com.starbase.starteam.IPRange

See Also

IPRange Class | Borland.StarTeam Namespace


IPRangeCollection Class

A strongly-typed collection of IPRanges.

For a list of all members of this type, see IPRangeCollection Members.

System.Object
ArrayAdapter
IPRangeCollection

public class IPRangeCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

IPRangeCollection Members | Borland.StarTeam Namespace


IPRangeCollection Members

IPRangeCollection overview

Public Static Methods

Wrap Creates an IPRangeCollection to represent the given array of IPRange (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit IPRangeCollection to IPRange[] Conversion | Converts an IPRangeCollection to an array of IPRanges.
Implicit IPRangeCollection to IPRange[] Conversion | Converts an IPRangeCollection from the Borland.StarTeam namespace to an IPRange[] in the com.starbase.starteam namespace.

Public Instance Constructors

IPRangeCollection Overloaded. Initializes a new instance of the IPRangeCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the IPRange at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an IPRange to end of the collection.
Append | Overloaded. Appends the IPRanges of the given IPRangeCollection to the end of this IPRangeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific IPRange.
CopyTo | Copies all of the IPRanges in the IPRangeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific IPRange in the collection.
Insert | Inserts an IPRange into the collection at the specified position.
Remove | Removes the first occurrence of a specific IPRange from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the IPRanges in this IPRangeCollection.
Sort | Sorts the IPRanges in this IPRangeCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection Constructor

Initializes an instance of the IPRangeCollection class.

Overload List

Initializes an instance of the IPRangeCollection class.

public IPRangeCollection();

Initializes an instance of the an IPRangeCollection class, copying the given array.

public IPRangeCollection(IPRange[]);

Initializes an instance of the an IPRangeCollection class, copying the given collection.

public IPRangeCollection(IPRangeCollection);

Initializes an instance of the an IPRangeCollection class, wrapping the given array of IPRange (from the com.starbase.starteam namespace).

public IPRangeCollection(IPRange[]);

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection Constructor ()

Initializes an instance of the IPRangeCollection class.

public IPRangeCollection();

See Also

IPRangeCollection Class | Borland.StarTeam Namespace | IPRangeCollection Constructor Overload List


IPRangeCollection Constructor (IPRange[])

Initializes an instance of the an IPRangeCollection class, wrapping the given array of IPRange (from the com.starbase.starteam namespace).

public IPRangeCollection(
IPRange[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace | IPRangeCollection Constructor Overload List | Wrap


IPRangeCollection Constructor (IPRangeCollection)

Initializes an instance of the an IPRangeCollection class, copying the given collection.

public IPRangeCollection(
IPRangeCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member IPRange objects of the original collection are shared, not copied.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace | IPRangeCollection Constructor Overload List


IPRangeCollection Constructor (IPRange[])

Initializes an instance of the an IPRangeCollection class, copying the given array.

public IPRangeCollection(
IPRange[] array
);

Parameters

array
The array to be copied.

Remarks

The member IPRange objects of the original array are shared, not copied.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace | IPRangeCollection Constructor Overload List


IPRangeCollection Properties

The properties of the IPRangeCollection class are listed below. For a complete list of IPRangeCollection class members, see the IPRangeCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the IPRange at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

IPRangeCollection.Item Property

Gets or sets the IPRange at the specified index.

public IPRange this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the IPRange to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection Methods

The methods of the IPRangeCollection class are listed below. For a complete list of IPRangeCollection class members, see the IPRangeCollection Members topic.

Public Static Methods

Wrap Creates an IPRangeCollection to represent the given array of IPRange (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds an IPRange to end of the collection.
Append | Overloaded. Appends the IPRanges of the given IPRangeCollection to the end of this IPRangeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific IPRange.
CopyTo | Copies all of the IPRanges in the IPRangeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific IPRange in the collection.
Insert | Inserts an IPRange into the collection at the specified position.
Remove | Removes the first occurrence of a specific IPRange from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the IPRanges in this IPRangeCollection.
Sort | Sorts the IPRanges in this IPRangeCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection.Add Method

Adds an IPRange to end of the collection.

public int Add(
IPRange value
);

Parameters

value
The IPRange to add to the collection.

Return Value

The position into which the new IPRange was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

IPRangeCollection.Append Method

Appends the IPRanges of the given array to the end of this IPRangeCollection.

Overload List

Appends the IPRanges of the given array to the end of this IPRangeCollection.

public IPRangeCollection Append(IPRange[]);

Appends the IPRanges of the given IPRangeCollection to the end of this IPRangeCollection.

public IPRangeCollection Append(IPRangeCollection);

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection.Append Method (IPRange[])

Appends the IPRanges of the given array to the end of this IPRangeCollection.

public IPRangeCollection Append(
IPRange[] array
);

Parameters

array
The array whose IPRanges are to be appended to this IPRangeCollection.

Return Value

This IPRangeCollection, modified to include the new IPRanges.

Remarks

The IPRangeCollection is modified to include the new members. The individual IPRange objects are shared, not copied.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace | IPRangeCollection.Append Overload List


IPRangeCollection.Append Method (IPRangeCollection)

Appends the IPRanges of the given IPRangeCollection to the end of this IPRangeCollection.

public IPRangeCollection Append(
IPRangeCollection collection
);

Parameters

collection
The IPRangeCollection whose IPRanges are to be appended to this IPRangeCollection.

Return Value

This IPRangeCollection, modified to include the new IPRanges.

Remarks

The IPRangeCollection is modified to include the new members. The individual IPRange objects are shared, not copied.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace | IPRangeCollection.Append Overload List


IPRangeCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.IPRange[].

Implements

IWrapper.Unwrap

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection.Contains Method

Determines whether or not the collection contains a specific IPRange.

public bool Contains(
IPRange value
);

Parameters

value
The IPRange to locate in the collection.

Return Value

true if the IPRange is found in the collection; otherwise, false.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection.CopyTo Method

Copies all of the IPRanges in the IPRangeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
IPRange[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the IPRanges copied from the IPRangeCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of IPRanges in the source IPRangeCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source IPRangeCollection cannot be cast automatically to the type of the destination array.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection.IndexOf Method

Determines the index of a specific IPRange in the collection.

public int IndexOf(
IPRange value
);

Parameters

value
The IPRange to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection.Insert Method

Inserts an IPRange into the collection at the specified position.

public void Insert(
Int32 index,
IPRange value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The IPRange to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection.Remove Method

Removes the first occurrence of a specific IPRange from the collection.

public void Remove(
IPRange value
);

Parameters

value
The IPRange to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection.Reverse Method

Reverses the order of the IPRanges in this IPRangeCollection.

new public IPRangeCollection Reverse();

Return Value

This IPRangeCollection, modified such that the IPRanges are reversed.

Remarks

The IPRangeCollection is modified in place.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection.Sort Method

Sorts the IPRanges in this IPRangeCollection, using the given comparer.

new public IPRangeCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two IPRanges.

Return Value

This IPRangeCollection, modified such that the IPRanges are sorted.

Remarks

The IPRangeCollection is modified in place.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection.Wrap Method

Creates an IPRangeCollection to represent the given array of IPRange (from the com.starbase.starteam namespace).

public static IPRangeCollection Wrap(
IPRange[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new IPRangeCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an IPRange[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection Type Conversions

The type conversions of the IPRangeCollection class are listed below. For a complete list of IPRangeCollection class members, see the IPRangeCollection Members topic.

Public Static Type Conversions

Implicit IPRangeCollection to IPRange[] Conversion | Converts an IPRangeCollection to an array of IPRanges.
Implicit IPRangeCollection to IPRange[] Conversion | Converts an IPRangeCollection from the Borland.StarTeam namespace to an IPRange[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

IPRangeCollection Class | IPRangeCollection Members | Borland.StarTeam Namespace


IPRangeCollection Implicit IPRangeCollection to IPRange[] Conversion

Converts an IPRangeCollection to an array of IPRanges.

public static implicit operator IPRange[](
IPRangeCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new IPRange wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one IPRange wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


IPRangeCollection Implicit IPRangeCollection to IPRange[] Conversion

Converts an IPRangeCollection from the Borland.StarTeam namespace to an IPRange[] in the com.starbase.starteam namespace.

public static implicit operator IPRange[](
IPRangeCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, IPRangeCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

IPRangeCollection Class | Borland.StarTeam Namespace


ISecurable Interface

An object that can be secured in the repository.

For a list of all members of this type, see ISecurable Members.

Borland.StarTeam.ISecurable
ISecurableObject

public interface ISecurable

Types that implement ISecurable

Type | Description
Audit | Represents a StarTeam Audit record
ChangeRequest | Represents a StarTeam ChangeRequest item.
File | Represents a StarTeam File item.
Filter | The Filter class is used to define criteria for which items (files, change requests) should be displayed to a user. It includes information on which items should be displayed, which properties should be displayed, and how the items should be sorted or grouped. The StarTeam GUI uses filters to determine what items in a folder to display.
Folder | Represents a StarTeam Folder.
ISecurableAdapter |
ISecurableObjectAdapter |
Item | Contextual reference to an object in a StarTeam repository. Items provide transparent access to the underlying entity (e.g., modifying the description of an item by calling Item.put("Description", "some text") actually modifies the Desription property of the underlying entity the Item references. An Item consists of the underlying entity and its context within a view. Therefore, an Item has direct knowledge of the items to which it is related. Items also maintain state information to determine if the underlying object is is new or modified relative to instances of the object stored in the repository. An Item also has a temporal aspect in that it represents a single development path (linear history) of the underlying object as of a moment in time.
Project | Represents a StarTeam project which is essentially just a collection of Views.
PromotionState | This class represents a promotion state associated with a promotion model. This class has no update() method so to save new or modified promotion states you must use PromotionModel.update()
Query | The QueryInfo class implements a query condition to be applied to items of a certain type. QueryInfo objects are used in conjunction with Filter objects for describing what items to display to the user and how to display them.
RecycleBin |
Task | Represents a StarTeam Task item.
Topic | Represents a StarTeam Topic.
TreeItem | A type of item with children.
View | Represents a StarTeam View.
MergePreview | Title: Starteam SDK Description: A MergePreview is a read-only reference View with additional properties, and some local, context specific overrides Copyright: Copyright (c) 2001 Company: Borland Corporation
VCMFolder |

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ISecurable Members | Borland.StarTeam Namespace


ISecurable Members

ISecurable overview

Public Instance Properties

ACL | [read/write] The access rights explicitly assigned to this object.
ParentContainer | [read] This object's parent container.
Type | [read] This object's type.

Public Instance Methods

HasPermission Determines whether or not the given permissions are granted to the logged in user for this securable object.

See Also

ISecurable Interface | Borland.StarTeam Namespace


ISecurable Properties

The properties of the ISecurable interface are listed below. For a complete list of ISecurable interface members, see the ISecurable Members topic.

Public Instance Properties

ACL | [read/write] The access rights explicitly assigned to this object.
ParentContainer | [read] This object's parent container.
Type | [read] This object's type.

See Also

ISecurable Interface | Borland.StarTeam Namespace


ACL Property

Borland StarTeam SDK for .NET

ISecurable.ACL Property

[read/write] The access rights explicitly assigned to this object.

ACL ACL {get; set;}

Property Value

The access rights explicitly assigned to this object.

See Also

ISecurable Interface | Borland.StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

ISecurable.ParentContainer Property

[read] This object's parent container.

ISecurableContainer ParentContainer {get;}

Property Value

This object's parent container.

See Also

ISecurable Interface | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

ISecurable.Type Property

[read] This object's type.

Type Type {get;}

Property Value

This object's type.

See Also

ISecurable Interface | Borland.StarTeam Namespace


ISecurable Methods

The methods of the ISecurable interface are listed below. For a complete list of ISecurable interface members, see the ISecurable Members topic.

Public Instance Methods

HasPermission Determines whether or not the given permissions are granted to the logged in user for this securable object.

See Also

ISecurable Interface | Borland.StarTeam Namespace


ISecurable.HasPermission Method

Determines whether or not the given permissions are granted to the logged in user for this securable object.

bool HasPermission(
Int32 permissions
);

Parameters

permissions
One or more permissions to be tested.

Return Value

true if all the requested permissions are granted; false if at least one of the requested permissions is denied.

See Also

ISecurable Interface | Borland.StarTeam Namespace | Permission


ISecurableAdapter Class

For a list of all members of this type, see ISecurableAdapter Members.

System.Object
ISecurableAdapter

public class ISecurableAdapter : ISecurable, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ISecurableAdapter Members | Borland.StarTeam Namespace


ISecurableAdapter Members

ISecurableAdapter overview

Public Instance Constructors

ISecurableAdapter Overloaded. Initializes a new instance of the ISecurableAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ISecurable.ACL
ISecurable.getACL
ISecurable.getParentContainer
ISecurable.getType
ISecurable.hasPermission
ISecurable.HasPermission
ISecurable.ParentContainer
ISecurable.setACL
ISecurable.Type

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurableAdapter Constructor

Overload List

public ISecurableAdapter(ISecurable);

public ISecurableAdapter(ISecurable);

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurableAdapter Constructor (ISecurable)

public ISecurableAdapter(
ISecurable arg
);

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace | ISecurableAdapter Constructor Overload List


ISecurableAdapter Properties

The properties of the ISecurableAdapter class are listed below. For a complete list of ISecurableAdapter class members, see the ISecurableAdapter Members topic.

Explicit Interface Implementations

ISecurable.ACL
ISecurable.getACL
ISecurable.getParentContainer
ISecurable.getType
ISecurable.hasPermission
ISecurable.HasPermission
ISecurable.ParentContainer
ISecurable.setACL
ISecurable.Type

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurable.ACL Property

Borland StarTeam SDK for .NET

ISecurableAdapter.ISecurable.ACL Property

private ACL ISecurable.ACL {get; set;}

Implements

ISecurable.ACL

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurable.ParentContainer Property

Borland StarTeam SDK for .NET

ISecurableAdapter.ISecurable.ParentContainer Property

private ISecurableContainer ISecurable.ParentContainer {get;}

Implements

ISecurable.ParentContainer

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurable.Type Property

Borland StarTeam SDK for .NET

ISecurableAdapter.ISecurable.Type Property

private Type ISecurable.Type {get;}

Implements

ISecurable.Type

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurableAdapter Methods

The methods of the ISecurableAdapter class are listed below. For a complete list of ISecurableAdapter class members, see the ISecurableAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ISecurable.ACL
ISecurable.getACL
ISecurable.getParentContainer
ISecurable.getType
ISecurable.hasPermission
ISecurable.HasPermission
ISecurable.ParentContainer
ISecurable.setACL
ISecurable.Type

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurableAdapter.ISecurable.HasPermission Method

bool ISecurable.HasPermission(
Int32 permissions
);

Implements

ISecurable.HasPermission

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurableAdapter.ISecurable.getACL Method

AclEntry[] ISecurable.getACL();

Implements

ISecurable.getACL

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurableAdapter.ISecurable.getParentContainer Method

ISecurableContainer ISecurable.getParentContainer();

Implements

ISecurable.getParentContainer

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurableAdapter.ISecurable.getType Method

Type ISecurable.getType();

Implements

ISecurable.getType

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurableAdapter.ISecurable.hasPermission Method

bool ISecurable.hasPermission(
Int32 permissions
);

Implements

ISecurable.hasPermission

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurableAdapter.ISecurable.setACL Method

void ISecurable.setACL(
AclEntry[] value
);

Implements

ISecurable.setACL

See Also

ISecurableAdapter Class | Borland.StarTeam Namespace


ISecurableContainer Interface

A container in the repository that can hold secured objects of a given type.

For a list of all members of this type, see ISecurableContainer Members.

public interface ISecurableContainer

Types that implement ISecurableContainer

Type | Description
Folder | Represents a StarTeam Folder.
ISecurableContainerAdapter |
Project | Represents a StarTeam project which is essentially just a collection of Views.
RecycleBin |
SecurableContainerAdapter | An implementation of ISecurableContainer that can be used as a wrapper for the object returned by getParentContainer(), for classes whose wrapped getParentContainer() method does not return an instance of a public class; for instance Filter and QueryInfo.
Type | Information describing certain StarTeam object types.
View | Represents a StarTeam View.
MergePreview | Title: Starteam SDK Description: A MergePreview is a read-only reference View with additional properties, and some local, context specific overrides Copyright: Copyright (c) 2001 Company: Borland Corporation
VCMFolder |

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ISecurableContainer Members | Borland.StarTeam Namespace


ISecurableContainer Members

ISecurableContainer overview

Public Instance Properties

ParentContainer [read] This object's parent container.

Public Instance Methods

GetContainerLevelACL | Gets the container-level access rights explicitly assigned to this container for objects of the given type.
HasPermission | Determines whether or not the given permissions are granted to the logged in user for securable objects of the given type in this container.
SetContainerLevelACL | Sets the container-level access rights explicitly assigned to this container for objects of the given type.

See Also

ISecurableContainer Interface | Borland.StarTeam Namespace


ISecurableContainer Properties

The properties of the ISecurableContainer interface are listed below. For a complete list of ISecurableContainer interface members, see the ISecurableContainer Members topic.

Public Instance Properties

ParentContainer [read] This object's parent container.

See Also

ISecurableContainer Interface | Borland.StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

ISecurableContainer.ParentContainer Property

[read] This object's parent container.

ISecurableContainer ParentContainer {get;}

Property Value

This object's parent container.

See Also

ISecurableContainer Interface | Borland.StarTeam Namespace


ISecurableContainer Methods

The methods of the ISecurableContainer interface are listed below. For a complete list of ISecurableContainer interface members, see the ISecurableContainer Members topic.

Public Instance Methods

GetContainerLevelACL | Gets the container-level access rights explicitly assigned to this container for objects of the given type.
HasPermission | Determines whether or not the given permissions are granted to the logged in user for securable objects of the given type in this container.
SetContainerLevelACL | Sets the container-level access rights explicitly assigned to this container for objects of the given type.

See Also

ISecurableContainer Interface | Borland.StarTeam Namespace


ISecurableContainer.GetContainerLevelACL Method

Gets the container-level access rights explicitly assigned to this container for objects of the given type.

ACL GetContainerLevelACL(
String typeName
);

Parameters

typeName
The name of the type of the secured objects in this container.

Return Value

The container-level access rights for objects of the given type, or null if there are none assigned to this container.

See Also

ISecurableContainer Interface | Borland.StarTeam Namespace | AclEntry | TypeNames


ISecurableContainer.HasPermission Method

Determines whether or not the given permissions are granted to the logged in user for securable objects of the given type in this container.

bool HasPermission(
Int32 permissions,
String typeName
);

Parameters

permissions
One or more permissions to be tested.
typeName
The name of the type of the secured objects in this container.

Return Value

true if all the requested permissions are granted; false if at least one of the requested permissions is denied.

See Also

ISecurableContainer Interface | Borland.StarTeam Namespace | Permission | TypeNames


ISecurableContainer.SetContainerLevelACL Method

Sets the container-level access rights explicitly assigned to this container for objects of the given type.

void SetContainerLevelACL(
ACL acl,
String typeName
);

Parameters

acl
The access control list for this container, or null to remove any existing access rights.
typeName
The name of the type of the secured objects in this container.

See Also

ISecurableContainer Interface | Borland.StarTeam Namespace | AclEntry | TypeNames


ISecurableContainerAdapter Class

For a list of all members of this type, see ISecurableContainerAdapter Members.

System.Object
ISecurableContainerAdapter

public class ISecurableContainerAdapter : ISecurableContainer, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ISecurableContainerAdapter Members | Borland.StarTeam Namespace


ISecurableContainerAdapter Members

ISecurableContainerAdapter overview

Public Instance Constructors

ISecurableContainerAdapter Overloaded. Initializes a new instance of the ISecurableContainerAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ISecurableContainer.getContainerLevelACL
ISecurableContainer.GetContainerLevelACL
ISecurableContainer.getParentContainer
ISecurableContainer.hasPermission
ISecurableContainer.HasPermission
ISecurableContainer.ParentContainer
ISecurableContainer.setContainerLevelACL
ISecurableContainer.SetContainerLevelACL

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableContainerAdapter Constructor

Overload List

public ISecurableContainerAdapter(ISecurableContainer);

public ISecurableContainerAdapter(ISecurableContainer);

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableContainerAdapter Constructor (ISecurableContainer)

public ISecurableContainerAdapter(
ISecurableContainer arg
);

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace | ISecurableContainerAdapter Constructor Overload List


ISecurableContainerAdapter Properties

The properties of the ISecurableContainerAdapter class are listed below. For a complete list of ISecurableContainerAdapter class members, see the ISecurableContainerAdapter Members topic.

Explicit Interface Implementations

ISecurableContainer.getContainerLevelACL
ISecurableContainer.GetContainerLevelACL
ISecurableContainer.getParentContainer
ISecurableContainer.hasPermission
ISecurableContainer.HasPermission
ISecurableContainer.ParentContainer
ISecurableContainer.setContainerLevelACL
ISecurableContainer.SetContainerLevelACL

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableContainer.ParentContainer Property

Borland StarTeam SDK for .NET

ISecurableContainerAdapter.ISecurableContainer.ParentContainer Property

private ISecurableContainer ISecurableContainer.ParentContainer {get;}

Implements

ISecurableContainer.ParentContainer

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableContainerAdapter Methods

The methods of the ISecurableContainerAdapter class are listed below. For a complete list of ISecurableContainerAdapter class members, see the ISecurableContainerAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ISecurableContainer.getContainerLevelACL
ISecurableContainer.GetContainerLevelACL
ISecurableContainer.getParentContainer
ISecurableContainer.hasPermission
ISecurableContainer.HasPermission
ISecurableContainer.ParentContainer
ISecurableContainer.setContainerLevelACL
ISecurableContainer.SetContainerLevelACL

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableContainerAdapter.ISecurableContainer.GetContainerLevelACL Method

ACL ISecurableContainer.GetContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.GetContainerLevelACL

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableContainerAdapter.ISecurableContainer.HasPermission Method

bool ISecurableContainer.HasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.HasPermission

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableContainerAdapter.ISecurableContainer.SetContainerLevelACL Method

void ISecurableContainer.SetContainerLevelACL(
ACL acl,
String typeName
);

Implements

ISecurableContainer.SetContainerLevelACL

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableContainerAdapter.ISecurableContainer.getContainerLevelACL Method

AclEntry[] ISecurableContainer.getContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.getContainerLevelACL

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableContainerAdapter.ISecurableContainer.getParentContainer Method

ISecurableContainer ISecurableContainer.getParentContainer();

Implements

ISecurableContainer.getParentContainer

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableContainerAdapter.ISecurableContainer.hasPermission Method

bool ISecurableContainer.hasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.hasPermission

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableContainerAdapter.ISecurableContainer.setContainerLevelACL Method

void ISecurableContainer.setContainerLevelACL(
AclEntry[] acl,
String typeName
);

Implements

ISecurableContainer.setContainerLevelACL

See Also

ISecurableContainerAdapter Class | Borland.StarTeam Namespace


ISecurableObject Interface

An object that can be secured in the repository.

For a list of all members of this type, see ISecurableObject Members.

public interface ISecurableObject : ISecurable

Types that implement ISecurableObject

Type | Description
Audit | Represents a StarTeam Audit record
ChangeRequest | Represents a StarTeam ChangeRequest item.
File | Represents a StarTeam File item.
Folder | Represents a StarTeam Folder.
ISecurableObjectAdapter |
Item | Contextual reference to an object in a StarTeam repository. Items provide transparent access to the underlying entity (e.g., modifying the description of an item by calling Item.put("Description", "some text") actually modifies the Desription property of the underlying entity the Item references. An Item consists of the underlying entity and its context within a view. Therefore, an Item has direct knowledge of the items to which it is related. Items also maintain state information to determine if the underlying object is is new or modified relative to instances of the object stored in the repository. An Item also has a temporal aspect in that it represents a single development path (linear history) of the underlying object as of a moment in time.
Project | Represents a StarTeam project which is essentially just a collection of Views.
PromotionState | This class represents a promotion state associated with a promotion model. This class has no update() method so to save new or modified promotion states you must use PromotionModel.update()
RecycleBin |
Task | Represents a StarTeam Task item.
Topic | Represents a StarTeam Topic.
TreeItem | A type of item with children.
View | Represents a StarTeam View.
MergePreview | Title: Starteam SDK Description: A MergePreview is a read-only reference View with additional properties, and some local, context specific overrides Copyright: Copyright (c) 2001 Company: Borland Corporation
VCMFolder |

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ISecurableObject Members | Borland.StarTeam Namespace


ISecurableObject Members

ISecurableObject overview

Public Instance Properties

Owner [read] The ID of the user who is the owner of this object.

Public Instance Methods

AcquireOwnership Sets ownership of this securable object to the logged in user.

See Also

ISecurableObject Interface | Borland.StarTeam Namespace


ISecurableObject Properties

The properties of the ISecurableObject interface are listed below. For a complete list of ISecurableObject interface members, see the ISecurableObject Members topic.

Public Instance Properties

Owner [read] The ID of the user who is the owner of this object.

See Also

ISecurableObject Interface | Borland.StarTeam Namespace


Owner Property

Borland StarTeam SDK for .NET

ISecurableObject.Owner Property

[read] The ID of the user who is the owner of this object.

Int32 Owner {get;}

Property Value

The ID of the user who is the owner of this object.

See Also

ISecurableObject Interface | Borland.StarTeam Namespace


ISecurableObject Methods

The methods of the ISecurableObject interface are listed below. For a complete list of ISecurableObject interface members, see the ISecurableObject Members topic.

Public Instance Methods

AcquireOwnership Sets ownership of this securable object to the logged in user.

See Also

ISecurableObject Interface | Borland.StarTeam Namespace


ISecurableObject.AcquireOwnership Method

Sets ownership of this securable object to the logged in user.

void AcquireOwnership();

See Also

ISecurableObject Interface | Borland.StarTeam Namespace


ISecurableObjectAdapter Class

For a list of all members of this type, see ISecurableObjectAdapter Members.

System.Object
ISecurableObjectAdapter

public class ISecurableObjectAdapter : ISecurableObject, ISecurable, ISecurableObject, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ISecurableObjectAdapter Members | Borland.StarTeam Namespace


ISecurableObjectAdapter Members

ISecurableObjectAdapter overview

Public Instance Constructors

ISecurableObjectAdapter Overloaded. Initializes a new instance of the ISecurableObjectAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ISecurable.ACL
ISecurable.getACL
ISecurable.getParentContainer
ISecurable.getType
ISecurable.hasPermission
ISecurable.HasPermission
ISecurable.ParentContainer
ISecurable.setACL
ISecurable.Type
ISecurableObject.acquireOwnership
ISecurableObject.AcquireOwnership
ISecurableObject.getOwner
ISecurableObject.Owner

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter Constructor

Overload List

public ISecurableObjectAdapter(ISecurableObject);

public ISecurableObjectAdapter(ISecurableObject);

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter Constructor (ISecurableObject)

public ISecurableObjectAdapter(
ISecurableObject arg
);

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace | ISecurableObjectAdapter Constructor Overload List


ISecurableObjectAdapter Properties

The properties of the ISecurableObjectAdapter class are listed below. For a complete list of ISecurableObjectAdapter class members, see the ISecurableObjectAdapter Members topic.

Explicit Interface Implementations

ISecurable.ACL
ISecurable.getACL
ISecurable.getParentContainer
ISecurable.getType
ISecurable.hasPermission
ISecurable.HasPermission
ISecurable.ParentContainer
ISecurable.setACL
ISecurable.Type
ISecurableObject.acquireOwnership
ISecurableObject.AcquireOwnership
ISecurableObject.getOwner
ISecurableObject.Owner

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurable.ACL Property

Borland StarTeam SDK for .NET

ISecurableObjectAdapter.ISecurable.ACL Property

private ACL ISecurable.ACL {get; set;}

Implements

ISecurable.ACL

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurable.ParentContainer Property

Borland StarTeam SDK for .NET

ISecurableObjectAdapter.ISecurable.ParentContainer Property

private ISecurableContainer ISecurable.ParentContainer {get;}

Implements

ISecurable.ParentContainer

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurable.Type Property

Borland StarTeam SDK for .NET

ISecurableObjectAdapter.ISecurable.Type Property

private Type ISecurable.Type {get;}

Implements

ISecurable.Type

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObject.Owner Property

Borland StarTeam SDK for .NET

ISecurableObjectAdapter.ISecurableObject.Owner Property

private Int32 ISecurableObject.Owner {get;}

Implements

ISecurableObject.Owner

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter Methods

The methods of the ISecurableObjectAdapter class are listed below. For a complete list of ISecurableObjectAdapter class members, see the ISecurableObjectAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ISecurable.ACL
ISecurable.getACL
ISecurable.getParentContainer
ISecurable.getType
ISecurable.hasPermission
ISecurable.HasPermission
ISecurable.ParentContainer
ISecurable.setACL
ISecurable.Type
ISecurableObject.acquireOwnership
ISecurableObject.AcquireOwnership
ISecurableObject.getOwner
ISecurableObject.Owner

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter.ISecurable.HasPermission Method

bool ISecurable.HasPermission(
Int32 permissions
);

Implements

ISecurable.HasPermission

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter.ISecurableObject.AcquireOwnership Method

void ISecurableObject.AcquireOwnership();

Implements

ISecurableObject.AcquireOwnership

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter.ISecurable.getACL Method

AclEntry[] ISecurable.getACL();

Implements

ISecurable.getACL

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter.ISecurable.getParentContainer Method

ISecurableContainer ISecurable.getParentContainer();

Implements

ISecurable.getParentContainer

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter.ISecurable.getType Method

Type ISecurable.getType();

Implements

ISecurable.getType

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter.ISecurable.hasPermission Method

bool ISecurable.hasPermission(
Int32 permissions
);

Implements

ISecurable.hasPermission

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter.ISecurable.setACL Method

void ISecurable.setACL(
AclEntry[] value
);

Implements

ISecurable.setACL

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter.ISecurableObject.acquireOwnership Method

void ISecurableObject.acquireOwnership();

Implements

ISecurableObject.acquireOwnership

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


ISecurableObjectAdapter.ISecurableObject.getOwner Method

int ISecurableObject.getOwner();

Implements

ISecurableObject.getOwner

See Also

ISecurableObjectAdapter Class | Borland.StarTeam Namespace


Item Class

Contextual reference to an object in a StarTeam repository. Items provide transparent access to the underlying entity (e.g., modifying the description of an item by calling Item.put("Description", "some text") actually modifies the Desription property of the underlying entity the Item references. An Item consists of the underlying entity and its context within a view. Therefore, an Item has direct knowledge of the items to which it is related. Items also maintain state information to determine if the underlying object is is new or modified relative to instances of the object stored in the repository. An Item also has a temporal aspect in that it represents a single development path (linear history) of the underlying object as of a moment in time.

For a list of all members of this type, see Item Members.

System.Object
TypedResource
SimpleTypedResource
Item
Audit
ChangeRequest
File
Folder
TreeItem

public class Item : SimpleTypedResource, ISecurableObject, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Item Members | Borland.StarTeam Namespace


Item Members

Item overview

Public Static Methods

CreateItem | This factory method will create a new StarTeam item of the specified type. If the typeName is one of the predefined types: File, ChangeRequest, Folder, Topic or Task then the appropriate subclass of Item will be created and returned. Otherwise an instance of Item itself will be created. This is useful and nescessary in order to create new instances of custom items. (Custom items are typically created by third party vendors.)
GetBranchRevisionFromDotNotation | Computes the "branch revision" from the specified dot notation. The branch revision is the final number in the notation. For example, the branch revision of "1.1" is 1; the branch revision of "1.2.4.7" is 7.
GetViewVersionFromDotNotation | Computes the "view version" from the specified dot notation. The view version starts at 1, and increments for each new item revision. For example, the view version of "1.1" is 2; the view version of "1.2.4.7" is 11.
Wrap | Dynamically wraps com.starbase.starteam.Item.

Public Static Type Conversions

Implicit Item to Item Conversion Implicitly convert Item to com.starbase.starteam.Item.

Public Instance Constructors

Item Constructor Construct Item from com.starbase.starteam.Item.

Public Instance Properties

ACL |
AllLabels | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachedLabels | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs | [read] the ids of all the attachments associated with this item
AttachmentNames | [read] the names of all the attachments associated with this item
Behavior | [read/write] ItemBehavior object associated with this Item
CachedProperties | [read] Property[]
Comment | [read/write] The comment describing this revision of the item.
CreatedBy | [read] The user ID of the user that created the first revision of the item.
CreatedTime | [read] The time at which the first revision of the item was created.
DebugString | [read] a debug string for this item
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
DotNotation | [read] The dot notation identification of this version.
Flag | [read] A value indicating whether or not the user has flagged this item.
History | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable | [read] true if this item is a type that is branchable.
IsDeleted | [read] True if this item is known to have been deleted; false otherwise.
IsDirty | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied | [read]
IsFromHistory | [read] true if this is a historical item obtained from the history.
IsNew | [read] true if this item has not yet been stored in the server.
IsRefreshRequired | [read] true if Item properties may be out of date.
IsRootShare | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID | [read] the unique item ID for this item.
ItemRevisions | [read]
Locker | [read] The user ID of the exclusive locker of this item.
MergeHistory | [read]
ModifiedBy | [read] The user ID of the user that created this revision of the item.
ModifiedTime | [read] The time at which this revision of the item was created.
MyLock | [read] the lock status of the item for the currently logged in user
NewRevisionComment | [read] the empty string.
ObjectID | [read] The object ID for this item.
Owner |
ParentContainer |
ParentFolder | [read] the folder in which this item exists.
ParentFolderHierarchy | [read] The fully-qualified name of this item's parent folder.
ParentFolderName | [read] the name of the item's parent folder.
ParentFolderPath | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName | [read] The fully-qualified name of this item's parent folder.
ParentRevision | [read] The revision number at which this item was branched.
PossibleFlag | [read] The possible values for the Flag property.
PossibleReadStatus | [read] The possible values for the ReadStatus property.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus | [read] A flag indicating whether or not the user has read this item before.
References | [read]
RevisionNumber | [read] The branch revision number for this item.
RootObjectID | [read] The root object ID for this item.
Server | [read] the server object to which this item belongs.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
View | [read] the View in which this item exists.
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AcquireOwnership
AddAttachment | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile | Creates a new attachment and returns the new attachment ID.
DeleteMergePoint | Deletes the specified merge point for this item.
Discard | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetDisplayValue | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetReadStatusDisplayName | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission
HasValues | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo
IsRefreshPropertiesRequired | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo | Moves this item to the specified folder. The item will be removed from its current folder.
Populate | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange | Sets the "Branch On Change" behavior.
SetFixedConfig | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Item Class | Borland.StarTeam Namespace


Item Constructor

Construct Item from com.starbase.starteam.Item.

public Item(
Item impl
);

Parameters

impl
The com.starbase.starteam.Item to be wrapped.

See Also

Item Class | Borland.StarTeam Namespace


Item Properties

The properties of the Item class are listed below. For a complete list of Item class members, see the Item Members topic.

Public Instance Properties

ACL |
AllLabels | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachedLabels | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs | [read] the ids of all the attachments associated with this item
AttachmentNames | [read] the names of all the attachments associated with this item
Behavior | [read/write] ItemBehavior object associated with this Item
CachedProperties | [read] Property[]
Comment | [read/write] The comment describing this revision of the item.
CreatedBy | [read] The user ID of the user that created the first revision of the item.
CreatedTime | [read] The time at which the first revision of the item was created.
DebugString | [read] a debug string for this item
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
DotNotation | [read] The dot notation identification of this version.
Flag | [read] A value indicating whether or not the user has flagged this item.
History | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable | [read] true if this item is a type that is branchable.
IsDeleted | [read] True if this item is known to have been deleted; false otherwise.
IsDirty | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied | [read]
IsFromHistory | [read] true if this is a historical item obtained from the history.
IsNew | [read] true if this item has not yet been stored in the server.
IsRefreshRequired | [read] true if Item properties may be out of date.
IsRootShare | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID | [read] the unique item ID for this item.
ItemRevisions | [read]
Locker | [read] The user ID of the exclusive locker of this item.
MergeHistory | [read]
ModifiedBy | [read] The user ID of the user that created this revision of the item.
ModifiedTime | [read] The time at which this revision of the item was created.
MyLock | [read] the lock status of the item for the currently logged in user
NewRevisionComment | [read] the empty string.
ObjectID | [read] The object ID for this item.
Owner |
ParentContainer |
ParentFolder | [read] the folder in which this item exists.
ParentFolderHierarchy | [read] The fully-qualified name of this item's parent folder.
ParentFolderName | [read] the name of the item's parent folder.
ParentFolderPath | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName | [read] The fully-qualified name of this item's parent folder.
ParentRevision | [read] The revision number at which this item was branched.
PossibleFlag | [read] The possible values for the Flag property.
PossibleReadStatus | [read] The possible values for the ReadStatus property.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus | [read] A flag indicating whether or not the user has read this item before.
References | [read]
RevisionNumber | [read] The branch revision number for this item.
RootObjectID | [read] The root object ID for this item.
Server | [read] the server object to which this item belongs.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
View | [read] the View in which this item exists.
ViewVersion | [read] The view version number of this item.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Item Class | Borland.StarTeam Namespace


ACL Property

Borland StarTeam SDK for .NET

Item.ACL Property

public virtual ACL ACL {get; set;}

Implements

ISecurable.ACL

See Also

Item Class | Borland.StarTeam Namespace


AllLabels Property

Borland StarTeam SDK for .NET

Item.AllLabels Property

[read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.

public virtual LabelCollection AllLabels {get;}

Property Value

an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.

See Also

Item Class | Borland.StarTeam Namespace


AttachedLabels Property

Borland StarTeam SDK for .NET

Item.AttachedLabels Property

[read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.

public virtual LabelCollection AttachedLabels {get;}

Property Value

an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.

See Also

Item Class | Borland.StarTeam Namespace


AttachmentIDs Property

Borland StarTeam SDK for .NET

Item.AttachmentIDs Property

[read] the ids of all the attachments associated with this item

public virtual Int32[] AttachmentIDs {get;}

Property Value

the ids of all the attachments associated with this item

See Also

Item Class | Borland.StarTeam Namespace


AttachmentNames Property

Borland StarTeam SDK for .NET

Item.AttachmentNames Property

[read] the names of all the attachments associated with this item

public virtual String[] AttachmentNames {get;}

Property Value

the names of all the attachments associated with this item

See Also

Item Class | Borland.StarTeam Namespace


Behavior Property

Borland StarTeam SDK for .NET

Item.Behavior Property

[read/write] ItemBehavior object associated with this Item

public virtual ItemBehavior Behavior {get; set;}

Property Value

ItemBehavior object associated with this Item

See Also

Item Class | Borland.StarTeam Namespace


CachedProperties Property

Borland StarTeam SDK for .NET

Item.CachedProperties Property

[read] Property[]

public virtual PropertyCollection CachedProperties {get;}

Property Value

Property[]

See Also

Item Class | Borland.StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Item.Comment Property

[read/write] The comment describing this revision of the item.

public virtual String Comment {get; set;}

Property Value

The comment describing this revision of the item.

See Also

Item Class | Borland.StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Item.CreatedBy Property

[read] The user ID of the user that created the first revision of the item.

public virtual Int32 CreatedBy {get;}

Property Value

The user ID of the user that created the first revision of the item.

See Also

Item Class | Borland.StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Item.CreatedTime Property

[read] The time at which the first revision of the item was created.

public virtual DateTime CreatedTime {get;}

Property Value

The time at which the first revision of the item was created.

See Also

Item Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Item.DebugString Property

[read] a debug string for this item

public virtual String DebugString {get;}

Property Value

a debug string for this item

See Also

Item Class | Borland.StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Item.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Item Class | Borland.StarTeam Namespace


DeletedUserID Property

Borland StarTeam SDK for .NET

Item.DeletedUserID Property

[read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.

public virtual Int32 DeletedUserID {get;}

Property Value

The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.

See Also

Item Class | Borland.StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Item.DotNotation Property

[read] The dot notation identification of this version.

public virtual String DotNotation {get;}

Property Value

The dot notation identification of this version.

See Also

Item Class | Borland.StarTeam Namespace


Flag Property

Borland StarTeam SDK for .NET

Item.Flag Property

[read] A value indicating whether or not the user has flagged this item.

public virtual Int32 Flag {get;}

Property Value

A value indicating whether or not the user has flagged this item.

See Also

Item Class | Borland.StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Item.History Property

[read] the past versions of this item.

public virtual ItemCollection History {get;}

Property Value

the past versions of this item.

See Also

Item Class | Borland.StarTeam Namespace


IsBranchable Property

Borland StarTeam SDK for .NET

Item.IsBranchable Property

[read] true if this item is a type that is branchable.

public virtual Boolean IsBranchable {get;}

Property Value

true if this item is a type that is branchable.

See Also

Item Class | Borland.StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Item.IsDeleted Property

[read] True if this item is known to have been deleted; false otherwise.

public virtual Boolean IsDeleted {get;}

Property Value

True if this item is known to have been deleted; false otherwise.

See Also

Item Class | Borland.StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Item.IsDirty Property

[read] true if any of this item's properties have been modified locally and not yet saved.

public virtual Boolean IsDirty {get;}

Property Value

true if any of this item's properties have been modified locally and not yet saved.

See Also

Item Class | Borland.StarTeam Namespace


IsDisembodied Property

Borland StarTeam SDK for .NET

Item.IsDisembodied Property

[read]

public virtual Boolean IsDisembodied {get;}

See Also

Item Class | Borland.StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Item.IsFromHistory Property

[read] true if this is a historical item obtained from the history.

public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical item obtained from the history.

See Also

Item Class | Borland.StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Item.IsNew Property

[read] true if this item has not yet been stored in the server.

public virtual Boolean IsNew {get;}

Property Value

true if this item has not yet been stored in the server.

See Also

Item Class | Borland.StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

Item.IsRefreshRequired Property

[read] true if Item properties may be out of date.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if Item properties may be out of date.

See Also

Item Class | Borland.StarTeam Namespace


IsRootShare Property

Borland StarTeam SDK for .NET

Item.IsRootShare Property

[read] true if this item is the root share; false otherwise.

public virtual Boolean IsRootShare {get;}

Property Value

true if this item is the root share; false otherwise.

See Also

Item Class | Borland.StarTeam Namespace


ItemID Property

Borland StarTeam SDK for .NET

Item.ItemID Property

[read] the unique item ID for this item.

public virtual Int32 ItemID {get;}

Property Value

the unique item ID for this item.

See Also

Item Class | Borland.StarTeam Namespace


ItemRevisions Property

Borland StarTeam SDK for .NET

Item.ItemRevisions Property

[read]

public virtual ItemRevisionCollection ItemRevisions {get;}

See Also

Item Class | Borland.StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Item.Locker Property

[read] The user ID of the exclusive locker of this item.

public virtual Int32 Locker {get;}

Property Value

The user ID of the exclusive locker of this item.

See Also

Item Class | Borland.StarTeam Namespace


MergeHistory Property

Borland StarTeam SDK for .NET

Item.MergeHistory Property

[read]

public virtual MergePointCollection MergeHistory {get;}

See Also

Item Class | Borland.StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Item.ModifiedBy Property

[read] The user ID of the user that created this revision of the item.

public virtual Int32 ModifiedBy {get;}

Property Value

The user ID of the user that created this revision of the item.

See Also

Item Class | Borland.StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Item.ModifiedTime Property

[read] The time at which this revision of the item was created.

public virtual DateTime ModifiedTime {get;}

Property Value

The time at which this revision of the item was created.

See Also

Item Class | Borland.StarTeam Namespace


MyLock Property

Borland StarTeam SDK for .NET

Item.MyLock Property

[read] the lock status of the item for the currently logged in user

public virtual Int32 MyLock {get;}

Property Value

the lock status of the item for the currently logged in user

See Also

Item Class | Borland.StarTeam Namespace


NewRevisionComment Property

Borland StarTeam SDK for .NET

Item.NewRevisionComment Property

[read] the empty string.

public virtual String NewRevisionComment {get;}

Property Value

the empty string.

See Also

Item Class | Borland.StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Item.ObjectID Property

[read] The object ID for this item.

public virtual Int32 ObjectID {get;}

Property Value

The object ID for this item.

See Also

Item Class | Borland.StarTeam Namespace


Owner Property

Borland StarTeam SDK for .NET

Item.Owner Property

public virtual Int32 Owner {get;}

Implements

ISecurableObject.Owner

See Also

Item Class | Borland.StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

Item.ParentContainer Property

public virtual ISecurableContainer ParentContainer {get;}

Implements

ISecurable.ParentContainer

See Also

Item Class | Borland.StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Item.ParentFolder Property

[read] the folder in which this item exists.

public virtual Folder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Item Class | Borland.StarTeam Namespace


ParentFolderHierarchy Property

Borland StarTeam SDK for .NET

Item.ParentFolderHierarchy Property

[read] The fully-qualified name of this item's parent folder.

public virtual String ParentFolderHierarchy {get;}

Property Value

The fully-qualified name of this item's parent folder.

See Also

Item Class | Borland.StarTeam Namespace


ParentFolderName Property

Borland StarTeam SDK for .NET

Item.ParentFolderName Property

[read] the name of the item's parent folder.

public virtual String ParentFolderName {get;}

Property Value

the name of the item's parent folder.

See Also

Item Class | Borland.StarTeam Namespace


ParentFolderPath Property

Borland StarTeam SDK for .NET

Item.ParentFolderPath Property

[read] the working directory path for the item's parent folder.

public virtual String ParentFolderPath {get;}

Property Value

the working directory path for the item's parent folder.

See Also

Item Class | Borland.StarTeam Namespace


ParentFolderQualifiedName Property

Borland StarTeam SDK for .NET

Item.ParentFolderQualifiedName Property

[read] The fully-qualified name of this item's parent folder.

public virtual String ParentFolderQualifiedName {get;}

Property Value

The fully-qualified name of this item's parent folder.

See Also

Item Class | Borland.StarTeam Namespace


ParentRevision Property

Borland StarTeam SDK for .NET

Item.ParentRevision Property

[read] The revision number at which this item was branched.

public virtual Int32 ParentRevision {get;}

Property Value

The revision number at which this item was branched.

See Also

Item Class | Borland.StarTeam Namespace


PossibleFlag Property

Borland StarTeam SDK for .NET

Item.PossibleFlag Property

[read] The possible values for the Flag property.

public virtual Int32[] PossibleFlag {get;}

Property Value

The possible values for the Flag property.

See Also

Item Class | Borland.StarTeam Namespace


PossibleReadStatus Property

Borland StarTeam SDK for .NET

Item.PossibleReadStatus Property

[read] The possible values for the ReadStatus property.

public virtual Int32[] PossibleReadStatus {get;}

Property Value

The possible values for the ReadStatus property.

See Also

Item Class | Borland.StarTeam Namespace


ReadStatus Property

Borland StarTeam SDK for .NET

Item.ReadStatus Property

[read] A flag indicating whether or not the user has read this item before.

public virtual Int32 ReadStatus {get;}

Property Value

A flag indicating whether or not the user has read this item before.

See Also

Item Class | Borland.StarTeam Namespace


References Property

Borland StarTeam SDK for .NET

Item.References Property

[read]

public virtual ItemReferenceCollection References {get;}

See Also

Item Class | Borland.StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Item.RevisionNumber Property

[read] The branch revision number for this item.

public virtual Int32 RevisionNumber {get;}

Property Value

The branch revision number for this item.

See Also

Item Class | Borland.StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Item.RootObjectID Property

[read] The root object ID for this item.

public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this item.

See Also

Item Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Item.Server Property

[read] the server object to which this item belongs.

public virtual Server Server {get;}

Property Value

the server object to which this item belongs.

See Also

Item Class | Borland.StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Item.View Property

[read] the View in which this item exists.

public virtual View View {get;}

Property Value

the View in which this item exists.

See Also

Item Class | Borland.StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Item.ViewVersion Property

[read] The view version number of this item.

public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Item Class | Borland.StarTeam Namespace


Item Methods

The methods of the Item class are listed below. For a complete list of Item class members, see the Item Members topic.

Public Static Methods

CreateItem | This factory method will create a new StarTeam item of the specified type. If the typeName is one of the predefined types: File, ChangeRequest, Folder, Topic or Task then the appropriate subclass of Item will be created and returned. Otherwise an instance of Item itself will be created. This is useful and nescessary in order to create new instances of custom items. (Custom items are typically created by third party vendors.)
GetBranchRevisionFromDotNotation | Computes the "branch revision" from the specified dot notation. The branch revision is the final number in the notation. For example, the branch revision of "1.1" is 1; the branch revision of "1.2.4.7" is 7.
GetViewVersionFromDotNotation | Computes the "view version" from the specified dot notation. The view version starts at 1, and increments for each new item revision. For example, the view version of "1.1" is 2; the view version of "1.2.4.7" is 11.
Wrap | Dynamically wraps com.starbase.starteam.Item.

Public Instance Methods

AcquireOwnership
AddAttachment | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile | Creates a new attachment and returns the new attachment ID.
DeleteMergePoint | Deletes the specified merge point for this item.
Discard | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetDisplayValue | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetReadStatusDisplayName | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission
HasValues | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo
IsRefreshPropertiesRequired | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo | Moves this item to the specified folder. The item will be removed from its current folder.
Populate | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange | Sets the "Branch On Change" behavior.
SetFixedConfig | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Item Class | Borland.StarTeam Namespace


Item.AcquireOwnership Method

public virtual void AcquireOwnership();

Implements

ISecurableObject.AcquireOwnership

See Also

Item Class | Borland.StarTeam Namespace


Item.AddAttachment Method

Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().

public virtual void AddAttachment(
String name,
Int32 attachmentID
);

Parameters

name
the name of the attachment. The name cannot contain a newline character.
attachmentID
the id of the attachment being added

See Also

Item Class | Borland.StarTeam Namespace | createAttachment | createAttachmentFromFile | ATTACHMENT_COUNT | ATTACHMENT_IDS | ATTACHMENT_NAMES


Item.Copy Method

Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().

public virtual Item Copy();

Return Value

A copy of the Item and all of its properties.

See Also

Item Class | Borland.StarTeam Namespace | isEqualTo


Item.CreateAttachment Method

Creates a new attachment and returns the new attachment ID.

public virtual int CreateAttachment(
String name,
Stream source
);

Parameters

name
the name of the attachment
source
the input stream source to use for the attachment contents

Return Value

the new attachment ID

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Item Class | Borland.StarTeam Namespace


Item.CreateAttachmentFromFile Method

Creates a new attachment and returns the new attachment ID.

public virtual int CreateAttachmentFromFile(
String name,
FileInfo source
);

Parameters

name
the name of the attachment
source
the file to use as the source for the attachment

Return Value

the new attachment ID

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Item Class | Borland.StarTeam Namespace


Item.CreateItem Method

This factory method will create a new StarTeam item of the specified type. If the typeName is one of the predefined types: File, ChangeRequest, Folder, Topic or Task then the appropriate subclass of Item will be created and returned. Otherwise an instance of Item itself will be created. This is useful and nescessary in order to create new instances of custom items. (Custom items are typically created by third party vendors.)

public static Item CreateItem(
String typeName,
Folder parent
);

Parameters

typeName
the name of item type to be created
parent
the folder in which the new item will be created. This may not be null.

See Also

Item Class | Borland.StarTeam Namespace | TypeNames


Item.DeleteMergePoint Method

Deletes the specified merge point for this item.

public virtual void DeleteMergePoint(
MergePoint mergePoint
);

Parameters

mergePoint
the merge point to be deleted

See Also

Item Class | Borland.StarTeam Namespace


Item.Discard Method

Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled).

If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.

public virtual void Discard();

See Also

Item Class | Borland.StarTeam Namespace | refresh


Item.GetAttachment Method

Retrieves the specified attachment and copies it to the specified output stream.

public virtual void GetAttachment(
Int32 attachmentID,
Stream _out
);

Parameters

attachmentID
the attachment ID to retrieve
_out

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Item Class | Borland.StarTeam Namespace


Item.GetAttachmentToFile Method

Retrieves the specified attachment and copies it to the specified output stream.

public virtual void GetAttachmentToFile(
Int32 attachmentID,
FileInfo outFile
);

Parameters

attachmentID
the attachment ID to retrieve
outFile
the file in which to save the attachment

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Item Class | Borland.StarTeam Namespace


Item.GetBranchRevisionFromDotNotation Method

Computes the "branch revision" from the specified dot notation. The branch revision is the final number in the notation. For example, the branch revision of "1.1" is 1; the branch revision of "1.2.4.7" is 7.

public static int GetBranchRevisionFromDotNotation(
String dotNotation
);

Parameters

dotNotation
A dot notation.

Return Value

The corresponding branch revision.

See Also

Item Class | Borland.StarTeam Namespace


Item.GetByProperty Method

Returns the value of the specified property. Retrieves value from persistent store if not already cached.

public virtual object GetByProperty(
Property property
);

Parameters

property
the desired property

Return Value

the value of this property as a java.lang.Object

Exceptions

Exception Type | Condition
 | com.starbase.starteam.NoSuchPropertyException

See Also

Item Class | Borland.StarTeam Namespace | get | getByPropertyID


Item.GetByPropertyID Method

Returns the value of the specified property. Retrieves value from persistent store if not already cached.

public virtual object GetByPropertyID(
Int32 propertyID
);

Parameters

propertyID
the internal ID of the desired property

Return Value

the value of this property as a java.lang.Object

Exceptions

Exception Type | Condition
 | com.starbase.starteam.NoSuchPropertyException

See Also

Item Class | Borland.StarTeam Namespace | get | getByProperty


Item.GetCommonAncestor Method

Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.

public virtual Item GetCommonAncestor(
Item other
);

Parameters

other
The item to be compared with this one.

Return Value

The most recent common ancestor between this item and the given item, or null if the two items have no common ancestor.

See Also

Item Class | Borland.StarTeam Namespace | isBranchable


Item.GetDisplayValue Method

Gets the value of a property in a form suitable for display.

public virtual string GetDisplayValue(
Property prop
);

Parameters

prop
A property of this item.

Return Value

The value of the property in a form suitable for display.

See Also

Item Class | Borland.StarTeam Namespace


Item.GetFlagDisplayName Method

Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetFlagDisplayName(
Int32 value
);

Parameters

value
The Flag value to be converted to a display name.

Return Value

A user-friendly display name for the given Flag value.

See Also

Item Class | Borland.StarTeam Namespace | getFlag | getPossibleFlag | getEnumDisplayName | FLAG | modifyFlagForUser


Item.GetFromHistoryByDate Method

Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.

public virtual Item GetFromHistoryByDate(
DateTime date
);

Parameters

date
The date specifying which historical version to return.

Return Value

The most recent version as of the specified date, or null if the date is prior to the first version of the item.

See Also

Item Class | Borland.StarTeam Namespace


Item.GetFromHistoryByLabelID Method

Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.

public virtual Item GetFromHistoryByLabelID(
Int32 labelID
);

Parameters

labelID
The label ID to be used for finding the specified revision.

Return Value

The specified revision of the item, or null if no version of the item has the label attached.

See Also

Item Class | Borland.StarTeam Namespace | Label | getHistory


Item.GetFromHistoryByVersion Method

Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.

public virtual Item GetFromHistoryByVersion(
Int32 viewVersion
);

Parameters

viewVersion
The desired version of the item.

Return Value

The specified version of the item or null if not found.

See Also

Item Class | Borland.StarTeam Namespace | getViewVersion | getHistory


Item.GetReadStatusDisplayName Method

Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetReadStatusDisplayName(
Int32 value
);

Parameters

value
The ReadStatus value to be converted to a display name.

Return Value

A user-friendly display name for the given ReadStatus value.

See Also

Item Class | Borland.StarTeam Namespace | getReadStatus | getPossibleReadStatus | getEnumDisplayName | READ_STATUS | modifyReadStatusForUser


Item.GetReference Method

Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.

public virtual ItemReference GetReference(
ViewConfiguration config
);

Parameters

config
the ItemConfig that describes the desired configuration, only "Current" and "Time" configurations are supported.

Return Value

the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted.

See Also

Item Class | Borland.StarTeam Namespace | isDisembodied | ViewConfiguration


Item.GetViewVersionFromDotNotation Method

Computes the "view version" from the specified dot notation. The view version starts at 1, and increments for each new item revision. For example, the view version of "1.1" is 2; the view version of "1.2.4.7" is 11.

public static int GetViewVersionFromDotNotation(
String dotNotation
);

Parameters

dotNotation
A dot notation.

Return Value

The corresponding view version.

See Also

Item Class | Borland.StarTeam Namespace


Item.HasPermission Method

public virtual bool HasPermission(
Int32 permissions
);

Implements

ISecurable.HasPermission

See Also

Item Class | Borland.StarTeam Namespace


Item.HasValues Method

Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.

public virtual bool HasValues(
String[] propertyNames
);

Parameters

propertyNames
the names of the properties being checked for cached values

Return Value

true if all of the specified properties have cached values in this item.

See Also

Item Class | Borland.StarTeam Namespace


Item.IsEqualTo Method

public virtual bool IsEqualTo(
Item item
);

See Also

Item Class | Borland.StarTeam Namespace


Item.IsRefreshPropertiesRequired Method

Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.

public virtual bool IsRefreshPropertiesRequired(
String[] propertyNames
);

Parameters

propertyNames
The item properties to be tested.

Return Value

true if Item properties may be out of date.

See Also

Item Class | Borland.StarTeam Namespace | isRefreshRequired | refresh | populate | enableMPX


Item.IsReverseShareRecommended Method

Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.

public virtual bool IsReverseShareRecommended(
Folder target
);

Parameters

target
The target folder.

Return Value

true if a reverse-share is appropriate; false otherwise.

See Also

Item Class | Borland.StarTeam Namespace | smartShareTo


Item.Lock Method

Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.

public virtual void Lock();

See Also

Item Class | Borland.StarTeam Namespace | Item.LockType | putLock


Item.ModifyFlagForUser Method

Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.

public virtual void ModifyFlagForUser(
Boolean setFlagged
);

Parameters

setFlagged
this item's new flag value

See Also

Item Class | Borland.StarTeam Namespace | getFlag | getPossibleFlag | getFlagDisplayName | FLAG


Item.ModifyReadStatusForUser Method

Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.

public virtual void ModifyReadStatusForUser(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Item Class | Borland.StarTeam Namespace | getReadStatus | READ_STATUS_USER_LIST


Item.Move Method

Moves this item to the specified folder. The item will be removed from its current folder.

public virtual void Move(
Folder toFolder
);

Parameters

toFolder
the new folder to which this item is to be moved.

See Also

Item Class | Borland.StarTeam Namespace | isDisembodied


Item.MoveTo Method

Moves this item to the specified folder. The item will be removed from its current folder.

public virtual void MoveTo(
Folder toFolder
);

Parameters

toFolder
the new folder to which this item is to be moved.

See Also

Item Class | Borland.StarTeam Namespace | isDisembodied


Populate Method

Borland StarTeam SDK for .NET

Item.Populate Method

Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.

Overload List

Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.

public virtual void Populate();

Ensures that the given item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.

public virtual void Populate(String[]);

See Also

Item Class | Borland.StarTeam Namespace | populate | refresh | discard


Item.Populate Method ()

Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.

public virtual void Populate();

See Also

Item Class | Borland.StarTeam Namespace | Item.Populate Overload List | populate | refresh | discard


Item.Populate Method (String[])

Ensures that the given item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.

public virtual void Populate(
String[] propertyNames
);

Parameters

propertyNames
The properties to populate, or null to populate all properties.

See Also

Item Class | Borland.StarTeam Namespace | Item.Populate Overload List | populate | refresh | discard


Item.PutLock Method

Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.

public virtual void PutLock(
Int32 lockType,
Boolean breakLock
);

Parameters

lockType
the type of lock to be obtained
breakLock
true if the server should break an exclusive lock

See Also

Item Class | Borland.StarTeam Namespace | Item.LockType


Item.RecordMergePoint Method

Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.

public virtual void RecordMergePoint(
Item source
);

Parameters

source
the source Item that is to be the "merge" origin of the revision specified by this item.

See Also

Item Class | Borland.StarTeam Namespace


Refresh Method

Borland StarTeam SDK for .NET

Item.Refresh Method

Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

Overload List

Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh();

Updates cached properties to reflect recent changes made on the server. Only the given properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh(String[]);

See Also

Item Class | Borland.StarTeam Namespace | refresh | isRefreshRequired | populate | discard | enableMPX


Item.Refresh Method ()

Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh();

See Also

Item Class | Borland.StarTeam Namespace | Item.Refresh Overload List | refresh | isRefreshRequired | populate | discard | enableMPX


Item.Refresh Method (String[])

Updates cached properties to reflect recent changes made on the server. Only the given properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh(
String[] propertyNames
);

Parameters

propertyNames
The properties to be refreshed, or null to refresh all properties.

See Also

Item Class | Borland.StarTeam Namespace | Item.Refresh Overload List | refresh | isRefreshRequired | populate | discard | enableMPX


Item.Remove Method

Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.

public virtual void Remove();

See Also

Item Class | Borland.StarTeam Namespace


Item.RemoveAttachment Method

Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.

public virtual void RemoveAttachment(
Int32 attachmentID
);

Parameters

attachmentID
the id of the attachment to remove

See Also

Item Class | Borland.StarTeam Namespace | getAttachmentIDs | ATTACHMENT_COUNT | ATTACHMENT_IDS | ATTACHMENT_NAMES


Item.ResolveMergePoint Method

Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.

public virtual MergePoint ResolveMergePoint(
Item source
);

Parameters

source
the source Item that was the "merge" origin of the revision specified by this item.

Return Value

the merge point used to create this revision of the item with respect to the specified source item.

See Also

Item Class | Borland.StarTeam Namespace


Item.ReverseShareTo Method

Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location.

In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one.

When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision.

Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.

public virtual Item ReverseShareTo(
Folder toFolder
);

Parameters

toFolder
The new parent folder.

Return Value

The item object representing the new item in the target folder.

See Also

Item Class | Borland.StarTeam Namespace | isDisembodied | moveTo | shareTo | Item


Item.SetBranchOnChange Method

Sets the "Branch On Change" behavior.

public virtual void SetBranchOnChange(
Boolean bBranchOnChange
);

Parameters

bBranchOnChange

See Also

Item Class | Borland.StarTeam Namespace | isDisembodied


Item.SetFixedConfig Method

Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.

public virtual void SetFixedConfig(
ViewConfiguration config
);

Parameters

config
The fixed configuration to be set.

See Also

Item Class | Borland.StarTeam Namespace | setFloatingConfig | setBehavior | isDisembodied


Item.SetFloatingConfig Method

Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.

public virtual void SetFloatingConfig();

See Also

Item Class | Borland.StarTeam Namespace | setFixedConfig | setBehavior | isDisembodied


Item.ShareTo Method

Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one.

If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.

public virtual Item ShareTo(
Folder toFolder
);

Parameters

toFolder
The new parent folder.

Return Value

The item object representing the newly shared item.

See Also

Item Class | Borland.StarTeam Namespace | isDisembodied | moveTo | reverseShareTo | isDeleted | RecycleBin


Item.SmartShareTo Method

Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.

public virtual Item SmartShareTo(
Folder target
);

Parameters

target
The target folder.

Return Value

The shared item.

See Also

Item Class | Borland.StarTeam Namespace | isReverseShareRecommended


Item.Unlock Method

Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.

public virtual void Unlock();

See Also

Item Class | Borland.StarTeam Namespace | Item.LockType | putLock


Item.Update Method

Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.

public virtual void Update();

See Also

Item Class | Borland.StarTeam Namespace


Item.UpdateRevisionComment Method

This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment (may not be null)

See Also

Item Class | Borland.StarTeam Namespace | getObjectID | getRevisionNumber


Item.Wrap Method

Dynamically wraps com.starbase.starteam.Item.

public static Item Wrap(
Item impl
);

Parameters

impl
com.starbase.starteam.Item to be wrapped.

Return Value

Item

See Also

Item Class | Borland.StarTeam Namespace


Item Type Conversions

The type conversions of the Item class are listed below. For a complete list of Item class members, see the Item Members topic.

Public Static Type Conversions

Implicit Item to Item Conversion Implicitly convert Item to com.starbase.starteam.Item.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Item Class | Item Members | Borland.StarTeam Namespace


Item Implicit Item to Item Conversion

Implicitly convert Item to com.starbase.starteam.Item.

public static implicit operator Item(
Item arg
);

Parameters

arg
Item to convert.

Return Value

com.starbase.starteam.Item

See Also

Item Class | Borland.StarTeam Namespace


Item.LockType Class

For a list of all members of this type, see Item.LockType Members.

System.Object
Item.LockType

public class Item.LockType : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Item.LockType Members | Borland.StarTeam Namespace


Item.LockType Members

Item.LockType overview

Public Static Properties

BREAK_FLAG
EXCLUSIVE
NONEXCLUSIVE
UNCHANGED
UNLOCKED

Public Static Type Conversions

Implicit Item.LockType to Item.LockType Conversion

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.Item.LockType.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Item.LockType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.Item.LockType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Item.LockType Class | Borland.StarTeam Namespace


Item.LockType Properties

The properties of the Item.LockType class are listed below. For a complete list of Item.LockType class members, see the Item.LockType Members topic.

Public Static Properties

BREAK_FLAG
EXCLUSIVE
NONEXCLUSIVE
UNCHANGED
UNLOCKED

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Item.LockType Class | Borland.StarTeam Namespace


BREAK_FLAG Property

Borland StarTeam SDK for .NET

Item.LockType.BREAK_FLAG Property

public static Int32 BREAK_FLAG {get;}

See Also

Item.LockType Class | Borland.StarTeam Namespace


EXCLUSIVE Property

Borland StarTeam SDK for .NET

Item.LockType.EXCLUSIVE Property

public static Int32 EXCLUSIVE {get;}

See Also

Item.LockType Class | Borland.StarTeam Namespace


NONEXCLUSIVE Property

Borland StarTeam SDK for .NET

Item.LockType.NONEXCLUSIVE Property

public static Int32 NONEXCLUSIVE {get;}

See Also

Item.LockType Class | Borland.StarTeam Namespace


UNCHANGED Property

Borland StarTeam SDK for .NET

Item.LockType.UNCHANGED Property

public static Int32 UNCHANGED {get;}

See Also

Item.LockType Class | Borland.StarTeam Namespace


UNLOCKED Property

Borland StarTeam SDK for .NET

Item.LockType.UNLOCKED Property

public static Int32 UNLOCKED {get;}

See Also

Item.LockType Class | Borland.StarTeam Namespace


Item.LockType Methods

The methods of the Item.LockType class are listed below. For a complete list of Item.LockType class members, see the Item.LockType Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.Item.LockType.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Item.LockType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.Item.LockType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Item.LockType Class | Borland.StarTeam Namespace


Item.LockType.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.Item.LockType

Implements

IWrapper.Unwrap

See Also

Item.LockType Class | Borland.StarTeam Namespace


Item.LockType.Equals Method

Delegate Equals() to com.starbase.starteam.Item.LockType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.Item.LockType.Equals(obj).

See Also

Item.LockType Class | Borland.StarTeam Namespace


Item.LockType.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.Item.LockType.

public override int GetHashCode();

Return Value

com.starbase.starteam.Item.LockType.GetHashCode().

See Also

Item.LockType Class | Borland.StarTeam Namespace


Item.LockType.ToString Method

Delegate ToString() to com.starbase.starteam.Item.LockType.

public override string ToString();

Return Value

com.starbase.starteam.Item.LockType.ToString()

See Also

Item.LockType Class | Borland.StarTeam Namespace


Item.LockType Type Conversions

The type conversions of the Item.LockType class are listed below. For a complete list of Item.LockType class members, see the Item.LockType Members topic.

Public Static Type Conversions

Implicit Item.LockType to Item.LockType Conversion

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Item.LockType Class | Item.LockType Members | Borland.StarTeam Namespace


Item.LockType Implicit Item.LockType to Item.LockType Conversion

public static implicit operator LockType(
Item.LockType arg
);

See Also

Item.LockType Class | Borland.StarTeam Namespace


ItemBehavior Class

A class that represents the behavior of an Item.

For a list of all members of this type, see ItemBehavior Members.

System.Object
ItemBehavior

public class ItemBehavior : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemBehavior Members | Borland.StarTeam Namespace


ItemBehavior Members

ItemBehavior overview

Public Static Properties

BRANCH_STATE_BRANCHABLE
BRANCH_STATE_BRANCHED
BRANCH_STATE_NOT_SUPPORTED
BRANCH_STATE_ROOT

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ItemBehavior.

Public Static Type Conversions

Implicit ItemBehavior to ItemBehavior Conversion Implicitly convert ItemBehavior to com.starbase.starteam.ItemBehavior.

Public Instance Constructors

ItemBehavior Overloaded. Initializes a new instance of the ItemBehavior class.

Public Instance Properties

BranchOnChange | [read/write] true if this ItemBehavior is set to branch on change; false otherwise.
BranchState | [read] The branch state.
Config | [read/write] This ItemBehavior's current configuration.
FixConfig | [read] true if the item (or its parent item) has a fixed configuration.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ItemBehavior.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ItemBehavior.
GetType (inherited from Object) | Gets the Type of the current instance.
SetFloatingConfig | Changes this ItemBehavior to use a floating configuration. Note that in order to apply the resulting behavior to an item, you must call Item.setBehavior().
ToString | Delegate ToString() to com.starbase.starteam.ItemBehavior.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemBehavior Class | Borland.StarTeam Namespace


ItemBehavior Constructor

Construct ItemBehavior from com.starbase.starteam.ItemBehavior.

Overload List

Constructs a new ItemBehavior that is a copy of an existing one.

public ItemBehavior(ItemBehavior);

Construct ItemBehavior from com.starbase.starteam.ItemBehavior.

public ItemBehavior(ItemBehavior);

See Also

ItemBehavior Class | Borland.StarTeam Namespace


ItemBehavior Constructor (ItemBehavior)

Construct ItemBehavior from com.starbase.starteam.ItemBehavior.

public ItemBehavior(
ItemBehavior impl
);

Parameters

impl
The com.starbase.starteam.ItemBehavior to be wrapped.

See Also

ItemBehavior Class | Borland.StarTeam Namespace | ItemBehavior Constructor Overload List


ItemBehavior Constructor (ItemBehavior)

Constructs a new ItemBehavior that is a copy of an existing one.

public ItemBehavior(
ItemBehavior behavior
);

Parameters

behavior
The existing ItemBehavior to be copied.

See Also

ItemBehavior Class | Borland.StarTeam Namespace | ItemBehavior Constructor Overload List


ItemBehavior Properties

The properties of the ItemBehavior class are listed below. For a complete list of ItemBehavior class members, see the ItemBehavior Members topic.

Public Static Properties

BRANCH_STATE_BRANCHABLE
BRANCH_STATE_BRANCHED
BRANCH_STATE_NOT_SUPPORTED
BRANCH_STATE_ROOT

Public Instance Properties

BranchOnChange | [read/write] true if this ItemBehavior is set to branch on change; false otherwise.
BranchState | [read] The branch state.
Config | [read/write] This ItemBehavior's current configuration.
FixConfig | [read] true if the item (or its parent item) has a fixed configuration.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemBehavior Class | Borland.StarTeam Namespace


BRANCH_STATE_BRANCHABLE Property

Borland StarTeam SDK for .NET

ItemBehavior.BRANCH_STATE_BRANCHABLE Property

public static Int32 BRANCH_STATE_BRANCHABLE {get;}

See Also

ItemBehavior Class | Borland.StarTeam Namespace


BRANCH_STATE_BRANCHED Property

Borland StarTeam SDK for .NET

ItemBehavior.BRANCH_STATE_BRANCHED Property

public static Int32 BRANCH_STATE_BRANCHED {get;}

See Also

ItemBehavior Class | Borland.StarTeam Namespace


BRANCH_STATE_NOT_SUPPORTED Property

Borland StarTeam SDK for .NET

ItemBehavior.BRANCH_STATE_NOT_SUPPORTED Property

public static Int32 BRANCH_STATE_NOT_SUPPORTED {get;}

See Also

ItemBehavior Class | Borland.StarTeam Namespace


BRANCH_STATE_ROOT Property

Borland StarTeam SDK for .NET

ItemBehavior.BRANCH_STATE_ROOT Property

public static Int32 BRANCH_STATE_ROOT {get;}

See Also

ItemBehavior Class | Borland.StarTeam Namespace


BranchOnChange Property

Borland StarTeam SDK for .NET

ItemBehavior.BranchOnChange Property

[read/write] true if this ItemBehavior is set to branch on change; false otherwise.

public virtual Boolean BranchOnChange {get; set;}

Property Value

true if this ItemBehavior is set to branch on change; false otherwise.

See Also

ItemBehavior Class | Borland.StarTeam Namespace


BranchState Property

Borland StarTeam SDK for .NET

ItemBehavior.BranchState Property

[read] The branch state.

public virtual Int32 BranchState {get;}

Property Value

The branch state.

See Also

ItemBehavior Class | Borland.StarTeam Namespace


Config Property

Borland StarTeam SDK for .NET

ItemBehavior.Config Property

[read/write] This ItemBehavior's current configuration.

public virtual ViewConfiguration Config {get; set;}

Property Value

This ItemBehavior's current configuration.

See Also

ItemBehavior Class | Borland.StarTeam Namespace


FixConfig Property

Borland StarTeam SDK for .NET

ItemBehavior.FixConfig Property

[read] true if the item (or its parent item) has a fixed configuration.

public virtual Boolean FixConfig {get;}

Property Value

true if the item (or its parent item) has a fixed configuration.

See Also

ItemBehavior Class | Borland.StarTeam Namespace


ItemBehavior Methods

The methods of the ItemBehavior class are listed below. For a complete list of ItemBehavior class members, see the ItemBehavior Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ItemBehavior.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ItemBehavior.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ItemBehavior.
GetType (inherited from Object) | Gets the Type of the current instance.
SetFloatingConfig | Changes this ItemBehavior to use a floating configuration. Note that in order to apply the resulting behavior to an item, you must call Item.setBehavior().
ToString | Delegate ToString() to com.starbase.starteam.ItemBehavior.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemBehavior Class | Borland.StarTeam Namespace


ItemBehavior.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ItemBehavior

Implements

IWrapper.Unwrap

See Also

ItemBehavior Class | Borland.StarTeam Namespace


ItemBehavior.Equals Method

Delegate Equals() to com.starbase.starteam.ItemBehavior.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ItemBehavior.Equals(obj).

See Also

ItemBehavior Class | Borland.StarTeam Namespace


ItemBehavior.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ItemBehavior.

public override int GetHashCode();

Return Value

com.starbase.starteam.ItemBehavior.GetHashCode().

See Also

ItemBehavior Class | Borland.StarTeam Namespace


ItemBehavior.SetFloatingConfig Method

Changes this ItemBehavior to use a floating configuration. Note that in order to apply the resulting behavior to an item, you must call Item.setBehavior().

public virtual void SetFloatingConfig();

See Also

ItemBehavior Class | Borland.StarTeam Namespace | setConfig | setBehavior


ItemBehavior.ToString Method

Delegate ToString() to com.starbase.starteam.ItemBehavior.

public override string ToString();

Return Value

com.starbase.starteam.ItemBehavior.ToString()

See Also

ItemBehavior Class | Borland.StarTeam Namespace


ItemBehavior.Wrap Method

Dynamically wraps com.starbase.starteam.ItemBehavior.

public static ItemBehavior Wrap(
ItemBehavior impl
);

Parameters

impl
com.starbase.starteam.ItemBehavior to be wrapped.

Return Value

ItemBehavior

See Also

ItemBehavior Class | Borland.StarTeam Namespace


ItemBehavior Type Conversions

The type conversions of the ItemBehavior class are listed below. For a complete list of ItemBehavior class members, see the ItemBehavior Members topic.

Public Static Type Conversions

Implicit ItemBehavior to ItemBehavior Conversion Implicitly convert ItemBehavior to com.starbase.starteam.ItemBehavior.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemBehavior Class | ItemBehavior Members | Borland.StarTeam Namespace


ItemBehavior Implicit ItemBehavior to ItemBehavior Conversion

Implicitly convert ItemBehavior to com.starbase.starteam.ItemBehavior.

public static implicit operator ItemBehavior(
ItemBehavior arg
);

Parameters

arg
ItemBehavior to convert.

Return Value

com.starbase.starteam.ItemBehavior

See Also

ItemBehavior Class | Borland.StarTeam Namespace


ItemCollection Class

For a list of all members of this type, see ItemCollection Members.

System.Object
ArrayAdapter
ItemCollection

public class ItemCollection : ArrayAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemCollection Members | Borland.StarTeam Namespace


ItemCollection Members

ItemCollection overview

Public Static Methods

Wrap

Public Static Type Conversions

Implicit ItemCollection to Item[] Conversion
Implicit ItemCollection to Item[] Conversion

Public Instance Constructors

ItemCollection Overloaded. Initializes a new instance of the ItemCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item |
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add |
Append | Overloaded.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf |
Insert |
PopulateInBackground |
PopulateNow |
Remove |
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse |
Sort |
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection Constructor

Initializes a new instance of the ItemCollection class.

Overload List

Initializes a new instance of the ItemCollection class.

public ItemCollection();

public ItemCollection(Item[]);

public ItemCollection(ItemCollection);

public ItemCollection(Item[]);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection Constructor ()

Initializes a new instance of the ItemCollection class.

public ItemCollection();

See Also

ItemCollection Class | Borland.StarTeam Namespace | ItemCollection Constructor Overload List


ItemCollection Constructor (Item[])

public ItemCollection(
Item[] impl
);

See Also

ItemCollection Class | Borland.StarTeam Namespace | ItemCollection Constructor Overload List


ItemCollection Constructor (ItemCollection)

public ItemCollection(
ItemCollection collection
);

See Also

ItemCollection Class | Borland.StarTeam Namespace | ItemCollection Constructor Overload List


ItemCollection Constructor (Item[])

public ItemCollection(
Item[] array
);

See Also

ItemCollection Class | Borland.StarTeam Namespace | ItemCollection Constructor Overload List


ItemCollection Properties

The properties of the ItemCollection class are listed below. For a complete list of ItemCollection class members, see the ItemCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item |
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.

See Also

ItemCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

ItemCollection.Item Property

public Item this[
Int32 index
] {get; set;}

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection Methods

The methods of the ItemCollection class are listed below. For a complete list of ItemCollection class members, see the ItemCollection Members topic.

Public Static Methods

Wrap

Public Instance Methods

Add |
Append | Overloaded.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf |
Insert |
PopulateInBackground |
PopulateNow |
Remove |
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse |
Sort |
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection.Add Method

public int Add(
Item value
);

See Also

ItemCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

ItemCollection.Append Method

Overload List

public ItemCollection Append(Item[]);

public ItemCollection Append(ItemCollection);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection.Append Method (Item[])

public ItemCollection Append(
Item[] array
);

See Also

ItemCollection Class | Borland.StarTeam Namespace | ItemCollection.Append Overload List


ItemCollection.Append Method (ItemCollection)

public ItemCollection Append(
ItemCollection collection
);

See Also

ItemCollection Class | Borland.StarTeam Namespace | ItemCollection.Append Overload List


ItemCollection.Contains Method

public bool Contains(
Item value
);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection.CopyTo Method

public void CopyTo(
Item[] array,
Int32 index
);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection.IndexOf Method

public int IndexOf(
Item value
);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection.Insert Method

public void Insert(
Int32 index,
Item value
);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection.PopulateInBackground Method

public virtual void PopulateInBackground(
String[] propertyNames
);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection.PopulateNow Method

public virtual void PopulateNow(
String[] propertyNames
);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection.Remove Method

public void Remove(
Item value
);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection.Reverse Method

new public ItemCollection Reverse();

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection.Sort Method

new public ItemCollection Sort(
IComparer comparer
);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection.Wrap Method

public static ItemCollection Wrap(
Item[] impl
);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemCollection Type Conversions

The type conversions of the ItemCollection class are listed below. For a complete list of ItemCollection class members, see the ItemCollection Members topic.

Public Static Type Conversions

Implicit ItemCollection to Item[] Conversion
Implicit ItemCollection to Item[] Conversion

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.

See Also

ItemCollection Class | ItemCollection Members | Borland.StarTeam Namespace


ItemCollection Implicit ItemCollection to Item[] Conversion

public static implicit operator Item[](
ItemCollection arg
);

See Also

ItemCollection Class | Borland.StarTeam Namespace


ItemEventArgs Class

For a list of all members of this type, see ItemEventArgs Members.

System.Object
EventArgs
ItemEventArgs

public class ItemEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemEventArgs Members | Borland.StarTeam Namespace


ItemEventArgs Members

ItemEventArgs overview

Public Static Type Conversions

Implicit ItemEventArgs to ItemEvent Conversion Implicitly convert ItemEventArgs to com.starbase.starteam.ItemEvent.

Public Instance Properties

NewItem | [read] The Item in its new state.
OldItem | [read] The Item in its old state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ItemEventArgs Class | Borland.StarTeam Namespace


ItemEventArgs Properties

The properties of the ItemEventArgs class are listed below. For a complete list of ItemEventArgs class members, see the ItemEventArgs Members topic.

Public Instance Properties

NewItem | [read] The Item in its new state.
OldItem | [read] The Item in its old state.

See Also

ItemEventArgs Class | Borland.StarTeam Namespace


NewItem Property

Borland StarTeam SDK for .NET

ItemEventArgs.NewItem Property

[read] The Item in its new state.

public virtual Item NewItem {get;}

Property Value

The Item in its new state.

See Also

ItemEventArgs Class | Borland.StarTeam Namespace


OldItem Property

Borland StarTeam SDK for .NET

ItemEventArgs.OldItem Property

[read] The Item in its old state.

public virtual Item OldItem {get;}

Property Value

The Item in its old state.

See Also

ItemEventArgs Class | Borland.StarTeam Namespace


ItemEventArgs Methods

The methods of the ItemEventArgs class are listed below. For a complete list of ItemEventArgs class members, see the ItemEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ItemEventArgs Class | Borland.StarTeam Namespace


ItemEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ItemEventArgs Class | Borland.StarTeam Namespace


ItemEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ItemEventArgs Class | Borland.StarTeam Namespace


ItemEventArgs.ToString Method

public override string ToString();

See Also

ItemEventArgs Class | Borland.StarTeam Namespace


ItemEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

ItemEventArgs Class | Borland.StarTeam Namespace


ItemEventArgs Type Conversions

The type conversions of the ItemEventArgs class are listed below. For a complete list of ItemEventArgs class members, see the ItemEventArgs Members topic.

Public Static Type Conversions

Implicit ItemEventArgs to ItemEvent Conversion Implicitly convert ItemEventArgs to com.starbase.starteam.ItemEvent.

See Also

ItemEventArgs Class | ItemEventArgs Members | Borland.StarTeam Namespace


ItemEventArgs Implicit ItemEventArgs to ItemEvent Conversion

Implicitly convert ItemEventArgs to com.starbase.starteam.ItemEvent.

public static implicit operator ItemEvent(
ItemEventArgs arg
);

Parameters

arg
ItemEventArgs to convert.

Return Value

com.starbase.starteam.ItemEvent

See Also

ItemEventArgs Class | Borland.StarTeam Namespace


ItemEventSource Class

For a list of all members of this type, see ItemEventSource Members.

System.Object
ItemEventSource

public class ItemEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemEventSource Members | Borland.StarTeam Namespace


ItemEventSource Members

ItemEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ItemAdded
ItemChanged
ItemMoved
ItemRemoved
OnItemAdded
OnItemChanged
OnItemMoved
OnItemRemoved

See Also

ItemEventSource Class | Borland.StarTeam Namespace


ItemEventSource Properties

The properties of the ItemEventSource class are listed below. For a complete list of ItemEventSource class members, see the ItemEventSource Members topic.

Public Instance Properties

Parent

See Also

ItemEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

ItemEventSource.Parent Property

public Object Parent {get;}

See Also

ItemEventSource Class | Borland.StarTeam Namespace


ItemEventSource Events

The events of the ItemEventSource class are listed below. For a complete list of ItemEventSource class members, see the ItemEventSource Members topic.

Public Instance Events

ItemAdded
ItemChanged
ItemMoved
ItemRemoved
OnItemAdded
OnItemChanged
OnItemMoved
OnItemRemoved

See Also

ItemEventSource Class | Borland.StarTeam Namespace


ItemEventSource.ItemAdded Event

public event ItemEventSource.Handler ItemAdded;

See Also

ItemEventSource Class | Borland.StarTeam Namespace


ItemEventSource.ItemChanged Event

public event ItemEventSource.Handler ItemChanged;

See Also

ItemEventSource Class | Borland.StarTeam Namespace


ItemEventSource.ItemMoved Event

public event ItemEventSource.Handler ItemMoved;

See Also

ItemEventSource Class | Borland.StarTeam Namespace


ItemEventSource.ItemRemoved Event

public event ItemEventSource.Handler ItemRemoved;

See Also

ItemEventSource Class | Borland.StarTeam Namespace


ItemEventSource.OnItemAdded Event

public event ItemEventSource.Handler OnItemAdded;

See Also

ItemEventSource Class | Borland.StarTeam Namespace


ItemEventSource.OnItemChanged Event

public event ItemEventSource.Handler OnItemChanged;

See Also

ItemEventSource Class | Borland.StarTeam Namespace


ItemEventSource.OnItemMoved Event

public event ItemEventSource.Handler OnItemMoved;

See Also

ItemEventSource Class | Borland.StarTeam Namespace


ItemEventSource.OnItemRemoved Event

public event ItemEventSource.Handler OnItemRemoved;

See Also

ItemEventSource Class | Borland.StarTeam Namespace


ItemEventSource.Handler Delegate

public delegate void ItemEventSource.Handler(
ItemEventSource source,
ItemEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


ItemIDEventArgs Class

For a list of all members of this type, see ItemIDEventArgs Members.

System.Object
EventArgs
ItemIDEventArgs

public class ItemIDEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemIDEventArgs Members | Borland.StarTeam Namespace


ItemIDEventArgs Members

ItemIDEventArgs overview

Public Static Type Conversions

Implicit ItemIDEventArgs to ItemIDEvent Conversion Implicitly convert ItemIDEventArgs to com.starbase.starteam.ItemIDEvent.

Public Instance Properties

ItemID [read] The ID of the Item that was added, changed or removed.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ItemIDEventArgs Class | Borland.StarTeam Namespace


ItemIDEventArgs Properties

The properties of the ItemIDEventArgs class are listed below. For a complete list of ItemIDEventArgs class members, see the ItemIDEventArgs Members topic.

Public Instance Properties

ItemID [read] The ID of the Item that was added, changed or removed.

See Also

ItemIDEventArgs Class | Borland.StarTeam Namespace


ItemID Property

Borland StarTeam SDK for .NET

ItemIDEventArgs.ItemID Property

[read] The ID of the Item that was added, changed or removed.

public virtual Int32 ItemID {get;}

Property Value

The ID of the Item that was added, changed or removed.

See Also

ItemIDEventArgs Class | Borland.StarTeam Namespace


ItemIDEventArgs Methods

The methods of the ItemIDEventArgs class are listed below. For a complete list of ItemIDEventArgs class members, see the ItemIDEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ItemIDEventArgs Class | Borland.StarTeam Namespace


ItemIDEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ItemIDEventArgs Class | Borland.StarTeam Namespace


ItemIDEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ItemIDEventArgs Class | Borland.StarTeam Namespace


ItemIDEventArgs.ToString Method

public override string ToString();

See Also

ItemIDEventArgs Class | Borland.StarTeam Namespace


ItemIDEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

ItemIDEventArgs Class | Borland.StarTeam Namespace


ItemIDEventArgs Type Conversions

The type conversions of the ItemIDEventArgs class are listed below. For a complete list of ItemIDEventArgs class members, see the ItemIDEventArgs Members topic.

Public Static Type Conversions

Implicit ItemIDEventArgs to ItemIDEvent Conversion Implicitly convert ItemIDEventArgs to com.starbase.starteam.ItemIDEvent.

See Also

ItemIDEventArgs Class | ItemIDEventArgs Members | Borland.StarTeam Namespace


ItemIDEventArgs Implicit ItemIDEventArgs to ItemIDEvent Conversion

Implicitly convert ItemIDEventArgs to com.starbase.starteam.ItemIDEvent.

public static implicit operator ItemIDEvent(
ItemIDEventArgs arg
);

Parameters

arg
ItemIDEventArgs to convert.

Return Value

com.starbase.starteam.ItemIDEvent

See Also

ItemIDEventArgs Class | Borland.StarTeam Namespace


ItemIDEventSource Class

For a list of all members of this type, see ItemIDEventSource Members.

System.Object
ItemIDEventSource

public class ItemIDEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemIDEventSource Members | Borland.StarTeam Namespace


ItemIDEventSource Members

ItemIDEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ItemAdded
ItemChanged
ItemRemoved
OnItemAdded
OnItemChanged
OnItemRemoved

See Also

ItemIDEventSource Class | Borland.StarTeam Namespace


ItemIDEventSource Properties

The properties of the ItemIDEventSource class are listed below. For a complete list of ItemIDEventSource class members, see the ItemIDEventSource Members topic.

Public Instance Properties

Parent

See Also

ItemIDEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

ItemIDEventSource.Parent Property

public Object Parent {get;}

See Also

ItemIDEventSource Class | Borland.StarTeam Namespace


ItemIDEventSource Events

The events of the ItemIDEventSource class are listed below. For a complete list of ItemIDEventSource class members, see the ItemIDEventSource Members topic.

Public Instance Events

ItemAdded
ItemChanged
ItemRemoved
OnItemAdded
OnItemChanged
OnItemRemoved

See Also

ItemIDEventSource Class | Borland.StarTeam Namespace


ItemIDEventSource.ItemAdded Event

public event ItemIDEventSource.Handler ItemAdded;

See Also

ItemIDEventSource Class | Borland.StarTeam Namespace


ItemIDEventSource.ItemChanged Event

public event ItemIDEventSource.Handler ItemChanged;

See Also

ItemIDEventSource Class | Borland.StarTeam Namespace


ItemIDEventSource.ItemRemoved Event

public event ItemIDEventSource.Handler ItemRemoved;

See Also

ItemIDEventSource Class | Borland.StarTeam Namespace


ItemIDEventSource.OnItemAdded Event

public event ItemIDEventSource.Handler OnItemAdded;

See Also

ItemIDEventSource Class | Borland.StarTeam Namespace


ItemIDEventSource.OnItemChanged Event

public event ItemIDEventSource.Handler OnItemChanged;

See Also

ItemIDEventSource Class | Borland.StarTeam Namespace


ItemIDEventSource.OnItemRemoved Event

public event ItemIDEventSource.Handler OnItemRemoved;

See Also

ItemIDEventSource Class | Borland.StarTeam Namespace


ItemIDEventSource.Handler Delegate

public delegate void ItemIDEventSource.Handler(
ItemIDEventSource source,
ItemIDEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


ItemListAdapter Class

For a list of all members of this type, see ItemListAdapter Members.

System.Object
ItemListAdapter

public class ItemListAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemListAdapter Members | Borland.StarTeam Namespace


ItemListAdapter Members

ItemListAdapter overview

Public Static Type Conversions

Implicit ItemListAdapter to ItemCollection Conversion
Implicit ItemListAdapter to ItemList Conversion

Public Instance Constructors

ItemListAdapter Overloaded. Initializes a new instance of the ItemListAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ItemListAdapter Class | Borland.StarTeam Namespace


ItemListAdapter Constructor

Overload List

public ItemListAdapter(ItemCollection);

public ItemListAdapter(ItemList);

See Also

ItemListAdapter Class | Borland.StarTeam Namespace


ItemListAdapter Constructor (ItemList)

public ItemListAdapter(
ItemList impl
);

See Also

ItemListAdapter Class | Borland.StarTeam Namespace | ItemListAdapter Constructor Overload List


ItemListAdapter Constructor (ItemCollection)

public ItemListAdapter(
ItemCollection impl
);

See Also

ItemListAdapter Class | Borland.StarTeam Namespace | ItemListAdapter Constructor Overload List


ItemListAdapter Type Conversions

The type conversions of the ItemListAdapter class are listed below. For a complete list of ItemListAdapter class members, see the ItemListAdapter Members topic.

Public Static Type Conversions

Implicit ItemListAdapter to ItemCollection Conversion
Implicit ItemListAdapter to ItemList Conversion

See Also

ItemListAdapter Class | ItemListAdapter Members | Borland.StarTeam Namespace


ItemListAdapter Implicit ItemListAdapter to ItemCollection Conversion

public static implicit operator ItemCollection(
ItemListAdapter arg
);

See Also

ItemListAdapter Class | Borland.StarTeam Namespace


ItemListAdapter Implicit ItemListAdapter to ItemList Conversion

public static implicit operator ItemList(
ItemListAdapter arg
);

See Also

ItemListAdapter Class | Borland.StarTeam Namespace


ItemListEventArgs Class

For a list of all members of this type, see ItemListEventArgs Members.

System.Object
EventArgs
ItemListEventArgs

public class ItemListEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemListEventArgs Members | Borland.StarTeam Namespace


ItemListEventArgs Members

ItemListEventArgs overview

Public Static Type Conversions

Implicit ItemListEventArgs to ItemListEvent Conversion Implicitly convert ItemListEventArgs to com.starbase.starteam.ItemListEvent.

Public Instance Properties

Folder | [read] The Folder whose Item list has changed.
Type | [read] The Folder whose Item list has changed.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ItemListEventArgs Class | Borland.StarTeam Namespace


ItemListEventArgs Properties

The properties of the ItemListEventArgs class are listed below. For a complete list of ItemListEventArgs class members, see the ItemListEventArgs Members topic.

Public Instance Properties

Folder | [read] The Folder whose Item list has changed.
Type | [read] The Folder whose Item list has changed.

See Also

ItemListEventArgs Class | Borland.StarTeam Namespace


Folder Property

Borland StarTeam SDK for .NET

ItemListEventArgs.Folder Property

[read] The Folder whose Item list has changed.

public virtual Folder Folder {get;}

Property Value

The Folder whose Item list has changed.

See Also

ItemListEventArgs Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

ItemListEventArgs.Type Property

[read] The Folder whose Item list has changed.

public virtual Type Type {get;}

Property Value

The Folder whose Item list has changed.

See Also

ItemListEventArgs Class | Borland.StarTeam Namespace


ItemListEventArgs Methods

The methods of the ItemListEventArgs class are listed below. For a complete list of ItemListEventArgs class members, see the ItemListEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ItemListEventArgs Class | Borland.StarTeam Namespace


ItemListEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ItemListEventArgs Class | Borland.StarTeam Namespace


ItemListEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ItemListEventArgs Class | Borland.StarTeam Namespace


ItemListEventArgs.ToString Method

public override string ToString();

See Also

ItemListEventArgs Class | Borland.StarTeam Namespace


ItemListEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

ItemListEventArgs Class | Borland.StarTeam Namespace


ItemListEventArgs Type Conversions

The type conversions of the ItemListEventArgs class are listed below. For a complete list of ItemListEventArgs class members, see the ItemListEventArgs Members topic.

Public Static Type Conversions

Implicit ItemListEventArgs to ItemListEvent Conversion Implicitly convert ItemListEventArgs to com.starbase.starteam.ItemListEvent.

See Also

ItemListEventArgs Class | ItemListEventArgs Members | Borland.StarTeam Namespace


ItemListEventArgs Implicit ItemListEventArgs to ItemListEvent Conversion

Implicitly convert ItemListEventArgs to com.starbase.starteam.ItemListEvent.

public static implicit operator ItemListEvent(
ItemListEventArgs arg
);

Parameters

arg
ItemListEventArgs to convert.

Return Value

com.starbase.starteam.ItemListEvent

See Also

ItemListEventArgs Class | Borland.StarTeam Namespace


ItemListEventSource Class

For a list of all members of this type, see ItemListEventSource Members.

System.Object
ItemListEventSource

public class ItemListEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemListEventSource Members | Borland.StarTeam Namespace


ItemListEventSource Members

ItemListEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ItemsChanged
OnItemsChanged

See Also

ItemListEventSource Class | Borland.StarTeam Namespace


ItemListEventSource Properties

The properties of the ItemListEventSource class are listed below. For a complete list of ItemListEventSource class members, see the ItemListEventSource Members topic.

Public Instance Properties

Parent

See Also

ItemListEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

ItemListEventSource.Parent Property

public Object Parent {get;}

See Also

ItemListEventSource Class | Borland.StarTeam Namespace


ItemListEventSource Events

The events of the ItemListEventSource class are listed below. For a complete list of ItemListEventSource class members, see the ItemListEventSource Members topic.

Public Instance Events

ItemsChanged
OnItemsChanged

See Also

ItemListEventSource Class | Borland.StarTeam Namespace


ItemListEventSource.ItemsChanged Event

public event ItemListEventSource.Handler ItemsChanged;

See Also

ItemListEventSource Class | Borland.StarTeam Namespace


ItemListEventSource.OnItemsChanged Event

public event ItemListEventSource.Handler OnItemsChanged;

See Also

ItemListEventSource Class | Borland.StarTeam Namespace


ItemListEventSource.Handler Delegate

public delegate void ItemListEventSource.Handler(
ItemListEventSource source,
ItemListEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


ItemListManager Class

Generates and manages a list of Items. All Items in the item list have a given type. Items are generated from a list of folders determined by a FolderListManager. The item list can be filtered, sorted, refreshed, queried, and so on. Items are retrieved via getItems() or getItemsArray(), which are optimized to do as little work as possible. For example, if only the sort order has changed since the last time the item list was retrieved, then the existing items in the list are resorted only.

For a list of all members of this type, see ItemListManager Members.

System.Object
ItemListManager

public class ItemListManager : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemListManager Members | Borland.StarTeam Namespace


ItemListManager Members

ItemListManager overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ItemListManager.

Public Static Type Conversions

Implicit ItemListManager to ItemListManager Conversion Implicitly convert ItemListManager to com.starbase.starteam.ItemListManager.

Public Instance Constructors

ItemListManager Overloaded. Initializes a new instance of the ItemListManager class.

Public Instance Properties

AllCachedProperties | [read] The list of properties that will be pre-fetched and cached for members of this item list.
CachedPropertiesForFilter | [read] The list of properties that will be pre-fetched and cached for members of this item list based on Filter criteria.
ExtraCachedProperties | [read/write] The list of "extra" properties that will be pre-fetched and cached for members of this item list.
Filter | [read/write] The filter to be applied to the item list.
FolderListManager | [read] The FolderListManager that determines which folders will be used to generate items in the item list.
FullDisplay | [read] the current display state of the list. The '\t' character indicates indents. The '|' character separates column values. Useful for debugging.
IsGrouped | [read] true if this ItemListManager has grouping criteria applied.
IsRefreshRequired | [read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.
ItemGroups | [read] an array of GroupNodes that describes the group membership of all Items managed by the ItemListManager. May return an empty array.
Items | [read] The list of items in the item list, updated, if necessary, to reflect any changes that have been made (in the folder list, filter, sort order, and so on) since the last time the item list was retrieved.
Type | [read] The type of item included in the item list.
UserVisibleFoldersOnly | [read/write] true if only Items in user-visible Folders are included, otherwise false.
VisibleLines | [read] the number of visible lines in the list, given the current collapsed/expanded state of its nodes.

Public Instance Methods

Close | Close this ItemListManager, release all its resources, and sever its ties to its parent FolderListManager t will automatically be reopened will automatically be re-opened when needed.
Discard | Discards all relevant cached data. It will be re-fetched from the server the next time the item list is retrieved (even when MPX is enabled).
Equals | Delegate Equals() to com.starbase.starteam.ItemListManager.
FindItem | Searches for a given item in the item list.
GetGroupNodeAtLine | Returns the GroupNode at line, given the list's current collapsed/expanded state, or null if that line doesn't contain a GroupNode.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ItemListManager.
GetItemAtLine | Returns the Item at line, given the list's current collapsed/expanded state, or null if that line doesn't contain an Item.
GetItemID | Returns the ItemID for an item; if we're managing not-in-view files, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view file object until it's been added to the repository.
GetItemsForFolder | Returns the items in a Folder and optionally all its descendants.
GetType (inherited from Object) | Gets the Type of the current instance.
GroupItems | Determines whether this ItemListManager should group items when returning them? Items can only be grouped if sortItems is also set to True Items will be grouped if the ItemListManager is attached to a Filter that specifies Group Sorting Information An ItemListManager is grouped by default
IsGroupNodeAtLine | Returns true if the object at line is a GroupNode or false if it's an Item, given the list's current collapsed/expanded state.
NewItemEventSource |
NewItemIDEventSource |
NewItemListEventSource |
NewItemUpdateEventSource |
NewNotificationEventSource |
Refresh | Updates the list of Items to reflect recent changes made on the server. Existing Item objects are modified in place whenever possible. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
SelectByLabel | Gets the subset of items in the item list to which the given label has been applied.
SelectByQuery | Gets the subset of items in the item list that match the given query.
SortItems | Determines whether this ItemListManager should sort items when returning them? Items will be sorted if the ItemListManager is attached to a Filter that specifies Group Sorting Information An ItemListManager is sorted by default
ToString | Delegate ToString() to com.starbase.starteam.ItemListManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager Constructor

Construct ItemListManager from com.starbase.starteam.ItemListManager.

Overload List

Constructs a new item list.

public ItemListManager(Type,FolderListManager);

Construct ItemListManager from com.starbase.starteam.ItemListManager.

public ItemListManager(ItemListManager);

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager Constructor (ItemListManager)

Construct ItemListManager from com.starbase.starteam.ItemListManager.

public ItemListManager(
ItemListManager impl
);

Parameters

impl
The com.starbase.starteam.ItemListManager to be wrapped.

See Also

ItemListManager Class | Borland.StarTeam Namespace | ItemListManager Constructor Overload List


ItemListManager Constructor (Type, FolderListManager)

Constructs a new item list.

public ItemListManager(
Type type,
FolderListManager folders
);

Parameters

type
The type of item to be included in the item list.
folders
The list of folders to be included in the item list.

See Also

ItemListManager Class | Borland.StarTeam Namespace | ItemListManager Constructor Overload List


ItemListManager Properties

The properties of the ItemListManager class are listed below. For a complete list of ItemListManager class members, see the ItemListManager Members topic.

Public Instance Properties

AllCachedProperties | [read] The list of properties that will be pre-fetched and cached for members of this item list.
CachedPropertiesForFilter | [read] The list of properties that will be pre-fetched and cached for members of this item list based on Filter criteria.
ExtraCachedProperties | [read/write] The list of "extra" properties that will be pre-fetched and cached for members of this item list.
Filter | [read/write] The filter to be applied to the item list.
FolderListManager | [read] The FolderListManager that determines which folders will be used to generate items in the item list.
FullDisplay | [read] the current display state of the list. The '\t' character indicates indents. The '|' character separates column values. Useful for debugging.
IsGrouped | [read] true if this ItemListManager has grouping criteria applied.
IsRefreshRequired | [read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.
ItemGroups | [read] an array of GroupNodes that describes the group membership of all Items managed by the ItemListManager. May return an empty array.
Items | [read] The list of items in the item list, updated, if necessary, to reflect any changes that have been made (in the folder list, filter, sort order, and so on) since the last time the item list was retrieved.
Type | [read] The type of item included in the item list.
UserVisibleFoldersOnly | [read/write] true if only Items in user-visible Folders are included, otherwise false.
VisibleLines | [read] the number of visible lines in the list, given the current collapsed/expanded state of its nodes.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemListManager Class | Borland.StarTeam Namespace


AllCachedProperties Property

Borland StarTeam SDK for .NET

ItemListManager.AllCachedProperties Property

[read] The list of properties that will be pre-fetched and cached for members of this item list.

public virtual PropertyCollection AllCachedProperties {get;}

Property Value

The list of properties that will be pre-fetched and cached for members of this item list.

See Also

ItemListManager Class | Borland.StarTeam Namespace


CachedPropertiesForFilter Property

Borland StarTeam SDK for .NET

ItemListManager.CachedPropertiesForFilter Property

[read] The list of properties that will be pre-fetched and cached for members of this item list based on Filter criteria.

public virtual PropertyCollection CachedPropertiesForFilter {get;}

Property Value

The list of properties that will be pre-fetched and cached for members of this item list based on Filter criteria.

See Also

ItemListManager Class | Borland.StarTeam Namespace


ExtraCachedProperties Property

Borland StarTeam SDK for .NET

ItemListManager.ExtraCachedProperties Property

[read/write] The list of "extra" properties that will be pre-fetched and cached for members of this item list.

public virtual PropertyCollection ExtraCachedProperties {get; set;}

Property Value

The list of "extra" properties that will be pre-fetched and cached for members of this item list.

See Also

ItemListManager Class | Borland.StarTeam Namespace


Filter Property

Borland StarTeam SDK for .NET

ItemListManager.Filter Property

[read/write] The filter to be applied to the item list.

public virtual Filter Filter {get; set;}

Property Value

The filter to be applied to the item list.

See Also

ItemListManager Class | Borland.StarTeam Namespace


FolderListManager Property

Borland StarTeam SDK for .NET

ItemListManager.FolderListManager Property

[read] The FolderListManager that determines which folders will be used to generate items in the item list.

public virtual FolderListManager FolderListManager {get;}

Property Value

The FolderListManager that determines which folders will be used to generate items in the item list.

See Also

ItemListManager Class | Borland.StarTeam Namespace


FullDisplay Property

Borland StarTeam SDK for .NET

ItemListManager.FullDisplay Property

[read] the current display state of the list. The '\t' character indicates indents. The '|' character separates column values. Useful for debugging.

public virtual String[] FullDisplay {get;}

Property Value

the current display state of the list. The '\t' character indicates indents. The '|' character separates column values. Useful for debugging.

See Also

ItemListManager Class | Borland.StarTeam Namespace


IsGrouped Property

Borland StarTeam SDK for .NET

ItemListManager.IsGrouped Property

[read] true if this ItemListManager has grouping criteria applied.

public virtual Boolean IsGrouped {get;}

Property Value

true if this ItemListManager has grouping criteria applied.

See Also

ItemListManager Class | Borland.StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

ItemListManager.IsRefreshRequired Property

[read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemGroups Property

Borland StarTeam SDK for .NET

ItemListManager.ItemGroups Property

[read] an array of GroupNodes that describes the group membership of all Items managed by the ItemListManager. May return an empty array.

public virtual GroupNodeCollection ItemGroups {get;}

Property Value

an array of GroupNodes that describes the group membership of all Items managed by the ItemListManager. May return an empty array.

See Also

ItemListManager Class | Borland.StarTeam Namespace


Items Property

Borland StarTeam SDK for .NET

ItemListManager.Items Property

[read] The list of items in the item list, updated, if necessary, to reflect any changes that have been made (in the folder list, filter, sort order, and so on) since the last time the item list was retrieved.

public virtual ItemCollection Items {get;}

Property Value

The list of items in the item list, updated, if necessary, to reflect any changes that have been made (in the folder list, filter, sort order, and so on) since the last time the item list was retrieved.

See Also

ItemListManager Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

ItemListManager.Type Property

[read] The type of item included in the item list.

public virtual Type Type {get;}

Property Value

The type of item included in the item list.

See Also

ItemListManager Class | Borland.StarTeam Namespace


UserVisibleFoldersOnly Property

Borland StarTeam SDK for .NET

ItemListManager.UserVisibleFoldersOnly Property

[read/write] true if only Items in user-visible Folders are included, otherwise false.

public virtual Boolean UserVisibleFoldersOnly {get; set;}

Property Value

true if only Items in user-visible Folders are included, otherwise false.

See Also

ItemListManager Class | Borland.StarTeam Namespace


VisibleLines Property

Borland StarTeam SDK for .NET

ItemListManager.VisibleLines Property

[read] the number of visible lines in the list, given the current collapsed/expanded state of its nodes.

public virtual Int32 VisibleLines {get;}

Property Value

the number of visible lines in the list, given the current collapsed/expanded state of its nodes.

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager Methods

The methods of the ItemListManager class are listed below. For a complete list of ItemListManager class members, see the ItemListManager Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ItemListManager.

Public Instance Methods

Close | Close this ItemListManager, release all its resources, and sever its ties to its parent FolderListManager t will automatically be reopened will automatically be re-opened when needed.
Discard | Discards all relevant cached data. It will be re-fetched from the server the next time the item list is retrieved (even when MPX is enabled).
Equals | Delegate Equals() to com.starbase.starteam.ItemListManager.
FindItem | Searches for a given item in the item list.
GetGroupNodeAtLine | Returns the GroupNode at line, given the list's current collapsed/expanded state, or null if that line doesn't contain a GroupNode.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ItemListManager.
GetItemAtLine | Returns the Item at line, given the list's current collapsed/expanded state, or null if that line doesn't contain an Item.
GetItemID | Returns the ItemID for an item; if we're managing not-in-view files, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view file object until it's been added to the repository.
GetItemsForFolder | Returns the items in a Folder and optionally all its descendants.
GetType (inherited from Object) | Gets the Type of the current instance.
GroupItems | Determines whether this ItemListManager should group items when returning them? Items can only be grouped if sortItems is also set to True Items will be grouped if the ItemListManager is attached to a Filter that specifies Group Sorting Information An ItemListManager is grouped by default
IsGroupNodeAtLine | Returns true if the object at line is a GroupNode or false if it's an Item, given the list's current collapsed/expanded state.
NewItemEventSource |
NewItemIDEventSource |
NewItemListEventSource |
NewItemUpdateEventSource |
NewNotificationEventSource |
Refresh | Updates the list of Items to reflect recent changes made on the server. Existing Item objects are modified in place whenever possible. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
SelectByLabel | Gets the subset of items in the item list to which the given label has been applied.
SelectByQuery | Gets the subset of items in the item list that match the given query.
SortItems | Determines whether this ItemListManager should sort items when returning them? Items will be sorted if the ItemListManager is attached to a Filter that specifies Group Sorting Information An ItemListManager is sorted by default
ToString | Delegate ToString() to com.starbase.starteam.ItemListManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ItemListManager

Implements

IWrapper.Unwrap

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.Close Method

Close this ItemListManager, release all its resources, and sever its ties to its parent FolderListManager t will automatically be reopened will automatically be re-opened when needed.

public virtual void Close();

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.Discard Method

Discards all relevant cached data. It will be re-fetched from the server the next time the item list is retrieved (even when MPX is enabled).

public virtual void Discard();

See Also

ItemListManager Class | Borland.StarTeam Namespace | refresh


ItemListManager.Equals Method

Delegate Equals() to com.starbase.starteam.ItemListManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ItemListManager.Equals(obj).

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.FindItem Method

Searches for a given item in the item list.

public virtual Item FindItem(
Int32 itemID
);

Parameters

itemID
The result of a call to getItemID(item).

Return Value

The item, or null if no item with the given ID was found in the item list.

See Also

ItemListManager Class | Borland.StarTeam Namespace | getItemID


ItemListManager.GetGroupNodeAtLine Method

Returns the GroupNode at line, given the list's current collapsed/expanded state, or null if that line doesn't contain a GroupNode.

public virtual GroupNode GetGroupNodeAtLine(
Int32 line
);

Parameters

line
the line to query, given the current collapsed/expanded state of the list.

Return Value

the GroupNode at line, given the list's current collapsed/expanded state, or null if that line doesn't contain a GroupNode.

See Also

ItemListManager Class | Borland.StarTeam Namespace | GroupNode


ItemListManager.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ItemListManager.

public override int GetHashCode();

Return Value

com.starbase.starteam.ItemListManager.GetHashCode().

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.GetItemAtLine Method

Returns the Item at line, given the list's current collapsed/expanded state, or null if that line doesn't contain an Item.

public virtual Item GetItemAtLine(
Int32 line
);

Parameters

line
the line to query, given the current collapsed/expanded state of the list.

Return Value

the Item at line, given the list's current collapsed/expanded state, or null if that line doesn't contain an Item.

See Also

ItemListManager Class | Borland.StarTeam Namespace | GroupNode | Item


ItemListManager.GetItemID Method

Returns the ItemID for an item; if we're managing not-in-view files, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view file object until it's been added to the repository.

public virtual int GetItemID(
Item item
);

Parameters

item
The item whose ItemID is returned.

Return Value

the ItemID for an item; if we're managing not-in-view files, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view file object until it's been added to the repository.

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.GetItemsForFolder Method

Returns the items in a Folder and optionally all its descendants.

public virtual ItemCollection GetItemsForFolder(
Folder folder,
Boolean bDescendants
);

Parameters

folder
the folder whose items are returned
bDescendants
true = plus all descendants of folder; false = folder only

Return Value

the items in a Folder and optionally all its descendants.

See Also

ItemListManager Class | Borland.StarTeam Namespace | Items | getItemsArrayForFolder


ItemListManager.GroupItems Method

Determines whether this ItemListManager should group items when returning them? Items can only be grouped if sortItems is also set to True Items will be grouped if the ItemListManager is attached to a Filter that specifies Group Sorting Information An ItemListManager is grouped by default

public virtual void GroupItems(
Boolean bGroup
);

Parameters

bGroup

See Also

ItemListManager Class | Borland.StarTeam Namespace | ItemListManager | getItems


ItemListManager.IsGroupNodeAtLine Method

Returns true if the object at line is a GroupNode or false if it's an Item, given the list's current collapsed/expanded state.

public virtual bool IsGroupNodeAtLine(
Int32 line
);

Parameters

line
the zero-based line to query, given the current collapsed/expanded state of the list.

Return Value

true if the object at line is a GroupNode or false if it's an Item, given the list's current collapsed/expanded state.

See Also

ItemListManager Class | Borland.StarTeam Namespace | GroupNode


ItemListManager.NewItemEventSource Method

public ItemEventSource NewItemEventSource();

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.NewItemIDEventSource Method

public ItemIDEventSource NewItemIDEventSource();

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.NewItemListEventSource Method

public ItemListEventSource NewItemListEventSource();

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.NewItemUpdateEventSource Method

public ItemUpdateEventSource NewItemUpdateEventSource();

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.NewNotificationEventSource Method

public NotificationEventSource NewNotificationEventSource();

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.Refresh Method

Updates the list of Items to reflect recent changes made on the server. Existing Item objects are modified in place whenever possible. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh();

See Also

ItemListManager Class | Borland.StarTeam Namespace | getItems | getItemsArray | isRefreshRequired | discard | isMPXEnabled


ItemListManager.SelectByLabel Method

Gets the subset of items in the item list to which the given label has been applied.

public virtual ItemCollection SelectByLabel(
Label label
);

Parameters

label
The label to be tested.

Return Value

The subset of items in the item list to which the given label has been applied.

See Also

ItemListManager Class | Borland.StarTeam Namespace | Items | getItems | getItemsArray | selectByQuery


ItemListManager.SelectByQuery Method

Gets the subset of items in the item list that match the given query.

public virtual ItemCollection SelectByQuery(
Query query
);

Parameters

query
The query to be matched.

Return Value

The subset of items in the item list that match the given query.

See Also

ItemListManager Class | Borland.StarTeam Namespace | Items | getItems | getItemsArray | selectByLabel


ItemListManager.SortItems Method

Determines whether this ItemListManager should sort items when returning them? Items will be sorted if the ItemListManager is attached to a Filter that specifies Group Sorting Information An ItemListManager is sorted by default

public virtual void SortItems(
Boolean bSort
);

Parameters

bSort
True to sort the items, False to return them in default order

See Also

ItemListManager Class | Borland.StarTeam Namespace | getItems


ItemListManager.ToString Method

Delegate ToString() to com.starbase.starteam.ItemListManager.

public override string ToString();

Return Value

com.starbase.starteam.ItemListManager.ToString()

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager.Wrap Method

Dynamically wraps com.starbase.starteam.ItemListManager.

public static ItemListManager Wrap(
ItemListManager impl
);

Parameters

impl
com.starbase.starteam.ItemListManager to be wrapped.

Return Value

ItemListManager

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemListManager Type Conversions

The type conversions of the ItemListManager class are listed below. For a complete list of ItemListManager class members, see the ItemListManager Members topic.

Public Static Type Conversions

Implicit ItemListManager to ItemListManager Conversion Implicitly convert ItemListManager to com.starbase.starteam.ItemListManager.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemListManager Class | ItemListManager Members | Borland.StarTeam Namespace


ItemListManager Implicit ItemListManager to ItemListManager Conversion

Implicitly convert ItemListManager to com.starbase.starteam.ItemListManager.

public static implicit operator ItemListManager(
ItemListManager arg
);

Parameters

arg
ItemListManager to convert.

Return Value

com.starbase.starteam.ItemListManager

See Also

ItemListManager Class | Borland.StarTeam Namespace


ItemNotFoundException Class

For a list of all members of this type, see ItemNotFoundException Members.

System.Object
Exception
ServerException
ItemNotFoundException

public class ItemNotFoundException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemNotFoundException Members | Borland.StarTeam Namespace


ItemNotFoundException Members

ItemNotFoundException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ItemNotFoundException.

Public Static Type Conversions

Implicit ItemNotFoundException to ItemNotFoundException Conversion Implicitly convert ItemNotFoundException to com.starbase.starteam.ItemNotFoundException.

Public Instance Constructors

ItemNotFoundException Constructor Construct ItemNotFoundException from com.starbase.starteam.ItemNotFoundException.

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

ItemNotFoundException Class | Borland.StarTeam Namespace


ItemNotFoundException Constructor

Construct ItemNotFoundException from com.starbase.starteam.ItemNotFoundException.

public ItemNotFoundException(
ItemNotFoundException impl
);

Parameters

impl
The com.starbase.starteam.ItemNotFoundException to be wrapped.

See Also

ItemNotFoundException Class | Borland.StarTeam Namespace


ItemNotFoundException Methods

The methods of the ItemNotFoundException class are listed below. For a complete list of ItemNotFoundException class members, see the ItemNotFoundException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ItemNotFoundException.

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

ItemNotFoundException Class | Borland.StarTeam Namespace


ItemNotFoundException.Wrap Method

Dynamically wraps com.starbase.starteam.ItemNotFoundException.

public static ItemNotFoundException Wrap(
ItemNotFoundException impl
);

Parameters

impl
com.starbase.starteam.ItemNotFoundException to be wrapped.

Return Value

ItemNotFoundException

See Also

ItemNotFoundException Class | Borland.StarTeam Namespace


ItemNotFoundException Type Conversions

The type conversions of the ItemNotFoundException class are listed below. For a complete list of ItemNotFoundException class members, see the ItemNotFoundException Members topic.

Public Static Type Conversions

Implicit ItemNotFoundException to ItemNotFoundException Conversion Implicitly convert ItemNotFoundException to com.starbase.starteam.ItemNotFoundException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

ItemNotFoundException Class | ItemNotFoundException Members | Borland.StarTeam Namespace


ItemNotFoundException Implicit ItemNotFoundException to ItemNotFoundException Conversion

Implicitly convert ItemNotFoundException to com.starbase.starteam.ItemNotFoundException.

public static implicit operator ItemNotFoundException(
ItemNotFoundException arg
);

Parameters

arg
ItemNotFoundException to convert.

Return Value

com.starbase.starteam.ItemNotFoundException

See Also

ItemNotFoundException Class | Borland.StarTeam Namespace


ItemReference Class

For a list of all members of this type, see ItemReference Members.

System.Object
TypedResource
SimpleTypedResource
ItemReference

public class ItemReference : SimpleTypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemReference Members | Borland.StarTeam Namespace


ItemReference Members

ItemReference overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ItemReference.

Public Static Type Conversions

Implicit ItemReference to ItemReference Conversion Implicitly convert ItemReference to com.starbase.starteam.ItemReference.

Public Instance Constructors

ItemReference Constructor Construct ItemReference from com.starbase.starteam.ItemReference.

Public Instance Properties

Children | [read] an array of ItemReferences that are direct children of this ItemReferences, or an empty array if there are none.
CreatedTime | [read] the CreatedTime for this item, only available on server versions 5.2 and higher.
CreatedUserID | [read] the CreatedUserID of this item, only available on server versions 5.2 and higher.
DeletedTime | [read] the DeletedTime of this item, only available on server versions 5.2 and higher.
DeletedUserID | [read] the DeletedUserID of this item, only available on server versions 5.2 and higher.
DerivedCount | [read] the number of shares directly derived from this item.
DotNotation | [read] the revision number in dot notation form.
EndModifiedTime | [read] the EndModifiedTime of this item, only available on server versions 5.2 and higher.
FolderItemID | [read] the Item ID of the referenced Item's parent Folder.
FolderPath | [read] the folder path of the referenced Item's parent Folder.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsDeleted | [read] true if the Item has been deleted.
IsRelated | [read] true if this item contains the revision queried by Item.getReferences() in its history.
IsViewDeleted | [read] true if the item's View has been deleted.
Item (inherited from TypedResource) |
ItemID | [read] the Item's ItemID.
ModifiedTime | [read] the ModifiedTime of this item, only available on server versions 5.2 and higher.
ModifiedUserID | [read] the ModifiedUserID of this item, only available on server versions 5.2 and higher.
ObjectID | [read] the item's object ID.
Parent | [read] the parent of this ItemReference, or null if this is the root of the share tree.
ProjectID | [read] the Project ID of the project that contains this reference.
ProjectName | [read] the containing Project's name.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
ViewID | [read] the ViewID for this item.
ViewPath | [read] the View path (in this format: "parent\child\grandchild...").

Public Instance Methods

AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ItemReference Class | Borland.StarTeam Namespace


ItemReference Constructor

Construct ItemReference from com.starbase.starteam.ItemReference.

public ItemReference(
ItemReference impl
);

Parameters

impl
The com.starbase.starteam.ItemReference to be wrapped.

See Also

ItemReference Class | Borland.StarTeam Namespace


ItemReference Properties

The properties of the ItemReference class are listed below. For a complete list of ItemReference class members, see the ItemReference Members topic.

Public Instance Properties

Children | [read] an array of ItemReferences that are direct children of this ItemReferences, or an empty array if there are none.
CreatedTime | [read] the CreatedTime for this item, only available on server versions 5.2 and higher.
CreatedUserID | [read] the CreatedUserID of this item, only available on server versions 5.2 and higher.
DeletedTime | [read] the DeletedTime of this item, only available on server versions 5.2 and higher.
DeletedUserID | [read] the DeletedUserID of this item, only available on server versions 5.2 and higher.
DerivedCount | [read] the number of shares directly derived from this item.
DotNotation | [read] the revision number in dot notation form.
EndModifiedTime | [read] the EndModifiedTime of this item, only available on server versions 5.2 and higher.
FolderItemID | [read] the Item ID of the referenced Item's parent Folder.
FolderPath | [read] the folder path of the referenced Item's parent Folder.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsDeleted | [read] true if the Item has been deleted.
IsRelated | [read] true if this item contains the revision queried by Item.getReferences() in its history.
IsViewDeleted | [read] true if the item's View has been deleted.
Item (inherited from TypedResource) |
ItemID | [read] the Item's ItemID.
ModifiedTime | [read] the ModifiedTime of this item, only available on server versions 5.2 and higher.
ModifiedUserID | [read] the ModifiedUserID of this item, only available on server versions 5.2 and higher.
ObjectID | [read] the item's object ID.
Parent | [read] the parent of this ItemReference, or null if this is the root of the share tree.
ProjectID | [read] the Project ID of the project that contains this reference.
ProjectName | [read] the containing Project's name.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
ViewID | [read] the ViewID for this item.
ViewPath | [read] the View path (in this format: "parent\child\grandchild...").

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ItemReference Class | Borland.StarTeam Namespace


Children Property

Borland StarTeam SDK for .NET

ItemReference.Children Property

[read] an array of ItemReferences that are direct children of this ItemReferences, or an empty array if there are none.

public virtual ItemReferenceCollection Children {get;}

Property Value

an array of ItemReferences that are direct children of this ItemReferences, or an empty array if there are none.

See Also

ItemReference Class | Borland.StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

ItemReference.CreatedTime Property

[read] the CreatedTime for this item, only available on server versions 5.2 and higher.

public virtual DateTime CreatedTime {get;}

Property Value

the CreatedTime for this item, only available on server versions 5.2 and higher.

See Also

ItemReference Class | Borland.StarTeam Namespace


CreatedUserID Property

Borland StarTeam SDK for .NET

ItemReference.CreatedUserID Property

[read] the CreatedUserID of this item, only available on server versions 5.2 and higher.

public virtual Int32 CreatedUserID {get;}

Property Value

the CreatedUserID of this item, only available on server versions 5.2 and higher.

See Also

ItemReference Class | Borland.StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

ItemReference.DeletedTime Property

[read] the DeletedTime of this item, only available on server versions 5.2 and higher.

public virtual DateTime DeletedTime {get;}

Property Value

the DeletedTime of this item, only available on server versions 5.2 and higher.

See Also

ItemReference Class | Borland.StarTeam Namespace


DeletedUserID Property

Borland StarTeam SDK for .NET

ItemReference.DeletedUserID Property

[read] the DeletedUserID of this item, only available on server versions 5.2 and higher.

public virtual Int32 DeletedUserID {get;}

Property Value

the DeletedUserID of this item, only available on server versions 5.2 and higher.

See Also

ItemReference Class | Borland.StarTeam Namespace


DerivedCount Property

Borland StarTeam SDK for .NET

ItemReference.DerivedCount Property

[read] the number of shares directly derived from this item.

public virtual Int32 DerivedCount {get;}

Property Value

the number of shares directly derived from this item.

See Also

ItemReference Class | Borland.StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

ItemReference.DotNotation Property

[read] the revision number in dot notation form.

public virtual String DotNotation {get;}

Property Value

the revision number in dot notation form.

See Also

ItemReference Class | Borland.StarTeam Namespace


EndModifiedTime Property

Borland StarTeam SDK for .NET

ItemReference.EndModifiedTime Property

[read] the EndModifiedTime of this item, only available on server versions 5.2 and higher.

public virtual DateTime EndModifiedTime {get;}

Property Value

the EndModifiedTime of this item, only available on server versions 5.2 and higher.

See Also

ItemReference Class | Borland.StarTeam Namespace


FolderItemID Property

Borland StarTeam SDK for .NET

ItemReference.FolderItemID Property

[read] the Item ID of the referenced Item's parent Folder.

public virtual Int32 FolderItemID {get;}

Property Value

the Item ID of the referenced Item's parent Folder.

See Also

ItemReference Class | Borland.StarTeam Namespace


FolderPath Property

Borland StarTeam SDK for .NET

ItemReference.FolderPath Property

[read] the folder path of the referenced Item's parent Folder.

public virtual String FolderPath {get;}

Property Value

the folder path of the referenced Item's parent Folder.

See Also

ItemReference Class | Borland.StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

ItemReference.IsDeleted Property

[read] true if the Item has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if the Item has been deleted.

See Also

ItemReference Class | Borland.StarTeam Namespace


IsRelated Property

Borland StarTeam SDK for .NET

ItemReference.IsRelated Property

[read] true if this item contains the revision queried by Item.getReferences() in its history.

public virtual Boolean IsRelated {get;}

Property Value

true if this item contains the revision queried by Item.getReferences() in its history.

See Also

ItemReference Class | Borland.StarTeam Namespace


IsViewDeleted Property

Borland StarTeam SDK for .NET

ItemReference.IsViewDeleted Property

[read] true if the item's View has been deleted.

public virtual Boolean IsViewDeleted {get;}

Property Value

true if the item's View has been deleted.

See Also

ItemReference Class | Borland.StarTeam Namespace


ItemID Property

Borland StarTeam SDK for .NET

ItemReference.ItemID Property

[read] the Item's ItemID.

public virtual Int32 ItemID {get;}

Property Value

the Item's ItemID.

See Also

ItemReference Class | Borland.StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

ItemReference.ModifiedTime Property

[read] the ModifiedTime of this item, only available on server versions 5.2 and higher.

public virtual DateTime ModifiedTime {get;}

Property Value

the ModifiedTime of this item, only available on server versions 5.2 and higher.

See Also

ItemReference Class | Borland.StarTeam Namespace


ModifiedUserID Property

Borland StarTeam SDK for .NET

ItemReference.ModifiedUserID Property

[read] the ModifiedUserID of this item, only available on server versions 5.2 and higher.

public virtual Int32 ModifiedUserID {get;}

Property Value

the ModifiedUserID of this item, only available on server versions 5.2 and higher.

See Also

ItemReference Class | Borland.StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

ItemReference.ObjectID Property

[read] the item's object ID.

public virtual Int32 ObjectID {get;}

Property Value

the item's object ID.

See Also

ItemReference Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

ItemReference.Parent Property

[read] the parent of this ItemReference, or null if this is the root of the share tree.

public virtual ItemReference Parent {get;}

Property Value

the parent of this ItemReference, or null if this is the root of the share tree.

See Also

ItemReference Class | Borland.StarTeam Namespace


ProjectID Property

Borland StarTeam SDK for .NET

ItemReference.ProjectID Property

[read] the Project ID of the project that contains this reference.

public virtual Int32 ProjectID {get;}

Property Value

the Project ID of the project that contains this reference.

See Also

ItemReference Class | Borland.StarTeam Namespace


ProjectName Property

Borland StarTeam SDK for .NET

ItemReference.ProjectName Property

[read] the containing Project's name.

public virtual String ProjectName {get;}

Property Value

the containing Project's name.

See Also

ItemReference Class | Borland.StarTeam Namespace


ViewID Property

Borland StarTeam SDK for .NET

ItemReference.ViewID Property

[read] the ViewID for this item.

public virtual Int32 ViewID {get;}

Property Value

the ViewID for this item.

See Also

ItemReference Class | Borland.StarTeam Namespace


ViewPath Property

Borland StarTeam SDK for .NET

ItemReference.ViewPath Property

[read] the View path (in this format: "parent\child\grandchild...").

public virtual String ViewPath {get;}

Property Value

the View path (in this format: "parent\child\grandchild...").

See Also

ItemReference Class | Borland.StarTeam Namespace


ItemReference Methods

The methods of the ItemReference class are listed below. For a complete list of ItemReference class members, see the ItemReference Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ItemReference.

Public Instance Methods

AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ItemReference Class | Borland.StarTeam Namespace


ItemReference.Wrap Method

Dynamically wraps com.starbase.starteam.ItemReference.

public static ItemReference Wrap(
ItemReference impl
);

Parameters

impl
com.starbase.starteam.ItemReference to be wrapped.

Return Value

ItemReference

See Also

ItemReference Class | Borland.StarTeam Namespace


ItemReference Type Conversions

The type conversions of the ItemReference class are listed below. For a complete list of ItemReference class members, see the ItemReference Members topic.

Public Static Type Conversions

Implicit ItemReference to ItemReference Conversion Implicitly convert ItemReference to com.starbase.starteam.ItemReference.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ItemReference Class | ItemReference Members | Borland.StarTeam Namespace


ItemReference Implicit ItemReference to ItemReference Conversion

Implicitly convert ItemReference to com.starbase.starteam.ItemReference.

public static implicit operator ItemReference(
ItemReference arg
);

Parameters

arg
ItemReference to convert.

Return Value

com.starbase.starteam.ItemReference

See Also

ItemReference Class | Borland.StarTeam Namespace


ItemReferenceCollection Class

A strongly-typed collection of ItemReferences.

For a list of all members of this type, see ItemReferenceCollection Members.

System.Object
ArrayAdapter
ItemReferenceCollection

public class ItemReferenceCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemReferenceCollection Members | Borland.StarTeam Namespace


ItemReferenceCollection Members

ItemReferenceCollection overview

Public Static Methods

Wrap Creates an ItemReferenceCollection to represent the given array of ItemReference (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit ItemReferenceCollection to ItemReference[] Conversion | Converts an ItemReferenceCollection to an array of ItemReferences.
Implicit ItemReferenceCollection to ItemReference[] Conversion | Converts an ItemReferenceCollection from the Borland.StarTeam namespace to an ItemReference[] in the com.starbase.starteam namespace.

Public Instance Constructors

ItemReferenceCollection Overloaded. Initializes a new instance of the ItemReferenceCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ItemReference at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an ItemReference to end of the collection.
Append | Overloaded. Appends the ItemReferences of the given ItemReferenceCollection to the end of this ItemReferenceCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ItemReference.
CopyTo | Copies all of the ItemReferences in the ItemReferenceCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the ItemReference with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ItemReference in the collection.
Insert | Inserts an ItemReference into the collection at the specified position.
Remove | Removes the first occurrence of a specific ItemReference from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ItemReferences in this ItemReferenceCollection.
Sort | Sorts the ItemReferences in this ItemReferenceCollection, using the given comparer.
SortByID | Sorts the ItemReferences in this ItemReferenceCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection Constructor

Initializes an instance of the ItemReferenceCollection class.

Overload List

Initializes an instance of the ItemReferenceCollection class.

public ItemReferenceCollection();

Initializes an instance of the an ItemReferenceCollection class, copying the given array.

public ItemReferenceCollection(ItemReference[]);

Initializes an instance of the an ItemReferenceCollection class, copying the given collection.

public ItemReferenceCollection(ItemReferenceCollection);

Initializes an instance of the an ItemReferenceCollection class, wrapping the given array of ItemReference (from the com.starbase.starteam namespace).

public ItemReferenceCollection(ItemReference[]);

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection Constructor ()

Initializes an instance of the ItemReferenceCollection class.

public ItemReferenceCollection();

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace | ItemReferenceCollection Constructor Overload List


ItemReferenceCollection Constructor (ItemReference[])

Initializes an instance of the an ItemReferenceCollection class, wrapping the given array of ItemReference (from the com.starbase.starteam namespace).

public ItemReferenceCollection(
ItemReference[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace | ItemReferenceCollection Constructor Overload List | Wrap


ItemReferenceCollection Constructor (ItemReferenceCollection)

Initializes an instance of the an ItemReferenceCollection class, copying the given collection.

public ItemReferenceCollection(
ItemReferenceCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member ItemReference objects of the original collection are shared, not copied.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace | ItemReferenceCollection Constructor Overload List


ItemReferenceCollection Constructor (ItemReference[])

Initializes an instance of the an ItemReferenceCollection class, copying the given array.

public ItemReferenceCollection(
ItemReference[] array
);

Parameters

array
The array to be copied.

Remarks

The member ItemReference objects of the original array are shared, not copied.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace | ItemReferenceCollection Constructor Overload List


ItemReferenceCollection Properties

The properties of the ItemReferenceCollection class are listed below. For a complete list of ItemReferenceCollection class members, see the ItemReferenceCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ItemReference at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

ItemReferenceCollection.Item Property

Gets or sets the ItemReference at the specified index.

public ItemReference this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the ItemReference to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection Methods

The methods of the ItemReferenceCollection class are listed below. For a complete list of ItemReferenceCollection class members, see the ItemReferenceCollection Members topic.

Public Static Methods

Wrap Creates an ItemReferenceCollection to represent the given array of ItemReference (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds an ItemReference to end of the collection.
Append | Overloaded. Appends the ItemReferences of the given ItemReferenceCollection to the end of this ItemReferenceCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ItemReference.
CopyTo | Copies all of the ItemReferences in the ItemReferenceCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the ItemReference with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ItemReference in the collection.
Insert | Inserts an ItemReference into the collection at the specified position.
Remove | Removes the first occurrence of a specific ItemReference from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ItemReferences in this ItemReferenceCollection.
Sort | Sorts the ItemReferences in this ItemReferenceCollection, using the given comparer.
SortByID | Sorts the ItemReferences in this ItemReferenceCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.Add Method

Adds an ItemReference to end of the collection.

public int Add(
ItemReference value
);

Parameters

value
The ItemReference to add to the collection.

Return Value

The position into which the new ItemReference was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

ItemReferenceCollection.Append Method

Appends the ItemReferences of the given array to the end of this ItemReferenceCollection.

Overload List

Appends the ItemReferences of the given array to the end of this ItemReferenceCollection.

public ItemReferenceCollection Append(ItemReference[]);

Appends the ItemReferences of the given ItemReferenceCollection to the end of this ItemReferenceCollection.

public ItemReferenceCollection Append(ItemReferenceCollection);

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.Append Method (ItemReference[])

Appends the ItemReferences of the given array to the end of this ItemReferenceCollection.

public ItemReferenceCollection Append(
ItemReference[] array
);

Parameters

array
The array whose ItemReferences are to be appended to this ItemReferenceCollection.

Return Value

This ItemReferenceCollection, modified to include the new ItemReferences.

Remarks

The ItemReferenceCollection is modified to include the new members. The individual ItemReference objects are shared, not copied.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace | ItemReferenceCollection.Append Overload List


ItemReferenceCollection.Append Method (ItemReferenceCollection)

Appends the ItemReferences of the given ItemReferenceCollection to the end of this ItemReferenceCollection.

public ItemReferenceCollection Append(
ItemReferenceCollection collection
);

Parameters

collection
The ItemReferenceCollection whose ItemReferences are to be appended to this ItemReferenceCollection.

Return Value

This ItemReferenceCollection, modified to include the new ItemReferences.

Remarks

The ItemReferenceCollection is modified to include the new members. The individual ItemReference objects are shared, not copied.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace | ItemReferenceCollection.Append Overload List


ItemReferenceCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.ItemReference[].

Implements

IWrapper.Unwrap

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.Contains Method

Determines whether or not the collection contains a specific ItemReference.

public bool Contains(
ItemReference value
);

Parameters

value
The ItemReference to locate in the collection.

Return Value

true if the ItemReference is found in the collection; otherwise, false.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.CopyTo Method

Copies all of the ItemReferences in the ItemReferenceCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
ItemReference[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the ItemReferences copied from the ItemReferenceCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of ItemReferences in the source ItemReferenceCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ItemReferenceCollection cannot be cast automatically to the type of the destination array.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.FindByID Method

Finds the ItemReference with the given ID.

public ItemReference FindByID(
Int32 id
);

Parameters

id
The ID of the ItemReference to be found.

Return Value

The ItemReference with the given ID, or null if there is no ItemReference with that ID in this ItemReferenceCollection.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.IndexOf Method

Determines the index of a specific ItemReference in the collection.

public int IndexOf(
ItemReference value
);

Parameters

value
The ItemReference to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.Insert Method

Inserts an ItemReference into the collection at the specified position.

public void Insert(
Int32 index,
ItemReference value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The ItemReference to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.Remove Method

Removes the first occurrence of a specific ItemReference from the collection.

public void Remove(
ItemReference value
);

Parameters

value
The ItemReference to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.Reverse Method

Reverses the order of the ItemReferences in this ItemReferenceCollection.

new public ItemReferenceCollection Reverse();

Return Value

This ItemReferenceCollection, modified such that the ItemReferences are reversed.

Remarks

The ItemReferenceCollection is modified in place.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.Sort Method

Sorts the ItemReferences in this ItemReferenceCollection, using the given comparer.

new public ItemReferenceCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two ItemReferences.

Return Value

This ItemReferenceCollection, modified such that the ItemReferences are sorted.

Remarks

The ItemReferenceCollection is modified in place.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.SortByID Method

Sorts the ItemReferences in this ItemReferenceCollection by ID.

public ItemReferenceCollection SortByID();

Return Value

This ItemReferenceCollection, modified such that the ItemReferences are sorted by ID.

Remarks

The ItemReferenceCollection is modified in place.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection.Wrap Method

Creates an ItemReferenceCollection to represent the given array of ItemReference (from the com.starbase.starteam namespace).

public static ItemReferenceCollection Wrap(
ItemReference[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ItemReferenceCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an ItemReference[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection Type Conversions

The type conversions of the ItemReferenceCollection class are listed below. For a complete list of ItemReferenceCollection class members, see the ItemReferenceCollection Members topic.

Public Static Type Conversions

Implicit ItemReferenceCollection to ItemReference[] Conversion | Converts an ItemReferenceCollection to an array of ItemReferences.
Implicit ItemReferenceCollection to ItemReference[] Conversion | Converts an ItemReferenceCollection from the Borland.StarTeam namespace to an ItemReference[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ItemReferenceCollection Class | ItemReferenceCollection Members | Borland.StarTeam Namespace


ItemReferenceCollection Implicit ItemReferenceCollection to ItemReference[] Conversion

Converts an ItemReferenceCollection to an array of ItemReferences.

public static implicit operator ItemReference[](
ItemReferenceCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new ItemReference wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one ItemReference wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemReferenceCollection Implicit ItemReferenceCollection to ItemReference[] Conversion

Converts an ItemReferenceCollection from the Borland.StarTeam namespace to an ItemReference[] in the com.starbase.starteam namespace.

public static implicit operator ItemReference[](
ItemReferenceCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ItemReferenceCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ItemReferenceCollection Class | Borland.StarTeam Namespace


ItemRevision Class

A ItemRevision represents a View member level revision of an item. Such revisions are created when one modifies the view level properties of a particular share of the item. These would be operations like: 1. changing the item branch behavior 2. changing the item configuration 3. branching the item 4. moving the item

For a list of all members of this type, see ItemRevision Members.

System.Object
TypedResource
SimpleTypedResource
ItemRevision

public class ItemRevision : SimpleTypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemRevision Members | Borland.StarTeam Namespace


ItemRevision Members

ItemRevision overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ItemRevision.

Public Static Type Conversions

Implicit ItemRevision to ItemRevision Conversion Implicitly convert ItemRevision to com.starbase.starteam.ItemRevision.

Public Instance Constructors

ItemRevision Constructor Construct ItemRevision from com.starbase.starteam.ItemRevision.

Public Instance Properties

BranchFlag | [read] the branch flag of this item revision.
BranchState | [read] the branch state of this item revision.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
Item (inherited from TypedResource) |
LocationItemID | [read] the location item ID of this item revision.
ObjectID | [read] the object ID for this item revision.
ObjectTime | [read] the time of this item revision.
ParentItemID | [read] the Item ID of the parent for this item revision.
ProjectID | [read] the Project ID of the project that contains this item revision.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Time | [read] the time of this item revision.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
UserID | [read] the created User ID for this item revision.
ViewID | [read] the View ID for this item revision.

Public Instance Methods

AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ItemRevision Class | Borland.StarTeam Namespace


ItemRevision Constructor

Construct ItemRevision from com.starbase.starteam.ItemRevision.

public ItemRevision(
ItemRevision impl
);

Parameters

impl
The com.starbase.starteam.ItemRevision to be wrapped.

See Also

ItemRevision Class | Borland.StarTeam Namespace


ItemRevision Properties

The properties of the ItemRevision class are listed below. For a complete list of ItemRevision class members, see the ItemRevision Members topic.

Public Instance Properties

BranchFlag | [read] the branch flag of this item revision.
BranchState | [read] the branch state of this item revision.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
Item (inherited from TypedResource) |
LocationItemID | [read] the location item ID of this item revision.
ObjectID | [read] the object ID for this item revision.
ObjectTime | [read] the time of this item revision.
ParentItemID | [read] the Item ID of the parent for this item revision.
ProjectID | [read] the Project ID of the project that contains this item revision.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Time | [read] the time of this item revision.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
UserID | [read] the created User ID for this item revision.
ViewID | [read] the View ID for this item revision.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ItemRevision Class | Borland.StarTeam Namespace


BranchFlag Property

Borland StarTeam SDK for .NET

ItemRevision.BranchFlag Property

[read] the branch flag of this item revision.

public virtual Int32 BranchFlag {get;}

Property Value

the branch flag of this item revision.

See Also

ItemRevision Class | Borland.StarTeam Namespace


BranchState Property

Borland StarTeam SDK for .NET

ItemRevision.BranchState Property

[read] the branch state of this item revision.

public virtual Int32 BranchState {get;}

Property Value

the branch state of this item revision.

See Also

ItemRevision Class | Borland.StarTeam Namespace


LocationItemID Property

Borland StarTeam SDK for .NET

ItemRevision.LocationItemID Property

[read] the location item ID of this item revision.

public virtual Int32 LocationItemID {get;}

Property Value

the location item ID of this item revision.

See Also

ItemRevision Class | Borland.StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

ItemRevision.ObjectID Property

[read] the object ID for this item revision.

public virtual Int32 ObjectID {get;}

Property Value

the object ID for this item revision.

See Also

ItemRevision Class | Borland.StarTeam Namespace


ObjectTime Property

Borland StarTeam SDK for .NET

ItemRevision.ObjectTime Property

[read] the time of this item revision.

public virtual DateTime ObjectTime {get;}

Property Value

the time of this item revision.

See Also

ItemRevision Class | Borland.StarTeam Namespace


ParentItemID Property

Borland StarTeam SDK for .NET

ItemRevision.ParentItemID Property

[read] the Item ID of the parent for this item revision.

public virtual Int32 ParentItemID {get;}

Property Value

the Item ID of the parent for this item revision.

See Also

ItemRevision Class | Borland.StarTeam Namespace


ProjectID Property

Borland StarTeam SDK for .NET

ItemRevision.ProjectID Property

[read] the Project ID of the project that contains this item revision.

public virtual Int32 ProjectID {get;}

Property Value

the Project ID of the project that contains this item revision.

See Also

ItemRevision Class | Borland.StarTeam Namespace


Time Property

Borland StarTeam SDK for .NET

ItemRevision.Time Property

[read] the time of this item revision.

public virtual DateTime Time {get;}

Property Value

the time of this item revision.

See Also

ItemRevision Class | Borland.StarTeam Namespace


UserID Property

Borland StarTeam SDK for .NET

ItemRevision.UserID Property

[read] the created User ID for this item revision.

public virtual Int32 UserID {get;}

Property Value

the created User ID for this item revision.

See Also

ItemRevision Class | Borland.StarTeam Namespace


ViewID Property

Borland StarTeam SDK for .NET

ItemRevision.ViewID Property

[read] the View ID for this item revision.

public virtual Int32 ViewID {get;}

Property Value

the View ID for this item revision.

See Also

ItemRevision Class | Borland.StarTeam Namespace


ItemRevision Methods

The methods of the ItemRevision class are listed below. For a complete list of ItemRevision class members, see the ItemRevision Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ItemRevision.

Public Instance Methods

AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ItemRevision Class | Borland.StarTeam Namespace


ItemRevision.Wrap Method

Dynamically wraps com.starbase.starteam.ItemRevision.

public static ItemRevision Wrap(
ItemRevision impl
);

Parameters

impl
com.starbase.starteam.ItemRevision to be wrapped.

Return Value

ItemRevision

See Also

ItemRevision Class | Borland.StarTeam Namespace


ItemRevision Type Conversions

The type conversions of the ItemRevision class are listed below. For a complete list of ItemRevision class members, see the ItemRevision Members topic.

Public Static Type Conversions

Implicit ItemRevision to ItemRevision Conversion Implicitly convert ItemRevision to com.starbase.starteam.ItemRevision.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

ItemRevision Class | ItemRevision Members | Borland.StarTeam Namespace


ItemRevision Implicit ItemRevision to ItemRevision Conversion

Implicitly convert ItemRevision to com.starbase.starteam.ItemRevision.

public static implicit operator ItemRevision(
ItemRevision arg
);

Parameters

arg
ItemRevision to convert.

Return Value

com.starbase.starteam.ItemRevision

See Also

ItemRevision Class | Borland.StarTeam Namespace


ItemRevisionCollection Class

A strongly-typed collection of ItemRevisions.

For a list of all members of this type, see ItemRevisionCollection Members.

System.Object
ArrayAdapter
ItemRevisionCollection

public class ItemRevisionCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemRevisionCollection Members | Borland.StarTeam Namespace


ItemRevisionCollection Members

ItemRevisionCollection overview

Public Static Methods

Wrap Creates an ItemRevisionCollection to represent the given array of ItemRevision (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit ItemRevisionCollection to ItemRevision[] Conversion | Converts an ItemRevisionCollection to an array of ItemRevisions.
Implicit ItemRevisionCollection to ItemRevision[] Conversion | Converts an ItemRevisionCollection from the Borland.StarTeam namespace to an ItemRevision[] in the com.starbase.starteam namespace.

Public Instance Constructors

ItemRevisionCollection Overloaded. Initializes a new instance of the ItemRevisionCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ItemRevision at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an ItemRevision to end of the collection.
Append | Overloaded. Appends the ItemRevisions of the given ItemRevisionCollection to the end of this ItemRevisionCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ItemRevision.
CopyTo | Copies all of the ItemRevisions in the ItemRevisionCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the ItemRevision with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ItemRevision in the collection.
Insert | Inserts an ItemRevision into the collection at the specified position.
Remove | Removes the first occurrence of a specific ItemRevision from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ItemRevisions in this ItemRevisionCollection.
Sort | Sorts the ItemRevisions in this ItemRevisionCollection, using the given comparer.
SortByID | Sorts the ItemRevisions in this ItemRevisionCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection Constructor

Initializes an instance of the ItemRevisionCollection class.

Overload List

Initializes an instance of the ItemRevisionCollection class.

public ItemRevisionCollection();

Initializes an instance of the an ItemRevisionCollection class, copying the given array.

public ItemRevisionCollection(ItemRevision[]);

Initializes an instance of the an ItemRevisionCollection class, copying the given collection.

public ItemRevisionCollection(ItemRevisionCollection);

Initializes an instance of the an ItemRevisionCollection class, wrapping the given array of ItemRevision (from the com.starbase.starteam namespace).

public ItemRevisionCollection(ItemRevision[]);

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection Constructor ()

Initializes an instance of the ItemRevisionCollection class.

public ItemRevisionCollection();

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace | ItemRevisionCollection Constructor Overload List


ItemRevisionCollection Constructor (ItemRevision[])

Initializes an instance of the an ItemRevisionCollection class, wrapping the given array of ItemRevision (from the com.starbase.starteam namespace).

public ItemRevisionCollection(
ItemRevision[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace | ItemRevisionCollection Constructor Overload List | Wrap


ItemRevisionCollection Constructor (ItemRevisionCollection)

Initializes an instance of the an ItemRevisionCollection class, copying the given collection.

public ItemRevisionCollection(
ItemRevisionCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member ItemRevision objects of the original collection are shared, not copied.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace | ItemRevisionCollection Constructor Overload List


ItemRevisionCollection Constructor (ItemRevision[])

Initializes an instance of the an ItemRevisionCollection class, copying the given array.

public ItemRevisionCollection(
ItemRevision[] array
);

Parameters

array
The array to be copied.

Remarks

The member ItemRevision objects of the original array are shared, not copied.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace | ItemRevisionCollection Constructor Overload List


ItemRevisionCollection Properties

The properties of the ItemRevisionCollection class are listed below. For a complete list of ItemRevisionCollection class members, see the ItemRevisionCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ItemRevision at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

ItemRevisionCollection.Item Property

Gets or sets the ItemRevision at the specified index.

public ItemRevision this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the ItemRevision to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection Methods

The methods of the ItemRevisionCollection class are listed below. For a complete list of ItemRevisionCollection class members, see the ItemRevisionCollection Members topic.

Public Static Methods

Wrap Creates an ItemRevisionCollection to represent the given array of ItemRevision (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds an ItemRevision to end of the collection.
Append | Overloaded. Appends the ItemRevisions of the given ItemRevisionCollection to the end of this ItemRevisionCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ItemRevision.
CopyTo | Copies all of the ItemRevisions in the ItemRevisionCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the ItemRevision with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ItemRevision in the collection.
Insert | Inserts an ItemRevision into the collection at the specified position.
Remove | Removes the first occurrence of a specific ItemRevision from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ItemRevisions in this ItemRevisionCollection.
Sort | Sorts the ItemRevisions in this ItemRevisionCollection, using the given comparer.
SortByID | Sorts the ItemRevisions in this ItemRevisionCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.Add Method

Adds an ItemRevision to end of the collection.

public int Add(
ItemRevision value
);

Parameters

value
The ItemRevision to add to the collection.

Return Value

The position into which the new ItemRevision was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

ItemRevisionCollection.Append Method

Appends the ItemRevisions of the given array to the end of this ItemRevisionCollection.

Overload List

Appends the ItemRevisions of the given array to the end of this ItemRevisionCollection.

public ItemRevisionCollection Append(ItemRevision[]);

Appends the ItemRevisions of the given ItemRevisionCollection to the end of this ItemRevisionCollection.

public ItemRevisionCollection Append(ItemRevisionCollection);

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.Append Method (ItemRevision[])

Appends the ItemRevisions of the given array to the end of this ItemRevisionCollection.

public ItemRevisionCollection Append(
ItemRevision[] array
);

Parameters

array
The array whose ItemRevisions are to be appended to this ItemRevisionCollection.

Return Value

This ItemRevisionCollection, modified to include the new ItemRevisions.

Remarks

The ItemRevisionCollection is modified to include the new members. The individual ItemRevision objects are shared, not copied.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace | ItemRevisionCollection.Append Overload List


ItemRevisionCollection.Append Method (ItemRevisionCollection)

Appends the ItemRevisions of the given ItemRevisionCollection to the end of this ItemRevisionCollection.

public ItemRevisionCollection Append(
ItemRevisionCollection collection
);

Parameters

collection
The ItemRevisionCollection whose ItemRevisions are to be appended to this ItemRevisionCollection.

Return Value

This ItemRevisionCollection, modified to include the new ItemRevisions.

Remarks

The ItemRevisionCollection is modified to include the new members. The individual ItemRevision objects are shared, not copied.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace | ItemRevisionCollection.Append Overload List


ItemRevisionCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.ItemRevision[].

Implements

IWrapper.Unwrap

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.Contains Method

Determines whether or not the collection contains a specific ItemRevision.

public bool Contains(
ItemRevision value
);

Parameters

value
The ItemRevision to locate in the collection.

Return Value

true if the ItemRevision is found in the collection; otherwise, false.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.CopyTo Method

Copies all of the ItemRevisions in the ItemRevisionCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
ItemRevision[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the ItemRevisions copied from the ItemRevisionCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of ItemRevisions in the source ItemRevisionCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ItemRevisionCollection cannot be cast automatically to the type of the destination array.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.FindByID Method

Finds the ItemRevision with the given ID.

public ItemRevision FindByID(
Int32 id
);

Parameters

id
The ID of the ItemRevision to be found.

Return Value

The ItemRevision with the given ID, or null if there is no ItemRevision with that ID in this ItemRevisionCollection.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.IndexOf Method

Determines the index of a specific ItemRevision in the collection.

public int IndexOf(
ItemRevision value
);

Parameters

value
The ItemRevision to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.Insert Method

Inserts an ItemRevision into the collection at the specified position.

public void Insert(
Int32 index,
ItemRevision value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The ItemRevision to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.Remove Method

Removes the first occurrence of a specific ItemRevision from the collection.

public void Remove(
ItemRevision value
);

Parameters

value
The ItemRevision to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.Reverse Method

Reverses the order of the ItemRevisions in this ItemRevisionCollection.

new public ItemRevisionCollection Reverse();

Return Value

This ItemRevisionCollection, modified such that the ItemRevisions are reversed.

Remarks

The ItemRevisionCollection is modified in place.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.Sort Method

Sorts the ItemRevisions in this ItemRevisionCollection, using the given comparer.

new public ItemRevisionCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two ItemRevisions.

Return Value

This ItemRevisionCollection, modified such that the ItemRevisions are sorted.

Remarks

The ItemRevisionCollection is modified in place.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.SortByID Method

Sorts the ItemRevisions in this ItemRevisionCollection by ID.

public ItemRevisionCollection SortByID();

Return Value

This ItemRevisionCollection, modified such that the ItemRevisions are sorted by ID.

Remarks

The ItemRevisionCollection is modified in place.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection.Wrap Method

Creates an ItemRevisionCollection to represent the given array of ItemRevision (from the com.starbase.starteam namespace).

public static ItemRevisionCollection Wrap(
ItemRevision[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ItemRevisionCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an ItemRevision[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection Type Conversions

The type conversions of the ItemRevisionCollection class are listed below. For a complete list of ItemRevisionCollection class members, see the ItemRevisionCollection Members topic.

Public Static Type Conversions

Implicit ItemRevisionCollection to ItemRevision[] Conversion | Converts an ItemRevisionCollection to an array of ItemRevisions.
Implicit ItemRevisionCollection to ItemRevision[] Conversion | Converts an ItemRevisionCollection from the Borland.StarTeam namespace to an ItemRevision[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ItemRevisionCollection Class | ItemRevisionCollection Members | Borland.StarTeam Namespace


ItemRevisionCollection Implicit ItemRevisionCollection to ItemRevision[] Conversion

Converts an ItemRevisionCollection to an array of ItemRevisions.

public static implicit operator ItemRevision[](
ItemRevisionCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new ItemRevision wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one ItemRevision wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemRevisionCollection Implicit ItemRevisionCollection to ItemRevision[] Conversion

Converts an ItemRevisionCollection from the Borland.StarTeam namespace to an ItemRevision[] in the com.starbase.starteam namespace.

public static implicit operator ItemRevision[](
ItemRevisionCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ItemRevisionCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ItemRevisionCollection Class | Borland.StarTeam Namespace


ItemsAdapter Class

For a list of all members of this type, see ItemsAdapter Members.

System.Object
ItemsAdapter

public class ItemsAdapter : Items

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemsAdapter Members | Borland.StarTeam Namespace


ItemsAdapter Members

ItemsAdapter overview

Public Static Type Conversions

Implicit ItemsAdapter to ItemCollection Conversion

Public Instance Constructors

ItemsAdapter Overloaded. Initializes a new instance of the ItemsAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAt |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
size |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ItemsAdapter Class | Borland.StarTeam Namespace


ItemsAdapter Constructor

Overload List

public ItemsAdapter(ItemCollection);

public ItemsAdapter(Items);

See Also

ItemsAdapter Class | Borland.StarTeam Namespace


ItemsAdapter Constructor (Items)

public ItemsAdapter(
Items impl
);

See Also

ItemsAdapter Class | Borland.StarTeam Namespace | ItemsAdapter Constructor Overload List


ItemsAdapter Constructor (ItemCollection)

public ItemsAdapter(
ItemCollection impl
);

See Also

ItemsAdapter Class | Borland.StarTeam Namespace | ItemsAdapter Constructor Overload List


ItemsAdapter Methods

The methods of the ItemsAdapter class are listed below. For a complete list of ItemsAdapter class members, see the ItemsAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAt |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
size |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ItemsAdapter Class | Borland.StarTeam Namespace


ItemsAdapter.getAt Method

public Item getAt(
Int32 index
);

Implements

Items.getAt

See Also

ItemsAdapter Class | Borland.StarTeam Namespace


ItemsAdapter.size Method

public int size();

Implements

Items.size

See Also

ItemsAdapter Class | Borland.StarTeam Namespace


ItemsAdapter Type Conversions

The type conversions of the ItemsAdapter class are listed below. For a complete list of ItemsAdapter class members, see the ItemsAdapter Members topic.

Public Static Type Conversions

Implicit ItemsAdapter to ItemCollection Conversion

See Also

ItemsAdapter Class | ItemsAdapter Members | Borland.StarTeam Namespace


ItemsAdapter Implicit ItemsAdapter to ItemCollection Conversion

public static implicit operator ItemCollection(
ItemsAdapter arg
);

See Also

ItemsAdapter Class | Borland.StarTeam Namespace


ItemUpdateEventArgs Class

For a list of all members of this type, see ItemUpdateEventArgs Members.

System.Object
EventArgs
ItemUpdateEventArgs

public class ItemUpdateEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemUpdateEventArgs Members | Borland.StarTeam Namespace


ItemUpdateEventArgs Members

ItemUpdateEventArgs overview

Public Static Type Conversions

Implicit ItemUpdateEventArgs to ItemUpdateEvent Conversion Implicitly convert ItemUpdateEventArgs to com.starbase.starteam.ItemUpdateEvent.

Public Instance Constructors

ItemUpdateEventArgs Constructor Constructs a new ItemUpdateEvent.

Public Instance Properties

NewItem | [read] The Item in its new state.
OldItem | [read] The Item in its old state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ItemUpdateEventArgs Class | Borland.StarTeam Namespace


ItemUpdateEventArgs Constructor

Constructs a new ItemUpdateEvent.

public ItemUpdateEventArgs(
Item oldItem,
Item newItem
);

Parameters

oldItem
The item in its old state, or null.
newItem
The item in its new state, or null.

See Also

ItemUpdateEventArgs Class | Borland.StarTeam Namespace


ItemUpdateEventArgs Properties

The properties of the ItemUpdateEventArgs class are listed below. For a complete list of ItemUpdateEventArgs class members, see the ItemUpdateEventArgs Members topic.

Public Instance Properties

NewItem | [read] The Item in its new state.
OldItem | [read] The Item in its old state.

See Also

ItemUpdateEventArgs Class | Borland.StarTeam Namespace


NewItem Property

Borland StarTeam SDK for .NET

ItemUpdateEventArgs.NewItem Property

[read] The Item in its new state.

public virtual Item NewItem {get;}

Property Value

The Item in its new state.

See Also

ItemUpdateEventArgs Class | Borland.StarTeam Namespace


OldItem Property

Borland StarTeam SDK for .NET

ItemUpdateEventArgs.OldItem Property

[read] The Item in its old state.

public virtual Item OldItem {get;}

Property Value

The Item in its old state.

See Also

ItemUpdateEventArgs Class | Borland.StarTeam Namespace


ItemUpdateEventArgs Methods

The methods of the ItemUpdateEventArgs class are listed below. For a complete list of ItemUpdateEventArgs class members, see the ItemUpdateEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ItemUpdateEventArgs Class | Borland.StarTeam Namespace


ItemUpdateEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ItemUpdateEventArgs Class | Borland.StarTeam Namespace


ItemUpdateEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ItemUpdateEventArgs Class | Borland.StarTeam Namespace


ItemUpdateEventArgs.ToString Method

public override string ToString();

See Also

ItemUpdateEventArgs Class | Borland.StarTeam Namespace


ItemUpdateEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

ItemUpdateEventArgs Class | Borland.StarTeam Namespace


ItemUpdateEventArgs Type Conversions

The type conversions of the ItemUpdateEventArgs class are listed below. For a complete list of ItemUpdateEventArgs class members, see the ItemUpdateEventArgs Members topic.

Public Static Type Conversions

Implicit ItemUpdateEventArgs to ItemUpdateEvent Conversion Implicitly convert ItemUpdateEventArgs to com.starbase.starteam.ItemUpdateEvent.

See Also

ItemUpdateEventArgs Class | ItemUpdateEventArgs Members | Borland.StarTeam Namespace


ItemUpdateEventArgs Implicit ItemUpdateEventArgs to ItemUpdateEvent Conversion

Implicitly convert ItemUpdateEventArgs to com.starbase.starteam.ItemUpdateEvent.

public static implicit operator ItemUpdateEvent(
ItemUpdateEventArgs arg
);

Parameters

arg
ItemUpdateEventArgs to convert.

Return Value

com.starbase.starteam.ItemUpdateEvent

See Also

ItemUpdateEventArgs Class | Borland.StarTeam Namespace


ItemUpdateEventSource Class

For a list of all members of this type, see ItemUpdateEventSource Members.

System.Object
ItemUpdateEventSource

public class ItemUpdateEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemUpdateEventSource Members | Borland.StarTeam Namespace


ItemUpdateEventSource Members

ItemUpdateEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ItemAdded
ItemChanged
ItemMoved
ItemRemoved
OnItemAdded
OnItemChanged
OnItemMoved
OnItemRemoved

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


ItemUpdateEventSource Properties

The properties of the ItemUpdateEventSource class are listed below. For a complete list of ItemUpdateEventSource class members, see the ItemUpdateEventSource Members topic.

Public Instance Properties

Parent

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

ItemUpdateEventSource.Parent Property

public Object Parent {get;}

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


ItemUpdateEventSource Events

The events of the ItemUpdateEventSource class are listed below. For a complete list of ItemUpdateEventSource class members, see the ItemUpdateEventSource Members topic.

Public Instance Events

ItemAdded
ItemChanged
ItemMoved
ItemRemoved
OnItemAdded
OnItemChanged
OnItemMoved
OnItemRemoved

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


ItemUpdateEventSource.ItemAdded Event

public event ItemUpdateEventSource.Handler ItemAdded;

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


ItemUpdateEventSource.ItemChanged Event

public event ItemUpdateEventSource.Handler ItemChanged;

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


ItemUpdateEventSource.ItemMoved Event

public event ItemUpdateEventSource.Handler ItemMoved;

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


ItemUpdateEventSource.ItemRemoved Event

public event ItemUpdateEventSource.Handler ItemRemoved;

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


ItemUpdateEventSource.OnItemAdded Event

public event ItemUpdateEventSource.Handler OnItemAdded;

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


ItemUpdateEventSource.OnItemChanged Event

public event ItemUpdateEventSource.Handler OnItemChanged;

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


ItemUpdateEventSource.OnItemMoved Event

public event ItemUpdateEventSource.Handler OnItemMoved;

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


ItemUpdateEventSource.OnItemRemoved Event

public event ItemUpdateEventSource.Handler OnItemRemoved;

See Also

ItemUpdateEventSource Class | Borland.StarTeam Namespace


ItemUpdateEventSource.Handler Delegate

public delegate void ItemUpdateEventSource.Handler(
ItemUpdateEventSource source,
ItemUpdateEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


Keyword Interface

A Keyword object that encapsulates information about a File keyword. When a file is added, checked-in or checked-out of the repository keyword expansion may be applied to the contents of the file. For example, an occurance of $Author$ in a file might be be replaced with $Author: Fred$ upon checkout.

For a list of all members of this type, see Keyword Members.

public interface Keyword

Types that implement Keyword

Type | Description
HistoryKeyword |
KeywordAdapter |
LogKeyword | An implementation of the StarTeam $Log$ keyword.
NoKeywords | A special Keyword implementation that halts keyword expansion for the rest of a file when encountered. The keyword is $NoKeywords$
SimpleKeyword | A Keyword object that encapsulates information about a File keyword. When checking a file is added, checked-in or checked-out of the repository keyword expansion may be applied to the contents of the file. For example, an occurance of $Author$ in a file might be be replaced with $Author: Fred$ upon checkout.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Keyword Members | Borland.StarTeam Namespace


Keyword Members

Keyword overview

Public Instance Properties

IsMultiLine | [read] true if this keyword spands multiple lines.
Name | [read] the keyword name.
StopExpanding | [read] true if keyword expansion should stop in a file after encountering this keyword.
Value | [read] the keyword value
XMLString | [read] an XML representation of the keyword.

Public Instance Methods

Expand | Returns the expanded or unexpanded version of this keyword. For example, if the keyword is "Author" then expanding this should return "Author: Fred$". Note that the leading $ is not returned, it is handled elsehwere. Unexpand would return "Author$"
Matches | Returns true of this keyword is found in the specified line. If found then the endPos parameter is treated as an output parameter and the value of endPos[0] should be the position in the line where the ending $ occurs.

See Also

Keyword Interface | Borland.StarTeam Namespace


Keyword Properties

The properties of the Keyword interface are listed below. For a complete list of Keyword interface members, see the Keyword Members topic.

Public Instance Properties

IsMultiLine | [read] true if this keyword spands multiple lines.
Name | [read] the keyword name.
StopExpanding | [read] true if keyword expansion should stop in a file after encountering this keyword.
Value | [read] the keyword value
XMLString | [read] an XML representation of the keyword.

See Also

Keyword Interface | Borland.StarTeam Namespace


IsMultiLine Property

Borland StarTeam SDK for .NET

Keyword.IsMultiLine Property

[read] true if this keyword spands multiple lines.

Boolean IsMultiLine {get;}

Property Value

true if this keyword spands multiple lines.

See Also

Keyword Interface | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Keyword.Name Property

[read] the keyword name.

String Name {get;}

Property Value

the keyword name.

See Also

Keyword Interface | Borland.StarTeam Namespace


StopExpanding Property

Borland StarTeam SDK for .NET

Keyword.StopExpanding Property

[read] true if keyword expansion should stop in a file after encountering this keyword.

Boolean StopExpanding {get;}

Property Value

true if keyword expansion should stop in a file after encountering this keyword.

See Also

Keyword Interface | Borland.StarTeam Namespace


Value Property

Borland StarTeam SDK for .NET

Keyword.Value Property

[read] the keyword value

String Value {get;}

Property Value

the keyword value

See Also

Keyword Interface | Borland.StarTeam Namespace


XMLString Property

Borland StarTeam SDK for .NET

Keyword.XMLString Property

[read] an XML representation of the keyword.

String XMLString {get;}

Property Value

an XML representation of the keyword.

See Also

Keyword Interface | Borland.StarTeam Namespace


Keyword Methods

The methods of the Keyword interface are listed below. For a complete list of Keyword interface members, see the Keyword Members topic.

Public Instance Methods

Expand | Returns the expanded or unexpanded version of this keyword. For example, if the keyword is "Author" then expanding this should return "Author: Fred$". Note that the leading $ is not returned, it is handled elsehwere. Unexpand would return "Author$"
Matches | Returns true of this keyword is found in the specified line. If found then the endPos parameter is treated as an output parameter and the value of endPos[0] should be the position in the line where the ending $ occurs.

See Also

Keyword Interface | Borland.StarTeam Namespace


Keyword.Expand Method

Returns the expanded or unexpanded version of this keyword. For example, if the keyword is "Author" then expanding this should return "Author: Fred$". Note that the leading $ is not returned, it is handled elsehwere. Unexpand would return "Author$"

string Expand(
String linePrefix,
String eol,
Boolean expand
);

Parameters

linePrefix
the begining of the line in the souce leading up to the keyword
eol
the end-of-line convention used in the source file
expand
true if the keyword is to be expanded and false for unexpand

Return Value

the appropriately expanded or unexpanded keyword.

See Also

Keyword Interface | Borland.StarTeam Namespace


Keyword.Matches Method

Returns true of this keyword is found in the specified line. If found then the endPos parameter is treated as an output parameter and the value of endPos[0] should be the position in the line where the ending $ occurs.

bool Matches(
String line,
Int32 start,
Int32[] endPos
);

Parameters

line
the line to search for this keyword
start
the position in the line (zero based) to start searching
endPos
and "output" array where the end of the keyword occurs.

Return Value

true if the keyword is found on the specified line

See Also

Keyword Interface | Borland.StarTeam Namespace


KeywordAdapter Class

For a list of all members of this type, see KeywordAdapter Members.

System.Object
KeywordAdapter

public class KeywordAdapter : Keyword, Keyword

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

KeywordAdapter Members | Borland.StarTeam Namespace


KeywordAdapter Members

KeywordAdapter overview

Public Instance Constructors

KeywordAdapter Overloaded. Initializes a new instance of the KeywordAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

Keyword.expand
Keyword.Expand
Keyword.getName
Keyword.getValue
Keyword.IsMultiLine
Keyword.matches
Keyword.Matches
Keyword.multiLine
Keyword.Name
Keyword.stopExpanding
Keyword.StopExpanding
Keyword.toXMLString
Keyword.Value
Keyword.XMLString

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter Constructor

Overload List

public KeywordAdapter(Keyword);

public KeywordAdapter(Keyword);

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter Constructor (Keyword)

public KeywordAdapter(
Keyword arg
);

See Also

KeywordAdapter Class | Borland.StarTeam Namespace | KeywordAdapter Constructor Overload List


KeywordAdapter Properties

The properties of the KeywordAdapter class are listed below. For a complete list of KeywordAdapter class members, see the KeywordAdapter Members topic.

Explicit Interface Implementations

Keyword.expand
Keyword.Expand
Keyword.getName
Keyword.getValue
Keyword.IsMultiLine
Keyword.matches
Keyword.Matches
Keyword.multiLine
Keyword.Name
Keyword.stopExpanding
Keyword.StopExpanding
Keyword.toXMLString
Keyword.Value
Keyword.XMLString

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


Keyword.IsMultiLine Property

Borland StarTeam SDK for .NET

KeywordAdapter.Keyword.IsMultiLine Property

private Boolean Keyword.IsMultiLine {get;}

Implements

Keyword.IsMultiLine

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


Keyword.Name Property

Borland StarTeam SDK for .NET

KeywordAdapter.Keyword.Name Property

private String Keyword.Name {get;}

Implements

Keyword.Name

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


Keyword.StopExpanding Property

Borland StarTeam SDK for .NET

KeywordAdapter.Keyword.StopExpanding Property

private Boolean Keyword.StopExpanding {get;}

Implements

Keyword.StopExpanding

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


Keyword.Value Property

Borland StarTeam SDK for .NET

KeywordAdapter.Keyword.Value Property

private String Keyword.Value {get;}

Implements

Keyword.Value

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


Keyword.XMLString Property

Borland StarTeam SDK for .NET

KeywordAdapter.Keyword.XMLString Property

private String Keyword.XMLString {get;}

Implements

Keyword.XMLString

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter Methods

The methods of the KeywordAdapter class are listed below. For a complete list of KeywordAdapter class members, see the KeywordAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

Keyword.expand
Keyword.Expand
Keyword.getName
Keyword.getValue
Keyword.IsMultiLine
Keyword.matches
Keyword.Matches
Keyword.multiLine
Keyword.Name
Keyword.stopExpanding
Keyword.StopExpanding
Keyword.toXMLString
Keyword.Value
Keyword.XMLString

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter.Keyword.Expand Method

string Keyword.Expand(
String linePrefix,
String eol,
Boolean expand
);

Implements

Keyword.Expand

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter.Keyword.Matches Method

bool Keyword.Matches(
String line,
Int32 start,
Int32[] endPos
);

Implements

Keyword.Matches

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter.Keyword.expand Method

string Keyword.expand(
String linePrefix,
String eol,
Boolean expand
);

Implements

Keyword.expand

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter.Keyword.getName Method

string Keyword.getName();

Implements

Keyword.getName

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter.Keyword.getValue Method

string Keyword.getValue();

Implements

Keyword.getValue

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter.Keyword.matches Method

bool Keyword.matches(
String line,
Int32 start,
Int32[] endPos
);

Implements

Keyword.matches

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter.Keyword.multiLine Method

bool Keyword.multiLine();

Implements

Keyword.multiLine

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter.Keyword.stopExpanding Method

bool Keyword.stopExpanding();

Implements

Keyword.stopExpanding

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordAdapter.Keyword.toXMLString Method

string Keyword.toXMLString();

Implements

Keyword.toXMLString

See Also

KeywordAdapter Class | Borland.StarTeam Namespace


KeywordCollection Class

A strongly-typed collection of Keywords.

For a list of all members of this type, see KeywordCollection Members.

System.Object
ArrayAdapter
KeywordCollection

public class KeywordCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

KeywordCollection Members | Borland.StarTeam Namespace


KeywordCollection Members

KeywordCollection overview

Public Static Methods

Wrap Creates a KeywordCollection to represent the given array of Keyword (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit KeywordCollection to Keyword[] Conversion | Converts a KeywordCollection to an array of Keywords.
Implicit KeywordCollection to Keyword[] Conversion | Converts a KeywordCollection from the Borland.StarTeam namespace to a Keyword[] in the com.starbase.starteam namespace.

Public Instance Constructors

KeywordCollection Overloaded. Initializes a new instance of the KeywordCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Keyword at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Keyword to end of the collection.
Append | Overloaded. Appends the Keywords of the given KeywordCollection to the end of this KeywordCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Keyword.
CopyTo | Copies all of the Keywords in the KeywordCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the Keyword with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Keyword in the collection.
Insert | Inserts a Keyword into the collection at the specified position.
Remove | Removes the first occurrence of a specific Keyword from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Keywords in this KeywordCollection.
Sort | Sorts the Keywords in this KeywordCollection, using the given comparer.
SortByName | Sorts the Keywords in this KeywordCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection Constructor

Initializes an instance of the KeywordCollection class.

Overload List

Initializes an instance of the KeywordCollection class.

public KeywordCollection();

Initializes an instance of the a KeywordCollection class, copying the given array.

public KeywordCollection(Keyword[]);

Initializes an instance of the a KeywordCollection class, copying the given collection.

public KeywordCollection(KeywordCollection);

Initializes an instance of the a KeywordCollection class, wrapping the given array of Keyword (from the com.starbase.starteam namespace).

public KeywordCollection(Keyword[]);

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection Constructor ()

Initializes an instance of the KeywordCollection class.

public KeywordCollection();

See Also

KeywordCollection Class | Borland.StarTeam Namespace | KeywordCollection Constructor Overload List


KeywordCollection Constructor (Keyword[])

Initializes an instance of the a KeywordCollection class, wrapping the given array of Keyword (from the com.starbase.starteam namespace).

public KeywordCollection(
Keyword[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

KeywordCollection Class | Borland.StarTeam Namespace | KeywordCollection Constructor Overload List | Wrap


KeywordCollection Constructor (KeywordCollection)

Initializes an instance of the a KeywordCollection class, copying the given collection.

public KeywordCollection(
KeywordCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Keyword objects of the original collection are shared, not copied.

See Also

KeywordCollection Class | Borland.StarTeam Namespace | KeywordCollection Constructor Overload List


KeywordCollection Constructor (Keyword[])

Initializes an instance of the a KeywordCollection class, copying the given array.

public KeywordCollection(
Keyword[] array
);

Parameters

array
The array to be copied.

Remarks

The member Keyword objects of the original array are shared, not copied.

See Also

KeywordCollection Class | Borland.StarTeam Namespace | KeywordCollection Constructor Overload List


KeywordCollection Properties

The properties of the KeywordCollection class are listed below. For a complete list of KeywordCollection class members, see the KeywordCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Keyword at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

KeywordCollection.Item Property

Gets or sets the Keyword at the specified index.

Overload List

Gets or sets the Keyword at the specified index.

public Keyword this[Int32] {get; set;}

Gets the Keyword with the given name.

public Keyword this[String] {get;}

See Also

KeywordCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

KeywordCollection.Item Property (Int32)

Gets or sets the Keyword at the specified index.

public Keyword this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Keyword to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

KeywordCollection Class | Borland.StarTeam Namespace | KeywordCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

KeywordCollection.Item Property (String)

Gets the Keyword with the given name.

public Keyword this[
String name
] {get;}

Parameters

name
The name of the Keyword to get.

Property Value

The Keyword with the given name, or null if there is no Keyword with that name in this KeywordCollection. Comparison is case sensitive.

See Also

KeywordCollection Class | Borland.StarTeam Namespace | KeywordCollection.Item Overload List | FindByName


KeywordCollection Methods

The methods of the KeywordCollection class are listed below. For a complete list of KeywordCollection class members, see the KeywordCollection Members topic.

Public Static Methods

Wrap Creates a KeywordCollection to represent the given array of Keyword (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a Keyword to end of the collection.
Append | Overloaded. Appends the Keywords of the given KeywordCollection to the end of this KeywordCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Keyword.
CopyTo | Copies all of the Keywords in the KeywordCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the Keyword with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Keyword in the collection.
Insert | Inserts a Keyword into the collection at the specified position.
Remove | Removes the first occurrence of a specific Keyword from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Keywords in this KeywordCollection.
Sort | Sorts the Keywords in this KeywordCollection, using the given comparer.
SortByName | Sorts the Keywords in this KeywordCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.Add Method

Adds a Keyword to end of the collection.

public int Add(
Keyword value
);

Parameters

value
The Keyword to add to the collection.

Return Value

The position into which the new Keyword was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

KeywordCollection.Append Method

Appends the Keywords of the given array to the end of this KeywordCollection.

Overload List

Appends the Keywords of the given array to the end of this KeywordCollection.

public KeywordCollection Append(Keyword[]);

Appends the Keywords of the given KeywordCollection to the end of this KeywordCollection.

public KeywordCollection Append(KeywordCollection);

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.Append Method (Keyword[])

Appends the Keywords of the given array to the end of this KeywordCollection.

public KeywordCollection Append(
Keyword[] array
);

Parameters

array
The array whose Keywords are to be appended to this KeywordCollection.

Return Value

This KeywordCollection, modified to include the new Keywords.

Remarks

The KeywordCollection is modified to include the new members. The individual Keyword objects are shared, not copied.

See Also

KeywordCollection Class | Borland.StarTeam Namespace | KeywordCollection.Append Overload List


KeywordCollection.Append Method (KeywordCollection)

Appends the Keywords of the given KeywordCollection to the end of this KeywordCollection.

public KeywordCollection Append(
KeywordCollection collection
);

Parameters

collection
The KeywordCollection whose Keywords are to be appended to this KeywordCollection.

Return Value

This KeywordCollection, modified to include the new Keywords.

Remarks

The KeywordCollection is modified to include the new members. The individual Keyword objects are shared, not copied.

See Also

KeywordCollection Class | Borland.StarTeam Namespace | KeywordCollection.Append Overload List


KeywordCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.Keyword[].

Implements

IWrapper.Unwrap

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.Contains Method

Determines whether or not the collection contains a specific Keyword.

public bool Contains(
Keyword value
);

Parameters

value
The Keyword to locate in the collection.

Return Value

true if the Keyword is found in the collection; otherwise, false.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.CopyTo Method

Copies all of the Keywords in the KeywordCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Keyword[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Keywords copied from the KeywordCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Keywords in the source KeywordCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source KeywordCollection cannot be cast automatically to the type of the destination array.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.FindByName Method

Finds the Keyword with the given name.

public Keyword FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the Keyword to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The Keyword with the given name, or null if there is no Keyword with that name in this KeywordCollection.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.IndexOf Method

Determines the index of a specific Keyword in the collection.

public int IndexOf(
Keyword value
);

Parameters

value
The Keyword to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.Insert Method

Inserts a Keyword into the collection at the specified position.

public void Insert(
Int32 index,
Keyword value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Keyword to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.Remove Method

Removes the first occurrence of a specific Keyword from the collection.

public void Remove(
Keyword value
);

Parameters

value
The Keyword to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.Reverse Method

Reverses the order of the Keywords in this KeywordCollection.

new public KeywordCollection Reverse();

Return Value

This KeywordCollection, modified such that the Keywords are reversed.

Remarks

The KeywordCollection is modified in place.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.Sort Method

Sorts the Keywords in this KeywordCollection, using the given comparer.

new public KeywordCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Keywords.

Return Value

This KeywordCollection, modified such that the Keywords are sorted.

Remarks

The KeywordCollection is modified in place.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.SortByName Method

Sorts the Keywords in this KeywordCollection by name.

public KeywordCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This KeywordCollection, modified such that the Keywords are sorted by name.

Remarks

The KeywordCollection is modified in place.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection.Wrap Method

Creates a KeywordCollection to represent the given array of Keyword (from the com.starbase.starteam namespace).

public static KeywordCollection Wrap(
Keyword[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new KeywordCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a Keyword[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection Type Conversions

The type conversions of the KeywordCollection class are listed below. For a complete list of KeywordCollection class members, see the KeywordCollection Members topic.

Public Static Type Conversions

Implicit KeywordCollection to Keyword[] Conversion | Converts a KeywordCollection to an array of Keywords.
Implicit KeywordCollection to Keyword[] Conversion | Converts a KeywordCollection from the Borland.StarTeam namespace to a Keyword[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

KeywordCollection Class | KeywordCollection Members | Borland.StarTeam Namespace


KeywordCollection Implicit KeywordCollection to Keyword[] Conversion

Converts a KeywordCollection to an array of Keywords.

public static implicit operator Keyword[](
KeywordCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Keyword wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Keyword wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordCollection Implicit KeywordCollection to Keyword[] Conversion

Converts a KeywordCollection from the Borland.StarTeam namespace to a Keyword[] in the com.starbase.starteam namespace.

public static implicit operator Keyword[](
KeywordCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, KeywordCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

KeywordCollection Class | Borland.StarTeam Namespace


KeywordReader Class

For a list of all members of this type, see KeywordReader Members.

System.Object
LineProcessor
KeywordReader

public class KeywordReader : LineProcessor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

KeywordReader Members | Borland.StarTeam Namespace


KeywordReader Members

KeywordReader overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.KeywordReader.

Public Static Type Conversions

Implicit KeywordReader to KeywordReader Conversion Implicitly convert KeywordReader to com.starbase.starteam.KeywordReader.

Public Instance Constructors

KeywordReader Overloaded. Initializes a new instance of the KeywordReader class.

Public Instance Properties

Encoding

Public Instance Methods

EndofInput (inherited from LineProcessor) |
Equals (inherited from LineProcessor) | Delegate Equals() to com.starbase.util.LineProcessor.
GetHashCode (inherited from LineProcessor) | Delegate GetHashCode() to com.starbase.util.LineProcessor.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLine (inherited from LineProcessor) |
ToString (inherited from LineProcessor) | Delegate ToString() to com.starbase.util.LineProcessor.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from LineProcessor) Implementation of IWrapper.Unwrap().

See Also

KeywordReader Class | Borland.StarTeam Namespace


KeywordReader Constructor

Construct KeywordReader from com.starbase.starteam.KeywordReader.

Overload List

public KeywordReader(LineReader,KeywordCollection,Boolean);

public KeywordReader(LineReader,KeywordCollection,Boolean,String);

Construct KeywordReader from com.starbase.starteam.KeywordReader.

public KeywordReader(KeywordReader);

See Also

KeywordReader Class | Borland.StarTeam Namespace


KeywordReader Constructor (KeywordReader)

Construct KeywordReader from com.starbase.starteam.KeywordReader.

public KeywordReader(
KeywordReader impl
);

Parameters

impl
The com.starbase.starteam.KeywordReader to be wrapped.

See Also

KeywordReader Class | Borland.StarTeam Namespace | KeywordReader Constructor Overload List


KeywordReader Constructor (LineReader, KeywordCollection, Boolean)

public KeywordReader(
LineReader source,
KeywordCollection keywords,
Boolean expand
);

See Also

KeywordReader Class | Borland.StarTeam Namespace | KeywordReader Constructor Overload List


KeywordReader Constructor (LineReader, KeywordCollection, Boolean, String)

public KeywordReader(
LineReader source,
KeywordCollection keywords,
Boolean expand,
String sEncoding
);

See Also

KeywordReader Class | Borland.StarTeam Namespace | KeywordReader Constructor Overload List


KeywordReader Properties

The properties of the KeywordReader class are listed below. For a complete list of KeywordReader class members, see the KeywordReader Members topic.

Public Instance Properties

Encoding

Explicit Interface Implementations

IWrapper.Unwrap (inherited from LineProcessor) Implementation of IWrapper.Unwrap().

See Also

KeywordReader Class | Borland.StarTeam Namespace


Encoding Property

Borland StarTeam SDK for .NET

KeywordReader.Encoding Property

public virtual String Encoding {set;}

See Also

KeywordReader Class | Borland.StarTeam Namespace


KeywordReader Methods

The methods of the KeywordReader class are listed below. For a complete list of KeywordReader class members, see the KeywordReader Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.KeywordReader.

Public Instance Methods

EndofInput (inherited from LineProcessor) |
Equals (inherited from LineProcessor) | Delegate Equals() to com.starbase.util.LineProcessor.
GetHashCode (inherited from LineProcessor) | Delegate GetHashCode() to com.starbase.util.LineProcessor.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLine (inherited from LineProcessor) |
ToString (inherited from LineProcessor) | Delegate ToString() to com.starbase.util.LineProcessor.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from LineProcessor) Implementation of IWrapper.Unwrap().

See Also

KeywordReader Class | Borland.StarTeam Namespace


KeywordReader.Wrap Method

Dynamically wraps com.starbase.starteam.KeywordReader.

public static KeywordReader Wrap(
KeywordReader impl
);

Parameters

impl
com.starbase.starteam.KeywordReader to be wrapped.

Return Value

KeywordReader

See Also

KeywordReader Class | Borland.StarTeam Namespace


KeywordReader Type Conversions

The type conversions of the KeywordReader class are listed below. For a complete list of KeywordReader class members, see the KeywordReader Members topic.

Public Static Type Conversions

Implicit KeywordReader to KeywordReader Conversion Implicitly convert KeywordReader to com.starbase.starteam.KeywordReader.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from LineProcessor) Implementation of IWrapper.Unwrap().

See Also

KeywordReader Class | KeywordReader Members | Borland.StarTeam Namespace


KeywordReader Implicit KeywordReader to KeywordReader Conversion

Implicitly convert KeywordReader to com.starbase.starteam.KeywordReader.

public static implicit operator KeywordReader(
KeywordReader arg
);

Parameters

arg
KeywordReader to convert.

Return Value

com.starbase.starteam.KeywordReader

See Also

KeywordReader Class | Borland.StarTeam Namespace


Label Class

Represents a named configuration of Items. Labels may be applied to an entire View or to individual item versions.

For a list of all members of this type, see Label Members.

System.Object
CacheRef
Label

public class Label : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Label Members | Borland.StarTeam Namespace


Label Members

Label overview

Public Static Properties

NEXT_BUILD_ID
SCOPE_ITEM_AND_CONTENTS
SCOPE_ITEM_ONLY
SCOPE_ITEM_TREE

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Label.

Public Static Type Conversions

Implicit Label to Label Conversion Implicitly convert Label to com.starbase.starteam.Label.

Public Instance Constructors

Label Constructor Construct Label from com.starbase.starteam.Label.

Public Instance Properties

DebugString | [read] a string containing various properties of this label.
Description | [read/write] the label's description.
ID | [read] this label's unique integer identifier.
IsBuildLabel | [read] true if this "view label" is a build label.
IsDeleted | [read] true if this label has been deleted.
IsLocked | [read/write] true if the label is locked or frozen.
IsModified | [read] true if this label has been modified but not yet saved.
IsNew | [read]
IsRevisionLabel | [read] true is the label is a revision label.
IsViewLabel | [read] true if the label is a view label.
Name | [read/write] the label's name.
OwningProjectID | [read]
OwningViewID | [read]
RevisionTime | [read] the label's revision time.
Time | [read/write] the label's primary rollback time.
View | [read] this label's View.

Public Instance Methods

AttachToFolder | Attaches the label to the specified folder. For 4.0 servers a scope value other than SCOPE_ITEM_ONLY means attach to the full tree. All server releases beyond 4.0 support the scope parameter.
AttachToItem | Associate a new item with this label. To attach a label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.
AttachToItems | Attach this label to the specified items as of the specified configuration. This is available only in server releases 4.1 and higher.
Clone (inherited from CacheRef) |
Copy | Creates a copy of this Label object. Useful to applications that want to save a snapshot of the label in a given state, for example, before calling View.refreshLabels().
DetachFromFolder | Removes the label from the specified folder. For 4.0 servers a scope value other than SCOPE_ITEM_ONLY means detach from the full tree. All server releases beyond 4.0 support the scope parameter.
DetachFromItems | Detaches this label from a collection of items. This is available only in server releases 4.1 and higher.
DetachItem | Removes the label from the specified item.
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetLabeledItemIDs | Determines which items from a given list have been labeled with this label in the current view.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two Label objects.
MoveItem | Overloaded. Associates the label with a different version of an item.
Remove | Removes (deletes) this label from the view. It will still appear in the list of labels returned from the view but it will be marked as deleted.
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.
Update | Stores all changed to a new or modified label to the StarTeam repository. You can only change the name, description and lock/frozen state after the label has need created. If those properties have not been changed then this method will immediately return.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Label Class | Borland.StarTeam Namespace


Label Constructor

Construct Label from com.starbase.starteam.Label.

public Label(
Label impl
);

Parameters

impl
The com.starbase.starteam.Label to be wrapped.

See Also

Label Class | Borland.StarTeam Namespace


Label Properties

The properties of the Label class are listed below. For a complete list of Label class members, see the Label Members topic.

Public Static Properties

NEXT_BUILD_ID
SCOPE_ITEM_AND_CONTENTS
SCOPE_ITEM_ONLY
SCOPE_ITEM_TREE

Public Instance Properties

DebugString | [read] a string containing various properties of this label.
Description | [read/write] the label's description.
ID | [read] this label's unique integer identifier.
IsBuildLabel | [read] true if this "view label" is a build label.
IsDeleted | [read] true if this label has been deleted.
IsLocked | [read/write] true if the label is locked or frozen.
IsModified | [read] true if this label has been modified but not yet saved.
IsNew | [read]
IsRevisionLabel | [read] true is the label is a revision label.
IsViewLabel | [read] true if the label is a view label.
Name | [read/write] the label's name.
OwningProjectID | [read]
OwningViewID | [read]
RevisionTime | [read] the label's revision time.
Time | [read/write] the label's primary rollback time.
View | [read] this label's View.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Label Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Label.DebugString Property

[read] a string containing various properties of this label.

public virtual String DebugString {get;}

Property Value

a string containing various properties of this label.

See Also

Label Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Label.Description Property

[read/write] the label's description.

public virtual String Description {get; set;}

Property Value

the label's description.

See Also

Label Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Label.ID Property

[read] this label's unique integer identifier.

public virtual Int32 ID {get;}

Property Value

this label's unique integer identifier.

See Also

Label Class | Borland.StarTeam Namespace


IsBuildLabel Property

Borland StarTeam SDK for .NET

Label.IsBuildLabel Property

[read] true if this "view label" is a build label.

public virtual Boolean IsBuildLabel {get;}

Property Value

true if this "view label" is a build label.

See Also

Label Class | Borland.StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Label.IsDeleted Property

[read] true if this label has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if this label has been deleted.

See Also

Label Class | Borland.StarTeam Namespace


IsLocked Property

Borland StarTeam SDK for .NET

Label.IsLocked Property

[read/write] true if the label is locked or frozen.

public virtual Boolean IsLocked {get; set;}

Property Value

true if the label is locked or frozen.

See Also

Label Class | Borland.StarTeam Namespace


IsModified Property

Borland StarTeam SDK for .NET

Label.IsModified Property

[read] true if this label has been modified but not yet saved.

public virtual Boolean IsModified {get;}

Property Value

true if this label has been modified but not yet saved.

See Also

Label Class | Borland.StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Label.IsNew Property

[read]

public virtual Boolean IsNew {get;}

See Also

Label Class | Borland.StarTeam Namespace


IsRevisionLabel Property

Borland StarTeam SDK for .NET

Label.IsRevisionLabel Property

[read] true is the label is a revision label.

public virtual Boolean IsRevisionLabel {get;}

Property Value

true is the label is a revision label.

See Also

Label Class | Borland.StarTeam Namespace


IsViewLabel Property

Borland StarTeam SDK for .NET

Label.IsViewLabel Property

[read] true if the label is a view label.

public virtual Boolean IsViewLabel {get;}

Property Value

true if the label is a view label.

See Also

Label Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Label.Name Property

[read/write] the label's name.

public virtual String Name {get; set;}

Property Value

the label's name.

See Also

Label Class | Borland.StarTeam Namespace


NEXT_BUILD_ID Property

Borland StarTeam SDK for .NET

Label.NEXT_BUILD_ID Property

public static Int32 NEXT_BUILD_ID {get;}

See Also

Label Class | Borland.StarTeam Namespace


OwningProjectID Property

Borland StarTeam SDK for .NET

Label.OwningProjectID Property

[read]

public virtual Int32 OwningProjectID {get;}

See Also

Label Class | Borland.StarTeam Namespace


OwningViewID Property

Borland StarTeam SDK for .NET

Label.OwningViewID Property

[read]

public virtual Int32 OwningViewID {get;}

See Also

Label Class | Borland.StarTeam Namespace


RevisionTime Property

Borland StarTeam SDK for .NET

Label.RevisionTime Property

[read] the label's revision time.

public virtual DateTime RevisionTime {get;}

Property Value

the label's revision time.

See Also

Label Class | Borland.StarTeam Namespace


SCOPE_ITEM_AND_CONTENTS Property

Borland StarTeam SDK for .NET

Label.SCOPE_ITEM_AND_CONTENTS Property

public static Int32 SCOPE_ITEM_AND_CONTENTS {get;}

See Also

Label Class | Borland.StarTeam Namespace


SCOPE_ITEM_ONLY Property

Borland StarTeam SDK for .NET

Label.SCOPE_ITEM_ONLY Property

public static Int32 SCOPE_ITEM_ONLY {get;}

See Also

Label Class | Borland.StarTeam Namespace


SCOPE_ITEM_TREE Property

Borland StarTeam SDK for .NET

Label.SCOPE_ITEM_TREE Property

public static Int32 SCOPE_ITEM_TREE {get;}

See Also

Label Class | Borland.StarTeam Namespace


Time Property

Borland StarTeam SDK for .NET

Label.Time Property

[read/write] the label's primary rollback time.

public virtual DateTime Time {get; set;}

Property Value

the label's primary rollback time.

See Also

Label Class | Borland.StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Label.View Property

[read] this label's View.

public virtual View View {get;}

Property Value

this label's View.

See Also

Label Class | Borland.StarTeam Namespace


Label Methods

The methods of the Label class are listed below. For a complete list of Label class members, see the Label Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Label.

Public Instance Methods

AttachToFolder | Attaches the label to the specified folder. For 4.0 servers a scope value other than SCOPE_ITEM_ONLY means attach to the full tree. All server releases beyond 4.0 support the scope parameter.
AttachToItem | Associate a new item with this label. To attach a label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.
AttachToItems | Attach this label to the specified items as of the specified configuration. This is available only in server releases 4.1 and higher.
Clone (inherited from CacheRef) |
Copy | Creates a copy of this Label object. Useful to applications that want to save a snapshot of the label in a given state, for example, before calling View.refreshLabels().
DetachFromFolder | Removes the label from the specified folder. For 4.0 servers a scope value other than SCOPE_ITEM_ONLY means detach from the full tree. All server releases beyond 4.0 support the scope parameter.
DetachFromItems | Detaches this label from a collection of items. This is available only in server releases 4.1 and higher.
DetachItem | Removes the label from the specified item.
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetLabeledItemIDs | Determines which items from a given list have been labeled with this label in the current view.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two Label objects.
MoveItem | Overloaded. Associates the label with a different version of an item.
Remove | Removes (deletes) this label from the view. It will still appear in the list of labels returned from the view but it will be marked as deleted.
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.
Update | Stores all changed to a new or modified label to the StarTeam repository. You can only change the name, description and lock/frozen state after the label has need created. If those properties have not been changed then this method will immediately return.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Label Class | Borland.StarTeam Namespace


Label.AttachToFolder Method

Attaches the label to the specified folder. For 4.0 servers a scope value other than SCOPE_ITEM_ONLY means attach to the full tree. All server releases beyond 4.0 support the scope parameter.

public virtual void AttachToFolder(
Folder folder,
Int32 scope
);

Parameters

folder
scope
for folder items this is the scope of the label detachment

See Also

Label Class | Borland.StarTeam Namespace | SCOPE_ITEM_ONLY | SCOPE_ITEM_AND_CONTENTS | SCOPE_ITEM_TREE


Label.AttachToItem Method

Associate a new item with this label. To attach a label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.

public virtual void AttachToItem(
Item item
);

Parameters

item
the item to which the label is to be attached

See Also

Label Class | Borland.StarTeam Namespace


Label.AttachToItems Method

Attach this label to the specified items as of the specified configuration. This is available only in server releases 4.1 and higher.

public virtual void AttachToItems(
Int32[] itemIDs,
ViewConfiguration configuration
);

Parameters

itemIDs
the collection of items to which the label should be attached
configuration

See Also

Label Class | Borland.StarTeam Namespace


Label.Copy Method

Creates a copy of this Label object. Useful to applications that want to save a snapshot of the label in a given state, for example, before calling View.refreshLabels().

public virtual Label Copy();

Return Value

A copy of this Label.

See Also

Label Class | Borland.StarTeam Namespace | isEqualTo


Label.DetachFromFolder Method

Removes the label from the specified folder. For 4.0 servers a scope value other than SCOPE_ITEM_ONLY means detach from the full tree. All server releases beyond 4.0 support the scope parameter.

public virtual void DetachFromFolder(
Folder item,
Int32 scope
);

Parameters

item
the folder item from which the label is to be removed.
scope
for folder items this is the scope of the label detachment

See Also

Label Class | Borland.StarTeam Namespace | SCOPE_ITEM_ONLY | SCOPE_ITEM_AND_CONTENTS | SCOPE_ITEM_TREE


Label.DetachFromItems Method

Detaches this label from a collection of items. This is available only in server releases 4.1 and higher.

public virtual void DetachFromItems(
Int32[] itemIDs
);

Parameters

itemIDs
the collection of items to which the label should be detached (may not be null)

See Also

Label Class | Borland.StarTeam Namespace


Label.DetachItem Method

Removes the label from the specified item.

public virtual void DetachItem(
Item item
);

Parameters

item
the item from which the label is to be removed.

See Also

Label Class | Borland.StarTeam Namespace


Label.GetLabeledItemIDs Method

Determines which items from a given list have been labeled with this label in the current view.

public virtual int[] GetLabeledItemIDs(
Int32[] itemIDs
);

Parameters

itemIDs
A list of item IDs.

Return Value

The subset of those IDs representing items that have been labeled with this label.

See Also

Label Class | Borland.StarTeam Namespace | attachItem


Label.IsEqualTo Method

Compares two Label objects.

public virtual bool IsEqualTo(
Label label
);

Parameters

label
The Label to be compared with this one.

Return Value

true if no differences were found.

See Also

Label Class | Borland.StarTeam Namespace | copy


MoveItem Method

Borland StarTeam SDK for .NET

Label.MoveItem Method

Associates the label with a different version of an item. To move the label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.

Overload List

Associates the label with a different version of an item. To move the label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.

public virtual void MoveItem(Item);

Associates the label with a different version of an item.

public virtual void MoveItem(Item,Int32,DateTime);

See Also

Label Class | Borland.StarTeam Namespace


Label.MoveItem Method (Item)

Associates the label with a different version of an item. To move the label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.

public virtual void MoveItem(
Item item
);

Parameters

item
the item to which the label is to be attached

See Also

Label Class | Borland.StarTeam Namespace | Label.MoveItem Overload List


Label.MoveItem Method (Item, Int32, DateTime)

Associates the label with a different version of an item.

public virtual void MoveItem(
Item item,
Int32 objectID,
DateTime revisionTime
);

Parameters

item
the item to which the label is to be attached
objectID
the object ID of the item being labeled
revisionTime
the time specifying to which revision the label should be attached

See Also

Label Class | Borland.StarTeam Namespace | Label.MoveItem Overload List | OBJECT_ID | MODIFIED_TIME | getObjectID | getModifiedTime


Label.Remove Method

Removes (deletes) this label from the view. It will still appear in the list of labels returned from the view but it will be marked as deleted.

public virtual void Remove();

See Also

Label Class | Borland.StarTeam Namespace


Label.Update Method

Stores all changed to a new or modified label to the StarTeam repository. You can only change the name, description and lock/frozen state after the label has need created. If those properties have not been changed then this method will immediately return.

public virtual void Update();

See Also

Label Class | Borland.StarTeam Namespace | setName | setDescription | setLocked


Label.Wrap Method

Dynamically wraps com.starbase.starteam.Label.

public static Label Wrap(
Label impl
);

Parameters

impl
com.starbase.starteam.Label to be wrapped.

Return Value

Label

See Also

Label Class | Borland.StarTeam Namespace


Label Type Conversions

The type conversions of the Label class are listed below. For a complete list of Label class members, see the Label Members topic.

Public Static Type Conversions

Implicit Label to Label Conversion Implicitly convert Label to com.starbase.starteam.Label.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Label Class | Label Members | Borland.StarTeam Namespace


Label Implicit Label to Label Conversion

Implicitly convert Label to com.starbase.starteam.Label.

public static implicit operator Label(
Label arg
);

Parameters

arg
Label to convert.

Return Value

com.starbase.starteam.Label

See Also

Label Class | Borland.StarTeam Namespace


LabelCollection Class

A strongly-typed collection of Labels.

For a list of all members of this type, see LabelCollection Members.

System.Object
ArrayAdapter
LabelCollection

public class LabelCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LabelCollection Members | Borland.StarTeam Namespace


LabelCollection Members

LabelCollection overview

Public Static Methods

Wrap Creates a LabelCollection to represent the given array of Label (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit LabelCollection to Label[] Conversion | Converts a LabelCollection to an array of Labels.
Implicit LabelCollection to Label[] Conversion | Converts a LabelCollection from the Borland.StarTeam namespace to a Label[] in the com.starbase.starteam namespace.

Public Instance Constructors

LabelCollection Overloaded. Initializes a new instance of the LabelCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Label at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Label to end of the collection.
Append | Overloaded. Appends the Labels of the given LabelCollection to the end of this LabelCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Label.
CopyTo | Copies all of the Labels in the LabelCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Label with the given ID.
FindByName | Finds the Label with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Label in the collection.
Insert | Inserts a Label into the collection at the specified position.
Remove | Removes the first occurrence of a specific Label from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Labels in this LabelCollection.
Sort | Sorts the Labels in this LabelCollection, using the given comparer.
SortByID | Sorts the Labels in this LabelCollection by ID.
SortByName | Sorts the Labels in this LabelCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection Constructor

Initializes an instance of the LabelCollection class.

Overload List

Initializes an instance of the LabelCollection class.

public LabelCollection();

Initializes an instance of the a LabelCollection class, copying the given array.

public LabelCollection(Label[]);

Initializes an instance of the a LabelCollection class, copying the given collection.

public LabelCollection(LabelCollection);

Initializes an instance of the a LabelCollection class, wrapping the given array of Label (from the com.starbase.starteam namespace).

public LabelCollection(Label[]);

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection Constructor ()

Initializes an instance of the LabelCollection class.

public LabelCollection();

See Also

LabelCollection Class | Borland.StarTeam Namespace | LabelCollection Constructor Overload List


LabelCollection Constructor (Label[])

Initializes an instance of the a LabelCollection class, wrapping the given array of Label (from the com.starbase.starteam namespace).

public LabelCollection(
Label[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

LabelCollection Class | Borland.StarTeam Namespace | LabelCollection Constructor Overload List | Wrap


LabelCollection Constructor (LabelCollection)

Initializes an instance of the a LabelCollection class, copying the given collection.

public LabelCollection(
LabelCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Label objects of the original collection are shared, not copied.

See Also

LabelCollection Class | Borland.StarTeam Namespace | LabelCollection Constructor Overload List


LabelCollection Constructor (Label[])

Initializes an instance of the a LabelCollection class, copying the given array.

public LabelCollection(
Label[] array
);

Parameters

array
The array to be copied.

Remarks

The member Label objects of the original array are shared, not copied.

See Also

LabelCollection Class | Borland.StarTeam Namespace | LabelCollection Constructor Overload List


LabelCollection Properties

The properties of the LabelCollection class are listed below. For a complete list of LabelCollection class members, see the LabelCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Label at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LabelCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

LabelCollection.Item Property

Gets or sets the Label at the specified index.

Overload List

Gets or sets the Label at the specified index.

public Label this[Int32] {get; set;}

Gets the Label with the given name.

public Label this[String] {get;}

See Also

LabelCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

LabelCollection.Item Property (Int32)

Gets or sets the Label at the specified index.

public Label this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Label to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

LabelCollection Class | Borland.StarTeam Namespace | LabelCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

LabelCollection.Item Property (String)

Gets the Label with the given name.

public Label this[
String name
] {get;}

Parameters

name
The name of the Label to get.

Property Value

The Label with the given name, or null if there is no Label with that name in this LabelCollection. Comparison is case sensitive.

See Also

LabelCollection Class | Borland.StarTeam Namespace | LabelCollection.Item Overload List | FindByName


LabelCollection Methods

The methods of the LabelCollection class are listed below. For a complete list of LabelCollection class members, see the LabelCollection Members topic.

Public Static Methods

Wrap Creates a LabelCollection to represent the given array of Label (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a Label to end of the collection.
Append | Overloaded. Appends the Labels of the given LabelCollection to the end of this LabelCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Label.
CopyTo | Copies all of the Labels in the LabelCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Label with the given ID.
FindByName | Finds the Label with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Label in the collection.
Insert | Inserts a Label into the collection at the specified position.
Remove | Removes the first occurrence of a specific Label from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Labels in this LabelCollection.
Sort | Sorts the Labels in this LabelCollection, using the given comparer.
SortByID | Sorts the Labels in this LabelCollection by ID.
SortByName | Sorts the Labels in this LabelCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.Add Method

Adds a Label to end of the collection.

public int Add(
Label value
);

Parameters

value
The Label to add to the collection.

Return Value

The position into which the new Label was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

LabelCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

LabelCollection.Append Method

Appends the Labels of the given array to the end of this LabelCollection.

Overload List

Appends the Labels of the given array to the end of this LabelCollection.

public LabelCollection Append(Label[]);

Appends the Labels of the given LabelCollection to the end of this LabelCollection.

public LabelCollection Append(LabelCollection);

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.Append Method (Label[])

Appends the Labels of the given array to the end of this LabelCollection.

public LabelCollection Append(
Label[] array
);

Parameters

array
The array whose Labels are to be appended to this LabelCollection.

Return Value

This LabelCollection, modified to include the new Labels.

Remarks

The LabelCollection is modified to include the new members. The individual Label objects are shared, not copied.

See Also

LabelCollection Class | Borland.StarTeam Namespace | LabelCollection.Append Overload List


LabelCollection.Append Method (LabelCollection)

Appends the Labels of the given LabelCollection to the end of this LabelCollection.

public LabelCollection Append(
LabelCollection collection
);

Parameters

collection
The LabelCollection whose Labels are to be appended to this LabelCollection.

Return Value

This LabelCollection, modified to include the new Labels.

Remarks

The LabelCollection is modified to include the new members. The individual Label objects are shared, not copied.

See Also

LabelCollection Class | Borland.StarTeam Namespace | LabelCollection.Append Overload List


LabelCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.Label[].

Implements

IWrapper.Unwrap

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.Contains Method

Determines whether or not the collection contains a specific Label.

public bool Contains(
Label value
);

Parameters

value
The Label to locate in the collection.

Return Value

true if the Label is found in the collection; otherwise, false.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.CopyTo Method

Copies all of the Labels in the LabelCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Label[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Labels copied from the LabelCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Labels in the source LabelCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source LabelCollection cannot be cast automatically to the type of the destination array.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.FindByID Method

Finds the Label with the given ID.

public Label FindByID(
Int32 id
);

Parameters

id
The ID of the Label to be found.

Return Value

The Label with the given ID, or null if there is no Label with that ID in this LabelCollection.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.FindByName Method

Finds the Label with the given name.

public Label FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the Label to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The Label with the given name, or null if there is no Label with that name in this LabelCollection.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.IndexOf Method

Determines the index of a specific Label in the collection.

public int IndexOf(
Label value
);

Parameters

value
The Label to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.Insert Method

Inserts a Label into the collection at the specified position.

public void Insert(
Int32 index,
Label value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Label to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.Remove Method

Removes the first occurrence of a specific Label from the collection.

public void Remove(
Label value
);

Parameters

value
The Label to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.Reverse Method

Reverses the order of the Labels in this LabelCollection.

new public LabelCollection Reverse();

Return Value

This LabelCollection, modified such that the Labels are reversed.

Remarks

The LabelCollection is modified in place.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.Sort Method

Sorts the Labels in this LabelCollection, using the given comparer.

new public LabelCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Labels.

Return Value

This LabelCollection, modified such that the Labels are sorted.

Remarks

The LabelCollection is modified in place.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.SortByID Method

Sorts the Labels in this LabelCollection by ID.

public LabelCollection SortByID();

Return Value

This LabelCollection, modified such that the Labels are sorted by ID.

Remarks

The LabelCollection is modified in place.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.SortByName Method

Sorts the Labels in this LabelCollection by name.

public LabelCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This LabelCollection, modified such that the Labels are sorted by name.

Remarks

The LabelCollection is modified in place.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection.Wrap Method

Creates a LabelCollection to represent the given array of Label (from the com.starbase.starteam namespace).

public static LabelCollection Wrap(
Label[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new LabelCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a Label[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection Type Conversions

The type conversions of the LabelCollection class are listed below. For a complete list of LabelCollection class members, see the LabelCollection Members topic.

Public Static Type Conversions

Implicit LabelCollection to Label[] Conversion | Converts a LabelCollection to an array of Labels.
Implicit LabelCollection to Label[] Conversion | Converts a LabelCollection from the Borland.StarTeam namespace to a Label[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LabelCollection Class | LabelCollection Members | Borland.StarTeam Namespace


LabelCollection Implicit LabelCollection to Label[] Conversion

Converts a LabelCollection to an array of Labels.

public static implicit operator Label[](
LabelCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Label wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Label wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelCollection Implicit LabelCollection to Label[] Conversion

Converts a LabelCollection from the Borland.StarTeam namespace to a Label[] in the com.starbase.starteam namespace.

public static implicit operator Label[](
LabelCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, LabelCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

LabelCollection Class | Borland.StarTeam Namespace


LabelEventArgs Class

For a list of all members of this type, see LabelEventArgs Members.

System.Object
EventArgs
LabelEventArgs

public class LabelEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LabelEventArgs Members | Borland.StarTeam Namespace


LabelEventArgs Members

LabelEventArgs overview

Public Static Type Conversions

Implicit LabelEventArgs to LabelEvent Conversion Implicitly convert LabelEventArgs to com.starbase.starteam.LabelEvent.

Public Instance Properties

Label [read] The Label that has been added, changed or deleted, in its new state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

LabelEventArgs Class | Borland.StarTeam Namespace


LabelEventArgs Properties

The properties of the LabelEventArgs class are listed below. For a complete list of LabelEventArgs class members, see the LabelEventArgs Members topic.

Public Instance Properties

Label [read] The Label that has been added, changed or deleted, in its new state.

See Also

LabelEventArgs Class | Borland.StarTeam Namespace


Label Property

Borland StarTeam SDK for .NET

LabelEventArgs.Label Property

[read] The Label that has been added, changed or deleted, in its new state.

public virtual Label Label {get;}

Property Value

The Label that has been added, changed or deleted, in its new state.

See Also

LabelEventArgs Class | Borland.StarTeam Namespace


LabelEventArgs Methods

The methods of the LabelEventArgs class are listed below. For a complete list of LabelEventArgs class members, see the LabelEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

LabelEventArgs Class | Borland.StarTeam Namespace


LabelEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

LabelEventArgs Class | Borland.StarTeam Namespace


LabelEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

LabelEventArgs Class | Borland.StarTeam Namespace


LabelEventArgs.ToString Method

public override string ToString();

See Also

LabelEventArgs Class | Borland.StarTeam Namespace


LabelEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

LabelEventArgs Class | Borland.StarTeam Namespace


LabelEventArgs Type Conversions

The type conversions of the LabelEventArgs class are listed below. For a complete list of LabelEventArgs class members, see the LabelEventArgs Members topic.

Public Static Type Conversions

Implicit LabelEventArgs to LabelEvent Conversion Implicitly convert LabelEventArgs to com.starbase.starteam.LabelEvent.

See Also

LabelEventArgs Class | LabelEventArgs Members | Borland.StarTeam Namespace


LabelEventArgs Implicit LabelEventArgs to LabelEvent Conversion

Implicitly convert LabelEventArgs to com.starbase.starteam.LabelEvent.

public static implicit operator LabelEvent(
LabelEventArgs arg
);

Parameters

arg
LabelEventArgs to convert.

Return Value

com.starbase.starteam.LabelEvent

See Also

LabelEventArgs Class | Borland.StarTeam Namespace


LabelEventSource Class

For a list of all members of this type, see LabelEventSource Members.

System.Object
LabelEventSource

public class LabelEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LabelEventSource Members | Borland.StarTeam Namespace


LabelEventSource Members

LabelEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

LabelAdded
LabelChanged
LabelDeleted
OnLabelAdded
OnLabelChanged
OnLabelDeleted

See Also

LabelEventSource Class | Borland.StarTeam Namespace


LabelEventSource Properties

The properties of the LabelEventSource class are listed below. For a complete list of LabelEventSource class members, see the LabelEventSource Members topic.

Public Instance Properties

Parent

See Also

LabelEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

LabelEventSource.Parent Property

public Object Parent {get;}

See Also

LabelEventSource Class | Borland.StarTeam Namespace


LabelEventSource Events

The events of the LabelEventSource class are listed below. For a complete list of LabelEventSource class members, see the LabelEventSource Members topic.

Public Instance Events

LabelAdded
LabelChanged
LabelDeleted
OnLabelAdded
OnLabelChanged
OnLabelDeleted

See Also

LabelEventSource Class | Borland.StarTeam Namespace


LabelEventSource.LabelAdded Event

public event LabelEventSource.Handler LabelAdded;

See Also

LabelEventSource Class | Borland.StarTeam Namespace


LabelEventSource.LabelChanged Event

public event LabelEventSource.Handler LabelChanged;

See Also

LabelEventSource Class | Borland.StarTeam Namespace


LabelEventSource.LabelDeleted Event

public event LabelEventSource.Handler LabelDeleted;

See Also

LabelEventSource Class | Borland.StarTeam Namespace


LabelEventSource.OnLabelAdded Event

public event LabelEventSource.Handler OnLabelAdded;

See Also

LabelEventSource Class | Borland.StarTeam Namespace


LabelEventSource.OnLabelChanged Event

public event LabelEventSource.Handler OnLabelChanged;

See Also

LabelEventSource Class | Borland.StarTeam Namespace


LabelEventSource.OnLabelDeleted Event

public event LabelEventSource.Handler OnLabelDeleted;

See Also

LabelEventSource Class | Borland.StarTeam Namespace


LabelEventSource.Handler Delegate

public delegate void LabelEventSource.Handler(
LabelEventSource source,
LabelEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


LicenseUsage Class

This class is a simple container for StarTeam license usage information.

For a list of all members of this type, see LicenseUsage Members.

System.Object
LicenseUsage

public class LicenseUsage : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LicenseUsage Members | Borland.StarTeam Namespace


LicenseUsage Members

LicenseUsage overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LicenseUsage.

Public Static Type Conversions

Implicit LicenseUsage to LicenseUsage Conversion Implicitly convert LicenseUsage to com.starbase.starteam.LicenseUsage.

Public Instance Constructors

LicenseUsage Constructor Construct LicenseUsage from com.starbase.starteam.LicenseUsage.

Public Instance Properties

EncryptedReport | [read] an encrypted version of the license usage report.
FormattedReport | [read] the formatted text version of the license usage report.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.LicenseUsage.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.LicenseUsage.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.LicenseUsage.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LicenseUsage Class | Borland.StarTeam Namespace


LicenseUsage Constructor

Construct LicenseUsage from com.starbase.starteam.LicenseUsage.

public LicenseUsage(
LicenseUsage impl
);

Parameters

impl
The com.starbase.starteam.LicenseUsage to be wrapped.

See Also

LicenseUsage Class | Borland.StarTeam Namespace


LicenseUsage Properties

The properties of the LicenseUsage class are listed below. For a complete list of LicenseUsage class members, see the LicenseUsage Members topic.

Public Instance Properties

EncryptedReport | [read] an encrypted version of the license usage report.
FormattedReport | [read] the formatted text version of the license usage report.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LicenseUsage Class | Borland.StarTeam Namespace


EncryptedReport Property

Borland StarTeam SDK for .NET

LicenseUsage.EncryptedReport Property

[read] an encrypted version of the license usage report.

public virtual Byte[] EncryptedReport {get;}

Property Value

an encrypted version of the license usage report.

See Also

LicenseUsage Class | Borland.StarTeam Namespace


FormattedReport Property

Borland StarTeam SDK for .NET

LicenseUsage.FormattedReport Property

[read] the formatted text version of the license usage report.

public virtual Byte[] FormattedReport {get;}

Property Value

the formatted text version of the license usage report.

See Also

LicenseUsage Class | Borland.StarTeam Namespace


LicenseUsage Methods

The methods of the LicenseUsage class are listed below. For a complete list of LicenseUsage class members, see the LicenseUsage Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LicenseUsage.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.LicenseUsage.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.LicenseUsage.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.LicenseUsage.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LicenseUsage Class | Borland.StarTeam Namespace


LicenseUsage.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.LicenseUsage

Implements

IWrapper.Unwrap

See Also

LicenseUsage Class | Borland.StarTeam Namespace


LicenseUsage.Equals Method

Delegate Equals() to com.starbase.starteam.LicenseUsage.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.LicenseUsage.Equals(obj).

See Also

LicenseUsage Class | Borland.StarTeam Namespace


LicenseUsage.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.LicenseUsage.

public override int GetHashCode();

Return Value

com.starbase.starteam.LicenseUsage.GetHashCode().

See Also

LicenseUsage Class | Borland.StarTeam Namespace


LicenseUsage.ToString Method

Delegate ToString() to com.starbase.starteam.LicenseUsage.

public override string ToString();

Return Value

com.starbase.starteam.LicenseUsage.ToString()

See Also

LicenseUsage Class | Borland.StarTeam Namespace


LicenseUsage.Wrap Method

Dynamically wraps com.starbase.starteam.LicenseUsage.

public static LicenseUsage Wrap(
LicenseUsage impl
);

Parameters

impl
com.starbase.starteam.LicenseUsage to be wrapped.

Return Value

LicenseUsage

See Also

LicenseUsage Class | Borland.StarTeam Namespace


LicenseUsage Type Conversions

The type conversions of the LicenseUsage class are listed below. For a complete list of LicenseUsage class members, see the LicenseUsage Members topic.

Public Static Type Conversions

Implicit LicenseUsage to LicenseUsage Conversion Implicitly convert LicenseUsage to com.starbase.starteam.LicenseUsage.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LicenseUsage Class | LicenseUsage Members | Borland.StarTeam Namespace


LicenseUsage Implicit LicenseUsage to LicenseUsage Conversion

Implicitly convert LicenseUsage to com.starbase.starteam.LicenseUsage.

public static implicit operator LicenseUsage(
LicenseUsage arg
);

Parameters

arg
LicenseUsage to convert.

Return Value

com.starbase.starteam.LicenseUsage

See Also

LicenseUsage Class | Borland.StarTeam Namespace


Link Class

Represents an instance of an association between two items.

For a list of all members of this type, see Link Members.

System.Object
Link

public class Link : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Link Members | Borland.StarTeam Namespace


Link Members

Link overview

Public Static Methods

LinkAndPin | Creates a new link between two items and pins the link endpoints to the specified item revisions.
Wrap | Dynamically wraps com.starbase.starteam.Link.

Public Static Type Conversions

Implicit Link to Link Conversion Implicitly convert Link to com.starbase.starteam.Link.

Public Instance Constructors

Link Overloaded. Initializes a new instance of the Link class.

Public Instance Properties

Child | [read] A disembodied item representing the resolved child enpoint.
ChildEndpoint | [read] a reference to the "child" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.
Comment | [read/write] the comment associated with this link.
CreatedTime | [read] the time at which this link was created.
CreatedUserID | [read] the user ID of the user who created this link.
DebugString | [read]
ID | [read] an integer that identifies this link.
Parent | [read] A disembodied item representing the resolved parent endpoint.
ParentEndpoint | [read] a reference to the "parent" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.
ParentFolderItemID | [read] the ItemID of the linked Item's parent Folder or -1 if unavailable.
Server | [read] the server object to which the parent endpoint of this link belongs.
View | [read] the view to which the parent endpoint of this link belongs.

Public Instance Methods

Copy | Copies this link, creating a new one with the same content.
Delete | Terminates the association of the linked items.
Equals | Delegate Equals() to com.starbase.starteam.Link.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Link.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Determines whether or not the contents of two links are the same.
PinChild | Pin the child endpoint of the link.
PinParent | Pin the parent endpoint of the link.
ToString | Delegate ToString() to com.starbase.starteam.Link.
UnpinChild | Unpin the child endpoint of the link.
UnpinParent | Unpin the parent endpoint of the link.
Update | Persists the link.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Link Class | Borland.StarTeam Namespace


Link Constructor

Construct Link from com.starbase.starteam.Link.

Overload List

Creates a new link object.

public Link(Item,Item);

Creates a new link object.

public Link(Item,Int32,Item,Int32);

Construct Link from com.starbase.starteam.Link.

public Link(Link);

See Also

Link Class | Borland.StarTeam Namespace


Link Constructor (Link)

Construct Link from com.starbase.starteam.Link.

public Link(
Link impl
);

Parameters

impl
The com.starbase.starteam.Link to be wrapped.

See Also

Link Class | Borland.StarTeam Namespace | Link Constructor Overload List


Link Constructor (Item, Item)

Creates a new link object.

public Link(
Item parent,
Item child
);

Parameters

parent
The parent end of the link. The link becomes visible at the first revision of this item's branch.
child
The child end of the link. The link becomes visible at the first revision of this item's branch.

See Also

Link Class | Borland.StarTeam Namespace | Link Constructor Overload List


Link Constructor (Item, Int32, Item, Int32)

Creates a new link object.

public Link(
Item parent,
Int32 parentRevision,
Item child,
Int32 childRevision
);

Parameters

parent
The parent end of the link.
parentRevision
The revision number of the first revision in the parent item's history for which this link is visible. If the value is -1, defaults to the first revision in the parent item's branch.
child
The child end of the link.
childRevision
The revision number of the first revision in the child item's history for which this link is visible. If the value is -1, defaults to the first revision in the child item's branch.

See Also

Link Class | Borland.StarTeam Namespace | Link Constructor Overload List


Link Properties

The properties of the Link class are listed below. For a complete list of Link class members, see the Link Members topic.

Public Instance Properties

Child | [read] A disembodied item representing the resolved child enpoint.
ChildEndpoint | [read] a reference to the "child" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.
Comment | [read/write] the comment associated with this link.
CreatedTime | [read] the time at which this link was created.
CreatedUserID | [read] the user ID of the user who created this link.
DebugString | [read]
ID | [read] an integer that identifies this link.
Parent | [read] A disembodied item representing the resolved parent endpoint.
ParentEndpoint | [read] a reference to the "parent" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.
ParentFolderItemID | [read] the ItemID of the linked Item's parent Folder or -1 if unavailable.
Server | [read] the server object to which the parent endpoint of this link belongs.
View | [read] the view to which the parent endpoint of this link belongs.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Link Class | Borland.StarTeam Namespace


Child Property

Borland StarTeam SDK for .NET

Link.Child Property

[read] A disembodied item representing the resolved child enpoint.

public virtual Item Child {get;}

Property Value

A disembodied item representing the resolved child enpoint.

See Also

Link Class | Borland.StarTeam Namespace


ChildEndpoint Property

Borland StarTeam SDK for .NET

Link.ChildEndpoint Property

[read] a reference to the "child" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.

public virtual LinkEndpoint ChildEndpoint {get;}

Property Value

a reference to the "child" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.

See Also

Link Class | Borland.StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Link.Comment Property

[read/write] the comment associated with this link.

public virtual String Comment {get; set;}

Property Value

the comment associated with this link.

See Also

Link Class | Borland.StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Link.CreatedTime Property

[read] the time at which this link was created.

public virtual DateTime CreatedTime {get;}

Property Value

the time at which this link was created.

See Also

Link Class | Borland.StarTeam Namespace


CreatedUserID Property

Borland StarTeam SDK for .NET

Link.CreatedUserID Property

[read] the user ID of the user who created this link.

public virtual Int32 CreatedUserID {get;}

Property Value

the user ID of the user who created this link.

See Also

Link Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Link.DebugString Property

[read]

public virtual String DebugString {get;}

See Also

Link Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Link.ID Property

[read] an integer that identifies this link.

public virtual Int32 ID {get;}

Property Value

an integer that identifies this link.

See Also

Link Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

Link.Parent Property

[read] A disembodied item representing the resolved parent endpoint.

public virtual Item Parent {get;}

Property Value

A disembodied item representing the resolved parent endpoint.

See Also

Link Class | Borland.StarTeam Namespace


ParentEndpoint Property

Borland StarTeam SDK for .NET

Link.ParentEndpoint Property

[read] a reference to the "parent" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.

public virtual LinkEndpoint ParentEndpoint {get;}

Property Value

a reference to the "parent" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.

See Also

Link Class | Borland.StarTeam Namespace


ParentFolderItemID Property

Borland StarTeam SDK for .NET

Link.ParentFolderItemID Property

[read] the ItemID of the linked Item's parent Folder or -1 if unavailable.

public virtual Int32 ParentFolderItemID {get;}

Property Value

the ItemID of the linked Item's parent Folder or -1 if unavailable.

See Also

Link Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Link.Server Property

[read] the server object to which the parent endpoint of this link belongs.

public virtual Server Server {get;}

Property Value

the server object to which the parent endpoint of this link belongs.

See Also

Link Class | Borland.StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Link.View Property

[read] the view to which the parent endpoint of this link belongs.

public virtual View View {get;}

Property Value

the view to which the parent endpoint of this link belongs.

See Also

Link Class | Borland.StarTeam Namespace


Link Methods

The methods of the Link class are listed below. For a complete list of Link class members, see the Link Members topic.

Public Static Methods

LinkAndPin | Creates a new link between two items and pins the link endpoints to the specified item revisions.
Wrap | Dynamically wraps com.starbase.starteam.Link.

Public Instance Methods

Copy | Copies this link, creating a new one with the same content.
Delete | Terminates the association of the linked items.
Equals | Delegate Equals() to com.starbase.starteam.Link.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Link.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Determines whether or not the contents of two links are the same.
PinChild | Pin the child endpoint of the link.
PinParent | Pin the parent endpoint of the link.
ToString | Delegate ToString() to com.starbase.starteam.Link.
UnpinChild | Unpin the child endpoint of the link.
UnpinParent | Unpin the parent endpoint of the link.
Update | Persists the link.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Link Class | Borland.StarTeam Namespace


Link.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.Link

Implements

IWrapper.Unwrap

See Also

Link Class | Borland.StarTeam Namespace


Link.Copy Method

Copies this link, creating a new one with the same content.

public virtual Link Copy();

Return Value

A new copy of this link.

See Also

Link Class | Borland.StarTeam Namespace


Link.Delete Method

Terminates the association of the linked items.

public virtual void Delete();

See Also

Link Class | Borland.StarTeam Namespace


Link.Equals Method

Delegate Equals() to com.starbase.starteam.Link.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.Link.Equals(obj).

See Also

Link Class | Borland.StarTeam Namespace


Link.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.Link.

public override int GetHashCode();

Return Value

com.starbase.starteam.Link.GetHashCode().

See Also

Link Class | Borland.StarTeam Namespace


Link.IsEqualTo Method

Determines whether or not the contents of two links are the same.

public virtual bool IsEqualTo(
Link other
);

Parameters

other
The link to be compared to this one.

Return Value

true if the links are the same; false otherwise.

See Also

Link Class | Borland.StarTeam Namespace


Link.LinkAndPin Method

Creates a new link between two items and pins the link endpoints to the specified item revisions.

public static Link LinkAndPin(
Item parent,
Item child,
String comment,
Boolean updateExistingLink
);

Parameters

parent
the parent end of the link
child
the child end of the link
comment
the link comment
updateExistingLink
if true this will modify a link that already exists between the two items rather than creating a new link.

Return Value

the resulting link

See Also

Link Class | Borland.StarTeam Namespace


Link.PinChild Method

Pin the child endpoint of the link.

public virtual void PinChild(
Item newChild
);

Parameters

newChild
the Item to which this endpoint should be pinned. Note that this item must lie in the history path of the original item for the endpoint, and cannot be an earlier revision than the earliest revision for the endpoint.

See Also

Link Class | Borland.StarTeam Namespace


Link.PinParent Method

Pin the parent endpoint of the link.

public virtual void PinParent(
Item newParent
);

Parameters

newParent
the Item to which this endpoint should be pinned. Note that this item must lie in the history path of the original item for the endpoint, and cannot be an earlier revision than the earliest revision for the endpoint.

See Also

Link Class | Borland.StarTeam Namespace


Link.ToString Method

Delegate ToString() to com.starbase.starteam.Link.

public override string ToString();

Return Value

com.starbase.starteam.Link.ToString()

See Also

Link Class | Borland.StarTeam Namespace


Link.UnpinChild Method

Unpin the child endpoint of the link.

public virtual void UnpinChild();

See Also

Link Class | Borland.StarTeam Namespace


Link.UnpinParent Method

Unpin the parent endpoint of the link.

public virtual void UnpinParent();

See Also

Link Class | Borland.StarTeam Namespace


Link.Update Method

Persists the link.

public virtual void Update();

See Also

Link Class | Borland.StarTeam Namespace


Link.Wrap Method

Dynamically wraps com.starbase.starteam.Link.

public static Link Wrap(
Link impl
);

Parameters

impl
com.starbase.starteam.Link to be wrapped.

Return Value

Link

See Also

Link Class | Borland.StarTeam Namespace


Link Type Conversions

The type conversions of the Link class are listed below. For a complete list of Link class members, see the Link Members topic.

Public Static Type Conversions

Implicit Link to Link Conversion Implicitly convert Link to com.starbase.starteam.Link.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Link Class | Link Members | Borland.StarTeam Namespace


Link Implicit Link to Link Conversion

Implicitly convert Link to com.starbase.starteam.Link.

public static implicit operator Link(
Link arg
);

Parameters

arg
Link to convert.

Return Value

com.starbase.starteam.Link

See Also

Link Class | Borland.StarTeam Namespace


LinkCache Class

Caches links for a given set of items. One LinkCache may be populated with links from multiple view configurations on multiple servers.

For a list of all members of this type, see LinkCache Members.

System.Object
LinkCache

public class LinkCache : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LinkCache Members | Borland.StarTeam Namespace


LinkCache Members

LinkCache overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LinkCache.

Public Static Type Conversions

Implicit LinkCache to LinkCache Conversion Implicitly convert LinkCache to com.starbase.starteam.LinkCache.

Public Instance Constructors

LinkCache Overloaded. Initializes a new instance of the LinkCache class.

Public Instance Properties

LinkFactory [read] The LinkFactory.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.LinkCache.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.LinkCache.
GetLinks | Gets the links for the given item. If the links were not previously cached, they are fetched from the server and cached now. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.
GetType (inherited from Object) | Gets the Type of the current instance.
IsPopulated | Determines whether of not the given item's links have already been cached.
NewLinkUpdateEventSource |
Populate | Overloaded. Ensures that the links are cached for all items of the given type in the given view. If the links for some of the items have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.
Refresh | Overloaded. Ensures that the latest links are available for all items of the given type in the given view. Existing Link objects are modified in place whenever possible. Note that since links are not currently MPX-aware, this re-fetches the links for all relevant items. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.
ToString | Delegate ToString() to com.starbase.starteam.LinkCache.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCache Constructor

Construct LinkCache from com.starbase.starteam.LinkCache.

Overload List

Constructs a new link cache. The cache is initially empty.

public LinkCache();

Construct LinkCache from com.starbase.starteam.LinkCache.

public LinkCache(LinkCache);

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCache Constructor (LinkCache)

Construct LinkCache from com.starbase.starteam.LinkCache.

public LinkCache(
LinkCache impl
);

Parameters

impl
The com.starbase.starteam.LinkCache to be wrapped.

See Also

LinkCache Class | Borland.StarTeam Namespace | LinkCache Constructor Overload List


LinkCache Constructor ()

Constructs a new link cache. The cache is initially empty.

public LinkCache();

See Also

LinkCache Class | Borland.StarTeam Namespace | LinkCache Constructor Overload List


LinkCache Properties

The properties of the LinkCache class are listed below. For a complete list of LinkCache class members, see the LinkCache Members topic.

Public Instance Properties

LinkFactory [read] The LinkFactory.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkFactory Property

Borland StarTeam SDK for .NET

LinkCache.LinkFactory Property

[read] The LinkFactory.

public virtual LinkFactory LinkFactory {get;}

Property Value

The LinkFactory.

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCache Methods

The methods of the LinkCache class are listed below. For a complete list of LinkCache class members, see the LinkCache Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LinkCache.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.LinkCache.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.LinkCache.
GetLinks | Gets the links for the given item. If the links were not previously cached, they are fetched from the server and cached now. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.
GetType (inherited from Object) | Gets the Type of the current instance.
IsPopulated | Determines whether of not the given item's links have already been cached.
NewLinkUpdateEventSource |
Populate | Overloaded. Ensures that the links are cached for all items of the given type in the given view. If the links for some of the items have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.
Refresh | Overloaded. Ensures that the latest links are available for all items of the given type in the given view. Existing Link objects are modified in place whenever possible. Note that since links are not currently MPX-aware, this re-fetches the links for all relevant items. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.
ToString | Delegate ToString() to com.starbase.starteam.LinkCache.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCache.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.LinkCache

Implements

IWrapper.Unwrap

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCache.Equals Method

Delegate Equals() to com.starbase.starteam.LinkCache.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.LinkCache.Equals(obj).

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCache.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.LinkCache.

public override int GetHashCode();

Return Value

com.starbase.starteam.LinkCache.GetHashCode().

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCache.GetLinks Method

Gets the links for the given item. If the links were not previously cached, they are fetched from the server and cached now.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual LinkCollection GetLinks(
Item item
);

Parameters

item
The item whose links are to be fetched.

Return Value

The set of links whose parent is the given item.

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCache.IsPopulated Method

Determines whether of not the given item's links have already been cached.

public virtual bool IsPopulated(
Item item
);

Parameters

item
The item to be tested.

Return Value

true if the given item's links have been cached, and false otherwise.

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCache.NewLinkUpdateEventSource Method

public LinkUpdateEventSource NewLinkUpdateEventSource();

See Also

LinkCache Class | Borland.StarTeam Namespace


Populate Method

Borland StarTeam SDK for .NET

LinkCache.Populate Method

Ensures that the links are cached for all items of the given type in the given folder. Items in subfolders may also be included.

If the links for some of the items have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

Overload List

Ensures that the links are cached for all items of the given type in the given folder. Items in subfolders may also be included. If the links for some of the items have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual void Populate(Folder,Type,Int32);

Ensures that the links are cached for all of the given items. If the links for some of the items have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual void Populate(ItemCollection);

Ensures that the links are cached for all items of the given type in the given view. If the links for some of the items have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual void Populate(View,Type);

See Also

LinkCache Class | Borland.StarTeam Namespace | hasBulkFetchLinks


LinkCache.Populate Method (Folder, Type, Int32)

Ensures that the links are cached for all items of the given type in the given folder. Items in subfolders may also be included.

If the links for some of the items have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual void Populate(
Folder folder,
Type itemType,
Int32 depth
);

Parameters

folder
The folder containing the items whose links are to be cached.
itemType
The type item whose links are to be cached.
depth
The number of levels deep in the folder tree that child folders should also be processed. A value of 0 causes only this folder to be processed. A positive value n will cause this folder and all subfolders up to n levels deeper to be processed. A negative value causes this folder and all subfolders to be processed.

See Also

LinkCache Class | Borland.StarTeam Namespace | LinkCache.Populate Overload List | hasBulkFetchLinks


LinkCache.Populate Method (ItemCollection)

Ensures that the links are cached for all of the given items.

If the links for some of the items have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual void Populate(
ItemCollection list
);

Parameters

list
The list of items whose links are to be cached.

See Also

LinkCache Class | Borland.StarTeam Namespace | LinkCache.Populate Overload List | hasBulkFetchLinks


LinkCache.Populate Method (View, Type)

Ensures that the links are cached for all items of the given type in the given view.

If the links for some of the items have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual void Populate(
View view,
Type itemType
);

Parameters

view
The view containing the items whose links are to be cached.
itemType
The type item whose links are to be cached.

See Also

LinkCache Class | Borland.StarTeam Namespace | LinkCache.Populate Overload List | hasBulkFetchLinks


Refresh Method

Borland StarTeam SDK for .NET

LinkCache.Refresh Method

Ensures that the latest links are available for all items of the given type in the given folder. Items in subfolders may also be included.

Existing Link objects are modified in place whenever possible.

Note that since links are not currently MPX-aware, this re-fetches the links for all relevant items. Links are fetched in bulk for servers that support it.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

Overload List

Ensures that the latest links are available for all items of the given type in the given folder. Items in subfolders may also be included. Existing Link objects are modified in place whenever possible. Note that since links are not currently MPX-aware, this re-fetches the links for all relevant items. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(Folder,Type,Int32);

Ensures that the latest links are available for the given item. Existing Link objects are modified in place whenever possible. Note that since links are not currently MPX-aware, this re-fetches the links for the given item. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(Item);

Ensures that the latest links are available for all of the given items. Existing Link objects are modified in place whenever possible. Note that since links are not currently MPX-aware, this re-fetches the links for all of the given items. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(ItemCollection);

Ensures that the latest links are available for all items of the given type in the given view. Existing Link objects are modified in place whenever possible. Note that since links are not currently MPX-aware, this re-fetches the links for all relevant items. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(View,Type);

See Also

LinkCache Class | Borland.StarTeam Namespace | hasBulkFetchLinks


LinkCache.Refresh Method (Folder, Type, Int32)

Ensures that the latest links are available for all items of the given type in the given folder. Items in subfolders may also be included.

Existing Link objects are modified in place whenever possible.

Note that since links are not currently MPX-aware, this re-fetches the links for all relevant items. Links are fetched in bulk for servers that support it.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(
Folder folder,
Type itemType,
Int32 depth
);

Parameters

folder
The folder containing the items whose links are to be refreshed.
itemType
The type item whose links are to be refreshed.
depth
The number of levels deep in the folder tree that child folders should also be processed. A value of 0 causes only this folder to be processed. A positive value n will cause this folder and all subfolders up to n levels deeper to be processed. A negative value causes this folder and all subfolders to be processed.

See Also

LinkCache Class | Borland.StarTeam Namespace | LinkCache.Refresh Overload List | hasBulkFetchLinks


LinkCache.Refresh Method (Item)

Ensures that the latest links are available for the given item.

Existing Link objects are modified in place whenever possible.

Note that since links are not currently MPX-aware, this re-fetches the links for the given item.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(
Item item
);

Parameters

item
The item whose links are to be refreshed.

See Also

LinkCache Class | Borland.StarTeam Namespace | LinkCache.Refresh Overload List


LinkCache.Refresh Method (ItemCollection)

Ensures that the latest links are available for all of the given items.

Existing Link objects are modified in place whenever possible.

Note that since links are not currently MPX-aware, this re-fetches the links for all of the given items. Links are fetched in bulk for servers that support it.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(
ItemCollection list
);

Parameters

list
The list of items whose links are to be refreshed.

See Also

LinkCache Class | Borland.StarTeam Namespace | LinkCache.Refresh Overload List | hasBulkFetchLinks


LinkCache.Refresh Method (View, Type)

Ensures that the latest links are available for all items of the given type in the given view.

Existing Link objects are modified in place whenever possible.

Note that since links are not currently MPX-aware, this re-fetches the links for all relevant items. Links are fetched in bulk for servers that support it.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(
View view,
Type itemType
);

Parameters

view
The view containing the items whose links are to be refreshed.
itemType
The type item whose links are to be refreshed.

See Also

LinkCache Class | Borland.StarTeam Namespace | LinkCache.Refresh Overload List | hasBulkFetchLinks


LinkCache.ToString Method

Delegate ToString() to com.starbase.starteam.LinkCache.

public override string ToString();

Return Value

com.starbase.starteam.LinkCache.ToString()

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCache.Wrap Method

Dynamically wraps com.starbase.starteam.LinkCache.

public static LinkCache Wrap(
LinkCache impl
);

Parameters

impl
com.starbase.starteam.LinkCache to be wrapped.

Return Value

LinkCache

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCache Type Conversions

The type conversions of the LinkCache class are listed below. For a complete list of LinkCache class members, see the LinkCache Members topic.

Public Static Type Conversions

Implicit LinkCache to LinkCache Conversion Implicitly convert LinkCache to com.starbase.starteam.LinkCache.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LinkCache Class | LinkCache Members | Borland.StarTeam Namespace


LinkCache Implicit LinkCache to LinkCache Conversion

Implicitly convert LinkCache to com.starbase.starteam.LinkCache.

public static implicit operator LinkCache(
LinkCache arg
);

Parameters

arg
LinkCache to convert.

Return Value

com.starbase.starteam.LinkCache

See Also

LinkCache Class | Borland.StarTeam Namespace


LinkCollection Class

A strongly-typed collection of Links.

For a list of all members of this type, see LinkCollection Members.

System.Object
ArrayAdapter
LinkCollection

public class LinkCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LinkCollection Members | Borland.StarTeam Namespace


LinkCollection Members

LinkCollection overview

Public Static Methods

Wrap Creates a LinkCollection to represent the given array of Link (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit LinkCollection to Link[] Conversion | Converts a LinkCollection to an array of Links.
Implicit LinkCollection to Link[] Conversion | Converts a LinkCollection from the Borland.StarTeam namespace to a Link[] in the com.starbase.starteam namespace.

Public Instance Constructors

LinkCollection Overloaded. Initializes a new instance of the LinkCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the Link at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Link to end of the collection.
Append | Overloaded. Appends the Links of the given LinkCollection to the end of this LinkCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Link.
CopyTo | Copies all of the Links in the LinkCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Link with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Link in the collection.
Insert | Inserts a Link into the collection at the specified position.
Remove | Removes the first occurrence of a specific Link from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Links in this LinkCollection.
Sort | Sorts the Links in this LinkCollection, using the given comparer.
SortByID | Sorts the Links in this LinkCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection Constructor

Initializes an instance of the LinkCollection class.

Overload List

Initializes an instance of the LinkCollection class.

public LinkCollection();

Initializes an instance of the a LinkCollection class, copying the given array.

public LinkCollection(Link[]);

Initializes an instance of the a LinkCollection class, copying the given collection.

public LinkCollection(LinkCollection);

Initializes an instance of the a LinkCollection class, wrapping the given array of Link (from the com.starbase.starteam namespace).

public LinkCollection(Link[]);

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection Constructor ()

Initializes an instance of the LinkCollection class.

public LinkCollection();

See Also

LinkCollection Class | Borland.StarTeam Namespace | LinkCollection Constructor Overload List


LinkCollection Constructor (Link[])

Initializes an instance of the a LinkCollection class, wrapping the given array of Link (from the com.starbase.starteam namespace).

public LinkCollection(
Link[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

LinkCollection Class | Borland.StarTeam Namespace | LinkCollection Constructor Overload List | Wrap


LinkCollection Constructor (LinkCollection)

Initializes an instance of the a LinkCollection class, copying the given collection.

public LinkCollection(
LinkCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Link objects of the original collection are shared, not copied.

See Also

LinkCollection Class | Borland.StarTeam Namespace | LinkCollection Constructor Overload List


LinkCollection Constructor (Link[])

Initializes an instance of the a LinkCollection class, copying the given array.

public LinkCollection(
Link[] array
);

Parameters

array
The array to be copied.

Remarks

The member Link objects of the original array are shared, not copied.

See Also

LinkCollection Class | Borland.StarTeam Namespace | LinkCollection Constructor Overload List


LinkCollection Properties

The properties of the LinkCollection class are listed below. For a complete list of LinkCollection class members, see the LinkCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the Link at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LinkCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

LinkCollection.Item Property

Gets or sets the Link at the specified index.

public Link this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Link to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection Methods

The methods of the LinkCollection class are listed below. For a complete list of LinkCollection class members, see the LinkCollection Members topic.

Public Static Methods

Wrap Creates a LinkCollection to represent the given array of Link (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a Link to end of the collection.
Append | Overloaded. Appends the Links of the given LinkCollection to the end of this LinkCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Link.
CopyTo | Copies all of the Links in the LinkCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Link with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Link in the collection.
Insert | Inserts a Link into the collection at the specified position.
Remove | Removes the first occurrence of a specific Link from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Links in this LinkCollection.
Sort | Sorts the Links in this LinkCollection, using the given comparer.
SortByID | Sorts the Links in this LinkCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.Add Method

Adds a Link to end of the collection.

public int Add(
Link value
);

Parameters

value
The Link to add to the collection.

Return Value

The position into which the new Link was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

LinkCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

LinkCollection.Append Method

Appends the Links of the given array to the end of this LinkCollection.

Overload List

Appends the Links of the given array to the end of this LinkCollection.

public LinkCollection Append(Link[]);

Appends the Links of the given LinkCollection to the end of this LinkCollection.

public LinkCollection Append(LinkCollection);

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.Append Method (Link[])

Appends the Links of the given array to the end of this LinkCollection.

public LinkCollection Append(
Link[] array
);

Parameters

array
The array whose Links are to be appended to this LinkCollection.

Return Value

This LinkCollection, modified to include the new Links.

Remarks

The LinkCollection is modified to include the new members. The individual Link objects are shared, not copied.

See Also

LinkCollection Class | Borland.StarTeam Namespace | LinkCollection.Append Overload List


LinkCollection.Append Method (LinkCollection)

Appends the Links of the given LinkCollection to the end of this LinkCollection.

public LinkCollection Append(
LinkCollection collection
);

Parameters

collection
The LinkCollection whose Links are to be appended to this LinkCollection.

Return Value

This LinkCollection, modified to include the new Links.

Remarks

The LinkCollection is modified to include the new members. The individual Link objects are shared, not copied.

See Also

LinkCollection Class | Borland.StarTeam Namespace | LinkCollection.Append Overload List


LinkCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.Link[].

Implements

IWrapper.Unwrap

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.Contains Method

Determines whether or not the collection contains a specific Link.

public bool Contains(
Link value
);

Parameters

value
The Link to locate in the collection.

Return Value

true if the Link is found in the collection; otherwise, false.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.CopyTo Method

Copies all of the Links in the LinkCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Link[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Links copied from the LinkCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Links in the source LinkCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source LinkCollection cannot be cast automatically to the type of the destination array.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.FindByID Method

Finds the Link with the given ID.

public Link FindByID(
Int32 id
);

Parameters

id
The ID of the Link to be found.

Return Value

The Link with the given ID, or null if there is no Link with that ID in this LinkCollection.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.IndexOf Method

Determines the index of a specific Link in the collection.

public int IndexOf(
Link value
);

Parameters

value
The Link to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.Insert Method

Inserts a Link into the collection at the specified position.

public void Insert(
Int32 index,
Link value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Link to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.Remove Method

Removes the first occurrence of a specific Link from the collection.

public void Remove(
Link value
);

Parameters

value
The Link to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.Reverse Method

Reverses the order of the Links in this LinkCollection.

new public LinkCollection Reverse();

Return Value

This LinkCollection, modified such that the Links are reversed.

Remarks

The LinkCollection is modified in place.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.Sort Method

Sorts the Links in this LinkCollection, using the given comparer.

new public LinkCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Links.

Return Value

This LinkCollection, modified such that the Links are sorted.

Remarks

The LinkCollection is modified in place.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.SortByID Method

Sorts the Links in this LinkCollection by ID.

public LinkCollection SortByID();

Return Value

This LinkCollection, modified such that the Links are sorted by ID.

Remarks

The LinkCollection is modified in place.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection.Wrap Method

Creates a LinkCollection to represent the given array of Link (from the com.starbase.starteam namespace).

public static LinkCollection Wrap(
Link[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new LinkCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a Link[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection Type Conversions

The type conversions of the LinkCollection class are listed below. For a complete list of LinkCollection class members, see the LinkCollection Members topic.

Public Static Type Conversions

Implicit LinkCollection to Link[] Conversion | Converts a LinkCollection to an array of Links.
Implicit LinkCollection to Link[] Conversion | Converts a LinkCollection from the Borland.StarTeam namespace to a Link[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LinkCollection Class | LinkCollection Members | Borland.StarTeam Namespace


LinkCollection Implicit LinkCollection to Link[] Conversion

Converts a LinkCollection to an array of Links.

public static implicit operator Link[](
LinkCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Link wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Link wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkCollection Implicit LinkCollection to Link[] Conversion

Converts a LinkCollection from the Borland.StarTeam namespace to a Link[] in the com.starbase.starteam namespace.

public static implicit operator Link[](
LinkCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, LinkCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

LinkCollection Class | Borland.StarTeam Namespace


LinkEndpoint Class

Represents a link reference to an item.

For a list of all members of this type, see LinkEndpoint Members.

System.Object
LinkEndpoint

public class LinkEndpoint : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LinkEndpoint Members | Borland.StarTeam Namespace


LinkEndpoint Members

LinkEndpoint overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LinkEndpoint.

Public Static Type Conversions

Implicit LinkEndpoint to LinkEndpoint Conversion Implicitly convert LinkEndpoint to com.starbase.starteam.LinkEndpoint.

Public Instance Constructors

LinkEndpoint Constructor Construct LinkEndpoint from com.starbase.starteam.LinkEndpoint.

Public Instance Properties

DebugString | [read] a debug string representation of this link endpoint.
DotNotation | [read] the dot notation for the item referenced by this link if the endpoint is pinned. Not meaningful if the endpoint is not pinned.
FolderObjectID | [read] the object ID for the parent folder of the linked item.
IsPinned | [read] true if this link endpoint is pinned to a specific revision.
Item | [read] The link endpoint, resolved to a new "disembodied" Item.
ItemID | [read] the itemID of the item being referenced
ObjectID | [read] the object ID for the referenced item. Note that this value is only meaningful if the endpoint is pinned. The value may be -1 if the endpoint is not pinned, or may in fact be an object ID if this is the "child" endpoint of the link. In any case, always check the value of the"Pinned" property to determine whether the endpoint is pinned before relying on this value.
RevisionNumber | [read] the revision number for the specific revision of a pinned endpoint, or -1 if the endpoint is not pinned.
Type | [read] the type of item being referenced
ViewID | [read] the view ID in which the referenced item exists.

Public Instance Methods

Copy | Copies this link endpoint, creating a new one with the same content.
Equals | Delegate Equals() to com.starbase.starteam.LinkEndpoint.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.LinkEndpoint.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Determines whether or not the contents of two link endpoints are the same.
ToString | Delegate ToString() to com.starbase.starteam.LinkEndpoint.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkEndpoint Constructor

Construct LinkEndpoint from com.starbase.starteam.LinkEndpoint.

public LinkEndpoint(
LinkEndpoint impl
);

Parameters

impl
The com.starbase.starteam.LinkEndpoint to be wrapped.

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkEndpoint Properties

The properties of the LinkEndpoint class are listed below. For a complete list of LinkEndpoint class members, see the LinkEndpoint Members topic.

Public Instance Properties

DebugString | [read] a debug string representation of this link endpoint.
DotNotation | [read] the dot notation for the item referenced by this link if the endpoint is pinned. Not meaningful if the endpoint is not pinned.
FolderObjectID | [read] the object ID for the parent folder of the linked item.
IsPinned | [read] true if this link endpoint is pinned to a specific revision.
Item | [read] The link endpoint, resolved to a new "disembodied" Item.
ItemID | [read] the itemID of the item being referenced
ObjectID | [read] the object ID for the referenced item. Note that this value is only meaningful if the endpoint is pinned. The value may be -1 if the endpoint is not pinned, or may in fact be an object ID if this is the "child" endpoint of the link. In any case, always check the value of the"Pinned" property to determine whether the endpoint is pinned before relying on this value.
RevisionNumber | [read] the revision number for the specific revision of a pinned endpoint, or -1 if the endpoint is not pinned.
Type | [read] the type of item being referenced
ViewID | [read] the view ID in which the referenced item exists.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

LinkEndpoint.DebugString Property

[read] a debug string representation of this link endpoint.

public virtual String DebugString {get;}

Property Value

a debug string representation of this link endpoint.

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

LinkEndpoint.DotNotation Property

[read] the dot notation for the item referenced by this link if the endpoint is pinned. Not meaningful if the endpoint is not pinned.

public virtual String DotNotation {get;}

Property Value

the dot notation for the item referenced by this link if the endpoint is pinned. Not meaningful if the endpoint is not pinned.

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


FolderObjectID Property

Borland StarTeam SDK for .NET

LinkEndpoint.FolderObjectID Property

[read] the object ID for the parent folder of the linked item.

public virtual Int32 FolderObjectID {get;}

Property Value

the object ID for the parent folder of the linked item.

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

LinkEndpoint.IsPinned Property

[read] true if this link endpoint is pinned to a specific revision.

public virtual Boolean IsPinned {get;}

Property Value

true if this link endpoint is pinned to a specific revision.

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

LinkEndpoint.Item Property

[read] The link endpoint, resolved to a new "disembodied" Item.

public virtual Item Item {get;}

Property Value

The link endpoint, resolved to a new "disembodied" Item.

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


ItemID Property

Borland StarTeam SDK for .NET

LinkEndpoint.ItemID Property

[read] the itemID of the item being referenced

public virtual Int32 ItemID {get;}

Property Value

the itemID of the item being referenced

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

LinkEndpoint.ObjectID Property

[read] the object ID for the referenced item. Note that this value is only meaningful if the endpoint is pinned. The value may be -1 if the endpoint is not pinned, or may in fact be an object ID if this is the "child" endpoint of the link. In any case, always check the value of the"Pinned" property to determine whether the endpoint is pinned before relying on this value.

public virtual Int32 ObjectID {get;}

Property Value

the object ID for the referenced item. Note that this value is only meaningful if the endpoint is pinned. The value may be -1 if the endpoint is not pinned, or may in fact be an object ID if this is the "child" endpoint of the link. In any case, always check the value of the"Pinned" property to determine whether the endpoint is pinned before relying on this value.

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

LinkEndpoint.RevisionNumber Property

[read] the revision number for the specific revision of a pinned endpoint, or -1 if the endpoint is not pinned.

public virtual Int32 RevisionNumber {get;}

Property Value

the revision number for the specific revision of a pinned endpoint, or -1 if the endpoint is not pinned.

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

LinkEndpoint.Type Property

[read] the type of item being referenced

public virtual Type Type {get;}

Property Value

the type of item being referenced

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


ViewID Property

Borland StarTeam SDK for .NET

LinkEndpoint.ViewID Property

[read] the view ID in which the referenced item exists.

public virtual Int32 ViewID {get;}

Property Value

the view ID in which the referenced item exists.

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkEndpoint Methods

The methods of the LinkEndpoint class are listed below. For a complete list of LinkEndpoint class members, see the LinkEndpoint Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LinkEndpoint.

Public Instance Methods

Copy | Copies this link endpoint, creating a new one with the same content.
Equals | Delegate Equals() to com.starbase.starteam.LinkEndpoint.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.LinkEndpoint.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Determines whether or not the contents of two link endpoints are the same.
ToString | Delegate ToString() to com.starbase.starteam.LinkEndpoint.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkEndpoint.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.LinkEndpoint

Implements

IWrapper.Unwrap

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkEndpoint.Copy Method

Copies this link endpoint, creating a new one with the same content.

public virtual LinkEndpoint Copy();

Return Value

A new copy of this link endpoint.

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkEndpoint.Equals Method

Delegate Equals() to com.starbase.starteam.LinkEndpoint.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.LinkEndpoint.Equals(obj).

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkEndpoint.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.LinkEndpoint.

public override int GetHashCode();

Return Value

com.starbase.starteam.LinkEndpoint.GetHashCode().

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkEndpoint.IsEqualTo Method

Determines whether or not the contents of two link endpoints are the same.

public virtual bool IsEqualTo(
LinkEndpoint other
);

Parameters

other
The link endpoint to be compared to this one.

Return Value

true if the link endpoints are the same; false otherwise.

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkEndpoint.ToString Method

Delegate ToString() to com.starbase.starteam.LinkEndpoint.

public override string ToString();

Return Value

com.starbase.starteam.LinkEndpoint.ToString()

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkEndpoint.Wrap Method

Dynamically wraps com.starbase.starteam.LinkEndpoint.

public static LinkEndpoint Wrap(
LinkEndpoint impl
);

Parameters

impl
com.starbase.starteam.LinkEndpoint to be wrapped.

Return Value

LinkEndpoint

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkEndpoint Type Conversions

The type conversions of the LinkEndpoint class are listed below. For a complete list of LinkEndpoint class members, see the LinkEndpoint Members topic.

Public Static Type Conversions

Implicit LinkEndpoint to LinkEndpoint Conversion Implicitly convert LinkEndpoint to com.starbase.starteam.LinkEndpoint.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LinkEndpoint Class | LinkEndpoint Members | Borland.StarTeam Namespace


LinkEndpoint Implicit LinkEndpoint to LinkEndpoint Conversion

Implicitly convert LinkEndpoint to com.starbase.starteam.LinkEndpoint.

public static implicit operator LinkEndpoint(
LinkEndpoint arg
);

Parameters

arg
LinkEndpoint to convert.

Return Value

com.starbase.starteam.LinkEndpoint

See Also

LinkEndpoint Class | Borland.StarTeam Namespace


LinkFactory Class

Supports bulk link creation, on servers that support it.

For a list of all members of this type, see LinkFactory Members.

System.Object
LinkFactory

public class LinkFactory : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LinkFactory Members | Borland.StarTeam Namespace


LinkFactory Members

LinkFactory overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LinkFactory.

Public Static Type Conversions

Implicit LinkFactory to LinkFactory Conversion Implicitly convert LinkFactory to com.starbase.starteam.LinkFactory.

Public Instance Constructors

LinkFactory Overloaded. Initializes a new instance of the LinkFactory class.

Public Instance Methods

CreateLink | Overloaded. Creates a new link object. The link is not actually created in the StarTeam repository until updateAll() is called.
Equals | Delegate Equals() to com.starbase.starteam.LinkFactory.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.LinkFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
LinkAndPin | Creates a new link between two items and pins the link endpoints to the specified item revisions. The link is not actually created in the StarTeam repository until updateAll() is called.
ToString | Delegate ToString() to com.starbase.starteam.LinkFactory.
UpdateAll | Saves the links created by this LinkFactory. For servers that support bulk link creation, the number of commands issued is minimized.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LinkFactory Class | Borland.StarTeam Namespace


LinkFactory Constructor

Construct LinkFactory from com.starbase.starteam.LinkFactory.

Overload List

Creates a LinkFactory.

public LinkFactory();

Construct LinkFactory from com.starbase.starteam.LinkFactory.

public LinkFactory(LinkFactory);

See Also

LinkFactory Class | Borland.StarTeam Namespace


LinkFactory Constructor (LinkFactory)

Construct LinkFactory from com.starbase.starteam.LinkFactory.

public LinkFactory(
LinkFactory impl
);

Parameters

impl
The com.starbase.starteam.LinkFactory to be wrapped.

See Also

LinkFactory Class | Borland.StarTeam Namespace | LinkFactory Constructor Overload List


LinkFactory Constructor ()

Creates a LinkFactory.

public LinkFactory();

See Also

LinkFactory Class | Borland.StarTeam Namespace | LinkFactory Constructor Overload List


LinkFactory Methods

The methods of the LinkFactory class are listed below. For a complete list of LinkFactory class members, see the LinkFactory Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LinkFactory.

Public Instance Methods

CreateLink | Overloaded. Creates a new link object. The link is not actually created in the StarTeam repository until updateAll() is called.
Equals | Delegate Equals() to com.starbase.starteam.LinkFactory.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.LinkFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
LinkAndPin | Creates a new link between two items and pins the link endpoints to the specified item revisions. The link is not actually created in the StarTeam repository until updateAll() is called.
ToString | Delegate ToString() to com.starbase.starteam.LinkFactory.
UpdateAll | Saves the links created by this LinkFactory. For servers that support bulk link creation, the number of commands issued is minimized.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LinkFactory Class | Borland.StarTeam Namespace


LinkFactory.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.LinkFactory

Implements

IWrapper.Unwrap

See Also

LinkFactory Class | Borland.StarTeam Namespace


CreateLink Method

Borland StarTeam SDK for .NET

LinkFactory.CreateLink Method

Creates a new link object. The link is not actually created in the StarTeam repository until updateAll() is called.

Overload List

Creates a new link object. The link is not actually created in the StarTeam repository until updateAll() is called.

public virtual Link CreateLink(Item,Item);

Creates a new link object. The link is not actually created in the StarTeam repository until updateAll() is called.

public virtual Link CreateLink(Item,Int32,Item,Int32);

See Also

LinkFactory Class | Borland.StarTeam Namespace | updateAll


LinkFactory.CreateLink Method (Item, Item)

Creates a new link object. The link is not actually created in the StarTeam repository until updateAll() is called.

public virtual Link CreateLink(
Item parent,
Item child
);

Parameters

parent
The parent end of the link. The link becomes visible at the first revision of this item's branch.
child
The child end of the link. The link becomes visible at the first revision of this item's branch.

Return Value

The resulting link object, not yet created in the StarTeam repository.

See Also

LinkFactory Class | Borland.StarTeam Namespace | LinkFactory.CreateLink Overload List | updateAll


LinkFactory.CreateLink Method (Item, Int32, Item, Int32)

Creates a new link object. The link is not actually created in the StarTeam repository until updateAll() is called.

public virtual Link CreateLink(
Item parent,
Int32 parentRevision,
Item child,
Int32 childRevision
);

Parameters

parent
The parent end of the link.
parentRevision
The revision number of the first revision in the parent item's history for which this link is visible. If the value is -1, defaults to the first revision in the parent item's branch.
child
The child end of the link.
childRevision
The revision number of the first revision in the child item's history for which this link is visible. If the value is -1, defaults to the first revision in the child item's branch.

Return Value

The resulting link object, not yet created in the StarTeam repository.

See Also

LinkFactory Class | Borland.StarTeam Namespace | LinkFactory.CreateLink Overload List | updateAll


LinkFactory.Equals Method

Delegate Equals() to com.starbase.starteam.LinkFactory.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.LinkFactory.Equals(obj).

See Also

LinkFactory Class | Borland.StarTeam Namespace


LinkFactory.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.LinkFactory.

public override int GetHashCode();

Return Value

com.starbase.starteam.LinkFactory.GetHashCode().

See Also

LinkFactory Class | Borland.StarTeam Namespace


LinkFactory.LinkAndPin Method

Creates a new link between two items and pins the link endpoints to the specified item revisions. The link is not actually created in the StarTeam repository until updateAll() is called.

public virtual Link LinkAndPin(
Item parent,
Item child,
String comment,
Boolean updateExistingLink
);

Parameters

parent
The parent endpoint of the link.
child
The child endpoint of the link.
comment
The link comment.
updateExistingLink
If true this will modify a link that already exists between the two items rather than creating a new link.

Return Value

The resulting link object, not yet created in the StarTeam repository.

See Also

LinkFactory Class | Borland.StarTeam Namespace | updateAll


LinkFactory.ToString Method

Delegate ToString() to com.starbase.starteam.LinkFactory.

public override string ToString();

Return Value

com.starbase.starteam.LinkFactory.ToString()

See Also

LinkFactory Class | Borland.StarTeam Namespace


LinkFactory.UpdateAll Method

Saves the links created by this LinkFactory. For servers that support bulk link creation, the number of commands issued is minimized.

public virtual void UpdateAll();

See Also

LinkFactory Class | Borland.StarTeam Namespace


LinkFactory.Wrap Method

Dynamically wraps com.starbase.starteam.LinkFactory.

public static LinkFactory Wrap(
LinkFactory impl
);

Parameters

impl
com.starbase.starteam.LinkFactory to be wrapped.

Return Value

LinkFactory

See Also

LinkFactory Class | Borland.StarTeam Namespace


LinkFactory Type Conversions

The type conversions of the LinkFactory class are listed below. For a complete list of LinkFactory class members, see the LinkFactory Members topic.

Public Static Type Conversions

Implicit LinkFactory to LinkFactory Conversion Implicitly convert LinkFactory to com.starbase.starteam.LinkFactory.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LinkFactory Class | LinkFactory Members | Borland.StarTeam Namespace


LinkFactory Implicit LinkFactory to LinkFactory Conversion

Implicitly convert LinkFactory to com.starbase.starteam.LinkFactory.

public static implicit operator LinkFactory(
LinkFactory arg
);

Parameters

arg
LinkFactory to convert.

Return Value

com.starbase.starteam.LinkFactory

See Also

LinkFactory Class | Borland.StarTeam Namespace


LinkUpdateEventArgs Class

For a list of all members of this type, see LinkUpdateEventArgs Members.

System.Object
EventArgs
LinkUpdateEventArgs

public class LinkUpdateEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LinkUpdateEventArgs Members | Borland.StarTeam Namespace


LinkUpdateEventArgs Members

LinkUpdateEventArgs overview

Public Static Type Conversions

Implicit LinkUpdateEventArgs to LinkUpdateEvent Conversion Implicitly convert LinkUpdateEventArgs to com.starbase.starteam.LinkUpdateEvent.

Public Instance Properties

NewLink | [read] The Link in its new state.
OldLink | [read] The Link in its old state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

LinkUpdateEventArgs Class | Borland.StarTeam Namespace


LinkUpdateEventArgs Properties

The properties of the LinkUpdateEventArgs class are listed below. For a complete list of LinkUpdateEventArgs class members, see the LinkUpdateEventArgs Members topic.

Public Instance Properties

NewLink | [read] The Link in its new state.
OldLink | [read] The Link in its old state.

See Also

LinkUpdateEventArgs Class | Borland.StarTeam Namespace


NewLink Property

Borland StarTeam SDK for .NET

LinkUpdateEventArgs.NewLink Property

[read] The Link in its new state.

public virtual Link NewLink {get;}

Property Value

The Link in its new state.

See Also

LinkUpdateEventArgs Class | Borland.StarTeam Namespace


OldLink Property

Borland StarTeam SDK for .NET

LinkUpdateEventArgs.OldLink Property

[read] The Link in its old state.

public virtual Link OldLink {get;}

Property Value

The Link in its old state.

See Also

LinkUpdateEventArgs Class | Borland.StarTeam Namespace


LinkUpdateEventArgs Methods

The methods of the LinkUpdateEventArgs class are listed below. For a complete list of LinkUpdateEventArgs class members, see the LinkUpdateEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

LinkUpdateEventArgs Class | Borland.StarTeam Namespace


LinkUpdateEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

LinkUpdateEventArgs Class | Borland.StarTeam Namespace


LinkUpdateEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

LinkUpdateEventArgs Class | Borland.StarTeam Namespace


LinkUpdateEventArgs.ToString Method

public override string ToString();

See Also

LinkUpdateEventArgs Class | Borland.StarTeam Namespace


LinkUpdateEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

LinkUpdateEventArgs Class | Borland.StarTeam Namespace


LinkUpdateEventArgs Type Conversions

The type conversions of the LinkUpdateEventArgs class are listed below. For a complete list of LinkUpdateEventArgs class members, see the LinkUpdateEventArgs Members topic.

Public Static Type Conversions

Implicit LinkUpdateEventArgs to LinkUpdateEvent Conversion Implicitly convert LinkUpdateEventArgs to com.starbase.starteam.LinkUpdateEvent.

See Also

LinkUpdateEventArgs Class | LinkUpdateEventArgs Members | Borland.StarTeam Namespace


LinkUpdateEventArgs Implicit LinkUpdateEventArgs to LinkUpdateEvent Conversion

Implicitly convert LinkUpdateEventArgs to com.starbase.starteam.LinkUpdateEvent.

public static implicit operator LinkUpdateEvent(
LinkUpdateEventArgs arg
);

Parameters

arg
LinkUpdateEventArgs to convert.

Return Value

com.starbase.starteam.LinkUpdateEvent

See Also

LinkUpdateEventArgs Class | Borland.StarTeam Namespace


LinkUpdateEventSource Class

For a list of all members of this type, see LinkUpdateEventSource Members.

System.Object
LinkUpdateEventSource

public class LinkUpdateEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LinkUpdateEventSource Members | Borland.StarTeam Namespace


LinkUpdateEventSource Members

LinkUpdateEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

LinkAdded
LinkChanged
LinkRemoved
OnLinkAdded
OnLinkChanged
OnLinkRemoved

See Also

LinkUpdateEventSource Class | Borland.StarTeam Namespace


LinkUpdateEventSource Properties

The properties of the LinkUpdateEventSource class are listed below. For a complete list of LinkUpdateEventSource class members, see the LinkUpdateEventSource Members topic.

Public Instance Properties

Parent

See Also

LinkUpdateEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

LinkUpdateEventSource.Parent Property

public Object Parent {get;}

See Also

LinkUpdateEventSource Class | Borland.StarTeam Namespace


LinkUpdateEventSource Events

The events of the LinkUpdateEventSource class are listed below. For a complete list of LinkUpdateEventSource class members, see the LinkUpdateEventSource Members topic.

Public Instance Events

LinkAdded
LinkChanged
LinkRemoved
OnLinkAdded
OnLinkChanged
OnLinkRemoved

See Also

LinkUpdateEventSource Class | Borland.StarTeam Namespace


LinkUpdateEventSource.LinkAdded Event

public event LinkUpdateEventSource.Handler LinkAdded;

See Also

LinkUpdateEventSource Class | Borland.StarTeam Namespace


LinkUpdateEventSource.LinkChanged Event

public event LinkUpdateEventSource.Handler LinkChanged;

See Also

LinkUpdateEventSource Class | Borland.StarTeam Namespace


LinkUpdateEventSource.LinkRemoved Event

public event LinkUpdateEventSource.Handler LinkRemoved;

See Also

LinkUpdateEventSource Class | Borland.StarTeam Namespace


LinkUpdateEventSource.OnLinkAdded Event

public event LinkUpdateEventSource.Handler OnLinkAdded;

See Also

LinkUpdateEventSource Class | Borland.StarTeam Namespace


LinkUpdateEventSource.OnLinkChanged Event

public event LinkUpdateEventSource.Handler OnLinkChanged;

See Also

LinkUpdateEventSource Class | Borland.StarTeam Namespace


LinkUpdateEventSource.OnLinkRemoved Event

public event LinkUpdateEventSource.Handler OnLinkRemoved;

See Also

LinkUpdateEventSource Class | Borland.StarTeam Namespace


LinkUpdateEventSource.Handler Delegate

public delegate void LinkUpdateEventSource.Handler(
LinkUpdateEventSource source,
LinkUpdateEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


LogKeyword Class

An implementation of the StarTeam $Log$ keyword.

For a list of all members of this type, see LogKeyword Members.

System.Object
SimpleKeyword
LogKeyword

public class LogKeyword : SimpleKeyword

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LogKeyword Members | Borland.StarTeam Namespace


LogKeyword Members

LogKeyword overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LogKeyword.

Public Static Type Conversions

Implicit LogKeyword to LogKeyword Conversion Implicitly convert LogKeyword to com.starbase.starteam.LogKeyword.

Public Instance Constructors

LogKeyword Overloaded. Initializes a new instance of the LogKeyword class.

Public Instance Properties

IsMultiLine (inherited from SimpleKeyword)
Name (inherited from SimpleKeyword)
StopExpanding (inherited from SimpleKeyword)
Value (inherited from SimpleKeyword)
XMLString (inherited from SimpleKeyword)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from SimpleKeyword) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches (inherited from SimpleKeyword) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LogKeyword Class | Borland.StarTeam Namespace


LogKeyword Constructor

Construct LogKeyword from com.starbase.starteam.LogKeyword.

Overload List

Constructs a $Log$ keyword using the specified log entries.

public LogKeyword(LogLineCollection);

Constructs a $Log$ keyword using the specified log entries. If the utcDates parameter is true the keyword will be $LogUTC$ and all dates will be written in UTC format.

public LogKeyword(LogLineCollection,Boolean);

Construct LogKeyword from com.starbase.starteam.LogKeyword.

public LogKeyword(LogKeyword);

See Also

LogKeyword Class | Borland.StarTeam Namespace


LogKeyword Constructor (LogKeyword)

Construct LogKeyword from com.starbase.starteam.LogKeyword.

public LogKeyword(
LogKeyword impl
);

Parameters

impl
The com.starbase.starteam.LogKeyword to be wrapped.

See Also

LogKeyword Class | Borland.StarTeam Namespace | LogKeyword Constructor Overload List


LogKeyword Constructor (LogLineCollection)

Constructs a $Log$ keyword using the specified log entries.

public LogKeyword(
LogLineCollection logLines
);

Parameters

logLines
the log lines that make up this $Log$ keyword.

See Also

LogKeyword Class | Borland.StarTeam Namespace | LogKeyword Constructor Overload List


LogKeyword Constructor (LogLineCollection, Boolean)

Constructs a $Log$ keyword using the specified log entries. If the utcDates parameter is true the keyword will be $LogUTC$ and all dates will be written in UTC format.

public LogKeyword(
LogLineCollection logLines,
Boolean utcDates
);

Parameters

logLines
the log lines that make up this $Log$ keyword.
utcDates
if true will format dates in UTC format

See Also

LogKeyword Class | Borland.StarTeam Namespace | LogKeyword Constructor Overload List


LogKeyword Methods

The methods of the LogKeyword class are listed below. For a complete list of LogKeyword class members, see the LogKeyword Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LogKeyword.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from SimpleKeyword) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches (inherited from SimpleKeyword) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LogKeyword Class | Borland.StarTeam Namespace


LogKeyword.Wrap Method

Dynamically wraps com.starbase.starteam.LogKeyword.

public static LogKeyword Wrap(
LogKeyword impl
);

Parameters

impl
com.starbase.starteam.LogKeyword to be wrapped.

Return Value

LogKeyword

See Also

LogKeyword Class | Borland.StarTeam Namespace


LogKeyword Type Conversions

The type conversions of the LogKeyword class are listed below. For a complete list of LogKeyword class members, see the LogKeyword Members topic.

Public Static Type Conversions

Implicit LogKeyword to LogKeyword Conversion Implicitly convert LogKeyword to com.starbase.starteam.LogKeyword.

See Also

LogKeyword Class | LogKeyword Members | Borland.StarTeam Namespace


LogKeyword Implicit LogKeyword to LogKeyword Conversion

Implicitly convert LogKeyword to com.starbase.starteam.LogKeyword.

public static implicit operator LogKeyword(
LogKeyword arg
);

Parameters

arg
LogKeyword to convert.

Return Value

com.starbase.starteam.LogKeyword

See Also

LogKeyword Class | Borland.StarTeam Namespace


LogLine Class

A class containing information specific to a single version entry for expansion of the $Log$ keyword.

For a list of all members of this type, see LogLine Members.

System.Object
LogLine
HistoryLine

public class LogLine : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LogLine Members | Borland.StarTeam Namespace


LogLine Members

LogLine overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LogLine.

Public Static Type Conversions

Implicit LogLine to LogLine Conversion Implicitly convert LogLine to com.starbase.starteam.LogLine.

Public Instance Constructors

LogLine Overloaded. Initializes a new instance of the LogLine class.

Public Instance Properties

XMLString [read] an XML representation of this log line entry

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.LogLine.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.LogLine.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.LogLine.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LogLine Class | Borland.StarTeam Namespace


LogLine Constructor

Construct LogLine from com.starbase.starteam.LogLine.

Overload List

Construct LogLine from com.starbase.starteam.LogLine.

public LogLine(LogLine);

Creates new information for a single $Log keyword entry. Each revision of a file will have its own LogLine.

public LogLine(Int32,String,String,DateTime,String,String);

See Also

LogLine Class | Borland.StarTeam Namespace


LogLine Constructor (LogLine)

Construct LogLine from com.starbase.starteam.LogLine.

public LogLine(
LogLine impl
);

Parameters

impl
The com.starbase.starteam.LogLine to be wrapped.

See Also

LogLine Class | Borland.StarTeam Namespace | LogLine Constructor Overload List


LogLine Constructor (Int32, String, String, DateTime, String, String)

Creates new information for a single $Log keyword entry. Each revision of a file will have its own LogLine.

public LogLine(
Int32 version,
String viewName,
String dotNotation,
DateTime date,
String author,
String comment
);

Parameters

version
the version number for the revision
viewName
the name of the view in which the revision was created
dotNotation
the dot notation for the revision (for example "1.2.3.0")
date
the time at which the revision was created
author
the name of the author of the revision
comment
the version number for the revision

See Also

LogLine Class | Borland.StarTeam Namespace | LogLine Constructor Overload List


LogLine Properties

The properties of the LogLine class are listed below. For a complete list of LogLine class members, see the LogLine Members topic.

Public Instance Properties

XMLString [read] an XML representation of this log line entry

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LogLine Class | Borland.StarTeam Namespace


XMLString Property

Borland StarTeam SDK for .NET

LogLine.XMLString Property

[read] an XML representation of this log line entry

public virtual String XMLString {get;}

Property Value

an XML representation of this log line entry

See Also

LogLine Class | Borland.StarTeam Namespace


LogLine Methods

The methods of the LogLine class are listed below. For a complete list of LogLine class members, see the LogLine Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LogLine.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.LogLine.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.LogLine.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.LogLine.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LogLine Class | Borland.StarTeam Namespace


LogLine.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.LogLine

Implements

IWrapper.Unwrap

See Also

LogLine Class | Borland.StarTeam Namespace


LogLine.Equals Method

Delegate Equals() to com.starbase.starteam.LogLine.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.LogLine.Equals(obj).

See Also

LogLine Class | Borland.StarTeam Namespace


LogLine.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.LogLine.

public override int GetHashCode();

Return Value

com.starbase.starteam.LogLine.GetHashCode().

See Also

LogLine Class | Borland.StarTeam Namespace


LogLine.ToString Method

Delegate ToString() to com.starbase.starteam.LogLine.

public override string ToString();

Return Value

com.starbase.starteam.LogLine.ToString()

See Also

LogLine Class | Borland.StarTeam Namespace


LogLine.Wrap Method

Dynamically wraps com.starbase.starteam.LogLine.

public static LogLine Wrap(
LogLine impl
);

Parameters

impl
com.starbase.starteam.LogLine to be wrapped.

Return Value

LogLine

See Also

LogLine Class | Borland.StarTeam Namespace


LogLine Type Conversions

The type conversions of the LogLine class are listed below. For a complete list of LogLine class members, see the LogLine Members topic.

Public Static Type Conversions

Implicit LogLine to LogLine Conversion Implicitly convert LogLine to com.starbase.starteam.LogLine.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LogLine Class | LogLine Members | Borland.StarTeam Namespace


LogLine Implicit LogLine to LogLine Conversion

Implicitly convert LogLine to com.starbase.starteam.LogLine.

public static implicit operator LogLine(
LogLine arg
);

Parameters

arg
LogLine to convert.

Return Value

com.starbase.starteam.LogLine

See Also

LogLine Class | Borland.StarTeam Namespace


LogLineCollection Class

A strongly-typed collection of LogLines.

For a list of all members of this type, see LogLineCollection Members.

System.Object
ArrayAdapter
LogLineCollection

public class LogLineCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LogLineCollection Members | Borland.StarTeam Namespace


LogLineCollection Members

LogLineCollection overview

Public Static Methods

Wrap Creates a LogLineCollection to represent the given array of LogLine (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit LogLineCollection to LogLine[] Conversion | Converts a LogLineCollection to an array of LogLines.
Implicit LogLineCollection to LogLine[] Conversion | Converts a LogLineCollection from the Borland.StarTeam namespace to a LogLine[] in the com.starbase.starteam namespace.

Public Instance Constructors

LogLineCollection Overloaded. Initializes a new instance of the LogLineCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the LogLine at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a LogLine to end of the collection.
Append | Overloaded. Appends the LogLines of the given LogLineCollection to the end of this LogLineCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific LogLine.
CopyTo | Copies all of the LogLines in the LogLineCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific LogLine in the collection.
Insert | Inserts a LogLine into the collection at the specified position.
Remove | Removes the first occurrence of a specific LogLine from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the LogLines in this LogLineCollection.
Sort | Sorts the LogLines in this LogLineCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection Constructor

Initializes an instance of the LogLineCollection class.

Overload List

Initializes an instance of the LogLineCollection class.

public LogLineCollection();

Initializes an instance of the a LogLineCollection class, copying the given array.

public LogLineCollection(LogLine[]);

Initializes an instance of the a LogLineCollection class, copying the given collection.

public LogLineCollection(LogLineCollection);

Initializes an instance of the a LogLineCollection class, wrapping the given array of LogLine (from the com.starbase.starteam namespace).

public LogLineCollection(LogLine[]);

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection Constructor ()

Initializes an instance of the LogLineCollection class.

public LogLineCollection();

See Also

LogLineCollection Class | Borland.StarTeam Namespace | LogLineCollection Constructor Overload List


LogLineCollection Constructor (LogLine[])

Initializes an instance of the a LogLineCollection class, wrapping the given array of LogLine (from the com.starbase.starteam namespace).

public LogLineCollection(
LogLine[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

LogLineCollection Class | Borland.StarTeam Namespace | LogLineCollection Constructor Overload List | Wrap


LogLineCollection Constructor (LogLineCollection)

Initializes an instance of the a LogLineCollection class, copying the given collection.

public LogLineCollection(
LogLineCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member LogLine objects of the original collection are shared, not copied.

See Also

LogLineCollection Class | Borland.StarTeam Namespace | LogLineCollection Constructor Overload List


LogLineCollection Constructor (LogLine[])

Initializes an instance of the a LogLineCollection class, copying the given array.

public LogLineCollection(
LogLine[] array
);

Parameters

array
The array to be copied.

Remarks

The member LogLine objects of the original array are shared, not copied.

See Also

LogLineCollection Class | Borland.StarTeam Namespace | LogLineCollection Constructor Overload List


LogLineCollection Properties

The properties of the LogLineCollection class are listed below. For a complete list of LogLineCollection class members, see the LogLineCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the LogLine at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

LogLineCollection.Item Property

Gets or sets the LogLine at the specified index.

public LogLine this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the LogLine to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection Methods

The methods of the LogLineCollection class are listed below. For a complete list of LogLineCollection class members, see the LogLineCollection Members topic.

Public Static Methods

Wrap Creates a LogLineCollection to represent the given array of LogLine (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a LogLine to end of the collection.
Append | Overloaded. Appends the LogLines of the given LogLineCollection to the end of this LogLineCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific LogLine.
CopyTo | Copies all of the LogLines in the LogLineCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific LogLine in the collection.
Insert | Inserts a LogLine into the collection at the specified position.
Remove | Removes the first occurrence of a specific LogLine from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the LogLines in this LogLineCollection.
Sort | Sorts the LogLines in this LogLineCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection.Add Method

Adds a LogLine to end of the collection.

public int Add(
LogLine value
);

Parameters

value
The LogLine to add to the collection.

Return Value

The position into which the new LogLine was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

LogLineCollection.Append Method

Appends the LogLines of the given array to the end of this LogLineCollection.

Overload List

Appends the LogLines of the given array to the end of this LogLineCollection.

public LogLineCollection Append(LogLine[]);

Appends the LogLines of the given LogLineCollection to the end of this LogLineCollection.

public LogLineCollection Append(LogLineCollection);

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection.Append Method (LogLine[])

Appends the LogLines of the given array to the end of this LogLineCollection.

public LogLineCollection Append(
LogLine[] array
);

Parameters

array
The array whose LogLines are to be appended to this LogLineCollection.

Return Value

This LogLineCollection, modified to include the new LogLines.

Remarks

The LogLineCollection is modified to include the new members. The individual LogLine objects are shared, not copied.

See Also

LogLineCollection Class | Borland.StarTeam Namespace | LogLineCollection.Append Overload List


LogLineCollection.Append Method (LogLineCollection)

Appends the LogLines of the given LogLineCollection to the end of this LogLineCollection.

public LogLineCollection Append(
LogLineCollection collection
);

Parameters

collection
The LogLineCollection whose LogLines are to be appended to this LogLineCollection.

Return Value

This LogLineCollection, modified to include the new LogLines.

Remarks

The LogLineCollection is modified to include the new members. The individual LogLine objects are shared, not copied.

See Also

LogLineCollection Class | Borland.StarTeam Namespace | LogLineCollection.Append Overload List


LogLineCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.LogLine[].

Implements

IWrapper.Unwrap

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection.Contains Method

Determines whether or not the collection contains a specific LogLine.

public bool Contains(
LogLine value
);

Parameters

value
The LogLine to locate in the collection.

Return Value

true if the LogLine is found in the collection; otherwise, false.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection.CopyTo Method

Copies all of the LogLines in the LogLineCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
LogLine[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the LogLines copied from the LogLineCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of LogLines in the source LogLineCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source LogLineCollection cannot be cast automatically to the type of the destination array.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection.IndexOf Method

Determines the index of a specific LogLine in the collection.

public int IndexOf(
LogLine value
);

Parameters

value
The LogLine to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection.Insert Method

Inserts a LogLine into the collection at the specified position.

public void Insert(
Int32 index,
LogLine value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The LogLine to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection.Remove Method

Removes the first occurrence of a specific LogLine from the collection.

public void Remove(
LogLine value
);

Parameters

value
The LogLine to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection.Reverse Method

Reverses the order of the LogLines in this LogLineCollection.

new public LogLineCollection Reverse();

Return Value

This LogLineCollection, modified such that the LogLines are reversed.

Remarks

The LogLineCollection is modified in place.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection.Sort Method

Sorts the LogLines in this LogLineCollection, using the given comparer.

new public LogLineCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two LogLines.

Return Value

This LogLineCollection, modified such that the LogLines are sorted.

Remarks

The LogLineCollection is modified in place.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection.Wrap Method

Creates a LogLineCollection to represent the given array of LogLine (from the com.starbase.starteam namespace).

public static LogLineCollection Wrap(
LogLine[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new LogLineCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a LogLine[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection Type Conversions

The type conversions of the LogLineCollection class are listed below. For a complete list of LogLineCollection class members, see the LogLineCollection Members topic.

Public Static Type Conversions

Implicit LogLineCollection to LogLine[] Conversion | Converts a LogLineCollection to an array of LogLines.
Implicit LogLineCollection to LogLine[] Conversion | Converts a LogLineCollection from the Borland.StarTeam namespace to a LogLine[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

LogLineCollection Class | LogLineCollection Members | Borland.StarTeam Namespace


LogLineCollection Implicit LogLineCollection to LogLine[] Conversion

Converts a LogLineCollection to an array of LogLines.

public static implicit operator LogLine[](
LogLineCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new LogLine wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one LogLine wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogLineCollection Implicit LogLineCollection to LogLine[] Conversion

Converts a LogLineCollection from the Borland.StarTeam namespace to a LogLine[] in the com.starbase.starteam namespace.

public static implicit operator LogLine[](
LogLineCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, LogLineCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

LogLineCollection Class | Borland.StarTeam Namespace


LogonException Class

For a list of all members of this type, see LogonException Members.

System.Object
Exception
ServerException
LogonException
PasswordExpiredException

public class LogonException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LogonException Members | Borland.StarTeam Namespace


LogonException Members

LogonException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LogonException.

Public Static Type Conversions

Implicit LogonException to LogonException Conversion Implicitly convert LogonException to com.starbase.starteam.LogonException.

Public Instance Constructors

LogonException Constructor Construct LogonException from com.starbase.starteam.LogonException.

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
IsUserNameValid |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

LogonException Class | Borland.StarTeam Namespace


LogonException Constructor

Construct LogonException from com.starbase.starteam.LogonException.

public LogonException(
LogonException impl
);

Parameters

impl
The com.starbase.starteam.LogonException to be wrapped.

See Also

LogonException Class | Borland.StarTeam Namespace


LogonException Properties

The properties of the LogonException class are listed below. For a complete list of LogonException class members, see the LogonException Members topic.

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
IsUserNameValid |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

LogonException Class | Borland.StarTeam Namespace


IsUserNameValid Property

Borland StarTeam SDK for .NET

LogonException.IsUserNameValid Property

public virtual Boolean IsUserNameValid {get;}

See Also

LogonException Class | Borland.StarTeam Namespace


LogonException Methods

The methods of the LogonException class are listed below. For a complete list of LogonException class members, see the LogonException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.LogonException.

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

LogonException Class | Borland.StarTeam Namespace


LogonException.Wrap Method

Dynamically wraps com.starbase.starteam.LogonException.

public static LogonException Wrap(
LogonException impl
);

Parameters

impl
com.starbase.starteam.LogonException to be wrapped.

Return Value

LogonException

See Also

LogonException Class | Borland.StarTeam Namespace


LogonException Type Conversions

The type conversions of the LogonException class are listed below. For a complete list of LogonException class members, see the LogonException Members topic.

Public Static Type Conversions

Implicit LogonException to LogonException Conversion Implicitly convert LogonException to com.starbase.starteam.LogonException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

LogonException Class | LogonException Members | Borland.StarTeam Namespace


LogonException Implicit LogonException to LogonException Conversion

Implicitly convert LogonException to com.starbase.starteam.LogonException.

public static implicit operator LogonException(
LogonException arg
);

Parameters

arg
LogonException to convert.

Return Value

com.starbase.starteam.LogonException

See Also

LogonException Class | Borland.StarTeam Namespace


MatchedACE Class

Used when explaining the results of an access test.

Each MatchedACE provides a subset of the permissions that were tested, as well as the corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.

For a list of all members of this type, see MatchedACE Members.

System.Object
MatchedACE

public class MatchedACE : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MatchedACE Members | Borland.StarTeam Namespace


MatchedACE Members

MatchedACE overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.MatchedACE.

Public Static Type Conversions

Implicit MatchedACE to MatchedACE Conversion Implicitly convert MatchedACE to com.starbase.starteam.MatchedACE.

Public Instance Constructors

MatchedACE Constructor Construct MatchedACE from com.starbase.starteam.MatchedACE.

Public Instance Properties

EffectiveACE | [read] The corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.
IndexInACL | [read] The index of this ACE in its Effective Access Control List, or -1 if this ACE does not appear in the Effective ACL.
Permissions | [read] A subset of the permissions that were tested.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.MatchedACE.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.MatchedACE.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.MatchedACE.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MatchedACE Class | Borland.StarTeam Namespace


MatchedACE Constructor

Construct MatchedACE from com.starbase.starteam.MatchedACE.

public MatchedACE(
MatchedACE impl
);

Parameters

impl
The com.starbase.starteam.MatchedACE to be wrapped.

See Also

MatchedACE Class | Borland.StarTeam Namespace


MatchedACE Properties

The properties of the MatchedACE class are listed below. For a complete list of MatchedACE class members, see the MatchedACE Members topic.

Public Instance Properties

EffectiveACE | [read] The corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.
IndexInACL | [read] The index of this ACE in its Effective Access Control List, or -1 if this ACE does not appear in the Effective ACL.
Permissions | [read] A subset of the permissions that were tested.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MatchedACE Class | Borland.StarTeam Namespace


EffectiveACE Property

Borland StarTeam SDK for .NET

MatchedACE.EffectiveACE Property

[read] The corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.

public virtual EffectiveACE EffectiveACE {get;}

Property Value

The corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.

See Also

MatchedACE Class | Borland.StarTeam Namespace


IndexInACL Property

Borland StarTeam SDK for .NET

MatchedACE.IndexInACL Property

[read] The index of this ACE in its Effective Access Control List, or -1 if this ACE does not appear in the Effective ACL.

public virtual Int32 IndexInACL {get;}

Property Value

The index of this ACE in its Effective Access Control List, or -1 if this ACE does not appear in the Effective ACL.

See Also

MatchedACE Class | Borland.StarTeam Namespace


Permissions Property

Borland StarTeam SDK for .NET

MatchedACE.Permissions Property

[read] A subset of the permissions that were tested.

public virtual Int32 Permissions {get;}

Property Value

A subset of the permissions that were tested.

See Also

MatchedACE Class | Borland.StarTeam Namespace


MatchedACE Methods

The methods of the MatchedACE class are listed below. For a complete list of MatchedACE class members, see the MatchedACE Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.MatchedACE.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.MatchedACE.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.MatchedACE.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.MatchedACE.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MatchedACE Class | Borland.StarTeam Namespace


MatchedACE.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.MatchedACE

Implements

IWrapper.Unwrap

See Also

MatchedACE Class | Borland.StarTeam Namespace


MatchedACE.Equals Method

Delegate Equals() to com.starbase.starteam.MatchedACE.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.MatchedACE.Equals(obj).

See Also

MatchedACE Class | Borland.StarTeam Namespace


MatchedACE.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.MatchedACE.

public override int GetHashCode();

Return Value

com.starbase.starteam.MatchedACE.GetHashCode().

See Also

MatchedACE Class | Borland.StarTeam Namespace


MatchedACE.ToString Method

Delegate ToString() to com.starbase.starteam.MatchedACE.

public override string ToString();

Return Value

com.starbase.starteam.MatchedACE.ToString()

See Also

MatchedACE Class | Borland.StarTeam Namespace


MatchedACE.Wrap Method

Dynamically wraps com.starbase.starteam.MatchedACE.

public static MatchedACE Wrap(
MatchedACE impl
);

Parameters

impl
com.starbase.starteam.MatchedACE to be wrapped.

Return Value

MatchedACE

See Also

MatchedACE Class | Borland.StarTeam Namespace


MatchedACE Type Conversions

The type conversions of the MatchedACE class are listed below. For a complete list of MatchedACE class members, see the MatchedACE Members topic.

Public Static Type Conversions

Implicit MatchedACE to MatchedACE Conversion Implicitly convert MatchedACE to com.starbase.starteam.MatchedACE.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MatchedACE Class | MatchedACE Members | Borland.StarTeam Namespace


MatchedACE Implicit MatchedACE to MatchedACE Conversion

Implicitly convert MatchedACE to com.starbase.starteam.MatchedACE.

public static implicit operator MatchedACE(
MatchedACE arg
);

Parameters

arg
MatchedACE to convert.

Return Value

com.starbase.starteam.MatchedACE

See Also

MatchedACE Class | Borland.StarTeam Namespace


MatchedACECollection Class

A strongly-typed collection of MatchedACEs.

For a list of all members of this type, see MatchedACECollection Members.

System.Object
ArrayAdapter
MatchedACECollection

public class MatchedACECollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MatchedACECollection Members | Borland.StarTeam Namespace


MatchedACECollection Members

MatchedACECollection overview

Public Static Methods

Wrap Creates a MatchedACECollection to represent the given array of MatchedACE (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit MatchedACECollection to MatchedACE[] Conversion | Converts a MatchedACECollection to an array of MatchedACEs.
Implicit MatchedACECollection to MatchedACE[] Conversion | Converts a MatchedACECollection from the Borland.StarTeam namespace to a MatchedACE[] in the com.starbase.starteam namespace.

Public Instance Constructors

MatchedACECollection Overloaded. Initializes a new instance of the MatchedACECollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the MatchedACE at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a MatchedACE to end of the collection.
Append | Overloaded. Appends the MatchedACEs of the given MatchedACECollection to the end of this MatchedACECollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific MatchedACE.
CopyTo | Copies all of the MatchedACEs in the MatchedACECollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific MatchedACE in the collection.
Insert | Inserts a MatchedACE into the collection at the specified position.
Remove | Removes the first occurrence of a specific MatchedACE from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the MatchedACEs in this MatchedACECollection.
Sort | Sorts the MatchedACEs in this MatchedACECollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection Constructor

Initializes an instance of the MatchedACECollection class.

Overload List

Initializes an instance of the MatchedACECollection class.

public MatchedACECollection();

Initializes an instance of the a MatchedACECollection class, copying the given array.

public MatchedACECollection(MatchedACE[]);

Initializes an instance of the a MatchedACECollection class, copying the given collection.

public MatchedACECollection(MatchedACECollection);

Initializes an instance of the a MatchedACECollection class, wrapping the given array of MatchedACE (from the com.starbase.starteam namespace).

public MatchedACECollection(MatchedACE[]);

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection Constructor ()

Initializes an instance of the MatchedACECollection class.

public MatchedACECollection();

See Also

MatchedACECollection Class | Borland.StarTeam Namespace | MatchedACECollection Constructor Overload List


MatchedACECollection Constructor (MatchedACE[])

Initializes an instance of the a MatchedACECollection class, wrapping the given array of MatchedACE (from the com.starbase.starteam namespace).

public MatchedACECollection(
MatchedACE[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace | MatchedACECollection Constructor Overload List | Wrap


MatchedACECollection Constructor (MatchedACECollection)

Initializes an instance of the a MatchedACECollection class, copying the given collection.

public MatchedACECollection(
MatchedACECollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member MatchedACE objects of the original collection are shared, not copied.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace | MatchedACECollection Constructor Overload List


MatchedACECollection Constructor (MatchedACE[])

Initializes an instance of the a MatchedACECollection class, copying the given array.

public MatchedACECollection(
MatchedACE[] array
);

Parameters

array
The array to be copied.

Remarks

The member MatchedACE objects of the original array are shared, not copied.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace | MatchedACECollection Constructor Overload List


MatchedACECollection Properties

The properties of the MatchedACECollection class are listed below. For a complete list of MatchedACECollection class members, see the MatchedACECollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the MatchedACE at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

MatchedACECollection.Item Property

Gets or sets the MatchedACE at the specified index.

public MatchedACE this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the MatchedACE to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection Methods

The methods of the MatchedACECollection class are listed below. For a complete list of MatchedACECollection class members, see the MatchedACECollection Members topic.

Public Static Methods

Wrap Creates a MatchedACECollection to represent the given array of MatchedACE (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a MatchedACE to end of the collection.
Append | Overloaded. Appends the MatchedACEs of the given MatchedACECollection to the end of this MatchedACECollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific MatchedACE.
CopyTo | Copies all of the MatchedACEs in the MatchedACECollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific MatchedACE in the collection.
Insert | Inserts a MatchedACE into the collection at the specified position.
Remove | Removes the first occurrence of a specific MatchedACE from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the MatchedACEs in this MatchedACECollection.
Sort | Sorts the MatchedACEs in this MatchedACECollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection.Add Method

Adds a MatchedACE to end of the collection.

public int Add(
MatchedACE value
);

Parameters

value
The MatchedACE to add to the collection.

Return Value

The position into which the new MatchedACE was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

MatchedACECollection.Append Method

Appends the MatchedACEs of the given array to the end of this MatchedACECollection.

Overload List

Appends the MatchedACEs of the given array to the end of this MatchedACECollection.

public MatchedACECollection Append(MatchedACE[]);

Appends the MatchedACEs of the given MatchedACECollection to the end of this MatchedACECollection.

public MatchedACECollection Append(MatchedACECollection);

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection.Append Method (MatchedACE[])

Appends the MatchedACEs of the given array to the end of this MatchedACECollection.

public MatchedACECollection Append(
MatchedACE[] array
);

Parameters

array
The array whose MatchedACEs are to be appended to this MatchedACECollection.

Return Value

This MatchedACECollection, modified to include the new MatchedACEs.

Remarks

The MatchedACECollection is modified to include the new members. The individual MatchedACE objects are shared, not copied.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace | MatchedACECollection.Append Overload List


MatchedACECollection.Append Method (MatchedACECollection)

Appends the MatchedACEs of the given MatchedACECollection to the end of this MatchedACECollection.

public MatchedACECollection Append(
MatchedACECollection collection
);

Parameters

collection
The MatchedACECollection whose MatchedACEs are to be appended to this MatchedACECollection.

Return Value

This MatchedACECollection, modified to include the new MatchedACEs.

Remarks

The MatchedACECollection is modified to include the new members. The individual MatchedACE objects are shared, not copied.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace | MatchedACECollection.Append Overload List


MatchedACECollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.MatchedACE[].

Implements

IWrapper.Unwrap

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection.Contains Method

Determines whether or not the collection contains a specific MatchedACE.

public bool Contains(
MatchedACE value
);

Parameters

value
The MatchedACE to locate in the collection.

Return Value

true if the MatchedACE is found in the collection; otherwise, false.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection.CopyTo Method

Copies all of the MatchedACEs in the MatchedACECollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
MatchedACE[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the MatchedACEs copied from the MatchedACECollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of MatchedACEs in the source MatchedACECollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source MatchedACECollection cannot be cast automatically to the type of the destination array.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection.IndexOf Method

Determines the index of a specific MatchedACE in the collection.

public int IndexOf(
MatchedACE value
);

Parameters

value
The MatchedACE to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection.Insert Method

Inserts a MatchedACE into the collection at the specified position.

public void Insert(
Int32 index,
MatchedACE value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The MatchedACE to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection.Remove Method

Removes the first occurrence of a specific MatchedACE from the collection.

public void Remove(
MatchedACE value
);

Parameters

value
The MatchedACE to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection.Reverse Method

Reverses the order of the MatchedACEs in this MatchedACECollection.

new public MatchedACECollection Reverse();

Return Value

This MatchedACECollection, modified such that the MatchedACEs are reversed.

Remarks

The MatchedACECollection is modified in place.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection.Sort Method

Sorts the MatchedACEs in this MatchedACECollection, using the given comparer.

new public MatchedACECollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two MatchedACEs.

Return Value

This MatchedACECollection, modified such that the MatchedACEs are sorted.

Remarks

The MatchedACECollection is modified in place.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection.Wrap Method

Creates a MatchedACECollection to represent the given array of MatchedACE (from the com.starbase.starteam namespace).

public static MatchedACECollection Wrap(
MatchedACE[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new MatchedACECollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a MatchedACE[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection Type Conversions

The type conversions of the MatchedACECollection class are listed below. For a complete list of MatchedACECollection class members, see the MatchedACECollection Members topic.

Public Static Type Conversions

Implicit MatchedACECollection to MatchedACE[] Conversion | Converts a MatchedACECollection to an array of MatchedACEs.
Implicit MatchedACECollection to MatchedACE[] Conversion | Converts a MatchedACECollection from the Borland.StarTeam namespace to a MatchedACE[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

MatchedACECollection Class | MatchedACECollection Members | Borland.StarTeam Namespace


MatchedACECollection Implicit MatchedACECollection to MatchedACE[] Conversion

Converts a MatchedACECollection to an array of MatchedACEs.

public static implicit operator MatchedACE[](
MatchedACECollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new MatchedACE wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one MatchedACE wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MatchedACECollection Implicit MatchedACECollection to MatchedACE[] Conversion

Converts a MatchedACECollection from the Borland.StarTeam namespace to a MatchedACE[] in the com.starbase.starteam namespace.

public static implicit operator MatchedACE[](
MatchedACECollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, MatchedACECollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

MatchedACECollection Class | Borland.StarTeam Namespace


MergePoint Class

This class provides information about how two item revisions are related with respect to merging. Suppose the file "foo.txt" branches at revision 1.3 to create a new revision 1.3.1.0. A checkin on the main branch will create revision 1.4 and a subsequent checkin on the alternate branch will create revision 1.3.1.1. If the user then merges the changes between 1.3 to 1.4 in to a new branch revision 1.3.1.2 a MergePoint can be used to record the sources used to create this new revision. In this case the MergePoint would have a source RevisionID corresponding to the 1.4 revision of "foo.txt" and a target RevisionID corresponding to the 1.3.1.2 revision of "foo.txt".

For a list of all members of this type, see MergePoint Members.

System.Object
MergePoint

public class MergePoint : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MergePoint Members | Borland.StarTeam Namespace


MergePoint Members

MergePoint overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.MergePoint.

Public Static Type Conversions

Implicit MergePoint to MergePoint Conversion Implicitly convert MergePoint to com.starbase.starteam.MergePoint.

Public Instance Constructors

MergePoint Overloaded. Initializes a new instance of the MergePoint class.

Public Instance Properties

Source | [read/write] the RevisionID of the merge source.
Target | [read/write] the RevisionID of the merge target.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.MergePoint.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.MergePoint.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.MergePoint.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergePoint Class | Borland.StarTeam Namespace


MergePoint Constructor

Construct MergePoint from com.starbase.starteam.MergePoint.

Overload List

Creates a new MergePoint for the specified source and target RevisionIDs.

public MergePoint(RevisionID,RevisionID);

Construct MergePoint from com.starbase.starteam.MergePoint.

public MergePoint(MergePoint);

See Also

MergePoint Class | Borland.StarTeam Namespace


MergePoint Constructor (MergePoint)

Construct MergePoint from com.starbase.starteam.MergePoint.

public MergePoint(
MergePoint impl
);

Parameters

impl
The com.starbase.starteam.MergePoint to be wrapped.

See Also

MergePoint Class | Borland.StarTeam Namespace | MergePoint Constructor Overload List


MergePoint Constructor (RevisionID, RevisionID)

Creates a new MergePoint for the specified source and target RevisionIDs.

public MergePoint(
RevisionID source,
RevisionID target
);

Parameters

source
the source RevisionID
target
the target RevisionID

See Also

MergePoint Class | Borland.StarTeam Namespace | MergePoint Constructor Overload List


MergePoint Properties

The properties of the MergePoint class are listed below. For a complete list of MergePoint class members, see the MergePoint Members topic.

Public Instance Properties

Source | [read/write] the RevisionID of the merge source.
Target | [read/write] the RevisionID of the merge target.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergePoint Class | Borland.StarTeam Namespace


Source Property

Borland StarTeam SDK for .NET

MergePoint.Source Property

[read/write] the RevisionID of the merge source.

public virtual RevisionID Source {get; set;}

Property Value

the RevisionID of the merge source.

See Also

MergePoint Class | Borland.StarTeam Namespace


Target Property

Borland StarTeam SDK for .NET

MergePoint.Target Property

[read/write] the RevisionID of the merge target.

public virtual RevisionID Target {get; set;}

Property Value

the RevisionID of the merge target.

See Also

MergePoint Class | Borland.StarTeam Namespace


MergePoint Methods

The methods of the MergePoint class are listed below. For a complete list of MergePoint class members, see the MergePoint Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.MergePoint.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.MergePoint.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.MergePoint.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.MergePoint.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergePoint Class | Borland.StarTeam Namespace


MergePoint.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.MergePoint

Implements

IWrapper.Unwrap

See Also

MergePoint Class | Borland.StarTeam Namespace


MergePoint.Equals Method

Delegate Equals() to com.starbase.starteam.MergePoint.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.MergePoint.Equals(obj).

See Also

MergePoint Class | Borland.StarTeam Namespace


MergePoint.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.MergePoint.

public override int GetHashCode();

Return Value

com.starbase.starteam.MergePoint.GetHashCode().

See Also

MergePoint Class | Borland.StarTeam Namespace


MergePoint.ToString Method

Delegate ToString() to com.starbase.starteam.MergePoint.

public override string ToString();

Return Value

com.starbase.starteam.MergePoint.ToString()

See Also

MergePoint Class | Borland.StarTeam Namespace


MergePoint.Wrap Method

Dynamically wraps com.starbase.starteam.MergePoint.

public static MergePoint Wrap(
MergePoint impl
);

Parameters

impl
com.starbase.starteam.MergePoint to be wrapped.

Return Value

MergePoint

See Also

MergePoint Class | Borland.StarTeam Namespace


MergePoint Type Conversions

The type conversions of the MergePoint class are listed below. For a complete list of MergePoint class members, see the MergePoint Members topic.

Public Static Type Conversions

Implicit MergePoint to MergePoint Conversion Implicitly convert MergePoint to com.starbase.starteam.MergePoint.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergePoint Class | MergePoint Members | Borland.StarTeam Namespace


MergePoint Implicit MergePoint to MergePoint Conversion

Implicitly convert MergePoint to com.starbase.starteam.MergePoint.

public static implicit operator MergePoint(
MergePoint arg
);

Parameters

arg
MergePoint to convert.

Return Value

com.starbase.starteam.MergePoint

See Also

MergePoint Class | Borland.StarTeam Namespace


MergePointCollection Class

A strongly-typed collection of MergePoints.

For a list of all members of this type, see MergePointCollection Members.

System.Object
ArrayAdapter
MergePointCollection

public class MergePointCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MergePointCollection Members | Borland.StarTeam Namespace


MergePointCollection Members

MergePointCollection overview

Public Static Methods

Wrap Creates a MergePointCollection to represent the given array of MergePoint (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit MergePointCollection to MergePoint[] Conversion | Converts a MergePointCollection to an array of MergePoints.
Implicit MergePointCollection to MergePoint[] Conversion | Converts a MergePointCollection from the Borland.StarTeam namespace to a MergePoint[] in the com.starbase.starteam namespace.

Public Instance Constructors

MergePointCollection Overloaded. Initializes a new instance of the MergePointCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the MergePoint at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a MergePoint to end of the collection.
Append | Overloaded. Appends the MergePoints of the given MergePointCollection to the end of this MergePointCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific MergePoint.
CopyTo | Copies all of the MergePoints in the MergePointCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific MergePoint in the collection.
Insert | Inserts a MergePoint into the collection at the specified position.
Remove | Removes the first occurrence of a specific MergePoint from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the MergePoints in this MergePointCollection.
Sort | Sorts the MergePoints in this MergePointCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection Constructor

Initializes an instance of the MergePointCollection class.

Overload List

Initializes an instance of the MergePointCollection class.

public MergePointCollection();

Initializes an instance of the a MergePointCollection class, copying the given array.

public MergePointCollection(MergePoint[]);

Initializes an instance of the a MergePointCollection class, copying the given collection.

public MergePointCollection(MergePointCollection);

Initializes an instance of the a MergePointCollection class, wrapping the given array of MergePoint (from the com.starbase.starteam namespace).

public MergePointCollection(MergePoint[]);

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection Constructor ()

Initializes an instance of the MergePointCollection class.

public MergePointCollection();

See Also

MergePointCollection Class | Borland.StarTeam Namespace | MergePointCollection Constructor Overload List


MergePointCollection Constructor (MergePoint[])

Initializes an instance of the a MergePointCollection class, wrapping the given array of MergePoint (from the com.starbase.starteam namespace).

public MergePointCollection(
MergePoint[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

MergePointCollection Class | Borland.StarTeam Namespace | MergePointCollection Constructor Overload List | Wrap


MergePointCollection Constructor (MergePointCollection)

Initializes an instance of the a MergePointCollection class, copying the given collection.

public MergePointCollection(
MergePointCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member MergePoint objects of the original collection are shared, not copied.

See Also

MergePointCollection Class | Borland.StarTeam Namespace | MergePointCollection Constructor Overload List


MergePointCollection Constructor (MergePoint[])

Initializes an instance of the a MergePointCollection class, copying the given array.

public MergePointCollection(
MergePoint[] array
);

Parameters

array
The array to be copied.

Remarks

The member MergePoint objects of the original array are shared, not copied.

See Also

MergePointCollection Class | Borland.StarTeam Namespace | MergePointCollection Constructor Overload List


MergePointCollection Properties

The properties of the MergePointCollection class are listed below. For a complete list of MergePointCollection class members, see the MergePointCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the MergePoint at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

MergePointCollection.Item Property

Gets or sets the MergePoint at the specified index.

public MergePoint this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the MergePoint to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection Methods

The methods of the MergePointCollection class are listed below. For a complete list of MergePointCollection class members, see the MergePointCollection Members topic.

Public Static Methods

Wrap Creates a MergePointCollection to represent the given array of MergePoint (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a MergePoint to end of the collection.
Append | Overloaded. Appends the MergePoints of the given MergePointCollection to the end of this MergePointCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific MergePoint.
CopyTo | Copies all of the MergePoints in the MergePointCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific MergePoint in the collection.
Insert | Inserts a MergePoint into the collection at the specified position.
Remove | Removes the first occurrence of a specific MergePoint from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the MergePoints in this MergePointCollection.
Sort | Sorts the MergePoints in this MergePointCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection.Add Method

Adds a MergePoint to end of the collection.

public int Add(
MergePoint value
);

Parameters

value
The MergePoint to add to the collection.

Return Value

The position into which the new MergePoint was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

MergePointCollection.Append Method

Appends the MergePoints of the given array to the end of this MergePointCollection.

Overload List

Appends the MergePoints of the given array to the end of this MergePointCollection.

public MergePointCollection Append(MergePoint[]);

Appends the MergePoints of the given MergePointCollection to the end of this MergePointCollection.

public MergePointCollection Append(MergePointCollection);

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection.Append Method (MergePoint[])

Appends the MergePoints of the given array to the end of this MergePointCollection.

public MergePointCollection Append(
MergePoint[] array
);

Parameters

array
The array whose MergePoints are to be appended to this MergePointCollection.

Return Value

This MergePointCollection, modified to include the new MergePoints.

Remarks

The MergePointCollection is modified to include the new members. The individual MergePoint objects are shared, not copied.

See Also

MergePointCollection Class | Borland.StarTeam Namespace | MergePointCollection.Append Overload List


MergePointCollection.Append Method (MergePointCollection)

Appends the MergePoints of the given MergePointCollection to the end of this MergePointCollection.

public MergePointCollection Append(
MergePointCollection collection
);

Parameters

collection
The MergePointCollection whose MergePoints are to be appended to this MergePointCollection.

Return Value

This MergePointCollection, modified to include the new MergePoints.

Remarks

The MergePointCollection is modified to include the new members. The individual MergePoint objects are shared, not copied.

See Also

MergePointCollection Class | Borland.StarTeam Namespace | MergePointCollection.Append Overload List


MergePointCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.MergePoint[].

Implements

IWrapper.Unwrap

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection.Contains Method

Determines whether or not the collection contains a specific MergePoint.

public bool Contains(
MergePoint value
);

Parameters

value
The MergePoint to locate in the collection.

Return Value

true if the MergePoint is found in the collection; otherwise, false.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection.CopyTo Method

Copies all of the MergePoints in the MergePointCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
MergePoint[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the MergePoints copied from the MergePointCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of MergePoints in the source MergePointCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source MergePointCollection cannot be cast automatically to the type of the destination array.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection.IndexOf Method

Determines the index of a specific MergePoint in the collection.

public int IndexOf(
MergePoint value
);

Parameters

value
The MergePoint to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection.Insert Method

Inserts a MergePoint into the collection at the specified position.

public void Insert(
Int32 index,
MergePoint value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The MergePoint to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection.Remove Method

Removes the first occurrence of a specific MergePoint from the collection.

public void Remove(
MergePoint value
);

Parameters

value
The MergePoint to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection.Reverse Method

Reverses the order of the MergePoints in this MergePointCollection.

new public MergePointCollection Reverse();

Return Value

This MergePointCollection, modified such that the MergePoints are reversed.

Remarks

The MergePointCollection is modified in place.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection.Sort Method

Sorts the MergePoints in this MergePointCollection, using the given comparer.

new public MergePointCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two MergePoints.

Return Value

This MergePointCollection, modified such that the MergePoints are sorted.

Remarks

The MergePointCollection is modified in place.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection.Wrap Method

Creates a MergePointCollection to represent the given array of MergePoint (from the com.starbase.starteam namespace).

public static MergePointCollection Wrap(
MergePoint[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new MergePointCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a MergePoint[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection Type Conversions

The type conversions of the MergePointCollection class are listed below. For a complete list of MergePointCollection class members, see the MergePointCollection Members topic.

Public Static Type Conversions

Implicit MergePointCollection to MergePoint[] Conversion | Converts a MergePointCollection to an array of MergePoints.
Implicit MergePointCollection to MergePoint[] Conversion | Converts a MergePointCollection from the Borland.StarTeam namespace to a MergePoint[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

MergePointCollection Class | MergePointCollection Members | Borland.StarTeam Namespace


MergePointCollection Implicit MergePointCollection to MergePoint[] Conversion

Converts a MergePointCollection to an array of MergePoints.

public static implicit operator MergePoint[](
MergePointCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new MergePoint wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one MergePoint wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MergePointCollection Implicit MergePointCollection to MergePoint[] Conversion

Converts a MergePointCollection from the Borland.StarTeam namespace to a MergePoint[] in the com.starbase.starteam namespace.

public static implicit operator MergePoint[](
MergePointCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, MergePointCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

MergePointCollection Class | Borland.StarTeam Namespace


MPXException Class

For a list of all members of this type, see MPXException Members.

System.Object
Exception
MPXException

public class MPXException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MPXException Members | Borland.StarTeam Namespace


MPXException Members

MPXException overview

Public Static Properties

E_CONNECT
E_MESSAGETHREAD
E_MPX_BASE
E_MULTICAST_NOT_SUPPORTED
E_NO_DEFAULT_PROFILE
E_NO_SUCH_PROFILE
E_NORESPONSE
E_NOT_INSTALLED
E_NOT_SUPPORTED
E_NOTCONNECTED
E_TRANSMITTER
E_UNEXPECTED

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.MPXException.

Public Static Type Conversions

Implicit MPXException to MPXException Conversion Implicitly convert MPXException to com.starbase.starteam.MPXException.

Public Instance Constructors

MPXException Constructor Construct MPXException from com.starbase.starteam.MPXException.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.MPXException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.MPXException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.MPXException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MPXException Class | Borland.StarTeam Namespace


MPXException Constructor

Construct MPXException from com.starbase.starteam.MPXException.

public MPXException(
MPXException impl
);

Parameters

impl
The com.starbase.starteam.MPXException to be wrapped.

See Also

MPXException Class | Borland.StarTeam Namespace


MPXException Properties

The properties of the MPXException class are listed below. For a complete list of MPXException class members, see the MPXException Members topic.

Public Static Properties

E_CONNECT
E_MESSAGETHREAD
E_MPX_BASE
E_MULTICAST_NOT_SUPPORTED
E_NO_DEFAULT_PROFILE
E_NO_SUCH_PROFILE
E_NORESPONSE
E_NOT_INSTALLED
E_NOT_SUPPORTED
E_NOTCONNECTED
E_TRANSMITTER
E_UNEXPECTED

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MPXException Class | Borland.StarTeam Namespace


E_CONNECT Property

Borland StarTeam SDK for .NET

MPXException.E_CONNECT Property

public static Int32 E_CONNECT {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


E_MESSAGETHREAD Property

Borland StarTeam SDK for .NET

MPXException.E_MESSAGETHREAD Property

public static Int32 E_MESSAGETHREAD {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


E_MPX_BASE Property

Borland StarTeam SDK for .NET

MPXException.E_MPX_BASE Property

public static Int32 E_MPX_BASE {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


E_MULTICAST_NOT_SUPPORTED Property

Borland StarTeam SDK for .NET

MPXException.E_MULTICAST_NOT_SUPPORTED Property

public static Int32 E_MULTICAST_NOT_SUPPORTED {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


E_NO_DEFAULT_PROFILE Property

Borland StarTeam SDK for .NET

MPXException.E_NO_DEFAULT_PROFILE Property

public static Int32 E_NO_DEFAULT_PROFILE {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


E_NO_SUCH_PROFILE Property

Borland StarTeam SDK for .NET

MPXException.E_NO_SUCH_PROFILE Property

public static Int32 E_NO_SUCH_PROFILE {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


E_NORESPONSE Property

Borland StarTeam SDK for .NET

MPXException.E_NORESPONSE Property

public static Int32 E_NORESPONSE {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


E_NOT_INSTALLED Property

Borland StarTeam SDK for .NET

MPXException.E_NOT_INSTALLED Property

public static Int32 E_NOT_INSTALLED {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


E_NOT_SUPPORTED Property

Borland StarTeam SDK for .NET

MPXException.E_NOT_SUPPORTED Property

public static Int32 E_NOT_SUPPORTED {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


E_NOTCONNECTED Property

Borland StarTeam SDK for .NET

MPXException.E_NOTCONNECTED Property

public static Int32 E_NOTCONNECTED {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


E_TRANSMITTER Property

Borland StarTeam SDK for .NET

MPXException.E_TRANSMITTER Property

public static Int32 E_TRANSMITTER {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


E_UNEXPECTED Property

Borland StarTeam SDK for .NET

MPXException.E_UNEXPECTED Property

public static Int32 E_UNEXPECTED {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


ErrorCode Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode Property

public virtual Int32 ErrorCode {get;}

See Also

MPXException Class | Borland.StarTeam Namespace


MPXException Methods

The methods of the MPXException class are listed below. For a complete list of MPXException class members, see the MPXException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.MPXException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.MPXException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.MPXException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.MPXException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MPXException Class | Borland.StarTeam Namespace


MPXException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.MPXException

Implements

IWrapper.Unwrap

See Also

MPXException Class | Borland.StarTeam Namespace


MPXException.Equals Method

Delegate Equals() to com.starbase.starteam.MPXException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.MPXException.Equals(obj).

See Also

MPXException Class | Borland.StarTeam Namespace


MPXException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.MPXException.

public override int GetHashCode();

Return Value

com.starbase.starteam.MPXException.GetHashCode().

See Also

MPXException Class | Borland.StarTeam Namespace


MPXException.ToString Method

Delegate ToString() to com.starbase.starteam.MPXException.

public override string ToString();

Return Value

com.starbase.starteam.MPXException.ToString()

See Also

MPXException Class | Borland.StarTeam Namespace


MPXException.Wrap Method

Dynamically wraps com.starbase.starteam.MPXException.

public static MPXException Wrap(
MPXException impl
);

Parameters

impl
com.starbase.starteam.MPXException to be wrapped.

Return Value

MPXException

See Also

MPXException Class | Borland.StarTeam Namespace


MPXException Type Conversions

The type conversions of the MPXException class are listed below. For a complete list of MPXException class members, see the MPXException Members topic.

Public Static Type Conversions

Implicit MPXException to MPXException Conversion Implicitly convert MPXException to com.starbase.starteam.MPXException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MPXException Class | MPXException Members | Borland.StarTeam Namespace


MPXException Implicit MPXException to MPXException Conversion

Implicitly convert MPXException to com.starbase.starteam.MPXException.

public static implicit operator MPXException(
MPXException arg
);

Parameters

arg
MPXException to convert.

Return Value

com.starbase.starteam.MPXException

See Also

MPXException Class | Borland.StarTeam Namespace


MPXStatusEventArgs Class

For a list of all members of this type, see MPXStatusEventArgs Members.

System.Object
EventArgs
MPXStatusEventArgs

public class MPXStatusEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MPXStatusEventArgs Members | Borland.StarTeam Namespace


MPXStatusEventArgs Members

MPXStatusEventArgs overview

Public Static Type Conversions

Implicit MPXStatusEventArgs to MPXStatusEvent Conversion Implicitly convert MPXStatusEventArgs to com.starbase.starteam.MPXStatusEvent.

Public Instance Properties

Exception |
Server | [read] The Server object that was used to register the listener.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

MPXStatusEventArgs Class | Borland.StarTeam Namespace


MPXStatusEventArgs Properties

The properties of the MPXStatusEventArgs class are listed below. For a complete list of MPXStatusEventArgs class members, see the MPXStatusEventArgs Members topic.

Public Instance Properties

Exception |
Server | [read] The Server object that was used to register the listener.

See Also

MPXStatusEventArgs Class | Borland.StarTeam Namespace


Exception Property

Borland StarTeam SDK for .NET

MPXStatusEventArgs.Exception Property

public virtual MPXException Exception {get;}

See Also

MPXStatusEventArgs Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

MPXStatusEventArgs.Server Property

[read] The Server object that was used to register the listener.

public virtual Server Server {get;}

Property Value

The Server object that was used to register the listener.

See Also

MPXStatusEventArgs Class | Borland.StarTeam Namespace


MPXStatusEventArgs Methods

The methods of the MPXStatusEventArgs class are listed below. For a complete list of MPXStatusEventArgs class members, see the MPXStatusEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

MPXStatusEventArgs Class | Borland.StarTeam Namespace


MPXStatusEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

MPXStatusEventArgs Class | Borland.StarTeam Namespace


MPXStatusEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

MPXStatusEventArgs Class | Borland.StarTeam Namespace


MPXStatusEventArgs.ToString Method

public override string ToString();

See Also

MPXStatusEventArgs Class | Borland.StarTeam Namespace


MPXStatusEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

MPXStatusEventArgs Class | Borland.StarTeam Namespace


MPXStatusEventArgs Type Conversions

The type conversions of the MPXStatusEventArgs class are listed below. For a complete list of MPXStatusEventArgs class members, see the MPXStatusEventArgs Members topic.

Public Static Type Conversions

Implicit MPXStatusEventArgs to MPXStatusEvent Conversion Implicitly convert MPXStatusEventArgs to com.starbase.starteam.MPXStatusEvent.

See Also

MPXStatusEventArgs Class | MPXStatusEventArgs Members | Borland.StarTeam Namespace


MPXStatusEventArgs Implicit MPXStatusEventArgs to MPXStatusEvent Conversion

Implicitly convert MPXStatusEventArgs to com.starbase.starteam.MPXStatusEvent.

public static implicit operator MPXStatusEvent(
MPXStatusEventArgs arg
);

Parameters

arg
MPXStatusEventArgs to convert.

Return Value

com.starbase.starteam.MPXStatusEvent

See Also

MPXStatusEventArgs Class | Borland.StarTeam Namespace


MPXStatusEventSource Class

For a list of all members of this type, see MPXStatusEventSource Members.

System.Object
MPXStatusEventSource

public class MPXStatusEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MPXStatusEventSource Members | Borland.StarTeam Namespace


MPXStatusEventSource Members

MPXStatusEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Disabled
Enabled
Exception
Offline
OnDisabled
OnEnabled
OnException
Online
OnOffline
OnOnline

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource Properties

The properties of the MPXStatusEventSource class are listed below. For a complete list of MPXStatusEventSource class members, see the MPXStatusEventSource Members topic.

Public Instance Properties

Parent

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

MPXStatusEventSource.Parent Property

public Object Parent {get;}

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource Events

The events of the MPXStatusEventSource class are listed below. For a complete list of MPXStatusEventSource class members, see the MPXStatusEventSource Members topic.

Public Instance Events

Disabled
Enabled
Exception
Offline
OnDisabled
OnEnabled
OnException
Online
OnOffline
OnOnline

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource.Disabled Event

public event MPXStatusEventSource.Handler Disabled;

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource.Enabled Event

public event MPXStatusEventSource.Handler Enabled;

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource.Exception Event

public event MPXStatusEventSource.Handler Exception;

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource.Offline Event

public event MPXStatusEventSource.Handler Offline;

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource.OnDisabled Event

public event MPXStatusEventSource.Handler OnDisabled;

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource.OnEnabled Event

public event MPXStatusEventSource.Handler OnEnabled;

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource.OnException Event

public event MPXStatusEventSource.Handler OnException;

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource.Online Event

public event MPXStatusEventSource.Handler Online;

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource.OnOffline Event

public event MPXStatusEventSource.Handler OnOffline;

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource.OnOnline Event

public event MPXStatusEventSource.Handler OnOnline;

See Also

MPXStatusEventSource Class | Borland.StarTeam Namespace


MPXStatusEventSource.Handler Delegate

public delegate void MPXStatusEventSource.Handler(
MPXStatusEventSource source,
MPXStatusEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


MyUserAccount Class

This class represents the user account information that every user can specify/modify about themselves. The basic proceedure is to call the Server.getMyUserAccount, then modify the appropriate fields then call update() on the object to save the changes on the server.

For a list of all members of this type, see MyUserAccount Members.

System.Object
MyUserAccount

public class MyUserAccount : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MyUserAccount Members | Borland.StarTeam Namespace


MyUserAccount Members

MyUserAccount overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.MyUserAccount.

Public Static Type Conversions

Implicit MyUserAccount to MyUserAccount Conversion Implicitly convert MyUserAccount to com.starbase.starteam.MyUserAccount.

Public Instance Constructors

MyUserAccount Constructor Construct MyUserAccount from com.starbase.starteam.MyUserAccount.

Public Instance Properties

EmailAddress | [read/write] the user's email address.
FaxNumber | [read/write] the user's fax number.
ID | [read] the integer that represents this user account.
LogOnName | [read] ths user's logon name.
MinimumPasswordLength | [read] the minimum required password length.
Name | [read/write] the full name that this user goes by.
PagerNumber | [read/write] the user's pager number.
Password | [write] Modify the user's password. The maximum password length is 127 characters.
PasswordChangeRequired | [read] true if a password change is required during the current session.
PasswordDaysRemaining | [read] The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.
PhoneNumber | [read/write] the user's phone number.
PostalAddress | [read/write] the user's postal address.
VoiceMailNumber | [read/write] the user's voice mail number.

Public Instance Methods

Copy | Creates a copy of this user account.
Equals | Delegate Equals() to com.starbase.starteam.MyUserAccount.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.MyUserAccount.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two user account objects.
ToString | Delegate ToString() to com.starbase.starteam.MyUserAccount.
Update | Updates this user account information on the StarTeam server.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MyUserAccount Class | Borland.StarTeam Namespace


MyUserAccount Constructor

Construct MyUserAccount from com.starbase.starteam.MyUserAccount.

public MyUserAccount(
MyUserAccount impl
);

Parameters

impl
The com.starbase.starteam.MyUserAccount to be wrapped.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


MyUserAccount Properties

The properties of the MyUserAccount class are listed below. For a complete list of MyUserAccount class members, see the MyUserAccount Members topic.

Public Instance Properties

EmailAddress | [read/write] the user's email address.
FaxNumber | [read/write] the user's fax number.
ID | [read] the integer that represents this user account.
LogOnName | [read] ths user's logon name.
MinimumPasswordLength | [read] the minimum required password length.
Name | [read/write] the full name that this user goes by.
PagerNumber | [read/write] the user's pager number.
Password | [write] Modify the user's password. The maximum password length is 127 characters.
PasswordChangeRequired | [read] true if a password change is required during the current session.
PasswordDaysRemaining | [read] The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.
PhoneNumber | [read/write] the user's phone number.
PostalAddress | [read/write] the user's postal address.
VoiceMailNumber | [read/write] the user's voice mail number.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MyUserAccount Class | Borland.StarTeam Namespace


EmailAddress Property

Borland StarTeam SDK for .NET

MyUserAccount.EmailAddress Property

[read/write] the user's email address.

public virtual String EmailAddress {get; set;}

Property Value

the user's email address.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


FaxNumber Property

Borland StarTeam SDK for .NET

MyUserAccount.FaxNumber Property

[read/write] the user's fax number.

public virtual String FaxNumber {get; set;}

Property Value

the user's fax number.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

MyUserAccount.ID Property

[read] the integer that represents this user account.

public virtual Int32 ID {get;}

Property Value

the integer that represents this user account.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


LogOnName Property

Borland StarTeam SDK for .NET

MyUserAccount.LogOnName Property

[read] ths user's logon name.

public virtual String LogOnName {get;}

Property Value

ths user's logon name.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


MinimumPasswordLength Property

Borland StarTeam SDK for .NET

MyUserAccount.MinimumPasswordLength Property

[read] the minimum required password length.

public virtual Int32 MinimumPasswordLength {get;}

Property Value

the minimum required password length.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

MyUserAccount.Name Property

[read/write] the full name that this user goes by.

public virtual String Name {get; set;}

Property Value

the full name that this user goes by.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


PagerNumber Property

Borland StarTeam SDK for .NET

MyUserAccount.PagerNumber Property

[read/write] the user's pager number.

public virtual String PagerNumber {get; set;}

Property Value

the user's pager number.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


Password Property

Borland StarTeam SDK for .NET

MyUserAccount.Password Property

[write] Modify the user's password. The maximum password length is 127 characters.

public virtual String Password {set;}

Property Value

Modify the user's password. The maximum password length is 127 characters.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


PasswordChangeRequired Property

Borland StarTeam SDK for .NET

MyUserAccount.PasswordChangeRequired Property

[read] true if a password change is required during the current session.

public virtual Boolean PasswordChangeRequired {get;}

Property Value

true if a password change is required during the current session.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


PasswordDaysRemaining Property

Borland StarTeam SDK for .NET

MyUserAccount.PasswordDaysRemaining Property

[read] The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.

public virtual Int32 PasswordDaysRemaining {get;}

Property Value

The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


PhoneNumber Property

Borland StarTeam SDK for .NET

MyUserAccount.PhoneNumber Property

[read/write] the user's phone number.

public virtual String PhoneNumber {get; set;}

Property Value

the user's phone number.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


PostalAddress Property

Borland StarTeam SDK for .NET

MyUserAccount.PostalAddress Property

[read/write] the user's postal address.

public virtual String PostalAddress {get; set;}

Property Value

the user's postal address.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


VoiceMailNumber Property

Borland StarTeam SDK for .NET

MyUserAccount.VoiceMailNumber Property

[read/write] the user's voice mail number.

public virtual String VoiceMailNumber {get; set;}

Property Value

the user's voice mail number.

See Also

MyUserAccount Class | Borland.StarTeam Namespace


MyUserAccount Methods

The methods of the MyUserAccount class are listed below. For a complete list of MyUserAccount class members, see the MyUserAccount Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.MyUserAccount.

Public Instance Methods

Copy | Creates a copy of this user account.
Equals | Delegate Equals() to com.starbase.starteam.MyUserAccount.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.MyUserAccount.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two user account objects.
ToString | Delegate ToString() to com.starbase.starteam.MyUserAccount.
Update | Updates this user account information on the StarTeam server.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MyUserAccount Class | Borland.StarTeam Namespace


MyUserAccount.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.MyUserAccount

Implements

IWrapper.Unwrap

See Also

MyUserAccount Class | Borland.StarTeam Namespace


MyUserAccount.Copy Method

Creates a copy of this user account.

public virtual MyUserAccount Copy();

Return Value

A new copy of this user account.

See Also

MyUserAccount Class | Borland.StarTeam Namespace | isEqualTo


MyUserAccount.Equals Method

Delegate Equals() to com.starbase.starteam.MyUserAccount.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.MyUserAccount.Equals(obj).

See Also

MyUserAccount Class | Borland.StarTeam Namespace


MyUserAccount.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.MyUserAccount.

public override int GetHashCode();

Return Value

com.starbase.starteam.MyUserAccount.GetHashCode().

See Also

MyUserAccount Class | Borland.StarTeam Namespace


MyUserAccount.IsEqualTo Method

Compares two user account objects.

public virtual bool IsEqualTo(
MyUserAccount account
);

Parameters

account
The user account to be compared with this one.

Return Value

true if no differences were found.

See Also

MyUserAccount Class | Borland.StarTeam Namespace | copy


MyUserAccount.ToString Method

Delegate ToString() to com.starbase.starteam.MyUserAccount.

public override string ToString();

Return Value

com.starbase.starteam.MyUserAccount.ToString()

See Also

MyUserAccount Class | Borland.StarTeam Namespace


MyUserAccount.Update Method

Updates this user account information on the StarTeam server.

public virtual void Update();

See Also

MyUserAccount Class | Borland.StarTeam Namespace


MyUserAccount.Wrap Method

Dynamically wraps com.starbase.starteam.MyUserAccount.

public static MyUserAccount Wrap(
MyUserAccount impl
);

Parameters

impl
com.starbase.starteam.MyUserAccount to be wrapped.

Return Value

MyUserAccount

See Also

MyUserAccount Class | Borland.StarTeam Namespace


MyUserAccount Type Conversions

The type conversions of the MyUserAccount class are listed below. For a complete list of MyUserAccount class members, see the MyUserAccount Members topic.

Public Static Type Conversions

Implicit MyUserAccount to MyUserAccount Conversion Implicitly convert MyUserAccount to com.starbase.starteam.MyUserAccount.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MyUserAccount Class | MyUserAccount Members | Borland.StarTeam Namespace


MyUserAccount Implicit MyUserAccount to MyUserAccount Conversion

Implicitly convert MyUserAccount to com.starbase.starteam.MyUserAccount.

public static implicit operator MyUserAccount(
MyUserAccount arg
);

Parameters

arg
MyUserAccount to convert.

Return Value

com.starbase.starteam.MyUserAccount

See Also

MyUserAccount Class | Borland.StarTeam Namespace


NetMonitor Class

Displays information about the commands that are being sent to the StarTeam Server. This may be useful in diagnosing performance problems.

For a list of all members of this type, see NetMonitor Members.

System.Object
NetMonitor

public class NetMonitor : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

NetMonitor Members | Borland.StarTeam Namespace


NetMonitor Members

NetMonitor overview

Public Static Properties

RunningCommandCount [read] The total number of server commands currently being executed across all threads.

Public Static Methods

Kill | Turns off the NetMonitor.
NewCacheAgentEventSource |
NewServerCommandEventSource |
On | Turns on the NetMonitor, sending output to the NetMonitor window.
OnConsole | Turns on the NetMonitor, sending output to the system console.
OnFile | Turns on the NetMonitor, sending output to the given file.
Println | Writes a message to the NetMonitor output. Useful for debugging.

Public Static Type Conversions

Implicit NetMonitor to NetMonitor Conversion Implicitly convert NetMonitor to com.starbase.starteam.vts.comm.NetMonitor.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.vts.comm.NetMonitor.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.vts.comm.NetMonitor.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.vts.comm.NetMonitor.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor Properties

The properties of the NetMonitor class are listed below. For a complete list of NetMonitor class members, see the NetMonitor Members topic.

Public Static Properties

RunningCommandCount [read] The total number of server commands currently being executed across all threads.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NetMonitor Class | Borland.StarTeam Namespace


RunningCommandCount Property

Borland StarTeam SDK for .NET

NetMonitor.RunningCommandCount Property

[read] The total number of server commands currently being executed across all threads.

public static Int32 RunningCommandCount {get;}

Property Value

The total number of server commands currently being executed across all threads.

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor Methods

The methods of the NetMonitor class are listed below. For a complete list of NetMonitor class members, see the NetMonitor Members topic.

Public Static Methods

Kill | Turns off the NetMonitor.
NewCacheAgentEventSource |
NewServerCommandEventSource |
On | Turns on the NetMonitor, sending output to the NetMonitor window.
OnConsole | Turns on the NetMonitor, sending output to the system console.
OnFile | Turns on the NetMonitor, sending output to the given file.
Println | Writes a message to the NetMonitor output. Useful for debugging.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.vts.comm.NetMonitor.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.vts.comm.NetMonitor.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.vts.comm.NetMonitor.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.vts.comm.NetMonitor

Implements

IWrapper.Unwrap

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor.Equals Method

Delegate Equals() to com.starbase.starteam.vts.comm.NetMonitor.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.vts.comm.NetMonitor.Equals(obj).

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.vts.comm.NetMonitor.

public override int GetHashCode();

Return Value

com.starbase.starteam.vts.comm.NetMonitor.GetHashCode().

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor.Kill Method

Turns off the NetMonitor.

public static void Kill();

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor.NewCacheAgentEventSource Method

public static CacheAgentEventSource NewCacheAgentEventSource();

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor.NewServerCommandEventSource Method

public static ServerCommandEventSource NewServerCommandEventSource();

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor.On Method

Turns on the NetMonitor, sending output to the NetMonitor window.

public static void On();

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor.OnConsole Method

Turns on the NetMonitor, sending output to the system console.

public static void OnConsole();

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor.OnFile Method

Turns on the NetMonitor, sending output to the given file.

public static void OnFile(
FileInfo file
);

Parameters

file
The output file.

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor.Println Method

Writes a message to the NetMonitor output. Useful for debugging.

public static void Println(
String info
);

Parameters

info
The message to be written.

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor.ToString Method

Delegate ToString() to com.starbase.starteam.vts.comm.NetMonitor.

public override string ToString();

Return Value

com.starbase.starteam.vts.comm.NetMonitor.ToString()

See Also

NetMonitor Class | Borland.StarTeam Namespace


NetMonitor Type Conversions

The type conversions of the NetMonitor class are listed below. For a complete list of NetMonitor class members, see the NetMonitor Members topic.

Public Static Type Conversions

Implicit NetMonitor to NetMonitor Conversion Implicitly convert NetMonitor to com.starbase.starteam.vts.comm.NetMonitor.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NetMonitor Class | NetMonitor Members | Borland.StarTeam Namespace


NetMonitor Implicit NetMonitor to NetMonitor Conversion

Implicitly convert NetMonitor to com.starbase.starteam.vts.comm.NetMonitor.

public static implicit operator NetMonitor(
NetMonitor arg
);

Parameters

arg
NetMonitor to convert.

Return Value

com.starbase.starteam.vts.comm.NetMonitor

See Also

NetMonitor Class | Borland.StarTeam Namespace


NoKeywords Class

A special Keyword implementation that halts keyword expansion for the rest of a file when encountered. The keyword is $NoKeywords$

For a list of all members of this type, see NoKeywords Members.

System.Object
SimpleKeyword
NoKeywords

public class NoKeywords : SimpleKeyword

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

NoKeywords Members | Borland.StarTeam Namespace


NoKeywords Members

NoKeywords overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.NoKeywords.

Public Static Type Conversions

Implicit NoKeywords to NoKeywords Conversion Implicitly convert NoKeywords to com.starbase.starteam.NoKeywords.

Public Instance Constructors

NoKeywords Overloaded. Initializes a new instance of the NoKeywords class.

Public Instance Properties

IsMultiLine (inherited from SimpleKeyword)
Name (inherited from SimpleKeyword)
StopExpanding (inherited from SimpleKeyword)
Value (inherited from SimpleKeyword)
XMLString (inherited from SimpleKeyword)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from SimpleKeyword) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches (inherited from SimpleKeyword) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

NoKeywords Class | Borland.StarTeam Namespace


NoKeywords Constructor

Construct NoKeywords from com.starbase.starteam.NoKeywords.

Overload List

Creates a instance of this class.

public NoKeywords();

Construct NoKeywords from com.starbase.starteam.NoKeywords.

public NoKeywords(NoKeywords);

See Also

NoKeywords Class | Borland.StarTeam Namespace


NoKeywords Constructor (NoKeywords)

Construct NoKeywords from com.starbase.starteam.NoKeywords.

public NoKeywords(
NoKeywords impl
);

Parameters

impl
The com.starbase.starteam.NoKeywords to be wrapped.

See Also

NoKeywords Class | Borland.StarTeam Namespace | NoKeywords Constructor Overload List


NoKeywords Constructor ()

Creates a instance of this class.

public NoKeywords();

See Also

NoKeywords Class | Borland.StarTeam Namespace | NoKeywords Constructor Overload List


NoKeywords Methods

The methods of the NoKeywords class are listed below. For a complete list of NoKeywords class members, see the NoKeywords Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.NoKeywords.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from SimpleKeyword) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches (inherited from SimpleKeyword) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

NoKeywords Class | Borland.StarTeam Namespace


NoKeywords.Wrap Method

Dynamically wraps com.starbase.starteam.NoKeywords.

public static NoKeywords Wrap(
NoKeywords impl
);

Parameters

impl
com.starbase.starteam.NoKeywords to be wrapped.

Return Value

NoKeywords

See Also

NoKeywords Class | Borland.StarTeam Namespace


NoKeywords Type Conversions

The type conversions of the NoKeywords class are listed below. For a complete list of NoKeywords class members, see the NoKeywords Members topic.

Public Static Type Conversions

Implicit NoKeywords to NoKeywords Conversion Implicitly convert NoKeywords to com.starbase.starteam.NoKeywords.

See Also

NoKeywords Class | NoKeywords Members | Borland.StarTeam Namespace


NoKeywords Implicit NoKeywords to NoKeywords Conversion

Implicitly convert NoKeywords to com.starbase.starteam.NoKeywords.

public static implicit operator NoKeywords(
NoKeywords arg
);

Parameters

arg
NoKeywords to convert.

Return Value

com.starbase.starteam.NoKeywords

See Also

NoKeywords Class | Borland.StarTeam Namespace


NoSuchPropertyException Class

For a list of all members of this type, see NoSuchPropertyException Members.

System.Object
Exception
NoSuchPropertyException

public class NoSuchPropertyException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

NoSuchPropertyException Members | Borland.StarTeam Namespace


NoSuchPropertyException Members

NoSuchPropertyException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.NoSuchPropertyException.

Public Static Type Conversions

Implicit NoSuchPropertyException to NoSuchPropertyException Conversion Implicitly convert NoSuchPropertyException to com.starbase.starteam.NoSuchPropertyException.

Public Instance Constructors

NoSuchPropertyException Overloaded. Initializes a new instance of the NoSuchPropertyException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
PropertyID |
PropertyName |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.NoSuchPropertyException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.NoSuchPropertyException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.NoSuchPropertyException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


NoSuchPropertyException Constructor

Construct NoSuchPropertyException from com.starbase.starteam.NoSuchPropertyException.

Overload List

Construct NoSuchPropertyException from com.starbase.starteam.NoSuchPropertyException.

public NoSuchPropertyException(NoSuchPropertyException);

public NoSuchPropertyException(String);

public NoSuchPropertyException(String,Int32);

public NoSuchPropertyException(String,String);

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


NoSuchPropertyException Constructor (NoSuchPropertyException)

Construct NoSuchPropertyException from com.starbase.starteam.NoSuchPropertyException.

public NoSuchPropertyException(
NoSuchPropertyException impl
);

Parameters

impl
The com.starbase.starteam.NoSuchPropertyException to be wrapped.

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace | NoSuchPropertyException Constructor Overload List


NoSuchPropertyException Constructor (String)

public NoSuchPropertyException(
String message
);

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace | NoSuchPropertyException Constructor Overload List


NoSuchPropertyException Constructor (String, String)

public NoSuchPropertyException(
String typeName,
String propertyName
);

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace | NoSuchPropertyException Constructor Overload List


NoSuchPropertyException Constructor (String, Int32)

public NoSuchPropertyException(
String typeName,
Int32 nPropertyID
);

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace | NoSuchPropertyException Constructor Overload List


NoSuchPropertyException Properties

The properties of the NoSuchPropertyException class are listed below. For a complete list of NoSuchPropertyException class members, see the NoSuchPropertyException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
PropertyID |
PropertyName |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


PropertyID Property

Borland StarTeam SDK for .NET

NoSuchPropertyException.PropertyID Property

public virtual Int32 PropertyID {get;}

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


PropertyName Property

Borland StarTeam SDK for .NET

NoSuchPropertyException.PropertyName Property

public virtual String PropertyName {get;}

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


NoSuchPropertyException Methods

The methods of the NoSuchPropertyException class are listed below. For a complete list of NoSuchPropertyException class members, see the NoSuchPropertyException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.NoSuchPropertyException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.NoSuchPropertyException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.NoSuchPropertyException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.NoSuchPropertyException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


NoSuchPropertyException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.NoSuchPropertyException

Implements

IWrapper.Unwrap

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


NoSuchPropertyException.Equals Method

Delegate Equals() to com.starbase.starteam.NoSuchPropertyException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.NoSuchPropertyException.Equals(obj).

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


NoSuchPropertyException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.NoSuchPropertyException.

public override int GetHashCode();

Return Value

com.starbase.starteam.NoSuchPropertyException.GetHashCode().

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


NoSuchPropertyException.ToString Method

Delegate ToString() to com.starbase.starteam.NoSuchPropertyException.

public override string ToString();

Return Value

com.starbase.starteam.NoSuchPropertyException.ToString()

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


NoSuchPropertyException.Wrap Method

Dynamically wraps com.starbase.starteam.NoSuchPropertyException.

public static NoSuchPropertyException Wrap(
NoSuchPropertyException impl
);

Parameters

impl
com.starbase.starteam.NoSuchPropertyException to be wrapped.

Return Value

NoSuchPropertyException

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


NoSuchPropertyException Type Conversions

The type conversions of the NoSuchPropertyException class are listed below. For a complete list of NoSuchPropertyException class members, see the NoSuchPropertyException Members topic.

Public Static Type Conversions

Implicit NoSuchPropertyException to NoSuchPropertyException Conversion Implicitly convert NoSuchPropertyException to com.starbase.starteam.NoSuchPropertyException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NoSuchPropertyException Class | NoSuchPropertyException Members | Borland.StarTeam Namespace


NoSuchPropertyException Implicit NoSuchPropertyException to NoSuchPropertyException Conversion

Implicitly convert NoSuchPropertyException to com.starbase.starteam.NoSuchPropertyException.

public static implicit operator NoSuchPropertyException(
NoSuchPropertyException arg
);

Parameters

arg
NoSuchPropertyException to convert.

Return Value

com.starbase.starteam.NoSuchPropertyException

See Also

NoSuchPropertyException Class | Borland.StarTeam Namespace


NotificationEventArgs Class

For a list of all members of this type, see NotificationEventArgs Members.

System.Object
EventArgs
NotificationEventArgs

public class NotificationEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

NotificationEventArgs Members | Borland.StarTeam Namespace


NotificationEventArgs Members

NotificationEventArgs overview

Public Static Type Conversions

Implicit NotificationEventArgs to NotificationEvent Conversion Implicitly convert NotificationEventArgs to com.starbase.starteam.NotificationEvent.

Public Instance Properties

Item [read] The Item whose notification state has changed.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

NotificationEventArgs Class | Borland.StarTeam Namespace


NotificationEventArgs Properties

The properties of the NotificationEventArgs class are listed below. For a complete list of NotificationEventArgs class members, see the NotificationEventArgs Members topic.

Public Instance Properties

Item [read] The Item whose notification state has changed.

See Also

NotificationEventArgs Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

NotificationEventArgs.Item Property

[read] The Item whose notification state has changed.

public virtual Item Item {get;}

Property Value

The Item whose notification state has changed.

See Also

NotificationEventArgs Class | Borland.StarTeam Namespace


NotificationEventArgs Methods

The methods of the NotificationEventArgs class are listed below. For a complete list of NotificationEventArgs class members, see the NotificationEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

NotificationEventArgs Class | Borland.StarTeam Namespace


NotificationEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

NotificationEventArgs Class | Borland.StarTeam Namespace


NotificationEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

NotificationEventArgs Class | Borland.StarTeam Namespace


NotificationEventArgs.ToString Method

public override string ToString();

See Also

NotificationEventArgs Class | Borland.StarTeam Namespace


NotificationEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

NotificationEventArgs Class | Borland.StarTeam Namespace


NotificationEventArgs Type Conversions

The type conversions of the NotificationEventArgs class are listed below. For a complete list of NotificationEventArgs class members, see the NotificationEventArgs Members topic.

Public Static Type Conversions

Implicit NotificationEventArgs to NotificationEvent Conversion Implicitly convert NotificationEventArgs to com.starbase.starteam.NotificationEvent.

See Also

NotificationEventArgs Class | NotificationEventArgs Members | Borland.StarTeam Namespace


NotificationEventArgs Implicit NotificationEventArgs to NotificationEvent Conversion

Implicitly convert NotificationEventArgs to com.starbase.starteam.NotificationEvent.

public static implicit operator NotificationEvent(
NotificationEventArgs arg
);

Parameters

arg
NotificationEventArgs to convert.

Return Value

com.starbase.starteam.NotificationEvent

See Also

NotificationEventArgs Class | Borland.StarTeam Namespace


NotificationEventSource Class

For a list of all members of this type, see NotificationEventSource Members.

System.Object
NotificationEventSource

public class NotificationEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

NotificationEventSource Members | Borland.StarTeam Namespace


NotificationEventSource Members

NotificationEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Notify
OnNotify

See Also

NotificationEventSource Class | Borland.StarTeam Namespace


NotificationEventSource Properties

The properties of the NotificationEventSource class are listed below. For a complete list of NotificationEventSource class members, see the NotificationEventSource Members topic.

Public Instance Properties

Parent

See Also

NotificationEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

NotificationEventSource.Parent Property

public Object Parent {get;}

See Also

NotificationEventSource Class | Borland.StarTeam Namespace


NotificationEventSource Events

The events of the NotificationEventSource class are listed below. For a complete list of NotificationEventSource class members, see the NotificationEventSource Members topic.

Public Instance Events

Notify
OnNotify

See Also

NotificationEventSource Class | Borland.StarTeam Namespace


NotificationEventSource.Notify Event

public event NotificationEventSource.Handler Notify;

See Also

NotificationEventSource Class | Borland.StarTeam Namespace


NotificationEventSource.OnNotify Event

public event NotificationEventSource.Handler OnNotify;

See Also

NotificationEventSource Class | Borland.StarTeam Namespace


NotificationEventSource.Handler Delegate

public delegate void NotificationEventSource.Handler(
NotificationEventSource source,
NotificationEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


NotificationItem Class

This class bundles together information about new "notification" items of a particular type in a particular view that the user may be interested in knowing about.

For a list of all members of this type, see NotificationItem Members.

System.Object
NotificationItem

public class NotificationItem : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

NotificationItem Members | Borland.StarTeam Namespace


NotificationItem Members

NotificationItem overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.NotificationItem.

Public Static Type Conversions

Implicit NotificationItem to NotificationItem Conversion Implicitly convert NotificationItem to com.starbase.starteam.NotificationItem.

Public Instance Constructors

NotificationItem Constructor Construct NotificationItem from com.starbase.starteam.NotificationItem.

Public Instance Properties

ItemID | [read] the notification item's item ID.
ItemObjectID | [read] the notification item's object ID.
ParentFolderItemID | [read] the item ID of the notification item's parent folder.
Type | [read] the type of the notification item. May not be null.
View | [read] the view in which the notification item lives. May not be null.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.NotificationItem.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.NotificationItem.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.NotificationItem.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NotificationItem Class | Borland.StarTeam Namespace


NotificationItem Constructor

Construct NotificationItem from com.starbase.starteam.NotificationItem.

public NotificationItem(
NotificationItem impl
);

Parameters

impl
The com.starbase.starteam.NotificationItem to be wrapped.

See Also

NotificationItem Class | Borland.StarTeam Namespace


NotificationItem Properties

The properties of the NotificationItem class are listed below. For a complete list of NotificationItem class members, see the NotificationItem Members topic.

Public Instance Properties

ItemID | [read] the notification item's item ID.
ItemObjectID | [read] the notification item's object ID.
ParentFolderItemID | [read] the item ID of the notification item's parent folder.
Type | [read] the type of the notification item. May not be null.
View | [read] the view in which the notification item lives. May not be null.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NotificationItem Class | Borland.StarTeam Namespace


ItemID Property

Borland StarTeam SDK for .NET

NotificationItem.ItemID Property

[read] the notification item's item ID.

public virtual Int32 ItemID {get;}

Property Value

the notification item's item ID.

See Also

NotificationItem Class | Borland.StarTeam Namespace


ItemObjectID Property

Borland StarTeam SDK for .NET

NotificationItem.ItemObjectID Property

[read] the notification item's object ID.

public virtual Int32 ItemObjectID {get;}

Property Value

the notification item's object ID.

See Also

NotificationItem Class | Borland.StarTeam Namespace


ParentFolderItemID Property

Borland StarTeam SDK for .NET

NotificationItem.ParentFolderItemID Property

[read] the item ID of the notification item's parent folder.

public virtual Int32 ParentFolderItemID {get;}

Property Value

the item ID of the notification item's parent folder.

See Also

NotificationItem Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

NotificationItem.Type Property

[read] the type of the notification item. May not be null.

public virtual Type Type {get;}

Property Value

the type of the notification item. May not be null.

See Also

NotificationItem Class | Borland.StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

NotificationItem.View Property

[read] the view in which the notification item lives. May not be null.

public virtual View View {get;}

Property Value

the view in which the notification item lives. May not be null.

See Also

NotificationItem Class | Borland.StarTeam Namespace


NotificationItem Methods

The methods of the NotificationItem class are listed below. For a complete list of NotificationItem class members, see the NotificationItem Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.NotificationItem.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.NotificationItem.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.NotificationItem.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.NotificationItem.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NotificationItem Class | Borland.StarTeam Namespace


NotificationItem.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.NotificationItem

Implements

IWrapper.Unwrap

See Also

NotificationItem Class | Borland.StarTeam Namespace


NotificationItem.Equals Method

Delegate Equals() to com.starbase.starteam.NotificationItem.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.NotificationItem.Equals(obj).

See Also

NotificationItem Class | Borland.StarTeam Namespace


NotificationItem.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.NotificationItem.

public override int GetHashCode();

Return Value

com.starbase.starteam.NotificationItem.GetHashCode().

See Also

NotificationItem Class | Borland.StarTeam Namespace


NotificationItem.ToString Method

Delegate ToString() to com.starbase.starteam.NotificationItem.

public override string ToString();

Return Value

com.starbase.starteam.NotificationItem.ToString()

See Also

NotificationItem Class | Borland.StarTeam Namespace


NotificationItem.Wrap Method

Dynamically wraps com.starbase.starteam.NotificationItem.

public static NotificationItem Wrap(
NotificationItem impl
);

Parameters

impl
com.starbase.starteam.NotificationItem to be wrapped.

Return Value

NotificationItem

See Also

NotificationItem Class | Borland.StarTeam Namespace


NotificationItem Type Conversions

The type conversions of the NotificationItem class are listed below. For a complete list of NotificationItem class members, see the NotificationItem Members topic.

Public Static Type Conversions

Implicit NotificationItem to NotificationItem Conversion Implicitly convert NotificationItem to com.starbase.starteam.NotificationItem.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

NotificationItem Class | NotificationItem Members | Borland.StarTeam Namespace


NotificationItem Implicit NotificationItem to NotificationItem Conversion

Implicitly convert NotificationItem to com.starbase.starteam.NotificationItem.

public static implicit operator NotificationItem(
NotificationItem arg
);

Parameters

arg
NotificationItem to convert.

Return Value

com.starbase.starteam.NotificationItem

See Also

NotificationItem Class | Borland.StarTeam Namespace


NotificationItemCollection Class

A strongly-typed collection of NotificationItems.

For a list of all members of this type, see NotificationItemCollection Members.

System.Object
ArrayAdapter
NotificationItemCollection

public class NotificationItemCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

NotificationItemCollection Members | Borland.StarTeam Namespace


NotificationItemCollection Members

NotificationItemCollection overview

Public Static Methods

Wrap Creates a NotificationItemCollection to represent the given array of NotificationItem (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit NotificationItemCollection to NotificationItem[] Conversion | Converts a NotificationItemCollection to an array of NotificationItems.
Implicit NotificationItemCollection to NotificationItem[] Conversion | Converts a NotificationItemCollection from the Borland.StarTeam namespace to a NotificationItem[] in the com.starbase.starteam namespace.

Public Instance Constructors

NotificationItemCollection Overloaded. Initializes a new instance of the NotificationItemCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the NotificationItem at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a NotificationItem to end of the collection.
Append | Overloaded. Appends the NotificationItems of the given NotificationItemCollection to the end of this NotificationItemCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific NotificationItem.
CopyTo | Copies all of the NotificationItems in the NotificationItemCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific NotificationItem in the collection.
Insert | Inserts a NotificationItem into the collection at the specified position.
Remove | Removes the first occurrence of a specific NotificationItem from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the NotificationItems in this NotificationItemCollection.
Sort | Sorts the NotificationItems in this NotificationItemCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection Constructor

Initializes an instance of the NotificationItemCollection class.

Overload List

Initializes an instance of the NotificationItemCollection class.

public NotificationItemCollection();

Initializes an instance of the a NotificationItemCollection class, copying the given array.

public NotificationItemCollection(NotificationItem[]);

Initializes an instance of the a NotificationItemCollection class, copying the given collection.

public NotificationItemCollection(NotificationItemCollection);

Initializes an instance of the a NotificationItemCollection class, wrapping the given array of NotificationItem (from the com.starbase.starteam namespace).

public NotificationItemCollection(NotificationItem[]);

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection Constructor ()

Initializes an instance of the NotificationItemCollection class.

public NotificationItemCollection();

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace | NotificationItemCollection Constructor Overload List


NotificationItemCollection Constructor (NotificationItem[])

Initializes an instance of the a NotificationItemCollection class, wrapping the given array of NotificationItem (from the com.starbase.starteam namespace).

public NotificationItemCollection(
NotificationItem[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace | NotificationItemCollection Constructor Overload List | Wrap


NotificationItemCollection Constructor (NotificationItemCollection)

Initializes an instance of the a NotificationItemCollection class, copying the given collection.

public NotificationItemCollection(
NotificationItemCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member NotificationItem objects of the original collection are shared, not copied.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace | NotificationItemCollection Constructor Overload List


NotificationItemCollection Constructor (NotificationItem[])

Initializes an instance of the a NotificationItemCollection class, copying the given array.

public NotificationItemCollection(
NotificationItem[] array
);

Parameters

array
The array to be copied.

Remarks

The member NotificationItem objects of the original array are shared, not copied.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace | NotificationItemCollection Constructor Overload List


NotificationItemCollection Properties

The properties of the NotificationItemCollection class are listed below. For a complete list of NotificationItemCollection class members, see the NotificationItemCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the NotificationItem at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

NotificationItemCollection.Item Property

Gets or sets the NotificationItem at the specified index.

public NotificationItem this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the NotificationItem to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection Methods

The methods of the NotificationItemCollection class are listed below. For a complete list of NotificationItemCollection class members, see the NotificationItemCollection Members topic.

Public Static Methods

Wrap Creates a NotificationItemCollection to represent the given array of NotificationItem (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a NotificationItem to end of the collection.
Append | Overloaded. Appends the NotificationItems of the given NotificationItemCollection to the end of this NotificationItemCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific NotificationItem.
CopyTo | Copies all of the NotificationItems in the NotificationItemCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific NotificationItem in the collection.
Insert | Inserts a NotificationItem into the collection at the specified position.
Remove | Removes the first occurrence of a specific NotificationItem from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the NotificationItems in this NotificationItemCollection.
Sort | Sorts the NotificationItems in this NotificationItemCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection.Add Method

Adds a NotificationItem to end of the collection.

public int Add(
NotificationItem value
);

Parameters

value
The NotificationItem to add to the collection.

Return Value

The position into which the new NotificationItem was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

NotificationItemCollection.Append Method

Appends the NotificationItems of the given array to the end of this NotificationItemCollection.

Overload List

Appends the NotificationItems of the given array to the end of this NotificationItemCollection.

public NotificationItemCollection Append(NotificationItem[]);

Appends the NotificationItems of the given NotificationItemCollection to the end of this NotificationItemCollection.

public NotificationItemCollection Append(NotificationItemCollection);

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection.Append Method (NotificationItem[])

Appends the NotificationItems of the given array to the end of this NotificationItemCollection.

public NotificationItemCollection Append(
NotificationItem[] array
);

Parameters

array
The array whose NotificationItems are to be appended to this NotificationItemCollection.

Return Value

This NotificationItemCollection, modified to include the new NotificationItems.

Remarks

The NotificationItemCollection is modified to include the new members. The individual NotificationItem objects are shared, not copied.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace | NotificationItemCollection.Append Overload List


NotificationItemCollection.Append Method (NotificationItemCollection)

Appends the NotificationItems of the given NotificationItemCollection to the end of this NotificationItemCollection.

public NotificationItemCollection Append(
NotificationItemCollection collection
);

Parameters

collection
The NotificationItemCollection whose NotificationItems are to be appended to this NotificationItemCollection.

Return Value

This NotificationItemCollection, modified to include the new NotificationItems.

Remarks

The NotificationItemCollection is modified to include the new members. The individual NotificationItem objects are shared, not copied.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace | NotificationItemCollection.Append Overload List


NotificationItemCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.NotificationItem[].

Implements

IWrapper.Unwrap

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection.Contains Method

Determines whether or not the collection contains a specific NotificationItem.

public bool Contains(
NotificationItem value
);

Parameters

value
The NotificationItem to locate in the collection.

Return Value

true if the NotificationItem is found in the collection; otherwise, false.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection.CopyTo Method

Copies all of the NotificationItems in the NotificationItemCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
NotificationItem[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the NotificationItems copied from the NotificationItemCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of NotificationItems in the source NotificationItemCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source NotificationItemCollection cannot be cast automatically to the type of the destination array.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection.IndexOf Method

Determines the index of a specific NotificationItem in the collection.

public int IndexOf(
NotificationItem value
);

Parameters

value
The NotificationItem to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection.Insert Method

Inserts a NotificationItem into the collection at the specified position.

public void Insert(
Int32 index,
NotificationItem value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The NotificationItem to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection.Remove Method

Removes the first occurrence of a specific NotificationItem from the collection.

public void Remove(
NotificationItem value
);

Parameters

value
The NotificationItem to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection.Reverse Method

Reverses the order of the NotificationItems in this NotificationItemCollection.

new public NotificationItemCollection Reverse();

Return Value

This NotificationItemCollection, modified such that the NotificationItems are reversed.

Remarks

The NotificationItemCollection is modified in place.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection.Sort Method

Sorts the NotificationItems in this NotificationItemCollection, using the given comparer.

new public NotificationItemCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two NotificationItems.

Return Value

This NotificationItemCollection, modified such that the NotificationItems are sorted.

Remarks

The NotificationItemCollection is modified in place.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection.Wrap Method

Creates a NotificationItemCollection to represent the given array of NotificationItem (from the com.starbase.starteam namespace).

public static NotificationItemCollection Wrap(
NotificationItem[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new NotificationItemCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a NotificationItem[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection Type Conversions

The type conversions of the NotificationItemCollection class are listed below. For a complete list of NotificationItemCollection class members, see the NotificationItemCollection Members topic.

Public Static Type Conversions

Implicit NotificationItemCollection to NotificationItem[] Conversion | Converts a NotificationItemCollection to an array of NotificationItems.
Implicit NotificationItemCollection to NotificationItem[] Conversion | Converts a NotificationItemCollection from the Borland.StarTeam namespace to a NotificationItem[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

NotificationItemCollection Class | NotificationItemCollection Members | Borland.StarTeam Namespace


NotificationItemCollection Implicit NotificationItemCollection to NotificationItem[] Conversion

Converts a NotificationItemCollection to an array of NotificationItems.

public static implicit operator NotificationItem[](
NotificationItemCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new NotificationItem wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one NotificationItem wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


NotificationItemCollection Implicit NotificationItemCollection to NotificationItem[] Conversion

Converts a NotificationItemCollection from the Borland.StarTeam namespace to a NotificationItem[] in the com.starbase.starteam namespace.

public static implicit operator NotificationItem[](
NotificationItemCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, NotificationItemCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

NotificationItemCollection Class | Borland.StarTeam Namespace


ObjectACLSecLogID Class

For Object ACL events.

For a list of all members of this type, see ObjectACLSecLogID Members.

System.Object
ObjectACLSecLogID

public class ObjectACLSecLogID : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ObjectACLSecLogID Members | Borland.StarTeam Namespace


ObjectACLSecLogID Members

ObjectACLSecLogID overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ObjectACLSecLogID.

Public Static Type Conversions

Implicit ObjectACLSecLogID to ObjectACLSecLogID Conversion Implicitly convert ObjectACLSecLogID to com.starbase.starteam.ObjectACLSecLogID.

Public Instance Constructors

ObjectACLSecLogID Constructor Construct ObjectACLSecLogID from com.starbase.starteam.ObjectACLSecLogID.

Public Instance Properties

ClassID | [read] The class id.
ObjectID | [read] The object id.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ObjectACLSecLogID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ObjectACLSecLogID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ObjectACLSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


ObjectACLSecLogID Constructor

Construct ObjectACLSecLogID from com.starbase.starteam.ObjectACLSecLogID.

public ObjectACLSecLogID(
ObjectACLSecLogID impl
);

Parameters

impl
The com.starbase.starteam.ObjectACLSecLogID to be wrapped.

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


ObjectACLSecLogID Properties

The properties of the ObjectACLSecLogID class are listed below. For a complete list of ObjectACLSecLogID class members, see the ObjectACLSecLogID Members topic.

Public Instance Properties

ClassID | [read] The class id.
ObjectID | [read] The object id.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


ClassID Property

Borland StarTeam SDK for .NET

ObjectACLSecLogID.ClassID Property

[read] The class id.

public virtual Int32 ClassID {get;}

Property Value

The class id.

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

ObjectACLSecLogID.ObjectID Property

[read] The object id.

public virtual Int32 ObjectID {get;}

Property Value

The object id.

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


ObjectACLSecLogID Methods

The methods of the ObjectACLSecLogID class are listed below. For a complete list of ObjectACLSecLogID class members, see the ObjectACLSecLogID Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ObjectACLSecLogID.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ObjectACLSecLogID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ObjectACLSecLogID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ObjectACLSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


ObjectACLSecLogID.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ObjectACLSecLogID

Implements

IWrapper.Unwrap

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


ObjectACLSecLogID.Equals Method

Delegate Equals() to com.starbase.starteam.ObjectACLSecLogID.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ObjectACLSecLogID.Equals(obj).

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


ObjectACLSecLogID.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ObjectACLSecLogID.

public override int GetHashCode();

Return Value

com.starbase.starteam.ObjectACLSecLogID.GetHashCode().

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


ObjectACLSecLogID.ToString Method

Delegate ToString() to com.starbase.starteam.ObjectACLSecLogID.

public override string ToString();

Return Value

com.starbase.starteam.ObjectACLSecLogID.ToString()

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


ObjectACLSecLogID.Wrap Method

Dynamically wraps com.starbase.starteam.ObjectACLSecLogID.

public static ObjectACLSecLogID Wrap(
ObjectACLSecLogID impl
);

Parameters

impl
com.starbase.starteam.ObjectACLSecLogID to be wrapped.

Return Value

ObjectACLSecLogID

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


ObjectACLSecLogID Type Conversions

The type conversions of the ObjectACLSecLogID class are listed below. For a complete list of ObjectACLSecLogID class members, see the ObjectACLSecLogID Members topic.

Public Static Type Conversions

Implicit ObjectACLSecLogID to ObjectACLSecLogID Conversion Implicitly convert ObjectACLSecLogID to com.starbase.starteam.ObjectACLSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ObjectACLSecLogID Class | ObjectACLSecLogID Members | Borland.StarTeam Namespace


ObjectACLSecLogID Implicit ObjectACLSecLogID to ObjectACLSecLogID Conversion

Implicitly convert ObjectACLSecLogID to com.starbase.starteam.ObjectACLSecLogID.

public static implicit operator ObjectACLSecLogID(
ObjectACLSecLogID arg
);

Parameters

arg
ObjectACLSecLogID to convert.

Return Value

com.starbase.starteam.ObjectACLSecLogID

See Also

ObjectACLSecLogID Class | Borland.StarTeam Namespace


PasswordExpiredException Class

For a list of all members of this type, see PasswordExpiredException Members.

System.Object
Exception
ServerException
LogonException
PasswordExpiredException

public class PasswordExpiredException : LogonException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PasswordExpiredException Members | Borland.StarTeam Namespace


PasswordExpiredException Members

PasswordExpiredException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PasswordExpiredException.

Public Static Type Conversions

Implicit PasswordExpiredException to PasswordExpiredException Conversion Implicitly convert PasswordExpiredException to com.starbase.starteam.PasswordExpiredException.

Public Instance Constructors

PasswordExpiredException Constructor Construct PasswordExpiredException from com.starbase.starteam.PasswordExpiredException.

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
IsUserNameValid (inherited from LogonException) |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

PasswordExpiredException Class | Borland.StarTeam Namespace


PasswordExpiredException Constructor

Construct PasswordExpiredException from com.starbase.starteam.PasswordExpiredException.

public PasswordExpiredException(
PasswordExpiredException impl
);

Parameters

impl
The com.starbase.starteam.PasswordExpiredException to be wrapped.

See Also

PasswordExpiredException Class | Borland.StarTeam Namespace


PasswordExpiredException Methods

The methods of the PasswordExpiredException class are listed below. For a complete list of PasswordExpiredException class members, see the PasswordExpiredException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PasswordExpiredException.

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

PasswordExpiredException Class | Borland.StarTeam Namespace


PasswordExpiredException.Wrap Method

Dynamically wraps com.starbase.starteam.PasswordExpiredException.

public static PasswordExpiredException Wrap(
PasswordExpiredException impl
);

Parameters

impl
com.starbase.starteam.PasswordExpiredException to be wrapped.

Return Value

PasswordExpiredException

See Also

PasswordExpiredException Class | Borland.StarTeam Namespace


PasswordExpiredException Type Conversions

The type conversions of the PasswordExpiredException class are listed below. For a complete list of PasswordExpiredException class members, see the PasswordExpiredException Members topic.

Public Static Type Conversions

Implicit PasswordExpiredException to PasswordExpiredException Conversion Implicitly convert PasswordExpiredException to com.starbase.starteam.PasswordExpiredException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

PasswordExpiredException Class | PasswordExpiredException Members | Borland.StarTeam Namespace


PasswordExpiredException Implicit PasswordExpiredException to PasswordExpiredException Conversion

Implicitly convert PasswordExpiredException to com.starbase.starteam.PasswordExpiredException.

public static implicit operator PasswordExpiredException(
PasswordExpiredException arg
);

Parameters

arg
PasswordExpiredException to convert.

Return Value

com.starbase.starteam.PasswordExpiredException

See Also

PasswordExpiredException Class | Borland.StarTeam Namespace


Permission Class

This interface contains fields defining all the different permission settings used by StarTeam.

For a list of all members of this type, see Permission Members.

System.Object
Permission

public class Permission : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Permission Members | Borland.StarTeam Namespace


Permission Members

Permission overview

Public Static Properties

ALL
COMPONENT_CREATE_FILTERS
COMPONENT_CREATE_QUERIES
FILE_CHECKIN
FILE_CHECKOUT
GENERIC_AQUIRE_OWNERSHIP
GENERIC_CHANGE_ACCESS_RIGHTS
GENERIC_CREATE_NEW_OBJECT
GENERIC_DELETE_OBJECT
GENERIC_MODIFY_OBJECT
GENERIC_PURGE_OBJECT
GENERIC_SEE_OBJECT
ITEM_ADD_LABEL
ITEM_ADD_TO_REVISION_LABEL
ITEM_ADD_TO_VIEW_LABEL
ITEM_ADJUST_LABEL
ITEM_BREAK_EXCLUSIVE_LOCK
ITEM_CREATE_LINKS
ITEM_DELETE_LINKS
ITEM_DETACH_FROM_REVISION_LABEL
ITEM_DETACH_FROM_VIEW_LABEL
ITEM_DETACH_LABEL
ITEM_LOCK_EXCLUSIVELY
ITEM_MODIFY_BEHAVIOR
ITEM_MODIFY_LINKS
ITEM_PERFORM_MAINTENANCE
ITEM_SEE_HISTORY
ITEM_SEE_LINKS
ITEM_SHARE_MOVE
PROMOTION_STATE_MODIFY_STATUS
SERVER_ADD_COLLABORATION_USER
SERVER_ADMIN_REMOTELY
SERVER_ADMIN_USER_ACCOUNTS
SERVER_ADMINISTER_COMPONENT_RIGHTS
SERVER_CREATE_PROJECT
SERVER_MODIFY_CONFIGURATION
SERVER_MODIFY_SCHEMA
SERVER_MODIFY_SYSTEM_POLICY
SERVER_REPLICATION_RIGHTS
SERVER_VIEW_COMMAND_STATS
SERVER_VIEW_CONFIGURATION
SERVER_VIEW_DIAGNOSTICS
SERVER_VIEW_LOG
SERVER_VIEW_SECURITY_LOG
SERVER_VIEW_SYSTEM_POLICY
VIEW_CREATE_LABEL
VIEW_CREATE_REVISION_LABEL
VIEW_CREATE_VIEW_LABEL
VIEW_DEFINE_PROMOTION_MODEL
VIEW_DELETE_LABEL
VIEW_DELETE_REVISION_LABEL
VIEW_DELETE_VIEW_LABEL
VIEW_EDIT_LABEL
VIEW_EDIT_REVISION_LABEL
VIEW_EDIT_VIEW_LABEL
VIEW_MODIFY_PROMOTION_STATUS
VIEW_OVERRIDE_DEFAULT_TYPES

Public Static Type Conversions

Implicit Permission to Permission Conversion Implicitly convert Permission to com.starbase.starteam.Permission.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.Permission.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Permission.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.Permission.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Permission Class | Borland.StarTeam Namespace


Permission Properties

The properties of the Permission class are listed below. For a complete list of Permission class members, see the Permission Members topic.

Public Static Properties

ALL
COMPONENT_CREATE_FILTERS
COMPONENT_CREATE_QUERIES
FILE_CHECKIN
FILE_CHECKOUT
GENERIC_AQUIRE_OWNERSHIP
GENERIC_CHANGE_ACCESS_RIGHTS
GENERIC_CREATE_NEW_OBJECT
GENERIC_DELETE_OBJECT
GENERIC_MODIFY_OBJECT
GENERIC_PURGE_OBJECT
GENERIC_SEE_OBJECT
ITEM_ADD_LABEL
ITEM_ADD_TO_REVISION_LABEL
ITEM_ADD_TO_VIEW_LABEL
ITEM_ADJUST_LABEL
ITEM_BREAK_EXCLUSIVE_LOCK
ITEM_CREATE_LINKS
ITEM_DELETE_LINKS
ITEM_DETACH_FROM_REVISION_LABEL
ITEM_DETACH_FROM_VIEW_LABEL
ITEM_DETACH_LABEL
ITEM_LOCK_EXCLUSIVELY
ITEM_MODIFY_BEHAVIOR
ITEM_MODIFY_LINKS
ITEM_PERFORM_MAINTENANCE
ITEM_SEE_HISTORY
ITEM_SEE_LINKS
ITEM_SHARE_MOVE
PROMOTION_STATE_MODIFY_STATUS
SERVER_ADD_COLLABORATION_USER
SERVER_ADMIN_REMOTELY
SERVER_ADMIN_USER_ACCOUNTS
SERVER_ADMINISTER_COMPONENT_RIGHTS
SERVER_CREATE_PROJECT
SERVER_MODIFY_CONFIGURATION
SERVER_MODIFY_SCHEMA
SERVER_MODIFY_SYSTEM_POLICY
SERVER_REPLICATION_RIGHTS
SERVER_VIEW_COMMAND_STATS
SERVER_VIEW_CONFIGURATION
SERVER_VIEW_DIAGNOSTICS
SERVER_VIEW_LOG
SERVER_VIEW_SECURITY_LOG
SERVER_VIEW_SYSTEM_POLICY
VIEW_CREATE_LABEL
VIEW_CREATE_REVISION_LABEL
VIEW_CREATE_VIEW_LABEL
VIEW_DEFINE_PROMOTION_MODEL
VIEW_DELETE_LABEL
VIEW_DELETE_REVISION_LABEL
VIEW_DELETE_VIEW_LABEL
VIEW_EDIT_LABEL
VIEW_EDIT_REVISION_LABEL
VIEW_EDIT_VIEW_LABEL
VIEW_MODIFY_PROMOTION_STATUS
VIEW_OVERRIDE_DEFAULT_TYPES

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Permission Class | Borland.StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Permission.ALL Property

public static Int32 ALL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


COMPONENT_CREATE_FILTERS Property

Borland StarTeam SDK for .NET

Permission.COMPONENT_CREATE_FILTERS Property

public static Int32 COMPONENT_CREATE_FILTERS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


COMPONENT_CREATE_QUERIES Property

Borland StarTeam SDK for .NET

Permission.COMPONENT_CREATE_QUERIES Property

public static Int32 COMPONENT_CREATE_QUERIES {get;}

See Also

Permission Class | Borland.StarTeam Namespace


FILE_CHECKIN Property

Borland StarTeam SDK for .NET

Permission.FILE_CHECKIN Property

public static Int32 FILE_CHECKIN {get;}

See Also

Permission Class | Borland.StarTeam Namespace


FILE_CHECKOUT Property

Borland StarTeam SDK for .NET

Permission.FILE_CHECKOUT Property

public static Int32 FILE_CHECKOUT {get;}

See Also

Permission Class | Borland.StarTeam Namespace


GENERIC_AQUIRE_OWNERSHIP Property

Borland StarTeam SDK for .NET

Permission.GENERIC_AQUIRE_OWNERSHIP Property

public static Int32 GENERIC_AQUIRE_OWNERSHIP {get;}

See Also

Permission Class | Borland.StarTeam Namespace


GENERIC_CHANGE_ACCESS_RIGHTS Property

Borland StarTeam SDK for .NET

Permission.GENERIC_CHANGE_ACCESS_RIGHTS Property

public static Int32 GENERIC_CHANGE_ACCESS_RIGHTS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


GENERIC_CREATE_NEW_OBJECT Property

Borland StarTeam SDK for .NET

Permission.GENERIC_CREATE_NEW_OBJECT Property

public static Int32 GENERIC_CREATE_NEW_OBJECT {get;}

See Also

Permission Class | Borland.StarTeam Namespace


GENERIC_DELETE_OBJECT Property

Borland StarTeam SDK for .NET

Permission.GENERIC_DELETE_OBJECT Property

public static Int32 GENERIC_DELETE_OBJECT {get;}

See Also

Permission Class | Borland.StarTeam Namespace


GENERIC_MODIFY_OBJECT Property

Borland StarTeam SDK for .NET

Permission.GENERIC_MODIFY_OBJECT Property

public static Int32 GENERIC_MODIFY_OBJECT {get;}

See Also

Permission Class | Borland.StarTeam Namespace


GENERIC_PURGE_OBJECT Property

Borland StarTeam SDK for .NET

Permission.GENERIC_PURGE_OBJECT Property

public static Int32 GENERIC_PURGE_OBJECT {get;}

See Also

Permission Class | Borland.StarTeam Namespace


GENERIC_SEE_OBJECT Property

Borland StarTeam SDK for .NET

Permission.GENERIC_SEE_OBJECT Property

public static Int32 GENERIC_SEE_OBJECT {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_ADD_LABEL Property

Borland StarTeam SDK for .NET

Permission.ITEM_ADD_LABEL Property

public static Int32 ITEM_ADD_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_ADD_TO_REVISION_LABEL Property

Borland StarTeam SDK for .NET

Permission.ITEM_ADD_TO_REVISION_LABEL Property

public static Int32 ITEM_ADD_TO_REVISION_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_ADD_TO_VIEW_LABEL Property

Borland StarTeam SDK for .NET

Permission.ITEM_ADD_TO_VIEW_LABEL Property

public static Int32 ITEM_ADD_TO_VIEW_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_ADJUST_LABEL Property

Borland StarTeam SDK for .NET

Permission.ITEM_ADJUST_LABEL Property

public static Int32 ITEM_ADJUST_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_BREAK_EXCLUSIVE_LOCK Property

Borland StarTeam SDK for .NET

Permission.ITEM_BREAK_EXCLUSIVE_LOCK Property

public static Int32 ITEM_BREAK_EXCLUSIVE_LOCK {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_CREATE_LINKS Property

Borland StarTeam SDK for .NET

Permission.ITEM_CREATE_LINKS Property

public static Int32 ITEM_CREATE_LINKS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_DELETE_LINKS Property

Borland StarTeam SDK for .NET

Permission.ITEM_DELETE_LINKS Property

public static Int32 ITEM_DELETE_LINKS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_DETACH_FROM_REVISION_LABEL Property

Borland StarTeam SDK for .NET

Permission.ITEM_DETACH_FROM_REVISION_LABEL Property

public static Int32 ITEM_DETACH_FROM_REVISION_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_DETACH_FROM_VIEW_LABEL Property

Borland StarTeam SDK for .NET

Permission.ITEM_DETACH_FROM_VIEW_LABEL Property

public static Int32 ITEM_DETACH_FROM_VIEW_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_DETACH_LABEL Property

Borland StarTeam SDK for .NET

Permission.ITEM_DETACH_LABEL Property

public static Int32 ITEM_DETACH_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_LOCK_EXCLUSIVELY Property

Borland StarTeam SDK for .NET

Permission.ITEM_LOCK_EXCLUSIVELY Property

public static Int32 ITEM_LOCK_EXCLUSIVELY {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_MODIFY_BEHAVIOR Property

Borland StarTeam SDK for .NET

Permission.ITEM_MODIFY_BEHAVIOR Property

public static Int32 ITEM_MODIFY_BEHAVIOR {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_MODIFY_LINKS Property

Borland StarTeam SDK for .NET

Permission.ITEM_MODIFY_LINKS Property

public static Int32 ITEM_MODIFY_LINKS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_PERFORM_MAINTENANCE Property

Borland StarTeam SDK for .NET

Permission.ITEM_PERFORM_MAINTENANCE Property

public static Int32 ITEM_PERFORM_MAINTENANCE {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_SEE_HISTORY Property

Borland StarTeam SDK for .NET

Permission.ITEM_SEE_HISTORY Property

public static Int32 ITEM_SEE_HISTORY {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_SEE_LINKS Property

Borland StarTeam SDK for .NET

Permission.ITEM_SEE_LINKS Property

public static Int32 ITEM_SEE_LINKS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


ITEM_SHARE_MOVE Property

Borland StarTeam SDK for .NET

Permission.ITEM_SHARE_MOVE Property

public static Int32 ITEM_SHARE_MOVE {get;}

See Also

Permission Class | Borland.StarTeam Namespace


PROMOTION_STATE_MODIFY_STATUS Property

Borland StarTeam SDK for .NET

Permission.PROMOTION_STATE_MODIFY_STATUS Property

public static Int32 PROMOTION_STATE_MODIFY_STATUS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_ADD_COLLABORATION_USER Property

Borland StarTeam SDK for .NET

Permission.SERVER_ADD_COLLABORATION_USER Property

public static Int32 SERVER_ADD_COLLABORATION_USER {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_ADMIN_REMOTELY Property

Borland StarTeam SDK for .NET

Permission.SERVER_ADMIN_REMOTELY Property

public static Int32 SERVER_ADMIN_REMOTELY {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_ADMIN_USER_ACCOUNTS Property

Borland StarTeam SDK for .NET

Permission.SERVER_ADMIN_USER_ACCOUNTS Property

public static Int32 SERVER_ADMIN_USER_ACCOUNTS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_ADMINISTER_COMPONENT_RIGHTS Property

Borland StarTeam SDK for .NET

Permission.SERVER_ADMINISTER_COMPONENT_RIGHTS Property

public static Int32 SERVER_ADMINISTER_COMPONENT_RIGHTS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_CREATE_PROJECT Property

Borland StarTeam SDK for .NET

Permission.SERVER_CREATE_PROJECT Property

public static Int32 SERVER_CREATE_PROJECT {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_MODIFY_CONFIGURATION Property

Borland StarTeam SDK for .NET

Permission.SERVER_MODIFY_CONFIGURATION Property

public static Int32 SERVER_MODIFY_CONFIGURATION {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_MODIFY_SCHEMA Property

Borland StarTeam SDK for .NET

Permission.SERVER_MODIFY_SCHEMA Property

public static Int32 SERVER_MODIFY_SCHEMA {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_MODIFY_SYSTEM_POLICY Property

Borland StarTeam SDK for .NET

Permission.SERVER_MODIFY_SYSTEM_POLICY Property

public static Int32 SERVER_MODIFY_SYSTEM_POLICY {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_REPLICATION_RIGHTS Property

Borland StarTeam SDK for .NET

Permission.SERVER_REPLICATION_RIGHTS Property

public static Int32 SERVER_REPLICATION_RIGHTS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_VIEW_COMMAND_STATS Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_COMMAND_STATS Property

public static Int32 SERVER_VIEW_COMMAND_STATS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_VIEW_CONFIGURATION Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_CONFIGURATION Property

public static Int32 SERVER_VIEW_CONFIGURATION {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_VIEW_DIAGNOSTICS Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_DIAGNOSTICS Property

public static Int32 SERVER_VIEW_DIAGNOSTICS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_VIEW_LOG Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_LOG Property

public static Int32 SERVER_VIEW_LOG {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_VIEW_SECURITY_LOG Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_SECURITY_LOG Property

public static Int32 SERVER_VIEW_SECURITY_LOG {get;}

See Also

Permission Class | Borland.StarTeam Namespace


SERVER_VIEW_SYSTEM_POLICY Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_SYSTEM_POLICY Property

public static Int32 SERVER_VIEW_SYSTEM_POLICY {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_CREATE_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_CREATE_LABEL Property

public static Int32 VIEW_CREATE_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_CREATE_REVISION_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_CREATE_REVISION_LABEL Property

public static Int32 VIEW_CREATE_REVISION_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_CREATE_VIEW_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_CREATE_VIEW_LABEL Property

public static Int32 VIEW_CREATE_VIEW_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_DEFINE_PROMOTION_MODEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_DEFINE_PROMOTION_MODEL Property

public static Int32 VIEW_DEFINE_PROMOTION_MODEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_DELETE_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_DELETE_LABEL Property

public static Int32 VIEW_DELETE_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_DELETE_REVISION_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_DELETE_REVISION_LABEL Property

public static Int32 VIEW_DELETE_REVISION_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_DELETE_VIEW_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_DELETE_VIEW_LABEL Property

public static Int32 VIEW_DELETE_VIEW_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_EDIT_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_EDIT_LABEL Property

public static Int32 VIEW_EDIT_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_EDIT_REVISION_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_EDIT_REVISION_LABEL Property

public static Int32 VIEW_EDIT_REVISION_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_EDIT_VIEW_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_EDIT_VIEW_LABEL Property

public static Int32 VIEW_EDIT_VIEW_LABEL {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_MODIFY_PROMOTION_STATUS Property

Borland StarTeam SDK for .NET

Permission.VIEW_MODIFY_PROMOTION_STATUS Property

public static Int32 VIEW_MODIFY_PROMOTION_STATUS {get;}

See Also

Permission Class | Borland.StarTeam Namespace


VIEW_OVERRIDE_DEFAULT_TYPES Property

Borland StarTeam SDK for .NET

Permission.VIEW_OVERRIDE_DEFAULT_TYPES Property

public static Int32 VIEW_OVERRIDE_DEFAULT_TYPES {get;}

See Also

Permission Class | Borland.StarTeam Namespace


Permission Methods

The methods of the Permission class are listed below. For a complete list of Permission class members, see the Permission Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.Permission.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Permission.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.Permission.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Permission Class | Borland.StarTeam Namespace


Permission.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.Permission

Implements

IWrapper.Unwrap

See Also

Permission Class | Borland.StarTeam Namespace


Permission.Equals Method

Delegate Equals() to com.starbase.starteam.Permission.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.Permission.Equals(obj).

See Also

Permission Class | Borland.StarTeam Namespace


Permission.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.Permission.

public override int GetHashCode();

Return Value

com.starbase.starteam.Permission.GetHashCode().

See Also

Permission Class | Borland.StarTeam Namespace


Permission.ToString Method

Delegate ToString() to com.starbase.starteam.Permission.

public override string ToString();

Return Value

com.starbase.starteam.Permission.ToString()

See Also

Permission Class | Borland.StarTeam Namespace


Permission Type Conversions

The type conversions of the Permission class are listed below. For a complete list of Permission class members, see the Permission Members topic.

Public Static Type Conversions

Implicit Permission to Permission Conversion Implicitly convert Permission to com.starbase.starteam.Permission.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Permission Class | Permission Members | Borland.StarTeam Namespace


Permission Implicit Permission to Permission Conversion

Implicitly convert Permission to com.starbase.starteam.Permission.

public static implicit operator Permission(
Permission arg
);

Parameters

arg
Permission to convert.

Return Value

com.starbase.starteam.Permission

See Also

Permission Class | Borland.StarTeam Namespace


ProcessItem Class

A process item in the context of a given target view.

For a list of all members of this type, see ProcessItem Members.

System.Object
ProcessItem

public class ProcessItem : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ProcessItem Members | Borland.StarTeam Namespace


ProcessItem Members

ProcessItem overview

Public Static Methods

GetActiveProcessItems | Overloaded. Gets the list of process items of the given type that are in a valid active state.
GetProcessItemTypes | Gets the list of item types that are legal process item types for the given target view.
Wrap | Dynamically wraps com.starbase.starteam.ProcessItem.

Public Static Type Conversions

Implicit ProcessItem to ProcessItem Conversion Implicitly convert ProcessItem to com.starbase.starteam.ProcessItem.

Public Instance Constructors

ProcessItem Overloaded. Initializes a new instance of the ProcessItem class.

Public Instance Properties

AllProcessTasks | [read] The list of process tasks associated with this process item in its target view. The process tasks may be in any state.
AllProcessTasksInAnyView | [read] The list of process tasks associated with this process item. The process tasks may reside in any view and be in any state. Some of them may be disembodied items.
IsActiveState | [read] true if this is a legal process item in a legal state to be selected as an active process item for its target view, or false otherwise.
IsEnhanced | [read] true if this is an enhanced process item in the context of its target view; false otherwise.
IsLegalType | [read] true if this is a legal type of process item for its target view, or false otherwise.
Item | [read] The underlying item.
TargetView | [read] The target view.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ProcessItem.
GetAllProcessTasksInProgress | Gets the list of process tasks in progress in the target view.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ProcessItem.
GetProcessTaskInProgress | Gets the process task in progress in the target view.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSelectable | Determines whether or not this process item is in a state that allows it to be selected as the active process item for its target view.
Resolve | Resolves this process item in the context of its target view.
ToString | Delegate ToString() to com.starbase.starteam.ProcessItem.
VerifyIsSelectable | Verifies that this process item is in a state that allows it to be selected as the active process item for its target view.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem Constructor

Construct ProcessItem from com.starbase.starteam.ProcessItem.

Overload List

Constructs a process item. Assumes that the item resides in the target view.

public ProcessItem(Item);

Constructs a process item in the context of a given target view.

public ProcessItem(Item,View);

Construct ProcessItem from com.starbase.starteam.ProcessItem.

public ProcessItem(ProcessItem);

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem Constructor (ProcessItem)

Construct ProcessItem from com.starbase.starteam.ProcessItem.

public ProcessItem(
ProcessItem impl
);

Parameters

impl
The com.starbase.starteam.ProcessItem to be wrapped.

See Also

ProcessItem Class | Borland.StarTeam Namespace | ProcessItem Constructor Overload List


ProcessItem Constructor (Item)

Constructs a process item. Assumes that the item resides in the target view.

public ProcessItem(
Item item
);

Parameters

item
The item to be treated as a process item. The item is not necessarily a valid type for the target view.

See Also

ProcessItem Class | Borland.StarTeam Namespace | ProcessItem Constructor Overload List


ProcessItem Constructor (Item, View)

Constructs a process item in the context of a given target view.

public ProcessItem(
Item item,
View target
);

Parameters

item
The item to be treated as a process item. The item is not necessarily a valid type for the target view.
target

See Also

ProcessItem Class | Borland.StarTeam Namespace | ProcessItem Constructor Overload List


ProcessItem Properties

The properties of the ProcessItem class are listed below. For a complete list of ProcessItem class members, see the ProcessItem Members topic.

Public Instance Properties

AllProcessTasks | [read] The list of process tasks associated with this process item in its target view. The process tasks may be in any state.
AllProcessTasksInAnyView | [read] The list of process tasks associated with this process item. The process tasks may reside in any view and be in any state. Some of them may be disembodied items.
IsActiveState | [read] true if this is a legal process item in a legal state to be selected as an active process item for its target view, or false otherwise.
IsEnhanced | [read] true if this is an enhanced process item in the context of its target view; false otherwise.
IsLegalType | [read] true if this is a legal type of process item for its target view, or false otherwise.
Item | [read] The underlying item.
TargetView | [read] The target view.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ProcessItem Class | Borland.StarTeam Namespace


AllProcessTasks Property

Borland StarTeam SDK for .NET

ProcessItem.AllProcessTasks Property

[read] The list of process tasks associated with this process item in its target view. The process tasks may be in any state.

public virtual ItemCollection AllProcessTasks {get;}

Property Value

The list of process tasks associated with this process item in its target view. The process tasks may be in any state.

See Also

ProcessItem Class | Borland.StarTeam Namespace


AllProcessTasksInAnyView Property

Borland StarTeam SDK for .NET

ProcessItem.AllProcessTasksInAnyView Property

[read] The list of process tasks associated with this process item. The process tasks may reside in any view and be in any state. Some of them may be disembodied items.

public virtual ItemCollection AllProcessTasksInAnyView {get;}

Property Value

The list of process tasks associated with this process item. The process tasks may reside in any view and be in any state. Some of them may be disembodied items.

See Also

ProcessItem Class | Borland.StarTeam Namespace


IsActiveState Property

Borland StarTeam SDK for .NET

ProcessItem.IsActiveState Property

[read] true if this is a legal process item in a legal state to be selected as an active process item for its target view, or false otherwise.

public virtual Boolean IsActiveState {get;}

Property Value

true if this is a legal process item in a legal state to be selected as an active process item for its target view, or false otherwise.

See Also

ProcessItem Class | Borland.StarTeam Namespace


IsEnhanced Property

Borland StarTeam SDK for .NET

ProcessItem.IsEnhanced Property

[read] true if this is an enhanced process item in the context of its target view; false otherwise.

public virtual Boolean IsEnhanced {get;}

Property Value

true if this is an enhanced process item in the context of its target view; false otherwise.

See Also

ProcessItem Class | Borland.StarTeam Namespace


IsLegalType Property

Borland StarTeam SDK for .NET

ProcessItem.IsLegalType Property

[read] true if this is a legal type of process item for its target view, or false otherwise.

public virtual Boolean IsLegalType {get;}

Property Value

true if this is a legal type of process item for its target view, or false otherwise.

See Also

ProcessItem Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

ProcessItem.Item Property

[read] The underlying item.

public virtual Item Item {get;}

Property Value

The underlying item.

See Also

ProcessItem Class | Borland.StarTeam Namespace


TargetView Property

Borland StarTeam SDK for .NET

ProcessItem.TargetView Property

[read] The target view.

public virtual View TargetView {get;}

Property Value

The target view.

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem Methods

The methods of the ProcessItem class are listed below. For a complete list of ProcessItem class members, see the ProcessItem Members topic.

Public Static Methods

GetActiveProcessItems | Overloaded. Gets the list of process items of the given type that are in a valid active state.
GetProcessItemTypes | Gets the list of item types that are legal process item types for the given target view.
Wrap | Dynamically wraps com.starbase.starteam.ProcessItem.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ProcessItem.
GetAllProcessTasksInProgress | Gets the list of process tasks in progress in the target view.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ProcessItem.
GetProcessTaskInProgress | Gets the process task in progress in the target view.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSelectable | Determines whether or not this process item is in a state that allows it to be selected as the active process item for its target view.
Resolve | Resolves this process item in the context of its target view.
ToString | Delegate ToString() to com.starbase.starteam.ProcessItem.
VerifyIsSelectable | Verifies that this process item is in a state that allows it to be selected as the active process item for its target view.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ProcessItem

Implements

IWrapper.Unwrap

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem.Equals Method

Delegate Equals() to com.starbase.starteam.ProcessItem.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ProcessItem.Equals(obj).

See Also

ProcessItem Class | Borland.StarTeam Namespace


GetActiveProcessItems Method

Borland StarTeam SDK for .NET

ProcessItem.GetActiveProcessItems Method

Gets the list of process items of the given type that are in a valid active state.

Overload List

Gets the list of process items of the given type that are in a valid active state.

public static ItemCollection GetActiveProcessItems(Type,View);

Gets the list of process items of the given type that are in a valid active state for the given target view.

public static ItemCollection GetActiveProcessItems(Type,View,Folder,Int32);

Gets the list of process items of the given type that are in a valid active state for the given target view.

public static ItemCollection GetActiveProcessItems(Type,View,View);

Gets the list of process items of the given type that are in a valid active state for the given target view.

public static ItemCollection GetActiveProcessItems(View,ItemListManager);

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem.GetActiveProcessItems Method (Type, View)

Gets the list of process items of the given type that are in a valid active state.

public static ItemCollection GetActiveProcessItems(
Type type,
View view
);

Parameters

type
The item type.
view
A view that is both the target view and the source of the candidate process items.

Return Value

A list of the process items that are in a valid active state.

See Also

ProcessItem Class | Borland.StarTeam Namespace | ProcessItem.GetActiveProcessItems Overload List


ProcessItem.GetActiveProcessItems Method (Type, View, Folder, Int32)

Gets the list of process items of the given type that are in a valid active state for the given target view.

public static ItemCollection GetActiveProcessItems(
Type type,
View target,
Folder source,
Int32 depth
);

Parameters

type
The item type.
target
The target view.
source
The folder that is the source of the candidate process items.
depth
Determines which folders are searched for process items. Zero searches only the given folder; 1 searches the folder and all child folders to a depth of 1; and so on. Use -1 to search the folder and all child folders to any depth.

Return Value

A list of the process items that are in a valid active state.

See Also

ProcessItem Class | Borland.StarTeam Namespace | ProcessItem.GetActiveProcessItems Overload List


ProcessItem.GetActiveProcessItems Method (Type, View, View)

Gets the list of process items of the given type that are in a valid active state for the given target view.

public static ItemCollection GetActiveProcessItems(
Type type,
View target,
View source
);

Parameters

type
The item type.
target
The target view.
source
The view that is the source of the candidate process items.

Return Value

A list of the process items that are in a valid active state.

See Also

ProcessItem Class | Borland.StarTeam Namespace | ProcessItem.GetActiveProcessItems Overload List


ProcessItem.GetActiveProcessItems Method (View, ItemListManager)

Gets the list of process items of the given type that are in a valid active state for the given target view.

public static ItemCollection GetActiveProcessItems(
View target,
ItemListManager source
);

Parameters

target
The target view.
source
The source of the candidate process items.

Return Value

A list of the process items that are in a valid active state.

See Also

ProcessItem Class | Borland.StarTeam Namespace | ProcessItem.GetActiveProcessItems Overload List


ProcessItem.GetAllProcessTasksInProgress Method

Gets the list of process tasks in progress in the target view.

public virtual ItemCollection GetAllProcessTasksInProgress(
ProcessItemUsage usage
);

Parameters

usage
The operation being performed that will result in changed files or folders (for example, CHECKIN). If null, then any usage is acceptable.

Return Value

The list of process tasks in progress in this process item's target view. In most cases, there will be at most one.

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ProcessItem.

public override int GetHashCode();

Return Value

com.starbase.starteam.ProcessItem.GetHashCode().

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem.GetProcessItemTypes Method

Gets the list of item types that are legal process item types for the given target view.

public static TypeCollection GetProcessItemTypes(
View targetView
);

Parameters

targetView

Return Value

The list of item types that are legal process item types for the given target view.

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem.GetProcessTaskInProgress Method

Gets the process task in progress in the target view.

public virtual Item GetProcessTaskInProgress(
ProcessItemUsage usage
);

Parameters

usage
The operation being performed that will result in changed files or folders (for example, CHECKIN). May not be null.

Return Value

The process task in progress in this process item's target view, or null if there isn't one.

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem.IsSelectable Method

Determines whether or not this process item is in a state that allows it to be selected as the active process item for its target view.

public virtual bool IsSelectable(
ProcessItemUsage usage
);

Parameters

usage
The intended usage of this process item.

Return Value

true if this process item may be selected as the active process item for its target view; false otherwise.

See Also

ProcessItem Class | Borland.StarTeam Namespace | verifyIsSelectable


ProcessItem.Resolve Method

Resolves this process item in the context of its target view.

public virtual ItemCollection Resolve();

Return Value

The list of associated file and folder revisions representing changes associated with this process item in the target view.

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem.ToString Method

Delegate ToString() to com.starbase.starteam.ProcessItem.

public override string ToString();

Return Value

com.starbase.starteam.ProcessItem.ToString()

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem.VerifyIsSelectable Method

Verifies that this process item is in a state that allows it to be selected as the active process item for its target view.

public virtual void VerifyIsSelectable(
ProcessItemUsage usage
);

Parameters

usage
The intended usage of this process item.

See Also

ProcessItem Class | Borland.StarTeam Namespace | isSelectable


ProcessItem.Wrap Method

Dynamically wraps com.starbase.starteam.ProcessItem.

public static ProcessItem Wrap(
ProcessItem impl
);

Parameters

impl
com.starbase.starteam.ProcessItem to be wrapped.

Return Value

ProcessItem

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItem Type Conversions

The type conversions of the ProcessItem class are listed below. For a complete list of ProcessItem class members, see the ProcessItem Members topic.

Public Static Type Conversions

Implicit ProcessItem to ProcessItem Conversion Implicitly convert ProcessItem to com.starbase.starteam.ProcessItem.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ProcessItem Class | ProcessItem Members | Borland.StarTeam Namespace


ProcessItem Implicit ProcessItem to ProcessItem Conversion

Implicitly convert ProcessItem to com.starbase.starteam.ProcessItem.

public static implicit operator ProcessItem(
ProcessItem arg
);

Parameters

arg
ProcessItem to convert.

Return Value

com.starbase.starteam.ProcessItem

See Also

ProcessItem Class | Borland.StarTeam Namespace


ProcessItemUsage Class

Indicates the type of operation that created a given process task and its associated process links.

For a list of all members of this type, see ProcessItemUsage Members.

System.Object
EnumeratedValue
ProcessItemUsage

public class ProcessItemUsage : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ProcessItemUsage Members | Borland.StarTeam Namespace


ProcessItemUsage Members

ProcessItemUsage overview

Public Static Properties

CHECKIN
OTHER
PROMOTE
REBASE
REPLICATE

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ProcessItemUsage.

Public Static Type Conversions

Implicit ProcessItemUsage to ProcessItemUsage Conversion Implicitly convert ProcessItemUsage to com.starbase.starteam.ProcessItemUsage.

Public Instance Constructors

ProcessItemUsage Constructor Construct ProcessItemUsage from com.starbase.starteam.ProcessItemUsage.

Public Instance Properties

Code (inherited from EnumeratedValue) | [read/write] the enum code for this object.
Description (inherited from EnumeratedValue) | [read/write] the description of this object. This may return null.
DisplayName (inherited from EnumeratedValue) | [read]
Enabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
SortOrder (inherited from EnumeratedValue) | [read] The sort order of this enumerated value.
Translations (inherited from EnumeratedValue) | [read/write]

Public Instance Methods

Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Equals (inherited from EnumeratedValue) | Delegate Equals() to com.starbase.starteam.EnumeratedValue.
GetHashCode (inherited from EnumeratedValue) | Delegate GetHashCode() to com.starbase.starteam.EnumeratedValue.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from EnumeratedValue) | Delegate ToString() to com.starbase.starteam.EnumeratedValue.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

ProcessItemUsage Class | Borland.StarTeam Namespace


ProcessItemUsage Constructor

Construct ProcessItemUsage from com.starbase.starteam.ProcessItemUsage.

public ProcessItemUsage(
ProcessItemUsage impl
);

Parameters

impl
The com.starbase.starteam.ProcessItemUsage to be wrapped.

See Also

ProcessItemUsage Class | Borland.StarTeam Namespace


ProcessItemUsage Properties

The properties of the ProcessItemUsage class are listed below. For a complete list of ProcessItemUsage class members, see the ProcessItemUsage Members topic.

Public Static Properties

CHECKIN
OTHER
PROMOTE
REBASE
REPLICATE

Public Instance Properties

Code (inherited from EnumeratedValue) | [read/write] the enum code for this object.
Description (inherited from EnumeratedValue) | [read/write] the description of this object. This may return null.
DisplayName (inherited from EnumeratedValue) | [read]
Enabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
SortOrder (inherited from EnumeratedValue) | [read] The sort order of this enumerated value.
Translations (inherited from EnumeratedValue) | [read/write]

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

ProcessItemUsage Class | Borland.StarTeam Namespace


CHECKIN Property

Borland StarTeam SDK for .NET

ProcessItemUsage.CHECKIN Property

public static ProcessItemUsage CHECKIN {get;}

See Also

ProcessItemUsage Class | Borland.StarTeam Namespace


OTHER Property

Borland StarTeam SDK for .NET

ProcessItemUsage.OTHER Property

public static ProcessItemUsage OTHER {get;}

See Also

ProcessItemUsage Class | Borland.StarTeam Namespace


PROMOTE Property

Borland StarTeam SDK for .NET

ProcessItemUsage.PROMOTE Property

public static ProcessItemUsage PROMOTE {get;}

See Also

ProcessItemUsage Class | Borland.StarTeam Namespace


REBASE Property

Borland StarTeam SDK for .NET

ProcessItemUsage.REBASE Property

public static ProcessItemUsage REBASE {get;}

See Also

ProcessItemUsage Class | Borland.StarTeam Namespace


REPLICATE Property

Borland StarTeam SDK for .NET

ProcessItemUsage.REPLICATE Property

public static ProcessItemUsage REPLICATE {get;}

See Also

ProcessItemUsage Class | Borland.StarTeam Namespace


ProcessItemUsage Methods

The methods of the ProcessItemUsage class are listed below. For a complete list of ProcessItemUsage class members, see the ProcessItemUsage Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ProcessItemUsage.

Public Instance Methods

Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Equals (inherited from EnumeratedValue) | Delegate Equals() to com.starbase.starteam.EnumeratedValue.
GetHashCode (inherited from EnumeratedValue) | Delegate GetHashCode() to com.starbase.starteam.EnumeratedValue.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from EnumeratedValue) | Delegate ToString() to com.starbase.starteam.EnumeratedValue.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

ProcessItemUsage Class | Borland.StarTeam Namespace


ProcessItemUsage.Wrap Method

Dynamically wraps com.starbase.starteam.ProcessItemUsage.

public static ProcessItemUsage Wrap(
ProcessItemUsage impl
);

Parameters

impl
com.starbase.starteam.ProcessItemUsage to be wrapped.

Return Value

ProcessItemUsage

See Also

ProcessItemUsage Class | Borland.StarTeam Namespace


ProcessItemUsage Type Conversions

The type conversions of the ProcessItemUsage class are listed below. For a complete list of ProcessItemUsage class members, see the ProcessItemUsage Members topic.

Public Static Type Conversions

Implicit ProcessItemUsage to ProcessItemUsage Conversion Implicitly convert ProcessItemUsage to com.starbase.starteam.ProcessItemUsage.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EnumeratedValue) Implementation of IWrapper.Unwrap().

See Also

ProcessItemUsage Class | ProcessItemUsage Members | Borland.StarTeam Namespace


ProcessItemUsage Implicit ProcessItemUsage to ProcessItemUsage Conversion

Implicitly convert ProcessItemUsage to com.starbase.starteam.ProcessItemUsage.

public static implicit operator ProcessItemUsage(
ProcessItemUsage arg
);

Parameters

arg
ProcessItemUsage to convert.

Return Value

com.starbase.starteam.ProcessItemUsage

See Also

ProcessItemUsage Class | Borland.StarTeam Namespace


ProductCodes Class

This class defines constant values for the various StarTeam product codes.

For a list of all members of this type, see ProductCodes Members.

System.Object
ProductCodes

public class ProductCodes : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ProductCodes Members | Borland.StarTeam Namespace


ProductCodes Members

ProductCodes overview

Public Static Properties

CUSTOMIZATION
ELITE
ENTERPRISE
MPX
REQUIREMENTS
STANDARD
STARDISK
TASKS

Public Static Type Conversions

Implicit ProductCodes to ProductCodes Conversion Implicitly convert ProductCodes to com.starbase.starteam.ProductCodes.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ProductCodes.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ProductCodes.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ProductCodes.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ProductCodes Class | Borland.StarTeam Namespace


ProductCodes Properties

The properties of the ProductCodes class are listed below. For a complete list of ProductCodes class members, see the ProductCodes Members topic.

Public Static Properties

CUSTOMIZATION
ELITE
ENTERPRISE
MPX
REQUIREMENTS
STANDARD
STARDISK
TASKS

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ProductCodes Class | Borland.StarTeam Namespace


CUSTOMIZATION Property

Borland StarTeam SDK for .NET

ProductCodes.CUSTOMIZATION Property

public static Int32 CUSTOMIZATION {get;}

See Also

ProductCodes Class | Borland.StarTeam Namespace


ELITE Property

Borland StarTeam SDK for .NET

ProductCodes.ELITE Property

public static Int32 ELITE {get;}

See Also

ProductCodes Class | Borland.StarTeam Namespace


ENTERPRISE Property

Borland StarTeam SDK for .NET

ProductCodes.ENTERPRISE Property

public static Int32 ENTERPRISE {get;}

See Also

ProductCodes Class | Borland.StarTeam Namespace


MPX Property

Borland StarTeam SDK for .NET

ProductCodes.MPX Property

public static Int32 MPX {get;}

See Also

ProductCodes Class | Borland.StarTeam Namespace


REQUIREMENTS Property

Borland StarTeam SDK for .NET

ProductCodes.REQUIREMENTS Property

public static Int32 REQUIREMENTS {get;}

See Also

ProductCodes Class | Borland.StarTeam Namespace


STANDARD Property

Borland StarTeam SDK for .NET

ProductCodes.STANDARD Property

public static Int32 STANDARD {get;}

See Also

ProductCodes Class | Borland.StarTeam Namespace


STARDISK Property

Borland StarTeam SDK for .NET

ProductCodes.STARDISK Property

public static Int32 STARDISK {get;}

See Also

ProductCodes Class | Borland.StarTeam Namespace


TASKS Property

Borland StarTeam SDK for .NET

ProductCodes.TASKS Property

public static Int32 TASKS {get;}

See Also

ProductCodes Class | Borland.StarTeam Namespace


ProductCodes Methods

The methods of the ProductCodes class are listed below. For a complete list of ProductCodes class members, see the ProductCodes Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ProductCodes.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ProductCodes.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ProductCodes.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ProductCodes Class | Borland.StarTeam Namespace


ProductCodes.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ProductCodes

Implements

IWrapper.Unwrap

See Also

ProductCodes Class | Borland.StarTeam Namespace


ProductCodes.Equals Method

Delegate Equals() to com.starbase.starteam.ProductCodes.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ProductCodes.Equals(obj).

See Also

ProductCodes Class | Borland.StarTeam Namespace


ProductCodes.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ProductCodes.

public override int GetHashCode();

Return Value

com.starbase.starteam.ProductCodes.GetHashCode().

See Also

ProductCodes Class | Borland.StarTeam Namespace


ProductCodes.ToString Method

Delegate ToString() to com.starbase.starteam.ProductCodes.

public override string ToString();

Return Value

com.starbase.starteam.ProductCodes.ToString()

See Also

ProductCodes Class | Borland.StarTeam Namespace


ProductCodes Type Conversions

The type conversions of the ProductCodes class are listed below. For a complete list of ProductCodes class members, see the ProductCodes Members topic.

Public Static Type Conversions

Implicit ProductCodes to ProductCodes Conversion Implicitly convert ProductCodes to com.starbase.starteam.ProductCodes.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ProductCodes Class | ProductCodes Members | Borland.StarTeam Namespace


ProductCodes Implicit ProductCodes to ProductCodes Conversion

Implicitly convert ProductCodes to com.starbase.starteam.ProductCodes.

public static implicit operator ProductCodes(
ProductCodes arg
);

Parameters

arg
ProductCodes to convert.

Return Value

com.starbase.starteam.ProductCodes

See Also

ProductCodes Class | Borland.StarTeam Namespace


Project Class

Represents a StarTeam project which is essentially just a collection of Views.

For a list of all members of this type, see Project Members.

System.Object
TypedResource
SimpleTypedResource
Project

public class Project : SimpleTypedResource, ISecurableObject, ISecurable, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Project Members | Borland.StarTeam Namespace


Project Members

Project overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Project.

Public Static Type Conversions

Implicit Project to Project Conversion Implicitly convert Project to com.starbase.starteam.Project.

Public Instance Constructors

Project Overloaded. Initializes a new instance of the Project class.

Public Instance Properties

AccessibleViews | [read] The set of Views accessible from this Project. May be empty (but is never null).
ACL |
ConfigSource1 | [read] the ConfigSource1 value. This is only meaningful for foreign archive projects.
ConfigSource2 | [read] the ConfigSource2 value. This is only meaningful for foreign archive projects.
CreatedBy | [read] the user ID of the user that created the project.
CreatedTime | [read] the time at which the project was created.
DefaultItemTypes | [read/write] Type[] the set of item types that will be shared upon creation of a variant view.
DefaultView | [read] The default View for this Project.
Description | [read/write] the description of this project.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsDeleted | [read] True if the project has been deleted from the server; false otherwise.
IsEnhancedProcessItemsEnabled | [read/write] true if the enhanced process item model is in effect for this project, and false otherwise.
IsExpandKeywords | [read/write] true if keywords are expanded when files are checked out.
IsForceCheckinReason | [read/write] true if a comment must be included with file check in operations.
IsMailUsed | [read] true if email is used in this project.
IsNew | [read] true if this project has not yet been saved on the server.
IsProcessItemsRequired | [read/write] true if process items are required for this project on add and checkin operations; false otherwise.
IsRefreshRequired | [read] true if project properties may be out of date.
IsRequireLockForCheckin | [read/write] true if files must be locked before they are checked in.
Item (inherited from TypedResource) |
KeywordExpansionFileExtensions | [read/write] the list of file extensions for keyword expansion
Name | [read/write] the name of this project.
Owner |
ParentContainer |
ProjectType | [read] the project type.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Server | [read] the server to which this project belongs.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
Views | [read] All the Views from this Project. May be empty (but is never null).

Public Instance Methods

AcquireOwnership
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this Project object, with project properties fully populated. Useful to applications that want to save a snapshot of the Project in a given state, for example, before calling refresh().
Discard | Discards all of the cached properties for this project. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a project are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetContainerLevelACL
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GoNative | Converts a foreign PVCS or VSS project to a native StarTeam project. If this is a foreign project, goNative() starts a background process on the server to perform the conversion. In any case, goNative() returns immediately. When the conversion completes successfully, the project type will be changed to PROJECT_TYPE_STARTEAM. Note that you may need to refresh the project properties to see the new property value. If the conversion fails, the "go native" server log will contain detailed information regarding the cause of the problem.
HasPermission | Overloaded.
IsActiveProcessItemStateEnabled | Determines whether or not a given status value is one that can be used for an active process item.
IsEqualTo | Compares the properties of two Projects.
IsProcessItemTypeEnabled | Determines whether or not process items of the given type are supported for this project.
NewProjectEventSource
NewViewEventSource
Populate | Populates project properties, if they have not already been populated.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
Refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove | Removes the project from the server.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetActiveProcessItemStateEnabled | Enables or disables a given status value as one that can be used for an active process item. An active process item is one that accepts new process links. Note that currently, only a very specific set of status values, for specific properties and item types, are supported, as follows: Change Requests: Only the CR_STATUS_OPEN and CR_STATUS_IN_PROGRESS values of the CR_STATUS property are supported. If neither of these status values is enabled, but Change Requests in general are legal process items, then it is assumed that any status value is acceptable. Tasks: Only the REQ_STATUS_APPROVED value of the REQ_STATUS property is supported. If this status value is not enabled, but Requirements in general are legal process items, then it is assumed that any status value is acceptable. Tasks: Only the TASK_STATUS_READY_TO_START and TASK_STATUS_IN_PROGRESS values of the TASK_STATUS property are supported. If neither of these status values is enabled, but Tasks in general are legal process items, then it is assumed that any status value is acceptable. Note that if process items are not required for this project, then these settings are ignored; that is, if process items are optional, you may use any Change Request, Requirement or Task in any status as a process item. Also note that a process task in the In Progress state is itself always a legal process item.
SetContainerLevelACL
SetProcessItemTypeEnabled | Enables or disables process items of the given type to be used for this project. Currently, only ChangeRequests, Requirements and Tasks may be used as process items; each of those types may be enabled or disabled individually for each project. Note that if process items are not required for this project, then these settings are ignored; that is, if process items are optional, you may use any Change Request, Requirement or Task as a process item. Also note that whether or not a project explicitly enables Tasks as a legal process item type, process tasks (in the correct state) are always allowed.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Update | Persists this project's properties to its Server. If this project wraps around a foreign archive, Folder hierarchy will be created according to the configuration file and archive path of the foreign archive specified.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Project Class | Borland.StarTeam Namespace


Project Constructor

Construct Project from com.starbase.starteam.Project.

Overload List

Constructs a new project.

public Project(Server,String,String);

Constructs a new project.

public Project(Server,String,String,Int32,Int32,Boolean,String,Int32,String,String,Folder);

Constructs a new project that wraps around a foreign archive.

public Project(Server,String,String,Int32,Int32,Boolean,String,Int32,String,String,String);

Construct Project from com.starbase.starteam.Project.

public Project(Project);

See Also

Project Class | Borland.StarTeam Namespace


Project Constructor (Project)

Construct Project from com.starbase.starteam.Project.

public Project(
Project impl
);

Parameters

impl
The com.starbase.starteam.Project to be wrapped.

See Also

Project Class | Borland.StarTeam Namespace | Project Constructor Overload List


Project Constructor (Server, String, String, Int32, Int32, Boolean, String, Int32, String, String, Folder)

Constructs a new project.

public Project(
Server server,
String name,
String description,
Int32 nCompaction,
Int32 nEncryption,
Boolean bUseMail,
String rootDirectory,
Int32 projectType,
String configSource1,
String configSource2,
Folder folderTree
);

Parameters

server
the repository in which to create this project
name
the name of the project
description
textual description of the project
nCompaction
flags whether or not compaction is used (0=no, 1=yes)
nEncryption
not supported pass in 0
bUseMail
flags whether or not this project will use StarTeam's email capabilities
rootDirectory
path to be used as the default root directory
projectType
pass in 0 for normal StarTeam projects
configSource1
configSource2
folderTree
the root folder of the initial folder tree, may not be null

See Also

Project Class | Borland.StarTeam Namespace | Project Constructor Overload List


Project Constructor (Server, String, String, Int32, Int32, Boolean, String, Int32, String, String, String)

Constructs a new project that wraps around a foreign archive.

public Project(
Server server,
String name,
String description,
Int32 nCompaction,
Int32 nEncryption,
Boolean bUseMail,
String rootDirectory,
Int32 projectType,
String sForeignPassword,
String configFile,
String archivePath
);

Parameters

server
the repository in which to create this project
name
the name of the project
description
textual description of the project
nCompaction
flags whether or not compaction is used (0=no, 1=yes)
nEncryption
not supported pass in 0
bUseMail
flags whether or not this project will use StarTeam's email capabilities
rootDirectory
path to be used as the default root directory
projectType
pass in 1 for PVCS project, and 2 for VSS projectc.
sForeignPassword
password to the foreign archive.
configFile
the configuration files for the foreign archive.
archivePath
the internal path to the foreign archive. To query the paths, use Server.getForeignArchivePaths().

See Also

Project Class | Borland.StarTeam Namespace | Project Constructor Overload List | getPropertyEnums | PROJECT_TYPE_PVCS | PROJECT_TYPE_VISUAL_SOURCESAFE | getForeignArchivePaths | update


Project Constructor (Server, String, String)

Constructs a new project.

public Project(
Server server,
String name,
String rootDirectory
);

Parameters

server
the repository in which to create this project
name
the name of the project
rootDirectory
path to be used as the default root directory

See Also

Project Class | Borland.StarTeam Namespace | Project Constructor Overload List


Project Properties

The properties of the Project class are listed below. For a complete list of Project class members, see the Project Members topic.

Public Instance Properties

AccessibleViews | [read] The set of Views accessible from this Project. May be empty (but is never null).
ACL |
ConfigSource1 | [read] the ConfigSource1 value. This is only meaningful for foreign archive projects.
ConfigSource2 | [read] the ConfigSource2 value. This is only meaningful for foreign archive projects.
CreatedBy | [read] the user ID of the user that created the project.
CreatedTime | [read] the time at which the project was created.
DefaultItemTypes | [read/write] Type[] the set of item types that will be shared upon creation of a variant view.
DefaultView | [read] The default View for this Project.
Description | [read/write] the description of this project.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsDeleted | [read] True if the project has been deleted from the server; false otherwise.
IsEnhancedProcessItemsEnabled | [read/write] true if the enhanced process item model is in effect for this project, and false otherwise.
IsExpandKeywords | [read/write] true if keywords are expanded when files are checked out.
IsForceCheckinReason | [read/write] true if a comment must be included with file check in operations.
IsMailUsed | [read] true if email is used in this project.
IsNew | [read] true if this project has not yet been saved on the server.
IsProcessItemsRequired | [read/write] true if process items are required for this project on add and checkin operations; false otherwise.
IsRefreshRequired | [read] true if project properties may be out of date.
IsRequireLockForCheckin | [read/write] true if files must be locked before they are checked in.
Item (inherited from TypedResource) |
KeywordExpansionFileExtensions | [read/write] the list of file extensions for keyword expansion
Name | [read/write] the name of this project.
Owner |
ParentContainer |
ProjectType | [read] the project type.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Server | [read] the server to which this project belongs.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
Views | [read] All the Views from this Project. May be empty (but is never null).

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Project Class | Borland.StarTeam Namespace


AccessibleViews Property

Borland StarTeam SDK for .NET

Project.AccessibleViews Property

[read] The set of Views accessible from this Project. May be empty (but is never null).

public virtual ViewCollection AccessibleViews {get;}

Property Value

The set of Views accessible from this Project. May be empty (but is never null).

See Also

Project Class | Borland.StarTeam Namespace


ACL Property

Borland StarTeam SDK for .NET

Project.ACL Property

public virtual ACL ACL {get; set;}

Implements

ISecurable.ACL

See Also

Project Class | Borland.StarTeam Namespace


ConfigSource1 Property

Borland StarTeam SDK for .NET

Project.ConfigSource1 Property

[read] the ConfigSource1 value. This is only meaningful for foreign archive projects.

public virtual String ConfigSource1 {get;}

Property Value

the ConfigSource1 value. This is only meaningful for foreign archive projects.

See Also

Project Class | Borland.StarTeam Namespace


ConfigSource2 Property

Borland StarTeam SDK for .NET

Project.ConfigSource2 Property

[read] the ConfigSource2 value. This is only meaningful for foreign archive projects.

public virtual String ConfigSource2 {get;}

Property Value

the ConfigSource2 value. This is only meaningful for foreign archive projects.

See Also

Project Class | Borland.StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Project.CreatedBy Property

[read] the user ID of the user that created the project.

public virtual Int32 CreatedBy {get;}

Property Value

the user ID of the user that created the project.

See Also

Project Class | Borland.StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Project.CreatedTime Property

[read] the time at which the project was created.

public virtual DateTime CreatedTime {get;}

Property Value

the time at which the project was created.

See Also

Project Class | Borland.StarTeam Namespace


DefaultItemTypes Property

Borland StarTeam SDK for .NET

Project.DefaultItemTypes Property

[read/write] Type[] the set of item types that will be shared upon creation of a variant view.

public virtual TypeCollection DefaultItemTypes {get; set;}

Property Value

Type[] the set of item types that will be shared upon creation of a variant view.

See Also

Project Class | Borland.StarTeam Namespace


DefaultView Property

Borland StarTeam SDK for .NET

Project.DefaultView Property

[read] The default View for this Project.

public virtual View DefaultView {get;}

Property Value

The default View for this Project.

See Also

Project Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Project.Description Property

[read/write] the description of this project.

public virtual String Description {get; set;}

Property Value

the description of this project.

See Also

Project Class | Borland.StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Project.IsDeleted Property

[read] True if the project has been deleted from the server; false otherwise.

public virtual Boolean IsDeleted {get;}

Property Value

True if the project has been deleted from the server; false otherwise.

See Also

Project Class | Borland.StarTeam Namespace


IsEnhancedProcessItemsEnabled Property

Borland StarTeam SDK for .NET

Project.IsEnhancedProcessItemsEnabled Property

[read/write] true if the enhanced process item model is in effect for this project, and false otherwise.

public virtual Boolean IsEnhancedProcessItemsEnabled {get; set;}

Property Value

true if the enhanced process item model is in effect for this project, and false otherwise.

See Also

Project Class | Borland.StarTeam Namespace


IsExpandKeywords Property

Borland StarTeam SDK for .NET

Project.IsExpandKeywords Property

[read/write] true if keywords are expanded when files are checked out.

public virtual Boolean IsExpandKeywords {get; set;}

Property Value

true if keywords are expanded when files are checked out.

See Also

Project Class | Borland.StarTeam Namespace


IsForceCheckinReason Property

Borland StarTeam SDK for .NET

Project.IsForceCheckinReason Property

[read/write] true if a comment must be included with file check in operations.

public virtual Boolean IsForceCheckinReason {get; set;}

Property Value

true if a comment must be included with file check in operations.

See Also

Project Class | Borland.StarTeam Namespace


IsMailUsed Property

Borland StarTeam SDK for .NET

Project.IsMailUsed Property

[read] true if email is used in this project.

public virtual Boolean IsMailUsed {get;}

Property Value

true if email is used in this project.

See Also

Project Class | Borland.StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Project.IsNew Property

[read] true if this project has not yet been saved on the server.

public virtual Boolean IsNew {get;}

Property Value

true if this project has not yet been saved on the server.

See Also

Project Class | Borland.StarTeam Namespace


IsProcessItemsRequired Property

Borland StarTeam SDK for .NET

Project.IsProcessItemsRequired Property

[read/write] true if process items are required for this project on add and checkin operations; false otherwise.

public virtual Boolean IsProcessItemsRequired {get; set;}

Property Value

true if process items are required for this project on add and checkin operations; false otherwise.

See Also

Project Class | Borland.StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

Project.IsRefreshRequired Property

[read] true if project properties may be out of date.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if project properties may be out of date.

See Also

Project Class | Borland.StarTeam Namespace


IsRequireLockForCheckin Property

Borland StarTeam SDK for .NET

Project.IsRequireLockForCheckin Property

[read/write] true if files must be locked before they are checked in.

public virtual Boolean IsRequireLockForCheckin {get; set;}

Property Value

true if files must be locked before they are checked in.

See Also

Project Class | Borland.StarTeam Namespace


KeywordExpansionFileExtensions Property

Borland StarTeam SDK for .NET

Project.KeywordExpansionFileExtensions Property

[read/write] the list of file extensions for keyword expansion

public virtual String KeywordExpansionFileExtensions {get; set;}

Property Value

the list of file extensions for keyword expansion

See Also

Project Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Project.Name Property

[read/write] the name of this project.

public virtual String Name {get; set;}

Property Value

the name of this project.

See Also

Project Class | Borland.StarTeam Namespace


Owner Property

Borland StarTeam SDK for .NET

Project.Owner Property

public virtual Int32 Owner {get;}

Implements

ISecurableObject.Owner

See Also

Project Class | Borland.StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

Project.ParentContainer Property

public virtual ISecurableContainer ParentContainer {get;}

Implements

ISecurableContainer.ParentContainer

See Also

Project Class | Borland.StarTeam Namespace


ProjectType Property

Borland StarTeam SDK for .NET

Project.ProjectType Property

[read] the project type.

public virtual Int32 ProjectType {get;}

Property Value

the project type.

See Also

Project Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Project.Server Property

[read] the server to which this project belongs.

public virtual Server Server {get;}

Property Value

the server to which this project belongs.

See Also

Project Class | Borland.StarTeam Namespace


Views Property

Borland StarTeam SDK for .NET

Project.Views Property

[read] All the Views from this Project. May be empty (but is never null).

public virtual ViewCollection Views {get;}

Property Value

All the Views from this Project. May be empty (but is never null).

See Also

Project Class | Borland.StarTeam Namespace


Project Methods

The methods of the Project class are listed below. For a complete list of Project class members, see the Project Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Project.

Public Instance Methods

AcquireOwnership
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this Project object, with project properties fully populated. Useful to applications that want to save a snapshot of the Project in a given state, for example, before calling refresh().
Discard | Discards all of the cached properties for this project. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a project are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetContainerLevelACL
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GoNative | Converts a foreign PVCS or VSS project to a native StarTeam project. If this is a foreign project, goNative() starts a background process on the server to perform the conversion. In any case, goNative() returns immediately. When the conversion completes successfully, the project type will be changed to PROJECT_TYPE_STARTEAM. Note that you may need to refresh the project properties to see the new property value. If the conversion fails, the "go native" server log will contain detailed information regarding the cause of the problem.
HasPermission | Overloaded.
IsActiveProcessItemStateEnabled | Determines whether or not a given status value is one that can be used for an active process item.
IsEqualTo | Compares the properties of two Projects.
IsProcessItemTypeEnabled | Determines whether or not process items of the given type are supported for this project.
NewProjectEventSource
NewViewEventSource
Populate | Populates project properties, if they have not already been populated.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
Refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove | Removes the project from the server.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetActiveProcessItemStateEnabled | Enables or disables a given status value as one that can be used for an active process item. An active process item is one that accepts new process links. Note that currently, only a very specific set of status values, for specific properties and item types, are supported, as follows: Change Requests: Only the CR_STATUS_OPEN and CR_STATUS_IN_PROGRESS values of the CR_STATUS property are supported. If neither of these status values is enabled, but Change Requests in general are legal process items, then it is assumed that any status value is acceptable. Tasks: Only the REQ_STATUS_APPROVED value of the REQ_STATUS property is supported. If this status value is not enabled, but Requirements in general are legal process items, then it is assumed that any status value is acceptable. Tasks: Only the TASK_STATUS_READY_TO_START and TASK_STATUS_IN_PROGRESS values of the TASK_STATUS property are supported. If neither of these status values is enabled, but Tasks in general are legal process items, then it is assumed that any status value is acceptable. Note that if process items are not required for this project, then these settings are ignored; that is, if process items are optional, you may use any Change Request, Requirement or Task in any status as a process item. Also note that a process task in the In Progress state is itself always a legal process item.
SetContainerLevelACL
SetProcessItemTypeEnabled | Enables or disables process items of the given type to be used for this project. Currently, only ChangeRequests, Requirements and Tasks may be used as process items; each of those types may be enabled or disabled individually for each project. Note that if process items are not required for this project, then these settings are ignored; that is, if process items are optional, you may use any Change Request, Requirement or Task as a process item. Also note that whether or not a project explicitly enables Tasks as a legal process item type, process tasks (in the correct state) are always allowed.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Update | Persists this project's properties to its Server. If this project wraps around a foreign archive, Folder hierarchy will be created according to the configuration file and archive path of the foreign archive specified.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Project Class | Borland.StarTeam Namespace


Project.AcquireOwnership Method

public virtual void AcquireOwnership();

Implements

ISecurableObject.AcquireOwnership

See Also

Project Class | Borland.StarTeam Namespace


Project.Copy Method

Creates a copy of this Project object, with project properties fully populated. Useful to applications that want to save a snapshot of the Project in a given state, for example, before calling refresh().

public virtual Project Copy();

Return Value

A new copy of this Project object.

See Also

Project Class | Borland.StarTeam Namespace | isEqualTo


Project.Discard Method

Discards all of the cached properties for this project. They will be re-fetched from the server on demand (even when MPX is enabled).

If the properties of a project are changed, and discard() is called without first calling update(), the changes will be lost.

public virtual void Discard();

See Also

Project Class | Borland.StarTeam Namespace | refresh


Project.GetContainerLevelACL Method

public virtual ACL GetContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.GetContainerLevelACL

See Also

Project Class | Borland.StarTeam Namespace


Project.GoNative Method

Converts a foreign PVCS or VSS project to a native StarTeam project.

If this is a foreign project, goNative() starts a background process on the server to perform the conversion. In any case, goNative() returns immediately.

When the conversion completes successfully, the project type will be changed to PROJECT_TYPE_STARTEAM. Note that you may need to refresh the project properties to see the new property value.

If the conversion fails, the "go native" server log will contain detailed information regarding the cause of the problem.

public virtual void GoNative();

See Also

Project Class | Borland.StarTeam Namespace | getProjectType | PROJECT_TYPE_STARTEAM | PROJECT_TYPE_PVCS | PROJECT_TYPE_VISUAL_SOURCESAFE


HasPermission Method

Borland StarTeam SDK for .NET

Project.HasPermission Method

Overload List

public virtual bool HasPermission(Int32);

public virtual bool HasPermission(Int32,String);

See Also

Project Class | Borland.StarTeam Namespace


Project.HasPermission Method (Int32)

public virtual bool HasPermission(
Int32 permissions
);

Implements

ISecurable.HasPermission

See Also

Project Class | Borland.StarTeam Namespace | Project.HasPermission Overload List


Project.HasPermission Method (Int32, String)

public virtual bool HasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.HasPermission

See Also

Project Class | Borland.StarTeam Namespace | Project.HasPermission Overload List


Project.IsActiveProcessItemStateEnabled Method

Determines whether or not a given status value is one that can be used for an active process item.

public virtual bool IsActiveProcessItemStateEnabled(
EnumeratedValue value
);

Parameters

value
The status value to be tested.

Return Value

true if the given status value is legal for an active process item, and false otherwise.

See Also

Project Class | Borland.StarTeam Namespace | setActiveProcessItemStateEnabled


Project.IsEqualTo Method

Compares the properties of two Projects.

public virtual bool IsEqualTo(
Project project
);

Parameters

project
The project to be compared to this one.

Return Value

true if no differences were found.

See Also

Project Class | Borland.StarTeam Namespace | copy


Project.IsProcessItemTypeEnabled Method

Determines whether or not process items of the given type are supported for this project.

public virtual bool IsProcessItemTypeEnabled(
Type type
);

Parameters

type
An item type.

Return Value

true if process items of the given type are enabled for this project; false otherwise.

See Also

Project Class | Borland.StarTeam Namespace | setProcessItemTypeEnabled | isProcessItemsRequired | isActiveProcessItemStateEnabled


Project.NewProjectEventSource Method

public ProjectEventSource NewProjectEventSource();

See Also

Project Class | Borland.StarTeam Namespace


Project.NewViewEventSource Method

public ViewEventSource NewViewEventSource();

See Also

Project Class | Borland.StarTeam Namespace


Project.Populate Method

Populates project properties, if they have not already been populated.

public virtual void Populate();

See Also

Project Class | Borland.StarTeam Namespace | refresh


Project.Refresh Method

Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh();

See Also

Project Class | Borland.StarTeam Namespace | isRefreshRequired | populate | enableMPX


Project.Remove Method

Removes the project from the server.

public virtual void Remove();

See Also

Project Class | Borland.StarTeam Namespace


Project.SetActiveProcessItemStateEnabled Method

Enables or disables a given status value as one that can be used for an active process item. An active process item is one that accepts new process links.

Note that currently, only a very specific set of status values, for specific properties and item types, are supported, as follows:

Change Requests: Only the CR_STATUS_OPEN and CR_STATUS_IN_PROGRESS values of the CR_STATUS property are supported. If neither of these status values is enabled, but Change Requests in general are legal process items, then it is assumed that any status value is acceptable.

Tasks: Only the REQ_STATUS_APPROVED value of the REQ_STATUS property is supported. If this status value is not enabled, but Requirements in general are legal process items, then it is assumed that any status value is acceptable.

Tasks: Only the TASK_STATUS_READY_TO_START and TASK_STATUS_IN_PROGRESS values of the TASK_STATUS property are supported. If neither of these status values is enabled, but Tasks in general are legal process items, then it is assumed that any status value is acceptable.

Note that if process items are not required for this project, then these settings are ignored; that is, if process items are optional, you may use any Change Request, Requirement or Task in any status as a process item.

Also note that a process task in the In Progress state is itself always a legal process item.

public virtual void SetActiveProcessItemStateEnabled(
EnumeratedValue value,
Boolean isEnabled
);

Parameters

value
isEnabled

See Also

Project Class | Borland.StarTeam Namespace | CR_STATUS_OPEN | CR_STATUS_IN_PROGRESS | REQ_STATUS_APPROVED | TASK_STATUS_READY_TO_START | TASK_STATUS_IN_PROGRESS | PROJECT_PROCESS_SHOW_CR_OPEN | PROJECT_PROCESS_SHOW_CR_IN_PROGRESS | PROJECT_PROCESS_SHOW_REQUIREMENT_APPROVED | PROJECT_PROCESS_SHOW_TASK_READY | PROJECT_PROCESS_SHOW_TASK_IN_PROGRESS | isActiveProcessItemStateEnabled | isProcessTask | ProcessItem


Project.SetContainerLevelACL Method

public virtual void SetContainerLevelACL(
ACL acl,
String typeName
);

Implements

ISecurableContainer.SetContainerLevelACL

See Also

Project Class | Borland.StarTeam Namespace


Project.SetProcessItemTypeEnabled Method

Enables or disables process items of the given type to be used for this project.

Currently, only ChangeRequests, Requirements and Tasks may be used as process items; each of those types may be enabled or disabled individually for each project.

Note that if process items are not required for this project, then these settings are ignored; that is, if process items are optional, you may use any Change Request, Requirement or Task as a process item.

Also note that whether or not a project explicitly enables Tasks as a legal process item type, process tasks (in the correct state) are always allowed.

public virtual void SetProcessItemTypeEnabled(
Type type,
Boolean isEnabled
);

Parameters

type
An item type (Change Request, Requirement or Task).
isEnabled
true to enable process items of the given type; false to disable them.

See Also

Project Class | Borland.StarTeam Namespace | isProcessItemTypeEnabled | setProcessItemsRequired | setActiveProcessItemStateEnabled | PROJECT_PROCESS_SELECT_CR | PROJECT_PROCESS_SELECT_REQUIREMENT | PROJECT_PROCESS_SELECT_TASK | isProcessTask | ProcessItem


Project.Update Method

Persists this project's properties to its Server. If this project wraps around a foreign archive, Folder hierarchy will be created according to the configuration file and archive path of the foreign archive specified.

public virtual void Update();

See Also

Project Class | Borland.StarTeam Namespace


Project.Wrap Method

Dynamically wraps com.starbase.starteam.Project.

public static Project Wrap(
Project impl
);

Parameters

impl
com.starbase.starteam.Project to be wrapped.

Return Value

Project

See Also

Project Class | Borland.StarTeam Namespace


Project Type Conversions

The type conversions of the Project class are listed below. For a complete list of Project class members, see the Project Members topic.

Public Static Type Conversions

Implicit Project to Project Conversion Implicitly convert Project to com.starbase.starteam.Project.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Project Class | Project Members | Borland.StarTeam Namespace


Project Implicit Project to Project Conversion

Implicitly convert Project to com.starbase.starteam.Project.

public static implicit operator Project(
Project arg
);

Parameters

arg
Project to convert.

Return Value

com.starbase.starteam.Project

See Also

Project Class | Borland.StarTeam Namespace


ProjectCollection Class

A strongly-typed collection of Projects.

For a list of all members of this type, see ProjectCollection Members.

System.Object
ArrayAdapter
ProjectCollection

public class ProjectCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ProjectCollection Members | Borland.StarTeam Namespace


ProjectCollection Members

ProjectCollection overview

Public Static Methods

Wrap Creates a ProjectCollection to represent the given array of Project (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit ProjectCollection to Project[] Conversion | Converts a ProjectCollection to an array of Projects.
Implicit ProjectCollection to Project[] Conversion | Converts a ProjectCollection from the Borland.StarTeam namespace to a Project[] in the com.starbase.starteam namespace.

Public Instance Constructors

ProjectCollection Overloaded. Initializes a new instance of the ProjectCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Project at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Project to end of the collection.
Append | Overloaded. Appends the Projects of the given ProjectCollection to the end of this ProjectCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Project.
CopyTo | Copies all of the Projects in the ProjectCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Project with the given ID.
FindByName | Finds the Project with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Project in the collection.
Insert | Inserts a Project into the collection at the specified position.
Remove | Removes the first occurrence of a specific Project from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Projects in this ProjectCollection.
Sort | Sorts the Projects in this ProjectCollection, using the given comparer.
SortByID | Sorts the Projects in this ProjectCollection by ID.
SortByName | Sorts the Projects in this ProjectCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection Constructor

Initializes an instance of the ProjectCollection class.

Overload List

Initializes an instance of the ProjectCollection class.

public ProjectCollection();

Initializes an instance of the a ProjectCollection class, copying the given array.

public ProjectCollection(Project[]);

Initializes an instance of the a ProjectCollection class, copying the given collection.

public ProjectCollection(ProjectCollection);

Initializes an instance of the a ProjectCollection class, wrapping the given array of Project (from the com.starbase.starteam namespace).

public ProjectCollection(Project[]);

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection Constructor ()

Initializes an instance of the ProjectCollection class.

public ProjectCollection();

See Also

ProjectCollection Class | Borland.StarTeam Namespace | ProjectCollection Constructor Overload List


ProjectCollection Constructor (Project[])

Initializes an instance of the a ProjectCollection class, wrapping the given array of Project (from the com.starbase.starteam namespace).

public ProjectCollection(
Project[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ProjectCollection Class | Borland.StarTeam Namespace | ProjectCollection Constructor Overload List | Wrap


ProjectCollection Constructor (ProjectCollection)

Initializes an instance of the a ProjectCollection class, copying the given collection.

public ProjectCollection(
ProjectCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Project objects of the original collection are shared, not copied.

See Also

ProjectCollection Class | Borland.StarTeam Namespace | ProjectCollection Constructor Overload List


ProjectCollection Constructor (Project[])

Initializes an instance of the a ProjectCollection class, copying the given array.

public ProjectCollection(
Project[] array
);

Parameters

array
The array to be copied.

Remarks

The member Project objects of the original array are shared, not copied.

See Also

ProjectCollection Class | Borland.StarTeam Namespace | ProjectCollection Constructor Overload List


ProjectCollection Properties

The properties of the ProjectCollection class are listed below. For a complete list of ProjectCollection class members, see the ProjectCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Project at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

ProjectCollection.Item Property

Gets or sets the Project at the specified index.

Overload List

Gets or sets the Project at the specified index.

public Project this[Int32] {get; set;}

Gets the Project with the given name.

public Project this[String] {get;}

See Also

ProjectCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

ProjectCollection.Item Property (Int32)

Gets or sets the Project at the specified index.

public Project this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Project to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ProjectCollection Class | Borland.StarTeam Namespace | ProjectCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

ProjectCollection.Item Property (String)

Gets the Project with the given name.

public Project this[
String name
] {get;}

Parameters

name
The name of the Project to get.

Property Value

The Project with the given name, or null if there is no Project with that name in this ProjectCollection. Comparison is case sensitive.

See Also

ProjectCollection Class | Borland.StarTeam Namespace | ProjectCollection.Item Overload List | FindByName


ProjectCollection Methods

The methods of the ProjectCollection class are listed below. For a complete list of ProjectCollection class members, see the ProjectCollection Members topic.

Public Static Methods

Wrap Creates a ProjectCollection to represent the given array of Project (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a Project to end of the collection.
Append | Overloaded. Appends the Projects of the given ProjectCollection to the end of this ProjectCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Project.
CopyTo | Copies all of the Projects in the ProjectCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Project with the given ID.
FindByName | Finds the Project with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Project in the collection.
Insert | Inserts a Project into the collection at the specified position.
Remove | Removes the first occurrence of a specific Project from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Projects in this ProjectCollection.
Sort | Sorts the Projects in this ProjectCollection, using the given comparer.
SortByID | Sorts the Projects in this ProjectCollection by ID.
SortByName | Sorts the Projects in this ProjectCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.Add Method

Adds a Project to end of the collection.

public int Add(
Project value
);

Parameters

value
The Project to add to the collection.

Return Value

The position into which the new Project was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

ProjectCollection.Append Method

Appends the Projects of the given array to the end of this ProjectCollection.

Overload List

Appends the Projects of the given array to the end of this ProjectCollection.

public ProjectCollection Append(Project[]);

Appends the Projects of the given ProjectCollection to the end of this ProjectCollection.

public ProjectCollection Append(ProjectCollection);

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.Append Method (Project[])

Appends the Projects of the given array to the end of this ProjectCollection.

public ProjectCollection Append(
Project[] array
);

Parameters

array
The array whose Projects are to be appended to this ProjectCollection.

Return Value

This ProjectCollection, modified to include the new Projects.

Remarks

The ProjectCollection is modified to include the new members. The individual Project objects are shared, not copied.

See Also

ProjectCollection Class | Borland.StarTeam Namespace | ProjectCollection.Append Overload List


ProjectCollection.Append Method (ProjectCollection)

Appends the Projects of the given ProjectCollection to the end of this ProjectCollection.

public ProjectCollection Append(
ProjectCollection collection
);

Parameters

collection
The ProjectCollection whose Projects are to be appended to this ProjectCollection.

Return Value

This ProjectCollection, modified to include the new Projects.

Remarks

The ProjectCollection is modified to include the new members. The individual Project objects are shared, not copied.

See Also

ProjectCollection Class | Borland.StarTeam Namespace | ProjectCollection.Append Overload List


ProjectCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.Project[].

Implements

IWrapper.Unwrap

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.Contains Method

Determines whether or not the collection contains a specific Project.

public bool Contains(
Project value
);

Parameters

value
The Project to locate in the collection.

Return Value

true if the Project is found in the collection; otherwise, false.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.CopyTo Method

Copies all of the Projects in the ProjectCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Project[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Projects copied from the ProjectCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Projects in the source ProjectCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ProjectCollection cannot be cast automatically to the type of the destination array.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.FindByID Method

Finds the Project with the given ID.

public Project FindByID(
Int32 id
);

Parameters

id
The ID of the Project to be found.

Return Value

The Project with the given ID, or null if there is no Project with that ID in this ProjectCollection.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.FindByName Method

Finds the Project with the given name.

public Project FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the Project to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The Project with the given name, or null if there is no Project with that name in this ProjectCollection.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.IndexOf Method

Determines the index of a specific Project in the collection.

public int IndexOf(
Project value
);

Parameters

value
The Project to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.Insert Method

Inserts a Project into the collection at the specified position.

public void Insert(
Int32 index,
Project value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Project to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.Remove Method

Removes the first occurrence of a specific Project from the collection.

public void Remove(
Project value
);

Parameters

value
The Project to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.Reverse Method

Reverses the order of the Projects in this ProjectCollection.

new public ProjectCollection Reverse();

Return Value

This ProjectCollection, modified such that the Projects are reversed.

Remarks

The ProjectCollection is modified in place.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.Sort Method

Sorts the Projects in this ProjectCollection, using the given comparer.

new public ProjectCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Projects.

Return Value

This ProjectCollection, modified such that the Projects are sorted.

Remarks

The ProjectCollection is modified in place.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.SortByID Method

Sorts the Projects in this ProjectCollection by ID.

public ProjectCollection SortByID();

Return Value

This ProjectCollection, modified such that the Projects are sorted by ID.

Remarks

The ProjectCollection is modified in place.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.SortByName Method

Sorts the Projects in this ProjectCollection by name.

public ProjectCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This ProjectCollection, modified such that the Projects are sorted by name.

Remarks

The ProjectCollection is modified in place.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection.Wrap Method

Creates a ProjectCollection to represent the given array of Project (from the com.starbase.starteam namespace).

public static ProjectCollection Wrap(
Project[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ProjectCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a Project[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection Type Conversions

The type conversions of the ProjectCollection class are listed below. For a complete list of ProjectCollection class members, see the ProjectCollection Members topic.

Public Static Type Conversions

Implicit ProjectCollection to Project[] Conversion | Converts a ProjectCollection to an array of Projects.
Implicit ProjectCollection to Project[] Conversion | Converts a ProjectCollection from the Borland.StarTeam namespace to a Project[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ProjectCollection Class | ProjectCollection Members | Borland.StarTeam Namespace


ProjectCollection Implicit ProjectCollection to Project[] Conversion

Converts a ProjectCollection to an array of Projects.

public static implicit operator Project[](
ProjectCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Project wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Project wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectCollection Implicit ProjectCollection to Project[] Conversion

Converts a ProjectCollection from the Borland.StarTeam namespace to a Project[] in the com.starbase.starteam namespace.

public static implicit operator Project[](
ProjectCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ProjectCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ProjectCollection Class | Borland.StarTeam Namespace


ProjectEventArgs Class

For a list of all members of this type, see ProjectEventArgs Members.

System.Object
EventArgs
ProjectEventArgs

public class ProjectEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ProjectEventArgs Members | Borland.StarTeam Namespace


ProjectEventArgs Members

ProjectEventArgs overview

Public Static Type Conversions

Implicit ProjectEventArgs to ProjectEvent Conversion Implicitly convert ProjectEventArgs to com.starbase.starteam.ProjectEvent.

Public Instance Properties

Project [read] The Project that has been added, changed or deleted, in its new state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ProjectEventArgs Class | Borland.StarTeam Namespace


ProjectEventArgs Properties

The properties of the ProjectEventArgs class are listed below. For a complete list of ProjectEventArgs class members, see the ProjectEventArgs Members topic.

Public Instance Properties

Project [read] The Project that has been added, changed or deleted, in its new state.

See Also

ProjectEventArgs Class | Borland.StarTeam Namespace


Project Property

Borland StarTeam SDK for .NET

ProjectEventArgs.Project Property

[read] The Project that has been added, changed or deleted, in its new state.

public virtual Project Project {get;}

Property Value

The Project that has been added, changed or deleted, in its new state.

See Also

ProjectEventArgs Class | Borland.StarTeam Namespace


ProjectEventArgs Methods

The methods of the ProjectEventArgs class are listed below. For a complete list of ProjectEventArgs class members, see the ProjectEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ProjectEventArgs Class | Borland.StarTeam Namespace


ProjectEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ProjectEventArgs Class | Borland.StarTeam Namespace


ProjectEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ProjectEventArgs Class | Borland.StarTeam Namespace


ProjectEventArgs.ToString Method

public override string ToString();

See Also

ProjectEventArgs Class | Borland.StarTeam Namespace


ProjectEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

ProjectEventArgs Class | Borland.StarTeam Namespace


ProjectEventArgs Type Conversions

The type conversions of the ProjectEventArgs class are listed below. For a complete list of ProjectEventArgs class members, see the ProjectEventArgs Members topic.

Public Static Type Conversions

Implicit ProjectEventArgs to ProjectEvent Conversion Implicitly convert ProjectEventArgs to com.starbase.starteam.ProjectEvent.

See Also

ProjectEventArgs Class | ProjectEventArgs Members | Borland.StarTeam Namespace


ProjectEventArgs Implicit ProjectEventArgs to ProjectEvent Conversion

Implicitly convert ProjectEventArgs to com.starbase.starteam.ProjectEvent.

public static implicit operator ProjectEvent(
ProjectEventArgs arg
);

Parameters

arg
ProjectEventArgs to convert.

Return Value

com.starbase.starteam.ProjectEvent

See Also

ProjectEventArgs Class | Borland.StarTeam Namespace


ProjectEventSource Class

For a list of all members of this type, see ProjectEventSource Members.

System.Object
ProjectEventSource

public class ProjectEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ProjectEventSource Members | Borland.StarTeam Namespace


ProjectEventSource Members

ProjectEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnProjectAdded
OnProjectChanged
OnProjectDeleted
ProjectAdded
ProjectChanged
ProjectDeleted

See Also

ProjectEventSource Class | Borland.StarTeam Namespace


ProjectEventSource Properties

The properties of the ProjectEventSource class are listed below. For a complete list of ProjectEventSource class members, see the ProjectEventSource Members topic.

Public Instance Properties

Parent

See Also

ProjectEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

ProjectEventSource.Parent Property

public Object Parent {get;}

See Also

ProjectEventSource Class | Borland.StarTeam Namespace


ProjectEventSource Events

The events of the ProjectEventSource class are listed below. For a complete list of ProjectEventSource class members, see the ProjectEventSource Members topic.

Public Instance Events

OnProjectAdded
OnProjectChanged
OnProjectDeleted
ProjectAdded
ProjectChanged
ProjectDeleted

See Also

ProjectEventSource Class | Borland.StarTeam Namespace


ProjectEventSource.OnProjectAdded Event

public event ProjectEventSource.Handler OnProjectAdded;

See Also

ProjectEventSource Class | Borland.StarTeam Namespace


ProjectEventSource.OnProjectChanged Event

public event ProjectEventSource.Handler OnProjectChanged;

See Also

ProjectEventSource Class | Borland.StarTeam Namespace


ProjectEventSource.OnProjectDeleted Event

public event ProjectEventSource.Handler OnProjectDeleted;

See Also

ProjectEventSource Class | Borland.StarTeam Namespace


ProjectEventSource.ProjectAdded Event

public event ProjectEventSource.Handler ProjectAdded;

See Also

ProjectEventSource Class | Borland.StarTeam Namespace


ProjectEventSource.ProjectChanged Event

public event ProjectEventSource.Handler ProjectChanged;

See Also

ProjectEventSource Class | Borland.StarTeam Namespace


ProjectEventSource.ProjectDeleted Event

public event ProjectEventSource.Handler ProjectDeleted;

See Also

ProjectEventSource Class | Borland.StarTeam Namespace


ProjectEventSource.Handler Delegate

public delegate void ProjectEventSource.Handler(
ProjectEventSource source,
ProjectEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


PromotionModel Class

This class represents the Promotion model for a view. Each view has a single promotion model. The PromotionModel class primarily acts as the owner of an ordered list of PromotionStates.

For a list of all members of this type, see PromotionModel Members.

System.Object
TypedResource
SimpleTypedResource
PromotionModel

public class PromotionModel : SimpleTypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PromotionModel Members | Borland.StarTeam Namespace


PromotionModel Members

PromotionModel overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PromotionModel.

Public Static Type Conversions

Implicit PromotionModel to PromotionModel Conversion Implicitly convert PromotionModel to com.starbase.starteam.PromotionModel.

Public Instance Constructors

PromotionModel Constructor Construct PromotionModel from com.starbase.starteam.PromotionModel.

Public Instance Properties

CreatedBy | [read] the user ID for the creator of this model
CreatedOn | [read] the time at which this model was created
DebugString | [read] a debug string for this model.
DeletedBy | [read] the user ID for who deleted the model
DeletedOn | [read] the time at which this model was deleted
Description | [read/write] a description string for this model
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
Item (inherited from TypedResource) |
Name | [read/write] the name of the model
ObjectID | [read] the model's object ID
PromotionStates | [read/write] an array of promotion states defining this model
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
View | [read] the view for this model.

Public Instance Methods

AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Update | Stores the modified PromotionModel in the repository. Until this is called all changes to the model are local.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

PromotionModel Class | Borland.StarTeam Namespace


PromotionModel Constructor

Construct PromotionModel from com.starbase.starteam.PromotionModel.

public PromotionModel(
PromotionModel impl
);

Parameters

impl
The com.starbase.starteam.PromotionModel to be wrapped.

See Also

PromotionModel Class | Borland.StarTeam Namespace


PromotionModel Properties

The properties of the PromotionModel class are listed below. For a complete list of PromotionModel class members, see the PromotionModel Members topic.

Public Instance Properties

CreatedBy | [read] the user ID for the creator of this model
CreatedOn | [read] the time at which this model was created
DebugString | [read] a debug string for this model.
DeletedBy | [read] the user ID for who deleted the model
DeletedOn | [read] the time at which this model was deleted
Description | [read/write] a description string for this model
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
Item (inherited from TypedResource) |
Name | [read/write] the name of the model
ObjectID | [read] the model's object ID
PromotionStates | [read/write] an array of promotion states defining this model
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
View | [read] the view for this model.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

PromotionModel Class | Borland.StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

PromotionModel.CreatedBy Property

[read] the user ID for the creator of this model

public virtual Int32 CreatedBy {get;}

Property Value

the user ID for the creator of this model

See Also

PromotionModel Class | Borland.StarTeam Namespace


CreatedOn Property

Borland StarTeam SDK for .NET

PromotionModel.CreatedOn Property

[read] the time at which this model was created

public virtual DateTime CreatedOn {get;}

Property Value

the time at which this model was created

See Also

PromotionModel Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

PromotionModel.DebugString Property

[read] a debug string for this model.

public virtual String DebugString {get;}

Property Value

a debug string for this model.

See Also

PromotionModel Class | Borland.StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

PromotionModel.DeletedBy Property

[read] the user ID for who deleted the model

public virtual Int32 DeletedBy {get;}

Property Value

the user ID for who deleted the model

See Also

PromotionModel Class | Borland.StarTeam Namespace


DeletedOn Property

Borland StarTeam SDK for .NET

PromotionModel.DeletedOn Property

[read] the time at which this model was deleted

public virtual DateTime DeletedOn {get;}

Property Value

the time at which this model was deleted

See Also

PromotionModel Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

PromotionModel.Description Property

[read/write] a description string for this model

public virtual String Description {get; set;}

Property Value

a description string for this model

See Also

PromotionModel Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

PromotionModel.Name Property

[read/write] the name of the model

public virtual String Name {get; set;}

Property Value

the name of the model

See Also

PromotionModel Class | Borland.StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

PromotionModel.ObjectID Property

[read] the model's object ID

public virtual Int32 ObjectID {get;}

Property Value

the model's object ID

See Also

PromotionModel Class | Borland.StarTeam Namespace


PromotionStates Property

Borland StarTeam SDK for .NET

PromotionModel.PromotionStates Property

[read/write] an array of promotion states defining this model

public virtual PromotionStateCollection PromotionStates {get; set;}

Property Value

an array of promotion states defining this model

See Also

PromotionModel Class | Borland.StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

PromotionModel.View Property

[read] the view for this model.

public virtual View View {get;}

Property Value

the view for this model.

See Also

PromotionModel Class | Borland.StarTeam Namespace


PromotionModel Methods

The methods of the PromotionModel class are listed below. For a complete list of PromotionModel class members, see the PromotionModel Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PromotionModel.

Public Instance Methods

AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Update | Stores the modified PromotionModel in the repository. Until this is called all changes to the model are local.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

PromotionModel Class | Borland.StarTeam Namespace


PromotionModel.Update Method

Stores the modified PromotionModel in the repository. Until this is called all changes to the model are local.

public virtual void Update();

See Also

PromotionModel Class | Borland.StarTeam Namespace


PromotionModel.Wrap Method

Dynamically wraps com.starbase.starteam.PromotionModel.

public static PromotionModel Wrap(
PromotionModel impl
);

Parameters

impl
com.starbase.starteam.PromotionModel to be wrapped.

Return Value

PromotionModel

See Also

PromotionModel Class | Borland.StarTeam Namespace


PromotionModel Type Conversions

The type conversions of the PromotionModel class are listed below. For a complete list of PromotionModel class members, see the PromotionModel Members topic.

Public Static Type Conversions

Implicit PromotionModel to PromotionModel Conversion Implicitly convert PromotionModel to com.starbase.starteam.PromotionModel.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

PromotionModel Class | PromotionModel Members | Borland.StarTeam Namespace


PromotionModel Implicit PromotionModel to PromotionModel Conversion

Implicitly convert PromotionModel to com.starbase.starteam.PromotionModel.

public static implicit operator PromotionModel(
PromotionModel arg
);

Parameters

arg
PromotionModel to convert.

Return Value

com.starbase.starteam.PromotionModel

See Also

PromotionModel Class | Borland.StarTeam Namespace


PromotionState Class

This class represents a promotion state associated with a promotion model. This class has no update() method so to save new or modified promotion states you must use PromotionModel.update()

For a list of all members of this type, see PromotionState Members.

System.Object
TypedResource
SimpleTypedResource
PromotionState

public class PromotionState : SimpleTypedResource, ISecurableObject, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PromotionState Members | Borland.StarTeam Namespace


PromotionState Members

PromotionState overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PromotionState.

Public Static Type Conversions

Implicit PromotionState to PromotionState Conversion Implicitly convert PromotionState to com.starbase.starteam.PromotionState.

Public Instance Constructors

PromotionState Overloaded. Initializes a new instance of the PromotionState class.

Public Instance Properties

ACL |
CreatedBy | [read] the user ID that created the state.
CreatedOn | [read] the time at which the state was created.
DeletedBy | [read] the user ID for who deleted this state
DeletedOn | [read] the time at which the state was deleted.
Description | [read/write] this state's description
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
Item (inherited from TypedResource) |
LabelID | [read/write] the label ID for this state
Name | [read/write] the name of the PromotionState.
ObjectID | [read] the object ID for the PromotionState.
Owner |
ParentContainer |
PromotionModel | [read] the "owning" PromotionModel object for this PromotionState.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.

Public Instance Methods

AcquireOwnership |
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission |
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

PromotionState Class | Borland.StarTeam Namespace


PromotionState Constructor

Construct PromotionState from com.starbase.starteam.PromotionState.

Overload List

Create a new PromotionState for the specified model.

public PromotionState(PromotionModel);

Construct PromotionState from com.starbase.starteam.PromotionState.

public PromotionState(PromotionState);

See Also

PromotionState Class | Borland.StarTeam Namespace


PromotionState Constructor (PromotionState)

Construct PromotionState from com.starbase.starteam.PromotionState.

public PromotionState(
PromotionState impl
);

Parameters

impl
The com.starbase.starteam.PromotionState to be wrapped.

See Also

PromotionState Class | Borland.StarTeam Namespace | PromotionState Constructor Overload List


PromotionState Constructor (PromotionModel)

Create a new PromotionState for the specified model.

public PromotionState(
PromotionModel model
);

Parameters

model
the owning PromotionModel

See Also

PromotionState Class | Borland.StarTeam Namespace | PromotionState Constructor Overload List


PromotionState Properties

The properties of the PromotionState class are listed below. For a complete list of PromotionState class members, see the PromotionState Members topic.

Public Instance Properties

ACL |
CreatedBy | [read] the user ID that created the state.
CreatedOn | [read] the time at which the state was created.
DeletedBy | [read] the user ID for who deleted this state
DeletedOn | [read] the time at which the state was deleted.
Description | [read/write] this state's description
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
Item (inherited from TypedResource) |
LabelID | [read/write] the label ID for this state
Name | [read/write] the name of the PromotionState.
ObjectID | [read] the object ID for the PromotionState.
Owner |
ParentContainer |
PromotionModel | [read] the "owning" PromotionModel object for this PromotionState.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

PromotionState Class | Borland.StarTeam Namespace


ACL Property

Borland StarTeam SDK for .NET

PromotionState.ACL Property

public virtual ACL ACL {get; set;}

Implements

ISecurable.ACL

See Also

PromotionState Class | Borland.StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

PromotionState.CreatedBy Property

[read] the user ID that created the state.

public virtual Int32 CreatedBy {get;}

Property Value

the user ID that created the state.

See Also

PromotionState Class | Borland.StarTeam Namespace


CreatedOn Property

Borland StarTeam SDK for .NET

PromotionState.CreatedOn Property

[read] the time at which the state was created.

public virtual DateTime CreatedOn {get;}

Property Value

the time at which the state was created.

See Also

PromotionState Class | Borland.StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

PromotionState.DeletedBy Property

[read] the user ID for who deleted this state

public virtual Int32 DeletedBy {get;}

Property Value

the user ID for who deleted this state

See Also

PromotionState Class | Borland.StarTeam Namespace


DeletedOn Property

Borland StarTeam SDK for .NET

PromotionState.DeletedOn Property

[read] the time at which the state was deleted.

public virtual DateTime DeletedOn {get;}

Property Value

the time at which the state was deleted.

See Also

PromotionState Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

PromotionState.Description Property

[read/write] this state's description

public virtual String Description {get; set;}

Property Value

this state's description

See Also

PromotionState Class | Borland.StarTeam Namespace


LabelID Property

Borland StarTeam SDK for .NET

PromotionState.LabelID Property

[read/write] the label ID for this state

public virtual Int32 LabelID {get; set;}

Property Value

the label ID for this state

See Also

PromotionState Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

PromotionState.Name Property

[read/write] the name of the PromotionState.

public virtual String Name {get; set;}

Property Value

the name of the PromotionState.

See Also

PromotionState Class | Borland.StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

PromotionState.ObjectID Property

[read] the object ID for the PromotionState.

public virtual Int32 ObjectID {get;}

Property Value

the object ID for the PromotionState.

See Also

PromotionState Class | Borland.StarTeam Namespace


Owner Property

Borland StarTeam SDK for .NET

PromotionState.Owner Property

public virtual Int32 Owner {get;}

Implements

ISecurableObject.Owner

See Also

PromotionState Class | Borland.StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

PromotionState.ParentContainer Property

public virtual ISecurableContainer ParentContainer {get;}

Implements

ISecurable.ParentContainer

See Also

PromotionState Class | Borland.StarTeam Namespace


PromotionModel Property

Borland StarTeam SDK for .NET

PromotionState.PromotionModel Property

[read] the "owning" PromotionModel object for this PromotionState.

public virtual PromotionModel PromotionModel {get;}

Property Value

the "owning" PromotionModel object for this PromotionState.

See Also

PromotionState Class | Borland.StarTeam Namespace


PromotionState Methods

The methods of the PromotionState class are listed below. For a complete list of PromotionState class members, see the PromotionState Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PromotionState.

Public Instance Methods

AcquireOwnership |
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission |
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

PromotionState Class | Borland.StarTeam Namespace


PromotionState.AcquireOwnership Method

public virtual void AcquireOwnership();

Implements

ISecurableObject.AcquireOwnership

See Also

PromotionState Class | Borland.StarTeam Namespace


PromotionState.HasPermission Method

public virtual bool HasPermission(
Int32 permissions
);

Implements

ISecurable.HasPermission

See Also

PromotionState Class | Borland.StarTeam Namespace


PromotionState.Wrap Method

Dynamically wraps com.starbase.starteam.PromotionState.

public static PromotionState Wrap(
PromotionState impl
);

Parameters

impl
com.starbase.starteam.PromotionState to be wrapped.

Return Value

PromotionState

See Also

PromotionState Class | Borland.StarTeam Namespace


PromotionState Type Conversions

The type conversions of the PromotionState class are listed below. For a complete list of PromotionState class members, see the PromotionState Members topic.

Public Static Type Conversions

Implicit PromotionState to PromotionState Conversion Implicitly convert PromotionState to com.starbase.starteam.PromotionState.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

PromotionState Class | PromotionState Members | Borland.StarTeam Namespace


PromotionState Implicit PromotionState to PromotionState Conversion

Implicitly convert PromotionState to com.starbase.starteam.PromotionState.

public static implicit operator PromotionState(
PromotionState arg
);

Parameters

arg
PromotionState to convert.

Return Value

com.starbase.starteam.PromotionState

See Also

PromotionState Class | Borland.StarTeam Namespace


PromotionStateCollection Class

A strongly-typed collection of PromotionStates.

For a list of all members of this type, see PromotionStateCollection Members.

System.Object
ArrayAdapter
PromotionStateCollection

public class PromotionStateCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PromotionStateCollection Members | Borland.StarTeam Namespace


PromotionStateCollection Members

PromotionStateCollection overview

Public Static Methods

Wrap Creates a PromotionStateCollection to represent the given array of PromotionState (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit PromotionStateCollection to PromotionState[] Conversion | Converts a PromotionStateCollection to an array of PromotionStates.
Implicit PromotionStateCollection to PromotionState[] Conversion | Converts a PromotionStateCollection from the Borland.StarTeam namespace to a PromotionState[] in the com.starbase.starteam namespace.

Public Instance Constructors

PromotionStateCollection Overloaded. Initializes a new instance of the PromotionStateCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the PromotionState at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a PromotionState to end of the collection.
Append | Overloaded. Appends the PromotionStates of the given PromotionStateCollection to the end of this PromotionStateCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific PromotionState.
CopyTo | Copies all of the PromotionStates in the PromotionStateCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the PromotionState with the given ID.
FindByName | Finds the PromotionState with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific PromotionState in the collection.
Insert | Inserts a PromotionState into the collection at the specified position.
Remove | Removes the first occurrence of a specific PromotionState from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the PromotionStates in this PromotionStateCollection.
Sort | Sorts the PromotionStates in this PromotionStateCollection, using the given comparer.
SortByID | Sorts the PromotionStates in this PromotionStateCollection by ID.
SortByName | Sorts the PromotionStates in this PromotionStateCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection Constructor

Initializes an instance of the PromotionStateCollection class.

Overload List

Initializes an instance of the PromotionStateCollection class.

public PromotionStateCollection();

Initializes an instance of the a PromotionStateCollection class, copying the given array.

public PromotionStateCollection(PromotionState[]);

Initializes an instance of the a PromotionStateCollection class, copying the given collection.

public PromotionStateCollection(PromotionStateCollection);

Initializes an instance of the a PromotionStateCollection class, wrapping the given array of PromotionState (from the com.starbase.starteam namespace).

public PromotionStateCollection(PromotionState[]);

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection Constructor ()

Initializes an instance of the PromotionStateCollection class.

public PromotionStateCollection();

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace | PromotionStateCollection Constructor Overload List


PromotionStateCollection Constructor (PromotionState[])

Initializes an instance of the a PromotionStateCollection class, wrapping the given array of PromotionState (from the com.starbase.starteam namespace).

public PromotionStateCollection(
PromotionState[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace | PromotionStateCollection Constructor Overload List | Wrap


PromotionStateCollection Constructor (PromotionStateCollection)

Initializes an instance of the a PromotionStateCollection class, copying the given collection.

public PromotionStateCollection(
PromotionStateCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member PromotionState objects of the original collection are shared, not copied.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace | PromotionStateCollection Constructor Overload List


PromotionStateCollection Constructor (PromotionState[])

Initializes an instance of the a PromotionStateCollection class, copying the given array.

public PromotionStateCollection(
PromotionState[] array
);

Parameters

array
The array to be copied.

Remarks

The member PromotionState objects of the original array are shared, not copied.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace | PromotionStateCollection Constructor Overload List


PromotionStateCollection Properties

The properties of the PromotionStateCollection class are listed below. For a complete list of PromotionStateCollection class members, see the PromotionStateCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the PromotionState at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

PromotionStateCollection.Item Property

Gets or sets the PromotionState at the specified index.

Overload List

Gets or sets the PromotionState at the specified index.

public PromotionState this[Int32] {get; set;}

Gets the PromotionState with the given name.

public PromotionState this[String] {get;}

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

PromotionStateCollection.Item Property (Int32)

Gets or sets the PromotionState at the specified index.

public PromotionState this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the PromotionState to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace | PromotionStateCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

PromotionStateCollection.Item Property (String)

Gets the PromotionState with the given name.

public PromotionState this[
String name
] {get;}

Parameters

name
The name of the PromotionState to get.

Property Value

The PromotionState with the given name, or null if there is no PromotionState with that name in this PromotionStateCollection. Comparison is case sensitive.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace | PromotionStateCollection.Item Overload List | FindByName


PromotionStateCollection Methods

The methods of the PromotionStateCollection class are listed below. For a complete list of PromotionStateCollection class members, see the PromotionStateCollection Members topic.

Public Static Methods

Wrap Creates a PromotionStateCollection to represent the given array of PromotionState (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a PromotionState to end of the collection.
Append | Overloaded. Appends the PromotionStates of the given PromotionStateCollection to the end of this PromotionStateCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific PromotionState.
CopyTo | Copies all of the PromotionStates in the PromotionStateCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the PromotionState with the given ID.
FindByName | Finds the PromotionState with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific PromotionState in the collection.
Insert | Inserts a PromotionState into the collection at the specified position.
Remove | Removes the first occurrence of a specific PromotionState from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the PromotionStates in this PromotionStateCollection.
Sort | Sorts the PromotionStates in this PromotionStateCollection, using the given comparer.
SortByID | Sorts the PromotionStates in this PromotionStateCollection by ID.
SortByName | Sorts the PromotionStates in this PromotionStateCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.Add Method

Adds a PromotionState to end of the collection.

public int Add(
PromotionState value
);

Parameters

value
The PromotionState to add to the collection.

Return Value

The position into which the new PromotionState was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

PromotionStateCollection.Append Method

Appends the PromotionStates of the given array to the end of this PromotionStateCollection.

Overload List

Appends the PromotionStates of the given array to the end of this PromotionStateCollection.

public PromotionStateCollection Append(PromotionState[]);

Appends the PromotionStates of the given PromotionStateCollection to the end of this PromotionStateCollection.

public PromotionStateCollection Append(PromotionStateCollection);

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.Append Method (PromotionState[])

Appends the PromotionStates of the given array to the end of this PromotionStateCollection.

public PromotionStateCollection Append(
PromotionState[] array
);

Parameters

array
The array whose PromotionStates are to be appended to this PromotionStateCollection.

Return Value

This PromotionStateCollection, modified to include the new PromotionStates.

Remarks

The PromotionStateCollection is modified to include the new members. The individual PromotionState objects are shared, not copied.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace | PromotionStateCollection.Append Overload List


PromotionStateCollection.Append Method (PromotionStateCollection)

Appends the PromotionStates of the given PromotionStateCollection to the end of this PromotionStateCollection.

public PromotionStateCollection Append(
PromotionStateCollection collection
);

Parameters

collection
The PromotionStateCollection whose PromotionStates are to be appended to this PromotionStateCollection.

Return Value

This PromotionStateCollection, modified to include the new PromotionStates.

Remarks

The PromotionStateCollection is modified to include the new members. The individual PromotionState objects are shared, not copied.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace | PromotionStateCollection.Append Overload List


PromotionStateCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.PromotionState[].

Implements

IWrapper.Unwrap

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.Contains Method

Determines whether or not the collection contains a specific PromotionState.

public bool Contains(
PromotionState value
);

Parameters

value
The PromotionState to locate in the collection.

Return Value

true if the PromotionState is found in the collection; otherwise, false.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.CopyTo Method

Copies all of the PromotionStates in the PromotionStateCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
PromotionState[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the PromotionStates copied from the PromotionStateCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of PromotionStates in the source PromotionStateCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source PromotionStateCollection cannot be cast automatically to the type of the destination array.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.FindByID Method

Finds the PromotionState with the given ID.

public PromotionState FindByID(
Int32 id
);

Parameters

id
The ID of the PromotionState to be found.

Return Value

The PromotionState with the given ID, or null if there is no PromotionState with that ID in this PromotionStateCollection.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.FindByName Method

Finds the PromotionState with the given name.

public PromotionState FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the PromotionState to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The PromotionState with the given name, or null if there is no PromotionState with that name in this PromotionStateCollection.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.IndexOf Method

Determines the index of a specific PromotionState in the collection.

public int IndexOf(
PromotionState value
);

Parameters

value
The PromotionState to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.Insert Method

Inserts a PromotionState into the collection at the specified position.

public void Insert(
Int32 index,
PromotionState value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The PromotionState to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.Remove Method

Removes the first occurrence of a specific PromotionState from the collection.

public void Remove(
PromotionState value
);

Parameters

value
The PromotionState to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.Reverse Method

Reverses the order of the PromotionStates in this PromotionStateCollection.

new public PromotionStateCollection Reverse();

Return Value

This PromotionStateCollection, modified such that the PromotionStates are reversed.

Remarks

The PromotionStateCollection is modified in place.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.Sort Method

Sorts the PromotionStates in this PromotionStateCollection, using the given comparer.

new public PromotionStateCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two PromotionStates.

Return Value

This PromotionStateCollection, modified such that the PromotionStates are sorted.

Remarks

The PromotionStateCollection is modified in place.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.SortByID Method

Sorts the PromotionStates in this PromotionStateCollection by ID.

public PromotionStateCollection SortByID();

Return Value

This PromotionStateCollection, modified such that the PromotionStates are sorted by ID.

Remarks

The PromotionStateCollection is modified in place.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.SortByName Method

Sorts the PromotionStates in this PromotionStateCollection by name.

public PromotionStateCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This PromotionStateCollection, modified such that the PromotionStates are sorted by name.

Remarks

The PromotionStateCollection is modified in place.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection.Wrap Method

Creates a PromotionStateCollection to represent the given array of PromotionState (from the com.starbase.starteam namespace).

public static PromotionStateCollection Wrap(
PromotionState[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new PromotionStateCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a PromotionState[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection Type Conversions

The type conversions of the PromotionStateCollection class are listed below. For a complete list of PromotionStateCollection class members, see the PromotionStateCollection Members topic.

Public Static Type Conversions

Implicit PromotionStateCollection to PromotionState[] Conversion | Converts a PromotionStateCollection to an array of PromotionStates.
Implicit PromotionStateCollection to PromotionState[] Conversion | Converts a PromotionStateCollection from the Borland.StarTeam namespace to a PromotionState[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PromotionStateCollection Class | PromotionStateCollection Members | Borland.StarTeam Namespace


PromotionStateCollection Implicit PromotionStateCollection to PromotionState[] Conversion

Converts a PromotionStateCollection to an array of PromotionStates.

public static implicit operator PromotionState[](
PromotionStateCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new PromotionState wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one PromotionState wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


PromotionStateCollection Implicit PromotionStateCollection to PromotionState[] Conversion

Converts a PromotionStateCollection from the Borland.StarTeam namespace to a PromotionState[] in the com.starbase.starteam namespace.

public static implicit operator PromotionState[](
PromotionStateCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, PromotionStateCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

PromotionStateCollection Class | Borland.StarTeam Namespace


Property Class

Each different Type supported by a StarTeam Server (e.g. File, Change Request, Topic...) has an associated set of properties. The Property class provides information about a Type's property.

For a list of all members of this type, see Property Members.

System.Object
CacheRef
Property

public class Property : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Property Members | Borland.StarTeam Namespace


Property Members

Property overview

Public Static Methods

AreValuesEqual | Compares two property values for equality. Handles all StarTeam data types in a "natural" fashion. For example, two IDARRAY values are considered equal if they contain the same IDs in the same order.
ResolveAllDependencies | This will return the full set of dependent properties based on the specified set. The returned set will include the specified properties. The returned set will not have duplicate elements.
Wrap | Dynamically wraps com.starbase.starteam.Property.

Public Static Type Conversions

Implicit Property to Property Conversion Implicitly convert Property to com.starbase.starteam.Property.

Public Instance Constructors

Property Constructor Construct Property from com.starbase.starteam.Property.

Public Instance Properties

ClassIDOfValue | [read] the class ID for values of this property.
DebugString | [read] a debug string for this property.
DefaultValue | [read] the property's default value.
DependentProperties | [read] the properties that this property depends upon
DisplayName | [read] this property's display name.
EnumeratedValues | [read] an array of EnumeratedValue objects
EnumValues | [read] an array of integer enum codes.
ID | [read] this property's internal ID.
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDisabled | [read] true is the property is flagged as disabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsTimeTruncated | [read] true if the time part of this property should be truncated during display; valid for time-valued properties only.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read] The maximum number of characters permitted.
Name | [read] this property's internal name.
Translations | [read]
Type | [read] the Type object that "owns" this property.
TypeCode | [read] this property's type code.

Public Instance Methods

Clone (inherited from CacheRef) |
Coerce | Converts property values to the appropriate type when possible. For example, a property whose value is an Integer one may pass in a Byte or Short without precision loss. This method will return the approrpate value when possible or throw a ClassCastException when not. The supported conversions are as follows: Integer: values will accept Integer, Short, or Byte Double: values will accept Number (and consequently Double, Long, Float, Integer, Short, Byte) OLEDate: values will accept OLEDate and java.util.Date
Copy | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetEnumDisabled | Returns true if the given enumerated value has been marked disabled. This will throw an IllegalArgumentException if the code is not a valid enum for this Property.
GetEnumDisplayName | Return the display name for the enumerated value with the specified code. This will throw an IllegalArgumentException if the code is not a valid enum for this Property.
GetEnumTranslations | Returns a copy of the Translations for the specified enumerated value. Will return null if the property is client calculated.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsInstance | Returns true if the specified object is a legal value for this property.
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Property Class | Borland.StarTeam Namespace


Property Constructor

Construct Property from com.starbase.starteam.Property.

public Property(
Property impl
);

Parameters

impl
The com.starbase.starteam.Property to be wrapped.

See Also

Property Class | Borland.StarTeam Namespace


Property Properties

The properties of the Property class are listed below. For a complete list of Property class members, see the Property Members topic.

Public Instance Properties

ClassIDOfValue | [read] the class ID for values of this property.
DebugString | [read] a debug string for this property.
DefaultValue | [read] the property's default value.
DependentProperties | [read] the properties that this property depends upon
DisplayName | [read] this property's display name.
EnumeratedValues | [read] an array of EnumeratedValue objects
EnumValues | [read] an array of integer enum codes.
ID | [read] this property's internal ID.
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDisabled | [read] true is the property is flagged as disabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsTimeTruncated | [read] true if the time part of this property should be truncated during display; valid for time-valued properties only.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read] The maximum number of characters permitted.
Name | [read] this property's internal name.
Translations | [read]
Type | [read] the Type object that "owns" this property.
TypeCode | [read] this property's type code.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Property Class | Borland.StarTeam Namespace


ClassIDOfValue Property

Borland StarTeam SDK for .NET

Property.ClassIDOfValue Property

[read] the class ID for values of this property.

public virtual Int32 ClassIDOfValue {get;}

Property Value

the class ID for values of this property.

See Also

Property Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Property.DebugString Property

[read] a debug string for this property.

public virtual String DebugString {get;}

Property Value

a debug string for this property.

See Also

Property Class | Borland.StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

Property.DefaultValue Property

[read] the property's default value.

public virtual Object DefaultValue {get;}

Property Value

the property's default value.

See Also

Property Class | Borland.StarTeam Namespace


DependentProperties Property

Borland StarTeam SDK for .NET

Property.DependentProperties Property

[read] the properties that this property depends upon

public virtual PropertyCollection DependentProperties {get;}

Property Value

the properties that this property depends upon

See Also

Property Class | Borland.StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Property.DisplayName Property

[read] this property's display name.

public virtual String DisplayName {get;}

Property Value

this property's display name.

See Also

Property Class | Borland.StarTeam Namespace


EnumeratedValues Property

Borland StarTeam SDK for .NET

Property.EnumeratedValues Property

[read] an array of EnumeratedValue objects

public virtual EnumeratedValueCollection EnumeratedValues {get;}

Property Value

an array of EnumeratedValue objects

See Also

Property Class | Borland.StarTeam Namespace


EnumValues Property

Borland StarTeam SDK for .NET

Property.EnumValues Property

[read] an array of integer enum codes.

public virtual Int32[] EnumValues {get;}

Property Value

an array of integer enum codes.

See Also

Property Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Property.ID Property

[read] this property's internal ID.

public virtual Int32 ID {get;}

Property Value

this property's internal ID.

See Also

Property Class | Borland.StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

Property.IsAdvanced Property

[read] true if the property is considered advanced.

public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

Property Class | Borland.StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

Property.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

Property Class | Borland.StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

Property.IsClientCalculated Property

[read] true if the property is client calculated.

public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

Property Class | Borland.StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

Property.IsDescriptor Property

[read] true is this property is a descriptor.

public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

Property Class | Borland.StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

Property.IsDisabled Property

[read] true is the property is flagged as disabled.

public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

Property Class | Borland.StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

Property.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

Property Class | Borland.StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

Property.IsHeader Property

[read] true if this property is stored in a header field in the database

public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

Property Class | Borland.StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

Property.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

Property Class | Borland.StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

Property.IsRequired Property

[read] true if a value for this property is required; valid for user-defined properties only.

public virtual Boolean IsRequired {get;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

Property Class | Borland.StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

Property.IsRestricted Property

[read] true if this is a restricted property.

public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

Property Class | Borland.StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

Property.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

Property Class | Borland.StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

Property.IsServerCalculated Property

[read] true if the property if server calculated.

public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

Property Class | Borland.StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

Property.IsStored Property

[read] true if the property is stored in the server's database.

public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

Property Class | Borland.StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

Property.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

Property Class | Borland.StarTeam Namespace


IsTimeTruncated Property

Borland StarTeam SDK for .NET

Property.IsTimeTruncated Property

[read] true if the time part of this property should be truncated during display; valid for time-valued properties only.

public virtual Boolean IsTimeTruncated {get;}

Property Value

true if the time part of this property should be truncated during display; valid for time-valued properties only.

See Also

Property Class | Borland.StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

Property.IsUserCustomized Property

[read] true if this property is a user defined property.

public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

Property Class | Borland.StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

Property.IsUserDefined Property

[read] true if the property is user defined.

public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

Property Class | Borland.StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

Property.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

Property Class | Borland.StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

Property.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

Property Class | Borland.StarTeam Namespace


MaxLength Property

Borland StarTeam SDK for .NET

Property.MaxLength Property

[read] The maximum number of characters permitted.

public virtual Int32 MaxLength {get;}

Property Value

The maximum number of characters permitted.

See Also

Property Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Property.Name Property

[read] this property's internal name.

public virtual String Name {get;}

Property Value

this property's internal name.

See Also

Property Class | Borland.StarTeam Namespace


Translations Property

Borland StarTeam SDK for .NET

Property.Translations Property

[read]

public virtual Translations Translations {get;}

See Also

Property Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

Property.Type Property

[read] the Type object that "owns" this property.

public virtual Type Type {get;}

Property Value

the Type object that "owns" this property.

See Also

Property Class | Borland.StarTeam Namespace


TypeCode Property

Borland StarTeam SDK for .NET

Property.TypeCode Property

[read] this property's type code.

public virtual Int32 TypeCode {get;}

Property Value

this property's type code.

See Also

Property Class | Borland.StarTeam Namespace


Property Methods

The methods of the Property class are listed below. For a complete list of Property class members, see the Property Members topic.

Public Static Methods

AreValuesEqual | Compares two property values for equality. Handles all StarTeam data types in a "natural" fashion. For example, two IDARRAY values are considered equal if they contain the same IDs in the same order.
ResolveAllDependencies | This will return the full set of dependent properties based on the specified set. The returned set will include the specified properties. The returned set will not have duplicate elements.
Wrap | Dynamically wraps com.starbase.starteam.Property.

Public Instance Methods

Clone (inherited from CacheRef) |
Coerce | Converts property values to the appropriate type when possible. For example, a property whose value is an Integer one may pass in a Byte or Short without precision loss. This method will return the approrpate value when possible or throw a ClassCastException when not. The supported conversions are as follows: Integer: values will accept Integer, Short, or Byte Double: values will accept Number (and consequently Double, Long, Float, Integer, Short, Byte) OLEDate: values will accept OLEDate and java.util.Date
Copy | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetEnumDisabled | Returns true if the given enumerated value has been marked disabled. This will throw an IllegalArgumentException if the code is not a valid enum for this Property.
GetEnumDisplayName | Return the display name for the enumerated value with the specified code. This will throw an IllegalArgumentException if the code is not a valid enum for this Property.
GetEnumTranslations | Returns a copy of the Translations for the specified enumerated value. Will return null if the property is client calculated.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsInstance | Returns true if the specified object is a legal value for this property.
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Property Class | Borland.StarTeam Namespace


Property.AreValuesEqual Method

Compares two property values for equality. Handles all StarTeam data types in a "natural" fashion. For example, two IDARRAY values are considered equal if they contain the same IDs in the same order.

public static bool AreValuesEqual(
Object v1,
Object v2
);

Parameters

v1
Property value.
v2
Another property value.

Return Value

true if the two values are equal.

See Also

Property Class | Borland.StarTeam Namespace


Property.Coerce Method

Converts property values to the appropriate type when possible. For example, a property whose value is an Integer one may pass in a Byte or Short without precision loss. This method will return the approrpate value when possible or throw a ClassCastException when not. The supported conversions are as follows:

Integer: values will accept Integer, Short, or Byte

Double: values will accept Number (and consequently Double, Long, Float, Integer, Short, Byte)

OLEDate: values will accept OLEDate and java.util.Date

public virtual object Coerce(
Object value
);

Parameters

value
the property value to be coerced to the proper type. This cannot be null.

Return Value

the coerced value. It may remain unchanged if of the proper type already.

Exceptions

Exception Type | Condition
 | System.InvalidCastException

See Also

Property Class | Borland.StarTeam Namespace


Property.Copy Method

Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes().

The copied property will have the same parent Type as the original property. The Type object is not copied.

For enumerated properties, the enumerated values are copied.

For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.

public virtual Property Copy();

Return Value

A copy of this property object.

See Also

Property Class | Borland.StarTeam Namespace | isEqualTo


Property.GetDisplayValue Method

Converts the given property value to a string suitable for display.

public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

Property Class | Borland.StarTeam Namespace


Property.GetEnumDisabled Method

Returns true if the given enumerated value has been marked disabled. This will throw an IllegalArgumentException if the code is not a valid enum for this Property.

public virtual bool GetEnumDisabled(
Int32 code
);

Parameters

code
the enumerated value code

Return Value

true if the enumerated value has been marked disabled, and false otherwise.

See Also

Property Class | Borland.StarTeam Namespace | getEnumValues | getEnumDisplayName


Property.GetEnumDisplayName Method

Return the display name for the enumerated value with the specified code. This will throw an IllegalArgumentException if the code is not a valid enum for this Property.

public virtual string GetEnumDisplayName(
Int32 code
);

Parameters

code
the enumerated value code

Return Value

the display name String for the specified code.

See Also

Property Class | Borland.StarTeam Namespace | getEnumValues | getEnumDisabled


Property.GetEnumTranslations Method

Returns a copy of the Translations for the specified enumerated value. Will return null if the property is client calculated.

public virtual Translations GetEnumTranslations(
Int32 code
);

Parameters

code

See Also

Property Class | Borland.StarTeam Namespace


Property.IsEqualTo Method

Compares two Property objects.

The parent Types are compared by ClassID.

For enumerated properties, the enumerated values are compared using a deep comparison.

For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.

public virtual bool IsEqualTo(
Property property
);

Parameters

property

Return Value

true if no differences were found.

See Also

Property Class | Borland.StarTeam Namespace | copy


Property.IsInstance Method

Returns true if the specified object is a legal value for this property.

public virtual bool IsInstance(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

Property Class | Borland.StarTeam Namespace


Property.ResolveAllDependencies Method

This will return the full set of dependent properties based on the specified set. The returned set will include the specified properties. The returned set will not have duplicate elements.

public static PropertyCollection ResolveAllDependencies(
PropertyCollection props
);

Parameters

props

See Also

Property Class | Borland.StarTeam Namespace | getDependentProperties


Property.Wrap Method

Dynamically wraps com.starbase.starteam.Property.

public static Property Wrap(
Property impl
);

Parameters

impl
com.starbase.starteam.Property to be wrapped.

Return Value

Property

See Also

Property Class | Borland.StarTeam Namespace


Property Type Conversions

The type conversions of the Property class are listed below. For a complete list of Property class members, see the Property Members topic.

Public Static Type Conversions

Implicit Property to Property Conversion Implicitly convert Property to com.starbase.starteam.Property.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

Property Class | Property Members | Borland.StarTeam Namespace


Property Implicit Property to Property Conversion

Implicitly convert Property to com.starbase.starteam.Property.

public static implicit operator Property(
Property arg
);

Parameters

arg
Property to convert.

Return Value

com.starbase.starteam.Property

See Also

Property Class | Borland.StarTeam Namespace


Property.Types Class

For a list of all members of this type, see Property.Types Members.

System.Object
Property.Types

public class Property.Types : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Property.Types Members | Borland.StarTeam Namespace


Property.Types Members

Property.Types overview

Public Static Properties

BINARY
COMMENT_ID
ENUMERATED
FLOAT64
IDARRAY
INT32
OBJECT_ID
TEXT
TIME
UNKNOWN
USER_ID
VIEW_ID

Public Static Type Conversions

Implicit Property.Types to Property.Types Conversion

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.Property.Types.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Property.Types.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.Property.Types.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Property.Types Class | Borland.StarTeam Namespace


Property.Types Properties

The properties of the Property.Types class are listed below. For a complete list of Property.Types class members, see the Property.Types Members topic.

Public Static Properties

BINARY
COMMENT_ID
ENUMERATED
FLOAT64
IDARRAY
INT32
OBJECT_ID
TEXT
TIME
UNKNOWN
USER_ID
VIEW_ID

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Property.Types Class | Borland.StarTeam Namespace


BINARY Property

Borland StarTeam SDK for .NET

Property.Types.BINARY Property

public static Int32 BINARY {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Property.Types.COMMENT_ID Property

public static Int32 COMMENT_ID {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


ENUMERATED Property

Borland StarTeam SDK for .NET

Property.Types.ENUMERATED Property

public static Int32 ENUMERATED {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


FLOAT64 Property

Borland StarTeam SDK for .NET

Property.Types.FLOAT64 Property

public static Int32 FLOAT64 {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


IDARRAY Property

Borland StarTeam SDK for .NET

Property.Types.IDARRAY Property

public static Int32 IDARRAY {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


INT32 Property

Borland StarTeam SDK for .NET

Property.Types.INT32 Property

public static Int32 INT32 {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


OBJECT_ID Property

Borland StarTeam SDK for .NET

Property.Types.OBJECT_ID Property

public static Int32 OBJECT_ID {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


TEXT Property

Borland StarTeam SDK for .NET

Property.Types.TEXT Property

public static Int32 TEXT {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


TIME Property

Borland StarTeam SDK for .NET

Property.Types.TIME Property

public static Int32 TIME {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

Property.Types.UNKNOWN Property

public static Int32 UNKNOWN {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


USER_ID Property

Borland StarTeam SDK for .NET

Property.Types.USER_ID Property

public static Int32 USER_ID {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


VIEW_ID Property

Borland StarTeam SDK for .NET

Property.Types.VIEW_ID Property

public static Int32 VIEW_ID {get;}

See Also

Property.Types Class | Borland.StarTeam Namespace


Property.Types Methods

The methods of the Property.Types class are listed below. For a complete list of Property.Types class members, see the Property.Types Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.Property.Types.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Property.Types.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.Property.Types.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Property.Types Class | Borland.StarTeam Namespace


Property.Types.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.Property.Types

Implements

IWrapper.Unwrap

See Also

Property.Types Class | Borland.StarTeam Namespace


Property.Types.Equals Method

Delegate Equals() to com.starbase.starteam.Property.Types.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.Property.Types.Equals(obj).

See Also

Property.Types Class | Borland.StarTeam Namespace


Property.Types.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.Property.Types.

public override int GetHashCode();

Return Value

com.starbase.starteam.Property.Types.GetHashCode().

See Also

Property.Types Class | Borland.StarTeam Namespace


Property.Types.ToString Method

Delegate ToString() to com.starbase.starteam.Property.Types.

public override string ToString();

Return Value

com.starbase.starteam.Property.Types.ToString()

See Also

Property.Types Class | Borland.StarTeam Namespace


Property.Types Type Conversions

The type conversions of the Property.Types class are listed below. For a complete list of Property.Types class members, see the Property.Types Members topic.

Public Static Type Conversions

Implicit Property.Types to Property.Types Conversion

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Property.Types Class | Property.Types Members | Borland.StarTeam Namespace


Property.Types Implicit Property.Types to Property.Types Conversion

public static implicit operator Types(
Property.Types arg
);

See Also

Property.Types Class | Borland.StarTeam Namespace


PropertyCollection Class

A strongly-typed collection of Propertys.

For a list of all members of this type, see PropertyCollection Members.

System.Object
ArrayAdapter
PropertyCollection

public class PropertyCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PropertyCollection Members | Borland.StarTeam Namespace


PropertyCollection Members

PropertyCollection overview

Public Static Methods

Wrap Creates a PropertyCollection to represent the given array of Property (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit PropertyCollection to Property[] Conversion | Converts a PropertyCollection to an array of Propertys.
Implicit PropertyCollection to Property[] Conversion | Converts a PropertyCollection from the Borland.StarTeam namespace to a Property[] in the com.starbase.starteam namespace.

Public Instance Constructors

PropertyCollection Overloaded. Initializes a new instance of the PropertyCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Property at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Property to end of the collection.
Append | Overloaded. Appends the Propertys of the given PropertyCollection to the end of this PropertyCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Property.
CopyTo | Copies all of the Propertys in the PropertyCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Property with the given ID.
FindByName | Finds the Property with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Property in the collection.
Insert | Inserts a Property into the collection at the specified position.
Remove | Removes the first occurrence of a specific Property from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Propertys in this PropertyCollection.
Sort | Sorts the Propertys in this PropertyCollection, using the given comparer.
SortByID | Sorts the Propertys in this PropertyCollection by ID.
SortByName | Sorts the Propertys in this PropertyCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection Constructor

Initializes an instance of the PropertyCollection class.

Overload List

Initializes an instance of the PropertyCollection class.

public PropertyCollection();

Initializes an instance of the a PropertyCollection class, copying the given array.

public PropertyCollection(Property[]);

Initializes an instance of the a PropertyCollection class, copying the given collection.

public PropertyCollection(PropertyCollection);

Initializes an instance of the a PropertyCollection class, wrapping the given array of Property (from the com.starbase.starteam namespace).

public PropertyCollection(Property[]);

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection Constructor ()

Initializes an instance of the PropertyCollection class.

public PropertyCollection();

See Also

PropertyCollection Class | Borland.StarTeam Namespace | PropertyCollection Constructor Overload List


PropertyCollection Constructor (Property[])

Initializes an instance of the a PropertyCollection class, wrapping the given array of Property (from the com.starbase.starteam namespace).

public PropertyCollection(
Property[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

PropertyCollection Class | Borland.StarTeam Namespace | PropertyCollection Constructor Overload List | Wrap


PropertyCollection Constructor (PropertyCollection)

Initializes an instance of the a PropertyCollection class, copying the given collection.

public PropertyCollection(
PropertyCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Property objects of the original collection are shared, not copied.

See Also

PropertyCollection Class | Borland.StarTeam Namespace | PropertyCollection Constructor Overload List


PropertyCollection Constructor (Property[])

Initializes an instance of the a PropertyCollection class, copying the given array.

public PropertyCollection(
Property[] array
);

Parameters

array
The array to be copied.

Remarks

The member Property objects of the original array are shared, not copied.

See Also

PropertyCollection Class | Borland.StarTeam Namespace | PropertyCollection Constructor Overload List


PropertyCollection Properties

The properties of the PropertyCollection class are listed below. For a complete list of PropertyCollection class members, see the PropertyCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Property at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

PropertyCollection.Item Property

Gets or sets the Property at the specified index.

Overload List

Gets or sets the Property at the specified index.

public Property this[Int32] {get; set;}

Gets the Property with the given name.

public Property this[String] {get;}

See Also

PropertyCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

PropertyCollection.Item Property (Int32)

Gets or sets the Property at the specified index.

public Property this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Property to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

PropertyCollection Class | Borland.StarTeam Namespace | PropertyCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

PropertyCollection.Item Property (String)

Gets the Property with the given name.

public Property this[
String name
] {get;}

Parameters

name
The name of the Property to get.

Property Value

The Property with the given name, or null if there is no Property with that name in this PropertyCollection. Comparison is case sensitive.

See Also

PropertyCollection Class | Borland.StarTeam Namespace | PropertyCollection.Item Overload List | FindByName


PropertyCollection Methods

The methods of the PropertyCollection class are listed below. For a complete list of PropertyCollection class members, see the PropertyCollection Members topic.

Public Static Methods

Wrap Creates a PropertyCollection to represent the given array of Property (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a Property to end of the collection.
Append | Overloaded. Appends the Propertys of the given PropertyCollection to the end of this PropertyCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Property.
CopyTo | Copies all of the Propertys in the PropertyCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Property with the given ID.
FindByName | Finds the Property with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Property in the collection.
Insert | Inserts a Property into the collection at the specified position.
Remove | Removes the first occurrence of a specific Property from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Propertys in this PropertyCollection.
Sort | Sorts the Propertys in this PropertyCollection, using the given comparer.
SortByID | Sorts the Propertys in this PropertyCollection by ID.
SortByName | Sorts the Propertys in this PropertyCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.Add Method

Adds a Property to end of the collection.

public int Add(
Property value
);

Parameters

value
The Property to add to the collection.

Return Value

The position into which the new Property was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

PropertyCollection.Append Method

Appends the Propertys of the given array to the end of this PropertyCollection.

Overload List

Appends the Propertys of the given array to the end of this PropertyCollection.

public PropertyCollection Append(Property[]);

Appends the Propertys of the given PropertyCollection to the end of this PropertyCollection.

public PropertyCollection Append(PropertyCollection);

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.Append Method (Property[])

Appends the Propertys of the given array to the end of this PropertyCollection.

public PropertyCollection Append(
Property[] array
);

Parameters

array
The array whose Propertys are to be appended to this PropertyCollection.

Return Value

This PropertyCollection, modified to include the new Propertys.

Remarks

The PropertyCollection is modified to include the new members. The individual Property objects are shared, not copied.

See Also

PropertyCollection Class | Borland.StarTeam Namespace | PropertyCollection.Append Overload List


PropertyCollection.Append Method (PropertyCollection)

Appends the Propertys of the given PropertyCollection to the end of this PropertyCollection.

public PropertyCollection Append(
PropertyCollection collection
);

Parameters

collection
The PropertyCollection whose Propertys are to be appended to this PropertyCollection.

Return Value

This PropertyCollection, modified to include the new Propertys.

Remarks

The PropertyCollection is modified to include the new members. The individual Property objects are shared, not copied.

See Also

PropertyCollection Class | Borland.StarTeam Namespace | PropertyCollection.Append Overload List


PropertyCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.Property[].

Implements

IWrapper.Unwrap

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.Contains Method

Determines whether or not the collection contains a specific Property.

public bool Contains(
Property value
);

Parameters

value
The Property to locate in the collection.

Return Value

true if the Property is found in the collection; otherwise, false.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.CopyTo Method

Copies all of the Propertys in the PropertyCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Property[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Propertys copied from the PropertyCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Propertys in the source PropertyCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source PropertyCollection cannot be cast automatically to the type of the destination array.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.FindByID Method

Finds the Property with the given ID.

public Property FindByID(
Int32 id
);

Parameters

id
The ID of the Property to be found.

Return Value

The Property with the given ID, or null if there is no Property with that ID in this PropertyCollection.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.FindByName Method

Finds the Property with the given name.

public Property FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the Property to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The Property with the given name, or null if there is no Property with that name in this PropertyCollection.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.IndexOf Method

Determines the index of a specific Property in the collection.

public int IndexOf(
Property value
);

Parameters

value
The Property to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.Insert Method

Inserts a Property into the collection at the specified position.

public void Insert(
Int32 index,
Property value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Property to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.Remove Method

Removes the first occurrence of a specific Property from the collection.

public void Remove(
Property value
);

Parameters

value
The Property to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.Reverse Method

Reverses the order of the Propertys in this PropertyCollection.

new public PropertyCollection Reverse();

Return Value

This PropertyCollection, modified such that the Propertys are reversed.

Remarks

The PropertyCollection is modified in place.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.Sort Method

Sorts the Propertys in this PropertyCollection, using the given comparer.

new public PropertyCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Propertys.

Return Value

This PropertyCollection, modified such that the Propertys are sorted.

Remarks

The PropertyCollection is modified in place.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.SortByID Method

Sorts the Propertys in this PropertyCollection by ID.

public PropertyCollection SortByID();

Return Value

This PropertyCollection, modified such that the Propertys are sorted by ID.

Remarks

The PropertyCollection is modified in place.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.SortByName Method

Sorts the Propertys in this PropertyCollection by name.

public PropertyCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This PropertyCollection, modified such that the Propertys are sorted by name.

Remarks

The PropertyCollection is modified in place.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection.Wrap Method

Creates a PropertyCollection to represent the given array of Property (from the com.starbase.starteam namespace).

public static PropertyCollection Wrap(
Property[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new PropertyCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a Property[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection Type Conversions

The type conversions of the PropertyCollection class are listed below. For a complete list of PropertyCollection class members, see the PropertyCollection Members topic.

Public Static Type Conversions

Implicit PropertyCollection to Property[] Conversion | Converts a PropertyCollection to an array of Propertys.
Implicit PropertyCollection to Property[] Conversion | Converts a PropertyCollection from the Borland.StarTeam namespace to a Property[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PropertyCollection Class | PropertyCollection Members | Borland.StarTeam Namespace


PropertyCollection Implicit PropertyCollection to Property[] Conversion

Converts a PropertyCollection to an array of Propertys.

public static implicit operator Property[](
PropertyCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Property wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Property wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyCollection Implicit PropertyCollection to Property[] Conversion

Converts a PropertyCollection from the Borland.StarTeam namespace to a Property[] in the com.starbase.starteam namespace.

public static implicit operator Property[](
PropertyCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, PropertyCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

PropertyCollection Class | Borland.StarTeam Namespace


PropertyEnums Class

This class provides a conventient place to get the values of various built-in StarTeam enumerated item properties. The member variables here should be used instead of hard-coded numeric values. This does lead to a bit of indirection but is the safest way of being sure you are using the right enumerated value. This class also insulates you from any enumerated value changes that could occur from one release of StarTeam to the next.

For a list of all members of this type, see PropertyEnums Members.

System.Object
PropertyEnums

public class PropertyEnums : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PropertyEnums Members | Borland.StarTeam Namespace


PropertyEnums Members

PropertyEnums overview

Public Static Properties

FILE_EOL_CLIENT_DEFINED
FILE_EOL_FIXED_CR
FILE_EOL_FIXED_CRLF
FILE_EOL_FIXED_LF
PROJECT_PROCESS_LINKS_DIRECT
PROJECT_PROCESS_LINKS_VIA_PROCESS_TASK
REQ_STATUS_ACCEPTED
REQ_STATUS_APPROVED
REQ_STATUS_COMPLETE
REQ_STATUS_DEFERRED
REQ_STATUS_DRAFT
REQ_STATUS_PENDING
REQ_STATUS_READY
REQ_STATUS_REJECTED
REQ_STATUS_REVIEW
REQ_STATUS_SUBMITTED
TASK_USAGE_CHECKIN
TASK_USAGE_OTHER
TASK_USAGE_PROMOTE
TASK_USAGE_REBASE
TASK_USAGE_REPLICATE

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PropertyEnums.

Public Static Type Conversions

Implicit PropertyEnums to PropertyEnums Conversion Implicitly convert PropertyEnums to com.starbase.starteam.PropertyEnums.

Public Instance Constructors

PropertyEnums Constructor Construct PropertyEnums from com.starbase.starteam.PropertyEnums.

Public Instance Properties

AM_I_RECIPIENT_NO
AM_I_RECIPIENT_YES
AUDIT_EVENT_ID_ADDED
AUDIT_EVENT_ID_BRANCHED
AUDIT_EVENT_ID_CHECKED_IN
AUDIT_EVENT_ID_CHECKED_OUT
AUDIT_EVENT_ID_COMMENT_EDITED
AUDIT_EVENT_ID_CREATED
AUDIT_EVENT_ID_DELETED
AUDIT_EVENT_ID_ITEM_OVERWRITTEN
AUDIT_EVENT_ID_LOCK_BROKEN
AUDIT_EVENT_ID_LOCKED
AUDIT_EVENT_ID_MODIFIED
AUDIT_EVENT_ID_MOVED_FROM
AUDIT_EVENT_ID_MOVED_TO
AUDIT_EVENT_ID_SHARED
AUDIT_EVENT_ID_UNLOCKED
AUDIT_EVENT_ID_VAULT_CONVERTED
BRANCH_ON_CHANGE_NO
BRANCH_ON_CHANGE_YES
BRANCH_STATE_BRANCHED
BRANCH_STATE_NOT_BRANCHED
BRANCH_STATE_ROOT
CR_PLATFORM_ALL
CR_PLATFORM_MACOS
CR_PLATFORM_OTHER
CR_PLATFORM_UNIX
CR_PLATFORM_WINDOWS_2000
CR_PLATFORM_WINDOWS_95
CR_PLATFORM_WINDOWS_98
CR_PLATFORM_WINDOWS_NT
CR_PRIORITY_NO
CR_PRIORITY_YES
CR_SEVERITY_HIGH
CR_SEVERITY_LOW
CR_SEVERITY_MEDIUM
CR_STATUS_AS_DESIGNED
CR_STATUS_CANNOT_REPRODUCE
CR_STATUS_CLOSED_AS_DESIGNED
CR_STATUS_CLOSED_CANNOT_REPRODUCE
CR_STATUS_CLOSED_DEFERRED
CR_STATUS_CLOSED_DOCUMENTED
CR_STATUS_CLOSED_FIXED
CR_STATUS_CLOSED_IS_DUPLICATE
CR_STATUS_DEFERRED
CR_STATUS_DOCUMENTED
CR_STATUS_FIXED
CR_STATUS_IN_PROGRESS
CR_STATUS_IS_DUPLICATE
CR_STATUS_NEW
CR_STATUS_OPEN
CR_STATUS_VERIFIED_AS_DESIGNED
CR_STATUS_VERIFIED_CANNOT_REPRODUCE
CR_STATUS_VERIFIED_DEFERRED
CR_STATUS_VERIFIED_DOCUMENTED
CR_STATUS_VERIFIED_FIXED
CR_STATUS_VERIFIED_IS_DUPLICATE
CR_TYPE_DEFECT
CR_TYPE_SUGGESTION
FILE_ARCHIVE_FORMAT_NATIVE_I
FILE_ARCHIVE_FORMAT_NATIVE_II
FILE_ARCHIVE_FORMAT_NOT_APPLICABLE
FILE_ARCHIVE_TYPE_NATIVE
FILE_ARCHIVE_TYPE_PVCS
FILE_ARCHIVE_TYPE_VSS
FILE_COMPRESSION_LEVEL_DEFAULT
FILE_COMPRESSION_LEVEL_MAXIMIZE_COMPRESSION
FILE_COMPRESSION_LEVEL_MAXIMIZE_SPEED
FILE_COMPRESSION_LEVEL_NONE
FILE_ENCODING_ASCII
FILE_ENCODING_BINARY
FILE_ENCODING_UNICODE
FILE_EXECUTABLE_NO
FILE_EXECUTABLE_YES
FILE_LOCAL_FILE_EXISTS_NO
FILE_LOCAL_FILE_EXISTS_YES
FILE_STATUS_CURRENT
FILE_STATUS_MERGE
FILE_STATUS_MISSING
FILE_STATUS_MODIFIED
FILE_STATUS_NOT_IN_VIEW
FILE_STATUS_OUT_OF_DATE
FILE_STATUS_UNKNOWN
FILE_STORAGE_TYPE_DELTA
FILE_STORAGE_TYPE_FULL_VERSIONS
FILE_SYNC_KNOWN_NO
FILE_SYNC_KNOWN_YES
FILE_SYNC_ON_ROOT_PATH_NO
FILE_SYNC_ON_ROOT_PATH_YES
FLAG_NO
FLAG_YES
FOLDER_EXCLUDE_FLAGS_INHERIT_AND_LOCAL_EXCLUDE_LIST
FOLDER_EXCLUDE_FLAGS_LOCAL_EXCLUDE_LIST
FOLDER_EXCLUDE_FLAGS_NO_EXCLUDE_LIST
MY_LOCK_EXCLUSIVELY_LOCKED_BY_ME
MY_LOCK_NON_EXCLUSIVELY_LOCKED_BY_ME
MY_LOCK_NOT_LOCKED_BY_ME
PROJECT_ENCRYPTION_NONE
PROJECT_ENCRYPTION_RC2_CBC
PROJECT_ENCRYPTION_RC2_CFB
PROJECT_ENCRYPTION_RC2_ECB
PROJECT_ENCRYPTION_RC4
PROJECT_TYPE_PVCS
PROJECT_TYPE_STARTEAM
PROJECT_TYPE_VISUAL_SOURCESAFE
READ_ONLY_NO
READ_ONLY_YES
READ_STATUS_READ
READ_STATUS_UNREAD
SHARE_STATE_DERIVED_SHARE
SHARE_STATE_NOT_SHARED
SHARE_STATE_ROOT_SHARE
TASK_CONSTRAINT_TYPE_AS_LATE_AS_POSSIBLE
TASK_CONSTRAINT_TYPE_AS_SOON_AS_POSSIBLE
TASK_CONSTRAINT_TYPE_FINISH_NO_EARLIER_THAN
TASK_CONSTRAINT_TYPE_FINISH_NO_LATER_THAN
TASK_CONSTRAINT_TYPE_MUST_FINISH_ON
TASK_CONSTRAINT_TYPE_MUST_START_ON
TASK_CONSTRAINT_TYPE_START_NO_EARLIER_THAN
TASK_CONSTRAINT_TYPE_START_NO_LATER_THAN
TASK_IS_MY_TASK_NO
TASK_IS_MY_TASK_YES
TASK_MILESTONE_NO
TASK_MILESTONE_YES
TASK_NEEDS_ATTENTION_NO
TASK_NEEDS_ATTENTION_YES
TASK_ORIGIN_MSPROJECT
TASK_ORIGIN_STARTEAM
TASK_PRIORITY_DO_NOT_LEVEL
TASK_PRIORITY_HIGH
TASK_PRIORITY_HIGHER
TASK_PRIORITY_HIGHEST
TASK_PRIORITY_LOW
TASK_PRIORITY_LOWER
TASK_PRIORITY_LOWEST
TASK_PRIORITY_MEDIUM
TASK_PRIORITY_VERY_HIGH
TASK_PRIORITY_VERY_LOW
TASK_STATUS_CLOSED
TASK_STATUS_FINISHED
TASK_STATUS_HOLD
TASK_STATUS_IN_PROGRESS
TASK_STATUS_PENDING
TASK_STATUS_READY_TO_START
TASK_TYPE_FIXED_DURATION
TASK_TYPE_FIXED_UNITS
TASK_TYPE_FIXED_WORK
TASKDEPENDENCY_TYPE_FF
TASKDEPENDENCY_TYPE_FS
TASKDEPENDENCY_TYPE_SF
TASKDEPENDENCY_TYPE_SS
TOPIC_PRIORITY_HIGH
TOPIC_PRIORITY_LOW
TOPIC_PRIORITY_NORMAL
TOPIC_STATUS_ACTIVE
TOPIC_STATUS_INACTIVE
TOPIC_TYPE_RESPONSE
TOPIC_TYPE_TOPIC

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.PropertyEnums.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.PropertyEnums.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.PropertyEnums.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PropertyEnums Constructor

Construct PropertyEnums from com.starbase.starteam.PropertyEnums.

public PropertyEnums(
PropertyEnums impl
);

Parameters

impl
The com.starbase.starteam.PropertyEnums to be wrapped.

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PropertyEnums Properties

The properties of the PropertyEnums class are listed below. For a complete list of PropertyEnums class members, see the PropertyEnums Members topic.

Public Static Properties

FILE_EOL_CLIENT_DEFINED
FILE_EOL_FIXED_CR
FILE_EOL_FIXED_CRLF
FILE_EOL_FIXED_LF
PROJECT_PROCESS_LINKS_DIRECT
PROJECT_PROCESS_LINKS_VIA_PROCESS_TASK
REQ_STATUS_ACCEPTED
REQ_STATUS_APPROVED
REQ_STATUS_COMPLETE
REQ_STATUS_DEFERRED
REQ_STATUS_DRAFT
REQ_STATUS_PENDING
REQ_STATUS_READY
REQ_STATUS_REJECTED
REQ_STATUS_REVIEW
REQ_STATUS_SUBMITTED
TASK_USAGE_CHECKIN
TASK_USAGE_OTHER
TASK_USAGE_PROMOTE
TASK_USAGE_REBASE
TASK_USAGE_REPLICATE

Public Instance Properties

AM_I_RECIPIENT_NO
AM_I_RECIPIENT_YES
AUDIT_EVENT_ID_ADDED
AUDIT_EVENT_ID_BRANCHED
AUDIT_EVENT_ID_CHECKED_IN
AUDIT_EVENT_ID_CHECKED_OUT
AUDIT_EVENT_ID_COMMENT_EDITED
AUDIT_EVENT_ID_CREATED
AUDIT_EVENT_ID_DELETED
AUDIT_EVENT_ID_ITEM_OVERWRITTEN
AUDIT_EVENT_ID_LOCK_BROKEN
AUDIT_EVENT_ID_LOCKED
AUDIT_EVENT_ID_MODIFIED
AUDIT_EVENT_ID_MOVED_FROM
AUDIT_EVENT_ID_MOVED_TO
AUDIT_EVENT_ID_SHARED
AUDIT_EVENT_ID_UNLOCKED
AUDIT_EVENT_ID_VAULT_CONVERTED
BRANCH_ON_CHANGE_NO
BRANCH_ON_CHANGE_YES
BRANCH_STATE_BRANCHED
BRANCH_STATE_NOT_BRANCHED
BRANCH_STATE_ROOT
CR_PLATFORM_ALL
CR_PLATFORM_MACOS
CR_PLATFORM_OTHER
CR_PLATFORM_UNIX
CR_PLATFORM_WINDOWS_2000
CR_PLATFORM_WINDOWS_95
CR_PLATFORM_WINDOWS_98
CR_PLATFORM_WINDOWS_NT
CR_PRIORITY_NO
CR_PRIORITY_YES
CR_SEVERITY_HIGH
CR_SEVERITY_LOW
CR_SEVERITY_MEDIUM
CR_STATUS_AS_DESIGNED
CR_STATUS_CANNOT_REPRODUCE
CR_STATUS_CLOSED_AS_DESIGNED
CR_STATUS_CLOSED_CANNOT_REPRODUCE
CR_STATUS_CLOSED_DEFERRED
CR_STATUS_CLOSED_DOCUMENTED
CR_STATUS_CLOSED_FIXED
CR_STATUS_CLOSED_IS_DUPLICATE
CR_STATUS_DEFERRED
CR_STATUS_DOCUMENTED
CR_STATUS_FIXED
CR_STATUS_IN_PROGRESS
CR_STATUS_IS_DUPLICATE
CR_STATUS_NEW
CR_STATUS_OPEN
CR_STATUS_VERIFIED_AS_DESIGNED
CR_STATUS_VERIFIED_CANNOT_REPRODUCE
CR_STATUS_VERIFIED_DEFERRED
CR_STATUS_VERIFIED_DOCUMENTED
CR_STATUS_VERIFIED_FIXED
CR_STATUS_VERIFIED_IS_DUPLICATE
CR_TYPE_DEFECT
CR_TYPE_SUGGESTION
FILE_ARCHIVE_FORMAT_NATIVE_I
FILE_ARCHIVE_FORMAT_NATIVE_II
FILE_ARCHIVE_FORMAT_NOT_APPLICABLE
FILE_ARCHIVE_TYPE_NATIVE
FILE_ARCHIVE_TYPE_PVCS
FILE_ARCHIVE_TYPE_VSS
FILE_COMPRESSION_LEVEL_DEFAULT
FILE_COMPRESSION_LEVEL_MAXIMIZE_COMPRESSION
FILE_COMPRESSION_LEVEL_MAXIMIZE_SPEED
FILE_COMPRESSION_LEVEL_NONE
FILE_ENCODING_ASCII
FILE_ENCODING_BINARY
FILE_ENCODING_UNICODE
FILE_EXECUTABLE_NO
FILE_EXECUTABLE_YES
FILE_LOCAL_FILE_EXISTS_NO
FILE_LOCAL_FILE_EXISTS_YES
FILE_STATUS_CURRENT
FILE_STATUS_MERGE
FILE_STATUS_MISSING
FILE_STATUS_MODIFIED
FILE_STATUS_NOT_IN_VIEW
FILE_STATUS_OUT_OF_DATE
FILE_STATUS_UNKNOWN
FILE_STORAGE_TYPE_DELTA
FILE_STORAGE_TYPE_FULL_VERSIONS
FILE_SYNC_KNOWN_NO
FILE_SYNC_KNOWN_YES
FILE_SYNC_ON_ROOT_PATH_NO
FILE_SYNC_ON_ROOT_PATH_YES
FLAG_NO
FLAG_YES
FOLDER_EXCLUDE_FLAGS_INHERIT_AND_LOCAL_EXCLUDE_LIST
FOLDER_EXCLUDE_FLAGS_LOCAL_EXCLUDE_LIST
FOLDER_EXCLUDE_FLAGS_NO_EXCLUDE_LIST
MY_LOCK_EXCLUSIVELY_LOCKED_BY_ME
MY_LOCK_NON_EXCLUSIVELY_LOCKED_BY_ME
MY_LOCK_NOT_LOCKED_BY_ME
PROJECT_ENCRYPTION_NONE
PROJECT_ENCRYPTION_RC2_CBC
PROJECT_ENCRYPTION_RC2_CFB
PROJECT_ENCRYPTION_RC2_ECB
PROJECT_ENCRYPTION_RC4
PROJECT_TYPE_PVCS
PROJECT_TYPE_STARTEAM
PROJECT_TYPE_VISUAL_SOURCESAFE
READ_ONLY_NO
READ_ONLY_YES
READ_STATUS_READ
READ_STATUS_UNREAD
SHARE_STATE_DERIVED_SHARE
SHARE_STATE_NOT_SHARED
SHARE_STATE_ROOT_SHARE
TASK_CONSTRAINT_TYPE_AS_LATE_AS_POSSIBLE
TASK_CONSTRAINT_TYPE_AS_SOON_AS_POSSIBLE
TASK_CONSTRAINT_TYPE_FINISH_NO_EARLIER_THAN
TASK_CONSTRAINT_TYPE_FINISH_NO_LATER_THAN
TASK_CONSTRAINT_TYPE_MUST_FINISH_ON
TASK_CONSTRAINT_TYPE_MUST_START_ON
TASK_CONSTRAINT_TYPE_START_NO_EARLIER_THAN
TASK_CONSTRAINT_TYPE_START_NO_LATER_THAN
TASK_IS_MY_TASK_NO
TASK_IS_MY_TASK_YES
TASK_MILESTONE_NO
TASK_MILESTONE_YES
TASK_NEEDS_ATTENTION_NO
TASK_NEEDS_ATTENTION_YES
TASK_ORIGIN_MSPROJECT
TASK_ORIGIN_STARTEAM
TASK_PRIORITY_DO_NOT_LEVEL
TASK_PRIORITY_HIGH
TASK_PRIORITY_HIGHER
TASK_PRIORITY_HIGHEST
TASK_PRIORITY_LOW
TASK_PRIORITY_LOWER
TASK_PRIORITY_LOWEST
TASK_PRIORITY_MEDIUM
TASK_PRIORITY_VERY_HIGH
TASK_PRIORITY_VERY_LOW
TASK_STATUS_CLOSED
TASK_STATUS_FINISHED
TASK_STATUS_HOLD
TASK_STATUS_IN_PROGRESS
TASK_STATUS_PENDING
TASK_STATUS_READY_TO_START
TASK_TYPE_FIXED_DURATION
TASK_TYPE_FIXED_UNITS
TASK_TYPE_FIXED_WORK
TASKDEPENDENCY_TYPE_FF
TASKDEPENDENCY_TYPE_FS
TASKDEPENDENCY_TYPE_SF
TASKDEPENDENCY_TYPE_SS
TOPIC_PRIORITY_HIGH
TOPIC_PRIORITY_LOW
TOPIC_PRIORITY_NORMAL
TOPIC_STATUS_ACTIVE
TOPIC_STATUS_INACTIVE
TOPIC_TYPE_RESPONSE
TOPIC_TYPE_TOPIC

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AM_I_RECIPIENT_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.AM_I_RECIPIENT_NO Property

public Int32 AM_I_RECIPIENT_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AM_I_RECIPIENT_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.AM_I_RECIPIENT_YES Property

public Int32 AM_I_RECIPIENT_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_ADDED Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_ADDED Property

public Int32 AUDIT_EVENT_ID_ADDED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_BRANCHED Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_BRANCHED Property

public Int32 AUDIT_EVENT_ID_BRANCHED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_CHECKED_IN Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_CHECKED_IN Property

public Int32 AUDIT_EVENT_ID_CHECKED_IN {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_CHECKED_OUT Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_CHECKED_OUT Property

public Int32 AUDIT_EVENT_ID_CHECKED_OUT {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_COMMENT_EDITED Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_COMMENT_EDITED Property

public Int32 AUDIT_EVENT_ID_COMMENT_EDITED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_CREATED Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_CREATED Property

public Int32 AUDIT_EVENT_ID_CREATED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_DELETED Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_DELETED Property

public Int32 AUDIT_EVENT_ID_DELETED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_ITEM_OVERWRITTEN Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_ITEM_OVERWRITTEN Property

public Int32 AUDIT_EVENT_ID_ITEM_OVERWRITTEN {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_LOCK_BROKEN Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_LOCK_BROKEN Property

public Int32 AUDIT_EVENT_ID_LOCK_BROKEN {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_LOCKED Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_LOCKED Property

public Int32 AUDIT_EVENT_ID_LOCKED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_MODIFIED Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_MODIFIED Property

public Int32 AUDIT_EVENT_ID_MODIFIED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_MOVED_FROM Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_MOVED_FROM Property

public Int32 AUDIT_EVENT_ID_MOVED_FROM {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_MOVED_TO Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_MOVED_TO Property

public Int32 AUDIT_EVENT_ID_MOVED_TO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_SHARED Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_SHARED Property

public Int32 AUDIT_EVENT_ID_SHARED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_UNLOCKED Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_UNLOCKED Property

public Int32 AUDIT_EVENT_ID_UNLOCKED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID_VAULT_CONVERTED Property

Borland StarTeam SDK for .NET

PropertyEnums.AUDIT_EVENT_ID_VAULT_CONVERTED Property

public Int32 AUDIT_EVENT_ID_VAULT_CONVERTED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


BRANCH_ON_CHANGE_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.BRANCH_ON_CHANGE_NO Property

public Int32 BRANCH_ON_CHANGE_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


BRANCH_ON_CHANGE_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.BRANCH_ON_CHANGE_YES Property

public Int32 BRANCH_ON_CHANGE_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


BRANCH_STATE_BRANCHED Property

Borland StarTeam SDK for .NET

PropertyEnums.BRANCH_STATE_BRANCHED Property

public Int32 BRANCH_STATE_BRANCHED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


BRANCH_STATE_NOT_BRANCHED Property

Borland StarTeam SDK for .NET

PropertyEnums.BRANCH_STATE_NOT_BRANCHED Property

public Int32 BRANCH_STATE_NOT_BRANCHED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


BRANCH_STATE_ROOT Property

Borland StarTeam SDK for .NET

PropertyEnums.BRANCH_STATE_ROOT Property

public Int32 BRANCH_STATE_ROOT {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_PLATFORM_ALL Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_PLATFORM_ALL Property

public Int32 CR_PLATFORM_ALL {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_PLATFORM_MACOS Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_PLATFORM_MACOS Property

public Int32 CR_PLATFORM_MACOS {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_PLATFORM_OTHER Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_PLATFORM_OTHER Property

public Int32 CR_PLATFORM_OTHER {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_PLATFORM_UNIX Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_PLATFORM_UNIX Property

public Int32 CR_PLATFORM_UNIX {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_PLATFORM_WINDOWS_2000 Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_PLATFORM_WINDOWS_2000 Property

public Int32 CR_PLATFORM_WINDOWS_2000 {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_PLATFORM_WINDOWS_95 Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_PLATFORM_WINDOWS_95 Property

public Int32 CR_PLATFORM_WINDOWS_95 {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_PLATFORM_WINDOWS_98 Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_PLATFORM_WINDOWS_98 Property

public Int32 CR_PLATFORM_WINDOWS_98 {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_PLATFORM_WINDOWS_NT Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_PLATFORM_WINDOWS_NT Property

public Int32 CR_PLATFORM_WINDOWS_NT {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_PRIORITY_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_PRIORITY_NO Property

public Int32 CR_PRIORITY_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_PRIORITY_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_PRIORITY_YES Property

public Int32 CR_PRIORITY_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_SEVERITY_HIGH Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_SEVERITY_HIGH Property

public Int32 CR_SEVERITY_HIGH {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_SEVERITY_LOW Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_SEVERITY_LOW Property

public Int32 CR_SEVERITY_LOW {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_SEVERITY_MEDIUM Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_SEVERITY_MEDIUM Property

public Int32 CR_SEVERITY_MEDIUM {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_AS_DESIGNED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_AS_DESIGNED Property

public Int32 CR_STATUS_AS_DESIGNED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_CANNOT_REPRODUCE Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_CANNOT_REPRODUCE Property

public Int32 CR_STATUS_CANNOT_REPRODUCE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_CLOSED_AS_DESIGNED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_CLOSED_AS_DESIGNED Property

public Int32 CR_STATUS_CLOSED_AS_DESIGNED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_CLOSED_CANNOT_REPRODUCE Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_CLOSED_CANNOT_REPRODUCE Property

public Int32 CR_STATUS_CLOSED_CANNOT_REPRODUCE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_CLOSED_DEFERRED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_CLOSED_DEFERRED Property

public Int32 CR_STATUS_CLOSED_DEFERRED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_CLOSED_DOCUMENTED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_CLOSED_DOCUMENTED Property

public Int32 CR_STATUS_CLOSED_DOCUMENTED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_CLOSED_FIXED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_CLOSED_FIXED Property

public Int32 CR_STATUS_CLOSED_FIXED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_CLOSED_IS_DUPLICATE Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_CLOSED_IS_DUPLICATE Property

public Int32 CR_STATUS_CLOSED_IS_DUPLICATE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_DEFERRED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_DEFERRED Property

public Int32 CR_STATUS_DEFERRED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_DOCUMENTED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_DOCUMENTED Property

public Int32 CR_STATUS_DOCUMENTED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_FIXED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_FIXED Property

public Int32 CR_STATUS_FIXED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_IN_PROGRESS Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_IN_PROGRESS Property

public Int32 CR_STATUS_IN_PROGRESS {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_IS_DUPLICATE Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_IS_DUPLICATE Property

public Int32 CR_STATUS_IS_DUPLICATE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_NEW Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_NEW Property

public Int32 CR_STATUS_NEW {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_OPEN Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_OPEN Property

public Int32 CR_STATUS_OPEN {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_VERIFIED_AS_DESIGNED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_VERIFIED_AS_DESIGNED Property

public Int32 CR_STATUS_VERIFIED_AS_DESIGNED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_VERIFIED_CANNOT_REPRODUCE Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_VERIFIED_CANNOT_REPRODUCE Property

public Int32 CR_STATUS_VERIFIED_CANNOT_REPRODUCE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_VERIFIED_DEFERRED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_VERIFIED_DEFERRED Property

public Int32 CR_STATUS_VERIFIED_DEFERRED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_VERIFIED_DOCUMENTED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_VERIFIED_DOCUMENTED Property

public Int32 CR_STATUS_VERIFIED_DOCUMENTED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_VERIFIED_FIXED Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_VERIFIED_FIXED Property

public Int32 CR_STATUS_VERIFIED_FIXED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_STATUS_VERIFIED_IS_DUPLICATE Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_STATUS_VERIFIED_IS_DUPLICATE Property

public Int32 CR_STATUS_VERIFIED_IS_DUPLICATE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_TYPE_DEFECT Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_TYPE_DEFECT Property

public Int32 CR_TYPE_DEFECT {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


CR_TYPE_SUGGESTION Property

Borland StarTeam SDK for .NET

PropertyEnums.CR_TYPE_SUGGESTION Property

public Int32 CR_TYPE_SUGGESTION {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_ARCHIVE_FORMAT_NATIVE_I Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_ARCHIVE_FORMAT_NATIVE_I Property

public Int32 FILE_ARCHIVE_FORMAT_NATIVE_I {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_ARCHIVE_FORMAT_NATIVE_II Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_ARCHIVE_FORMAT_NATIVE_II Property

public Int32 FILE_ARCHIVE_FORMAT_NATIVE_II {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_ARCHIVE_FORMAT_NOT_APPLICABLE Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_ARCHIVE_FORMAT_NOT_APPLICABLE Property

public Int32 FILE_ARCHIVE_FORMAT_NOT_APPLICABLE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_ARCHIVE_TYPE_NATIVE Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_ARCHIVE_TYPE_NATIVE Property

public Int32 FILE_ARCHIVE_TYPE_NATIVE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_ARCHIVE_TYPE_PVCS Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_ARCHIVE_TYPE_PVCS Property

public Int32 FILE_ARCHIVE_TYPE_PVCS {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_ARCHIVE_TYPE_VSS Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_ARCHIVE_TYPE_VSS Property

public Int32 FILE_ARCHIVE_TYPE_VSS {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_COMPRESSION_LEVEL_DEFAULT Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_COMPRESSION_LEVEL_DEFAULT Property

public Int32 FILE_COMPRESSION_LEVEL_DEFAULT {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_COMPRESSION_LEVEL_MAXIMIZE_COMPRESSION Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_COMPRESSION_LEVEL_MAXIMIZE_COMPRESSION Property

public Int32 FILE_COMPRESSION_LEVEL_MAXIMIZE_COMPRESSION {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_COMPRESSION_LEVEL_MAXIMIZE_SPEED Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_COMPRESSION_LEVEL_MAXIMIZE_SPEED Property

public Int32 FILE_COMPRESSION_LEVEL_MAXIMIZE_SPEED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_COMPRESSION_LEVEL_NONE Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_COMPRESSION_LEVEL_NONE Property

public Int32 FILE_COMPRESSION_LEVEL_NONE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_ENCODING_ASCII Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_ENCODING_ASCII Property

public Int32 FILE_ENCODING_ASCII {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_ENCODING_BINARY Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_ENCODING_BINARY Property

public Int32 FILE_ENCODING_BINARY {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_ENCODING_UNICODE Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_ENCODING_UNICODE Property

public Int32 FILE_ENCODING_UNICODE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_EOL_CLIENT_DEFINED Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_EOL_CLIENT_DEFINED Property

public static Int32 FILE_EOL_CLIENT_DEFINED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_EOL_FIXED_CR Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_EOL_FIXED_CR Property

public static Int32 FILE_EOL_FIXED_CR {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_EOL_FIXED_CRLF Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_EOL_FIXED_CRLF Property

public static Int32 FILE_EOL_FIXED_CRLF {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_EOL_FIXED_LF Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_EOL_FIXED_LF Property

public static Int32 FILE_EOL_FIXED_LF {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_EXECUTABLE_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_EXECUTABLE_NO Property

public Int32 FILE_EXECUTABLE_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_EXECUTABLE_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_EXECUTABLE_YES Property

public Int32 FILE_EXECUTABLE_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_LOCAL_FILE_EXISTS_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_LOCAL_FILE_EXISTS_NO Property

public Int32 FILE_LOCAL_FILE_EXISTS_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_LOCAL_FILE_EXISTS_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_LOCAL_FILE_EXISTS_YES Property

public Int32 FILE_LOCAL_FILE_EXISTS_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_STATUS_CURRENT Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_STATUS_CURRENT Property

public Int32 FILE_STATUS_CURRENT {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_STATUS_MERGE Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_STATUS_MERGE Property

public Int32 FILE_STATUS_MERGE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_STATUS_MISSING Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_STATUS_MISSING Property

public Int32 FILE_STATUS_MISSING {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_STATUS_MODIFIED Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_STATUS_MODIFIED Property

public Int32 FILE_STATUS_MODIFIED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_STATUS_NOT_IN_VIEW Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_STATUS_NOT_IN_VIEW Property

public Int32 FILE_STATUS_NOT_IN_VIEW {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_STATUS_OUT_OF_DATE Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_STATUS_OUT_OF_DATE Property

public Int32 FILE_STATUS_OUT_OF_DATE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_STATUS_UNKNOWN Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_STATUS_UNKNOWN Property

public Int32 FILE_STATUS_UNKNOWN {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_STORAGE_TYPE_DELTA Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_STORAGE_TYPE_DELTA Property

public Int32 FILE_STORAGE_TYPE_DELTA {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_STORAGE_TYPE_FULL_VERSIONS Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_STORAGE_TYPE_FULL_VERSIONS Property

public Int32 FILE_STORAGE_TYPE_FULL_VERSIONS {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_SYNC_KNOWN_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_SYNC_KNOWN_NO Property

public Int32 FILE_SYNC_KNOWN_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_SYNC_KNOWN_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_SYNC_KNOWN_YES Property

public Int32 FILE_SYNC_KNOWN_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_SYNC_ON_ROOT_PATH_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_SYNC_ON_ROOT_PATH_NO Property

public Int32 FILE_SYNC_ON_ROOT_PATH_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FILE_SYNC_ON_ROOT_PATH_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.FILE_SYNC_ON_ROOT_PATH_YES Property

public Int32 FILE_SYNC_ON_ROOT_PATH_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FLAG_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.FLAG_NO Property

public Int32 FLAG_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FLAG_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.FLAG_YES Property

public Int32 FLAG_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FOLDER_EXCLUDE_FLAGS_INHERIT_AND_LOCAL_EXCLUDE_LIST Property

Borland StarTeam SDK for .NET

PropertyEnums.FOLDER_EXCLUDE_FLAGS_INHERIT_AND_LOCAL_EXCLUDE_LIST Property

public Int32 FOLDER_EXCLUDE_FLAGS_INHERIT_AND_LOCAL_EXCLUDE_LIST {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FOLDER_EXCLUDE_FLAGS_LOCAL_EXCLUDE_LIST Property

Borland StarTeam SDK for .NET

PropertyEnums.FOLDER_EXCLUDE_FLAGS_LOCAL_EXCLUDE_LIST Property

public Int32 FOLDER_EXCLUDE_FLAGS_LOCAL_EXCLUDE_LIST {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


FOLDER_EXCLUDE_FLAGS_NO_EXCLUDE_LIST Property

Borland StarTeam SDK for .NET

PropertyEnums.FOLDER_EXCLUDE_FLAGS_NO_EXCLUDE_LIST Property

public Int32 FOLDER_EXCLUDE_FLAGS_NO_EXCLUDE_LIST {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


MY_LOCK_EXCLUSIVELY_LOCKED_BY_ME Property

Borland StarTeam SDK for .NET

PropertyEnums.MY_LOCK_EXCLUSIVELY_LOCKED_BY_ME Property

public Int32 MY_LOCK_EXCLUSIVELY_LOCKED_BY_ME {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


MY_LOCK_NON_EXCLUSIVELY_LOCKED_BY_ME Property

Borland StarTeam SDK for .NET

PropertyEnums.MY_LOCK_NON_EXCLUSIVELY_LOCKED_BY_ME Property

public Int32 MY_LOCK_NON_EXCLUSIVELY_LOCKED_BY_ME {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


MY_LOCK_NOT_LOCKED_BY_ME Property

Borland StarTeam SDK for .NET

PropertyEnums.MY_LOCK_NOT_LOCKED_BY_ME Property

public Int32 MY_LOCK_NOT_LOCKED_BY_ME {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PROJECT_ENCRYPTION_NONE Property

Borland StarTeam SDK for .NET

PropertyEnums.PROJECT_ENCRYPTION_NONE Property

public Int32 PROJECT_ENCRYPTION_NONE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PROJECT_ENCRYPTION_RC2_CBC Property

Borland StarTeam SDK for .NET

PropertyEnums.PROJECT_ENCRYPTION_RC2_CBC Property

public Int32 PROJECT_ENCRYPTION_RC2_CBC {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PROJECT_ENCRYPTION_RC2_CFB Property

Borland StarTeam SDK for .NET

PropertyEnums.PROJECT_ENCRYPTION_RC2_CFB Property

public Int32 PROJECT_ENCRYPTION_RC2_CFB {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PROJECT_ENCRYPTION_RC2_ECB Property

Borland StarTeam SDK for .NET

PropertyEnums.PROJECT_ENCRYPTION_RC2_ECB Property

public Int32 PROJECT_ENCRYPTION_RC2_ECB {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PROJECT_ENCRYPTION_RC4 Property

Borland StarTeam SDK for .NET

PropertyEnums.PROJECT_ENCRYPTION_RC4 Property

public Int32 PROJECT_ENCRYPTION_RC4 {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PROJECT_PROCESS_LINKS_DIRECT Property

Borland StarTeam SDK for .NET

PropertyEnums.PROJECT_PROCESS_LINKS_DIRECT Property

public static Int32 PROJECT_PROCESS_LINKS_DIRECT {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PROJECT_PROCESS_LINKS_VIA_PROCESS_TASK Property

Borland StarTeam SDK for .NET

PropertyEnums.PROJECT_PROCESS_LINKS_VIA_PROCESS_TASK Property

public static Int32 PROJECT_PROCESS_LINKS_VIA_PROCESS_TASK {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PROJECT_TYPE_PVCS Property

Borland StarTeam SDK for .NET

PropertyEnums.PROJECT_TYPE_PVCS Property

public Int32 PROJECT_TYPE_PVCS {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PROJECT_TYPE_STARTEAM Property

Borland StarTeam SDK for .NET

PropertyEnums.PROJECT_TYPE_STARTEAM Property

public Int32 PROJECT_TYPE_STARTEAM {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PROJECT_TYPE_VISUAL_SOURCESAFE Property

Borland StarTeam SDK for .NET

PropertyEnums.PROJECT_TYPE_VISUAL_SOURCESAFE Property

public Int32 PROJECT_TYPE_VISUAL_SOURCESAFE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


READ_ONLY_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.READ_ONLY_NO Property

public Int32 READ_ONLY_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


READ_ONLY_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.READ_ONLY_YES Property

public Int32 READ_ONLY_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


READ_STATUS_READ Property

Borland StarTeam SDK for .NET

PropertyEnums.READ_STATUS_READ Property

public Int32 READ_STATUS_READ {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


READ_STATUS_UNREAD Property

Borland StarTeam SDK for .NET

PropertyEnums.READ_STATUS_UNREAD Property

public Int32 READ_STATUS_UNREAD {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


REQ_STATUS_ACCEPTED Property

Borland StarTeam SDK for .NET

PropertyEnums.REQ_STATUS_ACCEPTED Property

public static Int32 REQ_STATUS_ACCEPTED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


REQ_STATUS_APPROVED Property

Borland StarTeam SDK for .NET

PropertyEnums.REQ_STATUS_APPROVED Property

public static Int32 REQ_STATUS_APPROVED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


REQ_STATUS_COMPLETE Property

Borland StarTeam SDK for .NET

PropertyEnums.REQ_STATUS_COMPLETE Property

public static Int32 REQ_STATUS_COMPLETE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


REQ_STATUS_DEFERRED Property

Borland StarTeam SDK for .NET

PropertyEnums.REQ_STATUS_DEFERRED Property

public static Int32 REQ_STATUS_DEFERRED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


REQ_STATUS_DRAFT Property

Borland StarTeam SDK for .NET

PropertyEnums.REQ_STATUS_DRAFT Property

public static Int32 REQ_STATUS_DRAFT {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


REQ_STATUS_PENDING Property

Borland StarTeam SDK for .NET

PropertyEnums.REQ_STATUS_PENDING Property

public static Int32 REQ_STATUS_PENDING {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


REQ_STATUS_READY Property

Borland StarTeam SDK for .NET

PropertyEnums.REQ_STATUS_READY Property

public static Int32 REQ_STATUS_READY {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


REQ_STATUS_REJECTED Property

Borland StarTeam SDK for .NET

PropertyEnums.REQ_STATUS_REJECTED Property

public static Int32 REQ_STATUS_REJECTED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


REQ_STATUS_REVIEW Property

Borland StarTeam SDK for .NET

PropertyEnums.REQ_STATUS_REVIEW Property

public static Int32 REQ_STATUS_REVIEW {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


REQ_STATUS_SUBMITTED Property

Borland StarTeam SDK for .NET

PropertyEnums.REQ_STATUS_SUBMITTED Property

public static Int32 REQ_STATUS_SUBMITTED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


SHARE_STATE_DERIVED_SHARE Property

Borland StarTeam SDK for .NET

PropertyEnums.SHARE_STATE_DERIVED_SHARE Property

public Int32 SHARE_STATE_DERIVED_SHARE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


SHARE_STATE_NOT_SHARED Property

Borland StarTeam SDK for .NET

PropertyEnums.SHARE_STATE_NOT_SHARED Property

public Int32 SHARE_STATE_NOT_SHARED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


SHARE_STATE_ROOT_SHARE Property

Borland StarTeam SDK for .NET

PropertyEnums.SHARE_STATE_ROOT_SHARE Property

public Int32 SHARE_STATE_ROOT_SHARE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_CONSTRAINT_TYPE_AS_LATE_AS_POSSIBLE Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_CONSTRAINT_TYPE_AS_LATE_AS_POSSIBLE Property

public Int32 TASK_CONSTRAINT_TYPE_AS_LATE_AS_POSSIBLE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_CONSTRAINT_TYPE_AS_SOON_AS_POSSIBLE Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_CONSTRAINT_TYPE_AS_SOON_AS_POSSIBLE Property

public Int32 TASK_CONSTRAINT_TYPE_AS_SOON_AS_POSSIBLE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_CONSTRAINT_TYPE_FINISH_NO_EARLIER_THAN Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_CONSTRAINT_TYPE_FINISH_NO_EARLIER_THAN Property

public Int32 TASK_CONSTRAINT_TYPE_FINISH_NO_EARLIER_THAN {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_CONSTRAINT_TYPE_FINISH_NO_LATER_THAN Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_CONSTRAINT_TYPE_FINISH_NO_LATER_THAN Property

public Int32 TASK_CONSTRAINT_TYPE_FINISH_NO_LATER_THAN {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_CONSTRAINT_TYPE_MUST_FINISH_ON Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_CONSTRAINT_TYPE_MUST_FINISH_ON Property

public Int32 TASK_CONSTRAINT_TYPE_MUST_FINISH_ON {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_CONSTRAINT_TYPE_MUST_START_ON Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_CONSTRAINT_TYPE_MUST_START_ON Property

public Int32 TASK_CONSTRAINT_TYPE_MUST_START_ON {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_CONSTRAINT_TYPE_START_NO_EARLIER_THAN Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_CONSTRAINT_TYPE_START_NO_EARLIER_THAN Property

public Int32 TASK_CONSTRAINT_TYPE_START_NO_EARLIER_THAN {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_CONSTRAINT_TYPE_START_NO_LATER_THAN Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_CONSTRAINT_TYPE_START_NO_LATER_THAN Property

public Int32 TASK_CONSTRAINT_TYPE_START_NO_LATER_THAN {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_IS_MY_TASK_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_IS_MY_TASK_NO Property

public Int32 TASK_IS_MY_TASK_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_IS_MY_TASK_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_IS_MY_TASK_YES Property

public Int32 TASK_IS_MY_TASK_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_MILESTONE_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_MILESTONE_NO Property

public Int32 TASK_MILESTONE_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_MILESTONE_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_MILESTONE_YES Property

public Int32 TASK_MILESTONE_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_NEEDS_ATTENTION_NO Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_NEEDS_ATTENTION_NO Property

public Int32 TASK_NEEDS_ATTENTION_NO {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_NEEDS_ATTENTION_YES Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_NEEDS_ATTENTION_YES Property

public Int32 TASK_NEEDS_ATTENTION_YES {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_ORIGIN_MSPROJECT Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_ORIGIN_MSPROJECT Property

public Int32 TASK_ORIGIN_MSPROJECT {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_ORIGIN_STARTEAM Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_ORIGIN_STARTEAM Property

public Int32 TASK_ORIGIN_STARTEAM {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_PRIORITY_DO_NOT_LEVEL Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_PRIORITY_DO_NOT_LEVEL Property

public Int32 TASK_PRIORITY_DO_NOT_LEVEL {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_PRIORITY_HIGH Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_PRIORITY_HIGH Property

public Int32 TASK_PRIORITY_HIGH {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_PRIORITY_HIGHER Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_PRIORITY_HIGHER Property

public Int32 TASK_PRIORITY_HIGHER {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_PRIORITY_HIGHEST Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_PRIORITY_HIGHEST Property

public Int32 TASK_PRIORITY_HIGHEST {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_PRIORITY_LOW Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_PRIORITY_LOW Property

public Int32 TASK_PRIORITY_LOW {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_PRIORITY_LOWER Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_PRIORITY_LOWER Property

public Int32 TASK_PRIORITY_LOWER {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_PRIORITY_LOWEST Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_PRIORITY_LOWEST Property

public Int32 TASK_PRIORITY_LOWEST {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_PRIORITY_MEDIUM Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_PRIORITY_MEDIUM Property

public Int32 TASK_PRIORITY_MEDIUM {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_PRIORITY_VERY_HIGH Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_PRIORITY_VERY_HIGH Property

public Int32 TASK_PRIORITY_VERY_HIGH {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_PRIORITY_VERY_LOW Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_PRIORITY_VERY_LOW Property

public Int32 TASK_PRIORITY_VERY_LOW {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_STATUS_CLOSED Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_STATUS_CLOSED Property

public Int32 TASK_STATUS_CLOSED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_STATUS_FINISHED Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_STATUS_FINISHED Property

public Int32 TASK_STATUS_FINISHED {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_STATUS_HOLD Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_STATUS_HOLD Property

public Int32 TASK_STATUS_HOLD {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_STATUS_IN_PROGRESS Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_STATUS_IN_PROGRESS Property

public Int32 TASK_STATUS_IN_PROGRESS {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_STATUS_PENDING Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_STATUS_PENDING Property

public Int32 TASK_STATUS_PENDING {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_STATUS_READY_TO_START Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_STATUS_READY_TO_START Property

public Int32 TASK_STATUS_READY_TO_START {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_TYPE_FIXED_DURATION Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_TYPE_FIXED_DURATION Property

public Int32 TASK_TYPE_FIXED_DURATION {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_TYPE_FIXED_UNITS Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_TYPE_FIXED_UNITS Property

public Int32 TASK_TYPE_FIXED_UNITS {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_TYPE_FIXED_WORK Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_TYPE_FIXED_WORK Property

public Int32 TASK_TYPE_FIXED_WORK {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_USAGE_CHECKIN Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_USAGE_CHECKIN Property

public static Int32 TASK_USAGE_CHECKIN {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_USAGE_OTHER Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_USAGE_OTHER Property

public static Int32 TASK_USAGE_OTHER {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_USAGE_PROMOTE Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_USAGE_PROMOTE Property

public static Int32 TASK_USAGE_PROMOTE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_USAGE_REBASE Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_USAGE_REBASE Property

public static Int32 TASK_USAGE_REBASE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASK_USAGE_REPLICATE Property

Borland StarTeam SDK for .NET

PropertyEnums.TASK_USAGE_REPLICATE Property

public static Int32 TASK_USAGE_REPLICATE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASKDEPENDENCY_TYPE_FF Property

Borland StarTeam SDK for .NET

PropertyEnums.TASKDEPENDENCY_TYPE_FF Property

public Int32 TASKDEPENDENCY_TYPE_FF {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASKDEPENDENCY_TYPE_FS Property

Borland StarTeam SDK for .NET

PropertyEnums.TASKDEPENDENCY_TYPE_FS Property

public Int32 TASKDEPENDENCY_TYPE_FS {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASKDEPENDENCY_TYPE_SF Property

Borland StarTeam SDK for .NET

PropertyEnums.TASKDEPENDENCY_TYPE_SF Property

public Int32 TASKDEPENDENCY_TYPE_SF {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TASKDEPENDENCY_TYPE_SS Property

Borland StarTeam SDK for .NET

PropertyEnums.TASKDEPENDENCY_TYPE_SS Property

public Int32 TASKDEPENDENCY_TYPE_SS {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TOPIC_PRIORITY_HIGH Property

Borland StarTeam SDK for .NET

PropertyEnums.TOPIC_PRIORITY_HIGH Property

public Int32 TOPIC_PRIORITY_HIGH {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TOPIC_PRIORITY_LOW Property

Borland StarTeam SDK for .NET

PropertyEnums.TOPIC_PRIORITY_LOW Property

public Int32 TOPIC_PRIORITY_LOW {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TOPIC_PRIORITY_NORMAL Property

Borland StarTeam SDK for .NET

PropertyEnums.TOPIC_PRIORITY_NORMAL Property

public Int32 TOPIC_PRIORITY_NORMAL {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TOPIC_STATUS_ACTIVE Property

Borland StarTeam SDK for .NET

PropertyEnums.TOPIC_STATUS_ACTIVE Property

public Int32 TOPIC_STATUS_ACTIVE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TOPIC_STATUS_INACTIVE Property

Borland StarTeam SDK for .NET

PropertyEnums.TOPIC_STATUS_INACTIVE Property

public Int32 TOPIC_STATUS_INACTIVE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TOPIC_TYPE_RESPONSE Property

Borland StarTeam SDK for .NET

PropertyEnums.TOPIC_TYPE_RESPONSE Property

public Int32 TOPIC_TYPE_RESPONSE {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


TOPIC_TYPE_TOPIC Property

Borland StarTeam SDK for .NET

PropertyEnums.TOPIC_TYPE_TOPIC Property

public Int32 TOPIC_TYPE_TOPIC {get;}

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PropertyEnums Methods

The methods of the PropertyEnums class are listed below. For a complete list of PropertyEnums class members, see the PropertyEnums Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PropertyEnums.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.PropertyEnums.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.PropertyEnums.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.PropertyEnums.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PropertyEnums.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.PropertyEnums

Implements

IWrapper.Unwrap

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PropertyEnums.Equals Method

Delegate Equals() to com.starbase.starteam.PropertyEnums.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.PropertyEnums.Equals(obj).

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PropertyEnums.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.PropertyEnums.

public override int GetHashCode();

Return Value

com.starbase.starteam.PropertyEnums.GetHashCode().

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PropertyEnums.ToString Method

Delegate ToString() to com.starbase.starteam.PropertyEnums.

public override string ToString();

Return Value

com.starbase.starteam.PropertyEnums.ToString()

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PropertyEnums.Wrap Method

Dynamically wraps com.starbase.starteam.PropertyEnums.

public static PropertyEnums Wrap(
PropertyEnums impl
);

Parameters

impl
com.starbase.starteam.PropertyEnums to be wrapped.

Return Value

PropertyEnums

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PropertyEnums Type Conversions

The type conversions of the PropertyEnums class are listed below. For a complete list of PropertyEnums class members, see the PropertyEnums Members topic.

Public Static Type Conversions

Implicit PropertyEnums to PropertyEnums Conversion Implicitly convert PropertyEnums to com.starbase.starteam.PropertyEnums.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyEnums Class | PropertyEnums Members | Borland.StarTeam Namespace


PropertyEnums Implicit PropertyEnums to PropertyEnums Conversion

Implicitly convert PropertyEnums to com.starbase.starteam.PropertyEnums.

public static implicit operator PropertyEnums(
PropertyEnums arg
);

Parameters

arg
PropertyEnums to convert.

Return Value

com.starbase.starteam.PropertyEnums

See Also

PropertyEnums Class | Borland.StarTeam Namespace


PropertyNames Class

This class provides a conventient place to get the names of various built-in StarTeam Item (and some non-item) property names. The member variables here should always be used instead of hard-coded String values. For example, on a File Item you should not call get("Name") to get the name property but rather file.get(file.getPropertyNames().FILE_NAME); This does lead to a bit of indirection but is the safest way of being sure you are using the right property name. This class also insulates you from any property name changes that could occur from one release of StarTeam to the next.

For a list of all members of this type, see PropertyNames Members.

System.Object
PropertyNames

public class PropertyNames : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PropertyNames Members | Borland.StarTeam Namespace


PropertyNames Members

PropertyNames overview

Public Static Properties

ITEM_DELETED_TIME
ITEM_DELETED_USER_ID
PROJECT_DEFAULT_TYPES
PROJECT_PROCESS_LINKS
REQ_PARENT_OBJECTID
REQ_STATUS
TASK_USAGE
TASK_USAGE_90
VIEW_RESOLVED_ID

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PropertyNames.

Public Static Type Conversions

Implicit PropertyNames to PropertyNames Conversion Implicitly convert PropertyNames to com.starbase.starteam.PropertyNames.

Public Instance Constructors

PropertyNames Constructor Construct PropertyNames from com.starbase.starteam.PropertyNames.

Public Instance Properties

AM_I_RECIPIENT
ATTACHMENT_COUNT
ATTACHMENT_IDS
ATTACHMENT_NAMES
AUDIT_CLASS_ID
AUDIT_CLASS_NAME
AUDIT_CLASS2_NAME
AUDIT_CLASS3_NAME
AUDIT_DESCRIPTOR
AUDIT_DESCRIPTOR2
AUDIT_DESCRIPTOR3
AUDIT_EVENT_ID
AUDIT_FOLDER
AUDIT_FOLDER_VMID
AUDIT_ITEM_1_INFO
AUDIT_ITEM_2_INFO
AUDIT_ITEM_3_INFO
AUDIT_OBJECT_ID
AUDIT_PROJECT_ID
AUDIT_TARGET_1_REVISION_TIME
AUDIT_TARGET_2_CLASS_ID
AUDIT_TARGET_2_OBJECT_ID
AUDIT_TARGET_2_REVISION_TIME
AUDIT_TARGET_3_CLASS_ID
AUDIT_TARGET_3_OBJECT_ID
AUDIT_TARGET_3_REVISION_TIME
AUDIT_USER_ID
BRANCH_ON_CHANGE
BRANCH_STATE
COMMENT
COMMENT_ID
CONFIGURATION_TIME
CR_ADDRESSED_BY
CR_ADDRESSED_IN
CR_ADDRESSED_IN_VIEW
CR_CATEGORY
CR_CHANGE_NUMBER
CR_CLOSED_ON
CR_COMPONENT
CR_DESCRIPTION
CR_ENTERED_BY
CR_ENTERED_ON
CR_EXTERNAL_REFERENCE
CR_FIX
CR_FOLDER
CR_LAST_BUILD_TESTED
CR_PLATFORM
CR_PRIORITY
CR_RESOLVED_ON
CR_RESPONSIBILITY
CR_SEVERITY
CR_STATUS
CR_SYNOPSIS
CR_TEST_COMMAND
CR_TYPE
CR_VERIFIED_ON
CR_WORK_AROUND
CREATED_TIME
CREATED_USER_ID
DELETED_TIME
DELETED_USER_ID
DOTNOTATION
DOTNOTATION_ID
END_MODIFIED_TIME
EXCLUSIVE_LOCKER
FILE_ARCHIVE_FORMAT
FILE_ARCHIVE_NAME
FILE_ARCHIVE_PATH
FILE_ARCHIVE_TYPE
FILE_COMPRESSION_LEVEL
FILE_CONTENT_REVISION
FILE_DESCRIPTION
FILE_ENCODING
FILE_EOL_CHARACTER
FILE_EXECUTABLE
FILE_EXTENSION
FILE_FILE_TIME_AT_CHECKIN
FILE_FOLDER
FILE_HIVE_ID
FILE_LOCAL_EXECUTABLE
FILE_LOCAL_FILE_EXISTS
FILE_LOCAL_NAME
FILE_LOCAL_PATH
FILE_LOCAL_SIZE
FILE_LOCAL_TIMESTAMP
FILE_MD5_CHECKSUM
FILE_NAME
FILE_PATH
FILE_PROJECT_ID
FILE_PVCS_REVISION
FILE_SIZE
FILE_STATUS
FILE_STORAGE_TYPE
FILE_SYNC_CONTENT_VERSION
FILE_SYNC_KNOWN
FILE_SYNC_MD5
FILE_SYNC_OBJECT_VERSION
FILE_SYNC_ON_ROOT_PATH
FILE_SYNC_PATH_VERSION
FILE_SYNC_SIZE
FILE_SYNC_TIME
FILE_VAULT_BRANCH_VERSION
FILE_VIEW_VERSION
FLAG
FLAG_USER_LIST
FOLDER_CREATE_PROJECT_ID
FOLDER_DESCRIPTION
FOLDER_EXCLUDE_FLAGS
FOLDER_EXCLUDE_SPEC
FOLDER_NAME
FOLDER_PATH
FOLDER_WORKING_FOLDER
LABEL_DESCRIPTION
LABEL_FLAGS
LABEL_LABEL_TIME
LABEL_MEMBER_ID
LABEL_NAME
LABEL_PROJECT_ID
LABEL_VIEW_ID
MODIFIED_TIME
MODIFIED_USER_ID
MY_LOCK
NON_EXCLUSIVE_LOCKERS
OBJECT_ID
PARENT_OBJECT_ID
PARENT_REVISION
PATH_REVISION
PROJECT_ALTERNATE_CR_EDITOR_PATH
PROJECT_ALTERNATE_FILE_EDITOR_PATH
PROJECT_ALTERNATE_REQUIREMENT_EDITOR_PATH
PROJECT_ALTERNATE_TASK_EDITOR_PATH
PROJECT_ALTERNATE_TOPIC_EDITOR_PATH
PROJECT_COMPACTION
PROJECT_CONFIGSOURCE1
PROJECT_CONFIGSOURCE2
PROJECT_DEFAULT_VIEW_ID
PROJECT_DESCRIPTION
PROJECT_DISPLAY_ALTERNATE_CR_EDITOR
PROJECT_DISPLAY_ALTERNATE_FILE_EDITOR
PROJECT_DISPLAY_ALTERNATE_REQUIREMENT_EDITOR
PROJECT_DISPLAY_ALTERNATE_TASK_EDITOR
PROJECT_DISPLAY_ALTERNATE_TOPIC_EDITOR
PROJECT_ENCRYPTION
PROJECT_FORCE_CHECKIN_REASON
PROJECT_KEYWORD_EXTENSIONS
PROJECT_MAIL
PROJECT_MARK_UNLOCKED_FILES_READ_ONLY
PROJECT_NAME
PROJECT_PROCESS_REQUIRED
PROJECT_PROCESS_SELECT_CR
PROJECT_PROCESS_SELECT_REQUIREMENT
PROJECT_PROCESS_SELECT_TASK
PROJECT_PROCESS_SHOW_CR_IN_PROGRESS
PROJECT_PROCESS_SHOW_CR_OPEN
PROJECT_PROCESS_SHOW_REQUIREMENT_APPROVED
PROJECT_PROCESS_SHOW_TASK_IN_PROGRESS
PROJECT_PROCESS_SHOW_TASK_READY
PROJECT_REQUIRE_LOCK_FOR_CHECKIN
PROJECT_TYPE
PROJECT_USE_KEYWORDS
PROMOTIONMODEL_DESCRIPTION
PROMOTIONMODEL_NAME
PROMOTIONMODEL_STATE_COUNT
PROMOTIONMODEL_STATE_IDS
PROMOTIONSTATE_DESCRIPTION
PROMOTIONSTATE_LABEL_ID
PROMOTIONSTATE_NAME
READ_ONLY
READ_STATUS
READ_STATUS_USER_LIST
RECIPIENT_COUNT
RECIPIENT_IDS
RECIPIENT_NAMES
REF_CREATED_TIME
REF_CREATED_USER_ID
REF_DELETED_TIME
REF_DELETED_USER_ID
REF_DERIVED_COUNT
REF_END_MODIFIED_TIME
REF_FLAGS
REF_FOLDER_ITEM_ID
REF_FOLDER_PATH
REF_ITEM_ID
REF_ITEM_OBJECT_ID
REF_ITEM_REVISION
REF_MODIFIED_TIME
REF_MODIFIED_USER_ID
REF_PROJECT_ID
REF_PROJECT_NAME
REF_VIEW_ID
REF_VIEW_PATH
REV_BRANCH_FLAG
REV_BRANCH_STATE
REV_LOCATION_ITEM_ID
REV_OBJECT_ID
REV_OBJECT_TIME
REV_PARENT_ITEM_ID
REV_PROJECT_ID
REV_TIME
REV_USER_ID
REV_VIEW_ID
REVISION_FLAGS
REVISION_NUMBER
ROOT_OBJECT_ID
SHARE_STATE
SHORT_COMMENT
TASK_ACTUAL_FINISH
TASK_ACTUAL_HOURS
TASK_ACTUAL_START
TASK_ATTENTION_NOTES
TASK_CHILDREN_COUNT
TASK_CONSTRAINT_DATE
TASK_CONSTRAINT_TYPE
TASK_DURATION
TASK_ESTIMATED_FINISH
TASK_ESTIMATED_FINISH_VARIANCE
TASK_ESTIMATED_HOURS
TASK_ESTIMATED_HOURS_VARIANCE
TASK_ESTIMATED_START
TASK_ESTIMATED_START_VARIANCE
TASK_GUID
TASK_IS_MY_TASK
TASK_IS_REPLICATED
TASK_MILESTONE
TASK_MSPROJECT_FILENAME
TASK_MSPROJECT_LAST_UPDATE
TASK_NAME
TASK_NEEDS_ATTENTION
TASK_NOTES
TASK_NUMBER
TASK_ORIGIN
TASK_PARENT_ID
TASK_PERCENT_COMPLETE
TASK_PRIORITY
TASK_RESOURCE_COUNT
TASK_RESOURCE_IDS
TASK_RESOURCE_NAMES
TASK_RESPONSIBILITY
TASK_STATUS
TASK_TYPE
TASK_UNIQUE_ID
TASK_WBS_CODE
TASK_WORK_DEPENDENCY_LAST_UPDATE
TASK_WORKRECORD_COUNT
TASKDEPENDENCY_LAG_TIME
TASKDEPENDENCY_PREDECESSOR_ID
TASKDEPENDENCY_TASK_ID
TASKDEPENDENCY_TYPE
TOPIC_CHILDREN_COUNT
TOPIC_DESCRIPTION
TOPIC_NUMBER
TOPIC_PARENT
TOPIC_PRIORITY
TOPIC_STATUS
TOPIC_TITLE
TOPIC_TYPE
USER_ADDRESS
USER_EMAIL_ADDRESS
USER_FAX
USER_FULL_NAME
USER_PAGER
USER_PHONE
USER_VOICE_MAIL
VIEW_BASECONFIG_DATA
VIEW_BASECONFIG_TYPE
VIEW_DELETE_COMPLETE
VIEW_DESCRIPTION
VIEW_FLAGS
VIEW_ID
VIEW_NAME
VIEW_PARENT_VIEW_ID
VIEW_PROJECT_ID
VIEW_PROMOTION_ID
VIEW_ROOT_MEMBER_ID
VIEW_SHARE_FLAGS
VIEW_WORKING_FOLDER
WORKRECORD_COMMENT
WORKRECORD_DATE
WORKRECORD_HOURS
WORKRECORD_REMAINING_HOURS
WORKRECORD_TASK_ID
WORKRECORD_USER_ID

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.PropertyNames.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.PropertyNames.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.PropertyNames.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyNames Class | Borland.StarTeam Namespace


PropertyNames Constructor

Construct PropertyNames from com.starbase.starteam.PropertyNames.

public PropertyNames(
PropertyNames impl
);

Parameters

impl
The com.starbase.starteam.PropertyNames to be wrapped.

See Also

PropertyNames Class | Borland.StarTeam Namespace


PropertyNames Properties

The properties of the PropertyNames class are listed below. For a complete list of PropertyNames class members, see the PropertyNames Members topic.

Public Static Properties

ITEM_DELETED_TIME
ITEM_DELETED_USER_ID
PROJECT_DEFAULT_TYPES
PROJECT_PROCESS_LINKS
REQ_PARENT_OBJECTID
REQ_STATUS
TASK_USAGE
TASK_USAGE_90
VIEW_RESOLVED_ID

Public Instance Properties

AM_I_RECIPIENT
ATTACHMENT_COUNT
ATTACHMENT_IDS
ATTACHMENT_NAMES
AUDIT_CLASS_ID
AUDIT_CLASS_NAME
AUDIT_CLASS2_NAME
AUDIT_CLASS3_NAME
AUDIT_DESCRIPTOR
AUDIT_DESCRIPTOR2
AUDIT_DESCRIPTOR3
AUDIT_EVENT_ID
AUDIT_FOLDER
AUDIT_FOLDER_VMID
AUDIT_ITEM_1_INFO
AUDIT_ITEM_2_INFO
AUDIT_ITEM_3_INFO
AUDIT_OBJECT_ID
AUDIT_PROJECT_ID
AUDIT_TARGET_1_REVISION_TIME
AUDIT_TARGET_2_CLASS_ID
AUDIT_TARGET_2_OBJECT_ID
AUDIT_TARGET_2_REVISION_TIME
AUDIT_TARGET_3_CLASS_ID
AUDIT_TARGET_3_OBJECT_ID
AUDIT_TARGET_3_REVISION_TIME
AUDIT_USER_ID
BRANCH_ON_CHANGE
BRANCH_STATE
COMMENT
COMMENT_ID
CONFIGURATION_TIME
CR_ADDRESSED_BY
CR_ADDRESSED_IN
CR_ADDRESSED_IN_VIEW
CR_CATEGORY
CR_CHANGE_NUMBER
CR_CLOSED_ON
CR_COMPONENT
CR_DESCRIPTION
CR_ENTERED_BY
CR_ENTERED_ON
CR_EXTERNAL_REFERENCE
CR_FIX
CR_FOLDER
CR_LAST_BUILD_TESTED
CR_PLATFORM
CR_PRIORITY
CR_RESOLVED_ON
CR_RESPONSIBILITY
CR_SEVERITY
CR_STATUS
CR_SYNOPSIS
CR_TEST_COMMAND
CR_TYPE
CR_VERIFIED_ON
CR_WORK_AROUND
CREATED_TIME
CREATED_USER_ID
DELETED_TIME
DELETED_USER_ID
DOTNOTATION
DOTNOTATION_ID
END_MODIFIED_TIME
EXCLUSIVE_LOCKER
FILE_ARCHIVE_FORMAT
FILE_ARCHIVE_NAME
FILE_ARCHIVE_PATH
FILE_ARCHIVE_TYPE
FILE_COMPRESSION_LEVEL
FILE_CONTENT_REVISION
FILE_DESCRIPTION
FILE_ENCODING
FILE_EOL_CHARACTER
FILE_EXECUTABLE
FILE_EXTENSION
FILE_FILE_TIME_AT_CHECKIN
FILE_FOLDER
FILE_HIVE_ID
FILE_LOCAL_EXECUTABLE
FILE_LOCAL_FILE_EXISTS
FILE_LOCAL_NAME
FILE_LOCAL_PATH
FILE_LOCAL_SIZE
FILE_LOCAL_TIMESTAMP
FILE_MD5_CHECKSUM
FILE_NAME
FILE_PATH
FILE_PROJECT_ID
FILE_PVCS_REVISION
FILE_SIZE
FILE_STATUS
FILE_STORAGE_TYPE
FILE_SYNC_CONTENT_VERSION
FILE_SYNC_KNOWN
FILE_SYNC_MD5
FILE_SYNC_OBJECT_VERSION
FILE_SYNC_ON_ROOT_PATH
FILE_SYNC_PATH_VERSION
FILE_SYNC_SIZE
FILE_SYNC_TIME
FILE_VAULT_BRANCH_VERSION
FILE_VIEW_VERSION
FLAG
FLAG_USER_LIST
FOLDER_CREATE_PROJECT_ID
FOLDER_DESCRIPTION
FOLDER_EXCLUDE_FLAGS
FOLDER_EXCLUDE_SPEC
FOLDER_NAME
FOLDER_PATH
FOLDER_WORKING_FOLDER
LABEL_DESCRIPTION
LABEL_FLAGS
LABEL_LABEL_TIME
LABEL_MEMBER_ID
LABEL_NAME
LABEL_PROJECT_ID
LABEL_VIEW_ID
MODIFIED_TIME
MODIFIED_USER_ID
MY_LOCK
NON_EXCLUSIVE_LOCKERS
OBJECT_ID
PARENT_OBJECT_ID
PARENT_REVISION
PATH_REVISION
PROJECT_ALTERNATE_CR_EDITOR_PATH
PROJECT_ALTERNATE_FILE_EDITOR_PATH
PROJECT_ALTERNATE_REQUIREMENT_EDITOR_PATH
PROJECT_ALTERNATE_TASK_EDITOR_PATH
PROJECT_ALTERNATE_TOPIC_EDITOR_PATH
PROJECT_COMPACTION
PROJECT_CONFIGSOURCE1
PROJECT_CONFIGSOURCE2
PROJECT_DEFAULT_VIEW_ID
PROJECT_DESCRIPTION
PROJECT_DISPLAY_ALTERNATE_CR_EDITOR
PROJECT_DISPLAY_ALTERNATE_FILE_EDITOR
PROJECT_DISPLAY_ALTERNATE_REQUIREMENT_EDITOR
PROJECT_DISPLAY_ALTERNATE_TASK_EDITOR
PROJECT_DISPLAY_ALTERNATE_TOPIC_EDITOR
PROJECT_ENCRYPTION
PROJECT_FORCE_CHECKIN_REASON
PROJECT_KEYWORD_EXTENSIONS
PROJECT_MAIL
PROJECT_MARK_UNLOCKED_FILES_READ_ONLY
PROJECT_NAME
PROJECT_PROCESS_REQUIRED
PROJECT_PROCESS_SELECT_CR
PROJECT_PROCESS_SELECT_REQUIREMENT
PROJECT_PROCESS_SELECT_TASK
PROJECT_PROCESS_SHOW_CR_IN_PROGRESS
PROJECT_PROCESS_SHOW_CR_OPEN
PROJECT_PROCESS_SHOW_REQUIREMENT_APPROVED
PROJECT_PROCESS_SHOW_TASK_IN_PROGRESS
PROJECT_PROCESS_SHOW_TASK_READY
PROJECT_REQUIRE_LOCK_FOR_CHECKIN
PROJECT_TYPE
PROJECT_USE_KEYWORDS
PROMOTIONMODEL_DESCRIPTION
PROMOTIONMODEL_NAME
PROMOTIONMODEL_STATE_COUNT
PROMOTIONMODEL_STATE_IDS
PROMOTIONSTATE_DESCRIPTION
PROMOTIONSTATE_LABEL_ID
PROMOTIONSTATE_NAME
READ_ONLY
READ_STATUS
READ_STATUS_USER_LIST
RECIPIENT_COUNT
RECIPIENT_IDS
RECIPIENT_NAMES
REF_CREATED_TIME
REF_CREATED_USER_ID
REF_DELETED_TIME
REF_DELETED_USER_ID
REF_DERIVED_COUNT
REF_END_MODIFIED_TIME
REF_FLAGS
REF_FOLDER_ITEM_ID
REF_FOLDER_PATH
REF_ITEM_ID
REF_ITEM_OBJECT_ID
REF_ITEM_REVISION
REF_MODIFIED_TIME
REF_MODIFIED_USER_ID
REF_PROJECT_ID
REF_PROJECT_NAME
REF_VIEW_ID
REF_VIEW_PATH
REV_BRANCH_FLAG
REV_BRANCH_STATE
REV_LOCATION_ITEM_ID
REV_OBJECT_ID
REV_OBJECT_TIME
REV_PARENT_ITEM_ID
REV_PROJECT_ID
REV_TIME
REV_USER_ID
REV_VIEW_ID
REVISION_FLAGS
REVISION_NUMBER
ROOT_OBJECT_ID
SHARE_STATE
SHORT_COMMENT
TASK_ACTUAL_FINISH
TASK_ACTUAL_HOURS
TASK_ACTUAL_START
TASK_ATTENTION_NOTES
TASK_CHILDREN_COUNT
TASK_CONSTRAINT_DATE
TASK_CONSTRAINT_TYPE
TASK_DURATION
TASK_ESTIMATED_FINISH
TASK_ESTIMATED_FINISH_VARIANCE
TASK_ESTIMATED_HOURS
TASK_ESTIMATED_HOURS_VARIANCE
TASK_ESTIMATED_START
TASK_ESTIMATED_START_VARIANCE
TASK_GUID
TASK_IS_MY_TASK
TASK_IS_REPLICATED
TASK_MILESTONE
TASK_MSPROJECT_FILENAME
TASK_MSPROJECT_LAST_UPDATE
TASK_NAME
TASK_NEEDS_ATTENTION
TASK_NOTES
TASK_NUMBER
TASK_ORIGIN
TASK_PARENT_ID
TASK_PERCENT_COMPLETE
TASK_PRIORITY
TASK_RESOURCE_COUNT
TASK_RESOURCE_IDS
TASK_RESOURCE_NAMES
TASK_RESPONSIBILITY
TASK_STATUS
TASK_TYPE
TASK_UNIQUE_ID
TASK_WBS_CODE
TASK_WORK_DEPENDENCY_LAST_UPDATE
TASK_WORKRECORD_COUNT
TASKDEPENDENCY_LAG_TIME
TASKDEPENDENCY_PREDECESSOR_ID
TASKDEPENDENCY_TASK_ID
TASKDEPENDENCY_TYPE
TOPIC_CHILDREN_COUNT
TOPIC_DESCRIPTION
TOPIC_NUMBER
TOPIC_PARENT
TOPIC_PRIORITY
TOPIC_STATUS
TOPIC_TITLE
TOPIC_TYPE
USER_ADDRESS
USER_EMAIL_ADDRESS
USER_FAX
USER_FULL_NAME
USER_PAGER
USER_PHONE
USER_VOICE_MAIL
VIEW_BASECONFIG_DATA
VIEW_BASECONFIG_TYPE
VIEW_DELETE_COMPLETE
VIEW_DESCRIPTION
VIEW_FLAGS
VIEW_ID
VIEW_NAME
VIEW_PARENT_VIEW_ID
VIEW_PROJECT_ID
VIEW_PROMOTION_ID
VIEW_ROOT_MEMBER_ID
VIEW_SHARE_FLAGS
VIEW_WORKING_FOLDER
WORKRECORD_COMMENT
WORKRECORD_DATE
WORKRECORD_HOURS
WORKRECORD_REMAINING_HOURS
WORKRECORD_TASK_ID
WORKRECORD_USER_ID

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyNames Class | Borland.StarTeam Namespace


AM_I_RECIPIENT Property

Borland StarTeam SDK for .NET

PropertyNames.AM_I_RECIPIENT Property

public String AM_I_RECIPIENT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

PropertyNames.ATTACHMENT_COUNT Property

public String ATTACHMENT_COUNT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

PropertyNames.ATTACHMENT_IDS Property

public String ATTACHMENT_IDS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

PropertyNames.ATTACHMENT_NAMES Property

public String ATTACHMENT_NAMES {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_CLASS_ID Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_CLASS_ID Property

public String AUDIT_CLASS_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_CLASS_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_CLASS_NAME Property

public String AUDIT_CLASS_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_CLASS2_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_CLASS2_NAME Property

public String AUDIT_CLASS2_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_CLASS3_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_CLASS3_NAME Property

public String AUDIT_CLASS3_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_DESCRIPTOR Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_DESCRIPTOR Property

public String AUDIT_DESCRIPTOR {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_DESCRIPTOR2 Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_DESCRIPTOR2 Property

public String AUDIT_DESCRIPTOR2 {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_DESCRIPTOR3 Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_DESCRIPTOR3 Property

public String AUDIT_DESCRIPTOR3 {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_EVENT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_EVENT_ID Property

public String AUDIT_EVENT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_FOLDER Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_FOLDER Property

public String AUDIT_FOLDER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_FOLDER_VMID Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_FOLDER_VMID Property

public String AUDIT_FOLDER_VMID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_ITEM_1_INFO Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_ITEM_1_INFO Property

public String AUDIT_ITEM_1_INFO {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_ITEM_2_INFO Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_ITEM_2_INFO Property

public String AUDIT_ITEM_2_INFO {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_ITEM_3_INFO Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_ITEM_3_INFO Property

public String AUDIT_ITEM_3_INFO {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_OBJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_OBJECT_ID Property

public String AUDIT_OBJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_PROJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_PROJECT_ID Property

public String AUDIT_PROJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_TARGET_1_REVISION_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_TARGET_1_REVISION_TIME Property

public String AUDIT_TARGET_1_REVISION_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_TARGET_2_CLASS_ID Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_TARGET_2_CLASS_ID Property

public String AUDIT_TARGET_2_CLASS_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_TARGET_2_OBJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_TARGET_2_OBJECT_ID Property

public String AUDIT_TARGET_2_OBJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_TARGET_2_REVISION_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_TARGET_2_REVISION_TIME Property

public String AUDIT_TARGET_2_REVISION_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_TARGET_3_CLASS_ID Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_TARGET_3_CLASS_ID Property

public String AUDIT_TARGET_3_CLASS_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_TARGET_3_OBJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_TARGET_3_OBJECT_ID Property

public String AUDIT_TARGET_3_OBJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_TARGET_3_REVISION_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_TARGET_3_REVISION_TIME Property

public String AUDIT_TARGET_3_REVISION_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


AUDIT_USER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.AUDIT_USER_ID Property

public String AUDIT_USER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

PropertyNames.BRANCH_ON_CHANGE Property

public String BRANCH_ON_CHANGE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

PropertyNames.BRANCH_STATE Property

public String BRANCH_STATE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

PropertyNames.COMMENT Property

public String COMMENT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.COMMENT_ID Property

public String COMMENT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.CONFIGURATION_TIME Property

public String CONFIGURATION_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_ADDRESSED_BY Property

Borland StarTeam SDK for .NET

PropertyNames.CR_ADDRESSED_BY Property

public String CR_ADDRESSED_BY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_ADDRESSED_IN Property

Borland StarTeam SDK for .NET

PropertyNames.CR_ADDRESSED_IN Property

public String CR_ADDRESSED_IN {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_ADDRESSED_IN_VIEW Property

Borland StarTeam SDK for .NET

PropertyNames.CR_ADDRESSED_IN_VIEW Property

public String CR_ADDRESSED_IN_VIEW {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_CATEGORY Property

Borland StarTeam SDK for .NET

PropertyNames.CR_CATEGORY Property

public String CR_CATEGORY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_CHANGE_NUMBER Property

Borland StarTeam SDK for .NET

PropertyNames.CR_CHANGE_NUMBER Property

public String CR_CHANGE_NUMBER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_CLOSED_ON Property

Borland StarTeam SDK for .NET

PropertyNames.CR_CLOSED_ON Property

public String CR_CLOSED_ON {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_COMPONENT Property

Borland StarTeam SDK for .NET

PropertyNames.CR_COMPONENT Property

public String CR_COMPONENT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_DESCRIPTION Property

Borland StarTeam SDK for .NET

PropertyNames.CR_DESCRIPTION Property

public String CR_DESCRIPTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_ENTERED_BY Property

Borland StarTeam SDK for .NET

PropertyNames.CR_ENTERED_BY Property

public String CR_ENTERED_BY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_ENTERED_ON Property

Borland StarTeam SDK for .NET

PropertyNames.CR_ENTERED_ON Property

public String CR_ENTERED_ON {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_EXTERNAL_REFERENCE Property

Borland StarTeam SDK for .NET

PropertyNames.CR_EXTERNAL_REFERENCE Property

public String CR_EXTERNAL_REFERENCE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_FIX Property

Borland StarTeam SDK for .NET

PropertyNames.CR_FIX Property

public String CR_FIX {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_FOLDER Property

Borland StarTeam SDK for .NET

PropertyNames.CR_FOLDER Property

public String CR_FOLDER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_LAST_BUILD_TESTED Property

Borland StarTeam SDK for .NET

PropertyNames.CR_LAST_BUILD_TESTED Property

public String CR_LAST_BUILD_TESTED {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_PLATFORM Property

Borland StarTeam SDK for .NET

PropertyNames.CR_PLATFORM Property

public String CR_PLATFORM {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_PRIORITY Property

Borland StarTeam SDK for .NET

PropertyNames.CR_PRIORITY Property

public String CR_PRIORITY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_RESOLVED_ON Property

Borland StarTeam SDK for .NET

PropertyNames.CR_RESOLVED_ON Property

public String CR_RESOLVED_ON {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_RESPONSIBILITY Property

Borland StarTeam SDK for .NET

PropertyNames.CR_RESPONSIBILITY Property

public String CR_RESPONSIBILITY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_SEVERITY Property

Borland StarTeam SDK for .NET

PropertyNames.CR_SEVERITY Property

public String CR_SEVERITY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_STATUS Property

Borland StarTeam SDK for .NET

PropertyNames.CR_STATUS Property

public String CR_STATUS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_SYNOPSIS Property

Borland StarTeam SDK for .NET

PropertyNames.CR_SYNOPSIS Property

public String CR_SYNOPSIS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_TEST_COMMAND Property

Borland StarTeam SDK for .NET

PropertyNames.CR_TEST_COMMAND Property

public String CR_TEST_COMMAND {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_TYPE Property

Borland StarTeam SDK for .NET

PropertyNames.CR_TYPE Property

public String CR_TYPE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_VERIFIED_ON Property

Borland StarTeam SDK for .NET

PropertyNames.CR_VERIFIED_ON Property

public String CR_VERIFIED_ON {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CR_WORK_AROUND Property

Borland StarTeam SDK for .NET

PropertyNames.CR_WORK_AROUND Property

public String CR_WORK_AROUND {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.CREATED_TIME Property

public String CREATED_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


CREATED_USER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.CREATED_USER_ID Property

public String CREATED_USER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.DELETED_TIME Property

public String DELETED_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


DELETED_USER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.DELETED_USER_ID Property

public String DELETED_USER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


DOTNOTATION Property

Borland StarTeam SDK for .NET

PropertyNames.DOTNOTATION Property

public String DOTNOTATION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


DOTNOTATION_ID Property

Borland StarTeam SDK for .NET

PropertyNames.DOTNOTATION_ID Property

public String DOTNOTATION_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.END_MODIFIED_TIME Property

public String END_MODIFIED_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

PropertyNames.EXCLUSIVE_LOCKER Property

public String EXCLUSIVE_LOCKER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_ARCHIVE_FORMAT Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_ARCHIVE_FORMAT Property

public String FILE_ARCHIVE_FORMAT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_ARCHIVE_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_ARCHIVE_NAME Property

public String FILE_ARCHIVE_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_ARCHIVE_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_ARCHIVE_PATH Property

public String FILE_ARCHIVE_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_ARCHIVE_TYPE Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_ARCHIVE_TYPE Property

public String FILE_ARCHIVE_TYPE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_COMPRESSION_LEVEL Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_COMPRESSION_LEVEL Property

public String FILE_COMPRESSION_LEVEL {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_CONTENT_REVISION Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_CONTENT_REVISION Property

public String FILE_CONTENT_REVISION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_DESCRIPTION Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_DESCRIPTION Property

public String FILE_DESCRIPTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_ENCODING Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_ENCODING Property

public String FILE_ENCODING {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_EOL_CHARACTER Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_EOL_CHARACTER Property

public String FILE_EOL_CHARACTER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_EXECUTABLE Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_EXECUTABLE Property

public String FILE_EXECUTABLE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_EXTENSION Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_EXTENSION Property

public String FILE_EXTENSION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_FILE_TIME_AT_CHECKIN Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_FILE_TIME_AT_CHECKIN Property

public String FILE_FILE_TIME_AT_CHECKIN {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_FOLDER Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_FOLDER Property

public String FILE_FOLDER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_HIVE_ID Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_HIVE_ID Property

public String FILE_HIVE_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_LOCAL_EXECUTABLE Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_LOCAL_EXECUTABLE Property

public String FILE_LOCAL_EXECUTABLE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_LOCAL_FILE_EXISTS Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_LOCAL_FILE_EXISTS Property

public String FILE_LOCAL_FILE_EXISTS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_LOCAL_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_LOCAL_NAME Property

public String FILE_LOCAL_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_LOCAL_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_LOCAL_PATH Property

public String FILE_LOCAL_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_LOCAL_SIZE Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_LOCAL_SIZE Property

public String FILE_LOCAL_SIZE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_LOCAL_TIMESTAMP Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_LOCAL_TIMESTAMP Property

public String FILE_LOCAL_TIMESTAMP {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_MD5_CHECKSUM Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_MD5_CHECKSUM Property

public String FILE_MD5_CHECKSUM {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_NAME Property

public String FILE_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_PATH Property

public String FILE_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_PROJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_PROJECT_ID Property

public String FILE_PROJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_PVCS_REVISION Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_PVCS_REVISION Property

public String FILE_PVCS_REVISION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_SIZE Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_SIZE Property

public String FILE_SIZE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_STATUS Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_STATUS Property

public String FILE_STATUS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_STORAGE_TYPE Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_STORAGE_TYPE Property

public String FILE_STORAGE_TYPE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_SYNC_CONTENT_VERSION Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_SYNC_CONTENT_VERSION Property

public String FILE_SYNC_CONTENT_VERSION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_SYNC_KNOWN Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_SYNC_KNOWN Property

public String FILE_SYNC_KNOWN {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_SYNC_MD5 Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_SYNC_MD5 Property

public String FILE_SYNC_MD5 {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_SYNC_OBJECT_VERSION Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_SYNC_OBJECT_VERSION Property

public String FILE_SYNC_OBJECT_VERSION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_SYNC_ON_ROOT_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_SYNC_ON_ROOT_PATH Property

public String FILE_SYNC_ON_ROOT_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_SYNC_PATH_VERSION Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_SYNC_PATH_VERSION Property

public String FILE_SYNC_PATH_VERSION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_SYNC_SIZE Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_SYNC_SIZE Property

public String FILE_SYNC_SIZE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_SYNC_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_SYNC_TIME Property

public String FILE_SYNC_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_VAULT_BRANCH_VERSION Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_VAULT_BRANCH_VERSION Property

public String FILE_VAULT_BRANCH_VERSION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FILE_VIEW_VERSION Property

Borland StarTeam SDK for .NET

PropertyNames.FILE_VIEW_VERSION Property

public String FILE_VIEW_VERSION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FLAG Property

Borland StarTeam SDK for .NET

PropertyNames.FLAG Property

public String FLAG {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FLAG_USER_LIST Property

Borland StarTeam SDK for .NET

PropertyNames.FLAG_USER_LIST Property

public String FLAG_USER_LIST {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FOLDER_CREATE_PROJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.FOLDER_CREATE_PROJECT_ID Property

public String FOLDER_CREATE_PROJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FOLDER_DESCRIPTION Property

Borland StarTeam SDK for .NET

PropertyNames.FOLDER_DESCRIPTION Property

public String FOLDER_DESCRIPTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FOLDER_EXCLUDE_FLAGS Property

Borland StarTeam SDK for .NET

PropertyNames.FOLDER_EXCLUDE_FLAGS Property

public String FOLDER_EXCLUDE_FLAGS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FOLDER_EXCLUDE_SPEC Property

Borland StarTeam SDK for .NET

PropertyNames.FOLDER_EXCLUDE_SPEC Property

public String FOLDER_EXCLUDE_SPEC {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FOLDER_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.FOLDER_NAME Property

public String FOLDER_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FOLDER_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.FOLDER_PATH Property

public String FOLDER_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


FOLDER_WORKING_FOLDER Property

Borland StarTeam SDK for .NET

PropertyNames.FOLDER_WORKING_FOLDER Property

public String FOLDER_WORKING_FOLDER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.ITEM_DELETED_TIME Property

public static String ITEM_DELETED_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


ITEM_DELETED_USER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.ITEM_DELETED_USER_ID Property

public static String ITEM_DELETED_USER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


LABEL_DESCRIPTION Property

Borland StarTeam SDK for .NET

PropertyNames.LABEL_DESCRIPTION Property

public String LABEL_DESCRIPTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


LABEL_FLAGS Property

Borland StarTeam SDK for .NET

PropertyNames.LABEL_FLAGS Property

public String LABEL_FLAGS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


LABEL_LABEL_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.LABEL_LABEL_TIME Property

public String LABEL_LABEL_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


LABEL_MEMBER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.LABEL_MEMBER_ID Property

public String LABEL_MEMBER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


LABEL_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.LABEL_NAME Property

public String LABEL_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


LABEL_PROJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.LABEL_PROJECT_ID Property

public String LABEL_PROJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


LABEL_VIEW_ID Property

Borland StarTeam SDK for .NET

PropertyNames.LABEL_VIEW_ID Property

public String LABEL_VIEW_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.MODIFIED_TIME Property

public String MODIFIED_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


MODIFIED_USER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.MODIFIED_USER_ID Property

public String MODIFIED_USER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


MY_LOCK Property

Borland StarTeam SDK for .NET

PropertyNames.MY_LOCK Property

public String MY_LOCK {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

PropertyNames.NON_EXCLUSIVE_LOCKERS Property

public String NON_EXCLUSIVE_LOCKERS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


OBJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.OBJECT_ID Property

public String OBJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.PARENT_OBJECT_ID Property

public String PARENT_OBJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PARENT_REVISION Property

Borland StarTeam SDK for .NET

PropertyNames.PARENT_REVISION Property

public String PARENT_REVISION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PATH_REVISION Property

Borland StarTeam SDK for .NET

PropertyNames.PATH_REVISION Property

public String PATH_REVISION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_ALTERNATE_CR_EDITOR_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_ALTERNATE_CR_EDITOR_PATH Property

public String PROJECT_ALTERNATE_CR_EDITOR_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_ALTERNATE_FILE_EDITOR_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_ALTERNATE_FILE_EDITOR_PATH Property

public String PROJECT_ALTERNATE_FILE_EDITOR_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_ALTERNATE_REQUIREMENT_EDITOR_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_ALTERNATE_REQUIREMENT_EDITOR_PATH Property

public String PROJECT_ALTERNATE_REQUIREMENT_EDITOR_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_ALTERNATE_TASK_EDITOR_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_ALTERNATE_TASK_EDITOR_PATH Property

public String PROJECT_ALTERNATE_TASK_EDITOR_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_ALTERNATE_TOPIC_EDITOR_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_ALTERNATE_TOPIC_EDITOR_PATH Property

public String PROJECT_ALTERNATE_TOPIC_EDITOR_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_COMPACTION Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_COMPACTION Property

public String PROJECT_COMPACTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_CONFIGSOURCE1 Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_CONFIGSOURCE1 Property

public String PROJECT_CONFIGSOURCE1 {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_CONFIGSOURCE2 Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_CONFIGSOURCE2 Property

public String PROJECT_CONFIGSOURCE2 {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_DEFAULT_TYPES Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_DEFAULT_TYPES Property

public static String PROJECT_DEFAULT_TYPES {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_DEFAULT_VIEW_ID Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_DEFAULT_VIEW_ID Property

public String PROJECT_DEFAULT_VIEW_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_DESCRIPTION Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_DESCRIPTION Property

public String PROJECT_DESCRIPTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_DISPLAY_ALTERNATE_CR_EDITOR Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_DISPLAY_ALTERNATE_CR_EDITOR Property

public String PROJECT_DISPLAY_ALTERNATE_CR_EDITOR {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_DISPLAY_ALTERNATE_FILE_EDITOR Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_DISPLAY_ALTERNATE_FILE_EDITOR Property

public String PROJECT_DISPLAY_ALTERNATE_FILE_EDITOR {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_DISPLAY_ALTERNATE_REQUIREMENT_EDITOR Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_DISPLAY_ALTERNATE_REQUIREMENT_EDITOR Property

public String PROJECT_DISPLAY_ALTERNATE_REQUIREMENT_EDITOR {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_DISPLAY_ALTERNATE_TASK_EDITOR Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_DISPLAY_ALTERNATE_TASK_EDITOR Property

public String PROJECT_DISPLAY_ALTERNATE_TASK_EDITOR {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_DISPLAY_ALTERNATE_TOPIC_EDITOR Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_DISPLAY_ALTERNATE_TOPIC_EDITOR Property

public String PROJECT_DISPLAY_ALTERNATE_TOPIC_EDITOR {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_ENCRYPTION Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_ENCRYPTION Property

public String PROJECT_ENCRYPTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_FORCE_CHECKIN_REASON Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_FORCE_CHECKIN_REASON Property

public String PROJECT_FORCE_CHECKIN_REASON {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_KEYWORD_EXTENSIONS Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_KEYWORD_EXTENSIONS Property

public String PROJECT_KEYWORD_EXTENSIONS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_MAIL Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_MAIL Property

public String PROJECT_MAIL {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_MARK_UNLOCKED_FILES_READ_ONLY Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_MARK_UNLOCKED_FILES_READ_ONLY Property

public String PROJECT_MARK_UNLOCKED_FILES_READ_ONLY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_NAME Property

public String PROJECT_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_PROCESS_LINKS Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_PROCESS_LINKS Property

public static String PROJECT_PROCESS_LINKS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_PROCESS_REQUIRED Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_PROCESS_REQUIRED Property

public String PROJECT_PROCESS_REQUIRED {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_PROCESS_SELECT_CR Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_PROCESS_SELECT_CR Property

public String PROJECT_PROCESS_SELECT_CR {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_PROCESS_SELECT_REQUIREMENT Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_PROCESS_SELECT_REQUIREMENT Property

public String PROJECT_PROCESS_SELECT_REQUIREMENT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_PROCESS_SELECT_TASK Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_PROCESS_SELECT_TASK Property

public String PROJECT_PROCESS_SELECT_TASK {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_PROCESS_SHOW_CR_IN_PROGRESS Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_PROCESS_SHOW_CR_IN_PROGRESS Property

public String PROJECT_PROCESS_SHOW_CR_IN_PROGRESS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_PROCESS_SHOW_CR_OPEN Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_PROCESS_SHOW_CR_OPEN Property

public String PROJECT_PROCESS_SHOW_CR_OPEN {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_PROCESS_SHOW_REQUIREMENT_APPROVED Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_PROCESS_SHOW_REQUIREMENT_APPROVED Property

public String PROJECT_PROCESS_SHOW_REQUIREMENT_APPROVED {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_PROCESS_SHOW_TASK_IN_PROGRESS Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_PROCESS_SHOW_TASK_IN_PROGRESS Property

public String PROJECT_PROCESS_SHOW_TASK_IN_PROGRESS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_PROCESS_SHOW_TASK_READY Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_PROCESS_SHOW_TASK_READY Property

public String PROJECT_PROCESS_SHOW_TASK_READY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_REQUIRE_LOCK_FOR_CHECKIN Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_REQUIRE_LOCK_FOR_CHECKIN Property

public String PROJECT_REQUIRE_LOCK_FOR_CHECKIN {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_TYPE Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_TYPE Property

public String PROJECT_TYPE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROJECT_USE_KEYWORDS Property

Borland StarTeam SDK for .NET

PropertyNames.PROJECT_USE_KEYWORDS Property

public String PROJECT_USE_KEYWORDS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROMOTIONMODEL_DESCRIPTION Property

Borland StarTeam SDK for .NET

PropertyNames.PROMOTIONMODEL_DESCRIPTION Property

public String PROMOTIONMODEL_DESCRIPTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROMOTIONMODEL_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.PROMOTIONMODEL_NAME Property

public String PROMOTIONMODEL_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROMOTIONMODEL_STATE_COUNT Property

Borland StarTeam SDK for .NET

PropertyNames.PROMOTIONMODEL_STATE_COUNT Property

public String PROMOTIONMODEL_STATE_COUNT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROMOTIONMODEL_STATE_IDS Property

Borland StarTeam SDK for .NET

PropertyNames.PROMOTIONMODEL_STATE_IDS Property

public String PROMOTIONMODEL_STATE_IDS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROMOTIONSTATE_DESCRIPTION Property

Borland StarTeam SDK for .NET

PropertyNames.PROMOTIONSTATE_DESCRIPTION Property

public String PROMOTIONSTATE_DESCRIPTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROMOTIONSTATE_LABEL_ID Property

Borland StarTeam SDK for .NET

PropertyNames.PROMOTIONSTATE_LABEL_ID Property

public String PROMOTIONSTATE_LABEL_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PROMOTIONSTATE_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.PROMOTIONSTATE_NAME Property

public String PROMOTIONSTATE_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


READ_ONLY Property

Borland StarTeam SDK for .NET

PropertyNames.READ_ONLY Property

public String READ_ONLY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


READ_STATUS Property

Borland StarTeam SDK for .NET

PropertyNames.READ_STATUS Property

public String READ_STATUS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


READ_STATUS_USER_LIST Property

Borland StarTeam SDK for .NET

PropertyNames.READ_STATUS_USER_LIST Property

public String READ_STATUS_USER_LIST {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


RECIPIENT_COUNT Property

Borland StarTeam SDK for .NET

PropertyNames.RECIPIENT_COUNT Property

public String RECIPIENT_COUNT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


RECIPIENT_IDS Property

Borland StarTeam SDK for .NET

PropertyNames.RECIPIENT_IDS Property

public String RECIPIENT_IDS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


RECIPIENT_NAMES Property

Borland StarTeam SDK for .NET

PropertyNames.RECIPIENT_NAMES Property

public String RECIPIENT_NAMES {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_CREATED_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.REF_CREATED_TIME Property

public String REF_CREATED_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_CREATED_USER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REF_CREATED_USER_ID Property

public String REF_CREATED_USER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_DELETED_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.REF_DELETED_TIME Property

public String REF_DELETED_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_DELETED_USER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REF_DELETED_USER_ID Property

public String REF_DELETED_USER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_DERIVED_COUNT Property

Borland StarTeam SDK for .NET

PropertyNames.REF_DERIVED_COUNT Property

public String REF_DERIVED_COUNT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.REF_END_MODIFIED_TIME Property

public String REF_END_MODIFIED_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_FLAGS Property

Borland StarTeam SDK for .NET

PropertyNames.REF_FLAGS Property

public String REF_FLAGS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_FOLDER_ITEM_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REF_FOLDER_ITEM_ID Property

public String REF_FOLDER_ITEM_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_FOLDER_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.REF_FOLDER_PATH Property

public String REF_FOLDER_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_ITEM_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REF_ITEM_ID Property

public String REF_ITEM_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_ITEM_OBJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REF_ITEM_OBJECT_ID Property

public String REF_ITEM_OBJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_ITEM_REVISION Property

Borland StarTeam SDK for .NET

PropertyNames.REF_ITEM_REVISION Property

public String REF_ITEM_REVISION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.REF_MODIFIED_TIME Property

public String REF_MODIFIED_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_MODIFIED_USER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REF_MODIFIED_USER_ID Property

public String REF_MODIFIED_USER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_PROJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REF_PROJECT_ID Property

public String REF_PROJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_PROJECT_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.REF_PROJECT_NAME Property

public String REF_PROJECT_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_VIEW_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REF_VIEW_ID Property

public String REF_VIEW_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REF_VIEW_PATH Property

Borland StarTeam SDK for .NET

PropertyNames.REF_VIEW_PATH Property

public String REF_VIEW_PATH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REQ_PARENT_OBJECTID Property

Borland StarTeam SDK for .NET

PropertyNames.REQ_PARENT_OBJECTID Property

public static String REQ_PARENT_OBJECTID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REQ_STATUS Property

Borland StarTeam SDK for .NET

PropertyNames.REQ_STATUS Property

public static String REQ_STATUS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REV_BRANCH_FLAG Property

Borland StarTeam SDK for .NET

PropertyNames.REV_BRANCH_FLAG Property

public String REV_BRANCH_FLAG {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REV_BRANCH_STATE Property

Borland StarTeam SDK for .NET

PropertyNames.REV_BRANCH_STATE Property

public String REV_BRANCH_STATE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REV_LOCATION_ITEM_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REV_LOCATION_ITEM_ID Property

public String REV_LOCATION_ITEM_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REV_OBJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REV_OBJECT_ID Property

public String REV_OBJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REV_OBJECT_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.REV_OBJECT_TIME Property

public String REV_OBJECT_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REV_PARENT_ITEM_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REV_PARENT_ITEM_ID Property

public String REV_PARENT_ITEM_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REV_PROJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REV_PROJECT_ID Property

public String REV_PROJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REV_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.REV_TIME Property

public String REV_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REV_USER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REV_USER_ID Property

public String REV_USER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REV_VIEW_ID Property

Borland StarTeam SDK for .NET

PropertyNames.REV_VIEW_ID Property

public String REV_VIEW_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

PropertyNames.REVISION_FLAGS Property

public String REVISION_FLAGS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

PropertyNames.REVISION_NUMBER Property

public String REVISION_NUMBER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.ROOT_OBJECT_ID Property

public String ROOT_OBJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

PropertyNames.SHARE_STATE Property

public String SHARE_STATE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

PropertyNames.SHORT_COMMENT Property

public String SHORT_COMMENT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_ACTUAL_FINISH Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_ACTUAL_FINISH Property

public String TASK_ACTUAL_FINISH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_ACTUAL_HOURS Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_ACTUAL_HOURS Property

public String TASK_ACTUAL_HOURS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_ACTUAL_START Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_ACTUAL_START Property

public String TASK_ACTUAL_START {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_ATTENTION_NOTES Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_ATTENTION_NOTES Property

public String TASK_ATTENTION_NOTES {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_CHILDREN_COUNT Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_CHILDREN_COUNT Property

public String TASK_CHILDREN_COUNT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_CONSTRAINT_DATE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_CONSTRAINT_DATE Property

public String TASK_CONSTRAINT_DATE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_CONSTRAINT_TYPE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_CONSTRAINT_TYPE Property

public String TASK_CONSTRAINT_TYPE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_DURATION Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_DURATION Property

public String TASK_DURATION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_ESTIMATED_FINISH Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_ESTIMATED_FINISH Property

public String TASK_ESTIMATED_FINISH {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_ESTIMATED_FINISH_VARIANCE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_ESTIMATED_FINISH_VARIANCE Property

public String TASK_ESTIMATED_FINISH_VARIANCE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_ESTIMATED_HOURS Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_ESTIMATED_HOURS Property

public String TASK_ESTIMATED_HOURS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_ESTIMATED_HOURS_VARIANCE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_ESTIMATED_HOURS_VARIANCE Property

public String TASK_ESTIMATED_HOURS_VARIANCE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_ESTIMATED_START Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_ESTIMATED_START Property

public String TASK_ESTIMATED_START {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_ESTIMATED_START_VARIANCE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_ESTIMATED_START_VARIANCE Property

public String TASK_ESTIMATED_START_VARIANCE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_GUID Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_GUID Property

public String TASK_GUID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_IS_MY_TASK Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_IS_MY_TASK Property

public String TASK_IS_MY_TASK {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_IS_REPLICATED Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_IS_REPLICATED Property

public String TASK_IS_REPLICATED {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_MILESTONE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_MILESTONE Property

public String TASK_MILESTONE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_MSPROJECT_FILENAME Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_MSPROJECT_FILENAME Property

public String TASK_MSPROJECT_FILENAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_MSPROJECT_LAST_UPDATE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_MSPROJECT_LAST_UPDATE Property

public String TASK_MSPROJECT_LAST_UPDATE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_NAME Property

public String TASK_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_NEEDS_ATTENTION Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_NEEDS_ATTENTION Property

public String TASK_NEEDS_ATTENTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_NOTES Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_NOTES Property

public String TASK_NOTES {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_NUMBER Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_NUMBER Property

public String TASK_NUMBER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_ORIGIN Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_ORIGIN Property

public String TASK_ORIGIN {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_PARENT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_PARENT_ID Property

public String TASK_PARENT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_PERCENT_COMPLETE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_PERCENT_COMPLETE Property

public String TASK_PERCENT_COMPLETE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_PRIORITY Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_PRIORITY Property

public String TASK_PRIORITY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_RESOURCE_COUNT Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_RESOURCE_COUNT Property

public String TASK_RESOURCE_COUNT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_RESOURCE_IDS Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_RESOURCE_IDS Property

public String TASK_RESOURCE_IDS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_RESOURCE_NAMES Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_RESOURCE_NAMES Property

public String TASK_RESOURCE_NAMES {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_RESPONSIBILITY Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_RESPONSIBILITY Property

public String TASK_RESPONSIBILITY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_STATUS Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_STATUS Property

public String TASK_STATUS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_TYPE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_TYPE Property

public String TASK_TYPE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_UNIQUE_ID Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_UNIQUE_ID Property

public String TASK_UNIQUE_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_USAGE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_USAGE Property

public static String TASK_USAGE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_USAGE_90 Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_USAGE_90 Property

public static String TASK_USAGE_90 {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_WBS_CODE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_WBS_CODE Property

public String TASK_WBS_CODE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_WORK_DEPENDENCY_LAST_UPDATE Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_WORK_DEPENDENCY_LAST_UPDATE Property

public String TASK_WORK_DEPENDENCY_LAST_UPDATE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASK_WORKRECORD_COUNT Property

Borland StarTeam SDK for .NET

PropertyNames.TASK_WORKRECORD_COUNT Property

public String TASK_WORKRECORD_COUNT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASKDEPENDENCY_LAG_TIME Property

Borland StarTeam SDK for .NET

PropertyNames.TASKDEPENDENCY_LAG_TIME Property

public String TASKDEPENDENCY_LAG_TIME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASKDEPENDENCY_PREDECESSOR_ID Property

Borland StarTeam SDK for .NET

PropertyNames.TASKDEPENDENCY_PREDECESSOR_ID Property

public String TASKDEPENDENCY_PREDECESSOR_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASKDEPENDENCY_TASK_ID Property

Borland StarTeam SDK for .NET

PropertyNames.TASKDEPENDENCY_TASK_ID Property

public String TASKDEPENDENCY_TASK_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TASKDEPENDENCY_TYPE Property

Borland StarTeam SDK for .NET

PropertyNames.TASKDEPENDENCY_TYPE Property

public String TASKDEPENDENCY_TYPE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TOPIC_CHILDREN_COUNT Property

Borland StarTeam SDK for .NET

PropertyNames.TOPIC_CHILDREN_COUNT Property

public String TOPIC_CHILDREN_COUNT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TOPIC_DESCRIPTION Property

Borland StarTeam SDK for .NET

PropertyNames.TOPIC_DESCRIPTION Property

public String TOPIC_DESCRIPTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TOPIC_NUMBER Property

Borland StarTeam SDK for .NET

PropertyNames.TOPIC_NUMBER Property

public String TOPIC_NUMBER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TOPIC_PARENT Property

Borland StarTeam SDK for .NET

PropertyNames.TOPIC_PARENT Property

public String TOPIC_PARENT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TOPIC_PRIORITY Property

Borland StarTeam SDK for .NET

PropertyNames.TOPIC_PRIORITY Property

public String TOPIC_PRIORITY {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TOPIC_STATUS Property

Borland StarTeam SDK for .NET

PropertyNames.TOPIC_STATUS Property

public String TOPIC_STATUS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TOPIC_TITLE Property

Borland StarTeam SDK for .NET

PropertyNames.TOPIC_TITLE Property

public String TOPIC_TITLE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


TOPIC_TYPE Property

Borland StarTeam SDK for .NET

PropertyNames.TOPIC_TYPE Property

public String TOPIC_TYPE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


USER_ADDRESS Property

Borland StarTeam SDK for .NET

PropertyNames.USER_ADDRESS Property

public String USER_ADDRESS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


USER_EMAIL_ADDRESS Property

Borland StarTeam SDK for .NET

PropertyNames.USER_EMAIL_ADDRESS Property

public String USER_EMAIL_ADDRESS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


USER_FAX Property

Borland StarTeam SDK for .NET

PropertyNames.USER_FAX Property

public String USER_FAX {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


USER_FULL_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.USER_FULL_NAME Property

public String USER_FULL_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


USER_PAGER Property

Borland StarTeam SDK for .NET

PropertyNames.USER_PAGER Property

public String USER_PAGER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


USER_PHONE Property

Borland StarTeam SDK for .NET

PropertyNames.USER_PHONE Property

public String USER_PHONE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


USER_VOICE_MAIL Property

Borland StarTeam SDK for .NET

PropertyNames.USER_VOICE_MAIL Property

public String USER_VOICE_MAIL {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_BASECONFIG_DATA Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_BASECONFIG_DATA Property

public String VIEW_BASECONFIG_DATA {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_BASECONFIG_TYPE Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_BASECONFIG_TYPE Property

public String VIEW_BASECONFIG_TYPE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_DELETE_COMPLETE Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_DELETE_COMPLETE Property

public String VIEW_DELETE_COMPLETE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_DESCRIPTION Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_DESCRIPTION Property

public String VIEW_DESCRIPTION {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_FLAGS Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_FLAGS Property

public String VIEW_FLAGS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_ID Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_ID Property

public String VIEW_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_NAME Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_NAME Property

public String VIEW_NAME {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_PARENT_VIEW_ID Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_PARENT_VIEW_ID Property

public String VIEW_PARENT_VIEW_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_PROJECT_ID Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_PROJECT_ID Property

public String VIEW_PROJECT_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_PROMOTION_ID Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_PROMOTION_ID Property

public String VIEW_PROMOTION_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_RESOLVED_ID Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_RESOLVED_ID Property

public static String VIEW_RESOLVED_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_ROOT_MEMBER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_ROOT_MEMBER_ID Property

public String VIEW_ROOT_MEMBER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_SHARE_FLAGS Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_SHARE_FLAGS Property

public String VIEW_SHARE_FLAGS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


VIEW_WORKING_FOLDER Property

Borland StarTeam SDK for .NET

PropertyNames.VIEW_WORKING_FOLDER Property

public String VIEW_WORKING_FOLDER {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


WORKRECORD_COMMENT Property

Borland StarTeam SDK for .NET

PropertyNames.WORKRECORD_COMMENT Property

public String WORKRECORD_COMMENT {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


WORKRECORD_DATE Property

Borland StarTeam SDK for .NET

PropertyNames.WORKRECORD_DATE Property

public String WORKRECORD_DATE {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


WORKRECORD_HOURS Property

Borland StarTeam SDK for .NET

PropertyNames.WORKRECORD_HOURS Property

public String WORKRECORD_HOURS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


WORKRECORD_REMAINING_HOURS Property

Borland StarTeam SDK for .NET

PropertyNames.WORKRECORD_REMAINING_HOURS Property

public String WORKRECORD_REMAINING_HOURS {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


WORKRECORD_TASK_ID Property

Borland StarTeam SDK for .NET

PropertyNames.WORKRECORD_TASK_ID Property

public String WORKRECORD_TASK_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


WORKRECORD_USER_ID Property

Borland StarTeam SDK for .NET

PropertyNames.WORKRECORD_USER_ID Property

public String WORKRECORD_USER_ID {get;}

See Also

PropertyNames Class | Borland.StarTeam Namespace


PropertyNames Methods

The methods of the PropertyNames class are listed below. For a complete list of PropertyNames class members, see the PropertyNames Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PropertyNames.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.PropertyNames.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.PropertyNames.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.PropertyNames.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyNames Class | Borland.StarTeam Namespace


PropertyNames.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.PropertyNames

Implements

IWrapper.Unwrap

See Also

PropertyNames Class | Borland.StarTeam Namespace


PropertyNames.Equals Method

Delegate Equals() to com.starbase.starteam.PropertyNames.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.PropertyNames.Equals(obj).

See Also

PropertyNames Class | Borland.StarTeam Namespace


PropertyNames.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.PropertyNames.

public override int GetHashCode();

Return Value

com.starbase.starteam.PropertyNames.GetHashCode().

See Also

PropertyNames Class | Borland.StarTeam Namespace


PropertyNames.ToString Method

Delegate ToString() to com.starbase.starteam.PropertyNames.

public override string ToString();

Return Value

com.starbase.starteam.PropertyNames.ToString()

See Also

PropertyNames Class | Borland.StarTeam Namespace


PropertyNames.Wrap Method

Dynamically wraps com.starbase.starteam.PropertyNames.

public static PropertyNames Wrap(
PropertyNames impl
);

Parameters

impl
com.starbase.starteam.PropertyNames to be wrapped.

Return Value

PropertyNames

See Also

PropertyNames Class | Borland.StarTeam Namespace


PropertyNames Type Conversions

The type conversions of the PropertyNames class are listed below. For a complete list of PropertyNames class members, see the PropertyNames Members topic.

Public Static Type Conversions

Implicit PropertyNames to PropertyNames Conversion Implicitly convert PropertyNames to com.starbase.starteam.PropertyNames.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyNames Class | PropertyNames Members | Borland.StarTeam Namespace


PropertyNames Implicit PropertyNames to PropertyNames Conversion

Implicitly convert PropertyNames to com.starbase.starteam.PropertyNames.

public static implicit operator PropertyNames(
PropertyNames arg
);

Parameters

arg
PropertyNames to convert.

Return Value

com.starbase.starteam.PropertyNames

See Also

PropertyNames Class | Borland.StarTeam Namespace


PropertyNotWritableException Class

For a list of all members of this type, see PropertyNotWritableException Members.

System.Object
Exception
PropertyNotWritableException

public class PropertyNotWritableException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PropertyNotWritableException Members | Borland.StarTeam Namespace


PropertyNotWritableException Members

PropertyNotWritableException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PropertyNotWritableException.

Public Static Type Conversions

Implicit PropertyNotWritableException to PropertyNotWritableException Conversion Implicitly convert PropertyNotWritableException to com.starbase.starteam.PropertyNotWritableException.

Public Instance Constructors

PropertyNotWritableException Constructor Construct PropertyNotWritableException from com.starbase.starteam.PropertyNotWritableException.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Property |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.PropertyNotWritableException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.PropertyNotWritableException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.PropertyNotWritableException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyNotWritableException Class | Borland.StarTeam Namespace


PropertyNotWritableException Constructor

Construct PropertyNotWritableException from com.starbase.starteam.PropertyNotWritableException.

public PropertyNotWritableException(
PropertyNotWritableException impl
);

Parameters

impl
The com.starbase.starteam.PropertyNotWritableException to be wrapped.

See Also

PropertyNotWritableException Class | Borland.StarTeam Namespace


PropertyNotWritableException Properties

The properties of the PropertyNotWritableException class are listed below. For a complete list of PropertyNotWritableException class members, see the PropertyNotWritableException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Property |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyNotWritableException Class | Borland.StarTeam Namespace


Property Property

Borland StarTeam SDK for .NET

PropertyNotWritableException.Property Property

public virtual Property Property {get;}

See Also

PropertyNotWritableException Class | Borland.StarTeam Namespace


PropertyNotWritableException Methods

The methods of the PropertyNotWritableException class are listed below. For a complete list of PropertyNotWritableException class members, see the PropertyNotWritableException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PropertyNotWritableException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.PropertyNotWritableException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.PropertyNotWritableException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.PropertyNotWritableException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyNotWritableException Class | Borland.StarTeam Namespace


PropertyNotWritableException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.PropertyNotWritableException

Implements

IWrapper.Unwrap

See Also

PropertyNotWritableException Class | Borland.StarTeam Namespace


PropertyNotWritableException.Equals Method

Delegate Equals() to com.starbase.starteam.PropertyNotWritableException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.PropertyNotWritableException.Equals(obj).

See Also

PropertyNotWritableException Class | Borland.StarTeam Namespace


PropertyNotWritableException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.PropertyNotWritableException.

public override int GetHashCode();

Return Value

com.starbase.starteam.PropertyNotWritableException.GetHashCode().

See Also

PropertyNotWritableException Class | Borland.StarTeam Namespace


PropertyNotWritableException.ToString Method

Delegate ToString() to com.starbase.starteam.PropertyNotWritableException.

public override string ToString();

Return Value

com.starbase.starteam.PropertyNotWritableException.ToString()

See Also

PropertyNotWritableException Class | Borland.StarTeam Namespace


PropertyNotWritableException.Wrap Method

Dynamically wraps com.starbase.starteam.PropertyNotWritableException.

public static PropertyNotWritableException Wrap(
PropertyNotWritableException impl
);

Parameters

impl
com.starbase.starteam.PropertyNotWritableException to be wrapped.

Return Value

PropertyNotWritableException

See Also

PropertyNotWritableException Class | Borland.StarTeam Namespace


PropertyNotWritableException Type Conversions

The type conversions of the PropertyNotWritableException class are listed below. For a complete list of PropertyNotWritableException class members, see the PropertyNotWritableException Members topic.

Public Static Type Conversions

Implicit PropertyNotWritableException to PropertyNotWritableException Conversion Implicitly convert PropertyNotWritableException to com.starbase.starteam.PropertyNotWritableException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyNotWritableException Class | PropertyNotWritableException Members | Borland.StarTeam Namespace


PropertyNotWritableException Implicit PropertyNotWritableException to PropertyNotWritableException Conversion

Implicitly convert PropertyNotWritableException to com.starbase.starteam.PropertyNotWritableException.

public static implicit operator PropertyNotWritableException(
PropertyNotWritableException arg
);

Parameters

arg
PropertyNotWritableException to convert.

Return Value

com.starbase.starteam.PropertyNotWritableException

See Also

PropertyNotWritableException Class | Borland.StarTeam Namespace


PurgeControl Class

Provides control over the Online Purge service. The service may be configured to start automatically when the server starts up. If configured to do so, it will run a purge in the background while the server is running. This eliminates the requirement for costly down time just to purge the starteam repository. The online purge will not affect any resources deleted during the current active server session. Access the purge log by issuing a writeLogFile command with a logType value of 1.

For a list of all members of this type, see PurgeControl Members.

System.Object
PurgeControl

public class PurgeControl : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PurgeControl Members | Borland.StarTeam Namespace


PurgeControl Members

PurgeControl overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PurgeControl.

Public Static Type Conversions

Implicit PurgeControl to PurgeControl Conversion Implicitly convert PurgeControl to com.starbase.starteam.PurgeControl.

Public Instance Constructors

PurgeControl Constructor Construct PurgeControl from com.starbase.starteam.PurgeControl.

Public Instance Properties

PurgeStatus [read] the status of the Purge Service (Ready = 0, In Progress = 1, Completed = 2, Error = -1)

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.PurgeControl.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.PurgeControl.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Start the online purge service
Stop | Stop the online purge service.
ToString | Delegate ToString() to com.starbase.starteam.PurgeControl.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeControl Constructor

Construct PurgeControl from com.starbase.starteam.PurgeControl.

public PurgeControl(
PurgeControl impl
);

Parameters

impl
The com.starbase.starteam.PurgeControl to be wrapped.

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeControl Properties

The properties of the PurgeControl class are listed below. For a complete list of PurgeControl class members, see the PurgeControl Members topic.

Public Instance Properties

PurgeStatus [read] the status of the Purge Service (Ready = 0, In Progress = 1, Completed = 2, Error = -1)

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeStatus Property

Borland StarTeam SDK for .NET

PurgeControl.PurgeStatus Property

[read] the status of the Purge Service (Ready = 0, In Progress = 1, Completed = 2, Error = -1)

public virtual PurgeStatus PurgeStatus {get;}

Property Value

the status of the Purge Service (Ready = 0, In Progress = 1, Completed = 2, Error = -1)

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeControl Methods

The methods of the PurgeControl class are listed below. For a complete list of PurgeControl class members, see the PurgeControl Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PurgeControl.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.PurgeControl.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.PurgeControl.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Start the online purge service
Stop | Stop the online purge service.
ToString | Delegate ToString() to com.starbase.starteam.PurgeControl.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeControl.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.PurgeControl

Implements

IWrapper.Unwrap

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeControl.Equals Method

Delegate Equals() to com.starbase.starteam.PurgeControl.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.PurgeControl.Equals(obj).

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeControl.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.PurgeControl.

public override int GetHashCode();

Return Value

com.starbase.starteam.PurgeControl.GetHashCode().

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeControl.Start Method

Start the online purge service

public virtual PurgeStatus Start();

Return Value

the status of the start request

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeControl.Stop Method

Stop the online purge service.

public virtual PurgeStatus Stop();

Return Value

the status of the stop request

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeControl.ToString Method

Delegate ToString() to com.starbase.starteam.PurgeControl.

public override string ToString();

Return Value

com.starbase.starteam.PurgeControl.ToString()

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeControl.Wrap Method

Dynamically wraps com.starbase.starteam.PurgeControl.

public static PurgeControl Wrap(
PurgeControl impl
);

Parameters

impl
com.starbase.starteam.PurgeControl to be wrapped.

Return Value

PurgeControl

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeControl Type Conversions

The type conversions of the PurgeControl class are listed below. For a complete list of PurgeControl class members, see the PurgeControl Members topic.

Public Static Type Conversions

Implicit PurgeControl to PurgeControl Conversion Implicitly convert PurgeControl to com.starbase.starteam.PurgeControl.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PurgeControl Class | PurgeControl Members | Borland.StarTeam Namespace


PurgeControl Implicit PurgeControl to PurgeControl Conversion

Implicitly convert PurgeControl to com.starbase.starteam.PurgeControl.

public static implicit operator PurgeControl(
PurgeControl arg
);

Parameters

arg
PurgeControl to convert.

Return Value

com.starbase.starteam.PurgeControl

See Also

PurgeControl Class | Borland.StarTeam Namespace


PurgeStatus Class

Describes the current state of the purge service

For a list of all members of this type, see PurgeStatus Members.

System.Object
PurgeStatus

public class PurgeStatus : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PurgeStatus Members | Borland.StarTeam Namespace


PurgeStatus Members

PurgeStatus overview

Public Static Properties

All | [read] MergeAction[] an array of all PurgeStatus instances
COMPLETED |
FAILED |
IN_PROGRESS |
READY |
STOPPING |

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PurgeStatus.

Public Static Type Conversions

Implicit PurgeStatus to PurgeStatus Conversion Implicitly convert PurgeStatus to com.starbase.starteam.PurgeStatus.

Public Instance Constructors

PurgeStatus Constructor Construct PurgeStatus from com.starbase.starteam.PurgeStatus.

Public Instance Properties

Name | [read] a description of the status of the purge.
Status | [read] the status of the purge.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.PurgeStatus.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.PurgeStatus.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.PurgeStatus.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PurgeStatus Class | Borland.StarTeam Namespace


PurgeStatus Constructor

Construct PurgeStatus from com.starbase.starteam.PurgeStatus.

public PurgeStatus(
PurgeStatus impl
);

Parameters

impl
The com.starbase.starteam.PurgeStatus to be wrapped.

See Also

PurgeStatus Class | Borland.StarTeam Namespace


PurgeStatus Properties

The properties of the PurgeStatus class are listed below. For a complete list of PurgeStatus class members, see the PurgeStatus Members topic.

Public Static Properties

All | [read] MergeAction[] an array of all PurgeStatus instances
COMPLETED |
FAILED |
IN_PROGRESS |
READY |
STOPPING |

Public Instance Properties

Name | [read] a description of the status of the purge.
Status | [read] the status of the purge.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PurgeStatus Class | Borland.StarTeam Namespace


All Property

Borland StarTeam SDK for .NET

PurgeStatus.All Property

[read] MergeAction[] an array of all PurgeStatus instances

public static PurgeStatusCollection All {get;}

Property Value

MergeAction[] an array of all PurgeStatus instances

See Also

PurgeStatus Class | Borland.StarTeam Namespace


COMPLETED Property

Borland StarTeam SDK for .NET

PurgeStatus.COMPLETED Property

public static PurgeStatus COMPLETED {get;}

See Also

PurgeStatus Class | Borland.StarTeam Namespace


FAILED Property

Borland StarTeam SDK for .NET

PurgeStatus.FAILED Property

public static PurgeStatus FAILED {get;}

See Also

PurgeStatus Class | Borland.StarTeam Namespace


IN_PROGRESS Property

Borland StarTeam SDK for .NET

PurgeStatus.IN_PROGRESS Property

public static PurgeStatus IN_PROGRESS {get;}

See Also

PurgeStatus Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

PurgeStatus.Name Property

[read] a description of the status of the purge.

public virtual String Name {get;}

Property Value

a description of the status of the purge.

See Also

PurgeStatus Class | Borland.StarTeam Namespace


READY Property

Borland StarTeam SDK for .NET

PurgeStatus.READY Property

public static PurgeStatus READY {get;}

See Also

PurgeStatus Class | Borland.StarTeam Namespace


Status Property

Borland StarTeam SDK for .NET

PurgeStatus.Status Property

[read] the status of the purge.

public virtual Int32 Status {get;}

Property Value

the status of the purge.

See Also

PurgeStatus Class | Borland.StarTeam Namespace


STOPPING Property

Borland StarTeam SDK for .NET

PurgeStatus.STOPPING Property

public static PurgeStatus STOPPING {get;}

See Also

PurgeStatus Class | Borland.StarTeam Namespace


PurgeStatus Methods

The methods of the PurgeStatus class are listed below. For a complete list of PurgeStatus class members, see the PurgeStatus Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.PurgeStatus.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.PurgeStatus.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.PurgeStatus.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.PurgeStatus.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PurgeStatus Class | Borland.StarTeam Namespace


PurgeStatus.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.PurgeStatus

Implements

IWrapper.Unwrap

See Also

PurgeStatus Class | Borland.StarTeam Namespace


PurgeStatus.Equals Method

Delegate Equals() to com.starbase.starteam.PurgeStatus.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.PurgeStatus.Equals(obj).

See Also

PurgeStatus Class | Borland.StarTeam Namespace


PurgeStatus.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.PurgeStatus.

public override int GetHashCode();

Return Value

com.starbase.starteam.PurgeStatus.GetHashCode().

See Also

PurgeStatus Class | Borland.StarTeam Namespace


PurgeStatus.ToString Method

Delegate ToString() to com.starbase.starteam.PurgeStatus.

public override string ToString();

Return Value

com.starbase.starteam.PurgeStatus.ToString()

See Also

PurgeStatus Class | Borland.StarTeam Namespace


PurgeStatus.Wrap Method

Dynamically wraps com.starbase.starteam.PurgeStatus.

public static PurgeStatus Wrap(
PurgeStatus impl
);

Parameters

impl
com.starbase.starteam.PurgeStatus to be wrapped.

Return Value

PurgeStatus

See Also

PurgeStatus Class | Borland.StarTeam Namespace


PurgeStatus Type Conversions

The type conversions of the PurgeStatus class are listed below. For a complete list of PurgeStatus class members, see the PurgeStatus Members topic.

Public Static Type Conversions

Implicit PurgeStatus to PurgeStatus Conversion Implicitly convert PurgeStatus to com.starbase.starteam.PurgeStatus.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PurgeStatus Class | PurgeStatus Members | Borland.StarTeam Namespace


PurgeStatus Implicit PurgeStatus to PurgeStatus Conversion

Implicitly convert PurgeStatus to com.starbase.starteam.PurgeStatus.

public static implicit operator PurgeStatus(
PurgeStatus arg
);

Parameters

arg
PurgeStatus to convert.

Return Value

com.starbase.starteam.PurgeStatus

See Also

PurgeStatus Class | Borland.StarTeam Namespace


PurgeStatusCollection Class

A strongly-typed collection of PurgeStatuss.

For a list of all members of this type, see PurgeStatusCollection Members.

System.Object
ArrayAdapter
PurgeStatusCollection

public class PurgeStatusCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PurgeStatusCollection Members | Borland.StarTeam Namespace


PurgeStatusCollection Members

PurgeStatusCollection overview

Public Static Methods

Wrap Creates a PurgeStatusCollection to represent the given array of PurgeStatus (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit PurgeStatusCollection to PurgeStatus[] Conversion | Converts a PurgeStatusCollection to an array of PurgeStatuss.
Implicit PurgeStatusCollection to PurgeStatus[] Conversion | Converts a PurgeStatusCollection from the Borland.StarTeam namespace to a PurgeStatus[] in the com.starbase.starteam namespace.

Public Instance Constructors

PurgeStatusCollection Overloaded. Initializes a new instance of the PurgeStatusCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the PurgeStatus at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a PurgeStatus to end of the collection.
Append | Overloaded. Appends the PurgeStatuss of the given PurgeStatusCollection to the end of this PurgeStatusCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific PurgeStatus.
CopyTo | Copies all of the PurgeStatuss in the PurgeStatusCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the PurgeStatus with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific PurgeStatus in the collection.
Insert | Inserts a PurgeStatus into the collection at the specified position.
Remove | Removes the first occurrence of a specific PurgeStatus from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the PurgeStatuss in this PurgeStatusCollection.
Sort | Sorts the PurgeStatuss in this PurgeStatusCollection, using the given comparer.
SortByName | Sorts the PurgeStatuss in this PurgeStatusCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection Constructor

Initializes an instance of the PurgeStatusCollection class.

Overload List

Initializes an instance of the PurgeStatusCollection class.

public PurgeStatusCollection();

Initializes an instance of the a PurgeStatusCollection class, copying the given array.

public PurgeStatusCollection(PurgeStatus[]);

Initializes an instance of the a PurgeStatusCollection class, copying the given collection.

public PurgeStatusCollection(PurgeStatusCollection);

Initializes an instance of the a PurgeStatusCollection class, wrapping the given array of PurgeStatus (from the com.starbase.starteam namespace).

public PurgeStatusCollection(PurgeStatus[]);

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection Constructor ()

Initializes an instance of the PurgeStatusCollection class.

public PurgeStatusCollection();

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace | PurgeStatusCollection Constructor Overload List


PurgeStatusCollection Constructor (PurgeStatus[])

Initializes an instance of the a PurgeStatusCollection class, wrapping the given array of PurgeStatus (from the com.starbase.starteam namespace).

public PurgeStatusCollection(
PurgeStatus[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace | PurgeStatusCollection Constructor Overload List | Wrap


PurgeStatusCollection Constructor (PurgeStatusCollection)

Initializes an instance of the a PurgeStatusCollection class, copying the given collection.

public PurgeStatusCollection(
PurgeStatusCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member PurgeStatus objects of the original collection are shared, not copied.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace | PurgeStatusCollection Constructor Overload List


PurgeStatusCollection Constructor (PurgeStatus[])

Initializes an instance of the a PurgeStatusCollection class, copying the given array.

public PurgeStatusCollection(
PurgeStatus[] array
);

Parameters

array
The array to be copied.

Remarks

The member PurgeStatus objects of the original array are shared, not copied.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace | PurgeStatusCollection Constructor Overload List


PurgeStatusCollection Properties

The properties of the PurgeStatusCollection class are listed below. For a complete list of PurgeStatusCollection class members, see the PurgeStatusCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the PurgeStatus at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

PurgeStatusCollection.Item Property

Gets or sets the PurgeStatus at the specified index.

Overload List

Gets or sets the PurgeStatus at the specified index.

public PurgeStatus this[Int32] {get; set;}

Gets the PurgeStatus with the given name.

public PurgeStatus this[String] {get;}

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

PurgeStatusCollection.Item Property (Int32)

Gets or sets the PurgeStatus at the specified index.

public PurgeStatus this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the PurgeStatus to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace | PurgeStatusCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

PurgeStatusCollection.Item Property (String)

Gets the PurgeStatus with the given name.

public PurgeStatus this[
String name
] {get;}

Parameters

name
The name of the PurgeStatus to get.

Property Value

The PurgeStatus with the given name, or null if there is no PurgeStatus with that name in this PurgeStatusCollection. Comparison is case sensitive.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace | PurgeStatusCollection.Item Overload List | FindByName


PurgeStatusCollection Methods

The methods of the PurgeStatusCollection class are listed below. For a complete list of PurgeStatusCollection class members, see the PurgeStatusCollection Members topic.

Public Static Methods

Wrap Creates a PurgeStatusCollection to represent the given array of PurgeStatus (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a PurgeStatus to end of the collection.
Append | Overloaded. Appends the PurgeStatuss of the given PurgeStatusCollection to the end of this PurgeStatusCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific PurgeStatus.
CopyTo | Copies all of the PurgeStatuss in the PurgeStatusCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the PurgeStatus with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific PurgeStatus in the collection.
Insert | Inserts a PurgeStatus into the collection at the specified position.
Remove | Removes the first occurrence of a specific PurgeStatus from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the PurgeStatuss in this PurgeStatusCollection.
Sort | Sorts the PurgeStatuss in this PurgeStatusCollection, using the given comparer.
SortByName | Sorts the PurgeStatuss in this PurgeStatusCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.Add Method

Adds a PurgeStatus to end of the collection.

public int Add(
PurgeStatus value
);

Parameters

value
The PurgeStatus to add to the collection.

Return Value

The position into which the new PurgeStatus was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

PurgeStatusCollection.Append Method

Appends the PurgeStatuss of the given array to the end of this PurgeStatusCollection.

Overload List

Appends the PurgeStatuss of the given array to the end of this PurgeStatusCollection.

public PurgeStatusCollection Append(PurgeStatus[]);

Appends the PurgeStatuss of the given PurgeStatusCollection to the end of this PurgeStatusCollection.

public PurgeStatusCollection Append(PurgeStatusCollection);

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.Append Method (PurgeStatus[])

Appends the PurgeStatuss of the given array to the end of this PurgeStatusCollection.

public PurgeStatusCollection Append(
PurgeStatus[] array
);

Parameters

array
The array whose PurgeStatuss are to be appended to this PurgeStatusCollection.

Return Value

This PurgeStatusCollection, modified to include the new PurgeStatuss.

Remarks

The PurgeStatusCollection is modified to include the new members. The individual PurgeStatus objects are shared, not copied.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace | PurgeStatusCollection.Append Overload List


PurgeStatusCollection.Append Method (PurgeStatusCollection)

Appends the PurgeStatuss of the given PurgeStatusCollection to the end of this PurgeStatusCollection.

public PurgeStatusCollection Append(
PurgeStatusCollection collection
);

Parameters

collection
The PurgeStatusCollection whose PurgeStatuss are to be appended to this PurgeStatusCollection.

Return Value

This PurgeStatusCollection, modified to include the new PurgeStatuss.

Remarks

The PurgeStatusCollection is modified to include the new members. The individual PurgeStatus objects are shared, not copied.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace | PurgeStatusCollection.Append Overload List


PurgeStatusCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.PurgeStatus[].

Implements

IWrapper.Unwrap

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.Contains Method

Determines whether or not the collection contains a specific PurgeStatus.

public bool Contains(
PurgeStatus value
);

Parameters

value
The PurgeStatus to locate in the collection.

Return Value

true if the PurgeStatus is found in the collection; otherwise, false.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.CopyTo Method

Copies all of the PurgeStatuss in the PurgeStatusCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
PurgeStatus[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the PurgeStatuss copied from the PurgeStatusCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of PurgeStatuss in the source PurgeStatusCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source PurgeStatusCollection cannot be cast automatically to the type of the destination array.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.FindByName Method

Finds the PurgeStatus with the given name.

public PurgeStatus FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the PurgeStatus to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The PurgeStatus with the given name, or null if there is no PurgeStatus with that name in this PurgeStatusCollection.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.IndexOf Method

Determines the index of a specific PurgeStatus in the collection.

public int IndexOf(
PurgeStatus value
);

Parameters

value
The PurgeStatus to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.Insert Method

Inserts a PurgeStatus into the collection at the specified position.

public void Insert(
Int32 index,
PurgeStatus value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The PurgeStatus to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.Remove Method

Removes the first occurrence of a specific PurgeStatus from the collection.

public void Remove(
PurgeStatus value
);

Parameters

value
The PurgeStatus to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.Reverse Method

Reverses the order of the PurgeStatuss in this PurgeStatusCollection.

new public PurgeStatusCollection Reverse();

Return Value

This PurgeStatusCollection, modified such that the PurgeStatuss are reversed.

Remarks

The PurgeStatusCollection is modified in place.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.Sort Method

Sorts the PurgeStatuss in this PurgeStatusCollection, using the given comparer.

new public PurgeStatusCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two PurgeStatuss.

Return Value

This PurgeStatusCollection, modified such that the PurgeStatuss are sorted.

Remarks

The PurgeStatusCollection is modified in place.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.SortByName Method

Sorts the PurgeStatuss in this PurgeStatusCollection by name.

public PurgeStatusCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This PurgeStatusCollection, modified such that the PurgeStatuss are sorted by name.

Remarks

The PurgeStatusCollection is modified in place.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection.Wrap Method

Creates a PurgeStatusCollection to represent the given array of PurgeStatus (from the com.starbase.starteam namespace).

public static PurgeStatusCollection Wrap(
PurgeStatus[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new PurgeStatusCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a PurgeStatus[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection Type Conversions

The type conversions of the PurgeStatusCollection class are listed below. For a complete list of PurgeStatusCollection class members, see the PurgeStatusCollection Members topic.

Public Static Type Conversions

Implicit PurgeStatusCollection to PurgeStatus[] Conversion | Converts a PurgeStatusCollection to an array of PurgeStatuss.
Implicit PurgeStatusCollection to PurgeStatus[] Conversion | Converts a PurgeStatusCollection from the Borland.StarTeam namespace to a PurgeStatus[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

PurgeStatusCollection Class | PurgeStatusCollection Members | Borland.StarTeam Namespace


PurgeStatusCollection Implicit PurgeStatusCollection to PurgeStatus[] Conversion

Converts a PurgeStatusCollection to an array of PurgeStatuss.

public static implicit operator PurgeStatus[](
PurgeStatusCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new PurgeStatus wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one PurgeStatus wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


PurgeStatusCollection Implicit PurgeStatusCollection to PurgeStatus[] Conversion

Converts a PurgeStatusCollection from the Borland.StarTeam namespace to a PurgeStatus[] in the com.starbase.starteam namespace.

public static implicit operator PurgeStatus[](
PurgeStatusCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, PurgeStatusCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

PurgeStatusCollection Class | Borland.StarTeam Namespace


Query Class

The QueryInfo class implements a query condition to be applied to items of a certain type. QueryInfo objects are used in conjunction with Filter objects for describing what items to display to the user and how to display them.

For a list of all members of this type, see Query Members.

System.Object
Query

public class Query : ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Query Members | Borland.StarTeam Namespace


Query Members

Query overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.QueryInfo.

Public Static Type Conversions

Implicit Query to QueryInfo Conversion Implicitly convert Query to com.starbase.starteam.QueryInfo.

Public Instance Constructors

Query Overloaded. Initializes a new instance of the Query class.

Public Instance Properties

ACL |
DebugString | [read] a debug string for this query.
ID | [read]
IsDeleted | [read] true if this query has been deleted.
IsDirty | [read] true if the query has unsaved modifications.
IsNew | [read] true if this query is newly created and not yet saved in the repository.
IsPublic | [read] true if the filter is publicly visible.
Name | [read/write] the name of the query.
ParentContainer |
PropertyIDs | [read]
QueryNode | [read/write] the boolean expression defining this query.
Type |
UserID | [read] the user ID for the user who created this query.

Public Instance Methods

Copy | Creates a copy of this QueryInfo object. Useful to applications that want to save a snapshot of the query in a given state, for example, before calling Type.refreshFiltersAndQueries().
Delete | Deletes this query from the repository.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Evaluate | Evaluate this QueryPart with respect to the specified item.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission |
IsEqualTo | Compares two QueryInfo objects.
MakePublic |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Store this query in the repository. If the query is new then a new query will be added, if it exists then it will be modified. It is possible that the ID (getID()) for the query will change after calling this method even for an existing query. This method cannot be called on a deleted query.

See Also

Query Class | Borland.StarTeam Namespace


Query Constructor

Construct Query from com.starbase.starteam.QueryInfo.

Overload List

Create a new QueryInfo object for the specified type.

public Query(Type,Boolean,String,QueryNode);

Construct Query from com.starbase.starteam.QueryInfo.

public Query(QueryInfo);

See Also

Query Class | Borland.StarTeam Namespace


Query Constructor (QueryInfo)

Construct Query from com.starbase.starteam.QueryInfo.

public Query(
QueryInfo impl
);

Parameters

impl
The com.starbase.starteam.QueryInfo to be wrapped.

See Also

Query Class | Borland.StarTeam Namespace | Query Constructor Overload List


Query Constructor (Type, Boolean, String, QueryNode)

Create a new QueryInfo object for the specified type.

public Query(
Type type,
Boolean bPublic,
String name,
QueryNode node
);

Parameters

type
the Item type to which this query can be applied. Cannot be null.
bPublic
true if the QueryInfo is to be publicly visible or not.
name
the name of the QueryInfo object. Cannot be null.
node
the boolean expression defining the query. Cannot be null.

See Also

Query Class | Borland.StarTeam Namespace | Query Constructor Overload List


Query Properties

The properties of the Query class are listed below. For a complete list of Query class members, see the Query Members topic.

Public Instance Properties

ACL |
DebugString | [read] a debug string for this query.
ID | [read]
IsDeleted | [read] true if this query has been deleted.
IsDirty | [read] true if the query has unsaved modifications.
IsNew | [read] true if this query is newly created and not yet saved in the repository.
IsPublic | [read] true if the filter is publicly visible.
Name | [read/write] the name of the query.
ParentContainer |
PropertyIDs | [read]
QueryNode | [read/write] the boolean expression defining this query.
Type |
UserID | [read] the user ID for the user who created this query.

See Also

Query Class | Borland.StarTeam Namespace


ACL Property

Borland StarTeam SDK for .NET

Query.ACL Property

public virtual ACL ACL {get; set;}

Implements

ISecurable.ACL

See Also

Query Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Query.DebugString Property

[read] a debug string for this query.

public virtual String DebugString {get;}

Property Value

a debug string for this query.

See Also

Query Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Query.ID Property

[read]

public virtual Int32 ID {get;}

See Also

Query Class | Borland.StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Query.IsDeleted Property

[read] true if this query has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if this query has been deleted.

See Also

Query Class | Borland.StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Query.IsDirty Property

[read] true if the query has unsaved modifications.

public virtual Boolean IsDirty {get;}

Property Value

true if the query has unsaved modifications.

See Also

Query Class | Borland.StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Query.IsNew Property

[read] true if this query is newly created and not yet saved in the repository.

public virtual Boolean IsNew {get;}

Property Value

true if this query is newly created and not yet saved in the repository.

See Also

Query Class | Borland.StarTeam Namespace


IsPublic Property

Borland StarTeam SDK for .NET

Query.IsPublic Property

[read] true if the filter is publicly visible.

public virtual Boolean IsPublic {get;}

Property Value

true if the filter is publicly visible.

See Also

Query Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Query.Name Property

[read/write] the name of the query.

public virtual String Name {get; set;}

Property Value

the name of the query.

See Also

Query Class | Borland.StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

Query.ParentContainer Property

public virtual ISecurableContainer ParentContainer {get;}

Implements

ISecurable.ParentContainer

See Also

Query Class | Borland.StarTeam Namespace


PropertyIDs Property

Borland StarTeam SDK for .NET

Query.PropertyIDs Property

[read]

public virtual Int32[] PropertyIDs {get;}

See Also

Query Class | Borland.StarTeam Namespace


QueryNode Property

Borland StarTeam SDK for .NET

Query.QueryNode Property

[read/write] the boolean expression defining this query.

public virtual QueryNode QueryNode {get; set;}

Property Value

the boolean expression defining this query.

See Also

Query Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

Query.Type Property

public virtual Type Type {get;}

Implements

ISecurable.Type

See Also

Query Class | Borland.StarTeam Namespace


UserID Property

Borland StarTeam SDK for .NET

Query.UserID Property

[read] the user ID for the user who created this query.

public virtual Int32 UserID {get;}

Property Value

the user ID for the user who created this query.

See Also

Query Class | Borland.StarTeam Namespace


Query Methods

The methods of the Query class are listed below. For a complete list of Query class members, see the Query Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.QueryInfo.

Public Instance Methods

Copy | Creates a copy of this QueryInfo object. Useful to applications that want to save a snapshot of the query in a given state, for example, before calling Type.refreshFiltersAndQueries().
Delete | Deletes this query from the repository.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Evaluate | Evaluate this QueryPart with respect to the specified item.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission |
IsEqualTo | Compares two QueryInfo objects.
MakePublic |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Store this query in the repository. If the query is new then a new query will be added, if it exists then it will be modified. It is possible that the ID (getID()) for the query will change after calling this method even for an existing query. This method cannot be called on a deleted query.

See Also

Query Class | Borland.StarTeam Namespace


Query.Copy Method

Creates a copy of this QueryInfo object. Useful to applications that want to save a snapshot of the query in a given state, for example, before calling Type.refreshFiltersAndQueries().

public virtual Query Copy();

Return Value

A copy of this QueryInfo object.

See Also

Query Class | Borland.StarTeam Namespace | isEqualTo


Query.Delete Method

Deletes this query from the repository.

public virtual void Delete();

See Also

Query Class | Borland.StarTeam Namespace


Query.Evaluate Method

Evaluate this QueryPart with respect to the specified item.

public virtual bool Evaluate(
Item item
);

Parameters

item
the item whose specified property value to test against

Return Value

true if the item satisfies the query and false otherwise.

See Also

Query Class | Borland.StarTeam Namespace


Query.HasPermission Method

public virtual bool HasPermission(
Int32 permissions
);

Implements

ISecurable.HasPermission

See Also

Query Class | Borland.StarTeam Namespace


Query.IsEqualTo Method

Compares two QueryInfo objects.

public virtual bool IsEqualTo(
Query query
);

Parameters

query
The QueryInfo to be compared with this one.

Return Value

true if no differences were found.

See Also

Query Class | Borland.StarTeam Namespace | copy


Query.MakePublic Method

public virtual void MakePublic();

See Also

Query Class | Borland.StarTeam Namespace


Query.Update Method

Store this query in the repository. If the query is new then a new query will be added, if it exists then it will be modified. It is possible that the ID (getID()) for the query will change after calling this method even for an existing query. This method cannot be called on a deleted query.

public virtual void Update();

See Also

Query Class | Borland.StarTeam Namespace


Query.Wrap Method

Dynamically wraps com.starbase.starteam.QueryInfo.

public static Query Wrap(
QueryInfo impl
);

Parameters

impl
com.starbase.starteam.QueryInfo to be wrapped.

Return Value

Query

See Also

Query Class | Borland.StarTeam Namespace


Query Type Conversions

The type conversions of the Query class are listed below. For a complete list of Query class members, see the Query Members topic.

Public Static Type Conversions

Implicit Query to QueryInfo Conversion Implicitly convert Query to com.starbase.starteam.QueryInfo.

See Also

Query Class | Query Members | Borland.StarTeam Namespace


Query Implicit Query to QueryInfo Conversion

Implicitly convert Query to com.starbase.starteam.QueryInfo.

public static implicit operator QueryInfo(
Query arg
);

Parameters

arg
Query to convert.

Return Value

com.starbase.starteam.QueryInfo

See Also

Query Class | Borland.StarTeam Namespace


QueryCollection Class

A strongly-typed collection of Querys.

For a list of all members of this type, see QueryCollection Members.

System.Object
ArrayAdapter
QueryCollection

public class QueryCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

QueryCollection Members | Borland.StarTeam Namespace


QueryCollection Members

QueryCollection overview

Public Static Methods

Wrap Creates a QueryCollection to represent the given array of QueryInfo (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit QueryCollection to Query[] Conversion | Converts a QueryCollection to an array of Querys.
Implicit QueryCollection to QueryInfo[] Conversion | Converts a QueryCollection from the Borland.StarTeam namespace to a QueryInfo[] in the com.starbase.starteam namespace.

Public Instance Constructors

QueryCollection Overloaded. Initializes a new instance of the QueryCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Query at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Query to end of the collection.
Append | Overloaded. Appends the Querys of the given QueryCollection to the end of this QueryCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Query.
CopyTo | Copies all of the Querys in the QueryCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Query with the given ID.
FindByName | Finds the Query with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Query in the collection.
Insert | Inserts a Query into the collection at the specified position.
Remove | Removes the first occurrence of a specific Query from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Querys in this QueryCollection.
Sort | Sorts the Querys in this QueryCollection, using the given comparer.
SortByID | Sorts the Querys in this QueryCollection by ID.
SortByName | Sorts the Querys in this QueryCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection Constructor

Initializes an instance of the QueryCollection class.

Overload List

Initializes an instance of the QueryCollection class.

public QueryCollection();

Initializes an instance of the a QueryCollection class, copying the given array.

public QueryCollection(Query[]);

Initializes an instance of the a QueryCollection class, copying the given collection.

public QueryCollection(QueryCollection);

Initializes an instance of the a QueryCollection class, wrapping the given array of QueryInfo (from the com.starbase.starteam namespace).

public QueryCollection(QueryInfo[]);

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection Constructor ()

Initializes an instance of the QueryCollection class.

public QueryCollection();

See Also

QueryCollection Class | Borland.StarTeam Namespace | QueryCollection Constructor Overload List


QueryCollection Constructor (QueryInfo[])

Initializes an instance of the a QueryCollection class, wrapping the given array of QueryInfo (from the com.starbase.starteam namespace).

public QueryCollection(
QueryInfo[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

QueryCollection Class | Borland.StarTeam Namespace | QueryCollection Constructor Overload List | Wrap


QueryCollection Constructor (QueryCollection)

Initializes an instance of the a QueryCollection class, copying the given collection.

public QueryCollection(
QueryCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Query objects of the original collection are shared, not copied.

See Also

QueryCollection Class | Borland.StarTeam Namespace | QueryCollection Constructor Overload List


QueryCollection Constructor (Query[])

Initializes an instance of the a QueryCollection class, copying the given array.

public QueryCollection(
Query[] array
);

Parameters

array
The array to be copied.

Remarks

The member Query objects of the original array are shared, not copied.

See Also

QueryCollection Class | Borland.StarTeam Namespace | QueryCollection Constructor Overload List


QueryCollection Properties

The properties of the QueryCollection class are listed below. For a complete list of QueryCollection class members, see the QueryCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Query at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

QueryCollection.Item Property

Gets or sets the Query at the specified index.

Overload List

Gets or sets the Query at the specified index.

public Query this[Int32] {get; set;}

Gets the Query with the given name.

public Query this[String] {get;}

See Also

QueryCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

QueryCollection.Item Property (Int32)

Gets or sets the Query at the specified index.

public Query this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Query to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

QueryCollection Class | Borland.StarTeam Namespace | QueryCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

QueryCollection.Item Property (String)

Gets the Query with the given name.

public Query this[
String name
] {get;}

Parameters

name
The name of the Query to get.

Property Value

The Query with the given name, or null if there is no Query with that name in this QueryCollection. Comparison is case sensitive.

See Also

QueryCollection Class | Borland.StarTeam Namespace | QueryCollection.Item Overload List | FindByName


QueryCollection Methods

The methods of the QueryCollection class are listed below. For a complete list of QueryCollection class members, see the QueryCollection Members topic.

Public Static Methods

Wrap Creates a QueryCollection to represent the given array of QueryInfo (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a Query to end of the collection.
Append | Overloaded. Appends the Querys of the given QueryCollection to the end of this QueryCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Query.
CopyTo | Copies all of the Querys in the QueryCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the Query with the given ID.
FindByName | Finds the Query with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Query in the collection.
Insert | Inserts a Query into the collection at the specified position.
Remove | Removes the first occurrence of a specific Query from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Querys in this QueryCollection.
Sort | Sorts the Querys in this QueryCollection, using the given comparer.
SortByID | Sorts the Querys in this QueryCollection by ID.
SortByName | Sorts the Querys in this QueryCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.Add Method

Adds a Query to end of the collection.

public int Add(
Query value
);

Parameters

value
The Query to add to the collection.

Return Value

The position into which the new Query was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

QueryCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

QueryCollection.Append Method

Appends the Querys of the given array to the end of this QueryCollection.

Overload List

Appends the Querys of the given array to the end of this QueryCollection.

public QueryCollection Append(Query[]);

Appends the Querys of the given QueryCollection to the end of this QueryCollection.

public QueryCollection Append(QueryCollection);

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.Append Method (Query[])

Appends the Querys of the given array to the end of this QueryCollection.

public QueryCollection Append(
Query[] array
);

Parameters

array
The array whose Querys are to be appended to this QueryCollection.

Return Value

This QueryCollection, modified to include the new Querys.

Remarks

The QueryCollection is modified to include the new members. The individual Query objects are shared, not copied.

See Also

QueryCollection Class | Borland.StarTeam Namespace | QueryCollection.Append Overload List


QueryCollection.Append Method (QueryCollection)

Appends the Querys of the given QueryCollection to the end of this QueryCollection.

public QueryCollection Append(
QueryCollection collection
);

Parameters

collection
The QueryCollection whose Querys are to be appended to this QueryCollection.

Return Value

This QueryCollection, modified to include the new Querys.

Remarks

The QueryCollection is modified to include the new members. The individual Query objects are shared, not copied.

See Also

QueryCollection Class | Borland.StarTeam Namespace | QueryCollection.Append Overload List


QueryCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.QueryInfo[].

Implements

IWrapper.Unwrap

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.Contains Method

Determines whether or not the collection contains a specific Query.

public bool Contains(
Query value
);

Parameters

value
The Query to locate in the collection.

Return Value

true if the Query is found in the collection; otherwise, false.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.CopyTo Method

Copies all of the Querys in the QueryCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Query[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Querys copied from the QueryCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Querys in the source QueryCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source QueryCollection cannot be cast automatically to the type of the destination array.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.FindByID Method

Finds the Query with the given ID.

public Query FindByID(
Int32 id
);

Parameters

id
The ID of the Query to be found.

Return Value

The Query with the given ID, or null if there is no Query with that ID in this QueryCollection.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.FindByName Method

Finds the Query with the given name.

public Query FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the Query to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The Query with the given name, or null if there is no Query with that name in this QueryCollection.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.IndexOf Method

Determines the index of a specific Query in the collection.

public int IndexOf(
Query value
);

Parameters

value
The Query to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.Insert Method

Inserts a Query into the collection at the specified position.

public void Insert(
Int32 index,
Query value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Query to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.Remove Method

Removes the first occurrence of a specific Query from the collection.

public void Remove(
Query value
);

Parameters

value
The Query to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.Reverse Method

Reverses the order of the Querys in this QueryCollection.

new public QueryCollection Reverse();

Return Value

This QueryCollection, modified such that the Querys are reversed.

Remarks

The QueryCollection is modified in place.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.Sort Method

Sorts the Querys in this QueryCollection, using the given comparer.

new public QueryCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Querys.

Return Value

This QueryCollection, modified such that the Querys are sorted.

Remarks

The QueryCollection is modified in place.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.SortByID Method

Sorts the Querys in this QueryCollection by ID.

public QueryCollection SortByID();

Return Value

This QueryCollection, modified such that the Querys are sorted by ID.

Remarks

The QueryCollection is modified in place.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.SortByName Method

Sorts the Querys in this QueryCollection by name.

public QueryCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This QueryCollection, modified such that the Querys are sorted by name.

Remarks

The QueryCollection is modified in place.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection.Wrap Method

Creates a QueryCollection to represent the given array of QueryInfo (from the com.starbase.starteam namespace).

public static QueryCollection Wrap(
QueryInfo[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new QueryCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a QueryInfo[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection Type Conversions

The type conversions of the QueryCollection class are listed below. For a complete list of QueryCollection class members, see the QueryCollection Members topic.

Public Static Type Conversions

Implicit QueryCollection to Query[] Conversion | Converts a QueryCollection to an array of Querys.
Implicit QueryCollection to QueryInfo[] Conversion | Converts a QueryCollection from the Borland.StarTeam namespace to a QueryInfo[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryCollection Class | QueryCollection Members | Borland.StarTeam Namespace


QueryCollection Implicit QueryCollection to Query[] Conversion

Converts a QueryCollection to an array of Querys.

public static implicit operator Query[](
QueryCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Query wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Query wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryCollection Implicit QueryCollection to QueryInfo[] Conversion

Converts a QueryCollection from the Borland.StarTeam namespace to a QueryInfo[] in the com.starbase.starteam namespace.

public static implicit operator QueryInfo[](
QueryCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, QueryCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

QueryCollection Class | Borland.StarTeam Namespace


QueryEventArgs Class

For a list of all members of this type, see QueryEventArgs Members.

System.Object
EventArgs
QueryEventArgs

public class QueryEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

QueryEventArgs Members | Borland.StarTeam Namespace


QueryEventArgs Members

QueryEventArgs overview

Public Static Type Conversions

Implicit QueryEventArgs to QueryEvent Conversion Implicitly convert QueryEventArgs to com.starbase.starteam.QueryEvent.

Public Instance Properties

Query [read] The QueryInfo that has been added, changed or deleted, in its new state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

QueryEventArgs Class | Borland.StarTeam Namespace


QueryEventArgs Properties

The properties of the QueryEventArgs class are listed below. For a complete list of QueryEventArgs class members, see the QueryEventArgs Members topic.

Public Instance Properties

Query [read] The QueryInfo that has been added, changed or deleted, in its new state.

See Also

QueryEventArgs Class | Borland.StarTeam Namespace


Query Property

Borland StarTeam SDK for .NET

QueryEventArgs.Query Property

[read] The QueryInfo that has been added, changed or deleted, in its new state.

public virtual Query Query {get;}

Property Value

The QueryInfo that has been added, changed or deleted, in its new state.

See Also

QueryEventArgs Class | Borland.StarTeam Namespace


QueryEventArgs Methods

The methods of the QueryEventArgs class are listed below. For a complete list of QueryEventArgs class members, see the QueryEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

QueryEventArgs Class | Borland.StarTeam Namespace


QueryEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

QueryEventArgs Class | Borland.StarTeam Namespace


QueryEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

QueryEventArgs Class | Borland.StarTeam Namespace


QueryEventArgs.ToString Method

public override string ToString();

See Also

QueryEventArgs Class | Borland.StarTeam Namespace


QueryEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

QueryEventArgs Class | Borland.StarTeam Namespace


QueryEventArgs Type Conversions

The type conversions of the QueryEventArgs class are listed below. For a complete list of QueryEventArgs class members, see the QueryEventArgs Members topic.

Public Static Type Conversions

Implicit QueryEventArgs to QueryEvent Conversion Implicitly convert QueryEventArgs to com.starbase.starteam.QueryEvent.

See Also

QueryEventArgs Class | QueryEventArgs Members | Borland.StarTeam Namespace


QueryEventArgs Implicit QueryEventArgs to QueryEvent Conversion

Implicitly convert QueryEventArgs to com.starbase.starteam.QueryEvent.

public static implicit operator QueryEvent(
QueryEventArgs arg
);

Parameters

arg
QueryEventArgs to convert.

Return Value

com.starbase.starteam.QueryEvent

See Also

QueryEventArgs Class | Borland.StarTeam Namespace


QueryEventSource Class

For a list of all members of this type, see QueryEventSource Members.

System.Object
QueryEventSource

public class QueryEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

QueryEventSource Members | Borland.StarTeam Namespace


QueryEventSource Members

QueryEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnQueryAdded
OnQueryChanged
OnQueryDeleted
QueryAdded
QueryChanged
QueryDeleted

See Also

QueryEventSource Class | Borland.StarTeam Namespace


QueryEventSource Properties

The properties of the QueryEventSource class are listed below. For a complete list of QueryEventSource class members, see the QueryEventSource Members topic.

Public Instance Properties

Parent

See Also

QueryEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

QueryEventSource.Parent Property

public Object Parent {get;}

See Also

QueryEventSource Class | Borland.StarTeam Namespace


QueryEventSource Events

The events of the QueryEventSource class are listed below. For a complete list of QueryEventSource class members, see the QueryEventSource Members topic.

Public Instance Events

OnQueryAdded
OnQueryChanged
OnQueryDeleted
QueryAdded
QueryChanged
QueryDeleted

See Also

QueryEventSource Class | Borland.StarTeam Namespace


QueryEventSource.OnQueryAdded Event

public event QueryEventSource.Handler OnQueryAdded;

See Also

QueryEventSource Class | Borland.StarTeam Namespace


QueryEventSource.OnQueryChanged Event

public event QueryEventSource.Handler OnQueryChanged;

See Also

QueryEventSource Class | Borland.StarTeam Namespace


QueryEventSource.OnQueryDeleted Event

public event QueryEventSource.Handler OnQueryDeleted;

See Also

QueryEventSource Class | Borland.StarTeam Namespace


QueryEventSource.QueryAdded Event

public event QueryEventSource.Handler QueryAdded;

See Also

QueryEventSource Class | Borland.StarTeam Namespace


QueryEventSource.QueryChanged Event

public event QueryEventSource.Handler QueryChanged;

See Also

QueryEventSource Class | Borland.StarTeam Namespace


QueryEventSource.QueryDeleted Event

public event QueryEventSource.Handler QueryDeleted;

See Also

QueryEventSource Class | Borland.StarTeam Namespace


QueryEventSource.Handler Delegate

public delegate void QueryEventSource.Handler(
QueryEventSource source,
QueryEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


QueryNode Class

A QueryNode represents a boolean expression. The expression is applied to an item to determine if the query is true of the item or not.

For a list of all members of this type, see QueryNode Members.

System.Object
QueryNode

public class QueryNode : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

QueryNode Members | Borland.StarTeam Namespace


QueryNode Members

QueryNode overview

Public Static Properties

OP_AND
OP_NOT
OP_OR

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.QueryNode.

Public Static Type Conversions

Implicit QueryNode to QueryNode Conversion Implicitly convert QueryNode to com.starbase.starteam.QueryNode.

Public Instance Constructors

QueryNode Overloaded. Initializes a new instance of the QueryNode class.

Public Instance Properties

DebugString | [read] a debug string for this QueryNode.
Operator | [read/write]
QueryNodes | [read/write] the QueryParts associated with this QueryNode.
QueryParts | [read/write] the QueryParts associated with this QueryNode.

Public Instance Methods

AppendQueryNode | A convenience method to add a QueryNode at the end of the list.
AppendQueryPart | A convenience method to add a QueryParts at the end of the list.
ClearQueryNodes | A convenience method to remove all query parts.
ClearQueryParts | A convenience method to remove all query parts.
CopyQueryNode | Returns a deep copy of this QueryNode.
Equals | Delegate Equals() to com.starbase.starteam.QueryNode.
Evaluate | Evaluate this QueryPart with respect to the specified item.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.QueryNode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToDebugStringDepth | Returns a String with debug information about this QueryNode. You can specify the current indentation depth to use.
ToString | Delegate ToString() to com.starbase.starteam.QueryNode.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode Constructor

Construct QueryNode from com.starbase.starteam.QueryNode.

Overload List

Construct QueryNode from com.starbase.starteam.QueryNode.

public QueryNode(QueryNode);

Creates a new QueryNode of the specified type. The possible values can only be OP_AND and OP_OR. Newer server revisions also support the OP_NOT operator.

public QueryNode(Int32);

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode Constructor (QueryNode)

Construct QueryNode from com.starbase.starteam.QueryNode.

public QueryNode(
QueryNode impl
);

Parameters

impl
The com.starbase.starteam.QueryNode to be wrapped.

See Also

QueryNode Class | Borland.StarTeam Namespace | QueryNode Constructor Overload List


QueryNode Constructor (Int32)

Creates a new QueryNode of the specified type. The possible values can only be OP_AND and OP_OR. Newer server revisions also support the OP_NOT operator.

public QueryNode(
Int32 anOperator
);

Parameters

anOperator

See Also

QueryNode Class | Borland.StarTeam Namespace | QueryNode Constructor Overload List | OP_AND | OP_OR | OP_NOT | hasNOTQueryOperator


QueryNode Properties

The properties of the QueryNode class are listed below. For a complete list of QueryNode class members, see the QueryNode Members topic.

Public Static Properties

OP_AND
OP_NOT
OP_OR

Public Instance Properties

DebugString | [read] a debug string for this QueryNode.
Operator | [read/write]
QueryNodes | [read/write] the QueryParts associated with this QueryNode.
QueryParts | [read/write] the QueryParts associated with this QueryNode.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

QueryNode Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

QueryNode.DebugString Property

[read] a debug string for this QueryNode.

public virtual String DebugString {get;}

Property Value

a debug string for this QueryNode.

See Also

QueryNode Class | Borland.StarTeam Namespace


OP_AND Property

Borland StarTeam SDK for .NET

QueryNode.OP_AND Property

public static Int32 OP_AND {get;}

See Also

QueryNode Class | Borland.StarTeam Namespace


OP_NOT Property

Borland StarTeam SDK for .NET

QueryNode.OP_NOT Property

public static Int32 OP_NOT {get;}

See Also

QueryNode Class | Borland.StarTeam Namespace


OP_OR Property

Borland StarTeam SDK for .NET

QueryNode.OP_OR Property

public static Int32 OP_OR {get;}

See Also

QueryNode Class | Borland.StarTeam Namespace


Operator Property

Borland StarTeam SDK for .NET

QueryNode.Operator Property

[read/write]

public virtual Int32 Operator {get; set;}

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNodes Property

Borland StarTeam SDK for .NET

QueryNode.QueryNodes Property

[read/write] the QueryParts associated with this QueryNode.

public virtual QueryNodeCollection QueryNodes {get; set;}

Property Value

the QueryParts associated with this QueryNode.

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryParts Property

Borland StarTeam SDK for .NET

QueryNode.QueryParts Property

[read/write] the QueryParts associated with this QueryNode.

public virtual QueryPartCollection QueryParts {get; set;}

Property Value

the QueryParts associated with this QueryNode.

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode Methods

The methods of the QueryNode class are listed below. For a complete list of QueryNode class members, see the QueryNode Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.QueryNode.

Public Instance Methods

AppendQueryNode | A convenience method to add a QueryNode at the end of the list.
AppendQueryPart | A convenience method to add a QueryParts at the end of the list.
ClearQueryNodes | A convenience method to remove all query parts.
ClearQueryParts | A convenience method to remove all query parts.
CopyQueryNode | Returns a deep copy of this QueryNode.
Equals | Delegate Equals() to com.starbase.starteam.QueryNode.
Evaluate | Evaluate this QueryPart with respect to the specified item.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.QueryNode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToDebugStringDepth | Returns a String with debug information about this QueryNode. You can specify the current indentation depth to use.
ToString | Delegate ToString() to com.starbase.starteam.QueryNode.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.AppendQueryNode Method

A convenience method to add a QueryNode at the end of the list.

public virtual void AppendQueryNode(
QueryNode node
);

Parameters

node
the QueryNode to append.

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.AppendQueryPart Method

A convenience method to add a QueryParts at the end of the list.

public virtual void AppendQueryPart(
QueryPart part
);

Parameters

part
the QueryPart to append

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.QueryNode

Implements

IWrapper.Unwrap

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.ClearQueryNodes Method

A convenience method to remove all query parts.

public virtual void ClearQueryNodes();

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.ClearQueryParts Method

A convenience method to remove all query parts.

public virtual void ClearQueryParts();

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.CopyQueryNode Method

Returns a deep copy of this QueryNode.

public virtual QueryNode CopyQueryNode();

Return Value

a deep copy of this QueryNode

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.Equals Method

Delegate Equals() to com.starbase.starteam.QueryNode.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.QueryNode.Equals(obj).

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.Evaluate Method

Evaluate this QueryPart with respect to the specified item.

public virtual bool Evaluate(
Item item
);

Parameters

item
the item whose specified property value to test against

Return Value

true if the item satisfies the query and false otherwise.

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.QueryNode.

public override int GetHashCode();

Return Value

com.starbase.starteam.QueryNode.GetHashCode().

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.ToDebugStringDepth Method

Returns a String with debug information about this QueryNode. You can specify the current indentation depth to use.

public virtual string ToDebugStringDepth(
Int32 depth
);

Parameters

depth

Return Value

a debug string for this QueryNode.

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.ToString Method

Delegate ToString() to com.starbase.starteam.QueryNode.

public override string ToString();

Return Value

com.starbase.starteam.QueryNode.ToString()

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode.Wrap Method

Dynamically wraps com.starbase.starteam.QueryNode.

public static QueryNode Wrap(
QueryNode impl
);

Parameters

impl
com.starbase.starteam.QueryNode to be wrapped.

Return Value

QueryNode

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNode Type Conversions

The type conversions of the QueryNode class are listed below. For a complete list of QueryNode class members, see the QueryNode Members topic.

Public Static Type Conversions

Implicit QueryNode to QueryNode Conversion Implicitly convert QueryNode to com.starbase.starteam.QueryNode.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

QueryNode Class | QueryNode Members | Borland.StarTeam Namespace


QueryNode Implicit QueryNode to QueryNode Conversion

Implicitly convert QueryNode to com.starbase.starteam.QueryNode.

public static implicit operator QueryNode(
QueryNode arg
);

Parameters

arg
QueryNode to convert.

Return Value

com.starbase.starteam.QueryNode

See Also

QueryNode Class | Borland.StarTeam Namespace


QueryNodeCollection Class

A strongly-typed collection of QueryNodes.

For a list of all members of this type, see QueryNodeCollection Members.

System.Object
ArrayAdapter
QueryNodeCollection

public class QueryNodeCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

QueryNodeCollection Members | Borland.StarTeam Namespace


QueryNodeCollection Members

QueryNodeCollection overview

Public Static Methods

Wrap Creates a QueryNodeCollection to represent the given array of QueryNode (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit QueryNodeCollection to QueryNode[] Conversion | Converts a QueryNodeCollection to an array of QueryNodes.
Implicit QueryNodeCollection to QueryNode[] Conversion | Converts a QueryNodeCollection from the Borland.StarTeam namespace to a QueryNode[] in the com.starbase.starteam namespace.

Public Instance Constructors

QueryNodeCollection Overloaded. Initializes a new instance of the QueryNodeCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the QueryNode at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a QueryNode to end of the collection.
Append | Overloaded. Appends the QueryNodes of the given QueryNodeCollection to the end of this QueryNodeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific QueryNode.
CopyTo | Copies all of the QueryNodes in the QueryNodeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific QueryNode in the collection.
Insert | Inserts a QueryNode into the collection at the specified position.
Remove | Removes the first occurrence of a specific QueryNode from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the QueryNodes in this QueryNodeCollection.
Sort | Sorts the QueryNodes in this QueryNodeCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection Constructor

Initializes an instance of the QueryNodeCollection class.

Overload List

Initializes an instance of the QueryNodeCollection class.

public QueryNodeCollection();

Initializes an instance of the a QueryNodeCollection class, copying the given array.

public QueryNodeCollection(QueryNode[]);

Initializes an instance of the a QueryNodeCollection class, copying the given collection.

public QueryNodeCollection(QueryNodeCollection);

Initializes an instance of the a QueryNodeCollection class, wrapping the given array of QueryNode (from the com.starbase.starteam namespace).

public QueryNodeCollection(QueryNode[]);

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection Constructor ()

Initializes an instance of the QueryNodeCollection class.

public QueryNodeCollection();

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace | QueryNodeCollection Constructor Overload List


QueryNodeCollection Constructor (QueryNode[])

Initializes an instance of the a QueryNodeCollection class, wrapping the given array of QueryNode (from the com.starbase.starteam namespace).

public QueryNodeCollection(
QueryNode[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace | QueryNodeCollection Constructor Overload List | Wrap


QueryNodeCollection Constructor (QueryNodeCollection)

Initializes an instance of the a QueryNodeCollection class, copying the given collection.

public QueryNodeCollection(
QueryNodeCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member QueryNode objects of the original collection are shared, not copied.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace | QueryNodeCollection Constructor Overload List


QueryNodeCollection Constructor (QueryNode[])

Initializes an instance of the a QueryNodeCollection class, copying the given array.

public QueryNodeCollection(
QueryNode[] array
);

Parameters

array
The array to be copied.

Remarks

The member QueryNode objects of the original array are shared, not copied.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace | QueryNodeCollection Constructor Overload List


QueryNodeCollection Properties

The properties of the QueryNodeCollection class are listed below. For a complete list of QueryNodeCollection class members, see the QueryNodeCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the QueryNode at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

QueryNodeCollection.Item Property

Gets or sets the QueryNode at the specified index.

public QueryNode this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the QueryNode to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection Methods

The methods of the QueryNodeCollection class are listed below. For a complete list of QueryNodeCollection class members, see the QueryNodeCollection Members topic.

Public Static Methods

Wrap Creates a QueryNodeCollection to represent the given array of QueryNode (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a QueryNode to end of the collection.
Append | Overloaded. Appends the QueryNodes of the given QueryNodeCollection to the end of this QueryNodeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific QueryNode.
CopyTo | Copies all of the QueryNodes in the QueryNodeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific QueryNode in the collection.
Insert | Inserts a QueryNode into the collection at the specified position.
Remove | Removes the first occurrence of a specific QueryNode from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the QueryNodes in this QueryNodeCollection.
Sort | Sorts the QueryNodes in this QueryNodeCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection.Add Method

Adds a QueryNode to end of the collection.

public int Add(
QueryNode value
);

Parameters

value
The QueryNode to add to the collection.

Return Value

The position into which the new QueryNode was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

QueryNodeCollection.Append Method

Appends the QueryNodes of the given array to the end of this QueryNodeCollection.

Overload List

Appends the QueryNodes of the given array to the end of this QueryNodeCollection.

public QueryNodeCollection Append(QueryNode[]);

Appends the QueryNodes of the given QueryNodeCollection to the end of this QueryNodeCollection.

public QueryNodeCollection Append(QueryNodeCollection);

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection.Append Method (QueryNode[])

Appends the QueryNodes of the given array to the end of this QueryNodeCollection.

public QueryNodeCollection Append(
QueryNode[] array
);

Parameters

array
The array whose QueryNodes are to be appended to this QueryNodeCollection.

Return Value

This QueryNodeCollection, modified to include the new QueryNodes.

Remarks

The QueryNodeCollection is modified to include the new members. The individual QueryNode objects are shared, not copied.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace | QueryNodeCollection.Append Overload List


QueryNodeCollection.Append Method (QueryNodeCollection)

Appends the QueryNodes of the given QueryNodeCollection to the end of this QueryNodeCollection.

public QueryNodeCollection Append(
QueryNodeCollection collection
);

Parameters

collection
The QueryNodeCollection whose QueryNodes are to be appended to this QueryNodeCollection.

Return Value

This QueryNodeCollection, modified to include the new QueryNodes.

Remarks

The QueryNodeCollection is modified to include the new members. The individual QueryNode objects are shared, not copied.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace | QueryNodeCollection.Append Overload List


QueryNodeCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.QueryNode[].

Implements

IWrapper.Unwrap

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection.Contains Method

Determines whether or not the collection contains a specific QueryNode.

public bool Contains(
QueryNode value
);

Parameters

value
The QueryNode to locate in the collection.

Return Value

true if the QueryNode is found in the collection; otherwise, false.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection.CopyTo Method

Copies all of the QueryNodes in the QueryNodeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
QueryNode[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the QueryNodes copied from the QueryNodeCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of QueryNodes in the source QueryNodeCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source QueryNodeCollection cannot be cast automatically to the type of the destination array.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection.IndexOf Method

Determines the index of a specific QueryNode in the collection.

public int IndexOf(
QueryNode value
);

Parameters

value
The QueryNode to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection.Insert Method

Inserts a QueryNode into the collection at the specified position.

public void Insert(
Int32 index,
QueryNode value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The QueryNode to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection.Remove Method

Removes the first occurrence of a specific QueryNode from the collection.

public void Remove(
QueryNode value
);

Parameters

value
The QueryNode to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection.Reverse Method

Reverses the order of the QueryNodes in this QueryNodeCollection.

new public QueryNodeCollection Reverse();

Return Value

This QueryNodeCollection, modified such that the QueryNodes are reversed.

Remarks

The QueryNodeCollection is modified in place.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection.Sort Method

Sorts the QueryNodes in this QueryNodeCollection, using the given comparer.

new public QueryNodeCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two QueryNodes.

Return Value

This QueryNodeCollection, modified such that the QueryNodes are sorted.

Remarks

The QueryNodeCollection is modified in place.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection.Wrap Method

Creates a QueryNodeCollection to represent the given array of QueryNode (from the com.starbase.starteam namespace).

public static QueryNodeCollection Wrap(
QueryNode[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new QueryNodeCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a QueryNode[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection Type Conversions

The type conversions of the QueryNodeCollection class are listed below. For a complete list of QueryNodeCollection class members, see the QueryNodeCollection Members topic.

Public Static Type Conversions

Implicit QueryNodeCollection to QueryNode[] Conversion | Converts a QueryNodeCollection to an array of QueryNodes.
Implicit QueryNodeCollection to QueryNode[] Conversion | Converts a QueryNodeCollection from the Borland.StarTeam namespace to a QueryNode[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryNodeCollection Class | QueryNodeCollection Members | Borland.StarTeam Namespace


QueryNodeCollection Implicit QueryNodeCollection to QueryNode[] Conversion

Converts a QueryNodeCollection to an array of QueryNodes.

public static implicit operator QueryNode[](
QueryNodeCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new QueryNode wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one QueryNode wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryNodeCollection Implicit QueryNodeCollection to QueryNode[] Conversion

Converts a QueryNodeCollection from the Borland.StarTeam namespace to a QueryNode[] in the com.starbase.starteam namespace.

public static implicit operator QueryNode[](
QueryNodeCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, QueryNodeCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

QueryNodeCollection Class | Borland.StarTeam Namespace


QueryPart Class

A QueryPart object represents a boolean expression on the value of a particular property of an item. For example, it could be used to define query to match file objects whose name starts with a specific string.

For a list of all members of this type, see QueryPart Members.

System.Object
QueryPart

public class QueryPart : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

QueryPart Members | Borland.StarTeam Namespace


QueryPart Members

QueryPart overview

Public Static Properties

REL_ENDTEXT
REL_EQUAL
REL_GREATEROREQUAL
REL_GREATERTHAN
REL_LASTDAYS
REL_LASTWEEKS
REL_LESSOREQUAL
REL_LESSTHAN
REL_NOTEQUAL
REL_OLDERDAYS
REL_OLDERWEEKS
REL_STARTTEXT
REL_TEXTSEARCH

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.QueryPart.

Public Static Type Conversions

Implicit QueryPart to QueryPart Conversion Implicitly convert QueryPart to com.starbase.starteam.QueryPart.

Public Instance Constructors

QueryPart Overloaded. Initializes a new instance of the QueryPart class.

Public Instance Properties

DebugString | [read] a debug string representation of this QueryPart.
IsIgnoreCase | [read/write]
IsIgnoreTime | [read/write]
PropertyID | [read/write]
Relation | [read/write]
Value | [read]

Public Instance Methods

CopyQueryPart | Returns a copy of this QueryPart. It is a deep copy so the new one may be freely modified without affecting the original. The copy will be identical but for the ID which will be -1 for the new copy.
Equals | Delegate Equals() to com.starbase.starteam.QueryPart.
Evaluate | Evaluate this QueryPart with respect to the specified item.
EvaluateAgainst | Evaluate this QueryPart with respect to the specified value. The value must be of the appropriate type for the relation type. The possible types are Integer, Double, OLEDate, String, byte[] and int[].
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.QueryPart.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.QueryPart.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart Constructor

Construct QueryPart from com.starbase.starteam.QueryPart.

Overload List

Construct QueryPart from com.starbase.starteam.QueryPart.

public QueryPart(QueryPart);

Creates a new QueryPart for the specified property. The test is for byte array valued properties.

public QueryPart(Int32,Int32,Byte[]);

Creates a new QueryPart for the specified property. The test is for date valued properties.

public QueryPart(Int32,Int32,DateTime,Boolean);

Creates a new QueryPart for the specified property. The test is for byte array valued properties.

public QueryPart(Int32,Int32,Double);

Creates a new QueryPart for the specified property. The test is for date valued properties.

public QueryPart(Int32,Int32,Double,Boolean);

Creates a new QueryPart for the specified property. The test is for byte array valued properties.

public QueryPart(Int32,Int32,Int32);

Creates a new QueryPart for the specified property. The test is for byte array valued properties.

public QueryPart(Int32,Int32,Int32[]);

Creates a new QueryPart for the specified property. The test is for String valued properties.

public QueryPart(Int32,Int32,String,Boolean);

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart Constructor (QueryPart)

Construct QueryPart from com.starbase.starteam.QueryPart.

public QueryPart(
QueryPart impl
);

Parameters

impl
The com.starbase.starteam.QueryPart to be wrapped.

See Also

QueryPart Class | Borland.StarTeam Namespace | QueryPart Constructor Overload List


QueryPart Constructor (Int32, Int32, Int32)

Creates a new QueryPart for the specified property. The test is for byte array valued properties.

public QueryPart(
Int32 propertyID,
Int32 relation,
Int32 value
);

Parameters

propertyID
the property to test
relation
the relation operator defining the comparison test
value
the byte array value to compare against

See Also

QueryPart Class | Borland.StarTeam Namespace | QueryPart Constructor Overload List


QueryPart Constructor (Int32, Int32, Double)

Creates a new QueryPart for the specified property. The test is for byte array valued properties.

public QueryPart(
Int32 propertyID,
Int32 relation,
Double value
);

Parameters

propertyID
the property to test
relation
the relation operator defining the comparison test
value
the byte array value to compare against

See Also

QueryPart Class | Borland.StarTeam Namespace | QueryPart Constructor Overload List


QueryPart Constructor (Int32, Int32, Double, Boolean)

Creates a new QueryPart for the specified property. The test is for date valued properties.

public QueryPart(
Int32 propertyID,
Int32 relation,
Double value,
Boolean ignoreTime
);

Parameters

propertyID
the property to test
relation
the relation operator defining the comparison test
value
the date value to compare against
ignoreTime
true if the comparsion should ignore the time of day (and just use the date)

See Also

QueryPart Class | Borland.StarTeam Namespace | QueryPart Constructor Overload List


QueryPart Constructor (Int32, Int32, DateTime, Boolean)

Creates a new QueryPart for the specified property. The test is for date valued properties.

public QueryPart(
Int32 propertyID,
Int32 relation,
DateTime value,
Boolean ignoreTime
);

Parameters

propertyID
the property to test
relation
the relation operator defining the comparison test
value
the date value to compare against
ignoreTime
true if the comparsion should ignore the time of day (and just use the date)

See Also

QueryPart Class | Borland.StarTeam Namespace | QueryPart Constructor Overload List


QueryPart Constructor (Int32, Int32, String, Boolean)

Creates a new QueryPart for the specified property. The test is for String valued properties.

public QueryPart(
Int32 propertyID,
Int32 relation,
String value,
Boolean caseSensitive
);

Parameters

propertyID
the property to test
relation
the relation operator defining the comparison test
value
the string value to compare against
caseSensitive
true if the comparison should be case-sensitive

See Also

QueryPart Class | Borland.StarTeam Namespace | QueryPart Constructor Overload List


QueryPart Constructor (Int32, Int32, Byte[])

Creates a new QueryPart for the specified property. The test is for byte array valued properties.

public QueryPart(
Int32 propertyID,
Int32 relation,
Byte[] value
);

Parameters

propertyID
the property to test
relation
the relation operator defining the comparison test
value
the byte array value to compare against

See Also

QueryPart Class | Borland.StarTeam Namespace | QueryPart Constructor Overload List


QueryPart Constructor (Int32, Int32, Int32[])

Creates a new QueryPart for the specified property. The test is for byte array valued properties.

public QueryPart(
Int32 propertyID,
Int32 relation,
Int32[] value
);

Parameters

propertyID
the property to test
relation
the relation operator defining the comparison test
value
the byte array value to compare against

See Also

QueryPart Class | Borland.StarTeam Namespace | QueryPart Constructor Overload List


QueryPart Properties

The properties of the QueryPart class are listed below. For a complete list of QueryPart class members, see the QueryPart Members topic.

Public Static Properties

REL_ENDTEXT
REL_EQUAL
REL_GREATEROREQUAL
REL_GREATERTHAN
REL_LASTDAYS
REL_LASTWEEKS
REL_LESSOREQUAL
REL_LESSTHAN
REL_NOTEQUAL
REL_OLDERDAYS
REL_OLDERWEEKS
REL_STARTTEXT
REL_TEXTSEARCH

Public Instance Properties

DebugString | [read] a debug string representation of this QueryPart.
IsIgnoreCase | [read/write]
IsIgnoreTime | [read/write]
PropertyID | [read/write]
Relation | [read/write]
Value | [read]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

QueryPart Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

QueryPart.DebugString Property

[read] a debug string representation of this QueryPart.

public virtual String DebugString {get;}

Property Value

a debug string representation of this QueryPart.

See Also

QueryPart Class | Borland.StarTeam Namespace


IsIgnoreCase Property

Borland StarTeam SDK for .NET

QueryPart.IsIgnoreCase Property

[read/write]

public virtual Boolean IsIgnoreCase {get; set;}

See Also

QueryPart Class | Borland.StarTeam Namespace


IsIgnoreTime Property

Borland StarTeam SDK for .NET

QueryPart.IsIgnoreTime Property

[read/write]

public virtual Boolean IsIgnoreTime {get; set;}

See Also

QueryPart Class | Borland.StarTeam Namespace


PropertyID Property

Borland StarTeam SDK for .NET

QueryPart.PropertyID Property

[read/write]

public virtual Int32 PropertyID {get; set;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_ENDTEXT Property

Borland StarTeam SDK for .NET

QueryPart.REL_ENDTEXT Property

public static Int32 REL_ENDTEXT {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_EQUAL Property

Borland StarTeam SDK for .NET

QueryPart.REL_EQUAL Property

public static Int32 REL_EQUAL {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_GREATEROREQUAL Property

Borland StarTeam SDK for .NET

QueryPart.REL_GREATEROREQUAL Property

public static Int32 REL_GREATEROREQUAL {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_GREATERTHAN Property

Borland StarTeam SDK for .NET

QueryPart.REL_GREATERTHAN Property

public static Int32 REL_GREATERTHAN {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_LASTDAYS Property

Borland StarTeam SDK for .NET

QueryPart.REL_LASTDAYS Property

public static Int32 REL_LASTDAYS {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_LASTWEEKS Property

Borland StarTeam SDK for .NET

QueryPart.REL_LASTWEEKS Property

public static Int32 REL_LASTWEEKS {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_LESSOREQUAL Property

Borland StarTeam SDK for .NET

QueryPart.REL_LESSOREQUAL Property

public static Int32 REL_LESSOREQUAL {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_LESSTHAN Property

Borland StarTeam SDK for .NET

QueryPart.REL_LESSTHAN Property

public static Int32 REL_LESSTHAN {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_NOTEQUAL Property

Borland StarTeam SDK for .NET

QueryPart.REL_NOTEQUAL Property

public static Int32 REL_NOTEQUAL {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_OLDERDAYS Property

Borland StarTeam SDK for .NET

QueryPart.REL_OLDERDAYS Property

public static Int32 REL_OLDERDAYS {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_OLDERWEEKS Property

Borland StarTeam SDK for .NET

QueryPart.REL_OLDERWEEKS Property

public static Int32 REL_OLDERWEEKS {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_STARTTEXT Property

Borland StarTeam SDK for .NET

QueryPart.REL_STARTTEXT Property

public static Int32 REL_STARTTEXT {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


REL_TEXTSEARCH Property

Borland StarTeam SDK for .NET

QueryPart.REL_TEXTSEARCH Property

public static Int32 REL_TEXTSEARCH {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


Relation Property

Borland StarTeam SDK for .NET

QueryPart.Relation Property

[read/write]

public virtual Int32 Relation {get; set;}

See Also

QueryPart Class | Borland.StarTeam Namespace


Value Property

Borland StarTeam SDK for .NET

QueryPart.Value Property

[read]

public virtual Object Value {get;}

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart Methods

The methods of the QueryPart class are listed below. For a complete list of QueryPart class members, see the QueryPart Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.QueryPart.

Public Instance Methods

CopyQueryPart | Returns a copy of this QueryPart. It is a deep copy so the new one may be freely modified without affecting the original. The copy will be identical but for the ID which will be -1 for the new copy.
Equals | Delegate Equals() to com.starbase.starteam.QueryPart.
Evaluate | Evaluate this QueryPart with respect to the specified item.
EvaluateAgainst | Evaluate this QueryPart with respect to the specified value. The value must be of the appropriate type for the relation type. The possible types are Integer, Double, OLEDate, String, byte[] and int[].
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.QueryPart.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.QueryPart.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.QueryPart

Implements

IWrapper.Unwrap

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart.CopyQueryPart Method

Returns a copy of this QueryPart. It is a deep copy so the new one may be freely modified without affecting the original. The copy will be identical but for the ID which will be -1 for the new copy.

public virtual QueryPart CopyQueryPart();

Return Value

a copy of this QueryPart

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart.Equals Method

Delegate Equals() to com.starbase.starteam.QueryPart.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.QueryPart.Equals(obj).

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart.Evaluate Method

Evaluate this QueryPart with respect to the specified item.

public virtual bool Evaluate(
Item item
);

Parameters

item
the item whose specified property value to test against

Return Value

true if the item satisfies the query and false otherwise.

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart.EvaluateAgainst Method

Evaluate this QueryPart with respect to the specified value. The value must be of the appropriate type for the relation type. The possible types are Integer, Double, OLEDate, String, byte[] and int[].

public virtual bool EvaluateAgainst(
Object value
);

Parameters

value
the value to test against

Return Value

true if the item satisfies the query and false otherwise.

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.QueryPart.

public override int GetHashCode();

Return Value

com.starbase.starteam.QueryPart.GetHashCode().

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart.ToString Method

Delegate ToString() to com.starbase.starteam.QueryPart.

public override string ToString();

Return Value

com.starbase.starteam.QueryPart.ToString()

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart.Wrap Method

Dynamically wraps com.starbase.starteam.QueryPart.

public static QueryPart Wrap(
QueryPart impl
);

Parameters

impl
com.starbase.starteam.QueryPart to be wrapped.

Return Value

QueryPart

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPart Type Conversions

The type conversions of the QueryPart class are listed below. For a complete list of QueryPart class members, see the QueryPart Members topic.

Public Static Type Conversions

Implicit QueryPart to QueryPart Conversion Implicitly convert QueryPart to com.starbase.starteam.QueryPart.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

QueryPart Class | QueryPart Members | Borland.StarTeam Namespace


QueryPart Implicit QueryPart to QueryPart Conversion

Implicitly convert QueryPart to com.starbase.starteam.QueryPart.

public static implicit operator QueryPart(
QueryPart arg
);

Parameters

arg
QueryPart to convert.

Return Value

com.starbase.starteam.QueryPart

See Also

QueryPart Class | Borland.StarTeam Namespace


QueryPartCollection Class

A strongly-typed collection of QueryParts.

For a list of all members of this type, see QueryPartCollection Members.

System.Object
ArrayAdapter
QueryPartCollection

public class QueryPartCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

QueryPartCollection Members | Borland.StarTeam Namespace


QueryPartCollection Members

QueryPartCollection overview

Public Static Methods

Wrap Creates a QueryPartCollection to represent the given array of QueryPart (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit QueryPartCollection to QueryPart[] Conversion | Converts a QueryPartCollection to an array of QueryParts.
Implicit QueryPartCollection to QueryPart[] Conversion | Converts a QueryPartCollection from the Borland.StarTeam namespace to a QueryPart[] in the com.starbase.starteam namespace.

Public Instance Constructors

QueryPartCollection Overloaded. Initializes a new instance of the QueryPartCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the QueryPart at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a QueryPart to end of the collection.
Append | Overloaded. Appends the QueryParts of the given QueryPartCollection to the end of this QueryPartCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific QueryPart.
CopyTo | Copies all of the QueryParts in the QueryPartCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific QueryPart in the collection.
Insert | Inserts a QueryPart into the collection at the specified position.
Remove | Removes the first occurrence of a specific QueryPart from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the QueryParts in this QueryPartCollection.
Sort | Sorts the QueryParts in this QueryPartCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection Constructor

Initializes an instance of the QueryPartCollection class.

Overload List

Initializes an instance of the QueryPartCollection class.

public QueryPartCollection();

Initializes an instance of the a QueryPartCollection class, copying the given array.

public QueryPartCollection(QueryPart[]);

Initializes an instance of the a QueryPartCollection class, copying the given collection.

public QueryPartCollection(QueryPartCollection);

Initializes an instance of the a QueryPartCollection class, wrapping the given array of QueryPart (from the com.starbase.starteam namespace).

public QueryPartCollection(QueryPart[]);

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection Constructor ()

Initializes an instance of the QueryPartCollection class.

public QueryPartCollection();

See Also

QueryPartCollection Class | Borland.StarTeam Namespace | QueryPartCollection Constructor Overload List


QueryPartCollection Constructor (QueryPart[])

Initializes an instance of the a QueryPartCollection class, wrapping the given array of QueryPart (from the com.starbase.starteam namespace).

public QueryPartCollection(
QueryPart[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace | QueryPartCollection Constructor Overload List | Wrap


QueryPartCollection Constructor (QueryPartCollection)

Initializes an instance of the a QueryPartCollection class, copying the given collection.

public QueryPartCollection(
QueryPartCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member QueryPart objects of the original collection are shared, not copied.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace | QueryPartCollection Constructor Overload List


QueryPartCollection Constructor (QueryPart[])

Initializes an instance of the a QueryPartCollection class, copying the given array.

public QueryPartCollection(
QueryPart[] array
);

Parameters

array
The array to be copied.

Remarks

The member QueryPart objects of the original array are shared, not copied.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace | QueryPartCollection Constructor Overload List


QueryPartCollection Properties

The properties of the QueryPartCollection class are listed below. For a complete list of QueryPartCollection class members, see the QueryPartCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the QueryPart at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

QueryPartCollection.Item Property

Gets or sets the QueryPart at the specified index.

public QueryPart this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the QueryPart to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection Methods

The methods of the QueryPartCollection class are listed below. For a complete list of QueryPartCollection class members, see the QueryPartCollection Members topic.

Public Static Methods

Wrap Creates a QueryPartCollection to represent the given array of QueryPart (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a QueryPart to end of the collection.
Append | Overloaded. Appends the QueryParts of the given QueryPartCollection to the end of this QueryPartCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific QueryPart.
CopyTo | Copies all of the QueryParts in the QueryPartCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific QueryPart in the collection.
Insert | Inserts a QueryPart into the collection at the specified position.
Remove | Removes the first occurrence of a specific QueryPart from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the QueryParts in this QueryPartCollection.
Sort | Sorts the QueryParts in this QueryPartCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection.Add Method

Adds a QueryPart to end of the collection.

public int Add(
QueryPart value
);

Parameters

value
The QueryPart to add to the collection.

Return Value

The position into which the new QueryPart was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

QueryPartCollection.Append Method

Appends the QueryParts of the given array to the end of this QueryPartCollection.

Overload List

Appends the QueryParts of the given array to the end of this QueryPartCollection.

public QueryPartCollection Append(QueryPart[]);

Appends the QueryParts of the given QueryPartCollection to the end of this QueryPartCollection.

public QueryPartCollection Append(QueryPartCollection);

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection.Append Method (QueryPart[])

Appends the QueryParts of the given array to the end of this QueryPartCollection.

public QueryPartCollection Append(
QueryPart[] array
);

Parameters

array
The array whose QueryParts are to be appended to this QueryPartCollection.

Return Value

This QueryPartCollection, modified to include the new QueryParts.

Remarks

The QueryPartCollection is modified to include the new members. The individual QueryPart objects are shared, not copied.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace | QueryPartCollection.Append Overload List


QueryPartCollection.Append Method (QueryPartCollection)

Appends the QueryParts of the given QueryPartCollection to the end of this QueryPartCollection.

public QueryPartCollection Append(
QueryPartCollection collection
);

Parameters

collection
The QueryPartCollection whose QueryParts are to be appended to this QueryPartCollection.

Return Value

This QueryPartCollection, modified to include the new QueryParts.

Remarks

The QueryPartCollection is modified to include the new members. The individual QueryPart objects are shared, not copied.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace | QueryPartCollection.Append Overload List


QueryPartCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.QueryPart[].

Implements

IWrapper.Unwrap

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection.Contains Method

Determines whether or not the collection contains a specific QueryPart.

public bool Contains(
QueryPart value
);

Parameters

value
The QueryPart to locate in the collection.

Return Value

true if the QueryPart is found in the collection; otherwise, false.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection.CopyTo Method

Copies all of the QueryParts in the QueryPartCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
QueryPart[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the QueryParts copied from the QueryPartCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of QueryParts in the source QueryPartCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source QueryPartCollection cannot be cast automatically to the type of the destination array.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection.IndexOf Method

Determines the index of a specific QueryPart in the collection.

public int IndexOf(
QueryPart value
);

Parameters

value
The QueryPart to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection.Insert Method

Inserts a QueryPart into the collection at the specified position.

public void Insert(
Int32 index,
QueryPart value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The QueryPart to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection.Remove Method

Removes the first occurrence of a specific QueryPart from the collection.

public void Remove(
QueryPart value
);

Parameters

value
The QueryPart to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection.Reverse Method

Reverses the order of the QueryParts in this QueryPartCollection.

new public QueryPartCollection Reverse();

Return Value

This QueryPartCollection, modified such that the QueryParts are reversed.

Remarks

The QueryPartCollection is modified in place.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection.Sort Method

Sorts the QueryParts in this QueryPartCollection, using the given comparer.

new public QueryPartCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two QueryParts.

Return Value

This QueryPartCollection, modified such that the QueryParts are sorted.

Remarks

The QueryPartCollection is modified in place.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection.Wrap Method

Creates a QueryPartCollection to represent the given array of QueryPart (from the com.starbase.starteam namespace).

public static QueryPartCollection Wrap(
QueryPart[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new QueryPartCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a QueryPart[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection Type Conversions

The type conversions of the QueryPartCollection class are listed below. For a complete list of QueryPartCollection class members, see the QueryPartCollection Members topic.

Public Static Type Conversions

Implicit QueryPartCollection to QueryPart[] Conversion | Converts a QueryPartCollection to an array of QueryParts.
Implicit QueryPartCollection to QueryPart[] Conversion | Converts a QueryPartCollection from the Borland.StarTeam namespace to a QueryPart[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

QueryPartCollection Class | QueryPartCollection Members | Borland.StarTeam Namespace


QueryPartCollection Implicit QueryPartCollection to QueryPart[] Conversion

Converts a QueryPartCollection to an array of QueryParts.

public static implicit operator QueryPart[](
QueryPartCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new QueryPart wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one QueryPart wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


QueryPartCollection Implicit QueryPartCollection to QueryPart[] Conversion

Converts a QueryPartCollection from the Borland.StarTeam namespace to a QueryPart[] in the com.starbase.starteam namespace.

public static implicit operator QueryPart[](
QueryPartCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, QueryPartCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

QueryPartCollection Class | Borland.StarTeam Namespace


RecycleBin Class

For a list of all members of this type, see RecycleBin Members.

System.Object
TypedResource
SimpleTypedResource
View
RecycleBin

public class RecycleBin : View

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

RecycleBin Members | Borland.StarTeam Namespace


RecycleBin Members

RecycleBin overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.RecycleBin.

Public Static Type Conversions

Implicit RecycleBin to RecycleBin Conversion Implicitly convert RecycleBin to com.starbase.starteam.RecycleBin.

Public Instance Constructors

RecycleBin Constructor Construct RecycleBin from com.starbase.starteam.RecycleBin.

Public Instance Properties

ACL (inherited from View) |
ActiveLabels (inherited from View) | [read] The active (non-deleted) labels for this view.
AlternatePath (inherited from View) | [read/write] the alternate working file path to be used for this view.
BaseConfiguration (inherited from View) | [read] the ViewConfiguration from which this View was derived.
Configuration (inherited from View) | [read] this view's configuration.
CreatedBy (inherited from View) | [read] the user ID of the user that created the view.
CreatedTime (inherited from View) | [read] the time at which the view was created.
DefaultPath (inherited from View) | [read/write] the default working file path to be used for this view.
DeletedAsOf | [read/write] The deletion time. Only folders and/or item deleted after this time are included. Default value is null, indicating that all deleted folders and/or items are included.
DerivedViews (inherited from View) | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description (inherited from View) | [read/write] the description of this view.
FileStatusManager (inherited from View) | [read] The FileBasedStatusManager for this View.
FullName (inherited from View) | [read] the full hierarchical name of this view.
HaveAccessRights (inherited from View) | [read] true if the logged on user has rights to access this view.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IncludeActiveItems | [read/write] true if the resulting folders may contain active items; false if they may contain only deleted items. Default value is false. At least one of IncludeDeletedItems and IncludeActiveItems is always set.
IncludeDeletedFolders | [read/write] true if deleted folders are included in the folder tree; false if only active folders are included. Default value is true.
IncludeDeletedItems | [read/write] true if the resulting folders may contain deleted items; false if they may contain only active items. Default value is true. At least one of IncludeDeletedItems and IncludeActiveItems is always set.
IsAccessible (inherited from View) | [read] true if the logged on user has access to this view.
IsBranch (inherited from View) | [read] true if this view is a Branch view.
IsBranchAll (inherited from View) | [read] true if this view's original branching default was set "All".
IsBranchNone (inherited from View) | [read] true if this view's original branching default was set "None".
IsBranchOnShare (inherited from View) | [read/write] true if this view is set to branch shared items.
IsDeleted (inherited from View) | [read] True if the view has been deleted from the server; false otherwise.
IsNonDerived (inherited from View) | [read] true if this view is Non-Derived view.
IsReadOnly (inherited from View) | [read] true if this view is ReadOnly, otherwise false.
IsReference (inherited from View) | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired (inherited from View) | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired (inherited from View) | [read] true if folder information may be out of date.
IsRefreshLabelsRequired (inherited from View) | [read] true if label information may be out of date.
IsRefreshRequired (inherited from View) | [read] true if view properties may be out of date.
IsRoot (inherited from View) | [read] true if this view is a Root view.
Item (inherited from TypedResource) |
Labels (inherited from View) | [read] The labels (both active and deleted) that exist in this view.
Name (inherited from View) | [read/write] the name of this view.
Owner (inherited from View) |
ParentContainer (inherited from View) |
ParentView (inherited from View) | [read] the parent of this view, or null if there is no parent.
Path (inherited from View) | [read] the working file path being used for this view.
Project (inherited from View) | [read] the project to which this view belongs.
PromotionModel (inherited from View) | [read] the promotion model associated with this view.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
RecycleBin (inherited from View) | [read] The recycle bin associated with this view.
RootFolder (inherited from View) | [read] The root folder of this view.
Server (inherited from View) | [read] the server to which this view belongs.
StatusMethodOverride (inherited from View) | [read/write]
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
ViewID (inherited from View) | [read] the unique integer identifier for this view.

Public Instance Methods

AcquireOwnership (inherited from View) |
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
CloneRevisionLabel (inherited from View) | Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed.
CloneViewLabel (inherited from View) | Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed.
Close (inherited from View) | Frees all cached resources associated with this view, and closes the associated view session. Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
Copy (inherited from View) | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
CreateCheckinManager (inherited from View) | Overloaded. Constructs a CheckinManager with default options for this view.
CreateCheckoutManager (inherited from View) | Overloaded. Constructs a CheckoutManager with default options for this view.
CreateChildViewShareAllItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.
CreateChildViewShareDefaultItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.
CreateChildViewShareNoItems (inherited from View) | Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.
CreateChildViewShareTheseItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.
CreateRevisionLabel (inherited from View) | Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
CreateViewLabel (inherited from View) | Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
Discard (inherited from View) | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardActiveLabels (inherited from View) | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
DiscardFolders (inherited from View) | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardLabels (inherited from View) | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
FetchAllLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
FetchAllLabelsFromView (inherited from View) | Returns all the active (non-deleted) labels for the given project and view. This method is only available for 4.1 and later servers. The labels are not cached. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. fetchAllLabelsFromView() is not MPX-enabled; the labels are always retrieved directly from the repository.
FindFolder (inherited from View) | Returns a Folder in the View, given its Item ID, or NULL if none found.
FindItem (inherited from View) | Returns an Item in the View, given its Type and Item ID, or NULL if none found.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetContainerLevelACL (inherited from View) |
GetDisembodiedItem (inherited from View) | Retrieves an Item by Item ID. The Item can reside anywhere in this view, or in any other view on the same server. However, the resulting Item is "disembodied"; that is, it is not attached to its normal parent Folder. Disembodied Items are useful for resolving LinkEndpoints, which can cross project and view boundaries. However, many normal Item operations are not supported for disembodied items. getDisembodiedItem() is not MPX-enabled; each call to getDisembodiedItem() retrieves data directly from the server.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetHistoryForItemID (inherited from View) | Returns "disembodied" Items from the item history
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetNewNotificationItems (inherited from View) | Return the list of "notification" items for the specified type. This method will not return null but may return an empty list. Once this call has been made to the server for a particular view subsequent calls will not return the same information. The act of getting the information "clears" it from the server.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasNewNotificationItems (inherited from View) | Return true if any new notification items are available in this view for the specified item type.
HasPermission (inherited from View) | Overloaded.
IsEqualTo (inherited from View) | Compares the properties of two Views.
ModifyItemsFlagForUser (inherited from View) | Modifies this items flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyItemsReadStatusForUser (inherited from View) | Modifies this list of item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File items.
NewFolderEventSource (inherited from View) |
NewFolderTreeEventSource (inherited from View) |
NewFolderUpdateEventSource (inherited from View) |
NewItemEventSource (inherited from View) | Overloaded.
NewItemIDEventSource (inherited from View) | Overloaded.
NewItemListEventSource (inherited from View) | Overloaded.
NewItemUpdateEventSource (inherited from View) |
NewLabelEventSource (inherited from View) |
NewNotificationEventSource (inherited from View) | Overloaded.
NewViewEventSource (inherited from View) |
Populate (inherited from View) | Populates project properties, if they have not already been populated.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
Refresh (inherited from View) | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshActiveLabels (inherited from View) | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
RefreshFolders (inherited from View) | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
RefreshLabels (inherited from View) | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
RefreshPromotionModel (inherited from View) | Refreshes the local cached information about this view's promotion model.
Remove (inherited from View) | Removes the view from the server.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveLinkEndpoint (inherited from View) | Returns the item in this view referred to by the LinkEndpoint. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
SetContainerLevelACL (inherited from View) |
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Update (inherited from View) | Persists this view's properties to its Server.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

RecycleBin Class | Borland.StarTeam Namespace


RecycleBin Constructor

Construct RecycleBin from com.starbase.starteam.RecycleBin.

public RecycleBin(
RecycleBin impl
);

Parameters

impl
The com.starbase.starteam.RecycleBin to be wrapped.

See Also

RecycleBin Class | Borland.StarTeam Namespace


RecycleBin Properties

The properties of the RecycleBin class are listed below. For a complete list of RecycleBin class members, see the RecycleBin Members topic.

Public Instance Properties

ACL (inherited from View) |
ActiveLabels (inherited from View) | [read] The active (non-deleted) labels for this view.
AlternatePath (inherited from View) | [read/write] the alternate working file path to be used for this view.
BaseConfiguration (inherited from View) | [read] the ViewConfiguration from which this View was derived.
Configuration (inherited from View) | [read] this view's configuration.
CreatedBy (inherited from View) | [read] the user ID of the user that created the view.
CreatedTime (inherited from View) | [read] the time at which the view was created.
DefaultPath (inherited from View) | [read/write] the default working file path to be used for this view.
DeletedAsOf | [read/write] The deletion time. Only folders and/or item deleted after this time are included. Default value is null, indicating that all deleted folders and/or items are included.
DerivedViews (inherited from View) | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description (inherited from View) | [read/write] the description of this view.
FileStatusManager (inherited from View) | [read] The FileBasedStatusManager for this View.
FullName (inherited from View) | [read] the full hierarchical name of this view.
HaveAccessRights (inherited from View) | [read] true if the logged on user has rights to access this view.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IncludeActiveItems | [read/write] true if the resulting folders may contain active items; false if they may contain only deleted items. Default value is false. At least one of IncludeDeletedItems and IncludeActiveItems is always set.
IncludeDeletedFolders | [read/write] true if deleted folders are included in the folder tree; false if only active folders are included. Default value is true.
IncludeDeletedItems | [read/write] true if the resulting folders may contain deleted items; false if they may contain only active items. Default value is true. At least one of IncludeDeletedItems and IncludeActiveItems is always set.
IsAccessible (inherited from View) | [read] true if the logged on user has access to this view.
IsBranch (inherited from View) | [read] true if this view is a Branch view.
IsBranchAll (inherited from View) | [read] true if this view's original branching default was set "All".
IsBranchNone (inherited from View) | [read] true if this view's original branching default was set "None".
IsBranchOnShare (inherited from View) | [read/write] true if this view is set to branch shared items.
IsDeleted (inherited from View) | [read] True if the view has been deleted from the server; false otherwise.
IsNonDerived (inherited from View) | [read] true if this view is Non-Derived view.
IsReadOnly (inherited from View) | [read] true if this view is ReadOnly, otherwise false.
IsReference (inherited from View) | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired (inherited from View) | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired (inherited from View) | [read] true if folder information may be out of date.
IsRefreshLabelsRequired (inherited from View) | [read] true if label information may be out of date.
IsRefreshRequired (inherited from View) | [read] true if view properties may be out of date.
IsRoot (inherited from View) | [read] true if this view is a Root view.
Item (inherited from TypedResource) |
Labels (inherited from View) | [read] The labels (both active and deleted) that exist in this view.
Name (inherited from View) | [read/write] the name of this view.
Owner (inherited from View) |
ParentContainer (inherited from View) |
ParentView (inherited from View) | [read] the parent of this view, or null if there is no parent.
Path (inherited from View) | [read] the working file path being used for this view.
Project (inherited from View) | [read] the project to which this view belongs.
PromotionModel (inherited from View) | [read] the promotion model associated with this view.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
RecycleBin (inherited from View) | [read] The recycle bin associated with this view.
RootFolder (inherited from View) | [read] The root folder of this view.
Server (inherited from View) | [read] the server to which this view belongs.
StatusMethodOverride (inherited from View) | [read/write]
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
ViewID (inherited from View) | [read] the unique integer identifier for this view.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

RecycleBin Class | Borland.StarTeam Namespace


DeletedAsOf Property

Borland StarTeam SDK for .NET

RecycleBin.DeletedAsOf Property

[read/write] The deletion time. Only folders and/or item deleted after this time are included. Default value is null, indicating that all deleted folders and/or items are included.

public virtual DateTime DeletedAsOf {get; set;}

Property Value

The deletion time. Only folders and/or item deleted after this time are included. Default value is null, indicating that all deleted folders and/or items are included.

See Also

RecycleBin Class | Borland.StarTeam Namespace


IncludeActiveItems Property

Borland StarTeam SDK for .NET

RecycleBin.IncludeActiveItems Property

[read/write] true if the resulting folders may contain active items; false if they may contain only deleted items. Default value is false. At least one of IncludeDeletedItems and IncludeActiveItems is always set.

public virtual Boolean IncludeActiveItems {get; set;}

Property Value

true if the resulting folders may contain active items; false if they may contain only deleted items. Default value is false. At least one of IncludeDeletedItems and IncludeActiveItems is always set.

See Also

RecycleBin Class | Borland.StarTeam Namespace


IncludeDeletedFolders Property

Borland StarTeam SDK for .NET

RecycleBin.IncludeDeletedFolders Property

[read/write] true if deleted folders are included in the folder tree; false if only active folders are included. Default value is true.

public virtual Boolean IncludeDeletedFolders {get; set;}

Property Value

true if deleted folders are included in the folder tree; false if only active folders are included. Default value is true.

See Also

RecycleBin Class | Borland.StarTeam Namespace


IncludeDeletedItems Property

Borland StarTeam SDK for .NET

RecycleBin.IncludeDeletedItems Property

[read/write] true if the resulting folders may contain deleted items; false if they may contain only active items. Default value is true. At least one of IncludeDeletedItems and IncludeActiveItems is always set.

public virtual Boolean IncludeDeletedItems {get; set;}

Property Value

true if the resulting folders may contain deleted items; false if they may contain only active items. Default value is true. At least one of IncludeDeletedItems and IncludeActiveItems is always set.

See Also

RecycleBin Class | Borland.StarTeam Namespace


RecycleBin Methods

The methods of the RecycleBin class are listed below. For a complete list of RecycleBin class members, see the RecycleBin Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.RecycleBin.

Public Instance Methods

AcquireOwnership (inherited from View) |
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
CloneRevisionLabel (inherited from View) | Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed.
CloneViewLabel (inherited from View) | Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed.
Close (inherited from View) | Frees all cached resources associated with this view, and closes the associated view session. Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
Copy (inherited from View) | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
CreateCheckinManager (inherited from View) | Overloaded. Constructs a CheckinManager with default options for this view.
CreateCheckoutManager (inherited from View) | Overloaded. Constructs a CheckoutManager with default options for this view.
CreateChildViewShareAllItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.
CreateChildViewShareDefaultItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.
CreateChildViewShareNoItems (inherited from View) | Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.
CreateChildViewShareTheseItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.
CreateRevisionLabel (inherited from View) | Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
CreateViewLabel (inherited from View) | Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
Discard (inherited from View) | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardActiveLabels (inherited from View) | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
DiscardFolders (inherited from View) | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardLabels (inherited from View) | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
FetchAllLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
FetchAllLabelsFromView (inherited from View) | Returns all the active (non-deleted) labels for the given project and view. This method is only available for 4.1 and later servers. The labels are not cached. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. fetchAllLabelsFromView() is not MPX-enabled; the labels are always retrieved directly from the repository.
FindFolder (inherited from View) | Returns a Folder in the View, given its Item ID, or NULL if none found.
FindItem (inherited from View) | Returns an Item in the View, given its Type and Item ID, or NULL if none found.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetContainerLevelACL (inherited from View) |
GetDisembodiedItem (inherited from View) | Retrieves an Item by Item ID. The Item can reside anywhere in this view, or in any other view on the same server. However, the resulting Item is "disembodied"; that is, it is not attached to its normal parent Folder. Disembodied Items are useful for resolving LinkEndpoints, which can cross project and view boundaries. However, many normal Item operations are not supported for disembodied items. getDisembodiedItem() is not MPX-enabled; each call to getDisembodiedItem() retrieves data directly from the server.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetHistoryForItemID (inherited from View) | Returns "disembodied" Items from the item history
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetNewNotificationItems (inherited from View) | Return the list of "notification" items for the specified type. This method will not return null but may return an empty list. Once this call has been made to the server for a particular view subsequent calls will not return the same information. The act of getting the information "clears" it from the server.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasNewNotificationItems (inherited from View) | Return true if any new notification items are available in this view for the specified item type.
HasPermission (inherited from View) | Overloaded.
IsEqualTo (inherited from View) | Compares the properties of two Views.
ModifyItemsFlagForUser (inherited from View) | Modifies this items flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyItemsReadStatusForUser (inherited from View) | Modifies this list of item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File items.
NewFolderEventSource (inherited from View) |
NewFolderTreeEventSource (inherited from View) |
NewFolderUpdateEventSource (inherited from View) |
NewItemEventSource (inherited from View) | Overloaded.
NewItemIDEventSource (inherited from View) | Overloaded.
NewItemListEventSource (inherited from View) | Overloaded.
NewItemUpdateEventSource (inherited from View) |
NewLabelEventSource (inherited from View) |
NewNotificationEventSource (inherited from View) | Overloaded.
NewViewEventSource (inherited from View) |
Populate (inherited from View) | Populates project properties, if they have not already been populated.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
Refresh (inherited from View) | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshActiveLabels (inherited from View) | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
RefreshFolders (inherited from View) | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
RefreshLabels (inherited from View) | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
RefreshPromotionModel (inherited from View) | Refreshes the local cached information about this view's promotion model.
Remove (inherited from View) | Removes the view from the server.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveLinkEndpoint (inherited from View) | Returns the item in this view referred to by the LinkEndpoint. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
SetContainerLevelACL (inherited from View) |
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Update (inherited from View) | Persists this view's properties to its Server.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

RecycleBin Class | Borland.StarTeam Namespace


RecycleBin.Wrap Method

Dynamically wraps com.starbase.starteam.RecycleBin.

public static RecycleBin Wrap(
RecycleBin impl
);

Parameters

impl
com.starbase.starteam.RecycleBin to be wrapped.

Return Value

RecycleBin

See Also

RecycleBin Class | Borland.StarTeam Namespace


RecycleBin Type Conversions

The type conversions of the RecycleBin class are listed below. For a complete list of RecycleBin class members, see the RecycleBin Members topic.

Public Static Type Conversions

Implicit RecycleBin to RecycleBin Conversion Implicitly convert RecycleBin to com.starbase.starteam.RecycleBin.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

RecycleBin Class | RecycleBin Members | Borland.StarTeam Namespace


RecycleBin Implicit RecycleBin to RecycleBin Conversion

Implicitly convert RecycleBin to com.starbase.starteam.RecycleBin.

public static implicit operator RecycleBin(
RecycleBin arg
);

Parameters

arg
RecycleBin to convert.

Return Value

com.starbase.starteam.RecycleBin

See Also

RecycleBin Class | Borland.StarTeam Namespace


RevisionID Class

A simple class representing a unique revision of an Item in the repository. For items of the same type revisions can be uniquely int a repository byte the item's objectID and revision number.

For a list of all members of this type, see RevisionID Members.

System.Object
RevisionID

public class RevisionID : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

RevisionID Members | Borland.StarTeam Namespace


RevisionID Members

RevisionID overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.RevisionID.

Public Static Type Conversions

Implicit RevisionID to RevisionID Conversion Implicitly convert RevisionID to com.starbase.starteam.RevisionID.

Public Instance Constructors

RevisionID Overloaded. Initializes a new instance of the RevisionID class.

Public Instance Properties

IsTip | [read] true if the revision identifier represents the "tip" revision of a branch.
ObjectID | [read/write] the revision identifier's object ID.
Revision | [read/write] the revision identifier's revision number.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.RevisionID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.RevisionID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.RevisionID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

RevisionID Class | Borland.StarTeam Namespace


RevisionID Constructor

Construct RevisionID from com.starbase.starteam.RevisionID.

Overload List

Construct RevisionID from com.starbase.starteam.RevisionID.

public RevisionID(RevisionID);

Create a new RevisionID based on the specified object ID and revision number.

public RevisionID(Int32,Int32);

See Also

RevisionID Class | Borland.StarTeam Namespace


RevisionID Constructor (RevisionID)

Construct RevisionID from com.starbase.starteam.RevisionID.

public RevisionID(
RevisionID impl
);

Parameters

impl
The com.starbase.starteam.RevisionID to be wrapped.

See Also

RevisionID Class | Borland.StarTeam Namespace | RevisionID Constructor Overload List


RevisionID Constructor (Int32, Int32)

Create a new RevisionID based on the specified object ID and revision number.

public RevisionID(
Int32 objectID,
Int32 revision
);

Parameters

objectID
the revision identifier's object ID
revision
the revision identifier's revision number

See Also

RevisionID Class | Borland.StarTeam Namespace | RevisionID Constructor Overload List | getObjectID | getRevisionNumber


RevisionID Properties

The properties of the RevisionID class are listed below. For a complete list of RevisionID class members, see the RevisionID Members topic.

Public Instance Properties

IsTip | [read] true if the revision identifier represents the "tip" revision of a branch.
ObjectID | [read/write] the revision identifier's object ID.
Revision | [read/write] the revision identifier's revision number.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

RevisionID Class | Borland.StarTeam Namespace


IsTip Property

Borland StarTeam SDK for .NET

RevisionID.IsTip Property

[read] true if the revision identifier represents the "tip" revision of a branch.

public virtual Boolean IsTip {get;}

Property Value

true if the revision identifier represents the "tip" revision of a branch.

See Also

RevisionID Class | Borland.StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

RevisionID.ObjectID Property

[read/write] the revision identifier's object ID.

public virtual Int32 ObjectID {get; set;}

Property Value

the revision identifier's object ID.

See Also

RevisionID Class | Borland.StarTeam Namespace


Revision Property

Borland StarTeam SDK for .NET

RevisionID.Revision Property

[read/write] the revision identifier's revision number.

public virtual Int32 Revision {get; set;}

Property Value

the revision identifier's revision number.

See Also

RevisionID Class | Borland.StarTeam Namespace


RevisionID Methods

The methods of the RevisionID class are listed below. For a complete list of RevisionID class members, see the RevisionID Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.RevisionID.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.RevisionID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.RevisionID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.RevisionID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

RevisionID Class | Borland.StarTeam Namespace


RevisionID.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.RevisionID

Implements

IWrapper.Unwrap

See Also

RevisionID Class | Borland.StarTeam Namespace


RevisionID.Equals Method

Delegate Equals() to com.starbase.starteam.RevisionID.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.RevisionID.Equals(obj).

See Also

RevisionID Class | Borland.StarTeam Namespace


RevisionID.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.RevisionID.

public override int GetHashCode();

Return Value

com.starbase.starteam.RevisionID.GetHashCode().

See Also

RevisionID Class | Borland.StarTeam Namespace


RevisionID.ToString Method

Delegate ToString() to com.starbase.starteam.RevisionID.

public override string ToString();

Return Value

com.starbase.starteam.RevisionID.ToString()

See Also

RevisionID Class | Borland.StarTeam Namespace


RevisionID.Wrap Method

Dynamically wraps com.starbase.starteam.RevisionID.

public static RevisionID Wrap(
RevisionID impl
);

Parameters

impl
com.starbase.starteam.RevisionID to be wrapped.

Return Value

RevisionID

See Also

RevisionID Class | Borland.StarTeam Namespace


RevisionID Type Conversions

The type conversions of the RevisionID class are listed below. For a complete list of RevisionID class members, see the RevisionID Members topic.

Public Static Type Conversions

Implicit RevisionID to RevisionID Conversion Implicitly convert RevisionID to com.starbase.starteam.RevisionID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

RevisionID Class | RevisionID Members | Borland.StarTeam Namespace


RevisionID Implicit RevisionID to RevisionID Conversion

Implicitly convert RevisionID to com.starbase.starteam.RevisionID.

public static implicit operator RevisionID(
RevisionID arg
);

Parameters

arg
RevisionID to convert.

Return Value

com.starbase.starteam.RevisionID

See Also

RevisionID Class | Borland.StarTeam Namespace


RevisionIdentifier Interface

The RevisionIdentifier interface globally and uniquely identifies a specific revision of a StarTeam object.

For a list of all members of this type, see RevisionIdentifier Members.

public interface RevisionIdentifier

Types that implement RevisionIdentifier

Type | Description
RevisionIdentifierAdapter |

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

RevisionIdentifier Members | Borland.StarTeam Namespace


RevisionIdentifier Members

RevisionIdentifier overview

Public Instance Properties

ContentRevision | [read/write] The content version of this item revision.
DotNotation | [read/write] The dot notation of this revision of the repository object.
ObjectID | [read/write] The objectID of this revision of the repository object.
RepositoryID | [read] An ID that uniquely identifies the repository in which the object in question exists.
RevisionNumber | [read/write] The version number of this revision of the repository object within its branch.
RootObjectID | [read/write] The RootObjectID of the repository object.

See Also

RevisionIdentifier Interface | Borland.StarTeam Namespace


RevisionIdentifier Properties

The properties of the RevisionIdentifier interface are listed below. For a complete list of RevisionIdentifier interface members, see the RevisionIdentifier Members topic.

Public Instance Properties

ContentRevision | [read/write] The content version of this item revision.
DotNotation | [read/write] The dot notation of this revision of the repository object.
ObjectID | [read/write] The objectID of this revision of the repository object.
RepositoryID | [read] An ID that uniquely identifies the repository in which the object in question exists.
RevisionNumber | [read/write] The version number of this revision of the repository object within its branch.
RootObjectID | [read/write] The RootObjectID of the repository object.

See Also

RevisionIdentifier Interface | Borland.StarTeam Namespace


ContentRevision Property

Borland StarTeam SDK for .NET

RevisionIdentifier.ContentRevision Property

[read/write] The content version of this item revision.

Int32 ContentRevision {get; set;}

Property Value

The content version of this item revision.

See Also

RevisionIdentifier Interface | Borland.StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

RevisionIdentifier.DotNotation Property

[read/write] The dot notation of this revision of the repository object.

String DotNotation {get; set;}

Property Value

The dot notation of this revision of the repository object.

See Also

RevisionIdentifier Interface | Borland.StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

RevisionIdentifier.ObjectID Property

[read/write] The objectID of this revision of the repository object.

Int32 ObjectID {get; set;}

Property Value

The objectID of this revision of the repository object.

See Also

RevisionIdentifier Interface | Borland.StarTeam Namespace


RepositoryID Property

Borland StarTeam SDK for .NET

RevisionIdentifier.RepositoryID Property

[read] An ID that uniquely identifies the repository in which the object in question exists.

String RepositoryID {get;}

Property Value

An ID that uniquely identifies the repository in which the object in question exists.

See Also

RevisionIdentifier Interface | Borland.StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

RevisionIdentifier.RevisionNumber Property

[read/write] The version number of this revision of the repository object within its branch.

Int32 RevisionNumber {get; set;}

Property Value

The version number of this revision of the repository object within its branch.

See Also

RevisionIdentifier Interface | Borland.StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

RevisionIdentifier.RootObjectID Property

[read/write] The RootObjectID of the repository object.

Int32 RootObjectID {get; set;}

Property Value

The RootObjectID of the repository object.

See Also

RevisionIdentifier Interface | Borland.StarTeam Namespace


RevisionIdentifierAdapter Class

For a list of all members of this type, see RevisionIdentifierAdapter Members.

System.Object
RevisionIdentifierAdapter

public class RevisionIdentifierAdapter : RevisionIdentifier, RevisionIdentifier

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

RevisionIdentifierAdapter Members | Borland.StarTeam Namespace


RevisionIdentifierAdapter Members

RevisionIdentifierAdapter overview

Public Instance Constructors

RevisionIdentifierAdapter Overloaded. Initializes a new instance of the RevisionIdentifierAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

RevisionIdentifier.ContentRevision
RevisionIdentifier.DotNotation
RevisionIdentifier.getContentRevision
RevisionIdentifier.getDotNotation
RevisionIdentifier.getObjectID
RevisionIdentifier.getRepositoryID
RevisionIdentifier.getRevisionNumber
RevisionIdentifier.getRootObjectID
RevisionIdentifier.ObjectID
RevisionIdentifier.RepositoryID
RevisionIdentifier.RevisionNumber
RevisionIdentifier.RootObjectID
RevisionIdentifier.setContentRevision
RevisionIdentifier.setDotNotation
RevisionIdentifier.setObjectID
RevisionIdentifier.setRevisionNumber
RevisionIdentifier.setRootObjectID

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter Constructor

Overload List

public RevisionIdentifierAdapter(RevisionIdentifier);

public RevisionIdentifierAdapter(RevisionIdentifier);

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter Constructor (RevisionIdentifier)

public RevisionIdentifierAdapter(
RevisionIdentifier arg
);

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace | RevisionIdentifierAdapter Constructor Overload List


RevisionIdentifierAdapter Properties

The properties of the RevisionIdentifierAdapter class are listed below. For a complete list of RevisionIdentifierAdapter class members, see the RevisionIdentifierAdapter Members topic.

Explicit Interface Implementations

RevisionIdentifier.ContentRevision
RevisionIdentifier.DotNotation
RevisionIdentifier.getContentRevision
RevisionIdentifier.getDotNotation
RevisionIdentifier.getObjectID
RevisionIdentifier.getRepositoryID
RevisionIdentifier.getRevisionNumber
RevisionIdentifier.getRootObjectID
RevisionIdentifier.ObjectID
RevisionIdentifier.RepositoryID
RevisionIdentifier.RevisionNumber
RevisionIdentifier.RootObjectID
RevisionIdentifier.setContentRevision
RevisionIdentifier.setDotNotation
RevisionIdentifier.setObjectID
RevisionIdentifier.setRevisionNumber
RevisionIdentifier.setRootObjectID

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifier.ContentRevision Property

Borland StarTeam SDK for .NET

RevisionIdentifierAdapter.RevisionIdentifier.ContentRevision Property

private Int32 RevisionIdentifier.ContentRevision {get; set;}

Implements

RevisionIdentifier.ContentRevision

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifier.DotNotation Property

Borland StarTeam SDK for .NET

RevisionIdentifierAdapter.RevisionIdentifier.DotNotation Property

private String RevisionIdentifier.DotNotation {get; set;}

Implements

RevisionIdentifier.DotNotation

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifier.ObjectID Property

Borland StarTeam SDK for .NET

RevisionIdentifierAdapter.RevisionIdentifier.ObjectID Property

private Int32 RevisionIdentifier.ObjectID {get; set;}

Implements

RevisionIdentifier.ObjectID

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifier.RepositoryID Property

Borland StarTeam SDK for .NET

RevisionIdentifierAdapter.RevisionIdentifier.RepositoryID Property

private String RevisionIdentifier.RepositoryID {get;}

Implements

RevisionIdentifier.RepositoryID

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifier.RevisionNumber Property

Borland StarTeam SDK for .NET

RevisionIdentifierAdapter.RevisionIdentifier.RevisionNumber Property

private Int32 RevisionIdentifier.RevisionNumber {get; set;}

Implements

RevisionIdentifier.RevisionNumber

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifier.RootObjectID Property

Borland StarTeam SDK for .NET

RevisionIdentifierAdapter.RevisionIdentifier.RootObjectID Property

private Int32 RevisionIdentifier.RootObjectID {get; set;}

Implements

RevisionIdentifier.RootObjectID

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter Methods

The methods of the RevisionIdentifierAdapter class are listed below. For a complete list of RevisionIdentifierAdapter class members, see the RevisionIdentifierAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

RevisionIdentifier.ContentRevision
RevisionIdentifier.DotNotation
RevisionIdentifier.getContentRevision
RevisionIdentifier.getDotNotation
RevisionIdentifier.getObjectID
RevisionIdentifier.getRepositoryID
RevisionIdentifier.getRevisionNumber
RevisionIdentifier.getRootObjectID
RevisionIdentifier.ObjectID
RevisionIdentifier.RepositoryID
RevisionIdentifier.RevisionNumber
RevisionIdentifier.RootObjectID
RevisionIdentifier.setContentRevision
RevisionIdentifier.setDotNotation
RevisionIdentifier.setObjectID
RevisionIdentifier.setRevisionNumber
RevisionIdentifier.setRootObjectID

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter.RevisionIdentifier.getContentRevision Method

int RevisionIdentifier.getContentRevision();

Implements

RevisionIdentifier.getContentRevision

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter.RevisionIdentifier.getDotNotation Method

string RevisionIdentifier.getDotNotation();

Implements

RevisionIdentifier.getDotNotation

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter.RevisionIdentifier.getObjectID Method

int RevisionIdentifier.getObjectID();

Implements

RevisionIdentifier.getObjectID

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter.RevisionIdentifier.getRepositoryID Method

string RevisionIdentifier.getRepositoryID();

Implements

RevisionIdentifier.getRepositoryID

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter.RevisionIdentifier.getRevisionNumber Method

int RevisionIdentifier.getRevisionNumber();

Implements

RevisionIdentifier.getRevisionNumber

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter.RevisionIdentifier.getRootObjectID Method

int RevisionIdentifier.getRootObjectID();

Implements

RevisionIdentifier.getRootObjectID

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter.RevisionIdentifier.setContentRevision Method

void RevisionIdentifier.setContentRevision(
Int32 value
);

Implements

RevisionIdentifier.setContentRevision

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter.RevisionIdentifier.setDotNotation Method

void RevisionIdentifier.setDotNotation(
String value
);

Implements

RevisionIdentifier.setDotNotation

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter.RevisionIdentifier.setObjectID Method

void RevisionIdentifier.setObjectID(
Int32 value
);

Implements

RevisionIdentifier.setObjectID

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter.RevisionIdentifier.setRevisionNumber Method

void RevisionIdentifier.setRevisionNumber(
Int32 value
);

Implements

RevisionIdentifier.setRevisionNumber

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


RevisionIdentifierAdapter.RevisionIdentifier.setRootObjectID Method

void RevisionIdentifier.setRootObjectID(
Int32 value
);

Implements

RevisionIdentifier.setRootObjectID

See Also

RevisionIdentifierAdapter Class | Borland.StarTeam Namespace


SDKRuntimeException Class

For a list of all members of this type, see SDKRuntimeException Members.

System.Object
Exception
SDKRuntimeException

public class SDKRuntimeException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SDKRuntimeException Members | Borland.StarTeam Namespace


SDKRuntimeException Members

SDKRuntimeException overview

Public Static Methods

IsInternalApplicationError |
Wrap | Dynamically wraps com.starbase.starteam.SDKRuntimeException.

Public Static Type Conversions

Implicit SDKRuntimeException to SDKRuntimeException Conversion Implicitly convert SDKRuntimeException to com.starbase.starteam.SDKRuntimeException.

Public Instance Constructors

SDKRuntimeException Overloaded. Initializes a new instance of the SDKRuntimeException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Exception |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsInternalError |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.SDKRuntimeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.SDKRuntimeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.SDKRuntimeException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


SDKRuntimeException Constructor

Construct SDKRuntimeException from com.starbase.starteam.SDKRuntimeException.

Overload List

Construct SDKRuntimeException from com.starbase.starteam.SDKRuntimeException.

public SDKRuntimeException(SDKRuntimeException);

public SDKRuntimeException(Exception);

public SDKRuntimeException(String);

public SDKRuntimeException(String,Exception);

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


SDKRuntimeException Constructor (SDKRuntimeException)

Construct SDKRuntimeException from com.starbase.starteam.SDKRuntimeException.

public SDKRuntimeException(
SDKRuntimeException impl
);

Parameters

impl
The com.starbase.starteam.SDKRuntimeException to be wrapped.

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace | SDKRuntimeException Constructor Overload List


SDKRuntimeException Constructor (String)

public SDKRuntimeException(
String message
);

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace | SDKRuntimeException Constructor Overload List


SDKRuntimeException Constructor (Exception)

public SDKRuntimeException(
Exception exception
);

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace | SDKRuntimeException Constructor Overload List


SDKRuntimeException Constructor (String, Exception)

public SDKRuntimeException(
String message,
Exception exception
);

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace | SDKRuntimeException Constructor Overload List


SDKRuntimeException Properties

The properties of the SDKRuntimeException class are listed below. For a complete list of SDKRuntimeException class members, see the SDKRuntimeException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Exception |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsInternalError |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


Exception Property

Borland StarTeam SDK for .NET

SDKRuntimeException.Exception Property

public virtual Exception Exception {get;}

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace | SDKRuntimeException.Exception Overload List


IsInternalError Property

Borland StarTeam SDK for .NET

SDKRuntimeException.IsInternalError Property

public virtual Boolean IsInternalError {get;}

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


SDKRuntimeException Methods

The methods of the SDKRuntimeException class are listed below. For a complete list of SDKRuntimeException class members, see the SDKRuntimeException Members topic.

Public Static Methods

IsInternalApplicationError |
Wrap | Dynamically wraps com.starbase.starteam.SDKRuntimeException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.SDKRuntimeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.SDKRuntimeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.SDKRuntimeException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


SDKRuntimeException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.SDKRuntimeException

Implements

IWrapper.Unwrap

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


SDKRuntimeException.Equals Method

Delegate Equals() to com.starbase.starteam.SDKRuntimeException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.SDKRuntimeException.Equals(obj).

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


SDKRuntimeException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.SDKRuntimeException.

public override int GetHashCode();

Return Value

com.starbase.starteam.SDKRuntimeException.GetHashCode().

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


SDKRuntimeException.IsInternalApplicationError Method

public static bool IsInternalApplicationError(
Exception throwable
);

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


SDKRuntimeException.ToString Method

Delegate ToString() to com.starbase.starteam.SDKRuntimeException.

public override string ToString();

Return Value

com.starbase.starteam.SDKRuntimeException.ToString()

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


SDKRuntimeException.Wrap Method

Dynamically wraps com.starbase.starteam.SDKRuntimeException.

public static SDKRuntimeException Wrap(
SDKRuntimeException impl
);

Parameters

impl
com.starbase.starteam.SDKRuntimeException to be wrapped.

Return Value

SDKRuntimeException

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


SDKRuntimeException Type Conversions

The type conversions of the SDKRuntimeException class are listed below. For a complete list of SDKRuntimeException class members, see the SDKRuntimeException Members topic.

Public Static Type Conversions

Implicit SDKRuntimeException to SDKRuntimeException Conversion Implicitly convert SDKRuntimeException to com.starbase.starteam.SDKRuntimeException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SDKRuntimeException Class | SDKRuntimeException Members | Borland.StarTeam Namespace


SDKRuntimeException Implicit SDKRuntimeException to SDKRuntimeException Conversion

Implicitly convert SDKRuntimeException to com.starbase.starteam.SDKRuntimeException.

public static implicit operator SDKRuntimeException(
SDKRuntimeException arg
);

Parameters

arg
SDKRuntimeException to convert.

Return Value

com.starbase.starteam.SDKRuntimeException

See Also

SDKRuntimeException Class | Borland.StarTeam Namespace


SDKWrapper Class

For a list of all members of this type, see SDKWrapper Members.

System.Object
Wrapper
SDKWrapper

public class SDKWrapper : Wrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SDKWrapper Members | Borland.StarTeam Namespace


SDKWrapper Members

SDKWrapper overview

Public Static Methods

Init

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SDKWrapper Class | Borland.StarTeam Namespace


SDKWrapper Methods

The methods of the SDKWrapper class are listed below. For a complete list of SDKWrapper class members, see the SDKWrapper Members topic.

Public Static Methods

Init

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SDKWrapper Class | Borland.StarTeam Namespace


SDKWrapper.Init Method

public static void Init();

See Also

SDKWrapper Class | Borland.StarTeam Namespace


SecurableContainerAdapter Class

An implementation of ISecurableContainer that can be used as a wrapper for the object returned by getParentContainer(), for classes whose wrapped getParentContainer() method does not return an instance of a public class; for instance Filter and QueryInfo.

For a list of all members of this type, see SecurableContainerAdapter Members.

System.Object
SecurableContainerAdapter

public class SecurableContainerAdapter : ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SecurableContainerAdapter Members | Borland.StarTeam Namespace


SecurableContainerAdapter Members

SecurableContainerAdapter overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SecurableContainerAdapter.

Public Static Type Conversions

Implicit SecurableContainerAdapter to SecurableContainerAdapter Conversion Implicitly convert SecurableContainerAdapter to com.starbase.starteam.SecurableContainerAdapter.

Public Instance Constructors

SecurableContainerAdapter Overloaded. Initializes a new instance of the SecurableContainerAdapter class.

Public Instance Properties

ParentContainer

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetContainerLevelACL |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission |
SetContainerLevelACL |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace


SecurableContainerAdapter Constructor

Construct SecurableContainerAdapter from com.starbase.starteam.SecurableContainerAdapter.

Overload List

public SecurableContainerAdapter(ISecurableContainer);

Construct SecurableContainerAdapter from com.starbase.starteam.SecurableContainerAdapter.

public SecurableContainerAdapter(SecurableContainerAdapter);

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace


SecurableContainerAdapter Constructor (SecurableContainerAdapter)

Construct SecurableContainerAdapter from com.starbase.starteam.SecurableContainerAdapter.

public SecurableContainerAdapter(
SecurableContainerAdapter impl
);

Parameters

impl
The com.starbase.starteam.SecurableContainerAdapter to be wrapped.

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace | SecurableContainerAdapter Constructor Overload List


SecurableContainerAdapter Constructor (ISecurableContainer)

public SecurableContainerAdapter(
ISecurableContainer arg
);

Parameters

arg

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace | SecurableContainerAdapter Constructor Overload List


SecurableContainerAdapter Properties

The properties of the SecurableContainerAdapter class are listed below. For a complete list of SecurableContainerAdapter class members, see the SecurableContainerAdapter Members topic.

Public Instance Properties

ParentContainer

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

SecurableContainerAdapter.ParentContainer Property

public virtual ISecurableContainer ParentContainer {get;}

Implements

ISecurableContainer.ParentContainer

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace


SecurableContainerAdapter Methods

The methods of the SecurableContainerAdapter class are listed below. For a complete list of SecurableContainerAdapter class members, see the SecurableContainerAdapter Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SecurableContainerAdapter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetContainerLevelACL |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission |
SetContainerLevelACL |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace


SecurableContainerAdapter.GetContainerLevelACL Method

public virtual ACL GetContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.GetContainerLevelACL

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace


SecurableContainerAdapter.HasPermission Method

public virtual bool HasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.HasPermission

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace


SecurableContainerAdapter.SetContainerLevelACL Method

public virtual void SetContainerLevelACL(
ACL acl,
String typeName
);

Implements

ISecurableContainer.SetContainerLevelACL

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace


SecurableContainerAdapter.Wrap Method

Dynamically wraps com.starbase.starteam.SecurableContainerAdapter.

public static SecurableContainerAdapter Wrap(
SecurableContainerAdapter impl
);

Parameters

impl
com.starbase.starteam.SecurableContainerAdapter to be wrapped.

Return Value

SecurableContainerAdapter

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace


SecurableContainerAdapter Type Conversions

The type conversions of the SecurableContainerAdapter class are listed below. For a complete list of SecurableContainerAdapter class members, see the SecurableContainerAdapter Members topic.

Public Static Type Conversions

Implicit SecurableContainerAdapter to SecurableContainerAdapter Conversion Implicitly convert SecurableContainerAdapter to com.starbase.starteam.SecurableContainerAdapter.

See Also

SecurableContainerAdapter Class | SecurableContainerAdapter Members | Borland.StarTeam Namespace


SecurableContainerAdapter Implicit SecurableContainerAdapter to SecurableContainerAdapter Conversion

Implicitly convert SecurableContainerAdapter to com.starbase.starteam.SecurableContainerAdapter.

public static implicit operator SecurableContainerAdapter(
SecurableContainerAdapter arg
);

Parameters

arg
SecurableContainerAdapter to convert.

Return Value

com.starbase.starteam.SecurableContainerAdapter

See Also

SecurableContainerAdapter Class | Borland.StarTeam Namespace


SecurityLogEntry Class

For a list of all members of this type, see SecurityLogEntry Members.

System.Object
SecurityLogEntry

public class SecurityLogEntry : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SecurityLogEntry Members | Borland.StarTeam Namespace


SecurityLogEntry Members

SecurityLogEntry overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SecurityLogEntry.

Public Static Type Conversions

Implicit SecurityLogEntry to SecurityLogEntry Conversion Implicitly convert SecurityLogEntry to com.starbase.starteam.SecurityLogEntry.

Public Instance Constructors

SecurityLogEntry Constructor Construct SecurityLogEntry from com.starbase.starteam.SecurityLogEntry.

Public Instance Properties

AccessCheckSecLogID | [read] The AccessCheckSecLogID or null.
ContainerACLSecLogID | [read] The ContainerACLSecLogID or null.
IsFailure | [read] true if this event was a failure, otherwise false.
ObjectACLSecLogID | [read] The ObjectACLSecLogID or null.
ObjectDisplayText | [read] The display text for the security event.
Timestamp | [read] The timestamp.
User | [read] The User object that represents the user id.
UserGroupSecLogID | [read] The UserGroupSecLogID or null.
UserID | [read] The user id.
Workstation | [read] The Workstation object that represents the workstation id.
WorkstationID | [read] The workstation id.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.SecurityLogEntry.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.SecurityLogEntry.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.SecurityLogEntry.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


SecurityLogEntry Constructor

Construct SecurityLogEntry from com.starbase.starteam.SecurityLogEntry.

public SecurityLogEntry(
SecurityLogEntry impl
);

Parameters

impl
The com.starbase.starteam.SecurityLogEntry to be wrapped.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


SecurityLogEntry Properties

The properties of the SecurityLogEntry class are listed below. For a complete list of SecurityLogEntry class members, see the SecurityLogEntry Members topic.

Public Instance Properties

AccessCheckSecLogID | [read] The AccessCheckSecLogID or null.
ContainerACLSecLogID | [read] The ContainerACLSecLogID or null.
IsFailure | [read] true if this event was a failure, otherwise false.
ObjectACLSecLogID | [read] The ObjectACLSecLogID or null.
ObjectDisplayText | [read] The display text for the security event.
Timestamp | [read] The timestamp.
User | [read] The User object that represents the user id.
UserGroupSecLogID | [read] The UserGroupSecLogID or null.
UserID | [read] The user id.
Workstation | [read] The Workstation object that represents the workstation id.
WorkstationID | [read] The workstation id.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


AccessCheckSecLogID Property

Borland StarTeam SDK for .NET

SecurityLogEntry.AccessCheckSecLogID Property

[read] The AccessCheckSecLogID or null.

public virtual AccessCheckSecLogID AccessCheckSecLogID {get;}

Property Value

The AccessCheckSecLogID or null.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


ContainerACLSecLogID Property

Borland StarTeam SDK for .NET

SecurityLogEntry.ContainerACLSecLogID Property

[read] The ContainerACLSecLogID or null.

public virtual ContainerACLSecLogID ContainerACLSecLogID {get;}

Property Value

The ContainerACLSecLogID or null.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


IsFailure Property

Borland StarTeam SDK for .NET

SecurityLogEntry.IsFailure Property

[read] true if this event was a failure, otherwise false.

public virtual Boolean IsFailure {get;}

Property Value

true if this event was a failure, otherwise false.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


ObjectACLSecLogID Property

Borland StarTeam SDK for .NET

SecurityLogEntry.ObjectACLSecLogID Property

[read] The ObjectACLSecLogID or null.

public virtual ObjectACLSecLogID ObjectACLSecLogID {get;}

Property Value

The ObjectACLSecLogID or null.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


ObjectDisplayText Property

Borland StarTeam SDK for .NET

SecurityLogEntry.ObjectDisplayText Property

[read] The display text for the security event.

public virtual String ObjectDisplayText {get;}

Property Value

The display text for the security event.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


Timestamp Property

Borland StarTeam SDK for .NET

SecurityLogEntry.Timestamp Property

[read] The timestamp.

public virtual DateTime Timestamp {get;}

Property Value

The timestamp.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


User Property

Borland StarTeam SDK for .NET

SecurityLogEntry.User Property

[read] The User object that represents the user id.

public virtual User User {get;}

Property Value

The User object that represents the user id.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


UserGroupSecLogID Property

Borland StarTeam SDK for .NET

SecurityLogEntry.UserGroupSecLogID Property

[read] The UserGroupSecLogID or null.

public virtual UserGroupSecLogID UserGroupSecLogID {get;}

Property Value

The UserGroupSecLogID or null.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


UserID Property

Borland StarTeam SDK for .NET

SecurityLogEntry.UserID Property

[read] The user id.

public virtual Int32 UserID {get;}

Property Value

The user id.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


Workstation Property

Borland StarTeam SDK for .NET

SecurityLogEntry.Workstation Property

[read] The Workstation object that represents the workstation id.

public virtual Workstation Workstation {get;}

Property Value

The Workstation object that represents the workstation id.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


WorkstationID Property

Borland StarTeam SDK for .NET

SecurityLogEntry.WorkstationID Property

[read] The workstation id.

public virtual Int32 WorkstationID {get;}

Property Value

The workstation id.

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


SecurityLogEntry Methods

The methods of the SecurityLogEntry class are listed below. For a complete list of SecurityLogEntry class members, see the SecurityLogEntry Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SecurityLogEntry.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.SecurityLogEntry.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.SecurityLogEntry.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.SecurityLogEntry.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


SecurityLogEntry.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.SecurityLogEntry

Implements

IWrapper.Unwrap

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


SecurityLogEntry.Equals Method

Delegate Equals() to com.starbase.starteam.SecurityLogEntry.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.SecurityLogEntry.Equals(obj).

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


SecurityLogEntry.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.SecurityLogEntry.

public override int GetHashCode();

Return Value

com.starbase.starteam.SecurityLogEntry.GetHashCode().

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


SecurityLogEntry.ToString Method

Delegate ToString() to com.starbase.starteam.SecurityLogEntry.

public override string ToString();

Return Value

com.starbase.starteam.SecurityLogEntry.ToString()

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


SecurityLogEntry.Wrap Method

Dynamically wraps com.starbase.starteam.SecurityLogEntry.

public static SecurityLogEntry Wrap(
SecurityLogEntry impl
);

Parameters

impl
com.starbase.starteam.SecurityLogEntry to be wrapped.

Return Value

SecurityLogEntry

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


SecurityLogEntry Type Conversions

The type conversions of the SecurityLogEntry class are listed below. For a complete list of SecurityLogEntry class members, see the SecurityLogEntry Members topic.

Public Static Type Conversions

Implicit SecurityLogEntry to SecurityLogEntry Conversion Implicitly convert SecurityLogEntry to com.starbase.starteam.SecurityLogEntry.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SecurityLogEntry Class | SecurityLogEntry Members | Borland.StarTeam Namespace


SecurityLogEntry Implicit SecurityLogEntry to SecurityLogEntry Conversion

Implicitly convert SecurityLogEntry to com.starbase.starteam.SecurityLogEntry.

public static implicit operator SecurityLogEntry(
SecurityLogEntry arg
);

Parameters

arg
SecurityLogEntry to convert.

Return Value

com.starbase.starteam.SecurityLogEntry

See Also

SecurityLogEntry Class | Borland.StarTeam Namespace


SecurityLogEntry.SecurityEventType Class

For a list of all members of this type, see SecurityLogEntry.SecurityEventType Members.

System.Object
SecurityLogEntry.SecurityEventType

public class SecurityLogEntry.SecurityEventType : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SecurityLogEntry.SecurityEventType Members | Borland.StarTeam Namespace


SecurityLogEntry.SecurityEventType Members

SecurityLogEntry.SecurityEventType overview

Public Static Properties

eAccessTimeRestricted
eContainerACLAddEdit
eContainerACLDelete
eLockout
eLoginFailure
eLogon
eLogout
eNoSuchLoginName
eObjectAccessCheck
eObjectACLAcquireOwnership
eObjectACLAddEdit
eObjectACLAddOwner
eObjectACLDelete
eObjectACLDropOwner
ePasswordExpired
ePolicyChange
eSuspendedAccount
eUnknownEvent
eUserChange
eUserGroupAdd
eUserGroupDrop
eUserGroupEdit
eUserGroupForceLogout
eUserGroupStatusChange

Public Static Type Conversions

Implicit SecurityLogEntry.SecurityEventType to SecurityLogEntry.SecurityEventType Conversion

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.SecurityLogEntry.SecurityEventType.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.SecurityLogEntry.SecurityEventType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.SecurityLogEntry.SecurityEventType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


SecurityLogEntry.SecurityEventType Properties

The properties of the SecurityLogEntry.SecurityEventType class are listed below. For a complete list of SecurityLogEntry.SecurityEventType class members, see the SecurityLogEntry.SecurityEventType Members topic.

Public Static Properties

eAccessTimeRestricted
eContainerACLAddEdit
eContainerACLDelete
eLockout
eLoginFailure
eLogon
eLogout
eNoSuchLoginName
eObjectAccessCheck
eObjectACLAcquireOwnership
eObjectACLAddEdit
eObjectACLAddOwner
eObjectACLDelete
eObjectACLDropOwner
ePasswordExpired
ePolicyChange
eSuspendedAccount
eUnknownEvent
eUserChange
eUserGroupAdd
eUserGroupDrop
eUserGroupEdit
eUserGroupForceLogout
eUserGroupStatusChange

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eAccessTimeRestricted Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eAccessTimeRestricted Property

public static Int32 eAccessTimeRestricted {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eContainerACLAddEdit Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eContainerACLAddEdit Property

public static Int32 eContainerACLAddEdit {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eContainerACLDelete Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eContainerACLDelete Property

public static Int32 eContainerACLDelete {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eLockout Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eLockout Property

public static Int32 eLockout {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eLoginFailure Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eLoginFailure Property

public static Int32 eLoginFailure {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eLogon Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eLogon Property

public static Int32 eLogon {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eLogout Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eLogout Property

public static Int32 eLogout {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eNoSuchLoginName Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eNoSuchLoginName Property

public static Int32 eNoSuchLoginName {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eObjectAccessCheck Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eObjectAccessCheck Property

public static Int32 eObjectAccessCheck {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eObjectACLAcquireOwnership Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eObjectACLAcquireOwnership Property

public static Int32 eObjectACLAcquireOwnership {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eObjectACLAddEdit Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eObjectACLAddEdit Property

public static Int32 eObjectACLAddEdit {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eObjectACLAddOwner Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eObjectACLAddOwner Property

public static Int32 eObjectACLAddOwner {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eObjectACLDelete Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eObjectACLDelete Property

public static Int32 eObjectACLDelete {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eObjectACLDropOwner Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eObjectACLDropOwner Property

public static Int32 eObjectACLDropOwner {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


ePasswordExpired Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.ePasswordExpired Property

public static Int32 ePasswordExpired {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


ePolicyChange Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.ePolicyChange Property

public static Int32 ePolicyChange {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eSuspendedAccount Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eSuspendedAccount Property

public static Int32 eSuspendedAccount {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eUnknownEvent Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eUnknownEvent Property

public static Int32 eUnknownEvent {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eUserChange Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eUserChange Property

public static Int32 eUserChange {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eUserGroupAdd Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eUserGroupAdd Property

public static Int32 eUserGroupAdd {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eUserGroupDrop Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eUserGroupDrop Property

public static Int32 eUserGroupDrop {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eUserGroupEdit Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eUserGroupEdit Property

public static Int32 eUserGroupEdit {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eUserGroupForceLogout Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eUserGroupForceLogout Property

public static Int32 eUserGroupForceLogout {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


eUserGroupStatusChange Property

Borland StarTeam SDK for .NET

SecurityLogEntry.SecurityEventType.eUserGroupStatusChange Property

public static Int32 eUserGroupStatusChange {get;}

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


SecurityLogEntry.SecurityEventType Methods

The methods of the SecurityLogEntry.SecurityEventType class are listed below. For a complete list of SecurityLogEntry.SecurityEventType class members, see the SecurityLogEntry.SecurityEventType Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.SecurityLogEntry.SecurityEventType.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.SecurityLogEntry.SecurityEventType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.SecurityLogEntry.SecurityEventType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


SecurityLogEntry.SecurityEventType.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.SecurityLogEntry.SecurityEventType

Implements

IWrapper.Unwrap

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


SecurityLogEntry.SecurityEventType.Equals Method

Delegate Equals() to com.starbase.starteam.SecurityLogEntry.SecurityEventType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.SecurityLogEntry.SecurityEventType.Equals(obj).

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


SecurityLogEntry.SecurityEventType.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.SecurityLogEntry.SecurityEventType.

public override int GetHashCode();

Return Value

com.starbase.starteam.SecurityLogEntry.SecurityEventType.GetHashCode().

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


SecurityLogEntry.SecurityEventType.ToString Method

Delegate ToString() to com.starbase.starteam.SecurityLogEntry.SecurityEventType.

public override string ToString();

Return Value

com.starbase.starteam.SecurityLogEntry.SecurityEventType.ToString()

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


SecurityLogEntry.SecurityEventType Type Conversions

The type conversions of the SecurityLogEntry.SecurityEventType class are listed below. For a complete list of SecurityLogEntry.SecurityEventType class members, see the SecurityLogEntry.SecurityEventType Members topic.

Public Static Type Conversions

Implicit SecurityLogEntry.SecurityEventType to SecurityLogEntry.SecurityEventType Conversion

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SecurityLogEntry.SecurityEventType Class | SecurityLogEntry.SecurityEventType Members | Borland.StarTeam Namespace


SecurityLogEntry.SecurityEventType Implicit SecurityLogEntry.SecurityEventType to SecurityLogEntry.SecurityEventType Conversion

public static implicit operator SecurityEventType(
SecurityLogEntry.SecurityEventType arg
);

See Also

SecurityLogEntry.SecurityEventType Class | Borland.StarTeam Namespace


SecurityLogEntryCollection Class

A strongly-typed collection of SecurityLogEntrys.

For a list of all members of this type, see SecurityLogEntryCollection Members.

System.Object
ArrayAdapter
SecurityLogEntryCollection

public class SecurityLogEntryCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SecurityLogEntryCollection Members | Borland.StarTeam Namespace


SecurityLogEntryCollection Members

SecurityLogEntryCollection overview

Public Static Methods

Wrap Creates a SecurityLogEntryCollection to represent the given array of SecurityLogEntry (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit SecurityLogEntryCollection to SecurityLogEntry[] Conversion | Converts a SecurityLogEntryCollection to an array of SecurityLogEntrys.
Implicit SecurityLogEntryCollection to SecurityLogEntry[] Conversion | Converts a SecurityLogEntryCollection from the Borland.StarTeam namespace to a SecurityLogEntry[] in the com.starbase.starteam namespace.

Public Instance Constructors

SecurityLogEntryCollection Overloaded. Initializes a new instance of the SecurityLogEntryCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the SecurityLogEntry at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a SecurityLogEntry to end of the collection.
Append | Overloaded. Appends the SecurityLogEntrys of the given SecurityLogEntryCollection to the end of this SecurityLogEntryCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific SecurityLogEntry.
CopyTo | Copies all of the SecurityLogEntrys in the SecurityLogEntryCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific SecurityLogEntry in the collection.
Insert | Inserts a SecurityLogEntry into the collection at the specified position.
Remove | Removes the first occurrence of a specific SecurityLogEntry from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the SecurityLogEntrys in this SecurityLogEntryCollection.
Sort | Sorts the SecurityLogEntrys in this SecurityLogEntryCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection Constructor

Initializes an instance of the SecurityLogEntryCollection class.

Overload List

Initializes an instance of the SecurityLogEntryCollection class.

public SecurityLogEntryCollection();

Initializes an instance of the a SecurityLogEntryCollection class, copying the given array.

public SecurityLogEntryCollection(SecurityLogEntry[]);

Initializes an instance of the a SecurityLogEntryCollection class, copying the given collection.

public SecurityLogEntryCollection(SecurityLogEntryCollection);

Initializes an instance of the a SecurityLogEntryCollection class, wrapping the given array of SecurityLogEntry (from the com.starbase.starteam namespace).

public SecurityLogEntryCollection(SecurityLogEntry[]);

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection Constructor ()

Initializes an instance of the SecurityLogEntryCollection class.

public SecurityLogEntryCollection();

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace | SecurityLogEntryCollection Constructor Overload List


SecurityLogEntryCollection Constructor (SecurityLogEntry[])

Initializes an instance of the a SecurityLogEntryCollection class, wrapping the given array of SecurityLogEntry (from the com.starbase.starteam namespace).

public SecurityLogEntryCollection(
SecurityLogEntry[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace | SecurityLogEntryCollection Constructor Overload List | Wrap


SecurityLogEntryCollection Constructor (SecurityLogEntryCollection)

Initializes an instance of the a SecurityLogEntryCollection class, copying the given collection.

public SecurityLogEntryCollection(
SecurityLogEntryCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member SecurityLogEntry objects of the original collection are shared, not copied.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace | SecurityLogEntryCollection Constructor Overload List


SecurityLogEntryCollection Constructor (SecurityLogEntry[])

Initializes an instance of the a SecurityLogEntryCollection class, copying the given array.

public SecurityLogEntryCollection(
SecurityLogEntry[] array
);

Parameters

array
The array to be copied.

Remarks

The member SecurityLogEntry objects of the original array are shared, not copied.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace | SecurityLogEntryCollection Constructor Overload List


SecurityLogEntryCollection Properties

The properties of the SecurityLogEntryCollection class are listed below. For a complete list of SecurityLogEntryCollection class members, see the SecurityLogEntryCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the SecurityLogEntry at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

SecurityLogEntryCollection.Item Property

Gets or sets the SecurityLogEntry at the specified index.

public SecurityLogEntry this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the SecurityLogEntry to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection Methods

The methods of the SecurityLogEntryCollection class are listed below. For a complete list of SecurityLogEntryCollection class members, see the SecurityLogEntryCollection Members topic.

Public Static Methods

Wrap Creates a SecurityLogEntryCollection to represent the given array of SecurityLogEntry (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a SecurityLogEntry to end of the collection.
Append | Overloaded. Appends the SecurityLogEntrys of the given SecurityLogEntryCollection to the end of this SecurityLogEntryCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific SecurityLogEntry.
CopyTo | Copies all of the SecurityLogEntrys in the SecurityLogEntryCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific SecurityLogEntry in the collection.
Insert | Inserts a SecurityLogEntry into the collection at the specified position.
Remove | Removes the first occurrence of a specific SecurityLogEntry from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the SecurityLogEntrys in this SecurityLogEntryCollection.
Sort | Sorts the SecurityLogEntrys in this SecurityLogEntryCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection.Add Method

Adds a SecurityLogEntry to end of the collection.

public int Add(
SecurityLogEntry value
);

Parameters

value
The SecurityLogEntry to add to the collection.

Return Value

The position into which the new SecurityLogEntry was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

SecurityLogEntryCollection.Append Method

Appends the SecurityLogEntrys of the given array to the end of this SecurityLogEntryCollection.

Overload List

Appends the SecurityLogEntrys of the given array to the end of this SecurityLogEntryCollection.

public SecurityLogEntryCollection Append(SecurityLogEntry[]);

Appends the SecurityLogEntrys of the given SecurityLogEntryCollection to the end of this SecurityLogEntryCollection.

public SecurityLogEntryCollection Append(SecurityLogEntryCollection);

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection.Append Method (SecurityLogEntry[])

Appends the SecurityLogEntrys of the given array to the end of this SecurityLogEntryCollection.

public SecurityLogEntryCollection Append(
SecurityLogEntry[] array
);

Parameters

array
The array whose SecurityLogEntrys are to be appended to this SecurityLogEntryCollection.

Return Value

This SecurityLogEntryCollection, modified to include the new SecurityLogEntrys.

Remarks

The SecurityLogEntryCollection is modified to include the new members. The individual SecurityLogEntry objects are shared, not copied.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace | SecurityLogEntryCollection.Append Overload List


SecurityLogEntryCollection.Append Method (SecurityLogEntryCollection)

Appends the SecurityLogEntrys of the given SecurityLogEntryCollection to the end of this SecurityLogEntryCollection.

public SecurityLogEntryCollection Append(
SecurityLogEntryCollection collection
);

Parameters

collection
The SecurityLogEntryCollection whose SecurityLogEntrys are to be appended to this SecurityLogEntryCollection.

Return Value

This SecurityLogEntryCollection, modified to include the new SecurityLogEntrys.

Remarks

The SecurityLogEntryCollection is modified to include the new members. The individual SecurityLogEntry objects are shared, not copied.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace | SecurityLogEntryCollection.Append Overload List


SecurityLogEntryCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.SecurityLogEntry[].

Implements

IWrapper.Unwrap

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection.Contains Method

Determines whether or not the collection contains a specific SecurityLogEntry.

public bool Contains(
SecurityLogEntry value
);

Parameters

value
The SecurityLogEntry to locate in the collection.

Return Value

true if the SecurityLogEntry is found in the collection; otherwise, false.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection.CopyTo Method

Copies all of the SecurityLogEntrys in the SecurityLogEntryCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
SecurityLogEntry[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the SecurityLogEntrys copied from the SecurityLogEntryCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of SecurityLogEntrys in the source SecurityLogEntryCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source SecurityLogEntryCollection cannot be cast automatically to the type of the destination array.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection.IndexOf Method

Determines the index of a specific SecurityLogEntry in the collection.

public int IndexOf(
SecurityLogEntry value
);

Parameters

value
The SecurityLogEntry to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection.Insert Method

Inserts a SecurityLogEntry into the collection at the specified position.

public void Insert(
Int32 index,
SecurityLogEntry value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The SecurityLogEntry to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection.Remove Method

Removes the first occurrence of a specific SecurityLogEntry from the collection.

public void Remove(
SecurityLogEntry value
);

Parameters

value
The SecurityLogEntry to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection.Reverse Method

Reverses the order of the SecurityLogEntrys in this SecurityLogEntryCollection.

new public SecurityLogEntryCollection Reverse();

Return Value

This SecurityLogEntryCollection, modified such that the SecurityLogEntrys are reversed.

Remarks

The SecurityLogEntryCollection is modified in place.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection.Sort Method

Sorts the SecurityLogEntrys in this SecurityLogEntryCollection, using the given comparer.

new public SecurityLogEntryCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two SecurityLogEntrys.

Return Value

This SecurityLogEntryCollection, modified such that the SecurityLogEntrys are sorted.

Remarks

The SecurityLogEntryCollection is modified in place.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection.Wrap Method

Creates a SecurityLogEntryCollection to represent the given array of SecurityLogEntry (from the com.starbase.starteam namespace).

public static SecurityLogEntryCollection Wrap(
SecurityLogEntry[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new SecurityLogEntryCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a SecurityLogEntry[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection Type Conversions

The type conversions of the SecurityLogEntryCollection class are listed below. For a complete list of SecurityLogEntryCollection class members, see the SecurityLogEntryCollection Members topic.

Public Static Type Conversions

Implicit SecurityLogEntryCollection to SecurityLogEntry[] Conversion | Converts a SecurityLogEntryCollection to an array of SecurityLogEntrys.
Implicit SecurityLogEntryCollection to SecurityLogEntry[] Conversion | Converts a SecurityLogEntryCollection from the Borland.StarTeam namespace to a SecurityLogEntry[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

SecurityLogEntryCollection Class | SecurityLogEntryCollection Members | Borland.StarTeam Namespace


SecurityLogEntryCollection Implicit SecurityLogEntryCollection to SecurityLogEntry[] Conversion

Converts a SecurityLogEntryCollection to an array of SecurityLogEntrys.

public static implicit operator SecurityLogEntry[](
SecurityLogEntryCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new SecurityLogEntry wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one SecurityLogEntry wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


SecurityLogEntryCollection Implicit SecurityLogEntryCollection to SecurityLogEntry[] Conversion

Converts a SecurityLogEntryCollection from the Borland.StarTeam namespace to a SecurityLogEntry[] in the com.starbase.starteam namespace.

public static implicit operator SecurityLogEntry[](
SecurityLogEntryCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, SecurityLogEntryCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

SecurityLogEntryCollection Class | Borland.StarTeam Namespace


Server Class

The Server class provides network access to a remote StarTeam Server. It only supports access through TCP/IP sockets and has the ability to encrypt and compress all communication between the client server.

For a list of all members of this type, see Server Members.

System.Object
Server

public class Server : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Server Members | Borland.StarTeam Namespace


Server Members

Server overview

Public Static Properties

IsCredentialCachingAvailable | [read] true if the credential caching feature is available on this workstation, and false otherwise.
IsCredentialCachingEnabled | [read] true if credential caching is enabled on this workstation, and false otherwise.

Public Static Methods

EnableCredentialCaching | Enables credential caching on this workstation, if it is available and not already enabled. Currently, this starts the StarTeam Toolbar.
Wrap | Dynamically wraps com.starbase.starteam.Server.

Public Static Type Conversions

Implicit Server to Server Conversion Implicitly convert Server to com.starbase.starteam.Server.

Public Instance Constructors

Server Overloaded. Initializes a new instance of the Server class.

Public Instance Properties

ActiveGroups | [read] All of the active (non-deleted) groups in this Server.
ActiveUsers | [read] All of the active (non-deleted) users in this Server.
Address | [read] string representing the network address
Administration | [read] the ServerAdministration object for this server.
AutoReconnectAttempts | [read/write] If automatic reconnect is enabled, the maximum number of attempts to reconnect that will be made while executing a single server command. Default value is 1.
AutoReconnectWait | [read/write] If automatic reconnect is enabled, the number of seconds that we will wait before each reconnect attempt. Default value is 2 seconds.
ClientContext | [read] the ClientContext associated when logged in to the Server. May return null if not logged in.
CommandAPIRevisionLevel | [read] the command API revision level of this server.
CommandCount | [read] The number of commands sent to the StarTeam server since the connection was established.
CommandUserID | [write] act like a given User different from the User currently logged in
CurrentCacheAgent | [read] CacheAgent the CacheAgent currently in use by this server, or null
CurrentMPXProfile | [read] The EventHandlerProfile of the MPX message broker, or null if MPX is not currently enabled.
CurrentTime | [read] The current server time.
EncryptionAlgorithm | [read] The level of encryption requested for the connection.
EventHandlerInfoNames | [read] an array containing the names of all existing EventHandlerInfos on this server.
ForeignPassword | [write] Sets a password for the foreign archive associated with this project.
Groups | [read] All of the groups on this server.
HasProductCodeInformation | [read] true if the licensed product codes are available from this server.
IsAutoLogOnAvailable | [read] true if logon credentials for this server have been cached on this workstation, and false otherwise.
IsAutoReconnectEnabled | [read/write] true if a reconnect is automatically attempted whenever a connection problem is detected while executing a server command. Automatic reconnect is enabled by default.
IsCompressed | [read] true if the connection is compressed; false otherwise.
IsConnected | [read] true if a network connection to the StarTeam server has been established.
IsKeepAlive | [read/write] true if keep-alive mode is in effect; false otherwise. In keep-alive mode, a background thread periodically pings the server to keep the connection alive. Keep-alive is off by default.
IsLoggedOn | [read] true if someone has logged on through this server object.
IsMailAvailable | [read] true if the server supports email.
IsMPXAvailable | [read] true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).
IsMPXEnabled | [read] true if MPX has been enabled for this server, and false otherwise.
IsMPXResponding | [read] true if the MPX server is running properly, and false otherwise.
IsRefreshAccountsRequired | [read] true if User or Group information may be out of date.
IsRefreshGroupsRequired | [read] true if Group information may be out of date.
IsRefreshTypesRequired | [read] true if Type information may be out of date.
IsRefreshUsersRequired | [read] true if User information may be out of date.
KeepAliveInterval | [read/write] The current keep-alive interval, in minutes.
MPXCacheAgentEnabled | [read/write] True to enable checkouts via the MPX cache agent; false to force all checkouts to use the StarTeam server directly.
MPXMessageCount | [read] The number of MPX messages received since MPX was enabled; 0 if not enabled.
MPXTransmitterName | [read]
MyUserAccount | [read] The user account for the currently logged on user.
Port | [read] server's TCP/IP port
ProductCodes | [read] The product codes licensed for this server.
Projects | [read] The set of Projects accessible from this Server. May be empty (but is never null).
PropertyEnums | [read] enumerated property values for this server.
PropertyNames | [read] property names for this server.
Protocol | [read] The protocol used to connect to the server.
RepositoryID | [read] com.starbase.util.GUID
RequiredEncryptionLevel | [read] level of encryption required to connect to the server
RevisionLevel | [read] the revision level of this server.
ServerBuild | [read] The server build number.
ServerBuildDescription | [read] The server build description.
Session | [read] session information for the currently logged on user.
SupportedFeatures | [read] An instance of the SupportedFeatures class that can tell which features are available for this StarTeam server
TypeNames | [read] type names for this server.
Types | [read] an array of Types instances
Users | [read] All of the users in this Server.

Public Instance Methods

AutoLocateCacheAgent | autoLocate a Cache Agent, return null if none found Attempts to autolocate can be expensive
AutoLogOn | Log on to this server using credentials that have been cached on this workstation.
CacheLogOnCredentials | Saves logon credentials for this server so that they may be used in future calls to autoLogOn().
ChangePassword | Changes the password to the specified new password upon a successful login to the server, and immediately logs out. New password is immediately effective upon a successful change of password.
Connect | Establishes a network connection to the remote server process. If the network connection is successfully established, and an MPXProfileName was specified in the Server constructor, then an attempt is made to automatically enable MPX. If an MPXException is thrown, it will be ignored, and will not cause the connect() to fail. An application can use isMPXEnabled() to determine whether or not MPX was properly enabled.
DisableMPX | Disables MPX, if it was enabled for this server.
DiscardAccounts | Discards all cached User and Group information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardGroups | Discards cached Group information. The next call to getGroups() will re-fetch the group information from the StarTeam Server.
DiscardTypes | Discards all cached Type information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardUsers | Discards cached User information. The next call to getUsers() will re-fetch the user information from the StarTeam Server (even when MPX is enabled).
Disconnect | Terminates the network connection to the remote server process. The user will be logged off.
EnableMPX | Overloaded. Enables MPX using the default client MPX profile.
Equals | Delegate Equals() to com.starbase.starteam.Server.
FetchEmailUsers | This method issues a command to the server to return the list of users that are able to recieve email messages.
FindLinks | Returns an array of Link objects associated with this item.
GetEventHandlerInfo | Returns the specified EventHandlerInfo object on this server. If no such EventhandlerInfo exist, a null is returned.
GetFilterList
GetForeignArchivePaths | Get the archive paths of the foreign archive specified. Note that if the password for the foreign archive is different from the StarTeam password, then you must first call setForeignPasswordExplicit().
GetGroup | Returns the Group object for the given ID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Server.
GetQueryList
GetType (inherited from Object) | Gets the Type of the current instance.
GetUser | Returns the User object for the given ID.
HandleEvents | Places the current thread in an event-handling state. While in an event-handling state, the thread is usually asleep, waking occasionally just long enough to ping the server (keeping the connection alive). The event-handling loop continues until some other thread (presumably, the event-handling thread for this Server object) calls interruptHandleEvents(). An application does not need to call handleEvents() in order to handle events; this is just a convenience method for applications that have nothing else they need to do while waiting for an event to occur. Only one thread may call handleEvents() per Server object at any given time. After handleEvents() exits (as a result of a call to interruptHandleEvents), then handleEvents() may be called again by the same thread or by some other thread. handleEvents() will fail if MPX is not enabled, or if there are no event-handlers running. handleEvents() should not be called from within an event handler. (This would put the event-handling thread to sleep.)
HasProductCode | Determines whether or not the server has a license for the specified product code. Will return false if the information is not available from the server.
InterruptHandleEvents | Interrupts a handleEvents() loop, if there is one running. Usually called from within an event-handler, running in the event-handling thread for this Server object.
IsTypeSupported | Return true if the type with the specified name is supported by this server.
LocateCacheAgent | locate a CacheAgent at a given address and port
LogOn | Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the priveleges associated with the supplied user credentials.
LogOnForWorkstation | Establishes a user-session with the remote server process, on behalf of the workstation with the given ID. This is useful when running on behalf of a remote client workstation.
LogOnWithClientContext | Establishes a user-session with the remote server process, on behalf of the specified ClientContext. This is useful when running on behalf of a remote client workstation.
NewMPXStatusEventSource
NewProjectEventSource
NewServerControlEventSource
NewTypeEventSource
NewUserEventSource
Ping | Verifies that the server is responding and informs the server that this connection/user session is still active.
PingMPXServer | Throws an appropriate MPXException if the MPX server is not running properly.
Reconnect | Overloaded. Attempts to re-establish the connection to the server, re-opening any existing view sessions. Uses the user credentials provided at logon time.
RefreshAccounts | Refreshes cached User and Group information. Existing User and Group objects are modified in place whenever possible.
RefreshGroups | Refreshes cached Group information to reflect recent changes to the repository. Modifies existing Group objects in place whenever possible.
RefreshTypes | Refreshes cached Type information to reflect recent changes to the repository. Existing Type and Property objects are modified in place, whenever possible. If MPX is enabled, refreshTypes() is optimized to avoid unnecessary server commands.
RefreshUsers | Refreshes cached User information to reflect recent changes to the repository. Modifies existing User objects in place whenever possible. If MPX is enabled, refreshUsers() is optimized to avoid unnecessary server commands.
SendMailFromView | Directs the StarTeam Server to send mail to the specified StarTeam users.
SendMailWithAttachments | Directs the StarTeam Server to send mail to the specified StarTeam users.
SetForeignPasswordExplicit | Sets a password for the foreign archive specified.
ToString | Delegate ToString() to com.starbase.starteam.Server.
TypeForClassID | Looks up the type information based on a type-number.
TypeForName | Returns a type instance for a type name.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Server Class | Borland.StarTeam Namespace


Server Constructor

Construct Server from com.starbase.starteam.Server.

Overload List

Creates a new Server object, using the given connection information. The ServerInfo must specify a supported protocol; otherwise, an IllegalArgumentException will be thrown. If ServerInfo specifies an MPXProfileName, then later, after the Server connection itself is established, an attempt will be made to automatically enable MPX.

public Server(ServerInfo);

Construct Server from com.starbase.starteam.Server.

public Server(Server);

Constructs an object that represents a remote server process. Uses whatever encryption algorithm and compression level the server requires. It does not automatically connect to the server.

public Server(String,Int32);

Constructs an object that represents a remote server process specifying the encpryption algorithm and compression levels to use. It does not automatically connect to the server. The connection will be encrypted with a level of encryption at least as strong as specified by the algorithmID paramter and possibly higher if the server requires it.

public Server(String,Int32,EncryptionAlgorithm,Boolean);

Constructs an object that represents a remote server process specifying the encpryption algorithm and compression levels to use. It does not automatically connect to the server. The connection will be encrypted with a level of encryption at least as strong as specified by the algorithmID paramter and possibly higher if the server requires it.

public Server(String,Int32,EncryptionAlgorithm,Boolean,Int32);

See Also

Server Class | Borland.StarTeam Namespace


Server Constructor (Server)

Construct Server from com.starbase.starteam.Server.

public Server(
Server impl
);

Parameters

impl
The com.starbase.starteam.Server to be wrapped.

See Also

Server Class | Borland.StarTeam Namespace | Server Constructor Overload List


Server Constructor (String, Int32)

Constructs an object that represents a remote server process. Uses whatever encryption algorithm and compression level the server requires. It does not automatically connect to the server.

public Server(
String address,
Int32 port
);

Parameters

address
the host address of the remote server
port
the TCP/IP port of the remote server

See Also

Server Class | Borland.StarTeam Namespace | Server Constructor Overload List


Server Constructor (String, Int32, EncryptionAlgorithm, Boolean)

Constructs an object that represents a remote server process specifying the encpryption algorithm and compression levels to use. It does not automatically connect to the server. The connection will be encrypted with a level of encryption at least as strong as specified by the algorithmID paramter and possibly higher if the server requires it.

public Server(
String address,
Int32 port,
EncryptionAlgorithm algorithmID,
Boolean compressionLevel
);

Parameters

address
the host address of the remote server (may not be null)
port
the TCP/IP port of the remote server
algorithmID
the level of encryption desired for the connection. Value may be null.
compressionLevel
true if compression should be used for data transmission.

See Also

Server Class | Borland.StarTeam Namespace | Server Constructor Overload List


Server Constructor (String, Int32, EncryptionAlgorithm, Boolean, Int32)

Constructs an object that represents a remote server process specifying the encpryption algorithm and compression levels to use. It does not automatically connect to the server. The connection will be encrypted with a level of encryption at least as strong as specified by the algorithmID paramter and possibly higher if the server requires it.

public Server(
String address,
Int32 port,
EncryptionAlgorithm algorithmID,
Boolean compressionLevel,
Int32 protocol
);

Parameters

address
the host address of the remote server (may not be null)
port
the TCP/IP port of the remote server
algorithmID
the level of encryption desired for the connection. Value may be null.
compressionLevel
true if compression should be used for data transmission.
protocol
to be used to connect to the server. Can only be ServerConfiguration.PROTOCOL_TCP_IP_SOCKETS_XML or ServerConfiguration.PROTOCOL_TCP_IP_SOCKETS

See Also

Server Class | Borland.StarTeam Namespace | Server Constructor Overload List | PROTOCOL_TCP_IP_SOCKETS_XML | PROTOCOL_TCP_IP_SOCKETS


Server Constructor (ServerInfo)

Creates a new Server object, using the given connection information.

The ServerInfo must specify a supported protocol; otherwise, an IllegalArgumentException will be thrown.

If ServerInfo specifies an MPXProfileName, then later, after the Server connection itself is established, an attempt will be made to automatically enable MPX.

public Server(
ServerInfo info
);

Parameters

info
Server connection information.

See Also

Server Class | Borland.StarTeam Namespace | Server Constructor Overload List | ServerInfo | connect | enableMPX


Server Properties

The properties of the Server class are listed below. For a complete list of Server class members, see the Server Members topic.

Public Static Properties

IsCredentialCachingAvailable | [read] true if the credential caching feature is available on this workstation, and false otherwise.
IsCredentialCachingEnabled | [read] true if credential caching is enabled on this workstation, and false otherwise.

Public Instance Properties

ActiveGroups | [read] All of the active (non-deleted) groups in this Server.
ActiveUsers | [read] All of the active (non-deleted) users in this Server.
Address | [read] string representing the network address
Administration | [read] the ServerAdministration object for this server.
AutoReconnectAttempts | [read/write] If automatic reconnect is enabled, the maximum number of attempts to reconnect that will be made while executing a single server command. Default value is 1.
AutoReconnectWait | [read/write] If automatic reconnect is enabled, the number of seconds that we will wait before each reconnect attempt. Default value is 2 seconds.
ClientContext | [read] the ClientContext associated when logged in to the Server. May return null if not logged in.
CommandAPIRevisionLevel | [read] the command API revision level of this server.
CommandCount | [read] The number of commands sent to the StarTeam server since the connection was established.
CommandUserID | [write] act like a given User different from the User currently logged in
CurrentCacheAgent | [read] CacheAgent the CacheAgent currently in use by this server, or null
CurrentMPXProfile | [read] The EventHandlerProfile of the MPX message broker, or null if MPX is not currently enabled.
CurrentTime | [read] The current server time.
EncryptionAlgorithm | [read] The level of encryption requested for the connection.
EventHandlerInfoNames | [read] an array containing the names of all existing EventHandlerInfos on this server.
ForeignPassword | [write] Sets a password for the foreign archive associated with this project.
Groups | [read] All of the groups on this server.
HasProductCodeInformation | [read] true if the licensed product codes are available from this server.
IsAutoLogOnAvailable | [read] true if logon credentials for this server have been cached on this workstation, and false otherwise.
IsAutoReconnectEnabled | [read/write] true if a reconnect is automatically attempted whenever a connection problem is detected while executing a server command. Automatic reconnect is enabled by default.
IsCompressed | [read] true if the connection is compressed; false otherwise.
IsConnected | [read] true if a network connection to the StarTeam server has been established.
IsKeepAlive | [read/write] true if keep-alive mode is in effect; false otherwise. In keep-alive mode, a background thread periodically pings the server to keep the connection alive. Keep-alive is off by default.
IsLoggedOn | [read] true if someone has logged on through this server object.
IsMailAvailable | [read] true if the server supports email.
IsMPXAvailable | [read] true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).
IsMPXEnabled | [read] true if MPX has been enabled for this server, and false otherwise.
IsMPXResponding | [read] true if the MPX server is running properly, and false otherwise.
IsRefreshAccountsRequired | [read] true if User or Group information may be out of date.
IsRefreshGroupsRequired | [read] true if Group information may be out of date.
IsRefreshTypesRequired | [read] true if Type information may be out of date.
IsRefreshUsersRequired | [read] true if User information may be out of date.
KeepAliveInterval | [read/write] The current keep-alive interval, in minutes.
MPXCacheAgentEnabled | [read/write] True to enable checkouts via the MPX cache agent; false to force all checkouts to use the StarTeam server directly.
MPXMessageCount | [read] The number of MPX messages received since MPX was enabled; 0 if not enabled.
MPXTransmitterName | [read]
MyUserAccount | [read] The user account for the currently logged on user.
Port | [read] server's TCP/IP port
ProductCodes | [read] The product codes licensed for this server.
Projects | [read] The set of Projects accessible from this Server. May be empty (but is never null).
PropertyEnums | [read] enumerated property values for this server.
PropertyNames | [read] property names for this server.
Protocol | [read] The protocol used to connect to the server.
RepositoryID | [read] com.starbase.util.GUID
RequiredEncryptionLevel | [read] level of encryption required to connect to the server
RevisionLevel | [read] the revision level of this server.
ServerBuild | [read] The server build number.
ServerBuildDescription | [read] The server build description.
Session | [read] session information for the currently logged on user.
SupportedFeatures | [read] An instance of the SupportedFeatures class that can tell which features are available for this StarTeam server
TypeNames | [read] type names for this server.
Types | [read] an array of Types instances
Users | [read] All of the users in this Server.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Server Class | Borland.StarTeam Namespace


ActiveGroups Property

Borland StarTeam SDK for .NET

Server.ActiveGroups Property

[read] All of the active (non-deleted) groups in this Server.

public virtual GroupCollection ActiveGroups {get;}

Property Value

All of the active (non-deleted) groups in this Server.

See Also

Server Class | Borland.StarTeam Namespace


ActiveUsers Property

Borland StarTeam SDK for .NET

Server.ActiveUsers Property

[read] All of the active (non-deleted) users in this Server.

public virtual UserCollection ActiveUsers {get;}

Property Value

All of the active (non-deleted) users in this Server.

See Also

Server Class | Borland.StarTeam Namespace


Address Property

Borland StarTeam SDK for .NET

Server.Address Property

[read] string representing the network address

public virtual String Address {get;}

Property Value

string representing the network address

See Also

Server Class | Borland.StarTeam Namespace


Administration Property

Borland StarTeam SDK for .NET

Server.Administration Property

[read] the ServerAdministration object for this server.

public virtual ServerAdministration Administration {get;}

Property Value

the ServerAdministration object for this server.

See Also

Server Class | Borland.StarTeam Namespace


AutoReconnectAttempts Property

Borland StarTeam SDK for .NET

Server.AutoReconnectAttempts Property

[read/write] If automatic reconnect is enabled, the maximum number of attempts to reconnect that will be made while executing a single server command. Default value is 1.

public virtual Int32 AutoReconnectAttempts {get; set;}

Property Value

If automatic reconnect is enabled, the maximum number of attempts to reconnect that will be made while executing a single server command. Default value is 1.

See Also

Server Class | Borland.StarTeam Namespace


AutoReconnectWait Property

Borland StarTeam SDK for .NET

Server.AutoReconnectWait Property

[read/write] If automatic reconnect is enabled, the number of seconds that we will wait before each reconnect attempt. Default value is 2 seconds.

public virtual Int32 AutoReconnectWait {get; set;}

Property Value

If automatic reconnect is enabled, the number of seconds that we will wait before each reconnect attempt. Default value is 2 seconds.

See Also

Server Class | Borland.StarTeam Namespace


ClientContext Property

Borland StarTeam SDK for .NET

Server.ClientContext Property

[read] the ClientContext associated when logged in to the Server. May return null if not logged in.

public virtual ClientContext ClientContext {get;}

Property Value

the ClientContext associated when logged in to the Server. May return null if not logged in.

See Also

Server Class | Borland.StarTeam Namespace


CommandAPIRevisionLevel Property

Borland StarTeam SDK for .NET

Server.CommandAPIRevisionLevel Property

[read] the command API revision level of this server.

public virtual String CommandAPIRevisionLevel {get;}

Property Value

the command API revision level of this server.

See Also

Server Class | Borland.StarTeam Namespace


CommandCount Property

Borland StarTeam SDK for .NET

Server.CommandCount Property

[read] The number of commands sent to the StarTeam server since the connection was established.

public virtual Int32 CommandCount {get;}

Property Value

The number of commands sent to the StarTeam server since the connection was established.

See Also

Server Class | Borland.StarTeam Namespace


CommandUserID Property

Borland StarTeam SDK for .NET

Server.CommandUserID Property

[write] act like a given User different from the User currently logged in

public virtual Int32 CommandUserID {set;}

Property Value

act like a given User different from the User currently logged in

See Also

Server Class | Borland.StarTeam Namespace


CurrentCacheAgent Property

Borland StarTeam SDK for .NET

Server.CurrentCacheAgent Property

[read] CacheAgent the CacheAgent currently in use by this server, or null

public virtual CacheAgent CurrentCacheAgent {get;}

Property Value

CacheAgent the CacheAgent currently in use by this server, or null

See Also

Server Class | Borland.StarTeam Namespace


CurrentMPXProfile Property

Borland StarTeam SDK for .NET

Server.CurrentMPXProfile Property

[read] The EventHandlerProfile of the MPX message broker, or null if MPX is not currently enabled.

public virtual EventHandlerProfile CurrentMPXProfile {get;}

Property Value

The EventHandlerProfile of the MPX message broker, or null if MPX is not currently enabled.

See Also

Server Class | Borland.StarTeam Namespace


CurrentTime Property

Borland StarTeam SDK for .NET

Server.CurrentTime Property

[read] The current server time.

public virtual DateTime CurrentTime {get;}

Property Value

The current server time.

See Also

Server Class | Borland.StarTeam Namespace


EncryptionAlgorithm Property

Borland StarTeam SDK for .NET

Server.EncryptionAlgorithm Property

[read] The level of encryption requested for the connection.

public virtual EncryptionAlgorithm EncryptionAlgorithm {get;}

Property Value

The level of encryption requested for the connection.

See Also

Server Class | Borland.StarTeam Namespace


EventHandlerInfoNames Property

Borland StarTeam SDK for .NET

Server.EventHandlerInfoNames Property

[read] an array containing the names of all existing EventHandlerInfos on this server.

public virtual String[] EventHandlerInfoNames {get;}

Property Value

an array containing the names of all existing EventHandlerInfos on this server.

See Also

Server Class | Borland.StarTeam Namespace


ForeignPassword Property

Borland StarTeam SDK for .NET

Server.ForeignPassword Property

[write] Sets a password for the foreign archive associated with this project.

public virtual Project ForeignPassword {set;}

Property Value

Sets a password for the foreign archive associated with this project.

See Also

Server Class | Borland.StarTeam Namespace


Groups Property

Borland StarTeam SDK for .NET

Server.Groups Property

[read] All of the groups on this server.

public virtual GroupCollection Groups {get;}

Property Value

All of the groups on this server.

See Also

Server Class | Borland.StarTeam Namespace


HasProductCodeInformation Property

Borland StarTeam SDK for .NET

Server.HasProductCodeInformation Property

[read] true if the licensed product codes are available from this server.

public virtual Boolean HasProductCodeInformation {get;}

Property Value

true if the licensed product codes are available from this server.

See Also

Server Class | Borland.StarTeam Namespace


IsAutoLogOnAvailable Property

Borland StarTeam SDK for .NET

Server.IsAutoLogOnAvailable Property

[read] true if logon credentials for this server have been cached on this workstation, and false otherwise.

public virtual Boolean IsAutoLogOnAvailable {get;}

Property Value

true if logon credentials for this server have been cached on this workstation, and false otherwise.

See Also

Server Class | Borland.StarTeam Namespace


IsAutoReconnectEnabled Property

Borland StarTeam SDK for .NET

Server.IsAutoReconnectEnabled Property

[read/write] true if a reconnect is automatically attempted whenever a connection problem is detected while executing a server command. Automatic reconnect is enabled by default.

public virtual Boolean IsAutoReconnectEnabled {get; set;}

Property Value

true if a reconnect is automatically attempted whenever a connection problem is detected while executing a server command. Automatic reconnect is enabled by default.

See Also

Server Class | Borland.StarTeam Namespace


IsCompressed Property

Borland StarTeam SDK for .NET

Server.IsCompressed Property

[read] true if the connection is compressed; false otherwise.

public virtual Boolean IsCompressed {get;}

Property Value

true if the connection is compressed; false otherwise.

See Also

Server Class | Borland.StarTeam Namespace


IsConnected Property

Borland StarTeam SDK for .NET

Server.IsConnected Property

[read] true if a network connection to the StarTeam server has been established.

public virtual Boolean IsConnected {get;}

Property Value

true if a network connection to the StarTeam server has been established.

See Also

Server Class | Borland.StarTeam Namespace


IsCredentialCachingAvailable Property

Borland StarTeam SDK for .NET

Server.IsCredentialCachingAvailable Property

[read] true if the credential caching feature is available on this workstation, and false otherwise.

public static Boolean IsCredentialCachingAvailable {get;}

Property Value

true if the credential caching feature is available on this workstation, and false otherwise.

See Also

Server Class | Borland.StarTeam Namespace


IsCredentialCachingEnabled Property

Borland StarTeam SDK for .NET

Server.IsCredentialCachingEnabled Property

[read] true if credential caching is enabled on this workstation, and false otherwise.

public static Boolean IsCredentialCachingEnabled {get;}

Property Value

true if credential caching is enabled on this workstation, and false otherwise.

See Also

Server Class | Borland.StarTeam Namespace


IsKeepAlive Property

Borland StarTeam SDK for .NET

Server.IsKeepAlive Property

[read/write] true if keep-alive mode is in effect; false otherwise. In keep-alive mode, a background thread periodically pings the server to keep the connection alive. Keep-alive is off by default.

public virtual Boolean IsKeepAlive {get; set;}

Property Value

true if keep-alive mode is in effect; false otherwise. In keep-alive mode, a background thread periodically pings the server to keep the connection alive. Keep-alive is off by default.

See Also

Server Class | Borland.StarTeam Namespace


IsLoggedOn Property

Borland StarTeam SDK for .NET

Server.IsLoggedOn Property

[read] true if someone has logged on through this server object.

public virtual Boolean IsLoggedOn {get;}

Property Value

true if someone has logged on through this server object.

See Also

Server Class | Borland.StarTeam Namespace


IsMailAvailable Property

Borland StarTeam SDK for .NET

Server.IsMailAvailable Property

[read] true if the server supports email.

public virtual Boolean IsMailAvailable {get;}

Property Value

true if the server supports email.

See Also

Server Class | Borland.StarTeam Namespace


IsMPXAvailable Property

Borland StarTeam SDK for .NET

Server.IsMPXAvailable Property

[read] true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).

public virtual Boolean IsMPXAvailable {get;}

Property Value

true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).

See Also

Server Class | Borland.StarTeam Namespace


IsMPXEnabled Property

Borland StarTeam SDK for .NET

Server.IsMPXEnabled Property

[read] true if MPX has been enabled for this server, and false otherwise.

public virtual Boolean IsMPXEnabled {get;}

Property Value

true if MPX has been enabled for this server, and false otherwise.

See Also

Server Class | Borland.StarTeam Namespace


IsMPXResponding Property

Borland StarTeam SDK for .NET

Server.IsMPXResponding Property

[read] true if the MPX server is running properly, and false otherwise.

public virtual Boolean IsMPXResponding {get;}

Property Value

true if the MPX server is running properly, and false otherwise.

See Also

Server Class | Borland.StarTeam Namespace


IsRefreshAccountsRequired Property

Borland StarTeam SDK for .NET

Server.IsRefreshAccountsRequired Property

[read] true if User or Group information may be out of date.

public virtual Boolean IsRefreshAccountsRequired {get;}

Property Value

true if User or Group information may be out of date.

See Also

Server Class | Borland.StarTeam Namespace


IsRefreshGroupsRequired Property

Borland StarTeam SDK for .NET

Server.IsRefreshGroupsRequired Property

[read] true if Group information may be out of date.

public virtual Boolean IsRefreshGroupsRequired {get;}

Property Value

true if Group information may be out of date.

See Also

Server Class | Borland.StarTeam Namespace


IsRefreshTypesRequired Property

Borland StarTeam SDK for .NET

Server.IsRefreshTypesRequired Property

[read] true if Type information may be out of date.

public virtual Boolean IsRefreshTypesRequired {get;}

Property Value

true if Type information may be out of date.

See Also

Server Class | Borland.StarTeam Namespace


IsRefreshUsersRequired Property

Borland StarTeam SDK for .NET

Server.IsRefreshUsersRequired Property

[read] true if User information may be out of date.

public virtual Boolean IsRefreshUsersRequired {get;}

Property Value

true if User information may be out of date.

See Also

Server Class | Borland.StarTeam Namespace


KeepAliveInterval Property

Borland StarTeam SDK for .NET

Server.KeepAliveInterval Property

[read/write] The current keep-alive interval, in minutes.

public virtual Int32 KeepAliveInterval {get; set;}

Property Value

The current keep-alive interval, in minutes.

See Also

Server Class | Borland.StarTeam Namespace


MPXCacheAgentEnabled Property

Borland StarTeam SDK for .NET

Server.MPXCacheAgentEnabled Property

[read/write] True to enable checkouts via the MPX cache agent; false to force all checkouts to use the StarTeam server directly.

public virtual Boolean MPXCacheAgentEnabled {get; set;}

Property Value

True to enable checkouts via the MPX cache agent; false to force all checkouts to use the StarTeam server directly.

See Also

Server Class | Borland.StarTeam Namespace


MPXMessageCount Property

Borland StarTeam SDK for .NET

Server.MPXMessageCount Property

[read] The number of MPX messages received since MPX was enabled; 0 if not enabled.

public virtual Int32 MPXMessageCount {get;}

Property Value

The number of MPX messages received since MPX was enabled; 0 if not enabled.

See Also

Server Class | Borland.StarTeam Namespace


MPXTransmitterName Property

Borland StarTeam SDK for .NET

Server.MPXTransmitterName Property

[read]

public virtual String MPXTransmitterName {get;}

See Also

Server Class | Borland.StarTeam Namespace


MyUserAccount Property

Borland StarTeam SDK for .NET

Server.MyUserAccount Property

[read] The user account for the currently logged on user.

public virtual MyUserAccount MyUserAccount {get;}

Property Value

The user account for the currently logged on user.

See Also

Server Class | Borland.StarTeam Namespace


Port Property

Borland StarTeam SDK for .NET

Server.Port Property

[read] server's TCP/IP port

public virtual Int32 Port {get;}

Property Value

server's TCP/IP port

See Also

Server Class | Borland.StarTeam Namespace


ProductCodes Property

Borland StarTeam SDK for .NET

Server.ProductCodes Property

[read] The product codes licensed for this server.

public virtual Int32[] ProductCodes {get;}

Property Value

The product codes licensed for this server.

See Also

Server Class | Borland.StarTeam Namespace


Projects Property

Borland StarTeam SDK for .NET

Server.Projects Property

[read] The set of Projects accessible from this Server. May be empty (but is never null).

public virtual ProjectCollection Projects {get;}

Property Value

The set of Projects accessible from this Server. May be empty (but is never null).

See Also

Server Class | Borland.StarTeam Namespace


PropertyEnums Property

Borland StarTeam SDK for .NET

Server.PropertyEnums Property

[read] enumerated property values for this server.

public virtual PropertyEnums PropertyEnums {get;}

Property Value

enumerated property values for this server.

See Also

Server Class | Borland.StarTeam Namespace


PropertyNames Property

Borland StarTeam SDK for .NET

Server.PropertyNames Property

[read] property names for this server.

public virtual PropertyNames PropertyNames {get;}

Property Value

property names for this server.

See Also

Server Class | Borland.StarTeam Namespace


Protocol Property

Borland StarTeam SDK for .NET

Server.Protocol Property

[read] The protocol used to connect to the server.

public virtual Int32 Protocol {get;}

Property Value

The protocol used to connect to the server.

See Also

Server Class | Borland.StarTeam Namespace


RepositoryID Property

Borland StarTeam SDK for .NET

Server.RepositoryID Property

[read] com.starbase.util.GUID

public virtual GUID RepositoryID {get;}

Property Value

com.starbase.util.GUID

See Also

Server Class | Borland.StarTeam Namespace


RequiredEncryptionLevel Property

Borland StarTeam SDK for .NET

Server.RequiredEncryptionLevel Property

[read] level of encryption required to connect to the server

public virtual EncryptionAlgorithm RequiredEncryptionLevel {get;}

Property Value

level of encryption required to connect to the server

See Also

Server Class | Borland.StarTeam Namespace


RevisionLevel Property

Borland StarTeam SDK for .NET

Server.RevisionLevel Property

[read] the revision level of this server.

public virtual Int16 RevisionLevel {get;}

Property Value

the revision level of this server.

See Also

Server Class | Borland.StarTeam Namespace


ServerBuild Property

Borland StarTeam SDK for .NET

Server.ServerBuild Property

[read] The server build number.

public virtual String ServerBuild {get;}

Property Value

The server build number.

See Also

Server Class | Borland.StarTeam Namespace


ServerBuildDescription Property

Borland StarTeam SDK for .NET

Server.ServerBuildDescription Property

[read] The server build description.

public virtual String ServerBuildDescription {get;}

Property Value

The server build description.

See Also

Server Class | Borland.StarTeam Namespace


Session Property

Borland StarTeam SDK for .NET

Server.Session Property

[read] session information for the currently logged on user.

public virtual ServerSession Session {get;}

Property Value

session information for the currently logged on user.

See Also

Server Class | Borland.StarTeam Namespace


SupportedFeatures Property

Borland StarTeam SDK for .NET

Server.SupportedFeatures Property

[read] An instance of the SupportedFeatures class that can tell which features are available for this StarTeam server

public virtual SupportedFeatures SupportedFeatures {get;}

Property Value

An instance of the SupportedFeatures class that can tell which features are available for this StarTeam server

See Also

Server Class | Borland.StarTeam Namespace


TypeNames Property

Borland StarTeam SDK for .NET

Server.TypeNames Property

[read] type names for this server.

public virtual TypeNames TypeNames {get;}

Property Value

type names for this server.

See Also

Server Class | Borland.StarTeam Namespace


Types Property

Borland StarTeam SDK for .NET

Server.Types Property

[read] an array of Types instances

public virtual TypeCollection Types {get;}

Property Value

an array of Types instances

See Also

Server Class | Borland.StarTeam Namespace


Users Property

Borland StarTeam SDK for .NET

Server.Users Property

[read] All of the users in this Server.

public virtual UserCollection Users {get;}

Property Value

All of the users in this Server.

See Also

Server Class | Borland.StarTeam Namespace


Server Methods

The methods of the Server class are listed below. For a complete list of Server class members, see the Server Members topic.

Public Static Methods

EnableCredentialCaching | Enables credential caching on this workstation, if it is available and not already enabled. Currently, this starts the StarTeam Toolbar.
Wrap | Dynamically wraps com.starbase.starteam.Server.

Public Instance Methods

AutoLocateCacheAgent | autoLocate a Cache Agent, return null if none found Attempts to autolocate can be expensive
AutoLogOn | Log on to this server using credentials that have been cached on this workstation.
CacheLogOnCredentials | Saves logon credentials for this server so that they may be used in future calls to autoLogOn().
ChangePassword | Changes the password to the specified new password upon a successful login to the server, and immediately logs out. New password is immediately effective upon a successful change of password.
Connect | Establishes a network connection to the remote server process. If the network connection is successfully established, and an MPXProfileName was specified in the Server constructor, then an attempt is made to automatically enable MPX. If an MPXException is thrown, it will be ignored, and will not cause the connect() to fail. An application can use isMPXEnabled() to determine whether or not MPX was properly enabled.
DisableMPX | Disables MPX, if it was enabled for this server.
DiscardAccounts | Discards all cached User and Group information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardGroups | Discards cached Group information. The next call to getGroups() will re-fetch the group information from the StarTeam Server.
DiscardTypes | Discards all cached Type information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardUsers | Discards cached User information. The next call to getUsers() will re-fetch the user information from the StarTeam Server (even when MPX is enabled).
Disconnect | Terminates the network connection to the remote server process. The user will be logged off.
EnableMPX | Overloaded. Enables MPX using the default client MPX profile.
Equals | Delegate Equals() to com.starbase.starteam.Server.
FetchEmailUsers | This method issues a command to the server to return the list of users that are able to recieve email messages.
FindLinks | Returns an array of Link objects associated with this item.
GetEventHandlerInfo | Returns the specified EventHandlerInfo object on this server. If no such EventhandlerInfo exist, a null is returned.
GetFilterList
GetForeignArchivePaths | Get the archive paths of the foreign archive specified. Note that if the password for the foreign archive is different from the StarTeam password, then you must first call setForeignPasswordExplicit().
GetGroup | Returns the Group object for the given ID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Server.
GetQueryList
GetType (inherited from Object) | Gets the Type of the current instance.
GetUser | Returns the User object for the given ID.
HandleEvents | Places the current thread in an event-handling state. While in an event-handling state, the thread is usually asleep, waking occasionally just long enough to ping the server (keeping the connection alive). The event-handling loop continues until some other thread (presumably, the event-handling thread for this Server object) calls interruptHandleEvents(). An application does not need to call handleEvents() in order to handle events; this is just a convenience method for applications that have nothing else they need to do while waiting for an event to occur. Only one thread may call handleEvents() per Server object at any given time. After handleEvents() exits (as a result of a call to interruptHandleEvents), then handleEvents() may be called again by the same thread or by some other thread. handleEvents() will fail if MPX is not enabled, or if there are no event-handlers running. handleEvents() should not be called from within an event handler. (This would put the event-handling thread to sleep.)
HasProductCode | Determines whether or not the server has a license for the specified product code. Will return false if the information is not available from the server.
InterruptHandleEvents | Interrupts a handleEvents() loop, if there is one running. Usually called from within an event-handler, running in the event-handling thread for this Server object.
IsTypeSupported | Return true if the type with the specified name is supported by this server.
LocateCacheAgent | locate a CacheAgent at a given address and port
LogOn | Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the priveleges associated with the supplied user credentials.
LogOnForWorkstation | Establishes a user-session with the remote server process, on behalf of the workstation with the given ID. This is useful when running on behalf of a remote client workstation.
LogOnWithClientContext | Establishes a user-session with the remote server process, on behalf of the specified ClientContext. This is useful when running on behalf of a remote client workstation.
NewMPXStatusEventSource
NewProjectEventSource
NewServerControlEventSource
NewTypeEventSource
NewUserEventSource
Ping | Verifies that the server is responding and informs the server that this connection/user session is still active.
PingMPXServer | Throws an appropriate MPXException if the MPX server is not running properly.
Reconnect | Overloaded. Attempts to re-establish the connection to the server, re-opening any existing view sessions. Uses the user credentials provided at logon time.
RefreshAccounts | Refreshes cached User and Group information. Existing User and Group objects are modified in place whenever possible.
RefreshGroups | Refreshes cached Group information to reflect recent changes to the repository. Modifies existing Group objects in place whenever possible.
RefreshTypes | Refreshes cached Type information to reflect recent changes to the repository. Existing Type and Property objects are modified in place, whenever possible. If MPX is enabled, refreshTypes() is optimized to avoid unnecessary server commands.
RefreshUsers | Refreshes cached User information to reflect recent changes to the repository. Modifies existing User objects in place whenever possible. If MPX is enabled, refreshUsers() is optimized to avoid unnecessary server commands.
SendMailFromView | Directs the StarTeam Server to send mail to the specified StarTeam users.
SendMailWithAttachments | Directs the StarTeam Server to send mail to the specified StarTeam users.
SetForeignPasswordExplicit | Sets a password for the foreign archive specified.
ToString | Delegate ToString() to com.starbase.starteam.Server.
TypeForClassID | Looks up the type information based on a type-number.
TypeForName | Returns a type instance for a type name.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Server Class | Borland.StarTeam Namespace


Server.AutoLocateCacheAgent Method

autoLocate a Cache Agent, return null if none found Attempts to autolocate can be expensive

public virtual CacheAgent AutoLocateCacheAgent();

Return Value

CacheAgent a CacheAgent if found, or null

See Also

Server Class | Borland.StarTeam Namespace


Server.AutoLogOn Method

Log on to this server using credentials that have been cached on this workstation.

public virtual int AutoLogOn();

Return Value

the userID for the logged on user.

See Also

Server Class | Borland.StarTeam Namespace | isAutoLogOnAvailable | cacheLogOnCredentials


Server.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.Server

Implements

IWrapper.Unwrap

See Also

Server Class | Borland.StarTeam Namespace


Server.CacheLogOnCredentials Method

Saves logon credentials for this server so that they may be used in future calls to autoLogOn().

public virtual void CacheLogOnCredentials(
String username,
String password
);

Parameters

username
the user name to save.
password
the password to save.

Return Value

true if successful, otherwise false.

See Also

Server Class | Borland.StarTeam Namespace | autoLogOn | isAutoLogOnAvailable | isCredentialCachingEnabled


Server.ChangePassword Method

Changes the password to the specified new password upon a successful login to the server, and immediately logs out. New password is immediately effective upon a successful change of password.

public virtual void ChangePassword(
String logOnName,
String password,
String newPassword
);

Parameters

logOnName
password
newPassword

See Also

Server Class | Borland.StarTeam Namespace


Server.Connect Method

Establishes a network connection to the remote server process.

If the network connection is successfully established, and an MPXProfileName was specified in the Server constructor, then an attempt is made to automatically enable MPX. If an MPXException is thrown, it will be ignored, and will not cause the connect() to fail. An application can use isMPXEnabled() to determine whether or not MPX was properly enabled.

public virtual void Connect();

See Also

Server Class | Borland.StarTeam Namespace | Server | enableMPX | isMPXEnabled


Server.DisableMPX Method

Disables MPX, if it was enabled for this server.

public virtual void DisableMPX();

See Also

Server Class | Borland.StarTeam Namespace


Server.DiscardAccounts Method

Discards all cached User and Group information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void DiscardAccounts();

See Also

Server Class | Borland.StarTeam Namespace | refreshAccounts


Server.DiscardGroups Method

Discards cached Group information. The next call to getGroups() will re-fetch the group information from the StarTeam Server.

public virtual void DiscardGroups();

See Also

Server Class | Borland.StarTeam Namespace | getGroups | refreshGroups


Server.DiscardTypes Method

Discards all cached Type information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void DiscardTypes();

See Also

Server Class | Borland.StarTeam Namespace


Server.DiscardUsers Method

Discards cached User information. The next call to getUsers() will re-fetch the user information from the StarTeam Server (even when MPX is enabled).

public virtual void DiscardUsers();

See Also

Server Class | Borland.StarTeam Namespace | getUsers | refreshUsers


Server.Disconnect Method

Terminates the network connection to the remote server process. The user will be logged off.

public virtual void Disconnect();

See Also

Server Class | Borland.StarTeam Namespace


Server.EnableCredentialCaching Method

Enables credential caching on this workstation, if it is available and not already enabled. Currently, this starts the StarTeam Toolbar.

public static void EnableCredentialCaching();

Return Value

true if credential caching is enabled, and false otherwise.

See Also

Server Class | Borland.StarTeam Namespace | autoLogOn | isCredentialCachingAvailable | isCredentialCachingEnabled | cacheLogOnCredentials


EnableMPX Method

Borland StarTeam SDK for .NET

Server.EnableMPX Method

Enables MPX using the default client MPX profile.

Overload List

Enables MPX using the default client MPX profile.

public virtual void EnableMPX();

Enables MPX using the given MPX profile.

public virtual void EnableMPX(EventHandlerProfile);

Enables MPX using the MPX profile with the given name.

public virtual void EnableMPX(String);

See Also

Server Class | Borland.StarTeam Namespace | enableMPX | enableMPX


Server.EnableMPX Method ()

Enables MPX using the default client MPX profile.

public virtual void EnableMPX();

Exceptions

Exception Type | Condition
 | com.starbase.starteam.MPXException

See Also

Server Class | Borland.StarTeam Namespace | Server.EnableMPX Overload List | enableMPX | enableMPX


Server.EnableMPX Method (EventHandlerProfile)

Enables MPX using the given MPX profile.

public virtual void EnableMPX(
EventHandlerProfile profile
);

Parameters

profile
An MPX profile.

Exceptions

Exception Type | Condition
 | com.starbase.starteam.MPXException

See Also

Server Class | Borland.StarTeam Namespace | Server.EnableMPX Overload List | enableMPX | enableMPX | isMPXAvailable | isMPXEnabled | isMPXResponding | pingMPXServer | disableMPX


Server.EnableMPX Method (String)

Enables MPX using the MPX profile with the given name.

public virtual void EnableMPX(
String strProfileName
);

Parameters

strProfileName
The name of an MPX profile on this server.

Exceptions

Exception Type | Condition
 | com.starbase.starteam.MPXException

See Also

Server Class | Borland.StarTeam Namespace | Server.EnableMPX Overload List | enableMPX | enableMPX


Server.Equals Method

Delegate Equals() to com.starbase.starteam.Server.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.Server.Equals(obj).

See Also

Server Class | Borland.StarTeam Namespace


Server.FetchEmailUsers Method

This method issues a command to the server to return the list of users that are able to recieve email messages.

public virtual UserCollection FetchEmailUsers();

Return Value

the list of users that can receieve email messages

See Also

Server Class | Borland.StarTeam Namespace | sendMailFromView | sendMailWithAttachments


Server.FindLinks Method

Returns an array of Link objects associated with this item.

public virtual LinkCollection FindLinks(
Item item
);

Parameters

item
the item

Return Value

an array of Link objects

See Also

Server Class | Borland.StarTeam Namespace


Server.GetEventHandlerInfo Method

Returns the specified EventHandlerInfo object on this server. If no such EventhandlerInfo exist, a null is returned.

public virtual EventHandlerInfo GetEventHandlerInfo(
String eventHandlerInfoName
);

Parameters

eventHandlerInfoName
The name of the EventHandlerInfo object to be returned.

Return Value

the specified EventHandlerInfo object on this server. If no such EventhandlerInfo exist, a null is returned.

See Also

Server Class | Borland.StarTeam Namespace | getEventHandlerInfoNames


Server.GetFilterList Method

public virtual FilterCollection GetFilterList(
Type type,
Boolean pub
);

Parameters

type
pub

See Also

Server Class | Borland.StarTeam Namespace


Server.GetForeignArchivePaths Method

Get the archive paths of the foreign archive specified. Note that if the password for the foreign archive is different from the StarTeam password, then you must first call setForeignPasswordExplicit().

public virtual string[] GetForeignArchivePaths(
Int32 projectType,
String configFile
);

Parameters

projectType
configFile

See Also

Server Class | Borland.StarTeam Namespace | setForeignPasswordExplicit | PROJECT_TYPE_PVCS | PROJECT_TYPE_VISUAL_SOURCESAFE


Server.GetGroup Method

Returns the Group object for the given ID.

public virtual Group GetGroup(
Int32 groupID
);

Parameters

groupID
the group ID in question

Return Value

the Group object with the given ID. Will return null if not found.

See Also

Server Class | Borland.StarTeam Namespace | getGroups


Server.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.Server.

public override int GetHashCode();

Return Value

com.starbase.starteam.Server.GetHashCode().

See Also

Server Class | Borland.StarTeam Namespace


Server.GetQueryList Method

public virtual QueryCollection GetQueryList(
Type type,
Boolean pub
);

Parameters

type
pub

See Also

Server Class | Borland.StarTeam Namespace


Server.GetUser Method

Returns the User object for the given ID.

public virtual User GetUser(
Int32 userID
);

Parameters

userID
the user ID in question

Return Value

the User object with the given ID. Will return null if not found.

See Also

Server Class | Borland.StarTeam Namespace | getUsers


Server.HandleEvents Method

Places the current thread in an event-handling state.

While in an event-handling state, the thread is usually asleep, waking occasionally just long enough to ping the server (keeping the connection alive). The event-handling loop continues until some other thread (presumably, the event-handling thread for this Server object) calls interruptHandleEvents().

An application does not need to call handleEvents() in order to handle events; this is just a convenience method for applications that have nothing else they need to do while waiting for an event to occur.

Only one thread may call handleEvents() per Server object at any given time. After handleEvents() exits (as a result of a call to interruptHandleEvents), then handleEvents() may be called again by the same thread or by some other thread.

handleEvents() will fail if MPX is not enabled, or if there are no event-handlers running.

handleEvents() should not be called from within an event handler. (This would put the event-handling thread to sleep.)

public virtual void HandleEvents();

See Also

Server Class | Borland.StarTeam Namespace | interruptHandleEvents | enableMPX


Server.HasProductCode Method

Determines whether or not the server has a license for the specified product code. Will return false if the information is not available from the server.

public virtual bool HasProductCode(
Int32 code
);

Parameters

code
A product code.

Return Value

true if the server has a license for the specified product code.

See Also

Server Class | Borland.StarTeam Namespace | ProductCodes | getProductCodes | hasProductCodeInformation


Server.InterruptHandleEvents Method

Interrupts a handleEvents() loop, if there is one running. Usually called from within an event-handler, running in the event-handling thread for this Server object.

public virtual void InterruptHandleEvents();

See Also

Server Class | Borland.StarTeam Namespace | handleEvents


Server.IsTypeSupported Method

Return true if the type with the specified name is supported by this server.

public virtual bool IsTypeSupported(
String typeName
);

Parameters

typeName
the name of the type in question.

Return Value

true if the type is supported by this server.

See Also

Server Class | Borland.StarTeam Namespace | getTypes | typeForClassID | typeForName | getTypeNames


Server.LocateCacheAgent Method

locate a CacheAgent at a given address and port

public virtual CacheAgent LocateCacheAgent(
String hostName,
Int32 port
);

Parameters

hostName
String the address at which to look for a cache agent
port
int the port the port the cache agent is running on

Return Value

CacheAgent a CacheAgent if found, or null

See Also

Server Class | Borland.StarTeam Namespace


Server.LogOn Method

Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the priveleges associated with the supplied user credentials.

public virtual int LogOn(
String logOnName,
String password
);

Parameters

logOnName
the user's logon name
password
the user's password

Return Value

the userID for the logged on user

See Also

Server Class | Borland.StarTeam Namespace


Server.LogOnForWorkstation Method

Establishes a user-session with the remote server process, on behalf of the workstation with the given ID. This is useful when running on behalf of a remote client workstation.

public virtual int LogOnForWorkstation(
String logOnName,
String password,
GUID workStationID
);

Parameters

logOnName
The user's logon name.
password
The user's password.
workStationID
The GUID of the client workstation.

Return Value

The userID for the logged on user.

See Also

Server Class | Borland.StarTeam Namespace | GUID


Server.LogOnWithClientContext Method

Establishes a user-session with the remote server process, on behalf of the specified ClientContext. This is useful when running on behalf of a remote client workstation.

public virtual int LogOnWithClientContext(
String logOnName,
String password,
ClientContext context
);

Parameters

logOnName
The user's logon name.
password
The user's password.
context
The ClientContext of the client workstation.

Return Value

The userID for the logged on user.

See Also

Server Class | Borland.StarTeam Namespace | GUID


Server.NewMPXStatusEventSource Method

public MPXStatusEventSource NewMPXStatusEventSource();

See Also

Server Class | Borland.StarTeam Namespace


Server.NewProjectEventSource Method

public ProjectEventSource NewProjectEventSource();

See Also

Server Class | Borland.StarTeam Namespace


Server.NewServerControlEventSource Method

public ServerControlEventSource NewServerControlEventSource();

See Also

Server Class | Borland.StarTeam Namespace


Server.NewTypeEventSource Method

public TypeEventSource NewTypeEventSource();

See Also

Server Class | Borland.StarTeam Namespace


Server.NewUserEventSource Method

public UserEventSource NewUserEventSource();

See Also

Server Class | Borland.StarTeam Namespace


Server.Ping Method

Verifies that the server is responding and informs the server that this connection/user session is still active.

public virtual bool Ping();

Return Value

true if the server responds, false if the server fails to respond for any reason, including not being connected

See Also

Server Class | Borland.StarTeam Namespace


Server.PingMPXServer Method

Throws an appropriate MPXException if the MPX server is not running properly.

public virtual void PingMPXServer();

Exceptions

Exception Type | Condition
 | com.starbase.starteam.MPXException

See Also

Server Class | Borland.StarTeam Namespace


Reconnect Method

Borland StarTeam SDK for .NET

Server.Reconnect Method

Attempts to re-establish the connection to the server, re-opening any existing view sessions.

Uses the user credentials provided at logon time.

Overload List

Attempts to re-establish the connection to the server, re-opening any existing view sessions. Uses the user credentials provided at logon time.

public virtual void Reconnect();

Attempts to re-establish the connection to the server, re-opening any existing view sessions. The server will re-authenticate the connection using the user name provided at logon time and the given password.

public virtual void Reconnect(String);

See Also

Server Class | Borland.StarTeam Namespace | isAutoReconnectEnabled


Server.Reconnect Method ()

Attempts to re-establish the connection to the server, re-opening any existing view sessions.

Uses the user credentials provided at logon time.

public virtual void Reconnect();

See Also

Server Class | Borland.StarTeam Namespace | Server.Reconnect Overload List | isAutoReconnectEnabled


Server.Reconnect Method (String)

Attempts to re-establish the connection to the server, re-opening any existing view sessions.

The server will re-authenticate the connection using the user name provided at logon time and the given password.

public virtual void Reconnect(
String password
);

Parameters

password
The password used to re-authenticate the connection.

See Also

Server Class | Borland.StarTeam Namespace | Server.Reconnect Overload List


Server.RefreshAccounts Method

Refreshes cached User and Group information. Existing User and Group objects are modified in place whenever possible.

public virtual void RefreshAccounts();

See Also

Server Class | Borland.StarTeam Namespace | isRefreshAccountsRequired | refreshUsers | refreshGroups | discardAccounts


Server.RefreshGroups Method

Refreshes cached Group information to reflect recent changes to the repository. Modifies existing Group objects in place whenever possible.

public virtual void RefreshGroups();

See Also

Server Class | Borland.StarTeam Namespace | isRefreshGroupsRequired | getGroups | discardGroups


Server.RefreshTypes Method

Refreshes cached Type information to reflect recent changes to the repository. Existing Type and Property objects are modified in place, whenever possible. If MPX is enabled, refreshTypes() is optimized to avoid unnecessary server commands.

public virtual void RefreshTypes();

See Also

Server Class | Borland.StarTeam Namespace | getTypes | isRefreshTypesRequired | discardTypes | enableMPX


Server.RefreshUsers Method

Refreshes cached User information to reflect recent changes to the repository. Modifies existing User objects in place whenever possible. If MPX is enabled, refreshUsers() is optimized to avoid unnecessary server commands.

public virtual void RefreshUsers();

See Also

Server Class | Borland.StarTeam Namespace | isRefreshUsersRequired | getUsers | discardUsers | enableMPX


Server.SendMailFromView Method

Directs the StarTeam Server to send mail to the specified StarTeam users.

public virtual void SendMailFromView(
View view,
Int32[] to,
Int32[] cc,
Int32[] bcc,
String subject,
String body
);

Parameters

view
a valid view the sender has access to
to
the user IDs to whom the mail should be sent (To:)
cc
the user IDs to whom the mail should be cc'd (Cc:)
bcc
the user IDs to whom the mail should be blind-cc'd (Bcc:)
subject
the subject text for the mail message
body
the body of the mail message

See Also

Server Class | Borland.StarTeam Namespace


Server.SendMailWithAttachments Method

Directs the StarTeam Server to send mail to the specified StarTeam users.

public virtual void SendMailWithAttachments(
View view,
Int32[] to,
Int32[] cc,
Int32[] bcc,
String subject,
String body,
EmailAttachmentCollection attachments
);

Parameters

view
a valid view the sender has access to
to
the user IDs to whom the mail should be sent (To:)
cc
the user IDs to whom the mail should be cc'd (Cc:)
bcc
the user IDs to whom the mail should be blind-cc'd (Bcc:)
subject
the subject text for the mail message
body
the body of the mail message
attachments
The attachments to include with the email

See Also

Server Class | Borland.StarTeam Namespace


Server.SetForeignPasswordExplicit Method

Sets a password for the foreign archive specified.

public virtual void SetForeignPasswordExplicit(
String configPath,
Int32 type,
String password
);

Parameters

configPath
the path to the configuration file of the foreign archive.
type
type of the project.
password
the new password to the foreign archive.

See Also

Server Class | Borland.StarTeam Namespace


Server.ToString Method

Delegate ToString() to com.starbase.starteam.Server.

public override string ToString();

Return Value

com.starbase.starteam.Server.ToString()

See Also

Server Class | Borland.StarTeam Namespace


Server.TypeForClassID Method

Looks up the type information based on a type-number.

public virtual Type TypeForClassID(
Int32 classID
);

Parameters

classID
a server-assigned number that identifies the type

Return Value

the type information for the given type-number

Exceptions

Exception Type | Condition
 | com.starbase.starteam.TypeNotFoundException

See Also

Server Class | Borland.StarTeam Namespace | isTypeSupported | getTypes | typeForName | getTypeNames


Server.TypeForName Method

Returns a type instance for a type name.

public virtual Type TypeForName(
String typeName
);

Parameters

typeName
name of type in question. Must not be null.

Return Value

Type object representing the type information

Exceptions

Exception Type | Condition
 | System.ArgumentException
 | com.starbase.starteam.TypeNotFoundException

See Also

Server Class | Borland.StarTeam Namespace | isTypeSupported | getTypes | typeForClassID | getTypeNames


Server.Wrap Method

Dynamically wraps com.starbase.starteam.Server.

public static Server Wrap(
Server impl
);

Parameters

impl
com.starbase.starteam.Server to be wrapped.

Return Value

Server

See Also

Server Class | Borland.StarTeam Namespace


Server Type Conversions

The type conversions of the Server class are listed below. For a complete list of Server class members, see the Server Members topic.

Public Static Type Conversions

Implicit Server to Server Conversion Implicitly convert Server to com.starbase.starteam.Server.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Server Class | Server Members | Borland.StarTeam Namespace


Server Implicit Server to Server Conversion

Implicitly convert Server to com.starbase.starteam.Server.

public static implicit operator Server(
Server arg
);

Parameters

arg
Server to convert.

Return Value

com.starbase.starteam.Server

See Also

Server Class | Borland.StarTeam Namespace


ServerAdministration Class

The ServerAdministration class provides a convenient interface to perform various server level administration commands. The current set of operations are for field customization. Ultimately these methods should hang off of the core Type and Property objects but the refresh issues are too complex to deal with at this time. After calling any of the customization methods one should do a FULL refresh by discarding everything including the Server object itself and start over.

For a list of all members of this type, see ServerAdministration Members.

System.Object
ServerAdministration

public class ServerAdministration : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerAdministration Members | Borland.StarTeam Namespace


ServerAdministration Members

ServerAdministration overview

Public Static Properties

LOG_ALL
LOG_ASSERTIONS
LOG_EXCEPTIONS
LOG_MESSAGES
LOG_TYPE_PURGE
LOG_TYPE_SERVER
LOG_WARNINGS
SERVER_LOCKED
SERVER_LOCKED_EXCLUSIVELY
SERVER_UNLOCKED
UNKNOWN

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerAdministration.

Public Static Type Conversions

Implicit ServerAdministration to ServerAdministration Conversion Implicitly convert ServerAdministration to com.starbase.starteam.ServerAdministration.

Public Instance Constructors

ServerAdministration Constructor Construct ServerAdministration from com.starbase.starteam.ServerAdministration.

Public Instance Properties

ACL | [read/write] the access control list for this server. May return null.
Configuration | [read/write] The current server configuration options.
GroupAccounts | [read] all of the active group accounts on the server.
HiveManager | [read] the HiveManager.
IsRefreshAccountsRequired | [read] true if account information may be out of date.
LicenseInformation | [read] Information about the licenses registered on this server, or null if the license information is not available.
LicenseUsage | [read] a license usage report from the server.
Log | [read] the server log.
Policy | [read/write] The current system policy options.
PurgeControl | [read] PurgeControl
Server | [read] Server
ServerLockStatus | [read] the "locked", "locked exclusively" or "unlocked" status of the server.
UserAccounts | [read] all of the active user accounts on the server.

Public Instance Methods

AddDoubleField | Adds a new floating point double field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddDoubleFieldEx | Adds a new floating point double field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddEnumeratedField | Adds a new Enumerated field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddEnumeratedFieldEx | Adds a new Enumerated field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddIntegerField | Adds a new Integer field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddIntegerFieldEx | Adds a new Integer field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddRequiredTextField | Adds a new required Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddRequiredTextFieldEx | Adds a new required Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddRequiredUserField | Adds a new required User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddRequiredUserFieldEx | Adds a new required User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddTextField | Adds a new Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddTextFieldEx | Adds a new Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddTimeField | Adds a new Date/Time field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddTimeFieldEx | Adds a new Date/Time field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddUserField | Adds a new User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddUserFieldEx | Adds a new User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
DiscardAccounts | Discards all cached UserAccount and GroupAccount information. It will be re-fetched from the server on demand (even when MPX is enabled).
EnableProperty | Set the specified property to enabled or disabled.
Equals | Delegate Equals() to com.starbase.starteam.ServerAdministration.
FindGroupAccount | Returns the GroupAccount object for the given ID.
FindUserAccount | Returns the User object for the given ID.
GenerateDiagnosticDump | Creates a diagnostic file and places it in the server configurations' log path. While creating the file, the server does no other processing This may take several minutes Use only at the direction of Borland Technical Suport Throws an SDKRuntimeException if the call fails
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerAdministration.
GetNamedConfigOptions | Return a String array of values that matches the input String array of option names. This method is supported by server release 6.0 and later; ignored for earlier releases.
GetSecurityLog | Returns an array of SecurityLogEntry objects for this server, for the specified security event type.
GetServerCommandStats | Retrieves the server's command statistics and writes it to the specified output stream.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Returns true if desired permissions are granted
LockServer | Puts the server in "Locked" mode. No one can perform operations. Useful for freezing server for database backups.
LockServerExclusively | Puts the server in "LockedExclusively" mode: only the locker can perform operations. Useful for restricting server access during replication operations.
ModifyDoubleField | Modify a floating point double property for the specified Type.
ModifyDoubleFieldEx | Modify a floating point double property for the specified Type.
ModifyEnumeratedField | Modify an Enumerated property for the specified Type. If an existing Enum is not present in the enums argument then that enum will be disabled. If it is listed and the name has changed then the display name of the enumerated value will be changed. If an Enum appears in the enums argument that is not already a valid enum for this field then the new enum value will be added.
ModifyEnumeratedFieldEx | Modify an Enumerated property for the specified Type. Any EnumeratedValues passed in the enums argument that are already legal values for this property are automatically enabled, if necessary. Any existing EnumeratedValues passed that are not passed in the enums argument are automatically disabled, if necessary. Any changes to any of the display names are saved in the property definition. The sort order of existing EnumeratedValues is unchanged. Any new EnumeratedValues passed in the enum argument are added to the property definition at the end of the list.
ModifyIntegerField | Modify an Integer property for the specified Type.
ModifyIntegerFieldEx | Modify an Integer property for the specified Type.
ModifyTextField | Modify a Text property for the specified Type.
ModifyTextFieldEx | Modify a Text property for the specified Type.
ModifyTimeField | Modify a Time property for the specified Type.
ModifyTimeFieldEx | Modify a Time property for the specified Type.
ModifyUserField | Modify a User property for the specified Type.
ModifyUserFieldEx | Modify a User property for the specified Type.
RefreshAccounts | Updates cached UserAccount and GroupAccount information to reflect recent changes to the repository. Existing UserAccount and GroupAccount objects are modified in place whenever possible.
RestartServer | Shuts down and restarts the server. This has the side-effect of making the associated Server instance rather useless as the StarTeam Server it was connected to will be shut down and restarted.
SetFieldRequired | Change the required/non-required status of a custom-defined User or Text property.
SetNamedConfigOptions | Overloaded. Set a group of named configuration options. This method is supported by server release 6.0 and later; ignored for earlier releases.
ShutdownServer | Shuts down the server. This has the obvious side-effect of making the associated Server instance rather useless, as the StarTeam Server it was connected to will be shut down.
TestDirectoryServiceSettings | Tests this set of Directory Service parameters. Returns true if the test succeeds, otherwise false. Only meaningful for servers 7.0 and later; always returns false for earlier releases.
ToString | Delegate ToString() to com.starbase.starteam.ServerAdministration.
UnlockServer | Unlocks a server in "Locked" mode.
UpdateEnumeratedField | Modifies an existing Enumerated property. The EnumeratedValues for this property must be completely specified; that is, the list must include all existing enumerated values for this property, including both enabled and disabled ones. The list may also include new enumerated values that were not previously valid. The sort order of the EnumeratedValues in the property definition is updated to reflect the order as specified here. updateEnumeratedField() does not automatically change the enabled/disabled state of any of the EnumeratedValues provided. You can change the state by calling EnumeratedValue.setEnabled() prior to calling updateEnumeratedField(). Any changes to any of the display names are saved in the property definition.
UpdateLicenseUsage | Notify server of client license usage
WriteLogFile | Retrieves the server log and writes it to the specified file.
WriteServerCommandStats | Retrieves the server's command statistics and writes it to the specified file.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration Constructor

Construct ServerAdministration from com.starbase.starteam.ServerAdministration.

public ServerAdministration(
ServerAdministration impl
);

Parameters

impl
The com.starbase.starteam.ServerAdministration to be wrapped.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration Properties

The properties of the ServerAdministration class are listed below. For a complete list of ServerAdministration class members, see the ServerAdministration Members topic.

Public Static Properties

LOG_ALL
LOG_ASSERTIONS
LOG_EXCEPTIONS
LOG_MESSAGES
LOG_TYPE_PURGE
LOG_TYPE_SERVER
LOG_WARNINGS
SERVER_LOCKED
SERVER_LOCKED_EXCLUSIVELY
SERVER_UNLOCKED
UNKNOWN

Public Instance Properties

ACL | [read/write] the access control list for this server. May return null.
Configuration | [read/write] The current server configuration options.
GroupAccounts | [read] all of the active group accounts on the server.
HiveManager | [read] the HiveManager.
IsRefreshAccountsRequired | [read] true if account information may be out of date.
LicenseInformation | [read] Information about the licenses registered on this server, or null if the license information is not available.
LicenseUsage | [read] a license usage report from the server.
Log | [read] the server log.
Policy | [read/write] The current system policy options.
PurgeControl | [read] PurgeControl
Server | [read] Server
ServerLockStatus | [read] the "locked", "locked exclusively" or "unlocked" status of the server.
UserAccounts | [read] all of the active user accounts on the server.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ACL Property

Borland StarTeam SDK for .NET

ServerAdministration.ACL Property

[read/write] the access control list for this server. May return null.

public virtual ACL ACL {get; set;}

Property Value

the access control list for this server. May return null.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


Configuration Property

Borland StarTeam SDK for .NET

ServerAdministration.Configuration Property

[read/write] The current server configuration options.

public virtual ServerConfiguration Configuration {get; set;}

Property Value

The current server configuration options.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


GroupAccounts Property

Borland StarTeam SDK for .NET

ServerAdministration.GroupAccounts Property

[read] all of the active group accounts on the server.

public virtual GroupAccountCollection GroupAccounts {get;}

Property Value

all of the active group accounts on the server.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


HiveManager Property

Borland StarTeam SDK for .NET

ServerAdministration.HiveManager Property

[read] the HiveManager.

public virtual HiveManager HiveManager {get;}

Property Value

the HiveManager.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


IsRefreshAccountsRequired Property

Borland StarTeam SDK for .NET

ServerAdministration.IsRefreshAccountsRequired Property

[read] true if account information may be out of date.

public virtual Boolean IsRefreshAccountsRequired {get;}

Property Value

true if account information may be out of date.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


LicenseInformation Property

Borland StarTeam SDK for .NET

ServerAdministration.LicenseInformation Property

[read] Information about the licenses registered on this server, or null if the license information is not available.

public virtual ServerLicenseInfo LicenseInformation {get;}

Property Value

Information about the licenses registered on this server, or null if the license information is not available.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


LicenseUsage Property

Borland StarTeam SDK for .NET

ServerAdministration.LicenseUsage Property

[read] a license usage report from the server.

public virtual LicenseUsage LicenseUsage {get;}

Property Value

a license usage report from the server.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


Log Property

Borland StarTeam SDK for .NET

ServerAdministration.Log Property

[read] the server log.

public virtual String Log {get;}

Property Value

the server log.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


LOG_ALL Property

Borland StarTeam SDK for .NET

ServerAdministration.LOG_ALL Property

public static Int32 LOG_ALL {get;}

See Also

ServerAdministration Class | Borland.StarTeam Namespace


LOG_ASSERTIONS Property

Borland StarTeam SDK for .NET

ServerAdministration.LOG_ASSERTIONS Property

public static Int32 LOG_ASSERTIONS {get;}

See Also

ServerAdministration Class | Borland.StarTeam Namespace


LOG_EXCEPTIONS Property

Borland StarTeam SDK for .NET

ServerAdministration.LOG_EXCEPTIONS Property

public static Int32 LOG_EXCEPTIONS {get;}

See Also

ServerAdministration Class | Borland.StarTeam Namespace


LOG_MESSAGES Property

Borland StarTeam SDK for .NET

ServerAdministration.LOG_MESSAGES Property

public static Int32 LOG_MESSAGES {get;}

See Also

ServerAdministration Class | Borland.StarTeam Namespace


LOG_TYPE_PURGE Property

Borland StarTeam SDK for .NET

ServerAdministration.LOG_TYPE_PURGE Property

public static Int32 LOG_TYPE_PURGE {get;}

See Also

ServerAdministration Class | Borland.StarTeam Namespace


LOG_TYPE_SERVER Property

Borland StarTeam SDK for .NET

ServerAdministration.LOG_TYPE_SERVER Property

public static Int32 LOG_TYPE_SERVER {get;}

See Also

ServerAdministration Class | Borland.StarTeam Namespace


LOG_WARNINGS Property

Borland StarTeam SDK for .NET

ServerAdministration.LOG_WARNINGS Property

public static Int32 LOG_WARNINGS {get;}

See Also

ServerAdministration Class | Borland.StarTeam Namespace


Policy Property

Borland StarTeam SDK for .NET

ServerAdministration.Policy Property

[read/write] The current system policy options.

public virtual SystemPolicy Policy {get; set;}

Property Value

The current system policy options.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


PurgeControl Property

Borland StarTeam SDK for .NET

ServerAdministration.PurgeControl Property

[read] PurgeControl

public virtual PurgeControl PurgeControl {get;}

Property Value

PurgeControl

See Also

ServerAdministration Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ServerAdministration.Server Property

[read] Server

public virtual Server Server {get;}

Property Value

Server

See Also

ServerAdministration Class | Borland.StarTeam Namespace


SERVER_LOCKED Property

Borland StarTeam SDK for .NET

ServerAdministration.SERVER_LOCKED Property

public static Int32 SERVER_LOCKED {get;}

See Also

ServerAdministration Class | Borland.StarTeam Namespace


SERVER_LOCKED_EXCLUSIVELY Property

Borland StarTeam SDK for .NET

ServerAdministration.SERVER_LOCKED_EXCLUSIVELY Property

public static Int32 SERVER_LOCKED_EXCLUSIVELY {get;}

See Also

ServerAdministration Class | Borland.StarTeam Namespace


SERVER_UNLOCKED Property

Borland StarTeam SDK for .NET

ServerAdministration.SERVER_UNLOCKED Property

public static Int32 SERVER_UNLOCKED {get;}

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerLockStatus Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLockStatus Property

[read] the "locked", "locked exclusively" or "unlocked" status of the server.

public virtual Int32 ServerLockStatus {get;}

Property Value

the "locked", "locked exclusively" or "unlocked" status of the server.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

ServerAdministration.UNKNOWN Property

public static Int32 UNKNOWN {get;}

See Also

ServerAdministration Class | Borland.StarTeam Namespace


UserAccounts Property

Borland StarTeam SDK for .NET

ServerAdministration.UserAccounts Property

[read] all of the active user accounts on the server.

public virtual UserAccountCollection UserAccounts {get;}

Property Value

all of the active user accounts on the server.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration Methods

The methods of the ServerAdministration class are listed below. For a complete list of ServerAdministration class members, see the ServerAdministration Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerAdministration.

Public Instance Methods

AddDoubleField | Adds a new floating point double field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddDoubleFieldEx | Adds a new floating point double field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddEnumeratedField | Adds a new Enumerated field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddEnumeratedFieldEx | Adds a new Enumerated field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddIntegerField | Adds a new Integer field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddIntegerFieldEx | Adds a new Integer field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddRequiredTextField | Adds a new required Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddRequiredTextFieldEx | Adds a new required Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddRequiredUserField | Adds a new required User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddRequiredUserFieldEx | Adds a new required User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddTextField | Adds a new Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddTextFieldEx | Adds a new Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddTimeField | Adds a new Date/Time field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddTimeFieldEx | Adds a new Date/Time field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddUserField | Adds a new User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
AddUserFieldEx | Adds a new User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".
DiscardAccounts | Discards all cached UserAccount and GroupAccount information. It will be re-fetched from the server on demand (even when MPX is enabled).
EnableProperty | Set the specified property to enabled or disabled.
Equals | Delegate Equals() to com.starbase.starteam.ServerAdministration.
FindGroupAccount | Returns the GroupAccount object for the given ID.
FindUserAccount | Returns the User object for the given ID.
GenerateDiagnosticDump | Creates a diagnostic file and places it in the server configurations' log path. While creating the file, the server does no other processing This may take several minutes Use only at the direction of Borland Technical Suport Throws an SDKRuntimeException if the call fails
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerAdministration.
GetNamedConfigOptions | Return a String array of values that matches the input String array of option names. This method is supported by server release 6.0 and later; ignored for earlier releases.
GetSecurityLog | Returns an array of SecurityLogEntry objects for this server, for the specified security event type.
GetServerCommandStats | Retrieves the server's command statistics and writes it to the specified output stream.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Returns true if desired permissions are granted
LockServer | Puts the server in "Locked" mode. No one can perform operations. Useful for freezing server for database backups.
LockServerExclusively | Puts the server in "LockedExclusively" mode: only the locker can perform operations. Useful for restricting server access during replication operations.
ModifyDoubleField | Modify a floating point double property for the specified Type.
ModifyDoubleFieldEx | Modify a floating point double property for the specified Type.
ModifyEnumeratedField | Modify an Enumerated property for the specified Type. If an existing Enum is not present in the enums argument then that enum will be disabled. If it is listed and the name has changed then the display name of the enumerated value will be changed. If an Enum appears in the enums argument that is not already a valid enum for this field then the new enum value will be added.
ModifyEnumeratedFieldEx | Modify an Enumerated property for the specified Type. Any EnumeratedValues passed in the enums argument that are already legal values for this property are automatically enabled, if necessary. Any existing EnumeratedValues passed that are not passed in the enums argument are automatically disabled, if necessary. Any changes to any of the display names are saved in the property definition. The sort order of existing EnumeratedValues is unchanged. Any new EnumeratedValues passed in the enum argument are added to the property definition at the end of the list.
ModifyIntegerField | Modify an Integer property for the specified Type.
ModifyIntegerFieldEx | Modify an Integer property for the specified Type.
ModifyTextField | Modify a Text property for the specified Type.
ModifyTextFieldEx | Modify a Text property for the specified Type.
ModifyTimeField | Modify a Time property for the specified Type.
ModifyTimeFieldEx | Modify a Time property for the specified Type.
ModifyUserField | Modify a User property for the specified Type.
ModifyUserFieldEx | Modify a User property for the specified Type.
RefreshAccounts | Updates cached UserAccount and GroupAccount information to reflect recent changes to the repository. Existing UserAccount and GroupAccount objects are modified in place whenever possible.
RestartServer | Shuts down and restarts the server. This has the side-effect of making the associated Server instance rather useless as the StarTeam Server it was connected to will be shut down and restarted.
SetFieldRequired | Change the required/non-required status of a custom-defined User or Text property.
SetNamedConfigOptions | Overloaded. Set a group of named configuration options. This method is supported by server release 6.0 and later; ignored for earlier releases.
ShutdownServer | Shuts down the server. This has the obvious side-effect of making the associated Server instance rather useless, as the StarTeam Server it was connected to will be shut down.
TestDirectoryServiceSettings | Tests this set of Directory Service parameters. Returns true if the test succeeds, otherwise false. Only meaningful for servers 7.0 and later; always returns false for earlier releases.
ToString | Delegate ToString() to com.starbase.starteam.ServerAdministration.
UnlockServer | Unlocks a server in "Locked" mode.
UpdateEnumeratedField | Modifies an existing Enumerated property. The EnumeratedValues for this property must be completely specified; that is, the list must include all existing enumerated values for this property, including both enabled and disabled ones. The list may also include new enumerated values that were not previously valid. The sort order of the EnumeratedValues in the property definition is updated to reflect the order as specified here. updateEnumeratedField() does not automatically change the enabled/disabled state of any of the EnumeratedValues provided. You can change the state by calling EnumeratedValue.setEnabled() prior to calling updateEnumeratedField(). Any changes to any of the display names are saved in the property definition.
UpdateLicenseUsage | Notify server of client license usage
WriteLogFile | Retrieves the server log and writes it to the specified file.
WriteServerCommandStats | Retrieves the server's command statistics and writes it to the specified file.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddDoubleField Method

Adds a new floating point double field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddDoubleField(
Type type,
String sqlname,
String displayName,
Double defaultValue
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayName
The String that will be used when GUIs display the field
defaultValue
The default value to use when creating a new item.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddDoubleFieldEx Method

Adds a new floating point double field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddDoubleFieldEx(
Type type,
String sqlname,
Translations displayNames,
Double defaultValue
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayNames
The translations to use for the property display name
defaultValue
The default value to use when creating a new item.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddEnumeratedField Method

Adds a new Enumerated field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddEnumeratedField(
Type type,
String sqlname,
String displayName,
EnumeratedValueCollection enums,
Int32 defaultCode
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayName
The String that will be used when GUIs display the field
enums
An array of the EnumeratedValues this field will support.
defaultCode
The code value of the default EnumeratedValue to use when creating new items of this type

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddEnumeratedFieldEx Method

Adds a new Enumerated field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddEnumeratedFieldEx(
Type type,
String sqlname,
Translations displayNames,
EnumeratedValueCollection enums,
Int32 defaultCode
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayNames
The translations to use for the property display name
enums
An array of the EnumeratedValues this field will support.
defaultCode
The code value of the default EnumeratedValue to use when creating new items of this type

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddIntegerField Method

Adds a new Integer field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddIntegerField(
Type type,
String sqlname,
String displayName,
Int32 defaultValue
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayName
The String that will be used when GUIs display the field
defaultValue
The default value to use when creating a new item.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddIntegerFieldEx Method

Adds a new Integer field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddIntegerFieldEx(
Type type,
String sqlname,
Translations displayNames,
Int32 defaultValue
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayNames
The translations to use for the property display name
defaultValue
The default value to use when creating a new item.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddRequiredTextField Method

Adds a new required Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddRequiredTextField(
Type type,
String sqlname,
String displayName,
Int32 maxLength
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayName
The String that will be used when GUIs display the field
maxLength
The maximum length of Strings that can be stored in this field

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddRequiredTextFieldEx Method

Adds a new required Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddRequiredTextFieldEx(
Type type,
String sqlname,
Translations displayNames,
Int32 maxLength
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayNames
The translations to use for the property display name
maxLength
The maximum length of Strings that can be stored in this field

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddRequiredUserField Method

Adds a new required User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddRequiredUserField(
Type type,
String sqlname,
String displayName
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayName
The String that will be used when GUIs display the field

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddRequiredUserFieldEx Method

Adds a new required User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddRequiredUserFieldEx(
Type type,
String sqlname,
Translations displayNames
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayNames
The translations to use for the property display name

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddTextField Method

Adds a new Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddTextField(
Type type,
String sqlname,
String displayName,
Int32 maxLength
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayName
The String that will be used when GUIs display the field
maxLength
The maximum length of Strings that can be stored in this field

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddTextFieldEx Method

Adds a new Text field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddTextFieldEx(
Type type,
String sqlname,
Translations displayNames,
Int32 maxLength
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayNames
The translations to use for the property display name
maxLength
The maximum length of Strings that can be stored in this field

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddTimeField Method

Adds a new Date/Time field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddTimeField(
Type type,
String sqlname,
String displayName,
DateTime defaultTime
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayName
The String that will be used when GUIs display the field
defaultTime
The default time to use when creating a new item.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddTimeFieldEx Method

Adds a new Date/Time field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddTimeFieldEx(
Type type,
String sqlname,
Translations displayNames,
DateTime defaultTime
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayNames
The translations to use for the property display name
defaultTime
The default time to use when creating a new item.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddUserField Method

Adds a new User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddUserField(
Type type,
String sqlname,
String displayName
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayName
The String that will be used when GUIs display the field

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.AddUserFieldEx Method

Adds a new User field to the specified Type. Note that when you later want to use the new field you must access it with the sqlname you provided prefixed with "Usr_".

public virtual void AddUserFieldEx(
Type type,
String sqlname,
Translations displayNames
);

Parameters

type
The Type object being modified
sqlname
The database field name for this type
displayNames
The translations to use for the property display name

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ServerAdministration

Implements

IWrapper.Unwrap

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.DiscardAccounts Method

Discards all cached UserAccount and GroupAccount information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void DiscardAccounts();

See Also

ServerAdministration Class | Borland.StarTeam Namespace | getUserAccounts | getGroupAccounts | refreshAccounts


ServerAdministration.EnableProperty Method

Set the specified property to enabled or disabled.

public virtual void EnableProperty(
Property prop,
Boolean enabled
);

Parameters

prop
the property being modified
enabled
true if the property is to be enabled and false otherwise

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.Equals Method

Delegate Equals() to com.starbase.starteam.ServerAdministration.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ServerAdministration.Equals(obj).

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.FindGroupAccount Method

Returns the GroupAccount object for the given ID.

public virtual GroupAccount FindGroupAccount(
Int32 groupID
);

Parameters

groupID
the Group ID in question

Return Value

the GroupAccount object with the given ID. Will return null if not found.

See Also

ServerAdministration Class | Borland.StarTeam Namespace | getGroupAccounts


ServerAdministration.FindUserAccount Method

Returns the User object for the given ID.

public virtual UserAccount FindUserAccount(
Int32 userID
);

Parameters

userID
the user ID in question

Return Value

the UserAccount object with the given ID. Will return null if not found.

See Also

ServerAdministration Class | Borland.StarTeam Namespace | getUserAccounts


ServerAdministration.GenerateDiagnosticDump Method

Creates a diagnostic file and places it in the server configurations' log path. While creating the file, the server does no other processing This may take several minutes Use only at the direction of Borland Technical Suport Throws an SDKRuntimeException if the call fails

public virtual string GenerateDiagnosticDump(
Int32 minidumptype
);

Parameters

minidumptype
A mini-dump type

Return Value

the result of the dump command being executed

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ServerAdministration.

public override int GetHashCode();

Return Value

com.starbase.starteam.ServerAdministration.GetHashCode().

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.GetNamedConfigOptions Method

Return a String array of values that matches the input String array of option names. This method is supported by server release 6.0 and later; ignored for earlier releases.

public virtual string[] GetNamedConfigOptions(
String[] names
);

Parameters

names
the key values of the options to retrieve.

Return Value

a String array of values that matches the input String array of option names.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.GetSecurityLog Method

Returns an array of SecurityLogEntry objects for this server, for the specified security event type.

public virtual SecurityLogEntryCollection GetSecurityLog(
Int32 eventType
);

Parameters

eventType
an integer value that specifies the desired security event type. Must be one of the values defined in SecurityLogEntry.SecurityEventType.

Return Value

An array of SecurityLogEntry objects for this server, for the specified security event type.

See Also

ServerAdministration Class | Borland.StarTeam Namespace | SecurityLogEntry.SecurityEventType


ServerAdministration.GetServerCommandStats Method

Retrieves the server's command statistics and writes it to the specified output stream.

public virtual void GetServerCommandStats(
Stream _out
);

Parameters

_out

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ServerAdministration Class | Borland.StarTeam Namespace | hasServerCommandStats


ServerAdministration.HasPermission Method

Returns true if desired permissions are granted

public virtual bool HasPermission(
Int32 permissions
);

Parameters

permissions
the desired permissions

See Also

ServerAdministration Class | Borland.StarTeam Namespace | Permission


ServerAdministration.LockServer Method

Puts the server in "Locked" mode. No one can perform operations. Useful for freezing server for database backups.

public virtual void LockServer();

See Also

ServerAdministration Class | Borland.StarTeam Namespace | getServerLockStatus | lockServerExclusively | unlockServer


ServerAdministration.LockServerExclusively Method

Puts the server in "LockedExclusively" mode: only the locker can perform operations. Useful for restricting server access during replication operations.

public virtual void LockServerExclusively();

See Also

ServerAdministration Class | Borland.StarTeam Namespace | getServerLockStatus | lockServer | unlockServer | hasServerExclusiveLock


ServerAdministration.ModifyDoubleField Method

Modify a floating point double property for the specified Type.

public virtual void ModifyDoubleField(
Type type,
Property prop,
Boolean enabled,
String name,
Double defaultValue
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
name
The new display name for this field.
defaultValue
The new default value for this field.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ModifyDoubleFieldEx Method

Modify a floating point double property for the specified Type.

public virtual void ModifyDoubleFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names,
Double defaultValue
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
names
The display name translations to use for this property.
defaultValue
The new default value for this field.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ModifyEnumeratedField Method

Modify an Enumerated property for the specified Type. If an existing Enum is not present in the enums argument then that enum will be disabled. If it is listed and the name has changed then the display name of the enumerated value will be changed. If an Enum appears in the enums argument that is not already a valid enum for this field then the new enum value will be added.

public virtual void ModifyEnumeratedField(
Type type,
Property prop,
Boolean enabled,
String name,
EnumeratedValueCollection enums,
Int32 defaultCode
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
name
The new display name for this field.
enums
The list of enabled Enum objects for this field.
defaultCode
The code for the new default Enum.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ModifyEnumeratedFieldEx Method

Modify an Enumerated property for the specified Type.

Any EnumeratedValues passed in the enums argument that are already legal values for this property are automatically enabled, if necessary. Any existing EnumeratedValues passed that are not passed in the enums argument are automatically disabled, if necessary. Any changes to any of the display names are saved in the property definition. The sort order of existing EnumeratedValues is unchanged.

Any new EnumeratedValues passed in the enum argument are added to the property definition at the end of the list.

public virtual void ModifyEnumeratedFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names,
EnumeratedValueCollection enums,
Int32 defaultCode
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
names
The display name translations to use for this property.
enums
The list of enabled Enum objects for this field.
defaultCode
The code for the new default Enum.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ModifyIntegerField Method

Modify an Integer property for the specified Type.

public virtual void ModifyIntegerField(
Type type,
Property prop,
Boolean enabled,
String name,
Int32 defaultValue
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
name
The new display name for this field.
defaultValue
The new default value for this field.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ModifyIntegerFieldEx Method

Modify an Integer property for the specified Type.

public virtual void ModifyIntegerFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names,
Int32 defaultValue
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
names
The display name translations to use for this property.
defaultValue
The new default value for this field.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ModifyTextField Method

Modify a Text property for the specified Type.

public virtual void ModifyTextField(
Type type,
Property prop,
Boolean enabled,
String name
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
name
The String that will be used when GUIs display the field

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ModifyTextFieldEx Method

Modify a Text property for the specified Type.

public virtual void ModifyTextFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
names
The display name translations to use for this property.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ModifyTimeField Method

Modify a Time property for the specified Type.

public virtual void ModifyTimeField(
Type type,
Property prop,
Boolean enabled,
String name,
DateTime defaultValue
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
name
The new display name for this field.
defaultValue
The new default value for this field.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ModifyTimeFieldEx Method

Modify a Time property for the specified Type.

public virtual void ModifyTimeFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names,
DateTime defaultValue
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
names
The display name translations to use for this property.
defaultValue
The new default value for this field.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ModifyUserField Method

Modify a User property for the specified Type.

public virtual void ModifyUserField(
Type type,
Property prop,
Boolean enabled,
String name
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
name
The new display name for this field.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ModifyUserFieldEx Method

Modify a User property for the specified Type.

public virtual void ModifyUserFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names
);

Parameters

type
The Type object being modified
prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
names
The display name translations to use for this property.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.RefreshAccounts Method

Updates cached UserAccount and GroupAccount information to reflect recent changes to the repository. Existing UserAccount and GroupAccount objects are modified in place whenever possible.

public virtual void RefreshAccounts();

See Also

ServerAdministration Class | Borland.StarTeam Namespace | isRefreshAccountsRequired | populateAccounts | discardAccounts


ServerAdministration.RestartServer Method

Shuts down and restarts the server. This has the side-effect of making the associated Server instance rather useless as the StarTeam Server it was connected to will be shut down and restarted.

public virtual void RestartServer();

See Also

ServerAdministration Class | Borland.StarTeam Namespace | hasServerShutdown


ServerAdministration.SetFieldRequired Method

Change the required/non-required status of a custom-defined User or Text property.

public virtual void SetFieldRequired(
Property prop,
Boolean bRequired
);

Parameters

prop
The Property object being modified.
bRequired
Specify if the field is to be required or not.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


SetNamedConfigOptions Method

Borland StarTeam SDK for .NET

ServerAdministration.SetNamedConfigOptions Method

Overload List

public virtual void SetNamedConfigOptions(Hashtable);

Set a group of named configuration options. This method is supported by server release 6.0 and later; ignored for earlier releases.

public virtual void SetNamedConfigOptions(String[],String[]);

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.SetNamedConfigOptions Method (Hashtable)

public virtual void SetNamedConfigOptions(
Hashtable options
);

See Also

ServerAdministration Class | Borland.StarTeam Namespace | ServerAdministration.SetNamedConfigOptions Overload List


ServerAdministration.SetNamedConfigOptions Method (String[], String[])

Set a group of named configuration options. This method is supported by server release 6.0 and later; ignored for earlier releases.

public virtual void SetNamedConfigOptions(
String[] names,
String[] values
);

Parameters

names
names of the options whose values are set.
values
values of the options to be set, in same sequence a names.

See Also

ServerAdministration Class | Borland.StarTeam Namespace | ServerAdministration.SetNamedConfigOptions Overload List


ServerAdministration.ShutdownServer Method

Shuts down the server. This has the obvious side-effect of making the associated Server instance rather useless, as the StarTeam Server it was connected to will be shut down.

public virtual void ShutdownServer();

See Also

ServerAdministration Class | Borland.StarTeam Namespace | hasServerShutdown


ServerAdministration.TestDirectoryServiceSettings Method

Tests this set of Directory Service parameters. Returns true if the test succeeds, otherwise false. Only meaningful for servers 7.0 and later; always returns false for earlier releases.

public virtual bool TestDirectoryServiceSettings(
String URL,
Int32 port,
Boolean bUseSecureDirectoryService
);

Parameters

URL
port
bUseSecureDirectoryService

Return Value

true if the test succeeds, otherwise false.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.ToString Method

Delegate ToString() to com.starbase.starteam.ServerAdministration.

public override string ToString();

Return Value

com.starbase.starteam.ServerAdministration.ToString()

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.UnlockServer Method

Unlocks a server in "Locked" mode.

public virtual void UnlockServer();

See Also

ServerAdministration Class | Borland.StarTeam Namespace | getServerLockStatus | lockServer | lockServerExclusively


ServerAdministration.UpdateEnumeratedField Method

Modifies an existing Enumerated property.

The EnumeratedValues for this property must be completely specified; that is, the list must include all existing enumerated values for this property, including both enabled and disabled ones. The list may also include new enumerated values that were not previously valid.

The sort order of the EnumeratedValues in the property definition is updated to reflect the order as specified here.

updateEnumeratedField() does not automatically change the enabled/disabled state of any of the EnumeratedValues provided. You can change the state by calling EnumeratedValue.setEnabled() prior to calling updateEnumeratedField().

Any changes to any of the display names are saved in the property definition.

public virtual void UpdateEnumeratedField(
Property prop,
Boolean enabled,
Translations names,
EnumeratedValueCollection enums,
Int32 defaultCode
);

Parameters

prop
The Property object being modified.
enabled
Specify if the field is not be enabled or disabled.
names
The display name translations to use for this property.
enums
The list of enabled Enum objects for this field.
defaultCode
The code for the new default Enum.

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.UpdateLicenseUsage Method

Notify server of client license usage

public virtual void UpdateLicenseUsage(
String keys,
ServerInfoCollection servers
);

Parameters

keys
servers

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.Wrap Method

Dynamically wraps com.starbase.starteam.ServerAdministration.

public static ServerAdministration Wrap(
ServerAdministration impl
);

Parameters

impl
com.starbase.starteam.ServerAdministration to be wrapped.

Return Value

ServerAdministration

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration.WriteLogFile Method

Retrieves the server log and writes it to the specified file.

public virtual void WriteLogFile(
FileInfo _out,
Int32 logType,
Int32 logMode
);

Parameters

_out
logType
Log type (LOG_TYPE_SERVER, LOG_TYPE_PURGE, other types to be defined.)
logMode
Log mode. Valid values are: 1. LOG_ALL, LOG_ASSERTIONS, LOG_EXCEPTIONS, LOG_MESSAGES, LOG_WARNINGS or a combination of them. 2. LOG_MODE_ALL or LOG_MODE_ERRORS (note these are deprecated.)

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ServerAdministration Class | Borland.StarTeam Namespace | getLog | LOG_ALL | LOG_ASSERTIONS | LOG_EXCEPTIONS | LOG_MESSAGES | LOG_WARNINGS


ServerAdministration.WriteServerCommandStats Method

Retrieves the server's command statistics and writes it to the specified file.

public virtual void WriteServerCommandStats(
FileInfo file
);

Parameters

file
the file to which the commands statistics will be written.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerAdministration Type Conversions

The type conversions of the ServerAdministration class are listed below. For a complete list of ServerAdministration class members, see the ServerAdministration Members topic.

Public Static Type Conversions

Implicit ServerAdministration to ServerAdministration Conversion Implicitly convert ServerAdministration to com.starbase.starteam.ServerAdministration.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerAdministration Class | ServerAdministration Members | Borland.StarTeam Namespace


ServerAdministration Implicit ServerAdministration to ServerAdministration Conversion

Implicitly convert ServerAdministration to com.starbase.starteam.ServerAdministration.

public static implicit operator ServerAdministration(
ServerAdministration arg
);

Parameters

arg
ServerAdministration to convert.

Return Value

com.starbase.starteam.ServerAdministration

See Also

ServerAdministration Class | Borland.StarTeam Namespace


ServerCommandEventArgs Class

For a list of all members of this type, see ServerCommandEventArgs Members.

System.Object
EventArgs
ServerCommandEventArgs

public class ServerCommandEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerCommandEventArgs Members | Borland.StarTeam Namespace


ServerCommandEventArgs Members

ServerCommandEventArgs overview

Public Static Type Conversions

Implicit ServerCommandEventArgs to ServerCommandEvent Conversion Implicitly convert ServerCommandEventArgs to com.starbase.starteam.vts.comm.ServerCommandEvent.

Public Instance Properties

BytesReceived | [read] The total number of bytes returned by the server to the client, or zero if this is a start event.
BytesSent | [read] The total number of bytes sent from the client to the server, or zero if this is a start event.
CommandCount | [read] The number of commands executed in this command session.
CommandID | [read] The internal ID assigned to this command.
CommandName | [read] A symbolic name that describes this command ID.
CommandTime | [read] The total execution time of this command, in milliseconds, or zero if this is a start event.
Error |
IsCommandFinished | [read] false for a start event; true for an end or error event.
IsPropertyFetchTriggered | [read] boolean true if this command triggers a property fetch for a single item
IsSuccessful | [read] true if the command terminated normally; false if an exception occurred during the execution of the command.
ItemsExpected | [read] The total number of items to be processed, or zero if this server command is not a bulk command that processes items in chunks.
ItemsSoFar | [read] The number of items processed so far, or zero if this server command is not a bulk command that processes items in chunks.
PendingCommandCount | [read] The total number of server commands currently in progress in this client application.
PropertyNameBeingFetched | [read] String the name of the property that has triggered the fetch
Server | [read] Server the server against which this command was issued
SessionID | [read] A unique id assigned to this command session.
Type | [read] Type the Type of Object associated with this Command, if any

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


ServerCommandEventArgs Properties

The properties of the ServerCommandEventArgs class are listed below. For a complete list of ServerCommandEventArgs class members, see the ServerCommandEventArgs Members topic.

Public Instance Properties

BytesReceived | [read] The total number of bytes returned by the server to the client, or zero if this is a start event.
BytesSent | [read] The total number of bytes sent from the client to the server, or zero if this is a start event.
CommandCount | [read] The number of commands executed in this command session.
CommandID | [read] The internal ID assigned to this command.
CommandName | [read] A symbolic name that describes this command ID.
CommandTime | [read] The total execution time of this command, in milliseconds, or zero if this is a start event.
Error |
IsCommandFinished | [read] false for a start event; true for an end or error event.
IsPropertyFetchTriggered | [read] boolean true if this command triggers a property fetch for a single item
IsSuccessful | [read] true if the command terminated normally; false if an exception occurred during the execution of the command.
ItemsExpected | [read] The total number of items to be processed, or zero if this server command is not a bulk command that processes items in chunks.
ItemsSoFar | [read] The number of items processed so far, or zero if this server command is not a bulk command that processes items in chunks.
PendingCommandCount | [read] The total number of server commands currently in progress in this client application.
PropertyNameBeingFetched | [read] String the name of the property that has triggered the fetch
Server | [read] Server the server against which this command was issued
SessionID | [read] A unique id assigned to this command session.
Type | [read] Type the Type of Object associated with this Command, if any

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


BytesReceived Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.BytesReceived Property

[read] The total number of bytes returned by the server to the client, or zero if this is a start event.

public virtual Int64 BytesReceived {get;}

Property Value

The total number of bytes returned by the server to the client, or zero if this is a start event.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


BytesSent Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.BytesSent Property

[read] The total number of bytes sent from the client to the server, or zero if this is a start event.

public virtual Int64 BytesSent {get;}

Property Value

The total number of bytes sent from the client to the server, or zero if this is a start event.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


CommandCount Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.CommandCount Property

[read] The number of commands executed in this command session.

public virtual Int32 CommandCount {get;}

Property Value

The number of commands executed in this command session.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


CommandID Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.CommandID Property

[read] The internal ID assigned to this command.

public virtual Int32 CommandID {get;}

Property Value

The internal ID assigned to this command.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


CommandName Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.CommandName Property

[read] A symbolic name that describes this command ID.

public virtual String CommandName {get;}

Property Value

A symbolic name that describes this command ID.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


CommandTime Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.CommandTime Property

[read] The total execution time of this command, in milliseconds, or zero if this is a start event.

public virtual Int64 CommandTime {get;}

Property Value

The total execution time of this command, in milliseconds, or zero if this is a start event.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


Error Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.Error Property

public virtual Exception Error {get;}

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


IsCommandFinished Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.IsCommandFinished Property

[read] false for a start event; true for an end or error event.

public virtual Boolean IsCommandFinished {get;}

Property Value

false for a start event; true for an end or error event.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


IsPropertyFetchTriggered Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.IsPropertyFetchTriggered Property

[read] boolean true if this command triggers a property fetch for a single item

public virtual Boolean IsPropertyFetchTriggered {get;}

Property Value

boolean true if this command triggers a property fetch for a single item

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


IsSuccessful Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.IsSuccessful Property

[read] true if the command terminated normally; false if an exception occurred during the execution of the command.

public virtual Boolean IsSuccessful {get;}

Property Value

true if the command terminated normally; false if an exception occurred during the execution of the command.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


ItemsExpected Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.ItemsExpected Property

[read] The total number of items to be processed, or zero if this server command is not a bulk command that processes items in chunks.

public virtual Int32 ItemsExpected {get;}

Property Value

The total number of items to be processed, or zero if this server command is not a bulk command that processes items in chunks.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


ItemsSoFar Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.ItemsSoFar Property

[read] The number of items processed so far, or zero if this server command is not a bulk command that processes items in chunks.

public virtual Int32 ItemsSoFar {get;}

Property Value

The number of items processed so far, or zero if this server command is not a bulk command that processes items in chunks.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


PendingCommandCount Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.PendingCommandCount Property

[read] The total number of server commands currently in progress in this client application.

public virtual Int32 PendingCommandCount {get;}

Property Value

The total number of server commands currently in progress in this client application.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


PropertyNameBeingFetched Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.PropertyNameBeingFetched Property

[read] String the name of the property that has triggered the fetch

public virtual String PropertyNameBeingFetched {get;}

Property Value

String the name of the property that has triggered the fetch

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.Server Property

[read] Server the server against which this command was issued

public virtual Server Server {get;}

Property Value

Server the server against which this command was issued

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


SessionID Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.SessionID Property

[read] A unique id assigned to this command session.

public virtual Int32 SessionID {get;}

Property Value

A unique id assigned to this command session.

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.Type Property

[read] Type the Type of Object associated with this Command, if any

public virtual Type Type {get;}

Property Value

Type the Type of Object associated with this Command, if any

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


ServerCommandEventArgs Methods

The methods of the ServerCommandEventArgs class are listed below. For a complete list of ServerCommandEventArgs class members, see the ServerCommandEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


ServerCommandEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


ServerCommandEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


ServerCommandEventArgs.ToString Method

public override string ToString();

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


ServerCommandEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


ServerCommandEventArgs Type Conversions

The type conversions of the ServerCommandEventArgs class are listed below. For a complete list of ServerCommandEventArgs class members, see the ServerCommandEventArgs Members topic.

Public Static Type Conversions

Implicit ServerCommandEventArgs to ServerCommandEvent Conversion Implicitly convert ServerCommandEventArgs to com.starbase.starteam.vts.comm.ServerCommandEvent.

See Also

ServerCommandEventArgs Class | ServerCommandEventArgs Members | Borland.StarTeam Namespace


ServerCommandEventArgs Implicit ServerCommandEventArgs to ServerCommandEvent Conversion

Implicitly convert ServerCommandEventArgs to com.starbase.starteam.vts.comm.ServerCommandEvent.

public static implicit operator ServerCommandEvent(
ServerCommandEventArgs arg
);

Parameters

arg
ServerCommandEventArgs to convert.

Return Value

com.starbase.starteam.vts.comm.ServerCommandEvent

See Also

ServerCommandEventArgs Class | Borland.StarTeam Namespace


ServerCommandEventSource Class

For a list of all members of this type, see ServerCommandEventSource Members.

System.Object
ServerCommandEventSource

public class ServerCommandEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerCommandEventSource Members | Borland.StarTeam Namespace


ServerCommandEventSource Members

ServerCommandEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

End
Error
OnEnd
OnError
OnStart
Start

See Also

ServerCommandEventSource Class | Borland.StarTeam Namespace


ServerCommandEventSource Properties

The properties of the ServerCommandEventSource class are listed below. For a complete list of ServerCommandEventSource class members, see the ServerCommandEventSource Members topic.

Public Instance Properties

Parent

See Also

ServerCommandEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

ServerCommandEventSource.Parent Property

public Object Parent {get;}

See Also

ServerCommandEventSource Class | Borland.StarTeam Namespace


ServerCommandEventSource Events

The events of the ServerCommandEventSource class are listed below. For a complete list of ServerCommandEventSource class members, see the ServerCommandEventSource Members topic.

Public Instance Events

End
Error
OnEnd
OnError
OnStart
Start

See Also

ServerCommandEventSource Class | Borland.StarTeam Namespace


ServerCommandEventSource.End Event

public event ServerCommandEventSource.Handler End;

See Also

ServerCommandEventSource Class | Borland.StarTeam Namespace


ServerCommandEventSource.Error Event

public event ServerCommandEventSource.Handler Error;

See Also

ServerCommandEventSource Class | Borland.StarTeam Namespace


ServerCommandEventSource.OnEnd Event

public event ServerCommandEventSource.Handler OnEnd;

See Also

ServerCommandEventSource Class | Borland.StarTeam Namespace


ServerCommandEventSource.OnError Event

public event ServerCommandEventSource.Handler OnError;

See Also

ServerCommandEventSource Class | Borland.StarTeam Namespace


ServerCommandEventSource.OnStart Event

public event ServerCommandEventSource.Handler OnStart;

See Also

ServerCommandEventSource Class | Borland.StarTeam Namespace


ServerCommandEventSource.Start Event

public event ServerCommandEventSource.Handler Start;

See Also

ServerCommandEventSource Class | Borland.StarTeam Namespace


ServerCommandEventSource.Handler Delegate

public delegate void ServerCommandEventSource.Handler(
ServerCommandEventSource source,
ServerCommandEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


ServerConfiguration Class

For a list of all members of this type, see ServerConfiguration Members.

System.Object
ServerConfiguration

public class ServerConfiguration : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerConfiguration Members | Borland.StarTeam Namespace


ServerConfiguration Members

ServerConfiguration overview

Public Static Properties

DBTYPE_DB2
DBTYPE_INFORMIX
DBTYPE_MSACCESS
DBTYPE_ORACLE
DBTYPE_SQLSERVER
DBTYPE_SYBASE
DBTYPE_UNKNOWN
NOTIFICATION_TYPE_BOTH
NOTIFICATION_TYPE_EMAIL
NOTIFICATION_TYPE_SYSTRAY
PROTOCOL_IPX
PROTOCOL_LRPC
PROTOCOL_NAMED_PIPE
PROTOCOL_NETBIOS
PROTOCOL_TCP_IP_RPC
PROTOCOL_TCP_IP_SOCKETS
PROTOCOL_TCP_IP_SOCKETS_XML

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerConfiguration.

Public Static Type Conversions

Implicit ServerConfiguration to ServerConfiguration Conversion Implicitly convert ServerConfiguration to com.starbase.starteam.ServerConfiguration.

Public Instance Constructors

ServerConfiguration Overloaded. Initializes a new instance of the ServerConfiguration class.

Public Instance Properties

ArchiveDirectory | [read/write] The path to the server's archive directory.
AttachmentDirectory | [read/write] The path to the server's attachment directory.
AuditsAutoPurgeDays | [read/write] The number of days after which audit information is purged from the server.
AuditsEnabled | [read/write] true if auditing is enabled on the server.
CacheDirectory | [read/write] The path to the server's vault directory.
Cipher | [read/write] The server's cipher string.
DBAutoRecovery | [read/write] true if the server automatically recovers from errors. This property is supported by StarTeam 4.1 and later.
DBDSN | [read/write] The server data source name.
DBPooledConnections | [read/write] The number of pooled connections to the server database.
DBTransactionsEnabled | [read/write] true if database transactions are enabled.
DBType | [read/write] The server database type.
DBVerifyOnStartup | [read/write] true if the server database is verified on startup. This property is supported by StarTeam 4.1 and later.
DiagnosticStatisticsReportingInterval | [read/write] The frequency, in seconds, with which the server will report diagnostic statistics. The default value is zero, which disables reporting.
DirectoryServiceEnabled | [read/write] true if Directory Service is enabled on this server. This property is supported by server release 6.0 and later; ignored for earlier releases.
DirectoryServiceHost | [read/write] the name or IP Address of the Directory Service host. This property is supported by server release 6.0 and later; ignored for earlier releases.
DirectoryServicePort | [read/write] the Directory Service SSL port. This property is supported by server release 6.0 and later; ignored for earlier releases.
DumpAsserts | [read/write] whether the server will create a diagnostic dump when unexpected conditions [i.e., asserts] are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.
DumpErrors | [read/write] whether the server will create a diagnostic dump when errors are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.
DumpType | [read/write] int the mini dump type used for diagnostic dumps
EnableDiagnostics | [read/write] true if server diagnostics are enabled.
EncryptionRequirements | [read/write] the required encryption levels for various ranges of TCP/IP addresses.
ExpensiveOperationMinimum | [read/write] the minimum number of milliseconds used to determine what is an expensive operation for tracing purposes. Meaningful for server release 6.0 and later; returns -1 for earlier releases.
FileStatusAutoPurgeDays | [read/write] The number of days after which a file's status information will be purged.
ForeignRefreshRate | [read/write] The rate at which files are refreshed from foreign archives.
InactivityTimeout | [read/write] The server's inactivity timeout, in seconds.
IsAdvancedViewsDisabled | [read/write] whether the server is configured to disable advanced views. Meaningful for server release 10.0 and later; always false for earlier releases.
IsAtomicTransactionsDisabled | [read/write] whether the server is configured to disable atomic transactions. Meaningful for server release 10.0 and later; always false for earlier releases.
IsEnhancedProcessItemsEnabledForNewProjects | [read/write] true if the enhanced process item model is in effect by default for new projects, and false otherwise.
LogFile | [read/write] The path to the server's log file.
LogonTimeout | [read/write] The server's logon timeout, in seconds.
MailEnabled | [read/write] true if email is enabled on the server.
MultiPartDirectory | [read/write] The path to the server's multi-part directory.
NotifyBy | [read/write] The method by which notification messages are sent to StarTeam users. This property is supported by StarTeam 4.2 and later.
NoTimeoutNamedLicenses | [read/write] the server's "NoTimeoutNamedLicenses" setting for servers 7.0 and later.
ReconnectTimeout | [read/write] The server's reconnect timeout, in seconds. Available for StarTeam 6.0 servers and later.
RepositoryPath | [read/write] The path to the server's data repository.
ServerGUID | [read/write] The server's globally unique identifier.
SMTPAddress | [read/write] The SMTP address of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
SMTPPort | [read/write] The SMTP port of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
StopServerOnErrors | [read/write] true if the server automatically stops after an error. This property is supported by StarTeam 4.1 and later.
TraceExpensiveOperations | [read/write] whether the server will trace expensive operations. Meaningful for server release 6.0 and later; always false for earlier releases.
UsingSecureDirectoryService | [read/write] the server's "Using Secure Directory Service (LDAPS)" value for servers 7.0 and later.
VaultCacheMaxSize | [read/write] The server's vault cache size limit, in megabytes.
VaultCacheRefreshInterval | [read/write] The server's vault cache refresh interval, in seconds.
VaultDirectory | [read/write] The path to the server's vault directory.
VaultLockTimeLimit | [read/write] The server's vault lock time limit, in seconds.

Public Instance Methods

Copy | return a copy of this ServerConfiguration instance
Equals | Delegate Equals() to com.starbase.starteam.ServerConfiguration.
GetEnabled | Returns true if the specified protocol is enabled.
GetEndPoint | Returns the endpoint for the specified protocol.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEnhancedProcessItemsEnabledForAllProjects | Determines whether or not the enhanced process item model is currently enabled for all projects on this server.
IsEqualTo | returns true if this object instance is equal to the source
IsProtocolAvailable | Returns true if the server supports the specified protocol.
SetEnabled | Enable or disable the specified communication procotol.
SetEndPoint | Modifies the specified protocol's endpoint. The endpoint is protocol specific.
SetEnhancedProcessItemsEnabledForAllProjects | Enables or disables the enhanced process item model for all projects on this server. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task. On StarTeam server versions 9.1 and later, this method disables the enhanced model for every existing project individually, and also disables the enhanced model for new projects. On earlier servers, the enhanced model can only be enabled or disabled globally. Internally, this is done by enabling or disabling the TASK_USAGE_90 property, as necessary.
ToString | Delegate ToString() to com.starbase.starteam.ServerConfiguration.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration Constructor

Construct ServerConfiguration from com.starbase.starteam.ServerConfiguration.

Overload List

construct a new ServerConfiguration from the source

public ServerConfiguration(ServerConfiguration);

Construct ServerConfiguration from com.starbase.starteam.ServerConfiguration.

public ServerConfiguration(ServerConfiguration);

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration Constructor (ServerConfiguration)

Construct ServerConfiguration from com.starbase.starteam.ServerConfiguration.

public ServerConfiguration(
ServerConfiguration impl
);

Parameters

impl
The com.starbase.starteam.ServerConfiguration to be wrapped.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace | ServerConfiguration Constructor Overload List


ServerConfiguration Constructor (ServerConfiguration)

construct a new ServerConfiguration from the source

public ServerConfiguration(
ServerConfiguration source
);

Parameters

source
ServerConfiguration the ServerConfiguration to copy

See Also

ServerConfiguration Class | Borland.StarTeam Namespace | ServerConfiguration Constructor Overload List


ServerConfiguration Properties

The properties of the ServerConfiguration class are listed below. For a complete list of ServerConfiguration class members, see the ServerConfiguration Members topic.

Public Static Properties

DBTYPE_DB2
DBTYPE_INFORMIX
DBTYPE_MSACCESS
DBTYPE_ORACLE
DBTYPE_SQLSERVER
DBTYPE_SYBASE
DBTYPE_UNKNOWN
NOTIFICATION_TYPE_BOTH
NOTIFICATION_TYPE_EMAIL
NOTIFICATION_TYPE_SYSTRAY
PROTOCOL_IPX
PROTOCOL_LRPC
PROTOCOL_NAMED_PIPE
PROTOCOL_NETBIOS
PROTOCOL_TCP_IP_RPC
PROTOCOL_TCP_IP_SOCKETS
PROTOCOL_TCP_IP_SOCKETS_XML

Public Instance Properties

ArchiveDirectory | [read/write] The path to the server's archive directory.
AttachmentDirectory | [read/write] The path to the server's attachment directory.
AuditsAutoPurgeDays | [read/write] The number of days after which audit information is purged from the server.
AuditsEnabled | [read/write] true if auditing is enabled on the server.
CacheDirectory | [read/write] The path to the server's vault directory.
Cipher | [read/write] The server's cipher string.
DBAutoRecovery | [read/write] true if the server automatically recovers from errors. This property is supported by StarTeam 4.1 and later.
DBDSN | [read/write] The server data source name.
DBPooledConnections | [read/write] The number of pooled connections to the server database.
DBTransactionsEnabled | [read/write] true if database transactions are enabled.
DBType | [read/write] The server database type.
DBVerifyOnStartup | [read/write] true if the server database is verified on startup. This property is supported by StarTeam 4.1 and later.
DiagnosticStatisticsReportingInterval | [read/write] The frequency, in seconds, with which the server will report diagnostic statistics. The default value is zero, which disables reporting.
DirectoryServiceEnabled | [read/write] true if Directory Service is enabled on this server. This property is supported by server release 6.0 and later; ignored for earlier releases.
DirectoryServiceHost | [read/write] the name or IP Address of the Directory Service host. This property is supported by server release 6.0 and later; ignored for earlier releases.
DirectoryServicePort | [read/write] the Directory Service SSL port. This property is supported by server release 6.0 and later; ignored for earlier releases.
DumpAsserts | [read/write] whether the server will create a diagnostic dump when unexpected conditions [i.e., asserts] are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.
DumpErrors | [read/write] whether the server will create a diagnostic dump when errors are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.
DumpType | [read/write] int the mini dump type used for diagnostic dumps
EnableDiagnostics | [read/write] true if server diagnostics are enabled.
EncryptionRequirements | [read/write] the required encryption levels for various ranges of TCP/IP addresses.
ExpensiveOperationMinimum | [read/write] the minimum number of milliseconds used to determine what is an expensive operation for tracing purposes. Meaningful for server release 6.0 and later; returns -1 for earlier releases.
FileStatusAutoPurgeDays | [read/write] The number of days after which a file's status information will be purged.
ForeignRefreshRate | [read/write] The rate at which files are refreshed from foreign archives.
InactivityTimeout | [read/write] The server's inactivity timeout, in seconds.
IsAdvancedViewsDisabled | [read/write] whether the server is configured to disable advanced views. Meaningful for server release 10.0 and later; always false for earlier releases.
IsAtomicTransactionsDisabled | [read/write] whether the server is configured to disable atomic transactions. Meaningful for server release 10.0 and later; always false for earlier releases.
IsEnhancedProcessItemsEnabledForNewProjects | [read/write] true if the enhanced process item model is in effect by default for new projects, and false otherwise.
LogFile | [read/write] The path to the server's log file.
LogonTimeout | [read/write] The server's logon timeout, in seconds.
MailEnabled | [read/write] true if email is enabled on the server.
MultiPartDirectory | [read/write] The path to the server's multi-part directory.
NotifyBy | [read/write] The method by which notification messages are sent to StarTeam users. This property is supported by StarTeam 4.2 and later.
NoTimeoutNamedLicenses | [read/write] the server's "NoTimeoutNamedLicenses" setting for servers 7.0 and later.
ReconnectTimeout | [read/write] The server's reconnect timeout, in seconds. Available for StarTeam 6.0 servers and later.
RepositoryPath | [read/write] The path to the server's data repository.
ServerGUID | [read/write] The server's globally unique identifier.
SMTPAddress | [read/write] The SMTP address of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
SMTPPort | [read/write] The SMTP port of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
StopServerOnErrors | [read/write] true if the server automatically stops after an error. This property is supported by StarTeam 4.1 and later.
TraceExpensiveOperations | [read/write] whether the server will trace expensive operations. Meaningful for server release 6.0 and later; always false for earlier releases.
UsingSecureDirectoryService | [read/write] the server's "Using Secure Directory Service (LDAPS)" value for servers 7.0 and later.
VaultCacheMaxSize | [read/write] The server's vault cache size limit, in megabytes.
VaultCacheRefreshInterval | [read/write] The server's vault cache refresh interval, in seconds.
VaultDirectory | [read/write] The path to the server's vault directory.
VaultLockTimeLimit | [read/write] The server's vault lock time limit, in seconds.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ArchiveDirectory Property

Borland StarTeam SDK for .NET

ServerConfiguration.ArchiveDirectory Property

[read/write] The path to the server's archive directory.

public virtual String ArchiveDirectory {get; set;}

Property Value

The path to the server's archive directory.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


AttachmentDirectory Property

Borland StarTeam SDK for .NET

ServerConfiguration.AttachmentDirectory Property

[read/write] The path to the server's attachment directory.

public virtual String AttachmentDirectory {get; set;}

Property Value

The path to the server's attachment directory.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


AuditsAutoPurgeDays Property

Borland StarTeam SDK for .NET

ServerConfiguration.AuditsAutoPurgeDays Property

[read/write] The number of days after which audit information is purged from the server.

public virtual Int32 AuditsAutoPurgeDays {get; set;}

Property Value

The number of days after which audit information is purged from the server.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


AuditsEnabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.AuditsEnabled Property

[read/write] true if auditing is enabled on the server.

public virtual Boolean AuditsEnabled {get; set;}

Property Value

true if auditing is enabled on the server.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


CacheDirectory Property

Borland StarTeam SDK for .NET

ServerConfiguration.CacheDirectory Property

[read/write] The path to the server's vault directory.

public virtual String CacheDirectory {get; set;}

Property Value

The path to the server's vault directory.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


Cipher Property

Borland StarTeam SDK for .NET

ServerConfiguration.Cipher Property

[read/write] The server's cipher string.

public virtual String Cipher {get; set;}

Property Value

The server's cipher string.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBAutoRecovery Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBAutoRecovery Property

[read/write] true if the server automatically recovers from errors. This property is supported by StarTeam 4.1 and later.

public virtual Boolean DBAutoRecovery {get; set;}

Property Value

true if the server automatically recovers from errors. This property is supported by StarTeam 4.1 and later.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBDSN Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBDSN Property

[read/write] The server data source name.

public virtual String DBDSN {get; set;}

Property Value

The server data source name.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBPooledConnections Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBPooledConnections Property

[read/write] The number of pooled connections to the server database.

public virtual Int32 DBPooledConnections {get; set;}

Property Value

The number of pooled connections to the server database.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBTransactionsEnabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBTransactionsEnabled Property

[read/write] true if database transactions are enabled.

public virtual Boolean DBTransactionsEnabled {get; set;}

Property Value

true if database transactions are enabled.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBType Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBType Property

[read/write] The server database type.

public virtual Int32 DBType {get; set;}

Property Value

The server database type.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBTYPE_DB2 Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBTYPE_DB2 Property

public static Int32 DBTYPE_DB2 {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBTYPE_INFORMIX Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBTYPE_INFORMIX Property

public static Int32 DBTYPE_INFORMIX {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBTYPE_MSACCESS Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBTYPE_MSACCESS Property

public static Int32 DBTYPE_MSACCESS {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBTYPE_ORACLE Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBTYPE_ORACLE Property

public static Int32 DBTYPE_ORACLE {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBTYPE_SQLSERVER Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBTYPE_SQLSERVER Property

public static Int32 DBTYPE_SQLSERVER {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBTYPE_SYBASE Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBTYPE_SYBASE Property

public static Int32 DBTYPE_SYBASE {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBTYPE_UNKNOWN Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBTYPE_UNKNOWN Property

public static Int32 DBTYPE_UNKNOWN {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DBVerifyOnStartup Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBVerifyOnStartup Property

[read/write] true if the server database is verified on startup. This property is supported by StarTeam 4.1 and later.

public virtual Boolean DBVerifyOnStartup {get; set;}

Property Value

true if the server database is verified on startup. This property is supported by StarTeam 4.1 and later.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DiagnosticStatisticsReportingInterval Property

Borland StarTeam SDK for .NET

ServerConfiguration.DiagnosticStatisticsReportingInterval Property

[read/write] The frequency, in seconds, with which the server will report diagnostic statistics. The default value is zero, which disables reporting.

public virtual Int32 DiagnosticStatisticsReportingInterval {get; set;}

Property Value

The frequency, in seconds, with which the server will report diagnostic statistics. The default value is zero, which disables reporting.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DirectoryServiceEnabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServiceEnabled Property

[read/write] true if Directory Service is enabled on this server. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual Boolean DirectoryServiceEnabled {get; set;}

Property Value

true if Directory Service is enabled on this server. This property is supported by server release 6.0 and later; ignored for earlier releases.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DirectoryServiceHost Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServiceHost Property

[read/write] the name or IP Address of the Directory Service host. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual String DirectoryServiceHost {get; set;}

Property Value

the name or IP Address of the Directory Service host. This property is supported by server release 6.0 and later; ignored for earlier releases.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DirectoryServicePort Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServicePort Property

[read/write] the Directory Service SSL port. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual Int32 DirectoryServicePort {get; set;}

Property Value

the Directory Service SSL port. This property is supported by server release 6.0 and later; ignored for earlier releases.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DumpAsserts Property

Borland StarTeam SDK for .NET

ServerConfiguration.DumpAsserts Property

[read/write] whether the server will create a diagnostic dump when unexpected conditions [i.e., asserts] are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.

public virtual Boolean DumpAsserts {get; set;}

Property Value

whether the server will create a diagnostic dump when unexpected conditions [i.e., asserts] are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DumpErrors Property

Borland StarTeam SDK for .NET

ServerConfiguration.DumpErrors Property

[read/write] whether the server will create a diagnostic dump when errors are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.

public virtual Boolean DumpErrors {get; set;}

Property Value

whether the server will create a diagnostic dump when errors are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


DumpType Property

Borland StarTeam SDK for .NET

ServerConfiguration.DumpType Property

[read/write] int the mini dump type used for diagnostic dumps

public virtual Int32 DumpType {get; set;}

Property Value

int the mini dump type used for diagnostic dumps

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


EnableDiagnostics Property

Borland StarTeam SDK for .NET

ServerConfiguration.EnableDiagnostics Property

[read/write] true if server diagnostics are enabled.

public virtual Boolean EnableDiagnostics {get; set;}

Property Value

true if server diagnostics are enabled.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


EncryptionRequirements Property

Borland StarTeam SDK for .NET

ServerConfiguration.EncryptionRequirements Property

[read/write] the required encryption levels for various ranges of TCP/IP addresses.

public virtual IPRangeCollection EncryptionRequirements {get; set;}

Property Value

the required encryption levels for various ranges of TCP/IP addresses.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ExpensiveOperationMinimum Property

Borland StarTeam SDK for .NET

ServerConfiguration.ExpensiveOperationMinimum Property

[read/write] the minimum number of milliseconds used to determine what is an expensive operation for tracing purposes. Meaningful for server release 6.0 and later; returns -1 for earlier releases.

public virtual Int32 ExpensiveOperationMinimum {get; set;}

Property Value

the minimum number of milliseconds used to determine what is an expensive operation for tracing purposes. Meaningful for server release 6.0 and later; returns -1 for earlier releases.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


FileStatusAutoPurgeDays Property

Borland StarTeam SDK for .NET

ServerConfiguration.FileStatusAutoPurgeDays Property

[read/write] The number of days after which a file's status information will be purged.

public virtual Int32 FileStatusAutoPurgeDays {get; set;}

Property Value

The number of days after which a file's status information will be purged.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ForeignRefreshRate Property

Borland StarTeam SDK for .NET

ServerConfiguration.ForeignRefreshRate Property

[read/write] The rate at which files are refreshed from foreign archives.

public virtual Int32 ForeignRefreshRate {get; set;}

Property Value

The rate at which files are refreshed from foreign archives.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


InactivityTimeout Property

Borland StarTeam SDK for .NET

ServerConfiguration.InactivityTimeout Property

[read/write] The server's inactivity timeout, in seconds.

public virtual Int32 InactivityTimeout {get; set;}

Property Value

The server's inactivity timeout, in seconds.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


IsAdvancedViewsDisabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.IsAdvancedViewsDisabled Property

[read/write] whether the server is configured to disable advanced views. Meaningful for server release 10.0 and later; always false for earlier releases.

public virtual Boolean IsAdvancedViewsDisabled {get; set;}

Property Value

whether the server is configured to disable advanced views. Meaningful for server release 10.0 and later; always false for earlier releases.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


IsAtomicTransactionsDisabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.IsAtomicTransactionsDisabled Property

[read/write] whether the server is configured to disable atomic transactions. Meaningful for server release 10.0 and later; always false for earlier releases.

public virtual Boolean IsAtomicTransactionsDisabled {get; set;}

Property Value

whether the server is configured to disable atomic transactions. Meaningful for server release 10.0 and later; always false for earlier releases.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


IsEnhancedProcessItemsEnabledForNewProjects Property

Borland StarTeam SDK for .NET

ServerConfiguration.IsEnhancedProcessItemsEnabledForNewProjects Property

[read/write] true if the enhanced process item model is in effect by default for new projects, and false otherwise.

public virtual Boolean IsEnhancedProcessItemsEnabledForNewProjects {get; set;}

Property Value

true if the enhanced process item model is in effect by default for new projects, and false otherwise.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


LogFile Property

Borland StarTeam SDK for .NET

ServerConfiguration.LogFile Property

[read/write] The path to the server's log file.

public virtual String LogFile {get; set;}

Property Value

The path to the server's log file.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


LogonTimeout Property

Borland StarTeam SDK for .NET

ServerConfiguration.LogonTimeout Property

[read/write] The server's logon timeout, in seconds.

public virtual Int32 LogonTimeout {get; set;}

Property Value

The server's logon timeout, in seconds.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


MailEnabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.MailEnabled Property

[read/write] true if email is enabled on the server.

public virtual Boolean MailEnabled {get; set;}

Property Value

true if email is enabled on the server.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


MultiPartDirectory Property

Borland StarTeam SDK for .NET

ServerConfiguration.MultiPartDirectory Property

[read/write] The path to the server's multi-part directory.

public virtual String MultiPartDirectory {get; set;}

Property Value

The path to the server's multi-part directory.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


NOTIFICATION_TYPE_BOTH Property

Borland StarTeam SDK for .NET

ServerConfiguration.NOTIFICATION_TYPE_BOTH Property

public static Int32 NOTIFICATION_TYPE_BOTH {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


NOTIFICATION_TYPE_EMAIL Property

Borland StarTeam SDK for .NET

ServerConfiguration.NOTIFICATION_TYPE_EMAIL Property

public static Int32 NOTIFICATION_TYPE_EMAIL {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


NOTIFICATION_TYPE_SYSTRAY Property

Borland StarTeam SDK for .NET

ServerConfiguration.NOTIFICATION_TYPE_SYSTRAY Property

public static Int32 NOTIFICATION_TYPE_SYSTRAY {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


NotifyBy Property

Borland StarTeam SDK for .NET

ServerConfiguration.NotifyBy Property

[read/write] The method by which notification messages are sent to StarTeam users. This property is supported by StarTeam 4.2 and later.

public virtual Int32 NotifyBy {get; set;}

Property Value

The method by which notification messages are sent to StarTeam users. This property is supported by StarTeam 4.2 and later.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


NoTimeoutNamedLicenses Property

Borland StarTeam SDK for .NET

ServerConfiguration.NoTimeoutNamedLicenses Property

[read/write] the server's "NoTimeoutNamedLicenses" setting for servers 7.0 and later.

public virtual Boolean NoTimeoutNamedLicenses {get; set;}

Property Value

the server's "NoTimeoutNamedLicenses" setting for servers 7.0 and later.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


PROTOCOL_IPX Property

Borland StarTeam SDK for .NET

ServerConfiguration.PROTOCOL_IPX Property

public static Int32 PROTOCOL_IPX {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


PROTOCOL_LRPC Property

Borland StarTeam SDK for .NET

ServerConfiguration.PROTOCOL_LRPC Property

public static Int32 PROTOCOL_LRPC {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


PROTOCOL_NAMED_PIPE Property

Borland StarTeam SDK for .NET

ServerConfiguration.PROTOCOL_NAMED_PIPE Property

public static Int32 PROTOCOL_NAMED_PIPE {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


PROTOCOL_NETBIOS Property

Borland StarTeam SDK for .NET

ServerConfiguration.PROTOCOL_NETBIOS Property

public static Int32 PROTOCOL_NETBIOS {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


PROTOCOL_TCP_IP_RPC Property

Borland StarTeam SDK for .NET

ServerConfiguration.PROTOCOL_TCP_IP_RPC Property

public static Int32 PROTOCOL_TCP_IP_RPC {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


PROTOCOL_TCP_IP_SOCKETS Property

Borland StarTeam SDK for .NET

ServerConfiguration.PROTOCOL_TCP_IP_SOCKETS Property

public static Int32 PROTOCOL_TCP_IP_SOCKETS {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


PROTOCOL_TCP_IP_SOCKETS_XML Property

Borland StarTeam SDK for .NET

ServerConfiguration.PROTOCOL_TCP_IP_SOCKETS_XML Property

public static Int32 PROTOCOL_TCP_IP_SOCKETS_XML {get;}

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ReconnectTimeout Property

Borland StarTeam SDK for .NET

ServerConfiguration.ReconnectTimeout Property

[read/write] The server's reconnect timeout, in seconds. Available for StarTeam 6.0 servers and later.

public virtual Int32 ReconnectTimeout {get; set;}

Property Value

The server's reconnect timeout, in seconds. Available for StarTeam 6.0 servers and later.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


RepositoryPath Property

Borland StarTeam SDK for .NET

ServerConfiguration.RepositoryPath Property

[read/write] The path to the server's data repository.

public virtual String RepositoryPath {get; set;}

Property Value

The path to the server's data repository.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerGUID Property

Borland StarTeam SDK for .NET

ServerConfiguration.ServerGUID Property

[read/write] The server's globally unique identifier.

public virtual String ServerGUID {get; set;}

Property Value

The server's globally unique identifier.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


SMTPAddress Property

Borland StarTeam SDK for .NET

ServerConfiguration.SMTPAddress Property

[read/write] The SMTP address of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.

public virtual String SMTPAddress {get; set;}

Property Value

The SMTP address of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


SMTPPort Property

Borland StarTeam SDK for .NET

ServerConfiguration.SMTPPort Property

[read/write] The SMTP port of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.

public virtual Int32 SMTPPort {get; set;}

Property Value

The SMTP port of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


StopServerOnErrors Property

Borland StarTeam SDK for .NET

ServerConfiguration.StopServerOnErrors Property

[read/write] true if the server automatically stops after an error. This property is supported by StarTeam 4.1 and later.

public virtual Boolean StopServerOnErrors {get; set;}

Property Value

true if the server automatically stops after an error. This property is supported by StarTeam 4.1 and later.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


TraceExpensiveOperations Property

Borland StarTeam SDK for .NET

ServerConfiguration.TraceExpensiveOperations Property

[read/write] whether the server will trace expensive operations. Meaningful for server release 6.0 and later; always false for earlier releases.

public virtual Boolean TraceExpensiveOperations {get; set;}

Property Value

whether the server will trace expensive operations. Meaningful for server release 6.0 and later; always false for earlier releases.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


UsingSecureDirectoryService Property

Borland StarTeam SDK for .NET

ServerConfiguration.UsingSecureDirectoryService Property

[read/write] the server's "Using Secure Directory Service (LDAPS)" value for servers 7.0 and later.

public virtual Boolean UsingSecureDirectoryService {get; set;}

Property Value

the server's "Using Secure Directory Service (LDAPS)" value for servers 7.0 and later.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


VaultCacheMaxSize Property

Borland StarTeam SDK for .NET

ServerConfiguration.VaultCacheMaxSize Property

[read/write] The server's vault cache size limit, in megabytes.

public virtual Int32 VaultCacheMaxSize {get; set;}

Property Value

The server's vault cache size limit, in megabytes.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


VaultCacheRefreshInterval Property

Borland StarTeam SDK for .NET

ServerConfiguration.VaultCacheRefreshInterval Property

[read/write] The server's vault cache refresh interval, in seconds.

public virtual Int32 VaultCacheRefreshInterval {get; set;}

Property Value

The server's vault cache refresh interval, in seconds.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


VaultDirectory Property

Borland StarTeam SDK for .NET

ServerConfiguration.VaultDirectory Property

[read/write] The path to the server's vault directory.

public virtual String VaultDirectory {get; set;}

Property Value

The path to the server's vault directory.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


VaultLockTimeLimit Property

Borland StarTeam SDK for .NET

ServerConfiguration.VaultLockTimeLimit Property

[read/write] The server's vault lock time limit, in seconds.

public virtual Int32 VaultLockTimeLimit {get; set;}

Property Value

The server's vault lock time limit, in seconds.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration Methods

The methods of the ServerConfiguration class are listed below. For a complete list of ServerConfiguration class members, see the ServerConfiguration Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerConfiguration.

Public Instance Methods

Copy | return a copy of this ServerConfiguration instance
Equals | Delegate Equals() to com.starbase.starteam.ServerConfiguration.
GetEnabled | Returns true if the specified protocol is enabled.
GetEndPoint | Returns the endpoint for the specified protocol.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEnhancedProcessItemsEnabledForAllProjects | Determines whether or not the enhanced process item model is currently enabled for all projects on this server.
IsEqualTo | returns true if this object instance is equal to the source
IsProtocolAvailable | Returns true if the server supports the specified protocol.
SetEnabled | Enable or disable the specified communication procotol.
SetEndPoint | Modifies the specified protocol's endpoint. The endpoint is protocol specific.
SetEnhancedProcessItemsEnabledForAllProjects | Enables or disables the enhanced process item model for all projects on this server. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task. On StarTeam server versions 9.1 and later, this method disables the enhanced model for every existing project individually, and also disables the enhanced model for new projects. On earlier servers, the enhanced model can only be enabled or disabled globally. Internally, this is done by enabling or disabling the TASK_USAGE_90 property, as necessary.
ToString | Delegate ToString() to com.starbase.starteam.ServerConfiguration.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ServerConfiguration

Implements

IWrapper.Unwrap

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.Copy Method

return a copy of this ServerConfiguration instance

public virtual ServerConfiguration Copy();

Return Value

ServerConfiguration a copy of this ServerConfiguration instance

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.Equals Method

Delegate Equals() to com.starbase.starteam.ServerConfiguration.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ServerConfiguration.Equals(obj).

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.GetEnabled Method

Returns true if the specified protocol is enabled.

public virtual bool GetEnabled(
Int32 protocol
);

Parameters

protocol
the protocol identifier

Return Value

true if the specified protocol is enabled.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.GetEndPoint Method

Returns the endpoint for the specified protocol.

public virtual string GetEndPoint(
Int32 protocol
);

Parameters

protocol
the protocol identifier

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ServerConfiguration.

public override int GetHashCode();

Return Value

com.starbase.starteam.ServerConfiguration.GetHashCode().

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.IsEnhancedProcessItemsEnabledForAllProjects Method

Determines whether or not the enhanced process item model is currently enabled for all projects on this server.

public virtual bool IsEnhancedProcessItemsEnabledForAllProjects();

Return Value

true if the enhanced model is enabled for all projects on this server; false otherwise.

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.IsEqualTo Method

returns true if this object instance is equal to the source

public virtual bool IsEqualTo(
ServerConfiguration source
);

Parameters

source
Object the source to comapre with

Return Value

boolean true if this object is equal to the source

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.IsProtocolAvailable Method

Returns true if the server supports the specified protocol.

public virtual bool IsProtocolAvailable(
Int32 protocol
);

Parameters

protocol
the protocol identifier

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.SetEnabled Method

Enable or disable the specified communication procotol.

public virtual void SetEnabled(
Int32 protocol,
Boolean enabled
);

Parameters

protocol
the protocol identifier
enabled
true if the protocol should be enabled

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.SetEndPoint Method

Modifies the specified protocol's endpoint. The endpoint is protocol specific.

public virtual void SetEndPoint(
Int32 protocol,
String endpoint
);

Parameters

protocol
the protocol identifier
endpoint
the new endpoint for the specified protocol

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.SetEnhancedProcessItemsEnabledForAllProjects Method

Enables or disables the enhanced process item model for all projects on this server. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task.

On StarTeam server versions 9.1 and later, this method disables the enhanced model for every existing project individually, and also disables the enhanced model for new projects.

On earlier servers, the enhanced model can only be enabled or disabled globally. Internally, this is done by enabling or disabling the TASK_USAGE_90 property, as necessary.

public virtual void SetEnhancedProcessItemsEnabledForAllProjects(
Boolean bEnabled
);

Parameters

bEnabled

See Also

ServerConfiguration Class | Borland.StarTeam Namespace | setEnhancedProcessItemsEnabledForNewProjects | setEnhancedProcessItemsEnabled | hasEnhancedProcessItemsNative | TASK_USAGE_90


ServerConfiguration.ToString Method

Delegate ToString() to com.starbase.starteam.ServerConfiguration.

public override string ToString();

Return Value

com.starbase.starteam.ServerConfiguration.ToString()

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration.Wrap Method

Dynamically wraps com.starbase.starteam.ServerConfiguration.

public static ServerConfiguration Wrap(
ServerConfiguration impl
);

Parameters

impl
com.starbase.starteam.ServerConfiguration to be wrapped.

Return Value

ServerConfiguration

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerConfiguration Type Conversions

The type conversions of the ServerConfiguration class are listed below. For a complete list of ServerConfiguration class members, see the ServerConfiguration Members topic.

Public Static Type Conversions

Implicit ServerConfiguration to ServerConfiguration Conversion Implicitly convert ServerConfiguration to com.starbase.starteam.ServerConfiguration.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerConfiguration Class | ServerConfiguration Members | Borland.StarTeam Namespace


ServerConfiguration Implicit ServerConfiguration to ServerConfiguration Conversion

Implicitly convert ServerConfiguration to com.starbase.starteam.ServerConfiguration.

public static implicit operator ServerConfiguration(
ServerConfiguration arg
);

Parameters

arg
ServerConfiguration to convert.

Return Value

com.starbase.starteam.ServerConfiguration

See Also

ServerConfiguration Class | Borland.StarTeam Namespace


ServerControlEventArgs Class

For a list of all members of this type, see ServerControlEventArgs Members.

System.Object
EventArgs
ServerControlEventArgs

public class ServerControlEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerControlEventArgs Members | Borland.StarTeam Namespace


ServerControlEventArgs Members

ServerControlEventArgs overview

Public Static Type Conversions

Implicit ServerControlEventArgs to ServerControlEvent Conversion Implicitly convert ServerControlEventArgs to com.starbase.starteam.ServerControlEvent.

Public Instance Properties

Server [read] The Server object whose status has changed.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ServerControlEventArgs Class | Borland.StarTeam Namespace


ServerControlEventArgs Properties

The properties of the ServerControlEventArgs class are listed below. For a complete list of ServerControlEventArgs class members, see the ServerControlEventArgs Members topic.

Public Instance Properties

Server [read] The Server object whose status has changed.

See Also

ServerControlEventArgs Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ServerControlEventArgs.Server Property

[read] The Server object whose status has changed.

public virtual Server Server {get;}

Property Value

The Server object whose status has changed.

See Also

ServerControlEventArgs Class | Borland.StarTeam Namespace


ServerControlEventArgs Methods

The methods of the ServerControlEventArgs class are listed below. For a complete list of ServerControlEventArgs class members, see the ServerControlEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ServerControlEventArgs Class | Borland.StarTeam Namespace


ServerControlEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ServerControlEventArgs Class | Borland.StarTeam Namespace


ServerControlEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ServerControlEventArgs Class | Borland.StarTeam Namespace


ServerControlEventArgs.ToString Method

public override string ToString();

See Also

ServerControlEventArgs Class | Borland.StarTeam Namespace


ServerControlEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

ServerControlEventArgs Class | Borland.StarTeam Namespace


ServerControlEventArgs Type Conversions

The type conversions of the ServerControlEventArgs class are listed below. For a complete list of ServerControlEventArgs class members, see the ServerControlEventArgs Members topic.

Public Static Type Conversions

Implicit ServerControlEventArgs to ServerControlEvent Conversion Implicitly convert ServerControlEventArgs to com.starbase.starteam.ServerControlEvent.

See Also

ServerControlEventArgs Class | ServerControlEventArgs Members | Borland.StarTeam Namespace


ServerControlEventArgs Implicit ServerControlEventArgs to ServerControlEvent Conversion

Implicitly convert ServerControlEventArgs to com.starbase.starteam.ServerControlEvent.

public static implicit operator ServerControlEvent(
ServerControlEventArgs arg
);

Parameters

arg
ServerControlEventArgs to convert.

Return Value

com.starbase.starteam.ServerControlEvent

See Also

ServerControlEventArgs Class | Borland.StarTeam Namespace


ServerControlEventSource Class

For a list of all members of this type, see ServerControlEventSource Members.

System.Object
ServerControlEventSource

public class ServerControlEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerControlEventSource Members | Borland.StarTeam Namespace


ServerControlEventSource Members

ServerControlEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnServerStarted
OnServerStopped
ServerStarted
ServerStopped

See Also

ServerControlEventSource Class | Borland.StarTeam Namespace


ServerControlEventSource Properties

The properties of the ServerControlEventSource class are listed below. For a complete list of ServerControlEventSource class members, see the ServerControlEventSource Members topic.

Public Instance Properties

Parent

See Also

ServerControlEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

ServerControlEventSource.Parent Property

public Object Parent {get;}

See Also

ServerControlEventSource Class | Borland.StarTeam Namespace


ServerControlEventSource Events

The events of the ServerControlEventSource class are listed below. For a complete list of ServerControlEventSource class members, see the ServerControlEventSource Members topic.

Public Instance Events

OnServerStarted
OnServerStopped
ServerStarted
ServerStopped

See Also

ServerControlEventSource Class | Borland.StarTeam Namespace


ServerControlEventSource.OnServerStarted Event

public event ServerControlEventSource.Handler OnServerStarted;

See Also

ServerControlEventSource Class | Borland.StarTeam Namespace


ServerControlEventSource.OnServerStopped Event

public event ServerControlEventSource.Handler OnServerStopped;

See Also

ServerControlEventSource Class | Borland.StarTeam Namespace


ServerControlEventSource.ServerStarted Event

public event ServerControlEventSource.Handler ServerStarted;

See Also

ServerControlEventSource Class | Borland.StarTeam Namespace


ServerControlEventSource.ServerStopped Event

public event ServerControlEventSource.Handler ServerStopped;

See Also

ServerControlEventSource Class | Borland.StarTeam Namespace


ServerControlEventSource.Handler Delegate

public delegate void ServerControlEventSource.Handler(
ServerControlEventSource source,
ServerControlEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


ServerException Class

For a list of all members of this type, see ServerException Members.

System.Object
Exception
ServerException
CommandAbortedException
ForeignPasswordException
ItemNotFoundException
LogonException
ServerUnavailableException

public class ServerException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerException Members | Borland.StarTeam Namespace


ServerException Members

ServerException overview

Public Static Methods

ForError |
Wrap | Dynamically wraps com.starbase.starteam.ServerException.

Public Static Type Conversions

Implicit ServerException to ServerException Conversion Implicitly convert ServerException to com.starbase.starteam.ServerException.

Public Instance Constructors

ServerException Constructor Construct ServerException from com.starbase.starteam.ServerException.

Public Instance Properties

AuxKeys |
ClassName |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode |
ErrorMessage |
ErrorSource |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged |
LogEntry |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged |

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerException Class | Borland.StarTeam Namespace


ServerException Constructor

Construct ServerException from com.starbase.starteam.ServerException.

public ServerException(
ServerException impl
);

Parameters

impl
The com.starbase.starteam.ServerException to be wrapped.

See Also

ServerException Class | Borland.StarTeam Namespace


ServerException Properties

The properties of the ServerException class are listed below. For a complete list of ServerException class members, see the ServerException Members topic.

Public Instance Properties

AuxKeys |
ClassName |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode |
ErrorMessage |
ErrorSource |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged |
LogEntry |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged |

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerException Class | Borland.StarTeam Namespace


AuxKeys Property

Borland StarTeam SDK for .NET

ServerException.AuxKeys Property

public virtual String[] AuxKeys {get;}

See Also

ServerException Class | Borland.StarTeam Namespace


ClassName Property

Borland StarTeam SDK for .NET

ServerException.ClassName Property

public virtual String ClassName {get;}

See Also

ServerException Class | Borland.StarTeam Namespace


ErrorCode Property

Borland StarTeam SDK for .NET

ServerException.ErrorCode Property

public virtual Int32 ErrorCode {get;}

See Also

ServerException Class | Borland.StarTeam Namespace


ErrorMessage Property

Borland StarTeam SDK for .NET

ServerException.ErrorMessage Property

public virtual String ErrorMessage {get; set;}

See Also

ServerException Class | Borland.StarTeam Namespace


ErrorSource Property

Borland StarTeam SDK for .NET

ServerException.ErrorSource Property

public virtual String ErrorSource {get;}

See Also

ServerException Class | Borland.StarTeam Namespace


IsLogged Property

Borland StarTeam SDK for .NET

ServerException.IsLogged Property

public virtual Boolean IsLogged {get;}

See Also

ServerException Class | Borland.StarTeam Namespace


LogEntry Property

Borland StarTeam SDK for .NET

ServerException.LogEntry Property

public virtual Int32 LogEntry {get;}

See Also

ServerException Class | Borland.StarTeam Namespace


NonLocalizedMessage Property

Borland StarTeam SDK for .NET

ServerException.NonLocalizedMessage Property

public virtual String NonLocalizedMessage {get;}

See Also

ServerException Class | Borland.StarTeam Namespace


TimeLogged Property

Borland StarTeam SDK for .NET

ServerException.TimeLogged Property

public virtual DateTime TimeLogged {get;}

See Also

ServerException Class | Borland.StarTeam Namespace


ServerException Methods

The methods of the ServerException class are listed below. For a complete list of ServerException class members, see the ServerException Members topic.

Public Static Methods

ForError |
Wrap | Dynamically wraps com.starbase.starteam.ServerException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerException Class | Borland.StarTeam Namespace


ServerException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ServerException

Implements

IWrapper.Unwrap

See Also

ServerException Class | Borland.StarTeam Namespace


ServerException.Equals Method

Delegate Equals() to com.starbase.starteam.ServerException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ServerException.Equals(obj).

See Also

ServerException Class | Borland.StarTeam Namespace


ServerException.ForError Method

public static ServerException ForError(
Server server,
String className,
String errorSource,
Int32 errorCode,
String errorMessage,
Boolean logged,
Double loggedTime,
Int32 logEntry,
Hashtable auxiliaryData
);

See Also

ServerException Class | Borland.StarTeam Namespace


ServerException.GetAuxData Method

public virtual object GetAuxData(
String key
);

See Also

ServerException Class | Borland.StarTeam Namespace


ServerException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ServerException.

public override int GetHashCode();

Return Value

com.starbase.starteam.ServerException.GetHashCode().

See Also

ServerException Class | Borland.StarTeam Namespace


ServerException.ToString Method

Delegate ToString() to com.starbase.starteam.ServerException.

public override string ToString();

Return Value

com.starbase.starteam.ServerException.ToString()

See Also

ServerException Class | Borland.StarTeam Namespace


ServerException.Wrap Method

Dynamically wraps com.starbase.starteam.ServerException.

public static ServerException Wrap(
ServerException impl
);

Parameters

impl
com.starbase.starteam.ServerException to be wrapped.

Return Value

ServerException

See Also

ServerException Class | Borland.StarTeam Namespace


ServerException Type Conversions

The type conversions of the ServerException class are listed below. For a complete list of ServerException class members, see the ServerException Members topic.

Public Static Type Conversions

Implicit ServerException to ServerException Conversion Implicitly convert ServerException to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerException Class | ServerException Members | Borland.StarTeam Namespace


ServerException Implicit ServerException to ServerException Conversion

Implicitly convert ServerException to com.starbase.starteam.ServerException.

public static implicit operator ServerException(
ServerException arg
);

Parameters

arg
ServerException to convert.

Return Value

com.starbase.starteam.ServerException

See Also

ServerException Class | Borland.StarTeam Namespace


ServerInfo Class

For a list of all members of this type, see ServerInfo Members.

System.Object
ServerInfo

public class ServerInfo : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerInfo Members | Borland.StarTeam Namespace


ServerInfo Members

ServerInfo overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerInfo.

Public Static Type Conversions

Implicit ServerInfo to ServerInfo Conversion Implicitly convert ServerInfo to com.starbase.starteam.ServerInfo.

Public Instance Constructors

ServerInfo Overloaded. Initializes a new instance of the ServerInfo class.

Public Instance Properties

AlwaysEnableCacheAgentForObjectProperties | [read/write] boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server
AutoLocateCacheAgent | [read/write] true to autolocate a cache agent, or false to use the cache agent at the specified address and port.
ConnectionType | [read/write] the connection type to be used.
DebugString | [read] a debug string representation of this server info.
Description | [read/write] the description for this server info entry.
EnableCacheAgentForFileContent | [read/write] boolean true to use a cache agent for file content checkout false to force all checkouts to use the StarTeam server directly.
EnableCacheAgentForObjectProperties | [read/write] boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server
Encryption | [read/write] the encryption algorithm to use for connections to the server.
Endpoint | [read/write] the protocol endpoint for the server info.
Host | [read/write] the host name for the server info.
IsCompression | [read/write] true if compression is to be used when communicating with the server.
MPXCacheAgentAddress | [read/write] The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.
MPXCacheAgentPort | [read/write] The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.
MPXCacheAgentThreadCount | [read/write] The number of threads used by the MPX cache agent to fetch file content. The default value is 3.
MPXProfileName | [read/write] The name of the MPX profile to be used when connecting to this server, or the empty string if MPX should not be enabled.
Owner | [read] the owning ServerList.
Port | [read/write] the protocol endpoint for the server info.

Public Instance Methods

Copy | return a copy of this ServerInfo
Equals | Delegate Equals() to com.starbase.starteam.ServerInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if this object instance is equal to the source
ToString | Delegate ToString() to com.starbase.starteam.ServerInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfo Constructor

Construct ServerInfo from com.starbase.starteam.ServerInfo.

Overload List

Construct a ServerInfo instance

public ServerInfo();

Create a copy of a ServerInfo from another one

public ServerInfo(ServerInfo);

Construct ServerInfo from com.starbase.starteam.ServerInfo.

public ServerInfo(ServerInfo);

Create a new ServerInfo object.

public ServerInfo(String,Int32,String,String,Boolean,EncryptionAlgorithm);

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfo Constructor (ServerInfo)

Construct ServerInfo from com.starbase.starteam.ServerInfo.

public ServerInfo(
ServerInfo impl
);

Parameters

impl
The com.starbase.starteam.ServerInfo to be wrapped.

See Also

ServerInfo Class | Borland.StarTeam Namespace | ServerInfo Constructor Overload List


ServerInfo Constructor ()

Construct a ServerInfo instance

public ServerInfo();

See Also

ServerInfo Class | Borland.StarTeam Namespace | ServerInfo Constructor Overload List


ServerInfo Constructor (ServerInfo)

Create a copy of a ServerInfo from another one

public ServerInfo(
ServerInfo source
);

Parameters

source

See Also

ServerInfo Class | Borland.StarTeam Namespace | ServerInfo Constructor Overload List


ServerInfo Constructor (String, Int32, String, String, Boolean, EncryptionAlgorithm)

Create a new ServerInfo object.

public ServerInfo(
String description,
Int32 connectionType,
String host,
String endpoint,
Boolean compression,
EncryptionAlgorithm encryption
);

Parameters

description
the description to use for this server entry
connectionType
the type of connection to use
host
the host address for the server
endpoint
the protocol specific endpoint. For TCP/IP connections this would be the TCP/IP port number.
compression
true if the connection should use compression
encryption
the type of encryption to use

See Also

ServerInfo Class | Borland.StarTeam Namespace | ServerInfo Constructor Overload List | PROTOCOL_LRPC | PROTOCOL_TCP_IP_SOCKETS | PROTOCOL_TCP_IP_SOCKETS_XML | PROTOCOL_NETBIOS | PROTOCOL_IPX | PROTOCOL_NAMED_PIPE | PROTOCOL_TCP_IP_RPC | ServerInfo


ServerInfo Properties

The properties of the ServerInfo class are listed below. For a complete list of ServerInfo class members, see the ServerInfo Members topic.

Public Instance Properties

AlwaysEnableCacheAgentForObjectProperties | [read/write] boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server
AutoLocateCacheAgent | [read/write] true to autolocate a cache agent, or false to use the cache agent at the specified address and port.
ConnectionType | [read/write] the connection type to be used.
DebugString | [read] a debug string representation of this server info.
Description | [read/write] the description for this server info entry.
EnableCacheAgentForFileContent | [read/write] boolean true to use a cache agent for file content checkout false to force all checkouts to use the StarTeam server directly.
EnableCacheAgentForObjectProperties | [read/write] boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server
Encryption | [read/write] the encryption algorithm to use for connections to the server.
Endpoint | [read/write] the protocol endpoint for the server info.
Host | [read/write] the host name for the server info.
IsCompression | [read/write] true if compression is to be used when communicating with the server.
MPXCacheAgentAddress | [read/write] The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.
MPXCacheAgentPort | [read/write] The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.
MPXCacheAgentThreadCount | [read/write] The number of threads used by the MPX cache agent to fetch file content. The default value is 3.
MPXProfileName | [read/write] The name of the MPX profile to be used when connecting to this server, or the empty string if MPX should not be enabled.
Owner | [read] the owning ServerList.
Port | [read/write] the protocol endpoint for the server info.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerInfo Class | Borland.StarTeam Namespace


AlwaysEnableCacheAgentForObjectProperties Property

Borland StarTeam SDK for .NET

ServerInfo.AlwaysEnableCacheAgentForObjectProperties Property

[read/write] boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server

public virtual Boolean AlwaysEnableCacheAgentForObjectProperties {get; set;}

Property Value

boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server

See Also

ServerInfo Class | Borland.StarTeam Namespace


AutoLocateCacheAgent Property

Borland StarTeam SDK for .NET

ServerInfo.AutoLocateCacheAgent Property

[read/write] true to autolocate a cache agent, or false to use the cache agent at the specified address and port.

public virtual Boolean AutoLocateCacheAgent {get; set;}

Property Value

true to autolocate a cache agent, or false to use the cache agent at the specified address and port.

See Also

ServerInfo Class | Borland.StarTeam Namespace


ConnectionType Property

Borland StarTeam SDK for .NET

ServerInfo.ConnectionType Property

[read/write] the connection type to be used.

public virtual Int32 ConnectionType {get; set;}

Property Value

the connection type to be used.

See Also

ServerInfo Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

ServerInfo.DebugString Property

[read] a debug string representation of this server info.

public virtual String DebugString {get;}

Property Value

a debug string representation of this server info.

See Also

ServerInfo Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

ServerInfo.Description Property

[read/write] the description for this server info entry.

public virtual String Description {get; set;}

Property Value

the description for this server info entry.

See Also

ServerInfo Class | Borland.StarTeam Namespace


EnableCacheAgentForFileContent Property

Borland StarTeam SDK for .NET

ServerInfo.EnableCacheAgentForFileContent Property

[read/write] boolean true to use a cache agent for file content checkout false to force all checkouts to use the StarTeam server directly.

public virtual Boolean EnableCacheAgentForFileContent {get; set;}

Property Value

boolean true to use a cache agent for file content checkout false to force all checkouts to use the StarTeam server directly.

See Also

ServerInfo Class | Borland.StarTeam Namespace


EnableCacheAgentForObjectProperties Property

Borland StarTeam SDK for .NET

ServerInfo.EnableCacheAgentForObjectProperties Property

[read/write] boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server

public virtual Boolean EnableCacheAgentForObjectProperties {get; set;}

Property Value

boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server

See Also

ServerInfo Class | Borland.StarTeam Namespace


Encryption Property

Borland StarTeam SDK for .NET

ServerInfo.Encryption Property

[read/write] the encryption algorithm to use for connections to the server.

public virtual EncryptionAlgorithm Encryption {get; set;}

Property Value

the encryption algorithm to use for connections to the server.

See Also

ServerInfo Class | Borland.StarTeam Namespace


Endpoint Property

Borland StarTeam SDK for .NET

ServerInfo.Endpoint Property

[read/write] the protocol endpoint for the server info.

public virtual String Endpoint {get; set;}

Property Value

the protocol endpoint for the server info.

See Also

ServerInfo Class | Borland.StarTeam Namespace


Host Property

Borland StarTeam SDK for .NET

ServerInfo.Host Property

[read/write] the host name for the server info.

public virtual String Host {get; set;}

Property Value

the host name for the server info.

See Also

ServerInfo Class | Borland.StarTeam Namespace


IsCompression Property

Borland StarTeam SDK for .NET

ServerInfo.IsCompression Property

[read/write] true if compression is to be used when communicating with the server.

public virtual Boolean IsCompression {get; set;}

Property Value

true if compression is to be used when communicating with the server.

See Also

ServerInfo Class | Borland.StarTeam Namespace


MPXCacheAgentAddress Property

Borland StarTeam SDK for .NET

ServerInfo.MPXCacheAgentAddress Property

[read/write] The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.

public virtual String MPXCacheAgentAddress {get; set;}

Property Value

The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.

See Also

ServerInfo Class | Borland.StarTeam Namespace


MPXCacheAgentPort Property

Borland StarTeam SDK for .NET

ServerInfo.MPXCacheAgentPort Property

[read/write] The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.

public virtual Int32 MPXCacheAgentPort {get; set;}

Property Value

The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.

See Also

ServerInfo Class | Borland.StarTeam Namespace


MPXCacheAgentThreadCount Property

Borland StarTeam SDK for .NET

ServerInfo.MPXCacheAgentThreadCount Property

[read/write] The number of threads used by the MPX cache agent to fetch file content. The default value is 3.

public virtual Int32 MPXCacheAgentThreadCount {get; set;}

Property Value

The number of threads used by the MPX cache agent to fetch file content. The default value is 3.

See Also

ServerInfo Class | Borland.StarTeam Namespace


MPXProfileName Property

Borland StarTeam SDK for .NET

ServerInfo.MPXProfileName Property

[read/write] The name of the MPX profile to be used when connecting to this server, or the empty string if MPX should not be enabled.

public virtual String MPXProfileName {get; set;}

Property Value

The name of the MPX profile to be used when connecting to this server, or the empty string if MPX should not be enabled.

See Also

ServerInfo Class | Borland.StarTeam Namespace


Owner Property

Borland StarTeam SDK for .NET

ServerInfo.Owner Property

[read] the owning ServerList.

public virtual ServerList Owner {get;}

Property Value

the owning ServerList.

See Also

ServerInfo Class | Borland.StarTeam Namespace


Port Property

Borland StarTeam SDK for .NET

ServerInfo.Port Property

[read/write] the protocol endpoint for the server info.

public virtual Int32 Port {get; set;}

Property Value

the protocol endpoint for the server info.

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfo Methods

The methods of the ServerInfo class are listed below. For a complete list of ServerInfo class members, see the ServerInfo Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerInfo.

Public Instance Methods

Copy | return a copy of this ServerInfo
Equals | Delegate Equals() to com.starbase.starteam.ServerInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if this object instance is equal to the source
ToString | Delegate ToString() to com.starbase.starteam.ServerInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfo.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ServerInfo

Implements

IWrapper.Unwrap

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfo.Copy Method

return a copy of this ServerInfo

public virtual ServerInfo Copy();

Return Value

ServerInfo a copy of this ServerInfo

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfo.Equals Method

Delegate Equals() to com.starbase.starteam.ServerInfo.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ServerInfo.Equals(obj).

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfo.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ServerInfo.

public override int GetHashCode();

Return Value

com.starbase.starteam.ServerInfo.GetHashCode().

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfo.IsEqualTo Method

returns true if this object instance is equal to the source

public virtual bool IsEqualTo(
ServerInfo source
);

Parameters

source
Object the source to comapre with

Return Value

boolean true if this object is equal to the source

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfo.ToString Method

Delegate ToString() to com.starbase.starteam.ServerInfo.

public override string ToString();

Return Value

com.starbase.starteam.ServerInfo.ToString()

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfo.Wrap Method

Dynamically wraps com.starbase.starteam.ServerInfo.

public static ServerInfo Wrap(
ServerInfo impl
);

Parameters

impl
com.starbase.starteam.ServerInfo to be wrapped.

Return Value

ServerInfo

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfo Type Conversions

The type conversions of the ServerInfo class are listed below. For a complete list of ServerInfo class members, see the ServerInfo Members topic.

Public Static Type Conversions

Implicit ServerInfo to ServerInfo Conversion Implicitly convert ServerInfo to com.starbase.starteam.ServerInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerInfo Class | ServerInfo Members | Borland.StarTeam Namespace


ServerInfo Implicit ServerInfo to ServerInfo Conversion

Implicitly convert ServerInfo to com.starbase.starteam.ServerInfo.

public static implicit operator ServerInfo(
ServerInfo arg
);

Parameters

arg
ServerInfo to convert.

Return Value

com.starbase.starteam.ServerInfo

See Also

ServerInfo Class | Borland.StarTeam Namespace


ServerInfoCollection Class

A strongly-typed collection of ServerInfos.

For a list of all members of this type, see ServerInfoCollection Members.

System.Object
ArrayAdapter
ServerInfoCollection

public class ServerInfoCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerInfoCollection Members | Borland.StarTeam Namespace


ServerInfoCollection Members

ServerInfoCollection overview

Public Static Methods

Wrap Creates a ServerInfoCollection to represent the given array of ServerInfo (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit ServerInfoCollection to ServerInfo[] Conversion | Converts a ServerInfoCollection to an array of ServerInfos.
Implicit ServerInfoCollection to ServerInfo[] Conversion | Converts a ServerInfoCollection from the Borland.StarTeam namespace to a ServerInfo[] in the com.starbase.starteam namespace.

Public Instance Constructors

ServerInfoCollection Overloaded. Initializes a new instance of the ServerInfoCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ServerInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a ServerInfo to end of the collection.
Append | Overloaded. Appends the ServerInfos of the given ServerInfoCollection to the end of this ServerInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ServerInfo.
CopyTo | Copies all of the ServerInfos in the ServerInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ServerInfo in the collection.
Insert | Inserts a ServerInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific ServerInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ServerInfos in this ServerInfoCollection.
Sort | Sorts the ServerInfos in this ServerInfoCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection Constructor

Initializes an instance of the ServerInfoCollection class.

Overload List

Initializes an instance of the ServerInfoCollection class.

public ServerInfoCollection();

Initializes an instance of the a ServerInfoCollection class, copying the given array.

public ServerInfoCollection(ServerInfo[]);

Initializes an instance of the a ServerInfoCollection class, copying the given collection.

public ServerInfoCollection(ServerInfoCollection);

Initializes an instance of the a ServerInfoCollection class, wrapping the given array of ServerInfo (from the com.starbase.starteam namespace).

public ServerInfoCollection(ServerInfo[]);

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection Constructor ()

Initializes an instance of the ServerInfoCollection class.

public ServerInfoCollection();

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace | ServerInfoCollection Constructor Overload List


ServerInfoCollection Constructor (ServerInfo[])

Initializes an instance of the a ServerInfoCollection class, wrapping the given array of ServerInfo (from the com.starbase.starteam namespace).

public ServerInfoCollection(
ServerInfo[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace | ServerInfoCollection Constructor Overload List | Wrap


ServerInfoCollection Constructor (ServerInfoCollection)

Initializes an instance of the a ServerInfoCollection class, copying the given collection.

public ServerInfoCollection(
ServerInfoCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member ServerInfo objects of the original collection are shared, not copied.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace | ServerInfoCollection Constructor Overload List


ServerInfoCollection Constructor (ServerInfo[])

Initializes an instance of the a ServerInfoCollection class, copying the given array.

public ServerInfoCollection(
ServerInfo[] array
);

Parameters

array
The array to be copied.

Remarks

The member ServerInfo objects of the original array are shared, not copied.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace | ServerInfoCollection Constructor Overload List


ServerInfoCollection Properties

The properties of the ServerInfoCollection class are listed below. For a complete list of ServerInfoCollection class members, see the ServerInfoCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ServerInfo at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

ServerInfoCollection.Item Property

Gets or sets the ServerInfo at the specified index.

public ServerInfo this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the ServerInfo to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection Methods

The methods of the ServerInfoCollection class are listed below. For a complete list of ServerInfoCollection class members, see the ServerInfoCollection Members topic.

Public Static Methods

Wrap Creates a ServerInfoCollection to represent the given array of ServerInfo (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a ServerInfo to end of the collection.
Append | Overloaded. Appends the ServerInfos of the given ServerInfoCollection to the end of this ServerInfoCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ServerInfo.
CopyTo | Copies all of the ServerInfos in the ServerInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ServerInfo in the collection.
Insert | Inserts a ServerInfo into the collection at the specified position.
Remove | Removes the first occurrence of a specific ServerInfo from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ServerInfos in this ServerInfoCollection.
Sort | Sorts the ServerInfos in this ServerInfoCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection.Add Method

Adds a ServerInfo to end of the collection.

public int Add(
ServerInfo value
);

Parameters

value
The ServerInfo to add to the collection.

Return Value

The position into which the new ServerInfo was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

ServerInfoCollection.Append Method

Appends the ServerInfos of the given array to the end of this ServerInfoCollection.

Overload List

Appends the ServerInfos of the given array to the end of this ServerInfoCollection.

public ServerInfoCollection Append(ServerInfo[]);

Appends the ServerInfos of the given ServerInfoCollection to the end of this ServerInfoCollection.

public ServerInfoCollection Append(ServerInfoCollection);

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection.Append Method (ServerInfo[])

Appends the ServerInfos of the given array to the end of this ServerInfoCollection.

public ServerInfoCollection Append(
ServerInfo[] array
);

Parameters

array
The array whose ServerInfos are to be appended to this ServerInfoCollection.

Return Value

This ServerInfoCollection, modified to include the new ServerInfos.

Remarks

The ServerInfoCollection is modified to include the new members. The individual ServerInfo objects are shared, not copied.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace | ServerInfoCollection.Append Overload List


ServerInfoCollection.Append Method (ServerInfoCollection)

Appends the ServerInfos of the given ServerInfoCollection to the end of this ServerInfoCollection.

public ServerInfoCollection Append(
ServerInfoCollection collection
);

Parameters

collection
The ServerInfoCollection whose ServerInfos are to be appended to this ServerInfoCollection.

Return Value

This ServerInfoCollection, modified to include the new ServerInfos.

Remarks

The ServerInfoCollection is modified to include the new members. The individual ServerInfo objects are shared, not copied.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace | ServerInfoCollection.Append Overload List


ServerInfoCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.ServerInfo[].

Implements

IWrapper.Unwrap

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection.Contains Method

Determines whether or not the collection contains a specific ServerInfo.

public bool Contains(
ServerInfo value
);

Parameters

value
The ServerInfo to locate in the collection.

Return Value

true if the ServerInfo is found in the collection; otherwise, false.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection.CopyTo Method

Copies all of the ServerInfos in the ServerInfoCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
ServerInfo[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the ServerInfos copied from the ServerInfoCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of ServerInfos in the source ServerInfoCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ServerInfoCollection cannot be cast automatically to the type of the destination array.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection.IndexOf Method

Determines the index of a specific ServerInfo in the collection.

public int IndexOf(
ServerInfo value
);

Parameters

value
The ServerInfo to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection.Insert Method

Inserts a ServerInfo into the collection at the specified position.

public void Insert(
Int32 index,
ServerInfo value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The ServerInfo to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection.Remove Method

Removes the first occurrence of a specific ServerInfo from the collection.

public void Remove(
ServerInfo value
);

Parameters

value
The ServerInfo to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection.Reverse Method

Reverses the order of the ServerInfos in this ServerInfoCollection.

new public ServerInfoCollection Reverse();

Return Value

This ServerInfoCollection, modified such that the ServerInfos are reversed.

Remarks

The ServerInfoCollection is modified in place.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection.Sort Method

Sorts the ServerInfos in this ServerInfoCollection, using the given comparer.

new public ServerInfoCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two ServerInfos.

Return Value

This ServerInfoCollection, modified such that the ServerInfos are sorted.

Remarks

The ServerInfoCollection is modified in place.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection.Wrap Method

Creates a ServerInfoCollection to represent the given array of ServerInfo (from the com.starbase.starteam namespace).

public static ServerInfoCollection Wrap(
ServerInfo[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ServerInfoCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a ServerInfo[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection Type Conversions

The type conversions of the ServerInfoCollection class are listed below. For a complete list of ServerInfoCollection class members, see the ServerInfoCollection Members topic.

Public Static Type Conversions

Implicit ServerInfoCollection to ServerInfo[] Conversion | Converts a ServerInfoCollection to an array of ServerInfos.
Implicit ServerInfoCollection to ServerInfo[] Conversion | Converts a ServerInfoCollection from the Borland.StarTeam namespace to a ServerInfo[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ServerInfoCollection Class | ServerInfoCollection Members | Borland.StarTeam Namespace


ServerInfoCollection Implicit ServerInfoCollection to ServerInfo[] Conversion

Converts a ServerInfoCollection to an array of ServerInfos.

public static implicit operator ServerInfo[](
ServerInfoCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new ServerInfo wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one ServerInfo wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerInfoCollection Implicit ServerInfoCollection to ServerInfo[] Conversion

Converts a ServerInfoCollection from the Borland.StarTeam namespace to a ServerInfo[] in the com.starbase.starteam namespace.

public static implicit operator ServerInfo[](
ServerInfoCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ServerInfoCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ServerInfoCollection Class | Borland.StarTeam Namespace


ServerLicenseInfo Class

Information about the licenses registered on a StarTeam Server.

For a list of all members of this type, see ServerLicenseInfo Members.

System.Object
ServerLicenseInfo

public class ServerLicenseInfo : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerLicenseInfo Members | Borland.StarTeam Namespace


ServerLicenseInfo Members

ServerLicenseInfo overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerLicenseInfo.

Public Static Type Conversions

Implicit ServerLicenseInfo to ServerLicenseInfo Conversion Implicitly convert ServerLicenseInfo to com.starbase.starteam.ServerLicenseInfo.

Public Instance Constructors

ServerLicenseInfo Constructor Construct ServerLicenseInfo from com.starbase.starteam.ServerLicenseInfo.

Public Instance Properties

AvailableFixedLicenses | [read] The number of fixed (named-user) licenses currently available on the server.
AvailableFloatingLicenses | [read] The number of floating (concurrent) licenses currently available on the server.
BLSLicenses | [read] The licenses managed by the Borland License Server.
BLSSlipGUIDs | [read] The Slip IDs of the licenses managed by the Borland License Server.
TotalFixedLicenses | [read] The total number of fixed (named-user) licenses registered on the server.
TotalFloatingLicenses | [read] The total number of floating (concurrent) licenses registered on the server.
UnassignedLicenseUsers | [read] The number of users without an assigned license on the server.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ServerLicenseInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerLicenseInfo.
GetNumUsersForBLSLicense | Gets the number of users currently assigned to the BLS license with the given Slip ID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ServerLicenseInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


ServerLicenseInfo Constructor

Construct ServerLicenseInfo from com.starbase.starteam.ServerLicenseInfo.

public ServerLicenseInfo(
ServerLicenseInfo impl
);

Parameters

impl
The com.starbase.starteam.ServerLicenseInfo to be wrapped.

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


ServerLicenseInfo Properties

The properties of the ServerLicenseInfo class are listed below. For a complete list of ServerLicenseInfo class members, see the ServerLicenseInfo Members topic.

Public Instance Properties

AvailableFixedLicenses | [read] The number of fixed (named-user) licenses currently available on the server.
AvailableFloatingLicenses | [read] The number of floating (concurrent) licenses currently available on the server.
BLSLicenses | [read] The licenses managed by the Borland License Server.
BLSSlipGUIDs | [read] The Slip IDs of the licenses managed by the Borland License Server.
TotalFixedLicenses | [read] The total number of fixed (named-user) licenses registered on the server.
TotalFloatingLicenses | [read] The total number of floating (concurrent) licenses registered on the server.
UnassignedLicenseUsers | [read] The number of users without an assigned license on the server.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


AvailableFixedLicenses Property

Borland StarTeam SDK for .NET

ServerLicenseInfo.AvailableFixedLicenses Property

[read] The number of fixed (named-user) licenses currently available on the server.

public virtual Int32 AvailableFixedLicenses {get;}

Property Value

The number of fixed (named-user) licenses currently available on the server.

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


AvailableFloatingLicenses Property

Borland StarTeam SDK for .NET

ServerLicenseInfo.AvailableFloatingLicenses Property

[read] The number of floating (concurrent) licenses currently available on the server.

public virtual Int32 AvailableFloatingLicenses {get;}

Property Value

The number of floating (concurrent) licenses currently available on the server.

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


BLSLicenses Property

Borland StarTeam SDK for .NET

ServerLicenseInfo.BLSLicenses Property

[read] The licenses managed by the Borland License Server.

public virtual BLSLicenseInfoCollection BLSLicenses {get;}

Property Value

The licenses managed by the Borland License Server.

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


BLSSlipGUIDs Property

Borland StarTeam SDK for .NET

ServerLicenseInfo.BLSSlipGUIDs Property

[read] The Slip IDs of the licenses managed by the Borland License Server.

public virtual Int32[] BLSSlipGUIDs {get;}

Property Value

The Slip IDs of the licenses managed by the Borland License Server.

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


TotalFixedLicenses Property

Borland StarTeam SDK for .NET

ServerLicenseInfo.TotalFixedLicenses Property

[read] The total number of fixed (named-user) licenses registered on the server.

public virtual Int32 TotalFixedLicenses {get;}

Property Value

The total number of fixed (named-user) licenses registered on the server.

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


TotalFloatingLicenses Property

Borland StarTeam SDK for .NET

ServerLicenseInfo.TotalFloatingLicenses Property

[read] The total number of floating (concurrent) licenses registered on the server.

public virtual Int32 TotalFloatingLicenses {get;}

Property Value

The total number of floating (concurrent) licenses registered on the server.

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


UnassignedLicenseUsers Property

Borland StarTeam SDK for .NET

ServerLicenseInfo.UnassignedLicenseUsers Property

[read] The number of users without an assigned license on the server.

public virtual Int32 UnassignedLicenseUsers {get;}

Property Value

The number of users without an assigned license on the server.

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


ServerLicenseInfo Methods

The methods of the ServerLicenseInfo class are listed below. For a complete list of ServerLicenseInfo class members, see the ServerLicenseInfo Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerLicenseInfo.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ServerLicenseInfo.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerLicenseInfo.
GetNumUsersForBLSLicense | Gets the number of users currently assigned to the BLS license with the given Slip ID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.ServerLicenseInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


ServerLicenseInfo.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ServerLicenseInfo

Implements

IWrapper.Unwrap

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


ServerLicenseInfo.Equals Method

Delegate Equals() to com.starbase.starteam.ServerLicenseInfo.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ServerLicenseInfo.Equals(obj).

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


ServerLicenseInfo.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ServerLicenseInfo.

public override int GetHashCode();

Return Value

com.starbase.starteam.ServerLicenseInfo.GetHashCode().

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


ServerLicenseInfo.GetNumUsersForBLSLicense Method

Gets the number of users currently assigned to the BLS license with the given Slip ID.

public virtual int GetNumUsersForBLSLicense(
Int32 slipGuid
);

Parameters

slipGuid
The Slip ID of a BLS license.

Return Value

The number of users currently assigned to the BLS license with the given Slip ID, or 0 if the given Slip ID does not refer to a valid BLS license.

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace | hasBLSLicensing


ServerLicenseInfo.ToString Method

Delegate ToString() to com.starbase.starteam.ServerLicenseInfo.

public override string ToString();

Return Value

com.starbase.starteam.ServerLicenseInfo.ToString()

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


ServerLicenseInfo.Wrap Method

Dynamically wraps com.starbase.starteam.ServerLicenseInfo.

public static ServerLicenseInfo Wrap(
ServerLicenseInfo impl
);

Parameters

impl
com.starbase.starteam.ServerLicenseInfo to be wrapped.

Return Value

ServerLicenseInfo

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


ServerLicenseInfo Type Conversions

The type conversions of the ServerLicenseInfo class are listed below. For a complete list of ServerLicenseInfo class members, see the ServerLicenseInfo Members topic.

Public Static Type Conversions

Implicit ServerLicenseInfo to ServerLicenseInfo Conversion Implicitly convert ServerLicenseInfo to com.starbase.starteam.ServerLicenseInfo.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerLicenseInfo Class | ServerLicenseInfo Members | Borland.StarTeam Namespace


ServerLicenseInfo Implicit ServerLicenseInfo to ServerLicenseInfo Conversion

Implicitly convert ServerLicenseInfo to com.starbase.starteam.ServerLicenseInfo.

public static implicit operator ServerLicenseInfo(
ServerLicenseInfo arg
);

Parameters

arg
ServerLicenseInfo to convert.

Return Value

com.starbase.starteam.ServerLicenseInfo

See Also

ServerLicenseInfo Class | Borland.StarTeam Namespace


ServerList Class

This class is used to manage a list of ServerInfo objects. Methods to read and write the server list to a file are supported. The server list file is also used by the StarTeam GUI.

For a list of all members of this type, see ServerList Members.

System.Object
ServerList

public class ServerList : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerList Members | Borland.StarTeam Namespace


ServerList Members

ServerList overview

Public Static Properties

DefaultFile [read] The default location that StarTeam applications should use for the server list. The default file name is "starteam-servers.xml".

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerList.

Public Static Type Conversions

Implicit ServerList to ServerList Conversion Implicitly convert ServerList to com.starbase.starteam.ServerList.

Public Instance Constructors

ServerList Overloaded. Initializes a new instance of the ServerList class.

Public Instance Properties

Servers | [read] all the servers in the server list.
SocketBasedServers | [read] the servers in the server list that use the "TCP/IP Sockets" or "XML over TCP/IP" protocol.

Public Instance Methods

AddServer | Adds the specified ServerInfo to this ServerList. An instance of a ServerInfo object can belong to only one ServerList. The server info will be added in alphabetical order (using case insensitive comparision).
Contains | Returns true if the specified server info is a member of this server list.
DescriptionExists | Return true if there exists a server info entry with the specified description. The comparison for description is case-insensitive.
Equals | Delegate Equals() to com.starbase.starteam.ServerList.
Find | Returns the server info entry with the specified description. The comparison for description is case-insensitive. Returns null if none found.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerList.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFrom | Loads the server list from the specified file. This will throw an exception if there are any problems reading the file or if the file is not a properly formatted server list file.
RemoveAll | Remove all the servers from the list.
RemoveServer | Removes the specified server info from the server list.
SaveTo | Writes the server list out to the specified file.
ToString | Delegate ToString() to com.starbase.starteam.ServerList.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList Constructor

Construct ServerList from com.starbase.starteam.ServerList.

Overload List

Initializes a new instance of the ServerList class.

public ServerList();

Construct ServerList from com.starbase.starteam.ServerList.

public ServerList(ServerList);

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList Constructor (ServerList)

Construct ServerList from com.starbase.starteam.ServerList.

public ServerList(
ServerList impl
);

Parameters

impl
The com.starbase.starteam.ServerList to be wrapped.

See Also

ServerList Class | Borland.StarTeam Namespace | ServerList Constructor Overload List


ServerList Constructor ()

Initializes a new instance of the ServerList class.

public ServerList();

See Also

ServerList Class | Borland.StarTeam Namespace | ServerList Constructor Overload List


ServerList Properties

The properties of the ServerList class are listed below. For a complete list of ServerList class members, see the ServerList Members topic.

Public Static Properties

DefaultFile [read] The default location that StarTeam applications should use for the server list. The default file name is "starteam-servers.xml".

Public Instance Properties

Servers | [read] all the servers in the server list.
SocketBasedServers | [read] the servers in the server list that use the "TCP/IP Sockets" or "XML over TCP/IP" protocol.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerList Class | Borland.StarTeam Namespace


DefaultFile Property

Borland StarTeam SDK for .NET

ServerList.DefaultFile Property

[read] The default location that StarTeam applications should use for the server list. The default file name is "starteam-servers.xml".

public static FileInfo DefaultFile {get;}

Property Value

The default location that StarTeam applications should use for the server list. The default file name is "starteam-servers.xml".

See Also

ServerList Class | Borland.StarTeam Namespace


Servers Property

Borland StarTeam SDK for .NET

ServerList.Servers Property

[read] all the servers in the server list.

public virtual ServerInfoCollection Servers {get;}

Property Value

all the servers in the server list.

See Also

ServerList Class | Borland.StarTeam Namespace


SocketBasedServers Property

Borland StarTeam SDK for .NET

ServerList.SocketBasedServers Property

[read] the servers in the server list that use the "TCP/IP Sockets" or "XML over TCP/IP" protocol.

public virtual ServerInfoCollection SocketBasedServers {get;}

Property Value

the servers in the server list that use the "TCP/IP Sockets" or "XML over TCP/IP" protocol.

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList Methods

The methods of the ServerList class are listed below. For a complete list of ServerList class members, see the ServerList Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerList.

Public Instance Methods

AddServer | Adds the specified ServerInfo to this ServerList. An instance of a ServerInfo object can belong to only one ServerList. The server info will be added in alphabetical order (using case insensitive comparision).
Contains | Returns true if the specified server info is a member of this server list.
DescriptionExists | Return true if there exists a server info entry with the specified description. The comparison for description is case-insensitive.
Equals | Delegate Equals() to com.starbase.starteam.ServerList.
Find | Returns the server info entry with the specified description. The comparison for description is case-insensitive. Returns null if none found.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ServerList.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFrom | Loads the server list from the specified file. This will throw an exception if there are any problems reading the file or if the file is not a properly formatted server list file.
RemoveAll | Remove all the servers from the list.
RemoveServer | Removes the specified server info from the server list.
SaveTo | Writes the server list out to the specified file.
ToString | Delegate ToString() to com.starbase.starteam.ServerList.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.AddServer Method

Adds the specified ServerInfo to this ServerList. An instance of a ServerInfo object can belong to only one ServerList. The server info will be added in alphabetical order (using case insensitive comparision).

public virtual void AddServer(
ServerInfo info
);

Parameters

info
the server info to add (cannot be null)

Exceptions

Exception Type | Condition
 | com.starbase.starteam.DuplicateServerListEntryException

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ServerList

Implements

IWrapper.Unwrap

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.Contains Method

Returns true if the specified server info is a member of this server list.

public virtual bool Contains(
ServerInfo info
);

Parameters

info
the server info to check for

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.DescriptionExists Method

Return true if there exists a server info entry with the specified description. The comparison for description is case-insensitive.

public virtual bool DescriptionExists(
String description
);

Parameters

description
the description of the server info entry to be found

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.Equals Method

Delegate Equals() to com.starbase.starteam.ServerList.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ServerList.Equals(obj).

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.Find Method

Returns the server info entry with the specified description. The comparison for description is case-insensitive. Returns null if none found.

public virtual ServerInfo Find(
String description
);

Parameters

description
the description of the server info entry to be found

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ServerList.

public override int GetHashCode();

Return Value

com.starbase.starteam.ServerList.GetHashCode().

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.LoadFrom Method

Loads the server list from the specified file. This will throw an exception if there are any problems reading the file or if the file is not a properly formatted server list file.

public virtual void LoadFrom(
FileInfo file
);

Parameters

file
the from which to load the server list.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.RemoveAll Method

Remove all the servers from the list.

public virtual void RemoveAll();

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.RemoveServer Method

Removes the specified server info from the server list.

public virtual void RemoveServer(
ServerInfo info
);

Parameters

info
the server info to remove

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.SaveTo Method

Writes the server list out to the specified file.

public virtual void SaveTo(
FileInfo file
);

Parameters

file
the file to save the list to

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.ToString Method

Delegate ToString() to com.starbase.starteam.ServerList.

public override string ToString();

Return Value

com.starbase.starteam.ServerList.ToString()

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList.Wrap Method

Dynamically wraps com.starbase.starteam.ServerList.

public static ServerList Wrap(
ServerList impl
);

Parameters

impl
com.starbase.starteam.ServerList to be wrapped.

Return Value

ServerList

See Also

ServerList Class | Borland.StarTeam Namespace


ServerList Type Conversions

The type conversions of the ServerList class are listed below. For a complete list of ServerList class members, see the ServerList Members topic.

Public Static Type Conversions

Implicit ServerList to ServerList Conversion Implicitly convert ServerList to com.starbase.starteam.ServerList.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ServerList Class | ServerList Members | Borland.StarTeam Namespace


ServerList Implicit ServerList to ServerList Conversion

Implicitly convert ServerList to com.starbase.starteam.ServerList.

public static implicit operator ServerList(
ServerList arg
);

Parameters

arg
ServerList to convert.

Return Value

com.starbase.starteam.ServerList

See Also

ServerList Class | Borland.StarTeam Namespace


ServerSession Interface

Represents a user's session with the server. Note: Though this class is public, it is for internal use only.

For a list of all members of this type, see ServerSession Members.

public interface ServerSession

Types that implement ServerSession

Type | Description
ServerSessionAdapter |

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerSession Members | Borland.StarTeam Namespace


ServerSession Members

ServerSession overview

Public Instance Properties

ID | [read] the session identifier.
UserID | [read] the user ID for the logged in to this session.

See Also

ServerSession Interface | Borland.StarTeam Namespace


ServerSession Properties

The properties of the ServerSession interface are listed below. For a complete list of ServerSession interface members, see the ServerSession Members topic.

Public Instance Properties

ID | [read] the session identifier.
UserID | [read] the user ID for the logged in to this session.

See Also

ServerSession Interface | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ServerSession.ID Property

[read] the session identifier.

GUID ID {get;}

Property Value

the session identifier.

See Also

ServerSession Interface | Borland.StarTeam Namespace


UserID Property

Borland StarTeam SDK for .NET

ServerSession.UserID Property

[read] the user ID for the logged in to this session.

Int32 UserID {get;}

Property Value

the user ID for the logged in to this session.

See Also

ServerSession Interface | Borland.StarTeam Namespace


ServerSessionAdapter Class

For a list of all members of this type, see ServerSessionAdapter Members.

System.Object
ServerSessionAdapter

public class ServerSessionAdapter : ServerSession, ServerSession

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerSessionAdapter Members | Borland.StarTeam Namespace


ServerSessionAdapter Members

ServerSessionAdapter overview

Public Instance Constructors

ServerSessionAdapter Overloaded. Initializes a new instance of the ServerSessionAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ServerSession.getID
ServerSession.getUserID
ServerSession.ID
ServerSession.UserID

See Also

ServerSessionAdapter Class | Borland.StarTeam Namespace


ServerSessionAdapter Constructor

Overload List

public ServerSessionAdapter(ServerSession);

public ServerSessionAdapter(ServerSession);

See Also

ServerSessionAdapter Class | Borland.StarTeam Namespace


ServerSessionAdapter Constructor (ServerSession)

public ServerSessionAdapter(
ServerSession arg
);

See Also

ServerSessionAdapter Class | Borland.StarTeam Namespace | ServerSessionAdapter Constructor Overload List


ServerSessionAdapter Properties

The properties of the ServerSessionAdapter class are listed below. For a complete list of ServerSessionAdapter class members, see the ServerSessionAdapter Members topic.

Explicit Interface Implementations

ServerSession.getID
ServerSession.getUserID
ServerSession.ID
ServerSession.UserID

See Also

ServerSessionAdapter Class | Borland.StarTeam Namespace


ServerSession.ID Property

Borland StarTeam SDK for .NET

ServerSessionAdapter.ServerSession.ID Property

private GUID ServerSession.ID {get;}

Implements

ServerSession.ID

See Also

ServerSessionAdapter Class | Borland.StarTeam Namespace


ServerSession.UserID Property

Borland StarTeam SDK for .NET

ServerSessionAdapter.ServerSession.UserID Property

private Int32 ServerSession.UserID {get;}

Implements

ServerSession.UserID

See Also

ServerSessionAdapter Class | Borland.StarTeam Namespace


ServerSessionAdapter Methods

The methods of the ServerSessionAdapter class are listed below. For a complete list of ServerSessionAdapter class members, see the ServerSessionAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ServerSession.getID
ServerSession.getUserID
ServerSession.ID
ServerSession.UserID

See Also

ServerSessionAdapter Class | Borland.StarTeam Namespace


ServerSessionAdapter.ServerSession.getID Method

GUID ServerSession.getID();

Implements

ServerSession.getID

See Also

ServerSessionAdapter Class | Borland.StarTeam Namespace


ServerSessionAdapter.ServerSession.getUserID Method

int ServerSession.getUserID();

Implements

ServerSession.getUserID

See Also

ServerSessionAdapter Class | Borland.StarTeam Namespace


ServerUnavailableException Class

For a list of all members of this type, see ServerUnavailableException Members.

System.Object
Exception
ServerException
ServerUnavailableException

public class ServerUnavailableException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ServerUnavailableException Members | Borland.StarTeam Namespace


ServerUnavailableException Members

ServerUnavailableException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerUnavailableException.

Public Static Type Conversions

Implicit ServerUnavailableException to ServerUnavailableException Conversion Implicitly convert ServerUnavailableException to com.starbase.starteam.ServerUnavailableException.

Public Instance Constructors

ServerUnavailableException Constructor Construct ServerUnavailableException from com.starbase.starteam.ServerUnavailableException.

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

ServerUnavailableException Class | Borland.StarTeam Namespace


ServerUnavailableException Constructor

Construct ServerUnavailableException from com.starbase.starteam.ServerUnavailableException.

public ServerUnavailableException(
ServerUnavailableException impl
);

Parameters

impl
The com.starbase.starteam.ServerUnavailableException to be wrapped.

See Also

ServerUnavailableException Class | Borland.StarTeam Namespace


ServerUnavailableException Methods

The methods of the ServerUnavailableException class are listed below. For a complete list of ServerUnavailableException class members, see the ServerUnavailableException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ServerUnavailableException.

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starbase.starteam.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starbase.starteam.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starbase.starteam.ServerException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

ServerUnavailableException Class | Borland.StarTeam Namespace


ServerUnavailableException.Wrap Method

Dynamically wraps com.starbase.starteam.ServerUnavailableException.

public static ServerUnavailableException Wrap(
ServerUnavailableException impl
);

Parameters

impl
com.starbase.starteam.ServerUnavailableException to be wrapped.

Return Value

ServerUnavailableException

See Also

ServerUnavailableException Class | Borland.StarTeam Namespace


ServerUnavailableException Type Conversions

The type conversions of the ServerUnavailableException class are listed below. For a complete list of ServerUnavailableException class members, see the ServerUnavailableException Members topic.

Public Static Type Conversions

Implicit ServerUnavailableException to ServerUnavailableException Conversion Implicitly convert ServerUnavailableException to com.starbase.starteam.ServerUnavailableException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from ServerException) Implementation of IWrapper.Unwrap().

See Also

ServerUnavailableException Class | ServerUnavailableException Members | Borland.StarTeam Namespace


ServerUnavailableException Implicit ServerUnavailableException to ServerUnavailableException Conversion

Implicitly convert ServerUnavailableException to com.starbase.starteam.ServerUnavailableException.

public static implicit operator ServerUnavailableException(
ServerUnavailableException arg
);

Parameters

arg
ServerUnavailableException to convert.

Return Value

com.starbase.starteam.ServerUnavailableException

See Also

ServerUnavailableException Class | Borland.StarTeam Namespace


SimpleKeyword Class

A Keyword object that encapsulates information about a File keyword. When checking a file is added, checked-in or checked-out of the repository keyword expansion may be applied to the contents of the file. For example, an occurance of $Author$ in a file might be be replaced with $Author: Fred$ upon checkout.

For a list of all members of this type, see SimpleKeyword Members.

System.Object
SimpleKeyword
HistoryKeyword
LogKeyword
NoKeywords

public class SimpleKeyword : Keyword

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SimpleKeyword Members | Borland.StarTeam Namespace


SimpleKeyword Members

SimpleKeyword overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SimpleKeyword.

Public Static Type Conversions

Implicit SimpleKeyword to SimpleKeyword Conversion Implicitly convert SimpleKeyword to com.starbase.starteam.SimpleKeyword.

Public Instance Constructors

SimpleKeyword Overloaded. Initializes a new instance of the SimpleKeyword class.

Public Instance Properties

IsMultiLine
Name
StopExpanding
Value
XMLString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


SimpleKeyword Constructor

Construct SimpleKeyword from com.starbase.starteam.SimpleKeyword.

Overload List

Construct SimpleKeyword from com.starbase.starteam.SimpleKeyword.

public SimpleKeyword(SimpleKeyword);

Create a new basic keyword object with the specified name and expansion value.

public SimpleKeyword(String,String);

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


SimpleKeyword Constructor (SimpleKeyword)

Construct SimpleKeyword from com.starbase.starteam.SimpleKeyword.

public SimpleKeyword(
SimpleKeyword impl
);

Parameters

impl
The com.starbase.starteam.SimpleKeyword to be wrapped.

See Also

SimpleKeyword Class | Borland.StarTeam Namespace | SimpleKeyword Constructor Overload List


SimpleKeyword Constructor (String, String)

Create a new basic keyword object with the specified name and expansion value.

public SimpleKeyword(
String name,
String value
);

Parameters

name
the name of the keyword. E.g. "Author"
value
the value to expand to. E.g. "Fred"

See Also

SimpleKeyword Class | Borland.StarTeam Namespace | SimpleKeyword Constructor Overload List


SimpleKeyword Properties

The properties of the SimpleKeyword class are listed below. For a complete list of SimpleKeyword class members, see the SimpleKeyword Members topic.

Public Instance Properties

IsMultiLine
Name
StopExpanding
Value
XMLString

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


IsMultiLine Property

Borland StarTeam SDK for .NET

SimpleKeyword.IsMultiLine Property

public virtual Boolean IsMultiLine {get;}

Implements

Keyword.IsMultiLine

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

SimpleKeyword.Name Property

public virtual String Name {get;}

Implements

Keyword.Name

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


StopExpanding Property

Borland StarTeam SDK for .NET

SimpleKeyword.StopExpanding Property

public virtual Boolean StopExpanding {get;}

Implements

Keyword.StopExpanding

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


Value Property

Borland StarTeam SDK for .NET

SimpleKeyword.Value Property

public virtual String Value {get;}

Implements

Keyword.Value

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


XMLString Property

Borland StarTeam SDK for .NET

SimpleKeyword.XMLString Property

public virtual String XMLString {get;}

Implements

Keyword.XMLString

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


SimpleKeyword Methods

The methods of the SimpleKeyword class are listed below. For a complete list of SimpleKeyword class members, see the SimpleKeyword Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SimpleKeyword.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


SimpleKeyword.Expand Method

public virtual string Expand(
String linePrefix,
String eol,
Boolean expand
);

Implements

Keyword.Expand

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


SimpleKeyword.Matches Method

public virtual bool Matches(
String line,
Int32 start,
Int32[] endPos
);

Implements

Keyword.Matches

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


SimpleKeyword.Wrap Method

Dynamically wraps com.starbase.starteam.SimpleKeyword.

public static SimpleKeyword Wrap(
SimpleKeyword impl
);

Parameters

impl
com.starbase.starteam.SimpleKeyword to be wrapped.

Return Value

SimpleKeyword

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


SimpleKeyword Type Conversions

The type conversions of the SimpleKeyword class are listed below. For a complete list of SimpleKeyword class members, see the SimpleKeyword Members topic.

Public Static Type Conversions

Implicit SimpleKeyword to SimpleKeyword Conversion Implicitly convert SimpleKeyword to com.starbase.starteam.SimpleKeyword.

See Also

SimpleKeyword Class | SimpleKeyword Members | Borland.StarTeam Namespace


SimpleKeyword Implicit SimpleKeyword to SimpleKeyword Conversion

Implicitly convert SimpleKeyword to com.starbase.starteam.SimpleKeyword.

public static implicit operator SimpleKeyword(
SimpleKeyword arg
);

Parameters

arg
SimpleKeyword to convert.

Return Value

com.starbase.starteam.SimpleKeyword

See Also

SimpleKeyword Class | Borland.StarTeam Namespace


SimpleTypedResource Class

A simple implementation of the TypedResource class.

For a list of all members of this type, see SimpleTypedResource Members.

System.Object
TypedResource
SimpleTypedResource
Derived types

public class SimpleTypedResource : TypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SimpleTypedResource Members | Borland.StarTeam Namespace


SimpleTypedResource Members

SimpleTypedResource overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SimpleTypedResource.

Public Static Type Conversions

Implicit SimpleTypedResource to SimpleTypedResource Conversion Implicitly convert SimpleTypedResource to com.starbase.starteam.SimpleTypedResource.

Public Instance Constructors

SimpleTypedResource Overloaded. Initializes a new instance of the SimpleTypedResource class.

Public Instance Properties

ID | [read] the identifier for the resource object.
Item (inherited from TypedResource) |
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.

Public Instance Methods

AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

SimpleTypedResource Class | Borland.StarTeam Namespace


SimpleTypedResource Constructor

Construct SimpleTypedResource from com.starbase.starteam.SimpleTypedResource.

Overload List

Create a new SimpleTypedResource based on a Type.

public SimpleTypedResource(Type);

Construct SimpleTypedResource from com.starbase.starteam.SimpleTypedResource.

public SimpleTypedResource(SimpleTypedResource);

See Also

SimpleTypedResource Class | Borland.StarTeam Namespace


SimpleTypedResource Constructor (SimpleTypedResource)

Construct SimpleTypedResource from com.starbase.starteam.SimpleTypedResource.

public SimpleTypedResource(
SimpleTypedResource impl
);

Parameters

impl
The com.starbase.starteam.SimpleTypedResource to be wrapped.

See Also

SimpleTypedResource Class | Borland.StarTeam Namespace | SimpleTypedResource Constructor Overload List


SimpleTypedResource Constructor (Type)

Create a new SimpleTypedResource based on a Type.

public SimpleTypedResource(
Type type
);

Parameters

type
the Type for this resource.

See Also

SimpleTypedResource Class | Borland.StarTeam Namespace | SimpleTypedResource Constructor Overload List


SimpleTypedResource Properties

The properties of the SimpleTypedResource class are listed below. For a complete list of SimpleTypedResource class members, see the SimpleTypedResource Members topic.

Public Instance Properties

ID | [read] the identifier for the resource object.
Item (inherited from TypedResource) |
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

SimpleTypedResource Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

SimpleTypedResource.ID Property

[read] the identifier for the resource object.

public virtual Int32 ID {get;}

Property Value

the identifier for the resource object.

See Also

SimpleTypedResource Class | Borland.StarTeam Namespace


SimpleTypedResource Methods

The methods of the SimpleTypedResource class are listed below. For a complete list of SimpleTypedResource class members, see the SimpleTypedResource Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SimpleTypedResource.

Public Instance Methods

AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

SimpleTypedResource Class | Borland.StarTeam Namespace


SimpleTypedResource.PutByPropertyID Method

Set the value of the property specified by its property ID and return the old value.

public virtual object PutByPropertyID(
Int32 propertyID,
Object value
);

Parameters

propertyID
the ID of the property to set
value
the new value to set for the specified property

Return Value

the old property value

Exceptions

Exception Type | Condition
 | com.starbase.starteam.NoSuchPropertyException
 | System.InvalidCastException

See Also

SimpleTypedResource Class | Borland.StarTeam Namespace | getID


SimpleTypedResource.Wrap Method

Dynamically wraps com.starbase.starteam.SimpleTypedResource.

public static SimpleTypedResource Wrap(
SimpleTypedResource impl
);

Parameters

impl
com.starbase.starteam.SimpleTypedResource to be wrapped.

Return Value

SimpleTypedResource

See Also

SimpleTypedResource Class | Borland.StarTeam Namespace


SimpleTypedResource Type Conversions

The type conversions of the SimpleTypedResource class are listed below. For a complete list of SimpleTypedResource class members, see the SimpleTypedResource Members topic.

Public Static Type Conversions

Implicit SimpleTypedResource to SimpleTypedResource Conversion Implicitly convert SimpleTypedResource to com.starbase.starteam.SimpleTypedResource.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

SimpleTypedResource Class | SimpleTypedResource Members | Borland.StarTeam Namespace


SimpleTypedResource Implicit SimpleTypedResource to SimpleTypedResource Conversion

Implicitly convert SimpleTypedResource to com.starbase.starteam.SimpleTypedResource.

public static implicit operator SimpleTypedResource(
SimpleTypedResource arg
);

Parameters

arg
SimpleTypedResource to convert.

Return Value

com.starbase.starteam.SimpleTypedResource

See Also

SimpleTypedResource Class | Borland.StarTeam Namespace


StarTeamClientOptions Class

For a list of all members of this type, see StarTeamClientOptions Members.

System.Object
StarTeamClientOptions

public class StarTeamClientOptions : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

StarTeamClientOptions Members | Borland.StarTeam Namespace


StarTeamClientOptions Members

StarTeamClientOptions overview

Public Static Properties

CHANGE_CHECK_NEW_ITEM_ACTIVATED |
CHANGE_CHECK_NEW_ITEM_INTERVAL |
CHANGE_READ_ON_SELECT_CHANGE_ACTIVATED |
CHANGE_SELECTED_ITEM_TIMER_ACTIVATED |
CHANGE_SELECTED_ITEM_TIMER_INTERVAL |
Default | [read]
DefaultFile | [read]
FILE_CENTRAL_STATUS_DIRECTORY |
FILE_CLEAR_LOCKS_ON_CHECK_IN |
FILE_COMPARE_OPTIONS |
FILE_COMPARE_PATH |
FILE_DEFAULT_ENCODING |
FILE_DEFAULT_EOL |
FILE_DEFAULT_STATUS_METHOD |
FILE_EDITOR_OPTIONS |
FILE_EDITOR_PATH |
FILE_LOCALDIRECTORYWATCH |
FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT |
FILE_MARK_UNLOCKED_FILES_READ_ONLY |
FILE_MERGE_OPTIONS |
FILE_MERGE_PATH |
FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS |
FILE_PERFORM_EOL_CONVERSION |
FILE_POPUP_VISMERGE_ALWAYS |
FILE_USE_ALTERNATE_COMPARE |
FILE_USE_ALTERNATE_EDITOR |
FILE_USE_ALTERNATE_MERGE |
FILE_USE_MD5_TO_CALCULATE_STATUS |
FILE_USE_MODIFIED_TIME_STAMP |
FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS |
TASK_CHECK_NEW_ITEM_ACTIVATED |
TASK_CHECK_NEW_ITEM_INTERVAL |
TASK_READ_ON_SELECT_CHANGE_ACTIVATED |
TASK_SELECTED_ITEM_TIMER_ACTIVATED |
TASK_SELECTED_ITEM_TIMER_INTERVAL |
TOPIC_CHECK_NEW_ITEM_ACTIVATED |
TOPIC_CHECK_NEW_ITEM_INTERVAL |
TOPIC_READ_ON_SELECT_CHANGE_ACTIVATED |
TOPIC_SELECTED_ITEM_TIMER_ACTIVATED |
TOPIC_SELECTED_ITEM_TIMER_INTERVAL |
WORKSPACE_AUTO_REFRESH |
WORKSPACE_CHANGE_SCOPE_FOLDER |
WORKSPACE_CONFIRM_DELETE |
WORKSPACE_CONFIRM_MOVE |
WORKSPACE_FALCON |
WORKSPACE_FOLDER_CONTEXT |
WORKSPACE_HISTORY_UTC |
WORKSPACE_INSTANT_REFRESH |
WORKSPACE_INSTANT_REFRESH_MAX_TIME |
WORKSPACE_INSTANT_REFRESH_MIN_TIME |
WORKSPACE_LOG_COMMAND_DETAILS |
WORKSPACE_LOG_COMMANDS |
WORKSPACE_LOG_ERRORS |
WORKSPACE_LOG_EVENTS |
WORKSPACE_LOG_OUTPUT_PATH |
WORKSPACE_LOG_THRESHOLD |
WORKSPACE_LOG_UI_OPERATIONS |
WORKSPACE_MAINTAIN_GROUP_STATE |
WORKSPACE_REFRESH_TIME |
WORKSPACE_REPORT_OUTPUT_PATH |
WORKSPACE_RESTORE_SHORTCUTS |
WORKSPACE_SHOW_STATUSBAR |
WORKSPACE_SHOW_TOOLBARS |
WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS |
WORKSPACE_WARNINGS |

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.StarTeamClientOptions.

Public Static Type Conversions

Implicit StarTeamClientOptions to StarTeamClientOptions Conversion Implicitly convert StarTeamClientOptions to com.starbase.starteam.StarTeamClientOptions.

Public Instance Constructors

StarTeamClientOptions Overloaded. Initializes a new instance of the StarTeamClientOptions class.

Public Instance Properties

CentralStatusDirectory | [read/write]
ChangeCheckNewItemActivated | [read/write] option value. Default if not defined: true
ChangeCheckNewItemInterval | [read/write] option value. Default if not defined: 600
ChangeReadOnSelectChangeActivated | [read/write] option value. Default if not defined: false
ChangeSelectedItemTimerActivated | [read/write] option value. Default if not defined: false
ChangeSelectedItemTimerInterval | [read/write] option value. Default if not defined: 45
DefaultStatusMethod | [read/write] the default status method to be used by the client. If not set in these options then this method CENTRAL.
FileClearLocksOnCheckIn | [read/write] option value. Default if not defined: false
FileCompareOptions | [read/write] option value. Default if not defined: ""
FileComparePath | [read/write] option value. Default if not defined: ""
FileDefaultEncoding | [read/write] option value. Default if not defined: the value of the system property "file.encoding"
FileDefaultEOL | [read/write] option value. Default if not defined: "CRLF"
FileEditorOptions | [read/write] option value. Default if not defined: ""
FileEditorPath | [read/write] option value. Default if not defined: ""
FileLocalDirectoryWatch | [read/write] option value. Default if not defined: true
FileLockFilesExclusivelyOnCheckOut | [read/write] option value. Default if not defined: false
FileMarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
FileMergeOptions | [read/write] option value. Default if not defined: ""
FileMergePath | [read/write] option value. Default if not defined: ""
FileOptimizeForSlowConnections | [read/write] option value. Default if not defined: false
FilePerformEOLConversion | [read/write] option value. Default if not defined: true
FilePopupVisMergeAlways | [read/write] option value. Default if not defined: true
FileUseAlternateCompare | [read/write] option value. Default if not defined: false
FileUseAlternateEditor | [read/write] option value. Default if not defined: false
FileUseAlternateMerge | [read/write] option value. Default if not defined: false
FileUseMD5ToCalculateStatus | [read/write] option value. Default if not defined: false
FileUseModifiedTimeStamp | [read/write] option value. Default if not defined: false
FileUseNonExclusiveLocksInIntegrations | [read/write] option value. Default if not defined: true
MPXEnabled | [read/write] option value. Default if not defined: true
TaskCheckNewItemActivated | [read/write] option value. Default if not defined: true
TaskCheckNewItemInterval | [read/write] option value. Default if not defined: 600
TaskReadOnSelectChangeActivated | [read/write] option value. Default if not defined: false
TaskSelectedItemTimerActivated | [read/write] option value. Default if not defined: false
TaskSelectedItemTimerInterval | [read/write] option value. Default if not defined: 45
TopicCheckNewItemActivated | [read/write] option value. Default if not defined: true
TopicCheckNewItemInterval | [read/write] option value. Default if not defined: 600
TopicReadOnSelectChangeActivated | [read/write] option value. Default if not defined: false
TopicSelectedItemTimerActivated | [read/write] option value. Default if not defined: false
TopicSelectedItemTimerInterval | [read/write] option value. Default if not defined: 45
WorkspaceAutoRefresh | [read/write] option value. Default if not defined: false
WorkspaceChangeScopeFolder | [read/write] option value. Default if not defined: false
WorkspaceConfirmDelete | [read/write] option value. Default if not defined: true
WorkspaceConfirmMove | [read/write] option value. Default if not defined: true
WorkspaceFalcon | [read/write] option value. Default if not defined: true
WorkspaceFolderContext | [read/write] option value. Default if not defined: true
WorkspaceHistoryUTC | [read/write] option value. Default if not defined: false
WorkspaceInstantRefresh | [read/write] option value. Default if not defined: true
WorkspaceInstantRefreshMaxTime | [read/write] option value. Default if not defined: 30
WorkspaceInstantRefreshMinTime | [read/write] option value. Default if not defined: 5
WorkspaceLogCommandDetails | [read/write] option value. Default if not defined: false
WorkspaceLogCommands | [read/write] option value. Default if not defined: false
WorkspaceLogErrors | [read/write] option value. Default if not defined: true
WorkspaceLogEvents | [read/write] option value. Default if not defined: false
WorkspaceLogOutputPath | [read/write] option value. Default if not defined: ""
WorkspaceLogThreshold | [read/write] option value. Default if not defined: 10
WorkspaceLogUIOperations | [read/write] option value. Default if not defined: false
WorkspaceMaintainGroupState | [read/write] option value. Default if not defined: true
WorkspaceRefreshTime | [read/write] option value. Default if not defined: false
WorkspaceReportOutputPath | [read/write] option value. Default if not defined: ""
WorkspaceRestoreShortcuts | [read/write] option value. Default if not defined: true
WorkspaceShowStatusBar | [read/write] option value. Default if not defined: true
WorkspaceShowToolbars | [read/write] option value. Default if not defined: true
WorkspaceShowVirtualMeetingOptions | [read/write] option value. Default if not defined: false
WorkspaceWarnings | [read/write] option value. Default if not defined: true

Public Instance Methods

ClearProcessItem | Clears the process item for the specified view.
Equals | Delegate Equals() to com.starbase.starteam.StarTeamClientOptions.
GetAllProcessItems | Gets the list of items that have been set as the current process item for at least one view on the given server.
GetComponentOption | Returns the specified workstation option. If the option is not set then the specified default value is returned.
GetFolderAlternatePath | Returns the alternate working directory for the specified folder. This may return null.
GetFolderAlternatePathEnabled | Return true if the alternate working directory is enabled for this folder.
GetFolderUserVisible | Return true if the specified folder is user visible. A UI should not display items in an invisible folder.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.StarTeamClientOptions.
GetOption | Returns the specified workstation option. If the option is not set then the specified default value is returned.
GetProcessItem | Gets the current process item in the given target view.
GetProcessItemClassID | Returns the class ID of the process item for the specified view. Will return -1 if no process item is specified for the view.
GetProcessItemID | Returns the item ID of the process item for the specified view. Will return -1 if no process item is specified for the view.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewAlternatePath | Returns the alternate working directory for the specified view. This may return null.
GetViewAlternatePathEnabled | Return true if the alternate working directory is enabled for this view.
GetViewStatusMethodOverride | Returns the option value stored for the specified View's status method.
Load | Load the options from the specified file. This file becomes the new underlying file for this StarTeamClientOptions object.
LoadDefault | Loads the options from the default file.
Reload | Re-loads the underlying options file.
ReloadIfNeeded | Re-loads the ini only if the file's last modified time stamp has changed.
Save | Writes the options to the underlying file.
SaveTo | Saves the options to the new file. This becomes the new underlying file for this StarTeamClientOptions object.
SetComponentOption | Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.
SetFolderAlternatePath | Change the option value stored for the specified Folder's alternate working directory. This does not modify the folder object.
SetFolderAlternatePathEnabled | Change whether or not the alternate working directory should be used for the specified folder.
SetFolderUserVisible | Change whether or not the specified folder should be visible. Typically, a UI should not display items in an invisible folder.
SetOption | Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.
SetProcessItem | Overloaded. Sets the process item for the specified item's view.
SetViewAlternatePath | Change the option value stored for the specified View's alternate working directory. This does not modify the view object.
SetViewAlternatePathEnabled | Change whether or not the alternate working directory should be used for the specified view.
SetViewStatusMethodOverride | Change the option value stored for the specified View's status method This does not modify the view object.
ToString | Delegate ToString() to com.starbase.starteam.StarTeamClientOptions.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions Constructor

Construct StarTeamClientOptions from com.starbase.starteam.StarTeamClientOptions.

Overload List

Creates a new StarTeamClientOptions instance which can be used to get/set client side options used by StarTeam clients.

public StarTeamClientOptions();

Construct StarTeamClientOptions from com.starbase.starteam.StarTeamClientOptions.

public StarTeamClientOptions(StarTeamClientOptions);

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions Constructor (StarTeamClientOptions)

Construct StarTeamClientOptions from com.starbase.starteam.StarTeamClientOptions.

public StarTeamClientOptions(
StarTeamClientOptions impl
);

Parameters

impl
The com.starbase.starteam.StarTeamClientOptions to be wrapped.

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | StarTeamClientOptions Constructor Overload List


StarTeamClientOptions Constructor ()

Creates a new StarTeamClientOptions instance which can be used to get/set client side options used by StarTeam clients.

public StarTeamClientOptions();

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | StarTeamClientOptions Constructor Overload List


StarTeamClientOptions Properties

The properties of the StarTeamClientOptions class are listed below. For a complete list of StarTeamClientOptions class members, see the StarTeamClientOptions Members topic.

Public Static Properties

CHANGE_CHECK_NEW_ITEM_ACTIVATED |
CHANGE_CHECK_NEW_ITEM_INTERVAL |
CHANGE_READ_ON_SELECT_CHANGE_ACTIVATED |
CHANGE_SELECTED_ITEM_TIMER_ACTIVATED |
CHANGE_SELECTED_ITEM_TIMER_INTERVAL |
Default | [read]
DefaultFile | [read]
FILE_CENTRAL_STATUS_DIRECTORY |
FILE_CLEAR_LOCKS_ON_CHECK_IN |
FILE_COMPARE_OPTIONS |
FILE_COMPARE_PATH |
FILE_DEFAULT_ENCODING |
FILE_DEFAULT_EOL |
FILE_DEFAULT_STATUS_METHOD |
FILE_EDITOR_OPTIONS |
FILE_EDITOR_PATH |
FILE_LOCALDIRECTORYWATCH |
FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT |
FILE_MARK_UNLOCKED_FILES_READ_ONLY |
FILE_MERGE_OPTIONS |
FILE_MERGE_PATH |
FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS |
FILE_PERFORM_EOL_CONVERSION |
FILE_POPUP_VISMERGE_ALWAYS |
FILE_USE_ALTERNATE_COMPARE |
FILE_USE_ALTERNATE_EDITOR |
FILE_USE_ALTERNATE_MERGE |
FILE_USE_MD5_TO_CALCULATE_STATUS |
FILE_USE_MODIFIED_TIME_STAMP |
FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS |
TASK_CHECK_NEW_ITEM_ACTIVATED |
TASK_CHECK_NEW_ITEM_INTERVAL |
TASK_READ_ON_SELECT_CHANGE_ACTIVATED |
TASK_SELECTED_ITEM_TIMER_ACTIVATED |
TASK_SELECTED_ITEM_TIMER_INTERVAL |
TOPIC_CHECK_NEW_ITEM_ACTIVATED |
TOPIC_CHECK_NEW_ITEM_INTERVAL |
TOPIC_READ_ON_SELECT_CHANGE_ACTIVATED |
TOPIC_SELECTED_ITEM_TIMER_ACTIVATED |
TOPIC_SELECTED_ITEM_TIMER_INTERVAL |
WORKSPACE_AUTO_REFRESH |
WORKSPACE_CHANGE_SCOPE_FOLDER |
WORKSPACE_CONFIRM_DELETE |
WORKSPACE_CONFIRM_MOVE |
WORKSPACE_FALCON |
WORKSPACE_FOLDER_CONTEXT |
WORKSPACE_HISTORY_UTC |
WORKSPACE_INSTANT_REFRESH |
WORKSPACE_INSTANT_REFRESH_MAX_TIME |
WORKSPACE_INSTANT_REFRESH_MIN_TIME |
WORKSPACE_LOG_COMMAND_DETAILS |
WORKSPACE_LOG_COMMANDS |
WORKSPACE_LOG_ERRORS |
WORKSPACE_LOG_EVENTS |
WORKSPACE_LOG_OUTPUT_PATH |
WORKSPACE_LOG_THRESHOLD |
WORKSPACE_LOG_UI_OPERATIONS |
WORKSPACE_MAINTAIN_GROUP_STATE |
WORKSPACE_REFRESH_TIME |
WORKSPACE_REPORT_OUTPUT_PATH |
WORKSPACE_RESTORE_SHORTCUTS |
WORKSPACE_SHOW_STATUSBAR |
WORKSPACE_SHOW_TOOLBARS |
WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS |
WORKSPACE_WARNINGS |

Public Instance Properties

CentralStatusDirectory | [read/write]
ChangeCheckNewItemActivated | [read/write] option value. Default if not defined: true
ChangeCheckNewItemInterval | [read/write] option value. Default if not defined: 600
ChangeReadOnSelectChangeActivated | [read/write] option value. Default if not defined: false
ChangeSelectedItemTimerActivated | [read/write] option value. Default if not defined: false
ChangeSelectedItemTimerInterval | [read/write] option value. Default if not defined: 45
DefaultStatusMethod | [read/write] the default status method to be used by the client. If not set in these options then this method CENTRAL.
FileClearLocksOnCheckIn | [read/write] option value. Default if not defined: false
FileCompareOptions | [read/write] option value. Default if not defined: ""
FileComparePath | [read/write] option value. Default if not defined: ""
FileDefaultEncoding | [read/write] option value. Default if not defined: the value of the system property "file.encoding"
FileDefaultEOL | [read/write] option value. Default if not defined: "CRLF"
FileEditorOptions | [read/write] option value. Default if not defined: ""
FileEditorPath | [read/write] option value. Default if not defined: ""
FileLocalDirectoryWatch | [read/write] option value. Default if not defined: true
FileLockFilesExclusivelyOnCheckOut | [read/write] option value. Default if not defined: false
FileMarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
FileMergeOptions | [read/write] option value. Default if not defined: ""
FileMergePath | [read/write] option value. Default if not defined: ""
FileOptimizeForSlowConnections | [read/write] option value. Default if not defined: false
FilePerformEOLConversion | [read/write] option value. Default if not defined: true
FilePopupVisMergeAlways | [read/write] option value. Default if not defined: true
FileUseAlternateCompare | [read/write] option value. Default if not defined: false
FileUseAlternateEditor | [read/write] option value. Default if not defined: false
FileUseAlternateMerge | [read/write] option value. Default if not defined: false
FileUseMD5ToCalculateStatus | [read/write] option value. Default if not defined: false
FileUseModifiedTimeStamp | [read/write] option value. Default if not defined: false
FileUseNonExclusiveLocksInIntegrations | [read/write] option value. Default if not defined: true
MPXEnabled | [read/write] option value. Default if not defined: true
TaskCheckNewItemActivated | [read/write] option value. Default if not defined: true
TaskCheckNewItemInterval | [read/write] option value. Default if not defined: 600
TaskReadOnSelectChangeActivated | [read/write] option value. Default if not defined: false
TaskSelectedItemTimerActivated | [read/write] option value. Default if not defined: false
TaskSelectedItemTimerInterval | [read/write] option value. Default if not defined: 45
TopicCheckNewItemActivated | [read/write] option value. Default if not defined: true
TopicCheckNewItemInterval | [read/write] option value. Default if not defined: 600
TopicReadOnSelectChangeActivated | [read/write] option value. Default if not defined: false
TopicSelectedItemTimerActivated | [read/write] option value. Default if not defined: false
TopicSelectedItemTimerInterval | [read/write] option value. Default if not defined: 45
WorkspaceAutoRefresh | [read/write] option value. Default if not defined: false
WorkspaceChangeScopeFolder | [read/write] option value. Default if not defined: false
WorkspaceConfirmDelete | [read/write] option value. Default if not defined: true
WorkspaceConfirmMove | [read/write] option value. Default if not defined: true
WorkspaceFalcon | [read/write] option value. Default if not defined: true
WorkspaceFolderContext | [read/write] option value. Default if not defined: true
WorkspaceHistoryUTC | [read/write] option value. Default if not defined: false
WorkspaceInstantRefresh | [read/write] option value. Default if not defined: true
WorkspaceInstantRefreshMaxTime | [read/write] option value. Default if not defined: 30
WorkspaceInstantRefreshMinTime | [read/write] option value. Default if not defined: 5
WorkspaceLogCommandDetails | [read/write] option value. Default if not defined: false
WorkspaceLogCommands | [read/write] option value. Default if not defined: false
WorkspaceLogErrors | [read/write] option value. Default if not defined: true
WorkspaceLogEvents | [read/write] option value. Default if not defined: false
WorkspaceLogOutputPath | [read/write] option value. Default if not defined: ""
WorkspaceLogThreshold | [read/write] option value. Default if not defined: 10
WorkspaceLogUIOperations | [read/write] option value. Default if not defined: false
WorkspaceMaintainGroupState | [read/write] option value. Default if not defined: true
WorkspaceRefreshTime | [read/write] option value. Default if not defined: false
WorkspaceReportOutputPath | [read/write] option value. Default if not defined: ""
WorkspaceRestoreShortcuts | [read/write] option value. Default if not defined: true
WorkspaceShowStatusBar | [read/write] option value. Default if not defined: true
WorkspaceShowToolbars | [read/write] option value. Default if not defined: true
WorkspaceShowVirtualMeetingOptions | [read/write] option value. Default if not defined: false
WorkspaceWarnings | [read/write] option value. Default if not defined: true

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


CentralStatusDirectory Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.CentralStatusDirectory Property

[read/write]

public virtual String CentralStatusDirectory {get; set;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


CHANGE_CHECK_NEW_ITEM_ACTIVATED Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.CHANGE_CHECK_NEW_ITEM_ACTIVATED Property

public static String CHANGE_CHECK_NEW_ITEM_ACTIVATED {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


CHANGE_CHECK_NEW_ITEM_INTERVAL Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.CHANGE_CHECK_NEW_ITEM_INTERVAL Property

public static String CHANGE_CHECK_NEW_ITEM_INTERVAL {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


CHANGE_READ_ON_SELECT_CHANGE_ACTIVATED Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.CHANGE_READ_ON_SELECT_CHANGE_ACTIVATED Property

public static String CHANGE_READ_ON_SELECT_CHANGE_ACTIVATED {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


CHANGE_SELECTED_ITEM_TIMER_ACTIVATED Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.CHANGE_SELECTED_ITEM_TIMER_ACTIVATED Property

public static String CHANGE_SELECTED_ITEM_TIMER_ACTIVATED {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


CHANGE_SELECTED_ITEM_TIMER_INTERVAL Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.CHANGE_SELECTED_ITEM_TIMER_INTERVAL Property

public static String CHANGE_SELECTED_ITEM_TIMER_INTERVAL {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


ChangeCheckNewItemActivated Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.ChangeCheckNewItemActivated Property

[read/write] option value. Default if not defined: true

public virtual Boolean ChangeCheckNewItemActivated {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


ChangeCheckNewItemInterval Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.ChangeCheckNewItemInterval Property

[read/write] option value. Default if not defined: 600

public virtual Int32 ChangeCheckNewItemInterval {get; set;}

Property Value

option value. Default if not defined: 600

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


ChangeReadOnSelectChangeActivated Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.ChangeReadOnSelectChangeActivated Property

[read/write] option value. Default if not defined: false

public virtual Boolean ChangeReadOnSelectChangeActivated {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


ChangeSelectedItemTimerActivated Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.ChangeSelectedItemTimerActivated Property

[read/write] option value. Default if not defined: false

public virtual Boolean ChangeSelectedItemTimerActivated {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


ChangeSelectedItemTimerInterval Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.ChangeSelectedItemTimerInterval Property

[read/write] option value. Default if not defined: 45

public virtual Int32 ChangeSelectedItemTimerInterval {get; set;}

Property Value

option value. Default if not defined: 45

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


Default Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.Default Property

[read]

public static StarTeamClientOptions Default {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


DefaultFile Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.DefaultFile Property

[read]

public static FileInfo DefaultFile {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


DefaultStatusMethod Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.DefaultStatusMethod Property

[read/write] the default status method to be used by the client. If not set in these options then this method CENTRAL.

public virtual StatusMethod DefaultStatusMethod {get; set;}

Property Value

the default status method to be used by the client. If not set in these options then this method CENTRAL.

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_CENTRAL_STATUS_DIRECTORY Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_CENTRAL_STATUS_DIRECTORY Property

public static String FILE_CENTRAL_STATUS_DIRECTORY {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_CLEAR_LOCKS_ON_CHECK_IN Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_CLEAR_LOCKS_ON_CHECK_IN Property

public static String FILE_CLEAR_LOCKS_ON_CHECK_IN {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_COMPARE_OPTIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_COMPARE_OPTIONS Property

public static String FILE_COMPARE_OPTIONS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_COMPARE_PATH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_COMPARE_PATH Property

public static String FILE_COMPARE_PATH {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_DEFAULT_ENCODING Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_DEFAULT_ENCODING Property

public static String FILE_DEFAULT_ENCODING {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_DEFAULT_EOL Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_DEFAULT_EOL Property

public static String FILE_DEFAULT_EOL {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_DEFAULT_STATUS_METHOD Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_DEFAULT_STATUS_METHOD Property

public static String FILE_DEFAULT_STATUS_METHOD {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_EDITOR_OPTIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_EDITOR_OPTIONS Property

public static String FILE_EDITOR_OPTIONS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_EDITOR_PATH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_EDITOR_PATH Property

public static String FILE_EDITOR_PATH {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_LOCALDIRECTORYWATCH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_LOCALDIRECTORYWATCH Property

public static String FILE_LOCALDIRECTORYWATCH {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT Property

public static String FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_MARK_UNLOCKED_FILES_READ_ONLY Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_MARK_UNLOCKED_FILES_READ_ONLY Property

public static String FILE_MARK_UNLOCKED_FILES_READ_ONLY {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_MERGE_OPTIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_MERGE_OPTIONS Property

public static String FILE_MERGE_OPTIONS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_MERGE_PATH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_MERGE_PATH Property

public static String FILE_MERGE_PATH {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS Property

public static String FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_PERFORM_EOL_CONVERSION Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_PERFORM_EOL_CONVERSION Property

public static String FILE_PERFORM_EOL_CONVERSION {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_POPUP_VISMERGE_ALWAYS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_POPUP_VISMERGE_ALWAYS Property

public static String FILE_POPUP_VISMERGE_ALWAYS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_USE_ALTERNATE_COMPARE Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_ALTERNATE_COMPARE Property

public static String FILE_USE_ALTERNATE_COMPARE {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_USE_ALTERNATE_EDITOR Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_ALTERNATE_EDITOR Property

public static String FILE_USE_ALTERNATE_EDITOR {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_USE_ALTERNATE_MERGE Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_ALTERNATE_MERGE Property

public static String FILE_USE_ALTERNATE_MERGE {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_USE_MD5_TO_CALCULATE_STATUS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_MD5_TO_CALCULATE_STATUS Property

public static String FILE_USE_MD5_TO_CALCULATE_STATUS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_USE_MODIFIED_TIME_STAMP Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_MODIFIED_TIME_STAMP Property

public static String FILE_USE_MODIFIED_TIME_STAMP {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS Property

public static String FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileClearLocksOnCheckIn Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileClearLocksOnCheckIn Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileClearLocksOnCheckIn {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileCompareOptions Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileCompareOptions Property

[read/write] option value. Default if not defined: ""

public virtual String FileCompareOptions {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileComparePath Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileComparePath Property

[read/write] option value. Default if not defined: ""

public virtual String FileComparePath {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileDefaultEncoding Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileDefaultEncoding Property

[read/write] option value. Default if not defined: the value of the system property "file.encoding"

public virtual String FileDefaultEncoding {get; set;}

Property Value

option value. Default if not defined: the value of the system property "file.encoding"

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileDefaultEOL Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileDefaultEOL Property

[read/write] option value. Default if not defined: "CRLF"

public virtual String FileDefaultEOL {get; set;}

Property Value

option value. Default if not defined: "CRLF"

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileEditorOptions Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileEditorOptions Property

[read/write] option value. Default if not defined: ""

public virtual String FileEditorOptions {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileEditorPath Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileEditorPath Property

[read/write] option value. Default if not defined: ""

public virtual String FileEditorPath {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileLocalDirectoryWatch Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileLocalDirectoryWatch Property

[read/write] option value. Default if not defined: true

public virtual Boolean FileLocalDirectoryWatch {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileLockFilesExclusivelyOnCheckOut Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileLockFilesExclusivelyOnCheckOut Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileLockFilesExclusivelyOnCheckOut {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileMarkUnlockedFilesReadOnly Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileMarkUnlockedFilesReadOnly Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileMarkUnlockedFilesReadOnly {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileMergeOptions Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileMergeOptions Property

[read/write] option value. Default if not defined: ""

public virtual String FileMergeOptions {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileMergePath Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileMergePath Property

[read/write] option value. Default if not defined: ""

public virtual String FileMergePath {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileOptimizeForSlowConnections Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileOptimizeForSlowConnections Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileOptimizeForSlowConnections {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FilePerformEOLConversion Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FilePerformEOLConversion Property

[read/write] option value. Default if not defined: true

public virtual Boolean FilePerformEOLConversion {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FilePopupVisMergeAlways Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FilePopupVisMergeAlways Property

[read/write] option value. Default if not defined: true

public virtual Boolean FilePopupVisMergeAlways {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileUseAlternateCompare Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseAlternateCompare Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileUseAlternateCompare {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileUseAlternateEditor Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseAlternateEditor Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileUseAlternateEditor {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileUseAlternateMerge Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseAlternateMerge Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileUseAlternateMerge {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileUseMD5ToCalculateStatus Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseMD5ToCalculateStatus Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileUseMD5ToCalculateStatus {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileUseModifiedTimeStamp Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseModifiedTimeStamp Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileUseModifiedTimeStamp {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


FileUseNonExclusiveLocksInIntegrations Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseNonExclusiveLocksInIntegrations Property

[read/write] option value. Default if not defined: true

public virtual Boolean FileUseNonExclusiveLocksInIntegrations {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


MPXEnabled Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.MPXEnabled Property

[read/write] option value. Default if not defined: true

public virtual Boolean MPXEnabled {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TASK_CHECK_NEW_ITEM_ACTIVATED Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TASK_CHECK_NEW_ITEM_ACTIVATED Property

public static String TASK_CHECK_NEW_ITEM_ACTIVATED {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TASK_CHECK_NEW_ITEM_INTERVAL Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TASK_CHECK_NEW_ITEM_INTERVAL Property

public static String TASK_CHECK_NEW_ITEM_INTERVAL {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TASK_READ_ON_SELECT_CHANGE_ACTIVATED Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TASK_READ_ON_SELECT_CHANGE_ACTIVATED Property

public static String TASK_READ_ON_SELECT_CHANGE_ACTIVATED {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TASK_SELECTED_ITEM_TIMER_ACTIVATED Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TASK_SELECTED_ITEM_TIMER_ACTIVATED Property

public static String TASK_SELECTED_ITEM_TIMER_ACTIVATED {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TASK_SELECTED_ITEM_TIMER_INTERVAL Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TASK_SELECTED_ITEM_TIMER_INTERVAL Property

public static String TASK_SELECTED_ITEM_TIMER_INTERVAL {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TaskCheckNewItemActivated Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TaskCheckNewItemActivated Property

[read/write] option value. Default if not defined: true

public virtual Boolean TaskCheckNewItemActivated {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TaskCheckNewItemInterval Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TaskCheckNewItemInterval Property

[read/write] option value. Default if not defined: 600

public virtual Int32 TaskCheckNewItemInterval {get; set;}

Property Value

option value. Default if not defined: 600

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TaskReadOnSelectChangeActivated Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TaskReadOnSelectChangeActivated Property

[read/write] option value. Default if not defined: false

public virtual Boolean TaskReadOnSelectChangeActivated {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TaskSelectedItemTimerActivated Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TaskSelectedItemTimerActivated Property

[read/write] option value. Default if not defined: false

public virtual Boolean TaskSelectedItemTimerActivated {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TaskSelectedItemTimerInterval Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TaskSelectedItemTimerInterval Property

[read/write] option value. Default if not defined: 45

public virtual Int32 TaskSelectedItemTimerInterval {get; set;}

Property Value

option value. Default if not defined: 45

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TOPIC_CHECK_NEW_ITEM_ACTIVATED Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TOPIC_CHECK_NEW_ITEM_ACTIVATED Property

public static String TOPIC_CHECK_NEW_ITEM_ACTIVATED {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TOPIC_CHECK_NEW_ITEM_INTERVAL Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TOPIC_CHECK_NEW_ITEM_INTERVAL Property

public static String TOPIC_CHECK_NEW_ITEM_INTERVAL {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TOPIC_READ_ON_SELECT_CHANGE_ACTIVATED Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TOPIC_READ_ON_SELECT_CHANGE_ACTIVATED Property

public static String TOPIC_READ_ON_SELECT_CHANGE_ACTIVATED {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TOPIC_SELECTED_ITEM_TIMER_ACTIVATED Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TOPIC_SELECTED_ITEM_TIMER_ACTIVATED Property

public static String TOPIC_SELECTED_ITEM_TIMER_ACTIVATED {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TOPIC_SELECTED_ITEM_TIMER_INTERVAL Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TOPIC_SELECTED_ITEM_TIMER_INTERVAL Property

public static String TOPIC_SELECTED_ITEM_TIMER_INTERVAL {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TopicCheckNewItemActivated Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TopicCheckNewItemActivated Property

[read/write] option value. Default if not defined: true

public virtual Boolean TopicCheckNewItemActivated {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TopicCheckNewItemInterval Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TopicCheckNewItemInterval Property

[read/write] option value. Default if not defined: 600

public virtual Int32 TopicCheckNewItemInterval {get; set;}

Property Value

option value. Default if not defined: 600

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TopicReadOnSelectChangeActivated Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TopicReadOnSelectChangeActivated Property

[read/write] option value. Default if not defined: false

public virtual Boolean TopicReadOnSelectChangeActivated {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TopicSelectedItemTimerActivated Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TopicSelectedItemTimerActivated Property

[read/write] option value. Default if not defined: false

public virtual Boolean TopicSelectedItemTimerActivated {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


TopicSelectedItemTimerInterval Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.TopicSelectedItemTimerInterval Property

[read/write] option value. Default if not defined: 45

public virtual Int32 TopicSelectedItemTimerInterval {get; set;}

Property Value

option value. Default if not defined: 45

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_AUTO_REFRESH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_AUTO_REFRESH Property

public static String WORKSPACE_AUTO_REFRESH {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_CHANGE_SCOPE_FOLDER Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_CHANGE_SCOPE_FOLDER Property

public static String WORKSPACE_CHANGE_SCOPE_FOLDER {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_CONFIRM_DELETE Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_CONFIRM_DELETE Property

public static String WORKSPACE_CONFIRM_DELETE {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_CONFIRM_MOVE Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_CONFIRM_MOVE Property

public static String WORKSPACE_CONFIRM_MOVE {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_FALCON Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_FALCON Property

public static String WORKSPACE_FALCON {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_FOLDER_CONTEXT Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_FOLDER_CONTEXT Property

public static String WORKSPACE_FOLDER_CONTEXT {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_HISTORY_UTC Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_HISTORY_UTC Property

public static String WORKSPACE_HISTORY_UTC {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_INSTANT_REFRESH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_INSTANT_REFRESH Property

public static String WORKSPACE_INSTANT_REFRESH {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_INSTANT_REFRESH_MAX_TIME Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_INSTANT_REFRESH_MAX_TIME Property

public static String WORKSPACE_INSTANT_REFRESH_MAX_TIME {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_INSTANT_REFRESH_MIN_TIME Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_INSTANT_REFRESH_MIN_TIME Property

public static String WORKSPACE_INSTANT_REFRESH_MIN_TIME {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_LOG_COMMAND_DETAILS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_COMMAND_DETAILS Property

public static String WORKSPACE_LOG_COMMAND_DETAILS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_LOG_COMMANDS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_COMMANDS Property

public static String WORKSPACE_LOG_COMMANDS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_LOG_ERRORS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_ERRORS Property

public static String WORKSPACE_LOG_ERRORS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_LOG_EVENTS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_EVENTS Property

public static String WORKSPACE_LOG_EVENTS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_LOG_OUTPUT_PATH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_OUTPUT_PATH Property

public static String WORKSPACE_LOG_OUTPUT_PATH {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_LOG_THRESHOLD Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_THRESHOLD Property

public static String WORKSPACE_LOG_THRESHOLD {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_LOG_UI_OPERATIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_UI_OPERATIONS Property

public static String WORKSPACE_LOG_UI_OPERATIONS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_MAINTAIN_GROUP_STATE Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_MAINTAIN_GROUP_STATE Property

public static String WORKSPACE_MAINTAIN_GROUP_STATE {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_REFRESH_TIME Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_REFRESH_TIME Property

public static String WORKSPACE_REFRESH_TIME {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_REPORT_OUTPUT_PATH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_REPORT_OUTPUT_PATH Property

public static String WORKSPACE_REPORT_OUTPUT_PATH {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_RESTORE_SHORTCUTS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_RESTORE_SHORTCUTS Property

public static String WORKSPACE_RESTORE_SHORTCUTS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_SHOW_STATUSBAR Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_SHOW_STATUSBAR Property

public static String WORKSPACE_SHOW_STATUSBAR {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_SHOW_TOOLBARS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_SHOW_TOOLBARS Property

public static String WORKSPACE_SHOW_TOOLBARS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS Property

public static String WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WORKSPACE_WARNINGS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_WARNINGS Property

public static String WORKSPACE_WARNINGS {get;}

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceAutoRefresh Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceAutoRefresh Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceAutoRefresh {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceChangeScopeFolder Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceChangeScopeFolder Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceChangeScopeFolder {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceConfirmDelete Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceConfirmDelete Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceConfirmDelete {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceConfirmMove Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceConfirmMove Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceConfirmMove {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceFalcon Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceFalcon Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceFalcon {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceFolderContext Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceFolderContext Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceFolderContext {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceHistoryUTC Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceHistoryUTC Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceHistoryUTC {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceInstantRefresh Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceInstantRefresh Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceInstantRefresh {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceInstantRefreshMaxTime Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceInstantRefreshMaxTime Property

[read/write] option value. Default if not defined: 30

public virtual Int32 WorkspaceInstantRefreshMaxTime {get; set;}

Property Value

option value. Default if not defined: 30

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceInstantRefreshMinTime Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceInstantRefreshMinTime Property

[read/write] option value. Default if not defined: 5

public virtual Int32 WorkspaceInstantRefreshMinTime {get; set;}

Property Value

option value. Default if not defined: 5

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceLogCommandDetails Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogCommandDetails Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceLogCommandDetails {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceLogCommands Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogCommands Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceLogCommands {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceLogErrors Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogErrors Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceLogErrors {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceLogEvents Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogEvents Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceLogEvents {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceLogOutputPath Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogOutputPath Property

[read/write] option value. Default if not defined: ""

public virtual String WorkspaceLogOutputPath {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceLogThreshold Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogThreshold Property

[read/write] option value. Default if not defined: 10

public virtual Int32 WorkspaceLogThreshold {get; set;}

Property Value

option value. Default if not defined: 10

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceLogUIOperations Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogUIOperations Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceLogUIOperations {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceMaintainGroupState Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceMaintainGroupState Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceMaintainGroupState {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceRefreshTime Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceRefreshTime Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceRefreshTime {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceReportOutputPath Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceReportOutputPath Property

[read/write] option value. Default if not defined: ""

public virtual String WorkspaceReportOutputPath {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceRestoreShortcuts Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceRestoreShortcuts Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceRestoreShortcuts {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceShowStatusBar Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceShowStatusBar Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceShowStatusBar {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceShowToolbars Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceShowToolbars Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceShowToolbars {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceShowVirtualMeetingOptions Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceShowVirtualMeetingOptions Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceShowVirtualMeetingOptions {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


WorkspaceWarnings Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceWarnings Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceWarnings {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions Methods

The methods of the StarTeamClientOptions class are listed below. For a complete list of StarTeamClientOptions class members, see the StarTeamClientOptions Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.StarTeamClientOptions.

Public Instance Methods

ClearProcessItem | Clears the process item for the specified view.
Equals | Delegate Equals() to com.starbase.starteam.StarTeamClientOptions.
GetAllProcessItems | Gets the list of items that have been set as the current process item for at least one view on the given server.
GetComponentOption | Returns the specified workstation option. If the option is not set then the specified default value is returned.
GetFolderAlternatePath | Returns the alternate working directory for the specified folder. This may return null.
GetFolderAlternatePathEnabled | Return true if the alternate working directory is enabled for this folder.
GetFolderUserVisible | Return true if the specified folder is user visible. A UI should not display items in an invisible folder.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.StarTeamClientOptions.
GetOption | Returns the specified workstation option. If the option is not set then the specified default value is returned.
GetProcessItem | Gets the current process item in the given target view.
GetProcessItemClassID | Returns the class ID of the process item for the specified view. Will return -1 if no process item is specified for the view.
GetProcessItemID | Returns the item ID of the process item for the specified view. Will return -1 if no process item is specified for the view.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewAlternatePath | Returns the alternate working directory for the specified view. This may return null.
GetViewAlternatePathEnabled | Return true if the alternate working directory is enabled for this view.
GetViewStatusMethodOverride | Returns the option value stored for the specified View's status method.
Load | Load the options from the specified file. This file becomes the new underlying file for this StarTeamClientOptions object.
LoadDefault | Loads the options from the default file.
Reload | Re-loads the underlying options file.
ReloadIfNeeded | Re-loads the ini only if the file's last modified time stamp has changed.
Save | Writes the options to the underlying file.
SaveTo | Saves the options to the new file. This becomes the new underlying file for this StarTeamClientOptions object.
SetComponentOption | Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.
SetFolderAlternatePath | Change the option value stored for the specified Folder's alternate working directory. This does not modify the folder object.
SetFolderAlternatePathEnabled | Change whether or not the alternate working directory should be used for the specified folder.
SetFolderUserVisible | Change whether or not the specified folder should be visible. Typically, a UI should not display items in an invisible folder.
SetOption | Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.
SetProcessItem | Overloaded. Sets the process item for the specified item's view.
SetViewAlternatePath | Change the option value stored for the specified View's alternate working directory. This does not modify the view object.
SetViewAlternatePathEnabled | Change whether or not the alternate working directory should be used for the specified view.
SetViewStatusMethodOverride | Change the option value stored for the specified View's status method This does not modify the view object.
ToString | Delegate ToString() to com.starbase.starteam.StarTeamClientOptions.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.StarTeamClientOptions

Implements

IWrapper.Unwrap

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.ClearProcessItem Method

Clears the process item for the specified view.

public virtual void ClearProcessItem(
View view
);

Parameters

view
the view whose process item is to be cleared.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | setProcessItem


StarTeamClientOptions.Equals Method

Delegate Equals() to com.starbase.starteam.StarTeamClientOptions.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.StarTeamClientOptions.Equals(obj).

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.GetAllProcessItems Method

Gets the list of items that have been set as the current process item for at least one view on the given server.

public virtual ItemCollection GetAllProcessItems(
Server s
);

Parameters

s
A StarTeam server.

Return Value

Item[] The list of items that have been set as the current process item for at least one view on the given server.

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.GetComponentOption Method

Returns the specified workstation option. If the option is not set then the specified default value is returned.

public virtual string GetComponentOption(
String componentName,
String optionName,
String defaultValue
);

Parameters

componentName
the component name of the option
optionName
the component specific options name
defaultValue
the default value to return if the option is not set

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.GetFolderAlternatePath Method

Returns the alternate working directory for the specified folder. This may return null.

public virtual string GetFolderAlternatePath(
Folder folder
);

Parameters

folder

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.GetFolderAlternatePathEnabled Method

Return true if the alternate working directory is enabled for this folder.

public virtual bool GetFolderAlternatePathEnabled(
Folder folder
);

Parameters

folder

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.GetFolderUserVisible Method

Return true if the specified folder is user visible. A UI should not display items in an invisible folder.

public virtual bool GetFolderUserVisible(
Folder folder
);

Parameters

folder
the folder whose visiblity is to be determined

Return Value

true if this Folder is user visible.

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | getUserVisible | setUserVisible | resolveUserVisible


StarTeamClientOptions.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.StarTeamClientOptions.

public override int GetHashCode();

Return Value

com.starbase.starteam.StarTeamClientOptions.GetHashCode().

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.GetOption Method

Returns the specified workstation option. If the option is not set then the specified default value is returned.

public virtual string GetOption(
String optionName,
String defaultValue
);

Parameters

optionName
the option name
defaultValue
the default value to return if the option is not set

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.GetProcessItem Method

Gets the current process item in the given target view.

public virtual Item GetProcessItem(
View target
);

Parameters

target
The target view.

Return Value

The current process item in the given target view, or null if there is no current process item in that view.

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.GetProcessItemClassID Method

Returns the class ID of the process item for the specified view. Will return -1 if no process item is specified for the view.

public virtual int GetProcessItemClassID(
View view
);

Parameters

view
the view whose process item class ID is to be returned

Return Value

the class ID of the view's process item, or -1 if no process item is defined for the view.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | setProcessItem


StarTeamClientOptions.GetProcessItemID Method

Returns the item ID of the process item for the specified view. Will return -1 if no process item is specified for the view.

public virtual int GetProcessItemID(
View view
);

Parameters

view
the view whose process item ID is to be returned

Return Value

the item ID of the view's process item, or -1 if no process item is defined for the view.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | setProcessItem


StarTeamClientOptions.GetViewAlternatePath Method

Returns the alternate working directory for the specified view. This may return null.

public virtual string GetViewAlternatePath(
View view
);

Parameters

view

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.GetViewAlternatePathEnabled Method

Return true if the alternate working directory is enabled for this view.

public virtual bool GetViewAlternatePathEnabled(
View view
);

Parameters

view

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.GetViewStatusMethodOverride Method

Returns the option value stored for the specified View's status method.

public virtual StatusMethod GetViewStatusMethodOverride(
View view
);

Parameters

view
the view whose status method is to be returned

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | getStatusMethodOverride | setStatusMethodOverride


StarTeamClientOptions.Load Method

Load the options from the specified file. This file becomes the new underlying file for this StarTeamClientOptions object.

public virtual void Load(
FileInfo file
);

Parameters

file

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.LoadDefault Method

Loads the options from the default file.

public virtual void LoadDefault();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.Reload Method

Re-loads the underlying options file.

public virtual void Reload();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.ReloadIfNeeded Method

Re-loads the ini only if the file's last modified time stamp has changed.

public virtual void ReloadIfNeeded();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.Save Method

Writes the options to the underlying file.

public virtual void Save();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.SaveTo Method

Saves the options to the new file. This becomes the new underlying file for this StarTeamClientOptions object.

public virtual void SaveTo(
FileInfo file
);

Parameters

file

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.SetComponentOption Method

Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.

public virtual void SetComponentOption(
String componentName,
String optionName,
String value
);

Parameters

componentName
the component name of the option
optionName
the component specific options name
value
the new option value

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.SetFolderAlternatePath Method

Change the option value stored for the specified Folder's alternate working directory. This does not modify the folder object.

public virtual void SetFolderAlternatePath(
Folder folder,
String path
);

Parameters

folder
the folder whose working directory is to be overriden
path
the new alternate working directory for the folder

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.SetFolderAlternatePathEnabled Method

Change whether or not the alternate working directory should be used for the specified folder.

public virtual void SetFolderAlternatePathEnabled(
Folder folder,
Boolean enabled
);

Parameters

folder
enabled
true if the alternate path is to be applied

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.SetFolderUserVisible Method

Change whether or not the specified folder should be visible. Typically, a UI should not display items in an invisible folder.

public virtual void SetFolderUserVisible(
Folder folder,
Boolean visible
);

Parameters

folder
the folder whose working directory is to be overriden
visible
true if the folder should be visible, false otherwise

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | getUserVisible | setUserVisible | resolveUserVisible


StarTeamClientOptions.SetOption Method

Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.

public virtual void SetOption(
String optionName,
String value
);

Parameters

optionName
the option name
value
the new option value

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


SetProcessItem Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.SetProcessItem Method

Sets the process item for the specified item's view.

Overload List

Sets the process item for the specified item's view.

public virtual void SetProcessItem(Item);

Sets the current process item for the given target view.

public virtual void SetProcessItem(Item,View);

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | setProcessItem


StarTeamClientOptions.SetProcessItem Method (Item)

Sets the process item for the specified item's view.

public virtual void SetProcessItem(
Item item
);

Parameters

item
the item which is to be the process item. May not be null.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | StarTeamClientOptions.SetProcessItem Overload List | setProcessItem


StarTeamClientOptions.SetProcessItem Method (Item, View)

Sets the current process item for the given target view.

public virtual void SetProcessItem(
Item item,
View target
);

Parameters

item
A process item, or null to clear the process item in the given target view.
target
The target view.

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | StarTeamClientOptions.SetProcessItem Overload List


StarTeamClientOptions.SetViewAlternatePath Method

Change the option value stored for the specified View's alternate working directory. This does not modify the view object.

public virtual void SetViewAlternatePath(
View view,
String path
);

Parameters

view
the view whose working directory is to be overriden
path
the new alternate working directory for the view

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.SetViewAlternatePathEnabled Method

Change whether or not the alternate working directory should be used for the specified view.

public virtual void SetViewAlternatePathEnabled(
View view,
Boolean enabled
);

Parameters

view
the view whose working directory is to be overriden
enabled
true if the alternate path is to be applied

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.SetViewStatusMethodOverride Method

Change the option value stored for the specified View's status method This does not modify the view object.

public virtual void SetViewStatusMethodOverride(
View view,
StatusMethod method
);

Parameters

view
the view whose status method is to be overriden
method
the new status method to use for files in this view

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace | setStatusMethodOverride | getStatusMethodOverride


StarTeamClientOptions.ToString Method

Delegate ToString() to com.starbase.starteam.StarTeamClientOptions.

public override string ToString();

Return Value

com.starbase.starteam.StarTeamClientOptions.ToString()

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions.Wrap Method

Dynamically wraps com.starbase.starteam.StarTeamClientOptions.

public static StarTeamClientOptions Wrap(
StarTeamClientOptions impl
);

Parameters

impl
com.starbase.starteam.StarTeamClientOptions to be wrapped.

Return Value

StarTeamClientOptions

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamClientOptions Type Conversions

The type conversions of the StarTeamClientOptions class are listed below. For a complete list of StarTeamClientOptions class members, see the StarTeamClientOptions Members topic.

Public Static Type Conversions

Implicit StarTeamClientOptions to StarTeamClientOptions Conversion Implicitly convert StarTeamClientOptions to com.starbase.starteam.StarTeamClientOptions.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamClientOptions Class | StarTeamClientOptions Members | Borland.StarTeam Namespace


StarTeamClientOptions Implicit StarTeamClientOptions to StarTeamClientOptions Conversion

Implicitly convert StarTeamClientOptions to com.starbase.starteam.StarTeamClientOptions.

public static implicit operator StarTeamClientOptions(
StarTeamClientOptions arg
);

Parameters

arg
StarTeamClientOptions to convert.

Return Value

com.starbase.starteam.StarTeamClientOptions

See Also

StarTeamClientOptions Class | Borland.StarTeam Namespace


StarTeamFinder Class

A utility class for easily obtaining a connection to a StarTeam server and finding various objects like projects, views, folders and files.

For a list of all members of this type, see StarTeamFinder Members.

System.Object
StarTeamFinder

public class StarTeamFinder : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

StarTeamFinder Members | Borland.StarTeam Namespace


StarTeamFinder Members

StarTeamFinder overview

Public Static Methods

FindFile | Finds the specified file from the specified folder. You can specify whether comparisons should be case sensitive or not.
FindFolder | Given a folder and a path to a subfolder this method will return the subfolder if found. This will return null if the specified folder can not be found. The specified path should be relative to the folder being searched from.
FindSubFolder | Finds a subfolder in the specified folder. Returns null if not found. The name comparisons are case insensitive.
OpenFolder |
OpenFolderWithOverride |
OpenProject |
OpenServer |
OpenView |
OpenViewWithOverride |

Public Static Type Conversions

Implicit StarTeamFinder to StarTeamFinder Conversion Implicitly convert StarTeamFinder to com.starbase.starteam.StarTeamFinder.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.StarTeamFinder.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.StarTeamFinder.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.StarTeamFinder.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder Methods

The methods of the StarTeamFinder class are listed below. For a complete list of StarTeamFinder class members, see the StarTeamFinder Members topic.

Public Static Methods

FindFile | Finds the specified file from the specified folder. You can specify whether comparisons should be case sensitive or not.
FindFolder | Given a folder and a path to a subfolder this method will return the subfolder if found. This will return null if the specified folder can not be found. The specified path should be relative to the folder being searched from.
FindSubFolder | Finds a subfolder in the specified folder. Returns null if not found. The name comparisons are case insensitive.
OpenFolder |
OpenFolderWithOverride |
OpenProject |
OpenServer |
OpenView |
OpenViewWithOverride |

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.StarTeamFinder.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.StarTeamFinder.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.StarTeamFinder.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.StarTeamFinder

Implements

IWrapper.Unwrap

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.Equals Method

Delegate Equals() to com.starbase.starteam.StarTeamFinder.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.StarTeamFinder.Equals(obj).

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.FindFile Method

Finds the specified file from the specified folder. You can specify whether comparisons should be case sensitive or not.

public static File FindFile(
Folder source,
String name,
Boolean matchCase
);

Parameters

source
the folder to be searched
name
the name of the file to be found
matchCase
should be true if comparison is case sensitive

Return Value

the specified file or null if not found

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.FindFolder Method

Given a folder and a path to a subfolder this method will return the subfolder if found. This will return null if the specified folder can not be found. The specified path should be relative to the folder being searched from.

public static Folder FindFolder(
Folder from,
String folderPath
);

Parameters

from
the folder from which to start the search
folderPath
the path to the subfolder. This should not include the from folder's name.

Return Value

the specified sub folder or null if not found.

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.FindSubFolder Method

Finds a subfolder in the specified folder. Returns null if not found. The name comparisons are case insensitive.

public static Folder FindSubFolder(
Folder from,
String subFolderName
);

Parameters

from
the folder being searched
subFolderName
the name of the subfolder to be found

Return Value

the subfolder with the specified name or null if not found.

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.StarTeamFinder.

public override int GetHashCode();

Return Value

com.starbase.starteam.StarTeamFinder.GetHashCode().

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.OpenFolder Method

public static Folder OpenFolder(
String url
);

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.OpenFolderWithOverride Method

public static Folder OpenFolderWithOverride(
String url,
String viewPath
);

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.OpenProject Method

public static Project OpenProject(
String url
);

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.OpenServer Method

public static Server OpenServer(
String url
);

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.OpenView Method

public static View OpenView(
String url
);

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.OpenViewWithOverride Method

public static View OpenViewWithOverride(
String url,
String viewPath
);

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder.ToString Method

Delegate ToString() to com.starbase.starteam.StarTeamFinder.

public override string ToString();

Return Value

com.starbase.starteam.StarTeamFinder.ToString()

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamFinder Type Conversions

The type conversions of the StarTeamFinder class are listed below. For a complete list of StarTeamFinder class members, see the StarTeamFinder Members topic.

Public Static Type Conversions

Implicit StarTeamFinder to StarTeamFinder Conversion Implicitly convert StarTeamFinder to com.starbase.starteam.StarTeamFinder.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamFinder Class | StarTeamFinder Members | Borland.StarTeam Namespace


StarTeamFinder Implicit StarTeamFinder to StarTeamFinder Conversion

Implicitly convert StarTeamFinder to com.starbase.starteam.StarTeamFinder.

public static implicit operator StarTeamFinder(
StarTeamFinder arg
);

Parameters

arg
StarTeamFinder to convert.

Return Value

com.starbase.starteam.StarTeamFinder

See Also

StarTeamFinder Class | Borland.StarTeam Namespace


StarTeamURL Class

StarTeamURL uses a URL-like syntax to reference a StarTeam Server, Project, View or Folder. Used in conjunction with StarTeamFinder, it provides a convenient way to locate important StarTeam objects.

StarTeamURL supports the following syntax:

starteam://username:password@hostname:port/Project/View/FolderA/FolderB/...

The "starteam://" prefix is optional.

Alternatively, the following syntax is also supported:

starteam://username:password@server/Project/View/FolderA/FolderB/...

Thus, if no ":port" is specified, the hostname is interpreted as a server description. The description is looked up in the server list, and, if found, the connection information from the server list (host address, port, encryption and compression settings, and MPX profile name) are used to establish the server connection.

For a list of all members of this type, see StarTeamURL Members.

System.Object
StarTeamURL

public class StarTeamURL : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

StarTeamURL Members | Borland.StarTeam Namespace


StarTeamURL Members

StarTeamURL overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.StarTeamURL.

Public Static Type Conversions

Implicit StarTeamURL to StarTeamURL Conversion Implicitly convert StarTeamURL to com.starbase.starteam.StarTeamURL.

Public Instance Constructors

StarTeamURL Overloaded. Initializes a new instance of the StarTeamURL class.

Public Instance Properties

Folders | [read] a StringTokenizer that can be used to enumerate the folder names found in the path portion of the URL.
HostName | [read] the host name specified in the URL or null of not found.
Password | [read] the password specified in the URL or null of not found.
Path | [read] the path specified in the URL or null of not found.
Port | [read] the port specified in the URL or null of not found.
ProjectName | [read] the project name specified in the URL or null of not found.
Protocol | [read] the protocol specified in the URL or PROTOCOL_TCP_IP_SOCKETS of not found.
Source | [read] the original string provided when this StarTeamURL was created
UserName | [read] the user name specified in the URL or null of not found.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.StarTeamURL.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.StarTeamURL.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.StarTeamURL.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamURL Class | Borland.StarTeam Namespace


StarTeamURL Constructor

Construct StarTeamURL from com.starbase.starteam.StarTeamURL.

Overload List

Construct StarTeamURL from com.starbase.starteam.StarTeamURL.

public StarTeamURL(StarTeamURL);

Construct a new StarTeamURL with the given specifier. The most general form of the URL is: "username:password@hostname:port/projectname/view/folder/folder/" Additionally, you can prefix the string with an optional protocol prefix. Use "starteam://" to indicate the "TCP/IP Sockets" protocol, or "starteam:xml//" to indicate the "XML over TCP/IP" protocol. If no protocol prefix is specified, "TCP/IP Sockets" is assumed.

public StarTeamURL(String);

See Also

StarTeamURL Class | Borland.StarTeam Namespace


StarTeamURL Constructor (StarTeamURL)

Construct StarTeamURL from com.starbase.starteam.StarTeamURL.

public StarTeamURL(
StarTeamURL impl
);

Parameters

impl
The com.starbase.starteam.StarTeamURL to be wrapped.

See Also

StarTeamURL Class | Borland.StarTeam Namespace | StarTeamURL Constructor Overload List


StarTeamURL Constructor (String)

Construct a new StarTeamURL with the given specifier. The most general form of the URL is: "username:password@hostname:port/projectname/view/folder/folder/" Additionally, you can prefix the string with an optional protocol prefix. Use "starteam://" to indicate the "TCP/IP Sockets" protocol, or "starteam:xml//" to indicate the "XML over TCP/IP" protocol. If no protocol prefix is specified, "TCP/IP Sockets" is assumed.

public StarTeamURL(
String url
);

Parameters

url
the string specifier of the StarTeamURL.

See Also

StarTeamURL Class | Borland.StarTeam Namespace | StarTeamURL Constructor Overload List


StarTeamURL Properties

The properties of the StarTeamURL class are listed below. For a complete list of StarTeamURL class members, see the StarTeamURL Members topic.

Public Instance Properties

Folders | [read] a StringTokenizer that can be used to enumerate the folder names found in the path portion of the URL.
HostName | [read] the host name specified in the URL or null of not found.
Password | [read] the password specified in the URL or null of not found.
Path | [read] the path specified in the URL or null of not found.
Port | [read] the port specified in the URL or null of not found.
ProjectName | [read] the project name specified in the URL or null of not found.
Protocol | [read] the protocol specified in the URL or PROTOCOL_TCP_IP_SOCKETS of not found.
Source | [read] the original string provided when this StarTeamURL was created
UserName | [read] the user name specified in the URL or null of not found.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamURL Class | Borland.StarTeam Namespace


Folders Property

Borland StarTeam SDK for .NET

StarTeamURL.Folders Property

[read] a StringTokenizer that can be used to enumerate the folder names found in the path portion of the URL.

public virtual StringEnumerator Folders {get;}

Property Value

a StringTokenizer that can be used to enumerate the folder names found in the path portion of the URL.

See Also

StarTeamURL Class | Borland.StarTeam Namespace


HostName Property

Borland StarTeam SDK for .NET

StarTeamURL.HostName Property

[read] the host name specified in the URL or null of not found.

public virtual String HostName {get;}

Property Value

the host name specified in the URL or null of not found.

See Also

StarTeamURL Class | Borland.StarTeam Namespace


Password Property

Borland StarTeam SDK for .NET

StarTeamURL.Password Property

[read] the password specified in the URL or null of not found.

public virtual String Password {get;}

Property Value

the password specified in the URL or null of not found.

See Also

StarTeamURL Class | Borland.StarTeam Namespace


Path Property

Borland StarTeam SDK for .NET

StarTeamURL.Path Property

[read] the path specified in the URL or null of not found.

public virtual String Path {get;}

Property Value

the path specified in the URL or null of not found.

See Also

StarTeamURL Class | Borland.StarTeam Namespace


Port Property

Borland StarTeam SDK for .NET

StarTeamURL.Port Property

[read] the port specified in the URL or null of not found.

public virtual String Port {get;}

Property Value

the port specified in the URL or null of not found.

See Also

StarTeamURL Class | Borland.StarTeam Namespace


ProjectName Property

Borland StarTeam SDK for .NET

StarTeamURL.ProjectName Property

[read] the project name specified in the URL or null of not found.

public virtual String ProjectName {get;}

Property Value

the project name specified in the URL or null of not found.

See Also

StarTeamURL Class | Borland.StarTeam Namespace


Protocol Property

Borland StarTeam SDK for .NET

StarTeamURL.Protocol Property

[read] the protocol specified in the URL or PROTOCOL_TCP_IP_SOCKETS of not found.

public virtual Int32 Protocol {get;}

Property Value

the protocol specified in the URL or PROTOCOL_TCP_IP_SOCKETS of not found.

See Also

StarTeamURL Class | Borland.StarTeam Namespace


Source Property

Borland StarTeam SDK for .NET

StarTeamURL.Source Property

[read] the original string provided when this StarTeamURL was created

public virtual String Source {get;}

Property Value

the original string provided when this StarTeamURL was created

See Also

StarTeamURL Class | Borland.StarTeam Namespace


UserName Property

Borland StarTeam SDK for .NET

StarTeamURL.UserName Property

[read] the user name specified in the URL or null of not found.

public virtual String UserName {get;}

Property Value

the user name specified in the URL or null of not found.

See Also

StarTeamURL Class | Borland.StarTeam Namespace


StarTeamURL Methods

The methods of the StarTeamURL class are listed below. For a complete list of StarTeamURL class members, see the StarTeamURL Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.StarTeamURL.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.StarTeamURL.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.StarTeamURL.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.StarTeamURL.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamURL Class | Borland.StarTeam Namespace


StarTeamURL.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.StarTeamURL

Implements

IWrapper.Unwrap

See Also

StarTeamURL Class | Borland.StarTeam Namespace


StarTeamURL.Equals Method

Delegate Equals() to com.starbase.starteam.StarTeamURL.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.StarTeamURL.Equals(obj).

See Also

StarTeamURL Class | Borland.StarTeam Namespace


StarTeamURL.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.StarTeamURL.

public override int GetHashCode();

Return Value

com.starbase.starteam.StarTeamURL.GetHashCode().

See Also

StarTeamURL Class | Borland.StarTeam Namespace


StarTeamURL.ToString Method

Delegate ToString() to com.starbase.starteam.StarTeamURL.

public override string ToString();

Return Value

com.starbase.starteam.StarTeamURL.ToString()

See Also

StarTeamURL Class | Borland.StarTeam Namespace


StarTeamURL.Wrap Method

Dynamically wraps com.starbase.starteam.StarTeamURL.

public static StarTeamURL Wrap(
StarTeamURL impl
);

Parameters

impl
com.starbase.starteam.StarTeamURL to be wrapped.

Return Value

StarTeamURL

See Also

StarTeamURL Class | Borland.StarTeam Namespace


StarTeamURL Type Conversions

The type conversions of the StarTeamURL class are listed below. For a complete list of StarTeamURL class members, see the StarTeamURL Members topic.

Public Static Type Conversions

Implicit StarTeamURL to StarTeamURL Conversion Implicitly convert StarTeamURL to com.starbase.starteam.StarTeamURL.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamURL Class | StarTeamURL Members | Borland.StarTeam Namespace


StarTeamURL Implicit StarTeamURL to StarTeamURL Conversion

Implicitly convert StarTeamURL to com.starbase.starteam.StarTeamURL.

public static implicit operator StarTeamURL(
StarTeamURL arg
);

Parameters

arg
StarTeamURL to convert.

Return Value

com.starbase.starteam.StarTeamURL

See Also

StarTeamURL Class | Borland.StarTeam Namespace


Status Class

Represents the status of a working file relative to its corresponding file in the repository.

For a list of all members of this type, see Status Members.

System.Object
Status

public class Status : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Status Members | Borland.StarTeam Namespace


Status Members

Status overview

Public Static Properties

CURRENT
MERGE
MISSING
MODIFIED
NEW
OUTOFDATE
UNKNOWN

Public Static Methods

Name Returns a display name for the status represented by the specified code. If the statusValue is not one of the specified constants in this class then an Exception will be thrown.

Public Static Type Conversions

Implicit Status to Status Conversion Implicitly convert Status to com.starbase.starteam.Status.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.Status.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.Status.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Status Class | Borland.StarTeam Namespace


Status Properties

The properties of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Static Properties

CURRENT
MERGE
MISSING
MODIFIED
NEW
OUTOFDATE
UNKNOWN

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Status Class | Borland.StarTeam Namespace


CURRENT Property

Borland StarTeam SDK for .NET

Status.CURRENT Property

public static Int32 CURRENT {get;}

See Also

Status Class | Borland.StarTeam Namespace


MERGE Property

Borland StarTeam SDK for .NET

Status.MERGE Property

public static Int32 MERGE {get;}

See Also

Status Class | Borland.StarTeam Namespace


MISSING Property

Borland StarTeam SDK for .NET

Status.MISSING Property

public static Int32 MISSING {get;}

See Also

Status Class | Borland.StarTeam Namespace


MODIFIED Property

Borland StarTeam SDK for .NET

Status.MODIFIED Property

public static Int32 MODIFIED {get;}

See Also

Status Class | Borland.StarTeam Namespace


NEW Property

Borland StarTeam SDK for .NET

Status.NEW Property

public static Int32 NEW {get;}

See Also

Status Class | Borland.StarTeam Namespace


OUTOFDATE Property

Borland StarTeam SDK for .NET

Status.OUTOFDATE Property

public static Int32 OUTOFDATE {get;}

See Also

Status Class | Borland.StarTeam Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

Status.UNKNOWN Property

public static Int32 UNKNOWN {get;}

See Also

Status Class | Borland.StarTeam Namespace


Status Methods

The methods of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Static Methods

Name Returns a display name for the status represented by the specified code. If the statusValue is not one of the specified constants in this class then an Exception will be thrown.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.Status.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.Status.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Status Class | Borland.StarTeam Namespace


Status.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.Status

Implements

IWrapper.Unwrap

See Also

Status Class | Borland.StarTeam Namespace


Status.Equals Method

Delegate Equals() to com.starbase.starteam.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.Status.Equals(obj).

See Also

Status Class | Borland.StarTeam Namespace


Status.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.Status.

public override int GetHashCode();

Return Value

com.starbase.starteam.Status.GetHashCode().

See Also

Status Class | Borland.StarTeam Namespace


Status.Name Method

Returns a display name for the status represented by the specified code. If the statusValue is not one of the specified constants in this class then an Exception will be thrown.

public static string Name(
Int32 statusValue
);

Parameters

statusValue
the status value for which a display name is to be returned

Return Value

a display name for the status value.

See Also

Status Class | Borland.StarTeam Namespace


Status.ToString Method

Delegate ToString() to com.starbase.starteam.Status.

public override string ToString();

Return Value

com.starbase.starteam.Status.ToString()

See Also

Status Class | Borland.StarTeam Namespace


Status Type Conversions

The type conversions of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Static Type Conversions

Implicit Status to Status Conversion Implicitly convert Status to com.starbase.starteam.Status.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Status Class | Status Members | Borland.StarTeam Namespace


Status Implicit Status to Status Conversion

Implicitly convert Status to com.starbase.starteam.Status.

public static implicit operator Status(
Status arg
);

Parameters

arg
Status to convert.

Return Value

com.starbase.starteam.Status

See Also

Status Class | Borland.StarTeam Namespace


StatusMethod Class

This class provides information about how file status is managed for the client. Prior to StarTeam 5.2 all file status information was stored on the StarTeam Server. In 5.2 this staus information moved to the client. There are two ways in which that status information can be stored. These are refered to as "Per folder" and "Central"

"Per folder" status information is stored as close to the source file as possible. Assuming a file under revision control is stored in C:/project/foo.txt then the status information for that file will be stored in C:/project/.sbas/SyncDB. In fact, the status information for all files under C:/project will be stored in the file. There are a number of advantages of storing it in this location. For example, whole local folder structures may be moved or copied to new locations and all the status information will go along with it. The downside to this scheme is that in some cases users will not want the .sbas folders mixed in with the source files they are managing with StarTeam.

"Central" status information is all stored under a single user specified directory on the client's machine. This keeps the status information away from the user's source files. The downside to this approach is that you cannot easily move or copy source directories and have status information go along with it.

Users may specify which of these two methods to use by default along with the location of the central status information. Additionaly, users may override this on a per-View basis.

For a list of all members of this type, see StatusMethod Members.

System.Object
StatusMethod

public class StatusMethod : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

StatusMethod Members | Borland.StarTeam Namespace


StatusMethod Members

StatusMethod overview

Public Static Properties

CENTRAL |
CentralStatusDirectory | [read/write]
CentralStatusManager | [read] A FileBasedStatusManager for managing status in the central location for this workstation.
DEFAULT |
DefaultStatusManager | [read] The default FileBasedStatusManager for this workstation.
DefaultStatusMethod | [read/write]
PER_FOLDER |
PerFolderStatusManager | [read] A FileBasedStatusManager for managing status in the central location for this workstation.

Public Static Methods

DeleteSyncDB | Deletes all the status information for the specified directory path. The value for the "key" parameter must be a path in the proper format, one that would be returned from the getSourceDirs method.
GetSourceDirs | Given a root directory which contains centrally managed status data, this method will return an enumeration of all the local directory paths for which there is status data. The values in the enumeration will be String objects which are paths to local folders. The paths are in a platform independent format in which all directory delimiters are specified using the backslash (\) character.
GetSourceDirsCount | Returns the number of local directories that the specified centrally managed status directory is maintaining.
GetStatusManagerForView | Gets the FileBasedStatusManager that manages file status information for the given View. The corresponding StarTeam Server must support client-managed status.
GetStatusManagerForViewId | Gets the FileBasedStatusManager that manages file status information for the given View ID and Server ID.
Wrap | Dynamically wraps com.starbase.starteam.StatusMethod.

Public Static Type Conversions

Implicit StatusMethod to StatusMethod Conversion Implicitly convert StatusMethod to com.starbase.starteam.StatusMethod.

Public Instance Constructors

StatusMethod Constructor Construct StatusMethod from com.starbase.starteam.StatusMethod.

Public Instance Properties

DisplayName | [read] A display name for this StatusMethod.
Name | [read] The internal name of this StatusMethod.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.StatusMethod.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.StatusMethod.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.StatusMethod.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod Constructor

Construct StatusMethod from com.starbase.starteam.StatusMethod.

public StatusMethod(
StatusMethod impl
);

Parameters

impl
The com.starbase.starteam.StatusMethod to be wrapped.

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod Properties

The properties of the StatusMethod class are listed below. For a complete list of StatusMethod class members, see the StatusMethod Members topic.

Public Static Properties

CENTRAL |
CentralStatusDirectory | [read/write]
CentralStatusManager | [read] A FileBasedStatusManager for managing status in the central location for this workstation.
DEFAULT |
DefaultStatusManager | [read] The default FileBasedStatusManager for this workstation.
DefaultStatusMethod | [read/write]
PER_FOLDER |
PerFolderStatusManager | [read] A FileBasedStatusManager for managing status in the central location for this workstation.

Public Instance Properties

DisplayName | [read] A display name for this StatusMethod.
Name | [read] The internal name of this StatusMethod.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StatusMethod Class | Borland.StarTeam Namespace


CENTRAL Property

Borland StarTeam SDK for .NET

StatusMethod.CENTRAL Property

public static StatusMethod CENTRAL {get;}

See Also

StatusMethod Class | Borland.StarTeam Namespace


CentralStatusDirectory Property

Borland StarTeam SDK for .NET

StatusMethod.CentralStatusDirectory Property

[read/write]

public static String CentralStatusDirectory {get; set;}

See Also

StatusMethod Class | Borland.StarTeam Namespace


CentralStatusManager Property

Borland StarTeam SDK for .NET

StatusMethod.CentralStatusManager Property

[read] A FileBasedStatusManager for managing status in the central location for this workstation.

public static FileBasedStatusManager CentralStatusManager {get;}

Property Value

A FileBasedStatusManager for managing status in the central location for this workstation.

See Also

StatusMethod Class | Borland.StarTeam Namespace


DEFAULT Property

Borland StarTeam SDK for .NET

StatusMethod.DEFAULT Property

public static StatusMethod DEFAULT {get;}

See Also

StatusMethod Class | Borland.StarTeam Namespace


DefaultStatusManager Property

Borland StarTeam SDK for .NET

StatusMethod.DefaultStatusManager Property

[read] The default FileBasedStatusManager for this workstation.

public static FileBasedStatusManager DefaultStatusManager {get;}

Property Value

The default FileBasedStatusManager for this workstation.

See Also

StatusMethod Class | Borland.StarTeam Namespace


DefaultStatusMethod Property

Borland StarTeam SDK for .NET

StatusMethod.DefaultStatusMethod Property

[read/write]

public static StatusMethod DefaultStatusMethod {get; set;}

See Also

StatusMethod Class | Borland.StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

StatusMethod.DisplayName Property

[read] A display name for this StatusMethod.

public virtual String DisplayName {get;}

Property Value

A display name for this StatusMethod.

See Also

StatusMethod Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

StatusMethod.Name Property

[read] The internal name of this StatusMethod.

public virtual String Name {get;}

Property Value

The internal name of this StatusMethod.

See Also

StatusMethod Class | Borland.StarTeam Namespace


PER_FOLDER Property

Borland StarTeam SDK for .NET

StatusMethod.PER_FOLDER Property

public static StatusMethod PER_FOLDER {get;}

See Also

StatusMethod Class | Borland.StarTeam Namespace


PerFolderStatusManager Property

Borland StarTeam SDK for .NET

StatusMethod.PerFolderStatusManager Property

[read] A FileBasedStatusManager for managing status in the central location for this workstation.

public static FileBasedStatusManager PerFolderStatusManager {get;}

Property Value

A FileBasedStatusManager for managing status in the central location for this workstation.

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod Methods

The methods of the StatusMethod class are listed below. For a complete list of StatusMethod class members, see the StatusMethod Members topic.

Public Static Methods

DeleteSyncDB | Deletes all the status information for the specified directory path. The value for the "key" parameter must be a path in the proper format, one that would be returned from the getSourceDirs method.
GetSourceDirs | Given a root directory which contains centrally managed status data, this method will return an enumeration of all the local directory paths for which there is status data. The values in the enumeration will be String objects which are paths to local folders. The paths are in a platform independent format in which all directory delimiters are specified using the backslash (\) character.
GetSourceDirsCount | Returns the number of local directories that the specified centrally managed status directory is maintaining.
GetStatusManagerForView | Gets the FileBasedStatusManager that manages file status information for the given View. The corresponding StarTeam Server must support client-managed status.
GetStatusManagerForViewId | Gets the FileBasedStatusManager that manages file status information for the given View ID and Server ID.
Wrap | Dynamically wraps com.starbase.starteam.StatusMethod.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.StatusMethod.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.StatusMethod.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.StatusMethod.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.StatusMethod

Implements

IWrapper.Unwrap

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod.DeleteSyncDB Method

Deletes all the status information for the specified directory path. The value for the "key" parameter must be a path in the proper format, one that would be returned from the getSourceDirs method.

public static void DeleteSyncDB(
FileInfo syncDirRoot,
String key
);

Parameters

syncDirRoot
the root of the centrally managed status directory
key
the platform independent directory path whose status will be deleted.

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod.Equals Method

Delegate Equals() to com.starbase.starteam.StatusMethod.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.StatusMethod.Equals(obj).

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.StatusMethod.

public override int GetHashCode();

Return Value

com.starbase.starteam.StatusMethod.GetHashCode().

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod.GetSourceDirs Method

Given a root directory which contains centrally managed status data, this method will return an enumeration of all the local directory paths for which there is status data. The values in the enumeration will be String objects which are paths to local folders. The paths are in a platform independent format in which all directory delimiters are specified using the backslash (\) character.

public static IEnumerator GetSourceDirs(
FileInfo syncDirRoot
);

Parameters

syncDirRoot
the root of the centrally managed status directory

Return Value

an enumeration of all the local directory paths that have status information

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod.GetSourceDirsCount Method

Returns the number of local directories that the specified centrally managed status directory is maintaining.

public static int GetSourceDirsCount(
FileInfo syncDirRoot
);

Parameters

syncDirRoot
the root of the centrally managed status directory

Return Value

the total number of local dirs that have status information

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod.GetStatusManagerForView Method

Gets the FileBasedStatusManager that manages file status information for the given View. The corresponding StarTeam Server must support client-managed status.

public static FileBasedStatusManager GetStatusManagerForView(
View view
);

Parameters

view

Return Value

The FileBasedStatusManager for the given View.

See Also

StatusMethod Class | Borland.StarTeam Namespace | hasClientManagedFileStatus | getFileStatusManager | FileBasedStatusManager


StatusMethod.GetStatusManagerForViewId Method

Gets the FileBasedStatusManager that manages file status information for the given View ID and Server ID.

public static FileBasedStatusManager GetStatusManagerForViewId(
Int32 viewID,
String serverGUID
);

Parameters

viewID
the view's ID.
serverGUID
server's repository id (which is a GUID) in string form.

Return Value

The FileBasedStatusManager for the given View.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StatusMethod Class | Borland.StarTeam Namespace | getFileStatusManager | FileBasedStatusManager


StatusMethod.ToString Method

Delegate ToString() to com.starbase.starteam.StatusMethod.

public override string ToString();

Return Value

com.starbase.starteam.StatusMethod.ToString()

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod.Wrap Method

Dynamically wraps com.starbase.starteam.StatusMethod.

public static StatusMethod Wrap(
StatusMethod impl
);

Parameters

impl
com.starbase.starteam.StatusMethod to be wrapped.

Return Value

StatusMethod

See Also

StatusMethod Class | Borland.StarTeam Namespace


StatusMethod Type Conversions

The type conversions of the StatusMethod class are listed below. For a complete list of StatusMethod class members, see the StatusMethod Members topic.

Public Static Type Conversions

Implicit StatusMethod to StatusMethod Conversion Implicitly convert StatusMethod to com.starbase.starteam.StatusMethod.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StatusMethod Class | StatusMethod Members | Borland.StarTeam Namespace


StatusMethod Implicit StatusMethod to StatusMethod Conversion

Implicitly convert StatusMethod to com.starbase.starteam.StatusMethod.

public static implicit operator StatusMethod(
StatusMethod arg
);

Parameters

arg
StatusMethod to convert.

Return Value

com.starbase.starteam.StatusMethod

See Also

StatusMethod Class | Borland.StarTeam Namespace


SupportedFeatures Class

The SupportedFeatures class contains a number of methods that report whether or not a particular feature is available for a StarTeam server.

For a list of all members of this type, see SupportedFeatures Members.

System.Object
SupportedFeatures

public class SupportedFeatures : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SupportedFeatures Members | Borland.StarTeam Namespace


SupportedFeatures Members

SupportedFeatures overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SupportedFeatures.

Public Static Type Conversions

Implicit SupportedFeatures to SupportedFeatures Conversion Implicitly convert SupportedFeatures to com.starbase.starteam.SupportedFeatures.

Public Instance Constructors

SupportedFeatures Constructor Construct SupportedFeatures from com.starbase.starteam.SupportedFeatures.

Public Instance Properties

DebugString | [read]
HasBLSLicensing | [read] true for all supported versions of StarTeam Server.
HasClientManagedFileStatus | [read]
HasConcurrentLicensing | [read]
HasCustomTranslations | [read] true for all supported versions of StarTeam Server.
HasDeletedItems | [read] True if the server supports retrieval of information regarding deleted items; false otherwise.
HasDiagnostics | [read] true for all supported versions of StarTeam Server.
HasDiagnosticStatisticsReporting | [read] true if this server can report diagnostic statistics, and false otherwise.
HasDirectoryServiceSupport | [read] true for all supported versions of StarTeam Server.
HasEnhancedProcessItemCustomizations | [read] true if this is a StarTeam server that has been customized to support the enhanced process item model.
HasEnhancedProcessItems | [read] true if this server supports the enhanced process item model, and false otherwise.
HasEnhancedProcessItemsNative | [read] true if this server has native support for the enhanced process item model, and false otherwise.
HasFileExecutablePermission | [read] true for all supported versions of StarTeam Server.
HasForwardCompatibility | [read] true for all supported versions of StarTeam Server.
HasGroupMembers | [read] true for all supported versions of StarTeam Server.
HasItemRevision | [read] true for all supported versions of StarTeam Server.
HasLabelCopy | [read] true for all supported versions of StarTeam Server.
HasLabelLocking | [read] true for all supported versions of StarTeam Server.
HasLicenseUsage | [read] Return true if server supports "License Usage" feature.
HasLinkParentFolderItemID | [read] true for all supported versions of StarTeam Server.
HasLongFileSizes | [read] boolean true if file sizes greater than 2GB are supported, and false otherwise.
HasMergeHistory | [read] true for all supported versions of StarTeam Server.
HasMergeService | [read] true for all supported versions of StarTeam Server.
HasMultiCommandTransactions | [read] true if the server supports multi-command transactions, false otherwise.
HasNamedConfigOptions | [read] true for all supported versions of StarTeam Server.
HasNativeIIVault | [read] for all supported versions of StarTeam Server.
HasNewAuditProperties | [read] true for all supported versions of StarTeam Server.
HasNewUserCertificate | [read] Return true if server supports "New User Certificate" feature.
HasNoTimeoutNamedLicenses | [read] true for all supported versions of StarTeam Server.
HasNOTQueryOperator | [read] true for all supported versions of StarTeam Server.
HasObjectOwnership | [read] true if "Object Ownership" is supported; false otherwise.
HasPromotionStateRights | [read] true for all supported versions of StarTeam Server.
HasReconnect | [read] true for all supported versions of StarTeam Server.
HasSecureDirectoryService | [read] true for all supported versions of StarTeam Server.
HasServerCommandStats | [read] true for all supported versions of StarTeam Server.
HasServerExclusiveLock | [read]
HasServerLicenseInfo | [read]
HasServerLockStatus | [read]
HasServerShutdown | [read]
IsServerLocalized | [read] true for all supported versions of StarTeam Server.
IsShareTreeTimeBased | [read]

Public Instance Methods

CanShareFolderOnly | Determines whether or not the server supports sharing a folder without sharing any of its subfolders or contained items.
Equals | Delegate Equals() to com.starbase.starteam.SupportedFeatures.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.SupportedFeatures.
GetType (inherited from Object) | Gets the Type of the current instance.
HasBulkCreateLinks | Determines whether or not the server can create multiple links via a single server command.
HasBulkFetchLinks | Determines whether or not the server fetch links for multiple items via a single server command.
HasCurrentTime | Determines whether or not the server can report its current time.
HasFileEOLFormat | Determines whether or not the server supports setting the EOLFormat of a file. This feature is supported for StarTeam 2006 and later.
HasFolderComponentAccessRights | Return true if the server supports component-level access rights for Folders. This first appeared in 9.0.42 release.
HasLabelCommandsOnRolledBackView | Determins whether or not the server supports the following Label operations in rolled back views: 1. attachment, 2. detachment 3. movement.
HasOnlinePurgeControl |
HasPVCSSupport | Determines whether or not PVCS foreign archives are supported.
HasVSSSupport | Determines whether or not VSS foreign archives are supported.
ToString | Delegate ToString() to com.starbase.starteam.SupportedFeatures.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures Constructor

Construct SupportedFeatures from com.starbase.starteam.SupportedFeatures.

public SupportedFeatures(
SupportedFeatures impl
);

Parameters

impl
The com.starbase.starteam.SupportedFeatures to be wrapped.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures Properties

The properties of the SupportedFeatures class are listed below. For a complete list of SupportedFeatures class members, see the SupportedFeatures Members topic.

Public Instance Properties

DebugString | [read]
HasBLSLicensing | [read] true for all supported versions of StarTeam Server.
HasClientManagedFileStatus | [read]
HasConcurrentLicensing | [read]
HasCustomTranslations | [read] true for all supported versions of StarTeam Server.
HasDeletedItems | [read] True if the server supports retrieval of information regarding deleted items; false otherwise.
HasDiagnostics | [read] true for all supported versions of StarTeam Server.
HasDiagnosticStatisticsReporting | [read] true if this server can report diagnostic statistics, and false otherwise.
HasDirectoryServiceSupport | [read] true for all supported versions of StarTeam Server.
HasEnhancedProcessItemCustomizations | [read] true if this is a StarTeam server that has been customized to support the enhanced process item model.
HasEnhancedProcessItems | [read] true if this server supports the enhanced process item model, and false otherwise.
HasEnhancedProcessItemsNative | [read] true if this server has native support for the enhanced process item model, and false otherwise.
HasFileExecutablePermission | [read] true for all supported versions of StarTeam Server.
HasForwardCompatibility | [read] true for all supported versions of StarTeam Server.
HasGroupMembers | [read] true for all supported versions of StarTeam Server.
HasItemRevision | [read] true for all supported versions of StarTeam Server.
HasLabelCopy | [read] true for all supported versions of StarTeam Server.
HasLabelLocking | [read] true for all supported versions of StarTeam Server.
HasLicenseUsage | [read] Return true if server supports "License Usage" feature.
HasLinkParentFolderItemID | [read] true for all supported versions of StarTeam Server.
HasLongFileSizes | [read] boolean true if file sizes greater than 2GB are supported, and false otherwise.
HasMergeHistory | [read] true for all supported versions of StarTeam Server.
HasMergeService | [read] true for all supported versions of StarTeam Server.
HasMultiCommandTransactions | [read] true if the server supports multi-command transactions, false otherwise.
HasNamedConfigOptions | [read] true for all supported versions of StarTeam Server.
HasNativeIIVault | [read] for all supported versions of StarTeam Server.
HasNewAuditProperties | [read] true for all supported versions of StarTeam Server.
HasNewUserCertificate | [read] Return true if server supports "New User Certificate" feature.
HasNoTimeoutNamedLicenses | [read] true for all supported versions of StarTeam Server.
HasNOTQueryOperator | [read] true for all supported versions of StarTeam Server.
HasObjectOwnership | [read] true if "Object Ownership" is supported; false otherwise.
HasPromotionStateRights | [read] true for all supported versions of StarTeam Server.
HasReconnect | [read] true for all supported versions of StarTeam Server.
HasSecureDirectoryService | [read] true for all supported versions of StarTeam Server.
HasServerCommandStats | [read] true for all supported versions of StarTeam Server.
HasServerExclusiveLock | [read]
HasServerLicenseInfo | [read]
HasServerLockStatus | [read]
HasServerShutdown | [read]
IsServerLocalized | [read] true for all supported versions of StarTeam Server.
IsShareTreeTimeBased | [read]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

SupportedFeatures.DebugString Property

[read]

public virtual String DebugString {get;}

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasBLSLicensing Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasBLSLicensing Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasBLSLicensing {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasClientManagedFileStatus Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasClientManagedFileStatus Property

[read]

public virtual Boolean HasClientManagedFileStatus {get;}

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasConcurrentLicensing Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasConcurrentLicensing Property

[read]

public virtual Boolean HasConcurrentLicensing {get;}

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasCustomTranslations Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasCustomTranslations Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasCustomTranslations {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasDeletedItems Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasDeletedItems Property

[read] True if the server supports retrieval of information regarding deleted items; false otherwise.

public virtual Boolean HasDeletedItems {get;}

Property Value

True if the server supports retrieval of information regarding deleted items; false otherwise.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasDiagnostics Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasDiagnostics Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasDiagnostics {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasDiagnosticStatisticsReporting Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasDiagnosticStatisticsReporting Property

[read] true if this server can report diagnostic statistics, and false otherwise.

public virtual Boolean HasDiagnosticStatisticsReporting {get;}

Property Value

true if this server can report diagnostic statistics, and false otherwise.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasDirectoryServiceSupport Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasDirectoryServiceSupport Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasDirectoryServiceSupport {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasEnhancedProcessItemCustomizations Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasEnhancedProcessItemCustomizations Property

[read] true if this is a StarTeam server that has been customized to support the enhanced process item model.

public virtual Boolean HasEnhancedProcessItemCustomizations {get;}

Property Value

true if this is a StarTeam server that has been customized to support the enhanced process item model.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasEnhancedProcessItems Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasEnhancedProcessItems Property

[read] true if this server supports the enhanced process item model, and false otherwise.

public virtual Boolean HasEnhancedProcessItems {get;}

Property Value

true if this server supports the enhanced process item model, and false otherwise.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasEnhancedProcessItemsNative Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasEnhancedProcessItemsNative Property

[read] true if this server has native support for the enhanced process item model, and false otherwise.

public virtual Boolean HasEnhancedProcessItemsNative {get;}

Property Value

true if this server has native support for the enhanced process item model, and false otherwise.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasFileExecutablePermission Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasFileExecutablePermission Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasFileExecutablePermission {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasForwardCompatibility Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasForwardCompatibility Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasForwardCompatibility {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasGroupMembers Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasGroupMembers Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasGroupMembers {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasItemRevision Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasItemRevision Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasItemRevision {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasLabelCopy Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasLabelCopy Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasLabelCopy {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasLabelLocking Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasLabelLocking Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasLabelLocking {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasLicenseUsage Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasLicenseUsage Property

[read] Return true if server supports "License Usage" feature.

public virtual Boolean HasLicenseUsage {get;}

Property Value

Return true if server supports "License Usage" feature.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasLinkParentFolderItemID Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasLinkParentFolderItemID Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasLinkParentFolderItemID {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasLongFileSizes Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasLongFileSizes Property

[read] boolean true if file sizes greater than 2GB are supported, and false otherwise.

public virtual Boolean HasLongFileSizes {get;}

Property Value

boolean true if file sizes greater than 2GB are supported, and false otherwise.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasMergeHistory Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasMergeHistory Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasMergeHistory {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasMergeService Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasMergeService Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasMergeService {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasMultiCommandTransactions Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasMultiCommandTransactions Property

[read] true if the server supports multi-command transactions, false otherwise.

public virtual Boolean HasMultiCommandTransactions {get;}

Property Value

true if the server supports multi-command transactions, false otherwise.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasNamedConfigOptions Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasNamedConfigOptions Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasNamedConfigOptions {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasNativeIIVault Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasNativeIIVault Property

[read] for all supported versions of StarTeam Server.

public virtual Boolean HasNativeIIVault {get;}

Property Value

for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasNewAuditProperties Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasNewAuditProperties Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasNewAuditProperties {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasNewUserCertificate Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasNewUserCertificate Property

[read] Return true if server supports "New User Certificate" feature.

public virtual Boolean HasNewUserCertificate {get;}

Property Value

Return true if server supports "New User Certificate" feature.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasNoTimeoutNamedLicenses Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasNoTimeoutNamedLicenses Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasNoTimeoutNamedLicenses {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasNOTQueryOperator Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasNOTQueryOperator Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasNOTQueryOperator {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasObjectOwnership Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasObjectOwnership Property

[read] true if "Object Ownership" is supported; false otherwise.

public virtual Boolean HasObjectOwnership {get;}

Property Value

true if "Object Ownership" is supported; false otherwise.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasPromotionStateRights Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasPromotionStateRights Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasPromotionStateRights {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasReconnect Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasReconnect Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasReconnect {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasSecureDirectoryService Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasSecureDirectoryService Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasSecureDirectoryService {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasServerCommandStats Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasServerCommandStats Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean HasServerCommandStats {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasServerExclusiveLock Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasServerExclusiveLock Property

[read]

public virtual Boolean HasServerExclusiveLock {get;}

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasServerLicenseInfo Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasServerLicenseInfo Property

[read]

public virtual Boolean HasServerLicenseInfo {get;}

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasServerLockStatus Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasServerLockStatus Property

[read]

public virtual Boolean HasServerLockStatus {get;}

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


HasServerShutdown Property

Borland StarTeam SDK for .NET

SupportedFeatures.HasServerShutdown Property

[read]

public virtual Boolean HasServerShutdown {get;}

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


IsServerLocalized Property

Borland StarTeam SDK for .NET

SupportedFeatures.IsServerLocalized Property

[read] true for all supported versions of StarTeam Server.

public virtual Boolean IsServerLocalized {get;}

Property Value

true for all supported versions of StarTeam Server.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


IsShareTreeTimeBased Property

Borland StarTeam SDK for .NET

SupportedFeatures.IsShareTreeTimeBased Property

[read]

public virtual Boolean IsShareTreeTimeBased {get;}

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures Methods

The methods of the SupportedFeatures class are listed below. For a complete list of SupportedFeatures class members, see the SupportedFeatures Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SupportedFeatures.

Public Instance Methods

CanShareFolderOnly | Determines whether or not the server supports sharing a folder without sharing any of its subfolders or contained items.
Equals | Delegate Equals() to com.starbase.starteam.SupportedFeatures.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.SupportedFeatures.
GetType (inherited from Object) | Gets the Type of the current instance.
HasBulkCreateLinks | Determines whether or not the server can create multiple links via a single server command.
HasBulkFetchLinks | Determines whether or not the server fetch links for multiple items via a single server command.
HasCurrentTime | Determines whether or not the server can report its current time.
HasFileEOLFormat | Determines whether or not the server supports setting the EOLFormat of a file. This feature is supported for StarTeam 2006 and later.
HasFolderComponentAccessRights | Return true if the server supports component-level access rights for Folders. This first appeared in 9.0.42 release.
HasLabelCommandsOnRolledBackView | Determins whether or not the server supports the following Label operations in rolled back views: 1. attachment, 2. detachment 3. movement.
HasOnlinePurgeControl |
HasPVCSSupport | Determines whether or not PVCS foreign archives are supported.
HasVSSSupport | Determines whether or not VSS foreign archives are supported.
ToString | Delegate ToString() to com.starbase.starteam.SupportedFeatures.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.SupportedFeatures

Implements

IWrapper.Unwrap

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures.CanShareFolderOnly Method

Determines whether or not the server supports sharing a folder without sharing any of its subfolders or contained items.

public virtual bool CanShareFolderOnly();

Return Value

true if the server supports sharing a folder without sharing any of its subfolders or contained items; false if sharing a folder always shares its contained items.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace | shareTo


SupportedFeatures.Equals Method

Delegate Equals() to com.starbase.starteam.SupportedFeatures.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.SupportedFeatures.Equals(obj).

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.SupportedFeatures.

public override int GetHashCode();

Return Value

com.starbase.starteam.SupportedFeatures.GetHashCode().

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures.HasBulkCreateLinks Method

Determines whether or not the server can create multiple links via a single server command.

public virtual bool HasBulkCreateLinks();

See Also

SupportedFeatures Class | Borland.StarTeam Namespace | LinkFactory


SupportedFeatures.HasBulkFetchLinks Method

Determines whether or not the server fetch links for multiple items via a single server command.

public virtual bool HasBulkFetchLinks();

See Also

SupportedFeatures Class | Borland.StarTeam Namespace | LinkCache


SupportedFeatures.HasCurrentTime Method

Determines whether or not the server can report its current time.

public virtual bool HasCurrentTime();

Return Value

true if the server can report its current time; false otherwise.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace | getCurrentTime


SupportedFeatures.HasFileEOLFormat Method

Determines whether or not the server supports setting the EOLFormat of a file. This feature is supported for StarTeam 2006 and later.

public virtual bool HasFileEOLFormat();

Return Value

boolean

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures.HasFolderComponentAccessRights Method

Return true if the server supports component-level access rights for Folders. This first appeared in 9.0.42 release.

public virtual bool HasFolderComponentAccessRights();

Return Value

true if the server supports component-level access rights for Folders.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures.HasLabelCommandsOnRolledBackView Method

Determins whether or not the server supports the following Label operations in rolled back views: 1. attachment, 2. detachment 3. movement.

public virtual bool HasLabelCommandsOnRolledBackView();

Return Value

True if the server supports the above operations; false otherwise.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace | attachItem | attachToFolder | attachToItems | detachFromFolder | detachFromItems | detachItem | moveItem


SupportedFeatures.HasOnlinePurgeControl Method

public virtual bool HasOnlinePurgeControl();

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures.HasPVCSSupport Method

Determines whether or not PVCS foreign archives are supported.

public virtual bool HasPVCSSupport();

Return Value

true if PVCS foreign archives are supported, and false otherwise.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures.HasVSSSupport Method

Determines whether or not VSS foreign archives are supported.

public virtual bool HasVSSSupport();

Return Value

true if VSS foreign archives are supported, and false otherwise.

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures.ToString Method

Delegate ToString() to com.starbase.starteam.SupportedFeatures.

public override string ToString();

Return Value

com.starbase.starteam.SupportedFeatures.ToString()

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures.Wrap Method

Dynamically wraps com.starbase.starteam.SupportedFeatures.

public static SupportedFeatures Wrap(
SupportedFeatures impl
);

Parameters

impl
com.starbase.starteam.SupportedFeatures to be wrapped.

Return Value

SupportedFeatures

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SupportedFeatures Type Conversions

The type conversions of the SupportedFeatures class are listed below. For a complete list of SupportedFeatures class members, see the SupportedFeatures Members topic.

Public Static Type Conversions

Implicit SupportedFeatures to SupportedFeatures Conversion Implicitly convert SupportedFeatures to com.starbase.starteam.SupportedFeatures.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SupportedFeatures Class | SupportedFeatures Members | Borland.StarTeam Namespace


SupportedFeatures Implicit SupportedFeatures to SupportedFeatures Conversion

Implicitly convert SupportedFeatures to com.starbase.starteam.SupportedFeatures.

public static implicit operator SupportedFeatures(
SupportedFeatures arg
);

Parameters

arg
SupportedFeatures to convert.

Return Value

com.starbase.starteam.SupportedFeatures

See Also

SupportedFeatures Class | Borland.StarTeam Namespace


SystemPolicy Class

For a list of all members of this type, see SystemPolicy Members.

System.Object
SystemPolicy

public class SystemPolicy : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SystemPolicy Members | Borland.StarTeam Namespace


SystemPolicy Members

SystemPolicy overview

Public Static Properties

ALLOW_BLANK_PASSWORDS
FAILED_LOGIN_NO_LIMIT
LOCKOUT_FOREVER
PASSWORDS_NEVER_EXPIRE
SECURITYLOG_AUTOPURGE_DEFAULT
SECURITYLOG_AUTOPURGE_NEVER

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SystemPolicy.

Public Static Type Conversions

Implicit SystemPolicy to SystemPolicy Conversion Implicitly convert SystemPolicy to com.starbase.starteam.SystemPolicy.

Public Instance Constructors

SystemPolicy Overloaded. Initializes a new instance of the SystemPolicy class.

Public Instance Properties

FailedLoginLimit | [read/write] The number of acceptable failed login attempts.
FailedLoginLockout | [read/write] The number of minutes a user will be locked out after exceeding the failed login limit.
IsStrongPasswordRulesSupported | [read] true if the "strong password rules" feature is supported by the server.
MinimumPasswordLength | [read/write] The minimum password length.
NotifyByEmail | [read/write] true if security administrators will be notified by email.
PasswordExpirationPeriod | [read/write] The number of days after which a password will expire.
SecurityLogAutoPurgeDays | [read/write] The number of days of information that will be saved.
SkipGroupPrivilegesCheck | [read/write] true if access validation will ignore group privileges, and false otherwise.
SkipOwnershipCheck | [read/write] true if access validation will ignore object ownership, and false otherwise.
StrongPasswordRulesEnforced | [read/write] true if strong password rules are enforced, and false otherwise.

Public Instance Methods

Copy | returns a copy of this SystemPolicy instance
Equals | Delegate Equals() to com.starbase.starteam.SystemPolicy.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.SystemPolicy.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if the paramter is a System Policy whose values are identical to those of this instance
ToString | Delegate ToString() to com.starbase.starteam.SystemPolicy.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemPolicy Constructor

Construct SystemPolicy from com.starbase.starteam.SystemPolicy.

Overload List

construct a SystemPolicy instance from the specified source

public SystemPolicy(SystemPolicy);

Construct SystemPolicy from com.starbase.starteam.SystemPolicy.

public SystemPolicy(SystemPolicy);

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemPolicy Constructor (SystemPolicy)

Construct SystemPolicy from com.starbase.starteam.SystemPolicy.

public SystemPolicy(
SystemPolicy impl
);

Parameters

impl
The com.starbase.starteam.SystemPolicy to be wrapped.

See Also

SystemPolicy Class | Borland.StarTeam Namespace | SystemPolicy Constructor Overload List


SystemPolicy Constructor (SystemPolicy)

construct a SystemPolicy instance from the specified source

public SystemPolicy(
SystemPolicy source
);

Parameters

source
SystemPolicy a SystemPolicy instance to copy from

See Also

SystemPolicy Class | Borland.StarTeam Namespace | SystemPolicy Constructor Overload List


SystemPolicy Properties

The properties of the SystemPolicy class are listed below. For a complete list of SystemPolicy class members, see the SystemPolicy Members topic.

Public Static Properties

ALLOW_BLANK_PASSWORDS
FAILED_LOGIN_NO_LIMIT
LOCKOUT_FOREVER
PASSWORDS_NEVER_EXPIRE
SECURITYLOG_AUTOPURGE_DEFAULT
SECURITYLOG_AUTOPURGE_NEVER

Public Instance Properties

FailedLoginLimit | [read/write] The number of acceptable failed login attempts.
FailedLoginLockout | [read/write] The number of minutes a user will be locked out after exceeding the failed login limit.
IsStrongPasswordRulesSupported | [read] true if the "strong password rules" feature is supported by the server.
MinimumPasswordLength | [read/write] The minimum password length.
NotifyByEmail | [read/write] true if security administrators will be notified by email.
PasswordExpirationPeriod | [read/write] The number of days after which a password will expire.
SecurityLogAutoPurgeDays | [read/write] The number of days of information that will be saved.
SkipGroupPrivilegesCheck | [read/write] true if access validation will ignore group privileges, and false otherwise.
SkipOwnershipCheck | [read/write] true if access validation will ignore object ownership, and false otherwise.
StrongPasswordRulesEnforced | [read/write] true if strong password rules are enforced, and false otherwise.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SystemPolicy Class | Borland.StarTeam Namespace


ALLOW_BLANK_PASSWORDS Property

Borland StarTeam SDK for .NET

SystemPolicy.ALLOW_BLANK_PASSWORDS Property

public static Int32 ALLOW_BLANK_PASSWORDS {get;}

See Also

SystemPolicy Class | Borland.StarTeam Namespace


FAILED_LOGIN_NO_LIMIT Property

Borland StarTeam SDK for .NET

SystemPolicy.FAILED_LOGIN_NO_LIMIT Property

public static Int32 FAILED_LOGIN_NO_LIMIT {get;}

See Also

SystemPolicy Class | Borland.StarTeam Namespace


FailedLoginLimit Property

Borland StarTeam SDK for .NET

SystemPolicy.FailedLoginLimit Property

[read/write] The number of acceptable failed login attempts.

public virtual Int32 FailedLoginLimit {get; set;}

Property Value

The number of acceptable failed login attempts.

See Also

SystemPolicy Class | Borland.StarTeam Namespace


FailedLoginLockout Property

Borland StarTeam SDK for .NET

SystemPolicy.FailedLoginLockout Property

[read/write] The number of minutes a user will be locked out after exceeding the failed login limit.

public virtual Int32 FailedLoginLockout {get; set;}

Property Value

The number of minutes a user will be locked out after exceeding the failed login limit.

See Also

SystemPolicy Class | Borland.StarTeam Namespace


IsStrongPasswordRulesSupported Property

Borland StarTeam SDK for .NET

SystemPolicy.IsStrongPasswordRulesSupported Property

[read] true if the "strong password rules" feature is supported by the server.

public virtual Boolean IsStrongPasswordRulesSupported {get;}

Property Value

true if the "strong password rules" feature is supported by the server.

See Also

SystemPolicy Class | Borland.StarTeam Namespace


LOCKOUT_FOREVER Property

Borland StarTeam SDK for .NET

SystemPolicy.LOCKOUT_FOREVER Property

public static Int32 LOCKOUT_FOREVER {get;}

See Also

SystemPolicy Class | Borland.StarTeam Namespace


MinimumPasswordLength Property

Borland StarTeam SDK for .NET

SystemPolicy.MinimumPasswordLength Property

[read/write] The minimum password length.

public virtual Int32 MinimumPasswordLength {get; set;}

Property Value

The minimum password length.

See Also

SystemPolicy Class | Borland.StarTeam Namespace


NotifyByEmail Property

Borland StarTeam SDK for .NET

SystemPolicy.NotifyByEmail Property

[read/write] true if security administrators will be notified by email.

public virtual Boolean NotifyByEmail {get; set;}

Property Value

true if security administrators will be notified by email.

See Also

SystemPolicy Class | Borland.StarTeam Namespace


PasswordExpirationPeriod Property

Borland StarTeam SDK for .NET

SystemPolicy.PasswordExpirationPeriod Property

[read/write] The number of days after which a password will expire.

public virtual Int32 PasswordExpirationPeriod {get; set;}

Property Value

The number of days after which a password will expire.

See Also

SystemPolicy Class | Borland.StarTeam Namespace


PASSWORDS_NEVER_EXPIRE Property

Borland StarTeam SDK for .NET

SystemPolicy.PASSWORDS_NEVER_EXPIRE Property

public static Int32 PASSWORDS_NEVER_EXPIRE {get;}

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SECURITYLOG_AUTOPURGE_DEFAULT Property

Borland StarTeam SDK for .NET

SystemPolicy.SECURITYLOG_AUTOPURGE_DEFAULT Property

public static Int32 SECURITYLOG_AUTOPURGE_DEFAULT {get;}

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SECURITYLOG_AUTOPURGE_NEVER Property

Borland StarTeam SDK for .NET

SystemPolicy.SECURITYLOG_AUTOPURGE_NEVER Property

public static Int32 SECURITYLOG_AUTOPURGE_NEVER {get;}

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SecurityLogAutoPurgeDays Property

Borland StarTeam SDK for .NET

SystemPolicy.SecurityLogAutoPurgeDays Property

[read/write] The number of days of information that will be saved.

public virtual Int32 SecurityLogAutoPurgeDays {get; set;}

Property Value

The number of days of information that will be saved.

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SkipGroupPrivilegesCheck Property

Borland StarTeam SDK for .NET

SystemPolicy.SkipGroupPrivilegesCheck Property

[read/write] true if access validation will ignore group privileges, and false otherwise.

public virtual Boolean SkipGroupPrivilegesCheck {get; set;}

Property Value

true if access validation will ignore group privileges, and false otherwise.

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SkipOwnershipCheck Property

Borland StarTeam SDK for .NET

SystemPolicy.SkipOwnershipCheck Property

[read/write] true if access validation will ignore object ownership, and false otherwise.

public virtual Boolean SkipOwnershipCheck {get; set;}

Property Value

true if access validation will ignore object ownership, and false otherwise.

See Also

SystemPolicy Class | Borland.StarTeam Namespace


StrongPasswordRulesEnforced Property

Borland StarTeam SDK for .NET

SystemPolicy.StrongPasswordRulesEnforced Property

[read/write] true if strong password rules are enforced, and false otherwise.

public virtual Boolean StrongPasswordRulesEnforced {get; set;}

Property Value

true if strong password rules are enforced, and false otherwise.

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemPolicy Methods

The methods of the SystemPolicy class are listed below. For a complete list of SystemPolicy class members, see the SystemPolicy Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.SystemPolicy.

Public Instance Methods

Copy | returns a copy of this SystemPolicy instance
Equals | Delegate Equals() to com.starbase.starteam.SystemPolicy.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.SystemPolicy.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if the paramter is a System Policy whose values are identical to those of this instance
ToString | Delegate ToString() to com.starbase.starteam.SystemPolicy.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemPolicy.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.SystemPolicy

Implements

IWrapper.Unwrap

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemPolicy.Copy Method

returns a copy of this SystemPolicy instance

public virtual SystemPolicy Copy();

Return Value

SystemPolicy a copy of this SystemPolicy instance

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemPolicy.Equals Method

Delegate Equals() to com.starbase.starteam.SystemPolicy.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.SystemPolicy.Equals(obj).

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemPolicy.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.SystemPolicy.

public override int GetHashCode();

Return Value

com.starbase.starteam.SystemPolicy.GetHashCode().

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemPolicy.IsEqualTo Method

returns true if the paramter is a System Policy whose values are identical to those of this instance

public virtual bool IsEqualTo(
SystemPolicy theOther
);

Parameters

theOther
Object the other System Policy instance to be evaluated

Return Value

boolean true if the the other System Policy has values identical to those of this instance

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemPolicy.ToString Method

Delegate ToString() to com.starbase.starteam.SystemPolicy.

public override string ToString();

Return Value

com.starbase.starteam.SystemPolicy.ToString()

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemPolicy.Wrap Method

Dynamically wraps com.starbase.starteam.SystemPolicy.

public static SystemPolicy Wrap(
SystemPolicy impl
);

Parameters

impl
com.starbase.starteam.SystemPolicy to be wrapped.

Return Value

SystemPolicy

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemPolicy Type Conversions

The type conversions of the SystemPolicy class are listed below. For a complete list of SystemPolicy class members, see the SystemPolicy Members topic.

Public Static Type Conversions

Implicit SystemPolicy to SystemPolicy Conversion Implicitly convert SystemPolicy to com.starbase.starteam.SystemPolicy.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SystemPolicy Class | SystemPolicy Members | Borland.StarTeam Namespace


SystemPolicy Implicit SystemPolicy to SystemPolicy Conversion

Implicitly convert SystemPolicy to com.starbase.starteam.SystemPolicy.

public static implicit operator SystemPolicy(
SystemPolicy arg
);

Parameters

arg
SystemPolicy to convert.

Return Value

com.starbase.starteam.SystemPolicy

See Also

SystemPolicy Class | Borland.StarTeam Namespace


SystemRevisionNumbers Class

For a list of all members of this type, see SystemRevisionNumbers Members.

System.Object
SystemRevisionNumbers

public class SystemRevisionNumbers : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SystemRevisionNumbers Members | Borland.StarTeam Namespace


SystemRevisionNumbers Members

SystemRevisionNumbers overview

Public Static Properties

REV_42 |
REV_CLIENT_STATUS |
REV_CONCURRENT_LICENSES_SUPPORTED |
REV_CORRECTED_REF_MODIFIED_TIME |
REV_FALCON_ADDED_CLIENT_PROPS |
REV_FIRST_5_2_BUILD |
REV_FORWARD_COMPATIBILITY |
REV_GET_SERVER_LOCK |
REV_IDARRAY_STREAMED_AS_INTARRAY |
REV_MODIFIED_CREATE_LINK |
REV_MOVE_FOLDER_DELETE_ABANDONS_VIEWS |
REV_PORTABLE_VTS |
REV_PROTOCOL_TCPIPXML_SUPPORTED |
REV_REPLICATION_SUPPORT |
REV_SECURE_COMMANDS |
REV_SERVER_LICENSE_INFO_SUPPORTED |
REV_SHARE_FLAGS_ADDED |
REV_SHUTDOWN_SUPPORTED |
SupportedRevs | [read]

Public Static Methods

EqualOrGreater | Return true if the specified server is at a revision level greater than or equal to the specified revision level and dot revision.
IsClientManagedStatus | Returns true if the command revision level provides support for client managed status.

Public Static Type Conversions

Implicit SystemRevisionNumbers to SystemRevisionNumbers Conversion Implicitly convert SystemRevisionNumbers to com.starbase.starteam.vts.comm.SystemRevisionNumbers.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.vts.comm.SystemRevisionNumbers.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.vts.comm.SystemRevisionNumbers.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.vts.comm.SystemRevisionNumbers.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


SystemRevisionNumbers Properties

The properties of the SystemRevisionNumbers class are listed below. For a complete list of SystemRevisionNumbers class members, see the SystemRevisionNumbers Members topic.

Public Static Properties

REV_42 |
REV_CLIENT_STATUS |
REV_CONCURRENT_LICENSES_SUPPORTED |
REV_CORRECTED_REF_MODIFIED_TIME |
REV_FALCON_ADDED_CLIENT_PROPS |
REV_FIRST_5_2_BUILD |
REV_FORWARD_COMPATIBILITY |
REV_GET_SERVER_LOCK |
REV_IDARRAY_STREAMED_AS_INTARRAY |
REV_MODIFIED_CREATE_LINK |
REV_MOVE_FOLDER_DELETE_ABANDONS_VIEWS |
REV_PORTABLE_VTS |
REV_PROTOCOL_TCPIPXML_SUPPORTED |
REV_REPLICATION_SUPPORT |
REV_SECURE_COMMANDS |
REV_SERVER_LICENSE_INFO_SUPPORTED |
REV_SHARE_FLAGS_ADDED |
REV_SHUTDOWN_SUPPORTED |
SupportedRevs | [read]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_42 Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_42 Property

public static Int16 REV_42 {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_CLIENT_STATUS Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_CLIENT_STATUS Property

public static Int16 REV_CLIENT_STATUS {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_CONCURRENT_LICENSES_SUPPORTED Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_CONCURRENT_LICENSES_SUPPORTED Property

public static Int16 REV_CONCURRENT_LICENSES_SUPPORTED {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_CORRECTED_REF_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_CORRECTED_REF_MODIFIED_TIME Property

public static Int16 REV_CORRECTED_REF_MODIFIED_TIME {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_FALCON_ADDED_CLIENT_PROPS Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_FALCON_ADDED_CLIENT_PROPS Property

public static Int16 REV_FALCON_ADDED_CLIENT_PROPS {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_FIRST_5_2_BUILD Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_FIRST_5_2_BUILD Property

public static Int16 REV_FIRST_5_2_BUILD {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_FORWARD_COMPATIBILITY Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_FORWARD_COMPATIBILITY Property

public static Int16 REV_FORWARD_COMPATIBILITY {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_GET_SERVER_LOCK Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_GET_SERVER_LOCK Property

public static Int16 REV_GET_SERVER_LOCK {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_IDARRAY_STREAMED_AS_INTARRAY Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_IDARRAY_STREAMED_AS_INTARRAY Property

public static Int16 REV_IDARRAY_STREAMED_AS_INTARRAY {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_MODIFIED_CREATE_LINK Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_MODIFIED_CREATE_LINK Property

public static Int16 REV_MODIFIED_CREATE_LINK {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_MOVE_FOLDER_DELETE_ABANDONS_VIEWS Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_MOVE_FOLDER_DELETE_ABANDONS_VIEWS Property

public static Int16 REV_MOVE_FOLDER_DELETE_ABANDONS_VIEWS {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_PORTABLE_VTS Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_PORTABLE_VTS Property

public static Int16 REV_PORTABLE_VTS {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_PROTOCOL_TCPIPXML_SUPPORTED Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_PROTOCOL_TCPIPXML_SUPPORTED Property

public static Int16 REV_PROTOCOL_TCPIPXML_SUPPORTED {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_REPLICATION_SUPPORT Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_REPLICATION_SUPPORT Property

public static Int16 REV_REPLICATION_SUPPORT {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_SECURE_COMMANDS Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_SECURE_COMMANDS Property

public static Int16 REV_SECURE_COMMANDS {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_SERVER_LICENSE_INFO_SUPPORTED Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_SERVER_LICENSE_INFO_SUPPORTED Property

public static Int16 REV_SERVER_LICENSE_INFO_SUPPORTED {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_SHARE_FLAGS_ADDED Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_SHARE_FLAGS_ADDED Property

public static Int16 REV_SHARE_FLAGS_ADDED {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


REV_SHUTDOWN_SUPPORTED Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.REV_SHUTDOWN_SUPPORTED Property

public static Int16 REV_SHUTDOWN_SUPPORTED {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


SupportedRevs Property

Borland StarTeam SDK for .NET

SystemRevisionNumbers.SupportedRevs Property

[read]

public static Int16[] SupportedRevs {get;}

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


SystemRevisionNumbers Methods

The methods of the SystemRevisionNumbers class are listed below. For a complete list of SystemRevisionNumbers class members, see the SystemRevisionNumbers Members topic.

Public Static Methods

EqualOrGreater | Return true if the specified server is at a revision level greater than or equal to the specified revision level and dot revision.
IsClientManagedStatus | Returns true if the command revision level provides support for client managed status.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.vts.comm.SystemRevisionNumbers.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.vts.comm.SystemRevisionNumbers.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.vts.comm.SystemRevisionNumbers.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


SystemRevisionNumbers.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.vts.comm.SystemRevisionNumbers

Implements

IWrapper.Unwrap

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


SystemRevisionNumbers.EqualOrGreater Method

Return true if the specified server is at a revision level greater than or equal to the specified revision level and dot revision.

public static bool EqualOrGreater(
Int16 serverRev,
String serverDot,
Int16 revisionLevel,
String dotRevision
);

Parameters

serverRev
the server's revision level
serverDot
the server's dot revision level
revisionLevel
the revision level being tested
dotRevision
the dot revision level being tested

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


SystemRevisionNumbers.Equals Method

Delegate Equals() to com.starbase.starteam.vts.comm.SystemRevisionNumbers.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.vts.comm.SystemRevisionNumbers.Equals(obj).

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


SystemRevisionNumbers.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.vts.comm.SystemRevisionNumbers.

public override int GetHashCode();

Return Value

com.starbase.starteam.vts.comm.SystemRevisionNumbers.GetHashCode().

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


SystemRevisionNumbers.IsClientManagedStatus Method

Returns true if the command revision level provides support for client managed status.

public static bool IsClientManagedStatus(
Int16 nRevisionLevel
);

Parameters

nRevisionLevel
the command revision level to be tested.

Return Value

true if the command revision level provides support for client managed status.

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


SystemRevisionNumbers.ToString Method

Delegate ToString() to com.starbase.starteam.vts.comm.SystemRevisionNumbers.

public override string ToString();

Return Value

com.starbase.starteam.vts.comm.SystemRevisionNumbers.ToString()

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


SystemRevisionNumbers Type Conversions

The type conversions of the SystemRevisionNumbers class are listed below. For a complete list of SystemRevisionNumbers class members, see the SystemRevisionNumbers Members topic.

Public Static Type Conversions

Implicit SystemRevisionNumbers to SystemRevisionNumbers Conversion Implicitly convert SystemRevisionNumbers to com.starbase.starteam.vts.comm.SystemRevisionNumbers.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SystemRevisionNumbers Class | SystemRevisionNumbers Members | Borland.StarTeam Namespace


SystemRevisionNumbers Implicit SystemRevisionNumbers to SystemRevisionNumbers Conversion

Implicitly convert SystemRevisionNumbers to com.starbase.starteam.vts.comm.SystemRevisionNumbers.

public static implicit operator SystemRevisionNumbers(
SystemRevisionNumbers arg
);

Parameters

arg
SystemRevisionNumbers to convert.

Return Value

com.starbase.starteam.vts.comm.SystemRevisionNumbers

See Also

SystemRevisionNumbers Class | Borland.StarTeam Namespace


Task Class

Represents a StarTeam Task item.

For a list of all members of this type, see Task Members.

System.Object
TypedResource
SimpleTypedResource
Item
TreeItem
Task

public class Task : TreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Task Members | Borland.StarTeam Namespace


Task Members

Task overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Task.

Public Static Type Conversions

Implicit Task to Task Conversion Implicitly convert Task to com.starbase.starteam.Task.

Public Instance Constructors

Task Overloaded. Initializes a new instance of the Task class.

Public Instance Properties

ACL (inherited from Item) |
ActualFinish | [read] The actual finish date of this task.
ActualHours | [read] The actual number of hours spent on this task.
ActualStart | [read] The actual start date of this task.
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
AttentionNotes | [read/write] The text in the "Needs Attention" note for this task.
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
ChildrenCount | [read] The number of tasks that are subtasks of this one.
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
ConstraintDate | [read] The task's Constraint Date from MS Project.
ConstraintType | [read] The MS Project Constraint Type of this task.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
DependencyLastUpdate | [read] The date that a work record or task dependency (predecessor or successor) was last added to this task.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
Duration | [read/write] The number of hours during which at least one user is working on this task.
EstimatedFinish | [read/write] The estimated date at which this task will be completed.
EstimatedFinishVariance | [read] The Estimated Finish Variance of this task.
EstimatedHours | [read] An estimate of the number of hours that will be spent completing this task.
EstimatedHoursVariance | [read] The Estimated Hours Variance of this task.
EstimatedStart | [read/write] The estimated start date of this task.
EstimatedStartVariance | [read] The Estimated Start Variance of this task.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
GUID | [read] The MS Project GUID of this task.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsMyTask | [read] A value indicating whether the logged on user is responsible for this task.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsProcessTask | [read] true if this task is a process task; false otherwise.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsReplicated | [read/write] true if this task is replicated in MS Project.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
Milestone | [read/write] A value indicating whether or not this task represents a milestone.
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MSProjectFileName | [read] The MS Project FileName of this task.
MSProjectLastUpdate | [read] The date that this task was last updated from MS Project.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
Name | [read/write] The Name of this task.
NeedsAttention | [read/write] A value that indicates whether or not this task needs attention.
NewRevisionComment (inherited from Item) | [read] the empty string.
Notes | [read/write] The text in the "Notes" for this task.
Number | [read] The number assigned to this task.
ObjectID (inherited from Item) | [read] The object ID for this item.
Origin | [read/write] A value indicating the origin (e.g., StarTeam or MS Project) of this task.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
PercentComplete | [read/write] A percentage indicating how much of the task has been completed.
PossibleConstraintType | [read] The possible values for the ConstraintType property.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossibleIsMyTask | [read] The possible values for the IsMyTask property.
PossibleMilestone | [read] The possible values for the Milestone property.
PossibleNeedsAttention | [read] The possible values for the NeedsAttention property.
PossibleOrigin | [read] The possible values for the Origin property.
PossiblePriority | [read] The possible values for the Priority property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PossibleStatus | [read] The possible values for the Status property.
PossibleTaskType | [read] The possible values for the TaskType property.
PredecessorLinks | [read] The predecessor tasks to this this task.
Priority | [read/write] The Priority of this task.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
ResourceCount | [read] The number of resources assigned to this task.
ResourceNames | [read] The names of the users assigned as resources of this task.
Resources | [read] The IDs of the users assigned as resources of this task.
Responsibility | [read/write] The user ID of the user who is responsibile for this task.
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Status | [read/write] The Status of this task.
SuccessorLinks | [read] The successor tasks to this this task.
TaskType | [read] The task's type in MS Project.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
UniqueID | [read] The MS Project UniqueID of this task.
Usage | [read/write] The task usage. The usage determines whether or not this is a process task and, if so, the type of operation that created the task and its process links.
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.
WBSCode | [read] The MS Project WBS Code of this task.
WorkRecordCount | [read] The number of work records that have been added to this task.
WorkRecords | [read] The work records associates with this task.

Public Instance Methods

AcquireOwnership (inherited from Item)
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddPredecessorLink | Adds a new predecessor to this task.
AddResource | Adds the specified user ID as a resource for this Task.
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
AddWorkRecord | Adds a work record to this task.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateChild (inherited from TreeItem) | Creates a new child item.
CreateWorkRecord | Creates a new WorkRecord for the specified Task and user.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetConstraintTypeDisplayName | Returns a user-friendly display name for the given ConstraintType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetIsMyTaskDisplayName | Returns a user-friendly display name for the given IsMyTask value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetMilestoneDisplayName | Returns a user-friendly display name for the given Milestone value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetNeedsAttentionDisplayName | Returns a user-friendly display name for the given NeedsAttention value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetOriginDisplayName | Returns a user-friendly display name for the given Origin value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPriorityDisplayName | Returns a user-friendly display name for the given Priority value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetStatusDisplayName | Returns a user-friendly display name for the given Status value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetTaskTypeDisplayName | Returns a user-friendly display name for the given TaskType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified parent. Child items, if any, are also moved.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveDependency | Removed the specified task dependency from this task. The dependency must be either a successor or predecessor to this task or an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveResource | Removes the specified user ID as a resource from this task.
RemoveWorkRecord | Removes the work record from this task. The work record must already be associated with this task or an exception will be thrown.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Task Class | Borland.StarTeam Namespace


Task Constructor

Construct Task from com.starbase.starteam.Task.

Overload List

Creates a new task in the specified folder.

public Task(Folder);

Creates a new task that is a subtask of an existing task.

public Task(Task);

Construct Task from com.starbase.starteam.Task.

public Task(Task);

See Also

Task Class | Borland.StarTeam Namespace


Task Constructor (Task)

Construct Task from com.starbase.starteam.Task.

public Task(
Task impl
);

Parameters

impl
The com.starbase.starteam.Task to be wrapped.

See Also

Task Class | Borland.StarTeam Namespace | Task Constructor Overload List


Task Constructor (Folder)

Creates a new task in the specified folder.

public Task(
Folder parentFolder
);

Parameters

parentFolder
The folder to which this new task will be added.

See Also

Task Class | Borland.StarTeam Namespace | Task Constructor Overload List


Task Constructor (Task)

Creates a new task that is a subtask of an existing task.

public Task(
Task parentTask
);

Parameters

parentTask
The parent task.

See Also

Task Class | Borland.StarTeam Namespace | Task Constructor Overload List


Task Properties

The properties of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Instance Properties

ACL (inherited from Item) |
ActualFinish | [read] The actual finish date of this task.
ActualHours | [read] The actual number of hours spent on this task.
ActualStart | [read] The actual start date of this task.
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
AttentionNotes | [read/write] The text in the "Needs Attention" note for this task.
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
ChildrenCount | [read] The number of tasks that are subtasks of this one.
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
ConstraintDate | [read] The task's Constraint Date from MS Project.
ConstraintType | [read] The MS Project Constraint Type of this task.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
DependencyLastUpdate | [read] The date that a work record or task dependency (predecessor or successor) was last added to this task.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
Duration | [read/write] The number of hours during which at least one user is working on this task.
EstimatedFinish | [read/write] The estimated date at which this task will be completed.
EstimatedFinishVariance | [read] The Estimated Finish Variance of this task.
EstimatedHours | [read] An estimate of the number of hours that will be spent completing this task.
EstimatedHoursVariance | [read] The Estimated Hours Variance of this task.
EstimatedStart | [read/write] The estimated start date of this task.
EstimatedStartVariance | [read] The Estimated Start Variance of this task.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
GUID | [read] The MS Project GUID of this task.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsMyTask | [read] A value indicating whether the logged on user is responsible for this task.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsProcessTask | [read] true if this task is a process task; false otherwise.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsReplicated | [read/write] true if this task is replicated in MS Project.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
Milestone | [read/write] A value indicating whether or not this task represents a milestone.
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MSProjectFileName | [read] The MS Project FileName of this task.
MSProjectLastUpdate | [read] The date that this task was last updated from MS Project.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
Name | [read/write] The Name of this task.
NeedsAttention | [read/write] A value that indicates whether or not this task needs attention.
NewRevisionComment (inherited from Item) | [read] the empty string.
Notes | [read/write] The text in the "Notes" for this task.
Number | [read] The number assigned to this task.
ObjectID (inherited from Item) | [read] The object ID for this item.
Origin | [read/write] A value indicating the origin (e.g., StarTeam or MS Project) of this task.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
PercentComplete | [read/write] A percentage indicating how much of the task has been completed.
PossibleConstraintType | [read] The possible values for the ConstraintType property.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossibleIsMyTask | [read] The possible values for the IsMyTask property.
PossibleMilestone | [read] The possible values for the Milestone property.
PossibleNeedsAttention | [read] The possible values for the NeedsAttention property.
PossibleOrigin | [read] The possible values for the Origin property.
PossiblePriority | [read] The possible values for the Priority property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PossibleStatus | [read] The possible values for the Status property.
PossibleTaskType | [read] The possible values for the TaskType property.
PredecessorLinks | [read] The predecessor tasks to this this task.
Priority | [read/write] The Priority of this task.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
ResourceCount | [read] The number of resources assigned to this task.
ResourceNames | [read] The names of the users assigned as resources of this task.
Resources | [read] The IDs of the users assigned as resources of this task.
Responsibility | [read/write] The user ID of the user who is responsibile for this task.
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Status | [read/write] The Status of this task.
SuccessorLinks | [read] The successor tasks to this this task.
TaskType | [read] The task's type in MS Project.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
UniqueID | [read] The MS Project UniqueID of this task.
Usage | [read/write] The task usage. The usage determines whether or not this is a process task and, if so, the type of operation that created the task and its process links.
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.
WBSCode | [read] The MS Project WBS Code of this task.
WorkRecordCount | [read] The number of work records that have been added to this task.
WorkRecords | [read] The work records associates with this task.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Task Class | Borland.StarTeam Namespace


ActualFinish Property

Borland StarTeam SDK for .NET

Task.ActualFinish Property

[read] The actual finish date of this task.

public virtual DateTime ActualFinish {get;}

Property Value

The actual finish date of this task.

See Also

Task Class | Borland.StarTeam Namespace


ActualHours Property

Borland StarTeam SDK for .NET

Task.ActualHours Property

[read] The actual number of hours spent on this task.

public virtual Double ActualHours {get;}

Property Value

The actual number of hours spent on this task.

See Also

Task Class | Borland.StarTeam Namespace


ActualStart Property

Borland StarTeam SDK for .NET

Task.ActualStart Property

[read] The actual start date of this task.

public virtual DateTime ActualStart {get;}

Property Value

The actual start date of this task.

See Also

Task Class | Borland.StarTeam Namespace


AttentionNotes Property

Borland StarTeam SDK for .NET

Task.AttentionNotes Property

[read/write] The text in the "Needs Attention" note for this task.

public virtual String AttentionNotes {get; set;}

Property Value

The text in the "Needs Attention" note for this task.

See Also

Task Class | Borland.StarTeam Namespace


ChildrenCount Property

Borland StarTeam SDK for .NET

Task.ChildrenCount Property

[read] The number of tasks that are subtasks of this one.

public virtual Int32 ChildrenCount {get;}

Property Value

The number of tasks that are subtasks of this one.

See Also

Task Class | Borland.StarTeam Namespace


ConstraintDate Property

Borland StarTeam SDK for .NET

Task.ConstraintDate Property

[read] The task's Constraint Date from MS Project.

public virtual DateTime ConstraintDate {get;}

Property Value

The task's Constraint Date from MS Project.

See Also

Task Class | Borland.StarTeam Namespace


ConstraintType Property

Borland StarTeam SDK for .NET

Task.ConstraintType Property

[read] The MS Project Constraint Type of this task.

public virtual Int32 ConstraintType {get;}

Property Value

The MS Project Constraint Type of this task.

See Also

Task Class | Borland.StarTeam Namespace


DependencyLastUpdate Property

Borland StarTeam SDK for .NET

Task.DependencyLastUpdate Property

[read] The date that a work record or task dependency (predecessor or successor) was last added to this task.

public virtual DateTime DependencyLastUpdate {get;}

Property Value

The date that a work record or task dependency (predecessor or successor) was last added to this task.

See Also

Task Class | Borland.StarTeam Namespace


Duration Property

Borland StarTeam SDK for .NET

Task.Duration Property

[read/write] The number of hours during which at least one user is working on this task.

public virtual Double Duration {get; set;}

Property Value

The number of hours during which at least one user is working on this task.

See Also

Task Class | Borland.StarTeam Namespace


EstimatedFinish Property

Borland StarTeam SDK for .NET

Task.EstimatedFinish Property

[read/write] The estimated date at which this task will be completed.

public virtual DateTime EstimatedFinish {get; set;}

Property Value

The estimated date at which this task will be completed.

See Also

Task Class | Borland.StarTeam Namespace


EstimatedFinishVariance Property

Borland StarTeam SDK for .NET

Task.EstimatedFinishVariance Property

[read] The Estimated Finish Variance of this task.

public virtual Int32 EstimatedFinishVariance {get;}

Property Value

The Estimated Finish Variance of this task.

See Also

Task Class | Borland.StarTeam Namespace


EstimatedHours Property

Borland StarTeam SDK for .NET

Task.EstimatedHours Property

[read] An estimate of the number of hours that will be spent completing this task.

public virtual Double EstimatedHours {get;}

Property Value

An estimate of the number of hours that will be spent completing this task.

See Also

Task Class | Borland.StarTeam Namespace


EstimatedHoursVariance Property

Borland StarTeam SDK for .NET

Task.EstimatedHoursVariance Property

[read] The Estimated Hours Variance of this task.

public virtual Double EstimatedHoursVariance {get;}

Property Value

The Estimated Hours Variance of this task.

See Also

Task Class | Borland.StarTeam Namespace


EstimatedStart Property

Borland StarTeam SDK for .NET

Task.EstimatedStart Property

[read/write] The estimated start date of this task.

public virtual DateTime EstimatedStart {get; set;}

Property Value

The estimated start date of this task.

See Also

Task Class | Borland.StarTeam Namespace


EstimatedStartVariance Property

Borland StarTeam SDK for .NET

Task.EstimatedStartVariance Property

[read] The Estimated Start Variance of this task.

public virtual Int32 EstimatedStartVariance {get;}

Property Value

The Estimated Start Variance of this task.

See Also

Task Class | Borland.StarTeam Namespace


GUID Property

Borland StarTeam SDK for .NET

Task.GUID Property

[read] The MS Project GUID of this task.

public virtual String GUID {get;}

Property Value

The MS Project GUID of this task.

See Also

Task Class | Borland.StarTeam Namespace


IsMyTask Property

Borland StarTeam SDK for .NET

Task.IsMyTask Property

[read] A value indicating whether the logged on user is responsible for this task.

public virtual Int32 IsMyTask {get;}

Property Value

A value indicating whether the logged on user is responsible for this task.

See Also

Task Class | Borland.StarTeam Namespace


IsProcessTask Property

Borland StarTeam SDK for .NET

Task.IsProcessTask Property

[read] true if this task is a process task; false otherwise.

public virtual Boolean IsProcessTask {get;}

Property Value

true if this task is a process task; false otherwise.

See Also

Task Class | Borland.StarTeam Namespace


IsReplicated Property

Borland StarTeam SDK for .NET

Task.IsReplicated Property

[read/write] true if this task is replicated in MS Project.

public virtual Boolean IsReplicated {get; set;}

Property Value

true if this task is replicated in MS Project.

See Also

Task Class | Borland.StarTeam Namespace


Milestone Property

Borland StarTeam SDK for .NET

Task.Milestone Property

[read/write] A value indicating whether or not this task represents a milestone.

public virtual Int32 Milestone {get; set;}

Property Value

A value indicating whether or not this task represents a milestone.

See Also

Task Class | Borland.StarTeam Namespace


MSProjectFileName Property

Borland StarTeam SDK for .NET

Task.MSProjectFileName Property

[read] The MS Project FileName of this task.

public virtual String MSProjectFileName {get;}

Property Value

The MS Project FileName of this task.

See Also

Task Class | Borland.StarTeam Namespace


MSProjectLastUpdate Property

Borland StarTeam SDK for .NET

Task.MSProjectLastUpdate Property

[read] The date that this task was last updated from MS Project.

public virtual DateTime MSProjectLastUpdate {get;}

Property Value

The date that this task was last updated from MS Project.

See Also

Task Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Task.Name Property

[read/write] The Name of this task.

public virtual String Name {get; set;}

Property Value

The Name of this task.

See Also

Task Class | Borland.StarTeam Namespace


NeedsAttention Property

Borland StarTeam SDK for .NET

Task.NeedsAttention Property

[read/write] A value that indicates whether or not this task needs attention.

public virtual Int32 NeedsAttention {get; set;}

Property Value

A value that indicates whether or not this task needs attention.

See Also

Task Class | Borland.StarTeam Namespace


Notes Property

Borland StarTeam SDK for .NET

Task.Notes Property

[read/write] The text in the "Notes" for this task.

public virtual String Notes {get; set;}

Property Value

The text in the "Notes" for this task.

See Also

Task Class | Borland.StarTeam Namespace


Number Property

Borland StarTeam SDK for .NET

Task.Number Property

[read] The number assigned to this task.

public virtual Int32 Number {get;}

Property Value

The number assigned to this task.

See Also

Task Class | Borland.StarTeam Namespace


Origin Property

Borland StarTeam SDK for .NET

Task.Origin Property

[read/write] A value indicating the origin (e.g., StarTeam or MS Project) of this task.

public virtual Int32 Origin {get; set;}

Property Value

A value indicating the origin (e.g., StarTeam or MS Project) of this task.

See Also

Task Class | Borland.StarTeam Namespace


PercentComplete Property

Borland StarTeam SDK for .NET

Task.PercentComplete Property

[read/write] A percentage indicating how much of the task has been completed.

public virtual Int32 PercentComplete {get; set;}

Property Value

A percentage indicating how much of the task has been completed.

See Also

Task Class | Borland.StarTeam Namespace


PossibleConstraintType Property

Borland StarTeam SDK for .NET

Task.PossibleConstraintType Property

[read] The possible values for the ConstraintType property.

public virtual Int32[] PossibleConstraintType {get;}

Property Value

The possible values for the ConstraintType property.

See Also

Task Class | Borland.StarTeam Namespace


PossibleIsMyTask Property

Borland StarTeam SDK for .NET

Task.PossibleIsMyTask Property

[read] The possible values for the IsMyTask property.

public virtual Int32[] PossibleIsMyTask {get;}

Property Value

The possible values for the IsMyTask property.

See Also

Task Class | Borland.StarTeam Namespace


PossibleMilestone Property

Borland StarTeam SDK for .NET

Task.PossibleMilestone Property

[read] The possible values for the Milestone property.

public virtual Int32[] PossibleMilestone {get;}

Property Value

The possible values for the Milestone property.

See Also

Task Class | Borland.StarTeam Namespace


PossibleNeedsAttention Property

Borland StarTeam SDK for .NET

Task.PossibleNeedsAttention Property

[read] The possible values for the NeedsAttention property.

public virtual Int32[] PossibleNeedsAttention {get;}

Property Value

The possible values for the NeedsAttention property.

See Also

Task Class | Borland.StarTeam Namespace


PossibleOrigin Property

Borland StarTeam SDK for .NET

Task.PossibleOrigin Property

[read] The possible values for the Origin property.

public virtual Int32[] PossibleOrigin {get;}

Property Value

The possible values for the Origin property.

See Also

Task Class | Borland.StarTeam Namespace


PossiblePriority Property

Borland StarTeam SDK for .NET

Task.PossiblePriority Property

[read] The possible values for the Priority property.

public virtual Int32[] PossiblePriority {get;}

Property Value

The possible values for the Priority property.

See Also

Task Class | Borland.StarTeam Namespace


PossibleStatus Property

Borland StarTeam SDK for .NET

Task.PossibleStatus Property

[read] The possible values for the Status property.

public virtual Int32[] PossibleStatus {get;}

Property Value

The possible values for the Status property.

See Also

Task Class | Borland.StarTeam Namespace


PossibleTaskType Property

Borland StarTeam SDK for .NET

Task.PossibleTaskType Property

[read] The possible values for the TaskType property.

public virtual Int32[] PossibleTaskType {get;}

Property Value

The possible values for the TaskType property.

See Also

Task Class | Borland.StarTeam Namespace


PredecessorLinks Property

Borland StarTeam SDK for .NET

Task.PredecessorLinks Property

[read] The predecessor tasks to this this task.

public virtual TaskDependencyCollection PredecessorLinks {get;}

Property Value

The predecessor tasks to this this task.

See Also

Task Class | Borland.StarTeam Namespace


Priority Property

Borland StarTeam SDK for .NET

Task.Priority Property

[read/write] The Priority of this task.

public virtual Int32 Priority {get; set;}

Property Value

The Priority of this task.

See Also

Task Class | Borland.StarTeam Namespace


ResourceCount Property

Borland StarTeam SDK for .NET

Task.ResourceCount Property

[read] The number of resources assigned to this task.

public virtual Int32 ResourceCount {get;}

Property Value

The number of resources assigned to this task.

See Also

Task Class | Borland.StarTeam Namespace


ResourceNames Property

Borland StarTeam SDK for .NET

Task.ResourceNames Property

[read] The names of the users assigned as resources of this task.

public virtual String[] ResourceNames {get;}

Property Value

The names of the users assigned as resources of this task.

See Also

Task Class | Borland.StarTeam Namespace


Resources Property

Borland StarTeam SDK for .NET

Task.Resources Property

[read] The IDs of the users assigned as resources of this task.

public virtual Int32[] Resources {get;}

Property Value

The IDs of the users assigned as resources of this task.

See Also

Task Class | Borland.StarTeam Namespace


Responsibility Property

Borland StarTeam SDK for .NET

Task.Responsibility Property

[read/write] The user ID of the user who is responsibile for this task.

public virtual Int32 Responsibility {get; set;}

Property Value

The user ID of the user who is responsibile for this task.

See Also

Task Class | Borland.StarTeam Namespace


Status Property

Borland StarTeam SDK for .NET

Task.Status Property

[read/write] The Status of this task.

public virtual Int32 Status {get; set;}

Property Value

The Status of this task.

See Also

Task Class | Borland.StarTeam Namespace


SuccessorLinks Property

Borland StarTeam SDK for .NET

Task.SuccessorLinks Property

[read] The successor tasks to this this task.

public virtual TaskDependencyCollection SuccessorLinks {get;}

Property Value

The successor tasks to this this task.

See Also

Task Class | Borland.StarTeam Namespace


TaskType Property

Borland StarTeam SDK for .NET

Task.TaskType Property

[read] The task's type in MS Project.

public virtual Int32 TaskType {get;}

Property Value

The task's type in MS Project.

See Also

Task Class | Borland.StarTeam Namespace


UniqueID Property

Borland StarTeam SDK for .NET

Task.UniqueID Property

[read] The MS Project UniqueID of this task.

public virtual Int32 UniqueID {get;}

Property Value

The MS Project UniqueID of this task.

See Also

Task Class | Borland.StarTeam Namespace


Usage Property

Borland StarTeam SDK for .NET

Task.Usage Property

[read/write] The task usage. The usage determines whether or not this is a process task and, if so, the type of operation that created the task and its process links.

public virtual ProcessItemUsage Usage {get; set;}

Property Value

The task usage. The usage determines whether or not this is a process task and, if so, the type of operation that created the task and its process links.

See Also

Task Class | Borland.StarTeam Namespace


WBSCode Property

Borland StarTeam SDK for .NET

Task.WBSCode Property

[read] The MS Project WBS Code of this task.

public virtual String WBSCode {get;}

Property Value

The MS Project WBS Code of this task.

See Also

Task Class | Borland.StarTeam Namespace


WorkRecordCount Property

Borland StarTeam SDK for .NET

Task.WorkRecordCount Property

[read] The number of work records that have been added to this task.

public virtual Int32 WorkRecordCount {get;}

Property Value

The number of work records that have been added to this task.

See Also

Task Class | Borland.StarTeam Namespace


WorkRecords Property

Borland StarTeam SDK for .NET

Task.WorkRecords Property

[read] The work records associates with this task.

public virtual WorkRecordCollection WorkRecords {get;}

Property Value

The work records associates with this task.

See Also

Task Class | Borland.StarTeam Namespace


Task Methods

The methods of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Task.

Public Instance Methods

AcquireOwnership (inherited from Item)
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddPredecessorLink | Adds a new predecessor to this task.
AddResource | Adds the specified user ID as a resource for this Task.
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
AddWorkRecord | Adds a work record to this task.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateChild (inherited from TreeItem) | Creates a new child item.
CreateWorkRecord | Creates a new WorkRecord for the specified Task and user.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetConstraintTypeDisplayName | Returns a user-friendly display name for the given ConstraintType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetIsMyTaskDisplayName | Returns a user-friendly display name for the given IsMyTask value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetMilestoneDisplayName | Returns a user-friendly display name for the given Milestone value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetNeedsAttentionDisplayName | Returns a user-friendly display name for the given NeedsAttention value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetOriginDisplayName | Returns a user-friendly display name for the given Origin value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPriorityDisplayName | Returns a user-friendly display name for the given Priority value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetStatusDisplayName | Returns a user-friendly display name for the given Status value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetTaskTypeDisplayName | Returns a user-friendly display name for the given TaskType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified parent. Child items, if any, are also moved.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveDependency | Removed the specified task dependency from this task. The dependency must be either a successor or predecessor to this task or an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveResource | Removes the specified user ID as a resource from this task.
RemoveWorkRecord | Removes the work record from this task. The work record must already be associated with this task or an exception will be thrown.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Task Class | Borland.StarTeam Namespace


Task.AddPredecessorLink Method

Adds a new predecessor to this task.

public virtual void AddPredecessorLink(
Int32 predecessorID,
Int32 lagTime,
Int32 depType
);

Parameters

predecessorID
the task id of the predecessor task
lagTime
the lag time for this dependency
depType
the dependency type.

See Also

Task Class | Borland.StarTeam Namespace | TASKDEPENDENCY_TYPE


Task.AddResource Method

Adds the specified user ID as a resource for this Task.

public virtual void AddResource(
Int32 userID
);

Parameters

userID
the user ID to add as a resource for this task,

See Also

Task Class | Borland.StarTeam Namespace


Task.AddWorkRecord Method

Adds a work record to this task.

public virtual void AddWorkRecord(
WorkRecord record
);

Parameters

record
the work record to be added

See Also

Task Class | Borland.StarTeam Namespace | createWorkRecord


Task.CreateWorkRecord Method

Creates a new WorkRecord for the specified Task and user.

public virtual WorkRecord CreateWorkRecord(
User user
);

Parameters

user
the the user that performs the work

See Also

Task Class | Borland.StarTeam Namespace


Task.GetConstraintTypeDisplayName Method

Returns a user-friendly display name for the given ConstraintType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetConstraintTypeDisplayName(
Int32 value
);

Parameters

value
The ConstraintType value to be converted to a display name.

Return Value

A user-friendly display name for the given ConstraintType value.

See Also

Task Class | Borland.StarTeam Namespace | getConstraintType | getPossibleConstraintType | getEnumDisplayName | TASK_CONSTRAINT_TYPE


Task.GetIsMyTaskDisplayName Method

Returns a user-friendly display name for the given IsMyTask value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetIsMyTaskDisplayName(
Int32 value
);

Parameters

value
The IsMyTask value to be converted to a display name.

Return Value

A user-friendly display name for the given IsMyTask value.

See Also

Task Class | Borland.StarTeam Namespace | getIsMyTask | getPossibleIsMyTask | getEnumDisplayName | TASK_IS_MY_TASK


Task.GetMilestoneDisplayName Method

Returns a user-friendly display name for the given Milestone value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetMilestoneDisplayName(
Int32 value
);

Parameters

value
The Milestone value to be converted to a display name.

Return Value

A user-friendly display name for the given Milestone value.

See Also

Task Class | Borland.StarTeam Namespace | getMilestone | getPossibleMilestone | getEnumDisplayName | TASK_MILESTONE


Task.GetNeedsAttentionDisplayName Method

Returns a user-friendly display name for the given NeedsAttention value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetNeedsAttentionDisplayName(
Int32 value
);

Parameters

value
The NeedsAttention value to be converted to a display name.

Return Value

A user-friendly display name for the given NeedsAttention value.

See Also

Task Class | Borland.StarTeam Namespace | getNeedsAttention | getPossibleNeedsAttention | getEnumDisplayName | TASK_NEEDS_ATTENTION


Task.GetOriginDisplayName Method

Returns a user-friendly display name for the given Origin value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetOriginDisplayName(
Int32 value
);

Parameters

value
The Origin value to be converted to a display name.

Return Value

A user-friendly display name for the given Origin value.

See Also

Task Class | Borland.StarTeam Namespace | getOrigin | getPossibleOrigin | getEnumDisplayName | TASK_ORIGIN


Task.GetPriorityDisplayName Method

Returns a user-friendly display name for the given Priority value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetPriorityDisplayName(
Int32 value
);

Parameters

value
The Priority value to be converted to a display name.

Return Value

A user-friendly display name for the given Priority value.

See Also

Task Class | Borland.StarTeam Namespace | getPriority | getPossiblePriority | getEnumDisplayName | TASK_PRIORITY


Task.GetStatusDisplayName Method

Returns a user-friendly display name for the given Status value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetStatusDisplayName(
Int32 value
);

Parameters

value
The Status value to be converted to a display name.

Return Value

A user-friendly display name for the given Status value.

See Also

Task Class | Borland.StarTeam Namespace | getStatus | getPossibleStatus | getEnumDisplayName | TASK_STATUS


Task.GetTaskTypeDisplayName Method

Returns a user-friendly display name for the given TaskType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetTaskTypeDisplayName(
Int32 value
);

Parameters

value
The TaskType value to be converted to a display name.

Return Value

A user-friendly display name for the given TaskType value.

See Also

Task Class | Borland.StarTeam Namespace | getTaskType | getPossibleTaskType | getEnumDisplayName | TASK_TYPE


Task.RemoveDependency Method

Removed the specified task dependency from this task. The dependency must be either a successor or predecessor to this task or an exception will be thrown.

public virtual void RemoveDependency(
TaskDependency dependency
);

Parameters

dependency
the task depenency to remove

See Also

Task Class | Borland.StarTeam Namespace


Task.RemoveResource Method

Removes the specified user ID as a resource from this task.

public virtual void RemoveResource(
Int32 userID
);

Parameters

userID
the user ID resource to remove from this task.

See Also

Task Class | Borland.StarTeam Namespace


Task.RemoveWorkRecord Method

Removes the work record from this task. The work record must already be associated with this task or an exception will be thrown.

public virtual void RemoveWorkRecord(
WorkRecord record
);

Parameters

record
the work record to be removed.

See Also

Task Class | Borland.StarTeam Namespace


Task.Wrap Method

Dynamically wraps com.starbase.starteam.Task.

public static Task Wrap(
Task impl
);

Parameters

impl
com.starbase.starteam.Task to be wrapped.

Return Value

Task

See Also

Task Class | Borland.StarTeam Namespace


Task Type Conversions

The type conversions of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Static Type Conversions

Implicit Task to Task Conversion Implicitly convert Task to com.starbase.starteam.Task.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Task Class | Task Members | Borland.StarTeam Namespace


Task Implicit Task to Task Conversion

Implicitly convert Task to com.starbase.starteam.Task.

public static implicit operator Task(
Task arg
);

Parameters

arg
Task to convert.

Return Value

com.starbase.starteam.Task

See Also

Task Class | Borland.StarTeam Namespace


TaskDependency Class

This is a class representing a dependency between two tasks.

For a list of all members of this type, see TaskDependency Members.

System.Object
TypedResource
SimpleTypedResource
TaskDependency

public class TaskDependency : SimpleTypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

TaskDependency Members | Borland.StarTeam Namespace


TaskDependency Members

TaskDependency overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.TaskDependency.

Public Static Type Conversions

Implicit TaskDependency to TaskDependency Conversion Implicitly convert TaskDependency to com.starbase.starteam.TaskDependency.

Public Instance Constructors

TaskDependency Constructor Construct TaskDependency from com.starbase.starteam.TaskDependency.

Public Instance Properties

ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsDirty | [read] true if this task dependency has been modified but not yet saved.
Item (inherited from TypedResource) |
LagTime | [read/write] the lag time for this task dependency.
PossiblePredecessorType | [read] the possible values for the PredecessorType property.
PredecessorID | [read] The ObjectID of the predecessor Task.
PredecessorType | [read/write] the PredecessorType of this task dependency.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
TaskID | [read] The ObjectID of the successor Task.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.

Public Instance Methods

AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPredecessorTypeDisplayName | Returns a user-friendly display name for the given PredecessorType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

TaskDependency Class | Borland.StarTeam Namespace


TaskDependency Constructor

Construct TaskDependency from com.starbase.starteam.TaskDependency.

public TaskDependency(
TaskDependency impl
);

Parameters

impl
The com.starbase.starteam.TaskDependency to be wrapped.

See Also

TaskDependency Class | Borland.StarTeam Namespace


TaskDependency Properties

The properties of the TaskDependency class are listed below. For a complete list of TaskDependency class members, see the TaskDependency Members topic.

Public Instance Properties

ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsDirty | [read] true if this task dependency has been modified but not yet saved.
Item (inherited from TypedResource) |
LagTime | [read/write] the lag time for this task dependency.
PossiblePredecessorType | [read] the possible values for the PredecessorType property.
PredecessorID | [read] The ObjectID of the predecessor Task.
PredecessorType | [read/write] the PredecessorType of this task dependency.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
TaskID | [read] The ObjectID of the successor Task.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

TaskDependency Class | Borland.StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

TaskDependency.IsDirty Property

[read] true if this task dependency has been modified but not yet saved.

public virtual Boolean IsDirty {get;}

Property Value

true if this task dependency has been modified but not yet saved.

See Also

TaskDependency Class | Borland.StarTeam Namespace


LagTime Property

Borland StarTeam SDK for .NET

TaskDependency.LagTime Property

[read/write] the lag time for this task dependency.

public virtual Int32 LagTime {get; set;}

Property Value

the lag time for this task dependency.

See Also

TaskDependency Class | Borland.StarTeam Namespace


PossiblePredecessorType Property

Borland StarTeam SDK for .NET

TaskDependency.PossiblePredecessorType Property

[read] the possible values for the PredecessorType property.

public virtual Int32[] PossiblePredecessorType {get;}

Property Value

the possible values for the PredecessorType property.

See Also

TaskDependency Class | Borland.StarTeam Namespace


PredecessorID Property

Borland StarTeam SDK for .NET

TaskDependency.PredecessorID Property

[read] The ObjectID of the predecessor Task.

public virtual Int32 PredecessorID {get;}

Property Value

The ObjectID of the predecessor Task.

See Also

TaskDependency Class | Borland.StarTeam Namespace


PredecessorType Property

Borland StarTeam SDK for .NET

TaskDependency.PredecessorType Property

[read/write] the PredecessorType of this task dependency.

public virtual Int32 PredecessorType {get; set;}

Property Value

the PredecessorType of this task dependency.

See Also

TaskDependency Class | Borland.StarTeam Namespace


TaskID Property

Borland StarTeam SDK for .NET

TaskDependency.TaskID Property

[read] The ObjectID of the successor Task.

public virtual Int32 TaskID {get;}

Property Value

The ObjectID of the successor Task.

See Also

TaskDependency Class | Borland.StarTeam Namespace


TaskDependency Methods

The methods of the TaskDependency class are listed below. For a complete list of TaskDependency class members, see the TaskDependency Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.TaskDependency.

Public Instance Methods

AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPredecessorTypeDisplayName | Returns a user-friendly display name for the given PredecessorType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

TaskDependency Class | Borland.StarTeam Namespace


TaskDependency.GetPredecessorTypeDisplayName Method

Returns a user-friendly display name for the given PredecessorType value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetPredecessorTypeDisplayName(
Int32 value
);

Parameters

value

Return Value

a user-friendly display name for the given PredecessorType value.

See Also

TaskDependency Class | Borland.StarTeam Namespace | getPredecessorType | getPossiblePredecessorType | getEnumDisplayName | TASKDEPENDENCY_TYPE


TaskDependency.Wrap Method

Dynamically wraps com.starbase.starteam.TaskDependency.

public static TaskDependency Wrap(
TaskDependency impl
);

Parameters

impl
com.starbase.starteam.TaskDependency to be wrapped.

Return Value

TaskDependency

See Also

TaskDependency Class | Borland.StarTeam Namespace


TaskDependency Type Conversions

The type conversions of the TaskDependency class are listed below. For a complete list of TaskDependency class members, see the TaskDependency Members topic.

Public Static Type Conversions

Implicit TaskDependency to TaskDependency Conversion Implicitly convert TaskDependency to com.starbase.starteam.TaskDependency.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

TaskDependency Class | TaskDependency Members | Borland.StarTeam Namespace


TaskDependency Implicit TaskDependency to TaskDependency Conversion

Implicitly convert TaskDependency to com.starbase.starteam.TaskDependency.

public static implicit operator TaskDependency(
TaskDependency arg
);

Parameters

arg
TaskDependency to convert.

Return Value

com.starbase.starteam.TaskDependency

See Also

TaskDependency Class | Borland.StarTeam Namespace


TaskDependencyCollection Class

A strongly-typed collection of TaskDependencys.

For a list of all members of this type, see TaskDependencyCollection Members.

System.Object
ArrayAdapter
TaskDependencyCollection

public class TaskDependencyCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

TaskDependencyCollection Members | Borland.StarTeam Namespace


TaskDependencyCollection Members

TaskDependencyCollection overview

Public Static Methods

Wrap Creates a TaskDependencyCollection to represent the given array of TaskDependency (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit TaskDependencyCollection to TaskDependency[] Conversion | Converts a TaskDependencyCollection to an array of TaskDependencys.
Implicit TaskDependencyCollection to TaskDependency[] Conversion | Converts a TaskDependencyCollection from the Borland.StarTeam namespace to a TaskDependency[] in the com.starbase.starteam namespace.

Public Instance Constructors

TaskDependencyCollection Overloaded. Initializes a new instance of the TaskDependencyCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the TaskDependency at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a TaskDependency to end of the collection.
Append | Overloaded. Appends the TaskDependencys of the given TaskDependencyCollection to the end of this TaskDependencyCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific TaskDependency.
CopyTo | Copies all of the TaskDependencys in the TaskDependencyCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the TaskDependency with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific TaskDependency in the collection.
Insert | Inserts a TaskDependency into the collection at the specified position.
Remove | Removes the first occurrence of a specific TaskDependency from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the TaskDependencys in this TaskDependencyCollection.
Sort | Sorts the TaskDependencys in this TaskDependencyCollection, using the given comparer.
SortByID | Sorts the TaskDependencys in this TaskDependencyCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection Constructor

Initializes an instance of the TaskDependencyCollection class.

Overload List

Initializes an instance of the TaskDependencyCollection class.

public TaskDependencyCollection();

Initializes an instance of the a TaskDependencyCollection class, copying the given array.

public TaskDependencyCollection(TaskDependency[]);

Initializes an instance of the a TaskDependencyCollection class, copying the given collection.

public TaskDependencyCollection(TaskDependencyCollection);

Initializes an instance of the a TaskDependencyCollection class, wrapping the given array of TaskDependency (from the com.starbase.starteam namespace).

public TaskDependencyCollection(TaskDependency[]);

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection Constructor ()

Initializes an instance of the TaskDependencyCollection class.

public TaskDependencyCollection();

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace | TaskDependencyCollection Constructor Overload List


TaskDependencyCollection Constructor (TaskDependency[])

Initializes an instance of the a TaskDependencyCollection class, wrapping the given array of TaskDependency (from the com.starbase.starteam namespace).

public TaskDependencyCollection(
TaskDependency[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace | TaskDependencyCollection Constructor Overload List | Wrap


TaskDependencyCollection Constructor (TaskDependencyCollection)

Initializes an instance of the a TaskDependencyCollection class, copying the given collection.

public TaskDependencyCollection(
TaskDependencyCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member TaskDependency objects of the original collection are shared, not copied.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace | TaskDependencyCollection Constructor Overload List


TaskDependencyCollection Constructor (TaskDependency[])

Initializes an instance of the a TaskDependencyCollection class, copying the given array.

public TaskDependencyCollection(
TaskDependency[] array
);

Parameters

array
The array to be copied.

Remarks

The member TaskDependency objects of the original array are shared, not copied.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace | TaskDependencyCollection Constructor Overload List


TaskDependencyCollection Properties

The properties of the TaskDependencyCollection class are listed below. For a complete list of TaskDependencyCollection class members, see the TaskDependencyCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the TaskDependency at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

TaskDependencyCollection.Item Property

Gets or sets the TaskDependency at the specified index.

public TaskDependency this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the TaskDependency to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection Methods

The methods of the TaskDependencyCollection class are listed below. For a complete list of TaskDependencyCollection class members, see the TaskDependencyCollection Members topic.

Public Static Methods

Wrap Creates a TaskDependencyCollection to represent the given array of TaskDependency (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a TaskDependency to end of the collection.
Append | Overloaded. Appends the TaskDependencys of the given TaskDependencyCollection to the end of this TaskDependencyCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific TaskDependency.
CopyTo | Copies all of the TaskDependencys in the TaskDependencyCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the TaskDependency with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific TaskDependency in the collection.
Insert | Inserts a TaskDependency into the collection at the specified position.
Remove | Removes the first occurrence of a specific TaskDependency from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the TaskDependencys in this TaskDependencyCollection.
Sort | Sorts the TaskDependencys in this TaskDependencyCollection, using the given comparer.
SortByID | Sorts the TaskDependencys in this TaskDependencyCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.Add Method

Adds a TaskDependency to end of the collection.

public int Add(
TaskDependency value
);

Parameters

value
The TaskDependency to add to the collection.

Return Value

The position into which the new TaskDependency was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

TaskDependencyCollection.Append Method

Appends the TaskDependencys of the given array to the end of this TaskDependencyCollection.

Overload List

Appends the TaskDependencys of the given array to the end of this TaskDependencyCollection.

public TaskDependencyCollection Append(TaskDependency[]);

Appends the TaskDependencys of the given TaskDependencyCollection to the end of this TaskDependencyCollection.

public TaskDependencyCollection Append(TaskDependencyCollection);

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.Append Method (TaskDependency[])

Appends the TaskDependencys of the given array to the end of this TaskDependencyCollection.

public TaskDependencyCollection Append(
TaskDependency[] array
);

Parameters

array
The array whose TaskDependencys are to be appended to this TaskDependencyCollection.

Return Value

This TaskDependencyCollection, modified to include the new TaskDependencys.

Remarks

The TaskDependencyCollection is modified to include the new members. The individual TaskDependency objects are shared, not copied.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace | TaskDependencyCollection.Append Overload List


TaskDependencyCollection.Append Method (TaskDependencyCollection)

Appends the TaskDependencys of the given TaskDependencyCollection to the end of this TaskDependencyCollection.

public TaskDependencyCollection Append(
TaskDependencyCollection collection
);

Parameters

collection
The TaskDependencyCollection whose TaskDependencys are to be appended to this TaskDependencyCollection.

Return Value

This TaskDependencyCollection, modified to include the new TaskDependencys.

Remarks

The TaskDependencyCollection is modified to include the new members. The individual TaskDependency objects are shared, not copied.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace | TaskDependencyCollection.Append Overload List


TaskDependencyCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.TaskDependency[].

Implements

IWrapper.Unwrap

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.Contains Method

Determines whether or not the collection contains a specific TaskDependency.

public bool Contains(
TaskDependency value
);

Parameters

value
The TaskDependency to locate in the collection.

Return Value

true if the TaskDependency is found in the collection; otherwise, false.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.CopyTo Method

Copies all of the TaskDependencys in the TaskDependencyCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
TaskDependency[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the TaskDependencys copied from the TaskDependencyCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of TaskDependencys in the source TaskDependencyCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source TaskDependencyCollection cannot be cast automatically to the type of the destination array.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.FindByID Method

Finds the TaskDependency with the given ID.

public TaskDependency FindByID(
Int32 id
);

Parameters

id
The ID of the TaskDependency to be found.

Return Value

The TaskDependency with the given ID, or null if there is no TaskDependency with that ID in this TaskDependencyCollection.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.IndexOf Method

Determines the index of a specific TaskDependency in the collection.

public int IndexOf(
TaskDependency value
);

Parameters

value
The TaskDependency to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.Insert Method

Inserts a TaskDependency into the collection at the specified position.

public void Insert(
Int32 index,
TaskDependency value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The TaskDependency to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.Remove Method

Removes the first occurrence of a specific TaskDependency from the collection.

public void Remove(
TaskDependency value
);

Parameters

value
The TaskDependency to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.Reverse Method

Reverses the order of the TaskDependencys in this TaskDependencyCollection.

new public TaskDependencyCollection Reverse();

Return Value

This TaskDependencyCollection, modified such that the TaskDependencys are reversed.

Remarks

The TaskDependencyCollection is modified in place.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.Sort Method

Sorts the TaskDependencys in this TaskDependencyCollection, using the given comparer.

new public TaskDependencyCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two TaskDependencys.

Return Value

This TaskDependencyCollection, modified such that the TaskDependencys are sorted.

Remarks

The TaskDependencyCollection is modified in place.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.SortByID Method

Sorts the TaskDependencys in this TaskDependencyCollection by ID.

public TaskDependencyCollection SortByID();

Return Value

This TaskDependencyCollection, modified such that the TaskDependencys are sorted by ID.

Remarks

The TaskDependencyCollection is modified in place.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection.Wrap Method

Creates a TaskDependencyCollection to represent the given array of TaskDependency (from the com.starbase.starteam namespace).

public static TaskDependencyCollection Wrap(
TaskDependency[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new TaskDependencyCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a TaskDependency[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection Type Conversions

The type conversions of the TaskDependencyCollection class are listed below. For a complete list of TaskDependencyCollection class members, see the TaskDependencyCollection Members topic.

Public Static Type Conversions

Implicit TaskDependencyCollection to TaskDependency[] Conversion | Converts a TaskDependencyCollection to an array of TaskDependencys.
Implicit TaskDependencyCollection to TaskDependency[] Conversion | Converts a TaskDependencyCollection from the Borland.StarTeam namespace to a TaskDependency[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

TaskDependencyCollection Class | TaskDependencyCollection Members | Borland.StarTeam Namespace


TaskDependencyCollection Implicit TaskDependencyCollection to TaskDependency[] Conversion

Converts a TaskDependencyCollection to an array of TaskDependencys.

public static implicit operator TaskDependency[](
TaskDependencyCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new TaskDependency wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one TaskDependency wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


TaskDependencyCollection Implicit TaskDependencyCollection to TaskDependency[] Conversion

Converts a TaskDependencyCollection from the Borland.StarTeam namespace to a TaskDependency[] in the com.starbase.starteam namespace.

public static implicit operator TaskDependency[](
TaskDependencyCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, TaskDependencyCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

TaskDependencyCollection Class | Borland.StarTeam Namespace


Topic Class

Represents a StarTeam Topic.

For a list of all members of this type, see Topic Members.

System.Object
TypedResource
SimpleTypedResource
Item
TreeItem
Topic

public class Topic : TreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Topic Members | Borland.StarTeam Namespace


Topic Members

Topic overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Topic.

Public Static Type Conversions

Implicit Topic to Topic Conversion Implicitly convert Topic to com.starbase.starteam.Topic.

Public Instance Constructors

Topic Overloaded. Initializes a new instance of the Topic class.

Public Instance Properties

ACL (inherited from Item) |
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AmIRecipient | [read] A value indicating whether the logged on user is a recipient of this topic.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
ChildrenCount | [read] The number of topics that are subtopics of this one.
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
NewRevisionComment (inherited from Item) | [read] the empty string.
Number | [read] The topic number of this topic.
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
ParentTopic | [read] The object ID of this topic's parent. A value of -1 means the topic has no parent.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossiblePriority | [read] The possible values for the Priority property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PossibleStatus | [read] The possible values for the Status property.
Priority | [read/write] The Priority of this topic.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
RecipientCount | [read] The number of recipients assigned to this topic.
Recipients | [read] The IDs of the users assigned as recipients of this topic.
References (inherited from Item) | [read]
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Status | [read/write] The Status of this topic.
Text | [read/write] The text or body of the topic.
Title | [read/write] The title or subject of the topic.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.

Public Instance Methods

AcquireOwnership (inherited from Item)
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddRecipient | Adds the specified user ID as a recipient for this topic.
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateChild (inherited from TreeItem) | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPriorityDisplayName | Returns a user-friendly display name for the given Priority value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetStatusDisplayName | Returns a user-friendly display name for the given Status value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified parent. Child items, if any, are also moved.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveRecipient | Removes the specified user ID as a recipient from this topic.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Topic Class | Borland.StarTeam Namespace


Topic Constructor

Construct Topic from com.starbase.starteam.Topic.

Overload List

Creates a new topic in the specified folder.

public Topic(Folder);

Creates a new topic that is a subtopic of an existing topic.

public Topic(Topic);

Construct Topic from com.starbase.starteam.Topic.

public Topic(Topic);

See Also

Topic Class | Borland.StarTeam Namespace


Topic Constructor (Topic)

Construct Topic from com.starbase.starteam.Topic.

public Topic(
Topic impl
);

Parameters

impl
The com.starbase.starteam.Topic to be wrapped.

See Also

Topic Class | Borland.StarTeam Namespace | Topic Constructor Overload List


Topic Constructor (Folder)

Creates a new topic in the specified folder.

public Topic(
Folder parentFolder
);

Parameters

parentFolder
The folder to which this new topic will be added.

See Also

Topic Class | Borland.StarTeam Namespace | Topic Constructor Overload List


Topic Constructor (Topic)

Creates a new topic that is a subtopic of an existing topic.

public Topic(
Topic parentTopic
);

Parameters

parentTopic
The parent topic.

See Also

Topic Class | Borland.StarTeam Namespace | Topic Constructor Overload List


Topic Properties

The properties of the Topic class are listed below. For a complete list of Topic class members, see the Topic Members topic.

Public Instance Properties

ACL (inherited from Item) |
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AmIRecipient | [read] A value indicating whether the logged on user is a recipient of this topic.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
ChildrenCount | [read] The number of topics that are subtopics of this one.
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
NewRevisionComment (inherited from Item) | [read] the empty string.
Number | [read] The topic number of this topic.
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
ParentTopic | [read] The object ID of this topic's parent. A value of -1 means the topic has no parent.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossiblePriority | [read] The possible values for the Priority property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PossibleStatus | [read] The possible values for the Status property.
Priority | [read/write] The Priority of this topic.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
RecipientCount | [read] The number of recipients assigned to this topic.
Recipients | [read] The IDs of the users assigned as recipients of this topic.
References (inherited from Item) | [read]
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Status | [read/write] The Status of this topic.
Text | [read/write] The text or body of the topic.
Title | [read/write] The title or subject of the topic.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Topic Class | Borland.StarTeam Namespace


AmIRecipient Property

Borland StarTeam SDK for .NET

Topic.AmIRecipient Property

[read] A value indicating whether the logged on user is a recipient of this topic.

public virtual Int32 AmIRecipient {get;}

Property Value

A value indicating whether the logged on user is a recipient of this topic.

See Also

Topic Class | Borland.StarTeam Namespace


ChildrenCount Property

Borland StarTeam SDK for .NET

Topic.ChildrenCount Property

[read] The number of topics that are subtopics of this one.

public virtual Int32 ChildrenCount {get;}

Property Value

The number of topics that are subtopics of this one.

See Also

Topic Class | Borland.StarTeam Namespace


Number Property

Borland StarTeam SDK for .NET

Topic.Number Property

[read] The topic number of this topic.

public virtual Int32 Number {get;}

Property Value

The topic number of this topic.

See Also

Topic Class | Borland.StarTeam Namespace


ParentTopic Property

Borland StarTeam SDK for .NET

Topic.ParentTopic Property

[read] The object ID of this topic's parent. A value of -1 means the topic has no parent.

public virtual Int32 ParentTopic {get;}

Property Value

The object ID of this topic's parent. A value of -1 means the topic has no parent.

See Also

Topic Class | Borland.StarTeam Namespace


PossiblePriority Property

Borland StarTeam SDK for .NET

Topic.PossiblePriority Property

[read] The possible values for the Priority property.

public virtual Int32[] PossiblePriority {get;}

Property Value

The possible values for the Priority property.

See Also

Topic Class | Borland.StarTeam Namespace


PossibleStatus Property

Borland StarTeam SDK for .NET

Topic.PossibleStatus Property

[read] The possible values for the Status property.

public virtual Int32[] PossibleStatus {get;}

Property Value

The possible values for the Status property.

See Also

Topic Class | Borland.StarTeam Namespace


Priority Property

Borland StarTeam SDK for .NET

Topic.Priority Property

[read/write] The Priority of this topic.

public virtual Int32 Priority {get; set;}

Property Value

The Priority of this topic.

See Also

Topic Class | Borland.StarTeam Namespace


RecipientCount Property

Borland StarTeam SDK for .NET

Topic.RecipientCount Property

[read] The number of recipients assigned to this topic.

public virtual Int32 RecipientCount {get;}

Property Value

The number of recipients assigned to this topic.

See Also

Topic Class | Borland.StarTeam Namespace


Recipients Property

Borland StarTeam SDK for .NET

Topic.Recipients Property

[read] The IDs of the users assigned as recipients of this topic.

public virtual Int32[] Recipients {get;}

Property Value

The IDs of the users assigned as recipients of this topic.

See Also

Topic Class | Borland.StarTeam Namespace


Status Property

Borland StarTeam SDK for .NET

Topic.Status Property

[read/write] The Status of this topic.

public virtual Int32 Status {get; set;}

Property Value

The Status of this topic.

See Also

Topic Class | Borland.StarTeam Namespace


Text Property

Borland StarTeam SDK for .NET

Topic.Text Property

[read/write] The text or body of the topic.

public virtual String Text {get; set;}

Property Value

The text or body of the topic.

See Also

Topic Class | Borland.StarTeam Namespace


Title Property

Borland StarTeam SDK for .NET

Topic.Title Property

[read/write] The title or subject of the topic.

public virtual String Title {get; set;}

Property Value

The title or subject of the topic.

See Also

Topic Class | Borland.StarTeam Namespace


Topic Methods

The methods of the Topic class are listed below. For a complete list of Topic class members, see the Topic Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Topic.

Public Instance Methods

AcquireOwnership (inherited from Item)
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddRecipient | Adds the specified user ID as a recipient for this topic.
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateChild (inherited from TreeItem) | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPriorityDisplayName | Returns a user-friendly display name for the given Priority value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetStatusDisplayName | Returns a user-friendly display name for the given Status value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified parent. Child items, if any, are also moved.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveRecipient | Removes the specified user ID as a recipient from this topic.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Topic Class | Borland.StarTeam Namespace


Topic.AddRecipient Method

Adds the specified user ID as a recipient for this topic.

public virtual void AddRecipient(
Int32 userID
);

Parameters

userID
the user ID to add as a recipient for this topic,

See Also

Topic Class | Borland.StarTeam Namespace


Topic.GetPriorityDisplayName Method

Returns a user-friendly display name for the given Priority value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetPriorityDisplayName(
Int32 value
);

Parameters

value
The Priority value to be converted to a display name.

Return Value

A user-friendly display name for the given Priority value.

See Also

Topic Class | Borland.StarTeam Namespace | getPriority | getPossiblePriority | getEnumDisplayName | TOPIC_PRIORITY


Topic.GetStatusDisplayName Method

Returns a user-friendly display name for the given Status value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.

public virtual string GetStatusDisplayName(
Int32 value
);

Parameters

value
The Status value to be converted to a display name.

Return Value

A user-friendly display name for the given Status value.

See Also

Topic Class | Borland.StarTeam Namespace | getStatus | getPossibleStatus | getEnumDisplayName | TOPIC_STATUS


Topic.RemoveRecipient Method

Removes the specified user ID as a recipient from this topic.

public virtual void RemoveRecipient(
Int32 userID
);

Parameters

userID
the user ID recipient to remove from this topic.

See Also

Topic Class | Borland.StarTeam Namespace


Topic.Wrap Method

Dynamically wraps com.starbase.starteam.Topic.

public static Topic Wrap(
Topic impl
);

Parameters

impl
com.starbase.starteam.Topic to be wrapped.

Return Value

Topic

See Also

Topic Class | Borland.StarTeam Namespace


Topic Type Conversions

The type conversions of the Topic class are listed below. For a complete list of Topic class members, see the Topic Members topic.

Public Static Type Conversions

Implicit Topic to Topic Conversion Implicitly convert Topic to com.starbase.starteam.Topic.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

Topic Class | Topic Members | Borland.StarTeam Namespace


Topic Implicit Topic to Topic Conversion

Implicitly convert Topic to com.starbase.starteam.Topic.

public static implicit operator Topic(
Topic arg
);

Parameters

arg
Topic to convert.

Return Value

com.starbase.starteam.Topic

See Also

Topic Class | Borland.StarTeam Namespace


Translations Class

The Translations class defines the possible localized translations of a particular resource. There is the notion of a default translation which should be used when no translation exists for a particular language. In addition to the default there may be any number of specific localizations defined on a per-locale basis.

For a list of all members of this type, see Translations Members.

System.Object
Translations

public class Translations : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Translations Members | Borland.StarTeam Namespace


Translations Members

Translations overview

Public Static Methods

ParseLocale |
ToString | Overloaded.
Wrap | Dynamically wraps com.starbase.starteam.Translations.

Public Static Type Conversions

Implicit Translations to Translations Conversion Implicitly convert Translations to com.starbase.starteam.Translations.

Public Instance Constructors

Translations Overloaded. Initializes a new instance of the Translations class.

Public Instance Properties

Default | [read/write]
LocaleNames | [read]
Locales |

Public Instance Methods

ClosestDefined |
Copy |
Equals | Delegate Equals() to com.starbase.starteam.Translations.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Translations.
GetTranslation | Overloaded. Return the translation for the specified locale.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo |
RemoveLocale | Overloaded. Remove this the translation for the specified locale.
SetTranslation | Overloaded. Create or modify an existing translation.
ToDebugString |
ToString | Overloaded. Delegate ToString() to com.starbase.starteam.Translations.
Translate | Overloaded. Returns the most appropriate translation for this resource for the specified locale.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Translations Class | Borland.StarTeam Namespace


Translations Constructor

Construct Translations from com.starbase.starteam.Translations.

Overload List

Create a new Translations object with only a default set to the empty string.

public Translations();

Construct Translations from com.starbase.starteam.Translations.

public Translations(Translations);

Create a new Translations object with the default set to the specified string.

public Translations(String);

See Also

Translations Class | Borland.StarTeam Namespace


Translations Constructor (Translations)

Construct Translations from com.starbase.starteam.Translations.

public Translations(
Translations impl
);

Parameters

impl
The com.starbase.starteam.Translations to be wrapped.

See Also

Translations Class | Borland.StarTeam Namespace | Translations Constructor Overload List


Translations Constructor ()

Create a new Translations object with only a default set to the empty string.

public Translations();

See Also

Translations Class | Borland.StarTeam Namespace | Translations Constructor Overload List


Translations Constructor (String)

Create a new Translations object with the default set to the specified string.

public Translations(
String defaultValue
);

Parameters

defaultValue
the default display name. May not be null.

See Also

Translations Class | Borland.StarTeam Namespace | Translations Constructor Overload List


Translations Properties

The properties of the Translations class are listed below. For a complete list of Translations class members, see the Translations Members topic.

Public Instance Properties

Default | [read/write]
LocaleNames | [read]
Locales |

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Translations Class | Borland.StarTeam Namespace


Default Property

Borland StarTeam SDK for .NET

Translations.Default Property

[read/write]

public virtual String Default {get; set;}

See Also

Translations Class | Borland.StarTeam Namespace


LocaleNames Property

Borland StarTeam SDK for .NET

Translations.LocaleNames Property

[read]

public virtual String[] LocaleNames {get;}

See Also

Translations Class | Borland.StarTeam Namespace


Locales Property

Borland StarTeam SDK for .NET

Translations.Locales Property

public virtual CultureInfoCollection Locales {get;}

See Also

Translations Class | Borland.StarTeam Namespace


Translations Methods

The methods of the Translations class are listed below. For a complete list of Translations class members, see the Translations Members topic.

Public Static Methods

ParseLocale |
ToString | Overloaded.
Wrap | Dynamically wraps com.starbase.starteam.Translations.

Public Instance Methods

ClosestDefined |
Copy |
Equals | Delegate Equals() to com.starbase.starteam.Translations.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Translations.
GetTranslation | Overloaded. Return the translation for the specified locale.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo |
RemoveLocale | Overloaded. Remove this the translation for the specified locale.
SetTranslation | Overloaded. Create or modify an existing translation.
ToDebugString |
ToString | Overloaded. Delegate ToString() to com.starbase.starteam.Translations.
Translate | Overloaded. Returns the most appropriate translation for this resource for the specified locale.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Translations Class | Borland.StarTeam Namespace


Translations.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.Translations

Implements

IWrapper.Unwrap

See Also

Translations Class | Borland.StarTeam Namespace


Translations.ClosestDefined Method

public virtual CultureInfo ClosestDefined(
CultureInfo locale
);

See Also

Translations Class | Borland.StarTeam Namespace


Translations.Copy Method

public virtual Translations Copy();

See Also

Translations Class | Borland.StarTeam Namespace


Translations.Equals Method

Delegate Equals() to com.starbase.starteam.Translations.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.Translations.Equals(obj).

See Also

Translations Class | Borland.StarTeam Namespace


Translations.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.Translations.

public override int GetHashCode();

Return Value

com.starbase.starteam.Translations.GetHashCode().

See Also

Translations Class | Borland.StarTeam Namespace


GetTranslation Method

Borland StarTeam SDK for .NET

Translations.GetTranslation Method

Return the translation for the specified locale.

Overload List

Return the translation for the specified locale.

public virtual string GetTranslation(CultureInfo);

Return the translation for the specified locale.

public virtual string GetTranslation(String);

See Also

Translations Class | Borland.StarTeam Namespace


Translations.GetTranslation Method (CultureInfo)

Return the translation for the specified locale.

public virtual string GetTranslation(
CultureInfo locale
);

Parameters

locale
the locale of the desired translation. May not be null.

Return Value

returns the translation for the specified locale or null if none exists.

See Also

Translations Class | Borland.StarTeam Namespace | Translations.GetTranslation Overload List


Translations.GetTranslation Method (String)

Return the translation for the specified locale.

public virtual string GetTranslation(
String locale
);

Parameters

locale
the locale of the desired translation. May not be null.

Return Value

returns the translation for the specified locale or null if none exists.

See Also

Translations Class | Borland.StarTeam Namespace | Translations.GetTranslation Overload List


Translations.IsEqualTo Method

public virtual bool IsEqualTo(
Translations other
);

Parameters

other

See Also

Translations Class | Borland.StarTeam Namespace


Translations.ParseLocale Method

public static CultureInfo ParseLocale(
String pattern
);

See Also

Translations Class | Borland.StarTeam Namespace


RemoveLocale Method

Borland StarTeam SDK for .NET

Translations.RemoveLocale Method

Remove this the translation for the specified locale.

Overload List

Remove this the translation for the specified locale.

public virtual void RemoveLocale(CultureInfo);

Remove this the translation for the specified locale.

public virtual void RemoveLocale(String);

See Also

Translations Class | Borland.StarTeam Namespace


Translations.RemoveLocale Method (CultureInfo)

Remove this the translation for the specified locale.

public virtual void RemoveLocale(
CultureInfo locale
);

Parameters

locale
the locale to be removed

See Also

Translations Class | Borland.StarTeam Namespace | Translations.RemoveLocale Overload List


Translations.RemoveLocale Method (String)

Remove this the translation for the specified locale.

public virtual void RemoveLocale(
String locale
);

Parameters

locale
the locale to be removed

See Also

Translations Class | Borland.StarTeam Namespace | Translations.RemoveLocale Overload List


SetTranslation Method

Borland StarTeam SDK for .NET

Translations.SetTranslation Method

Create or modify an existing translation.

Overload List

Create or modify an existing translation.

public virtual string SetTranslation(CultureInfo,String);

Create or modify an existing translation.

public virtual string SetTranslation(String,String);

See Also

Translations Class | Borland.StarTeam Namespace


Translations.SetTranslation Method (CultureInfo, String)

Create or modify an existing translation.

public virtual string SetTranslation(
CultureInfo locale,
String value
);

Parameters

locale
the locale for the new translation
value
the locale specific translation

Return Value

the previous translation or null if there was none.

See Also

Translations Class | Borland.StarTeam Namespace | Translations.SetTranslation Overload List


Translations.SetTranslation Method (String, String)

Create or modify an existing translation.

public virtual string SetTranslation(
String locale,
String value
);

Parameters

locale
the locale for the new translation
value
the locale specific translation

Return Value

the previous translation or null if there was none.

See Also

Translations Class | Borland.StarTeam Namespace | Translations.SetTranslation Overload List


Translations.ToDebugString Method

public virtual string ToDebugString();

See Also

Translations Class | Borland.StarTeam Namespace


ToString Method

Borland StarTeam SDK for .NET

Translations.ToString Method

Delegate ToString() to com.starbase.starteam.Translations.

Overload List

Delegate ToString() to com.starbase.starteam.Translations.

public override string ToString();

public static string ToString(CultureInfo);

See Also

Translations Class | Borland.StarTeam Namespace


Translations.ToString Method ()

Delegate ToString() to com.starbase.starteam.Translations.

public override string ToString();

Return Value

com.starbase.starteam.Translations.ToString()

See Also

Translations Class | Borland.StarTeam Namespace | Translations.ToString Overload List


Translations.ToString Method (CultureInfo)

public static string ToString(
CultureInfo locale
);

See Also

Translations Class | Borland.StarTeam Namespace | Translations.ToString Overload List


Translate Method

Borland StarTeam SDK for .NET

Translations.Translate Method

Returns the most appropriate translation for this resource based on the default locale.

Overload List

Returns the most appropriate translation for this resource based on the default locale.

public virtual string Translate();

Returns the most appropriate translation for this resource for the specified locale.

public virtual string Translate(CultureInfo);

Returns the most appropriate translation for this resource for the specified locale.

public virtual string Translate(String);

See Also

Translations Class | Borland.StarTeam Namespace


Translations.Translate Method ()

Returns the most appropriate translation for this resource based on the default locale.

public virtual string Translate();

See Also

Translations Class | Borland.StarTeam Namespace | Translations.Translate Overload List


Translations.Translate Method (CultureInfo)

Returns the most appropriate translation for this resource for the specified locale.

public virtual string Translate(
CultureInfo locale
);

Parameters

locale
the locale of the desired translation. A null value will return the default translation.

See Also

Translations Class | Borland.StarTeam Namespace | Translations.Translate Overload List


Translations.Translate Method (String)

Returns the most appropriate translation for this resource for the specified locale.

public virtual string Translate(
String locale
);

Parameters

locale
the locale of the desired translation. A null value will return the default translation.

See Also

Translations Class | Borland.StarTeam Namespace | Translations.Translate Overload List


Translations.Wrap Method

Dynamically wraps com.starbase.starteam.Translations.

public static Translations Wrap(
Translations impl
);

Parameters

impl
com.starbase.starteam.Translations to be wrapped.

Return Value

Translations

See Also

Translations Class | Borland.StarTeam Namespace


Translations Type Conversions

The type conversions of the Translations class are listed below. For a complete list of Translations class members, see the Translations Members topic.

Public Static Type Conversions

Implicit Translations to Translations Conversion Implicitly convert Translations to com.starbase.starteam.Translations.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Translations Class | Translations Members | Borland.StarTeam Namespace


Translations Implicit Translations to Translations Conversion

Implicitly convert Translations to com.starbase.starteam.Translations.

public static implicit operator Translations(
Translations arg
);

Parameters

arg
Translations to convert.

Return Value

com.starbase.starteam.Translations

See Also

Translations Class | Borland.StarTeam Namespace


TreeItem Class

A type of item with children.

For a list of all members of this type, see TreeItem Members.

System.Object
TypedResource
SimpleTypedResource
Item
TreeItem
Task
Topic

public class TreeItem : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

TreeItem Members | Borland.StarTeam Namespace


TreeItem Members

TreeItem overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.TreeItem.

Public Static Type Conversions

Implicit TreeItem to TreeItem Conversion Implicitly convert TreeItem to com.starbase.starteam.TreeItem.

Public Instance Constructors

TreeItem Constructor Construct TreeItem from com.starbase.starteam.TreeItem.

Public Instance Properties

ACL (inherited from Item) |
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
NewRevisionComment (inherited from Item) | [read] the empty string.
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.

Public Instance Methods

AcquireOwnership (inherited from Item)
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateChild | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo | Overloaded. Moves this item to the specified parent. Child items, if any, are also moved.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

TreeItem Class | Borland.StarTeam Namespace


TreeItem Constructor

Construct TreeItem from com.starbase.starteam.TreeItem.

public TreeItem(
TreeItem impl
);

Parameters

impl
The com.starbase.starteam.TreeItem to be wrapped.

See Also

TreeItem Class | Borland.StarTeam Namespace


TreeItem Properties

The properties of the TreeItem class are listed below. For a complete list of TreeItem class members, see the TreeItem Members topic.

Public Instance Properties

ACL (inherited from Item) |
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
NewRevisionComment (inherited from Item) | [read] the empty string.
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

TreeItem Class | Borland.StarTeam Namespace


ParentID Property

Borland StarTeam SDK for .NET

TreeItem.ParentID Property

[read] The ObjectID of this item's parent, or -1 if this is a root item.

public virtual Int32 ParentID {get;}

Property Value

The ObjectID of this item's parent, or -1 if this is a root item.

See Also

TreeItem Class | Borland.StarTeam Namespace


TreeItem Methods

The methods of the TreeItem class are listed below. For a complete list of TreeItem class members, see the TreeItem Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.TreeItem.

Public Instance Methods

AcquireOwnership (inherited from Item)
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateChild | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Item)
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo | Overloaded. Moves this item to the specified parent. Child items, if any, are also moved.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. The item will be removed from its current folder.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

TreeItem Class | Borland.StarTeam Namespace


TreeItem.CreateChild Method

Creates a new child item.

public virtual TreeItem CreateChild();

Return Value

A new child item of the appropriate type. The item is not saved to the repository until update() is called.

See Also

TreeItem Class | Borland.StarTeam Namespace


MoveTo Method

Borland StarTeam SDK for .NET

TreeItem.MoveTo Method

Moves this item to the specified parent. Child items, if any, are also moved.

Overload List

Inherited from Item.

public virtual void MoveTo(Folder);

Moves this item to the specified parent. Child items, if any, are also moved.

public virtual void MoveTo(TreeItem);

See Also

TreeItem Class | Borland.StarTeam Namespace | isDisembodied


TreeItem.MoveTo Method (TreeItem)

Moves this item to the specified parent. Child items, if any, are also moved.

public virtual void MoveTo(
TreeItem parent
);

Parameters

parent
The new parent to which this item is to be moved.

See Also

TreeItem Class | Borland.StarTeam Namespace | TreeItem.MoveTo Overload List | isDisembodied


TreeItem.Wrap Method

Dynamically wraps com.starbase.starteam.TreeItem.

public static TreeItem Wrap(
TreeItem impl
);

Parameters

impl
com.starbase.starteam.TreeItem to be wrapped.

Return Value

TreeItem

See Also

TreeItem Class | Borland.StarTeam Namespace


TreeItem Type Conversions

The type conversions of the TreeItem class are listed below. For a complete list of TreeItem class members, see the TreeItem Members topic.

Public Static Type Conversions

Implicit TreeItem to TreeItem Conversion Implicitly convert TreeItem to com.starbase.starteam.TreeItem.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

TreeItem Class | TreeItem Members | Borland.StarTeam Namespace


TreeItem Implicit TreeItem to TreeItem Conversion

Implicitly convert TreeItem to com.starbase.starteam.TreeItem.

public static implicit operator TreeItem(
TreeItem arg
);

Parameters

arg
TreeItem to convert.

Return Value

com.starbase.starteam.TreeItem

See Also

TreeItem Class | Borland.StarTeam Namespace


Type Class

Information describing certain StarTeam object types.

For a list of all members of this type, see Type Members.

System.Object
Type

public class Type : ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Type Members | Borland.StarTeam Namespace


Type Members

Type overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Type.

Public Static Type Conversions

Implicit Type to Type Conversion Implicitly convert Type to com.starbase.starteam.Type.

Public Instance Constructors

Type Constructor Construct Type from com.starbase.starteam.Type.

Public Instance Properties

Catalog | [read] the catalog for this type.
ClassID | [read] the class ID for this type.
ComponentACL | [read/write] the access control list for this type. May return null.
ComponentGUID | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DBTableName | [read] the database table name for this type
DebugString | [read] a debug string for this type.
DisplayName | [read] a display name for this type.
FilterACL | [read/write] the access control list for this type. May return null.
Filters | [read] an array of all Filters for this type.
IsComponentType | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsItemType | [read] true if this Type corresponds to a StarTeam "item" (that is, a type of object that can be contained in a Folder).
IsMPXSupported | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired | [read] true if Filter or Query information may be out of date.
Name | [read] the name of this type
ParentContainer |
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties | [read] an array of all properties belonging to this type.
PropertyCount | [read] the number of properties belonging to this type.
Queries | [read] an array of all QueryInfo for this type.
QueryACL | [read/write] the access control list for this type. May return null.
Server | [read] the Server object containing this Type.

Public Instance Methods

Copy | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or QueryInfo objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard | Discards all of the cached properties for this Type. They will be re-fetched from the server on demand (even when MPX is enabled).
DiscardFiltersAndQueries | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetContainerLevelACL |
GetFilterForID | Returns the cached Filter object belonging to this type with the specified filter ID. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetFilterForName | Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQueryForID | Returns the cached QueryInfo object belonging to this type with the specified QueryInfo ID. This will not return null, but will throw an IllegalArgumentException if the QueryInfo is not found.
GetQueryForName | Returns the cached QueryInfo object belonging to this type with the specified QueryInfo name. This will not return null, but will throw an IllegalArgumentException if the QueryInfo is not found.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilterForID | Returns true if the cache contains a Filter with the provided ID.
HasFilterForName | Returns true if the cache contains a Filter with the provided name.
HasPermission | Overloaded.
HasPropertyForName | Returns true if a property given the specified name exists for this type.
HasPropertyForPID | Returns true if a property given the specified id exists for this type.
HasQueryForID | Returns true if the cache contains a QueryInfo with the provided ID.
HasQueryForName | Returns true if the cache contains a QueryInfo with the provided name.
IsEqualTo | Compares two Type objects. Does not compare any associated Property, Filter or Query objects.
NewFilterEventSource |
NewQueryEventSource |
NewTypeEventSource |
PidForIndex | Gets the property ID of the property at the given cache index.
PropertiesForNames | This is a convenience method for returning an array of Property objects from the specified names. The input array of property names may be null in which case all properties of this type will be returned. If any of the specified property names does not correspond to a property then an Exception will be thrown.
PropertyForName | Return the Property object belonging to this type with the specified property name. This will not return null and will throw an Exception if the property is not found.
PropertyForPID | Return the Property object belonging to this type with the specified property ID. This will not return null and will throw an Exception if the property is not found.
Refresh | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries | Refreshes cached Filter and Query information to reflect recent changes to the repository. Modifies existing Filter and Query objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetContainerLevelACL |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Type Class | Borland.StarTeam Namespace


Type Constructor

Construct Type from com.starbase.starteam.Type.

public Type(
Type impl
);

Parameters

impl
The com.starbase.starteam.Type to be wrapped.

See Also

Type Class | Borland.StarTeam Namespace


Type Properties

The properties of the Type class are listed below. For a complete list of Type class members, see the Type Members topic.

Public Instance Properties

Catalog | [read] the catalog for this type.
ClassID | [read] the class ID for this type.
ComponentACL | [read/write] the access control list for this type. May return null.
ComponentGUID | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DBTableName | [read] the database table name for this type
DebugString | [read] a debug string for this type.
DisplayName | [read] a display name for this type.
FilterACL | [read/write] the access control list for this type. May return null.
Filters | [read] an array of all Filters for this type.
IsComponentType | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsItemType | [read] true if this Type corresponds to a StarTeam "item" (that is, a type of object that can be contained in a Folder).
IsMPXSupported | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired | [read] true if Filter or Query information may be out of date.
Name | [read] the name of this type
ParentContainer |
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties | [read] an array of all properties belonging to this type.
PropertyCount | [read] the number of properties belonging to this type.
Queries | [read] an array of all QueryInfo for this type.
QueryACL | [read/write] the access control list for this type. May return null.
Server | [read] the Server object containing this Type.

See Also

Type Class | Borland.StarTeam Namespace


Catalog Property

Borland StarTeam SDK for .NET

Type.Catalog Property

[read] the catalog for this type.

public virtual Catalog Catalog {get;}

Property Value

the catalog for this type.

See Also

Type Class | Borland.StarTeam Namespace


ClassID Property

Borland StarTeam SDK for .NET

Type.ClassID Property

[read] the class ID for this type.

public virtual Int32 ClassID {get;}

Property Value

the class ID for this type.

See Also

Type Class | Borland.StarTeam Namespace


ComponentACL Property

Borland StarTeam SDK for .NET

Type.ComponentACL Property

[read/write] the access control list for this type. May return null.

public virtual ACL ComponentACL {get; set;}

Property Value

the access control list for this type. May return null.

See Also

Type Class | Borland.StarTeam Namespace


ComponentGUID Property

Borland StarTeam SDK for .NET

Type.ComponentGUID Property

[read] The server-defined component GUID, or null if this Type does not represent a component type.

public virtual GUID ComponentGUID {get;}

Property Value

The server-defined component GUID, or null if this Type does not represent a component type.

See Also

Type Class | Borland.StarTeam Namespace


DBTableName Property

Borland StarTeam SDK for .NET

Type.DBTableName Property

[read] the database table name for this type

public virtual String DBTableName {get;}

Property Value

the database table name for this type

See Also

Type Class | Borland.StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Type.DebugString Property

[read] a debug string for this type.

public virtual String DebugString {get;}

Property Value

a debug string for this type.

See Also

Type Class | Borland.StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Type.DisplayName Property

[read] a display name for this type.

public virtual String DisplayName {get;}

Property Value

a display name for this type.

See Also

Type Class | Borland.StarTeam Namespace


FilterACL Property

Borland StarTeam SDK for .NET

Type.FilterACL Property

[read/write] the access control list for this type. May return null.

public virtual ACL FilterACL {get; set;}

Property Value

the access control list for this type. May return null.

See Also

Type Class | Borland.StarTeam Namespace


Filters Property

Borland StarTeam SDK for .NET

Type.Filters Property

[read] an array of all Filters for this type.

public virtual FilterCollection Filters {get;}

Property Value

an array of all Filters for this type.

See Also

Type Class | Borland.StarTeam Namespace


IsComponentType Property

Borland StarTeam SDK for .NET

Type.IsComponentType Property

[read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).

public virtual Boolean IsComponentType {get;}

Property Value

true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).

See Also

Type Class | Borland.StarTeam Namespace


IsItemType Property

Borland StarTeam SDK for .NET

Type.IsItemType Property

[read] true if this Type corresponds to a StarTeam "item" (that is, a type of object that can be contained in a Folder).

public virtual Boolean IsItemType {get;}

Property Value

true if this Type corresponds to a StarTeam "item" (that is, a type of object that can be contained in a Folder).

See Also

Type Class | Borland.StarTeam Namespace


IsMPXSupported Property

Borland StarTeam SDK for .NET

Type.IsMPXSupported Property

[read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).

public virtual Boolean IsMPXSupported {get;}

Property Value

true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).

See Also

Type Class | Borland.StarTeam Namespace


IsRefreshFiltersAndQueriesRequired Property

Borland StarTeam SDK for .NET

Type.IsRefreshFiltersAndQueriesRequired Property

[read] true if Filter or Query information may be out of date.

public virtual Boolean IsRefreshFiltersAndQueriesRequired {get;}

Property Value

true if Filter or Query information may be out of date.

See Also

Type Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Type.Name Property

[read] the name of this type

public virtual String Name {get;}

Property Value

the name of this type

See Also

Type Class | Borland.StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

Type.ParentContainer Property

public virtual ISecurableContainer ParentContainer {get;}

Implements

ISecurableContainer.ParentContainer

See Also

Type Class | Borland.StarTeam Namespace


PrimaryDescriptor Property

Borland StarTeam SDK for .NET

Type.PrimaryDescriptor Property

[read] The primary descriptor of this type, or null if this type has no primary descriptor.

public virtual Property PrimaryDescriptor {get;}

Property Value

The primary descriptor of this type, or null if this type has no primary descriptor.

See Also

Type Class | Borland.StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Type.Properties Property

[read] an array of all properties belonging to this type.

public virtual PropertyCollection Properties {get;}

Property Value

an array of all properties belonging to this type.

See Also

Type Class | Borland.StarTeam Namespace


PropertyCount Property

Borland StarTeam SDK for .NET

Type.PropertyCount Property

[read] the number of properties belonging to this type.

public virtual Int32 PropertyCount {get;}

Property Value

the number of properties belonging to this type.

See Also

Type Class | Borland.StarTeam Namespace


Queries Property

Borland StarTeam SDK for .NET

Type.Queries Property

[read] an array of all QueryInfo for this type.

public virtual QueryCollection Queries {get;}

Property Value

an array of all QueryInfo for this type.

See Also

Type Class | Borland.StarTeam Namespace


QueryACL Property

Borland StarTeam SDK for .NET

Type.QueryACL Property

[read/write] the access control list for this type. May return null.

public virtual ACL QueryACL {get; set;}

Property Value

the access control list for this type. May return null.

See Also

Type Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Type.Server Property

[read] the Server object containing this Type.

public virtual Server Server {get;}

Property Value

the Server object containing this Type.

See Also

Type Class | Borland.StarTeam Namespace


Type Methods

The methods of the Type class are listed below. For a complete list of Type class members, see the Type Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Type.

Public Instance Methods

Copy | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or QueryInfo objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard | Discards all of the cached properties for this Type. They will be re-fetched from the server on demand (even when MPX is enabled).
DiscardFiltersAndQueries | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetContainerLevelACL |
GetFilterForID | Returns the cached Filter object belonging to this type with the specified filter ID. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetFilterForName | Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQueryForID | Returns the cached QueryInfo object belonging to this type with the specified QueryInfo ID. This will not return null, but will throw an IllegalArgumentException if the QueryInfo is not found.
GetQueryForName | Returns the cached QueryInfo object belonging to this type with the specified QueryInfo name. This will not return null, but will throw an IllegalArgumentException if the QueryInfo is not found.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilterForID | Returns true if the cache contains a Filter with the provided ID.
HasFilterForName | Returns true if the cache contains a Filter with the provided name.
HasPermission | Overloaded.
HasPropertyForName | Returns true if a property given the specified name exists for this type.
HasPropertyForPID | Returns true if a property given the specified id exists for this type.
HasQueryForID | Returns true if the cache contains a QueryInfo with the provided ID.
HasQueryForName | Returns true if the cache contains a QueryInfo with the provided name.
IsEqualTo | Compares two Type objects. Does not compare any associated Property, Filter or Query objects.
NewFilterEventSource |
NewQueryEventSource |
NewTypeEventSource |
PidForIndex | Gets the property ID of the property at the given cache index.
PropertiesForNames | This is a convenience method for returning an array of Property objects from the specified names. The input array of property names may be null in which case all properties of this type will be returned. If any of the specified property names does not correspond to a property then an Exception will be thrown.
PropertyForName | Return the Property object belonging to this type with the specified property name. This will not return null and will throw an Exception if the property is not found.
PropertyForPID | Return the Property object belonging to this type with the specified property ID. This will not return null and will throw an Exception if the property is not found.
Refresh | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries | Refreshes cached Filter and Query information to reflect recent changes to the repository. Modifies existing Filter and Query objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetContainerLevelACL |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Type Class | Borland.StarTeam Namespace


Type.Copy Method

Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or QueryInfo objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().

public virtual Type Copy();

Return Value

A copy of this Type.

See Also

Type Class | Borland.StarTeam Namespace | isEqualTo


Type.Discard Method

Discards all of the cached properties for this Type. They will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void Discard();

See Also

Type Class | Borland.StarTeam Namespace


Type.DiscardFiltersAndQueries Method

Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void DiscardFiltersAndQueries();

See Also

Type Class | Borland.StarTeam Namespace | refreshFiltersAndQueries


Type.GetContainerLevelACL Method

public virtual ACL GetContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.GetContainerLevelACL

See Also

Type Class | Borland.StarTeam Namespace


Type.GetFilterForID Method

Returns the cached Filter object belonging to this type with the specified filter ID. This will not return null, but will throw an IllegalArgumentException if the filter is not found.

public virtual Filter GetFilterForID(
Int32 ID
);

Parameters

ID
A filter ID.

Return Value

the Filter object belonging to this type with the specified filter ID.

See Also

Type Class | Borland.StarTeam Namespace | refreshFiltersAndQueries | Filter


Type.GetFilterForName Method

Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.

public virtual Filter GetFilterForName(
String name
);

Parameters

name
A filter name.

Return Value

the Filter object belonging to this type with the specified filter name.

See Also

Type Class | Borland.StarTeam Namespace | refreshFiltersAndQueries | Filter


Type.GetQueryForID Method

Returns the cached QueryInfo object belonging to this type with the specified QueryInfo ID. This will not return null, but will throw an IllegalArgumentException if the QueryInfo is not found.

public virtual Query GetQueryForID(
Int32 ID
);

Parameters

ID
A Query ID.

Return Value

the QueryInfo object belonging to this type with the specified QueryInfo ID.

See Also

Type Class | Borland.StarTeam Namespace | refreshFiltersAndQueries | QueryInfo


Type.GetQueryForName Method

Returns the cached QueryInfo object belonging to this type with the specified QueryInfo name. This will not return null, but will throw an IllegalArgumentException if the QueryInfo is not found.

public virtual Query GetQueryForName(
String name
);

Parameters

name
A Query name.

Return Value

the QueryInfo object belonging to this type with the specified QueryInfo name.

See Also

Type Class | Borland.StarTeam Namespace | refreshFiltersAndQueries | QueryInfo


Type.HasFilterForID Method

Returns true if the cache contains a Filter with the provided ID.

public virtual bool HasFilterForID(
Int32 ID
);

Parameters

ID
A filter ID.

Return Value

true if the cache contains a Filter with the provided ID.

See Also

Type Class | Borland.StarTeam Namespace | refreshFiltersAndQueries | Filter


Type.HasFilterForName Method

Returns true if the cache contains a Filter with the provided name.

public virtual bool HasFilterForName(
String name
);

Parameters

name
A filter name.

Return Value

true if the cache contains a Filter with the provided name.

See Also

Type Class | Borland.StarTeam Namespace | refreshFiltersAndQueries | Filter


HasPermission Method

Borland StarTeam SDK for .NET

Type.HasPermission Method

Overload List

public virtual bool HasPermission(Int32);

public virtual bool HasPermission(Int32,String);

See Also

Type Class | Borland.StarTeam Namespace


Type.HasPermission Method (Int32)

public virtual bool HasPermission(
Int32 permissions
);

See Also

Type Class | Borland.StarTeam Namespace | Type.HasPermission Overload List


Type.HasPermission Method (Int32, String)

public virtual bool HasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.HasPermission

See Also

Type Class | Borland.StarTeam Namespace | Type.HasPermission Overload List


Type.HasPropertyForName Method

Returns true if a property given the specified name exists for this type.

public virtual bool HasPropertyForName(
String propertyName
);

Parameters

propertyName
the name of the desired Property object

Return Value

true if the specified property exists

See Also

Type Class | Borland.StarTeam Namespace | getName


Type.HasPropertyForPID Method

Returns true if a property given the specified id exists for this type.

public virtual bool HasPropertyForPID(
Int32 propertyID
);

Parameters

propertyID
the property ID of the desired Property

Return Value

true if the specified property exists

See Also

Type Class | Borland.StarTeam Namespace | getID


Type.HasQueryForID Method

Returns true if the cache contains a QueryInfo with the provided ID.

public virtual bool HasQueryForID(
Int32 ID
);

Parameters

ID
A Query ID.

Return Value

true if the cache contains a QueryInfo with the provided ID.

See Also

Type Class | Borland.StarTeam Namespace | refreshFiltersAndQueries | QueryInfo


Type.HasQueryForName Method

Returns true if the cache contains a QueryInfo with the provided name.

public virtual bool HasQueryForName(
String name
);

Parameters

name
A Query name.

Return Value

true if the cache contains a QueryInfo with the provided name.

See Also

Type Class | Borland.StarTeam Namespace | refreshFiltersAndQueries | QueryInfo


Type.IsEqualTo Method

Compares two Type objects. Does not compare any associated Property, Filter or Query objects.

public virtual bool IsEqualTo(
Type type
);

Parameters

type
A Type object to be compared with this one.

Return Value

true if no differences are found.

See Also

Type Class | Borland.StarTeam Namespace | copy


Type.NewFilterEventSource Method

public FilterEventSource NewFilterEventSource();

See Also

Type Class | Borland.StarTeam Namespace


Type.NewQueryEventSource Method

public QueryEventSource NewQueryEventSource();

See Also

Type Class | Borland.StarTeam Namespace


Type.NewTypeEventSource Method

public TypeEventSource NewTypeEventSource();

See Also

Type Class | Borland.StarTeam Namespace


Type.PidForIndex Method

Gets the property ID of the property at the given cache index.

public virtual int PidForIndex(
Int32 i
);

Parameters

i
The cache index.

Return Value

The corresponding property id.

See Also

Type Class | Borland.StarTeam Namespace


Type.PropertiesForNames Method

This is a convenience method for returning an array of Property objects from the specified names. The input array of property names may be null in which case all properties of this type will be returned. If any of the specified property names does not correspond to a property then an Exception will be thrown.

public virtual PropertyCollection PropertiesForNames(
String[] propertyNames
);

Parameters

propertyNames
an array of property names to be found. This may be null.

Return Value

an array of properties corresponding to the specified names.

See Also

Type Class | Borland.StarTeam Namespace | propertyForName


Type.PropertyForName Method

Return the Property object belonging to this type with the specified property name. This will not return null and will throw an Exception if the property is not found.

public virtual Property PropertyForName(
String propertyName
);

Parameters

propertyName
the name of the desired Property object

Return Value

the property with the specified name.

See Also

Type Class | Borland.StarTeam Namespace | getName


Type.PropertyForPID Method

Return the Property object belonging to this type with the specified property ID. This will not return null and will throw an Exception if the property is not found.

public virtual Property PropertyForPID(
Int32 propertyID
);

Parameters

propertyID
the property ID of the desired Property

Return Value

the property with the specified ID.

See Also

Type Class | Borland.StarTeam Namespace | getID


Type.Refresh Method

Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command

public virtual void Refresh();

See Also

Type Class | Borland.StarTeam Namespace


Type.RefreshFiltersAndQueries Method

Refreshes cached Filter and Query information to reflect recent changes to the repository. Modifies existing Filter and Query objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.

public virtual void RefreshFiltersAndQueries();

See Also

Type Class | Borland.StarTeam Namespace | getFilters | getQueries | isRefreshFiltersAndQueriesRequired | discardFiltersAndQueries | enableMPX


Type.SetContainerLevelACL Method

public virtual void SetContainerLevelACL(
ACL acl,
String typeName
);

Implements

ISecurableContainer.SetContainerLevelACL

See Also

Type Class | Borland.StarTeam Namespace


Type.Wrap Method

Dynamically wraps com.starbase.starteam.Type.

public static Type Wrap(
Type impl
);

Parameters

impl
com.starbase.starteam.Type to be wrapped.

Return Value

Type

See Also

Type Class | Borland.StarTeam Namespace


Type Type Conversions

The type conversions of the Type class are listed below. For a complete list of Type class members, see the Type Members topic.

Public Static Type Conversions

Implicit Type to Type Conversion Implicitly convert Type to com.starbase.starteam.Type.

See Also

Type Class | Type Members | Borland.StarTeam Namespace


Type Implicit Type to Type Conversion

Implicitly convert Type to com.starbase.starteam.Type.

public static implicit operator Type(
Type arg
);

Parameters

arg
Type to convert.

Return Value

com.starbase.starteam.Type

See Also

Type Class | Borland.StarTeam Namespace


TypeCollection Class

A strongly-typed collection of Types.

For a list of all members of this type, see TypeCollection Members.

System.Object
ArrayAdapter
TypeCollection

public class TypeCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

TypeCollection Members | Borland.StarTeam Namespace


TypeCollection Members

TypeCollection overview

Public Static Methods

Wrap Creates a TypeCollection to represent the given array of Type (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit TypeCollection to Type[] Conversion | Converts a TypeCollection to an array of Types.
Implicit TypeCollection to Type[] Conversion | Converts a TypeCollection from the Borland.StarTeam namespace to a Type[] in the com.starbase.starteam namespace.

Public Instance Constructors

TypeCollection Overloaded. Initializes a new instance of the TypeCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Type at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Type to end of the collection.
Append | Overloaded. Appends the Types of the given TypeCollection to the end of this TypeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Type.
CopyTo | Copies all of the Types in the TypeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the Type with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Type in the collection.
Insert | Inserts a Type into the collection at the specified position.
Remove | Removes the first occurrence of a specific Type from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Types in this TypeCollection.
Sort | Sorts the Types in this TypeCollection, using the given comparer.
SortByName | Sorts the Types in this TypeCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection Constructor

Initializes an instance of the TypeCollection class.

Overload List

Initializes an instance of the TypeCollection class.

public TypeCollection();

Initializes an instance of the a TypeCollection class, copying the given array.

public TypeCollection(Type[]);

Initializes an instance of the a TypeCollection class, copying the given collection.

public TypeCollection(TypeCollection);

Initializes an instance of the a TypeCollection class, wrapping the given array of Type (from the com.starbase.starteam namespace).

public TypeCollection(Type[]);

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection Constructor ()

Initializes an instance of the TypeCollection class.

public TypeCollection();

See Also

TypeCollection Class | Borland.StarTeam Namespace | TypeCollection Constructor Overload List


TypeCollection Constructor (Type[])

Initializes an instance of the a TypeCollection class, wrapping the given array of Type (from the com.starbase.starteam namespace).

public TypeCollection(
Type[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

TypeCollection Class | Borland.StarTeam Namespace | TypeCollection Constructor Overload List | Wrap


TypeCollection Constructor (TypeCollection)

Initializes an instance of the a TypeCollection class, copying the given collection.

public TypeCollection(
TypeCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Type objects of the original collection are shared, not copied.

See Also

TypeCollection Class | Borland.StarTeam Namespace | TypeCollection Constructor Overload List


TypeCollection Constructor (Type[])

Initializes an instance of the a TypeCollection class, copying the given array.

public TypeCollection(
Type[] array
);

Parameters

array
The array to be copied.

Remarks

The member Type objects of the original array are shared, not copied.

See Also

TypeCollection Class | Borland.StarTeam Namespace | TypeCollection Constructor Overload List


TypeCollection Properties

The properties of the TypeCollection class are listed below. For a complete list of TypeCollection class members, see the TypeCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Type at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

TypeCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

TypeCollection.Item Property

Gets or sets the Type at the specified index.

Overload List

Gets or sets the Type at the specified index.

public Type this[Int32] {get; set;}

Gets the Type with the given name.

public Type this[String] {get;}

See Also

TypeCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

TypeCollection.Item Property (Int32)

Gets or sets the Type at the specified index.

public Type this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Type to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

TypeCollection Class | Borland.StarTeam Namespace | TypeCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

TypeCollection.Item Property (String)

Gets the Type with the given name.

public Type this[
String name
] {get;}

Parameters

name
The name of the Type to get.

Property Value

The Type with the given name, or null if there is no Type with that name in this TypeCollection. Comparison is case sensitive.

See Also

TypeCollection Class | Borland.StarTeam Namespace | TypeCollection.Item Overload List | FindByName


TypeCollection Methods

The methods of the TypeCollection class are listed below. For a complete list of TypeCollection class members, see the TypeCollection Members topic.

Public Static Methods

Wrap Creates a TypeCollection to represent the given array of Type (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a Type to end of the collection.
Append | Overloaded. Appends the Types of the given TypeCollection to the end of this TypeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Type.
CopyTo | Copies all of the Types in the TypeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the Type with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Type in the collection.
Insert | Inserts a Type into the collection at the specified position.
Remove | Removes the first occurrence of a specific Type from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Types in this TypeCollection.
Sort | Sorts the Types in this TypeCollection, using the given comparer.
SortByName | Sorts the Types in this TypeCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.Add Method

Adds a Type to end of the collection.

public int Add(
Type value
);

Parameters

value
The Type to add to the collection.

Return Value

The position into which the new Type was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

TypeCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

TypeCollection.Append Method

Appends the Types of the given array to the end of this TypeCollection.

Overload List

Appends the Types of the given array to the end of this TypeCollection.

public TypeCollection Append(Type[]);

Appends the Types of the given TypeCollection to the end of this TypeCollection.

public TypeCollection Append(TypeCollection);

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.Append Method (Type[])

Appends the Types of the given array to the end of this TypeCollection.

public TypeCollection Append(
Type[] array
);

Parameters

array
The array whose Types are to be appended to this TypeCollection.

Return Value

This TypeCollection, modified to include the new Types.

Remarks

The TypeCollection is modified to include the new members. The individual Type objects are shared, not copied.

See Also

TypeCollection Class | Borland.StarTeam Namespace | TypeCollection.Append Overload List


TypeCollection.Append Method (TypeCollection)

Appends the Types of the given TypeCollection to the end of this TypeCollection.

public TypeCollection Append(
TypeCollection collection
);

Parameters

collection
The TypeCollection whose Types are to be appended to this TypeCollection.

Return Value

This TypeCollection, modified to include the new Types.

Remarks

The TypeCollection is modified to include the new members. The individual Type objects are shared, not copied.

See Also

TypeCollection Class | Borland.StarTeam Namespace | TypeCollection.Append Overload List


TypeCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.Type[].

Implements

IWrapper.Unwrap

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.Contains Method

Determines whether or not the collection contains a specific Type.

public bool Contains(
Type value
);

Parameters

value
The Type to locate in the collection.

Return Value

true if the Type is found in the collection; otherwise, false.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.CopyTo Method

Copies all of the Types in the TypeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Type[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Types copied from the TypeCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Types in the source TypeCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source TypeCollection cannot be cast automatically to the type of the destination array.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.FindByName Method

Finds the Type with the given name.

public Type FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the Type to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The Type with the given name, or null if there is no Type with that name in this TypeCollection.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.IndexOf Method

Determines the index of a specific Type in the collection.

public int IndexOf(
Type value
);

Parameters

value
The Type to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.Insert Method

Inserts a Type into the collection at the specified position.

public void Insert(
Int32 index,
Type value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Type to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.Remove Method

Removes the first occurrence of a specific Type from the collection.

public void Remove(
Type value
);

Parameters

value
The Type to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.Reverse Method

Reverses the order of the Types in this TypeCollection.

new public TypeCollection Reverse();

Return Value

This TypeCollection, modified such that the Types are reversed.

Remarks

The TypeCollection is modified in place.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.Sort Method

Sorts the Types in this TypeCollection, using the given comparer.

new public TypeCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Types.

Return Value

This TypeCollection, modified such that the Types are sorted.

Remarks

The TypeCollection is modified in place.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.SortByName Method

Sorts the Types in this TypeCollection by name.

public TypeCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This TypeCollection, modified such that the Types are sorted by name.

Remarks

The TypeCollection is modified in place.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection.Wrap Method

Creates a TypeCollection to represent the given array of Type (from the com.starbase.starteam namespace).

public static TypeCollection Wrap(
Type[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new TypeCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a Type[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection Type Conversions

The type conversions of the TypeCollection class are listed below. For a complete list of TypeCollection class members, see the TypeCollection Members topic.

Public Static Type Conversions

Implicit TypeCollection to Type[] Conversion | Converts a TypeCollection to an array of Types.
Implicit TypeCollection to Type[] Conversion | Converts a TypeCollection from the Borland.StarTeam namespace to a Type[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

TypeCollection Class | TypeCollection Members | Borland.StarTeam Namespace


TypeCollection Implicit TypeCollection to Type[] Conversion

Converts a TypeCollection to an array of Types.

public static implicit operator Type[](
TypeCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Type wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Type wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypeCollection Implicit TypeCollection to Type[] Conversion

Converts a TypeCollection from the Borland.StarTeam namespace to a Type[] in the com.starbase.starteam namespace.

public static implicit operator Type[](
TypeCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, TypeCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

TypeCollection Class | Borland.StarTeam Namespace


TypedResource Class

This is a parent interface for many instances of StarTeam types (e.g. File, ChangeRequest). The interface describes objects that have property/value pairs. Each TypedResource is associated with the properties from a Type object. A TypedResource has a constraint that only valid Type properties may be used for set/get and that type checking for set will be enforced.

For a list of all members of this type, see TypedResource Members.

System.Object
TypedResource
SimpleTypedResource

public class TypedResource : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

TypedResource Members | Borland.StarTeam Namespace


TypedResource Members

TypedResource overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.TypedResource.

Public Static Type Conversions

Implicit TypedResource to TypedResource Conversion Implicitly convert TypedResource to com.starbase.starteam.TypedResource.

Public Instance Constructors

TypedResource Constructor Construct TypedResource from com.starbase.starteam.TypedResource.

Public Instance Properties

Item |
PropertyNames | [read] the PropertyNames object from this items' server object.
Type | [read] the type of this object
TypeNames | [read] the TypeNames object from the owning server.

Public Instance Methods

AddToIntArray | Add a new array item to a property whose value is an integer array.
Equals | Delegate Equals() to com.starbase.starteam.TypedResource.
Get | Return the value for the specified property.
GetByteArray | A convenience method for returning byte[] valued properties.
GetDouble | A convenience method for returning double valued properties.
GetEnumDisplayName | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt | A convenience method for returning integer valued properties.
GetIntArray | A convenience method for returning int[] valued properties.
GetOLEDate | A convenience method for returning OLEDate valued properties.
GetPossibleValues | A convenience method for returning an array of the possible values of an enumerated property.
GetString | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put | Set the value of the specified property and return the old value.
RemoveFromIntArray | Remove an array item from a property whose value is an integer array.
ToString | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource Constructor

Construct TypedResource from com.starbase.starteam.TypedResource.

public TypedResource(
TypedResource impl
);

Parameters

impl
The com.starbase.starteam.TypedResource to be wrapped.

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource Properties

The properties of the TypedResource class are listed below. For a complete list of TypedResource class members, see the TypedResource Members topic.

Public Instance Properties

Item |
PropertyNames | [read] the PropertyNames object from this items' server object.
Type | [read] the type of this object
TypeNames | [read] the TypeNames object from the owning server.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypedResource Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

TypedResource.Item Property

public Object this[
String index
] {get; set;}

See Also

TypedResource Class | Borland.StarTeam Namespace


PropertyNames Property

Borland StarTeam SDK for .NET

TypedResource.PropertyNames Property

[read] the PropertyNames object from this items' server object.

public virtual PropertyNames PropertyNames {get;}

Property Value

the PropertyNames object from this items' server object.

See Also

TypedResource Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

TypedResource.Type Property

[read] the type of this object

public virtual Type Type {get;}

Property Value

the type of this object

See Also

TypedResource Class | Borland.StarTeam Namespace


TypeNames Property

Borland StarTeam SDK for .NET

TypedResource.TypeNames Property

[read] the TypeNames object from the owning server.

public virtual TypeNames TypeNames {get;}

Property Value

the TypeNames object from the owning server.

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource Methods

The methods of the TypedResource class are listed below. For a complete list of TypedResource class members, see the TypedResource Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.TypedResource.

Public Instance Methods

AddToIntArray | Add a new array item to a property whose value is an integer array.
Equals | Delegate Equals() to com.starbase.starteam.TypedResource.
Get | Return the value for the specified property.
GetByteArray | A convenience method for returning byte[] valued properties.
GetDouble | A convenience method for returning double valued properties.
GetEnumDisplayName | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt | A convenience method for returning integer valued properties.
GetIntArray | A convenience method for returning int[] valued properties.
GetOLEDate | A convenience method for returning OLEDate valued properties.
GetPossibleValues | A convenience method for returning an array of the possible values of an enumerated property.
GetString | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
Put | Set the value of the specified property and return the old value.
RemoveFromIntArray | Remove an array item from a property whose value is an integer array.
ToString | Delegate ToString() to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.AddToIntArray Method

Add a new array item to a property whose value is an integer array.

public virtual void AddToIntArray(
String countProperty,
String dataProperty,
Int32 value
);

Parameters

countProperty
the name of the property containing the count of values in the array.
dataProperty
the name of the property containing the array.
value
the new item to add to the array.

See Also

TypedResource Class | Borland.StarTeam Namespace | getIntArray | removeFromIntArray


TypedResource.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.TypedResource

Implements

IWrapper.Unwrap

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.Equals Method

Delegate Equals() to com.starbase.starteam.TypedResource.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.TypedResource.Equals(obj).

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.Get Method

Return the value for the specified property.

public virtual object Get(
String propertyName
);

Parameters

propertyName
the name of property to be retreived

Return Value

the value of the specified property

Exceptions

Exception Type | Condition
 | com.starbase.starteam.NoSuchPropertyException

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.GetByteArray Method

A convenience method for returning byte[] valued properties.

public virtual byte[] GetByteArray(
String propertyName
);

Parameters

propertyName
the name of the property to be retrieved

Return Value

the byte array value of the specified property

Exceptions

Exception Type | Condition
 | com.starbase.starteam.NoSuchPropertyException
 | System.InvalidCastException

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.GetDouble Method

A convenience method for returning double valued properties.

public virtual double GetDouble(
String propertyName
);

Parameters

propertyName
the name of the property to be retrieved

Return Value

the double value of the specified property

Exceptions

Exception Type | Condition
 | com.starbase.starteam.NoSuchPropertyException
 | System.InvalidCastException

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.GetEnumDisplayName Method

A convenience method for returning the display name for a given value of an enumerated property.

public virtual string GetEnumDisplayName(
String propertyName,
Int32 value
);

Parameters

propertyName
the name of the property
value
one of the possible enumerated values of the indicated property

Return Value

a user-friendly display name for the given value

See Also

TypedResource Class | Borland.StarTeam Namespace | getEnumDisplayName


TypedResource.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.TypedResource.

public override int GetHashCode();

Return Value

com.starbase.starteam.TypedResource.GetHashCode().

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.GetInt Method

A convenience method for returning integer valued properties.

public virtual int GetInt(
String propertyName
);

Parameters

propertyName
the name of the property to be retrieved

Return Value

the integer value of the specified property

Exceptions

Exception Type | Condition
 | com.starbase.starteam.NoSuchPropertyException
 | System.InvalidCastException

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.GetIntArray Method

A convenience method for returning int[] valued properties.

public virtual int[] GetIntArray(
String propertyName
);

Parameters

propertyName
the name of the property to be retrieved

Return Value

the int array value of the specified property

Exceptions

Exception Type | Condition
 | com.starbase.starteam.NoSuchPropertyException
 | System.InvalidCastException

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.GetOLEDate Method

A convenience method for returning OLEDate valued properties.

public virtual DateTime GetOLEDate(
String propertyName
);

Parameters

propertyName
the name of the property to be retrieved

Return Value

the String value of the specified property

Exceptions

Exception Type | Condition
 | com.starbase.starteam.NoSuchPropertyException
 | System.InvalidCastException

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.GetPossibleValues Method

A convenience method for returning an array of the possible values of an enumerated property.

public virtual int[] GetPossibleValues(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

an array of the possible values for the indicated property

See Also

TypedResource Class | Borland.StarTeam Namespace | getEnumValues


TypedResource.GetString Method

A convenience method for returning String valued properties.

public virtual string GetString(
String propertyName
);

Parameters

propertyName
the name of the property to be retrieved

Return Value

the String value of the specified property

Exceptions

Exception Type | Condition
 | com.starbase.starteam.NoSuchPropertyException
 | System.InvalidCastException

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.Put Method

Set the value of the specified property and return the old value.

public virtual object Put(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property to set
value
the new value to set for the specified property

Return Value

the old property value

Exceptions

Exception Type | Condition
 | com.starbase.starteam.NoSuchPropertyException
 | System.InvalidCastException

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.RemoveFromIntArray Method

Remove an array item from a property whose value is an integer array.

public virtual void RemoveFromIntArray(
String countProperty,
String dataProperty,
Int32 value
);

Parameters

countProperty
the name of the property containing the count of values in the array.
dataProperty
the name of the property containing the array.
value
the item to remove from the array.

See Also

TypedResource Class | Borland.StarTeam Namespace | getIntArray | addToIntArray


TypedResource.ToString Method

Delegate ToString() to com.starbase.starteam.TypedResource.

public override string ToString();

Return Value

com.starbase.starteam.TypedResource.ToString()

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource.Wrap Method

Dynamically wraps com.starbase.starteam.TypedResource.

public static TypedResource Wrap(
TypedResource impl
);

Parameters

impl
com.starbase.starteam.TypedResource to be wrapped.

Return Value

TypedResource

See Also

TypedResource Class | Borland.StarTeam Namespace


TypedResource Type Conversions

The type conversions of the TypedResource class are listed below. For a complete list of TypedResource class members, see the TypedResource Members topic.

Public Static Type Conversions

Implicit TypedResource to TypedResource Conversion Implicitly convert TypedResource to com.starbase.starteam.TypedResource.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypedResource Class | TypedResource Members | Borland.StarTeam Namespace


TypedResource Implicit TypedResource to TypedResource Conversion

Implicitly convert TypedResource to com.starbase.starteam.TypedResource.

public static implicit operator TypedResource(
TypedResource arg
);

Parameters

arg
TypedResource to convert.

Return Value

com.starbase.starteam.TypedResource

See Also

TypedResource Class | Borland.StarTeam Namespace


TypeEventArgs Class

For a list of all members of this type, see TypeEventArgs Members.

System.Object
EventArgs
TypeEventArgs

public class TypeEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

TypeEventArgs Members | Borland.StarTeam Namespace


TypeEventArgs Members

TypeEventArgs overview

Public Static Type Conversions

Implicit TypeEventArgs to TypeEvent Conversion Implicitly convert TypeEventArgs to com.starbase.starteam.TypeEvent.

Public Instance Properties

Type [read] The Type that has changed, in its new state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

TypeEventArgs Class | Borland.StarTeam Namespace


TypeEventArgs Properties

The properties of the TypeEventArgs class are listed below. For a complete list of TypeEventArgs class members, see the TypeEventArgs Members topic.

Public Instance Properties

Type [read] The Type that has changed, in its new state.

See Also

TypeEventArgs Class | Borland.StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

TypeEventArgs.Type Property

[read] The Type that has changed, in its new state.

public virtual Type Type {get;}

Property Value

The Type that has changed, in its new state.

See Also

TypeEventArgs Class | Borland.StarTeam Namespace


TypeEventArgs Methods

The methods of the TypeEventArgs class are listed below. For a complete list of TypeEventArgs class members, see the TypeEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

TypeEventArgs Class | Borland.StarTeam Namespace


TypeEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

TypeEventArgs Class | Borland.StarTeam Namespace


TypeEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

TypeEventArgs Class | Borland.StarTeam Namespace


TypeEventArgs.ToString Method

public override string ToString();

See Also

TypeEventArgs Class | Borland.StarTeam Namespace


TypeEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

TypeEventArgs Class | Borland.StarTeam Namespace


TypeEventArgs Type Conversions

The type conversions of the TypeEventArgs class are listed below. For a complete list of TypeEventArgs class members, see the TypeEventArgs Members topic.

Public Static Type Conversions

Implicit TypeEventArgs to TypeEvent Conversion Implicitly convert TypeEventArgs to com.starbase.starteam.TypeEvent.

See Also

TypeEventArgs Class | TypeEventArgs Members | Borland.StarTeam Namespace


TypeEventArgs Implicit TypeEventArgs to TypeEvent Conversion

Implicitly convert TypeEventArgs to com.starbase.starteam.TypeEvent.

public static implicit operator TypeEvent(
TypeEventArgs arg
);

Parameters

arg
TypeEventArgs to convert.

Return Value

com.starbase.starteam.TypeEvent

See Also

TypeEventArgs Class | Borland.StarTeam Namespace


TypeEventSource Class

For a list of all members of this type, see TypeEventSource Members.

System.Object
TypeEventSource

public class TypeEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

TypeEventSource Members | Borland.StarTeam Namespace


TypeEventSource Members

TypeEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnTypeChanged
TypeChanged

See Also

TypeEventSource Class | Borland.StarTeam Namespace


TypeEventSource Properties

The properties of the TypeEventSource class are listed below. For a complete list of TypeEventSource class members, see the TypeEventSource Members topic.

Public Instance Properties

Parent

See Also

TypeEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

TypeEventSource.Parent Property

public Object Parent {get;}

See Also

TypeEventSource Class | Borland.StarTeam Namespace


TypeEventSource Events

The events of the TypeEventSource class are listed below. For a complete list of TypeEventSource class members, see the TypeEventSource Members topic.

Public Instance Events

OnTypeChanged
TypeChanged

See Also

TypeEventSource Class | Borland.StarTeam Namespace


TypeEventSource.OnTypeChanged Event

public event TypeEventSource.Handler OnTypeChanged;

See Also

TypeEventSource Class | Borland.StarTeam Namespace


TypeEventSource.TypeChanged Event

public event TypeEventSource.Handler TypeChanged;

See Also

TypeEventSource Class | Borland.StarTeam Namespace


TypeEventSource.Handler Delegate

public delegate void TypeEventSource.Handler(
TypeEventSource source,
TypeEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


TypeNames Class

TypeNames is a class defining pseudo-constants for the names of various types in StarTeam.

For a list of all members of this type, see TypeNames Members.

System.Object
TypeNames

public class TypeNames : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

TypeNames Members | Borland.StarTeam Namespace


TypeNames Members

TypeNames overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.TypeNames.

Public Static Type Conversions

Implicit TypeNames to TypeNames Conversion Implicitly convert TypeNames to com.starbase.starteam.TypeNames.

Public Instance Constructors

TypeNames Constructor Construct TypeNames from com.starbase.starteam.TypeNames.

Public Instance Properties

AUDIT |
CHANGEREQUEST |
FILE |
FOLDER |
ITEM |
ITEM_REFERENCE |
ITEM_REVISION |
LABEL |
LINK |
MappedValues | [read]
PROJECT |
PROMOTIONMODEL |
PROMOTIONSTATE |
REQUIREMENT |
TASK |
TASKDEPENDENCY |
TOPIC |
TYPE |
USER |
USERACCOUNT |
VIEW |
WORKRECORD |

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.TypeNames.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.TypeNames.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.TypeNames.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypeNames Class | Borland.StarTeam Namespace


TypeNames Constructor

Construct TypeNames from com.starbase.starteam.TypeNames.

public TypeNames(
TypeNames impl
);

Parameters

impl
The com.starbase.starteam.TypeNames to be wrapped.

See Also

TypeNames Class | Borland.StarTeam Namespace


TypeNames Properties

The properties of the TypeNames class are listed below. For a complete list of TypeNames class members, see the TypeNames Members topic.

Public Instance Properties

AUDIT |
CHANGEREQUEST |
FILE |
FOLDER |
ITEM |
ITEM_REFERENCE |
ITEM_REVISION |
LABEL |
LINK |
MappedValues | [read]
PROJECT |
PROMOTIONMODEL |
PROMOTIONSTATE |
REQUIREMENT |
TASK |
TASKDEPENDENCY |
TOPIC |
TYPE |
USER |
USERACCOUNT |
VIEW |
WORKRECORD |

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypeNames Class | Borland.StarTeam Namespace


AUDIT Property

Borland StarTeam SDK for .NET

TypeNames.AUDIT Property

public String AUDIT {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


CHANGEREQUEST Property

Borland StarTeam SDK for .NET

TypeNames.CHANGEREQUEST Property

public String CHANGEREQUEST {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


FILE Property

Borland StarTeam SDK for .NET

TypeNames.FILE Property

public String FILE {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


FOLDER Property

Borland StarTeam SDK for .NET

TypeNames.FOLDER Property

public String FOLDER {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


ITEM Property

Borland StarTeam SDK for .NET

TypeNames.ITEM Property

public String ITEM {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


ITEM_REFERENCE Property

Borland StarTeam SDK for .NET

TypeNames.ITEM_REFERENCE Property

public String ITEM_REFERENCE {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


ITEM_REVISION Property

Borland StarTeam SDK for .NET

TypeNames.ITEM_REVISION Property

public String ITEM_REVISION {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


LABEL Property

Borland StarTeam SDK for .NET

TypeNames.LABEL Property

public String LABEL {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


LINK Property

Borland StarTeam SDK for .NET

TypeNames.LINK Property

public String LINK {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


MappedValues Property

Borland StarTeam SDK for .NET

TypeNames.MappedValues Property

[read]

public virtual String[] MappedValues {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


PROJECT Property

Borland StarTeam SDK for .NET

TypeNames.PROJECT Property

public String PROJECT {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


PROMOTIONMODEL Property

Borland StarTeam SDK for .NET

TypeNames.PROMOTIONMODEL Property

public String PROMOTIONMODEL {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


PROMOTIONSTATE Property

Borland StarTeam SDK for .NET

TypeNames.PROMOTIONSTATE Property

public String PROMOTIONSTATE {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


REQUIREMENT Property

Borland StarTeam SDK for .NET

TypeNames.REQUIREMENT Property

public String REQUIREMENT {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


TASK Property

Borland StarTeam SDK for .NET

TypeNames.TASK Property

public String TASK {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


TASKDEPENDENCY Property

Borland StarTeam SDK for .NET

TypeNames.TASKDEPENDENCY Property

public String TASKDEPENDENCY {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


TOPIC Property

Borland StarTeam SDK for .NET

TypeNames.TOPIC Property

public String TOPIC {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


TYPE Property

Borland StarTeam SDK for .NET

TypeNames.TYPE Property

public String TYPE {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


USER Property

Borland StarTeam SDK for .NET

TypeNames.USER Property

public String USER {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


USERACCOUNT Property

Borland StarTeam SDK for .NET

TypeNames.USERACCOUNT Property

public String USERACCOUNT {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

TypeNames.VIEW Property

public String VIEW {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


WORKRECORD Property

Borland StarTeam SDK for .NET

TypeNames.WORKRECORD Property

public String WORKRECORD {get;}

See Also

TypeNames Class | Borland.StarTeam Namespace


TypeNames Methods

The methods of the TypeNames class are listed below. For a complete list of TypeNames class members, see the TypeNames Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.TypeNames.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.TypeNames.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.TypeNames.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.TypeNames.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypeNames Class | Borland.StarTeam Namespace


TypeNames.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.TypeNames

Implements

IWrapper.Unwrap

See Also

TypeNames Class | Borland.StarTeam Namespace


TypeNames.Equals Method

Delegate Equals() to com.starbase.starteam.TypeNames.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.TypeNames.Equals(obj).

See Also

TypeNames Class | Borland.StarTeam Namespace


TypeNames.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.TypeNames.

public override int GetHashCode();

Return Value

com.starbase.starteam.TypeNames.GetHashCode().

See Also

TypeNames Class | Borland.StarTeam Namespace


TypeNames.ToString Method

Delegate ToString() to com.starbase.starteam.TypeNames.

public override string ToString();

Return Value

com.starbase.starteam.TypeNames.ToString()

See Also

TypeNames Class | Borland.StarTeam Namespace


TypeNames.Wrap Method

Dynamically wraps com.starbase.starteam.TypeNames.

public static TypeNames Wrap(
TypeNames impl
);

Parameters

impl
com.starbase.starteam.TypeNames to be wrapped.

Return Value

TypeNames

See Also

TypeNames Class | Borland.StarTeam Namespace


TypeNames Type Conversions

The type conversions of the TypeNames class are listed below. For a complete list of TypeNames class members, see the TypeNames Members topic.

Public Static Type Conversions

Implicit TypeNames to TypeNames Conversion Implicitly convert TypeNames to com.starbase.starteam.TypeNames.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypeNames Class | TypeNames Members | Borland.StarTeam Namespace


TypeNames Implicit TypeNames to TypeNames Conversion

Implicitly convert TypeNames to com.starbase.starteam.TypeNames.

public static implicit operator TypeNames(
TypeNames arg
);

Parameters

arg
TypeNames to convert.

Return Value

com.starbase.starteam.TypeNames

See Also

TypeNames Class | Borland.StarTeam Namespace


TypeNotFoundException Class

For a list of all members of this type, see TypeNotFoundException Members.

System.Object
Exception
TypeNotFoundException

public class TypeNotFoundException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

TypeNotFoundException Members | Borland.StarTeam Namespace


TypeNotFoundException Members

TypeNotFoundException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.TypeNotFoundException.

Public Static Type Conversions

Implicit TypeNotFoundException to TypeNotFoundException Conversion Implicitly convert TypeNotFoundException to com.starbase.starteam.TypeNotFoundException.

Public Instance Constructors

TypeNotFoundException Overloaded. Initializes a new instance of the TypeNotFoundException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TypeID |
TypeName |

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.TypeNotFoundException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.TypeNotFoundException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.TypeNotFoundException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


TypeNotFoundException Constructor

Construct TypeNotFoundException from com.starbase.starteam.TypeNotFoundException.

Overload List

Construct TypeNotFoundException from com.starbase.starteam.TypeNotFoundException.

public TypeNotFoundException(TypeNotFoundException);

public TypeNotFoundException(Int32);

public TypeNotFoundException(String);

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


TypeNotFoundException Constructor (TypeNotFoundException)

Construct TypeNotFoundException from com.starbase.starteam.TypeNotFoundException.

public TypeNotFoundException(
TypeNotFoundException impl
);

Parameters

impl
The com.starbase.starteam.TypeNotFoundException to be wrapped.

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace | TypeNotFoundException Constructor Overload List


TypeNotFoundException Constructor (String)

public TypeNotFoundException(
String typeName
);

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace | TypeNotFoundException Constructor Overload List


TypeNotFoundException Constructor (Int32)

public TypeNotFoundException(
Int32 typeID
);

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace | TypeNotFoundException Constructor Overload List


TypeNotFoundException Properties

The properties of the TypeNotFoundException class are listed below. For a complete list of TypeNotFoundException class members, see the TypeNotFoundException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TypeID |
TypeName |

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


TypeID Property

Borland StarTeam SDK for .NET

TypeNotFoundException.TypeID Property

public virtual Int32 TypeID {get;}

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


TypeName Property

Borland StarTeam SDK for .NET

TypeNotFoundException.TypeName Property

public virtual String TypeName {get;}

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


TypeNotFoundException Methods

The methods of the TypeNotFoundException class are listed below. For a complete list of TypeNotFoundException class members, see the TypeNotFoundException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.TypeNotFoundException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.TypeNotFoundException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.TypeNotFoundException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.TypeNotFoundException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


TypeNotFoundException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.TypeNotFoundException

Implements

IWrapper.Unwrap

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


TypeNotFoundException.Equals Method

Delegate Equals() to com.starbase.starteam.TypeNotFoundException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.TypeNotFoundException.Equals(obj).

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


TypeNotFoundException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.TypeNotFoundException.

public override int GetHashCode();

Return Value

com.starbase.starteam.TypeNotFoundException.GetHashCode().

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


TypeNotFoundException.ToString Method

Delegate ToString() to com.starbase.starteam.TypeNotFoundException.

public override string ToString();

Return Value

com.starbase.starteam.TypeNotFoundException.ToString()

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


TypeNotFoundException.Wrap Method

Dynamically wraps com.starbase.starteam.TypeNotFoundException.

public static TypeNotFoundException Wrap(
TypeNotFoundException impl
);

Parameters

impl
com.starbase.starteam.TypeNotFoundException to be wrapped.

Return Value

TypeNotFoundException

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


TypeNotFoundException Type Conversions

The type conversions of the TypeNotFoundException class are listed below. For a complete list of TypeNotFoundException class members, see the TypeNotFoundException Members topic.

Public Static Type Conversions

Implicit TypeNotFoundException to TypeNotFoundException Conversion Implicitly convert TypeNotFoundException to com.starbase.starteam.TypeNotFoundException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

TypeNotFoundException Class | TypeNotFoundException Members | Borland.StarTeam Namespace


TypeNotFoundException Implicit TypeNotFoundException to TypeNotFoundException Conversion

Implicitly convert TypeNotFoundException to com.starbase.starteam.TypeNotFoundException.

public static implicit operator TypeNotFoundException(
TypeNotFoundException arg
);

Parameters

arg
TypeNotFoundException to convert.

Return Value

com.starbase.starteam.TypeNotFoundException

See Also

TypeNotFoundException Class | Borland.StarTeam Namespace


User Class

Represents a StarTeam user. Only a limited subset of the whole user information is available. The UserAccount class has the full user information but it is only accessible to user's with the appropriate permissions.

For a list of all members of this type, see User Members.

System.Object
CacheRef
User

public class User : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

User Members | Borland.StarTeam Namespace


User Members

User overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.User.

Public Static Type Conversions

Implicit User to User Conversion Implicitly convert User to com.starbase.starteam.User.

Public Instance Constructors

User Constructor Construct User from com.starbase.starteam.User.

Public Instance Properties

ID | [read] the integer idenitifier for this user.
IsDeleted | [read] true if this user has been deleted.
Name | [read] the user's name
Server | [read] the Server object to which this user belongs.

Public Instance Methods

Clone (inherited from CacheRef) |
Copy | Creates a copy of this User object. Useful to applications that want to save a snapshot of the user in a given state, for example, before calling Server.refreshUsers().
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two User objects.
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

User Class | Borland.StarTeam Namespace


User Constructor

Construct User from com.starbase.starteam.User.

public User(
User impl
);

Parameters

impl
The com.starbase.starteam.User to be wrapped.

See Also

User Class | Borland.StarTeam Namespace


User Properties

The properties of the User class are listed below. For a complete list of User class members, see the User Members topic.

Public Instance Properties

ID | [read] the integer idenitifier for this user.
IsDeleted | [read] true if this user has been deleted.
Name | [read] the user's name
Server | [read] the Server object to which this user belongs.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

User Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

User.ID Property

[read] the integer idenitifier for this user.

public virtual Int32 ID {get;}

Property Value

the integer idenitifier for this user.

See Also

User Class | Borland.StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

User.IsDeleted Property

[read] true if this user has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if this user has been deleted.

See Also

User Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

User.Name Property

[read] the user's name

public virtual String Name {get;}

Property Value

the user's name

See Also

User Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

User.Server Property

[read] the Server object to which this user belongs.

public virtual Server Server {get;}

Property Value

the Server object to which this user belongs.

See Also

User Class | Borland.StarTeam Namespace


User Methods

The methods of the User class are listed below. For a complete list of User class members, see the User Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.User.

Public Instance Methods

Clone (inherited from CacheRef) |
Copy | Creates a copy of this User object. Useful to applications that want to save a snapshot of the user in a given state, for example, before calling Server.refreshUsers().
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two User objects.
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

User Class | Borland.StarTeam Namespace


User.Copy Method

Creates a copy of this User object. Useful to applications that want to save a snapshot of the user in a given state, for example, before calling Server.refreshUsers().

public virtual User Copy();

Return Value

A new copy of this User object.

See Also

User Class | Borland.StarTeam Namespace | isEqualTo


User.IsEqualTo Method

Compares two User objects.

public virtual bool IsEqualTo(
User user
);

Parameters

user
The User to be compared with this one.

Return Value

true if no differences were found.

See Also

User Class | Borland.StarTeam Namespace | copy


User.Wrap Method

Dynamically wraps com.starbase.starteam.User.

public static User Wrap(
User impl
);

Parameters

impl
com.starbase.starteam.User to be wrapped.

Return Value

User

See Also

User Class | Borland.StarTeam Namespace


User Type Conversions

The type conversions of the User class are listed below. For a complete list of User class members, see the User Members topic.

Public Static Type Conversions

Implicit User to User Conversion Implicitly convert User to com.starbase.starteam.User.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

User Class | User Members | Borland.StarTeam Namespace


User Implicit User to User Conversion

Implicitly convert User to com.starbase.starteam.User.

public static implicit operator User(
User arg
);

Parameters

arg
User to convert.

Return Value

com.starbase.starteam.User

See Also

User Class | Borland.StarTeam Namespace


UserAccount Class

Represents a StarTeam user account. That is, an active user account on a StarTeam Server. This is not to be confused with a User object which simply represents a user that does participate or has participated in operations on the items in the repository.

For a list of all members of this type, see UserAccount Members.

System.Object
CacheRef
UserAccount

public class UserAccount : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

UserAccount Members | Borland.StarTeam Namespace


UserAccount Members

UserAccount overview

Public Static Properties

DAY_FRIDAY
DAY_MONDAY
DAY_SATURDAY
DAY_SUNDAY
DAY_THURSDAY
DAY_TUESDAY
DAY_WEDNESDAY
LICENSE_TYPE_LICENSE_SERVER
LICENSE_TYPE_STARTEAM
LICENSE_TYPE_UNASSIGNED
POLICY_ALWAYS
POLICY_CUSTOM
POLICY_STANDARD
STATUS_LOCKED_OUT
STATUS_NORMAL
STATUS_PASSWORD_CHANGE_NOTIFIED
STATUS_PASSWORD_CHANGE_REQUIRED
STATUS_SUSPENDED

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.UserAccount.

Public Static Type Conversions

Implicit UserAccount to UserAccount Conversion Implicitly convert UserAccount to com.starbase.starteam.UserAccount.

Public Instance Constructors

UserAccount Overloaded. Initializes a new instance of the UserAccount class.

Public Instance Properties

AccessPolicy | [read/write] this account's access policy
AccountStatus | [read/write] this account's status.
BLSSlipGuid | [read/write] The Slip ID assigned to this license, or 0 if this user does not have a license managed by the Borland License Server.
CreatedTime | [read] The time at which this UserAccount was created.
DistinguishedName | [read/write] the Distinguished Name for Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.
EmailAddress | [read/write] the user's email address.
FaxNumber | [read/write] the user's fax number.
GroupAccounts | [read] all of the group accounts to which this user belongs.
HasFixedLicense | [read/write] True if this user has a fixed ( named-user ) license; false if this user has a floating ( concurrent ) license. Note that if the StarTeam Server does not support floating licenses, then every user has a fixed license.
ID | [read] an integer ID that represents this user account.
IsNew | [read] true is this user account has not yet been created in the server.
LicenseType | [read/write] The type of license assigned to this user.
LogOnCount | [read] the number of times this user is logged in to the server.
LogOnName | [read/write] the logon name or identifier for this account.
Name | [read/write] the full name that this user goes by.
PagerNumber | [read/write] the user's pager number.
Password | [write] Sets the password for this account. The password should be passed in as clear text.
PhoneNumber | [read/write] the user's phone number.
PolicyTimeZoneShift | [read/write] this timezone shift for this account's access policy.
PostalAddress | [read/write] the user's postal address.
ValidateThroughDirectoryService | [read/write] true if the user validates through Directory Service, otherwise false. This property is supported by server release 6.0 and later; ignored for earlier releases. Note that when setting this value to false, a valid password must also be set.
VoiceMailNumber | [read/write] the user's voice mail number.
Workstations | [read] a list of workstation names.

Public Instance Methods

AddToGroupAccount | Adds this user to the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call update() to save the changes on the server.
Clone (inherited from CacheRef) |
Copy | Creates a copy of this UserAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
ForceLogoff | Forces this user account to be logged off from the server. The effect is immediate ( no need to call the update() method ).
ForcePasswordChange | Forces a password change for this user account. The effect is immediate ( no need to call the update() method ).
GetAccessEndTime1 | Returns the end time for the specified day for the first custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the first custom access policy.
GetAccessEndTime2 | Returns the end time for the specified day for the second custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the second custom access policy.
GetAccessStartTime1 | Returns the start time for the specified day for the first custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the first custom access policy.
GetAccessStartTime2 | Returns the start time for the specified day for the second custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the second custom access policy.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two UserAccount objects.
Reactivate | Reactivates this user account. The effect is immediate ( no need to call the update() method ).
Remove | Removes this user account from the server, and from any group of which it is a member.
RemoveFromGroupAccount | Removes this user from the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call update() to save the changes on the server.
SetAccessTimes | Changes the custom access policy start and end times for the specified day of the week.
Suspend | Suspend this user account. The effect is immediate ( no need to call the update() method ).
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.
Unlock | Unlocks this user account. The effect is immediate ( no need to call the update() method ).
Update | Create or modify this UserAccount in the StarTeam Server. If the account is new it will be created otherwise the account information will be modified.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount Constructor

Construct UserAccount from com.starbase.starteam.UserAccount.

Overload List

Creates a new user account to be activated on the server. The new account will not actually be created until update() is called.

public UserAccount(Server);

Construct UserAccount from com.starbase.starteam.UserAccount.

public UserAccount(UserAccount);

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount Constructor (UserAccount)

Construct UserAccount from com.starbase.starteam.UserAccount.

public UserAccount(
UserAccount impl
);

Parameters

impl
The com.starbase.starteam.UserAccount to be wrapped.

See Also

UserAccount Class | Borland.StarTeam Namespace | UserAccount Constructor Overload List


UserAccount Constructor (Server)

Creates a new user account to be activated on the server. The new account will not actually be created until update() is called.

public UserAccount(
Server server
);

Parameters

server
the server where the new account is to be created

See Also

UserAccount Class | Borland.StarTeam Namespace | UserAccount Constructor Overload List


UserAccount Properties

The properties of the UserAccount class are listed below. For a complete list of UserAccount class members, see the UserAccount Members topic.

Public Static Properties

DAY_FRIDAY
DAY_MONDAY
DAY_SATURDAY
DAY_SUNDAY
DAY_THURSDAY
DAY_TUESDAY
DAY_WEDNESDAY
LICENSE_TYPE_LICENSE_SERVER
LICENSE_TYPE_STARTEAM
LICENSE_TYPE_UNASSIGNED
POLICY_ALWAYS
POLICY_CUSTOM
POLICY_STANDARD
STATUS_LOCKED_OUT
STATUS_NORMAL
STATUS_PASSWORD_CHANGE_NOTIFIED
STATUS_PASSWORD_CHANGE_REQUIRED
STATUS_SUSPENDED

Public Instance Properties

AccessPolicy | [read/write] this account's access policy
AccountStatus | [read/write] this account's status.
BLSSlipGuid | [read/write] The Slip ID assigned to this license, or 0 if this user does not have a license managed by the Borland License Server.
CreatedTime | [read] The time at which this UserAccount was created.
DistinguishedName | [read/write] the Distinguished Name for Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.
EmailAddress | [read/write] the user's email address.
FaxNumber | [read/write] the user's fax number.
GroupAccounts | [read] all of the group accounts to which this user belongs.
HasFixedLicense | [read/write] True if this user has a fixed ( named-user ) license; false if this user has a floating ( concurrent ) license. Note that if the StarTeam Server does not support floating licenses, then every user has a fixed license.
ID | [read] an integer ID that represents this user account.
IsNew | [read] true is this user account has not yet been created in the server.
LicenseType | [read/write] The type of license assigned to this user.
LogOnCount | [read] the number of times this user is logged in to the server.
LogOnName | [read/write] the logon name or identifier for this account.
Name | [read/write] the full name that this user goes by.
PagerNumber | [read/write] the user's pager number.
Password | [write] Sets the password for this account. The password should be passed in as clear text.
PhoneNumber | [read/write] the user's phone number.
PolicyTimeZoneShift | [read/write] this timezone shift for this account's access policy.
PostalAddress | [read/write] the user's postal address.
ValidateThroughDirectoryService | [read/write] true if the user validates through Directory Service, otherwise false. This property is supported by server release 6.0 and later; ignored for earlier releases. Note that when setting this value to false, a valid password must also be set.
VoiceMailNumber | [read/write] the user's voice mail number.
Workstations | [read] a list of workstation names.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

UserAccount Class | Borland.StarTeam Namespace


AccessPolicy Property

Borland StarTeam SDK for .NET

UserAccount.AccessPolicy Property

[read/write] this account's access policy

public virtual Int32 AccessPolicy {get; set;}

Property Value

this account's access policy

See Also

UserAccount Class | Borland.StarTeam Namespace


AccountStatus Property

Borland StarTeam SDK for .NET

UserAccount.AccountStatus Property

[read/write] this account's status.

public virtual Int32 AccountStatus {get; set;}

Property Value

this account's status.

See Also

UserAccount Class | Borland.StarTeam Namespace


BLSSlipGuid Property

Borland StarTeam SDK for .NET

UserAccount.BLSSlipGuid Property

[read/write] The Slip ID assigned to this license, or 0 if this user does not have a license managed by the Borland License Server.

public virtual Int32 BLSSlipGuid {get; set;}

Property Value

The Slip ID assigned to this license, or 0 if this user does not have a license managed by the Borland License Server.

See Also

UserAccount Class | Borland.StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

UserAccount.CreatedTime Property

[read] The time at which this UserAccount was created.

public virtual DateTime CreatedTime {get;}

Property Value

The time at which this UserAccount was created.

See Also

UserAccount Class | Borland.StarTeam Namespace


DAY_FRIDAY Property

Borland StarTeam SDK for .NET

UserAccount.DAY_FRIDAY Property

public static Int32 DAY_FRIDAY {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


DAY_MONDAY Property

Borland StarTeam SDK for .NET

UserAccount.DAY_MONDAY Property

public static Int32 DAY_MONDAY {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


DAY_SATURDAY Property

Borland StarTeam SDK for .NET

UserAccount.DAY_SATURDAY Property

public static Int32 DAY_SATURDAY {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


DAY_SUNDAY Property

Borland StarTeam SDK for .NET

UserAccount.DAY_SUNDAY Property

public static Int32 DAY_SUNDAY {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


DAY_THURSDAY Property

Borland StarTeam SDK for .NET

UserAccount.DAY_THURSDAY Property

public static Int32 DAY_THURSDAY {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


DAY_TUESDAY Property

Borland StarTeam SDK for .NET

UserAccount.DAY_TUESDAY Property

public static Int32 DAY_TUESDAY {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


DAY_WEDNESDAY Property

Borland StarTeam SDK for .NET

UserAccount.DAY_WEDNESDAY Property

public static Int32 DAY_WEDNESDAY {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


DistinguishedName Property

Borland StarTeam SDK for .NET

UserAccount.DistinguishedName Property

[read/write] the Distinguished Name for Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual String DistinguishedName {get; set;}

Property Value

the Distinguished Name for Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.

See Also

UserAccount Class | Borland.StarTeam Namespace


EmailAddress Property

Borland StarTeam SDK for .NET

UserAccount.EmailAddress Property

[read/write] the user's email address.

public virtual String EmailAddress {get; set;}

Property Value

the user's email address.

See Also

UserAccount Class | Borland.StarTeam Namespace


FaxNumber Property

Borland StarTeam SDK for .NET

UserAccount.FaxNumber Property

[read/write] the user's fax number.

public virtual String FaxNumber {get; set;}

Property Value

the user's fax number.

See Also

UserAccount Class | Borland.StarTeam Namespace


GroupAccounts Property

Borland StarTeam SDK for .NET

UserAccount.GroupAccounts Property

[read] all of the group accounts to which this user belongs.

public virtual GroupAccountCollection GroupAccounts {get;}

Property Value

all of the group accounts to which this user belongs.

See Also

UserAccount Class | Borland.StarTeam Namespace


HasFixedLicense Property

Borland StarTeam SDK for .NET

UserAccount.HasFixedLicense Property

[read/write] True if this user has a fixed ( named-user ) license; false if this user has a floating ( concurrent ) license. Note that if the StarTeam Server does not support floating licenses, then every user has a fixed license.

public virtual Boolean HasFixedLicense {get; set;}

Property Value

True if this user has a fixed ( named-user ) license; false if this user has a floating ( concurrent ) license. Note that if the StarTeam Server does not support floating licenses, then every user has a fixed license.

See Also

UserAccount Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

UserAccount.ID Property

[read] an integer ID that represents this user account.

public virtual Int32 ID {get;}

Property Value

an integer ID that represents this user account.

See Also

UserAccount Class | Borland.StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

UserAccount.IsNew Property

[read] true is this user account has not yet been created in the server.

public virtual Boolean IsNew {get;}

Property Value

true is this user account has not yet been created in the server.

See Also

UserAccount Class | Borland.StarTeam Namespace


LICENSE_TYPE_LICENSE_SERVER Property

Borland StarTeam SDK for .NET

UserAccount.LICENSE_TYPE_LICENSE_SERVER Property

public static Int32 LICENSE_TYPE_LICENSE_SERVER {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


LICENSE_TYPE_STARTEAM Property

Borland StarTeam SDK for .NET

UserAccount.LICENSE_TYPE_STARTEAM Property

public static Int32 LICENSE_TYPE_STARTEAM {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


LICENSE_TYPE_UNASSIGNED Property

Borland StarTeam SDK for .NET

UserAccount.LICENSE_TYPE_UNASSIGNED Property

public static Int32 LICENSE_TYPE_UNASSIGNED {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


LicenseType Property

Borland StarTeam SDK for .NET

UserAccount.LicenseType Property

[read/write] The type of license assigned to this user.

public virtual Int32 LicenseType {get; set;}

Property Value

The type of license assigned to this user.

See Also

UserAccount Class | Borland.StarTeam Namespace


LogOnCount Property

Borland StarTeam SDK for .NET

UserAccount.LogOnCount Property

[read] the number of times this user is logged in to the server.

public virtual Int32 LogOnCount {get;}

Property Value

the number of times this user is logged in to the server.

See Also

UserAccount Class | Borland.StarTeam Namespace


LogOnName Property

Borland StarTeam SDK for .NET

UserAccount.LogOnName Property

[read/write] the logon name or identifier for this account.

public virtual String LogOnName {get; set;}

Property Value

the logon name or identifier for this account.

See Also

UserAccount Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

UserAccount.Name Property

[read/write] the full name that this user goes by.

public virtual String Name {get; set;}

Property Value

the full name that this user goes by.

See Also

UserAccount Class | Borland.StarTeam Namespace


PagerNumber Property

Borland StarTeam SDK for .NET

UserAccount.PagerNumber Property

[read/write] the user's pager number.

public virtual String PagerNumber {get; set;}

Property Value

the user's pager number.

See Also

UserAccount Class | Borland.StarTeam Namespace


Password Property

Borland StarTeam SDK for .NET

UserAccount.Password Property

[write] Sets the password for this account. The password should be passed in as clear text.

public virtual String Password {set;}

Property Value

Sets the password for this account. The password should be passed in as clear text.

See Also

UserAccount Class | Borland.StarTeam Namespace


PhoneNumber Property

Borland StarTeam SDK for .NET

UserAccount.PhoneNumber Property

[read/write] the user's phone number.

public virtual String PhoneNumber {get; set;}

Property Value

the user's phone number.

See Also

UserAccount Class | Borland.StarTeam Namespace


POLICY_ALWAYS Property

Borland StarTeam SDK for .NET

UserAccount.POLICY_ALWAYS Property

public static Int32 POLICY_ALWAYS {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


POLICY_CUSTOM Property

Borland StarTeam SDK for .NET

UserAccount.POLICY_CUSTOM Property

public static Int32 POLICY_CUSTOM {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


POLICY_STANDARD Property

Borland StarTeam SDK for .NET

UserAccount.POLICY_STANDARD Property

public static Int32 POLICY_STANDARD {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


PolicyTimeZoneShift Property

Borland StarTeam SDK for .NET

UserAccount.PolicyTimeZoneShift Property

[read/write] this timezone shift for this account's access policy.

public virtual Int32 PolicyTimeZoneShift {get; set;}

Property Value

this timezone shift for this account's access policy.

See Also

UserAccount Class | Borland.StarTeam Namespace


PostalAddress Property

Borland StarTeam SDK for .NET

UserAccount.PostalAddress Property

[read/write] the user's postal address.

public virtual String PostalAddress {get; set;}

Property Value

the user's postal address.

See Also

UserAccount Class | Borland.StarTeam Namespace


STATUS_LOCKED_OUT Property

Borland StarTeam SDK for .NET

UserAccount.STATUS_LOCKED_OUT Property

public static Int32 STATUS_LOCKED_OUT {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


STATUS_NORMAL Property

Borland StarTeam SDK for .NET

UserAccount.STATUS_NORMAL Property

public static Int32 STATUS_NORMAL {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


STATUS_PASSWORD_CHANGE_NOTIFIED Property

Borland StarTeam SDK for .NET

UserAccount.STATUS_PASSWORD_CHANGE_NOTIFIED Property

public static Int32 STATUS_PASSWORD_CHANGE_NOTIFIED {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


STATUS_PASSWORD_CHANGE_REQUIRED Property

Borland StarTeam SDK for .NET

UserAccount.STATUS_PASSWORD_CHANGE_REQUIRED Property

public static Int32 STATUS_PASSWORD_CHANGE_REQUIRED {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


STATUS_SUSPENDED Property

Borland StarTeam SDK for .NET

UserAccount.STATUS_SUSPENDED Property

public static Int32 STATUS_SUSPENDED {get;}

See Also

UserAccount Class | Borland.StarTeam Namespace


ValidateThroughDirectoryService Property

Borland StarTeam SDK for .NET

UserAccount.ValidateThroughDirectoryService Property

[read/write] true if the user validates through Directory Service, otherwise false. This property is supported by server release 6.0 and later; ignored for earlier releases. Note that when setting this value to false, a valid password must also be set.

public virtual Boolean ValidateThroughDirectoryService {get; set;}

Property Value

true if the user validates through Directory Service, otherwise false. This property is supported by server release 6.0 and later; ignored for earlier releases. Note that when setting this value to false, a valid password must also be set.

See Also

UserAccount Class | Borland.StarTeam Namespace


VoiceMailNumber Property

Borland StarTeam SDK for .NET

UserAccount.VoiceMailNumber Property

[read/write] the user's voice mail number.

public virtual String VoiceMailNumber {get; set;}

Property Value

the user's voice mail number.

See Also

UserAccount Class | Borland.StarTeam Namespace


Workstations Property

Borland StarTeam SDK for .NET

UserAccount.Workstations Property

[read] a list of workstation names.

public virtual String[] Workstations {get;}

Property Value

a list of workstation names.

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount Methods

The methods of the UserAccount class are listed below. For a complete list of UserAccount class members, see the UserAccount Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.UserAccount.

Public Instance Methods

AddToGroupAccount | Adds this user to the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call update() to save the changes on the server.
Clone (inherited from CacheRef) |
Copy | Creates a copy of this UserAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals (inherited from CacheRef) | Delegate Equals() to com.starbase.starteam.CacheRef.
ForceLogoff | Forces this user account to be logged off from the server. The effect is immediate ( no need to call the update() method ).
ForcePasswordChange | Forces a password change for this user account. The effect is immediate ( no need to call the update() method ).
GetAccessEndTime1 | Returns the end time for the specified day for the first custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the first custom access policy.
GetAccessEndTime2 | Returns the end time for the specified day for the second custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the second custom access policy.
GetAccessStartTime1 | Returns the start time for the specified day for the first custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the first custom access policy.
GetAccessStartTime2 | Returns the start time for the specified day for the second custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the second custom access policy.
GetHashCode (inherited from CacheRef) | Delegate GetHashCode() to com.starbase.starteam.CacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two UserAccount objects.
Reactivate | Reactivates this user account. The effect is immediate ( no need to call the update() method ).
Remove | Removes this user account from the server, and from any group of which it is a member.
RemoveFromGroupAccount | Removes this user from the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call update() to save the changes on the server.
SetAccessTimes | Changes the custom access policy start and end times for the specified day of the week.
Suspend | Suspend this user account. The effect is immediate ( no need to call the update() method ).
ToString (inherited from CacheRef) | Delegate ToString() to com.starbase.starteam.CacheRef.
Unlock | Unlocks this user account. The effect is immediate ( no need to call the update() method ).
Update | Create or modify this UserAccount in the StarTeam Server. If the account is new it will be created otherwise the account information will be modified.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount.AddToGroupAccount Method

Adds this user to the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call update() to save the changes on the server.

public virtual void AddToGroupAccount(
GroupAccount groupAccount
);

Parameters

groupAccount
the group account to which this user will be added.

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount.Copy Method

Creates a copy of this UserAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().

public virtual UserAccount Copy();

Return Value

A new copy of this UserAccount object.

See Also

UserAccount Class | Borland.StarTeam Namespace | isEqualTo


UserAccount.ForceLogoff Method

Forces this user account to be logged off from the server. The effect is immediate ( no need to call the update() method ).

public virtual void ForceLogoff();

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount.ForcePasswordChange Method

Forces a password change for this user account. The effect is immediate ( no need to call the update() method ).

public virtual void ForcePasswordChange();

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount.GetAccessEndTime1 Method

Returns the end time for the specified day for the first custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the first custom access policy.

public virtual int GetAccessEndTime1(
Int32 dayOfWeek
);

Parameters

dayOfWeek
must be a valid day of the week

Return Value

the end time for the specified day for the first custom access policy.

See Also

UserAccount Class | Borland.StarTeam Namespace | DAY_SUNDAY | DAY_MONDAY | DAY_TUESDAY | DAY_WEDNESDAY | DAY_THURSDAY | DAY_FRIDAY | DAY_SATURDAY


UserAccount.GetAccessEndTime2 Method

Returns the end time for the specified day for the second custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the second custom access policy.

public virtual int GetAccessEndTime2(
Int32 dayOfWeek
);

Parameters

dayOfWeek
a valid day of the week, e.g. DAY_SUNDAY

Return Value

the end time for the specified day for the second custom access policy.

See Also

UserAccount Class | Borland.StarTeam Namespace | DAY_SUNDAY | DAY_MONDAY | DAY_TUESDAY | DAY_WEDNESDAY | DAY_THURSDAY | DAY_FRIDAY | DAY_SATURDAY


UserAccount.GetAccessStartTime1 Method

Returns the start time for the specified day for the first custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the first custom access policy.

public virtual int GetAccessStartTime1(
Int32 dayOfWeek
);

Parameters

dayOfWeek
must be a valid day of the week

Return Value

the start time for the specified day for the first custom access policy.

See Also

UserAccount Class | Borland.StarTeam Namespace | DAY_SUNDAY | DAY_MONDAY | DAY_TUESDAY | DAY_WEDNESDAY | DAY_THURSDAY | DAY_FRIDAY | DAY_SATURDAY


UserAccount.GetAccessStartTime2 Method

Returns the start time for the specified day for the second custom access policy. The time is expressed in minutes from midnight. A value of -1 indicates access is denied on the specified day for the second custom access policy.

public virtual int GetAccessStartTime2(
Int32 dayOfWeek
);

Parameters

dayOfWeek
must be a valid day of the week

Return Value

the start time for the specified day for the second custom access policy.

See Also

UserAccount Class | Borland.StarTeam Namespace | DAY_SUNDAY | DAY_MONDAY | DAY_TUESDAY | DAY_WEDNESDAY | DAY_THURSDAY | DAY_FRIDAY | DAY_SATURDAY


UserAccount.IsEqualTo Method

Compares two UserAccount objects.

public virtual bool IsEqualTo(
UserAccount account
);

Parameters

account
The UserAccount to be compared with this one.

Return Value

true if no differences were found.

See Also

UserAccount Class | Borland.StarTeam Namespace | copy


UserAccount.Reactivate Method

Reactivates this user account. The effect is immediate ( no need to call the update() method ).

public virtual void Reactivate();

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount.Remove Method

Removes this user account from the server, and from any group of which it is a member.

public virtual void Remove();

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount.RemoveFromGroupAccount Method

Removes this user from the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call update() to save the changes on the server.

public virtual void RemoveFromGroupAccount(
GroupAccount groupAccount
);

Parameters

groupAccount
the group account from which this user will be removed.

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount.SetAccessTimes Method

Changes the custom access policy start and end times for the specified day of the week.

public virtual void SetAccessTimes(
Int32 dayOfWeek,
Int32 start1,
Int32 end1,
Int32 start2,
Int32 end2
);

Parameters

dayOfWeek
a valid day of the week, e.g. DAY_SUNDAY
start1
start time in minutes from midnight
end1
end time in minutes from midnight
start2
start time in minutes from midnight
end2
end time in minutes from midnight

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount.Suspend Method

Suspend this user account. The effect is immediate ( no need to call the update() method ).

public virtual void Suspend();

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount.Unlock Method

Unlocks this user account. The effect is immediate ( no need to call the update() method ).

public virtual void Unlock();

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount.Update Method

Create or modify this UserAccount in the StarTeam Server. If the account is new it will be created otherwise the account information will be modified.

public virtual void Update();

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount.Wrap Method

Dynamically wraps com.starbase.starteam.UserAccount.

public static UserAccount Wrap(
UserAccount impl
);

Parameters

impl
com.starbase.starteam.UserAccount to be wrapped.

Return Value

UserAccount

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccount Type Conversions

The type conversions of the UserAccount class are listed below. For a complete list of UserAccount class members, see the UserAccount Members topic.

Public Static Type Conversions

Implicit UserAccount to UserAccount Conversion Implicitly convert UserAccount to com.starbase.starteam.UserAccount.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from CacheRef) Implementation of IWrapper.Unwrap().

See Also

UserAccount Class | UserAccount Members | Borland.StarTeam Namespace


UserAccount Implicit UserAccount to UserAccount Conversion

Implicitly convert UserAccount to com.starbase.starteam.UserAccount.

public static implicit operator UserAccount(
UserAccount arg
);

Parameters

arg
UserAccount to convert.

Return Value

com.starbase.starteam.UserAccount

See Also

UserAccount Class | Borland.StarTeam Namespace


UserAccountCollection Class

A strongly-typed collection of UserAccounts.

For a list of all members of this type, see UserAccountCollection Members.

System.Object
ArrayAdapter
UserAccountCollection

public class UserAccountCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

UserAccountCollection Members | Borland.StarTeam Namespace


UserAccountCollection Members

UserAccountCollection overview

Public Static Methods

Wrap Creates an UserAccountCollection to represent the given array of UserAccount (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit UserAccountCollection to UserAccount[] Conversion | Converts an UserAccountCollection to an array of UserAccounts.
Implicit UserAccountCollection to UserAccount[] Conversion | Converts an UserAccountCollection from the Borland.StarTeam namespace to an UserAccount[] in the com.starbase.starteam namespace.

Public Instance Constructors

UserAccountCollection Overloaded. Initializes a new instance of the UserAccountCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the UserAccount at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an UserAccount to end of the collection.
Append | Overloaded. Appends the UserAccounts of the given UserAccountCollection to the end of this UserAccountCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific UserAccount.
CopyTo | Copies all of the UserAccounts in the UserAccountCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the UserAccount with the given ID.
FindByName | Finds the UserAccount with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific UserAccount in the collection.
Insert | Inserts an UserAccount into the collection at the specified position.
Remove | Removes the first occurrence of a specific UserAccount from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the UserAccounts in this UserAccountCollection.
Sort | Sorts the UserAccounts in this UserAccountCollection, using the given comparer.
SortByID | Sorts the UserAccounts in this UserAccountCollection by ID.
SortByName | Sorts the UserAccounts in this UserAccountCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection Constructor

Initializes an instance of the UserAccountCollection class.

Overload List

Initializes an instance of the UserAccountCollection class.

public UserAccountCollection();

Initializes an instance of the an UserAccountCollection class, copying the given array.

public UserAccountCollection(UserAccount[]);

Initializes an instance of the an UserAccountCollection class, copying the given collection.

public UserAccountCollection(UserAccountCollection);

Initializes an instance of the an UserAccountCollection class, wrapping the given array of UserAccount (from the com.starbase.starteam namespace).

public UserAccountCollection(UserAccount[]);

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection Constructor ()

Initializes an instance of the UserAccountCollection class.

public UserAccountCollection();

See Also

UserAccountCollection Class | Borland.StarTeam Namespace | UserAccountCollection Constructor Overload List


UserAccountCollection Constructor (UserAccount[])

Initializes an instance of the an UserAccountCollection class, wrapping the given array of UserAccount (from the com.starbase.starteam namespace).

public UserAccountCollection(
UserAccount[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace | UserAccountCollection Constructor Overload List | Wrap


UserAccountCollection Constructor (UserAccountCollection)

Initializes an instance of the an UserAccountCollection class, copying the given collection.

public UserAccountCollection(
UserAccountCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member UserAccount objects of the original collection are shared, not copied.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace | UserAccountCollection Constructor Overload List


UserAccountCollection Constructor (UserAccount[])

Initializes an instance of the an UserAccountCollection class, copying the given array.

public UserAccountCollection(
UserAccount[] array
);

Parameters

array
The array to be copied.

Remarks

The member UserAccount objects of the original array are shared, not copied.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace | UserAccountCollection Constructor Overload List


UserAccountCollection Properties

The properties of the UserAccountCollection class are listed below. For a complete list of UserAccountCollection class members, see the UserAccountCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the UserAccount at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

UserAccountCollection.Item Property

Gets or sets the UserAccount at the specified index.

Overload List

Gets or sets the UserAccount at the specified index.

public UserAccount this[Int32] {get; set;}

Gets the UserAccount with the given name.

public UserAccount this[String] {get;}

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

UserAccountCollection.Item Property (Int32)

Gets or sets the UserAccount at the specified index.

public UserAccount this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the UserAccount to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace | UserAccountCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

UserAccountCollection.Item Property (String)

Gets the UserAccount with the given name.

public UserAccount this[
String name
] {get;}

Parameters

name
The name of the UserAccount to get.

Property Value

The UserAccount with the given name, or null if there is no UserAccount with that name in this UserAccountCollection. Comparison is case sensitive.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace | UserAccountCollection.Item Overload List | FindByName


UserAccountCollection Methods

The methods of the UserAccountCollection class are listed below. For a complete list of UserAccountCollection class members, see the UserAccountCollection Members topic.

Public Static Methods

Wrap Creates an UserAccountCollection to represent the given array of UserAccount (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds an UserAccount to end of the collection.
Append | Overloaded. Appends the UserAccounts of the given UserAccountCollection to the end of this UserAccountCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific UserAccount.
CopyTo | Copies all of the UserAccounts in the UserAccountCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the UserAccount with the given ID.
FindByName | Finds the UserAccount with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific UserAccount in the collection.
Insert | Inserts an UserAccount into the collection at the specified position.
Remove | Removes the first occurrence of a specific UserAccount from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the UserAccounts in this UserAccountCollection.
Sort | Sorts the UserAccounts in this UserAccountCollection, using the given comparer.
SortByID | Sorts the UserAccounts in this UserAccountCollection by ID.
SortByName | Sorts the UserAccounts in this UserAccountCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.Add Method

Adds an UserAccount to end of the collection.

public int Add(
UserAccount value
);

Parameters

value
The UserAccount to add to the collection.

Return Value

The position into which the new UserAccount was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

UserAccountCollection.Append Method

Appends the UserAccounts of the given array to the end of this UserAccountCollection.

Overload List

Appends the UserAccounts of the given array to the end of this UserAccountCollection.

public UserAccountCollection Append(UserAccount[]);

Appends the UserAccounts of the given UserAccountCollection to the end of this UserAccountCollection.

public UserAccountCollection Append(UserAccountCollection);

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.Append Method (UserAccount[])

Appends the UserAccounts of the given array to the end of this UserAccountCollection.

public UserAccountCollection Append(
UserAccount[] array
);

Parameters

array
The array whose UserAccounts are to be appended to this UserAccountCollection.

Return Value

This UserAccountCollection, modified to include the new UserAccounts.

Remarks

The UserAccountCollection is modified to include the new members. The individual UserAccount objects are shared, not copied.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace | UserAccountCollection.Append Overload List


UserAccountCollection.Append Method (UserAccountCollection)

Appends the UserAccounts of the given UserAccountCollection to the end of this UserAccountCollection.

public UserAccountCollection Append(
UserAccountCollection collection
);

Parameters

collection
The UserAccountCollection whose UserAccounts are to be appended to this UserAccountCollection.

Return Value

This UserAccountCollection, modified to include the new UserAccounts.

Remarks

The UserAccountCollection is modified to include the new members. The individual UserAccount objects are shared, not copied.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace | UserAccountCollection.Append Overload List


UserAccountCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.UserAccount[].

Implements

IWrapper.Unwrap

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.Contains Method

Determines whether or not the collection contains a specific UserAccount.

public bool Contains(
UserAccount value
);

Parameters

value
The UserAccount to locate in the collection.

Return Value

true if the UserAccount is found in the collection; otherwise, false.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.CopyTo Method

Copies all of the UserAccounts in the UserAccountCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
UserAccount[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the UserAccounts copied from the UserAccountCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of UserAccounts in the source UserAccountCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source UserAccountCollection cannot be cast automatically to the type of the destination array.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.FindByID Method

Finds the UserAccount with the given ID.

public UserAccount FindByID(
Int32 id
);

Parameters

id
The ID of the UserAccount to be found.

Return Value

The UserAccount with the given ID, or null if there is no UserAccount with that ID in this UserAccountCollection.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.FindByName Method

Finds the UserAccount with the given name.

public UserAccount FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the UserAccount to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The UserAccount with the given name, or null if there is no UserAccount with that name in this UserAccountCollection.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.IndexOf Method

Determines the index of a specific UserAccount in the collection.

public int IndexOf(
UserAccount value
);

Parameters

value
The UserAccount to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.Insert Method

Inserts an UserAccount into the collection at the specified position.

public void Insert(
Int32 index,
UserAccount value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The UserAccount to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.Remove Method

Removes the first occurrence of a specific UserAccount from the collection.

public void Remove(
UserAccount value
);

Parameters

value
The UserAccount to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.Reverse Method

Reverses the order of the UserAccounts in this UserAccountCollection.

new public UserAccountCollection Reverse();

Return Value

This UserAccountCollection, modified such that the UserAccounts are reversed.

Remarks

The UserAccountCollection is modified in place.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.Sort Method

Sorts the UserAccounts in this UserAccountCollection, using the given comparer.

new public UserAccountCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two UserAccounts.

Return Value

This UserAccountCollection, modified such that the UserAccounts are sorted.

Remarks

The UserAccountCollection is modified in place.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.SortByID Method

Sorts the UserAccounts in this UserAccountCollection by ID.

public UserAccountCollection SortByID();

Return Value

This UserAccountCollection, modified such that the UserAccounts are sorted by ID.

Remarks

The UserAccountCollection is modified in place.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.SortByName Method

Sorts the UserAccounts in this UserAccountCollection by name.

public UserAccountCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This UserAccountCollection, modified such that the UserAccounts are sorted by name.

Remarks

The UserAccountCollection is modified in place.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection.Wrap Method

Creates an UserAccountCollection to represent the given array of UserAccount (from the com.starbase.starteam namespace).

public static UserAccountCollection Wrap(
UserAccount[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new UserAccountCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an UserAccount[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection Type Conversions

The type conversions of the UserAccountCollection class are listed below. For a complete list of UserAccountCollection class members, see the UserAccountCollection Members topic.

Public Static Type Conversions

Implicit UserAccountCollection to UserAccount[] Conversion | Converts an UserAccountCollection to an array of UserAccounts.
Implicit UserAccountCollection to UserAccount[] Conversion | Converts an UserAccountCollection from the Borland.StarTeam namespace to an UserAccount[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

UserAccountCollection Class | UserAccountCollection Members | Borland.StarTeam Namespace


UserAccountCollection Implicit UserAccountCollection to UserAccount[] Conversion

Converts an UserAccountCollection to an array of UserAccounts.

public static implicit operator UserAccount[](
UserAccountCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new UserAccount wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one UserAccount wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserAccountCollection Implicit UserAccountCollection to UserAccount[] Conversion

Converts an UserAccountCollection from the Borland.StarTeam namespace to an UserAccount[] in the com.starbase.starteam namespace.

public static implicit operator UserAccount[](
UserAccountCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, UserAccountCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

UserAccountCollection Class | Borland.StarTeam Namespace


UserCollection Class

A strongly-typed collection of Users.

For a list of all members of this type, see UserCollection Members.

System.Object
ArrayAdapter
UserCollection

public class UserCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

UserCollection Members | Borland.StarTeam Namespace


UserCollection Members

UserCollection overview

Public Static Methods

Wrap Creates an UserCollection to represent the given array of User (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit UserCollection to User[] Conversion | Converts an UserCollection to an array of Users.
Implicit UserCollection to User[] Conversion | Converts an UserCollection from the Borland.StarTeam namespace to an User[] in the com.starbase.starteam namespace.

Public Instance Constructors

UserCollection Overloaded. Initializes a new instance of the UserCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the User at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an User to end of the collection.
Append | Overloaded. Appends the Users of the given UserCollection to the end of this UserCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific User.
CopyTo | Copies all of the Users in the UserCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the User with the given ID.
FindByName | Finds the User with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific User in the collection.
Insert | Inserts an User into the collection at the specified position.
Remove | Removes the first occurrence of a specific User from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Users in this UserCollection.
Sort | Sorts the Users in this UserCollection, using the given comparer.
SortByID | Sorts the Users in this UserCollection by ID.
SortByName | Sorts the Users in this UserCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection Constructor

Initializes an instance of the UserCollection class.

Overload List

Initializes an instance of the UserCollection class.

public UserCollection();

Initializes an instance of the an UserCollection class, copying the given array.

public UserCollection(User[]);

Initializes an instance of the an UserCollection class, copying the given collection.

public UserCollection(UserCollection);

Initializes an instance of the an UserCollection class, wrapping the given array of User (from the com.starbase.starteam namespace).

public UserCollection(User[]);

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection Constructor ()

Initializes an instance of the UserCollection class.

public UserCollection();

See Also

UserCollection Class | Borland.StarTeam Namespace | UserCollection Constructor Overload List


UserCollection Constructor (User[])

Initializes an instance of the an UserCollection class, wrapping the given array of User (from the com.starbase.starteam namespace).

public UserCollection(
User[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

UserCollection Class | Borland.StarTeam Namespace | UserCollection Constructor Overload List | Wrap


UserCollection Constructor (UserCollection)

Initializes an instance of the an UserCollection class, copying the given collection.

public UserCollection(
UserCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member User objects of the original collection are shared, not copied.

See Also

UserCollection Class | Borland.StarTeam Namespace | UserCollection Constructor Overload List


UserCollection Constructor (User[])

Initializes an instance of the an UserCollection class, copying the given array.

public UserCollection(
User[] array
);

Parameters

array
The array to be copied.

Remarks

The member User objects of the original array are shared, not copied.

See Also

UserCollection Class | Borland.StarTeam Namespace | UserCollection Constructor Overload List


UserCollection Properties

The properties of the UserCollection class are listed below. For a complete list of UserCollection class members, see the UserCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the User at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

UserCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

UserCollection.Item Property

Gets or sets the User at the specified index.

Overload List

Gets or sets the User at the specified index.

public User this[Int32] {get; set;}

Gets the User with the given name.

public User this[String] {get;}

See Also

UserCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

UserCollection.Item Property (Int32)

Gets or sets the User at the specified index.

public User this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the User to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

UserCollection Class | Borland.StarTeam Namespace | UserCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

UserCollection.Item Property (String)

Gets the User with the given name.

public User this[
String name
] {get;}

Parameters

name
The name of the User to get.

Property Value

The User with the given name, or null if there is no User with that name in this UserCollection. Comparison is case sensitive.

See Also

UserCollection Class | Borland.StarTeam Namespace | UserCollection.Item Overload List | FindByName


UserCollection Methods

The methods of the UserCollection class are listed below. For a complete list of UserCollection class members, see the UserCollection Members topic.

Public Static Methods

Wrap Creates an UserCollection to represent the given array of User (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds an User to end of the collection.
Append | Overloaded. Appends the Users of the given UserCollection to the end of this UserCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific User.
CopyTo | Copies all of the Users in the UserCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the User with the given ID.
FindByName | Finds the User with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific User in the collection.
Insert | Inserts an User into the collection at the specified position.
Remove | Removes the first occurrence of a specific User from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Users in this UserCollection.
Sort | Sorts the Users in this UserCollection, using the given comparer.
SortByID | Sorts the Users in this UserCollection by ID.
SortByName | Sorts the Users in this UserCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.Add Method

Adds an User to end of the collection.

public int Add(
User value
);

Parameters

value
The User to add to the collection.

Return Value

The position into which the new User was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

UserCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

UserCollection.Append Method

Appends the Users of the given array to the end of this UserCollection.

Overload List

Appends the Users of the given array to the end of this UserCollection.

public UserCollection Append(User[]);

Appends the Users of the given UserCollection to the end of this UserCollection.

public UserCollection Append(UserCollection);

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.Append Method (User[])

Appends the Users of the given array to the end of this UserCollection.

public UserCollection Append(
User[] array
);

Parameters

array
The array whose Users are to be appended to this UserCollection.

Return Value

This UserCollection, modified to include the new Users.

Remarks

The UserCollection is modified to include the new members. The individual User objects are shared, not copied.

See Also

UserCollection Class | Borland.StarTeam Namespace | UserCollection.Append Overload List


UserCollection.Append Method (UserCollection)

Appends the Users of the given UserCollection to the end of this UserCollection.

public UserCollection Append(
UserCollection collection
);

Parameters

collection
The UserCollection whose Users are to be appended to this UserCollection.

Return Value

This UserCollection, modified to include the new Users.

Remarks

The UserCollection is modified to include the new members. The individual User objects are shared, not copied.

See Also

UserCollection Class | Borland.StarTeam Namespace | UserCollection.Append Overload List


UserCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.User[].

Implements

IWrapper.Unwrap

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.Contains Method

Determines whether or not the collection contains a specific User.

public bool Contains(
User value
);

Parameters

value
The User to locate in the collection.

Return Value

true if the User is found in the collection; otherwise, false.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.CopyTo Method

Copies all of the Users in the UserCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
User[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Users copied from the UserCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Users in the source UserCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source UserCollection cannot be cast automatically to the type of the destination array.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.FindByID Method

Finds the User with the given ID.

public User FindByID(
Int32 id
);

Parameters

id
The ID of the User to be found.

Return Value

The User with the given ID, or null if there is no User with that ID in this UserCollection.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.FindByName Method

Finds the User with the given name.

public User FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the User to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The User with the given name, or null if there is no User with that name in this UserCollection.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.IndexOf Method

Determines the index of a specific User in the collection.

public int IndexOf(
User value
);

Parameters

value
The User to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.Insert Method

Inserts an User into the collection at the specified position.

public void Insert(
Int32 index,
User value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The User to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.Remove Method

Removes the first occurrence of a specific User from the collection.

public void Remove(
User value
);

Parameters

value
The User to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.Reverse Method

Reverses the order of the Users in this UserCollection.

new public UserCollection Reverse();

Return Value

This UserCollection, modified such that the Users are reversed.

Remarks

The UserCollection is modified in place.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.Sort Method

Sorts the Users in this UserCollection, using the given comparer.

new public UserCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Users.

Return Value

This UserCollection, modified such that the Users are sorted.

Remarks

The UserCollection is modified in place.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.SortByID Method

Sorts the Users in this UserCollection by ID.

public UserCollection SortByID();

Return Value

This UserCollection, modified such that the Users are sorted by ID.

Remarks

The UserCollection is modified in place.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.SortByName Method

Sorts the Users in this UserCollection by name.

public UserCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This UserCollection, modified such that the Users are sorted by name.

Remarks

The UserCollection is modified in place.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection.Wrap Method

Creates an UserCollection to represent the given array of User (from the com.starbase.starteam namespace).

public static UserCollection Wrap(
User[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new UserCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an User[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection Type Conversions

The type conversions of the UserCollection class are listed below. For a complete list of UserCollection class members, see the UserCollection Members topic.

Public Static Type Conversions

Implicit UserCollection to User[] Conversion | Converts an UserCollection to an array of Users.
Implicit UserCollection to User[] Conversion | Converts an UserCollection from the Borland.StarTeam namespace to an User[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

UserCollection Class | UserCollection Members | Borland.StarTeam Namespace


UserCollection Implicit UserCollection to User[] Conversion

Converts an UserCollection to an array of Users.

public static implicit operator User[](
UserCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new User wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one User wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserCollection Implicit UserCollection to User[] Conversion

Converts an UserCollection from the Borland.StarTeam namespace to an User[] in the com.starbase.starteam namespace.

public static implicit operator User[](
UserCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, UserCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

UserCollection Class | Borland.StarTeam Namespace


UserEventArgs Class

For a list of all members of this type, see UserEventArgs Members.

System.Object
EventArgs
UserEventArgs

public class UserEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

UserEventArgs Members | Borland.StarTeam Namespace


UserEventArgs Members

UserEventArgs overview

Public Static Type Conversions

Implicit UserEventArgs to UserEvent Conversion Implicitly convert UserEventArgs to com.starbase.starteam.UserEvent.

Public Instance Properties

User [read] The User that has been added, changed or deleted, in its new state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

UserEventArgs Class | Borland.StarTeam Namespace


UserEventArgs Properties

The properties of the UserEventArgs class are listed below. For a complete list of UserEventArgs class members, see the UserEventArgs Members topic.

Public Instance Properties

User [read] The User that has been added, changed or deleted, in its new state.

See Also

UserEventArgs Class | Borland.StarTeam Namespace


User Property

Borland StarTeam SDK for .NET

UserEventArgs.User Property

[read] The User that has been added, changed or deleted, in its new state.

public virtual User User {get;}

Property Value

The User that has been added, changed or deleted, in its new state.

See Also

UserEventArgs Class | Borland.StarTeam Namespace


UserEventArgs Methods

The methods of the UserEventArgs class are listed below. For a complete list of UserEventArgs class members, see the UserEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

UserEventArgs Class | Borland.StarTeam Namespace


UserEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

UserEventArgs Class | Borland.StarTeam Namespace


UserEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

UserEventArgs Class | Borland.StarTeam Namespace


UserEventArgs.ToString Method

public override string ToString();

See Also

UserEventArgs Class | Borland.StarTeam Namespace


UserEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

UserEventArgs Class | Borland.StarTeam Namespace


UserEventArgs Type Conversions

The type conversions of the UserEventArgs class are listed below. For a complete list of UserEventArgs class members, see the UserEventArgs Members topic.

Public Static Type Conversions

Implicit UserEventArgs to UserEvent Conversion Implicitly convert UserEventArgs to com.starbase.starteam.UserEvent.

See Also

UserEventArgs Class | UserEventArgs Members | Borland.StarTeam Namespace


UserEventArgs Implicit UserEventArgs to UserEvent Conversion

Implicitly convert UserEventArgs to com.starbase.starteam.UserEvent.

public static implicit operator UserEvent(
UserEventArgs arg
);

Parameters

arg
UserEventArgs to convert.

Return Value

com.starbase.starteam.UserEvent

See Also

UserEventArgs Class | Borland.StarTeam Namespace


UserEventSource Class

For a list of all members of this type, see UserEventSource Members.

System.Object
UserEventSource

public class UserEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

UserEventSource Members | Borland.StarTeam Namespace


UserEventSource Members

UserEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnUserAdded
OnUserChanged
OnUserDeleted
UserAdded
UserChanged
UserDeleted

See Also

UserEventSource Class | Borland.StarTeam Namespace


UserEventSource Properties

The properties of the UserEventSource class are listed below. For a complete list of UserEventSource class members, see the UserEventSource Members topic.

Public Instance Properties

Parent

See Also

UserEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

UserEventSource.Parent Property

public Object Parent {get;}

See Also

UserEventSource Class | Borland.StarTeam Namespace


UserEventSource Events

The events of the UserEventSource class are listed below. For a complete list of UserEventSource class members, see the UserEventSource Members topic.

Public Instance Events

OnUserAdded
OnUserChanged
OnUserDeleted
UserAdded
UserChanged
UserDeleted

See Also

UserEventSource Class | Borland.StarTeam Namespace


UserEventSource.OnUserAdded Event

public event UserEventSource.Handler OnUserAdded;

See Also

UserEventSource Class | Borland.StarTeam Namespace


UserEventSource.OnUserChanged Event

public event UserEventSource.Handler OnUserChanged;

See Also

UserEventSource Class | Borland.StarTeam Namespace


UserEventSource.OnUserDeleted Event

public event UserEventSource.Handler OnUserDeleted;

See Also

UserEventSource Class | Borland.StarTeam Namespace


UserEventSource.UserAdded Event

public event UserEventSource.Handler UserAdded;

See Also

UserEventSource Class | Borland.StarTeam Namespace


UserEventSource.UserChanged Event

public event UserEventSource.Handler UserChanged;

See Also

UserEventSource Class | Borland.StarTeam Namespace


UserEventSource.UserDeleted Event

public event UserEventSource.Handler UserDeleted;

See Also

UserEventSource Class | Borland.StarTeam Namespace


UserEventSource.Handler Delegate

public delegate void UserEventSource.Handler(
UserEventSource source,
UserEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


UserGroupSecLogID Class

For User-based security log events.

For a list of all members of this type, see UserGroupSecLogID Members.

System.Object
UserGroupSecLogID

public class UserGroupSecLogID : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

UserGroupSecLogID Members | Borland.StarTeam Namespace


UserGroupSecLogID Members

UserGroupSecLogID overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.UserGroupSecLogID.

Public Static Type Conversions

Implicit UserGroupSecLogID to UserGroupSecLogID Conversion Implicitly convert UserGroupSecLogID to com.starbase.starteam.UserGroupSecLogID.

Public Instance Constructors

UserGroupSecLogID Constructor Construct UserGroupSecLogID from com.starbase.starteam.UserGroupSecLogID.

Public Instance Properties

UserGroupID [read] The user group id.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.UserGroupSecLogID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.UserGroupSecLogID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.UserGroupSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

UserGroupSecLogID Class | Borland.StarTeam Namespace


UserGroupSecLogID Constructor

Construct UserGroupSecLogID from com.starbase.starteam.UserGroupSecLogID.

public UserGroupSecLogID(
UserGroupSecLogID impl
);

Parameters

impl
The com.starbase.starteam.UserGroupSecLogID to be wrapped.

See Also

UserGroupSecLogID Class | Borland.StarTeam Namespace


UserGroupSecLogID Properties

The properties of the UserGroupSecLogID class are listed below. For a complete list of UserGroupSecLogID class members, see the UserGroupSecLogID Members topic.

Public Instance Properties

UserGroupID [read] The user group id.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

UserGroupSecLogID Class | Borland.StarTeam Namespace


UserGroupID Property

Borland StarTeam SDK for .NET

UserGroupSecLogID.UserGroupID Property

[read] The user group id.

public virtual Int32 UserGroupID {get;}

Property Value

The user group id.

See Also

UserGroupSecLogID Class | Borland.StarTeam Namespace


UserGroupSecLogID Methods

The methods of the UserGroupSecLogID class are listed below. For a complete list of UserGroupSecLogID class members, see the UserGroupSecLogID Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.UserGroupSecLogID.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.UserGroupSecLogID.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.UserGroupSecLogID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.UserGroupSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

UserGroupSecLogID Class | Borland.StarTeam Namespace


UserGroupSecLogID.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.UserGroupSecLogID

Implements

IWrapper.Unwrap

See Also

UserGroupSecLogID Class | Borland.StarTeam Namespace


UserGroupSecLogID.Equals Method

Delegate Equals() to com.starbase.starteam.UserGroupSecLogID.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.UserGroupSecLogID.Equals(obj).

See Also

UserGroupSecLogID Class | Borland.StarTeam Namespace


UserGroupSecLogID.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.UserGroupSecLogID.

public override int GetHashCode();

Return Value

com.starbase.starteam.UserGroupSecLogID.GetHashCode().

See Also

UserGroupSecLogID Class | Borland.StarTeam Namespace


UserGroupSecLogID.ToString Method

Delegate ToString() to com.starbase.starteam.UserGroupSecLogID.

public override string ToString();

Return Value

com.starbase.starteam.UserGroupSecLogID.ToString()

See Also

UserGroupSecLogID Class | Borland.StarTeam Namespace


UserGroupSecLogID.Wrap Method

Dynamically wraps com.starbase.starteam.UserGroupSecLogID.

public static UserGroupSecLogID Wrap(
UserGroupSecLogID impl
);

Parameters

impl
com.starbase.starteam.UserGroupSecLogID to be wrapped.

Return Value

UserGroupSecLogID

See Also

UserGroupSecLogID Class | Borland.StarTeam Namespace


UserGroupSecLogID Type Conversions

The type conversions of the UserGroupSecLogID class are listed below. For a complete list of UserGroupSecLogID class members, see the UserGroupSecLogID Members topic.

Public Static Type Conversions

Implicit UserGroupSecLogID to UserGroupSecLogID Conversion Implicitly convert UserGroupSecLogID to com.starbase.starteam.UserGroupSecLogID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

UserGroupSecLogID Class | UserGroupSecLogID Members | Borland.StarTeam Namespace


UserGroupSecLogID Implicit UserGroupSecLogID to UserGroupSecLogID Conversion

Implicitly convert UserGroupSecLogID to com.starbase.starteam.UserGroupSecLogID.

public static implicit operator UserGroupSecLogID(
UserGroupSecLogID arg
);

Parameters

arg
UserGroupSecLogID to convert.

Return Value

com.starbase.starteam.UserGroupSecLogID

See Also

UserGroupSecLogID Class | Borland.StarTeam Namespace


View Class

Represents a StarTeam View.

For a list of all members of this type, see View Members.

System.Object
TypedResource
SimpleTypedResource
View
RecycleBin
MergePreview

public class View : SimpleTypedResource, ISecurableObject, ISecurable, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

View Members | Borland.StarTeam Namespace


View Members

View overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.View.

Public Static Type Conversions

Implicit View to View Conversion Implicitly convert View to com.starbase.starteam.View.

Public Instance Constructors

View Overloaded. Initializes a new instance of the View class.

Public Instance Properties

ACL |
ActiveLabels | [read] The active (non-deleted) labels for this view.
AlternatePath | [read/write] the alternate working file path to be used for this view.
BaseConfiguration | [read] the ViewConfiguration from which this View was derived.
Configuration | [read] this view's configuration.
CreatedBy | [read] the user ID of the user that created the view.
CreatedTime | [read] the time at which the view was created.
DefaultPath | [read/write] the default working file path to be used for this view.
DerivedViews | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description | [read/write] the description of this view.
FileStatusManager | [read] The FileBasedStatusManager for this View.
FullName | [read] the full hierarchical name of this view.
HaveAccessRights | [read] true if the logged on user has rights to access this view.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsAccessible | [read] true if the logged on user has access to this view.
IsBranch | [read] true if this view is a Branch view.
IsBranchAll | [read] true if this view's original branching default was set "All".
IsBranchNone | [read] true if this view's original branching default was set "None".
IsBranchOnShare | [read/write] true if this view is set to branch shared items.
IsDeleted | [read] True if the view has been deleted from the server; false otherwise.
IsNonDerived | [read] true if this view is Non-Derived view.
IsReadOnly | [read] true if this view is ReadOnly, otherwise false.
IsReference | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired | [read] true if folder information may be out of date.
IsRefreshLabelsRequired | [read] true if label information may be out of date.
IsRefreshRequired | [read] true if view properties may be out of date.
IsRoot | [read] true if this view is a Root view.
Item (inherited from TypedResource) |
Labels | [read] The labels (both active and deleted) that exist in this view.
Name | [read/write] the name of this view.
Owner |
ParentContainer |
ParentView | [read] the parent of this view, or null if there is no parent.
Path | [read] the working file path being used for this view.
Project | [read] the project to which this view belongs.
PromotionModel | [read] the promotion model associated with this view.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
RecycleBin | [read] The recycle bin associated with this view.
RootFolder | [read] The root folder of this view.
Server | [read] the server to which this view belongs.
StatusMethodOverride | [read/write]
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
ViewID | [read] the unique integer identifier for this view.

Public Instance Methods

AcquireOwnership |
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
CloneRevisionLabel | Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed.
CloneViewLabel | Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed.
Close | Frees all cached resources associated with this view, and closes the associated view session. Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
Copy | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
CreateCheckinManager | Overloaded. Constructs a CheckinManager with default options for this view.
CreateCheckoutManager | Overloaded. Constructs a CheckoutManager with default options for this view.
CreateChildViewShareAllItems | Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.
CreateChildViewShareDefaultItems | Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.
CreateChildViewShareNoItems | Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.
CreateChildViewShareTheseItems | Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.
CreateRevisionLabel | Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
CreateViewLabel | Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
Discard | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardActiveLabels | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
DiscardFolders | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardLabels | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
FetchAllLabels | Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
FetchAllLabelsFromView | Returns all the active (non-deleted) labels for the given project and view. This method is only available for 4.1 and later servers. The labels are not cached. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. fetchAllLabelsFromView() is not MPX-enabled; the labels are always retrieved directly from the repository.
FindFolder | Returns a Folder in the View, given its Item ID, or NULL if none found.
FindItem | Returns an Item in the View, given its Type and Item ID, or NULL if none found.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetContainerLevelACL |
GetDisembodiedItem | Retrieves an Item by Item ID. The Item can reside anywhere in this view, or in any other view on the same server. However, the resulting Item is "disembodied"; that is, it is not attached to its normal parent Folder. Disembodied Items are useful for resolving LinkEndpoints, which can cross project and view boundaries. However, many normal Item operations are not supported for disembodied items. getDisembodiedItem() is not MPX-enabled; each call to getDisembodiedItem() retrieves data directly from the server.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetHistoryForItemID | Returns "disembodied" Items from the item history
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetNewNotificationItems | Return the list of "notification" items for the specified type. This method will not return null but may return an empty list. Once this call has been made to the server for a particular view subsequent calls will not return the same information. The act of getting the information "clears" it from the server.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasNewNotificationItems | Return true if any new notification items are available in this view for the specified item type.
HasPermission | Overloaded.
IsEqualTo | Compares the properties of two Views.
ModifyItemsFlagForUser | Modifies this items flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyItemsReadStatusForUser | Modifies this list of item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File items.
NewFolderEventSource |
NewFolderTreeEventSource |
NewFolderUpdateEventSource |
NewItemEventSource | Overloaded.
NewItemIDEventSource | Overloaded.
NewItemListEventSource | Overloaded.
NewItemUpdateEventSource |
NewLabelEventSource |
NewNotificationEventSource | Overloaded.
NewViewEventSource |
Populate | Populates project properties, if they have not already been populated.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
Refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshActiveLabels | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
RefreshFolders | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
RefreshLabels | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
RefreshPromotionModel | Refreshes the local cached information about this view's promotion model.
Remove | Removes the view from the server.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveLinkEndpoint | Returns the item in this view referred to by the LinkEndpoint. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
SetContainerLevelACL |
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Update | Persists this view's properties to its Server.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

View Class | Borland.StarTeam Namespace


View Constructor

Construct View from com.starbase.starteam.View.

Overload List

A view "copy" constructor that allows the specification of an arbitrary configuration. This does not really create a new view on the server but rather creates a client side View object set to the specified configuration.

public View(View,ViewConfiguration);

A constructor used to create a new view.

public View(View,Boolean,Boolean,String,String,Folder,String,ViewConfiguration,Boolean);

A constructor used to create a blank view.

public View(View,String,String,String);

Construct View from com.starbase.starteam.View.

public View(View);

See Also

View Class | Borland.StarTeam Namespace


View Constructor (View)

Construct View from com.starbase.starteam.View.

public View(
View impl
);

Parameters

impl
The com.starbase.starteam.View to be wrapped.

See Also

View Class | Borland.StarTeam Namespace | View Constructor Overload List


View Constructor (View, Boolean, Boolean, String, String, Folder, String, ViewConfiguration, Boolean)

A constructor used to create a new view.

public View(
View parent,
Boolean bIsVariantView,
Boolean bIsROView,
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

Parameters

parent
the new view's parent view.
bIsVariantView
true for a variant view, false for a reference view.
bIsROView
true for a read-only view, false for a normal view.
name
the new view's name.
description
the new view's description.
rootFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
defaultWorkingFolder
the default working folder path for the view. This can be overridden on each workstation as needed.
baseConfig
the ViewConfiguration for the view. For a derived view, specify the parent view's configuration. For a floating view, specify a "current" configuration.
bIsBranched
true for branch on change. Sets initial branching behavior in derived variant views for all items shared during the view creation from the active view. Specify true for default branching, false for default floating.

See Also

View Class | Borland.StarTeam Namespace | View Constructor Overload List | ViewConfiguration


View Constructor (View, String, String, String)

A constructor used to create a blank view.

public View(
View parent,
String name,
String description,
String defaultWorkingFolder
);

Parameters

parent
the new view's parent view.
name
the new view's name.
description
the new view's description.
defaultWorkingFolder
the default working folder path for the view. This can be overridden on each workstation as needed.

See Also

View Class | Borland.StarTeam Namespace | View Constructor Overload List


View Constructor (View, ViewConfiguration)

A view "copy" constructor that allows the specification of an arbitrary configuration. This does not really create a new view on the server but rather creates a client side View object set to the specified configuration.

public View(
View view,
ViewConfiguration configuration
);

Parameters

view
the view being configured
configuration
the desired configuration of the specified view.

See Also

View Class | Borland.StarTeam Namespace | View Constructor Overload List


View Properties

The properties of the View class are listed below. For a complete list of View class members, see the View Members topic.

Public Instance Properties

ACL |
ActiveLabels | [read] The active (non-deleted) labels for this view.
AlternatePath | [read/write] the alternate working file path to be used for this view.
BaseConfiguration | [read] the ViewConfiguration from which this View was derived.
Configuration | [read] this view's configuration.
CreatedBy | [read] the user ID of the user that created the view.
CreatedTime | [read] the time at which the view was created.
DefaultPath | [read/write] the default working file path to be used for this view.
DerivedViews | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description | [read/write] the description of this view.
FileStatusManager | [read] The FileBasedStatusManager for this View.
FullName | [read] the full hierarchical name of this view.
HaveAccessRights | [read] true if the logged on user has rights to access this view.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsAccessible | [read] true if the logged on user has access to this view.
IsBranch | [read] true if this view is a Branch view.
IsBranchAll | [read] true if this view's original branching default was set "All".
IsBranchNone | [read] true if this view's original branching default was set "None".
IsBranchOnShare | [read/write] true if this view is set to branch shared items.
IsDeleted | [read] True if the view has been deleted from the server; false otherwise.
IsNonDerived | [read] true if this view is Non-Derived view.
IsReadOnly | [read] true if this view is ReadOnly, otherwise false.
IsReference | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired | [read] true if folder information may be out of date.
IsRefreshLabelsRequired | [read] true if label information may be out of date.
IsRefreshRequired | [read] true if view properties may be out of date.
IsRoot | [read] true if this view is a Root view.
Item (inherited from TypedResource) |
Labels | [read] The labels (both active and deleted) that exist in this view.
Name | [read/write] the name of this view.
Owner |
ParentContainer |
ParentView | [read] the parent of this view, or null if there is no parent.
Path | [read] the working file path being used for this view.
Project | [read] the project to which this view belongs.
PromotionModel | [read] the promotion model associated with this view.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
RecycleBin | [read] The recycle bin associated with this view.
RootFolder | [read] The root folder of this view.
Server | [read] the server to which this view belongs.
StatusMethodOverride | [read/write]
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
ViewID | [read] the unique integer identifier for this view.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

View Class | Borland.StarTeam Namespace


ACL Property

Borland StarTeam SDK for .NET

View.ACL Property

public virtual ACL ACL {get; set;}

Implements

ISecurable.ACL

See Also

View Class | Borland.StarTeam Namespace


ActiveLabels Property

Borland StarTeam SDK for .NET

View.ActiveLabels Property

[read] The active (non-deleted) labels for this view.

public virtual LabelCollection ActiveLabels {get;}

Property Value

The active (non-deleted) labels for this view.

See Also

View Class | Borland.StarTeam Namespace


AlternatePath Property

Borland StarTeam SDK for .NET

View.AlternatePath Property

[read/write] the alternate working file path to be used for this view.

public virtual String AlternatePath {get; set;}

Property Value

the alternate working file path to be used for this view.

See Also

View Class | Borland.StarTeam Namespace


BaseConfiguration Property

Borland StarTeam SDK for .NET

View.BaseConfiguration Property

[read] the ViewConfiguration from which this View was derived.

public virtual ViewConfiguration BaseConfiguration {get;}

Property Value

the ViewConfiguration from which this View was derived.

See Also

View Class | Borland.StarTeam Namespace


Configuration Property

Borland StarTeam SDK for .NET

View.Configuration Property

[read] this view's configuration.

public virtual ViewConfiguration Configuration {get;}

Property Value

this view's configuration.

See Also

View Class | Borland.StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

View.CreatedBy Property

[read] the user ID of the user that created the view.

public virtual Int32 CreatedBy {get;}

Property Value

the user ID of the user that created the view.

See Also

View Class | Borland.StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

View.CreatedTime Property

[read] the time at which the view was created.

public virtual DateTime CreatedTime {get;}

Property Value

the time at which the view was created.

See Also

View Class | Borland.StarTeam Namespace


DefaultPath Property

Borland StarTeam SDK for .NET

View.DefaultPath Property

[read/write] the default working file path to be used for this view.

public virtual String DefaultPath {get; set;}

Property Value

the default working file path to be used for this view.

See Also

View Class | Borland.StarTeam Namespace


DerivedViews Property

Borland StarTeam SDK for .NET

View.DerivedViews Property

[read] The set of views derived from this one. Returns an empty array if there are no derived views.

public virtual ViewCollection DerivedViews {get;}

Property Value

The set of views derived from this one. Returns an empty array if there are no derived views.

See Also

View Class | Borland.StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

View.Description Property

[read/write] the description of this view.

public virtual String Description {get; set;}

Property Value

the description of this view.

See Also

View Class | Borland.StarTeam Namespace


FileStatusManager Property

Borland StarTeam SDK for .NET

View.FileStatusManager Property

[read] The FileBasedStatusManager for this View.

public virtual FileBasedStatusManager FileStatusManager {get;}

Property Value

The FileBasedStatusManager for this View.

See Also

View Class | Borland.StarTeam Namespace


FullName Property

Borland StarTeam SDK for .NET

View.FullName Property

[read] the full hierarchical name of this view.

public virtual String FullName {get;}

Property Value

the full hierarchical name of this view.

See Also

View Class | Borland.StarTeam Namespace


HaveAccessRights Property

Borland StarTeam SDK for .NET

View.HaveAccessRights Property

[read] true if the logged on user has rights to access this view.

public virtual Boolean HaveAccessRights {get;}

Property Value

true if the logged on user has rights to access this view.

See Also

View Class | Borland.StarTeam Namespace


IsAccessible Property

Borland StarTeam SDK for .NET

View.IsAccessible Property

[read] true if the logged on user has access to this view.

public virtual Boolean IsAccessible {get;}

Property Value

true if the logged on user has access to this view.

See Also

View Class | Borland.StarTeam Namespace


IsBranch Property

Borland StarTeam SDK for .NET

View.IsBranch Property

[read] true if this view is a Branch view.

public virtual Boolean IsBranch {get;}

Property Value

true if this view is a Branch view.

See Also

View Class | Borland.StarTeam Namespace


IsBranchAll Property

Borland StarTeam SDK for .NET

View.IsBranchAll Property

[read] true if this view's original branching default was set "All".

public virtual Boolean IsBranchAll {get;}

Property Value

true if this view's original branching default was set "All".

See Also

View Class | Borland.StarTeam Namespace


IsBranchNone Property

Borland StarTeam SDK for .NET

View.IsBranchNone Property

[read] true if this view's original branching default was set "None".

public virtual Boolean IsBranchNone {get;}

Property Value

true if this view's original branching default was set "None".

See Also

View Class | Borland.StarTeam Namespace


IsBranchOnShare Property

Borland StarTeam SDK for .NET

View.IsBranchOnShare Property

[read/write] true if this view is set to branch shared items.

public virtual Boolean IsBranchOnShare {get; set;}

Property Value

true if this view is set to branch shared items.

See Also

View Class | Borland.StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

View.IsDeleted Property

[read] True if the view has been deleted from the server; false otherwise.

public virtual Boolean IsDeleted {get;}

Property Value

True if the view has been deleted from the server; false otherwise.

See Also

View Class | Borland.StarTeam Namespace


IsNonDerived Property

Borland StarTeam SDK for .NET

View.IsNonDerived Property

[read] true if this view is Non-Derived view.

public virtual Boolean IsNonDerived {get;}

Property Value

true if this view is Non-Derived view.

See Also

View Class | Borland.StarTeam Namespace


IsReadOnly Property

Borland StarTeam SDK for .NET

View.IsReadOnly Property

[read] true if this view is ReadOnly, otherwise false.

public virtual Boolean IsReadOnly {get;}

Property Value

true if this view is ReadOnly, otherwise false.

See Also

View Class | Borland.StarTeam Namespace


IsReference Property

Borland StarTeam SDK for .NET

View.IsReference Property

[read] true if this is a reference view, otherwise false.

public virtual Boolean IsReference {get;}

Property Value

true if this is a reference view, otherwise false.

See Also

View Class | Borland.StarTeam Namespace


IsRefreshActiveLabelsRequired Property

Borland StarTeam SDK for .NET

View.IsRefreshActiveLabelsRequired Property

[read] true if the active label information may be out of date.

public virtual Boolean IsRefreshActiveLabelsRequired {get;}

Property Value

true if the active label information may be out of date.

See Also

View Class | Borland.StarTeam Namespace


IsRefreshFoldersRequired Property

Borland StarTeam SDK for .NET

View.IsRefreshFoldersRequired Property

[read] true if folder information may be out of date.

public virtual Boolean IsRefreshFoldersRequired {get;}

Property Value

true if folder information may be out of date.

See Also

View Class | Borland.StarTeam Namespace


IsRefreshLabelsRequired Property

Borland StarTeam SDK for .NET

View.IsRefreshLabelsRequired Property

[read] true if label information may be out of date.

public virtual Boolean IsRefreshLabelsRequired {get;}

Property Value

true if label information may be out of date.

See Also

View Class | Borland.StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

View.IsRefreshRequired Property

[read] true if view properties may be out of date.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if view properties may be out of date.

See Also

View Class | Borland.StarTeam Namespace


IsRoot Property

Borland StarTeam SDK for .NET

View.IsRoot Property

[read] true if this view is a Root view.

public virtual Boolean IsRoot {get;}

Property Value

true if this view is a Root view.

See Also

View Class | Borland.StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

View.Labels Property

[read] The labels (both active and deleted) that exist in this view.

public virtual LabelCollection Labels {get;}

Property Value

The labels (both active and deleted) that exist in this view.

See Also

View Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

View.Name Property

[read/write] the name of this view.

public virtual String Name {get; set;}

Property Value

the name of this view.

See Also

View Class | Borland.StarTeam Namespace


Owner Property

Borland StarTeam SDK for .NET

View.Owner Property

public virtual Int32 Owner {get;}

Implements

ISecurableObject.Owner

See Also

View Class | Borland.StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

View.ParentContainer Property

public virtual ISecurableContainer ParentContainer {get;}

Implements

ISecurableContainer.ParentContainer

See Also

View Class | Borland.StarTeam Namespace


ParentView Property

Borland StarTeam SDK for .NET

View.ParentView Property

[read] the parent of this view, or null if there is no parent.

public virtual View ParentView {get;}

Property Value

the parent of this view, or null if there is no parent.

See Also

View Class | Borland.StarTeam Namespace


Path Property

Borland StarTeam SDK for .NET

View.Path Property

[read] the working file path being used for this view.

public virtual String Path {get;}

Property Value

the working file path being used for this view.

See Also

View Class | Borland.StarTeam Namespace


Project Property

Borland StarTeam SDK for .NET

View.Project Property

[read] the project to which this view belongs.

public virtual Project Project {get;}

Property Value

the project to which this view belongs.

See Also

View Class | Borland.StarTeam Namespace


PromotionModel Property

Borland StarTeam SDK for .NET

View.PromotionModel Property

[read] the promotion model associated with this view.

public virtual PromotionModel PromotionModel {get;}

Property Value

the promotion model associated with this view.

See Also

View Class | Borland.StarTeam Namespace


RecycleBin Property

Borland StarTeam SDK for .NET

View.RecycleBin Property

[read] The recycle bin associated with this view.

public virtual RecycleBin RecycleBin {get;}

Property Value

The recycle bin associated with this view.

See Also

View Class | Borland.StarTeam Namespace


RootFolder Property

Borland StarTeam SDK for .NET

View.RootFolder Property

[read] The root folder of this view.

public virtual Folder RootFolder {get;}

Property Value

The root folder of this view.

See Also

View Class | Borland.StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

View.Server Property

[read] the server to which this view belongs.

public virtual Server Server {get;}

Property Value

the server to which this view belongs.

See Also

View Class | Borland.StarTeam Namespace


StatusMethodOverride Property

Borland StarTeam SDK for .NET

View.StatusMethodOverride Property

[read/write]

public virtual StatusMethod StatusMethodOverride {get; set;}

See Also

View Class | Borland.StarTeam Namespace


ViewID Property

Borland StarTeam SDK for .NET

View.ViewID Property

[read] the unique integer identifier for this view.

public virtual Int32 ViewID {get;}

Property Value

the unique integer identifier for this view.

See Also

View Class | Borland.StarTeam Namespace


View Methods

The methods of the View class are listed below. For a complete list of View class members, see the View Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.View.

Public Instance Methods

AcquireOwnership |
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
CloneRevisionLabel | Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed.
CloneViewLabel | Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed.
Close | Frees all cached resources associated with this view, and closes the associated view session. Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
Copy | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
CreateCheckinManager | Overloaded. Constructs a CheckinManager with default options for this view.
CreateCheckoutManager | Overloaded. Constructs a CheckoutManager with default options for this view.
CreateChildViewShareAllItems | Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.
CreateChildViewShareDefaultItems | Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.
CreateChildViewShareNoItems | Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.
CreateChildViewShareTheseItems | Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.
CreateRevisionLabel | Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
CreateViewLabel | Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
Discard | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardActiveLabels | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
DiscardFolders | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardLabels | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
FetchAllLabels | Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
FetchAllLabelsFromView | Returns all the active (non-deleted) labels for the given project and view. This method is only available for 4.1 and later servers. The labels are not cached. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. fetchAllLabelsFromView() is not MPX-enabled; the labels are always retrieved directly from the repository.
FindFolder | Returns a Folder in the View, given its Item ID, or NULL if none found.
FindItem | Returns an Item in the View, given its Type and Item ID, or NULL if none found.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetContainerLevelACL |
GetDisembodiedItem | Retrieves an Item by Item ID. The Item can reside anywhere in this view, or in any other view on the same server. However, the resulting Item is "disembodied"; that is, it is not attached to its normal parent Folder. Disembodied Items are useful for resolving LinkEndpoints, which can cross project and view boundaries. However, many normal Item operations are not supported for disembodied items. getDisembodiedItem() is not MPX-enabled; each call to getDisembodiedItem() retrieves data directly from the server.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetHistoryForItemID | Returns "disembodied" Items from the item history
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetNewNotificationItems | Return the list of "notification" items for the specified type. This method will not return null but may return an empty list. Once this call has been made to the server for a particular view subsequent calls will not return the same information. The act of getting the information "clears" it from the server.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasNewNotificationItems | Return true if any new notification items are available in this view for the specified item type.
HasPermission | Overloaded.
IsEqualTo | Compares the properties of two Views.
ModifyItemsFlagForUser | Modifies this items flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyItemsReadStatusForUser | Modifies this list of item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File items.
NewFolderEventSource |
NewFolderTreeEventSource |
NewFolderUpdateEventSource |
NewItemEventSource | Overloaded.
NewItemIDEventSource | Overloaded.
NewItemListEventSource | Overloaded.
NewItemUpdateEventSource |
NewLabelEventSource |
NewNotificationEventSource | Overloaded.
NewViewEventSource |
Populate | Populates project properties, if they have not already been populated.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
Refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshActiveLabels | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
RefreshFolders | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
RefreshLabels | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
RefreshPromotionModel | Refreshes the local cached information about this view's promotion model.
Remove | Removes the view from the server.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveLinkEndpoint | Returns the item in this view referred to by the LinkEndpoint. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
SetContainerLevelACL |
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Update | Persists this view's properties to its Server.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

View Class | Borland.StarTeam Namespace


View.AcquireOwnership Method

public virtual void AcquireOwnership();

Implements

ISecurableObject.AcquireOwnership

See Also

View Class | Borland.StarTeam Namespace


View.CloneRevisionLabel Method

Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed.

public virtual Label CloneRevisionLabel(
Label source,
String name,
String description,
Boolean frozen
);

Parameters

source
the label to be cloned (it must be from the active view)
name
the label name (may not be null)
description
the label description (may not be null)
frozen
true if the label is "frozen" (a frozen label can not be moved from one revision to another)

See Also

View Class | Borland.StarTeam Namespace


View.CloneViewLabel Method

Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed.

public virtual Label CloneViewLabel(
Label source,
String name,
String description,
Boolean buildLabel,
Boolean frozen
);

Parameters

source
the label to be cloned (it must be from the active view)
name
the label name (may not be null)
description
the label description (may not be null)
buildLabel
true if the label is to be a "Build Label"
frozen
true if the label is "frozen" (a frozen label can not be moved from one revision to another)

See Also

View Class | Borland.StarTeam Namespace


View.Close Method

Frees all cached resources associated with this view, and closes the associated view session.

Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close().

After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.

public virtual void Close();

See Also

View Class | Borland.StarTeam Namespace | discard | discardFolders | discardLabels | discardItems | disconnect


View.Copy Method

Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().

public virtual View Copy();

Return Value

A new copy of this View object.

See Also

View Class | Borland.StarTeam Namespace | isEqualTo


CreateCheckinManager Method

Borland StarTeam SDK for .NET

View.CreateCheckinManager Method

Constructs a CheckinManager with default options for this view.

Overload List

Constructs a CheckinManager with default options for this view.

public virtual CheckinManager CreateCheckinManager();

Constructs a CheckinManager using a specific set of options. Note that individual options can be overridden on a file-by-file basis by registering a CheckinListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckinManager CreateCheckinManager(CheckinOptions);

See Also

View Class | Borland.StarTeam Namespace


View.CreateCheckinManager Method ()

Constructs a CheckinManager with default options for this view.

public virtual CheckinManager CreateCheckinManager();

See Also

View Class | Borland.StarTeam Namespace | View.CreateCheckinManager Overload List


View.CreateCheckinManager Method (CheckinOptions)

Constructs a CheckinManager using a specific set of options.

Note that individual options can be overridden on a file-by-file basis by registering a CheckinListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckinManager CreateCheckinManager(
CheckinOptions options
);

Parameters

options
The specific CheckinOtions to be used.

See Also

View Class | Borland.StarTeam Namespace | View.CreateCheckinManager Overload List | CheckinOptions | View | onStartFile


CreateCheckoutManager Method

Borland StarTeam SDK for .NET

View.CreateCheckoutManager Method

Constructs a CheckoutManager with default options for this view.

Overload List

Constructs a CheckoutManager with default options for this view.

public virtual CheckoutManager CreateCheckoutManager();

Constructs a CheckoutManager using a specific set of options. Note that individual options can be overridden on a file-by-file basis by registering a CheckoutListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckoutManager CreateCheckoutManager(CheckoutOptions);

See Also

View Class | Borland.StarTeam Namespace


View.CreateCheckoutManager Method ()

Constructs a CheckoutManager with default options for this view.

public virtual CheckoutManager CreateCheckoutManager();

See Also

View Class | Borland.StarTeam Namespace | View.CreateCheckoutManager Overload List


View.CreateCheckoutManager Method (CheckoutOptions)

Constructs a CheckoutManager using a specific set of options.

Note that individual options can be overridden on a file-by-file basis by registering a CheckoutListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckoutManager CreateCheckoutManager(
CheckoutOptions options
);

Parameters

options
The specific CheckoutOtions to be used.

See Also

View Class | Borland.StarTeam Namespace | View.CreateCheckoutManager Overload List | CheckoutOptions | View | onStartFile


View.CreateChildViewShareAllItems Method

Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.

public virtual View CreateChildViewShareAllItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

Parameters

name
may not be null
description
the new view's name.
rootFolder
the new view's description.
defaultWorkingFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
baseConfig
the default working folder path for the view. This can be overridden on each workstation as needed.
bIsBranched
the ViewConfiguration for the view. Specify the configuration of this view that is used as a starting point for the new variant view.

Return Value

the new variant view.

See Also

View Class | Borland.StarTeam Namespace | ViewConfiguration


View.CreateChildViewShareDefaultItems Method

Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.

public virtual View CreateChildViewShareDefaultItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

Parameters

name
may not be null
description
the new view's name.
rootFolder
the new view's description.
defaultWorkingFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
baseConfig
the default working folder path for the view. This can be overridden on each workstation as needed.
bIsBranched
the ViewConfiguration for the view. Specify the configuration of this view that is used as a starting point for the new variant view.

Return Value

the new variant view.

See Also

View Class | Borland.StarTeam Namespace | ViewConfiguration


View.CreateChildViewShareNoItems Method

Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.

public virtual View CreateChildViewShareNoItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

Parameters

name
may not be null
description
the new view's name.
rootFolder
the new view's description.
defaultWorkingFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
baseConfig
the default working folder path for the view. This can be overridden on each workstation as needed.
bIsBranched
the ViewConfiguration for the view. Specify the configuration of this view that is used as a starting point for the new variant view.

Return Value

the new variant view.

See Also

View Class | Borland.StarTeam Namespace | ViewConfiguration


View.CreateChildViewShareTheseItems Method

Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.

public virtual View CreateChildViewShareTheseItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched,
TypeCollection itemTypes
);

Parameters

name
may not be null
description
the new view's name.
rootFolder
the new view's description.
defaultWorkingFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
baseConfig
the default working folder path for the view. This can be overridden on each workstation as needed.
bIsBranched
the ViewConfiguration for the view. Specify the configuration of this view that is used as a starting point for the new variant view.
itemTypes
true for branch on change. Sets initial branching behavior for all items shared from this view during view creation. Specify true for default branching, false for default floating.

Return Value

the new variant view.

See Also

View Class | Borland.StarTeam Namespace | ViewConfiguration | Type


View.CreateRevisionLabel Method

Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.

public virtual Label CreateRevisionLabel(
String name,
String description,
Boolean frozen
);

Parameters

name
the label name (may not be null)
description
the label description (may not be null)
frozen
true if the label is "frozen" (a frozen label can not be moved from one revision to another)

See Also

View Class | Borland.StarTeam Namespace


View.CreateViewLabel Method

Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed.

public virtual Label CreateViewLabel(
String name,
String description,
DateTime time,
Boolean buildLabel,
Boolean frozen
);

Parameters

name
the label name (may not be null)
description
the label description (may not be null)
time
the view configuration time (may not be null)
buildLabel
true if the label is to be a "Build Label"
frozen
true if the label is "frozen" (a frozen label can not be moved from one revision to another)

See Also

View Class | Borland.StarTeam Namespace


View.Discard Method

Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled).

If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.

public virtual void Discard();

See Also

View Class | Borland.StarTeam Namespace | refresh


View.DiscardActiveLabels Method

Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).

public virtual void DiscardActiveLabels();

See Also

View Class | Borland.StarTeam Namespace | getActiveLabels | refreshActiveLabels | enableMPX


View.DiscardFolders Method

Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void DiscardFolders();

See Also

View Class | Borland.StarTeam Namespace | getRootFolder | refreshFolders


View.DiscardLabels Method

Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).

public virtual void DiscardLabels();

See Also

View Class | Borland.StarTeam Namespace | getLabels | refreshLabels


View.FetchAllLabels Method

Returns all the active (non-deleted) labels for this view.

The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects.

If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.

public virtual LabelCollection FetchAllLabels();

Return Value

The active (non-deleted) labels for this view. May be empty (but is never null).

See Also

View Class | Borland.StarTeam Namespace


View.FetchAllLabelsFromView Method

Returns all the active (non-deleted) labels for the given project and view. This method is only available for 4.1 and later servers.

The labels are not cached. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects.

fetchAllLabelsFromView() is not MPX-enabled; the labels are always retrieved directly from the repository.

public virtual LabelCollection FetchAllLabelsFromView(
Int32 projectID,
Int32 viewID
);

Parameters

projectID
viewID

Return Value

The active (non-deleted) labels for the given project and view. May be empty (but is never null).

See Also

View Class | Borland.StarTeam Namespace


View.FindFolder Method

Returns a Folder in the View, given its Item ID, or NULL if none found.

public virtual Folder FindFolder(
Int32 itemID
);

Parameters

itemID
the Item ID of the Folder to be retrieved.

Return Value

a Folder in the View, given its Item ID, or NULL if none found.

See Also

View Class | Borland.StarTeam Namespace


View.FindItem Method

Returns an Item in the View, given its Type and Item ID, or NULL if none found.

public virtual Item FindItem(
Type type,
Int32 itemID
);

Parameters

type
the Type of the Item to be retrieved.
itemID
the Item ID of the Item to be retrieved.

Return Value

an Item in the View, given its Type and Item ID, or NULL if none found.

See Also

View Class | Borland.StarTeam Namespace


View.GetContainerLevelACL Method

public virtual ACL GetContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.GetContainerLevelACL

See Also

View Class | Borland.StarTeam Namespace


View.GetDisembodiedItem Method

Retrieves an Item by Item ID. The Item can reside anywhere in this view, or in any other view on the same server. However, the resulting Item is "disembodied"; that is, it is not attached to its normal parent Folder.

Disembodied Items are useful for resolving LinkEndpoints, which can cross project and view boundaries. However, many normal Item operations are not supported for disembodied items.

getDisembodiedItem() is not MPX-enabled; each call to getDisembodiedItem() retrieves data directly from the server.

public virtual Item GetDisembodiedItem(
Int32 itemID,
Type type
);

Parameters

itemID
type

See Also

View Class | Borland.StarTeam Namespace | isDisembodied | getItem


View.GetHistoryForItemID Method

Returns "disembodied" Items from the item history

public virtual ItemCollection GetHistoryForItemID(
Int32 itemID,
Type type
);

Parameters

itemID
type

See Also

View Class | Borland.StarTeam Namespace | isDisembodied


View.GetNewNotificationItems Method

Return the list of "notification" items for the specified type. This method will not return null but may return an empty list. Once this call has been made to the server for a particular view subsequent calls will not return the same information. The act of getting the information "clears" it from the server.

public virtual NotificationItemCollection GetNewNotificationItems(
String typeName
);

Parameters

typeName
the desired item type

Return Value

the list of "notification" items for the logged in user.

See Also

View Class | Borland.StarTeam Namespace


View.HasNewNotificationItems Method

Return true if any new notification items are available in this view for the specified item type.

public virtual bool HasNewNotificationItems(
String typeName
);

Parameters

typeName
the desired item type

See Also

View Class | Borland.StarTeam Namespace


HasPermission Method

Borland StarTeam SDK for .NET

View.HasPermission Method

Overload List

public virtual bool HasPermission(Int32);

public virtual bool HasPermission(Int32,String);

See Also

View Class | Borland.StarTeam Namespace


View.HasPermission Method (Int32)

public virtual bool HasPermission(
Int32 permissions
);

Implements

ISecurable.HasPermission

See Also

View Class | Borland.StarTeam Namespace | View.HasPermission Overload List


View.HasPermission Method (Int32, String)

public virtual bool HasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.HasPermission

See Also

View Class | Borland.StarTeam Namespace | View.HasPermission Overload List


View.IsEqualTo Method

Compares the properties of two Views.

public virtual bool IsEqualTo(
View view
);

Parameters

view
The view to be compared to this one.

Return Value

true if no differences were found.

See Also

View Class | Borland.StarTeam Namespace | copy


View.ModifyItemsFlagForUser Method

Modifies this items flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.

public virtual void ModifyItemsFlagForUser(
Int32[] itemIDs,
Type type,
Boolean setFlagged
);

Parameters

itemIDs
the collection of Item IDs to modify (may not be null)
type
the Type of the Items represented by the Item IDs (may not be null)
setFlagged
this items new flag value

See Also

View Class | Borland.StarTeam Namespace | getFlag | getPossibleFlag | getFlagDisplayName | FLAG


View.ModifyItemsReadStatusForUser Method

Modifies this list of item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File items.

public virtual void ModifyItemsReadStatusForUser(
Int32[] itemIDs,
Type type,
Boolean bSetAsRead
);

Parameters

itemIDs
the collection of Item IDs to modify (may not be null)
type
the Type of the Items represented by the Item IDs (may not be null)
bSetAsRead
this items new read status

See Also

View Class | Borland.StarTeam Namespace | getReadStatus


View.NewFolderEventSource Method

public FolderEventSource NewFolderEventSource();

See Also

View Class | Borland.StarTeam Namespace


View.NewFolderTreeEventSource Method

public FolderTreeEventSource NewFolderTreeEventSource();

See Also

View Class | Borland.StarTeam Namespace


View.NewFolderUpdateEventSource Method

public FolderUpdateEventSource NewFolderUpdateEventSource();

See Also

View Class | Borland.StarTeam Namespace


NewItemEventSource Method

Borland StarTeam SDK for .NET

View.NewItemEventSource Method

Overload List

public ItemEventSource NewItemEventSource(Type);

public ItemEventSource NewItemEventSource(Type,String[]);

See Also

View Class | Borland.StarTeam Namespace


View.NewItemEventSource Method (Type)

public ItemEventSource NewItemEventSource(
Type type
);

See Also

View Class | Borland.StarTeam Namespace | View.NewItemEventSource Overload List


View.NewItemEventSource Method (Type, String[])

public ItemEventSource NewItemEventSource(
Type type,
String[] propertyNames
);

See Also

View Class | Borland.StarTeam Namespace | View.NewItemEventSource Overload List


NewItemIDEventSource Method

Borland StarTeam SDK for .NET

View.NewItemIDEventSource Method

Overload List

public ItemIDEventSource NewItemIDEventSource(Type);

public ItemIDEventSource NewItemIDEventSource(Type,String[]);

See Also

View Class | Borland.StarTeam Namespace


View.NewItemIDEventSource Method (Type)

public ItemIDEventSource NewItemIDEventSource(
Type type
);

See Also

View Class | Borland.StarTeam Namespace | View.NewItemIDEventSource Overload List


View.NewItemIDEventSource Method (Type, String[])

public ItemIDEventSource NewItemIDEventSource(
Type type,
String[] propertyNames
);

See Also

View Class | Borland.StarTeam Namespace | View.NewItemIDEventSource Overload List


NewItemListEventSource Method

Borland StarTeam SDK for .NET

View.NewItemListEventSource Method

Overload List

public ItemListEventSource NewItemListEventSource(Type);

public ItemListEventSource NewItemListEventSource(Type,String[]);

See Also

View Class | Borland.StarTeam Namespace


View.NewItemListEventSource Method (Type)

public ItemListEventSource NewItemListEventSource(
Type type
);

See Also

View Class | Borland.StarTeam Namespace | View.NewItemListEventSource Overload List


View.NewItemListEventSource Method (Type, String[])

public ItemListEventSource NewItemListEventSource(
Type type,
String[] propertyNames
);

See Also

View Class | Borland.StarTeam Namespace | View.NewItemListEventSource Overload List


View.NewItemUpdateEventSource Method

public ItemUpdateEventSource NewItemUpdateEventSource(
Type type
);

See Also

View Class | Borland.StarTeam Namespace


View.NewLabelEventSource Method

public LabelEventSource NewLabelEventSource();

See Also

View Class | Borland.StarTeam Namespace


NewNotificationEventSource Method

Borland StarTeam SDK for .NET

View.NewNotificationEventSource Method

Overload List

public NotificationEventSource NewNotificationEventSource(Type);

public NotificationEventSource NewNotificationEventSource(Type,String[]);

See Also

View Class | Borland.StarTeam Namespace


View.NewNotificationEventSource Method (Type)

public NotificationEventSource NewNotificationEventSource(
Type type
);

See Also

View Class | Borland.StarTeam Namespace | View.NewNotificationEventSource Overload List


View.NewNotificationEventSource Method (Type, String[])

public NotificationEventSource NewNotificationEventSource(
Type type,
String[] propertyNames
);

See Also

View Class | Borland.StarTeam Namespace | View.NewNotificationEventSource Overload List


View.NewViewEventSource Method

public ViewEventSource NewViewEventSource();

See Also

View Class | Borland.StarTeam Namespace


View.Populate Method

Populates project properties, if they have not already been populated.

public virtual void Populate();

See Also

View Class | Borland.StarTeam Namespace | refresh


View.Refresh Method

Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh();

See Also

View Class | Borland.StarTeam Namespace | isRefreshRequired | populate | enableMPX


View.RefreshActiveLabels Method

Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.

public virtual void RefreshActiveLabels();

See Also

View Class | Borland.StarTeam Namespace | isRefreshActiveLabelsRequired | getActiveLabels | discardActiveLabels | refreshLabels | enableMPX


View.RefreshFolders Method

Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible.

If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands.

In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.

public virtual void RefreshFolders();

See Also

View Class | Borland.StarTeam Namespace | isRefreshFoldersRequired | getRootFolder | discardFolders | enableMPX


View.RefreshLabels Method

Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.

public virtual void RefreshLabels();

See Also

View Class | Borland.StarTeam Namespace | isRefreshLabelsRequired | getLabels | discardLabels | enableMPX


View.RefreshPromotionModel Method

Refreshes the local cached information about this view's promotion model.

public virtual void RefreshPromotionModel();

See Also

View Class | Borland.StarTeam Namespace


View.Remove Method

Removes the view from the server.

public virtual void Remove();

See Also

View Class | Borland.StarTeam Namespace


View.ResolveLinkEndpoint Method

Returns the item in this view referred to by the LinkEndpoint. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.

public virtual Item ResolveLinkEndpoint(
LinkEndpoint endpoint
);

Parameters

endpoint
the endpoint to be resolved

Return Value

the item referred to by the LinkEndpoint or null if the reference does not refer to a valid item in this view.

See Also

View Class | Borland.StarTeam Namespace


View.SetContainerLevelACL Method

public virtual void SetContainerLevelACL(
ACL acl,
String typeName
);

Implements

ISecurableContainer.SetContainerLevelACL

See Also

View Class | Borland.StarTeam Namespace


View.Update Method

Persists this view's properties to its Server.

public virtual void Update();

See Also

View Class | Borland.StarTeam Namespace


View.Wrap Method

Dynamically wraps com.starbase.starteam.View.

public static View Wrap(
View impl
);

Parameters

impl
com.starbase.starteam.View to be wrapped.

Return Value

View

See Also

View Class | Borland.StarTeam Namespace


View Type Conversions

The type conversions of the View class are listed below. For a complete list of View class members, see the View Members topic.

Public Static Type Conversions

Implicit View to View Conversion Implicitly convert View to com.starbase.starteam.View.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

View Class | View Members | Borland.StarTeam Namespace


View Implicit View to View Conversion

Implicitly convert View to com.starbase.starteam.View.

public static implicit operator View(
View arg
);

Parameters

arg
View to convert.

Return Value

com.starbase.starteam.View

See Also

View Class | Borland.StarTeam Namespace


ViewCollection Class

A strongly-typed collection of Views.

For a list of all members of this type, see ViewCollection Members.

System.Object
ArrayAdapter
ViewCollection

public class ViewCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ViewCollection Members | Borland.StarTeam Namespace


ViewCollection Members

ViewCollection overview

Public Static Methods

Wrap Creates a ViewCollection to represent the given array of View (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit ViewCollection to View[] Conversion | Converts a ViewCollection to an array of Views.
Implicit ViewCollection to View[] Conversion | Converts a ViewCollection from the Borland.StarTeam namespace to a View[] in the com.starbase.starteam namespace.

Public Instance Constructors

ViewCollection Overloaded. Initializes a new instance of the ViewCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the View at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a View to end of the collection.
Append | Overloaded. Appends the Views of the given ViewCollection to the end of this ViewCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific View.
CopyTo | Copies all of the Views in the ViewCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the View with the given ID.
FindByName | Finds the View with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific View in the collection.
Insert | Inserts a View into the collection at the specified position.
Remove | Removes the first occurrence of a specific View from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Views in this ViewCollection.
Sort | Sorts the Views in this ViewCollection, using the given comparer.
SortByID | Sorts the Views in this ViewCollection by ID.
SortByName | Sorts the Views in this ViewCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection Constructor

Initializes an instance of the ViewCollection class.

Overload List

Initializes an instance of the ViewCollection class.

public ViewCollection();

Initializes an instance of the a ViewCollection class, copying the given array.

public ViewCollection(View[]);

Initializes an instance of the a ViewCollection class, copying the given collection.

public ViewCollection(ViewCollection);

Initializes an instance of the a ViewCollection class, wrapping the given array of View (from the com.starbase.starteam namespace).

public ViewCollection(View[]);

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection Constructor ()

Initializes an instance of the ViewCollection class.

public ViewCollection();

See Also

ViewCollection Class | Borland.StarTeam Namespace | ViewCollection Constructor Overload List


ViewCollection Constructor (View[])

Initializes an instance of the a ViewCollection class, wrapping the given array of View (from the com.starbase.starteam namespace).

public ViewCollection(
View[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ViewCollection Class | Borland.StarTeam Namespace | ViewCollection Constructor Overload List | Wrap


ViewCollection Constructor (ViewCollection)

Initializes an instance of the a ViewCollection class, copying the given collection.

public ViewCollection(
ViewCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member View objects of the original collection are shared, not copied.

See Also

ViewCollection Class | Borland.StarTeam Namespace | ViewCollection Constructor Overload List


ViewCollection Constructor (View[])

Initializes an instance of the a ViewCollection class, copying the given array.

public ViewCollection(
View[] array
);

Parameters

array
The array to be copied.

Remarks

The member View objects of the original array are shared, not copied.

See Also

ViewCollection Class | Borland.StarTeam Namespace | ViewCollection Constructor Overload List


ViewCollection Properties

The properties of the ViewCollection class are listed below. For a complete list of ViewCollection class members, see the ViewCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the View at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ViewCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

ViewCollection.Item Property

Gets or sets the View at the specified index.

Overload List

Gets or sets the View at the specified index.

public View this[Int32] {get; set;}

Gets the View with the given name.

public View this[String] {get;}

See Also

ViewCollection Class | Borland.StarTeam Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

ViewCollection.Item Property (Int32)

Gets or sets the View at the specified index.

public View this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the View to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ViewCollection Class | Borland.StarTeam Namespace | ViewCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

ViewCollection.Item Property (String)

Gets the View with the given name.

public View this[
String name
] {get;}

Parameters

name
The name of the View to get.

Property Value

The View with the given name, or null if there is no View with that name in this ViewCollection. Comparison is case sensitive.

See Also

ViewCollection Class | Borland.StarTeam Namespace | ViewCollection.Item Overload List | FindByName


ViewCollection Methods

The methods of the ViewCollection class are listed below. For a complete list of ViewCollection class members, see the ViewCollection Members topic.

Public Static Methods

Wrap Creates a ViewCollection to represent the given array of View (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a View to end of the collection.
Append | Overloaded. Appends the Views of the given ViewCollection to the end of this ViewCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific View.
CopyTo | Copies all of the Views in the ViewCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the View with the given ID.
FindByName | Finds the View with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific View in the collection.
Insert | Inserts a View into the collection at the specified position.
Remove | Removes the first occurrence of a specific View from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Views in this ViewCollection.
Sort | Sorts the Views in this ViewCollection, using the given comparer.
SortByID | Sorts the Views in this ViewCollection by ID.
SortByName | Sorts the Views in this ViewCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.Add Method

Adds a View to end of the collection.

public int Add(
View value
);

Parameters

value
The View to add to the collection.

Return Value

The position into which the new View was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ViewCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

ViewCollection.Append Method

Appends the Views of the given array to the end of this ViewCollection.

Overload List

Appends the Views of the given array to the end of this ViewCollection.

public ViewCollection Append(View[]);

Appends the Views of the given ViewCollection to the end of this ViewCollection.

public ViewCollection Append(ViewCollection);

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.Append Method (View[])

Appends the Views of the given array to the end of this ViewCollection.

public ViewCollection Append(
View[] array
);

Parameters

array
The array whose Views are to be appended to this ViewCollection.

Return Value

This ViewCollection, modified to include the new Views.

Remarks

The ViewCollection is modified to include the new members. The individual View objects are shared, not copied.

See Also

ViewCollection Class | Borland.StarTeam Namespace | ViewCollection.Append Overload List


ViewCollection.Append Method (ViewCollection)

Appends the Views of the given ViewCollection to the end of this ViewCollection.

public ViewCollection Append(
ViewCollection collection
);

Parameters

collection
The ViewCollection whose Views are to be appended to this ViewCollection.

Return Value

This ViewCollection, modified to include the new Views.

Remarks

The ViewCollection is modified to include the new members. The individual View objects are shared, not copied.

See Also

ViewCollection Class | Borland.StarTeam Namespace | ViewCollection.Append Overload List


ViewCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.View[].

Implements

IWrapper.Unwrap

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.Contains Method

Determines whether or not the collection contains a specific View.

public bool Contains(
View value
);

Parameters

value
The View to locate in the collection.

Return Value

true if the View is found in the collection; otherwise, false.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.CopyTo Method

Copies all of the Views in the ViewCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
View[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Views copied from the ViewCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Views in the source ViewCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ViewCollection cannot be cast automatically to the type of the destination array.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.FindByID Method

Finds the View with the given ID.

public View FindByID(
Int32 id
);

Parameters

id
The ID of the View to be found.

Return Value

The View with the given ID, or null if there is no View with that ID in this ViewCollection.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.FindByName Method

Finds the View with the given name.

public View FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the View to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The View with the given name, or null if there is no View with that name in this ViewCollection.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.IndexOf Method

Determines the index of a specific View in the collection.

public int IndexOf(
View value
);

Parameters

value
The View to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.Insert Method

Inserts a View into the collection at the specified position.

public void Insert(
Int32 index,
View value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The View to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.Remove Method

Removes the first occurrence of a specific View from the collection.

public void Remove(
View value
);

Parameters

value
The View to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.Reverse Method

Reverses the order of the Views in this ViewCollection.

new public ViewCollection Reverse();

Return Value

This ViewCollection, modified such that the Views are reversed.

Remarks

The ViewCollection is modified in place.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.Sort Method

Sorts the Views in this ViewCollection, using the given comparer.

new public ViewCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Views.

Return Value

This ViewCollection, modified such that the Views are sorted.

Remarks

The ViewCollection is modified in place.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.SortByID Method

Sorts the Views in this ViewCollection by ID.

public ViewCollection SortByID();

Return Value

This ViewCollection, modified such that the Views are sorted by ID.

Remarks

The ViewCollection is modified in place.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.SortByName Method

Sorts the Views in this ViewCollection by name.

public ViewCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This ViewCollection, modified such that the Views are sorted by name.

Remarks

The ViewCollection is modified in place.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection.Wrap Method

Creates a ViewCollection to represent the given array of View (from the com.starbase.starteam namespace).

public static ViewCollection Wrap(
View[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ViewCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a View[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection Type Conversions

The type conversions of the ViewCollection class are listed below. For a complete list of ViewCollection class members, see the ViewCollection Members topic.

Public Static Type Conversions

Implicit ViewCollection to View[] Conversion | Converts a ViewCollection to an array of Views.
Implicit ViewCollection to View[] Conversion | Converts a ViewCollection from the Borland.StarTeam namespace to a View[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

ViewCollection Class | ViewCollection Members | Borland.StarTeam Namespace


ViewCollection Implicit ViewCollection to View[] Conversion

Converts a ViewCollection to an array of Views.

public static implicit operator View[](
ViewCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new View wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one View wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewCollection Implicit ViewCollection to View[] Conversion

Converts a ViewCollection from the Borland.StarTeam namespace to a View[] in the com.starbase.starteam namespace.

public static implicit operator View[](
ViewCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ViewCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ViewCollection Class | Borland.StarTeam Namespace


ViewConfiguration Class

A class that represents the possible configuration states for a View. A StarTeam View can be in one of four different configurations: Current: all items in the view are the most recent or "tip" versions, Label: all items reference the version with the specified label attached, Time: all items reference the version that was tip as of some time, Promotion: like a label-based view but with respect to some promotion state.

For a list of all members of this type, see ViewConfiguration Members.

System.Object
ViewConfiguration

public class ViewConfiguration : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ViewConfiguration Members | Borland.StarTeam Namespace


ViewConfiguration Members

ViewConfiguration overview

Public Static Methods

CreateFromLabel | Creates a new ViewConfiguration object that represents a view in the specified label-based configuration.
CreateFromPromotionState | Creates a new ViewConfiguration object that represents a view in the specified PromotionState-based configuration.
CreateFromTime | Creates a new ViewConfiguration object that represents a view as-of a specified point in time.
CreateTip | Creates a new ViewConfiguration object that represents the current or "tip" state of a view.
Wrap | Dynamically wraps com.starbase.starteam.ViewConfiguration.

Public Static Type Conversions

Implicit ViewConfiguration to ViewConfiguration Conversion Implicitly convert ViewConfiguration to com.starbase.starteam.ViewConfiguration.

Public Instance Constructors

ViewConfiguration Constructor Construct ViewConfiguration from com.starbase.starteam.ViewConfiguration.

Public Instance Properties

IsLabelBased | [read] true if this configuration is label-based
IsPromotionStateBased | [read] true if this configuration is PromotionState-based
IsTimeBased | [read] true if this configuration is time-based
IsTip | [read] true if this configuration is tip-based
LabelID | [read] the label ID for this configuration
PromotionStateID | [read] the PromotionState ID for this configuration
Time | [read] the as-of time for this configuration

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ViewConfiguration.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ViewConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if this ViewConfiguration instance can be considered equal to the other
ToString | Delegate ToString() to com.starbase.starteam.ViewConfiguration.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration Constructor

Construct ViewConfiguration from com.starbase.starteam.ViewConfiguration.

public ViewConfiguration(
ViewConfiguration impl
);

Parameters

impl
The com.starbase.starteam.ViewConfiguration to be wrapped.

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration Properties

The properties of the ViewConfiguration class are listed below. For a complete list of ViewConfiguration class members, see the ViewConfiguration Members topic.

Public Instance Properties

IsLabelBased | [read] true if this configuration is label-based
IsPromotionStateBased | [read] true if this configuration is PromotionState-based
IsTimeBased | [read] true if this configuration is time-based
IsTip | [read] true if this configuration is tip-based
LabelID | [read] the label ID for this configuration
PromotionStateID | [read] the PromotionState ID for this configuration
Time | [read] the as-of time for this configuration

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


IsLabelBased Property

Borland StarTeam SDK for .NET

ViewConfiguration.IsLabelBased Property

[read] true if this configuration is label-based

public virtual Boolean IsLabelBased {get;}

Property Value

true if this configuration is label-based

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


IsPromotionStateBased Property

Borland StarTeam SDK for .NET

ViewConfiguration.IsPromotionStateBased Property

[read] true if this configuration is PromotionState-based

public virtual Boolean IsPromotionStateBased {get;}

Property Value

true if this configuration is PromotionState-based

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


IsTimeBased Property

Borland StarTeam SDK for .NET

ViewConfiguration.IsTimeBased Property

[read] true if this configuration is time-based

public virtual Boolean IsTimeBased {get;}

Property Value

true if this configuration is time-based

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


IsTip Property

Borland StarTeam SDK for .NET

ViewConfiguration.IsTip Property

[read] true if this configuration is tip-based

public virtual Boolean IsTip {get;}

Property Value

true if this configuration is tip-based

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


LabelID Property

Borland StarTeam SDK for .NET

ViewConfiguration.LabelID Property

[read] the label ID for this configuration

public virtual Int32 LabelID {get;}

Property Value

the label ID for this configuration

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


PromotionStateID Property

Borland StarTeam SDK for .NET

ViewConfiguration.PromotionStateID Property

[read] the PromotionState ID for this configuration

public virtual Int32 PromotionStateID {get;}

Property Value

the PromotionState ID for this configuration

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


Time Property

Borland StarTeam SDK for .NET

ViewConfiguration.Time Property

[read] the as-of time for this configuration

public virtual DateTime Time {get;}

Property Value

the as-of time for this configuration

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration Methods

The methods of the ViewConfiguration class are listed below. For a complete list of ViewConfiguration class members, see the ViewConfiguration Members topic.

Public Static Methods

CreateFromLabel | Creates a new ViewConfiguration object that represents a view in the specified label-based configuration.
CreateFromPromotionState | Creates a new ViewConfiguration object that represents a view in the specified PromotionState-based configuration.
CreateFromTime | Creates a new ViewConfiguration object that represents a view as-of a specified point in time.
CreateTip | Creates a new ViewConfiguration object that represents the current or "tip" state of a view.
Wrap | Dynamically wraps com.starbase.starteam.ViewConfiguration.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.ViewConfiguration.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ViewConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if this ViewConfiguration instance can be considered equal to the other
ToString | Delegate ToString() to com.starbase.starteam.ViewConfiguration.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ViewConfiguration

Implements

IWrapper.Unwrap

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration.CreateFromLabel Method

Creates a new ViewConfiguration object that represents a view in the specified label-based configuration.

public static ViewConfiguration CreateFromLabel(
Int32 labelID
);

Parameters

labelID
The label ID from which to base the configuration.

Return Value

a new configuration based on the specified label ID

See Also

ViewConfiguration Class | Borland.StarTeam Namespace | getID


ViewConfiguration.CreateFromPromotionState Method

Creates a new ViewConfiguration object that represents a view in the specified PromotionState-based configuration.

public static ViewConfiguration CreateFromPromotionState(
Int32 stateID
);

Parameters

stateID
The PromotionState ID from which to base the configuration.

Return Value

a new configuration based on the specified PromotionState ID

See Also

ViewConfiguration Class | Borland.StarTeam Namespace | getObjectID


ViewConfiguration.CreateFromTime Method

Creates a new ViewConfiguration object that represents a view as-of a specified point in time.

public static ViewConfiguration CreateFromTime(
DateTime oleTime
);

Parameters

oleTime
the view's as-of time

Return Value

a new configuration of the view as-of the specified time

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration.CreateTip Method

Creates a new ViewConfiguration object that represents the current or "tip" state of a view.

public static ViewConfiguration CreateTip();

Return Value

a new configuration for the tip state.

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration.Equals Method

Delegate Equals() to com.starbase.starteam.ViewConfiguration.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ViewConfiguration.Equals(obj).

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ViewConfiguration.

public override int GetHashCode();

Return Value

com.starbase.starteam.ViewConfiguration.GetHashCode().

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration.IsEqualTo Method

returns true if this ViewConfiguration instance can be considered equal to the other

public virtual bool IsEqualTo(
ViewConfiguration theOther
);

Parameters

theOther

Return Value

boolean true if this ViewConfiguration instance can be considered equal to the other

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration.ToString Method

Delegate ToString() to com.starbase.starteam.ViewConfiguration.

public override string ToString();

Return Value

com.starbase.starteam.ViewConfiguration.ToString()

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration.Wrap Method

Dynamically wraps com.starbase.starteam.ViewConfiguration.

public static ViewConfiguration Wrap(
ViewConfiguration impl
);

Parameters

impl
com.starbase.starteam.ViewConfiguration to be wrapped.

Return Value

ViewConfiguration

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfiguration Type Conversions

The type conversions of the ViewConfiguration class are listed below. For a complete list of ViewConfiguration class members, see the ViewConfiguration Members topic.

Public Static Type Conversions

Implicit ViewConfiguration to ViewConfiguration Conversion Implicitly convert ViewConfiguration to com.starbase.starteam.ViewConfiguration.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewConfiguration Class | ViewConfiguration Members | Borland.StarTeam Namespace


ViewConfiguration Implicit ViewConfiguration to ViewConfiguration Conversion

Implicitly convert ViewConfiguration to com.starbase.starteam.ViewConfiguration.

public static implicit operator ViewConfiguration(
ViewConfiguration arg
);

Parameters

arg
ViewConfiguration to convert.

Return Value

com.starbase.starteam.ViewConfiguration

See Also

ViewConfiguration Class | Borland.StarTeam Namespace


ViewConfigurationDiffer Class

Used to compare two configurations of a given view, triggering FolderUpdateEvents and ItemUpdateEvents describing the changes detected between the two.

Events are triggered only for differences detectable by comparing the two view configurations. For example, if an item was added sometime after the time represented by the first configuration, and then removed sometime before the time represented by the second configuration, then no events would be triggered for that item.

Events are triggered in an order that reflects the times the change actually occurred, when possible. For some older server versions, and for some types of view configurations, it is not currently possible to determine when a move has occurred. It is also not currently possible to determine when a folder or item was removed. Such events are triggered last.

For a list of all members of this type, see ViewConfigurationDiffer Members.

System.Object
ViewConfigurationDiffer

public class ViewConfigurationDiffer : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ViewConfigurationDiffer Members | Borland.StarTeam Namespace


ViewConfigurationDiffer Members

ViewConfigurationDiffer overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ViewConfigurationDiffer.

Public Static Type Conversions

Implicit ViewConfigurationDiffer to ViewConfigurationDiffer Conversion Implicitly convert ViewConfigurationDiffer to com.starbase.starteam.ViewConfigurationDiffer.

Public Instance Constructors

ViewConfigurationDiffer Overloaded. Initializes a new instance of the ViewConfigurationDiffer class.

Public Instance Properties

AllPropertyNamesRequired [write] Marks all property names as required for a given type. All properties will be populated as items of the given type are compared.

Public Instance Methods

AddRequiredPropertyName | Marks a given property name as required for a given type. This property will be populated as items of the given type are compared. If addPropertyName() or any of its variations is never called for a given type, then a default set of properties (including the type's descriptors) is assumed. In fact, if neither addPropertyName() nor addItemUpdateListener() is called, then that item type is not even compared.
AddRequiredPropertyNames | Marks a list of property names as required for a given type. These properties will be populated as items of the given type are compared.
Close | Frees all cached resources associated with this ViewConfigurationDiffer, and closes the associated view.
Compare | Comnpares the two given configurations of this view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected between the two. The folder tree is always compared. In addition, the items are compared for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.
Equals | Delegate Equals() to com.starbase.starteam.ViewConfigurationDiffer.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ViewConfigurationDiffer.
GetType (inherited from Object) | Gets the Type of the current instance.
NewFolderUpdateEventSource |
NewItemUpdateEventSource |
ToString | Delegate ToString() to com.starbase.starteam.ViewConfigurationDiffer.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer Constructor

Construct ViewConfigurationDiffer from com.starbase.starteam.ViewConfigurationDiffer.

Overload List

Constructs a new ViewCOnfigurationDiffer.

public ViewConfigurationDiffer(View);

Construct ViewConfigurationDiffer from com.starbase.starteam.ViewConfigurationDiffer.

public ViewConfigurationDiffer(ViewConfigurationDiffer);

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer Constructor (ViewConfigurationDiffer)

Construct ViewConfigurationDiffer from com.starbase.starteam.ViewConfigurationDiffer.

public ViewConfigurationDiffer(
ViewConfigurationDiffer impl
);

Parameters

impl
The com.starbase.starteam.ViewConfigurationDiffer to be wrapped.

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace | ViewConfigurationDiffer Constructor Overload List


ViewConfigurationDiffer Constructor (View)

Constructs a new ViewCOnfigurationDiffer.

public ViewConfigurationDiffer(
View view
);

Parameters

view
The view whose configurations are to be compared.

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace | ViewConfigurationDiffer Constructor Overload List


ViewConfigurationDiffer Properties

The properties of the ViewConfigurationDiffer class are listed below. For a complete list of ViewConfigurationDiffer class members, see the ViewConfigurationDiffer Members topic.

Public Instance Properties

AllPropertyNamesRequired [write] Marks all property names as required for a given type. All properties will be populated as items of the given type are compared.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


AllPropertyNamesRequired Property

Borland StarTeam SDK for .NET

ViewConfigurationDiffer.AllPropertyNamesRequired Property

[write] Marks all property names as required for a given type. All properties will be populated as items of the given type are compared.

public virtual Type AllPropertyNamesRequired {set;}

Property Value

Marks all property names as required for a given type. All properties will be populated as items of the given type are compared.

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer Methods

The methods of the ViewConfigurationDiffer class are listed below. For a complete list of ViewConfigurationDiffer class members, see the ViewConfigurationDiffer Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ViewConfigurationDiffer.

Public Instance Methods

AddRequiredPropertyName | Marks a given property name as required for a given type. This property will be populated as items of the given type are compared. If addPropertyName() or any of its variations is never called for a given type, then a default set of properties (including the type's descriptors) is assumed. In fact, if neither addPropertyName() nor addItemUpdateListener() is called, then that item type is not even compared.
AddRequiredPropertyNames | Marks a list of property names as required for a given type. These properties will be populated as items of the given type are compared.
Close | Frees all cached resources associated with this ViewConfigurationDiffer, and closes the associated view.
Compare | Comnpares the two given configurations of this view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected between the two. The folder tree is always compared. In addition, the items are compared for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.
Equals | Delegate Equals() to com.starbase.starteam.ViewConfigurationDiffer.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ViewConfigurationDiffer.
GetType (inherited from Object) | Gets the Type of the current instance.
NewFolderUpdateEventSource |
NewItemUpdateEventSource |
ToString | Delegate ToString() to com.starbase.starteam.ViewConfigurationDiffer.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer.AddRequiredPropertyName Method

Marks a given property name as required for a given type. This property will be populated as items of the given type are compared.

If addPropertyName() or any of its variations is never called for a given type, then a default set of properties (including the type's descriptors) is assumed. In fact, if neither addPropertyName() nor addItemUpdateListener() is called, then that item type is not even compared.

public virtual void AddRequiredPropertyName(
Type type,
String propertyName
);

Parameters

type
An item type.
propertyName
A property name.

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace | compare | addRequiredPropertyNames | setAllPropertyNamesRequired


ViewConfigurationDiffer.AddRequiredPropertyNames Method

Marks a list of property names as required for a given type. These properties will be populated as items of the given type are compared.

public virtual void AddRequiredPropertyNames(
Type type,
String[] propertyNames
);

Parameters

type
An item type.
propertyNames
A list of property names.

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace | addRequiredPropertyName


ViewConfigurationDiffer.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ViewConfigurationDiffer

Implements

IWrapper.Unwrap

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer.Close Method

Frees all cached resources associated with this ViewConfigurationDiffer, and closes the associated view.

public virtual void Close();

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace | close


ViewConfigurationDiffer.Compare Method

Comnpares the two given configurations of this view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected between the two.

The folder tree is always compared. In addition, the items are compared for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.

public virtual void Compare(
ViewConfiguration config1,
ViewConfiguration config2
);

Parameters

config1
The first (earlier) view configuration.
config2
The second (later) view configuration.

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer.Equals Method

Delegate Equals() to com.starbase.starteam.ViewConfigurationDiffer.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ViewConfigurationDiffer.Equals(obj).

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ViewConfigurationDiffer.

public override int GetHashCode();

Return Value

com.starbase.starteam.ViewConfigurationDiffer.GetHashCode().

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer.NewFolderUpdateEventSource Method

public FolderUpdateEventSource NewFolderUpdateEventSource();

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer.NewItemUpdateEventSource Method

public ItemUpdateEventSource NewItemUpdateEventSource(
Type type
);

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer.ToString Method

Delegate ToString() to com.starbase.starteam.ViewConfigurationDiffer.

public override string ToString();

Return Value

com.starbase.starteam.ViewConfigurationDiffer.ToString()

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer.Wrap Method

Dynamically wraps com.starbase.starteam.ViewConfigurationDiffer.

public static ViewConfigurationDiffer Wrap(
ViewConfigurationDiffer impl
);

Parameters

impl
com.starbase.starteam.ViewConfigurationDiffer to be wrapped.

Return Value

ViewConfigurationDiffer

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewConfigurationDiffer Type Conversions

The type conversions of the ViewConfigurationDiffer class are listed below. For a complete list of ViewConfigurationDiffer class members, see the ViewConfigurationDiffer Members topic.

Public Static Type Conversions

Implicit ViewConfigurationDiffer to ViewConfigurationDiffer Conversion Implicitly convert ViewConfigurationDiffer to com.starbase.starteam.ViewConfigurationDiffer.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewConfigurationDiffer Class | ViewConfigurationDiffer Members | Borland.StarTeam Namespace


ViewConfigurationDiffer Implicit ViewConfigurationDiffer to ViewConfigurationDiffer Conversion

Implicitly convert ViewConfigurationDiffer to com.starbase.starteam.ViewConfigurationDiffer.

public static implicit operator ViewConfigurationDiffer(
ViewConfigurationDiffer arg
);

Parameters

arg
ViewConfigurationDiffer to convert.

Return Value

com.starbase.starteam.ViewConfigurationDiffer

See Also

ViewConfigurationDiffer Class | Borland.StarTeam Namespace


ViewEventArgs Class

For a list of all members of this type, see ViewEventArgs Members.

System.Object
EventArgs
ViewEventArgs

public class ViewEventArgs : EventArgs, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ViewEventArgs Members | Borland.StarTeam Namespace


ViewEventArgs Members

ViewEventArgs overview

Public Static Type Conversions

Implicit ViewEventArgs to ViewEvent Conversion Implicitly convert ViewEventArgs to com.starbase.starteam.ViewEvent.

Public Instance Properties

View [read] The View that has been added, changed or deleted, in its new state.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ViewEventArgs Class | Borland.StarTeam Namespace


ViewEventArgs Properties

The properties of the ViewEventArgs class are listed below. For a complete list of ViewEventArgs class members, see the ViewEventArgs Members topic.

Public Instance Properties

View [read] The View that has been added, changed or deleted, in its new state.

See Also

ViewEventArgs Class | Borland.StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

ViewEventArgs.View Property

[read] The View that has been added, changed or deleted, in its new state.

public virtual View View {get;}

Property Value

The View that has been added, changed or deleted, in its new state.

See Also

ViewEventArgs Class | Borland.StarTeam Namespace


ViewEventArgs Methods

The methods of the ViewEventArgs class are listed below. For a complete list of ViewEventArgs class members, see the ViewEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Unwrap |

See Also

ViewEventArgs Class | Borland.StarTeam Namespace


ViewEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ViewEventArgs Class | Borland.StarTeam Namespace


ViewEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ViewEventArgs Class | Borland.StarTeam Namespace


ViewEventArgs.ToString Method

public override string ToString();

See Also

ViewEventArgs Class | Borland.StarTeam Namespace


ViewEventArgs.Unwrap Method

public object Unwrap();

Implements

IWrapper.Unwrap

See Also

ViewEventArgs Class | Borland.StarTeam Namespace


ViewEventArgs Type Conversions

The type conversions of the ViewEventArgs class are listed below. For a complete list of ViewEventArgs class members, see the ViewEventArgs Members topic.

Public Static Type Conversions

Implicit ViewEventArgs to ViewEvent Conversion Implicitly convert ViewEventArgs to com.starbase.starteam.ViewEvent.

See Also

ViewEventArgs Class | ViewEventArgs Members | Borland.StarTeam Namespace


ViewEventArgs Implicit ViewEventArgs to ViewEvent Conversion

Implicitly convert ViewEventArgs to com.starbase.starteam.ViewEvent.

public static implicit operator ViewEvent(
ViewEventArgs arg
);

Parameters

arg
ViewEventArgs to convert.

Return Value

com.starbase.starteam.ViewEvent

See Also

ViewEventArgs Class | Borland.StarTeam Namespace


ViewEventSource Class

For a list of all members of this type, see ViewEventSource Members.

System.Object
ViewEventSource

public class ViewEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ViewEventSource Members | Borland.StarTeam Namespace


ViewEventSource Members

ViewEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnViewAdded
OnViewChanged
OnViewDeleted
ViewAdded
ViewChanged
ViewDeleted

See Also

ViewEventSource Class | Borland.StarTeam Namespace


ViewEventSource Properties

The properties of the ViewEventSource class are listed below. For a complete list of ViewEventSource class members, see the ViewEventSource Members topic.

Public Instance Properties

Parent

See Also

ViewEventSource Class | Borland.StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

ViewEventSource.Parent Property

public Object Parent {get;}

See Also

ViewEventSource Class | Borland.StarTeam Namespace


ViewEventSource Events

The events of the ViewEventSource class are listed below. For a complete list of ViewEventSource class members, see the ViewEventSource Members topic.

Public Instance Events

OnViewAdded
OnViewChanged
OnViewDeleted
ViewAdded
ViewChanged
ViewDeleted

See Also

ViewEventSource Class | Borland.StarTeam Namespace


ViewEventSource.OnViewAdded Event

public event ViewEventSource.Handler OnViewAdded;

See Also

ViewEventSource Class | Borland.StarTeam Namespace


ViewEventSource.OnViewChanged Event

public event ViewEventSource.Handler OnViewChanged;

See Also

ViewEventSource Class | Borland.StarTeam Namespace


ViewEventSource.OnViewDeleted Event

public event ViewEventSource.Handler OnViewDeleted;

See Also

ViewEventSource Class | Borland.StarTeam Namespace


ViewEventSource.ViewAdded Event

public event ViewEventSource.Handler ViewAdded;

See Also

ViewEventSource Class | Borland.StarTeam Namespace


ViewEventSource.ViewChanged Event

public event ViewEventSource.Handler ViewChanged;

See Also

ViewEventSource Class | Borland.StarTeam Namespace


ViewEventSource.ViewDeleted Event

public event ViewEventSource.Handler ViewDeleted;

See Also

ViewEventSource Class | Borland.StarTeam Namespace


ViewEventSource.Handler Delegate

public delegate void ViewEventSource.Handler(
ViewEventSource source,
ViewEventArgs e
);

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Borland.StarTeam Namespace

Copyright 2004, Borland Corp.


ViewPollingAgent Class

Used to periodically poll a given view for recent changes, triggering FolderUpdateEvents and ItemUpdateEvents describing the changes detected since the last poll.

Events are triggered only for differences detectable across the polling interval. For example, if an item is added then removed without an intervening refresh, then no events would be triggered for that item.

Events are triggered in an order that reflects the times the change actually occurred, when possible. For some older server versions, it is not possible to determine when a move has occurred. It is also not currently possible to determine when a folder or item was removed. Such events are triggered last.

There are two basic ways to use a ViewPollingAgent. The first way is to create one and keep it around for a long time, periodically calling refresh() to trigger events. This is generally faster than creating a new ViewPollingAgent for each refresh(). However, the ViewPollingAgent consumes memory while it is in use.

The second way is to create a new ViewPollingAgent at each polling interval, call refresh() once to trigger events, and save the time returned by refresh() to use later when creating a ViewPollingAgent for the next poll. This is slower, but uses less memory between polls.

For a list of all members of this type, see ViewPollingAgent Members.

System.Object
ViewPollingAgent

public class ViewPollingAgent : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ViewPollingAgent Members | Borland.StarTeam Namespace


ViewPollingAgent Members

ViewPollingAgent overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ViewPollingAgent.

Public Static Type Conversions

Implicit ViewPollingAgent to ViewPollingAgent Conversion Implicitly convert ViewPollingAgent to com.starbase.starteam.ViewPollingAgent.

Public Instance Constructors

ViewPollingAgent Overloaded. Initializes a new instance of the ViewPollingAgent class.

Public Instance Properties

AllPropertyNamesRequired [write] Marks all property names as required for a given type. All refresh operations on that type will include all properties.

Public Instance Methods

AddRequiredPropertyName | Marks a given property name as required for a given type. All refresh operations on that type will include this property. If addPropertyName() or any of its variations is never called for a given type, then a default set of properties (including the type's descriptors) is assumed. In fact, if neither addPropertyName() nor addItemUpdateListener() is called, then that item type is not even refreshed.
AddRequiredPropertyNames | Marks a list of property names as required for a given type. All refresh operations on that type will include these properties.
Close | Frees all cached resources associated with this ViewPollingAgent, and closes the associated view.
Equals | Delegate Equals() to com.starbase.starteam.ViewPollingAgent.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ViewPollingAgent.
GetType (inherited from Object) | Gets the Type of the current instance.
NewFolderUpdateEventSource |
NewItemUpdateEventSource |
Refresh | Refreshes the view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected since the previous refresh (or since the start ViewPollingAgent's start time, if this is the first refresh). The folder tree is always refreshed. In addition, all items a refreshed for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.
ToString | Delegate ToString() to com.starbase.starteam.ViewPollingAgent.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent Constructor

Construct ViewPollingAgent from com.starbase.starteam.ViewPollingAgent.

Overload List

Constructs a new ViewPollingAgent.

public ViewPollingAgent(View,DateTime);

Construct ViewPollingAgent from com.starbase.starteam.ViewPollingAgent.

public ViewPollingAgent(ViewPollingAgent);

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent Constructor (ViewPollingAgent)

Construct ViewPollingAgent from com.starbase.starteam.ViewPollingAgent.

public ViewPollingAgent(
ViewPollingAgent impl
);

Parameters

impl
The com.starbase.starteam.ViewPollingAgent to be wrapped.

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace | ViewPollingAgent Constructor Overload List


ViewPollingAgent Constructor (View, DateTime)

Constructs a new ViewPollingAgent.

public ViewPollingAgent(
View view,
DateTime startTime
);

Parameters

view
The view whose changes are to be monitored.
startTime
The start time for detecting changes. Often the same as the time returned by the last call to refresh() from a previously instantiated ViewPollingAgent.

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace | ViewPollingAgent Constructor Overload List


ViewPollingAgent Properties

The properties of the ViewPollingAgent class are listed below. For a complete list of ViewPollingAgent class members, see the ViewPollingAgent Members topic.

Public Instance Properties

AllPropertyNamesRequired [write] Marks all property names as required for a given type. All refresh operations on that type will include all properties.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


AllPropertyNamesRequired Property

Borland StarTeam SDK for .NET

ViewPollingAgent.AllPropertyNamesRequired Property

[write] Marks all property names as required for a given type. All refresh operations on that type will include all properties.

public virtual Type AllPropertyNamesRequired {set;}

Property Value

Marks all property names as required for a given type. All refresh operations on that type will include all properties.

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent Methods

The methods of the ViewPollingAgent class are listed below. For a complete list of ViewPollingAgent class members, see the ViewPollingAgent Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.ViewPollingAgent.

Public Instance Methods

AddRequiredPropertyName | Marks a given property name as required for a given type. All refresh operations on that type will include this property. If addPropertyName() or any of its variations is never called for a given type, then a default set of properties (including the type's descriptors) is assumed. In fact, if neither addPropertyName() nor addItemUpdateListener() is called, then that item type is not even refreshed.
AddRequiredPropertyNames | Marks a list of property names as required for a given type. All refresh operations on that type will include these properties.
Close | Frees all cached resources associated with this ViewPollingAgent, and closes the associated view.
Equals | Delegate Equals() to com.starbase.starteam.ViewPollingAgent.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.ViewPollingAgent.
GetType (inherited from Object) | Gets the Type of the current instance.
NewFolderUpdateEventSource |
NewItemUpdateEventSource |
Refresh | Refreshes the view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected since the previous refresh (or since the start ViewPollingAgent's start time, if this is the first refresh). The folder tree is always refreshed. In addition, all items a refreshed for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.
ToString | Delegate ToString() to com.starbase.starteam.ViewPollingAgent.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent.AddRequiredPropertyName Method

Marks a given property name as required for a given type. All refresh operations on that type will include this property.

If addPropertyName() or any of its variations is never called for a given type, then a default set of properties (including the type's descriptors) is assumed. In fact, if neither addPropertyName() nor addItemUpdateListener() is called, then that item type is not even refreshed.

public virtual void AddRequiredPropertyName(
Type type,
String propertyName
);

Parameters

type
An item type.
propertyName
A property name.

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace | refresh | addRequiredPropertyNames | setAllPropertyNamesRequired


ViewPollingAgent.AddRequiredPropertyNames Method

Marks a list of property names as required for a given type. All refresh operations on that type will include these properties.

public virtual void AddRequiredPropertyNames(
Type type,
String[] propertyNames
);

Parameters

type
An item type.
propertyNames
A list of property names.

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace | addRequiredPropertyName


ViewPollingAgent.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.ViewPollingAgent

Implements

IWrapper.Unwrap

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent.Close Method

Frees all cached resources associated with this ViewPollingAgent, and closes the associated view.

public virtual void Close();

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace | close


ViewPollingAgent.Equals Method

Delegate Equals() to com.starbase.starteam.ViewPollingAgent.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.ViewPollingAgent.Equals(obj).

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.ViewPollingAgent.

public override int GetHashCode();

Return Value

com.starbase.starteam.ViewPollingAgent.GetHashCode().

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent.NewFolderUpdateEventSource Method

public FolderUpdateEventSource NewFolderUpdateEventSource();

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent.NewItemUpdateEventSource Method

public ItemUpdateEventSource NewItemUpdateEventSource(
Type type
);

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent.Refresh Method

Refreshes the view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected since the previous refresh (or since the start ViewPollingAgent's start time, if this is the first refresh).

The folder tree is always refreshed. In addition, all items a refreshed for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.

public virtual DateTime Refresh();

Return Value

The poll time used for this refresh operation. You can continue to refresh using this ViewPollingAgent, or use this poll time as the start time for a new ViewPollingAgent to pick up where this one left off.

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent.ToString Method

Delegate ToString() to com.starbase.starteam.ViewPollingAgent.

public override string ToString();

Return Value

com.starbase.starteam.ViewPollingAgent.ToString()

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent.Wrap Method

Dynamically wraps com.starbase.starteam.ViewPollingAgent.

public static ViewPollingAgent Wrap(
ViewPollingAgent impl
);

Parameters

impl
com.starbase.starteam.ViewPollingAgent to be wrapped.

Return Value

ViewPollingAgent

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


ViewPollingAgent Type Conversions

The type conversions of the ViewPollingAgent class are listed below. For a complete list of ViewPollingAgent class members, see the ViewPollingAgent Members topic.

Public Static Type Conversions

Implicit ViewPollingAgent to ViewPollingAgent Conversion Implicitly convert ViewPollingAgent to com.starbase.starteam.ViewPollingAgent.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ViewPollingAgent Class | ViewPollingAgent Members | Borland.StarTeam Namespace


ViewPollingAgent Implicit ViewPollingAgent to ViewPollingAgent Conversion

Implicitly convert ViewPollingAgent to com.starbase.starteam.ViewPollingAgent.

public static implicit operator ViewPollingAgent(
ViewPollingAgent arg
);

Parameters

arg
ViewPollingAgent to convert.

Return Value

com.starbase.starteam.ViewPollingAgent

See Also

ViewPollingAgent Class | Borland.StarTeam Namespace


WorkRecord Class

Record of a period of work expended for a task.

For a list of all members of this type, see WorkRecord Members.

System.Object
WorkRecord

public class WorkRecord : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

WorkRecord Members | Borland.StarTeam Namespace


WorkRecord Members

WorkRecord overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.WorkRecord.

Public Static Type Conversions

Implicit WorkRecord to WorkRecord Conversion Implicitly convert WorkRecord to com.starbase.starteam.WorkRecord.

Public Instance Constructors

WorkRecord Overloaded. Initializes a new instance of the WorkRecord class.

Public Instance Properties

DateWorkBegan | [read/write] the date on which the work was begun.
HoursRemaining | [read/write] the estimated number of hours remaining to complete the task after this period.
HoursWorked | [read/write] the number of hours spent on the task during this period.
ID | [read] the integer identifier of the work record.
IsDirty | [read] true if this WorkRecord has been modified but not yet saved.
Notes | [read/write] the notes about this work record.
WorkPerformedBy | [read/write] the user ID for the person who performed the work.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.WorkRecord.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.WorkRecord.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.WorkRecord.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

WorkRecord Class | Borland.StarTeam Namespace


WorkRecord Constructor

Construct WorkRecord from com.starbase.starteam.WorkRecord.

Overload List

Creates a new WorkRecord for the specified Task and user.

public WorkRecord(Task,Int32);

Construct WorkRecord from com.starbase.starteam.WorkRecord.

public WorkRecord(WorkRecord);

See Also

WorkRecord Class | Borland.StarTeam Namespace


WorkRecord Constructor (WorkRecord)

Construct WorkRecord from com.starbase.starteam.WorkRecord.

public WorkRecord(
WorkRecord impl
);

Parameters

impl
The com.starbase.starteam.WorkRecord to be wrapped.

See Also

WorkRecord Class | Borland.StarTeam Namespace | WorkRecord Constructor Overload List


WorkRecord Constructor (Task, Int32)

Creates a new WorkRecord for the specified Task and user.

public WorkRecord(
Task task,
Int32 userID
);

Parameters

task
the to which this work record belongs
userID
the user ID for the user that performed the work

See Also

WorkRecord Class | Borland.StarTeam Namespace | WorkRecord Constructor Overload List


WorkRecord Properties

The properties of the WorkRecord class are listed below. For a complete list of WorkRecord class members, see the WorkRecord Members topic.

Public Instance Properties

DateWorkBegan | [read/write] the date on which the work was begun.
HoursRemaining | [read/write] the estimated number of hours remaining to complete the task after this period.
HoursWorked | [read/write] the number of hours spent on the task during this period.
ID | [read] the integer identifier of the work record.
IsDirty | [read] true if this WorkRecord has been modified but not yet saved.
Notes | [read/write] the notes about this work record.
WorkPerformedBy | [read/write] the user ID for the person who performed the work.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

WorkRecord Class | Borland.StarTeam Namespace


DateWorkBegan Property

Borland StarTeam SDK for .NET

WorkRecord.DateWorkBegan Property

[read/write] the date on which the work was begun.

public virtual DateTime DateWorkBegan {get; set;}

Property Value

the date on which the work was begun.

See Also

WorkRecord Class | Borland.StarTeam Namespace


HoursRemaining Property

Borland StarTeam SDK for .NET

WorkRecord.HoursRemaining Property

[read/write] the estimated number of hours remaining to complete the task after this period.

public virtual Double HoursRemaining {get; set;}

Property Value

the estimated number of hours remaining to complete the task after this period.

See Also

WorkRecord Class | Borland.StarTeam Namespace


HoursWorked Property

Borland StarTeam SDK for .NET

WorkRecord.HoursWorked Property

[read/write] the number of hours spent on the task during this period.

public virtual Double HoursWorked {get; set;}

Property Value

the number of hours spent on the task during this period.

See Also

WorkRecord Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

WorkRecord.ID Property

[read] the integer identifier of the work record.

public virtual Int32 ID {get;}

Property Value

the integer identifier of the work record.

See Also

WorkRecord Class | Borland.StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

WorkRecord.IsDirty Property

[read] true if this WorkRecord has been modified but not yet saved.

public virtual Boolean IsDirty {get;}

Property Value

true if this WorkRecord has been modified but not yet saved.

See Also

WorkRecord Class | Borland.StarTeam Namespace


Notes Property

Borland StarTeam SDK for .NET

WorkRecord.Notes Property

[read/write] the notes about this work record.

public virtual String Notes {get; set;}

Property Value

the notes about this work record.

See Also

WorkRecord Class | Borland.StarTeam Namespace


WorkPerformedBy Property

Borland StarTeam SDK for .NET

WorkRecord.WorkPerformedBy Property

[read/write] the user ID for the person who performed the work.

public virtual Int32 WorkPerformedBy {get; set;}

Property Value

the user ID for the person who performed the work.

See Also

WorkRecord Class | Borland.StarTeam Namespace


WorkRecord Methods

The methods of the WorkRecord class are listed below. For a complete list of WorkRecord class members, see the WorkRecord Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.WorkRecord.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.WorkRecord.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.WorkRecord.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.WorkRecord.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

WorkRecord Class | Borland.StarTeam Namespace


WorkRecord.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.WorkRecord

Implements

IWrapper.Unwrap

See Also

WorkRecord Class | Borland.StarTeam Namespace


WorkRecord.Equals Method

Delegate Equals() to com.starbase.starteam.WorkRecord.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.WorkRecord.Equals(obj).

See Also

WorkRecord Class | Borland.StarTeam Namespace


WorkRecord.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.WorkRecord.

public override int GetHashCode();

Return Value

com.starbase.starteam.WorkRecord.GetHashCode().

See Also

WorkRecord Class | Borland.StarTeam Namespace


WorkRecord.ToString Method

Delegate ToString() to com.starbase.starteam.WorkRecord.

public override string ToString();

Return Value

com.starbase.starteam.WorkRecord.ToString()

See Also

WorkRecord Class | Borland.StarTeam Namespace


WorkRecord.Wrap Method

Dynamically wraps com.starbase.starteam.WorkRecord.

public static WorkRecord Wrap(
WorkRecord impl
);

Parameters

impl
com.starbase.starteam.WorkRecord to be wrapped.

Return Value

WorkRecord

See Also

WorkRecord Class | Borland.StarTeam Namespace


WorkRecord Type Conversions

The type conversions of the WorkRecord class are listed below. For a complete list of WorkRecord class members, see the WorkRecord Members topic.

Public Static Type Conversions

Implicit WorkRecord to WorkRecord Conversion Implicitly convert WorkRecord to com.starbase.starteam.WorkRecord.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

WorkRecord Class | WorkRecord Members | Borland.StarTeam Namespace


WorkRecord Implicit WorkRecord to WorkRecord Conversion

Implicitly convert WorkRecord to com.starbase.starteam.WorkRecord.

public static implicit operator WorkRecord(
WorkRecord arg
);

Parameters

arg
WorkRecord to convert.

Return Value

com.starbase.starteam.WorkRecord

See Also

WorkRecord Class | Borland.StarTeam Namespace


WorkRecordCollection Class

A strongly-typed collection of WorkRecords.

For a list of all members of this type, see WorkRecordCollection Members.

System.Object
ArrayAdapter
WorkRecordCollection

public class WorkRecordCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

WorkRecordCollection Members | Borland.StarTeam Namespace


WorkRecordCollection Members

WorkRecordCollection overview

Public Static Methods

Wrap Creates a WorkRecordCollection to represent the given array of WorkRecord (from the com.starbase.starteam namespace).

Public Static Type Conversions

Implicit WorkRecordCollection to WorkRecord[] Conversion | Converts a WorkRecordCollection to an array of WorkRecords.
Implicit WorkRecordCollection to WorkRecord[] Conversion | Converts a WorkRecordCollection from the Borland.StarTeam namespace to a WorkRecord[] in the com.starbase.starteam namespace.

Public Instance Constructors

WorkRecordCollection Overloaded. Initializes a new instance of the WorkRecordCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the WorkRecord at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a WorkRecord to end of the collection.
Append | Overloaded. Appends the WorkRecords of the given WorkRecordCollection to the end of this WorkRecordCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific WorkRecord.
CopyTo | Copies all of the WorkRecords in the WorkRecordCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the WorkRecord with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific WorkRecord in the collection.
Insert | Inserts a WorkRecord into the collection at the specified position.
Remove | Removes the first occurrence of a specific WorkRecord from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the WorkRecords in this WorkRecordCollection.
Sort | Sorts the WorkRecords in this WorkRecordCollection, using the given comparer.
SortByID | Sorts the WorkRecords in this WorkRecordCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection Constructor

Initializes an instance of the WorkRecordCollection class.

Overload List

Initializes an instance of the WorkRecordCollection class.

public WorkRecordCollection();

Initializes an instance of the a WorkRecordCollection class, copying the given array.

public WorkRecordCollection(WorkRecord[]);

Initializes an instance of the a WorkRecordCollection class, copying the given collection.

public WorkRecordCollection(WorkRecordCollection);

Initializes an instance of the a WorkRecordCollection class, wrapping the given array of WorkRecord (from the com.starbase.starteam namespace).

public WorkRecordCollection(WorkRecord[]);

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection Constructor ()

Initializes an instance of the WorkRecordCollection class.

public WorkRecordCollection();

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace | WorkRecordCollection Constructor Overload List


WorkRecordCollection Constructor (WorkRecord[])

Initializes an instance of the a WorkRecordCollection class, wrapping the given array of WorkRecord (from the com.starbase.starteam namespace).

public WorkRecordCollection(
WorkRecord[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace | WorkRecordCollection Constructor Overload List | Wrap


WorkRecordCollection Constructor (WorkRecordCollection)

Initializes an instance of the a WorkRecordCollection class, copying the given collection.

public WorkRecordCollection(
WorkRecordCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member WorkRecord objects of the original collection are shared, not copied.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace | WorkRecordCollection Constructor Overload List


WorkRecordCollection Constructor (WorkRecord[])

Initializes an instance of the a WorkRecordCollection class, copying the given array.

public WorkRecordCollection(
WorkRecord[] array
);

Parameters

array
The array to be copied.

Remarks

The member WorkRecord objects of the original array are shared, not copied.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace | WorkRecordCollection Constructor Overload List


WorkRecordCollection Properties

The properties of the WorkRecordCollection class are listed below. For a complete list of WorkRecordCollection class members, see the WorkRecordCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the WorkRecord at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

WorkRecordCollection.Item Property

Gets or sets the WorkRecord at the specified index.

public WorkRecord this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the WorkRecord to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection Methods

The methods of the WorkRecordCollection class are listed below. For a complete list of WorkRecordCollection class members, see the WorkRecordCollection Members topic.

Public Static Methods

Wrap Creates a WorkRecordCollection to represent the given array of WorkRecord (from the com.starbase.starteam namespace).

Public Instance Methods

Add | Adds a WorkRecord to end of the collection.
Append | Overloaded. Appends the WorkRecords of the given WorkRecordCollection to the end of this WorkRecordCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific WorkRecord.
CopyTo | Copies all of the WorkRecords in the WorkRecordCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the WorkRecord with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific WorkRecord in the collection.
Insert | Inserts a WorkRecord into the collection at the specified position.
Remove | Removes the first occurrence of a specific WorkRecord from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the WorkRecords in this WorkRecordCollection.
Sort | Sorts the WorkRecords in this WorkRecordCollection, using the given comparer.
SortByID | Sorts the WorkRecords in this WorkRecordCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.Add Method

Adds a WorkRecord to end of the collection.

public int Add(
WorkRecord value
);

Parameters

value
The WorkRecord to add to the collection.

Return Value

The position into which the new WorkRecord was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


Append Method

Borland StarTeam SDK for .NET

WorkRecordCollection.Append Method

Appends the WorkRecords of the given array to the end of this WorkRecordCollection.

Overload List

Appends the WorkRecords of the given array to the end of this WorkRecordCollection.

public WorkRecordCollection Append(WorkRecord[]);

Appends the WorkRecords of the given WorkRecordCollection to the end of this WorkRecordCollection.

public WorkRecordCollection Append(WorkRecordCollection);

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.Append Method (WorkRecord[])

Appends the WorkRecords of the given array to the end of this WorkRecordCollection.

public WorkRecordCollection Append(
WorkRecord[] array
);

Parameters

array
The array whose WorkRecords are to be appended to this WorkRecordCollection.

Return Value

This WorkRecordCollection, modified to include the new WorkRecords.

Remarks

The WorkRecordCollection is modified to include the new members. The individual WorkRecord objects are shared, not copied.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace | WorkRecordCollection.Append Overload List


WorkRecordCollection.Append Method (WorkRecordCollection)

Appends the WorkRecords of the given WorkRecordCollection to the end of this WorkRecordCollection.

public WorkRecordCollection Append(
WorkRecordCollection collection
);

Parameters

collection
The WorkRecordCollection whose WorkRecords are to be appended to this WorkRecordCollection.

Return Value

This WorkRecordCollection, modified to include the new WorkRecords.

Remarks

The WorkRecordCollection is modified to include the new members. The individual WorkRecord objects are shared, not copied.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace | WorkRecordCollection.Append Overload List


WorkRecordCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.WorkRecord[].

Implements

IWrapper.Unwrap

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.Contains Method

Determines whether or not the collection contains a specific WorkRecord.

public bool Contains(
WorkRecord value
);

Parameters

value
The WorkRecord to locate in the collection.

Return Value

true if the WorkRecord is found in the collection; otherwise, false.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.CopyTo Method

Copies all of the WorkRecords in the WorkRecordCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
WorkRecord[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the WorkRecords copied from the WorkRecordCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of WorkRecords in the source WorkRecordCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source WorkRecordCollection cannot be cast automatically to the type of the destination array.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.FindByID Method

Finds the WorkRecord with the given ID.

public WorkRecord FindByID(
Int32 id
);

Parameters

id
The ID of the WorkRecord to be found.

Return Value

The WorkRecord with the given ID, or null if there is no WorkRecord with that ID in this WorkRecordCollection.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.IndexOf Method

Determines the index of a specific WorkRecord in the collection.

public int IndexOf(
WorkRecord value
);

Parameters

value
The WorkRecord to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.Insert Method

Inserts a WorkRecord into the collection at the specified position.

public void Insert(
Int32 index,
WorkRecord value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The WorkRecord to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.Remove Method

Removes the first occurrence of a specific WorkRecord from the collection.

public void Remove(
WorkRecord value
);

Parameters

value
The WorkRecord to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.Reverse Method

Reverses the order of the WorkRecords in this WorkRecordCollection.

new public WorkRecordCollection Reverse();

Return Value

This WorkRecordCollection, modified such that the WorkRecords are reversed.

Remarks

The WorkRecordCollection is modified in place.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.Sort Method

Sorts the WorkRecords in this WorkRecordCollection, using the given comparer.

new public WorkRecordCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two WorkRecords.

Return Value

This WorkRecordCollection, modified such that the WorkRecords are sorted.

Remarks

The WorkRecordCollection is modified in place.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.SortByID Method

Sorts the WorkRecords in this WorkRecordCollection by ID.

public WorkRecordCollection SortByID();

Return Value

This WorkRecordCollection, modified such that the WorkRecords are sorted by ID.

Remarks

The WorkRecordCollection is modified in place.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection.Wrap Method

Creates a WorkRecordCollection to represent the given array of WorkRecord (from the com.starbase.starteam namespace).

public static WorkRecordCollection Wrap(
WorkRecord[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new WorkRecordCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a WorkRecord[] from the com.starbase.starteam namespace to the Borland.StarTeam namespace.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection Type Conversions

The type conversions of the WorkRecordCollection class are listed below. For a complete list of WorkRecordCollection class members, see the WorkRecordCollection Members topic.

Public Static Type Conversions

Implicit WorkRecordCollection to WorkRecord[] Conversion | Converts a WorkRecordCollection to an array of WorkRecords.
Implicit WorkRecordCollection to WorkRecord[] Conversion | Converts a WorkRecordCollection from the Borland.StarTeam namespace to a WorkRecord[] in the com.starbase.starteam namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam namespace.

See Also

WorkRecordCollection Class | WorkRecordCollection Members | Borland.StarTeam Namespace


WorkRecordCollection Implicit WorkRecordCollection to WorkRecord[] Conversion

Converts a WorkRecordCollection to an array of WorkRecords.

public static implicit operator WorkRecord[](
WorkRecordCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new WorkRecord wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one WorkRecord wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


WorkRecordCollection Implicit WorkRecordCollection to WorkRecord[] Conversion

Converts a WorkRecordCollection from the Borland.StarTeam namespace to a WorkRecord[] in the com.starbase.starteam namespace.

public static implicit operator WorkRecord[](
WorkRecordCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam namespace to methods in the com.starbase.starteam namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, WorkRecordCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

WorkRecordCollection Class | Borland.StarTeam Namespace


Workstation Class

For a list of all members of this type, see Workstation Members.

System.Object
Workstation

public class Workstation : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Workstation Members | Borland.StarTeam Namespace


Workstation Members

Workstation overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Workstation.

Public Static Type Conversions

Implicit Workstation to Workstation Conversion Implicitly convert Workstation to com.starbase.starteam.Workstation.

Public Instance Constructors

Workstation Constructor Construct Workstation from com.starbase.starteam.Workstation.

Public Instance Properties

ID | [read] The number assigned by the server to this workstation.
Name | [read] The name of the workstation.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.Workstation.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Workstation.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.Workstation.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Workstation Class | Borland.StarTeam Namespace


Workstation Constructor

Construct Workstation from com.starbase.starteam.Workstation.

public Workstation(
Workstation impl
);

Parameters

impl
The com.starbase.starteam.Workstation to be wrapped.

See Also

Workstation Class | Borland.StarTeam Namespace


Workstation Properties

The properties of the Workstation class are listed below. For a complete list of Workstation class members, see the Workstation Members topic.

Public Instance Properties

ID | [read] The number assigned by the server to this workstation.
Name | [read] The name of the workstation.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Workstation Class | Borland.StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Workstation.ID Property

[read] The number assigned by the server to this workstation.

public virtual Int32 ID {get;}

Property Value

The number assigned by the server to this workstation.

See Also

Workstation Class | Borland.StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Workstation.Name Property

[read] The name of the workstation.

public virtual String Name {get;}

Property Value

The name of the workstation.

See Also

Workstation Class | Borland.StarTeam Namespace


Workstation Methods

The methods of the Workstation class are listed below. For a complete list of Workstation class members, see the Workstation Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.Workstation.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.Workstation.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.Workstation.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.Workstation.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Workstation Class | Borland.StarTeam Namespace


Workstation.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.Workstation

Implements

IWrapper.Unwrap

See Also

Workstation Class | Borland.StarTeam Namespace


Workstation.Equals Method

Delegate Equals() to com.starbase.starteam.Workstation.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.Workstation.Equals(obj).

See Also

Workstation Class | Borland.StarTeam Namespace


Workstation.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.Workstation.

public override int GetHashCode();

Return Value

com.starbase.starteam.Workstation.GetHashCode().

See Also

Workstation Class | Borland.StarTeam Namespace


Workstation.ToString Method

Delegate ToString() to com.starbase.starteam.Workstation.

public override string ToString();

Return Value

com.starbase.starteam.Workstation.ToString()

See Also

Workstation Class | Borland.StarTeam Namespace


Workstation.Wrap Method

Dynamically wraps com.starbase.starteam.Workstation.

public static Workstation Wrap(
Workstation impl
);

Parameters

impl
com.starbase.starteam.Workstation to be wrapped.

Return Value

Workstation

See Also

Workstation Class | Borland.StarTeam Namespace


Workstation Type Conversions

The type conversions of the Workstation class are listed below. For a complete list of Workstation class members, see the Workstation Members topic.

Public Static Type Conversions

Implicit Workstation to Workstation Conversion Implicitly convert Workstation to com.starbase.starteam.Workstation.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Workstation Class | Workstation Members | Borland.StarTeam Namespace


Workstation Implicit Workstation to Workstation Conversion

Implicitly convert Workstation to com.starbase.starteam.Workstation.

public static implicit operator Workstation(
Workstation arg
);

Parameters

arg
Workstation to convert.

Return Value

com.starbase.starteam.Workstation

See Also

Workstation Class | Borland.StarTeam Namespace


Borland.StarTeam.Diff

Borland StarTeam SDK for .NET

Borland.StarTeam.Diff Namespace

Namespace hierarchy

Classes

Class | Description
BasicColumnMask | This class implements the ColumnMask interface. It supports masks deinfed as a column range (e.g. columns 2-4) an optionally require the first character to be numeric. This is a common type of mask and is used by PVCS.
BasicCompare | BasicCompare is a implementation of the DiffCompare interface that can be used to compare two files with many different options. This class supports column masking (ignoring chars in a column), ignoring case and different white space ignore options. See also DiffOptions for case and whitespace options.
BinaryCompare | A simple implementation of the Compare interface that strictly compares all the bytes of two sequences for equality.
ByteSequenceAdapter |
CharSequenceAdapter |
ColumnMaskAdapter |
ColumnMaskCollection | A strongly-typed collection of ColumnMasks.
ConsoleWriter | This interface can be used when reconstructing a target from a source and a delta
DiffCompareAdapter |
DifferAdapter |
DiffException |
Edit |
EditCollection | A strongly-typed collection of Edits.
EditList |
EditListWriter | This interface can be used when reconstructing a target from a source and a delta
HTMLDiffWriter | Writes a simple HTML page showing the differences between two text files.
HTMLInterleavedDiffWriter | Writes a simple HTML page showing the differences between two text files.
HTMLStereoDiffWriter | Writes a simple HTML page showing the differences between two text files.
HTMLTableDiffWriter | Shared implementation for HTMLInterleavedDiffWriter and HTMLStereoDiffWriter.
IntralineSequence | Represents a sequence of characters within a line.
LineIterator | This class iterates over characters in a line. It actually iterates from the back forward.
ParsedCharSequence |
SequenceAdapter |
SharedCharSequence | An implementation of the ByteSequence interface that uses an underlying byte array along with an offset and length parameter.
StarTeamDiff |
StarTeamMerge |
StringCharSequence |

Interfaces

Interface | Description
ByteSequence | The ByteSequence interface is an interface that describes a sequence of bytes.
CharSequence | The ByteSequence interface is used by the diff engine. The intention is that a file be broken down into "lines" which are exposed as a ByteSequence. The interface is quite simple, it need only support the ability to determine the length of the sequence and the ability to get a byte at a specific location (0 based). In this respect is very similar to a byte array.
ColumnMask |
DiffCompare | The DiffCompare interface can be used to delegate the comparison of objects. It is used to compute a has value for an object and compare two objects for equality.
Differ | Differ is a very simple interface for providing "diff" functionality. We most commonly think of diffing two files but this can apply to any two sequences of Objects. For example, this could be used to show differences between the characters in two lines.
Sequence |


BasicColumnMask Class

This class implements the ColumnMask interface. It supports masks deinfed as a column range (e.g. columns 2-4) an optionally require the first character to be numeric. This is a common type of mask and is used by PVCS.

For a list of all members of this type, see BasicColumnMask Members.

System.Object
BasicColumnMask

public class BasicColumnMask : ColumnMask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

BasicColumnMask Members | Borland.StarTeam.Diff Namespace


BasicColumnMask Members

BasicColumnMask overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.BasicColumnMask.

Public Static Type Conversions

Implicit BasicColumnMask to BasicColumnMask Conversion Implicitly convert BasicColumnMask to com.starbase.diff.BasicColumnMask.

Public Instance Constructors

BasicColumnMask Overloaded. Initializes a new instance of the BasicColumnMask class.

Public Instance Properties

DebugString [read]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SkipBy |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BasicColumnMask Class | Borland.StarTeam.Diff Namespace


BasicColumnMask Constructor

Construct BasicColumnMask from com.starbase.diff.BasicColumnMask.

Overload List

Construct BasicColumnMask from com.starbase.diff.BasicColumnMask.

public BasicColumnMask(BasicColumnMask);

Construct a new BasiColumn mask from first to last (inclusive). If numeric is true then the column will only be masked if the character in the first column is a digit.

public BasicColumnMask(Int32,Int32,Boolean);

See Also

BasicColumnMask Class | Borland.StarTeam.Diff Namespace


BasicColumnMask Constructor (BasicColumnMask)

Construct BasicColumnMask from com.starbase.diff.BasicColumnMask.

public BasicColumnMask(
BasicColumnMask impl
);

Parameters

impl
The com.starbase.diff.BasicColumnMask to be wrapped.

See Also

BasicColumnMask Class | Borland.StarTeam.Diff Namespace | BasicColumnMask Constructor Overload List


BasicColumnMask Constructor (Int32, Int32, Boolean)

Construct a new BasiColumn mask from first to last (inclusive). If numeric is true then the column will only be masked if the character in the first column is a digit.

public BasicColumnMask(
Int32 first,
Int32 last,
Boolean numeric
);

Parameters

first
last
numeric

See Also

BasicColumnMask Class | Borland.StarTeam.Diff Namespace | BasicColumnMask Constructor Overload List


BasicColumnMask Properties

The properties of the BasicColumnMask class are listed below. For a complete list of BasicColumnMask class members, see the BasicColumnMask Members topic.

Public Instance Properties

DebugString [read]

See Also

BasicColumnMask Class | Borland.StarTeam.Diff Namespace


DebugString Property

Borland StarTeam SDK for .NET

BasicColumnMask.DebugString Property

[read]

public virtual String DebugString {get;}

See Also

BasicColumnMask Class | Borland.StarTeam.Diff Namespace


BasicColumnMask Methods

The methods of the BasicColumnMask class are listed below. For a complete list of BasicColumnMask class members, see the BasicColumnMask Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.BasicColumnMask.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SkipBy |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BasicColumnMask Class | Borland.StarTeam.Diff Namespace


BasicColumnMask.SkipBy Method

public virtual int SkipBy(
Int32 column,
CharSequence sequence
);

Implements

ColumnMask.SkipBy

See Also

BasicColumnMask Class | Borland.StarTeam.Diff Namespace


BasicColumnMask.Wrap Method

Dynamically wraps com.starbase.diff.BasicColumnMask.

public static BasicColumnMask Wrap(
BasicColumnMask impl
);

Parameters

impl
com.starbase.diff.BasicColumnMask to be wrapped.

Return Value

BasicColumnMask

See Also

BasicColumnMask Class | Borland.StarTeam.Diff Namespace


BasicColumnMask Type Conversions

The type conversions of the BasicColumnMask class are listed below. For a complete list of BasicColumnMask class members, see the BasicColumnMask Members topic.

Public Static Type Conversions

Implicit BasicColumnMask to BasicColumnMask Conversion Implicitly convert BasicColumnMask to com.starbase.diff.BasicColumnMask.

See Also

BasicColumnMask Class | BasicColumnMask Members | Borland.StarTeam.Diff Namespace


BasicColumnMask Implicit BasicColumnMask to BasicColumnMask Conversion

Implicitly convert BasicColumnMask to com.starbase.diff.BasicColumnMask.

public static implicit operator BasicColumnMask(
BasicColumnMask arg
);

Parameters

arg
BasicColumnMask to convert.

Return Value

com.starbase.diff.BasicColumnMask

See Also

BasicColumnMask Class | Borland.StarTeam.Diff Namespace


BasicCompare Class

BasicCompare is a implementation of the DiffCompare interface that can be used to compare two files with many different options. This class supports column masking (ignoring chars in a column), ignoring case and different white space ignore options. See also DiffOptions for case and whitespace options.

For a list of all members of this type, see BasicCompare Members.

System.Object
BasicCompare

public class BasicCompare : DiffCompare

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

BasicCompare Members | Borland.StarTeam.Diff Namespace


BasicCompare Members

BasicCompare overview

Public Static Properties

COMPARE_EOL
DIFF_B_WS
DIFF_W_WS
IGNORE_CASE
INTERIOR_WS_EQUIV
INTERIOR_WS_IGNORE
LEADING_WS_EQUIV
LEADING_WS_IGNORE
PVCS_WS
TRAILING_WS_EQUIV
TRAILING_WS_IGNORE
VSS_WS

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.BasicCompare.

Public Static Type Conversions

Implicit BasicCompare to BasicCompare Conversion Implicitly convert BasicCompare to com.starbase.diff.BasicCompare.

Public Instance Constructors

BasicCompare Overloaded. Initializes a new instance of the BasicCompare class.

Public Instance Methods

EqualObjects |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HashObject |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


BasicCompare Constructor

Construct BasicCompare from com.starbase.diff.BasicCompare.

Overload List

Can be used for binary comparison. Does no case folding, white space ignore nor column masking.

public BasicCompare();

Construct BasicCompare from com.starbase.diff.BasicCompare.

public BasicCompare(BasicCompare);

columnMask is an array of column numbers to ignore. It can be null.

public BasicCompare(Int32,ColumnMaskCollection);

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


BasicCompare Constructor (BasicCompare)

Construct BasicCompare from com.starbase.diff.BasicCompare.

public BasicCompare(
BasicCompare impl
);

Parameters

impl
The com.starbase.diff.BasicCompare to be wrapped.

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace | BasicCompare Constructor Overload List


BasicCompare Constructor (Int32, ColumnMaskCollection)

columnMask is an array of column numbers to ignore. It can be null.

public BasicCompare(
Int32 flags,
ColumnMaskCollection columnMask
);

Parameters

flags
columnMask

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace | BasicCompare Constructor Overload List


BasicCompare Constructor ()

Can be used for binary comparison. Does no case folding, white space ignore nor column masking.

public BasicCompare();

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace | BasicCompare Constructor Overload List


BasicCompare Properties

The properties of the BasicCompare class are listed below. For a complete list of BasicCompare class members, see the BasicCompare Members topic.

Public Static Properties

COMPARE_EOL
DIFF_B_WS
DIFF_W_WS
IGNORE_CASE
INTERIOR_WS_EQUIV
INTERIOR_WS_IGNORE
LEADING_WS_EQUIV
LEADING_WS_IGNORE
PVCS_WS
TRAILING_WS_EQUIV
TRAILING_WS_IGNORE
VSS_WS

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


COMPARE_EOL Property

Borland StarTeam SDK for .NET

BasicCompare.COMPARE_EOL Property

public static Int32 COMPARE_EOL {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


DIFF_B_WS Property

Borland StarTeam SDK for .NET

BasicCompare.DIFF_B_WS Property

public static Int32 DIFF_B_WS {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


DIFF_W_WS Property

Borland StarTeam SDK for .NET

BasicCompare.DIFF_W_WS Property

public static Int32 DIFF_W_WS {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


IGNORE_CASE Property

Borland StarTeam SDK for .NET

BasicCompare.IGNORE_CASE Property

public static Int32 IGNORE_CASE {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


INTERIOR_WS_EQUIV Property

Borland StarTeam SDK for .NET

BasicCompare.INTERIOR_WS_EQUIV Property

public static Int32 INTERIOR_WS_EQUIV {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


INTERIOR_WS_IGNORE Property

Borland StarTeam SDK for .NET

BasicCompare.INTERIOR_WS_IGNORE Property

public static Int32 INTERIOR_WS_IGNORE {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


LEADING_WS_EQUIV Property

Borland StarTeam SDK for .NET

BasicCompare.LEADING_WS_EQUIV Property

public static Int32 LEADING_WS_EQUIV {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


LEADING_WS_IGNORE Property

Borland StarTeam SDK for .NET

BasicCompare.LEADING_WS_IGNORE Property

public static Int32 LEADING_WS_IGNORE {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


PVCS_WS Property

Borland StarTeam SDK for .NET

BasicCompare.PVCS_WS Property

public static Int32 PVCS_WS {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


TRAILING_WS_EQUIV Property

Borland StarTeam SDK for .NET

BasicCompare.TRAILING_WS_EQUIV Property

public static Int32 TRAILING_WS_EQUIV {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


TRAILING_WS_IGNORE Property

Borland StarTeam SDK for .NET

BasicCompare.TRAILING_WS_IGNORE Property

public static Int32 TRAILING_WS_IGNORE {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


VSS_WS Property

Borland StarTeam SDK for .NET

BasicCompare.VSS_WS Property

public static Int32 VSS_WS {get;}

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


BasicCompare Methods

The methods of the BasicCompare class are listed below. For a complete list of BasicCompare class members, see the BasicCompare Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.BasicCompare.

Public Instance Methods

EqualObjects |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HashObject |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


BasicCompare.EqualObjects Method

public virtual bool EqualObjects(
Object src,
Object trg
);

Implements

DiffCompare.EqualObjects

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


BasicCompare.HashObject Method

public virtual int HashObject(
Object _object
);

Implements

DiffCompare.HashObject

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


BasicCompare.Wrap Method

Dynamically wraps com.starbase.diff.BasicCompare.

public static BasicCompare Wrap(
BasicCompare impl
);

Parameters

impl
com.starbase.diff.BasicCompare to be wrapped.

Return Value

BasicCompare

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


BasicCompare Type Conversions

The type conversions of the BasicCompare class are listed below. For a complete list of BasicCompare class members, see the BasicCompare Members topic.

Public Static Type Conversions

Implicit BasicCompare to BasicCompare Conversion Implicitly convert BasicCompare to com.starbase.diff.BasicCompare.

See Also

BasicCompare Class | BasicCompare Members | Borland.StarTeam.Diff Namespace


BasicCompare Implicit BasicCompare to BasicCompare Conversion

Implicitly convert BasicCompare to com.starbase.diff.BasicCompare.

public static implicit operator BasicCompare(
BasicCompare arg
);

Parameters

arg
BasicCompare to convert.

Return Value

com.starbase.diff.BasicCompare

See Also

BasicCompare Class | Borland.StarTeam.Diff Namespace


BinaryCompare Class

A simple implementation of the Compare interface that strictly compares all the bytes of two sequences for equality.

For a list of all members of this type, see BinaryCompare Members.

System.Object
BinaryCompare

public class BinaryCompare : DiffCompare

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

BinaryCompare Members | Borland.StarTeam.Diff Namespace


BinaryCompare Members

BinaryCompare overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.BinaryCompare.

Public Static Type Conversions

Implicit BinaryCompare to BinaryCompare Conversion Implicitly convert BinaryCompare to com.starbase.diff.BinaryCompare.

Public Instance Constructors

BinaryCompare Overloaded. Initializes a new instance of the BinaryCompare class.

Public Instance Methods

EqualObjects |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HashObject |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BinaryCompare Class | Borland.StarTeam.Diff Namespace


BinaryCompare Constructor

Construct BinaryCompare from com.starbase.diff.BinaryCompare.

Overload List

Initializes a new instance of the BinaryCompare class.

public BinaryCompare();

Construct BinaryCompare from com.starbase.diff.BinaryCompare.

public BinaryCompare(BinaryCompare);

See Also

BinaryCompare Class | Borland.StarTeam.Diff Namespace


BinaryCompare Constructor (BinaryCompare)

Construct BinaryCompare from com.starbase.diff.BinaryCompare.

public BinaryCompare(
BinaryCompare impl
);

Parameters

impl
The com.starbase.diff.BinaryCompare to be wrapped.

See Also

BinaryCompare Class | Borland.StarTeam.Diff Namespace | BinaryCompare Constructor Overload List


BinaryCompare Constructor ()

Initializes a new instance of the BinaryCompare class.

public BinaryCompare();

See Also

BinaryCompare Class | Borland.StarTeam.Diff Namespace | BinaryCompare Constructor Overload List


BinaryCompare Methods

The methods of the BinaryCompare class are listed below. For a complete list of BinaryCompare class members, see the BinaryCompare Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.BinaryCompare.

Public Instance Methods

EqualObjects |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HashObject |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BinaryCompare Class | Borland.StarTeam.Diff Namespace


BinaryCompare.EqualObjects Method

public virtual bool EqualObjects(
Object src,
Object trg
);

Implements

DiffCompare.EqualObjects

See Also

BinaryCompare Class | Borland.StarTeam.Diff Namespace


BinaryCompare.HashObject Method

public virtual int HashObject(
Object _object
);

Implements

DiffCompare.HashObject

See Also

BinaryCompare Class | Borland.StarTeam.Diff Namespace


BinaryCompare.Wrap Method

Dynamically wraps com.starbase.diff.BinaryCompare.

public static BinaryCompare Wrap(
BinaryCompare impl
);

Parameters

impl
com.starbase.diff.BinaryCompare to be wrapped.

Return Value

BinaryCompare

See Also

BinaryCompare Class | Borland.StarTeam.Diff Namespace


BinaryCompare Type Conversions

The type conversions of the BinaryCompare class are listed below. For a complete list of BinaryCompare class members, see the BinaryCompare Members topic.

Public Static Type Conversions

Implicit BinaryCompare to BinaryCompare Conversion Implicitly convert BinaryCompare to com.starbase.diff.BinaryCompare.

See Also

BinaryCompare Class | BinaryCompare Members | Borland.StarTeam.Diff Namespace


BinaryCompare Implicit BinaryCompare to BinaryCompare Conversion

Implicitly convert BinaryCompare to com.starbase.diff.BinaryCompare.

public static implicit operator BinaryCompare(
BinaryCompare arg
);

Parameters

arg
BinaryCompare to convert.

Return Value

com.starbase.diff.BinaryCompare

See Also

BinaryCompare Class | Borland.StarTeam.Diff Namespace


ByteSequence Interface

The ByteSequence interface is an interface that describes a sequence of bytes.

For a list of all members of this type, see ByteSequence Members.

public interface ByteSequence

Types that implement ByteSequence

Type | Description
ByteSequenceAdapter |

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ByteSequence Members | Borland.StarTeam.Diff Namespace


ByteSequence Members

ByteSequence overview

Public Instance Properties

Length [read]

Public Instance Methods

ByteAt Returns the byte located at the nth position (zero-based).

See Also

ByteSequence Interface | Borland.StarTeam.Diff Namespace


ByteSequence Properties

The properties of the ByteSequence interface are listed below. For a complete list of ByteSequence interface members, see the ByteSequence Members topic.

Public Instance Properties

Length [read]

See Also

ByteSequence Interface | Borland.StarTeam.Diff Namespace


Length Property

Borland StarTeam SDK for .NET

ByteSequence.Length Property

[read]

Int32 Length {get;}

See Also

ByteSequence Interface | Borland.StarTeam.Diff Namespace


ByteSequence Methods

The methods of the ByteSequence interface are listed below. For a complete list of ByteSequence interface members, see the ByteSequence Members topic.

Public Instance Methods

ByteAt Returns the byte located at the nth position (zero-based).

See Also

ByteSequence Interface | Borland.StarTeam.Diff Namespace


ByteSequence.ByteAt Method

Returns the byte located at the nth position (zero-based).

byte ByteAt(
Int32 n
);

Parameters

n

See Also

ByteSequence Interface | Borland.StarTeam.Diff Namespace


ByteSequenceAdapter Class

For a list of all members of this type, see ByteSequenceAdapter Members.

System.Object
ByteSequenceAdapter

public class ByteSequenceAdapter : ByteSequence, ByteSequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ByteSequenceAdapter Members | Borland.StarTeam.Diff Namespace


ByteSequenceAdapter Members

ByteSequenceAdapter overview

Public Instance Constructors

ByteSequenceAdapter Overloaded. Initializes a new instance of the ByteSequenceAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ByteSequence.byteAt
ByteSequence.ByteAt
ByteSequence.length
ByteSequence.Length

See Also

ByteSequenceAdapter Class | Borland.StarTeam.Diff Namespace


ByteSequenceAdapter Constructor

Overload List

public ByteSequenceAdapter(ByteSequence);

public ByteSequenceAdapter(ByteSequence);

See Also

ByteSequenceAdapter Class | Borland.StarTeam.Diff Namespace


ByteSequenceAdapter Constructor (ByteSequence)

public ByteSequenceAdapter(
ByteSequence arg
);

See Also

ByteSequenceAdapter Class | Borland.StarTeam.Diff Namespace | ByteSequenceAdapter Constructor Overload List


ByteSequenceAdapter Properties

The properties of the ByteSequenceAdapter class are listed below. For a complete list of ByteSequenceAdapter class members, see the ByteSequenceAdapter Members topic.

Explicit Interface Implementations

ByteSequence.byteAt
ByteSequence.ByteAt
ByteSequence.length
ByteSequence.Length

See Also

ByteSequenceAdapter Class | Borland.StarTeam.Diff Namespace


ByteSequence.Length Property

Borland StarTeam SDK for .NET

ByteSequenceAdapter.ByteSequence.Length Property

private Int32 ByteSequence.Length {get;}

Implements

ByteSequence.Length

See Also

ByteSequenceAdapter Class | Borland.StarTeam.Diff Namespace


ByteSequenceAdapter Methods

The methods of the ByteSequenceAdapter class are listed below. For a complete list of ByteSequenceAdapter class members, see the ByteSequenceAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ByteSequence.byteAt
ByteSequence.ByteAt
ByteSequence.length
ByteSequence.Length

See Also

ByteSequenceAdapter Class | Borland.StarTeam.Diff Namespace


ByteSequenceAdapter.ByteSequence.ByteAt Method

byte ByteSequence.ByteAt(
Int32 n
);

Implements

ByteSequence.ByteAt

See Also

ByteSequenceAdapter Class | Borland.StarTeam.Diff Namespace


ByteSequenceAdapter.ByteSequence.byteAt Method

sbyte ByteSequence.byteAt(
Int32 n
);

Implements

ByteSequence.byteAt

See Also

ByteSequenceAdapter Class | Borland.StarTeam.Diff Namespace


ByteSequenceAdapter.ByteSequence.length Method

int ByteSequence.length();

Implements

ByteSequence.length

See Also

ByteSequenceAdapter Class | Borland.StarTeam.Diff Namespace


CharSequence Interface

The ByteSequence interface is used by the diff engine. The intention is that a file be broken down into "lines" which are exposed as a ByteSequence. The interface is quite simple, it need only support the ability to determine the length of the sequence and the ability to get a byte at a specific location (0 based). In this respect is very similar to a byte array.

For a list of all members of this type, see CharSequence Members.

public interface CharSequence

Types that implement CharSequence

Type | Description
CharSequenceAdapter |
SharedCharSequence | An implementation of the ByteSequence interface that uses an underlying byte array along with an offset and length parameter.
StringCharSequence |

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CharSequence Members | Borland.StarTeam.Diff Namespace


CharSequence Members

CharSequence overview

Public Instance Properties

Length [read]

Public Instance Methods

CharAt Returns the char located at the nth position (zero-based).

See Also

CharSequence Interface | Borland.StarTeam.Diff Namespace


CharSequence Properties

The properties of the CharSequence interface are listed below. For a complete list of CharSequence interface members, see the CharSequence Members topic.

Public Instance Properties

Length [read]

See Also

CharSequence Interface | Borland.StarTeam.Diff Namespace


Length Property

Borland StarTeam SDK for .NET

CharSequence.Length Property

[read]

Int32 Length {get;}

See Also

CharSequence Interface | Borland.StarTeam.Diff Namespace


CharSequence Methods

The methods of the CharSequence interface are listed below. For a complete list of CharSequence interface members, see the CharSequence Members topic.

Public Instance Methods

CharAt Returns the char located at the nth position (zero-based).

See Also

CharSequence Interface | Borland.StarTeam.Diff Namespace


CharSequence.CharAt Method

Returns the char located at the nth position (zero-based).

char CharAt(
Int32 n
);

Parameters

n

See Also

CharSequence Interface | Borland.StarTeam.Diff Namespace


CharSequenceAdapter Class

For a list of all members of this type, see CharSequenceAdapter Members.

System.Object
CharSequenceAdapter

public class CharSequenceAdapter : CharSequence, CharSequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

CharSequenceAdapter Members | Borland.StarTeam.Diff Namespace


CharSequenceAdapter Members

CharSequenceAdapter overview

Public Instance Constructors

CharSequenceAdapter Overloaded. Initializes a new instance of the CharSequenceAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

CharSequence.charAt
CharSequence.CharAt
CharSequence.length
CharSequence.Length

See Also

CharSequenceAdapter Class | Borland.StarTeam.Diff Namespace


CharSequenceAdapter Constructor

Overload List

public CharSequenceAdapter(CharSequence);

public CharSequenceAdapter(CharSequence);

See Also

CharSequenceAdapter Class | Borland.StarTeam.Diff Namespace


CharSequenceAdapter Constructor (CharSequence)

public CharSequenceAdapter(
CharSequence arg
);

See Also

CharSequenceAdapter Class | Borland.StarTeam.Diff Namespace | CharSequenceAdapter Constructor Overload List


CharSequenceAdapter Properties

The properties of the CharSequenceAdapter class are listed below. For a complete list of CharSequenceAdapter class members, see the CharSequenceAdapter Members topic.

Explicit Interface Implementations

CharSequence.charAt
CharSequence.CharAt
CharSequence.length
CharSequence.Length

See Also

CharSequenceAdapter Class | Borland.StarTeam.Diff Namespace


CharSequence.Length Property

Borland StarTeam SDK for .NET

CharSequenceAdapter.CharSequence.Length Property

private Int32 CharSequence.Length {get;}

Implements

CharSequence.Length

See Also

CharSequenceAdapter Class | Borland.StarTeam.Diff Namespace


CharSequenceAdapter Methods

The methods of the CharSequenceAdapter class are listed below. For a complete list of CharSequenceAdapter class members, see the CharSequenceAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

CharSequence.charAt
CharSequence.CharAt
CharSequence.length
CharSequence.Length

See Also

CharSequenceAdapter Class | Borland.StarTeam.Diff Namespace


CharSequenceAdapter.CharSequence.CharAt Method

char CharSequence.CharAt(
Int32 n
);

Implements

CharSequence.CharAt

See Also

CharSequenceAdapter Class | Borland.StarTeam.Diff Namespace


CharSequenceAdapter.CharSequence.charAt Method

char CharSequence.charAt(
Int32 n
);

Implements

CharSequence.charAt

See Also

CharSequenceAdapter Class | Borland.StarTeam.Diff Namespace


CharSequenceAdapter.CharSequence.length Method

int CharSequence.length();

Implements

CharSequence.length

See Also

CharSequenceAdapter Class | Borland.StarTeam.Diff Namespace


ColumnMask Interface

For a list of all members of this type, see ColumnMask Members.

public interface ColumnMask

Types that implement ColumnMask

Type | Description
BasicColumnMask | This class implements the ColumnMask interface. It supports masks deinfed as a column range (e.g. columns 2-4) an optionally require the first character to be numeric. This is a common type of mask and is used by PVCS.
ColumnMaskAdapter |

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ColumnMask Members | Borland.StarTeam.Diff Namespace


ColumnMask Members

ColumnMask overview

Public Instance Methods

SkipBy Returns distance to skip from column if this ColumnMask includes this column. Should return 0 if not skipped. offset is the offset into the data array where column 1 can be found.

See Also

ColumnMask Interface | Borland.StarTeam.Diff Namespace


ColumnMask Methods

The methods of the ColumnMask interface are listed below. For a complete list of ColumnMask interface members, see the ColumnMask Members topic.

Public Instance Methods

SkipBy Returns distance to skip from column if this ColumnMask includes this column. Should return 0 if not skipped. offset is the offset into the data array where column 1 can be found.

See Also

ColumnMask Interface | Borland.StarTeam.Diff Namespace


ColumnMask.SkipBy Method

Returns distance to skip from column if this ColumnMask includes this column. Should return 0 if not skipped. offset is the offset into the data array where column 1 can be found.

int SkipBy(
Int32 column,
CharSequence sequence
);

Parameters

column
sequence

See Also

ColumnMask Interface | Borland.StarTeam.Diff Namespace


ColumnMaskAdapter Class

For a list of all members of this type, see ColumnMaskAdapter Members.

System.Object
ColumnMaskAdapter

public class ColumnMaskAdapter : ColumnMask, ColumnMask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ColumnMaskAdapter Members | Borland.StarTeam.Diff Namespace


ColumnMaskAdapter Members

ColumnMaskAdapter overview

Public Instance Constructors

ColumnMaskAdapter Overloaded. Initializes a new instance of the ColumnMaskAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ColumnMask.skipBy
ColumnMask.SkipBy

See Also

ColumnMaskAdapter Class | Borland.StarTeam.Diff Namespace


ColumnMaskAdapter Constructor

Overload List

public ColumnMaskAdapter(ColumnMask);

public ColumnMaskAdapter(ColumnMask);

See Also

ColumnMaskAdapter Class | Borland.StarTeam.Diff Namespace


ColumnMaskAdapter Constructor (ColumnMask)

public ColumnMaskAdapter(
ColumnMask arg
);

See Also

ColumnMaskAdapter Class | Borland.StarTeam.Diff Namespace | ColumnMaskAdapter Constructor Overload List


ColumnMaskAdapter Methods

The methods of the ColumnMaskAdapter class are listed below. For a complete list of ColumnMaskAdapter class members, see the ColumnMaskAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ColumnMask.skipBy
ColumnMask.SkipBy

See Also

ColumnMaskAdapter Class | Borland.StarTeam.Diff Namespace


ColumnMaskAdapter.ColumnMask.SkipBy Method

int ColumnMask.SkipBy(
Int32 column,
CharSequence sequence
);

Implements

ColumnMask.SkipBy

See Also

ColumnMaskAdapter Class | Borland.StarTeam.Diff Namespace


ColumnMaskAdapter.ColumnMask.skipBy Method

int ColumnMask.skipBy(
Int32 column,
CharSequence sequence
);

Implements

ColumnMask.skipBy

See Also

ColumnMaskAdapter Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection Class

A strongly-typed collection of ColumnMasks.

For a list of all members of this type, see ColumnMaskCollection Members.

System.Object
ArrayAdapter
ColumnMaskCollection

public class ColumnMaskCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ColumnMaskCollection Members | Borland.StarTeam.Diff Namespace


ColumnMaskCollection Members

ColumnMaskCollection overview

Public Static Methods

Wrap Creates a ColumnMaskCollection to represent the given array of ColumnMask (from the com.starbase.diff namespace).

Public Static Type Conversions

Implicit ColumnMaskCollection to ColumnMask[] Conversion | Converts a ColumnMaskCollection to an array of ColumnMasks.
Implicit ColumnMaskCollection to ColumnMask[] Conversion | Converts a ColumnMaskCollection from the Borland.StarTeam.Diff namespace to a ColumnMask[] in the com.starbase.diff namespace.

Public Instance Constructors

ColumnMaskCollection Overloaded. Initializes a new instance of the ColumnMaskCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ColumnMask at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a ColumnMask to end of the collection.
Append | Overloaded. Appends the ColumnMasks of the given ColumnMaskCollection to the end of this ColumnMaskCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ColumnMask.
CopyTo | Copies all of the ColumnMasks in the ColumnMaskCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ColumnMask in the collection.
Insert | Inserts a ColumnMask into the collection at the specified position.
Remove | Removes the first occurrence of a specific ColumnMask from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ColumnMasks in this ColumnMaskCollection.
Sort | Sorts the ColumnMasks in this ColumnMaskCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.diff namespace.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection Constructor

Initializes an instance of the ColumnMaskCollection class.

Overload List

Initializes an instance of the ColumnMaskCollection class.

public ColumnMaskCollection();

Initializes an instance of the a ColumnMaskCollection class, copying the given array.

public ColumnMaskCollection(ColumnMask[]);

Initializes an instance of the a ColumnMaskCollection class, copying the given collection.

public ColumnMaskCollection(ColumnMaskCollection);

Initializes an instance of the a ColumnMaskCollection class, wrapping the given array of ColumnMask (from the com.starbase.diff namespace).

public ColumnMaskCollection(ColumnMask[]);

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection Constructor ()

Initializes an instance of the ColumnMaskCollection class.

public ColumnMaskCollection();

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace | ColumnMaskCollection Constructor Overload List


ColumnMaskCollection Constructor (ColumnMask[])

Initializes an instance of the a ColumnMaskCollection class, wrapping the given array of ColumnMask (from the com.starbase.diff namespace).

public ColumnMaskCollection(
ColumnMask[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.diff namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace | ColumnMaskCollection Constructor Overload List | Wrap


ColumnMaskCollection Constructor (ColumnMaskCollection)

Initializes an instance of the a ColumnMaskCollection class, copying the given collection.

public ColumnMaskCollection(
ColumnMaskCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member ColumnMask objects of the original collection are shared, not copied.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace | ColumnMaskCollection Constructor Overload List


ColumnMaskCollection Constructor (ColumnMask[])

Initializes an instance of the a ColumnMaskCollection class, copying the given array.

public ColumnMaskCollection(
ColumnMask[] array
);

Parameters

array
The array to be copied.

Remarks

The member ColumnMask objects of the original array are shared, not copied.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace | ColumnMaskCollection Constructor Overload List


ColumnMaskCollection Properties

The properties of the ColumnMaskCollection class are listed below. For a complete list of ColumnMaskCollection class members, see the ColumnMaskCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ColumnMask at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.diff namespace.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


Item Property

Borland StarTeam SDK for .NET

ColumnMaskCollection.Item Property

Gets or sets the ColumnMask at the specified index.

public ColumnMask this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the ColumnMask to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection Methods

The methods of the ColumnMaskCollection class are listed below. For a complete list of ColumnMaskCollection class members, see the ColumnMaskCollection Members topic.

Public Static Methods

Wrap Creates a ColumnMaskCollection to represent the given array of ColumnMask (from the com.starbase.diff namespace).

Public Instance Methods

Add | Adds a ColumnMask to end of the collection.
Append | Overloaded. Appends the ColumnMasks of the given ColumnMaskCollection to the end of this ColumnMaskCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ColumnMask.
CopyTo | Copies all of the ColumnMasks in the ColumnMaskCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ColumnMask in the collection.
Insert | Inserts a ColumnMask into the collection at the specified position.
Remove | Removes the first occurrence of a specific ColumnMask from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ColumnMasks in this ColumnMaskCollection.
Sort | Sorts the ColumnMasks in this ColumnMaskCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.diff namespace.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection.Add Method

Adds a ColumnMask to end of the collection.

public int Add(
ColumnMask value
);

Parameters

value
The ColumnMask to add to the collection.

Return Value

The position into which the new ColumnMask was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


Append Method

Borland StarTeam SDK for .NET

ColumnMaskCollection.Append Method

Appends the ColumnMasks of the given array to the end of this ColumnMaskCollection.

Overload List

Appends the ColumnMasks of the given array to the end of this ColumnMaskCollection.

public ColumnMaskCollection Append(ColumnMask[]);

Appends the ColumnMasks of the given ColumnMaskCollection to the end of this ColumnMaskCollection.

public ColumnMaskCollection Append(ColumnMaskCollection);

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection.Append Method (ColumnMask[])

Appends the ColumnMasks of the given array to the end of this ColumnMaskCollection.

public ColumnMaskCollection Append(
ColumnMask[] array
);

Parameters

array
The array whose ColumnMasks are to be appended to this ColumnMaskCollection.

Return Value

This ColumnMaskCollection, modified to include the new ColumnMasks.

Remarks

The ColumnMaskCollection is modified to include the new members. The individual ColumnMask objects are shared, not copied.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace | ColumnMaskCollection.Append Overload List


ColumnMaskCollection.Append Method (ColumnMaskCollection)

Appends the ColumnMasks of the given ColumnMaskCollection to the end of this ColumnMaskCollection.

public ColumnMaskCollection Append(
ColumnMaskCollection collection
);

Parameters

collection
The ColumnMaskCollection whose ColumnMasks are to be appended to this ColumnMaskCollection.

Return Value

This ColumnMaskCollection, modified to include the new ColumnMasks.

Remarks

The ColumnMaskCollection is modified to include the new members. The individual ColumnMask objects are shared, not copied.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace | ColumnMaskCollection.Append Overload List


ColumnMaskCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.diff namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.diff.ColumnMask[].

Implements

IWrapper.Unwrap

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection.Contains Method

Determines whether or not the collection contains a specific ColumnMask.

public bool Contains(
ColumnMask value
);

Parameters

value
The ColumnMask to locate in the collection.

Return Value

true if the ColumnMask is found in the collection; otherwise, false.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection.CopyTo Method

Copies all of the ColumnMasks in the ColumnMaskCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
ColumnMask[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the ColumnMasks copied from the ColumnMaskCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of ColumnMasks in the source ColumnMaskCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ColumnMaskCollection cannot be cast automatically to the type of the destination array.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection.IndexOf Method

Determines the index of a specific ColumnMask in the collection.

public int IndexOf(
ColumnMask value
);

Parameters

value
The ColumnMask to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection.Insert Method

Inserts a ColumnMask into the collection at the specified position.

public void Insert(
Int32 index,
ColumnMask value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The ColumnMask to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection.Remove Method

Removes the first occurrence of a specific ColumnMask from the collection.

public void Remove(
ColumnMask value
);

Parameters

value
The ColumnMask to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection.Reverse Method

Reverses the order of the ColumnMasks in this ColumnMaskCollection.

new public ColumnMaskCollection Reverse();

Return Value

This ColumnMaskCollection, modified such that the ColumnMasks are reversed.

Remarks

The ColumnMaskCollection is modified in place.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection.Sort Method

Sorts the ColumnMasks in this ColumnMaskCollection, using the given comparer.

new public ColumnMaskCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two ColumnMasks.

Return Value

This ColumnMaskCollection, modified such that the ColumnMasks are sorted.

Remarks

The ColumnMaskCollection is modified in place.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection.Wrap Method

Creates a ColumnMaskCollection to represent the given array of ColumnMask (from the com.starbase.diff namespace).

public static ColumnMaskCollection Wrap(
ColumnMask[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ColumnMaskCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a ColumnMask[] from the com.starbase.diff namespace to the Borland.StarTeam.Diff namespace.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection Type Conversions

The type conversions of the ColumnMaskCollection class are listed below. For a complete list of ColumnMaskCollection class members, see the ColumnMaskCollection Members topic.

Public Static Type Conversions

Implicit ColumnMaskCollection to ColumnMask[] Conversion | Converts a ColumnMaskCollection to an array of ColumnMasks.
Implicit ColumnMaskCollection to ColumnMask[] Conversion | Converts a ColumnMaskCollection from the Borland.StarTeam.Diff namespace to a ColumnMask[] in the com.starbase.diff namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.diff namespace.

See Also

ColumnMaskCollection Class | ColumnMaskCollection Members | Borland.StarTeam.Diff Namespace


ColumnMaskCollection Implicit ColumnMaskCollection to ColumnMask[] Conversion

Converts a ColumnMaskCollection to an array of ColumnMasks.

public static implicit operator ColumnMask[](
ColumnMaskCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new ColumnMask wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one ColumnMask wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ColumnMaskCollection Implicit ColumnMaskCollection to ColumnMask[] Conversion

Converts a ColumnMaskCollection from the Borland.StarTeam.Diff namespace to a ColumnMask[] in the com.starbase.diff namespace.

public static implicit operator ColumnMask[](
ColumnMaskCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam.Diff namespace to methods in the com.starbase.diff namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ColumnMaskCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ColumnMaskCollection Class | Borland.StarTeam.Diff Namespace


ConsoleWriter Class

This interface can be used when reconstructing a target from a source and a delta

For a list of all members of this type, see ConsoleWriter Members.

System.Object
EditListWriter
ConsoleWriter

public class ConsoleWriter : EditListWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ConsoleWriter Members | Borland.StarTeam.Diff Namespace


ConsoleWriter Members

ConsoleWriter overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.ConsoleWriter.

Public Static Type Conversions

Implicit ConsoleWriter to ConsoleWriter Conversion Implicitly convert ConsoleWriter to com.starbase.diff.ConsoleWriter.

Public Instance Constructors

ConsoleWriter Overloaded. Initializes a new instance of the ConsoleWriter class.

Public Instance Methods

DeleteLines (inherited from EditListWriter) |
Equals (inherited from EditListWriter) | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish (inherited from EditListWriter) |
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) |
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

ConsoleWriter Class | Borland.StarTeam.Diff Namespace


ConsoleWriter Constructor

Construct ConsoleWriter from com.starbase.diff.ConsoleWriter.

Overload List

Construct ConsoleWriter from com.starbase.diff.ConsoleWriter.

public ConsoleWriter(ConsoleWriter);

public ConsoleWriter(TextWriter,Boolean,Int32,Int32,ParsedCharSequence,ParsedCharSequence);

See Also

ConsoleWriter Class | Borland.StarTeam.Diff Namespace


ConsoleWriter Constructor (ConsoleWriter)

Construct ConsoleWriter from com.starbase.diff.ConsoleWriter.

public ConsoleWriter(
ConsoleWriter impl
);

Parameters

impl
The com.starbase.diff.ConsoleWriter to be wrapped.

See Also

ConsoleWriter Class | Borland.StarTeam.Diff Namespace | ConsoleWriter Constructor Overload List


ConsoleWriter Constructor (TextWriter, Boolean, Int32, Int32, ParsedCharSequence, ParsedCharSequence)

public ConsoleWriter(
TextWriter output,
Boolean lineNumbers,
Int32 tabs,
Int32 contextLines,
ParsedCharSequence source,
ParsedCharSequence target
);

See Also

ConsoleWriter Class | Borland.StarTeam.Diff Namespace | ConsoleWriter Constructor Overload List


ConsoleWriter Methods

The methods of the ConsoleWriter class are listed below. For a complete list of ConsoleWriter class members, see the ConsoleWriter Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.ConsoleWriter.

Public Instance Methods

DeleteLines (inherited from EditListWriter) |
Equals (inherited from EditListWriter) | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish (inherited from EditListWriter) |
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) |
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

ConsoleWriter Class | Borland.StarTeam.Diff Namespace


ConsoleWriter.Wrap Method

Dynamically wraps com.starbase.diff.ConsoleWriter.

public static ConsoleWriter Wrap(
ConsoleWriter impl
);

Parameters

impl
com.starbase.diff.ConsoleWriter to be wrapped.

Return Value

ConsoleWriter

See Also

ConsoleWriter Class | Borland.StarTeam.Diff Namespace


ConsoleWriter Type Conversions

The type conversions of the ConsoleWriter class are listed below. For a complete list of ConsoleWriter class members, see the ConsoleWriter Members topic.

Public Static Type Conversions

Implicit ConsoleWriter to ConsoleWriter Conversion Implicitly convert ConsoleWriter to com.starbase.diff.ConsoleWriter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

ConsoleWriter Class | ConsoleWriter Members | Borland.StarTeam.Diff Namespace


ConsoleWriter Implicit ConsoleWriter to ConsoleWriter Conversion

Implicitly convert ConsoleWriter to com.starbase.diff.ConsoleWriter.

public static implicit operator ConsoleWriter(
ConsoleWriter arg
);

Parameters

arg
ConsoleWriter to convert.

Return Value

com.starbase.diff.ConsoleWriter

See Also

ConsoleWriter Class | Borland.StarTeam.Diff Namespace


DiffCompare Interface

The DiffCompare interface can be used to delegate the comparison of objects. It is used to compute a has value for an object and compare two objects for equality.

For a list of all members of this type, see DiffCompare Members.

public interface DiffCompare

Types that implement DiffCompare

Type | Description
BasicCompare | BasicCompare is a implementation of the DiffCompare interface that can be used to compare two files with many different options. This class supports column masking (ignoring chars in a column), ignoring case and different white space ignore options. See also DiffOptions for case and whitespace options.
BinaryCompare | A simple implementation of the Compare interface that strictly compares all the bytes of two sequences for equality.
DiffCompareAdapter |

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DiffCompare Members | Borland.StarTeam.Diff Namespace


DiffCompare Members

DiffCompare overview

Public Instance Methods

EqualObjects | Return true if the two arguments are "equal".
HashObject | Compute a hash value for the object.

See Also

DiffCompare Interface | Borland.StarTeam.Diff Namespace


DiffCompare Methods

The methods of the DiffCompare interface are listed below. For a complete list of DiffCompare interface members, see the DiffCompare Members topic.

Public Instance Methods

EqualObjects | Return true if the two arguments are "equal".
HashObject | Compute a hash value for the object.

See Also

DiffCompare Interface | Borland.StarTeam.Diff Namespace


DiffCompare.EqualObjects Method

Return true if the two arguments are "equal".

bool EqualObjects(
Object source,
Object target
);

Parameters

source
target

See Also

DiffCompare Interface | Borland.StarTeam.Diff Namespace


DiffCompare.HashObject Method

Compute a hash value for the object.

int HashObject(
Object _object
);

Parameters

_object

See Also

DiffCompare Interface | Borland.StarTeam.Diff Namespace


DiffCompareAdapter Class

For a list of all members of this type, see DiffCompareAdapter Members.

System.Object
DiffCompareAdapter

public class DiffCompareAdapter : DiffCompare, DiffCompare

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DiffCompareAdapter Members | Borland.StarTeam.Diff Namespace


DiffCompareAdapter Members

DiffCompareAdapter overview

Public Instance Constructors

DiffCompareAdapter Overloaded. Initializes a new instance of the DiffCompareAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

DiffCompare.equalObjects
DiffCompare.EqualObjects
DiffCompare.hashObject
DiffCompare.HashObject

See Also

DiffCompareAdapter Class | Borland.StarTeam.Diff Namespace


DiffCompareAdapter Constructor

Overload List

public DiffCompareAdapter(DiffCompare);

public DiffCompareAdapter(DiffCompare);

See Also

DiffCompareAdapter Class | Borland.StarTeam.Diff Namespace


DiffCompareAdapter Constructor (DiffCompare)

public DiffCompareAdapter(
DiffCompare arg
);

See Also

DiffCompareAdapter Class | Borland.StarTeam.Diff Namespace | DiffCompareAdapter Constructor Overload List


DiffCompareAdapter Methods

The methods of the DiffCompareAdapter class are listed below. For a complete list of DiffCompareAdapter class members, see the DiffCompareAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

DiffCompare.equalObjects
DiffCompare.EqualObjects
DiffCompare.hashObject
DiffCompare.HashObject

See Also

DiffCompareAdapter Class | Borland.StarTeam.Diff Namespace


DiffCompareAdapter.DiffCompare.EqualObjects Method

bool DiffCompare.EqualObjects(
Object source,
Object target
);

Implements

DiffCompare.EqualObjects

See Also

DiffCompareAdapter Class | Borland.StarTeam.Diff Namespace


DiffCompareAdapter.DiffCompare.HashObject Method

int DiffCompare.HashObject(
Object _object
);

Implements

DiffCompare.HashObject

See Also

DiffCompareAdapter Class | Borland.StarTeam.Diff Namespace


DiffCompareAdapter.DiffCompare.equalObjects Method

bool DiffCompare.equalObjects(
Object source,
Object target
);

Implements

DiffCompare.equalObjects

See Also

DiffCompareAdapter Class | Borland.StarTeam.Diff Namespace


DiffCompareAdapter.DiffCompare.hashObject Method

int DiffCompare.hashObject(
Object _object
);

Implements

DiffCompare.hashObject

See Also

DiffCompareAdapter Class | Borland.StarTeam.Diff Namespace


Differ Interface

Differ is a very simple interface for providing "diff" functionality. We most commonly think of diffing two files but this can apply to any two sequences of Objects. For example, this could be used to show differences between the characters in two lines.

For a list of all members of this type, see Differ Members.

public interface Differ

Types that implement Differ

Type | Description
DifferAdapter |
StarTeamDiff |

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Differ Members | Borland.StarTeam.Diff Namespace


Differ Members

Differ overview

Public Instance Methods

Diff The diff method takes two sequences of objects and an instance of a Compare interface for comparing Objects in the sequences and returns an EditList that can be used to transform the source in to target.

See Also

Differ Interface | Borland.StarTeam.Diff Namespace


Differ Methods

The methods of the Differ interface are listed below. For a complete list of Differ interface members, see the Differ Members topic.

Public Instance Methods

Diff The diff method takes two sequences of objects and an instance of a Compare interface for comparing Objects in the sequences and returns an EditList that can be used to transform the source in to target.

See Also

Differ Interface | Borland.StarTeam.Diff Namespace


Differ.Diff Method

The diff method takes two sequences of objects and an instance of a Compare interface for comparing Objects in the sequences and returns an EditList that can be used to transform the source in to target.

EditList Diff(
Sequence source,
Sequence target,
DiffCompare compare
);

Parameters

source
target
compare

Exceptions

Exception Type | Condition
 | com.starbase.diff.DiffException

See Also

Differ Interface | Borland.StarTeam.Diff Namespace


DifferAdapter Class

For a list of all members of this type, see DifferAdapter Members.

System.Object
DifferAdapter

public class DifferAdapter : Differ, Differ

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DifferAdapter Members | Borland.StarTeam.Diff Namespace


DifferAdapter Members

DifferAdapter overview

Public Instance Constructors

DifferAdapter Overloaded. Initializes a new instance of the DifferAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

Differ.diff
Differ.Diff

See Also

DifferAdapter Class | Borland.StarTeam.Diff Namespace


DifferAdapter Constructor

Overload List

public DifferAdapter(Differ);

public DifferAdapter(Differ);

See Also

DifferAdapter Class | Borland.StarTeam.Diff Namespace


DifferAdapter Constructor (Differ)

public DifferAdapter(
Differ arg
);

See Also

DifferAdapter Class | Borland.StarTeam.Diff Namespace | DifferAdapter Constructor Overload List


DifferAdapter Methods

The methods of the DifferAdapter class are listed below. For a complete list of DifferAdapter class members, see the DifferAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

Differ.diff
Differ.Diff

See Also

DifferAdapter Class | Borland.StarTeam.Diff Namespace


DifferAdapter.Differ.Diff Method

EditList Differ.Diff(
Sequence source,
Sequence target,
DiffCompare compare
);

Implements

Differ.Diff

See Also

DifferAdapter Class | Borland.StarTeam.Diff Namespace


DifferAdapter.Differ.diff Method

EditList Differ.diff(
Sequence source,
Sequence target,
DiffCompare compare
);

Implements

Differ.diff

See Also

DifferAdapter Class | Borland.StarTeam.Diff Namespace


DiffException Class

For a list of all members of this type, see DiffException Members.

System.Object
Exception
DiffException

public class DiffException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DiffException Members | Borland.StarTeam.Diff Namespace


DiffException Members

DiffException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.DiffException.

Public Static Type Conversions

Implicit DiffException to DiffException Conversion Implicitly convert DiffException to com.starbase.diff.DiffException.

Public Instance Constructors

DiffException Overloaded. Initializes a new instance of the DiffException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.diff.DiffException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.diff.DiffException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.diff.DiffException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DiffException Class | Borland.StarTeam.Diff Namespace


DiffException Constructor

Construct DiffException from com.starbase.diff.DiffException.

Overload List

Construct DiffException from com.starbase.diff.DiffException.

public DiffException(DiffException);

public DiffException(String);

See Also

DiffException Class | Borland.StarTeam.Diff Namespace


DiffException Constructor (DiffException)

Construct DiffException from com.starbase.diff.DiffException.

public DiffException(
DiffException impl
);

Parameters

impl
The com.starbase.diff.DiffException to be wrapped.

See Also

DiffException Class | Borland.StarTeam.Diff Namespace | DiffException Constructor Overload List


DiffException Constructor (String)

public DiffException(
String msg
);

See Also

DiffException Class | Borland.StarTeam.Diff Namespace | DiffException Constructor Overload List


DiffException Methods

The methods of the DiffException class are listed below. For a complete list of DiffException class members, see the DiffException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.DiffException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.diff.DiffException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.diff.DiffException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.diff.DiffException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DiffException Class | Borland.StarTeam.Diff Namespace


DiffException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.diff.DiffException

Implements

IWrapper.Unwrap

See Also

DiffException Class | Borland.StarTeam.Diff Namespace


DiffException.Equals Method

Delegate Equals() to com.starbase.diff.DiffException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.diff.DiffException.Equals(obj).

See Also

DiffException Class | Borland.StarTeam.Diff Namespace


DiffException.GetHashCode Method

Delegate GetHashCode() to com.starbase.diff.DiffException.

public override int GetHashCode();

Return Value

com.starbase.diff.DiffException.GetHashCode().

See Also

DiffException Class | Borland.StarTeam.Diff Namespace


DiffException.ToString Method

Delegate ToString() to com.starbase.diff.DiffException.

public override string ToString();

Return Value

com.starbase.diff.DiffException.ToString()

See Also

DiffException Class | Borland.StarTeam.Diff Namespace


DiffException.Wrap Method

Dynamically wraps com.starbase.diff.DiffException.

public static DiffException Wrap(
DiffException impl
);

Parameters

impl
com.starbase.diff.DiffException to be wrapped.

Return Value

DiffException

See Also

DiffException Class | Borland.StarTeam.Diff Namespace


DiffException Type Conversions

The type conversions of the DiffException class are listed below. For a complete list of DiffException class members, see the DiffException Members topic.

Public Static Type Conversions

Implicit DiffException to DiffException Conversion Implicitly convert DiffException to com.starbase.diff.DiffException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DiffException Class | DiffException Members | Borland.StarTeam.Diff Namespace


DiffException Implicit DiffException to DiffException Conversion

Implicitly convert DiffException to com.starbase.diff.DiffException.

public static implicit operator DiffException(
DiffException arg
);

Parameters

arg
DiffException to convert.

Return Value

com.starbase.diff.DiffException

See Also

DiffException Class | Borland.StarTeam.Diff Namespace


Edit Class

For a list of all members of this type, see Edit Members.

System.Object
Edit

public class Edit : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Edit Members | Borland.StarTeam.Diff Namespace


Edit Members

Edit overview

Public Static Properties

DELETE
INSERT
REPLACE
UNCHANGED

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.Edit.

Public Static Type Conversions

Implicit Edit to Edit Conversion Implicitly convert Edit to com.starbase.diff.Edit.

Public Instance Constructors

Edit Overloaded. Initializes a new instance of the Edit class.

Public Instance Properties

Action | [read]
EndSource | [read]
EndTarget | [read]
NumSourceChanges | [read]
NumTargetChanges | [read]
SourceChanges | [read]
StartSource | [read]
StartTarget | [read]
TargetChanges | [read]

Public Instance Methods

Equals | Delegate Equals() to com.starbase.diff.Edit.
GetHashCode | Delegate GetHashCode() to com.starbase.diff.Edit.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.diff.Edit.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Edit Class | Borland.StarTeam.Diff Namespace


Edit Constructor

Construct Edit from com.starbase.diff.Edit.

Overload List

Construct Edit from com.starbase.diff.Edit.

public Edit(Edit);

public Edit(Int32,Int32,Int32,Int32,Int32);

See Also

Edit Class | Borland.StarTeam.Diff Namespace


Edit Constructor (Edit)

Construct Edit from com.starbase.diff.Edit.

public Edit(
Edit impl
);

Parameters

impl
The com.starbase.diff.Edit to be wrapped.

See Also

Edit Class | Borland.StarTeam.Diff Namespace | Edit Constructor Overload List


Edit Constructor (Int32, Int32, Int32, Int32, Int32)

public Edit(
Int32 eAction,
Int32 nStartSource,
Int32 nEndSource,
Int32 nStartTarget,
Int32 nEndTarget
);

Parameters

eAction
nStartSource
nEndSource
nStartTarget
nEndTarget

See Also

Edit Class | Borland.StarTeam.Diff Namespace | Edit Constructor Overload List


Edit Properties

The properties of the Edit class are listed below. For a complete list of Edit class members, see the Edit Members topic.

Public Static Properties

DELETE
INSERT
REPLACE
UNCHANGED

Public Instance Properties

Action | [read]
EndSource | [read]
EndTarget | [read]
NumSourceChanges | [read]
NumTargetChanges | [read]
SourceChanges | [read]
StartSource | [read]
StartTarget | [read]
TargetChanges | [read]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Edit Class | Borland.StarTeam.Diff Namespace


Action Property

Borland StarTeam SDK for .NET

Edit.Action Property

[read]

public virtual Int32 Action {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


DELETE Property

Borland StarTeam SDK for .NET

Edit.DELETE Property

public static Int32 DELETE {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


EndSource Property

Borland StarTeam SDK for .NET

Edit.EndSource Property

[read]

public virtual Int32 EndSource {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


EndTarget Property

Borland StarTeam SDK for .NET

Edit.EndTarget Property

[read]

public virtual Int32 EndTarget {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


INSERT Property

Borland StarTeam SDK for .NET

Edit.INSERT Property

public static Int32 INSERT {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


NumSourceChanges Property

Borland StarTeam SDK for .NET

Edit.NumSourceChanges Property

[read]

public virtual Int32 NumSourceChanges {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


NumTargetChanges Property

Borland StarTeam SDK for .NET

Edit.NumTargetChanges Property

[read]

public virtual Int32 NumTargetChanges {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


REPLACE Property

Borland StarTeam SDK for .NET

Edit.REPLACE Property

public static Int32 REPLACE {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


SourceChanges Property

Borland StarTeam SDK for .NET

Edit.SourceChanges Property

[read]

public virtual Int32 SourceChanges {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


StartSource Property

Borland StarTeam SDK for .NET

Edit.StartSource Property

[read]

public virtual Int32 StartSource {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


StartTarget Property

Borland StarTeam SDK for .NET

Edit.StartTarget Property

[read]

public virtual Int32 StartTarget {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


TargetChanges Property

Borland StarTeam SDK for .NET

Edit.TargetChanges Property

[read]

public virtual Int32 TargetChanges {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


UNCHANGED Property

Borland StarTeam SDK for .NET

Edit.UNCHANGED Property

public static Int32 UNCHANGED {get;}

See Also

Edit Class | Borland.StarTeam.Diff Namespace


Edit Methods

The methods of the Edit class are listed below. For a complete list of Edit class members, see the Edit Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.Edit.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.diff.Edit.
GetHashCode | Delegate GetHashCode() to com.starbase.diff.Edit.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.diff.Edit.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Edit Class | Borland.StarTeam.Diff Namespace


Edit.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.diff.Edit

Implements

IWrapper.Unwrap

See Also

Edit Class | Borland.StarTeam.Diff Namespace


Edit.Equals Method

Delegate Equals() to com.starbase.diff.Edit.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.diff.Edit.Equals(obj).

See Also

Edit Class | Borland.StarTeam.Diff Namespace


Edit.GetHashCode Method

Delegate GetHashCode() to com.starbase.diff.Edit.

public override int GetHashCode();

Return Value

com.starbase.diff.Edit.GetHashCode().

See Also

Edit Class | Borland.StarTeam.Diff Namespace


Edit.ToString Method

Delegate ToString() to com.starbase.diff.Edit.

public override string ToString();

Return Value

com.starbase.diff.Edit.ToString()

See Also

Edit Class | Borland.StarTeam.Diff Namespace


Edit.Wrap Method

Dynamically wraps com.starbase.diff.Edit.

public static Edit Wrap(
Edit impl
);

Parameters

impl
com.starbase.diff.Edit to be wrapped.

Return Value

Edit

See Also

Edit Class | Borland.StarTeam.Diff Namespace


Edit Type Conversions

The type conversions of the Edit class are listed below. For a complete list of Edit class members, see the Edit Members topic.

Public Static Type Conversions

Implicit Edit to Edit Conversion Implicitly convert Edit to com.starbase.diff.Edit.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Edit Class | Edit Members | Borland.StarTeam.Diff Namespace


Edit Implicit Edit to Edit Conversion

Implicitly convert Edit to com.starbase.diff.Edit.

public static implicit operator Edit(
Edit arg
);

Parameters

arg
Edit to convert.

Return Value

com.starbase.diff.Edit

See Also

Edit Class | Borland.StarTeam.Diff Namespace


EditCollection Class

A strongly-typed collection of Edits.

For a list of all members of this type, see EditCollection Members.

System.Object
ArrayAdapter
EditCollection

public class EditCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EditCollection Members | Borland.StarTeam.Diff Namespace


EditCollection Members

EditCollection overview

Public Static Methods

Wrap Creates an EditCollection to represent the given array of Edit (from the com.starbase.diff namespace).

Public Static Type Conversions

Implicit EditCollection to Edit[] Conversion | Converts an EditCollection to an array of Edits.
Implicit EditCollection to Edit[] Conversion | Converts an EditCollection from the Borland.StarTeam.Diff namespace to an Edit[] in the com.starbase.diff namespace.

Public Instance Constructors

EditCollection Overloaded. Initializes a new instance of the EditCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the Edit at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an Edit to end of the collection.
Append | Overloaded. Appends the Edits of the given EditCollection to the end of this EditCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Edit.
CopyTo | Copies all of the Edits in the EditCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Edit in the collection.
Insert | Inserts an Edit into the collection at the specified position.
Remove | Removes the first occurrence of a specific Edit from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Edits in this EditCollection.
Sort | Sorts the Edits in this EditCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.diff namespace.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection Constructor

Initializes an instance of the EditCollection class.

Overload List

Initializes an instance of the EditCollection class.

public EditCollection();

Initializes an instance of the an EditCollection class, copying the given array.

public EditCollection(Edit[]);

Initializes an instance of the an EditCollection class, copying the given collection.

public EditCollection(EditCollection);

Initializes an instance of the an EditCollection class, wrapping the given array of Edit (from the com.starbase.diff namespace).

public EditCollection(Edit[]);

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection Constructor ()

Initializes an instance of the EditCollection class.

public EditCollection();

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace | EditCollection Constructor Overload List


EditCollection Constructor (Edit[])

Initializes an instance of the an EditCollection class, wrapping the given array of Edit (from the com.starbase.diff namespace).

public EditCollection(
Edit[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.diff namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace | EditCollection Constructor Overload List | Wrap


EditCollection Constructor (EditCollection)

Initializes an instance of the an EditCollection class, copying the given collection.

public EditCollection(
EditCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Edit objects of the original collection are shared, not copied.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace | EditCollection Constructor Overload List


EditCollection Constructor (Edit[])

Initializes an instance of the an EditCollection class, copying the given array.

public EditCollection(
Edit[] array
);

Parameters

array
The array to be copied.

Remarks

The member Edit objects of the original array are shared, not copied.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace | EditCollection Constructor Overload List


EditCollection Properties

The properties of the EditCollection class are listed below. For a complete list of EditCollection class members, see the EditCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the Edit at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.diff namespace.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


Item Property

Borland StarTeam SDK for .NET

EditCollection.Item Property

Gets or sets the Edit at the specified index.

public Edit this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Edit to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection Methods

The methods of the EditCollection class are listed below. For a complete list of EditCollection class members, see the EditCollection Members topic.

Public Static Methods

Wrap Creates an EditCollection to represent the given array of Edit (from the com.starbase.diff namespace).

Public Instance Methods

Add | Adds an Edit to end of the collection.
Append | Overloaded. Appends the Edits of the given EditCollection to the end of this EditCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Edit.
CopyTo | Copies all of the Edits in the EditCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Edit in the collection.
Insert | Inserts an Edit into the collection at the specified position.
Remove | Removes the first occurrence of a specific Edit from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Edits in this EditCollection.
Sort | Sorts the Edits in this EditCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.diff namespace.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection.Add Method

Adds an Edit to end of the collection.

public int Add(
Edit value
);

Parameters

value
The Edit to add to the collection.

Return Value

The position into which the new Edit was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


Append Method

Borland StarTeam SDK for .NET

EditCollection.Append Method

Appends the Edits of the given array to the end of this EditCollection.

Overload List

Appends the Edits of the given array to the end of this EditCollection.

public EditCollection Append(Edit[]);

Appends the Edits of the given EditCollection to the end of this EditCollection.

public EditCollection Append(EditCollection);

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection.Append Method (Edit[])

Appends the Edits of the given array to the end of this EditCollection.

public EditCollection Append(
Edit[] array
);

Parameters

array
The array whose Edits are to be appended to this EditCollection.

Return Value

This EditCollection, modified to include the new Edits.

Remarks

The EditCollection is modified to include the new members. The individual Edit objects are shared, not copied.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace | EditCollection.Append Overload List


EditCollection.Append Method (EditCollection)

Appends the Edits of the given EditCollection to the end of this EditCollection.

public EditCollection Append(
EditCollection collection
);

Parameters

collection
The EditCollection whose Edits are to be appended to this EditCollection.

Return Value

This EditCollection, modified to include the new Edits.

Remarks

The EditCollection is modified to include the new members. The individual Edit objects are shared, not copied.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace | EditCollection.Append Overload List


EditCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.diff namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.diff.Edit[].

Implements

IWrapper.Unwrap

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection.Contains Method

Determines whether or not the collection contains a specific Edit.

public bool Contains(
Edit value
);

Parameters

value
The Edit to locate in the collection.

Return Value

true if the Edit is found in the collection; otherwise, false.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection.CopyTo Method

Copies all of the Edits in the EditCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Edit[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Edits copied from the EditCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Edits in the source EditCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source EditCollection cannot be cast automatically to the type of the destination array.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection.IndexOf Method

Determines the index of a specific Edit in the collection.

public int IndexOf(
Edit value
);

Parameters

value
The Edit to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection.Insert Method

Inserts an Edit into the collection at the specified position.

public void Insert(
Int32 index,
Edit value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Edit to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection.Remove Method

Removes the first occurrence of a specific Edit from the collection.

public void Remove(
Edit value
);

Parameters

value
The Edit to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection.Reverse Method

Reverses the order of the Edits in this EditCollection.

new public EditCollection Reverse();

Return Value

This EditCollection, modified such that the Edits are reversed.

Remarks

The EditCollection is modified in place.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection.Sort Method

Sorts the Edits in this EditCollection, using the given comparer.

new public EditCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Edits.

Return Value

This EditCollection, modified such that the Edits are sorted.

Remarks

The EditCollection is modified in place.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection.Wrap Method

Creates an EditCollection to represent the given array of Edit (from the com.starbase.diff namespace).

public static EditCollection Wrap(
Edit[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new EditCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an Edit[] from the com.starbase.diff namespace to the Borland.StarTeam.Diff namespace.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection Type Conversions

The type conversions of the EditCollection class are listed below. For a complete list of EditCollection class members, see the EditCollection Members topic.

Public Static Type Conversions

Implicit EditCollection to Edit[] Conversion | Converts an EditCollection to an array of Edits.
Implicit EditCollection to Edit[] Conversion | Converts an EditCollection from the Borland.StarTeam.Diff namespace to an Edit[] in the com.starbase.diff namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.diff namespace.

See Also

EditCollection Class | EditCollection Members | Borland.StarTeam.Diff Namespace


EditCollection Implicit EditCollection to Edit[] Conversion

Converts an EditCollection to an array of Edits.

public static implicit operator Edit[](
EditCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Edit wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Edit wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditCollection Implicit EditCollection to Edit[] Conversion

Converts an EditCollection from the Borland.StarTeam.Diff namespace to an Edit[] in the com.starbase.diff namespace.

public static implicit operator Edit[](
EditCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam.Diff namespace to methods in the com.starbase.diff namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, EditCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

EditCollection Class | Borland.StarTeam.Diff Namespace


EditList Class

For a list of all members of this type, see EditList Members.

System.Object
EditList

public class EditList : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EditList Members | Borland.StarTeam.Diff Namespace


EditList Members

EditList overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.EditList.

Public Static Type Conversions

Implicit EditList to EditList Conversion Implicitly convert EditList to com.starbase.diff.EditList.

Public Instance Constructors

EditList Overloaded. Initializes a new instance of the EditList class.

Public Instance Properties

Changes | [read]
Length | [read]

Public Instance Methods

AddChange |
Equals | Delegate Equals() to com.starbase.diff.EditList.
GetHashCode | Delegate GetHashCode() to com.starbase.diff.EditList.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.diff.EditList.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EditList Class | Borland.StarTeam.Diff Namespace


EditList Constructor

Construct EditList from com.starbase.diff.EditList.

Overload List

Initializes a new instance of the EditList class.

public EditList();

Construct EditList from com.starbase.diff.EditList.

public EditList(EditList);

See Also

EditList Class | Borland.StarTeam.Diff Namespace


EditList Constructor (EditList)

Construct EditList from com.starbase.diff.EditList.

public EditList(
EditList impl
);

Parameters

impl
The com.starbase.diff.EditList to be wrapped.

See Also

EditList Class | Borland.StarTeam.Diff Namespace | EditList Constructor Overload List


EditList Constructor ()

Initializes a new instance of the EditList class.

public EditList();

See Also

EditList Class | Borland.StarTeam.Diff Namespace | EditList Constructor Overload List


EditList Properties

The properties of the EditList class are listed below. For a complete list of EditList class members, see the EditList Members topic.

Public Instance Properties

Changes | [read]
Length | [read]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EditList Class | Borland.StarTeam.Diff Namespace


Changes Property

Borland StarTeam SDK for .NET

EditList.Changes Property

[read]

public virtual EditCollection Changes {get;}

See Also

EditList Class | Borland.StarTeam.Diff Namespace


Length Property

Borland StarTeam SDK for .NET

EditList.Length Property

[read]

public virtual Int32 Length {get;}

See Also

EditList Class | Borland.StarTeam.Diff Namespace


EditList Methods

The methods of the EditList class are listed below. For a complete list of EditList class members, see the EditList Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.EditList.

Public Instance Methods

AddChange |
Equals | Delegate Equals() to com.starbase.diff.EditList.
GetHashCode | Delegate GetHashCode() to com.starbase.diff.EditList.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.diff.EditList.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EditList Class | Borland.StarTeam.Diff Namespace


EditList.AddChange Method

public virtual void AddChange(
Edit change
);

Parameters

change

See Also

EditList Class | Borland.StarTeam.Diff Namespace


EditList.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.diff.EditList

Implements

IWrapper.Unwrap

See Also

EditList Class | Borland.StarTeam.Diff Namespace


EditList.Equals Method

Delegate Equals() to com.starbase.diff.EditList.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.diff.EditList.Equals(obj).

See Also

EditList Class | Borland.StarTeam.Diff Namespace


EditList.GetHashCode Method

Delegate GetHashCode() to com.starbase.diff.EditList.

public override int GetHashCode();

Return Value

com.starbase.diff.EditList.GetHashCode().

See Also

EditList Class | Borland.StarTeam.Diff Namespace


EditList.ToString Method

Delegate ToString() to com.starbase.diff.EditList.

public override string ToString();

Return Value

com.starbase.diff.EditList.ToString()

See Also

EditList Class | Borland.StarTeam.Diff Namespace


EditList.Wrap Method

Dynamically wraps com.starbase.diff.EditList.

public static EditList Wrap(
EditList impl
);

Parameters

impl
com.starbase.diff.EditList to be wrapped.

Return Value

EditList

See Also

EditList Class | Borland.StarTeam.Diff Namespace


EditList Type Conversions

The type conversions of the EditList class are listed below. For a complete list of EditList class members, see the EditList Members topic.

Public Static Type Conversions

Implicit EditList to EditList Conversion Implicitly convert EditList to com.starbase.diff.EditList.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EditList Class | EditList Members | Borland.StarTeam.Diff Namespace


EditList Implicit EditList to EditList Conversion

Implicitly convert EditList to com.starbase.diff.EditList.

public static implicit operator EditList(
EditList arg
);

Parameters

arg
EditList to convert.

Return Value

com.starbase.diff.EditList

See Also

EditList Class | Borland.StarTeam.Diff Namespace


EditListWriter Class

This interface can be used when reconstructing a target from a source and a delta

For a list of all members of this type, see EditListWriter Members.

System.Object
EditListWriter
ConsoleWriter
HTMLDiffWriter

public class EditListWriter : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EditListWriter Members | Borland.StarTeam.Diff Namespace


EditListWriter Members

EditListWriter overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.EditListWriter.

Public Static Type Conversions

Implicit EditListWriter to EditListWriter Conversion Implicitly convert EditListWriter to com.starbase.diff.EditListWriter.

Public Instance Constructors

EditListWriter Constructor Construct EditListWriter from com.starbase.diff.EditListWriter.

Public Instance Methods

DeleteLines |
Equals | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish |
GetHashCode | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines |
ReplaceLines | Called when lines in the source are replaced by lines in the target.
Start | Called to tell writer where it can get the source for the lines.
ToString | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines | When an original line from the source carries over into the rebuilt output
Write |

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter Constructor

Construct EditListWriter from com.starbase.diff.EditListWriter.

public EditListWriter(
EditListWriter impl
);

Parameters

impl
The com.starbase.diff.EditListWriter to be wrapped.

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter Methods

The methods of the EditListWriter class are listed below. For a complete list of EditListWriter class members, see the EditListWriter Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.EditListWriter.

Public Instance Methods

DeleteLines |
Equals | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish |
GetHashCode | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines |
ReplaceLines | Called when lines in the source are replaced by lines in the target.
Start | Called to tell writer where it can get the source for the lines.
ToString | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines | When an original line from the source carries over into the rebuilt output
Write |

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.diff.EditListWriter

Implements

IWrapper.Unwrap

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.DeleteLines Method

public virtual void DeleteLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

Parameters

sourceStart
targetStart
length

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.Equals Method

Delegate Equals() to com.starbase.diff.EditListWriter.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.diff.EditListWriter.Equals(obj).

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.Finish Method

public virtual void Finish();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.GetHashCode Method

Delegate GetHashCode() to com.starbase.diff.EditListWriter.

public override int GetHashCode();

Return Value

com.starbase.diff.EditListWriter.GetHashCode().

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.InsertLines Method

public virtual void InsertLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

Parameters

sourceStart
targetStart
length

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.ReplaceLines Method

Called when lines in the source are replaced by lines in the target.

public virtual void ReplaceLines(
Int32 sourceStart,
Int32 sourceLen,
Int32 targetStart,
Int32 targetLen
);

Parameters

sourceStart
sourceLen
targetStart
targetLen

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.Start Method

Called to tell writer where it can get the source for the lines.

public virtual void Start();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.ToString Method

Delegate ToString() to com.starbase.diff.EditListWriter.

public override string ToString();

Return Value

com.starbase.diff.EditListWriter.ToString()

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.UnchangedLines Method

When an original line from the source carries over into the rebuilt output

public virtual void UnchangedLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

Parameters

sourceStart
targetStart
length

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.Wrap Method

Dynamically wraps com.starbase.diff.EditListWriter.

public static EditListWriter Wrap(
EditListWriter impl
);

Parameters

impl
com.starbase.diff.EditListWriter to be wrapped.

Return Value

EditListWriter

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter.Write Method

public virtual void Write(
EditList list,
Int32 sourceLen,
Int32 destLen
);

Parameters

list
sourceLen
destLen

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


EditListWriter Type Conversions

The type conversions of the EditListWriter class are listed below. For a complete list of EditListWriter class members, see the EditListWriter Members topic.

Public Static Type Conversions

Implicit EditListWriter to EditListWriter Conversion Implicitly convert EditListWriter to com.starbase.diff.EditListWriter.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

EditListWriter Class | EditListWriter Members | Borland.StarTeam.Diff Namespace


EditListWriter Implicit EditListWriter to EditListWriter Conversion

Implicitly convert EditListWriter to com.starbase.diff.EditListWriter.

public static implicit operator EditListWriter(
EditListWriter arg
);

Parameters

arg
EditListWriter to convert.

Return Value

com.starbase.diff.EditListWriter

See Also

EditListWriter Class | Borland.StarTeam.Diff Namespace


HTMLDiffWriter Class

Writes a simple HTML page showing the differences between two text files.

For a list of all members of this type, see HTMLDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter

public class HTMLDiffWriter : EditListWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

HTMLDiffWriter Members | Borland.StarTeam.Diff Namespace


HTMLDiffWriter Members

HTMLDiffWriter overview

Public Static Properties

DEFAULT_SPACES_PER_TAB

Public Static Methods

SimpleDiff | Compares two text files, and generates a simple HTML file describing the differences. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.
Wrap | Dynamically wraps com.starbase.diff.HTMLDiffWriter.

Public Static Type Conversions

Implicit HTMLDiffWriter to HTMLDiffWriter Conversion Implicitly convert HTMLDiffWriter to com.starbase.diff.HTMLDiffWriter.

Public Instance Constructors

HTMLDiffWriter Overloaded. Initializes a new instance of the HTMLDiffWriter class.

Public Instance Properties

AddedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates an "added" line.
ApplicationFooterHTML | [read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.
ApplicationHeaderHTML | [read/write] Application-specific HTML text to be drawn at the top of the output HTML page.
CRHTML | [read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
DeletedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates a "deleted" line.
EmbedDefaultStyles | [read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.
GotoBlankHTML | [read/write] The HTML text used to draw whitespace the same width as a naviation control.
GotoBottomHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
GotoFirstDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
GotoLastDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
GotoNextDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
GotoPrevDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
GotoTopHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.
InlineDeleteMarkHTML | [read/write] The HTML text used to mark an in-line deletion point within a source line.
InlineInsertMarkHTML | [read/write] The HTML text used to mark an in-line insertion point within a source line.
LFHTML | [read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".
NavigateOnEveryChangedLine | [read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.
NumContextLines | [read/write] The maximum number of unchanged lines displayed before and after each changed line.
PageBaseURL | [read/write] The base URL of the output HTML page.
PageTitle | [read/write] The title of the output HTML page.
ReplacedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates a "replaced" line.
ShowEOLs | [read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.
ShowInlineDiffs | [read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.
ShowLineNumbers | [read/write] true (the default) to embed line numbers in the HTML output; false otherwise.
ShowUnchangedLines | [read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.
SourceFileHTML | [read/write] The HTML text used to display the name of the source file on the output page.
SourceFileURL | [read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.
SpacesPerTab | [read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.
StyleSheetURL | [read/write] The URL used to reference a linked style sheet.
TargetFileHTML | [read/write] The HTML text used to display the name of the target file on the output page.
TargetFileURL | [read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.
UnchangedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

Public Instance Methods

DeleteLines (inherited from EditListWriter) |
Equals (inherited from EditListWriter) | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish (inherited from EditListWriter) |
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) |
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLDiffWriter Constructor

Construct HTMLDiffWriter from com.starbase.diff.HTMLDiffWriter.

Overload List

Constructs a simple HTMLDiffWriter, writing output to the specified file.

public HTMLDiffWriter(ParsedCharSequence,ParsedCharSequence,FileInfo);

Constructs a simple HTMLDiffWriter, writing output to the specified file.

public HTMLDiffWriter(ParsedCharSequence,ParsedCharSequence,TextWriter);

Construct HTMLDiffWriter from com.starbase.diff.HTMLDiffWriter.

public HTMLDiffWriter(HTMLDiffWriter);

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLDiffWriter Constructor (HTMLDiffWriter)

Construct HTMLDiffWriter from com.starbase.diff.HTMLDiffWriter.

public HTMLDiffWriter(
HTMLDiffWriter impl
);

Parameters

impl
The com.starbase.diff.HTMLDiffWriter to be wrapped.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLDiffWriter Constructor Overload List


HTMLDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, FileInfo)

Constructs a simple HTMLDiffWriter, writing output to the specified file.

public HTMLDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
FileInfo output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLDiffWriter Constructor Overload List | ParsedCharSequence


HTMLDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, TextWriter)

Constructs a simple HTMLDiffWriter, writing output to the specified file.

public HTMLDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
TextWriter output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLDiffWriter Constructor Overload List | ParsedCharSequence


HTMLDiffWriter Properties

The properties of the HTMLDiffWriter class are listed below. For a complete list of HTMLDiffWriter class members, see the HTMLDiffWriter Members topic.

Public Static Properties

DEFAULT_SPACES_PER_TAB

Public Instance Properties

AddedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates an "added" line.
ApplicationFooterHTML | [read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.
ApplicationHeaderHTML | [read/write] Application-specific HTML text to be drawn at the top of the output HTML page.
CRHTML | [read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
DeletedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates a "deleted" line.
EmbedDefaultStyles | [read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.
GotoBlankHTML | [read/write] The HTML text used to draw whitespace the same width as a naviation control.
GotoBottomHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
GotoFirstDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
GotoLastDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
GotoNextDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
GotoPrevDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
GotoTopHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.
InlineDeleteMarkHTML | [read/write] The HTML text used to mark an in-line deletion point within a source line.
InlineInsertMarkHTML | [read/write] The HTML text used to mark an in-line insertion point within a source line.
LFHTML | [read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".
NavigateOnEveryChangedLine | [read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.
NumContextLines | [read/write] The maximum number of unchanged lines displayed before and after each changed line.
PageBaseURL | [read/write] The base URL of the output HTML page.
PageTitle | [read/write] The title of the output HTML page.
ReplacedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates a "replaced" line.
ShowEOLs | [read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.
ShowInlineDiffs | [read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.
ShowLineNumbers | [read/write] true (the default) to embed line numbers in the HTML output; false otherwise.
ShowUnchangedLines | [read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.
SourceFileHTML | [read/write] The HTML text used to display the name of the source file on the output page.
SourceFileURL | [read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.
SpacesPerTab | [read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.
StyleSheetURL | [read/write] The URL used to reference a linked style sheet.
TargetFileHTML | [read/write] The HTML text used to display the name of the target file on the output page.
TargetFileURL | [read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.
UnchangedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


AddedSymbolHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.AddedSymbolHTML Property

[read/write] The HTML text used to draw the symbol that indicates an "added" line.

public virtual String AddedSymbolHTML {get; set;}

Property Value

The HTML text used to draw the symbol that indicates an "added" line.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


ApplicationFooterHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ApplicationFooterHTML Property

[read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.

public virtual String ApplicationFooterHTML {get; set;}

Property Value

Application-specific HTML text to be drawn at the bottom of the output HTML page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


ApplicationHeaderHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ApplicationHeaderHTML Property

[read/write] Application-specific HTML text to be drawn at the top of the output HTML page.

public virtual String ApplicationHeaderHTML {get; set;}

Property Value

Application-specific HTML text to be drawn at the top of the output HTML page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


CRHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.CRHTML Property

[read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".

public virtual String CRHTML {get; set;}

Property Value

The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


DEFAULT_SPACES_PER_TAB Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.DEFAULT_SPACES_PER_TAB Property

public static Int32 DEFAULT_SPACES_PER_TAB {get;}

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


DeletedSymbolHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.DeletedSymbolHTML Property

[read/write] The HTML text used to draw the symbol that indicates a "deleted" line.

public virtual String DeletedSymbolHTML {get; set;}

Property Value

The HTML text used to draw the symbol that indicates a "deleted" line.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


EmbedDefaultStyles Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.EmbedDefaultStyles Property

[read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.

public virtual Boolean EmbedDefaultStyles {get; set;}

Property Value

true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


GotoBlankHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoBlankHTML Property

[read/write] The HTML text used to draw whitespace the same width as a naviation control.

public virtual String GotoBlankHTML {get; set;}

Property Value

The HTML text used to draw whitespace the same width as a naviation control.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


GotoBottomHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoBottomHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.

public virtual String GotoBottomHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


GotoFirstDiffHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoFirstDiffHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.

public virtual String GotoFirstDiffHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


GotoLastDiffHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoLastDiffHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.

public virtual String GotoLastDiffHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


GotoNextDiffHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoNextDiffHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.

public virtual String GotoNextDiffHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


GotoPrevDiffHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoPrevDiffHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.

public virtual String GotoPrevDiffHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


GotoTopHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoTopHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.

public virtual String GotoTopHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the top of the output page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


InlineDeleteMarkHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.InlineDeleteMarkHTML Property

[read/write] The HTML text used to mark an in-line deletion point within a source line.

public virtual String InlineDeleteMarkHTML {get; set;}

Property Value

The HTML text used to mark an in-line deletion point within a source line.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


InlineInsertMarkHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.InlineInsertMarkHTML Property

[read/write] The HTML text used to mark an in-line insertion point within a source line.

public virtual String InlineInsertMarkHTML {get; set;}

Property Value

The HTML text used to mark an in-line insertion point within a source line.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


LFHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.LFHTML Property

[read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".

public virtual String LFHTML {get; set;}

Property Value

The string representation of the line-feed character in the HTML document. The default value is "[LF]".

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


NavigateOnEveryChangedLine Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.NavigateOnEveryChangedLine Property

[read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.

public virtual Boolean NavigateOnEveryChangedLine {get; set;}

Property Value

true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


NumContextLines Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.NumContextLines Property

[read/write] The maximum number of unchanged lines displayed before and after each changed line.

public virtual Int32 NumContextLines {get; set;}

Property Value

The maximum number of unchanged lines displayed before and after each changed line.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


PageBaseURL Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.PageBaseURL Property

[read/write] The base URL of the output HTML page.

public virtual String PageBaseURL {get; set;}

Property Value

The base URL of the output HTML page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


PageTitle Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.PageTitle Property

[read/write] The title of the output HTML page.

public virtual String PageTitle {get; set;}

Property Value

The title of the output HTML page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


ReplacedSymbolHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ReplacedSymbolHTML Property

[read/write] The HTML text used to draw the symbol that indicates a "replaced" line.

public virtual String ReplacedSymbolHTML {get; set;}

Property Value

The HTML text used to draw the symbol that indicates a "replaced" line.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


ShowEOLs Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ShowEOLs Property

[read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.

public virtual Boolean ShowEOLs {get; set;}

Property Value

true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


ShowInlineDiffs Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ShowInlineDiffs Property

[read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.

public virtual Boolean ShowInlineDiffs {get; set;}

Property Value

true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


ShowLineNumbers Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ShowLineNumbers Property

[read/write] true (the default) to embed line numbers in the HTML output; false otherwise.

public virtual Boolean ShowLineNumbers {get; set;}

Property Value

true (the default) to embed line numbers in the HTML output; false otherwise.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


ShowUnchangedLines Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ShowUnchangedLines Property

[read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.

public virtual Boolean ShowUnchangedLines {get; set;}

Property Value

true (the default) to display unchanged lines in the HTML output; false otherwise.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


SourceFileHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.SourceFileHTML Property

[read/write] The HTML text used to display the name of the source file on the output page.

public virtual String SourceFileHTML {get; set;}

Property Value

The HTML text used to display the name of the source file on the output page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


SourceFileURL Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.SourceFileURL Property

[read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.

public virtual String SourceFileURL {get; set;}

Property Value

The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


SpacesPerTab Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.SpacesPerTab Property

[read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.

public virtual Int32 SpacesPerTab {get; set;}

Property Value

The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


StyleSheetURL Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.StyleSheetURL Property

[read/write] The URL used to reference a linked style sheet.

public virtual String StyleSheetURL {get; set;}

Property Value

The URL used to reference a linked style sheet.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


TargetFileHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.TargetFileHTML Property

[read/write] The HTML text used to display the name of the target file on the output page.

public virtual String TargetFileHTML {get; set;}

Property Value

The HTML text used to display the name of the target file on the output page.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


TargetFileURL Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.TargetFileURL Property

[read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.

public virtual String TargetFileURL {get; set;}

Property Value

The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


UnchangedSymbolHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.UnchangedSymbolHTML Property

[read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

public virtual String UnchangedSymbolHTML {get; set;}

Property Value

The HTML text used to draw the symbol that indicates an "unchanged" line.

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLDiffWriter Methods

The methods of the HTMLDiffWriter class are listed below. For a complete list of HTMLDiffWriter class members, see the HTMLDiffWriter Members topic.

Public Static Methods

SimpleDiff | Compares two text files, and generates a simple HTML file describing the differences. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.
Wrap | Dynamically wraps com.starbase.diff.HTMLDiffWriter.

Public Instance Methods

DeleteLines (inherited from EditListWriter) |
Equals (inherited from EditListWriter) | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish (inherited from EditListWriter) |
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) |
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLDiffWriter.SimpleDiff Method

Compares two text files, and generates a simple HTML file describing the differences.

Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

public static void SimpleDiff(
FileInfo source,
FileInfo target,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLDiffWriter.Wrap Method

Dynamically wraps com.starbase.diff.HTMLDiffWriter.

public static HTMLDiffWriter Wrap(
HTMLDiffWriter impl
);

Parameters

impl
com.starbase.diff.HTMLDiffWriter to be wrapped.

Return Value

HTMLDiffWriter

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLDiffWriter Type Conversions

The type conversions of the HTMLDiffWriter class are listed below. For a complete list of HTMLDiffWriter class members, see the HTMLDiffWriter Members topic.

Public Static Type Conversions

Implicit HTMLDiffWriter to HTMLDiffWriter Conversion Implicitly convert HTMLDiffWriter to com.starbase.diff.HTMLDiffWriter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLDiffWriter Class | HTMLDiffWriter Members | Borland.StarTeam.Diff Namespace


HTMLDiffWriter Implicit HTMLDiffWriter to HTMLDiffWriter Conversion

Implicitly convert HTMLDiffWriter to com.starbase.diff.HTMLDiffWriter.

public static implicit operator HTMLDiffWriter(
HTMLDiffWriter arg
);

Parameters

arg
HTMLDiffWriter to convert.

Return Value

com.starbase.diff.HTMLDiffWriter

See Also

HTMLDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLInterleavedDiffWriter Class

Writes a simple HTML page showing the differences between two text files.

For a list of all members of this type, see HTMLInterleavedDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter
HTMLInterleavedDiffWriter

public class HTMLInterleavedDiffWriter : HTMLTableDiffWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

HTMLInterleavedDiffWriter Members | Borland.StarTeam.Diff Namespace


HTMLInterleavedDiffWriter Members

HTMLInterleavedDiffWriter overview

Public Static Methods

Diff | Overloaded. Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.
Wrap | Dynamically wraps com.starbase.diff.HTMLInterleavedDiffWriter.

Public Static Type Conversions

Implicit HTMLInterleavedDiffWriter to HTMLInterleavedDiffWriter Conversion Implicitly convert HTMLInterleavedDiffWriter to com.starbase.diff.HTMLInterleavedDiffWriter.

Public Instance Constructors

HTMLInterleavedDiffWriter Overloaded. Initializes a new instance of the HTMLInterleavedDiffWriter class.

Public Instance Properties

AddedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "added" line.
ApplicationFooterHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.
ApplicationHeaderHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the top of the output HTML page.
CRHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
DeletedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "deleted" line.
EmbedDefaultStyles (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.
GotoBlankHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw whitespace the same width as a naviation control.
GotoBottomHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
GotoFirstDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
GotoLastDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
GotoNextDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
GotoPrevDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
GotoTopHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.
InlineDeleteMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line deletion point within a source line.
InlineInsertMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line insertion point within a source line.
LFHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".
NavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | [read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.
NumContextLines (inherited from HTMLDiffWriter) | [read/write] The maximum number of unchanged lines displayed before and after each changed line.
PageBaseURL (inherited from HTMLDiffWriter) | [read/write] The base URL of the output HTML page.
PageTitle (inherited from HTMLDiffWriter) | [read/write] The title of the output HTML page.
ReplacedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "replaced" line.
ShowEOLs (inherited from HTMLDiffWriter) | [read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.
ShowInlineDiffs (inherited from HTMLDiffWriter) | [read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.
ShowLineNumbers (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed line numbers in the HTML output; false otherwise.
ShowUnchangedLines (inherited from HTMLDiffWriter) | [read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.
SourceFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the source file on the output page.
SourceFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.
SpacesPerTab (inherited from HTMLDiffWriter) | [read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.
StyleSheetURL (inherited from HTMLDiffWriter) | [read/write] The URL used to reference a linked style sheet.
TargetFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the target file on the output page.
TargetFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.
UnchangedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

Public Instance Methods

DeleteLines (inherited from EditListWriter) |
Equals (inherited from EditListWriter) | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish (inherited from EditListWriter) |
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) |
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLInterleavedDiffWriter Constructor

Construct HTMLInterleavedDiffWriter from com.starbase.diff.HTMLInterleavedDiffWriter.

Overload List

Constructs an interleaved HTMLDiffWriter, writing output to the specified file.

public HTMLInterleavedDiffWriter(ParsedCharSequence,ParsedCharSequence,FileInfo);

Constructs an interleaved HTMLDiffWriter, writing output to the specified file.

public HTMLInterleavedDiffWriter(ParsedCharSequence,ParsedCharSequence,TextWriter);

Construct HTMLInterleavedDiffWriter from com.starbase.diff.HTMLInterleavedDiffWriter.

public HTMLInterleavedDiffWriter(HTMLInterleavedDiffWriter);

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLInterleavedDiffWriter Constructor (HTMLInterleavedDiffWriter)

Construct HTMLInterleavedDiffWriter from com.starbase.diff.HTMLInterleavedDiffWriter.

public HTMLInterleavedDiffWriter(
HTMLInterleavedDiffWriter impl
);

Parameters

impl
The com.starbase.diff.HTMLInterleavedDiffWriter to be wrapped.

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLInterleavedDiffWriter Constructor Overload List


HTMLInterleavedDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, FileInfo)

Constructs an interleaved HTMLDiffWriter, writing output to the specified file.

public HTMLInterleavedDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
FileInfo output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLInterleavedDiffWriter Constructor Overload List | ParsedCharSequence


HTMLInterleavedDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, TextWriter)

Constructs an interleaved HTMLDiffWriter, writing output to the specified file.

public HTMLInterleavedDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
TextWriter output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLInterleavedDiffWriter Constructor Overload List | ParsedCharSequence


HTMLInterleavedDiffWriter Methods

The methods of the HTMLInterleavedDiffWriter class are listed below. For a complete list of HTMLInterleavedDiffWriter class members, see the HTMLInterleavedDiffWriter Members topic.

Public Static Methods

Diff | Overloaded. Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.
Wrap | Dynamically wraps com.starbase.diff.HTMLInterleavedDiffWriter.

Public Instance Methods

DeleteLines (inherited from EditListWriter) |
Equals (inherited from EditListWriter) | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish (inherited from EditListWriter) |
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) |
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace


Diff Method

Borland StarTeam SDK for .NET

HTMLInterleavedDiffWriter.Diff Method

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

Overload List

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

public static void Diff(FileInfo,FileInfo,DiffCompare,FileInfo);

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a text comparison algorithm defined by via a set of BasicCompare flags (e.g., LEADING_WS_IGNORE, INTERIOR_WS_EQUIV, and so on).

public static void Diff(FileInfo,FileInfo,Int32,FileInfo);

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

public static void Diff(FileInfo,FileInfo,FileInfo);

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace | DiffCompare


HTMLInterleavedDiffWriter.Diff Method (FileInfo, FileInfo, DiffCompare, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

public static void Diff(
FileInfo source,
FileInfo target,
DiffCompare compare,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
compare
Text comparison algorithm.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLInterleavedDiffWriter.Diff Overload List | DiffCompare


HTMLInterleavedDiffWriter.Diff Method (FileInfo, FileInfo, Int32, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a text comparison algorithm defined by via a set of BasicCompare flags (e.g., LEADING_WS_IGNORE, INTERIOR_WS_EQUIV, and so on).

public static void Diff(
FileInfo source,
FileInfo target,
Int32 compareFlags,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
compareFlags
Flags that define the text comparison algorithm.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLInterleavedDiffWriter.Diff Overload List | BasicCompare


HTMLInterleavedDiffWriter.Diff Method (FileInfo, FileInfo, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion.

Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

public static void Diff(
FileInfo source,
FileInfo target,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLInterleavedDiffWriter.Diff Overload List


HTMLInterleavedDiffWriter.Wrap Method

Dynamically wraps com.starbase.diff.HTMLInterleavedDiffWriter.

public static HTMLInterleavedDiffWriter Wrap(
HTMLInterleavedDiffWriter impl
);

Parameters

impl
com.starbase.diff.HTMLInterleavedDiffWriter to be wrapped.

Return Value

HTMLInterleavedDiffWriter

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLInterleavedDiffWriter Type Conversions

The type conversions of the HTMLInterleavedDiffWriter class are listed below. For a complete list of HTMLInterleavedDiffWriter class members, see the HTMLInterleavedDiffWriter Members topic.

Public Static Type Conversions

Implicit HTMLInterleavedDiffWriter to HTMLInterleavedDiffWriter Conversion Implicitly convert HTMLInterleavedDiffWriter to com.starbase.diff.HTMLInterleavedDiffWriter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLInterleavedDiffWriter Class | HTMLInterleavedDiffWriter Members | Borland.StarTeam.Diff Namespace


HTMLInterleavedDiffWriter Implicit HTMLInterleavedDiffWriter to HTMLInterleavedDiffWriter Conversion

Implicitly convert HTMLInterleavedDiffWriter to com.starbase.diff.HTMLInterleavedDiffWriter.

public static implicit operator HTMLInterleavedDiffWriter(
HTMLInterleavedDiffWriter arg
);

Parameters

arg
HTMLInterleavedDiffWriter to convert.

Return Value

com.starbase.diff.HTMLInterleavedDiffWriter

See Also

HTMLInterleavedDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLStereoDiffWriter Class

Writes a simple HTML page showing the differences between two text files.

For a list of all members of this type, see HTMLStereoDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter
HTMLStereoDiffWriter

public class HTMLStereoDiffWriter : HTMLTableDiffWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

HTMLStereoDiffWriter Members | Borland.StarTeam.Diff Namespace


HTMLStereoDiffWriter Members

HTMLStereoDiffWriter overview

Public Static Methods

Diff | Overloaded. Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.
Wrap | Dynamically wraps com.starbase.diff.HTMLStereoDiffWriter.

Public Static Type Conversions

Implicit HTMLStereoDiffWriter to HTMLStereoDiffWriter Conversion Implicitly convert HTMLStereoDiffWriter to com.starbase.diff.HTMLStereoDiffWriter.

Public Instance Constructors

HTMLStereoDiffWriter Overloaded. Initializes a new instance of the HTMLStereoDiffWriter class.

Public Instance Properties

AddedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "added" line.
ApplicationFooterHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.
ApplicationHeaderHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the top of the output HTML page.
CRHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
DeletedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "deleted" line.
EmbedDefaultStyles (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.
GotoBlankHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw whitespace the same width as a naviation control.
GotoBottomHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
GotoFirstDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
GotoLastDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
GotoNextDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
GotoPrevDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
GotoTopHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.
InlineDeleteMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line deletion point within a source line.
InlineInsertMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line insertion point within a source line.
LFHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".
NavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | [read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.
NumContextLines (inherited from HTMLDiffWriter) | [read/write] The maximum number of unchanged lines displayed before and after each changed line.
PageBaseURL (inherited from HTMLDiffWriter) | [read/write] The base URL of the output HTML page.
PageTitle (inherited from HTMLDiffWriter) | [read/write] The title of the output HTML page.
ReplacedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "replaced" line.
ShowEOLs (inherited from HTMLDiffWriter) | [read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.
ShowInlineDiffs (inherited from HTMLDiffWriter) | [read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.
ShowLineNumbers (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed line numbers in the HTML output; false otherwise.
ShowUnchangedLines (inherited from HTMLDiffWriter) | [read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.
SourceFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the source file on the output page.
SourceFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.
SpacesPerTab (inherited from HTMLDiffWriter) | [read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.
StyleSheetURL (inherited from HTMLDiffWriter) | [read/write] The URL used to reference a linked style sheet.
TargetFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the target file on the output page.
TargetFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.
UnchangedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

Public Instance Methods

DeleteLines (inherited from EditListWriter) |
Equals (inherited from EditListWriter) | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish (inherited from EditListWriter) |
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) |
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLStereoDiffWriter Constructor

Construct HTMLStereoDiffWriter from com.starbase.diff.HTMLStereoDiffWriter.

Overload List

Constructs a side-by-side HTMLDiffWriter, writing output to the specified file.

public HTMLStereoDiffWriter(ParsedCharSequence,ParsedCharSequence,FileInfo);

Constructs a side-by-side HTMLDiffWriter, writing output to the specified file.

public HTMLStereoDiffWriter(ParsedCharSequence,ParsedCharSequence,TextWriter);

Construct HTMLStereoDiffWriter from com.starbase.diff.HTMLStereoDiffWriter.

public HTMLStereoDiffWriter(HTMLStereoDiffWriter);

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLStereoDiffWriter Constructor (HTMLStereoDiffWriter)

Construct HTMLStereoDiffWriter from com.starbase.diff.HTMLStereoDiffWriter.

public HTMLStereoDiffWriter(
HTMLStereoDiffWriter impl
);

Parameters

impl
The com.starbase.diff.HTMLStereoDiffWriter to be wrapped.

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLStereoDiffWriter Constructor Overload List


HTMLStereoDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, FileInfo)

Constructs a side-by-side HTMLDiffWriter, writing output to the specified file.

public HTMLStereoDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
FileInfo output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLStereoDiffWriter Constructor Overload List | ParsedCharSequence


HTMLStereoDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, TextWriter)

Constructs a side-by-side HTMLDiffWriter, writing output to the specified file.

public HTMLStereoDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
TextWriter output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLStereoDiffWriter Constructor Overload List | ParsedCharSequence


HTMLStereoDiffWriter Methods

The methods of the HTMLStereoDiffWriter class are listed below. For a complete list of HTMLStereoDiffWriter class members, see the HTMLStereoDiffWriter Members topic.

Public Static Methods

Diff | Overloaded. Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.
Wrap | Dynamically wraps com.starbase.diff.HTMLStereoDiffWriter.

Public Instance Methods

DeleteLines (inherited from EditListWriter) |
Equals (inherited from EditListWriter) | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish (inherited from EditListWriter) |
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) |
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace


Diff Method

Borland StarTeam SDK for .NET

HTMLStereoDiffWriter.Diff Method

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

Overload List

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

public static void Diff(FileInfo,FileInfo,DiffCompare,FileInfo);

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a text comparison algorithm defined via a set of BasicCompare flags (e.g., LEADING_WS_IGNORE, INTERIOR_WS_EQUIV, and so on).

public static void Diff(FileInfo,FileInfo,Int32,FileInfo);

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

public static void Diff(FileInfo,FileInfo,FileInfo);

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace | DiffCompare


HTMLStereoDiffWriter.Diff Method (FileInfo, FileInfo, DiffCompare, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

public static void Diff(
FileInfo source,
FileInfo target,
DiffCompare compare,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
compare
Text comparison algorithm.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLStereoDiffWriter.Diff Overload List | DiffCompare


HTMLStereoDiffWriter.Diff Method (FileInfo, FileInfo, Int32, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a text comparison algorithm defined via a set of BasicCompare flags (e.g., LEADING_WS_IGNORE, INTERIOR_WS_EQUIV, and so on).

public static void Diff(
FileInfo source,
FileInfo target,
Int32 compareFlags,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
compareFlags
Flags that define the text comparison algorithm.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLStereoDiffWriter.Diff Overload List | BasicCompare


HTMLStereoDiffWriter.Diff Method (FileInfo, FileInfo, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion.

Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

public static void Diff(
FileInfo source,
FileInfo target,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace | HTMLStereoDiffWriter.Diff Overload List


HTMLStereoDiffWriter.Wrap Method

Dynamically wraps com.starbase.diff.HTMLStereoDiffWriter.

public static HTMLStereoDiffWriter Wrap(
HTMLStereoDiffWriter impl
);

Parameters

impl
com.starbase.diff.HTMLStereoDiffWriter to be wrapped.

Return Value

HTMLStereoDiffWriter

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLStereoDiffWriter Type Conversions

The type conversions of the HTMLStereoDiffWriter class are listed below. For a complete list of HTMLStereoDiffWriter class members, see the HTMLStereoDiffWriter Members topic.

Public Static Type Conversions

Implicit HTMLStereoDiffWriter to HTMLStereoDiffWriter Conversion Implicitly convert HTMLStereoDiffWriter to com.starbase.diff.HTMLStereoDiffWriter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLStereoDiffWriter Class | HTMLStereoDiffWriter Members | Borland.StarTeam.Diff Namespace


HTMLStereoDiffWriter Implicit HTMLStereoDiffWriter to HTMLStereoDiffWriter Conversion

Implicitly convert HTMLStereoDiffWriter to com.starbase.diff.HTMLStereoDiffWriter.

public static implicit operator HTMLStereoDiffWriter(
HTMLStereoDiffWriter arg
);

Parameters

arg
HTMLStereoDiffWriter to convert.

Return Value

com.starbase.diff.HTMLStereoDiffWriter

See Also

HTMLStereoDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLTableDiffWriter Class

Shared implementation for HTMLInterleavedDiffWriter and HTMLStereoDiffWriter.

For a list of all members of this type, see HTMLTableDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter
HTMLInterleavedDiffWriter
HTMLStereoDiffWriter

public class HTMLTableDiffWriter : HTMLDiffWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

HTMLTableDiffWriter Members | Borland.StarTeam.Diff Namespace


HTMLTableDiffWriter Members

HTMLTableDiffWriter overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.HTMLTableDiffWriter.

Public Static Type Conversions

Implicit HTMLTableDiffWriter to HTMLTableDiffWriter Conversion Implicitly convert HTMLTableDiffWriter to com.starbase.diff.HTMLTableDiffWriter.

Public Instance Constructors

HTMLTableDiffWriter Constructor Construct HTMLTableDiffWriter from com.starbase.diff.HTMLTableDiffWriter.

Public Instance Properties

AddedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "added" line.
ApplicationFooterHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.
ApplicationHeaderHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the top of the output HTML page.
CRHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
DeletedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "deleted" line.
EmbedDefaultStyles (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.
GotoBlankHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw whitespace the same width as a naviation control.
GotoBottomHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
GotoFirstDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
GotoLastDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
GotoNextDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
GotoPrevDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
GotoTopHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.
InlineDeleteMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line deletion point within a source line.
InlineInsertMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line insertion point within a source line.
LFHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".
NavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | [read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.
NumContextLines (inherited from HTMLDiffWriter) | [read/write] The maximum number of unchanged lines displayed before and after each changed line.
PageBaseURL (inherited from HTMLDiffWriter) | [read/write] The base URL of the output HTML page.
PageTitle (inherited from HTMLDiffWriter) | [read/write] The title of the output HTML page.
ReplacedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "replaced" line.
ShowEOLs (inherited from HTMLDiffWriter) | [read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.
ShowInlineDiffs (inherited from HTMLDiffWriter) | [read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.
ShowLineNumbers (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed line numbers in the HTML output; false otherwise.
ShowUnchangedLines (inherited from HTMLDiffWriter) | [read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.
SourceFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the source file on the output page.
SourceFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.
SpacesPerTab (inherited from HTMLDiffWriter) | [read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.
StyleSheetURL (inherited from HTMLDiffWriter) | [read/write] The URL used to reference a linked style sheet.
TargetFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the target file on the output page.
TargetFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.
UnchangedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

Public Instance Methods

DeleteLines (inherited from EditListWriter) |
Equals (inherited from EditListWriter) | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish (inherited from EditListWriter) |
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) |
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLTableDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLTableDiffWriter Constructor

Construct HTMLTableDiffWriter from com.starbase.diff.HTMLTableDiffWriter.

public HTMLTableDiffWriter(
HTMLTableDiffWriter impl
);

Parameters

impl
The com.starbase.diff.HTMLTableDiffWriter to be wrapped.

See Also

HTMLTableDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLTableDiffWriter Methods

The methods of the HTMLTableDiffWriter class are listed below. For a complete list of HTMLTableDiffWriter class members, see the HTMLTableDiffWriter Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.HTMLTableDiffWriter.

Public Instance Methods

DeleteLines (inherited from EditListWriter) |
Equals (inherited from EditListWriter) | Delegate Equals() to com.starbase.diff.EditListWriter.
Finish (inherited from EditListWriter) |
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starbase.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) |
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starbase.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) |

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLTableDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLTableDiffWriter.Wrap Method

Dynamically wraps com.starbase.diff.HTMLTableDiffWriter.

public static HTMLTableDiffWriter Wrap(
HTMLTableDiffWriter impl
);

Parameters

impl
com.starbase.diff.HTMLTableDiffWriter to be wrapped.

Return Value

HTMLTableDiffWriter

See Also

HTMLTableDiffWriter Class | Borland.StarTeam.Diff Namespace


HTMLTableDiffWriter Type Conversions

The type conversions of the HTMLTableDiffWriter class are listed below. For a complete list of HTMLTableDiffWriter class members, see the HTMLTableDiffWriter Members topic.

Public Static Type Conversions

Implicit HTMLTableDiffWriter to HTMLTableDiffWriter Conversion Implicitly convert HTMLTableDiffWriter to com.starbase.diff.HTMLTableDiffWriter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from EditListWriter) Implementation of IWrapper.Unwrap().

See Also

HTMLTableDiffWriter Class | HTMLTableDiffWriter Members | Borland.StarTeam.Diff Namespace


HTMLTableDiffWriter Implicit HTMLTableDiffWriter to HTMLTableDiffWriter Conversion

Implicitly convert HTMLTableDiffWriter to com.starbase.diff.HTMLTableDiffWriter.

public static implicit operator HTMLTableDiffWriter(
HTMLTableDiffWriter arg
);

Parameters

arg
HTMLTableDiffWriter to convert.

Return Value

com.starbase.diff.HTMLTableDiffWriter

See Also

HTMLTableDiffWriter Class | Borland.StarTeam.Diff Namespace


IntralineSequence Class

Represents a sequence of characters within a line.

For a list of all members of this type, see IntralineSequence Members.

System.Object
IntralineSequence

public class IntralineSequence : Sequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

IntralineSequence Members | Borland.StarTeam.Diff Namespace


IntralineSequence Members

IntralineSequence overview

Public Static Properties

DiffCompare [read] A DiffCompare interface appropriate for comparing members of an intraline sequence.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.IntralineSequence.

Public Static Type Conversions

Implicit IntralineSequence to IntralineSequence Conversion Implicitly convert IntralineSequence to com.starbase.diff.IntralineSequence.

Public Instance Constructors

IntralineSequence Overloaded. Initializes a new instance of the IntralineSequence class.

Public Instance Properties

Item
Size

Public Instance Methods

Add |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace


IntralineSequence Constructor

Construct IntralineSequence from com.starbase.diff.IntralineSequence.

Overload List

Constructs an intraline sequence based on a sequence of characters from a single line of text. A word-based sequence is created by default.

public IntralineSequence(CharSequence);

Constructs an intraline sequence based on a sequence of characters from a single line of text. Creates a word-based or a character-based sequence, depending on the value of the bCharacterBased parameter.

public IntralineSequence(CharSequence,Boolean);

Construct IntralineSequence from com.starbase.diff.IntralineSequence.

public IntralineSequence(IntralineSequence);

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace


IntralineSequence Constructor (IntralineSequence)

Construct IntralineSequence from com.starbase.diff.IntralineSequence.

public IntralineSequence(
IntralineSequence impl
);

Parameters

impl
The com.starbase.diff.IntralineSequence to be wrapped.

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace | IntralineSequence Constructor Overload List


IntralineSequence Constructor (CharSequence)

Constructs an intraline sequence based on a sequence of characters from a single line of text. A word-based sequence is created by default.

public IntralineSequence(
CharSequence chars
);

Parameters

chars
The underlying character sequence.

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace | IntralineSequence Constructor Overload List


IntralineSequence Constructor (CharSequence, Boolean)

Constructs an intraline sequence based on a sequence of characters from a single line of text. Creates a word-based or a character-based sequence, depending on the value of the bCharacterBased parameter.

public IntralineSequence(
CharSequence chars,
Boolean bCharacterBased
);

Parameters

chars
The underlying character sequence.
bCharacterBased
true to create a character-based sequence (for deep comparison); false to create a word-based sequence (for comparisons that are likely to appear more natural to the user).

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace | IntralineSequence Constructor Overload List


IntralineSequence Properties

The properties of the IntralineSequence class are listed below. For a complete list of IntralineSequence class members, see the IntralineSequence Members topic.

Public Static Properties

DiffCompare [read] A DiffCompare interface appropriate for comparing members of an intraline sequence.

Public Instance Properties

Item
Size

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace


DiffCompare Property

Borland StarTeam SDK for .NET

IntralineSequence.DiffCompare Property

[read] A DiffCompare interface appropriate for comparing members of an intraline sequence.

public static DiffCompare DiffCompare {get;}

Property Value

A DiffCompare interface appropriate for comparing members of an intraline sequence.

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace


Item Property

Borland StarTeam SDK for .NET

IntralineSequence.Item Property

public Object this[
Int32 index
] {get;}

Implements

Sequence.Item

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace


Size Property

Borland StarTeam SDK for .NET

IntralineSequence.Size Property

public virtual Int32 Size {get;}

Implements

Sequence.Size

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace


IntralineSequence Methods

The methods of the IntralineSequence class are listed below. For a complete list of IntralineSequence class members, see the IntralineSequence Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.IntralineSequence.

Public Instance Methods

Add |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace


IntralineSequence.Add Method

public virtual bool Add(
Object o
);

Implements

Sequence.Add

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace


IntralineSequence.Get Method

public virtual object Get(
Int32 index
);

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace


IntralineSequence.Wrap Method

Dynamically wraps com.starbase.diff.IntralineSequence.

public static IntralineSequence Wrap(
IntralineSequence impl
);

Parameters

impl
com.starbase.diff.IntralineSequence to be wrapped.

Return Value

IntralineSequence

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace


IntralineSequence Type Conversions

The type conversions of the IntralineSequence class are listed below. For a complete list of IntralineSequence class members, see the IntralineSequence Members topic.

Public Static Type Conversions

Implicit IntralineSequence to IntralineSequence Conversion Implicitly convert IntralineSequence to com.starbase.diff.IntralineSequence.

See Also

IntralineSequence Class | IntralineSequence Members | Borland.StarTeam.Diff Namespace


IntralineSequence Implicit IntralineSequence to IntralineSequence Conversion

Implicitly convert IntralineSequence to com.starbase.diff.IntralineSequence.

public static implicit operator IntralineSequence(
IntralineSequence arg
);

Parameters

arg
IntralineSequence to convert.

Return Value

com.starbase.diff.IntralineSequence

See Also

IntralineSequence Class | Borland.StarTeam.Diff Namespace


LineIterator Class

This class iterates over characters in a line. It actually iterates from the back forward.

For a list of all members of this type, see LineIterator Members.

System.Object
LineIterator

public class LineIterator : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LineIterator Members | Borland.StarTeam.Diff Namespace


LineIterator Members

LineIterator overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.LineIterator.

Public Static Type Conversions

Implicit LineIterator to LineIterator Conversion Implicitly convert LineIterator to com.starbase.diff.LineIterator.

Public Instance Constructors

LineIterator Overloaded. Initializes a new instance of the LineIterator class.

Public Instance Properties

HasNext | [read]
Index | [read]

Public Instance Methods

Equals | Delegate Equals() to com.starbase.diff.LineIterator.
GetHashCode | Delegate GetHashCode() to com.starbase.diff.LineIterator.
GetType (inherited from Object) | Gets the Type of the current instance.
NextChar | Returns the next char in the underlying sequence.
ToString | Delegate ToString() to com.starbase.diff.LineIterator.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


LineIterator Constructor

Construct LineIterator from com.starbase.diff.LineIterator.

Overload List

public LineIterator(CharSequence,Int32,ColumnMaskCollection);

Construct LineIterator from com.starbase.diff.LineIterator.

public LineIterator(LineIterator);

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


LineIterator Constructor (LineIterator)

Construct LineIterator from com.starbase.diff.LineIterator.

public LineIterator(
LineIterator impl
);

Parameters

impl
The com.starbase.diff.LineIterator to be wrapped.

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace | LineIterator Constructor Overload List


LineIterator Constructor (CharSequence, Int32, ColumnMaskCollection)

public LineIterator(
CharSequence sequence,
Int32 flags,
ColumnMaskCollection mask
);

Parameters

sequence
flags
mask

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace | LineIterator Constructor Overload List


LineIterator Properties

The properties of the LineIterator class are listed below. For a complete list of LineIterator class members, see the LineIterator Members topic.

Public Instance Properties

HasNext | [read]
Index | [read]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


HasNext Property

Borland StarTeam SDK for .NET

LineIterator.HasNext Property

[read]

public virtual Boolean HasNext {get;}

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


Index Property

Borland StarTeam SDK for .NET

LineIterator.Index Property

[read]

public virtual Int32 Index {get;}

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


LineIterator Methods

The methods of the LineIterator class are listed below. For a complete list of LineIterator class members, see the LineIterator Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.LineIterator.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.diff.LineIterator.
GetHashCode | Delegate GetHashCode() to com.starbase.diff.LineIterator.
GetType (inherited from Object) | Gets the Type of the current instance.
NextChar | Returns the next char in the underlying sequence.
ToString | Delegate ToString() to com.starbase.diff.LineIterator.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


LineIterator.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.diff.LineIterator

Implements

IWrapper.Unwrap

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


LineIterator.Equals Method

Delegate Equals() to com.starbase.diff.LineIterator.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.diff.LineIterator.Equals(obj).

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


LineIterator.GetHashCode Method

Delegate GetHashCode() to com.starbase.diff.LineIterator.

public override int GetHashCode();

Return Value

com.starbase.diff.LineIterator.GetHashCode().

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


LineIterator.NextChar Method

Returns the next char in the underlying sequence.

public virtual char NextChar();

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


LineIterator.ToString Method

Delegate ToString() to com.starbase.diff.LineIterator.

public override string ToString();

Return Value

com.starbase.diff.LineIterator.ToString()

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


LineIterator.Wrap Method

Dynamically wraps com.starbase.diff.LineIterator.

public static LineIterator Wrap(
LineIterator impl
);

Parameters

impl
com.starbase.diff.LineIterator to be wrapped.

Return Value

LineIterator

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


LineIterator Type Conversions

The type conversions of the LineIterator class are listed below. For a complete list of LineIterator class members, see the LineIterator Members topic.

Public Static Type Conversions

Implicit LineIterator to LineIterator Conversion Implicitly convert LineIterator to com.starbase.diff.LineIterator.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LineIterator Class | LineIterator Members | Borland.StarTeam.Diff Namespace


LineIterator Implicit LineIterator to LineIterator Conversion

Implicitly convert LineIterator to com.starbase.diff.LineIterator.

public static implicit operator LineIterator(
LineIterator arg
);

Parameters

arg
LineIterator to convert.

Return Value

com.starbase.diff.LineIterator

See Also

LineIterator Class | Borland.StarTeam.Diff Namespace


ParsedCharSequence Class

For a list of all members of this type, see ParsedCharSequence Members.

System.Object
ParsedCharSequence

public class ParsedCharSequence : Sequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ParsedCharSequence Members | Borland.StarTeam.Diff Namespace


ParsedCharSequence Members

ParsedCharSequence overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.ParsedCharSequence.

Public Static Type Conversions

Implicit ParsedCharSequence to ParsedCharSequence Conversion Implicitly convert ParsedCharSequence to com.starbase.diff.ParsedCharSequence.

Public Instance Constructors

ParsedCharSequence Overloaded. Initializes a new instance of the ParsedCharSequence class.

Public Instance Properties

Item
Size

Public Instance Methods

Add |
AddLine |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLine |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


ParsedCharSequence Constructor

Construct ParsedCharSequence from com.starbase.diff.ParsedCharSequence.

Overload List

public ParsedCharSequence(CharSequence);

public ParsedCharSequence(CharSequence,Char);

public ParsedCharSequence(LineReader);

Construct ParsedCharSequence from com.starbase.diff.ParsedCharSequence.

public ParsedCharSequence(ParsedCharSequence);

public ParsedCharSequence(FileInfo);

public ParsedCharSequence(FileInfo,Boolean);

public ParsedCharSequence(FileInfo,String);

public ParsedCharSequence(FileInfo,String,Boolean);

public ParsedCharSequence(TextReader);

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


ParsedCharSequence Constructor (ParsedCharSequence)

Construct ParsedCharSequence from com.starbase.diff.ParsedCharSequence.

public ParsedCharSequence(
ParsedCharSequence impl
);

Parameters

impl
The com.starbase.diff.ParsedCharSequence to be wrapped.

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (CharSequence)

public ParsedCharSequence(
CharSequence sequence
);

Parameters

sequence

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (CharSequence, Char)

public ParsedCharSequence(
CharSequence sequence,
Char delimiter
);

Parameters

sequence
delimiter

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (TextReader)

public ParsedCharSequence(
TextReader reader
);

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (LineReader)

public ParsedCharSequence(
LineReader reader
);

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (FileInfo)

public ParsedCharSequence(
FileInfo source
);

Parameters

source

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (FileInfo, String)

public ParsedCharSequence(
FileInfo source,
String encoding
);

Parameters

source
encoding

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (FileInfo, Boolean)

public ParsedCharSequence(
FileInfo source,
Boolean bIgnoreEOLs
);

Parameters

source
bIgnoreEOLs

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (FileInfo, String, Boolean)

public ParsedCharSequence(
FileInfo source,
String encoding,
Boolean bIgnoreEOLs
);

Parameters

source
encoding
bIgnoreEOLs

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Properties

The properties of the ParsedCharSequence class are listed below. For a complete list of ParsedCharSequence class members, see the ParsedCharSequence Members topic.

Public Instance Properties

Item
Size

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


Item Property

Borland StarTeam SDK for .NET

ParsedCharSequence.Item Property

public Object this[
Int32 index
] {get;}

Implements

Sequence.Item

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


Size Property

Borland StarTeam SDK for .NET

ParsedCharSequence.Size Property

public virtual Int32 Size {get;}

Implements

Sequence.Size

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


ParsedCharSequence Methods

The methods of the ParsedCharSequence class are listed below. For a complete list of ParsedCharSequence class members, see the ParsedCharSequence Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.ParsedCharSequence.

Public Instance Methods

Add |
AddLine |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLine |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


ParsedCharSequence.Add Method

public virtual bool Add(
Object o
);

Implements

Sequence.Add

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


ParsedCharSequence.AddLine Method

public virtual void AddLine(
CharSequence aLine
);

Parameters

aLine

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


ParsedCharSequence.Get Method

public virtual object Get(
Int32 index
);

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


ParsedCharSequence.GetLine Method

public virtual CharSequence GetLine(
Int32 n
);

Parameters

n

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


ParsedCharSequence.Wrap Method

Dynamically wraps com.starbase.diff.ParsedCharSequence.

public static ParsedCharSequence Wrap(
ParsedCharSequence impl
);

Parameters

impl
com.starbase.diff.ParsedCharSequence to be wrapped.

Return Value

ParsedCharSequence

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


ParsedCharSequence Type Conversions

The type conversions of the ParsedCharSequence class are listed below. For a complete list of ParsedCharSequence class members, see the ParsedCharSequence Members topic.

Public Static Type Conversions

Implicit ParsedCharSequence to ParsedCharSequence Conversion Implicitly convert ParsedCharSequence to com.starbase.diff.ParsedCharSequence.

See Also

ParsedCharSequence Class | ParsedCharSequence Members | Borland.StarTeam.Diff Namespace


ParsedCharSequence Implicit ParsedCharSequence to ParsedCharSequence Conversion

Implicitly convert ParsedCharSequence to com.starbase.diff.ParsedCharSequence.

public static implicit operator ParsedCharSequence(
ParsedCharSequence arg
);

Parameters

arg
ParsedCharSequence to convert.

Return Value

com.starbase.diff.ParsedCharSequence

See Also

ParsedCharSequence Class | Borland.StarTeam.Diff Namespace


Sequence Interface

For a list of all members of this type, see Sequence Members.

public interface Sequence

Types that implement Sequence

Type | Description
IntralineSequence | Represents a sequence of characters within a line.
ParsedCharSequence |
SequenceAdapter |

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Sequence Members | Borland.StarTeam.Diff Namespace


Sequence Members

Sequence overview

Public Instance Properties

Item |
Size | [read]

Public Instance Methods

Add

See Also

Sequence Interface | Borland.StarTeam.Diff Namespace


Sequence Properties

The properties of the Sequence interface are listed below. For a complete list of Sequence interface members, see the Sequence Members topic.

Public Instance Properties

Item |
Size | [read]

See Also

Sequence Interface | Borland.StarTeam.Diff Namespace


Item Property

Borland StarTeam SDK for .NET

Sequence.Item Property

Object this[
Int32 index
] {get;}

See Also

Sequence Interface | Borland.StarTeam.Diff Namespace


Size Property

Borland StarTeam SDK for .NET

Sequence.Size Property

[read]

Int32 Size {get;}

See Also

Sequence Interface | Borland.StarTeam.Diff Namespace


Sequence Methods

The methods of the Sequence interface are listed below. For a complete list of Sequence interface members, see the Sequence Members topic.

Public Instance Methods

Add

See Also

Sequence Interface | Borland.StarTeam.Diff Namespace


Sequence.Add Method

bool Add(
Object o
);

Parameters

o

See Also

Sequence Interface | Borland.StarTeam.Diff Namespace


SequenceAdapter Class

For a list of all members of this type, see SequenceAdapter Members.

System.Object
SequenceAdapter

public class SequenceAdapter : Sequence, Sequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SequenceAdapter Members | Borland.StarTeam.Diff Namespace


SequenceAdapter Members

SequenceAdapter overview

Public Instance Constructors

SequenceAdapter Overloaded. Initializes a new instance of the SequenceAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

Sequence.add
Sequence.Add
Sequence.get
Sequence.Item
Sequence.size
Sequence.Size

See Also

SequenceAdapter Class | Borland.StarTeam.Diff Namespace


SequenceAdapter Constructor

Overload List

public SequenceAdapter(Sequence);

public SequenceAdapter(Sequence);

See Also

SequenceAdapter Class | Borland.StarTeam.Diff Namespace


SequenceAdapter Constructor (Sequence)

public SequenceAdapter(
Sequence arg
);

See Also

SequenceAdapter Class | Borland.StarTeam.Diff Namespace | SequenceAdapter Constructor Overload List


SequenceAdapter Properties

The properties of the SequenceAdapter class are listed below. For a complete list of SequenceAdapter class members, see the SequenceAdapter Members topic.

Explicit Interface Implementations

Sequence.add
Sequence.Add
Sequence.get
Sequence.Item
Sequence.size
Sequence.Size

See Also

SequenceAdapter Class | Borland.StarTeam.Diff Namespace


Sequence.Item Property

Borland StarTeam SDK for .NET

SequenceAdapter.Sequence.Item Property

private Object this[
Int32 index
] {get;}

Implements

Sequence.Item

See Also

SequenceAdapter Class | Borland.StarTeam.Diff Namespace


Sequence.Size Property

Borland StarTeam SDK for .NET

SequenceAdapter.Sequence.Size Property

private Int32 Sequence.Size {get;}

Implements

Sequence.Size

See Also

SequenceAdapter Class | Borland.StarTeam.Diff Namespace


SequenceAdapter Methods

The methods of the SequenceAdapter class are listed below. For a complete list of SequenceAdapter class members, see the SequenceAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

Sequence.add
Sequence.Add
Sequence.get
Sequence.Item
Sequence.size
Sequence.Size

See Also

SequenceAdapter Class | Borland.StarTeam.Diff Namespace


SequenceAdapter.Sequence.Add Method

bool Sequence.Add(
Object o
);

Implements

Sequence.Add

See Also

SequenceAdapter Class | Borland.StarTeam.Diff Namespace


SequenceAdapter.Sequence.add Method

bool Sequence.add(
Object o
);

Implements

Sequence.add

See Also

SequenceAdapter Class | Borland.StarTeam.Diff Namespace


SequenceAdapter.Sequence.get Method

object Sequence.get(
Int32 index
);

Implements

Sequence.get

See Also

SequenceAdapter Class | Borland.StarTeam.Diff Namespace


SequenceAdapter.Sequence.size Method

int Sequence.size();

Implements

Sequence.size

See Also

SequenceAdapter Class | Borland.StarTeam.Diff Namespace


SharedCharSequence Class

An implementation of the ByteSequence interface that uses an underlying byte array along with an offset and length parameter.

For a list of all members of this type, see SharedCharSequence Members.

System.Object
SharedCharSequence

public class SharedCharSequence : CharSequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SharedCharSequence Members | Borland.StarTeam.Diff Namespace


SharedCharSequence Members

SharedCharSequence overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.SharedCharSequence.

Public Static Type Conversions

Implicit SharedCharSequence to SharedCharSequence Conversion Implicitly convert SharedCharSequence to com.starbase.diff.SharedCharSequence.

Public Instance Constructors

SharedCharSequence Overloaded. Initializes a new instance of the SharedCharSequence class.

Public Instance Properties

Length

Public Instance Methods

CharAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SharedCharSequence Class | Borland.StarTeam.Diff Namespace


SharedCharSequence Constructor

Construct SharedCharSequence from com.starbase.diff.SharedCharSequence.

Overload List

Create a new sequence using the underlying data. The sequence begins at start and has the specified length.

public SharedCharSequence(CharSequence,Int32,Int32);

Construct SharedCharSequence from com.starbase.diff.SharedCharSequence.

public SharedCharSequence(SharedCharSequence);

See Also

SharedCharSequence Class | Borland.StarTeam.Diff Namespace


SharedCharSequence Constructor (SharedCharSequence)

Construct SharedCharSequence from com.starbase.diff.SharedCharSequence.

public SharedCharSequence(
SharedCharSequence impl
);

Parameters

impl
The com.starbase.diff.SharedCharSequence to be wrapped.

See Also

SharedCharSequence Class | Borland.StarTeam.Diff Namespace | SharedCharSequence Constructor Overload List


SharedCharSequence Constructor (CharSequence, Int32, Int32)

Create a new sequence using the underlying data. The sequence begins at start and has the specified length.

public SharedCharSequence(
CharSequence data,
Int32 start,
Int32 length
);

Parameters

data
start
length

See Also

SharedCharSequence Class | Borland.StarTeam.Diff Namespace | SharedCharSequence Constructor Overload List


SharedCharSequence Properties

The properties of the SharedCharSequence class are listed below. For a complete list of SharedCharSequence class members, see the SharedCharSequence Members topic.

Public Instance Properties

Length

See Also

SharedCharSequence Class | Borland.StarTeam.Diff Namespace


Length Property

Borland StarTeam SDK for .NET

SharedCharSequence.Length Property

public virtual Int32 Length {get;}

Implements

CharSequence.Length

See Also

SharedCharSequence Class | Borland.StarTeam.Diff Namespace


SharedCharSequence Methods

The methods of the SharedCharSequence class are listed below. For a complete list of SharedCharSequence class members, see the SharedCharSequence Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.SharedCharSequence.

Public Instance Methods

CharAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SharedCharSequence Class | Borland.StarTeam.Diff Namespace


SharedCharSequence.CharAt Method

public virtual char CharAt(
Int32 n
);

Implements

CharSequence.CharAt

See Also

SharedCharSequence Class | Borland.StarTeam.Diff Namespace


SharedCharSequence.Wrap Method

Dynamically wraps com.starbase.diff.SharedCharSequence.

public static SharedCharSequence Wrap(
SharedCharSequence impl
);

Parameters

impl
com.starbase.diff.SharedCharSequence to be wrapped.

Return Value

SharedCharSequence

See Also

SharedCharSequence Class | Borland.StarTeam.Diff Namespace


SharedCharSequence Type Conversions

The type conversions of the SharedCharSequence class are listed below. For a complete list of SharedCharSequence class members, see the SharedCharSequence Members topic.

Public Static Type Conversions

Implicit SharedCharSequence to SharedCharSequence Conversion Implicitly convert SharedCharSequence to com.starbase.diff.SharedCharSequence.

See Also

SharedCharSequence Class | SharedCharSequence Members | Borland.StarTeam.Diff Namespace


SharedCharSequence Implicit SharedCharSequence to SharedCharSequence Conversion

Implicitly convert SharedCharSequence to com.starbase.diff.SharedCharSequence.

public static implicit operator SharedCharSequence(
SharedCharSequence arg
);

Parameters

arg
SharedCharSequence to convert.

Return Value

com.starbase.diff.SharedCharSequence

See Also

SharedCharSequence Class | Borland.StarTeam.Diff Namespace


StarTeamDiff Class

For a list of all members of this type, see StarTeamDiff Members.

System.Object
StarTeamDiff

public class StarTeamDiff : Differ

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

StarTeamDiff Members | Borland.StarTeam.Diff Namespace


StarTeamDiff Members

StarTeamDiff overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.StarTeamDiff.

Public Static Type Conversions

Implicit StarTeamDiff to StarTeamDiff Conversion Implicitly convert StarTeamDiff to com.starbase.diff.StarTeamDiff.

Public Instance Constructors

StarTeamDiff Overloaded. Initializes a new instance of the StarTeamDiff class.

Public Instance Methods

Diff |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StarTeamDiff Class | Borland.StarTeam.Diff Namespace


StarTeamDiff Constructor

Construct StarTeamDiff from com.starbase.diff.StarTeamDiff.

Overload List

Initializes a new instance of the StarTeamDiff class.

public StarTeamDiff();

Construct StarTeamDiff from com.starbase.diff.StarTeamDiff.

public StarTeamDiff(StarTeamDiff);

See Also

StarTeamDiff Class | Borland.StarTeam.Diff Namespace


StarTeamDiff Constructor (StarTeamDiff)

Construct StarTeamDiff from com.starbase.diff.StarTeamDiff.

public StarTeamDiff(
StarTeamDiff impl
);

Parameters

impl
The com.starbase.diff.StarTeamDiff to be wrapped.

See Also

StarTeamDiff Class | Borland.StarTeam.Diff Namespace | StarTeamDiff Constructor Overload List


StarTeamDiff Constructor ()

Initializes a new instance of the StarTeamDiff class.

public StarTeamDiff();

See Also

StarTeamDiff Class | Borland.StarTeam.Diff Namespace | StarTeamDiff Constructor Overload List


StarTeamDiff Methods

The methods of the StarTeamDiff class are listed below. For a complete list of StarTeamDiff class members, see the StarTeamDiff Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.StarTeamDiff.

Public Instance Methods

Diff |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StarTeamDiff Class | Borland.StarTeam.Diff Namespace


StarTeamDiff.Diff Method

public virtual EditList Diff(
Sequence source,
Sequence target,
DiffCompare compare
);

Implements

Differ.Diff

See Also

StarTeamDiff Class | Borland.StarTeam.Diff Namespace


StarTeamDiff.Wrap Method

Dynamically wraps com.starbase.diff.StarTeamDiff.

public static StarTeamDiff Wrap(
StarTeamDiff impl
);

Parameters

impl
com.starbase.diff.StarTeamDiff to be wrapped.

Return Value

StarTeamDiff

See Also

StarTeamDiff Class | Borland.StarTeam.Diff Namespace


StarTeamDiff Type Conversions

The type conversions of the StarTeamDiff class are listed below. For a complete list of StarTeamDiff class members, see the StarTeamDiff Members topic.

Public Static Type Conversions

Implicit StarTeamDiff to StarTeamDiff Conversion Implicitly convert StarTeamDiff to com.starbase.diff.StarTeamDiff.

See Also

StarTeamDiff Class | StarTeamDiff Members | Borland.StarTeam.Diff Namespace


StarTeamDiff Implicit StarTeamDiff to StarTeamDiff Conversion

Implicitly convert StarTeamDiff to com.starbase.diff.StarTeamDiff.

public static implicit operator StarTeamDiff(
StarTeamDiff arg
);

Parameters

arg
StarTeamDiff to convert.

Return Value

com.starbase.diff.StarTeamDiff

See Also

StarTeamDiff Class | Borland.StarTeam.Diff Namespace


StarTeamMerge Class

For a list of all members of this type, see StarTeamMerge Members.

System.Object
StarTeamMerge

public class StarTeamMerge : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

StarTeamMerge Members | Borland.StarTeam.Diff Namespace


StarTeamMerge Members

StarTeamMerge overview

Public Static Methods

Merge | Overloaded. Performs a three-way merge of two text files and their common ancestor. It uses the platform's default end-of-line sequence for the output.
MergeToFile | Overloaded. Performs a three-way merge of two text files and their common ancestor. All input an output files are assumed to use the ISO-8859-1 encoding.

Public Static Type Conversions

Implicit StarTeamMerge to StarTeamMerge Conversion Implicitly convert StarTeamMerge to com.starbase.diff.StarTeamMerge.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.diff.StarTeamMerge.
GetHashCode | Delegate GetHashCode() to com.starbase.diff.StarTeamMerge.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.diff.StarTeamMerge.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace


StarTeamMerge Methods

The methods of the StarTeamMerge class are listed below. For a complete list of StarTeamMerge class members, see the StarTeamMerge Members topic.

Public Static Methods

Merge | Overloaded. Performs a three-way merge of two text files and their common ancestor. It uses the platform's default end-of-line sequence for the output.
MergeToFile | Overloaded. Performs a three-way merge of two text files and their common ancestor. All input an output files are assumed to use the ISO-8859-1 encoding.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.diff.StarTeamMerge.
GetHashCode | Delegate GetHashCode() to com.starbase.diff.StarTeamMerge.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.diff.StarTeamMerge.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace


StarTeamMerge.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.diff.StarTeamMerge

Implements

IWrapper.Unwrap

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace


StarTeamMerge.Equals Method

Delegate Equals() to com.starbase.diff.StarTeamMerge.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.diff.StarTeamMerge.Equals(obj).

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace


StarTeamMerge.GetHashCode Method

Delegate GetHashCode() to com.starbase.diff.StarTeamMerge.

public override int GetHashCode();

Return Value

com.starbase.diff.StarTeamMerge.GetHashCode().

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace


Merge Method

Borland StarTeam SDK for .NET

StarTeamMerge.Merge Method

Performs a three-way merge of two text files and their common ancestor. It uses the platform's default end-of-line sequence for the output.

Overload List

Performs a three-way merge of two text files and their common ancestor. It uses the platform's default end-of-line sequence for the output.

public static bool Merge(FileInfo,FileInfo,FileInfo,DiffCompare,FileInfo,String,String,String,Boolean,Boolean);

Performs a three-way merge of two text files and their common ancestor. It uses the platform's default end-of-line sequence for the output.

public static bool Merge(FileInfo,FileInfo,FileInfo,DiffCompare,Stream,String,String,String,Boolean,Boolean);

Performs a three-way merge of two text files and their common ancestor. All input an output files are assumed to use the ISO-8859-1 encoding.

public static bool Merge(FileInfo,FileInfo,FileInfo,DiffCompare,Stream,String,String,String,Boolean,Boolean,String);

Performs a three-way merge of two text files and their common ancestor.

public static bool Merge(FileInfo,String,FileInfo,String,FileInfo,String,DiffCompare,Stream,String,String,String,String,Boolean,Boolean,String);

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace


StarTeamMerge.Merge Method (FileInfo, FileInfo, FileInfo, DiffCompare, FileInfo, String, String, String, Boolean, Boolean)

Performs a three-way merge of two text files and their common ancestor. It uses the platform's default end-of-line sequence for the output.

public static bool Merge(
FileInfo mine,
FileInfo common,
FileInfo yours,
DiffCompare compare,
FileInfo output,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly
);

Parameters

mine
The first file to be merged.
common
The common ancestor of the two files to be merged.
yours
The second file to be merged.
compare
the method by which lines are compared for equality when computing changes between two files
output
The output file where the merged results are written.
mineLabel
A label to be used to identify the first file in the markup text.
commonLabel
A label to be used to identify the common ancestor in the markup text.
yoursLabel
A label to be used to identify the second file in the markup text.
showFromCommon
if true output will include changed lines from the common file. Typically you'll set this to false.
overlapOnly
if true, do not output information for non-overlapping changes. Typically you'll set this to false.

Return Value

true if conflicts were found; false otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace | StarTeamMerge.Merge Overload List


StarTeamMerge.Merge Method (FileInfo, FileInfo, FileInfo, DiffCompare, Stream, String, String, String, Boolean, Boolean)

Performs a three-way merge of two text files and their common ancestor. It uses the platform's default end-of-line sequence for the output.

public static bool Merge(
FileInfo mine,
FileInfo common,
FileInfo yours,
DiffCompare compare,
Stream output,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly
);

Parameters

mine
The first file to be merged.
common
The common ancestor of the two files to be merged.
yours
The second file to be merged.
compare
the method by which lines are compared for equality when computing changes between two files
output
The output file where the merged results are written.
mineLabel
A label to be used to identify the first file in the markup text.
commonLabel
A label to be used to identify the common ancestor in the markup text.
yoursLabel
A label to be used to identify the second file in the markup text.
showFromCommon
if true output will include changed lines from the common file. Typically you'll set this to false.
overlapOnly
if true, do not output information for non-overlapping changes. Typically you'll set this to false.

Return Value

true if conflicts were found; false otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace | StarTeamMerge.Merge Overload List


StarTeamMerge.Merge Method (FileInfo, FileInfo, FileInfo, DiffCompare, Stream, String, String, String, Boolean, Boolean, String)

Performs a three-way merge of two text files and their common ancestor. All input an output files are assumed to use the ISO-8859-1 encoding.

public static bool Merge(
FileInfo mine,
FileInfo common,
FileInfo yours,
DiffCompare compare,
Stream output,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly,
String eol
);

Parameters

mine
The first file to be merged.
common
The common ancestor of the two files to be merged.
yours
The second file to be merged.
compare
the method by which lines are compared for equality when computing changes between two files
output
The output stream where the merged results are written.
mineLabel
A label to be used to identify the first file in the markup text.
commonLabel
A label to be used to identify the common ancestor in the markup text.
yoursLabel
A label to be used to identify the second file in the markup text.
showFromCommon
if true output will include changed lines from the common file. Typically you'll set this to false.
overlapOnly
if true, do not output information for non-overlapping diffs. Typically you'll set this to false.
eol
the end-of-line sequence to use in the output

Return Value

true if conflicts were found; false otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace | StarTeamMerge.Merge Overload List


StarTeamMerge.Merge Method (FileInfo, String, FileInfo, String, FileInfo, String, DiffCompare, Stream, String, String, String, String, Boolean, Boolean, String)

Performs a three-way merge of two text files and their common ancestor.

public static bool Merge(
FileInfo mine,
String mineEncoding,
FileInfo common,
String commonEncoding,
FileInfo yours,
String yoursEncoding,
DiffCompare compare,
Stream output,
String outputEncoding,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly,
String eol
);

Parameters

mine
The first file to be merged.
mineEncoding
The first file's encoding.
common
The common ancestor of the two files to be merged.
commonEncoding
The common file's encoding.
yours
The second file to be merged.
yoursEncoding
The second file's encoding.
compare
the method by which lines are compared for equality when computing changes between two files
output
The output stream where the merged results are written.
outputEncoding
The output file's encoding.
mineLabel
A label to be used to identify the first file in the markup text.
commonLabel
A label to be used to identify the common ancestor in the markup text.
yoursLabel
A label to be used to identify the second file in the markup text.
showFromCommon
if true output will include changed lines from the common file. Typically you'll set this to false.
overlapOnly
if true, do not output information for non-overlapping diffs. Typically you'll set this to false.
eol
the end-of-line sequence to use in the output

Return Value

true if conflicts were found; false otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace | StarTeamMerge.Merge Overload List


MergeToFile Method

Borland StarTeam SDK for .NET

StarTeamMerge.MergeToFile Method

Performs a three-way merge of two text files and their common ancestor. All input an output files are assumed to use the ISO-8859-1 encoding.

Overload List

Performs a three-way merge of two text files and their common ancestor. All input an output files are assumed to use the ISO-8859-1 encoding.

public static bool MergeToFile(FileInfo,FileInfo,FileInfo,DiffCompare,FileInfo,String,String,String,Boolean,Boolean,String);

Performs a three-way merge of two text files and their common ancestor.

public static bool MergeToFile(FileInfo,String,FileInfo,String,FileInfo,String,DiffCompare,FileInfo,String,String,String,String,Boolean,Boolean,String);

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace


StarTeamMerge.MergeToFile Method (FileInfo, FileInfo, FileInfo, DiffCompare, FileInfo, String, String, String, Boolean, Boolean, String)

Performs a three-way merge of two text files and their common ancestor. All input an output files are assumed to use the ISO-8859-1 encoding.

public static bool MergeToFile(
FileInfo mine,
FileInfo common,
FileInfo yours,
DiffCompare compare,
FileInfo output,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly,
String eol
);

Parameters

mine
The first file to be merged.
common
The common ancestor of the two files to be merged.
yours
The second file to be merged.
compare
the method by which lines are compared for equality when computing changes between two files
output
The output file where the merged results are written.
mineLabel
A label to be used to identify the first file in the markup text.
commonLabel
A label to be used to identify the common ancestor in the markup text.
yoursLabel
A label to be used to identify the second file in the markup text.
showFromCommon
if true output will include changed lines from the common file. Typically you'll set this to false.
overlapOnly
if true, do not output information for non-overlapping changes. Typically you'll set this to false.
eol
the end-of-line sequence to use in the output

Return Value

true if conflicts were found; false otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace | StarTeamMerge.MergeToFile Overload List


StarTeamMerge.MergeToFile Method (FileInfo, String, FileInfo, String, FileInfo, String, DiffCompare, FileInfo, String, String, String, String, Boolean, Boolean, String)

Performs a three-way merge of two text files and their common ancestor.

public static bool MergeToFile(
FileInfo mine,
String mineEncoding,
FileInfo common,
String commonEncoding,
FileInfo yours,
String yoursEncoding,
DiffCompare compare,
FileInfo output,
String outputEncoding,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly,
String eol
);

Parameters

mine
The first file to be merged.
mineEncoding
The first file's encoding.
common
The common ancestor of the two files to be merged.
commonEncoding
The common file's encoding.
yours
The second file to be merged.
yoursEncoding
The second file's encoding.
compare
the method by which lines are compared for equality when computing changes between two files
output
The output file where the merged results are written.
outputEncoding
The output file's encoding.
mineLabel
A label to be used to identify the first file in the markup text.
commonLabel
A label to be used to identify the common ancestor in the markup text.
yoursLabel
A label to be used to identify the second file in the markup text.
showFromCommon
if true output will include changed lines from the common file. Typically you'll set this to false.
overlapOnly
if true, do not output information for non-overlapping changes. Typically you'll set this to false.
eol
the end-of-line sequence to use in the output

Return Value

true if conflicts were found; false otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.starbase.diff.DiffException

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace | StarTeamMerge.MergeToFile Overload List


StarTeamMerge.ToString Method

Delegate ToString() to com.starbase.diff.StarTeamMerge.

public override string ToString();

Return Value

com.starbase.diff.StarTeamMerge.ToString()

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace


StarTeamMerge Type Conversions

The type conversions of the StarTeamMerge class are listed below. For a complete list of StarTeamMerge class members, see the StarTeamMerge Members topic.

Public Static Type Conversions

Implicit StarTeamMerge to StarTeamMerge Conversion Implicitly convert StarTeamMerge to com.starbase.diff.StarTeamMerge.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

StarTeamMerge Class | StarTeamMerge Members | Borland.StarTeam.Diff Namespace


StarTeamMerge Implicit StarTeamMerge to StarTeamMerge Conversion

Implicitly convert StarTeamMerge to com.starbase.diff.StarTeamMerge.

public static implicit operator StarTeamMerge(
StarTeamMerge arg
);

Parameters

arg
StarTeamMerge to convert.

Return Value

com.starbase.diff.StarTeamMerge

See Also

StarTeamMerge Class | Borland.StarTeam.Diff Namespace


StringCharSequence Class

For a list of all members of this type, see StringCharSequence Members.

System.Object
StringCharSequence

public class StringCharSequence : CharSequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Diff

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

StringCharSequence Members | Borland.StarTeam.Diff Namespace


StringCharSequence Members

StringCharSequence overview

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.StringCharSequence.

Public Static Type Conversions

Implicit StringCharSequence to StringCharSequence Conversion Implicitly convert StringCharSequence to com.starbase.diff.StringCharSequence.

Public Instance Constructors

StringCharSequence Overloaded. Initializes a new instance of the StringCharSequence class.

Public Instance Properties

Length

Public Instance Methods

CharAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringCharSequence Class | Borland.StarTeam.Diff Namespace


StringCharSequence Constructor

Construct StringCharSequence from com.starbase.diff.StringCharSequence.

Overload List

Construct StringCharSequence from com.starbase.diff.StringCharSequence.

public StringCharSequence(StringCharSequence);

public StringCharSequence(String);

See Also

StringCharSequence Class | Borland.StarTeam.Diff Namespace


StringCharSequence Constructor (StringCharSequence)

Construct StringCharSequence from com.starbase.diff.StringCharSequence.

public StringCharSequence(
StringCharSequence impl
);

Parameters

impl
The com.starbase.diff.StringCharSequence to be wrapped.

See Also

StringCharSequence Class | Borland.StarTeam.Diff Namespace | StringCharSequence Constructor Overload List


StringCharSequence Constructor (String)

public StringCharSequence(
String src
);

Parameters

src

See Also

StringCharSequence Class | Borland.StarTeam.Diff Namespace | StringCharSequence Constructor Overload List


StringCharSequence Properties

The properties of the StringCharSequence class are listed below. For a complete list of StringCharSequence class members, see the StringCharSequence Members topic.

Public Instance Properties

Length

See Also

StringCharSequence Class | Borland.StarTeam.Diff Namespace


Length Property

Borland StarTeam SDK for .NET

StringCharSequence.Length Property

public virtual Int32 Length {get;}

Implements

CharSequence.Length

See Also

StringCharSequence Class | Borland.StarTeam.Diff Namespace


StringCharSequence Methods

The methods of the StringCharSequence class are listed below. For a complete list of StringCharSequence class members, see the StringCharSequence Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.diff.StringCharSequence.

Public Instance Methods

CharAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringCharSequence Class | Borland.StarTeam.Diff Namespace


StringCharSequence.CharAt Method

public virtual char CharAt(
Int32 n
);

Implements

CharSequence.CharAt

See Also

StringCharSequence Class | Borland.StarTeam.Diff Namespace


StringCharSequence.Wrap Method

Dynamically wraps com.starbase.diff.StringCharSequence.

public static StringCharSequence Wrap(
StringCharSequence impl
);

Parameters

impl
com.starbase.diff.StringCharSequence to be wrapped.

Return Value

StringCharSequence

See Also

StringCharSequence Class | Borland.StarTeam.Diff Namespace


StringCharSequence Type Conversions

The type conversions of the StringCharSequence class are listed below. For a complete list of StringCharSequence class members, see the StringCharSequence Members topic.

Public Static Type Conversions

Implicit StringCharSequence to StringCharSequence Conversion Implicitly convert StringCharSequence to com.starbase.diff.StringCharSequence.

See Also

StringCharSequence Class | StringCharSequence Members | Borland.StarTeam.Diff Namespace


StringCharSequence Implicit StringCharSequence to StringCharSequence Conversion

Implicitly convert StringCharSequence to com.starbase.diff.StringCharSequence.

public static implicit operator StringCharSequence(
StringCharSequence arg
);

Parameters

arg
StringCharSequence to convert.

Return Value

com.starbase.diff.StringCharSequence

See Also

StringCharSequence Class | Borland.StarTeam.Diff Namespace


Borland.StarTeam.Util

Borland StarTeam SDK for .NET

Borland.StarTeam.Util Namespace

Namespace hierarchy

Classes

Class | Description
ArrayAdapter | Base class used for collections that wrap an array of objects from the com.starbase namespace.
Base64 | A utility class for encoding and decoding binary data in base64. More information on base64 encoding can be found in RFC 2045 - Multipurpose Internet Mail Extensions (MIME) part one.
Diagnostics | A simple utility class with methods for generating detailed system and error information.
Encoding | This interface exposed the Java Class: com.borland.starteam.util.Encoding. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/util/Encoding.html
EncodingCollection | A strongly-typed collection of Encodings.
EOLReader |
FileUtils | Utility class for accessing file info.
GUID |
ISO8601 | A utility class for encoding and parsing ISO8601 date/time format strings. The following sites have more information: W3C NOTE - Date and Time Formated Appendix 2 of the WebDAV specification. Discussion by Markus Kuhn
LineProcessor |
LineReader |
MD5 |
OLEDateAdapter |
OSEnvironment | Support for reading environment varaibles from the OS.
Platform | The Platform class is where I collect all platform specific APIs for things like end-of-line character and file lastModified methods... At some point, parts of this may need to be implemented in native code
UTF8 | Implements UTF-8 conversion routines as described by RFC-2279
UTF8InputStreamReader |
WorkStationException |
WorkStationOptionsAdapter |
XMLUtils | A class with XML related utility methods.

Interfaces

Interface | Description
WorkStationOptions |


ArrayAdapter Class

Base class used for collections that wrap an array of objects from the com.starbase namespace.

For a list of all members of this type, see ArrayAdapter Members.

System.Object
ArrayAdapter
Derived types

public class ArrayAdapter : IList, ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ArrayAdapter Members | Borland.StarTeam.Util Namespace | IEnumerable | ICollection | IList


ArrayAdapter Members

ArrayAdapter overview

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsFixedSize | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly | Gets a value indicating whether or not the collection can be modified.
IsSynchronized | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Clear | Removes all items from the collection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveAt | Removes the item at the specified index from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add | Adds an item to end of the collection.
IList.Contains | Determines whether or not the collection contains a specific value.
IList.IndexOf | Determines the index of a specific item in the collection.
IList.Insert | Inserts an item into the collection at the specified position.
IList.Item | Gets or sets the element at the specified index.
IList.Remove | Removes the first occurrence of the specific object from the collection.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace | IEnumerable | ICollection | IList


ArrayAdapter Properties

The properties of the ArrayAdapter class are listed below. For a complete list of ArrayAdapter class members, see the ArrayAdapter Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsFixedSize | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly | Gets a value indicating whether or not the collection can be modified.
IsSynchronized | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add | Adds an item to end of the collection.
IList.Contains | Determines whether or not the collection contains a specific value.
IList.IndexOf | Determines the index of a specific item in the collection.
IList.Insert | Inserts an item into the collection at the specified position.
IList.Item | Gets or sets the element at the specified index.
IList.Remove | Removes the first occurrence of the specific object from the collection.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace | IEnumerable | ICollection | IList


Count Property

Borland StarTeam SDK for .NET

ArrayAdapter.Count Property

Gets the number of elements contained in the collection.

public Int32 Count {get;}

Implements

ICollection.Count

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


IsFixedSize Property

Borland StarTeam SDK for .NET

ArrayAdapter.IsFixedSize Property

Gets a value indicating whether or not the collection has a fixed size.

public Boolean IsFixedSize {get;}

Implements

IList.IsFixedSize

Remarks

By default, ArrayAdapter-derived classes return false.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


IsReadOnly Property

Borland StarTeam SDK for .NET

ArrayAdapter.IsReadOnly Property

Gets a value indicating whether or not the collection can be modified.

public Boolean IsReadOnly {get;}

Implements

IList.IsReadOnly

Remarks

By default, ArrayAdapter-derived classes return false.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


IsSynchronized Property

Borland StarTeam SDK for .NET

ArrayAdapter.IsSynchronized Property

Gets a value indicating whether or not access to the collection is synchronized (thread-safe).

public Boolean IsSynchronized {get;}

Implements

ICollection.IsSynchronized

Remarks

By default, ArrayAdapter-derived classes return false.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


SyncRoot Property

Borland StarTeam SDK for .NET

ArrayAdapter.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public Object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


IList.Item Property

Borland StarTeam SDK for .NET

ArrayAdapter.IList.Item Property

Gets or sets the element at the specified index.

private Object this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Implements

IList.Item

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


ArrayAdapter Methods

The methods of the ArrayAdapter class are listed below. For a complete list of ArrayAdapter class members, see the ArrayAdapter Members topic.

Public Instance Methods

Clear | Removes all items from the collection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveAt | Removes the item at the specified index from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add | Adds an item to end of the collection.
IList.Contains | Determines whether or not the collection contains a specific value.
IList.IndexOf | Determines the index of a specific item in the collection.
IList.Insert | Inserts an item into the collection at the specified position.
IList.Item | Gets or sets the element at the specified index.
IList.Remove | Removes the first occurrence of the specific object from the collection.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace | IEnumerable | ICollection | IList


ArrayAdapter.Clear Method

Removes all items from the collection.

public void Clear();

Implements

IList.Clear

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


ArrayAdapter.GetEnumerator Method

Gets an enumerator that can iterate through members of the collection.

public IEnumerator GetEnumerator();

Return Value

An IEnumerator that can iterate through members of the collection.

Implements

IEnumerable.GetEnumerator

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


ArrayAdapter.RemoveAt Method

Removes the item at the specified index from the collection.

public void RemoveAt(
Int32 index
);

Parameters

index
The zero-based index of the item to remove.

Implements

IList.RemoveAt

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


ArrayAdapter.ICollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

void ICollection.CopyTo(
Array array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from the ArrayAdapter collection.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of elements in the source collection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ArrayAdapter cannot be cast automatically to the type of the destination array.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


ArrayAdapter.IList.Add Method

Adds an item to end of the collection.

int IList.Add(
Object value
);

Parameters

value
The Object to add to the collection.

Return Value

The position into which the new element was inserted.

Implements

IList.Add

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


ArrayAdapter.IList.Contains Method

Determines whether or not the collection contains a specific value.

bool IList.Contains(
Object value
);

Parameters

value
The Object to locate in the collection.

Return Value

true if the Object is found in the collection; otherwise, false.

Implements

IList.Contains

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


ArrayAdapter.IList.IndexOf Method

Determines the index of a specific item in the collection.

int IList.IndexOf(
Object value
);

Parameters

value
The Object to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

Implements

IList.IndexOf

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


ArrayAdapter.IList.Insert Method

Inserts an item into the collection at the specified position.

void IList.Insert(
Int32 index,
Object value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Object to insert into the collection.

Implements

IList.Insert

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


ArrayAdapter.IList.Remove Method

Removes the first occurrence of the specific object from the collection.

void IList.Remove(
Object value
);

Parameters

value
The Object to remove from the collection.

Implements

IList.Remove

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ArrayAdapter Class | Borland.StarTeam.Util Namespace


Base64 Class

A utility class for encoding and decoding binary data in base64. More information on base64 encoding can be found in RFC 2045 - Multipurpose Internet Mail Extensions (MIME) part one.

For a list of all members of this type, see Base64 Members.

System.Object
Base64

public class Base64 : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Base64 Members | Borland.StarTeam.Util Namespace


Base64 Members

Base64 overview

Public Static Methods

Decode | Returns the byte array represented by the specified base64 encoded data.
DecodeAsString | Returns the String decoding of the specified base64 encoded data. Since decoding really should return a byte array this method simply treats each byte as the corresponding Unicode character with the high byte set to zero. This is equivalent to treating the decoded bytes as the ISO-8859-1 encoding of the returned string.
DecodeToFile | Decodes the specified base64 encoded data but puts the output in to the specified File.
DecodeToStream | Decodes the specified base64 encoded data but puts the output in to the specified OutputStream.
Encode | Returns a String encoding of the specified data in base64.
EncodeBytes | Returns a byte array encoding of the specified data in base64.

Public Static Type Conversions

Implicit Base64 to Base64 Conversion Implicitly convert Base64 to com.starbase.util.Base64.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.Base64.
GetHashCode | Delegate GetHashCode() to com.starbase.util.Base64.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.Base64.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64 Methods

The methods of the Base64 class are listed below. For a complete list of Base64 class members, see the Base64 Members topic.

Public Static Methods

Decode | Returns the byte array represented by the specified base64 encoded data.
DecodeAsString | Returns the String decoding of the specified base64 encoded data. Since decoding really should return a byte array this method simply treats each byte as the corresponding Unicode character with the high byte set to zero. This is equivalent to treating the decoded bytes as the ISO-8859-1 encoding of the returned string.
DecodeToFile | Decodes the specified base64 encoded data but puts the output in to the specified File.
DecodeToStream | Decodes the specified base64 encoded data but puts the output in to the specified OutputStream.
Encode | Returns a String encoding of the specified data in base64.
EncodeBytes | Returns a byte array encoding of the specified data in base64.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.Base64.
GetHashCode | Delegate GetHashCode() to com.starbase.util.Base64.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.Base64.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.Base64

Implements

IWrapper.Unwrap

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64.Decode Method

Returns the byte array represented by the specified base64 encoded data.

public static byte[] Decode(
String data
);

Parameters

data
the base64 data to be decoded

Return Value

the decoded data

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64.DecodeAsString Method

Returns the String decoding of the specified base64 encoded data. Since decoding really should return a byte array this method simply treats each byte as the corresponding Unicode character with the high byte set to zero. This is equivalent to treating the decoded bytes as the ISO-8859-1 encoding of the returned string.

public static string DecodeAsString(
String data
);

Parameters

data
the base64 encoded data to be decoded

Return Value

the decoded data represented as a String

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64.DecodeToFile Method

Decodes the specified base64 encoded data but puts the output in to the specified File.

public static void DecodeToFile(
String data,
FileInfo outFile
);

Parameters

data
a base64 encoding of some data
outFile

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64.DecodeToStream Method

Decodes the specified base64 encoded data but puts the output in to the specified OutputStream.

public static void DecodeToStream(
String data,
Stream _out
);

Parameters

data
a base64 encoding of some data
_out

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64.Encode Method

Returns a String encoding of the specified data in base64.

public static string Encode(
Byte[] data
);

Parameters

data
the data to be encoded

Return Value

the base64 encoding of the specified data

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64.EncodeBytes Method

Returns a byte array encoding of the specified data in base64.

public static byte[] EncodeBytes(
Byte[] data,
Int32 pos,
Int32 len
);

Parameters

data
the data to be encoded
pos
the starting position of the data to be encoded
len
the length of data to be encoded

Return Value

the base64 encoding of the specified data as a byte array

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64.Equals Method

Delegate Equals() to com.starbase.util.Base64.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.Base64.Equals(obj).

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.Base64.

public override int GetHashCode();

Return Value

com.starbase.util.Base64.GetHashCode().

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64.ToString Method

Delegate ToString() to com.starbase.util.Base64.

public override string ToString();

Return Value

com.starbase.util.Base64.ToString()

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Base64 Type Conversions

The type conversions of the Base64 class are listed below. For a complete list of Base64 class members, see the Base64 Members topic.

Public Static Type Conversions

Implicit Base64 to Base64 Conversion Implicitly convert Base64 to com.starbase.util.Base64.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Base64 Class | Base64 Members | Borland.StarTeam.Util Namespace


Base64 Implicit Base64 to Base64 Conversion

Implicitly convert Base64 to com.starbase.util.Base64.

public static implicit operator Base64(
Base64 arg
);

Parameters

arg
Base64 to convert.

Return Value

com.starbase.util.Base64

See Also

Base64 Class | Borland.StarTeam.Util Namespace


Diagnostics Class

A simple utility class with methods for generating detailed system and error information.

For a list of all members of this type, see Diagnostics Members.

System.Object
Diagnostics

public class Diagnostics : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Diagnostics Members | Borland.StarTeam.Util Namespace


Diagnostics Members

Diagnostics overview

Public Static Properties

SystemInfo [read]

Public Static Methods

CreateBugReport

Public Static Type Conversions

Implicit Diagnostics to Diagnostics Conversion Implicitly convert Diagnostics to com.starbase.util.Diagnostics.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.Diagnostics.
GetHashCode | Delegate GetHashCode() to com.starbase.util.Diagnostics.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.Diagnostics.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Diagnostics Class | Borland.StarTeam.Util Namespace


Diagnostics Properties

The properties of the Diagnostics class are listed below. For a complete list of Diagnostics class members, see the Diagnostics Members topic.

Public Static Properties

SystemInfo [read]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Diagnostics Class | Borland.StarTeam.Util Namespace


SystemInfo Property

Borland StarTeam SDK for .NET

Diagnostics.SystemInfo Property

[read]

public static String SystemInfo {get;}

See Also

Diagnostics Class | Borland.StarTeam.Util Namespace


Diagnostics Methods

The methods of the Diagnostics class are listed below. For a complete list of Diagnostics class members, see the Diagnostics Members topic.

Public Static Methods

CreateBugReport

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.Diagnostics.
GetHashCode | Delegate GetHashCode() to com.starbase.util.Diagnostics.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.Diagnostics.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Diagnostics Class | Borland.StarTeam.Util Namespace


Diagnostics.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.Diagnostics

Implements

IWrapper.Unwrap

See Also

Diagnostics Class | Borland.StarTeam.Util Namespace


Diagnostics.CreateBugReport Method

public static string CreateBugReport(
Exception err
);

See Also

Diagnostics Class | Borland.StarTeam.Util Namespace


Diagnostics.Equals Method

Delegate Equals() to com.starbase.util.Diagnostics.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.Diagnostics.Equals(obj).

See Also

Diagnostics Class | Borland.StarTeam.Util Namespace


Diagnostics.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.Diagnostics.

public override int GetHashCode();

Return Value

com.starbase.util.Diagnostics.GetHashCode().

See Also

Diagnostics Class | Borland.StarTeam.Util Namespace


Diagnostics.ToString Method

Delegate ToString() to com.starbase.util.Diagnostics.

public override string ToString();

Return Value

com.starbase.util.Diagnostics.ToString()

See Also

Diagnostics Class | Borland.StarTeam.Util Namespace


Diagnostics Type Conversions

The type conversions of the Diagnostics class are listed below. For a complete list of Diagnostics class members, see the Diagnostics Members topic.

Public Static Type Conversions

Implicit Diagnostics to Diagnostics Conversion Implicitly convert Diagnostics to com.starbase.util.Diagnostics.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Diagnostics Class | Diagnostics Members | Borland.StarTeam.Util Namespace


Diagnostics Implicit Diagnostics to Diagnostics Conversion

Implicitly convert Diagnostics to com.starbase.util.Diagnostics.

public static implicit operator Diagnostics(
Diagnostics arg
);

Parameters

arg
Diagnostics to convert.

Return Value

com.starbase.util.Diagnostics

See Also

Diagnostics Class | Borland.StarTeam.Util Namespace


Encoding Class

This interface exposed the Java Class: com.borland.starteam.util.Encoding. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/util/Encoding.html

For a list of all members of this type, see Encoding Members.

System.Object
Encoding

public class Encoding : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Encoding Members | Borland.StarTeam.Util Namespace


Encoding Members

Encoding overview

Public Static Properties

AllKnownEncodings | [read] A list of all known encodings, including ones that are not supported by the current platform. The encodings are sorted by name.
CODEPAGE_UNKNOWN |
DefaultPlatformEncoding | [read] The default platform encoding. Never returns null.
DefaultStarTeamEncoding | [read/write] The default StarTeam encoding. Never returns null.
ID_UNKNOWN |
ISO_8859_1 |
ReadableEncodings | [read] A list of all known encodings that are supported for reading (and possibly also writing) by the current platform. The encodings are sorted by the name used for reading on this platform.
STARTEAM_PROPERTY |
SupportedEncodings | [read] A list of all known encodings that are fully supported (for both reading and writing) by the current platform. The encodings are sorted by the name they are known by on this platform.
US_ASCII |
UTF_16 |
UTF_16BE |
UTF_16LE |
UTF_8 |
WritableEncodings | [read] A list of all known encodings that are supported for writing (and possibly also reading) by the current platform. The encodings are sorted by the name used for writing on this platform.

Public Static Methods

ForCodePage |
ForID |
ForName |
Wrap | Dynamically wraps com.borland.starteam.util.Encoding.

Public Static Type Conversions

Implicit Encoding to Encoding Conversion Implicitly convert Encoding to com.borland.starteam.util.Encoding.

Public Instance Constructors

Encoding Constructor Construct Encoding from com.borland.starteam.util.Encoding.

Public Instance Properties

AllNames | [read] The list of known names for this encoding. The first name is always the common name. If this encoding has both a preferred MIME name and a regsitered IANA name, and they are different, then the second entry is the regsitered IANA name. Other names appear in an arbitrary order.
CodePage | [read] The code page of this encoding, or CODEPAGE_UNKNOWN (-1) if this encoding does not have a corresponding code page, or if the code page cannot be represented by a number (e.g., "Cp949C").
IsReadingSupported | [read] true if this encoding is supported for reading by this platform; false otherwise.
IsSupported | [read] true if this encoding is fully supported (for both reading and writing) by this platform; false otherwise.
IsWritingSupported | [read] true if this encoding is supported for writing by this platform; false otherwise.
MimeName | [read] The preferred MIME name of this encoding, or null if this encoding does not have a preferred MIME name.
Name | [read] The common name of this encoding. If this encoding has a preferred MIME name, then that is always used as the common name. Otherwise, if the encoding is registered with IANA, then that is used as the common name. Otherwise, the common name is the preferred Java alias for this encoding.
PlatformName | [read] The name by which this encoding is known on this platform. If the encoding is known by multiple names, then the preferred name is returned. Returns null if this encoding is not fully supported (for both reading and writing) by this platform.
PlatformNameForReading | [read] A name that can be used to read this encoding on this platform. If multiple names can be used to read this encoding, then the preferred name for reading is returned. Returns null if reading is not supported for this encoding by this platform.
PlatformNameForWriting | [read] A name that can be used to write this encoding on this platform. If multiple names can be used to write this encoding, then the preferred name for writing is returned. Returns null if writing is not supported for this encoding by this platform.
RegisteredID | [read] The registered name of this encoding, or ID_UNKNOWN (-1) if this encoding is not registered with IANA, or was not assigned a unique ID.
RegisteredName | [read] The registered name of this encoding, or null if this encoding is not registered with IANA.

Public Instance Methods

Equals | Delegate Equals() to com.borland.starteam.util.Encoding.
GetHashCode | Delegate GetHashCode() to com.borland.starteam.util.Encoding.
GetType (inherited from Object) | Gets the Type of the current instance.
IsNamed |
ToString | Delegate ToString() to com.borland.starteam.util.Encoding.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding Constructor

Construct Encoding from com.borland.starteam.util.Encoding.

public Encoding(
Encoding impl
);

Parameters

impl
The com.borland.starteam.util.Encoding to be wrapped.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding Properties

The properties of the Encoding class are listed below. For a complete list of Encoding class members, see the Encoding Members topic.

Public Static Properties

AllKnownEncodings | [read] A list of all known encodings, including ones that are not supported by the current platform. The encodings are sorted by name.
CODEPAGE_UNKNOWN |
DefaultPlatformEncoding | [read] The default platform encoding. Never returns null.
DefaultStarTeamEncoding | [read/write] The default StarTeam encoding. Never returns null.
ID_UNKNOWN |
ISO_8859_1 |
ReadableEncodings | [read] A list of all known encodings that are supported for reading (and possibly also writing) by the current platform. The encodings are sorted by the name used for reading on this platform.
STARTEAM_PROPERTY |
SupportedEncodings | [read] A list of all known encodings that are fully supported (for both reading and writing) by the current platform. The encodings are sorted by the name they are known by on this platform.
US_ASCII |
UTF_16 |
UTF_16BE |
UTF_16LE |
UTF_8 |
WritableEncodings | [read] A list of all known encodings that are supported for writing (and possibly also reading) by the current platform. The encodings are sorted by the name used for writing on this platform.

Public Instance Properties

AllNames | [read] The list of known names for this encoding. The first name is always the common name. If this encoding has both a preferred MIME name and a regsitered IANA name, and they are different, then the second entry is the regsitered IANA name. Other names appear in an arbitrary order.
CodePage | [read] The code page of this encoding, or CODEPAGE_UNKNOWN (-1) if this encoding does not have a corresponding code page, or if the code page cannot be represented by a number (e.g., "Cp949C").
IsReadingSupported | [read] true if this encoding is supported for reading by this platform; false otherwise.
IsSupported | [read] true if this encoding is fully supported (for both reading and writing) by this platform; false otherwise.
IsWritingSupported | [read] true if this encoding is supported for writing by this platform; false otherwise.
MimeName | [read] The preferred MIME name of this encoding, or null if this encoding does not have a preferred MIME name.
Name | [read] The common name of this encoding. If this encoding has a preferred MIME name, then that is always used as the common name. Otherwise, if the encoding is registered with IANA, then that is used as the common name. Otherwise, the common name is the preferred Java alias for this encoding.
PlatformName | [read] The name by which this encoding is known on this platform. If the encoding is known by multiple names, then the preferred name is returned. Returns null if this encoding is not fully supported (for both reading and writing) by this platform.
PlatformNameForReading | [read] A name that can be used to read this encoding on this platform. If multiple names can be used to read this encoding, then the preferred name for reading is returned. Returns null if reading is not supported for this encoding by this platform.
PlatformNameForWriting | [read] A name that can be used to write this encoding on this platform. If multiple names can be used to write this encoding, then the preferred name for writing is returned. Returns null if writing is not supported for this encoding by this platform.
RegisteredID | [read] The registered name of this encoding, or ID_UNKNOWN (-1) if this encoding is not registered with IANA, or was not assigned a unique ID.
RegisteredName | [read] The registered name of this encoding, or null if this encoding is not registered with IANA.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Encoding Class | Borland.StarTeam.Util Namespace


AllKnownEncodings Property

Borland StarTeam SDK for .NET

Encoding.AllKnownEncodings Property

[read] A list of all known encodings, including ones that are not supported by the current platform. The encodings are sorted by name.

public static EncodingCollection AllKnownEncodings {get;}

Property Value

A list of all known encodings, including ones that are not supported by the current platform. The encodings are sorted by name.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


AllNames Property

Borland StarTeam SDK for .NET

Encoding.AllNames Property

[read] The list of known names for this encoding. The first name is always the common name. If this encoding has both a preferred MIME name and a regsitered IANA name, and they are different, then the second entry is the regsitered IANA name. Other names appear in an arbitrary order.

public virtual String[] AllNames {get;}

Property Value

The list of known names for this encoding. The first name is always the common name. If this encoding has both a preferred MIME name and a regsitered IANA name, and they are different, then the second entry is the regsitered IANA name. Other names appear in an arbitrary order.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


CodePage Property

Borland StarTeam SDK for .NET

Encoding.CodePage Property

[read] The code page of this encoding, or CODEPAGE_UNKNOWN (-1) if this encoding does not have a corresponding code page, or if the code page cannot be represented by a number (e.g., "Cp949C").

public virtual Int32 CodePage {get;}

Property Value

The code page of this encoding, or CODEPAGE_UNKNOWN (-1) if this encoding does not have a corresponding code page, or if the code page cannot be represented by a number (e.g., "Cp949C").

See Also

Encoding Class | Borland.StarTeam.Util Namespace


CODEPAGE_UNKNOWN Property

Borland StarTeam SDK for .NET

Encoding.CODEPAGE_UNKNOWN Property

public static Int32 CODEPAGE_UNKNOWN {get;}

See Also

Encoding Class | Borland.StarTeam.Util Namespace


DefaultPlatformEncoding Property

Borland StarTeam SDK for .NET

Encoding.DefaultPlatformEncoding Property

[read] The default platform encoding. Never returns null.

public static Encoding DefaultPlatformEncoding {get;}

Property Value

The default platform encoding. Never returns null.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


DefaultStarTeamEncoding Property

Borland StarTeam SDK for .NET

Encoding.DefaultStarTeamEncoding Property

[read/write] The default StarTeam encoding. Never returns null.

public static Encoding DefaultStarTeamEncoding {get; set;}

Property Value

The default StarTeam encoding. Never returns null.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


ID_UNKNOWN Property

Borland StarTeam SDK for .NET

Encoding.ID_UNKNOWN Property

public static Int32 ID_UNKNOWN {get;}

See Also

Encoding Class | Borland.StarTeam.Util Namespace


ISO_8859_1 Property

Borland StarTeam SDK for .NET

Encoding.ISO_8859_1 Property

public static Encoding ISO_8859_1 {get;}

See Also

Encoding Class | Borland.StarTeam.Util Namespace


IsReadingSupported Property

Borland StarTeam SDK for .NET

Encoding.IsReadingSupported Property

[read] true if this encoding is supported for reading by this platform; false otherwise.

public virtual Boolean IsReadingSupported {get;}

Property Value

true if this encoding is supported for reading by this platform; false otherwise.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


IsSupported Property

Borland StarTeam SDK for .NET

Encoding.IsSupported Property

[read] true if this encoding is fully supported (for both reading and writing) by this platform; false otherwise.

public virtual Boolean IsSupported {get;}

Property Value

true if this encoding is fully supported (for both reading and writing) by this platform; false otherwise.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


IsWritingSupported Property

Borland StarTeam SDK for .NET

Encoding.IsWritingSupported Property

[read] true if this encoding is supported for writing by this platform; false otherwise.

public virtual Boolean IsWritingSupported {get;}

Property Value

true if this encoding is supported for writing by this platform; false otherwise.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


MimeName Property

Borland StarTeam SDK for .NET

Encoding.MimeName Property

[read] The preferred MIME name of this encoding, or null if this encoding does not have a preferred MIME name.

public virtual String MimeName {get;}

Property Value

The preferred MIME name of this encoding, or null if this encoding does not have a preferred MIME name.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Name Property

Borland StarTeam SDK for .NET

Encoding.Name Property

[read] The common name of this encoding. If this encoding has a preferred MIME name, then that is always used as the common name. Otherwise, if the encoding is registered with IANA, then that is used as the common name. Otherwise, the common name is the preferred Java alias for this encoding.

public virtual String Name {get;}

Property Value

The common name of this encoding. If this encoding has a preferred MIME name, then that is always used as the common name. Otherwise, if the encoding is registered with IANA, then that is used as the common name. Otherwise, the common name is the preferred Java alias for this encoding.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


PlatformName Property

Borland StarTeam SDK for .NET

Encoding.PlatformName Property

[read] The name by which this encoding is known on this platform. If the encoding is known by multiple names, then the preferred name is returned. Returns null if this encoding is not fully supported (for both reading and writing) by this platform.

public virtual String PlatformName {get;}

Property Value

The name by which this encoding is known on this platform. If the encoding is known by multiple names, then the preferred name is returned. Returns null if this encoding is not fully supported (for both reading and writing) by this platform.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


PlatformNameForReading Property

Borland StarTeam SDK for .NET

Encoding.PlatformNameForReading Property

[read] A name that can be used to read this encoding on this platform. If multiple names can be used to read this encoding, then the preferred name for reading is returned. Returns null if reading is not supported for this encoding by this platform.

public virtual String PlatformNameForReading {get;}

Property Value

A name that can be used to read this encoding on this platform. If multiple names can be used to read this encoding, then the preferred name for reading is returned. Returns null if reading is not supported for this encoding by this platform.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


PlatformNameForWriting Property

Borland StarTeam SDK for .NET

Encoding.PlatformNameForWriting Property

[read] A name that can be used to write this encoding on this platform. If multiple names can be used to write this encoding, then the preferred name for writing is returned. Returns null if writing is not supported for this encoding by this platform.

public virtual String PlatformNameForWriting {get;}

Property Value

A name that can be used to write this encoding on this platform. If multiple names can be used to write this encoding, then the preferred name for writing is returned. Returns null if writing is not supported for this encoding by this platform.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


ReadableEncodings Property

Borland StarTeam SDK for .NET

Encoding.ReadableEncodings Property

[read] A list of all known encodings that are supported for reading (and possibly also writing) by the current platform. The encodings are sorted by the name used for reading on this platform.

public static EncodingCollection ReadableEncodings {get;}

Property Value

A list of all known encodings that are supported for reading (and possibly also writing) by the current platform. The encodings are sorted by the name used for reading on this platform.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


RegisteredID Property

Borland StarTeam SDK for .NET

Encoding.RegisteredID Property

[read] The registered name of this encoding, or ID_UNKNOWN (-1) if this encoding is not registered with IANA, or was not assigned a unique ID.

public virtual Int32 RegisteredID {get;}

Property Value

The registered name of this encoding, or ID_UNKNOWN (-1) if this encoding is not registered with IANA, or was not assigned a unique ID.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


RegisteredName Property

Borland StarTeam SDK for .NET

Encoding.RegisteredName Property

[read] The registered name of this encoding, or null if this encoding is not registered with IANA.

public virtual String RegisteredName {get;}

Property Value

The registered name of this encoding, or null if this encoding is not registered with IANA.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


STARTEAM_PROPERTY Property

Borland StarTeam SDK for .NET

Encoding.STARTEAM_PROPERTY Property

public static String STARTEAM_PROPERTY {get;}

See Also

Encoding Class | Borland.StarTeam.Util Namespace


SupportedEncodings Property

Borland StarTeam SDK for .NET

Encoding.SupportedEncodings Property

[read] A list of all known encodings that are fully supported (for both reading and writing) by the current platform. The encodings are sorted by the name they are known by on this platform.

public static EncodingCollection SupportedEncodings {get;}

Property Value

A list of all known encodings that are fully supported (for both reading and writing) by the current platform. The encodings are sorted by the name they are known by on this platform.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


US_ASCII Property

Borland StarTeam SDK for .NET

Encoding.US_ASCII Property

public static Encoding US_ASCII {get;}

See Also

Encoding Class | Borland.StarTeam.Util Namespace


UTF_16 Property

Borland StarTeam SDK for .NET

Encoding.UTF_16 Property

public static Encoding UTF_16 {get;}

See Also

Encoding Class | Borland.StarTeam.Util Namespace


UTF_16BE Property

Borland StarTeam SDK for .NET

Encoding.UTF_16BE Property

public static Encoding UTF_16BE {get;}

See Also

Encoding Class | Borland.StarTeam.Util Namespace


UTF_16LE Property

Borland StarTeam SDK for .NET

Encoding.UTF_16LE Property

public static Encoding UTF_16LE {get;}

See Also

Encoding Class | Borland.StarTeam.Util Namespace


UTF_8 Property

Borland StarTeam SDK for .NET

Encoding.UTF_8 Property

public static Encoding UTF_8 {get;}

See Also

Encoding Class | Borland.StarTeam.Util Namespace


WritableEncodings Property

Borland StarTeam SDK for .NET

Encoding.WritableEncodings Property

[read] A list of all known encodings that are supported for writing (and possibly also reading) by the current platform. The encodings are sorted by the name used for writing on this platform.

public static EncodingCollection WritableEncodings {get;}

Property Value

A list of all known encodings that are supported for writing (and possibly also reading) by the current platform. The encodings are sorted by the name used for writing on this platform.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding Methods

The methods of the Encoding class are listed below. For a complete list of Encoding class members, see the Encoding Members topic.

Public Static Methods

ForCodePage |
ForID |
ForName |
Wrap | Dynamically wraps com.borland.starteam.util.Encoding.

Public Instance Methods

Equals | Delegate Equals() to com.borland.starteam.util.Encoding.
GetHashCode | Delegate GetHashCode() to com.borland.starteam.util.Encoding.
GetType (inherited from Object) | Gets the Type of the current instance.
IsNamed |
ToString | Delegate ToString() to com.borland.starteam.util.Encoding.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.borland.starteam.util.Encoding

Implements

IWrapper.Unwrap

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding.Equals Method

Delegate Equals() to com.borland.starteam.util.Encoding.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.borland.starteam.util.Encoding.Equals(obj).

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding.ForCodePage Method

public static Encoding ForCodePage(
Int32 cp
);

Parameters

cp

Return Value

The corresponding code page, or null if there is no such encoding.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding.ForID Method

public static Encoding ForID(
Int32 id
);

Parameters

id

Return Value

The corresponding encoding, or null if there is no such encoding.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding.ForName Method

public static Encoding ForName(
String name
);

Parameters

name

Return Value

The corresponding encoding, or null if there is no such encoding.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding.GetHashCode Method

Delegate GetHashCode() to com.borland.starteam.util.Encoding.

public override int GetHashCode();

Return Value

com.borland.starteam.util.Encoding.GetHashCode().

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding.IsNamed Method

public virtual bool IsNamed(
String name
);

Parameters

name

Return Value

true if the given name refers to this encoding; false otherwise.

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding.ToString Method

Delegate ToString() to com.borland.starteam.util.Encoding.

public override string ToString();

Return Value

com.borland.starteam.util.Encoding.ToString()

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding.Wrap Method

Dynamically wraps com.borland.starteam.util.Encoding.

public static Encoding Wrap(
Encoding impl
);

Parameters

impl
com.borland.starteam.util.Encoding to be wrapped.

Return Value

Encoding

See Also

Encoding Class | Borland.StarTeam.Util Namespace


Encoding Type Conversions

The type conversions of the Encoding class are listed below. For a complete list of Encoding class members, see the Encoding Members topic.

Public Static Type Conversions

Implicit Encoding to Encoding Conversion Implicitly convert Encoding to com.borland.starteam.util.Encoding.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Encoding Class | Encoding Members | Borland.StarTeam.Util Namespace


Encoding Implicit Encoding to Encoding Conversion

Implicitly convert Encoding to com.borland.starteam.util.Encoding.

public static implicit operator Encoding(
Encoding arg
);

Parameters

arg
Encoding to convert.

Return Value

com.borland.starteam.util.Encoding

See Also

Encoding Class | Borland.StarTeam.Util Namespace


EncodingCollection Class

A strongly-typed collection of Encodings.

For a list of all members of this type, see EncodingCollection Members.

System.Object
ArrayAdapter
EncodingCollection

public class EncodingCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EncodingCollection Members | Borland.StarTeam.Util Namespace


EncodingCollection Members

EncodingCollection overview

Public Static Methods

Wrap Creates an EncodingCollection to represent the given array of Encoding (from the com.borland.starteam.util namespace).

Public Static Type Conversions

Implicit EncodingCollection to Encoding[] Conversion | Converts an EncodingCollection to an array of Encodings.
Implicit EncodingCollection to Encoding[] Conversion | Converts an EncodingCollection from the Borland.StarTeam.Util namespace to an Encoding[] in the com.borland.starteam.util namespace.

Public Instance Constructors

EncodingCollection Overloaded. Initializes a new instance of the EncodingCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Encoding at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an Encoding to end of the collection.
Append | Overloaded. Appends the Encodings of the given EncodingCollection to the end of this EncodingCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Encoding.
CopyTo | Copies all of the Encodings in the EncodingCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the Encoding with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Encoding in the collection.
Insert | Inserts an Encoding into the collection at the specified position.
Remove | Removes the first occurrence of a specific Encoding from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Encodings in this EncodingCollection.
Sort | Sorts the Encodings in this EncodingCollection, using the given comparer.
SortByName | Sorts the Encodings in this EncodingCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.util namespace.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection Constructor

Initializes an instance of the EncodingCollection class.

Overload List

Initializes an instance of the EncodingCollection class.

public EncodingCollection();

Initializes an instance of the an EncodingCollection class, copying the given array.

public EncodingCollection(Encoding[]);

Initializes an instance of the an EncodingCollection class, copying the given collection.

public EncodingCollection(EncodingCollection);

Initializes an instance of the an EncodingCollection class, wrapping the given array of Encoding (from the com.borland.starteam.util namespace).

public EncodingCollection(Encoding[]);

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection Constructor ()

Initializes an instance of the EncodingCollection class.

public EncodingCollection();

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace | EncodingCollection Constructor Overload List


EncodingCollection Constructor (Encoding[])

Initializes an instance of the an EncodingCollection class, wrapping the given array of Encoding (from the com.borland.starteam.util namespace).

public EncodingCollection(
Encoding[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.borland.starteam.util namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace | EncodingCollection Constructor Overload List | Wrap


EncodingCollection Constructor (EncodingCollection)

Initializes an instance of the an EncodingCollection class, copying the given collection.

public EncodingCollection(
EncodingCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Encoding objects of the original collection are shared, not copied.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace | EncodingCollection Constructor Overload List


EncodingCollection Constructor (Encoding[])

Initializes an instance of the an EncodingCollection class, copying the given array.

public EncodingCollection(
Encoding[] array
);

Parameters

array
The array to be copied.

Remarks

The member Encoding objects of the original array are shared, not copied.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace | EncodingCollection Constructor Overload List


EncodingCollection Properties

The properties of the EncodingCollection class are listed below. For a complete list of EncodingCollection class members, see the EncodingCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the Encoding at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.util namespace.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


Item Property

Borland StarTeam SDK for .NET

EncodingCollection.Item Property

Gets or sets the Encoding at the specified index.

Overload List

Gets or sets the Encoding at the specified index.

public Encoding this[Int32] {get; set;}

Gets the Encoding with the given name.

public Encoding this[String] {get;}

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

EncodingCollection.Item Property (Int32)

Gets or sets the Encoding at the specified index.

public Encoding this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Encoding to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace | EncodingCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

EncodingCollection.Item Property (String)

Gets the Encoding with the given name.

public Encoding this[
String name
] {get;}

Parameters

name
The name of the Encoding to get.

Property Value

The Encoding with the given name, or null if there is no Encoding with that name in this EncodingCollection. Comparison is case sensitive.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace | EncodingCollection.Item Overload List | FindByName


EncodingCollection Methods

The methods of the EncodingCollection class are listed below. For a complete list of EncodingCollection class members, see the EncodingCollection Members topic.

Public Static Methods

Wrap Creates an EncodingCollection to represent the given array of Encoding (from the com.borland.starteam.util namespace).

Public Instance Methods

Add | Adds an Encoding to end of the collection.
Append | Overloaded. Appends the Encodings of the given EncodingCollection to the end of this EncodingCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Encoding.
CopyTo | Copies all of the Encodings in the EncodingCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the Encoding with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Encoding in the collection.
Insert | Inserts an Encoding into the collection at the specified position.
Remove | Removes the first occurrence of a specific Encoding from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Encodings in this EncodingCollection.
Sort | Sorts the Encodings in this EncodingCollection, using the given comparer.
SortByName | Sorts the Encodings in this EncodingCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.util namespace.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.Add Method

Adds an Encoding to end of the collection.

public int Add(
Encoding value
);

Parameters

value
The Encoding to add to the collection.

Return Value

The position into which the new Encoding was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


Append Method

Borland StarTeam SDK for .NET

EncodingCollection.Append Method

Appends the Encodings of the given array to the end of this EncodingCollection.

Overload List

Appends the Encodings of the given array to the end of this EncodingCollection.

public EncodingCollection Append(Encoding[]);

Appends the Encodings of the given EncodingCollection to the end of this EncodingCollection.

public EncodingCollection Append(EncodingCollection);

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.Append Method (Encoding[])

Appends the Encodings of the given array to the end of this EncodingCollection.

public EncodingCollection Append(
Encoding[] array
);

Parameters

array
The array whose Encodings are to be appended to this EncodingCollection.

Return Value

This EncodingCollection, modified to include the new Encodings.

Remarks

The EncodingCollection is modified to include the new members. The individual Encoding objects are shared, not copied.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace | EncodingCollection.Append Overload List


EncodingCollection.Append Method (EncodingCollection)

Appends the Encodings of the given EncodingCollection to the end of this EncodingCollection.

public EncodingCollection Append(
EncodingCollection collection
);

Parameters

collection
The EncodingCollection whose Encodings are to be appended to this EncodingCollection.

Return Value

This EncodingCollection, modified to include the new Encodings.

Remarks

The EncodingCollection is modified to include the new members. The individual Encoding objects are shared, not copied.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace | EncodingCollection.Append Overload List


EncodingCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.borland.starteam.util namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.borland.starteam.util.Encoding[].

Implements

IWrapper.Unwrap

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.Contains Method

Determines whether or not the collection contains a specific Encoding.

public bool Contains(
Encoding value
);

Parameters

value
The Encoding to locate in the collection.

Return Value

true if the Encoding is found in the collection; otherwise, false.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.CopyTo Method

Copies all of the Encodings in the EncodingCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Encoding[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Encodings copied from the EncodingCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Encodings in the source EncodingCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source EncodingCollection cannot be cast automatically to the type of the destination array.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.FindByName Method

Finds the Encoding with the given name.

public Encoding FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the Encoding to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The Encoding with the given name, or null if there is no Encoding with that name in this EncodingCollection.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.IndexOf Method

Determines the index of a specific Encoding in the collection.

public int IndexOf(
Encoding value
);

Parameters

value
The Encoding to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.Insert Method

Inserts an Encoding into the collection at the specified position.

public void Insert(
Int32 index,
Encoding value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Encoding to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.Remove Method

Removes the first occurrence of a specific Encoding from the collection.

public void Remove(
Encoding value
);

Parameters

value
The Encoding to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.Reverse Method

Reverses the order of the Encodings in this EncodingCollection.

new public EncodingCollection Reverse();

Return Value

This EncodingCollection, modified such that the Encodings are reversed.

Remarks

The EncodingCollection is modified in place.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.Sort Method

Sorts the Encodings in this EncodingCollection, using the given comparer.

new public EncodingCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Encodings.

Return Value

This EncodingCollection, modified such that the Encodings are sorted.

Remarks

The EncodingCollection is modified in place.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.SortByName Method

Sorts the Encodings in this EncodingCollection by name.

public EncodingCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This EncodingCollection, modified such that the Encodings are sorted by name.

Remarks

The EncodingCollection is modified in place.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection.Wrap Method

Creates an EncodingCollection to represent the given array of Encoding (from the com.borland.starteam.util namespace).

public static EncodingCollection Wrap(
Encoding[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new EncodingCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an Encoding[] from the com.borland.starteam.util namespace to the Borland.StarTeam.Util namespace.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection Type Conversions

The type conversions of the EncodingCollection class are listed below. For a complete list of EncodingCollection class members, see the EncodingCollection Members topic.

Public Static Type Conversions

Implicit EncodingCollection to Encoding[] Conversion | Converts an EncodingCollection to an array of Encodings.
Implicit EncodingCollection to Encoding[] Conversion | Converts an EncodingCollection from the Borland.StarTeam.Util namespace to an Encoding[] in the com.borland.starteam.util namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.util namespace.

See Also

EncodingCollection Class | EncodingCollection Members | Borland.StarTeam.Util Namespace


EncodingCollection Implicit EncodingCollection to Encoding[] Conversion

Converts an EncodingCollection to an array of Encodings.

public static implicit operator Encoding[](
EncodingCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Encoding wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Encoding wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EncodingCollection Implicit EncodingCollection to Encoding[] Conversion

Converts an EncodingCollection from the Borland.StarTeam.Util namespace to an Encoding[] in the com.borland.starteam.util namespace.

public static implicit operator Encoding[](
EncodingCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam.Util namespace to methods in the com.borland.starteam.util namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, EncodingCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

EncodingCollection Class | Borland.StarTeam.Util Namespace


EOLReader Class

For a list of all members of this type, see EOLReader Members.

System.Object
LineProcessor
EOLReader

public class EOLReader : LineProcessor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EOLReader Members | Borland.StarTeam.Util Namespace


EOLReader Members

EOLReader overview

Public Static Methods

Wrap Dynamically wraps com.starbase.util.EOLReader.

Public Static Type Conversions

Implicit EOLReader to EOLReader Conversion Implicitly convert EOLReader to com.starbase.util.EOLReader.

Public Instance Constructors

EOLReader Overloaded. Initializes a new instance of the EOLReader class.

Public Instance Methods

EndofInput (inherited from LineProcessor) |
Equals (inherited from LineProcessor) | Delegate Equals() to com.starbase.util.LineProcessor.
GetHashCode (inherited from LineProcessor) | Delegate GetHashCode() to com.starbase.util.LineProcessor.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLine (inherited from LineProcessor) |
ToString (inherited from LineProcessor) | Delegate ToString() to com.starbase.util.LineProcessor.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from LineProcessor) Implementation of IWrapper.Unwrap().

See Also

EOLReader Class | Borland.StarTeam.Util Namespace


EOLReader Constructor

Construct EOLReader from com.starbase.util.EOLReader.

Overload List

public EOLReader(LineReader,String);

Construct EOLReader from com.starbase.util.EOLReader.

public EOLReader(EOLReader);

See Also

EOLReader Class | Borland.StarTeam.Util Namespace


EOLReader Constructor (EOLReader)

Construct EOLReader from com.starbase.util.EOLReader.

public EOLReader(
EOLReader impl
);

Parameters

impl
The com.starbase.util.EOLReader to be wrapped.

See Also

EOLReader Class | Borland.StarTeam.Util Namespace | EOLReader Constructor Overload List


EOLReader Constructor (LineReader, String)

public EOLReader(
LineReader source,
String newEOL
);

See Also

EOLReader Class | Borland.StarTeam.Util Namespace | EOLReader Constructor Overload List


EOLReader Methods

The methods of the EOLReader class are listed below. For a complete list of EOLReader class members, see the EOLReader Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.util.EOLReader.

Public Instance Methods

EndofInput (inherited from LineProcessor) |
Equals (inherited from LineProcessor) | Delegate Equals() to com.starbase.util.LineProcessor.
GetHashCode (inherited from LineProcessor) | Delegate GetHashCode() to com.starbase.util.LineProcessor.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLine (inherited from LineProcessor) |
ToString (inherited from LineProcessor) | Delegate ToString() to com.starbase.util.LineProcessor.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from LineProcessor) Implementation of IWrapper.Unwrap().

See Also

EOLReader Class | Borland.StarTeam.Util Namespace


EOLReader.Wrap Method

Dynamically wraps com.starbase.util.EOLReader.

public static EOLReader Wrap(
EOLReader impl
);

Parameters

impl
com.starbase.util.EOLReader to be wrapped.

Return Value

EOLReader

See Also

EOLReader Class | Borland.StarTeam.Util Namespace


EOLReader Type Conversions

The type conversions of the EOLReader class are listed below. For a complete list of EOLReader class members, see the EOLReader Members topic.

Public Static Type Conversions

Implicit EOLReader to EOLReader Conversion Implicitly convert EOLReader to com.starbase.util.EOLReader.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from LineProcessor) Implementation of IWrapper.Unwrap().

See Also

EOLReader Class | EOLReader Members | Borland.StarTeam.Util Namespace


EOLReader Implicit EOLReader to EOLReader Conversion

Implicitly convert EOLReader to com.starbase.util.EOLReader.

public static implicit operator EOLReader(
EOLReader arg
);

Parameters

arg
EOLReader to convert.

Return Value

com.starbase.util.EOLReader

See Also

EOLReader Class | Borland.StarTeam.Util Namespace


FileUtils Class

Utility class for accessing file info.

For a list of all members of this type, see FileUtils Members.

System.Object
FileUtils

public class FileUtils : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileUtils Members | Borland.StarTeam.Util Namespace


FileUtils Members

FileUtils overview

Public Static Properties

MAX_FILE_LENGTH
MAX_FILE_LENGTH_80

Public Static Methods

Cmp |
CondenseFilePaths | Compares the two paths and returns a relative path that represents the childFolderPath relative to parentFolderPath or null if either of the paths passed in are already relative or invalid, or if childFolderPath cannot be expressed relative to parentFolderPath. Both c: and \folderName are invalid paths for the purposes of this function. GetCanonicalPathName is called on boths paths prior to comparison. This function is essentially Windows-specific, but should work correctly with at least Unix paths.
FullyResolvedPath |
GetAbsolutePath | Returns the absolute pathname of the given pathname. If the pathname is an absolute pathname, then return the pathname. Otherwise, return a pathname that is a concatenation of the current user directory, the separator character, and the pathname of this file object. The system property user.dir contains the current user directory.
GetCanonicalPathName |
GetFileLength | Gets the length of the given file.
GetFileLengthEx | Gets the length of the given file.
GetName | Returns the name of the file represented by this pathname. The name is everything in the pathame after the last occurrence of the separator character.
GetParent | Returns the parent part of the given pathname, or null if the name has no parent part. The parent part is generally everything leading up to the last occurrence of the separator character, although the precise definition is system dependent. On UNIX, for example, the parent part of "/usr/lib" is "/usr", whose parent part is "/", which in turn has no parent. On Windows platforms, the parent part of "c:\java" is "c:\", which in turn has no parent.
IsAbsolute | Tests if the given pathname is an absolute pathname. The definition of an absolute pathname is system dependent. For example, on UNIX, a pathname is absolute if its first character is the separator character. On Windows platforms, a pathname is absolute if its first character is an ASCII '\' or '/', or if it begins with a letter followed by a colon.
IsBinary | Returns true if the file is considered to be binary. The definition of binary is that the file has at least one null (0x0) character.
Match |
MatchesAnyPattern |
MatchPatternList |
ParsePatternList |

Public Static Type Conversions

Implicit FileUtils to FileUtils Conversion Implicitly convert FileUtils to com.starbase.util.FileUtils.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.FileUtils.
GetHashCode | Delegate GetHashCode() to com.starbase.util.FileUtils.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.FileUtils.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils Properties

The properties of the FileUtils class are listed below. For a complete list of FileUtils class members, see the FileUtils Members topic.

Public Static Properties

MAX_FILE_LENGTH
MAX_FILE_LENGTH_80

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


MAX_FILE_LENGTH Property

Borland StarTeam SDK for .NET

FileUtils.MAX_FILE_LENGTH Property

public static Int64 MAX_FILE_LENGTH {get;}

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


MAX_FILE_LENGTH_80 Property

Borland StarTeam SDK for .NET

FileUtils.MAX_FILE_LENGTH_80 Property

public static Int64 MAX_FILE_LENGTH_80 {get;}

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils Methods

The methods of the FileUtils class are listed below. For a complete list of FileUtils class members, see the FileUtils Members topic.

Public Static Methods

Cmp |
CondenseFilePaths | Compares the two paths and returns a relative path that represents the childFolderPath relative to parentFolderPath or null if either of the paths passed in are already relative or invalid, or if childFolderPath cannot be expressed relative to parentFolderPath. Both c: and \folderName are invalid paths for the purposes of this function. GetCanonicalPathName is called on boths paths prior to comparison. This function is essentially Windows-specific, but should work correctly with at least Unix paths.
FullyResolvedPath |
GetAbsolutePath | Returns the absolute pathname of the given pathname. If the pathname is an absolute pathname, then return the pathname. Otherwise, return a pathname that is a concatenation of the current user directory, the separator character, and the pathname of this file object. The system property user.dir contains the current user directory.
GetCanonicalPathName |
GetFileLength | Gets the length of the given file.
GetFileLengthEx | Gets the length of the given file.
GetName | Returns the name of the file represented by this pathname. The name is everything in the pathame after the last occurrence of the separator character.
GetParent | Returns the parent part of the given pathname, or null if the name has no parent part. The parent part is generally everything leading up to the last occurrence of the separator character, although the precise definition is system dependent. On UNIX, for example, the parent part of "/usr/lib" is "/usr", whose parent part is "/", which in turn has no parent. On Windows platforms, the parent part of "c:\java" is "c:\", which in turn has no parent.
IsAbsolute | Tests if the given pathname is an absolute pathname. The definition of an absolute pathname is system dependent. For example, on UNIX, a pathname is absolute if its first character is the separator character. On Windows platforms, a pathname is absolute if its first character is an ASCII '\' or '/', or if it begins with a letter followed by a colon.
IsBinary | Returns true if the file is considered to be binary. The definition of binary is that the file has at least one null (0x0) character.
Match |
MatchesAnyPattern |
MatchPatternList |
ParsePatternList |

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.FileUtils.
GetHashCode | Delegate GetHashCode() to com.starbase.util.FileUtils.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.FileUtils.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.FileUtils

Implements

IWrapper.Unwrap

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.Cmp Method

public static long Cmp(
FileInfo f1,
FileInfo f2
);

Parameters

f1
f2

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.CondenseFilePaths Method

Compares the two paths and returns a relative path that represents the childFolderPath relative to parentFolderPath or null if either of the paths passed in are already relative or invalid, or if childFolderPath cannot be expressed relative to parentFolderPath.

Both c: and \folderName are invalid paths for the purposes of this function. GetCanonicalPathName is called on boths paths prior to comparison. This function is essentially Windows-specific, but should work correctly with at least Unix paths.

public static string CondenseFilePaths(
String parentFolderPath,
String childFolderPath,
Boolean caseSensitive,
String delimiter
);

Parameters

parentFolderPath
childFolderPath
caseSensitive
delimiter

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.Equals Method

Delegate Equals() to com.starbase.util.FileUtils.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.FileUtils.Equals(obj).

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.FullyResolvedPath Method

public static string FullyResolvedPath(
String name,
String pathDelim
);

Parameters

name
pathDelim

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.GetAbsolutePath Method

Returns the absolute pathname of the given pathname. If the pathname is an absolute pathname, then return the pathname. Otherwise, return a pathname that is a concatenation of the current user directory, the separator character, and the pathname of this file object.

The system property user.dir contains the current user directory.

public static string GetAbsolutePath(
String path
);

Parameters

path
A pathname.

Return Value

a system-dependent absolute pathname.

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.GetCanonicalPathName Method

public static string GetCanonicalPathName(
String aPathName,
Boolean bCaseSensitive
);

Parameters

aPathName
bCaseSensitive

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.GetFileLength Method

Gets the length of the given file.

public static int GetFileLength(
FileInfo f
);

Parameters

f
A file whose length is to be determined.

Return Value

int The file length.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileUtils Class | Borland.StarTeam.Util Namespace | getFileLengthEx


FileUtils.GetFileLengthEx Method

Gets the length of the given file.

public static long GetFileLengthEx(
FileInfo f
);

Parameters

f
A file whose length is to be determined.

Return Value

long The file length.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.FileUtils.

public override int GetHashCode();

Return Value

com.starbase.util.FileUtils.GetHashCode().

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.GetName Method

Returns the name of the file represented by this pathname. The name is everything in the pathame after the last occurrence of the separator character.

public static string GetName(
String path,
String pathDelim
);

Parameters

path
A pathname.
pathDelim
The path delimiter.

Return Value

the name of the file (without any directory components) represented by this pathname.

See Also

FileUtils Class | Borland.StarTeam.Util Namespace | getParent


FileUtils.GetParent Method

Returns the parent part of the given pathname, or null if the name has no parent part. The parent part is generally everything leading up to the last occurrence of the separator character, although the precise definition is system dependent. On UNIX, for example, the parent part of "/usr/lib" is "/usr", whose parent part is "/", which in turn has no parent. On Windows platforms, the parent part of "c:\java" is "c:\", which in turn has no parent.

public static string GetParent(
String path,
String pathDelim
);

Parameters

path
A pathname.
pathDelim
The path delimiter.

Return Value

The parent part of the pathname, or null if the name has no parent part.

See Also

FileUtils Class | Borland.StarTeam.Util Namespace | getName


FileUtils.IsAbsolute Method

Tests if the given pathname is an absolute pathname. The definition of an absolute pathname is system dependent. For example, on UNIX, a pathname is absolute if its first character is the separator character. On Windows platforms, a pathname is absolute if its first character is an ASCII '\' or '/', or if it begins with a letter followed by a colon.

public static bool IsAbsolute(
String path
);

Parameters

path
A pathname.

Return Value

true if the pathname indicated by the File object is an absolute pathname; false otherwise.

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.IsBinary Method

Returns true if the file is considered to be binary. The definition of binary is that the file has at least one null (0x0) character.

public static bool IsBinary(
FileInfo f
);

Parameters

f

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.Match Method

public static bool Match(
String pattern,
String file,
Boolean caseSensitive
);

Parameters

pattern
file
caseSensitive

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.MatchesAnyPattern Method

public static bool MatchesAnyPattern(
String filename,
String[] patterns,
Boolean caseSensitive
);

Parameters

filename
patterns
caseSensitive

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.MatchPatternList Method

public static bool MatchPatternList(
String filename,
String patternList,
Boolean caseSensitive
);

Parameters

filename
patternList
caseSensitive

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.ParsePatternList Method

public static string[] ParsePatternList(
String patternList
);

Parameters

patternList

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils.ToString Method

Delegate ToString() to com.starbase.util.FileUtils.

public override string ToString();

Return Value

com.starbase.util.FileUtils.ToString()

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


FileUtils Type Conversions

The type conversions of the FileUtils class are listed below. For a complete list of FileUtils class members, see the FileUtils Members topic.

Public Static Type Conversions

Implicit FileUtils to FileUtils Conversion Implicitly convert FileUtils to com.starbase.util.FileUtils.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileUtils Class | FileUtils Members | Borland.StarTeam.Util Namespace


FileUtils Implicit FileUtils to FileUtils Conversion

Implicitly convert FileUtils to com.starbase.util.FileUtils.

public static implicit operator FileUtils(
FileUtils arg
);

Parameters

arg
FileUtils to convert.

Return Value

com.starbase.util.FileUtils

See Also

FileUtils Class | Borland.StarTeam.Util Namespace


GUID Class

For a list of all members of this type, see GUID Members.

System.Object
GUID

public class GUID : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

GUID Members | Borland.StarTeam.Util Namespace


GUID Members

GUID overview

Public Static Methods

Wrap Dynamically wraps com.starbase.util.GUID.

Public Static Type Conversions

Implicit GUID to GUID Conversion Implicitly convert GUID to com.starbase.util.GUID.

Public Instance Constructors

GUID Overloaded. Initializes a new instance of the GUID class.

Public Instance Properties

ByteString | [read]
CanonicalFormat | [read]
Data | [read]
DebugString | [read]

Public Instance Methods

Create |
Equals | Delegate Equals() to com.starbase.util.GUID.
GetHashCode | Delegate GetHashCode() to com.starbase.util.GUID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.GUID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GUID Class | Borland.StarTeam.Util Namespace


GUID Constructor

Construct GUID from com.starbase.util.GUID.

Overload List

Initializes a new instance of the GUID class.

public GUID();

Construct GUID from com.starbase.util.GUID.

public GUID(GUID);

public GUID(Byte[]);

public GUID(String);

See Also

GUID Class | Borland.StarTeam.Util Namespace


GUID Constructor (GUID)

Construct GUID from com.starbase.util.GUID.

public GUID(
GUID impl
);

Parameters

impl
The com.starbase.util.GUID to be wrapped.

See Also

GUID Class | Borland.StarTeam.Util Namespace | GUID Constructor Overload List


GUID Constructor ()

Initializes a new instance of the GUID class.

public GUID();

See Also

GUID Class | Borland.StarTeam.Util Namespace | GUID Constructor Overload List


GUID Constructor (Byte[])

public GUID(
Byte[] source
);

Parameters

source

See Also

GUID Class | Borland.StarTeam.Util Namespace | GUID Constructor Overload List


GUID Constructor (String)

public GUID(
String spec
);

Parameters

spec

See Also

GUID Class | Borland.StarTeam.Util Namespace | GUID Constructor Overload List


GUID Properties

The properties of the GUID class are listed below. For a complete list of GUID class members, see the GUID Members topic.

Public Instance Properties

ByteString | [read]
CanonicalFormat | [read]
Data | [read]
DebugString | [read]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GUID Class | Borland.StarTeam.Util Namespace


ByteString Property

Borland StarTeam SDK for .NET

GUID.ByteString Property

[read]

public virtual String ByteString {get;}

See Also

GUID Class | Borland.StarTeam.Util Namespace


CanonicalFormat Property

Borland StarTeam SDK for .NET

GUID.CanonicalFormat Property

[read]

public virtual String CanonicalFormat {get;}

See Also

GUID Class | Borland.StarTeam.Util Namespace


Data Property

Borland StarTeam SDK for .NET

GUID.Data Property

[read]

public virtual Byte[] Data {get;}

See Also

GUID Class | Borland.StarTeam.Util Namespace


DebugString Property

Borland StarTeam SDK for .NET

GUID.DebugString Property

[read]

public virtual String DebugString {get;}

See Also

GUID Class | Borland.StarTeam.Util Namespace


GUID Methods

The methods of the GUID class are listed below. For a complete list of GUID class members, see the GUID Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.util.GUID.

Public Instance Methods

Create |
Equals | Delegate Equals() to com.starbase.util.GUID.
GetHashCode | Delegate GetHashCode() to com.starbase.util.GUID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.GUID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GUID Class | Borland.StarTeam.Util Namespace


GUID.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.GUID

Implements

IWrapper.Unwrap

See Also

GUID Class | Borland.StarTeam.Util Namespace


GUID.Create Method

public virtual void Create();

See Also

GUID Class | Borland.StarTeam.Util Namespace


GUID.Equals Method

Delegate Equals() to com.starbase.util.GUID.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.GUID.Equals(obj).

See Also

GUID Class | Borland.StarTeam.Util Namespace


GUID.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.GUID.

public override int GetHashCode();

Return Value

com.starbase.util.GUID.GetHashCode().

See Also

GUID Class | Borland.StarTeam.Util Namespace


GUID.ToString Method

Delegate ToString() to com.starbase.util.GUID.

public override string ToString();

Return Value

com.starbase.util.GUID.ToString()

See Also

GUID Class | Borland.StarTeam.Util Namespace


GUID.Wrap Method

Dynamically wraps com.starbase.util.GUID.

public static GUID Wrap(
GUID impl
);

Parameters

impl
com.starbase.util.GUID to be wrapped.

Return Value

GUID

See Also

GUID Class | Borland.StarTeam.Util Namespace


GUID Type Conversions

The type conversions of the GUID class are listed below. For a complete list of GUID class members, see the GUID Members topic.

Public Static Type Conversions

Implicit GUID to GUID Conversion Implicitly convert GUID to com.starbase.util.GUID.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

GUID Class | GUID Members | Borland.StarTeam.Util Namespace


GUID Implicit GUID to GUID Conversion

Implicitly convert GUID to com.starbase.util.GUID.

public static implicit operator GUID(
GUID arg
);

Parameters

arg
GUID to convert.

Return Value

com.starbase.util.GUID

See Also

GUID Class | Borland.StarTeam.Util Namespace


ISO8601 Class

A utility class for encoding and parsing ISO8601 date/time format strings. The following sites have more information:

W3C NOTE - Date and Time Formated

Appendix 2 of the WebDAV specification.

Discussion by Markus Kuhn

For a list of all members of this type, see ISO8601 Members.

System.Object
ISO8601

public class ISO8601 : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ISO8601 Members | Borland.StarTeam.Util Namespace


ISO8601 Members

ISO8601 overview

Public Static Methods

Parse Parses the provided IS08601 formated string abd returns the corresponding Java time. Some example formats:
  • 1999-06-17T16:43:07.982Z
  • 1999-06-17T16:43:07Z
  • 1999-06-17T16:43:07.982+02:00
ToGMTString | Returns the ISO8601 date/time format for the specified time. E.g: "1999-06-17T16:43:07.982Z"
ToLocalString | Returns the ISO8601 date/time string for the specified Java time with respect to the local timezone.

Public Static Type Conversions

Implicit ISO8601 to ISO8601 Conversion Implicitly convert ISO8601 to com.starbase.util.ISO8601.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.ISO8601.
GetHashCode | Delegate GetHashCode() to com.starbase.util.ISO8601.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.ISO8601.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ISO8601 Class | Borland.StarTeam.Util Namespace


ISO8601 Methods

The methods of the ISO8601 class are listed below. For a complete list of ISO8601 class members, see the ISO8601 Members topic.

Public Static Methods

Parse Parses the provided IS08601 formated string abd returns the corresponding Java time. Some example formats:
  • 1999-06-17T16:43:07.982Z
  • 1999-06-17T16:43:07Z
  • 1999-06-17T16:43:07.982+02:00
ToGMTString | Returns the ISO8601 date/time format for the specified time. E.g: "1999-06-17T16:43:07.982Z"
ToLocalString | Returns the ISO8601 date/time string for the specified Java time with respect to the local timezone.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.ISO8601.
GetHashCode | Delegate GetHashCode() to com.starbase.util.ISO8601.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.ISO8601.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ISO8601 Class | Borland.StarTeam.Util Namespace


ISO8601.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.ISO8601

Implements

IWrapper.Unwrap

See Also

ISO8601 Class | Borland.StarTeam.Util Namespace


ISO8601.Equals Method

Delegate Equals() to com.starbase.util.ISO8601.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.ISO8601.Equals(obj).

See Also

ISO8601 Class | Borland.StarTeam.Util Namespace


ISO8601.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.ISO8601.

public override int GetHashCode();

Return Value

com.starbase.util.ISO8601.GetHashCode().

See Also

ISO8601 Class | Borland.StarTeam.Util Namespace


ISO8601.Parse Method

Parses the provided IS08601 formated string abd returns the corresponding Java time. Some example formats:

  • 1999-06-17T16:43:07.982Z
  • 1999-06-17T16:43:07Z
  • 1999-06-17T16:43:07.982+02:00

public static long Parse(
String spec
);

Parameters

spec
the IS08601 date/time specification string

Return Value

the Java time value represented by the specified format string

See Also

ISO8601 Class | Borland.StarTeam.Util Namespace


ISO8601.ToGMTString Method

Returns the ISO8601 date/time format for the specified time. E.g: "1999-06-17T16:43:07.982Z"

public static string ToGMTString(
Int64 time
);

Parameters

time
the Java time value to represent as a String

Return Value

the IS08601 time format for the specified time

See Also

ISO8601 Class | Borland.StarTeam.Util Namespace


ISO8601.ToLocalString Method

Returns the ISO8601 date/time string for the specified Java time with respect to the local timezone.

public static string ToLocalString(
Int64 time
);

Parameters

time
Java time value to represent as a string

Return Value

the IS08601 time format for the specified time

See Also

ISO8601 Class | Borland.StarTeam.Util Namespace


ISO8601.ToString Method

Delegate ToString() to com.starbase.util.ISO8601.

public override string ToString();

Return Value

com.starbase.util.ISO8601.ToString()

See Also

ISO8601 Class | Borland.StarTeam.Util Namespace


ISO8601 Type Conversions

The type conversions of the ISO8601 class are listed below. For a complete list of ISO8601 class members, see the ISO8601 Members topic.

Public Static Type Conversions

Implicit ISO8601 to ISO8601 Conversion Implicitly convert ISO8601 to com.starbase.util.ISO8601.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ISO8601 Class | ISO8601 Members | Borland.StarTeam.Util Namespace


ISO8601 Implicit ISO8601 to ISO8601 Conversion

Implicitly convert ISO8601 to com.starbase.util.ISO8601.

public static implicit operator ISO8601(
ISO8601 arg
);

Parameters

arg
ISO8601 to convert.

Return Value

com.starbase.util.ISO8601

See Also

ISO8601 Class | Borland.StarTeam.Util Namespace


LineProcessor Class

For a list of all members of this type, see LineProcessor Members.

System.Object
LineProcessor
KeywordReader
EOLReader

public class LineProcessor : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LineProcessor Members | Borland.StarTeam.Util Namespace


LineProcessor Members

LineProcessor overview

Public Static Methods

Wrap Dynamically wraps com.starbase.util.LineProcessor.

Public Static Type Conversions

Implicit LineProcessor to LineProcessor Conversion Implicitly convert LineProcessor to com.starbase.util.LineProcessor.

Public Instance Constructors

LineProcessor Constructor Construct LineProcessor from com.starbase.util.LineProcessor.

Public Instance Methods

EndofInput |
Equals | Delegate Equals() to com.starbase.util.LineProcessor.
GetHashCode | Delegate GetHashCode() to com.starbase.util.LineProcessor.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLine |
ToString | Delegate ToString() to com.starbase.util.LineProcessor.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LineProcessor Class | Borland.StarTeam.Util Namespace


LineProcessor Constructor

Construct LineProcessor from com.starbase.util.LineProcessor.

public LineProcessor(
LineProcessor impl
);

Parameters

impl
The com.starbase.util.LineProcessor to be wrapped.

See Also

LineProcessor Class | Borland.StarTeam.Util Namespace


LineProcessor Methods

The methods of the LineProcessor class are listed below. For a complete list of LineProcessor class members, see the LineProcessor Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.util.LineProcessor.

Public Instance Methods

EndofInput |
Equals | Delegate Equals() to com.starbase.util.LineProcessor.
GetHashCode | Delegate GetHashCode() to com.starbase.util.LineProcessor.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLine |
ToString | Delegate ToString() to com.starbase.util.LineProcessor.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LineProcessor Class | Borland.StarTeam.Util Namespace


LineProcessor.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.LineProcessor

Implements

IWrapper.Unwrap

See Also

LineProcessor Class | Borland.StarTeam.Util Namespace


LineProcessor.EndofInput Method

public virtual TextReader EndofInput();

See Also

LineProcessor Class | Borland.StarTeam.Util Namespace


LineProcessor.Equals Method

Delegate Equals() to com.starbase.util.LineProcessor.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.LineProcessor.Equals(obj).

See Also

LineProcessor Class | Borland.StarTeam.Util Namespace


LineProcessor.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.LineProcessor.

public override int GetHashCode();

Return Value

com.starbase.util.LineProcessor.GetHashCode().

See Also

LineProcessor Class | Borland.StarTeam.Util Namespace


LineProcessor.ProcessLine Method

public virtual TextReader ProcessLine(
String line,
Int32 eol
);

See Also

LineProcessor Class | Borland.StarTeam.Util Namespace


LineProcessor.ToString Method

Delegate ToString() to com.starbase.util.LineProcessor.

public override string ToString();

Return Value

com.starbase.util.LineProcessor.ToString()

See Also

LineProcessor Class | Borland.StarTeam.Util Namespace


LineProcessor.Wrap Method

Dynamically wraps com.starbase.util.LineProcessor.

public static LineProcessor Wrap(
LineProcessor impl
);

Parameters

impl
com.starbase.util.LineProcessor to be wrapped.

Return Value

LineProcessor

See Also

LineProcessor Class | Borland.StarTeam.Util Namespace


LineProcessor Type Conversions

The type conversions of the LineProcessor class are listed below. For a complete list of LineProcessor class members, see the LineProcessor Members topic.

Public Static Type Conversions

Implicit LineProcessor to LineProcessor Conversion Implicitly convert LineProcessor to com.starbase.util.LineProcessor.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LineProcessor Class | LineProcessor Members | Borland.StarTeam.Util Namespace


LineProcessor Implicit LineProcessor to LineProcessor Conversion

Implicitly convert LineProcessor to com.starbase.util.LineProcessor.

public static implicit operator LineProcessor(
LineProcessor arg
);

Parameters

arg
LineProcessor to convert.

Return Value

com.starbase.util.LineProcessor

See Also

LineProcessor Class | Borland.StarTeam.Util Namespace


LineReader Class

For a list of all members of this type, see LineReader Members.

System.Object
LineReader

public class LineReader : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LineReader Members | Borland.StarTeam.Util Namespace


LineReader Members

LineReader overview

Public Static Properties

EOL_CR
EOL_CRLF
EOL_EOF
EOL_LF
EOL_UNKNOWN

Public Static Methods

Wrap Dynamically wraps com.starbase.util.LineReader.

Public Static Type Conversions

Implicit LineReader to LineReader Conversion Implicitly convert LineReader to com.starbase.util.LineReader.

Public Instance Constructors

LineReader Overloaded. Initializes a new instance of the LineReader class.

Public Instance Properties

LastEOL

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.LineReader.
GetHashCode | Delegate GetHashCode() to com.starbase.util.LineReader.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadLine |
ToString | Delegate ToString() to com.starbase.util.LineReader.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LineReader Class | Borland.StarTeam.Util Namespace


LineReader Constructor

Construct LineReader from com.starbase.util.LineReader.

Overload List

Construct LineReader from com.starbase.util.LineReader.

public LineReader(LineReader);

public LineReader(TextReader);

public LineReader(TextReader,Int32);

See Also

LineReader Class | Borland.StarTeam.Util Namespace


LineReader Constructor (LineReader)

Construct LineReader from com.starbase.util.LineReader.

public LineReader(
LineReader impl
);

Parameters

impl
The com.starbase.util.LineReader to be wrapped.

See Also

LineReader Class | Borland.StarTeam.Util Namespace | LineReader Constructor Overload List


LineReader Constructor (TextReader, Int32)

public LineReader(
TextReader _in,
Int32 sz
);

See Also

LineReader Class | Borland.StarTeam.Util Namespace | LineReader Constructor Overload List


LineReader Constructor (TextReader)

public LineReader(
TextReader _in
);

See Also

LineReader Class | Borland.StarTeam.Util Namespace | LineReader Constructor Overload List


LineReader Properties

The properties of the LineReader class are listed below. For a complete list of LineReader class members, see the LineReader Members topic.

Public Static Properties

EOL_CR
EOL_CRLF
EOL_EOF
EOL_LF
EOL_UNKNOWN

Public Instance Properties

LastEOL

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LineReader Class | Borland.StarTeam.Util Namespace


EOL_CR Property

Borland StarTeam SDK for .NET

LineReader.EOL_CR Property

public static Int32 EOL_CR {get;}

See Also

LineReader Class | Borland.StarTeam.Util Namespace


EOL_CRLF Property

Borland StarTeam SDK for .NET

LineReader.EOL_CRLF Property

public static Int32 EOL_CRLF {get;}

See Also

LineReader Class | Borland.StarTeam.Util Namespace


EOL_EOF Property

Borland StarTeam SDK for .NET

LineReader.EOL_EOF Property

public static Int32 EOL_EOF {get;}

See Also

LineReader Class | Borland.StarTeam.Util Namespace


EOL_LF Property

Borland StarTeam SDK for .NET

LineReader.EOL_LF Property

public static Int32 EOL_LF {get;}

See Also

LineReader Class | Borland.StarTeam.Util Namespace


EOL_UNKNOWN Property

Borland StarTeam SDK for .NET

LineReader.EOL_UNKNOWN Property

public static Int32 EOL_UNKNOWN {get;}

See Also

LineReader Class | Borland.StarTeam.Util Namespace


LastEOL Property

Borland StarTeam SDK for .NET

LineReader.LastEOL Property

public virtual Int32 LastEOL {get;}

See Also

LineReader Class | Borland.StarTeam.Util Namespace


LineReader Methods

The methods of the LineReader class are listed below. For a complete list of LineReader class members, see the LineReader Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.util.LineReader.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.LineReader.
GetHashCode | Delegate GetHashCode() to com.starbase.util.LineReader.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadLine |
ToString | Delegate ToString() to com.starbase.util.LineReader.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LineReader Class | Borland.StarTeam.Util Namespace


LineReader.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.LineReader

Implements

IWrapper.Unwrap

See Also

LineReader Class | Borland.StarTeam.Util Namespace


LineReader.Equals Method

Delegate Equals() to com.starbase.util.LineReader.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.LineReader.Equals(obj).

See Also

LineReader Class | Borland.StarTeam.Util Namespace


LineReader.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.LineReader.

public override int GetHashCode();

Return Value

com.starbase.util.LineReader.GetHashCode().

See Also

LineReader Class | Borland.StarTeam.Util Namespace


LineReader.ReadLine Method

public virtual string ReadLine();

See Also

LineReader Class | Borland.StarTeam.Util Namespace


LineReader.ToString Method

Delegate ToString() to com.starbase.util.LineReader.

public override string ToString();

Return Value

com.starbase.util.LineReader.ToString()

See Also

LineReader Class | Borland.StarTeam.Util Namespace


LineReader.Wrap Method

Dynamically wraps com.starbase.util.LineReader.

public static LineReader Wrap(
LineReader impl
);

Parameters

impl
com.starbase.util.LineReader to be wrapped.

Return Value

LineReader

See Also

LineReader Class | Borland.StarTeam.Util Namespace


LineReader Type Conversions

The type conversions of the LineReader class are listed below. For a complete list of LineReader class members, see the LineReader Members topic.

Public Static Type Conversions

Implicit LineReader to LineReader Conversion Implicitly convert LineReader to com.starbase.util.LineReader.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

LineReader Class | LineReader Members | Borland.StarTeam.Util Namespace


LineReader Implicit LineReader to LineReader Conversion

Implicitly convert LineReader to com.starbase.util.LineReader.

public static implicit operator LineReader(
LineReader arg
);

Parameters

arg
LineReader to convert.

Return Value

com.starbase.util.LineReader

See Also

LineReader Class | Borland.StarTeam.Util Namespace


MD5 Class

For a list of all members of this type, see MD5 Members.

System.Object
MD5

public class MD5 : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MD5 Members | Borland.StarTeam.Util Namespace


MD5 Members

MD5 overview

Public Static Methods

Wrap Dynamically wraps com.starbase.util.MD5.

Public Static Type Conversions

Implicit MD5 to MD5 Conversion Implicitly convert MD5 to com.starbase.util.MD5.

Public Instance Constructors

MD5 Overloaded. Initializes a new instance of the MD5 class.

Public Instance Properties

Data [read/write]

Public Instance Methods

ComputeBufferMD5 | Compute MD5 for a byte array.
ComputeFileMD5 | Computes the MD5 of the given file.
ComputeFileMD5Ex | Computes the MD5 of the given file.
ComputeStreamMD5 | Computes the MD5 of the given input stream.
ComputeStreamMD5Ex | Computes the MD5 of the given input stream.
Equals | Delegate Equals() to com.starbase.util.MD5.
GetHashCode | Delegate GetHashCode() to com.starbase.util.MD5.
GetType (inherited from Object) | Gets the Type of the current instance.
ToHexString | Return the a 32-character String equal to the hex equivalent of this MD5 value.
ToString | Delegate ToString() to com.starbase.util.MD5.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5 Constructor

Construct MD5 from com.starbase.util.MD5.

Overload List

Initializes a new instance of the MD5 class.

public MD5();

public MD5(MD5);

Construct MD5 from com.starbase.util.MD5.

public MD5(MD5);

public MD5(Byte[]);

Construct a new MD5 with the given String value.

public MD5(String);

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5 Constructor (MD5)

Construct MD5 from com.starbase.util.MD5.

public MD5(
MD5 impl
);

Parameters

impl
The com.starbase.util.MD5 to be wrapped.

See Also

MD5 Class | Borland.StarTeam.Util Namespace | MD5 Constructor Overload List


MD5 Constructor (String)

Construct a new MD5 with the given String value.

public MD5(
String stringMD5
);

Parameters

stringMD5
A 32-character hex value of an MD5 value.

See Also

MD5 Class | Borland.StarTeam.Util Namespace | MD5 Constructor Overload List


MD5 Constructor ()

Initializes a new instance of the MD5 class.

public MD5();

See Also

MD5 Class | Borland.StarTeam.Util Namespace | MD5 Constructor Overload List


MD5 Constructor (Byte[])

public MD5(
Byte[] aSourceBytes
);

Parameters

aSourceBytes

See Also

MD5 Class | Borland.StarTeam.Util Namespace | MD5 Constructor Overload List


MD5 Constructor (MD5)

public MD5(
MD5 aMD5
);

Parameters

aMD5

See Also

MD5 Class | Borland.StarTeam.Util Namespace | MD5 Constructor Overload List


MD5 Properties

The properties of the MD5 class are listed below. For a complete list of MD5 class members, see the MD5 Members topic.

Public Instance Properties

Data [read/write]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MD5 Class | Borland.StarTeam.Util Namespace


Data Property

Borland StarTeam SDK for .NET

MD5.Data Property

[read/write]

public virtual Byte[] Data {get; set;}

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5 Methods

The methods of the MD5 class are listed below. For a complete list of MD5 class members, see the MD5 Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.util.MD5.

Public Instance Methods

ComputeBufferMD5 | Compute MD5 for a byte array.
ComputeFileMD5 | Computes the MD5 of the given file.
ComputeFileMD5Ex | Computes the MD5 of the given file.
ComputeStreamMD5 | Computes the MD5 of the given input stream.
ComputeStreamMD5Ex | Computes the MD5 of the given input stream.
Equals | Delegate Equals() to com.starbase.util.MD5.
GetHashCode | Delegate GetHashCode() to com.starbase.util.MD5.
GetType (inherited from Object) | Gets the Type of the current instance.
ToHexString | Return the a 32-character String equal to the hex equivalent of this MD5 value.
ToString | Delegate ToString() to com.starbase.util.MD5.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.MD5

Implements

IWrapper.Unwrap

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5.ComputeBufferMD5 Method

Compute MD5 for a byte array.

public virtual void ComputeBufferMD5(
Byte[] data
);

Parameters

data

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5.ComputeFileMD5 Method

Computes the MD5 of the given file.

public virtual int ComputeFileMD5(
FileInfo file
);

Parameters

file
The input file.

Return Value

The file size.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

MD5 Class | Borland.StarTeam.Util Namespace | computeFileMD5Ex


MD5.ComputeFileMD5Ex Method

Computes the MD5 of the given file.

public virtual long ComputeFileMD5Ex(
FileInfo file
);

Parameters

file
The input file.

Return Value

The file size.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5.ComputeStreamMD5 Method

Computes the MD5 of the given input stream.

public virtual int ComputeStreamMD5(
Stream _in
);

Parameters

_in

Return Value

The file size.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

MD5 Class | Borland.StarTeam.Util Namespace | computeStreamMD5Ex


MD5.ComputeStreamMD5Ex Method

Computes the MD5 of the given input stream.

public virtual long ComputeStreamMD5Ex(
Stream _in
);

Parameters

_in

Return Value

The file size.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5.Equals Method

Delegate Equals() to com.starbase.util.MD5.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.MD5.Equals(obj).

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.MD5.

public override int GetHashCode();

Return Value

com.starbase.util.MD5.GetHashCode().

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5.ToHexString Method

Return the a 32-character String equal to the hex equivalent of this MD5 value.

public virtual string ToHexString();

Return Value

A 32-character String equal to the hex equivalent of this MD5 value.

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5.ToString Method

Delegate ToString() to com.starbase.util.MD5.

public override string ToString();

Return Value

com.starbase.util.MD5.ToString()

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5.Wrap Method

Dynamically wraps com.starbase.util.MD5.

public static MD5 Wrap(
MD5 impl
);

Parameters

impl
com.starbase.util.MD5 to be wrapped.

Return Value

MD5

See Also

MD5 Class | Borland.StarTeam.Util Namespace


MD5 Type Conversions

The type conversions of the MD5 class are listed below. For a complete list of MD5 class members, see the MD5 Members topic.

Public Static Type Conversions

Implicit MD5 to MD5 Conversion Implicitly convert MD5 to com.starbase.util.MD5.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MD5 Class | MD5 Members | Borland.StarTeam.Util Namespace


MD5 Implicit MD5 to MD5 Conversion

Implicitly convert MD5 to com.starbase.util.MD5.

public static implicit operator MD5(
MD5 arg
);

Parameters

arg
MD5 to convert.

Return Value

com.starbase.util.MD5

See Also

MD5 Class | Borland.StarTeam.Util Namespace


OLEDateAdapter Class

For a list of all members of this type, see OLEDateAdapter Members.

System.Object
OLEDateAdapter

public class OLEDateAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

OLEDateAdapter Members | Borland.StarTeam.Util Namespace


OLEDateAdapter Members

OLEDateAdapter overview

Public Static Fields

CURRENT_SERVER_TIME

Public Static Type Conversions

Implicit OLEDateAdapter to OLEDate Conversion
Implicit OLEDateAdapter to DateTime Conversion

Public Instance Constructors

OLEDateAdapter Overloaded. Initializes a new instance of the OLEDateAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

OLEDateAdapter Class | Borland.StarTeam.Util Namespace


OLEDateAdapter Constructor

Overload List

public OLEDateAdapter(OLEDate);

public OLEDateAdapter(DateTime);

See Also

OLEDateAdapter Class | Borland.StarTeam.Util Namespace


OLEDateAdapter Constructor (OLEDate)

public OLEDateAdapter(
OLEDate impl
);

See Also

OLEDateAdapter Class | Borland.StarTeam.Util Namespace | OLEDateAdapter Constructor Overload List


OLEDateAdapter Constructor (DateTime)

public OLEDateAdapter(
DateTime impl
);

See Also

OLEDateAdapter Class | Borland.StarTeam.Util Namespace | OLEDateAdapter Constructor Overload List


OLEDateAdapter Fields

The fields of the OLEDateAdapter class are listed below. For a complete list of OLEDateAdapter class members, see the OLEDateAdapter Members topic.

Public Static Fields

CURRENT_SERVER_TIME

See Also

OLEDateAdapter Class | Borland.StarTeam.Util Namespace


OLEDateAdapter.CURRENT_SERVER_TIME Field

public static DateTime CURRENT_SERVER_TIME;

See Also

OLEDateAdapter Class | Borland.StarTeam.Util Namespace


OLEDateAdapter Type Conversions

The type conversions of the OLEDateAdapter class are listed below. For a complete list of OLEDateAdapter class members, see the OLEDateAdapter Members topic.

Public Static Type Conversions

Implicit OLEDateAdapter to OLEDate Conversion
Implicit OLEDateAdapter to DateTime Conversion

See Also

OLEDateAdapter Class | OLEDateAdapter Members | Borland.StarTeam.Util Namespace


OLEDateAdapter Implicit OLEDateAdapter to OLEDate Conversion

public static implicit operator OLEDate(
OLEDateAdapter arg
);

See Also

OLEDateAdapter Class | Borland.StarTeam.Util Namespace


OLEDateAdapter Implicit OLEDateAdapter to DateTime Conversion

public static implicit operator DateTime(
OLEDateAdapter arg
);

See Also

OLEDateAdapter Class | Borland.StarTeam.Util Namespace


OSEnvironment Class

Support for reading environment varaibles from the OS.

For a list of all members of this type, see OSEnvironment Members.

System.Object
OSEnvironment

public class OSEnvironment : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

OSEnvironment Members | Borland.StarTeam.Util Namespace


OSEnvironment Members

OSEnvironment overview

Public Static Properties

IsAvailable [read] true if calls to getEnvironmentVariable will be valid.

Public Static Methods

GetEnvironmentVariable Returns a value of the specified environment variable. Calls to this method are only valid if isAvailable returns true.

Public Static Type Conversions

Implicit OSEnvironment to OSEnvironment Conversion Implicitly convert OSEnvironment to com.starbase.util.OSEnvironment.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.OSEnvironment.
GetHashCode | Delegate GetHashCode() to com.starbase.util.OSEnvironment.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.OSEnvironment.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

OSEnvironment Class | Borland.StarTeam.Util Namespace


OSEnvironment Properties

The properties of the OSEnvironment class are listed below. For a complete list of OSEnvironment class members, see the OSEnvironment Members topic.

Public Static Properties

IsAvailable [read] true if calls to getEnvironmentVariable will be valid.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

OSEnvironment Class | Borland.StarTeam.Util Namespace


IsAvailable Property

Borland StarTeam SDK for .NET

OSEnvironment.IsAvailable Property

[read] true if calls to getEnvironmentVariable will be valid.

public static Boolean IsAvailable {get;}

Property Value

true if calls to getEnvironmentVariable will be valid.

See Also

OSEnvironment Class | Borland.StarTeam.Util Namespace


OSEnvironment Methods

The methods of the OSEnvironment class are listed below. For a complete list of OSEnvironment class members, see the OSEnvironment Members topic.

Public Static Methods

GetEnvironmentVariable Returns a value of the specified environment variable. Calls to this method are only valid if isAvailable returns true.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.OSEnvironment.
GetHashCode | Delegate GetHashCode() to com.starbase.util.OSEnvironment.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.OSEnvironment.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

OSEnvironment Class | Borland.StarTeam.Util Namespace


OSEnvironment.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.OSEnvironment

Implements

IWrapper.Unwrap

See Also

OSEnvironment Class | Borland.StarTeam.Util Namespace


OSEnvironment.Equals Method

Delegate Equals() to com.starbase.util.OSEnvironment.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.OSEnvironment.Equals(obj).

See Also

OSEnvironment Class | Borland.StarTeam.Util Namespace


OSEnvironment.GetEnvironmentVariable Method

Returns a value of the specified environment variable. Calls to this method are only valid if isAvailable returns true.

public static string GetEnvironmentVariable(
String varName
);

Parameters

varName
name of the environment variable to lookup.

Return Value

the value of the variable if set, null otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

OSEnvironment Class | Borland.StarTeam.Util Namespace | isAvailable


OSEnvironment.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.OSEnvironment.

public override int GetHashCode();

Return Value

com.starbase.util.OSEnvironment.GetHashCode().

See Also

OSEnvironment Class | Borland.StarTeam.Util Namespace


OSEnvironment.ToString Method

Delegate ToString() to com.starbase.util.OSEnvironment.

public override string ToString();

Return Value

com.starbase.util.OSEnvironment.ToString()

See Also

OSEnvironment Class | Borland.StarTeam.Util Namespace


OSEnvironment Type Conversions

The type conversions of the OSEnvironment class are listed below. For a complete list of OSEnvironment class members, see the OSEnvironment Members topic.

Public Static Type Conversions

Implicit OSEnvironment to OSEnvironment Conversion Implicitly convert OSEnvironment to com.starbase.util.OSEnvironment.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

OSEnvironment Class | OSEnvironment Members | Borland.StarTeam.Util Namespace


OSEnvironment Implicit OSEnvironment to OSEnvironment Conversion

Implicitly convert OSEnvironment to com.starbase.util.OSEnvironment.

public static implicit operator OSEnvironment(
OSEnvironment arg
);

Parameters

arg
OSEnvironment to convert.

Return Value

com.starbase.util.OSEnvironment

See Also

OSEnvironment Class | Borland.StarTeam.Util Namespace


Platform Class

The Platform class is where I collect all platform specific APIs for things like end-of-line character and file lastModified methods... At some point, parts of this may need to be implemented in native code

For a list of all members of this type, see Platform Members.

System.Object
Platform

public class Platform : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Platform Members | Borland.StarTeam.Util Namespace


Platform Members

Platform overview

Public Static Properties

CaseSensitiveFileNames | [read]
EOL | [read]
FilePathDelim | [read]
HostAddress | [read]
IsDotNET | [read] true if we are running in a .NET environment.
IsWin32 | [read] true if running under Win32.
MachineName | [read]
OSName | [read] A descriptive name for the operating system.
SetReadOnlyCmd | [read]
SetWritableCmd | [read]
TouchCmd | [read]
WorkStationID | [read]
WSOptions | [read]

Public Static Methods

GetFileExecutable |
GetFileLastModified | Overloaded. returns the last modified time for the given file via a native platform call
GetFileWritable |
GetLastModified | Overloaded. returns the last modified time for the given file via a native platform call
PrintProps |
SetFileExecutable |
SetFileLastModified |
SetFileWritable |

Public Static Type Conversions

Implicit Platform to Platform Conversion Implicitly convert Platform to com.starbase.util.Platform.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.Platform.
GetHashCode | Delegate GetHashCode() to com.starbase.util.Platform.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.Platform.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform Properties

The properties of the Platform class are listed below. For a complete list of Platform class members, see the Platform Members topic.

Public Static Properties

CaseSensitiveFileNames | [read]
EOL | [read]
FilePathDelim | [read]
HostAddress | [read]
IsDotNET | [read] true if we are running in a .NET environment.
IsWin32 | [read] true if running under Win32.
MachineName | [read]
OSName | [read] A descriptive name for the operating system.
SetReadOnlyCmd | [read]
SetWritableCmd | [read]
TouchCmd | [read]
WorkStationID | [read]
WSOptions | [read]

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Platform Class | Borland.StarTeam.Util Namespace


CaseSensitiveFileNames Property

Borland StarTeam SDK for .NET

Platform.CaseSensitiveFileNames Property

[read]

public static Boolean CaseSensitiveFileNames {get;}

See Also

Platform Class | Borland.StarTeam.Util Namespace


EOL Property

Borland StarTeam SDK for .NET

Platform.EOL Property

[read]

public static String EOL {get;}

See Also

Platform Class | Borland.StarTeam.Util Namespace


FilePathDelim Property

Borland StarTeam SDK for .NET

Platform.FilePathDelim Property

[read]

public static String FilePathDelim {get;}

See Also

Platform Class | Borland.StarTeam.Util Namespace


HostAddress Property

Borland StarTeam SDK for .NET

Platform.HostAddress Property

[read]

public static String HostAddress {get;}

See Also

Platform Class | Borland.StarTeam.Util Namespace


IsDotNET Property

Borland StarTeam SDK for .NET

Platform.IsDotNET Property

[read] true if we are running in a .NET environment.

public static Boolean IsDotNET {get;}

Property Value

true if we are running in a .NET environment.

See Also

Platform Class | Borland.StarTeam.Util Namespace


IsWin32 Property

Borland StarTeam SDK for .NET

Platform.IsWin32 Property

[read] true if running under Win32.

public static Boolean IsWin32 {get;}

Property Value

true if running under Win32.

See Also

Platform Class | Borland.StarTeam.Util Namespace


MachineName Property

Borland StarTeam SDK for .NET

Platform.MachineName Property

[read]

public static String MachineName {get;}

See Also

Platform Class | Borland.StarTeam.Util Namespace


OSName Property

Borland StarTeam SDK for .NET

Platform.OSName Property

[read] A descriptive name for the operating system.

public static String OSName {get;}

Property Value

A descriptive name for the operating system.

See Also

Platform Class | Borland.StarTeam.Util Namespace


SetReadOnlyCmd Property

Borland StarTeam SDK for .NET

Platform.SetReadOnlyCmd Property

[read]

public static String SetReadOnlyCmd {get;}

See Also

Platform Class | Borland.StarTeam.Util Namespace


SetWritableCmd Property

Borland StarTeam SDK for .NET

Platform.SetWritableCmd Property

[read]

public static String SetWritableCmd {get;}

See Also

Platform Class | Borland.StarTeam.Util Namespace


TouchCmd Property

Borland StarTeam SDK for .NET

Platform.TouchCmd Property

[read]

public static String TouchCmd {get;}

See Also

Platform Class | Borland.StarTeam.Util Namespace


WorkStationID Property

Borland StarTeam SDK for .NET

Platform.WorkStationID Property

[read]

public static GUID WorkStationID {get;}

See Also

Platform Class | Borland.StarTeam.Util Namespace


WSOptions Property

Borland StarTeam SDK for .NET

Platform.WSOptions Property

[read]

public static WorkStationOptions WSOptions {get;}

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform Methods

The methods of the Platform class are listed below. For a complete list of Platform class members, see the Platform Members topic.

Public Static Methods

GetFileExecutable |
GetFileLastModified | Overloaded. returns the last modified time for the given file via a native platform call
GetFileWritable |
GetLastModified | Overloaded. returns the last modified time for the given file via a native platform call
PrintProps |
SetFileExecutable |
SetFileLastModified |
SetFileWritable |

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.Platform.
GetHashCode | Delegate GetHashCode() to com.starbase.util.Platform.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.Platform.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.Platform

Implements

IWrapper.Unwrap

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform.Equals Method

Delegate Equals() to com.starbase.util.Platform.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.Platform.Equals(obj).

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform.GetFileExecutable Method

public static bool GetFileExecutable(
FileInfo file
);

Parameters

file

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | Borland.StarTeam.Util Namespace


GetFileLastModified Method

Borland StarTeam SDK for .NET

Platform.GetFileLastModified Method

returns the last modified time for the given file via a native platform call

Overload List

returns the last modified time for the given file via a native platform call

public static double GetFileLastModified(FileInfo);

returns the last modified time for the given file via a native platform call

public static double GetFileLastModified(String);

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform.GetFileLastModified Method (FileInfo)

returns the last modified time for the given file via a native platform call

public static double GetFileLastModified(
FileInfo file
);

Parameters

file
File

Return Value

double the last modified time converted to an OLE double

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | Borland.StarTeam.Util Namespace | Platform.GetFileLastModified Overload List


Platform.GetFileLastModified Method (String)

returns the last modified time for the given file via a native platform call

public static double GetFileLastModified(
String fileName
);

Parameters

fileName
String the absolute path to the file

Return Value

long the last modified time

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | Borland.StarTeam.Util Namespace | Platform.GetFileLastModified Overload List


Platform.GetFileWritable Method

public static bool GetFileWritable(
FileInfo file
);

Parameters

file

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.Platform.

public override int GetHashCode();

Return Value

com.starbase.util.Platform.GetHashCode().

See Also

Platform Class | Borland.StarTeam.Util Namespace


GetLastModified Method

Borland StarTeam SDK for .NET

Platform.GetLastModified Method

returns the last modified time for the given file via a native platform call

Overload List

returns the last modified time for the given file via a native platform call

public static long GetLastModified(FileInfo);

returns the last modified time for the given file via a native platform call

public static long GetLastModified(String);

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform.GetLastModified Method (FileInfo)

returns the last modified time for the given file via a native platform call

public static long GetLastModified(
FileInfo file
);

Parameters

file
File

Return Value

long the last modified time

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | Borland.StarTeam.Util Namespace | Platform.GetLastModified Overload List


Platform.GetLastModified Method (String)

returns the last modified time for the given file via a native platform call

public static long GetLastModified(
String fileName
);

Parameters

fileName
String the absolute path to the file

Return Value

long the last modified time

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | Borland.StarTeam.Util Namespace | Platform.GetLastModified Overload List


Platform.PrintProps Method

public static void PrintProps();

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform.SetFileExecutable Method

public static void SetFileExecutable(
FileInfo file,
Boolean executable
);

Parameters

file
executable

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform.SetFileLastModified Method

public static void SetFileLastModified(
FileInfo file,
Double oletime
);

Parameters

file
oletime

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform.SetFileWritable Method

public static void SetFileWritable(
FileInfo file,
Boolean val
);

Parameters

file
val

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform.ToString Method

Delegate ToString() to com.starbase.util.Platform.

public override string ToString();

Return Value

com.starbase.util.Platform.ToString()

See Also

Platform Class | Borland.StarTeam.Util Namespace


Platform Type Conversions

The type conversions of the Platform class are listed below. For a complete list of Platform class members, see the Platform Members topic.

Public Static Type Conversions

Implicit Platform to Platform Conversion Implicitly convert Platform to com.starbase.util.Platform.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Platform Class | Platform Members | Borland.StarTeam.Util Namespace


Platform Implicit Platform to Platform Conversion

Implicitly convert Platform to com.starbase.util.Platform.

public static implicit operator Platform(
Platform arg
);

Parameters

arg
Platform to convert.

Return Value

com.starbase.util.Platform

See Also

Platform Class | Borland.StarTeam.Util Namespace


UTF8 Class

Implements UTF-8 conversion routines as described by RFC-2279

For a list of all members of this type, see UTF8 Members.

System.Object
UTF8

public class UTF8 : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

UTF8 Members | Borland.StarTeam.Util Namespace


UTF8 Members

UTF8 overview

Public Static Methods

StringToUtf8 | Converts a string to an array of UTF-8 characters.
Utf16ToUtf8 | Converts an array of characters in UTF-16/Unicode format to an array of characters in UTF-8 characters.
Utf8ToString | Converts an array of characters in UTF-8 format to a Unicode string.
Utf8ToUtf16 | Converts an array of characters in UTF-8 format to an array of UTF-16/Unicode characters.
Utf8ToUtf16Char | Returns a single UTF-16 character by reading as many characters as necessary from a given InputStream, which is a stream of UTF-8 bytes.

Public Static Type Conversions

Implicit UTF8 to UTF8 Conversion Implicitly convert UTF8 to com.starbase.util.UTF8.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.UTF8.
GetHashCode | Delegate GetHashCode() to com.starbase.util.UTF8.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.UTF8.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8 Methods

The methods of the UTF8 class are listed below. For a complete list of UTF8 class members, see the UTF8 Members topic.

Public Static Methods

StringToUtf8 | Converts a string to an array of UTF-8 characters.
Utf16ToUtf8 | Converts an array of characters in UTF-16/Unicode format to an array of characters in UTF-8 characters.
Utf8ToString | Converts an array of characters in UTF-8 format to a Unicode string.
Utf8ToUtf16 | Converts an array of characters in UTF-8 format to an array of UTF-16/Unicode characters.
Utf8ToUtf16Char | Returns a single UTF-16 character by reading as many characters as necessary from a given InputStream, which is a stream of UTF-8 bytes.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.UTF8.
GetHashCode | Delegate GetHashCode() to com.starbase.util.UTF8.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.UTF8.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.UTF8

Implements

IWrapper.Unwrap

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8.Equals Method

Delegate Equals() to com.starbase.util.UTF8.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.UTF8.Equals(obj).

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.UTF8.

public override int GetHashCode();

Return Value

com.starbase.util.UTF8.GetHashCode().

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8.StringToUtf8 Method

Converts a string to an array of UTF-8 characters.

public static byte[] StringToUtf8(
String src
);

Parameters

src
Source string.

Return Value

The translated array of characters in UTF-8 format.

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8.ToString Method

Delegate ToString() to com.starbase.util.UTF8.

public override string ToString();

Return Value

com.starbase.util.UTF8.ToString()

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8.Utf16ToUtf8 Method

Converts an array of characters in UTF-16/Unicode format to an array of characters in UTF-8 characters.

public static int Utf16ToUtf8(
Char[] src,
Byte[] dst
);

Parameters

src
Source string, in unicode format.
dst
Output buffer for utf-8 characters.

Return Value

The number of bytes written. If dst is null, then only returns the number of bytes needed.

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8.Utf8ToString Method

Converts an array of characters in UTF-8 format to a Unicode string.

public static string Utf8ToString(
Byte[] src
);

Parameters

src
Source string, in UTF-8 format.

Return Value

The translated string.

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8.Utf8ToUtf16 Method

Converts an array of characters in UTF-8 format to an array of UTF-16/Unicode characters.

public static int Utf8ToUtf16(
Byte[] src,
Char[] dst
);

Parameters

src
Source string, in UTF-8 format.
dst
Output buffer for unicode characters.

Return Value

The number of characters written. If dst is null, then only returns the number of chars needed.

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8.Utf8ToUtf16Char Method

Returns a single UTF-16 character by reading as many characters as necessary from a given InputStream, which is a stream of UTF-8 bytes.

public static int Utf8ToUtf16Char(
Stream src
);

Parameters

src
Source stream, in UTF-8 format.

Return Value

The next character constructed from the stream, -1 if no more.

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8 Type Conversions

The type conversions of the UTF8 class are listed below. For a complete list of UTF8 class members, see the UTF8 Members topic.

Public Static Type Conversions

Implicit UTF8 to UTF8 Conversion Implicitly convert UTF8 to com.starbase.util.UTF8.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

UTF8 Class | UTF8 Members | Borland.StarTeam.Util Namespace


UTF8 Implicit UTF8 to UTF8 Conversion

Implicitly convert UTF8 to com.starbase.util.UTF8.

public static implicit operator UTF8(
UTF8 arg
);

Parameters

arg
UTF8 to convert.

Return Value

com.starbase.util.UTF8

See Also

UTF8 Class | Borland.StarTeam.Util Namespace


UTF8InputStreamReader Class

For a list of all members of this type, see UTF8InputStreamReader Members.

System.Object
UTF8InputStreamReader

public class UTF8InputStreamReader : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

UTF8InputStreamReader Members | Borland.StarTeam.Util Namespace


UTF8InputStreamReader Members

UTF8InputStreamReader overview

Public Static Methods

Wrap Dynamically wraps com.starbase.util.UTF8InputStreamReader.

Public Static Type Conversions

Implicit UTF8InputStreamReader to UTF8InputStreamReader Conversion Implicitly convert UTF8InputStreamReader to com.starbase.util.UTF8InputStreamReader.

Public Instance Constructors

UTF8InputStreamReader Overloaded. Initializes a new instance of the UTF8InputStreamReader class.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.UTF8InputStreamReader.
GetHashCode | Delegate GetHashCode() to com.starbase.util.UTF8InputStreamReader.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.UTF8InputStreamReader.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

UTF8InputStreamReader Class | Borland.StarTeam.Util Namespace


UTF8InputStreamReader Constructor

Construct UTF8InputStreamReader from com.starbase.util.UTF8InputStreamReader.

Overload List

Construct UTF8InputStreamReader from com.starbase.util.UTF8InputStreamReader.

public UTF8InputStreamReader(UTF8InputStreamReader);

public UTF8InputStreamReader(Stream);

See Also

UTF8InputStreamReader Class | Borland.StarTeam.Util Namespace


UTF8InputStreamReader Constructor (UTF8InputStreamReader)

Construct UTF8InputStreamReader from com.starbase.util.UTF8InputStreamReader.

public UTF8InputStreamReader(
UTF8InputStreamReader impl
);

Parameters

impl
The com.starbase.util.UTF8InputStreamReader to be wrapped.

See Also

UTF8InputStreamReader Class | Borland.StarTeam.Util Namespace | UTF8InputStreamReader Constructor Overload List


UTF8InputStreamReader Constructor (Stream)

public UTF8InputStreamReader(
Stream utf8stream
);

See Also

UTF8InputStreamReader Class | Borland.StarTeam.Util Namespace | UTF8InputStreamReader Constructor Overload List


UTF8InputStreamReader Methods

The methods of the UTF8InputStreamReader class are listed below. For a complete list of UTF8InputStreamReader class members, see the UTF8InputStreamReader Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.util.UTF8InputStreamReader.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.UTF8InputStreamReader.
GetHashCode | Delegate GetHashCode() to com.starbase.util.UTF8InputStreamReader.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.UTF8InputStreamReader.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

UTF8InputStreamReader Class | Borland.StarTeam.Util Namespace


UTF8InputStreamReader.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.UTF8InputStreamReader

Implements

IWrapper.Unwrap

See Also

UTF8InputStreamReader Class | Borland.StarTeam.Util Namespace


UTF8InputStreamReader.Equals Method

Delegate Equals() to com.starbase.util.UTF8InputStreamReader.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.UTF8InputStreamReader.Equals(obj).

See Also

UTF8InputStreamReader Class | Borland.StarTeam.Util Namespace


UTF8InputStreamReader.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.UTF8InputStreamReader.

public override int GetHashCode();

Return Value

com.starbase.util.UTF8InputStreamReader.GetHashCode().

See Also

UTF8InputStreamReader Class | Borland.StarTeam.Util Namespace


UTF8InputStreamReader.ToString Method

Delegate ToString() to com.starbase.util.UTF8InputStreamReader.

public override string ToString();

Return Value

com.starbase.util.UTF8InputStreamReader.ToString()

See Also

UTF8InputStreamReader Class | Borland.StarTeam.Util Namespace


UTF8InputStreamReader.Wrap Method

Dynamically wraps com.starbase.util.UTF8InputStreamReader.

public static UTF8InputStreamReader Wrap(
UTF8InputStreamReader impl
);

Parameters

impl
com.starbase.util.UTF8InputStreamReader to be wrapped.

Return Value

UTF8InputStreamReader

See Also

UTF8InputStreamReader Class | Borland.StarTeam.Util Namespace


UTF8InputStreamReader Type Conversions

The type conversions of the UTF8InputStreamReader class are listed below. For a complete list of UTF8InputStreamReader class members, see the UTF8InputStreamReader Members topic.

Public Static Type Conversions

Implicit UTF8InputStreamReader to UTF8InputStreamReader Conversion Implicitly convert UTF8InputStreamReader to com.starbase.util.UTF8InputStreamReader.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

UTF8InputStreamReader Class | UTF8InputStreamReader Members | Borland.StarTeam.Util Namespace


UTF8InputStreamReader Implicit UTF8InputStreamReader to UTF8InputStreamReader Conversion

Implicitly convert UTF8InputStreamReader to com.starbase.util.UTF8InputStreamReader.

public static implicit operator UTF8InputStreamReader(
UTF8InputStreamReader arg
);

Parameters

arg
UTF8InputStreamReader to convert.

Return Value

com.starbase.util.UTF8InputStreamReader

See Also

UTF8InputStreamReader Class | Borland.StarTeam.Util Namespace


WorkStationException Class

For a list of all members of this type, see WorkStationException Members.

System.Object
Exception
WorkStationException

public class WorkStationException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

WorkStationException Members | Borland.StarTeam.Util Namespace


WorkStationException Members

WorkStationException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.util.WorkStationException.

Public Static Type Conversions

Implicit WorkStationException to WorkStationException Conversion Implicitly convert WorkStationException to com.starbase.util.WorkStationException.

Public Instance Constructors

WorkStationException Overloaded. Initializes a new instance of the WorkStationException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.WorkStationException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.util.WorkStationException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.util.WorkStationException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

WorkStationException Class | Borland.StarTeam.Util Namespace


WorkStationException Constructor

Construct WorkStationException from com.starbase.util.WorkStationException.

Overload List

Construct WorkStationException from com.starbase.util.WorkStationException.

public WorkStationException(WorkStationException);

public WorkStationException(String);

See Also

WorkStationException Class | Borland.StarTeam.Util Namespace


WorkStationException Constructor (WorkStationException)

Construct WorkStationException from com.starbase.util.WorkStationException.

public WorkStationException(
WorkStationException impl
);

Parameters

impl
The com.starbase.util.WorkStationException to be wrapped.

See Also

WorkStationException Class | Borland.StarTeam.Util Namespace | WorkStationException Constructor Overload List


WorkStationException Constructor (String)

public WorkStationException(
String message
);

See Also

WorkStationException Class | Borland.StarTeam.Util Namespace | WorkStationException Constructor Overload List


WorkStationException Methods

The methods of the WorkStationException class are listed below. For a complete list of WorkStationException class members, see the WorkStationException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.util.WorkStationException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.WorkStationException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.util.WorkStationException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.util.WorkStationException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

WorkStationException Class | Borland.StarTeam.Util Namespace


WorkStationException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.WorkStationException

Implements

IWrapper.Unwrap

See Also

WorkStationException Class | Borland.StarTeam.Util Namespace


WorkStationException.Equals Method

Delegate Equals() to com.starbase.util.WorkStationException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.WorkStationException.Equals(obj).

See Also

WorkStationException Class | Borland.StarTeam.Util Namespace


WorkStationException.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.WorkStationException.

public override int GetHashCode();

Return Value

com.starbase.util.WorkStationException.GetHashCode().

See Also

WorkStationException Class | Borland.StarTeam.Util Namespace


WorkStationException.ToString Method

Delegate ToString() to com.starbase.util.WorkStationException.

public override string ToString();

Return Value

com.starbase.util.WorkStationException.ToString()

See Also

WorkStationException Class | Borland.StarTeam.Util Namespace


WorkStationException.Wrap Method

Dynamically wraps com.starbase.util.WorkStationException.

public static WorkStationException Wrap(
WorkStationException impl
);

Parameters

impl
com.starbase.util.WorkStationException to be wrapped.

Return Value

WorkStationException

See Also

WorkStationException Class | Borland.StarTeam.Util Namespace


WorkStationException Type Conversions

The type conversions of the WorkStationException class are listed below. For a complete list of WorkStationException class members, see the WorkStationException Members topic.

Public Static Type Conversions

Implicit WorkStationException to WorkStationException Conversion Implicitly convert WorkStationException to com.starbase.util.WorkStationException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

WorkStationException Class | WorkStationException Members | Borland.StarTeam.Util Namespace


WorkStationException Implicit WorkStationException to WorkStationException Conversion

Implicitly convert WorkStationException to com.starbase.util.WorkStationException.

public static implicit operator WorkStationException(
WorkStationException arg
);

Parameters

arg
WorkStationException to convert.

Return Value

com.starbase.util.WorkStationException

See Also

WorkStationException Class | Borland.StarTeam.Util Namespace


WorkStationOptions Interface

For a list of all members of this type, see WorkStationOptions Members.

public interface WorkStationOptions

Types that implement WorkStationOptions

Type | Description
WorkStationOptionsAdapter |

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

WorkStationOptions Members | Borland.StarTeam.Util Namespace


WorkStationOptions Members

WorkStationOptions overview

Public Instance Properties

LocationMsg [read]

Public Instance Methods

GetOption
SetOption

See Also

WorkStationOptions Interface | Borland.StarTeam.Util Namespace


WorkStationOptions Properties

The properties of the WorkStationOptions interface are listed below. For a complete list of WorkStationOptions interface members, see the WorkStationOptions Members topic.

Public Instance Properties

LocationMsg [read]

See Also

WorkStationOptions Interface | Borland.StarTeam.Util Namespace


LocationMsg Property

Borland StarTeam SDK for .NET

WorkStationOptions.LocationMsg Property

[read]

String LocationMsg {get;}

See Also

WorkStationOptions Interface | Borland.StarTeam.Util Namespace


WorkStationOptions Methods

The methods of the WorkStationOptions interface are listed below. For a complete list of WorkStationOptions interface members, see the WorkStationOptions Members topic.

Public Instance Methods

GetOption
SetOption

See Also

WorkStationOptions Interface | Borland.StarTeam.Util Namespace


WorkStationOptions.GetOption Method

string GetOption(
String option
);

Parameters

option

Exceptions

Exception Type | Condition
 | com.starbase.util.WorkStationException

See Also

WorkStationOptions Interface | Borland.StarTeam.Util Namespace


WorkStationOptions.SetOption Method

void SetOption(
String option,
String value
);

Parameters

option
value

Exceptions

Exception Type | Condition
 | com.starbase.util.WorkStationException

See Also

WorkStationOptions Interface | Borland.StarTeam.Util Namespace


WorkStationOptionsAdapter Class

For a list of all members of this type, see WorkStationOptionsAdapter Members.

System.Object
WorkStationOptionsAdapter

public class WorkStationOptionsAdapter : WorkStationOptions, WorkStationOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

WorkStationOptionsAdapter Members | Borland.StarTeam.Util Namespace


WorkStationOptionsAdapter Members

WorkStationOptionsAdapter overview

Public Instance Constructors

WorkStationOptionsAdapter Overloaded. Initializes a new instance of the WorkStationOptionsAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

WorkStationOptions.getOption
WorkStationOptions.GetOption
WorkStationOptions.locationMsg
WorkStationOptions.LocationMsg
WorkStationOptions.setOption
WorkStationOptions.SetOption

See Also

WorkStationOptionsAdapter Class | Borland.StarTeam.Util Namespace


WorkStationOptionsAdapter Constructor

Overload List

public WorkStationOptionsAdapter(WorkStationOptions);

public WorkStationOptionsAdapter(WorkStationOptions);

See Also

WorkStationOptionsAdapter Class | Borland.StarTeam.Util Namespace


WorkStationOptionsAdapter Constructor (WorkStationOptions)

public WorkStationOptionsAdapter(
WorkStationOptions arg
);

See Also

WorkStationOptionsAdapter Class | Borland.StarTeam.Util Namespace | WorkStationOptionsAdapter Constructor Overload List


WorkStationOptionsAdapter Properties

The properties of the WorkStationOptionsAdapter class are listed below. For a complete list of WorkStationOptionsAdapter class members, see the WorkStationOptionsAdapter Members topic.

Explicit Interface Implementations

WorkStationOptions.getOption
WorkStationOptions.GetOption
WorkStationOptions.locationMsg
WorkStationOptions.LocationMsg
WorkStationOptions.setOption
WorkStationOptions.SetOption

See Also

WorkStationOptionsAdapter Class | Borland.StarTeam.Util Namespace


WorkStationOptions.LocationMsg Property

Borland StarTeam SDK for .NET

WorkStationOptionsAdapter.WorkStationOptions.LocationMsg Property

private String WorkStationOptions.LocationMsg {get;}

Implements

WorkStationOptions.LocationMsg

See Also

WorkStationOptionsAdapter Class | Borland.StarTeam.Util Namespace


WorkStationOptionsAdapter Methods

The methods of the WorkStationOptionsAdapter class are listed below. For a complete list of WorkStationOptionsAdapter class members, see the WorkStationOptionsAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

WorkStationOptions.getOption
WorkStationOptions.GetOption
WorkStationOptions.locationMsg
WorkStationOptions.LocationMsg
WorkStationOptions.setOption
WorkStationOptions.SetOption

See Also

WorkStationOptionsAdapter Class | Borland.StarTeam.Util Namespace


WorkStationOptionsAdapter.WorkStationOptions.GetOption Method

string WorkStationOptions.GetOption(
String option
);

Implements

WorkStationOptions.GetOption

See Also

WorkStationOptionsAdapter Class | Borland.StarTeam.Util Namespace


WorkStationOptionsAdapter.WorkStationOptions.SetOption Method

void WorkStationOptions.SetOption(
String option,
String value
);

Implements

WorkStationOptions.SetOption

See Also

WorkStationOptionsAdapter Class | Borland.StarTeam.Util Namespace


WorkStationOptionsAdapter.WorkStationOptions.getOption Method

string WorkStationOptions.getOption(
String option
);

Implements

WorkStationOptions.getOption

See Also

WorkStationOptionsAdapter Class | Borland.StarTeam.Util Namespace


WorkStationOptionsAdapter.WorkStationOptions.locationMsg Method

string WorkStationOptions.locationMsg();

Implements

WorkStationOptions.locationMsg

See Also

WorkStationOptionsAdapter Class | Borland.StarTeam.Util Namespace


WorkStationOptionsAdapter.WorkStationOptions.setOption Method

void WorkStationOptions.setOption(
String option,
String value
);

Implements

WorkStationOptions.setOption

See Also

WorkStationOptionsAdapter Class | Borland.StarTeam.Util Namespace


XMLUtils Class

A class with XML related utility methods.

For a list of all members of this type, see XMLUtils Members.

System.Object
XMLUtils

public class XMLUtils : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

XMLUtils Members | Borland.StarTeam.Util Namespace


XMLUtils Members

XMLUtils overview

Public Static Methods

Escape | Returns the specified arbitrary text reformated in a form suitable for the contents of an XML element. In particular the following characters will be escaped: ", ', >, <, &
IsXML |
Wrap | Dynamically wraps com.starbase.util.XMLUtils.
WriteEscaped | Overloaded.
WriteEscapedAttributeValue |

Public Static Type Conversions

Implicit XMLUtils to XMLUtils Conversion Implicitly convert XMLUtils to com.starbase.util.XMLUtils.

Public Instance Constructors

XMLUtils Constructor Construct XMLUtils from com.starbase.util.XMLUtils.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.XMLUtils.
GetHashCode | Delegate GetHashCode() to com.starbase.util.XMLUtils.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.XMLUtils.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


XMLUtils Constructor

Construct XMLUtils from com.starbase.util.XMLUtils.

public XMLUtils(
XMLUtils impl
);

Parameters

impl
The com.starbase.util.XMLUtils to be wrapped.

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


XMLUtils Methods

The methods of the XMLUtils class are listed below. For a complete list of XMLUtils class members, see the XMLUtils Members topic.

Public Static Methods

Escape | Returns the specified arbitrary text reformated in a form suitable for the contents of an XML element. In particular the following characters will be escaped: ", ', >, <, &
IsXML |
Wrap | Dynamically wraps com.starbase.util.XMLUtils.
WriteEscaped | Overloaded.
WriteEscapedAttributeValue |

Public Instance Methods

Equals | Delegate Equals() to com.starbase.util.XMLUtils.
GetHashCode | Delegate GetHashCode() to com.starbase.util.XMLUtils.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.util.XMLUtils.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


XMLUtils.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.util.XMLUtils

Implements

IWrapper.Unwrap

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


XMLUtils.Equals Method

Delegate Equals() to com.starbase.util.XMLUtils.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.util.XMLUtils.Equals(obj).

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


XMLUtils.Escape Method

Returns the specified arbitrary text reformated in a form suitable for the contents of an XML element. In particular the following characters will be escaped: ", ', >, <, &

public static string Escape(
String rawText
);

Parameters

rawText
the raw text to be encoded for XML output

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


XMLUtils.GetHashCode Method

Delegate GetHashCode() to com.starbase.util.XMLUtils.

public override int GetHashCode();

Return Value

com.starbase.util.XMLUtils.GetHashCode().

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


XMLUtils.IsXML Method

public static bool IsXML(
FileInfo file
);

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


XMLUtils.ToString Method

Delegate ToString() to com.starbase.util.XMLUtils.

public override string ToString();

Return Value

com.starbase.util.XMLUtils.ToString()

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


XMLUtils.Wrap Method

Dynamically wraps com.starbase.util.XMLUtils.

public static XMLUtils Wrap(
XMLUtils impl
);

Parameters

impl
com.starbase.util.XMLUtils to be wrapped.

Return Value

XMLUtils

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


WriteEscaped Method

Borland StarTeam SDK for .NET

XMLUtils.WriteEscaped Method

Overload List

public static void WriteEscaped(String,TextWriter);

public static void WriteEscaped(String,StringBuilder);

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


XMLUtils.WriteEscaped Method (String, TextWriter)

public static void WriteEscaped(
String rawText,
TextWriter _out
);

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace | XMLUtils.WriteEscaped Overload List


XMLUtils.WriteEscaped Method (String, StringBuilder)

public static void WriteEscaped(
String rawText,
StringBuilder _out
);

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace | XMLUtils.WriteEscaped Overload List


XMLUtils.WriteEscapedAttributeValue Method

public static void WriteEscapedAttributeValue(
String rawText,
TextWriter _out
);

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


XMLUtils Type Conversions

The type conversions of the XMLUtils class are listed below. For a complete list of XMLUtils class members, see the XMLUtils Members topic.

Public Static Type Conversions

Implicit XMLUtils to XMLUtils Conversion Implicitly convert XMLUtils to com.starbase.util.XMLUtils.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLUtils Class | XMLUtils Members | Borland.StarTeam.Util Namespace


XMLUtils Implicit XMLUtils to XMLUtils Conversion

Implicitly convert XMLUtils to com.starbase.util.XMLUtils.

public static implicit operator XMLUtils(
XMLUtils arg
);

Parameters

arg
XMLUtils to convert.

Return Value

com.starbase.util.XMLUtils

See Also

XMLUtils Class | Borland.StarTeam.Util Namespace


Borland.StarTeam.Util.JSharp

Borland StarTeam SDK for .NET

Borland.StarTeam.Util.JSharp Namespace

Namespace hierarchy

Classes

Class | Description
DateAdapter | A two-way adapter for converting between java.util.Date and System.DateTime.
EnumerationAdapter | A two-way adapter class to convert from java.util.Enumeration and System.Collections.IEnumerator.
FileAdapter | A two-way adapter for converting between java.io.File and System.IO.FileInfo.
FileNotFoundExceptionAdapter | A two-way adapter for converting between java.io.FileNotFoundException and System.IO.FileNotFoundException.
HashtableAdapter | A two-way adapter for converting between java.util.Hashtable and System.Collections.Hashtable.
InputStreamAdapter | A two-way adapter for converting between java.io.InputStream and System.IO.Stream.
IOExceptionAdapter | A two-way adapter for converting between java.io.IOException and System.IO.IOException.
LocaleAdapter | A two-way adapter for converting between java.util.Locale and System.Globalization.CultureInfo.
OutputStreamAdapter | A two-way adapter for converting between java.io.OutputStream and System.IO.Stream.
ReaderAdapter | A two-way adapter for converting between java.io.Reader and System.IO.TextReader.
SByteArrayAdapter | A two-way adapter for converting between sbyte[] and byte[].
StringBufferAdapter | An adapter for converting from System.Text.StringBuilder to java.lang.StringBuffer.
StringTokenizerAdapter | A two-way adapter for converting between java.util.StringTokenizer and System.Collections.Specialized.StringEnumerator.
ThrowableAdapter | A two-way adapter for converting between java.lang.Throwable and System.Exception.
Translation |
Wrapper |
WriterAdapter | A two-way adapter for converting between java.io.Writer and System.IO.TextWriter.

Interfaces

Interface | Description
IWrapper |
IWrapperFactory |


DateAdapter Class

A two-way adapter for converting between java.util.Date and System.DateTime.

For a list of all members of this type, see DateAdapter Members.

System.Object
DateAdapter

public class DateAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DateAdapter Members | Borland.StarTeam.Util.JSharp Namespace


DateAdapter Members

DateAdapter overview

Public Static Type Conversions

Implicit DateAdapter to Date Conversion | Converts this date to a java.util.Date.
Implicit DateAdapter to DateTime Conversion | Converts this date to a System.DateTime.

Public Instance Constructors

DateAdapter Overloaded. Initializes a new instance of the DateAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DateAdapter Class | Borland.StarTeam.Util.JSharp Namespace


DateAdapter Constructor

Constructs a DateAdapter.

Overload List

Constructs a DateAdapter.

public DateAdapter(Date);

Constructs a DateAdapter.

public DateAdapter(DateTime);

See Also

DateAdapter Class | Borland.StarTeam.Util.JSharp Namespace


DateAdapter Constructor (Date)

Constructs a DateAdapter.

public DateAdapter(
Date impl
);

Parameters

impl
A java.util.Date to be converted.

See Also

DateAdapter Class | Borland.StarTeam.Util.JSharp Namespace | DateAdapter Constructor Overload List


DateAdapter Constructor (DateTime)

Constructs a DateAdapter.

public DateAdapter(
DateTime impl
);

Parameters

impl
A System.DateTime to be converted.

See Also

DateAdapter Class | Borland.StarTeam.Util.JSharp Namespace | DateAdapter Constructor Overload List


DateAdapter Type Conversions

The type conversions of the DateAdapter class are listed below. For a complete list of DateAdapter class members, see the DateAdapter Members topic.

Public Static Type Conversions

Implicit DateAdapter to Date Conversion | Converts this date to a java.util.Date.
Implicit DateAdapter to DateTime Conversion | Converts this date to a System.DateTime.

See Also

DateAdapter Class | DateAdapter Members | Borland.StarTeam.Util.JSharp Namespace


DateAdapter Implicit DateAdapter to Date Conversion

Converts this date to a java.util.Date.

public static implicit operator Date(
DateAdapter arg
);

See Also

DateAdapter Class | Borland.StarTeam.Util.JSharp Namespace


DateAdapter Implicit DateAdapter to DateTime Conversion

Converts this date to a System.DateTime.

public static implicit operator DateTime(
DateAdapter arg
);

See Also

DateAdapter Class | Borland.StarTeam.Util.JSharp Namespace


EnumerationAdapter Class

A two-way adapter class to convert from java.util.Enumeration and System.Collections.IEnumerator.

For a list of all members of this type, see EnumerationAdapter Members.

System.Object
EnumerationAdapter

public class EnumerationAdapter : IWrapper, Enumeration, IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EnumerationAdapter Members | Borland.StarTeam.Util.JSharp Namespace


EnumerationAdapter Members

EnumerationAdapter overview

Public Instance Constructors

EnumerationAdapter Overloaded. Initializes a new instance of the EnumerationAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

Enumeration.hasMoreElements | Tests if this enumeration contains more elements.
Enumeration.nextElement | Gets the next element of this enumeration.
IEnumerator.Current | Gets the current element in the collection.
IEnumerator.MoveNext | Advances the enumerator to the next element of the collection.
IEnumerator.Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
IWrapper.Unwrap | Unwraps this object.

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace


EnumerationAdapter Constructor

Constructs an EnumerationAdapter.

Overload List

Constructs an EnumerationAdapter.

public EnumerationAdapter(Enumeration);

Constructs an EnumerationAdapter.

public EnumerationAdapter(IEnumerator);

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace


EnumerationAdapter Constructor (Enumeration)

Constructs an EnumerationAdapter.

public EnumerationAdapter(
Enumeration impl
);

Parameters

impl
A java.util.Enumeration to be converted.

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace | EnumerationAdapter Constructor Overload List


EnumerationAdapter Constructor (IEnumerator)

Constructs an EnumerationAdapter.

public EnumerationAdapter(
IEnumerator impl
);

Parameters

impl
A System.Collections.IEnumerator to be converted.

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace | EnumerationAdapter Constructor Overload List


EnumerationAdapter Properties

The properties of the EnumerationAdapter class are listed below. For a complete list of EnumerationAdapter class members, see the EnumerationAdapter Members topic.

Explicit Interface Implementations

Enumeration.hasMoreElements | Tests if this enumeration contains more elements.
Enumeration.nextElement | Gets the next element of this enumeration.
IEnumerator.Current | Gets the current element in the collection.
IEnumerator.MoveNext | Advances the enumerator to the next element of the collection.
IEnumerator.Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
IWrapper.Unwrap | Unwraps this object.

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace


IEnumerator.Current Property

Borland StarTeam SDK for .NET

EnumerationAdapter.IEnumerator.Current Property

Gets the current element in the collection.

private Object IEnumerator.Current {get;}

Implements

IEnumerator.Current

Exceptions

Exception Type | Condition
InvalidOperationException | The enumerator is positioned before the first element of the collection or after the last element.

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace


EnumerationAdapter Methods

The methods of the EnumerationAdapter class are listed below. For a complete list of EnumerationAdapter class members, see the EnumerationAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

Enumeration.hasMoreElements | Tests if this enumeration contains more elements.
Enumeration.nextElement | Gets the next element of this enumeration.
IEnumerator.Current | Gets the current element in the collection.
IEnumerator.MoveNext | Advances the enumerator to the next element of the collection.
IEnumerator.Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
IWrapper.Unwrap | Unwraps this object.

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace


EnumerationAdapter.IWrapper.Unwrap Method

Unwraps this object.

object IWrapper.Unwrap();

Return Value

A java.util.Enumeration.

Implements

IWrapper.Unwrap

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace


EnumerationAdapter.Enumeration.hasMoreElements Method

Tests if this enumeration contains more elements.

bool Enumeration.hasMoreElements();

Return Value

true if and only if this enumeration object contains at least one more element to provide; false otherwise.

Implements

Enumeration.hasMoreElements

Exceptions

Exception Type | Condition
NoSuchElementException | If there are no more elements to be enumerated.

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace


EnumerationAdapter.Enumeration.nextElement Method

Gets the next element of this enumeration.

object Enumeration.nextElement();

Return Value

The next element of this enumeration, if this enumeration object has at least one more element to provide.

Implements

Enumeration.nextElement

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace


EnumerationAdapter.IEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

bool IEnumerator.MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator.MoveNext

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace


EnumerationAdapter.IEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

void IEnumerator.Reset();

Implements

IEnumerator.Reset

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

EnumerationAdapter Class | Borland.StarTeam.Util.JSharp Namespace


FileAdapter Class

A two-way adapter for converting between java.io.File and System.IO.FileInfo.

For a list of all members of this type, see FileAdapter Members.

System.Object
FileAdapter

public class FileAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileAdapter Members | Borland.StarTeam.Util.JSharp Namespace


FileAdapter Members

FileAdapter overview

Public Static Type Conversions

Implicit FileAdapter to File Conversion
Implicit FileAdapter to FileInfo Conversion

Public Instance Constructors

FileAdapter Overloaded. Initializes a new instance of the FileAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileAdapter Class | Borland.StarTeam.Util.JSharp Namespace


FileAdapter Constructor

Overload List

public FileAdapter(File);

public FileAdapter(FileInfo);

See Also

FileAdapter Class | Borland.StarTeam.Util.JSharp Namespace


FileAdapter Constructor (File)

public FileAdapter(
File path
);

See Also

FileAdapter Class | Borland.StarTeam.Util.JSharp Namespace | FileAdapter Constructor Overload List


FileAdapter Constructor (FileInfo)

public FileAdapter(
FileInfo path
);

See Also

FileAdapter Class | Borland.StarTeam.Util.JSharp Namespace | FileAdapter Constructor Overload List


FileAdapter Type Conversions

The type conversions of the FileAdapter class are listed below. For a complete list of FileAdapter class members, see the FileAdapter Members topic.

Public Static Type Conversions

Implicit FileAdapter to File Conversion
Implicit FileAdapter to FileInfo Conversion

See Also

FileAdapter Class | FileAdapter Members | Borland.StarTeam.Util.JSharp Namespace


FileAdapter Implicit FileAdapter to File Conversion

public static implicit operator File(
FileAdapter arg
);

See Also

FileAdapter Class | Borland.StarTeam.Util.JSharp Namespace


FileAdapter Implicit FileAdapter to FileInfo Conversion

public static implicit operator FileInfo(
FileAdapter arg
);

See Also

FileAdapter Class | Borland.StarTeam.Util.JSharp Namespace


FileNotFoundExceptionAdapter Class

A two-way adapter for converting between java.io.FileNotFoundException and System.IO.FileNotFoundException.

For a list of all members of this type, see FileNotFoundExceptionAdapter Members.

System.Object
FileNotFoundExceptionAdapter

public class FileNotFoundExceptionAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileNotFoundExceptionAdapter Members | Borland.StarTeam.Util.JSharp Namespace


FileNotFoundExceptionAdapter Members

FileNotFoundExceptionAdapter overview

Public Static Type Conversions

Implicit FileNotFoundExceptionAdapter to FileNotFoundException Conversion
Implicit FileNotFoundExceptionAdapter to FileNotFoundException Conversion

Public Instance Constructors

FileNotFoundExceptionAdapter Overloaded. Initializes a new instance of the FileNotFoundExceptionAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileNotFoundExceptionAdapter Class | Borland.StarTeam.Util.JSharp Namespace


FileNotFoundExceptionAdapter Constructor

Overload List

public FileNotFoundExceptionAdapter(FileNotFoundException);

public FileNotFoundExceptionAdapter(FileNotFoundException);

See Also

FileNotFoundExceptionAdapter Class | Borland.StarTeam.Util.JSharp Namespace


FileNotFoundExceptionAdapter Constructor (FileNotFoundException)

public FileNotFoundExceptionAdapter(
FileNotFoundException impl
);

See Also

FileNotFoundExceptionAdapter Class | Borland.StarTeam.Util.JSharp Namespace | FileNotFoundExceptionAdapter Constructor Overload List


FileNotFoundExceptionAdapter Type Conversions

The type conversions of the FileNotFoundExceptionAdapter class are listed below. For a complete list of FileNotFoundExceptionAdapter class members, see the FileNotFoundExceptionAdapter Members topic.

Public Static Type Conversions

Implicit FileNotFoundExceptionAdapter to FileNotFoundException Conversion
Implicit FileNotFoundExceptionAdapter to FileNotFoundException Conversion

See Also

FileNotFoundExceptionAdapter Class | FileNotFoundExceptionAdapter Members | Borland.StarTeam.Util.JSharp Namespace


FileNotFoundExceptionAdapter Implicit FileNotFoundExceptionAdapter to FileNotFoundException Conversion

public static implicit operator FileNotFoundException(
FileNotFoundExceptionAdapter arg
);

See Also

FileNotFoundExceptionAdapter Class | Borland.StarTeam.Util.JSharp Namespace


HashtableAdapter Class

A two-way adapter for converting between java.util.Hashtable and System.Collections.Hashtable.

For a list of all members of this type, see HashtableAdapter Members.

System.Object
HashtableAdapter

public class HashtableAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

HashtableAdapter Members | Borland.StarTeam.Util.JSharp Namespace


HashtableAdapter Members

HashtableAdapter overview

Public Static Methods

isNullValue

Public Static Type Conversions

Implicit HashtableAdapter to Hashtable Conversion
Implicit HashtableAdapter to Hashtable Conversion

Public Instance Constructors

HashtableAdapter Overloaded. Initializes a new instance of the HashtableAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HashtableAdapter Class | Borland.StarTeam.Util.JSharp Namespace


HashtableAdapter Constructor

Overload List

public HashtableAdapter(Hashtable);

public HashtableAdapter(Hashtable);

See Also

HashtableAdapter Class | Borland.StarTeam.Util.JSharp Namespace


HashtableAdapter Constructor (Hashtable)

public HashtableAdapter(
Hashtable impl
);

See Also

HashtableAdapter Class | Borland.StarTeam.Util.JSharp Namespace | HashtableAdapter Constructor Overload List


HashtableAdapter Methods

The methods of the HashtableAdapter class are listed below. For a complete list of HashtableAdapter class members, see the HashtableAdapter Members topic.

Public Static Methods

isNullValue

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HashtableAdapter Class | Borland.StarTeam.Util.JSharp Namespace


HashtableAdapter.isNullValue Method

public static bool isNullValue(
Object value
);

See Also

HashtableAdapter Class | Borland.StarTeam.Util.JSharp Namespace


HashtableAdapter Type Conversions

The type conversions of the HashtableAdapter class are listed below. For a complete list of HashtableAdapter class members, see the HashtableAdapter Members topic.

Public Static Type Conversions

Implicit HashtableAdapter to Hashtable Conversion
Implicit HashtableAdapter to Hashtable Conversion

See Also

HashtableAdapter Class | HashtableAdapter Members | Borland.StarTeam.Util.JSharp Namespace


HashtableAdapter Implicit HashtableAdapter to Hashtable Conversion

public static implicit operator Hashtable(
HashtableAdapter arg
);

See Also

HashtableAdapter Class | Borland.StarTeam.Util.JSharp Namespace


InputStreamAdapter Class

A two-way adapter for converting between java.io.InputStream and System.IO.Stream.

For a list of all members of this type, see InputStreamAdapter Members.

System.Object
InputStreamAdapter

public class InputStreamAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

InputStreamAdapter Members | Borland.StarTeam.Util.JSharp Namespace


InputStreamAdapter Members

InputStreamAdapter overview

Public Static Type Conversions

Implicit InputStreamAdapter to InputStream Conversion
Implicit InputStreamAdapter to Stream Conversion

Public Instance Constructors

InputStreamAdapter Overloaded. Initializes a new instance of the InputStreamAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

InputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace


InputStreamAdapter Constructor

Overload List

public InputStreamAdapter(InputStream);

public InputStreamAdapter(Stream);

See Also

InputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace


InputStreamAdapter Constructor (InputStream)

public InputStreamAdapter(
InputStream impl
);

See Also

InputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace | InputStreamAdapter Constructor Overload List


InputStreamAdapter Constructor (Stream)

public InputStreamAdapter(
Stream impl
);

See Also

InputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace | InputStreamAdapter Constructor Overload List


InputStreamAdapter Type Conversions

The type conversions of the InputStreamAdapter class are listed below. For a complete list of InputStreamAdapter class members, see the InputStreamAdapter Members topic.

Public Static Type Conversions

Implicit InputStreamAdapter to InputStream Conversion
Implicit InputStreamAdapter to Stream Conversion

See Also

InputStreamAdapter Class | InputStreamAdapter Members | Borland.StarTeam.Util.JSharp Namespace


InputStreamAdapter Implicit InputStreamAdapter to InputStream Conversion

public static implicit operator InputStream(
InputStreamAdapter arg
);

See Also

InputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace


InputStreamAdapter Implicit InputStreamAdapter to Stream Conversion

public static implicit operator Stream(
InputStreamAdapter arg
);

See Also

InputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace


IOExceptionAdapter Class

A two-way adapter for converting between java.io.IOException and System.IO.IOException.

For a list of all members of this type, see IOExceptionAdapter Members.

System.Object
IOExceptionAdapter

public class IOExceptionAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

IOExceptionAdapter Members | Borland.StarTeam.Util.JSharp Namespace


IOExceptionAdapter Members

IOExceptionAdapter overview

Public Static Type Conversions

Implicit IOExceptionAdapter to IOException Conversion
Implicit IOExceptionAdapter to IOException Conversion

Public Instance Constructors

IOExceptionAdapter Overloaded. Initializes a new instance of the IOExceptionAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IOExceptionAdapter Class | Borland.StarTeam.Util.JSharp Namespace


IOExceptionAdapter Constructor

Overload List

public IOExceptionAdapter(IOException);

public IOExceptionAdapter(IOException);

See Also

IOExceptionAdapter Class | Borland.StarTeam.Util.JSharp Namespace


IOExceptionAdapter Constructor (IOException)

public IOExceptionAdapter(
IOException impl
);

See Also

IOExceptionAdapter Class | Borland.StarTeam.Util.JSharp Namespace | IOExceptionAdapter Constructor Overload List


IOExceptionAdapter Type Conversions

The type conversions of the IOExceptionAdapter class are listed below. For a complete list of IOExceptionAdapter class members, see the IOExceptionAdapter Members topic.

Public Static Type Conversions

Implicit IOExceptionAdapter to IOException Conversion
Implicit IOExceptionAdapter to IOException Conversion

See Also

IOExceptionAdapter Class | IOExceptionAdapter Members | Borland.StarTeam.Util.JSharp Namespace


IOExceptionAdapter Implicit IOExceptionAdapter to IOException Conversion

public static implicit operator IOException(
IOExceptionAdapter arg
);

See Also

IOExceptionAdapter Class | Borland.StarTeam.Util.JSharp Namespace


IWrapper Interface

For a list of all members of this type, see IWrapper Members.

public interface IWrapper

Types that implement IWrapper

Type | Description
AccessCheckSecLogID | For Access Check events.
AccessRightsManager

Provides utilities for manipulating access rights.

Access rights information is fetched from the server as necessary, and cached to improve performance of subsequent access tests.
AccessTestResults

Represents the results of an access test.

Indicates whether or not access is granted, and provides an explanation in terms of the EffectiveACEs that were relevant for each tested permission.
ACE | An Access Control List entry. An AclEntry specifies a set of permissions that are either granted or denied to a particular user or group. A collection of such entries makes an ACL or Access Control List.
ACL | A strongly-typed collection of ACEs.
AddResult | The class holds return information specific to the file add operation.
Audit | Represents a StarTeam Audit record
BLSLicenseInfo | A license managed by the Borland License Server.
BLSLicenseInfoCollection | A strongly-typed collection of BLSLicenseInfos.
BuildNumber | A simple class that provides access to version information for the StarTeam SDK. The current version is "StarTeam SDK 11.0, Build 35".
CacheAgent | Describes the features of a Cache Agent, including the type of content it caches, the projects supported, and whether or not it caches file content.
CacheAgentEventArgs
CacheController | For each repository accessed via some Server object, we maintain a local cache that holds data fetched from the repository. Normally, when a given cache is no longer referened by any Server object, the cache is discarded, freeing up memory used by the cached data objects. However, "server-oriented" applications, which open and close many Server connections on behalf of various clients, may benefit from keeping these local caches around even after they are no longer referenced by any Server object. This is especially true when MPX is enabled. CacheController allows an application to adjust the behavior of the SDK caching mechanisms as appropriate.
CacheRef | For internal use only.
Catalog | The Catalog class provides "global" access to certain properties of objects from different classes. The catalog provides information about Property values for the primary and secondary descriptors of objects.
ChangeRequest | Represents a StarTeam ChangeRequest item.
ChangeRequestCollection | A strongly-typed collection of ChangeRequests.
CharacterSet | The Character Set of a text file on disk.
CharacterSetCollection | A strongly-typed collection of CharacterSets.
CheckinEventArgs
CheckinManager | Provides a way to check out multiple files, applying a consistent set of options across all files.
CheckinOptions | Maintains the checkout options used by CheckinManager.
CheckinPhase | Information on the phase of a checkin progress of the checkin operation from CheckinManager.
CheckinProgress | Information on the progress of a checkin operation from CheckinManager. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use CheckinManager.getProgress().
CheckInResult | The class holds return information specific to the file checkin operation.
CheckoutEventArgs
CheckoutManager | Provides a way to check out multiple files, applying a consistent set of options across all files.
CheckoutOptions | Maintains the checkout options used by CheckoutManager.
CheckoutProgress | Information on the progress of a checkout operation from CheckoutManager. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use CheckoutManager.getProgress().
CheckOutResult | The class holds return information specific to the file checkout operation.
ClientApplication | Manages information about the client application. This information is reported to the StarTeam Server for diagnostic purposes. Diagnostic information is used by StarTeam Server versions 6.0 and later.
ClientContext | The ClientContext class contains the nescessary information in order to run the SDK on one machine for a client running on a different machine. This is useful, for example, when running an SDK application within a Web server for a remote browser based client. The information in the ClientContext includes a unique client GUID identitfier, the hostname of the client machine, the client's end-of-line convention, whether or not the client treats file names as case sensitive or not and the string used to delimit directory names within an absolute file path. The Platform class has methods for returning those values on the host running the SDK.
ColumnInfo
ColumnInfoCollection | A strongly-typed collection of ColumnInfos.
CommandAbortedException
CommandException
ConfigFiles | All client stored config file locations for StarTeam can be found using this class.
ConnectionException
ContainerACLSecLogID | For Container-level security log events.
CultureInfoCollection | A strongly-typed collection of CultureInfos.
ColumnMaskCollection | A strongly-typed collection of ColumnMasks.
ConsoleWriter | This interface can be used when reconstructing a target from a source and a delta
DiffException
Edit
EditCollection | A strongly-typed collection of Edits.
EditList
EditListWriter | This interface can be used when reconstructing a target from a source and a delta
HTMLDiffWriter | Writes a simple HTML page showing the differences between two text files.
HTMLInterleavedDiffWriter | Writes a simple HTML page showing the differences between two text files.
HTMLStereoDiffWriter | Writes a simple HTML page showing the differences between two text files.
HTMLTableDiffWriter | Shared implementation for HTMLInterleavedDiffWriter and HTMLStereoDiffWriter.
LineIterator | This class iterates over characters in a line. It actually iterates from the back forward.
StarTeamMerge
DirectoryOverrides | A class that can parse a StarTeam.ini file and work with the view and folder overrides it specifies.
DisembodiedItemException
DuplicateServerListEntryException
EffectiveACE

An Access Control Entry (ACE) in an Effective Access Control List (ACL).

An EffectiveACE may be an ACE that is explicitly listed in the ACL for an object or for its parent container, or may be implied by group permissions that have been defined, or by object ownership rules, or by the StarTeam access test algorithm itself.

Each EffectiveACE provides information about its origin, including a description in human-readable form.

EffectiveACEs are important with respect to explaining the results of an access test.
EffectiveACL | A strongly-typed collection of EffectiveACEs.
EmailAttachment | This class embodies an email attachment.
EmailAttachmentCollection | A strongly-typed collection of EmailAttachments.
EncryptionAlgorithm | This class provides a convenient place to refer to the different encryption algorithms that can be used for secure StarTeam connections. This class is used by various encryption methods on the connection and server objects. There is also some support for mapping the algorithm to an enum code used by the server. These methods should not be needed by the general user of security.
EnumeratedValue | A simple integer/String pair object to be used for adding new custom enumerated fields (Property) and modifying existing enumerated fields (Property).
EnumeratedValueCollection | A strongly-typed collection of EnumeratedValues.
EOLFormat | The EOL format of a text file on disk.
EOLFormatCollection | A strongly-typed collection of EOLFormats.
EventHandlerInfo | The EventHandlerInfo class describes a registered event handler, such as the one for the StarTeam MPX Server.
EventHandlerProfile | The EventHandlerProfile class contains the information of one of profiles of an EventHandlerInfo.
File | Represents a StarTeam File item.
FileBasedStatusManager | Manages File Status information on the local client workstation.
FileCollection | A strongly-typed collection of Files.
FileResult | The class holds return information common to the file operations of add, checkin and checkout.
FileStream | Provides utility function for manipulating File streams.
FilterCollection | A strongly-typed collection of Filters.
FilterEventArgs
Folder | Represents a StarTeam Folder.
FolderCollection | A strongly-typed collection of Folders.
FolderEventArgs
FolderListManager | Manages a collection of folders created by including and excluding selected folders and their subfolders. Currently, all folders in the list must belong to the same view. Remembers the set of operations used to create the collection, so that the collection can be refreshed using the latest information from the StarTeam repository.
FolderTreeEventArgs
FolderUpdateEventArgs
ForeignPasswordException
ForeignRefreshResult | The class holds return information specific to the "foreign" refresh operation.
Group | Represents a StarTeam Group. Only a limited subset of the whole group information is available. The GroupAccount class has the full group information but it is only accessible to user's with the appropriate permissions.
GroupAccount | This class represents a full StarTeam Group account. New groups can be added to a StarTeam Server and existing groups can be modified through this class. Whereas the Group class only provides access to a group's name and ID, the GroupAccount supports access to all information about a group. All users can obtain Group information but only users with the appropriate permissions can access GroupAccount information.
GroupAccountCollection | A strongly-typed collection of GroupAccounts.
GroupCollection | A strongly-typed collection of Groups.
GroupNode | Describes a group of objects that may be a subgroup of a larger, indexable group. Maintains a range mapping into the underlying ordered collection. Each Node may be in an expanded or collapsed state. Note that it is the client's responsibility to ensure valid index ranges relative to the underlying collection.
GroupNodeCollection | A strongly-typed collection of GroupNodes.
GroupSortInfo
GroupSortInfoCollection | A strongly-typed collection of GroupSortInfos.
HistoryLine | A class containing information specific to a single version entry for expansion of the $History$ keyword.
HiveInfo | Describes a vault hive on the server.
HiveInfo.HiveType
HiveInfoCollection | A strongly-typed collection of HiveInfos.
HiveManager | Manages vault hives on the server.
IOExceptionCollection | A strongly-typed collection of IOExceptions.
IPRange | This class represents a range of TCP/IP addresses and the required level of encryption for clients to connect to the StarTeam server.
IPRangeCollection | A strongly-typed collection of IPRanges.
Item | Contextual reference to an object in a StarTeam repository. Items provide transparent access to the underlying entity (e.g., modifying the description of an item by calling Item.put("Description", "some text") actually modifies the Desription property of the underlying entity the Item references. An Item consists of the underlying entity and its context within a view. Therefore, an Item has direct knowledge of the items to which it is related. Items also maintain state information to determine if the underlying object is is new or modified relative to instances of the object stored in the repository. An Item also has a temporal aspect in that it represents a single development path (linear history) of the underlying object as of a moment in time.
Item.LockType
ItemBehavior | A class that represents the behavior of an Item.
ItemEventArgs
ItemIDEventArgs
ItemListEventArgs
ItemListManager | Generates and manages a list of Items. All Items in the item list have a given type. Items are generated from a list of folders determined by a FolderListManager. The item list can be filtered, sorted, refreshed, queried, and so on. Items are retrieved via getItems() or getItemsArray(), which are optimized to do as little work as possible. For example, if only the sort order has changed since the last time the item list was retrieved, then the existing items in the list are resorted only.
ItemNotFoundException
ItemReference
ItemReferenceCollection | A strongly-typed collection of ItemReferences.
ItemRevision | A ItemRevision represents a View member level revision of an item. Such revisions are created when one modifies the view level properties of a particular share of the item. These would be operations like: 1. changing the item branch behavior 2. changing the item configuration 3. branching the item 4. moving the item
ItemRevisionCollection | A strongly-typed collection of ItemRevisions.
ItemUpdateEventArgs
KeywordCollection | A strongly-typed collection of Keywords.
KeywordReader
Label | Represents a named configuration of Items. Labels may be applied to an entire View or to individual item versions.
LabelCollection | A strongly-typed collection of Labels.
LabelEventArgs
LicenseUsage | This class is a simple container for StarTeam license usage information.
Link | Represents an instance of an association between two items.
LinkCache | Caches links for a given set of items. One LinkCache may be populated with links from multiple view configurations on multiple servers.
LinkCollection | A strongly-typed collection of Links.
LinkEndpoint | Represents a link reference to an item.
LinkFactory | Supports bulk link creation, on servers that support it.
LinkUpdateEventArgs
LogLine | A class containing information specific to a single version entry for expansion of the $Log$ keyword.
LogLineCollection | A strongly-typed collection of LogLines.
LogonException
MatchedACE

Used when explaining the results of an access test.

Each MatchedACE provides a subset of the permissions that were tested, as well as the corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.
MatchedACECollection | A strongly-typed collection of MatchedACEs.
MergePoint | This class provides information about how two item revisions are related with respect to merging. Suppose the file "foo.txt" branches at revision 1.3 to create a new revision 1.3.1.0. A checkin on the main branch will create revision 1.4 and a subsequent checkin on the alternate branch will create revision 1.3.1.1. If the user then merges the changes between 1.3 to 1.4 in to a new branch revision 1.3.1.2 a MergePoint can be used to record the sources used to create this new revision. In this case the MergePoint would have a source RevisionID corresponding to the 1.4 revision of "foo.txt" and a target RevisionID corresponding to the 1.3.1.2 revision of "foo.txt".
MergePointCollection | A strongly-typed collection of MergePoints.
MPXException
MPXStatusEventArgs
MyUserAccount | This class represents the user account information that every user can specify/modify about themselves. The basic proceedure is to call the Server.getMyUserAccount, then modify the appropriate fields then call update() on the object to save the changes on the server.
NetMonitor | Displays information about the commands that are being sent to the StarTeam Server. This may be useful in diagnosing performance problems.
NoSuchPropertyException
NotificationEventArgs
NotificationItem | This class bundles together information about new "notification" items of a particular type in a particular view that the user may be interested in knowing about.
NotificationItemCollection | A strongly-typed collection of NotificationItems.
ObjectACLSecLogID | For Object ACL events.
PasswordExpiredException
Permission | This interface contains fields defining all the different permission settings used by StarTeam.
ProcessItem | A process item in the context of a given target view.
ProcessItemUsage | Indicates the type of operation that created a given process task and its associated process links.
ProductCodes | This class defines constant values for the various StarTeam product codes.
Project | Represents a StarTeam project which is essentially just a collection of Views.
ProjectCollection | A strongly-typed collection of Projects.
ProjectEventArgs
PromotionModel | This class represents the Promotion model for a view. Each view has a single promotion model. The PromotionModel class primarily acts as the owner of an ordered list of PromotionStates.
PromotionState | This class represents a promotion state associated with a promotion model. This class has no update() method so to save new or modified promotion states you must use PromotionModel.update()
PromotionStateCollection | A strongly-typed collection of PromotionStates.
Property | Each different Type supported by a StarTeam Server (e.g. File, Change Request, Topic...) has an associated set of properties. The Property class provides information about a Type's property.
Property.Types
PropertyCollection | A strongly-typed collection of Propertys.
PropertyEnums | This class provides a conventient place to get the values of various built-in StarTeam enumerated item properties. The member variables here should be used instead of hard-coded numeric values. This does lead to a bit of indirection but is the safest way of being sure you are using the right enumerated value. This class also insulates you from any enumerated value changes that could occur from one release of StarTeam to the next.
PropertyNames | This class provides a conventient place to get the names of various built-in StarTeam Item (and some non-item) property names. The member variables here should always be used instead of hard-coded String values. For example, on a File Item you should not call get("Name") to get the name property but rather file.get(file.getPropertyNames().FILE_NAME); This does lead to a bit of indirection but is the safest way of being sure you are using the right property name. This class also insulates you from any property name changes that could occur from one release of StarTeam to the next.
PropertyNotWritableException
PurgeControl | Provides control over the Online Purge service. The service may be configured to start automatically when the server starts up. If configured to do so, it will run a purge in the background while the server is running. This eliminates the requirement for costly down time just to purge the starteam repository. The online purge will not affect any resources deleted during the current active server session. Access the purge log by issuing a writeLogFile command with a logType value of 1.
PurgeStatus | Describes the current state of the purge service
PurgeStatusCollection | A strongly-typed collection of PurgeStatuss.
QueryCollection | A strongly-typed collection of Querys.
QueryEventArgs
QueryNode | A QueryNode represents a boolean expression. The expression is applied to an item to determine if the query is true of the item or not.
QueryNodeCollection | A strongly-typed collection of QueryNodes.
QueryPart | A QueryPart object represents a boolean expression on the value of a particular property of an item. For example, it could be used to define query to match file objects whose name starts with a specific string.
QueryPartCollection | A strongly-typed collection of QueryParts.
RecycleBin
RevisionID | A simple class representing a unique revision of an Item in the repository. For items of the same type revisions can be uniquely int a repository byte the item's objectID and revision number.
SDKRuntimeException
SecurityLogEntry
SecurityLogEntry.SecurityEventType
SecurityLogEntryCollection | A strongly-typed collection of SecurityLogEntrys.
Server | The Server class provides network access to a remote StarTeam Server. It only supports access through TCP/IP sockets and has the ability to encrypt and compress all communication between the client server.
ServerAdministration | The ServerAdministration class provides a convenient interface to perform various server level administration commands. The current set of operations are for field customization. Ultimately these methods should hang off of the core Type and Property objects but the refresh issues are too complex to deal with at this time. After calling any of the customization methods one should do a FULL refresh by discarding everything including the Server object itself and start over.
ServerCommandEventArgs
ServerConfiguration
ServerControlEventArgs
ServerException
ServerInfo
ServerInfoCollection | A strongly-typed collection of ServerInfos.
ServerLicenseInfo | Information about the licenses registered on a StarTeam Server.
ServerList | This class is used to manage a list of ServerInfo objects. Methods to read and write the server list to a file are supported. The server list file is also used by the StarTeam GUI.
ServerUnavailableException
SimpleTypedResource | A simple implementation of the TypedResource class.
StarTeamClientOptions
StarTeamFinder | A utility class for easily obtaining a connection to a StarTeam server and finding various objects like projects, views, folders and files.
StarTeamURL

StarTeamURL uses a URL-like syntax to reference a StarTeam Server, Project, View or Folder. Used in conjunction with StarTeamFinder, it provides a convenient way to locate important StarTeam objects.

StarTeamURL supports the following syntax:

starteam://username:password@hostname:port/Project/View/FolderA/FolderB/...

The "starteam://" prefix is optional.

Alternatively, the following syntax is also supported:

starteam://username:password@server/Project/View/FolderA/FolderB/...

Thus, if no ":port" is specified, the hostname is interpreted as a server description. The description is looked up in the server list, and, if found, the connection information from the server list (host address, port, encryption and compression settings, and MPX profile name) are used to establish the server connection.
Status | Represents the status of a working file relative to its corresponding file in the repository.
StatusMethod

This class provides information about how file status is managed for the client. Prior to StarTeam 5.2 all file status information was stored on the StarTeam Server. In 5.2 this staus information moved to the client. There are two ways in which that status information can be stored. These are refered to as "Per folder" and "Central"

"Per folder" status information is stored as close to the source file as possible. Assuming a file under revision control is stored in C:/project/foo.txt then the status information for that file will be stored in C:/project/.sbas/SyncDB. In fact, the status information for all files under C:/project will be stored in the file. There are a number of advantages of storing it in this location. For example, whole local folder structures may be moved or copied to new locations and all the status information will go along with it. The downside to this scheme is that in some cases users will not want the .sbas folders mixed in with the source files they are managing with StarTeam.

"Central" status information is all stored under a single user specified directory on the client's machine. This keeps the status information away from the user's source files. The downside to this approach is that you cannot easily move or copy source directories and have status information go along with it.

Users may specify which of these two methods to use by default along with the location of the central status information. Additionaly, users may override this on a per-View basis.
SupportedFeatures | The SupportedFeatures class contains a number of methods that report whether or not a particular feature is available for a StarTeam server.
SystemPolicy
SystemRevisionNumbers
Task | Represents a StarTeam Task item.
TaskDependency | This is a class representing a dependency between two tasks.
TaskDependencyCollection | A strongly-typed collection of TaskDependencys.
Topic | Represents a StarTeam Topic.
Translations | The Translations class defines the possible localized translations of a particular resource. There is the notion of a default translation which should be used when no translation exists for a particular language. In addition to the default there may be any number of specific localizations defined on a per-locale basis.
TreeItem | A type of item with children.
TypeCollection | A strongly-typed collection of Types.
TypedResource | This is a parent interface for many instances of StarTeam types (e.g. File, ChangeRequest). The interface describes objects that have property/value pairs. Each TypedResource is associated with the properties from a Type object. A TypedResource has a constraint that only valid Type properties may be used for set/get and that type checking for set will be enforced.
TypeEventArgs
TypeNames | TypeNames is a class defining pseudo-constants for the names of various types in StarTeam.
TypeNotFoundException
User | Represents a StarTeam user. Only a limited subset of the whole user information is available. The UserAccount class has the full user information but it is only accessible to user's with the appropriate permissions.
UserAccount | Represents a StarTeam user account. That is, an active user account on a StarTeam Server. This is not to be confused with a User object which simply represents a user that does participate or has participated in operations on the items in the repository.
UserAccountCollection | A strongly-typed collection of UserAccounts.
UserCollection | A strongly-typed collection of Users.
UserEventArgs
UserGroupSecLogID | For User-based security log events.
Base64 | A utility class for encoding and decoding binary data in base64. More information on base64 encoding can be found in RFC 2045 - Multipurpose Internet Mail Extensions (MIME) part one.
Diagnostics | A simple utility class with methods for generating detailed system and error information.
Encoding | This interface exposed the Java Class: com.borland.starteam.util.Encoding. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/util/Encoding.html
EncodingCollection | A strongly-typed collection of Encodings.
EOLReader
FileUtils | Utility class for accessing file info.
GUID
ISO8601

A utility class for encoding and parsing ISO8601 date/time format strings. The following sites have more information:

W3C NOTE - Date and Time Formated

Appendix 2 of the WebDAV specification.

Discussion by Markus Kuhn

EnumerationAdapter | A two-way adapter class to convert from java.util.Enumeration and System.Collections.IEnumerator.
LineProcessor
LineReader
MD5
OSEnvironment | Support for reading environment varaibles from the OS.
Platform | The Platform class is where I collect all platform specific APIs for things like end-of-line character and file lastModified methods... At some point, parts of this may need to be implemented in native code
UTF8 | Implements UTF-8 conversion routines as described by RFC-2279
UTF8InputStreamReader
WorkStationException
XMLUtils | A class with XML related utility methods.
View | Represents a StarTeam View.
ViewCollection | A strongly-typed collection of Views.
ActionOverride

Title: Starteam SDK

An object that provides a MergeState / MergeAction pair

ActionOverrideCollection | A strongly-typed collection of ActionOverrides.
AmbiguousMatchException
AnyScope | Combines multiple scopes. An item is considered in scope if it is included in at least one member scope.
Custom3WayMergeAdapter Facilitates the use of an external merge tool to resolve a 3-way file merge condition. For example:
 String app = "C:\\MyApp\\MyApp.exe"; String commandline = "-s $source -t $target -a $ancestor -out $result"; FileMergeAdapter tool = new Custom3WayMergeAdapter(diff, app, commandline); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("MyApp failed with exit code: " + exitCode); }
DifferenceType | Classifies the relationship between a source item and a target item.
DifferenceTypeCollection | A strongly-typed collection of DifferenceTypes.
EveryScope | Combines multiple scopes. An item is considered in scope if it is included in every member scope.
FileMergeAdapter | An abstract class designed to facilitate the use of an external tool for resolving a file merge condition.
FileMergeException
FolderScope | Allows folders to be included or excluded from the scope of the view compare/merge operation in a flexible way.
ItemDifference | Represents the difference between a given item from the source view and the corresponding item in the target view.
ItemDifferenceCollection | A strongly-typed collection of ItemDifferences.
ItemListScope
ItemTypeScope | Allows item types to be included or excluded from the scope of the view compare/merge operation. Note that folders are always included in the view compare/merge operation, whether or not the ItemTypeScope explicitly reports indicates that they should be included.
MatchState | Describes the relationship between an item in the source view and an item in the target view.
MergeAction | An action that may be used to resolve a merge condition.
MergeActionCollection | A strongly-typed collection of MergeActions.
MergePreview

Title: Starteam SDK

Description: A MergePreview is a read-only reference View with additional properties, and some local, context specific overrides

Copyright: Copyright (c) 2001

Company: Borland Corporation
MergeType | The type of view compare/merge operation to be performed.
MergeTypeCollection | A strongly-typed collection of MergeTypes.
Options | A set of user preferences that guide a view compare/merge operation. For any invocation of view compare and/or merge, these preferences may be overridden. The intent is that this set of preferences can be stored persistently and retrieved when setting up a view compare/merge operation, and that the set of options reflects what this user will usually want for the operation.
PreviewState | The preview state represents a highest precedence summary of all contained items and sub-folders and their contents. "has conflicts" is higher than "has changes" which is higher than "has compared items" which is higher than "has no compared items". A folder, for example, may contain items (directly or via sub-folders) in each of the four states, but the current value represents the highest precedence.
ProcessItemScope | Includes a processs item, and the items that are linked and pinned to it, in the scope of a session.
Progress | Information on the progress of a Merge operation from ViewMerger. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use ViewMerger.getProgress().
PropertyMergeException
RevisionLabelScope | Includes all item revisions with a given revision label in the scope of the view compare/merge session.
Scope

Provides a client application a flexible way to specify the scope of a view compare/merge operation.

The View Compare/Merge engine provides implementations of Scope that should suffice for most applications. In each case, the implementation is public, and may be re-used in the development of custom Scopes.
ScopeCollection | A strongly-typed collection of Scopes.
Session

A view compare/merge (VCM) session.

Each VCM session has associated source view and target views. {@linkplain #compare() Comparing} the two generates a set of {@linkplain #getDifferences() differences}. For each difference, you can detect {@linkplain ItemDifference#isConflictDetected conflicts}, {@linkplain ItemDifference#setAction override} default actions, and so on.

Conflicts may be resolved by merging {@linkplain ItemDifference#setMergedPropertyValue(com.starbase.starteam.Property, Object) item properties} or {@linkplain ItemDifference#setMergedFileContent(java.io.File) file content}. Alternatively, you can set property values or checkin new file revisions via the {@linkplain #getMergePreview merge preview}, which shows what the target view would look like were the session to be committed in its current state.

When ready, you can {@linkplain #commit() commit} the changes, which updates the target view.

For general information on using the VCM APIs, see com.starbase.startem.viewcomparemerge.
SessionState | An enumeration of states. A session may be in one and only one of these states at any given time.
StarTeamFileMergeAdapter Facilitates the use of the StarTeam File Compare / Merge tool (also known as "DeltaII") to resolve a file merge condition. Used as follows:
 FileMergeAdapter tool = new StarTeamFileMergeAdapter(diff); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("Merge failed with exit code: " + exitCode); }
Note that StarTeam File Compare / Merge is the default file merge tool in StarTeam 9.0 and later. It replaces VisMerge.exe, which is now obsolete.
VCMFolder
VisMergeAdapter Facilitates the use of the StarTeam VisMerge tool to resolve a file merge condition. Used as follows:
 VisMergeAdapter tool = new VisMergeAdapter(diff); tool.setIgnoreWhiteSpace(true); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("VisMerge failed with exit code: " + exitCode); }
Note that VisMerge was the default file merge tool in StarTeam 8.0 and earlier.
WorkstationDefaultMergeAdapter Uses the workstation default merge tool to resolve a file merge condition. For example:
 FileMergeAdapter tool = new WorkstationDefaultMergeAdapter(diff); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("The merge failed with exit code: " + exitCode); }
Note that if no file merge tool is registered in starteam-client-options.xml, then StarTeam File Compare / Merge (also known as "Delta II") is used by default.
ViewConfiguration | A class that represents the possible configuration states for a View. A StarTeam View can be in one of four different configurations: Current: all items in the view are the most recent or "tip" versions, Label: all items reference the version with the specified label attached, Time: all items reference the version that was tip as of some time, Promotion: like a label-based view but with respect to some promotion state.
ViewConfigurationDiffer

Used to compare two configurations of a given view, triggering FolderUpdateEvents and ItemUpdateEvents describing the changes detected between the two.

Events are triggered only for differences detectable by comparing the two view configurations. For example, if an item was added sometime after the time represented by the first configuration, and then removed sometime before the time represented by the second configuration, then no events would be triggered for that item.

Events are triggered in an order that reflects the times the change actually occurred, when possible. For some older server versions, and for some types of view configurations, it is not currently possible to determine when a move has occurred. It is also not currently possible to determine when a folder or item was removed. Such events are triggered last.
ViewEventArgs
ViewPollingAgent

Used to periodically poll a given view for recent changes, triggering FolderUpdateEvents and ItemUpdateEvents describing the changes detected since the last poll.

Events are triggered only for differences detectable across the polling interval. For example, if an item is added then removed without an intervening refresh, then no events would be triggered for that item.

Events are triggered in an order that reflects the times the change actually occurred, when possible. For some older server versions, it is not possible to determine when a move has occurred. It is also not currently possible to determine when a folder or item was removed. Such events are triggered last.

There are two basic ways to use a ViewPollingAgent. The first way is to create one and keep it around for a long time, periodically calling refresh() to trigger events. This is generally faster than creating a new ViewPollingAgent for each refresh(). However, the ViewPollingAgent consumes memory while it is in use.

The second way is to create a new ViewPollingAgent at each polling interval, call refresh() once to trigger events, and save the time returned by refresh() to use later when creating a ViewPollingAgent for the next poll. This is slower, but uses less memory between polls.
WorkRecord | Record of a period of work expended for a task.
WorkRecordCollection | A strongly-typed collection of WorkRecords.
Workstation
XMLAttribute | This interface exposed the Java Class: com.borland.starteam.xml.XMLAttribute. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/xml/XMLAttribute.html
XMLAttributeCollection | A strongly-typed collection of XMLAttributes.
XMLDocument | This interface exposed the Java Class: com.borland.starteam.xml.XMLDocument. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/xml/XMLDocument.html
XMLElement | This interface exposed the Java Class: com.borland.starteam.xml.XMLElement. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/xml/XMLElement.html
XMLElementCollection | A strongly-typed collection of XMLElements.
XMLException
XMLParseException

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

IWrapper Members | Borland.StarTeam.Util.JSharp Namespace


IWrapper Members

IWrapper overview

Public Instance Methods

Unwrap

See Also

IWrapper Interface | Borland.StarTeam.Util.JSharp Namespace


IWrapper Methods

The methods of the IWrapper interface are listed below. For a complete list of IWrapper interface members, see the IWrapper Members topic.

Public Instance Methods

Unwrap

See Also

IWrapper Interface | Borland.StarTeam.Util.JSharp Namespace


IWrapper.Unwrap Method

object Unwrap();

See Also

IWrapper Interface | Borland.StarTeam.Util.JSharp Namespace


IWrapperFactory Interface

For a list of all members of this type, see IWrapperFactory Members.

public interface IWrapperFactory

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

IWrapperFactory Members | Borland.StarTeam.Util.JSharp Namespace


IWrapperFactory Members

IWrapperFactory overview

Public Instance Methods

GetWrapperForType

See Also

IWrapperFactory Interface | Borland.StarTeam.Util.JSharp Namespace


IWrapperFactory Methods

The methods of the IWrapperFactory interface are listed below. For a complete list of IWrapperFactory interface members, see the IWrapperFactory Members topic.

Public Instance Methods

GetWrapperForType

See Also

IWrapperFactory Interface | Borland.StarTeam.Util.JSharp Namespace


IWrapperFactory.GetWrapperForType Method

Type GetWrapperForType(
Type t
);

See Also

IWrapperFactory Interface | Borland.StarTeam.Util.JSharp Namespace


LocaleAdapter Class

A two-way adapter for converting between java.util.Locale and System.Globalization.CultureInfo.

For a list of all members of this type, see LocaleAdapter Members.

System.Object
LocaleAdapter

public class LocaleAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

LocaleAdapter Members | Borland.StarTeam.Util.JSharp Namespace


LocaleAdapter Members

LocaleAdapter overview

Public Static Type Conversions

Implicit LocaleAdapter to Locale Conversion
Implicit LocaleAdapter to CultureInfo Conversion

Public Instance Constructors

LocaleAdapter Overloaded. Initializes a new instance of the LocaleAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LocaleAdapter Class | Borland.StarTeam.Util.JSharp Namespace


LocaleAdapter Constructor

Overload List

public LocaleAdapter(Locale);

public LocaleAdapter(CultureInfo);

See Also

LocaleAdapter Class | Borland.StarTeam.Util.JSharp Namespace


LocaleAdapter Constructor (Locale)

public LocaleAdapter(
Locale impl
);

See Also

LocaleAdapter Class | Borland.StarTeam.Util.JSharp Namespace | LocaleAdapter Constructor Overload List


LocaleAdapter Constructor (CultureInfo)

public LocaleAdapter(
CultureInfo impl
);

See Also

LocaleAdapter Class | Borland.StarTeam.Util.JSharp Namespace | LocaleAdapter Constructor Overload List


LocaleAdapter Type Conversions

The type conversions of the LocaleAdapter class are listed below. For a complete list of LocaleAdapter class members, see the LocaleAdapter Members topic.

Public Static Type Conversions

Implicit LocaleAdapter to Locale Conversion
Implicit LocaleAdapter to CultureInfo Conversion

See Also

LocaleAdapter Class | LocaleAdapter Members | Borland.StarTeam.Util.JSharp Namespace


LocaleAdapter Implicit LocaleAdapter to Locale Conversion

public static implicit operator Locale(
LocaleAdapter arg
);

See Also

LocaleAdapter Class | Borland.StarTeam.Util.JSharp Namespace


LocaleAdapter Implicit LocaleAdapter to CultureInfo Conversion

public static implicit operator CultureInfo(
LocaleAdapter arg
);

See Also

LocaleAdapter Class | Borland.StarTeam.Util.JSharp Namespace


OutputStreamAdapter Class

A two-way adapter for converting between java.io.OutputStream and System.IO.Stream.

For a list of all members of this type, see OutputStreamAdapter Members.

System.Object
OutputStreamAdapter

public class OutputStreamAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note that the adapter output streams are buffered; you must call flush (or close) to ensure that all bytes are written to the destination.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

OutputStreamAdapter Members | Borland.StarTeam.Util.JSharp Namespace


OutputStreamAdapter Members

OutputStreamAdapter overview

Public Static Type Conversions

Implicit OutputStreamAdapter to OutputStream Conversion
Implicit OutputStreamAdapter to Stream Conversion

Public Instance Constructors

OutputStreamAdapter Overloaded. Initializes a new instance of the OutputStreamAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

OutputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace


OutputStreamAdapter Constructor

Overload List

public OutputStreamAdapter(OutputStream);

public OutputStreamAdapter(Stream);

See Also

OutputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace


OutputStreamAdapter Constructor (OutputStream)

public OutputStreamAdapter(
OutputStream impl
);

See Also

OutputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace | OutputStreamAdapter Constructor Overload List


OutputStreamAdapter Constructor (Stream)

public OutputStreamAdapter(
Stream impl
);

See Also

OutputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace | OutputStreamAdapter Constructor Overload List


OutputStreamAdapter Type Conversions

The type conversions of the OutputStreamAdapter class are listed below. For a complete list of OutputStreamAdapter class members, see the OutputStreamAdapter Members topic.

Public Static Type Conversions

Implicit OutputStreamAdapter to OutputStream Conversion
Implicit OutputStreamAdapter to Stream Conversion

See Also

OutputStreamAdapter Class | OutputStreamAdapter Members | Borland.StarTeam.Util.JSharp Namespace


OutputStreamAdapter Implicit OutputStreamAdapter to OutputStream Conversion

public static implicit operator OutputStream(
OutputStreamAdapter arg
);

See Also

OutputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace


OutputStreamAdapter Implicit OutputStreamAdapter to Stream Conversion

public static implicit operator Stream(
OutputStreamAdapter arg
);

See Also

OutputStreamAdapter Class | Borland.StarTeam.Util.JSharp Namespace


ReaderAdapter Class

A two-way adapter for converting between java.io.Reader and System.IO.TextReader.

For a list of all members of this type, see ReaderAdapter Members.

System.Object
ReaderAdapter

public class ReaderAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ReaderAdapter Members | Borland.StarTeam.Util.JSharp Namespace


ReaderAdapter Members

ReaderAdapter overview

Public Static Type Conversions

Implicit ReaderAdapter to Reader Conversion
Implicit ReaderAdapter to TextReader Conversion

Public Instance Constructors

ReaderAdapter Overloaded. Initializes a new instance of the ReaderAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ReaderAdapter Class | Borland.StarTeam.Util.JSharp Namespace


ReaderAdapter Constructor

Overload List

public ReaderAdapter(Reader);

public ReaderAdapter(TextReader);

See Also

ReaderAdapter Class | Borland.StarTeam.Util.JSharp Namespace


ReaderAdapter Constructor (Reader)

public ReaderAdapter(
Reader impl
);

See Also

ReaderAdapter Class | Borland.StarTeam.Util.JSharp Namespace | ReaderAdapter Constructor Overload List


ReaderAdapter Constructor (TextReader)

public ReaderAdapter(
TextReader impl
);

See Also

ReaderAdapter Class | Borland.StarTeam.Util.JSharp Namespace | ReaderAdapter Constructor Overload List


ReaderAdapter Type Conversions

The type conversions of the ReaderAdapter class are listed below. For a complete list of ReaderAdapter class members, see the ReaderAdapter Members topic.

Public Static Type Conversions

Implicit ReaderAdapter to Reader Conversion
Implicit ReaderAdapter to TextReader Conversion

See Also

ReaderAdapter Class | ReaderAdapter Members | Borland.StarTeam.Util.JSharp Namespace


ReaderAdapter Implicit ReaderAdapter to Reader Conversion

public static implicit operator Reader(
ReaderAdapter arg
);

See Also

ReaderAdapter Class | Borland.StarTeam.Util.JSharp Namespace


ReaderAdapter Implicit ReaderAdapter to TextReader Conversion

public static implicit operator TextReader(
ReaderAdapter arg
);

See Also

ReaderAdapter Class | Borland.StarTeam.Util.JSharp Namespace


SByteArrayAdapter Class

A two-way adapter for converting between sbyte[] and byte[].

For a list of all members of this type, see SByteArrayAdapter Members.

System.Object
SByteArrayAdapter

public class SByteArrayAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SByteArrayAdapter Members | Borland.StarTeam.Util.JSharp Namespace


SByteArrayAdapter Members

SByteArrayAdapter overview

Public Static Type Conversions

Implicit SByteArrayAdapter to Byte[] Conversion
Implicit SByteArrayAdapter to SByte[] Conversion

Public Instance Constructors

SByteArrayAdapter Overloaded. Initializes a new instance of the SByteArrayAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SByteArrayAdapter Class | Borland.StarTeam.Util.JSharp Namespace


SByteArrayAdapter Constructor

Overload List

public SByteArrayAdapter(Byte[]);

public SByteArrayAdapter(SByte[]);

See Also

SByteArrayAdapter Class | Borland.StarTeam.Util.JSharp Namespace


SByteArrayAdapter Constructor (SByte[])

public SByteArrayAdapter(
SByte[] sbytes
);

See Also

SByteArrayAdapter Class | Borland.StarTeam.Util.JSharp Namespace | SByteArrayAdapter Constructor Overload List


SByteArrayAdapter Constructor (Byte[])

public SByteArrayAdapter(
Byte[] bytes
);

See Also

SByteArrayAdapter Class | Borland.StarTeam.Util.JSharp Namespace | SByteArrayAdapter Constructor Overload List


SByteArrayAdapter Type Conversions

The type conversions of the SByteArrayAdapter class are listed below. For a complete list of SByteArrayAdapter class members, see the SByteArrayAdapter Members topic.

Public Static Type Conversions

Implicit SByteArrayAdapter to Byte[] Conversion
Implicit SByteArrayAdapter to SByte[] Conversion

See Also

SByteArrayAdapter Class | SByteArrayAdapter Members | Borland.StarTeam.Util.JSharp Namespace


SByteArrayAdapter Implicit SByteArrayAdapter to Byte[] Conversion

public static implicit operator byte[](
SByteArrayAdapter arg
);

See Also

SByteArrayAdapter Class | Borland.StarTeam.Util.JSharp Namespace


SByteArrayAdapter Implicit SByteArrayAdapter to SByte[] Conversion

public static implicit operator sbyte[](
SByteArrayAdapter arg
);

See Also

SByteArrayAdapter Class | Borland.StarTeam.Util.JSharp Namespace


StringBufferAdapter Class

An adapter for converting from System.Text.StringBuilder to java.lang.StringBuffer.

For a list of all members of this type, see StringBufferAdapter Members.

System.Object
StringBufferAdapter

public class StringBufferAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The reverse translation is not supported; System.Text.StringBuilder is a final class, and cannot be inherited.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

StringBufferAdapter Members | Borland.StarTeam.Util.JSharp Namespace


StringBufferAdapter Members

StringBufferAdapter overview

Public Static Type Conversions

Implicit StringBufferAdapter to StringBuffer Conversion
Implicit StringBufferAdapter to StringBuilder Conversion

Public Instance Constructors

StringBufferAdapter Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringBufferAdapter Class | Borland.StarTeam.Util.JSharp Namespace


StringBufferAdapter Constructor

public StringBufferAdapter(
StringBuilder impl
);

See Also

StringBufferAdapter Class | Borland.StarTeam.Util.JSharp Namespace


StringBufferAdapter Type Conversions

The type conversions of the StringBufferAdapter class are listed below. For a complete list of StringBufferAdapter class members, see the StringBufferAdapter Members topic.

Public Static Type Conversions

Implicit StringBufferAdapter to StringBuffer Conversion
Implicit StringBufferAdapter to StringBuilder Conversion

See Also

StringBufferAdapter Class | StringBufferAdapter Members | Borland.StarTeam.Util.JSharp Namespace


StringBufferAdapter Implicit StringBufferAdapter to StringBuffer Conversion

public static implicit operator StringBuffer(
StringBufferAdapter arg
);

See Also

StringBufferAdapter Class | Borland.StarTeam.Util.JSharp Namespace


StringBufferAdapter Implicit StringBufferAdapter to StringBuilder Conversion

public static implicit operator StringBuilder(
StringBufferAdapter arg
);

See Also

StringBufferAdapter Class | Borland.StarTeam.Util.JSharp Namespace


StringTokenizerAdapter Class

A two-way adapter for converting between java.util.StringTokenizer and System.Collections.Specialized.StringEnumerator.

For a list of all members of this type, see StringTokenizerAdapter Members.

System.Object
StringTokenizerAdapter

public class StringTokenizerAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

StringTokenizerAdapter Members | Borland.StarTeam.Util.JSharp Namespace


StringTokenizerAdapter Members

StringTokenizerAdapter overview

Public Static Type Conversions

Implicit StringTokenizerAdapter to StringTokenizer Conversion
Implicit StringTokenizerAdapter to StringEnumerator Conversion

Public Instance Constructors

StringTokenizerAdapter Overloaded. Initializes a new instance of the StringTokenizerAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringTokenizerAdapter Class | Borland.StarTeam.Util.JSharp Namespace


StringTokenizerAdapter Constructor

Overload List

public StringTokenizerAdapter(StringTokenizer);

public StringTokenizerAdapter(StringEnumerator);

See Also

StringTokenizerAdapter Class | Borland.StarTeam.Util.JSharp Namespace


StringTokenizerAdapter Constructor (StringTokenizer)

public StringTokenizerAdapter(
StringTokenizer impl
);

See Also

StringTokenizerAdapter Class | Borland.StarTeam.Util.JSharp Namespace | StringTokenizerAdapter Constructor Overload List


StringTokenizerAdapter Constructor (StringEnumerator)

public StringTokenizerAdapter(
StringEnumerator impl
);

See Also

StringTokenizerAdapter Class | Borland.StarTeam.Util.JSharp Namespace | StringTokenizerAdapter Constructor Overload List


StringTokenizerAdapter Type Conversions

The type conversions of the StringTokenizerAdapter class are listed below. For a complete list of StringTokenizerAdapter class members, see the StringTokenizerAdapter Members topic.

Public Static Type Conversions

Implicit StringTokenizerAdapter to StringTokenizer Conversion
Implicit StringTokenizerAdapter to StringEnumerator Conversion

See Also

StringTokenizerAdapter Class | StringTokenizerAdapter Members | Borland.StarTeam.Util.JSharp Namespace


StringTokenizerAdapter Implicit StringTokenizerAdapter to StringTokenizer Conversion

public static implicit operator StringTokenizer(
StringTokenizerAdapter arg
);

See Also

StringTokenizerAdapter Class | Borland.StarTeam.Util.JSharp Namespace


StringTokenizerAdapter Implicit StringTokenizerAdapter to StringEnumerator Conversion

public static implicit operator StringEnumerator(
StringTokenizerAdapter arg
);

See Also

StringTokenizerAdapter Class | Borland.StarTeam.Util.JSharp Namespace


ThrowableAdapter Class

A two-way adapter for converting between java.lang.Throwable and System.Exception.

For a list of all members of this type, see ThrowableAdapter Members.

System.Object
ThrowableAdapter

public class ThrowableAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ThrowableAdapter Members | Borland.StarTeam.Util.JSharp Namespace


ThrowableAdapter Members

ThrowableAdapter overview

Public Static Type Conversions

Implicit ThrowableAdapter to Throwable Conversion
Implicit ThrowableAdapter to Exception Conversion

Public Instance Constructors

ThrowableAdapter Overloaded. Initializes a new instance of the ThrowableAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ThrowableAdapter Class | Borland.StarTeam.Util.JSharp Namespace


ThrowableAdapter Constructor

Overload List

public ThrowableAdapter(Throwable);

public ThrowableAdapter(Exception);

See Also

ThrowableAdapter Class | Borland.StarTeam.Util.JSharp Namespace


ThrowableAdapter Constructor (Throwable)

public ThrowableAdapter(
Throwable impl
);

See Also

ThrowableAdapter Class | Borland.StarTeam.Util.JSharp Namespace | ThrowableAdapter Constructor Overload List


ThrowableAdapter Constructor (Exception)

public ThrowableAdapter(
Exception impl
);

See Also

ThrowableAdapter Class | Borland.StarTeam.Util.JSharp Namespace | ThrowableAdapter Constructor Overload List


ThrowableAdapter Type Conversions

The type conversions of the ThrowableAdapter class are listed below. For a complete list of ThrowableAdapter class members, see the ThrowableAdapter Members topic.

Public Static Type Conversions

Implicit ThrowableAdapter to Throwable Conversion
Implicit ThrowableAdapter to Exception Conversion

See Also

ThrowableAdapter Class | ThrowableAdapter Members | Borland.StarTeam.Util.JSharp Namespace


ThrowableAdapter Implicit ThrowableAdapter to Throwable Conversion

public static implicit operator Throwable(
ThrowableAdapter arg
);

See Also

ThrowableAdapter Class | Borland.StarTeam.Util.JSharp Namespace


ThrowableAdapter Implicit ThrowableAdapter to Exception Conversion

public static implicit operator Exception(
ThrowableAdapter arg
);

See Also

ThrowableAdapter Class | Borland.StarTeam.Util.JSharp Namespace


Translation Class

For a list of all members of this type, see Translation Members.

System.Object
Translation

public class Translation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Translation Members | Borland.StarTeam.Util.JSharp Namespace


Translation Members

Translation overview

Public Static Methods

Find
FromType
RegisterAdapter
ToType

Public Instance Properties

Adapter
From
To

Public Instance Methods

Apply |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Translation Class | Borland.StarTeam.Util.JSharp Namespace


Translation Properties

The properties of the Translation class are listed below. For a complete list of Translation class members, see the Translation Members topic.

Public Instance Properties

Adapter
From
To

See Also

Translation Class | Borland.StarTeam.Util.JSharp Namespace


Adapter Property

Borland StarTeam SDK for .NET

Translation.Adapter Property

public Type Adapter {get;}

See Also

Translation Class | Borland.StarTeam.Util.JSharp Namespace


From Property

Borland StarTeam SDK for .NET

Translation.From Property

public Type From {get;}

See Also

Translation Class | Borland.StarTeam.Util.JSharp Namespace


To Property

Borland StarTeam SDK for .NET

Translation.To Property

public Type To {get;}

See Also

Translation Class | Borland.StarTeam.Util.JSharp Namespace


Translation Methods

The methods of the Translation class are listed below. For a complete list of Translation class members, see the Translation Members topic.

Public Static Methods

Find
FromType
RegisterAdapter
ToType

Public Instance Methods

Apply |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Translation Class | Borland.StarTeam.Util.JSharp Namespace


Translation.Apply Method

public abstract object Apply(
Object arg
);

See Also

Translation Class | Borland.StarTeam.Util.JSharp Namespace


Translation.Find Method

public static Translation[] Find(
Type from,
Type to
);

See Also

Translation Class | Borland.StarTeam.Util.JSharp Namespace


Translation.FromType Method

public static Translation FromType(
Type t
);

See Also

Translation Class | Borland.StarTeam.Util.JSharp Namespace


Translation.RegisterAdapter Method

public static void RegisterAdapter(
Type adapter
);

See Also

Translation Class | Borland.StarTeam.Util.JSharp Namespace


Translation.ToType Method

public static Translation ToType(
Type t
);

See Also

Translation Class | Borland.StarTeam.Util.JSharp Namespace


Wrapper Class

For a list of all members of this type, see Wrapper Members.

System.Object
Wrapper
SDKWrapper

public class Wrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Wrapper Members | Borland.StarTeam.Util.JSharp Namespace


Wrapper Members

Wrapper overview

Public Static Methods

Unwrap
Wrap

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Wrapper Class | Borland.StarTeam.Util.JSharp Namespace


Wrapper Methods

The methods of the Wrapper class are listed below. For a complete list of Wrapper class members, see the Wrapper Members topic.

Public Static Methods

Unwrap
Wrap

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Wrapper Class | Borland.StarTeam.Util.JSharp Namespace


Wrapper.Unwrap Method

public static object Unwrap(
Object arg
);

See Also

Wrapper Class | Borland.StarTeam.Util.JSharp Namespace


Wrapper.Wrap Method

public static object Wrap(
Object arg
);

See Also

Wrapper Class | Borland.StarTeam.Util.JSharp Namespace


WriterAdapter Class

A two-way adapter for converting between java.io.Writer and System.IO.TextWriter.

For a list of all members of this type, see WriterAdapter Members.

System.Object
WriterAdapter

public class WriterAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note that the adapter output streams are buffered; you must call flush (or close) to ensure that all chars are written to the destination.

Requirements

Namespace: Borland.StarTeam.Util.JSharp

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

WriterAdapter Members | Borland.StarTeam.Util.JSharp Namespace


WriterAdapter Members

WriterAdapter overview

Public Static Type Conversions

Implicit WriterAdapter to Writer Conversion
Implicit WriterAdapter to TextWriter Conversion

Public Instance Constructors

WriterAdapter Overloaded. Initializes a new instance of the WriterAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WriterAdapter Class | Borland.StarTeam.Util.JSharp Namespace


WriterAdapter Constructor

Overload List

public WriterAdapter(Writer);

public WriterAdapter(TextWriter);

See Also

WriterAdapter Class | Borland.StarTeam.Util.JSharp Namespace


WriterAdapter Constructor (Writer)

public WriterAdapter(
Writer impl
);

See Also

WriterAdapter Class | Borland.StarTeam.Util.JSharp Namespace | WriterAdapter Constructor Overload List


WriterAdapter Constructor (TextWriter)

public WriterAdapter(
TextWriter impl
);

See Also

WriterAdapter Class | Borland.StarTeam.Util.JSharp Namespace | WriterAdapter Constructor Overload List


WriterAdapter Type Conversions

The type conversions of the WriterAdapter class are listed below. For a complete list of WriterAdapter class members, see the WriterAdapter Members topic.

Public Static Type Conversions

Implicit WriterAdapter to Writer Conversion
Implicit WriterAdapter to TextWriter Conversion

See Also

WriterAdapter Class | WriterAdapter Members | Borland.StarTeam.Util.JSharp Namespace


WriterAdapter Implicit WriterAdapter to Writer Conversion

public static implicit operator Writer(
WriterAdapter arg
);

See Also

WriterAdapter Class | Borland.StarTeam.Util.JSharp Namespace


WriterAdapter Implicit WriterAdapter to TextWriter Conversion

public static implicit operator TextWriter(
WriterAdapter arg
);

See Also

WriterAdapter Class | Borland.StarTeam.Util.JSharp Namespace


Borland.StarTeam.Viewcomparemerge

Borland StarTeam SDK for .NET

Borland.StarTeam.Viewcomparemerge Namespace

Namespace hierarchy

Classes

Class | Description
ActionOverride

Title: Starteam SDK

An object that provides a MergeState / MergeAction pair

ActionOverrideCollection | A strongly-typed collection of ActionOverrides.
AmbiguousMatchException
AnyScope | Combines multiple scopes. An item is considered in scope if it is included in at least one member scope.
Custom3WayMergeAdapter Facilitates the use of an external merge tool to resolve a 3-way file merge condition. For example:
 String app = "C:\\MyApp\\MyApp.exe"; String commandline = "-s $source -t $target -a $ancestor -out $result"; FileMergeAdapter tool = new Custom3WayMergeAdapter(diff, app, commandline); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("MyApp failed with exit code: " + exitCode); }
DifferenceIteratorAdapter
DifferenceType | Classifies the relationship between a source item and a target item.
DifferenceTypeCollection | A strongly-typed collection of DifferenceTypes.
EveryScope | Combines multiple scopes. An item is considered in scope if it is included in every member scope.
FileMergeAdapter | An abstract class designed to facilitate the use of an external tool for resolving a file merge condition.
FileMergeException
FolderScope | Allows folders to be included or excluded from the scope of the view compare/merge operation in a flexible way.
ItemDifference | Represents the difference between a given item from the source view and the corresponding item in the target view.
ItemDifferenceCollection | A strongly-typed collection of ItemDifferences.
ItemListScope
ItemTypeScope | Allows item types to be included or excluded from the scope of the view compare/merge operation. Note that folders are always included in the view compare/merge operation, whether or not the ItemTypeScope explicitly reports indicates that they should be included.
MatchState | Describes the relationship between an item in the source view and an item in the target view.
MergeAction | An action that may be used to resolve a merge condition.
MergeActionCollection | A strongly-typed collection of MergeActions.
MergePreview

Title: Starteam SDK

Description: A MergePreview is a read-only reference View with additional properties, and some local, context specific overrides

Copyright: Copyright (c) 2001

Company: Borland Corporation
MergeType | The type of view compare/merge operation to be performed.
MergeTypeCollection | A strongly-typed collection of MergeTypes.
Options | A set of user preferences that guide a view compare/merge operation. For any invocation of view compare and/or merge, these preferences may be overridden. The intent is that this set of preferences can be stored persistently and retrieved when setting up a view compare/merge operation, and that the set of options reflects what this user will usually want for the operation.
PreviewState | The preview state represents a highest precedence summary of all contained items and sub-folders and their contents. "has conflicts" is higher than "has changes" which is higher than "has compared items" which is higher than "has no compared items". A folder, for example, may contain items (directly or via sub-folders) in each of the four states, but the current value represents the highest precedence.
ProcessItemScope | Includes a processs item, and the items that are linked and pinned to it, in the scope of a session.
Progress | Information on the progress of a Merge operation from ViewMerger. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use ViewMerger.getProgress().
PropertyMergeException
RevisionLabelScope | Includes all item revisions with a given revision label in the scope of the view compare/merge session.
Scope

Provides a client application a flexible way to specify the scope of a view compare/merge operation.

The View Compare/Merge engine provides implementations of Scope that should suffice for most applications. In each case, the implementation is public, and may be re-used in the development of custom Scopes.
ScopeCollection | A strongly-typed collection of Scopes.
Session

A view compare/merge (VCM) session.

Each VCM session has associated source view and target views. {@linkplain #compare() Comparing} the two generates a set of {@linkplain #getDifferences() differences}. For each difference, you can detect {@linkplain ItemDifference#isConflictDetected conflicts}, {@linkplain ItemDifference#setAction override} default actions, and so on.

Conflicts may be resolved by merging {@linkplain ItemDifference#setMergedPropertyValue(com.starbase.starteam.Property, Object) item properties} or {@linkplain ItemDifference#setMergedFileContent(java.io.File) file content}. Alternatively, you can set property values or checkin new file revisions via the {@linkplain #getMergePreview merge preview}, which shows what the target view would look like were the session to be committed in its current state.

When ready, you can {@linkplain #commit() commit} the changes, which updates the target view.

For general information on using the VCM APIs, see com.starbase.startem.viewcomparemerge.
SessionState | An enumeration of states. A session may be in one and only one of these states at any given time.
StarTeamFileMergeAdapter Facilitates the use of the StarTeam File Compare / Merge tool (also known as "DeltaII") to resolve a file merge condition. Used as follows:
 FileMergeAdapter tool = new StarTeamFileMergeAdapter(diff); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("Merge failed with exit code: " + exitCode); }
Note that StarTeam File Compare / Merge is the default file merge tool in StarTeam 9.0 and later. It replaces VisMerge.exe, which is now obsolete.
VCMFolder
VisMergeAdapter Facilitates the use of the StarTeam VisMerge tool to resolve a file merge condition. Used as follows:
 VisMergeAdapter tool = new VisMergeAdapter(diff); tool.setIgnoreWhiteSpace(true); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("VisMerge failed with exit code: " + exitCode); }
Note that VisMerge was the default file merge tool in StarTeam 8.0 and earlier.
WorkstationDefaultMergeAdapter Uses the workstation default merge tool to resolve a file merge condition. For example:
 FileMergeAdapter tool = new WorkstationDefaultMergeAdapter(diff); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("The merge failed with exit code: " + exitCode); }
Note that if no file merge tool is registered in starteam-client-options.xml, then StarTeam File Compare / Merge (also known as "Delta II") is used by default.

Interfaces

Interface Description
DifferenceIterator Iterates over a set of ItemDifferences. Used as follows:
 DifferenceIterator itr = session.getDifferences(); while (itr.hasMoreDifferences()) { ItemDifference diff = itr.nextDifference(); . . . }


ActionOverride Class

Title: Starteam SDK

An object that provides a MergeState / MergeAction pair

For a list of all members of this type, see ActionOverride Members.

System.Object
ActionOverride

public class ActionOverride : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ActionOverride Members | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverride Members

ActionOverride overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.ActionOverride.

Public Static Type Conversions

Implicit ActionOverride to ActionOverride Conversion Implicitly convert ActionOverride to com.starbase.starteam.viewcomparemerge.ActionOverride.

Public Instance Constructors

ActionOverride Constructor Construct ActionOverride from com.starbase.starteam.viewcomparemerge.ActionOverride.

Public Instance Properties

DifferenceType | [read] DifferenceType the DifferenceType contained within this ActionOverride
MatchState | [read] MatchState the MatchState contained within this ActionOverride
MergeAction | [read] MergeAction the MergeAction contained within this ActionOverride

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.ActionOverride.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.ActionOverride.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.ActionOverride.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverride Constructor

Construct ActionOverride from com.starbase.starteam.viewcomparemerge.ActionOverride.

public ActionOverride(
ActionOverride impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.ActionOverride to be wrapped.

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverride Properties

The properties of the ActionOverride class are listed below. For a complete list of ActionOverride class members, see the ActionOverride Members topic.

Public Instance Properties

DifferenceType | [read] DifferenceType the DifferenceType contained within this ActionOverride
MatchState | [read] MatchState the MatchState contained within this ActionOverride
MergeAction | [read] MergeAction the MergeAction contained within this ActionOverride

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType Property

Borland StarTeam SDK for .NET

ActionOverride.DifferenceType Property

[read] DifferenceType the DifferenceType contained within this ActionOverride

public virtual DifferenceType DifferenceType {get;}

Property Value

DifferenceType the DifferenceType contained within this ActionOverride

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState Property

Borland StarTeam SDK for .NET

ActionOverride.MatchState Property

[read] MatchState the MatchState contained within this ActionOverride

public virtual MatchState MatchState {get;}

Property Value

MatchState the MatchState contained within this ActionOverride

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction Property

Borland StarTeam SDK for .NET

ActionOverride.MergeAction Property

[read] MergeAction the MergeAction contained within this ActionOverride

public virtual MergeAction MergeAction {get;}

Property Value

MergeAction the MergeAction contained within this ActionOverride

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverride Methods

The methods of the ActionOverride class are listed below. For a complete list of ActionOverride class members, see the ActionOverride Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.ActionOverride.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.ActionOverride.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.ActionOverride.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.ActionOverride.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverride.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.ActionOverride

Implements

IWrapper.Unwrap

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverride.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.ActionOverride.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.ActionOverride.Equals(obj).

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverride.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.ActionOverride.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.ActionOverride.GetHashCode().

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverride.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.ActionOverride.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.ActionOverride.ToString()

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverride.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.ActionOverride.

public static ActionOverride Wrap(
ActionOverride impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.ActionOverride to be wrapped.

Return Value

ActionOverride

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverride Type Conversions

The type conversions of the ActionOverride class are listed below. For a complete list of ActionOverride class members, see the ActionOverride Members topic.

Public Static Type Conversions

Implicit ActionOverride to ActionOverride Conversion Implicitly convert ActionOverride to com.starbase.starteam.viewcomparemerge.ActionOverride.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ActionOverride Class | ActionOverride Members | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverride Implicit ActionOverride to ActionOverride Conversion

Implicitly convert ActionOverride to com.starbase.starteam.viewcomparemerge.ActionOverride.

public static implicit operator ActionOverride(
ActionOverride arg
);

Parameters

arg
ActionOverride to convert.

Return Value

com.starbase.starteam.viewcomparemerge.ActionOverride

See Also

ActionOverride Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection Class

A strongly-typed collection of ActionOverrides.

For a list of all members of this type, see ActionOverrideCollection Members.

System.Object
ArrayAdapter
ActionOverrideCollection

public class ActionOverrideCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ActionOverrideCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection Members

ActionOverrideCollection overview

Public Static Methods

Wrap Creates an ActionOverrideCollection to represent the given array of ActionOverride (from the com.starbase.starteam.viewcomparemerge namespace).

Public Static Type Conversions

Implicit ActionOverrideCollection to ActionOverride[] Conversion | Converts an ActionOverrideCollection to an array of ActionOverrides.
Implicit ActionOverrideCollection to ActionOverride[] Conversion | Converts an ActionOverrideCollection from the Borland.StarTeam.Viewcomparemerge namespace to an ActionOverride[] in the com.starbase.starteam.viewcomparemerge namespace.

Public Instance Constructors

ActionOverrideCollection Overloaded. Initializes a new instance of the ActionOverrideCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ActionOverride at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an ActionOverride to end of the collection.
Append | Overloaded. Appends the ActionOverrides of the given ActionOverrideCollection to the end of this ActionOverrideCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ActionOverride.
CopyTo | Copies all of the ActionOverrides in the ActionOverrideCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ActionOverride in the collection.
Insert | Inserts an ActionOverride into the collection at the specified position.
Remove | Removes the first occurrence of a specific ActionOverride from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ActionOverrides in this ActionOverrideCollection.
Sort | Sorts the ActionOverrides in this ActionOverrideCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection Constructor

Initializes an instance of the ActionOverrideCollection class.

Overload List

Initializes an instance of the ActionOverrideCollection class.

public ActionOverrideCollection();

Initializes an instance of the an ActionOverrideCollection class, copying the given array.

public ActionOverrideCollection(ActionOverride[]);

Initializes an instance of the an ActionOverrideCollection class, copying the given collection.

public ActionOverrideCollection(ActionOverrideCollection);

Initializes an instance of the an ActionOverrideCollection class, wrapping the given array of ActionOverride (from the com.starbase.starteam.viewcomparemerge namespace).

public ActionOverrideCollection(ActionOverride[]);

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection Constructor ()

Initializes an instance of the ActionOverrideCollection class.

public ActionOverrideCollection();

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ActionOverrideCollection Constructor Overload List


ActionOverrideCollection Constructor (ActionOverride[])

Initializes an instance of the an ActionOverrideCollection class, wrapping the given array of ActionOverride (from the com.starbase.starteam.viewcomparemerge namespace).

public ActionOverrideCollection(
ActionOverride[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam.viewcomparemerge namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ActionOverrideCollection Constructor Overload List | Wrap


ActionOverrideCollection Constructor (ActionOverrideCollection)

Initializes an instance of the an ActionOverrideCollection class, copying the given collection.

public ActionOverrideCollection(
ActionOverrideCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member ActionOverride objects of the original collection are shared, not copied.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ActionOverrideCollection Constructor Overload List


ActionOverrideCollection Constructor (ActionOverride[])

Initializes an instance of the an ActionOverrideCollection class, copying the given array.

public ActionOverrideCollection(
ActionOverride[] array
);

Parameters

array
The array to be copied.

Remarks

The member ActionOverride objects of the original array are shared, not copied.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ActionOverrideCollection Constructor Overload List


ActionOverrideCollection Properties

The properties of the ActionOverrideCollection class are listed below. For a complete list of ActionOverrideCollection class members, see the ActionOverrideCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ActionOverride at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Item Property

Borland StarTeam SDK for .NET

ActionOverrideCollection.Item Property

Gets or sets the ActionOverride at the specified index.

public ActionOverride this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the ActionOverride to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection Methods

The methods of the ActionOverrideCollection class are listed below. For a complete list of ActionOverrideCollection class members, see the ActionOverrideCollection Members topic.

Public Static Methods

Wrap Creates an ActionOverrideCollection to represent the given array of ActionOverride (from the com.starbase.starteam.viewcomparemerge namespace).

Public Instance Methods

Add | Adds an ActionOverride to end of the collection.
Append | Overloaded. Appends the ActionOverrides of the given ActionOverrideCollection to the end of this ActionOverrideCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ActionOverride.
CopyTo | Copies all of the ActionOverrides in the ActionOverrideCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ActionOverride in the collection.
Insert | Inserts an ActionOverride into the collection at the specified position.
Remove | Removes the first occurrence of a specific ActionOverride from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ActionOverrides in this ActionOverrideCollection.
Sort | Sorts the ActionOverrides in this ActionOverrideCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection.Add Method

Adds an ActionOverride to end of the collection.

public int Add(
ActionOverride value
);

Parameters

value
The ActionOverride to add to the collection.

Return Value

The position into which the new ActionOverride was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Append Method

Borland StarTeam SDK for .NET

ActionOverrideCollection.Append Method

Appends the ActionOverrides of the given array to the end of this ActionOverrideCollection.

Overload List

Appends the ActionOverrides of the given array to the end of this ActionOverrideCollection.

public ActionOverrideCollection Append(ActionOverride[]);

Appends the ActionOverrides of the given ActionOverrideCollection to the end of this ActionOverrideCollection.

public ActionOverrideCollection Append(ActionOverrideCollection);

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection.Append Method (ActionOverride[])

Appends the ActionOverrides of the given array to the end of this ActionOverrideCollection.

public ActionOverrideCollection Append(
ActionOverride[] array
);

Parameters

array
The array whose ActionOverrides are to be appended to this ActionOverrideCollection.

Return Value

This ActionOverrideCollection, modified to include the new ActionOverrides.

Remarks

The ActionOverrideCollection is modified to include the new members. The individual ActionOverride objects are shared, not copied.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ActionOverrideCollection.Append Overload List


ActionOverrideCollection.Append Method (ActionOverrideCollection)

Appends the ActionOverrides of the given ActionOverrideCollection to the end of this ActionOverrideCollection.

public ActionOverrideCollection Append(
ActionOverrideCollection collection
);

Parameters

collection
The ActionOverrideCollection whose ActionOverrides are to be appended to this ActionOverrideCollection.

Return Value

This ActionOverrideCollection, modified to include the new ActionOverrides.

Remarks

The ActionOverrideCollection is modified to include the new members. The individual ActionOverride objects are shared, not copied.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ActionOverrideCollection.Append Overload List


ActionOverrideCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.viewcomparemerge.ActionOverride[].

Implements

IWrapper.Unwrap

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection.Contains Method

Determines whether or not the collection contains a specific ActionOverride.

public bool Contains(
ActionOverride value
);

Parameters

value
The ActionOverride to locate in the collection.

Return Value

true if the ActionOverride is found in the collection; otherwise, false.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection.CopyTo Method

Copies all of the ActionOverrides in the ActionOverrideCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
ActionOverride[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the ActionOverrides copied from the ActionOverrideCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of ActionOverrides in the source ActionOverrideCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ActionOverrideCollection cannot be cast automatically to the type of the destination array.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection.IndexOf Method

Determines the index of a specific ActionOverride in the collection.

public int IndexOf(
ActionOverride value
);

Parameters

value
The ActionOverride to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection.Insert Method

Inserts an ActionOverride into the collection at the specified position.

public void Insert(
Int32 index,
ActionOverride value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The ActionOverride to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection.Remove Method

Removes the first occurrence of a specific ActionOverride from the collection.

public void Remove(
ActionOverride value
);

Parameters

value
The ActionOverride to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection.Reverse Method

Reverses the order of the ActionOverrides in this ActionOverrideCollection.

new public ActionOverrideCollection Reverse();

Return Value

This ActionOverrideCollection, modified such that the ActionOverrides are reversed.

Remarks

The ActionOverrideCollection is modified in place.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection.Sort Method

Sorts the ActionOverrides in this ActionOverrideCollection, using the given comparer.

new public ActionOverrideCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two ActionOverrides.

Return Value

This ActionOverrideCollection, modified such that the ActionOverrides are sorted.

Remarks

The ActionOverrideCollection is modified in place.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection.Wrap Method

Creates an ActionOverrideCollection to represent the given array of ActionOverride (from the com.starbase.starteam.viewcomparemerge namespace).

public static ActionOverrideCollection Wrap(
ActionOverride[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ActionOverrideCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an ActionOverride[] from the com.starbase.starteam.viewcomparemerge namespace to the Borland.StarTeam.Viewcomparemerge namespace.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection Type Conversions

The type conversions of the ActionOverrideCollection class are listed below. For a complete list of ActionOverrideCollection class members, see the ActionOverrideCollection Members topic.

Public Static Type Conversions

Implicit ActionOverrideCollection to ActionOverride[] Conversion | Converts an ActionOverrideCollection to an array of ActionOverrides.
Implicit ActionOverrideCollection to ActionOverride[] Conversion | Converts an ActionOverrideCollection from the Borland.StarTeam.Viewcomparemerge namespace to an ActionOverride[] in the com.starbase.starteam.viewcomparemerge namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ActionOverrideCollection Class | ActionOverrideCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection Implicit ActionOverrideCollection to ActionOverride[] Conversion

Converts an ActionOverrideCollection to an array of ActionOverrides.

public static implicit operator ActionOverride[](
ActionOverrideCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new ActionOverride wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one ActionOverride wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrideCollection Implicit ActionOverrideCollection to ActionOverride[] Conversion

Converts an ActionOverrideCollection from the Borland.StarTeam.Viewcomparemerge namespace to an ActionOverride[] in the com.starbase.starteam.viewcomparemerge namespace.

public static implicit operator ActionOverride[](
ActionOverrideCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam.Viewcomparemerge namespace to methods in the com.starbase.starteam.viewcomparemerge namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ActionOverrideCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ActionOverrideCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException Class

For a list of all members of this type, see AmbiguousMatchException Members.

System.Object
Exception
AmbiguousMatchException

public class AmbiguousMatchException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

AmbiguousMatchException Members | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException Members

AmbiguousMatchException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

Public Static Type Conversions

Implicit AmbiguousMatchException to AmbiguousMatchException Conversion Implicitly convert AmbiguousMatchException to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

Public Instance Constructors

AmbiguousMatchException Constructor Construct AmbiguousMatchException from com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsItemFromSourceView |
Item |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException Constructor

Construct AmbiguousMatchException from com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

public AmbiguousMatchException(
AmbiguousMatchException impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.AmbiguousMatchException to be wrapped.

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException Properties

The properties of the AmbiguousMatchException class are listed below. For a complete list of AmbiguousMatchException class members, see the AmbiguousMatchException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsItemFromSourceView |
Item |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


IsItemFromSourceView Property

Borland StarTeam SDK for .NET

AmbiguousMatchException.IsItemFromSourceView Property

public virtual Boolean IsItemFromSourceView {get;}

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


Item Property

Borland StarTeam SDK for .NET

AmbiguousMatchException.Item Property

public virtual Item Item {get;}

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException Methods

The methods of the AmbiguousMatchException class are listed below. For a complete list of AmbiguousMatchException class members, see the AmbiguousMatchException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.AmbiguousMatchException

Implements

IWrapper.Unwrap

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.Equals(obj).

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.GetHashCode().

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.ToString()

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

public static AmbiguousMatchException Wrap(
AmbiguousMatchException impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.AmbiguousMatchException to be wrapped.

Return Value

AmbiguousMatchException

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException Type Conversions

The type conversions of the AmbiguousMatchException class are listed below. For a complete list of AmbiguousMatchException class members, see the AmbiguousMatchException Members topic.

Public Static Type Conversions

Implicit AmbiguousMatchException to AmbiguousMatchException Conversion Implicitly convert AmbiguousMatchException to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

AmbiguousMatchException Class | AmbiguousMatchException Members | Borland.StarTeam.Viewcomparemerge Namespace


AmbiguousMatchException Implicit AmbiguousMatchException to AmbiguousMatchException Conversion

Implicitly convert AmbiguousMatchException to com.starbase.starteam.viewcomparemerge.AmbiguousMatchException.

public static implicit operator AmbiguousMatchException(
AmbiguousMatchException arg
);

Parameters

arg
AmbiguousMatchException to convert.

Return Value

com.starbase.starteam.viewcomparemerge.AmbiguousMatchException

See Also

AmbiguousMatchException Class | Borland.StarTeam.Viewcomparemerge Namespace


AnyScope Class

Combines multiple scopes. An item is considered in scope if it is included in at least one member scope.

For a list of all members of this type, see AnyScope Members.

System.Object
Scope
AnyScope

public class AnyScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

AnyScope Members | Borland.StarTeam.Viewcomparemerge Namespace


AnyScope Members

AnyScope overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.AnyScope.

Public Static Type Conversions

Implicit AnyScope to AnyScope Conversion Implicitly convert AnyScope to com.starbase.starteam.viewcomparemerge.AnyScope.

Public Instance Constructors

AnyScope Overloaded. Initializes a new instance of the AnyScope class.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

AnyScope Class | Borland.StarTeam.Viewcomparemerge Namespace


AnyScope Constructor

Construct AnyScope from com.starbase.starteam.viewcomparemerge.AnyScope.

Overload List

Creates an empty scope.

public AnyScope();

Creates a scope that initially contains the given members.

public AnyScope(ScopeCollection);

Construct AnyScope from com.starbase.starteam.viewcomparemerge.AnyScope.

public AnyScope(AnyScope);

See Also

AnyScope Class | Borland.StarTeam.Viewcomparemerge Namespace


AnyScope Constructor (AnyScope)

Construct AnyScope from com.starbase.starteam.viewcomparemerge.AnyScope.

public AnyScope(
AnyScope impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.AnyScope to be wrapped.

See Also

AnyScope Class | Borland.StarTeam.Viewcomparemerge Namespace | AnyScope Constructor Overload List


AnyScope Constructor ()

Creates an empty scope.

public AnyScope();

See Also

AnyScope Class | Borland.StarTeam.Viewcomparemerge Namespace | AnyScope Constructor Overload List


AnyScope Constructor (ScopeCollection)

Creates a scope that initially contains the given members.

public AnyScope(
ScopeCollection scopes
);

Parameters

scopes

See Also

AnyScope Class | Borland.StarTeam.Viewcomparemerge Namespace | AnyScope Constructor Overload List


AnyScope Methods

The methods of the AnyScope class are listed below. For a complete list of AnyScope class members, see the AnyScope Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.AnyScope.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

AnyScope Class | Borland.StarTeam.Viewcomparemerge Namespace


AnyScope.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.AnyScope.

public static AnyScope Wrap(
AnyScope impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.AnyScope to be wrapped.

Return Value

AnyScope

See Also

AnyScope Class | Borland.StarTeam.Viewcomparemerge Namespace


AnyScope Type Conversions

The type conversions of the AnyScope class are listed below. For a complete list of AnyScope class members, see the AnyScope Members topic.

Public Static Type Conversions

Implicit AnyScope to AnyScope Conversion Implicitly convert AnyScope to com.starbase.starteam.viewcomparemerge.AnyScope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

AnyScope Class | AnyScope Members | Borland.StarTeam.Viewcomparemerge Namespace


AnyScope Implicit AnyScope to AnyScope Conversion

Implicitly convert AnyScope to com.starbase.starteam.viewcomparemerge.AnyScope.

public static implicit operator AnyScope(
AnyScope arg
);

Parameters

arg
AnyScope to convert.

Return Value

com.starbase.starteam.viewcomparemerge.AnyScope

See Also

AnyScope Class | Borland.StarTeam.Viewcomparemerge Namespace


Custom3WayMergeAdapter Class

Facilitates the use of an external merge tool to resolve a 3-way file merge condition. For example:

 String app = "C:\\MyApp\\MyApp.exe"; String commandline = "-s $source -t $target -a $ancestor -out $result"; FileMergeAdapter tool = new Custom3WayMergeAdapter(diff, app, commandline); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("MyApp failed with exit code: " + exitCode); }

For a list of all members of this type, see Custom3WayMergeAdapter Members.

System.Object
FileMergeAdapter
Custom3WayMergeAdapter

public class Custom3WayMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Custom3WayMergeAdapter Members | Borland.StarTeam.Viewcomparemerge Namespace


Custom3WayMergeAdapter Members

Custom3WayMergeAdapter overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter.

Public Static Type Conversions

Implicit Custom3WayMergeAdapter to Custom3WayMergeAdapter Conversion Implicitly convert Custom3WayMergeAdapter to com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter.

Public Instance Constructors

Custom3WayMergeAdapter Overloaded. Initializes a new instance of the Custom3WayMergeAdapter class.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

Custom3WayMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


Custom3WayMergeAdapter Constructor

Construct Custom3WayMergeAdapter from com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter.

Overload List

Constructs an adapter for resolving a given file merge condition.

public Custom3WayMergeAdapter(ItemDifference,String,String);

Construct Custom3WayMergeAdapter from com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter.

public Custom3WayMergeAdapter(Custom3WayMergeAdapter);

See Also

Custom3WayMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


Custom3WayMergeAdapter Constructor (Custom3WayMergeAdapter)

Construct Custom3WayMergeAdapter from com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter.

public Custom3WayMergeAdapter(
Custom3WayMergeAdapter impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter to be wrapped.

See Also

Custom3WayMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace | Custom3WayMergeAdapter Constructor Overload List


Custom3WayMergeAdapter Constructor (ItemDifference, String, String)

Constructs an adapter for resolving a given file merge condition.

public Custom3WayMergeAdapter(
ItemDifference diff,
String application,
String commandline
);

Parameters

diff
The ItemDifference whose file merge condition is to be resolved.
application
The path to the external application to be run.
commandline
The paramaters to be passed to the application on the command line. May contain the special command-line symbols defined in FileMergeAdapter, which are expanded to file names before the application is executed.

See Also

Custom3WayMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace | Custom3WayMergeAdapter Constructor Overload List | PARAM_SOURCE_FILE | PARAM_TARGET_FILE | PARAM_COMMON_ANCESTOR | PARAM_OUTPUT_FILE


Custom3WayMergeAdapter Methods

The methods of the Custom3WayMergeAdapter class are listed below. For a complete list of Custom3WayMergeAdapter class members, see the Custom3WayMergeAdapter Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

Custom3WayMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


Custom3WayMergeAdapter.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter.

public static Custom3WayMergeAdapter Wrap(
Custom3WayMergeAdapter impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter to be wrapped.

Return Value

Custom3WayMergeAdapter

See Also

Custom3WayMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


Custom3WayMergeAdapter Type Conversions

The type conversions of the Custom3WayMergeAdapter class are listed below. For a complete list of Custom3WayMergeAdapter class members, see the Custom3WayMergeAdapter Members topic.

Public Static Type Conversions

Implicit Custom3WayMergeAdapter to Custom3WayMergeAdapter Conversion Implicitly convert Custom3WayMergeAdapter to com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

Custom3WayMergeAdapter Class | Custom3WayMergeAdapter Members | Borland.StarTeam.Viewcomparemerge Namespace


Custom3WayMergeAdapter Implicit Custom3WayMergeAdapter to Custom3WayMergeAdapter Conversion

Implicitly convert Custom3WayMergeAdapter to com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter.

public static implicit operator Custom3WayMergeAdapter(
Custom3WayMergeAdapter arg
);

Parameters

arg
Custom3WayMergeAdapter to convert.

Return Value

com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter

See Also

Custom3WayMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIterator Interface

Iterates over a set of ItemDifferences. Used as follows:

 DifferenceIterator itr = session.getDifferences(); while (itr.hasMoreDifferences()) { ItemDifference diff = itr.nextDifference(); . . . }

For a list of all members of this type, see DifferenceIterator Members.

public interface DifferenceIterator : IEnumerable

Types that implement DifferenceIterator

Type | Description
DifferenceIteratorAdapter |

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DifferenceIterator Members | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIterator Members

DifferenceIterator overview

Public Instance Methods

HasMoreDifferences | Tests if this ItemDifference iterator contains more elements.
NextDifference | Gets the next ItemDifference in this iterator, and advances the iterator to the next element.

See Also

DifferenceIterator Interface | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIterator Methods

The methods of the DifferenceIterator interface are listed below. For a complete list of DifferenceIterator interface members, see the DifferenceIterator Members topic.

Public Instance Methods

HasMoreDifferences | Tests if this ItemDifference iterator contains more elements.
NextDifference | Gets the next ItemDifference in this iterator, and advances the iterator to the next element.

See Also

DifferenceIterator Interface | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIterator.HasMoreDifferences Method

Tests if this ItemDifference iterator contains more elements.

bool HasMoreDifferences();

Return Value

True if this ItemDifference iterator contains at least one more element; false otherwise.

See Also

DifferenceIterator Interface | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIterator.NextDifference Method

Gets the next ItemDifference in this iterator, and advances the iterator to the next element.

ItemDifference NextDifference();

Return Value

The next ItemDifference in this iterator.

See Also

DifferenceIterator Interface | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIteratorAdapter Class

For a list of all members of this type, see DifferenceIteratorAdapter Members.

System.Object
DifferenceIteratorAdapter

public class DifferenceIteratorAdapter : DifferenceIterator, IEnumerable, DifferenceIterator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DifferenceIteratorAdapter Members | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIteratorAdapter Members

DifferenceIteratorAdapter overview

Public Instance Constructors

DifferenceIteratorAdapter Overloaded. Initializes a new instance of the DifferenceIteratorAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Gets an enumerator that can iterate through ItemDifferences.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

DifferenceIterator.hasMoreDifferences
DifferenceIterator.HasMoreDifferences
DifferenceIterator.nextDifference
DifferenceIterator.NextDifference

See Also

DifferenceIteratorAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIteratorAdapter Constructor

Overload List

public DifferenceIteratorAdapter(DifferenceIterator);

public DifferenceIteratorAdapter(DifferenceIterator);

See Also

DifferenceIteratorAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIteratorAdapter Constructor (DifferenceIterator)

public DifferenceIteratorAdapter(
DifferenceIterator arg
);

See Also

DifferenceIteratorAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace | DifferenceIteratorAdapter Constructor Overload List


DifferenceIteratorAdapter Methods

The methods of the DifferenceIteratorAdapter class are listed below. For a complete list of DifferenceIteratorAdapter class members, see the DifferenceIteratorAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Gets an enumerator that can iterate through ItemDifferences.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

DifferenceIterator.hasMoreDifferences
DifferenceIterator.HasMoreDifferences
DifferenceIterator.nextDifference
DifferenceIterator.NextDifference

See Also

DifferenceIteratorAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIteratorAdapter.DifferenceIterator.HasMoreDifferences Method

bool DifferenceIterator.HasMoreDifferences();

Implements

DifferenceIterator.HasMoreDifferences

See Also

DifferenceIteratorAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIteratorAdapter.DifferenceIterator.NextDifference Method

ItemDifference DifferenceIterator.NextDifference();

Implements

DifferenceIterator.NextDifference

See Also

DifferenceIteratorAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIteratorAdapter.DifferenceIterator.hasMoreDifferences Method

bool DifferenceIterator.hasMoreDifferences();

Implements

DifferenceIterator.hasMoreDifferences

See Also

DifferenceIteratorAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIteratorAdapter.DifferenceIterator.nextDifference Method

ItemDifference DifferenceIterator.nextDifference();

Implements

DifferenceIterator.nextDifference

See Also

DifferenceIteratorAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceIteratorAdapter.GetEnumerator Method

Gets an enumerator that can iterate through ItemDifferences.

public IEnumerator GetEnumerator();

Return Value

An IEnumerator that can iterate through ItemDifferences.

Implements

IEnumerable.GetEnumerator

See Also

DifferenceIteratorAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType Class

Classifies the relationship between a source item and a target item.

For a list of all members of this type, see DifferenceType Members.

System.Object
DifferenceType

public class DifferenceType : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DifferenceType Members | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType Members

DifferenceType overview

Public Static Properties

All [read] A list of all defined DifferenceTypes.

Public Static Methods

Lookup | Searches the list of known difference types, returning the one that describes the given match state.
Wrap | Dynamically wraps com.starbase.starteam.viewcomparemerge.DifferenceType.

Public Static Type Conversions

Implicit DifferenceType to DifferenceType Conversion Implicitly convert DifferenceType to com.starbase.starteam.viewcomparemerge.DifferenceType.

Public Instance Constructors

DifferenceType Constructor Construct DifferenceType from com.starbase.starteam.viewcomparemerge.DifferenceType.

Public Instance Properties

DefaultAction | [read] The default action for this difference type.
Description | [read] A description of this DifferenceType.
ID | [read] The unique ID associated with this DifferenceType.
IsDifference | [read] True if this difference type should really be considered a difference; false otherwise.
LegalActions | [read] The set of legal actions for a given merge type.
MatchState | [read] A copy of the MatchState associated with this DifferenceType.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.DifferenceType.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.DifferenceType.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalAction | Determines whether or not the given action is a legal action for this difference type.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.DifferenceType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType Constructor

Construct DifferenceType from com.starbase.starteam.viewcomparemerge.DifferenceType.

public DifferenceType(
DifferenceType impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.DifferenceType to be wrapped.

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType Properties

The properties of the DifferenceType class are listed below. For a complete list of DifferenceType class members, see the DifferenceType Members topic.

Public Static Properties

All [read] A list of all defined DifferenceTypes.

Public Instance Properties

DefaultAction | [read] The default action for this difference type.
Description | [read] A description of this DifferenceType.
ID | [read] The unique ID associated with this DifferenceType.
IsDifference | [read] True if this difference type should really be considered a difference; false otherwise.
LegalActions | [read] The set of legal actions for a given merge type.
MatchState | [read] A copy of the MatchState associated with this DifferenceType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


All Property

Borland StarTeam SDK for .NET

DifferenceType.All Property

[read] A list of all defined DifferenceTypes.

public static DifferenceTypeCollection All {get;}

Property Value

A list of all defined DifferenceTypes.

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DefaultAction Property

Borland StarTeam SDK for .NET

DifferenceType.DefaultAction Property

[read] The default action for this difference type.

public virtual MergeAction DefaultAction {get;}

Property Value

The default action for this difference type.

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


Description Property

Borland StarTeam SDK for .NET

DifferenceType.Description Property

[read] A description of this DifferenceType.

public virtual String Description {get;}

Property Value

A description of this DifferenceType.

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


ID Property

Borland StarTeam SDK for .NET

DifferenceType.ID Property

[read] The unique ID associated with this DifferenceType.

public virtual Int32 ID {get;}

Property Value

The unique ID associated with this DifferenceType.

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


IsDifference Property

Borland StarTeam SDK for .NET

DifferenceType.IsDifference Property

[read] True if this difference type should really be considered a difference; false otherwise.

public virtual Boolean IsDifference {get;}

Property Value

True if this difference type should really be considered a difference; false otherwise.

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


LegalActions Property

Borland StarTeam SDK for .NET

DifferenceType.LegalActions Property

[read] The set of legal actions for a given merge type.

public virtual MergeActionCollection LegalActions {get;}

Property Value

The set of legal actions for a given merge type.

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState Property

Borland StarTeam SDK for .NET

DifferenceType.MatchState Property

[read] A copy of the MatchState associated with this DifferenceType.

public virtual MatchState MatchState {get;}

Property Value

A copy of the MatchState associated with this DifferenceType.

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType Methods

The methods of the DifferenceType class are listed below. For a complete list of DifferenceType class members, see the DifferenceType Members topic.

Public Static Methods

Lookup | Searches the list of known difference types, returning the one that describes the given match state.
Wrap | Dynamically wraps com.starbase.starteam.viewcomparemerge.DifferenceType.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.DifferenceType.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.DifferenceType.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalAction | Determines whether or not the given action is a legal action for this difference type.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.DifferenceType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.DifferenceType

Implements

IWrapper.Unwrap

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.DifferenceType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.DifferenceType.Equals(obj).

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.DifferenceType.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.DifferenceType.GetHashCode().

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType.IsLegalAction Method

Determines whether or not the given action is a legal action for this difference type.

public virtual bool IsLegalAction(
MergeAction action
);

Parameters

action
The MergeAction to be tested.

Return Value

True if the action is legal for this difference type; false otherwise.

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType.Lookup Method

Searches the list of known difference types, returning the one that describes the given match state.

public static DifferenceType Lookup(
MatchState state
);

Parameters

state

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.DifferenceType.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.DifferenceType.ToString()

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.DifferenceType.

public static DifferenceType Wrap(
DifferenceType impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.DifferenceType to be wrapped.

Return Value

DifferenceType

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType Type Conversions

The type conversions of the DifferenceType class are listed below. For a complete list of DifferenceType class members, see the DifferenceType Members topic.

Public Static Type Conversions

Implicit DifferenceType to DifferenceType Conversion Implicitly convert DifferenceType to com.starbase.starteam.viewcomparemerge.DifferenceType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

DifferenceType Class | DifferenceType Members | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType Implicit DifferenceType to DifferenceType Conversion

Implicitly convert DifferenceType to com.starbase.starteam.viewcomparemerge.DifferenceType.

public static implicit operator DifferenceType(
DifferenceType arg
);

Parameters

arg
DifferenceType to convert.

Return Value

com.starbase.starteam.viewcomparemerge.DifferenceType

See Also

DifferenceType Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection Class

A strongly-typed collection of DifferenceTypes.

For a list of all members of this type, see DifferenceTypeCollection Members.

System.Object
ArrayAdapter
DifferenceTypeCollection

public class DifferenceTypeCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

DifferenceTypeCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection Members

DifferenceTypeCollection overview

Public Static Methods

Wrap Creates a DifferenceTypeCollection to represent the given array of DifferenceType (from the com.starbase.starteam.viewcomparemerge namespace).

Public Static Type Conversions

Implicit DifferenceTypeCollection to DifferenceType[] Conversion | Converts a DifferenceTypeCollection to an array of DifferenceTypes.
Implicit DifferenceTypeCollection to DifferenceType[] Conversion | Converts a DifferenceTypeCollection from the Borland.StarTeam.Viewcomparemerge namespace to a DifferenceType[] in the com.starbase.starteam.viewcomparemerge namespace.

Public Instance Constructors

DifferenceTypeCollection Overloaded. Initializes a new instance of the DifferenceTypeCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the DifferenceType at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a DifferenceType to end of the collection.
Append | Overloaded. Appends the DifferenceTypes of the given DifferenceTypeCollection to the end of this DifferenceTypeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific DifferenceType.
CopyTo | Copies all of the DifferenceTypes in the DifferenceTypeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the DifferenceType with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific DifferenceType in the collection.
Insert | Inserts a DifferenceType into the collection at the specified position.
Remove | Removes the first occurrence of a specific DifferenceType from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the DifferenceTypes in this DifferenceTypeCollection.
Sort | Sorts the DifferenceTypes in this DifferenceTypeCollection, using the given comparer.
SortByID | Sorts the DifferenceTypes in this DifferenceTypeCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection Constructor

Initializes an instance of the DifferenceTypeCollection class.

Overload List

Initializes an instance of the DifferenceTypeCollection class.

public DifferenceTypeCollection();

Initializes an instance of the a DifferenceTypeCollection class, copying the given array.

public DifferenceTypeCollection(DifferenceType[]);

Initializes an instance of the a DifferenceTypeCollection class, copying the given collection.

public DifferenceTypeCollection(DifferenceTypeCollection);

Initializes an instance of the a DifferenceTypeCollection class, wrapping the given array of DifferenceType (from the com.starbase.starteam.viewcomparemerge namespace).

public DifferenceTypeCollection(DifferenceType[]);

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection Constructor ()

Initializes an instance of the DifferenceTypeCollection class.

public DifferenceTypeCollection();

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | DifferenceTypeCollection Constructor Overload List


DifferenceTypeCollection Constructor (DifferenceType[])

Initializes an instance of the a DifferenceTypeCollection class, wrapping the given array of DifferenceType (from the com.starbase.starteam.viewcomparemerge namespace).

public DifferenceTypeCollection(
DifferenceType[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam.viewcomparemerge namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | DifferenceTypeCollection Constructor Overload List | Wrap


DifferenceTypeCollection Constructor (DifferenceTypeCollection)

Initializes an instance of the a DifferenceTypeCollection class, copying the given collection.

public DifferenceTypeCollection(
DifferenceTypeCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member DifferenceType objects of the original collection are shared, not copied.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | DifferenceTypeCollection Constructor Overload List


DifferenceTypeCollection Constructor (DifferenceType[])

Initializes an instance of the a DifferenceTypeCollection class, copying the given array.

public DifferenceTypeCollection(
DifferenceType[] array
);

Parameters

array
The array to be copied.

Remarks

The member DifferenceType objects of the original array are shared, not copied.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | DifferenceTypeCollection Constructor Overload List


DifferenceTypeCollection Properties

The properties of the DifferenceTypeCollection class are listed below. For a complete list of DifferenceTypeCollection class members, see the DifferenceTypeCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the DifferenceType at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Item Property

Borland StarTeam SDK for .NET

DifferenceTypeCollection.Item Property

Gets or sets the DifferenceType at the specified index.

public DifferenceType this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the DifferenceType to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection Methods

The methods of the DifferenceTypeCollection class are listed below. For a complete list of DifferenceTypeCollection class members, see the DifferenceTypeCollection Members topic.

Public Static Methods

Wrap Creates a DifferenceTypeCollection to represent the given array of DifferenceType (from the com.starbase.starteam.viewcomparemerge namespace).

Public Instance Methods

Add | Adds a DifferenceType to end of the collection.
Append | Overloaded. Appends the DifferenceTypes of the given DifferenceTypeCollection to the end of this DifferenceTypeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific DifferenceType.
CopyTo | Copies all of the DifferenceTypes in the DifferenceTypeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the DifferenceType with the given ID.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific DifferenceType in the collection.
Insert | Inserts a DifferenceType into the collection at the specified position.
Remove | Removes the first occurrence of a specific DifferenceType from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the DifferenceTypes in this DifferenceTypeCollection.
Sort | Sorts the DifferenceTypes in this DifferenceTypeCollection, using the given comparer.
SortByID | Sorts the DifferenceTypes in this DifferenceTypeCollection by ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.Add Method

Adds a DifferenceType to end of the collection.

public int Add(
DifferenceType value
);

Parameters

value
The DifferenceType to add to the collection.

Return Value

The position into which the new DifferenceType was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Append Method

Borland StarTeam SDK for .NET

DifferenceTypeCollection.Append Method

Appends the DifferenceTypes of the given array to the end of this DifferenceTypeCollection.

Overload List

Appends the DifferenceTypes of the given array to the end of this DifferenceTypeCollection.

public DifferenceTypeCollection Append(DifferenceType[]);

Appends the DifferenceTypes of the given DifferenceTypeCollection to the end of this DifferenceTypeCollection.

public DifferenceTypeCollection Append(DifferenceTypeCollection);

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.Append Method (DifferenceType[])

Appends the DifferenceTypes of the given array to the end of this DifferenceTypeCollection.

public DifferenceTypeCollection Append(
DifferenceType[] array
);

Parameters

array
The array whose DifferenceTypes are to be appended to this DifferenceTypeCollection.

Return Value

This DifferenceTypeCollection, modified to include the new DifferenceTypes.

Remarks

The DifferenceTypeCollection is modified to include the new members. The individual DifferenceType objects are shared, not copied.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | DifferenceTypeCollection.Append Overload List


DifferenceTypeCollection.Append Method (DifferenceTypeCollection)

Appends the DifferenceTypes of the given DifferenceTypeCollection to the end of this DifferenceTypeCollection.

public DifferenceTypeCollection Append(
DifferenceTypeCollection collection
);

Parameters

collection
The DifferenceTypeCollection whose DifferenceTypes are to be appended to this DifferenceTypeCollection.

Return Value

This DifferenceTypeCollection, modified to include the new DifferenceTypes.

Remarks

The DifferenceTypeCollection is modified to include the new members. The individual DifferenceType objects are shared, not copied.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | DifferenceTypeCollection.Append Overload List


DifferenceTypeCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.viewcomparemerge.DifferenceType[].

Implements

IWrapper.Unwrap

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.Contains Method

Determines whether or not the collection contains a specific DifferenceType.

public bool Contains(
DifferenceType value
);

Parameters

value
The DifferenceType to locate in the collection.

Return Value

true if the DifferenceType is found in the collection; otherwise, false.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.CopyTo Method

Copies all of the DifferenceTypes in the DifferenceTypeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
DifferenceType[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the DifferenceTypes copied from the DifferenceTypeCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of DifferenceTypes in the source DifferenceTypeCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source DifferenceTypeCollection cannot be cast automatically to the type of the destination array.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.FindByID Method

Finds the DifferenceType with the given ID.

public DifferenceType FindByID(
Int32 id
);

Parameters

id
The ID of the DifferenceType to be found.

Return Value

The DifferenceType with the given ID, or null if there is no DifferenceType with that ID in this DifferenceTypeCollection.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.IndexOf Method

Determines the index of a specific DifferenceType in the collection.

public int IndexOf(
DifferenceType value
);

Parameters

value
The DifferenceType to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.Insert Method

Inserts a DifferenceType into the collection at the specified position.

public void Insert(
Int32 index,
DifferenceType value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The DifferenceType to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.Remove Method

Removes the first occurrence of a specific DifferenceType from the collection.

public void Remove(
DifferenceType value
);

Parameters

value
The DifferenceType to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.Reverse Method

Reverses the order of the DifferenceTypes in this DifferenceTypeCollection.

new public DifferenceTypeCollection Reverse();

Return Value

This DifferenceTypeCollection, modified such that the DifferenceTypes are reversed.

Remarks

The DifferenceTypeCollection is modified in place.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.Sort Method

Sorts the DifferenceTypes in this DifferenceTypeCollection, using the given comparer.

new public DifferenceTypeCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two DifferenceTypes.

Return Value

This DifferenceTypeCollection, modified such that the DifferenceTypes are sorted.

Remarks

The DifferenceTypeCollection is modified in place.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.SortByID Method

Sorts the DifferenceTypes in this DifferenceTypeCollection by ID.

public DifferenceTypeCollection SortByID();

Return Value

This DifferenceTypeCollection, modified such that the DifferenceTypes are sorted by ID.

Remarks

The DifferenceTypeCollection is modified in place.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection.Wrap Method

Creates a DifferenceTypeCollection to represent the given array of DifferenceType (from the com.starbase.starteam.viewcomparemerge namespace).

public static DifferenceTypeCollection Wrap(
DifferenceType[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new DifferenceTypeCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a DifferenceType[] from the com.starbase.starteam.viewcomparemerge namespace to the Borland.StarTeam.Viewcomparemerge namespace.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection Type Conversions

The type conversions of the DifferenceTypeCollection class are listed below. For a complete list of DifferenceTypeCollection class members, see the DifferenceTypeCollection Members topic.

Public Static Type Conversions

Implicit DifferenceTypeCollection to DifferenceType[] Conversion | Converts a DifferenceTypeCollection to an array of DifferenceTypes.
Implicit DifferenceTypeCollection to DifferenceType[] Conversion | Converts a DifferenceTypeCollection from the Borland.StarTeam.Viewcomparemerge namespace to a DifferenceType[] in the com.starbase.starteam.viewcomparemerge namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

DifferenceTypeCollection Class | DifferenceTypeCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection Implicit DifferenceTypeCollection to DifferenceType[] Conversion

Converts a DifferenceTypeCollection to an array of DifferenceTypes.

public static implicit operator DifferenceType[](
DifferenceTypeCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new DifferenceType wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one DifferenceType wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceTypeCollection Implicit DifferenceTypeCollection to DifferenceType[] Conversion

Converts a DifferenceTypeCollection from the Borland.StarTeam.Viewcomparemerge namespace to a DifferenceType[] in the com.starbase.starteam.viewcomparemerge namespace.

public static implicit operator DifferenceType[](
DifferenceTypeCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam.Viewcomparemerge namespace to methods in the com.starbase.starteam.viewcomparemerge namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, DifferenceTypeCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

DifferenceTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


EveryScope Class

Combines multiple scopes. An item is considered in scope if it is included in every member scope.

For a list of all members of this type, see EveryScope Members.

System.Object
Scope
EveryScope

public class EveryScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

EveryScope Members | Borland.StarTeam.Viewcomparemerge Namespace


EveryScope Members

EveryScope overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.EveryScope.

Public Static Type Conversions

Implicit EveryScope to EveryScope Conversion Implicitly convert EveryScope to com.starbase.starteam.viewcomparemerge.EveryScope.

Public Instance Constructors

EveryScope Overloaded. Initializes a new instance of the EveryScope class.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

EveryScope Class | Borland.StarTeam.Viewcomparemerge Namespace


EveryScope Constructor

Construct EveryScope from com.starbase.starteam.viewcomparemerge.EveryScope.

Overload List

Creates an empty scope.

public EveryScope();

Creates a scope that initially contains the given members.

public EveryScope(ScopeCollection);

Construct EveryScope from com.starbase.starteam.viewcomparemerge.EveryScope.

public EveryScope(EveryScope);

See Also

EveryScope Class | Borland.StarTeam.Viewcomparemerge Namespace


EveryScope Constructor (EveryScope)

Construct EveryScope from com.starbase.starteam.viewcomparemerge.EveryScope.

public EveryScope(
EveryScope impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.EveryScope to be wrapped.

See Also

EveryScope Class | Borland.StarTeam.Viewcomparemerge Namespace | EveryScope Constructor Overload List


EveryScope Constructor ()

Creates an empty scope.

public EveryScope();

See Also

EveryScope Class | Borland.StarTeam.Viewcomparemerge Namespace | EveryScope Constructor Overload List


EveryScope Constructor (ScopeCollection)

Creates a scope that initially contains the given members.

public EveryScope(
ScopeCollection scopes
);

Parameters

scopes

See Also

EveryScope Class | Borland.StarTeam.Viewcomparemerge Namespace | EveryScope Constructor Overload List


EveryScope Methods

The methods of the EveryScope class are listed below. For a complete list of EveryScope class members, see the EveryScope Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.EveryScope.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

EveryScope Class | Borland.StarTeam.Viewcomparemerge Namespace


EveryScope.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.EveryScope.

public static EveryScope Wrap(
EveryScope impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.EveryScope to be wrapped.

Return Value

EveryScope

See Also

EveryScope Class | Borland.StarTeam.Viewcomparemerge Namespace


EveryScope Type Conversions

The type conversions of the EveryScope class are listed below. For a complete list of EveryScope class members, see the EveryScope Members topic.

Public Static Type Conversions

Implicit EveryScope to EveryScope Conversion Implicitly convert EveryScope to com.starbase.starteam.viewcomparemerge.EveryScope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

EveryScope Class | EveryScope Members | Borland.StarTeam.Viewcomparemerge Namespace


EveryScope Implicit EveryScope to EveryScope Conversion

Implicitly convert EveryScope to com.starbase.starteam.viewcomparemerge.EveryScope.

public static implicit operator EveryScope(
EveryScope arg
);

Parameters

arg
EveryScope to convert.

Return Value

com.starbase.starteam.viewcomparemerge.EveryScope

See Also

EveryScope Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter Class

An abstract class designed to facilitate the use of an external tool for resolving a file merge condition.

For a list of all members of this type, see FileMergeAdapter Members.

System.Object
FileMergeAdapter
Custom3WayMergeAdapter
StarTeamFileMergeAdapter
VisMergeAdapter
WorkstationDefaultMergeAdapter

public class FileMergeAdapter : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileMergeAdapter Members | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter Members

FileMergeAdapter overview

Public Static Properties

PARAM_COMMON_ANCESTOR
PARAM_OUTPUT_FILE
PARAM_SOURCE_ANCESTOR
PARAM_SOURCE_FILE
PARAM_TARGET_ANCESTOR
PARAM_TARGET_FILE

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Public Static Type Conversions

Implicit FileMergeAdapter to FileMergeAdapter Conversion Implicitly convert FileMergeAdapter to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Public Instance Constructors

FileMergeAdapter Constructor Construct FileMergeAdapter from com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter Constructor

Construct FileMergeAdapter from com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

public FileMergeAdapter(
FileMergeAdapter impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.FileMergeAdapter to be wrapped.

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter Properties

The properties of the FileMergeAdapter class are listed below. For a complete list of FileMergeAdapter class members, see the FileMergeAdapter Members topic.

Public Static Properties

PARAM_COMMON_ANCESTOR
PARAM_OUTPUT_FILE
PARAM_SOURCE_ANCESTOR
PARAM_SOURCE_FILE
PARAM_TARGET_ANCESTOR
PARAM_TARGET_FILE

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


PARAM_COMMON_ANCESTOR Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_COMMON_ANCESTOR Property

public static String PARAM_COMMON_ANCESTOR {get;}

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


PARAM_OUTPUT_FILE Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_OUTPUT_FILE Property

public static String PARAM_OUTPUT_FILE {get;}

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


PARAM_SOURCE_ANCESTOR Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_SOURCE_ANCESTOR Property

public static String PARAM_SOURCE_ANCESTOR {get;}

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


PARAM_SOURCE_FILE Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_SOURCE_FILE Property

public static String PARAM_SOURCE_FILE {get;}

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


PARAM_TARGET_ANCESTOR Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_TARGET_ANCESTOR Property

public static String PARAM_TARGET_ANCESTOR {get;}

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


PARAM_TARGET_FILE Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_TARGET_FILE Property

public static String PARAM_TARGET_FILE {get;}

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter Methods

The methods of the FileMergeAdapter class are listed below. For a complete list of FileMergeAdapter class members, see the FileMergeAdapter Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.FileMergeAdapter

Implements

IWrapper.Unwrap

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.FileMergeAdapter.Equals(obj).

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.FileMergeAdapter.GetHashCode().

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter.Merge Method

Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference.

If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved.

Any temporary files created during the process are automatically removed.

public virtual int Merge();

Return Value

The tool's exit code. Zero on success.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.FileMergeAdapter.ToString()

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

public static FileMergeAdapter Wrap(
FileMergeAdapter impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.FileMergeAdapter to be wrapped.

Return Value

FileMergeAdapter

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter Type Conversions

The type conversions of the FileMergeAdapter class are listed below. For a complete list of FileMergeAdapter class members, see the FileMergeAdapter Members topic.

Public Static Type Conversions

Implicit FileMergeAdapter to FileMergeAdapter Conversion Implicitly convert FileMergeAdapter to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileMergeAdapter Class | FileMergeAdapter Members | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeAdapter Implicit FileMergeAdapter to FileMergeAdapter Conversion

Implicitly convert FileMergeAdapter to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

public static implicit operator FileMergeAdapter(
FileMergeAdapter arg
);

Parameters

arg
FileMergeAdapter to convert.

Return Value

com.starbase.starteam.viewcomparemerge.FileMergeAdapter

See Also

FileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException Class

For a list of all members of this type, see FileMergeException Members.

System.Object
Exception
FileMergeException

public class FileMergeException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FileMergeException Members | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException Members

FileMergeException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.FileMergeException.

Public Static Type Conversions

Implicit FileMergeException to FileMergeException Conversion Implicitly convert FileMergeException to com.starbase.starteam.viewcomparemerge.FileMergeException.

Public Instance Constructors

FileMergeException Constructor Construct FileMergeException from com.starbase.starteam.viewcomparemerge.FileMergeException.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
ItemDifference |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException Constructor

Construct FileMergeException from com.starbase.starteam.viewcomparemerge.FileMergeException.

public FileMergeException(
FileMergeException impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.FileMergeException to be wrapped.

See Also

FileMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException Properties

The properties of the FileMergeException class are listed below. For a complete list of FileMergeException class members, see the FileMergeException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
ItemDifference |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference Property

Borland StarTeam SDK for .NET

FileMergeException.ItemDifference Property

public virtual ItemDifference ItemDifference {get;}

See Also

FileMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException Methods

The methods of the FileMergeException class are listed below. For a complete list of FileMergeException class members, see the FileMergeException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.FileMergeException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.FileMergeException

Implements

IWrapper.Unwrap

See Also

FileMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.FileMergeException.Equals(obj).

See Also

FileMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeException.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.FileMergeException.GetHashCode().

See Also

FileMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeException.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.FileMergeException.ToString()

See Also

FileMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.FileMergeException.

public static FileMergeException Wrap(
FileMergeException impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.FileMergeException to be wrapped.

Return Value

FileMergeException

See Also

FileMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException Type Conversions

The type conversions of the FileMergeException class are listed below. For a complete list of FileMergeException class members, see the FileMergeException Members topic.

Public Static Type Conversions

Implicit FileMergeException to FileMergeException Conversion Implicitly convert FileMergeException to com.starbase.starteam.viewcomparemerge.FileMergeException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

FileMergeException Class | FileMergeException Members | Borland.StarTeam.Viewcomparemerge Namespace


FileMergeException Implicit FileMergeException to FileMergeException Conversion

Implicitly convert FileMergeException to com.starbase.starteam.viewcomparemerge.FileMergeException.

public static implicit operator FileMergeException(
FileMergeException arg
);

Parameters

arg
FileMergeException to convert.

Return Value

com.starbase.starteam.viewcomparemerge.FileMergeException

See Also

FileMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


FolderScope Class

Allows folders to be included or excluded from the scope of the view compare/merge operation in a flexible way.

For a list of all members of this type, see FolderScope Members.

System.Object
Scope
FolderScope

public class FolderScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

FolderScope Members | Borland.StarTeam.Viewcomparemerge Namespace


FolderScope Members

FolderScope overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.FolderScope.

Public Static Type Conversions

Implicit FolderScope to FolderScope Conversion Implicitly convert FolderScope to com.starbase.starteam.viewcomparemerge.FolderScope.

Public Instance Constructors

FolderScope Overloaded. Initializes a new instance of the FolderScope class.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace


FolderScope Constructor

Construct FolderScope from com.starbase.starteam.viewcomparemerge.FolderScope.

Overload List

Creates a new FolderScope that includes the files in the given source folder.

public FolderScope(Folder);

Creates a new FolderScope that includes the items of the given type in the given source folder.

public FolderScope(Folder,Type);

Creates a new FolderScope that includes the items of all of the given types in the given source folder.

public FolderScope(Folder,TypeCollection);

Creates a new FolderScope that includes the files in the given source folder, and optionally in all of its child folders at any depth.

public FolderScope(Folder,Boolean);

Creates a new FolderScope that includes the files in the given source folder, and optionally in all of its child folders at any depth.

public FolderScope(Folder,Boolean,Type);

public FolderScope(Folder,Boolean,TypeCollection);

Creates a new FolderScope that includes all of the folders indicated by the given FolderListManager. The client application is free to include or exlude folders from the FolderListManager at any time. Changes will be reflected in the scope after the next refresh().

public FolderScope(FolderListManager);

public FolderScope(FolderListManager,Type);

public FolderScope(FolderListManager,TypeCollection);

Construct FolderScope from com.starbase.starteam.viewcomparemerge.FolderScope.

public FolderScope(FolderScope);

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace


FolderScope Constructor (FolderScope)

Construct FolderScope from com.starbase.starteam.viewcomparemerge.FolderScope.

public FolderScope(
FolderScope impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.FolderScope to be wrapped.

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (Folder)

Creates a new FolderScope that includes the files in the given source folder.

public FolderScope(
Folder f
);

Parameters

f
A folder in the source view.

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (Folder, Type)

Creates a new FolderScope that includes the items of the given type in the given source folder.

public FolderScope(
Folder f,
Type type
);

Parameters

f
A folder in the source view.
type
An item type.

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (Folder, TypeCollection)

Creates a new FolderScope that includes the items of all of the given types in the given source folder.

public FolderScope(
Folder f,
TypeCollection types
);

Parameters

f
A folder in the source view.
types
A list of item types.

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (Folder, Boolean)

Creates a new FolderScope that includes the files in the given source folder, and optionally in all of its child folders at any depth.

public FolderScope(
Folder f,
Boolean bIncludeSubfolders
);

Parameters

f
A folder in the source view.
bIncludeSubfolders
true to include files in child folders; false to include only the files in the folder itself.

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (Folder, Boolean, Type)

Creates a new FolderScope that includes the files in the given source folder, and optionally in all of its child folders at any depth.

public FolderScope(
Folder f,
Boolean bIncludeSubfolders,
Type type
);

Parameters

f
A folder in the source view.
bIncludeSubfolders
true to include files in child folders; false to include only the files in the folder itself.
type

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (Folder, Boolean, TypeCollection)

public FolderScope(
Folder f,
Boolean bIncludeSubfolders,
TypeCollection types
);

Parameters

f
bIncludeSubfolders
types

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (FolderListManager)

Creates a new FolderScope that includes all of the folders indicated by the given FolderListManager.

The client application is free to include or exlude folders from the FolderListManager at any time. Changes will be reflected in the scope after the next refresh().

public FolderScope(
FolderListManager folders
);

Parameters

folders
The FolderListManager that describes the scope.

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (FolderListManager, Type)

public FolderScope(
FolderListManager folders,
Type type
);

Parameters

folders
type

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (FolderListManager, TypeCollection)

public FolderScope(
FolderListManager folders,
TypeCollection types
);

Parameters

folders
types

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace | FolderScope Constructor Overload List


FolderScope Methods

The methods of the FolderScope class are listed below. For a complete list of FolderScope class members, see the FolderScope Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.FolderScope.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace


FolderScope.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.FolderScope.

public static FolderScope Wrap(
FolderScope impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.FolderScope to be wrapped.

Return Value

FolderScope

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace


FolderScope Type Conversions

The type conversions of the FolderScope class are listed below. For a complete list of FolderScope class members, see the FolderScope Members topic.

Public Static Type Conversions

Implicit FolderScope to FolderScope Conversion Implicitly convert FolderScope to com.starbase.starteam.viewcomparemerge.FolderScope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

FolderScope Class | FolderScope Members | Borland.StarTeam.Viewcomparemerge Namespace


FolderScope Implicit FolderScope to FolderScope Conversion

Implicitly convert FolderScope to com.starbase.starteam.viewcomparemerge.FolderScope.

public static implicit operator FolderScope(
FolderScope arg
);

Parameters

arg
FolderScope to convert.

Return Value

com.starbase.starteam.viewcomparemerge.FolderScope

See Also

FolderScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference Class

Represents the difference between a given item from the source view and the corresponding item in the target view.

For a list of all members of this type, see ItemDifference Members.

System.Object
ItemDifference

public class ItemDifference : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemDifference Members | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference Members

ItemDifference overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.ItemDifference.

Public Static Type Conversions

Implicit ItemDifference to ItemDifference Conversion Implicitly convert ItemDifference to com.starbase.starteam.viewcomparemerge.ItemDifference.

Public Instance Constructors

ItemDifference Constructor Construct ItemDifference from com.starbase.starteam.viewcomparemerge.ItemDifference.

Public Instance Properties

Action | [read/write] The action that will be performed at commit time.
DefaultAction | [read] The default action recommended when merging this difference to the target view.
Description | [read] A user-friendly description of this difference.
DifferenceType | [read] The difference type associated with this difference.
IsCommitted | [read] true if this difference has been committed.
IsConflictDetected | [read] true if this difference represents a merge conflict, and false otherwise.
IsFileCheckin | [read] true if applying the current action would result in a file checkin.
IsFileMerge | [read] true if this difference represents an file merge condition.
IsNonTipReverseShare | [read] true if committing this difference resulted in a reverse share from a non-tip revision.
IsPropertyMerge | [read] true if there is at least one item property requiring a merge, whether or not the merge condition has already been resolved.
IsUnresolved | [read] true if this difference has an unresolved merge condition, and false otherwise.
IsUnresolvedFileMerge | [read] true if this difference represents an unresolved file merge condition.
IsUnresolvedPropertyMerge | [read] true if there is at least one item property with a merge condition that has not yet been resolved.
LegalActions | [read] The list of merge actions that are legal for this difference.
MergedFileContent | [read/write] The path to the file where the merged file content for this difference resides.
MergedFileContentItem | [read/write] The StarTeam file revision whose content was used as the merged file content for this difference.
MergedItem | [read] An item that closely approximates the state the target item after the merge, if the session were to be committed in its current state.
MergePoint | [read] The merge point created when this difference was committed, if any.
ProcessLink | [read] The process link created for this difference, or null.
Session | [read] The VCM session to which this difference belongs.
SourceAncestor | [read] The item from the source item's history that was used to determine whether the source item has changed or moved since the last merge operation.
SourceItem | [read] The source item associated with this difference, or null.
SourceItemForCompare | [read] The source item associated with this difference, or null
TargetAncestor | [read] The item from the target item's history that was used to determine whether the target item has changed or moved since the last merge operation.
TargetItem | [read] The target item associated with this difference, or null.
TargetItemForCompare | [read] The target item associated with this difference, or null
Type | [read] The item type of the source and target items in this difference.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.ItemDifference.
GetAffectedDifferences | Determines which differences would be affected if the merge action for this difference were changed to the given one. For example, consider a folder that is "New in source". Changing the action from {@linkplain MergeAction#REVERSE_SHARE reverse share} to {@linkplain MergeAction#IGNORE ignore} would also affect the differences for any "New in source" files in that folder. (If the folder isn't shared, its children won't be either.) This method does not actually change the actions of any differences; the changes would not occur unless {@link #setAction setAction} were called.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.ItemDifference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.
IsUnresolvedPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.
SetMergedPropertyValue | Sets the value of the specified property on the merged item. This is the property value that will be saved to the target item at commit time. Setting the property value resolves any outstanding merge conflict associated with this property. Alternatively, an application can change the property value using the normal {@link SimpleTypedResource#put(String,Object) put} and {@link Item#update() update} methods available on the {@linkplain #getMergedItem merged item}.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.ItemDifference.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference Constructor

Construct ItemDifference from com.starbase.starteam.viewcomparemerge.ItemDifference.

public ItemDifference(
ItemDifference impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.ItemDifference to be wrapped.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference Properties

The properties of the ItemDifference class are listed below. For a complete list of ItemDifference class members, see the ItemDifference Members topic.

Public Instance Properties

Action | [read/write] The action that will be performed at commit time.
DefaultAction | [read] The default action recommended when merging this difference to the target view.
Description | [read] A user-friendly description of this difference.
DifferenceType | [read] The difference type associated with this difference.
IsCommitted | [read] true if this difference has been committed.
IsConflictDetected | [read] true if this difference represents a merge conflict, and false otherwise.
IsFileCheckin | [read] true if applying the current action would result in a file checkin.
IsFileMerge | [read] true if this difference represents an file merge condition.
IsNonTipReverseShare | [read] true if committing this difference resulted in a reverse share from a non-tip revision.
IsPropertyMerge | [read] true if there is at least one item property requiring a merge, whether or not the merge condition has already been resolved.
IsUnresolved | [read] true if this difference has an unresolved merge condition, and false otherwise.
IsUnresolvedFileMerge | [read] true if this difference represents an unresolved file merge condition.
IsUnresolvedPropertyMerge | [read] true if there is at least one item property with a merge condition that has not yet been resolved.
LegalActions | [read] The list of merge actions that are legal for this difference.
MergedFileContent | [read/write] The path to the file where the merged file content for this difference resides.
MergedFileContentItem | [read/write] The StarTeam file revision whose content was used as the merged file content for this difference.
MergedItem | [read] An item that closely approximates the state the target item after the merge, if the session were to be committed in its current state.
MergePoint | [read] The merge point created when this difference was committed, if any.
ProcessLink | [read] The process link created for this difference, or null.
Session | [read] The VCM session to which this difference belongs.
SourceAncestor | [read] The item from the source item's history that was used to determine whether the source item has changed or moved since the last merge operation.
SourceItem | [read] The source item associated with this difference, or null.
SourceItemForCompare | [read] The source item associated with this difference, or null
TargetAncestor | [read] The item from the target item's history that was used to determine whether the target item has changed or moved since the last merge operation.
TargetItem | [read] The target item associated with this difference, or null.
TargetItemForCompare | [read] The target item associated with this difference, or null
Type | [read] The item type of the source and target items in this difference.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


Action Property

Borland StarTeam SDK for .NET

ItemDifference.Action Property

[read/write] The action that will be performed at commit time.

public virtual MergeAction Action {get; set;}

Property Value

The action that will be performed at commit time.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


DefaultAction Property

Borland StarTeam SDK for .NET

ItemDifference.DefaultAction Property

[read] The default action recommended when merging this difference to the target view.

public virtual MergeAction DefaultAction {get;}

Property Value

The default action recommended when merging this difference to the target view.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


Description Property

Borland StarTeam SDK for .NET

ItemDifference.Description Property

[read] A user-friendly description of this difference.

public virtual String Description {get;}

Property Value

A user-friendly description of this difference.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


DifferenceType Property

Borland StarTeam SDK for .NET

ItemDifference.DifferenceType Property

[read] The difference type associated with this difference.

public virtual DifferenceType DifferenceType {get;}

Property Value

The difference type associated with this difference.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


IsCommitted Property

Borland StarTeam SDK for .NET

ItemDifference.IsCommitted Property

[read] true if this difference has been committed.

public virtual Boolean IsCommitted {get;}

Property Value

true if this difference has been committed.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


IsConflictDetected Property

Borland StarTeam SDK for .NET

ItemDifference.IsConflictDetected Property

[read] true if this difference represents a merge conflict, and false otherwise.

public virtual Boolean IsConflictDetected {get;}

Property Value

true if this difference represents a merge conflict, and false otherwise.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


IsFileCheckin Property

Borland StarTeam SDK for .NET

ItemDifference.IsFileCheckin Property

[read] true if applying the current action would result in a file checkin.

public virtual Boolean IsFileCheckin {get;}

Property Value

true if applying the current action would result in a file checkin.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


IsFileMerge Property

Borland StarTeam SDK for .NET

ItemDifference.IsFileMerge Property

[read] true if this difference represents an file merge condition.

public virtual Boolean IsFileMerge {get;}

Property Value

true if this difference represents an file merge condition.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


IsNonTipReverseShare Property

Borland StarTeam SDK for .NET

ItemDifference.IsNonTipReverseShare Property

[read] true if committing this difference resulted in a reverse share from a non-tip revision.

public virtual Boolean IsNonTipReverseShare {get;}

Property Value

true if committing this difference resulted in a reverse share from a non-tip revision.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


IsPropertyMerge Property

Borland StarTeam SDK for .NET

ItemDifference.IsPropertyMerge Property

[read] true if there is at least one item property requiring a merge, whether or not the merge condition has already been resolved.

public virtual Boolean IsPropertyMerge {get;}

Property Value

true if there is at least one item property requiring a merge, whether or not the merge condition has already been resolved.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


IsUnresolved Property

Borland StarTeam SDK for .NET

ItemDifference.IsUnresolved Property

[read] true if this difference has an unresolved merge condition, and false otherwise.

public virtual Boolean IsUnresolved {get;}

Property Value

true if this difference has an unresolved merge condition, and false otherwise.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


IsUnresolvedFileMerge Property

Borland StarTeam SDK for .NET

ItemDifference.IsUnresolvedFileMerge Property

[read] true if this difference represents an unresolved file merge condition.

public virtual Boolean IsUnresolvedFileMerge {get;}

Property Value

true if this difference represents an unresolved file merge condition.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


IsUnresolvedPropertyMerge Property

Borland StarTeam SDK for .NET

ItemDifference.IsUnresolvedPropertyMerge Property

[read] true if there is at least one item property with a merge condition that has not yet been resolved.

public virtual Boolean IsUnresolvedPropertyMerge {get;}

Property Value

true if there is at least one item property with a merge condition that has not yet been resolved.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


LegalActions Property

Borland StarTeam SDK for .NET

ItemDifference.LegalActions Property

[read] The list of merge actions that are legal for this difference.

public virtual MergeActionCollection LegalActions {get;}

Property Value

The list of merge actions that are legal for this difference.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


MergedFileContent Property

Borland StarTeam SDK for .NET

ItemDifference.MergedFileContent Property

[read/write] The path to the file where the merged file content for this difference resides.

public virtual FileInfo MergedFileContent {get; set;}

Property Value

The path to the file where the merged file content for this difference resides.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


MergedFileContentItem Property

Borland StarTeam SDK for .NET

ItemDifference.MergedFileContentItem Property

[read/write] The StarTeam file revision whose content was used as the merged file content for this difference.

public virtual File MergedFileContentItem {get; set;}

Property Value

The StarTeam file revision whose content was used as the merged file content for this difference.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


MergedItem Property

Borland StarTeam SDK for .NET

ItemDifference.MergedItem Property

[read] An item that closely approximates the state the target item after the merge, if the session were to be committed in its current state.

public virtual Item MergedItem {get;}

Property Value

An item that closely approximates the state the target item after the merge, if the session were to be committed in its current state.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


MergePoint Property

Borland StarTeam SDK for .NET

ItemDifference.MergePoint Property

[read] The merge point created when this difference was committed, if any.

public virtual MergePoint MergePoint {get;}

Property Value

The merge point created when this difference was committed, if any.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


ProcessLink Property

Borland StarTeam SDK for .NET

ItemDifference.ProcessLink Property

[read] The process link created for this difference, or null.

public virtual Link ProcessLink {get;}

Property Value

The process link created for this difference, or null.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


Session Property

Borland StarTeam SDK for .NET

ItemDifference.Session Property

[read] The VCM session to which this difference belongs.

public virtual Session Session {get;}

Property Value

The VCM session to which this difference belongs.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


SourceAncestor Property

Borland StarTeam SDK for .NET

ItemDifference.SourceAncestor Property

[read] The item from the source item's history that was used to determine whether the source item has changed or moved since the last merge operation.

public virtual Item SourceAncestor {get;}

Property Value

The item from the source item's history that was used to determine whether the source item has changed or moved since the last merge operation.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


SourceItem Property

Borland StarTeam SDK for .NET

ItemDifference.SourceItem Property

[read] The source item associated with this difference, or null.

public virtual Item SourceItem {get;}

Property Value

The source item associated with this difference, or null.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


SourceItemForCompare Property

Borland StarTeam SDK for .NET

ItemDifference.SourceItemForCompare Property

[read] The source item associated with this difference, or null

public virtual Item SourceItemForCompare {get;}

Property Value

The source item associated with this difference, or null

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


TargetAncestor Property

Borland StarTeam SDK for .NET

ItemDifference.TargetAncestor Property

[read] The item from the target item's history that was used to determine whether the target item has changed or moved since the last merge operation.

public virtual Item TargetAncestor {get;}

Property Value

The item from the target item's history that was used to determine whether the target item has changed or moved since the last merge operation.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


TargetItem Property

Borland StarTeam SDK for .NET

ItemDifference.TargetItem Property

[read] The target item associated with this difference, or null.

public virtual Item TargetItem {get;}

Property Value

The target item associated with this difference, or null.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


TargetItemForCompare Property

Borland StarTeam SDK for .NET

ItemDifference.TargetItemForCompare Property

[read] The target item associated with this difference, or null

public virtual Item TargetItemForCompare {get;}

Property Value

The target item associated with this difference, or null

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


Type Property

Borland StarTeam SDK for .NET

ItemDifference.Type Property

[read] The item type of the source and target items in this difference.

public virtual Type Type {get;}

Property Value

The item type of the source and target items in this difference.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference Methods

The methods of the ItemDifference class are listed below. For a complete list of ItemDifference class members, see the ItemDifference Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.ItemDifference.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.ItemDifference.
GetAffectedDifferences | Determines which differences would be affected if the merge action for this difference were changed to the given one. For example, consider a folder that is "New in source". Changing the action from {@linkplain MergeAction#REVERSE_SHARE reverse share} to {@linkplain MergeAction#IGNORE ignore} would also affect the differences for any "New in source" files in that folder. (If the folder isn't shared, its children won't be either.) This method does not actually change the actions of any differences; the changes would not occur unless {@link #setAction setAction} were called.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.ItemDifference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.
IsUnresolvedPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.
SetMergedPropertyValue | Sets the value of the specified property on the merged item. This is the property value that will be saved to the target item at commit time. Setting the property value resolves any outstanding merge conflict associated with this property. Alternatively, an application can change the property value using the normal {@link SimpleTypedResource#put(String,Object) put} and {@link Item#update() update} methods available on the {@linkplain #getMergedItem merged item}.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.ItemDifference.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.ItemDifference

Implements

IWrapper.Unwrap

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.ItemDifference.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.ItemDifference.Equals(obj).

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference.GetAffectedDifferences Method

Determines which differences would be affected if the merge action for this difference were changed to the given one.

For example, consider a folder that is "New in source". Changing the action from {@linkplain MergeAction#REVERSE_SHARE reverse share} to {@linkplain MergeAction#IGNORE ignore} would also affect the differences for any "New in source" files in that folder. (If the folder isn't shared, its children won't be either.)

This method does not actually change the actions of any differences; the changes would not occur unless {@link #setAction setAction} were called.

public virtual ItemDifferenceCollection GetAffectedDifferences(
MergeAction newAction
);

Parameters

newAction

Return Value

A list of the effected differences. The list is empty (zero length) if the action isn't changing, or isn't legal for this difference.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace | setAction | getLegalActions


ItemDifference.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.ItemDifference.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.ItemDifference.GetHashCode().

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference.IsPropertyMergeFor Method

Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.

public virtual bool IsPropertyMergeFor(
Property property
);

Parameters

property
An item property.

Return Value

true if the given item property requires a merge, whether or not the merge condition has already been resolved.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace | isPropertyMerge | isUnresolvedPropertyMergeFor | setMergedPropertyValue


ItemDifference.IsUnresolvedPropertyMergeFor Method

Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.

public virtual bool IsUnresolvedPropertyMergeFor(
Property property
);

Parameters

property
An item property.

Return Value

true if the given item property has a merge condition that has not yet been resolved.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace | isUnresolvedPropertyMerge | isPropertyMergeFor | setMergedPropertyValue


ItemDifference.SetMergedPropertyValue Method

Sets the value of the specified property on the merged item. This is the property value that will be saved to the target item at commit time.

Setting the property value resolves any outstanding merge conflict associated with this property.

Alternatively, an application can change the property value using the normal {@link SimpleTypedResource#put(String,Object) put} and {@link Item#update() update} methods available on the {@linkplain #getMergedItem merged item}.

public virtual object SetMergedPropertyValue(
Property property,
Object value
);

Parameters

property
The property whose value is to be changed.
value
The new property value.

Return Value

The previous value of the property.

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace | isPropertyMerge | isPropertyMergeFor | getMergedItem | put | update


ItemDifference.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.ItemDifference.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.ItemDifference.ToString()

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.ItemDifference.

public static ItemDifference Wrap(
ItemDifference impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.ItemDifference to be wrapped.

Return Value

ItemDifference

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference Type Conversions

The type conversions of the ItemDifference class are listed below. For a complete list of ItemDifference class members, see the ItemDifference Members topic.

Public Static Type Conversions

Implicit ItemDifference to ItemDifference Conversion Implicitly convert ItemDifference to com.starbase.starteam.viewcomparemerge.ItemDifference.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

ItemDifference Class | ItemDifference Members | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference Implicit ItemDifference to ItemDifference Conversion

Implicitly convert ItemDifference to com.starbase.starteam.viewcomparemerge.ItemDifference.

public static implicit operator ItemDifference(
ItemDifference arg
);

Parameters

arg
ItemDifference to convert.

Return Value

com.starbase.starteam.viewcomparemerge.ItemDifference

See Also

ItemDifference Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection Class

A strongly-typed collection of ItemDifferences.

For a list of all members of this type, see ItemDifferenceCollection Members.

System.Object
ArrayAdapter
ItemDifferenceCollection

public class ItemDifferenceCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemDifferenceCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection Members

ItemDifferenceCollection overview

Public Static Methods

Wrap Creates an ItemDifferenceCollection to represent the given array of ItemDifference (from the com.starbase.starteam.viewcomparemerge namespace).

Public Static Type Conversions

Implicit ItemDifferenceCollection to ItemDifference[] Conversion | Converts an ItemDifferenceCollection to an array of ItemDifferences.
Implicit ItemDifferenceCollection to ItemDifference[] Conversion | Converts an ItemDifferenceCollection from the Borland.StarTeam.Viewcomparemerge namespace to an ItemDifference[] in the com.starbase.starteam.viewcomparemerge namespace.

Public Instance Constructors

ItemDifferenceCollection Overloaded. Initializes a new instance of the ItemDifferenceCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ItemDifference at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds an ItemDifference to end of the collection.
Append | Overloaded. Appends the ItemDifferences of the given ItemDifferenceCollection to the end of this ItemDifferenceCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ItemDifference.
CopyTo | Copies all of the ItemDifferences in the ItemDifferenceCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ItemDifference in the collection.
Insert | Inserts an ItemDifference into the collection at the specified position.
Remove | Removes the first occurrence of a specific ItemDifference from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ItemDifferences in this ItemDifferenceCollection.
Sort | Sorts the ItemDifferences in this ItemDifferenceCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection Constructor

Initializes an instance of the ItemDifferenceCollection class.

Overload List

Initializes an instance of the ItemDifferenceCollection class.

public ItemDifferenceCollection();

Initializes an instance of the an ItemDifferenceCollection class, copying the given array.

public ItemDifferenceCollection(ItemDifference[]);

Initializes an instance of the an ItemDifferenceCollection class, copying the given collection.

public ItemDifferenceCollection(ItemDifferenceCollection);

Initializes an instance of the an ItemDifferenceCollection class, wrapping the given array of ItemDifference (from the com.starbase.starteam.viewcomparemerge namespace).

public ItemDifferenceCollection(ItemDifference[]);

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection Constructor ()

Initializes an instance of the ItemDifferenceCollection class.

public ItemDifferenceCollection();

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemDifferenceCollection Constructor Overload List


ItemDifferenceCollection Constructor (ItemDifference[])

Initializes an instance of the an ItemDifferenceCollection class, wrapping the given array of ItemDifference (from the com.starbase.starteam.viewcomparemerge namespace).

public ItemDifferenceCollection(
ItemDifference[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam.viewcomparemerge namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemDifferenceCollection Constructor Overload List | Wrap


ItemDifferenceCollection Constructor (ItemDifferenceCollection)

Initializes an instance of the an ItemDifferenceCollection class, copying the given collection.

public ItemDifferenceCollection(
ItemDifferenceCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member ItemDifference objects of the original collection are shared, not copied.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemDifferenceCollection Constructor Overload List


ItemDifferenceCollection Constructor (ItemDifference[])

Initializes an instance of the an ItemDifferenceCollection class, copying the given array.

public ItemDifferenceCollection(
ItemDifference[] array
);

Parameters

array
The array to be copied.

Remarks

The member ItemDifference objects of the original array are shared, not copied.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemDifferenceCollection Constructor Overload List


ItemDifferenceCollection Properties

The properties of the ItemDifferenceCollection class are listed below. For a complete list of ItemDifferenceCollection class members, see the ItemDifferenceCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the ItemDifference at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Item Property

Borland StarTeam SDK for .NET

ItemDifferenceCollection.Item Property

Gets or sets the ItemDifference at the specified index.

public ItemDifference this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the ItemDifference to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection Methods

The methods of the ItemDifferenceCollection class are listed below. For a complete list of ItemDifferenceCollection class members, see the ItemDifferenceCollection Members topic.

Public Static Methods

Wrap Creates an ItemDifferenceCollection to represent the given array of ItemDifference (from the com.starbase.starteam.viewcomparemerge namespace).

Public Instance Methods

Add | Adds an ItemDifference to end of the collection.
Append | Overloaded. Appends the ItemDifferences of the given ItemDifferenceCollection to the end of this ItemDifferenceCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific ItemDifference.
CopyTo | Copies all of the ItemDifferences in the ItemDifferenceCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific ItemDifference in the collection.
Insert | Inserts an ItemDifference into the collection at the specified position.
Remove | Removes the first occurrence of a specific ItemDifference from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the ItemDifferences in this ItemDifferenceCollection.
Sort | Sorts the ItemDifferences in this ItemDifferenceCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection.Add Method

Adds an ItemDifference to end of the collection.

public int Add(
ItemDifference value
);

Parameters

value
The ItemDifference to add to the collection.

Return Value

The position into which the new ItemDifference was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Append Method

Borland StarTeam SDK for .NET

ItemDifferenceCollection.Append Method

Appends the ItemDifferences of the given array to the end of this ItemDifferenceCollection.

Overload List

Appends the ItemDifferences of the given array to the end of this ItemDifferenceCollection.

public ItemDifferenceCollection Append(ItemDifference[]);

Appends the ItemDifferences of the given ItemDifferenceCollection to the end of this ItemDifferenceCollection.

public ItemDifferenceCollection Append(ItemDifferenceCollection);

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection.Append Method (ItemDifference[])

Appends the ItemDifferences of the given array to the end of this ItemDifferenceCollection.

public ItemDifferenceCollection Append(
ItemDifference[] array
);

Parameters

array
The array whose ItemDifferences are to be appended to this ItemDifferenceCollection.

Return Value

This ItemDifferenceCollection, modified to include the new ItemDifferences.

Remarks

The ItemDifferenceCollection is modified to include the new members. The individual ItemDifference objects are shared, not copied.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemDifferenceCollection.Append Overload List


ItemDifferenceCollection.Append Method (ItemDifferenceCollection)

Appends the ItemDifferences of the given ItemDifferenceCollection to the end of this ItemDifferenceCollection.

public ItemDifferenceCollection Append(
ItemDifferenceCollection collection
);

Parameters

collection
The ItemDifferenceCollection whose ItemDifferences are to be appended to this ItemDifferenceCollection.

Return Value

This ItemDifferenceCollection, modified to include the new ItemDifferences.

Remarks

The ItemDifferenceCollection is modified to include the new members. The individual ItemDifference objects are shared, not copied.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemDifferenceCollection.Append Overload List


ItemDifferenceCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.viewcomparemerge.ItemDifference[].

Implements

IWrapper.Unwrap

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection.Contains Method

Determines whether or not the collection contains a specific ItemDifference.

public bool Contains(
ItemDifference value
);

Parameters

value
The ItemDifference to locate in the collection.

Return Value

true if the ItemDifference is found in the collection; otherwise, false.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection.CopyTo Method

Copies all of the ItemDifferences in the ItemDifferenceCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
ItemDifference[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the ItemDifferences copied from the ItemDifferenceCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of ItemDifferences in the source ItemDifferenceCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ItemDifferenceCollection cannot be cast automatically to the type of the destination array.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection.IndexOf Method

Determines the index of a specific ItemDifference in the collection.

public int IndexOf(
ItemDifference value
);

Parameters

value
The ItemDifference to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection.Insert Method

Inserts an ItemDifference into the collection at the specified position.

public void Insert(
Int32 index,
ItemDifference value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The ItemDifference to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection.Remove Method

Removes the first occurrence of a specific ItemDifference from the collection.

public void Remove(
ItemDifference value
);

Parameters

value
The ItemDifference to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection.Reverse Method

Reverses the order of the ItemDifferences in this ItemDifferenceCollection.

new public ItemDifferenceCollection Reverse();

Return Value

This ItemDifferenceCollection, modified such that the ItemDifferences are reversed.

Remarks

The ItemDifferenceCollection is modified in place.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection.Sort Method

Sorts the ItemDifferences in this ItemDifferenceCollection, using the given comparer.

new public ItemDifferenceCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two ItemDifferences.

Return Value

This ItemDifferenceCollection, modified such that the ItemDifferences are sorted.

Remarks

The ItemDifferenceCollection is modified in place.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection.Wrap Method

Creates an ItemDifferenceCollection to represent the given array of ItemDifference (from the com.starbase.starteam.viewcomparemerge namespace).

public static ItemDifferenceCollection Wrap(
ItemDifference[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ItemDifferenceCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert an ItemDifference[] from the com.starbase.starteam.viewcomparemerge namespace to the Borland.StarTeam.Viewcomparemerge namespace.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection Type Conversions

The type conversions of the ItemDifferenceCollection class are listed below. For a complete list of ItemDifferenceCollection class members, see the ItemDifferenceCollection Members topic.

Public Static Type Conversions

Implicit ItemDifferenceCollection to ItemDifference[] Conversion | Converts an ItemDifferenceCollection to an array of ItemDifferences.
Implicit ItemDifferenceCollection to ItemDifference[] Conversion | Converts an ItemDifferenceCollection from the Borland.StarTeam.Viewcomparemerge namespace to an ItemDifference[] in the com.starbase.starteam.viewcomparemerge namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ItemDifferenceCollection Class | ItemDifferenceCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection Implicit ItemDifferenceCollection to ItemDifference[] Conversion

Converts an ItemDifferenceCollection to an array of ItemDifferences.

public static implicit operator ItemDifference[](
ItemDifferenceCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new ItemDifference wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one ItemDifference wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifferenceCollection Implicit ItemDifferenceCollection to ItemDifference[] Conversion

Converts an ItemDifferenceCollection from the Borland.StarTeam.Viewcomparemerge namespace to an ItemDifference[] in the com.starbase.starteam.viewcomparemerge namespace.

public static implicit operator ItemDifference[](
ItemDifferenceCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam.Viewcomparemerge namespace to methods in the com.starbase.starteam.viewcomparemerge namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ItemDifferenceCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ItemDifferenceCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemListScope Class

For a list of all members of this type, see ItemListScope Members.

System.Object
Scope
ItemListScope

public class ItemListScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemListScope Members | Borland.StarTeam.Viewcomparemerge Namespace


ItemListScope Members

ItemListScope overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.ItemListScope.

Public Static Type Conversions

Implicit ItemListScope to ItemListScope Conversion Implicitly convert ItemListScope to com.starbase.starteam.viewcomparemerge.ItemListScope.

Public Instance Constructors

ItemListScope Overloaded. Initializes a new instance of the ItemListScope class.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

ItemListScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemListScope Constructor

Construct ItemListScope from com.starbase.starteam.viewcomparemerge.ItemListScope.

Overload List

Create an ItemListScope for the specified Item

public ItemListScope(Item);

Create an ItemListScope from an array of Items

public ItemListScope(ItemCollection);

Construct ItemListScope from com.starbase.starteam.viewcomparemerge.ItemListScope.

public ItemListScope(ItemListScope);

See Also

ItemListScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemListScope Constructor (ItemListScope)

Construct ItemListScope from com.starbase.starteam.viewcomparemerge.ItemListScope.

public ItemListScope(
ItemListScope impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.ItemListScope to be wrapped.

See Also

ItemListScope Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemListScope Constructor Overload List


ItemListScope Constructor (Item)

Create an ItemListScope for the specified Item

public ItemListScope(
Item item
);

Parameters

item
Item the Item to be included in this scope

See Also

ItemListScope Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemListScope Constructor Overload List


ItemListScope Constructor (ItemCollection)

Create an ItemListScope from an array of Items

public ItemListScope(
ItemCollection items
);

Parameters

items
Item[] an array of Items

See Also

ItemListScope Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemListScope Constructor Overload List


ItemListScope Methods

The methods of the ItemListScope class are listed below. For a complete list of ItemListScope class members, see the ItemListScope Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.ItemListScope.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

ItemListScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemListScope.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.ItemListScope.

public static ItemListScope Wrap(
ItemListScope impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.ItemListScope to be wrapped.

Return Value

ItemListScope

See Also

ItemListScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemListScope Type Conversions

The type conversions of the ItemListScope class are listed below. For a complete list of ItemListScope class members, see the ItemListScope Members topic.

Public Static Type Conversions

Implicit ItemListScope to ItemListScope Conversion Implicitly convert ItemListScope to com.starbase.starteam.viewcomparemerge.ItemListScope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

ItemListScope Class | ItemListScope Members | Borland.StarTeam.Viewcomparemerge Namespace


ItemListScope Implicit ItemListScope to ItemListScope Conversion

Implicitly convert ItemListScope to com.starbase.starteam.viewcomparemerge.ItemListScope.

public static implicit operator ItemListScope(
ItemListScope arg
);

Parameters

arg
ItemListScope to convert.

Return Value

com.starbase.starteam.viewcomparemerge.ItemListScope

See Also

ItemListScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope Class

Allows item types to be included or excluded from the scope of the view compare/merge operation. Note that folders are always included in the view compare/merge operation, whether or not the ItemTypeScope explicitly reports indicates that they should be included.

For a list of all members of this type, see ItemTypeScope Members.

System.Object
Scope
ItemTypeScope

public class ItemTypeScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ItemTypeScope Members | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope Members

ItemTypeScope overview

Public Static Methods

ForAllTypes | Gets an ItemTypeScope containing all supported item types.
ForDefaultTypes | Gets an ItemTypeScope containing the default types (files and folders).
Wrap | Dynamically wraps com.starbase.starteam.viewcomparemerge.ItemTypeScope.

Public Static Type Conversions

Implicit ItemTypeScope to ItemTypeScope Conversion Implicitly convert ItemTypeScope to com.starbase.starteam.viewcomparemerge.ItemTypeScope.

Public Instance Constructors

ItemTypeScope Overloaded. Initializes a new instance of the ItemTypeScope class.

Public Instance Properties

ItemTypes [write] Sets the item types that are to be included in the view compare/merge operation.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
ExcludeItemType | Removes a given item type from the list of included item types.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeItemType | Adds a given item type to the list of included item types.
IsIncluded | Determines whether or not the given item type is included.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope Constructor

Construct ItemTypeScope from com.starbase.starteam.viewcomparemerge.ItemTypeScope.

Overload List

Creates an empty ItemTypeScope.

public ItemTypeScope();

Creates an ItemTypeScope that includes the given type.

public ItemTypeScope(Type);

Creates an ItemTypeScope that includes the given list of types.

public ItemTypeScope(TypeCollection);

Construct ItemTypeScope from com.starbase.starteam.viewcomparemerge.ItemTypeScope.

public ItemTypeScope(ItemTypeScope);

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope Constructor (ItemTypeScope)

Construct ItemTypeScope from com.starbase.starteam.viewcomparemerge.ItemTypeScope.

public ItemTypeScope(
ItemTypeScope impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.ItemTypeScope to be wrapped.

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemTypeScope Constructor Overload List


ItemTypeScope Constructor ()

Creates an empty ItemTypeScope.

public ItemTypeScope();

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemTypeScope Constructor Overload List


ItemTypeScope Constructor (Type)

Creates an ItemTypeScope that includes the given type.

public ItemTypeScope(
Type type
);

Parameters

type
The type to be included.

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemTypeScope Constructor Overload List


ItemTypeScope Constructor (TypeCollection)

Creates an ItemTypeScope that includes the given list of types.

public ItemTypeScope(
TypeCollection types
);

Parameters

types
The list of types to be included.

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace | ItemTypeScope Constructor Overload List


ItemTypeScope Properties

The properties of the ItemTypeScope class are listed below. For a complete list of ItemTypeScope class members, see the ItemTypeScope Members topic.

Public Instance Properties

ItemTypes [write] Sets the item types that are to be included in the view compare/merge operation.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypes Property

Borland StarTeam SDK for .NET

ItemTypeScope.ItemTypes Property

[write] Sets the item types that are to be included in the view compare/merge operation.

public virtual TypeCollection ItemTypes {set;}

Property Value

Sets the item types that are to be included in the view compare/merge operation.

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope Methods

The methods of the ItemTypeScope class are listed below. For a complete list of ItemTypeScope class members, see the ItemTypeScope Members topic.

Public Static Methods

ForAllTypes | Gets an ItemTypeScope containing all supported item types.
ForDefaultTypes | Gets an ItemTypeScope containing the default types (files and folders).
Wrap | Dynamically wraps com.starbase.starteam.viewcomparemerge.ItemTypeScope.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
ExcludeItemType | Removes a given item type from the list of included item types.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeItemType | Adds a given item type to the list of included item types.
IsIncluded | Determines whether or not the given item type is included.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope.ExcludeItemType Method

Removes a given item type from the list of included item types.

public virtual void ExcludeItemType(
Type type
);

Parameters

type
The item type to be excluded.

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope.ForAllTypes Method

Gets an ItemTypeScope containing all supported item types.

public static ItemTypeScope ForAllTypes(
Server s
);

Parameters

s
The server.

Return Value

An ItemTypeScope containing all supported item types.

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope.ForDefaultTypes Method

Gets an ItemTypeScope containing the default types (files and folders).

public static ItemTypeScope ForDefaultTypes(
Server s
);

Parameters

s
The server.

Return Value

An ItemTypeScope containing the default types (files and folders).

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope.IncludeItemType Method

Adds a given item type to the list of included item types.

public virtual void IncludeItemType(
Type type
);

Parameters

type
The item type to be included.

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope.IsIncluded Method

Determines whether or not the given item type is included.

public virtual bool IsIncluded(
Type type
);

Parameters

type
The item type to be tested.

Return Value

true if the type is included; false otherwise.

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.ItemTypeScope.

public static ItemTypeScope Wrap(
ItemTypeScope impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.ItemTypeScope to be wrapped.

Return Value

ItemTypeScope

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope Type Conversions

The type conversions of the ItemTypeScope class are listed below. For a complete list of ItemTypeScope class members, see the ItemTypeScope Members topic.

Public Static Type Conversions

Implicit ItemTypeScope to ItemTypeScope Conversion Implicitly convert ItemTypeScope to com.starbase.starteam.viewcomparemerge.ItemTypeScope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

ItemTypeScope Class | ItemTypeScope Members | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeScope Implicit ItemTypeScope to ItemTypeScope Conversion

Implicitly convert ItemTypeScope to com.starbase.starteam.viewcomparemerge.ItemTypeScope.

public static implicit operator ItemTypeScope(
ItemTypeScope arg
);

Parameters

arg
ItemTypeScope to convert.

Return Value

com.starbase.starteam.viewcomparemerge.ItemTypeScope

See Also

ItemTypeScope Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState Class

Describes the relationship between an item in the source view and an item in the target view.

For a list of all members of this type, see MatchState Members.

System.Object
MatchState

public class MatchState : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MatchState Members | Borland.StarTeam.Viewcomparemerge Namespace


MatchState Members

MatchState overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.MatchState.

Public Static Type Conversions

Implicit MatchState to MatchState Conversion Implicitly convert MatchState to com.starbase.starteam.viewcomparemerge.MatchState.

Public Instance Constructors

MatchState Overloaded. Initializes a new instance of the MatchState class.

Public Instance Properties

ItemDeletedInSource | [read/write] Boolean.TRUE if the item is deleted in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemDeletedInTarget | [read/write] Boolean.TRUE if the item is deleted in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemIsBinaryFile | [read/write] Boolean.TRUE if the item is a binary file. Default value is null ("Don't Know" / "Don't Care").
ItemModifiedInSource | [read/write] Boolean.TRUE if the item is modified in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemModifiedInTarget | [read/write] Boolean.TRUE if the item is modified in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemMovedInSource | [read/write] Boolean.TRUE if the item is moved in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemMovedInTarget | [read/write] Boolean.TRUE if the item is moved in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemPresentInSource | [read/write] Boolean.TRUE if the item is present in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemPresentInTarget | [read/write] Boolean.TRUE if the item is present in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemsHaveSameContent | [read/write] Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").
ItemsInDifferentBranches | [read/write] Boolean.TRUE if the items are in different branches. Default value is null ("Don't Know" / "Don't Care").
ItemTypeName | [read/write] The name of the item type. Default value is null, indicating that any type is acceptable.
MergeType | [read/write] The merge type. Default value is null, indicating that any merge type is acceptable.
ParentFolderDeletedInTarget | [read/write] Boolean.TRUE if the target item's parent folder has been deleted. Default value is null ("Don't Know" / "Don't Care").
ParentFolderFailed | [read/write] Boolean.TRUE if the target item's parent folder failed to be reconciled. Default value is null ("Don't Know" / "Don't Care").
ParentFolderIgnored | [read/write] Boolean.TRUE if the target item's parent folder is ignored. Default value is null ("Don't Know" / "Don't Care").
SomeChangedPropertiesExcludedFromMerge | [read/write] Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").
SourceChildShareOfTarget | [read/write] Boolean.TRUE if the source item is a child share of the target item. Default value is null ("Don't Know" / "Don't Care").
SourceIsFloating | [read/write] Boolean.TRUE if the source item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").
SourceItemOnRootBranch | [read/write] Boolean.TRUE if the source item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").
TargetChildShareOfSource | [read/write] Boolean.TRUE if the target item is a child share of the source item. Default value is null ("Don't Know" / "Don't Care").
TargetFolderHasFloatingShares | [read/write] Boolean.TRUE if the target item's parent folder has floating child shares. Default value is null ("Don't Know" / "Don't Care").
TargetIsFloating | [read/write] Boolean.TRUE if the target item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").
TargetItemOnRootBranch | [read/write] Boolean.TRUE if the target item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.MatchState.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.MatchState.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches | Determines whether or not this MatchState matches the conditions specified by the given pattern. "Don't Care" values in the pattern are ignored; other values in the pattern must match exactly.
SetParentFolderIgnored | Indicates whether or not the target item's parent folder is ignored.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.MatchState.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState Constructor

Construct MatchState from com.starbase.starteam.viewcomparemerge.MatchState.

Overload List

Constructs a new MatchState. Properties are initialized to their "Don't Know" / "Don't Care" values.

public MatchState();

Constructs a new MatchState that is a copy of an existing one.

public MatchState(MatchState);

Construct MatchState from com.starbase.starteam.viewcomparemerge.MatchState.

public MatchState(MatchState);

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState Constructor (MatchState)

Construct MatchState from com.starbase.starteam.viewcomparemerge.MatchState.

public MatchState(
MatchState impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.MatchState to be wrapped.

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace | MatchState Constructor Overload List


MatchState Constructor ()

Constructs a new MatchState. Properties are initialized to their "Don't Know" / "Don't Care" values.

public MatchState();

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace | MatchState Constructor Overload List


MatchState Constructor (MatchState)

Constructs a new MatchState that is a copy of an existing one.

public MatchState(
MatchState state
);

Parameters

state

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace | MatchState Constructor Overload List


MatchState Properties

The properties of the MatchState class are listed below. For a complete list of MatchState class members, see the MatchState Members topic.

Public Instance Properties

ItemDeletedInSource | [read/write] Boolean.TRUE if the item is deleted in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemDeletedInTarget | [read/write] Boolean.TRUE if the item is deleted in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemIsBinaryFile | [read/write] Boolean.TRUE if the item is a binary file. Default value is null ("Don't Know" / "Don't Care").
ItemModifiedInSource | [read/write] Boolean.TRUE if the item is modified in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemModifiedInTarget | [read/write] Boolean.TRUE if the item is modified in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemMovedInSource | [read/write] Boolean.TRUE if the item is moved in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemMovedInTarget | [read/write] Boolean.TRUE if the item is moved in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemPresentInSource | [read/write] Boolean.TRUE if the item is present in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemPresentInTarget | [read/write] Boolean.TRUE if the item is present in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemsHaveSameContent | [read/write] Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").
ItemsInDifferentBranches | [read/write] Boolean.TRUE if the items are in different branches. Default value is null ("Don't Know" / "Don't Care").
ItemTypeName | [read/write] The name of the item type. Default value is null, indicating that any type is acceptable.
MergeType | [read/write] The merge type. Default value is null, indicating that any merge type is acceptable.
ParentFolderDeletedInTarget | [read/write] Boolean.TRUE if the target item's parent folder has been deleted. Default value is null ("Don't Know" / "Don't Care").
ParentFolderFailed | [read/write] Boolean.TRUE if the target item's parent folder failed to be reconciled. Default value is null ("Don't Know" / "Don't Care").
ParentFolderIgnored | [read/write] Boolean.TRUE if the target item's parent folder is ignored. Default value is null ("Don't Know" / "Don't Care").
SomeChangedPropertiesExcludedFromMerge | [read/write] Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").
SourceChildShareOfTarget | [read/write] Boolean.TRUE if the source item is a child share of the target item. Default value is null ("Don't Know" / "Don't Care").
SourceIsFloating | [read/write] Boolean.TRUE if the source item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").
SourceItemOnRootBranch | [read/write] Boolean.TRUE if the source item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").
TargetChildShareOfSource | [read/write] Boolean.TRUE if the target item is a child share of the source item. Default value is null ("Don't Know" / "Don't Care").
TargetFolderHasFloatingShares | [read/write] Boolean.TRUE if the target item's parent folder has floating child shares. Default value is null ("Don't Know" / "Don't Care").
TargetIsFloating | [read/write] Boolean.TRUE if the target item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").
TargetItemOnRootBranch | [read/write] Boolean.TRUE if the target item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDeletedInSource Property

Borland StarTeam SDK for .NET

MatchState.ItemDeletedInSource Property

[read/write] Boolean.TRUE if the item is deleted in the source view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemDeletedInSource {get; set;}

Property Value

Boolean.TRUE if the item is deleted in the source view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDeletedInTarget Property

Borland StarTeam SDK for .NET

MatchState.ItemDeletedInTarget Property

[read/write] Boolean.TRUE if the item is deleted in the target view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemDeletedInTarget {get; set;}

Property Value

Boolean.TRUE if the item is deleted in the target view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemIsBinaryFile Property

Borland StarTeam SDK for .NET

MatchState.ItemIsBinaryFile Property

[read/write] Boolean.TRUE if the item is a binary file. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemIsBinaryFile {get; set;}

Property Value

Boolean.TRUE if the item is a binary file. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemModifiedInSource Property

Borland StarTeam SDK for .NET

MatchState.ItemModifiedInSource Property

[read/write] Boolean.TRUE if the item is modified in the source view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemModifiedInSource {get; set;}

Property Value

Boolean.TRUE if the item is modified in the source view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemModifiedInTarget Property

Borland StarTeam SDK for .NET

MatchState.ItemModifiedInTarget Property

[read/write] Boolean.TRUE if the item is modified in the target view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemModifiedInTarget {get; set;}

Property Value

Boolean.TRUE if the item is modified in the target view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemMovedInSource Property

Borland StarTeam SDK for .NET

MatchState.ItemMovedInSource Property

[read/write] Boolean.TRUE if the item is moved in the source view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemMovedInSource {get; set;}

Property Value

Boolean.TRUE if the item is moved in the source view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemMovedInTarget Property

Borland StarTeam SDK for .NET

MatchState.ItemMovedInTarget Property

[read/write] Boolean.TRUE if the item is moved in the target view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemMovedInTarget {get; set;}

Property Value

Boolean.TRUE if the item is moved in the target view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemPresentInSource Property

Borland StarTeam SDK for .NET

MatchState.ItemPresentInSource Property

[read/write] Boolean.TRUE if the item is present in the source view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemPresentInSource {get; set;}

Property Value

Boolean.TRUE if the item is present in the source view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemPresentInTarget Property

Borland StarTeam SDK for .NET

MatchState.ItemPresentInTarget Property

[read/write] Boolean.TRUE if the item is present in the target view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemPresentInTarget {get; set;}

Property Value

Boolean.TRUE if the item is present in the target view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemsHaveSameContent Property

Borland StarTeam SDK for .NET

MatchState.ItemsHaveSameContent Property

[read/write] Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemsHaveSameContent {get; set;}

Property Value

Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemsInDifferentBranches Property

Borland StarTeam SDK for .NET

MatchState.ItemsInDifferentBranches Property

[read/write] Boolean.TRUE if the items are in different branches. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemsInDifferentBranches {get; set;}

Property Value

Boolean.TRUE if the items are in different branches. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypeName Property

Borland StarTeam SDK for .NET

MatchState.ItemTypeName Property

[read/write] The name of the item type. Default value is null, indicating that any type is acceptable.

public virtual String ItemTypeName {get; set;}

Property Value

The name of the item type. Default value is null, indicating that any type is acceptable.

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType Property

Borland StarTeam SDK for .NET

MatchState.MergeType Property

[read/write] The merge type. Default value is null, indicating that any merge type is acceptable.

public virtual MergeType MergeType {get; set;}

Property Value

The merge type. Default value is null, indicating that any merge type is acceptable.

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ParentFolderDeletedInTarget Property

Borland StarTeam SDK for .NET

MatchState.ParentFolderDeletedInTarget Property

[read/write] Boolean.TRUE if the target item's parent folder has been deleted. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ParentFolderDeletedInTarget {get; set;}

Property Value

Boolean.TRUE if the target item's parent folder has been deleted. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ParentFolderFailed Property

Borland StarTeam SDK for .NET

MatchState.ParentFolderFailed Property

[read/write] Boolean.TRUE if the target item's parent folder failed to be reconciled. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ParentFolderFailed {get; set;}

Property Value

Boolean.TRUE if the target item's parent folder failed to be reconciled. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


ParentFolderIgnored Property

Borland StarTeam SDK for .NET

MatchState.ParentFolderIgnored Property

[read/write] Boolean.TRUE if the target item's parent folder is ignored. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ParentFolderIgnored {get; set;}

Property Value

Boolean.TRUE if the target item's parent folder is ignored. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


SomeChangedPropertiesExcludedFromMerge Property

Borland StarTeam SDK for .NET

MatchState.SomeChangedPropertiesExcludedFromMerge Property

[read/write] Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean SomeChangedPropertiesExcludedFromMerge {get; set;}

Property Value

Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


SourceChildShareOfTarget Property

Borland StarTeam SDK for .NET

MatchState.SourceChildShareOfTarget Property

[read/write] Boolean.TRUE if the source item is a child share of the target item. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean SourceChildShareOfTarget {get; set;}

Property Value

Boolean.TRUE if the source item is a child share of the target item. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


SourceIsFloating Property

Borland StarTeam SDK for .NET

MatchState.SourceIsFloating Property

[read/write] Boolean.TRUE if the source item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean SourceIsFloating {get; set;}

Property Value

Boolean.TRUE if the source item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


SourceItemOnRootBranch Property

Borland StarTeam SDK for .NET

MatchState.SourceItemOnRootBranch Property

[read/write] Boolean.TRUE if the source item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean SourceItemOnRootBranch {get; set;}

Property Value

Boolean.TRUE if the source item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


TargetChildShareOfSource Property

Borland StarTeam SDK for .NET

MatchState.TargetChildShareOfSource Property

[read/write] Boolean.TRUE if the target item is a child share of the source item. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean TargetChildShareOfSource {get; set;}

Property Value

Boolean.TRUE if the target item is a child share of the source item. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


TargetFolderHasFloatingShares Property

Borland StarTeam SDK for .NET

MatchState.TargetFolderHasFloatingShares Property

[read/write] Boolean.TRUE if the target item's parent folder has floating child shares. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean TargetFolderHasFloatingShares {get; set;}

Property Value

Boolean.TRUE if the target item's parent folder has floating child shares. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


TargetIsFloating Property

Borland StarTeam SDK for .NET

MatchState.TargetIsFloating Property

[read/write] Boolean.TRUE if the target item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean TargetIsFloating {get; set;}

Property Value

Boolean.TRUE if the target item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


TargetItemOnRootBranch Property

Borland StarTeam SDK for .NET

MatchState.TargetItemOnRootBranch Property

[read/write] Boolean.TRUE if the target item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean TargetItemOnRootBranch {get; set;}

Property Value

Boolean.TRUE if the target item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState Methods

The methods of the MatchState class are listed below. For a complete list of MatchState class members, see the MatchState Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.MatchState.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.MatchState.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.MatchState.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches | Determines whether or not this MatchState matches the conditions specified by the given pattern. "Don't Care" values in the pattern are ignored; other values in the pattern must match exactly.
SetParentFolderIgnored | Indicates whether or not the target item's parent folder is ignored.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.MatchState.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.MatchState

Implements

IWrapper.Unwrap

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.MatchState.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.MatchState.Equals(obj).

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.MatchState.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.MatchState.GetHashCode().

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState.Matches Method

Determines whether or not this MatchState matches the conditions specified by the given pattern. "Don't Care" values in the pattern are ignored; other values in the pattern must match exactly.

public virtual bool Matches(
MatchState pattern
);

Parameters

pattern
The pattern to be matched.

Return Value

true if this MatchState matches the given pattern; false otherwise.

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState.SetParentFolderIgnored Method

Indicates whether or not the target item's parent folder is ignored.

public virtual void SetParentFolderIgnored(
Boolean isIgnored
);

Parameters

isIgnored
True if the target item's parent folder is ignored.

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace | setParentFolderIgnored


MatchState.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.MatchState.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.MatchState.ToString()

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.MatchState.

public static MatchState Wrap(
MatchState impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.MatchState to be wrapped.

Return Value

MatchState

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchState Type Conversions

The type conversions of the MatchState class are listed below. For a complete list of MatchState class members, see the MatchState Members topic.

Public Static Type Conversions

Implicit MatchState to MatchState Conversion Implicitly convert MatchState to com.starbase.starteam.viewcomparemerge.MatchState.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MatchState Class | MatchState Members | Borland.StarTeam.Viewcomparemerge Namespace


MatchState Implicit MatchState to MatchState Conversion

Implicitly convert MatchState to com.starbase.starteam.viewcomparemerge.MatchState.

public static implicit operator MatchState(
MatchState arg
);

Parameters

arg
MatchState to convert.

Return Value

com.starbase.starteam.viewcomparemerge.MatchState

See Also

MatchState Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction Class

An action that may be used to resolve a merge condition.

For a list of all members of this type, see MergeAction Members.

System.Object
MergeAction

public class MergeAction : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MergeAction Members | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction Members

MergeAction overview

Public Static Properties

AllActions | [read] MergeAction[] an array of all MergeAction instances
AllPrimitiveActions | [read] MergeAction[] an array of all primitive MergeAction instances
DELETE |
DELETE_AND_REVERSE_SHARE |
FAIL |
IGNORE |
MARK_RESOLVED |
MERGE |
MOVE |
MOVE_AND_MERGE |
MOVE_AND_OVERWRITE |
MOVE_AND_RE_PIN |
NEEDS_REVIEW |
OVERWRITE |
RE_PIN |
REVERSE_SHARE |
SHARE |

Public Static Methods

FromID | Gets the MergeAction that corresponds to the given action ID.
Wrap | Dynamically wraps com.starbase.starteam.viewcomparemerge.MergeAction.

Public Static Type Conversions

Implicit MergeAction to MergeAction Conversion Implicitly convert MergeAction to com.starbase.starteam.viewcomparemerge.MergeAction.

Public Instance Constructors

MergeAction Constructor Construct MergeAction from com.starbase.starteam.viewcomparemerge.MergeAction.

Public Instance Properties

ID | [read] The unique ID associated with this action.
Name | [read] String a String representation of this merge action

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.MergeAction.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.MergeAction.
GetType (inherited from Object) | Gets the Type of the current instance.
Includes | Determines whether or not this action includes the primitives specified in the given action, in any order.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.MergeAction.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction Constructor

Construct MergeAction from com.starbase.starteam.viewcomparemerge.MergeAction.

public MergeAction(
MergeAction impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.MergeAction to be wrapped.

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction Properties

The properties of the MergeAction class are listed below. For a complete list of MergeAction class members, see the MergeAction Members topic.

Public Static Properties

AllActions | [read] MergeAction[] an array of all MergeAction instances
AllPrimitiveActions | [read] MergeAction[] an array of all primitive MergeAction instances
DELETE |
DELETE_AND_REVERSE_SHARE |
FAIL |
IGNORE |
MARK_RESOLVED |
MERGE |
MOVE |
MOVE_AND_MERGE |
MOVE_AND_OVERWRITE |
MOVE_AND_RE_PIN |
NEEDS_REVIEW |
OVERWRITE |
RE_PIN |
REVERSE_SHARE |
SHARE |

Public Instance Properties

ID | [read] The unique ID associated with this action.
Name | [read] String a String representation of this merge action

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


AllActions Property

Borland StarTeam SDK for .NET

MergeAction.AllActions Property

[read] MergeAction[] an array of all MergeAction instances

public static MergeActionCollection AllActions {get;}

Property Value

MergeAction[] an array of all MergeAction instances

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


AllPrimitiveActions Property

Borland StarTeam SDK for .NET

MergeAction.AllPrimitiveActions Property

[read] MergeAction[] an array of all primitive MergeAction instances

public static MergeActionCollection AllPrimitiveActions {get;}

Property Value

MergeAction[] an array of all primitive MergeAction instances

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


DELETE Property

Borland StarTeam SDK for .NET

MergeAction.DELETE Property

public static MergeAction DELETE {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


DELETE_AND_REVERSE_SHARE Property

Borland StarTeam SDK for .NET

MergeAction.DELETE_AND_REVERSE_SHARE Property

public static MergeAction DELETE_AND_REVERSE_SHARE {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


FAIL Property

Borland StarTeam SDK for .NET

MergeAction.FAIL Property

public static MergeAction FAIL {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


ID Property

Borland StarTeam SDK for .NET

MergeAction.ID Property

[read] The unique ID associated with this action.

public virtual Int32 ID {get;}

Property Value

The unique ID associated with this action.

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


IGNORE Property

Borland StarTeam SDK for .NET

MergeAction.IGNORE Property

public static MergeAction IGNORE {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MARK_RESOLVED Property

Borland StarTeam SDK for .NET

MergeAction.MARK_RESOLVED Property

public static MergeAction MARK_RESOLVED {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MERGE Property

Borland StarTeam SDK for .NET

MergeAction.MERGE Property

public static MergeAction MERGE {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MOVE Property

Borland StarTeam SDK for .NET

MergeAction.MOVE Property

public static MergeAction MOVE {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MOVE_AND_MERGE Property

Borland StarTeam SDK for .NET

MergeAction.MOVE_AND_MERGE Property

public static MergeAction MOVE_AND_MERGE {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MOVE_AND_OVERWRITE Property

Borland StarTeam SDK for .NET

MergeAction.MOVE_AND_OVERWRITE Property

public static MergeAction MOVE_AND_OVERWRITE {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MOVE_AND_RE_PIN Property

Borland StarTeam SDK for .NET

MergeAction.MOVE_AND_RE_PIN Property

public static MergeAction MOVE_AND_RE_PIN {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


Name Property

Borland StarTeam SDK for .NET

MergeAction.Name Property

[read] String a String representation of this merge action

public virtual String Name {get;}

Property Value

String a String representation of this merge action

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


NEEDS_REVIEW Property

Borland StarTeam SDK for .NET

MergeAction.NEEDS_REVIEW Property

public static MergeAction NEEDS_REVIEW {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


OVERWRITE Property

Borland StarTeam SDK for .NET

MergeAction.OVERWRITE Property

public static MergeAction OVERWRITE {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


RE_PIN Property

Borland StarTeam SDK for .NET

MergeAction.RE_PIN Property

public static MergeAction RE_PIN {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


REVERSE_SHARE Property

Borland StarTeam SDK for .NET

MergeAction.REVERSE_SHARE Property

public static MergeAction REVERSE_SHARE {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


SHARE Property

Borland StarTeam SDK for .NET

MergeAction.SHARE Property

public static MergeAction SHARE {get;}

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction Methods

The methods of the MergeAction class are listed below. For a complete list of MergeAction class members, see the MergeAction Members topic.

Public Static Methods

FromID | Gets the MergeAction that corresponds to the given action ID.
Wrap | Dynamically wraps com.starbase.starteam.viewcomparemerge.MergeAction.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.MergeAction.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.MergeAction.
GetType (inherited from Object) | Gets the Type of the current instance.
Includes | Determines whether or not this action includes the primitives specified in the given action, in any order.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.MergeAction.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.MergeAction

Implements

IWrapper.Unwrap

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.MergeAction.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.MergeAction.Equals(obj).

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction.FromID Method

Gets the MergeAction that corresponds to the given action ID.

public static MergeAction FromID(
Int32 actionID
);

Parameters

actionID
The unique ID of some merge action.

Return Value

The merge action.

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace | getID


MergeAction.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.MergeAction.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.MergeAction.GetHashCode().

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction.Includes Method

Determines whether or not this action includes the primitives specified in the given action, in any order.

public virtual bool Includes(
MergeAction action
);

Parameters

action
The MergeAction to be found.

Return Value

True if this action includes all the primitives specified in the given action, in any order; false otherwise.

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.MergeAction.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.MergeAction.ToString()

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.MergeAction.

public static MergeAction Wrap(
MergeAction impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.MergeAction to be wrapped.

Return Value

MergeAction

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction Type Conversions

The type conversions of the MergeAction class are listed below. For a complete list of MergeAction class members, see the MergeAction Members topic.

Public Static Type Conversions

Implicit MergeAction to MergeAction Conversion Implicitly convert MergeAction to com.starbase.starteam.viewcomparemerge.MergeAction.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergeAction Class | MergeAction Members | Borland.StarTeam.Viewcomparemerge Namespace


MergeAction Implicit MergeAction to MergeAction Conversion

Implicitly convert MergeAction to com.starbase.starteam.viewcomparemerge.MergeAction.

public static implicit operator MergeAction(
MergeAction arg
);

Parameters

arg
MergeAction to convert.

Return Value

com.starbase.starteam.viewcomparemerge.MergeAction

See Also

MergeAction Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection Class

A strongly-typed collection of MergeActions.

For a list of all members of this type, see MergeActionCollection Members.

System.Object
ArrayAdapter
MergeActionCollection

public class MergeActionCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MergeActionCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection Members

MergeActionCollection overview

Public Static Methods

Wrap Creates a MergeActionCollection to represent the given array of MergeAction (from the com.starbase.starteam.viewcomparemerge namespace).

Public Static Type Conversions

Implicit MergeActionCollection to MergeAction[] Conversion | Converts a MergeActionCollection to an array of MergeActions.
Implicit MergeActionCollection to MergeAction[] Conversion | Converts a MergeActionCollection from the Borland.StarTeam.Viewcomparemerge namespace to a MergeAction[] in the com.starbase.starteam.viewcomparemerge namespace.

Public Instance Constructors

MergeActionCollection Overloaded. Initializes a new instance of the MergeActionCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the MergeAction at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a MergeAction to end of the collection.
Append | Overloaded. Appends the MergeActions of the given MergeActionCollection to the end of this MergeActionCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific MergeAction.
CopyTo | Copies all of the MergeActions in the MergeActionCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the MergeAction with the given ID.
FindByName | Finds the MergeAction with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific MergeAction in the collection.
Insert | Inserts a MergeAction into the collection at the specified position.
Remove | Removes the first occurrence of a specific MergeAction from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the MergeActions in this MergeActionCollection.
Sort | Sorts the MergeActions in this MergeActionCollection, using the given comparer.
SortByID | Sorts the MergeActions in this MergeActionCollection by ID.
SortByName | Sorts the MergeActions in this MergeActionCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection Constructor

Initializes an instance of the MergeActionCollection class.

Overload List

Initializes an instance of the MergeActionCollection class.

public MergeActionCollection();

Initializes an instance of the a MergeActionCollection class, copying the given array.

public MergeActionCollection(MergeAction[]);

Initializes an instance of the a MergeActionCollection class, copying the given collection.

public MergeActionCollection(MergeActionCollection);

Initializes an instance of the a MergeActionCollection class, wrapping the given array of MergeAction (from the com.starbase.starteam.viewcomparemerge namespace).

public MergeActionCollection(MergeAction[]);

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection Constructor ()

Initializes an instance of the MergeActionCollection class.

public MergeActionCollection();

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeActionCollection Constructor Overload List


MergeActionCollection Constructor (MergeAction[])

Initializes an instance of the a MergeActionCollection class, wrapping the given array of MergeAction (from the com.starbase.starteam.viewcomparemerge namespace).

public MergeActionCollection(
MergeAction[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam.viewcomparemerge namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeActionCollection Constructor Overload List | Wrap


MergeActionCollection Constructor (MergeActionCollection)

Initializes an instance of the a MergeActionCollection class, copying the given collection.

public MergeActionCollection(
MergeActionCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member MergeAction objects of the original collection are shared, not copied.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeActionCollection Constructor Overload List


MergeActionCollection Constructor (MergeAction[])

Initializes an instance of the a MergeActionCollection class, copying the given array.

public MergeActionCollection(
MergeAction[] array
);

Parameters

array
The array to be copied.

Remarks

The member MergeAction objects of the original array are shared, not copied.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeActionCollection Constructor Overload List


MergeActionCollection Properties

The properties of the MergeActionCollection class are listed below. For a complete list of MergeActionCollection class members, see the MergeActionCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the MergeAction at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Item Property

Borland StarTeam SDK for .NET

MergeActionCollection.Item Property

Gets or sets the MergeAction at the specified index.

Overload List

Gets or sets the MergeAction at the specified index.

public MergeAction this[Int32] {get; set;}

Gets the MergeAction with the given name.

public MergeAction this[String] {get;}

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

MergeActionCollection.Item Property (Int32)

Gets or sets the MergeAction at the specified index.

public MergeAction this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the MergeAction to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeActionCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

MergeActionCollection.Item Property (String)

Gets the MergeAction with the given name.

public MergeAction this[
String name
] {get;}

Parameters

name
The name of the MergeAction to get.

Property Value

The MergeAction with the given name, or null if there is no MergeAction with that name in this MergeActionCollection. Comparison is case sensitive.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeActionCollection.Item Overload List | FindByName


MergeActionCollection Methods

The methods of the MergeActionCollection class are listed below. For a complete list of MergeActionCollection class members, see the MergeActionCollection Members topic.

Public Static Methods

Wrap Creates a MergeActionCollection to represent the given array of MergeAction (from the com.starbase.starteam.viewcomparemerge namespace).

Public Instance Methods

Add | Adds a MergeAction to end of the collection.
Append | Overloaded. Appends the MergeActions of the given MergeActionCollection to the end of this MergeActionCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific MergeAction.
CopyTo | Copies all of the MergeActions in the MergeActionCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID | Finds the MergeAction with the given ID.
FindByName | Finds the MergeAction with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific MergeAction in the collection.
Insert | Inserts a MergeAction into the collection at the specified position.
Remove | Removes the first occurrence of a specific MergeAction from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the MergeActions in this MergeActionCollection.
Sort | Sorts the MergeActions in this MergeActionCollection, using the given comparer.
SortByID | Sorts the MergeActions in this MergeActionCollection by ID.
SortByName | Sorts the MergeActions in this MergeActionCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.Add Method

Adds a MergeAction to end of the collection.

public int Add(
MergeAction value
);

Parameters

value
The MergeAction to add to the collection.

Return Value

The position into which the new MergeAction was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Append Method

Borland StarTeam SDK for .NET

MergeActionCollection.Append Method

Appends the MergeActions of the given array to the end of this MergeActionCollection.

Overload List

Appends the MergeActions of the given array to the end of this MergeActionCollection.

public MergeActionCollection Append(MergeAction[]);

Appends the MergeActions of the given MergeActionCollection to the end of this MergeActionCollection.

public MergeActionCollection Append(MergeActionCollection);

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.Append Method (MergeAction[])

Appends the MergeActions of the given array to the end of this MergeActionCollection.

public MergeActionCollection Append(
MergeAction[] array
);

Parameters

array
The array whose MergeActions are to be appended to this MergeActionCollection.

Return Value

This MergeActionCollection, modified to include the new MergeActions.

Remarks

The MergeActionCollection is modified to include the new members. The individual MergeAction objects are shared, not copied.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeActionCollection.Append Overload List


MergeActionCollection.Append Method (MergeActionCollection)

Appends the MergeActions of the given MergeActionCollection to the end of this MergeActionCollection.

public MergeActionCollection Append(
MergeActionCollection collection
);

Parameters

collection
The MergeActionCollection whose MergeActions are to be appended to this MergeActionCollection.

Return Value

This MergeActionCollection, modified to include the new MergeActions.

Remarks

The MergeActionCollection is modified to include the new members. The individual MergeAction objects are shared, not copied.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeActionCollection.Append Overload List


MergeActionCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.viewcomparemerge.MergeAction[].

Implements

IWrapper.Unwrap

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.Contains Method

Determines whether or not the collection contains a specific MergeAction.

public bool Contains(
MergeAction value
);

Parameters

value
The MergeAction to locate in the collection.

Return Value

true if the MergeAction is found in the collection; otherwise, false.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.CopyTo Method

Copies all of the MergeActions in the MergeActionCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
MergeAction[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the MergeActions copied from the MergeActionCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of MergeActions in the source MergeActionCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source MergeActionCollection cannot be cast automatically to the type of the destination array.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.FindByID Method

Finds the MergeAction with the given ID.

public MergeAction FindByID(
Int32 id
);

Parameters

id
The ID of the MergeAction to be found.

Return Value

The MergeAction with the given ID, or null if there is no MergeAction with that ID in this MergeActionCollection.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.FindByName Method

Finds the MergeAction with the given name.

public MergeAction FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the MergeAction to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The MergeAction with the given name, or null if there is no MergeAction with that name in this MergeActionCollection.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.IndexOf Method

Determines the index of a specific MergeAction in the collection.

public int IndexOf(
MergeAction value
);

Parameters

value
The MergeAction to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.Insert Method

Inserts a MergeAction into the collection at the specified position.

public void Insert(
Int32 index,
MergeAction value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The MergeAction to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.Remove Method

Removes the first occurrence of a specific MergeAction from the collection.

public void Remove(
MergeAction value
);

Parameters

value
The MergeAction to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.Reverse Method

Reverses the order of the MergeActions in this MergeActionCollection.

new public MergeActionCollection Reverse();

Return Value

This MergeActionCollection, modified such that the MergeActions are reversed.

Remarks

The MergeActionCollection is modified in place.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.Sort Method

Sorts the MergeActions in this MergeActionCollection, using the given comparer.

new public MergeActionCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two MergeActions.

Return Value

This MergeActionCollection, modified such that the MergeActions are sorted.

Remarks

The MergeActionCollection is modified in place.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.SortByID Method

Sorts the MergeActions in this MergeActionCollection by ID.

public MergeActionCollection SortByID();

Return Value

This MergeActionCollection, modified such that the MergeActions are sorted by ID.

Remarks

The MergeActionCollection is modified in place.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.SortByName Method

Sorts the MergeActions in this MergeActionCollection by name.

public MergeActionCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This MergeActionCollection, modified such that the MergeActions are sorted by name.

Remarks

The MergeActionCollection is modified in place.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection.Wrap Method

Creates a MergeActionCollection to represent the given array of MergeAction (from the com.starbase.starteam.viewcomparemerge namespace).

public static MergeActionCollection Wrap(
MergeAction[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new MergeActionCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a MergeAction[] from the com.starbase.starteam.viewcomparemerge namespace to the Borland.StarTeam.Viewcomparemerge namespace.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection Type Conversions

The type conversions of the MergeActionCollection class are listed below. For a complete list of MergeActionCollection class members, see the MergeActionCollection Members topic.

Public Static Type Conversions

Implicit MergeActionCollection to MergeAction[] Conversion | Converts a MergeActionCollection to an array of MergeActions.
Implicit MergeActionCollection to MergeAction[] Conversion | Converts a MergeActionCollection from the Borland.StarTeam.Viewcomparemerge namespace to a MergeAction[] in the com.starbase.starteam.viewcomparemerge namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

MergeActionCollection Class | MergeActionCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection Implicit MergeActionCollection to MergeAction[] Conversion

Converts a MergeActionCollection to an array of MergeActions.

public static implicit operator MergeAction[](
MergeActionCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new MergeAction wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one MergeAction wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeActionCollection Implicit MergeActionCollection to MergeAction[] Conversion

Converts a MergeActionCollection from the Borland.StarTeam.Viewcomparemerge namespace to a MergeAction[] in the com.starbase.starteam.viewcomparemerge namespace.

public static implicit operator MergeAction[](
MergeActionCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam.Viewcomparemerge namespace to methods in the com.starbase.starteam.viewcomparemerge namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, MergeActionCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

MergeActionCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergePreview Class

Title: Starteam SDK

Description: A MergePreview is a read-only reference View with additional properties, and some local, context specific overrides

Copyright: Copyright (c) 2001

Company: Borland Corporation

For a list of all members of this type, see MergePreview Members.

System.Object
TypedResource
SimpleTypedResource
View
MergePreview

public class MergePreview : View

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MergePreview Members | Borland.StarTeam.Viewcomparemerge Namespace


MergePreview Members

MergePreview overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.MergePreview.

Public Static Type Conversions

Implicit MergePreview to MergePreview Conversion Implicitly convert MergePreview to com.starbase.starteam.viewcomparemerge.MergePreview.

Public Instance Constructors

MergePreview Constructor Construct MergePreview from com.starbase.starteam.viewcomparemerge.MergePreview.

Public Instance Properties

ACL (inherited from View) |
ActiveLabels (inherited from View) | [read] The active (non-deleted) labels for this view.
AlternatePath (inherited from View) | [read/write] the alternate working file path to be used for this view.
BaseConfiguration (inherited from View) | [read] the ViewConfiguration from which this View was derived.
Configuration (inherited from View) | [read] this view's configuration.
CreatedBy (inherited from View) | [read] the user ID of the user that created the view.
CreatedTime (inherited from View) | [read] the time at which the view was created.
DefaultPath (inherited from View) | [read/write] the default working file path to be used for this view.
DerivedViews (inherited from View) | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description (inherited from View) | [read/write] the description of this view.
FileStatusManager (inherited from View) | [read] The FileBasedStatusManager for this View.
FullName (inherited from View) | [read] the full hierarchical name of this view.
HaveAccessRights (inherited from View) | [read] true if the logged on user has rights to access this view.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsAccessible (inherited from View) | [read] true if the logged on user has access to this view.
IsBranch (inherited from View) | [read] true if this view is a Branch view.
IsBranchAll (inherited from View) | [read] true if this view's original branching default was set "All".
IsBranchNone (inherited from View) | [read] true if this view's original branching default was set "None".
IsBranchOnShare (inherited from View) | [read/write] true if this view is set to branch shared items.
IsDeleted (inherited from View) | [read] True if the view has been deleted from the server; false otherwise.
IsNonDerived (inherited from View) | [read] true if this view is Non-Derived view.
IsReadOnly (inherited from View) | [read] true if this view is ReadOnly, otherwise false.
IsReference (inherited from View) | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired (inherited from View) | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired (inherited from View) | [read] true if folder information may be out of date.
IsRefreshLabelsRequired (inherited from View) | [read] true if label information may be out of date.
IsRefreshRequired (inherited from View) | [read] true if view properties may be out of date.
IsRoot (inherited from View) | [read] true if this view is a Root view.
Item (inherited from TypedResource) |
Labels (inherited from View) | [read] The labels (both active and deleted) that exist in this view.
Name (inherited from View) | [read/write] the name of this view.
Owner (inherited from View) |
ParentContainer (inherited from View) |
ParentView (inherited from View) | [read] the parent of this view, or null if there is no parent.
Path (inherited from View) | [read] the working file path being used for this view.
Project (inherited from View) | [read] the project to which this view belongs.
PromotionModel (inherited from View) | [read] the promotion model associated with this view.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
RecycleBin (inherited from View) | [read] The recycle bin associated with this view.
RootFolder (inherited from View) | [read] The root folder of this view.
Server (inherited from View) | [read] the server to which this view belongs.
Session | [read] Session the Session that this view belongs to
StatusMethodOverride (inherited from View) | [read/write]
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
ViewID (inherited from View) | [read] the unique integer identifier for this view.

Public Instance Methods

AcquireOwnership (inherited from View) |
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
CloneRevisionLabel (inherited from View) | Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed.
CloneViewLabel (inherited from View) | Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed.
Close (inherited from View) | Frees all cached resources associated with this view, and closes the associated view session. Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
Copy (inherited from View) | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
CreateCheckinManager (inherited from View) | Overloaded. Constructs a CheckinManager with default options for this view.
CreateCheckoutManager (inherited from View) | Overloaded. Constructs a CheckoutManager with default options for this view.
CreateChildViewShareAllItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.
CreateChildViewShareDefaultItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.
CreateChildViewShareNoItems (inherited from View) | Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.
CreateChildViewShareTheseItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.
CreateRevisionLabel (inherited from View) | Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
CreateViewLabel (inherited from View) | Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
Discard (inherited from View) | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardActiveLabels (inherited from View) | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
DiscardFolders (inherited from View) | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardLabels (inherited from View) | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
FetchAllLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
FetchAllLabelsFromView (inherited from View) | Returns all the active (non-deleted) labels for the given project and view. This method is only available for 4.1 and later servers. The labels are not cached. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. fetchAllLabelsFromView() is not MPX-enabled; the labels are always retrieved directly from the repository.
FindFolder (inherited from View) | Returns a Folder in the View, given its Item ID, or NULL if none found.
FindItem (inherited from View) | Returns an Item in the View, given its Type and Item ID, or NULL if none found.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetContainerLevelACL (inherited from View) |
GetDisembodiedItem (inherited from View) | Retrieves an Item by Item ID. The Item can reside anywhere in this view, or in any other view on the same server. However, the resulting Item is "disembodied"; that is, it is not attached to its normal parent Folder. Disembodied Items are useful for resolving LinkEndpoints, which can cross project and view boundaries. However, many normal Item operations are not supported for disembodied items. getDisembodiedItem() is not MPX-enabled; each call to getDisembodiedItem() retrieves data directly from the server.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetHistoryForItemID (inherited from View) | Returns "disembodied" Items from the item history
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetNewNotificationItems (inherited from View) | Return the list of "notification" items for the specified type. This method will not return null but may return an empty list. Once this call has been made to the server for a particular view subsequent calls will not return the same information. The act of getting the information "clears" it from the server.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasNewNotificationItems (inherited from View) | Return true if any new notification items are available in this view for the specified item type.
HasPermission (inherited from View) | Overloaded.
IsEqualTo (inherited from View) | Compares the properties of two Views.
ModifyItemsFlagForUser (inherited from View) | Modifies this items flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyItemsReadStatusForUser (inherited from View) | Modifies this list of item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File items.
NewFolderEventSource (inherited from View) |
NewFolderTreeEventSource (inherited from View) |
NewFolderUpdateEventSource (inherited from View) |
NewItemEventSource (inherited from View) | Overloaded.
NewItemIDEventSource (inherited from View) | Overloaded.
NewItemListEventSource (inherited from View) | Overloaded.
NewItemUpdateEventSource (inherited from View) |
NewLabelEventSource (inherited from View) |
NewNotificationEventSource (inherited from View) | Overloaded.
NewViewEventSource (inherited from View) |
Populate (inherited from View) | Populates project properties, if they have not already been populated.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
Refresh (inherited from View) | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshActiveLabels (inherited from View) | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
RefreshFolders (inherited from View) | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
RefreshLabels (inherited from View) | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
RefreshPromotionModel (inherited from View) | Refreshes the local cached information about this view's promotion model.
Remove (inherited from View) | Removes the view from the server.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveLinkEndpoint (inherited from View) | Returns the item in this view referred to by the LinkEndpoint. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
SetContainerLevelACL (inherited from View) |
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Update (inherited from View) | Persists this view's properties to its Server.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

MergePreview Class | Borland.StarTeam.Viewcomparemerge Namespace


MergePreview Constructor

Construct MergePreview from com.starbase.starteam.viewcomparemerge.MergePreview.

public MergePreview(
MergePreview impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.MergePreview to be wrapped.

See Also

MergePreview Class | Borland.StarTeam.Viewcomparemerge Namespace


MergePreview Properties

The properties of the MergePreview class are listed below. For a complete list of MergePreview class members, see the MergePreview Members topic.

Public Instance Properties

ACL (inherited from View) |
ActiveLabels (inherited from View) | [read] The active (non-deleted) labels for this view.
AlternatePath (inherited from View) | [read/write] the alternate working file path to be used for this view.
BaseConfiguration (inherited from View) | [read] the ViewConfiguration from which this View was derived.
Configuration (inherited from View) | [read] this view's configuration.
CreatedBy (inherited from View) | [read] the user ID of the user that created the view.
CreatedTime (inherited from View) | [read] the time at which the view was created.
DefaultPath (inherited from View) | [read/write] the default working file path to be used for this view.
DerivedViews (inherited from View) | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description (inherited from View) | [read/write] the description of this view.
FileStatusManager (inherited from View) | [read] The FileBasedStatusManager for this View.
FullName (inherited from View) | [read] the full hierarchical name of this view.
HaveAccessRights (inherited from View) | [read] true if the logged on user has rights to access this view.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsAccessible (inherited from View) | [read] true if the logged on user has access to this view.
IsBranch (inherited from View) | [read] true if this view is a Branch view.
IsBranchAll (inherited from View) | [read] true if this view's original branching default was set "All".
IsBranchNone (inherited from View) | [read] true if this view's original branching default was set "None".
IsBranchOnShare (inherited from View) | [read/write] true if this view is set to branch shared items.
IsDeleted (inherited from View) | [read] True if the view has been deleted from the server; false otherwise.
IsNonDerived (inherited from View) | [read] true if this view is Non-Derived view.
IsReadOnly (inherited from View) | [read] true if this view is ReadOnly, otherwise false.
IsReference (inherited from View) | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired (inherited from View) | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired (inherited from View) | [read] true if folder information may be out of date.
IsRefreshLabelsRequired (inherited from View) | [read] true if label information may be out of date.
IsRefreshRequired (inherited from View) | [read] true if view properties may be out of date.
IsRoot (inherited from View) | [read] true if this view is a Root view.
Item (inherited from TypedResource) |
Labels (inherited from View) | [read] The labels (both active and deleted) that exist in this view.
Name (inherited from View) | [read/write] the name of this view.
Owner (inherited from View) |
ParentContainer (inherited from View) |
ParentView (inherited from View) | [read] the parent of this view, or null if there is no parent.
Path (inherited from View) | [read] the working file path being used for this view.
Project (inherited from View) | [read] the project to which this view belongs.
PromotionModel (inherited from View) | [read] the promotion model associated with this view.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
RecycleBin (inherited from View) | [read] The recycle bin associated with this view.
RootFolder (inherited from View) | [read] The root folder of this view.
Server (inherited from View) | [read] the server to which this view belongs.
Session | [read] Session the Session that this view belongs to
StatusMethodOverride (inherited from View) | [read/write]
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
ViewID (inherited from View) | [read] the unique integer identifier for this view.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

MergePreview Class | Borland.StarTeam.Viewcomparemerge Namespace


Session Property

Borland StarTeam SDK for .NET

MergePreview.Session Property

[read] Session the Session that this view belongs to

public virtual Session Session {get;}

Property Value

Session the Session that this view belongs to

See Also

MergePreview Class | Borland.StarTeam.Viewcomparemerge Namespace


MergePreview Methods

The methods of the MergePreview class are listed below. For a complete list of MergePreview class members, see the MergePreview Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.MergePreview.

Public Instance Methods

AcquireOwnership (inherited from View) |
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
CloneRevisionLabel (inherited from View) | Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed.
CloneViewLabel (inherited from View) | Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed.
Close (inherited from View) | Frees all cached resources associated with this view, and closes the associated view session. Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
Copy (inherited from View) | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
CreateCheckinManager (inherited from View) | Overloaded. Constructs a CheckinManager with default options for this view.
CreateCheckoutManager (inherited from View) | Overloaded. Constructs a CheckoutManager with default options for this view.
CreateChildViewShareAllItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.
CreateChildViewShareDefaultItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.
CreateChildViewShareNoItems (inherited from View) | Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.
CreateChildViewShareTheseItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.
CreateRevisionLabel (inherited from View) | Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
CreateViewLabel (inherited from View) | Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
Discard (inherited from View) | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardActiveLabels (inherited from View) | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
DiscardFolders (inherited from View) | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardLabels (inherited from View) | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
FetchAllLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
FetchAllLabelsFromView (inherited from View) | Returns all the active (non-deleted) labels for the given project and view. This method is only available for 4.1 and later servers. The labels are not cached. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. fetchAllLabelsFromView() is not MPX-enabled; the labels are always retrieved directly from the repository.
FindFolder (inherited from View) | Returns a Folder in the View, given its Item ID, or NULL if none found.
FindItem (inherited from View) | Returns an Item in the View, given its Type and Item ID, or NULL if none found.
Get (inherited from TypedResource) | Return the value for the specified property.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetContainerLevelACL (inherited from View) |
GetDisembodiedItem (inherited from View) | Retrieves an Item by Item ID. The Item can reside anywhere in this view, or in any other view on the same server. However, the resulting Item is "disembodied"; that is, it is not attached to its normal parent Folder. Disembodied Items are useful for resolving LinkEndpoints, which can cross project and view boundaries. However, many normal Item operations are not supported for disembodied items. getDisembodiedItem() is not MPX-enabled; each call to getDisembodiedItem() retrieves data directly from the server.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetHistoryForItemID (inherited from View) | Returns "disembodied" Items from the item history
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetNewNotificationItems (inherited from View) | Return the list of "notification" items for the specified type. This method will not return null but may return an empty list. Once this call has been made to the server for a particular view subsequent calls will not return the same information. The act of getting the information "clears" it from the server.
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasNewNotificationItems (inherited from View) | Return true if any new notification items are available in this view for the specified item type.
HasPermission (inherited from View) | Overloaded.
IsEqualTo (inherited from View) | Compares the properties of two Views.
ModifyItemsFlagForUser (inherited from View) | Modifies this items flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyItemsReadStatusForUser (inherited from View) | Modifies this list of item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File items.
NewFolderEventSource (inherited from View) |
NewFolderTreeEventSource (inherited from View) |
NewFolderUpdateEventSource (inherited from View) |
NewItemEventSource (inherited from View) | Overloaded.
NewItemIDEventSource (inherited from View) | Overloaded.
NewItemListEventSource (inherited from View) | Overloaded.
NewItemUpdateEventSource (inherited from View) |
NewLabelEventSource (inherited from View) |
NewNotificationEventSource (inherited from View) | Overloaded.
NewViewEventSource (inherited from View) |
Populate (inherited from View) | Populates project properties, if they have not already been populated.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
Refresh (inherited from View) | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshActiveLabels (inherited from View) | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
RefreshFolders (inherited from View) | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
RefreshLabels (inherited from View) | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
RefreshPromotionModel (inherited from View) | Refreshes the local cached information about this view's promotion model.
Remove (inherited from View) | Removes the view from the server.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveLinkEndpoint (inherited from View) | Returns the item in this view referred to by the LinkEndpoint. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
SetContainerLevelACL (inherited from View) |
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Update (inherited from View) | Persists this view's properties to its Server.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

MergePreview Class | Borland.StarTeam.Viewcomparemerge Namespace


MergePreview.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.MergePreview.

public static MergePreview Wrap(
MergePreview impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.MergePreview to be wrapped.

Return Value

MergePreview

See Also

MergePreview Class | Borland.StarTeam.Viewcomparemerge Namespace


MergePreview Type Conversions

The type conversions of the MergePreview class are listed below. For a complete list of MergePreview class members, see the MergePreview Members topic.

Public Static Type Conversions

Implicit MergePreview to MergePreview Conversion Implicitly convert MergePreview to com.starbase.starteam.viewcomparemerge.MergePreview.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

MergePreview Class | MergePreview Members | Borland.StarTeam.Viewcomparemerge Namespace


MergePreview Implicit MergePreview to MergePreview Conversion

Implicitly convert MergePreview to com.starbase.starteam.viewcomparemerge.MergePreview.

public static implicit operator MergePreview(
MergePreview arg
);

Parameters

arg
MergePreview to convert.

Return Value

com.starbase.starteam.viewcomparemerge.MergePreview

See Also

MergePreview Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType Class

The type of view compare/merge operation to be performed.

For a list of all members of this type, see MergeType Members.

System.Object
MergeType

public class MergeType : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MergeType Members | Borland.StarTeam.Viewcomparemerge Namespace


MergeType Members

MergeType overview

Public Static Properties

COMPARE
PROMOTE
REBASE
REPLICATE

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.MergeType.

Public Static Type Conversions

Implicit MergeType to MergeType Conversion Implicitly convert MergeType to com.starbase.starteam.viewcomparemerge.MergeType.

Public Instance Constructors

MergeType Constructor Construct MergeType from com.starbase.starteam.viewcomparemerge.MergeType.

Public Instance Properties

AllMergeTypes | [read] A list of all supported merge types.
Name | [read] The user-friendly name of this merge type.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.MergeType.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.MergeType.
GetType (inherited from Object) | Gets the Type of the current instance.
IntValue | Gets an integer ID that is unique for each merge type.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.MergeType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType Constructor

Construct MergeType from com.starbase.starteam.viewcomparemerge.MergeType.

public MergeType(
MergeType impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.MergeType to be wrapped.

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType Properties

The properties of the MergeType class are listed below. For a complete list of MergeType class members, see the MergeType Members topic.

Public Static Properties

COMPARE
PROMOTE
REBASE
REPLICATE

Public Instance Properties

AllMergeTypes | [read] A list of all supported merge types.
Name | [read] The user-friendly name of this merge type.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


AllMergeTypes Property

Borland StarTeam SDK for .NET

MergeType.AllMergeTypes Property

[read] A list of all supported merge types.

public virtual MergeTypeCollection AllMergeTypes {get;}

Property Value

A list of all supported merge types.

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


COMPARE Property

Borland StarTeam SDK for .NET

MergeType.COMPARE Property

public static MergeType COMPARE {get;}

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


Name Property

Borland StarTeam SDK for .NET

MergeType.Name Property

[read] The user-friendly name of this merge type.

public virtual String Name {get;}

Property Value

The user-friendly name of this merge type.

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


PROMOTE Property

Borland StarTeam SDK for .NET

MergeType.PROMOTE Property

public static MergeType PROMOTE {get;}

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


REBASE Property

Borland StarTeam SDK for .NET

MergeType.REBASE Property

public static MergeType REBASE {get;}

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


REPLICATE Property

Borland StarTeam SDK for .NET

MergeType.REPLICATE Property

public static MergeType REPLICATE {get;}

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType Methods

The methods of the MergeType class are listed below. For a complete list of MergeType class members, see the MergeType Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.MergeType.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.MergeType.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.MergeType.
GetType (inherited from Object) | Gets the Type of the current instance.
IntValue | Gets an integer ID that is unique for each merge type.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.MergeType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.MergeType

Implements

IWrapper.Unwrap

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.MergeType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.MergeType.Equals(obj).

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.MergeType.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.MergeType.GetHashCode().

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType.IntValue Method

Gets an integer ID that is unique for each merge type.

public virtual int IntValue();

Return Value

An integer ID that is unique for each merge type.

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.MergeType.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.MergeType.ToString()

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.MergeType.

public static MergeType Wrap(
MergeType impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.MergeType to be wrapped.

Return Value

MergeType

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType Type Conversions

The type conversions of the MergeType class are listed below. For a complete list of MergeType class members, see the MergeType Members topic.

Public Static Type Conversions

Implicit MergeType to MergeType Conversion Implicitly convert MergeType to com.starbase.starteam.viewcomparemerge.MergeType.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

MergeType Class | MergeType Members | Borland.StarTeam.Viewcomparemerge Namespace


MergeType Implicit MergeType to MergeType Conversion

Implicitly convert MergeType to com.starbase.starteam.viewcomparemerge.MergeType.

public static implicit operator MergeType(
MergeType arg
);

Parameters

arg
MergeType to convert.

Return Value

com.starbase.starteam.viewcomparemerge.MergeType

See Also

MergeType Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection Class

A strongly-typed collection of MergeTypes.

For a list of all members of this type, see MergeTypeCollection Members.

System.Object
ArrayAdapter
MergeTypeCollection

public class MergeTypeCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

MergeTypeCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection Members

MergeTypeCollection overview

Public Static Methods

Wrap Creates a MergeTypeCollection to represent the given array of MergeType (from the com.starbase.starteam.viewcomparemerge namespace).

Public Static Type Conversions

Implicit MergeTypeCollection to MergeType[] Conversion | Converts a MergeTypeCollection to an array of MergeTypes.
Implicit MergeTypeCollection to MergeType[] Conversion | Converts a MergeTypeCollection from the Borland.StarTeam.Viewcomparemerge namespace to a MergeType[] in the com.starbase.starteam.viewcomparemerge namespace.

Public Instance Constructors

MergeTypeCollection Overloaded. Initializes a new instance of the MergeTypeCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the MergeType at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a MergeType to end of the collection.
Append | Overloaded. Appends the MergeTypes of the given MergeTypeCollection to the end of this MergeTypeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific MergeType.
CopyTo | Copies all of the MergeTypes in the MergeTypeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the MergeType with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific MergeType in the collection.
Insert | Inserts a MergeType into the collection at the specified position.
Remove | Removes the first occurrence of a specific MergeType from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the MergeTypes in this MergeTypeCollection.
Sort | Sorts the MergeTypes in this MergeTypeCollection, using the given comparer.
SortByName | Sorts the MergeTypes in this MergeTypeCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection Constructor

Initializes an instance of the MergeTypeCollection class.

Overload List

Initializes an instance of the MergeTypeCollection class.

public MergeTypeCollection();

Initializes an instance of the a MergeTypeCollection class, copying the given array.

public MergeTypeCollection(MergeType[]);

Initializes an instance of the a MergeTypeCollection class, copying the given collection.

public MergeTypeCollection(MergeTypeCollection);

Initializes an instance of the a MergeTypeCollection class, wrapping the given array of MergeType (from the com.starbase.starteam.viewcomparemerge namespace).

public MergeTypeCollection(MergeType[]);

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection Constructor ()

Initializes an instance of the MergeTypeCollection class.

public MergeTypeCollection();

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeTypeCollection Constructor Overload List


MergeTypeCollection Constructor (MergeType[])

Initializes an instance of the a MergeTypeCollection class, wrapping the given array of MergeType (from the com.starbase.starteam.viewcomparemerge namespace).

public MergeTypeCollection(
MergeType[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam.viewcomparemerge namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeTypeCollection Constructor Overload List | Wrap


MergeTypeCollection Constructor (MergeTypeCollection)

Initializes an instance of the a MergeTypeCollection class, copying the given collection.

public MergeTypeCollection(
MergeTypeCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member MergeType objects of the original collection are shared, not copied.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeTypeCollection Constructor Overload List


MergeTypeCollection Constructor (MergeType[])

Initializes an instance of the a MergeTypeCollection class, copying the given array.

public MergeTypeCollection(
MergeType[] array
);

Parameters

array
The array to be copied.

Remarks

The member MergeType objects of the original array are shared, not copied.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeTypeCollection Constructor Overload List


MergeTypeCollection Properties

The properties of the MergeTypeCollection class are listed below. For a complete list of MergeTypeCollection class members, see the MergeTypeCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the MergeType at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Item Property

Borland StarTeam SDK for .NET

MergeTypeCollection.Item Property

Gets or sets the MergeType at the specified index.

Overload List

Gets or sets the MergeType at the specified index.

public MergeType this[Int32] {get; set;}

Gets the MergeType with the given name.

public MergeType this[String] {get;}

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

MergeTypeCollection.Item Property (Int32)

Gets or sets the MergeType at the specified index.

public MergeType this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the MergeType to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeTypeCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

MergeTypeCollection.Item Property (String)

Gets the MergeType with the given name.

public MergeType this[
String name
] {get;}

Parameters

name
The name of the MergeType to get.

Property Value

The MergeType with the given name, or null if there is no MergeType with that name in this MergeTypeCollection. Comparison is case sensitive.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeTypeCollection.Item Overload List | FindByName


MergeTypeCollection Methods

The methods of the MergeTypeCollection class are listed below. For a complete list of MergeTypeCollection class members, see the MergeTypeCollection Members topic.

Public Static Methods

Wrap Creates a MergeTypeCollection to represent the given array of MergeType (from the com.starbase.starteam.viewcomparemerge namespace).

Public Instance Methods

Add | Adds a MergeType to end of the collection.
Append | Overloaded. Appends the MergeTypes of the given MergeTypeCollection to the end of this MergeTypeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific MergeType.
CopyTo | Copies all of the MergeTypes in the MergeTypeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the MergeType with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific MergeType in the collection.
Insert | Inserts a MergeType into the collection at the specified position.
Remove | Removes the first occurrence of a specific MergeType from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the MergeTypes in this MergeTypeCollection.
Sort | Sorts the MergeTypes in this MergeTypeCollection, using the given comparer.
SortByName | Sorts the MergeTypes in this MergeTypeCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.Add Method

Adds a MergeType to end of the collection.

public int Add(
MergeType value
);

Parameters

value
The MergeType to add to the collection.

Return Value

The position into which the new MergeType was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Append Method

Borland StarTeam SDK for .NET

MergeTypeCollection.Append Method

Appends the MergeTypes of the given array to the end of this MergeTypeCollection.

Overload List

Appends the MergeTypes of the given array to the end of this MergeTypeCollection.

public MergeTypeCollection Append(MergeType[]);

Appends the MergeTypes of the given MergeTypeCollection to the end of this MergeTypeCollection.

public MergeTypeCollection Append(MergeTypeCollection);

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.Append Method (MergeType[])

Appends the MergeTypes of the given array to the end of this MergeTypeCollection.

public MergeTypeCollection Append(
MergeType[] array
);

Parameters

array
The array whose MergeTypes are to be appended to this MergeTypeCollection.

Return Value

This MergeTypeCollection, modified to include the new MergeTypes.

Remarks

The MergeTypeCollection is modified to include the new members. The individual MergeType objects are shared, not copied.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeTypeCollection.Append Overload List


MergeTypeCollection.Append Method (MergeTypeCollection)

Appends the MergeTypes of the given MergeTypeCollection to the end of this MergeTypeCollection.

public MergeTypeCollection Append(
MergeTypeCollection collection
);

Parameters

collection
The MergeTypeCollection whose MergeTypes are to be appended to this MergeTypeCollection.

Return Value

This MergeTypeCollection, modified to include the new MergeTypes.

Remarks

The MergeTypeCollection is modified to include the new members. The individual MergeType objects are shared, not copied.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeTypeCollection.Append Overload List


MergeTypeCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.viewcomparemerge.MergeType[].

Implements

IWrapper.Unwrap

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.Contains Method

Determines whether or not the collection contains a specific MergeType.

public bool Contains(
MergeType value
);

Parameters

value
The MergeType to locate in the collection.

Return Value

true if the MergeType is found in the collection; otherwise, false.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.CopyTo Method

Copies all of the MergeTypes in the MergeTypeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
MergeType[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the MergeTypes copied from the MergeTypeCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of MergeTypes in the source MergeTypeCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source MergeTypeCollection cannot be cast automatically to the type of the destination array.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.FindByName Method

Finds the MergeType with the given name.

public MergeType FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the MergeType to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The MergeType with the given name, or null if there is no MergeType with that name in this MergeTypeCollection.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.IndexOf Method

Determines the index of a specific MergeType in the collection.

public int IndexOf(
MergeType value
);

Parameters

value
The MergeType to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.Insert Method

Inserts a MergeType into the collection at the specified position.

public void Insert(
Int32 index,
MergeType value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The MergeType to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.Remove Method

Removes the first occurrence of a specific MergeType from the collection.

public void Remove(
MergeType value
);

Parameters

value
The MergeType to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.Reverse Method

Reverses the order of the MergeTypes in this MergeTypeCollection.

new public MergeTypeCollection Reverse();

Return Value

This MergeTypeCollection, modified such that the MergeTypes are reversed.

Remarks

The MergeTypeCollection is modified in place.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.Sort Method

Sorts the MergeTypes in this MergeTypeCollection, using the given comparer.

new public MergeTypeCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two MergeTypes.

Return Value

This MergeTypeCollection, modified such that the MergeTypes are sorted.

Remarks

The MergeTypeCollection is modified in place.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.SortByName Method

Sorts the MergeTypes in this MergeTypeCollection by name.

public MergeTypeCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This MergeTypeCollection, modified such that the MergeTypes are sorted by name.

Remarks

The MergeTypeCollection is modified in place.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection.Wrap Method

Creates a MergeTypeCollection to represent the given array of MergeType (from the com.starbase.starteam.viewcomparemerge namespace).

public static MergeTypeCollection Wrap(
MergeType[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new MergeTypeCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a MergeType[] from the com.starbase.starteam.viewcomparemerge namespace to the Borland.StarTeam.Viewcomparemerge namespace.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection Type Conversions

The type conversions of the MergeTypeCollection class are listed below. For a complete list of MergeTypeCollection class members, see the MergeTypeCollection Members topic.

Public Static Type Conversions

Implicit MergeTypeCollection to MergeType[] Conversion | Converts a MergeTypeCollection to an array of MergeTypes.
Implicit MergeTypeCollection to MergeType[] Conversion | Converts a MergeTypeCollection from the Borland.StarTeam.Viewcomparemerge namespace to a MergeType[] in the com.starbase.starteam.viewcomparemerge namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

MergeTypeCollection Class | MergeTypeCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection Implicit MergeTypeCollection to MergeType[] Conversion

Converts a MergeTypeCollection to an array of MergeTypes.

public static implicit operator MergeType[](
MergeTypeCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new MergeType wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one MergeType wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeTypeCollection Implicit MergeTypeCollection to MergeType[] Conversion

Converts a MergeTypeCollection from the Borland.StarTeam.Viewcomparemerge namespace to a MergeType[] in the com.starbase.starteam.viewcomparemerge namespace.

public static implicit operator MergeType[](
MergeTypeCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam.Viewcomparemerge namespace to methods in the com.starbase.starteam.viewcomparemerge namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, MergeTypeCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

MergeTypeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Options Class

A set of user preferences that guide a view compare/merge operation. For any invocation of view compare and/or merge, these preferences may be overridden. The intent is that this set of preferences can be stored persistently and retrieved when setting up a view compare/merge operation, and that the set of options reflects what this user will usually want for the operation.

For a list of all members of this type, see Options Members.

System.Object
Options

public class Options : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Options Members | Borland.StarTeam.Viewcomparemerge Namespace


Options Members

Options overview

Public Static Properties

WorkstationDefault [read] the default Options for this workstation

Public Static Methods

GetExcludablePropertiesForMerge |
Wrap | Dynamically wraps com.starbase.starteam.viewcomparemerge.Options.

Public Static Type Conversions

Implicit Options to Options Conversion Implicitly convert Options to com.starbase.starteam.viewcomparemerge.Options.

Public Instance Constructors

Options Overloaded. Initializes a new instance of the Options class.

Public Instance Properties

ActionOverrides | [read] ActionOverride[] An array of ActionOverride's, returned in the order in which they were entered
AutoMergeFiles | [read/write] true if file pairs that have no conflicts will be automatically merged.
AutoMergeProperties | [read/write] true if property pairs that have no conflicts will be automatically merged.
BreakLocksAutomatically | [read/write] true if locks will automatically be broken as needed to check in merged revisions.
CheckTargetFoldersForFloatingShares | [read/write] true if VCM will check target folders for floating child shares, and fail if any are found. Enabled by default.
FixFloatingChildShares | [read/write] true if shares that float from the source view to the target view will automatically be detected during the compare phase and fixed during the commit; false otherwise.
IgnoreMergePoints | [read/write] true if all merge points should be ignored for comparisons, false if merge points should be used.
LockSourceForDifference | [read/write] true if a source item will be locked when a difference is detected.
LockTargetForDifference | [read/write] true if a target item will be locked when a difference is detected.
MatchFilesByFileName | [read/write] true if files (or folders) with the same name are to be considered matched, even if their object and/or item ids do not match.
PropertiesExcludedForMerge | [read] The set of properties excluded from a VCM Merge
PropertyNames | [read] String[] the array of all the keys in this property list
TransactionsEnabled | [read/write] true if commit operations are executed within an atomic transaction; false otherwise. Transactions are disabled by default.
TreatFileNamesAsCaseSensitive | [read/write] true if file (or folder) names are compared in a case-sensitive manner.
VerboseProcessLinks | [read/write] true if commit operations should create process links for all file and folder operations that add or modify target items; false if process links are created only for file checkins (which is consistent with the rest of StarTeam). Verbose process links are enabled by default.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Options.
ExcludePropertyFromMerge |
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Options.
GetProperty | Searches for the property with the specified key in this property list.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVerboseDifferences | Determines whether or not a difference is generated for every matched pair of source and target items, whether or not the match is considered a difference. The default value is false. Verbose differences are off by default, but are enabled for sessions whose scope is not the entire source view.
IsExcludedFromMerge | returns true if the specified property has been excluded from the merge
SetDefaultAction | Overloaded. Changes the default action in a given situation. Note that there may be one and only one default action for a given DifferenceType
SetExcludePropertyFromMerge |
SetProperty | Sets a value for the property identified by the specified key
SetVerboseDifferences | Determines whether or not a difference is generated for every matched pair of source and target items of a given type, whether or not the match is considered a difference. The default value is false. Verbose differences are off by default. If you change the scope of a session, then verbose differences are enabled for all types that are in scope, but not fully in scope.
SetWorkstationDefault | Saves the current set of options as the defaults for this workstation.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Options.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options Constructor

Construct Options from com.starbase.starteam.viewcomparemerge.Options.

Overload List

Constructs a set of Options with default values.

public Options();

Create an Options instance by copying the contents of another

public Options(Options);

Construct Options from com.starbase.starteam.viewcomparemerge.Options.

public Options(Options);

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options Constructor (Options)

Construct Options from com.starbase.starteam.viewcomparemerge.Options.

public Options(
Options impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.Options to be wrapped.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace | Options Constructor Overload List


Options Constructor ()

Constructs a set of Options with default values.

public Options();

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace | Options Constructor Overload List


Options Constructor (Options)

Create an Options instance by copying the contents of another

public Options(
Options other
);

Parameters

other

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace | Options Constructor Overload List


Options Properties

The properties of the Options class are listed below. For a complete list of Options class members, see the Options Members topic.

Public Static Properties

WorkstationDefault [read] the default Options for this workstation

Public Instance Properties

ActionOverrides | [read] ActionOverride[] An array of ActionOverride's, returned in the order in which they were entered
AutoMergeFiles | [read/write] true if file pairs that have no conflicts will be automatically merged.
AutoMergeProperties | [read/write] true if property pairs that have no conflicts will be automatically merged.
BreakLocksAutomatically | [read/write] true if locks will automatically be broken as needed to check in merged revisions.
CheckTargetFoldersForFloatingShares | [read/write] true if VCM will check target folders for floating child shares, and fail if any are found. Enabled by default.
FixFloatingChildShares | [read/write] true if shares that float from the source view to the target view will automatically be detected during the compare phase and fixed during the commit; false otherwise.
IgnoreMergePoints | [read/write] true if all merge points should be ignored for comparisons, false if merge points should be used.
LockSourceForDifference | [read/write] true if a source item will be locked when a difference is detected.
LockTargetForDifference | [read/write] true if a target item will be locked when a difference is detected.
MatchFilesByFileName | [read/write] true if files (or folders) with the same name are to be considered matched, even if their object and/or item ids do not match.
PropertiesExcludedForMerge | [read] The set of properties excluded from a VCM Merge
PropertyNames | [read] String[] the array of all the keys in this property list
TransactionsEnabled | [read/write] true if commit operations are executed within an atomic transaction; false otherwise. Transactions are disabled by default.
TreatFileNamesAsCaseSensitive | [read/write] true if file (or folder) names are compared in a case-sensitive manner.
VerboseProcessLinks | [read/write] true if commit operations should create process links for all file and folder operations that add or modify target items; false if process links are created only for file checkins (which is consistent with the rest of StarTeam). Verbose process links are enabled by default.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


ActionOverrides Property

Borland StarTeam SDK for .NET

Options.ActionOverrides Property

[read] ActionOverride[] An array of ActionOverride's, returned in the order in which they were entered

public virtual ActionOverrideCollection ActionOverrides {get;}

Property Value

ActionOverride[] An array of ActionOverride's, returned in the order in which they were entered

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


AutoMergeFiles Property

Borland StarTeam SDK for .NET

Options.AutoMergeFiles Property

[read/write] true if file pairs that have no conflicts will be automatically merged.

public virtual Boolean AutoMergeFiles {get; set;}

Property Value

true if file pairs that have no conflicts will be automatically merged.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


AutoMergeProperties Property

Borland StarTeam SDK for .NET

Options.AutoMergeProperties Property

[read/write] true if property pairs that have no conflicts will be automatically merged.

public virtual Boolean AutoMergeProperties {get; set;}

Property Value

true if property pairs that have no conflicts will be automatically merged.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


BreakLocksAutomatically Property

Borland StarTeam SDK for .NET

Options.BreakLocksAutomatically Property

[read/write] true if locks will automatically be broken as needed to check in merged revisions.

public virtual Boolean BreakLocksAutomatically {get; set;}

Property Value

true if locks will automatically be broken as needed to check in merged revisions.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


CheckTargetFoldersForFloatingShares Property

Borland StarTeam SDK for .NET

Options.CheckTargetFoldersForFloatingShares Property

[read/write] true if VCM will check target folders for floating child shares, and fail if any are found. Enabled by default.

public virtual Boolean CheckTargetFoldersForFloatingShares {get; set;}

Property Value

true if VCM will check target folders for floating child shares, and fail if any are found. Enabled by default.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


FixFloatingChildShares Property

Borland StarTeam SDK for .NET

Options.FixFloatingChildShares Property

[read/write] true if shares that float from the source view to the target view will automatically be detected during the compare phase and fixed during the commit; false otherwise.

public virtual Boolean FixFloatingChildShares {get; set;}

Property Value

true if shares that float from the source view to the target view will automatically be detected during the compare phase and fixed during the commit; false otherwise.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


IgnoreMergePoints Property

Borland StarTeam SDK for .NET

Options.IgnoreMergePoints Property

[read/write] true if all merge points should be ignored for comparisons, false if merge points should be used.

public virtual Boolean IgnoreMergePoints {get; set;}

Property Value

true if all merge points should be ignored for comparisons, false if merge points should be used.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


LockSourceForDifference Property

Borland StarTeam SDK for .NET

Options.LockSourceForDifference Property

[read/write] true if a source item will be locked when a difference is detected.

public virtual Boolean LockSourceForDifference {get; set;}

Property Value

true if a source item will be locked when a difference is detected.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


LockTargetForDifference Property

Borland StarTeam SDK for .NET

Options.LockTargetForDifference Property

[read/write] true if a target item will be locked when a difference is detected.

public virtual Boolean LockTargetForDifference {get; set;}

Property Value

true if a target item will be locked when a difference is detected.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


MatchFilesByFileName Property

Borland StarTeam SDK for .NET

Options.MatchFilesByFileName Property

[read/write] true if files (or folders) with the same name are to be considered matched, even if their object and/or item ids do not match.

public virtual Boolean MatchFilesByFileName {get; set;}

Property Value

true if files (or folders) with the same name are to be considered matched, even if their object and/or item ids do not match.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertiesExcludedForMerge Property

Borland StarTeam SDK for .NET

Options.PropertiesExcludedForMerge Property

[read] The set of properties excluded from a VCM Merge

public virtual PropertyCollection PropertiesExcludedForMerge {get;}

Property Value

The set of properties excluded from a VCM Merge

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertyNames Property

Borland StarTeam SDK for .NET

Options.PropertyNames Property

[read] String[] the array of all the keys in this property list

public virtual String[] PropertyNames {get;}

Property Value

String[] the array of all the keys in this property list

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


TransactionsEnabled Property

Borland StarTeam SDK for .NET

Options.TransactionsEnabled Property

[read/write] true if commit operations are executed within an atomic transaction; false otherwise. Transactions are disabled by default.

public virtual Boolean TransactionsEnabled {get; set;}

Property Value

true if commit operations are executed within an atomic transaction; false otherwise. Transactions are disabled by default.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


TreatFileNamesAsCaseSensitive Property

Borland StarTeam SDK for .NET

Options.TreatFileNamesAsCaseSensitive Property

[read/write] true if file (or folder) names are compared in a case-sensitive manner.

public virtual Boolean TreatFileNamesAsCaseSensitive {get; set;}

Property Value

true if file (or folder) names are compared in a case-sensitive manner.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


VerboseProcessLinks Property

Borland StarTeam SDK for .NET

Options.VerboseProcessLinks Property

[read/write] true if commit operations should create process links for all file and folder operations that add or modify target items; false if process links are created only for file checkins (which is consistent with the rest of StarTeam). Verbose process links are enabled by default.

public virtual Boolean VerboseProcessLinks {get; set;}

Property Value

true if commit operations should create process links for all file and folder operations that add or modify target items; false if process links are created only for file checkins (which is consistent with the rest of StarTeam). Verbose process links are enabled by default.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


WorkstationDefault Property

Borland StarTeam SDK for .NET

Options.WorkstationDefault Property

[read] the default Options for this workstation

public static Options WorkstationDefault {get;}

Property Value

the default Options for this workstation

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options Methods

The methods of the Options class are listed below. For a complete list of Options class members, see the Options Members topic.

Public Static Methods

GetExcludablePropertiesForMerge |
Wrap | Dynamically wraps com.starbase.starteam.viewcomparemerge.Options.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Options.
ExcludePropertyFromMerge |
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Options.
GetProperty | Searches for the property with the specified key in this property list.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVerboseDifferences | Determines whether or not a difference is generated for every matched pair of source and target items, whether or not the match is considered a difference. The default value is false. Verbose differences are off by default, but are enabled for sessions whose scope is not the entire source view.
IsExcludedFromMerge | returns true if the specified property has been excluded from the merge
SetDefaultAction | Overloaded. Changes the default action in a given situation. Note that there may be one and only one default action for a given DifferenceType
SetExcludePropertyFromMerge |
SetProperty | Sets a value for the property identified by the specified key
SetVerboseDifferences | Determines whether or not a difference is generated for every matched pair of source and target items of a given type, whether or not the match is considered a difference. The default value is false. Verbose differences are off by default. If you change the scope of a session, then verbose differences are enabled for all types that are in scope, but not fully in scope.
SetWorkstationDefault | Saves the current set of options as the defaults for this workstation.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Options.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.Options

Implements

IWrapper.Unwrap

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.Options.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.Options.Equals(obj).

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.ExcludePropertyFromMerge Method

public virtual void ExcludePropertyFromMerge(
Property p
);

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.GetExcludablePropertiesForMerge Method

public static PropertyCollection GetExcludablePropertiesForMerge(
Type type
);

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Options.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.Options.GetHashCode().

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.GetProperty Method

Searches for the property with the specified key in this property list.

public virtual string GetProperty(
String key
);

Parameters

key
String the key to search for

Return Value

String the stored property value for the specified key

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.GetVerboseDifferences Method

Determines whether or not a difference is generated for every matched pair of source and target items, whether or not the match is considered a difference. The default value is false.

Verbose differences are off by default, but are enabled for sessions whose scope is not the entire source view.

public virtual bool GetVerboseDifferences(
Type type
);

Parameters

type

Return Value

True to generate an ItemDifference for every matched pair of source and target items; false to generate an ItemDifference only when a true difference is detected.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace | Session


Options.IsExcludedFromMerge Method

returns true if the specified property has been excluded from the merge

public virtual bool IsExcludedFromMerge(
Property p
);

Parameters

p
a property to test

Return Value

true if the specified property has been excluded from the merge

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


SetDefaultAction Method

Borland StarTeam SDK for .NET

Options.SetDefaultAction Method

Changes the default action in a given situation.

Note that there may be one and only one default action for a given DifferenceType

Overload List

Changes the default action in a given situation. Note that there may be one and only one default action for a given DifferenceType

public virtual void SetDefaultAction(DifferenceType,MergeAction);

Changes the default action in a given situation. Note that if multiple calls to setDefaultAction() are made, the order is significant. If two overrides are both relevant to a given ItemDifference, the most recently specified one takes precedence.

public virtual void SetDefaultAction(MatchState,MergeAction);

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace | MergeAction


Options.SetDefaultAction Method (DifferenceType, MergeAction)

Changes the default action in a given situation.

Note that there may be one and only one default action for a given DifferenceType

public virtual void SetDefaultAction(
DifferenceType type,
MergeAction action
);

Parameters

type
action
The new default action for the given DifferenceType, or null to restore the default action to the engine's default value.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace | Options.SetDefaultAction Overload List | MergeAction


Options.SetDefaultAction Method (MatchState, MergeAction)

Changes the default action in a given situation.

Note that if multiple calls to setDefaultAction() are made, the order is significant. If two overrides are both relevant to a given ItemDifference, the most recently specified one takes precedence.

public virtual void SetDefaultAction(
MatchState state,
MergeAction action
);

Parameters

state
The MatchState for which the default action is to be changed.
action
The new default action for the given MatchState, or null to restore the default action to the engine's default value.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace | Options.SetDefaultAction Overload List | MergeAction


Options.SetExcludePropertyFromMerge Method

public virtual void SetExcludePropertyFromMerge(
Property p,
Boolean exclude
);

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.SetProperty Method

Sets a value for the property identified by the specified key

public virtual object SetProperty(
String key,
String value
);

Parameters

key
String the key for which a value needs to be set
value
String the value to set

Return Value

Object he previous value of the specified key in this property list, or null if it did not have one.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.SetVerboseDifferences Method

Determines whether or not a difference is generated for every matched pair of source and target items of a given type, whether or not the match is considered a difference. The default value is false.

Verbose differences are off by default. If you change the scope of a session, then verbose differences are enabled for all types that are in scope, but not fully in scope.

public virtual void SetVerboseDifferences(
Type type,
Boolean bVerbose
);

Parameters

type
An item type.
bVerbose
True to generate an ItemDifference for every matched pair of source and target items of the given type; false to generate an ItemDifference only when a true difference is detected.

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.SetWorkstationDefault Method

Saves the current set of options as the defaults for this workstation.

public virtual void SetWorkstationDefault();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.Options.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.Options.ToString()

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.Options.

public static Options Wrap(
Options impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.Options to be wrapped.

Return Value

Options

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


Options Type Conversions

The type conversions of the Options class are listed below. For a complete list of Options class members, see the Options Members topic.

Public Static Type Conversions

Implicit Options to Options Conversion Implicitly convert Options to com.starbase.starteam.viewcomparemerge.Options.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Options Class | Options Members | Borland.StarTeam.Viewcomparemerge Namespace


Options Implicit Options to Options Conversion

Implicitly convert Options to com.starbase.starteam.viewcomparemerge.Options.

public static implicit operator Options(
Options arg
);

Parameters

arg
Options to convert.

Return Value

com.starbase.starteam.viewcomparemerge.Options

See Also

Options Class | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState Class

The preview state represents a highest precedence summary of all contained items and sub-folders and their contents. "has conflicts" is higher than "has changes" which is higher than "has compared items" which is higher than "has no compared items". A folder, for example, may contain items (directly or via sub-folders) in each of the four states, but the current value represents the highest precedence.

For a list of all members of this type, see PreviewState Members.

System.Object
PreviewState

public class PreviewState : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PreviewState Members | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState Members

PreviewState overview

Public Static Properties

HasChanges
HasComparedItems
HasConflicts
HasNoComparedItems

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.PreviewState.

Public Static Type Conversions

Implicit PreviewState to PreviewState Conversion Implicitly convert PreviewState to com.starbase.starteam.viewcomparemerge.PreviewState.

Public Instance Constructors

PreviewState Constructor Construct PreviewState from com.starbase.starteam.viewcomparemerge.PreviewState.

Public Instance Properties

Name [read] a string representation of the preview state.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.PreviewState.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.PreviewState.
GetType (inherited from Object) | Gets the Type of the current instance.
IntValue | Returns an Integer representation of this preview state
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.PreviewState.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState Constructor

Construct PreviewState from com.starbase.starteam.viewcomparemerge.PreviewState.

public PreviewState(
PreviewState impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.PreviewState to be wrapped.

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState Properties

The properties of the PreviewState class are listed below. For a complete list of PreviewState class members, see the PreviewState Members topic.

Public Static Properties

HasChanges
HasComparedItems
HasConflicts
HasNoComparedItems

Public Instance Properties

Name [read] a string representation of the preview state.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


HasChanges Property

Borland StarTeam SDK for .NET

PreviewState.HasChanges Property

public static PreviewState HasChanges {get;}

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


HasComparedItems Property

Borland StarTeam SDK for .NET

PreviewState.HasComparedItems Property

public static PreviewState HasComparedItems {get;}

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


HasConflicts Property

Borland StarTeam SDK for .NET

PreviewState.HasConflicts Property

public static PreviewState HasConflicts {get;}

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


HasNoComparedItems Property

Borland StarTeam SDK for .NET

PreviewState.HasNoComparedItems Property

public static PreviewState HasNoComparedItems {get;}

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


Name Property

Borland StarTeam SDK for .NET

PreviewState.Name Property

[read] a string representation of the preview state.

public virtual String Name {get;}

Property Value

a string representation of the preview state.

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState Methods

The methods of the PreviewState class are listed below. For a complete list of PreviewState class members, see the PreviewState Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.PreviewState.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.PreviewState.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.PreviewState.
GetType (inherited from Object) | Gets the Type of the current instance.
IntValue | Returns an Integer representation of this preview state
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.PreviewState.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.PreviewState

Implements

IWrapper.Unwrap

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.PreviewState.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.PreviewState.Equals(obj).

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.PreviewState.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.PreviewState.GetHashCode().

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState.IntValue Method

Returns an Integer representation of this preview state

public virtual int IntValue();

Return Value

int an Integer representation of this preview state

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.PreviewState.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.PreviewState.ToString()

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.PreviewState.

public static PreviewState Wrap(
PreviewState impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.PreviewState to be wrapped.

Return Value

PreviewState

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState Type Conversions

The type conversions of the PreviewState class are listed below. For a complete list of PreviewState class members, see the PreviewState Members topic.

Public Static Type Conversions

Implicit PreviewState to PreviewState Conversion Implicitly convert PreviewState to com.starbase.starteam.viewcomparemerge.PreviewState.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PreviewState Class | PreviewState Members | Borland.StarTeam.Viewcomparemerge Namespace


PreviewState Implicit PreviewState to PreviewState Conversion

Implicitly convert PreviewState to com.starbase.starteam.viewcomparemerge.PreviewState.

public static implicit operator PreviewState(
PreviewState arg
);

Parameters

arg
PreviewState to convert.

Return Value

com.starbase.starteam.viewcomparemerge.PreviewState

See Also

PreviewState Class | Borland.StarTeam.Viewcomparemerge Namespace


ProcessItemScope Class

Includes a processs item, and the items that are linked and pinned to it, in the scope of a session.

For a list of all members of this type, see ProcessItemScope Members.

System.Object
Scope
ProcessItemScope

public class ProcessItemScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ProcessItemScope Members | Borland.StarTeam.Viewcomparemerge Namespace


ProcessItemScope Members

ProcessItemScope overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.ProcessItemScope.

Public Static Type Conversions

Implicit ProcessItemScope to ProcessItemScope Conversion Implicitly convert ProcessItemScope to com.starbase.starteam.viewcomparemerge.ProcessItemScope.

Public Instance Constructors

ProcessItemScope Overloaded. Initializes a new instance of the ProcessItemScope class.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

ProcessItemScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ProcessItemScope Constructor

Construct ProcessItemScope from com.starbase.starteam.viewcomparemerge.ProcessItemScope.

Overload List

Creates a new ProcessItemScope.

public ProcessItemScope(Item);

Creates a new ProcessItemScope.

public ProcessItemScope(Item,Boolean);

Construct ProcessItemScope from com.starbase.starteam.viewcomparemerge.ProcessItemScope.

public ProcessItemScope(ProcessItemScope);

See Also

ProcessItemScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ProcessItemScope Constructor (ProcessItemScope)

Construct ProcessItemScope from com.starbase.starteam.viewcomparemerge.ProcessItemScope.

public ProcessItemScope(
ProcessItemScope impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.ProcessItemScope to be wrapped.

See Also

ProcessItemScope Class | Borland.StarTeam.Viewcomparemerge Namespace | ProcessItemScope Constructor Overload List


ProcessItemScope Constructor (Item)

Creates a new ProcessItemScope.

public ProcessItemScope(
Item item
);

Parameters

item
A process item. If the item resides in the source view of the session, then the process item itself is in scope. Any file revisions from the source view that are linked via process links to this process item (pinned to a specific revision at both endpoints) are also in scope.

See Also

ProcessItemScope Class | Borland.StarTeam.Viewcomparemerge Namespace | ProcessItemScope Constructor Overload List


ProcessItemScope Constructor (Item, Boolean)

Creates a new ProcessItemScope.

public ProcessItemScope(
Item item,
Boolean bLinksOnly
);

Parameters

item
A process item. Any file revisions from the source view that are linked via process links to this process item (pinned to a specific revision at both endpoints) are in scope.
bLinksOnly
If false, then the process item itself will be included in the scope (provided that it resides in the source view). Otherwise, only linked files are included.

See Also

ProcessItemScope Class | Borland.StarTeam.Viewcomparemerge Namespace | ProcessItemScope Constructor Overload List


ProcessItemScope Methods

The methods of the ProcessItemScope class are listed below. For a complete list of ProcessItemScope class members, see the ProcessItemScope Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.ProcessItemScope.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

ProcessItemScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ProcessItemScope.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.ProcessItemScope.

public static ProcessItemScope Wrap(
ProcessItemScope impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.ProcessItemScope to be wrapped.

Return Value

ProcessItemScope

See Also

ProcessItemScope Class | Borland.StarTeam.Viewcomparemerge Namespace


ProcessItemScope Type Conversions

The type conversions of the ProcessItemScope class are listed below. For a complete list of ProcessItemScope class members, see the ProcessItemScope Members topic.

Public Static Type Conversions

Implicit ProcessItemScope to ProcessItemScope Conversion Implicitly convert ProcessItemScope to com.starbase.starteam.viewcomparemerge.ProcessItemScope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

ProcessItemScope Class | ProcessItemScope Members | Borland.StarTeam.Viewcomparemerge Namespace


ProcessItemScope Implicit ProcessItemScope to ProcessItemScope Conversion

Implicitly convert ProcessItemScope to com.starbase.starteam.viewcomparemerge.ProcessItemScope.

public static implicit operator ProcessItemScope(
ProcessItemScope arg
);

Parameters

arg
ProcessItemScope to convert.

Return Value

com.starbase.starteam.viewcomparemerge.ProcessItemScope

See Also

ProcessItemScope Class | Borland.StarTeam.Viewcomparemerge Namespace


Progress Class

Information on the progress of a Merge operation from ViewMerger. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use ViewMerger.getProgress().

For a list of all members of this type, see Progress Members.

System.Object
Progress

public class Progress : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Progress Members | Borland.StarTeam.Viewcomparemerge Namespace


Progress Members

Progress overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.Progress.

Public Static Type Conversions

Implicit Progress to Progress Conversion Implicitly convert Progress to com.starbase.starteam.viewcomparemerge.Progress.

Public Instance Constructors

Progress Constructor Construct Progress from com.starbase.starteam.viewcomparemerge.Progress.

Public Instance Properties

Description | [read] String a description of the current state of the session
EstimatedPercentComplete | [read] a percentage estimate of how complete the current operation is.
EstimatedTimeRemaining | [read] an estimate of the time that remains to complete the current compare operation.
RemainingUnitsOfWork | [read] Return the total number of operations yet to be completed..
TotalTimeSpent | [read] Return the total time spent so far (in milliseconds).
TotalUnitsOfWorkCompleted | [read] Return the total number of operations completed.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Progress.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Progress.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Progress.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


Progress Constructor

Construct Progress from com.starbase.starteam.viewcomparemerge.Progress.

public Progress(
Progress impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.Progress to be wrapped.

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


Progress Properties

The properties of the Progress class are listed below. For a complete list of Progress class members, see the Progress Members topic.

Public Instance Properties

Description | [read] String a description of the current state of the session
EstimatedPercentComplete | [read] a percentage estimate of how complete the current operation is.
EstimatedTimeRemaining | [read] an estimate of the time that remains to complete the current compare operation.
RemainingUnitsOfWork | [read] Return the total number of operations yet to be completed..
TotalTimeSpent | [read] Return the total time spent so far (in milliseconds).
TotalUnitsOfWorkCompleted | [read] Return the total number of operations completed.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


Description Property

Borland StarTeam SDK for .NET

Progress.Description Property

[read] String a description of the current state of the session

public virtual String Description {get;}

Property Value

String a description of the current state of the session

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


EstimatedPercentComplete Property

Borland StarTeam SDK for .NET

Progress.EstimatedPercentComplete Property

[read] a percentage estimate of how complete the current operation is.

public virtual Int32 EstimatedPercentComplete {get;}

Property Value

a percentage estimate of how complete the current operation is.

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


EstimatedTimeRemaining Property

Borland StarTeam SDK for .NET

Progress.EstimatedTimeRemaining Property

[read] an estimate of the time that remains to complete the current compare operation.

public virtual Int64 EstimatedTimeRemaining {get;}

Property Value

an estimate of the time that remains to complete the current compare operation.

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


RemainingUnitsOfWork Property

Borland StarTeam SDK for .NET

Progress.RemainingUnitsOfWork Property

[read] Return the total number of operations yet to be completed..

public virtual Int32 RemainingUnitsOfWork {get;}

Property Value

Return the total number of operations yet to be completed..

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


TotalTimeSpent Property

Borland StarTeam SDK for .NET

Progress.TotalTimeSpent Property

[read] Return the total time spent so far (in milliseconds).

public virtual Int64 TotalTimeSpent {get;}

Property Value

Return the total time spent so far (in milliseconds).

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


TotalUnitsOfWorkCompleted Property

Borland StarTeam SDK for .NET

Progress.TotalUnitsOfWorkCompleted Property

[read] Return the total number of operations completed.

public virtual Int32 TotalUnitsOfWorkCompleted {get;}

Property Value

Return the total number of operations completed.

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


Progress Methods

The methods of the Progress class are listed below. For a complete list of Progress class members, see the Progress Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.Progress.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Progress.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Progress.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Progress.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


Progress.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.Progress

Implements

IWrapper.Unwrap

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


Progress.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.Progress.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.Progress.Equals(obj).

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


Progress.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Progress.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.Progress.GetHashCode().

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


Progress.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.Progress.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.Progress.ToString()

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


Progress.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.Progress.

public static Progress Wrap(
Progress impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.Progress to be wrapped.

Return Value

Progress

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


Progress Type Conversions

The type conversions of the Progress class are listed below. For a complete list of Progress class members, see the Progress Members topic.

Public Static Type Conversions

Implicit Progress to Progress Conversion Implicitly convert Progress to com.starbase.starteam.viewcomparemerge.Progress.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Progress Class | Progress Members | Borland.StarTeam.Viewcomparemerge Namespace


Progress Implicit Progress to Progress Conversion

Implicitly convert Progress to com.starbase.starteam.viewcomparemerge.Progress.

public static implicit operator Progress(
Progress arg
);

Parameters

arg
Progress to convert.

Return Value

com.starbase.starteam.viewcomparemerge.Progress

See Also

Progress Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException Class

For a list of all members of this type, see PropertyMergeException Members.

System.Object
Exception
PropertyMergeException

public class PropertyMergeException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

PropertyMergeException Members | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException Members

PropertyMergeException overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.PropertyMergeException.

Public Static Type Conversions

Implicit PropertyMergeException to PropertyMergeException Conversion Implicitly convert PropertyMergeException to com.starbase.starteam.viewcomparemerge.PropertyMergeException.

Public Instance Constructors

PropertyMergeException Constructor Construct PropertyMergeException from com.starbase.starteam.viewcomparemerge.PropertyMergeException.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
ItemDifference |
Message (inherited from Exception) | Gets a message that describes the current exception.
Property |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.PropertyMergeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.PropertyMergeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.PropertyMergeException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException Constructor

Construct PropertyMergeException from com.starbase.starteam.viewcomparemerge.PropertyMergeException.

public PropertyMergeException(
PropertyMergeException impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.PropertyMergeException to be wrapped.

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException Properties

The properties of the PropertyMergeException class are listed below. For a complete list of PropertyMergeException class members, see the PropertyMergeException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
ItemDifference |
Message (inherited from Exception) | Gets a message that describes the current exception.
Property |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemDifference Property

Borland StarTeam SDK for .NET

PropertyMergeException.ItemDifference Property

public virtual ItemDifference ItemDifference {get;}

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


Property Property

Borland StarTeam SDK for .NET

PropertyMergeException.Property Property

public virtual Property Property {get;}

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException Methods

The methods of the PropertyMergeException class are listed below. For a complete list of PropertyMergeException class members, see the PropertyMergeException Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.PropertyMergeException.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.PropertyMergeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.PropertyMergeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.PropertyMergeException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.PropertyMergeException

Implements

IWrapper.Unwrap

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.PropertyMergeException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.PropertyMergeException.Equals(obj).

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.PropertyMergeException.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.PropertyMergeException.GetHashCode().

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.PropertyMergeException.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.PropertyMergeException.ToString()

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.PropertyMergeException.

public static PropertyMergeException Wrap(
PropertyMergeException impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.PropertyMergeException to be wrapped.

Return Value

PropertyMergeException

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException Type Conversions

The type conversions of the PropertyMergeException class are listed below. For a complete list of PropertyMergeException class members, see the PropertyMergeException Members topic.

Public Static Type Conversions

Implicit PropertyMergeException to PropertyMergeException Conversion Implicitly convert PropertyMergeException to com.starbase.starteam.viewcomparemerge.PropertyMergeException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

PropertyMergeException Class | PropertyMergeException Members | Borland.StarTeam.Viewcomparemerge Namespace


PropertyMergeException Implicit PropertyMergeException to PropertyMergeException Conversion

Implicitly convert PropertyMergeException to com.starbase.starteam.viewcomparemerge.PropertyMergeException.

public static implicit operator PropertyMergeException(
PropertyMergeException arg
);

Parameters

arg
PropertyMergeException to convert.

Return Value

com.starbase.starteam.viewcomparemerge.PropertyMergeException

See Also

PropertyMergeException Class | Borland.StarTeam.Viewcomparemerge Namespace


RevisionLabelScope Class

Includes all item revisions with a given revision label in the scope of the view compare/merge session.

For a list of all members of this type, see RevisionLabelScope Members.

System.Object
Scope
RevisionLabelScope

public class RevisionLabelScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

RevisionLabelScope Members | Borland.StarTeam.Viewcomparemerge Namespace


RevisionLabelScope Members

RevisionLabelScope overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.RevisionLabelScope.

Public Static Type Conversions

Implicit RevisionLabelScope to RevisionLabelScope Conversion Implicitly convert RevisionLabelScope to com.starbase.starteam.viewcomparemerge.RevisionLabelScope.

Public Instance Constructors

RevisionLabelScope Overloaded. Initializes a new instance of the RevisionLabelScope class.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

RevisionLabelScope Class | Borland.StarTeam.Viewcomparemerge Namespace


RevisionLabelScope Constructor

Construct RevisionLabelScope from com.starbase.starteam.viewcomparemerge.RevisionLabelScope.

Overload List

Creates a new RevisionLabelScope.

public RevisionLabelScope(Label);

Creates a new RevisionLabelScope.

public RevisionLabelScope(Label,Type);

Creates a new RevisionLabelScope.

public RevisionLabelScope(Label,TypeCollection);

Construct RevisionLabelScope from com.starbase.starteam.viewcomparemerge.RevisionLabelScope.

public RevisionLabelScope(RevisionLabelScope);

See Also

RevisionLabelScope Class | Borland.StarTeam.Viewcomparemerge Namespace


RevisionLabelScope Constructor (RevisionLabelScope)

Construct RevisionLabelScope from com.starbase.starteam.viewcomparemerge.RevisionLabelScope.

public RevisionLabelScope(
RevisionLabelScope impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.RevisionLabelScope to be wrapped.

See Also

RevisionLabelScope Class | Borland.StarTeam.Viewcomparemerge Namespace | RevisionLabelScope Constructor Overload List


RevisionLabelScope Constructor (Label)

Creates a new RevisionLabelScope.

public RevisionLabelScope(
Label label
);

Parameters

label
A revision label. All item revisions with this label are included in the scope of the view compare/merge session.

See Also

RevisionLabelScope Class | Borland.StarTeam.Viewcomparemerge Namespace | RevisionLabelScope Constructor Overload List


RevisionLabelScope Constructor (Label, Type)

Creates a new RevisionLabelScope.

public RevisionLabelScope(
Label label,
Type type
);

Parameters

label
A revision label. Item revisions with this label are included in the scope of the view compare/merge session.
type
An item type. Only items with this item type are included.

See Also

RevisionLabelScope Class | Borland.StarTeam.Viewcomparemerge Namespace | RevisionLabelScope Constructor Overload List


RevisionLabelScope Constructor (Label, TypeCollection)

Creates a new RevisionLabelScope.

public RevisionLabelScope(
Label label,
TypeCollection types
);

Parameters

label
A revision label. Item revisions with this label are included in the scope of the view compare/merge session.
types
A list of item types. Only items with these types are included.

See Also

RevisionLabelScope Class | Borland.StarTeam.Viewcomparemerge Namespace | RevisionLabelScope Constructor Overload List


RevisionLabelScope Methods

The methods of the RevisionLabelScope class are listed below. For a complete list of RevisionLabelScope class members, see the RevisionLabelScope Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.RevisionLabelScope.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Scope) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

RevisionLabelScope Class | Borland.StarTeam.Viewcomparemerge Namespace


RevisionLabelScope.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.RevisionLabelScope.

public static RevisionLabelScope Wrap(
RevisionLabelScope impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.RevisionLabelScope to be wrapped.

Return Value

RevisionLabelScope

See Also

RevisionLabelScope Class | Borland.StarTeam.Viewcomparemerge Namespace


RevisionLabelScope Type Conversions

The type conversions of the RevisionLabelScope class are listed below. For a complete list of RevisionLabelScope class members, see the RevisionLabelScope Members topic.

Public Static Type Conversions

Implicit RevisionLabelScope to RevisionLabelScope Conversion Implicitly convert RevisionLabelScope to com.starbase.starteam.viewcomparemerge.RevisionLabelScope.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from Scope) Implementation of IWrapper.Unwrap().

See Also

RevisionLabelScope Class | RevisionLabelScope Members | Borland.StarTeam.Viewcomparemerge Namespace


RevisionLabelScope Implicit RevisionLabelScope to RevisionLabelScope Conversion

Implicitly convert RevisionLabelScope to com.starbase.starteam.viewcomparemerge.RevisionLabelScope.

public static implicit operator RevisionLabelScope(
RevisionLabelScope arg
);

Parameters

arg
RevisionLabelScope to convert.

Return Value

com.starbase.starteam.viewcomparemerge.RevisionLabelScope

See Also

RevisionLabelScope Class | Borland.StarTeam.Viewcomparemerge Namespace


Scope Class

Provides a client application a flexible way to specify the scope of a view compare/merge operation.

The View Compare/Merge engine provides implementations of Scope that should suffice for most applications. In each case, the implementation is public, and may be re-used in the development of custom Scopes.

For a list of all members of this type, see Scope Members.

System.Object
Scope
Derived types

public class Scope : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Scope Members | Borland.StarTeam.Viewcomparemerge Namespace


Scope Members

Scope overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.Scope.

Public Static Type Conversions

Implicit Scope to Scope Conversion Implicitly convert Scope to com.starbase.starteam.viewcomparemerge.Scope.

Public Instance Constructors

Scope Constructor Construct Scope from com.starbase.starteam.viewcomparemerge.Scope.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Scope Class | Borland.StarTeam.Viewcomparemerge Namespace


Scope Constructor

Construct Scope from com.starbase.starteam.viewcomparemerge.Scope.

public Scope(
Scope impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.Scope to be wrapped.

See Also

Scope Class | Borland.StarTeam.Viewcomparemerge Namespace


Scope Methods

The methods of the Scope class are listed below. For a complete list of Scope class members, see the Scope Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.Scope.

Public Instance Methods

Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Scope Class | Borland.StarTeam.Viewcomparemerge Namespace


Scope.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.Scope

Implements

IWrapper.Unwrap

See Also

Scope Class | Borland.StarTeam.Viewcomparemerge Namespace


Scope.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.Scope.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.Scope.Equals(obj).

See Also

Scope Class | Borland.StarTeam.Viewcomparemerge Namespace


Scope.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Scope.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.Scope.GetHashCode().

See Also

Scope Class | Borland.StarTeam.Viewcomparemerge Namespace


Scope.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.Scope.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.Scope.ToString()

See Also

Scope Class | Borland.StarTeam.Viewcomparemerge Namespace


Scope.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.Scope.

public static Scope Wrap(
Scope impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.Scope to be wrapped.

Return Value

Scope

See Also

Scope Class | Borland.StarTeam.Viewcomparemerge Namespace


Scope Type Conversions

The type conversions of the Scope class are listed below. For a complete list of Scope class members, see the Scope Members topic.

Public Static Type Conversions

Implicit Scope to Scope Conversion Implicitly convert Scope to com.starbase.starteam.viewcomparemerge.Scope.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Scope Class | Scope Members | Borland.StarTeam.Viewcomparemerge Namespace


Scope Implicit Scope to Scope Conversion

Implicitly convert Scope to com.starbase.starteam.viewcomparemerge.Scope.

public static implicit operator Scope(
Scope arg
);

Parameters

arg
Scope to convert.

Return Value

com.starbase.starteam.viewcomparemerge.Scope

See Also

Scope Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection Class

A strongly-typed collection of Scopes.

For a list of all members of this type, see ScopeCollection Members.

System.Object
ArrayAdapter
ScopeCollection

public class ScopeCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

ScopeCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection Members

ScopeCollection overview

Public Static Methods

Wrap Creates a ScopeCollection to represent the given array of Scope (from the com.starbase.starteam.viewcomparemerge namespace).

Public Static Type Conversions

Implicit ScopeCollection to Scope[] Conversion | Converts a ScopeCollection to an array of Scopes.
Implicit ScopeCollection to Scope[] Conversion | Converts a ScopeCollection from the Borland.StarTeam.Viewcomparemerge namespace to a Scope[] in the com.starbase.starteam.viewcomparemerge namespace.

Public Instance Constructors

ScopeCollection Overloaded. Initializes a new instance of the ScopeCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the Scope at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Scope to end of the collection.
Append | Overloaded. Appends the Scopes of the given ScopeCollection to the end of this ScopeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Scope.
CopyTo | Copies all of the Scopes in the ScopeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Scope in the collection.
Insert | Inserts a Scope into the collection at the specified position.
Remove | Removes the first occurrence of a specific Scope from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Scopes in this ScopeCollection.
Sort | Sorts the Scopes in this ScopeCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection Constructor

Initializes an instance of the ScopeCollection class.

Overload List

Initializes an instance of the ScopeCollection class.

public ScopeCollection();

Initializes an instance of the a ScopeCollection class, copying the given array.

public ScopeCollection(Scope[]);

Initializes an instance of the a ScopeCollection class, copying the given collection.

public ScopeCollection(ScopeCollection);

Initializes an instance of the a ScopeCollection class, wrapping the given array of Scope (from the com.starbase.starteam.viewcomparemerge namespace).

public ScopeCollection(Scope[]);

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection Constructor ()

Initializes an instance of the ScopeCollection class.

public ScopeCollection();

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ScopeCollection Constructor Overload List


ScopeCollection Constructor (Scope[])

Initializes an instance of the a ScopeCollection class, wrapping the given array of Scope (from the com.starbase.starteam.viewcomparemerge namespace).

public ScopeCollection(
Scope[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.starbase.starteam.viewcomparemerge namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ScopeCollection Constructor Overload List | Wrap


ScopeCollection Constructor (ScopeCollection)

Initializes an instance of the a ScopeCollection class, copying the given collection.

public ScopeCollection(
ScopeCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member Scope objects of the original collection are shared, not copied.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ScopeCollection Constructor Overload List


ScopeCollection Constructor (Scope[])

Initializes an instance of the a ScopeCollection class, copying the given array.

public ScopeCollection(
Scope[] array
);

Parameters

array
The array to be copied.

Remarks

The member Scope objects of the original array are shared, not copied.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ScopeCollection Constructor Overload List


ScopeCollection Properties

The properties of the ScopeCollection class are listed below. For a complete list of ScopeCollection class members, see the ScopeCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Gets or sets the Scope at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Item Property

Borland StarTeam SDK for .NET

ScopeCollection.Item Property

Gets or sets the Scope at the specified index.

public Scope this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the Scope to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection Methods

The methods of the ScopeCollection class are listed below. For a complete list of ScopeCollection class members, see the ScopeCollection Members topic.

Public Static Methods

Wrap Creates a ScopeCollection to represent the given array of Scope (from the com.starbase.starteam.viewcomparemerge namespace).

Public Instance Methods

Add | Adds a Scope to end of the collection.
Append | Overloaded. Appends the Scopes of the given ScopeCollection to the end of this ScopeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific Scope.
CopyTo | Copies all of the Scopes in the ScopeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific Scope in the collection.
Insert | Inserts a Scope into the collection at the specified position.
Remove | Removes the first occurrence of a specific Scope from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the Scopes in this ScopeCollection.
Sort | Sorts the Scopes in this ScopeCollection, using the given comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection.Add Method

Adds a Scope to end of the collection.

public int Add(
Scope value
);

Parameters

value
The Scope to add to the collection.

Return Value

The position into which the new Scope was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Append Method

Borland StarTeam SDK for .NET

ScopeCollection.Append Method

Appends the Scopes of the given array to the end of this ScopeCollection.

Overload List

Appends the Scopes of the given array to the end of this ScopeCollection.

public ScopeCollection Append(Scope[]);

Appends the Scopes of the given ScopeCollection to the end of this ScopeCollection.

public ScopeCollection Append(ScopeCollection);

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection.Append Method (Scope[])

Appends the Scopes of the given array to the end of this ScopeCollection.

public ScopeCollection Append(
Scope[] array
);

Parameters

array
The array whose Scopes are to be appended to this ScopeCollection.

Return Value

This ScopeCollection, modified to include the new Scopes.

Remarks

The ScopeCollection is modified to include the new members. The individual Scope objects are shared, not copied.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ScopeCollection.Append Overload List


ScopeCollection.Append Method (ScopeCollection)

Appends the Scopes of the given ScopeCollection to the end of this ScopeCollection.

public ScopeCollection Append(
ScopeCollection collection
);

Parameters

collection
The ScopeCollection whose Scopes are to be appended to this ScopeCollection.

Return Value

This ScopeCollection, modified to include the new Scopes.

Remarks

The ScopeCollection is modified to include the new members. The individual Scope objects are shared, not copied.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace | ScopeCollection.Append Overload List


ScopeCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.starbase.starteam.viewcomparemerge.Scope[].

Implements

IWrapper.Unwrap

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection.Contains Method

Determines whether or not the collection contains a specific Scope.

public bool Contains(
Scope value
);

Parameters

value
The Scope to locate in the collection.

Return Value

true if the Scope is found in the collection; otherwise, false.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection.CopyTo Method

Copies all of the Scopes in the ScopeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
Scope[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the Scopes copied from the ScopeCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of Scopes in the source ScopeCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ScopeCollection cannot be cast automatically to the type of the destination array.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection.IndexOf Method

Determines the index of a specific Scope in the collection.

public int IndexOf(
Scope value
);

Parameters

value
The Scope to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection.Insert Method

Inserts a Scope into the collection at the specified position.

public void Insert(
Int32 index,
Scope value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Scope to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection.Remove Method

Removes the first occurrence of a specific Scope from the collection.

public void Remove(
Scope value
);

Parameters

value
The Scope to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection.Reverse Method

Reverses the order of the Scopes in this ScopeCollection.

new public ScopeCollection Reverse();

Return Value

This ScopeCollection, modified such that the Scopes are reversed.

Remarks

The ScopeCollection is modified in place.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection.Sort Method

Sorts the Scopes in this ScopeCollection, using the given comparer.

new public ScopeCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two Scopes.

Return Value

This ScopeCollection, modified such that the Scopes are sorted.

Remarks

The ScopeCollection is modified in place.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection.Wrap Method

Creates a ScopeCollection to represent the given array of Scope (from the com.starbase.starteam.viewcomparemerge namespace).

public static ScopeCollection Wrap(
Scope[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new ScopeCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a Scope[] from the com.starbase.starteam.viewcomparemerge namespace to the Borland.StarTeam.Viewcomparemerge namespace.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection Type Conversions

The type conversions of the ScopeCollection class are listed below. For a complete list of ScopeCollection class members, see the ScopeCollection Members topic.

Public Static Type Conversions

Implicit ScopeCollection to Scope[] Conversion | Converts a ScopeCollection to an array of Scopes.
Implicit ScopeCollection to Scope[] Conversion | Converts a ScopeCollection from the Borland.StarTeam.Viewcomparemerge namespace to a Scope[] in the com.starbase.starteam.viewcomparemerge namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.starbase.starteam.viewcomparemerge namespace.

See Also

ScopeCollection Class | ScopeCollection Members | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection Implicit ScopeCollection to Scope[] Conversion

Converts a ScopeCollection to an array of Scopes.

public static implicit operator Scope[](
ScopeCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new Scope wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one Scope wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


ScopeCollection Implicit ScopeCollection to Scope[] Conversion

Converts a ScopeCollection from the Borland.StarTeam.Viewcomparemerge namespace to a Scope[] in the com.starbase.starteam.viewcomparemerge namespace.

public static implicit operator Scope[](
ScopeCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam.Viewcomparemerge namespace to methods in the com.starbase.starteam.viewcomparemerge namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, ScopeCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

ScopeCollection Class | Borland.StarTeam.Viewcomparemerge Namespace


Session Class

A view compare/merge (VCM) session.

Each VCM session has associated source view and target views. {@linkplain #compare() Comparing} the two generates a set of {@linkplain #getDifferences() differences}. For each difference, you can detect {@linkplain ItemDifference#isConflictDetected conflicts}, {@linkplain ItemDifference#setAction override} default actions, and so on.

Conflicts may be resolved by merging {@linkplain ItemDifference#setMergedPropertyValue(com.starbase.starteam.Property, Object) item properties} or {@linkplain ItemDifference#setMergedFileContent(java.io.File) file content}. Alternatively, you can set property values or checkin new file revisions via the {@linkplain #getMergePreview merge preview}, which shows what the target view would look like were the session to be committed in its current state.

When ready, you can {@linkplain #commit() commit} the changes, which updates the target view.

For general information on using the VCM APIs, see com.starbase.startem.viewcomparemerge.

For a list of all members of this type, see Session Members.

System.Object
Session

public class Session : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

Session Members | Borland.StarTeam.Viewcomparemerge Namespace


Session Members

Session overview

Public Static Methods

GetMatchHint | Determines whether or not a match hint is available that indicates which item in the given target view should be matched to the specified source item.
Remove | Overloaded. Remove the temporary folder tree associated with the specified session file.
Resolve | Resolve a saved session file for a committed session (such as you'd find attached to a process task in the target view), to return a list of all the relevant target item revisions from the ItemDifferences that resulted in changes (i.e., everything except Ignore).
RestoreFrom Overloaded. Restores a saved session from a file. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. For example:
 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .
SetMatchHint | Saves a match hint, indicating that the given source item corresponds to the given target item, even though the two might otherwise be unrelated. Internally, the match hint is represented by a StarTeam link.
Wrap | Dynamically wraps com.starbase.starteam.viewcomparemerge.Session.

Public Static Type Conversions

Implicit Session to Session Conversion Implicitly convert Session to com.starbase.starteam.viewcomparemerge.Session.

Public Instance Constructors

Session Overloaded. Initializes a new instance of the Session class.

Public Instance Properties

ApplicationObject | [read/write] An application-specific object associated with this session, or null.
CanCommit | [read] boolean true if this session can be committed in its current state, and false otherwise.
DefaultComment | [read/write] The default checkin comment.
Differences | [read] An iterator over the set of differences.
HasDifferences | [read] True if there were differences detected, and false otherwise.
HasLocks | [read] true if any source or target items are currently locked on behalf of this session.
IsCommitTransacted | [read] true if the commit operation is atomic; false otherwise.
IsDirty | [read] true if this session has been changed since it was last saved or restored, and false if it has not been changed.
IsPartiallyCommitted | [read] true if this session was partially committed, and false otherwise.
IsPostCommitRevisionLabelEnabled | [read/write] true if the post-commit revision label will be created, and false otherwise.
IsPostCommitViewLabelEnabled | [read/write] true if the post-commit view label will be created, and false otherwise.
IsPreCommitRevisionLabelEnabled | [read/write] true if the pre-commit revision label will be created, and false otherwise.
IsPreCommitViewLabelEnabled | [read/write] true if the pre-commit view label will be created, and false otherwise.
IsReadOnly | [read] true if this is a read-only session.
IsVerbosePreview | [read/write] true if verbose preview mode is enabled; false if it is disabled.
ItemTypes | [read] The list of types included in the view compare/merge operation.
LockCount | [read] The number of source or target items that are currently locked on behalf of this session.
MergePreview | [read] A preview of the merge results for this session.
MergeType | [read] The merge type of this session.
Name | [read] The name of this session.
Options | [read/write] Options that influence the behavior of compare or merge operations.
PostCommitRevisionLabelName | [read/write] The name of the post-commit revision label.
PostCommitViewLabelName | [read/write] The name of the post-commit view label.
PreCommitRevisionLabelName | [read/write] The name of the pre-commit revision label.
PreCommitViewLabelName | [read/write] The name of the pre-commit view label.
ProcessTask | [read] The process task that was created in the target view when this session was committed.
Progress | [read] A snapshot of the state of the current compare or commit operation.
RootDirectory | [read] The path to the temporary folder on disk used by this session.
Scope | [read/write] A scope specifier, indicating which source items are compared against the target in this view compare/merge session, or null for a full-scope compare of files and folders.
Server | [read] The Server instance from which this session was constructed.
ServerInfo | [read] ServerInfo The ServerInfo associated with this session.
SessionState | [read] The current state of this session.
SourceView | [read] The source view associated with this session.
SourceViewForCompare | [read] The version of the source view used for comparison.
TargetView | [read] The target view associated with this session.
TargetViewForCompare | [read] The version of the target view used for comparison.

Public Instance Methods

Cancel | Cancels a compare or commit operation that is currently in progress. The {@link #compare compare} and {@link commit commit} methods return when complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread. If a commit that is being executed as an atomic transaction is canceled before it is completed, then the transaction is rolled back. The source and target views are left in the state they were in prior to the start of the commit.
Close | Close this session, freeing its internal resources. Closing a session that has not been persisted also deletes the associated temporary files on disk.
Commit | Commits changes to the target view. Note that this method returns when the commit is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
Compare | Compares the source and target views. Note that this method returns when the compare is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
Connect Connects a restored session to a server instance. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. For example:
 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .
Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Session.
GenerateDifferenceReport | Overloaded. Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.
GenerateSummary | Generates a summary session report for this session. The report is in HTML format.
GenerateUpdateReport | Generates an update report for this session. This report lists items that were added, changed or removed when the session was committed. The report is in HTML format.
GetDifferencesForMergedItem | Gets the ItemDifference that corresponds to a given merge item. The merged item may have been obtained through {@link ItemDifference#getMergeItem getMergeItem}, or it may have been obtained via the {@linkplain #getMergePreview merge preview}.
GetDifferencesForSourceItem | Gets the ItemDifference that corresponds to a given source item.
GetDifferencesForTargetItem | Gets the ItemDifference that corresponds to a given target item.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Session.
GetSourceMatchesForTargetItems | Finds the source items that are the best matches for the given target items. The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchesForTargetItems() may be used by an application that wants to define the scope starting with a set of target items. To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.
GetSourceMatchForTargetItem | Finds the source item that is the best match for the given target item. The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchForTargetItem() may be used by an application that wants to define the scope starting with a target item. To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope | Determines whether or not this session will perform a full-scope compare on the items of the given type.
IsIncluded | Overloaded. Determines whether or not the given item type is included in this view compare/merge session.
Remove | Overloaded. Removes this session and any associated temporary files on disk.
RemoveLocks | Unlocks any source or target items that were locked on behalf of this session.
SaveTo | Save this session to a file. If copyContent is false, then merged file content is stored in a session-specific temporary file on disk. This results in smaller session files, but means that they are generally useful only from the computer where they were generated. If copyContent is true, then merged file content is copied into the session file. This may result in very large session files, but allows them to be used from any computer, attached to email messages, and so on.
SetMatch | Tells the VCM engine to match a specific source item to a specific target item. This overrides the normal comparison logic. A client application can call setMatch() before calling compare() to avoid an AmbiguousMatchException.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Session.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session Constructor

Construct Session from com.starbase.starteam.viewcomparemerge.Session.

Overload List

Constructs a new VCM session, for comparing and merging changes from a given source view to a given target view.

public Session(MergeType,View,View);

Constructs a new VCM session, for comparing and merging changes from a given source view to a given target view.

public Session(MergeType,View,View,Options);

Construct Session from com.starbase.starteam.viewcomparemerge.Session.

public Session(Session);

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session Constructor (Session)

Construct Session from com.starbase.starteam.viewcomparemerge.Session.

public Session(
Session impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.Session to be wrapped.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session Constructor Overload List


Session Constructor (MergeType, View, View)

Constructs a new VCM session, for comparing and merging changes from a given source view to a given target view.

public Session(
MergeType mergeType,
View source,
View target
);

Parameters

mergeType
The type of compare/merge to be performed.
source
The source view.
target
The target view.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session Constructor Overload List | Session | getMergeType | getSourceView | getTargetView


Session Constructor (MergeType, View, View, Options)

Constructs a new VCM session, for comparing and merging changes from a given source view to a given target view.

public Session(
MergeType mergeType,
View source,
View target,
Options options
);

Parameters

mergeType
The type of compare/merge to be performed.
source
The source view.
target
The target view.
options
Options that influence the behavior of the compare or merge operations.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session Constructor Overload List | Session | getMergeType | getSourceView | getTargetView | getOptions


Session Properties

The properties of the Session class are listed below. For a complete list of Session class members, see the Session Members topic.

Public Instance Properties

ApplicationObject | [read/write] An application-specific object associated with this session, or null.
CanCommit | [read] boolean true if this session can be committed in its current state, and false otherwise.
DefaultComment | [read/write] The default checkin comment.
Differences | [read] An iterator over the set of differences.
HasDifferences | [read] True if there were differences detected, and false otherwise.
HasLocks | [read] true if any source or target items are currently locked on behalf of this session.
IsCommitTransacted | [read] true if the commit operation is atomic; false otherwise.
IsDirty | [read] true if this session has been changed since it was last saved or restored, and false if it has not been changed.
IsPartiallyCommitted | [read] true if this session was partially committed, and false otherwise.
IsPostCommitRevisionLabelEnabled | [read/write] true if the post-commit revision label will be created, and false otherwise.
IsPostCommitViewLabelEnabled | [read/write] true if the post-commit view label will be created, and false otherwise.
IsPreCommitRevisionLabelEnabled | [read/write] true if the pre-commit revision label will be created, and false otherwise.
IsPreCommitViewLabelEnabled | [read/write] true if the pre-commit view label will be created, and false otherwise.
IsReadOnly | [read] true if this is a read-only session.
IsVerbosePreview | [read/write] true if verbose preview mode is enabled; false if it is disabled.
ItemTypes | [read] The list of types included in the view compare/merge operation.
LockCount | [read] The number of source or target items that are currently locked on behalf of this session.
MergePreview | [read] A preview of the merge results for this session.
MergeType | [read] The merge type of this session.
Name | [read] The name of this session.
Options | [read/write] Options that influence the behavior of compare or merge operations.
PostCommitRevisionLabelName | [read/write] The name of the post-commit revision label.
PostCommitViewLabelName | [read/write] The name of the post-commit view label.
PreCommitRevisionLabelName | [read/write] The name of the pre-commit revision label.
PreCommitViewLabelName | [read/write] The name of the pre-commit view label.
ProcessTask | [read] The process task that was created in the target view when this session was committed.
Progress | [read] A snapshot of the state of the current compare or commit operation.
RootDirectory | [read] The path to the temporary folder on disk used by this session.
Scope | [read/write] A scope specifier, indicating which source items are compared against the target in this view compare/merge session, or null for a full-scope compare of files and folders.
Server | [read] The Server instance from which this session was constructed.
ServerInfo | [read] ServerInfo The ServerInfo associated with this session.
SessionState | [read] The current state of this session.
SourceView | [read] The source view associated with this session.
SourceViewForCompare | [read] The version of the source view used for comparison.
TargetView | [read] The target view associated with this session.
TargetViewForCompare | [read] The version of the target view used for comparison.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


ApplicationObject Property

Borland StarTeam SDK for .NET

Session.ApplicationObject Property

[read/write] An application-specific object associated with this session, or null.

public virtual Object ApplicationObject {get; set;}

Property Value

An application-specific object associated with this session, or null.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


CanCommit Property

Borland StarTeam SDK for .NET

Session.CanCommit Property

[read] boolean true if this session can be committed in its current state, and false otherwise.

public virtual Boolean CanCommit {get;}

Property Value

boolean true if this session can be committed in its current state, and false otherwise.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


DefaultComment Property

Borland StarTeam SDK for .NET

Session.DefaultComment Property

[read/write] The default checkin comment.

public virtual String DefaultComment {get; set;}

Property Value

The default checkin comment.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Differences Property

Borland StarTeam SDK for .NET

Session.Differences Property

[read] An iterator over the set of differences.

public virtual DifferenceIterator Differences {get;}

Property Value

An iterator over the set of differences.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


HasDifferences Property

Borland StarTeam SDK for .NET

Session.HasDifferences Property

[read] True if there were differences detected, and false otherwise.

public virtual Boolean HasDifferences {get;}

Property Value

True if there were differences detected, and false otherwise.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


HasLocks Property

Borland StarTeam SDK for .NET

Session.HasLocks Property

[read] true if any source or target items are currently locked on behalf of this session.

public virtual Boolean HasLocks {get;}

Property Value

true if any source or target items are currently locked on behalf of this session.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


IsCommitTransacted Property

Borland StarTeam SDK for .NET

Session.IsCommitTransacted Property

[read] true if the commit operation is atomic; false otherwise.

public virtual Boolean IsCommitTransacted {get;}

Property Value

true if the commit operation is atomic; false otherwise.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Session.IsDirty Property

[read] true if this session has been changed since it was last saved or restored, and false if it has not been changed.

public virtual Boolean IsDirty {get;}

Property Value

true if this session has been changed since it was last saved or restored, and false if it has not been changed.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


IsPartiallyCommitted Property

Borland StarTeam SDK for .NET

Session.IsPartiallyCommitted Property

[read] true if this session was partially committed, and false otherwise.

public virtual Boolean IsPartiallyCommitted {get;}

Property Value

true if this session was partially committed, and false otherwise.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


IsPostCommitRevisionLabelEnabled Property

Borland StarTeam SDK for .NET

Session.IsPostCommitRevisionLabelEnabled Property

[read/write] true if the post-commit revision label will be created, and false otherwise.

public virtual Boolean IsPostCommitRevisionLabelEnabled {get; set;}

Property Value

true if the post-commit revision label will be created, and false otherwise.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


IsPostCommitViewLabelEnabled Property

Borland StarTeam SDK for .NET

Session.IsPostCommitViewLabelEnabled Property

[read/write] true if the post-commit view label will be created, and false otherwise.

public virtual Boolean IsPostCommitViewLabelEnabled {get; set;}

Property Value

true if the post-commit view label will be created, and false otherwise.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


IsPreCommitRevisionLabelEnabled Property

Borland StarTeam SDK for .NET

Session.IsPreCommitRevisionLabelEnabled Property

[read/write] true if the pre-commit revision label will be created, and false otherwise.

public virtual Boolean IsPreCommitRevisionLabelEnabled {get; set;}

Property Value

true if the pre-commit revision label will be created, and false otherwise.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


IsPreCommitViewLabelEnabled Property

Borland StarTeam SDK for .NET

Session.IsPreCommitViewLabelEnabled Property

[read/write] true if the pre-commit view label will be created, and false otherwise.

public virtual Boolean IsPreCommitViewLabelEnabled {get; set;}

Property Value

true if the pre-commit view label will be created, and false otherwise.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


IsReadOnly Property

Borland StarTeam SDK for .NET

Session.IsReadOnly Property

[read] true if this is a read-only session.

public virtual Boolean IsReadOnly {get;}

Property Value

true if this is a read-only session.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


IsVerbosePreview Property

Borland StarTeam SDK for .NET

Session.IsVerbosePreview Property

[read/write] true if verbose preview mode is enabled; false if it is disabled.

public virtual Boolean IsVerbosePreview {get; set;}

Property Value

true if verbose preview mode is enabled; false if it is disabled.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


ItemTypes Property

Borland StarTeam SDK for .NET

Session.ItemTypes Property

[read] The list of types included in the view compare/merge operation.

public virtual TypeCollection ItemTypes {get;}

Property Value

The list of types included in the view compare/merge operation.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


LockCount Property

Borland StarTeam SDK for .NET

Session.LockCount Property

[read] The number of source or target items that are currently locked on behalf of this session.

public virtual Int32 LockCount {get;}

Property Value

The number of source or target items that are currently locked on behalf of this session.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


MergePreview Property

Borland StarTeam SDK for .NET

Session.MergePreview Property

[read] A preview of the merge results for this session.

public virtual View MergePreview {get;}

Property Value

A preview of the merge results for this session.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


MergeType Property

Borland StarTeam SDK for .NET

Session.MergeType Property

[read] The merge type of this session.

public virtual MergeType MergeType {get;}

Property Value

The merge type of this session.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Name Property

Borland StarTeam SDK for .NET

Session.Name Property

[read] The name of this session.

public virtual String Name {get;}

Property Value

The name of this session.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Options Property

Borland StarTeam SDK for .NET

Session.Options Property

[read/write] Options that influence the behavior of compare or merge operations.

public virtual Options Options {get; set;}

Property Value

Options that influence the behavior of compare or merge operations.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


PostCommitRevisionLabelName Property

Borland StarTeam SDK for .NET

Session.PostCommitRevisionLabelName Property

[read/write] The name of the post-commit revision label.

public virtual String PostCommitRevisionLabelName {get; set;}

Property Value

The name of the post-commit revision label.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


PostCommitViewLabelName Property

Borland StarTeam SDK for .NET

Session.PostCommitViewLabelName Property

[read/write] The name of the post-commit view label.

public virtual String PostCommitViewLabelName {get; set;}

Property Value

The name of the post-commit view label.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


PreCommitRevisionLabelName Property

Borland StarTeam SDK for .NET

Session.PreCommitRevisionLabelName Property

[read/write] The name of the pre-commit revision label.

public virtual String PreCommitRevisionLabelName {get; set;}

Property Value

The name of the pre-commit revision label.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


PreCommitViewLabelName Property

Borland StarTeam SDK for .NET

Session.PreCommitViewLabelName Property

[read/write] The name of the pre-commit view label.

public virtual String PreCommitViewLabelName {get; set;}

Property Value

The name of the pre-commit view label.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


ProcessTask Property

Borland StarTeam SDK for .NET

Session.ProcessTask Property

[read] The process task that was created in the target view when this session was committed.

public virtual Item ProcessTask {get;}

Property Value

The process task that was created in the target view when this session was committed.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Progress Property

Borland StarTeam SDK for .NET

Session.Progress Property

[read] A snapshot of the state of the current compare or commit operation.

public virtual Progress Progress {get;}

Property Value

A snapshot of the state of the current compare or commit operation.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


RootDirectory Property

Borland StarTeam SDK for .NET

Session.RootDirectory Property

[read] The path to the temporary folder on disk used by this session.

public virtual String RootDirectory {get;}

Property Value

The path to the temporary folder on disk used by this session.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Scope Property

Borland StarTeam SDK for .NET

Session.Scope Property

[read/write] A scope specifier, indicating which source items are compared against the target in this view compare/merge session, or null for a full-scope compare of files and folders.

public virtual Scope Scope {get; set;}

Property Value

A scope specifier, indicating which source items are compared against the target in this view compare/merge session, or null for a full-scope compare of files and folders.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Server Property

Borland StarTeam SDK for .NET

Session.Server Property

[read] The Server instance from which this session was constructed.

public virtual Server Server {get;}

Property Value

The Server instance from which this session was constructed.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


ServerInfo Property

Borland StarTeam SDK for .NET

Session.ServerInfo Property

[read] ServerInfo The ServerInfo associated with this session.

public virtual ServerInfo ServerInfo {get;}

Property Value

ServerInfo The ServerInfo associated with this session.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


SessionState Property

Borland StarTeam SDK for .NET

Session.SessionState Property

[read] The current state of this session.

public virtual SessionState SessionState {get;}

Property Value

The current state of this session.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


SourceView Property

Borland StarTeam SDK for .NET

Session.SourceView Property

[read] The source view associated with this session.

public virtual View SourceView {get;}

Property Value

The source view associated with this session.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


SourceViewForCompare Property

Borland StarTeam SDK for .NET

Session.SourceViewForCompare Property

[read] The version of the source view used for comparison.

public virtual View SourceViewForCompare {get;}

Property Value

The version of the source view used for comparison.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


TargetView Property

Borland StarTeam SDK for .NET

Session.TargetView Property

[read] The target view associated with this session.

public virtual View TargetView {get;}

Property Value

The target view associated with this session.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


TargetViewForCompare Property

Borland StarTeam SDK for .NET

Session.TargetViewForCompare Property

[read] The version of the target view used for comparison.

public virtual View TargetViewForCompare {get;}

Property Value

The version of the target view used for comparison.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session Methods

The methods of the Session class are listed below. For a complete list of Session class members, see the Session Members topic.

Public Static Methods

GetMatchHint | Determines whether or not a match hint is available that indicates which item in the given target view should be matched to the specified source item.
Remove | Overloaded. Remove the temporary folder tree associated with the specified session file.
Resolve | Resolve a saved session file for a committed session (such as you'd find attached to a process task in the target view), to return a list of all the relevant target item revisions from the ItemDifferences that resulted in changes (i.e., everything except Ignore).
RestoreFrom Overloaded. Restores a saved session from a file. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. For example:
 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .
SetMatchHint | Saves a match hint, indicating that the given source item corresponds to the given target item, even though the two might otherwise be unrelated. Internally, the match hint is represented by a StarTeam link.
Wrap | Dynamically wraps com.starbase.starteam.viewcomparemerge.Session.

Public Instance Methods

Cancel | Cancels a compare or commit operation that is currently in progress. The {@link #compare compare} and {@link commit commit} methods return when complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread. If a commit that is being executed as an atomic transaction is canceled before it is completed, then the transaction is rolled back. The source and target views are left in the state they were in prior to the start of the commit.
Close | Close this session, freeing its internal resources. Closing a session that has not been persisted also deletes the associated temporary files on disk.
Commit | Commits changes to the target view. Note that this method returns when the commit is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
Compare | Compares the source and target views. Note that this method returns when the compare is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
Connect Connects a restored session to a server instance. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. For example:
 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .
Equals | Delegate Equals() to com.starbase.starteam.viewcomparemerge.Session.
GenerateDifferenceReport | Overloaded. Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.
GenerateSummary | Generates a summary session report for this session. The report is in HTML format.
GenerateUpdateReport | Generates an update report for this session. This report lists items that were added, changed or removed when the session was committed. The report is in HTML format.
GetDifferencesForMergedItem | Gets the ItemDifference that corresponds to a given merge item. The merged item may have been obtained through {@link ItemDifference#getMergeItem getMergeItem}, or it may have been obtained via the {@linkplain #getMergePreview merge preview}.
GetDifferencesForSourceItem | Gets the ItemDifference that corresponds to a given source item.
GetDifferencesForTargetItem | Gets the ItemDifference that corresponds to a given target item.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Session.
GetSourceMatchesForTargetItems | Finds the source items that are the best matches for the given target items. The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchesForTargetItems() may be used by an application that wants to define the scope starting with a set of target items. To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.
GetSourceMatchForTargetItem | Finds the source item that is the best match for the given target item. The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchForTargetItem() may be used by an application that wants to define the scope starting with a target item. To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope | Determines whether or not this session will perform a full-scope compare on the items of the given type.
IsIncluded | Overloaded. Determines whether or not the given item type is included in this view compare/merge session.
Remove | Overloaded. Removes this session and any associated temporary files on disk.
RemoveLocks | Unlocks any source or target items that were locked on behalf of this session.
SaveTo | Save this session to a file. If copyContent is false, then merged file content is stored in a session-specific temporary file on disk. This results in smaller session files, but means that they are generally useful only from the computer where they were generated. If copyContent is true, then merged file content is copied into the session file. This may result in very large session files, but allows them to be used from any computer, attached to email messages, and so on.
SetMatch | Tells the VCM engine to match a specific source item to a specific target item. This overrides the normal comparison logic. A client application can call setMatch() before calling compare() to avoid an AmbiguousMatchException.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.Session.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.Session

Implements

IWrapper.Unwrap

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session.Cancel Method

Cancels a compare or commit operation that is currently in progress.

The {@link #compare compare} and {@link commit commit} methods return when complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.

If a commit that is being executed as an atomic transaction is canceled before it is completed, then the transaction is rolled back. The source and target views are left in the state they were in prior to the start of the commit.

public virtual void Cancel();

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | compare | commit | getProgress | isCommitTransacted


Session.Close Method

Close this session, freeing its internal resources.

Closing a session that has not been persisted also deletes the associated temporary files on disk.

public virtual void Close();

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | remove | saveTo


Session.Commit Method

Commits changes to the target view.

Note that this method returns when the commit is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.

public virtual void Commit();

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | canCommit | isCommitTransacted | getProgress | cancel


Session.Compare Method

Compares the source and target views.

Note that this method returns when the compare is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.

public virtual void Compare();

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | getProgress | cancel


Session.Connect Method

Connects a restored session to a server instance.

When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}.

For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

public virtual void Connect(
Server server
);

Parameters

server
The server instance to be connected. The server must refer to the same StarTeam repository with which the session was created.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | restoreFrom


Session.Equals Method

Delegate Equals() to com.starbase.starteam.viewcomparemerge.Session.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.Session.Equals(obj).

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


GenerateDifferenceReport Method

Borland StarTeam SDK for .NET

Session.GenerateDifferenceReport Method

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

Overload List

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

public virtual void GenerateDifferenceReport(FileInfo);

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

public virtual void GenerateDifferenceReport(FileInfo,Boolean);

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session.GenerateDifferenceReport Method (FileInfo)

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

public virtual void GenerateDifferenceReport(
FileInfo reportFile
);

Parameters

reportFile
The report output file.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session.GenerateDifferenceReport Overload List


Session.GenerateDifferenceReport Method (FileInfo, Boolean)

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

public virtual void GenerateDifferenceReport(
FileInfo reportFile,
Boolean bListItemsInMovedFolders
);

Parameters

reportFile
The report output file.
bListItemsInMovedFolders
true to list items whose parent folder has moved in either the source or target, even if the items themselves have no true differences.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session.GenerateDifferenceReport Overload List


Session.GenerateSummary Method

Generates a summary session report for this session. The report is in HTML format.

public virtual void GenerateSummary(
FileInfo reportFile,
Boolean bIncludeHeading
);

Parameters

reportFile
The report output file.
bIncludeHeading
false to suppress the generation of the heading.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session.GenerateUpdateReport Method

Generates an update report for this session. This report lists items that were added, changed or removed when the session was committed. The report is in HTML format.

public virtual void GenerateUpdateReport(
FileInfo reportFile
);

Parameters

reportFile
The report output file.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session.GetDifferencesForMergedItem Method

Gets the ItemDifference that corresponds to a given merge item.

The merged item may have been obtained through {@link ItemDifference#getMergeItem getMergeItem}, or it may have been obtained via the {@linkplain #getMergePreview merge preview}.

public virtual ItemDifference GetDifferencesForMergedItem(
Item item
);

Parameters

item
A merged item.

Return Value

The associated ItemDifference, or null if the given item is not a recognized merged item.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | getMergedItem | getMergePreview


Session.GetDifferencesForSourceItem Method

Gets the ItemDifference that corresponds to a given source item.

public virtual ItemDifference GetDifferencesForSourceItem(
Item item
);

Parameters

item
A source item.

Return Value

The associated ItemDifference, or null if the given item is not a source item with an associated difference.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | getSourceItem


Session.GetDifferencesForTargetItem Method

Gets the ItemDifference that corresponds to a given target item.

public virtual ItemDifference GetDifferencesForTargetItem(
Item item
);

Parameters

item
A target item.

Return Value

The associated ItemDifference, or null if the given item is not a target item with an associated difference.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | getTargetItem


Session.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.Session.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.Session.GetHashCode().

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session.GetMatchHint Method

Determines whether or not a match hint is available that indicates which item in the given target view should be matched to the specified source item.

public static Item GetMatchHint(
Item source,
View target
);

Parameters

source
A source item.
target
The desired target view.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session.GetSourceMatchesForTargetItems Method

Finds the source items that are the best matches for the given target items.

The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchesForTargetItems() may be used by an application that wants to define the scope starting with a set of target items.

To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.

public virtual ItemCollection GetSourceMatchesForTargetItems(
ItemCollection targetItems
);

Parameters

targetItems

Return Value

The matching source item, or null.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session.GetSourceMatchForTargetItem Method

Finds the source item that is the best match for the given target item.

The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchForTargetItem() may be used by an application that wants to define the scope starting with a target item.

To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.

public virtual Item GetSourceMatchForTargetItem(
Item targetItem
);

Parameters

targetItem
Item

Return Value

The matching source item, or null.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session.IsFullScope Method

Determines whether or not this session will perform a full-scope compare on the items of the given type.

public virtual bool IsFullScope(
Type type
);

Parameters

type
An item type.

Return Value

true if this session will perform a full-scope compare on the items of the given type; false if the item type is out of scope, or if only some items of the given type are in scope.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


IsIncluded Method

Borland StarTeam SDK for .NET

Session.IsIncluded Method

Determines whether or not the given item is in scope for the current view compare/merge operation.

Overload List

Determines whether or not the given item is in scope for the current view compare/merge operation.

public virtual bool IsIncluded(Item);

Determines whether or not the given item type is included in this view compare/merge session.

public virtual bool IsIncluded(Type);

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session | Session


Session.IsIncluded Method (Item)

Determines whether or not the given item is in scope for the current view compare/merge operation.

public virtual bool IsIncluded(
Item item
);

Parameters

item
The item to be tested.

Return Value

true if the item is in scope; false otherwise.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session.IsIncluded Overload List | Session | Session


Session.IsIncluded Method (Type)

Determines whether or not the given item type is included in this view compare/merge session.

public virtual bool IsIncluded(
Type type
);

Parameters

type
The type to be tested.

Return Value

true if this type is included, false otherwise.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session.IsIncluded Overload List


Remove Method

Borland StarTeam SDK for .NET

Session.Remove Method

Removes this session and any associated temporary files on disk.

Overload List

Removes this session and any associated temporary files on disk.

public virtual void Remove();

Remove the temporary folder tree associated with the specified session file.

public static void Remove(FileInfo);

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | remove | getRootDirectory


Session.Remove Method ()

Removes this session and any associated temporary files on disk.

public virtual void Remove();

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session.Remove Overload List | remove | getRootDirectory


Session.Remove Method (FileInfo)

Remove the temporary folder tree associated with the specified session file.

public static void Remove(
FileInfo theSession
);

Parameters

theSession
A saved session file.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session.Remove Overload List | remove | getRootDirectory


Session.RemoveLocks Method

Unlocks any source or target items that were locked on behalf of this session.

public virtual void RemoveLocks();

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | hasLocks | getLockCount | getLockSourceForDifference | getLockTargetForDifference


Session.Resolve Method

Resolve a saved session file for a committed session (such as you'd find attached to a process task in the target view), to return a list of all the relevant target item revisions from the ItemDifferences that resulted in changes (i.e., everything except Ignore).

public static ItemCollection Resolve(
View target,
FileInfo file
);

Parameters

target
View the target view to resolve to
file
File the java.io.File containing the saved session

Return Value

Item[] an array of Items resolved to the specified target View

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


RestoreFrom Method

Borland StarTeam SDK for .NET

Session.RestoreFrom Method

Restores a saved session from a file.

When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}.

For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

Overload List

Restores a saved session from a file. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

public static Session RestoreFrom(FileInfo);

Restores a saved session from a file. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

public static Session RestoreFrom(FileInfo,Boolean);

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | restoreFrom | saveTo | getSessionState | connect | DISCONNECTED


Session.RestoreFrom Method (FileInfo)

Restores a saved session from a file.

When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}.

For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

public static Session RestoreFrom(
FileInfo file
);

Parameters

file
The session file. The file must have been previously saved using {@link #saveTo saveTo}.

Return Value

A new session in the disconnected state.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session.RestoreFrom Overload List | restoreFrom | saveTo | getSessionState | connect | DISCONNECTED


Session.RestoreFrom Method (FileInfo, Boolean)

Restores a saved session from a file.

When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}.

For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

public static Session RestoreFrom(
FileInfo file,
Boolean willPersist
);

Parameters

file
The session file. The file must have been previously saved using {@link #saveTo saveTo}.
willPersist
True if the session will remain persisted on disk; false if it is a temporary session that will be removed. When a temporary session is closed, its working files on disk are automatically removed.

Return Value

A new session in the disconnected state.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | Session.RestoreFrom Overload List | restoreFrom | saveTo | getSessionState | connect | close | DISCONNECTED


Session.SaveTo Method

Save this session to a file.

If copyContent is false, then merged file content is stored in a session-specific temporary file on disk. This results in smaller session files, but means that they are generally useful only from the computer where they were generated.

If copyContent is true, then merged file content is copied into the session file. This may result in very large session files, but allows them to be used from any computer, attached to email messages, and so on.

public virtual void SaveTo(
FileInfo file,
Boolean copyContent
);

Parameters

file
The output file.
copyContent
True to copy merged file content into the session file; false to reference files stored on the local disk.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | restoreFrom | getRootDirectory


Session.SetMatch Method

Tells the VCM engine to match a specific source item to a specific target item. This overrides the normal comparison logic.

A client application can call setMatch() before calling compare() to avoid an AmbiguousMatchException.

public virtual void SetMatch(
Item source,
Item target
);

Parameters

source
An item from the source view.
target
The corresponding item from the target view.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace | compare


Session.SetMatchHint Method

Saves a match hint, indicating that the given source item corresponds to the given target item, even though the two might otherwise be unrelated.

Internally, the match hint is represented by a StarTeam link.

public static void SetMatchHint(
Item source,
Item target
);

Parameters

source
A source item.
target
The matching target item.

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.Session.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.Session.ToString()

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.Session.

public static Session Wrap(
Session impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.Session to be wrapped.

Return Value

Session

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


Session Type Conversions

The type conversions of the Session class are listed below. For a complete list of Session class members, see the Session Members topic.

Public Static Type Conversions

Implicit Session to Session Conversion Implicitly convert Session to com.starbase.starteam.viewcomparemerge.Session.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

Session Class | Session Members | Borland.StarTeam.Viewcomparemerge Namespace


Session Implicit Session to Session Conversion

Implicitly convert Session to com.starbase.starteam.viewcomparemerge.Session.

public static implicit operator Session(
Session arg
);

Parameters

arg
Session to convert.

Return Value

com.starbase.starteam.viewcomparemerge.Session

See Also

Session Class | Borland.StarTeam.Viewcomparemerge Namespace


SessionState Class

An enumeration of states. A session may be in one and only one of these states at any given time.

For a list of all members of this type, see SessionState Members.

System.Object
SessionState

public class SessionState : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

SessionState Members | Borland.StarTeam.Viewcomparemerge Namespace


SessionState Members

SessionState overview

Public Static Properties

CLOSED
COMMITTED
COMPARED
CONNECTED
DISCONNECTED

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.SessionState.

Public Static Type Conversions

Implicit SessionState to SessionState Conversion Implicitly convert SessionState to com.starbase.starteam.viewcomparemerge.SessionState.

Public Instance Constructors

SessionState Constructor Construct SessionState from com.starbase.starteam.viewcomparemerge.SessionState.

Public Instance Properties

Name [read] the name of this session state as a string.

Public Instance Methods

Equals | Overloaded. Delegate Equals() to com.starbase.starteam.viewcomparemerge.SessionState.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.SessionState.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.SessionState.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


SessionState Constructor

Construct SessionState from com.starbase.starteam.viewcomparemerge.SessionState.

public SessionState(
SessionState impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.SessionState to be wrapped.

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


SessionState Properties

The properties of the SessionState class are listed below. For a complete list of SessionState class members, see the SessionState Members topic.

Public Static Properties

CLOSED
COMMITTED
COMPARED
CONNECTED
DISCONNECTED

Public Instance Properties

Name [read] the name of this session state as a string.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


CLOSED Property

Borland StarTeam SDK for .NET

SessionState.CLOSED Property

public static SessionState CLOSED {get;}

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


COMMITTED Property

Borland StarTeam SDK for .NET

SessionState.COMMITTED Property

public static SessionState COMMITTED {get;}

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


COMPARED Property

Borland StarTeam SDK for .NET

SessionState.COMPARED Property

public static SessionState COMPARED {get;}

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


CONNECTED Property

Borland StarTeam SDK for .NET

SessionState.CONNECTED Property

public static SessionState CONNECTED {get;}

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


DISCONNECTED Property

Borland StarTeam SDK for .NET

SessionState.DISCONNECTED Property

public static SessionState DISCONNECTED {get;}

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


Name Property

Borland StarTeam SDK for .NET

SessionState.Name Property

[read] the name of this session state as a string.

public virtual String Name {get;}

Property Value

the name of this session state as a string.

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


SessionState Methods

The methods of the SessionState class are listed below. For a complete list of SessionState class members, see the SessionState Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.SessionState.

Public Instance Methods

Equals | Overloaded. Delegate Equals() to com.starbase.starteam.viewcomparemerge.SessionState.
GetHashCode | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.SessionState.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starbase.starteam.viewcomparemerge.SessionState.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


SessionState.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.starbase.starteam.viewcomparemerge.SessionState

Implements

IWrapper.Unwrap

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


Equals Method

Borland StarTeam SDK for .NET

SessionState.Equals Method

returns true if the two SessionStates represent the same state

Overload List

returns true if the two SessionStates represent the same state

public virtual bool Equals(SessionState);

Delegate Equals() to com.starbase.starteam.viewcomparemerge.SessionState.

public override bool Equals(Object);

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


SessionState.Equals Method (SessionState)

returns true if the two SessionStates represent the same state

public virtual bool Equals(
SessionState theOther
);

Parameters

theOther
SessionState a SessionState to test for equality

Return Value

boolean true if the two SessionStates are equal

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace | SessionState.Equals Overload List


SessionState.Equals Method (Object)

Delegate Equals() to com.starbase.starteam.viewcomparemerge.SessionState.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starbase.starteam.viewcomparemerge.SessionState.Equals(obj).

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace | SessionState.Equals Overload List


SessionState.GetHashCode Method

Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.SessionState.

public override int GetHashCode();

Return Value

com.starbase.starteam.viewcomparemerge.SessionState.GetHashCode().

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


SessionState.ToString Method

Delegate ToString() to com.starbase.starteam.viewcomparemerge.SessionState.

public override string ToString();

Return Value

com.starbase.starteam.viewcomparemerge.SessionState.ToString()

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


SessionState.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.SessionState.

public static SessionState Wrap(
SessionState impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.SessionState to be wrapped.

Return Value

SessionState

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


SessionState Type Conversions

The type conversions of the SessionState class are listed below. For a complete list of SessionState class members, see the SessionState Members topic.

Public Static Type Conversions

Implicit SessionState to SessionState Conversion Implicitly convert SessionState to com.starbase.starteam.viewcomparemerge.SessionState.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

SessionState Class | SessionState Members | Borland.StarTeam.Viewcomparemerge Namespace


SessionState Implicit SessionState to SessionState Conversion

Implicitly convert SessionState to com.starbase.starteam.viewcomparemerge.SessionState.

public static implicit operator SessionState(
SessionState arg
);

Parameters

arg
SessionState to convert.

Return Value

com.starbase.starteam.viewcomparemerge.SessionState

See Also

SessionState Class | Borland.StarTeam.Viewcomparemerge Namespace


StarTeamFileMergeAdapter Class

Facilitates the use of the StarTeam File Compare / Merge tool (also known as "DeltaII") to resolve a file merge condition. Used as follows:

 FileMergeAdapter tool = new StarTeamFileMergeAdapter(diff); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("Merge failed with exit code: " + exitCode); }
Note that StarTeam File Compare / Merge is the default file merge tool in StarTeam 9.0 and later. It replaces VisMerge.exe, which is now obsolete.

For a list of all members of this type, see StarTeamFileMergeAdapter Members.

System.Object
FileMergeAdapter
StarTeamFileMergeAdapter

public class StarTeamFileMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

StarTeamFileMergeAdapter Members | Borland.StarTeam.Viewcomparemerge Namespace


StarTeamFileMergeAdapter Members

StarTeamFileMergeAdapter overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter.

Public Static Type Conversions

Implicit StarTeamFileMergeAdapter to StarTeamFileMergeAdapter Conversion Implicitly convert StarTeamFileMergeAdapter to com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter.

Public Instance Constructors

StarTeamFileMergeAdapter Overloaded. Initializes a new instance of the StarTeamFileMergeAdapter class.

Public Instance Properties

AutoMergeLinesWithNoConflicts [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

StarTeamFileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


StarTeamFileMergeAdapter Constructor

Construct StarTeamFileMergeAdapter from com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter.

Overload List

Constructs a VisMerge adapter for resolving a given file merge condition.

public StarTeamFileMergeAdapter(ItemDifference);

Construct StarTeamFileMergeAdapter from com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter.

public StarTeamFileMergeAdapter(StarTeamFileMergeAdapter);

See Also

StarTeamFileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


StarTeamFileMergeAdapter Constructor (StarTeamFileMergeAdapter)

Construct StarTeamFileMergeAdapter from com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter.

public StarTeamFileMergeAdapter(
StarTeamFileMergeAdapter impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter to be wrapped.

See Also

StarTeamFileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace | StarTeamFileMergeAdapter Constructor Overload List


StarTeamFileMergeAdapter Constructor (ItemDifference)

Constructs a VisMerge adapter for resolving a given file merge condition.

public StarTeamFileMergeAdapter(
ItemDifference diff
);

Parameters

diff
The ItemDifference whose file merge condition is to be resolved.

See Also

StarTeamFileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace | StarTeamFileMergeAdapter Constructor Overload List


StarTeamFileMergeAdapter Properties

The properties of the StarTeamFileMergeAdapter class are listed below. For a complete list of StarTeamFileMergeAdapter class members, see the StarTeamFileMergeAdapter Members topic.

Public Instance Properties

AutoMergeLinesWithNoConflicts [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

StarTeamFileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


AutoMergeLinesWithNoConflicts Property

Borland StarTeam SDK for .NET

StarTeamFileMergeAdapter.AutoMergeLinesWithNoConflicts Property

[read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

public virtual Boolean AutoMergeLinesWithNoConflicts {get; set;}

Property Value

true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

See Also

StarTeamFileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


StarTeamFileMergeAdapter Methods

The methods of the StarTeamFileMergeAdapter class are listed below. For a complete list of StarTeamFileMergeAdapter class members, see the StarTeamFileMergeAdapter Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

StarTeamFileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


StarTeamFileMergeAdapter.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter.

public static StarTeamFileMergeAdapter Wrap(
StarTeamFileMergeAdapter impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter to be wrapped.

Return Value

StarTeamFileMergeAdapter

See Also

StarTeamFileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


StarTeamFileMergeAdapter Type Conversions

The type conversions of the StarTeamFileMergeAdapter class are listed below. For a complete list of StarTeamFileMergeAdapter class members, see the StarTeamFileMergeAdapter Members topic.

Public Static Type Conversions

Implicit StarTeamFileMergeAdapter to StarTeamFileMergeAdapter Conversion Implicitly convert StarTeamFileMergeAdapter to com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

StarTeamFileMergeAdapter Class | StarTeamFileMergeAdapter Members | Borland.StarTeam.Viewcomparemerge Namespace


StarTeamFileMergeAdapter Implicit StarTeamFileMergeAdapter to StarTeamFileMergeAdapter Conversion

Implicitly convert StarTeamFileMergeAdapter to com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter.

public static implicit operator StarTeamFileMergeAdapter(
StarTeamFileMergeAdapter arg
);

Parameters

arg
StarTeamFileMergeAdapter to convert.

Return Value

com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter

See Also

StarTeamFileMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


VCMFolder Class

For a list of all members of this type, see VCMFolder Members.

System.Object
TypedResource
SimpleTypedResource
Item
Folder
VCMFolder

public class VCMFolder : Folder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

VCMFolder Members | Borland.StarTeam.Viewcomparemerge Namespace


VCMFolder Members

VCMFolder overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.VCMFolder.

Public Static Type Conversions

Implicit VCMFolder to VCMFolder Conversion Implicitly convert VCMFolder to com.starbase.starteam.viewcomparemerge.VCMFolder.

Public Instance Constructors

VCMFolder Constructor Construct VCMFolder from com.starbase.starteam.viewcomparemerge.VCMFolder.

Public Instance Properties

ACL (inherited from Item) |
AllLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AlternatePathFragment (inherited from Folder) | [read/write] the alternate or overridden working path for this folder.
AttachedLabels (inherited from Item) | [read] an array of labels attached to any version of this item. Will not return null but an empty array if no labels are attached.
AttachmentIDs (inherited from Item) | [read] the ids of all the attachments associated with this item
AttachmentNames (inherited from Item) | [read] the names of all the attachments associated with this item
Behavior (inherited from Item) | [read/write] ItemBehavior object associated with this Item
CachedProperties (inherited from Item) | [read] Property[]
CaseSensitiveFileNames (inherited from Folder) | [read] True if the names of files in this folder are case sensitive, and false otherwise.
Comment (inherited from Item) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from Item) | [read] The user ID of the user that created the first revision of the item.
CreatedTime (inherited from Item) | [read] The time at which the first revision of the item was created.
DebugString (inherited from Item) | [read] a debug string for this item
DefaultPathFragment (inherited from Folder) | [read/write] this folder's specified working path.
DeletedTime (inherited from Item) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DeletedUserID (inherited from Item) | [read] The UserID of the user who deleted this item, or ObjectProperty.VALUE_NOT_SET.
Description (inherited from Folder) | [read/write] the description of this folder.
DotNotation (inherited from Item) | [read] The dot notation identification of this version.
EffectiveExcludeList (inherited from Folder) | [read] the fully resolved exclude list for this folder.
EffectiveUserVisible (inherited from Folder) | [read]
ExcludeFlags (inherited from Folder) | [read/write] the exclude type being used for this folder's exclude list
ExcludeList (inherited from Folder) | [read/write] the portion of the exclude list that this folder contributes.
FileEOL (inherited from Folder) | [read] The end-of-line character sequence to be used for text files in this folder.
Flag (inherited from Item) | [read] A value indicating whether or not the user has flagged this item.
FolderHierarchy (inherited from Folder) | [read] The fully-qualified name of this folder.
HasParentFolder (inherited from Folder) | [read] true if this folder has a parent folder.
History (inherited from Item) | [read] the past versions of this item.
ID (inherited from SimpleTypedResource) | [read] the identifier for the resource object.
IsBranchable (inherited from Item) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from Item) | [read] True if this item is known to have been deleted; false otherwise.
IsDirty (inherited from Item) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDisembodied (inherited from Item) | [read]
IsFromHistory (inherited from Item) | [read] true if this is a historical item obtained from the history.
IsNew (inherited from Item) | [read] true if this item has not yet been stored in the server.
IsRefreshRequired (inherited from Item) | [read] true if Item properties may be out of date.
IsRootShare (inherited from Item) | [read] true if this item is the root share; false otherwise.
Item (inherited from TypedResource) |
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemRevisions (inherited from Item) | [read]
Locker (inherited from Item) | [read] The user ID of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read]
ModifiedBy (inherited from Item) | [read] The user ID of the user that created this revision of the item.
ModifiedTime (inherited from Item) | [read] The time at which this revision of the item was created.
MyLock (inherited from Item) | [read] the lock status of the item for the currently logged in user
Name (inherited from Folder) | [read/write] the name of the folder.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotInViewFiles (inherited from Folder) | [read] an array of "not in view" File objects in this Folder, applying exclusions as appropriate.
ObjectID (inherited from Item) | [read] The object ID for this item.
Owner (inherited from Item) |
ParentContainer (inherited from Item) |
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from Item) | [read] The revision number at which this item was branched.
Path (inherited from Folder) | [read] the local working file path being used for this folder.
PathFragment (inherited from Folder) | [read] the path fragment to use for this folder.
PossibleFlag (inherited from Item) | [read] The possible values for the Flag property.
PossibleReadStatus (inherited from Item) | [read] The possible values for the ReadStatus property.
PropertyNames (inherited from TypedResource) | [read] the PropertyNames object from this items' server object.
QualifiedName (inherited from Folder) | [read] The fully-qualified name of this folder.
ReadStatus (inherited from Item) | [read] A flag indicating whether or not the user has read this item before.
References (inherited from Item) | [read]
RevisionNumber (inherited from Item) | [read] The branch revision number for this item.
RootObjectID (inherited from Item) | [read] The root object ID for this item.
Server (inherited from Item) | [read] the server object to which this item belongs.
SubFolderCount (inherited from Folder) | [read] the number of sub folders for this folder.
SubFolders (inherited from Folder) | [read] the subfolders of this folder. Will not return null but may return an empty array if the folder has no subfolders.
Type (inherited from TypedResource) | [read] the type of this object
TypeNames (inherited from TypedResource) | [read] the TypeNames object from the owning server.
UserVisible (inherited from Folder) | [read/write]
View (inherited from Item) | [read] the View in which this item exists.
ViewVersion (inherited from Item) | [read] The view version number of this item.

Public Instance Methods

AcquireOwnership (inherited from Item)
Add (inherited from Folder) | Adds the specified item to this folder. The added item will still exist in its original folder as well as in this one.
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CopyFolderTree (inherited from Folder) | Copies a folder tree. Does not populate any properties or copy any cached items.
CountItems (inherited from Folder) | Returns a count of the number of items (of a given type) reachable from this folder to the given depth
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardItems (inherited from Folder) | Discards cached items of the specified type in this folder. Subsequent calls to getItems will re-fetch the items from the server (even when MPX is enabled).
EnumerateItems (inherited from Folder) | Returns an Enumeration of the items of the specified type that exist in this folder.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContainerLevelACL (inherited from Folder)
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFilePath (inherited from Folder) | For a given file name, this method returns the concatenation of the file name and the working directory path of this folder.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFolderTree (inherited from Folder) | Retrieves a copy of this Folder object in the specified context and depth.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetItems (inherited from Folder) | Ensures that the list of items of the specified type for this folder have been retrieved from the server and cached locally. The list of items is retrieved from the server only if it has not already been retrieved. Therefore, the list of items may or may not be up-to-date with respect to the latest information on the server. To ensure that the list is up-to-date, use refresh(). getItems() does not retrieve any item properties. To ensure that a specific set of properties is avaliable, use populateNow().
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPreviewState
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Folder) | Overloaded.
HasPermission (inherited from Item) | Overloaded.
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsExcluded (inherited from Folder) | Determines if the given file name is one that will be excluded (matcthes the exclude list criteria) from operations in the working directory. Most StarTeam clients make use of a folder's exclude list by not allowing excluded files to be added to the repository. Nothing in the StarTeam SDK prevents any file being added to a repository it must be implemented as specific client-side logic. For example, the StarTeam GUI will not display any excluded files whose status is "Not In View" in the list control.
IsPopulated (inherited from Folder) | Determines whether or not this folder's items have been populated.
IsRefreshItemsRequired (inherited from Folder) Determines whether or not the items of the given type need to be refreshed. A refresh is required if the cached items are not known to be up-to-date with respect to the latest information in the repository. Specifically, a refresh is required if:
  • MPX is not enabled, or
  • At least one new item has been added since the last refresh, or
  • At least one item has been deleted since the last refresh, or
  • The value of one or more of the specified properties is not yet known for at least one of the items, or
  • The properties of at least one item have changed since the last refresh.
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
NewFolderEventSource (inherited from Folder)
NewFolderTreeEventSource (inherited from Folder)
NewFolderUpdateEventSource (inherited from Folder)
NewItemEventSource (inherited from Folder) | Overloaded.
NewItemIDEventSource (inherited from Folder) | Overloaded.
NewItemListEventSource (inherited from Folder) | Overloaded.
NewItemUpdateEventSource (inherited from Folder)
NewNotificationEventSource (inherited from Folder) | Overloaded.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
PopulateInBackground (inherited from Folder) | Similar to populateNow(). Items are populated in a background thread.
PopulateNow (inherited from Folder) | Ensures that the items of the specified type have been retrieved from the server and cached locally. Also ensures that the specified properties have been retrieved for each item. populateNow() does not retrieve any items or properties that have already been cached. Therefore, the item and property information may or may not be up-to-date with respect to the latest information on the server. To ensure that the item and property information is up-to-date, use refresh(). When an application attempts to access the value of a given property of an item, and that property has not yet been retrieved from the server, a command is issued to the server to retrieve all the properties of that item and cache them locally. For applications that examine many items, it is much more efficient to populate all the required properties up front, using populateNow(). It is sometimes difficult to determine exactly which item properties are used by a given application. If performance problems cause you to suspect that there is a property that has not been populated correctly, you can use NetMonitor to help diagnose the problem. If accessing a specific item property results in a fetch from the server, NetMonitor will display a message indicating which property caused the fetch.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshForeignFiles (inherited from Folder) | Refresh the foreign files in this folder, and its child folders depending on the specified "depth."
RefreshItems (inherited from Folder) | Ensures that the latest list of items of the specified type for this folder has been retrieved from the server and cached locally. Also ensures that the latest values of the specified properties have been retrieved for each item. refreshItems() is similar to populateNow(). However, refreshItems() ensures that the list of items and the properties of each item are up-to-date with respect to the latest information on the server. refreshItems() re-uses existing Item objects whenever possible, changing cached property values as necessary to bring older Items up-to-date. When MPX is enabled, refreshItems() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Folder) | Overloaded. Reverse shares this folder to a new parent folder. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetContainerLevelACL (inherited from Folder)
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Folder) | Overloaded. Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ShareTo (inherited from Item) | Overloaded. Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateFolderTree (inherited from Folder) | Calls update() on itself, and recursively calls Folder.updateAllFolders() on Folders returned from getSubFolders().
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

VCMFolder Class | Borland.StarTeam.Viewcomparemerge Namespace


VCMFolder Constructor

Construct VCMFolder from com.starbase.starteam.viewcomparemerge.VCMFolder.

public VCMFolder(
VCMFolder impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.VCMFolder to be wrapped.

See Also

VCMFolder Class | Borland.StarTeam.Viewcomparemerge Namespace


VCMFolder Methods

The methods of the VCMFolder class are listed below. For a complete list of VCMFolder class members, see the VCMFolder Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.VCMFolder.

Public Instance Methods

AcquireOwnership (inherited from Item)
Add (inherited from Folder) | Adds the specified item to this folder. The added item will still exist in its original folder as well as in this one.
AddAttachment (inherited from Item) | Add new attachment information to this item. The attachment should have already been created with a call to a createAttachment method. This method simply updates the item's properties describing which attachments it has associated with it. The name can not contain a newline character. The changes made must be saved with a call to update().
AddToIntArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
CopyFolderTree (inherited from Folder) | Copies a folder tree. Does not populate any properties or copy any cached items.
CountItems (inherited from Folder) | Returns a count of the number of items (of a given type) reachable from this folder to the given depth
CreateAttachment (inherited from Item) | Creates a new attachment and returns the new attachment ID.
CreateAttachmentFromFile (inherited from Item) | Creates a new attachment and returns the new attachment ID.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardItems (inherited from Folder) | Discards cached items of the specified type in this folder. Subsequent calls to getItems will re-fetch the items from the server (even when MPX is enabled).
EnumerateItems (inherited from Folder) | Returns an Enumeration of the items of the specified type that exist in this folder.
Equals (inherited from TypedResource) | Delegate Equals() to com.starbase.starteam.TypedResource.
Get (inherited from TypedResource) | Return the value for the specified property.
GetAttachment (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetAttachmentToFile (inherited from Item) | Retrieves the specified attachment and copies it to the specified output stream.
GetByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByPropertyID (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
GetByteArray (inherited from TypedResource) | A convenience method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContainerLevelACL (inherited from Folder)
GetDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
GetDouble (inherited from TypedResource) | A convenience method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetFilePath (inherited from Folder) | For a given file name, this method returns the concatenation of the file name and the working directory path of this folder.
GetFlagDisplayName (inherited from Item) | Returns a user-friendly display name for the given "Flag" value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetFolderTree (inherited from Folder) | Retrieves a copy of this Folder object in the specified context and depth.
GetFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns null if a version is not found that existed as of the given date.
GetFromHistoryByLabelID (inherited from Item) | Returns the specified version of this item based on the given label ID. Returns null if a version is not found that is associated with the given label ID.
GetFromHistoryByVersion (inherited from Item) | Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monitonically increases for each new version of the item, even across branches.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starbase.starteam.TypedResource.
GetInt (inherited from TypedResource) | A convenience method for returning integer valued properties.
GetIntArray (inherited from TypedResource) | A convenience method for returning int[] valued properties.
GetItems (inherited from Folder) | Ensures that the list of items of the specified type for this folder have been retrieved from the server and cached locally. The list of items is retrieved from the server only if it has not already been retrieved. Therefore, the list of items may or may not be up-to-date with respect to the latest information on the server. To ensure that the list is up-to-date, use refresh(). getItems() does not retrieve any item properties. To ensure that a specific set of properties is avaliable, use populateNow().
GetOLEDate (inherited from TypedResource) | A convenience method for returning OLEDate valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPreviewState
GetReadStatusDisplayName (inherited from Item) | Returns a user-friendly display name for the given ReadStatus value. This is really a convenience method for accessing TypedResource.getEnumDisplayName for this property.
GetReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
GetString (inherited from TypedResource) | A convenience method for returning String valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from Folder) | Overloaded.
HasPermission (inherited from Item) | Overloaded.
HasValues (inherited from Item) | Returns true if every property specified contains a value, either retrieved from persistent store or set by the client; otherwise, returns false. A null properties array will be interpretted as meaning "all properties". Ignores any properties that are not cachable.
IsEqualTo (inherited from Item)
IsExcluded (inherited from Folder) | Determines if the given file name is one that will be excluded (matcthes the exclude list criteria) from operations in the working directory. Most StarTeam clients make use of a folder's exclude list by not allowing excluded files to be added to the repository. Nothing in the StarTeam SDK prevents any file being added to a repository it must be implemented as specific client-side logic. For example, the StarTeam GUI will not display any excluded files whose status is "Not In View" in the list control.
IsPopulated (inherited from Folder) | Determines whether or not this folder's items have been populated.
IsRefreshItemsRequired (inherited from Folder) Determines whether or not the items of the given type need to be refreshed. A refresh is required if the cached items are not known to be up-to-date with respect to the latest information in the repository. Specifically, a refresh is required if:
  • MPX is not enabled, or
  • At least one new item has been added since the last refresh, or
  • At least one item has been deleted since the last refresh, or
  • The value of one or more of the specified properties is not yet known for at least one of the items, or
  • The properties of at least one item have changed since the last refresh.
IsRefreshPropertiesRequired (inherited from Item) | Returns true if a refresh() operation might have resulted in any of the given Item properties being updated; returns false if and only if it is known that the given Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
Lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
ModifyFlagForUser (inherited from Item) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatusForUser (inherited from Item) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Move (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
MoveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
NewFolderEventSource (inherited from Folder)
NewFolderTreeEventSource (inherited from Folder)
NewFolderUpdateEventSource (inherited from Folder)
NewItemEventSource (inherited from Folder) | Overloaded.
NewItemIDEventSource (inherited from Folder) | Overloaded.
NewItemListEventSource (inherited from Folder) | Overloaded.
NewItemUpdateEventSource (inherited from Folder)
NewNotificationEventSource (inherited from Folder) | Overloaded.
Populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
PopulateInBackground (inherited from Folder) | Similar to populateNow(). Items are populated in a background thread.
PopulateNow (inherited from Folder) | Ensures that the items of the specified type have been retrieved from the server and cached locally. Also ensures that the specified properties have been retrieved for each item. populateNow() does not retrieve any items or properties that have already been cached. Therefore, the item and property information may or may not be up-to-date with respect to the latest information on the server. To ensure that the item and property information is up-to-date, use refresh(). When an application attempts to access the value of a given property of an item, and that property has not yet been retrieved from the server, a command is issued to the server to retrieve all the properties of that item and cache them locally. For applications that examine many items, it is much more efficient to populate all the required properties up front, using populateNow(). It is sometimes difficult to determine exactly which item properties are used by a given application. If performance problems cause you to suspect that there is a property that has not been populated correctly, you can use NetMonitor to help diagnose the problem. If accessing a specific item property results in a fetch from the server, NetMonitor will display a message indicating which property caused the fetch.
Put (inherited from TypedResource) | Set the value of the specified property and return the old value.
PutByPropertyID (inherited from SimpleTypedResource) | Set the value of the property specified by its property ID and return the old value.
PutLock (inherited from Item) | Sets the current user's lock for this item. This method can be used to break another user's exclusive lock on the item. An exception will be thrown if a break is attempted for a user that does not have sufficient rights to break locks.
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
Refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshForeignFiles (inherited from Folder) | Refresh the foreign files in this folder, and its child folders depending on the specified "depth."
RefreshItems (inherited from Folder) | Ensures that the latest list of items of the specified type for this folder has been retrieved from the server and cached locally. Also ensures that the latest values of the specified properties have been retrieved for each item. refreshItems() is similar to populateNow(). However, refreshItems() ensures that the list of items and the properties of each item are up-to-date with respect to the latest information on the server. refreshItems() re-uses existing Item objects whenever possible, changing cached property values as necessary to bring older Items up-to-date. When MPX is enabled, refreshItems() is optimized to avoid unnecessary server commands.
Remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
RemoveAttachment (inherited from Item) | Removes the specified attachment from this item. This will not actually delete the attachment, it will only disassociate it from this item. The associated attachment name is removed as well. The changes made must be saved with a call to update(). If the specified attachment ID is not associated with this item then an exception will be thrown.
RemoveFromIntArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
ReverseShareTo (inherited from Folder) | Overloaded. Reverse shares this folder to a new parent folder. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBranchOnChange (inherited from Item) | Sets the "Branch On Change" behavior.
SetContainerLevelACL (inherited from Folder)
SetFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
ShareTo (inherited from Folder) | Overloaded. Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ShareTo (inherited from Item) | Overloaded. Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToString (inherited from TypedResource) | Delegate ToString() to com.starbase.starteam.TypedResource.
Unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
Update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
UpdateFolderTree (inherited from Folder) | Calls update() on itself, and recursively calls Folder.updateAllFolders() on Folders returned from getSubFolders().
UpdateRevisionComment (inherited from Item) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

VCMFolder Class | Borland.StarTeam.Viewcomparemerge Namespace


VCMFolder.GetPreviewState Method

public virtual PreviewState GetPreviewState(
Type type
);

See Also

VCMFolder Class | Borland.StarTeam.Viewcomparemerge Namespace


VCMFolder.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.VCMFolder.

public static VCMFolder Wrap(
VCMFolder impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.VCMFolder to be wrapped.

Return Value

VCMFolder

See Also

VCMFolder Class | Borland.StarTeam.Viewcomparemerge Namespace


VCMFolder Type Conversions

The type conversions of the VCMFolder class are listed below. For a complete list of VCMFolder class members, see the VCMFolder Members topic.

Public Static Type Conversions

Implicit VCMFolder to VCMFolder Conversion Implicitly convert VCMFolder to com.starbase.starteam.viewcomparemerge.VCMFolder.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from TypedResource) Implementation of IWrapper.Unwrap().

See Also

VCMFolder Class | VCMFolder Members | Borland.StarTeam.Viewcomparemerge Namespace


VCMFolder Implicit VCMFolder to VCMFolder Conversion

Implicitly convert VCMFolder to com.starbase.starteam.viewcomparemerge.VCMFolder.

public static implicit operator VCMFolder(
VCMFolder arg
);

Parameters

arg
VCMFolder to convert.

Return Value

com.starbase.starteam.viewcomparemerge.VCMFolder

See Also

VCMFolder Class | Borland.StarTeam.Viewcomparemerge Namespace


VisMergeAdapter Class

Facilitates the use of the StarTeam VisMerge tool to resolve a file merge condition. Used as follows:

 VisMergeAdapter tool = new VisMergeAdapter(diff); tool.setIgnoreWhiteSpace(true); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("VisMerge failed with exit code: " + exitCode); }
Note that VisMerge was the default file merge tool in StarTeam 8.0 and earlier.

For a list of all members of this type, see VisMergeAdapter Members.

System.Object
FileMergeAdapter
VisMergeAdapter

public class VisMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

VisMergeAdapter Members | Borland.StarTeam.Viewcomparemerge Namespace


VisMergeAdapter Members

VisMergeAdapter overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.VisMergeAdapter.

Public Static Type Conversions

Implicit VisMergeAdapter to VisMergeAdapter Conversion Implicitly convert VisMergeAdapter to com.starbase.starteam.viewcomparemerge.VisMergeAdapter.

Public Instance Constructors

VisMergeAdapter Overloaded. Initializes a new instance of the VisMergeAdapter class.

Public Instance Properties

AutoMergeLinesWithNoConflicts | [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.
IgnoreWhiteSpace | [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

VisMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


VisMergeAdapter Constructor

Construct VisMergeAdapter from com.starbase.starteam.viewcomparemerge.VisMergeAdapter.

Overload List

Constructs a VisMerge adapter for resolving a given file merge condition.

public VisMergeAdapter(ItemDifference);

Construct VisMergeAdapter from com.starbase.starteam.viewcomparemerge.VisMergeAdapter.

public VisMergeAdapter(VisMergeAdapter);

See Also

VisMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


VisMergeAdapter Constructor (VisMergeAdapter)

Construct VisMergeAdapter from com.starbase.starteam.viewcomparemerge.VisMergeAdapter.

public VisMergeAdapter(
VisMergeAdapter impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.VisMergeAdapter to be wrapped.

See Also

VisMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace | VisMergeAdapter Constructor Overload List


VisMergeAdapter Constructor (ItemDifference)

Constructs a VisMerge adapter for resolving a given file merge condition.

public VisMergeAdapter(
ItemDifference diff
);

Parameters

diff
The ItemDifference whose file merge condition is to be resolved.

See Also

VisMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace | VisMergeAdapter Constructor Overload List


VisMergeAdapter Properties

The properties of the VisMergeAdapter class are listed below. For a complete list of VisMergeAdapter class members, see the VisMergeAdapter Members topic.

Public Instance Properties

AutoMergeLinesWithNoConflicts | [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.
IgnoreWhiteSpace | [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

VisMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


AutoMergeLinesWithNoConflicts Property

Borland StarTeam SDK for .NET

VisMergeAdapter.AutoMergeLinesWithNoConflicts Property

[read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

public virtual Boolean AutoMergeLinesWithNoConflicts {get; set;}

Property Value

true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

See Also

VisMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


IgnoreWhiteSpace Property

Borland StarTeam SDK for .NET

VisMergeAdapter.IgnoreWhiteSpace Property

[read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

public virtual Boolean IgnoreWhiteSpace {get; set;}

Property Value

true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

See Also

VisMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


VisMergeAdapter Methods

The methods of the VisMergeAdapter class are listed below. For a complete list of VisMergeAdapter class members, see the VisMergeAdapter Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.VisMergeAdapter.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

VisMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


VisMergeAdapter.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.VisMergeAdapter.

public static VisMergeAdapter Wrap(
VisMergeAdapter impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.VisMergeAdapter to be wrapped.

Return Value

VisMergeAdapter

See Also

VisMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


VisMergeAdapter Type Conversions

The type conversions of the VisMergeAdapter class are listed below. For a complete list of VisMergeAdapter class members, see the VisMergeAdapter Members topic.

Public Static Type Conversions

Implicit VisMergeAdapter to VisMergeAdapter Conversion Implicitly convert VisMergeAdapter to com.starbase.starteam.viewcomparemerge.VisMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

VisMergeAdapter Class | VisMergeAdapter Members | Borland.StarTeam.Viewcomparemerge Namespace


VisMergeAdapter Implicit VisMergeAdapter to VisMergeAdapter Conversion

Implicitly convert VisMergeAdapter to com.starbase.starteam.viewcomparemerge.VisMergeAdapter.

public static implicit operator VisMergeAdapter(
VisMergeAdapter arg
);

Parameters

arg
VisMergeAdapter to convert.

Return Value

com.starbase.starteam.viewcomparemerge.VisMergeAdapter

See Also

VisMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


WorkstationDefaultMergeAdapter Class

Uses the workstation default merge tool to resolve a file merge condition. For example:

 FileMergeAdapter tool = new WorkstationDefaultMergeAdapter(diff); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("The merge failed with exit code: " + exitCode); }
Note that if no file merge tool is registered in starteam-client-options.xml, then StarTeam File Compare / Merge (also known as "Delta II") is used by default.

For a list of all members of this type, see WorkstationDefaultMergeAdapter Members.

System.Object
FileMergeAdapter
WorkstationDefaultMergeAdapter

public class WorkstationDefaultMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Viewcomparemerge

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

WorkstationDefaultMergeAdapter Members | Borland.StarTeam.Viewcomparemerge Namespace


WorkstationDefaultMergeAdapter Members

WorkstationDefaultMergeAdapter overview

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter.

Public Static Type Conversions

Implicit WorkstationDefaultMergeAdapter to WorkstationDefaultMergeAdapter Conversion Implicitly convert WorkstationDefaultMergeAdapter to com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter.

Public Instance Constructors

WorkstationDefaultMergeAdapter Overloaded. Initializes a new instance of the WorkstationDefaultMergeAdapter class.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

WorkstationDefaultMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


WorkstationDefaultMergeAdapter Constructor

Construct WorkstationDefaultMergeAdapter from com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter.

Overload List

Constructs an adapter for resolving a given file merge condition.

public WorkstationDefaultMergeAdapter(ItemDifference);

Construct WorkstationDefaultMergeAdapter from com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter.

public WorkstationDefaultMergeAdapter(WorkstationDefaultMergeAdapter);

See Also

WorkstationDefaultMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


WorkstationDefaultMergeAdapter Constructor (WorkstationDefaultMergeAdapter)

Construct WorkstationDefaultMergeAdapter from com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter.

public WorkstationDefaultMergeAdapter(
WorkstationDefaultMergeAdapter impl
);

Parameters

impl
The com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter to be wrapped.

See Also

WorkstationDefaultMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace | WorkstationDefaultMergeAdapter Constructor Overload List


WorkstationDefaultMergeAdapter Constructor (ItemDifference)

Constructs an adapter for resolving a given file merge condition.

public WorkstationDefaultMergeAdapter(
ItemDifference diff
);

Parameters

diff
The ItemDifference whose file merge condition is to be resolved.

See Also

WorkstationDefaultMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace | WorkstationDefaultMergeAdapter Constructor Overload List


WorkstationDefaultMergeAdapter Methods

The methods of the WorkstationDefaultMergeAdapter class are listed below. For a complete list of WorkstationDefaultMergeAdapter class members, see the WorkstationDefaultMergeAdapter Members topic.

Public Static Methods

Wrap Dynamically wraps com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starbase.starteam.viewcomparemerge.FileMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

WorkstationDefaultMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


WorkstationDefaultMergeAdapter.Wrap Method

Dynamically wraps com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter.

public static WorkstationDefaultMergeAdapter Wrap(
WorkstationDefaultMergeAdapter impl
);

Parameters

impl
com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter to be wrapped.

Return Value

WorkstationDefaultMergeAdapter

See Also

WorkstationDefaultMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


WorkstationDefaultMergeAdapter Type Conversions

The type conversions of the WorkstationDefaultMergeAdapter class are listed below. For a complete list of WorkstationDefaultMergeAdapter class members, see the WorkstationDefaultMergeAdapter Members topic.

Public Static Type Conversions

Implicit WorkstationDefaultMergeAdapter to WorkstationDefaultMergeAdapter Conversion Implicitly convert WorkstationDefaultMergeAdapter to com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from FileMergeAdapter) Implementation of IWrapper.Unwrap().

See Also

WorkstationDefaultMergeAdapter Class | WorkstationDefaultMergeAdapter Members | Borland.StarTeam.Viewcomparemerge Namespace


WorkstationDefaultMergeAdapter Implicit WorkstationDefaultMergeAdapter to WorkstationDefaultMergeAdapter Conversion

Implicitly convert WorkstationDefaultMergeAdapter to com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter.

public static implicit operator WorkstationDefaultMergeAdapter(
WorkstationDefaultMergeAdapter arg
);

Parameters

arg
WorkstationDefaultMergeAdapter to convert.

Return Value

com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter

See Also

WorkstationDefaultMergeAdapter Class | Borland.StarTeam.Viewcomparemerge Namespace


Borland.StarTeam.Xml

Borland StarTeam SDK for .NET

Borland.StarTeam.Xml Namespace

Namespace hierarchy

Classes

Class | Description
XMLAttribute | This interface exposed the Java Class: com.borland.starteam.xml.XMLAttribute. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/xml/XMLAttribute.html
XMLAttributeCollection | A strongly-typed collection of XMLAttributes.
XMLDocument | This interface exposed the Java Class: com.borland.starteam.xml.XMLDocument. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/xml/XMLDocument.html
XMLElement | This interface exposed the Java Class: com.borland.starteam.xml.XMLElement. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/xml/XMLElement.html
XMLElementCollection | A strongly-typed collection of XMLElements.
XMLException |
XMLParseException |


XMLAttribute Class

This interface exposed the Java Class: com.borland.starteam.xml.XMLAttribute. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/xml/XMLAttribute.html

For a list of all members of this type, see XMLAttribute Members.

System.Object
XMLAttribute

public class XMLAttribute : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Xml

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

XMLAttribute Members | Borland.StarTeam.Xml Namespace


XMLAttribute Members

XMLAttribute overview

Public Static Methods

Wrap Dynamically wraps com.borland.starteam.xml.XMLAttribute.

Public Static Type Conversions

Implicit XMLAttribute to XMLAttribute Conversion Implicitly convert XMLAttribute to com.borland.starteam.xml.XMLAttribute.

Public Instance Constructors

XMLAttribute Constructor Construct XMLAttribute from com.borland.starteam.xml.XMLAttribute.

Public Instance Properties

Name | [read] The local name of this attribute.
Parent | [read] The parent element of this attribute.
QualifiedName | [read] The qualified name of this attribute.
Value | [read] The value of this attribute.

Public Instance Methods

Equals | Delegate Equals() to com.borland.starteam.xml.XMLAttribute.
GetHashCode | Delegate GetHashCode() to com.borland.starteam.xml.XMLAttribute.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.borland.starteam.xml.XMLAttribute.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


XMLAttribute Constructor

Construct XMLAttribute from com.borland.starteam.xml.XMLAttribute.

public XMLAttribute(
XMLAttribute impl
);

Parameters

impl
The com.borland.starteam.xml.XMLAttribute to be wrapped.

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


XMLAttribute Properties

The properties of the XMLAttribute class are listed below. For a complete list of XMLAttribute class members, see the XMLAttribute Members topic.

Public Instance Properties

Name | [read] The local name of this attribute.
Parent | [read] The parent element of this attribute.
QualifiedName | [read] The qualified name of this attribute.
Value | [read] The value of this attribute.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


Name Property

Borland StarTeam SDK for .NET

XMLAttribute.Name Property

[read] The local name of this attribute.

public virtual String Name {get;}

Property Value

The local name of this attribute.

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


Parent Property

Borland StarTeam SDK for .NET

XMLAttribute.Parent Property

[read] The parent element of this attribute.

public virtual XMLElement Parent {get;}

Property Value

The parent element of this attribute.

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


QualifiedName Property

Borland StarTeam SDK for .NET

XMLAttribute.QualifiedName Property

[read] The qualified name of this attribute.

public virtual String QualifiedName {get;}

Property Value

The qualified name of this attribute.

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


Value Property

Borland StarTeam SDK for .NET

XMLAttribute.Value Property

[read] The value of this attribute.

public virtual String Value {get;}

Property Value

The value of this attribute.

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


XMLAttribute Methods

The methods of the XMLAttribute class are listed below. For a complete list of XMLAttribute class members, see the XMLAttribute Members topic.

Public Static Methods

Wrap Dynamically wraps com.borland.starteam.xml.XMLAttribute.

Public Instance Methods

Equals | Delegate Equals() to com.borland.starteam.xml.XMLAttribute.
GetHashCode | Delegate GetHashCode() to com.borland.starteam.xml.XMLAttribute.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.borland.starteam.xml.XMLAttribute.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


XMLAttribute.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.borland.starteam.xml.XMLAttribute

Implements

IWrapper.Unwrap

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


XMLAttribute.Equals Method

Delegate Equals() to com.borland.starteam.xml.XMLAttribute.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.borland.starteam.xml.XMLAttribute.Equals(obj).

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


XMLAttribute.GetHashCode Method

Delegate GetHashCode() to com.borland.starteam.xml.XMLAttribute.

public override int GetHashCode();

Return Value

com.borland.starteam.xml.XMLAttribute.GetHashCode().

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


XMLAttribute.ToString Method

Delegate ToString() to com.borland.starteam.xml.XMLAttribute.

public override string ToString();

Return Value

com.borland.starteam.xml.XMLAttribute.ToString()

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


XMLAttribute.Wrap Method

Dynamically wraps com.borland.starteam.xml.XMLAttribute.

public static XMLAttribute Wrap(
XMLAttribute impl
);

Parameters

impl
com.borland.starteam.xml.XMLAttribute to be wrapped.

Return Value

XMLAttribute

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


XMLAttribute Type Conversions

The type conversions of the XMLAttribute class are listed below. For a complete list of XMLAttribute class members, see the XMLAttribute Members topic.

Public Static Type Conversions

Implicit XMLAttribute to XMLAttribute Conversion Implicitly convert XMLAttribute to com.borland.starteam.xml.XMLAttribute.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLAttribute Class | XMLAttribute Members | Borland.StarTeam.Xml Namespace


XMLAttribute Implicit XMLAttribute to XMLAttribute Conversion

Implicitly convert XMLAttribute to com.borland.starteam.xml.XMLAttribute.

public static implicit operator XMLAttribute(
XMLAttribute arg
);

Parameters

arg
XMLAttribute to convert.

Return Value

com.borland.starteam.xml.XMLAttribute

See Also

XMLAttribute Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection Class

A strongly-typed collection of XMLAttributes.

For a list of all members of this type, see XMLAttributeCollection Members.

System.Object
ArrayAdapter
XMLAttributeCollection

public class XMLAttributeCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Xml

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

XMLAttributeCollection Members | Borland.StarTeam.Xml Namespace


XMLAttributeCollection Members

XMLAttributeCollection overview

Public Static Methods

Wrap Creates a XMLAttributeCollection to represent the given array of XMLAttribute (from the com.borland.starteam.xml namespace).

Public Static Type Conversions

Implicit XMLAttributeCollection to XMLAttribute[] Conversion | Converts a XMLAttributeCollection to an array of XMLAttributes.
Implicit XMLAttributeCollection to XMLAttribute[] Conversion | Converts a XMLAttributeCollection from the Borland.StarTeam.Xml namespace to a XMLAttribute[] in the com.borland.starteam.xml namespace.

Public Instance Constructors

XMLAttributeCollection Overloaded. Initializes a new instance of the XMLAttributeCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the XMLAttribute at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a XMLAttribute to end of the collection.
Append | Overloaded. Appends the XMLAttributes of the given XMLAttributeCollection to the end of this XMLAttributeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific XMLAttribute.
CopyTo | Copies all of the XMLAttributes in the XMLAttributeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the XMLAttribute with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific XMLAttribute in the collection.
Insert | Inserts a XMLAttribute into the collection at the specified position.
Remove | Removes the first occurrence of a specific XMLAttribute from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the XMLAttributes in this XMLAttributeCollection.
Sort | Sorts the XMLAttributes in this XMLAttributeCollection, using the given comparer.
SortByName | Sorts the XMLAttributes in this XMLAttributeCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.xml namespace.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection Constructor

Initializes an instance of the XMLAttributeCollection class.

Overload List

Initializes an instance of the XMLAttributeCollection class.

public XMLAttributeCollection();

Initializes an instance of the a XMLAttributeCollection class, copying the given array.

public XMLAttributeCollection(XMLAttribute[]);

Initializes an instance of the a XMLAttributeCollection class, copying the given collection.

public XMLAttributeCollection(XMLAttributeCollection);

Initializes an instance of the a XMLAttributeCollection class, wrapping the given array of XMLAttribute (from the com.borland.starteam.xml namespace).

public XMLAttributeCollection(XMLAttribute[]);

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection Constructor ()

Initializes an instance of the XMLAttributeCollection class.

public XMLAttributeCollection();

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace | XMLAttributeCollection Constructor Overload List


XMLAttributeCollection Constructor (XMLAttribute[])

Initializes an instance of the a XMLAttributeCollection class, wrapping the given array of XMLAttribute (from the com.borland.starteam.xml namespace).

public XMLAttributeCollection(
XMLAttribute[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.borland.starteam.xml namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace | XMLAttributeCollection Constructor Overload List | Wrap


XMLAttributeCollection Constructor (XMLAttributeCollection)

Initializes an instance of the a XMLAttributeCollection class, copying the given collection.

public XMLAttributeCollection(
XMLAttributeCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member XMLAttribute objects of the original collection are shared, not copied.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace | XMLAttributeCollection Constructor Overload List


XMLAttributeCollection Constructor (XMLAttribute[])

Initializes an instance of the a XMLAttributeCollection class, copying the given array.

public XMLAttributeCollection(
XMLAttribute[] array
);

Parameters

array
The array to be copied.

Remarks

The member XMLAttribute objects of the original array are shared, not copied.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace | XMLAttributeCollection Constructor Overload List


XMLAttributeCollection Properties

The properties of the XMLAttributeCollection class are listed below. For a complete list of XMLAttributeCollection class members, see the XMLAttributeCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the XMLAttribute at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.xml namespace.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


Item Property

Borland StarTeam SDK for .NET

XMLAttributeCollection.Item Property

Gets or sets the XMLAttribute at the specified index.

Overload List

Gets or sets the XMLAttribute at the specified index.

public XMLAttribute this[Int32] {get; set;}

Gets the XMLAttribute with the given name.

public XMLAttribute this[String] {get;}

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

XMLAttributeCollection.Item Property (Int32)

Gets or sets the XMLAttribute at the specified index.

public XMLAttribute this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the XMLAttribute to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace | XMLAttributeCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

XMLAttributeCollection.Item Property (String)

Gets the XMLAttribute with the given name.

public XMLAttribute this[
String name
] {get;}

Parameters

name
The name of the XMLAttribute to get.

Property Value

The XMLAttribute with the given name, or null if there is no XMLAttribute with that name in this XMLAttributeCollection. Comparison is case sensitive.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace | XMLAttributeCollection.Item Overload List | FindByName


XMLAttributeCollection Methods

The methods of the XMLAttributeCollection class are listed below. For a complete list of XMLAttributeCollection class members, see the XMLAttributeCollection Members topic.

Public Static Methods

Wrap Creates a XMLAttributeCollection to represent the given array of XMLAttribute (from the com.borland.starteam.xml namespace).

Public Instance Methods

Add | Adds a XMLAttribute to end of the collection.
Append | Overloaded. Appends the XMLAttributes of the given XMLAttributeCollection to the end of this XMLAttributeCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific XMLAttribute.
CopyTo | Copies all of the XMLAttributes in the XMLAttributeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the XMLAttribute with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific XMLAttribute in the collection.
Insert | Inserts a XMLAttribute into the collection at the specified position.
Remove | Removes the first occurrence of a specific XMLAttribute from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the XMLAttributes in this XMLAttributeCollection.
Sort | Sorts the XMLAttributes in this XMLAttributeCollection, using the given comparer.
SortByName | Sorts the XMLAttributes in this XMLAttributeCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.xml namespace.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.Add Method

Adds a XMLAttribute to end of the collection.

public int Add(
XMLAttribute value
);

Parameters

value
The XMLAttribute to add to the collection.

Return Value

The position into which the new XMLAttribute was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


Append Method

Borland StarTeam SDK for .NET

XMLAttributeCollection.Append Method

Appends the XMLAttributes of the given array to the end of this XMLAttributeCollection.

Overload List

Appends the XMLAttributes of the given array to the end of this XMLAttributeCollection.

public XMLAttributeCollection Append(XMLAttribute[]);

Appends the XMLAttributes of the given XMLAttributeCollection to the end of this XMLAttributeCollection.

public XMLAttributeCollection Append(XMLAttributeCollection);

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.Append Method (XMLAttribute[])

Appends the XMLAttributes of the given array to the end of this XMLAttributeCollection.

public XMLAttributeCollection Append(
XMLAttribute[] array
);

Parameters

array
The array whose XMLAttributes are to be appended to this XMLAttributeCollection.

Return Value

This XMLAttributeCollection, modified to include the new XMLAttributes.

Remarks

The XMLAttributeCollection is modified to include the new members. The individual XMLAttribute objects are shared, not copied.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace | XMLAttributeCollection.Append Overload List


XMLAttributeCollection.Append Method (XMLAttributeCollection)

Appends the XMLAttributes of the given XMLAttributeCollection to the end of this XMLAttributeCollection.

public XMLAttributeCollection Append(
XMLAttributeCollection collection
);

Parameters

collection
The XMLAttributeCollection whose XMLAttributes are to be appended to this XMLAttributeCollection.

Return Value

This XMLAttributeCollection, modified to include the new XMLAttributes.

Remarks

The XMLAttributeCollection is modified to include the new members. The individual XMLAttribute objects are shared, not copied.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace | XMLAttributeCollection.Append Overload List


XMLAttributeCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.borland.starteam.xml namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.borland.starteam.xml.XMLAttribute[].

Implements

IWrapper.Unwrap

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.Contains Method

Determines whether or not the collection contains a specific XMLAttribute.

public bool Contains(
XMLAttribute value
);

Parameters

value
The XMLAttribute to locate in the collection.

Return Value

true if the XMLAttribute is found in the collection; otherwise, false.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.CopyTo Method

Copies all of the XMLAttributes in the XMLAttributeCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
XMLAttribute[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the XMLAttributes copied from the XMLAttributeCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of XMLAttributes in the source XMLAttributeCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source XMLAttributeCollection cannot be cast automatically to the type of the destination array.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.FindByName Method

Finds the XMLAttribute with the given name.

public XMLAttribute FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the XMLAttribute to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The XMLAttribute with the given name, or null if there is no XMLAttribute with that name in this XMLAttributeCollection.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.IndexOf Method

Determines the index of a specific XMLAttribute in the collection.

public int IndexOf(
XMLAttribute value
);

Parameters

value
The XMLAttribute to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.Insert Method

Inserts a XMLAttribute into the collection at the specified position.

public void Insert(
Int32 index,
XMLAttribute value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The XMLAttribute to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.Remove Method

Removes the first occurrence of a specific XMLAttribute from the collection.

public void Remove(
XMLAttribute value
);

Parameters

value
The XMLAttribute to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.Reverse Method

Reverses the order of the XMLAttributes in this XMLAttributeCollection.

new public XMLAttributeCollection Reverse();

Return Value

This XMLAttributeCollection, modified such that the XMLAttributes are reversed.

Remarks

The XMLAttributeCollection is modified in place.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.Sort Method

Sorts the XMLAttributes in this XMLAttributeCollection, using the given comparer.

new public XMLAttributeCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two XMLAttributes.

Return Value

This XMLAttributeCollection, modified such that the XMLAttributes are sorted.

Remarks

The XMLAttributeCollection is modified in place.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.SortByName Method

Sorts the XMLAttributes in this XMLAttributeCollection by name.

public XMLAttributeCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This XMLAttributeCollection, modified such that the XMLAttributes are sorted by name.

Remarks

The XMLAttributeCollection is modified in place.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection.Wrap Method

Creates a XMLAttributeCollection to represent the given array of XMLAttribute (from the com.borland.starteam.xml namespace).

public static XMLAttributeCollection Wrap(
XMLAttribute[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new XMLAttributeCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a XMLAttribute[] from the com.borland.starteam.xml namespace to the Borland.StarTeam.Xml namespace.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection Type Conversions

The type conversions of the XMLAttributeCollection class are listed below. For a complete list of XMLAttributeCollection class members, see the XMLAttributeCollection Members topic.

Public Static Type Conversions

Implicit XMLAttributeCollection to XMLAttribute[] Conversion | Converts a XMLAttributeCollection to an array of XMLAttributes.
Implicit XMLAttributeCollection to XMLAttribute[] Conversion | Converts a XMLAttributeCollection from the Borland.StarTeam.Xml namespace to a XMLAttribute[] in the com.borland.starteam.xml namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.xml namespace.

See Also

XMLAttributeCollection Class | XMLAttributeCollection Members | Borland.StarTeam.Xml Namespace


XMLAttributeCollection Implicit XMLAttributeCollection to XMLAttribute[] Conversion

Converts a XMLAttributeCollection to an array of XMLAttributes.

public static implicit operator XMLAttribute[](
XMLAttributeCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new XMLAttribute wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one XMLAttribute wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLAttributeCollection Implicit XMLAttributeCollection to XMLAttribute[] Conversion

Converts a XMLAttributeCollection from the Borland.StarTeam.Xml namespace to a XMLAttribute[] in the com.borland.starteam.xml namespace.

public static implicit operator XMLAttribute[](
XMLAttributeCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam.Xml namespace to methods in the com.borland.starteam.xml namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, XMLAttributeCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

XMLAttributeCollection Class | Borland.StarTeam.Xml Namespace


XMLDocument Class

This interface exposed the Java Class: com.borland.starteam.xml.XMLDocument. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/xml/XMLDocument.html

For a list of all members of this type, see XMLDocument Members.

System.Object
XMLDocument

public class XMLDocument : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Xml

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

XMLDocument Members | Borland.StarTeam.Xml Namespace


XMLDocument Members

XMLDocument overview

Public Static Methods

Build | Overloaded.
Wrap | Dynamically wraps com.borland.starteam.xml.XMLDocument.

Public Static Type Conversions

Implicit XMLDocument to XMLDocument Conversion Implicitly convert XMLDocument to com.borland.starteam.xml.XMLDocument.

Public Instance Constructors

XMLDocument Constructor Construct XMLDocument from com.borland.starteam.xml.XMLDocument.

Public Instance Properties

RootElement [read] The root element of this document.

Public Instance Methods

Equals | Delegate Equals() to com.borland.starteam.xml.XMLDocument.
GetHashCode | Delegate GetHashCode() to com.borland.starteam.xml.XMLDocument.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.borland.starteam.xml.XMLDocument.
Write | Overloaded.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


XMLDocument Constructor

Construct XMLDocument from com.borland.starteam.xml.XMLDocument.

public XMLDocument(
XMLDocument impl
);

Parameters

impl
The com.borland.starteam.xml.XMLDocument to be wrapped.

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


XMLDocument Properties

The properties of the XMLDocument class are listed below. For a complete list of XMLDocument class members, see the XMLDocument Members topic.

Public Instance Properties

RootElement [read] The root element of this document.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


RootElement Property

Borland StarTeam SDK for .NET

XMLDocument.RootElement Property

[read] The root element of this document.

public virtual XMLElement RootElement {get;}

Property Value

The root element of this document.

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


XMLDocument Methods

The methods of the XMLDocument class are listed below. For a complete list of XMLDocument class members, see the XMLDocument Members topic.

Public Static Methods

Build | Overloaded.
Wrap | Dynamically wraps com.borland.starteam.xml.XMLDocument.

Public Instance Methods

Equals | Delegate Equals() to com.borland.starteam.xml.XMLDocument.
GetHashCode | Delegate GetHashCode() to com.borland.starteam.xml.XMLDocument.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.borland.starteam.xml.XMLDocument.
Write | Overloaded.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


XMLDocument.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.borland.starteam.xml.XMLDocument

Implements

IWrapper.Unwrap

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


Build Method

Borland StarTeam SDK for .NET

XMLDocument.Build Method

Overload List

public static XMLDocument Build(Byte[]);

public static XMLDocument Build(FileInfo);

public static XMLDocument Build(Stream);

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


XMLDocument.Build Method (Byte[])

public static XMLDocument Build(
Byte[] source
);

Parameters

source

Return Value

A parsed DOM representation of the XML document.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.borland.starteam.xml.XMLException

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace | XMLDocument.Build Overload List


XMLDocument.Build Method (FileInfo)

public static XMLDocument Build(
FileInfo source
);

Parameters

source

Return Value

A parsed DOM representation of the XML document.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.borland.starteam.xml.XMLException

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace | XMLDocument.Build Overload List


XMLDocument.Build Method (Stream)

public static XMLDocument Build(
Stream source
);

Parameters

source

Return Value

A parsed DOM representation of the XML document.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.borland.starteam.xml.XMLException

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace | XMLDocument.Build Overload List


XMLDocument.Equals Method

Delegate Equals() to com.borland.starteam.xml.XMLDocument.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.borland.starteam.xml.XMLDocument.Equals(obj).

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


XMLDocument.GetHashCode Method

Delegate GetHashCode() to com.borland.starteam.xml.XMLDocument.

public override int GetHashCode();

Return Value

com.borland.starteam.xml.XMLDocument.GetHashCode().

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


XMLDocument.ToString Method

Delegate ToString() to com.borland.starteam.xml.XMLDocument.

public override string ToString();

Return Value

com.borland.starteam.xml.XMLDocument.ToString()

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


XMLDocument.Wrap Method

Dynamically wraps com.borland.starteam.xml.XMLDocument.

public static XMLDocument Wrap(
XMLDocument impl
);

Parameters

impl
com.borland.starteam.xml.XMLDocument to be wrapped.

Return Value

XMLDocument

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


Write Method

Borland StarTeam SDK for .NET

XMLDocument.Write Method

Overload List

public virtual void Write(FileInfo);

public virtual void Write(Stream);

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


XMLDocument.Write Method (FileInfo)

public virtual void Write(
FileInfo _out
);

Parameters

_out

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.borland.starteam.xml.XMLException

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace | XMLDocument.Write Overload List


XMLDocument.Write Method (Stream)

public virtual void Write(
Stream _out
);

Parameters

_out

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.borland.starteam.xml.XMLException

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace | XMLDocument.Write Overload List


XMLDocument Type Conversions

The type conversions of the XMLDocument class are listed below. For a complete list of XMLDocument class members, see the XMLDocument Members topic.

Public Static Type Conversions

Implicit XMLDocument to XMLDocument Conversion Implicitly convert XMLDocument to com.borland.starteam.xml.XMLDocument.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLDocument Class | XMLDocument Members | Borland.StarTeam.Xml Namespace


XMLDocument Implicit XMLDocument to XMLDocument Conversion

Implicitly convert XMLDocument to com.borland.starteam.xml.XMLDocument.

public static implicit operator XMLDocument(
XMLDocument arg
);

Parameters

arg
XMLDocument to convert.

Return Value

com.borland.starteam.xml.XMLDocument

See Also

XMLDocument Class | Borland.StarTeam.Xml Namespace


XMLElement Class

This interface exposed the Java Class: com.borland.starteam.xml.XMLElement. Please refer to Sun's documentation for this class: http://java.sun.com/j2se/1.3/docs/api/com/borland/starteam/xml/XMLElement.html

For a list of all members of this type, see XMLElement Members.

System.Object
XMLElement

public class XMLElement : IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Xml

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

XMLElement Members | Borland.StarTeam.Xml Namespace


XMLElement Members

XMLElement overview

Public Static Methods

Wrap Dynamically wraps com.borland.starteam.xml.XMLElement.

Public Static Type Conversions

Implicit XMLElement to XMLElement Conversion Implicitly convert XMLElement to com.borland.starteam.xml.XMLElement.

Public Instance Constructors

XMLElement Constructor Construct XMLElement from com.borland.starteam.xml.XMLElement.

Public Instance Properties

Attributes | [read] The attributes associated with this element, or an empty array if there are none.
Children | [read] A list of all the direct child elements of this element.
Name | [read] The local name of this element.
QualifiedName | [read] The qualified name of this element.
Text | [read] The textual content of this element.

Public Instance Methods

Equals | Delegate Equals() to com.borland.starteam.xml.XMLElement.
GetAttributeValue |
GetChild |
GetChildren |
GetHashCode | Delegate GetHashCode() to com.borland.starteam.xml.XMLElement.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.borland.starteam.xml.XMLElement.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement Constructor

Construct XMLElement from com.borland.starteam.xml.XMLElement.

public XMLElement(
XMLElement impl
);

Parameters

impl
The com.borland.starteam.xml.XMLElement to be wrapped.

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement Properties

The properties of the XMLElement class are listed below. For a complete list of XMLElement class members, see the XMLElement Members topic.

Public Instance Properties

Attributes | [read] The attributes associated with this element, or an empty array if there are none.
Children | [read] A list of all the direct child elements of this element.
Name | [read] The local name of this element.
QualifiedName | [read] The qualified name of this element.
Text | [read] The textual content of this element.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


Attributes Property

Borland StarTeam SDK for .NET

XMLElement.Attributes Property

[read] The attributes associated with this element, or an empty array if there are none.

public virtual XMLAttributeCollection Attributes {get;}

Property Value

The attributes associated with this element, or an empty array if there are none.

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


Children Property

Borland StarTeam SDK for .NET

XMLElement.Children Property

[read] A list of all the direct child elements of this element.

public virtual XMLElementCollection Children {get;}

Property Value

A list of all the direct child elements of this element.

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


Name Property

Borland StarTeam SDK for .NET

XMLElement.Name Property

[read] The local name of this element.

public virtual String Name {get;}

Property Value

The local name of this element.

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


QualifiedName Property

Borland StarTeam SDK for .NET

XMLElement.QualifiedName Property

[read] The qualified name of this element.

public virtual String QualifiedName {get;}

Property Value

The qualified name of this element.

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


Text Property

Borland StarTeam SDK for .NET

XMLElement.Text Property

[read] The textual content of this element.

public virtual String Text {get;}

Property Value

The textual content of this element.

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement Methods

The methods of the XMLElement class are listed below. For a complete list of XMLElement class members, see the XMLElement Members topic.

Public Static Methods

Wrap Dynamically wraps com.borland.starteam.xml.XMLElement.

Public Instance Methods

Equals | Delegate Equals() to com.borland.starteam.xml.XMLElement.
GetAttributeValue |
GetChild |
GetChildren |
GetHashCode | Delegate GetHashCode() to com.borland.starteam.xml.XMLElement.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.borland.starteam.xml.XMLElement.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.borland.starteam.xml.XMLElement

Implements

IWrapper.Unwrap

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement.Equals Method

Delegate Equals() to com.borland.starteam.xml.XMLElement.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.borland.starteam.xml.XMLElement.Equals(obj).

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement.GetAttributeValue Method

public virtual string GetAttributeValue(
String name
);

Parameters

name

Return Value

The value of the attribute, or null.

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement.GetChild Method

public virtual XMLElement GetChild(
String name
);

Parameters

name

Return Value

The first child element with the given name, or null.

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement.GetChildren Method

public virtual XMLElementCollection GetChildren(
String name
);

Parameters

name

Return Value

A list of all the direct child elements with the given name.

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement.GetHashCode Method

Delegate GetHashCode() to com.borland.starteam.xml.XMLElement.

public override int GetHashCode();

Return Value

com.borland.starteam.xml.XMLElement.GetHashCode().

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement.ToString Method

Delegate ToString() to com.borland.starteam.xml.XMLElement.

public override string ToString();

Return Value

com.borland.starteam.xml.XMLElement.ToString()

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement.Wrap Method

Dynamically wraps com.borland.starteam.xml.XMLElement.

public static XMLElement Wrap(
XMLElement impl
);

Parameters

impl
com.borland.starteam.xml.XMLElement to be wrapped.

Return Value

XMLElement

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElement Type Conversions

The type conversions of the XMLElement class are listed below. For a complete list of XMLElement class members, see the XMLElement Members topic.

Public Static Type Conversions

Implicit XMLElement to XMLElement Conversion Implicitly convert XMLElement to com.borland.starteam.xml.XMLElement.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLElement Class | XMLElement Members | Borland.StarTeam.Xml Namespace


XMLElement Implicit XMLElement to XMLElement Conversion

Implicitly convert XMLElement to com.borland.starteam.xml.XMLElement.

public static implicit operator XMLElement(
XMLElement arg
);

Parameters

arg
XMLElement to convert.

Return Value

com.borland.starteam.xml.XMLElement

See Also

XMLElement Class | Borland.StarTeam.Xml Namespace


XMLElementCollection Class

A strongly-typed collection of XMLElements.

For a list of all members of this type, see XMLElementCollection Members.

System.Object
ArrayAdapter
XMLElementCollection

public class XMLElementCollection : ArrayAdapter, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Xml

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

XMLElementCollection Members | Borland.StarTeam.Xml Namespace


XMLElementCollection Members

XMLElementCollection overview

Public Static Methods

Wrap Creates a XMLElementCollection to represent the given array of XMLElement (from the com.borland.starteam.xml namespace).

Public Static Type Conversions

Implicit XMLElementCollection to XMLElement[] Conversion | Converts a XMLElementCollection to an array of XMLElements.
Implicit XMLElementCollection to XMLElement[] Conversion | Converts a XMLElementCollection from the Borland.StarTeam.Xml namespace to a XMLElement[] in the com.borland.starteam.xml namespace.

Public Instance Constructors

XMLElementCollection Overloaded. Initializes a new instance of the XMLElementCollection class.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the XMLElement at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a XMLElement to end of the collection.
Append | Overloaded. Appends the XMLElements of the given XMLElementCollection to the end of this XMLElementCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific XMLElement.
CopyTo | Copies all of the XMLElements in the XMLElementCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the XMLElement with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific XMLElement in the collection.
Insert | Inserts a XMLElement into the collection at the specified position.
Remove | Removes the first occurrence of a specific XMLElement from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the XMLElements in this XMLElementCollection.
Sort | Sorts the XMLElements in this XMLElementCollection, using the given comparer.
SortByName | Sorts the XMLElements in this XMLElementCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.xml namespace.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection Constructor

Initializes an instance of the XMLElementCollection class.

Overload List

Initializes an instance of the XMLElementCollection class.

public XMLElementCollection();

Initializes an instance of the a XMLElementCollection class, copying the given array.

public XMLElementCollection(XMLElement[]);

Initializes an instance of the a XMLElementCollection class, copying the given collection.

public XMLElementCollection(XMLElementCollection);

Initializes an instance of the a XMLElementCollection class, wrapping the given array of XMLElement (from the com.borland.starteam.xml namespace).

public XMLElementCollection(XMLElement[]);

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection Constructor ()

Initializes an instance of the XMLElementCollection class.

public XMLElementCollection();

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace | XMLElementCollection Constructor Overload List


XMLElementCollection Constructor (XMLElement[])

Initializes an instance of the a XMLElementCollection class, wrapping the given array of XMLElement (from the com.borland.starteam.xml namespace).

public XMLElementCollection(
XMLElement[] impl
);

Parameters

impl
The array to be wrapped.

Remarks

The original array is referenced, not copied.

Most applications will not need to explicitly wrap objects from the com.borland.starteam.xml namespace. Those that do will usually use Wrap instead of calling this constructor directly.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace | XMLElementCollection Constructor Overload List | Wrap


XMLElementCollection Constructor (XMLElementCollection)

Initializes an instance of the a XMLElementCollection class, copying the given collection.

public XMLElementCollection(
XMLElementCollection collection
);

Parameters

collection
The collection to be copied.

Remarks

The member XMLElement objects of the original collection are shared, not copied.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace | XMLElementCollection Constructor Overload List


XMLElementCollection Constructor (XMLElement[])

Initializes an instance of the a XMLElementCollection class, copying the given array.

public XMLElementCollection(
XMLElement[] array
);

Parameters

array
The array to be copied.

Remarks

The member XMLElement objects of the original array are shared, not copied.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace | XMLElementCollection Constructor Overload List


XMLElementCollection Properties

The properties of the XMLElementCollection class are listed below. For a complete list of XMLElementCollection class members, see the XMLElementCollection Members topic.

Public Instance Properties

Count (inherited from ArrayAdapter) | Gets the number of elements contained in the collection.
IsFixedSize (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection has a fixed size.
IsReadOnly (inherited from ArrayAdapter) | Gets a value indicating whether or not the collection can be modified.
IsSynchronized (inherited from ArrayAdapter) | Gets a value indicating whether or not access to the collection is synchronized (thread-safe).
Item | Overloaded. Gets or sets the XMLElement at the specified index.
SyncRoot (inherited from ArrayAdapter) | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.xml namespace.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


Item Property

Borland StarTeam SDK for .NET

XMLElementCollection.Item Property

Gets or sets the XMLElement at the specified index.

Overload List

Gets or sets the XMLElement at the specified index.

public XMLElement this[Int32] {get; set;}

Gets the XMLElement with the given name.

public XMLElement this[String] {get;}

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


Item Property (Int32)

Borland StarTeam SDK for .NET

XMLElementCollection.Item Property (Int32)

Gets or sets the XMLElement at the specified index.

public XMLElement this[
Int32 index
] {get; set;}

Parameters

index
The zero-based index of the XMLElement to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace | XMLElementCollection.Item Overload List


Item Property (String)

Borland StarTeam SDK for .NET

XMLElementCollection.Item Property (String)

Gets the XMLElement with the given name.

public XMLElement this[
String name
] {get;}

Parameters

name
The name of the XMLElement to get.

Property Value

The XMLElement with the given name, or null if there is no XMLElement with that name in this XMLElementCollection. Comparison is case sensitive.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace | XMLElementCollection.Item Overload List | FindByName


XMLElementCollection Methods

The methods of the XMLElementCollection class are listed below. For a complete list of XMLElementCollection class members, see the XMLElementCollection Members topic.

Public Static Methods

Wrap Creates a XMLElementCollection to represent the given array of XMLElement (from the com.borland.starteam.xml namespace).

Public Instance Methods

Add | Adds a XMLElement to end of the collection.
Append | Overloaded. Appends the XMLElements of the given XMLElementCollection to the end of this XMLElementCollection.
Clear (inherited from ArrayAdapter) | Removes all items from the collection.
Contains | Determines whether or not the collection contains a specific XMLElement.
CopyTo | Copies all of the XMLElements in the XMLElementCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Finds the XMLElement with the given name.
GetEnumerator (inherited from ArrayAdapter) | Gets an enumerator that can iterate through members of the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Determines the index of a specific XMLElement in the collection.
Insert | Inserts a XMLElement into the collection at the specified position.
Remove | Removes the first occurrence of a specific XMLElement from the collection.
RemoveAt (inherited from ArrayAdapter) | Removes the item at the specified index from the collection.
Reverse | Reverses the order of the XMLElements in this XMLElementCollection.
Sort | Sorts the XMLElements in this XMLElementCollection, using the given comparer.
SortByName | Sorts the XMLElements in this XMLElementCollection by name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.xml namespace.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.Add Method

Adds a XMLElement to end of the collection.

public int Add(
XMLElement value
);

Parameters

value
The XMLElement to add to the collection.

Return Value

The position into which the new XMLElement was inserted.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


Append Method

Borland StarTeam SDK for .NET

XMLElementCollection.Append Method

Appends the XMLElements of the given array to the end of this XMLElementCollection.

Overload List

Appends the XMLElements of the given array to the end of this XMLElementCollection.

public XMLElementCollection Append(XMLElement[]);

Appends the XMLElements of the given XMLElementCollection to the end of this XMLElementCollection.

public XMLElementCollection Append(XMLElementCollection);

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.Append Method (XMLElement[])

Appends the XMLElements of the given array to the end of this XMLElementCollection.

public XMLElementCollection Append(
XMLElement[] array
);

Parameters

array
The array whose XMLElements are to be appended to this XMLElementCollection.

Return Value

This XMLElementCollection, modified to include the new XMLElements.

Remarks

The XMLElementCollection is modified to include the new members. The individual XMLElement objects are shared, not copied.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace | XMLElementCollection.Append Overload List


XMLElementCollection.Append Method (XMLElementCollection)

Appends the XMLElements of the given XMLElementCollection to the end of this XMLElementCollection.

public XMLElementCollection Append(
XMLElementCollection collection
);

Parameters

collection
The XMLElementCollection whose XMLElements are to be appended to this XMLElementCollection.

Return Value

This XMLElementCollection, modified to include the new XMLElements.

Remarks

The XMLElementCollection is modified to include the new members. The individual XMLElement objects are shared, not copied.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace | XMLElementCollection.Append Overload List


XMLElementCollection.IWrapper.Unwrap Method

Unwraps this object, translating it to the com.borland.starteam.xml namespace.

object IWrapper.Unwrap();

Return Value

The underlying com.borland.starteam.xml.XMLElement[].

Implements

IWrapper.Unwrap

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.Contains Method

Determines whether or not the collection contains a specific XMLElement.

public bool Contains(
XMLElement value
);

Parameters

value
The XMLElement to locate in the collection.

Return Value

true if the XMLElement is found in the collection; otherwise, false.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.CopyTo Method

Copies all of the XMLElements in the XMLElementCollection to a compatible one-dimensional Array, starting at the specified index of the target array.

public void CopyTo(
XMLElement[] array,
Int32 index
);

Parameters

array
The one-dimensional Array that is the destination of the XMLElements copied from the XMLElementCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of XMLElements in the source XMLElementCollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source XMLElementCollection cannot be cast automatically to the type of the destination array.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.FindByName Method

Finds the XMLElement with the given name.

public XMLElement FindByName(
String name,
Boolean bIgnoreCase
);

Parameters

name
The name of the XMLElement to find.
bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

The XMLElement with the given name, or null if there is no XMLElement with that name in this XMLElementCollection.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.IndexOf Method

Determines the index of a specific XMLElement in the collection.

public int IndexOf(
XMLElement value
);

Parameters

value
The XMLElement to locate in the collection.

Return Value

The zero-based index of value, if found in the collection; otherwise, -1.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.Insert Method

Inserts a XMLElement into the collection at the specified position.

public void Insert(
Int32 index,
XMLElement value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The XMLElement to insert into the collection.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the collection.
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.Remove Method

Removes the first occurrence of a specific XMLElement from the collection.

public void Remove(
XMLElement value
);

Parameters

value
The XMLElement to remove from the collection.

Exceptions

Exception Type | Condition
NotSupportedException | The collection is read-only. -or- The collection has a fixed size.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.Reverse Method

Reverses the order of the XMLElements in this XMLElementCollection.

new public XMLElementCollection Reverse();

Return Value

This XMLElementCollection, modified such that the XMLElements are reversed.

Remarks

The XMLElementCollection is modified in place.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.Sort Method

Sorts the XMLElements in this XMLElementCollection, using the given comparer.

new public XMLElementCollection Sort(
IComparer comparer
);

Parameters

comparer
The IComparer used to determine the sort order of two XMLElements.

Return Value

This XMLElementCollection, modified such that the XMLElements are sorted.

Remarks

The XMLElementCollection is modified in place.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.SortByName Method

Sorts the XMLElements in this XMLElementCollection by name.

public XMLElementCollection SortByName(
Boolean bIgnoreCase
);

Parameters

bIgnoreCase
false for case-sensitive comparison; true for case insensitive comparison.

Return Value

This XMLElementCollection, modified such that the XMLElements are sorted by name.

Remarks

The XMLElementCollection is modified in place.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection.Wrap Method

Creates a XMLElementCollection to represent the given array of XMLElement (from the com.borland.starteam.xml namespace).

public static XMLElementCollection Wrap(
XMLElement[] impl
);

Parameters

impl
The array to be wrapped.

Return Value

A new XMLElementCollection, or null if impl is null.

Remarks

Most applications will not need to call Wrap directly. However, Core/Edge applications (for example, with business logic implemented in J# and user interface implemented in C#) may use Wrap to explicitly convert a XMLElement[] from the com.borland.starteam.xml namespace to the Borland.StarTeam.Xml namespace.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection Type Conversions

The type conversions of the XMLElementCollection class are listed below. For a complete list of XMLElementCollection class members, see the XMLElementCollection Members topic.

Public Static Type Conversions

Implicit XMLElementCollection to XMLElement[] Conversion | Converts a XMLElementCollection to an array of XMLElements.
Implicit XMLElementCollection to XMLElement[] Conversion | Converts a XMLElementCollection from the Borland.StarTeam.Xml namespace to a XMLElement[] in the com.borland.starteam.xml namespace.

Explicit Interface Implementations

ICollection.CopyTo (inherited from ArrayAdapter) | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
IList.Add (inherited from ArrayAdapter) | Adds an item to end of the collection.
IList.Contains (inherited from ArrayAdapter) | Determines whether or not the collection contains a specific value.
IList.IndexOf (inherited from ArrayAdapter) | Determines the index of a specific item in the collection.
IList.Insert (inherited from ArrayAdapter) | Inserts an item into the collection at the specified position.
IList.Remove (inherited from ArrayAdapter) | Removes the first occurrence of the specific object from the collection.
IWrapper.Unwrap | Unwraps this object, translating it to the com.borland.starteam.xml namespace.

See Also

XMLElementCollection Class | XMLElementCollection Members | Borland.StarTeam.Xml Namespace


XMLElementCollection Implicit XMLElementCollection to XMLElement[] Conversion

Converts a XMLElementCollection to an array of XMLElements.

public static implicit operator XMLElement[](
XMLElementCollection arg
);

Remarks

This conversion requires the allocation of a new array. Furthermore, in many cases, a new XMLElement wrapper object might be allocated for each member of the collection.

For applications that do not require an array, you should consider alternative approaches. For example, to iterate over the members of the collection, use the standard IEnumerable interface. This does not require allocation of a new array object. In addition, only one XMLElement wrapper object is allocated at a time. Thus, this approach may be more memory efficient, particularly for large collections.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLElementCollection Implicit XMLElementCollection to XMLElement[] Conversion

Converts a XMLElementCollection from the Borland.StarTeam.Xml namespace to a XMLElement[] in the com.borland.starteam.xml namespace.

public static implicit operator XMLElement[](
XMLElementCollection arg
);

Remarks

Useful when passing objects from the Borland.StarTeam.Xml namespace to methods in the com.borland.starteam.xml namespace.

This is normally a trivial conversion implemented by accessing a member variable. However, XMLElementCollection is a writable collection. If the collection has been modified (for example, via Add or Remove), then the conversion may require the allocation of a new array object.

See Also

XMLElementCollection Class | Borland.StarTeam.Xml Namespace


XMLException Class

For a list of all members of this type, see XMLException Members.

System.Object
Exception
XMLException
XMLParseException

public class XMLException : Exception, IWrapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Xml

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

XMLException Members | Borland.StarTeam.Xml Namespace


XMLException Members

XMLException overview

Public Static Methods

Wrap Dynamically wraps com.borland.starteam.xml.XMLException.

Public Static Type Conversions

Implicit XMLException to XMLException Conversion Implicitly convert XMLException to com.borland.starteam.xml.XMLException.

Public Instance Constructors

XMLException Constructor Construct XMLException from com.borland.starteam.xml.XMLException.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Exception |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.borland.starteam.xml.XMLException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.borland.starteam.xml.XMLException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.borland.starteam.xml.XMLException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLException Class | Borland.StarTeam.Xml Namespace


XMLException Constructor

Construct XMLException from com.borland.starteam.xml.XMLException.

public XMLException(
XMLException impl
);

Parameters

impl
The com.borland.starteam.xml.XMLException to be wrapped.

See Also

XMLException Class | Borland.StarTeam.Xml Namespace


XMLException Properties

The properties of the XMLException class are listed below. For a complete list of XMLException class members, see the XMLException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Exception |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLException Class | Borland.StarTeam.Xml Namespace


Exception Property

Borland StarTeam SDK for .NET

XMLException.Exception Property

public virtual Exception Exception {get;}

See Also

XMLException Class | Borland.StarTeam.Xml Namespace | XMLException.Exception Overload List


XMLException Methods

The methods of the XMLException class are listed below. For a complete list of XMLException class members, see the XMLException Members topic.

Public Static Methods

Wrap Dynamically wraps com.borland.starteam.xml.XMLException.

Public Instance Methods

Equals | Delegate Equals() to com.borland.starteam.xml.XMLException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.borland.starteam.xml.XMLException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.borland.starteam.xml.XMLException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLException Class | Borland.StarTeam.Xml Namespace


XMLException.IWrapper.Unwrap Method

Implementation of IWrapper.Unwrap().

object IWrapper.Unwrap();

Return Value

com.borland.starteam.xml.XMLException

Implements

IWrapper.Unwrap

See Also

XMLException Class | Borland.StarTeam.Xml Namespace


XMLException.Equals Method

Delegate Equals() to com.borland.starteam.xml.XMLException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.borland.starteam.xml.XMLException.Equals(obj).

See Also

XMLException Class | Borland.StarTeam.Xml Namespace


XMLException.GetHashCode Method

Delegate GetHashCode() to com.borland.starteam.xml.XMLException.

public override int GetHashCode();

Return Value

com.borland.starteam.xml.XMLException.GetHashCode().

See Also

XMLException Class | Borland.StarTeam.Xml Namespace


XMLException.ToString Method

Delegate ToString() to com.borland.starteam.xml.XMLException.

public override string ToString();

Return Value

com.borland.starteam.xml.XMLException.ToString()

See Also

XMLException Class | Borland.StarTeam.Xml Namespace


XMLException.Wrap Method

Dynamically wraps com.borland.starteam.xml.XMLException.

public static XMLException Wrap(
XMLException impl
);

Parameters

impl
com.borland.starteam.xml.XMLException to be wrapped.

Return Value

XMLException

See Also

XMLException Class | Borland.StarTeam.Xml Namespace


XMLException Type Conversions

The type conversions of the XMLException class are listed below. For a complete list of XMLException class members, see the XMLException Members topic.

Public Static Type Conversions

Implicit XMLException to XMLException Conversion Implicitly convert XMLException to com.borland.starteam.xml.XMLException.

Explicit Interface Implementations

IWrapper.Unwrap Implementation of IWrapper.Unwrap().

See Also

XMLException Class | XMLException Members | Borland.StarTeam.Xml Namespace


XMLException Implicit XMLException to XMLException Conversion

Implicitly convert XMLException to com.borland.starteam.xml.XMLException.

public static implicit operator XMLException(
XMLException arg
);

Parameters

arg
XMLException to convert.

Return Value

com.borland.starteam.xml.XMLException

See Also

XMLException Class | Borland.StarTeam.Xml Namespace


XMLParseException Class

For a list of all members of this type, see XMLParseException Members.

System.Object
Exception
XMLException
XMLParseException

public class XMLParseException : XMLException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Borland.StarTeam.Xml

Assembly: Borland.StarTeam (in Borland.StarTeam.dll)

See Also

XMLParseException Members | Borland.StarTeam.Xml Namespace


XMLParseException Members

XMLParseException overview

Public Static Methods

Wrap Dynamically wraps com.borland.starteam.xml.XMLParseException.

Public Static Type Conversions

Implicit XMLParseException to XMLParseException Conversion Implicitly convert XMLParseException to com.borland.starteam.xml.XMLParseException.

Public Instance Constructors

XMLParseException Constructor Construct XMLParseException from com.borland.starteam.xml.XMLParseException.

Public Instance Properties

ColumnNumber |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Exception (inherited from XMLException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
LineNumber |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from XMLException) | Delegate Equals() to com.borland.starteam.xml.XMLException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from XMLException) | Delegate GetHashCode() to com.borland.starteam.xml.XMLException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from XMLException) | Delegate ToString() to com.borland.starteam.xml.XMLException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from XMLException) Implementation of IWrapper.Unwrap().

See Also

XMLParseException Class | Borland.StarTeam.Xml Namespace


XMLParseException Constructor

Construct XMLParseException from com.borland.starteam.xml.XMLParseException.

public XMLParseException(
XMLParseException impl
);

Parameters

impl
The com.borland.starteam.xml.XMLParseException to be wrapped.

See Also

XMLParseException Class | Borland.StarTeam.Xml Namespace


XMLParseException Properties

The properties of the XMLParseException class are listed below. For a complete list of XMLParseException class members, see the XMLParseException Members topic.

Public Instance Properties

ColumnNumber |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Exception (inherited from XMLException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
LineNumber |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from XMLException) Implementation of IWrapper.Unwrap().

See Also

XMLParseException Class | Borland.StarTeam.Xml Namespace


ColumnNumber Property

Borland StarTeam SDK for .NET

XMLParseException.ColumnNumber Property

public virtual Int32 ColumnNumber {get;}

See Also

XMLParseException Class | Borland.StarTeam.Xml Namespace


LineNumber Property

Borland StarTeam SDK for .NET

XMLParseException.LineNumber Property

public virtual Int32 LineNumber {get;}

See Also

XMLParseException Class | Borland.StarTeam.Xml Namespace


XMLParseException Methods

The methods of the XMLParseException class are listed below. For a complete list of XMLParseException class members, see the XMLParseException Members topic.

Public Static Methods

Wrap Dynamically wraps com.borland.starteam.xml.XMLParseException.

Public Instance Methods

Equals (inherited from XMLException) | Delegate Equals() to com.borland.starteam.xml.XMLException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from XMLException) | Delegate GetHashCode() to com.borland.starteam.xml.XMLException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from XMLException) | Delegate ToString() to com.borland.starteam.xml.XMLException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from XMLException) Implementation of IWrapper.Unwrap().

See Also

XMLParseException Class | Borland.StarTeam.Xml Namespace


XMLParseException.Wrap Method

Dynamically wraps com.borland.starteam.xml.XMLParseException.

public static XMLParseException Wrap(
XMLParseException impl
);

Parameters

impl
com.borland.starteam.xml.XMLParseException to be wrapped.

Return Value

XMLParseException

See Also

XMLParseException Class | Borland.StarTeam.Xml Namespace


XMLParseException Type Conversions

The type conversions of the XMLParseException class are listed below. For a complete list of XMLParseException class members, see the XMLParseException Members topic.

Public Static Type Conversions

Implicit XMLParseException to XMLParseException Conversion Implicitly convert XMLParseException to com.borland.starteam.xml.XMLParseException.

Explicit Interface Implementations

IWrapper.Unwrap (inherited from XMLException) Implementation of IWrapper.Unwrap().

See Also

XMLParseException Class | XMLParseException Members | Borland.StarTeam.Xml Namespace


XMLParseException Implicit XMLParseException to XMLParseException Conversion

Implicitly convert XMLParseException to com.borland.starteam.xml.XMLParseException.

public static implicit operator XMLParseException(
XMLParseException arg
);

Parameters

arg
XMLParseException to convert.

Return Value

com.borland.starteam.xml.XMLParseException

See Also

XMLParseException Class | Borland.StarTeam.Xml Namespace


com.borland.starteam.util

Borland StarTeam SDK for .NET

com.borland.starteam.util Namespace

Namespace hierarchy

Classes

Class | Description
Encoding |


Encoding Class

For a list of all members of this type, see Encoding Members.

System.Object
Encoding

public class Encoding

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.borland.starteam.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Encoding Members | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding Members

Encoding overview

Public Static Fields

CODEPAGE_UNKNOWN
ID_UNKNOWN
ISO_8859_1
STARTEAM_PROPERTY
US_ASCII
UTF_16
UTF_16BE
UTF_16LE
UTF_8

Public Static Methods

forCodePage
forID
forName
getAllKnownEncodings
getDefaultPlatformEncoding
getDefaultStarTeamEncoding
getReadableEncodings
getSupportedEncodings
getWritableEncodings
setDefaultStarTeamEncoding

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAllNames |
getCodePage |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getMimeName |
getName |
getPlatformName |
getPlatformNameForReading |
getPlatformNameForWriting |
getRegisteredID |
getRegisteredName |
GetType (inherited from Object) | Gets the Type of the current instance.
isNamed |
isReadingSupported |
isSupported |
isWritingSupported |
MemberwiseClone |
ToString |

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding Fields

The fields of the Encoding class are listed below. For a complete list of Encoding class members, see the Encoding Members topic.

Public Static Fields

CODEPAGE_UNKNOWN
ID_UNKNOWN
ISO_8859_1
STARTEAM_PROPERTY
US_ASCII
UTF_16
UTF_16BE
UTF_16LE
UTF_8

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.CODEPAGE_UNKNOWN Field

public const Int32 CODEPAGE_UNKNOWN = -1;

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.ID_UNKNOWN Field

public const Int32 ID_UNKNOWN = -1;

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.ISO_8859_1 Field

public static readonly Encoding ISO_8859_1;

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.STARTEAM_PROPERTY Field

public const String STARTEAM_PROPERTY = "starteam.file.encoding";

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.US_ASCII Field

public static readonly Encoding US_ASCII;

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.UTF_16 Field

public static readonly Encoding UTF_16;

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.UTF_16BE Field

public static readonly Encoding UTF_16BE;

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.UTF_16LE Field

public static readonly Encoding UTF_16LE;

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.UTF_8 Field

public static readonly Encoding UTF_8;

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding Methods

The methods of the Encoding class are listed below. For a complete list of Encoding class members, see the Encoding Members topic.

Public Static Methods

forCodePage
forID
forName
getAllKnownEncodings
getDefaultPlatformEncoding
getDefaultStarTeamEncoding
getReadableEncodings
getSupportedEncodings
getWritableEncodings
setDefaultStarTeamEncoding

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAllNames |
getCodePage |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getMimeName |
getName |
getPlatformName |
getPlatformNameForReading |
getPlatformNameForWriting |
getRegisteredID |
getRegisteredName |
GetType (inherited from Object) | Gets the Type of the current instance.
isNamed |
isReadingSupported |
isSupported |
isWritingSupported |
MemberwiseClone |
ToString |

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.forCodePage Method

public static Encoding forCodePage(
Int32 cp
);

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.forID Method

public static Encoding forID(
Int32 id
);

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.forName Method

public static Encoding forName(
String name
);

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getAllKnownEncodings Method

public static Encoding[] getAllKnownEncodings();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getAllNames Method

public virtual string[] getAllNames();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getCodePage Method

public virtual int getCodePage();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getDefaultPlatformEncoding Method

public static Encoding getDefaultPlatformEncoding();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getDefaultStarTeamEncoding Method

public static Encoding getDefaultStarTeamEncoding();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getMimeName Method

public virtual string getMimeName();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getName Method

public virtual string getName();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getPlatformName Method

public virtual string getPlatformName();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getPlatformNameForReading Method

public virtual string getPlatformNameForReading();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getPlatformNameForWriting Method

public virtual string getPlatformNameForWriting();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getReadableEncodings Method

public static Encoding[] getReadableEncodings();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getRegisteredID Method

public virtual int getRegisteredID();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getRegisteredName Method

public virtual string getRegisteredName();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getSupportedEncodings Method

public static Encoding[] getSupportedEncodings();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.getWritableEncodings Method

public static Encoding[] getWritableEncodings();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.isNamed Method

public virtual bool isNamed(
String name
);

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.isReadingSupported Method

public virtual bool isReadingSupported();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.isSupported Method

public virtual bool isSupported();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.isWritingSupported Method

public virtual bool isWritingSupported();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.setDefaultStarTeamEncoding Method

public static void setDefaultStarTeamEncoding(
Encoding e
);

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Encoding.ToString Method

public override string ToString();

See Also

Encoding Class | com.borland.starteam.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


com.borland.starteam.xml

Borland StarTeam SDK for .NET

com.borland.starteam.xml Namespace

Namespace hierarchy

Classes

Class | Description
XMLAttribute |
XMLDocument |
XMLElement |
XMLException |
XMLParseException |


XMLAttribute Class

For a list of all members of this type, see XMLAttribute Members.

System.Object
XMLAttribute

public class XMLAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.borland.starteam.xml

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

XMLAttribute Members | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLAttribute Members

XMLAttribute overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName |
getParent |
getQualifiedName |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue |
MemberwiseClone |
ToString |

See Also

XMLAttribute Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLAttribute Methods

The methods of the XMLAttribute class are listed below. For a complete list of XMLAttribute class members, see the XMLAttribute Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName |
getParent |
getQualifiedName |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue |
MemberwiseClone |
ToString |

See Also

XMLAttribute Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLAttribute.getName Method

public virtual string getName();

See Also

XMLAttribute Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLAttribute.getParent Method

public virtual XMLElement getParent();

See Also

XMLAttribute Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLAttribute.getQualifiedName Method

public virtual string getQualifiedName();

See Also

XMLAttribute Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLAttribute.getValue Method

public virtual string getValue();

See Also

XMLAttribute Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLAttribute.MemberwiseClone Method

public override object MemberwiseClone();

See Also

XMLAttribute Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLAttribute.ToString Method

public override string ToString();

See Also

XMLAttribute Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLDocument Class

For a list of all members of this type, see XMLDocument Members.

System.Object
XMLDocument

public class XMLDocument

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.borland.starteam.xml

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

XMLDocument Members | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLDocument Members

XMLDocument overview

Public Static Methods

build Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getRootElement |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |
write | Overloaded.

See Also

XMLDocument Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLDocument Methods

The methods of the XMLDocument class are listed below. For a complete list of XMLDocument class members, see the XMLDocument Members topic.

Public Static Methods

build Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getRootElement |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |
write | Overloaded.

See Also

XMLDocument Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


build Method

Borland StarTeam SDK for .NET

XMLDocument.build Method

Overload List

public static XMLDocument build(File);

public static XMLDocument build(InputStream);

public static XMLDocument build(SByte[]);

See Also

XMLDocument Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLDocument.build Method (File)

public static XMLDocument build(
File source
);

See Also

XMLDocument Class | com.borland.starteam.xml Namespace | XMLDocument.build Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLDocument.build Method (InputStream)

public static XMLDocument build(
InputStream source
);

See Also

XMLDocument Class | com.borland.starteam.xml Namespace | XMLDocument.build Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLDocument.build Method (SByte[])

public static XMLDocument build(
SByte[] source
);

See Also

XMLDocument Class | com.borland.starteam.xml Namespace | XMLDocument.build Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLDocument.getRootElement Method

public virtual XMLElement getRootElement();

See Also

XMLDocument Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLDocument.MemberwiseClone Method

public override object MemberwiseClone();

See Also

XMLDocument Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLDocument.ToString Method

public override string ToString();

See Also

XMLDocument Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


write Method

Borland StarTeam SDK for .NET

XMLDocument.write Method

Overload List

public virtual void write(File);

public virtual void write(OutputStream);

See Also

XMLDocument Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLDocument.write Method (File)

public virtual void write(
File out
);

See Also

XMLDocument Class | com.borland.starteam.xml Namespace | XMLDocument.write Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLDocument.write Method (OutputStream)

public virtual void write(
OutputStream out
);

See Also

XMLDocument Class | com.borland.starteam.xml Namespace | XMLDocument.write Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement Class

For a list of all members of this type, see XMLElement Members.

System.Object
XMLElement

public class XMLElement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.borland.starteam.xml

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

XMLElement Members | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement Members

XMLElement overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAttributes |
getAttributeValue |
getChild |
getChildren | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName |
getQualifiedName |
getText |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

XMLElement Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement Methods

The methods of the XMLElement class are listed below. For a complete list of XMLElement class members, see the XMLElement Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAttributes |
getAttributeValue |
getChild |
getChildren | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName |
getQualifiedName |
getText |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

XMLElement Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement.getAttributes Method

public virtual XMLAttribute[] getAttributes();

See Also

XMLElement Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement.getAttributeValue Method

public virtual string getAttributeValue(
String name
);

See Also

XMLElement Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement.getChild Method

public virtual XMLElement getChild(
String name
);

See Also

XMLElement Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


getChildren Method

Borland StarTeam SDK for .NET

XMLElement.getChildren Method

Overload List

public virtual XMLElement[] getChildren();

public virtual XMLElement[] getChildren(String);

See Also

XMLElement Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement.getChildren Method ()

public virtual XMLElement[] getChildren();

See Also

XMLElement Class | com.borland.starteam.xml Namespace | XMLElement.getChildren Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement.getChildren Method (String)

public virtual XMLElement[] getChildren(
String name
);

See Also

XMLElement Class | com.borland.starteam.xml Namespace | XMLElement.getChildren Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement.getName Method

public virtual string getName();

See Also

XMLElement Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement.getQualifiedName Method

public virtual string getQualifiedName();

See Also

XMLElement Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement.getText Method

public virtual string getText();

See Also

XMLElement Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement.MemberwiseClone Method

public override object MemberwiseClone();

See Also

XMLElement Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLElement.ToString Method

public override string ToString();

See Also

XMLElement Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLException Class

For a list of all members of this type, see XMLException Members.

System.Object
Exception
Throwable
Exception
XMLException
XMLParseException

public class XMLException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.borland.starteam.xml

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

XMLException Members | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLException Members

XMLException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getException |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

XMLException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLException Methods

The methods of the XMLException class are listed below. For a complete list of XMLException class members, see the XMLException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getException |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

XMLException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLException.getException Method

public virtual Throwable getException();

See Also

XMLException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLException.getMessage Method

public override string getMessage();

See Also

XMLException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

XMLException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLException.unwrap Method

public virtual XMLException unwrap();

See Also

XMLException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLException.wrap Method

public static XMLException wrap(
XMLException arg
);

See Also

XMLException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLParseException Class

For a list of all members of this type, see XMLParseException Members.

System.Object
Exception
Throwable
Exception
XMLException
XMLParseException

public class XMLParseException : XMLException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.borland.starteam.xml

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

XMLParseException Members | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLParseException Members

XMLParseException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getColumnNumber |
getException (inherited from XMLException) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLineNumber |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from XMLException) |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone (inherited from XMLException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap (inherited from XMLException) |

See Also

XMLParseException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLParseException Methods

The methods of the XMLParseException class are listed below. For a complete list of XMLParseException class members, see the XMLParseException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getColumnNumber |
getException (inherited from XMLException) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLineNumber |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from XMLException) |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone (inherited from XMLException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap (inherited from XMLException) |

See Also

XMLParseException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLParseException.getColumnNumber Method

public virtual int getColumnNumber();

See Also

XMLParseException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLParseException.getLineNumber Method

public virtual int getLineNumber();

See Also

XMLParseException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLParseException.wrap Method

public static XMLParseException wrap(
XMLParseException arg
);

See Also

XMLParseException Class | com.borland.starteam.xml Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


com.starbase.diff

Borland StarTeam SDK for .NET

com.starbase.diff Namespace

Namespace hierarchy

Classes

Class | Description
BasicColumnMask |
BasicCompare |
BinaryCompare |
ConsoleWriter |
DiffException |
Edit |
EditList |
EditListWriter |
HTMLDiffWriter |
HTMLInterleavedDiffWriter |
HTMLStereoDiffWriter |
HTMLTableDiffWriter |
IntralineSequence |
LineIterator |
ParsedCharSequence |
SharedCharSequence |
StarTeamDiff |
StarTeamMerge |
StringCharSequence |

Interfaces

Interface | Description
ByteSequence |
CharSequence |
ColumnMask |
DiffCompare |
Differ |
Sequence |


BasicColumnMask Class

For a list of all members of this type, see BasicColumnMask Members.

System.Object
BasicColumnMask

public class BasicColumnMask : ColumnMask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

BasicColumnMask Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicColumnMask Members

BasicColumnMask overview

Public Instance Constructors

BasicColumnMask Constructor

Public Instance Methods

debugDump | Returns a string used for debugging and testing
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
skipBy |
ToString |

See Also

BasicColumnMask Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicColumnMask Constructor

public BasicColumnMask(
Int32 first,
Int32 last,
Boolean numeric
);

See Also

BasicColumnMask Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicColumnMask Methods

The methods of the BasicColumnMask class are listed below. For a complete list of BasicColumnMask class members, see the BasicColumnMask Members topic.

Public Instance Methods

debugDump | Returns a string used for debugging and testing
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
skipBy |
ToString |

See Also

BasicColumnMask Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicColumnMask.debugDump Method

Returns a string used for debugging and testing

public virtual string debugDump();

See Also

BasicColumnMask Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicColumnMask.MemberwiseClone Method

public override object MemberwiseClone();

See Also

BasicColumnMask Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicColumnMask.skipBy Method

public virtual int skipBy(
Int32 column,
CharSequence sequence
);

Implements

ColumnMask.skipBy

See Also

BasicColumnMask Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicColumnMask.ToString Method

public override string ToString();

See Also

BasicColumnMask Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare Class

For a list of all members of this type, see BasicCompare Members.

System.Object
BasicCompare

public class BasicCompare : DiffCompare

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

BasicCompare Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare Members

BasicCompare overview

Public Static Fields

COMPARE_EOL
DIFF_B_WS
DIFF_W_WS
IGNORE_CASE
INTERIOR_WS_EQUIV
INTERIOR_WS_IGNORE
LEADING_WS_EQUIV
LEADING_WS_IGNORE
PVCS_WS
TRAILING_WS_EQUIV
TRAILING_WS_IGNORE
VSS_WS

Public Instance Constructors

BasicCompare Overloaded. Initializes a new instance of the BasicCompare class.

Public Instance Methods

equalObjects |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
hashObject |
MemberwiseClone |
ToString |

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare Constructor

Overload List

Can be used for binary comparison. Does no case folding, white space ignore nor column masking.

public BasicCompare();

public BasicCompare(Int32,ColumnMask[]);

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare Constructor (Int32, ColumnMask[])

public BasicCompare(
Int32 flags,
ColumnMask[] columnMask
);

See Also

BasicCompare Class | com.starbase.diff Namespace | BasicCompare Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare Constructor ()

Can be used for binary comparison. Does no case folding, white space ignore nor column masking.

public BasicCompare();

See Also

BasicCompare Class | com.starbase.diff Namespace | BasicCompare Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare Fields

The fields of the BasicCompare class are listed below. For a complete list of BasicCompare class members, see the BasicCompare Members topic.

Public Static Fields

COMPARE_EOL
DIFF_B_WS
DIFF_W_WS
IGNORE_CASE
INTERIOR_WS_EQUIV
INTERIOR_WS_IGNORE
LEADING_WS_EQUIV
LEADING_WS_IGNORE
PVCS_WS
TRAILING_WS_EQUIV
TRAILING_WS_IGNORE
VSS_WS

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.COMPARE_EOL Field

public const Int32 COMPARE_EOL = 128;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.DIFF_B_WS Field

public const Int32 DIFF_B_WS = 26;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.DIFF_W_WS Field

public const Int32 DIFF_W_WS = 21;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.IGNORE_CASE Field

public const Int32 IGNORE_CASE = 256;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.INTERIOR_WS_EQUIV Field

public const Int32 INTERIOR_WS_EQUIV = 8;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.INTERIOR_WS_IGNORE Field

public const Int32 INTERIOR_WS_IGNORE = 4;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.LEADING_WS_EQUIV Field

public const Int32 LEADING_WS_EQUIV = 2;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.LEADING_WS_IGNORE Field

public const Int32 LEADING_WS_IGNORE = 1;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.PVCS_WS Field

public const Int32 PVCS_WS = 17;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.TRAILING_WS_EQUIV Field

public const Int32 TRAILING_WS_EQUIV = 32;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.TRAILING_WS_IGNORE Field

public const Int32 TRAILING_WS_IGNORE = 16;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.VSS_WS Field

public const Int32 VSS_WS = 21;

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare Methods

The methods of the BasicCompare class are listed below. For a complete list of BasicCompare class members, see the BasicCompare Members topic.

Public Instance Methods

equalObjects |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
hashObject |
MemberwiseClone |
ToString |

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.equalObjects Method

public virtual bool equalObjects(
Object src,
Object trg
);

Implements

DiffCompare.equalObjects

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.hashObject Method

public virtual int hashObject(
Object object
);

Implements

DiffCompare.hashObject

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.MemberwiseClone Method

public override object MemberwiseClone();

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BasicCompare.ToString Method

public override string ToString();

See Also

BasicCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BinaryCompare Class

For a list of all members of this type, see BinaryCompare Members.

System.Object
BinaryCompare

public class BinaryCompare : DiffCompare

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

BinaryCompare Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BinaryCompare Members

BinaryCompare overview

Public Instance Constructors

BinaryCompare Constructor Initializes a new instance of the BinaryCompare class.

Public Instance Methods

equalObjects |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
hashObject |
MemberwiseClone |
ToString |

See Also

BinaryCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BinaryCompare Constructor

Initializes a new instance of the BinaryCompare class.

public BinaryCompare();

See Also

BinaryCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BinaryCompare Methods

The methods of the BinaryCompare class are listed below. For a complete list of BinaryCompare class members, see the BinaryCompare Members topic.

Public Instance Methods

equalObjects |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
hashObject |
MemberwiseClone |
ToString |

See Also

BinaryCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BinaryCompare.equalObjects Method

public virtual bool equalObjects(
Object src,
Object trg
);

Implements

DiffCompare.equalObjects

See Also

BinaryCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BinaryCompare.hashObject Method

public virtual int hashObject(
Object object
);

Implements

DiffCompare.hashObject

See Also

BinaryCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BinaryCompare.MemberwiseClone Method

public override object MemberwiseClone();

See Also

BinaryCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BinaryCompare.ToString Method

public override string ToString();

See Also

BinaryCompare Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ByteSequence Interface

For a list of all members of this type, see ByteSequence Members.

public interface ByteSequence

Types that implement ByteSequence

Type | Description
ByteSequenceAdapter |

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ByteSequence Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ByteSequence Members

ByteSequence overview

Public Instance Methods

byteAt |
length | Returns the length of the sequence.

See Also

ByteSequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ByteSequence Methods

The methods of the ByteSequence interface are listed below. For a complete list of ByteSequence interface members, see the ByteSequence Members topic.

Public Instance Methods

byteAt |
length | Returns the length of the sequence.

See Also

ByteSequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ByteSequence.byteAt Method

sbyte byteAt(
Int32 n
);

See Also

ByteSequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ByteSequence.length Method

Returns the length of the sequence.

int length();

See Also

ByteSequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharSequence Interface

For a list of all members of this type, see CharSequence Members.

public interface CharSequence

Types that implement CharSequence

Type | Description
CharSequenceAdapter |
SharedCharSequence |
StringCharSequence |

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CharSequence Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharSequence Members

CharSequence overview

Public Instance Methods

charAt |
length | Returns the length of the sequence.

See Also

CharSequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharSequence Methods

The methods of the CharSequence interface are listed below. For a complete list of CharSequence interface members, see the CharSequence Members topic.

Public Instance Methods

charAt |
length | Returns the length of the sequence.

See Also

CharSequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharSequence.charAt Method

char charAt(
Int32 n
);

See Also

CharSequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharSequence.length Method

Returns the length of the sequence.

int length();

See Also

CharSequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnMask Interface

For a list of all members of this type, see ColumnMask Members.

public interface ColumnMask

Types that implement ColumnMask

Type | Description
ColumnMaskAdapter |
BasicColumnMask |

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ColumnMask Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnMask Members

ColumnMask overview

Public Instance Methods

skipBy

See Also

ColumnMask Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnMask Methods

The methods of the ColumnMask interface are listed below. For a complete list of ColumnMask interface members, see the ColumnMask Members topic.

Public Instance Methods

skipBy

See Also

ColumnMask Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnMask.skipBy Method

int skipBy(
Int32 column,
CharSequence sequence
);

See Also

ColumnMask Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter Class

For a list of all members of this type, see ConsoleWriter Members.

System.Object
EditListWriter
ConsoleWriter

public class ConsoleWriter : EditListWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ConsoleWriter Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter Members

ConsoleWriter overview

Public Instance Constructors

ConsoleWriter Overloaded. Initializes a new instance of the ConsoleWriter class.

Public Instance Methods

deleteLines |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
insertLines |
MemberwiseClone (inherited from EditListWriter) |
replaceLines |
start |
ToString (inherited from EditListWriter) |
unchangedLines |
write (inherited from EditListWriter) |

See Also

ConsoleWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter Constructor

NOTE: This constructor is now obsolete.

Overload List

Obsolete.

public ConsoleWriter(BufferedWriter,Boolean,Int32,Int32,ParsedCharSequence,ParsedCharSequence);

public ConsoleWriter(Writer,Boolean,Int32,Int32,ParsedCharSequence,ParsedCharSequence);

See Also

ConsoleWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter Constructor (BufferedWriter, Boolean, Int32, Int32, ParsedCharSequence, ParsedCharSequence)

NOTE: This constructor is now obsolete.

public ConsoleWriter(
BufferedWriter output,
Boolean lineNumbers,
Int32 tabs,
Int32 contextLines,
ParsedCharSequence source,
ParsedCharSequence target
);

See Also

ConsoleWriter Class | com.starbase.diff Namespace | ConsoleWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter Constructor (Writer, Boolean, Int32, Int32, ParsedCharSequence, ParsedCharSequence)

public ConsoleWriter(
Writer output,
Boolean lineNumbers,
Int32 tabs,
Int32 contextLines,
ParsedCharSequence source,
ParsedCharSequence target
);

See Also

ConsoleWriter Class | com.starbase.diff Namespace | ConsoleWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter Methods

The methods of the ConsoleWriter class are listed below. For a complete list of ConsoleWriter class members, see the ConsoleWriter Members topic.

Public Instance Methods

deleteLines |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
insertLines |
MemberwiseClone (inherited from EditListWriter) |
replaceLines |
start |
ToString (inherited from EditListWriter) |
unchangedLines |
write (inherited from EditListWriter) |

See Also

ConsoleWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter.deleteLines Method

public override void deleteLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

ConsoleWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter.finish Method

public override void finish();

See Also

ConsoleWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter.insertLines Method

public override void insertLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

ConsoleWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter.replaceLines Method

public override void replaceLines(
Int32 sourcePos,
Int32 sourceLen,
Int32 targetPos,
Int32 targetLen
);

See Also

ConsoleWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter.start Method

public override void start();

See Also

ConsoleWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConsoleWriter.unchangedLines Method

public override void unchangedLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

ConsoleWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffCompare Interface

For a list of all members of this type, see DiffCompare Members.

public interface DiffCompare

Types that implement DiffCompare

Type | Description
DiffCompareAdapter |
BasicCompare |
BinaryCompare |

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

DiffCompare Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffCompare Members

DiffCompare overview

Public Instance Methods

equalObjects
hashObject

See Also

DiffCompare Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffCompare Methods

The methods of the DiffCompare interface are listed below. For a complete list of DiffCompare interface members, see the DiffCompare Members topic.

Public Instance Methods

equalObjects
hashObject

See Also

DiffCompare Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffCompare.equalObjects Method

bool equalObjects(
Object source,
Object target
);

See Also

DiffCompare Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffCompare.hashObject Method

int hashObject(
Object object
);

See Also

DiffCompare Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Differ Interface

For a list of all members of this type, see Differ Members.

public interface Differ

Types that implement Differ

Type | Description
DifferAdapter |
StarTeamDiff |

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Differ Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Differ Members

Differ overview

Public Instance Methods

diff

See Also

Differ Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Differ Methods

The methods of the Differ interface are listed below. For a complete list of Differ interface members, see the Differ Members topic.

Public Instance Methods

diff

See Also

Differ Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Differ.diff Method

EditList diff(
Sequence source,
Sequence target,
DiffCompare compare
);

See Also

Differ Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffException Class

For a list of all members of this type, see DiffException Members.

System.Object
Exception
Throwable
Exception
DiffException

public class DiffException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

DiffException Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffException Members

DiffException overview

Public Static Methods

wrap

Public Instance Constructors

DiffException Constructor

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from java.lang.Throwable) |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

DiffException Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffException Constructor

public DiffException(
String msg
);

See Also

DiffException Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffException Methods

The methods of the DiffException class are listed below. For a complete list of DiffException class members, see the DiffException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from java.lang.Throwable) |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

DiffException Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

DiffException Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffException.unwrap Method

public virtual DiffException unwrap();

See Also

DiffException Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DiffException.wrap Method

public static DiffException wrap(
DiffException arg
);

See Also

DiffException Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit Class

For a list of all members of this type, see Edit Members.

System.Object
Edit

public class Edit

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Edit Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit Members

Edit overview

Public Static Fields

DELETE
INSERT
REPLACE
UNCHANGED

Public Instance Constructors

Edit Constructor

Public Instance Methods

endSource |
endTarget |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAction |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getNumSourceChanges |
getNumTargetChanges |
getSourceChanges |
getTargetChanges |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
startSource |
startTarget |
ToString |

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit Constructor

public Edit(
Int32 eAction,
Int32 nStartSource,
Int32 nEndSource,
Int32 nStartTarget,
Int32 nEndTarget
);

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit Fields

The fields of the Edit class are listed below. For a complete list of Edit class members, see the Edit Members topic.

Public Static Fields

DELETE
INSERT
REPLACE
UNCHANGED

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.DELETE Field

public const Int32 DELETE = 2;

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.INSERT Field

public const Int32 INSERT = 1;

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.REPLACE Field

public const Int32 REPLACE = 3;

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.UNCHANGED Field

public const Int32 UNCHANGED = 0;

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit Methods

The methods of the Edit class are listed below. For a complete list of Edit class members, see the Edit Members topic.

Public Instance Methods

endSource |
endTarget |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAction |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getNumSourceChanges |
getNumTargetChanges |
getSourceChanges |
getTargetChanges |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
startSource |
startTarget |
ToString |

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.endSource Method

public virtual int endSource();

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.endTarget Method

public virtual int endTarget();

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.getAction Method

public virtual int getAction();

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.getNumSourceChanges Method

public virtual int getNumSourceChanges();

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.getNumTargetChanges Method

public virtual int getNumTargetChanges();

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.getSourceChanges Method

public virtual int getSourceChanges();

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.getTargetChanges Method

public virtual int getTargetChanges();

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.startSource Method

public virtual int startSource();

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.startTarget Method

public virtual int startTarget();

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Edit.ToString Method

public override string ToString();

See Also

Edit Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditList Class

For a list of all members of this type, see EditList Members.

System.Object
EditList

public class EditList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

EditList Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditList Members

EditList overview

Public Instance Constructors

EditList Constructor Initializes a new instance of the EditList class.

Public Instance Methods

addChange |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getChanges |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
length |
MemberwiseClone |
ToString |

See Also

EditList Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditList Constructor

Initializes a new instance of the EditList class.

public EditList();

See Also

EditList Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditList Methods

The methods of the EditList class are listed below. For a complete list of EditList class members, see the EditList Members topic.

Public Instance Methods

addChange |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getChanges |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
length |
MemberwiseClone |
ToString |

See Also

EditList Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditList.addChange Method

public virtual void addChange(
Edit change
);

See Also

EditList Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditList.getChanges Method

public virtual Edit[] getChanges();

See Also

EditList Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditList.length Method

public virtual int length();

See Also

EditList Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditList.MemberwiseClone Method

public override object MemberwiseClone();

See Also

EditList Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditList.ToString Method

public override string ToString();

See Also

EditList Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter Class

For a list of all members of this type, see EditListWriter Members.

System.Object
EditListWriter
ConsoleWriter
HTMLDiffWriter

public class EditListWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

EditListWriter Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter Members

EditListWriter overview

Public Instance Constructors

EditListWriter Constructor Initializes a new instance of the EditListWriter class.

Public Instance Methods

deleteLines |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
insertLines |
MemberwiseClone |
replaceLines |
start | Called to tell writer where it can get the source for the lines.
ToString |
unchangedLines |
write |

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter Constructor

Initializes a new instance of the EditListWriter class.

public EditListWriter();

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter Methods

The methods of the EditListWriter class are listed below. For a complete list of EditListWriter class members, see the EditListWriter Members topic.

Public Instance Methods

deleteLines |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
insertLines |
MemberwiseClone |
replaceLines |
start | Called to tell writer where it can get the source for the lines.
ToString |
unchangedLines |
write |

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter.deleteLines Method

public abstract void deleteLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter.finish Method

public abstract void finish();

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter.insertLines Method

public abstract void insertLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter.replaceLines Method

public abstract void replaceLines(
Int32 sourceStart,
Int32 sourceLen,
Int32 targetStart,
Int32 targetLen
);

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter.start Method

Called to tell writer where it can get the source for the lines.

public abstract void start();

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter.ToString Method

public override string ToString();

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter.unchangedLines Method

public abstract void unchangedLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EditListWriter.write Method

public virtual void write(
EditList list,
Int32 sourceLen,
Int32 destLen
);

See Also

EditListWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter Class

For a list of all members of this type, see HTMLDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter

public class HTMLDiffWriter : EditListWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

HTMLDiffWriter Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter Members

HTMLDiffWriter overview

Public Static Fields

DEFAULT_SPACES_PER_TAB

Public Static Methods

simpleDiff

Public Instance Constructors

HTMLDiffWriter Overloaded. Initializes a new instance of the HTMLDiffWriter class.

Public Instance Methods

deleteLines |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish |
getAddedSymbolHTML | Gets the HTML text used to draw the symbol that indicates an "added" line.
getApplicationFooterHTML | Gets application-specific HTML text to be drawn at the bottom of the output HTML page.
getApplicationHeaderHTML | Gets application-specific HTML text to be drawn at the top of the output HTML page.
getCRHTML | Returns the string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
getDeletedSymbolHTML | Gets the HTML text used to draw the symbol that indicates a "deleted" line.
getEmbedDefaultStyles | Determines whether or not a default style sheet is embedded in the HTML document.
getGotoBlankHTML | Gets the HTML text used to draw whitespace the same width as a naviation control.
getGotoBottomHTML | Gets the HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
getGotoFirstDiffHTML | Gets the HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
getGotoLastDiffHTML | Gets the HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
getGotoNextDiffHTML | Gets the HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
getGotoPrevDiffHTML | Gets the HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
getGotoTopHTML | Gets the HTML text used to draw the navigation symbol that jumps to the top of the output page.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getInlineDeleteMarkHTML | Gets the HTML text used to mark an in-line deletion point within a source line.
getInlineInsertMarkHTML | Gets the HTML text used to mark an in-line insertion point within a source line.
getLFHTML | Returns the string representation of the line-feed character in the HTML document. The default value is "[LF]".
getNavigateOnEveryChangedLine | Indicates whether or not navigation symbols will be drawn on every changed line.
getNumContextLines | Gets the maximum number of unchanged lines displayed before and after each changed line.
getPageBaseURL | Gets the base URL of the output HTML page.
getPageTitle | Gets the title of the output HTML page.
getReplacedSymbolHTML | Gets the HTML text used to draw the symbol that indicates a "replaced" line.
getShowEOLs | Indicates whether or not "replaced" lines show markup within the line.
getShowInlineDiffs | Indicates whether or not "replaced" lines show markup within the line.
getShowLineNumbers | Determines whether or not line numbers are embedded in the HTML document.
getShowUnchangedLines | Determines whether or not unchanged lines are displayed in the HTML document.
getSourceFileHTML | Gets the HTML text used to display the name of the source file on the output page.
getSourceFileURL | Gets the URL used to link to the source file from the output HTML page.
getSpacesPerTab | Gets the number of spaces per tab character.
getStyleSheetURL | The URL used to reference a linked style sheet. Ignored if getEmbedDefaultStyles() is true. The default URL used to reference an linked style sheet is "diff.css".
getTargetFileHTML | Gets the HTML text used to display the name of the target file on the output page.
getTargetFileURL | Gets the URL used to link to the target file from the output HTML page.
GetType (inherited from Object) | Gets the Type of the current instance.
getUnchangedSymbolHTML | Gets the HTML text used to draw the symbol that indicates an "unchanged" line.
insertLines |
MemberwiseClone (inherited from EditListWriter) |
replaceLines |
setAddedSymbolHTML |
setApplicationFooterHTML |
setApplicationHeaderHTML |
setCRHTML |
setDeletedSymbolHTML |
setEmbedDefaultStyles |
setGotoBlankHTML |
setGotoBottomHTML |
setGotoFirstDiffHTML |
setGotoLastDiffHTML |
setGotoNextDiffHTML |
setGotoPrevDiffHTML |
setGotoTopHTML |
setInlineDeleteMarkHTML |
setInlineInsertMarkHTML |
setLFHTML |
setNavigateOnEveryChangedLine |
setNumContextLines |
setPageBaseURL |
setPageTitle |
setReplacedSymbolHTML |
setShowEOLs |
setShowInlineDiffs |
setShowLineNumbers |
setShowUnchangedLines |
setSourceFileHTML |
setSourceFileURL |
setSpacesPerTab |
setStyleSheetURL |
setTargetFileHTML |
setTargetFileURL |
setUnchangedSymbolHTML |
start |
ToString (inherited from EditListWriter) |
unchangedLines |
write (inherited from EditListWriter) |

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter Constructor

Overload List

Obsolete.

public HTMLDiffWriter(ParsedCharSequence,ParsedCharSequence,BufferedWriter);

public HTMLDiffWriter(ParsedCharSequence,ParsedCharSequence,File);

public HTMLDiffWriter(ParsedCharSequence,ParsedCharSequence,Writer);

Obsolete.

public HTMLDiffWriter(BufferedWriter,Int32,ParsedCharSequence,ParsedCharSequence);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, File)

public HTMLDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
File output
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace | HTMLDiffWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter Constructor (BufferedWriter, Int32, ParsedCharSequence, ParsedCharSequence)

NOTE: This constructor is now obsolete.

public HTMLDiffWriter(
BufferedWriter output,
Int32 tabs,
ParsedCharSequence source,
ParsedCharSequence target
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace | HTMLDiffWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, BufferedWriter)

NOTE: This constructor is now obsolete.

public HTMLDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
BufferedWriter output
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace | HTMLDiffWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, Writer)

public HTMLDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
Writer output
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace | HTMLDiffWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter Fields

The fields of the HTMLDiffWriter class are listed below. For a complete list of HTMLDiffWriter class members, see the HTMLDiffWriter Members topic.

Public Static Fields

DEFAULT_SPACES_PER_TAB

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.DEFAULT_SPACES_PER_TAB Field

public const Int32 DEFAULT_SPACES_PER_TAB = 4;

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter Methods

The methods of the HTMLDiffWriter class are listed below. For a complete list of HTMLDiffWriter class members, see the HTMLDiffWriter Members topic.

Public Static Methods

simpleDiff

Public Instance Methods

deleteLines |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish |
getAddedSymbolHTML | Gets the HTML text used to draw the symbol that indicates an "added" line.
getApplicationFooterHTML | Gets application-specific HTML text to be drawn at the bottom of the output HTML page.
getApplicationHeaderHTML | Gets application-specific HTML text to be drawn at the top of the output HTML page.
getCRHTML | Returns the string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
getDeletedSymbolHTML | Gets the HTML text used to draw the symbol that indicates a "deleted" line.
getEmbedDefaultStyles | Determines whether or not a default style sheet is embedded in the HTML document.
getGotoBlankHTML | Gets the HTML text used to draw whitespace the same width as a naviation control.
getGotoBottomHTML | Gets the HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
getGotoFirstDiffHTML | Gets the HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
getGotoLastDiffHTML | Gets the HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
getGotoNextDiffHTML | Gets the HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
getGotoPrevDiffHTML | Gets the HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
getGotoTopHTML | Gets the HTML text used to draw the navigation symbol that jumps to the top of the output page.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getInlineDeleteMarkHTML | Gets the HTML text used to mark an in-line deletion point within a source line.
getInlineInsertMarkHTML | Gets the HTML text used to mark an in-line insertion point within a source line.
getLFHTML | Returns the string representation of the line-feed character in the HTML document. The default value is "[LF]".
getNavigateOnEveryChangedLine | Indicates whether or not navigation symbols will be drawn on every changed line.
getNumContextLines | Gets the maximum number of unchanged lines displayed before and after each changed line.
getPageBaseURL | Gets the base URL of the output HTML page.
getPageTitle | Gets the title of the output HTML page.
getReplacedSymbolHTML | Gets the HTML text used to draw the symbol that indicates a "replaced" line.
getShowEOLs | Indicates whether or not "replaced" lines show markup within the line.
getShowInlineDiffs | Indicates whether or not "replaced" lines show markup within the line.
getShowLineNumbers | Determines whether or not line numbers are embedded in the HTML document.
getShowUnchangedLines | Determines whether or not unchanged lines are displayed in the HTML document.
getSourceFileHTML | Gets the HTML text used to display the name of the source file on the output page.
getSourceFileURL | Gets the URL used to link to the source file from the output HTML page.
getSpacesPerTab | Gets the number of spaces per tab character.
getStyleSheetURL | The URL used to reference a linked style sheet. Ignored if getEmbedDefaultStyles() is true. The default URL used to reference an linked style sheet is "diff.css".
getTargetFileHTML | Gets the HTML text used to display the name of the target file on the output page.
getTargetFileURL | Gets the URL used to link to the target file from the output HTML page.
GetType (inherited from Object) | Gets the Type of the current instance.
getUnchangedSymbolHTML | Gets the HTML text used to draw the symbol that indicates an "unchanged" line.
insertLines |
MemberwiseClone (inherited from EditListWriter) |
replaceLines |
setAddedSymbolHTML |
setApplicationFooterHTML |
setApplicationHeaderHTML |
setCRHTML |
setDeletedSymbolHTML |
setEmbedDefaultStyles |
setGotoBlankHTML |
setGotoBottomHTML |
setGotoFirstDiffHTML |
setGotoLastDiffHTML |
setGotoNextDiffHTML |
setGotoPrevDiffHTML |
setGotoTopHTML |
setInlineDeleteMarkHTML |
setInlineInsertMarkHTML |
setLFHTML |
setNavigateOnEveryChangedLine |
setNumContextLines |
setPageBaseURL |
setPageTitle |
setReplacedSymbolHTML |
setShowEOLs |
setShowInlineDiffs |
setShowLineNumbers |
setShowUnchangedLines |
setSourceFileHTML |
setSourceFileURL |
setSpacesPerTab |
setStyleSheetURL |
setTargetFileHTML |
setTargetFileURL |
setUnchangedSymbolHTML |
start |
ToString (inherited from EditListWriter) |
unchangedLines |
write (inherited from EditListWriter) |

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.deleteLines Method

public override void deleteLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.finish Method

public override void finish();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getAddedSymbolHTML Method

Gets the HTML text used to draw the symbol that indicates an "added" line.

public virtual string getAddedSymbolHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getApplicationFooterHTML Method

Gets application-specific HTML text to be drawn at the bottom of the output HTML page.

public virtual string getApplicationFooterHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getApplicationHeaderHTML Method

Gets application-specific HTML text to be drawn at the top of the output HTML page.

public virtual string getApplicationHeaderHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getCRHTML Method

Returns the string representation of the Carriage-return character in the HTML document. The default value is "[CR]".

public virtual string getCRHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getDeletedSymbolHTML Method

Gets the HTML text used to draw the symbol that indicates a "deleted" line.

public virtual string getDeletedSymbolHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getEmbedDefaultStyles Method

Determines whether or not a default style sheet is embedded in the HTML document.

public virtual bool getEmbedDefaultStyles();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getGotoBlankHTML Method

Gets the HTML text used to draw whitespace the same width as a naviation control.

public virtual string getGotoBlankHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getGotoBottomHTML Method

Gets the HTML text used to draw the navigation symbol that jumps to the bottom of the output page.

public virtual string getGotoBottomHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getGotoFirstDiffHTML Method

Gets the HTML text used to draw the navigation symbol that jumps to the first difference on the output page.

public virtual string getGotoFirstDiffHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getGotoLastDiffHTML Method

Gets the HTML text used to draw the navigation symbol that jumps to the last difference on the output page.

public virtual string getGotoLastDiffHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getGotoNextDiffHTML Method

Gets the HTML text used to draw the navigation symbol that jumps to the next difference on the output page.

public virtual string getGotoNextDiffHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getGotoPrevDiffHTML Method

Gets the HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.

public virtual string getGotoPrevDiffHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getGotoTopHTML Method

Gets the HTML text used to draw the navigation symbol that jumps to the top of the output page.

public virtual string getGotoTopHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getInlineDeleteMarkHTML Method

Gets the HTML text used to mark an in-line deletion point within a source line.

public virtual string getInlineDeleteMarkHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getInlineInsertMarkHTML Method

Gets the HTML text used to mark an in-line insertion point within a source line.

public virtual string getInlineInsertMarkHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getLFHTML Method

Returns the string representation of the line-feed character in the HTML document. The default value is "[LF]".

public virtual string getLFHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getNavigateOnEveryChangedLine Method

Indicates whether or not navigation symbols will be drawn on every changed line.

public virtual bool getNavigateOnEveryChangedLine();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getNumContextLines Method

Gets the maximum number of unchanged lines displayed before and after each changed line.

public virtual int getNumContextLines();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getPageBaseURL Method

Gets the base URL of the output HTML page.

public virtual string getPageBaseURL();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getPageTitle Method

Gets the title of the output HTML page.

public virtual string getPageTitle();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getReplacedSymbolHTML Method

Gets the HTML text used to draw the symbol that indicates a "replaced" line.

public virtual string getReplacedSymbolHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getShowEOLs Method

Indicates whether or not "replaced" lines show markup within the line.

public virtual bool getShowEOLs();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getShowInlineDiffs Method

Indicates whether or not "replaced" lines show markup within the line.

public virtual bool getShowInlineDiffs();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getShowLineNumbers Method

Determines whether or not line numbers are embedded in the HTML document.

public virtual bool getShowLineNumbers();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getShowUnchangedLines Method

Determines whether or not unchanged lines are displayed in the HTML document.

public virtual bool getShowUnchangedLines();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getSourceFileHTML Method

Gets the HTML text used to display the name of the source file on the output page.

public virtual string getSourceFileHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getSourceFileURL Method

Gets the URL used to link to the source file from the output HTML page.

public virtual string getSourceFileURL();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getSpacesPerTab Method

Gets the number of spaces per tab character.

public virtual int getSpacesPerTab();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getStyleSheetURL Method

The URL used to reference a linked style sheet. Ignored if getEmbedDefaultStyles() is true. The default URL used to reference an linked style sheet is "diff.css".

public virtual string getStyleSheetURL();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getTargetFileHTML Method

Gets the HTML text used to display the name of the target file on the output page.

public virtual string getTargetFileHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getTargetFileURL Method

Gets the URL used to link to the target file from the output HTML page.

public virtual string getTargetFileURL();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.getUnchangedSymbolHTML Method

Gets the HTML text used to draw the symbol that indicates an "unchanged" line.

public virtual string getUnchangedSymbolHTML();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.insertLines Method

public override void insertLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.replaceLines Method

public override void replaceLines(
Int32 sourcePos,
Int32 sourceLen,
Int32 targetPos,
Int32 targetLen
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setAddedSymbolHTML Method

public virtual void setAddedSymbolHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setApplicationFooterHTML Method

public virtual void setApplicationFooterHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setApplicationHeaderHTML Method

public virtual void setApplicationHeaderHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setCRHTML Method

public virtual void setCRHTML(
String strCRHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setDeletedSymbolHTML Method

public virtual void setDeletedSymbolHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setEmbedDefaultStyles Method

public virtual void setEmbedDefaultStyles(
Boolean bEmbed
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setGotoBlankHTML Method

public virtual void setGotoBlankHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setGotoBottomHTML Method

public virtual void setGotoBottomHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setGotoFirstDiffHTML Method

public virtual void setGotoFirstDiffHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setGotoLastDiffHTML Method

public virtual void setGotoLastDiffHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setGotoNextDiffHTML Method

public virtual void setGotoNextDiffHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setGotoPrevDiffHTML Method

public virtual void setGotoPrevDiffHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setGotoTopHTML Method

public virtual void setGotoTopHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setInlineDeleteMarkHTML Method

public virtual void setInlineDeleteMarkHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setInlineInsertMarkHTML Method

public virtual void setInlineInsertMarkHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setLFHTML Method

public virtual void setLFHTML(
String strLFHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setNavigateOnEveryChangedLine Method

public virtual void setNavigateOnEveryChangedLine(
Boolean bEveryLine
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setNumContextLines Method

public virtual void setNumContextLines(
Int32 nContextLines
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setPageBaseURL Method

public virtual void setPageBaseURL(
String strURL
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setPageTitle Method

public virtual void setPageTitle(
String strTitle
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setReplacedSymbolHTML Method

public virtual void setReplacedSymbolHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setShowEOLs Method

public virtual void setShowEOLs(
Boolean bShow
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setShowInlineDiffs Method

public virtual void setShowInlineDiffs(
Boolean bShow
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setShowLineNumbers Method

public virtual void setShowLineNumbers(
Boolean bShowLineNumbers
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setShowUnchangedLines Method

public virtual void setShowUnchangedLines(
Boolean bShowUnchangedLines
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setSourceFileHTML Method

public virtual void setSourceFileHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setSourceFileURL Method

public virtual void setSourceFileURL(
String strURL
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setSpacesPerTab Method

public virtual void setSpacesPerTab(
Int32 nSpaces
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setStyleSheetURL Method

public virtual void setStyleSheetURL(
String strURL
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setTargetFileHTML Method

public virtual void setTargetFileHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setTargetFileURL Method

public virtual void setTargetFileURL(
String strURL
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.setUnchangedSymbolHTML Method

public virtual void setUnchangedSymbolHTML(
String strHTML
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.simpleDiff Method

public static void simpleDiff(
File source,
File target,
File output
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.start Method

public override void start();

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLDiffWriter.unchangedLines Method

public override void unchangedLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

HTMLDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLInterleavedDiffWriter Class

For a list of all members of this type, see HTMLInterleavedDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter
HTMLInterleavedDiffWriter

public class HTMLInterleavedDiffWriter : HTMLTableDiffWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

HTMLInterleavedDiffWriter Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLInterleavedDiffWriter Members

HTMLInterleavedDiffWriter overview

Public Static Methods

diff Overloaded.

Public Instance Constructors

HTMLInterleavedDiffWriter Overloaded. Initializes a new instance of the HTMLInterleavedDiffWriter class.

Public Instance Methods

deleteLines (inherited from HTMLTableDiffWriter) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish (inherited from HTMLDiffWriter) |
getAddedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "added" line.
getApplicationFooterHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the bottom of the output HTML page.
getApplicationHeaderHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the top of the output HTML page.
getCRHTML (inherited from HTMLDiffWriter) | Returns the string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
getDeletedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "deleted" line.
getEmbedDefaultStyles (inherited from HTMLDiffWriter) | Determines whether or not a default style sheet is embedded in the HTML document.
getGotoBlankHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw whitespace the same width as a naviation control.
getGotoBottomHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
getGotoFirstDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
getGotoLastDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
getGotoNextDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
getGotoPrevDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
getGotoTopHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the top of the output page.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getInlineDeleteMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line deletion point within a source line.
getInlineInsertMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line insertion point within a source line.
getLFHTML (inherited from HTMLDiffWriter) | Returns the string representation of the line-feed character in the HTML document. The default value is "[LF]".
getNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | Indicates whether or not navigation symbols will be drawn on every changed line.
getNumContextLines (inherited from HTMLDiffWriter) | Gets the maximum number of unchanged lines displayed before and after each changed line.
getPageBaseURL (inherited from HTMLDiffWriter) | Gets the base URL of the output HTML page.
getPageTitle (inherited from HTMLDiffWriter) | Gets the title of the output HTML page.
getReplacedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "replaced" line.
getShowEOLs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowInlineDiffs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowLineNumbers (inherited from HTMLDiffWriter) | Determines whether or not line numbers are embedded in the HTML document.
getShowUnchangedLines (inherited from HTMLDiffWriter) | Determines whether or not unchanged lines are displayed in the HTML document.
getSourceFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the source file on the output page.
getSourceFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the source file from the output HTML page.
getSpacesPerTab (inherited from HTMLDiffWriter) | Gets the number of spaces per tab character.
getStyleSheetURL (inherited from HTMLDiffWriter) | The URL used to reference a linked style sheet. Ignored if getEmbedDefaultStyles() is true. The default URL used to reference an linked style sheet is "diff.css".
getTargetFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the target file on the output page.
getTargetFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the target file from the output HTML page.
GetType (inherited from Object) | Gets the Type of the current instance.
getUnchangedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "unchanged" line.
insertLines (inherited from HTMLTableDiffWriter) |
MemberwiseClone (inherited from EditListWriter) |
replaceLines (inherited from HTMLTableDiffWriter) |
setAddedSymbolHTML (inherited from HTMLDiffWriter) |
setApplicationFooterHTML (inherited from HTMLDiffWriter) |
setApplicationHeaderHTML (inherited from HTMLDiffWriter) |
setCRHTML (inherited from HTMLDiffWriter) |
setDeletedSymbolHTML (inherited from HTMLDiffWriter) |
setEmbedDefaultStyles (inherited from HTMLDiffWriter) |
setGotoBlankHTML (inherited from HTMLDiffWriter) |
setGotoBottomHTML (inherited from HTMLDiffWriter) |
setGotoFirstDiffHTML (inherited from HTMLDiffWriter) |
setGotoLastDiffHTML (inherited from HTMLDiffWriter) |
setGotoNextDiffHTML (inherited from HTMLDiffWriter) |
setGotoPrevDiffHTML (inherited from HTMLDiffWriter) |
setGotoTopHTML (inherited from HTMLDiffWriter) |
setInlineDeleteMarkHTML (inherited from HTMLDiffWriter) |
setInlineInsertMarkHTML (inherited from HTMLDiffWriter) |
setLFHTML (inherited from HTMLDiffWriter) |
setNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) |
setNumContextLines (inherited from HTMLDiffWriter) |
setPageBaseURL (inherited from HTMLDiffWriter) |
setPageTitle (inherited from HTMLDiffWriter) |
setReplacedSymbolHTML (inherited from HTMLDiffWriter) |
setShowEOLs (inherited from HTMLDiffWriter) |
setShowInlineDiffs (inherited from HTMLDiffWriter) |
setShowLineNumbers (inherited from HTMLDiffWriter) |
setShowUnchangedLines (inherited from HTMLDiffWriter) |
setSourceFileHTML (inherited from HTMLDiffWriter) |
setSourceFileURL (inherited from HTMLDiffWriter) |
setSpacesPerTab (inherited from HTMLDiffWriter) |
setStyleSheetURL (inherited from HTMLDiffWriter) |
setTargetFileHTML (inherited from HTMLDiffWriter) |
setTargetFileURL (inherited from HTMLDiffWriter) |
setUnchangedSymbolHTML (inherited from HTMLDiffWriter) |
start (inherited from HTMLDiffWriter) |
ToString (inherited from EditListWriter) |
unchangedLines (inherited from HTMLTableDiffWriter) |
write (inherited from EditListWriter) |

See Also

HTMLInterleavedDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLInterleavedDiffWriter Constructor

Overload List

Obsolete.

public HTMLInterleavedDiffWriter(ParsedCharSequence,ParsedCharSequence,BufferedWriter);

public HTMLInterleavedDiffWriter(ParsedCharSequence,ParsedCharSequence,File);

public HTMLInterleavedDiffWriter(ParsedCharSequence,ParsedCharSequence,Writer);

See Also

HTMLInterleavedDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLInterleavedDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, File)

public HTMLInterleavedDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
File output
);

See Also

HTMLInterleavedDiffWriter Class | com.starbase.diff Namespace | HTMLInterleavedDiffWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLInterleavedDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, BufferedWriter)

NOTE: This constructor is now obsolete.

public HTMLInterleavedDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
BufferedWriter output
);

See Also

HTMLInterleavedDiffWriter Class | com.starbase.diff Namespace | HTMLInterleavedDiffWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLInterleavedDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, Writer)

public HTMLInterleavedDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
Writer output
);

See Also

HTMLInterleavedDiffWriter Class | com.starbase.diff Namespace | HTMLInterleavedDiffWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLInterleavedDiffWriter Methods

The methods of the HTMLInterleavedDiffWriter class are listed below. For a complete list of HTMLInterleavedDiffWriter class members, see the HTMLInterleavedDiffWriter Members topic.

Public Static Methods

diff Overloaded.

Public Instance Methods

deleteLines (inherited from HTMLTableDiffWriter) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish (inherited from HTMLDiffWriter) |
getAddedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "added" line.
getApplicationFooterHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the bottom of the output HTML page.
getApplicationHeaderHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the top of the output HTML page.
getCRHTML (inherited from HTMLDiffWriter) | Returns the string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
getDeletedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "deleted" line.
getEmbedDefaultStyles (inherited from HTMLDiffWriter) | Determines whether or not a default style sheet is embedded in the HTML document.
getGotoBlankHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw whitespace the same width as a naviation control.
getGotoBottomHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
getGotoFirstDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
getGotoLastDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
getGotoNextDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
getGotoPrevDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
getGotoTopHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the top of the output page.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getInlineDeleteMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line deletion point within a source line.
getInlineInsertMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line insertion point within a source line.
getLFHTML (inherited from HTMLDiffWriter) | Returns the string representation of the line-feed character in the HTML document. The default value is "[LF]".
getNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | Indicates whether or not navigation symbols will be drawn on every changed line.
getNumContextLines (inherited from HTMLDiffWriter) | Gets the maximum number of unchanged lines displayed before and after each changed line.
getPageBaseURL (inherited from HTMLDiffWriter) | Gets the base URL of the output HTML page.
getPageTitle (inherited from HTMLDiffWriter) | Gets the title of the output HTML page.
getReplacedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "replaced" line.
getShowEOLs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowInlineDiffs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowLineNumbers (inherited from HTMLDiffWriter) | Determines whether or not line numbers are embedded in the HTML document.
getShowUnchangedLines (inherited from HTMLDiffWriter) | Determines whether or not unchanged lines are displayed in the HTML document.
getSourceFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the source file on the output page.
getSourceFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the source file from the output HTML page.
getSpacesPerTab (inherited from HTMLDiffWriter) | Gets the number of spaces per tab character.
getStyleSheetURL (inherited from HTMLDiffWriter) | The URL used to reference a linked style sheet. Ignored if getEmbedDefaultStyles() is true. The default URL used to reference an linked style sheet is "diff.css".
getTargetFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the target file on the output page.
getTargetFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the target file from the output HTML page.
GetType (inherited from Object) | Gets the Type of the current instance.
getUnchangedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "unchanged" line.
insertLines (inherited from HTMLTableDiffWriter) |
MemberwiseClone (inherited from EditListWriter) |
replaceLines (inherited from HTMLTableDiffWriter) |
setAddedSymbolHTML (inherited from HTMLDiffWriter) |
setApplicationFooterHTML (inherited from HTMLDiffWriter) |
setApplicationHeaderHTML (inherited from HTMLDiffWriter) |
setCRHTML (inherited from HTMLDiffWriter) |
setDeletedSymbolHTML (inherited from HTMLDiffWriter) |
setEmbedDefaultStyles (inherited from HTMLDiffWriter) |
setGotoBlankHTML (inherited from HTMLDiffWriter) |
setGotoBottomHTML (inherited from HTMLDiffWriter) |
setGotoFirstDiffHTML (inherited from HTMLDiffWriter) |
setGotoLastDiffHTML (inherited from HTMLDiffWriter) |
setGotoNextDiffHTML (inherited from HTMLDiffWriter) |
setGotoPrevDiffHTML (inherited from HTMLDiffWriter) |
setGotoTopHTML (inherited from HTMLDiffWriter) |
setInlineDeleteMarkHTML (inherited from HTMLDiffWriter) |
setInlineInsertMarkHTML (inherited from HTMLDiffWriter) |
setLFHTML (inherited from HTMLDiffWriter) |
setNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) |
setNumContextLines (inherited from HTMLDiffWriter) |
setPageBaseURL (inherited from HTMLDiffWriter) |
setPageTitle (inherited from HTMLDiffWriter) |
setReplacedSymbolHTML (inherited from HTMLDiffWriter) |
setShowEOLs (inherited from HTMLDiffWriter) |
setShowInlineDiffs (inherited from HTMLDiffWriter) |
setShowLineNumbers (inherited from HTMLDiffWriter) |
setShowUnchangedLines (inherited from HTMLDiffWriter) |
setSourceFileHTML (inherited from HTMLDiffWriter) |
setSourceFileURL (inherited from HTMLDiffWriter) |
setSpacesPerTab (inherited from HTMLDiffWriter) |
setStyleSheetURL (inherited from HTMLDiffWriter) |
setTargetFileHTML (inherited from HTMLDiffWriter) |
setTargetFileURL (inherited from HTMLDiffWriter) |
setUnchangedSymbolHTML (inherited from HTMLDiffWriter) |
start (inherited from HTMLDiffWriter) |
ToString (inherited from EditListWriter) |
unchangedLines (inherited from HTMLTableDiffWriter) |
write (inherited from EditListWriter) |

See Also

HTMLInterleavedDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


diff Method

Borland StarTeam SDK for .NET

HTMLInterleavedDiffWriter.diff Method

Overload List

public static void diff(File,File,DiffCompare,File);

public static void diff(File,File,File);

public static void diff(File,File,Int32,File);

See Also

HTMLInterleavedDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLInterleavedDiffWriter.diff Method (File, File, DiffCompare, File)

public static void diff(
File source,
File target,
DiffCompare compare,
File output
);

See Also

HTMLInterleavedDiffWriter Class | com.starbase.diff Namespace | HTMLInterleavedDiffWriter.diff Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLInterleavedDiffWriter.diff Method (File, File, File)

public static void diff(
File source,
File target,
File output
);

See Also

HTMLInterleavedDiffWriter Class | com.starbase.diff Namespace | HTMLInterleavedDiffWriter.diff Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLInterleavedDiffWriter.diff Method (File, File, Int32, File)

public static void diff(
File source,
File target,
Int32 compareFlags,
File output
);

See Also

HTMLInterleavedDiffWriter Class | com.starbase.diff Namespace | HTMLInterleavedDiffWriter.diff Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLStereoDiffWriter Class

For a list of all members of this type, see HTMLStereoDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter
HTMLStereoDiffWriter

public class HTMLStereoDiffWriter : HTMLTableDiffWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

HTMLStereoDiffWriter Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLStereoDiffWriter Members

HTMLStereoDiffWriter overview

Public Static Methods

diff Overloaded.

Public Instance Constructors

HTMLStereoDiffWriter Overloaded. Initializes a new instance of the HTMLStereoDiffWriter class.

Public Instance Methods

deleteLines (inherited from HTMLTableDiffWriter) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish (inherited from HTMLDiffWriter) |
getAddedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "added" line.
getApplicationFooterHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the bottom of the output HTML page.
getApplicationHeaderHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the top of the output HTML page.
getCRHTML (inherited from HTMLDiffWriter) | Returns the string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
getDeletedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "deleted" line.
getEmbedDefaultStyles (inherited from HTMLDiffWriter) | Determines whether or not a default style sheet is embedded in the HTML document.
getGotoBlankHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw whitespace the same width as a naviation control.
getGotoBottomHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
getGotoFirstDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
getGotoLastDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
getGotoNextDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
getGotoPrevDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
getGotoTopHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the top of the output page.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getInlineDeleteMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line deletion point within a source line.
getInlineInsertMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line insertion point within a source line.
getLFHTML (inherited from HTMLDiffWriter) | Returns the string representation of the line-feed character in the HTML document. The default value is "[LF]".
getNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | Indicates whether or not navigation symbols will be drawn on every changed line.
getNumContextLines (inherited from HTMLDiffWriter) | Gets the maximum number of unchanged lines displayed before and after each changed line.
getPageBaseURL (inherited from HTMLDiffWriter) | Gets the base URL of the output HTML page.
getPageTitle (inherited from HTMLDiffWriter) | Gets the title of the output HTML page.
getReplacedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "replaced" line.
getShowEOLs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowInlineDiffs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowLineNumbers (inherited from HTMLDiffWriter) | Determines whether or not line numbers are embedded in the HTML document.
getShowUnchangedLines (inherited from HTMLDiffWriter) | Determines whether or not unchanged lines are displayed in the HTML document.
getSourceFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the source file on the output page.
getSourceFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the source file from the output HTML page.
getSpacesPerTab (inherited from HTMLDiffWriter) | Gets the number of spaces per tab character.
getStyleSheetURL (inherited from HTMLDiffWriter) | The URL used to reference a linked style sheet. Ignored if getEmbedDefaultStyles() is true. The default URL used to reference an linked style sheet is "diff.css".
getTargetFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the target file on the output page.
getTargetFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the target file from the output HTML page.
GetType (inherited from Object) | Gets the Type of the current instance.
getUnchangedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "unchanged" line.
insertLines (inherited from HTMLTableDiffWriter) |
MemberwiseClone (inherited from EditListWriter) |
replaceLines (inherited from HTMLTableDiffWriter) |
setAddedSymbolHTML (inherited from HTMLDiffWriter) |
setApplicationFooterHTML (inherited from HTMLDiffWriter) |
setApplicationHeaderHTML (inherited from HTMLDiffWriter) |
setCRHTML (inherited from HTMLDiffWriter) |
setDeletedSymbolHTML (inherited from HTMLDiffWriter) |
setEmbedDefaultStyles (inherited from HTMLDiffWriter) |
setGotoBlankHTML (inherited from HTMLDiffWriter) |
setGotoBottomHTML (inherited from HTMLDiffWriter) |
setGotoFirstDiffHTML (inherited from HTMLDiffWriter) |
setGotoLastDiffHTML (inherited from HTMLDiffWriter) |
setGotoNextDiffHTML (inherited from HTMLDiffWriter) |
setGotoPrevDiffHTML (inherited from HTMLDiffWriter) |
setGotoTopHTML (inherited from HTMLDiffWriter) |
setInlineDeleteMarkHTML (inherited from HTMLDiffWriter) |
setInlineInsertMarkHTML (inherited from HTMLDiffWriter) |
setLFHTML (inherited from HTMLDiffWriter) |
setNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) |
setNumContextLines (inherited from HTMLDiffWriter) |
setPageBaseURL (inherited from HTMLDiffWriter) |
setPageTitle (inherited from HTMLDiffWriter) |
setReplacedSymbolHTML (inherited from HTMLDiffWriter) |
setShowEOLs (inherited from HTMLDiffWriter) |
setShowInlineDiffs (inherited from HTMLDiffWriter) |
setShowLineNumbers (inherited from HTMLDiffWriter) |
setShowUnchangedLines (inherited from HTMLDiffWriter) |
setSourceFileHTML (inherited from HTMLDiffWriter) |
setSourceFileURL (inherited from HTMLDiffWriter) |
setSpacesPerTab (inherited from HTMLDiffWriter) |
setStyleSheetURL (inherited from HTMLDiffWriter) |
setTargetFileHTML (inherited from HTMLDiffWriter) |
setTargetFileURL (inherited from HTMLDiffWriter) |
setUnchangedSymbolHTML (inherited from HTMLDiffWriter) |
start (inherited from HTMLDiffWriter) |
ToString (inherited from EditListWriter) |
unchangedLines (inherited from HTMLTableDiffWriter) |
write (inherited from EditListWriter) |

See Also

HTMLStereoDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLStereoDiffWriter Constructor

Overload List

Obsolete.

public HTMLStereoDiffWriter(ParsedCharSequence,ParsedCharSequence,BufferedWriter);

public HTMLStereoDiffWriter(ParsedCharSequence,ParsedCharSequence,File);

public HTMLStereoDiffWriter(ParsedCharSequence,ParsedCharSequence,Writer);

See Also

HTMLStereoDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLStereoDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, File)

public HTMLStereoDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
File output
);

See Also

HTMLStereoDiffWriter Class | com.starbase.diff Namespace | HTMLStereoDiffWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLStereoDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, BufferedWriter)

NOTE: This constructor is now obsolete.

public HTMLStereoDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
BufferedWriter output
);

See Also

HTMLStereoDiffWriter Class | com.starbase.diff Namespace | HTMLStereoDiffWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLStereoDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, Writer)

public HTMLStereoDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
Writer output
);

See Also

HTMLStereoDiffWriter Class | com.starbase.diff Namespace | HTMLStereoDiffWriter Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLStereoDiffWriter Methods

The methods of the HTMLStereoDiffWriter class are listed below. For a complete list of HTMLStereoDiffWriter class members, see the HTMLStereoDiffWriter Members topic.

Public Static Methods

diff Overloaded.

Public Instance Methods

deleteLines (inherited from HTMLTableDiffWriter) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish (inherited from HTMLDiffWriter) |
getAddedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "added" line.
getApplicationFooterHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the bottom of the output HTML page.
getApplicationHeaderHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the top of the output HTML page.
getCRHTML (inherited from HTMLDiffWriter) | Returns the string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
getDeletedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "deleted" line.
getEmbedDefaultStyles (inherited from HTMLDiffWriter) | Determines whether or not a default style sheet is embedded in the HTML document.
getGotoBlankHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw whitespace the same width as a naviation control.
getGotoBottomHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
getGotoFirstDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
getGotoLastDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
getGotoNextDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
getGotoPrevDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
getGotoTopHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the top of the output page.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getInlineDeleteMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line deletion point within a source line.
getInlineInsertMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line insertion point within a source line.
getLFHTML (inherited from HTMLDiffWriter) | Returns the string representation of the line-feed character in the HTML document. The default value is "[LF]".
getNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | Indicates whether or not navigation symbols will be drawn on every changed line.
getNumContextLines (inherited from HTMLDiffWriter) | Gets the maximum number of unchanged lines displayed before and after each changed line.
getPageBaseURL (inherited from HTMLDiffWriter) | Gets the base URL of the output HTML page.
getPageTitle (inherited from HTMLDiffWriter) | Gets the title of the output HTML page.
getReplacedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "replaced" line.
getShowEOLs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowInlineDiffs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowLineNumbers (inherited from HTMLDiffWriter) | Determines whether or not line numbers are embedded in the HTML document.
getShowUnchangedLines (inherited from HTMLDiffWriter) | Determines whether or not unchanged lines are displayed in the HTML document.
getSourceFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the source file on the output page.
getSourceFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the source file from the output HTML page.
getSpacesPerTab (inherited from HTMLDiffWriter) | Gets the number of spaces per tab character.
getStyleSheetURL (inherited from HTMLDiffWriter) | The URL used to reference a linked style sheet. Ignored if getEmbedDefaultStyles() is true. The default URL used to reference an linked style sheet is "diff.css".
getTargetFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the target file on the output page.
getTargetFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the target file from the output HTML page.
GetType (inherited from Object) | Gets the Type of the current instance.
getUnchangedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "unchanged" line.
insertLines (inherited from HTMLTableDiffWriter) |
MemberwiseClone (inherited from EditListWriter) |
replaceLines (inherited from HTMLTableDiffWriter) |
setAddedSymbolHTML (inherited from HTMLDiffWriter) |
setApplicationFooterHTML (inherited from HTMLDiffWriter) |
setApplicationHeaderHTML (inherited from HTMLDiffWriter) |
setCRHTML (inherited from HTMLDiffWriter) |
setDeletedSymbolHTML (inherited from HTMLDiffWriter) |
setEmbedDefaultStyles (inherited from HTMLDiffWriter) |
setGotoBlankHTML (inherited from HTMLDiffWriter) |
setGotoBottomHTML (inherited from HTMLDiffWriter) |
setGotoFirstDiffHTML (inherited from HTMLDiffWriter) |
setGotoLastDiffHTML (inherited from HTMLDiffWriter) |
setGotoNextDiffHTML (inherited from HTMLDiffWriter) |
setGotoPrevDiffHTML (inherited from HTMLDiffWriter) |
setGotoTopHTML (inherited from HTMLDiffWriter) |
setInlineDeleteMarkHTML (inherited from HTMLDiffWriter) |
setInlineInsertMarkHTML (inherited from HTMLDiffWriter) |
setLFHTML (inherited from HTMLDiffWriter) |
setNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) |
setNumContextLines (inherited from HTMLDiffWriter) |
setPageBaseURL (inherited from HTMLDiffWriter) |
setPageTitle (inherited from HTMLDiffWriter) |
setReplacedSymbolHTML (inherited from HTMLDiffWriter) |
setShowEOLs (inherited from HTMLDiffWriter) |
setShowInlineDiffs (inherited from HTMLDiffWriter) |
setShowLineNumbers (inherited from HTMLDiffWriter) |
setShowUnchangedLines (inherited from HTMLDiffWriter) |
setSourceFileHTML (inherited from HTMLDiffWriter) |
setSourceFileURL (inherited from HTMLDiffWriter) |
setSpacesPerTab (inherited from HTMLDiffWriter) |
setStyleSheetURL (inherited from HTMLDiffWriter) |
setTargetFileHTML (inherited from HTMLDiffWriter) |
setTargetFileURL (inherited from HTMLDiffWriter) |
setUnchangedSymbolHTML (inherited from HTMLDiffWriter) |
start (inherited from HTMLDiffWriter) |
ToString (inherited from EditListWriter) |
unchangedLines (inherited from HTMLTableDiffWriter) |
write (inherited from EditListWriter) |

See Also

HTMLStereoDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


diff Method

Borland StarTeam SDK for .NET

HTMLStereoDiffWriter.diff Method

Overload List

public static void diff(File,File,DiffCompare,File);

public static void diff(File,File,File);

public static void diff(File,File,Int32,File);

See Also

HTMLStereoDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLStereoDiffWriter.diff Method (File, File, DiffCompare, File)

public static void diff(
File source,
File target,
DiffCompare compare,
File output
);

See Also

HTMLStereoDiffWriter Class | com.starbase.diff Namespace | HTMLStereoDiffWriter.diff Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLStereoDiffWriter.diff Method (File, File, File)

public static void diff(
File source,
File target,
File output
);

See Also

HTMLStereoDiffWriter Class | com.starbase.diff Namespace | HTMLStereoDiffWriter.diff Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLStereoDiffWriter.diff Method (File, File, Int32, File)

public static void diff(
File source,
File target,
Int32 compareFlags,
File output
);

See Also

HTMLStereoDiffWriter Class | com.starbase.diff Namespace | HTMLStereoDiffWriter.diff Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLTableDiffWriter Class

For a list of all members of this type, see HTMLTableDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter
HTMLInterleavedDiffWriter
HTMLStereoDiffWriter

public class HTMLTableDiffWriter : HTMLDiffWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

HTMLTableDiffWriter Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLTableDiffWriter Members

HTMLTableDiffWriter overview

Public Instance Methods

deleteLines |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish (inherited from HTMLDiffWriter) |
getAddedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "added" line.
getApplicationFooterHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the bottom of the output HTML page.
getApplicationHeaderHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the top of the output HTML page.
getCRHTML (inherited from HTMLDiffWriter) | Returns the string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
getDeletedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "deleted" line.
getEmbedDefaultStyles (inherited from HTMLDiffWriter) | Determines whether or not a default style sheet is embedded in the HTML document.
getGotoBlankHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw whitespace the same width as a naviation control.
getGotoBottomHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
getGotoFirstDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
getGotoLastDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
getGotoNextDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
getGotoPrevDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
getGotoTopHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the top of the output page.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getInlineDeleteMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line deletion point within a source line.
getInlineInsertMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line insertion point within a source line.
getLFHTML (inherited from HTMLDiffWriter) | Returns the string representation of the line-feed character in the HTML document. The default value is "[LF]".
getNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | Indicates whether or not navigation symbols will be drawn on every changed line.
getNumContextLines (inherited from HTMLDiffWriter) | Gets the maximum number of unchanged lines displayed before and after each changed line.
getPageBaseURL (inherited from HTMLDiffWriter) | Gets the base URL of the output HTML page.
getPageTitle (inherited from HTMLDiffWriter) | Gets the title of the output HTML page.
getReplacedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "replaced" line.
getShowEOLs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowInlineDiffs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowLineNumbers (inherited from HTMLDiffWriter) | Determines whether or not line numbers are embedded in the HTML document.
getShowUnchangedLines (inherited from HTMLDiffWriter) | Determines whether or not unchanged lines are displayed in the HTML document.
getSourceFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the source file on the output page.
getSourceFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the source file from the output HTML page.
getSpacesPerTab (inherited from HTMLDiffWriter) | Gets the number of spaces per tab character.
getStyleSheetURL (inherited from HTMLDiffWriter) | The URL used to reference a linked style sheet. Ignored if getEmbedDefaultStyles() is true. The default URL used to reference an linked style sheet is "diff.css".
getTargetFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the target file on the output page.
getTargetFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the target file from the output HTML page.
GetType (inherited from Object) | Gets the Type of the current instance.
getUnchangedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "unchanged" line.
insertLines |
MemberwiseClone (inherited from EditListWriter) |
replaceLines |
setAddedSymbolHTML (inherited from HTMLDiffWriter) |
setApplicationFooterHTML (inherited from HTMLDiffWriter) |
setApplicationHeaderHTML (inherited from HTMLDiffWriter) |
setCRHTML (inherited from HTMLDiffWriter) |
setDeletedSymbolHTML (inherited from HTMLDiffWriter) |
setEmbedDefaultStyles (inherited from HTMLDiffWriter) |
setGotoBlankHTML (inherited from HTMLDiffWriter) |
setGotoBottomHTML (inherited from HTMLDiffWriter) |
setGotoFirstDiffHTML (inherited from HTMLDiffWriter) |
setGotoLastDiffHTML (inherited from HTMLDiffWriter) |
setGotoNextDiffHTML (inherited from HTMLDiffWriter) |
setGotoPrevDiffHTML (inherited from HTMLDiffWriter) |
setGotoTopHTML (inherited from HTMLDiffWriter) |
setInlineDeleteMarkHTML (inherited from HTMLDiffWriter) |
setInlineInsertMarkHTML (inherited from HTMLDiffWriter) |
setLFHTML (inherited from HTMLDiffWriter) |
setNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) |
setNumContextLines (inherited from HTMLDiffWriter) |
setPageBaseURL (inherited from HTMLDiffWriter) |
setPageTitle (inherited from HTMLDiffWriter) |
setReplacedSymbolHTML (inherited from HTMLDiffWriter) |
setShowEOLs (inherited from HTMLDiffWriter) |
setShowInlineDiffs (inherited from HTMLDiffWriter) |
setShowLineNumbers (inherited from HTMLDiffWriter) |
setShowUnchangedLines (inherited from HTMLDiffWriter) |
setSourceFileHTML (inherited from HTMLDiffWriter) |
setSourceFileURL (inherited from HTMLDiffWriter) |
setSpacesPerTab (inherited from HTMLDiffWriter) |
setStyleSheetURL (inherited from HTMLDiffWriter) |
setTargetFileHTML (inherited from HTMLDiffWriter) |
setTargetFileURL (inherited from HTMLDiffWriter) |
setUnchangedSymbolHTML (inherited from HTMLDiffWriter) |
start (inherited from HTMLDiffWriter) |
ToString (inherited from EditListWriter) |
unchangedLines |
write (inherited from EditListWriter) |

See Also

HTMLTableDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLTableDiffWriter Methods

The methods of the HTMLTableDiffWriter class are listed below. For a complete list of HTMLTableDiffWriter class members, see the HTMLTableDiffWriter Members topic.

Public Instance Methods

deleteLines |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
finish (inherited from HTMLDiffWriter) |
getAddedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "added" line.
getApplicationFooterHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the bottom of the output HTML page.
getApplicationHeaderHTML (inherited from HTMLDiffWriter) | Gets application-specific HTML text to be drawn at the top of the output HTML page.
getCRHTML (inherited from HTMLDiffWriter) | Returns the string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
getDeletedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "deleted" line.
getEmbedDefaultStyles (inherited from HTMLDiffWriter) | Determines whether or not a default style sheet is embedded in the HTML document.
getGotoBlankHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw whitespace the same width as a naviation control.
getGotoBottomHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
getGotoFirstDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
getGotoLastDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
getGotoNextDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
getGotoPrevDiffHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
getGotoTopHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the navigation symbol that jumps to the top of the output page.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getInlineDeleteMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line deletion point within a source line.
getInlineInsertMarkHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to mark an in-line insertion point within a source line.
getLFHTML (inherited from HTMLDiffWriter) | Returns the string representation of the line-feed character in the HTML document. The default value is "[LF]".
getNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | Indicates whether or not navigation symbols will be drawn on every changed line.
getNumContextLines (inherited from HTMLDiffWriter) | Gets the maximum number of unchanged lines displayed before and after each changed line.
getPageBaseURL (inherited from HTMLDiffWriter) | Gets the base URL of the output HTML page.
getPageTitle (inherited from HTMLDiffWriter) | Gets the title of the output HTML page.
getReplacedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates a "replaced" line.
getShowEOLs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowInlineDiffs (inherited from HTMLDiffWriter) | Indicates whether or not "replaced" lines show markup within the line.
getShowLineNumbers (inherited from HTMLDiffWriter) | Determines whether or not line numbers are embedded in the HTML document.
getShowUnchangedLines (inherited from HTMLDiffWriter) | Determines whether or not unchanged lines are displayed in the HTML document.
getSourceFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the source file on the output page.
getSourceFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the source file from the output HTML page.
getSpacesPerTab (inherited from HTMLDiffWriter) | Gets the number of spaces per tab character.
getStyleSheetURL (inherited from HTMLDiffWriter) | The URL used to reference a linked style sheet. Ignored if getEmbedDefaultStyles() is true. The default URL used to reference an linked style sheet is "diff.css".
getTargetFileHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to display the name of the target file on the output page.
getTargetFileURL (inherited from HTMLDiffWriter) | Gets the URL used to link to the target file from the output HTML page.
GetType (inherited from Object) | Gets the Type of the current instance.
getUnchangedSymbolHTML (inherited from HTMLDiffWriter) | Gets the HTML text used to draw the symbol that indicates an "unchanged" line.
insertLines |
MemberwiseClone (inherited from EditListWriter) |
replaceLines |
setAddedSymbolHTML (inherited from HTMLDiffWriter) |
setApplicationFooterHTML (inherited from HTMLDiffWriter) |
setApplicationHeaderHTML (inherited from HTMLDiffWriter) |
setCRHTML (inherited from HTMLDiffWriter) |
setDeletedSymbolHTML (inherited from HTMLDiffWriter) |
setEmbedDefaultStyles (inherited from HTMLDiffWriter) |
setGotoBlankHTML (inherited from HTMLDiffWriter) |
setGotoBottomHTML (inherited from HTMLDiffWriter) |
setGotoFirstDiffHTML (inherited from HTMLDiffWriter) |
setGotoLastDiffHTML (inherited from HTMLDiffWriter) |
setGotoNextDiffHTML (inherited from HTMLDiffWriter) |
setGotoPrevDiffHTML (inherited from HTMLDiffWriter) |
setGotoTopHTML (inherited from HTMLDiffWriter) |
setInlineDeleteMarkHTML (inherited from HTMLDiffWriter) |
setInlineInsertMarkHTML (inherited from HTMLDiffWriter) |
setLFHTML (inherited from HTMLDiffWriter) |
setNavigateOnEveryChangedLine (inherited from HTMLDiffWriter) |
setNumContextLines (inherited from HTMLDiffWriter) |
setPageBaseURL (inherited from HTMLDiffWriter) |
setPageTitle (inherited from HTMLDiffWriter) |
setReplacedSymbolHTML (inherited from HTMLDiffWriter) |
setShowEOLs (inherited from HTMLDiffWriter) |
setShowInlineDiffs (inherited from HTMLDiffWriter) |
setShowLineNumbers (inherited from HTMLDiffWriter) |
setShowUnchangedLines (inherited from HTMLDiffWriter) |
setSourceFileHTML (inherited from HTMLDiffWriter) |
setSourceFileURL (inherited from HTMLDiffWriter) |
setSpacesPerTab (inherited from HTMLDiffWriter) |
setStyleSheetURL (inherited from HTMLDiffWriter) |
setTargetFileHTML (inherited from HTMLDiffWriter) |
setTargetFileURL (inherited from HTMLDiffWriter) |
setUnchangedSymbolHTML (inherited from HTMLDiffWriter) |
start (inherited from HTMLDiffWriter) |
ToString (inherited from EditListWriter) |
unchangedLines |
write (inherited from EditListWriter) |

See Also

HTMLTableDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLTableDiffWriter.deleteLines Method

public override void deleteLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

HTMLTableDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLTableDiffWriter.insertLines Method

public override void insertLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

HTMLTableDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLTableDiffWriter.replaceLines Method

public override void replaceLines(
Int32 sourcePos,
Int32 sourceLen,
Int32 targetPos,
Int32 targetLen
);

See Also

HTMLTableDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HTMLTableDiffWriter.unchangedLines Method

public override void unchangedLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

See Also

HTMLTableDiffWriter Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence Class

For a list of all members of this type, see IntralineSequence Members.

System.Object
IntralineSequence

public class IntralineSequence : Sequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

IntralineSequence Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence Members

IntralineSequence overview

Public Static Methods

getDiffCompare Gets a DiffCompare interface appropriate for comparing members of an intraline sequence.

Public Instance Constructors

IntralineSequence Overloaded. Initializes a new instance of the IntralineSequence class.

Public Instance Methods

add |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
size |
ToString |

See Also

IntralineSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence Constructor

Constructs an intraline sequence based on a sequence of characters from a single line of text. A word-based sequence is created by default.

Overload List

Constructs an intraline sequence based on a sequence of characters from a single line of text. A word-based sequence is created by default.

public IntralineSequence(CharSequence);

public IntralineSequence(CharSequence,Boolean);

See Also

IntralineSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence Constructor (CharSequence)

Constructs an intraline sequence based on a sequence of characters from a single line of text. A word-based sequence is created by default.

public IntralineSequence(
CharSequence chars
);

See Also

IntralineSequence Class | com.starbase.diff Namespace | IntralineSequence Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence Constructor (CharSequence, Boolean)

public IntralineSequence(
CharSequence chars,
Boolean bCharacterBased
);

See Also

IntralineSequence Class | com.starbase.diff Namespace | IntralineSequence Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence Methods

The methods of the IntralineSequence class are listed below. For a complete list of IntralineSequence class members, see the IntralineSequence Members topic.

Public Static Methods

getDiffCompare Gets a DiffCompare interface appropriate for comparing members of an intraline sequence.

Public Instance Methods

add |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
size |
ToString |

See Also

IntralineSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence.add Method

public virtual bool add(
Object o
);

Implements

Sequence.add

See Also

IntralineSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence.get Method

public virtual object get(
Int32 index
);

Implements

Sequence.get

See Also

IntralineSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence.getDiffCompare Method

Gets a DiffCompare interface appropriate for comparing members of an intraline sequence.

public static DiffCompare getDiffCompare();

See Also

IntralineSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence.MemberwiseClone Method

public override object MemberwiseClone();

See Also

IntralineSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence.size Method

public virtual int size();

Implements

Sequence.size

See Also

IntralineSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IntralineSequence.ToString Method

public override string ToString();

See Also

IntralineSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineIterator Class

For a list of all members of this type, see LineIterator Members.

System.Object
LineIterator

public class LineIterator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LineIterator Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineIterator Members

LineIterator overview

Public Instance Constructors

LineIterator Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
hasNext | return true if there are more chars available to be read.
index | Returns the underlying CharSequence index of the last char retrieved. Returns -1 if nextChar() has not been called.
MemberwiseClone |
nextChar | Returns the next char in the underlying sequence.
ToString |

See Also

LineIterator Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineIterator Constructor

public LineIterator(
CharSequence sequence,
Int32 flags,
ColumnMask[] mask
);

See Also

LineIterator Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineIterator Methods

The methods of the LineIterator class are listed below. For a complete list of LineIterator class members, see the LineIterator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
hasNext | return true if there are more chars available to be read.
index | Returns the underlying CharSequence index of the last char retrieved. Returns -1 if nextChar() has not been called.
MemberwiseClone |
nextChar | Returns the next char in the underlying sequence.
ToString |

See Also

LineIterator Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineIterator.hasNext Method

return true if there are more chars available to be read.

public virtual bool hasNext();

See Also

LineIterator Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineIterator.index Method

Returns the underlying CharSequence index of the last char retrieved. Returns -1 if nextChar() has not been called.

public virtual int index();

See Also

LineIterator Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineIterator.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LineIterator Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineIterator.nextChar Method

Returns the next char in the underlying sequence.

public virtual char nextChar();

See Also

LineIterator Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineIterator.ToString Method

public override string ToString();

See Also

LineIterator Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Class

For a list of all members of this type, see ParsedCharSequence Members.

System.Object
ParsedCharSequence

public class ParsedCharSequence : Sequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ParsedCharSequence Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Members

ParsedCharSequence overview

Public Instance Constructors

ParsedCharSequence Overloaded. Initializes a new instance of the ParsedCharSequence class.

Public Instance Methods

add |
addLine |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLine |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
size |
ToString |

See Also

ParsedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Constructor

Overload List

public ParsedCharSequence(CharSequence);

public ParsedCharSequence(CharSequence,Char);

public ParsedCharSequence(LineReader);

Obsolete.

public ParsedCharSequence(BufferedReader);

public ParsedCharSequence(File);

public ParsedCharSequence(File,Boolean);

public ParsedCharSequence(File,String);

public ParsedCharSequence(File,String,Boolean);

public ParsedCharSequence(Reader);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Constructor (CharSequence)

public ParsedCharSequence(
CharSequence sequence
);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace | ParsedCharSequence Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Constructor (CharSequence, Char)

public ParsedCharSequence(
CharSequence sequence,
Char delimiter
);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace | ParsedCharSequence Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Constructor (BufferedReader)

NOTE: This constructor is now obsolete.

public ParsedCharSequence(
BufferedReader reader
);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace | ParsedCharSequence Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Constructor (Reader)

public ParsedCharSequence(
Reader reader
);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace | ParsedCharSequence Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Constructor (LineReader)

public ParsedCharSequence(
LineReader reader
);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace | ParsedCharSequence Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Constructor (File)

public ParsedCharSequence(
File source
);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace | ParsedCharSequence Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Constructor (File, String)

public ParsedCharSequence(
File source,
String encoding
);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace | ParsedCharSequence Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Constructor (File, Boolean)

public ParsedCharSequence(
File source,
Boolean bIgnoreEOLs
);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace | ParsedCharSequence Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Constructor (File, String, Boolean)

public ParsedCharSequence(
File source,
String encoding,
Boolean bIgnoreEOLs
);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace | ParsedCharSequence Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence Methods

The methods of the ParsedCharSequence class are listed below. For a complete list of ParsedCharSequence class members, see the ParsedCharSequence Members topic.

Public Instance Methods

add |
addLine |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLine |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
size |
ToString |

See Also

ParsedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence.add Method

public virtual bool add(
Object o
);

Implements

Sequence.add

See Also

ParsedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence.addLine Method

public virtual void addLine(
CharSequence aLine
);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence.get Method

public virtual object get(
Int32 index
);

Implements

Sequence.get

See Also

ParsedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence.getLine Method

public virtual CharSequence getLine(
Int32 n
);

See Also

ParsedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ParsedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence.size Method

public virtual int size();

Implements

Sequence.size

See Also

ParsedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ParsedCharSequence.ToString Method

public override string ToString();

See Also

ParsedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sequence Interface

For a list of all members of this type, see Sequence Members.

public interface Sequence

Types that implement Sequence

Type | Description
SequenceAdapter |
IntralineSequence |
ParsedCharSequence |

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Sequence Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sequence Members

Sequence overview

Public Instance Methods

add
get
size

See Also

Sequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sequence Methods

The methods of the Sequence interface are listed below. For a complete list of Sequence interface members, see the Sequence Members topic.

Public Instance Methods

add
get
size

See Also

Sequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sequence.add Method

bool add(
Object o
);

See Also

Sequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sequence.get Method

object get(
Int32 index
);

See Also

Sequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sequence.size Method

int size();

See Also

Sequence Interface | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SharedCharSequence Class

For a list of all members of this type, see SharedCharSequence Members.

System.Object
SharedCharSequence

public class SharedCharSequence : CharSequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SharedCharSequence Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SharedCharSequence Members

SharedCharSequence overview

Public Instance Constructors

SharedCharSequence Constructor

Public Instance Methods

charAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
length |
MemberwiseClone |
ToString |

See Also

SharedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SharedCharSequence Constructor

public SharedCharSequence(
CharSequence data,
Int32 start,
Int32 length
);

See Also

SharedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SharedCharSequence Methods

The methods of the SharedCharSequence class are listed below. For a complete list of SharedCharSequence class members, see the SharedCharSequence Members topic.

Public Instance Methods

charAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
length |
MemberwiseClone |
ToString |

See Also

SharedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SharedCharSequence.charAt Method

public virtual char charAt(
Int32 n
);

Implements

CharSequence.charAt

See Also

SharedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SharedCharSequence.length Method

public virtual int length();

Implements

CharSequence.length

See Also

SharedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SharedCharSequence.MemberwiseClone Method

public override object MemberwiseClone();

See Also

SharedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SharedCharSequence.ToString Method

public override string ToString();

See Also

SharedCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamDiff Class

For a list of all members of this type, see StarTeamDiff Members.

System.Object
StarTeamDiff

public class StarTeamDiff : Differ

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

StarTeamDiff Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamDiff Members

StarTeamDiff overview

Public Instance Constructors

StarTeamDiff Constructor Initializes a new instance of the StarTeamDiff class.

Public Instance Methods

diff |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

StarTeamDiff Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamDiff Constructor

Initializes a new instance of the StarTeamDiff class.

public StarTeamDiff();

See Also

StarTeamDiff Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamDiff Methods

The methods of the StarTeamDiff class are listed below. For a complete list of StarTeamDiff class members, see the StarTeamDiff Members topic.

Public Instance Methods

diff |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

StarTeamDiff Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamDiff.diff Method

public virtual EditList diff(
Sequence source,
Sequence target,
DiffCompare compare
);

Implements

Differ.diff

See Also

StarTeamDiff Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamDiff.MemberwiseClone Method

public override object MemberwiseClone();

See Also

StarTeamDiff Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamDiff.ToString Method

public override string ToString();

See Also

StarTeamDiff Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamMerge Class

For a list of all members of this type, see StarTeamMerge Members.

System.Object
StarTeamMerge

public class StarTeamMerge

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

StarTeamMerge Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamMerge Members

StarTeamMerge overview

Public Static Methods

merge | Overloaded.
mergeToFile | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

StarTeamMerge Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamMerge Methods

The methods of the StarTeamMerge class are listed below. For a complete list of StarTeamMerge class members, see the StarTeamMerge Members topic.

Public Static Methods

merge | Overloaded.
mergeToFile | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

StarTeamMerge Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamMerge.MemberwiseClone Method

public override object MemberwiseClone();

See Also

StarTeamMerge Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


merge Method

Borland StarTeam SDK for .NET

StarTeamMerge.merge Method

Overload List

public static bool merge(File,File,File,DiffCompare,File,String,String,String,Boolean,Boolean);

public static bool merge(File,File,File,DiffCompare,OutputStream,String,String,String,Boolean,Boolean);

public static bool merge(File,File,File,DiffCompare,OutputStream,String,String,String,Boolean,Boolean,String);

public static bool merge(File,String,File,String,File,String,DiffCompare,OutputStream,String,String,String,String,Boolean,Boolean,String);

See Also

StarTeamMerge Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamMerge.merge Method (File, File, File, DiffCompare, File, String, String, String, Boolean, Boolean)

public static bool merge(
File mine,
File common,
File yours,
DiffCompare compare,
File output,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly
);

See Also

StarTeamMerge Class | com.starbase.diff Namespace | StarTeamMerge.merge Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamMerge.merge Method (File, File, File, DiffCompare, OutputStream, String, String, String, Boolean, Boolean)

public static bool merge(
File mine,
File common,
File yours,
DiffCompare compare,
OutputStream output,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly
);

See Also

StarTeamMerge Class | com.starbase.diff Namespace | StarTeamMerge.merge Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamMerge.merge Method (File, File, File, DiffCompare, OutputStream, String, String, String, Boolean, Boolean, String)

public static bool merge(
File mine,
File common,
File yours,
DiffCompare compare,
OutputStream output,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly,
String eol
);

See Also

StarTeamMerge Class | com.starbase.diff Namespace | StarTeamMerge.merge Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamMerge.merge Method (File, String, File, String, File, String, DiffCompare, OutputStream, String, String, String, String, Boolean, Boolean, String)

public static bool merge(
File mine,
String mineEncoding,
File common,
String commonEncoding,
File yours,
String yoursEncoding,
DiffCompare compare,
OutputStream output,
String outputEncoding,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly,
String eol
);

See Also

StarTeamMerge Class | com.starbase.diff Namespace | StarTeamMerge.merge Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


mergeToFile Method

Borland StarTeam SDK for .NET

StarTeamMerge.mergeToFile Method

Overload List

public static bool mergeToFile(File,File,File,DiffCompare,File,String,String,String,Boolean,Boolean,String);

public static bool mergeToFile(File,String,File,String,File,String,DiffCompare,File,String,String,String,String,Boolean,Boolean,String);

See Also

StarTeamMerge Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamMerge.mergeToFile Method (File, File, File, DiffCompare, File, String, String, String, Boolean, Boolean, String)

public static bool mergeToFile(
File mine,
File common,
File yours,
DiffCompare compare,
File output,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly,
String eol
);

See Also

StarTeamMerge Class | com.starbase.diff Namespace | StarTeamMerge.mergeToFile Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamMerge.mergeToFile Method (File, String, File, String, File, String, DiffCompare, File, String, String, String, String, Boolean, Boolean, String)

public static bool mergeToFile(
File mine,
String mineEncoding,
File common,
String commonEncoding,
File yours,
String yoursEncoding,
DiffCompare compare,
File output,
String outputEncoding,
String mineLabel,
String commonLabel,
String yoursLabel,
Boolean showFromCommon,
Boolean overlapOnly,
String eol
);

See Also

StarTeamMerge Class | com.starbase.diff Namespace | StarTeamMerge.mergeToFile Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamMerge.ToString Method

public override string ToString();

See Also

StarTeamMerge Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StringCharSequence Class

For a list of all members of this type, see StringCharSequence Members.

System.Object
StringCharSequence

public class StringCharSequence : CharSequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.diff

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

StringCharSequence Members | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StringCharSequence Members

StringCharSequence overview

Public Instance Constructors

StringCharSequence Constructor

Public Instance Methods

charAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
length |
MemberwiseClone |
ToString |

See Also

StringCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StringCharSequence Constructor

public StringCharSequence(
String src
);

See Also

StringCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StringCharSequence Methods

The methods of the StringCharSequence class are listed below. For a complete list of StringCharSequence class members, see the StringCharSequence Members topic.

Public Instance Methods

charAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
length |
MemberwiseClone |
ToString |

See Also

StringCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StringCharSequence.charAt Method

public virtual char charAt(
Int32 n
);

Implements

CharSequence.charAt

See Also

StringCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StringCharSequence.length Method

public virtual int length();

Implements

CharSequence.length

See Also

StringCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StringCharSequence.MemberwiseClone Method

public override object MemberwiseClone();

See Also

StringCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StringCharSequence.ToString Method

public override string ToString();

See Also

StringCharSequence Class | com.starbase.diff Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


com.starbase.starteam

Borland StarTeam SDK for .NET

com.starbase.starteam Namespace

Namespace hierarchy

Classes

Class | Description
AccessCheckSecLogID |
AccessRightsManager |
AccessTestResults |
AclEntry |
AddResult |
Audit |
BLSLicenseInfo |
BuildNumber |
CacheAgent |
CacheAgentAdapter |
CacheAgentEvent |
CacheController |
CacheRef |
Catalog |
ChangeRequest |
CharacterSet |
CheckinEvent |
CheckinManager |
CheckinOptions |
CheckinPhase |
CheckinProgress |
CheckInResult |
CheckoutEvent |
CheckoutManager |
CheckoutOptions |
CheckoutProgress |
CheckOutResult |
ClientApplication |
ClientContext |
ColumnInfo |
CommandAbortedException |
ConfigFiles |
ContainerACLSecLogID |
DirectoryOverrides |
DisembodiedItemException |
DuplicateServerListEntryException |
EffectiveACE |
EmailAttachment |
EnumeratedValue |
EOLFormat |
EventHandlerInfo |
EventHandlerProfile |
File |
FileBasedStatusManager |
FileResult |
FileStream |
Filter |
FilterAdapter |
FilterEvent |
FilterQueryAdapter |
Folder |
FolderAdapter |
FolderEvent |
FolderListManager |
FolderTreeAdapter |
FolderTreeEvent |
FolderUpdateAdapter |
FolderUpdateEvent |
ForeignPasswordException |
ForeignRefreshResult |
Group |
GroupAccount |
GroupNode |
GroupSortInfo |
HistoryKeyword |
HistoryLine |
HiveInfo |
HiveInfo.HiveType |
HiveManager |
ImportUtility |
IPRange |
Item |
Item.LockType |
ItemAdapter |
ItemBehavior |
ItemEvent |
ItemIDAdapter |
ItemIDEvent |
ItemList |
ItemListAdapter |
ItemListEvent |
ItemListManager |
ItemNotFoundException |
ItemReference |
ItemRevision |
ItemUpdateAdapter |
ItemUpdateEvent |
KeywordReader |
Label |
LabelAdapter |
LabelEvent |
LicenseUsage | Obsolete.
Link |
LinkCache |
LinkEndpoint |
LinkFactory |
LinkUpdateAdapter |
LinkUpdateEvent |
LogKeyword |
LogLine |
LogonException |
MatchedACE |
MergePoint |
MPXException |
MPXStatusAdapter |
MPXStatusEvent |
MyUserAccount |
NoKeywords |
NoSuchPropertyException |
NotificationAdapter |
NotificationEvent |
NotificationItem |
ObjectACLSecLogID |
PasswordExpiredException |
Permission |
ProcessItem |
ProcessItemUsage |
ProductCodes |
Project |
ProjectAdapter |
ProjectEvent |
PromotionModel |
PromotionState |
Property |
Property.Types |
PropertyEnums |
PropertyNames |
PropertyNotWritableException |
PurgeControl |
PurgeStatus |
QueryAdapter |
QueryEvent |
QueryInfo |
QueryNode |
QueryPart |
RecycleBin |
Res |
ResIDs |
RevisionID |
SDKRuntimeException |
SecurableContainerAdapter |
SecurityLogEntry |
SecurityLogEntry.SecurityEventType |
Server |
ServerAdministration |
ServerConfiguration |
ServerControlAdapter |
ServerControlEvent |
ServerException |
ServerInfo |
ServerLicenseInfo |
ServerList |
ServerUnavailableException |
SimpleKeyword |
SimpleTypedResource |
StarTeamClientOptions |
StarTeamFinder |
StarTeamURL |
Status |
StatusMethod |
SupportedFeatures |
SystemPolicy |
Task |
TaskDependency |
Topic |
Translations |
TreeItem |
Type |
TypeAdapter |
TypedResource |
TypeEvent |
TypeNames |
TypeNotFoundException |
User |
UserAccount |
UserAdapter |
UserEvent |
UserGroupSecLogID |
View |
ViewAdapter |
ViewConfiguration |
ViewConfigurationDiffer |
ViewEvent |
ViewPollingAgent |
WorkRecord |
Workstation |

Interfaces

Interface | Description
CacheAgentListener |
CheckinListener |
CheckoutListener |
ContentFilter |
FileDigest |
FileSyncInfo |
FilterListener |
FolderListener |
FolderTreeListener |
FolderUpdateListener |
IFilterQueryListener |
IFolderListener |
IItemListener |
ISecurable |
ISecurableContainer |
ISecurableObject |
ItemIDListener |
ItemListener |
ItemListListener |
Items |
ItemUpdateListener |
Keyword |
LabelListener |
LinkUpdateListener |
MPXStatusListener |
NotificationListener |
ProjectListener |
QueryListener |
RevisionIdentifier |
ServerControlListener |
ServerSession |
TypeListener |
UserListener |
ViewListener |


AccessCheckSecLogID Class

For a list of all members of this type, see AccessCheckSecLogID Members.

System.Object
AccessCheckSecLogID

public class AccessCheckSecLogID

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

AccessCheckSecLogID Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessCheckSecLogID Members

AccessCheckSecLogID overview

Public Instance Methods

Equals |
getClassID | Returns the class id.
GetHashCode |
getObjectID | Returns the object id.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

AccessCheckSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessCheckSecLogID Methods

The methods of the AccessCheckSecLogID class are listed below. For a complete list of AccessCheckSecLogID class members, see the AccessCheckSecLogID Members topic.

Public Instance Methods

Equals |
getClassID | Returns the class id.
GetHashCode |
getObjectID | Returns the object id.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

AccessCheckSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessCheckSecLogID.Equals Method

public override bool Equals(
Object source
);

See Also

AccessCheckSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessCheckSecLogID.getClassID Method

Returns the class id.

public virtual int getClassID();

See Also

AccessCheckSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessCheckSecLogID.GetHashCode Method

public override int GetHashCode();

See Also

AccessCheckSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessCheckSecLogID.getObjectID Method

Returns the object id.

public virtual int getObjectID();

See Also

AccessCheckSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessCheckSecLogID.MemberwiseClone Method

public override object MemberwiseClone();

See Also

AccessCheckSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessCheckSecLogID.ToString Method

public override string ToString();

See Also

AccessCheckSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager Class

For a list of all members of this type, see AccessRightsManager Members.

System.Object
AccessRightsManager

public class AccessRightsManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

AccessRightsManager Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager Members

AccessRightsManager overview

Public Instance Constructors

AccessRightsManager Constructor Creates a new access rights manager for the given server.

Public Instance Methods

accessTest | Overloaded.
discard | Discards cached access rights information. Access rights information will be fetched from the server as needed.
Equals |
getEffectiveACL | Gets the effective access control list for the given securable object. <p> The effective access control list completely encompasses all information used by the server to perform an access test for the given object. <p> This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.
getEffectiveContainerACL |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
isAccessGranted | Overloaded.
MemberwiseClone |
refresh | Refreshes cached access rights information to reflect recent changes to the server.
ToString |

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager Constructor

Creates a new access rights manager for the given server.

public AccessRightsManager(
Server s
);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager Methods

The methods of the AccessRightsManager class are listed below. For a complete list of AccessRightsManager class members, see the AccessRightsManager Members topic.

Public Instance Methods

accessTest | Overloaded.
discard | Discards cached access rights information. Access rights information will be fetched from the server as needed.
Equals |
getEffectiveACL | Gets the effective access control list for the given securable object. <p> The effective access control list completely encompasses all information used by the server to perform an access test for the given object. <p> This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.
getEffectiveContainerACL |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
isAccessGranted | Overloaded.
MemberwiseClone |
refresh | Refreshes cached access rights information to reflect recent changes to the server.
ToString |

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


accessTest Method

Borland StarTeam SDK for .NET

AccessRightsManager.accessTest Method

Overload List

public virtual AccessTestResults accessTest(Int32,Int32,EffectiveACE[]);

public virtual AccessTestResults accessTest(Int32,Int32,ISecurable);

public virtual AccessTestResults accessTest(Int32,Int32,ISecurableContainer,Type);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.accessTest Method (Int32, Int32, EffectiveACE[])

public virtual AccessTestResults accessTest(
Int32 userID,
Int32 permissions,
EffectiveACE[] acl
);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace | AccessRightsManager.accessTest Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.accessTest Method (Int32, Int32, ISecurable)

public virtual AccessTestResults accessTest(
Int32 userID,
Int32 permissions,
ISecurable obj
);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace | AccessRightsManager.accessTest Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.accessTest Method (Int32, Int32, ISecurableContainer, Type)

public virtual AccessTestResults accessTest(
Int32 userID,
Int32 permissions,
ISecurableContainer container,
Type type
);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace | AccessRightsManager.accessTest Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.discard Method

Discards cached access rights information. Access rights information will be fetched from the server as needed.

public virtual void discard();

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.Equals Method

public override bool Equals(
Object source
);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.getEffectiveACL Method

Gets the effective access control list for the given securable object. <p> The effective access control list completely encompasses all information used by the server to perform an access test for the given object. <p> This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.

public virtual EffectiveACE[] getEffectiveACL(
ISecurable obj
);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.getEffectiveContainerACL Method

public virtual EffectiveACE[] getEffectiveContainerACL(
ISecurableContainer container,
Type type
);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.GetHashCode Method

public override int GetHashCode();

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


isAccessGranted Method

Borland StarTeam SDK for .NET

AccessRightsManager.isAccessGranted Method

Overload List

public virtual bool isAccessGranted(Int32,Int32,EffectiveACE[]);

public virtual bool isAccessGranted(Int32,Int32,ISecurable);

public virtual bool isAccessGranted(Int32,Int32,ISecurableContainer,Type);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.isAccessGranted Method (Int32, Int32, EffectiveACE[])

public virtual bool isAccessGranted(
Int32 userID,
Int32 permissions,
EffectiveACE[] acl
);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace | AccessRightsManager.isAccessGranted Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.isAccessGranted Method (Int32, Int32, ISecurable)

public virtual bool isAccessGranted(
Int32 userID,
Int32 permissions,
ISecurable obj
);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace | AccessRightsManager.isAccessGranted Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.isAccessGranted Method (Int32, Int32, ISecurableContainer, Type)

public virtual bool isAccessGranted(
Int32 userID,
Int32 permissions,
ISecurableContainer container,
Type type
);

See Also

AccessRightsManager Class | com.starbase.starteam Namespace | AccessRightsManager.isAccessGranted Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.MemberwiseClone Method

public override object MemberwiseClone();

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.refresh Method

Refreshes cached access rights information to reflect recent changes to the server.

public virtual void refresh();

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessRightsManager.ToString Method

public override string ToString();

See Also

AccessRightsManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessTestResults Class

For a list of all members of this type, see AccessTestResults Members.

System.Object
AccessTestResults

public class AccessTestResults

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

AccessTestResults Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessTestResults Members

AccessTestResults overview

Public Instance Methods

Equals |
getExplanation | Describes why access was granted or denied.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
isGranted | Determines whether or not access was granted.
MemberwiseClone |
ToString |

See Also

AccessTestResults Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessTestResults Methods

The methods of the AccessTestResults class are listed below. For a complete list of AccessTestResults class members, see the AccessTestResults Members topic.

Public Instance Methods

Equals |
getExplanation | Describes why access was granted or denied.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
isGranted | Determines whether or not access was granted.
MemberwiseClone |
ToString |

See Also

AccessTestResults Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessTestResults.Equals Method

public override bool Equals(
Object source
);

See Also

AccessTestResults Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessTestResults.getExplanation Method

Describes why access was granted or denied.

public virtual MatchedACE[] getExplanation();

See Also

AccessTestResults Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessTestResults.GetHashCode Method

public override int GetHashCode();

See Also

AccessTestResults Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessTestResults.isGranted Method

Determines whether or not access was granted.

public virtual bool isGranted();

See Also

AccessTestResults Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessTestResults.MemberwiseClone Method

public override object MemberwiseClone();

See Also

AccessTestResults Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AccessTestResults.ToString Method

public override string ToString();

See Also

AccessTestResults Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry Class

For a list of all members of this type, see AclEntry Members.

System.Object
AclEntry
EffectiveACE

public class AclEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

AclEntry Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry Members

AclEntry overview

Public Instance Constructors

AclEntry Overloaded. Initializes a new instance of the AclEntry class.

Public Instance Methods

addPermission |
Equals |
GetHashCode |
getID | Returns the user or group ID for this entry.
getPermissionFlags | Returns the internal "bit set" representation of this entry's permissions. This is the bitwise OR of all added permissions.
GetType (inherited from Object) | Gets the Type of the current instance.
hasPermission |
isGranted | Returns true if the permissions are granted and false if denied.
isGroupID | Returns true if the ID represents a group.
MemberwiseClone |
removePermission |
setGranted |
ToString |

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry Constructor

Overload List

public AclEntry(Int32,Boolean);

public AclEntry(Int32,Int32,Boolean);

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry Constructor (Int32, Boolean)

public AclEntry(
Int32 id,
Boolean isGranted
);

See Also

AclEntry Class | com.starbase.starteam Namespace | AclEntry Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry Constructor (Int32, Int32, Boolean)

public AclEntry(
Int32 id,
Int32 permissions,
Boolean isGranted
);

See Also

AclEntry Class | com.starbase.starteam Namespace | AclEntry Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry Methods

The methods of the AclEntry class are listed below. For a complete list of AclEntry class members, see the AclEntry Members topic.

Public Instance Methods

addPermission |
Equals |
GetHashCode |
getID | Returns the user or group ID for this entry.
getPermissionFlags | Returns the internal "bit set" representation of this entry's permissions. This is the bitwise OR of all added permissions.
GetType (inherited from Object) | Gets the Type of the current instance.
hasPermission |
isGranted | Returns true if the permissions are granted and false if denied.
isGroupID | Returns true if the ID represents a group.
MemberwiseClone |
removePermission |
setGranted |
ToString |

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.addPermission Method

public virtual void addPermission(
Int32 permission
);

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.Equals Method

public override bool Equals(
Object source
);

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.GetHashCode Method

public override int GetHashCode();

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.getID Method

Returns the user or group ID for this entry.

public virtual int getID();

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.getPermissionFlags Method

Returns the internal "bit set" representation of this entry's permissions. This is the bitwise OR of all added permissions.

public virtual int getPermissionFlags();

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.hasPermission Method

public virtual bool hasPermission(
Int32 permission
);

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.isGranted Method

Returns true if the permissions are granted and false if denied.

public virtual bool isGranted();

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.isGroupID Method

Returns true if the ID represents a group.

public virtual bool isGroupID();

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.MemberwiseClone Method

public override object MemberwiseClone();

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.removePermission Method

public virtual void removePermission(
Int32 permission
);

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.setGranted Method

public virtual void setGranted(
Boolean value
);

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AclEntry.ToString Method

public override string ToString();

See Also

AclEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AddResult Class

For a list of all members of this type, see AddResult Members.

System.Object
FileResult
AddResult

public class AddResult : FileResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

AddResult Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AddResult Members

AddResult overview

Public Instance Methods

Equals |
GetHashCode |
getKeywords (inherited from FileResult) | Returns the keywords used in the add/checkin/checkout operation. If no keywords were used the array will empty. This method will not return null.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileResult) |
ToString (inherited from FileResult) |

See Also

AddResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AddResult Methods

The methods of the AddResult class are listed below. For a complete list of AddResult class members, see the AddResult Members topic.

Public Instance Methods

Equals |
GetHashCode |
getKeywords (inherited from FileResult) | Returns the keywords used in the add/checkin/checkout operation. If no keywords were used the array will empty. This method will not return null.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileResult) |
ToString (inherited from FileResult) |

See Also

AddResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AddResult.Equals Method

public override bool Equals(
Object source
);

See Also

AddResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AddResult.GetHashCode Method

public override int GetHashCode();

See Also

AddResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Audit Class

For a list of all members of this type, see Audit Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Item
Audit

public class Audit : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Audit Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Audit Members

Audit overview

Public Instance Methods

acquireOwnership (inherited from Item)
addAttachment (inherited from Item)
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals
get (inherited from Item)
getACL (inherited from Item)
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemClass2Name | Returns the name of the second "operand" item's type (if any). Not available on older servers.
getItemClass3Name | Returns the name of the third "operand" item's type (if any). Not available on older servers.
getItemClassName | Returns the name of the audited item's type.
getItemDescriptor | Returns the primary descriptor for the underlying audited object.
getItemDescriptor2 | Returns the primary descriptor for the second "operand" object (if any). Not available on older servers.
getItemDescriptor3 | Returns the primary descriptor for the third "operand" object (if any). Not available on older servers.
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPropertyNames (inherited from Item)
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getString (inherited from Item)
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move (inherited from Item) | Obsolete. Moves this item to the specified folder. The item will be removed from its current folder.
moveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put (inherited from Item)
putByPropertyID (inherited from Item)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
removeAttachment (inherited from Item)
removeFromIntArray (inherited from TypedResource)
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
shareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. <p> If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString (inherited from Item)
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
updateRevisionComment (inherited from Item)

See Also

Audit Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Audit Methods

The methods of the Audit class are listed below. For a complete list of Audit class members, see the Audit Members topic.

Public Instance Methods

acquireOwnership (inherited from Item)
addAttachment (inherited from Item)
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals
get (inherited from Item)
getACL (inherited from Item)
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemClass2Name | Returns the name of the second "operand" item's type (if any). Not available on older servers.
getItemClass3Name | Returns the name of the third "operand" item's type (if any). Not available on older servers.
getItemClassName | Returns the name of the audited item's type.
getItemDescriptor | Returns the primary descriptor for the underlying audited object.
getItemDescriptor2 | Returns the primary descriptor for the second "operand" object (if any). Not available on older servers.
getItemDescriptor3 | Returns the primary descriptor for the third "operand" object (if any). Not available on older servers.
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPropertyNames (inherited from Item)
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getString (inherited from Item)
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move (inherited from Item) | Obsolete. Moves this item to the specified folder. The item will be removed from its current folder.
moveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put (inherited from Item)
putByPropertyID (inherited from Item)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
removeAttachment (inherited from Item)
removeFromIntArray (inherited from TypedResource)
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
shareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. <p> If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString (inherited from Item)
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
updateRevisionComment (inherited from Item)

See Also

Audit Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Audit.Equals Method

public override bool Equals(
Object source
);

See Also

Audit Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Audit.GetHashCode Method

public override int GetHashCode();

See Also

Audit Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Audit.getItemClass2Name Method

Returns the name of the second "operand" item's type (if any). Not available on older servers.

public virtual string getItemClass2Name();

See Also

Audit Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Audit.getItemClass3Name Method

Returns the name of the third "operand" item's type (if any). Not available on older servers.

public virtual string getItemClass3Name();

See Also

Audit Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Audit.getItemClassName Method

Returns the name of the audited item's type.

public virtual string getItemClassName();

See Also

Audit Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Audit.getItemDescriptor Method

Returns the primary descriptor for the underlying audited object.

public virtual string getItemDescriptor();

See Also

Audit Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Audit.getItemDescriptor2 Method

Returns the primary descriptor for the second "operand" object (if any). Not available on older servers.

public virtual string getItemDescriptor2();

See Also

Audit Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Audit.getItemDescriptor3 Method

Returns the primary descriptor for the third "operand" object (if any). Not available on older servers.

public virtual string getItemDescriptor3();

See Also

Audit Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BLSLicenseInfo Class

For a list of all members of this type, see BLSLicenseInfo Members.

System.Object
BLSLicenseInfo

public class BLSLicenseInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

BLSLicenseInfo Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BLSLicenseInfo Members

BLSLicenseInfo overview

Public Instance Methods

Equals |
getDescription | Gets the description of this license.
GetHashCode |
getSlipGuid | Gets the Slip ID assigned by the Borland License Server to identify this license.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

BLSLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BLSLicenseInfo Methods

The methods of the BLSLicenseInfo class are listed below. For a complete list of BLSLicenseInfo class members, see the BLSLicenseInfo Members topic.

Public Instance Methods

Equals |
getDescription | Gets the description of this license.
GetHashCode |
getSlipGuid | Gets the Slip ID assigned by the Borland License Server to identify this license.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

BLSLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BLSLicenseInfo.Equals Method

public override bool Equals(
Object source
);

See Also

BLSLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BLSLicenseInfo.getDescription Method

Gets the description of this license.

public virtual string getDescription();

See Also

BLSLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BLSLicenseInfo.GetHashCode Method

public override int GetHashCode();

See Also

BLSLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BLSLicenseInfo.getSlipGuid Method

Gets the Slip ID assigned by the Borland License Server to identify this license.

public virtual int getSlipGuid();

See Also

BLSLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BLSLicenseInfo.MemberwiseClone Method

public override object MemberwiseClone();

See Also

BLSLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BLSLicenseInfo.ToString Method

public override string ToString();

See Also

BLSLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber Class

For a list of all members of this type, see BuildNumber Members.

System.Object
BuildNumber

public class BuildNumber

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

BuildNumber Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber Members

BuildNumber overview

Public Static Methods

currentBuild | Obsolete. Gets a string describing the current product build (currently "11.0.35"). Similar to getBuildString(), except that the third part (internal development branch) is not included. Provided for backward compatibilty only.
currentRelease | Obsolete. Same as getVersionString(). Provided for backward compatibility.
getBranchNumber | Gets the internal development branch number.
getBuildNumber | Gets the product build number.
getBuildString | Gets the full product version string.
getDisplayString | Gets a display string showing the full product name, version and build number.
getDotRelease | Obsolete. No longer used.
getMajorVersion | Gets the product major version number.
getMinorVersion | Gets the product minor version number.
getProductName | Gets the product name.
getVersionString | Gets the product version string.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber Methods

The methods of the BuildNumber class are listed below. For a complete list of BuildNumber class members, see the BuildNumber Members topic.

Public Static Methods

currentBuild | Obsolete. Gets a string describing the current product build (currently "11.0.35"). Similar to getBuildString(), except that the third part (internal development branch) is not included. Provided for backward compatibilty only.
currentRelease | Obsolete. Same as getVersionString(). Provided for backward compatibility.
getBranchNumber | Gets the internal development branch number.
getBuildNumber | Gets the product build number.
getBuildString | Gets the full product version string.
getDisplayString | Gets a display string showing the full product name, version and build number.
getDotRelease | Obsolete. No longer used.
getMajorVersion | Gets the product major version number.
getMinorVersion | Gets the product minor version number.
getProductName | Gets the product name.
getVersionString | Gets the product version string.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.currentBuild Method

NOTE: This method is now obsolete.

Gets a string describing the current product build (currently "11.0.35"). Similar to getBuildString(), except that the third part (internal development branch) is not included. Provided for backward compatibilty only.

public static string currentBuild();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.currentRelease Method

NOTE: This method is now obsolete.

Same as getVersionString(). Provided for backward compatibility.

public static string currentRelease();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.getBranchNumber Method

Gets the internal development branch number.

public static int getBranchNumber();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.getBuildNumber Method

Gets the product build number.

public static int getBuildNumber();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.getBuildString Method

Gets the full product version string.

public static string getBuildString();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.getDisplayString Method

Gets a display string showing the full product name, version and build number.

public static string getDisplayString();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.getDotRelease Method

NOTE: This method is now obsolete.

No longer used.

public static int getDotRelease();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.getMajorVersion Method

Gets the product major version number.

public static int getMajorVersion();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.getMinorVersion Method

Gets the product minor version number.

public static int getMinorVersion();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.getProductName Method

Gets the product name.

public static string getProductName();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.getVersionString Method

Gets the product version string.

public static string getVersionString();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.MemberwiseClone Method

public override object MemberwiseClone();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


BuildNumber.ToString Method

public override string ToString();

See Also

BuildNumber Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent Class

For a list of all members of this type, see CacheAgent Members.

System.Object
CacheAgent

public class CacheAgent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CacheAgent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent Members

CacheAgent overview

Public Instance Methods

cachesFileContent | returns true if this cache agent caches file content
cachesObjectPropertyContent | returns true if this cache agent caches object property content
cachesProject | Indicate if the Cache Agent is caching content for the given StarTeam server project. The method performs a case-insensitive project name comparison, leveraging the fact that some names cached by the Cache Agent may be patterns with "*" wildcards.
cachesType | Indicate if the object type is cached by the Cache Agent.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getHostName | Gets the host address of this cache agent.
getPort | returns the port number at which this cache agent is located
GetType (inherited from Object) | Gets the Type of the current instance.
getVersion | returns version information for this Cache Agent
isRoot | returns true if this a a Root Cache Agent
MemberwiseClone |
ToString |

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent Methods

The methods of the CacheAgent class are listed below. For a complete list of CacheAgent class members, see the CacheAgent Members topic.

Public Instance Methods

cachesFileContent | returns true if this cache agent caches file content
cachesObjectPropertyContent | returns true if this cache agent caches object property content
cachesProject | Indicate if the Cache Agent is caching content for the given StarTeam server project. The method performs a case-insensitive project name comparison, leveraging the fact that some names cached by the Cache Agent may be patterns with "*" wildcards.
cachesType | Indicate if the object type is cached by the Cache Agent.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getHostName | Gets the host address of this cache agent.
getPort | returns the port number at which this cache agent is located
GetType (inherited from Object) | Gets the Type of the current instance.
getVersion | returns version information for this Cache Agent
isRoot | returns true if this a a Root Cache Agent
MemberwiseClone |
ToString |

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent.cachesFileContent Method

returns true if this cache agent caches file content

public virtual bool cachesFileContent();

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent.cachesObjectPropertyContent Method

returns true if this cache agent caches object property content

public virtual bool cachesObjectPropertyContent();

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent.cachesProject Method

Indicate if the Cache Agent is caching content for the given StarTeam server project. The method performs a case-insensitive project name comparison, leveraging the fact that some names cached by the Cache Agent may be patterns with "*" wildcards.

public virtual bool cachesProject(
Project project
);

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent.cachesType Method

Indicate if the object type is cached by the Cache Agent.

public virtual bool cachesType(
Type type
);

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent.getHostName Method

Gets the host address of this cache agent.

public virtual string getHostName();

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent.getPort Method

returns the port number at which this cache agent is located

public virtual int getPort();

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent.getVersion Method

returns version information for this Cache Agent

public virtual string getVersion();

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent.isRoot Method

returns true if this a a Root Cache Agent

public virtual bool isRoot();

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgent.ToString Method

public override string ToString();

See Also

CacheAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentAdapter Class

For a list of all members of this type, see CacheAgentAdapter Members.

System.Object
CacheAgentAdapter

public class CacheAgentAdapter : CacheAgentListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CacheAgentAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentAdapter Members

CacheAgentAdapter overview

Public Instance Constructors

CacheAgentAdapter Constructor Initializes a new instance of the CacheAgentAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
itemMissed |
itemReceived |
MemberwiseClone |
ToString |

See Also

CacheAgentAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentAdapter Constructor

Initializes a new instance of the CacheAgentAdapter class.

public CacheAgentAdapter();

See Also

CacheAgentAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentAdapter Methods

The methods of the CacheAgentAdapter class are listed below. For a complete list of CacheAgentAdapter class members, see the CacheAgentAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
itemMissed |
itemReceived |
MemberwiseClone |
ToString |

See Also

CacheAgentAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentAdapter.itemMissed Method

public override void itemMissed(
CacheAgentEvent e
);

Implements

CacheAgentListener.itemMissed

See Also

CacheAgentAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentAdapter.itemReceived Method

public override void itemReceived(
CacheAgentEvent e
);

Implements

CacheAgentListener.itemReceived

See Also

CacheAgentAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CacheAgentAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentAdapter.ToString Method

public override string ToString();

See Also

CacheAgentAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent Class

For a list of all members of this type, see CacheAgentEvent Members.

System.Object
EventObject
CacheAgentEvent

public class CacheAgentEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CacheAgentEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent Members

CacheAgentEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
getBytesReceived | the number of bytes received from the Cache Agent for this item
getDebugString | return a string representation of the event generally useful for application debugging
getExecutionTime | returns the time (in msecs) taken to process the content for this item
GetHashCode |
getIsFileContent | returns true if the content is file specific, false otherwise
getIsObjectPropertyContent | returns true if the content describes properties of cached objects, false otherwise
getItemID | returns the item id of the StarTeam item whose content has been received
getMissingProperties | returns the set of properties that were requested but not received from the Cache Agent NULL if file content was retrieved from the cache agent an empty property array if no properties were missed
GetObjectData (inherited from java.util.EventObject) |
getSource |
getType | returns the type of the StarTeam item whose content has been received
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent Methods

The methods of the CacheAgentEvent class are listed below. For a complete list of CacheAgentEvent class members, see the CacheAgentEvent Members topic.

Public Instance Methods

Equals |
getBytesReceived | the number of bytes received from the Cache Agent for this item
getDebugString | return a string representation of the event generally useful for application debugging
getExecutionTime | returns the time (in msecs) taken to process the content for this item
GetHashCode |
getIsFileContent | returns true if the content is file specific, false otherwise
getIsObjectPropertyContent | returns true if the content describes properties of cached objects, false otherwise
getItemID | returns the item id of the StarTeam item whose content has been received
getMissingProperties | returns the set of properties that were requested but not received from the Cache Agent NULL if file content was retrieved from the cache agent an empty property array if no properties were missed
GetObjectData (inherited from java.util.EventObject) |
getSource |
getType | returns the type of the StarTeam item whose content has been received
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.Equals Method

public override bool Equals(
Object source
);

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.getBytesReceived Method

the number of bytes received from the Cache Agent for this item

public virtual long getBytesReceived();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.getDebugString Method

return a string representation of the event generally useful for application debugging

public virtual string getDebugString();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.getExecutionTime Method

returns the time (in msecs) taken to process the content for this item

public virtual int getExecutionTime();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.GetHashCode Method

public override int GetHashCode();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.getIsFileContent Method

returns true if the content is file specific, false otherwise

public virtual bool getIsFileContent();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.getIsObjectPropertyContent Method

returns true if the content describes properties of cached objects, false otherwise

public virtual bool getIsObjectPropertyContent();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.getItemID Method

returns the item id of the StarTeam item whose content has been received

public virtual int getItemID();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.getMissingProperties Method

returns the set of properties that were requested but not received from the Cache Agent NULL if file content was retrieved from the cache agent an empty property array if no properties were missed

public virtual Property[] getMissingProperties();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.getSource Method

public override object getSource();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.getType Method

returns the type of the StarTeam item whose content has been received

public virtual Type getType();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentEvent.ToString Method

public override string ToString();

See Also

CacheAgentEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentListener Interface

For a list of all members of this type, see CacheAgentListener Members.

public interface CacheAgentListener : EventListener

Types that implement CacheAgentListener

Type | Description
CacheAgentAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CacheAgentListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentListener Members

CacheAgentListener overview

Public Instance Methods

itemMissed | Triggered if an item's content was requested, but was not received from the cache agent.
itemReceived | Triggered whenever an item's content is received from the cache agent.

See Also

CacheAgentListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentListener Methods

The methods of the CacheAgentListener interface are listed below. For a complete list of CacheAgentListener interface members, see the CacheAgentListener Members topic.

Public Instance Methods

itemMissed | Triggered if an item's content was requested, but was not received from the cache agent.
itemReceived | Triggered whenever an item's content is received from the cache agent.

See Also

CacheAgentListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentListener.itemMissed Method

Triggered if an item's content was requested, but was not received from the cache agent.

void itemMissed(
CacheAgentEvent e
);

See Also

CacheAgentListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheAgentListener.itemReceived Method

Triggered whenever an item's content is received from the cache agent.

void itemReceived(
CacheAgentEvent e
);

See Also

CacheAgentListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheController Class

For a list of all members of this type, see CacheController Members.

System.Object
CacheController

public class CacheController

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CacheController Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheController Members

CacheController overview

Public Static Methods

getMaxCaches | Gets the maximum number of server caches.
setMaxCaches |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

CacheController Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheController Methods

The methods of the CacheController class are listed below. For a complete list of CacheController class members, see the CacheController Members topic.

Public Static Methods

getMaxCaches | Gets the maximum number of server caches.
setMaxCaches |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

CacheController Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheController.getMaxCaches Method

Gets the maximum number of server caches.

public static int getMaxCaches();

See Also

CacheController Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheController.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CacheController Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheController.setMaxCaches Method

public static void setMaxCaches(
Int32 n
);

See Also

CacheController Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheController.ToString Method

public override string ToString();

See Also

CacheController Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheRef Class

For a list of all members of this type, see CacheRef Members.

System.Object
CacheRef
Derived types

public class CacheRef : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CacheRef Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheRef Members

CacheRef overview

Public Instance Methods

Clone |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

CacheRef Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheRef Methods

The methods of the CacheRef class are listed below. For a complete list of CacheRef class members, see the CacheRef Members topic.

Public Instance Methods

Clone |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

CacheRef Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheRef.Clone Method

public virtual object Clone();

Implements

ICloneable.Clone

See Also

CacheRef Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheRef.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CacheRef Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheRef.ToString Method

public override string ToString();

See Also

CacheRef Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog Class

For a list of all members of this type, see Catalog Members.

System.Object
CatalogBase
Catalog

public class Catalog : CatalogBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Catalog Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog Members

Catalog overview

Public Instance Constructors

Catalog Constructor

Public Instance Methods

discard | Discards all cached data for this Catalog. A subsequent get() will re-fetch the data from the server (even when MPX is enabled).
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
get |
getAllIDs | Returns a list of the object IDs currently stored in the catalog.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getPrimaryDescriptor |
getPropertyIDs | Returns an array of property IDs for which this catalog has data.
GetType (inherited from Object) | Gets the Type of the current instance.
hasID |
isRefreshIDsRequired |
isRefreshRequired | Returns true if a refresh() operation might have resulted in the catalog information being updated; returns false if and only if it is known that the catalog information had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() returns true.
MemberwiseClone (inherited from com.starbase.starteam.CatalogBase) |
populate | Fetch the catalog data if needed. If the data has already been fetched then this is essentially a no-op.
refresh | Update the contents of the Catalog to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unneccessary server commands.
refreshIDs |
ToString (inherited from com.starbase.starteam.CatalogBase) |

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog Constructor

NOTE: This constructor is now obsolete.

public Catalog(
Server server,
Type type,
Int32 viewScopeID
);

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog Methods

The methods of the Catalog class are listed below. For a complete list of Catalog class members, see the Catalog Members topic.

Public Instance Methods

discard | Discards all cached data for this Catalog. A subsequent get() will re-fetch the data from the server (even when MPX is enabled).
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
get |
getAllIDs | Returns a list of the object IDs currently stored in the catalog.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getPrimaryDescriptor |
getPropertyIDs | Returns an array of property IDs for which this catalog has data.
GetType (inherited from Object) | Gets the Type of the current instance.
hasID |
isRefreshIDsRequired |
isRefreshRequired | Returns true if a refresh() operation might have resulted in the catalog information being updated; returns false if and only if it is known that the catalog information had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() returns true.
MemberwiseClone (inherited from com.starbase.starteam.CatalogBase) |
populate | Fetch the catalog data if needed. If the data has already been fetched then this is essentially a no-op.
refresh | Update the contents of the Catalog to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unneccessary server commands.
refreshIDs |
ToString (inherited from com.starbase.starteam.CatalogBase) |

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog.discard Method

Discards all cached data for this Catalog. A subsequent get() will re-fetch the data from the server (even when MPX is enabled).

public override void discard();

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog.get Method

public override object get(
Int32 objectID,
Int32 propertyID
);

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog.getAllIDs Method

Returns a list of the object IDs currently stored in the catalog.

public override int[] getAllIDs();

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog.getPrimaryDescriptor Method

public override object getPrimaryDescriptor(
Int32 objectID
);

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog.getPropertyIDs Method

Returns an array of property IDs for which this catalog has data.

public override int[] getPropertyIDs();

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog.hasID Method

public override bool hasID(
Int32 id
);

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog.isRefreshIDsRequired Method

public override bool isRefreshIDsRequired(
Int32[] objIDs
);

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog.isRefreshRequired Method

Returns true if a refresh() operation might have resulted in the catalog information being updated; returns false if and only if it is known that the catalog information had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() returns true.

public override bool isRefreshRequired();

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog.populate Method

Fetch the catalog data if needed. If the data has already been fetched then this is essentially a no-op.

public override void populate();

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog.refresh Method

Update the contents of the Catalog to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unneccessary server commands.

public override void refresh();

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Catalog.refreshIDs Method

public override void refreshIDs(
Int32[] objectIDs
);

See Also

Catalog Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest Class

For a list of all members of this type, see ChangeRequest Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Item
ChangeRequest

public class ChangeRequest : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ChangeRequest Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest Members

ChangeRequest overview

Public Instance Constructors

ChangeRequest Constructor Constructs a new ChangeRequest in the specified folder.

Public Instance Methods

acquireOwnership (inherited from Item)
addAttachment (inherited from Item)
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals
get (inherited from Item)
getACL (inherited from Item)
getAddressedBy | Returns the user ID for the user that addressed this request.
getAddressedIn | Returns a label ID representing the build or named configuration that this request was addressed in. This only applies to requests that are in a resolved state.
getAddressedInView | Returns the ID of the view from which this Change Request was addressed.
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getCategory | Returns the category of this request.
getClosedOn | Returns the date that this request was given a closed status.
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getComponent | Returns the component this request applies to.
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDescription | Returns the description of this change request.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getExternalReference | Returns a string value that represents some external reference, such as an identification number identifying this request in another system.
getFix | Returns the fix for this change request. This should be a description of the solution for the deficiency described by this request.
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLastBuildTested | Returns a label ID of the build or named configuration that this request was last tested in.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getNumber | Returns the numeric identifier of this change request in the StarTeam view.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPlatform | Returns the platform this Change Request applies to.
getPlatformDisplayName
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossiblePlatform | Returns the possible enum codes that are valid transition values for the Platform property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossiblePriority | Returns the possible enum codes that are valid transition values for the Priority property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleRequestType | Returns the possible enum codes that are valid transition values for the RequestType property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleSeverity | Returns the possible enum codes that are valid transition values for the Severity property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleStatus | Returns the possible enum codes that are valid transition values for the Status property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPriority | Returns the relative priority of this Change Request.
getPriorityDisplayName
getPropertyNames (inherited from Item)
getReadStatus
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRequestType | Returns this change request's type. The type denotes whether this request is a defect report or a feature enhancement.
getRequestTypeDisplayName
getResolvedOn | Returns the date that this Change Request was resolved.
getResponsibility | Returns the user ID that is currently responsible for this request.
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getSeverity | Return the relative severity of the condition that this Change Request represents.
getSeverityDisplayName
getStatus | Returns the status (Open, Fixed, Closed, etc.) of this Change Request.
getStatusDisplayName
getString (inherited from Item)
getSynopsis | Returns the synopsis or brief description of this request.
getTestCommand | Returns the test command string for this change request. This should be a string that can be used to launch a test to verify resolution of this request.
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getVerifiedOn | Returns the date that this Change Request was verified.
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
getWorkAround | Returns the workaround for this change request. This should be description of a possible way to avoid or render harmless the deficiency described by this request.
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move (inherited from Item) | Obsolete. Moves this item to the specified folder. The item will be removed from its current folder.
moveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put (inherited from Item)
putByPropertyID (inherited from Item)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
removeAttachment (inherited from Item)
removeFromIntArray (inherited from TypedResource)
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setAddressedBy
setAddressedIn
setAddressedInView
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setCategory
setComment (inherited from Item)
setComponent
setDescription
setExternalReference
setFix
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setLastBuildTested
setPlatform
setPriority
setRequestType
setResponsibility
setSeverity
setStatus
setSynopsis
setTestCommand
setWorkAround
shareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. <p> If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update
updateRevisionComment (inherited from Item)

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest Constructor

Constructs a new ChangeRequest in the specified folder.

public ChangeRequest(
Folder parentFolder
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest Methods

The methods of the ChangeRequest class are listed below. For a complete list of ChangeRequest class members, see the ChangeRequest Members topic.

Public Instance Methods

acquireOwnership (inherited from Item)
addAttachment (inherited from Item)
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals
get (inherited from Item)
getACL (inherited from Item)
getAddressedBy | Returns the user ID for the user that addressed this request.
getAddressedIn | Returns a label ID representing the build or named configuration that this request was addressed in. This only applies to requests that are in a resolved state.
getAddressedInView | Returns the ID of the view from which this Change Request was addressed.
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getCategory | Returns the category of this request.
getClosedOn | Returns the date that this request was given a closed status.
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getComponent | Returns the component this request applies to.
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDescription | Returns the description of this change request.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getExternalReference | Returns a string value that represents some external reference, such as an identification number identifying this request in another system.
getFix | Returns the fix for this change request. This should be a description of the solution for the deficiency described by this request.
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLastBuildTested | Returns a label ID of the build or named configuration that this request was last tested in.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getNumber | Returns the numeric identifier of this change request in the StarTeam view.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPlatform | Returns the platform this Change Request applies to.
getPlatformDisplayName
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossiblePlatform | Returns the possible enum codes that are valid transition values for the Platform property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossiblePriority | Returns the possible enum codes that are valid transition values for the Priority property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleRequestType | Returns the possible enum codes that are valid transition values for the RequestType property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleSeverity | Returns the possible enum codes that are valid transition values for the Severity property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleStatus | Returns the possible enum codes that are valid transition values for the Status property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPriority | Returns the relative priority of this Change Request.
getPriorityDisplayName
getPropertyNames (inherited from Item)
getReadStatus
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRequestType | Returns this change request's type. The type denotes whether this request is a defect report or a feature enhancement.
getRequestTypeDisplayName
getResolvedOn | Returns the date that this Change Request was resolved.
getResponsibility | Returns the user ID that is currently responsible for this request.
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getSeverity | Return the relative severity of the condition that this Change Request represents.
getSeverityDisplayName
getStatus | Returns the status (Open, Fixed, Closed, etc.) of this Change Request.
getStatusDisplayName
getString (inherited from Item)
getSynopsis | Returns the synopsis or brief description of this request.
getTestCommand | Returns the test command string for this change request. This should be a string that can be used to launch a test to verify resolution of this request.
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getVerifiedOn | Returns the date that this Change Request was verified.
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
getWorkAround | Returns the workaround for this change request. This should be description of a possible way to avoid or render harmless the deficiency described by this request.
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move (inherited from Item) | Obsolete. Moves this item to the specified folder. The item will be removed from its current folder.
moveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put (inherited from Item)
putByPropertyID (inherited from Item)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
removeAttachment (inherited from Item)
removeFromIntArray (inherited from TypedResource)
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setAddressedBy
setAddressedIn
setAddressedInView
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setCategory
setComment (inherited from Item)
setComponent
setDescription
setExternalReference
setFix
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setLastBuildTested
setPlatform
setPriority
setRequestType
setResponsibility
setSeverity
setStatus
setSynopsis
setTestCommand
setWorkAround
shareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. <p> If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update
updateRevisionComment (inherited from Item)

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.Equals Method

public override bool Equals(
Object source
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getAddressedBy Method

Returns the user ID for the user that addressed this request.

public virtual int getAddressedBy();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getAddressedIn Method

Returns a label ID representing the build or named configuration that this request was addressed in. This only applies to requests that are in a resolved state.

public virtual int getAddressedIn();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getAddressedInView Method

Returns the ID of the view from which this Change Request was addressed.

public virtual int getAddressedInView();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getCategory Method

Returns the category of this request.

public virtual string getCategory();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getClosedOn Method

Returns the date that this request was given a closed status.

public virtual OLEDate getClosedOn();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getComponent Method

Returns the component this request applies to.

public virtual string getComponent();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getDescription Method

Returns the description of this change request.

public virtual string getDescription();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getExternalReference Method

Returns a string value that represents some external reference, such as an identification number identifying this request in another system.

public virtual string getExternalReference();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getFix Method

Returns the fix for this change request. This should be a description of the solution for the deficiency described by this request.

public virtual string getFix();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.GetHashCode Method

public override int GetHashCode();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getLastBuildTested Method

Returns a label ID of the build or named configuration that this request was last tested in.

public virtual int getLastBuildTested();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getNumber Method

Returns the numeric identifier of this change request in the StarTeam view.

public virtual int getNumber();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getPlatform Method

Returns the platform this Change Request applies to.

public virtual int getPlatform();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getPlatformDisplayName Method

public virtual string getPlatformDisplayName(
Int32 value
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getPossiblePlatform Method

Returns the possible enum codes that are valid transition values for the Platform property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossiblePlatform();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getPossiblePriority Method

Returns the possible enum codes that are valid transition values for the Priority property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossiblePriority();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getPossibleRequestType Method

Returns the possible enum codes that are valid transition values for the RequestType property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleRequestType();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getPossibleSeverity Method

Returns the possible enum codes that are valid transition values for the Severity property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleSeverity();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getPossibleStatus Method

Returns the possible enum codes that are valid transition values for the Status property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleStatus();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getPriority Method

Returns the relative priority of this Change Request.

public virtual int getPriority();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getPriorityDisplayName Method

public virtual string getPriorityDisplayName(
Int32 value
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getReadStatus Method

public override int getReadStatus();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getRequestType Method

Returns this change request's type. The type denotes whether this request is a defect report or a feature enhancement.

public virtual int getRequestType();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getRequestTypeDisplayName Method

public virtual string getRequestTypeDisplayName(
Int32 value
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getResolvedOn Method

Returns the date that this Change Request was resolved.

public virtual OLEDate getResolvedOn();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getResponsibility Method

Returns the user ID that is currently responsible for this request.

public virtual int getResponsibility();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getSeverity Method

Return the relative severity of the condition that this Change Request represents.

public virtual int getSeverity();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getSeverityDisplayName Method

public virtual string getSeverityDisplayName(
Int32 value
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getStatus Method

Returns the status (Open, Fixed, Closed, etc.) of this Change Request.

public virtual int getStatus();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getStatusDisplayName Method

public virtual string getStatusDisplayName(
Int32 value
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getSynopsis Method

Returns the synopsis or brief description of this request.

public virtual string getSynopsis();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getTestCommand Method

Returns the test command string for this change request. This should be a string that can be used to launch a test to verify resolution of this request.

public virtual string getTestCommand();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getVerifiedOn Method

Returns the date that this Change Request was verified.

public virtual OLEDate getVerifiedOn();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.getWorkAround Method

Returns the workaround for this change request. This should be description of a possible way to avoid or render harmless the deficiency described by this request.

public virtual string getWorkAround();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setAddressedBy Method

public virtual void setAddressedBy(
Int32 userID
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setAddressedIn Method

public virtual void setAddressedIn(
Int32 labelID
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setAddressedInView Method

public virtual void setAddressedInView(
Int32 viewID
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setCategory Method

public virtual void setCategory(
String category
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setComponent Method

public virtual void setComponent(
String component
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setDescription Method

public virtual void setDescription(
String description
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setExternalReference Method

public virtual void setExternalReference(
String reference
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setFix Method

public virtual void setFix(
String fix
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setLastBuildTested Method

public virtual void setLastBuildTested(
Int32 labelID
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setPlatform Method

public virtual void setPlatform(
Int32 platform
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setPriority Method

public virtual void setPriority(
Int32 priority
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setRequestType Method

public virtual void setRequestType(
Int32 type
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setResponsibility Method

public virtual void setResponsibility(
Int32 userID
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setSeverity Method

public virtual void setSeverity(
Int32 severity
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setStatus Method

public virtual void setStatus(
Int32 status
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setSynopsis Method

public virtual void setSynopsis(
String synopsis
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setTestCommand Method

public virtual void setTestCommand(
String testCommand
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.setWorkAround Method

public virtual void setWorkAround(
String workAround
);

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.ToString Method

public override string ToString();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ChangeRequest.update Method

public override void update();

See Also

ChangeRequest Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharacterSet Class

For a list of all members of this type, see CharacterSet Members.

System.Object
EnumeratedValue
CharacterSet

public class CharacterSet : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CharacterSet Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharacterSet Members

CharacterSet overview

Public Static Fields

ALL
ASCII
BINARY
UNICODE

Public Instance Methods

copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Equals (inherited from EnumeratedValue) |
getCode (inherited from EnumeratedValue) | Return the enum code for this object.
getDescription (inherited from EnumeratedValue) | Returns the description of this object. This may return null if the object was created using a Translations.
getDisplayName (inherited from EnumeratedValue) | Returns the locale appropriate display name for the enumerated value.
getEnabled (inherited from EnumeratedValue) | Return true if this enumerated value is enabled.
GetHashCode (inherited from EnumeratedValue) |
getSortOrder (inherited from EnumeratedValue) | Get the sort order of this enumerated value.
getTranslations (inherited from EnumeratedValue) | Returns the display name translations for this enumerated value. May return null if this was created usng a single description string.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from EnumeratedValue) |
setCode (inherited from EnumeratedValue) |
setDescription (inherited from EnumeratedValue) |
setEnabled (inherited from EnumeratedValue) |
setTranslations (inherited from EnumeratedValue) | Sets the display name translations for this enumerated value.
ToString (inherited from EnumeratedValue) |

See Also

CharacterSet Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharacterSet Fields

The fields of the CharacterSet class are listed below. For a complete list of CharacterSet class members, see the CharacterSet Members topic.

Public Static Fields

ALL
ASCII
BINARY
UNICODE

See Also

CharacterSet Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharacterSet.ALL Field

public static readonly CharacterSet[] ALL;

See Also

CharacterSet Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharacterSet.ASCII Field

public static readonly CharacterSet ASCII;

See Also

CharacterSet Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharacterSet.BINARY Field

public static readonly CharacterSet BINARY;

See Also

CharacterSet Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CharacterSet.UNICODE Field

public static readonly CharacterSet UNICODE;

See Also

CharacterSet Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent Class

For a list of all members of this type, see CheckinEvent Members.

System.Object
EventObject
CheckinEvent

public class CheckinEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckinEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent Members

CheckinEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
getCheckinManager | Gets the CheckinManager that triggered this CheckinEvent.
getCheckinResult | Gets details describing the result of this checkin.
getCurrentFile | Gets the StarTeam File being checked in.
getCurrentWorkingFile | Gets the working file on disk where this file is being checked in from.
getError |
getErrorMessage | The error message for the error that occurred during the checkin of this file.
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getOptions | Gets the checkin options that apply to the current file. <p> To override any of the options for the current file, change them in the onStartFile event handler.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
isCanceled | Indicates whether or not the overall checkin operation has been canceled.
isFinished | Indicates whether or not the checkin operation for this file is finished.
isSuccessful | Indicates whether or not the checkin operation for this file has finished successfully.
MemberwiseClone |
setCurrentWorkingFile | Sets the working file on disk where this file is being checked in from.
ToString |

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent Methods

The methods of the CheckinEvent class are listed below. For a complete list of CheckinEvent class members, see the CheckinEvent Members topic.

Public Instance Methods

Equals |
getCheckinManager | Gets the CheckinManager that triggered this CheckinEvent.
getCheckinResult | Gets details describing the result of this checkin.
getCurrentFile | Gets the StarTeam File being checked in.
getCurrentWorkingFile | Gets the working file on disk where this file is being checked in from.
getError |
getErrorMessage | The error message for the error that occurred during the checkin of this file.
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getOptions | Gets the checkin options that apply to the current file. <p> To override any of the options for the current file, change them in the onStartFile event handler.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
isCanceled | Indicates whether or not the overall checkin operation has been canceled.
isFinished | Indicates whether or not the checkin operation for this file is finished.
isSuccessful | Indicates whether or not the checkin operation for this file has finished successfully.
MemberwiseClone |
setCurrentWorkingFile | Sets the working file on disk where this file is being checked in from.
ToString |

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.Equals Method

public override bool Equals(
Object source
);

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.getCheckinManager Method

Gets the CheckinManager that triggered this CheckinEvent.

public virtual CheckinManager getCheckinManager();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.getCheckinResult Method

Gets details describing the result of this checkin.

public virtual CheckInResult getCheckinResult();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.getCurrentFile Method

Gets the StarTeam File being checked in.

public virtual File getCurrentFile();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.getCurrentWorkingFile Method

Gets the working file on disk where this file is being checked in from.

public virtual File getCurrentWorkingFile();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.getError Method

public virtual Throwable getError();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.getErrorMessage Method

The error message for the error that occurred during the checkin of this file.

public virtual string getErrorMessage();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.GetHashCode Method

public override int GetHashCode();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.getOptions Method

Gets the checkin options that apply to the current file. <p> To override any of the options for the current file, change them in the onStartFile event handler.

public virtual CheckinOptions getOptions();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.getSource Method

public override object getSource();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.isCanceled Method

Indicates whether or not the overall checkin operation has been canceled.

public virtual bool isCanceled();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.isFinished Method

Indicates whether or not the checkin operation for this file is finished.

public virtual bool isFinished();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.isSuccessful Method

Indicates whether or not the checkin operation for this file has finished successfully.

public virtual bool isSuccessful();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.setCurrentWorkingFile Method

Sets the working file on disk where this file is being checked in from.

public virtual void setCurrentWorkingFile(
File workingFile
);

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinEvent.ToString Method

public override string ToString();

See Also

CheckinEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinListener Interface

For a list of all members of this type, see CheckinListener Members.

public interface CheckinListener : EventListener

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckinListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinListener Members

CheckinListener overview

Public Instance Methods

onNotifyProgress | Triggered during the checkin operation, to provide the client application with updated information about the progress of the operation. <p> If the checkin of a given file completes successfully, then the onNotifyProgress event is triggered with CheckinEvent.isFinished() and CheckinEvent.isSuccessfull() both returning true. <p> If the checkin of a given file terminates abnormally, then the onNotifyProgress event is triggered with CheckinEvent.isSuccessful() returning false. <p> If the checkin operation is canceled, then the onNotifyProgress event is triggered once for every file that has not yet completed. In this case, CheckinEvent.isCanceled() returns true.
onStartFile | Triggered once per file, at the start of the checkin operation for that file. This provides the client application with an opportunity to override any of the checkin parameters on a file-by-file basis, or to cancel the checkin process.

See Also

CheckinListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinListener Methods

The methods of the CheckinListener interface are listed below. For a complete list of CheckinListener interface members, see the CheckinListener Members topic.

Public Instance Methods

onNotifyProgress | Triggered during the checkin operation, to provide the client application with updated information about the progress of the operation. <p> If the checkin of a given file completes successfully, then the onNotifyProgress event is triggered with CheckinEvent.isFinished() and CheckinEvent.isSuccessfull() both returning true. <p> If the checkin of a given file terminates abnormally, then the onNotifyProgress event is triggered with CheckinEvent.isSuccessful() returning false. <p> If the checkin operation is canceled, then the onNotifyProgress event is triggered once for every file that has not yet completed. In this case, CheckinEvent.isCanceled() returns true.
onStartFile | Triggered once per file, at the start of the checkin operation for that file. This provides the client application with an opportunity to override any of the checkin parameters on a file-by-file basis, or to cancel the checkin process.

See Also

CheckinListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinListener.onNotifyProgress Method

Triggered during the checkin operation, to provide the client application with updated information about the progress of the operation. <p> If the checkin of a given file completes successfully, then the onNotifyProgress event is triggered with CheckinEvent.isFinished() and CheckinEvent.isSuccessfull() both returning true. <p> If the checkin of a given file terminates abnormally, then the onNotifyProgress event is triggered with CheckinEvent.isSuccessful() returning false. <p> If the checkin operation is canceled, then the onNotifyProgress event is triggered once for every file that has not yet completed. In this case, CheckinEvent.isCanceled() returns true.

void onNotifyProgress(
CheckinEvent event
);

See Also

CheckinListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinListener.onStartFile Method

Triggered once per file, at the start of the checkin operation for that file. This provides the client application with an opportunity to override any of the checkin parameters on a file-by-file basis, or to cancel the checkin process.

void onStartFile(
CheckinEvent event
);

See Also

CheckinListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager Class

For a list of all members of this type, see CheckinManager Members.

System.Object
CheckinManager

public class CheckinManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckinManager Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager Members

CheckinManager overview

Public Instance Constructors

CheckinManager Overloaded. Initializes a new instance of the CheckinManager class.

Public Instance Methods

addCheckinListener | Adds a listener for checkin-related events.
checkin | Overloaded. Checks in a single file from the default location.
checkinFrom | Overloaded.
Equals |
GetHashCode |
getOptions | Gets the checkin options currently in effect. <p> Note that individual options can be overridden on a file-by-file basis by registering a CheckinListener, and changing options as necessary in the onStartFile event handler.
getProgress | Gets a snapshot of the state of the current checkin operation.
GetType (inherited from Object) | Gets the Type of the current instance.
isCanceled | Indicates whether or not pending checkin operations have been canceled.
isRunning | Determines whether or not there is currently a checkin operation in progress.
MemberwiseClone |
removeCheckinListener | Removes a listener for checkin-related events.
setCanceled | Cancels any pending checkin operations.
setOptions | Changes the checkin options currently in effect.
ToString |

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager Constructor

NOTE: This constructor is now obsolete.

Constructs a CheckinManager with default options.

Overload List

Obsolete. Constructs a CheckinManager with default options.

public CheckinManager(View);

Obsolete.

public CheckinManager(View,CheckinManager);

Obsolete.

public CheckinManager(View,CheckinOptions);

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager Constructor (View)

NOTE: This constructor is now obsolete.

Constructs a CheckinManager with default options.

public CheckinManager(
View view
);

See Also

CheckinManager Class | com.starbase.starteam Namespace | CheckinManager Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager Constructor (View, CheckinOptions)

NOTE: This constructor is now obsolete.

public CheckinManager(
View view,
CheckinOptions options
);

See Also

CheckinManager Class | com.starbase.starteam Namespace | CheckinManager Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager Constructor (View, CheckinManager)

NOTE: This constructor is now obsolete.

public CheckinManager(
View view,
CheckinManager checkinManager
);

See Also

CheckinManager Class | com.starbase.starteam Namespace | CheckinManager Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager Methods

The methods of the CheckinManager class are listed below. For a complete list of CheckinManager class members, see the CheckinManager Members topic.

Public Instance Methods

addCheckinListener | Adds a listener for checkin-related events.
checkin | Overloaded. Checks in a single file from the default location.
checkinFrom | Overloaded.
Equals |
GetHashCode |
getOptions | Gets the checkin options currently in effect. <p> Note that individual options can be overridden on a file-by-file basis by registering a CheckinListener, and changing options as necessary in the onStartFile event handler.
getProgress | Gets a snapshot of the state of the current checkin operation.
GetType (inherited from Object) | Gets the Type of the current instance.
isCanceled | Indicates whether or not pending checkin operations have been canceled.
isRunning | Determines whether or not there is currently a checkin operation in progress.
MemberwiseClone |
removeCheckinListener | Removes a listener for checkin-related events.
setCanceled | Cancels any pending checkin operations.
setOptions | Changes the checkin options currently in effect.
ToString |

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.addCheckinListener Method

Adds a listener for checkin-related events.

public virtual void addCheckinListener(
CheckinListener listener
);

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


checkin Method

Borland StarTeam SDK for .NET

CheckinManager.checkin Method

Checks in a single file from the default location.

Overload List

Checks in a single file from the default location.

public virtual void checkin(File);

Checks in all the files in the given folder.

public virtual void checkin(Folder);

public virtual void checkin(Folder,Int32);

public virtual void checkin(Item[]);

Checks in the given set of files.

public virtual void checkin(ItemList);

Checks in the given set of files.

public virtual void checkin(Items);

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.checkin Method (File)

Checks in a single file from the default location.

public virtual void checkin(
File file
);

See Also

CheckinManager Class | com.starbase.starteam Namespace | CheckinManager.checkin Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.checkin Method (Folder)

Checks in all the files in the given folder.

public virtual void checkin(
Folder folder
);

See Also

CheckinManager Class | com.starbase.starteam Namespace | CheckinManager.checkin Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.checkin Method (Folder, Int32)

public virtual void checkin(
Folder folder,
Int32 depth
);

See Also

CheckinManager Class | com.starbase.starteam Namespace | CheckinManager.checkin Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.checkin Method (Item[])

public virtual void checkin(
Item[] files
);

See Also

CheckinManager Class | com.starbase.starteam Namespace | CheckinManager.checkin Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.checkin Method (ItemList)

Checks in the given set of files.

public virtual void checkin(
ItemList files
);

See Also

CheckinManager Class | com.starbase.starteam Namespace | CheckinManager.checkin Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.checkin Method (Items)

Checks in the given set of files.

public virtual void checkin(
Items files
);

See Also

CheckinManager Class | com.starbase.starteam Namespace | CheckinManager.checkin Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


checkinFrom Method

Borland StarTeam SDK for .NET

CheckinManager.checkinFrom Method

Overload List

public virtual void checkinFrom(File,File);

public virtual void checkinFrom(File,InputStream);

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.checkinFrom Method (File, File)

public virtual void checkinFrom(
File file,
File workingFile
);

See Also

CheckinManager Class | com.starbase.starteam Namespace | CheckinManager.checkinFrom Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.checkinFrom Method (File, InputStream)

public virtual void checkinFrom(
File file,
InputStream stream
);

See Also

CheckinManager Class | com.starbase.starteam Namespace | CheckinManager.checkinFrom Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.Equals Method

public override bool Equals(
Object source
);

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.GetHashCode Method

public override int GetHashCode();

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.getOptions Method

Gets the checkin options currently in effect. <p> Note that individual options can be overridden on a file-by-file basis by registering a CheckinListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckinOptions getOptions();

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.getProgress Method

Gets a snapshot of the state of the current checkin operation.

public virtual CheckinProgress getProgress();

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.isCanceled Method

Indicates whether or not pending checkin operations have been canceled.

public virtual bool isCanceled();

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.isRunning Method

Determines whether or not there is currently a checkin operation in progress.

public virtual bool isRunning();

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.removeCheckinListener Method

Removes a listener for checkin-related events.

public virtual void removeCheckinListener(
CheckinListener listener
);

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.setCanceled Method

Cancels any pending checkin operations.

public virtual void setCanceled();

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.setOptions Method

Changes the checkin options currently in effect.

public virtual void setOptions(
CheckinOptions checkinOptions
);

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinManager.ToString Method

public override string ToString();

See Also

CheckinManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions Class

For a list of all members of this type, see CheckinOptions Members.

System.Object
CheckinOptions

public class CheckinOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckinOptions Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions Members

CheckinOptions overview

Public Instance Constructors

CheckinOptions Overloaded. Initializes a new instance of the CheckinOptions class.

Public Instance Methods

Equals |
getAtomicCheckInDisabled | Returns the "Atomic Checkin Disabled" option value. The default value is false, meaning the feature will not be disabled if it is available from the server. Note that this is not re-evaluated on a per-file basis.
getAttachNewLabelsOnly | Determines under what conditions the specified revision label should be attached to the new file revision on checkin.
getCharacterSet | Gets the Character Set to be used for this file. <p> Default value is null, which leaves any previously specified Character Set unchanged. If the Character Set was not previously specified, the value will be inferred automatically from the file content.
getCheckinReason | Returns the "Checkin Reason" option value.
getCRsToMarkFixed | Returns the ChangeRequests to mark fixed.
getDeleteWorkingFile | Returns the "Delete Working File" option value.
getEOLConversionEnabled | Obsolete. Return whether EOL conversion is enabled when checking out text files.
getEOLFormat | Gets the End-of-Line format to be used for this file. <p> Default value is null, which leaves any previously specified End-of-Line format unchanged. If the End-of-Line format was not previously specified, the value will be inferred automatically from the file content. The End-of-Line format is ignored for binary files.
getFileEncoding | Returns the "File Encoding" option value.
getForceCheckin | Returns the "Force Checkin" option value.
GetHashCode |
getKeywordExpansionEnabled | Determin whether keyword expansion in text files is enabled.
getLockType | Return the type of lock to be used when checking out. Default is UNCHANGED. It may be one of these values: UNLOCKED, EXCLUSIVE, NONEXCLUSIVE, UNCHANGED, and BREAK_FLAG.
getMarkProcessItemComplete | Returns whether to mark the process item complete.
getMarkUnlockedFilesReadOnly | Returns the "Mark Unlocked Files ReadOnly" option value.
getMoveRevisionLabelIfAssigned | Obsolete. Returns whether to move the revision label if file already has one attached.
getProcessItem | Returns the process item to link and pin.
getRestoreFileOnError | Determine whether to restore previous working file if an error occurs during a checkout.
getRevisionLabel | Returns the revision label to attach.
GetType (inherited from Object) | Gets the Type of the current instance.
getUpdateStatus | Determine whether to update status information after a successful checkout.
isFileSkipped | Returns whether to skip checking out files or the file associated with this CheckinOptions object.
MemberwiseClone |
setAtomicCheckInDisabled |
setAttachNewLabelsOnly |
setCharacterSet | Sets the Character Set to be used for this file.
setCheckinReason |
setCRsToMarkFixed |
setDeleteWorkingFile |
setEOLConversionEnabled | Obsolete.
setEOLFormat | Sets the End-of-Line format to be used for this file.
setFileEncoding |
setFileSkipped |
setForceCheckin |
setKeywordExpansionEnabled |
setLockType |
setMarkProcessItemComplete |
setMarkUnlockedFilesReadOnly |
setMoveRevisionLabelIfAssigned | Obsolete.
setProcessItem | Sets the process item to link and pin.
setRestoreFileOnError |
setRevisionLabel | Sets the revision label to attach.
setUpdateStatus |
ToString |

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions Constructor

Construct a CheckinOptions object with default options from the View.

Overload List

Construct a CheckinOptions object with the same options as the given one.

public CheckinOptions(CheckinOptions);

Construct a CheckinOptions object with default options from a StarTeamClientOptions object.

public CheckinOptions(StarTeamClientOptions);

Construct a CheckinOptions object with default options from the View.

public CheckinOptions(View);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions Constructor (View)

Construct a CheckinOptions object with default options from the View.

public CheckinOptions(
View view
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace | CheckinOptions Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions Constructor (StarTeamClientOptions)

Construct a CheckinOptions object with default options from a StarTeamClientOptions object.

public CheckinOptions(
StarTeamClientOptions options
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace | CheckinOptions Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions Constructor (CheckinOptions)

Construct a CheckinOptions object with the same options as the given one.

public CheckinOptions(
CheckinOptions options
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace | CheckinOptions Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions Methods

The methods of the CheckinOptions class are listed below. For a complete list of CheckinOptions class members, see the CheckinOptions Members topic.

Public Instance Methods

Equals |
getAtomicCheckInDisabled | Returns the "Atomic Checkin Disabled" option value. The default value is false, meaning the feature will not be disabled if it is available from the server. Note that this is not re-evaluated on a per-file basis.
getAttachNewLabelsOnly | Determines under what conditions the specified revision label should be attached to the new file revision on checkin.
getCharacterSet | Gets the Character Set to be used for this file. <p> Default value is null, which leaves any previously specified Character Set unchanged. If the Character Set was not previously specified, the value will be inferred automatically from the file content.
getCheckinReason | Returns the "Checkin Reason" option value.
getCRsToMarkFixed | Returns the ChangeRequests to mark fixed.
getDeleteWorkingFile | Returns the "Delete Working File" option value.
getEOLConversionEnabled | Obsolete. Return whether EOL conversion is enabled when checking out text files.
getEOLFormat | Gets the End-of-Line format to be used for this file. <p> Default value is null, which leaves any previously specified End-of-Line format unchanged. If the End-of-Line format was not previously specified, the value will be inferred automatically from the file content. The End-of-Line format is ignored for binary files.
getFileEncoding | Returns the "File Encoding" option value.
getForceCheckin | Returns the "Force Checkin" option value.
GetHashCode |
getKeywordExpansionEnabled | Determin whether keyword expansion in text files is enabled.
getLockType | Return the type of lock to be used when checking out. Default is UNCHANGED. It may be one of these values: UNLOCKED, EXCLUSIVE, NONEXCLUSIVE, UNCHANGED, and BREAK_FLAG.
getMarkProcessItemComplete | Returns whether to mark the process item complete.
getMarkUnlockedFilesReadOnly | Returns the "Mark Unlocked Files ReadOnly" option value.
getMoveRevisionLabelIfAssigned | Obsolete. Returns whether to move the revision label if file already has one attached.
getProcessItem | Returns the process item to link and pin.
getRestoreFileOnError | Determine whether to restore previous working file if an error occurs during a checkout.
getRevisionLabel | Returns the revision label to attach.
GetType (inherited from Object) | Gets the Type of the current instance.
getUpdateStatus | Determine whether to update status information after a successful checkout.
isFileSkipped | Returns whether to skip checking out files or the file associated with this CheckinOptions object.
MemberwiseClone |
setAtomicCheckInDisabled |
setAttachNewLabelsOnly |
setCharacterSet | Sets the Character Set to be used for this file.
setCheckinReason |
setCRsToMarkFixed |
setDeleteWorkingFile |
setEOLConversionEnabled | Obsolete.
setEOLFormat | Sets the End-of-Line format to be used for this file.
setFileEncoding |
setFileSkipped |
setForceCheckin |
setKeywordExpansionEnabled |
setLockType |
setMarkProcessItemComplete |
setMarkUnlockedFilesReadOnly |
setMoveRevisionLabelIfAssigned | Obsolete.
setProcessItem | Sets the process item to link and pin.
setRestoreFileOnError |
setRevisionLabel | Sets the revision label to attach.
setUpdateStatus |
ToString |

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.Equals Method

public override bool Equals(
Object another
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getAtomicCheckInDisabled Method

Returns the "Atomic Checkin Disabled" option value. The default value is false, meaning the feature will not be disabled if it is available from the server. Note that this is not re-evaluated on a per-file basis.

public virtual bool getAtomicCheckInDisabled();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getAttachNewLabelsOnly Method

Determines under what conditions the specified revision label should be attached to the new file revision on checkin.

public virtual bool getAttachNewLabelsOnly();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getCharacterSet Method

Gets the Character Set to be used for this file. <p> Default value is null, which leaves any previously specified Character Set unchanged. If the Character Set was not previously specified, the value will be inferred automatically from the file content.

public virtual CharacterSet getCharacterSet();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getCheckinReason Method

Returns the "Checkin Reason" option value.

public virtual string getCheckinReason();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getCRsToMarkFixed Method

Returns the ChangeRequests to mark fixed.

public virtual ChangeRequest[] getCRsToMarkFixed();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getDeleteWorkingFile Method

Returns the "Delete Working File" option value.

public virtual bool getDeleteWorkingFile();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getEOLConversionEnabled Method

NOTE: This method is now obsolete.

Return whether EOL conversion is enabled when checking out text files.

public virtual bool getEOLConversionEnabled();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getEOLFormat Method

Gets the End-of-Line format to be used for this file. <p> Default value is null, which leaves any previously specified End-of-Line format unchanged. If the End-of-Line format was not previously specified, the value will be inferred automatically from the file content. The End-of-Line format is ignored for binary files.

public virtual EOLFormat getEOLFormat();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getFileEncoding Method

Returns the "File Encoding" option value.

public virtual string getFileEncoding();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getForceCheckin Method

Returns the "Force Checkin" option value.

public virtual bool getForceCheckin();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.GetHashCode Method

public override int GetHashCode();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getKeywordExpansionEnabled Method

Determin whether keyword expansion in text files is enabled.

public virtual bool getKeywordExpansionEnabled();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getLockType Method

Return the type of lock to be used when checking out. Default is UNCHANGED. It may be one of these values: UNLOCKED, EXCLUSIVE, NONEXCLUSIVE, UNCHANGED, and BREAK_FLAG.

public virtual int getLockType();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getMarkProcessItemComplete Method

Returns whether to mark the process item complete.

public virtual bool getMarkProcessItemComplete();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getMarkUnlockedFilesReadOnly Method

Returns the "Mark Unlocked Files ReadOnly" option value.

public virtual bool getMarkUnlockedFilesReadOnly();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getMoveRevisionLabelIfAssigned Method

NOTE: This method is now obsolete.

Returns whether to move the revision label if file already has one attached.

public virtual bool getMoveRevisionLabelIfAssigned();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getProcessItem Method

Returns the process item to link and pin.

public virtual Item getProcessItem();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getRestoreFileOnError Method

Determine whether to restore previous working file if an error occurs during a checkout.

public virtual bool getRestoreFileOnError();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getRevisionLabel Method

Returns the revision label to attach.

public virtual Label getRevisionLabel();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.getUpdateStatus Method

Determine whether to update status information after a successful checkout.

public virtual bool getUpdateStatus();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.isFileSkipped Method

Returns whether to skip checking out files or the file associated with this CheckinOptions object.

public virtual bool isFileSkipped();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setAtomicCheckInDisabled Method

public virtual void setAtomicCheckInDisabled(
Boolean bAtomicCheckInDisabled
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setAttachNewLabelsOnly Method

public virtual void setAttachNewLabelsOnly(
Boolean bNewLabelsOnly
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setCharacterSet Method

Sets the Character Set to be used for this file.

public virtual void setCharacterSet(
CharacterSet ce
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setCheckinReason Method

public virtual void setCheckinReason(
String sCheckinReason
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setCRsToMarkFixed Method

public virtual void setCRsToMarkFixed(
ChangeRequest[] changeRequests
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setDeleteWorkingFile Method

public virtual void setDeleteWorkingFile(
Boolean bEnabled
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setEOLConversionEnabled Method

NOTE: This method is now obsolete.

public virtual void setEOLConversionEnabled(
Boolean bEnabled
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setEOLFormat Method

Sets the End-of-Line format to be used for this file.

public virtual void setEOLFormat(
EOLFormat format
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setFileEncoding Method

public virtual void setFileEncoding(
String sEncoding
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setFileSkipped Method

public virtual void setFileSkipped(
Boolean bFileSkipped
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setForceCheckin Method

public virtual void setForceCheckin(
Boolean bEnabled
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setKeywordExpansionEnabled Method

public virtual void setKeywordExpansionEnabled(
Boolean bEnabled
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setLockType Method

public virtual void setLockType(
Int32 lockType
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setMarkProcessItemComplete Method

public virtual void setMarkProcessItemComplete(
Boolean bEnabled
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setMarkUnlockedFilesReadOnly Method

public virtual void setMarkUnlockedFilesReadOnly(
Boolean bMarkUnlockedFilesReadOnly
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setMoveRevisionLabelIfAssigned Method

NOTE: This method is now obsolete.

public virtual void setMoveRevisionLabelIfAssigned(
Boolean bEnabled
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setProcessItem Method

Sets the process item to link and pin.

public virtual void setProcessItem(
Item processItem
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setRestoreFileOnError Method

public virtual void setRestoreFileOnError(
Boolean bEnabled
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setRevisionLabel Method

Sets the revision label to attach.

public virtual void setRevisionLabel(
Label revisionLabel
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.setUpdateStatus Method

public virtual void setUpdateStatus(
Boolean bEnabled
);

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinOptions.ToString Method

public override string ToString();

See Also

CheckinOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase Class

For a list of all members of this type, see CheckinPhase Members.

System.Object
CheckinPhase

public class CheckinPhase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckinPhase Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase Members

CheckinPhase overview

Public Static Fields

ABORTING_CHANGES
CANCELED
COMMITTING_CHANGES
LINKING
POST_PROCESSING
PRE_PROCESSING
UPLOADING_CONTENT

Public Instance Methods

Equals |
GetHashCode |
getName | Get the name of this CheckinPhase.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase Fields

The fields of the CheckinPhase class are listed below. For a complete list of CheckinPhase class members, see the CheckinPhase Members topic.

Public Static Fields

ABORTING_CHANGES
CANCELED
COMMITTING_CHANGES
LINKING
POST_PROCESSING
PRE_PROCESSING
UPLOADING_CONTENT

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.ABORTING_CHANGES Field

public static readonly CheckinPhase ABORTING_CHANGES;

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.CANCELED Field

public static readonly CheckinPhase CANCELED;

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.COMMITTING_CHANGES Field

public static readonly CheckinPhase COMMITTING_CHANGES;

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.LINKING Field

public static readonly CheckinPhase LINKING;

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.POST_PROCESSING Field

public static readonly CheckinPhase POST_PROCESSING;

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.PRE_PROCESSING Field

public static readonly CheckinPhase PRE_PROCESSING;

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.UPLOADING_CONTENT Field

public static readonly CheckinPhase UPLOADING_CONTENT;

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase Methods

The methods of the CheckinPhase class are listed below. For a complete list of CheckinPhase class members, see the CheckinPhase Members topic.

Public Instance Methods

Equals |
GetHashCode |
getName | Get the name of this CheckinPhase.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.Equals Method

public override bool Equals(
Object source
);

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.GetHashCode Method

public override int GetHashCode();

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.getName Method

Get the name of this CheckinPhase.

public virtual string getName();

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinPhase.ToString Method

public override string ToString();

See Also

CheckinPhase Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress Class

For a list of all members of this type, see CheckinProgress Members.

System.Object
CheckinProgress

public class CheckinProgress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckinProgress Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress Members

CheckinProgress overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getCheckinPhase | Return the CheckinPhase associated with this CheckinProgress.
getCurrentPhaseEstimatedTimeRemaining | Return the estimated time remaining in milliseconds.
getCurrentPhaseUnitsOfWork | Get the total number of units of work.
getCurrentPhaseUnitsOfWorkProcessed | Return the number of units of work that has been processed in this phase.
getCurrentPhaseUnitsOfWorkRemaining | Get the total number of units of work that are yet to be done.
getCurrentStarteamItem | Get the current StarTeam Item object that is being processed in the current phase. The return value may be an Item if the currenet phase is iterating over items. Otherwise, a null is returned. For the most part, these Item's are File Objects. However, there can be phases in which other Items are returned, for instance Process Items during a link phase
getCurrentWorkingFile | Get the current File object that's being checked in. The return value may be the actual File, or a null if the phase is not a file-processing phase.
getDescription | Return a description of the current state of CheckinProgress. It's a string concatenating the name of the CheckPhase and the File Name.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLastError |
getSnapshotTime | Return the snapshot time that is set when the last clone was created.
getTotalBytesCheckedIn | Get the total number of bytes that are checked in.
getTotalFilesCheckedIn | Return the number of files that have been checked in.
getTotalFilesFailed | Get the total number of files that failed during checkin.
getTotalFilesForCheckin | Get the total number of files for checkin. The total number of files for checkin is a constant for this instance of the progress object.
getTotalFilesProcessed | Get the total number of files to be checked in.
getTotalFilesRemaining | Return the number of files left to be checked in.
getTotalFilesSkipped | Get the total number of files skipped without being checked in.
getTotalTimeSpent | Get the time spent on checking in in milliseconds.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress Methods

The methods of the CheckinProgress class are listed below. For a complete list of CheckinProgress class members, see the CheckinProgress Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getCheckinPhase | Return the CheckinPhase associated with this CheckinProgress.
getCurrentPhaseEstimatedTimeRemaining | Return the estimated time remaining in milliseconds.
getCurrentPhaseUnitsOfWork | Get the total number of units of work.
getCurrentPhaseUnitsOfWorkProcessed | Return the number of units of work that has been processed in this phase.
getCurrentPhaseUnitsOfWorkRemaining | Get the total number of units of work that are yet to be done.
getCurrentStarteamItem | Get the current StarTeam Item object that is being processed in the current phase. The return value may be an Item if the currenet phase is iterating over items. Otherwise, a null is returned. For the most part, these Item's are File Objects. However, there can be phases in which other Items are returned, for instance Process Items during a link phase
getCurrentWorkingFile | Get the current File object that's being checked in. The return value may be the actual File, or a null if the phase is not a file-processing phase.
getDescription | Return a description of the current state of CheckinProgress. It's a string concatenating the name of the CheckPhase and the File Name.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLastError |
getSnapshotTime | Return the snapshot time that is set when the last clone was created.
getTotalBytesCheckedIn | Get the total number of bytes that are checked in.
getTotalFilesCheckedIn | Return the number of files that have been checked in.
getTotalFilesFailed | Get the total number of files that failed during checkin.
getTotalFilesForCheckin | Get the total number of files for checkin. The total number of files for checkin is a constant for this instance of the progress object.
getTotalFilesProcessed | Get the total number of files to be checked in.
getTotalFilesRemaining | Return the number of files left to be checked in.
getTotalFilesSkipped | Get the total number of files skipped without being checked in.
getTotalTimeSpent | Get the time spent on checking in in milliseconds.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getCheckinPhase Method

Return the CheckinPhase associated with this CheckinProgress.

public virtual CheckinPhase getCheckinPhase();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getCurrentPhaseEstimatedTimeRemaining Method

Return the estimated time remaining in milliseconds.

public virtual long getCurrentPhaseEstimatedTimeRemaining();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getCurrentPhaseUnitsOfWork Method

Get the total number of units of work.

public virtual long getCurrentPhaseUnitsOfWork();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getCurrentPhaseUnitsOfWorkProcessed Method

Return the number of units of work that has been processed in this phase.

public virtual long getCurrentPhaseUnitsOfWorkProcessed();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getCurrentPhaseUnitsOfWorkRemaining Method

Get the total number of units of work that are yet to be done.

public virtual long getCurrentPhaseUnitsOfWorkRemaining();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getCurrentStarteamItem Method

Get the current StarTeam Item object that is being processed in the current phase. The return value may be an Item if the currenet phase is iterating over items. Otherwise, a null is returned. For the most part, these Item's are File Objects. However, there can be phases in which other Items are returned, for instance Process Items during a link phase

public virtual Item getCurrentStarteamItem();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getCurrentWorkingFile Method

Get the current File object that's being checked in. The return value may be the actual File, or a null if the phase is not a file-processing phase.

public virtual File getCurrentWorkingFile();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getDescription Method

Return a description of the current state of CheckinProgress. It's a string concatenating the name of the CheckPhase and the File Name.

public virtual string getDescription();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getLastError Method

public virtual Throwable getLastError();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getSnapshotTime Method

Return the snapshot time that is set when the last clone was created.

public virtual OLEDate getSnapshotTime();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getTotalBytesCheckedIn Method

Get the total number of bytes that are checked in.

public virtual long getTotalBytesCheckedIn();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getTotalFilesCheckedIn Method

Return the number of files that have been checked in.

public virtual long getTotalFilesCheckedIn();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getTotalFilesFailed Method

Get the total number of files that failed during checkin.

public virtual long getTotalFilesFailed();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getTotalFilesForCheckin Method

Get the total number of files for checkin. The total number of files for checkin is a constant for this instance of the progress object.

public virtual long getTotalFilesForCheckin();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getTotalFilesProcessed Method

Get the total number of files to be checked in.

public virtual long getTotalFilesProcessed();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getTotalFilesRemaining Method

Return the number of files left to be checked in.

public virtual long getTotalFilesRemaining();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getTotalFilesSkipped Method

Get the total number of files skipped without being checked in.

public virtual long getTotalFilesSkipped();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.getTotalTimeSpent Method

Get the time spent on checking in in milliseconds.

public virtual long getTotalTimeSpent();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckinProgress.ToString Method

public override string ToString();

See Also

CheckinProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckInResult Class

For a list of all members of this type, see CheckInResult Members.

System.Object
FileResult
CheckInResult

public class CheckInResult : FileResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckInResult Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckInResult Members

CheckInResult overview

Public Instance Methods

Equals |
getExclusiveLockerID | Returns the user ID of the user that has an exclusive lock on this file. Will return -1 if no one has an exclusive lock. Will also return -1 if getMyLockState() returns -1.
GetHashCode |
getKeywords (inherited from FileResult) | Returns the keywords used in the add/checkin/checkout operation. If no keywords were used the array will empty. This method will not return null.
getMyLockState | Returns the lock state of the file for the user performing the checkout. This is not fully supported against StarTeam Server versions 4.0 and older. Will return -1 if not supported otherwise one of the MY_LOCK enum values.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileResult) |
ToString (inherited from FileResult) |

See Also

CheckInResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckInResult Methods

The methods of the CheckInResult class are listed below. For a complete list of CheckInResult class members, see the CheckInResult Members topic.

Public Instance Methods

Equals |
getExclusiveLockerID | Returns the user ID of the user that has an exclusive lock on this file. Will return -1 if no one has an exclusive lock. Will also return -1 if getMyLockState() returns -1.
GetHashCode |
getKeywords (inherited from FileResult) | Returns the keywords used in the add/checkin/checkout operation. If no keywords were used the array will empty. This method will not return null.
getMyLockState | Returns the lock state of the file for the user performing the checkout. This is not fully supported against StarTeam Server versions 4.0 and older. Will return -1 if not supported otherwise one of the MY_LOCK enum values.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileResult) |
ToString (inherited from FileResult) |

See Also

CheckInResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckInResult.Equals Method

public override bool Equals(
Object source
);

See Also

CheckInResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckInResult.getExclusiveLockerID Method

Returns the user ID of the user that has an exclusive lock on this file. Will return -1 if no one has an exclusive lock. Will also return -1 if getMyLockState() returns -1.

public virtual int getExclusiveLockerID();

See Also

CheckInResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckInResult.GetHashCode Method

public override int GetHashCode();

See Also

CheckInResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckInResult.getMyLockState Method

Returns the lock state of the file for the user performing the checkout. This is not fully supported against StarTeam Server versions 4.0 and older. Will return -1 if not supported otherwise one of the MY_LOCK enum values.

public virtual int getMyLockState();

See Also

CheckInResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent Class

For a list of all members of this type, see CheckoutEvent Members.

System.Object
EventObject
CheckoutEvent

public class CheckoutEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckoutEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent Members

CheckoutEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
getCheckoutManager | Gets the CheckoutManager that triggered this CheckoutEvent.
getCheckoutResults | Gets details describing the result of this checkout.
getCheckoutThreadIndex | Get the index of this thread within the CheckoutManager's running thread list.
getCurrentBytesExpected | Gets the total number of bytes expected in this file.
getCurrentBytesSoFar | Get the number of bytes checked out so far for this file.
getCurrentFile | Gets the StarTeam File being checked out.
getCurrentWorkingFile | Gets the working file on disk where this file is being checked out to.
getError |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getOptions | Gets the checkout options that apply to the current file. <p> To override any of the options for the current file, change them in the onStartFile event handler.
getProgress | Gets a snapshot of the state of the current checkout operation, as of the time that this event was triggered.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
isCanceled | Indicates whether or not the overall checkout operation has been canceled.
isFinished | Indicates whether or not the checkout operation for this file is finished.
isMPXCacheAgentThread | Indicates whether this thread is checking out files from the MPX File Cache Agent, or directly from the server.
isSuccessful | Indicates whether or not the checkout operation for this file has finished successfully.
MemberwiseClone |
setCurrentWorkingFile | Sets the working file on disk where this file is being checked out to.
ToString |

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent Methods

The methods of the CheckoutEvent class are listed below. For a complete list of CheckoutEvent class members, see the CheckoutEvent Members topic.

Public Instance Methods

Equals |
getCheckoutManager | Gets the CheckoutManager that triggered this CheckoutEvent.
getCheckoutResults | Gets details describing the result of this checkout.
getCheckoutThreadIndex | Get the index of this thread within the CheckoutManager's running thread list.
getCurrentBytesExpected | Gets the total number of bytes expected in this file.
getCurrentBytesSoFar | Get the number of bytes checked out so far for this file.
getCurrentFile | Gets the StarTeam File being checked out.
getCurrentWorkingFile | Gets the working file on disk where this file is being checked out to.
getError |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getOptions | Gets the checkout options that apply to the current file. <p> To override any of the options for the current file, change them in the onStartFile event handler.
getProgress | Gets a snapshot of the state of the current checkout operation, as of the time that this event was triggered.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
isCanceled | Indicates whether or not the overall checkout operation has been canceled.
isFinished | Indicates whether or not the checkout operation for this file is finished.
isMPXCacheAgentThread | Indicates whether this thread is checking out files from the MPX File Cache Agent, or directly from the server.
isSuccessful | Indicates whether or not the checkout operation for this file has finished successfully.
MemberwiseClone |
setCurrentWorkingFile | Sets the working file on disk where this file is being checked out to.
ToString |

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.Equals Method

public override bool Equals(
Object source
);

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.getCheckoutManager Method

Gets the CheckoutManager that triggered this CheckoutEvent.

public virtual CheckoutManager getCheckoutManager();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.getCheckoutResults Method

Gets details describing the result of this checkout.

public virtual CheckOutResult getCheckoutResults();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.getCheckoutThreadIndex Method

Get the index of this thread within the CheckoutManager's running thread list.

public virtual int getCheckoutThreadIndex();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.getCurrentBytesExpected Method

Gets the total number of bytes expected in this file.

public virtual long getCurrentBytesExpected();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.getCurrentBytesSoFar Method

Get the number of bytes checked out so far for this file.

public virtual long getCurrentBytesSoFar();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.getCurrentFile Method

Gets the StarTeam File being checked out.

public virtual File getCurrentFile();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.getCurrentWorkingFile Method

Gets the working file on disk where this file is being checked out to.

public virtual File getCurrentWorkingFile();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.getError Method

public virtual Throwable getError();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.GetHashCode Method

public override int GetHashCode();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.getOptions Method

Gets the checkout options that apply to the current file. <p> To override any of the options for the current file, change them in the onStartFile event handler.

public virtual CheckoutOptions getOptions();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.getProgress Method

Gets a snapshot of the state of the current checkout operation, as of the time that this event was triggered.

public virtual CheckoutProgress getProgress();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.getSource Method

public override object getSource();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.isCanceled Method

Indicates whether or not the overall checkout operation has been canceled.

public virtual bool isCanceled();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.isFinished Method

Indicates whether or not the checkout operation for this file is finished.

public virtual bool isFinished();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.isMPXCacheAgentThread Method

Indicates whether this thread is checking out files from the MPX File Cache Agent, or directly from the server.

public virtual bool isMPXCacheAgentThread();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.isSuccessful Method

Indicates whether or not the checkout operation for this file has finished successfully.

public virtual bool isSuccessful();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.setCurrentWorkingFile Method

Sets the working file on disk where this file is being checked out to.

public virtual void setCurrentWorkingFile(
File workingFile
);

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutEvent.ToString Method

public override string ToString();

See Also

CheckoutEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutListener Interface

For a list of all members of this type, see CheckoutListener Members.

public interface CheckoutListener : EventListener

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckoutListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutListener Members

CheckoutListener overview

Public Instance Methods

onNotifyProgress | Triggered during the checkout operation, to provide the client application with updated information about the progress of the operation. <p> If the checkout of a given file completes successfully, then the onNotifyProgress event is triggered with CheckoutEvent.isFinished() and CheckoutEvent.isSuccessfull() both returning true. <p> If the checkout of a given file terminates abnormally, then the onNotifyProgress event is triggered with CheckoutEvent.isSuccessful() returning false. <p> If the checkout operation is canceled, then the onNotifyProgress event is triggered once for every file that has not yet completed. In this case, CheckoutEvent.isCanceled() returns true.
onStartFile | Triggered once per file, at the start of the checkout operation for that file. This provides the client application with an opportunity to override any of the checkout parameters on a file-by-file basis, or to cancel the checkout process.

See Also

CheckoutListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutListener Methods

The methods of the CheckoutListener interface are listed below. For a complete list of CheckoutListener interface members, see the CheckoutListener Members topic.

Public Instance Methods

onNotifyProgress | Triggered during the checkout operation, to provide the client application with updated information about the progress of the operation. <p> If the checkout of a given file completes successfully, then the onNotifyProgress event is triggered with CheckoutEvent.isFinished() and CheckoutEvent.isSuccessfull() both returning true. <p> If the checkout of a given file terminates abnormally, then the onNotifyProgress event is triggered with CheckoutEvent.isSuccessful() returning false. <p> If the checkout operation is canceled, then the onNotifyProgress event is triggered once for every file that has not yet completed. In this case, CheckoutEvent.isCanceled() returns true.
onStartFile | Triggered once per file, at the start of the checkout operation for that file. This provides the client application with an opportunity to override any of the checkout parameters on a file-by-file basis, or to cancel the checkout process.

See Also

CheckoutListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutListener.onNotifyProgress Method

Triggered during the checkout operation, to provide the client application with updated information about the progress of the operation. <p> If the checkout of a given file completes successfully, then the onNotifyProgress event is triggered with CheckoutEvent.isFinished() and CheckoutEvent.isSuccessfull() both returning true. <p> If the checkout of a given file terminates abnormally, then the onNotifyProgress event is triggered with CheckoutEvent.isSuccessful() returning false. <p> If the checkout operation is canceled, then the onNotifyProgress event is triggered once for every file that has not yet completed. In this case, CheckoutEvent.isCanceled() returns true.

void onNotifyProgress(
CheckoutEvent event
);

See Also

CheckoutListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutListener.onStartFile Method

Triggered once per file, at the start of the checkout operation for that file. This provides the client application with an opportunity to override any of the checkout parameters on a file-by-file basis, or to cancel the checkout process.

void onStartFile(
CheckoutEvent event
);

See Also

CheckoutListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager Class

For a list of all members of this type, see CheckoutManager Members.

System.Object
CheckoutManager

public class CheckoutManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckoutManager Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager Members

CheckoutManager overview

Public Instance Constructors

CheckoutManager Overloaded. Initializes a new instance of the CheckoutManager class.

Public Instance Methods

addCheckoutListener | Adds a listener for checkout-related events.
checkout | Overloaded. Checks out a single file to the default location.
checkoutTo | Overloaded.
Equals |
GetHashCode |
getMPXCacheAgentAddress | Obsolete. Gets the host address of the MPX cache agent.
getMPXCacheAgentEnabled | Obsolete. Indicates whether or not checkouts via the MPX cache agent are enabled. The cache agent is disabled by default.
getMPXCacheAgentPort | Obsolete. Gets the port number of the MPX cache agent.
getMPXCacheAgentThreadCount | Obsolete. Gets the number of threads used by the MPX cache agent to fetch file content.
getOptions | Gets the checkout options currently in effect. <p> Note that individual options can be overridden on a file-by-file basis by registering a CheckoutListener, and changing options as necessary in the onStartFile event handler.
getProgress | Gets a snapshot of the state of the current checkout operation.
GetType (inherited from Object) | Gets the Type of the current instance.
isCanceled | Indicates whether or not pending checkout operations have been canceled.
isRunning | Determines whether or not there is currently a checkout operation in progress.
MemberwiseClone |
removeCheckoutListener | Removes a listener for checkout-related events.
setCanceled | Cancels any pending checkout operations.
setMPXCacheAgentAddress | Obsolete.
setMPXCacheAgentEnabled | Obsolete.
setMPXCacheAgentPort | Obsolete.
setMPXCacheAgentThreadCount | Obsolete.
setOptions | Changes the checkout options currently in effect.
ToString |

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager Constructor

NOTE: This constructor is now obsolete.

Constructs a CheckoutManager with default options.

Overload List

Obsolete. Constructs a CheckoutManager with default options.

public CheckoutManager(View);

Obsolete.

public CheckoutManager(View,CheckoutManager);

Obsolete.

public CheckoutManager(View,CheckoutOptions);

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager Constructor (View)

NOTE: This constructor is now obsolete.

Constructs a CheckoutManager with default options.

public CheckoutManager(
View view
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace | CheckoutManager Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager Constructor (View, CheckoutOptions)

NOTE: This constructor is now obsolete.

public CheckoutManager(
View view,
CheckoutOptions options
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace | CheckoutManager Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager Constructor (View, CheckoutManager)

NOTE: This constructor is now obsolete.

public CheckoutManager(
View view,
CheckoutManager checkoutManager
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace | CheckoutManager Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager Methods

The methods of the CheckoutManager class are listed below. For a complete list of CheckoutManager class members, see the CheckoutManager Members topic.

Public Instance Methods

addCheckoutListener | Adds a listener for checkout-related events.
checkout | Overloaded. Checks out a single file to the default location.
checkoutTo | Overloaded.
Equals |
GetHashCode |
getMPXCacheAgentAddress | Obsolete. Gets the host address of the MPX cache agent.
getMPXCacheAgentEnabled | Obsolete. Indicates whether or not checkouts via the MPX cache agent are enabled. The cache agent is disabled by default.
getMPXCacheAgentPort | Obsolete. Gets the port number of the MPX cache agent.
getMPXCacheAgentThreadCount | Obsolete. Gets the number of threads used by the MPX cache agent to fetch file content.
getOptions | Gets the checkout options currently in effect. <p> Note that individual options can be overridden on a file-by-file basis by registering a CheckoutListener, and changing options as necessary in the onStartFile event handler.
getProgress | Gets a snapshot of the state of the current checkout operation.
GetType (inherited from Object) | Gets the Type of the current instance.
isCanceled | Indicates whether or not pending checkout operations have been canceled.
isRunning | Determines whether or not there is currently a checkout operation in progress.
MemberwiseClone |
removeCheckoutListener | Removes a listener for checkout-related events.
setCanceled | Cancels any pending checkout operations.
setMPXCacheAgentAddress | Obsolete.
setMPXCacheAgentEnabled | Obsolete.
setMPXCacheAgentPort | Obsolete.
setMPXCacheAgentThreadCount | Obsolete.
setOptions | Changes the checkout options currently in effect.
ToString |

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.addCheckoutListener Method

Adds a listener for checkout-related events.

public virtual void addCheckoutListener(
CheckoutListener listener
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


checkout Method

Borland StarTeam SDK for .NET

CheckoutManager.checkout Method

Checks out a single file to the default location.

Overload List

Checks out a single file to the default location.

public virtual void checkout(File);

Checks out all the files in the given folder.

public virtual void checkout(Folder);

public virtual void checkout(Folder,Int32);

public virtual void checkout(Item[]);

Checks out the given set of files.

public virtual void checkout(ItemList);

Checks out the given set of files.

public virtual void checkout(Items);

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.checkout Method (File)

Checks out a single file to the default location.

public virtual void checkout(
File file
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace | CheckoutManager.checkout Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.checkout Method (Folder)

Checks out all the files in the given folder.

public virtual void checkout(
Folder folder
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace | CheckoutManager.checkout Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.checkout Method (Folder, Int32)

public virtual void checkout(
Folder folder,
Int32 depth
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace | CheckoutManager.checkout Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.checkout Method (Item[])

public virtual void checkout(
Item[] files
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace | CheckoutManager.checkout Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.checkout Method (ItemList)

Checks out the given set of files.

public virtual void checkout(
ItemList files
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace | CheckoutManager.checkout Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.checkout Method (Items)

Checks out the given set of files.

public virtual void checkout(
Items files
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace | CheckoutManager.checkout Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


checkoutTo Method

Borland StarTeam SDK for .NET

CheckoutManager.checkoutTo Method

Overload List

public virtual void checkoutTo(File,File);

public virtual void checkoutTo(File,OutputStream);

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.checkoutTo Method (File, File)

public virtual void checkoutTo(
File file,
File workingFile
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace | CheckoutManager.checkoutTo Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.checkoutTo Method (File, OutputStream)

public virtual void checkoutTo(
File file,
OutputStream stream
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace | CheckoutManager.checkoutTo Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.Equals Method

public override bool Equals(
Object source
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.GetHashCode Method

public override int GetHashCode();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.getMPXCacheAgentAddress Method

NOTE: This method is now obsolete.

Gets the host address of the MPX cache agent.

public virtual string getMPXCacheAgentAddress();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.getMPXCacheAgentEnabled Method

NOTE: This method is now obsolete.

Indicates whether or not checkouts via the MPX cache agent are enabled. The cache agent is disabled by default.

public virtual bool getMPXCacheAgentEnabled();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.getMPXCacheAgentPort Method

NOTE: This method is now obsolete.

Gets the port number of the MPX cache agent.

public virtual int getMPXCacheAgentPort();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.getMPXCacheAgentThreadCount Method

NOTE: This method is now obsolete.

Gets the number of threads used by the MPX cache agent to fetch file content.

public virtual int getMPXCacheAgentThreadCount();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.getOptions Method

Gets the checkout options currently in effect. <p> Note that individual options can be overridden on a file-by-file basis by registering a CheckoutListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckoutOptions getOptions();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.getProgress Method

Gets a snapshot of the state of the current checkout operation.

public virtual CheckoutProgress getProgress();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.isCanceled Method

Indicates whether or not pending checkout operations have been canceled.

public virtual bool isCanceled();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.isRunning Method

Determines whether or not there is currently a checkout operation in progress.

public virtual bool isRunning();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.removeCheckoutListener Method

Removes a listener for checkout-related events.

public virtual void removeCheckoutListener(
CheckoutListener listener
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.setCanceled Method

Cancels any pending checkout operations.

public virtual void setCanceled();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.setMPXCacheAgentAddress Method

NOTE: This method is now obsolete.

public virtual void setMPXCacheAgentAddress(
String address
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.setMPXCacheAgentEnabled Method

NOTE: This method is now obsolete.

public virtual void setMPXCacheAgentEnabled(
Boolean bEnabled
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.setMPXCacheAgentPort Method

NOTE: This method is now obsolete.

public virtual void setMPXCacheAgentPort(
Int32 port
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.setMPXCacheAgentThreadCount Method

NOTE: This method is now obsolete.

public virtual void setMPXCacheAgentThreadCount(
Int32 nThreads
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.setOptions Method

Changes the checkout options currently in effect.

public virtual void setOptions(
CheckoutOptions checkoutOptions
);

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutManager.ToString Method

public override string ToString();

See Also

CheckoutManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions Class

For a list of all members of this type, see CheckoutOptions Members.

System.Object
CheckoutOptions

public class CheckoutOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckoutOptions Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions Members

CheckoutOptions overview

Public Static Fields

EOL_CR
EOL_CRLF
EOL_LF

Public Instance Constructors

CheckoutOptions Overloaded. Initializes a new instance of the CheckoutOptions class.

Public Instance Methods

Equals |
getCheckoutDate | Get OLEDate value for "checkout by date" option. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
getCheckoutLabelID | Get Label ID for "checkout by Label" option. Default is the tip; you can also select a historical revision by date, label or promotion state. Files that don't match (e.g., don't have the given Label attached) are skipped.
getContentFilter | Get the hook to be inserted after performing keyword expansion, eol conversion, etc.
getEOLChars | Obsolete. Get the contant value that represents the actual end-of-line sequence to be in EOL conversion. One of these values may be returned: EOL_CRLF, EOL_CR, and EOL_LF. The default value is EOL_CRLF when setEOLChars() is not called.
getEOLConversionEnabled | Obsolete. Return whether EOL conversion is enabled when checking out text files.
getEOLFormat | Gets the end-of-line format to be used by working files. <p> Default value is EOLFormat.PLATFORM, which uses the native platform end-of-line format. <p> null indicates that EOL conversion is disabled, which results in working files that have the server's canonical EOL format (which is CRLF on all platforms). <p> Ignored for binary files, and for files with a fixed EOL format.
getFileEncoding | Returns the "File Encoding" option value.
getForceCheckout | Returns the "Force Checkout" option value. When "Force Checkout" is true, the operation will check out files that might not otherwise be checked out, for example files that have a status of "modified", "merge" or "unknown".
GetHashCode |
getKeywordExpansionEnabled | Determin whether keyword expansion in text files is enabled.
getLockType | Return the type of lock to be used when checking out. Default is UNCHANGED. It may be one of these values: UNLOCKED, EXCLUSIVE, NONEXCLUSIVE, UNCHANGED, and BREAK_FLAG.
getMarkUnlockedFilesReadOnly | Returns the "Mark Unlocked Files ReadOnly" option value.
getOptimizeForSlowConnections | Determine whether to optimize for slow connections, when possible.
getPromotionStateID | Get the PromotionState ID for "checkout by PromotionState" option. Default is the tip; you can also select a historical revision by date, label or promotion state. Files that don't match (e.g., don't have the given PromotionState attached) are skipped.
getRestoreFileOnError | Determine whether to restore previous working file if an error occurs during a checkout.
getTimeStampNow | Return whether the current time is used as the last modified time.
GetType (inherited from Object) | Gets the Type of the current instance.
getUpdateStatus | Determine whether to update status information after a successful checkout.
isByDate | Determines whether "checkout by date" option is used.
isByLabel | Determines whether "checkout by Label" option is used.
isByPromotionState | Determines whether "checkout by PromotionState" option is used.
isByTips | Determine which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
isFileSkipped | Returns whether to skip checking out files or the file associated with this CheckoutOptions object.
MemberwiseClone |
setCheckoutDate | Set to "checkout by date" on the given OLEDate value. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., didn't have it on that date) are skipped.
setCheckoutLabelID |
setContentFilter | Set the hook inserted after performing keyword expansion, eol conversion, etc.
setEOLChars | Obsolete.
setEOLConversionEnabled | Obsolete.
setEOLFormat | Sets the EOL format to be used by working files. <p> Default value is EOLFormat.PLATFORM, which uses the native platform end-of-line format. <p> null indicates that EOL conversion is disabled, which results in working files that have the server's canonical EOL format (which is CRLF on all platforms). <p> Ignored for binary files, and for files with a fixed EOL format.
setFileEncoding |
setFileSkipped |
setForceCheckout |
setKeywordExpansionEnabled |
setLockType |
setMarkUnlockedFilesReadOnly |
setOptimizeForSlowConnections |
setPromotionStateID |
setRestoreFileOnError |
setTimeStampNow |
setTips | Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
setUpdateStatus |
ToString |

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions Constructor

Construct a CheckoutOptions object with default options from the View.

Overload List

Construct a CheckoutOptions object with the same options as the given one.

public CheckoutOptions(CheckoutOptions);

Construct a CheckoutOptions object with default options from a StarTeamClientOptions object.

public CheckoutOptions(StarTeamClientOptions);

Construct a CheckoutOptions object with default options from the View.

public CheckoutOptions(View);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions Constructor (View)

Construct a CheckoutOptions object with default options from the View.

public CheckoutOptions(
View view
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace | CheckoutOptions Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions Constructor (StarTeamClientOptions)

Construct a CheckoutOptions object with default options from a StarTeamClientOptions object.

public CheckoutOptions(
StarTeamClientOptions options
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace | CheckoutOptions Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions Constructor (CheckoutOptions)

Construct a CheckoutOptions object with the same options as the given one.

public CheckoutOptions(
CheckoutOptions options
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace | CheckoutOptions Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions Fields

The fields of the CheckoutOptions class are listed below. For a complete list of CheckoutOptions class members, see the CheckoutOptions Members topic.

Public Static Fields

EOL_CR
EOL_CRLF
EOL_LF

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.EOL_CR Field

public const Int32 EOL_CR = 0;

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.EOL_CRLF Field

public const Int32 EOL_CRLF = 2;

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.EOL_LF Field

public const Int32 EOL_LF = 1;

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions Methods

The methods of the CheckoutOptions class are listed below. For a complete list of CheckoutOptions class members, see the CheckoutOptions Members topic.

Public Instance Methods

Equals |
getCheckoutDate | Get OLEDate value for "checkout by date" option. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
getCheckoutLabelID | Get Label ID for "checkout by Label" option. Default is the tip; you can also select a historical revision by date, label or promotion state. Files that don't match (e.g., don't have the given Label attached) are skipped.
getContentFilter | Get the hook to be inserted after performing keyword expansion, eol conversion, etc.
getEOLChars | Obsolete. Get the contant value that represents the actual end-of-line sequence to be in EOL conversion. One of these values may be returned: EOL_CRLF, EOL_CR, and EOL_LF. The default value is EOL_CRLF when setEOLChars() is not called.
getEOLConversionEnabled | Obsolete. Return whether EOL conversion is enabled when checking out text files.
getEOLFormat | Gets the end-of-line format to be used by working files. <p> Default value is EOLFormat.PLATFORM, which uses the native platform end-of-line format. <p> null indicates that EOL conversion is disabled, which results in working files that have the server's canonical EOL format (which is CRLF on all platforms). <p> Ignored for binary files, and for files with a fixed EOL format.
getFileEncoding | Returns the "File Encoding" option value.
getForceCheckout | Returns the "Force Checkout" option value. When "Force Checkout" is true, the operation will check out files that might not otherwise be checked out, for example files that have a status of "modified", "merge" or "unknown".
GetHashCode |
getKeywordExpansionEnabled | Determin whether keyword expansion in text files is enabled.
getLockType | Return the type of lock to be used when checking out. Default is UNCHANGED. It may be one of these values: UNLOCKED, EXCLUSIVE, NONEXCLUSIVE, UNCHANGED, and BREAK_FLAG.
getMarkUnlockedFilesReadOnly | Returns the "Mark Unlocked Files ReadOnly" option value.
getOptimizeForSlowConnections | Determine whether to optimize for slow connections, when possible.
getPromotionStateID | Get the PromotionState ID for "checkout by PromotionState" option. Default is the tip; you can also select a historical revision by date, label or promotion state. Files that don't match (e.g., don't have the given PromotionState attached) are skipped.
getRestoreFileOnError | Determine whether to restore previous working file if an error occurs during a checkout.
getTimeStampNow | Return whether the current time is used as the last modified time.
GetType (inherited from Object) | Gets the Type of the current instance.
getUpdateStatus | Determine whether to update status information after a successful checkout.
isByDate | Determines whether "checkout by date" option is used.
isByLabel | Determines whether "checkout by Label" option is used.
isByPromotionState | Determines whether "checkout by PromotionState" option is used.
isByTips | Determine which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
isFileSkipped | Returns whether to skip checking out files or the file associated with this CheckoutOptions object.
MemberwiseClone |
setCheckoutDate | Set to "checkout by date" on the given OLEDate value. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., didn't have it on that date) are skipped.
setCheckoutLabelID |
setContentFilter | Set the hook inserted after performing keyword expansion, eol conversion, etc.
setEOLChars | Obsolete.
setEOLConversionEnabled | Obsolete.
setEOLFormat | Sets the EOL format to be used by working files. <p> Default value is EOLFormat.PLATFORM, which uses the native platform end-of-line format. <p> null indicates that EOL conversion is disabled, which results in working files that have the server's canonical EOL format (which is CRLF on all platforms). <p> Ignored for binary files, and for files with a fixed EOL format.
setFileEncoding |
setFileSkipped |
setForceCheckout |
setKeywordExpansionEnabled |
setLockType |
setMarkUnlockedFilesReadOnly |
setOptimizeForSlowConnections |
setPromotionStateID |
setRestoreFileOnError |
setTimeStampNow |
setTips | Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
setUpdateStatus |
ToString |

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.Equals Method

public override bool Equals(
Object source
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getCheckoutDate Method

Get OLEDate value for "checkout by date" option. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.

public virtual OLEDate getCheckoutDate();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getCheckoutLabelID Method

Get Label ID for "checkout by Label" option. Default is the tip; you can also select a historical revision by date, label or promotion state. Files that don't match (e.g., don't have the given Label attached) are skipped.

public virtual int getCheckoutLabelID();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getContentFilter Method

Get the hook to be inserted after performing keyword expansion, eol conversion, etc.

public virtual ContentFilter getContentFilter();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getEOLChars Method

NOTE: This method is now obsolete.

Get the contant value that represents the actual end-of-line sequence to be in EOL conversion. One of these values may be returned: EOL_CRLF, EOL_CR, and EOL_LF. The default value is EOL_CRLF when setEOLChars() is not called.

public virtual int getEOLChars();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getEOLConversionEnabled Method

NOTE: This method is now obsolete.

Return whether EOL conversion is enabled when checking out text files.

public virtual bool getEOLConversionEnabled();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getEOLFormat Method

Gets the end-of-line format to be used by working files. <p> Default value is EOLFormat.PLATFORM, which uses the native platform end-of-line format. <p> null indicates that EOL conversion is disabled, which results in working files that have the server's canonical EOL format (which is CRLF on all platforms). <p> Ignored for binary files, and for files with a fixed EOL format.

public virtual EOLFormat getEOLFormat();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getFileEncoding Method

Returns the "File Encoding" option value.

public virtual string getFileEncoding();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getForceCheckout Method

Returns the "Force Checkout" option value. When "Force Checkout" is true, the operation will check out files that might not otherwise be checked out, for example files that have a status of "modified", "merge" or "unknown".

public virtual bool getForceCheckout();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.GetHashCode Method

public override int GetHashCode();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getKeywordExpansionEnabled Method

Determin whether keyword expansion in text files is enabled.

public virtual bool getKeywordExpansionEnabled();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getLockType Method

Return the type of lock to be used when checking out. Default is UNCHANGED. It may be one of these values: UNLOCKED, EXCLUSIVE, NONEXCLUSIVE, UNCHANGED, and BREAK_FLAG.

public virtual int getLockType();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getMarkUnlockedFilesReadOnly Method

Returns the "Mark Unlocked Files ReadOnly" option value.

public virtual bool getMarkUnlockedFilesReadOnly();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getOptimizeForSlowConnections Method

Determine whether to optimize for slow connections, when possible.

public virtual bool getOptimizeForSlowConnections();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getPromotionStateID Method

Get the PromotionState ID for "checkout by PromotionState" option. Default is the tip; you can also select a historical revision by date, label or promotion state. Files that don't match (e.g., don't have the given PromotionState attached) are skipped.

public virtual int getPromotionStateID();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getRestoreFileOnError Method

Determine whether to restore previous working file if an error occurs during a checkout.

public virtual bool getRestoreFileOnError();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getTimeStampNow Method

Return whether the current time is used as the last modified time.

public virtual bool getTimeStampNow();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.getUpdateStatus Method

Determine whether to update status information after a successful checkout.

public virtual bool getUpdateStatus();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.isByDate Method

Determines whether "checkout by date" option is used.

public virtual bool isByDate();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.isByLabel Method

Determines whether "checkout by Label" option is used.

public virtual bool isByLabel();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.isByPromotionState Method

Determines whether "checkout by PromotionState" option is used.

public virtual bool isByPromotionState();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.isByTips Method

Determine which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.

public virtual bool isByTips();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.isFileSkipped Method

Returns whether to skip checking out files or the file associated with this CheckoutOptions object.

public virtual bool isFileSkipped();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setCheckoutDate Method

Set to "checkout by date" on the given OLEDate value. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., didn't have it on that date) are skipped.

public virtual void setCheckoutDate(
OLEDate d
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setCheckoutLabelID Method

public virtual void setCheckoutLabelID(
Int32 labelID
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setContentFilter Method

Set the hook inserted after performing keyword expansion, eol conversion, etc.

public virtual void setContentFilter(
ContentFilter filter
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setEOLChars Method

NOTE: This method is now obsolete.

public virtual void setEOLChars(
Int32 eol
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setEOLConversionEnabled Method

NOTE: This method is now obsolete.

public virtual void setEOLConversionEnabled(
Boolean bEnabled
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setEOLFormat Method

Sets the EOL format to be used by working files. <p> Default value is EOLFormat.PLATFORM, which uses the native platform end-of-line format. <p> null indicates that EOL conversion is disabled, which results in working files that have the server's canonical EOL format (which is CRLF on all platforms). <p> Ignored for binary files, and for files with a fixed EOL format.

public virtual void setEOLFormat(
EOLFormat format
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setFileEncoding Method

public virtual void setFileEncoding(
String sEncoding
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setFileSkipped Method

public virtual void setFileSkipped(
Boolean bFileSkipped
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setForceCheckout Method

public virtual void setForceCheckout(
Boolean bForceCheckout
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setKeywordExpansionEnabled Method

public virtual void setKeywordExpansionEnabled(
Boolean bEnabled
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setLockType Method

public virtual void setLockType(
Int32 lockType
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setMarkUnlockedFilesReadOnly Method

public virtual void setMarkUnlockedFilesReadOnly(
Boolean bMarkUnlockedFilesReadOnly
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setOptimizeForSlowConnections Method

public virtual void setOptimizeForSlowConnections(
Boolean bEnabled
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setPromotionStateID Method

public virtual void setPromotionStateID(
Int32 stateID
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setRestoreFileOnError Method

public virtual void setRestoreFileOnError(
Boolean bEnabled
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setTimeStampNow Method

public virtual void setTimeStampNow(
Boolean bTimeStampNow
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setTips Method

Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.

public virtual void setTips();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.setUpdateStatus Method

public virtual void setUpdateStatus(
Boolean bEnabled
);

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutOptions.ToString Method

public override string ToString();

See Also

CheckoutOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress Class

For a list of all members of this type, see CheckoutProgress Members.

System.Object
CheckoutProgress

public class CheckoutProgress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckoutProgress Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress Members

CheckoutProgress overview

Public Instance Methods

Equals |
getCurrentBytesExpected |
getCurrentBytesSoFar |
getCurrentFile |
GetHashCode |
getLastError |
getNumCheckoutThreads | Get the number of threads that contains checkout operations.
getTotalBytesCheckedOut | Overloaded. Get the total number of bytes that are checked out.
getTotalBytesCheckedOutByMPXCacheAgent | Get the number of bytes checked out through MPX File Cache Agent.
getTotalCommandTime | Get the time spent on checking out in milliseconds.
getTotalCommandTimeByMPXCacheAgent | Get the time spent on checking out in milliseconds through MPX File Cache Agent.
getTotalFilesCheckedOut | Overloaded. Get the total number of files checked out.
getTotalFilesCheckedOutByMPXCacheAgent | Get the number of files checked out through MPX File Cache Agent.
getTotalFilesFailed | Get the total number of files that failed during checkout.
getTotalFilesRemaining | Get the total number of files that are yet to be checked out.
getTotalFilesSkipped | Get the total number of files skipped without being checked out.
getTotalFilesSkippedByMPXCacheAgent | Get the number of files skipped without being checked out through MPX File Cache Agent.
GetType (inherited from Object) | Gets the Type of the current instance.
isMPXCacheAgentThread |
MemberwiseClone |
ToString |

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress Methods

The methods of the CheckoutProgress class are listed below. For a complete list of CheckoutProgress class members, see the CheckoutProgress Members topic.

Public Instance Methods

Equals |
getCurrentBytesExpected |
getCurrentBytesSoFar |
getCurrentFile |
GetHashCode |
getLastError |
getNumCheckoutThreads | Get the number of threads that contains checkout operations.
getTotalBytesCheckedOut | Overloaded. Get the total number of bytes that are checked out.
getTotalBytesCheckedOutByMPXCacheAgent | Get the number of bytes checked out through MPX File Cache Agent.
getTotalCommandTime | Get the time spent on checking out in milliseconds.
getTotalCommandTimeByMPXCacheAgent | Get the time spent on checking out in milliseconds through MPX File Cache Agent.
getTotalFilesCheckedOut | Overloaded. Get the total number of files checked out.
getTotalFilesCheckedOutByMPXCacheAgent | Get the number of files checked out through MPX File Cache Agent.
getTotalFilesFailed | Get the total number of files that failed during checkout.
getTotalFilesRemaining | Get the total number of files that are yet to be checked out.
getTotalFilesSkipped | Get the total number of files skipped without being checked out.
getTotalFilesSkippedByMPXCacheAgent | Get the number of files skipped without being checked out through MPX File Cache Agent.
GetType (inherited from Object) | Gets the Type of the current instance.
isMPXCacheAgentThread |
MemberwiseClone |
ToString |

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.Equals Method

public override bool Equals(
Object source
);

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getCurrentBytesExpected Method

public virtual long getCurrentBytesExpected(
Int32 threadIndex
);

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getCurrentBytesSoFar Method

public virtual long getCurrentBytesSoFar(
Int32 threadIndex
);

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getCurrentFile Method

public virtual File getCurrentFile(
Int32 threadIndex
);

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.GetHashCode Method

public override int GetHashCode();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getLastError Method

public virtual Throwable getLastError();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getNumCheckoutThreads Method

Get the number of threads that contains checkout operations.

public virtual int getNumCheckoutThreads();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


getTotalBytesCheckedOut Method

Borland StarTeam SDK for .NET

CheckoutProgress.getTotalBytesCheckedOut Method

Get the total number of bytes that are checked out.

Overload List

Get the total number of bytes that are checked out.

public virtual long getTotalBytesCheckedOut();

public virtual long getTotalBytesCheckedOut(Int32);

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalBytesCheckedOut Method ()

Get the total number of bytes that are checked out.

public virtual long getTotalBytesCheckedOut();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace | CheckoutProgress.getTotalBytesCheckedOut Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalBytesCheckedOut Method (Int32)

public virtual long getTotalBytesCheckedOut(
Int32 threadIndex
);

See Also

CheckoutProgress Class | com.starbase.starteam Namespace | CheckoutProgress.getTotalBytesCheckedOut Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalBytesCheckedOutByMPXCacheAgent Method

Get the number of bytes checked out through MPX File Cache Agent.

public virtual long getTotalBytesCheckedOutByMPXCacheAgent();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalCommandTime Method

Get the time spent on checking out in milliseconds.

public virtual long getTotalCommandTime();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalCommandTimeByMPXCacheAgent Method

Get the time spent on checking out in milliseconds through MPX File Cache Agent.

public virtual long getTotalCommandTimeByMPXCacheAgent();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


getTotalFilesCheckedOut Method

Borland StarTeam SDK for .NET

CheckoutProgress.getTotalFilesCheckedOut Method

Get the total number of files checked out.

Overload List

Get the total number of files checked out.

public virtual int getTotalFilesCheckedOut();

public virtual int getTotalFilesCheckedOut(Int32);

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalFilesCheckedOut Method ()

Get the total number of files checked out.

public virtual int getTotalFilesCheckedOut();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace | CheckoutProgress.getTotalFilesCheckedOut Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalFilesCheckedOut Method (Int32)

public virtual int getTotalFilesCheckedOut(
Int32 threadIndex
);

See Also

CheckoutProgress Class | com.starbase.starteam Namespace | CheckoutProgress.getTotalFilesCheckedOut Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalFilesCheckedOutByMPXCacheAgent Method

Get the number of files checked out through MPX File Cache Agent.

public virtual int getTotalFilesCheckedOutByMPXCacheAgent();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalFilesFailed Method

Get the total number of files that failed during checkout.

public virtual int getTotalFilesFailed();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalFilesRemaining Method

Get the total number of files that are yet to be checked out.

public virtual int getTotalFilesRemaining();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalFilesSkipped Method

Get the total number of files skipped without being checked out.

public virtual int getTotalFilesSkipped();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.getTotalFilesSkippedByMPXCacheAgent Method

Get the number of files skipped without being checked out through MPX File Cache Agent.

public virtual int getTotalFilesSkippedByMPXCacheAgent();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.isMPXCacheAgentThread Method

public virtual bool isMPXCacheAgentThread(
Int32 threadIndex
);

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckoutProgress.ToString Method

public override string ToString();

See Also

CheckoutProgress Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckOutResult Class

For a list of all members of this type, see CheckOutResult Members.

System.Object
FileResult
CheckOutResult

public class CheckOutResult : FileResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CheckOutResult Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckOutResult Members

CheckOutResult overview

Public Instance Methods

Equals |
getExclusiveLockerID | Returns the user ID of the user that has an exclusive lock on this file. Will return -1 if no one has an exclusive lock. Will also return -1 if getMyLockState() returns -1.
GetHashCode |
getKeywords (inherited from FileResult) | Returns the keywords used in the add/checkin/checkout operation. If no keywords were used the array will empty. This method will not return null.
getMyLockState | Returns the lock state of the file for the user performing the checkout. This is not fully supported against StarTeam Server versions 4.0 and older. Will return -1 if not supported otherwise one of the MY_LOCK enum values.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileResult) |
ToString (inherited from FileResult) |

See Also

CheckOutResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckOutResult Methods

The methods of the CheckOutResult class are listed below. For a complete list of CheckOutResult class members, see the CheckOutResult Members topic.

Public Instance Methods

Equals |
getExclusiveLockerID | Returns the user ID of the user that has an exclusive lock on this file. Will return -1 if no one has an exclusive lock. Will also return -1 if getMyLockState() returns -1.
GetHashCode |
getKeywords (inherited from FileResult) | Returns the keywords used in the add/checkin/checkout operation. If no keywords were used the array will empty. This method will not return null.
getMyLockState | Returns the lock state of the file for the user performing the checkout. This is not fully supported against StarTeam Server versions 4.0 and older. Will return -1 if not supported otherwise one of the MY_LOCK enum values.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileResult) |
ToString (inherited from FileResult) |

See Also

CheckOutResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckOutResult.Equals Method

public override bool Equals(
Object source
);

See Also

CheckOutResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckOutResult.getExclusiveLockerID Method

Returns the user ID of the user that has an exclusive lock on this file. Will return -1 if no one has an exclusive lock. Will also return -1 if getMyLockState() returns -1.

public virtual int getExclusiveLockerID();

See Also

CheckOutResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckOutResult.GetHashCode Method

public override int GetHashCode();

See Also

CheckOutResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CheckOutResult.getMyLockState Method

Returns the lock state of the file for the user performing the checkout. This is not fully supported against StarTeam Server versions 4.0 and older. Will return -1 if not supported otherwise one of the MY_LOCK enum values.

public virtual int getMyLockState();

See Also

CheckOutResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientApplication Class

For a list of all members of this type, see ClientApplication Members.

System.Object
ClientApplication

public class ClientApplication

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ClientApplication Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientApplication Members

ClientApplication overview

Public Static Methods

getDescription | Gets a verbose description of the client application. For example: "&lt;Unknown Application&gt;; SDK 6.0.0.039; JVM 1.4.2_01-b06; Windows XP".
getName | Gets the client application name.
setName |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ClientApplication Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientApplication Methods

The methods of the ClientApplication class are listed below. For a complete list of ClientApplication class members, see the ClientApplication Members topic.

Public Static Methods

getDescription | Gets a verbose description of the client application. For example: "&lt;Unknown Application&gt;; SDK 6.0.0.039; JVM 1.4.2_01-b06; Windows XP".
getName | Gets the client application name.
setName |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ClientApplication Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientApplication.getDescription Method

Gets a verbose description of the client application. For example: "&lt;Unknown Application&gt;; SDK 6.0.0.039; JVM 1.4.2_01-b06; Windows XP".

public static string getDescription();

See Also

ClientApplication Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientApplication.getName Method

Gets the client application name.

public static string getName();

See Also

ClientApplication Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientApplication.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ClientApplication Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientApplication.setName Method

public static void setName(
String name
);

See Also

ClientApplication Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientApplication.ToString Method

public override string ToString();

See Also

ClientApplication Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext Class

For a list of all members of this type, see ClientContext Members.

System.Object
ClientContext

public class ClientContext

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ClientContext Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext Members

ClientContext overview

Public Static Fields

EOL_CR
EOL_CRLF
EOL_LF
EOL_MAC
EOL_UNIX
EOL_WINDOWS

Public Instance Constructors

ClientContext Overloaded. Initializes a new instance of the ClientContext class.

Public Instance Methods

Equals |
getCaseSensitiveFileNames | Returns true if the client treats file names as case sensitive.
getDirectoryOverrides | Returns the directory override information for this client context. the directory overrides allow a client to override the default working directories on a per folder or view basis.
getEOL | Returns the client machine's end-of-line convention.
getFilePathDelimiter | Returns the string used to delimit directories in a file path. Should be "\" for Windows and "/" for Unix.
GetHashCode |
getHostName | Returns the client machine's host name.
GetType (inherited from Object) | Gets the Type of the current instance.
getWorkStationID | Returns the workstation GUID identifying the client.
MemberwiseClone |
setCaseSensitiveFileNames |
setDirectoryOverrides | Sets the directory override information for this client context. The directory overrides allow a client to override the default working directories on a per folder or view basis.
setEOL |
setFilePathDelimiter |
ToString |

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext Constructor

Creates a default client context based on propeties of the machine actually running the code.

Overload List

Creates a default client context based on propeties of the machine actually running the code.

public ClientContext();

Creates a default client context based on propeties of the machine actually running the code but using the specified workstation ID. Normally the workstation ID is read out of an ini file. Passing in null for the workStationID will read the GUID out of the appropriate ini file.

public ClientContext(GUID);

public ClientContext(GUID,String,String,Boolean,String,DirectoryOverrides);

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext Constructor ()

Creates a default client context based on propeties of the machine actually running the code.

public ClientContext();

See Also

ClientContext Class | com.starbase.starteam Namespace | ClientContext Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext Constructor (GUID)

Creates a default client context based on propeties of the machine actually running the code but using the specified workstation ID. Normally the workstation ID is read out of an ini file. Passing in null for the workStationID will read the GUID out of the appropriate ini file.

public ClientContext(
GUID workStationID
);

See Also

ClientContext Class | com.starbase.starteam Namespace | ClientContext Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext Constructor (GUID, String, String, Boolean, String, DirectoryOverrides)

public ClientContext(
GUID workStationID,
String hostname,
String eol,
Boolean caseSensitive,
String filePathDelim,
DirectoryOverrides overrides
);

See Also

ClientContext Class | com.starbase.starteam Namespace | ClientContext Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext Fields

The fields of the ClientContext class are listed below. For a complete list of ClientContext class members, see the ClientContext Members topic.

Public Static Fields

EOL_CR
EOL_CRLF
EOL_LF
EOL_MAC
EOL_UNIX
EOL_WINDOWS

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.EOL_CR Field

public const String EOL_CR = " ";

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.EOL_CRLF Field

public const String EOL_CRLF = " ";

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.EOL_LF Field

public const String EOL_LF = " ";

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.EOL_MAC Field

public const String EOL_MAC = " ";

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.EOL_UNIX Field

public const String EOL_UNIX = " ";

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.EOL_WINDOWS Field

public const String EOL_WINDOWS = " ";

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext Methods

The methods of the ClientContext class are listed below. For a complete list of ClientContext class members, see the ClientContext Members topic.

Public Instance Methods

Equals |
getCaseSensitiveFileNames | Returns true if the client treats file names as case sensitive.
getDirectoryOverrides | Returns the directory override information for this client context. the directory overrides allow a client to override the default working directories on a per folder or view basis.
getEOL | Returns the client machine's end-of-line convention.
getFilePathDelimiter | Returns the string used to delimit directories in a file path. Should be "\" for Windows and "/" for Unix.
GetHashCode |
getHostName | Returns the client machine's host name.
GetType (inherited from Object) | Gets the Type of the current instance.
getWorkStationID | Returns the workstation GUID identifying the client.
MemberwiseClone |
setCaseSensitiveFileNames |
setDirectoryOverrides | Sets the directory override information for this client context. The directory overrides allow a client to override the default working directories on a per folder or view basis.
setEOL |
setFilePathDelimiter |
ToString |

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.Equals Method

public override bool Equals(
Object source
);

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.getCaseSensitiveFileNames Method

Returns true if the client treats file names as case sensitive.

public virtual bool getCaseSensitiveFileNames();

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.getDirectoryOverrides Method

Returns the directory override information for this client context. the directory overrides allow a client to override the default working directories on a per folder or view basis.

public virtual DirectoryOverrides getDirectoryOverrides();

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.getEOL Method

Returns the client machine's end-of-line convention.

public virtual string getEOL();

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.getFilePathDelimiter Method

Returns the string used to delimit directories in a file path. Should be "\" for Windows and "/" for Unix.

public virtual string getFilePathDelimiter();

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.GetHashCode Method

public override int GetHashCode();

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.getHostName Method

Returns the client machine's host name.

public virtual string getHostName();

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.getWorkStationID Method

Returns the workstation GUID identifying the client.

public virtual GUID getWorkStationID();

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.setCaseSensitiveFileNames Method

public virtual void setCaseSensitiveFileNames(
Boolean caseSensitive
);

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.setDirectoryOverrides Method

Sets the directory override information for this client context. The directory overrides allow a client to override the default working directories on a per folder or view basis.

public virtual void setDirectoryOverrides(
DirectoryOverrides overrides
);

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.setEOL Method

public virtual void setEOL(
String eol
);

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.setFilePathDelimiter Method

public virtual void setFilePathDelimiter(
String delim
);

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ClientContext.ToString Method

public override string ToString();

See Also

ClientContext Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo Class

For a list of all members of this type, see ColumnInfo Members.

System.Object
ColumnInfo

public class ColumnInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ColumnInfo Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo Members

ColumnInfo overview

Public Instance Constructors

ColumnInfo Constructor

Public Instance Methods

Equals |
GetHashCode |
getPixelWidth |
getPropertyID |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setPixelWidth |
setPropertyID |
toDebugString |
ToString |

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo Constructor

public ColumnInfo(
Int32 propertyID,
Int32 pixelWidth
);

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo Methods

The methods of the ColumnInfo class are listed below. For a complete list of ColumnInfo class members, see the ColumnInfo Members topic.

Public Instance Methods

Equals |
GetHashCode |
getPixelWidth |
getPropertyID |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setPixelWidth |
setPropertyID |
toDebugString |
ToString |

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo.Equals Method

public override bool Equals(
Object source
);

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo.GetHashCode Method

public override int GetHashCode();

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo.getPixelWidth Method

public virtual int getPixelWidth();

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo.getPropertyID Method

public virtual int getPropertyID();

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo.setPixelWidth Method

public virtual void setPixelWidth(
Int32 pixelWidth
);

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo.setPropertyID Method

public virtual void setPropertyID(
Int32 propertyID
);

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo.toDebugString Method

public virtual string toDebugString();

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ColumnInfo.ToString Method

public override string ToString();

See Also

ColumnInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandAbortedException Class

For a list of all members of this type, see CommandAbortedException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
ServerException
CommandAbortedException

public class CommandAbortedException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CommandAbortedException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandAbortedException Members

CommandAbortedException overview

Public Static Methods

wrap

Public Instance Constructors

CommandAbortedException Constructor

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |
unwrapCAE |

See Also

CommandAbortedException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandAbortedException Constructor

public CommandAbortedException(
String sErrorMessage
);

See Also

CommandAbortedException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandAbortedException Methods

The methods of the CommandAbortedException class are listed below. For a complete list of CommandAbortedException class members, see the CommandAbortedException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |
unwrapCAE |

See Also

CommandAbortedException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandAbortedException.Equals Method

public override bool Equals(
Object source
);

See Also

CommandAbortedException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandAbortedException.GetHashCode Method

public override int GetHashCode();

See Also

CommandAbortedException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandAbortedException.getMessage Method

public override string getMessage();

See Also

CommandAbortedException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandAbortedException.unwrapCAE Method

public virtual CommandAbortedException unwrapCAE();

See Also

CommandAbortedException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandAbortedException.wrap Method

public static CommandAbortedException wrap(
CommandAbortedException arg
);

See Also

CommandAbortedException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConfigFiles Class

For a list of all members of this type, see ConfigFiles Members.

System.Object
ConfigFiles

public class ConfigFiles

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ConfigFiles Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConfigFiles Members

ConfigFiles overview

Public Static Methods

getConnectionManagerINI | Gets the full path to the ConnectionManager.ini file. <p> On Windows platforms, the file is located in a global application folder: for example, "C:\Documents and Settings\All Users\Application Data\Borland\StarTeam". (Older installations use "...\Application Data\Starbase".) <p> On non-windows platforms, the ConnectionManager.ini file is unused. In this case, getConnectionManagerINI() returns null.
getDefaultCentralStatusDirectory | Returns the default location of the client's local directory for storing centralized status information. <p> On Windows platforms, the file is located in a user-specific application folder: for example, "C:\Documents and Settings\UserName\Local Settings\Application Data\Borland\StarTeam\syncdb". (Older installations use "...\Application Data\Starbase\syncdb".) <p> On non-windows platforms, the file is located in the ".starteam-client/syncdb" subdirectory of the user's home directory. (Older installations use the ".starbase/syncdb" subdirectory.)
getNonWindowsConfig | Returns the default location of the client's configuration settings for non-Windows platforms. (This file is not used by the SDK on Windows.) <p> The name of the configuration file is "platform.ini", located in the ".starteam-client" subdirectory of the user's home directory. (Older installations use the ".starteam" file in ".starbase" subdirectory. Calling this method will copy the new platform.ini from the old location if the new one does not already exist.)
getServerList | Gets the default location of the client's "ServerList.st" file. This file contains a list of StarTeam Server names, with connection information for each server. <p> On Windows platforms, the file is located in a user-specific application folder: for example, "C:\Documents and Settings\UserName\Application Data\Borland\StarTeam". (Older installations use "...\Application Data\Starbase".) <p> On non-windows platforms, the file is located in the ".starteam-client" subdirectory of the user's home directory. (Older installations use the ".starbase" subdirectory.)
getStarTeamINI | Returns the default location of the client's "StarTeam.ini" file. This file contains GUI settings and view and folder working directory overrides. <p> On Windows platforms, the file is located in a user-specific application folder: for example, "C:\Documents and Settings\UserName\Application Data\Borland\StarTeam". (Older installations use "...\Application Data\Starbase".) <p> On non-windows platforms, the file is located in the ".starteam-client" subdirectory of the user's home directory. (Older installations use the ".starbase" subdirectory.)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ConfigFiles Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConfigFiles Methods

The methods of the ConfigFiles class are listed below. For a complete list of ConfigFiles class members, see the ConfigFiles Members topic.

Public Static Methods

getConnectionManagerINI | Gets the full path to the ConnectionManager.ini file. <p> On Windows platforms, the file is located in a global application folder: for example, "C:\Documents and Settings\All Users\Application Data\Borland\StarTeam". (Older installations use "...\Application Data\Starbase".) <p> On non-windows platforms, the ConnectionManager.ini file is unused. In this case, getConnectionManagerINI() returns null.
getDefaultCentralStatusDirectory | Returns the default location of the client's local directory for storing centralized status information. <p> On Windows platforms, the file is located in a user-specific application folder: for example, "C:\Documents and Settings\UserName\Local Settings\Application Data\Borland\StarTeam\syncdb". (Older installations use "...\Application Data\Starbase\syncdb".) <p> On non-windows platforms, the file is located in the ".starteam-client/syncdb" subdirectory of the user's home directory. (Older installations use the ".starbase/syncdb" subdirectory.)
getNonWindowsConfig | Returns the default location of the client's configuration settings for non-Windows platforms. (This file is not used by the SDK on Windows.) <p> The name of the configuration file is "platform.ini", located in the ".starteam-client" subdirectory of the user's home directory. (Older installations use the ".starteam" file in ".starbase" subdirectory. Calling this method will copy the new platform.ini from the old location if the new one does not already exist.)
getServerList | Gets the default location of the client's "ServerList.st" file. This file contains a list of StarTeam Server names, with connection information for each server. <p> On Windows platforms, the file is located in a user-specific application folder: for example, "C:\Documents and Settings\UserName\Application Data\Borland\StarTeam". (Older installations use "...\Application Data\Starbase".) <p> On non-windows platforms, the file is located in the ".starteam-client" subdirectory of the user's home directory. (Older installations use the ".starbase" subdirectory.)
getStarTeamINI | Returns the default location of the client's "StarTeam.ini" file. This file contains GUI settings and view and folder working directory overrides. <p> On Windows platforms, the file is located in a user-specific application folder: for example, "C:\Documents and Settings\UserName\Application Data\Borland\StarTeam". (Older installations use "...\Application Data\Starbase".) <p> On non-windows platforms, the file is located in the ".starteam-client" subdirectory of the user's home directory. (Older installations use the ".starbase" subdirectory.)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ConfigFiles Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConfigFiles.getConnectionManagerINI Method

Gets the full path to the ConnectionManager.ini file. <p> On Windows platforms, the file is located in a global application folder: for example, "C:\Documents and Settings\All Users\Application Data\Borland\StarTeam". (Older installations use "...\Application Data\Starbase".) <p> On non-windows platforms, the ConnectionManager.ini file is unused. In this case, getConnectionManagerINI() returns null.

public static File getConnectionManagerINI();

See Also

ConfigFiles Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConfigFiles.getDefaultCentralStatusDirectory Method

Returns the default location of the client's local directory for storing centralized status information. <p> On Windows platforms, the file is located in a user-specific application folder: for example, "C:\Documents and Settings\UserName\Local Settings\Application Data\Borland\StarTeam\syncdb". (Older installations use "...\Application Data\Starbase\syncdb".) <p> On non-windows platforms, the file is located in the ".starteam-client/syncdb" subdirectory of the user's home directory. (Older installations use the ".starbase/syncdb" subdirectory.)

public static File getDefaultCentralStatusDirectory();

See Also

ConfigFiles Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConfigFiles.getNonWindowsConfig Method

Returns the default location of the client's configuration settings for non-Windows platforms. (This file is not used by the SDK on Windows.) <p> The name of the configuration file is "platform.ini", located in the ".starteam-client" subdirectory of the user's home directory. (Older installations use the ".starteam" file in ".starbase" subdirectory. Calling this method will copy the new platform.ini from the old location if the new one does not already exist.)

public static File getNonWindowsConfig();

See Also

ConfigFiles Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConfigFiles.getServerList Method

Gets the default location of the client's "ServerList.st" file. This file contains a list of StarTeam Server names, with connection information for each server. <p> On Windows platforms, the file is located in a user-specific application folder: for example, "C:\Documents and Settings\UserName\Application Data\Borland\StarTeam". (Older installations use "...\Application Data\Starbase".) <p> On non-windows platforms, the file is located in the ".starteam-client" subdirectory of the user's home directory. (Older installations use the ".starbase" subdirectory.)

public static File getServerList();

See Also

ConfigFiles Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConfigFiles.getStarTeamINI Method

Returns the default location of the client's "StarTeam.ini" file. This file contains GUI settings and view and folder working directory overrides. <p> On Windows platforms, the file is located in a user-specific application folder: for example, "C:\Documents and Settings\UserName\Application Data\Borland\StarTeam". (Older installations use "...\Application Data\Starbase".) <p> On non-windows platforms, the file is located in the ".starteam-client" subdirectory of the user's home directory. (Older installations use the ".starbase" subdirectory.)

public static File getStarTeamINI();

See Also

ConfigFiles Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConfigFiles.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ConfigFiles Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConfigFiles.ToString Method

public override string ToString();

See Also

ConfigFiles Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContainerACLSecLogID Class

For a list of all members of this type, see ContainerACLSecLogID Members.

System.Object
ContainerACLSecLogID

public class ContainerACLSecLogID

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ContainerACLSecLogID Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContainerACLSecLogID Members

ContainerACLSecLogID overview

Public Instance Methods

Equals |
getClassID | Returns the class id.
getContainerID | Returns the container id.
GetHashCode |
getObjectID | Returns the object id.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ContainerACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContainerACLSecLogID Methods

The methods of the ContainerACLSecLogID class are listed below. For a complete list of ContainerACLSecLogID class members, see the ContainerACLSecLogID Members topic.

Public Instance Methods

Equals |
getClassID | Returns the class id.
getContainerID | Returns the container id.
GetHashCode |
getObjectID | Returns the object id.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ContainerACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContainerACLSecLogID.Equals Method

public override bool Equals(
Object source
);

See Also

ContainerACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContainerACLSecLogID.getClassID Method

Returns the class id.

public virtual int getClassID();

See Also

ContainerACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContainerACLSecLogID.getContainerID Method

Returns the container id.

public virtual int getContainerID();

See Also

ContainerACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContainerACLSecLogID.GetHashCode Method

public override int GetHashCode();

See Also

ContainerACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContainerACLSecLogID.getObjectID Method

Returns the object id.

public virtual int getObjectID();

See Also

ContainerACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContainerACLSecLogID.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ContainerACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContainerACLSecLogID.ToString Method

public override string ToString();

See Also

ContainerACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContentFilter Interface

For a list of all members of this type, see ContentFilter Members.

public interface ContentFilter

Types that implement ContentFilter

Type | Description
ContentFilterAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ContentFilter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContentFilter Members

ContentFilter overview

Public Instance Methods

getOutputStream

See Also

ContentFilter Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContentFilter Methods

The methods of the ContentFilter interface are listed below. For a complete list of ContentFilter interface members, see the ContentFilter Members topic.

Public Instance Methods

getOutputStream

See Also

ContentFilter Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ContentFilter.getOutputStream Method

OutputStream getOutputStream(
File file,
OutputStream stream
);

See Also

ContentFilter Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides Class

For a list of all members of this type, see DirectoryOverrides Members.

System.Object
DirectoryOverrides

public class DirectoryOverrides

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

DirectoryOverrides Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides Members

DirectoryOverrides overview

Public Instance Constructors

DirectoryOverrides Constructor Create a new instance with no overrides specified.

Public Instance Methods

Equals |
GetHashCode |
getSourceFile | Returns the source file specifying the override information.
GetType (inherited from Object) | Gets the Type of the current instance.
load | Loads the specified ini file. The parsing is very loose so no errors will occur if it is not really a <code>StarTeam.ini</code> file.
loadDefault | Loads the default ini file for the client platform. On Windows this is the value of the "StarTeam" environment variable which is usually "StarTeam.ini".
MemberwiseClone |
reload | Re-loads the ini.
reloadIfNeeded | Re-loads the ini only if the file's last modified time stamp has changed.
ToString |

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides Constructor

Create a new instance with no overrides specified.

public DirectoryOverrides();

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides Methods

The methods of the DirectoryOverrides class are listed below. For a complete list of DirectoryOverrides class members, see the DirectoryOverrides Members topic.

Public Instance Methods

Equals |
GetHashCode |
getSourceFile | Returns the source file specifying the override information.
GetType (inherited from Object) | Gets the Type of the current instance.
load | Loads the specified ini file. The parsing is very loose so no errors will occur if it is not really a <code>StarTeam.ini</code> file.
loadDefault | Loads the default ini file for the client platform. On Windows this is the value of the "StarTeam" environment variable which is usually "StarTeam.ini".
MemberwiseClone |
reload | Re-loads the ini.
reloadIfNeeded | Re-loads the ini only if the file's last modified time stamp has changed.
ToString |

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides.Equals Method

public override bool Equals(
Object source
);

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides.GetHashCode Method

public override int GetHashCode();

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides.getSourceFile Method

Returns the source file specifying the override information.

public virtual File getSourceFile();

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides.load Method

Loads the specified ini file. The parsing is very loose so no errors will occur if it is not really a <code>StarTeam.ini</code> file.

public virtual void load(
File iniFile
);

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides.loadDefault Method

Loads the default ini file for the client platform. On Windows this is the value of the "StarTeam" environment variable which is usually "StarTeam.ini".

public virtual void loadDefault();

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides.MemberwiseClone Method

public override object MemberwiseClone();

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides.reload Method

Re-loads the ini.

public virtual void reload();

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides.reloadIfNeeded Method

Re-loads the ini only if the file's last modified time stamp has changed.

public virtual void reloadIfNeeded();

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DirectoryOverrides.ToString Method

public override string ToString();

See Also

DirectoryOverrides Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException Class

For a list of all members of this type, see DisembodiedItemException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
DisembodiedItemException

public class DisembodiedItemException : RuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

DisembodiedItemException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException Members

DisembodiedItemException overview

Public Static Methods

wrap

Public Instance Constructors

DisembodiedItemException Overloaded. Initializes a new instance of the DisembodiedItemException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getItem |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException Constructor

Initializes a new instance of the DisembodiedItemException class.

Overload List

Initializes a new instance of the DisembodiedItemException class.

public DisembodiedItemException();

public DisembodiedItemException(String);

public DisembodiedItemException(String,Item);

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException Constructor ()

Initializes a new instance of the DisembodiedItemException class.

public DisembodiedItemException();

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace | DisembodiedItemException Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException Constructor (String)

public DisembodiedItemException(
String message
);

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace | DisembodiedItemException Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException Constructor (String, Item)

public DisembodiedItemException(
String message,
Item disembodiedItem
);

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace | DisembodiedItemException Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException Methods

The methods of the DisembodiedItemException class are listed below. For a complete list of DisembodiedItemException class members, see the DisembodiedItemException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getItem |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException.Equals Method

public override bool Equals(
Object source
);

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException.GetHashCode Method

public override int GetHashCode();

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException.getItem Method

public virtual Item getItem();

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException.getMessage Method

public override string getMessage();

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException.unwrap Method

public virtual DisembodiedException unwrap();

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DisembodiedItemException.wrap Method

public static DisembodiedItemException wrap(
DisembodiedException arg
);

See Also

DisembodiedItemException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DuplicateServerListEntryException Class

For a list of all members of this type, see DuplicateServerListEntryException Members.

System.Object
Exception
Throwable
Exception
DuplicateServerListEntryException

public class DuplicateServerListEntryException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

DuplicateServerListEntryException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DuplicateServerListEntryException Members

DuplicateServerListEntryException overview

Public Static Methods

wrap

Public Instance Constructors

DuplicateServerListEntryException Constructor

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

DuplicateServerListEntryException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DuplicateServerListEntryException Constructor

public DuplicateServerListEntryException(
String message
);

See Also

DuplicateServerListEntryException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DuplicateServerListEntryException Methods

The methods of the DuplicateServerListEntryException class are listed below. For a complete list of DuplicateServerListEntryException class members, see the DuplicateServerListEntryException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

DuplicateServerListEntryException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DuplicateServerListEntryException.Equals Method

public override bool Equals(
Object source
);

See Also

DuplicateServerListEntryException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DuplicateServerListEntryException.GetHashCode Method

public override int GetHashCode();

See Also

DuplicateServerListEntryException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DuplicateServerListEntryException.getMessage Method

public override string getMessage();

See Also

DuplicateServerListEntryException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DuplicateServerListEntryException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

DuplicateServerListEntryException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DuplicateServerListEntryException.unwrap Method

public virtual DuplicateServerListEntryException unwrap();

See Also

DuplicateServerListEntryException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DuplicateServerListEntryException.wrap Method

public static DuplicateServerListEntryException wrap(
DuplicateServerListEntryException arg
);

See Also

DuplicateServerListEntryException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE Class

For a list of all members of this type, see EffectiveACE Members.

System.Object
AclEntry
EffectiveACE

public class EffectiveACE : AclEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

EffectiveACE Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE Members

EffectiveACE overview

Public Instance Methods

addPermission (inherited from AclEntry) |
Equals |
getContainer | Gets the parent container whose ACL defined this ACE.
getDescription | Gets a description of this ACE, explaining its origin in human-readable form.
getGroup | Gets the Group to which this ACE applies.
GetHashCode |
getID (inherited from AclEntry) | Returns the user or group ID for this entry.
getObject | Gets the securable object to which this ACE applies.
getObjectType | Gets the type of securable object to which this ACE applies.
getPermissionFlags (inherited from AclEntry) | Returns the internal "bit set" representation of this entry's permissions. This is the bitwise OR of all added permissions.
GetType (inherited from Object) | Gets the Type of the current instance.
getUser | Gets the User to which this ACE applies.
getUserOrGroupName | Gets the name of the user or group to which this ACE applies.
hasPermission (inherited from AclEntry) |
isExplicitACE | Determines whether or not this is an ACE that is explicitly represented in an Access Control List (ACL) on the object or one of its parent containers.
isFromContainerACL | Determines whether or not this is an ACE that is explicitly defined in the Access Control List (ACL) of one of the object's parent containers.
isFromGroupPrivileges | Determines whether or not this is an ACE that is implied by group privileges.
isFromMissingACE | Determines whether or not this is an ACE that is implicit in the StarTeam access control algorithm: if a given permission is not explicitly specified in an Access Control List (ACL), then access is denied by default.
isFromMissingACL | Determines whether or not this is an ACE that is implicit in the StarTeam access control algorithm: if there is no Access Control List (ACL) defined on an object or on any of its parent containers, then access is granted by default.
isFromObjectACL | Determines whether or not this is an ACE that is explicitly defined in the object's Access Control List (ACL).
isFromObjectOwnership | Determines whether or not this is an ACE that is implied by object ownership rules.
isGranted (inherited from AclEntry) | Returns true if the permissions are granted and false if denied.
isGroupID (inherited from AclEntry) | Returns true if the ID represents a group.
isImpliedACE | Determines whether or not this is an implied ACE that is not explicitly represented in an ACL defined on the object or on one if its parent containers.
MemberwiseClone (inherited from AclEntry) |
removePermission (inherited from AclEntry) |
setGranted (inherited from AclEntry) |
ToString (inherited from AclEntry) |

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE Methods

The methods of the EffectiveACE class are listed below. For a complete list of EffectiveACE class members, see the EffectiveACE Members topic.

Public Instance Methods

addPermission (inherited from AclEntry) |
Equals |
getContainer | Gets the parent container whose ACL defined this ACE.
getDescription | Gets a description of this ACE, explaining its origin in human-readable form.
getGroup | Gets the Group to which this ACE applies.
GetHashCode |
getID (inherited from AclEntry) | Returns the user or group ID for this entry.
getObject | Gets the securable object to which this ACE applies.
getObjectType | Gets the type of securable object to which this ACE applies.
getPermissionFlags (inherited from AclEntry) | Returns the internal "bit set" representation of this entry's permissions. This is the bitwise OR of all added permissions.
GetType (inherited from Object) | Gets the Type of the current instance.
getUser | Gets the User to which this ACE applies.
getUserOrGroupName | Gets the name of the user or group to which this ACE applies.
hasPermission (inherited from AclEntry) |
isExplicitACE | Determines whether or not this is an ACE that is explicitly represented in an Access Control List (ACL) on the object or one of its parent containers.
isFromContainerACL | Determines whether or not this is an ACE that is explicitly defined in the Access Control List (ACL) of one of the object's parent containers.
isFromGroupPrivileges | Determines whether or not this is an ACE that is implied by group privileges.
isFromMissingACE | Determines whether or not this is an ACE that is implicit in the StarTeam access control algorithm: if a given permission is not explicitly specified in an Access Control List (ACL), then access is denied by default.
isFromMissingACL | Determines whether or not this is an ACE that is implicit in the StarTeam access control algorithm: if there is no Access Control List (ACL) defined on an object or on any of its parent containers, then access is granted by default.
isFromObjectACL | Determines whether or not this is an ACE that is explicitly defined in the object's Access Control List (ACL).
isFromObjectOwnership | Determines whether or not this is an ACE that is implied by object ownership rules.
isGranted (inherited from AclEntry) | Returns true if the permissions are granted and false if denied.
isGroupID (inherited from AclEntry) | Returns true if the ID represents a group.
isImpliedACE | Determines whether or not this is an implied ACE that is not explicitly represented in an ACL defined on the object or on one if its parent containers.
MemberwiseClone (inherited from AclEntry) |
removePermission (inherited from AclEntry) |
setGranted (inherited from AclEntry) |
ToString (inherited from AclEntry) |

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.Equals Method

public override bool Equals(
Object source
);

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.getContainer Method

Gets the parent container whose ACL defined this ACE.

public virtual ISecurableContainer getContainer();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.getDescription Method

Gets a description of this ACE, explaining its origin in human-readable form.

public virtual string getDescription();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.getGroup Method

Gets the Group to which this ACE applies.

public virtual Group getGroup();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.GetHashCode Method

public override int GetHashCode();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.getObject Method

Gets the securable object to which this ACE applies.

public virtual ISecurable getObject();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.getObjectType Method

Gets the type of securable object to which this ACE applies.

public virtual Type getObjectType();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.getUser Method

Gets the User to which this ACE applies.

public virtual User getUser();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.getUserOrGroupName Method

Gets the name of the user or group to which this ACE applies.

public virtual string getUserOrGroupName();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.isExplicitACE Method

Determines whether or not this is an ACE that is explicitly represented in an Access Control List (ACL) on the object or one of its parent containers.

public virtual bool isExplicitACE();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.isFromContainerACL Method

Determines whether or not this is an ACE that is explicitly defined in the Access Control List (ACL) of one of the object's parent containers.

public virtual bool isFromContainerACL();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.isFromGroupPrivileges Method

Determines whether or not this is an ACE that is implied by group privileges.

public virtual bool isFromGroupPrivileges();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.isFromMissingACE Method

Determines whether or not this is an ACE that is implicit in the StarTeam access control algorithm: if a given permission is not explicitly specified in an Access Control List (ACL), then access is denied by default.

public virtual bool isFromMissingACE();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.isFromMissingACL Method

Determines whether or not this is an ACE that is implicit in the StarTeam access control algorithm: if there is no Access Control List (ACL) defined on an object or on any of its parent containers, then access is granted by default.

public virtual bool isFromMissingACL();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.isFromObjectACL Method

Determines whether or not this is an ACE that is explicitly defined in the object's Access Control List (ACL).

public virtual bool isFromObjectACL();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.isFromObjectOwnership Method

Determines whether or not this is an ACE that is implied by object ownership rules.

public virtual bool isFromObjectOwnership();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EffectiveACE.isImpliedACE Method

Determines whether or not this is an implied ACE that is not explicitly represented in an ACL defined on the object or on one if its parent containers.

public virtual bool isImpliedACE();

See Also

EffectiveACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EmailAttachment Class

For a list of all members of this type, see EmailAttachment Members.

System.Object
EmailAttachment

public class EmailAttachment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

EmailAttachment Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EmailAttachment Members

EmailAttachment overview

Public Instance Constructors

EmailAttachment Constructor

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

EmailAttachment Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EmailAttachment Constructor

public EmailAttachment(
File source,
String name,
String contentType
);

See Also

EmailAttachment Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EmailAttachment Methods

The methods of the EmailAttachment class are listed below. For a complete list of EmailAttachment class members, see the EmailAttachment Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

EmailAttachment Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EmailAttachment.Equals Method

public override bool Equals(
Object source
);

See Also

EmailAttachment Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EmailAttachment.GetHashCode Method

public override int GetHashCode();

See Also

EmailAttachment Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EmailAttachment.MemberwiseClone Method

public override object MemberwiseClone();

See Also

EmailAttachment Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EmailAttachment.ToString Method

public override string ToString();

See Also

EmailAttachment Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue Class

For a list of all members of this type, see EnumeratedValue Members.

System.Object
EnumeratedValue
CharacterSet
EOLFormat
ProcessItemUsage

public class EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

EnumeratedValue Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue Members

EnumeratedValue overview

Public Instance Constructors

EnumeratedValue Overloaded. Initializes a new instance of the EnumeratedValue class.

Public Instance Methods

copy | Returns a deep copy of this object.
Equals |
getCode | Return the enum code for this object.
getDescription | Returns the description of this object. This may return null if the object was created using a Translations.
getDisplayName | Returns the locale appropriate display name for the enumerated value.
getEnabled | Return true if this enumerated value is enabled.
GetHashCode |
getSortOrder | Get the sort order of this enumerated value.
getTranslations | Returns the display name translations for this enumerated value. May return null if this was created usng a single description string.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setCode |
setDescription |
setEnabled |
setTranslations | Sets the display name translations for this enumerated value.
ToString |

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue Constructor

NOTE: This constructor is now obsolete.

Overload List

public EnumeratedValue(Int32,Translations);

Obsolete.

public EnumeratedValue(Int32,String);

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue Constructor (Int32, String)

NOTE: This constructor is now obsolete.

public EnumeratedValue(
Int32 code,
String description
);

See Also

EnumeratedValue Class | com.starbase.starteam Namespace | EnumeratedValue Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue Constructor (Int32, Translations)

public EnumeratedValue(
Int32 code,
Translations translations
);

See Also

EnumeratedValue Class | com.starbase.starteam Namespace | EnumeratedValue Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue Methods

The methods of the EnumeratedValue class are listed below. For a complete list of EnumeratedValue class members, see the EnumeratedValue Members topic.

Public Instance Methods

copy | Returns a deep copy of this object.
Equals |
getCode | Return the enum code for this object.
getDescription | Returns the description of this object. This may return null if the object was created using a Translations.
getDisplayName | Returns the locale appropriate display name for the enumerated value.
getEnabled | Return true if this enumerated value is enabled.
GetHashCode |
getSortOrder | Get the sort order of this enumerated value.
getTranslations | Returns the display name translations for this enumerated value. May return null if this was created usng a single description string.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setCode |
setDescription |
setEnabled |
setTranslations | Sets the display name translations for this enumerated value.
ToString |

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.copy Method

Returns a deep copy of this object.

public virtual EnumeratedValue copy();

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.Equals Method

public override bool Equals(
Object source
);

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.getCode Method

Return the enum code for this object.

public virtual int getCode();

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.getDescription Method

Returns the description of this object. This may return null if the object was created using a Translations.

public virtual string getDescription();

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.getDisplayName Method

Returns the locale appropriate display name for the enumerated value.

public virtual string getDisplayName();

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.getEnabled Method

Return true if this enumerated value is enabled.

public virtual bool getEnabled();

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.GetHashCode Method

public override int GetHashCode();

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.getSortOrder Method

Get the sort order of this enumerated value.

public virtual int getSortOrder();

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.getTranslations Method

Returns the display name translations for this enumerated value. May return null if this was created usng a single description string.

public virtual Translations getTranslations();

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.MemberwiseClone Method

public override object MemberwiseClone();

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.setCode Method

public virtual void setCode(
Int32 code
);

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.setDescription Method

public virtual void setDescription(
String description
);

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.setEnabled Method

public virtual void setEnabled(
Boolean enabled
);

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.setTranslations Method

Sets the display name translations for this enumerated value.

public virtual void setTranslations(
Translations translations
);

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EnumeratedValue.ToString Method

public override string ToString();

See Also

EnumeratedValue Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat Class

For a list of all members of this type, see EOLFormat Members.

System.Object
EnumeratedValue
EOLFormat

public class EOLFormat : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

EOLFormat Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat Members

EOLFormat overview

Public Static Fields

ALL
CLIENT_DEFINED
FIXED_CR
FIXED_CRLF
FIXED_LF
PLATFORM

Public Static Methods

fromEOL
fromEOLFormatID

Public Instance Methods

copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Equals (inherited from EnumeratedValue) |
getCode (inherited from EnumeratedValue) | Return the enum code for this object.
getDescription (inherited from EnumeratedValue) | Returns the description of this object. This may return null if the object was created using a Translations.
getDisplayName (inherited from EnumeratedValue) | Returns the locale appropriate display name for the enumerated value.
getEnabled (inherited from EnumeratedValue) | Return true if this enumerated value is enabled.
getEOL | Gets the actual end-of-line character sequence for this EOLFormat. For CLIENT_DEFINED, returns the default platform end-of-line sequence.
getEOLFormatID | An ID associated with this EOL format, as used in {@linkplain com.borland.starteam.impl.util.LineReader LineReader}.
GetHashCode (inherited from EnumeratedValue) |
getSortOrder (inherited from EnumeratedValue) | Get the sort order of this enumerated value.
getTranslations (inherited from EnumeratedValue) | Returns the display name translations for this enumerated value. May return null if this was created usng a single description string.
GetType (inherited from Object) | Gets the Type of the current instance.
isFixed | Returns true if this is one of the fixed EOL formats; false for CLIENT_DEFINED.
MemberwiseClone (inherited from EnumeratedValue) |
setCode (inherited from EnumeratedValue) |
setDescription (inherited from EnumeratedValue) |
setEnabled (inherited from EnumeratedValue) |
setTranslations (inherited from EnumeratedValue) | Sets the display name translations for this enumerated value.
toPropertyValue | Gets the EOLFormat used as the default value of the FILE_EOL_CHARACTER property for files whose actual EOLFormat is this one. <p> Returns CLIENT_DEFINED if this EOLFormat matches the PLATFORM EOLFormat; otehrwise, returns this EOLFormat itself.
ToString (inherited from EnumeratedValue) |

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat Fields

The fields of the EOLFormat class are listed below. For a complete list of EOLFormat class members, see the EOLFormat Members topic.

Public Static Fields

ALL
CLIENT_DEFINED
FIXED_CR
FIXED_CRLF
FIXED_LF
PLATFORM

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.ALL Field

public static readonly EOLFormat[] ALL;

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.CLIENT_DEFINED Field

public static readonly EOLFormat CLIENT_DEFINED;

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.FIXED_CR Field

public static readonly EOLFormat FIXED_CR;

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.FIXED_CRLF Field

public static readonly EOLFormat FIXED_CRLF;

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.FIXED_LF Field

public static readonly EOLFormat FIXED_LF;

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.PLATFORM Field

public static readonly EOLFormat PLATFORM;

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat Methods

The methods of the EOLFormat class are listed below. For a complete list of EOLFormat class members, see the EOLFormat Members topic.

Public Static Methods

fromEOL
fromEOLFormatID

Public Instance Methods

copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Equals (inherited from EnumeratedValue) |
getCode (inherited from EnumeratedValue) | Return the enum code for this object.
getDescription (inherited from EnumeratedValue) | Returns the description of this object. This may return null if the object was created using a Translations.
getDisplayName (inherited from EnumeratedValue) | Returns the locale appropriate display name for the enumerated value.
getEnabled (inherited from EnumeratedValue) | Return true if this enumerated value is enabled.
getEOL | Gets the actual end-of-line character sequence for this EOLFormat. For CLIENT_DEFINED, returns the default platform end-of-line sequence.
getEOLFormatID | An ID associated with this EOL format, as used in {@linkplain com.borland.starteam.impl.util.LineReader LineReader}.
GetHashCode (inherited from EnumeratedValue) |
getSortOrder (inherited from EnumeratedValue) | Get the sort order of this enumerated value.
getTranslations (inherited from EnumeratedValue) | Returns the display name translations for this enumerated value. May return null if this was created usng a single description string.
GetType (inherited from Object) | Gets the Type of the current instance.
isFixed | Returns true if this is one of the fixed EOL formats; false for CLIENT_DEFINED.
MemberwiseClone (inherited from EnumeratedValue) |
setCode (inherited from EnumeratedValue) |
setDescription (inherited from EnumeratedValue) |
setEnabled (inherited from EnumeratedValue) |
setTranslations (inherited from EnumeratedValue) | Sets the display name translations for this enumerated value.
toPropertyValue | Gets the EOLFormat used as the default value of the FILE_EOL_CHARACTER property for files whose actual EOLFormat is this one. <p> Returns CLIENT_DEFINED if this EOLFormat matches the PLATFORM EOLFormat; otehrwise, returns this EOLFormat itself.
ToString (inherited from EnumeratedValue) |

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.fromEOL Method

public static EOLFormat fromEOL(
String eol
);

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.fromEOLFormatID Method

public static EOLFormat fromEOLFormatID(
Int32 id
);

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.getEOL Method

Gets the actual end-of-line character sequence for this EOLFormat. For CLIENT_DEFINED, returns the default platform end-of-line sequence.

public virtual string getEOL();

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.getEOLFormatID Method

An ID associated with this EOL format, as used in {@linkplain com.borland.starteam.impl.util.LineReader LineReader}.

public virtual int getEOLFormatID();

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.isFixed Method

Returns true if this is one of the fixed EOL formats; false for CLIENT_DEFINED.

public virtual bool isFixed();

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLFormat.toPropertyValue Method

Gets the EOLFormat used as the default value of the FILE_EOL_CHARACTER property for files whose actual EOLFormat is this one. <p> Returns CLIENT_DEFINED if this EOLFormat matches the PLATFORM EOLFormat; otehrwise, returns this EOLFormat itself.

public virtual EOLFormat toPropertyValue();

See Also

EOLFormat Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo Class

For a list of all members of this type, see EventHandlerInfo Members.

System.Object
EventHandlerInfo

public class EventHandlerInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

EventHandlerInfo Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo Members

EventHandlerInfo overview

Public Static Fields

MPX_TRANSMITTER Obsolete.

Public Instance Methods

addProfile | Add an EventHandlerProfile to this EventHandlerInfo object.
deleteProfile | Remove an EventHandlerProfile from this EventHandlerInfo object.
Equals |
getDescription | Gets the description of this EventHandlerInfo.
GetHashCode |
getName | Gets the name of this EventHandlerInfo.
getProfile |
getProfileNames | Returns an array containing the names of all existing EventHandlerProfiles of this EventHandlerInfo.
getProperty |
getPropertyNames | Gets the names of all existing properties of this EventHandlerInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
putProperty |
removeProperty |
setDescription |
ToString |
update | Stores the existing EventHandlerInfo in the server.

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo Fields

The fields of the EventHandlerInfo class are listed below. For a complete list of EventHandlerInfo class members, see the EventHandlerInfo Members topic.

Public Static Fields

MPX_TRANSMITTER Obsolete.

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.MPX_TRANSMITTER Field

NOTE: This field is now obsolete.

public const String MPX_TRANSMITTER = "StarbaseMPX Transmitter";

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo Methods

The methods of the EventHandlerInfo class are listed below. For a complete list of EventHandlerInfo class members, see the EventHandlerInfo Members topic.

Public Instance Methods

addProfile | Add an EventHandlerProfile to this EventHandlerInfo object.
deleteProfile | Remove an EventHandlerProfile from this EventHandlerInfo object.
Equals |
getDescription | Gets the description of this EventHandlerInfo.
GetHashCode |
getName | Gets the name of this EventHandlerInfo.
getProfile |
getProfileNames | Returns an array containing the names of all existing EventHandlerProfiles of this EventHandlerInfo.
getProperty |
getPropertyNames | Gets the names of all existing properties of this EventHandlerInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
putProperty |
removeProperty |
setDescription |
ToString |
update | Stores the existing EventHandlerInfo in the server.

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.addProfile Method

Add an EventHandlerProfile to this EventHandlerInfo object.

public virtual void addProfile(
EventHandlerProfile profile
);

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.deleteProfile Method

Remove an EventHandlerProfile from this EventHandlerInfo object.

public virtual void deleteProfile(
EventHandlerProfile profile
);

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.Equals Method

public override bool Equals(
Object source
);

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.getDescription Method

Gets the description of this EventHandlerInfo.

public virtual string getDescription();

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.GetHashCode Method

public override int GetHashCode();

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.getName Method

Gets the name of this EventHandlerInfo.

public virtual string getName();

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.getProfile Method

public virtual EventHandlerProfile getProfile(
String profileName
);

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.getProfileNames Method

Returns an array containing the names of all existing EventHandlerProfiles of this EventHandlerInfo.

public virtual string[] getProfileNames();

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.getProperty Method

public virtual object getProperty(
String propertyName
);

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.getPropertyNames Method

Gets the names of all existing properties of this EventHandlerInfo.

public virtual string[] getPropertyNames();

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.MemberwiseClone Method

public override object MemberwiseClone();

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.putProperty Method

public virtual object putProperty(
String propertyName,
Object value
);

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.removeProperty Method

public virtual object removeProperty(
String propertyName
);

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.setDescription Method

public virtual void setDescription(
String description
);

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.ToString Method

public override string ToString();

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerInfo.update Method

Stores the existing EventHandlerInfo in the server.

public virtual void update();

See Also

EventHandlerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile Class

For a list of all members of this type, see EventHandlerProfile Members.

System.Object
EventHandlerProfile

public class EventHandlerProfile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

EventHandlerProfile Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile Members

EventHandlerProfile overview

Public Instance Constructors

EventHandlerProfile Constructor

Public Instance Methods

copy | Creates a copy of this EventHandlerProfile. Copies the Name, Description, all the individual properties, and their associated values.
duplicate | Obsolete.
Equals |
getDescription | Gets the description of this EventHandlerProfile.
GetHashCode |
getName | Gets the name of this EventHandlerProfile.
getProperty |
getPropertyNames | Gets the names of all existing properties of this EventHandlerProfile.
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo | Compares two EventHandlerProfile objects. Compares the Name, Description, all the individual properties, and their associated values.
MemberwiseClone |
putProperty |
removeProperty |
setDescription |
ToString |
update | Stores the existing EventHandlerProfile in the server. If the EventHandlerProfile is new, EventHandlerInfo.addProfile() should be called instead.

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile Constructor

public EventHandlerProfile(
String name,
String description
);

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile Methods

The methods of the EventHandlerProfile class are listed below. For a complete list of EventHandlerProfile class members, see the EventHandlerProfile Members topic.

Public Instance Methods

copy | Creates a copy of this EventHandlerProfile. Copies the Name, Description, all the individual properties, and their associated values.
duplicate | Obsolete.
Equals |
getDescription | Gets the description of this EventHandlerProfile.
GetHashCode |
getName | Gets the name of this EventHandlerProfile.
getProperty |
getPropertyNames | Gets the names of all existing properties of this EventHandlerProfile.
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo | Compares two EventHandlerProfile objects. Compares the Name, Description, all the individual properties, and their associated values.
MemberwiseClone |
putProperty |
removeProperty |
setDescription |
ToString |
update | Stores the existing EventHandlerProfile in the server. If the EventHandlerProfile is new, EventHandlerInfo.addProfile() should be called instead.

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.copy Method

Creates a copy of this EventHandlerProfile. Copies the Name, Description, all the individual properties, and their associated values.

public virtual EventHandlerProfile copy();

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.duplicate Method

NOTE: This method is now obsolete.

public virtual EventHandlerProfile duplicate(
String name,
String description
);

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.Equals Method

public override bool Equals(
Object source
);

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.getDescription Method

Gets the description of this EventHandlerProfile.

public virtual string getDescription();

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.GetHashCode Method

public override int GetHashCode();

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.getName Method

Gets the name of this EventHandlerProfile.

public virtual string getName();

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.getProperty Method

public virtual object getProperty(
String propertyName
);

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.getPropertyNames Method

Gets the names of all existing properties of this EventHandlerProfile.

public virtual string[] getPropertyNames();

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.isEqualTo Method

Compares two EventHandlerProfile objects. Compares the Name, Description, all the individual properties, and their associated values.

public virtual bool isEqualTo(
EventHandlerProfile p
);

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.MemberwiseClone Method

public override object MemberwiseClone();

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.putProperty Method

public virtual object putProperty(
String propertyName,
Object value
);

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.removeProperty Method

public virtual object removeProperty(
String propertyName
);

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.setDescription Method

public virtual void setDescription(
String description
);

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.ToString Method

public override string ToString();

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EventHandlerProfile.update Method

Stores the existing EventHandlerProfile in the server. If the EventHandlerProfile is new, EventHandlerInfo.addProfile() should be called instead.

public virtual void update();

See Also

EventHandlerProfile Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File Class

For a list of all members of this type, see File Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Item
File

public class File : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

File Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File Members

File overview

Public Static Methods

getDefaultEncoding | Obsolete. Gets the default file encoding.
isInSyncByMD5 |
isInSyncByTime |
setDefaultEncoding | Obsolete.

Public Instance Constructors

File Constructor Creates a new file instance.

Public Instance Methods

acquireOwnership (inherited from Item)
add | Overloaded.
addAndReturn | Overloaded.
addAttachment (inherited from Item)
addFromStream | Overloaded.
addToIntArray (inherited from TypedResource)
checkin | Overloaded. Check in this File using the specified options
checkinFrom | Overloaded.
checkinFromAndReturn | Overloaded.
checkinFromStream | Overloaded.
checkout | Overloaded. Check out this File using the specified options.
checkoutByDate
checkoutByLabelID
checkoutByVersion
checkoutTo
checkoutToAndReturn
checkoutToStream
Clone (inherited from CacheRef)
convertArchive
convertToNativeIIArchive
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
deleteLocalFile | Deletes the specified local file and has the side effect of deleting sync information from the server about the file.
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
deleteSyncInfo | Removes sync information from this File object's Server. Once it has been called the Status for file will be unknown. Use with caution.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals
findCommonAnscestor | Obsolete. Returns the most recent common ancestor of this file with the specified file. The common version is taken from this file's history. It may return null if no common version was found.
findMergeVersion | Returns a revision from this file's history that represents the most recent common ancestor of this file with the last known version on disk. It may return null if the status is Unknown or if the sync version is not from the same version graph.
get (inherited from Item)
getACL (inherited from Item)
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getArchiveFormat | The format of archive the server happens to be storing this file in -- Native-I, Native-II, or not applicable.
getArchiveFormatDisplayName
getArchiveName | The name of archive.
getArchiveType | The type of archive the server happens to be storing this file in--StarTeam native, PVCS, Visual SourceSafe, etc.
getArchiveTypeDisplayName
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getBlankKeywords | Returns an array of the default StarTeam keywords. All the keywords are "blank" meaning no values are filled in. This can be used to unexpand keywords in a file where the actual keyword values are not needed.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getCharacterSet | Returns the Character Set that determine this file content
getCharset | The character set this file appears to use. Text and binary are the only values currently supported.
getCharsetDisplayName
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getCompression | Returns an <code>int</code> describing the compression level being used to store versions of this file in the repository.
getCompressionDisplayName
getContentModificationTime | Returns the "last modified" timestamp of the working file when it was checked in to create this version. Note that this value comes from the local machine where the checkin occured.
getContentVersion | Returns the content version number for this file. The first revision of any file item will have a value of 1 for this property. The value only changes when a new revision of the file is checked-in for which the file contents or the file name has changed. This value does not increment if only meta properties are modified (for example, the description). When a file item branches the value of this property does not revert to 1 but rather continues to increase as new revisions are added. This value is maintained in order to make status computation easier and more "accurate" (for example, a file should not need checkout if only its description changed).
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDescription | Returns the description of this file.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getEOLFormat | Gets the end-of-line format used by this file's working files on disk. Supported only on StarTeam Server version 2009 and later; on earlier servers, the value is always reported as null.
getExtension | Returns the file name extension. E.g. for "foo.txt" this would return "txt", for "foo" it would return the empty string.
getFileSyncInfo | Obsolete.
getFileSyncInfoEx
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
getFullName | Returns the concatenation of this file's name with the working directory of the file's parent folder. This should return the full path to this file's working location on disk.
GetHashCode
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLastKnownStatus | Returns the last known status of the default working file relative to the file in the repository, using only information provided by the client during the last status update operation. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).
getLastKnownVersionOnDisk | Returns the last known version of this file on disk. Returns -1 if the status information is unknown. The value returned is the view version of the last known revision on disk. This method will refresh the status information prior to determining the value and hence might be expensive to compute if called often.
getLocalFileExecutable | Returns true if the local file is executable.
getLocalFileExists | Returns true if the local file exists on disk.
getLocalName | Returns the local file name, as recognized by the local file system.
getLocalPath | Returns the local path, as recognized by the local file system.
getLocalSize | Obsolete. Returns the local file's size. If the file does not exist this returns -1.
getLocalSizeEx | Returns the local file's size. If the file does not exist this returns -1.
getLocalTimeStamp | Returns the local file's time stamp. If the local file does not exist this will return a time whose double value is 0.0.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMD5 | The MD5 hash bytes of the file contents for this version. This is the value for the file contents in the repository which may differ from that of the corresponding file on disk if end-of-line or keyword expasion has been applied.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getName | Returns the name of this file. This is the name only--contrast with getFullName.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPossibleArchiveFormat | Returns the possible enum codes that are valid values for the ArchiveFormat property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleArchiveType | Returns the possible enum codes that are valid values for the ArchiveType property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleCharset | Returns the possible enum codes that are valid values for the Charset property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleCompression | Returns the possible enum codes that are valid values for the Compression property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleStorageFormat | Returns the possible enum codes that are valid values for the StorageFormat property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPropertyNames (inherited from Item)
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getSize | Obsolete. The size of this file in the repository. Note that this may be different than the size of the local file if end-of-line conversion or keyword expansion is used.
getSizeEx | The size of this file in the repository. Note that this may be different than the size of the local file if end-of-line conversion or keyword expansion is used.
getSmartStatus | Overloaded. Gets the status of the default working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.
getStatus | Overloaded. Gets the status of the default working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk.
getStatusByMD5 | Returns the status of the default working file relative to the file in the repository, using the given size MD5 signature of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).
getStatusByTime | Obsolete.
getStatusByTimeEx
getStatusKnown | Returns true if status information is known for this file. Returns true if status information is known for this file.
getStatusNow | Same as getStatus, but this method first goes to the server to refresh the status information.
getStorageFormat | Returns an enumerated value describing the storage format being used to store versions of this file--that is, delta or full version storage.
getStorageFormatDisplayName
getString (inherited from Item)
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getVaultVersion | Returns the vault version number for this file. The vault revision number is really an implementation detail of the StarTeam vault and the value of this property is not of much general use.
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBinary | Tells whether this file (in the repository) has been determined to be a binary file. StarTeam flags a file as "binary" if any null (0x0) characters are found in the file.
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
isUnicode | Tells whether this file (in the repository) has been determined to be a unicode file.
lock
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move (inherited from Item) | Obsolete. Moves this item to the specified folder. The item will be removed from its current folder.
moveLocalFile
moveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put (inherited from Item)
putByPropertyID (inherited from Item)
putLock
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
removeAndDeleteLocal | Removes the file item from its parent folder. Note that a file may be shared in another folder in the same or different view. This method will merely remove the one instance (or shared copy) that the method is called on. In addition, this method will delete the corresponding working file.
removeAttachment (inherited from Item)
removeFromIntArray (inherited from TypedResource)
rename
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
resyncStatus | Obsolete.
resyncStatusEx
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setCharacterSet | set the Character Set that determines this file content file content will be treated as ASCII, Binary or UNICODE, and is automatically determined when the file is being checked in, unless the encoding is explicitly specified. In this case, the specified encoding overrides any computed value
setComment (inherited from Item)
setCompression
setContentModificationTime | Sets this file's content modification time. You need to call one of the "update" (update, checkin, add) methods to persist this information.
setDescription
setEOLFormat | Sets the end-of-line format used by this file's working files on disk. Supported only on StarTeam Server version 2009 and later.
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setName
setStorageFormat
shareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. <p> If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString
unlock
update
updateRevisionComment (inherited from Item)
updateStatus | Overloaded.
updateStatusAfterMerge | Updates the server's status information to reflect the fact that the local file's contents were derived from this file's contents. You would most commonly want to call this after merging in changes. This file's status will be "Modified" after a call to this method if this file is the tip version of the file.
updateStatusFromMD5 | Updates the server's status information to reflect the fact that the local file's content has the given MD5 signature. <p>The file size and last modified date are assumed to be unknown. Any previously specified values will remain unchanged. <p>This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
updateStatusFromTime | Obsolete.
updateStatusFromTimeEx
updateStatusInformation | Obsolete.
updateStatusInformationEx
upgradeSyncInfo | Obsolete. Move status records from an old server to the new client managed status information. Returns true if sync information was found and moved locally and false otherwise. This will return false and do nothing if the file is from a newer server that supports client managed status.
usesKeywords | Tells whether or not this file will use keyword expansion. This is determined by looking at the project's keyword properties and this file's extension.

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File Constructor

Creates a new file instance.

public File(
Folder parentFolder
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File Methods

The methods of the File class are listed below. For a complete list of File class members, see the File Members topic.

Public Static Methods

getDefaultEncoding | Obsolete. Gets the default file encoding.
isInSyncByMD5 |
isInSyncByTime |
setDefaultEncoding | Obsolete.

Public Instance Methods

acquireOwnership (inherited from Item)
add | Overloaded.
addAndReturn | Overloaded.
addAttachment (inherited from Item)
addFromStream | Overloaded.
addToIntArray (inherited from TypedResource)
checkin | Overloaded. Check in this File using the specified options
checkinFrom | Overloaded.
checkinFromAndReturn | Overloaded.
checkinFromStream | Overloaded.
checkout | Overloaded. Check out this File using the specified options.
checkoutByDate
checkoutByLabelID
checkoutByVersion
checkoutTo
checkoutToAndReturn
checkoutToStream
Clone (inherited from CacheRef)
convertArchive
convertToNativeIIArchive
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
deleteLocalFile | Deletes the specified local file and has the side effect of deleting sync information from the server about the file.
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
deleteSyncInfo | Removes sync information from this File object's Server. Once it has been called the Status for file will be unknown. Use with caution.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals
findCommonAnscestor | Obsolete. Returns the most recent common ancestor of this file with the specified file. The common version is taken from this file's history. It may return null if no common version was found.
findMergeVersion | Returns a revision from this file's history that represents the most recent common ancestor of this file with the last known version on disk. It may return null if the status is Unknown or if the sync version is not from the same version graph.
get (inherited from Item)
getACL (inherited from Item)
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getArchiveFormat | The format of archive the server happens to be storing this file in -- Native-I, Native-II, or not applicable.
getArchiveFormatDisplayName
getArchiveName | The name of archive.
getArchiveType | The type of archive the server happens to be storing this file in--StarTeam native, PVCS, Visual SourceSafe, etc.
getArchiveTypeDisplayName
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getBlankKeywords | Returns an array of the default StarTeam keywords. All the keywords are "blank" meaning no values are filled in. This can be used to unexpand keywords in a file where the actual keyword values are not needed.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getCharacterSet | Returns the Character Set that determine this file content
getCharset | The character set this file appears to use. Text and binary are the only values currently supported.
getCharsetDisplayName
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getCompression | Returns an <code>int</code> describing the compression level being used to store versions of this file in the repository.
getCompressionDisplayName
getContentModificationTime | Returns the "last modified" timestamp of the working file when it was checked in to create this version. Note that this value comes from the local machine where the checkin occured.
getContentVersion | Returns the content version number for this file. The first revision of any file item will have a value of 1 for this property. The value only changes when a new revision of the file is checked-in for which the file contents or the file name has changed. This value does not increment if only meta properties are modified (for example, the description). When a file item branches the value of this property does not revert to 1 but rather continues to increase as new revisions are added. This value is maintained in order to make status computation easier and more "accurate" (for example, a file should not need checkout if only its description changed).
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDescription | Returns the description of this file.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getEOLFormat | Gets the end-of-line format used by this file's working files on disk. Supported only on StarTeam Server version 2009 and later; on earlier servers, the value is always reported as null.
getExtension | Returns the file name extension. E.g. for "foo.txt" this would return "txt", for "foo" it would return the empty string.
getFileSyncInfo | Obsolete.
getFileSyncInfoEx
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
getFullName | Returns the concatenation of this file's name with the working directory of the file's parent folder. This should return the full path to this file's working location on disk.
GetHashCode
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLastKnownStatus | Returns the last known status of the default working file relative to the file in the repository, using only information provided by the client during the last status update operation. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).
getLastKnownVersionOnDisk | Returns the last known version of this file on disk. Returns -1 if the status information is unknown. The value returned is the view version of the last known revision on disk. This method will refresh the status information prior to determining the value and hence might be expensive to compute if called often.
getLocalFileExecutable | Returns true if the local file is executable.
getLocalFileExists | Returns true if the local file exists on disk.
getLocalName | Returns the local file name, as recognized by the local file system.
getLocalPath | Returns the local path, as recognized by the local file system.
getLocalSize | Obsolete. Returns the local file's size. If the file does not exist this returns -1.
getLocalSizeEx | Returns the local file's size. If the file does not exist this returns -1.
getLocalTimeStamp | Returns the local file's time stamp. If the local file does not exist this will return a time whose double value is 0.0.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMD5 | The MD5 hash bytes of the file contents for this version. This is the value for the file contents in the repository which may differ from that of the corresponding file on disk if end-of-line or keyword expasion has been applied.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getName | Returns the name of this file. This is the name only--contrast with getFullName.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPossibleArchiveFormat | Returns the possible enum codes that are valid values for the ArchiveFormat property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleArchiveType | Returns the possible enum codes that are valid values for the ArchiveType property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleCharset | Returns the possible enum codes that are valid values for the Charset property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleCompression | Returns the possible enum codes that are valid values for the Compression property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleStorageFormat | Returns the possible enum codes that are valid values for the StorageFormat property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPropertyNames (inherited from Item)
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getSize | Obsolete. The size of this file in the repository. Note that this may be different than the size of the local file if end-of-line conversion or keyword expansion is used.
getSizeEx | The size of this file in the repository. Note that this may be different than the size of the local file if end-of-line conversion or keyword expansion is used.
getSmartStatus | Overloaded. Gets the status of the default working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.
getStatus | Overloaded. Gets the status of the default working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk.
getStatusByMD5 | Returns the status of the default working file relative to the file in the repository, using the given size MD5 signature of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).
getStatusByTime | Obsolete.
getStatusByTimeEx
getStatusKnown | Returns true if status information is known for this file. Returns true if status information is known for this file.
getStatusNow | Same as getStatus, but this method first goes to the server to refresh the status information.
getStorageFormat | Returns an enumerated value describing the storage format being used to store versions of this file--that is, delta or full version storage.
getStorageFormatDisplayName
getString (inherited from Item)
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getVaultVersion | Returns the vault version number for this file. The vault revision number is really an implementation detail of the StarTeam vault and the value of this property is not of much general use.
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBinary | Tells whether this file (in the repository) has been determined to be a binary file. StarTeam flags a file as "binary" if any null (0x0) characters are found in the file.
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
isUnicode | Tells whether this file (in the repository) has been determined to be a unicode file.
lock
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move (inherited from Item) | Obsolete. Moves this item to the specified folder. The item will be removed from its current folder.
moveLocalFile
moveTo (inherited from Item) | Moves this item to the specified folder. The item will be removed from its current folder.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put (inherited from Item)
putByPropertyID (inherited from Item)
putLock
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove (inherited from Item) | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
removeAndDeleteLocal | Removes the file item from its parent folder. Note that a file may be shared in another folder in the same or different view. This method will merely remove the one instance (or shared copy) that the method is called on. In addition, this method will delete the corresponding working file.
removeAttachment (inherited from Item)
removeFromIntArray (inherited from TypedResource)
rename
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
resyncStatus | Obsolete.
resyncStatusEx
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setCharacterSet | set the Character Set that determines this file content file content will be treated as ASCII, Binary or UNICODE, and is automatically determined when the file is being checked in, unless the encoding is explicitly specified. In this case, the specified encoding overrides any computed value
setComment (inherited from Item)
setCompression
setContentModificationTime | Sets this file's content modification time. You need to call one of the "update" (update, checkin, add) methods to persist this information.
setDescription
setEOLFormat | Sets the end-of-line format used by this file's working files on disk. Supported only on StarTeam Server version 2009 and later.
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setName
setStorageFormat
shareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. <p> If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString
unlock
update
updateRevisionComment (inherited from Item)
updateStatus | Overloaded.
updateStatusAfterMerge | Updates the server's status information to reflect the fact that the local file's contents were derived from this file's contents. You would most commonly want to call this after merging in changes. This file's status will be "Modified" after a call to this method if this file is the tip version of the file.
updateStatusFromMD5 | Updates the server's status information to reflect the fact that the local file's content has the given MD5 signature. <p>The file size and last modified date are assumed to be unknown. Any previously specified values will remain unchanged. <p>This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.
updateStatusFromTime | Obsolete.
updateStatusFromTimeEx
updateStatusInformation | Obsolete.
updateStatusInformationEx
upgradeSyncInfo | Obsolete. Move status records from an old server to the new client managed status information. Returns true if sync information was found and moved locally and false otherwise. This will return false and do nothing if the file is from a newer server that supports client managed status.
usesKeywords | Tells whether or not this file will use keyword expansion. This is determined by looking at the project's keyword properties and this file's extension.

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


add Method

Borland StarTeam SDK for .NET

File.add Method

Overload List

public virtual void add(File,String,String,String,Int32,Boolean);

Obsolete.

public virtual void add(File,String,String,String,Int32,Boolean,Boolean);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.add Method (File, String, String, String, Int32, Boolean)

public virtual void add(
File file,
String name,
String desc,
String reason,
Int32 lockStatus,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.add Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.add Method (File, String, String, String, Int32, Boolean, Boolean)

NOTE: This method is now obsolete.

public virtual void add(
File file,
String name,
String desc,
String reason,
Int32 lockStatus,
Boolean eol,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.add Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


addAndReturn Method

Borland StarTeam SDK for .NET

File.addAndReturn Method

Overload List

public virtual AddResult addAndReturn(File,String,String,String,Int32,Boolean);

Obsolete.

public virtual AddResult addAndReturn(File,String,String,String,Int32,Boolean,Boolean);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.addAndReturn Method (File, String, String, String, Int32, Boolean)

public virtual AddResult addAndReturn(
File file,
String name,
String desc,
String reason,
Int32 lockStatus,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.addAndReturn Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.addAndReturn Method (File, String, String, String, Int32, Boolean, Boolean)

NOTE: This method is now obsolete.

public virtual AddResult addAndReturn(
File file,
String name,
String desc,
String reason,
Int32 lockStatus,
Boolean eol,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.addAndReturn Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


addFromStream Method

Borland StarTeam SDK for .NET

File.addFromStream Method

Overload List

public virtual void addFromStream(InputStream,String,String,String,Int32);

Obsolete.

public virtual void addFromStream(InputStream,String,String,String,Int32,Boolean);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.addFromStream Method (InputStream, String, String, String, Int32)

public virtual void addFromStream(
InputStream stream,
String fileName,
String description,
String comment,
Int32 lockStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.addFromStream Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.addFromStream Method (InputStream, String, String, String, Int32, Boolean)

NOTE: This method is now obsolete.

public virtual void addFromStream(
InputStream stream,
String fileName,
String description,
String comment,
Int32 lockStatus,
Boolean eol
);

See Also

File Class | com.starbase.starteam Namespace | File.addFromStream Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


checkin Method

Borland StarTeam SDK for .NET

File.checkin Method

Check in this File using the specified options

Overload List

Check in this File using the specified options

public virtual void checkin(CheckinOptions);

public virtual void checkin(String,Int32,Boolean,Boolean);

Obsolete.

public virtual void checkin(String,Int32,Boolean,Boolean,Boolean);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkin Method (CheckinOptions)

Check in this File using the specified options

public virtual void checkin(
CheckinOptions options
);

See Also

File Class | com.starbase.starteam Namespace | File.checkin Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkin Method (String, Int32, Boolean, Boolean)

public virtual void checkin(
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.checkin Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkin Method (String, Int32, Boolean, Boolean, Boolean)

NOTE: This method is now obsolete.

public virtual void checkin(
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean eol,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.checkin Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


checkinFrom Method

Borland StarTeam SDK for .NET

File.checkinFrom Method

Overload List

public virtual void checkinFrom(File,String,Int32,Boolean,Boolean);

Obsolete.

public virtual void checkinFrom(File,String,Int32,Boolean,Boolean,Boolean);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkinFrom Method (File, String, Int32, Boolean, Boolean)

public virtual void checkinFrom(
File file,
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.checkinFrom Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkinFrom Method (File, String, Int32, Boolean, Boolean, Boolean)

NOTE: This method is now obsolete.

public virtual void checkinFrom(
File file,
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean eol,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.checkinFrom Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


checkinFromAndReturn Method

Borland StarTeam SDK for .NET

File.checkinFromAndReturn Method

Overload List

public virtual CheckInResult checkinFromAndReturn(File,String,Int32,Boolean,Boolean);

Obsolete.

public virtual CheckInResult checkinFromAndReturn(File,String,Int32,Boolean,Boolean,Boolean);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkinFromAndReturn Method (File, String, Int32, Boolean, Boolean)

public virtual CheckInResult checkinFromAndReturn(
File file,
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.checkinFromAndReturn Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkinFromAndReturn Method (File, String, Int32, Boolean, Boolean, Boolean)

NOTE: This method is now obsolete.

public virtual CheckInResult checkinFromAndReturn(
File file,
String reason,
Int32 lockStatus,
Boolean forceCheckin,
Boolean eol,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.checkinFromAndReturn Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


checkinFromStream Method

Borland StarTeam SDK for .NET

File.checkinFromStream Method

Overload List

public virtual void checkinFromStream(InputStream,String,Int32);

public virtual void checkinFromStream(InputStream,String,Int32,Boolean);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkinFromStream Method (InputStream, String, Int32)

public virtual void checkinFromStream(
InputStream source,
String checkinReason,
Int32 lockStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.checkinFromStream Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkinFromStream Method (InputStream, String, Int32, Boolean)

public virtual void checkinFromStream(
InputStream source,
String checkinReason,
Int32 lockStatus,
Boolean eol
);

See Also

File Class | com.starbase.starteam Namespace | File.checkinFromStream Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


checkout Method

Borland StarTeam SDK for .NET

File.checkout Method

Check out this File using the specified options.

Overload List

Check out this File using the specified options.

public virtual void checkout(CheckoutOptions);

public virtual void checkout(Int32,Boolean,Boolean,Boolean);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkout Method (CheckoutOptions)

Check out this File using the specified options.

public virtual void checkout(
CheckoutOptions options
);

See Also

File Class | com.starbase.starteam Namespace | File.checkout Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkout Method (Int32, Boolean, Boolean, Boolean)

public virtual void checkout(
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace | File.checkout Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkoutByDate Method

public virtual bool checkoutByDate(
File checkoutTo,
OLEDate date,
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkoutByLabelID Method

public virtual bool checkoutByLabelID(
File checkoutTo,
Int32 labelID,
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkoutByVersion Method

public virtual bool checkoutByVersion(
File checkoutTo,
Int32 viewVersion,
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkoutTo Method

public virtual void checkoutTo(
File checkoutTo,
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkoutToAndReturn Method

public virtual CheckOutResult checkoutToAndReturn(
File checkoutTo,
Int32 lockStatus,
Boolean timeStampNow,
Boolean eol,
Boolean updateStatus
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.checkoutToStream Method

public virtual void checkoutToStream(
OutputStream destination,
Int32 lockStatus,
Boolean eol
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.convertArchive Method

public virtual void convertArchive(
Boolean useDeltaStorage,
Int32 compressionLevel
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.convertToNativeIIArchive Method

public virtual void convertToNativeIIArchive(
Boolean bDeleteOldArchives
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.deleteLocalFile Method

Deletes the specified local file and has the side effect of deleting sync information from the server about the file.

public virtual bool deleteLocalFile(
File file
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.deleteSyncInfo Method

Removes sync information from this File object's Server. Once it has been called the Status for file will be unknown. Use with caution.

public virtual void deleteSyncInfo(
File file
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.Equals Method

public override bool Equals(
Object source
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.findCommonAnscestor Method

NOTE: This method is now obsolete.

Returns the most recent common ancestor of this file with the specified file. The common version is taken from this file's history. It may return null if no common version was found.

public virtual File findCommonAnscestor(
File other
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.findMergeVersion Method

Returns a revision from this file's history that represents the most recent common ancestor of this file with the last known version on disk. It may return null if the status is Unknown or if the sync version is not from the same version graph.

public virtual File findMergeVersion();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getArchiveFormat Method

The format of archive the server happens to be storing this file in -- Native-I, Native-II, or not applicable.

public virtual int getArchiveFormat();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getArchiveFormatDisplayName Method

public virtual string getArchiveFormatDisplayName(
Int32 value
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getArchiveName Method

The name of archive.

public virtual string getArchiveName();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getArchiveType Method

The type of archive the server happens to be storing this file in--StarTeam native, PVCS, Visual SourceSafe, etc.

public virtual int getArchiveType();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getArchiveTypeDisplayName Method

public virtual string getArchiveTypeDisplayName(
Int32 value
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getBlankKeywords Method

Returns an array of the default StarTeam keywords. All the keywords are "blank" meaning no values are filled in. This can be used to unexpand keywords in a file where the actual keyword values are not needed.

public virtual Keyword[] getBlankKeywords();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getCharacterSet Method

Returns the Character Set that determine this file content

public virtual CharacterSet getCharacterSet();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getCharset Method

The character set this file appears to use. Text and binary are the only values currently supported.

public virtual int getCharset();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getCharsetDisplayName Method

public virtual string getCharsetDisplayName(
Int32 value
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getCompression Method

Returns an <code>int</code> describing the compression level being used to store versions of this file in the repository.

public virtual int getCompression();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getCompressionDisplayName Method

public virtual string getCompressionDisplayName(
Int32 value
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getContentModificationTime Method

Returns the "last modified" timestamp of the working file when it was checked in to create this version. Note that this value comes from the local machine where the checkin occured.

public virtual OLEDate getContentModificationTime();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getContentVersion Method

Returns the content version number for this file. The first revision of any file item will have a value of 1 for this property. The value only changes when a new revision of the file is checked-in for which the file contents or the file name has changed. This value does not increment if only meta properties are modified (for example, the description). When a file item branches the value of this property does not revert to 1 but rather continues to increase as new revisions are added. This value is maintained in order to make status computation easier and more "accurate" (for example, a file should not need checkout if only its description changed).

public virtual int getContentVersion();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getDefaultEncoding Method

NOTE: This method is now obsolete.

Gets the default file encoding.

public static string getDefaultEncoding();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getDescription Method

Returns the description of this file.

public virtual string getDescription();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getEOLFormat Method

Gets the end-of-line format used by this file's working files on disk. Supported only on StarTeam Server version 2009 and later; on earlier servers, the value is always reported as null.

public virtual EOLFormat getEOLFormat();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getExtension Method

Returns the file name extension. E.g. for "foo.txt" this would return "txt", for "foo" it would return the empty string.

public virtual string getExtension();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getFileSyncInfo Method

NOTE: This method is now obsolete.

public virtual FileSyncInfo getFileSyncInfo(
MD5 compareMD5,
Int32 compareSize,
MD5 syncMD5,
Int32 syncSize,
OLEDate syncTime
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getFileSyncInfoEx Method

public virtual FileSyncInfo getFileSyncInfoEx(
MD5 compareMD5,
Int64 compareSize,
MD5 syncMD5,
Int64 syncSize,
OLEDate syncTime
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getFullName Method

Returns the concatenation of this file's name with the working directory of the file's parent folder. This should return the full path to this file's working location on disk.

public virtual string getFullName();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.GetHashCode Method

public override int GetHashCode();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getLastKnownStatus Method

Returns the last known status of the default working file relative to the file in the repository, using only information provided by the client during the last status update operation. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).

public virtual int getLastKnownStatus();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getLastKnownVersionOnDisk Method

Returns the last known version of this file on disk. Returns -1 if the status information is unknown. The value returned is the view version of the last known revision on disk. This method will refresh the status information prior to determining the value and hence might be expensive to compute if called often.

public virtual int getLastKnownVersionOnDisk();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getLocalFileExecutable Method

Returns true if the local file is executable.

public virtual bool getLocalFileExecutable();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getLocalFileExists Method

Returns true if the local file exists on disk.

public virtual bool getLocalFileExists();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getLocalName Method

Returns the local file name, as recognized by the local file system.

public virtual string getLocalName();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getLocalPath Method

Returns the local path, as recognized by the local file system.

public virtual string getLocalPath();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getLocalSize Method

NOTE: This method is now obsolete.

Returns the local file's size. If the file does not exist this returns -1.

public virtual int getLocalSize();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getLocalSizeEx Method

Returns the local file's size. If the file does not exist this returns -1.

public virtual long getLocalSizeEx();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getLocalTimeStamp Method

Returns the local file's time stamp. If the local file does not exist this will return a time whose double value is 0.0.

public virtual OLEDate getLocalTimeStamp();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getMD5 Method

The MD5 hash bytes of the file contents for this version. This is the value for the file contents in the repository which may differ from that of the corresponding file on disk if end-of-line or keyword expasion has been applied.

public virtual sbyte[] getMD5();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getName Method

Returns the name of this file. This is the name only--contrast with getFullName.

public virtual string getName();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getPossibleArchiveFormat Method

Returns the possible enum codes that are valid values for the ArchiveFormat property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleArchiveFormat();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getPossibleArchiveType Method

Returns the possible enum codes that are valid values for the ArchiveType property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleArchiveType();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getPossibleCharset Method

Returns the possible enum codes that are valid values for the Charset property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleCharset();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getPossibleCompression Method

Returns the possible enum codes that are valid values for the Compression property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleCompression();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getPossibleStorageFormat Method

Returns the possible enum codes that are valid values for the StorageFormat property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleStorageFormat();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getSize Method

NOTE: This method is now obsolete.

The size of this file in the repository. Note that this may be different than the size of the local file if end-of-line conversion or keyword expansion is used.

public virtual int getSize();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getSizeEx Method

The size of this file in the repository. Note that this may be different than the size of the local file if end-of-line conversion or keyword expansion is used.

public virtual long getSizeEx();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


getSmartStatus Method

Borland StarTeam SDK for .NET

File.getSmartStatus Method

Gets the status of the default working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.

Overload List

Gets the status of the default working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.

public virtual int getSmartStatus();

Gets the status of the given working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.

public virtual int getSmartStatus(File);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getSmartStatus Method ()

Gets the status of the default working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.

public virtual int getSmartStatus();

See Also

File Class | com.starbase.starteam Namespace | File.getSmartStatus Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getSmartStatus Method (File)

Gets the status of the given working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.

public virtual int getSmartStatus(
File file
);

See Also

File Class | com.starbase.starteam Namespace | File.getSmartStatus Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


getStatus Method

Borland StarTeam SDK for .NET

File.getStatus Method

Gets the status of the default working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk.

Overload List

Gets the status of the default working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk.

public virtual int getStatus();

Gets the status of the given working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk.

public virtual int getStatus(File);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getStatus Method ()

Gets the status of the default working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk.

public virtual int getStatus();

See Also

File Class | com.starbase.starteam Namespace | File.getStatus Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getStatus Method (File)

Gets the status of the given working file relative to the latest version of this file in the repository. <p> Status is determined by comparing the current size and last modified time with that of the last known version on disk.

public virtual int getStatus(
File file
);

See Also

File Class | com.starbase.starteam Namespace | File.getStatus Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getStatusByMD5 Method

Returns the status of the default working file relative to the file in the repository, using the given size MD5 signature of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).

public virtual int getStatusByMD5(
MD5 md5
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getStatusByTime Method

NOTE: This method is now obsolete.

public virtual int getStatusByTime(
Int32 size,
OLEDate lastModified
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getStatusByTimeEx Method

public virtual int getStatusByTimeEx(
Int64 size,
OLEDate lastModified
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getStatusKnown Method

Returns true if status information is known for this file. Returns true if status information is known for this file.

public virtual bool getStatusKnown();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getStatusNow Method

Same as getStatus, but this method first goes to the server to refresh the status information.

public virtual int getStatusNow();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getStorageFormat Method

Returns an enumerated value describing the storage format being used to store versions of this file--that is, delta or full version storage.

public virtual int getStorageFormat();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getStorageFormatDisplayName Method

public virtual string getStorageFormatDisplayName(
Int32 value
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.getVaultVersion Method

Returns the vault version number for this file. The vault revision number is really an implementation detail of the StarTeam vault and the value of this property is not of much general use.

public virtual int getVaultVersion();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.isBinary Method

Tells whether this file (in the repository) has been determined to be a binary file. StarTeam flags a file as "binary" if any null (0x0) characters are found in the file.

public virtual bool isBinary();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.isInSyncByMD5 Method

public static bool isInSyncByMD5(
File file,
FileSyncInfo syncInfo
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.isInSyncByTime Method

public static bool isInSyncByTime(
File file,
FileSyncInfo syncInfo
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.isUnicode Method

Tells whether this file (in the repository) has been determined to be a unicode file.

public virtual bool isUnicode();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.lock Method

public override void lock();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.moveLocalFile Method

public virtual File moveLocalFile(
File fromFile,
String toFolderPath
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.putLock Method

public override void putLock(
Int32 lockType,
Boolean breakLock
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.removeAndDeleteLocal Method

Removes the file item from its parent folder. Note that a file may be shared in another folder in the same or different view. This method will merely remove the one instance (or shared copy) that the method is called on. In addition, this method will delete the corresponding working file.

public virtual void removeAndDeleteLocal();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.rename Method

public virtual void rename(
String newName
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.resyncStatus Method

NOTE: This method is now obsolete.

public virtual void resyncStatus(
MD5 compareMD5,
Int32 compareSize,
MD5 syncMD5,
Int32 syncSize,
OLEDate syncTime
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.resyncStatusEx Method

public virtual void resyncStatusEx(
MD5 compareMD5,
Int64 compareSize,
MD5 syncMD5,
Int64 syncSize,
OLEDate syncTime
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.setCharacterSet Method

set the Character Set that determines this file content file content will be treated as ASCII, Binary or UNICODE, and is automatically determined when the file is being checked in, unless the encoding is explicitly specified. In this case, the specified encoding overrides any computed value

public virtual void setCharacterSet(
CharacterSet ce
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.setCompression Method

public virtual void setCompression(
Int32 compressionLevel
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.setContentModificationTime Method

Sets this file's content modification time. You need to call one of the "update" (update, checkin, add) methods to persist this information.

public virtual void setContentModificationTime(
OLEDate time
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.setDefaultEncoding Method

NOTE: This method is now obsolete.

public static void setDefaultEncoding(
String name
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.setDescription Method

public virtual void setDescription(
String description
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.setEOLFormat Method

Sets the end-of-line format used by this file's working files on disk. Supported only on StarTeam Server version 2009 and later.

public virtual void setEOLFormat(
EOLFormat format
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.setName Method

public virtual void setName(
String name
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.setStorageFormat Method

public virtual void setStorageFormat(
Int32 storageFormat
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.ToString Method

public override string ToString();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.unlock Method

public override void unlock();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.update Method

public override void update();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


updateStatus Method

Borland StarTeam SDK for .NET

File.updateStatus Method

Overload List

public virtual void updateStatus(Boolean);

Obsolete.

public virtual void updateStatus(Boolean,Boolean);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.updateStatus Method (Boolean)

public virtual void updateStatus(
Boolean useMD5
);

See Also

File Class | com.starbase.starteam Namespace | File.updateStatus Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.updateStatus Method (Boolean, Boolean)

NOTE: This method is now obsolete.

public virtual void updateStatus(
Boolean eolConversion,
Boolean useMD5
);

See Also

File Class | com.starbase.starteam Namespace | File.updateStatus Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.updateStatusAfterMerge Method

Updates the server's status information to reflect the fact that the local file's contents were derived from this file's contents. You would most commonly want to call this after merging in changes. This file's status will be "Modified" after a call to this method if this file is the tip version of the file.

public virtual void updateStatusAfterMerge();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.updateStatusFromMD5 Method

Updates the server's status information to reflect the fact that the local file's content has the given MD5 signature. <p>The file size and last modified date are assumed to be unknown. Any previously specified values will remain unchanged. <p>This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void updateStatusFromMD5(
MD5 signature
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.updateStatusFromTime Method

NOTE: This method is now obsolete.

public virtual void updateStatusFromTime(
Int32 size,
OLEDate lastModified
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.updateStatusFromTimeEx Method

public virtual void updateStatusFromTimeEx(
Int64 size,
OLEDate lastModified
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.updateStatusInformation Method

NOTE: This method is now obsolete.

public virtual void updateStatusInformation(
Int32 fileSize,
OLEDate lastModified,
MD5 signature
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.updateStatusInformationEx Method

public virtual void updateStatusInformationEx(
Int64 fileSize,
OLEDate lastModified,
MD5 signature
);

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.upgradeSyncInfo Method

NOTE: This method is now obsolete.

Move status records from an old server to the new client managed status information. Returns true if sync information was found and moved locally and false otherwise. This will return false and do nothing if the file is from a newer server that supports client managed status.

public virtual bool upgradeSyncInfo();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


File.usesKeywords Method

Tells whether or not this file will use keyword expansion. This is determined by looking at the project's keyword properties and this file's extension.

public virtual bool usesKeywords();

See Also

File Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager Class

For a list of all members of this type, see FileBasedStatusManager Members.

System.Object
FileBasedStatusManager

public class FileBasedStatusManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FileBasedStatusManager Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager Members

FileBasedStatusManager overview

Public Instance Methods

deleteFileSyncInfo |
Equals |
getFileSyncInfo |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
isCentral | Determines whether or not status information is centrally managed.
isPerFolder | Determines whether or not status information managed on a per-folder basis.
MemberwiseClone |
moveFileSyncInfo |
setFileSyncInfo |
ToString |

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager Methods

The methods of the FileBasedStatusManager class are listed below. For a complete list of FileBasedStatusManager class members, see the FileBasedStatusManager Members topic.

Public Instance Methods

deleteFileSyncInfo |
Equals |
getFileSyncInfo |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
isCentral | Determines whether or not status information is centrally managed.
isPerFolder | Determines whether or not status information managed on a per-folder basis.
MemberwiseClone |
moveFileSyncInfo |
setFileSyncInfo |
ToString |

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager.deleteFileSyncInfo Method

public virtual void deleteFileSyncInfo(
File file,
Boolean cs
);

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager.Equals Method

public override bool Equals(
Object source
);

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager.getFileSyncInfo Method

public virtual FileSyncInfo getFileSyncInfo(
File file,
Boolean cs
);

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager.GetHashCode Method

public override int GetHashCode();

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager.isCentral Method

Determines whether or not status information is centrally managed.

public virtual bool isCentral();

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager.isPerFolder Method

Determines whether or not status information managed on a per-folder basis.

public virtual bool isPerFolder();

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager.moveFileSyncInfo Method

public virtual bool moveFileSyncInfo(
File oldFile,
File newFile,
Boolean caseSensitive
);

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager.setFileSyncInfo Method

public virtual void setFileSyncInfo(
File file,
FileSyncInfo rec,
Boolean cs
);

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileBasedStatusManager.ToString Method

public override string ToString();

See Also

FileBasedStatusManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileDigest Interface

For a list of all members of this type, see FileDigest Members.

public interface FileDigest

Types that implement FileDigest

Type | Description
FileDigestAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FileDigest Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileDigest Members

FileDigest overview

Public Instance Methods

getFileMD5 | Gets the MD5 cryptographic hash of the file's content. See <a href="http://info.internet.isi.edu:80/in-notes/rfc/files/rfc1321.txt">RFC1321<a>.
getFileSize | Gets the file's size. This is returned as a long (8 bytes) because an int (4 bytes) can only support file sizes up to roughly 2.1GB.
getFileTime | Gets the file's last modified time. Follows Microsoft's COLEDateTime specification, which is the number of days from midnight, 30 December 1899, in UTC.
setFileMD5 | Sets the MD5 cryptographic hash of the file's content.
setFileSize |
setFileTime |

See Also

FileDigest Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileDigest Methods

The methods of the FileDigest interface are listed below. For a complete list of FileDigest interface members, see the FileDigest Members topic.

Public Instance Methods

getFileMD5 | Gets the MD5 cryptographic hash of the file's content. See <a href="http://info.internet.isi.edu:80/in-notes/rfc/files/rfc1321.txt">RFC1321<a>.
getFileSize | Gets the file's size. This is returned as a long (8 bytes) because an int (4 bytes) can only support file sizes up to roughly 2.1GB.
getFileTime | Gets the file's last modified time. Follows Microsoft's COLEDateTime specification, which is the number of days from midnight, 30 December 1899, in UTC.
setFileMD5 | Sets the MD5 cryptographic hash of the file's content.
setFileSize |
setFileTime |

See Also

FileDigest Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileDigest.getFileMD5 Method

Gets the MD5 cryptographic hash of the file's content. See <a href="http://info.internet.isi.edu:80/in-notes/rfc/files/rfc1321.txt">RFC1321<a>.

MD5 getFileMD5();

See Also

FileDigest Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileDigest.getFileSize Method

Gets the file's size. This is returned as a long (8 bytes) because an int (4 bytes) can only support file sizes up to roughly 2.1GB.

long getFileSize();

See Also

FileDigest Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileDigest.getFileTime Method

Gets the file's last modified time. Follows Microsoft's COLEDateTime specification, which is the number of days from midnight, 30 December 1899, in UTC.

double getFileTime();

See Also

FileDigest Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileDigest.setFileMD5 Method

Sets the MD5 cryptographic hash of the file's content.

void setFileMD5(
MD5 md5
);

See Also

FileDigest Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileDigest.setFileSize Method

void setFileSize(
Int64 size
);

See Also

FileDigest Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileDigest.setFileTime Method

void setFileTime(
Double time
);

See Also

FileDigest Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileResult Class

For a list of all members of this type, see FileResult Members.

System.Object
FileResult
AddResult
CheckInResult
CheckOutResult

public class FileResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FileResult Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileResult Members

FileResult overview

Public Instance Methods

Equals |
GetHashCode |
getKeywords | Returns the keywords used in the add/checkin/checkout operation. If no keywords were used the array will empty. This method will not return null.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FileResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileResult Methods

The methods of the FileResult class are listed below. For a complete list of FileResult class members, see the FileResult Members topic.

Public Instance Methods

Equals |
GetHashCode |
getKeywords | Returns the keywords used in the add/checkin/checkout operation. If no keywords were used the array will empty. This method will not return null.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FileResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileResult.Equals Method

public override bool Equals(
Object source
);

See Also

FileResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileResult.GetHashCode Method

public override int GetHashCode();

See Also

FileResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileResult.getKeywords Method

Returns the keywords used in the add/checkin/checkout operation. If no keywords were used the array will empty. This method will not return null.

public virtual Keyword[] getKeywords();

See Also

FileResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileResult.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FileResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileResult.ToString Method

public override string ToString();

See Also

FileResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileStream Class

For a list of all members of this type, see FileStream Members.

System.Object
FileStream

public class FileStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FileStream Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileStream Members

FileStream overview

Public Static Methods

computeCompareMD5 | Obsolete.
computeCompareMD5Ex |
computeSyncMD5 | Obsolete.
computeSyncMD5Ex |

Public Instance Constructors

FileStream Constructor Initializes a new instance of the FileStream class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FileStream Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileStream Constructor

NOTE: This constructor is now obsolete.

Initializes a new instance of the FileStream class.

public FileStream();

See Also

FileStream Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileStream Methods

The methods of the FileStream class are listed below. For a complete list of FileStream class members, see the FileStream Members topic.

Public Static Methods

computeCompareMD5 | Obsolete.
computeCompareMD5Ex |
computeSyncMD5 | Obsolete.
computeSyncMD5Ex |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FileStream Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileStream.computeCompareMD5 Method

NOTE: This method is now obsolete.

public static int computeCompareMD5(
File file,
Boolean bUsesKeywords,
Boolean bConvertEOL,
MD5 md5
);

See Also

FileStream Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileStream.computeCompareMD5Ex Method

public static long computeCompareMD5Ex(
File file,
Boolean bUsesKeywords,
Boolean bConvertEOL,
MD5 md5
);

See Also

FileStream Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileStream.computeSyncMD5 Method

NOTE: This method is now obsolete.

public static int computeSyncMD5(
File file,
MD5 md5
);

See Also

FileStream Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileStream.computeSyncMD5Ex Method

public static long computeSyncMD5Ex(
File file,
MD5 md5
);

See Also

FileStream Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileStream.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FileStream Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileStream.ToString Method

public override string ToString();

See Also

FileStream Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileSyncInfo Interface

For a list of all members of this type, see FileSyncInfo Members.

public interface FileSyncInfo

Types that implement FileSyncInfo

Type | Description
FileSyncInfoAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FileSyncInfo Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileSyncInfo Members

FileSyncInfo overview

Public Instance Methods

getFileDigest | Gets the FileDigest for the file in question. This summarizes "checksum" information about the state of the file when it was written to disk, before any outside source was able to modify it.
getRevisionIdentifier | Gets the RevisionIdentifier for the file in question. This tells exactly what version of what object should be on the user's disk.

See Also

FileSyncInfo Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileSyncInfo Methods

The methods of the FileSyncInfo interface are listed below. For a complete list of FileSyncInfo interface members, see the FileSyncInfo Members topic.

Public Instance Methods

getFileDigest | Gets the FileDigest for the file in question. This summarizes "checksum" information about the state of the file when it was written to disk, before any outside source was able to modify it.
getRevisionIdentifier | Gets the RevisionIdentifier for the file in question. This tells exactly what version of what object should be on the user's disk.

See Also

FileSyncInfo Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileSyncInfo.getFileDigest Method

Gets the FileDigest for the file in question. This summarizes "checksum" information about the state of the file when it was written to disk, before any outside source was able to modify it.

FileDigest getFileDigest();

See Also

FileSyncInfo Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileSyncInfo.getRevisionIdentifier Method

Gets the RevisionIdentifier for the file in question. This tells exactly what version of what object should be on the user's disk.

RevisionIdentifier getRevisionIdentifier();

See Also

FileSyncInfo Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter Class

For a list of all members of this type, see Filter Members.

System.Object
CacheRef
NamedCacheRef
Filter

public class Filter : NamedCacheRef, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Filter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter Members

Filter overview

Public Static Fields

CONTEXT_LOCAL
CONTEXT_LOCAL_AND_SERVER
CONTEXT_SERVER

Public Instance Constructors

Filter Constructor

Public Instance Methods

appendColumn |
appendGroupSortInfo |
clearColumns | A convenience method to remove all column display information.
clearGroupSortInfo | A convenience method to remove all sort and group information.
Clone (inherited from CacheRef) |
copy | Creates a copy of this Filter object. Useful to applications that want to save a snapshot of the filter in a given state, for example, before calling Type.refreshFiltersAndQueries(). <p> The copied filter will have the same parent Type as the original property. The Type object is not copied. <p>
delete |
Equals |
getACL |
getColumnInfo |
getContext |
getGroupingDepth | Returns the number of grouping levels specified for the Filter.
getGroupSortInfo |
GetHashCode |
getID | Returns the internal ID of the filter. This will be -1 for a filter not yet saved in the repository.
getName | Returns the display name of the filter.
getParentContainer |
getProperties | Returns an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.
getQueryID | Returns the ID of the query associated with the filter. It will return -1 if no query is specified.
getType |
GetType (inherited from Object) | Gets the Type of the current instance.
getUserID | Returns the user ID for whoever created the filter.
hasPermission |
isDeleted |
isDirty | Returns true if the filter has unsaved modifications.
isEqualTo | Compares two Filter objects.
isNew |
isPublic | Returns true if the filter is visible to all users.
makePublic |
MemberwiseClone (inherited from CacheRef) |
setACL |
setColumnInfo |
setContext |
setGroupSortInfo |
setName |
setQueryID |
toDebugString |
ToString |
update |

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter Constructor

public Filter(
Type type,
String name,
Int32 context,
Boolean publicFilter
);

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter Fields

The fields of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Static Fields

CONTEXT_LOCAL
CONTEXT_LOCAL_AND_SERVER
CONTEXT_SERVER

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.CONTEXT_LOCAL Field

public const Int32 CONTEXT_LOCAL = 2;

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.CONTEXT_LOCAL_AND_SERVER Field

public const Int32 CONTEXT_LOCAL_AND_SERVER = 3;

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.CONTEXT_SERVER Field

public const Int32 CONTEXT_SERVER = 1;

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter Methods

The methods of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Instance Methods

appendColumn |
appendGroupSortInfo |
clearColumns | A convenience method to remove all column display information.
clearGroupSortInfo | A convenience method to remove all sort and group information.
Clone (inherited from CacheRef) |
copy | Creates a copy of this Filter object. Useful to applications that want to save a snapshot of the filter in a given state, for example, before calling Type.refreshFiltersAndQueries(). <p> The copied filter will have the same parent Type as the original property. The Type object is not copied. <p>
delete |
Equals |
getACL |
getColumnInfo |
getContext |
getGroupingDepth | Returns the number of grouping levels specified for the Filter.
getGroupSortInfo |
GetHashCode |
getID | Returns the internal ID of the filter. This will be -1 for a filter not yet saved in the repository.
getName | Returns the display name of the filter.
getParentContainer |
getProperties | Returns an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.
getQueryID | Returns the ID of the query associated with the filter. It will return -1 if no query is specified.
getType |
GetType (inherited from Object) | Gets the Type of the current instance.
getUserID | Returns the user ID for whoever created the filter.
hasPermission |
isDeleted |
isDirty | Returns true if the filter has unsaved modifications.
isEqualTo | Compares two Filter objects.
isNew |
isPublic | Returns true if the filter is visible to all users.
makePublic |
MemberwiseClone (inherited from CacheRef) |
setACL |
setColumnInfo |
setContext |
setGroupSortInfo |
setName |
setQueryID |
toDebugString |
ToString |
update |

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.appendColumn Method

public virtual void appendColumn(
String propertyName,
Int32 pixelWidth
);

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.appendGroupSortInfo Method

public virtual void appendGroupSortInfo(
Boolean group,
String propertyName,
Boolean ascending
);

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.clearColumns Method

A convenience method to remove all column display information.

public virtual void clearColumns();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.clearGroupSortInfo Method

A convenience method to remove all sort and group information.

public virtual void clearGroupSortInfo();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.copy Method

Creates a copy of this Filter object. Useful to applications that want to save a snapshot of the filter in a given state, for example, before calling Type.refreshFiltersAndQueries(). <p> The copied filter will have the same parent Type as the original property. The Type object is not copied. <p>

public virtual Filter copy();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.delete Method

public virtual void delete();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.Equals Method

public override bool Equals(
Object source
);

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getACL Method

public virtual AclEntry[] getACL();

Implements

ISecurable.getACL

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getColumnInfo Method

public virtual ColumnInfo[] getColumnInfo();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getContext Method

public virtual int getContext();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getGroupingDepth Method

Returns the number of grouping levels specified for the Filter.

public virtual int getGroupingDepth();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getGroupSortInfo Method

public virtual GroupSortInfo[] getGroupSortInfo();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.GetHashCode Method

public override int GetHashCode();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getID Method

Returns the internal ID of the filter. This will be -1 for a filter not yet saved in the repository.

public virtual int getID();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getName Method

Returns the display name of the filter.

public virtual string getName();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getParentContainer Method

public virtual ISecurableContainer getParentContainer();

Implements

ISecurable.getParentContainer

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getProperties Method

Returns an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.

public virtual Property[] getProperties();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getQueryID Method

Returns the ID of the query associated with the filter. It will return -1 if no query is specified.

public virtual int getQueryID();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getType Method

public virtual Type getType();

Implements

ISecurable.getType

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.getUserID Method

Returns the user ID for whoever created the filter.

public virtual int getUserID();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.hasPermission Method

public virtual bool hasPermission(
Int32 permissions
);

Implements

ISecurable.hasPermission

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.isDeleted Method

public virtual bool isDeleted();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.isDirty Method

Returns true if the filter has unsaved modifications.

public virtual bool isDirty();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.isEqualTo Method

Compares two Filter objects.

public virtual bool isEqualTo(
Filter filter
);

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.isNew Method

public virtual bool isNew();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.isPublic Method

Returns true if the filter is visible to all users.

public virtual bool isPublic();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.makePublic Method

public virtual void makePublic();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.setACL Method

public virtual void setACL(
AclEntry[] acl
);

Implements

ISecurable.setACL

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.setColumnInfo Method

public virtual void setColumnInfo(
ColumnInfo[] info
);

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.setContext Method

public virtual void setContext(
Int32 context
);

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.setGroupSortInfo Method

public virtual void setGroupSortInfo(
GroupSortInfo[] info
);

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.setName Method

public virtual void setName(
String name
);

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.setQueryID Method

public virtual void setQueryID(
Int32 queryID
);

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.toDebugString Method

public virtual string toDebugString();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.ToString Method

public override string ToString();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Filter.update Method

public virtual void update();

See Also

Filter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterAdapter Class

For a list of all members of this type, see FilterAdapter Members.

System.Object
FilterAdapter

public class FilterAdapter : FilterListener, IFilterQueryListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FilterAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterAdapter Members

FilterAdapter overview

Public Instance Constructors

FilterAdapter Constructor Initializes a new instance of the FilterAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
filterAdded |
filterChanged |
filterDeleted |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FilterAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterAdapter Constructor

Initializes a new instance of the FilterAdapter class.

public FilterAdapter();

See Also

FilterAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterAdapter Methods

The methods of the FilterAdapter class are listed below. For a complete list of FilterAdapter class members, see the FilterAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
filterAdded |
filterChanged |
filterDeleted |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FilterAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterAdapter.filterAdded Method

public override void filterAdded(
FilterEvent e
);

Implements

FilterListener.filterAdded

See Also

FilterAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterAdapter.filterChanged Method

public override void filterChanged(
FilterEvent e
);

Implements

FilterListener.filterChanged

See Also

FilterAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterAdapter.filterDeleted Method

public override void filterDeleted(
FilterEvent e
);

Implements

FilterListener.filterDeleted

See Also

FilterAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FilterAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterAdapter.ToString Method

public override string ToString();

See Also

FilterAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterEvent Class

For a list of all members of this type, see FilterEvent Members.

System.Object
EventObject
FilterEvent

public class FilterEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FilterEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterEvent Members

FilterEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
getFilter | Gets the Filter that has been added, changed or deleted, in its new state. <p> Filter.getType() will return a Type whose properties are up-to-date as of the time the event was triggered. This Type object is a physically different object from the Type object used to register the event handler. (In the case where the event handler was registered with a Server object, this Type object is physically different from the corresponding Type object in the Server's Type collection.) <p> Furthermore, the Type's QueryInfo collection is also up-to-date as of the time the event was triggered. <p> If an application wants to refresh the list of filters associated with the original Type object, it must do so by explicitly calling Type.refreshFiltersAndQueries().
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FilterEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterEvent Methods

The methods of the FilterEvent class are listed below. For a complete list of FilterEvent class members, see the FilterEvent Members topic.

Public Instance Methods

Equals |
getFilter | Gets the Filter that has been added, changed or deleted, in its new state. <p> Filter.getType() will return a Type whose properties are up-to-date as of the time the event was triggered. This Type object is a physically different object from the Type object used to register the event handler. (In the case where the event handler was registered with a Server object, this Type object is physically different from the corresponding Type object in the Server's Type collection.) <p> Furthermore, the Type's QueryInfo collection is also up-to-date as of the time the event was triggered. <p> If an application wants to refresh the list of filters associated with the original Type object, it must do so by explicitly calling Type.refreshFiltersAndQueries().
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FilterEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterEvent.Equals Method

public override bool Equals(
Object source
);

See Also

FilterEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterEvent.getFilter Method

Gets the Filter that has been added, changed or deleted, in its new state. <p> Filter.getType() will return a Type whose properties are up-to-date as of the time the event was triggered. This Type object is a physically different object from the Type object used to register the event handler. (In the case where the event handler was registered with a Server object, this Type object is physically different from the corresponding Type object in the Server's Type collection.) <p> Furthermore, the Type's QueryInfo collection is also up-to-date as of the time the event was triggered. <p> If an application wants to refresh the list of filters associated with the original Type object, it must do so by explicitly calling Type.refreshFiltersAndQueries().

public virtual Filter getFilter();

See Also

FilterEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterEvent.GetHashCode Method

public override int GetHashCode();

See Also

FilterEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterEvent.getSource Method

public override object getSource();

See Also

FilterEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FilterEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterEvent.ToString Method

public override string ToString();

See Also

FilterEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterListener Interface

For a list of all members of this type, see FilterListener Members.

public interface FilterListener : IFilterQueryListener, EventListener

Types that implement FilterListener

Type | Description
FilterAdapter |
FilterQueryAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FilterListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterListener Members

FilterListener overview

Public Instance Methods

filterAdded | Invoked when a new Filter has been added to the server.
filterChanged | Invoked when an existing Filter has been modified on the server.
filterDeleted | Invoked when an existing Filter has been deleted on the server.

See Also

FilterListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterListener Methods

The methods of the FilterListener interface are listed below. For a complete list of FilterListener interface members, see the FilterListener Members topic.

Public Instance Methods

filterAdded | Invoked when a new Filter has been added to the server.
filterChanged | Invoked when an existing Filter has been modified on the server.
filterDeleted | Invoked when an existing Filter has been deleted on the server.

See Also

FilterListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterListener.filterAdded Method

Invoked when a new Filter has been added to the server.

void filterAdded(
FilterEvent e
);

See Also

FilterListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterListener.filterChanged Method

Invoked when an existing Filter has been modified on the server.

void filterChanged(
FilterEvent e
);

See Also

FilterListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterListener.filterDeleted Method

Invoked when an existing Filter has been deleted on the server.

void filterDeleted(
FilterEvent e
);

See Also

FilterListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter Class

For a list of all members of this type, see FilterQueryAdapter Members.

System.Object
FilterQueryAdapter

public class FilterQueryAdapter : FilterListener, IFilterQueryListener, EventListener, QueryListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FilterQueryAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter Members

FilterQueryAdapter overview

Public Instance Constructors

FilterQueryAdapter Constructor Initializes a new instance of the FilterQueryAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
filterAdded |
filterChanged |
filterDeleted |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
queryAdded |
queryChanged |
queryDeleted |
ToString |

See Also

FilterQueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter Constructor

Initializes a new instance of the FilterQueryAdapter class.

public FilterQueryAdapter();

See Also

FilterQueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter Methods

The methods of the FilterQueryAdapter class are listed below. For a complete list of FilterQueryAdapter class members, see the FilterQueryAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
filterAdded |
filterChanged |
filterDeleted |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
queryAdded |
queryChanged |
queryDeleted |
ToString |

See Also

FilterQueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter.filterAdded Method

public override void filterAdded(
FilterEvent e
);

Implements

FilterListener.filterAdded

See Also

FilterQueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter.filterChanged Method

public override void filterChanged(
FilterEvent e
);

Implements

FilterListener.filterChanged

See Also

FilterQueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter.filterDeleted Method

public override void filterDeleted(
FilterEvent e
);

Implements

FilterListener.filterDeleted

See Also

FilterQueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FilterQueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter.queryAdded Method

public override void queryAdded(
QueryEvent e
);

Implements

QueryListener.queryAdded

See Also

FilterQueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter.queryChanged Method

public override void queryChanged(
QueryEvent e
);

Implements

QueryListener.queryChanged

See Also

FilterQueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter.queryDeleted Method

public override void queryDeleted(
QueryEvent e
);

Implements

QueryListener.queryDeleted

See Also

FilterQueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FilterQueryAdapter.ToString Method

public override string ToString();

See Also

FilterQueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder Class

For a list of all members of this type, see Folder Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Item
Folder
VCMFolder

public class Folder : Item, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Folder Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder Members

Folder overview

Public Static Fields

EOL_CR
EOL_CRLF
EOL_LF
EXCLUDE_INHERIT
EXCLUDE_LOCAL
EXCLUDE_NONE

Public Instance Constructors

Folder Overloaded. Initializes a new instance of the Folder class.

Public Instance Methods

acquireOwnership (inherited from Item)
add | Obsolete. Adds the specified item to this folder. The added item will still exist in its original folder as well as in this one.
addAttachment (inherited from Item)
addFolderListener
addFolderUpdateListener
addItemListener | Overloaded.
addItemUpdateListener
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy
copyFolderTree | Copies a folder tree. Does not populate any properties or copy any cached items.
countItems
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
discardItems
enumerateItems
Equals
get (inherited from Item)
getACL
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAlternatePathFragment | Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getCaseSensitiveFileNames | Returns true if the names of files in this folder are case sensitive.
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getContainerLevelACL
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDefaultPathFragment | Returns this folder's specified default working path. This is the <code>FOLDER_WORKING_FOLDER</code> property associated with this folder. The folder's fully resolved location on disk may use this value along with the values for all of its parent folders.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDescription | Returns the description of this folder.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getExcludeFlags | Returns an <code>int</code> representing the method by which the exclude list is determined.
getExcludeList | Returns the portion of the exclude list that this folder contributes. Use resolveExcludeList to get the full exclude list which may include specifications inherited from the parent folder.
getFileEOL | Returns the end-of-line character sequence to be used for text files in this folder.
getFilePath
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFolderHierarchy | Gets the fully-qualified name of this folder. The names of this folder and all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getFolderTree
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode
getHistory
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getItems
getList
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getName | Returns the name of the folder.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getNotInViewFiles | Returns an array of "not in view" File objects in this Folder, applying exclusions as appropriate.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer
getParentFolder
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPath | Returns the local working file path being used for this folder. This path is the concatenation of either the default path fragment or the alternate path fragment with the path of this folder's parent folder or the path of the view if this folder has no parent. A non-null alternate path fragment takes precedence over a default path fragment.
getPathFragment | Return the path fragment to use for this folder. If an alternate path fragment is set then it will be used instead of the default path fragment.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPropertyNames (inherited from Item)
getQualifiedName | Gets the fully-qualified name of this folder. The names of this folder and all parent folders up to the root are included, separated by the backslash character ("\") on all platforms. There is no terminating backslash.
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getString (inherited from Item)
getSubFolderCount | Returns the number of sub folders for this folder.
getSubFolders | Returns the subfolders of this folder. Will not return null but may return an empty array if the folder has no subfolders.
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getUserVisible | Returns true if items in this folder should be visible to the user. Typically, a UI should not display the items in an invisible folder. The value for this folder may have been set upon opening a view based on client settings.
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasParentFolder | Returns true if this folder has a parent folder.
hasPermission | Overloaded.
hasPermission (inherited from Item) | Overloaded.
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo
isExcluded
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isPopulated
isRefreshItemsRequired
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move | Obsolete.
moveTo
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
populateAsNeeded | Obsolete.
populateInBackground
populateNow
put
putByPropertyID
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
refreshForeignFiles
refreshItems
remove
removeAttachment (inherited from Item)
removeFolderListener
removeFolderUpdateListener
removeFromIntArray (inherited from TypedResource)
removeItemListener
removeItemUpdateListener
resolveExcludeList | Returns the fully resolved exclude list. This may be the catenation of this folder's exclude list with its parent exclude list depending on the exclude list types.
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
resolveUserVisible | Returns false if this folder or any parent is set to be not visible.
reverseShareTo | Overloaded.
reverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL
setAlternatePathFragment
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setContainerLevelACL
setDefaultPathFragment
setDescription
setExcludeFlags
setExcludeList
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setName
setUserVisible
shareTo | Overloaded.
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update
updateFolderTree
updateRevisionComment (inherited from Item)

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder Constructor

Special constructor for the root folder of a view, to be used during the creation of a project. NOTE that this needs to remain public because it's used in the COM API for CreateProjectEx().

Overload List

Creates a new folder specifying in which folder it is to reside. Note that a valid name is required prior to update.

public Folder(Folder);

public Folder(Folder,String,String);

Special constructor for the root folder of a view, to be used during the creation of a project. NOTE that this needs to remain public because it's used in the COM API for CreateProjectEx().

public Folder(Server);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder Constructor (Server)

Special constructor for the root folder of a view, to be used during the creation of a project. NOTE that this needs to remain public because it's used in the COM API for CreateProjectEx().

public Folder(
Server server
);

See Also

Folder Class | com.starbase.starteam Namespace | Folder Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder Constructor (Folder)

Creates a new folder specifying in which folder it is to reside. Note that a valid name is required prior to update.

public Folder(
Folder parent
);

See Also

Folder Class | com.starbase.starteam Namespace | Folder Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder Constructor (Folder, String, String)

public Folder(
Folder parent,
String name,
String workingFolder
);

See Also

Folder Class | com.starbase.starteam Namespace | Folder Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder Fields

The fields of the Folder class are listed below. For a complete list of Folder class members, see the Folder Members topic.

Public Static Fields

EOL_CR
EOL_CRLF
EOL_LF
EXCLUDE_INHERIT
EXCLUDE_LOCAL
EXCLUDE_NONE

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.EOL_CR Field

public const String EOL_CR = " ";

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.EOL_CRLF Field

public const String EOL_CRLF = " ";

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.EOL_LF Field

public const String EOL_LF = " ";

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.EXCLUDE_INHERIT Field

public const Int32 EXCLUDE_INHERIT = 2;

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.EXCLUDE_LOCAL Field

public const Int32 EXCLUDE_LOCAL = 1;

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.EXCLUDE_NONE Field

public const Int32 EXCLUDE_NONE = 0;

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder Methods

The methods of the Folder class are listed below. For a complete list of Folder class members, see the Folder Members topic.

Public Instance Methods

acquireOwnership (inherited from Item)
add | Obsolete. Adds the specified item to this folder. The added item will still exist in its original folder as well as in this one.
addAttachment (inherited from Item)
addFolderListener
addFolderUpdateListener
addItemListener | Overloaded.
addItemUpdateListener
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy
copyFolderTree | Copies a folder tree. Does not populate any properties or copy any cached items.
countItems
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
discardItems
enumerateItems
Equals
get (inherited from Item)
getACL
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAlternatePathFragment | Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getCaseSensitiveFileNames | Returns true if the names of files in this folder are case sensitive.
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getContainerLevelACL
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDefaultPathFragment | Returns this folder's specified default working path. This is the <code>FOLDER_WORKING_FOLDER</code> property associated with this folder. The folder's fully resolved location on disk may use this value along with the values for all of its parent folders.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDescription | Returns the description of this folder.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getExcludeFlags | Returns an <code>int</code> representing the method by which the exclude list is determined.
getExcludeList | Returns the portion of the exclude list that this folder contributes. Use resolveExcludeList to get the full exclude list which may include specifications inherited from the parent folder.
getFileEOL | Returns the end-of-line character sequence to be used for text files in this folder.
getFilePath
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFolderHierarchy | Gets the fully-qualified name of this folder. The names of this folder and all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getFolderTree
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode
getHistory
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getItems
getList
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getName | Returns the name of the folder.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getNotInViewFiles | Returns an array of "not in view" File objects in this Folder, applying exclusions as appropriate.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer
getParentFolder
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPath | Returns the local working file path being used for this folder. This path is the concatenation of either the default path fragment or the alternate path fragment with the path of this folder's parent folder or the path of the view if this folder has no parent. A non-null alternate path fragment takes precedence over a default path fragment.
getPathFragment | Return the path fragment to use for this folder. If an alternate path fragment is set then it will be used instead of the default path fragment.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPropertyNames (inherited from Item)
getQualifiedName | Gets the fully-qualified name of this folder. The names of this folder and all parent folders up to the root are included, separated by the backslash character ("\") on all platforms. There is no terminating backslash.
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getString (inherited from Item)
getSubFolderCount | Returns the number of sub folders for this folder.
getSubFolders | Returns the subfolders of this folder. Will not return null but may return an empty array if the folder has no subfolders.
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getUserVisible | Returns true if items in this folder should be visible to the user. Typically, a UI should not display the items in an invisible folder. The value for this folder may have been set upon opening a view based on client settings.
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasParentFolder | Returns true if this folder has a parent folder.
hasPermission | Overloaded.
hasPermission (inherited from Item) | Overloaded.
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo
isExcluded
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isPopulated
isRefreshItemsRequired
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move | Obsolete.
moveTo
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
populateAsNeeded | Obsolete.
populateInBackground
populateNow
put
putByPropertyID
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
refreshForeignFiles
refreshItems
remove
removeAttachment (inherited from Item)
removeFolderListener
removeFolderUpdateListener
removeFromIntArray (inherited from TypedResource)
removeItemListener
removeItemUpdateListener
resolveExcludeList | Returns the fully resolved exclude list. This may be the catenation of this folder's exclude list with its parent exclude list depending on the exclude list types.
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
resolveUserVisible | Returns false if this folder or any parent is set to be not visible.
reverseShareTo | Overloaded.
reverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL
setAlternatePathFragment
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setContainerLevelACL
setDefaultPathFragment
setDescription
setExcludeFlags
setExcludeList
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setName
setUserVisible
shareTo | Overloaded.
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update
updateFolderTree
updateRevisionComment (inherited from Item)

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.add Method

NOTE: This method is now obsolete.

Adds the specified item to this folder. The added item will still exist in its original folder as well as in this one.

public virtual Item add(
Item child
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.addFolderListener Method

public virtual void addFolderListener(
IFolderListener listener,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.addFolderUpdateListener Method

public virtual void addFolderUpdateListener(
FolderUpdateListener listener,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


addItemListener Method

Borland StarTeam SDK for .NET

Folder.addItemListener Method

Overload List

public virtual void addItemListener(IItemListener,Type,Int32);

public virtual void addItemListener(IItemListener,Type,String[],Int32);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.addItemListener Method (IItemListener, Type, Int32)

public virtual void addItemListener(
IItemListener listener,
Type type,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace | Folder.addItemListener Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.addItemListener Method (IItemListener, Type, String[], Int32)

public virtual void addItemListener(
IItemListener listener,
Type type,
String[] propertyNames,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace | Folder.addItemListener Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.addItemUpdateListener Method

public virtual void addItemUpdateListener(
ItemUpdateListener listener,
Type type,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.copy Method

public override Item copy();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.copyFolderTree Method

Copies a folder tree. Does not populate any properties or copy any cached items.

public virtual Folder copyFolderTree();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.countItems Method

public virtual long countItems(
Type type,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.discardItems Method

public virtual void discardItems(
String typeName,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.enumerateItems Method

public virtual Enumeration enumerateItems(
String typeName
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.Equals Method

public override bool Equals(
Object source
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getACL Method

public override AclEntry[] getACL();

Implements

ISecurable.getACL

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getAlternatePathFragment Method

Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.

public virtual string getAlternatePathFragment();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getCaseSensitiveFileNames Method

Returns true if the names of files in this folder are case sensitive.

public virtual bool getCaseSensitiveFileNames();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getContainerLevelACL Method

public virtual AclEntry[] getContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.getContainerLevelACL

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getDefaultPathFragment Method

Returns this folder's specified default working path. This is the <code>FOLDER_WORKING_FOLDER</code> property associated with this folder. The folder's fully resolved location on disk may use this value along with the values for all of its parent folders.

public virtual string getDefaultPathFragment();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getDescription Method

Returns the description of this folder.

public virtual string getDescription();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getDotNotation Method

public override string getDotNotation();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getExcludeFlags Method

Returns an <code>int</code> representing the method by which the exclude list is determined.

public virtual int getExcludeFlags();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getExcludeList Method

Returns the portion of the exclude list that this folder contributes. Use resolveExcludeList to get the full exclude list which may include specifications inherited from the parent folder.

public virtual string getExcludeList();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getFileEOL Method

Returns the end-of-line character sequence to be used for text files in this folder.

public virtual string getFileEOL();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getFilePath Method

public virtual string getFilePath(
String fileName
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getFolderHierarchy Method

Gets the fully-qualified name of this folder. The names of this folder and all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.

public virtual string getFolderHierarchy();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getFolderTree Method

public virtual Folder getFolderTree(
Int32 context,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.GetHashCode Method

public override int GetHashCode();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getHistory Method

public override Item[] getHistory();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getItems Method

public virtual Item[] getItems(
String typeName
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getList Method

public virtual ItemList getList(
String typeName
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getName Method

Returns the name of the folder.

public virtual string getName();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getNotInViewFiles Method

Returns an array of "not in view" File objects in this Folder, applying exclusions as appropriate.

public virtual File[] getNotInViewFiles();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getParentContainer Method

public override ISecurableContainer getParentContainer();

Implements

ISecurableContainer.getParentContainer

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getParentFolder Method

public override Folder getParentFolder();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getPath Method

Returns the local working file path being used for this folder. This path is the concatenation of either the default path fragment or the alternate path fragment with the path of this folder's parent folder or the path of the view if this folder has no parent. A non-null alternate path fragment takes precedence over a default path fragment.

public virtual string getPath();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getPathFragment Method

Return the path fragment to use for this folder. If an alternate path fragment is set then it will be used instead of the default path fragment.

public virtual string getPathFragment();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getQualifiedName Method

Gets the fully-qualified name of this folder. The names of this folder and all parent folders up to the root are included, separated by the backslash character ("\") on all platforms. There is no terminating backslash.

public virtual string getQualifiedName();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getSubFolderCount Method

Returns the number of sub folders for this folder.

public virtual int getSubFolderCount();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getSubFolders Method

Returns the subfolders of this folder. Will not return null but may return an empty array if the folder has no subfolders.

public virtual Folder[] getSubFolders();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.getUserVisible Method

Returns true if items in this folder should be visible to the user. Typically, a UI should not display the items in an invisible folder. The value for this folder may have been set upon opening a view based on client settings.

public virtual bool getUserVisible();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.hasParentFolder Method

Returns true if this folder has a parent folder.

public virtual bool hasParentFolder();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


hasPermission Method

Borland StarTeam SDK for .NET

Folder.hasPermission Method

Overload List

Inherited from Item.

public virtual bool hasPermission(Int32);

public virtual bool hasPermission(Int32,String);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.hasPermission Method (Int32, String)

public virtual bool hasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.hasPermission

See Also

Folder Class | com.starbase.starteam Namespace | Folder.hasPermission Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.isEqualTo Method

public override bool isEqualTo(
Item item
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.isExcluded Method

public virtual bool isExcluded(
String filename
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.isPopulated Method

public virtual bool isPopulated(
String typeName
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.isRefreshItemsRequired Method

public virtual bool isRefreshItemsRequired(
String typeName,
String[] propertyNames,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.move Method

NOTE: This method is now obsolete.

public override void move(
Folder toFolder
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.moveTo Method

public override void moveTo(
Folder toFolder
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.populateAsNeeded Method

NOTE: This method is now obsolete.

public virtual void populateAsNeeded(
String typeName,
String[] propertyNames,
Int32 chunkSize
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.populateInBackground Method

public virtual void populateInBackground(
String typeName,
String[] propertyNames,
Int32 chunkSize
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.populateNow Method

public virtual void populateNow(
String typeName,
String[] propertyNames,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.put Method

public override object put(
String propertyName,
Object value
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.putByPropertyID Method

public override object putByPropertyID(
Int32 propertyID,
Object value
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.refreshForeignFiles Method

public virtual ForeignRefreshResult refreshForeignFiles(
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.refreshItems Method

public virtual void refreshItems(
String typeName,
String[] propertyNames,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.remove Method

public override void remove();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.removeFolderListener Method

public virtual void removeFolderListener(
IFolderListener listener,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.removeFolderUpdateListener Method

public virtual void removeFolderUpdateListener(
FolderUpdateListener listener,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.removeItemListener Method

public virtual void removeItemListener(
IItemListener listener,
Type type,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.removeItemUpdateListener Method

public virtual void removeItemUpdateListener(
ItemUpdateListener listener,
Type type,
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.resolveExcludeList Method

Returns the fully resolved exclude list. This may be the catenation of this folder's exclude list with its parent exclude list depending on the exclude list types.

public virtual string resolveExcludeList();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.resolveUserVisible Method

Returns false if this folder or any parent is set to be not visible.

public virtual bool resolveUserVisible();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


reverseShareTo Method

Borland StarTeam SDK for .NET

Folder.reverseShareTo Method

Overload List

Inherited from Item.

public virtual Item reverseShareTo(Folder);

public virtual Folder reverseShareTo(Folder,Boolean);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.reverseShareTo Method (Folder, Boolean)

public virtual Folder reverseShareTo(
Folder toFolder,
Boolean bThisFolderOnly
);

See Also

Folder Class | com.starbase.starteam Namespace | Folder.reverseShareTo Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.setACL Method

public override void setACL(
AclEntry[] acl
);

Implements

ISecurable.setACL

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.setAlternatePathFragment Method

public virtual void setAlternatePathFragment(
String path
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.setContainerLevelACL Method

public virtual void setContainerLevelACL(
AclEntry[] acl,
String typeName
);

Implements

ISecurableContainer.setContainerLevelACL

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.setDefaultPathFragment Method

public virtual void setDefaultPathFragment(
String path
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.setDescription Method

public virtual void setDescription(
String description
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.setExcludeFlags Method

public virtual void setExcludeFlags(
Int32 flag
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.setExcludeList Method

public virtual void setExcludeList(
String excludeList
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.setName Method

public virtual void setName(
String name
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.setUserVisible Method

public virtual void setUserVisible(
Boolean visible
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


shareTo Method

Borland StarTeam SDK for .NET

Folder.shareTo Method

Overload List

public override Item shareTo(Folder);

public virtual Folder shareTo(Folder,Boolean);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.shareTo Method (Folder)

public override Item shareTo(
Folder toFolder
);

See Also

Folder Class | com.starbase.starteam Namespace | Folder.shareTo Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.shareTo Method (Folder, Boolean)

public virtual Folder shareTo(
Folder toFolder,
Boolean bThisFolderOnly
);

See Also

Folder Class | com.starbase.starteam Namespace | Folder.shareTo Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.ToString Method

public override string ToString();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.update Method

public override void update();

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Folder.updateFolderTree Method

public virtual void updateFolderTree(
Int32 depth
);

See Also

Folder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderAdapter Class

For a list of all members of this type, see FolderAdapter Members.

System.Object
FolderAdapter

public class FolderAdapter : FolderListener, IFolderListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FolderAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderAdapter Members

FolderAdapter overview

Public Instance Constructors

FolderAdapter Constructor Initializes a new instance of the FolderAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
folderAdded |
folderChanged |
folderMoved |
folderRemoved |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderAdapter Constructor

Initializes a new instance of the FolderAdapter class.

public FolderAdapter();

See Also

FolderAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderAdapter Methods

The methods of the FolderAdapter class are listed below. For a complete list of FolderAdapter class members, see the FolderAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
folderAdded |
folderChanged |
folderMoved |
folderRemoved |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderAdapter.folderAdded Method

public override void folderAdded(
FolderEvent e
);

Implements

FolderListener.folderAdded

See Also

FolderAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderAdapter.folderChanged Method

public override void folderChanged(
FolderEvent e
);

Implements

FolderListener.folderChanged

See Also

FolderAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderAdapter.folderMoved Method

public override void folderMoved(
FolderEvent e
);

Implements

FolderListener.folderMoved

See Also

FolderAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderAdapter.folderRemoved Method

public override void folderRemoved(
FolderEvent e
);

Implements

FolderListener.folderRemoved

See Also

FolderAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FolderAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderAdapter.ToString Method

public override string ToString();

See Also

FolderAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderEvent Class

For a list of all members of this type, see FolderEvent Members.

System.Object
EventObject
FolderEvent

public class FolderEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FolderEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderEvent Members

FolderEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
getNewFolder | Gets the Folder in its new state. <p> Used in folderAdded(), folderMoved() and folderChanged() events. In folderRemoved() events, getNewFolder() null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are correct as of the time the event was triggered. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Folders associated with the original View object, it must do so by explicitly calling View.refreshFolders().
GetObjectData (inherited from java.util.EventObject) |
getOldFolder | Gets the Folder in its old state. <p> Used in folderChanged(), folderMoved() and folderRemoved() events. In folderAdded() events, getOldFolder() returns null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that correctly represent the old state of the folder. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderEvent Methods

The methods of the FolderEvent class are listed below. For a complete list of FolderEvent class members, see the FolderEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
getNewFolder | Gets the Folder in its new state. <p> Used in folderAdded(), folderMoved() and folderChanged() events. In folderRemoved() events, getNewFolder() null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are correct as of the time the event was triggered. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Folders associated with the original View object, it must do so by explicitly calling View.refreshFolders().
GetObjectData (inherited from java.util.EventObject) |
getOldFolder | Gets the Folder in its old state. <p> Used in folderChanged(), folderMoved() and folderRemoved() events. In folderAdded() events, getOldFolder() returns null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that correctly represent the old state of the folder. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderEvent.Equals Method

public override bool Equals(
Object source
);

See Also

FolderEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderEvent.GetHashCode Method

public override int GetHashCode();

See Also

FolderEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderEvent.getNewFolder Method

Gets the Folder in its new state. <p> Used in folderAdded(), folderMoved() and folderChanged() events. In folderRemoved() events, getNewFolder() null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are correct as of the time the event was triggered. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Folders associated with the original View object, it must do so by explicitly calling View.refreshFolders().

public virtual Folder getNewFolder();

See Also

FolderEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderEvent.getOldFolder Method

Gets the Folder in its old state. <p> Used in folderChanged(), folderMoved() and folderRemoved() events. In folderAdded() events, getOldFolder() returns null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that correctly represent the old state of the folder. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy.

public virtual Folder getOldFolder();

See Also

FolderEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderEvent.getSource Method

public override object getSource();

See Also

FolderEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FolderEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderEvent.ToString Method

public override string ToString();

See Also

FolderEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListener Interface

For a list of all members of this type, see FolderListener Members.

public interface FolderListener : IFolderListener, EventListener

Types that implement FolderListener

Type | Description
FolderAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FolderListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListener Members

FolderListener overview

Public Instance Methods

folderAdded | Invoked when a Folder is added to a view. <p> A folderAdded event is triggered whenever a Folder with a new ItemID appears in the folder tree. This might be because a new folder was created (either directly, or as a result of creating a new project or view); because a folder was moved or shared in from another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no new Folder items are created. In this case, a folderMoved event is triggered instead of a folderAdded event. <p> If a folder with subfolders is added to a view (for example, by moving or sharing a subtree from another view), then a folderAdded event is triggered for each folder in the subtree. The folderAdded events for child folders are triggered after the folderAdded event for the parent. <p> If the logged-in user does not have access rights to see the folder in its new context, then no event is triggered. <p> For folderAdded events, FolderEvent.getNewFolder() returns the added folder in its new context. FolderEvent.getOldFolder() returns null.
folderChanged | Invoked when the properties of a Folder have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as Description or ExcludeSpec). <p> For folderChanged events, FolderEvent.getOldFolder() returns a Folder object representing the folder before its old state (that is, before its properties were changed). FolderEvent.getNewFolder() returns the folder in its new state (after its properties were changed).
folderMoved | Invoked when a Folder is moved within a view. <p> A folderMoved event is triggered whenever a Folder (or subtree) is moved from one parent folder to another parent within the same view. In this case, no folders with new ItemIDs are added to the view, and no folders are removed. Thus, when a folderMoved event is triggered, corresponding folderAdded and folderRemoved events will not be triggered. <p> If a folder exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the folder does not exist. If the folder is then moved to a new parent folder in the same view such that it is now accessible, then, from that user's point of view, the folder has been added, not moved. Thus, in that case, a folderAdded event will be triggered instead of a folderMoved event. <p> Similarly, if a folder is moved in such a way that it is no longer visible to the current user, a folderRemoved event will be triggered instead of a folderMoved event. <p> For folderMoved events, FolderEvent.getOldFolder() returns a Folder object representing the folder before it was moved (that is, attached to the old parent folder). FolderEvent.getNewFolder() returns a Folder object representing the folder after it was moved (attached to the new parent).
folderRemoved | Invoked when a Folder is removed from a view. <p> A folderRemoved event is triggered whenever a Folder disappears from the folder tree. This might be because a folder was deleted (either directly, or as a result of deleting a project or view); because a folder was moved to another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no Folder items are removed. In this case, a folderMoved event is triggered instead of a folderRemoved event. <p> If a folder with subfolders is removed from a view (for example, by deleting a subtree), then a folderRemoved event is triggered for each folder in the subtree. The folderRemoved events for child folders are triggered before the folderRemoved events for the parent. <p> For folderRemoved events, FolderEvent.getOldFolder() returns the removed folder in its old context (that is, prior to being removed). FolderEvent.getNewFolder() returns null.

See Also

FolderListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListener Methods

The methods of the FolderListener interface are listed below. For a complete list of FolderListener interface members, see the FolderListener Members topic.

Public Instance Methods

folderAdded | Invoked when a Folder is added to a view. <p> A folderAdded event is triggered whenever a Folder with a new ItemID appears in the folder tree. This might be because a new folder was created (either directly, or as a result of creating a new project or view); because a folder was moved or shared in from another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no new Folder items are created. In this case, a folderMoved event is triggered instead of a folderAdded event. <p> If a folder with subfolders is added to a view (for example, by moving or sharing a subtree from another view), then a folderAdded event is triggered for each folder in the subtree. The folderAdded events for child folders are triggered after the folderAdded event for the parent. <p> If the logged-in user does not have access rights to see the folder in its new context, then no event is triggered. <p> For folderAdded events, FolderEvent.getNewFolder() returns the added folder in its new context. FolderEvent.getOldFolder() returns null.
folderChanged | Invoked when the properties of a Folder have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as Description or ExcludeSpec). <p> For folderChanged events, FolderEvent.getOldFolder() returns a Folder object representing the folder before its old state (that is, before its properties were changed). FolderEvent.getNewFolder() returns the folder in its new state (after its properties were changed).
folderMoved | Invoked when a Folder is moved within a view. <p> A folderMoved event is triggered whenever a Folder (or subtree) is moved from one parent folder to another parent within the same view. In this case, no folders with new ItemIDs are added to the view, and no folders are removed. Thus, when a folderMoved event is triggered, corresponding folderAdded and folderRemoved events will not be triggered. <p> If a folder exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the folder does not exist. If the folder is then moved to a new parent folder in the same view such that it is now accessible, then, from that user's point of view, the folder has been added, not moved. Thus, in that case, a folderAdded event will be triggered instead of a folderMoved event. <p> Similarly, if a folder is moved in such a way that it is no longer visible to the current user, a folderRemoved event will be triggered instead of a folderMoved event. <p> For folderMoved events, FolderEvent.getOldFolder() returns a Folder object representing the folder before it was moved (that is, attached to the old parent folder). FolderEvent.getNewFolder() returns a Folder object representing the folder after it was moved (attached to the new parent).
folderRemoved | Invoked when a Folder is removed from a view. <p> A folderRemoved event is triggered whenever a Folder disappears from the folder tree. This might be because a folder was deleted (either directly, or as a result of deleting a project or view); because a folder was moved to another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no Folder items are removed. In this case, a folderMoved event is triggered instead of a folderRemoved event. <p> If a folder with subfolders is removed from a view (for example, by deleting a subtree), then a folderRemoved event is triggered for each folder in the subtree. The folderRemoved events for child folders are triggered before the folderRemoved events for the parent. <p> For folderRemoved events, FolderEvent.getOldFolder() returns the removed folder in its old context (that is, prior to being removed). FolderEvent.getNewFolder() returns null.

See Also

FolderListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListener.folderAdded Method

Invoked when a Folder is added to a view. <p> A folderAdded event is triggered whenever a Folder with a new ItemID appears in the folder tree. This might be because a new folder was created (either directly, or as a result of creating a new project or view); because a folder was moved or shared in from another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no new Folder items are created. In this case, a folderMoved event is triggered instead of a folderAdded event. <p> If a folder with subfolders is added to a view (for example, by moving or sharing a subtree from another view), then a folderAdded event is triggered for each folder in the subtree. The folderAdded events for child folders are triggered after the folderAdded event for the parent. <p> If the logged-in user does not have access rights to see the folder in its new context, then no event is triggered. <p> For folderAdded events, FolderEvent.getNewFolder() returns the added folder in its new context. FolderEvent.getOldFolder() returns null.

void folderAdded(
FolderEvent e
);

See Also

FolderListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListener.folderChanged Method

Invoked when the properties of a Folder have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as Description or ExcludeSpec). <p> For folderChanged events, FolderEvent.getOldFolder() returns a Folder object representing the folder before its old state (that is, before its properties were changed). FolderEvent.getNewFolder() returns the folder in its new state (after its properties were changed).

void folderChanged(
FolderEvent e
);

See Also

FolderListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListener.folderMoved Method

Invoked when a Folder is moved within a view. <p> A folderMoved event is triggered whenever a Folder (or subtree) is moved from one parent folder to another parent within the same view. In this case, no folders with new ItemIDs are added to the view, and no folders are removed. Thus, when a folderMoved event is triggered, corresponding folderAdded and folderRemoved events will not be triggered. <p> If a folder exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the folder does not exist. If the folder is then moved to a new parent folder in the same view such that it is now accessible, then, from that user's point of view, the folder has been added, not moved. Thus, in that case, a folderAdded event will be triggered instead of a folderMoved event. <p> Similarly, if a folder is moved in such a way that it is no longer visible to the current user, a folderRemoved event will be triggered instead of a folderMoved event. <p> For folderMoved events, FolderEvent.getOldFolder() returns a Folder object representing the folder before it was moved (that is, attached to the old parent folder). FolderEvent.getNewFolder() returns a Folder object representing the folder after it was moved (attached to the new parent).

void folderMoved(
FolderEvent e
);

See Also

FolderListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListener.folderRemoved Method

Invoked when a Folder is removed from a view. <p> A folderRemoved event is triggered whenever a Folder disappears from the folder tree. This might be because a folder was deleted (either directly, or as a result of deleting a project or view); because a folder was moved to another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no Folder items are removed. In this case, a folderMoved event is triggered instead of a folderRemoved event. <p> If a folder with subfolders is removed from a view (for example, by deleting a subtree), then a folderRemoved event is triggered for each folder in the subtree. The folderRemoved events for child folders are triggered before the folderRemoved events for the parent. <p> For folderRemoved events, FolderEvent.getOldFolder() returns the removed folder in its old context (that is, prior to being removed). FolderEvent.getNewFolder() returns null.

void folderRemoved(
FolderEvent e
);

See Also

FolderListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager Class

For a list of all members of this type, see FolderListManager Members.

System.Object
FolderListManager

public class FolderListManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FolderListManager Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager Members

FolderListManager overview

Public Instance Constructors

FolderListManager Overloaded. Initializes a new instance of the FolderListManager class.

Public Instance Methods

addFolderListener | Adds a listener for Folder-related events. Events are triggered only for those folders that are in scope at the time the event occurs. <p> In order to handle events, an application must enable MPX.
addFolderUpdateListener | Listens for updates to this view's folder tree. <p> Similar to addFolderListener(), except that events are triggered by explicit operations performed by the client application. For example, calling View.refreshFolders(), Folder.update() or Folder.remove() might each trigger update events. <p> MPX is not required to receive folder update events.
clear | Removes all folders from the folder list.
discard | Discards cached folder information. It will be re-fetched from the server the next time the folder list is retrieved (even when MPX is enabled).
Equals |
excludeFolder | Excludes the given folder from the folder list.
excludeFolders | Overloaded.
getFolderID | Returns the ItemID for a folder; if we're managing not-in-view folders, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view folder object until it's been added to the repository.
getFolders | Gets the complete list of folders in the folder list.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
getView | Returns the view for this FolderListManager.
includeFolder | Includes the given folder in the folder list.
includeFolders | Overloaded.
isFolderIncluded | Determines whether or not the given folder is included in the folder list.
isRefreshRequired | Returns true if a refresh() operation might have resulted in the folder list being updated; returns false if and only if it is known that the Folder list had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() returns true.
MemberwiseClone |
refresh | Refreshes the list of folders using the latest information available from the repository. <p> The result is similar to refreshing the folders in the underlying view, emptying the folder list, and re-issuing the sequence of include and exclude calls that were used to construct the original folder list. <p> For example, suppose a folder list was constructed as follows: <p> FolderListManager F = new FolderListManager(); <br> F.includeFolders(A, -1); <p> Initially, folder A has no subfolders; thus, <p> F.getFolders() -> {A} <p> Now, suppose another user has added subfolders B and C to A in the repository. Then, <p> F.refresh(); <br> F.getFolders() -> {A, B, C} <p> If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
removeFolderListener | Removes a listener for Folder-related events.
removeFolderUpdateListener | Removes a listener for folder update events.
ToString |

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager Constructor

Constructs a new folder list.

Overload List

Creates a new folder list with the same folders as an existing folder list.

public FolderListManager(FolderListManager);

Constructs a new folder list.

public FolderListManager(View);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager Constructor (View)

Constructs a new folder list.

public FolderListManager(
View view
);

See Also

FolderListManager Class | com.starbase.starteam Namespace | FolderListManager Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager Constructor (FolderListManager)

Creates a new folder list with the same folders as an existing folder list.

public FolderListManager(
FolderListManager folderList
);

See Also

FolderListManager Class | com.starbase.starteam Namespace | FolderListManager Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager Methods

The methods of the FolderListManager class are listed below. For a complete list of FolderListManager class members, see the FolderListManager Members topic.

Public Instance Methods

addFolderListener | Adds a listener for Folder-related events. Events are triggered only for those folders that are in scope at the time the event occurs. <p> In order to handle events, an application must enable MPX.
addFolderUpdateListener | Listens for updates to this view's folder tree. <p> Similar to addFolderListener(), except that events are triggered by explicit operations performed by the client application. For example, calling View.refreshFolders(), Folder.update() or Folder.remove() might each trigger update events. <p> MPX is not required to receive folder update events.
clear | Removes all folders from the folder list.
discard | Discards cached folder information. It will be re-fetched from the server the next time the folder list is retrieved (even when MPX is enabled).
Equals |
excludeFolder | Excludes the given folder from the folder list.
excludeFolders | Overloaded.
getFolderID | Returns the ItemID for a folder; if we're managing not-in-view folders, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view folder object until it's been added to the repository.
getFolders | Gets the complete list of folders in the folder list.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
getView | Returns the view for this FolderListManager.
includeFolder | Includes the given folder in the folder list.
includeFolders | Overloaded.
isFolderIncluded | Determines whether or not the given folder is included in the folder list.
isRefreshRequired | Returns true if a refresh() operation might have resulted in the folder list being updated; returns false if and only if it is known that the Folder list had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() returns true.
MemberwiseClone |
refresh | Refreshes the list of folders using the latest information available from the repository. <p> The result is similar to refreshing the folders in the underlying view, emptying the folder list, and re-issuing the sequence of include and exclude calls that were used to construct the original folder list. <p> For example, suppose a folder list was constructed as follows: <p> FolderListManager F = new FolderListManager(); <br> F.includeFolders(A, -1); <p> Initially, folder A has no subfolders; thus, <p> F.getFolders() -> {A} <p> Now, suppose another user has added subfolders B and C to A in the repository. Then, <p> F.refresh(); <br> F.getFolders() -> {A, B, C} <p> If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
removeFolderListener | Removes a listener for Folder-related events.
removeFolderUpdateListener | Removes a listener for folder update events.
ToString |

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.addFolderListener Method

Adds a listener for Folder-related events. Events are triggered only for those folders that are in scope at the time the event occurs. <p> In order to handle events, an application must enable MPX.

public virtual void addFolderListener(
IFolderListener listener
);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.addFolderUpdateListener Method

Listens for updates to this view's folder tree. <p> Similar to addFolderListener(), except that events are triggered by explicit operations performed by the client application. For example, calling View.refreshFolders(), Folder.update() or Folder.remove() might each trigger update events. <p> MPX is not required to receive folder update events.

public virtual void addFolderUpdateListener(
FolderUpdateListener listener
);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.clear Method

Removes all folders from the folder list.

public virtual void clear();

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.discard Method

Discards cached folder information. It will be re-fetched from the server the next time the folder list is retrieved (even when MPX is enabled).

public virtual void discard();

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.Equals Method

public override bool Equals(
Object source
);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.excludeFolder Method

Excludes the given folder from the folder list.

public virtual void excludeFolder(
Folder folder
);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


excludeFolders Method

Borland StarTeam SDK for .NET

FolderListManager.excludeFolders Method

Overload List

public virtual void excludeFolders(Folder,Int32);

public virtual void excludeFolders(Folder,Int32,Int32);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.excludeFolders Method (Folder, Int32)

public virtual void excludeFolders(
Folder folder,
Int32 depth
);

See Also

FolderListManager Class | com.starbase.starteam Namespace | FolderListManager.excludeFolders Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.excludeFolders Method (Folder, Int32, Int32)

public virtual void excludeFolders(
Folder folder,
Int32 context,
Int32 depth
);

See Also

FolderListManager Class | com.starbase.starteam Namespace | FolderListManager.excludeFolders Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.getFolderID Method

Returns the ItemID for a folder; if we're managing not-in-view folders, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view folder object until it's been added to the repository.

public virtual int getFolderID(
Folder folder
);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.getFolders Method

Gets the complete list of folders in the folder list.

public virtual Folder[] getFolders();

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.GetHashCode Method

public override int GetHashCode();

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.getView Method

Returns the view for this FolderListManager.

public virtual View getView();

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.includeFolder Method

Includes the given folder in the folder list.

public virtual void includeFolder(
Folder folder
);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


includeFolders Method

Borland StarTeam SDK for .NET

FolderListManager.includeFolders Method

Overload List

public virtual void includeFolders(Folder,Int32);

public virtual void includeFolders(Folder,Int32,Int32);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.includeFolders Method (Folder, Int32)

public virtual void includeFolders(
Folder folder,
Int32 depth
);

See Also

FolderListManager Class | com.starbase.starteam Namespace | FolderListManager.includeFolders Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.includeFolders Method (Folder, Int32, Int32)

public virtual void includeFolders(
Folder folder,
Int32 context,
Int32 depth
);

See Also

FolderListManager Class | com.starbase.starteam Namespace | FolderListManager.includeFolders Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.isFolderIncluded Method

Determines whether or not the given folder is included in the folder list.

public virtual bool isFolderIncluded(
Folder folder
);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.isRefreshRequired Method

Returns true if a refresh() operation might have resulted in the folder list being updated; returns false if and only if it is known that the Folder list had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() returns true.

public virtual bool isRefreshRequired();

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.refresh Method

Refreshes the list of folders using the latest information available from the repository. <p> The result is similar to refreshing the folders in the underlying view, emptying the folder list, and re-issuing the sequence of include and exclude calls that were used to construct the original folder list. <p> For example, suppose a folder list was constructed as follows: <p> FolderListManager F = new FolderListManager(); <br> F.includeFolders(A, -1); <p> Initially, folder A has no subfolders; thus, <p> F.getFolders() -> {A} <p> Now, suppose another user has added subfolders B and C to A in the repository. Then, <p> F.refresh(); <br> F.getFolders() -> {A, B, C} <p> If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void refresh();

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.removeFolderListener Method

Removes a listener for Folder-related events.

public virtual void removeFolderListener(
IFolderListener listener
);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.removeFolderUpdateListener Method

Removes a listener for folder update events.

public virtual void removeFolderUpdateListener(
FolderUpdateListener listener
);

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderListManager.ToString Method

public override string ToString();

See Also

FolderListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeAdapter Class

For a list of all members of this type, see FolderTreeAdapter Members.

System.Object
FolderTreeAdapter

public class FolderTreeAdapter : FolderTreeListener, IFolderListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FolderTreeAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeAdapter Members

FolderTreeAdapter overview

Public Instance Constructors

FolderTreeAdapter Constructor Initializes a new instance of the FolderTreeAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
folderTreeChanged |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderTreeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeAdapter Constructor

Initializes a new instance of the FolderTreeAdapter class.

public FolderTreeAdapter();

See Also

FolderTreeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeAdapter Methods

The methods of the FolderTreeAdapter class are listed below. For a complete list of FolderTreeAdapter class members, see the FolderTreeAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
folderTreeChanged |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderTreeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeAdapter.folderTreeChanged Method

public override void folderTreeChanged(
FolderTreeEvent e
);

Implements

FolderTreeListener.folderTreeChanged

See Also

FolderTreeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FolderTreeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeAdapter.ToString Method

public override string ToString();

See Also

FolderTreeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeEvent Class

For a list of all members of this type, see FolderTreeEvent Members.

System.Object
EventObject
FolderTreeEvent

public class FolderTreeEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FolderTreeEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeEvent Members

FolderTreeEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
getFolder | Gets the Folder at the root of the part of the hierarchy that has changed. This is the deepest folder that fully encompasses the change to the folder hierarchy. <p> Returns a new Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are up-to-date as of the time the event was triggered. In fact, an application can rely on the entire Folder hierarchy being up-to-date. For performance reasons, these same Folder objects may be re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should first make a copy. <p> If an application wants to refresh the Folders associated with the original View object, it must do so by explicitly calling View.refreshFolders().
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderTreeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeEvent Methods

The methods of the FolderTreeEvent class are listed below. For a complete list of FolderTreeEvent class members, see the FolderTreeEvent Members topic.

Public Instance Methods

Equals |
getFolder | Gets the Folder at the root of the part of the hierarchy that has changed. This is the deepest folder that fully encompasses the change to the folder hierarchy. <p> Returns a new Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are up-to-date as of the time the event was triggered. In fact, an application can rely on the entire Folder hierarchy being up-to-date. For performance reasons, these same Folder objects may be re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should first make a copy. <p> If an application wants to refresh the Folders associated with the original View object, it must do so by explicitly calling View.refreshFolders().
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderTreeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeEvent.Equals Method

public override bool Equals(
Object source
);

See Also

FolderTreeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeEvent.getFolder Method

Gets the Folder at the root of the part of the hierarchy that has changed. This is the deepest folder that fully encompasses the change to the folder hierarchy. <p> Returns a new Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are up-to-date as of the time the event was triggered. In fact, an application can rely on the entire Folder hierarchy being up-to-date. For performance reasons, these same Folder objects may be re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should first make a copy. <p> If an application wants to refresh the Folders associated with the original View object, it must do so by explicitly calling View.refreshFolders().

public virtual Folder getFolder();

See Also

FolderTreeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeEvent.GetHashCode Method

public override int GetHashCode();

See Also

FolderTreeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeEvent.getSource Method

public override object getSource();

See Also

FolderTreeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FolderTreeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeEvent.ToString Method

public override string ToString();

See Also

FolderTreeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeListener Interface

For a list of all members of this type, see FolderTreeListener Members.

public interface FolderTreeListener : IFolderListener, EventListener

Types that implement FolderTreeListener

Type | Description
FolderTreeAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FolderTreeListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeListener Members

FolderTreeListener overview

Public Instance Methods

folderTreeChanged Invoked when the Folder hierarchy has changed. This includes whenever a Folder is added, moved, shared, deleted, etc. <p> FolderTreeEvent.getFolder() returns the Folder at the root of the affected folder tree. For example, if Folder A has subfolder C, and folder C is moved so that it is instead a subfolder of B, folderTreeChanged events are triggered for Folder A and Folder B. <p> Applications that are more interested in receiving information about Folder B in this case should instead listen for FolderEvents by registering a FolderListener.

See Also

FolderTreeListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeListener Methods

The methods of the FolderTreeListener interface are listed below. For a complete list of FolderTreeListener interface members, see the FolderTreeListener Members topic.

Public Instance Methods

folderTreeChanged Invoked when the Folder hierarchy has changed. This includes whenever a Folder is added, moved, shared, deleted, etc. <p> FolderTreeEvent.getFolder() returns the Folder at the root of the affected folder tree. For example, if Folder A has subfolder C, and folder C is moved so that it is instead a subfolder of B, folderTreeChanged events are triggered for Folder A and Folder B. <p> Applications that are more interested in receiving information about Folder B in this case should instead listen for FolderEvents by registering a FolderListener.

See Also

FolderTreeListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderTreeListener.folderTreeChanged Method

Invoked when the Folder hierarchy has changed. This includes whenever a Folder is added, moved, shared, deleted, etc. <p> FolderTreeEvent.getFolder() returns the Folder at the root of the affected folder tree. For example, if Folder A has subfolder C, and folder C is moved so that it is instead a subfolder of B, folderTreeChanged events are triggered for Folder A and Folder B. <p> Applications that are more interested in receiving information about Folder B in this case should instead listen for FolderEvents by registering a FolderListener.

void folderTreeChanged(
FolderTreeEvent e
);

See Also

FolderTreeListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateAdapter Class

For a list of all members of this type, see FolderUpdateAdapter Members.

System.Object
FolderUpdateAdapter

public class FolderUpdateAdapter : FolderUpdateListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FolderUpdateAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateAdapter Members

FolderUpdateAdapter overview

Public Instance Constructors

FolderUpdateAdapter Constructor Initializes a new instance of the FolderUpdateAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
folderAdded |
folderChanged |
folderMoved |
folderRemoved |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateAdapter Constructor

Initializes a new instance of the FolderUpdateAdapter class.

public FolderUpdateAdapter();

See Also

FolderUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateAdapter Methods

The methods of the FolderUpdateAdapter class are listed below. For a complete list of FolderUpdateAdapter class members, see the FolderUpdateAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
folderAdded |
folderChanged |
folderMoved |
folderRemoved |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateAdapter.folderAdded Method

public override void folderAdded(
FolderUpdateEvent e
);

Implements

FolderUpdateListener.folderAdded

See Also

FolderUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateAdapter.folderChanged Method

public override void folderChanged(
FolderUpdateEvent e
);

Implements

FolderUpdateListener.folderChanged

See Also

FolderUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateAdapter.folderMoved Method

public override void folderMoved(
FolderUpdateEvent e
);

Implements

FolderUpdateListener.folderMoved

See Also

FolderUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateAdapter.folderRemoved Method

public override void folderRemoved(
FolderUpdateEvent e
);

Implements

FolderUpdateListener.folderRemoved

See Also

FolderUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FolderUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateAdapter.ToString Method

public override string ToString();

See Also

FolderUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateEvent Class

For a list of all members of this type, see FolderUpdateEvent Members.

System.Object
EventObject
FolderUpdateEvent

public class FolderUpdateEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FolderUpdateEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateEvent Members

FolderUpdateEvent overview

Public Instance Constructors

FolderUpdateEvent Constructor

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
getNewFolder | Gets the Folder in its new state. <p> Used in folderAdded(), folderMoved() and folderChanged() events. In folderRemoved() events, getNewFolder() null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are correct as of the time the event was triggered. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Folders associated with the original View object, it must do so by explicitly calling View.refreshFolders().
GetObjectData (inherited from java.util.EventObject) |
getOldFolder | Gets the Folder in its old state. <p> Used in folderChanged(), folderMoved() and folderRemoved() events. In folderAdded() events, getOldFolder() returns null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that correctly represent the old state of the folder. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateEvent Constructor

public FolderUpdateEvent(
Folder oldFolder,
Folder newFolder
);

See Also

FolderUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateEvent Methods

The methods of the FolderUpdateEvent class are listed below. For a complete list of FolderUpdateEvent class members, see the FolderUpdateEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
getNewFolder | Gets the Folder in its new state. <p> Used in folderAdded(), folderMoved() and folderChanged() events. In folderRemoved() events, getNewFolder() null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are correct as of the time the event was triggered. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Folders associated with the original View object, it must do so by explicitly calling View.refreshFolders().
GetObjectData (inherited from java.util.EventObject) |
getOldFolder | Gets the Folder in its old state. <p> Used in folderChanged(), folderMoved() and folderRemoved() events. In folderAdded() events, getOldFolder() returns null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that correctly represent the old state of the folder. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FolderUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateEvent.Equals Method

public override bool Equals(
Object source
);

See Also

FolderUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateEvent.GetHashCode Method

public override int GetHashCode();

See Also

FolderUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateEvent.getNewFolder Method

Gets the Folder in its new state. <p> Used in folderAdded(), folderMoved() and folderChanged() events. In folderRemoved() events, getNewFolder() null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are correct as of the time the event was triggered. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Folders associated with the original View object, it must do so by explicitly calling View.refreshFolders().

public virtual Folder getNewFolder();

See Also

FolderUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateEvent.getOldFolder Method

Gets the Folder in its old state. <p> Used in folderChanged(), folderMoved() and folderRemoved() events. In folderAdded() events, getOldFolder() returns null. <p> Returns a Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that correctly represent the old state of the folder. In fact, the entire Folder hierarchy is valid. For performance reasons, these same Folder objects may be modified and re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should make its own private copy.

public virtual Folder getOldFolder();

See Also

FolderUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateEvent.getSource Method

public override object getSource();

See Also

FolderUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FolderUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateEvent.ToString Method

public override string ToString();

See Also

FolderUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateListener Interface

For a list of all members of this type, see FolderUpdateListener Members.

public interface FolderUpdateListener : EventListener

Types that implement FolderUpdateListener

Type | Description
FolderUpdateAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FolderUpdateListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateListener Members

FolderUpdateListener overview

Public Instance Methods

folderAdded | Invoked when a Folder is added to a view. <p> A folderAdded event is triggered whenever a Folder with a new ItemID appears in the folder tree. This might be because a new folder was created (either directly, or as a result of creating a new project or view); because a folder was moved or shared in from another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no new Folder items are created. In this case, a folderMoved event is triggered instead of a folderAdded event. <p> If a folder with subfolders is added to a view (for example, by moving or sharing a subtree from another view), then a folderAdded event is triggered for each folder in the subtree. The folderAdded events for child folders are triggered after the folderAdded event for the parent. <p> If the logged-in user does not have access rights to see the folder in its new context, then no event is triggered. <p> For folderAdded events, FolderUpdateEvent.getNewFolder() returns the added folder in its new context. FolderUpdateEvent.getOldFolder() returns null.
folderChanged | Invoked when the properties of a Folder have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as Description or ExcludeSpec). <p> For folderChanged events, FolderUpdateEvent.getOldFolder() returns a Folder object representing the folder before its old state (that is, before its properties were changed). FolderUpdateEvent.getNewFolder() returns the folder in its new state (after its properties were changed).
folderMoved | Invoked when a Folder is moved within a view. <p> A folderMoved event is triggered whenever a Folder (or subtree) is moved from one parent folder to another parent within the same view. In this case, no folders with new ItemIDs are added to the view, and no folders are removed. Thus, when a folderMoved event is triggered, corresponding folderAdded and folderRemoved events will not be triggered. <p> If a folder exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the folder does not exist. If the folder is then moved to a new parent folder in the same view such that it is now accessible, then, from that user's point of view, the folder has been added, not moved. Thus, in that case, a folderAdded event will be triggered instead of a folderMoved event. <p> Similarly, if a folder is moved in such a way that it is no longer visible to the current user, a folderRemoved event will be triggered instead of a folderMoved event. <p> For folderMoved events, FolderUpdateEvent.getOldFolder() returns a Folder object representing the folder before it was moved (that is, attached to the old parent folder). FolderUpdateEvent.getNewFolder() returns a Folder object representing the folder after it was moved (attached to the new parent).
folderRemoved | Invoked when a Folder is removed from a view. <p> A folderRemoved event is triggered whenever a Folder disappears from the folder tree. This might be because a folder was deleted (either directly, or as a result of deleting a project or view); because a folder was moved to another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no Folder items are removed. In this case, a folderMoved event is triggered instead of a folderRemoved event. <p> If a folder with subfolders is removed from a view (for example, by deleting a subtree), then a folderRemoved event is triggered for each folder in the subtree. The folderRemoved events for child folders are triggered before the folderRemoved events for the parent. <p> For folderRemoved events, FolderUpdateEvent.getOldFolder() returns the removed folder in its old context (that is, prior to being removed). FolderUpdateEvent.getNewFolder() returns null.

See Also

FolderUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateListener Methods

The methods of the FolderUpdateListener interface are listed below. For a complete list of FolderUpdateListener interface members, see the FolderUpdateListener Members topic.

Public Instance Methods

folderAdded | Invoked when a Folder is added to a view. <p> A folderAdded event is triggered whenever a Folder with a new ItemID appears in the folder tree. This might be because a new folder was created (either directly, or as a result of creating a new project or view); because a folder was moved or shared in from another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no new Folder items are created. In this case, a folderMoved event is triggered instead of a folderAdded event. <p> If a folder with subfolders is added to a view (for example, by moving or sharing a subtree from another view), then a folderAdded event is triggered for each folder in the subtree. The folderAdded events for child folders are triggered after the folderAdded event for the parent. <p> If the logged-in user does not have access rights to see the folder in its new context, then no event is triggered. <p> For folderAdded events, FolderUpdateEvent.getNewFolder() returns the added folder in its new context. FolderUpdateEvent.getOldFolder() returns null.
folderChanged | Invoked when the properties of a Folder have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as Description or ExcludeSpec). <p> For folderChanged events, FolderUpdateEvent.getOldFolder() returns a Folder object representing the folder before its old state (that is, before its properties were changed). FolderUpdateEvent.getNewFolder() returns the folder in its new state (after its properties were changed).
folderMoved | Invoked when a Folder is moved within a view. <p> A folderMoved event is triggered whenever a Folder (or subtree) is moved from one parent folder to another parent within the same view. In this case, no folders with new ItemIDs are added to the view, and no folders are removed. Thus, when a folderMoved event is triggered, corresponding folderAdded and folderRemoved events will not be triggered. <p> If a folder exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the folder does not exist. If the folder is then moved to a new parent folder in the same view such that it is now accessible, then, from that user's point of view, the folder has been added, not moved. Thus, in that case, a folderAdded event will be triggered instead of a folderMoved event. <p> Similarly, if a folder is moved in such a way that it is no longer visible to the current user, a folderRemoved event will be triggered instead of a folderMoved event. <p> For folderMoved events, FolderUpdateEvent.getOldFolder() returns a Folder object representing the folder before it was moved (that is, attached to the old parent folder). FolderUpdateEvent.getNewFolder() returns a Folder object representing the folder after it was moved (attached to the new parent).
folderRemoved | Invoked when a Folder is removed from a view. <p> A folderRemoved event is triggered whenever a Folder disappears from the folder tree. This might be because a folder was deleted (either directly, or as a result of deleting a project or view); because a folder was moved to another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no Folder items are removed. In this case, a folderMoved event is triggered instead of a folderRemoved event. <p> If a folder with subfolders is removed from a view (for example, by deleting a subtree), then a folderRemoved event is triggered for each folder in the subtree. The folderRemoved events for child folders are triggered before the folderRemoved events for the parent. <p> For folderRemoved events, FolderUpdateEvent.getOldFolder() returns the removed folder in its old context (that is, prior to being removed). FolderUpdateEvent.getNewFolder() returns null.

See Also

FolderUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateListener.folderAdded Method

Invoked when a Folder is added to a view. <p> A folderAdded event is triggered whenever a Folder with a new ItemID appears in the folder tree. This might be because a new folder was created (either directly, or as a result of creating a new project or view); because a folder was moved or shared in from another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no new Folder items are created. In this case, a folderMoved event is triggered instead of a folderAdded event. <p> If a folder with subfolders is added to a view (for example, by moving or sharing a subtree from another view), then a folderAdded event is triggered for each folder in the subtree. The folderAdded events for child folders are triggered after the folderAdded event for the parent. <p> If the logged-in user does not have access rights to see the folder in its new context, then no event is triggered. <p> For folderAdded events, FolderUpdateEvent.getNewFolder() returns the added folder in its new context. FolderUpdateEvent.getOldFolder() returns null.

void folderAdded(
FolderUpdateEvent e
);

See Also

FolderUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateListener.folderChanged Method

Invoked when the properties of a Folder have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as Description or ExcludeSpec). <p> For folderChanged events, FolderUpdateEvent.getOldFolder() returns a Folder object representing the folder before its old state (that is, before its properties were changed). FolderUpdateEvent.getNewFolder() returns the folder in its new state (after its properties were changed).

void folderChanged(
FolderUpdateEvent e
);

See Also

FolderUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateListener.folderMoved Method

Invoked when a Folder is moved within a view. <p> A folderMoved event is triggered whenever a Folder (or subtree) is moved from one parent folder to another parent within the same view. In this case, no folders with new ItemIDs are added to the view, and no folders are removed. Thus, when a folderMoved event is triggered, corresponding folderAdded and folderRemoved events will not be triggered. <p> If a folder exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the folder does not exist. If the folder is then moved to a new parent folder in the same view such that it is now accessible, then, from that user's point of view, the folder has been added, not moved. Thus, in that case, a folderAdded event will be triggered instead of a folderMoved event. <p> Similarly, if a folder is moved in such a way that it is no longer visible to the current user, a folderRemoved event will be triggered instead of a folderMoved event. <p> For folderMoved events, FolderUpdateEvent.getOldFolder() returns a Folder object representing the folder before it was moved (that is, attached to the old parent folder). FolderUpdateEvent.getNewFolder() returns a Folder object representing the folder after it was moved (attached to the new parent).

void folderMoved(
FolderUpdateEvent e
);

See Also

FolderUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderUpdateListener.folderRemoved Method

Invoked when a Folder is removed from a view. <p> A folderRemoved event is triggered whenever a Folder disappears from the folder tree. This might be because a folder was deleted (either directly, or as a result of deleting a project or view); because a folder was moved to another view; etc. <p> If a folder is moved from one parent folder to another parent within the same view, then no Folder items are removed. In this case, a folderMoved event is triggered instead of a folderRemoved event. <p> If a folder with subfolders is removed from a view (for example, by deleting a subtree), then a folderRemoved event is triggered for each folder in the subtree. The folderRemoved events for child folders are triggered before the folderRemoved events for the parent. <p> For folderRemoved events, FolderUpdateEvent.getOldFolder() returns the removed folder in its old context (that is, prior to being removed). FolderUpdateEvent.getNewFolder() returns null.

void folderRemoved(
FolderUpdateEvent e
);

See Also

FolderUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignPasswordException Class

For a list of all members of this type, see ForeignPasswordException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
ServerException
ForeignPasswordException

public class ForeignPasswordException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ForeignPasswordException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignPasswordException Members

ForeignPasswordException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getConfigPath |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getProjectType |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
isPVCS |
isVSS |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |

See Also

ForeignPasswordException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignPasswordException Methods

The methods of the ForeignPasswordException class are listed below. For a complete list of ForeignPasswordException class members, see the ForeignPasswordException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getConfigPath |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getProjectType |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
isPVCS |
isVSS |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |

See Also

ForeignPasswordException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignPasswordException.Equals Method

public override bool Equals(
Object source
);

See Also

ForeignPasswordException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignPasswordException.getConfigPath Method

public virtual string getConfigPath();

See Also

ForeignPasswordException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignPasswordException.GetHashCode Method

public override int GetHashCode();

See Also

ForeignPasswordException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignPasswordException.getMessage Method

public override string getMessage();

See Also

ForeignPasswordException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignPasswordException.getProjectType Method

public virtual int getProjectType();

See Also

ForeignPasswordException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignPasswordException.isPVCS Method

public virtual bool isPVCS();

See Also

ForeignPasswordException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignPasswordException.isVSS Method

public virtual bool isVSS();

See Also

ForeignPasswordException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignPasswordException.wrap Method

public static ForeignPasswordException wrap(
ForeignPasswordException arg
);

See Also

ForeignPasswordException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignRefreshResult Class

For a list of all members of this type, see ForeignRefreshResult Members.

System.Object
ForeignRefreshResult

public class ForeignRefreshResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ForeignRefreshResult Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignRefreshResult Members

ForeignRefreshResult overview

Public Instance Methods

Equals |
getFilesChanged | Returns true if any file is changed as a result of the corresponding "foreign" refresh operation.
getFoldersChanged | Returns true if any folder is changed as a result of the corresponding "foreign" refresh operation.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ForeignRefreshResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignRefreshResult Methods

The methods of the ForeignRefreshResult class are listed below. For a complete list of ForeignRefreshResult class members, see the ForeignRefreshResult Members topic.

Public Instance Methods

Equals |
getFilesChanged | Returns true if any file is changed as a result of the corresponding "foreign" refresh operation.
getFoldersChanged | Returns true if any folder is changed as a result of the corresponding "foreign" refresh operation.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ForeignRefreshResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignRefreshResult.Equals Method

public override bool Equals(
Object source
);

See Also

ForeignRefreshResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignRefreshResult.getFilesChanged Method

Returns true if any file is changed as a result of the corresponding "foreign" refresh operation.

public virtual bool getFilesChanged();

See Also

ForeignRefreshResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignRefreshResult.getFoldersChanged Method

Returns true if any folder is changed as a result of the corresponding "foreign" refresh operation.

public virtual bool getFoldersChanged();

See Also

ForeignRefreshResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignRefreshResult.GetHashCode Method

public override int GetHashCode();

See Also

ForeignRefreshResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignRefreshResult.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ForeignRefreshResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ForeignRefreshResult.ToString Method

public override string ToString();

See Also

ForeignRefreshResult Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group Class

For a list of all members of this type, see Group Members.

System.Object
CacheRef
Group

public class Group : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Group Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group Members

Group overview

Public Instance Methods

Clone (inherited from CacheRef) |
copy | Creates a copy of this Group object. Useful to applications that want to save a snapshot of the group in a given state, for example, before calling Server.refreshGroups(). <p> The copied group will have the same parent server as the original group. The Server object is not copied.
Equals |
fetchMemberUserIDs |
GetHashCode |
getID | Returns the integer idenitifier for this group.
getName | Returns the group's name.
getServer | Returns the Server object to which this group belongs.
GetType (inherited from Object) | Gets the Type of the current instance.
isDeleted | Returns true if the Group has been deleted.
isEqualTo | Compares two Group objects, and their member User IDs. Requires admin privileges on 5.2 and earlier servers. <p> The parent Servers are not compared.
isMember |
MemberwiseClone (inherited from CacheRef) |
ToString |

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group Methods

The methods of the Group class are listed below. For a complete list of Group class members, see the Group Members topic.

Public Instance Methods

Clone (inherited from CacheRef) |
copy | Creates a copy of this Group object. Useful to applications that want to save a snapshot of the group in a given state, for example, before calling Server.refreshGroups(). <p> The copied group will have the same parent server as the original group. The Server object is not copied.
Equals |
fetchMemberUserIDs |
GetHashCode |
getID | Returns the integer idenitifier for this group.
getName | Returns the group's name.
getServer | Returns the Server object to which this group belongs.
GetType (inherited from Object) | Gets the Type of the current instance.
isDeleted | Returns true if the Group has been deleted.
isEqualTo | Compares two Group objects, and their member User IDs. Requires admin privileges on 5.2 and earlier servers. <p> The parent Servers are not compared.
isMember |
MemberwiseClone (inherited from CacheRef) |
ToString |

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group.copy Method

Creates a copy of this Group object. Useful to applications that want to save a snapshot of the group in a given state, for example, before calling Server.refreshGroups(). <p> The copied group will have the same parent server as the original group. The Server object is not copied.

public virtual Group copy();

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group.Equals Method

public override bool Equals(
Object source
);

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group.fetchMemberUserIDs Method

public virtual int[] fetchMemberUserIDs(
Boolean bDescendants
);

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group.GetHashCode Method

public override int GetHashCode();

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group.getID Method

Returns the integer idenitifier for this group.

public virtual int getID();

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group.getName Method

Returns the group's name.

public virtual string getName();

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group.getServer Method

Returns the Server object to which this group belongs.

public virtual Server getServer();

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group.isDeleted Method

Returns true if the Group has been deleted.

public virtual bool isDeleted();

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group.isEqualTo Method

Compares two Group objects, and their member User IDs. Requires admin privileges on 5.2 and earlier servers. <p> The parent Servers are not compared.

public virtual bool isEqualTo(
Group group
);

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group.isMember Method

public virtual bool isMember(
Int32 userID
);

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Group.ToString Method

public override string ToString();

See Also

Group Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount Class

For a list of all members of this type, see GroupAccount Members.

System.Object
CacheRef
GroupAccount

public class GroupAccount : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

GroupAccount Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount Members

GroupAccount overview

Public Static Fields

ID_ALL_USERS

Public Instance Constructors

GroupAccount Constructor Creates a new StarTeam Group object. It is initially not a subgroup of any existing group and one should call <code>setParent</code> to change this. The name is initially the empty string. To create this group in the StarTeam server you must call <code>update</code>.

Public Instance Methods

addPermission |
canRemove | Returns true if this GroupAccount and all of its descendants can be deleted without leaving any "orphan" users (i.e., users with no group membership).
Clone (inherited from CacheRef) |
copy | Creates a copy of this GroupAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals |
getDescription | Returns the group description.
getFullName | Returns a qualified name for the group, showing both the group and its parents.
GetHashCode |
getID | Returns this group's integer indentifier.
getName | Returns the group name.
getParent | Returns this groups's parent GroupAccount. If the group is a top-level group then this may return null.
getPermissionsFlags | Returns the permissions flags for this group.
getServer | Returns the Server object to which this GroupAccount belongs.
getSubGroupAccounts | Returns all of the sub-GroupAccounts for which this GroupAccount is the parent. The list may be empty but will never be null. The only way to change this list of sub groups is by modifying the parent GroupAccount of one of the children.
GetType (inherited from Object) | Gets the Type of the current instance.
getUserAccounts | Returns a list of UserAccount objects that directly belong to this group. The only way to change this list is through the UserAccount methods for adding and removing the UserAccount to a GroupAccount.
hasPermission |
isBuiltin | Return true if this is a builtin GroupAccount.
isDeleted | Returns true if the GroupAccount has been deleted.
isEqualTo | Compares two GroupAccount objects.
isMember |
isNew | Returns true if this GroupAccount has not yet been created on the Server.
isRoot | Returns true if this is a top-level group with no parent group.
MemberwiseClone (inherited from CacheRef) |
remove | Removes this group from the StarTeam server, plus any direct or indirect subgroups of this group. If the GroupAccount was never saved (isNew() returns true), if it is a builtin account, or if removing this group or any of its descendants would leave one or more users without any group membership, then an exception will be thrown. Note also that any affected UserAccounts will be updated, including any pending changes, as a side effect of this method.
removePermission |
setDescription |
setName |
setParent | Change the parent GroupAccount for this group. The parent may be null in which case the group will be a root group.
ToString (inherited from CacheRef) |
update | Persistently saves the changes to this GroupAccount in the server. If the GroupAccount is new it will be added, otherwise it will be modified.

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount Constructor

Creates a new StarTeam Group object. It is initially not a subgroup of any existing group and one should call <code>setParent</code> to change this. The name is initially the empty string. To create this group in the StarTeam server you must call <code>update</code>.

public GroupAccount(
Server server
);

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount Fields

The fields of the GroupAccount class are listed below. For a complete list of GroupAccount class members, see the GroupAccount Members topic.

Public Static Fields

ID_ALL_USERS

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.ID_ALL_USERS Field

public const Int32 ID_ALL_USERS = -2147483648;

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount Methods

The methods of the GroupAccount class are listed below. For a complete list of GroupAccount class members, see the GroupAccount Members topic.

Public Instance Methods

addPermission |
canRemove | Returns true if this GroupAccount and all of its descendants can be deleted without leaving any "orphan" users (i.e., users with no group membership).
Clone (inherited from CacheRef) |
copy | Creates a copy of this GroupAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals |
getDescription | Returns the group description.
getFullName | Returns a qualified name for the group, showing both the group and its parents.
GetHashCode |
getID | Returns this group's integer indentifier.
getName | Returns the group name.
getParent | Returns this groups's parent GroupAccount. If the group is a top-level group then this may return null.
getPermissionsFlags | Returns the permissions flags for this group.
getServer | Returns the Server object to which this GroupAccount belongs.
getSubGroupAccounts | Returns all of the sub-GroupAccounts for which this GroupAccount is the parent. The list may be empty but will never be null. The only way to change this list of sub groups is by modifying the parent GroupAccount of one of the children.
GetType (inherited from Object) | Gets the Type of the current instance.
getUserAccounts | Returns a list of UserAccount objects that directly belong to this group. The only way to change this list is through the UserAccount methods for adding and removing the UserAccount to a GroupAccount.
hasPermission |
isBuiltin | Return true if this is a builtin GroupAccount.
isDeleted | Returns true if the GroupAccount has been deleted.
isEqualTo | Compares two GroupAccount objects.
isMember |
isNew | Returns true if this GroupAccount has not yet been created on the Server.
isRoot | Returns true if this is a top-level group with no parent group.
MemberwiseClone (inherited from CacheRef) |
remove | Removes this group from the StarTeam server, plus any direct or indirect subgroups of this group. If the GroupAccount was never saved (isNew() returns true), if it is a builtin account, or if removing this group or any of its descendants would leave one or more users without any group membership, then an exception will be thrown. Note also that any affected UserAccounts will be updated, including any pending changes, as a side effect of this method.
removePermission |
setDescription |
setName |
setParent | Change the parent GroupAccount for this group. The parent may be null in which case the group will be a root group.
ToString (inherited from CacheRef) |
update | Persistently saves the changes to this GroupAccount in the server. If the GroupAccount is new it will be added, otherwise it will be modified.

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.addPermission Method

public virtual void addPermission(
Int32 permission
);

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.canRemove Method

Returns true if this GroupAccount and all of its descendants can be deleted without leaving any "orphan" users (i.e., users with no group membership).

public virtual bool canRemove();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.copy Method

Creates a copy of this GroupAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().

public virtual GroupAccount copy();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.Equals Method

public override bool Equals(
Object source
);

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.getDescription Method

Returns the group description.

public virtual string getDescription();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.getFullName Method

Returns a qualified name for the group, showing both the group and its parents.

public virtual string getFullName();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.GetHashCode Method

public override int GetHashCode();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.getID Method

Returns this group's integer indentifier.

public virtual int getID();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.getName Method

Returns the group name.

public virtual string getName();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.getParent Method

Returns this groups's parent GroupAccount. If the group is a top-level group then this may return null.

public virtual GroupAccount getParent();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.getPermissionsFlags Method

Returns the permissions flags for this group.

public virtual int getPermissionsFlags();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.getServer Method

Returns the Server object to which this GroupAccount belongs.

public virtual Server getServer();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.getSubGroupAccounts Method

Returns all of the sub-GroupAccounts for which this GroupAccount is the parent. The list may be empty but will never be null. The only way to change this list of sub groups is by modifying the parent GroupAccount of one of the children.

public virtual GroupAccount[] getSubGroupAccounts();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.getUserAccounts Method

Returns a list of UserAccount objects that directly belong to this group. The only way to change this list is through the UserAccount methods for adding and removing the UserAccount to a GroupAccount.

public virtual UserAccount[] getUserAccounts();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.hasPermission Method

public virtual bool hasPermission(
Int32 permission
);

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.isBuiltin Method

Return true if this is a builtin GroupAccount.

public virtual bool isBuiltin();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.isDeleted Method

Returns true if the GroupAccount has been deleted.

public virtual bool isDeleted();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.isEqualTo Method

Compares two GroupAccount objects.

public virtual bool isEqualTo(
GroupAccount account
);

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.isMember Method

public virtual bool isMember(
Int32 userID
);

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.isNew Method

Returns true if this GroupAccount has not yet been created on the Server.

public virtual bool isNew();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.isRoot Method

Returns true if this is a top-level group with no parent group.

public virtual bool isRoot();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.remove Method

Removes this group from the StarTeam server, plus any direct or indirect subgroups of this group. If the GroupAccount was never saved (isNew() returns true), if it is a builtin account, or if removing this group or any of its descendants would leave one or more users without any group membership, then an exception will be thrown. Note also that any affected UserAccounts will be updated, including any pending changes, as a side effect of this method.

public virtual void remove();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.removePermission Method

public virtual void removePermission(
Int32 permission
);

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.setDescription Method

public virtual void setDescription(
String description
);

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.setName Method

public virtual void setName(
String name
);

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.setParent Method

Change the parent GroupAccount for this group. The parent may be null in which case the group will be a root group.

public virtual void setParent(
GroupAccount parent
);

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupAccount.update Method

Persistently saves the changes to this GroupAccount in the server. If the GroupAccount is new it will be added, otherwise it will be modified.

public virtual void update();

See Also

GroupAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode Class

For a list of all members of this type, see GroupNode Members.

System.Object
GroupNode

public class GroupNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

GroupNode Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode Members

GroupNode overview

Public Instance Constructors

GroupNode Constructor

Public Instance Methods

addChild | Adds a GroupNode as a child of this GroupNode.
Equals |
getChildren | Returns the direct subgroups of this group.
getDepth | Returns the zero-based depth of this GroupNode in the grouping hierarchy.
GetHashCode |
getLength | Returns the number of contiguous objects spanned in the underlying indexable collection.
getName | Returns the display name of this group.
getNumChildren | Returns the number of direct subgroups of this group.
getNumVisibleLines | Returns the number of visible lines represented in this node, based on the current collapsed/expanded state of the hierarchy.
getParent | Returns the parent GroupNode.
getStart | Returns the index of the first leaf object of this node in the associated indexable collection.
GetType (inherited from Object) | Gets the Type of the current instance.
isExpanded | Returns true if this GroupNode is expanded.
isLeafNode | Returns true if this is a leaf-level GroupNode.
MemberwiseClone |
setExpanded |
toDebugString | Prints a String representation of the GroupNode, helpful for debugging.
ToString |

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode Constructor

public GroupNode(
String name,
Int32 start,
Int32 length
);

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode Methods

The methods of the GroupNode class are listed below. For a complete list of GroupNode class members, see the GroupNode Members topic.

Public Instance Methods

addChild | Adds a GroupNode as a child of this GroupNode.
Equals |
getChildren | Returns the direct subgroups of this group.
getDepth | Returns the zero-based depth of this GroupNode in the grouping hierarchy.
GetHashCode |
getLength | Returns the number of contiguous objects spanned in the underlying indexable collection.
getName | Returns the display name of this group.
getNumChildren | Returns the number of direct subgroups of this group.
getNumVisibleLines | Returns the number of visible lines represented in this node, based on the current collapsed/expanded state of the hierarchy.
getParent | Returns the parent GroupNode.
getStart | Returns the index of the first leaf object of this node in the associated indexable collection.
GetType (inherited from Object) | Gets the Type of the current instance.
isExpanded | Returns true if this GroupNode is expanded.
isLeafNode | Returns true if this is a leaf-level GroupNode.
MemberwiseClone |
setExpanded |
toDebugString | Prints a String representation of the GroupNode, helpful for debugging.
ToString |

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.addChild Method

Adds a GroupNode as a child of this GroupNode.

public virtual void addChild(
GroupNode child
);

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.Equals Method

public override bool Equals(
Object source
);

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.getChildren Method

Returns the direct subgroups of this group.

public virtual GroupNode[] getChildren();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.getDepth Method

Returns the zero-based depth of this GroupNode in the grouping hierarchy.

public virtual int getDepth();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.GetHashCode Method

public override int GetHashCode();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.getLength Method

Returns the number of contiguous objects spanned in the underlying indexable collection.

public virtual int getLength();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.getName Method

Returns the display name of this group.

public virtual string getName();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.getNumChildren Method

Returns the number of direct subgroups of this group.

public virtual int getNumChildren();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.getNumVisibleLines Method

Returns the number of visible lines represented in this node, based on the current collapsed/expanded state of the hierarchy.

public virtual int getNumVisibleLines();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.getParent Method

Returns the parent GroupNode.

public virtual GroupNode getParent();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.getStart Method

Returns the index of the first leaf object of this node in the associated indexable collection.

public virtual int getStart();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.isExpanded Method

Returns true if this GroupNode is expanded.

public virtual bool isExpanded();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.isLeafNode Method

Returns true if this is a leaf-level GroupNode.

public virtual bool isLeafNode();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.MemberwiseClone Method

public override object MemberwiseClone();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.setExpanded Method

public virtual void setExpanded(
Boolean bExpand
);

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.toDebugString Method

Prints a String representation of the GroupNode, helpful for debugging.

public virtual void toDebugString();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupNode.ToString Method

public override string ToString();

See Also

GroupNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo Class

For a list of all members of this type, see GroupSortInfo Members.

System.Object
GroupSortInfo

public class GroupSortInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

GroupSortInfo Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo Members

GroupSortInfo overview

Public Instance Constructors

GroupSortInfo Constructor

Public Instance Methods

Equals |
GetHashCode |
getPropertyID |
GetType (inherited from Object) | Gets the Type of the current instance.
isAscending |
isByDateOnly |
isByTextValue |
isCaseSensitive |
isGroup |
isSort |
MemberwiseClone |
setAscending |
setByDateOnly |
setByTextValue |
setCaseSensitive |
setPropertyID |
toDebugString |
ToString |

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo Constructor

public GroupSortInfo(
Boolean group,
Int32 propertyID,
Boolean ascending
);

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo Methods

The methods of the GroupSortInfo class are listed below. For a complete list of GroupSortInfo class members, see the GroupSortInfo Members topic.

Public Instance Methods

Equals |
GetHashCode |
getPropertyID |
GetType (inherited from Object) | Gets the Type of the current instance.
isAscending |
isByDateOnly |
isByTextValue |
isCaseSensitive |
isGroup |
isSort |
MemberwiseClone |
setAscending |
setByDateOnly |
setByTextValue |
setCaseSensitive |
setPropertyID |
toDebugString |
ToString |

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.Equals Method

public override bool Equals(
Object source
);

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.GetHashCode Method

public override int GetHashCode();

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.getPropertyID Method

public virtual int getPropertyID();

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.isAscending Method

public virtual bool isAscending();

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.isByDateOnly Method

public virtual bool isByDateOnly();

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.isByTextValue Method

public virtual bool isByTextValue();

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.isCaseSensitive Method

public virtual bool isCaseSensitive();

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.isGroup Method

public virtual bool isGroup();

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.isSort Method

public virtual bool isSort();

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.MemberwiseClone Method

public override object MemberwiseClone();

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.setAscending Method

public virtual void setAscending(
Boolean value
);

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.setByDateOnly Method

public virtual void setByDateOnly(
Boolean value
);

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.setByTextValue Method

public virtual void setByTextValue(
Boolean value
);

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.setCaseSensitive Method

public virtual void setCaseSensitive(
Boolean value
);

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.setPropertyID Method

public virtual void setPropertyID(
Int32 propertyID
);

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.toDebugString Method

public virtual string toDebugString();

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GroupSortInfo.ToString Method

public override string ToString();

See Also

GroupSortInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryKeyword Class

For a list of all members of this type, see HistoryKeyword Members.

System.Object
SimpleKeyword
HistoryKeyword

public class HistoryKeyword : SimpleKeyword

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

HistoryKeyword Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryKeyword Members

HistoryKeyword overview

Public Instance Constructors

HistoryKeyword Constructor Constructs a $History$ keyword using the specified history entries.

Public Instance Methods

Equals |
expand |
GetHashCode |
getName (inherited from SimpleKeyword) |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue (inherited from SimpleKeyword) |
matches |
MemberwiseClone (inherited from SimpleKeyword) |
multiLine |
stopExpanding (inherited from SimpleKeyword) |
ToString (inherited from SimpleKeyword) |
toXMLString |

See Also

HistoryKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryKeyword Constructor

Constructs a $History$ keyword using the specified history entries.

public HistoryKeyword(
HistoryLine historyLine
);

See Also

HistoryKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryKeyword Methods

The methods of the HistoryKeyword class are listed below. For a complete list of HistoryKeyword class members, see the HistoryKeyword Members topic.

Public Instance Methods

Equals |
expand |
GetHashCode |
getName (inherited from SimpleKeyword) |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue (inherited from SimpleKeyword) |
matches |
MemberwiseClone (inherited from SimpleKeyword) |
multiLine |
stopExpanding (inherited from SimpleKeyword) |
ToString (inherited from SimpleKeyword) |
toXMLString |

See Also

HistoryKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryKeyword.Equals Method

public override bool Equals(
Object source
);

See Also

HistoryKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryKeyword.expand Method

public override string expand(
String linePrefix,
String eol,
Boolean expand
);

Implements

Keyword.expand

See Also

HistoryKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryKeyword.GetHashCode Method

public override int GetHashCode();

See Also

HistoryKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryKeyword.matches Method

public override bool matches(
String line,
Int32 start,
Int32[] endPos
);

Implements

Keyword.matches

See Also

HistoryKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryKeyword.multiLine Method

public override bool multiLine();

Implements

Keyword.multiLine

See Also

HistoryKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryKeyword.toXMLString Method

public override string toXMLString();

Implements

Keyword.toXMLString

See Also

HistoryKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryLine Class

For a list of all members of this type, see HistoryLine Members.

System.Object
LogLine
HistoryLine

public class HistoryLine : LogLine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

HistoryLine Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryLine Members

HistoryLine overview

Public Instance Constructors

HistoryLine Constructor

Public Instance Methods

Equals |
format |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from LogLine) |
ToString (inherited from LogLine) |
toXMLString |

See Also

HistoryLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryLine Constructor

public HistoryLine(
Int32 version,
String viewName,
String dotNotation,
OLEDate date,
String author,
String comment
);

See Also

HistoryLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryLine Methods

The methods of the HistoryLine class are listed below. For a complete list of HistoryLine class members, see the HistoryLine Members topic.

Public Instance Methods

Equals |
format |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from LogLine) |
ToString (inherited from LogLine) |
toXMLString |

See Also

HistoryLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryLine.Equals Method

public override bool Equals(
Object source
);

See Also

HistoryLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryLine.format Method

public virtual string format(
String prefix,
String eol
);

See Also

HistoryLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryLine.GetHashCode Method

public override int GetHashCode();

See Also

HistoryLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HistoryLine.toXMLString Method

public override string toXMLString();

See Also

HistoryLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo Class

For a list of all members of this type, see HiveInfo Members.

System.Object
HiveInfo

public class HiveInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

HiveInfo Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo Members

HiveInfo overview

Public Instance Constructors

HiveInfo Overloaded. Initializes a new instance of the HiveInfo class.

Public Instance Methods

copy | return a copy of this HiveInfo instance
Equals |
getAllowNewArchives | Indicates whether new archive files can be added to the hive. The default is TRUE.
getArchiveDirectory | Path to the hive's Archive directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Archives.
getCacheCleanupInterval | Seconds between cache cleanup operations. The default value is 600. The range is 60 (1 minute) to 3153600 (1 year).
getCacheDirectory | Path to the hive's Cache directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Cache.
GetHashCode |
getID | The number assigned by StarTeam to identify the hive.
getMaxCacheSize | Maximum number of megabytes of hard disk space that the cache can use. -1 is the default and represents 20 percent of the available disk space at the time the option is set. The range is -1 to 9,223,372,036,854,775,807.
getName | The name of the hive. Note that on UNIX-based systems the name should not include any spaces.
getRootCacheAgentArchiveDirectory | Same folder path as for ArchiveDirectory but from the perspective of the computer on which the Root Cache Agent is installed. If the Root Cache Agent is installed on the same computer as the StarTeam Server, this can be empty or the same setting as the ArchiveDirectory.
getRootDirectory | Shortcut to creating path to Cache and Archive directories; when set, CacheDirectory and ArchiveDirectory do not need to be set. The default is [repository_path]\DefaultHive.
getStorageLimitThreshold | Percentage of total disk space allowed for hive. When this percentage of total disk space has been used, no more archives can be added to the hive. -1 is the default and represents 95 percent of total disk space. The range is -1 to 100.
getType | The number assigned by StarTeam to identify the the type of archive files stored in the hive: 0 for unknown; 1 for PVCS, 2 for VSS, or 3 for Native II.
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo | Return true if this HiveInfo is equal to the argument.
MemberwiseClone |
setAllowNewArchives |
setArchiveDirectory |
setCacheCleanupInterval |
setCacheDirectory |
setMaxCacheSize |
setName |
setRootCacheAgentArchiveDirectory |
setRootDirectory |
setStorageLimitThreshold |
ToString |

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo Constructor

Overload List

construct a new HiveInfo from the source

public HiveInfo(HiveInfo);

Obsolete.

public HiveInfo(Int32);

public HiveInfo(Int32,String,String,String,String,String,Boolean,Int32,Int64,Int32);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo Constructor (Int32, String, String, String, String, String, Boolean, Int32, Int64, Int32)

public HiveInfo(
Int32 hiveType,
String name,
String rootDirectory,
String cacheDirectory,
String archiveDirectory,
String rootCacheAgentArchiveDirectory,
Boolean bAllowNewArchives,
Int32 storageLimitThreshold,
Int64 maxCacheSize,
Int32 cacheCleanupInterval
);

See Also

HiveInfo Class | com.starbase.starteam Namespace | HiveInfo Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo Constructor (Int32)

NOTE: This constructor is now obsolete.

public HiveInfo(
Int32 ID
);

See Also

HiveInfo Class | com.starbase.starteam Namespace | HiveInfo Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo Constructor (HiveInfo)

construct a new HiveInfo from the source

public HiveInfo(
HiveInfo source
);

See Also

HiveInfo Class | com.starbase.starteam Namespace | HiveInfo Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo Methods

The methods of the HiveInfo class are listed below. For a complete list of HiveInfo class members, see the HiveInfo Members topic.

Public Instance Methods

copy | return a copy of this HiveInfo instance
Equals |
getAllowNewArchives | Indicates whether new archive files can be added to the hive. The default is TRUE.
getArchiveDirectory | Path to the hive's Archive directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Archives.
getCacheCleanupInterval | Seconds between cache cleanup operations. The default value is 600. The range is 60 (1 minute) to 3153600 (1 year).
getCacheDirectory | Path to the hive's Cache directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Cache.
GetHashCode |
getID | The number assigned by StarTeam to identify the hive.
getMaxCacheSize | Maximum number of megabytes of hard disk space that the cache can use. -1 is the default and represents 20 percent of the available disk space at the time the option is set. The range is -1 to 9,223,372,036,854,775,807.
getName | The name of the hive. Note that on UNIX-based systems the name should not include any spaces.
getRootCacheAgentArchiveDirectory | Same folder path as for ArchiveDirectory but from the perspective of the computer on which the Root Cache Agent is installed. If the Root Cache Agent is installed on the same computer as the StarTeam Server, this can be empty or the same setting as the ArchiveDirectory.
getRootDirectory | Shortcut to creating path to Cache and Archive directories; when set, CacheDirectory and ArchiveDirectory do not need to be set. The default is [repository_path]\DefaultHive.
getStorageLimitThreshold | Percentage of total disk space allowed for hive. When this percentage of total disk space has been used, no more archives can be added to the hive. -1 is the default and represents 95 percent of total disk space. The range is -1 to 100.
getType | The number assigned by StarTeam to identify the the type of archive files stored in the hive: 0 for unknown; 1 for PVCS, 2 for VSS, or 3 for Native II.
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo | Return true if this HiveInfo is equal to the argument.
MemberwiseClone |
setAllowNewArchives |
setArchiveDirectory |
setCacheCleanupInterval |
setCacheDirectory |
setMaxCacheSize |
setName |
setRootCacheAgentArchiveDirectory |
setRootDirectory |
setStorageLimitThreshold |
ToString |

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.copy Method

return a copy of this HiveInfo instance

public virtual HiveInfo copy();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.Equals Method

public override bool Equals(
Object source
);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.getAllowNewArchives Method

Indicates whether new archive files can be added to the hive. The default is TRUE.

public virtual bool getAllowNewArchives();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.getArchiveDirectory Method

Path to the hive's Archive directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Archives.

public virtual string getArchiveDirectory();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.getCacheCleanupInterval Method

Seconds between cache cleanup operations. The default value is 600. The range is 60 (1 minute) to 3153600 (1 year).

public virtual int getCacheCleanupInterval();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.getCacheDirectory Method

Path to the hive's Cache directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Cache.

public virtual string getCacheDirectory();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.GetHashCode Method

public override int GetHashCode();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.getID Method

The number assigned by StarTeam to identify the hive.

public virtual int getID();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.getMaxCacheSize Method

Maximum number of megabytes of hard disk space that the cache can use. -1 is the default and represents 20 percent of the available disk space at the time the option is set. The range is -1 to 9,223,372,036,854,775,807.

public virtual long getMaxCacheSize();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.getName Method

The name of the hive. Note that on UNIX-based systems the name should not include any spaces.

public virtual string getName();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.getRootCacheAgentArchiveDirectory Method

Same folder path as for ArchiveDirectory but from the perspective of the computer on which the Root Cache Agent is installed. If the Root Cache Agent is installed on the same computer as the StarTeam Server, this can be empty or the same setting as the ArchiveDirectory.

public virtual string getRootCacheAgentArchiveDirectory();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.getRootDirectory Method

Shortcut to creating path to Cache and Archive directories; when set, CacheDirectory and ArchiveDirectory do not need to be set. The default is [repository_path]\DefaultHive.

public virtual string getRootDirectory();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.getStorageLimitThreshold Method

Percentage of total disk space allowed for hive. When this percentage of total disk space has been used, no more archives can be added to the hive. -1 is the default and represents 95 percent of total disk space. The range is -1 to 100.

public virtual int getStorageLimitThreshold();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.getType Method

The number assigned by StarTeam to identify the the type of archive files stored in the hive: 0 for unknown; 1 for PVCS, 2 for VSS, or 3 for Native II.

public virtual int getType();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.isEqualTo Method

Return true if this HiveInfo is equal to the argument.

public virtual bool isEqualTo(
HiveInfo other
);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.MemberwiseClone Method

public override object MemberwiseClone();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.setAllowNewArchives Method

public virtual void setAllowNewArchives(
Boolean bAllowNewArchives
);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.setArchiveDirectory Method

public virtual void setArchiveDirectory(
String archiveDirectory
);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.setCacheCleanupInterval Method

public virtual void setCacheCleanupInterval(
Int32 cacheCleanupInterval
);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.setCacheDirectory Method

public virtual void setCacheDirectory(
String cacheDirectory
);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.setMaxCacheSize Method

public virtual void setMaxCacheSize(
Int64 maxCacheSize
);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.setName Method

public virtual void setName(
String name
);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.setRootCacheAgentArchiveDirectory Method

public virtual void setRootCacheAgentArchiveDirectory(
String rootCacheAgentArchiveDirectory
);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.setRootDirectory Method

public virtual void setRootDirectory(
String rootDirectory
);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.setStorageLimitThreshold Method

public virtual void setStorageLimitThreshold(
Int32 storageLimitThreshold
);

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.ToString Method

public override string ToString();

See Also

HiveInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.HiveType Class

For a list of all members of this type, see HiveInfo.HiveType Members.

System.Object
HiveInfo.HiveType

public class HiveInfo.HiveType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

HiveInfo.HiveType Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.HiveType Members

HiveInfo.HiveType overview

Public Static Fields

eNativeII
ePVCS
eUNKNOWN
eVSS

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HiveInfo.HiveType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.HiveType Fields

The fields of the HiveInfo.HiveType class are listed below. For a complete list of HiveInfo.HiveType class members, see the HiveInfo.HiveType Members topic.

Public Static Fields

eNativeII
ePVCS
eUNKNOWN
eVSS

See Also

HiveInfo.HiveType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.HiveType.eNativeII Field

public const Int32 eNativeII = 3;

See Also

HiveInfo.HiveType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.HiveType.ePVCS Field

public const Int32 ePVCS = 1;

See Also

HiveInfo.HiveType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.HiveType.eUNKNOWN Field

public const Int32 eUNKNOWN = 0;

See Also

HiveInfo.HiveType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveInfo.HiveType.eVSS Field

public const Int32 eVSS = 2;

See Also

HiveInfo.HiveType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveManager Class

For a list of all members of this type, see HiveManager Members.

System.Object
HiveManager

public class HiveManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

HiveManager Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveManager Members

HiveManager overview

Public Instance Constructors

HiveManager Constructor Constructor.

Public Instance Methods

Equals |
GetHashCode |
getHiveInfo | Returns the current set of HiveInfos from the server, or null if new vault format is not supported on this server. Available on server release 7.0 and later.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setHiveInfo |
ToString |

See Also

HiveManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveManager Constructor

Constructor.

public HiveManager(
Server server
);

See Also

HiveManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveManager Methods

The methods of the HiveManager class are listed below. For a complete list of HiveManager class members, see the HiveManager Members topic.

Public Instance Methods

Equals |
GetHashCode |
getHiveInfo | Returns the current set of HiveInfos from the server, or null if new vault format is not supported on this server. Available on server release 7.0 and later.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setHiveInfo |
ToString |

See Also

HiveManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveManager.Equals Method

public override bool Equals(
Object source
);

See Also

HiveManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveManager.GetHashCode Method

public override int GetHashCode();

See Also

HiveManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveManager.getHiveInfo Method

Returns the current set of HiveInfos from the server, or null if new vault format is not supported on this server. Available on server release 7.0 and later.

public virtual HiveInfo[] getHiveInfo();

See Also

HiveManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveManager.MemberwiseClone Method

public override object MemberwiseClone();

See Also

HiveManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveManager.setHiveInfo Method

public virtual bool setHiveInfo(
HiveInfo[] info
);

See Also

HiveManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


HiveManager.ToString Method

public override string ToString();

See Also

HiveManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IFilterQueryListener Interface

com.starbase.starteam.IFilterQueryListener
FilterListener
QueryListener

public interface IFilterQueryListener : EventListener

Types that implement IFilterQueryListener

Type | Description
FilterAdapter |
FilterQueryAdapter |
QueryAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IFolderListener Interface

com.starbase.starteam.IFolderListener
FolderListener
FolderTreeListener

public interface IFolderListener : EventListener

Types that implement IFolderListener

Type | Description
FolderAdapter |
FolderTreeAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IItemListener Interface

com.starbase.starteam.IItemListener
ItemIDListener
ItemListener
ItemListListener
NotificationListener

public interface IItemListener : EventListener

Types that implement IItemListener

Type | Description
ItemAdapter |
ItemIDAdapter |
ItemListAdapter |
NotificationAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility Class

For a list of all members of this type, see ImportUtility Members.

System.Object
ImportUtility

public class ImportUtility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ImportUtility Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility Members

ImportUtility overview

Public Instance Constructors

ImportUtility Constructor Creates a new ImportUtility object for the specified server.

Public Instance Methods

enableImportMode | <b>Warning: This method is potentially very dangerous and should be used with extreme caution.</b> Calling this method will put the server into a state in which the same server object can be used to perform operations for different users. Once the server has been put into import mode it cannot be put out of that mode
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setCommandTime |
setCommandUserID |
switchUserContext |
ToString |

See Also

ImportUtility Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility Constructor

Creates a new ImportUtility object for the specified server.

public ImportUtility(
Server server
);

See Also

ImportUtility Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility Methods

The methods of the ImportUtility class are listed below. For a complete list of ImportUtility class members, see the ImportUtility Members topic.

Public Instance Methods

enableImportMode | <b>Warning: This method is potentially very dangerous and should be used with extreme caution.</b> Calling this method will put the server into a state in which the same server object can be used to perform operations for different users. Once the server has been put into import mode it cannot be put out of that mode
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setCommandTime |
setCommandUserID |
switchUserContext |
ToString |

See Also

ImportUtility Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility.enableImportMode Method

<b>Warning: This method is potentially very dangerous and should be used with extreme caution.</b> Calling this method will put the server into a state in which the same server object can be used to perform operations for different users. Once the server has been put into import mode it cannot be put out of that mode

public virtual void enableImportMode();

See Also

ImportUtility Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility.Equals Method

public override bool Equals(
Object source
);

See Also

ImportUtility Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility.GetHashCode Method

public override int GetHashCode();

See Also

ImportUtility Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ImportUtility Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility.setCommandTime Method

public virtual void setCommandTime(
Double time
);

See Also

ImportUtility Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility.setCommandUserID Method

public virtual void setCommandUserID(
Int32 userID
);

See Also

ImportUtility Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility.switchUserContext Method

public virtual void switchUserContext(
Int32 userID
);

See Also

ImportUtility Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ImportUtility.ToString Method

public override string ToString();

See Also

ImportUtility Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange Class

For a list of all members of this type, see IPRange Members.

System.Object
IPRange

public class IPRange

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

IPRange Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange Members

IPRange overview

Public Instance Constructors

IPRange Overloaded. Initializes a new instance of the IPRange class.

Public Instance Methods

copy | return a copy of this IPRange instance
Equals |
getAlgorithm | Returns the minimum required level of encryption for this range.
GetHashCode |
getMaxIP | Returns the maximum IP address for this range. The form will be "0.0.0.0".
getMinIP | Returns the minimum IP address for this range. The form will be "0.0.0.0".
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo | returns true if this object instance is equal to the source
MemberwiseClone |
setAlgorithm | Sets the minimum required level of encryption for this range.
setMaxIP |
setMinIP |
ToString |

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange Constructor

Overload List

construct a new IPRange from the source

public IPRange(IPRange);

public IPRange(String,String,EncryptionAlgorithm);

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange Constructor (String, String, EncryptionAlgorithm)

public IPRange(
String min,
String max,
EncryptionAlgorithm required
);

See Also

IPRange Class | com.starbase.starteam Namespace | IPRange Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange Constructor (IPRange)

construct a new IPRange from the source

public IPRange(
IPRange source
);

See Also

IPRange Class | com.starbase.starteam Namespace | IPRange Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange Methods

The methods of the IPRange class are listed below. For a complete list of IPRange class members, see the IPRange Members topic.

Public Instance Methods

copy | return a copy of this IPRange instance
Equals |
getAlgorithm | Returns the minimum required level of encryption for this range.
GetHashCode |
getMaxIP | Returns the maximum IP address for this range. The form will be "0.0.0.0".
getMinIP | Returns the minimum IP address for this range. The form will be "0.0.0.0".
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo | returns true if this object instance is equal to the source
MemberwiseClone |
setAlgorithm | Sets the minimum required level of encryption for this range.
setMaxIP |
setMinIP |
ToString |

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.copy Method

return a copy of this IPRange instance

public virtual IPRange copy();

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.Equals Method

public override bool Equals(
Object source
);

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.getAlgorithm Method

Returns the minimum required level of encryption for this range.

public virtual EncryptionAlgorithm getAlgorithm();

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.GetHashCode Method

public override int GetHashCode();

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.getMaxIP Method

Returns the maximum IP address for this range. The form will be "0.0.0.0".

public virtual string getMaxIP();

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.getMinIP Method

Returns the minimum IP address for this range. The form will be "0.0.0.0".

public virtual string getMinIP();

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.isEqualTo Method

returns true if this object instance is equal to the source

public virtual bool isEqualTo(
IPRange source
);

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.MemberwiseClone Method

public override object MemberwiseClone();

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.setAlgorithm Method

Sets the minimum required level of encryption for this range.

public virtual void setAlgorithm(
EncryptionAlgorithm algorithm
);

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.setMaxIP Method

public virtual void setMaxIP(
String ip
);

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.setMinIP Method

public virtual void setMinIP(
String ip
);

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


IPRange.ToString Method

public override string ToString();

See Also

IPRange Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurable Interface

For a list of all members of this type, see ISecurable Members.

com.starbase.starteam.ISecurable
ISecurableObject

public interface ISecurable

Types that implement ISecurable

Type | Description
ISecurableAdapter |
ISecurableObjectAdapter |
Audit |
ChangeRequest |
File |
Filter |
Folder |
Item |
Project |
PromotionState |
QueryInfo |
RecycleBin |
Task |
Topic |
TreeItem |
View |
MergePreview |
VCMFolder |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ISecurable Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurable Members

ISecurable overview

Public Instance Methods

getACL | Gets the access rights explicitly assigned to this object.
getParentContainer | If there are no access rights explicitly assigned to this object, then the effective access rights come from a parent container.
getType | If there are no access rights explicitly assigned to this object, then the effective access rights come from a parent container. Access rights in the parent container are type-specific.
hasPermission |
setACL |

See Also

ISecurable Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurable Methods

The methods of the ISecurable interface are listed below. For a complete list of ISecurable interface members, see the ISecurable Members topic.

Public Instance Methods

getACL | Gets the access rights explicitly assigned to this object.
getParentContainer | If there are no access rights explicitly assigned to this object, then the effective access rights come from a parent container.
getType | If there are no access rights explicitly assigned to this object, then the effective access rights come from a parent container. Access rights in the parent container are type-specific.
hasPermission |
setACL |

See Also

ISecurable Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurable.getACL Method

Gets the access rights explicitly assigned to this object.

AclEntry[] getACL();

See Also

ISecurable Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurable.getParentContainer Method

If there are no access rights explicitly assigned to this object, then the effective access rights come from a parent container.

ISecurableContainer getParentContainer();

See Also

ISecurable Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurable.getType Method

If there are no access rights explicitly assigned to this object, then the effective access rights come from a parent container. Access rights in the parent container are type-specific.

Type getType();

See Also

ISecurable Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurable.hasPermission Method

bool hasPermission(
Int32 permissions
);

See Also

ISecurable Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurable.setACL Method

void setACL(
AclEntry[] acl
);

See Also

ISecurable Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableContainer Interface

For a list of all members of this type, see ISecurableContainer Members.

public interface ISecurableContainer

Types that implement ISecurableContainer

Type | Description
ISecurableContainerAdapter |
Folder |
Project |
RecycleBin |
SecurableContainerAdapter |
Type |
View |
MergePreview |
VCMFolder |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ISecurableContainer Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableContainer Members

ISecurableContainer overview

Public Instance Methods

getContainerLevelACL |
getParentContainer | If there are no container-level access rights for the given type explicitly assigned to this container, then the effective container-level access rights come from a parent container.
hasPermission |
setContainerLevelACL |

See Also

ISecurableContainer Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableContainer Methods

The methods of the ISecurableContainer interface are listed below. For a complete list of ISecurableContainer interface members, see the ISecurableContainer Members topic.

Public Instance Methods

getContainerLevelACL |
getParentContainer | If there are no container-level access rights for the given type explicitly assigned to this container, then the effective container-level access rights come from a parent container.
hasPermission |
setContainerLevelACL |

See Also

ISecurableContainer Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableContainer.getContainerLevelACL Method

AclEntry[] getContainerLevelACL(
String typeName
);

See Also

ISecurableContainer Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableContainer.getParentContainer Method

If there are no container-level access rights for the given type explicitly assigned to this container, then the effective container-level access rights come from a parent container.

ISecurableContainer getParentContainer();

See Also

ISecurableContainer Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableContainer.hasPermission Method

bool hasPermission(
Int32 permissions,
String typeName
);

See Also

ISecurableContainer Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableContainer.setContainerLevelACL Method

void setContainerLevelACL(
AclEntry[] acl,
String typeName
);

See Also

ISecurableContainer Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableObject Interface

For a list of all members of this type, see ISecurableObject Members.

public interface ISecurableObject : ISecurable

Types that implement ISecurableObject

Type | Description
ISecurableObjectAdapter |
Audit |
ChangeRequest |
File |
Folder |
Item |
Project |
PromotionState |
RecycleBin |
Task |
Topic |
TreeItem |
View |
MergePreview |
VCMFolder |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ISecurableObject Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableObject Members

ISecurableObject overview

Public Instance Methods

acquireOwnership | Sets ownership of this securable object to the logged in user.
getOwner | Securable objects have an owner. The owner of an object is normally granted full access rights for the object.

See Also

ISecurableObject Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableObject Methods

The methods of the ISecurableObject interface are listed below. For a complete list of ISecurableObject interface members, see the ISecurableObject Members topic.

Public Instance Methods

acquireOwnership | Sets ownership of this securable object to the logged in user.
getOwner | Securable objects have an owner. The owner of an object is normally granted full access rights for the object.

See Also

ISecurableObject Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableObject.acquireOwnership Method

Sets ownership of this securable object to the logged in user.

void acquireOwnership();

See Also

ISecurableObject Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISecurableObject.getOwner Method

Securable objects have an owner. The owner of an object is normally granted full access rights for the object.

int getOwner();

See Also

ISecurableObject Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item Class

For a list of all members of this type, see Item Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Item
Audit
ChangeRequest
File
Folder
TreeItem

public class Item : SimpleTypedResource, ISecurableObject, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Item Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item Members

Item overview

Public Static Methods

createItem
getBranchRevisionFromDotNotation
getViewVersionFromDotNotation

Public Instance Methods

acquireOwnership
addAttachment
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment
createAttachmentFromFile
deleteMergePoint | Deletes the specified merge point for this item.
discard | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals
get
getACL
getAllLabels | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAttachedLabels | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment
getAttachmentIDs | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile
getBehavior | Returns ItemBehavior object associated with this Item.
getByProperty | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID
getByteArray
getCachedProperties | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getComment | Returns the comment describing this revision of the item.
getCommonAncestor | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getCreatedBy | Returns the user ID of the user that created the first revision of the item.
getCreatedTime | Returns the time at which the first revision of the item was created.
getDeletedTime | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDisplayValue | Gets the value of a property in a form suitable for display.
getDotNotation | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble
getEnumDisplayName
getFlag | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName
getFromHistoryByDate | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID
getFromHistoryByVersion
GetHashCode
getHistory | Returns the past versions of this item.
getID
getInt
getIntArray
getItemID | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLocker | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory | Returns the merge points for this item.
getModifiedBy | Returns the user ID of the user that created this revision of the item.
getModifiedTime | Returns the time at which this revision of the item was created.
getMyLock | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getNewRevisionComment | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getObjectID | Returns the object ID property for this item.
getOLEDate
getOwner
getParentContainer
getParentFolder | Returns the folder in which this item exists.
getParentFolderHierarchy | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName | Returns the name of the item's parent folder.
getParentFolderPath | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPossibleFlag | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues
getPropertyNames
getReadStatus | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName
getReference | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer | Returns the server object to which this item belongs.
getString
getType
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames
getView | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasPermission
hasValues
isBranchable | Returns true if this item is a type that is branchable.
isDeleted | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory | Determines whether or not this is a historical item obtained from the history.
isNew | Returns true if this item has not yet been stored in the server.
isRefreshRequired | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare | Determines whether or not this item is the root share of its share tree.
lock | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser
modifyReadStatusForUser
move | Obsolete. Moves this item to the specified folder. The item will be removed from its current folder.
moveTo | Moves this item to the specified folder. The item will be removed from its current folder.
populate | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put
putByPropertyID
putLock
recordMergePoint | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
removeAttachment
removeFromIntArray (inherited from TypedResource)
resolveMergePoint | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL
setBehavior | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange
setComment
setFixedConfig | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
shareTo | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. <p> If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
smartShareTo | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString | Returns a <code>String</code> that is potentially useful while debugging.
ToString
unlock | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
updateRevisionComment

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item Methods

The methods of the Item class are listed below. For a complete list of Item class members, see the Item Members topic.

Public Static Methods

createItem
getBranchRevisionFromDotNotation
getViewVersionFromDotNotation

Public Instance Methods

acquireOwnership
addAttachment
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment
createAttachmentFromFile
deleteMergePoint | Deletes the specified merge point for this item.
discard | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals
get
getACL
getAllLabels | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAttachedLabels | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment
getAttachmentIDs | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile
getBehavior | Returns ItemBehavior object associated with this Item.
getByProperty | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID
getByteArray
getCachedProperties | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getComment | Returns the comment describing this revision of the item.
getCommonAncestor | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getCreatedBy | Returns the user ID of the user that created the first revision of the item.
getCreatedTime | Returns the time at which the first revision of the item was created.
getDeletedTime | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDisplayValue | Gets the value of a property in a form suitable for display.
getDotNotation | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble
getEnumDisplayName
getFlag | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName
getFromHistoryByDate | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID
getFromHistoryByVersion
GetHashCode
getHistory | Returns the past versions of this item.
getID
getInt
getIntArray
getItemID | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLocker | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory | Returns the merge points for this item.
getModifiedBy | Returns the user ID of the user that created this revision of the item.
getModifiedTime | Returns the time at which this revision of the item was created.
getMyLock | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getNewRevisionComment | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getObjectID | Returns the object ID property for this item.
getOLEDate
getOwner
getParentContainer
getParentFolder | Returns the folder in which this item exists.
getParentFolderHierarchy | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName | Returns the name of the item's parent folder.
getParentFolderPath | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPossibleFlag | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues
getPropertyNames
getReadStatus | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName
getReference | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer | Returns the server object to which this item belongs.
getString
getType
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames
getView | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasPermission
hasValues
isBranchable | Returns true if this item is a type that is branchable.
isDeleted | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory | Determines whether or not this is a historical item obtained from the history.
isNew | Returns true if this item has not yet been stored in the server.
isRefreshRequired | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare | Determines whether or not this item is the root share of its share tree.
lock | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser
modifyReadStatusForUser
move | Obsolete. Moves this item to the specified folder. The item will be removed from its current folder.
moveTo | Moves this item to the specified folder. The item will be removed from its current folder.
populate | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put
putByPropertyID
putLock
recordMergePoint | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove | Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.
removeAttachment
removeFromIntArray (inherited from TypedResource)
resolveMergePoint | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL
setBehavior | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange
setComment
setFixedConfig | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
shareTo | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. <p> If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
smartShareTo | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString | Returns a <code>String</code> that is potentially useful while debugging.
ToString
unlock | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
updateRevisionComment

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.acquireOwnership Method

public virtual void acquireOwnership();

Implements

ISecurableObject.acquireOwnership

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.addAttachment Method

public virtual void addAttachment(
String name,
Int32 attachmentID
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.copy Method

Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().

public virtual Item copy();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.createAttachment Method

public virtual int createAttachment(
String name,
InputStream source
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.createAttachmentFromFile Method

public virtual int createAttachmentFromFile(
String name,
File source
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.createItem Method

public static Item createItem(
String typeName,
Folder parent
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.deleteMergePoint Method

Deletes the specified merge point for this item.

public virtual void deleteMergePoint(
MergePoint mergePoint
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.discard Method

Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.

public virtual void discard();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.Equals Method

public override bool Equals(
Object another
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.get Method

public override object get(
String propertyName
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getACL Method

public virtual AclEntry[] getACL();

Implements

ISecurable.getACL

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getAllLabels Method

Returns all labels attached to any version of this item. This includes both view labels and revision labels.

public virtual Label[] getAllLabels();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getAttachedLabels Method

Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.

public virtual Label[] getAttachedLabels();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getAttachment Method

public virtual void getAttachment(
Int32 attachmentID,
OutputStream out
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getAttachmentIDs Method

Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.

public virtual int[] getAttachmentIDs();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getAttachmentNames Method

Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.

public virtual string[] getAttachmentNames();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getAttachmentToFile Method

public virtual void getAttachmentToFile(
Int32 attachmentID,
File outFile
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getBehavior Method

Returns ItemBehavior object associated with this Item.

public virtual ItemBehavior getBehavior();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getBranchRevisionFromDotNotation Method

public static int getBranchRevisionFromDotNotation(
String dotNotation
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getByProperty Method

Returns the value of the specified property. Retrieves value from persistent store if not already cached.

public virtual object getByProperty(
Property property
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getByPropertyID Method

public virtual object getByPropertyID(
Int32 propertyID
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getByteArray Method

public override sbyte[] getByteArray(
String propertyName
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getCachedProperties Method

Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client

public virtual Property[] getCachedProperties();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getComment Method

Returns the comment describing this revision of the item.

public virtual string getComment();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getCommonAncestor Method

Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.

public virtual Item getCommonAncestor(
Item other
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getCreatedBy Method

Returns the user ID of the user that created the first revision of the item.

public virtual int getCreatedBy();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getCreatedTime Method

Returns the time at which the first revision of the item was created.

public virtual OLEDate getCreatedTime();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getDeletedTime Method

For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.

public virtual OLEDate getDeletedTime();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getDeletedUserID Method

For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.

public virtual int getDeletedUserID();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getDisplayValue Method

Gets the value of a property in a form suitable for display.

public virtual string getDisplayValue(
Property prop
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getDotNotation Method

Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.

public virtual string getDotNotation();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getDouble Method

public override double getDouble(
String propertyName
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getEnumDisplayName Method

public override string getEnumDisplayName(
String propertyName,
Int32 value
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getFlag Method

Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.

public virtual int getFlag();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getFlagDisplayName Method

public virtual string getFlagDisplayName(
Int32 value
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getFromHistoryByDate Method

Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.

public virtual Item getFromHistoryByDate(
OLEDate date
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getFromHistoryByLabelID Method

public virtual Item getFromHistoryByLabelID(
Int32 labelID
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getFromHistoryByVersion Method

public virtual Item getFromHistoryByVersion(
Int32 viewVersion
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.GetHashCode Method

public override int GetHashCode();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getHistory Method

Returns the past versions of this item.

public virtual Item[] getHistory();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getID Method

public override int getID();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getInt Method

public override int getInt(
String propertyName
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getIntArray Method

public override int[] getIntArray(
String propertyName
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getItemID Method

Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.

public virtual int getItemID();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getItemRevisions Method

Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.

public virtual ItemRevision[] getItemRevisions();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getLocker Method

Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.

public virtual int getLocker();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getMergeHistory Method

Returns the merge points for this item.

public virtual MergePoint[] getMergeHistory();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getModifiedBy Method

Returns the user ID of the user that created this revision of the item.

public virtual int getModifiedBy();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getModifiedTime Method

Returns the time at which this revision of the item was created.

public virtual OLEDate getModifiedTime();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getMyLock Method

Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.

public virtual int getMyLock();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getNewRevisionComment Method

Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.

public virtual string getNewRevisionComment();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getObjectID Method

Returns the object ID property for this item.

public virtual int getObjectID();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getOLEDate Method

public override OLEDate getOLEDate(
String propertyName
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getOwner Method

public virtual int getOwner();

Implements

ISecurableObject.getOwner

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getParentContainer Method

public virtual ISecurableContainer getParentContainer();

Implements

ISecurable.getParentContainer

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getParentFolder Method

Returns the folder in which this item exists.

public virtual Folder getParentFolder();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getParentFolderHierarchy Method

Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.

public virtual string getParentFolderHierarchy();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getParentFolderName Method

Returns the name of the item's parent folder.

public virtual string getParentFolderName();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getParentFolderPath Method

Returns the working directory path for the item's parent folder.

public virtual string getParentFolderPath();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getParentFolderQualifiedName Method

Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.

public virtual string getParentFolderQualifiedName();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getParentRevision Method

Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.

public virtual int getParentRevision();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getPossibleFlag Method

Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleFlag();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getPossibleReadStatus Method

Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleReadStatus();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getPossibleValues Method

public override int[] getPossibleValues(
String propertyName
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getPropertyNames Method

public override PropertyNames getPropertyNames();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getReadStatus Method

A flag indicating whether or not the user has read this item before. It is not supported for File objects.

public virtual int getReadStatus();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getReadStatusDisplayName Method

public virtual string getReadStatusDisplayName(
Int32 value
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getReference Method

Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.

public virtual ItemReference getReference(
ViewConfiguration config
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getReferences Method

Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().

public virtual ItemReference[] getReferences();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getRevisionNumber Method

Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).

public virtual int getRevisionNumber();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getRootObjectID Method

Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.

public virtual int getRootObjectID();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getServer Method

Returns the server object to which this item belongs.

public virtual Server getServer();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getString Method

public override string getString(
String propertyName
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getType Method

public override Type getType();

Implements

ISecurable.getType

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getTypeNames Method

public override TypeNames getTypeNames();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getView Method

Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.

public virtual View getView();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getViewVersion Method

The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).

public virtual int getViewVersion();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.getViewVersionFromDotNotation Method

public static int getViewVersionFromDotNotation(
String dotNotation
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.hasPermission Method

public virtual bool hasPermission(
Int32 permissions
);

Implements

ISecurable.hasPermission

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.hasValues Method

public virtual bool hasValues(
String[] propertyNames
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.isBranchable Method

Returns true if this item is a type that is branchable.

public virtual bool isBranchable();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.isDeleted Method

Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.

public virtual bool isDeleted();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.isDirty Method

Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().

public virtual bool isDirty();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.isDisembodied Method

A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.

public virtual bool isDisembodied();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.isEqualTo Method

Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>

public virtual bool isEqualTo(
Item item
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.isFromHistory Method

Determines whether or not this is a historical item obtained from the history.

public virtual bool isFromHistory();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.isNew Method

Returns true if this item has not yet been stored in the server.

public virtual bool isNew();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


isRefreshRequired Method

Borland StarTeam SDK for .NET

Item.isRefreshRequired Method

Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.

Overload List

Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.

public virtual bool isRefreshRequired();

public virtual bool isRefreshRequired(String[]);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.isRefreshRequired Method ()

Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.

public virtual bool isRefreshRequired();

See Also

Item Class | com.starbase.starteam Namespace | Item.isRefreshRequired Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.isRefreshRequired Method (String[])

public virtual bool isRefreshRequired(
String[] propertyNames
);

See Also

Item Class | com.starbase.starteam Namespace | Item.isRefreshRequired Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.isReverseShareRecommended Method

Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.

public virtual bool isReverseShareRecommended(
Folder target
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.isRootShare Method

Determines whether or not this item is the root share of its share tree.

public virtual bool isRootShare();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.lock Method

Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.

public virtual void lock();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.modifyFlagForUser Method

public virtual void modifyFlagForUser(
Boolean setFlagged
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.modifyReadStatusForUser Method

public virtual void modifyReadStatusForUser(
Boolean bSetAsRead
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.move Method

NOTE: This method is now obsolete.

Moves this item to the specified folder. The item will be removed from its current folder.

public virtual void move(
Folder toFolder
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.moveTo Method

Moves this item to the specified folder. The item will be removed from its current folder.

public virtual void moveTo(
Folder toFolder
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


populate Method

Borland StarTeam SDK for .NET

Item.populate Method

Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.

Overload List

Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.

public virtual void populate();

public virtual void populate(String[]);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.populate Method ()

Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.

public virtual void populate();

See Also

Item Class | com.starbase.starteam Namespace | Item.populate Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.populate Method (String[])

public virtual void populate(
String[] propertyNames
);

See Also

Item Class | com.starbase.starteam Namespace | Item.populate Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.put Method

public override object put(
String propertyName,
Object propertyValue
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.putByPropertyID Method

public override object putByPropertyID(
Int32 propertyID,
Object propertyValue
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.putLock Method

public virtual void putLock(
Int32 lockType,
Boolean breakLock
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.recordMergePoint Method

Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.

public virtual void recordMergePoint(
Item source
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


refresh Method

Borland StarTeam SDK for .NET

Item.refresh Method

Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

Overload List

Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void refresh();

public virtual void refresh(String[]);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.refresh Method ()

Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void refresh();

See Also

Item Class | com.starbase.starteam Namespace | Item.refresh Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.refresh Method (String[])

public virtual void refresh(
String[] propertyNames
);

See Also

Item Class | com.starbase.starteam Namespace | Item.refresh Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.remove Method

Removes this item from its current folder. This is not quite a delete operation because other items might refer to the same underlying object.

public virtual void remove();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.removeAttachment Method

public virtual void removeAttachment(
Int32 attachmentID
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.resolveMergePoint Method

Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.

public virtual MergePoint resolveMergePoint(
Item source
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.reverseShareTo Method

Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.

public virtual Item reverseShareTo(
Folder toFolder
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.setACL Method

public virtual void setACL(
AclEntry[] acl
);

Implements

ISecurable.setACL

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.setBehavior Method

Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.

public virtual void setBehavior(
ItemBehavior behavior
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.setBranchOnChange Method

public virtual void setBranchOnChange(
Boolean bBranchOnChange
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.setComment Method

public virtual void setComment(
String comment
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.setFixedConfig Method

Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.

public virtual void setFixedConfig(
ViewConfiguration config
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.setFloatingConfig Method

Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.

public virtual void setFloatingConfig();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.shareTo Method

Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. <p> If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.

public virtual Item shareTo(
Folder toFolder
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.smartShareTo Method

Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.

public virtual Item smartShareTo(
Folder target
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.toDebugString Method

Returns a <code>String</code> that is potentially useful while debugging.

public virtual string toDebugString();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.ToString Method

public override string ToString();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.unlock Method

Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.

public virtual void unlock();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.update Method

Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.

public virtual void update();

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.updateRevisionComment Method

public virtual void updateRevisionComment(
String comment
);

See Also

Item Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.LockType Class

For a list of all members of this type, see Item.LockType Members.

System.Object
Item.LockType

public class Item.LockType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Item.LockType Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.LockType Members

Item.LockType overview

Public Static Fields

BREAK_FLAG
EXCLUSIVE
NONEXCLUSIVE
UNCHANGED
UNLOCKED

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Item.LockType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.LockType Fields

The fields of the Item.LockType class are listed below. For a complete list of Item.LockType class members, see the Item.LockType Members topic.

Public Static Fields

BREAK_FLAG
EXCLUSIVE
NONEXCLUSIVE
UNCHANGED
UNLOCKED

See Also

Item.LockType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.LockType.BREAK_FLAG Field

public const Int32 BREAK_FLAG = 16;

See Also

Item.LockType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.LockType.EXCLUSIVE Field

public static readonly Int32 EXCLUSIVE;

See Also

Item.LockType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.LockType.NONEXCLUSIVE Field

public static readonly Int32 NONEXCLUSIVE;

See Also

Item.LockType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.LockType.UNCHANGED Field

public const Int32 UNCHANGED = 3;

See Also

Item.LockType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Item.LockType.UNLOCKED Field

public static readonly Int32 UNLOCKED;

See Also

Item.LockType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemAdapter Class

For a list of all members of this type, see ItemAdapter Members.

System.Object
ItemAdapter

public class ItemAdapter : ItemListener, IItemListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemAdapter Members

ItemAdapter overview

Public Instance Constructors

ItemAdapter Constructor Initializes a new instance of the ItemAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
itemAdded |
itemChanged |
itemMoved |
itemRemoved |
MemberwiseClone |
ToString |

See Also

ItemAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemAdapter Constructor

Initializes a new instance of the ItemAdapter class.

public ItemAdapter();

See Also

ItemAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemAdapter Methods

The methods of the ItemAdapter class are listed below. For a complete list of ItemAdapter class members, see the ItemAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
itemAdded |
itemChanged |
itemMoved |
itemRemoved |
MemberwiseClone |
ToString |

See Also

ItemAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemAdapter.itemAdded Method

public override void itemAdded(
ItemEvent e
);

Implements

ItemListener.itemAdded

See Also

ItemAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemAdapter.itemChanged Method

public override void itemChanged(
ItemEvent e
);

Implements

ItemListener.itemChanged

See Also

ItemAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemAdapter.itemMoved Method

public override void itemMoved(
ItemEvent e
);

Implements

ItemListener.itemMoved

See Also

ItemAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemAdapter.itemRemoved Method

public override void itemRemoved(
ItemEvent e
);

Implements

ItemListener.itemRemoved

See Also

ItemAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemAdapter.ToString Method

public override string ToString();

See Also

ItemAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior Class

For a list of all members of this type, see ItemBehavior Members.

System.Object
ItemBehavior

public class ItemBehavior

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemBehavior Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior Members

ItemBehavior overview

Public Static Fields

BRANCH_STATE_BRANCHABLE
BRANCH_STATE_BRANCHED
BRANCH_STATE_NOT_SUPPORTED
BRANCH_STATE_ROOT

Public Instance Constructors

ItemBehavior Constructor Constructs a new ItemBehavior that is a copy of an existing one.

Public Instance Methods

Equals |
getBranchOnChange | Determines whether or not this ItemBehavior is set to branch on change.
getBranchState | Gets the branch state.
getConfig | Gets this ItemBehavior's current configuration.
getFixConfig | Determines whether or not this item has a fixed configuration.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setBranchOnChange |
setConfig | Changes this ItemBehavior to use the given configuration. Note that in order to apply the resulting behavior to an item, you must call Item.setBehavior().
setFloatingConfig | Changes this ItemBehavior to use a floating configuration. Note that in order to apply the resulting behavior to an item, you must call Item.setBehavior().
ToString |

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior Constructor

Constructs a new ItemBehavior that is a copy of an existing one.

public ItemBehavior(
ItemBehavior behavior
);

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior Fields

The fields of the ItemBehavior class are listed below. For a complete list of ItemBehavior class members, see the ItemBehavior Members topic.

Public Static Fields

BRANCH_STATE_BRANCHABLE
BRANCH_STATE_BRANCHED
BRANCH_STATE_NOT_SUPPORTED
BRANCH_STATE_ROOT

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.BRANCH_STATE_BRANCHABLE Field

public const Int32 BRANCH_STATE_BRANCHABLE = 0;

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.BRANCH_STATE_BRANCHED Field

public const Int32 BRANCH_STATE_BRANCHED = 1;

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.BRANCH_STATE_NOT_SUPPORTED Field

public const Int32 BRANCH_STATE_NOT_SUPPORTED = 3;

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.BRANCH_STATE_ROOT Field

public const Int32 BRANCH_STATE_ROOT = 2;

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior Methods

The methods of the ItemBehavior class are listed below. For a complete list of ItemBehavior class members, see the ItemBehavior Members topic.

Public Instance Methods

Equals |
getBranchOnChange | Determines whether or not this ItemBehavior is set to branch on change.
getBranchState | Gets the branch state.
getConfig | Gets this ItemBehavior's current configuration.
getFixConfig | Determines whether or not this item has a fixed configuration.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setBranchOnChange |
setConfig | Changes this ItemBehavior to use the given configuration. Note that in order to apply the resulting behavior to an item, you must call Item.setBehavior().
setFloatingConfig | Changes this ItemBehavior to use a floating configuration. Note that in order to apply the resulting behavior to an item, you must call Item.setBehavior().
ToString |

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.Equals Method

public override bool Equals(
Object source
);

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.getBranchOnChange Method

Determines whether or not this ItemBehavior is set to branch on change.

public virtual bool getBranchOnChange();

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.getBranchState Method

Gets the branch state.

public virtual int getBranchState();

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.getConfig Method

Gets this ItemBehavior's current configuration.

public virtual ViewConfiguration getConfig();

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.getFixConfig Method

Determines whether or not this item has a fixed configuration.

public virtual bool getFixConfig();

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.GetHashCode Method

public override int GetHashCode();

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.setBranchOnChange Method

public virtual void setBranchOnChange(
Boolean bBranchOnChange
);

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.setConfig Method

Changes this ItemBehavior to use the given configuration. Note that in order to apply the resulting behavior to an item, you must call Item.setBehavior().

public virtual void setConfig(
ViewConfiguration config
);

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.setFloatingConfig Method

Changes this ItemBehavior to use a floating configuration. Note that in order to apply the resulting behavior to an item, you must call Item.setBehavior().

public virtual void setFloatingConfig();

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemBehavior.ToString Method

public override string ToString();

See Also

ItemBehavior Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemEvent Class

For a list of all members of this type, see ItemEvent Members.

System.Object
EventObject
ItemEvent

public class ItemEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemEvent Members

ItemEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
getNewItem | Gets the Item in its new state. <p> Used in itemAdded(), itemMoved() and itemChanged() events. In itemRemoved() events, getNewItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Items associated with the original Folder object, it must do so by explicitly calling Folder.refreshItems().
GetObjectData (inherited from java.util.EventObject) |
getOldItem | Gets the Item in its old state. <p> Used in itemChanged(), itemMoved() and itemRemoved() events. In itemAdded() events, getOldItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ItemEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemEvent Methods

The methods of the ItemEvent class are listed below. For a complete list of ItemEvent class members, see the ItemEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
getNewItem | Gets the Item in its new state. <p> Used in itemAdded(), itemMoved() and itemChanged() events. In itemRemoved() events, getNewItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Items associated with the original Folder object, it must do so by explicitly calling Folder.refreshItems().
GetObjectData (inherited from java.util.EventObject) |
getOldItem | Gets the Item in its old state. <p> Used in itemChanged(), itemMoved() and itemRemoved() events. In itemAdded() events, getOldItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ItemEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemEvent.Equals Method

public override bool Equals(
Object source
);

See Also

ItemEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemEvent.GetHashCode Method

public override int GetHashCode();

See Also

ItemEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemEvent.getNewItem Method

Gets the Item in its new state. <p> Used in itemAdded(), itemMoved() and itemChanged() events. In itemRemoved() events, getNewItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Items associated with the original Folder object, it must do so by explicitly calling Folder.refreshItems().

public virtual Item getNewItem();

See Also

ItemEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemEvent.getOldItem Method

Gets the Item in its old state. <p> Used in itemChanged(), itemMoved() and itemRemoved() events. In itemAdded() events, getOldItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy.

public virtual Item getOldItem();

See Also

ItemEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemEvent.getSource Method

public override object getSource();

See Also

ItemEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemEvent.ToString Method

public override string ToString();

See Also

ItemEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDAdapter Class

For a list of all members of this type, see ItemIDAdapter Members.

System.Object
ItemIDAdapter

public class ItemIDAdapter : ItemIDListener, IItemListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemIDAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDAdapter Members

ItemIDAdapter overview

Public Instance Constructors

ItemIDAdapter Constructor Initializes a new instance of the ItemIDAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
itemAdded |
itemChanged |
itemRemoved |
MemberwiseClone |
ToString |

See Also

ItemIDAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDAdapter Constructor

Initializes a new instance of the ItemIDAdapter class.

public ItemIDAdapter();

See Also

ItemIDAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDAdapter Methods

The methods of the ItemIDAdapter class are listed below. For a complete list of ItemIDAdapter class members, see the ItemIDAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
itemAdded |
itemChanged |
itemRemoved |
MemberwiseClone |
ToString |

See Also

ItemIDAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDAdapter.itemAdded Method

public override void itemAdded(
ItemIDEvent e
);

Implements

ItemIDListener.itemAdded

See Also

ItemIDAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDAdapter.itemChanged Method

public override void itemChanged(
ItemIDEvent e
);

Implements

ItemIDListener.itemChanged

See Also

ItemIDAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDAdapter.itemRemoved Method

public override void itemRemoved(
ItemIDEvent e
);

Implements

ItemIDListener.itemRemoved

See Also

ItemIDAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemIDAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDAdapter.ToString Method

public override string ToString();

See Also

ItemIDAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDEvent Class

For a list of all members of this type, see ItemIDEvent Members.

System.Object
EventObject
ItemIDEvent

public class ItemIDEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemIDEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDEvent Members

ItemIDEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
getItemID | Gets the ID of the Item that was added, changed or removed.
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ItemIDEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDEvent Methods

The methods of the ItemIDEvent class are listed below. For a complete list of ItemIDEvent class members, see the ItemIDEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
getItemID | Gets the ID of the Item that was added, changed or removed.
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ItemIDEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDEvent.Equals Method

public override bool Equals(
Object source
);

See Also

ItemIDEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDEvent.GetHashCode Method

public override int GetHashCode();

See Also

ItemIDEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDEvent.getItemID Method

Gets the ID of the Item that was added, changed or removed.

public virtual int getItemID();

See Also

ItemIDEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDEvent.getSource Method

public override object getSource();

See Also

ItemIDEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemIDEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDEvent.ToString Method

public override string ToString();

See Also

ItemIDEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDListener Interface

For a list of all members of this type, see ItemIDListener Members.

public interface ItemIDListener : IItemListener, EventListener

Types that implement ItemIDListener

Type | Description
ItemIDAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemIDListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDListener Members

ItemIDListener overview

Public Instance Methods

itemAdded | Invoked when an Item is added to a view. <p> An itemAdded event is triggered whenever an Item with a new ItemID appears in the view. This might be because a new item was created; because an item was moved or shared in from another view; etc. <p> ItemIDEvent.getItemID() provides the ItemID of the item that was added. <p> If an item is moved from one folder to another folder within the same view, itemAdded and itemRemoved events are both triggered. The order in which they are triggered is unpredictable. <p> If the logged-in user does not have access rights to see the item in its new context, then no event is triggered.
itemChanged | Invoked when the properties of an Item have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as CreatedUserID or ModifiedTime). <p> ItemIDEvent.getItemID() provides the ItemID of the item whose properties have changed.
itemRemoved | Invoked when an Item is removed from a view. <p> An itemRemoved event is triggered whenever an Item disappears from the view. This might be because an item was deleted; because an item was moved to another view; etc. <p> ItemIDEvent.getItemID() provides the ItemID of the item that was removed. <p> If an item is moved from one folder to another folder within the same view, itemAdded and itemRemoved events are both triggered. The order in which they are triggered is unpredictable.

See Also

ItemIDListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDListener Methods

The methods of the ItemIDListener interface are listed below. For a complete list of ItemIDListener interface members, see the ItemIDListener Members topic.

Public Instance Methods

itemAdded | Invoked when an Item is added to a view. <p> An itemAdded event is triggered whenever an Item with a new ItemID appears in the view. This might be because a new item was created; because an item was moved or shared in from another view; etc. <p> ItemIDEvent.getItemID() provides the ItemID of the item that was added. <p> If an item is moved from one folder to another folder within the same view, itemAdded and itemRemoved events are both triggered. The order in which they are triggered is unpredictable. <p> If the logged-in user does not have access rights to see the item in its new context, then no event is triggered.
itemChanged | Invoked when the properties of an Item have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as CreatedUserID or ModifiedTime). <p> ItemIDEvent.getItemID() provides the ItemID of the item whose properties have changed.
itemRemoved | Invoked when an Item is removed from a view. <p> An itemRemoved event is triggered whenever an Item disappears from the view. This might be because an item was deleted; because an item was moved to another view; etc. <p> ItemIDEvent.getItemID() provides the ItemID of the item that was removed. <p> If an item is moved from one folder to another folder within the same view, itemAdded and itemRemoved events are both triggered. The order in which they are triggered is unpredictable.

See Also

ItemIDListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDListener.itemAdded Method

Invoked when an Item is added to a view. <p> An itemAdded event is triggered whenever an Item with a new ItemID appears in the view. This might be because a new item was created; because an item was moved or shared in from another view; etc. <p> ItemIDEvent.getItemID() provides the ItemID of the item that was added. <p> If an item is moved from one folder to another folder within the same view, itemAdded and itemRemoved events are both triggered. The order in which they are triggered is unpredictable. <p> If the logged-in user does not have access rights to see the item in its new context, then no event is triggered.

void itemAdded(
ItemIDEvent e
);

See Also

ItemIDListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDListener.itemChanged Method

Invoked when the properties of an Item have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as CreatedUserID or ModifiedTime). <p> ItemIDEvent.getItemID() provides the ItemID of the item whose properties have changed.

void itemChanged(
ItemIDEvent e
);

See Also

ItemIDListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemIDListener.itemRemoved Method

Invoked when an Item is removed from a view. <p> An itemRemoved event is triggered whenever an Item disappears from the view. This might be because an item was deleted; because an item was moved to another view; etc. <p> ItemIDEvent.getItemID() provides the ItemID of the item that was removed. <p> If an item is moved from one folder to another folder within the same view, itemAdded and itemRemoved events are both triggered. The order in which they are triggered is unpredictable.

void itemRemoved(
ItemIDEvent e
);

See Also

ItemIDListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList Class

For a list of all members of this type, see ItemList Members.

System.Object
ItemList

public class ItemList : Runnable, Items

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemList Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList Members

ItemList overview

Public Instance Constructors

ItemList Constructor Creates a new empty item list.

Public Instance Methods

addItem | Add an item to the end of the list.
copyInto | Copies the Items from this list to the specified ItemList. You might want to use this method rather than multiple calls to getItemsFrom and addItem because any time an item is retrieved from the list it will ensure that the item properties are available. This method will not cause the items in the source list to be populated before adding them to this list.
elements | Returns an <code>Enumeration</code> of the list's contents.
endThread | Obsolete. Suspends th thread that is performing the background retrieval of property values.
Equals |
getAt |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
isRefreshRequired |
killThread | Obsolete. Kills th thread that is performing the background retrieval of property values.
MemberwiseClone |
populateAsNeeded | Obsolete.
populateInBackground | Obsolete.
populateNow |
refresh |
removeAll | removes all the Items from this list
removeItem | Removes an item from the list.
run | Obsolete. This is Runnable's run method and is used for fetching data in a background thread. This method is for internal use only.
setAt |
size |
startThread | Obsolete. Starts or resumes the thread that is performing the background retrieval of property values.
swap |
ToString |

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList Constructor

Creates a new empty item list.

public ItemList();

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList Methods

The methods of the ItemList class are listed below. For a complete list of ItemList class members, see the ItemList Members topic.

Public Instance Methods

addItem | Add an item to the end of the list.
copyInto | Copies the Items from this list to the specified ItemList. You might want to use this method rather than multiple calls to getItemsFrom and addItem because any time an item is retrieved from the list it will ensure that the item properties are available. This method will not cause the items in the source list to be populated before adding them to this list.
elements | Returns an <code>Enumeration</code> of the list's contents.
endThread | Obsolete. Suspends th thread that is performing the background retrieval of property values.
Equals |
getAt |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
isRefreshRequired |
killThread | Obsolete. Kills th thread that is performing the background retrieval of property values.
MemberwiseClone |
populateAsNeeded | Obsolete.
populateInBackground | Obsolete.
populateNow |
refresh |
removeAll | removes all the Items from this list
removeItem | Removes an item from the list.
run | Obsolete. This is Runnable's run method and is used for fetching data in a background thread. This method is for internal use only.
setAt |
size |
startThread | Obsolete. Starts or resumes the thread that is performing the background retrieval of property values.
swap |
ToString |

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.addItem Method

Add an item to the end of the list.

public virtual void addItem(
Item item
);

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.copyInto Method

Copies the Items from this list to the specified ItemList. You might want to use this method rather than multiple calls to getItemsFrom and addItem because any time an item is retrieved from the list it will ensure that the item properties are available. This method will not cause the items in the source list to be populated before adding them to this list.

public virtual void copyInto(
ItemList list
);

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.elements Method

Returns an <code>Enumeration</code> of the list's contents.

public virtual Enumeration elements();

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.endThread Method

NOTE: This method is now obsolete.

Suspends th thread that is performing the background retrieval of property values.

public virtual void endThread();

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.Equals Method

public override bool Equals(
Object source
);

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.getAt Method

public virtual Item getAt(
Int32 index
);

Implements

Items.getAt

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.GetHashCode Method

public override int GetHashCode();

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.isRefreshRequired Method

public virtual bool isRefreshRequired(
String[] propertyNames
);

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.killThread Method

NOTE: This method is now obsolete.

Kills th thread that is performing the background retrieval of property values.

public virtual void killThread();

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.populateAsNeeded Method

NOTE: This method is now obsolete.

public virtual void populateAsNeeded(
String[] propertyNames,
Int32 chunkSize
);

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.populateInBackground Method

NOTE: This method is now obsolete.

public virtual void populateInBackground(
String[] propertyNames,
Int32 chunkSize
);

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.populateNow Method

public virtual void populateNow(
String[] propertyNames
);

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.refresh Method

public virtual void refresh(
String[] propertyNames
);

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.removeAll Method

removes all the Items from this list

public virtual void removeAll();

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.removeItem Method

Removes an item from the list.

public virtual void removeItem(
Item item
);

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.run Method

NOTE: This method is now obsolete.

This is Runnable's run method and is used for fetching data in a background thread. This method is for internal use only.

public virtual void run();

Implements

Runnable.run

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.setAt Method

public virtual void setAt(
Item item,
Int32 index
);

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.size Method

public virtual int size();

Implements

Items.size

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.startThread Method

NOTE: This method is now obsolete.

Starts or resumes the thread that is performing the background retrieval of property values.

public virtual void startThread();

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.swap Method

public virtual void swap(
Int32 indexA,
Int32 indexB
);

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemList.ToString Method

public override string ToString();

See Also

ItemList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListAdapter Class

For a list of all members of this type, see ItemListAdapter Members.

System.Object
ItemListAdapter

public class ItemListAdapter : ItemListListener, IItemListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemListAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListAdapter Members

ItemListAdapter overview

Public Instance Constructors

ItemListAdapter Constructor Initializes a new instance of the ItemListAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
itemsChanged |
MemberwiseClone |
ToString |

See Also

ItemListAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListAdapter Constructor

Initializes a new instance of the ItemListAdapter class.

public ItemListAdapter();

See Also

ItemListAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListAdapter Methods

The methods of the ItemListAdapter class are listed below. For a complete list of ItemListAdapter class members, see the ItemListAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
itemsChanged |
MemberwiseClone |
ToString |

See Also

ItemListAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListAdapter.itemsChanged Method

public override void itemsChanged(
ItemListEvent e
);

Implements

ItemListListener.itemsChanged

See Also

ItemListAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemListAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListAdapter.ToString Method

public override string ToString();

See Also

ItemListAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListener Interface

For a list of all members of this type, see ItemListener Members.

public interface ItemListener : IItemListener, EventListener

Types that implement ItemListener

Type | Description
ItemAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListener Members

ItemListener overview

Public Instance Methods

itemAdded | Invoked when an Item is added to a view. <p> An itemAdded event is triggered whenever an Item with a new ItemID appears in the view. This might be because a new item was created; because an item was moved or shared in from another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no new items are created. In this case, an itemMoved event is triggered instead of an itemAdded event. <p> If the logged-in user does not have access rights to see the item in its new context, then no event is triggered. <p> For itemAdded events, ItemEvent.getNewItem() returns the added item in its new context. ItemEvent.getOldItem() returns null.
itemChanged | Invoked when the properties of an Item have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as CreatedUserID or ModifiedTime). <p> For itemChanged events, ItemEvent.getOldItem() returns a Item object representing the item in its old state (that is, before its properties were changed). ItemEvent.getNewItem() returns the item in its new state (after its properties were changed).
itemMoved | Invoked when an Item is moved within a view. <p> An itemMoved event is triggered whenever an Item is moved from one folder to another folder within the same view. In this case, no items with new ItemIDs are added to the view, and no items are removed. Thus, when an itemMoved event is triggered, corresponding itemAdded and itemRemoved events will not be triggered. <p> If an item exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the item does not exist. If the item is then moved to a new parent item in the same view such that it is now accessible, then, from that user's point of view, the item has been added, not moved. Thus, in that case, an itemAdded event will be triggered instead of an itemMoved event. <p> Similarly, if an item is moved in such a way that it is no longer visible to the current user, an itemRemoved event will be triggered instead of an itemMoved event. <p> For itemMoved events, ItemEvent.getOldItem() returns a Item object representing the item before it was moved (that is, attached to the old parent folder). ItemEvent.getNewItem() returns a Item object representing the item after it was moved (attached to the new parent).
itemRemoved | Invoked when an Item is removed from a view. <p> An itemRemoved event is triggered whenever an Item disappears from the view. This might be because an item was deleted; because an item was moved to another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no Item items are removed. In this case, an itemMoved event is triggered instead of an itemRemoved event. <p> For itemRemoved events, ItemEvent.getOldItem() returns the removed item in its old context (that is, prior to being removed). ItemEvent.getNewItem() returns null.

See Also

ItemListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListener Methods

The methods of the ItemListener interface are listed below. For a complete list of ItemListener interface members, see the ItemListener Members topic.

Public Instance Methods

itemAdded | Invoked when an Item is added to a view. <p> An itemAdded event is triggered whenever an Item with a new ItemID appears in the view. This might be because a new item was created; because an item was moved or shared in from another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no new items are created. In this case, an itemMoved event is triggered instead of an itemAdded event. <p> If the logged-in user does not have access rights to see the item in its new context, then no event is triggered. <p> For itemAdded events, ItemEvent.getNewItem() returns the added item in its new context. ItemEvent.getOldItem() returns null.
itemChanged | Invoked when the properties of an Item have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as CreatedUserID or ModifiedTime). <p> For itemChanged events, ItemEvent.getOldItem() returns a Item object representing the item in its old state (that is, before its properties were changed). ItemEvent.getNewItem() returns the item in its new state (after its properties were changed).
itemMoved | Invoked when an Item is moved within a view. <p> An itemMoved event is triggered whenever an Item is moved from one folder to another folder within the same view. In this case, no items with new ItemIDs are added to the view, and no items are removed. Thus, when an itemMoved event is triggered, corresponding itemAdded and itemRemoved events will not be triggered. <p> If an item exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the item does not exist. If the item is then moved to a new parent item in the same view such that it is now accessible, then, from that user's point of view, the item has been added, not moved. Thus, in that case, an itemAdded event will be triggered instead of an itemMoved event. <p> Similarly, if an item is moved in such a way that it is no longer visible to the current user, an itemRemoved event will be triggered instead of an itemMoved event. <p> For itemMoved events, ItemEvent.getOldItem() returns a Item object representing the item before it was moved (that is, attached to the old parent folder). ItemEvent.getNewItem() returns a Item object representing the item after it was moved (attached to the new parent).
itemRemoved | Invoked when an Item is removed from a view. <p> An itemRemoved event is triggered whenever an Item disappears from the view. This might be because an item was deleted; because an item was moved to another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no Item items are removed. In this case, an itemMoved event is triggered instead of an itemRemoved event. <p> For itemRemoved events, ItemEvent.getOldItem() returns the removed item in its old context (that is, prior to being removed). ItemEvent.getNewItem() returns null.

See Also

ItemListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListener.itemAdded Method

Invoked when an Item is added to a view. <p> An itemAdded event is triggered whenever an Item with a new ItemID appears in the view. This might be because a new item was created; because an item was moved or shared in from another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no new items are created. In this case, an itemMoved event is triggered instead of an itemAdded event. <p> If the logged-in user does not have access rights to see the item in its new context, then no event is triggered. <p> For itemAdded events, ItemEvent.getNewItem() returns the added item in its new context. ItemEvent.getOldItem() returns null.

void itemAdded(
ItemEvent e
);

See Also

ItemListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListener.itemChanged Method

Invoked when the properties of an Item have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as CreatedUserID or ModifiedTime). <p> For itemChanged events, ItemEvent.getOldItem() returns a Item object representing the item in its old state (that is, before its properties were changed). ItemEvent.getNewItem() returns the item in its new state (after its properties were changed).

void itemChanged(
ItemEvent e
);

See Also

ItemListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListener.itemMoved Method

Invoked when an Item is moved within a view. <p> An itemMoved event is triggered whenever an Item is moved from one folder to another folder within the same view. In this case, no items with new ItemIDs are added to the view, and no items are removed. Thus, when an itemMoved event is triggered, corresponding itemAdded and itemRemoved events will not be triggered. <p> If an item exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the item does not exist. If the item is then moved to a new parent item in the same view such that it is now accessible, then, from that user's point of view, the item has been added, not moved. Thus, in that case, an itemAdded event will be triggered instead of an itemMoved event. <p> Similarly, if an item is moved in such a way that it is no longer visible to the current user, an itemRemoved event will be triggered instead of an itemMoved event. <p> For itemMoved events, ItemEvent.getOldItem() returns a Item object representing the item before it was moved (that is, attached to the old parent folder). ItemEvent.getNewItem() returns a Item object representing the item after it was moved (attached to the new parent).

void itemMoved(
ItemEvent e
);

See Also

ItemListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListener.itemRemoved Method

Invoked when an Item is removed from a view. <p> An itemRemoved event is triggered whenever an Item disappears from the view. This might be because an item was deleted; because an item was moved to another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no Item items are removed. In this case, an itemMoved event is triggered instead of an itemRemoved event. <p> For itemRemoved events, ItemEvent.getOldItem() returns the removed item in its old context (that is, prior to being removed). ItemEvent.getNewItem() returns null.

void itemRemoved(
ItemEvent e
);

See Also

ItemListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListEvent Class

For a list of all members of this type, see ItemListEvent Members.

System.Object
EventObject
ItemListEvent

public class ItemListEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemListEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListEvent Members

ItemListEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
getFolder | Gets the Folder whose Item list has changed. <p> Returns a new Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are up-to-date as of the time the event was triggered. In fact, an application can rely on the entire Folder hierarchy being up-to-date. For performance reasons, these same Folder objects may be re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should first make a copy. <p> If an application wants to refresh the Items associated with the original Folder object, it must do so by explicitly calling Folder.refreshItems().
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
getType | Gets the Type of the item list has changed. <p> Returns a Type object that is not a member of the Server's Type collection. The Type is up-to-date as of the time the event is triggered.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ItemListEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListEvent Methods

The methods of the ItemListEvent class are listed below. For a complete list of ItemListEvent class members, see the ItemListEvent Members topic.

Public Instance Methods

Equals |
getFolder | Gets the Folder whose Item list has changed. <p> Returns a new Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are up-to-date as of the time the event was triggered. In fact, an application can rely on the entire Folder hierarchy being up-to-date. For performance reasons, these same Folder objects may be re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should first make a copy. <p> If an application wants to refresh the Items associated with the original Folder object, it must do so by explicitly calling Folder.refreshItems().
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
getType | Gets the Type of the item list has changed. <p> Returns a Type object that is not a member of the Server's Type collection. The Type is up-to-date as of the time the event is triggered.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ItemListEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListEvent.Equals Method

public override bool Equals(
Object source
);

See Also

ItemListEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListEvent.getFolder Method

Gets the Folder whose Item list has changed. <p> Returns a new Folder object that is not a member of any View's folder hierarchy. There may be a Folder in the hierarchy with the same ItemID, but it would be a physically different object that is likely to have different properties. <p> Folder.getParentFolder() and Folder.getSubFolders() will return values that are up-to-date as of the time the event was triggered. In fact, an application can rely on the entire Folder hierarchy being up-to-date. For performance reasons, these same Folder objects may be re-used in subsequent events. If an application wants to modify one of the Folder objects, or save its state for later use, it should first make a copy. <p> If an application wants to refresh the Items associated with the original Folder object, it must do so by explicitly calling Folder.refreshItems().

public virtual Folder getFolder();

See Also

ItemListEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListEvent.GetHashCode Method

public override int GetHashCode();

See Also

ItemListEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListEvent.getSource Method

public override object getSource();

See Also

ItemListEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListEvent.getType Method

Gets the Type of the item list has changed. <p> Returns a Type object that is not a member of the Server's Type collection. The Type is up-to-date as of the time the event is triggered.

public virtual Type getType();

See Also

ItemListEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemListEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListEvent.ToString Method

public override string ToString();

See Also

ItemListEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListListener Interface

For a list of all members of this type, see ItemListListener Members.

public interface ItemListListener : IItemListener, EventListener

Types that implement ItemListListener

Type | Description
ItemListAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemListListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListListener Members

ItemListListener overview

Public Instance Methods

itemsChanged Invoked when the list of Items of a particular Type has changed in a Folder. This includes whenever an Item is added, moved, shared, deleted, etc. <p> ItemListEvent.getFolder() returns the Folder whose item list has changed. For example, if Item A is moved from Folder B to Folder C, itemsChanged events are triggered for both Folder B and Folder C. <p> Applications that are more interested in receiving information about Item A in this case should listen for ItemEvents by registering an ItemListener.

See Also

ItemListListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListListener Methods

The methods of the ItemListListener interface are listed below. For a complete list of ItemListListener interface members, see the ItemListListener Members topic.

Public Instance Methods

itemsChanged Invoked when the list of Items of a particular Type has changed in a Folder. This includes whenever an Item is added, moved, shared, deleted, etc. <p> ItemListEvent.getFolder() returns the Folder whose item list has changed. For example, if Item A is moved from Folder B to Folder C, itemsChanged events are triggered for both Folder B and Folder C. <p> Applications that are more interested in receiving information about Item A in this case should listen for ItemEvents by registering an ItemListener.

See Also

ItemListListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListListener.itemsChanged Method

Invoked when the list of Items of a particular Type has changed in a Folder. This includes whenever an Item is added, moved, shared, deleted, etc. <p> ItemListEvent.getFolder() returns the Folder whose item list has changed. For example, if Item A is moved from Folder B to Folder C, itemsChanged events are triggered for both Folder B and Folder C. <p> Applications that are more interested in receiving information about Item A in this case should listen for ItemEvents by registering an ItemListener.

void itemsChanged(
ItemListEvent e
);

See Also

ItemListListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager Class

For a list of all members of this type, see ItemListManager Members.

System.Object
ItemListManager

public class ItemListManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemListManager Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager Members

ItemListManager overview

Public Instance Constructors

ItemListManager Constructor

Public Instance Methods

addItemListener | Adds a listener for Item-related events. <p> If listener is an ItemListener, then the properties that are populated in Item objects passed to the application's event handlers are those same properties that would normally be populated by the ItemListManager. To populate a specific set of properties for the event handlers, set the appropriate filter (and/or call setExtraCachedProperties) before registering the listener. <p> In order to handle events, an application must enable MPX.
addItemUpdateListener | Listens for updates to this ItemListManager. <p> Similar to addItemListener(), except that events are triggered by explicit operations performed by the client application. For example, calling Folder.refreshItems(), Item.update() or Item.remove() might each trigger update events. <p> MPX is not required to receive item update events.
close | Close this ItemListManager, release all its resources, and sever its ties to its parent FolderListManager t will automatically be reopened will automatically be re-opened when needed.
discard | Discards all relevant cached data. It will be re-fetched from the server the next time the item list is retrieved (even when MPX is enabled).
Equals |
findItem |
getAllCachedProperties | Gets the list of properties that will be pre-fetched and cached for members of this item list. By default, all properties are pre-fetched and cached. If a Filter is applied, the properties described in the Filter will be cached, along with zero or more "extra" properties set by the user. If no filter is applied, all properties are pre-fetched and cached, regardless of the extra properties set by the user.
getCachedPropertiesForFilter | Gets the list of properties that will be pre-fetched and cached for members of this item list based on Filter criteria. By default, all properties are pre-fetched and cached. If a Filter is applied, the properties described in the Filter will be cached, along with zero or more "extra" properties set by the user. If no filter is applied, all properties are pre-fetched and cached, regardless of the extra properties set by the user.
getExtraCachedProperties | Gets the list of "extra" properties that will be pre-fetched and cached for members of this item list. By default, all properties are pre-fetched and cached. If a Filter is applied, the properties described in the Filter will be cached, along with zero or more "extra" properties set by the user. If no filter is applied, all properties are pre-fetched and cached, regardless of the extra properties set by the user.
getFilter | Gets the filter that is applied to the item list. By default, no filter is applied.
getFolderListManager | Gets the FolderListManager that determines which folders will be used to generate items in the item list. The item list tracks changes to the folder list, and adjusts the item list accordingly. For example, if a folder is added to the list after a previous call to getItems()/getItemsArray(), then on the next call to getItems() or getItemsArray(), the new folder is automatically populated, the items in the new folder are filtered, and the entire item list is resorted.
getFullDisplay | Returns the current display state of the list. The '\t' character indicates indents. The '|' character separates column values. Useful for debugging.
getGroupNodeAtLine |
GetHashCode |
getItemAtLine |
getItemGroups | Returns an array of GroupNodes that describes the group membership of all Items managed by the ItemListManager. May return an empty array.
getItemID | Returns the ItemID for an item; if we're managing not-in-view files, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view file object until it's been added to the repository.
getItems | Gets the list of items in the item list. Optimized to do as little work as possible. For example, if only the sort order has changed since the last time the item list was retrieved, then the existing items in the list are resorted only.
getItemsArray | Returns the items in the item list as an array. Optimized to do as little work as possible. For example, if only the sort order has changed since the last time the item list was retrieved, then the existing items in the list are resorted only.
getItemsArrayForFolder |
getItemsForFolder |
getType | Gets the type of item included in the item list.
GetType (inherited from Object) | Gets the Type of the current instance.
getUserVisibleFoldersOnly | Returns true if only Items in user-visible Folders are included, otherwise false. By default all Items are included, even those in Folders that are not user-visible.
getVisibleLines | Returns the number of visible lines in the list, given the current collapsed/expanded state of its nodes.
groupItems |
isGrouped | Returns true if this ItemListManager has grouping criteria applied.
isGroupNodeAtLine |
isRefreshRequired | Returns true if a refresh() operation might have resulted in the item list being updated; returns false if and only if it is known that the item list had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() returns true.
MemberwiseClone |
refresh | Updates the list of Items to reflect recent changes made on the server. Existing Item objects are modified in place whenever possible. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
removeItemListener | Removes a listener for Item-related events.
removeItemUpdateListener | Removes a listener for item update events.
selectByLabel | Gets the subset of items in the item list to which the given label has been applied.
selectByQuery | Gets the subset of items in the item list that match the given query.
setExtraCachedProperties |
setFilter | Sets the filter to be applied to the item list. Only items that are accepted by the filter will be included in the item list. By default, no filter is applied.
setUserVisibleFoldersOnly |
sortItems |
ToString |

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager Constructor

public ItemListManager(
Type type,
FolderListManager folders
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager Methods

The methods of the ItemListManager class are listed below. For a complete list of ItemListManager class members, see the ItemListManager Members topic.

Public Instance Methods

addItemListener | Adds a listener for Item-related events. <p> If listener is an ItemListener, then the properties that are populated in Item objects passed to the application's event handlers are those same properties that would normally be populated by the ItemListManager. To populate a specific set of properties for the event handlers, set the appropriate filter (and/or call setExtraCachedProperties) before registering the listener. <p> In order to handle events, an application must enable MPX.
addItemUpdateListener | Listens for updates to this ItemListManager. <p> Similar to addItemListener(), except that events are triggered by explicit operations performed by the client application. For example, calling Folder.refreshItems(), Item.update() or Item.remove() might each trigger update events. <p> MPX is not required to receive item update events.
close | Close this ItemListManager, release all its resources, and sever its ties to its parent FolderListManager t will automatically be reopened will automatically be re-opened when needed.
discard | Discards all relevant cached data. It will be re-fetched from the server the next time the item list is retrieved (even when MPX is enabled).
Equals |
findItem |
getAllCachedProperties | Gets the list of properties that will be pre-fetched and cached for members of this item list. By default, all properties are pre-fetched and cached. If a Filter is applied, the properties described in the Filter will be cached, along with zero or more "extra" properties set by the user. If no filter is applied, all properties are pre-fetched and cached, regardless of the extra properties set by the user.
getCachedPropertiesForFilter | Gets the list of properties that will be pre-fetched and cached for members of this item list based on Filter criteria. By default, all properties are pre-fetched and cached. If a Filter is applied, the properties described in the Filter will be cached, along with zero or more "extra" properties set by the user. If no filter is applied, all properties are pre-fetched and cached, regardless of the extra properties set by the user.
getExtraCachedProperties | Gets the list of "extra" properties that will be pre-fetched and cached for members of this item list. By default, all properties are pre-fetched and cached. If a Filter is applied, the properties described in the Filter will be cached, along with zero or more "extra" properties set by the user. If no filter is applied, all properties are pre-fetched and cached, regardless of the extra properties set by the user.
getFilter | Gets the filter that is applied to the item list. By default, no filter is applied.
getFolderListManager | Gets the FolderListManager that determines which folders will be used to generate items in the item list. The item list tracks changes to the folder list, and adjusts the item list accordingly. For example, if a folder is added to the list after a previous call to getItems()/getItemsArray(), then on the next call to getItems() or getItemsArray(), the new folder is automatically populated, the items in the new folder are filtered, and the entire item list is resorted.
getFullDisplay | Returns the current display state of the list. The '\t' character indicates indents. The '|' character separates column values. Useful for debugging.
getGroupNodeAtLine |
GetHashCode |
getItemAtLine |
getItemGroups | Returns an array of GroupNodes that describes the group membership of all Items managed by the ItemListManager. May return an empty array.
getItemID | Returns the ItemID for an item; if we're managing not-in-view files, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view file object until it's been added to the repository.
getItems | Gets the list of items in the item list. Optimized to do as little work as possible. For example, if only the sort order has changed since the last time the item list was retrieved, then the existing items in the list are resorted only.
getItemsArray | Returns the items in the item list as an array. Optimized to do as little work as possible. For example, if only the sort order has changed since the last time the item list was retrieved, then the existing items in the list are resorted only.
getItemsArrayForFolder |
getItemsForFolder |
getType | Gets the type of item included in the item list.
GetType (inherited from Object) | Gets the Type of the current instance.
getUserVisibleFoldersOnly | Returns true if only Items in user-visible Folders are included, otherwise false. By default all Items are included, even those in Folders that are not user-visible.
getVisibleLines | Returns the number of visible lines in the list, given the current collapsed/expanded state of its nodes.
groupItems |
isGrouped | Returns true if this ItemListManager has grouping criteria applied.
isGroupNodeAtLine |
isRefreshRequired | Returns true if a refresh() operation might have resulted in the item list being updated; returns false if and only if it is known that the item list had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() returns true.
MemberwiseClone |
refresh | Updates the list of Items to reflect recent changes made on the server. Existing Item objects are modified in place whenever possible. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
removeItemListener | Removes a listener for Item-related events.
removeItemUpdateListener | Removes a listener for item update events.
selectByLabel | Gets the subset of items in the item list to which the given label has been applied.
selectByQuery | Gets the subset of items in the item list that match the given query.
setExtraCachedProperties |
setFilter | Sets the filter to be applied to the item list. Only items that are accepted by the filter will be included in the item list. By default, no filter is applied.
setUserVisibleFoldersOnly |
sortItems |
ToString |

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.addItemListener Method

Adds a listener for Item-related events. <p> If listener is an ItemListener, then the properties that are populated in Item objects passed to the application's event handlers are those same properties that would normally be populated by the ItemListManager. To populate a specific set of properties for the event handlers, set the appropriate filter (and/or call setExtraCachedProperties) before registering the listener. <p> In order to handle events, an application must enable MPX.

public virtual void addItemListener(
IItemListener listener
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.addItemUpdateListener Method

Listens for updates to this ItemListManager. <p> Similar to addItemListener(), except that events are triggered by explicit operations performed by the client application. For example, calling Folder.refreshItems(), Item.update() or Item.remove() might each trigger update events. <p> MPX is not required to receive item update events.

public virtual void addItemUpdateListener(
ItemUpdateListener listener
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.close Method

Close this ItemListManager, release all its resources, and sever its ties to its parent FolderListManager t will automatically be reopened will automatically be re-opened when needed.

public virtual void close();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.discard Method

Discards all relevant cached data. It will be re-fetched from the server the next time the item list is retrieved (even when MPX is enabled).

public virtual void discard();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.Equals Method

public override bool Equals(
Object source
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.findItem Method

public virtual Item findItem(
Int32 itemID
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getAllCachedProperties Method

Gets the list of properties that will be pre-fetched and cached for members of this item list. By default, all properties are pre-fetched and cached. If a Filter is applied, the properties described in the Filter will be cached, along with zero or more "extra" properties set by the user. If no filter is applied, all properties are pre-fetched and cached, regardless of the extra properties set by the user.

public virtual Property[] getAllCachedProperties();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getCachedPropertiesForFilter Method

Gets the list of properties that will be pre-fetched and cached for members of this item list based on Filter criteria. By default, all properties are pre-fetched and cached. If a Filter is applied, the properties described in the Filter will be cached, along with zero or more "extra" properties set by the user. If no filter is applied, all properties are pre-fetched and cached, regardless of the extra properties set by the user.

public virtual Property[] getCachedPropertiesForFilter();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getExtraCachedProperties Method

Gets the list of "extra" properties that will be pre-fetched and cached for members of this item list. By default, all properties are pre-fetched and cached. If a Filter is applied, the properties described in the Filter will be cached, along with zero or more "extra" properties set by the user. If no filter is applied, all properties are pre-fetched and cached, regardless of the extra properties set by the user.

public virtual Property[] getExtraCachedProperties();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getFilter Method

Gets the filter that is applied to the item list. By default, no filter is applied.

public virtual Filter getFilter();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getFolderListManager Method

Gets the FolderListManager that determines which folders will be used to generate items in the item list. The item list tracks changes to the folder list, and adjusts the item list accordingly. For example, if a folder is added to the list after a previous call to getItems()/getItemsArray(), then on the next call to getItems() or getItemsArray(), the new folder is automatically populated, the items in the new folder are filtered, and the entire item list is resorted.

public virtual FolderListManager getFolderListManager();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getFullDisplay Method

Returns the current display state of the list. The '\t' character indicates indents. The '|' character separates column values. Useful for debugging.

public virtual string[] getFullDisplay();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getGroupNodeAtLine Method

public virtual GroupNode getGroupNodeAtLine(
Int32 line
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.GetHashCode Method

public override int GetHashCode();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getItemAtLine Method

public virtual Item getItemAtLine(
Int32 line
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getItemGroups Method

Returns an array of GroupNodes that describes the group membership of all Items managed by the ItemListManager. May return an empty array.

public virtual GroupNode[] getItemGroups();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getItemID Method

Returns the ItemID for an item; if we're managing not-in-view files, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view file object until it's been added to the repository.

public virtual int getItemID(
Item item
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getItems Method

Gets the list of items in the item list. Optimized to do as little work as possible. For example, if only the sort order has changed since the last time the item list was retrieved, then the existing items in the list are resorted only.

public virtual Items getItems();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getItemsArray Method

Returns the items in the item list as an array. Optimized to do as little work as possible. For example, if only the sort order has changed since the last time the item list was retrieved, then the existing items in the list are resorted only.

public virtual Item[] getItemsArray();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getItemsArrayForFolder Method

public virtual Item[] getItemsArrayForFolder(
Folder folder,
Boolean bDescendants
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getItemsForFolder Method

public virtual Items getItemsForFolder(
Folder folder,
Boolean bDescendants
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getType Method

Gets the type of item included in the item list.

public virtual Type getType();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getUserVisibleFoldersOnly Method

Returns true if only Items in user-visible Folders are included, otherwise false. By default all Items are included, even those in Folders that are not user-visible.

public virtual bool getUserVisibleFoldersOnly();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.getVisibleLines Method

Returns the number of visible lines in the list, given the current collapsed/expanded state of its nodes.

public virtual int getVisibleLines();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.groupItems Method

public virtual void groupItems(
Boolean bGroup
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.isGrouped Method

Returns true if this ItemListManager has grouping criteria applied.

public virtual bool isGrouped();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.isGroupNodeAtLine Method

public virtual bool isGroupNodeAtLine(
Int32 line
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.isRefreshRequired Method

Returns true if a refresh() operation might have resulted in the item list being updated; returns false if and only if it is known that the item list had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() returns true.

public virtual bool isRefreshRequired();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.refresh Method

Updates the list of Items to reflect recent changes made on the server. Existing Item objects are modified in place whenever possible. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void refresh();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.removeItemListener Method

Removes a listener for Item-related events.

public virtual void removeItemListener(
IItemListener listener
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.removeItemUpdateListener Method

Removes a listener for item update events.

public virtual void removeItemUpdateListener(
ItemUpdateListener listener
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.selectByLabel Method

Gets the subset of items in the item list to which the given label has been applied.

public virtual Items selectByLabel(
Label label
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.selectByQuery Method

Gets the subset of items in the item list that match the given query.

public virtual Items selectByQuery(
QueryInfo query
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.setExtraCachedProperties Method

public virtual void setExtraCachedProperties(
Property[] properties
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.setFilter Method

Sets the filter to be applied to the item list. Only items that are accepted by the filter will be included in the item list. By default, no filter is applied.

public virtual void setFilter(
Filter filter
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.setUserVisibleFoldersOnly Method

public virtual void setUserVisibleFoldersOnly(
Boolean bUserVisibleFoldersOnly
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.sortItems Method

public virtual void sortItems(
Boolean bSort
);

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListManager.ToString Method

public override string ToString();

See Also

ItemListManager Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemNotFoundException Class

For a list of all members of this type, see ItemNotFoundException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
ServerException
ItemNotFoundException

public class ItemNotFoundException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemNotFoundException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemNotFoundException Members

ItemNotFoundException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |

See Also

ItemNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemNotFoundException Methods

The methods of the ItemNotFoundException class are listed below. For a complete list of ItemNotFoundException class members, see the ItemNotFoundException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |

See Also

ItemNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemNotFoundException.Equals Method

public override bool Equals(
Object source
);

See Also

ItemNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemNotFoundException.GetHashCode Method

public override int GetHashCode();

See Also

ItemNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemNotFoundException.getMessage Method

public override string getMessage();

See Also

ItemNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemNotFoundException.wrap Method

public static ItemNotFoundException wrap(
ItemNotFoundException arg
);

See Also

ItemNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference Class

For a list of all members of this type, see ItemReference Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
ItemReference

public class ItemReference : SimpleTypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemReference Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference Members

ItemReference overview

Public Instance Methods

addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get (inherited from SimpleTypedResource) |
getByteArray (inherited from SimpleTypedResource) |
getChildren | Returns an array of ItemReferences that are direct children of this ItemReferences, or an empty array if there are none.
getCreatedTime | Returns the CreatedTime for this item, only available on server versions 5.2 and higher.
getCreatedUserID | Returns the CreatedUserID of this item, only available on server versions 5.2 and higher.
getDeletedTime | Returns the DeletedTime of this item, only available on server versions 5.2 and higher.
getDeletedUserID | Returns the DeletedUserID of this item, only available on server versions 5.2 and higher.
getDerivedCount | Returns the number of shares directly derived from this item.
getDotNotation | Returns the revision number in dot notation form.
getDouble (inherited from SimpleTypedResource) |
getEndModifiedTime | Returns the EndModifiedTime of this item, only available on server versions 5.2 and higher.
getEnumDisplayName (inherited from SimpleTypedResource) |
getFolderItemID | Returns the Item ID of the referenced Item's parent Folder.
getFolderPath | Returns the folder path of the referenced Item's parent Folder.
GetHashCode |
getID (inherited from SimpleTypedResource) | Return the identifier for the resource object.
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getItemID | Returns the Item's ItemID.
getModifiedTime | Returns the ModifiedTime of this item, only available on server versions 5.2 and higher.
getModifiedUserID | Returns the ModifiedUserID of this item, only available on server versions 5.2 and higher.
getObjectID | Returns the item's object ID.
getOLEDate (inherited from SimpleTypedResource) |
getParent | Returns the parent of this ItemReference, or null if this is the root of the share tree.
getPossibleValues (inherited from SimpleTypedResource) |
getProjectID | Returns the Project ID of the project that contains this reference.
getProjectName | Returns the containing Project's name.
getPropertyNames (inherited from SimpleTypedResource) |
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getViewID | Returns the ViewID for this item.
getViewPath | Returns the View path (in this format: "parent\child\grandchild...").
isDeleted | Returns true if the Item has been deleted.
isRelated | Returns true if this item contains the revision queried by Item.getReferences() in its history.
isViewDeleted | Returns true if the item's View has been deleted.
MemberwiseClone (inherited from CacheRef) |
put (inherited from SimpleTypedResource) |
putByPropertyID (inherited from SimpleTypedResource) |
removeFromIntArray (inherited from TypedResource) |
ToString |

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference Methods

The methods of the ItemReference class are listed below. For a complete list of ItemReference class members, see the ItemReference Members topic.

Public Instance Methods

addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get (inherited from SimpleTypedResource) |
getByteArray (inherited from SimpleTypedResource) |
getChildren | Returns an array of ItemReferences that are direct children of this ItemReferences, or an empty array if there are none.
getCreatedTime | Returns the CreatedTime for this item, only available on server versions 5.2 and higher.
getCreatedUserID | Returns the CreatedUserID of this item, only available on server versions 5.2 and higher.
getDeletedTime | Returns the DeletedTime of this item, only available on server versions 5.2 and higher.
getDeletedUserID | Returns the DeletedUserID of this item, only available on server versions 5.2 and higher.
getDerivedCount | Returns the number of shares directly derived from this item.
getDotNotation | Returns the revision number in dot notation form.
getDouble (inherited from SimpleTypedResource) |
getEndModifiedTime | Returns the EndModifiedTime of this item, only available on server versions 5.2 and higher.
getEnumDisplayName (inherited from SimpleTypedResource) |
getFolderItemID | Returns the Item ID of the referenced Item's parent Folder.
getFolderPath | Returns the folder path of the referenced Item's parent Folder.
GetHashCode |
getID (inherited from SimpleTypedResource) | Return the identifier for the resource object.
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getItemID | Returns the Item's ItemID.
getModifiedTime | Returns the ModifiedTime of this item, only available on server versions 5.2 and higher.
getModifiedUserID | Returns the ModifiedUserID of this item, only available on server versions 5.2 and higher.
getObjectID | Returns the item's object ID.
getOLEDate (inherited from SimpleTypedResource) |
getParent | Returns the parent of this ItemReference, or null if this is the root of the share tree.
getPossibleValues (inherited from SimpleTypedResource) |
getProjectID | Returns the Project ID of the project that contains this reference.
getProjectName | Returns the containing Project's name.
getPropertyNames (inherited from SimpleTypedResource) |
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getViewID | Returns the ViewID for this item.
getViewPath | Returns the View path (in this format: "parent\child\grandchild...").
isDeleted | Returns true if the Item has been deleted.
isRelated | Returns true if this item contains the revision queried by Item.getReferences() in its history.
isViewDeleted | Returns true if the item's View has been deleted.
MemberwiseClone (inherited from CacheRef) |
put (inherited from SimpleTypedResource) |
putByPropertyID (inherited from SimpleTypedResource) |
removeFromIntArray (inherited from TypedResource) |
ToString |

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.Equals Method

public override bool Equals(
Object source
);

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getChildren Method

Returns an array of ItemReferences that are direct children of this ItemReferences, or an empty array if there are none.

public virtual ItemReference[] getChildren();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getCreatedTime Method

Returns the CreatedTime for this item, only available on server versions 5.2 and higher.

public virtual OLEDate getCreatedTime();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getCreatedUserID Method

Returns the CreatedUserID of this item, only available on server versions 5.2 and higher.

public virtual int getCreatedUserID();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getDeletedTime Method

Returns the DeletedTime of this item, only available on server versions 5.2 and higher.

public virtual OLEDate getDeletedTime();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getDeletedUserID Method

Returns the DeletedUserID of this item, only available on server versions 5.2 and higher.

public virtual int getDeletedUserID();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getDerivedCount Method

Returns the number of shares directly derived from this item.

public virtual int getDerivedCount();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getDotNotation Method

Returns the revision number in dot notation form.

public virtual string getDotNotation();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getEndModifiedTime Method

Returns the EndModifiedTime of this item, only available on server versions 5.2 and higher.

public virtual OLEDate getEndModifiedTime();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getFolderItemID Method

Returns the Item ID of the referenced Item's parent Folder.

public virtual int getFolderItemID();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getFolderPath Method

Returns the folder path of the referenced Item's parent Folder.

public virtual string getFolderPath();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.GetHashCode Method

public override int GetHashCode();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getItemID Method

Returns the Item's ItemID.

public virtual int getItemID();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getModifiedTime Method

Returns the ModifiedTime of this item, only available on server versions 5.2 and higher.

public virtual OLEDate getModifiedTime();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getModifiedUserID Method

Returns the ModifiedUserID of this item, only available on server versions 5.2 and higher.

public virtual int getModifiedUserID();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getObjectID Method

Returns the item's object ID.

public virtual int getObjectID();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getParent Method

Returns the parent of this ItemReference, or null if this is the root of the share tree.

public virtual ItemReference getParent();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getProjectID Method

Returns the Project ID of the project that contains this reference.

public virtual int getProjectID();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getProjectName Method

Returns the containing Project's name.

public virtual string getProjectName();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getViewID Method

Returns the ViewID for this item.

public virtual int getViewID();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.getViewPath Method

Returns the View path (in this format: "parent\child\grandchild...").

public virtual string getViewPath();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.isDeleted Method

Returns true if the Item has been deleted.

public virtual bool isDeleted();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.isRelated Method

Returns true if this item contains the revision queried by Item.getReferences() in its history.

public virtual bool isRelated();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.isViewDeleted Method

Returns true if the item's View has been deleted.

public virtual bool isViewDeleted();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemReference.ToString Method

public override string ToString();

See Also

ItemReference Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision Class

For a list of all members of this type, see ItemRevision Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
ItemRevision

public class ItemRevision : SimpleTypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemRevision Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision Members

ItemRevision overview

Public Instance Methods

addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get (inherited from SimpleTypedResource) |
getBranchFlag | Returns the branch flag of this item revision.
getBranchState | Returns the branch state of this item revision.
getByteArray (inherited from SimpleTypedResource) |
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
GetHashCode |
getID (inherited from SimpleTypedResource) | Return the identifier for the resource object.
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLocationItemID | Returns the location item ID of this item revision.
getObjectID | Returns the object ID for this item revision.
getObjectTime | Returns the time of this item revision.
getOLEDate (inherited from SimpleTypedResource) |
getParentItemID | Returns the Item ID of the parent for this item revision.
getPossibleValues (inherited from SimpleTypedResource) |
getProjectID | Returns the Project ID of the project that contains this item revision.
getPropertyNames (inherited from SimpleTypedResource) |
getString (inherited from SimpleTypedResource) |
getTime | Returns the time of this item revision.
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getUserID | Returns the created User ID for this item revision.
getViewID | Returns the View ID for this item revision.
MemberwiseClone (inherited from CacheRef) |
put (inherited from SimpleTypedResource) |
putByPropertyID (inherited from SimpleTypedResource) |
removeFromIntArray (inherited from TypedResource) |
ToString |

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision Methods

The methods of the ItemRevision class are listed below. For a complete list of ItemRevision class members, see the ItemRevision Members topic.

Public Instance Methods

addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get (inherited from SimpleTypedResource) |
getBranchFlag | Returns the branch flag of this item revision.
getBranchState | Returns the branch state of this item revision.
getByteArray (inherited from SimpleTypedResource) |
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
GetHashCode |
getID (inherited from SimpleTypedResource) | Return the identifier for the resource object.
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLocationItemID | Returns the location item ID of this item revision.
getObjectID | Returns the object ID for this item revision.
getObjectTime | Returns the time of this item revision.
getOLEDate (inherited from SimpleTypedResource) |
getParentItemID | Returns the Item ID of the parent for this item revision.
getPossibleValues (inherited from SimpleTypedResource) |
getProjectID | Returns the Project ID of the project that contains this item revision.
getPropertyNames (inherited from SimpleTypedResource) |
getString (inherited from SimpleTypedResource) |
getTime | Returns the time of this item revision.
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getUserID | Returns the created User ID for this item revision.
getViewID | Returns the View ID for this item revision.
MemberwiseClone (inherited from CacheRef) |
put (inherited from SimpleTypedResource) |
putByPropertyID (inherited from SimpleTypedResource) |
removeFromIntArray (inherited from TypedResource) |
ToString |

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.Equals Method

public override bool Equals(
Object source
);

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.getBranchFlag Method

Returns the branch flag of this item revision.

public virtual int getBranchFlag();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.getBranchState Method

Returns the branch state of this item revision.

public virtual int getBranchState();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.GetHashCode Method

public override int GetHashCode();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.getLocationItemID Method

Returns the location item ID of this item revision.

public virtual int getLocationItemID();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.getObjectID Method

Returns the object ID for this item revision.

public virtual int getObjectID();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.getObjectTime Method

Returns the time of this item revision.

public virtual OLEDate getObjectTime();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.getParentItemID Method

Returns the Item ID of the parent for this item revision.

public virtual int getParentItemID();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.getProjectID Method

Returns the Project ID of the project that contains this item revision.

public virtual int getProjectID();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.getTime Method

Returns the time of this item revision.

public virtual OLEDate getTime();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.getUserID Method

Returns the created User ID for this item revision.

public virtual int getUserID();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.getViewID Method

Returns the View ID for this item revision.

public virtual int getViewID();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemRevision.ToString Method

public override string ToString();

See Also

ItemRevision Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Items Interface

For a list of all members of this type, see Items Members.

public interface Items

Types that implement Items

Type | Description
ItemsAdapter |
ItemList |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Items Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Items Members

Items overview

Public Instance Methods

getAt |
size | Returns the size of the virtual array.

See Also

Items Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Items Methods

The methods of the Items interface are listed below. For a complete list of Items interface members, see the Items Members topic.

Public Instance Methods

getAt |
size | Returns the size of the virtual array.

See Also

Items Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Items.getAt Method

Item getAt(
Int32 index
);

See Also

Items Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Items.size Method

Returns the size of the virtual array.

int size();

See Also

Items Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateAdapter Class

For a list of all members of this type, see ItemUpdateAdapter Members.

System.Object
ItemUpdateAdapter

public class ItemUpdateAdapter : ItemUpdateListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemUpdateAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateAdapter Members

ItemUpdateAdapter overview

Public Instance Constructors

ItemUpdateAdapter Constructor Initializes a new instance of the ItemUpdateAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
itemAdded |
itemChanged |
itemMoved |
itemRemoved |
MemberwiseClone |
ToString |

See Also

ItemUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateAdapter Constructor

Initializes a new instance of the ItemUpdateAdapter class.

public ItemUpdateAdapter();

See Also

ItemUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateAdapter Methods

The methods of the ItemUpdateAdapter class are listed below. For a complete list of ItemUpdateAdapter class members, see the ItemUpdateAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
itemAdded |
itemChanged |
itemMoved |
itemRemoved |
MemberwiseClone |
ToString |

See Also

ItemUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateAdapter.itemAdded Method

public override void itemAdded(
ItemUpdateEvent e
);

Implements

ItemUpdateListener.itemAdded

See Also

ItemUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateAdapter.itemChanged Method

public override void itemChanged(
ItemUpdateEvent e
);

Implements

ItemUpdateListener.itemChanged

See Also

ItemUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateAdapter.itemMoved Method

public override void itemMoved(
ItemUpdateEvent e
);

Implements

ItemUpdateListener.itemMoved

See Also

ItemUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateAdapter.itemRemoved Method

public override void itemRemoved(
ItemUpdateEvent e
);

Implements

ItemUpdateListener.itemRemoved

See Also

ItemUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateAdapter.ToString Method

public override string ToString();

See Also

ItemUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateEvent Class

For a list of all members of this type, see ItemUpdateEvent Members.

System.Object
EventObject
ItemUpdateEvent

public class ItemUpdateEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemUpdateEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateEvent Members

ItemUpdateEvent overview

Public Instance Constructors

ItemUpdateEvent Constructor

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
getNewItem | Gets the Item in its new state. <p> Used in itemAdded(), itemMoved() and itemChanged() events. In itemRemoved() events, getNewItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Items associated with the original Folder object, it must do so by explicitly calling Folder.refreshItems().
GetObjectData (inherited from java.util.EventObject) |
getOldItem | Gets the Item in its old state. <p> Used in itemChanged(), itemMoved() and itemRemoved() events. In itemAdded() events, getOldItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ItemUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateEvent Constructor

public ItemUpdateEvent(
Item oldItem,
Item newItem
);

See Also

ItemUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateEvent Methods

The methods of the ItemUpdateEvent class are listed below. For a complete list of ItemUpdateEvent class members, see the ItemUpdateEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
getNewItem | Gets the Item in its new state. <p> Used in itemAdded(), itemMoved() and itemChanged() events. In itemRemoved() events, getNewItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Items associated with the original Folder object, it must do so by explicitly calling Folder.refreshItems().
GetObjectData (inherited from java.util.EventObject) |
getOldItem | Gets the Item in its old state. <p> Used in itemChanged(), itemMoved() and itemRemoved() events. In itemAdded() events, getOldItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ItemUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateEvent.Equals Method

public override bool Equals(
Object source
);

See Also

ItemUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateEvent.GetHashCode Method

public override int GetHashCode();

See Also

ItemUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateEvent.getNewItem Method

Gets the Item in its new state. <p> Used in itemAdded(), itemMoved() and itemChanged() events. In itemRemoved() events, getNewItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy. <p> If an application wants to refresh the Items associated with the original Folder object, it must do so by explicitly calling Folder.refreshItems().

public virtual Item getNewItem();

See Also

ItemUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateEvent.getOldItem Method

Gets the Item in its old state. <p> Used in itemChanged(), itemMoved() and itemRemoved() events. In itemAdded() events, getOldItem() returns null. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy.

public virtual Item getOldItem();

See Also

ItemUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateEvent.getSource Method

public override object getSource();

See Also

ItemUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateEvent.ToString Method

public override string ToString();

See Also

ItemUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateListener Interface

For a list of all members of this type, see ItemUpdateListener Members.

public interface ItemUpdateListener : EventListener

Types that implement ItemUpdateListener

Type | Description
ItemUpdateAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemUpdateListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateListener Members

ItemUpdateListener overview

Public Instance Methods

itemAdded | Invoked when an Item is added to a view. <p> An itemAdded event is triggered whenever an Item with a new ItemID appears in the view. This might be because a new item was created; because an item was moved or shared in from another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no new items are created. In this case, an itemMoved event is triggered instead of an itemAdded event. <p> If the logged-in user does not have access rights to see the item in its new context, then no event is triggered. <p> For itemAdded events, ItemUpdateEvent.getNewItem() returns the added item in its new context. ItemUpdateEvent.getOldItem() returns null.
itemChanged | Invoked when the properties of an Item have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as CreatedUserID or ModifiedTime). <p> For itemChanged events, ItemUpdateEvent.getOldItem() returns a Item object representing the item in its old state (that is, before its properties were changed). ItemUpdateEvent.getNewItem() returns the item in its new state (after its properties were changed).
itemMoved | Invoked when an Item is moved within a view. <p> An itemMoved event is triggered whenever an Item is moved from one folder to another folder within the same view. In this case, no items with new ItemIDs are added to the view, and no items are removed. Thus, when an itemMoved event is triggered, corresponding itemAdded and itemRemoved events will not be triggered. <p> If an item exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the item does not exist. If the item is then moved to a new parent item in the same view such that it is now accessible, then, from that user's point of view, the item has been added, not moved. Thus, in that case, an itemAdded event will be triggered instead of an itemMoved event. <p> Similarly, if an item is moved in such a way that it is no longer visible to the current user, an itemRemoved event will be triggered instead of an itemMoved event. <p> For itemMoved events, ItemUpdateEvent.getOldItem() returns a Item object representing the item before it was moved (that is, attached to the old parent folder). ItemUpdateEvent.getNewItem() returns a Item object representing the item after it was moved (attached to the new parent).
itemRemoved | Invoked when an Item is removed from a view. <p> An itemRemoved event is triggered whenever an Item disappears from the view. This might be because an item was deleted; because an item was moved to another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no Item items are removed. In this case, an itemMoved event is triggered instead of an itemRemoved event. <p> For itemRemoved events, ItemUpdateEvent.getOldItem() returns the removed item in its old context (that is, prior to being removed). ItemUpdateEvent.getNewItem() returns null.

See Also

ItemUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateListener Methods

The methods of the ItemUpdateListener interface are listed below. For a complete list of ItemUpdateListener interface members, see the ItemUpdateListener Members topic.

Public Instance Methods

itemAdded | Invoked when an Item is added to a view. <p> An itemAdded event is triggered whenever an Item with a new ItemID appears in the view. This might be because a new item was created; because an item was moved or shared in from another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no new items are created. In this case, an itemMoved event is triggered instead of an itemAdded event. <p> If the logged-in user does not have access rights to see the item in its new context, then no event is triggered. <p> For itemAdded events, ItemUpdateEvent.getNewItem() returns the added item in its new context. ItemUpdateEvent.getOldItem() returns null.
itemChanged | Invoked when the properties of an Item have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as CreatedUserID or ModifiedTime). <p> For itemChanged events, ItemUpdateEvent.getOldItem() returns a Item object representing the item in its old state (that is, before its properties were changed). ItemUpdateEvent.getNewItem() returns the item in its new state (after its properties were changed).
itemMoved | Invoked when an Item is moved within a view. <p> An itemMoved event is triggered whenever an Item is moved from one folder to another folder within the same view. In this case, no items with new ItemIDs are added to the view, and no items are removed. Thus, when an itemMoved event is triggered, corresponding itemAdded and itemRemoved events will not be triggered. <p> If an item exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the item does not exist. If the item is then moved to a new parent item in the same view such that it is now accessible, then, from that user's point of view, the item has been added, not moved. Thus, in that case, an itemAdded event will be triggered instead of an itemMoved event. <p> Similarly, if an item is moved in such a way that it is no longer visible to the current user, an itemRemoved event will be triggered instead of an itemMoved event. <p> For itemMoved events, ItemUpdateEvent.getOldItem() returns a Item object representing the item before it was moved (that is, attached to the old parent folder). ItemUpdateEvent.getNewItem() returns a Item object representing the item after it was moved (attached to the new parent).
itemRemoved | Invoked when an Item is removed from a view. <p> An itemRemoved event is triggered whenever an Item disappears from the view. This might be because an item was deleted; because an item was moved to another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no Item items are removed. In this case, an itemMoved event is triggered instead of an itemRemoved event. <p> For itemRemoved events, ItemUpdateEvent.getOldItem() returns the removed item in its old context (that is, prior to being removed). ItemUpdateEvent.getNewItem() returns null.

See Also

ItemUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateListener.itemAdded Method

Invoked when an Item is added to a view. <p> An itemAdded event is triggered whenever an Item with a new ItemID appears in the view. This might be because a new item was created; because an item was moved or shared in from another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no new items are created. In this case, an itemMoved event is triggered instead of an itemAdded event. <p> If the logged-in user does not have access rights to see the item in its new context, then no event is triggered. <p> For itemAdded events, ItemUpdateEvent.getNewItem() returns the added item in its new context. ItemUpdateEvent.getOldItem() returns null.

void itemAdded(
ItemUpdateEvent e
);

See Also

ItemUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateListener.itemChanged Method

Invoked when the properties of an Item have changed. <p> The changed properties may include Item-level properties (such as ConfigurationTime or BranchOnChange) or Object-level properties that are shared across references (such as CreatedUserID or ModifiedTime). <p> For itemChanged events, ItemUpdateEvent.getOldItem() returns a Item object representing the item in its old state (that is, before its properties were changed). ItemUpdateEvent.getNewItem() returns the item in its new state (after its properties were changed).

void itemChanged(
ItemUpdateEvent e
);

See Also

ItemUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateListener.itemMoved Method

Invoked when an Item is moved within a view. <p> An itemMoved event is triggered whenever an Item is moved from one folder to another folder within the same view. In this case, no items with new ItemIDs are added to the view, and no items are removed. Thus, when an itemMoved event is triggered, corresponding itemAdded and itemRemoved events will not be triggered. <p> If an item exists in a security context where it is not accessible to the current user, then, from that user's point of reference, the item does not exist. If the item is then moved to a new parent item in the same view such that it is now accessible, then, from that user's point of view, the item has been added, not moved. Thus, in that case, an itemAdded event will be triggered instead of an itemMoved event. <p> Similarly, if an item is moved in such a way that it is no longer visible to the current user, an itemRemoved event will be triggered instead of an itemMoved event. <p> For itemMoved events, ItemUpdateEvent.getOldItem() returns a Item object representing the item before it was moved (that is, attached to the old parent folder). ItemUpdateEvent.getNewItem() returns a Item object representing the item after it was moved (attached to the new parent).

void itemMoved(
ItemUpdateEvent e
);

See Also

ItemUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemUpdateListener.itemRemoved Method

Invoked when an Item is removed from a view. <p> An itemRemoved event is triggered whenever an Item disappears from the view. This might be because an item was deleted; because an item was moved to another view; etc. <p> If an item is moved from one folder to another folder within the same view, then no Item items are removed. In this case, an itemMoved event is triggered instead of an itemRemoved event. <p> For itemRemoved events, ItemUpdateEvent.getOldItem() returns the removed item in its old context (that is, prior to being removed). ItemUpdateEvent.getNewItem() returns null.

void itemRemoved(
ItemUpdateEvent e
);

See Also

ItemUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Keyword Interface

For a list of all members of this type, see Keyword Members.

public interface Keyword

Types that implement Keyword

Type | Description
KeywordAdapter |
HistoryKeyword |
LogKeyword |
NoKeywords |
SimpleKeyword |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Keyword Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Keyword Members

Keyword overview

Public Instance Methods

expand |
getName | Return the keyword name.
getValue | Return the keyword value.
matches |
multiLine | Returns true if this keyword spans multiple lines. This is only true for the StarTeam <code>$Log$</code> keyword.
stopExpanding | Return true if upon encountering this keyword in a file that no further keyword expansion will occur. This is true for the StarTeam keyword <code>$NoKeywords$</code>.
toXMLString | Returns an XML representation of the keyword.

See Also

Keyword Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Keyword Methods

The methods of the Keyword interface are listed below. For a complete list of Keyword interface members, see the Keyword Members topic.

Public Instance Methods

expand |
getName | Return the keyword name.
getValue | Return the keyword value.
matches |
multiLine | Returns true if this keyword spans multiple lines. This is only true for the StarTeam <code>$Log$</code> keyword.
stopExpanding | Return true if upon encountering this keyword in a file that no further keyword expansion will occur. This is true for the StarTeam keyword <code>$NoKeywords$</code>.
toXMLString | Returns an XML representation of the keyword.

See Also

Keyword Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Keyword.expand Method

string expand(
String linePrefix,
String eol,
Boolean expand
);

See Also

Keyword Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Keyword.getName Method

Return the keyword name.

string getName();

See Also

Keyword Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Keyword.getValue Method

Return the keyword value.

string getValue();

See Also

Keyword Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Keyword.matches Method

bool matches(
String line,
Int32 start,
Int32[] endPos
);

See Also

Keyword Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Keyword.multiLine Method

Returns true if this keyword spans multiple lines. This is only true for the StarTeam <code>$Log$</code> keyword.

bool multiLine();

See Also

Keyword Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Keyword.stopExpanding Method

Return true if upon encountering this keyword in a file that no further keyword expansion will occur. This is true for the StarTeam keyword <code>$NoKeywords$</code>.

bool stopExpanding();

See Also

Keyword Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Keyword.toXMLString Method

Returns an XML representation of the keyword.

string toXMLString();

See Also

Keyword Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader Class

For a list of all members of this type, see KeywordReader Members.

System.Object
Reader
LineProcessor
KeywordReader

public class KeywordReader : LineProcessor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

KeywordReader Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader Members

KeywordReader overview

Public Static Methods

wrap

Public Instance Constructors

KeywordReader Overloaded. Initializes a new instance of the KeywordReader class.

Public Instance Fields

lock (inherited from java.io.Reader)

Public Instance Methods

close (inherited from LineProcessor) |
endofInput |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
mark (inherited from java.io.Reader) |
markSupported (inherited from java.io.Reader) |
MemberwiseClone (inherited from LineProcessor) |
processLine |
read (inherited from LineProcessor) | Overloaded.
read (inherited from java.io.Reader) | Overloaded.
ready (inherited from java.io.Reader) |
reset (inherited from java.io.Reader) |
setEncoding |
skip (inherited from java.io.Reader) |
ToString (inherited from LineProcessor) |
unwrap (inherited from LineProcessor) |

See Also

KeywordReader Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader Constructor

Overload List

public KeywordReader(LineReader,Keyword[],Boolean);

public KeywordReader(LineReader,Keyword[],Boolean,String);

See Also

KeywordReader Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader Constructor (LineReader, Keyword[], Boolean)

public KeywordReader(
LineReader source,
Keyword[] keywords,
Boolean expand
);

See Also

KeywordReader Class | com.starbase.starteam Namespace | KeywordReader Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader Constructor (LineReader, Keyword[], Boolean, String)

public KeywordReader(
LineReader source,
Keyword[] keywords,
Boolean expand,
String sEncoding
);

See Also

KeywordReader Class | com.starbase.starteam Namespace | KeywordReader Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader Methods

The methods of the KeywordReader class are listed below. For a complete list of KeywordReader class members, see the KeywordReader Members topic.

Public Static Methods

wrap

Public Instance Methods

close (inherited from LineProcessor) |
endofInput |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
mark (inherited from java.io.Reader) |
markSupported (inherited from java.io.Reader) |
MemberwiseClone (inherited from LineProcessor) |
processLine |
read (inherited from LineProcessor) | Overloaded.
read (inherited from java.io.Reader) | Overloaded.
ready (inherited from java.io.Reader) |
reset (inherited from java.io.Reader) |
setEncoding |
skip (inherited from java.io.Reader) |
ToString (inherited from LineProcessor) |
unwrap (inherited from LineProcessor) |

See Also

KeywordReader Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader.endofInput Method

public override Reader endofInput();

See Also

KeywordReader Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader.Equals Method

public override bool Equals(
Object source
);

See Also

KeywordReader Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader.GetHashCode Method

public override int GetHashCode();

See Also

KeywordReader Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader.processLine Method

public override Reader processLine(
String line,
Int32 eol
);

See Also

KeywordReader Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader.setEncoding Method

public virtual void setEncoding(
String sEncoding
);

See Also

KeywordReader Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


KeywordReader.wrap Method

public static KeywordReader wrap(
KeywordReader arg
);

See Also

KeywordReader Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label Class

For a list of all members of this type, see Label Members.

System.Object
CacheRef
Label

public class Label : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Label Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label Members

Label overview

Public Static Fields

NEXT_BUILD_ID
SCOPE_ITEM_AND_CONTENTS
SCOPE_ITEM_ONLY
SCOPE_ITEM_TREE

Public Instance Constructors

Label Overloaded. Initializes a new instance of the Label class.

Public Instance Methods

attachItem | Overloaded.
attachToFolder |
attachToItem | Associate a new item with this label. To attach a label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.
attachToItems |
Clone (inherited from CacheRef) |
copy | Creates a copy of this Label object. Useful to applications that want to save a snapshot of the label in a given state, for example, before calling View.refreshLabels().
detachFromFolder |
detachFromItems |
detachItem | Removes the label from the specified item.
Equals |
getDescription | Returns the label's description.
GetHashCode |
getID | Returns this label's unique integer identifier.
getLabeledItemIDs |
getName | Return's the label's name. Label names must be unique within a view.
getOwningProjectID | Returns the ID of the project that owns the view that owns this label.
getOwningViewID | Returns the ID of the view that owns this label. This may be different that the value returned by getView() since it is possible to query for labels in other view.
getRevisionTime | Returns the label's revision time. This applies only to revision labels. The time specifies which revision of an item the label is attached to.
getTime | Returns the label's primary rollback time. This is only meaningful for view labels as opposed to revision labels.
GetType (inherited from Object) | Gets the Type of the current instance.
getView | Returns this label's View context. This is really the view context in which operations on the label occur. It is possible to query a view for labels from a different view. In that case the value of getView() and getOwningViewID() may differ.
isBuildLabel | Returns true if the label as being a StarTeam "Build" label. Change Requests that have an "AddressedIn" field value of next build will have this label assigned to that field when the label is created.
isDeleted | Returns true if this label has been deleted.
isEqualTo | Compares two Label objects.
isLocked | Return true if the label is locked or frozen. The item revision to which a locked label applies can not be modified.
isModified | Returns true if this label has been modified but not yet saved.
isNew | Returns true if the label has not been created on the server (using update())
isRevisionLabel | Returns true if the label is a revision label. By default a revision label applies to no items in a view whereas a view label, when created, applies to all items in the view.
isViewLabel | Returns true if the label is a view label. A view label applies to all items in the view.
MemberwiseClone (inherited from CacheRef) |
moveItem | Overloaded.
remove | Removes (deletes) this label from the view. It will still appear in the list of labels returned from the view but it will be marked as deleted.
setDescription |
setLocked |
setName |
setTime | Sets the label's primary rollback time. When a view label is first created it specifies a view configuration as-of a specified time. This method sets that time.
toDebugString | Returns a string containing various properties of this label.
ToString |
update | Stores all changed to a new or modified label to the StarTeam repository. You can only change the name, description and lock/frozen state after the label has need created. If those properties have not been changed then this method will immediately return.

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label Constructor

NOTE: This constructor is now obsolete.

Overload List

Obsolete.

public Label(View,String,String);

Obsolete.

public Label(View,String,String,Label);

Obsolete.

public Label(View,String,String,OLEDate,Boolean);

Obsolete.

public Label(View,String,String,Boolean);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label Constructor (View, String, String, OLEDate, Boolean)

NOTE: This constructor is now obsolete.

public Label(
View view,
String name,
String description,
OLEDate time,
Boolean isBuildLabel
);

See Also

Label Class | com.starbase.starteam Namespace | Label Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label Constructor (View, String, String, Boolean)

NOTE: This constructor is now obsolete.

public Label(
View view,
String name,
String description,
Boolean isBuildLabel
);

See Also

Label Class | com.starbase.starteam Namespace | Label Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label Constructor (View, String, String)

NOTE: This constructor is now obsolete.

public Label(
View view,
String name,
String description
);

See Also

Label Class | com.starbase.starteam Namespace | Label Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label Constructor (View, String, String, Label)

NOTE: This constructor is now obsolete.

public Label(
View view,
String name,
String description,
Label cloneFrom
);

See Also

Label Class | com.starbase.starteam Namespace | Label Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label Fields

The fields of the Label class are listed below. For a complete list of Label class members, see the Label Members topic.

Public Static Fields

NEXT_BUILD_ID
SCOPE_ITEM_AND_CONTENTS
SCOPE_ITEM_ONLY
SCOPE_ITEM_TREE

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.NEXT_BUILD_ID Field

public const Int32 NEXT_BUILD_ID = -2;

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.SCOPE_ITEM_AND_CONTENTS Field

public const Int32 SCOPE_ITEM_AND_CONTENTS = 1;

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.SCOPE_ITEM_ONLY Field

public const Int32 SCOPE_ITEM_ONLY = 0;

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.SCOPE_ITEM_TREE Field

public const Int32 SCOPE_ITEM_TREE = 2;

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label Methods

The methods of the Label class are listed below. For a complete list of Label class members, see the Label Members topic.

Public Instance Methods

attachItem | Overloaded.
attachToFolder |
attachToItem | Associate a new item with this label. To attach a label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.
attachToItems |
Clone (inherited from CacheRef) |
copy | Creates a copy of this Label object. Useful to applications that want to save a snapshot of the label in a given state, for example, before calling View.refreshLabels().
detachFromFolder |
detachFromItems |
detachItem | Removes the label from the specified item.
Equals |
getDescription | Returns the label's description.
GetHashCode |
getID | Returns this label's unique integer identifier.
getLabeledItemIDs |
getName | Return's the label's name. Label names must be unique within a view.
getOwningProjectID | Returns the ID of the project that owns the view that owns this label.
getOwningViewID | Returns the ID of the view that owns this label. This may be different that the value returned by getView() since it is possible to query for labels in other view.
getRevisionTime | Returns the label's revision time. This applies only to revision labels. The time specifies which revision of an item the label is attached to.
getTime | Returns the label's primary rollback time. This is only meaningful for view labels as opposed to revision labels.
GetType (inherited from Object) | Gets the Type of the current instance.
getView | Returns this label's View context. This is really the view context in which operations on the label occur. It is possible to query a view for labels from a different view. In that case the value of getView() and getOwningViewID() may differ.
isBuildLabel | Returns true if the label as being a StarTeam "Build" label. Change Requests that have an "AddressedIn" field value of next build will have this label assigned to that field when the label is created.
isDeleted | Returns true if this label has been deleted.
isEqualTo | Compares two Label objects.
isLocked | Return true if the label is locked or frozen. The item revision to which a locked label applies can not be modified.
isModified | Returns true if this label has been modified but not yet saved.
isNew | Returns true if the label has not been created on the server (using update())
isRevisionLabel | Returns true if the label is a revision label. By default a revision label applies to no items in a view whereas a view label, when created, applies to all items in the view.
isViewLabel | Returns true if the label is a view label. A view label applies to all items in the view.
MemberwiseClone (inherited from CacheRef) |
moveItem | Overloaded.
remove | Removes (deletes) this label from the view. It will still appear in the list of labels returned from the view but it will be marked as deleted.
setDescription |
setLocked |
setName |
setTime | Sets the label's primary rollback time. When a view label is first created it specifies a view configuration as-of a specified time. This method sets that time.
toDebugString | Returns a string containing various properties of this label.
ToString |
update | Stores all changed to a new or modified label to the StarTeam repository. You can only change the name, description and lock/frozen state after the label has need created. If those properties have not been changed then this method will immediately return.

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


attachItem Method

Borland StarTeam SDK for .NET

Label.attachItem Method

NOTE: This method is now obsolete.

Overload List

Obsolete.

public virtual void attachItem(Item,Boolean);

Obsolete.

public virtual void attachItem(Item,Int32,OLEDate,Boolean);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.attachItem Method (Item, Boolean)

NOTE: This method is now obsolete.

public virtual void attachItem(
Item item,
Boolean recurse
);

See Also

Label Class | com.starbase.starteam Namespace | Label.attachItem Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.attachItem Method (Item, Int32, OLEDate, Boolean)

NOTE: This method is now obsolete.

public virtual void attachItem(
Item item,
Int32 objectID,
OLEDate revisionTime,
Boolean recurse
);

See Also

Label Class | com.starbase.starteam Namespace | Label.attachItem Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.attachToFolder Method

public virtual void attachToFolder(
Folder folder,
Int32 scope
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.attachToItem Method

Associate a new item with this label. To attach a label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.

public virtual void attachToItem(
Item item
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.attachToItems Method

public virtual void attachToItems(
Int32[] itemIDs,
ViewConfiguration configuration
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.copy Method

Creates a copy of this Label object. Useful to applications that want to save a snapshot of the label in a given state, for example, before calling View.refreshLabels().

public virtual Label copy();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.detachFromFolder Method

public virtual void detachFromFolder(
Folder item,
Int32 scope
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.detachFromItems Method

public virtual void detachFromItems(
Int32[] itemIDs
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.detachItem Method

Removes the label from the specified item.

public virtual void detachItem(
Item item
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.Equals Method

public override bool Equals(
Object another
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.getDescription Method

Returns the label's description.

public virtual string getDescription();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.GetHashCode Method

public override int GetHashCode();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.getID Method

Returns this label's unique integer identifier.

public virtual int getID();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.getLabeledItemIDs Method

public virtual int[] getLabeledItemIDs(
Int32[] itemIDs
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.getName Method

Return's the label's name. Label names must be unique within a view.

public virtual string getName();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.getOwningProjectID Method

Returns the ID of the project that owns the view that owns this label.

public virtual int getOwningProjectID();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.getOwningViewID Method

Returns the ID of the view that owns this label. This may be different that the value returned by getView() since it is possible to query for labels in other view.

public virtual int getOwningViewID();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.getRevisionTime Method

Returns the label's revision time. This applies only to revision labels. The time specifies which revision of an item the label is attached to.

public virtual OLEDate getRevisionTime();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.getTime Method

Returns the label's primary rollback time. This is only meaningful for view labels as opposed to revision labels.

public virtual OLEDate getTime();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.getView Method

Returns this label's View context. This is really the view context in which operations on the label occur. It is possible to query a view for labels from a different view. In that case the value of getView() and getOwningViewID() may differ.

public virtual View getView();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.isBuildLabel Method

Returns true if the label as being a StarTeam "Build" label. Change Requests that have an "AddressedIn" field value of next build will have this label assigned to that field when the label is created.

public virtual bool isBuildLabel();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.isDeleted Method

Returns true if this label has been deleted.

public virtual bool isDeleted();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.isEqualTo Method

Compares two Label objects.

public virtual bool isEqualTo(
Label label
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.isLocked Method

Return true if the label is locked or frozen. The item revision to which a locked label applies can not be modified.

public virtual bool isLocked();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.isModified Method

Returns true if this label has been modified but not yet saved.

public virtual bool isModified();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.isNew Method

Returns true if the label has not been created on the server (using update())

public virtual bool isNew();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.isRevisionLabel Method

Returns true if the label is a revision label. By default a revision label applies to no items in a view whereas a view label, when created, applies to all items in the view.

public virtual bool isRevisionLabel();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.isViewLabel Method

Returns true if the label is a view label. A view label applies to all items in the view.

public virtual bool isViewLabel();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


moveItem Method

Borland StarTeam SDK for .NET

Label.moveItem Method

Associates the label with a different version of an item. To move the label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.

Overload List

Associates the label with a different version of an item. To move the label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.

public virtual void moveItem(Item);

public virtual void moveItem(Item,Int32,OLEDate);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.moveItem Method (Item)

Associates the label with a different version of an item. To move the label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.

public virtual void moveItem(
Item item
);

See Also

Label Class | com.starbase.starteam Namespace | Label.moveItem Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.moveItem Method (Item, Int32, OLEDate)

public virtual void moveItem(
Item item,
Int32 objectID,
OLEDate revisionTime
);

See Also

Label Class | com.starbase.starteam Namespace | Label.moveItem Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.remove Method

Removes (deletes) this label from the view. It will still appear in the list of labels returned from the view but it will be marked as deleted.

public virtual void remove();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.setDescription Method

public virtual void setDescription(
String description
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.setLocked Method

public virtual void setLocked(
Boolean isLocked
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.setName Method

public virtual void setName(
String name
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.setTime Method

Sets the label's primary rollback time. When a view label is first created it specifies a view configuration as-of a specified time. This method sets that time.

public virtual void setTime(
OLEDate time
);

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.toDebugString Method

Returns a string containing various properties of this label.

public virtual string toDebugString();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.ToString Method

public override string ToString();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Label.update Method

Stores all changed to a new or modified label to the StarTeam repository. You can only change the name, description and lock/frozen state after the label has need created. If those properties have not been changed then this method will immediately return.

public virtual void update();

See Also

Label Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelAdapter Class

For a list of all members of this type, see LabelAdapter Members.

System.Object
LabelAdapter

public class LabelAdapter : LabelListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LabelAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelAdapter Members

LabelAdapter overview

Public Instance Constructors

LabelAdapter Constructor Initializes a new instance of the LabelAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
labelAdded |
labelChanged |
labelDeleted |
MemberwiseClone |
ToString |

See Also

LabelAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelAdapter Constructor

Initializes a new instance of the LabelAdapter class.

public LabelAdapter();

See Also

LabelAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelAdapter Methods

The methods of the LabelAdapter class are listed below. For a complete list of LabelAdapter class members, see the LabelAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
labelAdded |
labelChanged |
labelDeleted |
MemberwiseClone |
ToString |

See Also

LabelAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelAdapter.labelAdded Method

public override void labelAdded(
LabelEvent e
);

Implements

LabelListener.labelAdded

See Also

LabelAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelAdapter.labelChanged Method

public override void labelChanged(
LabelEvent e
);

Implements

LabelListener.labelChanged

See Also

LabelAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelAdapter.labelDeleted Method

public override void labelDeleted(
LabelEvent e
);

Implements

LabelListener.labelDeleted

See Also

LabelAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LabelAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelAdapter.ToString Method

public override string ToString();

See Also

LabelAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelEvent Class

For a list of all members of this type, see LabelEvent Members.

System.Object
EventObject
LabelEvent

public class LabelEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LabelEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelEvent Members

LabelEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
getLabel | Gets the Label that has been added, changed or deleted, in its new state. <p> Returns a Label object that is not a member of the View's Label collection (that is, it is not among the Label objects returned by View.getLabels()). There may be a Label in the collection with the same ID, but it would be a physically different object that is likely to have different properties. <p> If an application wants to refresh the Label objects in the View's Label collection, it must explicitly call View.refreshLabels().
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

LabelEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelEvent Methods

The methods of the LabelEvent class are listed below. For a complete list of LabelEvent class members, see the LabelEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
getLabel | Gets the Label that has been added, changed or deleted, in its new state. <p> Returns a Label object that is not a member of the View's Label collection (that is, it is not among the Label objects returned by View.getLabels()). There may be a Label in the collection with the same ID, but it would be a physically different object that is likely to have different properties. <p> If an application wants to refresh the Label objects in the View's Label collection, it must explicitly call View.refreshLabels().
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

LabelEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelEvent.Equals Method

public override bool Equals(
Object source
);

See Also

LabelEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelEvent.GetHashCode Method

public override int GetHashCode();

See Also

LabelEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelEvent.getLabel Method

Gets the Label that has been added, changed or deleted, in its new state. <p> Returns a Label object that is not a member of the View's Label collection (that is, it is not among the Label objects returned by View.getLabels()). There may be a Label in the collection with the same ID, but it would be a physically different object that is likely to have different properties. <p> If an application wants to refresh the Label objects in the View's Label collection, it must explicitly call View.refreshLabels().

public virtual Label getLabel();

See Also

LabelEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelEvent.getSource Method

public override object getSource();

See Also

LabelEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LabelEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelEvent.ToString Method

public override string ToString();

See Also

LabelEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelListener Interface

For a list of all members of this type, see LabelListener Members.

public interface LabelListener : EventListener

Types that implement LabelListener

Type | Description
LabelAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LabelListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelListener Members

LabelListener overview

Public Instance Methods

labelAdded | Invoked when a new Label has been added to the server.
labelChanged | Invoked when an existing Label has been modified on the server.
labelDeleted | Invoked when an existing Label has been deleted on the server.

See Also

LabelListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelListener Methods

The methods of the LabelListener interface are listed below. For a complete list of LabelListener interface members, see the LabelListener Members topic.

Public Instance Methods

labelAdded | Invoked when a new Label has been added to the server.
labelChanged | Invoked when an existing Label has been modified on the server.
labelDeleted | Invoked when an existing Label has been deleted on the server.

See Also

LabelListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelListener.labelAdded Method

Invoked when a new Label has been added to the server.

void labelAdded(
LabelEvent e
);

See Also

LabelListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelListener.labelChanged Method

Invoked when an existing Label has been modified on the server.

void labelChanged(
LabelEvent e
);

See Also

LabelListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LabelListener.labelDeleted Method

Invoked when an existing Label has been deleted on the server.

void labelDeleted(
LabelEvent e
);

See Also

LabelListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LicenseUsage Class

NOTE: This class is now obsolete.

For a list of all members of this type, see LicenseUsage Members.

System.Object
LicenseUsage

public class LicenseUsage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LicenseUsage Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LicenseUsage Members

LicenseUsage overview

Public Instance Methods

Equals |
getEncryptedReport | Returns an encrypted version of the license usage report.
getFormattedReport | Returns the formatted text version of the license usage report.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

LicenseUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LicenseUsage Methods

The methods of the LicenseUsage class are listed below. For a complete list of LicenseUsage class members, see the LicenseUsage Members topic.

Public Instance Methods

Equals |
getEncryptedReport | Returns an encrypted version of the license usage report.
getFormattedReport | Returns the formatted text version of the license usage report.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

LicenseUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LicenseUsage.Equals Method

public override bool Equals(
Object source
);

See Also

LicenseUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LicenseUsage.getEncryptedReport Method

Returns an encrypted version of the license usage report.

public virtual sbyte[] getEncryptedReport();

See Also

LicenseUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LicenseUsage.getFormattedReport Method

Returns the formatted text version of the license usage report.

public virtual sbyte[] getFormattedReport();

See Also

LicenseUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LicenseUsage.GetHashCode Method

public override int GetHashCode();

See Also

LicenseUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LicenseUsage.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LicenseUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LicenseUsage.ToString Method

public override string ToString();

See Also

LicenseUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link Class

For a list of all members of this type, see Link Members.

System.Object
Link

public class Link

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Link Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link Members

Link overview

Public Static Methods

linkAndPin

Public Instance Constructors

Link Overloaded. Initializes a new instance of the Link class.

Public Instance Methods

copy | Copies this link, creating a new one with the same content.
delete | Terminates the association of the linked items.
Equals |
getChildEndpoint | Returns a reference to the "child" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.
getComment | Returns the comment associated with this link.
getCreatedTime | Returns the time at which this link was created.
getCreatedUserID | Returns the user ID of the user who created this link.
GetHashCode |
getID | Returns an integer that identifies this link.
getParentEndpoint | Returns a reference to the "parent" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.
getParentFolderItemID | Returns the ItemID of the linked item's parent folder if the item is in the current view, otherwise -1. Only available for server api revision 1.16 and later; earlier revisions will always return -1.
getServer | Returns the server object to which the parent endpoint of this link belongs.
GetType (inherited from Object) | Gets the Type of the current instance.
getView | Returns the view to which the parent endpoint of this link belongs.
isEqualTo | Determines whether or not the contents of two links are the same.
MemberwiseClone |
pinChild | Pin the child endpoint of the link.
pinParent | Pin the parent endpoint of the link.
resolveChild | Resolves the child endpoint of this link. The referenced Item may reside in any view on the server. However, the returned Item is always a disembodied Item. Many normal Item operations are not supported on disembodied Items.
resolveParent | Resolves the parent endpoint of this link. The referenced Item may reside in any view on the server. However, the returned Item is always a disembodied Item. Many normal Item operations are not supported on disembodied Items.
setComment |
toDebugString |
ToString |
unpinChild | Unpin the child endpoint of the link.
unpinParent | Unpin the parent endpoint of the link.
update | Persists the link.

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link Constructor

Overload List

public Link(Item,Item);

Obsolete.

public Link(Item,Boolean,Item,Boolean,String);

public Link(Item,Int32,Item,Int32);

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link Constructor (Item, Item)

public Link(
Item parent,
Item child
);

See Also

Link Class | com.starbase.starteam Namespace | Link Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link Constructor (Item, Int32, Item, Int32)

public Link(
Item parent,
Int32 parentRevision,
Item child,
Int32 childRevision
);

See Also

Link Class | com.starbase.starteam Namespace | Link Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link Constructor (Item, Boolean, Item, Boolean, String)

NOTE: This constructor is now obsolete.

public Link(
Item parent,
Boolean bPinParent,
Item child,
Boolean bPinChild,
String comment
);

See Also

Link Class | com.starbase.starteam Namespace | Link Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link Methods

The methods of the Link class are listed below. For a complete list of Link class members, see the Link Members topic.

Public Static Methods

linkAndPin

Public Instance Methods

copy | Copies this link, creating a new one with the same content.
delete | Terminates the association of the linked items.
Equals |
getChildEndpoint | Returns a reference to the "child" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.
getComment | Returns the comment associated with this link.
getCreatedTime | Returns the time at which this link was created.
getCreatedUserID | Returns the user ID of the user who created this link.
GetHashCode |
getID | Returns an integer that identifies this link.
getParentEndpoint | Returns a reference to the "parent" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.
getParentFolderItemID | Returns the ItemID of the linked item's parent folder if the item is in the current view, otherwise -1. Only available for server api revision 1.16 and later; earlier revisions will always return -1.
getServer | Returns the server object to which the parent endpoint of this link belongs.
GetType (inherited from Object) | Gets the Type of the current instance.
getView | Returns the view to which the parent endpoint of this link belongs.
isEqualTo | Determines whether or not the contents of two links are the same.
MemberwiseClone |
pinChild | Pin the child endpoint of the link.
pinParent | Pin the parent endpoint of the link.
resolveChild | Resolves the child endpoint of this link. The referenced Item may reside in any view on the server. However, the returned Item is always a disembodied Item. Many normal Item operations are not supported on disembodied Items.
resolveParent | Resolves the parent endpoint of this link. The referenced Item may reside in any view on the server. However, the returned Item is always a disembodied Item. Many normal Item operations are not supported on disembodied Items.
setComment |
toDebugString |
ToString |
unpinChild | Unpin the child endpoint of the link.
unpinParent | Unpin the parent endpoint of the link.
update | Persists the link.

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.copy Method

Copies this link, creating a new one with the same content.

public virtual Link copy();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.delete Method

Terminates the association of the linked items.

public virtual void delete();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.Equals Method

public override bool Equals(
Object source
);

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.getChildEndpoint Method

Returns a reference to the "child" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.

public virtual LinkEndpoint getChildEndpoint();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.getComment Method

Returns the comment associated with this link.

public virtual string getComment();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.getCreatedTime Method

Returns the time at which this link was created.

public virtual OLEDate getCreatedTime();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.getCreatedUserID Method

Returns the user ID of the user who created this link.

public virtual int getCreatedUserID();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.GetHashCode Method

public override int GetHashCode();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.getID Method

Returns an integer that identifies this link.

public virtual int getID();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.getParentEndpoint Method

Returns a reference to the "parent" item in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the item from which this link was enumerated.

public virtual LinkEndpoint getParentEndpoint();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.getParentFolderItemID Method

Returns the ItemID of the linked item's parent folder if the item is in the current view, otherwise -1. Only available for server api revision 1.16 and later; earlier revisions will always return -1.

public virtual int getParentFolderItemID();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.getServer Method

Returns the server object to which the parent endpoint of this link belongs.

public virtual Server getServer();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.getView Method

Returns the view to which the parent endpoint of this link belongs.

public virtual View getView();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.isEqualTo Method

Determines whether or not the contents of two links are the same.

public virtual bool isEqualTo(
Link other
);

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.linkAndPin Method

public static Link linkAndPin(
Item parent,
Item child,
String comment,
Boolean updateExistingLink
);

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.pinChild Method

Pin the child endpoint of the link.

public virtual void pinChild(
Item newChild
);

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.pinParent Method

Pin the parent endpoint of the link.

public virtual void pinParent(
Item newParent
);

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.resolveChild Method

Resolves the child endpoint of this link. The referenced Item may reside in any view on the server. However, the returned Item is always a disembodied Item. Many normal Item operations are not supported on disembodied Items.

public virtual Item resolveChild();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.resolveParent Method

Resolves the parent endpoint of this link. The referenced Item may reside in any view on the server. However, the returned Item is always a disembodied Item. Many normal Item operations are not supported on disembodied Items.

public virtual Item resolveParent();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.setComment Method

public virtual void setComment(
String comment
);

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.toDebugString Method

public virtual string toDebugString();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.ToString Method

public override string ToString();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.unpinChild Method

Unpin the child endpoint of the link.

public virtual void unpinChild();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.unpinParent Method

Unpin the parent endpoint of the link.

public virtual void unpinParent();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Link.update Method

Persists the link.

public virtual void update();

See Also

Link Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache Class

For a list of all members of this type, see LinkCache Members.

System.Object
LinkCache

public class LinkCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LinkCache Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache Members

LinkCache overview

Public Instance Constructors

LinkCache Constructor Constructs a new link cache. The cache is initially empty.

Public Instance Methods

addLinkUpdateListener | Registers a LinkUpdateListener, which will then receive LinkUpdateEvents whenever a link is added or removed from the cache, and whenever a previously cached link is modified.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLinkFactory | Gets a LinkFactory that may be used to create new links. <p> For items whose links are already cached, creating new links through this LinkFactory will ensure that the cached links are updated automatically, without having to explicitly refresh the cache.
getLinks | Gets the links for the given item. If the links were not previously cached, they are fetched from the server and cached now. <p> If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.
GetType (inherited from Object) | Gets the Type of the current instance.
isPopulated | Determines whether of not the given item's links have already been cached.
MemberwiseClone |
populate | Overloaded.
refresh | Overloaded.
removeLinkUpdateListener | Removes a previously registered LinkUpdateListener.
ToString |

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache Constructor

Constructs a new link cache. The cache is initially empty.

public LinkCache();

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache Methods

The methods of the LinkCache class are listed below. For a complete list of LinkCache class members, see the LinkCache Members topic.

Public Instance Methods

addLinkUpdateListener | Registers a LinkUpdateListener, which will then receive LinkUpdateEvents whenever a link is added or removed from the cache, and whenever a previously cached link is modified.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLinkFactory | Gets a LinkFactory that may be used to create new links. <p> For items whose links are already cached, creating new links through this LinkFactory will ensure that the cached links are updated automatically, without having to explicitly refresh the cache.
getLinks | Gets the links for the given item. If the links were not previously cached, they are fetched from the server and cached now. <p> If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.
GetType (inherited from Object) | Gets the Type of the current instance.
isPopulated | Determines whether of not the given item's links have already been cached.
MemberwiseClone |
populate | Overloaded.
refresh | Overloaded.
removeLinkUpdateListener | Removes a previously registered LinkUpdateListener.
ToString |

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.addLinkUpdateListener Method

Registers a LinkUpdateListener, which will then receive LinkUpdateEvents whenever a link is added or removed from the cache, and whenever a previously cached link is modified.

public virtual void addLinkUpdateListener(
LinkUpdateListener listener
);

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.getLinkFactory Method

Gets a LinkFactory that may be used to create new links. <p> For items whose links are already cached, creating new links through this LinkFactory will ensure that the cached links are updated automatically, without having to explicitly refresh the cache.

public virtual LinkFactory getLinkFactory();

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.getLinks Method

Gets the links for the given item. If the links were not previously cached, they are fetched from the server and cached now. <p> If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual Link[] getLinks(
Item item
);

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.isPopulated Method

Determines whether of not the given item's links have already been cached.

public virtual bool isPopulated(
Item item
);

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


populate Method

Borland StarTeam SDK for .NET

LinkCache.populate Method

Overload List

public virtual void populate(Folder,Type,Int32);

Ensures that the links are cached for all of the given items. <p> If the links for some of the items have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it. <p> If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual void populate(Items);

public virtual void populate(View,Type);

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.populate Method (Folder, Type, Int32)

public virtual void populate(
Folder folder,
Type itemType,
Int32 depth
);

See Also

LinkCache Class | com.starbase.starteam Namespace | LinkCache.populate Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.populate Method (Items)

Ensures that the links are cached for all of the given items. <p> If the links for some of the items have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it. <p> If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual void populate(
Items list
);

See Also

LinkCache Class | com.starbase.starteam Namespace | LinkCache.populate Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.populate Method (View, Type)

public virtual void populate(
View view,
Type itemType
);

See Also

LinkCache Class | com.starbase.starteam Namespace | LinkCache.populate Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


refresh Method

Borland StarTeam SDK for .NET

LinkCache.refresh Method

Overload List

public virtual void refresh(Folder,Type,Int32);

Ensures that the latest links are available for the given item. <p> Existing Link objects are modified in place whenever possible. <p> Note that since links are not currently MPX-aware, this re-fetches the links for the given item. <p> If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void refresh(Item);

Ensures that the latest links are available for all of the given items. <p> Existing Link objects are modified in place whenever possible. <p> Note that since links are not currently MPX-aware, this re-fetches the links for all of the given items. Links are fetched in bulk for servers that support it. <p> If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void refresh(Items);

public virtual void refresh(View,Type);

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.refresh Method (Folder, Type, Int32)

public virtual void refresh(
Folder folder,
Type itemType,
Int32 depth
);

See Also

LinkCache Class | com.starbase.starteam Namespace | LinkCache.refresh Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.refresh Method (Item)

Ensures that the latest links are available for the given item. <p> Existing Link objects are modified in place whenever possible. <p> Note that since links are not currently MPX-aware, this re-fetches the links for the given item. <p> If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void refresh(
Item item
);

See Also

LinkCache Class | com.starbase.starteam Namespace | LinkCache.refresh Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.refresh Method (Items)

Ensures that the latest links are available for all of the given items. <p> Existing Link objects are modified in place whenever possible. <p> Note that since links are not currently MPX-aware, this re-fetches the links for all of the given items. Links are fetched in bulk for servers that support it. <p> If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void refresh(
Items list
);

See Also

LinkCache Class | com.starbase.starteam Namespace | LinkCache.refresh Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.refresh Method (View, Type)

public virtual void refresh(
View view,
Type itemType
);

See Also

LinkCache Class | com.starbase.starteam Namespace | LinkCache.refresh Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.removeLinkUpdateListener Method

Removes a previously registered LinkUpdateListener.

public virtual void removeLinkUpdateListener(
LinkUpdateListener listener
);

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkCache.ToString Method

public override string ToString();

See Also

LinkCache Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint Class

For a list of all members of this type, see LinkEndpoint Members.

System.Object
LinkEndpoint

public class LinkEndpoint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LinkEndpoint Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint Members

LinkEndpoint overview

Public Instance Methods

copy | Copies this link endpoint, creating a new one with the same content.
Equals |
getDotNotation | Returns the dot notation for the revision being referenced by this link. This value will be meaningless if the endpoint is not pinned.
getFolderObjectID | Returns the object ID for the parent folder of the linked item.
GetHashCode |
getItem | Resolves this link endpoint.
getItemID | Returns the itemID of the item being referenced.
getObjectID | Returns the object ID of the underlying object referenced by the item. This value is only meaningful if the link is pinned. This value might be -1 if the link is not pinned. You should always use the <code>isPinned</code> method to determine if a link is pinned.
getRevisionNumber | Returns the revision number for the specific revision this link enpoint references. Will be -1 if the link endpoint is not "pinned"
getType | Returns the <code>Type</code> of the item for this link endpoint.
GetType (inherited from Object) | Gets the Type of the current instance.
getViewID | Returns the view ID in which the referenced item exists. Note that this may not be the same as the view in which the link was obtained.
isEqualTo | Determines whether or not the contents of two link endpoints are the same.
isPinned | Returns <code>true</code> if the item referenced is fixed at a specific revision such that the association does not propogate to newer versions of the item.
MemberwiseClone |
toDebugString | Returns a debug string representation of this link endpoint.
ToString |

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint Methods

The methods of the LinkEndpoint class are listed below. For a complete list of LinkEndpoint class members, see the LinkEndpoint Members topic.

Public Instance Methods

copy | Copies this link endpoint, creating a new one with the same content.
Equals |
getDotNotation | Returns the dot notation for the revision being referenced by this link. This value will be meaningless if the endpoint is not pinned.
getFolderObjectID | Returns the object ID for the parent folder of the linked item.
GetHashCode |
getItem | Resolves this link endpoint.
getItemID | Returns the itemID of the item being referenced.
getObjectID | Returns the object ID of the underlying object referenced by the item. This value is only meaningful if the link is pinned. This value might be -1 if the link is not pinned. You should always use the <code>isPinned</code> method to determine if a link is pinned.
getRevisionNumber | Returns the revision number for the specific revision this link enpoint references. Will be -1 if the link endpoint is not "pinned"
getType | Returns the <code>Type</code> of the item for this link endpoint.
GetType (inherited from Object) | Gets the Type of the current instance.
getViewID | Returns the view ID in which the referenced item exists. Note that this may not be the same as the view in which the link was obtained.
isEqualTo | Determines whether or not the contents of two link endpoints are the same.
isPinned | Returns <code>true</code> if the item referenced is fixed at a specific revision such that the association does not propogate to newer versions of the item.
MemberwiseClone |
toDebugString | Returns a debug string representation of this link endpoint.
ToString |

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.copy Method

Copies this link endpoint, creating a new one with the same content.

public virtual LinkEndpoint copy();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.Equals Method

public override bool Equals(
Object source
);

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.getDotNotation Method

Returns the dot notation for the revision being referenced by this link. This value will be meaningless if the endpoint is not pinned.

public virtual string getDotNotation();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.getFolderObjectID Method

Returns the object ID for the parent folder of the linked item.

public virtual int getFolderObjectID();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.GetHashCode Method

public override int GetHashCode();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.getItem Method

Resolves this link endpoint.

public virtual Item getItem();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.getItemID Method

Returns the itemID of the item being referenced.

public virtual int getItemID();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.getObjectID Method

Returns the object ID of the underlying object referenced by the item. This value is only meaningful if the link is pinned. This value might be -1 if the link is not pinned. You should always use the <code>isPinned</code> method to determine if a link is pinned.

public virtual int getObjectID();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.getRevisionNumber Method

Returns the revision number for the specific revision this link enpoint references. Will be -1 if the link endpoint is not "pinned"

public virtual int getRevisionNumber();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.getType Method

Returns the <code>Type</code> of the item for this link endpoint.

public virtual Type getType();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.getViewID Method

Returns the view ID in which the referenced item exists. Note that this may not be the same as the view in which the link was obtained.

public virtual int getViewID();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.isEqualTo Method

Determines whether or not the contents of two link endpoints are the same.

public virtual bool isEqualTo(
LinkEndpoint other
);

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.isPinned Method

Returns <code>true</code> if the item referenced is fixed at a specific revision such that the association does not propogate to newer versions of the item.

public virtual bool isPinned();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.toDebugString Method

Returns a debug string representation of this link endpoint.

public virtual string toDebugString();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkEndpoint.ToString Method

public override string ToString();

See Also

LinkEndpoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkFactory Class

For a list of all members of this type, see LinkFactory Members.

System.Object
LinkFactory

public class LinkFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LinkFactory Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkFactory Members

LinkFactory overview

Public Instance Constructors

LinkFactory Constructor Creates a LinkFactory.

Public Instance Methods

createLink | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
linkAndPin |
MemberwiseClone |
ToString |
updateAll | Saves the links created by this LinkFactory. For servers that support bulk link creation, the number of commands issued is minimized.

See Also

LinkFactory Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkFactory Constructor

Creates a LinkFactory.

public LinkFactory();

See Also

LinkFactory Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkFactory Methods

The methods of the LinkFactory class are listed below. For a complete list of LinkFactory class members, see the LinkFactory Members topic.

Public Instance Methods

createLink | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
linkAndPin |
MemberwiseClone |
ToString |
updateAll | Saves the links created by this LinkFactory. For servers that support bulk link creation, the number of commands issued is minimized.

See Also

LinkFactory Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


createLink Method

Borland StarTeam SDK for .NET

LinkFactory.createLink Method

Overload List

public virtual Link createLink(Item,Item);

public virtual Link createLink(Item,Int32,Item,Int32);

See Also

LinkFactory Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkFactory.createLink Method (Item, Item)

public virtual Link createLink(
Item parent,
Item child
);

See Also

LinkFactory Class | com.starbase.starteam Namespace | LinkFactory.createLink Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkFactory.createLink Method (Item, Int32, Item, Int32)

public virtual Link createLink(
Item parent,
Int32 parentRevision,
Item child,
Int32 childRevision
);

See Also

LinkFactory Class | com.starbase.starteam Namespace | LinkFactory.createLink Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkFactory.linkAndPin Method

public virtual Link linkAndPin(
Item parent,
Item child,
String comment,
Boolean updateExistingLink
);

See Also

LinkFactory Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkFactory.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LinkFactory Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkFactory.ToString Method

public override string ToString();

See Also

LinkFactory Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkFactory.updateAll Method

Saves the links created by this LinkFactory. For servers that support bulk link creation, the number of commands issued is minimized.

public virtual void updateAll();

See Also

LinkFactory Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateAdapter Class

For a list of all members of this type, see LinkUpdateAdapter Members.

System.Object
LinkUpdateAdapter

public class LinkUpdateAdapter : LinkUpdateListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LinkUpdateAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateAdapter Members

LinkUpdateAdapter overview

Public Instance Constructors

LinkUpdateAdapter Constructor Initializes a new instance of the LinkUpdateAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
linkAdded |
linkChanged |
linkRemoved |
MemberwiseClone |
ToString |

See Also

LinkUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateAdapter Constructor

Initializes a new instance of the LinkUpdateAdapter class.

public LinkUpdateAdapter();

See Also

LinkUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateAdapter Methods

The methods of the LinkUpdateAdapter class are listed below. For a complete list of LinkUpdateAdapter class members, see the LinkUpdateAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
linkAdded |
linkChanged |
linkRemoved |
MemberwiseClone |
ToString |

See Also

LinkUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateAdapter.linkAdded Method

public virtual void linkAdded(
LinkUpdateEvent e
);

Implements

LinkUpdateListener.linkAdded

See Also

LinkUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateAdapter.linkChanged Method

public virtual void linkChanged(
LinkUpdateEvent e
);

Implements

LinkUpdateListener.linkChanged

See Also

LinkUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateAdapter.linkRemoved Method

public virtual void linkRemoved(
LinkUpdateEvent e
);

Implements

LinkUpdateListener.linkRemoved

See Also

LinkUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LinkUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateAdapter.ToString Method

public override string ToString();

See Also

LinkUpdateAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateEvent Class

For a list of all members of this type, see LinkUpdateEvent Members.

System.Object
EventObject
LinkUpdateEvent

public class LinkUpdateEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LinkUpdateEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateEvent Members

LinkUpdateEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getNewLink | Gets the Link in its new state. <p> Used in linkAdded() and linkChanged() events. In linkRemoved() events, getNewLink() returns null.
GetObjectData (inherited from java.util.EventObject) |
getOldLink | Gets the Link in its old state. <p> Used in linkChanged() and linkRemoved() events. In linkAdded() events, getOldLink() returns null.
getSource (inherited from java.util.EventObject) |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

LinkUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateEvent Methods

The methods of the LinkUpdateEvent class are listed below. For a complete list of LinkUpdateEvent class members, see the LinkUpdateEvent Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getNewLink | Gets the Link in its new state. <p> Used in linkAdded() and linkChanged() events. In linkRemoved() events, getNewLink() returns null.
GetObjectData (inherited from java.util.EventObject) |
getOldLink | Gets the Link in its old state. <p> Used in linkChanged() and linkRemoved() events. In linkAdded() events, getOldLink() returns null.
getSource (inherited from java.util.EventObject) |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

LinkUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateEvent.getNewLink Method

Gets the Link in its new state. <p> Used in linkAdded() and linkChanged() events. In linkRemoved() events, getNewLink() returns null.

public virtual Link getNewLink();

See Also

LinkUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateEvent.getOldLink Method

Gets the Link in its old state. <p> Used in linkChanged() and linkRemoved() events. In linkAdded() events, getOldLink() returns null.

public virtual Link getOldLink();

See Also

LinkUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LinkUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateEvent.ToString Method

public override string ToString();

See Also

LinkUpdateEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateListener Interface

For a list of all members of this type, see LinkUpdateListener Members.

public interface LinkUpdateListener : EventListener

Types that implement LinkUpdateListener

Type | Description
LinkUpdateAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LinkUpdateListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateListener Members

LinkUpdateListener overview

Public Instance Methods

linkAdded | Invoked when a Link is added to a LinkCache. <p> For linkAdded events, LinkUpdateEvent.getNewLink() returns the added link in its new context. LinkUpdateEvent.getOldLink() returns null.
linkChanged | Invoked when the properties of an Link in a LinkCache have changed. <p> For linkChanged events, LinkUpdateEvent.getOldLink() returns a Link object representing the link in its old state (that is, before its properties were changed). LinkUpdateEvent.getNewLink() returns the link in its new state (after its properties were changed).
linkRemoved | Invoked when an Link is removed from a LinkCache. <p> For linkRemoved events, LinkUpdateEvent.getOldLink() returns the removed link in its old context (that is, prior to being removed). LinkUpdateEvent.getNewLink() returns null.

See Also

LinkUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateListener Methods

The methods of the LinkUpdateListener interface are listed below. For a complete list of LinkUpdateListener interface members, see the LinkUpdateListener Members topic.

Public Instance Methods

linkAdded | Invoked when a Link is added to a LinkCache. <p> For linkAdded events, LinkUpdateEvent.getNewLink() returns the added link in its new context. LinkUpdateEvent.getOldLink() returns null.
linkChanged | Invoked when the properties of an Link in a LinkCache have changed. <p> For linkChanged events, LinkUpdateEvent.getOldLink() returns a Link object representing the link in its old state (that is, before its properties were changed). LinkUpdateEvent.getNewLink() returns the link in its new state (after its properties were changed).
linkRemoved | Invoked when an Link is removed from a LinkCache. <p> For linkRemoved events, LinkUpdateEvent.getOldLink() returns the removed link in its old context (that is, prior to being removed). LinkUpdateEvent.getNewLink() returns null.

See Also

LinkUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateListener.linkAdded Method

Invoked when a Link is added to a LinkCache. <p> For linkAdded events, LinkUpdateEvent.getNewLink() returns the added link in its new context. LinkUpdateEvent.getOldLink() returns null.

void linkAdded(
LinkUpdateEvent e
);

See Also

LinkUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateListener.linkChanged Method

Invoked when the properties of an Link in a LinkCache have changed. <p> For linkChanged events, LinkUpdateEvent.getOldLink() returns a Link object representing the link in its old state (that is, before its properties were changed). LinkUpdateEvent.getNewLink() returns the link in its new state (after its properties were changed).

void linkChanged(
LinkUpdateEvent e
);

See Also

LinkUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LinkUpdateListener.linkRemoved Method

Invoked when an Link is removed from a LinkCache. <p> For linkRemoved events, LinkUpdateEvent.getOldLink() returns the removed link in its old context (that is, prior to being removed). LinkUpdateEvent.getNewLink() returns null.

void linkRemoved(
LinkUpdateEvent e
);

See Also

LinkUpdateListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword Class

For a list of all members of this type, see LogKeyword Members.

System.Object
SimpleKeyword
LogKeyword

public class LogKeyword : SimpleKeyword

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LogKeyword Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword Members

LogKeyword overview

Public Instance Constructors

LogKeyword Overloaded. Initializes a new instance of the LogKeyword class.

Public Instance Methods

Equals |
expand |
GetHashCode |
getName (inherited from SimpleKeyword) |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue (inherited from SimpleKeyword) |
matches |
MemberwiseClone (inherited from SimpleKeyword) |
multiLine |
stopExpanding (inherited from SimpleKeyword) |
ToString (inherited from SimpleKeyword) |
toXMLString |

See Also

LogKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword Constructor

Overload List

public LogKeyword(LogLine[]);

public LogKeyword(LogLine[],Boolean);

See Also

LogKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword Constructor (LogLine[])

public LogKeyword(
LogLine[] logLines
);

See Also

LogKeyword Class | com.starbase.starteam Namespace | LogKeyword Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword Constructor (LogLine[], Boolean)

public LogKeyword(
LogLine[] logLines,
Boolean utcDates
);

See Also

LogKeyword Class | com.starbase.starteam Namespace | LogKeyword Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword Methods

The methods of the LogKeyword class are listed below. For a complete list of LogKeyword class members, see the LogKeyword Members topic.

Public Instance Methods

Equals |
expand |
GetHashCode |
getName (inherited from SimpleKeyword) |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue (inherited from SimpleKeyword) |
matches |
MemberwiseClone (inherited from SimpleKeyword) |
multiLine |
stopExpanding (inherited from SimpleKeyword) |
ToString (inherited from SimpleKeyword) |
toXMLString |

See Also

LogKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword.Equals Method

public override bool Equals(
Object source
);

See Also

LogKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword.expand Method

public override string expand(
String linePrefix,
String eol,
Boolean expand
);

Implements

Keyword.expand

See Also

LogKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword.GetHashCode Method

public override int GetHashCode();

See Also

LogKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword.matches Method

public override bool matches(
String line,
Int32 start,
Int32[] endPos
);

Implements

Keyword.matches

See Also

LogKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword.multiLine Method

public override bool multiLine();

Implements

Keyword.multiLine

See Also

LogKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogKeyword.toXMLString Method

public override string toXMLString();

Implements

Keyword.toXMLString

See Also

LogKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogLine Class

For a list of all members of this type, see LogLine Members.

System.Object
LogLine
HistoryLine

public class LogLine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LogLine Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogLine Members

LogLine overview

Public Instance Constructors

LogLine Constructor

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |
toXMLString | Returns an XML representation of the log line entry. The default XML representation is of the form: <pre> &lt;logline&gt; &lt;version&gt;1&lt;/version&gt; &lt;view&gt;Main&lt;/view&gt; &lt;dotnotation&gt;1.0&lt;/dotnotation&gt; &lt;date&gt;2000-08-11T17:37:18Z&lt;/date&gt; &lt;author&gt;Bob&lt;/author&gt; &lt;comment&gt;&lt;/comment&gt; &lt;/logline&gt; </pre>

See Also

LogLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogLine Constructor

public LogLine(
Int32 version,
String viewName,
String dotNotation,
OLEDate date,
String author,
String comment
);

See Also

LogLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogLine Methods

The methods of the LogLine class are listed below. For a complete list of LogLine class members, see the LogLine Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |
toXMLString | Returns an XML representation of the log line entry. The default XML representation is of the form: <pre> &lt;logline&gt; &lt;version&gt;1&lt;/version&gt; &lt;view&gt;Main&lt;/view&gt; &lt;dotnotation&gt;1.0&lt;/dotnotation&gt; &lt;date&gt;2000-08-11T17:37:18Z&lt;/date&gt; &lt;author&gt;Bob&lt;/author&gt; &lt;comment&gt;&lt;/comment&gt; &lt;/logline&gt; </pre>

See Also

LogLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogLine.Equals Method

public override bool Equals(
Object source
);

See Also

LogLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogLine.GetHashCode Method

public override int GetHashCode();

See Also

LogLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogLine.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LogLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogLine.ToString Method

public override string ToString();

See Also

LogLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogLine.toXMLString Method

Returns an XML representation of the log line entry. The default XML representation is of the form: <pre> &lt;logline&gt; &lt;version&gt;1&lt;/version&gt; &lt;view&gt;Main&lt;/view&gt; &lt;dotnotation&gt;1.0&lt;/dotnotation&gt; &lt;date&gt;2000-08-11T17:37:18Z&lt;/date&gt; &lt;author&gt;Bob&lt;/author&gt; &lt;comment&gt;&lt;/comment&gt; &lt;/logline&gt; </pre>

public virtual string toXMLString();

See Also

LogLine Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogonException Class

For a list of all members of this type, see LogonException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
ServerException
LogonException
PasswordExpiredException

public class LogonException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LogonException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogonException Members

LogonException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
isUserNameValid |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |

See Also

LogonException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogonException Methods

The methods of the LogonException class are listed below. For a complete list of LogonException class members, see the LogonException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
isUserNameValid |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |

See Also

LogonException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogonException.Equals Method

public override bool Equals(
Object source
);

See Also

LogonException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogonException.GetHashCode Method

public override int GetHashCode();

See Also

LogonException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogonException.getMessage Method

public override string getMessage();

See Also

LogonException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogonException.isUserNameValid Method

public virtual bool isUserNameValid();

See Also

LogonException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LogonException.wrap Method

public static LogonException wrap(
LogonException arg
);

See Also

LogonException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchedACE Class

For a list of all members of this type, see MatchedACE Members.

System.Object
MatchedACE

public class MatchedACE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MatchedACE Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchedACE Members

MatchedACE overview

Public Instance Methods

Equals |
getEffectiveACE | Gets the corresponding EffectiveACE.
GetHashCode |
getIndexInACL | Gets the index of the matched ACE in its Effective Access Control List. <p> If an access test for a given permission is performed against an Effective ACL from an object for which the permission is not applicable, then it is possible for the resulting AccessTestResult to contain a MatchedACE for an EffectiveACE that did not appear in the original Effective ACL. In this case, getIndexInACL() will return -1.
getPermissions | Gets a subset of the permissions that were tested.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

MatchedACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchedACE Methods

The methods of the MatchedACE class are listed below. For a complete list of MatchedACE class members, see the MatchedACE Members topic.

Public Instance Methods

Equals |
getEffectiveACE | Gets the corresponding EffectiveACE.
GetHashCode |
getIndexInACL | Gets the index of the matched ACE in its Effective Access Control List. <p> If an access test for a given permission is performed against an Effective ACL from an object for which the permission is not applicable, then it is possible for the resulting AccessTestResult to contain a MatchedACE for an EffectiveACE that did not appear in the original Effective ACL. In this case, getIndexInACL() will return -1.
getPermissions | Gets a subset of the permissions that were tested.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

MatchedACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchedACE.Equals Method

public override bool Equals(
Object source
);

See Also

MatchedACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchedACE.getEffectiveACE Method

Gets the corresponding EffectiveACE.

public virtual EffectiveACE getEffectiveACE();

See Also

MatchedACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchedACE.GetHashCode Method

public override int GetHashCode();

See Also

MatchedACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchedACE.getIndexInACL Method

Gets the index of the matched ACE in its Effective Access Control List. <p> If an access test for a given permission is performed against an Effective ACL from an object for which the permission is not applicable, then it is possible for the resulting AccessTestResult to contain a MatchedACE for an EffectiveACE that did not appear in the original Effective ACL. In this case, getIndexInACL() will return -1.

public virtual int getIndexInACL();

See Also

MatchedACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchedACE.getPermissions Method

Gets a subset of the permissions that were tested.

public virtual int getPermissions();

See Also

MatchedACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchedACE.MemberwiseClone Method

public override object MemberwiseClone();

See Also

MatchedACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchedACE.ToString Method

public override string ToString();

See Also

MatchedACE Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint Class

For a list of all members of this type, see MergePoint Members.

System.Object
MergePoint

public class MergePoint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MergePoint Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint Members

MergePoint overview

Public Instance Constructors

MergePoint Constructor

Public Instance Methods

Equals |
GetHashCode |
getSource | Returns the RevisionID of the merge source.
getTarget | Returns the RevisionID of the merge target.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setSource | Sets the RevisionID of the source. The source cannot be null.
setTarget | Sets the RevisionID of the target. The target cannot be null.
ToString |

See Also

MergePoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint Constructor

public MergePoint(
RevisionID source,
RevisionID target
);

See Also

MergePoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint Methods

The methods of the MergePoint class are listed below. For a complete list of MergePoint class members, see the MergePoint Members topic.

Public Instance Methods

Equals |
GetHashCode |
getSource | Returns the RevisionID of the merge source.
getTarget | Returns the RevisionID of the merge target.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setSource | Sets the RevisionID of the source. The source cannot be null.
setTarget | Sets the RevisionID of the target. The target cannot be null.
ToString |

See Also

MergePoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint.Equals Method

public override bool Equals(
Object source
);

See Also

MergePoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint.GetHashCode Method

public override int GetHashCode();

See Also

MergePoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint.getSource Method

Returns the RevisionID of the merge source.

public virtual RevisionID getSource();

See Also

MergePoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint.getTarget Method

Returns the RevisionID of the merge target.

public virtual RevisionID getTarget();

See Also

MergePoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint.MemberwiseClone Method

public override object MemberwiseClone();

See Also

MergePoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint.setSource Method

Sets the RevisionID of the source. The source cannot be null.

public virtual void setSource(
RevisionID source
);

See Also

MergePoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint.setTarget Method

Sets the RevisionID of the target. The target cannot be null.

public virtual void setTarget(
RevisionID target
);

See Also

MergePoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePoint.ToString Method

public override string ToString();

See Also

MergePoint Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException Class

For a list of all members of this type, see MPXException Members.

System.Object
Exception
Throwable
Exception
MPXException

public class MPXException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MPXException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException Members

MPXException overview

Public Static Fields

E_CONNECT
E_MESSAGETHREAD
E_MPX_BASE
E_MULTICAST_NOT_SUPPORTED
E_NO_DEFAULT_PROFILE
E_NO_SUCH_PROFILE
E_NORESPONSE
E_NOT_INSTALLED
E_NOT_SUPPORTED
E_NOTCONNECTED
E_TRANSMITTER
E_UNEXPECTED

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getErrorCode |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException Fields

The fields of the MPXException class are listed below. For a complete list of MPXException class members, see the MPXException Members topic.

Public Static Fields

E_CONNECT
E_MESSAGETHREAD
E_MPX_BASE
E_MULTICAST_NOT_SUPPORTED
E_NO_DEFAULT_PROFILE
E_NO_SUCH_PROFILE
E_NORESPONSE
E_NOT_INSTALLED
E_NOT_SUPPORTED
E_NOTCONNECTED
E_TRANSMITTER
E_UNEXPECTED

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_CONNECT Field

public const Int32 E_CONNECT = 4;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_MESSAGETHREAD Field

public const Int32 E_MESSAGETHREAD = 7;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_MPX_BASE Field

public const Int32 E_MPX_BASE = 1000;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_MULTICAST_NOT_SUPPORTED Field

public const Int32 E_MULTICAST_NOT_SUPPORTED = 12;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_NO_DEFAULT_PROFILE Field

public const Int32 E_NO_DEFAULT_PROFILE = 2;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_NO_SUCH_PROFILE Field

public const Int32 E_NO_SUCH_PROFILE = 3;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_NORESPONSE Field

public const Int32 E_NORESPONSE = 6;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_NOT_INSTALLED Field

public const Int32 E_NOT_INSTALLED = 1;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_NOT_SUPPORTED Field

public const Int32 E_NOT_SUPPORTED = 11;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_NOTCONNECTED Field

public const Int32 E_NOTCONNECTED = 5;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_TRANSMITTER Field

public const Int32 E_TRANSMITTER = 8;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.E_UNEXPECTED Field

public const Int32 E_UNEXPECTED = 10;

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException Methods

The methods of the MPXException class are listed below. For a complete list of MPXException class members, see the MPXException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getErrorCode |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.Equals Method

public override bool Equals(
Object source
);

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.getErrorCode Method

public virtual int getErrorCode();

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.GetHashCode Method

public override int GetHashCode();

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.getMessage Method

public override string getMessage();

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.unwrap Method

public virtual MPXException unwrap();

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXException.wrap Method

public static MPXException wrap(
MPXException arg
);

See Also

MPXException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter Class

For a list of all members of this type, see MPXStatusAdapter Members.

System.Object
MPXStatusAdapter

public class MPXStatusAdapter : MPXStatusListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MPXStatusAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter Members

MPXStatusAdapter overview

Public Instance Constructors

MPXStatusAdapter Constructor Initializes a new instance of the MPXStatusAdapter class.

Public Instance Methods

disabled |
enabled |
Equals |
exception |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
offline |
online |
ToString |

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter Constructor

Initializes a new instance of the MPXStatusAdapter class.

public MPXStatusAdapter();

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter Methods

The methods of the MPXStatusAdapter class are listed below. For a complete list of MPXStatusAdapter class members, see the MPXStatusAdapter Members topic.

Public Instance Methods

disabled |
enabled |
Equals |
exception |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
offline |
online |
ToString |

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter.disabled Method

public override void disabled(
MPXStatusEvent e
);

Implements

MPXStatusListener.disabled

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter.enabled Method

public override void enabled(
MPXStatusEvent e
);

Implements

MPXStatusListener.enabled

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter.Equals Method

public override bool Equals(
Object source
);

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter.exception Method

public override void exception(
MPXStatusEvent e
);

Implements

MPXStatusListener.exception

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter.GetHashCode Method

public override int GetHashCode();

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter.offline Method

public override void offline(
MPXStatusEvent e
);

Implements

MPXStatusListener.offline

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter.online Method

public override void online(
MPXStatusEvent e
);

Implements

MPXStatusListener.online

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusAdapter.ToString Method

public override string ToString();

See Also

MPXStatusAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusEvent Class

For a list of all members of this type, see MPXStatusEvent Members.

System.Object
EventObject
MPXStatusEvent

public class MPXStatusEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MPXStatusEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusEvent Members

MPXStatusEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getException |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from java.util.EventObject) |
getServer | Gets the Server object that was used to register the listener.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

MPXStatusEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusEvent Methods

The methods of the MPXStatusEvent class are listed below. For a complete list of MPXStatusEvent class members, see the MPXStatusEvent Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getException |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from java.util.EventObject) |
getServer | Gets the Server object that was used to register the listener.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

MPXStatusEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusEvent.getException Method

public virtual MPXException getException();

See Also

MPXStatusEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusEvent.getServer Method

Gets the Server object that was used to register the listener.

public virtual Server getServer();

See Also

MPXStatusEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusEvent.getSource Method

public override object getSource();

See Also

MPXStatusEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

MPXStatusEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusEvent.ToString Method

public override string ToString();

See Also

MPXStatusEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusListener Interface

For a list of all members of this type, see MPXStatusListener Members.

public interface MPXStatusListener : EventListener

Types that implement MPXStatusListener

Type | Description
MPXStatusAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MPXStatusListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusListener Members

MPXStatusListener overview

Public Instance Methods

disabled | Invoked when MPX is disabled by the client application. Disabling MPX (e.g., via Server.disableMPX) disables MPX for all Server objects in the application that are connected to the StarTeam server with the same address and port.
enabled | Invoked when MPX is enabled by the client application. Enabling MPX (e.g., via Server.enableMPX) enables MPX for all Server objects in the application that are connected to the StarTeam server with the same address and port.
exception | Invoked when an exception occurs during MPX processing. <p> In this case, MPXStatusEvent.getException() will return an exception object that provides further information about the nature of the problem.
offline | Invoked when the StarTeam MPX transmitter goes offline (for example, due to network connectivity problems).
online | Invoked when the StarTeam MPX transmitter comes back online (for example, after going offline due to network connectivity problems).

See Also

MPXStatusListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusListener Methods

The methods of the MPXStatusListener interface are listed below. For a complete list of MPXStatusListener interface members, see the MPXStatusListener Members topic.

Public Instance Methods

disabled | Invoked when MPX is disabled by the client application. Disabling MPX (e.g., via Server.disableMPX) disables MPX for all Server objects in the application that are connected to the StarTeam server with the same address and port.
enabled | Invoked when MPX is enabled by the client application. Enabling MPX (e.g., via Server.enableMPX) enables MPX for all Server objects in the application that are connected to the StarTeam server with the same address and port.
exception | Invoked when an exception occurs during MPX processing. <p> In this case, MPXStatusEvent.getException() will return an exception object that provides further information about the nature of the problem.
offline | Invoked when the StarTeam MPX transmitter goes offline (for example, due to network connectivity problems).
online | Invoked when the StarTeam MPX transmitter comes back online (for example, after going offline due to network connectivity problems).

See Also

MPXStatusListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusListener.disabled Method

Invoked when MPX is disabled by the client application. Disabling MPX (e.g., via Server.disableMPX) disables MPX for all Server objects in the application that are connected to the StarTeam server with the same address and port.

void disabled(
MPXStatusEvent e
);

See Also

MPXStatusListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusListener.enabled Method

Invoked when MPX is enabled by the client application. Enabling MPX (e.g., via Server.enableMPX) enables MPX for all Server objects in the application that are connected to the StarTeam server with the same address and port.

void enabled(
MPXStatusEvent e
);

See Also

MPXStatusListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusListener.exception Method

Invoked when an exception occurs during MPX processing. <p> In this case, MPXStatusEvent.getException() will return an exception object that provides further information about the nature of the problem.

void exception(
MPXStatusEvent e
);

See Also

MPXStatusListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusListener.offline Method

Invoked when the StarTeam MPX transmitter goes offline (for example, due to network connectivity problems).

void offline(
MPXStatusEvent e
);

See Also

MPXStatusListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MPXStatusListener.online Method

Invoked when the StarTeam MPX transmitter comes back online (for example, after going offline due to network connectivity problems).

void online(
MPXStatusEvent e
);

See Also

MPXStatusListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount Class

For a list of all members of this type, see MyUserAccount Members.

System.Object
MyUserAccount

public class MyUserAccount

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MyUserAccount Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount Members

MyUserAccount overview

Public Instance Methods

copy | Creates a copy of this user account.
Equals |
getEmailAddress | Returns the user's email address.
getFaxNumber | Returns the user's fax number.
GetHashCode |
getID | Returns the integer that represents this user account.
getLogOnName | Returns ths user's logon name.
getMinimumPasswordLength | Returns the minimum required password length.
getName | Returns the full name that this user goes by.
getPagerNumber | Returns the user's pager number.
getPasswordChangeRequired | Determines whether or not a password change is required during the current session. If the password is not changed, the user will lose access to the StarTeam server.
getPasswordDaysRemaining | Returns the number of days remaining that the user's current password will remain valid.
getPhoneNumber | Returns the user's phone number.
getPostalAddress | Returns the user's postal address.
GetType (inherited from Object) | Gets the Type of the current instance.
getVoiceMailNumber | Return the user's voice mail number.
isEqualTo | Compares two user account objects.
MemberwiseClone |
setEmailAddress |
setFaxNumber |
setName |
setPagerNumber |
setPassword |
setPhoneNumber |
setPostalAddress |
setVoiceMailNumber |
ToString |
update | Updates this user account information on the StarTeam server.

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount Methods

The methods of the MyUserAccount class are listed below. For a complete list of MyUserAccount class members, see the MyUserAccount Members topic.

Public Instance Methods

copy | Creates a copy of this user account.
Equals |
getEmailAddress | Returns the user's email address.
getFaxNumber | Returns the user's fax number.
GetHashCode |
getID | Returns the integer that represents this user account.
getLogOnName | Returns ths user's logon name.
getMinimumPasswordLength | Returns the minimum required password length.
getName | Returns the full name that this user goes by.
getPagerNumber | Returns the user's pager number.
getPasswordChangeRequired | Determines whether or not a password change is required during the current session. If the password is not changed, the user will lose access to the StarTeam server.
getPasswordDaysRemaining | Returns the number of days remaining that the user's current password will remain valid.
getPhoneNumber | Returns the user's phone number.
getPostalAddress | Returns the user's postal address.
GetType (inherited from Object) | Gets the Type of the current instance.
getVoiceMailNumber | Return the user's voice mail number.
isEqualTo | Compares two user account objects.
MemberwiseClone |
setEmailAddress |
setFaxNumber |
setName |
setPagerNumber |
setPassword |
setPhoneNumber |
setPostalAddress |
setVoiceMailNumber |
ToString |
update | Updates this user account information on the StarTeam server.

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.copy Method

Creates a copy of this user account.

public virtual MyUserAccount copy();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.Equals Method

public override bool Equals(
Object source
);

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getEmailAddress Method

Returns the user's email address.

public virtual string getEmailAddress();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getFaxNumber Method

Returns the user's fax number.

public virtual string getFaxNumber();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.GetHashCode Method

public override int GetHashCode();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getID Method

Returns the integer that represents this user account.

public virtual int getID();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getLogOnName Method

Returns ths user's logon name.

public virtual string getLogOnName();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getMinimumPasswordLength Method

Returns the minimum required password length.

public virtual int getMinimumPasswordLength();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getName Method

Returns the full name that this user goes by.

public virtual string getName();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getPagerNumber Method

Returns the user's pager number.

public virtual string getPagerNumber();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getPasswordChangeRequired Method

Determines whether or not a password change is required during the current session. If the password is not changed, the user will lose access to the StarTeam server.

public virtual bool getPasswordChangeRequired();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getPasswordDaysRemaining Method

Returns the number of days remaining that the user's current password will remain valid.

public virtual int getPasswordDaysRemaining();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getPhoneNumber Method

Returns the user's phone number.

public virtual string getPhoneNumber();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getPostalAddress Method

Returns the user's postal address.

public virtual string getPostalAddress();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.getVoiceMailNumber Method

Return the user's voice mail number.

public virtual string getVoiceMailNumber();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.isEqualTo Method

Compares two user account objects.

public virtual bool isEqualTo(
MyUserAccount account
);

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.MemberwiseClone Method

public override object MemberwiseClone();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.setEmailAddress Method

public virtual void setEmailAddress(
String emailAddress
);

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.setFaxNumber Method

public virtual void setFaxNumber(
String faxNumber
);

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.setName Method

public virtual void setName(
String name
);

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.setPagerNumber Method

public virtual void setPagerNumber(
String pagerNumber
);

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.setPassword Method

public virtual void setPassword(
String password
);

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.setPhoneNumber Method

public virtual void setPhoneNumber(
String phoneNumber
);

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.setPostalAddress Method

public virtual void setPostalAddress(
String postalAddress
);

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.setVoiceMailNumber Method

public virtual void setVoiceMailNumber(
String voiceMailNumber
);

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.ToString Method

public override string ToString();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MyUserAccount.update Method

Updates this user account information on the StarTeam server.

public virtual void update();

See Also

MyUserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoKeywords Class

For a list of all members of this type, see NoKeywords Members.

System.Object
SimpleKeyword
NoKeywords

public class NoKeywords : SimpleKeyword

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

NoKeywords Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoKeywords Members

NoKeywords overview

Public Instance Constructors

NoKeywords Constructor Creates a instance of this class.

Public Instance Methods

Equals |
expand |
GetHashCode |
getName (inherited from SimpleKeyword) |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue (inherited from SimpleKeyword) |
matches (inherited from SimpleKeyword) |
MemberwiseClone (inherited from SimpleKeyword) |
multiLine (inherited from SimpleKeyword) |
stopExpanding |
ToString (inherited from SimpleKeyword) |
toXMLString (inherited from SimpleKeyword) |

See Also

NoKeywords Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoKeywords Constructor

Creates a instance of this class.

public NoKeywords();

See Also

NoKeywords Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoKeywords Methods

The methods of the NoKeywords class are listed below. For a complete list of NoKeywords class members, see the NoKeywords Members topic.

Public Instance Methods

Equals |
expand |
GetHashCode |
getName (inherited from SimpleKeyword) |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue (inherited from SimpleKeyword) |
matches (inherited from SimpleKeyword) |
MemberwiseClone (inherited from SimpleKeyword) |
multiLine (inherited from SimpleKeyword) |
stopExpanding |
ToString (inherited from SimpleKeyword) |
toXMLString (inherited from SimpleKeyword) |

See Also

NoKeywords Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoKeywords.Equals Method

public override bool Equals(
Object source
);

See Also

NoKeywords Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoKeywords.expand Method

public override string expand(
String linePrefix,
String eol,
Boolean expand
);

Implements

Keyword.expand

See Also

NoKeywords Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoKeywords.GetHashCode Method

public override int GetHashCode();

See Also

NoKeywords Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoKeywords.stopExpanding Method

public override bool stopExpanding();

Implements

Keyword.stopExpanding

See Also

NoKeywords Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException Class

For a list of all members of this type, see NoSuchPropertyException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
NoSuchPropertyException

public class NoSuchPropertyException : RuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

NoSuchPropertyException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException Members

NoSuchPropertyException overview

Public Static Methods

wrap

Public Instance Constructors

NoSuchPropertyException Overloaded. Initializes a new instance of the NoSuchPropertyException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
getPropertyID |
getPropertyName |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException Constructor

Overload List

public NoSuchPropertyException(String);

public NoSuchPropertyException(String,Int32);

public NoSuchPropertyException(String,String);

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException Constructor (String)

public NoSuchPropertyException(
String message
);

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace | NoSuchPropertyException Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException Constructor (String, String)

public NoSuchPropertyException(
String typeName,
String propertyName
);

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace | NoSuchPropertyException Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException Constructor (String, Int32)

public NoSuchPropertyException(
String typeName,
Int32 nPropertyID
);

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace | NoSuchPropertyException Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException Methods

The methods of the NoSuchPropertyException class are listed below. For a complete list of NoSuchPropertyException class members, see the NoSuchPropertyException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
getPropertyID |
getPropertyName |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException.Equals Method

public override bool Equals(
Object source
);

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException.GetHashCode Method

public override int GetHashCode();

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException.getMessage Method

public override string getMessage();

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException.getPropertyID Method

public virtual int getPropertyID();

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException.getPropertyName Method

public virtual string getPropertyName();

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException.unwrap Method

public virtual NoSuchPropertyException unwrap();

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NoSuchPropertyException.wrap Method

public static NoSuchPropertyException wrap(
NoSuchPropertyException arg
);

See Also

NoSuchPropertyException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationAdapter Class

For a list of all members of this type, see NotificationAdapter Members.

System.Object
NotificationAdapter

public class NotificationAdapter : NotificationListener, IItemListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

NotificationAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationAdapter Members

NotificationAdapter overview

Public Instance Constructors

NotificationAdapter Constructor Initializes a new instance of the NotificationAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
notify |
ToString |

See Also

NotificationAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationAdapter Constructor

Initializes a new instance of the NotificationAdapter class.

public NotificationAdapter();

See Also

NotificationAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationAdapter Methods

The methods of the NotificationAdapter class are listed below. For a complete list of NotificationAdapter class members, see the NotificationAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
notify |
ToString |

See Also

NotificationAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

NotificationAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationAdapter.notify Method

public override void notify(
NotificationEvent e
);

Implements

NotificationListener.notify

See Also

NotificationAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationAdapter.ToString Method

public override string ToString();

See Also

NotificationAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationEvent Class

For a list of all members of this type, see NotificationEvent Members.

System.Object
EventObject
NotificationEvent

public class NotificationEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

NotificationEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationEvent Members

NotificationEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
getItem | Gets the Item whose notification state has changed. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy.
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

NotificationEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationEvent Methods

The methods of the NotificationEvent class are listed below. For a complete list of NotificationEvent class members, see the NotificationEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
getItem | Gets the Item whose notification state has changed. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy.
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

NotificationEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationEvent.Equals Method

public override bool Equals(
Object source
);

See Also

NotificationEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationEvent.GetHashCode Method

public override int GetHashCode();

See Also

NotificationEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationEvent.getItem Method

Gets the Item whose notification state has changed. <p> Item.getParentItem() will return a valid parent Folder object. For performance reasons, the same Folder object may be modified and re-used in subsequent events. If an application wants to modify the Folder, or save its state for later use, it should make its own private copy.

public virtual Item getItem();

See Also

NotificationEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationEvent.getSource Method

public override object getSource();

See Also

NotificationEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

NotificationEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationEvent.ToString Method

public override string ToString();

See Also

NotificationEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem Class

For a list of all members of this type, see NotificationItem Members.

System.Object
NotificationItem

public class NotificationItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

NotificationItem Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem Members

NotificationItem overview

Public Instance Methods

Equals |
GetHashCode |
getItemID | Returns the notification item's item ID.
getItemObjectID | Returns the notification item's object ID.
getParentFolderItemID | Returns the item ID of the notification item's parent folder.
getType | Returns the type of the notification item.
GetType (inherited from Object) | Gets the Type of the current instance.
getView | Returns the view in which the notification item lives.
MemberwiseClone |
ToString |

See Also

NotificationItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem Methods

The methods of the NotificationItem class are listed below. For a complete list of NotificationItem class members, see the NotificationItem Members topic.

Public Instance Methods

Equals |
GetHashCode |
getItemID | Returns the notification item's item ID.
getItemObjectID | Returns the notification item's object ID.
getParentFolderItemID | Returns the item ID of the notification item's parent folder.
getType | Returns the type of the notification item.
GetType (inherited from Object) | Gets the Type of the current instance.
getView | Returns the view in which the notification item lives.
MemberwiseClone |
ToString |

See Also

NotificationItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem.Equals Method

public override bool Equals(
Object source
);

See Also

NotificationItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem.GetHashCode Method

public override int GetHashCode();

See Also

NotificationItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem.getItemID Method

Returns the notification item's item ID.

public virtual int getItemID();

See Also

NotificationItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem.getItemObjectID Method

Returns the notification item's object ID.

public virtual int getItemObjectID();

See Also

NotificationItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem.getParentFolderItemID Method

Returns the item ID of the notification item's parent folder.

public virtual int getParentFolderItemID();

See Also

NotificationItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem.getType Method

Returns the type of the notification item.

public virtual Type getType();

See Also

NotificationItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem.getView Method

Returns the view in which the notification item lives.

public virtual View getView();

See Also

NotificationItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem.MemberwiseClone Method

public override object MemberwiseClone();

See Also

NotificationItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationItem.ToString Method

public override string ToString();

See Also

NotificationItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationListener Interface

For a list of all members of this type, see NotificationListener Members.

public interface NotificationListener : IItemListener, EventListener

Types that implement NotificationListener

Type | Description
NotificationAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

NotificationListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationListener Members

NotificationListener overview

Public Instance Methods

notify Invoked whenever a new "notification" for the logged-in user is available on the Server.

See Also

NotificationListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationListener Methods

The methods of the NotificationListener interface are listed below. For a complete list of NotificationListener interface members, see the NotificationListener Members topic.

Public Instance Methods

notify Invoked whenever a new "notification" for the logged-in user is available on the Server.

See Also

NotificationListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NotificationListener.notify Method

Invoked whenever a new "notification" for the logged-in user is available on the Server.

void notify(
NotificationEvent e
);

See Also

NotificationListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ObjectACLSecLogID Class

For a list of all members of this type, see ObjectACLSecLogID Members.

System.Object
ObjectACLSecLogID

public class ObjectACLSecLogID

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ObjectACLSecLogID Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ObjectACLSecLogID Members

ObjectACLSecLogID overview

Public Instance Methods

Equals |
getClassID | Returns the class id.
GetHashCode |
getObjectID | Returns the object id.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ObjectACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ObjectACLSecLogID Methods

The methods of the ObjectACLSecLogID class are listed below. For a complete list of ObjectACLSecLogID class members, see the ObjectACLSecLogID Members topic.

Public Instance Methods

Equals |
getClassID | Returns the class id.
GetHashCode |
getObjectID | Returns the object id.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ObjectACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ObjectACLSecLogID.Equals Method

public override bool Equals(
Object source
);

See Also

ObjectACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ObjectACLSecLogID.getClassID Method

Returns the class id.

public virtual int getClassID();

See Also

ObjectACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ObjectACLSecLogID.GetHashCode Method

public override int GetHashCode();

See Also

ObjectACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ObjectACLSecLogID.getObjectID Method

Returns the object id.

public virtual int getObjectID();

See Also

ObjectACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ObjectACLSecLogID.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ObjectACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ObjectACLSecLogID.ToString Method

public override string ToString();

See Also

ObjectACLSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PasswordExpiredException Class

For a list of all members of this type, see PasswordExpiredException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
ServerException
LogonException
PasswordExpiredException

public class PasswordExpiredException : LogonException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

PasswordExpiredException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PasswordExpiredException Members

PasswordExpiredException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
isUserNameValid (inherited from LogonException) |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |

See Also

PasswordExpiredException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PasswordExpiredException Methods

The methods of the PasswordExpiredException class are listed below. For a complete list of PasswordExpiredException class members, see the PasswordExpiredException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
isUserNameValid (inherited from LogonException) |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |

See Also

PasswordExpiredException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PasswordExpiredException.Equals Method

public override bool Equals(
Object source
);

See Also

PasswordExpiredException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PasswordExpiredException.GetHashCode Method

public override int GetHashCode();

See Also

PasswordExpiredException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PasswordExpiredException.getMessage Method

public override string getMessage();

See Also

PasswordExpiredException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PasswordExpiredException.wrap Method

public static PasswordExpiredException wrap(
PasswordExpiredException arg
);

See Also

PasswordExpiredException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission Class

For a list of all members of this type, see Permission Members.

System.Object
Permission

public class Permission

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Permission Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission Members

Permission overview

Public Static Fields

ALL
COMPONENT_CREATE_FILTERS
COMPONENT_CREATE_QUERIES
FILE_CHECKIN
FILE_CHECKOUT
GENERIC_AQUIRE_OWNERSHIP
GENERIC_CHANGE_ACCESS_RIGHTS
GENERIC_CREATE_NEW_OBJECT
GENERIC_DELETE_OBJECT
GENERIC_MODIFY_OBJECT
GENERIC_PURGE_OBJECT
GENERIC_SEE_OBJECT
ITEM_ADD_LABEL
ITEM_ADD_TO_REVISION_LABEL
ITEM_ADD_TO_VIEW_LABEL
ITEM_ADJUST_LABEL
ITEM_BREAK_EXCLUSIVE_LOCK
ITEM_CREATE_LINKS
ITEM_DELETE_LINKS
ITEM_DETACH_FROM_REVISION_LABEL
ITEM_DETACH_FROM_VIEW_LABEL
ITEM_DETACH_LABEL
ITEM_LOCK_EXCLUSIVELY
ITEM_MODIFY_BEHAVIOR
ITEM_MODIFY_LINKS
ITEM_PERFORM_MAINTENANCE
ITEM_SEE_HISTORY
ITEM_SEE_LINKS
ITEM_SHARE_MOVE
PROMOTION_STATE_MODIFY_STATUS
SERVER_ADD_COLLABORATION_USER
SERVER_ADMIN_REMOTELY
SERVER_ADMIN_USER_ACCOUNTS
SERVER_ADMINISTER_COMPONENT_RIGHTS
SERVER_CREATE_PROJECT
SERVER_MODIFY_CONFIGURATION
SERVER_MODIFY_SCHEMA
SERVER_MODIFY_SYSTEM_POLICY
SERVER_REPLICATION_RIGHTS
SERVER_VIEW_COMMAND_STATS
SERVER_VIEW_CONFIGURATION
SERVER_VIEW_DIAGNOSTICS
SERVER_VIEW_LOG
SERVER_VIEW_SECURITY_LOG
SERVER_VIEW_SYSTEM_POLICY
VIEW_CREATE_LABEL
VIEW_CREATE_REVISION_LABEL
VIEW_CREATE_VIEW_LABEL
VIEW_DEFINE_PROMOTION_MODEL
VIEW_DELETE_LABEL
VIEW_DELETE_REVISION_LABEL
VIEW_DELETE_VIEW_LABEL
VIEW_EDIT_LABEL
VIEW_EDIT_REVISION_LABEL
VIEW_EDIT_VIEW_LABEL
VIEW_MODIFY_PROMOTION_STATUS
VIEW_OVERRIDE_DEFAULT_TYPES

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission Fields

The fields of the Permission class are listed below. For a complete list of Permission class members, see the Permission Members topic.

Public Static Fields

ALL
COMPONENT_CREATE_FILTERS
COMPONENT_CREATE_QUERIES
FILE_CHECKIN
FILE_CHECKOUT
GENERIC_AQUIRE_OWNERSHIP
GENERIC_CHANGE_ACCESS_RIGHTS
GENERIC_CREATE_NEW_OBJECT
GENERIC_DELETE_OBJECT
GENERIC_MODIFY_OBJECT
GENERIC_PURGE_OBJECT
GENERIC_SEE_OBJECT
ITEM_ADD_LABEL
ITEM_ADD_TO_REVISION_LABEL
ITEM_ADD_TO_VIEW_LABEL
ITEM_ADJUST_LABEL
ITEM_BREAK_EXCLUSIVE_LOCK
ITEM_CREATE_LINKS
ITEM_DELETE_LINKS
ITEM_DETACH_FROM_REVISION_LABEL
ITEM_DETACH_FROM_VIEW_LABEL
ITEM_DETACH_LABEL
ITEM_LOCK_EXCLUSIVELY
ITEM_MODIFY_BEHAVIOR
ITEM_MODIFY_LINKS
ITEM_PERFORM_MAINTENANCE
ITEM_SEE_HISTORY
ITEM_SEE_LINKS
ITEM_SHARE_MOVE
PROMOTION_STATE_MODIFY_STATUS
SERVER_ADD_COLLABORATION_USER
SERVER_ADMIN_REMOTELY
SERVER_ADMIN_USER_ACCOUNTS
SERVER_ADMINISTER_COMPONENT_RIGHTS
SERVER_CREATE_PROJECT
SERVER_MODIFY_CONFIGURATION
SERVER_MODIFY_SCHEMA
SERVER_MODIFY_SYSTEM_POLICY
SERVER_REPLICATION_RIGHTS
SERVER_VIEW_COMMAND_STATS
SERVER_VIEW_CONFIGURATION
SERVER_VIEW_DIAGNOSTICS
SERVER_VIEW_LOG
SERVER_VIEW_SECURITY_LOG
SERVER_VIEW_SYSTEM_POLICY
VIEW_CREATE_LABEL
VIEW_CREATE_REVISION_LABEL
VIEW_CREATE_VIEW_LABEL
VIEW_DEFINE_PROMOTION_MODEL
VIEW_DELETE_LABEL
VIEW_DELETE_REVISION_LABEL
VIEW_DELETE_VIEW_LABEL
VIEW_EDIT_LABEL
VIEW_EDIT_REVISION_LABEL
VIEW_EDIT_VIEW_LABEL
VIEW_MODIFY_PROMOTION_STATUS
VIEW_OVERRIDE_DEFAULT_TYPES

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ALL Field

public const Int32 ALL = -1;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.COMPONENT_CREATE_FILTERS Field

public const Int32 COMPONENT_CREATE_FILTERS = 3145728;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.COMPONENT_CREATE_QUERIES Field

public const Int32 COMPONENT_CREATE_QUERIES = 4194304;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.FILE_CHECKIN Field

public const Int32 FILE_CHECKIN = 1048576;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.FILE_CHECKOUT Field

public const Int32 FILE_CHECKOUT = 2097152;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.GENERIC_AQUIRE_OWNERSHIP Field

public const Int32 GENERIC_AQUIRE_OWNERSHIP = 1;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.GENERIC_CHANGE_ACCESS_RIGHTS Field

public const Int32 GENERIC_CHANGE_ACCESS_RIGHTS = 2;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.GENERIC_CREATE_NEW_OBJECT Field

public const Int32 GENERIC_CREATE_NEW_OBJECT = 256;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.GENERIC_DELETE_OBJECT Field

public const Int32 GENERIC_DELETE_OBJECT = 64;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.GENERIC_MODIFY_OBJECT Field

public const Int32 GENERIC_MODIFY_OBJECT = 32;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.GENERIC_PURGE_OBJECT Field

public const Int32 GENERIC_PURGE_OBJECT = 128;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.GENERIC_SEE_OBJECT Field

public const Int32 GENERIC_SEE_OBJECT = 16;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_ADD_LABEL Field

public const Int32 ITEM_ADD_LABEL = 16384;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_ADD_TO_REVISION_LABEL Field

public const Int32 ITEM_ADD_TO_REVISION_LABEL = 67108864;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_ADD_TO_VIEW_LABEL Field

public const Int32 ITEM_ADD_TO_VIEW_LABEL = 16384;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_ADJUST_LABEL Field

public const Int32 ITEM_ADJUST_LABEL = 32768;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_BREAK_EXCLUSIVE_LOCK Field

public const Int32 ITEM_BREAK_EXCLUSIVE_LOCK = 8;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_CREATE_LINKS Field

public const Int32 ITEM_CREATE_LINKS = 131072;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_DELETE_LINKS Field

public const Int32 ITEM_DELETE_LINKS = 524288;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_DETACH_FROM_REVISION_LABEL Field

public const Int32 ITEM_DETACH_FROM_REVISION_LABEL = 134217728;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_DETACH_FROM_VIEW_LABEL Field

public const Int32 ITEM_DETACH_FROM_VIEW_LABEL = 65536;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_DETACH_LABEL Field

public const Int32 ITEM_DETACH_LABEL = 65536;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_LOCK_EXCLUSIVELY Field

public const Int32 ITEM_LOCK_EXCLUSIVELY = 4;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_MODIFY_BEHAVIOR Field

public const Int32 ITEM_MODIFY_BEHAVIOR = 1024;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_MODIFY_LINKS Field

public const Int32 ITEM_MODIFY_LINKS = 262144;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_PERFORM_MAINTENANCE Field

public const Int32 ITEM_PERFORM_MAINTENANCE = 2048;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_SEE_HISTORY Field

public const Int32 ITEM_SEE_HISTORY = 4096;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_SEE_LINKS Field

public const Int32 ITEM_SEE_LINKS = 8192;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.ITEM_SHARE_MOVE Field

public const Int32 ITEM_SHARE_MOVE = 512;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.PROMOTION_STATE_MODIFY_STATUS Field

public const Int32 PROMOTION_STATE_MODIFY_STATUS = 131072;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_ADD_COLLABORATION_USER Field

public const Int32 SERVER_ADD_COLLABORATION_USER = 536870912;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_ADMIN_REMOTELY Field

public const Int32 SERVER_ADMIN_REMOTELY = 67108864;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_ADMIN_USER_ACCOUNTS Field

public const Int32 SERVER_ADMIN_USER_ACCOUNTS = 134217728;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_ADMINISTER_COMPONENT_RIGHTS Field

public const Int32 SERVER_ADMINISTER_COMPONENT_RIGHTS = 131072;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_CREATE_PROJECT Field

public const Int32 SERVER_CREATE_PROJECT = 65536;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_MODIFY_CONFIGURATION Field

public const Int32 SERVER_MODIFY_CONFIGURATION = 8388608;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_MODIFY_SCHEMA Field

public const Int32 SERVER_MODIFY_SCHEMA = 4096;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_MODIFY_SYSTEM_POLICY Field

public const Int32 SERVER_MODIFY_SYSTEM_POLICY = 33554432;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_REPLICATION_RIGHTS Field

public const Int32 SERVER_REPLICATION_RIGHTS = 524288;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_VIEW_COMMAND_STATS Field

public const Int32 SERVER_VIEW_COMMAND_STATS = 1073741824;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_VIEW_CONFIGURATION Field

public const Int32 SERVER_VIEW_CONFIGURATION = 4194304;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_VIEW_DIAGNOSTICS Field

public const Int32 SERVER_VIEW_DIAGNOSTICS = 2097152;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_VIEW_LOG Field

public const Int32 SERVER_VIEW_LOG = 1048576;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_VIEW_SECURITY_LOG Field

public const Int32 SERVER_VIEW_SECURITY_LOG = 268435456;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.SERVER_VIEW_SYSTEM_POLICY Field

public const Int32 SERVER_VIEW_SYSTEM_POLICY = 16777216;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_CREATE_LABEL Field

public const Int32 VIEW_CREATE_LABEL = 1048576;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_CREATE_REVISION_LABEL Field

public const Int32 VIEW_CREATE_REVISION_LABEL = 65536;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_CREATE_VIEW_LABEL Field

public const Int32 VIEW_CREATE_VIEW_LABEL = 1048576;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_DEFINE_PROMOTION_MODEL Field

public const Int32 VIEW_DEFINE_PROMOTION_MODEL = 16777216;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_DELETE_LABEL Field

public const Int32 VIEW_DELETE_LABEL = 4194304;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_DELETE_REVISION_LABEL Field

public const Int32 VIEW_DELETE_REVISION_LABEL = 262144;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_DELETE_VIEW_LABEL Field

public const Int32 VIEW_DELETE_VIEW_LABEL = 4194304;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_EDIT_LABEL Field

public const Int32 VIEW_EDIT_LABEL = 2097152;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_EDIT_REVISION_LABEL Field

public const Int32 VIEW_EDIT_REVISION_LABEL = 131072;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_EDIT_VIEW_LABEL Field

public const Int32 VIEW_EDIT_VIEW_LABEL = 2097152;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_MODIFY_PROMOTION_STATUS Field

public const Int32 VIEW_MODIFY_PROMOTION_STATUS = 33554432;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Permission.VIEW_OVERRIDE_DEFAULT_TYPES Field

public const Int32 VIEW_OVERRIDE_DEFAULT_TYPES = 268435456;

See Also

Permission Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem Class

For a list of all members of this type, see ProcessItem Members.

System.Object
ProcessItem

public class ProcessItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ProcessItem Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem Members

ProcessItem overview

Public Static Methods

getActiveProcessItems | Overloaded.
getProcessItemTypes | Gets the list of item types that are legal process item types for the given target view.

Public Instance Constructors

ProcessItem Overloaded. Initializes a new instance of the ProcessItem class.

Public Instance Methods

Equals |
getAllProcessTasks | Gets the list of process tasks associated with this process item in its target view.
getAllProcessTasksInAnyView | Gets the list of process tasks associated with this process item.
getAllProcessTasksInProgress | Gets the list of process tasks in progress in the target view.
GetHashCode |
getItem | Gets the underlying item.
getProcessTaskInProgress | Gets the process task in progress in the target view.
getTargetView | Gets the target view.
GetType (inherited from Object) | Gets the Type of the current instance.
isActiveState | Determines whether or not this process item is a legal process item for its target view, and is in a legal state to be selected as an active process item for that view.
isEnhanced | Determines whether or not this process item follows the rules of the enhanced process item model in the context of its target view. <p> In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task.
isLegalType | Determines whether or not this process item is a legal type of process item for its target view. <p> Note that even if this is a legal type of process item, it is not necessarily in a legal state to be selected as an active process item.
isSelectable | Determines whether or not this process item is in a state that allows it to be selected as the active process item for its target view.
MemberwiseClone |
resolve | Resolves this process item in the context of its target view.
ToString |
verifyIsSelectable | Verifies that this process item is in a state that allows it to be selected as the active process item for its target view.

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem Constructor

Constructs a process item. Assumes that the item resides in the target view.

Overload List

Constructs a process item. Assumes that the item resides in the target view.

public ProcessItem(Item);

public ProcessItem(Item,View);

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem Constructor (Item)

Constructs a process item. Assumes that the item resides in the target view.

public ProcessItem(
Item item
);

See Also

ProcessItem Class | com.starbase.starteam Namespace | ProcessItem Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem Constructor (Item, View)

public ProcessItem(
Item item,
View target
);

See Also

ProcessItem Class | com.starbase.starteam Namespace | ProcessItem Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem Methods

The methods of the ProcessItem class are listed below. For a complete list of ProcessItem class members, see the ProcessItem Members topic.

Public Static Methods

getActiveProcessItems | Overloaded.
getProcessItemTypes | Gets the list of item types that are legal process item types for the given target view.

Public Instance Methods

Equals |
getAllProcessTasks | Gets the list of process tasks associated with this process item in its target view.
getAllProcessTasksInAnyView | Gets the list of process tasks associated with this process item.
getAllProcessTasksInProgress | Gets the list of process tasks in progress in the target view.
GetHashCode |
getItem | Gets the underlying item.
getProcessTaskInProgress | Gets the process task in progress in the target view.
getTargetView | Gets the target view.
GetType (inherited from Object) | Gets the Type of the current instance.
isActiveState | Determines whether or not this process item is a legal process item for its target view, and is in a legal state to be selected as an active process item for that view.
isEnhanced | Determines whether or not this process item follows the rules of the enhanced process item model in the context of its target view. <p> In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task.
isLegalType | Determines whether or not this process item is a legal type of process item for its target view. <p> Note that even if this is a legal type of process item, it is not necessarily in a legal state to be selected as an active process item.
isSelectable | Determines whether or not this process item is in a state that allows it to be selected as the active process item for its target view.
MemberwiseClone |
resolve | Resolves this process item in the context of its target view.
ToString |
verifyIsSelectable | Verifies that this process item is in a state that allows it to be selected as the active process item for its target view.

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.Equals Method

public override bool Equals(
Object another
);

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


getActiveProcessItems Method

Borland StarTeam SDK for .NET

ProcessItem.getActiveProcessItems Method

Overload List

public static ItemList getActiveProcessItems(Type,View);

public static ItemList getActiveProcessItems(Type,View,Folder,Int32);

public static ItemList getActiveProcessItems(Type,View,View);

public static ItemList getActiveProcessItems(View,ItemListManager);

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.getActiveProcessItems Method (Type, View)

public static ItemList getActiveProcessItems(
Type type,
View view
);

See Also

ProcessItem Class | com.starbase.starteam Namespace | ProcessItem.getActiveProcessItems Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.getActiveProcessItems Method (Type, View, Folder, Int32)

public static ItemList getActiveProcessItems(
Type type,
View target,
Folder source,
Int32 depth
);

See Also

ProcessItem Class | com.starbase.starteam Namespace | ProcessItem.getActiveProcessItems Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.getActiveProcessItems Method (Type, View, View)

public static ItemList getActiveProcessItems(
Type type,
View target,
View source
);

See Also

ProcessItem Class | com.starbase.starteam Namespace | ProcessItem.getActiveProcessItems Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.getActiveProcessItems Method (View, ItemListManager)

public static ItemList getActiveProcessItems(
View target,
ItemListManager source
);

See Also

ProcessItem Class | com.starbase.starteam Namespace | ProcessItem.getActiveProcessItems Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.getAllProcessTasks Method

Gets the list of process tasks associated with this process item in its target view.

public virtual Item[] getAllProcessTasks();

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.getAllProcessTasksInAnyView Method

Gets the list of process tasks associated with this process item.

public virtual Item[] getAllProcessTasksInAnyView();

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.getAllProcessTasksInProgress Method

Gets the list of process tasks in progress in the target view.

public virtual Item[] getAllProcessTasksInProgress(
ProcessItemUsage usage
);

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.GetHashCode Method

public override int GetHashCode();

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.getItem Method

Gets the underlying item.

public virtual Item getItem();

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.getProcessItemTypes Method

Gets the list of item types that are legal process item types for the given target view.

public static Type[] getProcessItemTypes(
View targetView
);

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.getProcessTaskInProgress Method

Gets the process task in progress in the target view.

public virtual Item getProcessTaskInProgress(
ProcessItemUsage usage
);

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.getTargetView Method

Gets the target view.

public virtual View getTargetView();

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.isActiveState Method

Determines whether or not this process item is a legal process item for its target view, and is in a legal state to be selected as an active process item for that view.

public virtual bool isActiveState();

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.isEnhanced Method

Determines whether or not this process item follows the rules of the enhanced process item model in the context of its target view. <p> In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task.

public virtual bool isEnhanced();

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.isLegalType Method

Determines whether or not this process item is a legal type of process item for its target view. <p> Note that even if this is a legal type of process item, it is not necessarily in a legal state to be selected as an active process item.

public virtual bool isLegalType();

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.isSelectable Method

Determines whether or not this process item is in a state that allows it to be selected as the active process item for its target view.

public virtual bool isSelectable(
ProcessItemUsage usage
);

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.resolve Method

Resolves this process item in the context of its target view.

public virtual Item[] resolve();

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.ToString Method

public override string ToString();

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItem.verifyIsSelectable Method

Verifies that this process item is in a state that allows it to be selected as the active process item for its target view.

public virtual void verifyIsSelectable(
ProcessItemUsage usage
);

See Also

ProcessItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemUsage Class

For a list of all members of this type, see ProcessItemUsage Members.

System.Object
EnumeratedValue
ProcessItemUsage

public class ProcessItemUsage : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ProcessItemUsage Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemUsage Members

ProcessItemUsage overview

Public Static Fields

CHECKIN
OTHER
PROMOTE
REBASE
REPLICATE

Public Instance Methods

copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Equals (inherited from EnumeratedValue) |
getCode (inherited from EnumeratedValue) | Return the enum code for this object.
getDescription (inherited from EnumeratedValue) | Returns the description of this object. This may return null if the object was created using a Translations.
getDisplayName (inherited from EnumeratedValue) | Returns the locale appropriate display name for the enumerated value.
getEnabled (inherited from EnumeratedValue) | Return true if this enumerated value is enabled.
GetHashCode (inherited from EnumeratedValue) |
getSortOrder (inherited from EnumeratedValue) | Get the sort order of this enumerated value.
getTranslations (inherited from EnumeratedValue) | Returns the display name translations for this enumerated value. May return null if this was created usng a single description string.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from EnumeratedValue) |
setCode (inherited from EnumeratedValue) |
setDescription (inherited from EnumeratedValue) |
setEnabled (inherited from EnumeratedValue) |
setTranslations (inherited from EnumeratedValue) | Sets the display name translations for this enumerated value.
ToString (inherited from EnumeratedValue) |

See Also

ProcessItemUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemUsage Fields

The fields of the ProcessItemUsage class are listed below. For a complete list of ProcessItemUsage class members, see the ProcessItemUsage Members topic.

Public Static Fields

CHECKIN
OTHER
PROMOTE
REBASE
REPLICATE

See Also

ProcessItemUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemUsage.CHECKIN Field

public static readonly ProcessItemUsage CHECKIN;

See Also

ProcessItemUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemUsage.OTHER Field

public static readonly ProcessItemUsage OTHER;

See Also

ProcessItemUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemUsage.PROMOTE Field

public static readonly ProcessItemUsage PROMOTE;

See Also

ProcessItemUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemUsage.REBASE Field

public static readonly ProcessItemUsage REBASE;

See Also

ProcessItemUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemUsage.REPLICATE Field

public static readonly ProcessItemUsage REPLICATE;

See Also

ProcessItemUsage Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes Class

For a list of all members of this type, see ProductCodes Members.

System.Object
ProductCodes

public class ProductCodes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ProductCodes Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes Members

ProductCodes overview

Public Static Fields

CUSTOMIZATION
ELITE
ENTERPRISE
MPX
REQUIREMENTS
STANDARD
STARDISK
TASKS

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes Fields

The fields of the ProductCodes class are listed below. For a complete list of ProductCodes class members, see the ProductCodes Members topic.

Public Static Fields

CUSTOMIZATION
ELITE
ENTERPRISE
MPX
REQUIREMENTS
STANDARD
STARDISK
TASKS

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes.CUSTOMIZATION Field

public const Int32 CUSTOMIZATION = 37;

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes.ELITE Field

public const Int32 ELITE = 40;

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes.ENTERPRISE Field

public const Int32 ENTERPRISE = 36;

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes.MPX Field

public const Int32 MPX = 42;

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes.REQUIREMENTS Field

public const Int32 REQUIREMENTS = 39;

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes.STANDARD Field

public const Int32 STANDARD = 31;

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes.STARDISK Field

public const Int32 STARDISK = 35;

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes.TASKS Field

public const Int32 TASKS = 38;

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes Methods

The methods of the ProductCodes class are listed below. For a complete list of ProductCodes class members, see the ProductCodes Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProductCodes.ToString Method

public override string ToString();

See Also

ProductCodes Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project Class

For a list of all members of this type, see Project Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Project

public class Project : SimpleTypedResource, ISecurableObject, ISecurable, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Project Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project Members

Project overview

Public Instance Constructors

Project Overloaded. Initializes a new instance of the Project class.

Public Instance Methods

acquireOwnership |
addProjectListener | Adds a listener for Project events. <p> Event handlers will be tiggered if this Project is changed or deleted on the Server. <p> In order to handle events, an application must enable MPX.
addToIntArray (inherited from TypedResource) |
addViewListener | Adds a listener for View events. <p> Event handlers will be tiggered whenever a View is added, changed or deleted in this Project. Note that an application will not receive events for Views that the logged-in user does not have permission to access. <p> In order to handle events, an application must enable MPX.
Clone (inherited from CacheRef) |
copy | Creates a copy of this Project object, with project properties fully populated. Useful to applications that want to save a snapshot of the Project in a given state, for example, before calling refresh().
discard | Discards all of the cached properties for this project. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of a project are changed, and discard() is called without first calling update(), the changes will be lost.
Equals |
get |
getAccessibleViews | Gets the set of Views accessible from this Project. <p> The view list is not cached in the Project object. Each call to getViews() returns an up-to-date view list consisting of newly allocated View objects. <p> If MPX is enabled, getViews() is optimized to avoid unnecessary server commands.
getACL |
getByteArray (inherited from SimpleTypedResource) |
getConfigSource1 | Returns the ConfigSource1 value. This is only meaningful for foreign archive projects.
getConfigSource2 | Returns the ConfigSource2 value. This is only meaningful for foreign archive projects.
getContainerLevelACL |
getCreatedBy | Returns the user ID of the user that created the project.
getCreatedTime | Returns the time at which the project was created.
getDefaultItemTypes | Gets the default item types that will be shared upon creation of a variant view.
getDefaultView | Gets the default View for this Project. <p> The default view is not cached in the Project object. Each call to getDefaultView() returns an up-to-date view hierarchy consisting of newly allocated View objects. <p> If MPX is enabled, getDefaultView() is optimized to avoid unnecessary server commands.
getDescription | Returns the description of this project.
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
GetHashCode |
getID |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getKeywordExpansionFileExtensions | Returns the list of file extensions upon which to perform keyword expansion. The extension list can use the wildcards * and ? and multiple extensions can be delimited by commas, spaces or semicolons. For example: "*.class, *.obj".
getName | Returns the name of this project.
getOLEDate (inherited from SimpleTypedResource) |
getOwner |
getParentContainer |
getPossibleValues (inherited from SimpleTypedResource) |
getProjectType | Returns the project type: StarTeam, VSS, PVCS
getPropertyNames (inherited from SimpleTypedResource) |
getServer | Returns the server to which this project belongs.
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getViews | Gets all the views on this Project. <p> The view list is not cached in the Project object. Each call to getViews() returns an up-to-date view list consisting of newly allocated View objects. <p> If MPX is enabled, getViews() is optimized to avoid unnecessary server commands.
goNative | Converts a foreign PVCS or VSS project to a native StarTeam project. <p> If this is a foreign project, goNative() starts a background process on the server to perform the conversion. In any case, goNative() returns immediately. <p> When the conversion completes successfully, the project type will be changed to PROJECT_TYPE_STARTEAM. Note that you may need to refresh the project properties to see the new property value. <p> If the conversion fails, the "go native" server log will contain detailed information regarding the cause of the problem.
hasPermission | Overloaded.
isActiveProcessItemStateEnabled | Determines whether or not a given status value is one that can be used for an active process item.
isDeleted | Determines whether or not this project has been deleted from the server.
isEnhancedProcessItemsEnabled | Determines whether or not the enhanced process item model is in effect for this project. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task.
isEqualTo | Compares the properties of two Projects.
isExpandKeywords | Returns true if keywords are expanded when files are checked out. Only files matching a keyword file extension will be expanded.
isForceCheckinReason | Returns true if a comment must be included with file check in operations.
isMailUsed | Return true if email is used in this project.
isNew | Returns true if this project has not yet been saved on the server. To save a project you must call update().
isProcessItemsRequired | Determines whether or not process items are required for this project.
isProcessItemTypeEnabled | Determines whether or not process items of the given type are supported for this project.
isRefreshRequired | Returns true if a refresh() operation might have resulted in project properties being updated; returns false if and only if it is known that the project properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isRequireLockForCheckin | Returns true if files must be locked before they are checked in.
MemberwiseClone (inherited from CacheRef) |
populate | Populates project properties, if they have not already been populated.
put |
putByPropertyID |
refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove | Removes the project from the server.
removeFromIntArray (inherited from TypedResource) |
removeProjectListener | Removes a listener for Project events.
removeViewListener | Removes a listener for View events.
setACL |
setActiveProcessItemStateEnabled |
setContainerLevelACL |
setDefaultItemTypes |
setDescription |
setEnhancedProcessItemsEnabled |
setExpandKeywords |
setForceCheckinReason |
setKeywordExpansionFileExtensions |
setName |
setProcessItemsRequired |
setProcessItemTypeEnabled |
setRequireLockForCheckin |
ToString |
update | Persists this project's properties to its <code>Server</code>. If this project wraps around a foreign archive, Folder hierarchy will be created according to the configuration file and archive path of the foreign archive specified.

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project Constructor

NOTE: This constructor is now obsolete.

Overload List

public Project(Server,String,String);

Obsolete.

public Project(Server,String,String,Int32,Int32,Boolean,String,Int32,String,String,Folder);

public Project(Server,String,String,Int32,Int32,Boolean,String,Int32,String,String,String);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project Constructor (Server, String, String, Int32, Int32, Boolean, String, Int32, String, String, Folder)

NOTE: This constructor is now obsolete.

public Project(
Server server,
String name,
String description,
Int32 nCompaction,
Int32 nEncryption,
Boolean bUseMail,
String rootDirectory,
Int32 projectType,
String configSource1,
String configSource2,
Folder folderTree
);

See Also

Project Class | com.starbase.starteam Namespace | Project Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project Constructor (Server, String, String, Int32, Int32, Boolean, String, Int32, String, String, String)

public Project(
Server server,
String name,
String description,
Int32 nCompaction,
Int32 nEncryption,
Boolean bUseMail,
String rootDirectory,
Int32 projectType,
String sForeignPassword,
String configFile,
String archivePath
);

See Also

Project Class | com.starbase.starteam Namespace | Project Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project Constructor (Server, String, String)

public Project(
Server server,
String name,
String rootDirectory
);

See Also

Project Class | com.starbase.starteam Namespace | Project Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project Methods

The methods of the Project class are listed below. For a complete list of Project class members, see the Project Members topic.

Public Instance Methods

acquireOwnership |
addProjectListener | Adds a listener for Project events. <p> Event handlers will be tiggered if this Project is changed or deleted on the Server. <p> In order to handle events, an application must enable MPX.
addToIntArray (inherited from TypedResource) |
addViewListener | Adds a listener for View events. <p> Event handlers will be tiggered whenever a View is added, changed or deleted in this Project. Note that an application will not receive events for Views that the logged-in user does not have permission to access. <p> In order to handle events, an application must enable MPX.
Clone (inherited from CacheRef) |
copy | Creates a copy of this Project object, with project properties fully populated. Useful to applications that want to save a snapshot of the Project in a given state, for example, before calling refresh().
discard | Discards all of the cached properties for this project. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of a project are changed, and discard() is called without first calling update(), the changes will be lost.
Equals |
get |
getAccessibleViews | Gets the set of Views accessible from this Project. <p> The view list is not cached in the Project object. Each call to getViews() returns an up-to-date view list consisting of newly allocated View objects. <p> If MPX is enabled, getViews() is optimized to avoid unnecessary server commands.
getACL |
getByteArray (inherited from SimpleTypedResource) |
getConfigSource1 | Returns the ConfigSource1 value. This is only meaningful for foreign archive projects.
getConfigSource2 | Returns the ConfigSource2 value. This is only meaningful for foreign archive projects.
getContainerLevelACL |
getCreatedBy | Returns the user ID of the user that created the project.
getCreatedTime | Returns the time at which the project was created.
getDefaultItemTypes | Gets the default item types that will be shared upon creation of a variant view.
getDefaultView | Gets the default View for this Project. <p> The default view is not cached in the Project object. Each call to getDefaultView() returns an up-to-date view hierarchy consisting of newly allocated View objects. <p> If MPX is enabled, getDefaultView() is optimized to avoid unnecessary server commands.
getDescription | Returns the description of this project.
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
GetHashCode |
getID |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getKeywordExpansionFileExtensions | Returns the list of file extensions upon which to perform keyword expansion. The extension list can use the wildcards * and ? and multiple extensions can be delimited by commas, spaces or semicolons. For example: "*.class, *.obj".
getName | Returns the name of this project.
getOLEDate (inherited from SimpleTypedResource) |
getOwner |
getParentContainer |
getPossibleValues (inherited from SimpleTypedResource) |
getProjectType | Returns the project type: StarTeam, VSS, PVCS
getPropertyNames (inherited from SimpleTypedResource) |
getServer | Returns the server to which this project belongs.
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getViews | Gets all the views on this Project. <p> The view list is not cached in the Project object. Each call to getViews() returns an up-to-date view list consisting of newly allocated View objects. <p> If MPX is enabled, getViews() is optimized to avoid unnecessary server commands.
goNative | Converts a foreign PVCS or VSS project to a native StarTeam project. <p> If this is a foreign project, goNative() starts a background process on the server to perform the conversion. In any case, goNative() returns immediately. <p> When the conversion completes successfully, the project type will be changed to PROJECT_TYPE_STARTEAM. Note that you may need to refresh the project properties to see the new property value. <p> If the conversion fails, the "go native" server log will contain detailed information regarding the cause of the problem.
hasPermission | Overloaded.
isActiveProcessItemStateEnabled | Determines whether or not a given status value is one that can be used for an active process item.
isDeleted | Determines whether or not this project has been deleted from the server.
isEnhancedProcessItemsEnabled | Determines whether or not the enhanced process item model is in effect for this project. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task.
isEqualTo | Compares the properties of two Projects.
isExpandKeywords | Returns true if keywords are expanded when files are checked out. Only files matching a keyword file extension will be expanded.
isForceCheckinReason | Returns true if a comment must be included with file check in operations.
isMailUsed | Return true if email is used in this project.
isNew | Returns true if this project has not yet been saved on the server. To save a project you must call update().
isProcessItemsRequired | Determines whether or not process items are required for this project.
isProcessItemTypeEnabled | Determines whether or not process items of the given type are supported for this project.
isRefreshRequired | Returns true if a refresh() operation might have resulted in project properties being updated; returns false if and only if it is known that the project properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isRequireLockForCheckin | Returns true if files must be locked before they are checked in.
MemberwiseClone (inherited from CacheRef) |
populate | Populates project properties, if they have not already been populated.
put |
putByPropertyID |
refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove | Removes the project from the server.
removeFromIntArray (inherited from TypedResource) |
removeProjectListener | Removes a listener for Project events.
removeViewListener | Removes a listener for View events.
setACL |
setActiveProcessItemStateEnabled |
setContainerLevelACL |
setDefaultItemTypes |
setDescription |
setEnhancedProcessItemsEnabled |
setExpandKeywords |
setForceCheckinReason |
setKeywordExpansionFileExtensions |
setName |
setProcessItemsRequired |
setProcessItemTypeEnabled |
setRequireLockForCheckin |
ToString |
update | Persists this project's properties to its <code>Server</code>. If this project wraps around a foreign archive, Folder hierarchy will be created according to the configuration file and archive path of the foreign archive specified.

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.acquireOwnership Method

public virtual void acquireOwnership();

Implements

ISecurableObject.acquireOwnership

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.addProjectListener Method

Adds a listener for Project events. <p> Event handlers will be tiggered if this Project is changed or deleted on the Server. <p> In order to handle events, an application must enable MPX.

public virtual void addProjectListener(
ProjectListener listener
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.addViewListener Method

Adds a listener for View events. <p> Event handlers will be tiggered whenever a View is added, changed or deleted in this Project. Note that an application will not receive events for Views that the logged-in user does not have permission to access. <p> In order to handle events, an application must enable MPX.

public virtual void addViewListener(
ViewListener listener
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.copy Method

Creates a copy of this Project object, with project properties fully populated. Useful to applications that want to save a snapshot of the Project in a given state, for example, before calling refresh().

public virtual Project copy();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.discard Method

Discards all of the cached properties for this project. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of a project are changed, and discard() is called without first calling update(), the changes will be lost.

public virtual void discard();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.Equals Method

public override bool Equals(
Object another
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.get Method

public override object get(
String propertyName
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getAccessibleViews Method

Gets the set of Views accessible from this Project. <p> The view list is not cached in the Project object. Each call to getViews() returns an up-to-date view list consisting of newly allocated View objects. <p> If MPX is enabled, getViews() is optimized to avoid unnecessary server commands.

public virtual View[] getAccessibleViews();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getACL Method

public virtual AclEntry[] getACL();

Implements

ISecurable.getACL

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getConfigSource1 Method

Returns the ConfigSource1 value. This is only meaningful for foreign archive projects.

public virtual string getConfigSource1();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getConfigSource2 Method

Returns the ConfigSource2 value. This is only meaningful for foreign archive projects.

public virtual string getConfigSource2();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getContainerLevelACL Method

public virtual AclEntry[] getContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.getContainerLevelACL

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getCreatedBy Method

Returns the user ID of the user that created the project.

public virtual int getCreatedBy();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getCreatedTime Method

Returns the time at which the project was created.

public virtual OLEDate getCreatedTime();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getDefaultItemTypes Method

Gets the default item types that will be shared upon creation of a variant view.

public virtual Type[] getDefaultItemTypes();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getDefaultView Method

Gets the default View for this Project. <p> The default view is not cached in the Project object. Each call to getDefaultView() returns an up-to-date view hierarchy consisting of newly allocated View objects. <p> If MPX is enabled, getDefaultView() is optimized to avoid unnecessary server commands.

public virtual View getDefaultView();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getDescription Method

Returns the description of this project.

public virtual string getDescription();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.GetHashCode Method

public override int GetHashCode();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getID Method

public override int getID();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getKeywordExpansionFileExtensions Method

Returns the list of file extensions upon which to perform keyword expansion. The extension list can use the wildcards * and ? and multiple extensions can be delimited by commas, spaces or semicolons. For example: "*.class, *.obj".

public virtual string getKeywordExpansionFileExtensions();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getName Method

Returns the name of this project.

public virtual string getName();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getOwner Method

public virtual int getOwner();

Implements

ISecurableObject.getOwner

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getParentContainer Method

public virtual ISecurableContainer getParentContainer();

Implements

ISecurableContainer.getParentContainer

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getProjectType Method

Returns the project type: StarTeam, VSS, PVCS

public virtual int getProjectType();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getServer Method

Returns the server to which this project belongs.

public virtual Server getServer();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.getViews Method

Gets all the views on this Project. <p> The view list is not cached in the Project object. Each call to getViews() returns an up-to-date view list consisting of newly allocated View objects. <p> If MPX is enabled, getViews() is optimized to avoid unnecessary server commands.

public virtual View[] getViews();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.goNative Method

Converts a foreign PVCS or VSS project to a native StarTeam project. <p> If this is a foreign project, goNative() starts a background process on the server to perform the conversion. In any case, goNative() returns immediately. <p> When the conversion completes successfully, the project type will be changed to PROJECT_TYPE_STARTEAM. Note that you may need to refresh the project properties to see the new property value. <p> If the conversion fails, the "go native" server log will contain detailed information regarding the cause of the problem.

public virtual void goNative();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


hasPermission Method

Borland StarTeam SDK for .NET

Project.hasPermission Method

Overload List

public virtual bool hasPermission(Int32);

public virtual bool hasPermission(Int32,String);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.hasPermission Method (Int32)

public virtual bool hasPermission(
Int32 permissions
);

Implements

ISecurable.hasPermission

See Also

Project Class | com.starbase.starteam Namespace | Project.hasPermission Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.hasPermission Method (Int32, String)

public virtual bool hasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.hasPermission

See Also

Project Class | com.starbase.starteam Namespace | Project.hasPermission Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isActiveProcessItemStateEnabled Method

Determines whether or not a given status value is one that can be used for an active process item.

public virtual bool isActiveProcessItemStateEnabled(
EnumeratedValue value
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isDeleted Method

Determines whether or not this project has been deleted from the server.

public virtual bool isDeleted();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isEnhancedProcessItemsEnabled Method

Determines whether or not the enhanced process item model is in effect for this project. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task.

public virtual bool isEnhancedProcessItemsEnabled();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isEqualTo Method

Compares the properties of two Projects.

public virtual bool isEqualTo(
Project project
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isExpandKeywords Method

Returns true if keywords are expanded when files are checked out. Only files matching a keyword file extension will be expanded.

public virtual bool isExpandKeywords();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isForceCheckinReason Method

Returns true if a comment must be included with file check in operations.

public virtual bool isForceCheckinReason();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isMailUsed Method

Return true if email is used in this project.

public virtual bool isMailUsed();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isNew Method

Returns true if this project has not yet been saved on the server. To save a project you must call update().

public virtual bool isNew();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isProcessItemsRequired Method

Determines whether or not process items are required for this project.

public virtual bool isProcessItemsRequired();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isProcessItemTypeEnabled Method

Determines whether or not process items of the given type are supported for this project.

public virtual bool isProcessItemTypeEnabled(
Type type
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isRefreshRequired Method

Returns true if a refresh() operation might have resulted in project properties being updated; returns false if and only if it is known that the project properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.

public virtual bool isRefreshRequired();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.isRequireLockForCheckin Method

Returns true if files must be locked before they are checked in.

public virtual bool isRequireLockForCheckin();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.populate Method

Populates project properties, if they have not already been populated.

public virtual void populate();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.put Method

public override object put(
String propertyName,
Object value
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.putByPropertyID Method

public override object putByPropertyID(
Int32 propertyID,
Object value
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.refresh Method

Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void refresh();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.remove Method

Removes the project from the server.

public virtual void remove();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.removeProjectListener Method

Removes a listener for Project events.

public virtual void removeProjectListener(
ProjectListener listener
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.removeViewListener Method

Removes a listener for View events.

public virtual void removeViewListener(
ViewListener listener
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setACL Method

public virtual void setACL(
AclEntry[] acl
);

Implements

ISecurable.setACL

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setActiveProcessItemStateEnabled Method

public virtual void setActiveProcessItemStateEnabled(
EnumeratedValue value,
Boolean isEnabled
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setContainerLevelACL Method

public virtual void setContainerLevelACL(
AclEntry[] acl,
String typeName
);

Implements

ISecurableContainer.setContainerLevelACL

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setDefaultItemTypes Method

public virtual void setDefaultItemTypes(
Type[] types
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setDescription Method

public virtual void setDescription(
String description
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setEnhancedProcessItemsEnabled Method

public virtual void setEnhancedProcessItemsEnabled(
Boolean isEnabled
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setExpandKeywords Method

public virtual void setExpandKeywords(
Boolean bExpand
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setForceCheckinReason Method

public virtual void setForceCheckinReason(
Boolean bForceComment
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setKeywordExpansionFileExtensions Method

public virtual void setKeywordExpansionFileExtensions(
String fileExtensions
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setName Method

public virtual void setName(
String name
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setProcessItemsRequired Method

public virtual void setProcessItemsRequired(
Boolean isRequired
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setProcessItemTypeEnabled Method

public virtual void setProcessItemTypeEnabled(
Type type,
Boolean isEnabled
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.setRequireLockForCheckin Method

public virtual void setRequireLockForCheckin(
Boolean bRequireLock
);

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.ToString Method

public override string ToString();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Project.update Method

Persists this project's properties to its <code>Server</code>. If this project wraps around a foreign archive, Folder hierarchy will be created according to the configuration file and archive path of the foreign archive specified.

public virtual void update();

See Also

Project Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectAdapter Class

For a list of all members of this type, see ProjectAdapter Members.

System.Object
ProjectAdapter

public class ProjectAdapter : ProjectListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ProjectAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectAdapter Members

ProjectAdapter overview

Public Instance Constructors

ProjectAdapter Constructor Initializes a new instance of the ProjectAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
projectAdded |
projectChanged |
projectDeleted |
ToString |

See Also

ProjectAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectAdapter Constructor

Initializes a new instance of the ProjectAdapter class.

public ProjectAdapter();

See Also

ProjectAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectAdapter Methods

The methods of the ProjectAdapter class are listed below. For a complete list of ProjectAdapter class members, see the ProjectAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
projectAdded |
projectChanged |
projectDeleted |
ToString |

See Also

ProjectAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ProjectAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectAdapter.projectAdded Method

public override void projectAdded(
ProjectEvent e
);

Implements

ProjectListener.projectAdded

See Also

ProjectAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectAdapter.projectChanged Method

public override void projectChanged(
ProjectEvent e
);

Implements

ProjectListener.projectChanged

See Also

ProjectAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectAdapter.projectDeleted Method

public override void projectDeleted(
ProjectEvent e
);

Implements

ProjectListener.projectDeleted

See Also

ProjectAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectAdapter.ToString Method

public override string ToString();

See Also

ProjectAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectEvent Class

For a list of all members of this type, see ProjectEvent Members.

System.Object
EventObject
ProjectEvent

public class ProjectEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ProjectEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectEvent Members

ProjectEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getProject | Gets the Project that has been added, changed or deleted, in its new state.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ProjectEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectEvent Methods

The methods of the ProjectEvent class are listed below. For a complete list of ProjectEvent class members, see the ProjectEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getProject | Gets the Project that has been added, changed or deleted, in its new state.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ProjectEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectEvent.Equals Method

public override bool Equals(
Object source
);

See Also

ProjectEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectEvent.GetHashCode Method

public override int GetHashCode();

See Also

ProjectEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectEvent.getProject Method

Gets the Project that has been added, changed or deleted, in its new state.

public virtual Project getProject();

See Also

ProjectEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectEvent.getSource Method

public override object getSource();

See Also

ProjectEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ProjectEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectEvent.ToString Method

public override string ToString();

See Also

ProjectEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectListener Interface

For a list of all members of this type, see ProjectListener Members.

public interface ProjectListener : EventListener

Types that implement ProjectListener

Type | Description
ProjectAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ProjectListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectListener Members

ProjectListener overview

Public Instance Methods

projectAdded | Invoked when a new Project has been added to the server.
projectChanged | Invoked when an existing Project has been modified on the server.
projectDeleted | Invoked when an existing Project has been deleted on the server.

See Also

ProjectListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectListener Methods

The methods of the ProjectListener interface are listed below. For a complete list of ProjectListener interface members, see the ProjectListener Members topic.

Public Instance Methods

projectAdded | Invoked when a new Project has been added to the server.
projectChanged | Invoked when an existing Project has been modified on the server.
projectDeleted | Invoked when an existing Project has been deleted on the server.

See Also

ProjectListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectListener.projectAdded Method

Invoked when a new Project has been added to the server.

void projectAdded(
ProjectEvent e
);

See Also

ProjectListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectListener.projectChanged Method

Invoked when an existing Project has been modified on the server.

void projectChanged(
ProjectEvent e
);

See Also

ProjectListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProjectListener.projectDeleted Method

Invoked when an existing Project has been deleted on the server.

void projectDeleted(
ProjectEvent e
);

See Also

ProjectListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel Class

For a list of all members of this type, see PromotionModel Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
PromotionModel

public class PromotionModel : SimpleTypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

PromotionModel Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel Members

PromotionModel overview

Public Instance Methods

addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get (inherited from SimpleTypedResource) |
getByteArray (inherited from SimpleTypedResource) |
getCreatedBy | Returns the User ID for the creator of the PromotionModel.
getCreatedOn | Returns the time at which the PromotionModel was created.
getDeletedBy | Returns the User ID for the user that deleted the model. Will return -1 for non-deleted models.
getDeletedOn | Returns the time at which the PromotionModel was deleted.
getDescription | Returns the description of the PromotionModel.
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
GetHashCode |
getID |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getName | Returns the name of the PromotionModel.
getObjectID | Return the object ID for the PromotionModel.
getOLEDate (inherited from SimpleTypedResource) |
getPossibleValues (inherited from SimpleTypedResource) |
getPromotionStates | Returns an array of PromotionStates for this model. The ordering of states is significant.
getPropertyNames (inherited from SimpleTypedResource) |
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getView | Returns the View that owns this PromotionModel.
MemberwiseClone (inherited from CacheRef) |
put (inherited from SimpleTypedResource) |
putByPropertyID (inherited from SimpleTypedResource) |
removeFromIntArray (inherited from TypedResource) |
setDescription |
setName |
setPromotionStates |
toDebugString | Return a debug string for this model.
ToString (inherited from TypedResource) |
update | Stores the modified PromotionModel in the repository. Until this is called all changes to the model are local.

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel Methods

The methods of the PromotionModel class are listed below. For a complete list of PromotionModel class members, see the PromotionModel Members topic.

Public Instance Methods

addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get (inherited from SimpleTypedResource) |
getByteArray (inherited from SimpleTypedResource) |
getCreatedBy | Returns the User ID for the creator of the PromotionModel.
getCreatedOn | Returns the time at which the PromotionModel was created.
getDeletedBy | Returns the User ID for the user that deleted the model. Will return -1 for non-deleted models.
getDeletedOn | Returns the time at which the PromotionModel was deleted.
getDescription | Returns the description of the PromotionModel.
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
GetHashCode |
getID |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getName | Returns the name of the PromotionModel.
getObjectID | Return the object ID for the PromotionModel.
getOLEDate (inherited from SimpleTypedResource) |
getPossibleValues (inherited from SimpleTypedResource) |
getPromotionStates | Returns an array of PromotionStates for this model. The ordering of states is significant.
getPropertyNames (inherited from SimpleTypedResource) |
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getView | Returns the View that owns this PromotionModel.
MemberwiseClone (inherited from CacheRef) |
put (inherited from SimpleTypedResource) |
putByPropertyID (inherited from SimpleTypedResource) |
removeFromIntArray (inherited from TypedResource) |
setDescription |
setName |
setPromotionStates |
toDebugString | Return a debug string for this model.
ToString (inherited from TypedResource) |
update | Stores the modified PromotionModel in the repository. Until this is called all changes to the model are local.

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.Equals Method

public override bool Equals(
Object source
);

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.getCreatedBy Method

Returns the User ID for the creator of the PromotionModel.

public virtual int getCreatedBy();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.getCreatedOn Method

Returns the time at which the PromotionModel was created.

public virtual OLEDate getCreatedOn();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.getDeletedBy Method

Returns the User ID for the user that deleted the model. Will return -1 for non-deleted models.

public virtual int getDeletedBy();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.getDeletedOn Method

Returns the time at which the PromotionModel was deleted.

public virtual OLEDate getDeletedOn();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.getDescription Method

Returns the description of the PromotionModel.

public virtual string getDescription();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.GetHashCode Method

public override int GetHashCode();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.getID Method

public override int getID();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.getName Method

Returns the name of the PromotionModel.

public virtual string getName();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.getObjectID Method

Return the object ID for the PromotionModel.

public virtual int getObjectID();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.getPromotionStates Method

Returns an array of PromotionStates for this model. The ordering of states is significant.

public virtual PromotionState[] getPromotionStates();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.getView Method

Returns the View that owns this PromotionModel.

public virtual View getView();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.setDescription Method

public virtual void setDescription(
String description
);

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.setName Method

public virtual void setName(
String name
);

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.setPromotionStates Method

public virtual void setPromotionStates(
PromotionState[] states
);

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.toDebugString Method

Return a debug string for this model.

public virtual string toDebugString();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionModel.update Method

Stores the modified PromotionModel in the repository. Until this is called all changes to the model are local.

public virtual void update();

See Also

PromotionModel Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState Class

For a list of all members of this type, see PromotionState Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
PromotionState

public class PromotionState : SimpleTypedResource, ISecurableObject, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

PromotionState Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState Members

PromotionState overview

Public Instance Constructors

PromotionState Constructor Create a new PromotionState for the specified model.

Public Instance Methods

acquireOwnership |
addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get (inherited from SimpleTypedResource) |
getACL |
getByteArray (inherited from SimpleTypedResource) |
getCreatedBy | Returns the user ID that created the state.
getCreatedOn | Returns the time at which the state was created.
getDeletedBy | Returns the user ID that deleted the state. Will return -1 for non-deleted states.
getDeletedOn | Returns the time at which the state was deleted.
getDescription | Returns the description of the PromotionState.
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
GetHashCode |
getID |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLabelID | Returns the Label ID that defines this PromotionState. It may return -1 for PromotionStates defined as "current".
getName | Returns the name of the PromotionState.
getObjectID | Returns the object ID for the PromotionState.
getOLEDate (inherited from SimpleTypedResource) |
getOwner |
getParentContainer |
getPossibleValues (inherited from SimpleTypedResource) |
getPromotionModel | Returns the "owning" PromotionModel object for this PromotionState.
getPropertyNames (inherited from SimpleTypedResource) |
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
hasPermission |
MemberwiseClone (inherited from CacheRef) |
put (inherited from SimpleTypedResource) |
putByPropertyID (inherited from SimpleTypedResource) |
removeFromIntArray (inherited from TypedResource) |
setACL |
setDescription |
setLabelID |
setName |
ToString (inherited from TypedResource) |

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState Constructor

Create a new PromotionState for the specified model.

public PromotionState(
PromotionModel model
);

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState Methods

The methods of the PromotionState class are listed below. For a complete list of PromotionState class members, see the PromotionState Members topic.

Public Instance Methods

acquireOwnership |
addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get (inherited from SimpleTypedResource) |
getACL |
getByteArray (inherited from SimpleTypedResource) |
getCreatedBy | Returns the user ID that created the state.
getCreatedOn | Returns the time at which the state was created.
getDeletedBy | Returns the user ID that deleted the state. Will return -1 for non-deleted states.
getDeletedOn | Returns the time at which the state was deleted.
getDescription | Returns the description of the PromotionState.
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
GetHashCode |
getID |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLabelID | Returns the Label ID that defines this PromotionState. It may return -1 for PromotionStates defined as "current".
getName | Returns the name of the PromotionState.
getObjectID | Returns the object ID for the PromotionState.
getOLEDate (inherited from SimpleTypedResource) |
getOwner |
getParentContainer |
getPossibleValues (inherited from SimpleTypedResource) |
getPromotionModel | Returns the "owning" PromotionModel object for this PromotionState.
getPropertyNames (inherited from SimpleTypedResource) |
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
hasPermission |
MemberwiseClone (inherited from CacheRef) |
put (inherited from SimpleTypedResource) |
putByPropertyID (inherited from SimpleTypedResource) |
removeFromIntArray (inherited from TypedResource) |
setACL |
setDescription |
setLabelID |
setName |
ToString (inherited from TypedResource) |

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.acquireOwnership Method

public virtual void acquireOwnership();

Implements

ISecurableObject.acquireOwnership

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.Equals Method

public override bool Equals(
Object source
);

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getACL Method

public virtual AclEntry[] getACL();

Implements

ISecurable.getACL

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getCreatedBy Method

Returns the user ID that created the state.

public virtual int getCreatedBy();

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getCreatedOn Method

Returns the time at which the state was created.

public virtual OLEDate getCreatedOn();

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getDeletedBy Method

Returns the user ID that deleted the state. Will return -1 for non-deleted states.

public virtual int getDeletedBy();

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getDeletedOn Method

Returns the time at which the state was deleted.

public virtual OLEDate getDeletedOn();

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getDescription Method

Returns the description of the PromotionState.

public virtual string getDescription();

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.GetHashCode Method

public override int GetHashCode();

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getID Method

public override int getID();

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getLabelID Method

Returns the Label ID that defines this PromotionState. It may return -1 for PromotionStates defined as "current".

public virtual int getLabelID();

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getName Method

Returns the name of the PromotionState.

public virtual string getName();

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getObjectID Method

Returns the object ID for the PromotionState.

public virtual int getObjectID();

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getOwner Method

public virtual int getOwner();

Implements

ISecurableObject.getOwner

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getParentContainer Method

public virtual ISecurableContainer getParentContainer();

Implements

ISecurable.getParentContainer

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.getPromotionModel Method

Returns the "owning" PromotionModel object for this PromotionState.

public virtual PromotionModel getPromotionModel();

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.hasPermission Method

public virtual bool hasPermission(
Int32 permissions
);

Implements

ISecurable.hasPermission

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.setACL Method

public virtual void setACL(
AclEntry[] acl
);

Implements

ISecurable.setACL

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.setDescription Method

public virtual void setDescription(
String description
);

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.setLabelID Method

public virtual void setLabelID(
Int32 labelID
);

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PromotionState.setName Method

public virtual void setName(
String name
);

See Also

PromotionState Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property Class

For a list of all members of this type, see Property Members.

System.Object
CacheRef
Property

public class Property : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Property Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property Members

Property overview

Public Static Methods

areValuesEqual
resolveAllDependencies

Public Instance Methods

Clone (inherited from CacheRef) |
coerce |
copy | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). <p> The copied property will have the same parent Type as the original property. The Type object is not copied. <p> For enumerated properties, the enumerated values are copied. <p> For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals |
getClassIDOfValue | Returns the class ID for values of this property.
getDefaultValue | Returns the default value for this property.
getDependentProperties | Returns the set of properties that the computation of this property's value depends upon. If none, the list will be empty (will not return null). Only client calculated properties will have dependencies. It is possible that one of the returned properties also has dependencies.
getDisplayName | Returns this property's display name.
getDisplayValue |
getEnumDisabled |
getEnumDisplayName |
getEnumeratedValues | Returns an array of all the enumerated values for this property. The returned EnumeratedValue objects will all have Translations even when talking to older servers. However, the those Translations from older servers will only have a default value specified. The EnumeratedValue's getEnabled value will be properly set as well.
getEnumTranslations |
getEnumValues | Returns an array of all the enumerated values for this property.
GetHashCode |
getID | Returns this property's internal ID.
getMaxLength | For text-valued properties, returns the maximum number of characters permitted.
getName | Returns this property's internal name.
getTranslations | Returns a copy of the display name translations for this property. Will return null for client calculated properties. When working against servers that do not support display name translations the returned Translations object will only have the default value set.
getType | Returns the Type object than has this property as one of its properties.
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeCode | Returns the type code (e.g. USER_ID) for this property.
isAdvanced | Return true is the property is considered "advanced". Generally this means the property is used internally and would be meaningless to an end user.
isCalculated | Returns true if the property is calculated on-the-fly by the server as opposed to being stored on the server.
isClientCalculated | Return true is the property is calculated in the fly by the client.
isDescriptor | Returns true if the property is considered a descriptor. A Type may have multiple descriptors.
isDisabled | Return true if the property is flagged as disabled. Generally disabled properties should not be displayed nor edited by end users.
isEqualTo | Compares two Property objects. <p> The parent Types are compared by ClassID. <p> For enumerated properties, the enumerated values are compared using a deep comparison. <p> For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
isGenericCalculated | Returns true if the property is calculated on the server by the component.
isHeader | Returns true if this property is stored in the repository database and if the database field is a header field.
isInstance |
isPrimaryDescriptor | Return true if this property is the primary descriptor for this property's owning type. Each Type can have only one primary descriptor.
isRequired | Returns true if a value for this property is required; valid for user-defined properties only.
isRestricted | Return true if this is a restricted property.
isRevisionIndependent | Returns true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
isServerCalculated | Return true if the property if caclulated on the fly by the server.
isStored | Returns true if the property is stored in the server's database. (Some properties may be stored and others calculated on the fly by either the client or server).
isSysDefined | Returns true if the property is a built-in StarTeam property (as opposed to a custom property).
isTimeTruncated | Returns true if the time part of this property should be truncated during display; valid for time-valued properties only.
isUserCustomized | Returns true if this property is a user defined property.
isUserDefined | Returns true is the property was user defined through the repository customization feature.
isUserModifiable | Return true if the property is flagged as user modifiable. This is not enforced so some properties that are marked as non-modifiable can actually be modified. This is more of a clue for the StarTeam GUI whether or not to allow the user to edit the property.
isViewSpecific | Returns true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MemberwiseClone (inherited from CacheRef) |
toDebugString | Returns a String represetation of this property that may be useful for debugging purposes.
ToString |

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property Methods

The methods of the Property class are listed below. For a complete list of Property class members, see the Property Members topic.

Public Static Methods

areValuesEqual
resolveAllDependencies

Public Instance Methods

Clone (inherited from CacheRef) |
coerce |
copy | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). <p> The copied property will have the same parent Type as the original property. The Type object is not copied. <p> For enumerated properties, the enumerated values are copied. <p> For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals |
getClassIDOfValue | Returns the class ID for values of this property.
getDefaultValue | Returns the default value for this property.
getDependentProperties | Returns the set of properties that the computation of this property's value depends upon. If none, the list will be empty (will not return null). Only client calculated properties will have dependencies. It is possible that one of the returned properties also has dependencies.
getDisplayName | Returns this property's display name.
getDisplayValue |
getEnumDisabled |
getEnumDisplayName |
getEnumeratedValues | Returns an array of all the enumerated values for this property. The returned EnumeratedValue objects will all have Translations even when talking to older servers. However, the those Translations from older servers will only have a default value specified. The EnumeratedValue's getEnabled value will be properly set as well.
getEnumTranslations |
getEnumValues | Returns an array of all the enumerated values for this property.
GetHashCode |
getID | Returns this property's internal ID.
getMaxLength | For text-valued properties, returns the maximum number of characters permitted.
getName | Returns this property's internal name.
getTranslations | Returns a copy of the display name translations for this property. Will return null for client calculated properties. When working against servers that do not support display name translations the returned Translations object will only have the default value set.
getType | Returns the Type object than has this property as one of its properties.
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeCode | Returns the type code (e.g. USER_ID) for this property.
isAdvanced | Return true is the property is considered "advanced". Generally this means the property is used internally and would be meaningless to an end user.
isCalculated | Returns true if the property is calculated on-the-fly by the server as opposed to being stored on the server.
isClientCalculated | Return true is the property is calculated in the fly by the client.
isDescriptor | Returns true if the property is considered a descriptor. A Type may have multiple descriptors.
isDisabled | Return true if the property is flagged as disabled. Generally disabled properties should not be displayed nor edited by end users.
isEqualTo | Compares two Property objects. <p> The parent Types are compared by ClassID. <p> For enumerated properties, the enumerated values are compared using a deep comparison. <p> For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
isGenericCalculated | Returns true if the property is calculated on the server by the component.
isHeader | Returns true if this property is stored in the repository database and if the database field is a header field.
isInstance |
isPrimaryDescriptor | Return true if this property is the primary descriptor for this property's owning type. Each Type can have only one primary descriptor.
isRequired | Returns true if a value for this property is required; valid for user-defined properties only.
isRestricted | Return true if this is a restricted property.
isRevisionIndependent | Returns true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
isServerCalculated | Return true if the property if caclulated on the fly by the server.
isStored | Returns true if the property is stored in the server's database. (Some properties may be stored and others calculated on the fly by either the client or server).
isSysDefined | Returns true if the property is a built-in StarTeam property (as opposed to a custom property).
isTimeTruncated | Returns true if the time part of this property should be truncated during display; valid for time-valued properties only.
isUserCustomized | Returns true if this property is a user defined property.
isUserDefined | Returns true is the property was user defined through the repository customization feature.
isUserModifiable | Return true if the property is flagged as user modifiable. This is not enforced so some properties that are marked as non-modifiable can actually be modified. This is more of a clue for the StarTeam GUI whether or not to allow the user to edit the property.
isViewSpecific | Returns true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MemberwiseClone (inherited from CacheRef) |
toDebugString | Returns a String represetation of this property that may be useful for debugging purposes.
ToString |

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.areValuesEqual Method

public static bool areValuesEqual(
Object v1,
Object v2
);

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.coerce Method

public virtual object coerce(
Object value
);

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.copy Method

Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). <p> The copied property will have the same parent Type as the original property. The Type object is not copied. <p> For enumerated properties, the enumerated values are copied. <p> For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.

public virtual Property copy();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Equals Method

public override bool Equals(
Object source
);

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getClassIDOfValue Method

Returns the class ID for values of this property.

public virtual int getClassIDOfValue();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getDefaultValue Method

Returns the default value for this property.

public virtual object getDefaultValue();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getDependentProperties Method

Returns the set of properties that the computation of this property's value depends upon. If none, the list will be empty (will not return null). Only client calculated properties will have dependencies. It is possible that one of the returned properties also has dependencies.

public virtual Property[] getDependentProperties();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getDisplayName Method

Returns this property's display name.

public virtual string getDisplayName();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getDisplayValue Method

public virtual string getDisplayValue(
Object value
);

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getEnumDisabled Method

public virtual bool getEnumDisabled(
Int32 code
);

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getEnumDisplayName Method

public virtual string getEnumDisplayName(
Int32 code
);

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getEnumeratedValues Method

Returns an array of all the enumerated values for this property. The returned EnumeratedValue objects will all have Translations even when talking to older servers. However, the those Translations from older servers will only have a default value specified. The EnumeratedValue's getEnabled value will be properly set as well.

public virtual EnumeratedValue[] getEnumeratedValues();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getEnumTranslations Method

public virtual Translations getEnumTranslations(
Int32 code
);

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getEnumValues Method

Returns an array of all the enumerated values for this property.

public virtual int[] getEnumValues();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.GetHashCode Method

public override int GetHashCode();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getID Method

Returns this property's internal ID.

public virtual int getID();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getMaxLength Method

For text-valued properties, returns the maximum number of characters permitted.

public virtual int getMaxLength();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getName Method

Returns this property's internal name.

public virtual string getName();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getTranslations Method

Returns a copy of the display name translations for this property. Will return null for client calculated properties. When working against servers that do not support display name translations the returned Translations object will only have the default value set.

public virtual Translations getTranslations();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getType Method

Returns the Type object than has this property as one of its properties.

public virtual Type getType();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.getTypeCode Method

Returns the type code (e.g. USER_ID) for this property.

public virtual int getTypeCode();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isAdvanced Method

Return true is the property is considered "advanced". Generally this means the property is used internally and would be meaningless to an end user.

public virtual bool isAdvanced();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isCalculated Method

Returns true if the property is calculated on-the-fly by the server as opposed to being stored on the server.

public virtual bool isCalculated();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isClientCalculated Method

Return true is the property is calculated in the fly by the client.

public virtual bool isClientCalculated();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isDescriptor Method

Returns true if the property is considered a descriptor. A Type may have multiple descriptors.

public virtual bool isDescriptor();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isDisabled Method

Return true if the property is flagged as disabled. Generally disabled properties should not be displayed nor edited by end users.

public virtual bool isDisabled();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isEqualTo Method

Compares two Property objects. <p> The parent Types are compared by ClassID. <p> For enumerated properties, the enumerated values are compared using a deep comparison. <p> For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.

public virtual bool isEqualTo(
Property property
);

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isGenericCalculated Method

Returns true if the property is calculated on the server by the component.

public virtual bool isGenericCalculated();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isHeader Method

Returns true if this property is stored in the repository database and if the database field is a header field.

public virtual bool isHeader();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isInstance Method

public virtual bool isInstance(
Object object
);

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isPrimaryDescriptor Method

Return true if this property is the primary descriptor for this property's owning type. Each Type can have only one primary descriptor.

public virtual bool isPrimaryDescriptor();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isRequired Method

Returns true if a value for this property is required; valid for user-defined properties only.

public virtual bool isRequired();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isRestricted Method

Return true if this is a restricted property.

public virtual bool isRestricted();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isRevisionIndependent Method

Returns true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

public virtual bool isRevisionIndependent();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isServerCalculated Method

Return true if the property if caclulated on the fly by the server.

public virtual bool isServerCalculated();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isStored Method

Returns true if the property is stored in the server's database. (Some properties may be stored and others calculated on the fly by either the client or server).

public virtual bool isStored();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isSysDefined Method

Returns true if the property is a built-in StarTeam property (as opposed to a custom property).

public virtual bool isSysDefined();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isTimeTruncated Method

Returns true if the time part of this property should be truncated during display; valid for time-valued properties only.

public virtual bool isTimeTruncated();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isUserCustomized Method

Returns true if this property is a user defined property.

public virtual bool isUserCustomized();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isUserDefined Method

Returns true is the property was user defined through the repository customization feature.

public virtual bool isUserDefined();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isUserModifiable Method

Return true if the property is flagged as user modifiable. This is not enforced so some properties that are marked as non-modifiable can actually be modified. This is more of a clue for the StarTeam GUI whether or not to allow the user to edit the property.

public virtual bool isUserModifiable();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.isViewSpecific Method

Returns true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

public virtual bool isViewSpecific();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.resolveAllDependencies Method

public static Property[] resolveAllDependencies(
Property[] props
);

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.toDebugString Method

Returns a String represetation of this property that may be useful for debugging purposes.

public virtual string toDebugString();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.ToString Method

public override string ToString();

See Also

Property Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types Class

For a list of all members of this type, see Property.Types Members.

System.Object
Property.Types

public class Property.Types

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Property.Types Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types Members

Property.Types overview

Public Static Fields

BINARY
COMMENT_ID
ENUMERATED
FLOAT64
IDARRAY
INT32
OBJECT_ID
TEXT
TIME
UNKNOWN
USER_ID
VIEW_ID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types Fields

The fields of the Property.Types class are listed below. For a complete list of Property.Types class members, see the Property.Types Members topic.

Public Static Fields

BINARY
COMMENT_ID
ENUMERATED
FLOAT64
IDARRAY
INT32
OBJECT_ID
TEXT
TIME
UNKNOWN
USER_ID
VIEW_ID

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.BINARY Field

public const Int32 BINARY = 9;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.COMMENT_ID Field

public const Int32 COMMENT_ID = 5;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.ENUMERATED Field

public const Int32 ENUMERATED = 2;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.FLOAT64 Field

public const Int32 FLOAT64 = 6;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.IDARRAY Field

public const Int32 IDARRAY = 11;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.INT32 Field

public const Int32 INT32 = 1;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.OBJECT_ID Field

public const Int32 OBJECT_ID = 4;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.TEXT Field

public const Int32 TEXT = 8;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.TIME Field

public const Int32 TIME = 7;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.UNKNOWN Field

public const Int32 UNKNOWN = 0;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.USER_ID Field

public const Int32 USER_ID = 3;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Property.Types.VIEW_ID Field

public const Int32 VIEW_ID = 10;

See Also

Property.Types Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums Class

For a list of all members of this type, see PropertyEnums Members.

System.Object
PropertyEnums

public class PropertyEnums

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

PropertyEnums Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums Members

PropertyEnums overview

Public Static Fields

FILE_EOL_CLIENT_DEFINED
FILE_EOL_FIXED_CR
FILE_EOL_FIXED_CRLF
FILE_EOL_FIXED_LF
PROJECT_PROCESS_LINKS_DIRECT
PROJECT_PROCESS_LINKS_VIA_PROCESS_TASK
REQ_STATUS_ACCEPTED
REQ_STATUS_APPROVED
REQ_STATUS_COMPLETE
REQ_STATUS_DEFERRED
REQ_STATUS_DRAFT
REQ_STATUS_PENDING
REQ_STATUS_READY
REQ_STATUS_REJECTED
REQ_STATUS_REVIEW
REQ_STATUS_SUBMITTED
TASK_USAGE_CHECKIN
TASK_USAGE_OTHER
TASK_USAGE_PROMOTE
TASK_USAGE_REBASE
TASK_USAGE_REPLICATE

Public Instance Fields

AM_I_RECIPIENT_NO
AM_I_RECIPIENT_YES
AUDIT_EVENT_ID_ADDED
AUDIT_EVENT_ID_BRANCHED
AUDIT_EVENT_ID_CHECKED_IN
AUDIT_EVENT_ID_CHECKED_OUT
AUDIT_EVENT_ID_COMMENT_EDITED
AUDIT_EVENT_ID_CREATED
AUDIT_EVENT_ID_DELETED
AUDIT_EVENT_ID_ITEM_OVERWRITTEN
AUDIT_EVENT_ID_LOCK_BROKEN
AUDIT_EVENT_ID_LOCKED
AUDIT_EVENT_ID_MODIFIED
AUDIT_EVENT_ID_MOVED_FROM
AUDIT_EVENT_ID_MOVED_TO
AUDIT_EVENT_ID_SHARED
AUDIT_EVENT_ID_UNLOCKED
AUDIT_EVENT_ID_VAULT_CONVERTED
BRANCH_ON_CHANGE_NO
BRANCH_ON_CHANGE_YES
BRANCH_STATE_BRANCHED
BRANCH_STATE_NOT_BRANCHED
BRANCH_STATE_ROOT
CR_PLATFORM_ALL
CR_PLATFORM_MACOS
CR_PLATFORM_OTHER
CR_PLATFORM_UNIX
CR_PLATFORM_WINDOWS_2000
CR_PLATFORM_WINDOWS_95
CR_PLATFORM_WINDOWS_98
CR_PLATFORM_WINDOWS_NT
CR_PRIORITY_NO
CR_PRIORITY_YES
CR_SEVERITY_HIGH
CR_SEVERITY_LOW
CR_SEVERITY_MEDIUM
CR_STATUS_AS_DESIGNED
CR_STATUS_CANNOT_REPRODUCE
CR_STATUS_CLOSED_AS_DESIGNED
CR_STATUS_CLOSED_CANNOT_REPRODUCE
CR_STATUS_CLOSED_DEFERRED
CR_STATUS_CLOSED_DOCUMENTED
CR_STATUS_CLOSED_FIXED
CR_STATUS_CLOSED_IS_DUPLICATE
CR_STATUS_DEFERRED
CR_STATUS_DOCUMENTED
CR_STATUS_FIXED
CR_STATUS_IN_PROGRESS
CR_STATUS_IS_DUPLICATE
CR_STATUS_NEW
CR_STATUS_OPEN
CR_STATUS_VERIFIED_AS_DESIGNED
CR_STATUS_VERIFIED_CANNOT_REPRODUCE
CR_STATUS_VERIFIED_DEFERRED
CR_STATUS_VERIFIED_DOCUMENTED
CR_STATUS_VERIFIED_FIXED
CR_STATUS_VERIFIED_IS_DUPLICATE
CR_TYPE_DEFECT
CR_TYPE_SUGGESTION
FILE_ARCHIVE_FORMAT_NATIVE_I
FILE_ARCHIVE_FORMAT_NATIVE_II
FILE_ARCHIVE_FORMAT_NOT_APPLICABLE
FILE_ARCHIVE_TYPE_NATIVE
FILE_ARCHIVE_TYPE_PVCS
FILE_ARCHIVE_TYPE_VSS
FILE_COMPRESSION_LEVEL_DEFAULT
FILE_COMPRESSION_LEVEL_MAXIMIZE_COMPRESSION
FILE_COMPRESSION_LEVEL_MAXIMIZE_SPEED
FILE_COMPRESSION_LEVEL_NONE
FILE_ENCODING_ASCII
FILE_ENCODING_BINARY
FILE_ENCODING_UNICODE
FILE_EXECUTABLE_NO
FILE_EXECUTABLE_YES
FILE_LOCAL_FILE_EXISTS_NO
FILE_LOCAL_FILE_EXISTS_YES
FILE_STATUS_CURRENT
FILE_STATUS_MERGE
FILE_STATUS_MISSING
FILE_STATUS_MODIFIED
FILE_STATUS_NOT_IN_VIEW
FILE_STATUS_OUT_OF_DATE
FILE_STATUS_UNKNOWN
FILE_STORAGE_TYPE_DELTA
FILE_STORAGE_TYPE_FULL_VERSIONS
FILE_SYNC_KNOWN_NO
FILE_SYNC_KNOWN_YES
FILE_SYNC_ON_ROOT_PATH_NO
FILE_SYNC_ON_ROOT_PATH_YES
FLAG_NO
FLAG_YES
FOLDER_EXCLUDE_FLAGS_INHERIT_AND_LOCAL_EXCLUDE_LIST
FOLDER_EXCLUDE_FLAGS_LOCAL_EXCLUDE_LIST
FOLDER_EXCLUDE_FLAGS_NO_EXCLUDE_LIST
MY_LOCK_EXCLUSIVELY_LOCKED_BY_ME
MY_LOCK_NON_EXCLUSIVELY_LOCKED_BY_ME
MY_LOCK_NOT_LOCKED_BY_ME
PROJECT_ENCRYPTION_NONE
PROJECT_ENCRYPTION_RC2_CBC
PROJECT_ENCRYPTION_RC2_CFB
PROJECT_ENCRYPTION_RC2_ECB
PROJECT_ENCRYPTION_RC4
PROJECT_TYPE_PVCS
PROJECT_TYPE_STARTEAM
PROJECT_TYPE_VISUAL_SOURCESAFE
READ_ONLY_NO
READ_ONLY_YES
READ_STATUS_READ
READ_STATUS_UNREAD
SHARE_STATE_DERIVED_SHARE
SHARE_STATE_NOT_SHARED
SHARE_STATE_ROOT_SHARE
TASK_CONSTRAINT_TYPE_AS_LATE_AS_POSSIBLE
TASK_CONSTRAINT_TYPE_AS_SOON_AS_POSSIBLE
TASK_CONSTRAINT_TYPE_FINISH_NO_EARLIER_THAN
TASK_CONSTRAINT_TYPE_FINISH_NO_LATER_THAN
TASK_CONSTRAINT_TYPE_MUST_FINISH_ON
TASK_CONSTRAINT_TYPE_MUST_START_ON
TASK_CONSTRAINT_TYPE_START_NO_EARLIER_THAN
TASK_CONSTRAINT_TYPE_START_NO_LATER_THAN
TASK_IS_MY_TASK_NO
TASK_IS_MY_TASK_YES
TASK_MILESTONE_NO
TASK_MILESTONE_YES
TASK_NEEDS_ATTENTION_NO
TASK_NEEDS_ATTENTION_YES
TASK_ORIGIN_MSPROJECT
TASK_ORIGIN_STARTEAM
TASK_PRIORITY_DO_NOT_LEVEL
TASK_PRIORITY_HIGH
TASK_PRIORITY_HIGHER
TASK_PRIORITY_HIGHEST
TASK_PRIORITY_LOW
TASK_PRIORITY_LOWER
TASK_PRIORITY_LOWEST
TASK_PRIORITY_MEDIUM
TASK_PRIORITY_VERY_HIGH
TASK_PRIORITY_VERY_LOW
TASK_STATUS_CLOSED
TASK_STATUS_FINISHED
TASK_STATUS_HOLD
TASK_STATUS_IN_PROGRESS
TASK_STATUS_PENDING
TASK_STATUS_READY_TO_START
TASK_TYPE_FIXED_DURATION
TASK_TYPE_FIXED_UNITS
TASK_TYPE_FIXED_WORK
TASKDEPENDENCY_TYPE_FF
TASKDEPENDENCY_TYPE_FS
TASKDEPENDENCY_TYPE_SF
TASKDEPENDENCY_TYPE_SS
TOPIC_PRIORITY_HIGH
TOPIC_PRIORITY_LOW
TOPIC_PRIORITY_NORMAL
TOPIC_STATUS_ACTIVE
TOPIC_STATUS_INACTIVE
TOPIC_TYPE_RESPONSE
TOPIC_TYPE_TOPIC

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums Fields

The fields of the PropertyEnums class are listed below. For a complete list of PropertyEnums class members, see the PropertyEnums Members topic.

Public Static Fields

FILE_EOL_CLIENT_DEFINED
FILE_EOL_FIXED_CR
FILE_EOL_FIXED_CRLF
FILE_EOL_FIXED_LF
PROJECT_PROCESS_LINKS_DIRECT
PROJECT_PROCESS_LINKS_VIA_PROCESS_TASK
REQ_STATUS_ACCEPTED
REQ_STATUS_APPROVED
REQ_STATUS_COMPLETE
REQ_STATUS_DEFERRED
REQ_STATUS_DRAFT
REQ_STATUS_PENDING
REQ_STATUS_READY
REQ_STATUS_REJECTED
REQ_STATUS_REVIEW
REQ_STATUS_SUBMITTED
TASK_USAGE_CHECKIN
TASK_USAGE_OTHER
TASK_USAGE_PROMOTE
TASK_USAGE_REBASE
TASK_USAGE_REPLICATE

Public Instance Fields

AM_I_RECIPIENT_NO
AM_I_RECIPIENT_YES
AUDIT_EVENT_ID_ADDED
AUDIT_EVENT_ID_BRANCHED
AUDIT_EVENT_ID_CHECKED_IN
AUDIT_EVENT_ID_CHECKED_OUT
AUDIT_EVENT_ID_COMMENT_EDITED
AUDIT_EVENT_ID_CREATED
AUDIT_EVENT_ID_DELETED
AUDIT_EVENT_ID_ITEM_OVERWRITTEN
AUDIT_EVENT_ID_LOCK_BROKEN
AUDIT_EVENT_ID_LOCKED
AUDIT_EVENT_ID_MODIFIED
AUDIT_EVENT_ID_MOVED_FROM
AUDIT_EVENT_ID_MOVED_TO
AUDIT_EVENT_ID_SHARED
AUDIT_EVENT_ID_UNLOCKED
AUDIT_EVENT_ID_VAULT_CONVERTED
BRANCH_ON_CHANGE_NO
BRANCH_ON_CHANGE_YES
BRANCH_STATE_BRANCHED
BRANCH_STATE_NOT_BRANCHED
BRANCH_STATE_ROOT
CR_PLATFORM_ALL
CR_PLATFORM_MACOS
CR_PLATFORM_OTHER
CR_PLATFORM_UNIX
CR_PLATFORM_WINDOWS_2000
CR_PLATFORM_WINDOWS_95
CR_PLATFORM_WINDOWS_98
CR_PLATFORM_WINDOWS_NT
CR_PRIORITY_NO
CR_PRIORITY_YES
CR_SEVERITY_HIGH
CR_SEVERITY_LOW
CR_SEVERITY_MEDIUM
CR_STATUS_AS_DESIGNED
CR_STATUS_CANNOT_REPRODUCE
CR_STATUS_CLOSED_AS_DESIGNED
CR_STATUS_CLOSED_CANNOT_REPRODUCE
CR_STATUS_CLOSED_DEFERRED
CR_STATUS_CLOSED_DOCUMENTED
CR_STATUS_CLOSED_FIXED
CR_STATUS_CLOSED_IS_DUPLICATE
CR_STATUS_DEFERRED
CR_STATUS_DOCUMENTED
CR_STATUS_FIXED
CR_STATUS_IN_PROGRESS
CR_STATUS_IS_DUPLICATE
CR_STATUS_NEW
CR_STATUS_OPEN
CR_STATUS_VERIFIED_AS_DESIGNED
CR_STATUS_VERIFIED_CANNOT_REPRODUCE
CR_STATUS_VERIFIED_DEFERRED
CR_STATUS_VERIFIED_DOCUMENTED
CR_STATUS_VERIFIED_FIXED
CR_STATUS_VERIFIED_IS_DUPLICATE
CR_TYPE_DEFECT
CR_TYPE_SUGGESTION
FILE_ARCHIVE_FORMAT_NATIVE_I
FILE_ARCHIVE_FORMAT_NATIVE_II
FILE_ARCHIVE_FORMAT_NOT_APPLICABLE
FILE_ARCHIVE_TYPE_NATIVE
FILE_ARCHIVE_TYPE_PVCS
FILE_ARCHIVE_TYPE_VSS
FILE_COMPRESSION_LEVEL_DEFAULT
FILE_COMPRESSION_LEVEL_MAXIMIZE_COMPRESSION
FILE_COMPRESSION_LEVEL_MAXIMIZE_SPEED
FILE_COMPRESSION_LEVEL_NONE
FILE_ENCODING_ASCII
FILE_ENCODING_BINARY
FILE_ENCODING_UNICODE
FILE_EXECUTABLE_NO
FILE_EXECUTABLE_YES
FILE_LOCAL_FILE_EXISTS_NO
FILE_LOCAL_FILE_EXISTS_YES
FILE_STATUS_CURRENT
FILE_STATUS_MERGE
FILE_STATUS_MISSING
FILE_STATUS_MODIFIED
FILE_STATUS_NOT_IN_VIEW
FILE_STATUS_OUT_OF_DATE
FILE_STATUS_UNKNOWN
FILE_STORAGE_TYPE_DELTA
FILE_STORAGE_TYPE_FULL_VERSIONS
FILE_SYNC_KNOWN_NO
FILE_SYNC_KNOWN_YES
FILE_SYNC_ON_ROOT_PATH_NO
FILE_SYNC_ON_ROOT_PATH_YES
FLAG_NO
FLAG_YES
FOLDER_EXCLUDE_FLAGS_INHERIT_AND_LOCAL_EXCLUDE_LIST
FOLDER_EXCLUDE_FLAGS_LOCAL_EXCLUDE_LIST
FOLDER_EXCLUDE_FLAGS_NO_EXCLUDE_LIST
MY_LOCK_EXCLUSIVELY_LOCKED_BY_ME
MY_LOCK_NON_EXCLUSIVELY_LOCKED_BY_ME
MY_LOCK_NOT_LOCKED_BY_ME
PROJECT_ENCRYPTION_NONE
PROJECT_ENCRYPTION_RC2_CBC
PROJECT_ENCRYPTION_RC2_CFB
PROJECT_ENCRYPTION_RC2_ECB
PROJECT_ENCRYPTION_RC4
PROJECT_TYPE_PVCS
PROJECT_TYPE_STARTEAM
PROJECT_TYPE_VISUAL_SOURCESAFE
READ_ONLY_NO
READ_ONLY_YES
READ_STATUS_READ
READ_STATUS_UNREAD
SHARE_STATE_DERIVED_SHARE
SHARE_STATE_NOT_SHARED
SHARE_STATE_ROOT_SHARE
TASK_CONSTRAINT_TYPE_AS_LATE_AS_POSSIBLE
TASK_CONSTRAINT_TYPE_AS_SOON_AS_POSSIBLE
TASK_CONSTRAINT_TYPE_FINISH_NO_EARLIER_THAN
TASK_CONSTRAINT_TYPE_FINISH_NO_LATER_THAN
TASK_CONSTRAINT_TYPE_MUST_FINISH_ON
TASK_CONSTRAINT_TYPE_MUST_START_ON
TASK_CONSTRAINT_TYPE_START_NO_EARLIER_THAN
TASK_CONSTRAINT_TYPE_START_NO_LATER_THAN
TASK_IS_MY_TASK_NO
TASK_IS_MY_TASK_YES
TASK_MILESTONE_NO
TASK_MILESTONE_YES
TASK_NEEDS_ATTENTION_NO
TASK_NEEDS_ATTENTION_YES
TASK_ORIGIN_MSPROJECT
TASK_ORIGIN_STARTEAM
TASK_PRIORITY_DO_NOT_LEVEL
TASK_PRIORITY_HIGH
TASK_PRIORITY_HIGHER
TASK_PRIORITY_HIGHEST
TASK_PRIORITY_LOW
TASK_PRIORITY_LOWER
TASK_PRIORITY_LOWEST
TASK_PRIORITY_MEDIUM
TASK_PRIORITY_VERY_HIGH
TASK_PRIORITY_VERY_LOW
TASK_STATUS_CLOSED
TASK_STATUS_FINISHED
TASK_STATUS_HOLD
TASK_STATUS_IN_PROGRESS
TASK_STATUS_PENDING
TASK_STATUS_READY_TO_START
TASK_TYPE_FIXED_DURATION
TASK_TYPE_FIXED_UNITS
TASK_TYPE_FIXED_WORK
TASKDEPENDENCY_TYPE_FF
TASKDEPENDENCY_TYPE_FS
TASKDEPENDENCY_TYPE_SF
TASKDEPENDENCY_TYPE_SS
TOPIC_PRIORITY_HIGH
TOPIC_PRIORITY_LOW
TOPIC_PRIORITY_NORMAL
TOPIC_STATUS_ACTIVE
TOPIC_STATUS_INACTIVE
TOPIC_TYPE_RESPONSE
TOPIC_TYPE_TOPIC

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AM_I_RECIPIENT_NO Field

public readonly Int32 AM_I_RECIPIENT_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AM_I_RECIPIENT_YES Field

public readonly Int32 AM_I_RECIPIENT_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_ADDED Field

public readonly Int32 AUDIT_EVENT_ID_ADDED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_BRANCHED Field

public readonly Int32 AUDIT_EVENT_ID_BRANCHED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_CHECKED_IN Field

public readonly Int32 AUDIT_EVENT_ID_CHECKED_IN;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_CHECKED_OUT Field

public readonly Int32 AUDIT_EVENT_ID_CHECKED_OUT;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_COMMENT_EDITED Field

public readonly Int32 AUDIT_EVENT_ID_COMMENT_EDITED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_CREATED Field

public readonly Int32 AUDIT_EVENT_ID_CREATED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_DELETED Field

public readonly Int32 AUDIT_EVENT_ID_DELETED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_ITEM_OVERWRITTEN Field

public readonly Int32 AUDIT_EVENT_ID_ITEM_OVERWRITTEN;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_LOCK_BROKEN Field

public readonly Int32 AUDIT_EVENT_ID_LOCK_BROKEN;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_LOCKED Field

public readonly Int32 AUDIT_EVENT_ID_LOCKED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_MODIFIED Field

public readonly Int32 AUDIT_EVENT_ID_MODIFIED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_MOVED_FROM Field

public readonly Int32 AUDIT_EVENT_ID_MOVED_FROM;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_MOVED_TO Field

public readonly Int32 AUDIT_EVENT_ID_MOVED_TO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_SHARED Field

public readonly Int32 AUDIT_EVENT_ID_SHARED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_UNLOCKED Field

public readonly Int32 AUDIT_EVENT_ID_UNLOCKED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.AUDIT_EVENT_ID_VAULT_CONVERTED Field

public readonly Int32 AUDIT_EVENT_ID_VAULT_CONVERTED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.BRANCH_ON_CHANGE_NO Field

public readonly Int32 BRANCH_ON_CHANGE_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.BRANCH_ON_CHANGE_YES Field

public readonly Int32 BRANCH_ON_CHANGE_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.BRANCH_STATE_BRANCHED Field

public readonly Int32 BRANCH_STATE_BRANCHED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.BRANCH_STATE_NOT_BRANCHED Field

public readonly Int32 BRANCH_STATE_NOT_BRANCHED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.BRANCH_STATE_ROOT Field

public readonly Int32 BRANCH_STATE_ROOT;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_PLATFORM_ALL Field

public readonly Int32 CR_PLATFORM_ALL;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_PLATFORM_MACOS Field

public readonly Int32 CR_PLATFORM_MACOS;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_PLATFORM_OTHER Field

public readonly Int32 CR_PLATFORM_OTHER;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_PLATFORM_UNIX Field

public readonly Int32 CR_PLATFORM_UNIX;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_PLATFORM_WINDOWS_2000 Field

public readonly Int32 CR_PLATFORM_WINDOWS_2000;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_PLATFORM_WINDOWS_95 Field

public readonly Int32 CR_PLATFORM_WINDOWS_95;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_PLATFORM_WINDOWS_98 Field

public readonly Int32 CR_PLATFORM_WINDOWS_98;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_PLATFORM_WINDOWS_NT Field

public readonly Int32 CR_PLATFORM_WINDOWS_NT;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_PRIORITY_NO Field

public readonly Int32 CR_PRIORITY_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_PRIORITY_YES Field

public readonly Int32 CR_PRIORITY_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_SEVERITY_HIGH Field

public readonly Int32 CR_SEVERITY_HIGH;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_SEVERITY_LOW Field

public readonly Int32 CR_SEVERITY_LOW;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_SEVERITY_MEDIUM Field

public readonly Int32 CR_SEVERITY_MEDIUM;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_AS_DESIGNED Field

public readonly Int32 CR_STATUS_AS_DESIGNED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_CANNOT_REPRODUCE Field

public readonly Int32 CR_STATUS_CANNOT_REPRODUCE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_CLOSED_AS_DESIGNED Field

public readonly Int32 CR_STATUS_CLOSED_AS_DESIGNED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_CLOSED_CANNOT_REPRODUCE Field

public readonly Int32 CR_STATUS_CLOSED_CANNOT_REPRODUCE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_CLOSED_DEFERRED Field

public readonly Int32 CR_STATUS_CLOSED_DEFERRED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_CLOSED_DOCUMENTED Field

public readonly Int32 CR_STATUS_CLOSED_DOCUMENTED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_CLOSED_FIXED Field

public readonly Int32 CR_STATUS_CLOSED_FIXED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_CLOSED_IS_DUPLICATE Field

public readonly Int32 CR_STATUS_CLOSED_IS_DUPLICATE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_DEFERRED Field

public readonly Int32 CR_STATUS_DEFERRED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_DOCUMENTED Field

public readonly Int32 CR_STATUS_DOCUMENTED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_FIXED Field

public readonly Int32 CR_STATUS_FIXED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_IN_PROGRESS Field

public readonly Int32 CR_STATUS_IN_PROGRESS;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_IS_DUPLICATE Field

public readonly Int32 CR_STATUS_IS_DUPLICATE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_NEW Field

public readonly Int32 CR_STATUS_NEW;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_OPEN Field

public readonly Int32 CR_STATUS_OPEN;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_VERIFIED_AS_DESIGNED Field

public readonly Int32 CR_STATUS_VERIFIED_AS_DESIGNED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_VERIFIED_CANNOT_REPRODUCE Field

public readonly Int32 CR_STATUS_VERIFIED_CANNOT_REPRODUCE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_VERIFIED_DEFERRED Field

public readonly Int32 CR_STATUS_VERIFIED_DEFERRED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_VERIFIED_DOCUMENTED Field

public readonly Int32 CR_STATUS_VERIFIED_DOCUMENTED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_VERIFIED_FIXED Field

public readonly Int32 CR_STATUS_VERIFIED_FIXED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_STATUS_VERIFIED_IS_DUPLICATE Field

public readonly Int32 CR_STATUS_VERIFIED_IS_DUPLICATE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_TYPE_DEFECT Field

public readonly Int32 CR_TYPE_DEFECT;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.CR_TYPE_SUGGESTION Field

public readonly Int32 CR_TYPE_SUGGESTION;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_ARCHIVE_FORMAT_NATIVE_I Field

public readonly Int32 FILE_ARCHIVE_FORMAT_NATIVE_I;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_ARCHIVE_FORMAT_NATIVE_II Field

public readonly Int32 FILE_ARCHIVE_FORMAT_NATIVE_II;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_ARCHIVE_FORMAT_NOT_APPLICABLE Field

public readonly Int32 FILE_ARCHIVE_FORMAT_NOT_APPLICABLE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_ARCHIVE_TYPE_NATIVE Field

public readonly Int32 FILE_ARCHIVE_TYPE_NATIVE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_ARCHIVE_TYPE_PVCS Field

public readonly Int32 FILE_ARCHIVE_TYPE_PVCS;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_ARCHIVE_TYPE_VSS Field

public readonly Int32 FILE_ARCHIVE_TYPE_VSS;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_COMPRESSION_LEVEL_DEFAULT Field

public readonly Int32 FILE_COMPRESSION_LEVEL_DEFAULT;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_COMPRESSION_LEVEL_MAXIMIZE_COMPRESSION Field

public readonly Int32 FILE_COMPRESSION_LEVEL_MAXIMIZE_COMPRESSION;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_COMPRESSION_LEVEL_MAXIMIZE_SPEED Field

public readonly Int32 FILE_COMPRESSION_LEVEL_MAXIMIZE_SPEED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_COMPRESSION_LEVEL_NONE Field

public readonly Int32 FILE_COMPRESSION_LEVEL_NONE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_ENCODING_ASCII Field

public readonly Int32 FILE_ENCODING_ASCII;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_ENCODING_BINARY Field

public readonly Int32 FILE_ENCODING_BINARY;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_ENCODING_UNICODE Field

public readonly Int32 FILE_ENCODING_UNICODE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_EOL_CLIENT_DEFINED Field

public const Int32 FILE_EOL_CLIENT_DEFINED = 256;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_EOL_FIXED_CR Field

public const Int32 FILE_EOL_FIXED_CR = 257;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_EOL_FIXED_CRLF Field

public const Int32 FILE_EOL_FIXED_CRLF = 258;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_EOL_FIXED_LF Field

public const Int32 FILE_EOL_FIXED_LF = 259;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_EXECUTABLE_NO Field

public readonly Int32 FILE_EXECUTABLE_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_EXECUTABLE_YES Field

public readonly Int32 FILE_EXECUTABLE_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_LOCAL_FILE_EXISTS_NO Field

public readonly Int32 FILE_LOCAL_FILE_EXISTS_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_LOCAL_FILE_EXISTS_YES Field

public readonly Int32 FILE_LOCAL_FILE_EXISTS_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_STATUS_CURRENT Field

public readonly Int32 FILE_STATUS_CURRENT;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_STATUS_MERGE Field

public readonly Int32 FILE_STATUS_MERGE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_STATUS_MISSING Field

public readonly Int32 FILE_STATUS_MISSING;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_STATUS_MODIFIED Field

public readonly Int32 FILE_STATUS_MODIFIED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_STATUS_NOT_IN_VIEW Field

public readonly Int32 FILE_STATUS_NOT_IN_VIEW;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_STATUS_OUT_OF_DATE Field

public readonly Int32 FILE_STATUS_OUT_OF_DATE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_STATUS_UNKNOWN Field

public readonly Int32 FILE_STATUS_UNKNOWN;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_STORAGE_TYPE_DELTA Field

public readonly Int32 FILE_STORAGE_TYPE_DELTA;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_STORAGE_TYPE_FULL_VERSIONS Field

public readonly Int32 FILE_STORAGE_TYPE_FULL_VERSIONS;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_SYNC_KNOWN_NO Field

public readonly Int32 FILE_SYNC_KNOWN_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_SYNC_KNOWN_YES Field

public readonly Int32 FILE_SYNC_KNOWN_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_SYNC_ON_ROOT_PATH_NO Field

public readonly Int32 FILE_SYNC_ON_ROOT_PATH_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FILE_SYNC_ON_ROOT_PATH_YES Field

public readonly Int32 FILE_SYNC_ON_ROOT_PATH_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FLAG_NO Field

public readonly Int32 FLAG_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FLAG_YES Field

public readonly Int32 FLAG_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FOLDER_EXCLUDE_FLAGS_INHERIT_AND_LOCAL_EXCLUDE_LIST Field

public readonly Int32 FOLDER_EXCLUDE_FLAGS_INHERIT_AND_LOCAL_EXCLUDE_LIST;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FOLDER_EXCLUDE_FLAGS_LOCAL_EXCLUDE_LIST Field

public readonly Int32 FOLDER_EXCLUDE_FLAGS_LOCAL_EXCLUDE_LIST;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.FOLDER_EXCLUDE_FLAGS_NO_EXCLUDE_LIST Field

public readonly Int32 FOLDER_EXCLUDE_FLAGS_NO_EXCLUDE_LIST;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.MY_LOCK_EXCLUSIVELY_LOCKED_BY_ME Field

public readonly Int32 MY_LOCK_EXCLUSIVELY_LOCKED_BY_ME;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.MY_LOCK_NON_EXCLUSIVELY_LOCKED_BY_ME Field

public readonly Int32 MY_LOCK_NON_EXCLUSIVELY_LOCKED_BY_ME;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.MY_LOCK_NOT_LOCKED_BY_ME Field

public readonly Int32 MY_LOCK_NOT_LOCKED_BY_ME;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.PROJECT_ENCRYPTION_NONE Field

public readonly Int32 PROJECT_ENCRYPTION_NONE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.PROJECT_ENCRYPTION_RC2_CBC Field

public readonly Int32 PROJECT_ENCRYPTION_RC2_CBC;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.PROJECT_ENCRYPTION_RC2_CFB Field

public readonly Int32 PROJECT_ENCRYPTION_RC2_CFB;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.PROJECT_ENCRYPTION_RC2_ECB Field

public readonly Int32 PROJECT_ENCRYPTION_RC2_ECB;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.PROJECT_ENCRYPTION_RC4 Field

public readonly Int32 PROJECT_ENCRYPTION_RC4;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.PROJECT_PROCESS_LINKS_DIRECT Field

public const Int32 PROJECT_PROCESS_LINKS_DIRECT = 0;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.PROJECT_PROCESS_LINKS_VIA_PROCESS_TASK Field

public const Int32 PROJECT_PROCESS_LINKS_VIA_PROCESS_TASK = 1;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.PROJECT_TYPE_PVCS Field

public readonly Int32 PROJECT_TYPE_PVCS;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.PROJECT_TYPE_STARTEAM Field

public readonly Int32 PROJECT_TYPE_STARTEAM;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.PROJECT_TYPE_VISUAL_SOURCESAFE Field

public readonly Int32 PROJECT_TYPE_VISUAL_SOURCESAFE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.READ_ONLY_NO Field

public readonly Int32 READ_ONLY_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.READ_ONLY_YES Field

public readonly Int32 READ_ONLY_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.READ_STATUS_READ Field

public readonly Int32 READ_STATUS_READ;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.READ_STATUS_UNREAD Field

public readonly Int32 READ_STATUS_UNREAD;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.REQ_STATUS_ACCEPTED Field

public const Int32 REQ_STATUS_ACCEPTED = 2;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.REQ_STATUS_APPROVED Field

public const Int32 REQ_STATUS_APPROVED = 9;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.REQ_STATUS_COMPLETE Field

public const Int32 REQ_STATUS_COMPLETE = 6;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.REQ_STATUS_DEFERRED Field

public const Int32 REQ_STATUS_DEFERRED = 4;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.REQ_STATUS_DRAFT Field

public const Int32 REQ_STATUS_DRAFT = 3;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.REQ_STATUS_PENDING Field

public const Int32 REQ_STATUS_PENDING = 1;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.REQ_STATUS_READY Field

public const Int32 REQ_STATUS_READY = 7;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.REQ_STATUS_REJECTED Field

public const Int32 REQ_STATUS_REJECTED = 8;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.REQ_STATUS_REVIEW Field

public const Int32 REQ_STATUS_REVIEW = 5;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.REQ_STATUS_SUBMITTED Field

public const Int32 REQ_STATUS_SUBMITTED = 0;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.SHARE_STATE_DERIVED_SHARE Field

public readonly Int32 SHARE_STATE_DERIVED_SHARE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.SHARE_STATE_NOT_SHARED Field

public readonly Int32 SHARE_STATE_NOT_SHARED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.SHARE_STATE_ROOT_SHARE Field

public readonly Int32 SHARE_STATE_ROOT_SHARE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_CONSTRAINT_TYPE_AS_LATE_AS_POSSIBLE Field

public readonly Int32 TASK_CONSTRAINT_TYPE_AS_LATE_AS_POSSIBLE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_CONSTRAINT_TYPE_AS_SOON_AS_POSSIBLE Field

public readonly Int32 TASK_CONSTRAINT_TYPE_AS_SOON_AS_POSSIBLE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_CONSTRAINT_TYPE_FINISH_NO_EARLIER_THAN Field

public readonly Int32 TASK_CONSTRAINT_TYPE_FINISH_NO_EARLIER_THAN;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_CONSTRAINT_TYPE_FINISH_NO_LATER_THAN Field

public readonly Int32 TASK_CONSTRAINT_TYPE_FINISH_NO_LATER_THAN;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_CONSTRAINT_TYPE_MUST_FINISH_ON Field

public readonly Int32 TASK_CONSTRAINT_TYPE_MUST_FINISH_ON;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_CONSTRAINT_TYPE_MUST_START_ON Field

public readonly Int32 TASK_CONSTRAINT_TYPE_MUST_START_ON;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_CONSTRAINT_TYPE_START_NO_EARLIER_THAN Field

public readonly Int32 TASK_CONSTRAINT_TYPE_START_NO_EARLIER_THAN;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_CONSTRAINT_TYPE_START_NO_LATER_THAN Field

public readonly Int32 TASK_CONSTRAINT_TYPE_START_NO_LATER_THAN;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_IS_MY_TASK_NO Field

public readonly Int32 TASK_IS_MY_TASK_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_IS_MY_TASK_YES Field

public readonly Int32 TASK_IS_MY_TASK_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_MILESTONE_NO Field

public readonly Int32 TASK_MILESTONE_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_MILESTONE_YES Field

public readonly Int32 TASK_MILESTONE_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_NEEDS_ATTENTION_NO Field

public readonly Int32 TASK_NEEDS_ATTENTION_NO;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_NEEDS_ATTENTION_YES Field

public readonly Int32 TASK_NEEDS_ATTENTION_YES;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_ORIGIN_MSPROJECT Field

public readonly Int32 TASK_ORIGIN_MSPROJECT;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_ORIGIN_STARTEAM Field

public readonly Int32 TASK_ORIGIN_STARTEAM;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_PRIORITY_DO_NOT_LEVEL Field

public readonly Int32 TASK_PRIORITY_DO_NOT_LEVEL;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_PRIORITY_HIGH Field

public readonly Int32 TASK_PRIORITY_HIGH;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_PRIORITY_HIGHER Field

public readonly Int32 TASK_PRIORITY_HIGHER;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_PRIORITY_HIGHEST Field

public readonly Int32 TASK_PRIORITY_HIGHEST;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_PRIORITY_LOW Field

public readonly Int32 TASK_PRIORITY_LOW;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_PRIORITY_LOWER Field

public readonly Int32 TASK_PRIORITY_LOWER;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_PRIORITY_LOWEST Field

public readonly Int32 TASK_PRIORITY_LOWEST;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_PRIORITY_MEDIUM Field

public readonly Int32 TASK_PRIORITY_MEDIUM;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_PRIORITY_VERY_HIGH Field

public readonly Int32 TASK_PRIORITY_VERY_HIGH;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_PRIORITY_VERY_LOW Field

public readonly Int32 TASK_PRIORITY_VERY_LOW;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_STATUS_CLOSED Field

public readonly Int32 TASK_STATUS_CLOSED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_STATUS_FINISHED Field

public readonly Int32 TASK_STATUS_FINISHED;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_STATUS_HOLD Field

public readonly Int32 TASK_STATUS_HOLD;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_STATUS_IN_PROGRESS Field

public readonly Int32 TASK_STATUS_IN_PROGRESS;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_STATUS_PENDING Field

public readonly Int32 TASK_STATUS_PENDING;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_STATUS_READY_TO_START Field

public readonly Int32 TASK_STATUS_READY_TO_START;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_TYPE_FIXED_DURATION Field

public readonly Int32 TASK_TYPE_FIXED_DURATION;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_TYPE_FIXED_UNITS Field

public readonly Int32 TASK_TYPE_FIXED_UNITS;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_TYPE_FIXED_WORK Field

public readonly Int32 TASK_TYPE_FIXED_WORK;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_USAGE_CHECKIN Field

public static readonly Int32 TASK_USAGE_CHECKIN;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_USAGE_OTHER Field

public static readonly Int32 TASK_USAGE_OTHER;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_USAGE_PROMOTE Field

public static readonly Int32 TASK_USAGE_PROMOTE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_USAGE_REBASE Field

public static readonly Int32 TASK_USAGE_REBASE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASK_USAGE_REPLICATE Field

public static readonly Int32 TASK_USAGE_REPLICATE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASKDEPENDENCY_TYPE_FF Field

public readonly Int32 TASKDEPENDENCY_TYPE_FF;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASKDEPENDENCY_TYPE_FS Field

public readonly Int32 TASKDEPENDENCY_TYPE_FS;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASKDEPENDENCY_TYPE_SF Field

public readonly Int32 TASKDEPENDENCY_TYPE_SF;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TASKDEPENDENCY_TYPE_SS Field

public readonly Int32 TASKDEPENDENCY_TYPE_SS;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TOPIC_PRIORITY_HIGH Field

public readonly Int32 TOPIC_PRIORITY_HIGH;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TOPIC_PRIORITY_LOW Field

public readonly Int32 TOPIC_PRIORITY_LOW;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TOPIC_PRIORITY_NORMAL Field

public readonly Int32 TOPIC_PRIORITY_NORMAL;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TOPIC_STATUS_ACTIVE Field

public readonly Int32 TOPIC_STATUS_ACTIVE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TOPIC_STATUS_INACTIVE Field

public readonly Int32 TOPIC_STATUS_INACTIVE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TOPIC_TYPE_RESPONSE Field

public readonly Int32 TOPIC_TYPE_RESPONSE;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.TOPIC_TYPE_TOPIC Field

public readonly Int32 TOPIC_TYPE_TOPIC;

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums Methods

The methods of the PropertyEnums class are listed below. For a complete list of PropertyEnums class members, see the PropertyEnums Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.MemberwiseClone Method

public override object MemberwiseClone();

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyEnums.ToString Method

public override string ToString();

See Also

PropertyEnums Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames Class

For a list of all members of this type, see PropertyNames Members.

System.Object
PropertyNames

public class PropertyNames

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

PropertyNames Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames Members

PropertyNames overview

Public Static Fields

ITEM_DELETED_TIME
ITEM_DELETED_USER_ID
PROJECT_DEFAULT_TYPES
PROJECT_PROCESS_LINKS
REQ_PARENT_OBJECTID
REQ_STATUS
TASK_USAGE
TASK_USAGE_90
VIEW_RESOLVED_ID

Public Instance Fields

AM_I_RECIPIENT
ATTACHMENT_COUNT
ATTACHMENT_IDS
ATTACHMENT_NAMES
AUDIT_CLASS_ID
AUDIT_CLASS_NAME
AUDIT_CLASS2_NAME
AUDIT_CLASS3_NAME
AUDIT_DESCRIPTOR
AUDIT_DESCRIPTOR2
AUDIT_DESCRIPTOR3
AUDIT_EVENT_ID
AUDIT_FOLDER
AUDIT_FOLDER_VMID
AUDIT_ITEM_1_INFO
AUDIT_ITEM_2_INFO
AUDIT_ITEM_3_INFO
AUDIT_OBJECT_ID
AUDIT_PROJECT_ID
AUDIT_TARGET_1_REVISION_TIME
AUDIT_TARGET_2_CLASS_ID
AUDIT_TARGET_2_OBJECT_ID
AUDIT_TARGET_2_REVISION_TIME
AUDIT_TARGET_3_CLASS_ID
AUDIT_TARGET_3_OBJECT_ID
AUDIT_TARGET_3_REVISION_TIME
AUDIT_USER_ID
BRANCH_ON_CHANGE
BRANCH_STATE
COMMENT
COMMENT_ID
CONFIGURATION_TIME
CR_ADDRESSED_BY
CR_ADDRESSED_IN
CR_ADDRESSED_IN_VIEW
CR_CATEGORY
CR_CHANGE_NUMBER
CR_CLOSED_ON
CR_COMPONENT
CR_DESCRIPTION
CR_ENTERED_BY
CR_ENTERED_ON
CR_EXTERNAL_REFERENCE
CR_FIX
CR_FOLDER
CR_LAST_BUILD_TESTED
CR_PLATFORM
CR_PRIORITY
CR_RESOLVED_ON
CR_RESPONSIBILITY
CR_SEVERITY
CR_STATUS
CR_SYNOPSIS
CR_TEST_COMMAND
CR_TYPE
CR_VERIFIED_ON
CR_WORK_AROUND
CREATED_TIME
CREATED_USER_ID
DELETED_TIME
DELETED_USER_ID
DOTNOTATION
DOTNOTATION_ID
END_MODIFIED_TIME
EXCLUSIVE_LOCKER
FILE_ARCHIVE_FORMAT
FILE_ARCHIVE_NAME
FILE_ARCHIVE_PATH
FILE_ARCHIVE_TYPE
FILE_COMPRESSION_LEVEL
FILE_CONTENT_REVISION
FILE_DESCRIPTION
FILE_ENCODING
FILE_EOL_CHARACTER
FILE_EXECUTABLE
FILE_EXTENSION
FILE_FILE_TIME_AT_CHECKIN
FILE_FOLDER
FILE_HIVE_ID
FILE_LOCAL_EXECUTABLE
FILE_LOCAL_FILE_EXISTS
FILE_LOCAL_NAME
FILE_LOCAL_PATH
FILE_LOCAL_SIZE
FILE_LOCAL_TIMESTAMP
FILE_MD5_CHECKSUM
FILE_NAME
FILE_PATH
FILE_PROJECT_ID
FILE_PVCS_REVISION
FILE_SIZE
FILE_STATUS
FILE_STORAGE_TYPE
FILE_SYNC_CONTENT_VERSION
FILE_SYNC_KNOWN
FILE_SYNC_MD5
FILE_SYNC_OBJECT_VERSION
FILE_SYNC_ON_ROOT_PATH
FILE_SYNC_PATH_VERSION
FILE_SYNC_SIZE
FILE_SYNC_TIME
FILE_VAULT_BRANCH_VERSION
FILE_VIEW_VERSION
FLAG
FLAG_USER_LIST
FOLDER_CREATE_PROJECT_ID
FOLDER_DESCRIPTION
FOLDER_EXCLUDE_FLAGS
FOLDER_EXCLUDE_SPEC
FOLDER_NAME
FOLDER_PATH
FOLDER_WORKING_FOLDER
LABEL_DESCRIPTION
LABEL_FLAGS
LABEL_LABEL_TIME
LABEL_MEMBER_ID
LABEL_NAME
LABEL_PROJECT_ID
LABEL_VIEW_ID
MODIFIED_TIME
MODIFIED_USER_ID
MY_LOCK
NON_EXCLUSIVE_LOCKERS
OBJECT_ID
PARENT_OBJECT_ID
PARENT_REVISION
PATH_REVISION
PROJECT_ALTERNATE_CR_EDITOR_PATH
PROJECT_ALTERNATE_FILE_EDITOR_PATH
PROJECT_ALTERNATE_REQUIREMENT_EDITOR_PATH
PROJECT_ALTERNATE_TASK_EDITOR_PATH
PROJECT_ALTERNATE_TOPIC_EDITOR_PATH
PROJECT_COMPACTION
PROJECT_CONFIGSOURCE1
PROJECT_CONFIGSOURCE2
PROJECT_DEFAULT_VIEW_ID
PROJECT_DESCRIPTION
PROJECT_DISPLAY_ALTERNATE_CR_EDITOR
PROJECT_DISPLAY_ALTERNATE_FILE_EDITOR
PROJECT_DISPLAY_ALTERNATE_REQUIREMENT_EDITOR
PROJECT_DISPLAY_ALTERNATE_TASK_EDITOR
PROJECT_DISPLAY_ALTERNATE_TOPIC_EDITOR
PROJECT_ENCRYPTION
PROJECT_FORCE_CHECKIN_REASON
PROJECT_KEYWORD_EXTENSIONS
PROJECT_MAIL
PROJECT_MARK_UNLOCKED_FILES_READ_ONLY
PROJECT_NAME
PROJECT_PROCESS_REQUIRED
PROJECT_PROCESS_SELECT_CR
PROJECT_PROCESS_SELECT_REQUIREMENT
PROJECT_PROCESS_SELECT_TASK
PROJECT_PROCESS_SHOW_CR_IN_PROGRESS
PROJECT_PROCESS_SHOW_CR_OPEN
PROJECT_PROCESS_SHOW_REQUIREMENT_APPROVED
PROJECT_PROCESS_SHOW_TASK_IN_PROGRESS
PROJECT_PROCESS_SHOW_TASK_READY
PROJECT_REQUIRE_LOCK_FOR_CHECKIN
PROJECT_TYPE
PROJECT_USE_KEYWORDS
PROMOTIONMODEL_DESCRIPTION
PROMOTIONMODEL_NAME
PROMOTIONMODEL_STATE_COUNT
PROMOTIONMODEL_STATE_IDS
PROMOTIONSTATE_DESCRIPTION
PROMOTIONSTATE_LABEL_ID
PROMOTIONSTATE_NAME
READ_ONLY
READ_STATUS
READ_STATUS_USER_LIST
RECIPIENT_COUNT
RECIPIENT_IDS
RECIPIENT_NAMES
REF_CREATED_TIME
REF_CREATED_USER_ID
REF_DELETED_TIME
REF_DELETED_USER_ID
REF_DERIVED_COUNT
REF_END_MODIFIED_TIME
REF_FLAGS
REF_FOLDER_ITEM_ID
REF_FOLDER_PATH
REF_ITEM_ID
REF_ITEM_OBJECT_ID
REF_ITEM_REVISION
REF_MODIFIED_TIME
REF_MODIFIED_USER_ID
REF_PROJECT_ID
REF_PROJECT_NAME
REF_VIEW_ID
REF_VIEW_PATH
REV_BRANCH_FLAG
REV_BRANCH_STATE
REV_LOCATION_ITEM_ID
REV_OBJECT_ID
REV_OBJECT_TIME
REV_PARENT_ITEM_ID
REV_PROJECT_ID
REV_TIME
REV_USER_ID
REV_VIEW_ID
REVISION_FLAGS
REVISION_NUMBER
ROOT_OBJECT_ID
SHARE_STATE
SHORT_COMMENT
TASK_ACTUAL_FINISH
TASK_ACTUAL_HOURS
TASK_ACTUAL_START
TASK_ATTENTION_NOTES
TASK_CHILDREN_COUNT
TASK_CONSTRAINT_DATE
TASK_CONSTRAINT_TYPE
TASK_DURATION
TASK_ESTIMATED_FINISH
TASK_ESTIMATED_FINISH_VARIANCE
TASK_ESTIMATED_HOURS
TASK_ESTIMATED_HOURS_VARIANCE
TASK_ESTIMATED_START
TASK_ESTIMATED_START_VARIANCE
TASK_GUID
TASK_IS_MY_TASK
TASK_IS_REPLICATED
TASK_MILESTONE
TASK_MSPROJECT_FILENAME
TASK_MSPROJECT_LAST_UPDATE
TASK_NAME
TASK_NEEDS_ATTENTION
TASK_NOTES
TASK_NUMBER
TASK_ORIGIN
TASK_PARENT_ID
TASK_PERCENT_COMPLETE
TASK_PRIORITY
TASK_RESOURCE_COUNT
TASK_RESOURCE_IDS
TASK_RESOURCE_NAMES
TASK_RESPONSIBILITY
TASK_STATUS
TASK_TYPE
TASK_UNIQUE_ID
TASK_WBS_CODE
TASK_WORK_DEPENDENCY_LAST_UPDATE
TASK_WORKRECORD_COUNT
TASKDEPENDENCY_LAG_TIME
TASKDEPENDENCY_PREDECESSOR_ID
TASKDEPENDENCY_TASK_ID
TASKDEPENDENCY_TYPE
TOPIC_CHILDREN_COUNT
TOPIC_DESCRIPTION
TOPIC_NUMBER
TOPIC_PARENT
TOPIC_PRIORITY
TOPIC_STATUS
TOPIC_TITLE
TOPIC_TYPE
USER_ADDRESS
USER_EMAIL_ADDRESS
USER_FAX
USER_FULL_NAME
USER_PAGER
USER_PHONE
USER_VOICE_MAIL
VIEW_BASECONFIG_DATA
VIEW_BASECONFIG_TYPE
VIEW_DELETE_COMPLETE
VIEW_DESCRIPTION
VIEW_FLAGS
VIEW_ID
VIEW_NAME
VIEW_PARENT_VIEW_ID
VIEW_PROJECT_ID
VIEW_PROMOTION_ID
VIEW_ROOT_MEMBER_ID
VIEW_SHARE_FLAGS
VIEW_WORKING_FOLDER
WORKRECORD_COMMENT
WORKRECORD_DATE
WORKRECORD_HOURS
WORKRECORD_REMAINING_HOURS
WORKRECORD_TASK_ID
WORKRECORD_USER_ID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames Fields

The fields of the PropertyNames class are listed below. For a complete list of PropertyNames class members, see the PropertyNames Members topic.

Public Static Fields

ITEM_DELETED_TIME
ITEM_DELETED_USER_ID
PROJECT_DEFAULT_TYPES
PROJECT_PROCESS_LINKS
REQ_PARENT_OBJECTID
REQ_STATUS
TASK_USAGE
TASK_USAGE_90
VIEW_RESOLVED_ID

Public Instance Fields

AM_I_RECIPIENT
ATTACHMENT_COUNT
ATTACHMENT_IDS
ATTACHMENT_NAMES
AUDIT_CLASS_ID
AUDIT_CLASS_NAME
AUDIT_CLASS2_NAME
AUDIT_CLASS3_NAME
AUDIT_DESCRIPTOR
AUDIT_DESCRIPTOR2
AUDIT_DESCRIPTOR3
AUDIT_EVENT_ID
AUDIT_FOLDER
AUDIT_FOLDER_VMID
AUDIT_ITEM_1_INFO
AUDIT_ITEM_2_INFO
AUDIT_ITEM_3_INFO
AUDIT_OBJECT_ID
AUDIT_PROJECT_ID
AUDIT_TARGET_1_REVISION_TIME
AUDIT_TARGET_2_CLASS_ID
AUDIT_TARGET_2_OBJECT_ID
AUDIT_TARGET_2_REVISION_TIME
AUDIT_TARGET_3_CLASS_ID
AUDIT_TARGET_3_OBJECT_ID
AUDIT_TARGET_3_REVISION_TIME
AUDIT_USER_ID
BRANCH_ON_CHANGE
BRANCH_STATE
COMMENT
COMMENT_ID
CONFIGURATION_TIME
CR_ADDRESSED_BY
CR_ADDRESSED_IN
CR_ADDRESSED_IN_VIEW
CR_CATEGORY
CR_CHANGE_NUMBER
CR_CLOSED_ON
CR_COMPONENT
CR_DESCRIPTION
CR_ENTERED_BY
CR_ENTERED_ON
CR_EXTERNAL_REFERENCE
CR_FIX
CR_FOLDER
CR_LAST_BUILD_TESTED
CR_PLATFORM
CR_PRIORITY
CR_RESOLVED_ON
CR_RESPONSIBILITY
CR_SEVERITY
CR_STATUS
CR_SYNOPSIS
CR_TEST_COMMAND
CR_TYPE
CR_VERIFIED_ON
CR_WORK_AROUND
CREATED_TIME
CREATED_USER_ID
DELETED_TIME
DELETED_USER_ID
DOTNOTATION
DOTNOTATION_ID
END_MODIFIED_TIME
EXCLUSIVE_LOCKER
FILE_ARCHIVE_FORMAT
FILE_ARCHIVE_NAME
FILE_ARCHIVE_PATH
FILE_ARCHIVE_TYPE
FILE_COMPRESSION_LEVEL
FILE_CONTENT_REVISION
FILE_DESCRIPTION
FILE_ENCODING
FILE_EOL_CHARACTER
FILE_EXECUTABLE
FILE_EXTENSION
FILE_FILE_TIME_AT_CHECKIN
FILE_FOLDER
FILE_HIVE_ID
FILE_LOCAL_EXECUTABLE
FILE_LOCAL_FILE_EXISTS
FILE_LOCAL_NAME
FILE_LOCAL_PATH
FILE_LOCAL_SIZE
FILE_LOCAL_TIMESTAMP
FILE_MD5_CHECKSUM
FILE_NAME
FILE_PATH
FILE_PROJECT_ID
FILE_PVCS_REVISION
FILE_SIZE
FILE_STATUS
FILE_STORAGE_TYPE
FILE_SYNC_CONTENT_VERSION
FILE_SYNC_KNOWN
FILE_SYNC_MD5
FILE_SYNC_OBJECT_VERSION
FILE_SYNC_ON_ROOT_PATH
FILE_SYNC_PATH_VERSION
FILE_SYNC_SIZE
FILE_SYNC_TIME
FILE_VAULT_BRANCH_VERSION
FILE_VIEW_VERSION
FLAG
FLAG_USER_LIST
FOLDER_CREATE_PROJECT_ID
FOLDER_DESCRIPTION
FOLDER_EXCLUDE_FLAGS
FOLDER_EXCLUDE_SPEC
FOLDER_NAME
FOLDER_PATH
FOLDER_WORKING_FOLDER
LABEL_DESCRIPTION
LABEL_FLAGS
LABEL_LABEL_TIME
LABEL_MEMBER_ID
LABEL_NAME
LABEL_PROJECT_ID
LABEL_VIEW_ID
MODIFIED_TIME
MODIFIED_USER_ID
MY_LOCK
NON_EXCLUSIVE_LOCKERS
OBJECT_ID
PARENT_OBJECT_ID
PARENT_REVISION
PATH_REVISION
PROJECT_ALTERNATE_CR_EDITOR_PATH
PROJECT_ALTERNATE_FILE_EDITOR_PATH
PROJECT_ALTERNATE_REQUIREMENT_EDITOR_PATH
PROJECT_ALTERNATE_TASK_EDITOR_PATH
PROJECT_ALTERNATE_TOPIC_EDITOR_PATH
PROJECT_COMPACTION
PROJECT_CONFIGSOURCE1
PROJECT_CONFIGSOURCE2
PROJECT_DEFAULT_VIEW_ID
PROJECT_DESCRIPTION
PROJECT_DISPLAY_ALTERNATE_CR_EDITOR
PROJECT_DISPLAY_ALTERNATE_FILE_EDITOR
PROJECT_DISPLAY_ALTERNATE_REQUIREMENT_EDITOR
PROJECT_DISPLAY_ALTERNATE_TASK_EDITOR
PROJECT_DISPLAY_ALTERNATE_TOPIC_EDITOR
PROJECT_ENCRYPTION
PROJECT_FORCE_CHECKIN_REASON
PROJECT_KEYWORD_EXTENSIONS
PROJECT_MAIL
PROJECT_MARK_UNLOCKED_FILES_READ_ONLY
PROJECT_NAME
PROJECT_PROCESS_REQUIRED
PROJECT_PROCESS_SELECT_CR
PROJECT_PROCESS_SELECT_REQUIREMENT
PROJECT_PROCESS_SELECT_TASK
PROJECT_PROCESS_SHOW_CR_IN_PROGRESS
PROJECT_PROCESS_SHOW_CR_OPEN
PROJECT_PROCESS_SHOW_REQUIREMENT_APPROVED
PROJECT_PROCESS_SHOW_TASK_IN_PROGRESS
PROJECT_PROCESS_SHOW_TASK_READY
PROJECT_REQUIRE_LOCK_FOR_CHECKIN
PROJECT_TYPE
PROJECT_USE_KEYWORDS
PROMOTIONMODEL_DESCRIPTION
PROMOTIONMODEL_NAME
PROMOTIONMODEL_STATE_COUNT
PROMOTIONMODEL_STATE_IDS
PROMOTIONSTATE_DESCRIPTION
PROMOTIONSTATE_LABEL_ID
PROMOTIONSTATE_NAME
READ_ONLY
READ_STATUS
READ_STATUS_USER_LIST
RECIPIENT_COUNT
RECIPIENT_IDS
RECIPIENT_NAMES
REF_CREATED_TIME
REF_CREATED_USER_ID
REF_DELETED_TIME
REF_DELETED_USER_ID
REF_DERIVED_COUNT
REF_END_MODIFIED_TIME
REF_FLAGS
REF_FOLDER_ITEM_ID
REF_FOLDER_PATH
REF_ITEM_ID
REF_ITEM_OBJECT_ID
REF_ITEM_REVISION
REF_MODIFIED_TIME
REF_MODIFIED_USER_ID
REF_PROJECT_ID
REF_PROJECT_NAME
REF_VIEW_ID
REF_VIEW_PATH
REV_BRANCH_FLAG
REV_BRANCH_STATE
REV_LOCATION_ITEM_ID
REV_OBJECT_ID
REV_OBJECT_TIME
REV_PARENT_ITEM_ID
REV_PROJECT_ID
REV_TIME
REV_USER_ID
REV_VIEW_ID
REVISION_FLAGS
REVISION_NUMBER
ROOT_OBJECT_ID
SHARE_STATE
SHORT_COMMENT
TASK_ACTUAL_FINISH
TASK_ACTUAL_HOURS
TASK_ACTUAL_START
TASK_ATTENTION_NOTES
TASK_CHILDREN_COUNT
TASK_CONSTRAINT_DATE
TASK_CONSTRAINT_TYPE
TASK_DURATION
TASK_ESTIMATED_FINISH
TASK_ESTIMATED_FINISH_VARIANCE
TASK_ESTIMATED_HOURS
TASK_ESTIMATED_HOURS_VARIANCE
TASK_ESTIMATED_START
TASK_ESTIMATED_START_VARIANCE
TASK_GUID
TASK_IS_MY_TASK
TASK_IS_REPLICATED
TASK_MILESTONE
TASK_MSPROJECT_FILENAME
TASK_MSPROJECT_LAST_UPDATE
TASK_NAME
TASK_NEEDS_ATTENTION
TASK_NOTES
TASK_NUMBER
TASK_ORIGIN
TASK_PARENT_ID
TASK_PERCENT_COMPLETE
TASK_PRIORITY
TASK_RESOURCE_COUNT
TASK_RESOURCE_IDS
TASK_RESOURCE_NAMES
TASK_RESPONSIBILITY
TASK_STATUS
TASK_TYPE
TASK_UNIQUE_ID
TASK_WBS_CODE
TASK_WORK_DEPENDENCY_LAST_UPDATE
TASK_WORKRECORD_COUNT
TASKDEPENDENCY_LAG_TIME
TASKDEPENDENCY_PREDECESSOR_ID
TASKDEPENDENCY_TASK_ID
TASKDEPENDENCY_TYPE
TOPIC_CHILDREN_COUNT
TOPIC_DESCRIPTION
TOPIC_NUMBER
TOPIC_PARENT
TOPIC_PRIORITY
TOPIC_STATUS
TOPIC_TITLE
TOPIC_TYPE
USER_ADDRESS
USER_EMAIL_ADDRESS
USER_FAX
USER_FULL_NAME
USER_PAGER
USER_PHONE
USER_VOICE_MAIL
VIEW_BASECONFIG_DATA
VIEW_BASECONFIG_TYPE
VIEW_DELETE_COMPLETE
VIEW_DESCRIPTION
VIEW_FLAGS
VIEW_ID
VIEW_NAME
VIEW_PARENT_VIEW_ID
VIEW_PROJECT_ID
VIEW_PROMOTION_ID
VIEW_ROOT_MEMBER_ID
VIEW_SHARE_FLAGS
VIEW_WORKING_FOLDER
WORKRECORD_COMMENT
WORKRECORD_DATE
WORKRECORD_HOURS
WORKRECORD_REMAINING_HOURS
WORKRECORD_TASK_ID
WORKRECORD_USER_ID

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AM_I_RECIPIENT Field

public readonly String AM_I_RECIPIENT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.ATTACHMENT_COUNT Field

public readonly String ATTACHMENT_COUNT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.ATTACHMENT_IDS Field

public readonly String ATTACHMENT_IDS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.ATTACHMENT_NAMES Field

public readonly String ATTACHMENT_NAMES;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_CLASS_ID Field

public readonly String AUDIT_CLASS_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_CLASS_NAME Field

public readonly String AUDIT_CLASS_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_CLASS2_NAME Field

public readonly String AUDIT_CLASS2_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_CLASS3_NAME Field

public readonly String AUDIT_CLASS3_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_DESCRIPTOR Field

public readonly String AUDIT_DESCRIPTOR;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_DESCRIPTOR2 Field

public readonly String AUDIT_DESCRIPTOR2;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_DESCRIPTOR3 Field

public readonly String AUDIT_DESCRIPTOR3;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_EVENT_ID Field

public readonly String AUDIT_EVENT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_FOLDER Field

public readonly String AUDIT_FOLDER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_FOLDER_VMID Field

public readonly String AUDIT_FOLDER_VMID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_ITEM_1_INFO Field

public readonly String AUDIT_ITEM_1_INFO;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_ITEM_2_INFO Field

public readonly String AUDIT_ITEM_2_INFO;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_ITEM_3_INFO Field

public readonly String AUDIT_ITEM_3_INFO;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_OBJECT_ID Field

public readonly String AUDIT_OBJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_PROJECT_ID Field

public readonly String AUDIT_PROJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_TARGET_1_REVISION_TIME Field

public readonly String AUDIT_TARGET_1_REVISION_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_TARGET_2_CLASS_ID Field

public readonly String AUDIT_TARGET_2_CLASS_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_TARGET_2_OBJECT_ID Field

public readonly String AUDIT_TARGET_2_OBJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_TARGET_2_REVISION_TIME Field

public readonly String AUDIT_TARGET_2_REVISION_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_TARGET_3_CLASS_ID Field

public readonly String AUDIT_TARGET_3_CLASS_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_TARGET_3_OBJECT_ID Field

public readonly String AUDIT_TARGET_3_OBJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_TARGET_3_REVISION_TIME Field

public readonly String AUDIT_TARGET_3_REVISION_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.AUDIT_USER_ID Field

public readonly String AUDIT_USER_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.BRANCH_ON_CHANGE Field

public readonly String BRANCH_ON_CHANGE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.BRANCH_STATE Field

public readonly String BRANCH_STATE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.COMMENT Field

public readonly String COMMENT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.COMMENT_ID Field

public readonly String COMMENT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CONFIGURATION_TIME Field

public readonly String CONFIGURATION_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_ADDRESSED_BY Field

public readonly String CR_ADDRESSED_BY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_ADDRESSED_IN Field

public readonly String CR_ADDRESSED_IN;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_ADDRESSED_IN_VIEW Field

public readonly String CR_ADDRESSED_IN_VIEW;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_CATEGORY Field

public readonly String CR_CATEGORY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_CHANGE_NUMBER Field

public readonly String CR_CHANGE_NUMBER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_CLOSED_ON Field

public readonly String CR_CLOSED_ON;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_COMPONENT Field

public readonly String CR_COMPONENT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_DESCRIPTION Field

public readonly String CR_DESCRIPTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_ENTERED_BY Field

public readonly String CR_ENTERED_BY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_ENTERED_ON Field

public readonly String CR_ENTERED_ON;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_EXTERNAL_REFERENCE Field

public readonly String CR_EXTERNAL_REFERENCE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_FIX Field

public readonly String CR_FIX;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_FOLDER Field

public readonly String CR_FOLDER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_LAST_BUILD_TESTED Field

public readonly String CR_LAST_BUILD_TESTED;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_PLATFORM Field

public readonly String CR_PLATFORM;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_PRIORITY Field

public readonly String CR_PRIORITY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_RESOLVED_ON Field

public readonly String CR_RESOLVED_ON;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_RESPONSIBILITY Field

public readonly String CR_RESPONSIBILITY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_SEVERITY Field

public readonly String CR_SEVERITY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_STATUS Field

public readonly String CR_STATUS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_SYNOPSIS Field

public readonly String CR_SYNOPSIS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_TEST_COMMAND Field

public readonly String CR_TEST_COMMAND;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_TYPE Field

public readonly String CR_TYPE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_VERIFIED_ON Field

public readonly String CR_VERIFIED_ON;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CR_WORK_AROUND Field

public readonly String CR_WORK_AROUND;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CREATED_TIME Field

public readonly String CREATED_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.CREATED_USER_ID Field

public readonly String CREATED_USER_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.DELETED_TIME Field

public readonly String DELETED_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.DELETED_USER_ID Field

public readonly String DELETED_USER_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.DOTNOTATION Field

public readonly String DOTNOTATION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.DOTNOTATION_ID Field

public readonly String DOTNOTATION_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.END_MODIFIED_TIME Field

public readonly String END_MODIFIED_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.EXCLUSIVE_LOCKER Field

public readonly String EXCLUSIVE_LOCKER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_ARCHIVE_FORMAT Field

public readonly String FILE_ARCHIVE_FORMAT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_ARCHIVE_NAME Field

public readonly String FILE_ARCHIVE_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_ARCHIVE_PATH Field

public readonly String FILE_ARCHIVE_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_ARCHIVE_TYPE Field

public readonly String FILE_ARCHIVE_TYPE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_COMPRESSION_LEVEL Field

public readonly String FILE_COMPRESSION_LEVEL;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_CONTENT_REVISION Field

public readonly String FILE_CONTENT_REVISION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_DESCRIPTION Field

public readonly String FILE_DESCRIPTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_ENCODING Field

public readonly String FILE_ENCODING;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_EOL_CHARACTER Field

public readonly String FILE_EOL_CHARACTER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_EXECUTABLE Field

public readonly String FILE_EXECUTABLE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_EXTENSION Field

public readonly String FILE_EXTENSION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_FILE_TIME_AT_CHECKIN Field

public readonly String FILE_FILE_TIME_AT_CHECKIN;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_FOLDER Field

public readonly String FILE_FOLDER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_HIVE_ID Field

public readonly String FILE_HIVE_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_LOCAL_EXECUTABLE Field

public readonly String FILE_LOCAL_EXECUTABLE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_LOCAL_FILE_EXISTS Field

public readonly String FILE_LOCAL_FILE_EXISTS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_LOCAL_NAME Field

public readonly String FILE_LOCAL_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_LOCAL_PATH Field

public readonly String FILE_LOCAL_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_LOCAL_SIZE Field

public readonly String FILE_LOCAL_SIZE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_LOCAL_TIMESTAMP Field

public readonly String FILE_LOCAL_TIMESTAMP;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_MD5_CHECKSUM Field

public readonly String FILE_MD5_CHECKSUM;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_NAME Field

public readonly String FILE_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_PATH Field

public readonly String FILE_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_PROJECT_ID Field

public readonly String FILE_PROJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_PVCS_REVISION Field

public readonly String FILE_PVCS_REVISION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_SIZE Field

public readonly String FILE_SIZE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_STATUS Field

public readonly String FILE_STATUS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_STORAGE_TYPE Field

public readonly String FILE_STORAGE_TYPE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_SYNC_CONTENT_VERSION Field

public readonly String FILE_SYNC_CONTENT_VERSION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_SYNC_KNOWN Field

public readonly String FILE_SYNC_KNOWN;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_SYNC_MD5 Field

public readonly String FILE_SYNC_MD5;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_SYNC_OBJECT_VERSION Field

public readonly String FILE_SYNC_OBJECT_VERSION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_SYNC_ON_ROOT_PATH Field

public readonly String FILE_SYNC_ON_ROOT_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_SYNC_PATH_VERSION Field

public readonly String FILE_SYNC_PATH_VERSION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_SYNC_SIZE Field

public readonly String FILE_SYNC_SIZE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_SYNC_TIME Field

public readonly String FILE_SYNC_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_VAULT_BRANCH_VERSION Field

public readonly String FILE_VAULT_BRANCH_VERSION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FILE_VIEW_VERSION Field

public readonly String FILE_VIEW_VERSION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FLAG Field

public readonly String FLAG;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FLAG_USER_LIST Field

public readonly String FLAG_USER_LIST;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FOLDER_CREATE_PROJECT_ID Field

public readonly String FOLDER_CREATE_PROJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FOLDER_DESCRIPTION Field

public readonly String FOLDER_DESCRIPTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FOLDER_EXCLUDE_FLAGS Field

public readonly String FOLDER_EXCLUDE_FLAGS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FOLDER_EXCLUDE_SPEC Field

public readonly String FOLDER_EXCLUDE_SPEC;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FOLDER_NAME Field

public readonly String FOLDER_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FOLDER_PATH Field

public readonly String FOLDER_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.FOLDER_WORKING_FOLDER Field

public readonly String FOLDER_WORKING_FOLDER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.ITEM_DELETED_TIME Field

public const String ITEM_DELETED_TIME = "ItemDeletedTime";

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.ITEM_DELETED_USER_ID Field

public const String ITEM_DELETED_USER_ID = "ItemDeletedUserID";

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.LABEL_DESCRIPTION Field

public readonly String LABEL_DESCRIPTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.LABEL_FLAGS Field

public readonly String LABEL_FLAGS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.LABEL_LABEL_TIME Field

public readonly String LABEL_LABEL_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.LABEL_MEMBER_ID Field

public readonly String LABEL_MEMBER_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.LABEL_NAME Field

public readonly String LABEL_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.LABEL_PROJECT_ID Field

public readonly String LABEL_PROJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.LABEL_VIEW_ID Field

public readonly String LABEL_VIEW_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.MODIFIED_TIME Field

public readonly String MODIFIED_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.MODIFIED_USER_ID Field

public readonly String MODIFIED_USER_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.MY_LOCK Field

public readonly String MY_LOCK;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.NON_EXCLUSIVE_LOCKERS Field

public readonly String NON_EXCLUSIVE_LOCKERS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.OBJECT_ID Field

public readonly String OBJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PARENT_OBJECT_ID Field

public readonly String PARENT_OBJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PARENT_REVISION Field

public readonly String PARENT_REVISION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PATH_REVISION Field

public readonly String PATH_REVISION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_ALTERNATE_CR_EDITOR_PATH Field

public readonly String PROJECT_ALTERNATE_CR_EDITOR_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_ALTERNATE_FILE_EDITOR_PATH Field

public readonly String PROJECT_ALTERNATE_FILE_EDITOR_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_ALTERNATE_REQUIREMENT_EDITOR_PATH Field

public readonly String PROJECT_ALTERNATE_REQUIREMENT_EDITOR_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_ALTERNATE_TASK_EDITOR_PATH Field

public readonly String PROJECT_ALTERNATE_TASK_EDITOR_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_ALTERNATE_TOPIC_EDITOR_PATH Field

public readonly String PROJECT_ALTERNATE_TOPIC_EDITOR_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_COMPACTION Field

public readonly String PROJECT_COMPACTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_CONFIGSOURCE1 Field

public readonly String PROJECT_CONFIGSOURCE1;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_CONFIGSOURCE2 Field

public readonly String PROJECT_CONFIGSOURCE2;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_DEFAULT_TYPES Field

public const String PROJECT_DEFAULT_TYPES = "DefaultTypes";

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_DEFAULT_VIEW_ID Field

public readonly String PROJECT_DEFAULT_VIEW_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_DESCRIPTION Field

public readonly String PROJECT_DESCRIPTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_DISPLAY_ALTERNATE_CR_EDITOR Field

public readonly String PROJECT_DISPLAY_ALTERNATE_CR_EDITOR;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_DISPLAY_ALTERNATE_FILE_EDITOR Field

public readonly String PROJECT_DISPLAY_ALTERNATE_FILE_EDITOR;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_DISPLAY_ALTERNATE_REQUIREMENT_EDITOR Field

public readonly String PROJECT_DISPLAY_ALTERNATE_REQUIREMENT_EDITOR;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_DISPLAY_ALTERNATE_TASK_EDITOR Field

public readonly String PROJECT_DISPLAY_ALTERNATE_TASK_EDITOR;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_DISPLAY_ALTERNATE_TOPIC_EDITOR Field

public readonly String PROJECT_DISPLAY_ALTERNATE_TOPIC_EDITOR;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_ENCRYPTION Field

public readonly String PROJECT_ENCRYPTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_FORCE_CHECKIN_REASON Field

public readonly String PROJECT_FORCE_CHECKIN_REASON;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_KEYWORD_EXTENSIONS Field

public readonly String PROJECT_KEYWORD_EXTENSIONS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_MAIL Field

public readonly String PROJECT_MAIL;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_MARK_UNLOCKED_FILES_READ_ONLY Field

public readonly String PROJECT_MARK_UNLOCKED_FILES_READ_ONLY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_NAME Field

public readonly String PROJECT_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_PROCESS_LINKS Field

public const String PROJECT_PROCESS_LINKS = "ProcessLinks";

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_PROCESS_REQUIRED Field

public readonly String PROJECT_PROCESS_REQUIRED;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_PROCESS_SELECT_CR Field

public readonly String PROJECT_PROCESS_SELECT_CR;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_PROCESS_SELECT_REQUIREMENT Field

public readonly String PROJECT_PROCESS_SELECT_REQUIREMENT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_PROCESS_SELECT_TASK Field

public readonly String PROJECT_PROCESS_SELECT_TASK;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_PROCESS_SHOW_CR_IN_PROGRESS Field

public readonly String PROJECT_PROCESS_SHOW_CR_IN_PROGRESS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_PROCESS_SHOW_CR_OPEN Field

public readonly String PROJECT_PROCESS_SHOW_CR_OPEN;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_PROCESS_SHOW_REQUIREMENT_APPROVED Field

public readonly String PROJECT_PROCESS_SHOW_REQUIREMENT_APPROVED;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_PROCESS_SHOW_TASK_IN_PROGRESS Field

public readonly String PROJECT_PROCESS_SHOW_TASK_IN_PROGRESS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_PROCESS_SHOW_TASK_READY Field

public readonly String PROJECT_PROCESS_SHOW_TASK_READY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_REQUIRE_LOCK_FOR_CHECKIN Field

public readonly String PROJECT_REQUIRE_LOCK_FOR_CHECKIN;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_TYPE Field

public readonly String PROJECT_TYPE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROJECT_USE_KEYWORDS Field

public readonly String PROJECT_USE_KEYWORDS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROMOTIONMODEL_DESCRIPTION Field

public readonly String PROMOTIONMODEL_DESCRIPTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROMOTIONMODEL_NAME Field

public readonly String PROMOTIONMODEL_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROMOTIONMODEL_STATE_COUNT Field

public readonly String PROMOTIONMODEL_STATE_COUNT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROMOTIONMODEL_STATE_IDS Field

public readonly String PROMOTIONMODEL_STATE_IDS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROMOTIONSTATE_DESCRIPTION Field

public readonly String PROMOTIONSTATE_DESCRIPTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROMOTIONSTATE_LABEL_ID Field

public readonly String PROMOTIONSTATE_LABEL_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.PROMOTIONSTATE_NAME Field

public readonly String PROMOTIONSTATE_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.READ_ONLY Field

public readonly String READ_ONLY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.READ_STATUS Field

public readonly String READ_STATUS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.READ_STATUS_USER_LIST Field

public readonly String READ_STATUS_USER_LIST;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.RECIPIENT_COUNT Field

public readonly String RECIPIENT_COUNT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.RECIPIENT_IDS Field

public readonly String RECIPIENT_IDS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.RECIPIENT_NAMES Field

public readonly String RECIPIENT_NAMES;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_CREATED_TIME Field

public readonly String REF_CREATED_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_CREATED_USER_ID Field

public readonly String REF_CREATED_USER_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_DELETED_TIME Field

public readonly String REF_DELETED_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_DELETED_USER_ID Field

public readonly String REF_DELETED_USER_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_DERIVED_COUNT Field

public readonly String REF_DERIVED_COUNT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_END_MODIFIED_TIME Field

public readonly String REF_END_MODIFIED_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_FLAGS Field

public readonly String REF_FLAGS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_FOLDER_ITEM_ID Field

public readonly String REF_FOLDER_ITEM_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_FOLDER_PATH Field

public readonly String REF_FOLDER_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_ITEM_ID Field

public readonly String REF_ITEM_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_ITEM_OBJECT_ID Field

public readonly String REF_ITEM_OBJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_ITEM_REVISION Field

public readonly String REF_ITEM_REVISION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_MODIFIED_TIME Field

public readonly String REF_MODIFIED_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_MODIFIED_USER_ID Field

public readonly String REF_MODIFIED_USER_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_PROJECT_ID Field

public readonly String REF_PROJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_PROJECT_NAME Field

public readonly String REF_PROJECT_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_VIEW_ID Field

public readonly String REF_VIEW_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REF_VIEW_PATH Field

public readonly String REF_VIEW_PATH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REQ_PARENT_OBJECTID Field

public const String REQ_PARENT_OBJECTID = "ParentRequirementID";

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REQ_STATUS Field

public const String REQ_STATUS = "Status";

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REV_BRANCH_FLAG Field

public readonly String REV_BRANCH_FLAG;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REV_BRANCH_STATE Field

public readonly String REV_BRANCH_STATE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REV_LOCATION_ITEM_ID Field

public readonly String REV_LOCATION_ITEM_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REV_OBJECT_ID Field

public readonly String REV_OBJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REV_OBJECT_TIME Field

public readonly String REV_OBJECT_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REV_PARENT_ITEM_ID Field

public readonly String REV_PARENT_ITEM_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REV_PROJECT_ID Field

public readonly String REV_PROJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REV_TIME Field

public readonly String REV_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REV_USER_ID Field

public readonly String REV_USER_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REV_VIEW_ID Field

public readonly String REV_VIEW_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REVISION_FLAGS Field

public readonly String REVISION_FLAGS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.REVISION_NUMBER Field

public readonly String REVISION_NUMBER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.ROOT_OBJECT_ID Field

public readonly String ROOT_OBJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.SHARE_STATE Field

public readonly String SHARE_STATE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.SHORT_COMMENT Field

public readonly String SHORT_COMMENT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_ACTUAL_FINISH Field

public readonly String TASK_ACTUAL_FINISH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_ACTUAL_HOURS Field

public readonly String TASK_ACTUAL_HOURS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_ACTUAL_START Field

public readonly String TASK_ACTUAL_START;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_ATTENTION_NOTES Field

public readonly String TASK_ATTENTION_NOTES;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_CHILDREN_COUNT Field

public readonly String TASK_CHILDREN_COUNT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_CONSTRAINT_DATE Field

public readonly String TASK_CONSTRAINT_DATE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_CONSTRAINT_TYPE Field

public readonly String TASK_CONSTRAINT_TYPE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_DURATION Field

public readonly String TASK_DURATION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_ESTIMATED_FINISH Field

public readonly String TASK_ESTIMATED_FINISH;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_ESTIMATED_FINISH_VARIANCE Field

public readonly String TASK_ESTIMATED_FINISH_VARIANCE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_ESTIMATED_HOURS Field

public readonly String TASK_ESTIMATED_HOURS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_ESTIMATED_HOURS_VARIANCE Field

public readonly String TASK_ESTIMATED_HOURS_VARIANCE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_ESTIMATED_START Field

public readonly String TASK_ESTIMATED_START;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_ESTIMATED_START_VARIANCE Field

public readonly String TASK_ESTIMATED_START_VARIANCE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_GUID Field

public readonly String TASK_GUID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_IS_MY_TASK Field

public readonly String TASK_IS_MY_TASK;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_IS_REPLICATED Field

public readonly String TASK_IS_REPLICATED;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_MILESTONE Field

public readonly String TASK_MILESTONE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_MSPROJECT_FILENAME Field

public readonly String TASK_MSPROJECT_FILENAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_MSPROJECT_LAST_UPDATE Field

public readonly String TASK_MSPROJECT_LAST_UPDATE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_NAME Field

public readonly String TASK_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_NEEDS_ATTENTION Field

public readonly String TASK_NEEDS_ATTENTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_NOTES Field

public readonly String TASK_NOTES;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_NUMBER Field

public readonly String TASK_NUMBER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_ORIGIN Field

public readonly String TASK_ORIGIN;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_PARENT_ID Field

public readonly String TASK_PARENT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_PERCENT_COMPLETE Field

public readonly String TASK_PERCENT_COMPLETE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_PRIORITY Field

public readonly String TASK_PRIORITY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_RESOURCE_COUNT Field

public readonly String TASK_RESOURCE_COUNT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_RESOURCE_IDS Field

public readonly String TASK_RESOURCE_IDS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_RESOURCE_NAMES Field

public readonly String TASK_RESOURCE_NAMES;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_RESPONSIBILITY Field

public readonly String TASK_RESPONSIBILITY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_STATUS Field

public readonly String TASK_STATUS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_TYPE Field

public readonly String TASK_TYPE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_UNIQUE_ID Field

public readonly String TASK_UNIQUE_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_USAGE Field

public const String TASK_USAGE = "StTaskProcessUsage";

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_USAGE_90 Field

public const String TASK_USAGE_90 = "Usr_TaskProcessUsage";

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_WBS_CODE Field

public readonly String TASK_WBS_CODE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_WORK_DEPENDENCY_LAST_UPDATE Field

public readonly String TASK_WORK_DEPENDENCY_LAST_UPDATE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASK_WORKRECORD_COUNT Field

public readonly String TASK_WORKRECORD_COUNT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASKDEPENDENCY_LAG_TIME Field

public readonly String TASKDEPENDENCY_LAG_TIME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASKDEPENDENCY_PREDECESSOR_ID Field

public readonly String TASKDEPENDENCY_PREDECESSOR_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASKDEPENDENCY_TASK_ID Field

public readonly String TASKDEPENDENCY_TASK_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TASKDEPENDENCY_TYPE Field

public readonly String TASKDEPENDENCY_TYPE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TOPIC_CHILDREN_COUNT Field

public readonly String TOPIC_CHILDREN_COUNT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TOPIC_DESCRIPTION Field

public readonly String TOPIC_DESCRIPTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TOPIC_NUMBER Field

public readonly String TOPIC_NUMBER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TOPIC_PARENT Field

public readonly String TOPIC_PARENT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TOPIC_PRIORITY Field

public readonly String TOPIC_PRIORITY;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TOPIC_STATUS Field

public readonly String TOPIC_STATUS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TOPIC_TITLE Field

public readonly String TOPIC_TITLE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.TOPIC_TYPE Field

public readonly String TOPIC_TYPE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.USER_ADDRESS Field

public readonly String USER_ADDRESS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.USER_EMAIL_ADDRESS Field

public readonly String USER_EMAIL_ADDRESS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.USER_FAX Field

public readonly String USER_FAX;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.USER_FULL_NAME Field

public readonly String USER_FULL_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.USER_PAGER Field

public readonly String USER_PAGER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.USER_PHONE Field

public readonly String USER_PHONE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.USER_VOICE_MAIL Field

public readonly String USER_VOICE_MAIL;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_BASECONFIG_DATA Field

public readonly String VIEW_BASECONFIG_DATA;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_BASECONFIG_TYPE Field

public readonly String VIEW_BASECONFIG_TYPE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_DELETE_COMPLETE Field

public readonly String VIEW_DELETE_COMPLETE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_DESCRIPTION Field

public readonly String VIEW_DESCRIPTION;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_FLAGS Field

public readonly String VIEW_FLAGS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_ID Field

public readonly String VIEW_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_NAME Field

public readonly String VIEW_NAME;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_PARENT_VIEW_ID Field

public readonly String VIEW_PARENT_VIEW_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_PROJECT_ID Field

public readonly String VIEW_PROJECT_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_PROMOTION_ID Field

public readonly String VIEW_PROMOTION_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_RESOLVED_ID Field

public const String VIEW_RESOLVED_ID = "ResolvedViewID";

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_ROOT_MEMBER_ID Field

public readonly String VIEW_ROOT_MEMBER_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_SHARE_FLAGS Field

public readonly String VIEW_SHARE_FLAGS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.VIEW_WORKING_FOLDER Field

public readonly String VIEW_WORKING_FOLDER;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.WORKRECORD_COMMENT Field

public readonly String WORKRECORD_COMMENT;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.WORKRECORD_DATE Field

public readonly String WORKRECORD_DATE;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.WORKRECORD_HOURS Field

public readonly String WORKRECORD_HOURS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.WORKRECORD_REMAINING_HOURS Field

public readonly String WORKRECORD_REMAINING_HOURS;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.WORKRECORD_TASK_ID Field

public readonly String WORKRECORD_TASK_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.WORKRECORD_USER_ID Field

public readonly String WORKRECORD_USER_ID;

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames Methods

The methods of the PropertyNames class are listed below. For a complete list of PropertyNames class members, see the PropertyNames Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.MemberwiseClone Method

public override object MemberwiseClone();

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNames.ToString Method

public override string ToString();

See Also

PropertyNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNotWritableException Class

For a list of all members of this type, see PropertyNotWritableException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
PropertyNotWritableException

public class PropertyNotWritableException : RuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

PropertyNotWritableException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNotWritableException Members

PropertyNotWritableException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
getProperty |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

PropertyNotWritableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNotWritableException Methods

The methods of the PropertyNotWritableException class are listed below. For a complete list of PropertyNotWritableException class members, see the PropertyNotWritableException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
getProperty |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

PropertyNotWritableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNotWritableException.Equals Method

public override bool Equals(
Object source
);

See Also

PropertyNotWritableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNotWritableException.GetHashCode Method

public override int GetHashCode();

See Also

PropertyNotWritableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNotWritableException.getMessage Method

public override string getMessage();

See Also

PropertyNotWritableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNotWritableException.getProperty Method

public virtual Property getProperty();

See Also

PropertyNotWritableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNotWritableException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

PropertyNotWritableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNotWritableException.unwrap Method

public virtual PropertyNotWritableException unwrap();

See Also

PropertyNotWritableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyNotWritableException.wrap Method

public static PropertyNotWritableException wrap(
PropertyNotWritableException arg
);

See Also

PropertyNotWritableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeControl Class

For a list of all members of this type, see PurgeControl Members.

System.Object
PurgeControl

public class PurgeControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

PurgeControl Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeControl Members

PurgeControl overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getPurgeStatus | Request the status of the Purge Service
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
start | Start the online purge service
stop | Stop the online purge service.
ToString |

See Also

PurgeControl Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeControl Methods

The methods of the PurgeControl class are listed below. For a complete list of PurgeControl class members, see the PurgeControl Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getPurgeStatus | Request the status of the Purge Service
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
start | Start the online purge service
stop | Stop the online purge service.
ToString |

See Also

PurgeControl Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeControl.getPurgeStatus Method

Request the status of the Purge Service

public virtual PurgeStatus getPurgeStatus();

See Also

PurgeControl Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeControl.MemberwiseClone Method

public override object MemberwiseClone();

See Also

PurgeControl Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeControl.start Method

Start the online purge service

public virtual PurgeStatus start();

See Also

PurgeControl Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeControl.stop Method

Stop the online purge service.

public virtual PurgeStatus stop();

See Also

PurgeControl Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeControl.ToString Method

public override string ToString();

See Also

PurgeControl Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus Class

For a list of all members of this type, see PurgeStatus Members.

System.Object
PurgeStatus

public class PurgeStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

PurgeStatus Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus Members

PurgeStatus overview

Public Static Fields

COMPLETED
FAILED
IN_PROGRESS
READY
STOPPING

Public Static Methods

getAll Returns an array of all PurgeStatus instances

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName |
getStatus |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus Fields

The fields of the PurgeStatus class are listed below. For a complete list of PurgeStatus class members, see the PurgeStatus Members topic.

Public Static Fields

COMPLETED
FAILED
IN_PROGRESS
READY
STOPPING

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus.COMPLETED Field

public static readonly PurgeStatus COMPLETED;

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus.FAILED Field

public static readonly PurgeStatus FAILED;

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus.IN_PROGRESS Field

public static readonly PurgeStatus IN_PROGRESS;

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus.READY Field

public static readonly PurgeStatus READY;

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus.STOPPING Field

public static readonly PurgeStatus STOPPING;

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus Methods

The methods of the PurgeStatus class are listed below. For a complete list of PurgeStatus class members, see the PurgeStatus Members topic.

Public Static Methods

getAll Returns an array of all PurgeStatus instances

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName |
getStatus |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus.getAll Method

Returns an array of all PurgeStatus instances

public static PurgeStatus[] getAll();

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus.getName Method

public virtual string getName();

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus.getStatus Method

public virtual int getStatus();

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus.MemberwiseClone Method

public override object MemberwiseClone();

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PurgeStatus.ToString Method

public override string ToString();

See Also

PurgeStatus Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryAdapter Class

For a list of all members of this type, see QueryAdapter Members.

System.Object
QueryAdapter

public class QueryAdapter : QueryListener, IFilterQueryListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

QueryAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryAdapter Members

QueryAdapter overview

Public Instance Constructors

QueryAdapter Constructor Initializes a new instance of the QueryAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
queryAdded |
queryChanged |
queryDeleted |
ToString |

See Also

QueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryAdapter Constructor

Initializes a new instance of the QueryAdapter class.

public QueryAdapter();

See Also

QueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryAdapter Methods

The methods of the QueryAdapter class are listed below. For a complete list of QueryAdapter class members, see the QueryAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
queryAdded |
queryChanged |
queryDeleted |
ToString |

See Also

QueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

QueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryAdapter.queryAdded Method

public override void queryAdded(
QueryEvent e
);

Implements

QueryListener.queryAdded

See Also

QueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryAdapter.queryChanged Method

public override void queryChanged(
QueryEvent e
);

Implements

QueryListener.queryChanged

See Also

QueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryAdapter.queryDeleted Method

public override void queryDeleted(
QueryEvent e
);

Implements

QueryListener.queryDeleted

See Also

QueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryAdapter.ToString Method

public override string ToString();

See Also

QueryAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryEvent Class

For a list of all members of this type, see QueryEvent Members.

System.Object
EventObject
QueryEvent

public class QueryEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

QueryEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryEvent Members

QueryEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getQuery | Gets the QueryInfo that has been added, changed or deleted, in its new state. <p> QueryInfo.getType() will return a Type whose properties are up-to-date as of the time the event was triggered. This Type object is a physically different object from the Type object used to register the event handler. (In the case where the event handler was registered with a Server object, this Type object is physically different from the corresponding Type object in the Server's Type collection.) <p> If an application wants to refresh the list of queries associated with the original Type object, it must do so by explicitly calling Type.refreshFiltersAndQueries().
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

QueryEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryEvent Methods

The methods of the QueryEvent class are listed below. For a complete list of QueryEvent class members, see the QueryEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getQuery | Gets the QueryInfo that has been added, changed or deleted, in its new state. <p> QueryInfo.getType() will return a Type whose properties are up-to-date as of the time the event was triggered. This Type object is a physically different object from the Type object used to register the event handler. (In the case where the event handler was registered with a Server object, this Type object is physically different from the corresponding Type object in the Server's Type collection.) <p> If an application wants to refresh the list of queries associated with the original Type object, it must do so by explicitly calling Type.refreshFiltersAndQueries().
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

QueryEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryEvent.Equals Method

public override bool Equals(
Object source
);

See Also

QueryEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryEvent.GetHashCode Method

public override int GetHashCode();

See Also

QueryEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryEvent.getQuery Method

Gets the QueryInfo that has been added, changed or deleted, in its new state. <p> QueryInfo.getType() will return a Type whose properties are up-to-date as of the time the event was triggered. This Type object is a physically different object from the Type object used to register the event handler. (In the case where the event handler was registered with a Server object, this Type object is physically different from the corresponding Type object in the Server's Type collection.) <p> If an application wants to refresh the list of queries associated with the original Type object, it must do so by explicitly calling Type.refreshFiltersAndQueries().

public virtual QueryInfo getQuery();

See Also

QueryEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryEvent.getSource Method

public override object getSource();

See Also

QueryEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

QueryEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryEvent.ToString Method

public override string ToString();

See Also

QueryEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo Class

For a list of all members of this type, see QueryInfo Members.

System.Object
CacheRef
NamedCacheRef
QueryInfo

public class QueryInfo : NamedCacheRef, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

QueryInfo Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo Members

QueryInfo overview

Public Instance Constructors

QueryInfo Constructor

Public Instance Methods

Clone (inherited from CacheRef) |
copy | Creates a copy of this QueryInfo object. Useful to applications that want to save a snapshot of the query in a given state, for example, before calling Type.refreshFiltersAndQueries().
delete | Deletes this query from the repository.
Equals |
evaluate | Evaluate this QueryPart with respect to the specified item.
getACL |
GetHashCode |
getID | Return the internal ID of the QueryInfo.
getName | Return the name of the query.
getParentContainer |
getPropertyIDs | Returns the property IDs used by any of the QueryNode and QueryPart objects comprising this query.
getQueryNode | Return the boolean expression defining this query.
getType |
GetType (inherited from Object) | Gets the Type of the current instance.
getUserID | Return the user ID for the user who created this query. Returns -1 if it is a built-in query.
hasPermission |
isDeleted | Returns true if this query has been deleted.
isDirty | Returns true if the query has unsaved modifications.
isEqualTo | Compares two QueryInfo objects.
isNew | Returns true if this query is newly created and not yet saved in the repository.
isPublic | Return true if the filter is publicly visible.
makePublic |
MemberwiseClone (inherited from CacheRef) |
setACL |
setName |
setQueryNode | Sets the boolean expression used to define this query. Cannot be null.
toDebugString | Returns a String with debug information about this query.
ToString |
update | Store this query in the repository. If the query is new then a new query will be added, if it exists then it will be modified. It is possible that the ID (getID()) for the query will change after calling this method even for an existing query. This method cannot be called on a deleted query.

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo Constructor

public QueryInfo(
Type type,
Boolean bPublic,
String name,
QueryNode node
);

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo Methods

The methods of the QueryInfo class are listed below. For a complete list of QueryInfo class members, see the QueryInfo Members topic.

Public Instance Methods

Clone (inherited from CacheRef) |
copy | Creates a copy of this QueryInfo object. Useful to applications that want to save a snapshot of the query in a given state, for example, before calling Type.refreshFiltersAndQueries().
delete | Deletes this query from the repository.
Equals |
evaluate | Evaluate this QueryPart with respect to the specified item.
getACL |
GetHashCode |
getID | Return the internal ID of the QueryInfo.
getName | Return the name of the query.
getParentContainer |
getPropertyIDs | Returns the property IDs used by any of the QueryNode and QueryPart objects comprising this query.
getQueryNode | Return the boolean expression defining this query.
getType |
GetType (inherited from Object) | Gets the Type of the current instance.
getUserID | Return the user ID for the user who created this query. Returns -1 if it is a built-in query.
hasPermission |
isDeleted | Returns true if this query has been deleted.
isDirty | Returns true if the query has unsaved modifications.
isEqualTo | Compares two QueryInfo objects.
isNew | Returns true if this query is newly created and not yet saved in the repository.
isPublic | Return true if the filter is publicly visible.
makePublic |
MemberwiseClone (inherited from CacheRef) |
setACL |
setName |
setQueryNode | Sets the boolean expression used to define this query. Cannot be null.
toDebugString | Returns a String with debug information about this query.
ToString |
update | Store this query in the repository. If the query is new then a new query will be added, if it exists then it will be modified. It is possible that the ID (getID()) for the query will change after calling this method even for an existing query. This method cannot be called on a deleted query.

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.copy Method

Creates a copy of this QueryInfo object. Useful to applications that want to save a snapshot of the query in a given state, for example, before calling Type.refreshFiltersAndQueries().

public virtual QueryInfo copy();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.delete Method

Deletes this query from the repository.

public virtual void delete();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.Equals Method

public override bool Equals(
Object source
);

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.evaluate Method

Evaluate this QueryPart with respect to the specified item.

public virtual bool evaluate(
Item item
);

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.getACL Method

public virtual AclEntry[] getACL();

Implements

ISecurable.getACL

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.GetHashCode Method

public override int GetHashCode();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.getID Method

Return the internal ID of the QueryInfo.

public virtual int getID();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.getName Method

Return the name of the query.

public virtual string getName();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.getParentContainer Method

public virtual ISecurableContainer getParentContainer();

Implements

ISecurable.getParentContainer

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.getPropertyIDs Method

Returns the property IDs used by any of the QueryNode and QueryPart objects comprising this query.

public virtual int[] getPropertyIDs();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.getQueryNode Method

Return the boolean expression defining this query.

public virtual QueryNode getQueryNode();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.getType Method

public virtual Type getType();

Implements

ISecurable.getType

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.getUserID Method

Return the user ID for the user who created this query. Returns -1 if it is a built-in query.

public virtual int getUserID();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.hasPermission Method

public virtual bool hasPermission(
Int32 permissions
);

Implements

ISecurable.hasPermission

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.isDeleted Method

Returns true if this query has been deleted.

public virtual bool isDeleted();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.isDirty Method

Returns true if the query has unsaved modifications.

public virtual bool isDirty();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.isEqualTo Method

Compares two QueryInfo objects.

public virtual bool isEqualTo(
QueryInfo query
);

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.isNew Method

Returns true if this query is newly created and not yet saved in the repository.

public virtual bool isNew();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.isPublic Method

Return true if the filter is publicly visible.

public virtual bool isPublic();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.makePublic Method

public virtual void makePublic();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.setACL Method

public virtual void setACL(
AclEntry[] acl
);

Implements

ISecurable.setACL

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.setName Method

public virtual void setName(
String name
);

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.setQueryNode Method

Sets the boolean expression used to define this query. Cannot be null.

public virtual void setQueryNode(
QueryNode node
);

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.toDebugString Method

Returns a String with debug information about this query.

public virtual string toDebugString();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.ToString Method

public override string ToString();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryInfo.update Method

Store this query in the repository. If the query is new then a new query will be added, if it exists then it will be modified. It is possible that the ID (getID()) for the query will change after calling this method even for an existing query. This method cannot be called on a deleted query.

public virtual void update();

See Also

QueryInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryListener Interface

For a list of all members of this type, see QueryListener Members.

public interface QueryListener : IFilterQueryListener, EventListener

Types that implement QueryListener

Type | Description
FilterQueryAdapter |
QueryAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

QueryListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryListener Members

QueryListener overview

Public Instance Methods

queryAdded | Invoked when a new Query has been added to the server.
queryChanged | Invoked when an existing Query has been modified on the server.
queryDeleted | Invoked when an existing Query has been deleted on the server.

See Also

QueryListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryListener Methods

The methods of the QueryListener interface are listed below. For a complete list of QueryListener interface members, see the QueryListener Members topic.

Public Instance Methods

queryAdded | Invoked when a new Query has been added to the server.
queryChanged | Invoked when an existing Query has been modified on the server.
queryDeleted | Invoked when an existing Query has been deleted on the server.

See Also

QueryListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryListener.queryAdded Method

Invoked when a new Query has been added to the server.

void queryAdded(
QueryEvent e
);

See Also

QueryListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryListener.queryChanged Method

Invoked when an existing Query has been modified on the server.

void queryChanged(
QueryEvent e
);

See Also

QueryListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryListener.queryDeleted Method

Invoked when an existing Query has been deleted on the server.

void queryDeleted(
QueryEvent e
);

See Also

QueryListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode Class

For a list of all members of this type, see QueryNode Members.

System.Object
QueryNode

public class QueryNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

QueryNode Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode Members

QueryNode overview

Public Static Fields

OP_AND
OP_NOT
OP_OR

Public Instance Constructors

QueryNode Constructor

Public Instance Methods

appendQueryNode | A convenience method to add a QueryNode at the end of the list.
appendQueryPart | A convenience method to add a QueryParts at the end of the list.
clearQueryNodes | A convenience method to remove all query parts.
clearQueryParts | A convenience method to remove all query parts.
copyQueryNode | Returns a deep copy of this QueryNode.
Equals |
evaluate | Evaluate this QueryPart with respect to the specified item.
GetHashCode |
getOperator | Returns the operator type for this expression.
getQueryNodes | Returns the QueryNodes associated with this QueryNode. These nodes can be thought of as sub-expressions.
getQueryParts | Returns the QueryParts associated with this QueryNode. A QueryPart defines an expression on a single property of an item.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setOperator |
setQueryNodes |
setQueryParts |
toDebugString | Returns a String with debug information about this QueryNode.
toDebugStringDepth |
ToString |

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode Constructor

public QueryNode(
Int32 anOperator
);

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode Fields

The fields of the QueryNode class are listed below. For a complete list of QueryNode class members, see the QueryNode Members topic.

Public Static Fields

OP_AND
OP_NOT
OP_OR

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.OP_AND Field

public const Int32 OP_AND = 0;

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.OP_NOT Field

public const Int32 OP_NOT = 2;

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.OP_OR Field

public const Int32 OP_OR = 1;

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode Methods

The methods of the QueryNode class are listed below. For a complete list of QueryNode class members, see the QueryNode Members topic.

Public Instance Methods

appendQueryNode | A convenience method to add a QueryNode at the end of the list.
appendQueryPart | A convenience method to add a QueryParts at the end of the list.
clearQueryNodes | A convenience method to remove all query parts.
clearQueryParts | A convenience method to remove all query parts.
copyQueryNode | Returns a deep copy of this QueryNode.
Equals |
evaluate | Evaluate this QueryPart with respect to the specified item.
GetHashCode |
getOperator | Returns the operator type for this expression.
getQueryNodes | Returns the QueryNodes associated with this QueryNode. These nodes can be thought of as sub-expressions.
getQueryParts | Returns the QueryParts associated with this QueryNode. A QueryPart defines an expression on a single property of an item.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setOperator |
setQueryNodes |
setQueryParts |
toDebugString | Returns a String with debug information about this QueryNode.
toDebugStringDepth |
ToString |

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.appendQueryNode Method

A convenience method to add a QueryNode at the end of the list.

public virtual void appendQueryNode(
QueryNode node
);

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.appendQueryPart Method

A convenience method to add a QueryParts at the end of the list.

public virtual void appendQueryPart(
QueryPart part
);

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.clearQueryNodes Method

A convenience method to remove all query parts.

public virtual void clearQueryNodes();

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.clearQueryParts Method

A convenience method to remove all query parts.

public virtual void clearQueryParts();

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.copyQueryNode Method

Returns a deep copy of this QueryNode.

public virtual QueryNode copyQueryNode();

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.Equals Method

public override bool Equals(
Object source
);

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.evaluate Method

Evaluate this QueryPart with respect to the specified item.

public virtual bool evaluate(
Item item
);

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.GetHashCode Method

public override int GetHashCode();

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.getOperator Method

Returns the operator type for this expression.

public virtual int getOperator();

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.getQueryNodes Method

Returns the QueryNodes associated with this QueryNode. These nodes can be thought of as sub-expressions.

public virtual QueryNode[] getQueryNodes();

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.getQueryParts Method

Returns the QueryParts associated with this QueryNode. A QueryPart defines an expression on a single property of an item.

public virtual QueryPart[] getQueryParts();

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.MemberwiseClone Method

public override object MemberwiseClone();

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.setOperator Method

public virtual void setOperator(
Int32 anOperator
);

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.setQueryNodes Method

public virtual void setQueryNodes(
QueryNode[] nodes
);

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.setQueryParts Method

public virtual void setQueryParts(
QueryPart[] parts
);

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.toDebugString Method

Returns a String with debug information about this QueryNode.

public virtual string toDebugString();

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.toDebugStringDepth Method

public virtual string toDebugStringDepth(
Int32 depth
);

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryNode.ToString Method

public override string ToString();

See Also

QueryNode Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Class

For a list of all members of this type, see QueryPart Members.

System.Object
QueryPart

public class QueryPart

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

QueryPart Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Members

QueryPart overview

Public Static Fields

REL_ENDTEXT
REL_EQUAL
REL_GREATEROREQUAL
REL_GREATERTHAN
REL_LASTDAYS
REL_LASTWEEKS
REL_LESSOREQUAL
REL_LESSTHAN
REL_NOTEQUAL
REL_OLDERDAYS
REL_OLDERWEEKS
REL_STARTTEXT
REL_TEXTSEARCH

Public Instance Constructors

QueryPart Overloaded. Initializes a new instance of the QueryPart class.

Public Instance Methods

copyQueryPart | Returns a copy of this QueryPart. It is a deep copy so the new one may be freely modified without affecting the original. The copy will be identical but for the ID which will be -1 for the new copy.
Equals |
evaluate | Evaluate this QueryPart with respect to the specified item.
evaluateAgainst |
GetHashCode |
getPropertyID |
getRelation |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue |
isIgnoreCase |
isIgnoreTime |
MemberwiseClone |
setIgnoreCase |
setIgnoreTime |
setPropertyID |
setRelation |
toDebugString | Returns a debug string representation of this QueryPart.
ToString |

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Constructor

Overload List

public QueryPart(Int32,Int32,OLEDate,Boolean);

public QueryPart(Int32,Int32,Double);

public QueryPart(Int32,Int32,Double,Boolean);

public QueryPart(Int32,Int32,Int32);

public QueryPart(Int32,Int32,Int32[]);

public QueryPart(Int32,Int32,SByte[]);

public QueryPart(Int32,Int32,String,Boolean);

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Constructor (Int32, Int32, Int32)

public QueryPart(
Int32 propertyID,
Int32 relation,
Int32 value
);

See Also

QueryPart Class | com.starbase.starteam Namespace | QueryPart Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Constructor (Int32, Int32, Double)

public QueryPart(
Int32 propertyID,
Int32 relation,
Double value
);

See Also

QueryPart Class | com.starbase.starteam Namespace | QueryPart Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Constructor (Int32, Int32, Double, Boolean)

public QueryPart(
Int32 propertyID,
Int32 relation,
Double value,
Boolean ignoreTime
);

See Also

QueryPart Class | com.starbase.starteam Namespace | QueryPart Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Constructor (Int32, Int32, OLEDate, Boolean)

public QueryPart(
Int32 propertyID,
Int32 relation,
OLEDate value,
Boolean ignoreTime
);

See Also

QueryPart Class | com.starbase.starteam Namespace | QueryPart Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Constructor (Int32, Int32, String, Boolean)

public QueryPart(
Int32 propertyID,
Int32 relation,
String value,
Boolean caseSensitive
);

See Also

QueryPart Class | com.starbase.starteam Namespace | QueryPart Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Constructor (Int32, Int32, SByte[])

public QueryPart(
Int32 propertyID,
Int32 relation,
SByte[] value
);

See Also

QueryPart Class | com.starbase.starteam Namespace | QueryPart Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Constructor (Int32, Int32, Int32[])

public QueryPart(
Int32 propertyID,
Int32 relation,
Int32[] value
);

See Also

QueryPart Class | com.starbase.starteam Namespace | QueryPart Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Fields

The fields of the QueryPart class are listed below. For a complete list of QueryPart class members, see the QueryPart Members topic.

Public Static Fields

REL_ENDTEXT
REL_EQUAL
REL_GREATEROREQUAL
REL_GREATERTHAN
REL_LASTDAYS
REL_LASTWEEKS
REL_LESSOREQUAL
REL_LESSTHAN
REL_NOTEQUAL
REL_OLDERDAYS
REL_OLDERWEEKS
REL_STARTTEXT
REL_TEXTSEARCH

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_ENDTEXT Field

public const Int32 REL_ENDTEXT = 196608;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_EQUAL Field

public const Int32 REL_EQUAL = 3;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_GREATEROREQUAL Field

public const Int32 REL_GREATEROREQUAL = 4;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_GREATERTHAN Field

public const Int32 REL_GREATERTHAN = 5;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_LASTDAYS Field

public const Int32 REL_LASTDAYS = 9;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_LASTWEEKS Field

public const Int32 REL_LASTWEEKS = 10;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_LESSOREQUAL Field

public const Int32 REL_LESSOREQUAL = 2;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_LESSTHAN Field

public const Int32 REL_LESSTHAN = 1;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_NOTEQUAL Field

public const Int32 REL_NOTEQUAL = 6;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_OLDERDAYS Field

public const Int32 REL_OLDERDAYS = 11;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_OLDERWEEKS Field

public const Int32 REL_OLDERWEEKS = 12;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_STARTTEXT Field

public const Int32 REL_STARTTEXT = 131072;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.REL_TEXTSEARCH Field

public const Int32 REL_TEXTSEARCH = 65536;

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart Methods

The methods of the QueryPart class are listed below. For a complete list of QueryPart class members, see the QueryPart Members topic.

Public Instance Methods

copyQueryPart | Returns a copy of this QueryPart. It is a deep copy so the new one may be freely modified without affecting the original. The copy will be identical but for the ID which will be -1 for the new copy.
Equals |
evaluate | Evaluate this QueryPart with respect to the specified item.
evaluateAgainst |
GetHashCode |
getPropertyID |
getRelation |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue |
isIgnoreCase |
isIgnoreTime |
MemberwiseClone |
setIgnoreCase |
setIgnoreTime |
setPropertyID |
setRelation |
toDebugString | Returns a debug string representation of this QueryPart.
ToString |

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.copyQueryPart Method

Returns a copy of this QueryPart. It is a deep copy so the new one may be freely modified without affecting the original. The copy will be identical but for the ID which will be -1 for the new copy.

public virtual QueryPart copyQueryPart();

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.Equals Method

public override bool Equals(
Object source
);

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.evaluate Method

Evaluate this QueryPart with respect to the specified item.

public virtual bool evaluate(
Item item
);

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.evaluateAgainst Method

public virtual bool evaluateAgainst(
Object value
);

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.GetHashCode Method

public override int GetHashCode();

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.getPropertyID Method

public virtual int getPropertyID();

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.getRelation Method

public virtual int getRelation();

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.getValue Method

public virtual object getValue();

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.isIgnoreCase Method

public virtual bool isIgnoreCase();

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.isIgnoreTime Method

public virtual bool isIgnoreTime();

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.MemberwiseClone Method

public override object MemberwiseClone();

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.setIgnoreCase Method

public virtual void setIgnoreCase(
Boolean ignore
);

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.setIgnoreTime Method

public virtual void setIgnoreTime(
Boolean ignore
);

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.setPropertyID Method

public virtual void setPropertyID(
Int32 propertyID
);

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.setRelation Method

public virtual void setRelation(
Int32 relation
);

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.toDebugString Method

Returns a debug string representation of this QueryPart.

public virtual string toDebugString();

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QueryPart.ToString Method

public override string ToString();

See Also

QueryPart Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RecycleBin Class

For a list of all members of this type, see RecycleBin Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
View
RecycleBin

public class RecycleBin : View

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

RecycleBin Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RecycleBin Members

RecycleBin overview

Public Instance Methods

acquireOwnership (inherited from View) |
addFolderListener (inherited from View) | Adds a listener for Folder-related events. <p> In order to handle events, an application must enable MPX.
addFolderUpdateListener (inherited from View) | Listens for updates to this view's folder tree. <p> Similar to addFolderListener(), except that events are triggered by explicit operations performed by the client application. For example, calling View.refreshFolders(), Folder.update() or Folder.remove() might each trigger update events. <p> MPX is not required to receive folder update events.
addItemListener (inherited from View) | Overloaded.
addItemUpdateListener (inherited from View) |
addLabelListener (inherited from View) | Adds a listener for Label events. <p> Event handlers will be tiggered whenever a Label is added, changed, or deleted in this View. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
addToIntArray (inherited from TypedResource) |
addViewListener (inherited from View) | Adds a listener for View events. <p> Event handlers will be tiggered when this View is changed or deleted. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
Clone (inherited from CacheRef) |
cloneRevisionLabel (inherited from View) |
cloneViewLabel (inherited from View) |
close (inherited from View) | Frees all cached resources associated with this view, and closes the associated view session. <p> Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). <p> After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
copy (inherited from View) | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
createCheckinManager (inherited from View) | Overloaded. Constructs a CheckinManager with default options for this view.
createCheckoutManager (inherited from View) | Overloaded. Constructs a CheckoutManager with default options for this view.
createChildViewShareAllItems (inherited from View) |
createChildViewShareDefaultItems (inherited from View) |
createChildViewShareNoItems (inherited from View) |
createChildViewShareTheseItems (inherited from View) |
createRevisionLabel (inherited from View) |
createViewLabel (inherited from View) |
discard (inherited from View) | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
discardActiveLabels (inherited from View) | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
discardFolders (inherited from View) | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
discardLabels (inherited from View) | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from View) |
fetchAllLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. <p> The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. <p> If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
fetchAllLabelsFromView (inherited from View) |
findFolder (inherited from View) |
findItem (inherited from View) |
get (inherited from View) |
getACL (inherited from View) |
getActiveLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. The labels are cached until explicitly refreshed.
getAlternatePath (inherited from View) | Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.
getBaseConfiguration (inherited from View) | Returns the ViewConfiguration from which this View was derived.
getByteArray (inherited from SimpleTypedResource) |
getConfiguration (inherited from View) | Returns this view's configuration.
getContainerLevelACL (inherited from View) |
getCreatedBy (inherited from View) | Returns the user ID of the user that created the view.
getCreatedTime (inherited from View) | Returns the time at which the view was created.
getDefaultPath (inherited from View) | Returns the default working file path to be used for this view. This is the value stored in the repository.
getDeletedAsOf | Used to limit deleted folders and items to those that were after a given time.
getDerivedViews (inherited from View) | Returns the set of views derived from this one.
getDescription (inherited from View) | Returns the description of this view.
getDisembodiedItem (inherited from View) |
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
getFileStatusManager (inherited from View) | Get the FileBasedStatusManager that manages file status information for this View. The corresponding StarTeam Server must support client-managed status.
getFullName (inherited from View) | Returns the full hierarchical name of this view--that is, the concatentation of the root view and each descendent to this view.
GetHashCode (inherited from View) |
getHaveAccessRights (inherited from View) | Obsolete. Indicates whether or not the logged on user has rights to access this view.
getHistoryForItemID (inherited from View) |
getID (inherited from View) |
getIncludeActiveItems | Determines whether or not the resulting folders may contain active items.
getIncludeDeletedFolders | Determines whether or not deleted child folders will be inserted into the copy of the folder tree.
getIncludeDeletedItems | Determines whether or not the resulting folders may contain deleted items.
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLabels (inherited from View) | Returns the labels that exist in this view, including both active and deleted labels. The labels are cached until explicitly refreshed.
getName (inherited from View) | Returns the name of this view.
getNewNotificationItems (inherited from View) |
getOLEDate (inherited from SimpleTypedResource) |
getOwner (inherited from View) |
getParentContainer (inherited from View) |
getParentView (inherited from View) | Returns the parent of this view.
getPath (inherited from View) | Returns the working file path being used for this view. This path is either the default path or the alternate path. A non-null alternate path takes precedence over a default path.
getPossibleValues (inherited from SimpleTypedResource) |
getProject (inherited from View) | Returns the project to which this view belongs.
getPromotionModel (inherited from View) | Returns the promotion model associated with this view.
getPropertyNames (inherited from SimpleTypedResource) |
getRecycleBin (inherited from View) | Provides access to the items that have been deleted from a view. <p> For example: <pre> RecycleBin bin = view.getRecycleBin(); Folder root = bin.getRootFolder(); Item[] files = root.getItems(TypeNames.FILE); for (int i = 0; i < files.length; i++) { assertTrue(files[i].isDeleted()); } </pre> Note that this method is supported by StarTeam Server versions 9.0 and later.
getRootFolder (inherited from View) | Gets the root folder of this view. The Folder hierarchy is cached in the View object, until explicitly refreshed or discarded.
getServer (inherited from View) | Returns the server to which this view belongs.
getStatusMethodOverride (inherited from View) | Returns the status method used to determine status for files in this view. This method will not return null.
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getViewID (inherited from View) | Returns the unique integer identifier for this view.
hasNewNotificationItems (inherited from View) |
hasPermission (inherited from View) | Overloaded.
isAccessible (inherited from View) | Determines whether or not the logged on user has access to this view.
isBranch (inherited from View) | Return true if this view is a Branch view.
isBranchAll (inherited from View) | Return true if this view's original branching default was set "All".
isBranchNone (inherited from View) | Return true if this view's original branching default was set "None".
isBranchOnShare (inherited from View) | Returns true if this view is set to branch shared items.
isDeleted (inherited from View) | Determines whether or not this view has been deleted from the server.
isEqualTo (inherited from View) | Compares the properties of two Views.
isNonDerived (inherited from View) | Return true if this view is a Non-Derived view.
isReadOnly (inherited from View) | Return true if this is a ReadOnly view, otherwise false.
isReference (inherited from View) | Return true if this is a reference view, otherwise false.
isRefreshActiveLabelsRequired (inherited from View) | Returns true if a refreshLabels() operation might have resulted in Label information for active (non-deleted) labels being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshFoldersRequired (inherited from View) | Returns true if a View.refreshFolders() operation might have resulted in Folder information being updated; returns false if and only if it is known that the folders had not been changed since the last refresh. If MPX is not enabled, then isRefreshFoldersRequired() always returns true.
isRefreshLabelsRequired (inherited from View) | Returns true if a refreshLabels() operation might have resulted in Label information being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshRequired (inherited from View) | Returns true if a refresh() operation might have resulted in view properties being updated; returns false if and only if it is known that the view properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isRoot (inherited from View) | Return true if this view is a Root view.
MemberwiseClone (inherited from CacheRef) |
modifyItemsFlagForUser (inherited from View) |
modifyItemsReadStatusForUser (inherited from View) |
populate (inherited from View) | Populates project properties, if they have not already been populated.
put (inherited from View) |
putByPropertyID (inherited from View) |
refresh (inherited from View) | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
refreshActiveLabels (inherited from View) | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
refreshFolders (inherited from View) | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. <p> If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. <p> In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
refreshLabels (inherited from View) | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
refreshPromotionModel (inherited from View) | Refreshes the local cached information about this view's promotion model.
remove (inherited from View) | Removes the view from the server.
removeFolderListener (inherited from View) | Removes a listener for Folder-related events.
removeFolderUpdateListener (inherited from View) | Removes a listener for folder update events.
removeFromIntArray (inherited from TypedResource) |
removeItemListener (inherited from View) |
removeItemUpdateListener (inherited from View) |
removeLabelListener (inherited from View) | Removes a listener for Label events.
removeViewListener (inherited from View) | Removes a listener for View events.
resolveLinkEndpoint (inherited from View) | Returns the item in this view referred to by the <code>LinkEndpoint</code>. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
setACL (inherited from View) |
setAlternatePath (inherited from View) |
setBranchOnShare (inherited from View) |
setContainerLevelACL (inherited from View) |
setDefaultPath (inherited from View) |
setDeletedAsOf | Used to limit deleted folders and items to those that were after a given time. Zero copies just this folder, 1 copies this folder and immediate children, and so on. Specifying -1 copies this folder and all children to any depth.
setDescription (inherited from View) |
setIncludeActiveItems |
setIncludeDeletedFolders |
setIncludeDeletedItems |
setName (inherited from View) |
setStatusMethodOverride (inherited from View) | Changes the status method to use for files in this view. This is a client side setting and will not change the behavior for other users of this view.
ToString (inherited from View) |
update (inherited from View) | Persists this view's properties to its <code>Server</code>.

See Also

RecycleBin Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RecycleBin Methods

The methods of the RecycleBin class are listed below. For a complete list of RecycleBin class members, see the RecycleBin Members topic.

Public Instance Methods

acquireOwnership (inherited from View) |
addFolderListener (inherited from View) | Adds a listener for Folder-related events. <p> In order to handle events, an application must enable MPX.
addFolderUpdateListener (inherited from View) | Listens for updates to this view's folder tree. <p> Similar to addFolderListener(), except that events are triggered by explicit operations performed by the client application. For example, calling View.refreshFolders(), Folder.update() or Folder.remove() might each trigger update events. <p> MPX is not required to receive folder update events.
addItemListener (inherited from View) | Overloaded.
addItemUpdateListener (inherited from View) |
addLabelListener (inherited from View) | Adds a listener for Label events. <p> Event handlers will be tiggered whenever a Label is added, changed, or deleted in this View. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
addToIntArray (inherited from TypedResource) |
addViewListener (inherited from View) | Adds a listener for View events. <p> Event handlers will be tiggered when this View is changed or deleted. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
Clone (inherited from CacheRef) |
cloneRevisionLabel (inherited from View) |
cloneViewLabel (inherited from View) |
close (inherited from View) | Frees all cached resources associated with this view, and closes the associated view session. <p> Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). <p> After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
copy (inherited from View) | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
createCheckinManager (inherited from View) | Overloaded. Constructs a CheckinManager with default options for this view.
createCheckoutManager (inherited from View) | Overloaded. Constructs a CheckoutManager with default options for this view.
createChildViewShareAllItems (inherited from View) |
createChildViewShareDefaultItems (inherited from View) |
createChildViewShareNoItems (inherited from View) |
createChildViewShareTheseItems (inherited from View) |
createRevisionLabel (inherited from View) |
createViewLabel (inherited from View) |
discard (inherited from View) | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
discardActiveLabels (inherited from View) | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
discardFolders (inherited from View) | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
discardLabels (inherited from View) | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from View) |
fetchAllLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. <p> The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. <p> If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
fetchAllLabelsFromView (inherited from View) |
findFolder (inherited from View) |
findItem (inherited from View) |
get (inherited from View) |
getACL (inherited from View) |
getActiveLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. The labels are cached until explicitly refreshed.
getAlternatePath (inherited from View) | Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.
getBaseConfiguration (inherited from View) | Returns the ViewConfiguration from which this View was derived.
getByteArray (inherited from SimpleTypedResource) |
getConfiguration (inherited from View) | Returns this view's configuration.
getContainerLevelACL (inherited from View) |
getCreatedBy (inherited from View) | Returns the user ID of the user that created the view.
getCreatedTime (inherited from View) | Returns the time at which the view was created.
getDefaultPath (inherited from View) | Returns the default working file path to be used for this view. This is the value stored in the repository.
getDeletedAsOf | Used to limit deleted folders and items to those that were after a given time.
getDerivedViews (inherited from View) | Returns the set of views derived from this one.
getDescription (inherited from View) | Returns the description of this view.
getDisembodiedItem (inherited from View) |
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
getFileStatusManager (inherited from View) | Get the FileBasedStatusManager that manages file status information for this View. The corresponding StarTeam Server must support client-managed status.
getFullName (inherited from View) | Returns the full hierarchical name of this view--that is, the concatentation of the root view and each descendent to this view.
GetHashCode (inherited from View) |
getHaveAccessRights (inherited from View) | Obsolete. Indicates whether or not the logged on user has rights to access this view.
getHistoryForItemID (inherited from View) |
getID (inherited from View) |
getIncludeActiveItems | Determines whether or not the resulting folders may contain active items.
getIncludeDeletedFolders | Determines whether or not deleted child folders will be inserted into the copy of the folder tree.
getIncludeDeletedItems | Determines whether or not the resulting folders may contain deleted items.
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLabels (inherited from View) | Returns the labels that exist in this view, including both active and deleted labels. The labels are cached until explicitly refreshed.
getName (inherited from View) | Returns the name of this view.
getNewNotificationItems (inherited from View) |
getOLEDate (inherited from SimpleTypedResource) |
getOwner (inherited from View) |
getParentContainer (inherited from View) |
getParentView (inherited from View) | Returns the parent of this view.
getPath (inherited from View) | Returns the working file path being used for this view. This path is either the default path or the alternate path. A non-null alternate path takes precedence over a default path.
getPossibleValues (inherited from SimpleTypedResource) |
getProject (inherited from View) | Returns the project to which this view belongs.
getPromotionModel (inherited from View) | Returns the promotion model associated with this view.
getPropertyNames (inherited from SimpleTypedResource) |
getRecycleBin (inherited from View) | Provides access to the items that have been deleted from a view. <p> For example: <pre> RecycleBin bin = view.getRecycleBin(); Folder root = bin.getRootFolder(); Item[] files = root.getItems(TypeNames.FILE); for (int i = 0; i < files.length; i++) { assertTrue(files[i].isDeleted()); } </pre> Note that this method is supported by StarTeam Server versions 9.0 and later.
getRootFolder (inherited from View) | Gets the root folder of this view. The Folder hierarchy is cached in the View object, until explicitly refreshed or discarded.
getServer (inherited from View) | Returns the server to which this view belongs.
getStatusMethodOverride (inherited from View) | Returns the status method used to determine status for files in this view. This method will not return null.
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getViewID (inherited from View) | Returns the unique integer identifier for this view.
hasNewNotificationItems (inherited from View) |
hasPermission (inherited from View) | Overloaded.
isAccessible (inherited from View) | Determines whether or not the logged on user has access to this view.
isBranch (inherited from View) | Return true if this view is a Branch view.
isBranchAll (inherited from View) | Return true if this view's original branching default was set "All".
isBranchNone (inherited from View) | Return true if this view's original branching default was set "None".
isBranchOnShare (inherited from View) | Returns true if this view is set to branch shared items.
isDeleted (inherited from View) | Determines whether or not this view has been deleted from the server.
isEqualTo (inherited from View) | Compares the properties of two Views.
isNonDerived (inherited from View) | Return true if this view is a Non-Derived view.
isReadOnly (inherited from View) | Return true if this is a ReadOnly view, otherwise false.
isReference (inherited from View) | Return true if this is a reference view, otherwise false.
isRefreshActiveLabelsRequired (inherited from View) | Returns true if a refreshLabels() operation might have resulted in Label information for active (non-deleted) labels being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshFoldersRequired (inherited from View) | Returns true if a View.refreshFolders() operation might have resulted in Folder information being updated; returns false if and only if it is known that the folders had not been changed since the last refresh. If MPX is not enabled, then isRefreshFoldersRequired() always returns true.
isRefreshLabelsRequired (inherited from View) | Returns true if a refreshLabels() operation might have resulted in Label information being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshRequired (inherited from View) | Returns true if a refresh() operation might have resulted in view properties being updated; returns false if and only if it is known that the view properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isRoot (inherited from View) | Return true if this view is a Root view.
MemberwiseClone (inherited from CacheRef) |
modifyItemsFlagForUser (inherited from View) |
modifyItemsReadStatusForUser (inherited from View) |
populate (inherited from View) | Populates project properties, if they have not already been populated.
put (inherited from View) |
putByPropertyID (inherited from View) |
refresh (inherited from View) | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
refreshActiveLabels (inherited from View) | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
refreshFolders (inherited from View) | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. <p> If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. <p> In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
refreshLabels (inherited from View) | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
refreshPromotionModel (inherited from View) | Refreshes the local cached information about this view's promotion model.
remove (inherited from View) | Removes the view from the server.
removeFolderListener (inherited from View) | Removes a listener for Folder-related events.
removeFolderUpdateListener (inherited from View) | Removes a listener for folder update events.
removeFromIntArray (inherited from TypedResource) |
removeItemListener (inherited from View) |
removeItemUpdateListener (inherited from View) |
removeLabelListener (inherited from View) | Removes a listener for Label events.
removeViewListener (inherited from View) | Removes a listener for View events.
resolveLinkEndpoint (inherited from View) | Returns the item in this view referred to by the <code>LinkEndpoint</code>. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
setACL (inherited from View) |
setAlternatePath (inherited from View) |
setBranchOnShare (inherited from View) |
setContainerLevelACL (inherited from View) |
setDefaultPath (inherited from View) |
setDeletedAsOf | Used to limit deleted folders and items to those that were after a given time. Zero copies just this folder, 1 copies this folder and immediate children, and so on. Specifying -1 copies this folder and all children to any depth.
setDescription (inherited from View) |
setIncludeActiveItems |
setIncludeDeletedFolders |
setIncludeDeletedItems |
setName (inherited from View) |
setStatusMethodOverride (inherited from View) | Changes the status method to use for files in this view. This is a client side setting and will not change the behavior for other users of this view.
ToString (inherited from View) |
update (inherited from View) | Persists this view's properties to its <code>Server</code>.

See Also

RecycleBin Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RecycleBin.getDeletedAsOf Method

Used to limit deleted folders and items to those that were after a given time.

public virtual OLEDate getDeletedAsOf();

See Also

RecycleBin Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RecycleBin.getIncludeActiveItems Method

Determines whether or not the resulting folders may contain active items.

public virtual bool getIncludeActiveItems();

See Also

RecycleBin Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RecycleBin.getIncludeDeletedFolders Method

Determines whether or not deleted child folders will be inserted into the copy of the folder tree.

public virtual bool getIncludeDeletedFolders();

See Also

RecycleBin Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RecycleBin.getIncludeDeletedItems Method

Determines whether or not the resulting folders may contain deleted items.

public virtual bool getIncludeDeletedItems();

See Also

RecycleBin Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RecycleBin.setDeletedAsOf Method

Used to limit deleted folders and items to those that were after a given time. Zero copies just this folder, 1 copies this folder and immediate children, and so on. Specifying -1 copies this folder and all children to any depth.

public virtual void setDeletedAsOf(
OLEDate deletedAsOf
);

See Also

RecycleBin Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RecycleBin.setIncludeActiveItems Method

public virtual void setIncludeActiveItems(
Boolean isIncluded
);

See Also

RecycleBin Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RecycleBin.setIncludeDeletedFolders Method

public virtual void setIncludeDeletedFolders(
Boolean isIncluded
);

See Also

RecycleBin Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RecycleBin.setIncludeDeletedItems Method

public virtual void setIncludeDeletedItems(
Boolean isIncluded
);

See Also

RecycleBin Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Res Class

For a list of all members of this type, see Res Members.

System.Object
ResIDs
Res

public class Res : ResIDs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Res Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Res Members

Res overview

Public Static Methods

formatKey
getString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from ResIDs) |
ToString (inherited from ResIDs) |

See Also

Res Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Res Methods

The methods of the Res class are listed below. For a complete list of Res class members, see the Res Members topic.

Public Static Methods

formatKey
getString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from ResIDs) |
ToString (inherited from ResIDs) |

See Also

Res Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Res.formatKey Method

public static string formatKey(
String key,
Object[] args
);

See Also

Res Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Res.getString Method

public static string getString(
String key
);

See Also

Res Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs Class

For a list of all members of this type, see ResIDs Members.

System.Object
ResIDs
Res

public class ResIDs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ResIDs Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs Members

ResIDs overview

Public Static Fields

COMMON_COMMAND_ILLEGAL_ENCODING_ERROR_MSG
FILE_TOO_LARGE_FMT
INVALID_ENUM_CODE_FMT
INVALID_ENUM_PROPERTY_FMT
INVALID_PORT_FMT
INVALID_SERVER_NAME_FMT
MISMATCH_OBJECT_IDS_FMT
MISMATCH_REVISION_TIME_FMT
NO_SUCH_QUERY_ID_FMT
NO_SUCH_QUERY_NAME_FMT
PROPERTY_CANNOT_CONVERT_VALUE_OF_TYPE_FMT

Public Instance Constructors

ResIDs Constructor Initializes a new instance of the ResIDs class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs Constructor

Initializes a new instance of the ResIDs class.

public ResIDs();

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs Fields

The fields of the ResIDs class are listed below. For a complete list of ResIDs class members, see the ResIDs Members topic.

Public Static Fields

COMMON_COMMAND_ILLEGAL_ENCODING_ERROR_MSG
FILE_TOO_LARGE_FMT
INVALID_ENUM_CODE_FMT
INVALID_ENUM_PROPERTY_FMT
INVALID_PORT_FMT
INVALID_SERVER_NAME_FMT
MISMATCH_OBJECT_IDS_FMT
MISMATCH_REVISION_TIME_FMT
NO_SUCH_QUERY_ID_FMT
NO_SUCH_QUERY_NAME_FMT
PROPERTY_CANNOT_CONVERT_VALUE_OF_TYPE_FMT

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.COMMON_COMMAND_ILLEGAL_ENCODING_ERROR_MSG Field

public static readonly String COMMON_COMMAND_ILLEGAL_ENCODING_ERROR_MSG;

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.FILE_TOO_LARGE_FMT Field

public static readonly String FILE_TOO_LARGE_FMT;

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.INVALID_ENUM_CODE_FMT Field

public static readonly String INVALID_ENUM_CODE_FMT;

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.INVALID_ENUM_PROPERTY_FMT Field

public static readonly String INVALID_ENUM_PROPERTY_FMT;

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.INVALID_PORT_FMT Field

public static readonly String INVALID_PORT_FMT;

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.INVALID_SERVER_NAME_FMT Field

public static readonly String INVALID_SERVER_NAME_FMT;

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.MISMATCH_OBJECT_IDS_FMT Field

public static readonly String MISMATCH_OBJECT_IDS_FMT;

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.MISMATCH_REVISION_TIME_FMT Field

public static readonly String MISMATCH_REVISION_TIME_FMT;

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.NO_SUCH_QUERY_ID_FMT Field

public static readonly String NO_SUCH_QUERY_ID_FMT;

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.NO_SUCH_QUERY_NAME_FMT Field

public static readonly String NO_SUCH_QUERY_NAME_FMT;

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.PROPERTY_CANNOT_CONVERT_VALUE_OF_TYPE_FMT Field

public static readonly String PROPERTY_CANNOT_CONVERT_VALUE_OF_TYPE_FMT;

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs Methods

The methods of the ResIDs class are listed below. For a complete list of ResIDs class members, see the ResIDs Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.ToString Method

public override string ToString();

See Also

ResIDs Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID Class

For a list of all members of this type, see RevisionID Members.

System.Object
RevisionID

public class RevisionID

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

RevisionID Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID Members

RevisionID overview

Public Instance Constructors

RevisionID Constructor

Public Instance Methods

Equals |
GetHashCode |
getObjectID | Returns the revision identifier's object ID.
getRevision | Returns the revision identifier's revision number.
GetType (inherited from Object) | Gets the Type of the current instance.
isTip | Return true if the revision identifier represents the "tip" revision of a branch. This is defined as a revision number equal to -1.
MemberwiseClone |
setObjectID |
setRevision |
ToString |

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID Constructor

public RevisionID(
Int32 objectID,
Int32 revision
);

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID Methods

The methods of the RevisionID class are listed below. For a complete list of RevisionID class members, see the RevisionID Members topic.

Public Instance Methods

Equals |
GetHashCode |
getObjectID | Returns the revision identifier's object ID.
getRevision | Returns the revision identifier's revision number.
GetType (inherited from Object) | Gets the Type of the current instance.
isTip | Return true if the revision identifier represents the "tip" revision of a branch. This is defined as a revision number equal to -1.
MemberwiseClone |
setObjectID |
setRevision |
ToString |

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID.Equals Method

public override bool Equals(
Object source
);

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID.GetHashCode Method

public override int GetHashCode();

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID.getObjectID Method

Returns the revision identifier's object ID.

public virtual int getObjectID();

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID.getRevision Method

Returns the revision identifier's revision number.

public virtual int getRevision();

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID.isTip Method

Return true if the revision identifier represents the "tip" revision of a branch. This is defined as a revision number equal to -1.

public virtual bool isTip();

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID.MemberwiseClone Method

public override object MemberwiseClone();

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID.setObjectID Method

public virtual void setObjectID(
Int32 objectID
);

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID.setRevision Method

public virtual void setRevision(
Int32 revision
);

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionID.ToString Method

public override string ToString();

See Also

RevisionID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier Interface

For a list of all members of this type, see RevisionIdentifier Members.

public interface RevisionIdentifier

Types that implement RevisionIdentifier

Type | Description
RevisionIdentifierAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

RevisionIdentifier Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier Members

RevisionIdentifier overview

Public Instance Methods

getContentRevision | Gets the content version of this item revision. The content version does not increment in parallel with the view version; it only increments when the file contents (not just any property) changes.
getDotNotation | Gets the dot notation of this revision of the repository object. The dot notation uniquely identifies any revision from any branch off of the same root object ID. For example: "1.2.3.5".
getObjectID | Gets the objectID (also known as the branch identifier) of this revision of the repository object.
getRepositoryID | Gets an ID that uniquely identifies the repository in which the object in question exists. We use the server's GUID in lower-case canonical format.
getRevisionNumber | Gets the version number of this revision of the repository object within its branch.
getRootObjectID | Gets the RootObjectID of the repository object. All revisions and branches of an object share the same RootObjectID.
setContentRevision |
setDotNotation |
setObjectID |
setRevisionNumber |
setRootObjectID |

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier Methods

The methods of the RevisionIdentifier interface are listed below. For a complete list of RevisionIdentifier interface members, see the RevisionIdentifier Members topic.

Public Instance Methods

getContentRevision | Gets the content version of this item revision. The content version does not increment in parallel with the view version; it only increments when the file contents (not just any property) changes.
getDotNotation | Gets the dot notation of this revision of the repository object. The dot notation uniquely identifies any revision from any branch off of the same root object ID. For example: "1.2.3.5".
getObjectID | Gets the objectID (also known as the branch identifier) of this revision of the repository object.
getRepositoryID | Gets an ID that uniquely identifies the repository in which the object in question exists. We use the server's GUID in lower-case canonical format.
getRevisionNumber | Gets the version number of this revision of the repository object within its branch.
getRootObjectID | Gets the RootObjectID of the repository object. All revisions and branches of an object share the same RootObjectID.
setContentRevision |
setDotNotation |
setObjectID |
setRevisionNumber |
setRootObjectID |

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier.getContentRevision Method

Gets the content version of this item revision. The content version does not increment in parallel with the view version; it only increments when the file contents (not just any property) changes.

int getContentRevision();

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier.getDotNotation Method

Gets the dot notation of this revision of the repository object. The dot notation uniquely identifies any revision from any branch off of the same root object ID. For example: "1.2.3.5".

string getDotNotation();

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier.getObjectID Method

Gets the objectID (also known as the branch identifier) of this revision of the repository object.

int getObjectID();

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier.getRepositoryID Method

Gets an ID that uniquely identifies the repository in which the object in question exists. We use the server's GUID in lower-case canonical format.

string getRepositoryID();

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier.getRevisionNumber Method

Gets the version number of this revision of the repository object within its branch.

int getRevisionNumber();

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier.getRootObjectID Method

Gets the RootObjectID of the repository object. All revisions and branches of an object share the same RootObjectID.

int getRootObjectID();

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier.setContentRevision Method

void setContentRevision(
Int32 rev
);

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier.setDotNotation Method

void setDotNotation(
String dot
);

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier.setObjectID Method

void setObjectID(
Int32 id
);

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier.setRevisionNumber Method

void setRevisionNumber(
Int32 n
);

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionIdentifier.setRootObjectID Method

void setRootObjectID(
Int32 id
);

See Also

RevisionIdentifier Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException Class

For a list of all members of this type, see SDKRuntimeException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
SDKRuntimeException

public class SDKRuntimeException : RuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SDKRuntimeException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException Members

SDKRuntimeException overview

Public Static Methods

isInternalApplicationError
wrap

Public Instance Constructors

SDKRuntimeException Overloaded. Initializes a new instance of the SDKRuntimeException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getException |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isInternalError |
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException Constructor

Overload List

public SDKRuntimeException(Throwable);

public SDKRuntimeException(String);

public SDKRuntimeException(String,Throwable);

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException Constructor (String)

public SDKRuntimeException(
String message
);

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace | SDKRuntimeException Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException Constructor (Throwable)

public SDKRuntimeException(
Throwable exception
);

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace | SDKRuntimeException Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException Constructor (String, Throwable)

public SDKRuntimeException(
String message,
Throwable exception
);

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace | SDKRuntimeException Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException Methods

The methods of the SDKRuntimeException class are listed below. For a complete list of SDKRuntimeException class members, see the SDKRuntimeException Members topic.

Public Static Methods

isInternalApplicationError
wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getException |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isInternalError |
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException.Equals Method

public override bool Equals(
Object source
);

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException.getException Method

public virtual Throwable getException();

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException.GetHashCode Method

public override int GetHashCode();

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException.getMessage Method

public override string getMessage();

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException.isInternalApplicationError Method

public static bool isInternalApplicationError(
Throwable throwable
);

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException.isInternalError Method

public virtual bool isInternalError();

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException.unwrap Method

public virtual SDKRuntimeException unwrap();

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SDKRuntimeException.wrap Method

public static SDKRuntimeException wrap(
SDKRuntimeException arg
);

See Also

SDKRuntimeException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurableContainerAdapter Class

For a list of all members of this type, see SecurableContainerAdapter Members.

System.Object
SecurableContainerAdapter

public class SecurableContainerAdapter : ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SecurableContainerAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurableContainerAdapter Members

SecurableContainerAdapter overview

Public Instance Constructors

SecurableContainerAdapter Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getContainerLevelACL |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getParentContainer |
GetType (inherited from Object) | Gets the Type of the current instance.
hasPermission |
MemberwiseClone |
setContainerLevelACL |
ToString |

See Also

SecurableContainerAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurableContainerAdapter Constructor

public SecurableContainerAdapter(
ISecurableContainer arg
);

See Also

SecurableContainerAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurableContainerAdapter Methods

The methods of the SecurableContainerAdapter class are listed below. For a complete list of SecurableContainerAdapter class members, see the SecurableContainerAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getContainerLevelACL |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getParentContainer |
GetType (inherited from Object) | Gets the Type of the current instance.
hasPermission |
MemberwiseClone |
setContainerLevelACL |
ToString |

See Also

SecurableContainerAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurableContainerAdapter.getContainerLevelACL Method

public virtual AclEntry[] getContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.getContainerLevelACL

See Also

SecurableContainerAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurableContainerAdapter.getParentContainer Method

public virtual ISecurableContainer getParentContainer();

Implements

ISecurableContainer.getParentContainer

See Also

SecurableContainerAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurableContainerAdapter.hasPermission Method

public virtual bool hasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.hasPermission

See Also

SecurableContainerAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurableContainerAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

SecurableContainerAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurableContainerAdapter.setContainerLevelACL Method

public virtual void setContainerLevelACL(
AclEntry[] acl,
String typeName
);

Implements

ISecurableContainer.setContainerLevelACL

See Also

SecurableContainerAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurableContainerAdapter.ToString Method

public override string ToString();

See Also

SecurableContainerAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry Class

For a list of all members of this type, see SecurityLogEntry Members.

System.Object
SecurityLogEntry

public class SecurityLogEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SecurityLogEntry Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry Members

SecurityLogEntry overview

Public Instance Methods

Equals |
getAccessCheckSecLogID | Returns the AccessCheckSecLogID or null.
getContainerACLSecLogID | Returns the ContainerACLSecLogID or null.
GetHashCode |
getObjectACLSecLogID | Returns the ObjectACLSecLogID or null.
getObjectDisplayText | Returns the display text for the security event.
getTimestamp | Returns the timestamp.
GetType (inherited from Object) | Gets the Type of the current instance.
getUser | Returns the User object that represents the user id.
getUserGroupSecLogID | Returns the UserGroupSecLogID or null.
getUserID | Returns the user id.
getWorkstation | Returns the Workstation object that represents the workstation id.
getWorkstationID | Returns the workstation id.
isFailure | Returns true if this was a failure, otherwise false.
MemberwiseClone |
ToString |

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry Methods

The methods of the SecurityLogEntry class are listed below. For a complete list of SecurityLogEntry class members, see the SecurityLogEntry Members topic.

Public Instance Methods

Equals |
getAccessCheckSecLogID | Returns the AccessCheckSecLogID or null.
getContainerACLSecLogID | Returns the ContainerACLSecLogID or null.
GetHashCode |
getObjectACLSecLogID | Returns the ObjectACLSecLogID or null.
getObjectDisplayText | Returns the display text for the security event.
getTimestamp | Returns the timestamp.
GetType (inherited from Object) | Gets the Type of the current instance.
getUser | Returns the User object that represents the user id.
getUserGroupSecLogID | Returns the UserGroupSecLogID or null.
getUserID | Returns the user id.
getWorkstation | Returns the Workstation object that represents the workstation id.
getWorkstationID | Returns the workstation id.
isFailure | Returns true if this was a failure, otherwise false.
MemberwiseClone |
ToString |

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.Equals Method

public override bool Equals(
Object source
);

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.getAccessCheckSecLogID Method

Returns the AccessCheckSecLogID or null.

public virtual AccessCheckSecLogID getAccessCheckSecLogID();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.getContainerACLSecLogID Method

Returns the ContainerACLSecLogID or null.

public virtual ContainerACLSecLogID getContainerACLSecLogID();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.GetHashCode Method

public override int GetHashCode();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.getObjectACLSecLogID Method

Returns the ObjectACLSecLogID or null.

public virtual ObjectACLSecLogID getObjectACLSecLogID();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.getObjectDisplayText Method

Returns the display text for the security event.

public virtual string getObjectDisplayText();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.getTimestamp Method

Returns the timestamp.

public virtual OLEDate getTimestamp();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.getUser Method

Returns the User object that represents the user id.

public virtual User getUser();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.getUserGroupSecLogID Method

Returns the UserGroupSecLogID or null.

public virtual UserGroupSecLogID getUserGroupSecLogID();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.getUserID Method

Returns the user id.

public virtual int getUserID();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.getWorkstation Method

Returns the Workstation object that represents the workstation id.

public virtual Workstation getWorkstation();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.getWorkstationID Method

Returns the workstation id.

public virtual int getWorkstationID();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.isFailure Method

Returns true if this was a failure, otherwise false.

public virtual bool isFailure();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.MemberwiseClone Method

public override object MemberwiseClone();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.ToString Method

public override string ToString();

See Also

SecurityLogEntry Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType Class

For a list of all members of this type, see SecurityLogEntry.SecurityEventType Members.

System.Object
SecurityLogEntry.SecurityEventType

public class SecurityLogEntry.SecurityEventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SecurityLogEntry.SecurityEventType Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType Members

SecurityLogEntry.SecurityEventType overview

Public Static Fields

eAccessTimeRestricted
eContainerACLAddEdit
eContainerACLDelete
eLockout
eLoginFailure
eLogon
eLogout
eNoSuchLoginName
eObjectAccessCheck
eObjectACLAcquireOwnership
eObjectACLAddEdit
eObjectACLAddOwner
eObjectACLDelete
eObjectACLDropOwner
ePasswordExpired
ePolicyChange
eSuspendedAccount
eUnknownEvent
eUserChange
eUserGroupAdd
eUserGroupDrop
eUserGroupEdit
eUserGroupForceLogout
eUserGroupStatusChange

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType Fields

The fields of the SecurityLogEntry.SecurityEventType class are listed below. For a complete list of SecurityLogEntry.SecurityEventType class members, see the SecurityLogEntry.SecurityEventType Members topic.

Public Static Fields

eAccessTimeRestricted
eContainerACLAddEdit
eContainerACLDelete
eLockout
eLoginFailure
eLogon
eLogout
eNoSuchLoginName
eObjectAccessCheck
eObjectACLAcquireOwnership
eObjectACLAddEdit
eObjectACLAddOwner
eObjectACLDelete
eObjectACLDropOwner
ePasswordExpired
ePolicyChange
eSuspendedAccount
eUnknownEvent
eUserChange
eUserGroupAdd
eUserGroupDrop
eUserGroupEdit
eUserGroupForceLogout
eUserGroupStatusChange

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eAccessTimeRestricted Field

public const Int32 eAccessTimeRestricted = 4;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eContainerACLAddEdit Field

public const Int32 eContainerACLAddEdit = 65536;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eContainerACLDelete Field

public const Int32 eContainerACLDelete = 65537;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eLockout Field

public const Int32 eLockout = 8;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eLoginFailure Field

public const Int32 eLoginFailure = 6;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eLogon Field

public const Int32 eLogon = 1;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eLogout Field

public const Int32 eLogout = 2;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eNoSuchLoginName Field

public const Int32 eNoSuchLoginName = 5;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eObjectAccessCheck Field

public const Int32 eObjectAccessCheck = 1048576;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eObjectACLAcquireOwnership Field

public const Int32 eObjectACLAcquireOwnership = 4100;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eObjectACLAddEdit Field

public const Int32 eObjectACLAddEdit = 4096;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eObjectACLAddOwner Field

public const Int32 eObjectACLAddOwner = 4098;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eObjectACLDelete Field

public const Int32 eObjectACLDelete = 4097;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eObjectACLDropOwner Field

public const Int32 eObjectACLDropOwner = 4099;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.ePasswordExpired Field

public const Int32 ePasswordExpired = 7;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.ePolicyChange Field

public const Int32 ePolicyChange = 16;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eSuspendedAccount Field

public const Int32 eSuspendedAccount = 3;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eUnknownEvent Field

public const Int32 eUnknownEvent = 0;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eUserChange Field

public const Int32 eUserChange = 261;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eUserGroupAdd Field

public const Int32 eUserGroupAdd = 256;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eUserGroupDrop Field

public const Int32 eUserGroupDrop = 257;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eUserGroupEdit Field

public const Int32 eUserGroupEdit = 258;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eUserGroupForceLogout Field

public const Int32 eUserGroupForceLogout = 260;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SecurityLogEntry.SecurityEventType.eUserGroupStatusChange Field

public const Int32 eUserGroupStatusChange = 259;

See Also

SecurityLogEntry.SecurityEventType Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server Class

For a list of all members of this type, see Server Members.

System.Object
Server

public class Server

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Server Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server Members

Server overview

Public Static Methods

enableCredentialCaching | Enables credential caching on this workstation, if it is available and not already enabled. Currently, this starts the StarTeam Toolbar.
isCredentialCachingAvailable | Determines whether or not the credential caching feature is available on this workstation. Currently, credential caching is available only when the StarTeam toolbar is installed. Note that credential caching may be available, but not enabled.
isCredentialCachingEnabled | Determines whether or not credential caching is enabled on this workstation. Currently, credential caching is enabled only when the StarTeam toolbar is running.

Public Instance Constructors

Server Overloaded. Initializes a new instance of the Server class.

Public Instance Methods

addMPXStatusListener | Adds a listener for MPXStatusEvents. <p> Event handlers will be tiggered whenever an important change occurs in the status of MPX or the MPX event transmitter.
addProjectListener | Adds a listener for Project events. <p> Event handlers will be tiggered whenever a Project is added, changed or deleted on this Server. Note that an application will not receive events for Projects that the logged-in user does not have permission to access. <p> In order to handle events, an application must enable MPX.
addServerControlListener | Adds a listener for ServerControl events. <p> Event handlers will be tiggered whenever this Server is stopped or restarted. <p> In order to handle events, an application must enable MPX.
addTypeListener | Adds a listener for Type events. <p> Event handlers will be tiggered whenever a Type (or its associated Properties) are modified on this Server. <p> In order to handle events, an application must enable MPX.
addUserListener | Adds a listener for User events. <p> Event handlers will be tiggered whenever a User is added, changed or deleted on this Server. <p> In order to handle events, an application must enable MPX.
autoLocateCacheAgent | autoLocate a Cache Agent, return null if none found Attempts to autolocate can be expensive
autoLogOn | Log on to this server using credentials that have been cached on this workstation.
cacheLogOnCredentials
changePassword
connect | Establishes a network connection to the remote server process. <p> If the network connection is successfully established, and an MPXProfileName was specified in the Server constructor, then an attempt is made to automatically enable MPX. If an MPXException is thrown, it will be ignored, and will not cause the connect() to fail. An application can use isMPXEnabled() to determine whether or not MPX was properly enabled.
disableMPX | Disables MPX, if it was enabled for this server.
discardAccounts | Discards all cached User and Group information. It will be re-fetched from the server on demand (even when MPX is enabled).
discardGroups | Discards cached Group information. The next call to getGroups() will re-fetch the group information from the StarTeam Server.
discardTypes | Discards all cached Type information. It will be re-fetched from the server on demand (even when MPX is enabled).
discardUsers | Discards cached User information. The next call to getUsers() will re-fetch the user information from the StarTeam Server (even when MPX is enabled).
disconnect | Terminates the network connection to the remote server process. The user will be logged off.
enableMPX | Overloaded. Enables MPX using the default client MPX profile.
Equals
fetchEmailUsers | This method issues a command to the server to return the list of users that are able to recieve email messages.
findLinks | Returns an array of <code>Link</code> objects associated with this item.
getActiveGroups | Returns all of the active (non-deleted) groups in this Server.
getActiveUsers | Returns all of the active (non-deleted) users in this Server.
getAddress | Network address of this server.
getAdministration | Returns the <code>ServerAdministration</code> object through which various administration operations can be performed on the server.
getAutoReconnectAttempts | If automatic reconnect is enabled, indicates the maximum number of attempts to reconnect that will be made while executing a single server command.
getAutoReconnectWait | If automatic reconnect is enabled, indicates the number of seconds that we will wait before each reconnect attempt.
getClientContext | Returns the ClientContext associated when logged in to the Server. This may return null if not logged in.
getCommandAPIRevisionLevel | Returns the command interface revision level (dot notation) supported by this server. Different releases of StarTeam will have different revision levels indicating changes in command syntax or semantics. The SDK client classes will insulate users from these changes when possible by being backwards compatible with older releases of the StarTeam Server.
getCommandCount | Gets the number of commands sent to the StarTeam server since the connection was established. This method is useful for debugging performance related problems.
getCurrentCacheAgent | returns the CacheAgent currently in use by this server, or null
getCurrentMPXProfile | Gets the current MPX event handler profile.
getCurrentTime | Gets the current time on the server. Supported by StarTeam server versions 9.0 and later.
getEncryptionAlgorithm | Gets the level of encryption requested for the connection.
getEventHandlerInfo
getEventHandlerInfoNames | Returns an array containing the names of all existing EventHandlerInfos on this server.
getFilterList
getForeignArchivePaths
getGroup
getGroups | Returns all of the groups on this Server. This includes both active and deleted groups.
GetHashCode
getKeepAliveInterval | Gets the keep-alive interval, in minutes. When keep-alive is in effect, the keep-alive interval is the number of minutes between successive calls to ping().
getMPXCacheAgentEnabled | Obsolete. Indicates whether or not checkouts via the MPX cache agent are enabled. The cache agent is disabled by default.
getMPXMessageCount | Gets the number of MPX messages received by the server since MPX was enabled. Useful for debugging MPX related problems.
getMPXTransmitterName | The name of the event handler for the StarTeam MPX Transmitter. Pass this name to Server.getEventHandlerInfo() to get the event handler information for the MPX event transmitter. Pre-9.0 servers use the name "StarbaseMPX Transmitter" 9.0 servers use the name "StarTeamMPX Transmitter"
getMyUserAccount | Returns the user account for the currently logged on user. Every user has permission to modify his own user account. <p> The user account information is not cached in the Server object; each call to getMyUserAccount() returns up-to-date information in a newly allocated MyUserAccount object. <p> getMyUserAccount() is not MPX-enabled; the account information is always retrieved directly from the repository.
getPort | TCP/IP port on which to connect to the remote server.
getProductCodes | Gets the product codes licensed for this server. Will return an empty array if the server does not support that information or if a user has not yet logged in.
getProjects | Gets the set of Projects accessible from this Server. <p> The project list is not cached in the Server object. Each call to getProjects() returns an up-to-date project list consisting of newly allocated Project objects. <p> If MPX is enabled, getProjects() is optimized to avoid unnecessary server commands.
getPropertyEnums | Returns the <code>PropertyEnums</code> object for this server. You must have already connected to the server or an IllegalStateException will be thrown.
getPropertyNames | Returns the <code>PropertyNames</code> object for this server. You must have already connected to the server or an IllegalStateException will be thrown.
getProtocol | Gets the protocol used to connect to the server.
getQueryList
getRepositoryID | Uniquely identifies the repository served by this server amongst all StarTeam repositories in the universe. Be warned that it is possible to take an existing StarTeam repository and re-host it on another machine in which case this unique ID is no longer unique.
getRequiredEncryptionLevel | Returns the level of security required to connect to the server.
getRevisionLevel | Returns the interface revision level supported by this server. Different releases of StarTeam will have different revision levels indicating changes in command syntax or semantics. The SDK client classes will insulate users from these changes when possible by being backwards compatible with older releases of the StarTeam Server.
getServerBuild | Returns the server build number as reported by the server. Returns an empty string if this server object is not connected.
getServerBuildDescription | Returns a server build description as reported by the server. Will return an empty string if this server object is not connected to the server.
getSession | Returns session information for the currently logged on user.
getSupportedFeatures | Gets an instance of the SupportedFeatures class that can tell which features are available for this StarTeam server. Will throw an exception if the client is not yest connected to the server.
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames | Returns the <code>TypeNames</code> object for this server. You must have already connected to the server or an IllegalStateException will be thrown.
getTypes | Returns an array of <code>Type</code> objects supported by this server.
getUser
getUsers | Returns all of the users in this Server. This includes both active and deleted users.
handleEvents | Places the current thread in an event-handling state. <p> While in an event-handling state, the thread is usually asleep, waking occasionally just long enough to ping the server (keeping the connection alive). The event-handling loop continues until some other thread (presumably, the event-handling thread for this Server object) calls interruptHandleEvents(). <p> An application does not need to call handleEvents() in order to handle events; this is just a convenience method for applications that have nothing else they need to do while waiting for an event to occur. <p> Only one thread may call handleEvents() per Server object at any given time. After handleEvents() exits (as a result of a call to interruptHandleEvents), then handleEvents() may be called again by the same thread or by some other thread. <p> handleEvents() will fail if MPX is not enabled, or if there are no event-handlers running. <p> handleEvents() should not be called from within an event handler. (This would put the event-handling thread to sleep.)
hasProductCode
hasProductCodeInformation | Obsolete. Determines whether or not the licensed product codes are available from this server.
interruptHandleEvents | Interrupts a handleEvents() loop, if there is one running. Usually called from within an event-handler, running in the event-handling thread for this Server object.
isAutoLogOnAvailable | Determines whether or not logon credentials for this server have been cached on this workstation. If so, then the auto logon feature may be used to logon using the cached credentials.
isAutoReconnectEnabled | Indicates whether or not a reconnect is automatically attempted whenever a connection problem is detected while executing a server command.
isCompressed | Determines whether or not the server connection is compressed.
isConnected | Tells whether a network connection has been established to the server.
isKeepAlive | Determines whether or not keep-alive mode is in effect.
isLoggedOn | Returns true if someone has logged on through this server object.
isMailAvailable | Determines whether or not the server supports email.
isMPXAvailable | Determines whether or not MPX is installed on this server.
isMPXEnabled | Determines whether or not MPX has been enabled for this server.
isMPXResponding | Determines whether or not the MPX server is running properly.
isRefreshAccountsRequired | Returns true if a refreshAccounts() operation might have resulted in User or Group information being updated; returns false if and only if it is known that the User and Group information had not been changed since the last refresh. Note that since MPX does not currently broadcast any group-related events, isRefreshAccountsRequired() always returns true, even if MPX is enabled.
isRefreshGroupsRequired | Returns true if a refreshGroups() operation might have resulting in Group information being updated; returns false if and only if it is known that the Group information had not been changed since the last refresh. Note that since MPX does not currently broadcast any group-related events, isRefreshGroupsRequired() always returns true, even if MPX is enabled.
isRefreshTypesRequired | Returns true if a refreshTypes() operation might have resulted in Type or Property information being updated; returns false if and only if it is known that the Type information has not been changed since the last refresh. If MPX is not enabled, isRefreshTypesRequired() always returns true.
isRefreshUsersRequired | Returns true if a refreshUsers() operation might have resulted in User information being updated; returns false if and only if it is known that the User information had not been changed since the last refresh. If MPX is not enabled, then isRefreshUsersRequired() always returns true.
isTypeSupported
locateCacheAgent
logOn
logOnForWorkstation
logOnWithClientContext
MemberwiseClone
ping | Verifies that the server is responding and informs the server that this connection/user session is still active.
pingMPXServer | Throws an appropriate MPXException if the MPX server is not running properly.
reconnect | Overloaded. Attempts to re-establish the connection to the server, re-opening any existing view sessions. <p> Uses the user credentials provided at logon time.
refreshAccounts | Refreshes cached User and Group information. Existing User and Group objects are modified in place whenever possible.
refreshGroups | Refreshes cached Group information to reflect recent changes to the repository. Modifies existing Group objects in place whenever possible.
refreshTypes | Refreshes cached Type information to reflect recent changes to the repository. Existing Type and Property objects are modified in place, whenever possible. If MPX is enabled, refreshTypes() is optimized to avoid unnecessary server commands.
refreshTypesInPlace | Obsolete. Deprecated. Equivalent to refreshTypes().
refreshUsers | Refreshes cached User information to reflect recent changes to the repository. Modifies existing User objects in place whenever possible. If MPX is enabled, refreshUsers() is optimized to avoid unnecessary server commands.
removeMPXStatusListener | Removes a listener for MPXStatusEvents.
removeProjectListener | Removes a listener for Project events.
removeServerControlListener | Removes a listener for ServerControl events.
removeTypeListener | Removes a listener for Type events.
removeUserListener | Removes a listener for User events.
sendMailFromView
sendMailWithAttachments
setAutoReconnectAttempts
setAutoReconnectEnabled
setAutoReconnectWait
setCommandUserID
setForeignPassword | Sets a password for the foreign archive associated with this project.
setForeignPasswordExplicit
setKeepAlive
setKeepAliveInterval
setMPXCacheAgentEnabled | Obsolete.
ToString
typeForClassID
typeForName
useConnection

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server Constructor

Overload List

Creates a new Server object, using the given connection information. <p> The ServerInfo must specify a supported protocol; otherwise, an IllegalArgumentException will be thrown. <p> If ServerInfo specifies an MPXProfileName, then later, after the Server connection itself is established, an attempt will be made to automatically enable MPX.

public Server(ServerInfo);

public Server(String,Int32);

public Server(String,Int32,EncryptionAlgorithm,Boolean);

public Server(String,Int32,EncryptionAlgorithm,Boolean,Int32);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server Constructor (String, Int32)

public Server(
String address,
Int32 port
);

See Also

Server Class | com.starbase.starteam Namespace | Server Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server Constructor (String, Int32, EncryptionAlgorithm, Boolean)

public Server(
String address,
Int32 port,
EncryptionAlgorithm algorithmID,
Boolean compressionLevel
);

See Also

Server Class | com.starbase.starteam Namespace | Server Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server Constructor (String, Int32, EncryptionAlgorithm, Boolean, Int32)

public Server(
String address,
Int32 port,
EncryptionAlgorithm algorithmID,
Boolean compressionLevel,
Int32 protocol
);

See Also

Server Class | com.starbase.starteam Namespace | Server Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server Constructor (ServerInfo)

Creates a new Server object, using the given connection information. <p> The ServerInfo must specify a supported protocol; otherwise, an IllegalArgumentException will be thrown. <p> If ServerInfo specifies an MPXProfileName, then later, after the Server connection itself is established, an attempt will be made to automatically enable MPX.

public Server(
ServerInfo info
);

See Also

Server Class | com.starbase.starteam Namespace | Server Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server Methods

The methods of the Server class are listed below. For a complete list of Server class members, see the Server Members topic.

Public Static Methods

enableCredentialCaching | Enables credential caching on this workstation, if it is available and not already enabled. Currently, this starts the StarTeam Toolbar.
isCredentialCachingAvailable | Determines whether or not the credential caching feature is available on this workstation. Currently, credential caching is available only when the StarTeam toolbar is installed. Note that credential caching may be available, but not enabled.
isCredentialCachingEnabled | Determines whether or not credential caching is enabled on this workstation. Currently, credential caching is enabled only when the StarTeam toolbar is running.

Public Instance Methods

addMPXStatusListener | Adds a listener for MPXStatusEvents. <p> Event handlers will be tiggered whenever an important change occurs in the status of MPX or the MPX event transmitter.
addProjectListener | Adds a listener for Project events. <p> Event handlers will be tiggered whenever a Project is added, changed or deleted on this Server. Note that an application will not receive events for Projects that the logged-in user does not have permission to access. <p> In order to handle events, an application must enable MPX.
addServerControlListener | Adds a listener for ServerControl events. <p> Event handlers will be tiggered whenever this Server is stopped or restarted. <p> In order to handle events, an application must enable MPX.
addTypeListener | Adds a listener for Type events. <p> Event handlers will be tiggered whenever a Type (or its associated Properties) are modified on this Server. <p> In order to handle events, an application must enable MPX.
addUserListener | Adds a listener for User events. <p> Event handlers will be tiggered whenever a User is added, changed or deleted on this Server. <p> In order to handle events, an application must enable MPX.
autoLocateCacheAgent | autoLocate a Cache Agent, return null if none found Attempts to autolocate can be expensive
autoLogOn | Log on to this server using credentials that have been cached on this workstation.
cacheLogOnCredentials
changePassword
connect | Establishes a network connection to the remote server process. <p> If the network connection is successfully established, and an MPXProfileName was specified in the Server constructor, then an attempt is made to automatically enable MPX. If an MPXException is thrown, it will be ignored, and will not cause the connect() to fail. An application can use isMPXEnabled() to determine whether or not MPX was properly enabled.
disableMPX | Disables MPX, if it was enabled for this server.
discardAccounts | Discards all cached User and Group information. It will be re-fetched from the server on demand (even when MPX is enabled).
discardGroups | Discards cached Group information. The next call to getGroups() will re-fetch the group information from the StarTeam Server.
discardTypes | Discards all cached Type information. It will be re-fetched from the server on demand (even when MPX is enabled).
discardUsers | Discards cached User information. The next call to getUsers() will re-fetch the user information from the StarTeam Server (even when MPX is enabled).
disconnect | Terminates the network connection to the remote server process. The user will be logged off.
enableMPX | Overloaded. Enables MPX using the default client MPX profile.
Equals
fetchEmailUsers | This method issues a command to the server to return the list of users that are able to recieve email messages.
findLinks | Returns an array of <code>Link</code> objects associated with this item.
getActiveGroups | Returns all of the active (non-deleted) groups in this Server.
getActiveUsers | Returns all of the active (non-deleted) users in this Server.
getAddress | Network address of this server.
getAdministration | Returns the <code>ServerAdministration</code> object through which various administration operations can be performed on the server.
getAutoReconnectAttempts | If automatic reconnect is enabled, indicates the maximum number of attempts to reconnect that will be made while executing a single server command.
getAutoReconnectWait | If automatic reconnect is enabled, indicates the number of seconds that we will wait before each reconnect attempt.
getClientContext | Returns the ClientContext associated when logged in to the Server. This may return null if not logged in.
getCommandAPIRevisionLevel | Returns the command interface revision level (dot notation) supported by this server. Different releases of StarTeam will have different revision levels indicating changes in command syntax or semantics. The SDK client classes will insulate users from these changes when possible by being backwards compatible with older releases of the StarTeam Server.
getCommandCount | Gets the number of commands sent to the StarTeam server since the connection was established. This method is useful for debugging performance related problems.
getCurrentCacheAgent | returns the CacheAgent currently in use by this server, or null
getCurrentMPXProfile | Gets the current MPX event handler profile.
getCurrentTime | Gets the current time on the server. Supported by StarTeam server versions 9.0 and later.
getEncryptionAlgorithm | Gets the level of encryption requested for the connection.
getEventHandlerInfo
getEventHandlerInfoNames | Returns an array containing the names of all existing EventHandlerInfos on this server.
getFilterList
getForeignArchivePaths
getGroup
getGroups | Returns all of the groups on this Server. This includes both active and deleted groups.
GetHashCode
getKeepAliveInterval | Gets the keep-alive interval, in minutes. When keep-alive is in effect, the keep-alive interval is the number of minutes between successive calls to ping().
getMPXCacheAgentEnabled | Obsolete. Indicates whether or not checkouts via the MPX cache agent are enabled. The cache agent is disabled by default.
getMPXMessageCount | Gets the number of MPX messages received by the server since MPX was enabled. Useful for debugging MPX related problems.
getMPXTransmitterName | The name of the event handler for the StarTeam MPX Transmitter. Pass this name to Server.getEventHandlerInfo() to get the event handler information for the MPX event transmitter. Pre-9.0 servers use the name "StarbaseMPX Transmitter" 9.0 servers use the name "StarTeamMPX Transmitter"
getMyUserAccount | Returns the user account for the currently logged on user. Every user has permission to modify his own user account. <p> The user account information is not cached in the Server object; each call to getMyUserAccount() returns up-to-date information in a newly allocated MyUserAccount object. <p> getMyUserAccount() is not MPX-enabled; the account information is always retrieved directly from the repository.
getPort | TCP/IP port on which to connect to the remote server.
getProductCodes | Gets the product codes licensed for this server. Will return an empty array if the server does not support that information or if a user has not yet logged in.
getProjects | Gets the set of Projects accessible from this Server. <p> The project list is not cached in the Server object. Each call to getProjects() returns an up-to-date project list consisting of newly allocated Project objects. <p> If MPX is enabled, getProjects() is optimized to avoid unnecessary server commands.
getPropertyEnums | Returns the <code>PropertyEnums</code> object for this server. You must have already connected to the server or an IllegalStateException will be thrown.
getPropertyNames | Returns the <code>PropertyNames</code> object for this server. You must have already connected to the server or an IllegalStateException will be thrown.
getProtocol | Gets the protocol used to connect to the server.
getQueryList
getRepositoryID | Uniquely identifies the repository served by this server amongst all StarTeam repositories in the universe. Be warned that it is possible to take an existing StarTeam repository and re-host it on another machine in which case this unique ID is no longer unique.
getRequiredEncryptionLevel | Returns the level of security required to connect to the server.
getRevisionLevel | Returns the interface revision level supported by this server. Different releases of StarTeam will have different revision levels indicating changes in command syntax or semantics. The SDK client classes will insulate users from these changes when possible by being backwards compatible with older releases of the StarTeam Server.
getServerBuild | Returns the server build number as reported by the server. Returns an empty string if this server object is not connected.
getServerBuildDescription | Returns a server build description as reported by the server. Will return an empty string if this server object is not connected to the server.
getSession | Returns session information for the currently logged on user.
getSupportedFeatures | Gets an instance of the SupportedFeatures class that can tell which features are available for this StarTeam server. Will throw an exception if the client is not yest connected to the server.
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames | Returns the <code>TypeNames</code> object for this server. You must have already connected to the server or an IllegalStateException will be thrown.
getTypes | Returns an array of <code>Type</code> objects supported by this server.
getUser
getUsers | Returns all of the users in this Server. This includes both active and deleted users.
handleEvents | Places the current thread in an event-handling state. <p> While in an event-handling state, the thread is usually asleep, waking occasionally just long enough to ping the server (keeping the connection alive). The event-handling loop continues until some other thread (presumably, the event-handling thread for this Server object) calls interruptHandleEvents(). <p> An application does not need to call handleEvents() in order to handle events; this is just a convenience method for applications that have nothing else they need to do while waiting for an event to occur. <p> Only one thread may call handleEvents() per Server object at any given time. After handleEvents() exits (as a result of a call to interruptHandleEvents), then handleEvents() may be called again by the same thread or by some other thread. <p> handleEvents() will fail if MPX is not enabled, or if there are no event-handlers running. <p> handleEvents() should not be called from within an event handler. (This would put the event-handling thread to sleep.)
hasProductCode
hasProductCodeInformation | Obsolete. Determines whether or not the licensed product codes are available from this server.
interruptHandleEvents | Interrupts a handleEvents() loop, if there is one running. Usually called from within an event-handler, running in the event-handling thread for this Server object.
isAutoLogOnAvailable | Determines whether or not logon credentials for this server have been cached on this workstation. If so, then the auto logon feature may be used to logon using the cached credentials.
isAutoReconnectEnabled | Indicates whether or not a reconnect is automatically attempted whenever a connection problem is detected while executing a server command.
isCompressed | Determines whether or not the server connection is compressed.
isConnected | Tells whether a network connection has been established to the server.
isKeepAlive | Determines whether or not keep-alive mode is in effect.
isLoggedOn | Returns true if someone has logged on through this server object.
isMailAvailable | Determines whether or not the server supports email.
isMPXAvailable | Determines whether or not MPX is installed on this server.
isMPXEnabled | Determines whether or not MPX has been enabled for this server.
isMPXResponding | Determines whether or not the MPX server is running properly.
isRefreshAccountsRequired | Returns true if a refreshAccounts() operation might have resulted in User or Group information being updated; returns false if and only if it is known that the User and Group information had not been changed since the last refresh. Note that since MPX does not currently broadcast any group-related events, isRefreshAccountsRequired() always returns true, even if MPX is enabled.
isRefreshGroupsRequired | Returns true if a refreshGroups() operation might have resulting in Group information being updated; returns false if and only if it is known that the Group information had not been changed since the last refresh. Note that since MPX does not currently broadcast any group-related events, isRefreshGroupsRequired() always returns true, even if MPX is enabled.
isRefreshTypesRequired | Returns true if a refreshTypes() operation might have resulted in Type or Property information being updated; returns false if and only if it is known that the Type information has not been changed since the last refresh. If MPX is not enabled, isRefreshTypesRequired() always returns true.
isRefreshUsersRequired | Returns true if a refreshUsers() operation might have resulted in User information being updated; returns false if and only if it is known that the User information had not been changed since the last refresh. If MPX is not enabled, then isRefreshUsersRequired() always returns true.
isTypeSupported
locateCacheAgent
logOn
logOnForWorkstation
logOnWithClientContext
MemberwiseClone
ping | Verifies that the server is responding and informs the server that this connection/user session is still active.
pingMPXServer | Throws an appropriate MPXException if the MPX server is not running properly.
reconnect | Overloaded. Attempts to re-establish the connection to the server, re-opening any existing view sessions. <p> Uses the user credentials provided at logon time.
refreshAccounts | Refreshes cached User and Group information. Existing User and Group objects are modified in place whenever possible.
refreshGroups | Refreshes cached Group information to reflect recent changes to the repository. Modifies existing Group objects in place whenever possible.
refreshTypes | Refreshes cached Type information to reflect recent changes to the repository. Existing Type and Property objects are modified in place, whenever possible. If MPX is enabled, refreshTypes() is optimized to avoid unnecessary server commands.
refreshTypesInPlace | Obsolete. Deprecated. Equivalent to refreshTypes().
refreshUsers | Refreshes cached User information to reflect recent changes to the repository. Modifies existing User objects in place whenever possible. If MPX is enabled, refreshUsers() is optimized to avoid unnecessary server commands.
removeMPXStatusListener | Removes a listener for MPXStatusEvents.
removeProjectListener | Removes a listener for Project events.
removeServerControlListener | Removes a listener for ServerControl events.
removeTypeListener | Removes a listener for Type events.
removeUserListener | Removes a listener for User events.
sendMailFromView
sendMailWithAttachments
setAutoReconnectAttempts
setAutoReconnectEnabled
setAutoReconnectWait
setCommandUserID
setForeignPassword | Sets a password for the foreign archive associated with this project.
setForeignPasswordExplicit
setKeepAlive
setKeepAliveInterval
setMPXCacheAgentEnabled | Obsolete.
ToString
typeForClassID
typeForName
useConnection

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.addMPXStatusListener Method

Adds a listener for MPXStatusEvents. <p> Event handlers will be tiggered whenever an important change occurs in the status of MPX or the MPX event transmitter.

public virtual void addMPXStatusListener(
MPXStatusListener listener
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.addProjectListener Method

Adds a listener for Project events. <p> Event handlers will be tiggered whenever a Project is added, changed or deleted on this Server. Note that an application will not receive events for Projects that the logged-in user does not have permission to access. <p> In order to handle events, an application must enable MPX.

public virtual void addProjectListener(
ProjectListener listener
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.addServerControlListener Method

Adds a listener for ServerControl events. <p> Event handlers will be tiggered whenever this Server is stopped or restarted. <p> In order to handle events, an application must enable MPX.

public virtual void addServerControlListener(
ServerControlListener listener
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.addTypeListener Method

Adds a listener for Type events. <p> Event handlers will be tiggered whenever a Type (or its associated Properties) are modified on this Server. <p> In order to handle events, an application must enable MPX.

public virtual void addTypeListener(
TypeListener listener
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.addUserListener Method

Adds a listener for User events. <p> Event handlers will be tiggered whenever a User is added, changed or deleted on this Server. <p> In order to handle events, an application must enable MPX.

public virtual void addUserListener(
UserListener listener
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.autoLocateCacheAgent Method

autoLocate a Cache Agent, return null if none found Attempts to autolocate can be expensive

public virtual CacheAgent autoLocateCacheAgent();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.autoLogOn Method

Log on to this server using credentials that have been cached on this workstation.

public virtual int autoLogOn();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.cacheLogOnCredentials Method

public virtual void cacheLogOnCredentials(
String username,
String password
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.changePassword Method

public virtual void changePassword(
String logOnName,
String password,
String newPassword
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.connect Method

Establishes a network connection to the remote server process. <p> If the network connection is successfully established, and an MPXProfileName was specified in the Server constructor, then an attempt is made to automatically enable MPX. If an MPXException is thrown, it will be ignored, and will not cause the connect() to fail. An application can use isMPXEnabled() to determine whether or not MPX was properly enabled.

public virtual void connect();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.disableMPX Method

Disables MPX, if it was enabled for this server.

public virtual void disableMPX();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.discardAccounts Method

Discards all cached User and Group information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void discardAccounts();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.discardGroups Method

Discards cached Group information. The next call to getGroups() will re-fetch the group information from the StarTeam Server.

public virtual void discardGroups();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.discardTypes Method

Discards all cached Type information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void discardTypes();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.discardUsers Method

Discards cached User information. The next call to getUsers() will re-fetch the user information from the StarTeam Server (even when MPX is enabled).

public virtual void discardUsers();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.disconnect Method

Terminates the network connection to the remote server process. The user will be logged off.

public virtual void disconnect();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.enableCredentialCaching Method

Enables credential caching on this workstation, if it is available and not already enabled. Currently, this starts the StarTeam Toolbar.

public static void enableCredentialCaching();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


enableMPX Method

Borland StarTeam SDK for .NET

Server.enableMPX Method

Enables MPX using the default client MPX profile.

Overload List

Enables MPX using the default client MPX profile.

public virtual void enableMPX();

Enables MPX using the given MPX profile.

public virtual void enableMPX(EventHandlerProfile);

public virtual void enableMPX(String);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.enableMPX Method ()

Enables MPX using the default client MPX profile.

public virtual void enableMPX();

See Also

Server Class | com.starbase.starteam Namespace | Server.enableMPX Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.enableMPX Method (EventHandlerProfile)

Enables MPX using the given MPX profile.

public virtual void enableMPX(
EventHandlerProfile profile
);

See Also

Server Class | com.starbase.starteam Namespace | Server.enableMPX Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.enableMPX Method (String)

public virtual void enableMPX(
String strProfileName
);

See Also

Server Class | com.starbase.starteam Namespace | Server.enableMPX Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.Equals Method

public override bool Equals(
Object object
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.fetchEmailUsers Method

This method issues a command to the server to return the list of users that are able to recieve email messages.

public virtual User[] fetchEmailUsers();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.findLinks Method

Returns an array of <code>Link</code> objects associated with this item.

public virtual Link[] findLinks(
Item item
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getActiveGroups Method

Returns all of the active (non-deleted) groups in this Server.

public virtual Group[] getActiveGroups();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getActiveUsers Method

Returns all of the active (non-deleted) users in this Server.

public virtual User[] getActiveUsers();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getAddress Method

Network address of this server.

public virtual string getAddress();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getAdministration Method

Returns the <code>ServerAdministration</code> object through which various administration operations can be performed on the server.

public virtual ServerAdministration getAdministration();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getAutoReconnectAttempts Method

If automatic reconnect is enabled, indicates the maximum number of attempts to reconnect that will be made while executing a single server command.

public virtual int getAutoReconnectAttempts();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getAutoReconnectWait Method

If automatic reconnect is enabled, indicates the number of seconds that we will wait before each reconnect attempt.

public virtual int getAutoReconnectWait();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getClientContext Method

Returns the ClientContext associated when logged in to the Server. This may return null if not logged in.

public virtual ClientContext getClientContext();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getCommandAPIRevisionLevel Method

Returns the command interface revision level (dot notation) supported by this server. Different releases of StarTeam will have different revision levels indicating changes in command syntax or semantics. The SDK client classes will insulate users from these changes when possible by being backwards compatible with older releases of the StarTeam Server.

public virtual string getCommandAPIRevisionLevel();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getCommandCount Method

Gets the number of commands sent to the StarTeam server since the connection was established. This method is useful for debugging performance related problems.

public virtual int getCommandCount();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getCurrentCacheAgent Method

returns the CacheAgent currently in use by this server, or null

public virtual CacheAgent getCurrentCacheAgent();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getCurrentMPXProfile Method

Gets the current MPX event handler profile.

public virtual EventHandlerProfile getCurrentMPXProfile();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getCurrentTime Method

Gets the current time on the server. Supported by StarTeam server versions 9.0 and later.

public virtual OLEDate getCurrentTime();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getEncryptionAlgorithm Method

Gets the level of encryption requested for the connection.

public virtual EncryptionAlgorithm getEncryptionAlgorithm();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getEventHandlerInfo Method

public virtual EventHandlerInfo getEventHandlerInfo(
String eventHandlerInfoName
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getEventHandlerInfoNames Method

Returns an array containing the names of all existing EventHandlerInfos on this server.

public virtual string[] getEventHandlerInfoNames();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getFilterList Method

public virtual Filter[] getFilterList(
Type type,
Boolean pub
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getForeignArchivePaths Method

public virtual string[] getForeignArchivePaths(
Int32 projectType,
String configFile
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getGroup Method

public virtual Group getGroup(
Int32 groupID
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getGroups Method

Returns all of the groups on this Server. This includes both active and deleted groups.

public virtual Group[] getGroups();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.GetHashCode Method

public override int GetHashCode();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getKeepAliveInterval Method

Gets the keep-alive interval, in minutes. When keep-alive is in effect, the keep-alive interval is the number of minutes between successive calls to ping().

public virtual int getKeepAliveInterval();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getMPXCacheAgentEnabled Method

NOTE: This method is now obsolete.

Indicates whether or not checkouts via the MPX cache agent are enabled. The cache agent is disabled by default.

public virtual bool getMPXCacheAgentEnabled();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getMPXMessageCount Method

Gets the number of MPX messages received by the server since MPX was enabled. Useful for debugging MPX related problems.

public virtual int getMPXMessageCount();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getMPXTransmitterName Method

The name of the event handler for the StarTeam MPX Transmitter. Pass this name to Server.getEventHandlerInfo() to get the event handler information for the MPX event transmitter. Pre-9.0 servers use the name "StarbaseMPX Transmitter" 9.0 servers use the name "StarTeamMPX Transmitter"

public virtual string getMPXTransmitterName();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getMyUserAccount Method

Returns the user account for the currently logged on user. Every user has permission to modify his own user account. <p> The user account information is not cached in the Server object; each call to getMyUserAccount() returns up-to-date information in a newly allocated MyUserAccount object. <p> getMyUserAccount() is not MPX-enabled; the account information is always retrieved directly from the repository.

public virtual MyUserAccount getMyUserAccount();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getPort Method

TCP/IP port on which to connect to the remote server.

public virtual int getPort();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getProductCodes Method

Gets the product codes licensed for this server. Will return an empty array if the server does not support that information or if a user has not yet logged in.

public virtual int[] getProductCodes();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getProjects Method

Gets the set of Projects accessible from this Server. <p> The project list is not cached in the Server object. Each call to getProjects() returns an up-to-date project list consisting of newly allocated Project objects. <p> If MPX is enabled, getProjects() is optimized to avoid unnecessary server commands.

public virtual Project[] getProjects();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getPropertyEnums Method

Returns the <code>PropertyEnums</code> object for this server. You must have already connected to the server or an IllegalStateException will be thrown.

public virtual PropertyEnums getPropertyEnums();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getPropertyNames Method

Returns the <code>PropertyNames</code> object for this server. You must have already connected to the server or an IllegalStateException will be thrown.

public virtual PropertyNames getPropertyNames();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getProtocol Method

Gets the protocol used to connect to the server.

public virtual int getProtocol();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getQueryList Method

public virtual QueryInfo[] getQueryList(
Type type,
Boolean pub
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getRepositoryID Method

Uniquely identifies the repository served by this server amongst all StarTeam repositories in the universe. Be warned that it is possible to take an existing StarTeam repository and re-host it on another machine in which case this unique ID is no longer unique.

public virtual GUID getRepositoryID();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getRequiredEncryptionLevel Method

Returns the level of security required to connect to the server.

public virtual EncryptionAlgorithm getRequiredEncryptionLevel();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getRevisionLevel Method

Returns the interface revision level supported by this server. Different releases of StarTeam will have different revision levels indicating changes in command syntax or semantics. The SDK client classes will insulate users from these changes when possible by being backwards compatible with older releases of the StarTeam Server.

public virtual short getRevisionLevel();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getServerBuild Method

Returns the server build number as reported by the server. Returns an empty string if this server object is not connected.

public virtual string getServerBuild();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getServerBuildDescription Method

Returns a server build description as reported by the server. Will return an empty string if this server object is not connected to the server.

public virtual string getServerBuildDescription();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getSession Method

Returns session information for the currently logged on user.

public virtual ServerSession getSession();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getSupportedFeatures Method

Gets an instance of the SupportedFeatures class that can tell which features are available for this StarTeam server. Will throw an exception if the client is not yest connected to the server.

public virtual SupportedFeatures getSupportedFeatures();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getTypeNames Method

Returns the <code>TypeNames</code> object for this server. You must have already connected to the server or an IllegalStateException will be thrown.

public virtual TypeNames getTypeNames();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getTypes Method

Returns an array of <code>Type</code> objects supported by this server.

public virtual Type[] getTypes();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getUser Method

public virtual User getUser(
Int32 userID
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.getUsers Method

Returns all of the users in this Server. This includes both active and deleted users.

public virtual User[] getUsers();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.handleEvents Method

Places the current thread in an event-handling state. <p> While in an event-handling state, the thread is usually asleep, waking occasionally just long enough to ping the server (keeping the connection alive). The event-handling loop continues until some other thread (presumably, the event-handling thread for this Server object) calls interruptHandleEvents(). <p> An application does not need to call handleEvents() in order to handle events; this is just a convenience method for applications that have nothing else they need to do while waiting for an event to occur. <p> Only one thread may call handleEvents() per Server object at any given time. After handleEvents() exits (as a result of a call to interruptHandleEvents), then handleEvents() may be called again by the same thread or by some other thread. <p> handleEvents() will fail if MPX is not enabled, or if there are no event-handlers running. <p> handleEvents() should not be called from within an event handler. (This would put the event-handling thread to sleep.)

public virtual void handleEvents();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.hasProductCode Method

public virtual bool hasProductCode(
Int32 code
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.hasProductCodeInformation Method

NOTE: This method is now obsolete.

Determines whether or not the licensed product codes are available from this server.

public virtual bool hasProductCodeInformation();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.interruptHandleEvents Method

Interrupts a handleEvents() loop, if there is one running. Usually called from within an event-handler, running in the event-handling thread for this Server object.

public virtual void interruptHandleEvents();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isAutoLogOnAvailable Method

Determines whether or not logon credentials for this server have been cached on this workstation. If so, then the auto logon feature may be used to logon using the cached credentials.

public virtual bool isAutoLogOnAvailable();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isAutoReconnectEnabled Method

Indicates whether or not a reconnect is automatically attempted whenever a connection problem is detected while executing a server command.

public virtual bool isAutoReconnectEnabled();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isCompressed Method

Determines whether or not the server connection is compressed.

public virtual bool isCompressed();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isConnected Method

Tells whether a network connection has been established to the server.

public virtual bool isConnected();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isCredentialCachingAvailable Method

Determines whether or not the credential caching feature is available on this workstation. Currently, credential caching is available only when the StarTeam toolbar is installed. Note that credential caching may be available, but not enabled.

public static bool isCredentialCachingAvailable();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isCredentialCachingEnabled Method

Determines whether or not credential caching is enabled on this workstation. Currently, credential caching is enabled only when the StarTeam toolbar is running.

public static bool isCredentialCachingEnabled();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isKeepAlive Method

Determines whether or not keep-alive mode is in effect.

public virtual bool isKeepAlive();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isLoggedOn Method

Returns true if someone has logged on through this server object.

public virtual bool isLoggedOn();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isMailAvailable Method

Determines whether or not the server supports email.

public virtual bool isMailAvailable();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isMPXAvailable Method

Determines whether or not MPX is installed on this server.

public virtual bool isMPXAvailable();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isMPXEnabled Method

Determines whether or not MPX has been enabled for this server.

public virtual bool isMPXEnabled();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isMPXResponding Method

Determines whether or not the MPX server is running properly.

public virtual bool isMPXResponding();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isRefreshAccountsRequired Method

Returns true if a refreshAccounts() operation might have resulted in User or Group information being updated; returns false if and only if it is known that the User and Group information had not been changed since the last refresh. Note that since MPX does not currently broadcast any group-related events, isRefreshAccountsRequired() always returns true, even if MPX is enabled.

public virtual bool isRefreshAccountsRequired();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isRefreshGroupsRequired Method

Returns true if a refreshGroups() operation might have resulting in Group information being updated; returns false if and only if it is known that the Group information had not been changed since the last refresh. Note that since MPX does not currently broadcast any group-related events, isRefreshGroupsRequired() always returns true, even if MPX is enabled.

public virtual bool isRefreshGroupsRequired();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isRefreshTypesRequired Method

Returns true if a refreshTypes() operation might have resulted in Type or Property information being updated; returns false if and only if it is known that the Type information has not been changed since the last refresh. If MPX is not enabled, isRefreshTypesRequired() always returns true.

public virtual bool isRefreshTypesRequired();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isRefreshUsersRequired Method

Returns true if a refreshUsers() operation might have resulted in User information being updated; returns false if and only if it is known that the User information had not been changed since the last refresh. If MPX is not enabled, then isRefreshUsersRequired() always returns true.

public virtual bool isRefreshUsersRequired();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.isTypeSupported Method

public virtual bool isTypeSupported(
String typeName
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.locateCacheAgent Method

public virtual CacheAgent locateCacheAgent(
String hostName,
Int32 port
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.logOn Method

public virtual int logOn(
String logOnName,
String password
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.logOnForWorkstation Method

public virtual int logOnForWorkstation(
String logOnName,
String password,
GUID workStationID
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.logOnWithClientContext Method

public virtual int logOnWithClientContext(
String logOnName,
String password,
ClientContext context
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.ping Method

Verifies that the server is responding and informs the server that this connection/user session is still active.

public virtual bool ping();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.pingMPXServer Method

Throws an appropriate MPXException if the MPX server is not running properly.

public virtual void pingMPXServer();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


reconnect Method

Borland StarTeam SDK for .NET

Server.reconnect Method

Attempts to re-establish the connection to the server, re-opening any existing view sessions. <p> Uses the user credentials provided at logon time.

Overload List

Attempts to re-establish the connection to the server, re-opening any existing view sessions. <p> Uses the user credentials provided at logon time.

public virtual void reconnect();

public virtual void reconnect(String);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.reconnect Method ()

Attempts to re-establish the connection to the server, re-opening any existing view sessions. <p> Uses the user credentials provided at logon time.

public virtual void reconnect();

See Also

Server Class | com.starbase.starteam Namespace | Server.reconnect Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.reconnect Method (String)

public virtual void reconnect(
String password
);

See Also

Server Class | com.starbase.starteam Namespace | Server.reconnect Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.refreshAccounts Method

Refreshes cached User and Group information. Existing User and Group objects are modified in place whenever possible.

public virtual void refreshAccounts();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.refreshGroups Method

Refreshes cached Group information to reflect recent changes to the repository. Modifies existing Group objects in place whenever possible.

public virtual void refreshGroups();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.refreshTypes Method

Refreshes cached Type information to reflect recent changes to the repository. Existing Type and Property objects are modified in place, whenever possible. If MPX is enabled, refreshTypes() is optimized to avoid unnecessary server commands.

public virtual void refreshTypes();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.refreshTypesInPlace Method

NOTE: This method is now obsolete.

Deprecated. Equivalent to refreshTypes().

public virtual void refreshTypesInPlace();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.refreshUsers Method

Refreshes cached User information to reflect recent changes to the repository. Modifies existing User objects in place whenever possible. If MPX is enabled, refreshUsers() is optimized to avoid unnecessary server commands.

public virtual void refreshUsers();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.removeMPXStatusListener Method

Removes a listener for MPXStatusEvents.

public virtual void removeMPXStatusListener(
MPXStatusListener listener
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.removeProjectListener Method

Removes a listener for Project events.

public virtual void removeProjectListener(
ProjectListener listener
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.removeServerControlListener Method

Removes a listener for ServerControl events.

public virtual void removeServerControlListener(
ServerControlListener listener
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.removeTypeListener Method

Removes a listener for Type events.

public virtual void removeTypeListener(
TypeListener listener
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.removeUserListener Method

Removes a listener for User events.

public virtual void removeUserListener(
UserListener listener
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.sendMailFromView Method

public virtual void sendMailFromView(
View view,
Int32[] to,
Int32[] cc,
Int32[] bcc,
String subject,
String body
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.sendMailWithAttachments Method

public virtual void sendMailWithAttachments(
View view,
Int32[] to,
Int32[] cc,
Int32[] bcc,
String subject,
String body,
EmailAttachment[] attachments
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.setAutoReconnectAttempts Method

public virtual void setAutoReconnectAttempts(
Int32 nAttempts
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.setAutoReconnectEnabled Method

public virtual void setAutoReconnectEnabled(
Boolean bEnabled
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.setAutoReconnectWait Method

public virtual void setAutoReconnectWait(
Int32 nSeconds
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.setCommandUserID Method

public virtual void setCommandUserID(
Int32 userID
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.setForeignPassword Method

Sets a password for the foreign archive associated with this project.

public virtual void setForeignPassword(
Project project
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.setForeignPasswordExplicit Method

public virtual void setForeignPasswordExplicit(
String configPath,
Int32 type,
String password
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.setKeepAlive Method

public virtual void setKeepAlive(
Boolean bKeepAlive
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.setKeepAliveInterval Method

public virtual void setKeepAliveInterval(
Int32 nMinutes
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.setMPXCacheAgentEnabled Method

NOTE: This method is now obsolete.

public virtual void setMPXCacheAgentEnabled(
Boolean bEnabled
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.ToString Method

public override string ToString();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.typeForClassID Method

public virtual Type typeForClassID(
Int32 classID
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.typeForName Method

public virtual Type typeForName(
String typeName
);

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Server.useConnection Method

public virtual Connection useConnection();

See Also

Server Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration Class

For a list of all members of this type, see ServerAdministration Members.

System.Object
ServerAdministration

public class ServerAdministration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerAdministration Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration Members

ServerAdministration overview

Public Static Fields

LOG_ALL |
LOG_ASSERTIONS |
LOG_EXCEPTIONS |
LOG_MESSAGES |
LOG_MODE_ALL | Obsolete.
LOG_MODE_ERRORS | Obsolete.
LOG_TYPE_PURGE |
LOG_TYPE_SERVER |
LOG_WARNINGS |
SERVER_LOCKED |
SERVER_LOCKED_EXCLUSIVELY |
SERVER_UNLOCKED |
UNKNOWN |

Public Instance Methods

addDoubleField |
addDoubleFieldEx |
addEnumeratedField |
addEnumeratedFieldEx |
addIntegerField |
addIntegerFieldEx |
addRequiredTextField |
addRequiredTextFieldEx |
addRequiredUserField |
addRequiredUserFieldEx |
addTextField |
addTextFieldEx |
addTimeField |
addTimeFieldEx |
addUserField |
addUserFieldEx |
discardAccounts | Discards all cached UserAccount and GroupAccount information. It will be re-fetched from the server on demand (even when MPX is enabled).
enableProperty |
Equals |
findGroupAccount |
findUserAccount |
generateDiagnosticDump |
getACL | Returns the Access control list for this server. This will return null if this server has not access control list.
getConfiguration | Gets the current server configuration options.
getGroupAccounts | Returns all of the active group accounts on the server. Deleted group accounts are not included.
GetHashCode |
getHiveManager | Gets the HiveManager that manages new vault format hives.
getLicenseInformation | Gets information about the licenses registered on this server.
getLicenseUsage | Obsolete. Returns a license usage report from the server.
getLog | Return the server log for this server.
getNamedConfigOptions |
getPolicy | Gets the current system policy options.
getPurgeControl | Provides control of the Online Purge service. The service may be configured to start automatically when the server starts up. If configured to do so, it will run a purge in the background while the server is running. This eliminates the requirement for costly down time just to purge the starteam repository. The online purge will not affect any resources deleted during the current active server session. Access the purge log by issuing a writeLogFile command with a logType value of 1.
getSecurityLog |
getServer | returns an instance of the Server
getServerCommandStats | Retrieves the server's command statistics and writes it to the specified output stream.
getServerLockStatus | Returns the "locked", "locked exclusively" or "unlocked" status of the server.
GetType (inherited from Object) | Gets the Type of the current instance.
getUserAccounts | Returns all of the active user accounts on the server. Deleted user accounts are not included.
hasPermission |
isRefreshAccountsRequired | Returns true if a refreshAccounts() operation might have resulting in UserAccount or GroupAccount information being updated; returns false if and only if it is known that the UserAccount and GroupAccount information had not been changed since the last refresh. Note that since MPX does not currently broadcast any UserAccount-related or Group-related events, isRefreshAccountsRequired() always returns true, even if MPX is enabled.
lockServer | Puts the server in "Locked" mode. No one can perform operations. Useful for freezing server for database backups.
lockServerExclusively | Puts the server in "LockedExclusively" mode: only the locker can perform operations. Useful for restricting server access during replication operations.
MemberwiseClone |
modifyDoubleField |
modifyDoubleFieldEx |
modifyEnumeratedField |
modifyEnumeratedFieldEx | Obsolete.
modifyIntegerField |
modifyIntegerFieldEx |
modifyTextField |
modifyTextFieldEx |
modifyTimeField |
modifyTimeFieldEx |
modifyUserField |
modifyUserFieldEx |
populateAccounts | Obsolete. Deprecated. Caches UserAccount and GroupAccount information, if it hasn't already been cached. Account information is cached on demand; use getUserAccounts() or getGroupAccounts().
refreshAccounts | Updates cached UserAccount and GroupAccount information to reflect recent changes to the repository. Existing UserAccount and GroupAccount objects are modified in place whenever possible.
restartServer | Shuts down and restarts the server. This has the side-effect of making the associated <code>Server</code> instance rather useless as the StarTeam Server it was connected to will be shut down and restarted.
setACL |
setConfiguration | Saves the given server configuration options.
setFieldRequired |
setNamedConfigOptions | Overloaded.
setPolicy | Saves the given system policy options.
shutdownServer | Shuts down the server. This has the obvious side-effect of making the associated <code>Server</code> instance rather useless, as the StarTeam Server it was connected to will be shut down.
testDirectoryServiceSettings |
ToString |
unlockServer | Unlocks a server in "Locked" mode.
updateEnumeratedField |
updateLicenseUsage | Obsolete.
writeLogFile |
writeServerCommandStats | Retrieves the server's command statistics and writes it to the specified file.

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration Fields

The fields of the ServerAdministration class are listed below. For a complete list of ServerAdministration class members, see the ServerAdministration Members topic.

Public Static Fields

LOG_ALL |
LOG_ASSERTIONS |
LOG_EXCEPTIONS |
LOG_MESSAGES |
LOG_MODE_ALL | Obsolete.
LOG_MODE_ERRORS | Obsolete.
LOG_TYPE_PURGE |
LOG_TYPE_SERVER |
LOG_WARNINGS |
SERVER_LOCKED |
SERVER_LOCKED_EXCLUSIVELY |
SERVER_UNLOCKED |
UNKNOWN |

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.LOG_ALL Field

public const Int32 LOG_ALL = 65535;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.LOG_ASSERTIONS Field

public const Int32 LOG_ASSERTIONS = 4104;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.LOG_EXCEPTIONS Field

public const Int32 LOG_EXCEPTIONS = 4100;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.LOG_MESSAGES Field

public const Int32 LOG_MESSAGES = 4097;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.LOG_MODE_ALL Field

NOTE: This field is now obsolete.

public const Int32 LOG_MODE_ALL = 0;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.LOG_MODE_ERRORS Field

NOTE: This field is now obsolete.

public const Int32 LOG_MODE_ERRORS = 1;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.LOG_TYPE_PURGE Field

public const Int32 LOG_TYPE_PURGE = 1;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.LOG_TYPE_SERVER Field

public const Int32 LOG_TYPE_SERVER = 0;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.LOG_WARNINGS Field

public const Int32 LOG_WARNINGS = 4098;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.SERVER_LOCKED Field

public const Int32 SERVER_LOCKED = 1;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.SERVER_LOCKED_EXCLUSIVELY Field

public const Int32 SERVER_LOCKED_EXCLUSIVELY = 3;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.SERVER_UNLOCKED Field

public const Int32 SERVER_UNLOCKED = 2;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.UNKNOWN Field

public const Int32 UNKNOWN = -1;

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration Methods

The methods of the ServerAdministration class are listed below. For a complete list of ServerAdministration class members, see the ServerAdministration Members topic.

Public Instance Methods

addDoubleField |
addDoubleFieldEx |
addEnumeratedField |
addEnumeratedFieldEx |
addIntegerField |
addIntegerFieldEx |
addRequiredTextField |
addRequiredTextFieldEx |
addRequiredUserField |
addRequiredUserFieldEx |
addTextField |
addTextFieldEx |
addTimeField |
addTimeFieldEx |
addUserField |
addUserFieldEx |
discardAccounts | Discards all cached UserAccount and GroupAccount information. It will be re-fetched from the server on demand (even when MPX is enabled).
enableProperty |
Equals |
findGroupAccount |
findUserAccount |
generateDiagnosticDump |
getACL | Returns the Access control list for this server. This will return null if this server has not access control list.
getConfiguration | Gets the current server configuration options.
getGroupAccounts | Returns all of the active group accounts on the server. Deleted group accounts are not included.
GetHashCode |
getHiveManager | Gets the HiveManager that manages new vault format hives.
getLicenseInformation | Gets information about the licenses registered on this server.
getLicenseUsage | Obsolete. Returns a license usage report from the server.
getLog | Return the server log for this server.
getNamedConfigOptions |
getPolicy | Gets the current system policy options.
getPurgeControl | Provides control of the Online Purge service. The service may be configured to start automatically when the server starts up. If configured to do so, it will run a purge in the background while the server is running. This eliminates the requirement for costly down time just to purge the starteam repository. The online purge will not affect any resources deleted during the current active server session. Access the purge log by issuing a writeLogFile command with a logType value of 1.
getSecurityLog |
getServer | returns an instance of the Server
getServerCommandStats | Retrieves the server's command statistics and writes it to the specified output stream.
getServerLockStatus | Returns the "locked", "locked exclusively" or "unlocked" status of the server.
GetType (inherited from Object) | Gets the Type of the current instance.
getUserAccounts | Returns all of the active user accounts on the server. Deleted user accounts are not included.
hasPermission |
isRefreshAccountsRequired | Returns true if a refreshAccounts() operation might have resulting in UserAccount or GroupAccount information being updated; returns false if and only if it is known that the UserAccount and GroupAccount information had not been changed since the last refresh. Note that since MPX does not currently broadcast any UserAccount-related or Group-related events, isRefreshAccountsRequired() always returns true, even if MPX is enabled.
lockServer | Puts the server in "Locked" mode. No one can perform operations. Useful for freezing server for database backups.
lockServerExclusively | Puts the server in "LockedExclusively" mode: only the locker can perform operations. Useful for restricting server access during replication operations.
MemberwiseClone |
modifyDoubleField |
modifyDoubleFieldEx |
modifyEnumeratedField |
modifyEnumeratedFieldEx | Obsolete.
modifyIntegerField |
modifyIntegerFieldEx |
modifyTextField |
modifyTextFieldEx |
modifyTimeField |
modifyTimeFieldEx |
modifyUserField |
modifyUserFieldEx |
populateAccounts | Obsolete. Deprecated. Caches UserAccount and GroupAccount information, if it hasn't already been cached. Account information is cached on demand; use getUserAccounts() or getGroupAccounts().
refreshAccounts | Updates cached UserAccount and GroupAccount information to reflect recent changes to the repository. Existing UserAccount and GroupAccount objects are modified in place whenever possible.
restartServer | Shuts down and restarts the server. This has the side-effect of making the associated <code>Server</code> instance rather useless as the StarTeam Server it was connected to will be shut down and restarted.
setACL |
setConfiguration | Saves the given server configuration options.
setFieldRequired |
setNamedConfigOptions | Overloaded.
setPolicy | Saves the given system policy options.
shutdownServer | Shuts down the server. This has the obvious side-effect of making the associated <code>Server</code> instance rather useless, as the StarTeam Server it was connected to will be shut down.
testDirectoryServiceSettings |
ToString |
unlockServer | Unlocks a server in "Locked" mode.
updateEnumeratedField |
updateLicenseUsage | Obsolete.
writeLogFile |
writeServerCommandStats | Retrieves the server's command statistics and writes it to the specified file.

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addDoubleField Method

public virtual void addDoubleField(
Type type,
String sqlname,
String displayName,
Double defaultValue
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addDoubleFieldEx Method

public virtual void addDoubleFieldEx(
Type type,
String sqlname,
Translations displayNames,
Double defaultValue
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addEnumeratedField Method

public virtual void addEnumeratedField(
Type type,
String sqlname,
String displayName,
EnumeratedValue[] enums,
Int32 defaultCode
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addEnumeratedFieldEx Method

public virtual void addEnumeratedFieldEx(
Type type,
String sqlname,
Translations displayNames,
EnumeratedValue[] enums,
Int32 defaultCode
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addIntegerField Method

public virtual void addIntegerField(
Type type,
String sqlname,
String displayName,
Int32 defaultValue
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addIntegerFieldEx Method

public virtual void addIntegerFieldEx(
Type type,
String sqlname,
Translations displayNames,
Int32 defaultValue
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addRequiredTextField Method

public virtual void addRequiredTextField(
Type type,
String sqlname,
String displayName,
Int32 maxLength
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addRequiredTextFieldEx Method

public virtual void addRequiredTextFieldEx(
Type type,
String sqlname,
Translations displayNames,
Int32 maxLength
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addRequiredUserField Method

public virtual void addRequiredUserField(
Type type,
String sqlname,
String displayName
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addRequiredUserFieldEx Method

public virtual void addRequiredUserFieldEx(
Type type,
String sqlname,
Translations displayNames
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addTextField Method

public virtual void addTextField(
Type type,
String sqlname,
String displayName,
Int32 maxLength
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addTextFieldEx Method

public virtual void addTextFieldEx(
Type type,
String sqlname,
Translations displayNames,
Int32 maxLength
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addTimeField Method

public virtual void addTimeField(
Type type,
String sqlname,
String displayName,
OLEDate defaultTime
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addTimeFieldEx Method

public virtual void addTimeFieldEx(
Type type,
String sqlname,
Translations displayNames,
OLEDate defaultTime
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addUserField Method

public virtual void addUserField(
Type type,
String sqlname,
String displayName
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.addUserFieldEx Method

public virtual void addUserFieldEx(
Type type,
String sqlname,
Translations displayNames
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.discardAccounts Method

Discards all cached UserAccount and GroupAccount information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void discardAccounts();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.enableProperty Method

public virtual void enableProperty(
Property prop,
Boolean enabled
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.Equals Method

public override bool Equals(
Object source
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.findGroupAccount Method

public virtual GroupAccount findGroupAccount(
Int32 groupID
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.findUserAccount Method

public virtual UserAccount findUserAccount(
Int32 userID
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.generateDiagnosticDump Method

public virtual string generateDiagnosticDump(
Int32 minidumptype
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getACL Method

Returns the Access control list for this server. This will return null if this server has not access control list.

public virtual AclEntry[] getACL();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getConfiguration Method

Gets the current server configuration options.

public virtual ServerConfiguration getConfiguration();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getGroupAccounts Method

Returns all of the active group accounts on the server. Deleted group accounts are not included.

public virtual GroupAccount[] getGroupAccounts();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.GetHashCode Method

public override int GetHashCode();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getHiveManager Method

Gets the HiveManager that manages new vault format hives.

public virtual HiveManager getHiveManager();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getLicenseInformation Method

Gets information about the licenses registered on this server.

public virtual ServerLicenseInfo getLicenseInformation();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getLicenseUsage Method

NOTE: This method is now obsolete.

Returns a license usage report from the server.

public virtual LicenseUsage getLicenseUsage();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getLog Method

Return the server log for this server.

public virtual string getLog();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getNamedConfigOptions Method

public virtual string[] getNamedConfigOptions(
String[] names
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getPolicy Method

Gets the current system policy options.

public virtual SystemPolicy getPolicy();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getPurgeControl Method

Provides control of the Online Purge service. The service may be configured to start automatically when the server starts up. If configured to do so, it will run a purge in the background while the server is running. This eliminates the requirement for costly down time just to purge the starteam repository. The online purge will not affect any resources deleted during the current active server session. Access the purge log by issuing a writeLogFile command with a logType value of 1.

public virtual PurgeControl getPurgeControl();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getSecurityLog Method

public virtual SecurityLogEntry[] getSecurityLog(
Int32 eventType
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getServer Method

returns an instance of the Server

public virtual Server getServer();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getServerCommandStats Method

Retrieves the server's command statistics and writes it to the specified output stream.

public virtual void getServerCommandStats(
OutputStream out
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getServerLockStatus Method

Returns the "locked", "locked exclusively" or "unlocked" status of the server.

public virtual int getServerLockStatus();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.getUserAccounts Method

Returns all of the active user accounts on the server. Deleted user accounts are not included.

public virtual UserAccount[] getUserAccounts();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.hasPermission Method

public virtual bool hasPermission(
Int32 permissions
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.isRefreshAccountsRequired Method

Returns true if a refreshAccounts() operation might have resulting in UserAccount or GroupAccount information being updated; returns false if and only if it is known that the UserAccount and GroupAccount information had not been changed since the last refresh. Note that since MPX does not currently broadcast any UserAccount-related or Group-related events, isRefreshAccountsRequired() always returns true, even if MPX is enabled.

public virtual bool isRefreshAccountsRequired();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.lockServer Method

Puts the server in "Locked" mode. No one can perform operations. Useful for freezing server for database backups.

public virtual void lockServer();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.lockServerExclusively Method

Puts the server in "LockedExclusively" mode: only the locker can perform operations. Useful for restricting server access during replication operations.

public virtual void lockServerExclusively();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyDoubleField Method

public virtual void modifyDoubleField(
Type type,
Property prop,
Boolean enabled,
String name,
Double defaultValue
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyDoubleFieldEx Method

public virtual void modifyDoubleFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names,
Double defaultValue
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyEnumeratedField Method

public virtual void modifyEnumeratedField(
Type type,
Property prop,
Boolean enabled,
String name,
EnumeratedValue[] enums,
Int32 defaultCode
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyEnumeratedFieldEx Method

NOTE: This method is now obsolete.

public virtual void modifyEnumeratedFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names,
EnumeratedValue[] enums,
Int32 defaultCode
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyIntegerField Method

public virtual void modifyIntegerField(
Type type,
Property prop,
Boolean enabled,
String name,
Int32 defaultValue
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyIntegerFieldEx Method

public virtual void modifyIntegerFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names,
Int32 defaultValue
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyTextField Method

public virtual void modifyTextField(
Type type,
Property prop,
Boolean enabled,
String name
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyTextFieldEx Method

public virtual void modifyTextFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyTimeField Method

public virtual void modifyTimeField(
Type type,
Property prop,
Boolean enabled,
String name,
OLEDate defaultValue
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyTimeFieldEx Method

public virtual void modifyTimeFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names,
OLEDate defaultValue
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyUserField Method

public virtual void modifyUserField(
Type type,
Property prop,
Boolean enabled,
String name
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.modifyUserFieldEx Method

public virtual void modifyUserFieldEx(
Type type,
Property prop,
Boolean enabled,
Translations names
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.populateAccounts Method

NOTE: This method is now obsolete.

Deprecated. Caches UserAccount and GroupAccount information, if it hasn't already been cached. Account information is cached on demand; use getUserAccounts() or getGroupAccounts().

public virtual void populateAccounts();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.refreshAccounts Method

Updates cached UserAccount and GroupAccount information to reflect recent changes to the repository. Existing UserAccount and GroupAccount objects are modified in place whenever possible.

public virtual void refreshAccounts();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.restartServer Method

Shuts down and restarts the server. This has the side-effect of making the associated <code>Server</code> instance rather useless as the StarTeam Server it was connected to will be shut down and restarted.

public virtual void restartServer();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.setACL Method

public virtual void setACL(
AclEntry[] acl
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.setConfiguration Method

Saves the given server configuration options.

public virtual void setConfiguration(
ServerConfiguration config
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.setFieldRequired Method

public virtual void setFieldRequired(
Property prop,
Boolean bRequired
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setNamedConfigOptions Method

Borland StarTeam SDK for .NET

ServerAdministration.setNamedConfigOptions Method

Overload List

public virtual void setNamedConfigOptions(Hashtable);

public virtual void setNamedConfigOptions(String[],String[]);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.setNamedConfigOptions Method (Hashtable)

public virtual void setNamedConfigOptions(
Hashtable options
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace | ServerAdministration.setNamedConfigOptions Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.setNamedConfigOptions Method (String[], String[])

public virtual void setNamedConfigOptions(
String[] names,
String[] values
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace | ServerAdministration.setNamedConfigOptions Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.setPolicy Method

Saves the given system policy options.

public virtual void setPolicy(
SystemPolicy policy
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.shutdownServer Method

Shuts down the server. This has the obvious side-effect of making the associated <code>Server</code> instance rather useless, as the StarTeam Server it was connected to will be shut down.

public virtual void shutdownServer();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.testDirectoryServiceSettings Method

public virtual bool testDirectoryServiceSettings(
String URL,
Int32 port,
Boolean bUseSecureDirectoryService
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.ToString Method

public override string ToString();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.unlockServer Method

Unlocks a server in "Locked" mode.

public virtual void unlockServer();

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.updateEnumeratedField Method

public virtual void updateEnumeratedField(
Property prop,
Boolean enabled,
Translations names,
EnumeratedValue[] enums,
Int32 defaultCode
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.updateLicenseUsage Method

NOTE: This method is now obsolete.

public virtual void updateLicenseUsage(
String keys,
ServerInfo[] servers
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.writeLogFile Method

public virtual void writeLogFile(
File out,
Int32 logType,
Int32 logMode
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerAdministration.writeServerCommandStats Method

Retrieves the server's command statistics and writes it to the specified file.

public virtual void writeServerCommandStats(
File file
);

See Also

ServerAdministration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration Class

For a list of all members of this type, see ServerConfiguration Members.

System.Object
ServerConfiguration

public class ServerConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerConfiguration Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration Members

ServerConfiguration overview

Public Static Fields

DBTYPE_DB2
DBTYPE_INFORMIX
DBTYPE_MSACCESS
DBTYPE_ORACLE
DBTYPE_SQLSERVER
DBTYPE_SYBASE
DBTYPE_UNKNOWN
NOTIFICATION_TYPE_BOTH
NOTIFICATION_TYPE_EMAIL
NOTIFICATION_TYPE_SYSTRAY
PROTOCOL_IPX
PROTOCOL_LRPC
PROTOCOL_NAMED_PIPE
PROTOCOL_NETBIOS
PROTOCOL_TCP_IP_RPC
PROTOCOL_TCP_IP_SOCKETS
PROTOCOL_TCP_IP_SOCKETS_XML

Public Instance Constructors

ServerConfiguration Constructor construct a new ServerConfiguration from the source

Public Instance Methods

copy | return a copy of this ServerConfiguration instance
Equals |
getArchiveDirectory | Returns the path to the server's archive directory.
getAttachmentDirectory | Returns the path to the server's attachment directory.
getAuditsAutoPurgeDays | Returns the number of days after which audit information is purged from the server.
getAuditsEnabled | Indicates whether or not auditing is enabled on the server.
getCacheDirectory | Returns the path to the server's vault directory.
getCipher | Returns the server's cipher string.
getDBAutoRecovery | Indicates whether or not the server automatically recovers from errors. This property is supported by StarTeam 4.1 and later.
getDBDSN | Returns the server data source name.
getDBPooledConnections | Returns the number of pooled connections to the server database.
getDBTransactionsEnabled | Indicates whether or not database transactions are enabled.
getDBType | Returns the server database type.
getDBVerifyOnStartup | Indicates whether or not the server database is verified on startup. This property is supported by StarTeam 4.1 and later.
getDiagnosticStatisticsReportingInterval | Determines the frequency with which the server reports diagnostic statistics. <p> This setting is ignored by StarTeam server versions prior to 10.4.
getDirectoryServiceEnabled | Indicates whether Directory Service is enabled on this server. This property is supported by server release 6.0 and later; ignored for earlier releases.
getDirectoryServiceHost | Gets the URL to the Directory Service Host, if Directory Service is enabled. This property is supported by server release 6.0 and later; ignored for earlier releases.
getDirectoryServicePort | Gets the SSL port used by Directory Service, if Directory Service is enabled. This property is supported by server release 6.0 and later; ignored for earlier releases.
getDumpAsserts | Returns whether the server will create a diagnostic dump when unexpected conditions [i.e., asserts] are discovered.
getDumpErrors | Returns whether the server will create a diagnostic dump when errors are discovered.
getDumpType | Returns the mini dump type used for diagnostic dumps
getEnabled |
getEnableDiagnostics | Indicates whether or not server diagnostics are enabled.
getEncryptionRequirements | Returns the required encryption levels for various ranges of TCP/IP addresses.
getEndPoint |
getExpensiveOperationMinimum | Returns the minimum number of milliseconds used to determine what is an expensive operation for tracing purposes.
getFileStatusAutoPurgeDays | Returns the number of days after which a file's status information will be purged.
getForeignRefreshRate | Returns the rate at which files are refreshed from foreign archives.
GetHashCode |
getInactivityTimeout | Returns the server's inactivity timeout.
getLogFile | Returns the path to the server's log file.
getLogonTimeout | Returns the server's logon timeout.
getMailEnabled | Indicates whether or not email is enabled on the server.
getMultiPartDirectory | Returns the path to the server's multi-part directory.
getNotifyBy | Gets the method by which notification messages are sent to StarTeam users. This property is supported by StarTeam 4.2 and later.
getNoTimeoutNamedLicenses | Gets the server's "NoTimeoutNamedLicenses" setting for servers 7.0 and later.
getReconnectTimeout | Gets the server's reconnect timeout.
getRepositoryPath | Returns the path to the server's data repository.
getServerGUID | Returns the server's globally unique identifier.
getSMTPAddress | Gets the SMTP address of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
getSMTPPort | Gets the SMTP port of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
getStopServerOnErrors | Indicates whether or not the server automatically stops after an error. This property is supported by StarTeam 4.1 and later.
getTraceExpensiveOperations | Returns whether the server will trace expensive operations.
GetType (inherited from Object) | Gets the Type of the current instance.
getUsingSecureDirectoryService | Gets the server's "Using Secure Directory Service (LDAPS)" value for servers 7.0 and later. This property is supported by server release 7.0 and later; always false for earlier releases.
getVaultCacheMaxSize | Returns the server's vault cache size limit.
getVaultCacheRefreshInterval | Returns the server's vault cache refresh interval.
getVaultDirectory | Returns the path to the server's vault directory.
getVaultLockTimeLimit | Returns the server's vault lock time limit.
isAdvancedViewsDisabled | Returns whether the server is configured to disable advanced views.
isAtomicTransactionsDisabled | Returns whether the server is configured to disable atomic transactions.
isEnhancedProcessItemsEnabledForAllProjects | Determines whether or not the enhanced process item model is currently enabled for all projects on this server.
isEnhancedProcessItemsEnabledForNewProjects | Determines whether or not the enhanced process item model is in effect by default for new projects. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task. <p> This method requires StarTeam server version 9.3 or later.
isEqualTo | returns true if this object instance is equal to the source
isProtocolAvailable |
MemberwiseClone |
setAdvancedViewsDisabled |
setArchiveDirectory |
setAtomicTransactionsDisabled |
setAttachmentDirectory |
setAuditsAutoPurgeDays |
setAuditsEnabled |
setCacheDirectory |
setCipher |
setDBAutoRecovery |
setDBDSN |
setDBPooledConnections |
setDBTransactionsEnabled |
setDBType |
setDBVerifyOnStartup |
setDiagnosticStatisticsReportingInterval |
setDirectoryServiceEnabled |
setDirectoryServiceHost |
setDirectoryServicePort |
setDumpAsserts |
setDumpErrors |
setDumpType |
setEnabled |
setEnableDiagnostics |
setEncryptionRequirements |
setEndPoint |
setEnhancedProcessItemsEnabledForAllProjects |
setEnhancedProcessItemsEnabledForNewProjects |
setExpensiveOperationMinimum |
setFileStatusAutoPurgeDays |
setForeignRefreshRate |
setInactivityTimeout |
setLogFile |
setLogonTimeout |
setMailEnabled |
setMultiPartDirectory |
setNotifyBy |
setNoTimeoutNamedLicenses |
setReconnectTimeout |
setRepositoryPath |
setServerGUID |
setSMTPAddress |
setSMTPPort |
setStopServerOnErrors |
setTraceExpensiveOperations |
setUsingSecureDirectoryService |
setVaultCacheMaxSize |
setVaultCacheRefreshInterval |
setVaultDirectory |
setVaultLockTimeLimit |
ToString |

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration Constructor

construct a new ServerConfiguration from the source

public ServerConfiguration(
ServerConfiguration source
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration Fields

The fields of the ServerConfiguration class are listed below. For a complete list of ServerConfiguration class members, see the ServerConfiguration Members topic.

Public Static Fields

DBTYPE_DB2
DBTYPE_INFORMIX
DBTYPE_MSACCESS
DBTYPE_ORACLE
DBTYPE_SQLSERVER
DBTYPE_SYBASE
DBTYPE_UNKNOWN
NOTIFICATION_TYPE_BOTH
NOTIFICATION_TYPE_EMAIL
NOTIFICATION_TYPE_SYSTRAY
PROTOCOL_IPX
PROTOCOL_LRPC
PROTOCOL_NAMED_PIPE
PROTOCOL_NETBIOS
PROTOCOL_TCP_IP_RPC
PROTOCOL_TCP_IP_SOCKETS
PROTOCOL_TCP_IP_SOCKETS_XML

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.DBTYPE_DB2 Field

public const Int32 DBTYPE_DB2 = 6;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.DBTYPE_INFORMIX Field

public const Int32 DBTYPE_INFORMIX = 5;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.DBTYPE_MSACCESS Field

public const Int32 DBTYPE_MSACCESS = 1;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.DBTYPE_ORACLE Field

public const Int32 DBTYPE_ORACLE = 3;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.DBTYPE_SQLSERVER Field

public const Int32 DBTYPE_SQLSERVER = 2;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.DBTYPE_SYBASE Field

public const Int32 DBTYPE_SYBASE = 4;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.DBTYPE_UNKNOWN Field

public const Int32 DBTYPE_UNKNOWN = 0;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.NOTIFICATION_TYPE_BOTH Field

public const Int32 NOTIFICATION_TYPE_BOTH = 3;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.NOTIFICATION_TYPE_EMAIL Field

public const Int32 NOTIFICATION_TYPE_EMAIL = 2;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.NOTIFICATION_TYPE_SYSTRAY Field

public const Int32 NOTIFICATION_TYPE_SYSTRAY = 1;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.PROTOCOL_IPX Field

public const Int32 PROTOCOL_IPX = 3;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.PROTOCOL_LRPC Field

public const Int32 PROTOCOL_LRPC = 1;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.PROTOCOL_NAMED_PIPE Field

public const Int32 PROTOCOL_NAMED_PIPE = 4;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.PROTOCOL_NETBIOS Field

public const Int32 PROTOCOL_NETBIOS = 2;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.PROTOCOL_TCP_IP_RPC Field

public const Int32 PROTOCOL_TCP_IP_RPC = 5;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.PROTOCOL_TCP_IP_SOCKETS Field

public const Int32 PROTOCOL_TCP_IP_SOCKETS = 6;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.PROTOCOL_TCP_IP_SOCKETS_XML Field

public const Int32 PROTOCOL_TCP_IP_SOCKETS_XML = 7;

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration Methods

The methods of the ServerConfiguration class are listed below. For a complete list of ServerConfiguration class members, see the ServerConfiguration Members topic.

Public Instance Methods

copy | return a copy of this ServerConfiguration instance
Equals |
getArchiveDirectory | Returns the path to the server's archive directory.
getAttachmentDirectory | Returns the path to the server's attachment directory.
getAuditsAutoPurgeDays | Returns the number of days after which audit information is purged from the server.
getAuditsEnabled | Indicates whether or not auditing is enabled on the server.
getCacheDirectory | Returns the path to the server's vault directory.
getCipher | Returns the server's cipher string.
getDBAutoRecovery | Indicates whether or not the server automatically recovers from errors. This property is supported by StarTeam 4.1 and later.
getDBDSN | Returns the server data source name.
getDBPooledConnections | Returns the number of pooled connections to the server database.
getDBTransactionsEnabled | Indicates whether or not database transactions are enabled.
getDBType | Returns the server database type.
getDBVerifyOnStartup | Indicates whether or not the server database is verified on startup. This property is supported by StarTeam 4.1 and later.
getDiagnosticStatisticsReportingInterval | Determines the frequency with which the server reports diagnostic statistics. <p> This setting is ignored by StarTeam server versions prior to 10.4.
getDirectoryServiceEnabled | Indicates whether Directory Service is enabled on this server. This property is supported by server release 6.0 and later; ignored for earlier releases.
getDirectoryServiceHost | Gets the URL to the Directory Service Host, if Directory Service is enabled. This property is supported by server release 6.0 and later; ignored for earlier releases.
getDirectoryServicePort | Gets the SSL port used by Directory Service, if Directory Service is enabled. This property is supported by server release 6.0 and later; ignored for earlier releases.
getDumpAsserts | Returns whether the server will create a diagnostic dump when unexpected conditions [i.e., asserts] are discovered.
getDumpErrors | Returns whether the server will create a diagnostic dump when errors are discovered.
getDumpType | Returns the mini dump type used for diagnostic dumps
getEnabled |
getEnableDiagnostics | Indicates whether or not server diagnostics are enabled.
getEncryptionRequirements | Returns the required encryption levels for various ranges of TCP/IP addresses.
getEndPoint |
getExpensiveOperationMinimum | Returns the minimum number of milliseconds used to determine what is an expensive operation for tracing purposes.
getFileStatusAutoPurgeDays | Returns the number of days after which a file's status information will be purged.
getForeignRefreshRate | Returns the rate at which files are refreshed from foreign archives.
GetHashCode |
getInactivityTimeout | Returns the server's inactivity timeout.
getLogFile | Returns the path to the server's log file.
getLogonTimeout | Returns the server's logon timeout.
getMailEnabled | Indicates whether or not email is enabled on the server.
getMultiPartDirectory | Returns the path to the server's multi-part directory.
getNotifyBy | Gets the method by which notification messages are sent to StarTeam users. This property is supported by StarTeam 4.2 and later.
getNoTimeoutNamedLicenses | Gets the server's "NoTimeoutNamedLicenses" setting for servers 7.0 and later.
getReconnectTimeout | Gets the server's reconnect timeout.
getRepositoryPath | Returns the path to the server's data repository.
getServerGUID | Returns the server's globally unique identifier.
getSMTPAddress | Gets the SMTP address of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
getSMTPPort | Gets the SMTP port of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
getStopServerOnErrors | Indicates whether or not the server automatically stops after an error. This property is supported by StarTeam 4.1 and later.
getTraceExpensiveOperations | Returns whether the server will trace expensive operations.
GetType (inherited from Object) | Gets the Type of the current instance.
getUsingSecureDirectoryService | Gets the server's "Using Secure Directory Service (LDAPS)" value for servers 7.0 and later. This property is supported by server release 7.0 and later; always false for earlier releases.
getVaultCacheMaxSize | Returns the server's vault cache size limit.
getVaultCacheRefreshInterval | Returns the server's vault cache refresh interval.
getVaultDirectory | Returns the path to the server's vault directory.
getVaultLockTimeLimit | Returns the server's vault lock time limit.
isAdvancedViewsDisabled | Returns whether the server is configured to disable advanced views.
isAtomicTransactionsDisabled | Returns whether the server is configured to disable atomic transactions.
isEnhancedProcessItemsEnabledForAllProjects | Determines whether or not the enhanced process item model is currently enabled for all projects on this server.
isEnhancedProcessItemsEnabledForNewProjects | Determines whether or not the enhanced process item model is in effect by default for new projects. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task. <p> This method requires StarTeam server version 9.3 or later.
isEqualTo | returns true if this object instance is equal to the source
isProtocolAvailable |
MemberwiseClone |
setAdvancedViewsDisabled |
setArchiveDirectory |
setAtomicTransactionsDisabled |
setAttachmentDirectory |
setAuditsAutoPurgeDays |
setAuditsEnabled |
setCacheDirectory |
setCipher |
setDBAutoRecovery |
setDBDSN |
setDBPooledConnections |
setDBTransactionsEnabled |
setDBType |
setDBVerifyOnStartup |
setDiagnosticStatisticsReportingInterval |
setDirectoryServiceEnabled |
setDirectoryServiceHost |
setDirectoryServicePort |
setDumpAsserts |
setDumpErrors |
setDumpType |
setEnabled |
setEnableDiagnostics |
setEncryptionRequirements |
setEndPoint |
setEnhancedProcessItemsEnabledForAllProjects |
setEnhancedProcessItemsEnabledForNewProjects |
setExpensiveOperationMinimum |
setFileStatusAutoPurgeDays |
setForeignRefreshRate |
setInactivityTimeout |
setLogFile |
setLogonTimeout |
setMailEnabled |
setMultiPartDirectory |
setNotifyBy |
setNoTimeoutNamedLicenses |
setReconnectTimeout |
setRepositoryPath |
setServerGUID |
setSMTPAddress |
setSMTPPort |
setStopServerOnErrors |
setTraceExpensiveOperations |
setUsingSecureDirectoryService |
setVaultCacheMaxSize |
setVaultCacheRefreshInterval |
setVaultDirectory |
setVaultLockTimeLimit |
ToString |

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.copy Method

return a copy of this ServerConfiguration instance

public virtual ServerConfiguration copy();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.Equals Method

public override bool Equals(
Object source
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getArchiveDirectory Method

Returns the path to the server's archive directory.

public virtual string getArchiveDirectory();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getAttachmentDirectory Method

Returns the path to the server's attachment directory.

public virtual string getAttachmentDirectory();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getAuditsAutoPurgeDays Method

Returns the number of days after which audit information is purged from the server.

public virtual int getAuditsAutoPurgeDays();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getAuditsEnabled Method

Indicates whether or not auditing is enabled on the server.

public virtual bool getAuditsEnabled();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getCacheDirectory Method

Returns the path to the server's vault directory.

public virtual string getCacheDirectory();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getCipher Method

Returns the server's cipher string.

public virtual string getCipher();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDBAutoRecovery Method

Indicates whether or not the server automatically recovers from errors. This property is supported by StarTeam 4.1 and later.

public virtual bool getDBAutoRecovery();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDBDSN Method

Returns the server data source name.

public virtual string getDBDSN();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDBPooledConnections Method

Returns the number of pooled connections to the server database.

public virtual int getDBPooledConnections();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDBTransactionsEnabled Method

Indicates whether or not database transactions are enabled.

public virtual bool getDBTransactionsEnabled();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDBType Method

Returns the server database type.

public virtual int getDBType();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDBVerifyOnStartup Method

Indicates whether or not the server database is verified on startup. This property is supported by StarTeam 4.1 and later.

public virtual bool getDBVerifyOnStartup();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDiagnosticStatisticsReportingInterval Method

Determines the frequency with which the server reports diagnostic statistics. <p> This setting is ignored by StarTeam server versions prior to 10.4.

public virtual int getDiagnosticStatisticsReportingInterval();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDirectoryServiceEnabled Method

Indicates whether Directory Service is enabled on this server. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual bool getDirectoryServiceEnabled();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDirectoryServiceHost Method

Gets the URL to the Directory Service Host, if Directory Service is enabled. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual string getDirectoryServiceHost();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDirectoryServicePort Method

Gets the SSL port used by Directory Service, if Directory Service is enabled. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual int getDirectoryServicePort();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDumpAsserts Method

Returns whether the server will create a diagnostic dump when unexpected conditions [i.e., asserts] are discovered.

public virtual bool getDumpAsserts();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDumpErrors Method

Returns whether the server will create a diagnostic dump when errors are discovered.

public virtual bool getDumpErrors();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getDumpType Method

Returns the mini dump type used for diagnostic dumps

public virtual int getDumpType();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getEnabled Method

public virtual bool getEnabled(
Int32 protocol
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getEnableDiagnostics Method

Indicates whether or not server diagnostics are enabled.

public virtual bool getEnableDiagnostics();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getEncryptionRequirements Method

Returns the required encryption levels for various ranges of TCP/IP addresses.

public virtual IPRange[] getEncryptionRequirements();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getEndPoint Method

public virtual string getEndPoint(
Int32 protocol
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getExpensiveOperationMinimum Method

Returns the minimum number of milliseconds used to determine what is an expensive operation for tracing purposes.

public virtual int getExpensiveOperationMinimum();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getFileStatusAutoPurgeDays Method

Returns the number of days after which a file's status information will be purged.

public virtual int getFileStatusAutoPurgeDays();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getForeignRefreshRate Method

Returns the rate at which files are refreshed from foreign archives.

public virtual int getForeignRefreshRate();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.GetHashCode Method

public override int GetHashCode();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getInactivityTimeout Method

Returns the server's inactivity timeout.

public virtual int getInactivityTimeout();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getLogFile Method

Returns the path to the server's log file.

public virtual string getLogFile();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getLogonTimeout Method

Returns the server's logon timeout.

public virtual int getLogonTimeout();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getMailEnabled Method

Indicates whether or not email is enabled on the server.

public virtual bool getMailEnabled();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getMultiPartDirectory Method

Returns the path to the server's multi-part directory.

public virtual string getMultiPartDirectory();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getNotifyBy Method

Gets the method by which notification messages are sent to StarTeam users. This property is supported by StarTeam 4.2 and later.

public virtual int getNotifyBy();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getNoTimeoutNamedLicenses Method

Gets the server's "NoTimeoutNamedLicenses" setting for servers 7.0 and later.

public virtual bool getNoTimeoutNamedLicenses();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getReconnectTimeout Method

Gets the server's reconnect timeout.

public virtual int getReconnectTimeout();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getRepositoryPath Method

Returns the path to the server's data repository.

public virtual string getRepositoryPath();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getServerGUID Method

Returns the server's globally unique identifier.

public virtual string getServerGUID();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getSMTPAddress Method

Gets the SMTP address of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.

public virtual string getSMTPAddress();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getSMTPPort Method

Gets the SMTP port of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.

public virtual int getSMTPPort();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getStopServerOnErrors Method

Indicates whether or not the server automatically stops after an error. This property is supported by StarTeam 4.1 and later.

public virtual bool getStopServerOnErrors();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getTraceExpensiveOperations Method

Returns whether the server will trace expensive operations.

public virtual bool getTraceExpensiveOperations();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getUsingSecureDirectoryService Method

Gets the server's "Using Secure Directory Service (LDAPS)" value for servers 7.0 and later. This property is supported by server release 7.0 and later; always false for earlier releases.

public virtual bool getUsingSecureDirectoryService();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getVaultCacheMaxSize Method

Returns the server's vault cache size limit.

public virtual int getVaultCacheMaxSize();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getVaultCacheRefreshInterval Method

Returns the server's vault cache refresh interval.

public virtual int getVaultCacheRefreshInterval();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getVaultDirectory Method

Returns the path to the server's vault directory.

public virtual string getVaultDirectory();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.getVaultLockTimeLimit Method

Returns the server's vault lock time limit.

public virtual int getVaultLockTimeLimit();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.isAdvancedViewsDisabled Method

Returns whether the server is configured to disable advanced views.

public virtual bool isAdvancedViewsDisabled();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.isAtomicTransactionsDisabled Method

Returns whether the server is configured to disable atomic transactions.

public virtual bool isAtomicTransactionsDisabled();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.isEnhancedProcessItemsEnabledForAllProjects Method

Determines whether or not the enhanced process item model is currently enabled for all projects on this server.

public virtual bool isEnhancedProcessItemsEnabledForAllProjects();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.isEnhancedProcessItemsEnabledForNewProjects Method

Determines whether or not the enhanced process item model is in effect by default for new projects. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task. <p> This method requires StarTeam server version 9.3 or later.

public virtual bool isEnhancedProcessItemsEnabledForNewProjects();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.isEqualTo Method

returns true if this object instance is equal to the source

public virtual bool isEqualTo(
ServerConfiguration source
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.isProtocolAvailable Method

public virtual bool isProtocolAvailable(
Int32 protocol
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setAdvancedViewsDisabled Method

public virtual void setAdvancedViewsDisabled(
Boolean bDisabled
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setArchiveDirectory Method

public virtual void setArchiveDirectory(
String directory
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setAtomicTransactionsDisabled Method

public virtual void setAtomicTransactionsDisabled(
Boolean bDisabled
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setAttachmentDirectory Method

public virtual void setAttachmentDirectory(
String directory
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setAuditsAutoPurgeDays Method

public virtual void setAuditsAutoPurgeDays(
Int32 days
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setAuditsEnabled Method

public virtual void setAuditsEnabled(
Boolean enable
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setCacheDirectory Method

public virtual void setCacheDirectory(
String directory
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setCipher Method

public virtual void setCipher(
String cipher
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDBAutoRecovery Method

public virtual void setDBAutoRecovery(
Boolean recover
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDBDSN Method

public virtual void setDBDSN(
String dsn
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDBPooledConnections Method

public virtual void setDBPooledConnections(
Int32 connections
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDBTransactionsEnabled Method

public virtual void setDBTransactionsEnabled(
Boolean enabled
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDBType Method

public virtual void setDBType(
Int32 type
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDBVerifyOnStartup Method

public virtual void setDBVerifyOnStartup(
Boolean verify
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDiagnosticStatisticsReportingInterval Method

public virtual void setDiagnosticStatisticsReportingInterval(
Int32 nSeconds
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDirectoryServiceEnabled Method

public virtual void setDirectoryServiceEnabled(
Boolean bEnable
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDirectoryServiceHost Method

public virtual void setDirectoryServiceHost(
String host
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDirectoryServicePort Method

public virtual void setDirectoryServicePort(
Int32 port
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDumpAsserts Method

public virtual void setDumpAsserts(
Boolean bDump
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDumpErrors Method

public virtual void setDumpErrors(
Boolean bDump
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setDumpType Method

public virtual void setDumpType(
Int32 miniDumpType
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setEnabled Method

public virtual void setEnabled(
Int32 protocol,
Boolean enabled
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setEnableDiagnostics Method

public virtual void setEnableDiagnostics(
Boolean enable
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setEncryptionRequirements Method

public virtual void setEncryptionRequirements(
IPRange[] ranges
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setEndPoint Method

public virtual void setEndPoint(
Int32 protocol,
String endpoint
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setEnhancedProcessItemsEnabledForAllProjects Method

public virtual void setEnhancedProcessItemsEnabledForAllProjects(
Boolean bEnabled
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setEnhancedProcessItemsEnabledForNewProjects Method

public virtual void setEnhancedProcessItemsEnabledForNewProjects(
Boolean isEnabled
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setExpensiveOperationMinimum Method

public virtual void setExpensiveOperationMinimum(
Int32 milliseconds
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setFileStatusAutoPurgeDays Method

public virtual void setFileStatusAutoPurgeDays(
Int32 days
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setForeignRefreshRate Method

public virtual void setForeignRefreshRate(
Int32 rate
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setInactivityTimeout Method

public virtual void setInactivityTimeout(
Int32 seconds
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setLogFile Method

public virtual void setLogFile(
String systemLog
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setLogonTimeout Method

public virtual void setLogonTimeout(
Int32 seconds
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setMailEnabled Method

public virtual void setMailEnabled(
Boolean enable
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setMultiPartDirectory Method

public virtual void setMultiPartDirectory(
String directory
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setNotifyBy Method

public virtual void setNotifyBy(
Int32 method
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setNoTimeoutNamedLicenses Method

public virtual void setNoTimeoutNamedLicenses(
Boolean enable
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setReconnectTimeout Method

public virtual void setReconnectTimeout(
Int32 seconds
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setRepositoryPath Method

public virtual void setRepositoryPath(
String path
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setServerGUID Method

public virtual void setServerGUID(
String guid
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setSMTPAddress Method

public virtual void setSMTPAddress(
String address
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setSMTPPort Method

public virtual void setSMTPPort(
Int32 port
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setStopServerOnErrors Method

public virtual void setStopServerOnErrors(
Boolean stop
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setTraceExpensiveOperations Method

public virtual void setTraceExpensiveOperations(
Boolean bTrace
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setUsingSecureDirectoryService Method

public virtual void setUsingSecureDirectoryService(
Boolean useSecureDirectoryService
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setVaultCacheMaxSize Method

public virtual void setVaultCacheMaxSize(
Int32 megs
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setVaultCacheRefreshInterval Method

public virtual void setVaultCacheRefreshInterval(
Int32 seconds
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setVaultDirectory Method

public virtual void setVaultDirectory(
String directory
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.setVaultLockTimeLimit Method

public virtual void setVaultLockTimeLimit(
Int32 seconds
);

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerConfiguration.ToString Method

public override string ToString();

See Also

ServerConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlAdapter Class

For a list of all members of this type, see ServerControlAdapter Members.

System.Object
ServerControlAdapter

public class ServerControlAdapter : ServerControlListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerControlAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlAdapter Members

ServerControlAdapter overview

Public Instance Constructors

ServerControlAdapter Constructor Initializes a new instance of the ServerControlAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
serverStarted |
serverStopped |
ToString |

See Also

ServerControlAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlAdapter Constructor

Initializes a new instance of the ServerControlAdapter class.

public ServerControlAdapter();

See Also

ServerControlAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlAdapter Methods

The methods of the ServerControlAdapter class are listed below. For a complete list of ServerControlAdapter class members, see the ServerControlAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
serverStarted |
serverStopped |
ToString |

See Also

ServerControlAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ServerControlAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlAdapter.serverStarted Method

public override void serverStarted(
ServerControlEvent e
);

Implements

ServerControlListener.serverStarted

See Also

ServerControlAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlAdapter.serverStopped Method

public override void serverStopped(
ServerControlEvent e
);

Implements

ServerControlListener.serverStopped

See Also

ServerControlAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlAdapter.ToString Method

public override string ToString();

See Also

ServerControlAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlEvent Class

For a list of all members of this type, see ServerControlEvent Members.

System.Object
EventObject
ServerControlEvent

public class ServerControlEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerControlEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlEvent Members

ServerControlEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getServer | Gets the Server object whose status has changed. <p> Returns the same physical Server object used to register the ServerControlListener. There is no way to listen for start or stop events for arbitrary servers on the network; you must explicitly login to the server of interest and register a listener.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ServerControlEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlEvent Methods

The methods of the ServerControlEvent class are listed below. For a complete list of ServerControlEvent class members, see the ServerControlEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getServer | Gets the Server object whose status has changed. <p> Returns the same physical Server object used to register the ServerControlListener. There is no way to listen for start or stop events for arbitrary servers on the network; you must explicitly login to the server of interest and register a listener.
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ServerControlEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlEvent.Equals Method

public override bool Equals(
Object source
);

See Also

ServerControlEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlEvent.GetHashCode Method

public override int GetHashCode();

See Also

ServerControlEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlEvent.getServer Method

Gets the Server object whose status has changed. <p> Returns the same physical Server object used to register the ServerControlListener. There is no way to listen for start or stop events for arbitrary servers on the network; you must explicitly login to the server of interest and register a listener.

public virtual Server getServer();

See Also

ServerControlEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlEvent.getSource Method

public override object getSource();

See Also

ServerControlEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ServerControlEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlEvent.ToString Method

public override string ToString();

See Also

ServerControlEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlListener Interface

For a list of all members of this type, see ServerControlListener Members.

public interface ServerControlListener : EventListener

Types that implement ServerControlListener

Type | Description
ServerControlAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerControlListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlListener Members

ServerControlListener overview

Public Instance Methods

serverStarted | Invoked when a Server is restarted.
serverStopped | Invoked when a Server is stopped.

See Also

ServerControlListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlListener Methods

The methods of the ServerControlListener interface are listed below. For a complete list of ServerControlListener interface members, see the ServerControlListener Members topic.

Public Instance Methods

serverStarted | Invoked when a Server is restarted.
serverStopped | Invoked when a Server is stopped.

See Also

ServerControlListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlListener.serverStarted Method

Invoked when a Server is restarted.

void serverStarted(
ServerControlEvent e
);

See Also

ServerControlListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerControlListener.serverStopped Method

Invoked when a Server is stopped.

void serverStopped(
ServerControlEvent e
);

See Also

ServerControlListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException Class

For a list of all members of this type, see ServerException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
ServerException
CommandAbortedException
ForeignPasswordException
ItemNotFoundException
LogonException
ServerUnavailableException

public class ServerException : RuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException Members

ServerException overview

Public Static Methods

forError
wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData |
getAuxKeys |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName |
getErrorCode |
getErrorMessage |
getErrorSource |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry |
getMessage |
getNonLocalizedMessage |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged |
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage |
ToString |
unwrap |

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException Methods

The methods of the ServerException class are listed below. For a complete list of ServerException class members, see the ServerException Members topic.

Public Static Methods

forError
wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData |
getAuxKeys |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName |
getErrorCode |
getErrorMessage |
getErrorSource |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry |
getMessage |
getNonLocalizedMessage |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged |
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage |
ToString |
unwrap |

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.Equals Method

public override bool Equals(
Object source
);

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.forError Method

public static ServerException forError(
Server server,
String className,
String errorSource,
Int32 errorCode,
String errorMessage,
Boolean logged,
Double loggedTime,
Int32 logEntry,
Hashtable auxiliaryData
);

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.getAuxData Method

public virtual object getAuxData(
String key
);

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.getAuxKeys Method

public virtual string[] getAuxKeys();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.getClassName Method

public virtual string getClassName();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.getErrorCode Method

public virtual int getErrorCode();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.getErrorMessage Method

public virtual string getErrorMessage();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.getErrorSource Method

public virtual string getErrorSource();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.GetHashCode Method

public override int GetHashCode();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.getLogEntry Method

public virtual int getLogEntry();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.getMessage Method

public override string getMessage();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.getNonLocalizedMessage Method

public virtual string getNonLocalizedMessage();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.getTimeLogged Method

public virtual OLEDate getTimeLogged();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.isLogged Method

public virtual bool isLogged();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.setErrorMessage Method

public virtual void setErrorMessage(
String errorMessage
);

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.ToString Method

public override string ToString();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.unwrap Method

public virtual ServerException unwrap();

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerException.wrap Method

public static ServerException wrap(
ServerException arg
);

See Also

ServerException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo Class

For a list of all members of this type, see ServerInfo Members.

System.Object
ServerInfo

public class ServerInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerInfo Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo Members

ServerInfo overview

Public Instance Constructors

ServerInfo Overloaded. Initializes a new instance of the ServerInfo class.

Public Instance Methods

copy | return a copy of this ServerInfo
Equals |
getAlwaysEnableCacheAgentForObjectProperties | returns true to fetch object properties from a cache agent false to fetch all properties from the star team server
getAutoLocateCacheAgent | Indicates whether or not the best cache agent for this connection will be located automatically.
getConnectionType | Returns the connection type to be used.
getDescription | Returns the description for this server info entry.
getEnableCacheAgentForFileContent | returns true if a cache agent should be used for file content checkout false to force all checkouts to use the StarTeam server directly.
getEnableCacheAgentForObjectProperties | returns true to fetch object properties from a cache agent false to fetch all properties from the star team server
getEncryption | Returns the encryption algorithm to use for connections to the server.
getEndpoint | Obsolete. Returns the protocol endpoint for the server info. For example, this should be an IP port number if the protocol is "TCP/IP Sockets".
GetHashCode |
getHost | Returns the host name for the server info.
getMPXCacheAgentAddress | Gets the host address of the MPX cache agent.
getMPXCacheAgentPort | Gets the port number of the MPX cache agent.
getMPXCacheAgentThreadCount | Gets the number of threads used by the MPX cache agent to fetch file content.
getMPXProfileName | Gets the name of the MPX profile to be used when connecting to this server.
getOwner | Return the owning ServerList. May return null.
getPort | Returns the protocol endpoint for the server info. For example, this should be an IP port number if the protocol is "TCP/IP Sockets".
GetType (inherited from Object) | Gets the Type of the current instance.
isCompression | Returns true if compression is to be used when communicating with the server.
isEqualTo | returns true if this object instance is equal to the source
MemberwiseClone |
setAlwaysEnableCacheAgentForObjectProperties |
setAutoLocateCacheAgent |
setCompression |
setConnectionType |
setDescription |
setEnableCacheAgentForFileContent |
setEnableCacheAgentForObjectProperties |
setEncryption | Sets the encryption algorithm to use for conenctions to the server.
setEndpoint | Obsolete.
setHost |
setMPXCacheAgentAddress |
setMPXCacheAgentPort |
setMPXCacheAgentThreadCount |
setMPXProfileName |
setPort |
toDebugString | Returns a debug string representation of this server info.
ToString |

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo Constructor

Construct a ServerInfo instance

Overload List

Construct a ServerInfo instance

public ServerInfo();

Create a copy of a ServerInfo from another one

public ServerInfo(ServerInfo);

Obsolete.

public ServerInfo(String,Int32,String,String,Boolean,EncryptionAlgorithm);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo Constructor ()

Construct a ServerInfo instance

public ServerInfo();

See Also

ServerInfo Class | com.starbase.starteam Namespace | ServerInfo Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo Constructor (ServerInfo)

Create a copy of a ServerInfo from another one

public ServerInfo(
ServerInfo source
);

See Also

ServerInfo Class | com.starbase.starteam Namespace | ServerInfo Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo Constructor (String, Int32, String, String, Boolean, EncryptionAlgorithm)

NOTE: This constructor is now obsolete.

public ServerInfo(
String description,
Int32 connectionType,
String host,
String endpoint,
Boolean compression,
EncryptionAlgorithm encryption
);

See Also

ServerInfo Class | com.starbase.starteam Namespace | ServerInfo Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo Methods

The methods of the ServerInfo class are listed below. For a complete list of ServerInfo class members, see the ServerInfo Members topic.

Public Instance Methods

copy | return a copy of this ServerInfo
Equals |
getAlwaysEnableCacheAgentForObjectProperties | returns true to fetch object properties from a cache agent false to fetch all properties from the star team server
getAutoLocateCacheAgent | Indicates whether or not the best cache agent for this connection will be located automatically.
getConnectionType | Returns the connection type to be used.
getDescription | Returns the description for this server info entry.
getEnableCacheAgentForFileContent | returns true if a cache agent should be used for file content checkout false to force all checkouts to use the StarTeam server directly.
getEnableCacheAgentForObjectProperties | returns true to fetch object properties from a cache agent false to fetch all properties from the star team server
getEncryption | Returns the encryption algorithm to use for connections to the server.
getEndpoint | Obsolete. Returns the protocol endpoint for the server info. For example, this should be an IP port number if the protocol is "TCP/IP Sockets".
GetHashCode |
getHost | Returns the host name for the server info.
getMPXCacheAgentAddress | Gets the host address of the MPX cache agent.
getMPXCacheAgentPort | Gets the port number of the MPX cache agent.
getMPXCacheAgentThreadCount | Gets the number of threads used by the MPX cache agent to fetch file content.
getMPXProfileName | Gets the name of the MPX profile to be used when connecting to this server.
getOwner | Return the owning ServerList. May return null.
getPort | Returns the protocol endpoint for the server info. For example, this should be an IP port number if the protocol is "TCP/IP Sockets".
GetType (inherited from Object) | Gets the Type of the current instance.
isCompression | Returns true if compression is to be used when communicating with the server.
isEqualTo | returns true if this object instance is equal to the source
MemberwiseClone |
setAlwaysEnableCacheAgentForObjectProperties |
setAutoLocateCacheAgent |
setCompression |
setConnectionType |
setDescription |
setEnableCacheAgentForFileContent |
setEnableCacheAgentForObjectProperties |
setEncryption | Sets the encryption algorithm to use for conenctions to the server.
setEndpoint | Obsolete.
setHost |
setMPXCacheAgentAddress |
setMPXCacheAgentPort |
setMPXCacheAgentThreadCount |
setMPXProfileName |
setPort |
toDebugString | Returns a debug string representation of this server info.
ToString |

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.copy Method

return a copy of this ServerInfo

public virtual ServerInfo copy();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.Equals Method

public override bool Equals(
Object source
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getAlwaysEnableCacheAgentForObjectProperties Method

returns true to fetch object properties from a cache agent false to fetch all properties from the star team server

public virtual bool getAlwaysEnableCacheAgentForObjectProperties();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getAutoLocateCacheAgent Method

Indicates whether or not the best cache agent for this connection will be located automatically.

public virtual bool getAutoLocateCacheAgent();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getConnectionType Method

Returns the connection type to be used.

public virtual int getConnectionType();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getDescription Method

Returns the description for this server info entry.

public virtual string getDescription();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getEnableCacheAgentForFileContent Method

returns true if a cache agent should be used for file content checkout false to force all checkouts to use the StarTeam server directly.

public virtual bool getEnableCacheAgentForFileContent();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getEnableCacheAgentForObjectProperties Method

returns true to fetch object properties from a cache agent false to fetch all properties from the star team server

public virtual bool getEnableCacheAgentForObjectProperties();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getEncryption Method

Returns the encryption algorithm to use for connections to the server.

public virtual EncryptionAlgorithm getEncryption();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getEndpoint Method

NOTE: This method is now obsolete.

Returns the protocol endpoint for the server info. For example, this should be an IP port number if the protocol is "TCP/IP Sockets".

public virtual string getEndpoint();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.GetHashCode Method

public override int GetHashCode();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getHost Method

Returns the host name for the server info.

public virtual string getHost();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getMPXCacheAgentAddress Method

Gets the host address of the MPX cache agent.

public virtual string getMPXCacheAgentAddress();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getMPXCacheAgentPort Method

Gets the port number of the MPX cache agent.

public virtual int getMPXCacheAgentPort();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getMPXCacheAgentThreadCount Method

Gets the number of threads used by the MPX cache agent to fetch file content.

public virtual int getMPXCacheAgentThreadCount();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getMPXProfileName Method

Gets the name of the MPX profile to be used when connecting to this server.

public virtual string getMPXProfileName();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getOwner Method

Return the owning ServerList. May return null.

public virtual ServerList getOwner();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.getPort Method

Returns the protocol endpoint for the server info. For example, this should be an IP port number if the protocol is "TCP/IP Sockets".

public virtual int getPort();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.isCompression Method

Returns true if compression is to be used when communicating with the server.

public virtual bool isCompression();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.isEqualTo Method

returns true if this object instance is equal to the source

public virtual bool isEqualTo(
ServerInfo source
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setAlwaysEnableCacheAgentForObjectProperties Method

public virtual void setAlwaysEnableCacheAgentForObjectProperties(
Boolean enableCacheAgent
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setAutoLocateCacheAgent Method

public virtual void setAutoLocateCacheAgent(
Boolean autoLocateCacheAgent
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setCompression Method

public virtual void setCompression(
Boolean compress
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setConnectionType Method

public virtual void setConnectionType(
Int32 type
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setDescription Method

public virtual void setDescription(
String description
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setEnableCacheAgentForFileContent Method

public virtual void setEnableCacheAgentForFileContent(
Boolean EnableCacheAgent
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setEnableCacheAgentForObjectProperties Method

public virtual void setEnableCacheAgentForObjectProperties(
Boolean EnableCacheAgent
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setEncryption Method

Sets the encryption algorithm to use for conenctions to the server.

public virtual void setEncryption(
EncryptionAlgorithm encryption
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setEndpoint Method

NOTE: This method is now obsolete.

public virtual void setEndpoint(
String endpoint
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setHost Method

public virtual void setHost(
String host
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setMPXCacheAgentAddress Method

public virtual void setMPXCacheAgentAddress(
String address
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setMPXCacheAgentPort Method

public virtual void setMPXCacheAgentPort(
Int32 port
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setMPXCacheAgentThreadCount Method

public virtual void setMPXCacheAgentThreadCount(
Int32 nThreads
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setMPXProfileName Method

public virtual void setMPXProfileName(
String strName
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.setPort Method

public virtual void setPort(
Int32 port
);

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.toDebugString Method

Returns a debug string representation of this server info.

public virtual string toDebugString();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerInfo.ToString Method

public override string ToString();

See Also

ServerInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo Class

For a list of all members of this type, see ServerLicenseInfo Members.

System.Object
ServerLicenseInfo

public class ServerLicenseInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerLicenseInfo Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo Members

ServerLicenseInfo overview

Public Instance Methods

Equals |
getAvailableFixedLicenses | Gets the number of fixed (named-user) licenses currently available on the server.
getAvailableFloatingLicenses | Gets the number of floating (concurrent) licenses currently available on the server.
getBLSLicenses | Gets the licenses managed by the Borland License Server.
getBLSSlipGUIDs | Gets the Slip IDs of the licenses managed by the Borland License Server.
GetHashCode |
getNumUsersForBLSLicense |
getTotalFixedLicenses | Gets the total number of fixed (named-user) licenses registered on the server.
getTotalFloatingLicenses | Gets the total number of floating (concurrent) licenses registered on the server.
GetType (inherited from Object) | Gets the Type of the current instance.
getUnassignedLicenseUsers | Gets the number of users without an assigned license on the server.
MemberwiseClone |
ToString |

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo Methods

The methods of the ServerLicenseInfo class are listed below. For a complete list of ServerLicenseInfo class members, see the ServerLicenseInfo Members topic.

Public Instance Methods

Equals |
getAvailableFixedLicenses | Gets the number of fixed (named-user) licenses currently available on the server.
getAvailableFloatingLicenses | Gets the number of floating (concurrent) licenses currently available on the server.
getBLSLicenses | Gets the licenses managed by the Borland License Server.
getBLSSlipGUIDs | Gets the Slip IDs of the licenses managed by the Borland License Server.
GetHashCode |
getNumUsersForBLSLicense |
getTotalFixedLicenses | Gets the total number of fixed (named-user) licenses registered on the server.
getTotalFloatingLicenses | Gets the total number of floating (concurrent) licenses registered on the server.
GetType (inherited from Object) | Gets the Type of the current instance.
getUnassignedLicenseUsers | Gets the number of users without an assigned license on the server.
MemberwiseClone |
ToString |

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.Equals Method

public override bool Equals(
Object source
);

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.getAvailableFixedLicenses Method

Gets the number of fixed (named-user) licenses currently available on the server.

public virtual int getAvailableFixedLicenses();

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.getAvailableFloatingLicenses Method

Gets the number of floating (concurrent) licenses currently available on the server.

public virtual int getAvailableFloatingLicenses();

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.getBLSLicenses Method

Gets the licenses managed by the Borland License Server.

public virtual BLSLicenseInfo[] getBLSLicenses();

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.getBLSSlipGUIDs Method

Gets the Slip IDs of the licenses managed by the Borland License Server.

public virtual int[] getBLSSlipGUIDs();

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.GetHashCode Method

public override int GetHashCode();

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.getNumUsersForBLSLicense Method

public virtual int getNumUsersForBLSLicense(
Int32 slipGuid
);

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.getTotalFixedLicenses Method

Gets the total number of fixed (named-user) licenses registered on the server.

public virtual int getTotalFixedLicenses();

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.getTotalFloatingLicenses Method

Gets the total number of floating (concurrent) licenses registered on the server.

public virtual int getTotalFloatingLicenses();

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.getUnassignedLicenseUsers Method

Gets the number of users without an assigned license on the server.

public virtual int getUnassignedLicenseUsers();

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerLicenseInfo.ToString Method

public override string ToString();

See Also

ServerLicenseInfo Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList Class

For a list of all members of this type, see ServerList Members.

System.Object
ServerList

public class ServerList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerList Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList Members

ServerList overview

Public Static Methods

getDefaultFile

Public Instance Constructors

ServerList Constructor Initializes a new instance of the ServerList class.

Public Instance Methods

addServer | Adds the specified ServerInfo to this ServerList. An instance of a ServerInfo object can belong to only one ServerList. The server info will be added in alphabetical order (using case insensitive comparision).
contains | Returns true if the specified server info is a member of this server list.
descriptionExists |
Equals |
find |
GetHashCode |
getServers | Returns all the servers in the server list.
getSocketBasedServers | Returns the servers in the server list that use the "TCP/IP Sockets" or "XML over TCP/IP" protocols. These are the only two protocols currently supported by the SDK.
GetType (inherited from Object) | Gets the Type of the current instance.
loadFrom | Loads the server list from the specified file. This will throw an exception if there are any problems reading the file or if the file is not a properly formatted server list file.
MemberwiseClone |
removeAll | Remove all the servers from the list.
removeServer | Removes the specified server info from the server list.
saveTo | Writes the server list out to the specified file.
ToString |

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList Constructor

Initializes a new instance of the ServerList class.

public ServerList();

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList Methods

The methods of the ServerList class are listed below. For a complete list of ServerList class members, see the ServerList Members topic.

Public Static Methods

getDefaultFile

Public Instance Methods

addServer | Adds the specified ServerInfo to this ServerList. An instance of a ServerInfo object can belong to only one ServerList. The server info will be added in alphabetical order (using case insensitive comparision).
contains | Returns true if the specified server info is a member of this server list.
descriptionExists |
Equals |
find |
GetHashCode |
getServers | Returns all the servers in the server list.
getSocketBasedServers | Returns the servers in the server list that use the "TCP/IP Sockets" or "XML over TCP/IP" protocols. These are the only two protocols currently supported by the SDK.
GetType (inherited from Object) | Gets the Type of the current instance.
loadFrom | Loads the server list from the specified file. This will throw an exception if there are any problems reading the file or if the file is not a properly formatted server list file.
MemberwiseClone |
removeAll | Remove all the servers from the list.
removeServer | Removes the specified server info from the server list.
saveTo | Writes the server list out to the specified file.
ToString |

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.addServer Method

Adds the specified ServerInfo to this ServerList. An instance of a ServerInfo object can belong to only one ServerList. The server info will be added in alphabetical order (using case insensitive comparision).

public virtual void addServer(
ServerInfo info
);

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.contains Method

Returns true if the specified server info is a member of this server list.

public virtual bool contains(
ServerInfo info
);

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.descriptionExists Method

public virtual bool descriptionExists(
String description
);

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.Equals Method

public override bool Equals(
Object source
);

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.find Method

public virtual ServerInfo find(
String description
);

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.getDefaultFile Method

public static File getDefaultFile();

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.GetHashCode Method

public override int GetHashCode();

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.getServers Method

Returns all the servers in the server list.

public virtual ServerInfo[] getServers();

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.getSocketBasedServers Method

Returns the servers in the server list that use the "TCP/IP Sockets" or "XML over TCP/IP" protocols. These are the only two protocols currently supported by the SDK.

public virtual ServerInfo[] getSocketBasedServers();

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.loadFrom Method

Loads the server list from the specified file. This will throw an exception if there are any problems reading the file or if the file is not a properly formatted server list file.

public virtual void loadFrom(
File file
);

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.removeAll Method

Remove all the servers from the list.

public virtual void removeAll();

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.removeServer Method

Removes the specified server info from the server list.

public virtual void removeServer(
ServerInfo info
);

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.saveTo Method

Writes the server list out to the specified file.

public virtual void saveTo(
File file
);

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerList.ToString Method

public override string ToString();

See Also

ServerList Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerSession Interface

For a list of all members of this type, see ServerSession Members.

public interface ServerSession

Types that implement ServerSession

Type | Description
ServerSessionAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerSession Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerSession Members

ServerSession overview

Public Instance Methods

getID | Returns the session identifier.
getUserID | Returns the user ID for the logged in to this session.

See Also

ServerSession Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerSession Methods

The methods of the ServerSession interface are listed below. For a complete list of ServerSession interface members, see the ServerSession Members topic.

Public Instance Methods

getID | Returns the session identifier.
getUserID | Returns the user ID for the logged in to this session.

See Also

ServerSession Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerSession.getID Method

Returns the session identifier.

GUID getID();

See Also

ServerSession Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerSession.getUserID Method

Returns the user ID for the logged in to this session.

int getUserID();

See Also

ServerSession Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerUnavailableException Class

For a list of all members of this type, see ServerUnavailableException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
ServerException
ServerUnavailableException

public class ServerUnavailableException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerUnavailableException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerUnavailableException Members

ServerUnavailableException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |

See Also

ServerUnavailableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerUnavailableException Methods

The methods of the ServerUnavailableException class are listed below. For a complete list of ServerUnavailableException class members, see the ServerUnavailableException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
getAuxData (inherited from ServerException) |
getAuxKeys (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
getClassName (inherited from ServerException) |
getErrorCode (inherited from ServerException) |
getErrorMessage (inherited from ServerException) |
getErrorSource (inherited from ServerException) |
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getLogEntry (inherited from ServerException) |
getMessage |
getNonLocalizedMessage (inherited from ServerException) |
GetObjectData (inherited from java.lang.Throwable) |
getTimeLogged (inherited from ServerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isLogged (inherited from ServerException) |
MemberwiseClone (inherited from ServerException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
setErrorMessage (inherited from ServerException) |
ToString (inherited from ServerException) |
unwrap (inherited from ServerException) |

See Also

ServerUnavailableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerUnavailableException.Equals Method

public override bool Equals(
Object source
);

See Also

ServerUnavailableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerUnavailableException.GetHashCode Method

public override int GetHashCode();

See Also

ServerUnavailableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerUnavailableException.getMessage Method

public override string getMessage();

See Also

ServerUnavailableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerUnavailableException.wrap Method

public static ServerUnavailableException wrap(
ServerUnavailableException arg
);

See Also

ServerUnavailableException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword Class

For a list of all members of this type, see SimpleKeyword Members.

System.Object
SimpleKeyword
HistoryKeyword
LogKeyword
NoKeywords

public class SimpleKeyword : Keyword

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SimpleKeyword Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword Members

SimpleKeyword overview

Public Instance Constructors

SimpleKeyword Constructor

Public Instance Methods

Equals |
expand |
GetHashCode |
getName |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue |
matches |
MemberwiseClone |
multiLine |
stopExpanding |
ToString |
toXMLString |

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword Constructor

public SimpleKeyword(
String name,
String value
);

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword Methods

The methods of the SimpleKeyword class are listed below. For a complete list of SimpleKeyword class members, see the SimpleKeyword Members topic.

Public Instance Methods

Equals |
expand |
GetHashCode |
getName |
GetType (inherited from Object) | Gets the Type of the current instance.
getValue |
matches |
MemberwiseClone |
multiLine |
stopExpanding |
ToString |
toXMLString |

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword.Equals Method

public override bool Equals(
Object source
);

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword.expand Method

public virtual string expand(
String linePrefix,
String eol,
Boolean expand
);

Implements

Keyword.expand

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword.GetHashCode Method

public override int GetHashCode();

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword.getName Method

public virtual string getName();

Implements

Keyword.getName

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword.getValue Method

public virtual string getValue();

Implements

Keyword.getValue

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword.matches Method

public virtual bool matches(
String line,
Int32 start,
Int32[] endPos
);

Implements

Keyword.matches

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword.MemberwiseClone Method

public override object MemberwiseClone();

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword.multiLine Method

public virtual bool multiLine();

Implements

Keyword.multiLine

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword.stopExpanding Method

public virtual bool stopExpanding();

Implements

Keyword.stopExpanding

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword.ToString Method

public override string ToString();

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleKeyword.toXMLString Method

public virtual string toXMLString();

Implements

Keyword.toXMLString

See Also

SimpleKeyword Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource Class

For a list of all members of this type, see SimpleTypedResource Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Derived types

public class SimpleTypedResource : TypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SimpleTypedResource Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource Members

SimpleTypedResource overview

Public Instance Constructors

SimpleTypedResource Constructor Create a new SimpleTypedResource based on a Type.

Public Instance Methods

addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get |
getByteArray |
getDouble |
getEnumDisplayName |
GetHashCode |
getID | Return the identifier for the resource object.
getInt |
getIntArray |
getOLEDate |
getPossibleValues |
getPropertyNames |
getString |
getType |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames |
MemberwiseClone (inherited from CacheRef) |
put |
putByPropertyID |
removeFromIntArray (inherited from TypedResource) |
ToString (inherited from TypedResource) |

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource Constructor

Create a new SimpleTypedResource based on a Type.

public SimpleTypedResource(
Type type
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource Methods

The methods of the SimpleTypedResource class are listed below. For a complete list of SimpleTypedResource class members, see the SimpleTypedResource Members topic.

Public Instance Methods

addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get |
getByteArray |
getDouble |
getEnumDisplayName |
GetHashCode |
getID | Return the identifier for the resource object.
getInt |
getIntArray |
getOLEDate |
getPossibleValues |
getPropertyNames |
getString |
getType |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames |
MemberwiseClone (inherited from CacheRef) |
put |
putByPropertyID |
removeFromIntArray (inherited from TypedResource) |
ToString (inherited from TypedResource) |

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.Equals Method

public override bool Equals(
Object source
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.get Method

public override object get(
String propertyName
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getByteArray Method

public override sbyte[] getByteArray(
String propertyName
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getDouble Method

public override double getDouble(
String propertyName
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getEnumDisplayName Method

public override string getEnumDisplayName(
String propertyName,
Int32 value
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.GetHashCode Method

public override int GetHashCode();

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getID Method

Return the identifier for the resource object.

public virtual int getID();

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getInt Method

public override int getInt(
String propertyName
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getIntArray Method

public override int[] getIntArray(
String propertyName
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getOLEDate Method

public override OLEDate getOLEDate(
String propertyName
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getPossibleValues Method

public override int[] getPossibleValues(
String propertyName
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getPropertyNames Method

public override PropertyNames getPropertyNames();

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getString Method

public override string getString(
String propertyName
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getType Method

public override Type getType();

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.getTypeNames Method

public override TypeNames getTypeNames();

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.put Method

public override object put(
String propertyName,
Object value
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource.putByPropertyID Method

public virtual object putByPropertyID(
Int32 propertyID,
Object value
);

See Also

SimpleTypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions Class

For a list of all members of this type, see StarTeamClientOptions Members.

System.Object
StarTeamClientOptions

public class StarTeamClientOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

StarTeamClientOptions Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions Members

StarTeamClientOptions overview

Public Static Fields

CHANGE_CHECK_NEW_ITEM_ACTIVATED
CHANGE_CHECK_NEW_ITEM_INTERVAL
CHANGE_READ_ON_SELECT_CHANGE_ACTIVATED
CHANGE_SELECTED_ITEM_TIMER_ACTIVATED
CHANGE_SELECTED_ITEM_TIMER_INTERVAL
FILE_CENTRAL_STATUS_DIRECTORY
FILE_CLEAR_LOCKS_ON_CHECK_IN
FILE_COMPARE_OPTIONS
FILE_COMPARE_PATH
FILE_DEFAULT_ENCODING
FILE_DEFAULT_EOL
FILE_DEFAULT_STATUS_METHOD
FILE_EDITOR_OPTIONS
FILE_EDITOR_PATH
FILE_LOCALDIRECTORYWATCH
FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT
FILE_MARK_UNLOCKED_FILES_READ_ONLY
FILE_MERGE_OPTIONS
FILE_MERGE_PATH
FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS
FILE_PERFORM_EOL_CONVERSION
FILE_POPUP_VISMERGE_ALWAYS
FILE_USE_ALTERNATE_COMPARE
FILE_USE_ALTERNATE_EDITOR
FILE_USE_ALTERNATE_MERGE
FILE_USE_MD5_TO_CALCULATE_STATUS
FILE_USE_MODIFIED_TIME_STAMP
FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS
TASK_CHECK_NEW_ITEM_ACTIVATED
TASK_CHECK_NEW_ITEM_INTERVAL
TASK_READ_ON_SELECT_CHANGE_ACTIVATED
TASK_SELECTED_ITEM_TIMER_ACTIVATED
TASK_SELECTED_ITEM_TIMER_INTERVAL
TOPIC_CHECK_NEW_ITEM_ACTIVATED
TOPIC_CHECK_NEW_ITEM_INTERVAL
TOPIC_READ_ON_SELECT_CHANGE_ACTIVATED
TOPIC_SELECTED_ITEM_TIMER_ACTIVATED
TOPIC_SELECTED_ITEM_TIMER_INTERVAL
WORKSPACE_AUTO_REFRESH
WORKSPACE_CHANGE_SCOPE_FOLDER
WORKSPACE_CONFIRM_DELETE
WORKSPACE_CONFIRM_MOVE
WORKSPACE_FALCON
WORKSPACE_FOLDER_CONTEXT
WORKSPACE_HISTORY_UTC
WORKSPACE_INSTANT_REFRESH
WORKSPACE_INSTANT_REFRESH_MAX_TIME
WORKSPACE_INSTANT_REFRESH_MIN_TIME
WORKSPACE_LOG_COMMAND_DETAILS
WORKSPACE_LOG_COMMANDS
WORKSPACE_LOG_ERRORS
WORKSPACE_LOG_EVENTS
WORKSPACE_LOG_OUTPUT_PATH
WORKSPACE_LOG_THRESHOLD
WORKSPACE_LOG_UI_OPERATIONS
WORKSPACE_MAINTAIN_GROUP_STATE
WORKSPACE_REFRESH_TIME
WORKSPACE_REPORT_OUTPUT_PATH
WORKSPACE_RESTORE_SHORTCUTS
WORKSPACE_SHOW_STATUSBAR
WORKSPACE_SHOW_TOOLBARS
WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS
WORKSPACE_WARNINGS

Public Static Methods

getDefault | Returns the singleton default StarTeamClientOptions object based on the default options file location.
getDefaultFile | Returns the default StarTeamClientOptions file. On Windows this will be the value of the environment variable "StarTeam". On non-windows platforms this will be the file called "StarTeam.ini" in the user's home directory.

Public Instance Constructors

StarTeamClientOptions Constructor Creates a new StarTeamClientOptions instance which can be used to get/set client side options used by StarTeam clients.

Public Instance Methods

clearProcessItem | Obsolete. Clears the process item for the specified view.
Equals |
getAllProcessItems | Gets the list of items that have been set as the current process item for at least one view on the given server.
getCentralStatusDirectory | Returns the path to be user for storing centralized status information. If not set in this options file this will return a default location.
getChangeCheckNewItemActivated | Returns the workstation option value.
getChangeCheckNewItemInterval | Returns the workstation option value.
getChangeReadOnSelectChangeActivated | Returns the workstation option value.
getChangeSelectedItemTimerActivated | Returns the workstation option value.
getChangeSelectedItemTimerInterval | Returns the workstation option value.
getComponentOption |
getDefaultStatusMethod |
getFileClearLocksOnCheckIn | Returns the workstation option value.
getFileCompareOptions | Returns the workstation option value.
getFileComparePath | Returns the workstation option value.
getFileDefaultEncoding | Returns the workstation option value.
getFileDefaultEOL | Returns the workstation option value.
getFileEditorOptions | Returns the workstation option value.
getFileEditorPath | Returns the workstation option value.
getFileLocalDirectoryWatch | Returns the workstation option value.
getFileLockFilesExclusivelyOnCheckOut | Returns the workstation option value.
getFileMarkUnlockedFilesReadOnly | Returns the workstation option value.
getFileMergeOptions | Returns the workstation option value.
getFileMergePath | Returns the workstation option value.
getFileOptimizeForSlowConnections | Returns the workstation option value.
getFilePerformEOLConversion | Returns the workstation option value.
getFilePopupVisMergeAlways | Returns the workstation option value.
getFileUseAlternateCompare | Returns the workstation option value.
getFileUseAlternateEditor | Returns the workstation option value.
getFileUseAlternateMerge | Returns the workstation option value.
getFileUseMD5ToCalculateStatus | Returns the workstation option value.
getFileUseModifiedTimeStamp | Returns the workstation option value.
getFileUseNonExclusiveLocksInIntegrations | Returns the workstation option value.
getFolderAlternatePath | Returns the alternate working directory for the specified folder. This may return null.
getFolderAlternatePathEnabled | Return true if the alternate working directory is enabled for this folder.
getFolderUserVisible | Return true if the specified folder is user visible. A UI should not display items in an invisible folder.
GetHashCode |
getMPXEnabled | Returns the workstation option value to enable mpx.
getOption |
getProcessItem | Gets the current process item in the given target view.
getProcessItemClassID | Obsolete. Returns the class ID of the process item for the specified view. Will return -1 if no process item is specified for the view.
getProcessItemID | Obsolete. Returns the item ID of the process item for the specified view. Will return -1 if no process item is specified for the view.
getTaskCheckNewItemActivated | Returns the workstation option value.
getTaskCheckNewItemInterval | Returns the workstation option value.
getTaskReadOnSelectChangeActivated | Returns the workstation option value.
getTaskSelectedItemTimerActivated | Returns the workstation option value.
getTaskSelectedItemTimerInterval | Returns the workstation option value.
getTopicCheckNewItemActivated | Returns the workstation option value.
getTopicCheckNewItemInterval | Returns the workstation option value.
getTopicReadOnSelectChangeActivated | Returns the workstation option value.
getTopicSelectedItemTimerActivated | Returns the workstation option value.
getTopicSelectedItemTimerInterval | Returns the workstation option value.
GetType (inherited from Object) | Gets the Type of the current instance.
getViewAlternatePath | Returns the alternate working directory for the specified view. This may return null.
getViewAlternatePathEnabled | Return true if the alternate working directory is enabled for this view.
getViewStatusMethodOverride | Returns the option value stored for the specified View's status method.
getWorkspaceAutoRefresh | Returns the workstation option value.
getWorkspaceChangeScopeFolder | Returns the workstation option value.
getWorkspaceConfirmDelete | Returns the workstation option value.
getWorkspaceConfirmMove | Returns the workstation option value.
getWorkspaceFalcon | Obsolete. Returns the workstation option value to enable mpx.
getWorkspaceFolderContext | Returns the workstation option value.
getWorkspaceHistoryUTC | Returns the workstation option value.
getWorkspaceInstantRefresh | Returns the workstation option value.
getWorkspaceInstantRefreshMaxTime | Returns the workstation option value.
getWorkspaceInstantRefreshMinTime | Returns the workstation option value.
getWorkspaceLogCommandDetails | Returns the workstation option value.
getWorkspaceLogCommands | Returns the workstation option value.
getWorkspaceLogErrors | Returns the workstation option value.
getWorkspaceLogEvents | Returns the workstation option value.
getWorkspaceLogOutputPath | Returns the workstation option value.
getWorkspaceLogThreshold | Returns the workstation option value.
getWorkspaceLogUIOperations | Returns the workstation option value.
getWorkspaceMaintainGroupState | Returns the workstation option value.
getWorkspaceRefreshTime | Returns the workstation option value.
getWorkspaceReportOutputPath | Returns the workstation option value.
getWorkspaceRestoreShortcuts | Returns the workstation option value.
getWorkspaceShowStatusBar | Returns the workstation option value.
getWorkspaceShowToolbars | Returns the workstation option value.
getWorkspaceShowVirtualMeetingOptions | Returns the workstation option value.
getWorkspaceWarnings | Returns the workstation option value.
load | Load the options from the specified file. This file becomes the new underlying file for this StarTeamClientOptions object.
loadDefault | Loads the options from the default file.
MemberwiseClone |
reload | Re-loads the underlying options file.
reloadIfNeeded | Re-loads the ini only if the file's last modified time stamp has changed.
save | Writes the options to the underlying file.
saveTo | Saves the options to the new file. This becomes the new underlying file for this StarTeamClientOptions object.
setCentralStatusDirectory |
setChangeCheckNewItemActivated |
setChangeCheckNewItemInterval |
setChangeReadOnSelectChangeActivated |
setChangeSelectedItemTimerActivated |
setChangeSelectedItemTimerInterval |
setComponentOption |
setDefaultStatusMethod | Sets the default status method to be used by the client.
setFileClearLocksOnCheckIn |
setFileCompareOptions |
setFileComparePath |
setFileDefaultEncoding |
setFileDefaultEOL |
setFileEditorOptions |
setFileEditorPath |
setFileLocalDirectoryWatch |
setFileLockFilesExclusivelyOnCheckOut |
setFileMarkUnlockedFilesReadOnly |
setFileMergeOptions |
setFileMergePath |
setFileOptimizeForSlowConnections |
setFilePerformEOLConversion |
setFilePopupVisMergeAlways |
setFileUseAlternateCompare |
setFileUseAlternateEditor |
setFileUseAlternateMerge |
setFileUseMD5ToCalculateStatus |
setFileUseModifiedTimeStamp |
setFileUseNonExclusiveLocksInIntegrations |
setFolderAlternatePath |
setFolderAlternatePathEnabled |
setFolderUserVisible |
setMPXEnabled |
setOption |
setProcessItem | Overloaded. Sets the process item for the specified item's view.
setTaskCheckNewItemActivated |
setTaskCheckNewItemInterval |
setTaskReadOnSelectChangeActivated |
setTaskSelectedItemTimerActivated |
setTaskSelectedItemTimerInterval |
setTopicCheckNewItemActivated |
setTopicCheckNewItemInterval |
setTopicReadOnSelectChangeActivated |
setTopicSelectedItemTimerActivated |
setTopicSelectedItemTimerInterval |
setViewAlternatePath |
setViewAlternatePathEnabled |
setViewStatusMethodOverride |
setWorkspaceAutoRefresh |
setWorkspaceChangeScopeFolder |
setWorkspaceConfirmDelete |
setWorkspaceConfirmMove |
setWorkspaceFalcon | Obsolete.
setWorkspaceFolderContext |
setWorkspaceHistoryUTC |
setWorkspaceInstantRefresh |
setWorkspaceInstantRefreshMaxTime |
setWorkspaceInstantRefreshMinTime |
setWorkspaceLogCommandDetails |
setWorkspaceLogCommands |
setWorkspaceLogErrors |
setWorkspaceLogEvents |
setWorkspaceLogOutputPath |
setWorkspaceLogThreshold |
setWorkspaceLogUIOperations |
setWorkspaceMaintainGroupState |
setWorkspaceRefreshTime |
setWorkspaceReportOutputPath |
setWorkspaceRestoreShortcuts |
setWorkspaceShowStatusBar |
setWorkspaceShowToolbars |
setWorkspaceShowVirtualMeetingOptions |
setWorkspaceWarnings |
ToString |

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions Constructor

Creates a new StarTeamClientOptions instance which can be used to get/set client side options used by StarTeam clients.

public StarTeamClientOptions();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions Fields

The fields of the StarTeamClientOptions class are listed below. For a complete list of StarTeamClientOptions class members, see the StarTeamClientOptions Members topic.

Public Static Fields

CHANGE_CHECK_NEW_ITEM_ACTIVATED
CHANGE_CHECK_NEW_ITEM_INTERVAL
CHANGE_READ_ON_SELECT_CHANGE_ACTIVATED
CHANGE_SELECTED_ITEM_TIMER_ACTIVATED
CHANGE_SELECTED_ITEM_TIMER_INTERVAL
FILE_CENTRAL_STATUS_DIRECTORY
FILE_CLEAR_LOCKS_ON_CHECK_IN
FILE_COMPARE_OPTIONS
FILE_COMPARE_PATH
FILE_DEFAULT_ENCODING
FILE_DEFAULT_EOL
FILE_DEFAULT_STATUS_METHOD
FILE_EDITOR_OPTIONS
FILE_EDITOR_PATH
FILE_LOCALDIRECTORYWATCH
FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT
FILE_MARK_UNLOCKED_FILES_READ_ONLY
FILE_MERGE_OPTIONS
FILE_MERGE_PATH
FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS
FILE_PERFORM_EOL_CONVERSION
FILE_POPUP_VISMERGE_ALWAYS
FILE_USE_ALTERNATE_COMPARE
FILE_USE_ALTERNATE_EDITOR
FILE_USE_ALTERNATE_MERGE
FILE_USE_MD5_TO_CALCULATE_STATUS
FILE_USE_MODIFIED_TIME_STAMP
FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS
TASK_CHECK_NEW_ITEM_ACTIVATED
TASK_CHECK_NEW_ITEM_INTERVAL
TASK_READ_ON_SELECT_CHANGE_ACTIVATED
TASK_SELECTED_ITEM_TIMER_ACTIVATED
TASK_SELECTED_ITEM_TIMER_INTERVAL
TOPIC_CHECK_NEW_ITEM_ACTIVATED
TOPIC_CHECK_NEW_ITEM_INTERVAL
TOPIC_READ_ON_SELECT_CHANGE_ACTIVATED
TOPIC_SELECTED_ITEM_TIMER_ACTIVATED
TOPIC_SELECTED_ITEM_TIMER_INTERVAL
WORKSPACE_AUTO_REFRESH
WORKSPACE_CHANGE_SCOPE_FOLDER
WORKSPACE_CONFIRM_DELETE
WORKSPACE_CONFIRM_MOVE
WORKSPACE_FALCON
WORKSPACE_FOLDER_CONTEXT
WORKSPACE_HISTORY_UTC
WORKSPACE_INSTANT_REFRESH
WORKSPACE_INSTANT_REFRESH_MAX_TIME
WORKSPACE_INSTANT_REFRESH_MIN_TIME
WORKSPACE_LOG_COMMAND_DETAILS
WORKSPACE_LOG_COMMANDS
WORKSPACE_LOG_ERRORS
WORKSPACE_LOG_EVENTS
WORKSPACE_LOG_OUTPUT_PATH
WORKSPACE_LOG_THRESHOLD
WORKSPACE_LOG_UI_OPERATIONS
WORKSPACE_MAINTAIN_GROUP_STATE
WORKSPACE_REFRESH_TIME
WORKSPACE_REPORT_OUTPUT_PATH
WORKSPACE_RESTORE_SHORTCUTS
WORKSPACE_SHOW_STATUSBAR
WORKSPACE_SHOW_TOOLBARS
WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS
WORKSPACE_WARNINGS

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.CHANGE_CHECK_NEW_ITEM_ACTIVATED Field

public const String CHANGE_CHECK_NEW_ITEM_ACTIVATED = "Change Component::Check New Item Activated";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.CHANGE_CHECK_NEW_ITEM_INTERVAL Field

public const String CHANGE_CHECK_NEW_ITEM_INTERVAL = "Change Component::Check New Item Interval";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.CHANGE_READ_ON_SELECT_CHANGE_ACTIVATED Field

public const String CHANGE_READ_ON_SELECT_CHANGE_ACTIVATED = "Change Component::Read On Select Change Activated";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.CHANGE_SELECTED_ITEM_TIMER_ACTIVATED Field

public const String CHANGE_SELECTED_ITEM_TIMER_ACTIVATED = "Change Component::Selected Item Timer Activated";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.CHANGE_SELECTED_ITEM_TIMER_INTERVAL Field

public const String CHANGE_SELECTED_ITEM_TIMER_INTERVAL = "Change Component::Selected Item Timer Interval";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_CENTRAL_STATUS_DIRECTORY Field

public const String FILE_CENTRAL_STATUS_DIRECTORY = "File Component::CentralStatusDir";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_CLEAR_LOCKS_ON_CHECK_IN Field

public const String FILE_CLEAR_LOCKS_ON_CHECK_IN = "File Component::Clear Locks On Check-In";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_COMPARE_OPTIONS Field

public const String FILE_COMPARE_OPTIONS = "File Component::Compare Options";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_COMPARE_PATH Field

public const String FILE_COMPARE_PATH = "File Component::Compare Path";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_DEFAULT_ENCODING Field

public const String FILE_DEFAULT_ENCODING = "File Component::Default Encoding";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_DEFAULT_EOL Field

public const String FILE_DEFAULT_EOL = "File Component::Default EOL";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_DEFAULT_STATUS_METHOD Field

public const String FILE_DEFAULT_STATUS_METHOD = "File Component::DefaultStatusMethod";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_EDITOR_OPTIONS Field

public const String FILE_EDITOR_OPTIONS = "File Component::Editor Options";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_EDITOR_PATH Field

public const String FILE_EDITOR_PATH = "File Component::Editor Path";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_LOCALDIRECTORYWATCH Field

public const String FILE_LOCALDIRECTORYWATCH = "File Component::LocalDirectoryWatch";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT Field

public const String FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT = "File Component::Lock Files Exclusively On Check-Out";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_MARK_UNLOCKED_FILES_READ_ONLY Field

public const String FILE_MARK_UNLOCKED_FILES_READ_ONLY = "File Component::Mark Unlocked Files Read Only";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_MERGE_OPTIONS Field

public const String FILE_MERGE_OPTIONS = "File Component::Merge Options";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_MERGE_PATH Field

public const String FILE_MERGE_PATH = "File Component::Merge Path";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS Field

public const String FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS = "File Component::Optimize For Slow Connections";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_PERFORM_EOL_CONVERSION Field

public const String FILE_PERFORM_EOL_CONVERSION = "File Component::Perform EOL Conversion";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_POPUP_VISMERGE_ALWAYS Field

public const String FILE_POPUP_VISMERGE_ALWAYS = "File Component::Popup VisMerge Always";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_USE_ALTERNATE_COMPARE Field

public const String FILE_USE_ALTERNATE_COMPARE = "File Component::Use Alternate Compare";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_USE_ALTERNATE_EDITOR Field

public const String FILE_USE_ALTERNATE_EDITOR = "File Component::Use Alternate Editor";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_USE_ALTERNATE_MERGE Field

public const String FILE_USE_ALTERNATE_MERGE = "File Component::Use Alternate Merge";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_USE_MD5_TO_CALCULATE_STATUS Field

public const String FILE_USE_MD5_TO_CALCULATE_STATUS = "File Component::Use MD5 To Calculate Status";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_USE_MODIFIED_TIME_STAMP Field

public const String FILE_USE_MODIFIED_TIME_STAMP = "File Component::Use Modified Time Stamp";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS Field

public const String FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS = "File Component::Use Non-Exclusive Locks In Integrations";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.TASK_CHECK_NEW_ITEM_ACTIVATED Field

public const String TASK_CHECK_NEW_ITEM_ACTIVATED = "Task Component::Check New Item Activated";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.TASK_CHECK_NEW_ITEM_INTERVAL Field

public const String TASK_CHECK_NEW_ITEM_INTERVAL = "Task Component::Check New Item Interval";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.TASK_READ_ON_SELECT_CHANGE_ACTIVATED Field

public const String TASK_READ_ON_SELECT_CHANGE_ACTIVATED = "Task Component::Read On Select Change Activated";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.TASK_SELECTED_ITEM_TIMER_ACTIVATED Field

public const String TASK_SELECTED_ITEM_TIMER_ACTIVATED = "Task Component::Selected Item Timer Activated";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.TASK_SELECTED_ITEM_TIMER_INTERVAL Field

public const String TASK_SELECTED_ITEM_TIMER_INTERVAL = "Task Component::Selected Item Timer Interval";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.TOPIC_CHECK_NEW_ITEM_ACTIVATED Field

public const String TOPIC_CHECK_NEW_ITEM_ACTIVATED = "Topic Component::Check New Item Activated";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.TOPIC_CHECK_NEW_ITEM_INTERVAL Field

public const String TOPIC_CHECK_NEW_ITEM_INTERVAL = "Topic Component::Check New Item Interval";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.TOPIC_READ_ON_SELECT_CHANGE_ACTIVATED Field

public const String TOPIC_READ_ON_SELECT_CHANGE_ACTIVATED = "Task Component::Read On Select Change Activated";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.TOPIC_SELECTED_ITEM_TIMER_ACTIVATED Field

public const String TOPIC_SELECTED_ITEM_TIMER_ACTIVATED = "Topic Component::Selected Item Timer Activated";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.TOPIC_SELECTED_ITEM_TIMER_INTERVAL Field

public const String TOPIC_SELECTED_ITEM_TIMER_INTERVAL = "Topic Component::Selected Item Timer Interval";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_AUTO_REFRESH Field

public const String WORKSPACE_AUTO_REFRESH = "Workspace::Auto Refresh";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_CHANGE_SCOPE_FOLDER Field

public const String WORKSPACE_CHANGE_SCOPE_FOLDER = "Workspace::Change Scope Folder";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_CONFIRM_DELETE Field

public const String WORKSPACE_CONFIRM_DELETE = "Workspace::Confirm Delete";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_CONFIRM_MOVE Field

public const String WORKSPACE_CONFIRM_MOVE = "Workspace::Confirm Move";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_FALCON Field

public const String WORKSPACE_FALCON = "Workspace::Falcon";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_FOLDER_CONTEXT Field

public const String WORKSPACE_FOLDER_CONTEXT = "Workspace::Folder Context";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_HISTORY_UTC Field

public const String WORKSPACE_HISTORY_UTC = "Workspace::History UTC";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_INSTANT_REFRESH Field

public const String WORKSPACE_INSTANT_REFRESH = "Workspace::Instant Refresh";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_INSTANT_REFRESH_MAX_TIME Field

public const String WORKSPACE_INSTANT_REFRESH_MAX_TIME = "Workspace::Instant Refresh Max Time";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_INSTANT_REFRESH_MIN_TIME Field

public const String WORKSPACE_INSTANT_REFRESH_MIN_TIME = "Workspace::Instant Refresh Min Time";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_LOG_COMMAND_DETAILS Field

public const String WORKSPACE_LOG_COMMAND_DETAILS = "Workspace::Log Command Details";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_LOG_COMMANDS Field

public const String WORKSPACE_LOG_COMMANDS = "Workspace::Log Commands";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_LOG_ERRORS Field

public const String WORKSPACE_LOG_ERRORS = "Workspace::Log Errors";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_LOG_EVENTS Field

public const String WORKSPACE_LOG_EVENTS = "Workspace::Log Events";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_LOG_OUTPUT_PATH Field

public const String WORKSPACE_LOG_OUTPUT_PATH = "Workspace::Log Output Path";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_LOG_THRESHOLD Field

public const String WORKSPACE_LOG_THRESHOLD = "Workspace::Log Threshold";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_LOG_UI_OPERATIONS Field

public const String WORKSPACE_LOG_UI_OPERATIONS = "Workspace::Log UI Operations";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_MAINTAIN_GROUP_STATE Field

public const String WORKSPACE_MAINTAIN_GROUP_STATE = "Workspace::Maintain Group State";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_REFRESH_TIME Field

public const String WORKSPACE_REFRESH_TIME = "Workspace::Refresh Time";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_REPORT_OUTPUT_PATH Field

public const String WORKSPACE_REPORT_OUTPUT_PATH = "Workspace::Report Output Path";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_RESTORE_SHORTCUTS Field

public const String WORKSPACE_RESTORE_SHORTCUTS = "Workspace::Restore Shortcuts";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_SHOW_STATUSBAR Field

public const String WORKSPACE_SHOW_STATUSBAR = "Workspace::Show StatusBar";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_SHOW_TOOLBARS Field

public const String WORKSPACE_SHOW_TOOLBARS = "Workspace::Show Toolbars";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS Field

public const String WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS = "Workspace::Show Virtual Meeting Options";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.WORKSPACE_WARNINGS Field

public const String WORKSPACE_WARNINGS = "Workspace::Warnings";

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions Methods

The methods of the StarTeamClientOptions class are listed below. For a complete list of StarTeamClientOptions class members, see the StarTeamClientOptions Members topic.

Public Static Methods

getDefault | Returns the singleton default StarTeamClientOptions object based on the default options file location.
getDefaultFile | Returns the default StarTeamClientOptions file. On Windows this will be the value of the environment variable "StarTeam". On non-windows platforms this will be the file called "StarTeam.ini" in the user's home directory.

Public Instance Methods

clearProcessItem | Obsolete. Clears the process item for the specified view.
Equals |
getAllProcessItems | Gets the list of items that have been set as the current process item for at least one view on the given server.
getCentralStatusDirectory | Returns the path to be user for storing centralized status information. If not set in this options file this will return a default location.
getChangeCheckNewItemActivated | Returns the workstation option value.
getChangeCheckNewItemInterval | Returns the workstation option value.
getChangeReadOnSelectChangeActivated | Returns the workstation option value.
getChangeSelectedItemTimerActivated | Returns the workstation option value.
getChangeSelectedItemTimerInterval | Returns the workstation option value.
getComponentOption |
getDefaultStatusMethod |
getFileClearLocksOnCheckIn | Returns the workstation option value.
getFileCompareOptions | Returns the workstation option value.
getFileComparePath | Returns the workstation option value.
getFileDefaultEncoding | Returns the workstation option value.
getFileDefaultEOL | Returns the workstation option value.
getFileEditorOptions | Returns the workstation option value.
getFileEditorPath | Returns the workstation option value.
getFileLocalDirectoryWatch | Returns the workstation option value.
getFileLockFilesExclusivelyOnCheckOut | Returns the workstation option value.
getFileMarkUnlockedFilesReadOnly | Returns the workstation option value.
getFileMergeOptions | Returns the workstation option value.
getFileMergePath | Returns the workstation option value.
getFileOptimizeForSlowConnections | Returns the workstation option value.
getFilePerformEOLConversion | Returns the workstation option value.
getFilePopupVisMergeAlways | Returns the workstation option value.
getFileUseAlternateCompare | Returns the workstation option value.
getFileUseAlternateEditor | Returns the workstation option value.
getFileUseAlternateMerge | Returns the workstation option value.
getFileUseMD5ToCalculateStatus | Returns the workstation option value.
getFileUseModifiedTimeStamp | Returns the workstation option value.
getFileUseNonExclusiveLocksInIntegrations | Returns the workstation option value.
getFolderAlternatePath | Returns the alternate working directory for the specified folder. This may return null.
getFolderAlternatePathEnabled | Return true if the alternate working directory is enabled for this folder.
getFolderUserVisible | Return true if the specified folder is user visible. A UI should not display items in an invisible folder.
GetHashCode |
getMPXEnabled | Returns the workstation option value to enable mpx.
getOption |
getProcessItem | Gets the current process item in the given target view.
getProcessItemClassID | Obsolete. Returns the class ID of the process item for the specified view. Will return -1 if no process item is specified for the view.
getProcessItemID | Obsolete. Returns the item ID of the process item for the specified view. Will return -1 if no process item is specified for the view.
getTaskCheckNewItemActivated | Returns the workstation option value.
getTaskCheckNewItemInterval | Returns the workstation option value.
getTaskReadOnSelectChangeActivated | Returns the workstation option value.
getTaskSelectedItemTimerActivated | Returns the workstation option value.
getTaskSelectedItemTimerInterval | Returns the workstation option value.
getTopicCheckNewItemActivated | Returns the workstation option value.
getTopicCheckNewItemInterval | Returns the workstation option value.
getTopicReadOnSelectChangeActivated | Returns the workstation option value.
getTopicSelectedItemTimerActivated | Returns the workstation option value.
getTopicSelectedItemTimerInterval | Returns the workstation option value.
GetType (inherited from Object) | Gets the Type of the current instance.
getViewAlternatePath | Returns the alternate working directory for the specified view. This may return null.
getViewAlternatePathEnabled | Return true if the alternate working directory is enabled for this view.
getViewStatusMethodOverride | Returns the option value stored for the specified View's status method.
getWorkspaceAutoRefresh | Returns the workstation option value.
getWorkspaceChangeScopeFolder | Returns the workstation option value.
getWorkspaceConfirmDelete | Returns the workstation option value.
getWorkspaceConfirmMove | Returns the workstation option value.
getWorkspaceFalcon | Obsolete. Returns the workstation option value to enable mpx.
getWorkspaceFolderContext | Returns the workstation option value.
getWorkspaceHistoryUTC | Returns the workstation option value.
getWorkspaceInstantRefresh | Returns the workstation option value.
getWorkspaceInstantRefreshMaxTime | Returns the workstation option value.
getWorkspaceInstantRefreshMinTime | Returns the workstation option value.
getWorkspaceLogCommandDetails | Returns the workstation option value.
getWorkspaceLogCommands | Returns the workstation option value.
getWorkspaceLogErrors | Returns the workstation option value.
getWorkspaceLogEvents | Returns the workstation option value.
getWorkspaceLogOutputPath | Returns the workstation option value.
getWorkspaceLogThreshold | Returns the workstation option value.
getWorkspaceLogUIOperations | Returns the workstation option value.
getWorkspaceMaintainGroupState | Returns the workstation option value.
getWorkspaceRefreshTime | Returns the workstation option value.
getWorkspaceReportOutputPath | Returns the workstation option value.
getWorkspaceRestoreShortcuts | Returns the workstation option value.
getWorkspaceShowStatusBar | Returns the workstation option value.
getWorkspaceShowToolbars | Returns the workstation option value.
getWorkspaceShowVirtualMeetingOptions | Returns the workstation option value.
getWorkspaceWarnings | Returns the workstation option value.
load | Load the options from the specified file. This file becomes the new underlying file for this StarTeamClientOptions object.
loadDefault | Loads the options from the default file.
MemberwiseClone |
reload | Re-loads the underlying options file.
reloadIfNeeded | Re-loads the ini only if the file's last modified time stamp has changed.
save | Writes the options to the underlying file.
saveTo | Saves the options to the new file. This becomes the new underlying file for this StarTeamClientOptions object.
setCentralStatusDirectory |
setChangeCheckNewItemActivated |
setChangeCheckNewItemInterval |
setChangeReadOnSelectChangeActivated |
setChangeSelectedItemTimerActivated |
setChangeSelectedItemTimerInterval |
setComponentOption |
setDefaultStatusMethod | Sets the default status method to be used by the client.
setFileClearLocksOnCheckIn |
setFileCompareOptions |
setFileComparePath |
setFileDefaultEncoding |
setFileDefaultEOL |
setFileEditorOptions |
setFileEditorPath |
setFileLocalDirectoryWatch |
setFileLockFilesExclusivelyOnCheckOut |
setFileMarkUnlockedFilesReadOnly |
setFileMergeOptions |
setFileMergePath |
setFileOptimizeForSlowConnections |
setFilePerformEOLConversion |
setFilePopupVisMergeAlways |
setFileUseAlternateCompare |
setFileUseAlternateEditor |
setFileUseAlternateMerge |
setFileUseMD5ToCalculateStatus |
setFileUseModifiedTimeStamp |
setFileUseNonExclusiveLocksInIntegrations |
setFolderAlternatePath |
setFolderAlternatePathEnabled |
setFolderUserVisible |
setMPXEnabled |
setOption |
setProcessItem | Overloaded. Sets the process item for the specified item's view.
setTaskCheckNewItemActivated |
setTaskCheckNewItemInterval |
setTaskReadOnSelectChangeActivated |
setTaskSelectedItemTimerActivated |
setTaskSelectedItemTimerInterval |
setTopicCheckNewItemActivated |
setTopicCheckNewItemInterval |
setTopicReadOnSelectChangeActivated |
setTopicSelectedItemTimerActivated |
setTopicSelectedItemTimerInterval |
setViewAlternatePath |
setViewAlternatePathEnabled |
setViewStatusMethodOverride |
setWorkspaceAutoRefresh |
setWorkspaceChangeScopeFolder |
setWorkspaceConfirmDelete |
setWorkspaceConfirmMove |
setWorkspaceFalcon | Obsolete.
setWorkspaceFolderContext |
setWorkspaceHistoryUTC |
setWorkspaceInstantRefresh |
setWorkspaceInstantRefreshMaxTime |
setWorkspaceInstantRefreshMinTime |
setWorkspaceLogCommandDetails |
setWorkspaceLogCommands |
setWorkspaceLogErrors |
setWorkspaceLogEvents |
setWorkspaceLogOutputPath |
setWorkspaceLogThreshold |
setWorkspaceLogUIOperations |
setWorkspaceMaintainGroupState |
setWorkspaceRefreshTime |
setWorkspaceReportOutputPath |
setWorkspaceRestoreShortcuts |
setWorkspaceShowStatusBar |
setWorkspaceShowToolbars |
setWorkspaceShowVirtualMeetingOptions |
setWorkspaceWarnings |
ToString |

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.clearProcessItem Method

NOTE: This method is now obsolete.

Clears the process item for the specified view.

public virtual void clearProcessItem(
View view
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.Equals Method

public override bool Equals(
Object source
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getAllProcessItems Method

Gets the list of items that have been set as the current process item for at least one view on the given server.

public virtual Item[] getAllProcessItems(
Server s
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getCentralStatusDirectory Method

Returns the path to be user for storing centralized status information. If not set in this options file this will return a default location.

public virtual string getCentralStatusDirectory();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getChangeCheckNewItemActivated Method

Returns the workstation option value.

public virtual bool getChangeCheckNewItemActivated();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getChangeCheckNewItemInterval Method

Returns the workstation option value.

public virtual int getChangeCheckNewItemInterval();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getChangeReadOnSelectChangeActivated Method

Returns the workstation option value.

public virtual bool getChangeReadOnSelectChangeActivated();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getChangeSelectedItemTimerActivated Method

Returns the workstation option value.

public virtual bool getChangeSelectedItemTimerActivated();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getChangeSelectedItemTimerInterval Method

Returns the workstation option value.

public virtual int getChangeSelectedItemTimerInterval();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getComponentOption Method

public virtual string getComponentOption(
String componentName,
String optionName,
String defaultValue
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getDefault Method

Returns the singleton default StarTeamClientOptions object based on the default options file location.

public static StarTeamClientOptions getDefault();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getDefaultFile Method

Returns the default StarTeamClientOptions file. On Windows this will be the value of the environment variable "StarTeam". On non-windows platforms this will be the file called "StarTeam.ini" in the user's home directory.

public static File getDefaultFile();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getDefaultStatusMethod Method

public virtual StatusMethod getDefaultStatusMethod();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileClearLocksOnCheckIn Method

Returns the workstation option value.

public virtual bool getFileClearLocksOnCheckIn();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileCompareOptions Method

Returns the workstation option value.

public virtual string getFileCompareOptions();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileComparePath Method

Returns the workstation option value.

public virtual string getFileComparePath();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileDefaultEncoding Method

Returns the workstation option value.

public virtual string getFileDefaultEncoding();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileDefaultEOL Method

Returns the workstation option value.

public virtual string getFileDefaultEOL();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileEditorOptions Method

Returns the workstation option value.

public virtual string getFileEditorOptions();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileEditorPath Method

Returns the workstation option value.

public virtual string getFileEditorPath();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileLocalDirectoryWatch Method

Returns the workstation option value.

public virtual bool getFileLocalDirectoryWatch();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileLockFilesExclusivelyOnCheckOut Method

Returns the workstation option value.

public virtual bool getFileLockFilesExclusivelyOnCheckOut();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileMarkUnlockedFilesReadOnly Method

Returns the workstation option value.

public virtual bool getFileMarkUnlockedFilesReadOnly();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileMergeOptions Method

Returns the workstation option value.

public virtual string getFileMergeOptions();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileMergePath Method

Returns the workstation option value.

public virtual string getFileMergePath();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileOptimizeForSlowConnections Method

Returns the workstation option value.

public virtual bool getFileOptimizeForSlowConnections();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFilePerformEOLConversion Method

Returns the workstation option value.

public virtual bool getFilePerformEOLConversion();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFilePopupVisMergeAlways Method

Returns the workstation option value.

public virtual bool getFilePopupVisMergeAlways();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileUseAlternateCompare Method

Returns the workstation option value.

public virtual bool getFileUseAlternateCompare();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileUseAlternateEditor Method

Returns the workstation option value.

public virtual bool getFileUseAlternateEditor();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileUseAlternateMerge Method

Returns the workstation option value.

public virtual bool getFileUseAlternateMerge();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileUseMD5ToCalculateStatus Method

Returns the workstation option value.

public virtual bool getFileUseMD5ToCalculateStatus();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileUseModifiedTimeStamp Method

Returns the workstation option value.

public virtual bool getFileUseModifiedTimeStamp();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFileUseNonExclusiveLocksInIntegrations Method

Returns the workstation option value.

public virtual bool getFileUseNonExclusiveLocksInIntegrations();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFolderAlternatePath Method

Returns the alternate working directory for the specified folder. This may return null.

public virtual string getFolderAlternatePath(
Folder folder
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFolderAlternatePathEnabled Method

Return true if the alternate working directory is enabled for this folder.

public virtual bool getFolderAlternatePathEnabled(
Folder folder
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getFolderUserVisible Method

Return true if the specified folder is user visible. A UI should not display items in an invisible folder.

public virtual bool getFolderUserVisible(
Folder folder
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.GetHashCode Method

public override int GetHashCode();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getMPXEnabled Method

Returns the workstation option value to enable mpx.

public virtual bool getMPXEnabled();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getOption Method

public virtual string getOption(
String optionName,
String defaultValue
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getProcessItem Method

Gets the current process item in the given target view.

public virtual Item getProcessItem(
View target
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getProcessItemClassID Method

NOTE: This method is now obsolete.

Returns the class ID of the process item for the specified view. Will return -1 if no process item is specified for the view.

public virtual int getProcessItemClassID(
View view
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getProcessItemID Method

NOTE: This method is now obsolete.

Returns the item ID of the process item for the specified view. Will return -1 if no process item is specified for the view.

public virtual int getProcessItemID(
View view
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getTaskCheckNewItemActivated Method

Returns the workstation option value.

public virtual bool getTaskCheckNewItemActivated();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getTaskCheckNewItemInterval Method

Returns the workstation option value.

public virtual int getTaskCheckNewItemInterval();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getTaskReadOnSelectChangeActivated Method

Returns the workstation option value.

public virtual bool getTaskReadOnSelectChangeActivated();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getTaskSelectedItemTimerActivated Method

Returns the workstation option value.

public virtual bool getTaskSelectedItemTimerActivated();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getTaskSelectedItemTimerInterval Method

Returns the workstation option value.

public virtual int getTaskSelectedItemTimerInterval();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getTopicCheckNewItemActivated Method

Returns the workstation option value.

public virtual bool getTopicCheckNewItemActivated();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getTopicCheckNewItemInterval Method

Returns the workstation option value.

public virtual int getTopicCheckNewItemInterval();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getTopicReadOnSelectChangeActivated Method

Returns the workstation option value.

public virtual bool getTopicReadOnSelectChangeActivated();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getTopicSelectedItemTimerActivated Method

Returns the workstation option value.

public virtual bool getTopicSelectedItemTimerActivated();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getTopicSelectedItemTimerInterval Method

Returns the workstation option value.

public virtual int getTopicSelectedItemTimerInterval();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getViewAlternatePath Method

Returns the alternate working directory for the specified view. This may return null.

public virtual string getViewAlternatePath(
View view
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getViewAlternatePathEnabled Method

Return true if the alternate working directory is enabled for this view.

public virtual bool getViewAlternatePathEnabled(
View view
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getViewStatusMethodOverride Method

Returns the option value stored for the specified View's status method.

public virtual StatusMethod getViewStatusMethodOverride(
View view
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceAutoRefresh Method

Returns the workstation option value.

public virtual bool getWorkspaceAutoRefresh();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceChangeScopeFolder Method

Returns the workstation option value.

public virtual bool getWorkspaceChangeScopeFolder();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceConfirmDelete Method

Returns the workstation option value.

public virtual bool getWorkspaceConfirmDelete();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceConfirmMove Method

Returns the workstation option value.

public virtual bool getWorkspaceConfirmMove();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceFalcon Method

NOTE: This method is now obsolete.

Returns the workstation option value to enable mpx.

public virtual bool getWorkspaceFalcon();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceFolderContext Method

Returns the workstation option value.

public virtual bool getWorkspaceFolderContext();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceHistoryUTC Method

Returns the workstation option value.

public virtual bool getWorkspaceHistoryUTC();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceInstantRefresh Method

Returns the workstation option value.

public virtual bool getWorkspaceInstantRefresh();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceInstantRefreshMaxTime Method

Returns the workstation option value.

public virtual int getWorkspaceInstantRefreshMaxTime();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceInstantRefreshMinTime Method

Returns the workstation option value.

public virtual int getWorkspaceInstantRefreshMinTime();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceLogCommandDetails Method

Returns the workstation option value.

public virtual bool getWorkspaceLogCommandDetails();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceLogCommands Method

Returns the workstation option value.

public virtual bool getWorkspaceLogCommands();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceLogErrors Method

Returns the workstation option value.

public virtual bool getWorkspaceLogErrors();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceLogEvents Method

Returns the workstation option value.

public virtual bool getWorkspaceLogEvents();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceLogOutputPath Method

Returns the workstation option value.

public virtual string getWorkspaceLogOutputPath();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceLogThreshold Method

Returns the workstation option value.

public virtual int getWorkspaceLogThreshold();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceLogUIOperations Method

Returns the workstation option value.

public virtual bool getWorkspaceLogUIOperations();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceMaintainGroupState Method

Returns the workstation option value.

public virtual bool getWorkspaceMaintainGroupState();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceRefreshTime Method

Returns the workstation option value.

public virtual bool getWorkspaceRefreshTime();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceReportOutputPath Method

Returns the workstation option value.

public virtual string getWorkspaceReportOutputPath();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceRestoreShortcuts Method

Returns the workstation option value.

public virtual bool getWorkspaceRestoreShortcuts();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceShowStatusBar Method

Returns the workstation option value.

public virtual bool getWorkspaceShowStatusBar();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceShowToolbars Method

Returns the workstation option value.

public virtual bool getWorkspaceShowToolbars();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceShowVirtualMeetingOptions Method

Returns the workstation option value.

public virtual bool getWorkspaceShowVirtualMeetingOptions();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.getWorkspaceWarnings Method

Returns the workstation option value.

public virtual bool getWorkspaceWarnings();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.load Method

Load the options from the specified file. This file becomes the new underlying file for this StarTeamClientOptions object.

public virtual void load(
File file
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.loadDefault Method

Loads the options from the default file.

public virtual void loadDefault();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.MemberwiseClone Method

public override object MemberwiseClone();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.reload Method

Re-loads the underlying options file.

public virtual void reload();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.reloadIfNeeded Method

Re-loads the ini only if the file's last modified time stamp has changed.

public virtual void reloadIfNeeded();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.save Method

Writes the options to the underlying file.

public virtual void save();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.saveTo Method

Saves the options to the new file. This becomes the new underlying file for this StarTeamClientOptions object.

public virtual void saveTo(
File file
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setCentralStatusDirectory Method

public virtual void setCentralStatusDirectory(
String path
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setChangeCheckNewItemActivated Method

public virtual void setChangeCheckNewItemActivated(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setChangeCheckNewItemInterval Method

public virtual void setChangeCheckNewItemInterval(
Int32 value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setChangeReadOnSelectChangeActivated Method

public virtual void setChangeReadOnSelectChangeActivated(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setChangeSelectedItemTimerActivated Method

public virtual void setChangeSelectedItemTimerActivated(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setChangeSelectedItemTimerInterval Method

public virtual void setChangeSelectedItemTimerInterval(
Int32 value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setComponentOption Method

public virtual void setComponentOption(
String componentName,
String optionName,
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setDefaultStatusMethod Method

Sets the default status method to be used by the client.

public virtual void setDefaultStatusMethod(
StatusMethod method
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileClearLocksOnCheckIn Method

public virtual void setFileClearLocksOnCheckIn(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileCompareOptions Method

public virtual void setFileCompareOptions(
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileComparePath Method

public virtual void setFileComparePath(
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileDefaultEncoding Method

public virtual void setFileDefaultEncoding(
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileDefaultEOL Method

public virtual void setFileDefaultEOL(
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileEditorOptions Method

public virtual void setFileEditorOptions(
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileEditorPath Method

public virtual void setFileEditorPath(
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileLocalDirectoryWatch Method

public virtual void setFileLocalDirectoryWatch(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileLockFilesExclusivelyOnCheckOut Method

public virtual void setFileLockFilesExclusivelyOnCheckOut(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileMarkUnlockedFilesReadOnly Method

public virtual void setFileMarkUnlockedFilesReadOnly(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileMergeOptions Method

public virtual void setFileMergeOptions(
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileMergePath Method

public virtual void setFileMergePath(
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileOptimizeForSlowConnections Method

public virtual void setFileOptimizeForSlowConnections(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFilePerformEOLConversion Method

public virtual void setFilePerformEOLConversion(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFilePopupVisMergeAlways Method

public virtual void setFilePopupVisMergeAlways(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileUseAlternateCompare Method

public virtual void setFileUseAlternateCompare(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileUseAlternateEditor Method

public virtual void setFileUseAlternateEditor(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileUseAlternateMerge Method

public virtual void setFileUseAlternateMerge(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileUseMD5ToCalculateStatus Method

public virtual void setFileUseMD5ToCalculateStatus(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileUseModifiedTimeStamp Method

public virtual void setFileUseModifiedTimeStamp(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFileUseNonExclusiveLocksInIntegrations Method

public virtual void setFileUseNonExclusiveLocksInIntegrations(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFolderAlternatePath Method

public virtual void setFolderAlternatePath(
Folder folder,
String path
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFolderAlternatePathEnabled Method

public virtual void setFolderAlternatePathEnabled(
Folder folder,
Boolean enabled
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setFolderUserVisible Method

public virtual void setFolderUserVisible(
Folder folder,
Boolean visible
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setMPXEnabled Method

public virtual void setMPXEnabled(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setOption Method

public virtual void setOption(
String optionName,
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setProcessItem Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.setProcessItem Method

NOTE: This method is now obsolete.

Sets the process item for the specified item's view.

Overload List

Obsolete. Sets the process item for the specified item's view.

public virtual void setProcessItem(Item);

public virtual void setProcessItem(Item,View);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setProcessItem Method (Item)

NOTE: This method is now obsolete.

Sets the process item for the specified item's view.

public virtual void setProcessItem(
Item item
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace | StarTeamClientOptions.setProcessItem Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setProcessItem Method (Item, View)

public virtual void setProcessItem(
Item item,
View target
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace | StarTeamClientOptions.setProcessItem Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setTaskCheckNewItemActivated Method

public virtual void setTaskCheckNewItemActivated(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setTaskCheckNewItemInterval Method

public virtual void setTaskCheckNewItemInterval(
Int32 value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setTaskReadOnSelectChangeActivated Method

public virtual void setTaskReadOnSelectChangeActivated(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setTaskSelectedItemTimerActivated Method

public virtual void setTaskSelectedItemTimerActivated(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setTaskSelectedItemTimerInterval Method

public virtual void setTaskSelectedItemTimerInterval(
Int32 value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setTopicCheckNewItemActivated Method

public virtual void setTopicCheckNewItemActivated(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setTopicCheckNewItemInterval Method

public virtual void setTopicCheckNewItemInterval(
Int32 value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setTopicReadOnSelectChangeActivated Method

public virtual void setTopicReadOnSelectChangeActivated(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setTopicSelectedItemTimerActivated Method

public virtual void setTopicSelectedItemTimerActivated(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setTopicSelectedItemTimerInterval Method

public virtual void setTopicSelectedItemTimerInterval(
Int32 value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setViewAlternatePath Method

public virtual void setViewAlternatePath(
View view,
String path
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setViewAlternatePathEnabled Method

public virtual void setViewAlternatePathEnabled(
View view,
Boolean enabled
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setViewStatusMethodOverride Method

public virtual void setViewStatusMethodOverride(
View view,
StatusMethod method
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceAutoRefresh Method

public virtual void setWorkspaceAutoRefresh(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceChangeScopeFolder Method

public virtual void setWorkspaceChangeScopeFolder(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceConfirmDelete Method

public virtual void setWorkspaceConfirmDelete(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceConfirmMove Method

public virtual void setWorkspaceConfirmMove(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceFalcon Method

NOTE: This method is now obsolete.

public virtual void setWorkspaceFalcon(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceFolderContext Method

public virtual void setWorkspaceFolderContext(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceHistoryUTC Method

public virtual void setWorkspaceHistoryUTC(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceInstantRefresh Method

public virtual void setWorkspaceInstantRefresh(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceInstantRefreshMaxTime Method

public virtual void setWorkspaceInstantRefreshMaxTime(
Int32 value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceInstantRefreshMinTime Method

public virtual void setWorkspaceInstantRefreshMinTime(
Int32 value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceLogCommandDetails Method

public virtual void setWorkspaceLogCommandDetails(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceLogCommands Method

public virtual void setWorkspaceLogCommands(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceLogErrors Method

public virtual void setWorkspaceLogErrors(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceLogEvents Method

public virtual void setWorkspaceLogEvents(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceLogOutputPath Method

public virtual void setWorkspaceLogOutputPath(
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceLogThreshold Method

public virtual void setWorkspaceLogThreshold(
Int32 value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceLogUIOperations Method

public virtual void setWorkspaceLogUIOperations(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceMaintainGroupState Method

public virtual void setWorkspaceMaintainGroupState(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceRefreshTime Method

public virtual void setWorkspaceRefreshTime(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceReportOutputPath Method

public virtual void setWorkspaceReportOutputPath(
String value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceRestoreShortcuts Method

public virtual void setWorkspaceRestoreShortcuts(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceShowStatusBar Method

public virtual void setWorkspaceShowStatusBar(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceShowToolbars Method

public virtual void setWorkspaceShowToolbars(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceShowVirtualMeetingOptions Method

public virtual void setWorkspaceShowVirtualMeetingOptions(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.setWorkspaceWarnings Method

public virtual void setWorkspaceWarnings(
Boolean value
);

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamClientOptions.ToString Method

public override string ToString();

See Also

StarTeamClientOptions Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder Class

For a list of all members of this type, see StarTeamFinder Members.

System.Object
StarTeamFinder

public class StarTeamFinder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

StarTeamFinder Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder Members

StarTeamFinder overview

Public Static Methods

findFile
findFolder
findSubFolder
openFolder
openFolderWithOverride
openProject
openServer
openView
openViewWithOverride

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder Methods

The methods of the StarTeamFinder class are listed below. For a complete list of StarTeamFinder class members, see the StarTeamFinder Members topic.

Public Static Methods

findFile
findFolder
findSubFolder
openFolder
openFolderWithOverride
openProject
openServer
openView
openViewWithOverride

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder.findFile Method

public static File findFile(
Folder source,
String name,
Boolean matchCase
);

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder.findFolder Method

public static Folder findFolder(
Folder from,
String folderPath
);

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder.findSubFolder Method

public static Folder findSubFolder(
Folder from,
String subFolderName
);

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder.MemberwiseClone Method

public override object MemberwiseClone();

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder.openFolder Method

public static Folder openFolder(
String url
);

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder.openFolderWithOverride Method

public static Folder openFolderWithOverride(
String url,
String viewPath
);

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder.openProject Method

public static Project openProject(
String url
);

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder.openServer Method

public static Server openServer(
String url
);

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder.openView Method

public static View openView(
String url
);

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder.openViewWithOverride Method

public static View openViewWithOverride(
String url,
String viewPath
);

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFinder.ToString Method

public override string ToString();

See Also

StarTeamFinder Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL Class

For a list of all members of this type, see StarTeamURL Members.

System.Object
StarTeamURL

public class StarTeamURL

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

StarTeamURL Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL Members

StarTeamURL overview

Public Instance Constructors

StarTeamURL Constructor

Public Instance Methods

Equals |
getFolders | Returns a StringTokenizer that can be used to enumerate the folder names found in the path portion of the URL.
GetHashCode |
getHostName | Returns the host name specified in the URL or null of not found.
getPassword | Returns the password specified in the URL or null of not found.
getPath | Returns the path specified in the URL or null of not found. The path is everything in the URL after the project specifier.
getPort | Returns the port specified in the URL or null of not found.
getProjectName | Returns the project name specified in the URL or null of not found.
getProtocol | Returns the protocol specified in the URL or PROTOCOL_TCP_IP_SOCKETS of not found.
getSource | Returns the source string for the URL. This is the String the user passed in on the constructor.
GetType (inherited from Object) | Gets the Type of the current instance.
getUserName | Returns the user name specified in the URL or null of not found.
MemberwiseClone |
ToString |

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL Constructor

public StarTeamURL(
String url
);

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL Methods

The methods of the StarTeamURL class are listed below. For a complete list of StarTeamURL class members, see the StarTeamURL Members topic.

Public Instance Methods

Equals |
getFolders | Returns a StringTokenizer that can be used to enumerate the folder names found in the path portion of the URL.
GetHashCode |
getHostName | Returns the host name specified in the URL or null of not found.
getPassword | Returns the password specified in the URL or null of not found.
getPath | Returns the path specified in the URL or null of not found. The path is everything in the URL after the project specifier.
getPort | Returns the port specified in the URL or null of not found.
getProjectName | Returns the project name specified in the URL or null of not found.
getProtocol | Returns the protocol specified in the URL or PROTOCOL_TCP_IP_SOCKETS of not found.
getSource | Returns the source string for the URL. This is the String the user passed in on the constructor.
GetType (inherited from Object) | Gets the Type of the current instance.
getUserName | Returns the user name specified in the URL or null of not found.
MemberwiseClone |
ToString |

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.Equals Method

public override bool Equals(
Object source
);

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.getFolders Method

Returns a StringTokenizer that can be used to enumerate the folder names found in the path portion of the URL.

public virtual StringTokenizer getFolders();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.GetHashCode Method

public override int GetHashCode();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.getHostName Method

Returns the host name specified in the URL or null of not found.

public virtual string getHostName();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.getPassword Method

Returns the password specified in the URL or null of not found.

public virtual string getPassword();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.getPath Method

Returns the path specified in the URL or null of not found. The path is everything in the URL after the project specifier.

public virtual string getPath();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.getPort Method

Returns the port specified in the URL or null of not found.

public virtual string getPort();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.getProjectName Method

Returns the project name specified in the URL or null of not found.

public virtual string getProjectName();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.getProtocol Method

Returns the protocol specified in the URL or PROTOCOL_TCP_IP_SOCKETS of not found.

public virtual int getProtocol();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.getSource Method

Returns the source string for the URL. This is the String the user passed in on the constructor.

public virtual string getSource();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.getUserName Method

Returns the user name specified in the URL or null of not found.

public virtual string getUserName();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.MemberwiseClone Method

public override object MemberwiseClone();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamURL.ToString Method

public override string ToString();

See Also

StarTeamURL Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status Class

For a list of all members of this type, see Status Members.

System.Object
Status

public class Status

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Status Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status Members

Status overview

Public Static Fields

CURRENT
MERGE
MISSING
MODIFIED
NEW
OUTOFDATE
UNKNOWN

Public Static Methods

name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status Fields

The fields of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Static Fields

CURRENT
MERGE
MISSING
MODIFIED
NEW
OUTOFDATE
UNKNOWN

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status.CURRENT Field

public const Int32 CURRENT = 0;

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status.MERGE Field

public const Int32 MERGE = 1;

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status.MISSING Field

public const Int32 MISSING = 2;

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status.MODIFIED Field

public const Int32 MODIFIED = 3;

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status.NEW Field

public const Int32 NEW = 4;

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status.OUTOFDATE Field

public const Int32 OUTOFDATE = 5;

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status.UNKNOWN Field

public const Int32 UNKNOWN = 6;

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status Methods

The methods of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Static Methods

name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status.name Method

public static string name(
Int32 statusValue
);

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Status.ToString Method

public override string ToString();

See Also

Status Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod Class

For a list of all members of this type, see StatusMethod Members.

System.Object
StatusMethod

public class StatusMethod

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

StatusMethod Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod Members

StatusMethod overview

Public Static Fields

CENTRAL
DEFAULT
PER_FOLDER

Public Static Methods

deleteSyncDB |
getCentralStatusDirectory | Returns the location of the central status repository.
getCentralStatusManager | Gets a FileBasedStatusManager for managing status in the central location for this workstation.
getDefaultStatusManager | Gets the default FileBasedStatusManager for this workstation.
getDefaultStatusMethod | Returns the client's default method for storing status information. Only possible return values are PER_FOLDER and CENTRAL.
getPerFolderStatusManager | Gets a FileBasedStatusManager for managing status on a per-folder basis.
getSourceDirs | Given a root directory which contains centrally managed status data, this method will return an enumeration of all the local directory paths for which there is status data. The values in the enumeration will be String objects which are paths to local folders. The paths are in a platform independent format in which all directory delimiters are specified using the backslash (\) character.
getSourceDirsCount | Returns the number of local directories that the specified centrally managed status directory is maintaining.
getStatusManagerForView | Gets the FileBasedStatusManager that manages file status information for the given View. The corresponding StarTeam Server must support client-managed status.
getStatusManagerForViewId |
setCentralStatusDirectory |
setDefaultStatusMethod | Sets the client's default method for storing status information.

Public Instance Methods

Equals |
getDisplayName |
GetHashCode |
getName |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod Fields

The fields of the StatusMethod class are listed below. For a complete list of StatusMethod class members, see the StatusMethod Members topic.

Public Static Fields

CENTRAL
DEFAULT
PER_FOLDER

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.CENTRAL Field

public static readonly StatusMethod CENTRAL;

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.DEFAULT Field

public static readonly StatusMethod DEFAULT;

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.PER_FOLDER Field

public static readonly StatusMethod PER_FOLDER;

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod Methods

The methods of the StatusMethod class are listed below. For a complete list of StatusMethod class members, see the StatusMethod Members topic.

Public Static Methods

deleteSyncDB |
getCentralStatusDirectory | Returns the location of the central status repository.
getCentralStatusManager | Gets a FileBasedStatusManager for managing status in the central location for this workstation.
getDefaultStatusManager | Gets the default FileBasedStatusManager for this workstation.
getDefaultStatusMethod | Returns the client's default method for storing status information. Only possible return values are PER_FOLDER and CENTRAL.
getPerFolderStatusManager | Gets a FileBasedStatusManager for managing status on a per-folder basis.
getSourceDirs | Given a root directory which contains centrally managed status data, this method will return an enumeration of all the local directory paths for which there is status data. The values in the enumeration will be String objects which are paths to local folders. The paths are in a platform independent format in which all directory delimiters are specified using the backslash (\) character.
getSourceDirsCount | Returns the number of local directories that the specified centrally managed status directory is maintaining.
getStatusManagerForView | Gets the FileBasedStatusManager that manages file status information for the given View. The corresponding StarTeam Server must support client-managed status.
getStatusManagerForViewId |
setCentralStatusDirectory |
setDefaultStatusMethod | Sets the client's default method for storing status information.

Public Instance Methods

Equals |
getDisplayName |
GetHashCode |
getName |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.deleteSyncDB Method

public static void deleteSyncDB(
File syncDirRoot,
String key
);

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.Equals Method

public override bool Equals(
Object source
);

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.getCentralStatusDirectory Method

Returns the location of the central status repository.

public static string getCentralStatusDirectory();

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.getCentralStatusManager Method

Gets a FileBasedStatusManager for managing status in the central location for this workstation.

public static FileBasedStatusManager getCentralStatusManager();

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.getDefaultStatusManager Method

Gets the default FileBasedStatusManager for this workstation.

public static FileBasedStatusManager getDefaultStatusManager();

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.getDefaultStatusMethod Method

Returns the client's default method for storing status information. Only possible return values are PER_FOLDER and CENTRAL.

public static StatusMethod getDefaultStatusMethod();

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.getDisplayName Method

public virtual string getDisplayName();

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.GetHashCode Method

public override int GetHashCode();

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.getName Method

public virtual string getName();

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.getPerFolderStatusManager Method

Gets a FileBasedStatusManager for managing status on a per-folder basis.

public static FileBasedStatusManager getPerFolderStatusManager();

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.getSourceDirs Method

Given a root directory which contains centrally managed status data, this method will return an enumeration of all the local directory paths for which there is status data. The values in the enumeration will be String objects which are paths to local folders. The paths are in a platform independent format in which all directory delimiters are specified using the backslash (\) character.

public static Enumeration getSourceDirs(
File syncDirRoot
);

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.getSourceDirsCount Method

Returns the number of local directories that the specified centrally managed status directory is maintaining.

public static int getSourceDirsCount(
File syncDirRoot
);

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.getStatusManagerForView Method

Gets the FileBasedStatusManager that manages file status information for the given View. The corresponding StarTeam Server must support client-managed status.

public static FileBasedStatusManager getStatusManagerForView(
View view
);

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.getStatusManagerForViewId Method

public static FileBasedStatusManager getStatusManagerForViewId(
Int32 viewID,
String serverGUID
);

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.MemberwiseClone Method

public override object MemberwiseClone();

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.setCentralStatusDirectory Method

public static void setCentralStatusDirectory(
String path
);

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.setDefaultStatusMethod Method

Sets the client's default method for storing status information.

public static void setDefaultStatusMethod(
StatusMethod method
);

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StatusMethod.ToString Method

public override string ToString();

See Also

StatusMethod Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures Class

For a list of all members of this type, see SupportedFeatures Members.

System.Object
SupportedFeatures

public class SupportedFeatures

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SupportedFeatures Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures Members

SupportedFeatures overview

Public Instance Methods

canShareFolderOnly | Determines whether or not the server supports sharing a folder without sharing any of its subfolders or contained items.
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
hasBLSLicensing | Obsolete. Returns true if the server supports licenses managed by the Borland License Server. This feature first appeared in the 7.1 release.
hasBulkCreateLinks | Determines whether or not the server can create multiple links via a single server command.
hasBulkFetchLinks | Determines whether or not the server fetch links for multiple items via a single server command.
hasClientManagedFileStatus | Obsolete. Return true if file status is stored locally rather than by the server.
hasConcurrentLicensing | Obsolete. Return true if the server supports concurrent licensing.
hasCurrentTime | Determines whether or not the server can report its current time.
hasCustomTranslations | Obsolete. Return true if property and enum names can have customized display names for clients in different locales. This first appeared in the 5.4 release.
hasDeletedItems | Determines whether or not the server supports retrieval of information regarding deleted items.
hasDiagnostics | Obsolete. Determines whether or not the server supports server configuration diagnostic properties. This feature first appeared in the 6.0 release, command api 1.12.
hasDiagnosticStatisticsReporting | Determines whether or not this server can report diagnostic statistics. This feature was added in StarTeam 10.4.
hasDirectoryServiceSupport | Obsolete. Return true if Directory Service is supported. This first appeared in the 6.0 release.
hasEnhancedProcessItemCustomizations | Determines whether or not this is a StarTeam 9.0 or earlier server that has been customized to support the enhanced process item model.
hasEnhancedProcessItems | Determines whether or not this server has at least partial support for the enhanced process item model. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task. <p> StarTeam server versions 9.1 and later have full support for the enhanced process item model. Earlier servers must be customized in order to support the enhanced model on add and checkin operations.
hasEnhancedProcessItemsNative | Determines whether or not this server has native support for the enhanced process item model. These features were added in StarTeam 9.1.
hasFileEOLFormat | Determines whether or not the server supports setting the EOLFormat of a file. This feature is supported for StarTeam 2006 and later.
hasFileExecutablePermission | Obsolete. Return true if the "executable" permission for files is maintained and restored on checkout.
hasFolderComponentAccessRights | Return true if the server supports component-level access rights for Folders. This first appeared in 9.0.42 release.
hasForwardCompatibility | Obsolete. Returns true if older clients can talk to newer servers. This first appeared in the 5.3 release.
hasGroupMembers | Obsolete. Return true if the server can provide group membership information without requiring special privileges.
hasItemRevision | Obsolete. Determines whether or not the server supports ItemRevision. This feature first appeared in the 7.0 release, command api 1.17.
hasLabelCommandsOnRolledBackView | Determins whether or not the server supports the following Label operations in rolled back views: 1. attachment, 2. detachment 3. movement.
hasLabelCopy | Obsolete. Determines whether or not labels can be copied. This feature first appeared in the 4.0 release.
hasLabelLocking | Obsolete. Returns true if the server supports the locking (freezing) of labels. This first appeared in the 4.1 release.
hasLicenseUsage | Return true if server supports "License Usage" feature.
hasLinkParentFolderItemID | Obsolete. Determines whether or not the server supports retrieving parent Folder Item ID on a Link object. It affects the value returned from the calls to Link.getParentFolderItemID(). This feature first appeared in the 7.0 release, command api 1.16.
hasLongFileSizes | Determines whether or not file sizes greater than 2GB are supported.
hasMergeHistory | Obsolete. Determines whether or not the server supports MergeHistory feature. This feature first appeared in the 7.0 release, command api 1.17.
hasMergeService | Obsolete. Determines whether or not merge service is available. This feature first appeared in 4.2 SP3 release.
hasMultiCommandTransactions | Determines whether or not the server supports multi-command transactions. Transactions are currently supported in checkin and view compare/merge. This feature first appeared in the 9.0 release.
hasNamedConfigOptions | Obsolete. Determines whether or not the server supports named server configuration options. This feature first appeared in the 6.0 release, command api 1.12.
hasNativeIIVault | Obsolete. Determines whether or not the server supports the new "NativeII" vault format. This feature first appeared in the 7.0 release.
hasNewAuditProperties | Obsolete. Return true if server supports additional new properties for Audit items.
hasNewUserCertificate | Return true if server supports "New User Certificate" feature.
hasNoTimeoutNamedLicenses | Obsolete. Reports whether the server supports "NoTimeoutNamedLicenses" feature. It first appeared in the 7.0 release.
hasNOTQueryOperator | Obsolete. Return true if queries can be built using the NOT operator. This first appeared in the 5.3 release.
hasObjectOwnership | Determines whether or not the server supports "Object Ownership". This feature had been removed in command api 1.35.
hasOnlinePurgeControl |
hasPromotionStateRights | Obsolete. Return true if access rights are set on individual promotion states This first appeared in the 5.3 release.
hasPVCSSupport | Determines whether or not PVCS foreign archives are supported.
hasReconnect | Obsolete. Determines whether or not the server supports reconnect features. This feature first appeared in the 6.0 release.
hasSecureDirectoryService | Obsolete. Determines whether or not the server supports "Secure Directory Service (LDAPS)" feature. This feature first appeaered in the 7.0 release, command api 1.19.
hasServerCommandStats | Obsolete. Determines whether or not the server supports retrieval of command statistics. This feature first appeared in the 5.1 release.
hasServerExclusiveLock | Returns true if the server can be locked exclusively for the use of a specific user. This feature first appeared in the 5.1 release.
hasServerLicenseInfo | Obsolete. Return true if the server license information is available.
hasServerLock | Obsolete. Returns true if the server supports server locking enhancements. The name of this method is misleading, and therefore the method has been deprecated.
hasServerLockStatus | Obsolete. Returns true if the server can report its current lock status.
hasServerShutdown | Obsolete. Return true if the server can be shut down and restarted remotely from a client application.
hasVSSSupport | Determines whether or not VSS foreign archives are supported.
isServerLocalized | Obsolete. Return true if the server is localized. This first appeared in the 5.4 release.
isShareTreeTimeBased | If the share tree is time based, then Item.getReferences() returns a share tree that depends on the view configuration. For a rolled back view configuration, the share tree lists only those references that existed at that point in time. If the share tree is not time based, then Item.getReferences() always returns all the references that have been created to date, even for a rolled back view configuration.
MemberwiseClone |
toDebugString |
ToString |

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures Methods

The methods of the SupportedFeatures class are listed below. For a complete list of SupportedFeatures class members, see the SupportedFeatures Members topic.

Public Instance Methods

canShareFolderOnly | Determines whether or not the server supports sharing a folder without sharing any of its subfolders or contained items.
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
hasBLSLicensing | Obsolete. Returns true if the server supports licenses managed by the Borland License Server. This feature first appeared in the 7.1 release.
hasBulkCreateLinks | Determines whether or not the server can create multiple links via a single server command.
hasBulkFetchLinks | Determines whether or not the server fetch links for multiple items via a single server command.
hasClientManagedFileStatus | Obsolete. Return true if file status is stored locally rather than by the server.
hasConcurrentLicensing | Obsolete. Return true if the server supports concurrent licensing.
hasCurrentTime | Determines whether or not the server can report its current time.
hasCustomTranslations | Obsolete. Return true if property and enum names can have customized display names for clients in different locales. This first appeared in the 5.4 release.
hasDeletedItems | Determines whether or not the server supports retrieval of information regarding deleted items.
hasDiagnostics | Obsolete. Determines whether or not the server supports server configuration diagnostic properties. This feature first appeared in the 6.0 release, command api 1.12.
hasDiagnosticStatisticsReporting | Determines whether or not this server can report diagnostic statistics. This feature was added in StarTeam 10.4.
hasDirectoryServiceSupport | Obsolete. Return true if Directory Service is supported. This first appeared in the 6.0 release.
hasEnhancedProcessItemCustomizations | Determines whether or not this is a StarTeam 9.0 or earlier server that has been customized to support the enhanced process item model.
hasEnhancedProcessItems | Determines whether or not this server has at least partial support for the enhanced process item model. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task. <p> StarTeam server versions 9.1 and later have full support for the enhanced process item model. Earlier servers must be customized in order to support the enhanced model on add and checkin operations.
hasEnhancedProcessItemsNative | Determines whether or not this server has native support for the enhanced process item model. These features were added in StarTeam 9.1.
hasFileEOLFormat | Determines whether or not the server supports setting the EOLFormat of a file. This feature is supported for StarTeam 2006 and later.
hasFileExecutablePermission | Obsolete. Return true if the "executable" permission for files is maintained and restored on checkout.
hasFolderComponentAccessRights | Return true if the server supports component-level access rights for Folders. This first appeared in 9.0.42 release.
hasForwardCompatibility | Obsolete. Returns true if older clients can talk to newer servers. This first appeared in the 5.3 release.
hasGroupMembers | Obsolete. Return true if the server can provide group membership information without requiring special privileges.
hasItemRevision | Obsolete. Determines whether or not the server supports ItemRevision. This feature first appeared in the 7.0 release, command api 1.17.
hasLabelCommandsOnRolledBackView | Determins whether or not the server supports the following Label operations in rolled back views: 1. attachment, 2. detachment 3. movement.
hasLabelCopy | Obsolete. Determines whether or not labels can be copied. This feature first appeared in the 4.0 release.
hasLabelLocking | Obsolete. Returns true if the server supports the locking (freezing) of labels. This first appeared in the 4.1 release.
hasLicenseUsage | Return true if server supports "License Usage" feature.
hasLinkParentFolderItemID | Obsolete. Determines whether or not the server supports retrieving parent Folder Item ID on a Link object. It affects the value returned from the calls to Link.getParentFolderItemID(). This feature first appeared in the 7.0 release, command api 1.16.
hasLongFileSizes | Determines whether or not file sizes greater than 2GB are supported.
hasMergeHistory | Obsolete. Determines whether or not the server supports MergeHistory feature. This feature first appeared in the 7.0 release, command api 1.17.
hasMergeService | Obsolete. Determines whether or not merge service is available. This feature first appeared in 4.2 SP3 release.
hasMultiCommandTransactions | Determines whether or not the server supports multi-command transactions. Transactions are currently supported in checkin and view compare/merge. This feature first appeared in the 9.0 release.
hasNamedConfigOptions | Obsolete. Determines whether or not the server supports named server configuration options. This feature first appeared in the 6.0 release, command api 1.12.
hasNativeIIVault | Obsolete. Determines whether or not the server supports the new "NativeII" vault format. This feature first appeared in the 7.0 release.
hasNewAuditProperties | Obsolete. Return true if server supports additional new properties for Audit items.
hasNewUserCertificate | Return true if server supports "New User Certificate" feature.
hasNoTimeoutNamedLicenses | Obsolete. Reports whether the server supports "NoTimeoutNamedLicenses" feature. It first appeared in the 7.0 release.
hasNOTQueryOperator | Obsolete. Return true if queries can be built using the NOT operator. This first appeared in the 5.3 release.
hasObjectOwnership | Determines whether or not the server supports "Object Ownership". This feature had been removed in command api 1.35.
hasOnlinePurgeControl |
hasPromotionStateRights | Obsolete. Return true if access rights are set on individual promotion states This first appeared in the 5.3 release.
hasPVCSSupport | Determines whether or not PVCS foreign archives are supported.
hasReconnect | Obsolete. Determines whether or not the server supports reconnect features. This feature first appeared in the 6.0 release.
hasSecureDirectoryService | Obsolete. Determines whether or not the server supports "Secure Directory Service (LDAPS)" feature. This feature first appeaered in the 7.0 release, command api 1.19.
hasServerCommandStats | Obsolete. Determines whether or not the server supports retrieval of command statistics. This feature first appeared in the 5.1 release.
hasServerExclusiveLock | Returns true if the server can be locked exclusively for the use of a specific user. This feature first appeared in the 5.1 release.
hasServerLicenseInfo | Obsolete. Return true if the server license information is available.
hasServerLock | Obsolete. Returns true if the server supports server locking enhancements. The name of this method is misleading, and therefore the method has been deprecated.
hasServerLockStatus | Obsolete. Returns true if the server can report its current lock status.
hasServerShutdown | Obsolete. Return true if the server can be shut down and restarted remotely from a client application.
hasVSSSupport | Determines whether or not VSS foreign archives are supported.
isServerLocalized | Obsolete. Return true if the server is localized. This first appeared in the 5.4 release.
isShareTreeTimeBased | If the share tree is time based, then Item.getReferences() returns a share tree that depends on the view configuration. For a rolled back view configuration, the share tree lists only those references that existed at that point in time. If the share tree is not time based, then Item.getReferences() always returns all the references that have been created to date, even for a rolled back view configuration.
MemberwiseClone |
toDebugString |
ToString |

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.canShareFolderOnly Method

Determines whether or not the server supports sharing a folder without sharing any of its subfolders or contained items.

public virtual bool canShareFolderOnly();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.Equals Method

public override bool Equals(
Object source
);

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.GetHashCode Method

public override int GetHashCode();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasBLSLicensing Method

NOTE: This method is now obsolete.

Returns true if the server supports licenses managed by the Borland License Server. This feature first appeared in the 7.1 release.

public virtual bool hasBLSLicensing();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasBulkCreateLinks Method

Determines whether or not the server can create multiple links via a single server command.

public virtual bool hasBulkCreateLinks();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasBulkFetchLinks Method

Determines whether or not the server fetch links for multiple items via a single server command.

public virtual bool hasBulkFetchLinks();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasClientManagedFileStatus Method

NOTE: This method is now obsolete.

Return true if file status is stored locally rather than by the server.

public virtual bool hasClientManagedFileStatus();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasConcurrentLicensing Method

NOTE: This method is now obsolete.

Return true if the server supports concurrent licensing.

public virtual bool hasConcurrentLicensing();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasCurrentTime Method

Determines whether or not the server can report its current time.

public virtual bool hasCurrentTime();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasCustomTranslations Method

NOTE: This method is now obsolete.

Return true if property and enum names can have customized display names for clients in different locales. This first appeared in the 5.4 release.

public virtual bool hasCustomTranslations();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasDeletedItems Method

Determines whether or not the server supports retrieval of information regarding deleted items.

public virtual bool hasDeletedItems();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasDiagnostics Method

NOTE: This method is now obsolete.

Determines whether or not the server supports server configuration diagnostic properties. This feature first appeared in the 6.0 release, command api 1.12.

public virtual bool hasDiagnostics();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasDiagnosticStatisticsReporting Method

Determines whether or not this server can report diagnostic statistics. This feature was added in StarTeam 10.4.

public virtual bool hasDiagnosticStatisticsReporting();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasDirectoryServiceSupport Method

NOTE: This method is now obsolete.

Return true if Directory Service is supported. This first appeared in the 6.0 release.

public virtual bool hasDirectoryServiceSupport();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasEnhancedProcessItemCustomizations Method

Determines whether or not this is a StarTeam 9.0 or earlier server that has been customized to support the enhanced process item model.

public virtual bool hasEnhancedProcessItemCustomizations();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasEnhancedProcessItems Method

Determines whether or not this server has at least partial support for the enhanced process item model. In the enhanced model, changed files and folders are linked to process items indirectly, via a view-specific process task. <p> StarTeam server versions 9.1 and later have full support for the enhanced process item model. Earlier servers must be customized in order to support the enhanced model on add and checkin operations.

public virtual bool hasEnhancedProcessItems();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasEnhancedProcessItemsNative Method

Determines whether or not this server has native support for the enhanced process item model. These features were added in StarTeam 9.1.

public virtual bool hasEnhancedProcessItemsNative();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasFileEOLFormat Method

Determines whether or not the server supports setting the EOLFormat of a file. This feature is supported for StarTeam 2006 and later.

public virtual bool hasFileEOLFormat();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasFileExecutablePermission Method

NOTE: This method is now obsolete.

Return true if the "executable" permission for files is maintained and restored on checkout.

public virtual bool hasFileExecutablePermission();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasFolderComponentAccessRights Method

Return true if the server supports component-level access rights for Folders. This first appeared in 9.0.42 release.

public virtual bool hasFolderComponentAccessRights();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasForwardCompatibility Method

NOTE: This method is now obsolete.

Returns true if older clients can talk to newer servers. This first appeared in the 5.3 release.

public virtual bool hasForwardCompatibility();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasGroupMembers Method

NOTE: This method is now obsolete.

Return true if the server can provide group membership information without requiring special privileges.

public virtual bool hasGroupMembers();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasItemRevision Method

NOTE: This method is now obsolete.

Determines whether or not the server supports ItemRevision. This feature first appeared in the 7.0 release, command api 1.17.

public virtual bool hasItemRevision();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasLabelCommandsOnRolledBackView Method

Determins whether or not the server supports the following Label operations in rolled back views: 1. attachment, 2. detachment 3. movement.

public virtual bool hasLabelCommandsOnRolledBackView();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasLabelCopy Method

NOTE: This method is now obsolete.

Determines whether or not labels can be copied. This feature first appeared in the 4.0 release.

public virtual bool hasLabelCopy();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasLabelLocking Method

NOTE: This method is now obsolete.

Returns true if the server supports the locking (freezing) of labels. This first appeared in the 4.1 release.

public virtual bool hasLabelLocking();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasLicenseUsage Method

Return true if server supports "License Usage" feature.

public virtual bool hasLicenseUsage();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasLinkParentFolderItemID Method

NOTE: This method is now obsolete.

Determines whether or not the server supports retrieving parent Folder Item ID on a Link object. It affects the value returned from the calls to Link.getParentFolderItemID(). This feature first appeared in the 7.0 release, command api 1.16.

public virtual bool hasLinkParentFolderItemID();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasLongFileSizes Method

Determines whether or not file sizes greater than 2GB are supported.

public virtual bool hasLongFileSizes();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasMergeHistory Method

NOTE: This method is now obsolete.

Determines whether or not the server supports MergeHistory feature. This feature first appeared in the 7.0 release, command api 1.17.

public virtual bool hasMergeHistory();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasMergeService Method

NOTE: This method is now obsolete.

Determines whether or not merge service is available. This feature first appeared in 4.2 SP3 release.

public virtual bool hasMergeService();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasMultiCommandTransactions Method

Determines whether or not the server supports multi-command transactions. Transactions are currently supported in checkin and view compare/merge. This feature first appeared in the 9.0 release.

public virtual bool hasMultiCommandTransactions();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasNamedConfigOptions Method

NOTE: This method is now obsolete.

Determines whether or not the server supports named server configuration options. This feature first appeared in the 6.0 release, command api 1.12.

public virtual bool hasNamedConfigOptions();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasNativeIIVault Method

NOTE: This method is now obsolete.

Determines whether or not the server supports the new "NativeII" vault format. This feature first appeared in the 7.0 release.

public virtual bool hasNativeIIVault();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasNewAuditProperties Method

NOTE: This method is now obsolete.

Return true if server supports additional new properties for Audit items.

public virtual bool hasNewAuditProperties();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasNewUserCertificate Method

Return true if server supports "New User Certificate" feature.

public virtual bool hasNewUserCertificate();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasNoTimeoutNamedLicenses Method

NOTE: This method is now obsolete.

Reports whether the server supports "NoTimeoutNamedLicenses" feature. It first appeared in the 7.0 release.

public virtual bool hasNoTimeoutNamedLicenses();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasNOTQueryOperator Method

NOTE: This method is now obsolete.

Return true if queries can be built using the NOT operator. This first appeared in the 5.3 release.

public virtual bool hasNOTQueryOperator();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasObjectOwnership Method

Determines whether or not the server supports "Object Ownership". This feature had been removed in command api 1.35.

public virtual bool hasObjectOwnership();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasOnlinePurgeControl Method

public virtual bool hasOnlinePurgeControl();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasPromotionStateRights Method

NOTE: This method is now obsolete.

Return true if access rights are set on individual promotion states This first appeared in the 5.3 release.

public virtual bool hasPromotionStateRights();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasPVCSSupport Method

Determines whether or not PVCS foreign archives are supported.

public virtual bool hasPVCSSupport();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasReconnect Method

NOTE: This method is now obsolete.

Determines whether or not the server supports reconnect features. This feature first appeared in the 6.0 release.

public virtual bool hasReconnect();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasSecureDirectoryService Method

NOTE: This method is now obsolete.

Determines whether or not the server supports "Secure Directory Service (LDAPS)" feature. This feature first appeaered in the 7.0 release, command api 1.19.

public virtual bool hasSecureDirectoryService();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasServerCommandStats Method

NOTE: This method is now obsolete.

Determines whether or not the server supports retrieval of command statistics. This feature first appeared in the 5.1 release.

public virtual bool hasServerCommandStats();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasServerExclusiveLock Method

Returns true if the server can be locked exclusively for the use of a specific user. This feature first appeared in the 5.1 release.

public virtual bool hasServerExclusiveLock();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasServerLicenseInfo Method

NOTE: This method is now obsolete.

Return true if the server license information is available.

public virtual bool hasServerLicenseInfo();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasServerLock Method

NOTE: This method is now obsolete.

Returns true if the server supports server locking enhancements. The name of this method is misleading, and therefore the method has been deprecated.

public virtual bool hasServerLock();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasServerLockStatus Method

NOTE: This method is now obsolete.

Returns true if the server can report its current lock status.

public virtual bool hasServerLockStatus();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasServerShutdown Method

NOTE: This method is now obsolete.

Return true if the server can be shut down and restarted remotely from a client application.

public virtual bool hasServerShutdown();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.hasVSSSupport Method

Determines whether or not VSS foreign archives are supported.

public virtual bool hasVSSSupport();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.isServerLocalized Method

NOTE: This method is now obsolete.

Return true if the server is localized. This first appeared in the 5.4 release.

public virtual bool isServerLocalized();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.isShareTreeTimeBased Method

If the share tree is time based, then Item.getReferences() returns a share tree that depends on the view configuration. For a rolled back view configuration, the share tree lists only those references that existed at that point in time. If the share tree is not time based, then Item.getReferences() always returns all the references that have been created to date, even for a rolled back view configuration.

public virtual bool isShareTreeTimeBased();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.MemberwiseClone Method

public override object MemberwiseClone();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.toDebugString Method

public virtual string toDebugString();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SupportedFeatures.ToString Method

public override string ToString();

See Also

SupportedFeatures Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy Class

For a list of all members of this type, see SystemPolicy Members.

System.Object
SystemPolicy

public class SystemPolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SystemPolicy Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy Members

SystemPolicy overview

Public Static Fields

ALLOW_BLANK_PASSWORDS
FAILED_LOGIN_NO_LIMIT
LOCKOUT_FOREVER
PASSWORDS_NEVER_EXPIRE
SECURITYLOG_AUTOPURGE_DEFAULT
SECURITYLOG_AUTOPURGE_NEVER

Public Instance Constructors

SystemPolicy Constructor construct a SystemPolicy instance from the specified source

Public Instance Methods

copy | returns a copy of this SystemPolicy instance
Equals |
getFailedLoginLimit | Gets the number of acceptable failed login attempts.
getFailedLoginLockout | Gets the number of minutes a user will be locked out after exceeding the failed login limit.
GetHashCode |
getMinimumPasswordLength | Gets the minimum allowable password length.
getNotifyByEmail | Indicates whether or not security administrators will be notified of login lockouts by email.
getPasswordExpirationPeriod | Gets the number of days after which a password will expire.
getSecurityLogAutoPurgeDays | Gets the number of days of information that will be saved in the server's security log. This property is supported by StarTeam 4.1 or later.
getSkipGroupPrivilegesCheck | Indicates whether or not access validation will ignore group privileges. This property is supported by StarTeam 4.2 or later.
getSkipOwnershipCheck | Indicates whether or not access validation will ignore object ownership. This property is supported by StarTeam 4.2 or later.
getStrongPasswordRulesEnforced | Indicates whether or not strong password rules are enforced.
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo | returns true if the paramter is a System Policy whose values are identical to those of this instance
isStrongPasswordRulesSupported | Obsolete. Indicates whether or not the "strong password rules" feature is supported by the server.
MemberwiseClone |
setFailedLoginLimit |
setFailedLoginLockout |
setMinimumPasswordLength |
setNotifyByEmail |
setPasswordExpirationPeriod |
setSecurityLogAutoPurgeDays |
setSkipGroupPrivilegesCheck |
setSkipOwnershipCheck |
setStrongPasswordRulesEnforced |
ToString |

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy Constructor

construct a SystemPolicy instance from the specified source

public SystemPolicy(
SystemPolicy source
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy Fields

The fields of the SystemPolicy class are listed below. For a complete list of SystemPolicy class members, see the SystemPolicy Members topic.

Public Static Fields

ALLOW_BLANK_PASSWORDS
FAILED_LOGIN_NO_LIMIT
LOCKOUT_FOREVER
PASSWORDS_NEVER_EXPIRE
SECURITYLOG_AUTOPURGE_DEFAULT
SECURITYLOG_AUTOPURGE_NEVER

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.ALLOW_BLANK_PASSWORDS Field

public const Int32 ALLOW_BLANK_PASSWORDS = 0;

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.FAILED_LOGIN_NO_LIMIT Field

public const Int32 FAILED_LOGIN_NO_LIMIT = 2147483647;

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.LOCKOUT_FOREVER Field

public const Int32 LOCKOUT_FOREVER = 2147483647;

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.PASSWORDS_NEVER_EXPIRE Field

public const Int32 PASSWORDS_NEVER_EXPIRE = 2147483647;

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.SECURITYLOG_AUTOPURGE_DEFAULT Field

public const Int32 SECURITYLOG_AUTOPURGE_DEFAULT = 180;

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.SECURITYLOG_AUTOPURGE_NEVER Field

public const Int32 SECURITYLOG_AUTOPURGE_NEVER = 0;

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy Methods

The methods of the SystemPolicy class are listed below. For a complete list of SystemPolicy class members, see the SystemPolicy Members topic.

Public Instance Methods

copy | returns a copy of this SystemPolicy instance
Equals |
getFailedLoginLimit | Gets the number of acceptable failed login attempts.
getFailedLoginLockout | Gets the number of minutes a user will be locked out after exceeding the failed login limit.
GetHashCode |
getMinimumPasswordLength | Gets the minimum allowable password length.
getNotifyByEmail | Indicates whether or not security administrators will be notified of login lockouts by email.
getPasswordExpirationPeriod | Gets the number of days after which a password will expire.
getSecurityLogAutoPurgeDays | Gets the number of days of information that will be saved in the server's security log. This property is supported by StarTeam 4.1 or later.
getSkipGroupPrivilegesCheck | Indicates whether or not access validation will ignore group privileges. This property is supported by StarTeam 4.2 or later.
getSkipOwnershipCheck | Indicates whether or not access validation will ignore object ownership. This property is supported by StarTeam 4.2 or later.
getStrongPasswordRulesEnforced | Indicates whether or not strong password rules are enforced.
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo | returns true if the paramter is a System Policy whose values are identical to those of this instance
isStrongPasswordRulesSupported | Obsolete. Indicates whether or not the "strong password rules" feature is supported by the server.
MemberwiseClone |
setFailedLoginLimit |
setFailedLoginLockout |
setMinimumPasswordLength |
setNotifyByEmail |
setPasswordExpirationPeriod |
setSecurityLogAutoPurgeDays |
setSkipGroupPrivilegesCheck |
setSkipOwnershipCheck |
setStrongPasswordRulesEnforced |
ToString |

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.copy Method

returns a copy of this SystemPolicy instance

public virtual SystemPolicy copy();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.Equals Method

public override bool Equals(
Object theOther
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.getFailedLoginLimit Method

Gets the number of acceptable failed login attempts.

public virtual int getFailedLoginLimit();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.getFailedLoginLockout Method

Gets the number of minutes a user will be locked out after exceeding the failed login limit.

public virtual int getFailedLoginLockout();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.GetHashCode Method

public override int GetHashCode();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.getMinimumPasswordLength Method

Gets the minimum allowable password length.

public virtual int getMinimumPasswordLength();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.getNotifyByEmail Method

Indicates whether or not security administrators will be notified of login lockouts by email.

public virtual bool getNotifyByEmail();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.getPasswordExpirationPeriod Method

Gets the number of days after which a password will expire.

public virtual int getPasswordExpirationPeriod();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.getSecurityLogAutoPurgeDays Method

Gets the number of days of information that will be saved in the server's security log. This property is supported by StarTeam 4.1 or later.

public virtual int getSecurityLogAutoPurgeDays();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.getSkipGroupPrivilegesCheck Method

Indicates whether or not access validation will ignore group privileges. This property is supported by StarTeam 4.2 or later.

public virtual bool getSkipGroupPrivilegesCheck();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.getSkipOwnershipCheck Method

Indicates whether or not access validation will ignore object ownership. This property is supported by StarTeam 4.2 or later.

public virtual bool getSkipOwnershipCheck();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.getStrongPasswordRulesEnforced Method

Indicates whether or not strong password rules are enforced.

public virtual bool getStrongPasswordRulesEnforced();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.isEqualTo Method

returns true if the paramter is a System Policy whose values are identical to those of this instance

public virtual bool isEqualTo(
SystemPolicy theOther
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.isStrongPasswordRulesSupported Method

NOTE: This method is now obsolete.

Indicates whether or not the "strong password rules" feature is supported by the server.

public virtual bool isStrongPasswordRulesSupported();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.MemberwiseClone Method

public override object MemberwiseClone();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.setFailedLoginLimit Method

public virtual void setFailedLoginLimit(
Int32 nAttempts
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.setFailedLoginLockout Method

public virtual void setFailedLoginLockout(
Int32 nMinutes
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.setMinimumPasswordLength Method

public virtual void setMinimumPasswordLength(
Int32 length
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.setNotifyByEmail Method

public virtual void setNotifyByEmail(
Boolean bAlert
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.setPasswordExpirationPeriod Method

public virtual void setPasswordExpirationPeriod(
Int32 nDays
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.setSecurityLogAutoPurgeDays Method

public virtual void setSecurityLogAutoPurgeDays(
Int32 nDays
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.setSkipGroupPrivilegesCheck Method

public virtual void setSkipGroupPrivilegesCheck(
Boolean bSkip
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.setSkipOwnershipCheck Method

public virtual void setSkipOwnershipCheck(
Boolean bSkip
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.setStrongPasswordRulesEnforced Method

public virtual void setStrongPasswordRulesEnforced(
Boolean bStrongPasswords
);

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemPolicy.ToString Method

public override string ToString();

See Also

SystemPolicy Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task Class

For a list of all members of this type, see Task Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Item
TreeItem
Task

public class Task : TreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Task Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task Members

Task overview

Public Instance Constructors

Task Overloaded. Initializes a new instance of the Task class.

Public Instance Methods

acquireOwnership (inherited from Item)
addAttachment (inherited from Item)
addPredecessorLink
addResource
addToIntArray (inherited from TypedResource)
addWorkRecord | Obsolete. Adds a work record to this task.
Clone (inherited from CacheRef)
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
createChild (inherited from TreeItem) | Creates a new child item.
createWorkRecord | Creates a new WorkRecord for the specified Task and user.
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard
Equals
get (inherited from Item)
getACL (inherited from Item)
getActualFinish | Returns the actual finish date of this task.
getActualHours | Returns the actual number of hours spent on this task.
getActualStart | Returns the actual start date of this task.
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getAttentionNotes | Returns the text in the "Needs Attention" note for this task.
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getChildrenCount | Returns the number of tasks that are subtasks of this one.
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getConstraintDate | Returns the task's Constraint Date from MS Project.
getConstraintType | Returns the MS Project Constraint Type of this task.
getConstraintTypeDisplayName
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDependencyLastUpdate | Returns the date that a work record or task dependency (predecessor or successor) was last added to this task.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getDuration | Returns the number of hours during which at least one user is working on this task.
getEnumDisplayName (inherited from Item)
getEstimatedFinish | Returns the estimated date at which this task will be completed.
getEstimatedFinishVariance | Returns the Estimated Finish Variance of this task.
getEstimatedHours | Returns an estimate of the number of hours that will be spent completing this task.
getEstimatedHoursVariance | Returns the Estimated Hours Variance of this task.
getEstimatedStart | Returns the estimated start date of this task.
getEstimatedStartVariance | Returns the Estimated Start Variance of this task.
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
getGUID | Returns the MS Project GUID of this task.
GetHashCode
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getIsMyTask | Returns a value indicating whether the logged on user is responsible for this task.
getIsMyTaskDisplayName
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getMilestone | Returns a value indicating whether or not this task represents a milestone.
getMilestoneDisplayName
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMSProjectFileName | Returns the MS Project FileName of this task.
getMSProjectLastUpdate | Returns the date that this task was last updated from MS Project.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getName | Returns the Name of this task.
getNeedsAttention | Returns a value that indicates whether or not this task needs attention.
getNeedsAttentionDisplayName
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getNotes | Returns the text in the "Notes" for this task.
getNumber | Returns the number assigned to this task.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOrigin | Returns a value indicating the origin (e.g., StarTeam or MS Project) of this task.
getOriginDisplayName
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentID
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPercentComplete | Returns a percentage indicating how much of the task has been completed.
getPossibleConstraintType | Returns the possible enum codes that are valid values for the ConstraintType property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleIsMyTask | Returns the possible enum codes that are valid values for the IsMyTask property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleMilestone | Returns the possible enum codes that are valid values for the Milestone property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleNeedsAttention | Returns the possible enum codes that are valid values for the NeedsAttention property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleOrigin | Returns the possible enum codes that are valid values for the Origin property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossiblePriority | Returns the possible enum codes that are valid values for the Priority property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleStatus | Returns the possible enum codes that are valid values for the Status property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleTaskType | Returns the possible enum codes that are valid values for the TaskType property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPredecessorLinks | Returns the predecessor tasks to this this task. The predecessors are represented by a <code>TaskDependency</code> object.
getPriority | Returns the Priority of this task.
getPriorityDisplayName
getPropertyNames (inherited from Item)
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getResourceCount | Returns the number of resources assigned to this task.
getResourceNames | Returns the names of the users assigned as resources of this task.
getResources | Returns the IDs of the users assigned as resources of this task.
getResponsibility | Returns the user ID of the user who is responsibile for this task.
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getStatus | Returns the Status of this task.
getStatusDisplayName
getString (inherited from Item)
getSuccessorLinks | Returns the successor tasks to this this task. The successors are represented by a <code>TaskDependency</code> object.
getTaskType | Returns the task's type in MS Project.
getTaskTypeDisplayName
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getUniqueID | Returns the MS Project UniqueID of this task.
getUsage | Gets the usage of this task.
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
getWBSCode | Returns the MS Project WBS Code of this task.
getWorkRecordCount | Returns the number of work records that have been added to this task.
getWorkRecords | Returns the work records associates with this task.
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isProcessTask | Determines whether or not this task is a process task.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReplicated | Returns true if this task is replicated in MS Project.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move (inherited from TreeItem) | Obsolete.
moveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified parent. Child items, if any, are also moved.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put
putByPropertyID (inherited from Item)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove (inherited from TreeItem)
removeAttachment (inherited from Item)
removeDependency | Removed the specified task dependency from this task. The dependency must be either a successor or predecessor to this task or an exception will be thrown.
removeFromIntArray (inherited from TypedResource)
removeResource
removeWorkRecord | Removes the work record from this task. The work record must already be associated with this task or an exception will be thrown.
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setAttentionNotes
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setDuration
setEstimatedFinish | Sets the estimated date at which this task will be completed.
setEstimatedStart | Sets the estimated start date of this task.
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setMilestone
setName
setNeedsAttention
setNotes
setOrigin
setPercentComplete
setPriority
setReplicated
setResponsibility
setStatus
setUsage | Sets the task usage. The usage determines whether or not this is a process task and, if so, the type of operation that created the task and its process links. <p> Internally, how the usage is stored depends on the StarTeam server version number. StarTeam server versions 9.5 and later have a system-defined TASK_USAGE property. Earlier servers may have a functionally equivalent TASK_USAGE_90 custom property. For earlier servers that have not been customized, setUsage() will trigger a NoSuchPropertyException.
shareTo (inherited from TreeItem)
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString (inherited from Item)
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update
updateRevisionComment (inherited from Item)

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task Constructor

Creates a new task in the specified folder.

Overload List

Creates a new task in the specified folder.

public Task(Folder);

Creates a new task that is a subtask of an existing task.

public Task(Task);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task Constructor (Folder)

Creates a new task in the specified folder.

public Task(
Folder parentFolder
);

See Also

Task Class | com.starbase.starteam Namespace | Task Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task Constructor (Task)

Creates a new task that is a subtask of an existing task.

public Task(
Task parentTask
);

See Also

Task Class | com.starbase.starteam Namespace | Task Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task Methods

The methods of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Instance Methods

acquireOwnership (inherited from Item)
addAttachment (inherited from Item)
addPredecessorLink
addResource
addToIntArray (inherited from TypedResource)
addWorkRecord | Obsolete. Adds a work record to this task.
Clone (inherited from CacheRef)
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
createChild (inherited from TreeItem) | Creates a new child item.
createWorkRecord | Creates a new WorkRecord for the specified Task and user.
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard
Equals
get (inherited from Item)
getACL (inherited from Item)
getActualFinish | Returns the actual finish date of this task.
getActualHours | Returns the actual number of hours spent on this task.
getActualStart | Returns the actual start date of this task.
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getAttentionNotes | Returns the text in the "Needs Attention" note for this task.
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getChildrenCount | Returns the number of tasks that are subtasks of this one.
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getConstraintDate | Returns the task's Constraint Date from MS Project.
getConstraintType | Returns the MS Project Constraint Type of this task.
getConstraintTypeDisplayName
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDependencyLastUpdate | Returns the date that a work record or task dependency (predecessor or successor) was last added to this task.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getDuration | Returns the number of hours during which at least one user is working on this task.
getEnumDisplayName (inherited from Item)
getEstimatedFinish | Returns the estimated date at which this task will be completed.
getEstimatedFinishVariance | Returns the Estimated Finish Variance of this task.
getEstimatedHours | Returns an estimate of the number of hours that will be spent completing this task.
getEstimatedHoursVariance | Returns the Estimated Hours Variance of this task.
getEstimatedStart | Returns the estimated start date of this task.
getEstimatedStartVariance | Returns the Estimated Start Variance of this task.
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
getGUID | Returns the MS Project GUID of this task.
GetHashCode
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getIsMyTask | Returns a value indicating whether the logged on user is responsible for this task.
getIsMyTaskDisplayName
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getMilestone | Returns a value indicating whether or not this task represents a milestone.
getMilestoneDisplayName
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMSProjectFileName | Returns the MS Project FileName of this task.
getMSProjectLastUpdate | Returns the date that this task was last updated from MS Project.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getName | Returns the Name of this task.
getNeedsAttention | Returns a value that indicates whether or not this task needs attention.
getNeedsAttentionDisplayName
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getNotes | Returns the text in the "Notes" for this task.
getNumber | Returns the number assigned to this task.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOrigin | Returns a value indicating the origin (e.g., StarTeam or MS Project) of this task.
getOriginDisplayName
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentID
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPercentComplete | Returns a percentage indicating how much of the task has been completed.
getPossibleConstraintType | Returns the possible enum codes that are valid values for the ConstraintType property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleIsMyTask | Returns the possible enum codes that are valid values for the IsMyTask property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleMilestone | Returns the possible enum codes that are valid values for the Milestone property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleNeedsAttention | Returns the possible enum codes that are valid values for the NeedsAttention property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleOrigin | Returns the possible enum codes that are valid values for the Origin property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossiblePriority | Returns the possible enum codes that are valid values for the Priority property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleStatus | Returns the possible enum codes that are valid values for the Status property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleTaskType | Returns the possible enum codes that are valid values for the TaskType property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPredecessorLinks | Returns the predecessor tasks to this this task. The predecessors are represented by a <code>TaskDependency</code> object.
getPriority | Returns the Priority of this task.
getPriorityDisplayName
getPropertyNames (inherited from Item)
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getResourceCount | Returns the number of resources assigned to this task.
getResourceNames | Returns the names of the users assigned as resources of this task.
getResources | Returns the IDs of the users assigned as resources of this task.
getResponsibility | Returns the user ID of the user who is responsibile for this task.
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getStatus | Returns the Status of this task.
getStatusDisplayName
getString (inherited from Item)
getSuccessorLinks | Returns the successor tasks to this this task. The successors are represented by a <code>TaskDependency</code> object.
getTaskType | Returns the task's type in MS Project.
getTaskTypeDisplayName
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getUniqueID | Returns the MS Project UniqueID of this task.
getUsage | Gets the usage of this task.
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
getWBSCode | Returns the MS Project WBS Code of this task.
getWorkRecordCount | Returns the number of work records that have been added to this task.
getWorkRecords | Returns the work records associates with this task.
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isProcessTask | Determines whether or not this task is a process task.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReplicated | Returns true if this task is replicated in MS Project.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move (inherited from TreeItem) | Obsolete.
moveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified parent. Child items, if any, are also moved.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put
putByPropertyID (inherited from Item)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove (inherited from TreeItem)
removeAttachment (inherited from Item)
removeDependency | Removed the specified task dependency from this task. The dependency must be either a successor or predecessor to this task or an exception will be thrown.
removeFromIntArray (inherited from TypedResource)
removeResource
removeWorkRecord | Removes the work record from this task. The work record must already be associated with this task or an exception will be thrown.
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setAttentionNotes
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setDuration
setEstimatedFinish | Sets the estimated date at which this task will be completed.
setEstimatedStart | Sets the estimated start date of this task.
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setMilestone
setName
setNeedsAttention
setNotes
setOrigin
setPercentComplete
setPriority
setReplicated
setResponsibility
setStatus
setUsage | Sets the task usage. The usage determines whether or not this is a process task and, if so, the type of operation that created the task and its process links. <p> Internally, how the usage is stored depends on the StarTeam server version number. StarTeam server versions 9.5 and later have a system-defined TASK_USAGE property. Earlier servers may have a functionally equivalent TASK_USAGE_90 custom property. For earlier servers that have not been customized, setUsage() will trigger a NoSuchPropertyException.
shareTo (inherited from TreeItem)
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString (inherited from Item)
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update
updateRevisionComment (inherited from Item)

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.addPredecessorLink Method

public virtual void addPredecessorLink(
Int32 predecessorID,
Int32 lagTime,
Int32 depType
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.addResource Method

public virtual void addResource(
Int32 userID
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.addWorkRecord Method

NOTE: This method is now obsolete.

Adds a work record to this task.

public virtual void addWorkRecord(
WorkRecord record
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.createWorkRecord Method

Creates a new WorkRecord for the specified Task and user.

public virtual WorkRecord createWorkRecord(
User user
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.discard Method

public override void discard();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.Equals Method

public override bool Equals(
Object source
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getActualFinish Method

Returns the actual finish date of this task.

public virtual OLEDate getActualFinish();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getActualHours Method

Returns the actual number of hours spent on this task.

public virtual double getActualHours();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getActualStart Method

Returns the actual start date of this task.

public virtual OLEDate getActualStart();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getAttentionNotes Method

Returns the text in the "Needs Attention" note for this task.

public virtual string getAttentionNotes();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getChildrenCount Method

Returns the number of tasks that are subtasks of this one.

public virtual int getChildrenCount();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getConstraintDate Method

Returns the task's Constraint Date from MS Project.

public virtual OLEDate getConstraintDate();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getConstraintType Method

Returns the MS Project Constraint Type of this task.

public virtual int getConstraintType();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getConstraintTypeDisplayName Method

public virtual string getConstraintTypeDisplayName(
Int32 value
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getDependencyLastUpdate Method

Returns the date that a work record or task dependency (predecessor or successor) was last added to this task.

public virtual OLEDate getDependencyLastUpdate();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getDuration Method

Returns the number of hours during which at least one user is working on this task.

public virtual double getDuration();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getEstimatedFinish Method

Returns the estimated date at which this task will be completed.

public virtual OLEDate getEstimatedFinish();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getEstimatedFinishVariance Method

Returns the Estimated Finish Variance of this task.

public virtual int getEstimatedFinishVariance();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getEstimatedHours Method

Returns an estimate of the number of hours that will be spent completing this task.

public virtual double getEstimatedHours();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getEstimatedHoursVariance Method

Returns the Estimated Hours Variance of this task.

public virtual double getEstimatedHoursVariance();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getEstimatedStart Method

Returns the estimated start date of this task.

public virtual OLEDate getEstimatedStart();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getEstimatedStartVariance Method

Returns the Estimated Start Variance of this task.

public virtual int getEstimatedStartVariance();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getGUID Method

Returns the MS Project GUID of this task.

public virtual string getGUID();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.GetHashCode Method

public override int GetHashCode();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getIsMyTask Method

Returns a value indicating whether the logged on user is responsible for this task.

public virtual int getIsMyTask();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getIsMyTaskDisplayName Method

public virtual string getIsMyTaskDisplayName(
Int32 value
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getMilestone Method

Returns a value indicating whether or not this task represents a milestone.

public virtual int getMilestone();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getMilestoneDisplayName Method

public virtual string getMilestoneDisplayName(
Int32 value
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getMSProjectFileName Method

Returns the MS Project FileName of this task.

public virtual string getMSProjectFileName();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getMSProjectLastUpdate Method

Returns the date that this task was last updated from MS Project.

public virtual OLEDate getMSProjectLastUpdate();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getName Method

Returns the Name of this task.

public virtual string getName();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getNeedsAttention Method

Returns a value that indicates whether or not this task needs attention.

public virtual int getNeedsAttention();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getNeedsAttentionDisplayName Method

public virtual string getNeedsAttentionDisplayName(
Int32 value
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getNotes Method

Returns the text in the "Notes" for this task.

public virtual string getNotes();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getNumber Method

Returns the number assigned to this task.

public virtual int getNumber();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getOrigin Method

Returns a value indicating the origin (e.g., StarTeam or MS Project) of this task.

public virtual int getOrigin();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getOriginDisplayName Method

public virtual string getOriginDisplayName(
Int32 value
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getParentID Method

public override int getParentID();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPercentComplete Method

Returns a percentage indicating how much of the task has been completed.

public virtual int getPercentComplete();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPossibleConstraintType Method

Returns the possible enum codes that are valid values for the ConstraintType property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleConstraintType();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPossibleIsMyTask Method

Returns the possible enum codes that are valid values for the IsMyTask property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleIsMyTask();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPossibleMilestone Method

Returns the possible enum codes that are valid values for the Milestone property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleMilestone();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPossibleNeedsAttention Method

Returns the possible enum codes that are valid values for the NeedsAttention property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleNeedsAttention();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPossibleOrigin Method

Returns the possible enum codes that are valid values for the Origin property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleOrigin();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPossiblePriority Method

Returns the possible enum codes that are valid values for the Priority property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossiblePriority();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPossibleStatus Method

Returns the possible enum codes that are valid values for the Status property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleStatus();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPossibleTaskType Method

Returns the possible enum codes that are valid values for the TaskType property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleTaskType();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPredecessorLinks Method

Returns the predecessor tasks to this this task. The predecessors are represented by a <code>TaskDependency</code> object.

public virtual TaskDependency[] getPredecessorLinks();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPriority Method

Returns the Priority of this task.

public virtual int getPriority();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getPriorityDisplayName Method

public virtual string getPriorityDisplayName(
Int32 value
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getResourceCount Method

Returns the number of resources assigned to this task.

public virtual int getResourceCount();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getResourceNames Method

Returns the names of the users assigned as resources of this task.

public virtual string[] getResourceNames();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getResources Method

Returns the IDs of the users assigned as resources of this task.

public virtual int[] getResources();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getResponsibility Method

Returns the user ID of the user who is responsibile for this task.

public virtual int getResponsibility();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getStatus Method

Returns the Status of this task.

public virtual int getStatus();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getStatusDisplayName Method

public virtual string getStatusDisplayName(
Int32 value
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getSuccessorLinks Method

Returns the successor tasks to this this task. The successors are represented by a <code>TaskDependency</code> object.

public virtual TaskDependency[] getSuccessorLinks();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getTaskType Method

Returns the task's type in MS Project.

public virtual int getTaskType();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getTaskTypeDisplayName Method

public virtual string getTaskTypeDisplayName(
Int32 value
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getUniqueID Method

Returns the MS Project UniqueID of this task.

public virtual int getUniqueID();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getUsage Method

Gets the usage of this task.

public virtual ProcessItemUsage getUsage();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getWBSCode Method

Returns the MS Project WBS Code of this task.

public virtual string getWBSCode();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getWorkRecordCount Method

Returns the number of work records that have been added to this task.

public virtual int getWorkRecordCount();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.getWorkRecords Method

Returns the work records associates with this task.

public virtual WorkRecord[] getWorkRecords();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.isDirty Method

public override bool isDirty();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.isProcessTask Method

Determines whether or not this task is a process task.

public virtual bool isProcessTask();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.isReplicated Method

Returns true if this task is replicated in MS Project.

public virtual bool isReplicated();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.put Method

public override object put(
String propertyName,
Object value
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.removeDependency Method

Removed the specified task dependency from this task. The dependency must be either a successor or predecessor to this task or an exception will be thrown.

public virtual void removeDependency(
TaskDependency dependency
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.removeResource Method

public virtual void removeResource(
Int32 userID
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.removeWorkRecord Method

Removes the work record from this task. The work record must already be associated with this task or an exception will be thrown.

public virtual void removeWorkRecord(
WorkRecord record
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setAttentionNotes Method

public virtual void setAttentionNotes(
String AttentionNotes
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setDuration Method

public virtual void setDuration(
Double Duration
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setEstimatedFinish Method

Sets the estimated date at which this task will be completed.

public virtual void setEstimatedFinish(
OLEDate EstimatedFinish
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setEstimatedStart Method

Sets the estimated start date of this task.

public virtual void setEstimatedStart(
OLEDate EstimatedStart
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setMilestone Method

public virtual void setMilestone(
Int32 Milestone
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setName Method

public virtual void setName(
String Name
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setNeedsAttention Method

public virtual void setNeedsAttention(
Int32 NeedsAttention
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setNotes Method

public virtual void setNotes(
String Notes
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setOrigin Method

public virtual void setOrigin(
Int32 origin
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setPercentComplete Method

public virtual void setPercentComplete(
Int32 PercentComplete
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setPriority Method

public virtual void setPriority(
Int32 Priority
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setReplicated Method

public virtual void setReplicated(
Boolean replicated
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setResponsibility Method

public virtual void setResponsibility(
Int32 userID
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setStatus Method

public virtual void setStatus(
Int32 Status
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.setUsage Method

Sets the task usage. The usage determines whether or not this is a process task and, if so, the type of operation that created the task and its process links. <p> Internally, how the usage is stored depends on the StarTeam server version number. StarTeam server versions 9.5 and later have a system-defined TASK_USAGE property. Earlier servers may have a functionally equivalent TASK_USAGE_90 custom property. For earlier servers that have not been customized, setUsage() will trigger a NoSuchPropertyException.

public virtual void setUsage(
ProcessItemUsage usage
);

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Task.update Method

public override void update();

See Also

Task Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency Class

For a list of all members of this type, see TaskDependency Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
TaskDependency

public class TaskDependency : SimpleTypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

TaskDependency Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency Members

TaskDependency overview

Public Instance Methods

addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get (inherited from SimpleTypedResource) |
getByteArray (inherited from SimpleTypedResource) |
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
GetHashCode |
getID |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLagTime | Returns the lag time for this task dependency.
getOLEDate (inherited from SimpleTypedResource) |
getPossiblePredecessorType | Returns the possible enum codes that are valid values for the PredecessorType property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from SimpleTypedResource) |
getPredecessorID | Returns the ObjectID of the predecessor Task.
getPredecessorType | Returns the PredecessorType of this task dependency.
getPredecessorTypeDisplayName |
getPropertyNames (inherited from SimpleTypedResource) |
getString (inherited from SimpleTypedResource) |
getTaskID | Returns the ObjectID of the successor Task.
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
isDirty | Returns true if this task dependency has been modified but not yet saved. Task dependencies are saved but updating the to corresponding <code>Task</code> object.
MemberwiseClone (inherited from CacheRef) |
put |
putByPropertyID (inherited from SimpleTypedResource) |
removeFromIntArray (inherited from TypedResource) |
setLagTime |
setPredecessorType |
ToString (inherited from TypedResource) |

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency Methods

The methods of the TaskDependency class are listed below. For a complete list of TaskDependency class members, see the TaskDependency Members topic.

Public Instance Methods

addToIntArray (inherited from TypedResource) |
Clone (inherited from CacheRef) |
Equals |
get (inherited from SimpleTypedResource) |
getByteArray (inherited from SimpleTypedResource) |
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
GetHashCode |
getID |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLagTime | Returns the lag time for this task dependency.
getOLEDate (inherited from SimpleTypedResource) |
getPossiblePredecessorType | Returns the possible enum codes that are valid values for the PredecessorType property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from SimpleTypedResource) |
getPredecessorID | Returns the ObjectID of the predecessor Task.
getPredecessorType | Returns the PredecessorType of this task dependency.
getPredecessorTypeDisplayName |
getPropertyNames (inherited from SimpleTypedResource) |
getString (inherited from SimpleTypedResource) |
getTaskID | Returns the ObjectID of the successor Task.
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
isDirty | Returns true if this task dependency has been modified but not yet saved. Task dependencies are saved but updating the to corresponding <code>Task</code> object.
MemberwiseClone (inherited from CacheRef) |
put |
putByPropertyID (inherited from SimpleTypedResource) |
removeFromIntArray (inherited from TypedResource) |
setLagTime |
setPredecessorType |
ToString (inherited from TypedResource) |

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.Equals Method

public override bool Equals(
Object source
);

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.GetHashCode Method

public override int GetHashCode();

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.getID Method

public override int getID();

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.getLagTime Method

Returns the lag time for this task dependency.

public virtual int getLagTime();

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.getPossiblePredecessorType Method

Returns the possible enum codes that are valid values for the PredecessorType property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossiblePredecessorType();

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.getPredecessorID Method

Returns the ObjectID of the predecessor Task.

public virtual int getPredecessorID();

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.getPredecessorType Method

Returns the PredecessorType of this task dependency.

public virtual int getPredecessorType();

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.getPredecessorTypeDisplayName Method

public virtual string getPredecessorTypeDisplayName(
Int32 value
);

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.getTaskID Method

Returns the ObjectID of the successor Task.

public virtual int getTaskID();

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.isDirty Method

Returns true if this task dependency has been modified but not yet saved. Task dependencies are saved but updating the to corresponding <code>Task</code> object.

public virtual bool isDirty();

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.put Method

public override object put(
String propertyName,
Object value
);

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.setLagTime Method

public virtual void setLagTime(
Int32 lagTime
);

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TaskDependency.setPredecessorType Method

public virtual void setPredecessorType(
Int32 Type
);

See Also

TaskDependency Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic Class

For a list of all members of this type, see Topic Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Item
TreeItem
Topic

public class Topic : TreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Topic Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic Members

Topic overview

Public Instance Constructors

Topic Overloaded. Initializes a new instance of the Topic class.

Public Instance Methods

acquireOwnership (inherited from Item)
addAttachment (inherited from Item)
addRecipient
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
createChild (inherited from TreeItem) | Creates a new child item.
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals
get (inherited from Item)
getACL (inherited from Item)
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAmIRecipient | Returns a value indicating whether the logged on user is a recipient of this topic.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getChildrenCount | Returns the number of topics that are subtopics of this one.
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getNumber | Returns the topic number of this topic.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentID (inherited from TreeItem) | Gets the ObjectID of this item's parent. Returns -1 if this task has no parent.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getParentTopic | Returns the object ID of this topic's parent. A value of -1 means the topic has no parent.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossiblePriority | Returns the possible enum codes that are valid values for the Priority property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus
getPossibleStatus | Returns the possible enum codes that are valid values for the Status property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPriority | Returns the Priority of this topic.
getPriorityDisplayName
getPropertyNames (inherited from Item)
getReadStatus
getReadStatusDisplayName
getRecipientCount | Returns the number of recipients assigned to this topic.
getRecipients | Returns the IDs of the users assigned as recipients of this topic.
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getStatus | Returns the Status of this topic.
getStatusDisplayName
getString (inherited from Item)
getText | Returns the text or body of the topic.
getTitle | Returns the title or subject of the topic.
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser
move (inherited from TreeItem) | Obsolete.
moveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified parent. Child items, if any, are also moved.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put (inherited from Item)
putByPropertyID (inherited from Item)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove (inherited from TreeItem)
removeAttachment (inherited from Item)
removeFromIntArray (inherited from TypedResource)
removeRecipient
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setPriority
setStatus
setText
setTitle
shareTo (inherited from TreeItem)
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString (inherited from Item)
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
updateRevisionComment (inherited from Item)

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic Constructor

Creates a new topic in the specified folder.

Overload List

Creates a new topic in the specified folder.

public Topic(Folder);

Creates a new topic that is a subtopic of an existing topic.

public Topic(Topic);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic Constructor (Folder)

Creates a new topic in the specified folder.

public Topic(
Folder parentFolder
);

See Also

Topic Class | com.starbase.starteam Namespace | Topic Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic Constructor (Topic)

Creates a new topic that is a subtopic of an existing topic.

public Topic(
Topic parentTopic
);

See Also

Topic Class | com.starbase.starteam Namespace | Topic Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic Methods

The methods of the Topic class are listed below. For a complete list of Topic class members, see the Topic Members topic.

Public Instance Methods

acquireOwnership (inherited from Item)
addAttachment (inherited from Item)
addRecipient
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
createChild (inherited from TreeItem) | Creates a new child item.
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals
get (inherited from Item)
getACL (inherited from Item)
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAmIRecipient | Returns a value indicating whether the logged on user is a recipient of this topic.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getChildrenCount | Returns the number of topics that are subtopics of this one.
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getNumber | Returns the topic number of this topic.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentID (inherited from TreeItem) | Gets the ObjectID of this item's parent. Returns -1 if this task has no parent.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getParentTopic | Returns the object ID of this topic's parent. A value of -1 means the topic has no parent.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossiblePriority | Returns the possible enum codes that are valid values for the Priority property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus
getPossibleStatus | Returns the possible enum codes that are valid values for the Status property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPriority | Returns the Priority of this topic.
getPriorityDisplayName
getPropertyNames (inherited from Item)
getReadStatus
getReadStatusDisplayName
getRecipientCount | Returns the number of recipients assigned to this topic.
getRecipients | Returns the IDs of the users assigned as recipients of this topic.
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getStatus | Returns the Status of this topic.
getStatusDisplayName
getString (inherited from Item)
getText | Returns the text or body of the topic.
getTitle | Returns the title or subject of the topic.
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser
move (inherited from TreeItem) | Obsolete.
moveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified parent. Child items, if any, are also moved.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put (inherited from Item)
putByPropertyID (inherited from Item)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove (inherited from TreeItem)
removeAttachment (inherited from Item)
removeFromIntArray (inherited from TypedResource)
removeRecipient
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setPriority
setStatus
setText
setTitle
shareTo (inherited from TreeItem)
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString (inherited from Item)
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
updateRevisionComment (inherited from Item)

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.addRecipient Method

public virtual void addRecipient(
Int32 userID
);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.Equals Method

public override bool Equals(
Object source
);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getAmIRecipient Method

Returns a value indicating whether the logged on user is a recipient of this topic.

public virtual int getAmIRecipient();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getChildrenCount Method

Returns the number of topics that are subtopics of this one.

public virtual int getChildrenCount();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.GetHashCode Method

public override int GetHashCode();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getNumber Method

Returns the topic number of this topic.

public virtual int getNumber();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getParentTopic Method

Returns the object ID of this topic's parent. A value of -1 means the topic has no parent.

public virtual int getParentTopic();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getPossiblePriority Method

Returns the possible enum codes that are valid values for the Priority property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossiblePriority();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getPossibleReadStatus Method

public override int[] getPossibleReadStatus();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getPossibleStatus Method

Returns the possible enum codes that are valid values for the Status property. This is really a convenience method for accessing Property.getEnumValues for this property.

public virtual int[] getPossibleStatus();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getPriority Method

Returns the Priority of this topic.

public virtual int getPriority();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getPriorityDisplayName Method

public virtual string getPriorityDisplayName(
Int32 value
);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getReadStatus Method

public override int getReadStatus();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getReadStatusDisplayName Method

public override string getReadStatusDisplayName(
Int32 value
);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getRecipientCount Method

Returns the number of recipients assigned to this topic.

public virtual int getRecipientCount();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getRecipients Method

Returns the IDs of the users assigned as recipients of this topic.

public virtual int[] getRecipients();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getStatus Method

Returns the Status of this topic.

public virtual int getStatus();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getStatusDisplayName Method

public virtual string getStatusDisplayName(
Int32 value
);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getText Method

Returns the text or body of the topic.

public virtual string getText();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.getTitle Method

Returns the title or subject of the topic.

public virtual string getTitle();

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.modifyReadStatusForUser Method

public override void modifyReadStatusForUser(
Boolean bSetAsRead
);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.removeRecipient Method

public virtual void removeRecipient(
Int32 userID
);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.setPriority Method

public virtual void setPriority(
Int32 Priority
);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.setStatus Method

public virtual void setStatus(
Int32 Status
);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.setText Method

public virtual void setText(
String text
);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Topic.setTitle Method

public virtual void setTitle(
String title
);

See Also

Topic Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations Class

For a list of all members of this type, see Translations Members.

System.Object
Translations

public class Translations

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Translations Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations Members

Translations overview

Public Static Methods

parseLocale
toString

Public Instance Constructors

Translations Overloaded. Initializes a new instance of the Translations class.

Public Instance Methods

closestDefined |
copy |
Equals |
getDefault | Return the default translation. Will not return null because a default translation must always exist.
GetHashCode |
getLocaleNames | Return all of the locale names for which a translation exists.
getLocales |
getTranslation | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo |
MemberwiseClone |
removeLocale | Overloaded.
setDefault |
setTranslation | Overloaded.
toDebugString |
ToString |
translate | Overloaded.

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations Constructor

Create a new Translations object with only a default set to the empty string.

Overload List

Create a new Translations object with only a default set to the empty string.

public Translations();

public Translations(String);

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations Constructor ()

Create a new Translations object with only a default set to the empty string.

public Translations();

See Also

Translations Class | com.starbase.starteam Namespace | Translations Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations Constructor (String)

public Translations(
String defaultValue
);

See Also

Translations Class | com.starbase.starteam Namespace | Translations Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations Methods

The methods of the Translations class are listed below. For a complete list of Translations class members, see the Translations Members topic.

Public Static Methods

parseLocale
toString

Public Instance Methods

closestDefined |
copy |
Equals |
getDefault | Return the default translation. Will not return null because a default translation must always exist.
GetHashCode |
getLocaleNames | Return all of the locale names for which a translation exists.
getLocales |
getTranslation | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo |
MemberwiseClone |
removeLocale | Overloaded.
setDefault |
setTranslation | Overloaded.
toDebugString |
ToString |
translate | Overloaded.

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.closestDefined Method

public virtual Locale closestDefined(
Locale locale
);

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.copy Method

public virtual Translations copy();

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.Equals Method

public override bool Equals(
Object source
);

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.getDefault Method

Return the default translation. Will not return null because a default translation must always exist.

public virtual string getDefault();

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.GetHashCode Method

public override int GetHashCode();

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.getLocaleNames Method

Return all of the locale names for which a translation exists.

public virtual string[] getLocaleNames();

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.getLocales Method

public virtual Locale[] getLocales();

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


getTranslation Method

Borland StarTeam SDK for .NET

Translations.getTranslation Method

Overload List

public virtual string getTranslation(Locale);

public virtual string getTranslation(String);

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.getTranslation Method (Locale)

public virtual string getTranslation(
Locale locale
);

See Also

Translations Class | com.starbase.starteam Namespace | Translations.getTranslation Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.getTranslation Method (String)

public virtual string getTranslation(
String locale
);

See Also

Translations Class | com.starbase.starteam Namespace | Translations.getTranslation Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.isEqualTo Method

public virtual bool isEqualTo(
Translations other
);

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.parseLocale Method

public static Locale parseLocale(
String pattern
);

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


removeLocale Method

Borland StarTeam SDK for .NET

Translations.removeLocale Method

Overload List

public virtual void removeLocale(Locale);

public virtual void removeLocale(String);

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.removeLocale Method (Locale)

public virtual void removeLocale(
Locale locale
);

See Also

Translations Class | com.starbase.starteam Namespace | Translations.removeLocale Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.removeLocale Method (String)

public virtual void removeLocale(
String locale
);

See Also

Translations Class | com.starbase.starteam Namespace | Translations.removeLocale Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.setDefault Method

public virtual void setDefault(
String value
);

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setTranslation Method

Borland StarTeam SDK for .NET

Translations.setTranslation Method

Overload List

public virtual string setTranslation(Locale,String);

public virtual string setTranslation(String,String);

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.setTranslation Method (Locale, String)

public virtual string setTranslation(
Locale locale,
String value
);

See Also

Translations Class | com.starbase.starteam Namespace | Translations.setTranslation Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.setTranslation Method (String, String)

public virtual string setTranslation(
String locale,
String value
);

See Also

Translations Class | com.starbase.starteam Namespace | Translations.setTranslation Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.toDebugString Method

public virtual string toDebugString();

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.toString Method

public static string toString(
Locale locale
);

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


translate Method

Borland StarTeam SDK for .NET

Translations.translate Method

Returns the most appropriate translation for this resource based on the default locale.

Overload List

Returns the most appropriate translation for this resource based on the default locale.

public virtual string translate();

public virtual string translate(Locale);

public virtual string translate(String);

See Also

Translations Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.translate Method ()

Returns the most appropriate translation for this resource based on the default locale.

public virtual string translate();

See Also

Translations Class | com.starbase.starteam Namespace | Translations.translate Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.translate Method (Locale)

public virtual string translate(
Locale locale
);

See Also

Translations Class | com.starbase.starteam Namespace | Translations.translate Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Translations.translate Method (String)

public virtual string translate(
String locale
);

See Also

Translations Class | com.starbase.starteam Namespace | Translations.translate Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TreeItem Class

For a list of all members of this type, see TreeItem Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Item
TreeItem
Task
Topic

public class TreeItem : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

TreeItem Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TreeItem Members

TreeItem overview

Public Instance Methods

acquireOwnership (inherited from Item)
addAttachment (inherited from Item)
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
createChild | Creates a new child item.
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from Item)
get (inherited from Item)
getACL (inherited from Item)
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode (inherited from Item)
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentID | Gets the ObjectID of this item's parent. Returns -1 if this task has no parent.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPropertyNames (inherited from Item)
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getString (inherited from Item)
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move | Obsolete.
moveTo | Overloaded.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put (inherited from Item)
putByPropertyID (inherited from Item)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove
removeAttachment (inherited from Item)
removeFromIntArray (inherited from TypedResource)
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
shareTo
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString (inherited from Item)
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
updateRevisionComment (inherited from Item)

See Also

TreeItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TreeItem Methods

The methods of the TreeItem class are listed below. For a complete list of TreeItem class members, see the TreeItem Members topic.

Public Instance Methods

acquireOwnership (inherited from Item)
addAttachment (inherited from Item)
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy (inherited from Item) | Creates a copy of the Item and all of its properties. Does not copy the parent folder, type, etc. Useful to applications that want to save a snapshot of the Item in a given state, for example, before calling Item.refresh() or Folder.refreshItems().
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
createChild | Creates a new child item.
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
Equals (inherited from Item)
get (inherited from Item)
getACL (inherited from Item)
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Item) | Returns the dot notation identification of this version. The first version of an item added to the repository will have a dot notation of <code>"1.0"</code>. Each new revision will increment the version number portion so the second revision would be <code>"1.1"</code>. When an item branches a new branch number will be issued and revision will start counting from 0 again. For example, branching from version <code>"1.2"</code> might result in <code>"1.2.5.0"</code> after which the next version will be <code>"1.2.5.1"</code>. The value 5 in the previous example was assigned by the server based on the number of branches already made from the revision being branched.
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode (inherited from Item)
getHistory (inherited from Item) | Returns the past versions of this item.
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Item)
getParentFolder (inherited from Item) | Returns the folder in which this item exists.
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentID | Gets the ObjectID of this item's parent. Returns -1 if this task has no parent.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPropertyNames (inherited from Item)
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getString (inherited from Item)
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasPermission (inherited from Item)
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Item) | Compares two Items. The items are considered equal if: <ul><li> They have the same Type. Types are compared by ClassID. <li> They have the same ItemID, or are both new Items. <li> They belong to the same view. Views are compared by ID. <li> They both belong to the same folder. Folders are compared by ItemID. If both Items are themselves Folders, then they must have the same parent, or both be root folders without a parent. If both Items are disembodied, then the parent folder is not considered. <li> For all Item properties, the property values must be equal for both Items. </ul>
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move | Obsolete.
moveTo | Overloaded.
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
put (inherited from Item)
putByPropertyID (inherited from Item)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
remove
removeAttachment (inherited from Item)
removeFromIntArray (inherited from TypedResource)
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
reverseShareTo (inherited from Item) | Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Item)
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
shareTo
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString (inherited from Item)
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update (inherited from Item) | Stores the underlying entity in the server. If the item is new it will be created otherwise an existing item will be modified.
updateRevisionComment (inherited from Item)

See Also

TreeItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TreeItem.createChild Method

Creates a new child item.

public virtual TreeItem createChild();

See Also

TreeItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TreeItem.getParentID Method

Gets the ObjectID of this item's parent. Returns -1 if this task has no parent.

public virtual int getParentID();

See Also

TreeItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TreeItem.move Method

NOTE: This method is now obsolete.

public override void move(
Folder toFolder
);

See Also

TreeItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


moveTo Method

Borland StarTeam SDK for .NET

TreeItem.moveTo Method

Overload List

public override void moveTo(Folder);

Moves this item to the specified parent. Child items, if any, are also moved.

public virtual void moveTo(TreeItem);

See Also

TreeItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TreeItem.moveTo Method (Folder)

public override void moveTo(
Folder toFolder
);

See Also

TreeItem Class | com.starbase.starteam Namespace | TreeItem.moveTo Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TreeItem.moveTo Method (TreeItem)

Moves this item to the specified parent. Child items, if any, are also moved.

public virtual void moveTo(
TreeItem parent
);

See Also

TreeItem Class | com.starbase.starteam Namespace | TreeItem.moveTo Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TreeItem.remove Method

public override void remove();

See Also

TreeItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TreeItem.shareTo Method

public override Item shareTo(
Folder toFolder
);

See Also

TreeItem Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type Class

For a list of all members of this type, see Type Members.

System.Object
CacheRef
NamedCacheRef
Type

public class Type : NamedCacheRef, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Type Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type Members

Type overview

Public Instance Methods

addFilterQueryListener | Adds a listener for Filter and/or Query events. <p> Event handlers will be triggered whenever a Filter or Query of this Type is added, changed or deleted on the server. Note that an application will not receive events for Filters or Queries that the logged-in user does not have permission to access. <p> In order to handle events, an application must enable MPX.
addTypeListener | Adds a listener for Type events. <p> Event handlers will be triggered whenever this Type is changed on the server. <p> In order to handle events, an application must enable MPX.
Clone (inherited from CacheRef) |
copy | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or QueryInfo objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
discard | Discards all of the cached properties for this Type. They will be re-fetched from the server on demand (even when MPX is enabled).
discardFiltersAndQueries | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals |
getACL | Obsolete. Returns the Access Control List for this type. This will return null if this type has no access control list.
getCatalog | Returns a Catalog object for items of this type. The catalog is not scoped by View and hence can be used to access Catalog information for any object in any view in the associated server.
getClassID | Return the class ID for this type.
getComponentACL | Returns the Access Control List for this type. This will return null if this type has no access control list.
getComponentGUID | For Types that correspond to StarTeam components this method returns the server-defined component GUID. For all other types this returns null.
getContainerLevelACL |
getDBTableName | Returns the database table name for this type. This is provided mostly for informational purposes and is generally not needed.
getDisplayName | Returns a display name for this type.
getFilterACL | Returns the Access Control List for filter of this type. This will return null if this type has no access control list.
getFilterForID |
getFilterForName |
getFilters | Returns an array of all <code>Filter</code>s for this type.
GetHashCode |
getName | Returns the programatic name for this type. For example, this is the value you would use on the <code>Server.typeForName</code>.
getParentContainer |
getPrimaryDescriptor | Gets the primary descriptor of this type.
getProperties | Return an array of all <code>Property</code> objects belonging to this type.
getPropertyCount | Returns the number of properties for this type.
getQueries | Returns an array of all <code>QueryInfo</code> for this type.
getQueryACL | Returns the Access Control List for query of this type. This will return null if this type has no access control list.
getQueryForID |
getQueryForName |
getServer | Returns the Server object containing this Type.
GetType (inherited from Object) | Gets the Type of the current instance.
hasFilterForID |
hasFilterForName |
hasPermission | Overloaded.
hasPropertyForName |
hasPropertyForPID |
hasQueryForID |
hasQueryForName |
isComponentType | Determines whether or not this Type corresponds to a StarTeam "component". Standard StarTeam components include, Files, Change Requests, Tasks, Topics, and Audits. In addition the "Project" type is considered a component even though a Folder cannot contain items of that type.
isEqualTo | Compares two Type objects. Does not compare any associated Property, Filter or Query objects.
isItemType | Determines whether or not this Type corresponds to a StarTeam "item". Item types are those whose instances can be contained in a Folder.
isMPXSupported | Determines whether or not this Type supports MPX. If a Type supports MPX, then instances of that Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs.
isRefreshFiltersAndQueriesRequired | Returns true if a refreshFiltersAndQueries() operation might have resulted in Filter or Query information being updated; returns false if and only if it is known that the Filter and Query information had not been changed since the last refresh. If MPX is not enabled, then isRefreshFiltersAndQueriesRequired() always returns true.
MemberwiseClone (inherited from CacheRef) |
pidForIndex |
propertiesForNames |
propertyForName |
propertyForPID |
refresh | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
refreshFiltersAndQueries | Refreshes cached Filter and Query information to reflect recent changes to the repository. Modifies existing Filter and Query objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
removeFilterQueryListener | Removes a listener for Filter and/or Query events.
removeTypeListener | Removes a listener for Type events.
setACL | Obsolete.
setComponentACL |
setContainerLevelACL |
setFilterACL |
setQueryACL |
toDebugString | Returns a String with debug information about this type.
ToString |

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type Methods

The methods of the Type class are listed below. For a complete list of Type class members, see the Type Members topic.

Public Instance Methods

addFilterQueryListener | Adds a listener for Filter and/or Query events. <p> Event handlers will be triggered whenever a Filter or Query of this Type is added, changed or deleted on the server. Note that an application will not receive events for Filters or Queries that the logged-in user does not have permission to access. <p> In order to handle events, an application must enable MPX.
addTypeListener | Adds a listener for Type events. <p> Event handlers will be triggered whenever this Type is changed on the server. <p> In order to handle events, an application must enable MPX.
Clone (inherited from CacheRef) |
copy | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or QueryInfo objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
discard | Discards all of the cached properties for this Type. They will be re-fetched from the server on demand (even when MPX is enabled).
discardFiltersAndQueries | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals |
getACL | Obsolete. Returns the Access Control List for this type. This will return null if this type has no access control list.
getCatalog | Returns a Catalog object for items of this type. The catalog is not scoped by View and hence can be used to access Catalog information for any object in any view in the associated server.
getClassID | Return the class ID for this type.
getComponentACL | Returns the Access Control List for this type. This will return null if this type has no access control list.
getComponentGUID | For Types that correspond to StarTeam components this method returns the server-defined component GUID. For all other types this returns null.
getContainerLevelACL |
getDBTableName | Returns the database table name for this type. This is provided mostly for informational purposes and is generally not needed.
getDisplayName | Returns a display name for this type.
getFilterACL | Returns the Access Control List for filter of this type. This will return null if this type has no access control list.
getFilterForID |
getFilterForName |
getFilters | Returns an array of all <code>Filter</code>s for this type.
GetHashCode |
getName | Returns the programatic name for this type. For example, this is the value you would use on the <code>Server.typeForName</code>.
getParentContainer |
getPrimaryDescriptor | Gets the primary descriptor of this type.
getProperties | Return an array of all <code>Property</code> objects belonging to this type.
getPropertyCount | Returns the number of properties for this type.
getQueries | Returns an array of all <code>QueryInfo</code> for this type.
getQueryACL | Returns the Access Control List for query of this type. This will return null if this type has no access control list.
getQueryForID |
getQueryForName |
getServer | Returns the Server object containing this Type.
GetType (inherited from Object) | Gets the Type of the current instance.
hasFilterForID |
hasFilterForName |
hasPermission | Overloaded.
hasPropertyForName |
hasPropertyForPID |
hasQueryForID |
hasQueryForName |
isComponentType | Determines whether or not this Type corresponds to a StarTeam "component". Standard StarTeam components include, Files, Change Requests, Tasks, Topics, and Audits. In addition the "Project" type is considered a component even though a Folder cannot contain items of that type.
isEqualTo | Compares two Type objects. Does not compare any associated Property, Filter or Query objects.
isItemType | Determines whether or not this Type corresponds to a StarTeam "item". Item types are those whose instances can be contained in a Folder.
isMPXSupported | Determines whether or not this Type supports MPX. If a Type supports MPX, then instances of that Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs.
isRefreshFiltersAndQueriesRequired | Returns true if a refreshFiltersAndQueries() operation might have resulted in Filter or Query information being updated; returns false if and only if it is known that the Filter and Query information had not been changed since the last refresh. If MPX is not enabled, then isRefreshFiltersAndQueriesRequired() always returns true.
MemberwiseClone (inherited from CacheRef) |
pidForIndex |
propertiesForNames |
propertyForName |
propertyForPID |
refresh | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
refreshFiltersAndQueries | Refreshes cached Filter and Query information to reflect recent changes to the repository. Modifies existing Filter and Query objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
removeFilterQueryListener | Removes a listener for Filter and/or Query events.
removeTypeListener | Removes a listener for Type events.
setACL | Obsolete.
setComponentACL |
setContainerLevelACL |
setFilterACL |
setQueryACL |
toDebugString | Returns a String with debug information about this type.
ToString |

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.addFilterQueryListener Method

Adds a listener for Filter and/or Query events. <p> Event handlers will be triggered whenever a Filter or Query of this Type is added, changed or deleted on the server. Note that an application will not receive events for Filters or Queries that the logged-in user does not have permission to access. <p> In order to handle events, an application must enable MPX.

public virtual void addFilterQueryListener(
IFilterQueryListener listener
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.addTypeListener Method

Adds a listener for Type events. <p> Event handlers will be triggered whenever this Type is changed on the server. <p> In order to handle events, an application must enable MPX.

public virtual void addTypeListener(
TypeListener listener
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.copy Method

Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or QueryInfo objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().

public virtual Type copy();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.discard Method

Discards all of the cached properties for this Type. They will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void discard();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.discardFiltersAndQueries Method

Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void discardFiltersAndQueries();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.Equals Method

public override bool Equals(
Object source
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getACL Method

NOTE: This method is now obsolete.

Returns the Access Control List for this type. This will return null if this type has no access control list.

public virtual AclEntry[] getACL();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getCatalog Method

Returns a Catalog object for items of this type. The catalog is not scoped by View and hence can be used to access Catalog information for any object in any view in the associated server.

public virtual Catalog getCatalog();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getClassID Method

Return the class ID for this type.

public virtual int getClassID();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getComponentACL Method

Returns the Access Control List for this type. This will return null if this type has no access control list.

public virtual AclEntry[] getComponentACL();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getComponentGUID Method

For Types that correspond to StarTeam components this method returns the server-defined component GUID. For all other types this returns null.

public virtual GUID getComponentGUID();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getContainerLevelACL Method

public virtual AclEntry[] getContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.getContainerLevelACL

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getDBTableName Method

Returns the database table name for this type. This is provided mostly for informational purposes and is generally not needed.

public virtual string getDBTableName();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getDisplayName Method

Returns a display name for this type.

public virtual string getDisplayName();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getFilterACL Method

Returns the Access Control List for filter of this type. This will return null if this type has no access control list.

public virtual AclEntry[] getFilterACL();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getFilterForID Method

public virtual Filter getFilterForID(
Int32 ID
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getFilterForName Method

public virtual Filter getFilterForName(
String name
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getFilters Method

Returns an array of all <code>Filter</code>s for this type.

public virtual Filter[] getFilters();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.GetHashCode Method

public override int GetHashCode();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getName Method

Returns the programatic name for this type. For example, this is the value you would use on the <code>Server.typeForName</code>.

public virtual string getName();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getParentContainer Method

public virtual ISecurableContainer getParentContainer();

Implements

ISecurableContainer.getParentContainer

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getPrimaryDescriptor Method

Gets the primary descriptor of this type.

public virtual Property getPrimaryDescriptor();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getProperties Method

Return an array of all <code>Property</code> objects belonging to this type.

public virtual Property[] getProperties();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getPropertyCount Method

Returns the number of properties for this type.

public virtual int getPropertyCount();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getQueries Method

Returns an array of all <code>QueryInfo</code> for this type.

public virtual QueryInfo[] getQueries();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getQueryACL Method

Returns the Access Control List for query of this type. This will return null if this type has no access control list.

public virtual AclEntry[] getQueryACL();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getQueryForID Method

public virtual QueryInfo getQueryForID(
Int32 ID
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getQueryForName Method

public virtual QueryInfo getQueryForName(
String name
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.getServer Method

Returns the Server object containing this Type.

public virtual Server getServer();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.hasFilterForID Method

public virtual bool hasFilterForID(
Int32 ID
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.hasFilterForName Method

public virtual bool hasFilterForName(
String name
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


hasPermission Method

Borland StarTeam SDK for .NET

Type.hasPermission Method

Overload List

public virtual bool hasPermission(Int32);

public virtual bool hasPermission(Int32,String);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.hasPermission Method (Int32)

public virtual bool hasPermission(
Int32 permissions
);

See Also

Type Class | com.starbase.starteam Namespace | Type.hasPermission Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.hasPermission Method (Int32, String)

public virtual bool hasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.hasPermission

See Also

Type Class | com.starbase.starteam Namespace | Type.hasPermission Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.hasPropertyForName Method

public virtual bool hasPropertyForName(
String propertyName
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.hasPropertyForPID Method

public virtual bool hasPropertyForPID(
Int32 propertyID
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.hasQueryForID Method

public virtual bool hasQueryForID(
Int32 ID
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.hasQueryForName Method

public virtual bool hasQueryForName(
String name
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.isComponentType Method

Determines whether or not this Type corresponds to a StarTeam "component". Standard StarTeam components include, Files, Change Requests, Tasks, Topics, and Audits. In addition the "Project" type is considered a component even though a Folder cannot contain items of that type.

public virtual bool isComponentType();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.isEqualTo Method

Compares two Type objects. Does not compare any associated Property, Filter or Query objects.

public virtual bool isEqualTo(
Type type
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.isItemType Method

Determines whether or not this Type corresponds to a StarTeam "item". Item types are those whose instances can be contained in a Folder.

public virtual bool isItemType();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.isMPXSupported Method

Determines whether or not this Type supports MPX. If a Type supports MPX, then instances of that Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs.

public virtual bool isMPXSupported();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.isRefreshFiltersAndQueriesRequired Method

Returns true if a refreshFiltersAndQueries() operation might have resulted in Filter or Query information being updated; returns false if and only if it is known that the Filter and Query information had not been changed since the last refresh. If MPX is not enabled, then isRefreshFiltersAndQueriesRequired() always returns true.

public virtual bool isRefreshFiltersAndQueriesRequired();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.pidForIndex Method

public virtual int pidForIndex(
Int32 i
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.propertiesForNames Method

public virtual Property[] propertiesForNames(
String[] propertyNames
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.propertyForName Method

public virtual Property propertyForName(
String propertyName
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.propertyForPID Method

public virtual Property propertyForPID(
Int32 propertyID
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.refresh Method

Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command

public virtual void refresh();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.refreshFiltersAndQueries Method

Refreshes cached Filter and Query information to reflect recent changes to the repository. Modifies existing Filter and Query objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.

public virtual void refreshFiltersAndQueries();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.removeFilterQueryListener Method

Removes a listener for Filter and/or Query events.

public virtual void removeFilterQueryListener(
IFilterQueryListener listener
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.removeTypeListener Method

Removes a listener for Type events.

public virtual void removeTypeListener(
TypeListener listener
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.setACL Method

NOTE: This method is now obsolete.

public virtual void setACL(
AclEntry[] acl
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.setComponentACL Method

public virtual void setComponentACL(
AclEntry[] acl
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.setContainerLevelACL Method

public virtual void setContainerLevelACL(
AclEntry[] acl,
String typeName
);

Implements

ISecurableContainer.setContainerLevelACL

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.setFilterACL Method

public virtual void setFilterACL(
AclEntry[] acl
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.setQueryACL Method

public virtual void setQueryACL(
AclEntry[] acl
);

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.toDebugString Method

Returns a String with debug information about this type.

public virtual string toDebugString();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Type.ToString Method

public override string ToString();

See Also

Type Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeAdapter Class

For a list of all members of this type, see TypeAdapter Members.

System.Object
TypeAdapter

public class TypeAdapter : TypeListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

TypeAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeAdapter Members

TypeAdapter overview

Public Instance Constructors

TypeAdapter Constructor Initializes a new instance of the TypeAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |
typeChanged |

See Also

TypeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeAdapter Constructor

Initializes a new instance of the TypeAdapter class.

public TypeAdapter();

See Also

TypeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeAdapter Methods

The methods of the TypeAdapter class are listed below. For a complete list of TypeAdapter class members, see the TypeAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |
typeChanged |

See Also

TypeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

TypeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeAdapter.ToString Method

public override string ToString();

See Also

TypeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeAdapter.typeChanged Method

public override void typeChanged(
TypeEvent e
);

Implements

TypeListener.typeChanged

See Also

TypeAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource Class

For a list of all members of this type, see TypedResource Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource

public class TypedResource : NamedCacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

TypedResource Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource Members

TypedResource overview

Public Instance Constructors

TypedResource Constructor Initializes a new instance of the TypedResource class.

Public Instance Methods

addToIntArray |
Clone (inherited from CacheRef) |
Equals |
get |
getByteArray |
getDouble |
getEnumDisplayName |
GetHashCode |
getInt |
getIntArray |
getOLEDate |
getPossibleValues |
getPropertyNames | A convenience method for getting the PropertyNames object from the owning server for the associated Type.
getString |
getType | Returns the <code>Type</code> of this object.
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames | A convenience method for getting the TypeNames object from the owning server for the associated Type.
MemberwiseClone (inherited from CacheRef) |
put |
removeFromIntArray |
ToString |

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource Constructor

Initializes a new instance of the TypedResource class.

public TypedResource();

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource Methods

The methods of the TypedResource class are listed below. For a complete list of TypedResource class members, see the TypedResource Members topic.

Public Instance Methods

addToIntArray |
Clone (inherited from CacheRef) |
Equals |
get |
getByteArray |
getDouble |
getEnumDisplayName |
GetHashCode |
getInt |
getIntArray |
getOLEDate |
getPossibleValues |
getPropertyNames | A convenience method for getting the PropertyNames object from the owning server for the associated Type.
getString |
getType | Returns the <code>Type</code> of this object.
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames | A convenience method for getting the TypeNames object from the owning server for the associated Type.
MemberwiseClone (inherited from CacheRef) |
put |
removeFromIntArray |
ToString |

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.addToIntArray Method

public virtual void addToIntArray(
String countProperty,
String dataProperty,
Int32 value
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.Equals Method

public override bool Equals(
Object source
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.get Method

public abstract object get(
String propertyName
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.getByteArray Method

public virtual sbyte[] getByteArray(
String propertyName
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.getDouble Method

public virtual double getDouble(
String propertyName
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.getEnumDisplayName Method

public virtual string getEnumDisplayName(
String propertyName,
Int32 value
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.GetHashCode Method

public override int GetHashCode();

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.getInt Method

public virtual int getInt(
String propertyName
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.getIntArray Method

public virtual int[] getIntArray(
String propertyName
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.getOLEDate Method

public virtual OLEDate getOLEDate(
String propertyName
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.getPossibleValues Method

public virtual int[] getPossibleValues(
String propertyName
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.getPropertyNames Method

A convenience method for getting the PropertyNames object from the owning server for the associated Type.

public virtual PropertyNames getPropertyNames();

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.getString Method

public virtual string getString(
String propertyName
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.getType Method

Returns the <code>Type</code> of this object.

public abstract Type getType();

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.getTypeNames Method

A convenience method for getting the TypeNames object from the owning server for the associated Type.

public virtual TypeNames getTypeNames();

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.put Method

public abstract object put(
String propertyName,
Object value
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.removeFromIntArray Method

public virtual void removeFromIntArray(
String countProperty,
String dataProperty,
Int32 value
);

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypedResource.ToString Method

public override string ToString();

See Also

TypedResource Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeEvent Class

For a list of all members of this type, see TypeEvent Members.

System.Object
EventObject
TypeEvent

public class TypeEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

TypeEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeEvent Members

TypeEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
getType | Gets the Type that has changed, in its new state. <p> Returns a Type object that is not a member of the Server's Type collection (that is, it is not among the Type objects returned by Server.getTypes()). There will be a Type in the collection with the same ClassID, but it would be a physically different object that is likely to have different properties. <p> If an application wants to refresh the Type objects in the Server's Type collection, it must explicitly call Server.refreshTypes().
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

TypeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeEvent Methods

The methods of the TypeEvent class are listed below. For a complete list of TypeEvent class members, see the TypeEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
getType | Gets the Type that has changed, in its new state. <p> Returns a Type object that is not a member of the Server's Type collection (that is, it is not among the Type objects returned by Server.getTypes()). There will be a Type in the collection with the same ClassID, but it would be a physically different object that is likely to have different properties. <p> If an application wants to refresh the Type objects in the Server's Type collection, it must explicitly call Server.refreshTypes().
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

TypeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeEvent.Equals Method

public override bool Equals(
Object source
);

See Also

TypeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeEvent.GetHashCode Method

public override int GetHashCode();

See Also

TypeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeEvent.getSource Method

public override object getSource();

See Also

TypeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeEvent.getType Method

Gets the Type that has changed, in its new state. <p> Returns a Type object that is not a member of the Server's Type collection (that is, it is not among the Type objects returned by Server.getTypes()). There will be a Type in the collection with the same ClassID, but it would be a physically different object that is likely to have different properties. <p> If an application wants to refresh the Type objects in the Server's Type collection, it must explicitly call Server.refreshTypes().

public virtual Type getType();

See Also

TypeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

TypeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeEvent.ToString Method

public override string ToString();

See Also

TypeEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeListener Interface

For a list of all members of this type, see TypeListener Members.

public interface TypeListener : EventListener

Types that implement TypeListener

Type | Description
TypeAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

TypeListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeListener Members

TypeListener overview

Public Instance Methods

typeChanged Invoked when a Type is changed on the server.

See Also

TypeListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeListener Methods

The methods of the TypeListener interface are listed below. For a complete list of TypeListener interface members, see the TypeListener Members topic.

Public Instance Methods

typeChanged Invoked when a Type is changed on the server.

See Also

TypeListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeListener.typeChanged Method

Invoked when a Type is changed on the server.

void typeChanged(
TypeEvent e
);

See Also

TypeListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames Class

For a list of all members of this type, see TypeNames Members.

System.Object
TypeNames

public class TypeNames

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

TypeNames Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames Members

TypeNames overview

Public Instance Fields

AUDIT
CHANGEREQUEST
FILE
FOLDER
ITEM
ITEM_REFERENCE
ITEM_REVISION
LABEL
LINK
PROJECT
PROMOTIONMODEL
PROMOTIONSTATE
REQUIREMENT
TASK
TASKDEPENDENCY
TOPIC
TYPE
USER
USERACCOUNT
VIEW
WORKRECORD

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getMappedValues | Enumerate the typename map. Used for debugging.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames Fields

The fields of the TypeNames class are listed below. For a complete list of TypeNames class members, see the TypeNames Members topic.

Public Instance Fields

AUDIT
CHANGEREQUEST
FILE
FOLDER
ITEM
ITEM_REFERENCE
ITEM_REVISION
LABEL
LINK
PROJECT
PROMOTIONMODEL
PROMOTIONSTATE
REQUIREMENT
TASK
TASKDEPENDENCY
TOPIC
TYPE
USER
USERACCOUNT
VIEW
WORKRECORD

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.AUDIT Field

public readonly String AUDIT;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.CHANGEREQUEST Field

public readonly String CHANGEREQUEST;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.FILE Field

public readonly String FILE;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.FOLDER Field

public readonly String FOLDER;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.ITEM Field

public readonly String ITEM;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.ITEM_REFERENCE Field

public readonly String ITEM_REFERENCE;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.ITEM_REVISION Field

public readonly String ITEM_REVISION;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.LABEL Field

public readonly String LABEL;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.LINK Field

public readonly String LINK;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.PROJECT Field

public readonly String PROJECT;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.PROMOTIONMODEL Field

public readonly String PROMOTIONMODEL;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.PROMOTIONSTATE Field

public readonly String PROMOTIONSTATE;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.REQUIREMENT Field

public readonly String REQUIREMENT;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.TASK Field

public readonly String TASK;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.TASKDEPENDENCY Field

public readonly String TASKDEPENDENCY;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.TOPIC Field

public readonly String TOPIC;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.TYPE Field

public readonly String TYPE;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.USER Field

public readonly String USER;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.USERACCOUNT Field

public readonly String USERACCOUNT;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.VIEW Field

public readonly String VIEW;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.WORKRECORD Field

public readonly String WORKRECORD;

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames Methods

The methods of the TypeNames class are listed below. For a complete list of TypeNames class members, see the TypeNames Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getMappedValues | Enumerate the typename map. Used for debugging.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.getMappedValues Method

Enumerate the typename map. Used for debugging.

public virtual string[] getMappedValues();

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.MemberwiseClone Method

public override object MemberwiseClone();

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNames.ToString Method

public override string ToString();

See Also

TypeNames Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException Class

For a list of all members of this type, see TypeNotFoundException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
TypeNotFoundException

public class TypeNotFoundException : RuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

TypeNotFoundException Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException Members

TypeNotFoundException overview

Public Static Methods

wrap

Public Instance Constructors

TypeNotFoundException Overloaded. Initializes a new instance of the TypeNotFoundException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
getTypeID |
getTypeName |
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException Constructor

Overload List

public TypeNotFoundException(Int32);

public TypeNotFoundException(String);

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException Constructor (String)

public TypeNotFoundException(
String typeName
);

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace | TypeNotFoundException Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException Constructor (Int32)

public TypeNotFoundException(
Int32 typeID
);

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace | TypeNotFoundException Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException Methods

The methods of the TypeNotFoundException class are listed below. For a complete list of TypeNotFoundException class members, see the TypeNotFoundException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
getTypeID |
getTypeName |
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException.Equals Method

public override bool Equals(
Object source
);

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException.GetHashCode Method

public override int GetHashCode();

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException.getMessage Method

public override string getMessage();

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException.getTypeID Method

public virtual int getTypeID();

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException.getTypeName Method

public virtual string getTypeName();

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException.unwrap Method

public virtual TypeNotFoundException unwrap();

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TypeNotFoundException.wrap Method

public static TypeNotFoundException wrap(
TypeNotFoundException arg
);

See Also

TypeNotFoundException Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User Class

For a list of all members of this type, see User Members.

System.Object
CacheRef
User

public class User : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

User Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User Members

User overview

Public Instance Methods

Clone (inherited from CacheRef) |
copy | Creates a copy of this User object. Useful to applications that want to save a snapshot of the user in a given state, for example, before calling Server.refreshUsers().
Equals |
GetHashCode |
getID | Returns the integer idenitifier for this user.
getName | Returns the user's name. This is not the same as the user's logon name.
getServer | Returns the Server object to which this user belongs.
GetType (inherited from Object) | Gets the Type of the current instance.
isDeleted | Returns true if this user has been deleted.
isEqualTo | Compares two User objects.
MemberwiseClone (inherited from CacheRef) |
ToString |

See Also

User Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User Methods

The methods of the User class are listed below. For a complete list of User class members, see the User Members topic.

Public Instance Methods

Clone (inherited from CacheRef) |
copy | Creates a copy of this User object. Useful to applications that want to save a snapshot of the user in a given state, for example, before calling Server.refreshUsers().
Equals |
GetHashCode |
getID | Returns the integer idenitifier for this user.
getName | Returns the user's name. This is not the same as the user's logon name.
getServer | Returns the Server object to which this user belongs.
GetType (inherited from Object) | Gets the Type of the current instance.
isDeleted | Returns true if this user has been deleted.
isEqualTo | Compares two User objects.
MemberwiseClone (inherited from CacheRef) |
ToString |

See Also

User Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User.copy Method

Creates a copy of this User object. Useful to applications that want to save a snapshot of the user in a given state, for example, before calling Server.refreshUsers().

public virtual User copy();

See Also

User Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User.Equals Method

public override bool Equals(
Object source
);

See Also

User Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User.GetHashCode Method

public override int GetHashCode();

See Also

User Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User.getID Method

Returns the integer idenitifier for this user.

public virtual int getID();

See Also

User Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User.getName Method

Returns the user's name. This is not the same as the user's logon name.

public virtual string getName();

See Also

User Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User.getServer Method

Returns the Server object to which this user belongs.

public virtual Server getServer();

See Also

User Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User.isDeleted Method

Returns true if this user has been deleted.

public virtual bool isDeleted();

See Also

User Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User.isEqualTo Method

Compares two User objects.

public virtual bool isEqualTo(
User user
);

See Also

User Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


User.ToString Method

public override string ToString();

See Also

User Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount Class

For a list of all members of this type, see UserAccount Members.

System.Object
CacheRef
UserAccount

public class UserAccount : CacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

UserAccount Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount Members

UserAccount overview

Public Static Fields

DAY_FRIDAY
DAY_MONDAY
DAY_SATURDAY
DAY_SUNDAY
DAY_THURSDAY
DAY_TUESDAY
DAY_WEDNESDAY
LICENSE_TYPE_LICENSE_SERVER
LICENSE_TYPE_STARTEAM
LICENSE_TYPE_UNASSIGNED
POLICY_ALWAYS
POLICY_CUSTOM
POLICY_STANDARD
STATUS_LOCKED_OUT
STATUS_NORMAL
STATUS_PASSWORD_CHANGE_NOTIFIED
STATUS_PASSWORD_CHANGE_REQUIRED
STATUS_SUSPENDED

Public Instance Constructors

UserAccount Constructor Creates a new user account to be activated on the server. The new account will not actually be created until <code>update()</code> is called.

Public Instance Methods

addToGroupAccount | Adds this user to the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call <code>update()</code> to save the changes on the server.
Clone (inherited from CacheRef) |
copy | Creates a copy of this UserAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals |
forceLogoff | Forces this user account to be logged off from the server. The effect is immediate ( no need to call the update() method ).
forcePasswordChange | Forces a password change for this user account. The effect is immediate ( no need to call the update() method ).
getAccessEndTime1 |
getAccessEndTime2 |
getAccessPolicy | Return's this account's access policy. The access policy specifies when a user is allowed to connect to the server.
getAccessStartTime1 |
getAccessStartTime2 |
getAccountStatus | Returns this account's status.
getBLSSlipGuid | Gets the Slip ID assigned to this license.
getCreatedTime | Gets the time at which this UserAccount was created.
getDistinguishedName | Gets the Distinguished Name for Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.
getEmailAddress | Returns the user's email address.
getFaxNumber | Returns the user's fax number.
getGroupAccounts | Returns all of the group accounts to which this user belongs.
getHasFixedLicense | Determines whether this user has a fixed ( named-user ) license or a floating ( concurrent ) license.
GetHashCode |
getID | Returns an integer ID that represents this user account.
getLicenseType | Gets the type of license assigned to this user.
getLogOnCount | Returns the number of times this user is logged in to the server.
getLogOnName | Returns the logon name or identifier for this account.
getName | Returns the full name that this user goes by.
getPagerNumber | Returns the user's pager number.
getPhoneNumber | Returns the user's phone number.
getPolicyTimeZoneShift | Return's the timezone shift for this account's access policy. This value only applies if the policy is other than <code>POLICY_ALWAYS</code>. The value is in hours from GMT.
getPostalAddress | Returns the user's postal address.
GetType (inherited from Object) | Gets the Type of the current instance.
getValidateThroughDirectoryService | Indicates whether the user validates through Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.
getVoiceMailNumber | Returns the user's voice mail number.
getWorkstations | Currently unused.
isEqualTo | Compares two UserAccount objects.
isNew | Tells if this user account has been created on the server yet.
MemberwiseClone (inherited from CacheRef) |
reactivate | Reactivates this user account. The effect is immediate ( no need to call the update() method ).
remove | Removes this user account from the server, and from any group of which it is a member.
removeFromGroupAccount | Removes this user from the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call <code>update()</code> to save the changes on the server.
setAccessPolicy |
setAccessTimes |
setAccountStatus |
setBLSSlipGuid |
setDistinguishedName |
setEmailAddress |
setFaxNumber |
setHasFixedLicense |
setLicenseType |
setLogOnName |
setName |
setPagerNumber |
setPassword |
setPhoneNumber |
setPolicyTimeZoneShift |
setPostalAddress |
setValidateThroughDirectoryService |
setVoiceMailNumber |
suspend | Suspend this user account. The effect is immediate ( no need to call the update() method ).
ToString |
unlock | Unlocks this user account. The effect is immediate ( no need to call the update() method ).
update | Create or modify this UserAccount in the StarTeam Server. If the account is new it will be created otherwise the account information will be modified.

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount Constructor

Creates a new user account to be activated on the server. The new account will not actually be created until <code>update()</code> is called.

public UserAccount(
Server server
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount Fields

The fields of the UserAccount class are listed below. For a complete list of UserAccount class members, see the UserAccount Members topic.

Public Static Fields

DAY_FRIDAY
DAY_MONDAY
DAY_SATURDAY
DAY_SUNDAY
DAY_THURSDAY
DAY_TUESDAY
DAY_WEDNESDAY
LICENSE_TYPE_LICENSE_SERVER
LICENSE_TYPE_STARTEAM
LICENSE_TYPE_UNASSIGNED
POLICY_ALWAYS
POLICY_CUSTOM
POLICY_STANDARD
STATUS_LOCKED_OUT
STATUS_NORMAL
STATUS_PASSWORD_CHANGE_NOTIFIED
STATUS_PASSWORD_CHANGE_REQUIRED
STATUS_SUSPENDED

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.DAY_FRIDAY Field

public const Int32 DAY_FRIDAY = 5;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.DAY_MONDAY Field

public const Int32 DAY_MONDAY = 1;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.DAY_SATURDAY Field

public const Int32 DAY_SATURDAY = 6;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.DAY_SUNDAY Field

public const Int32 DAY_SUNDAY = 0;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.DAY_THURSDAY Field

public const Int32 DAY_THURSDAY = 4;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.DAY_TUESDAY Field

public const Int32 DAY_TUESDAY = 2;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.DAY_WEDNESDAY Field

public const Int32 DAY_WEDNESDAY = 3;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.LICENSE_TYPE_LICENSE_SERVER Field

public const Int32 LICENSE_TYPE_LICENSE_SERVER = 2;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.LICENSE_TYPE_STARTEAM Field

public const Int32 LICENSE_TYPE_STARTEAM = 1;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.LICENSE_TYPE_UNASSIGNED Field

public const Int32 LICENSE_TYPE_UNASSIGNED = 3;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.POLICY_ALWAYS Field

public const Int32 POLICY_ALWAYS = 0;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.POLICY_CUSTOM Field

public const Int32 POLICY_CUSTOM = 2;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.POLICY_STANDARD Field

public const Int32 POLICY_STANDARD = 1;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.STATUS_LOCKED_OUT Field

public const Int32 STATUS_LOCKED_OUT = 1;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.STATUS_NORMAL Field

public const Int32 STATUS_NORMAL = 0;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.STATUS_PASSWORD_CHANGE_NOTIFIED Field

public const Int32 STATUS_PASSWORD_CHANGE_NOTIFIED = 4;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.STATUS_PASSWORD_CHANGE_REQUIRED Field

public const Int32 STATUS_PASSWORD_CHANGE_REQUIRED = 3;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.STATUS_SUSPENDED Field

public const Int32 STATUS_SUSPENDED = 2;

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount Methods

The methods of the UserAccount class are listed below. For a complete list of UserAccount class members, see the UserAccount Members topic.

Public Instance Methods

addToGroupAccount | Adds this user to the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call <code>update()</code> to save the changes on the server.
Clone (inherited from CacheRef) |
copy | Creates a copy of this UserAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals |
forceLogoff | Forces this user account to be logged off from the server. The effect is immediate ( no need to call the update() method ).
forcePasswordChange | Forces a password change for this user account. The effect is immediate ( no need to call the update() method ).
getAccessEndTime1 |
getAccessEndTime2 |
getAccessPolicy | Return's this account's access policy. The access policy specifies when a user is allowed to connect to the server.
getAccessStartTime1 |
getAccessStartTime2 |
getAccountStatus | Returns this account's status.
getBLSSlipGuid | Gets the Slip ID assigned to this license.
getCreatedTime | Gets the time at which this UserAccount was created.
getDistinguishedName | Gets the Distinguished Name for Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.
getEmailAddress | Returns the user's email address.
getFaxNumber | Returns the user's fax number.
getGroupAccounts | Returns all of the group accounts to which this user belongs.
getHasFixedLicense | Determines whether this user has a fixed ( named-user ) license or a floating ( concurrent ) license.
GetHashCode |
getID | Returns an integer ID that represents this user account.
getLicenseType | Gets the type of license assigned to this user.
getLogOnCount | Returns the number of times this user is logged in to the server.
getLogOnName | Returns the logon name or identifier for this account.
getName | Returns the full name that this user goes by.
getPagerNumber | Returns the user's pager number.
getPhoneNumber | Returns the user's phone number.
getPolicyTimeZoneShift | Return's the timezone shift for this account's access policy. This value only applies if the policy is other than <code>POLICY_ALWAYS</code>. The value is in hours from GMT.
getPostalAddress | Returns the user's postal address.
GetType (inherited from Object) | Gets the Type of the current instance.
getValidateThroughDirectoryService | Indicates whether the user validates through Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.
getVoiceMailNumber | Returns the user's voice mail number.
getWorkstations | Currently unused.
isEqualTo | Compares two UserAccount objects.
isNew | Tells if this user account has been created on the server yet.
MemberwiseClone (inherited from CacheRef) |
reactivate | Reactivates this user account. The effect is immediate ( no need to call the update() method ).
remove | Removes this user account from the server, and from any group of which it is a member.
removeFromGroupAccount | Removes this user from the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call <code>update()</code> to save the changes on the server.
setAccessPolicy |
setAccessTimes |
setAccountStatus |
setBLSSlipGuid |
setDistinguishedName |
setEmailAddress |
setFaxNumber |
setHasFixedLicense |
setLicenseType |
setLogOnName |
setName |
setPagerNumber |
setPassword |
setPhoneNumber |
setPolicyTimeZoneShift |
setPostalAddress |
setValidateThroughDirectoryService |
setVoiceMailNumber |
suspend | Suspend this user account. The effect is immediate ( no need to call the update() method ).
ToString |
unlock | Unlocks this user account. The effect is immediate ( no need to call the update() method ).
update | Create or modify this UserAccount in the StarTeam Server. If the account is new it will be created otherwise the account information will be modified.

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.addToGroupAccount Method

Adds this user to the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call <code>update()</code> to save the changes on the server.

public virtual void addToGroupAccount(
GroupAccount groupAccount
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.copy Method

Creates a copy of this UserAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().

public virtual UserAccount copy();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.Equals Method

public override bool Equals(
Object source
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.forceLogoff Method

Forces this user account to be logged off from the server. The effect is immediate ( no need to call the update() method ).

public virtual void forceLogoff();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.forcePasswordChange Method

Forces a password change for this user account. The effect is immediate ( no need to call the update() method ).

public virtual void forcePasswordChange();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getAccessEndTime1 Method

public virtual int getAccessEndTime1(
Int32 dayOfWeek
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getAccessEndTime2 Method

public virtual int getAccessEndTime2(
Int32 dayOfWeek
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getAccessPolicy Method

Return's this account's access policy. The access policy specifies when a user is allowed to connect to the server.

public virtual int getAccessPolicy();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getAccessStartTime1 Method

public virtual int getAccessStartTime1(
Int32 dayOfWeek
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getAccessStartTime2 Method

public virtual int getAccessStartTime2(
Int32 dayOfWeek
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getAccountStatus Method

Returns this account's status.

public virtual int getAccountStatus();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getBLSSlipGuid Method

Gets the Slip ID assigned to this license.

public virtual int getBLSSlipGuid();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getCreatedTime Method

Gets the time at which this UserAccount was created.

public virtual OLEDate getCreatedTime();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getDistinguishedName Method

Gets the Distinguished Name for Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual string getDistinguishedName();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getEmailAddress Method

Returns the user's email address.

public virtual string getEmailAddress();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getFaxNumber Method

Returns the user's fax number.

public virtual string getFaxNumber();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getGroupAccounts Method

Returns all of the group accounts to which this user belongs.

public virtual GroupAccount[] getGroupAccounts();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getHasFixedLicense Method

Determines whether this user has a fixed ( named-user ) license or a floating ( concurrent ) license.

public virtual bool getHasFixedLicense();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.GetHashCode Method

public override int GetHashCode();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getID Method

Returns an integer ID that represents this user account.

public virtual int getID();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getLicenseType Method

Gets the type of license assigned to this user.

public virtual int getLicenseType();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getLogOnCount Method

Returns the number of times this user is logged in to the server.

public virtual int getLogOnCount();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getLogOnName Method

Returns the logon name or identifier for this account.

public virtual string getLogOnName();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getName Method

Returns the full name that this user goes by.

public virtual string getName();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getPagerNumber Method

Returns the user's pager number.

public virtual string getPagerNumber();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getPhoneNumber Method

Returns the user's phone number.

public virtual string getPhoneNumber();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getPolicyTimeZoneShift Method

Return's the timezone shift for this account's access policy. This value only applies if the policy is other than <code>POLICY_ALWAYS</code>. The value is in hours from GMT.

public virtual int getPolicyTimeZoneShift();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getPostalAddress Method

Returns the user's postal address.

public virtual string getPostalAddress();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getValidateThroughDirectoryService Method

Indicates whether the user validates through Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual bool getValidateThroughDirectoryService();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getVoiceMailNumber Method

Returns the user's voice mail number.

public virtual string getVoiceMailNumber();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.getWorkstations Method

Currently unused.

public virtual string[] getWorkstations();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.isEqualTo Method

Compares two UserAccount objects.

public virtual bool isEqualTo(
UserAccount account
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.isNew Method

Tells if this user account has been created on the server yet.

public virtual bool isNew();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.reactivate Method

Reactivates this user account. The effect is immediate ( no need to call the update() method ).

public virtual void reactivate();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.remove Method

Removes this user account from the server, and from any group of which it is a member.

public virtual void remove();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.removeFromGroupAccount Method

Removes this user from the specified group account. The group account cannot be null, must be from the same server at the user account and the group account must have already been created on the server. You must call <code>update()</code> to save the changes on the server.

public virtual void removeFromGroupAccount(
GroupAccount groupAccount
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setAccessPolicy Method

public virtual void setAccessPolicy(
Int32 policy
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setAccessTimes Method

public virtual void setAccessTimes(
Int32 dayOfWeek,
Int32 start1,
Int32 end1,
Int32 start2,
Int32 end2
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setAccountStatus Method

public virtual void setAccountStatus(
Int32 status
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setBLSSlipGuid Method

public virtual void setBLSSlipGuid(
Int32 nSlipGuid
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setDistinguishedName Method

public virtual void setDistinguishedName(
String distinguishedName
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setEmailAddress Method

public virtual void setEmailAddress(
String emailAddress
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setFaxNumber Method

public virtual void setFaxNumber(
String faxNumber
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setHasFixedLicense Method

public virtual void setHasFixedLicense(
Boolean bFixed
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setLicenseType Method

public virtual void setLicenseType(
Int32 nLicenseType
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setLogOnName Method

public virtual void setLogOnName(
String logOnName
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setName Method

public virtual void setName(
String name
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setPagerNumber Method

public virtual void setPagerNumber(
String pagerNumber
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setPassword Method

public virtual void setPassword(
String password
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setPhoneNumber Method

public virtual void setPhoneNumber(
String phoneNumber
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setPolicyTimeZoneShift Method

public virtual void setPolicyTimeZoneShift(
Int32 shift
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setPostalAddress Method

public virtual void setPostalAddress(
String postalAddress
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setValidateThroughDirectoryService Method

public virtual void setValidateThroughDirectoryService(
Boolean bValidateThroughDirectoryService
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.setVoiceMailNumber Method

public virtual void setVoiceMailNumber(
String voiceMailNumber
);

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.suspend Method

Suspend this user account. The effect is immediate ( no need to call the update() method ).

public virtual void suspend();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.ToString Method

public override string ToString();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.unlock Method

Unlocks this user account. The effect is immediate ( no need to call the update() method ).

public virtual void unlock();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAccount.update Method

Create or modify this UserAccount in the StarTeam Server. If the account is new it will be created otherwise the account information will be modified.

public virtual void update();

See Also

UserAccount Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAdapter Class

For a list of all members of this type, see UserAdapter Members.

System.Object
UserAdapter

public class UserAdapter : UserListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

UserAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAdapter Members

UserAdapter overview

Public Instance Constructors

UserAdapter Constructor Initializes a new instance of the UserAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |
userAdded |
userChanged |
userDeleted |

See Also

UserAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAdapter Constructor

Initializes a new instance of the UserAdapter class.

public UserAdapter();

See Also

UserAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAdapter Methods

The methods of the UserAdapter class are listed below. For a complete list of UserAdapter class members, see the UserAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |
userAdded |
userChanged |
userDeleted |

See Also

UserAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

UserAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAdapter.ToString Method

public override string ToString();

See Also

UserAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAdapter.userAdded Method

public override void userAdded(
UserEvent e
);

Implements

UserListener.userAdded

See Also

UserAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAdapter.userChanged Method

public override void userChanged(
UserEvent e
);

Implements

UserListener.userChanged

See Also

UserAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserAdapter.userDeleted Method

public override void userDeleted(
UserEvent e
);

Implements

UserListener.userDeleted

See Also

UserAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserEvent Class

For a list of all members of this type, see UserEvent Members.

System.Object
EventObject
UserEvent

public class UserEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

UserEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserEvent Members

UserEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
getUser | Gets the User that has been added, changed or deleted, in its new state. <p> Returns a User object that is not a member of the Server's User collection (that is, it is not among the User objects returned by Server.getUsers()). There may be a User in the collection with the same ID, but it would be a physically different object that is likely to have different properties. <p> If an application wants to refresh the User objects in the Server's User collection, it must explicitly call Server.refreshUsers().
MemberwiseClone |
ToString |

See Also

UserEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserEvent Methods

The methods of the UserEvent class are listed below. For a complete list of UserEvent class members, see the UserEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
getUser | Gets the User that has been added, changed or deleted, in its new state. <p> Returns a User object that is not a member of the Server's User collection (that is, it is not among the User objects returned by Server.getUsers()). There may be a User in the collection with the same ID, but it would be a physically different object that is likely to have different properties. <p> If an application wants to refresh the User objects in the Server's User collection, it must explicitly call Server.refreshUsers().
MemberwiseClone |
ToString |

See Also

UserEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserEvent.Equals Method

public override bool Equals(
Object source
);

See Also

UserEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserEvent.GetHashCode Method

public override int GetHashCode();

See Also

UserEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserEvent.getSource Method

public override object getSource();

See Also

UserEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserEvent.getUser Method

Gets the User that has been added, changed or deleted, in its new state. <p> Returns a User object that is not a member of the Server's User collection (that is, it is not among the User objects returned by Server.getUsers()). There may be a User in the collection with the same ID, but it would be a physically different object that is likely to have different properties. <p> If an application wants to refresh the User objects in the Server's User collection, it must explicitly call Server.refreshUsers().

public virtual User getUser();

See Also

UserEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

UserEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserEvent.ToString Method

public override string ToString();

See Also

UserEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserGroupSecLogID Class

For a list of all members of this type, see UserGroupSecLogID Members.

System.Object
UserGroupSecLogID

public class UserGroupSecLogID

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

UserGroupSecLogID Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserGroupSecLogID Members

UserGroupSecLogID overview

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
getUserGroupID | Returns the user group id.
MemberwiseClone |
ToString |

See Also

UserGroupSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserGroupSecLogID Methods

The methods of the UserGroupSecLogID class are listed below. For a complete list of UserGroupSecLogID class members, see the UserGroupSecLogID Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
getUserGroupID | Returns the user group id.
MemberwiseClone |
ToString |

See Also

UserGroupSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserGroupSecLogID.Equals Method

public override bool Equals(
Object source
);

See Also

UserGroupSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserGroupSecLogID.GetHashCode Method

public override int GetHashCode();

See Also

UserGroupSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserGroupSecLogID.getUserGroupID Method

Returns the user group id.

public virtual int getUserGroupID();

See Also

UserGroupSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserGroupSecLogID.MemberwiseClone Method

public override object MemberwiseClone();

See Also

UserGroupSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserGroupSecLogID.ToString Method

public override string ToString();

See Also

UserGroupSecLogID Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserListener Interface

For a list of all members of this type, see UserListener Members.

public interface UserListener : EventListener

Types that implement UserListener

Type | Description
UserAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

UserListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserListener Members

UserListener overview

Public Instance Methods

userAdded | Invoked when a new User has been added to the server.
userChanged | Invoked when an existing User has been modified on the server. <p> Note that a UserEvent is triggered whenever any information about the user is changed, including information that is accessible only via a UserAccount object. UserAccount information is not included in the UserEvent.
userDeleted | Invoked when an existing User has been deleted on the server.

See Also

UserListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserListener Methods

The methods of the UserListener interface are listed below. For a complete list of UserListener interface members, see the UserListener Members topic.

Public Instance Methods

userAdded | Invoked when a new User has been added to the server.
userChanged | Invoked when an existing User has been modified on the server. <p> Note that a UserEvent is triggered whenever any information about the user is changed, including information that is accessible only via a UserAccount object. UserAccount information is not included in the UserEvent.
userDeleted | Invoked when an existing User has been deleted on the server.

See Also

UserListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserListener.userAdded Method

Invoked when a new User has been added to the server.

void userAdded(
UserEvent e
);

See Also

UserListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserListener.userChanged Method

Invoked when an existing User has been modified on the server. <p> Note that a UserEvent is triggered whenever any information about the user is changed, including information that is accessible only via a UserAccount object. UserAccount information is not included in the UserEvent.

void userChanged(
UserEvent e
);

See Also

UserListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UserListener.userDeleted Method

Invoked when an existing User has been deleted on the server.

void userDeleted(
UserEvent e
);

See Also

UserListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View Class

For a list of all members of this type, see View Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
View
RecycleBin
MergePreview

public class View : SimpleTypedResource, ISecurableObject, ISecurable, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

View Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View Members

View overview

Public Instance Constructors

View Overloaded. Initializes a new instance of the View class.

Public Instance Methods

acquireOwnership |
addFolderListener | Adds a listener for Folder-related events. <p> In order to handle events, an application must enable MPX.
addFolderUpdateListener | Listens for updates to this view's folder tree. <p> Similar to addFolderListener(), except that events are triggered by explicit operations performed by the client application. For example, calling View.refreshFolders(), Folder.update() or Folder.remove() might each trigger update events. <p> MPX is not required to receive folder update events.
addItemListener | Overloaded.
addItemUpdateListener |
addLabelListener | Adds a listener for Label events. <p> Event handlers will be tiggered whenever a Label is added, changed, or deleted in this View. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
addToIntArray (inherited from TypedResource) |
addViewListener | Adds a listener for View events. <p> Event handlers will be tiggered when this View is changed or deleted. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
Clone (inherited from CacheRef) |
cloneRevisionLabel |
cloneViewLabel |
close | Frees all cached resources associated with this view, and closes the associated view session. <p> Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). <p> After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
copy | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
createCheckinManager | Overloaded. Constructs a CheckinManager with default options for this view.
createCheckoutManager | Overloaded. Constructs a CheckoutManager with default options for this view.
createChildViewShareAllItems |
createChildViewShareDefaultItems |
createChildViewShareNoItems |
createChildViewShareTheseItems |
createRevisionLabel |
createViewLabel |
discard | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
discardActiveLabels | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
discardFolders | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
discardLabels | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals |
fetchAllLabels | Returns all the active (non-deleted) labels for this view. <p> The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. <p> If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
fetchAllLabelsFromView |
findFolder |
findItem |
get |
getACL |
getActiveLabels | Returns all the active (non-deleted) labels for this view. The labels are cached until explicitly refreshed.
getAlternatePath | Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.
getBaseConfiguration | Returns the ViewConfiguration from which this View was derived.
getByteArray (inherited from SimpleTypedResource) |
getConfiguration | Returns this view's configuration.
getContainerLevelACL |
getCreatedBy | Returns the user ID of the user that created the view.
getCreatedTime | Returns the time at which the view was created.
getDefaultPath | Returns the default working file path to be used for this view. This is the value stored in the repository.
getDerivedViews | Returns the set of views derived from this one.
getDescription | Returns the description of this view.
getDisembodiedItem |
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
getFileStatusManager | Get the FileBasedStatusManager that manages file status information for this View. The corresponding StarTeam Server must support client-managed status.
getFullName | Returns the full hierarchical name of this view--that is, the concatentation of the root view and each descendent to this view.
GetHashCode |
getHaveAccessRights | Obsolete. Indicates whether or not the logged on user has rights to access this view.
getHistoryForItemID |
getID |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLabels | Returns the labels that exist in this view, including both active and deleted labels. The labels are cached until explicitly refreshed.
getName | Returns the name of this view.
getNewNotificationItems |
getOLEDate (inherited from SimpleTypedResource) |
getOwner |
getParentContainer |
getParentView | Returns the parent of this view.
getPath | Returns the working file path being used for this view. This path is either the default path or the alternate path. A non-null alternate path takes precedence over a default path.
getPossibleValues (inherited from SimpleTypedResource) |
getProject | Returns the project to which this view belongs.
getPromotionModel | Returns the promotion model associated with this view.
getPropertyNames (inherited from SimpleTypedResource) |
getRecycleBin | Provides access to the items that have been deleted from a view. <p> For example: <pre> RecycleBin bin = view.getRecycleBin(); Folder root = bin.getRootFolder(); Item[] files = root.getItems(TypeNames.FILE); for (int i = 0; i < files.length; i++) { assertTrue(files[i].isDeleted()); } </pre> Note that this method is supported by StarTeam Server versions 9.0 and later.
getRootFolder | Gets the root folder of this view. The Folder hierarchy is cached in the View object, until explicitly refreshed or discarded.
getServer | Returns the server to which this view belongs.
getStatusMethodOverride | Returns the status method used to determine status for files in this view. This method will not return null.
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getViewID | Returns the unique integer identifier for this view.
hasNewNotificationItems |
hasPermission | Overloaded.
isAccessible | Determines whether or not the logged on user has access to this view.
isBranch | Return true if this view is a Branch view.
isBranchAll | Return true if this view's original branching default was set "All".
isBranchNone | Return true if this view's original branching default was set "None".
isBranchOnShare | Returns true if this view is set to branch shared items.
isDeleted | Determines whether or not this view has been deleted from the server.
isEqualTo | Compares the properties of two Views.
isNonDerived | Return true if this view is a Non-Derived view.
isReadOnly | Return true if this is a ReadOnly view, otherwise false.
isReference | Return true if this is a reference view, otherwise false.
isRefreshActiveLabelsRequired | Returns true if a refreshLabels() operation might have resulted in Label information for active (non-deleted) labels being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshFoldersRequired | Returns true if a View.refreshFolders() operation might have resulted in Folder information being updated; returns false if and only if it is known that the folders had not been changed since the last refresh. If MPX is not enabled, then isRefreshFoldersRequired() always returns true.
isRefreshLabelsRequired | Returns true if a refreshLabels() operation might have resulted in Label information being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshRequired | Returns true if a refresh() operation might have resulted in view properties being updated; returns false if and only if it is known that the view properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isRoot | Return true if this view is a Root view.
MemberwiseClone (inherited from CacheRef) |
modifyItemsFlagForUser |
modifyItemsReadStatusForUser |
populate | Populates project properties, if they have not already been populated.
put |
putByPropertyID |
refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
refreshActiveLabels | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
refreshFolders | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. <p> If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. <p> In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
refreshLabels | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
refreshPromotionModel | Refreshes the local cached information about this view's promotion model.
remove | Removes the view from the server.
removeFolderListener | Removes a listener for Folder-related events.
removeFolderUpdateListener | Removes a listener for folder update events.
removeFromIntArray (inherited from TypedResource) |
removeItemListener |
removeItemUpdateListener |
removeLabelListener | Removes a listener for Label events.
removeViewListener | Removes a listener for View events.
resolveLinkEndpoint | Returns the item in this view referred to by the <code>LinkEndpoint</code>. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
setACL |
setAlternatePath |
setBranchOnShare |
setContainerLevelACL |
setDefaultPath |
setDescription |
setName |
setStatusMethodOverride | Changes the status method to use for files in this view. This is a client side setting and will not change the behavior for other users of this view.
ToString |
update | Persists this view's properties to its <code>Server</code>.

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View Constructor

Overload List

public View(View,ViewConfiguration);

public View(View,Boolean,Boolean,String,String,Folder,String,ViewConfiguration,Boolean);

public View(View,String,String,String);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View Constructor (View, Boolean, Boolean, String, String, Folder, String, ViewConfiguration, Boolean)

public View(
View parent,
Boolean bIsVariantView,
Boolean bIsROView,
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

See Also

View Class | com.starbase.starteam Namespace | View Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View Constructor (View, String, String, String)

public View(
View parent,
String name,
String description,
String defaultWorkingFolder
);

See Also

View Class | com.starbase.starteam Namespace | View Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View Constructor (View, ViewConfiguration)

public View(
View view,
ViewConfiguration configuration
);

See Also

View Class | com.starbase.starteam Namespace | View Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View Methods

The methods of the View class are listed below. For a complete list of View class members, see the View Members topic.

Public Instance Methods

acquireOwnership |
addFolderListener | Adds a listener for Folder-related events. <p> In order to handle events, an application must enable MPX.
addFolderUpdateListener | Listens for updates to this view's folder tree. <p> Similar to addFolderListener(), except that events are triggered by explicit operations performed by the client application. For example, calling View.refreshFolders(), Folder.update() or Folder.remove() might each trigger update events. <p> MPX is not required to receive folder update events.
addItemListener | Overloaded.
addItemUpdateListener |
addLabelListener | Adds a listener for Label events. <p> Event handlers will be tiggered whenever a Label is added, changed, or deleted in this View. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
addToIntArray (inherited from TypedResource) |
addViewListener | Adds a listener for View events. <p> Event handlers will be tiggered when this View is changed or deleted. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
Clone (inherited from CacheRef) |
cloneRevisionLabel |
cloneViewLabel |
close | Frees all cached resources associated with this view, and closes the associated view session. <p> Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). <p> After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
copy | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
createCheckinManager | Overloaded. Constructs a CheckinManager with default options for this view.
createCheckoutManager | Overloaded. Constructs a CheckoutManager with default options for this view.
createChildViewShareAllItems |
createChildViewShareDefaultItems |
createChildViewShareNoItems |
createChildViewShareTheseItems |
createRevisionLabel |
createViewLabel |
discard | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
discardActiveLabels | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
discardFolders | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
discardLabels | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals |
fetchAllLabels | Returns all the active (non-deleted) labels for this view. <p> The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. <p> If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
fetchAllLabelsFromView |
findFolder |
findItem |
get |
getACL |
getActiveLabels | Returns all the active (non-deleted) labels for this view. The labels are cached until explicitly refreshed.
getAlternatePath | Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.
getBaseConfiguration | Returns the ViewConfiguration from which this View was derived.
getByteArray (inherited from SimpleTypedResource) |
getConfiguration | Returns this view's configuration.
getContainerLevelACL |
getCreatedBy | Returns the user ID of the user that created the view.
getCreatedTime | Returns the time at which the view was created.
getDefaultPath | Returns the default working file path to be used for this view. This is the value stored in the repository.
getDerivedViews | Returns the set of views derived from this one.
getDescription | Returns the description of this view.
getDisembodiedItem |
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
getFileStatusManager | Get the FileBasedStatusManager that manages file status information for this View. The corresponding StarTeam Server must support client-managed status.
getFullName | Returns the full hierarchical name of this view--that is, the concatentation of the root view and each descendent to this view.
GetHashCode |
getHaveAccessRights | Obsolete. Indicates whether or not the logged on user has rights to access this view.
getHistoryForItemID |
getID |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLabels | Returns the labels that exist in this view, including both active and deleted labels. The labels are cached until explicitly refreshed.
getName | Returns the name of this view.
getNewNotificationItems |
getOLEDate (inherited from SimpleTypedResource) |
getOwner |
getParentContainer |
getParentView | Returns the parent of this view.
getPath | Returns the working file path being used for this view. This path is either the default path or the alternate path. A non-null alternate path takes precedence over a default path.
getPossibleValues (inherited from SimpleTypedResource) |
getProject | Returns the project to which this view belongs.
getPromotionModel | Returns the promotion model associated with this view.
getPropertyNames (inherited from SimpleTypedResource) |
getRecycleBin | Provides access to the items that have been deleted from a view. <p> For example: <pre> RecycleBin bin = view.getRecycleBin(); Folder root = bin.getRootFolder(); Item[] files = root.getItems(TypeNames.FILE); for (int i = 0; i < files.length; i++) { assertTrue(files[i].isDeleted()); } </pre> Note that this method is supported by StarTeam Server versions 9.0 and later.
getRootFolder | Gets the root folder of this view. The Folder hierarchy is cached in the View object, until explicitly refreshed or discarded.
getServer | Returns the server to which this view belongs.
getStatusMethodOverride | Returns the status method used to determine status for files in this view. This method will not return null.
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getViewID | Returns the unique integer identifier for this view.
hasNewNotificationItems |
hasPermission | Overloaded.
isAccessible | Determines whether or not the logged on user has access to this view.
isBranch | Return true if this view is a Branch view.
isBranchAll | Return true if this view's original branching default was set "All".
isBranchNone | Return true if this view's original branching default was set "None".
isBranchOnShare | Returns true if this view is set to branch shared items.
isDeleted | Determines whether or not this view has been deleted from the server.
isEqualTo | Compares the properties of two Views.
isNonDerived | Return true if this view is a Non-Derived view.
isReadOnly | Return true if this is a ReadOnly view, otherwise false.
isReference | Return true if this is a reference view, otherwise false.
isRefreshActiveLabelsRequired | Returns true if a refreshLabels() operation might have resulted in Label information for active (non-deleted) labels being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshFoldersRequired | Returns true if a View.refreshFolders() operation might have resulted in Folder information being updated; returns false if and only if it is known that the folders had not been changed since the last refresh. If MPX is not enabled, then isRefreshFoldersRequired() always returns true.
isRefreshLabelsRequired | Returns true if a refreshLabels() operation might have resulted in Label information being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshRequired | Returns true if a refresh() operation might have resulted in view properties being updated; returns false if and only if it is known that the view properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isRoot | Return true if this view is a Root view.
MemberwiseClone (inherited from CacheRef) |
modifyItemsFlagForUser |
modifyItemsReadStatusForUser |
populate | Populates project properties, if they have not already been populated.
put |
putByPropertyID |
refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
refreshActiveLabels | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
refreshFolders | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. <p> If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. <p> In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
refreshLabels | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
refreshPromotionModel | Refreshes the local cached information about this view's promotion model.
remove | Removes the view from the server.
removeFolderListener | Removes a listener for Folder-related events.
removeFolderUpdateListener | Removes a listener for folder update events.
removeFromIntArray (inherited from TypedResource) |
removeItemListener |
removeItemUpdateListener |
removeLabelListener | Removes a listener for Label events.
removeViewListener | Removes a listener for View events.
resolveLinkEndpoint | Returns the item in this view referred to by the <code>LinkEndpoint</code>. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
setACL |
setAlternatePath |
setBranchOnShare |
setContainerLevelACL |
setDefaultPath |
setDescription |
setName |
setStatusMethodOverride | Changes the status method to use for files in this view. This is a client side setting and will not change the behavior for other users of this view.
ToString |
update | Persists this view's properties to its <code>Server</code>.

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.acquireOwnership Method

public virtual void acquireOwnership();

Implements

ISecurableObject.acquireOwnership

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.addFolderListener Method

Adds a listener for Folder-related events. <p> In order to handle events, an application must enable MPX.

public virtual void addFolderListener(
IFolderListener listener
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.addFolderUpdateListener Method

Listens for updates to this view's folder tree. <p> Similar to addFolderListener(), except that events are triggered by explicit operations performed by the client application. For example, calling View.refreshFolders(), Folder.update() or Folder.remove() might each trigger update events. <p> MPX is not required to receive folder update events.

public virtual void addFolderUpdateListener(
FolderUpdateListener listener
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


addItemListener Method

Borland StarTeam SDK for .NET

View.addItemListener Method

Overload List

public virtual void addItemListener(IItemListener,Type);

public virtual void addItemListener(IItemListener,Type,String[]);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.addItemListener Method (IItemListener, Type)

public virtual void addItemListener(
IItemListener listener,
Type type
);

See Also

View Class | com.starbase.starteam Namespace | View.addItemListener Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.addItemListener Method (IItemListener, Type, String[])

public virtual void addItemListener(
IItemListener listener,
Type type,
String[] propertyNames
);

See Also

View Class | com.starbase.starteam Namespace | View.addItemListener Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.addItemUpdateListener Method

public virtual void addItemUpdateListener(
ItemUpdateListener listener,
Type type
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.addLabelListener Method

Adds a listener for Label events. <p> Event handlers will be tiggered whenever a Label is added, changed, or deleted in this View. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.

public virtual void addLabelListener(
LabelListener listener
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.addViewListener Method

Adds a listener for View events. <p> Event handlers will be tiggered when this View is changed or deleted. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.

public virtual void addViewListener(
ViewListener listener
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.cloneRevisionLabel Method

public virtual Label cloneRevisionLabel(
Label source,
String name,
String description,
Boolean frozen
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.cloneViewLabel Method

public virtual Label cloneViewLabel(
Label source,
String name,
String description,
Boolean buildLabel,
Boolean frozen
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.close Method

Frees all cached resources associated with this view, and closes the associated view session. <p> Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). <p> After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.

public virtual void close();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.copy Method

Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().

public virtual View copy();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


createCheckinManager Method

Borland StarTeam SDK for .NET

View.createCheckinManager Method

Constructs a CheckinManager with default options for this view.

Overload List

Constructs a CheckinManager with default options for this view.

public virtual CheckinManager createCheckinManager();

Constructs a CheckinManager using a specific set of options. <p> Note that individual options can be overridden on a file-by-file basis by registering a CheckinListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckinManager createCheckinManager(CheckinOptions);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.createCheckinManager Method ()

Constructs a CheckinManager with default options for this view.

public virtual CheckinManager createCheckinManager();

See Also

View Class | com.starbase.starteam Namespace | View.createCheckinManager Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.createCheckinManager Method (CheckinOptions)

Constructs a CheckinManager using a specific set of options. <p> Note that individual options can be overridden on a file-by-file basis by registering a CheckinListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckinManager createCheckinManager(
CheckinOptions options
);

See Also

View Class | com.starbase.starteam Namespace | View.createCheckinManager Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


createCheckoutManager Method

Borland StarTeam SDK for .NET

View.createCheckoutManager Method

Constructs a CheckoutManager with default options for this view.

Overload List

Constructs a CheckoutManager with default options for this view.

public virtual CheckoutManager createCheckoutManager();

Constructs a CheckoutManager using a specific set of options. <p> Note that individual options can be overridden on a file-by-file basis by registering a CheckoutListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckoutManager createCheckoutManager(CheckoutOptions);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.createCheckoutManager Method ()

Constructs a CheckoutManager with default options for this view.

public virtual CheckoutManager createCheckoutManager();

See Also

View Class | com.starbase.starteam Namespace | View.createCheckoutManager Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.createCheckoutManager Method (CheckoutOptions)

Constructs a CheckoutManager using a specific set of options. <p> Note that individual options can be overridden on a file-by-file basis by registering a CheckoutListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckoutManager createCheckoutManager(
CheckoutOptions options
);

See Also

View Class | com.starbase.starteam Namespace | View.createCheckoutManager Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.createChildViewShareAllItems Method

public virtual View createChildViewShareAllItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.createChildViewShareDefaultItems Method

public virtual View createChildViewShareDefaultItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.createChildViewShareNoItems Method

public virtual View createChildViewShareNoItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.createChildViewShareTheseItems Method

public virtual View createChildViewShareTheseItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched,
Type[] itemTypes
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.createRevisionLabel Method

public virtual Label createRevisionLabel(
String name,
String description,
Boolean frozen
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.createViewLabel Method

public virtual Label createViewLabel(
String name,
String description,
OLEDate time,
Boolean buildLabel,
Boolean frozen
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.discard Method

Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.

public virtual void discard();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.discardActiveLabels Method

Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).

public virtual void discardActiveLabels();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.discardFolders Method

Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void discardFolders();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.discardLabels Method

Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).

public virtual void discardLabels();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.Equals Method

public override bool Equals(
Object another
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.fetchAllLabels Method

Returns all the active (non-deleted) labels for this view. <p> The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. <p> If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.

public virtual Label[] fetchAllLabels();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.fetchAllLabelsFromView Method

public virtual Label[] fetchAllLabelsFromView(
Int32 projectID,
Int32 viewID
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.findFolder Method

public virtual Folder findFolder(
Int32 itemID
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.findItem Method

public virtual Item findItem(
Type type,
Int32 itemID
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.get Method

public override object get(
String propertyName
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getACL Method

public virtual AclEntry[] getACL();

Implements

ISecurable.getACL

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getActiveLabels Method

Returns all the active (non-deleted) labels for this view. The labels are cached until explicitly refreshed.

public virtual Label[] getActiveLabels();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getAlternatePath Method

Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.

public virtual string getAlternatePath();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getBaseConfiguration Method

Returns the ViewConfiguration from which this View was derived.

public virtual ViewConfiguration getBaseConfiguration();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getConfiguration Method

Returns this view's configuration.

public virtual ViewConfiguration getConfiguration();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getContainerLevelACL Method

public virtual AclEntry[] getContainerLevelACL(
String typeName
);

Implements

ISecurableContainer.getContainerLevelACL

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getCreatedBy Method

Returns the user ID of the user that created the view.

public virtual int getCreatedBy();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getCreatedTime Method

Returns the time at which the view was created.

public virtual OLEDate getCreatedTime();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getDefaultPath Method

Returns the default working file path to be used for this view. This is the value stored in the repository.

public virtual string getDefaultPath();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getDerivedViews Method

Returns the set of views derived from this one.

public virtual View[] getDerivedViews();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getDescription Method

Returns the description of this view.

public virtual string getDescription();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getDisembodiedItem Method

public virtual Item getDisembodiedItem(
Int32 itemID,
Type type
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getFileStatusManager Method

Get the FileBasedStatusManager that manages file status information for this View. The corresponding StarTeam Server must support client-managed status.

public virtual FileBasedStatusManager getFileStatusManager();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getFullName Method

Returns the full hierarchical name of this view--that is, the concatentation of the root view and each descendent to this view.

public virtual string getFullName();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.GetHashCode Method

public override int GetHashCode();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getHaveAccessRights Method

NOTE: This method is now obsolete.

Indicates whether or not the logged on user has rights to access this view.

public virtual bool getHaveAccessRights();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getHistoryForItemID Method

public virtual Item[] getHistoryForItemID(
Int32 itemID,
Type type
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getID Method

public override int getID();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getLabels Method

Returns the labels that exist in this view, including both active and deleted labels. The labels are cached until explicitly refreshed.

public virtual Label[] getLabels();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getName Method

Returns the name of this view.

public virtual string getName();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getNewNotificationItems Method

public virtual NotificationItem[] getNewNotificationItems(
String typeName
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getOwner Method

public virtual int getOwner();

Implements

ISecurableObject.getOwner

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getParentContainer Method

public virtual ISecurableContainer getParentContainer();

Implements

ISecurableContainer.getParentContainer

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getParentView Method

Returns the parent of this view.

public virtual View getParentView();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getPath Method

Returns the working file path being used for this view. This path is either the default path or the alternate path. A non-null alternate path takes precedence over a default path.

public virtual string getPath();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getProject Method

Returns the project to which this view belongs.

public virtual Project getProject();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getPromotionModel Method

Returns the promotion model associated with this view.

public virtual PromotionModel getPromotionModel();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getRecycleBin Method

Provides access to the items that have been deleted from a view. <p> For example: <pre> RecycleBin bin = view.getRecycleBin(); Folder root = bin.getRootFolder(); Item[] files = root.getItems(TypeNames.FILE); for (int i = 0; i < files.length; i++) { assertTrue(files[i].isDeleted()); } </pre> Note that this method is supported by StarTeam Server versions 9.0 and later.

public virtual RecycleBin getRecycleBin();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getRootFolder Method

Gets the root folder of this view. The Folder hierarchy is cached in the View object, until explicitly refreshed or discarded.

public virtual Folder getRootFolder();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getServer Method

Returns the server to which this view belongs.

public virtual Server getServer();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getStatusMethodOverride Method

Returns the status method used to determine status for files in this view. This method will not return null.

public virtual StatusMethod getStatusMethodOverride();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.getViewID Method

Returns the unique integer identifier for this view.

public virtual int getViewID();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.hasNewNotificationItems Method

public virtual bool hasNewNotificationItems(
String typeName
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


hasPermission Method

Borland StarTeam SDK for .NET

View.hasPermission Method

Overload List

public virtual bool hasPermission(Int32);

public virtual bool hasPermission(Int32,String);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.hasPermission Method (Int32)

public virtual bool hasPermission(
Int32 permissions
);

Implements

ISecurable.hasPermission

See Also

View Class | com.starbase.starteam Namespace | View.hasPermission Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.hasPermission Method (Int32, String)

public virtual bool hasPermission(
Int32 permissions,
String typeName
);

Implements

ISecurableContainer.hasPermission

See Also

View Class | com.starbase.starteam Namespace | View.hasPermission Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isAccessible Method

Determines whether or not the logged on user has access to this view.

public virtual bool isAccessible();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isBranch Method

Return true if this view is a Branch view.

public virtual bool isBranch();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isBranchAll Method

Return true if this view's original branching default was set "All".

public virtual bool isBranchAll();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isBranchNone Method

Return true if this view's original branching default was set "None".

public virtual bool isBranchNone();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isBranchOnShare Method

Returns true if this view is set to branch shared items.

public virtual bool isBranchOnShare();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isDeleted Method

Determines whether or not this view has been deleted from the server.

public virtual bool isDeleted();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isEqualTo Method

Compares the properties of two Views.

public virtual bool isEqualTo(
View view
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isNonDerived Method

Return true if this view is a Non-Derived view.

public virtual bool isNonDerived();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isReadOnly Method

Return true if this is a ReadOnly view, otherwise false.

public virtual bool isReadOnly();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isReference Method

Return true if this is a reference view, otherwise false.

public virtual bool isReference();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isRefreshActiveLabelsRequired Method

Returns true if a refreshLabels() operation might have resulted in Label information for active (non-deleted) labels being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.

public virtual bool isRefreshActiveLabelsRequired();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isRefreshFoldersRequired Method

Returns true if a View.refreshFolders() operation might have resulted in Folder information being updated; returns false if and only if it is known that the folders had not been changed since the last refresh. If MPX is not enabled, then isRefreshFoldersRequired() always returns true.

public virtual bool isRefreshFoldersRequired();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isRefreshLabelsRequired Method

Returns true if a refreshLabels() operation might have resulted in Label information being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.

public virtual bool isRefreshLabelsRequired();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isRefreshRequired Method

Returns true if a refresh() operation might have resulted in view properties being updated; returns false if and only if it is known that the view properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.

public virtual bool isRefreshRequired();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.isRoot Method

Return true if this view is a Root view.

public virtual bool isRoot();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.modifyItemsFlagForUser Method

public virtual void modifyItemsFlagForUser(
Int32[] itemIDs,
Type type,
Boolean setFlagged
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.modifyItemsReadStatusForUser Method

public virtual void modifyItemsReadStatusForUser(
Int32[] itemIDs,
Type type,
Boolean bSetAsRead
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.populate Method

Populates project properties, if they have not already been populated.

public virtual void populate();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.put Method

public override object put(
String propertyName,
Object value
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.putByPropertyID Method

public override object putByPropertyID(
Int32 propertyID,
Object value
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.refresh Method

Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void refresh();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.refreshActiveLabels Method

Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.

public virtual void refreshActiveLabels();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.refreshFolders Method

Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. <p> If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. <p> In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.

public virtual void refreshFolders();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.refreshLabels Method

Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.

public virtual void refreshLabels();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.refreshPromotionModel Method

Refreshes the local cached information about this view's promotion model.

public virtual void refreshPromotionModel();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.remove Method

Removes the view from the server.

public virtual void remove();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.removeFolderListener Method

Removes a listener for Folder-related events.

public virtual void removeFolderListener(
IFolderListener listener
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.removeFolderUpdateListener Method

Removes a listener for folder update events.

public virtual void removeFolderUpdateListener(
FolderUpdateListener listener
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.removeItemListener Method

public virtual void removeItemListener(
IItemListener listener,
Type type
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.removeItemUpdateListener Method

public virtual void removeItemUpdateListener(
ItemUpdateListener listener,
Type type
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.removeLabelListener Method

Removes a listener for Label events.

public virtual void removeLabelListener(
LabelListener listener
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.removeViewListener Method

Removes a listener for View events.

public virtual void removeViewListener(
ViewListener listener
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.resolveLinkEndpoint Method

Returns the item in this view referred to by the <code>LinkEndpoint</code>. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.

public virtual Item resolveLinkEndpoint(
LinkEndpoint endpoint
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.setACL Method

public virtual void setACL(
AclEntry[] acl
);

Implements

ISecurable.setACL

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.setAlternatePath Method

public virtual void setAlternatePath(
String path
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.setBranchOnShare Method

public virtual void setBranchOnShare(
Boolean branchOnShare
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.setContainerLevelACL Method

public virtual void setContainerLevelACL(
AclEntry[] acl,
String typeName
);

Implements

ISecurableContainer.setContainerLevelACL

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.setDefaultPath Method

public virtual void setDefaultPath(
String path
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.setDescription Method

public virtual void setDescription(
String description
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.setName Method

public virtual void setName(
String name
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.setStatusMethodOverride Method

Changes the status method to use for files in this view. This is a client side setting and will not change the behavior for other users of this view.

public virtual void setStatusMethodOverride(
StatusMethod method
);

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.ToString Method

public override string ToString();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


View.update Method

Persists this view's properties to its <code>Server</code>.

public virtual void update();

See Also

View Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewAdapter Class

For a list of all members of this type, see ViewAdapter Members.

System.Object
ViewAdapter

public class ViewAdapter : ViewListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ViewAdapter Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewAdapter Members

ViewAdapter overview

Public Instance Constructors

ViewAdapter Constructor Initializes a new instance of the ViewAdapter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |
viewAdded |
viewChanged |
viewDeleted |

See Also

ViewAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewAdapter Constructor

Initializes a new instance of the ViewAdapter class.

public ViewAdapter();

See Also

ViewAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewAdapter Methods

The methods of the ViewAdapter class are listed below. For a complete list of ViewAdapter class members, see the ViewAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |
viewAdded |
viewChanged |
viewDeleted |

See Also

ViewAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ViewAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewAdapter.ToString Method

public override string ToString();

See Also

ViewAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewAdapter.viewAdded Method

public override void viewAdded(
ViewEvent e
);

Implements

ViewListener.viewAdded

See Also

ViewAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewAdapter.viewChanged Method

public override void viewChanged(
ViewEvent e
);

Implements

ViewListener.viewChanged

See Also

ViewAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewAdapter.viewDeleted Method

public override void viewDeleted(
ViewEvent e
);

Implements

ViewListener.viewDeleted

See Also

ViewAdapter Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration Class

For a list of all members of this type, see ViewConfiguration Members.

System.Object
ViewConfiguration

public class ViewConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ViewConfiguration Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration Members

ViewConfiguration overview

Public Static Methods

createFromLabel |
createFromPromotionState |
createFromTime | Creates a new ViewConfiguration object that represents a view as-of a specified point in time.
createTip | Creates a new ViewConfiguration object that represents the current or "tip" state of a view.

Public Instance Methods

Equals |
GetHashCode |
getLabelID | Return the label ID for this configuration. Will throw an exception if the configuration is not label-based.
getPromotionStateID | Return the PromotionSate ID for this configuration. Will throw an exception if the configuration is not promotion state-based.
getTime | Return the as-of time for this configuration. Will throw an exception if the configuration is not time-based.
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo | returns true if this ViewConfiguration instance can be considered equal to the other
isLabelBased | Return true if this configuration is label-based.
isPromotionStateBased | Return true if this configuration is based on a <code>PromotionState</code>.
isTimeBased | Return true if this configuration is time-based.
isTip | Return true if this configuration is "tip" or "current".
MemberwiseClone |
ToString |

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration Methods

The methods of the ViewConfiguration class are listed below. For a complete list of ViewConfiguration class members, see the ViewConfiguration Members topic.

Public Static Methods

createFromLabel |
createFromPromotionState |
createFromTime | Creates a new ViewConfiguration object that represents a view as-of a specified point in time.
createTip | Creates a new ViewConfiguration object that represents the current or "tip" state of a view.

Public Instance Methods

Equals |
GetHashCode |
getLabelID | Return the label ID for this configuration. Will throw an exception if the configuration is not label-based.
getPromotionStateID | Return the PromotionSate ID for this configuration. Will throw an exception if the configuration is not promotion state-based.
getTime | Return the as-of time for this configuration. Will throw an exception if the configuration is not time-based.
GetType (inherited from Object) | Gets the Type of the current instance.
isEqualTo | returns true if this ViewConfiguration instance can be considered equal to the other
isLabelBased | Return true if this configuration is label-based.
isPromotionStateBased | Return true if this configuration is based on a <code>PromotionState</code>.
isTimeBased | Return true if this configuration is time-based.
isTip | Return true if this configuration is "tip" or "current".
MemberwiseClone |
ToString |

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.createFromLabel Method

public static ViewConfiguration createFromLabel(
Int32 labelID
);

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.createFromPromotionState Method

public static ViewConfiguration createFromPromotionState(
Int32 stateID
);

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.createFromTime Method

Creates a new ViewConfiguration object that represents a view as-of a specified point in time.

public static ViewConfiguration createFromTime(
OLEDate oleTime
);

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.createTip Method

Creates a new ViewConfiguration object that represents the current or "tip" state of a view.

public static ViewConfiguration createTip();

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.Equals Method

public override bool Equals(
Object source
);

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.GetHashCode Method

public override int GetHashCode();

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.getLabelID Method

Return the label ID for this configuration. Will throw an exception if the configuration is not label-based.

public virtual int getLabelID();

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.getPromotionStateID Method

Return the PromotionSate ID for this configuration. Will throw an exception if the configuration is not promotion state-based.

public virtual int getPromotionStateID();

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.getTime Method

Return the as-of time for this configuration. Will throw an exception if the configuration is not time-based.

public virtual OLEDate getTime();

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.isEqualTo Method

returns true if this ViewConfiguration instance can be considered equal to the other

public virtual bool isEqualTo(
ViewConfiguration theOther
);

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.isLabelBased Method

Return true if this configuration is label-based.

public virtual bool isLabelBased();

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.isPromotionStateBased Method

Return true if this configuration is based on a <code>PromotionState</code>.

public virtual bool isPromotionStateBased();

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.isTimeBased Method

Return true if this configuration is time-based.

public virtual bool isTimeBased();

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.isTip Method

Return true if this configuration is "tip" or "current".

public virtual bool isTip();

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfiguration.ToString Method

public override string ToString();

See Also

ViewConfiguration Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer Class

For a list of all members of this type, see ViewConfigurationDiffer Members.

System.Object
ViewConfigurationDiffer

public class ViewConfigurationDiffer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ViewConfigurationDiffer Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer Members

ViewConfigurationDiffer overview

Public Instance Constructors

ViewConfigurationDiffer Constructor Constructs a new ViewCOnfigurationDiffer.

Public Instance Methods

addFolderUpdateListener | Registers a FolderUpdateListener, whose methods will be invoked during a compare() whenever changes to the folder tree are detected.
addItemUpdateListener |
addRequiredPropertyName |
addRequiredPropertyNames |
close | Frees all cached resources associated with this ViewConfigurationDiffer, and closes the associated view.
compare |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
removeFolderUpdateListener | Unregisters a previously registered FolderUpdateListener.
removeItemUpdateListener |
setAllPropertyNamesRequired | Marks all property names as required for a given type. All properties will be populated as items of the given type are compared.
ToString |

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer Constructor

Constructs a new ViewCOnfigurationDiffer.

public ViewConfigurationDiffer(
View view
);

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer Methods

The methods of the ViewConfigurationDiffer class are listed below. For a complete list of ViewConfigurationDiffer class members, see the ViewConfigurationDiffer Members topic.

Public Instance Methods

addFolderUpdateListener | Registers a FolderUpdateListener, whose methods will be invoked during a compare() whenever changes to the folder tree are detected.
addItemUpdateListener |
addRequiredPropertyName |
addRequiredPropertyNames |
close | Frees all cached resources associated with this ViewConfigurationDiffer, and closes the associated view.
compare |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
removeFolderUpdateListener | Unregisters a previously registered FolderUpdateListener.
removeItemUpdateListener |
setAllPropertyNamesRequired | Marks all property names as required for a given type. All properties will be populated as items of the given type are compared.
ToString |

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.addFolderUpdateListener Method

Registers a FolderUpdateListener, whose methods will be invoked during a compare() whenever changes to the folder tree are detected.

public virtual void addFolderUpdateListener(
FolderUpdateListener listener
);

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.addItemUpdateListener Method

public virtual void addItemUpdateListener(
ItemUpdateListener listener,
Type type
);

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.addRequiredPropertyName Method

public virtual void addRequiredPropertyName(
Type type,
String propertyName
);

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.addRequiredPropertyNames Method

public virtual void addRequiredPropertyNames(
Type type,
String[] propertyNames
);

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.close Method

Frees all cached resources associated with this ViewConfigurationDiffer, and closes the associated view.

public virtual void close();

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.compare Method

public virtual void compare(
ViewConfiguration config1,
ViewConfiguration config2
);

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.Equals Method

public override bool Equals(
Object source
);

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.GetHashCode Method

public override int GetHashCode();

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.removeFolderUpdateListener Method

Unregisters a previously registered FolderUpdateListener.

public virtual void removeFolderUpdateListener(
FolderUpdateListener listener
);

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.removeItemUpdateListener Method

public virtual void removeItemUpdateListener(
ItemUpdateListener listener,
Type type
);

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.setAllPropertyNamesRequired Method

Marks all property names as required for a given type. All properties will be populated as items of the given type are compared.

public virtual void setAllPropertyNamesRequired(
Type type
);

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewConfigurationDiffer.ToString Method

public override string ToString();

See Also

ViewConfigurationDiffer Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewEvent Class

For a list of all members of this type, see ViewEvent Members.

System.Object
EventObject
ViewEvent

public class ViewEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ViewEvent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewEvent Members

ViewEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
getView | Gets the View that has been added, changed or deleted, in its new state.
MemberwiseClone |
ToString |

See Also

ViewEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewEvent Methods

The methods of the ViewEvent class are listed below. For a complete list of ViewEvent class members, see the ViewEvent Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetObjectData (inherited from java.util.EventObject) |
getSource |
GetType (inherited from Object) | Gets the Type of the current instance.
getView | Gets the View that has been added, changed or deleted, in its new state.
MemberwiseClone |
ToString |

See Also

ViewEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewEvent.Equals Method

public override bool Equals(
Object source
);

See Also

ViewEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewEvent.GetHashCode Method

public override int GetHashCode();

See Also

ViewEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewEvent.getSource Method

public override object getSource();

See Also

ViewEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewEvent.getView Method

Gets the View that has been added, changed or deleted, in its new state.

public virtual View getView();

See Also

ViewEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ViewEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewEvent.ToString Method

public override string ToString();

See Also

ViewEvent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewListener Interface

For a list of all members of this type, see ViewListener Members.

public interface ViewListener : EventListener

Types that implement ViewListener

Type | Description
ViewAdapter |

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ViewListener Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewListener Members

ViewListener overview

Public Instance Methods

viewAdded | Invoked when a new View has been added to the server.
viewChanged | Invoked when an existing View has been modified on the server.
viewDeleted | Invoked when an existing View has been deleted on the server.

See Also

ViewListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewListener Methods

The methods of the ViewListener interface are listed below. For a complete list of ViewListener interface members, see the ViewListener Members topic.

Public Instance Methods

viewAdded | Invoked when a new View has been added to the server.
viewChanged | Invoked when an existing View has been modified on the server.
viewDeleted | Invoked when an existing View has been deleted on the server.

See Also

ViewListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewListener.viewAdded Method

Invoked when a new View has been added to the server.

void viewAdded(
ViewEvent e
);

See Also

ViewListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewListener.viewChanged Method

Invoked when an existing View has been modified on the server.

void viewChanged(
ViewEvent e
);

See Also

ViewListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewListener.viewDeleted Method

Invoked when an existing View has been deleted on the server.

void viewDeleted(
ViewEvent e
);

See Also

ViewListener Interface | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent Class

For a list of all members of this type, see ViewPollingAgent Members.

System.Object
ViewPollingAgent

public class ViewPollingAgent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ViewPollingAgent Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent Members

ViewPollingAgent overview

Public Instance Constructors

ViewPollingAgent Constructor

Public Instance Methods

addFolderUpdateListener | Registers a FolderUpdateListener, whose methods will be invoked during a refresh() whenever changes to the folder tree are detected.
addItemUpdateListener |
addRequiredPropertyName |
addRequiredPropertyNames |
close | Frees all cached resources associated with this ViewPollingAgent, and closes the associated view.
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
refresh | Refreshes the view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected since the previous refresh (or since the start ViewPollingAgent's start time, if this is the first refresh). <p> The folder tree is always refreshed. In addition, all items a refreshed for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.
removeFolderUpdateListener | Unregisters a previously registered FolderUpdateListener.
removeItemUpdateListener |
setAllPropertyNamesRequired | Marks all property names as required for a given type. All refresh operations on that type will include all properties.
ToString |

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent Constructor

public ViewPollingAgent(
View view,
OLEDate startTime
);

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent Methods

The methods of the ViewPollingAgent class are listed below. For a complete list of ViewPollingAgent class members, see the ViewPollingAgent Members topic.

Public Instance Methods

addFolderUpdateListener | Registers a FolderUpdateListener, whose methods will be invoked during a refresh() whenever changes to the folder tree are detected.
addItemUpdateListener |
addRequiredPropertyName |
addRequiredPropertyNames |
close | Frees all cached resources associated with this ViewPollingAgent, and closes the associated view.
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
refresh | Refreshes the view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected since the previous refresh (or since the start ViewPollingAgent's start time, if this is the first refresh). <p> The folder tree is always refreshed. In addition, all items a refreshed for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.
removeFolderUpdateListener | Unregisters a previously registered FolderUpdateListener.
removeItemUpdateListener |
setAllPropertyNamesRequired | Marks all property names as required for a given type. All refresh operations on that type will include all properties.
ToString |

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.addFolderUpdateListener Method

Registers a FolderUpdateListener, whose methods will be invoked during a refresh() whenever changes to the folder tree are detected.

public virtual void addFolderUpdateListener(
FolderUpdateListener listener
);

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.addItemUpdateListener Method

public virtual void addItemUpdateListener(
ItemUpdateListener listener,
Type type
);

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.addRequiredPropertyName Method

public virtual void addRequiredPropertyName(
Type type,
String propertyName
);

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.addRequiredPropertyNames Method

public virtual void addRequiredPropertyNames(
Type type,
String[] propertyNames
);

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.close Method

Frees all cached resources associated with this ViewPollingAgent, and closes the associated view.

public virtual void close();

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.Equals Method

public override bool Equals(
Object source
);

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.GetHashCode Method

public override int GetHashCode();

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.refresh Method

Refreshes the view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected since the previous refresh (or since the start ViewPollingAgent's start time, if this is the first refresh). <p> The folder tree is always refreshed. In addition, all items a refreshed for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.

public virtual OLEDate refresh();

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.removeFolderUpdateListener Method

Unregisters a previously registered FolderUpdateListener.

public virtual void removeFolderUpdateListener(
FolderUpdateListener listener
);

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.removeItemUpdateListener Method

public virtual void removeItemUpdateListener(
ItemUpdateListener listener,
Type type
);

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.setAllPropertyNamesRequired Method

Marks all property names as required for a given type. All refresh operations on that type will include all properties.

public virtual void setAllPropertyNamesRequired(
Type type
);

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ViewPollingAgent.ToString Method

public override string ToString();

See Also

ViewPollingAgent Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord Class

For a list of all members of this type, see WorkRecord Members.

System.Object
WorkRecord

public class WorkRecord

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

WorkRecord Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord Members

WorkRecord overview

Public Instance Constructors

WorkRecord Constructor

Public Instance Methods

Equals |
getDateWorkBegan | Returns the date on which the work was begun. The default value for a new instance is equal to the creation time of the instance.
GetHashCode |
getHoursRemaining | Returns the estimated number of hours remaining to complete the task after this period.
getHoursWorked | Returns the number of hours spent on the task during this period.
getID | Returns the integer identifier of the work record.
getNotes | Return the notes about this work record.
GetType (inherited from Object) | Gets the Type of the current instance.
getWorkPerformedBy | Returns the user ID for the person who performed the work.
isDirty | Returns true if this WorkRecord has been modified but not yet saved.
MemberwiseClone |
setDateWorkBegan | Sets the date on which the work was begun.
setHoursRemaining |
setHoursWorked |
setNotes |
setWorkPerformedBy |
ToString |

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord Constructor

public WorkRecord(
Task task,
Int32 userID
);

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord Methods

The methods of the WorkRecord class are listed below. For a complete list of WorkRecord class members, see the WorkRecord Members topic.

Public Instance Methods

Equals |
getDateWorkBegan | Returns the date on which the work was begun. The default value for a new instance is equal to the creation time of the instance.
GetHashCode |
getHoursRemaining | Returns the estimated number of hours remaining to complete the task after this period.
getHoursWorked | Returns the number of hours spent on the task during this period.
getID | Returns the integer identifier of the work record.
getNotes | Return the notes about this work record.
GetType (inherited from Object) | Gets the Type of the current instance.
getWorkPerformedBy | Returns the user ID for the person who performed the work.
isDirty | Returns true if this WorkRecord has been modified but not yet saved.
MemberwiseClone |
setDateWorkBegan | Sets the date on which the work was begun.
setHoursRemaining |
setHoursWorked |
setNotes |
setWorkPerformedBy |
ToString |

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.Equals Method

public override bool Equals(
Object another
);

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.getDateWorkBegan Method

Returns the date on which the work was begun. The default value for a new instance is equal to the creation time of the instance.

public virtual OLEDate getDateWorkBegan();

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.GetHashCode Method

public override int GetHashCode();

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.getHoursRemaining Method

Returns the estimated number of hours remaining to complete the task after this period.

public virtual double getHoursRemaining();

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.getHoursWorked Method

Returns the number of hours spent on the task during this period.

public virtual double getHoursWorked();

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.getID Method

Returns the integer identifier of the work record.

public virtual int getID();

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.getNotes Method

Return the notes about this work record.

public virtual string getNotes();

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.getWorkPerformedBy Method

Returns the user ID for the person who performed the work.

public virtual int getWorkPerformedBy();

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.isDirty Method

Returns true if this WorkRecord has been modified but not yet saved.

public virtual bool isDirty();

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.MemberwiseClone Method

public override object MemberwiseClone();

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.setDateWorkBegan Method

Sets the date on which the work was begun.

public virtual void setDateWorkBegan(
OLEDate date
);

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.setHoursRemaining Method

public virtual void setHoursRemaining(
Double hours
);

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.setHoursWorked Method

public virtual void setHoursWorked(
Double hours
);

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.setNotes Method

public virtual void setNotes(
String notes
);

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.setWorkPerformedBy Method

public virtual void setWorkPerformedBy(
Int32 userID
);

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkRecord.ToString Method

public override string ToString();

See Also

WorkRecord Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Workstation Class

For a list of all members of this type, see Workstation Members.

System.Object
Workstation

public class Workstation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Workstation Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Workstation Members

Workstation overview

Public Instance Methods

Equals |
GetHashCode |
getID | The number assigned by the server to this workstation.
getName | The name of the workstation.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Workstation Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Workstation Methods

The methods of the Workstation class are listed below. For a complete list of Workstation class members, see the Workstation Members topic.

Public Instance Methods

Equals |
GetHashCode |
getID | The number assigned by the server to this workstation.
getName | The name of the workstation.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Workstation Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Workstation.Equals Method

public override bool Equals(
Object source
);

See Also

Workstation Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Workstation.GetHashCode Method

public override int GetHashCode();

See Also

Workstation Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Workstation.getID Method

The number assigned by the server to this workstation.

public virtual int getID();

See Also

Workstation Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Workstation.getName Method

The name of the workstation.

public virtual string getName();

See Also

Workstation Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Workstation.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Workstation Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Workstation.ToString Method

public override string ToString();

See Also

Workstation Class | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


com.starbase.starteam.viewcomparemerge

Borland StarTeam SDK for .NET

com.starbase.starteam.viewcomparemerge Namespace

Namespace hierarchy

Classes

Class | Description
ActionOverride |
AmbiguousMatchException |
AnyScope |
Custom3WayMergeAdapter |
DifferenceType |
EveryScope |
FileMergeAdapter |
FileMergeException |
FolderScope |
ItemDifference |
ItemListScope |
ItemTypeScope |
MatchState |
MergeAction |
MergePreview |
MergeType |
Options |
PreviewState |
ProcessItemScope |
Progress |
PropertyMergeException |
RevisionLabelScope |
Scope |
Session |
SessionState |
StarTeamFileMergeAdapter |
VCMFolder |
VisMergeAdapter |
WorkstationDefaultMergeAdapter |

Interfaces

Interface | Description
DifferenceIterator |


ActionOverride Class

For a list of all members of this type, see ActionOverride Members.

System.Object
ActionOverride

public class ActionOverride

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ActionOverride Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ActionOverride Members

ActionOverride overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getDifferenceType | Returns the DifferenceType contained within this ActionOverride or null
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getMatchState | Returns the MatchState contained within this ActionOverride
getMergeAction | Returns the MergeAction contained within this ActionOverride
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ActionOverride Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ActionOverride Methods

The methods of the ActionOverride class are listed below. For a complete list of ActionOverride class members, see the ActionOverride Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getDifferenceType | Returns the DifferenceType contained within this ActionOverride or null
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getMatchState | Returns the MatchState contained within this ActionOverride
getMergeAction | Returns the MergeAction contained within this ActionOverride
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ActionOverride Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ActionOverride.getDifferenceType Method

Returns the DifferenceType contained within this ActionOverride or null

public virtual DifferenceType getDifferenceType();

See Also

ActionOverride Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ActionOverride.getMatchState Method

Returns the MatchState contained within this ActionOverride

public virtual MatchState getMatchState();

See Also

ActionOverride Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ActionOverride.getMergeAction Method

Returns the MergeAction contained within this ActionOverride

public virtual MergeAction getMergeAction();

See Also

ActionOverride Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ActionOverride.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ActionOverride Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ActionOverride.ToString Method

public override string ToString();

See Also

ActionOverride Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AmbiguousMatchException Class

For a list of all members of this type, see AmbiguousMatchException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
AmbiguousMatchException

public class AmbiguousMatchException : RuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

AmbiguousMatchException Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AmbiguousMatchException Members

AmbiguousMatchException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getItem |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from java.lang.Throwable) |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isItemFromSourceView |
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

AmbiguousMatchException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AmbiguousMatchException Methods

The methods of the AmbiguousMatchException class are listed below. For a complete list of AmbiguousMatchException class members, see the AmbiguousMatchException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getItem |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from java.lang.Throwable) |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
isItemFromSourceView |
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

AmbiguousMatchException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AmbiguousMatchException.getItem Method

public virtual Item getItem();

See Also

AmbiguousMatchException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AmbiguousMatchException.isItemFromSourceView Method

public virtual bool isItemFromSourceView();

See Also

AmbiguousMatchException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AmbiguousMatchException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

AmbiguousMatchException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AmbiguousMatchException.unwrap Method

public virtual AmbiguousMatchException unwrap();

See Also

AmbiguousMatchException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AmbiguousMatchException.wrap Method

public static AmbiguousMatchException wrap(
AmbiguousMatchException arg
);

See Also

AmbiguousMatchException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AnyScope Class

For a list of all members of this type, see AnyScope Members.

System.Object
Scope
AnyScope

public class AnyScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

AnyScope Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AnyScope Members

AnyScope overview

Public Instance Constructors

AnyScope Overloaded. Initializes a new instance of the AnyScope class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from Scope) |
ToString (inherited from Scope) |

See Also

AnyScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AnyScope Constructor

Creates an empty scope.

Overload List

Creates an empty scope.

public AnyScope();

public AnyScope(Scope[]);

See Also

AnyScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AnyScope Constructor ()

Creates an empty scope.

public AnyScope();

See Also

AnyScope Class | com.starbase.starteam.viewcomparemerge Namespace | AnyScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


AnyScope Constructor (Scope[])

public AnyScope(
Scope[] scopes
);

See Also

AnyScope Class | com.starbase.starteam.viewcomparemerge Namespace | AnyScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Custom3WayMergeAdapter Class

For a list of all members of this type, see Custom3WayMergeAdapter Members.

System.Object
FileMergeAdapter
Custom3WayMergeAdapter

public class Custom3WayMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Custom3WayMergeAdapter Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Custom3WayMergeAdapter Members

Custom3WayMergeAdapter overview

Public Instance Constructors

Custom3WayMergeAdapter Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileMergeAdapter) |
merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. <p> If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. <p> Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) |

See Also

Custom3WayMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Custom3WayMergeAdapter Constructor

public Custom3WayMergeAdapter(
ItemDifference diff,
String application,
String commandline
);

See Also

Custom3WayMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceIterator Interface

For a list of all members of this type, see DifferenceIterator Members.

public interface DifferenceIterator

Types that implement DifferenceIterator

Type | Description
DifferenceIteratorAdapter |

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

DifferenceIterator Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceIterator Members

DifferenceIterator overview

Public Instance Methods

hasMoreDifferences | Tests if this ItemDifference iterator contains more elements.
nextDifference | Gets the next ItemDifference in this iterator, and advances the iterator to the next element.

See Also

DifferenceIterator Interface | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceIterator Methods

The methods of the DifferenceIterator interface are listed below. For a complete list of DifferenceIterator interface members, see the DifferenceIterator Members topic.

Public Instance Methods

hasMoreDifferences | Tests if this ItemDifference iterator contains more elements.
nextDifference | Gets the next ItemDifference in this iterator, and advances the iterator to the next element.

See Also

DifferenceIterator Interface | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceIterator.hasMoreDifferences Method

Tests if this ItemDifference iterator contains more elements.

bool hasMoreDifferences();

See Also

DifferenceIterator Interface | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceIterator.nextDifference Method

Gets the next ItemDifference in this iterator, and advances the iterator to the next element.

ItemDifference nextDifference();

See Also

DifferenceIterator Interface | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType Class

For a list of all members of this type, see DifferenceType Members.

System.Object
DifferenceType

public class DifferenceType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

DifferenceType Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType Members

DifferenceType overview

Public Static Methods

getAll | Gets a list of all defined DifferenceTypes in the decision table.
lookup | Searches the list of known difference types, returning the one that describes the given match state.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getDefaultAction | Gets the default action for this difference type.
getDescription | Gets a description of this DifferenceType.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getID | Gets the unique ID associated with this DifferenceType.
getLegalActions | Gets the set of legal actions for a given merge type.
getMatchState | Gets a copy of the MatchState associated with this DifferenceType.
GetType (inherited from Object) | Gets the Type of the current instance.
isDifference | Determines whether or not this difference type should really be considered a difference.
isLegalAction | Determines whether or not the given action is a legal action for this difference type.
MemberwiseClone |
ToString |

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType Methods

The methods of the DifferenceType class are listed below. For a complete list of DifferenceType class members, see the DifferenceType Members topic.

Public Static Methods

getAll | Gets a list of all defined DifferenceTypes in the decision table.
lookup | Searches the list of known difference types, returning the one that describes the given match state.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getDefaultAction | Gets the default action for this difference type.
getDescription | Gets a description of this DifferenceType.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getID | Gets the unique ID associated with this DifferenceType.
getLegalActions | Gets the set of legal actions for a given merge type.
getMatchState | Gets a copy of the MatchState associated with this DifferenceType.
GetType (inherited from Object) | Gets the Type of the current instance.
isDifference | Determines whether or not this difference type should really be considered a difference.
isLegalAction | Determines whether or not the given action is a legal action for this difference type.
MemberwiseClone |
ToString |

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType.getAll Method

Gets a list of all defined DifferenceTypes in the decision table.

public static DifferenceType[] getAll();

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType.getDefaultAction Method

Gets the default action for this difference type.

public virtual MergeAction getDefaultAction();

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType.getDescription Method

Gets a description of this DifferenceType.

public virtual string getDescription();

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType.getID Method

Gets the unique ID associated with this DifferenceType.

public virtual int getID();

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType.getLegalActions Method

Gets the set of legal actions for a given merge type.

public virtual MergeAction[] getLegalActions();

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType.getMatchState Method

Gets a copy of the MatchState associated with this DifferenceType.

public virtual MatchState getMatchState();

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType.isDifference Method

Determines whether or not this difference type should really be considered a difference.

public virtual bool isDifference();

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType.isLegalAction Method

Determines whether or not the given action is a legal action for this difference type.

public virtual bool isLegalAction(
MergeAction action
);

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType.lookup Method

Searches the list of known difference types, returning the one that describes the given match state.

public static DifferenceType lookup(
MatchState state
);

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType.MemberwiseClone Method

public override object MemberwiseClone();

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


DifferenceType.ToString Method

public override string ToString();

See Also

DifferenceType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EveryScope Class

For a list of all members of this type, see EveryScope Members.

System.Object
Scope
EveryScope

public class EveryScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

EveryScope Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EveryScope Members

EveryScope overview

Public Instance Constructors

EveryScope Overloaded. Initializes a new instance of the EveryScope class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from Scope) |
ToString (inherited from Scope) |

See Also

EveryScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EveryScope Constructor

Creates an empty scope.

Overload List

Creates an empty scope.

public EveryScope();

public EveryScope(Scope[]);

See Also

EveryScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EveryScope Constructor ()

Creates an empty scope.

public EveryScope();

See Also

EveryScope Class | com.starbase.starteam.viewcomparemerge Namespace | EveryScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EveryScope Constructor (Scope[])

public EveryScope(
Scope[] scopes
);

See Also

EveryScope Class | com.starbase.starteam.viewcomparemerge Namespace | EveryScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter Class

For a list of all members of this type, see FileMergeAdapter Members.

System.Object
FileMergeAdapter
Custom3WayMergeAdapter
StarTeamFileMergeAdapter
VisMergeAdapter
WorkstationDefaultMergeAdapter

public class FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FileMergeAdapter Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter Members

FileMergeAdapter overview

Public Static Fields

PARAM_COMMON_ANCESTOR
PARAM_OUTPUT_FILE
PARAM_SOURCE_ANCESTOR
PARAM_SOURCE_FILE
PARAM_TARGET_ANCESTOR
PARAM_TARGET_FILE

Public Instance Constructors

FileMergeAdapter Constructor Constructs an adapter for resolving a given file merge condition.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
merge | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. <p> If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. <p> Any temporary files created during the process are automatically removed.
ToString |

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter Constructor

Constructs an adapter for resolving a given file merge condition.

public FileMergeAdapter(
ItemDifference diff
);

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter Fields

The fields of the FileMergeAdapter class are listed below. For a complete list of FileMergeAdapter class members, see the FileMergeAdapter Members topic.

Public Static Fields

PARAM_COMMON_ANCESTOR
PARAM_OUTPUT_FILE
PARAM_SOURCE_ANCESTOR
PARAM_SOURCE_FILE
PARAM_TARGET_ANCESTOR
PARAM_TARGET_FILE

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter.PARAM_COMMON_ANCESTOR Field

public const String PARAM_COMMON_ANCESTOR = "$ancestor";

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter.PARAM_OUTPUT_FILE Field

public const String PARAM_OUTPUT_FILE = "$result";

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter.PARAM_SOURCE_ANCESTOR Field

public const String PARAM_SOURCE_ANCESTOR = "$sourceAncestor";

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter.PARAM_SOURCE_FILE Field

public const String PARAM_SOURCE_FILE = "$source";

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter.PARAM_TARGET_ANCESTOR Field

public const String PARAM_TARGET_ANCESTOR = "$targetAncestor";

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter.PARAM_TARGET_FILE Field

public const String PARAM_TARGET_FILE = "$target";

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter Methods

The methods of the FileMergeAdapter class are listed below. For a complete list of FileMergeAdapter class members, see the FileMergeAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
merge | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. <p> If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. <p> Any temporary files created during the process are automatically removed.
ToString |

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter.merge Method

Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. <p> If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. <p> Any temporary files created during the process are automatically removed.

public virtual int merge();

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeAdapter.ToString Method

public override string ToString();

See Also

FileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeException Class

For a list of all members of this type, see FileMergeException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
FileMergeException

public class FileMergeException : RuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FileMergeException Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeException Members

FileMergeException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getItemDifference |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from java.lang.Throwable) |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

FileMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeException Methods

The methods of the FileMergeException class are listed below. For a complete list of FileMergeException class members, see the FileMergeException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getItemDifference |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from java.lang.Throwable) |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

FileMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeException.getItemDifference Method

public virtual ItemDifference getItemDifference();

See Also

FileMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FileMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeException.unwrap Method

public virtual FileMergeException unwrap();

See Also

FileMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileMergeException.wrap Method

public static FileMergeException wrap(
FileMergeException arg
);

See Also

FileMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Class

For a list of all members of this type, see FolderScope Members.

System.Object
Scope
FolderScope

public class FolderScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FolderScope Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Members

FolderScope overview

Public Instance Constructors

FolderScope Overloaded. Initializes a new instance of the FolderScope class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from Scope) |
ToString (inherited from Scope) |

See Also

FolderScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Constructor

Creates a new FolderScope that includes the files in the given source folder.

Overload List

Creates a new FolderScope that includes the files in the given source folder.

public FolderScope(Folder);

public FolderScope(Folder,Type);

public FolderScope(Folder,Type[]);

public FolderScope(Folder,Boolean);

public FolderScope(Folder,Boolean,Type);

public FolderScope(Folder,Boolean,Type[]);

Creates a new FolderScope that includes all of the folders indicated by the given FolderListManager. <p> The client application is free to include or exlude folders from the FolderListManager at any time. Changes will be reflected in the scope after the next refresh().

public FolderScope(FolderListManager);

public FolderScope(FolderListManager,Type);

public FolderScope(FolderListManager,Type[]);

See Also

FolderScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Constructor (Folder)

Creates a new FolderScope that includes the files in the given source folder.

public FolderScope(
Folder f
);

See Also

FolderScope Class | com.starbase.starteam.viewcomparemerge Namespace | FolderScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Constructor (Folder, Type)

public FolderScope(
Folder f,
Type type
);

See Also

FolderScope Class | com.starbase.starteam.viewcomparemerge Namespace | FolderScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Constructor (Folder, Type[])

public FolderScope(
Folder f,
Type[] types
);

See Also

FolderScope Class | com.starbase.starteam.viewcomparemerge Namespace | FolderScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Constructor (Folder, Boolean)

public FolderScope(
Folder f,
Boolean bIncludeSubfolders
);

See Also

FolderScope Class | com.starbase.starteam.viewcomparemerge Namespace | FolderScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Constructor (Folder, Boolean, Type)

public FolderScope(
Folder f,
Boolean bIncludeSubfolders,
Type type
);

See Also

FolderScope Class | com.starbase.starteam.viewcomparemerge Namespace | FolderScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Constructor (Folder, Boolean, Type[])

public FolderScope(
Folder f,
Boolean bIncludeSubfolders,
Type[] types
);

See Also

FolderScope Class | com.starbase.starteam.viewcomparemerge Namespace | FolderScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Constructor (FolderListManager)

Creates a new FolderScope that includes all of the folders indicated by the given FolderListManager. <p> The client application is free to include or exlude folders from the FolderListManager at any time. Changes will be reflected in the scope after the next refresh().

public FolderScope(
FolderListManager folders
);

See Also

FolderScope Class | com.starbase.starteam.viewcomparemerge Namespace | FolderScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Constructor (FolderListManager, Type)

public FolderScope(
FolderListManager folders,
Type type
);

See Also

FolderScope Class | com.starbase.starteam.viewcomparemerge Namespace | FolderScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FolderScope Constructor (FolderListManager, Type[])

public FolderScope(
FolderListManager folders,
Type[] types
);

See Also

FolderScope Class | com.starbase.starteam.viewcomparemerge Namespace | FolderScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference Class

For a list of all members of this type, see ItemDifference Members.

System.Object
ItemDifference

public class ItemDifference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemDifference Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference Members

ItemDifference overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAction | Gets the action that will be performed at commit time to merge this difference from the source to the target.
getAffectedDifferences | Determines which differences would be affected if the merge action for this difference were changed to the given one. <p> For example, consider a folder that is "New in source". Changing the action from {@linkplain MergeAction#REVERSE_SHARE reverse share} to {@linkplain MergeAction#IGNORE ignore} would also affect the differences for any "New in source" files in that folder. (If the folder isn't shared, its children won't be either.) <p> This method does not actually change the actions of any differences; the changes would not occur unless {@link #setAction setAction} were called.
getDefaultAction | Gets the default action recommended when merging this difference to the target view. <p> The action associated with a given difference may be overridden, and therefore may differ from the default action.
getDescription | Gets a user-friendly description of this difference.
getDifferenceType | Gets the difference type associated with this difference.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLegalActions | Gets the list of merge actions that are legal for this difference. The list depends on the difference type.
getMergedFileContent | Gets the path to a file within this session's working vault where the merged file content for this difference resides. <p> The difference must be a file difference with a file merge condition that has already been resolved.
getMergedFileContentItem | Gets the StarTeam file revision whose content was used as the merged file content for this difference, or null if the merged content was not set via {@link #setMergedFileContentItem setMergedFileContentItem}.
getMergedItem | Gets an item that closely approximates the state the target item after the merge, if the session were to be committed in its current state. <p> The same merged item also appears in the {@linkplain Session#getMergePreview merge preview}.
getMergePoint | Gets the merge point created when this difference was committed, if any. <p> Merge points are created only when resolving merge conditions, where the source and target items were on different branches. A merge point is not created when the source and target have no common ancestor, and match only by name.
getProcessLink | Gets the process link that was created when this difference was committed. <p> Process links are not created for every difference. In general, process links are created only for files and folders that change in the target view as a result of the commit. Process links are not created for items that are deleted in the target. <p> When VCM creates a process link, it always links the target item to the process task for this session.
getSession | Gets the VCM session to which this difference belongs.
getSourceAncestor | Gets the item from the source item's history that was used to determine whether the source item has changed or moved since the last merge operation.
getSourceItem | Gets the source item associated with this difference. May be null for some difference types (for example, "New in target").
getSourceItemForCompare | Gets the source item associated with this difference May be null for some difference types (for example, "New in Target"). Prior to the commit, this item is the same as the source item After the commit, this item represents the source item prior to the commit
getTargetAncestor | Gets the item from the target item's history that was used to determine whether the target item has changed or moved since the last merge operation.
getTargetItem | Gets the target item associated with this difference. May be null for some difference types (for example, "New in source").
getTargetItemForCompare | Gets the target item associated with this difference May be null for some difference types (for example, "New in source"). Prior to the commit, this item is the same as the target item After the commit, this item represents the target item prior to the commit
getType | Gets the item type of the source and target items in this difference.
GetType (inherited from Object) | Gets the Type of the current instance.
isCommitted | Determines whether or not this difference has been commited. <p> Note that if the session was committed as an atomic transaction, then all differences are committed together. However, on a server that does not support atomic transactions, the session may be partially committed. In this case, some differences may report that they have been committed, while others may not.
isConflictDetected | Determines whether or not this difference represents a merge conflict. The conflict may or may not have already been resolved.
isFileCheckin | Determines whether or not applying the current action at commit time would result in a file checkin.
isFileMerge | Determines whether or not this difference represents a file whose content has changed in both the source and target in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.
isNonTipReverseShare | Determines whether or not committing this difference resulted in a reverse share from a non-tip revision. <p> When the source item being reverse shared is not the tip revision of the item, StarTeam compensates by: </p> <ol> <li><p>reverse sharing the tip revision;</p> <li><p>creating a new revision in the target view that has the effect of rolling back the item properties and/or file content to the desired non-tip revision;</p> <li><p>forcing the item to branch in the source view, so that a subsequent rebase will cause a merge condition.</p> </ol> <p> This isNonTipReverseShare flag is set at commit time, and is always false prior to the commit.
isPropertyMerge | Determines whether or not there is at least one property whose value has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.
isPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.
isUnresolved | Determines whether or not this difference has an unresolved merge condition.
isUnresolvedFileMerge | Determines whether or not this difference represents a file whose content has changed in both the source and target in such a way as to create a merge condition, and that merge condition has not yet been resolved.
isUnresolvedPropertyMerge | Determines whether or not there is at least one property whose value has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.
isUnresolvedPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.
MemberwiseClone |
setAction | Sets the action that will be performed at commit time to merge this difference from the source to the target. <p> The new action overrides the default. It must be one of the actions that is legal for this difference.
setMergedFileContent | Sets the merged file content for this difference. This is the content that will be checked into the target view at commit time. <p> The difference must be one with a file merge condition. The provided file content is copied into the session's working vault, and the file merge condition is marked resolved. <p> An alternate way to specify the merged file content for a difference is to check in the new content through the {@linkplain Session#getMergePreview merge preview}. For example: <pre> // The merged item is accessible through the ItemDifference // and through the merge preview; they are physically the same. Item item = diff.getMergedItem(); // Checking in a new file revision also resolves the conflict. View preview = session.getMergePreview(); CheckinManager mgr = preview.createCheckinManager(); mgr.checkin((File)item, path); </pre>
setMergedFileContentItem | Similar to {@link #setMergedFileContent setMergedFileContent}, except that the merged file content is taken from the given StarTeam file revision.
setMergedPropertyValue |
ToString |

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference Methods

The methods of the ItemDifference class are listed below. For a complete list of ItemDifference class members, see the ItemDifference Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAction | Gets the action that will be performed at commit time to merge this difference from the source to the target.
getAffectedDifferences | Determines which differences would be affected if the merge action for this difference were changed to the given one. <p> For example, consider a folder that is "New in source". Changing the action from {@linkplain MergeAction#REVERSE_SHARE reverse share} to {@linkplain MergeAction#IGNORE ignore} would also affect the differences for any "New in source" files in that folder. (If the folder isn't shared, its children won't be either.) <p> This method does not actually change the actions of any differences; the changes would not occur unless {@link #setAction setAction} were called.
getDefaultAction | Gets the default action recommended when merging this difference to the target view. <p> The action associated with a given difference may be overridden, and therefore may differ from the default action.
getDescription | Gets a user-friendly description of this difference.
getDifferenceType | Gets the difference type associated with this difference.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLegalActions | Gets the list of merge actions that are legal for this difference. The list depends on the difference type.
getMergedFileContent | Gets the path to a file within this session's working vault where the merged file content for this difference resides. <p> The difference must be a file difference with a file merge condition that has already been resolved.
getMergedFileContentItem | Gets the StarTeam file revision whose content was used as the merged file content for this difference, or null if the merged content was not set via {@link #setMergedFileContentItem setMergedFileContentItem}.
getMergedItem | Gets an item that closely approximates the state the target item after the merge, if the session were to be committed in its current state. <p> The same merged item also appears in the {@linkplain Session#getMergePreview merge preview}.
getMergePoint | Gets the merge point created when this difference was committed, if any. <p> Merge points are created only when resolving merge conditions, where the source and target items were on different branches. A merge point is not created when the source and target have no common ancestor, and match only by name.
getProcessLink | Gets the process link that was created when this difference was committed. <p> Process links are not created for every difference. In general, process links are created only for files and folders that change in the target view as a result of the commit. Process links are not created for items that are deleted in the target. <p> When VCM creates a process link, it always links the target item to the process task for this session.
getSession | Gets the VCM session to which this difference belongs.
getSourceAncestor | Gets the item from the source item's history that was used to determine whether the source item has changed or moved since the last merge operation.
getSourceItem | Gets the source item associated with this difference. May be null for some difference types (for example, "New in target").
getSourceItemForCompare | Gets the source item associated with this difference May be null for some difference types (for example, "New in Target"). Prior to the commit, this item is the same as the source item After the commit, this item represents the source item prior to the commit
getTargetAncestor | Gets the item from the target item's history that was used to determine whether the target item has changed or moved since the last merge operation.
getTargetItem | Gets the target item associated with this difference. May be null for some difference types (for example, "New in source").
getTargetItemForCompare | Gets the target item associated with this difference May be null for some difference types (for example, "New in source"). Prior to the commit, this item is the same as the target item After the commit, this item represents the target item prior to the commit
getType | Gets the item type of the source and target items in this difference.
GetType (inherited from Object) | Gets the Type of the current instance.
isCommitted | Determines whether or not this difference has been commited. <p> Note that if the session was committed as an atomic transaction, then all differences are committed together. However, on a server that does not support atomic transactions, the session may be partially committed. In this case, some differences may report that they have been committed, while others may not.
isConflictDetected | Determines whether or not this difference represents a merge conflict. The conflict may or may not have already been resolved.
isFileCheckin | Determines whether or not applying the current action at commit time would result in a file checkin.
isFileMerge | Determines whether or not this difference represents a file whose content has changed in both the source and target in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.
isNonTipReverseShare | Determines whether or not committing this difference resulted in a reverse share from a non-tip revision. <p> When the source item being reverse shared is not the tip revision of the item, StarTeam compensates by: </p> <ol> <li><p>reverse sharing the tip revision;</p> <li><p>creating a new revision in the target view that has the effect of rolling back the item properties and/or file content to the desired non-tip revision;</p> <li><p>forcing the item to branch in the source view, so that a subsequent rebase will cause a merge condition.</p> </ol> <p> This isNonTipReverseShare flag is set at commit time, and is always false prior to the commit.
isPropertyMerge | Determines whether or not there is at least one property whose value has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.
isPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.
isUnresolved | Determines whether or not this difference has an unresolved merge condition.
isUnresolvedFileMerge | Determines whether or not this difference represents a file whose content has changed in both the source and target in such a way as to create a merge condition, and that merge condition has not yet been resolved.
isUnresolvedPropertyMerge | Determines whether or not there is at least one property whose value has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.
isUnresolvedPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.
MemberwiseClone |
setAction | Sets the action that will be performed at commit time to merge this difference from the source to the target. <p> The new action overrides the default. It must be one of the actions that is legal for this difference.
setMergedFileContent | Sets the merged file content for this difference. This is the content that will be checked into the target view at commit time. <p> The difference must be one with a file merge condition. The provided file content is copied into the session's working vault, and the file merge condition is marked resolved. <p> An alternate way to specify the merged file content for a difference is to check in the new content through the {@linkplain Session#getMergePreview merge preview}. For example: <pre> // The merged item is accessible through the ItemDifference // and through the merge preview; they are physically the same. Item item = diff.getMergedItem(); // Checking in a new file revision also resolves the conflict. View preview = session.getMergePreview(); CheckinManager mgr = preview.createCheckinManager(); mgr.checkin((File)item, path); </pre>
setMergedFileContentItem | Similar to {@link #setMergedFileContent setMergedFileContent}, except that the merged file content is taken from the given StarTeam file revision.
setMergedPropertyValue |
ToString |

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getAction Method

Gets the action that will be performed at commit time to merge this difference from the source to the target.

public virtual MergeAction getAction();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getAffectedDifferences Method

Determines which differences would be affected if the merge action for this difference were changed to the given one. <p> For example, consider a folder that is "New in source". Changing the action from {@linkplain MergeAction#REVERSE_SHARE reverse share} to {@linkplain MergeAction#IGNORE ignore} would also affect the differences for any "New in source" files in that folder. (If the folder isn't shared, its children won't be either.) <p> This method does not actually change the actions of any differences; the changes would not occur unless {@link #setAction setAction} were called.

public virtual ItemDifference[] getAffectedDifferences(
MergeAction newAction
);

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getDefaultAction Method

Gets the default action recommended when merging this difference to the target view. <p> The action associated with a given difference may be overridden, and therefore may differ from the default action.

public virtual MergeAction getDefaultAction();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getDescription Method

Gets a user-friendly description of this difference.

public virtual string getDescription();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getDifferenceType Method

Gets the difference type associated with this difference.

public virtual DifferenceType getDifferenceType();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getLegalActions Method

Gets the list of merge actions that are legal for this difference. The list depends on the difference type.

public virtual MergeAction[] getLegalActions();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getMergedFileContent Method

Gets the path to a file within this session's working vault where the merged file content for this difference resides. <p> The difference must be a file difference with a file merge condition that has already been resolved.

public virtual File getMergedFileContent();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getMergedFileContentItem Method

Gets the StarTeam file revision whose content was used as the merged file content for this difference, or null if the merged content was not set via {@link #setMergedFileContentItem setMergedFileContentItem}.

public virtual File getMergedFileContentItem();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getMergedItem Method

Gets an item that closely approximates the state the target item after the merge, if the session were to be committed in its current state. <p> The same merged item also appears in the {@linkplain Session#getMergePreview merge preview}.

public virtual Item getMergedItem();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getMergePoint Method

Gets the merge point created when this difference was committed, if any. <p> Merge points are created only when resolving merge conditions, where the source and target items were on different branches. A merge point is not created when the source and target have no common ancestor, and match only by name.

public virtual MergePoint getMergePoint();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getProcessLink Method

Gets the process link that was created when this difference was committed. <p> Process links are not created for every difference. In general, process links are created only for files and folders that change in the target view as a result of the commit. Process links are not created for items that are deleted in the target. <p> When VCM creates a process link, it always links the target item to the process task for this session.

public virtual Link getProcessLink();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getSession Method

Gets the VCM session to which this difference belongs.

public virtual Session getSession();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getSourceAncestor Method

Gets the item from the source item's history that was used to determine whether the source item has changed or moved since the last merge operation.

public virtual Item getSourceAncestor();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getSourceItem Method

Gets the source item associated with this difference. May be null for some difference types (for example, "New in target").

public virtual Item getSourceItem();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getSourceItemForCompare Method

Gets the source item associated with this difference May be null for some difference types (for example, "New in Target"). Prior to the commit, this item is the same as the source item After the commit, this item represents the source item prior to the commit

public virtual Item getSourceItemForCompare();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getTargetAncestor Method

Gets the item from the target item's history that was used to determine whether the target item has changed or moved since the last merge operation.

public virtual Item getTargetAncestor();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getTargetItem Method

Gets the target item associated with this difference. May be null for some difference types (for example, "New in source").

public virtual Item getTargetItem();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getTargetItemForCompare Method

Gets the target item associated with this difference May be null for some difference types (for example, "New in source"). Prior to the commit, this item is the same as the target item After the commit, this item represents the target item prior to the commit

public virtual Item getTargetItemForCompare();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.getType Method

Gets the item type of the source and target items in this difference.

public virtual Type getType();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.isCommitted Method

Determines whether or not this difference has been commited. <p> Note that if the session was committed as an atomic transaction, then all differences are committed together. However, on a server that does not support atomic transactions, the session may be partially committed. In this case, some differences may report that they have been committed, while others may not.

public virtual bool isCommitted();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.isConflictDetected Method

Determines whether or not this difference represents a merge conflict. The conflict may or may not have already been resolved.

public virtual bool isConflictDetected();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.isFileCheckin Method

Determines whether or not applying the current action at commit time would result in a file checkin.

public virtual bool isFileCheckin();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.isFileMerge Method

Determines whether or not this difference represents a file whose content has changed in both the source and target in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.

public virtual bool isFileMerge();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.isNonTipReverseShare Method

Determines whether or not committing this difference resulted in a reverse share from a non-tip revision. <p> When the source item being reverse shared is not the tip revision of the item, StarTeam compensates by: </p> <ol> <li><p>reverse sharing the tip revision;</p> <li><p>creating a new revision in the target view that has the effect of rolling back the item properties and/or file content to the desired non-tip revision;</p> <li><p>forcing the item to branch in the source view, so that a subsequent rebase will cause a merge condition.</p> </ol> <p> This isNonTipReverseShare flag is set at commit time, and is always false prior to the commit.

public virtual bool isNonTipReverseShare();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.isPropertyMerge Method

Determines whether or not there is at least one property whose value has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.

public virtual bool isPropertyMerge();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.isPropertyMergeFor Method

Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.

public virtual bool isPropertyMergeFor(
Property property
);

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.isUnresolved Method

Determines whether or not this difference has an unresolved merge condition.

public virtual bool isUnresolved();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.isUnresolvedFileMerge Method

Determines whether or not this difference represents a file whose content has changed in both the source and target in such a way as to create a merge condition, and that merge condition has not yet been resolved.

public virtual bool isUnresolvedFileMerge();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.isUnresolvedPropertyMerge Method

Determines whether or not there is at least one property whose value has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.

public virtual bool isUnresolvedPropertyMerge();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.isUnresolvedPropertyMergeFor Method

Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.

public virtual bool isUnresolvedPropertyMergeFor(
Property property
);

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.setAction Method

Sets the action that will be performed at commit time to merge this difference from the source to the target. <p> The new action overrides the default. It must be one of the actions that is legal for this difference.

public virtual void setAction(
MergeAction newAction
);

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.setMergedFileContent Method

Sets the merged file content for this difference. This is the content that will be checked into the target view at commit time. <p> The difference must be one with a file merge condition. The provided file content is copied into the session's working vault, and the file merge condition is marked resolved. <p> An alternate way to specify the merged file content for a difference is to check in the new content through the {@linkplain Session#getMergePreview merge preview}. For example: <pre> // The merged item is accessible through the ItemDifference // and through the merge preview; they are physically the same. Item item = diff.getMergedItem(); // Checking in a new file revision also resolves the conflict. View preview = session.getMergePreview(); CheckinManager mgr = preview.createCheckinManager(); mgr.checkin((File)item, path); </pre>

public virtual void setMergedFileContent(
File mergeResult
);

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.setMergedFileContentItem Method

Similar to {@link #setMergedFileContent setMergedFileContent}, except that the merged file content is taken from the given StarTeam file revision.

public virtual void setMergedFileContentItem(
File starTeamFile
);

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.setMergedPropertyValue Method

public virtual object setMergedPropertyValue(
Property property,
Object value
);

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemDifference.ToString Method

public override string ToString();

See Also

ItemDifference Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListScope Class

For a list of all members of this type, see ItemListScope Members.

System.Object
Scope
ItemListScope

public class ItemListScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemListScope Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListScope Members

ItemListScope overview

Public Instance Constructors

ItemListScope Overloaded. Initializes a new instance of the ItemListScope class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from Scope) |
ToString (inherited from Scope) |

See Also

ItemListScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListScope Constructor

Create an ItemListScope for the specified Item

Overload List

Create an ItemListScope for the specified Item

public ItemListScope(Item);

public ItemListScope(Item[]);

Create an ItemListScope from a list of Items

public ItemListScope(Items);

See Also

ItemListScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListScope Constructor (Item)

Create an ItemListScope for the specified Item

public ItemListScope(
Item item
);

See Also

ItemListScope Class | com.starbase.starteam.viewcomparemerge Namespace | ItemListScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListScope Constructor (Items)

Create an ItemListScope from a list of Items

public ItemListScope(
Items items
);

See Also

ItemListScope Class | com.starbase.starteam.viewcomparemerge Namespace | ItemListScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemListScope Constructor (Item[])

public ItemListScope(
Item[] items
);

See Also

ItemListScope Class | com.starbase.starteam.viewcomparemerge Namespace | ItemListScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope Class

For a list of all members of this type, see ItemTypeScope Members.

System.Object
Scope
ItemTypeScope

public class ItemTypeScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ItemTypeScope Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope Members

ItemTypeScope overview

Public Static Methods

forAllTypes | Gets an ItemTypeScope containing all supported item types.
forDefaultTypes | Gets an ItemTypeScope containing the default types (files and folders).

Public Instance Constructors

ItemTypeScope Overloaded. Initializes a new instance of the ItemTypeScope class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
excludeItemType | Removes a given item type from the list of included item types.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
includeItemType | Adds a given item type to the list of included item types.
isIncluded | Determines whether or not the given item type is included.
MemberwiseClone (inherited from Scope) |
setItemTypes |
ToString (inherited from Scope) |

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope Constructor

Creates an empty ItemTypeScope.

Overload List

Creates an empty ItemTypeScope.

public ItemTypeScope();

Creates an ItemTypeScope that includes the given type.

public ItemTypeScope(Type);

public ItemTypeScope(Type[]);

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope Constructor ()

Creates an empty ItemTypeScope.

public ItemTypeScope();

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace | ItemTypeScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope Constructor (Type)

Creates an ItemTypeScope that includes the given type.

public ItemTypeScope(
Type type
);

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace | ItemTypeScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope Constructor (Type[])

public ItemTypeScope(
Type[] types
);

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace | ItemTypeScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope Methods

The methods of the ItemTypeScope class are listed below. For a complete list of ItemTypeScope class members, see the ItemTypeScope Members topic.

Public Static Methods

forAllTypes | Gets an ItemTypeScope containing all supported item types.
forDefaultTypes | Gets an ItemTypeScope containing the default types (files and folders).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
excludeItemType | Removes a given item type from the list of included item types.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
includeItemType | Adds a given item type to the list of included item types.
isIncluded | Determines whether or not the given item type is included.
MemberwiseClone (inherited from Scope) |
setItemTypes |
ToString (inherited from Scope) |

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope.excludeItemType Method

Removes a given item type from the list of included item types.

public virtual void excludeItemType(
Type type
);

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope.forAllTypes Method

Gets an ItemTypeScope containing all supported item types.

public static ItemTypeScope forAllTypes(
Server s
);

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope.forDefaultTypes Method

Gets an ItemTypeScope containing the default types (files and folders).

public static ItemTypeScope forDefaultTypes(
Server s
);

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope.includeItemType Method

Adds a given item type to the list of included item types.

public virtual void includeItemType(
Type type
);

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope.isIncluded Method

Determines whether or not the given item type is included.

public virtual bool isIncluded(
Type type
);

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ItemTypeScope.setItemTypes Method

public virtual void setItemTypes(
Type[] types
);

See Also

ItemTypeScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState Class

For a list of all members of this type, see MatchState Members.

System.Object
MatchState

public class MatchState

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MatchState Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState Members

MatchState overview

Public Instance Constructors

MatchState Overloaded. Initializes a new instance of the MatchState class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getItemDeletedInSource | Indicates whether or not the item in question is deleted in the source view.
getItemDeletedInTarget | Indicates whether or not the item in question is deleted in the target view.
getItemIsBinaryFile | Indicates whether or not the item in question is a binary file.
getItemModifiedInSource | Indicates whether or not the item in question is modified in the source view.
getItemModifiedInTarget | Indicates whether or not the item in question is modified in the target view.
getItemMovedInSource | Indicates whether or not the item in question is moved in the source view.
getItemMovedInTarget | Indicates whether or not the item in question is moved in the target view.
getItemPresentInSource | Indicates whether or not the item in question is present in the source view.
getItemPresentInTarget | Indicates whether or not the item in question is present in the target view.
getItemsHaveSameContent | Indicates whether or not the source and target items have identical content.
getItemsInDifferentBranches | Indicates whether or not the source and target items are in different branches of the object's version tree.
getItemTypeName | Gets the item type.
getMergeType | Gets the merge type.
getParentFolderDeletedInTarget | Obsolete. Indicates whether or not the target item's parent folder has been deleted.
getParentFolderFailed | Indicates whether or not the target item's parent folder failed to be reconciled.
getParentFolderIgnored | Indicates whether or not the target item's parent folder is ignored.
getSomeChangedPropertiesExcludedFromMerge | Indicates whether or not the source and target items have identical content.
getSourceChildShareOfTarget | Indicates whether or not the source item is a child share of the target item.
getSourceIsFloating | Indicates whether or not the source item has a floating configuration.
getSourceItemOnRootBranch | Indicates whether or not the source item is on the root branch of the share tree.
getTargetChildShareOfSource | Indicates whether or not the target item is a child share of the source item.
getTargetFolderHasFloatingShares | Indicates whether or not the target item's parent folder has floating child shares.
getTargetIsFloating | Indicates whether or not the target item has a floating configuration.
getTargetItemOnRootBranch | Indicates whether or not the target item is on the root branch of the share tree.
GetType (inherited from Object) | Gets the Type of the current instance.
matches | Determines whether or not this MatchState matches the conditions specified by the given pattern. "Don't Care" values in the pattern are ignored; other values in the pattern must match exactly.
MemberwiseClone |
setItemDeletedInSource | Overloaded.
setItemDeletedInTarget | Overloaded.
setItemIsBinaryFile | Overloaded.
setItemModifiedInSource | Overloaded.
setItemModifiedInTarget | Overloaded.
setItemMovedInSource | Overloaded.
setItemMovedInTarget | Overloaded.
setItemPresentInSource | Overloaded.
setItemPresentInTarget | Overloaded.
setItemsHaveSameContent | Overloaded.
setItemsInDifferentBranches | Overloaded.
setItemTypeName |
setMergeType | Sets the merge type.
setParentFolderDeletedInTarget | Overloaded.
setParentFolderFailed | Overloaded.
setParentFolderIgnored | Overloaded.
setSomeChangedPropertiesExcludedFromMerge | Overloaded.
setSourceChildShareOfTarget | Overloaded.
setSourceIsFloating | Overloaded.
setSourceItemOnRootBranch | Overloaded.
setTargetChildShareOfSource | Overloaded.
setTargetFolderHasFloatingShares | Overloaded.
setTargetIsFloating | Overloaded.
setTargetItemOnRootBranch | Overloaded.
ToString |

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState Constructor

Constructs a new MatchState. Properties are initialized to their "Don't Know" / "Don't Care" values.

Overload List

Constructs a new MatchState. Properties are initialized to their "Don't Know" / "Don't Care" values.

public MatchState();

Constructs a new MatchState that is a copy of an existing one.

public MatchState(MatchState);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState Constructor ()

Constructs a new MatchState. Properties are initialized to their "Don't Know" / "Don't Care" values.

public MatchState();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState Constructor (MatchState)

Constructs a new MatchState that is a copy of an existing one.

public MatchState(
MatchState state
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState Methods

The methods of the MatchState class are listed below. For a complete list of MatchState class members, see the MatchState Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getItemDeletedInSource | Indicates whether or not the item in question is deleted in the source view.
getItemDeletedInTarget | Indicates whether or not the item in question is deleted in the target view.
getItemIsBinaryFile | Indicates whether or not the item in question is a binary file.
getItemModifiedInSource | Indicates whether or not the item in question is modified in the source view.
getItemModifiedInTarget | Indicates whether or not the item in question is modified in the target view.
getItemMovedInSource | Indicates whether or not the item in question is moved in the source view.
getItemMovedInTarget | Indicates whether or not the item in question is moved in the target view.
getItemPresentInSource | Indicates whether or not the item in question is present in the source view.
getItemPresentInTarget | Indicates whether or not the item in question is present in the target view.
getItemsHaveSameContent | Indicates whether or not the source and target items have identical content.
getItemsInDifferentBranches | Indicates whether or not the source and target items are in different branches of the object's version tree.
getItemTypeName | Gets the item type.
getMergeType | Gets the merge type.
getParentFolderDeletedInTarget | Obsolete. Indicates whether or not the target item's parent folder has been deleted.
getParentFolderFailed | Indicates whether or not the target item's parent folder failed to be reconciled.
getParentFolderIgnored | Indicates whether or not the target item's parent folder is ignored.
getSomeChangedPropertiesExcludedFromMerge | Indicates whether or not the source and target items have identical content.
getSourceChildShareOfTarget | Indicates whether or not the source item is a child share of the target item.
getSourceIsFloating | Indicates whether or not the source item has a floating configuration.
getSourceItemOnRootBranch | Indicates whether or not the source item is on the root branch of the share tree.
getTargetChildShareOfSource | Indicates whether or not the target item is a child share of the source item.
getTargetFolderHasFloatingShares | Indicates whether or not the target item's parent folder has floating child shares.
getTargetIsFloating | Indicates whether or not the target item has a floating configuration.
getTargetItemOnRootBranch | Indicates whether or not the target item is on the root branch of the share tree.
GetType (inherited from Object) | Gets the Type of the current instance.
matches | Determines whether or not this MatchState matches the conditions specified by the given pattern. "Don't Care" values in the pattern are ignored; other values in the pattern must match exactly.
MemberwiseClone |
setItemDeletedInSource | Overloaded.
setItemDeletedInTarget | Overloaded.
setItemIsBinaryFile | Overloaded.
setItemModifiedInSource | Overloaded.
setItemModifiedInTarget | Overloaded.
setItemMovedInSource | Overloaded.
setItemMovedInTarget | Overloaded.
setItemPresentInSource | Overloaded.
setItemPresentInTarget | Overloaded.
setItemsHaveSameContent | Overloaded.
setItemsInDifferentBranches | Overloaded.
setItemTypeName |
setMergeType | Sets the merge type.
setParentFolderDeletedInTarget | Overloaded.
setParentFolderFailed | Overloaded.
setParentFolderIgnored | Overloaded.
setSomeChangedPropertiesExcludedFromMerge | Overloaded.
setSourceChildShareOfTarget | Overloaded.
setSourceIsFloating | Overloaded.
setSourceItemOnRootBranch | Overloaded.
setTargetChildShareOfSource | Overloaded.
setTargetFolderHasFloatingShares | Overloaded.
setTargetIsFloating | Overloaded.
setTargetItemOnRootBranch | Overloaded.
ToString |

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemDeletedInSource Method

Indicates whether or not the item in question is deleted in the source view.

public virtual bool getItemDeletedInSource();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemDeletedInTarget Method

Indicates whether or not the item in question is deleted in the target view.

public virtual bool getItemDeletedInTarget();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemIsBinaryFile Method

Indicates whether or not the item in question is a binary file.

public virtual bool getItemIsBinaryFile();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemModifiedInSource Method

Indicates whether or not the item in question is modified in the source view.

public virtual bool getItemModifiedInSource();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemModifiedInTarget Method

Indicates whether or not the item in question is modified in the target view.

public virtual bool getItemModifiedInTarget();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemMovedInSource Method

Indicates whether or not the item in question is moved in the source view.

public virtual bool getItemMovedInSource();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemMovedInTarget Method

Indicates whether or not the item in question is moved in the target view.

public virtual bool getItemMovedInTarget();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemPresentInSource Method

Indicates whether or not the item in question is present in the source view.

public virtual bool getItemPresentInSource();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemPresentInTarget Method

Indicates whether or not the item in question is present in the target view.

public virtual bool getItemPresentInTarget();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemsHaveSameContent Method

Indicates whether or not the source and target items have identical content.

public virtual bool getItemsHaveSameContent();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemsInDifferentBranches Method

Indicates whether or not the source and target items are in different branches of the object's version tree.

public virtual bool getItemsInDifferentBranches();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getItemTypeName Method

Gets the item type.

public virtual string getItemTypeName();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getMergeType Method

Gets the merge type.

public virtual MergeType getMergeType();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getParentFolderDeletedInTarget Method

NOTE: This method is now obsolete.

Indicates whether or not the target item's parent folder has been deleted.

public virtual bool getParentFolderDeletedInTarget();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getParentFolderFailed Method

Indicates whether or not the target item's parent folder failed to be reconciled.

public virtual bool getParentFolderFailed();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getParentFolderIgnored Method

Indicates whether or not the target item's parent folder is ignored.

public virtual bool getParentFolderIgnored();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getSomeChangedPropertiesExcludedFromMerge Method

Indicates whether or not the source and target items have identical content.

public virtual bool getSomeChangedPropertiesExcludedFromMerge();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getSourceChildShareOfTarget Method

Indicates whether or not the source item is a child share of the target item.

public virtual bool getSourceChildShareOfTarget();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getSourceIsFloating Method

Indicates whether or not the source item has a floating configuration.

public virtual bool getSourceIsFloating();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getSourceItemOnRootBranch Method

Indicates whether or not the source item is on the root branch of the share tree.

public virtual bool getSourceItemOnRootBranch();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getTargetChildShareOfSource Method

Indicates whether or not the target item is a child share of the source item.

public virtual bool getTargetChildShareOfSource();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getTargetFolderHasFloatingShares Method

Indicates whether or not the target item's parent folder has floating child shares.

public virtual bool getTargetFolderHasFloatingShares();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getTargetIsFloating Method

Indicates whether or not the target item has a floating configuration.

public virtual bool getTargetIsFloating();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.getTargetItemOnRootBranch Method

Indicates whether or not the target item is on the root branch of the share tree.

public virtual bool getTargetItemOnRootBranch();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.matches Method

Determines whether or not this MatchState matches the conditions specified by the given pattern. "Don't Care" values in the pattern are ignored; other values in the pattern must match exactly.

public virtual bool matches(
MatchState pattern
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.MemberwiseClone Method

public override object MemberwiseClone();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setItemDeletedInSource Method

Borland StarTeam SDK for .NET

MatchState.setItemDeletedInSource Method

Indicates whether or not the item in question is deleted in the source view.

Overload List

Indicates whether or not the item in question is deleted in the source view.

public virtual void setItemDeletedInSource(Boolean);

public virtual void setItemDeletedInSource(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemDeletedInSource Method (Boolean)

Indicates whether or not the item in question is deleted in the source view.

public virtual void setItemDeletedInSource(
Boolean isDeleted
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemDeletedInSource Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemDeletedInSource Method (Boolean)

public virtual void setItemDeletedInSource(
Boolean isDeleted
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemDeletedInSource Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setItemDeletedInTarget Method

Borland StarTeam SDK for .NET

MatchState.setItemDeletedInTarget Method

Indicates whether or not the item in question is deleted in the target view.

Overload List

Indicates whether or not the item in question is deleted in the target view.

public virtual void setItemDeletedInTarget(Boolean);

public virtual void setItemDeletedInTarget(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemDeletedInTarget Method (Boolean)

Indicates whether or not the item in question is deleted in the target view.

public virtual void setItemDeletedInTarget(
Boolean isDeleted
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemDeletedInTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemDeletedInTarget Method (Boolean)

public virtual void setItemDeletedInTarget(
Boolean isDeleted
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemDeletedInTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setItemIsBinaryFile Method

Borland StarTeam SDK for .NET

MatchState.setItemIsBinaryFile Method

Indicates whether or not the item in question is a binary file.

Overload List

Indicates whether or not the item in question is a binary file.

public virtual void setItemIsBinaryFile(Boolean);

public virtual void setItemIsBinaryFile(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemIsBinaryFile Method (Boolean)

Indicates whether or not the item in question is a binary file.

public virtual void setItemIsBinaryFile(
Boolean isBinary
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemIsBinaryFile Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemIsBinaryFile Method (Boolean)

public virtual void setItemIsBinaryFile(
Boolean isBinary
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemIsBinaryFile Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setItemModifiedInSource Method

Borland StarTeam SDK for .NET

MatchState.setItemModifiedInSource Method

Indicates whether or not the item in question is modified in the source view.

Overload List

Indicates whether or not the item in question is modified in the source view.

public virtual void setItemModifiedInSource(Boolean);

public virtual void setItemModifiedInSource(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemModifiedInSource Method (Boolean)

Indicates whether or not the item in question is modified in the source view.

public virtual void setItemModifiedInSource(
Boolean isModified
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemModifiedInSource Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemModifiedInSource Method (Boolean)

public virtual void setItemModifiedInSource(
Boolean isModified
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemModifiedInSource Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setItemModifiedInTarget Method

Borland StarTeam SDK for .NET

MatchState.setItemModifiedInTarget Method

Indicates whether or not the item in question is modified in the target view.

Overload List

Indicates whether or not the item in question is modified in the target view.

public virtual void setItemModifiedInTarget(Boolean);

public virtual void setItemModifiedInTarget(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemModifiedInTarget Method (Boolean)

Indicates whether or not the item in question is modified in the target view.

public virtual void setItemModifiedInTarget(
Boolean isModified
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemModifiedInTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemModifiedInTarget Method (Boolean)

public virtual void setItemModifiedInTarget(
Boolean isModified
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemModifiedInTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setItemMovedInSource Method

Borland StarTeam SDK for .NET

MatchState.setItemMovedInSource Method

Indicates whether or not the item in question is moved in the source view.

Overload List

Indicates whether or not the item in question is moved in the source view.

public virtual void setItemMovedInSource(Boolean);

public virtual void setItemMovedInSource(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemMovedInSource Method (Boolean)

Indicates whether or not the item in question is moved in the source view.

public virtual void setItemMovedInSource(
Boolean isMoved
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemMovedInSource Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemMovedInSource Method (Boolean)

public virtual void setItemMovedInSource(
Boolean isMoved
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemMovedInSource Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setItemMovedInTarget Method

Borland StarTeam SDK for .NET

MatchState.setItemMovedInTarget Method

Indicates whether or not the item in question is moved in the target view.

Overload List

Indicates whether or not the item in question is moved in the target view.

public virtual void setItemMovedInTarget(Boolean);

public virtual void setItemMovedInTarget(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemMovedInTarget Method (Boolean)

Indicates whether or not the item in question is moved in the target view.

public virtual void setItemMovedInTarget(
Boolean isMoved
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemMovedInTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemMovedInTarget Method (Boolean)

public virtual void setItemMovedInTarget(
Boolean isMoved
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemMovedInTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setItemPresentInSource Method

Borland StarTeam SDK for .NET

MatchState.setItemPresentInSource Method

Indicates whether or not the item in question is present in the source view.

Overload List

Indicates whether or not the item in question is present in the source view.

public virtual void setItemPresentInSource(Boolean);

public virtual void setItemPresentInSource(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemPresentInSource Method (Boolean)

Indicates whether or not the item in question is present in the source view.

public virtual void setItemPresentInSource(
Boolean isPresent
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemPresentInSource Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemPresentInSource Method (Boolean)

public virtual void setItemPresentInSource(
Boolean isPresent
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemPresentInSource Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setItemPresentInTarget Method

Borland StarTeam SDK for .NET

MatchState.setItemPresentInTarget Method

Indicates whether or not the item in question is present in the target view.

Overload List

Indicates whether or not the item in question is present in the target view.

public virtual void setItemPresentInTarget(Boolean);

public virtual void setItemPresentInTarget(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemPresentInTarget Method (Boolean)

Indicates whether or not the item in question is present in the target view.

public virtual void setItemPresentInTarget(
Boolean isPresent
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemPresentInTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemPresentInTarget Method (Boolean)

public virtual void setItemPresentInTarget(
Boolean isPresent
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemPresentInTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setItemsHaveSameContent Method

Borland StarTeam SDK for .NET

MatchState.setItemsHaveSameContent Method

Indicates whether or not the source and target items have identical content.

Overload List

Indicates whether or not the source and target items have identical content.

public virtual void setItemsHaveSameContent(Boolean);

public virtual void setItemsHaveSameContent(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemsHaveSameContent Method (Boolean)

Indicates whether or not the source and target items have identical content.

public virtual void setItemsHaveSameContent(
Boolean isSame
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemsHaveSameContent Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemsHaveSameContent Method (Boolean)

public virtual void setItemsHaveSameContent(
Boolean isSame
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemsHaveSameContent Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setItemsInDifferentBranches Method

Borland StarTeam SDK for .NET

MatchState.setItemsInDifferentBranches Method

Indicates whether or not the source and target items are in different branches of the object's version tree.

Overload List

Indicates whether or not the source and target items are in different branches of the object's version tree.

public virtual void setItemsInDifferentBranches(Boolean);

public virtual void setItemsInDifferentBranches(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemsInDifferentBranches Method (Boolean)

Indicates whether or not the source and target items are in different branches of the object's version tree.

public virtual void setItemsInDifferentBranches(
Boolean isDifferent
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemsInDifferentBranches Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemsInDifferentBranches Method (Boolean)

public virtual void setItemsInDifferentBranches(
Boolean isDifferent
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setItemsInDifferentBranches Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setItemTypeName Method

public virtual void setItemTypeName(
String typename
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setMergeType Method

Sets the merge type.

public virtual void setMergeType(
MergeType mergeType
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setParentFolderDeletedInTarget Method

Borland StarTeam SDK for .NET

MatchState.setParentFolderDeletedInTarget Method

NOTE: This method is now obsolete.

Indicates whether or not the target item's parent folder has been deleted.

Overload List

Obsolete. Indicates whether or not the target item's parent folder has been deleted.

public virtual void setParentFolderDeletedInTarget(Boolean);

Obsolete.

public virtual void setParentFolderDeletedInTarget(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setParentFolderDeletedInTarget Method (Boolean)

NOTE: This method is now obsolete.

Indicates whether or not the target item's parent folder has been deleted.

public virtual void setParentFolderDeletedInTarget(
Boolean isDeleted
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setParentFolderDeletedInTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setParentFolderDeletedInTarget Method (Boolean)

NOTE: This method is now obsolete.

public virtual void setParentFolderDeletedInTarget(
Boolean isDeleted
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setParentFolderDeletedInTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setParentFolderFailed Method

Borland StarTeam SDK for .NET

MatchState.setParentFolderFailed Method

Indicates whether or not the target item's parent folder failed to be reconciled.

Overload List

Indicates whether or not the target item's parent folder failed to be reconciled.

public virtual void setParentFolderFailed(Boolean);

public virtual void setParentFolderFailed(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setParentFolderFailed Method (Boolean)

Indicates whether or not the target item's parent folder failed to be reconciled.

public virtual void setParentFolderFailed(
Boolean isFailed
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setParentFolderFailed Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setParentFolderFailed Method (Boolean)

public virtual void setParentFolderFailed(
Boolean isFailed
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setParentFolderFailed Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setParentFolderIgnored Method

Borland StarTeam SDK for .NET

MatchState.setParentFolderIgnored Method

Indicates whether or not the target item's parent folder is ignored.

Overload List

Indicates whether or not the target item's parent folder is ignored.

public virtual void setParentFolderIgnored(Boolean);

public virtual void setParentFolderIgnored(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setParentFolderIgnored Method (Boolean)

Indicates whether or not the target item's parent folder is ignored.

public virtual void setParentFolderIgnored(
Boolean isIgnored
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setParentFolderIgnored Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setParentFolderIgnored Method (Boolean)

public virtual void setParentFolderIgnored(
Boolean isIgnored
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setParentFolderIgnored Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setSomeChangedPropertiesExcludedFromMerge Method

Borland StarTeam SDK for .NET

MatchState.setSomeChangedPropertiesExcludedFromMerge Method

Indicates whether or not the source and target items have identical content.

Overload List

Indicates whether or not the source and target items have identical content.

public virtual void setSomeChangedPropertiesExcludedFromMerge(Boolean);

public virtual void setSomeChangedPropertiesExcludedFromMerge(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setSomeChangedPropertiesExcludedFromMerge Method (Boolean)

Indicates whether or not the source and target items have identical content.

public virtual void setSomeChangedPropertiesExcludedFromMerge(
Boolean isSame
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setSomeChangedPropertiesExcludedFromMerge Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setSomeChangedPropertiesExcludedFromMerge Method (Boolean)

public virtual void setSomeChangedPropertiesExcludedFromMerge(
Boolean isSame
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setSomeChangedPropertiesExcludedFromMerge Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setSourceChildShareOfTarget Method

Borland StarTeam SDK for .NET

MatchState.setSourceChildShareOfTarget Method

Indicates whether or not the the source item is a child share of the target item.

Overload List

Indicates whether or not the the source item is a child share of the target item.

public virtual void setSourceChildShareOfTarget(Boolean);

public virtual void setSourceChildShareOfTarget(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setSourceChildShareOfTarget Method (Boolean)

Indicates whether or not the the source item is a child share of the target item.

public virtual void setSourceChildShareOfTarget(
Boolean isChildShare
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setSourceChildShareOfTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setSourceChildShareOfTarget Method (Boolean)

public virtual void setSourceChildShareOfTarget(
Boolean isChildShare
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setSourceChildShareOfTarget Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setSourceIsFloating Method

Borland StarTeam SDK for .NET

MatchState.setSourceIsFloating Method

Indicates whether or not the the source item has a floating configuration.

Overload List

Indicates whether or not the the source item has a floating configuration.

public virtual void setSourceIsFloating(Boolean);

public virtual void setSourceIsFloating(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setSourceIsFloating Method (Boolean)

Indicates whether or not the the source item has a floating configuration.

public virtual void setSourceIsFloating(
Boolean isFloating
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setSourceIsFloating Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setSourceIsFloating Method (Boolean)

public virtual void setSourceIsFloating(
Boolean isFloating
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setSourceIsFloating Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setSourceItemOnRootBranch Method

Borland StarTeam SDK for .NET

MatchState.setSourceItemOnRootBranch Method

Indicates whether or not the source item is on the root branch of the share tree.

Overload List

Indicates whether or not the source item is on the root branch of the share tree.

public virtual void setSourceItemOnRootBranch(Boolean);

public virtual void setSourceItemOnRootBranch(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setSourceItemOnRootBranch Method (Boolean)

Indicates whether or not the source item is on the root branch of the share tree.

public virtual void setSourceItemOnRootBranch(
Boolean isOnRootBranch
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setSourceItemOnRootBranch Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setSourceItemOnRootBranch Method (Boolean)

public virtual void setSourceItemOnRootBranch(
Boolean isOnRootBranch
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setSourceItemOnRootBranch Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setTargetChildShareOfSource Method

Borland StarTeam SDK for .NET

MatchState.setTargetChildShareOfSource Method

Indicates whether or not the the target item is a child share of the source item.

Overload List

Indicates whether or not the the target item is a child share of the source item.

public virtual void setTargetChildShareOfSource(Boolean);

public virtual void setTargetChildShareOfSource(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setTargetChildShareOfSource Method (Boolean)

Indicates whether or not the the target item is a child share of the source item.

public virtual void setTargetChildShareOfSource(
Boolean isChildShare
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setTargetChildShareOfSource Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setTargetChildShareOfSource Method (Boolean)

public virtual void setTargetChildShareOfSource(
Boolean isChildShare
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setTargetChildShareOfSource Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setTargetFolderHasFloatingShares Method

Borland StarTeam SDK for .NET

MatchState.setTargetFolderHasFloatingShares Method

Indicates whether or not the target item's parent folder has floating child shares.

Overload List

Indicates whether or not the target item's parent folder has floating child shares.

public virtual void setTargetFolderHasFloatingShares(Boolean);

public virtual void setTargetFolderHasFloatingShares(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setTargetFolderHasFloatingShares Method (Boolean)

Indicates whether or not the target item's parent folder has floating child shares.

public virtual void setTargetFolderHasFloatingShares(
Boolean hasFloatingShares
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setTargetFolderHasFloatingShares Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setTargetFolderHasFloatingShares Method (Boolean)

public virtual void setTargetFolderHasFloatingShares(
Boolean hasFloatingShares
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setTargetFolderHasFloatingShares Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setTargetIsFloating Method

Borland StarTeam SDK for .NET

MatchState.setTargetIsFloating Method

Indicates whether or not the target item has a floating configuration.

Overload List

Indicates whether or not the target item has a floating configuration.

public virtual void setTargetIsFloating(Boolean);

public virtual void setTargetIsFloating(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setTargetIsFloating Method (Boolean)

Indicates whether or not the target item has a floating configuration.

public virtual void setTargetIsFloating(
Boolean isFloating
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setTargetIsFloating Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setTargetIsFloating Method (Boolean)

public virtual void setTargetIsFloating(
Boolean isFloating
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setTargetIsFloating Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setTargetItemOnRootBranch Method

Borland StarTeam SDK for .NET

MatchState.setTargetItemOnRootBranch Method

Indicates whether or not the target item is on the root branch of the share tree.

Overload List

Indicates whether or not the target item is on the root branch of the share tree.

public virtual void setTargetItemOnRootBranch(Boolean);

public virtual void setTargetItemOnRootBranch(Boolean);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setTargetItemOnRootBranch Method (Boolean)

Indicates whether or not the target item is on the root branch of the share tree.

public virtual void setTargetItemOnRootBranch(
Boolean isOnRootBranch
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setTargetItemOnRootBranch Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.setTargetItemOnRootBranch Method (Boolean)

public virtual void setTargetItemOnRootBranch(
Boolean isOnRootBranch
);

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace | MatchState.setTargetItemOnRootBranch Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MatchState.ToString Method

public override string ToString();

See Also

MatchState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction Class

For a list of all members of this type, see MergeAction Members.

System.Object
MergeAction

public class MergeAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MergeAction Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction Members

MergeAction overview

Public Static Fields

DELETE |
DELETE_AND_REVERSE_SHARE |
FAIL | Obsolete.
IGNORE |
MARK_RESOLVED |
MERGE |
MOVE |
MOVE_AND_MERGE |
MOVE_AND_OVERWRITE |
MOVE_AND_RE_PIN |
NEEDS_REVIEW |
OVERWRITE |
RE_PIN |
REVERSE_SHARE |
SHARE |

Public Static Methods

fromID |
getAllActions | Returns an array of all MergeAction instances
getAllPrimitiveActions | Returns an array of all primitive MergeAction instances

Public Instance Methods

Equals |
GetHashCode |
getID | Gets the unique ID associated with this action.
getName | Returns a String representation of this merge action
GetType (inherited from Object) | Gets the Type of the current instance.
includes | Determines whether or not this action includes the primitives specified in the given action, in any order.
MemberwiseClone |
ToString |

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction Fields

The fields of the MergeAction class are listed below. For a complete list of MergeAction class members, see the MergeAction Members topic.

Public Static Fields

DELETE |
DELETE_AND_REVERSE_SHARE |
FAIL | Obsolete.
IGNORE |
MARK_RESOLVED |
MERGE |
MOVE |
MOVE_AND_MERGE |
MOVE_AND_OVERWRITE |
MOVE_AND_RE_PIN |
NEEDS_REVIEW |
OVERWRITE |
RE_PIN |
REVERSE_SHARE |
SHARE |

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.DELETE Field

public static readonly MergeAction DELETE;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.DELETE_AND_REVERSE_SHARE Field

public static readonly MergeAction DELETE_AND_REVERSE_SHARE;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.FAIL Field

NOTE: This field is now obsolete.

public static readonly MergeAction FAIL;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.IGNORE Field

public static readonly MergeAction IGNORE;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.MARK_RESOLVED Field

public static readonly MergeAction MARK_RESOLVED;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.MERGE Field

public static readonly MergeAction MERGE;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.MOVE Field

public static readonly MergeAction MOVE;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.MOVE_AND_MERGE Field

public static readonly MergeAction MOVE_AND_MERGE;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.MOVE_AND_OVERWRITE Field

public static readonly MergeAction MOVE_AND_OVERWRITE;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.MOVE_AND_RE_PIN Field

public static readonly MergeAction MOVE_AND_RE_PIN;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.NEEDS_REVIEW Field

public static readonly MergeAction NEEDS_REVIEW;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.OVERWRITE Field

public static readonly MergeAction OVERWRITE;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.RE_PIN Field

public static readonly MergeAction RE_PIN;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.REVERSE_SHARE Field

public static readonly MergeAction REVERSE_SHARE;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.SHARE Field

public static readonly MergeAction SHARE;

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction Methods

The methods of the MergeAction class are listed below. For a complete list of MergeAction class members, see the MergeAction Members topic.

Public Static Methods

fromID |
getAllActions | Returns an array of all MergeAction instances
getAllPrimitiveActions | Returns an array of all primitive MergeAction instances

Public Instance Methods

Equals |
GetHashCode |
getID | Gets the unique ID associated with this action.
getName | Returns a String representation of this merge action
GetType (inherited from Object) | Gets the Type of the current instance.
includes | Determines whether or not this action includes the primitives specified in the given action, in any order.
MemberwiseClone |
ToString |

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.Equals Method

public override bool Equals(
Object other
);

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.fromID Method

public static MergeAction fromID(
Int32 actionID
);

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.getAllActions Method

Returns an array of all MergeAction instances

public static MergeAction[] getAllActions();

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.getAllPrimitiveActions Method

Returns an array of all primitive MergeAction instances

public static MergeAction[] getAllPrimitiveActions();

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.GetHashCode Method

public override int GetHashCode();

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.getID Method

Gets the unique ID associated with this action.

public virtual int getID();

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.getName Method

Returns a String representation of this merge action

public virtual string getName();

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.includes Method

Determines whether or not this action includes the primitives specified in the given action, in any order.

public virtual bool includes(
MergeAction action
);

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.MemberwiseClone Method

public override object MemberwiseClone();

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeAction.ToString Method

public override string ToString();

See Also

MergeAction Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePreview Class

For a list of all members of this type, see MergePreview Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
View
MergePreview

public class MergePreview : View

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MergePreview Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePreview Members

MergePreview overview

Public Instance Methods

acquireOwnership (inherited from View) |
addFolderListener (inherited from View) | Adds a listener for Folder-related events. <p> In order to handle events, an application must enable MPX.
addFolderUpdateListener (inherited from View) | Listens for updates to this view's folder tree. <p> Similar to addFolderListener(), except that events are triggered by explicit operations performed by the client application. For example, calling View.refreshFolders(), Folder.update() or Folder.remove() might each trigger update events. <p> MPX is not required to receive folder update events.
addItemListener (inherited from View) | Overloaded.
addItemUpdateListener (inherited from View) |
addLabelListener (inherited from View) | Adds a listener for Label events. <p> Event handlers will be tiggered whenever a Label is added, changed, or deleted in this View. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
addToIntArray (inherited from TypedResource) |
addViewListener (inherited from View) | Adds a listener for View events. <p> Event handlers will be tiggered when this View is changed or deleted. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
Clone (inherited from CacheRef) |
cloneRevisionLabel (inherited from View) |
cloneViewLabel (inherited from View) |
close (inherited from View) | Frees all cached resources associated with this view, and closes the associated view session. <p> Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). <p> After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
copy (inherited from View) | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
createCheckinManager (inherited from View) | Overloaded. Constructs a CheckinManager with default options for this view.
createCheckoutManager (inherited from View) | Overloaded. Constructs a CheckoutManager with default options for this view.
createChildViewShareAllItems (inherited from View) |
createChildViewShareDefaultItems (inherited from View) |
createChildViewShareNoItems (inherited from View) |
createChildViewShareTheseItems (inherited from View) |
createRevisionLabel (inherited from View) |
createViewLabel (inherited from View) |
discard (inherited from View) | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
discardActiveLabels (inherited from View) | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
discardFolders (inherited from View) | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
discardLabels (inherited from View) | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from View) |
fetchAllLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. <p> The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. <p> If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
fetchAllLabelsFromView (inherited from View) |
findFolder (inherited from View) |
findItem (inherited from View) |
get (inherited from View) |
getACL (inherited from View) |
getActiveLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. The labels are cached until explicitly refreshed.
getAlternatePath (inherited from View) | Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.
getBaseConfiguration (inherited from View) | Returns the ViewConfiguration from which this View was derived.
getByteArray (inherited from SimpleTypedResource) |
getConfiguration (inherited from View) | Returns this view's configuration.
getContainerLevelACL (inherited from View) |
getCreatedBy (inherited from View) | Returns the user ID of the user that created the view.
getCreatedTime (inherited from View) | Returns the time at which the view was created.
getDefaultPath (inherited from View) | Returns the default working file path to be used for this view. This is the value stored in the repository.
getDerivedViews (inherited from View) | Returns the set of views derived from this one.
getDescription (inherited from View) | Returns the description of this view.
getDisembodiedItem (inherited from View) |
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
getFileStatusManager (inherited from View) | Get the FileBasedStatusManager that manages file status information for this View. The corresponding StarTeam Server must support client-managed status.
getFullName (inherited from View) | Returns the full hierarchical name of this view--that is, the concatentation of the root view and each descendent to this view.
GetHashCode (inherited from View) |
getHaveAccessRights (inherited from View) | Obsolete. Indicates whether or not the logged on user has rights to access this view.
getHistoryForItemID (inherited from View) |
getID (inherited from View) |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLabels (inherited from View) | Returns the labels that exist in this view, including both active and deleted labels. The labels are cached until explicitly refreshed.
getName (inherited from View) | Returns the name of this view.
getNewNotificationItems (inherited from View) |
getOLEDate (inherited from SimpleTypedResource) |
getOwner (inherited from View) |
getParentContainer (inherited from View) |
getParentView (inherited from View) | Returns the parent of this view.
getPath (inherited from View) | Returns the working file path being used for this view. This path is either the default path or the alternate path. A non-null alternate path takes precedence over a default path.
getPossibleValues (inherited from SimpleTypedResource) |
getProject (inherited from View) | Returns the project to which this view belongs.
getPromotionModel (inherited from View) | Returns the promotion model associated with this view.
getPropertyNames (inherited from SimpleTypedResource) |
getRecycleBin (inherited from View) | Provides access to the items that have been deleted from a view. <p> For example: <pre> RecycleBin bin = view.getRecycleBin(); Folder root = bin.getRootFolder(); Item[] files = root.getItems(TypeNames.FILE); for (int i = 0; i < files.length; i++) { assertTrue(files[i].isDeleted()); } </pre> Note that this method is supported by StarTeam Server versions 9.0 and later.
getRootFolder (inherited from View) | Gets the root folder of this view. The Folder hierarchy is cached in the View object, until explicitly refreshed or discarded.
getServer (inherited from View) | Returns the server to which this view belongs.
getSession | return the Session that this view belongs to
getStatusMethodOverride (inherited from View) | Returns the status method used to determine status for files in this view. This method will not return null.
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getViewID (inherited from View) | Returns the unique integer identifier for this view.
hasNewNotificationItems (inherited from View) |
hasPermission (inherited from View) | Overloaded.
isAccessible (inherited from View) | Determines whether or not the logged on user has access to this view.
isBranch (inherited from View) | Return true if this view is a Branch view.
isBranchAll (inherited from View) | Return true if this view's original branching default was set "All".
isBranchNone (inherited from View) | Return true if this view's original branching default was set "None".
isBranchOnShare (inherited from View) | Returns true if this view is set to branch shared items.
isDeleted (inherited from View) | Determines whether or not this view has been deleted from the server.
isEqualTo (inherited from View) | Compares the properties of two Views.
isNonDerived (inherited from View) | Return true if this view is a Non-Derived view.
isReadOnly (inherited from View) | Return true if this is a ReadOnly view, otherwise false.
isReference (inherited from View) | Return true if this is a reference view, otherwise false.
isRefreshActiveLabelsRequired (inherited from View) | Returns true if a refreshLabels() operation might have resulted in Label information for active (non-deleted) labels being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshFoldersRequired (inherited from View) | Returns true if a View.refreshFolders() operation might have resulted in Folder information being updated; returns false if and only if it is known that the folders had not been changed since the last refresh. If MPX is not enabled, then isRefreshFoldersRequired() always returns true.
isRefreshLabelsRequired (inherited from View) | Returns true if a refreshLabels() operation might have resulted in Label information being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshRequired (inherited from View) | Returns true if a refresh() operation might have resulted in view properties being updated; returns false if and only if it is known that the view properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isRoot (inherited from View) | Return true if this view is a Root view.
MemberwiseClone (inherited from CacheRef) |
modifyItemsFlagForUser (inherited from View) |
modifyItemsReadStatusForUser (inherited from View) |
populate (inherited from View) | Populates project properties, if they have not already been populated.
put (inherited from View) |
putByPropertyID (inherited from View) |
refresh (inherited from View) | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
refreshActiveLabels (inherited from View) | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
refreshFolders (inherited from View) | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. <p> If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. <p> In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
refreshLabels (inherited from View) | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
refreshPromotionModel (inherited from View) | Refreshes the local cached information about this view's promotion model.
remove (inherited from View) | Removes the view from the server.
removeFolderListener (inherited from View) | Removes a listener for Folder-related events.
removeFolderUpdateListener (inherited from View) | Removes a listener for folder update events.
removeFromIntArray (inherited from TypedResource) |
removeItemListener (inherited from View) |
removeItemUpdateListener (inherited from View) |
removeLabelListener (inherited from View) | Removes a listener for Label events.
removeViewListener (inherited from View) | Removes a listener for View events.
resolveLinkEndpoint (inherited from View) | Returns the item in this view referred to by the <code>LinkEndpoint</code>. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
setACL (inherited from View) |
setAlternatePath (inherited from View) |
setBranchOnShare (inherited from View) |
setContainerLevelACL (inherited from View) |
setDefaultPath (inherited from View) |
setDescription (inherited from View) |
setName (inherited from View) |
setStatusMethodOverride (inherited from View) | Changes the status method to use for files in this view. This is a client side setting and will not change the behavior for other users of this view.
ToString (inherited from View) |
update (inherited from View) | Persists this view's properties to its <code>Server</code>.

See Also

MergePreview Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePreview Methods

The methods of the MergePreview class are listed below. For a complete list of MergePreview class members, see the MergePreview Members topic.

Public Instance Methods

acquireOwnership (inherited from View) |
addFolderListener (inherited from View) | Adds a listener for Folder-related events. <p> In order to handle events, an application must enable MPX.
addFolderUpdateListener (inherited from View) | Listens for updates to this view's folder tree. <p> Similar to addFolderListener(), except that events are triggered by explicit operations performed by the client application. For example, calling View.refreshFolders(), Folder.update() or Folder.remove() might each trigger update events. <p> MPX is not required to receive folder update events.
addItemListener (inherited from View) | Overloaded.
addItemUpdateListener (inherited from View) |
addLabelListener (inherited from View) | Adds a listener for Label events. <p> Event handlers will be tiggered whenever a Label is added, changed, or deleted in this View. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
addToIntArray (inherited from TypedResource) |
addViewListener (inherited from View) | Adds a listener for View events. <p> Event handlers will be tiggered when this View is changed or deleted. <p> In order to handle events, an application must enable MPX. The logged-in user must have access permissions for this View.
Clone (inherited from CacheRef) |
cloneRevisionLabel (inherited from View) |
cloneViewLabel (inherited from View) |
close (inherited from View) | Frees all cached resources associated with this view, and closes the associated view session. <p> Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). <p> After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
copy (inherited from View) | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
createCheckinManager (inherited from View) | Overloaded. Constructs a CheckinManager with default options for this view.
createCheckoutManager (inherited from View) | Overloaded. Constructs a CheckoutManager with default options for this view.
createChildViewShareAllItems (inherited from View) |
createChildViewShareDefaultItems (inherited from View) |
createChildViewShareNoItems (inherited from View) |
createChildViewShareTheseItems (inherited from View) |
createRevisionLabel (inherited from View) |
createViewLabel (inherited from View) |
discard (inherited from View) | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
discardActiveLabels (inherited from View) | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
discardFolders (inherited from View) | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
discardLabels (inherited from View) | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from View) |
fetchAllLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. <p> The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. <p> If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
fetchAllLabelsFromView (inherited from View) |
findFolder (inherited from View) |
findItem (inherited from View) |
get (inherited from View) |
getACL (inherited from View) |
getActiveLabels (inherited from View) | Returns all the active (non-deleted) labels for this view. The labels are cached until explicitly refreshed.
getAlternatePath (inherited from View) | Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.
getBaseConfiguration (inherited from View) | Returns the ViewConfiguration from which this View was derived.
getByteArray (inherited from SimpleTypedResource) |
getConfiguration (inherited from View) | Returns this view's configuration.
getContainerLevelACL (inherited from View) |
getCreatedBy (inherited from View) | Returns the user ID of the user that created the view.
getCreatedTime (inherited from View) | Returns the time at which the view was created.
getDefaultPath (inherited from View) | Returns the default working file path to be used for this view. This is the value stored in the repository.
getDerivedViews (inherited from View) | Returns the set of views derived from this one.
getDescription (inherited from View) | Returns the description of this view.
getDisembodiedItem (inherited from View) |
getDouble (inherited from SimpleTypedResource) |
getEnumDisplayName (inherited from SimpleTypedResource) |
getFileStatusManager (inherited from View) | Get the FileBasedStatusManager that manages file status information for this View. The corresponding StarTeam Server must support client-managed status.
getFullName (inherited from View) | Returns the full hierarchical name of this view--that is, the concatentation of the root view and each descendent to this view.
GetHashCode (inherited from View) |
getHaveAccessRights (inherited from View) | Obsolete. Indicates whether or not the logged on user has rights to access this view.
getHistoryForItemID (inherited from View) |
getID (inherited from View) |
getInt (inherited from SimpleTypedResource) |
getIntArray (inherited from SimpleTypedResource) |
getLabels (inherited from View) | Returns the labels that exist in this view, including both active and deleted labels. The labels are cached until explicitly refreshed.
getName (inherited from View) | Returns the name of this view.
getNewNotificationItems (inherited from View) |
getOLEDate (inherited from SimpleTypedResource) |
getOwner (inherited from View) |
getParentContainer (inherited from View) |
getParentView (inherited from View) | Returns the parent of this view.
getPath (inherited from View) | Returns the working file path being used for this view. This path is either the default path or the alternate path. A non-null alternate path takes precedence over a default path.
getPossibleValues (inherited from SimpleTypedResource) |
getProject (inherited from View) | Returns the project to which this view belongs.
getPromotionModel (inherited from View) | Returns the promotion model associated with this view.
getPropertyNames (inherited from SimpleTypedResource) |
getRecycleBin (inherited from View) | Provides access to the items that have been deleted from a view. <p> For example: <pre> RecycleBin bin = view.getRecycleBin(); Folder root = bin.getRootFolder(); Item[] files = root.getItems(TypeNames.FILE); for (int i = 0; i < files.length; i++) { assertTrue(files[i].isDeleted()); } </pre> Note that this method is supported by StarTeam Server versions 9.0 and later.
getRootFolder (inherited from View) | Gets the root folder of this view. The Folder hierarchy is cached in the View object, until explicitly refreshed or discarded.
getServer (inherited from View) | Returns the server to which this view belongs.
getSession | return the Session that this view belongs to
getStatusMethodOverride (inherited from View) | Returns the status method used to determine status for files in this view. This method will not return null.
getString (inherited from SimpleTypedResource) |
getType (inherited from SimpleTypedResource) |
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from SimpleTypedResource) |
getViewID (inherited from View) | Returns the unique integer identifier for this view.
hasNewNotificationItems (inherited from View) |
hasPermission (inherited from View) | Overloaded.
isAccessible (inherited from View) | Determines whether or not the logged on user has access to this view.
isBranch (inherited from View) | Return true if this view is a Branch view.
isBranchAll (inherited from View) | Return true if this view's original branching default was set "All".
isBranchNone (inherited from View) | Return true if this view's original branching default was set "None".
isBranchOnShare (inherited from View) | Returns true if this view is set to branch shared items.
isDeleted (inherited from View) | Determines whether or not this view has been deleted from the server.
isEqualTo (inherited from View) | Compares the properties of two Views.
isNonDerived (inherited from View) | Return true if this view is a Non-Derived view.
isReadOnly (inherited from View) | Return true if this is a ReadOnly view, otherwise false.
isReference (inherited from View) | Return true if this is a reference view, otherwise false.
isRefreshActiveLabelsRequired (inherited from View) | Returns true if a refreshLabels() operation might have resulted in Label information for active (non-deleted) labels being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshFoldersRequired (inherited from View) | Returns true if a View.refreshFolders() operation might have resulted in Folder information being updated; returns false if and only if it is known that the folders had not been changed since the last refresh. If MPX is not enabled, then isRefreshFoldersRequired() always returns true.
isRefreshLabelsRequired (inherited from View) | Returns true if a refreshLabels() operation might have resulted in Label information being updated; returns false if and only if it is known that the Labels had not been changed since the last refresh. If MPX is not enabled, then isRefreshLabelsRequired() always returns true.
isRefreshRequired (inherited from View) | Returns true if a refresh() operation might have resulted in view properties being updated; returns false if and only if it is known that the view properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isRoot (inherited from View) | Return true if this view is a Root view.
MemberwiseClone (inherited from CacheRef) |
modifyItemsFlagForUser (inherited from View) |
modifyItemsReadStatusForUser (inherited from View) |
populate (inherited from View) | Populates project properties, if they have not already been populated.
put (inherited from View) |
putByPropertyID (inherited from View) |
refresh (inherited from View) | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
refreshActiveLabels (inherited from View) | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
refreshFolders (inherited from View) | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. <p> If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. <p> In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
refreshLabels (inherited from View) | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
refreshPromotionModel (inherited from View) | Refreshes the local cached information about this view's promotion model.
remove (inherited from View) | Removes the view from the server.
removeFolderListener (inherited from View) | Removes a listener for Folder-related events.
removeFolderUpdateListener (inherited from View) | Removes a listener for folder update events.
removeFromIntArray (inherited from TypedResource) |
removeItemListener (inherited from View) |
removeItemUpdateListener (inherited from View) |
removeLabelListener (inherited from View) | Removes a listener for Label events.
removeViewListener (inherited from View) | Removes a listener for View events.
resolveLinkEndpoint (inherited from View) | Returns the item in this view referred to by the <code>LinkEndpoint</code>. If the reference is pinned to a historical (non-tip) version, that version is returned from the history of the tip item in this view.
setACL (inherited from View) |
setAlternatePath (inherited from View) |
setBranchOnShare (inherited from View) |
setContainerLevelACL (inherited from View) |
setDefaultPath (inherited from View) |
setDescription (inherited from View) |
setName (inherited from View) |
setStatusMethodOverride (inherited from View) | Changes the status method to use for files in this view. This is a client side setting and will not change the behavior for other users of this view.
ToString (inherited from View) |
update (inherited from View) | Persists this view's properties to its <code>Server</code>.

See Also

MergePreview Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergePreview.getSession Method

return the Session that this view belongs to

public virtual Session getSession();

See Also

MergePreview Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType Class

For a list of all members of this type, see MergeType Members.

System.Object
MergeType

public class MergeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MergeType Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType Members

MergeType overview

Public Static Fields

COMPARE
PROMOTE
REBASE
REPLICATE

Public Instance Methods

Equals |
getAllMergeTypes | Gets a list of all supported merge types.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName | Gets the user-friendly name of this merge type.
GetType (inherited from Object) | Gets the Type of the current instance.
intValue | Gets an integer ID that is unique for each merge type.
MemberwiseClone |
ToString |

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType Fields

The fields of the MergeType class are listed below. For a complete list of MergeType class members, see the MergeType Members topic.

Public Static Fields

COMPARE
PROMOTE
REBASE
REPLICATE

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType.COMPARE Field

public static readonly MergeType COMPARE;

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType.PROMOTE Field

public static readonly MergeType PROMOTE;

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType.REBASE Field

public static readonly MergeType REBASE;

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType.REPLICATE Field

public static readonly MergeType REPLICATE;

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType Methods

The methods of the MergeType class are listed below. For a complete list of MergeType class members, see the MergeType Members topic.

Public Instance Methods

Equals |
getAllMergeTypes | Gets a list of all supported merge types.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName | Gets the user-friendly name of this merge type.
GetType (inherited from Object) | Gets the Type of the current instance.
intValue | Gets an integer ID that is unique for each merge type.
MemberwiseClone |
ToString |

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType.Equals Method

public override bool Equals(
Object mergeType
);

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType.getAllMergeTypes Method

Gets a list of all supported merge types.

public virtual MergeType[] getAllMergeTypes();

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType.getName Method

Gets the user-friendly name of this merge type.

public virtual string getName();

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType.intValue Method

Gets an integer ID that is unique for each merge type.

public virtual int intValue();

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType.MemberwiseClone Method

public override object MemberwiseClone();

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MergeType.ToString Method

public override string ToString();

See Also

MergeType Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options Class

For a list of all members of this type, see Options Members.

System.Object
Options

public class Options

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Options Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options Members

Options overview

Public Static Methods

getExcludablePropertiesForMerge | returns the set of properties (of a specified type) that may be excluded from a VCM compare & merge Excluding properties allows an application fine grained control over which properties should be considered relevant to a VCM View Compare Merge Session.
getWorkstationDefault | Returns the default Options for this workstation

Public Instance Constructors

Options Overloaded. Initializes a new instance of the Options class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
excludePropertyFromMerge | Specify a property to exclude from a VCM compare & merge Excluding properties allows an application fine grained control over which properties should be considered relevant to a VCM View Compare Merge Session. Excluded properties will not be compared, merged or overwritten Only user modifiable &/or attachment properties can be excluded from the merge
getActionOverrides | An array of ActionOverride's, in the order in which they have been set
getAutoMergeFiles | Returns true if file pairs that have no conflicts will be automatically merged. The default value is false.
getAutoMergeProperties | Returns true if property pairs that have no conflicts will be automatically merged. The default value is false.
getBreakLocksAutomatically | Returns true if locks will automatically be broken as needed to check in merged revisions. The default value is false.
getCheckTargetFoldersForFloatingShares | Determines whether or not VCM will check target folders for floating child shares, and fail if any are found.
getFixFloatingChildShares | Indicates whether or not shares that float from the source view to the target view will automatically be detected during the compare phase and fixed during the commit.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getIgnoreMergePoints | Returns true if all merge points should be ignored for comparisons. The default value is false.
getLockSourceForDifference | Returns true if a source item will be locked when a difference is detected. The default value is false.
getLockTargetForDifference | Returns true if a target item will be locked when a difference is detected. The default value is false.
getMatchFilesByFileName | Returns true if files (or folders) with the same name are to be considered matched, even if their object and/or item ids do not match. The default value is false.
getPropertiesExcludedForMerge | Returns the set of properties excluded from a VCM Merge Only user modifiable &/or attachment properties may be excluded
getProperty |
getPropertyNames | Returns an array of all the keys in this property list,
getTransactionsEnabled | Determines whether or not commit operations are executed within an atomic transaction, if supported by the StarTeam server.
getTreatFileNamesAsCaseSensitive | Returns true if file (or folder) names are compared in a case-sensitive manner. The default value is false.
GetType (inherited from Object) | Gets the Type of the current instance.
getVerboseDifferences | Determines whether or not a difference is generated for every matched pair of source and target items, whether or not the match is considered a difference. The default value is false. <p> Verbose differences are off by default, but are enabled for sessions whose scope is not the entire source view.
getVerboseProcessLinks | Determines whether or not a commit operation should create process links for all file and folder operations that add or modify target items.
isExcludedFromMerge | returns true if the specified property has been excluded from the merge
MemberwiseClone |
setAutoMergeFiles |
setAutoMergeProperties |
setBreakLocksAutomatically |
setCheckTargetFoldersForFloatingShares |
setDefaultAction | Overloaded.
setExcludePropertyFromMerge |
setFixFloatingChildShares |
setIgnoreMergePoints |
setLockSourceForDifference |
setLockTargetForDifference |
setMatchFilesByFileName |
setProperty |
setTransactionsEnabled |
setTreatFileNamesAsCaseSensitive |
setVerboseDifferences |
setVerboseProcessLinks |
setWorkstationDefault | Saves the current set of options as the defaults for this workstation.
ToString |

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options Constructor

Constructs a set of Options with default values.

Overload List

Constructs a set of Options with default values.

public Options();

Create an Options instance by copying the contents of another

public Options(Options);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options Constructor ()

Constructs a set of Options with default values.

public Options();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace | Options Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options Constructor (Options)

Create an Options instance by copying the contents of another

public Options(
Options other
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace | Options Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options Methods

The methods of the Options class are listed below. For a complete list of Options class members, see the Options Members topic.

Public Static Methods

getExcludablePropertiesForMerge | returns the set of properties (of a specified type) that may be excluded from a VCM compare & merge Excluding properties allows an application fine grained control over which properties should be considered relevant to a VCM View Compare Merge Session.
getWorkstationDefault | Returns the default Options for this workstation

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
excludePropertyFromMerge | Specify a property to exclude from a VCM compare & merge Excluding properties allows an application fine grained control over which properties should be considered relevant to a VCM View Compare Merge Session. Excluded properties will not be compared, merged or overwritten Only user modifiable &/or attachment properties can be excluded from the merge
getActionOverrides | An array of ActionOverride's, in the order in which they have been set
getAutoMergeFiles | Returns true if file pairs that have no conflicts will be automatically merged. The default value is false.
getAutoMergeProperties | Returns true if property pairs that have no conflicts will be automatically merged. The default value is false.
getBreakLocksAutomatically | Returns true if locks will automatically be broken as needed to check in merged revisions. The default value is false.
getCheckTargetFoldersForFloatingShares | Determines whether or not VCM will check target folders for floating child shares, and fail if any are found.
getFixFloatingChildShares | Indicates whether or not shares that float from the source view to the target view will automatically be detected during the compare phase and fixed during the commit.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getIgnoreMergePoints | Returns true if all merge points should be ignored for comparisons. The default value is false.
getLockSourceForDifference | Returns true if a source item will be locked when a difference is detected. The default value is false.
getLockTargetForDifference | Returns true if a target item will be locked when a difference is detected. The default value is false.
getMatchFilesByFileName | Returns true if files (or folders) with the same name are to be considered matched, even if their object and/or item ids do not match. The default value is false.
getPropertiesExcludedForMerge | Returns the set of properties excluded from a VCM Merge Only user modifiable &/or attachment properties may be excluded
getProperty |
getPropertyNames | Returns an array of all the keys in this property list,
getTransactionsEnabled | Determines whether or not commit operations are executed within an atomic transaction, if supported by the StarTeam server.
getTreatFileNamesAsCaseSensitive | Returns true if file (or folder) names are compared in a case-sensitive manner. The default value is false.
GetType (inherited from Object) | Gets the Type of the current instance.
getVerboseDifferences | Determines whether or not a difference is generated for every matched pair of source and target items, whether or not the match is considered a difference. The default value is false. <p> Verbose differences are off by default, but are enabled for sessions whose scope is not the entire source view.
getVerboseProcessLinks | Determines whether or not a commit operation should create process links for all file and folder operations that add or modify target items.
isExcludedFromMerge | returns true if the specified property has been excluded from the merge
MemberwiseClone |
setAutoMergeFiles |
setAutoMergeProperties |
setBreakLocksAutomatically |
setCheckTargetFoldersForFloatingShares |
setDefaultAction | Overloaded.
setExcludePropertyFromMerge |
setFixFloatingChildShares |
setIgnoreMergePoints |
setLockSourceForDifference |
setLockTargetForDifference |
setMatchFilesByFileName |
setProperty |
setTransactionsEnabled |
setTreatFileNamesAsCaseSensitive |
setVerboseDifferences |
setVerboseProcessLinks |
setWorkstationDefault | Saves the current set of options as the defaults for this workstation.
ToString |

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.excludePropertyFromMerge Method

Specify a property to exclude from a VCM compare & merge Excluding properties allows an application fine grained control over which properties should be considered relevant to a VCM View Compare Merge Session. Excluded properties will not be compared, merged or overwritten Only user modifiable &/or attachment properties can be excluded from the merge

public virtual void excludePropertyFromMerge(
Property p
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getActionOverrides Method

An array of ActionOverride's, in the order in which they have been set

public virtual ActionOverride[] getActionOverrides();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getAutoMergeFiles Method

Returns true if file pairs that have no conflicts will be automatically merged. The default value is false.

public virtual bool getAutoMergeFiles();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getAutoMergeProperties Method

Returns true if property pairs that have no conflicts will be automatically merged. The default value is false.

public virtual bool getAutoMergeProperties();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getBreakLocksAutomatically Method

Returns true if locks will automatically be broken as needed to check in merged revisions. The default value is false.

public virtual bool getBreakLocksAutomatically();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getCheckTargetFoldersForFloatingShares Method

Determines whether or not VCM will check target folders for floating child shares, and fail if any are found.

public virtual bool getCheckTargetFoldersForFloatingShares();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getExcludablePropertiesForMerge Method

returns the set of properties (of a specified type) that may be excluded from a VCM compare & merge Excluding properties allows an application fine grained control over which properties should be considered relevant to a VCM View Compare Merge Session.

public static Property[] getExcludablePropertiesForMerge(
Type type
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getFixFloatingChildShares Method

Indicates whether or not shares that float from the source view to the target view will automatically be detected during the compare phase and fixed during the commit.

public virtual bool getFixFloatingChildShares();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getIgnoreMergePoints Method

Returns true if all merge points should be ignored for comparisons. The default value is false.

public virtual bool getIgnoreMergePoints();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getLockSourceForDifference Method

Returns true if a source item will be locked when a difference is detected. The default value is false.

public virtual bool getLockSourceForDifference();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getLockTargetForDifference Method

Returns true if a target item will be locked when a difference is detected. The default value is false.

public virtual bool getLockTargetForDifference();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getMatchFilesByFileName Method

Returns true if files (or folders) with the same name are to be considered matched, even if their object and/or item ids do not match. The default value is false.

public virtual bool getMatchFilesByFileName();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getPropertiesExcludedForMerge Method

Returns the set of properties excluded from a VCM Merge Only user modifiable &/or attachment properties may be excluded

public virtual Property[] getPropertiesExcludedForMerge();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getProperty Method

public virtual string getProperty(
String key
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getPropertyNames Method

Returns an array of all the keys in this property list,

public virtual string[] getPropertyNames();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getTransactionsEnabled Method

Determines whether or not commit operations are executed within an atomic transaction, if supported by the StarTeam server.

public virtual bool getTransactionsEnabled();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getTreatFileNamesAsCaseSensitive Method

Returns true if file (or folder) names are compared in a case-sensitive manner. The default value is false.

public virtual bool getTreatFileNamesAsCaseSensitive();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getVerboseDifferences Method

Determines whether or not a difference is generated for every matched pair of source and target items, whether or not the match is considered a difference. The default value is false. <p> Verbose differences are off by default, but are enabled for sessions whose scope is not the entire source view.

public virtual bool getVerboseDifferences(
Type type
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getVerboseProcessLinks Method

Determines whether or not a commit operation should create process links for all file and folder operations that add or modify target items.

public virtual bool getVerboseProcessLinks();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.getWorkstationDefault Method

Returns the default Options for this workstation

public static Options getWorkstationDefault();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.isExcludedFromMerge Method

returns true if the specified property has been excluded from the merge

public virtual bool isExcludedFromMerge(
Property p
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setAutoMergeFiles Method

public virtual void setAutoMergeFiles(
Boolean bAutoMerge
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setAutoMergeProperties Method

public virtual void setAutoMergeProperties(
Boolean bAutoMerge
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setBreakLocksAutomatically Method

public virtual void setBreakLocksAutomatically(
Boolean bBreakLocks
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setCheckTargetFoldersForFloatingShares Method

public virtual void setCheckTargetFoldersForFloatingShares(
Boolean bEnabled
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


setDefaultAction Method

Borland StarTeam SDK for .NET

Options.setDefaultAction Method

Overload List

public virtual void setDefaultAction(DifferenceType,MergeAction);

public virtual void setDefaultAction(MatchState,MergeAction);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setDefaultAction Method (DifferenceType, MergeAction)

public virtual void setDefaultAction(
DifferenceType type,
MergeAction action
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace | Options.setDefaultAction Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setDefaultAction Method (MatchState, MergeAction)

public virtual void setDefaultAction(
MatchState state,
MergeAction action
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace | Options.setDefaultAction Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setExcludePropertyFromMerge Method

public virtual void setExcludePropertyFromMerge(
Property p,
Boolean exclude
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setFixFloatingChildShares Method

public virtual void setFixFloatingChildShares(
Boolean bFix
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setIgnoreMergePoints Method

public virtual void setIgnoreMergePoints(
Boolean bIgnoreMergePoints
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setLockSourceForDifference Method

public virtual void setLockSourceForDifference(
Boolean bLock
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setLockTargetForDifference Method

public virtual void setLockTargetForDifference(
Boolean bLock
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setMatchFilesByFileName Method

public virtual void setMatchFilesByFileName(
Boolean bMatchFilesByFileName
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setProperty Method

public virtual object setProperty(
String key,
String value
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setTransactionsEnabled Method

public virtual void setTransactionsEnabled(
Boolean bEnabled
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setTreatFileNamesAsCaseSensitive Method

public virtual void setTreatFileNamesAsCaseSensitive(
Boolean bCaseSensitive
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setVerboseDifferences Method

public virtual void setVerboseDifferences(
Type type,
Boolean bVerbose
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setVerboseProcessLinks Method

public virtual void setVerboseProcessLinks(
Boolean bEnabled
);

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.setWorkstationDefault Method

Saves the current set of options as the defaults for this workstation.

public virtual void setWorkstationDefault();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Options.ToString Method

public override string ToString();

See Also

Options Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState Class

For a list of all members of this type, see PreviewState Members.

System.Object
PreviewState

public class PreviewState

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

PreviewState Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState Members

PreviewState overview

Public Static Fields

HasChanges
HasComparedItems
HasConflicts
HasNoComparedItems

Public Instance Methods

Equals |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName | Returns a string representation of the preview state.
GetType (inherited from Object) | Gets the Type of the current instance.
intValue | Returns an Integer representation of this preview state
MemberwiseClone |
ToString |

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState Fields

The fields of the PreviewState class are listed below. For a complete list of PreviewState class members, see the PreviewState Members topic.

Public Static Fields

HasChanges
HasComparedItems
HasConflicts
HasNoComparedItems

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState.HasChanges Field

public static readonly PreviewState HasChanges;

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState.HasComparedItems Field

public static readonly PreviewState HasComparedItems;

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState.HasConflicts Field

public static readonly PreviewState HasConflicts;

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState.HasNoComparedItems Field

public static readonly PreviewState HasNoComparedItems;

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState Methods

The methods of the PreviewState class are listed below. For a complete list of PreviewState class members, see the PreviewState Members topic.

Public Instance Methods

Equals |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName | Returns a string representation of the preview state.
GetType (inherited from Object) | Gets the Type of the current instance.
intValue | Returns an Integer representation of this preview state
MemberwiseClone |
ToString |

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState.Equals Method

public override bool Equals(
Object previewState
);

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState.getName Method

Returns a string representation of the preview state.

public virtual string getName();

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState.intValue Method

Returns an Integer representation of this preview state

public virtual int intValue();

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState.MemberwiseClone Method

public override object MemberwiseClone();

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PreviewState.ToString Method

public override string ToString();

See Also

PreviewState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemScope Class

For a list of all members of this type, see ProcessItemScope Members.

System.Object
Scope
ProcessItemScope

public class ProcessItemScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ProcessItemScope Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemScope Members

ProcessItemScope overview

Public Instance Constructors

ProcessItemScope Overloaded. Initializes a new instance of the ProcessItemScope class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from Scope) |
ToString (inherited from Scope) |

See Also

ProcessItemScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemScope Constructor

Creates a new ProcessItemScope.

Overload List

Creates a new ProcessItemScope.

public ProcessItemScope(Item);

public ProcessItemScope(Item,Boolean);

See Also

ProcessItemScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemScope Constructor (Item)

Creates a new ProcessItemScope.

public ProcessItemScope(
Item item
);

See Also

ProcessItemScope Class | com.starbase.starteam.viewcomparemerge Namespace | ProcessItemScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ProcessItemScope Constructor (Item, Boolean)

public ProcessItemScope(
Item item,
Boolean bLinksOnly
);

See Also

ProcessItemScope Class | com.starbase.starteam.viewcomparemerge Namespace | ProcessItemScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Progress Class

For a list of all members of this type, see Progress Members.

System.Object
Progress

public class Progress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Progress Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Progress Members

Progress overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getDescription | Returns a description of the current state of the session
getEstimatedPercentComplete | Returns a percentage estimate of how complete the current operation is.
getEstimatedTimeRemaining | Returns an estimate of the time that remains to complete the current operation.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getRemainingUnitsOfWork | Get the total number of operations yet to be completed.
getTotalTimeSpent | Get the total time spent so far (in milliseconds).
getTotalUnitsOfWorkCompleted | Get the total number of operations completed.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Progress Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Progress Methods

The methods of the Progress class are listed below. For a complete list of Progress class members, see the Progress Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getDescription | Returns a description of the current state of the session
getEstimatedPercentComplete | Returns a percentage estimate of how complete the current operation is.
getEstimatedTimeRemaining | Returns an estimate of the time that remains to complete the current operation.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getRemainingUnitsOfWork | Get the total number of operations yet to be completed.
getTotalTimeSpent | Get the total time spent so far (in milliseconds).
getTotalUnitsOfWorkCompleted | Get the total number of operations completed.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Progress Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Progress.getDescription Method

Returns a description of the current state of the session

public virtual string getDescription();

See Also

Progress Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Progress.getEstimatedPercentComplete Method

Returns a percentage estimate of how complete the current operation is.

public virtual int getEstimatedPercentComplete();

See Also

Progress Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Progress.getEstimatedTimeRemaining Method

Returns an estimate of the time that remains to complete the current operation.

public virtual long getEstimatedTimeRemaining();

See Also

Progress Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Progress.getRemainingUnitsOfWork Method

Get the total number of operations yet to be completed.

public virtual int getRemainingUnitsOfWork();

See Also

Progress Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Progress.getTotalTimeSpent Method

Get the total time spent so far (in milliseconds).

public virtual long getTotalTimeSpent();

See Also

Progress Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Progress.getTotalUnitsOfWorkCompleted Method

Get the total number of operations completed.

public virtual int getTotalUnitsOfWorkCompleted();

See Also

Progress Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Progress.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Progress Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Progress.ToString Method

public override string ToString();

See Also

Progress Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyMergeException Class

For a list of all members of this type, see PropertyMergeException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
PropertyMergeException

public class PropertyMergeException : RuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

PropertyMergeException Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyMergeException Members

PropertyMergeException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getItemDifference |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from java.lang.Throwable) |
GetObjectData (inherited from java.lang.Throwable) |
getProperty |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

PropertyMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyMergeException Methods

The methods of the PropertyMergeException class are listed below. For a complete list of PropertyMergeException class members, see the PropertyMergeException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getItemDifference |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from java.lang.Throwable) |
GetObjectData (inherited from java.lang.Throwable) |
getProperty |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

PropertyMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyMergeException.getItemDifference Method

public virtual ItemDifference getItemDifference();

See Also

PropertyMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyMergeException.getProperty Method

public virtual Property getProperty();

See Also

PropertyMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyMergeException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

PropertyMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyMergeException.unwrap Method

public virtual PropertyMergeException unwrap();

See Also

PropertyMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


PropertyMergeException.wrap Method

public static PropertyMergeException wrap(
PropertyMergeException arg
);

See Also

PropertyMergeException Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionLabelScope Class

For a list of all members of this type, see RevisionLabelScope Members.

System.Object
Scope
RevisionLabelScope

public class RevisionLabelScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

RevisionLabelScope Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionLabelScope Members

RevisionLabelScope overview

Public Instance Constructors

RevisionLabelScope Overloaded. Initializes a new instance of the RevisionLabelScope class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from Scope) |
ToString (inherited from Scope) |

See Also

RevisionLabelScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionLabelScope Constructor

Creates a new RevisionLabelScope.

Overload List

Creates a new RevisionLabelScope.

public RevisionLabelScope(Label);

public RevisionLabelScope(Label,Type);

public RevisionLabelScope(Label,Type[]);

See Also

RevisionLabelScope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionLabelScope Constructor (Label)

Creates a new RevisionLabelScope.

public RevisionLabelScope(
Label label
);

See Also

RevisionLabelScope Class | com.starbase.starteam.viewcomparemerge Namespace | RevisionLabelScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionLabelScope Constructor (Label, Type)

public RevisionLabelScope(
Label label,
Type type
);

See Also

RevisionLabelScope Class | com.starbase.starteam.viewcomparemerge Namespace | RevisionLabelScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


RevisionLabelScope Constructor (Label, Type[])

public RevisionLabelScope(
Label label,
Type[] types
);

See Also

RevisionLabelScope Class | com.starbase.starteam.viewcomparemerge Namespace | RevisionLabelScope Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Scope Class

For a list of all members of this type, see Scope Members.

System.Object
Scope
Derived types

public class Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Scope Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Scope Members

Scope overview

Public Instance Constructors

Scope Constructor Initializes a new instance of the Scope class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Scope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Scope Constructor

Initializes a new instance of the Scope class.

public Scope();

See Also

Scope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Scope Methods

The methods of the Scope class are listed below. For a complete list of Scope class members, see the Scope Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Scope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Scope.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Scope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Scope.ToString Method

public override string ToString();

See Also

Scope Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session Class

For a list of all members of this type, see Session Members.

System.Object
Session

public class Session

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Session Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session Members

Session overview

Public Static Methods

getMatchHint |
remove | Overloaded. Remove the temporary folder tree associated with the specified session file.
resolve |
restoreFrom | Overloaded. Restores a saved session from a file. <p> When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. <p> For example: <pre> Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . . </pre>
setMatchHint |

Public Instance Constructors

Session Overloaded. Initializes a new instance of the Session class.

Public Instance Methods

cancel | Cancels a compare or commit operation that is currently in progress. <p> The {@link #compare compare} and {@link commit commit} methods return when complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread. <p> If a commit that is being executed as an atomic transaction is canceled before it is completed, then the transaction is rolled back. The source and target views are left in the state they were in prior to the start of the commit.
canCommit | Determines whether or not this session can be committed in its current state. <p> Note that a session cannot be committed if there are unresolved conflicts, or if there are no changes to be merged. <p> Also, a compare-only session or any other read-only session cannot be committed.
close | Close this session, freeing its internal resources. <p> Closing a session that has not been persisted also deletes the associated temporary files on disk.
commit | Commits changes to the target view. <p> Note that this method returns when the commit is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
compare | Compares the source and target views. <p> Note that this method returns when the compare is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
connect | Connects a restored session to a server instance. <p> When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. <p> For example: <pre> Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . . </pre>
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
generateDifferenceReport | Overloaded. Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.
generateSummary
generateUpdateReport | Generates an update report for this session. This report lists items that were added, changed or removed when the session was committed. The report is in HTML format.
getApplicationObject | Gets an application-specific object associated with this session. The object, if provided, is saved and restored with the session data.
getDefaultComment | Gets the default comment to use for checkin operations that occur when committing this session.
getDifferences | Allows an application to iterate over the set of differences detected when comparing the source and target views.
getDifferencesForMergedItem | Gets the ItemDifference that corresponds to a given merge item. <p> The merged item may have been obtained through {@link ItemDifference#getMergeItem getMergeItem}, or it may have been obtained via the {@linkplain #getMergePreview merge preview}.
getDifferencesForSourceItem | Gets the ItemDifference that corresponds to a given source item.
getDifferencesForTargetItem | Gets the ItemDifference that corresponds to a given target item.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getItemTypes | Gets the item types that are to be included in the view compare/merge operation. If no item types have been specified, files and folders are included by default. Note that folders are always included.
getLockCount | Gets the number of source or target items that are currently locked on behalf of this session.
getMergePreview | Gets a preview of the merge results for this session. <p> The preview is a close approximation of what the target view would look like if the session were to be committed in its current state. <p> Since the preview is itself a view, it provides applications with a familiar way to browse and manipulate the difference information. For example, in order to manually resolve a file merge conflict, an application may use the ItemDifference directly: <pre> // Manually resolve a file merge conflict // through the ItemDifference. diff.setMergedFileContent(path); </pre> Alternatively, the application may choose to checkin the new content through the merge preview: <pre> // The merged item is accessible through the ItemDifference // and through the merge preview; they are physically the same. Item item = diff.getMergedItem(); // Checking in a new file revision also resolves the conflict. View preview = session.getMergePreview(); CheckinManager mgr = preview.createCheckinManager(); mgr.checkin((File)item, path); </pre>
getMergeType | Gets the merge type of this session.
getName | Gets the name of this session. The name is suitable, for example, as a file name.
getOptions | Gets the current set of options that influence the behavior of compare or merge operations. <p> An application may change individual settings in the Options object, and they will affect this session.
getPostCommitRevisionLabelName | Gets the name of the post-commit revision label. This label is attached only to items that are added or changed during the commit. It is attached to the item revision that is current after making the change. <p> Creation of the post-commit revision label is optional, and is disabled by default. To enable creation of the label, use {@link #setPostCommitRevisionLabelEnabled setPostCommitRevisionLabelEnabled}.
getPostCommitViewLabelName | Gets the name of the post-commit view label. This label shows the target view after the changes have been merged. The label is created at the start of the commit, and is updated as each change is merged to the target view. <p> Creation of the post-commit view label is optional, and is enabled by default. To disable creation of the label, use {@link #setPostCommitViewLabelEnabled setPostCommitViewLabelEnabled}.
getPreCommitRevisionLabelName | Gets the name of the pre-commit revision label. This label is attached only to items that are changed or removed during the commit. It is attached to the item revision that is current prior to making the change. <p> Creation of the pre-commit revision label is optional, and is disabled by default. To enable creation of the label, use {@link #setPreCommitRevisionLabelEnabled setPreCommitRevisionLabelEnabled}.
getPreCommitViewLabelName | Gets the name of the pre-commit view label. This label shows the target view just before any changes are merged. <p> Creation of the pre-commit view label is optional, and is disabled by default. To enable creation of the label, use {@link #setPreCommitViewLabelEnabled setPreCommitViewLabelEnabled}.
getProcessTask | Gets the process task created in the target view when this session was committed. The process task contains the process links to each file and folder revision that was created or modified as a result of the commit.
getProgress | Gets a snapshot of the state of the current compare or commit operation. Used for progress monitoring.
getRootDirectory | Gets the path to the temporary folder on disk used by this session.
getScope | Gets the current scope of this view compare/merge session.
getServer | Gets the server from which this session was constructed.
getServerInfo | Gets the ServerInfo associated with this session. For a disconnected session, the ServerInfo would have been read from a serialized stream.
getSessionState | Gets the current state of this session.
getSourceMatchesForTargetItems
getSourceMatchForTargetItem | Finds the source item that is the best match for the given target item. <p> The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchForTargetItem() may be used by an application that wants to define the scope starting with a target item. <p> To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.
getSourceView | Gets the source view associated with this session.
getSourceViewForCompare | Gets the version of the source view used for comparison. This is not always the same view that was used to create the session; it is typically a time-based snapshot, and may be populated with both active and deleted items.
getTargetView | Gets the target view associated with this session.
getTargetViewForCompare | Gets the version of the target view used for comparison. This is not always the same view that was used to create the session; it is typically a time-based snapshot.
GetType (inherited from Object) | Gets the Type of the current instance.
hasDifferences | Determines whether or not there were any differences detected when comparing the source and target views.
hasLocks | Determines whether any source or target items are currently locked on behalf of this session.
isCommitTransacted | Determines whether or not the commit operation is atomic. Commits are atomic by default when running against StarTeam Server 9.0 or later.
isDirty | Determines whether or not this session has been changed since it was last saved or restored.
isFullScope | Determines whether or not this session will perform a full-scope compare on the items of the given type.
isIncluded | Overloaded. Determines whether or not the given item type is included in this view compare/merge session.
isPartiallyCommitted | Determines whether or not this session was partially committed. <p> Partially committed sessions may occur when VCM commits are not transacted. If the commit fails in the middle (for example, due to insufficient access rights), then the session is left in a state where some of the differences have been merged to the target view and others have not. <p> A partially committed session may be saved, restored and re-committed. Previously committed differences will be skipped on subsequent commits.
isPostCommitRevisionLabelEnabled | Determines whether or not the post-commit revision label will be created. The post-commit revision label is disabled by default.
isPostCommitViewLabelEnabled | Determines whether or not the post-commit view label will be created. The post-commit view label is enabled by default.
isPreCommitRevisionLabelEnabled | Determines whether or not the pre-commit revision label will be created. The pre-commit revision label is disabled by default.
isPreCommitViewLabelEnabled | Determines whether or not the pre-commit view label will be created. The pre-commit view label is disabled by default.
isReadOnly | Determines whether this is a read-only session. <p> Compare-only sessions are read-only, as are sessions that have already been committed.
isVerbosePreview | Determines whether or not verbose preview mode is enabled. <p> In verbose preview mode, every ItemDifference has a corresponding item in the MergePreview. In cases where the item will not actually appear in the target view after the merge, the preview item is marked deleted. <p> For example, in the case of an ItemDifference where the default action is "Delete", the item will be removed from the target view when the merge is commited. Thus, the merged item for this ItemDifference would normally be null. However, in verbose mode, the merged item for this ItemDifference would be a deleted item, and the deleted item would appear in the merge preview.
MemberwiseClone
remove | Overloaded. Removes this session and any associated temporary files on disk.
removeLocks | Unlocks any source or target items that were locked on behalf of this session.
saveTo
setApplicationObject
setDefaultComment
setMatch
setOptions | Sets options that influence the behavior of compare or merge operations. <p> An application may also call {@link #getOptions getOptions}, and change individual settings in the Options instance that is returned.
setPostCommitRevisionLabelEnabled
setPostCommitRevisionLabelName
setPostCommitViewLabelEnabled
setPostCommitViewLabelName
setPreCommitRevisionLabelEnabled
setPreCommitRevisionLabelName
setPreCommitViewLabelEnabled
setPreCommitViewLabelName
setScope | Sets the scope of this view compare/merge session. <p> By default, all files and folders in the source view are compared against the corresponding target items. An application can change the scope so that specific items or types are included.
setVerbosePreview
ToString

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session Constructor

Overload List

public Session(MergeType,View,View);

public Session(MergeType,View,View,Options);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session Constructor (MergeType, View, View)

public Session(
MergeType mergeType,
View source,
View target
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace | Session Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session Constructor (MergeType, View, View, Options)

public Session(
MergeType mergeType,
View source,
View target,
Options options
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace | Session Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session Methods

The methods of the Session class are listed below. For a complete list of Session class members, see the Session Members topic.

Public Static Methods

getMatchHint |
remove | Overloaded. Remove the temporary folder tree associated with the specified session file.
resolve |
restoreFrom | Overloaded. Restores a saved session from a file. <p> When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. <p> For example: <pre> Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . . </pre>
setMatchHint |

Public Instance Methods

cancel | Cancels a compare or commit operation that is currently in progress. <p> The {@link #compare compare} and {@link commit commit} methods return when complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread. <p> If a commit that is being executed as an atomic transaction is canceled before it is completed, then the transaction is rolled back. The source and target views are left in the state they were in prior to the start of the commit.
canCommit | Determines whether or not this session can be committed in its current state. <p> Note that a session cannot be committed if there are unresolved conflicts, or if there are no changes to be merged. <p> Also, a compare-only session or any other read-only session cannot be committed.
close | Close this session, freeing its internal resources. <p> Closing a session that has not been persisted also deletes the associated temporary files on disk.
commit | Commits changes to the target view. <p> Note that this method returns when the commit is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
compare | Compares the source and target views. <p> Note that this method returns when the compare is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
connect | Connects a restored session to a server instance. <p> When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. <p> For example: <pre> Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . . </pre>
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
generateDifferenceReport | Overloaded. Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.
generateSummary
generateUpdateReport | Generates an update report for this session. This report lists items that were added, changed or removed when the session was committed. The report is in HTML format.
getApplicationObject | Gets an application-specific object associated with this session. The object, if provided, is saved and restored with the session data.
getDefaultComment | Gets the default comment to use for checkin operations that occur when committing this session.
getDifferences | Allows an application to iterate over the set of differences detected when comparing the source and target views.
getDifferencesForMergedItem | Gets the ItemDifference that corresponds to a given merge item. <p> The merged item may have been obtained through {@link ItemDifference#getMergeItem getMergeItem}, or it may have been obtained via the {@linkplain #getMergePreview merge preview}.
getDifferencesForSourceItem | Gets the ItemDifference that corresponds to a given source item.
getDifferencesForTargetItem | Gets the ItemDifference that corresponds to a given target item.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getItemTypes | Gets the item types that are to be included in the view compare/merge operation. If no item types have been specified, files and folders are included by default. Note that folders are always included.
getLockCount | Gets the number of source or target items that are currently locked on behalf of this session.
getMergePreview | Gets a preview of the merge results for this session. <p> The preview is a close approximation of what the target view would look like if the session were to be committed in its current state. <p> Since the preview is itself a view, it provides applications with a familiar way to browse and manipulate the difference information. For example, in order to manually resolve a file merge conflict, an application may use the ItemDifference directly: <pre> // Manually resolve a file merge conflict // through the ItemDifference. diff.setMergedFileContent(path); </pre> Alternatively, the application may choose to checkin the new content through the merge preview: <pre> // The merged item is accessible through the ItemDifference // and through the merge preview; they are physically the same. Item item = diff.getMergedItem(); // Checking in a new file revision also resolves the conflict. View preview = session.getMergePreview(); CheckinManager mgr = preview.createCheckinManager(); mgr.checkin((File)item, path); </pre>
getMergeType | Gets the merge type of this session.
getName | Gets the name of this session. The name is suitable, for example, as a file name.
getOptions | Gets the current set of options that influence the behavior of compare or merge operations. <p> An application may change individual settings in the Options object, and they will affect this session.
getPostCommitRevisionLabelName | Gets the name of the post-commit revision label. This label is attached only to items that are added or changed during the commit. It is attached to the item revision that is current after making the change. <p> Creation of the post-commit revision label is optional, and is disabled by default. To enable creation of the label, use {@link #setPostCommitRevisionLabelEnabled setPostCommitRevisionLabelEnabled}.
getPostCommitViewLabelName | Gets the name of the post-commit view label. This label shows the target view after the changes have been merged. The label is created at the start of the commit, and is updated as each change is merged to the target view. <p> Creation of the post-commit view label is optional, and is enabled by default. To disable creation of the label, use {@link #setPostCommitViewLabelEnabled setPostCommitViewLabelEnabled}.
getPreCommitRevisionLabelName | Gets the name of the pre-commit revision label. This label is attached only to items that are changed or removed during the commit. It is attached to the item revision that is current prior to making the change. <p> Creation of the pre-commit revision label is optional, and is disabled by default. To enable creation of the label, use {@link #setPreCommitRevisionLabelEnabled setPreCommitRevisionLabelEnabled}.
getPreCommitViewLabelName | Gets the name of the pre-commit view label. This label shows the target view just before any changes are merged. <p> Creation of the pre-commit view label is optional, and is disabled by default. To enable creation of the label, use {@link #setPreCommitViewLabelEnabled setPreCommitViewLabelEnabled}.
getProcessTask | Gets the process task created in the target view when this session was committed. The process task contains the process links to each file and folder revision that was created or modified as a result of the commit.
getProgress | Gets a snapshot of the state of the current compare or commit operation. Used for progress monitoring.
getRootDirectory | Gets the path to the temporary folder on disk used by this session.
getScope | Gets the current scope of this view compare/merge session.
getServer | Gets the server from which this session was constructed.
getServerInfo | Gets the ServerInfo associated with this session. For a disconnected session, the ServerInfo would have been read from a serialized stream.
getSessionState | Gets the current state of this session.
getSourceMatchesForTargetItems
getSourceMatchForTargetItem | Finds the source item that is the best match for the given target item. <p> The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchForTargetItem() may be used by an application that wants to define the scope starting with a target item. <p> To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.
getSourceView | Gets the source view associated with this session.
getSourceViewForCompare | Gets the version of the source view used for comparison. This is not always the same view that was used to create the session; it is typically a time-based snapshot, and may be populated with both active and deleted items.
getTargetView | Gets the target view associated with this session.
getTargetViewForCompare | Gets the version of the target view used for comparison. This is not always the same view that was used to create the session; it is typically a time-based snapshot.
GetType (inherited from Object) | Gets the Type of the current instance.
hasDifferences | Determines whether or not there were any differences detected when comparing the source and target views.
hasLocks | Determines whether any source or target items are currently locked on behalf of this session.
isCommitTransacted | Determines whether or not the commit operation is atomic. Commits are atomic by default when running against StarTeam Server 9.0 or later.
isDirty | Determines whether or not this session has been changed since it was last saved or restored.
isFullScope | Determines whether or not this session will perform a full-scope compare on the items of the given type.
isIncluded | Overloaded. Determines whether or not the given item type is included in this view compare/merge session.
isPartiallyCommitted | Determines whether or not this session was partially committed. <p> Partially committed sessions may occur when VCM commits are not transacted. If the commit fails in the middle (for example, due to insufficient access rights), then the session is left in a state where some of the differences have been merged to the target view and others have not. <p> A partially committed session may be saved, restored and re-committed. Previously committed differences will be skipped on subsequent commits.
isPostCommitRevisionLabelEnabled | Determines whether or not the post-commit revision label will be created. The post-commit revision label is disabled by default.
isPostCommitViewLabelEnabled | Determines whether or not the post-commit view label will be created. The post-commit view label is enabled by default.
isPreCommitRevisionLabelEnabled | Determines whether or not the pre-commit revision label will be created. The pre-commit revision label is disabled by default.
isPreCommitViewLabelEnabled | Determines whether or not the pre-commit view label will be created. The pre-commit view label is disabled by default.
isReadOnly | Determines whether this is a read-only session. <p> Compare-only sessions are read-only, as are sessions that have already been committed.
isVerbosePreview | Determines whether or not verbose preview mode is enabled. <p> In verbose preview mode, every ItemDifference has a corresponding item in the MergePreview. In cases where the item will not actually appear in the target view after the merge, the preview item is marked deleted. <p> For example, in the case of an ItemDifference where the default action is "Delete", the item will be removed from the target view when the merge is commited. Thus, the merged item for this ItemDifference would normally be null. However, in verbose mode, the merged item for this ItemDifference would be a deleted item, and the deleted item would appear in the merge preview.
MemberwiseClone
remove | Overloaded. Removes this session and any associated temporary files on disk.
removeLocks | Unlocks any source or target items that were locked on behalf of this session.
saveTo
setApplicationObject
setDefaultComment
setMatch
setOptions | Sets options that influence the behavior of compare or merge operations. <p> An application may also call {@link #getOptions getOptions}, and change individual settings in the Options instance that is returned.
setPostCommitRevisionLabelEnabled
setPostCommitRevisionLabelName
setPostCommitViewLabelEnabled
setPostCommitViewLabelName
setPreCommitRevisionLabelEnabled
setPreCommitRevisionLabelName
setPreCommitViewLabelEnabled
setPreCommitViewLabelName
setScope | Sets the scope of this view compare/merge session. <p> By default, all files and folders in the source view are compared against the corresponding target items. An application can change the scope so that specific items or types are included.
setVerbosePreview
ToString

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.cancel Method

Cancels a compare or commit operation that is currently in progress. <p> The {@link #compare compare} and {@link commit commit} methods return when complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread. <p> If a commit that is being executed as an atomic transaction is canceled before it is completed, then the transaction is rolled back. The source and target views are left in the state they were in prior to the start of the commit.

public virtual void cancel();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.canCommit Method

Determines whether or not this session can be committed in its current state. <p> Note that a session cannot be committed if there are unresolved conflicts, or if there are no changes to be merged. <p> Also, a compare-only session or any other read-only session cannot be committed.

public virtual bool canCommit();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.close Method

Close this session, freeing its internal resources. <p> Closing a session that has not been persisted also deletes the associated temporary files on disk.

public virtual void close();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.commit Method

Commits changes to the target view. <p> Note that this method returns when the commit is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.

public virtual void commit();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.compare Method

Compares the source and target views. <p> Note that this method returns when the compare is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.

public virtual void compare();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.connect Method

Connects a restored session to a server instance. <p> When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. <p> For example: <pre> Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . . </pre>

public virtual void connect(
Server server
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


generateDifferenceReport Method

Borland StarTeam SDK for .NET

Session.generateDifferenceReport Method

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

Overload List

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

public virtual void generateDifferenceReport(File);

public virtual void generateDifferenceReport(File,Boolean);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.generateDifferenceReport Method (File)

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

public virtual void generateDifferenceReport(
File reportFile
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace | Session.generateDifferenceReport Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.generateDifferenceReport Method (File, Boolean)

public virtual void generateDifferenceReport(
File reportFile,
Boolean bListItemsInMovedFolders
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace | Session.generateDifferenceReport Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.generateSummary Method

public virtual void generateSummary(
File reportFile,
Boolean bIncludeHeading
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.generateUpdateReport Method

Generates an update report for this session. This report lists items that were added, changed or removed when the session was committed. The report is in HTML format.

public virtual void generateUpdateReport(
File reportFile
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getApplicationObject Method

Gets an application-specific object associated with this session. The object, if provided, is saved and restored with the session data.

public virtual object getApplicationObject();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getDefaultComment Method

Gets the default comment to use for checkin operations that occur when committing this session.

public virtual string getDefaultComment();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getDifferences Method

Allows an application to iterate over the set of differences detected when comparing the source and target views.

public virtual DifferenceIterator getDifferences();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getDifferencesForMergedItem Method

Gets the ItemDifference that corresponds to a given merge item. <p> The merged item may have been obtained through {@link ItemDifference#getMergeItem getMergeItem}, or it may have been obtained via the {@linkplain #getMergePreview merge preview}.

public virtual ItemDifference getDifferencesForMergedItem(
Item item
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getDifferencesForSourceItem Method

Gets the ItemDifference that corresponds to a given source item.

public virtual ItemDifference getDifferencesForSourceItem(
Item item
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getDifferencesForTargetItem Method

Gets the ItemDifference that corresponds to a given target item.

public virtual ItemDifference getDifferencesForTargetItem(
Item item
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getItemTypes Method

Gets the item types that are to be included in the view compare/merge operation. If no item types have been specified, files and folders are included by default. Note that folders are always included.

public virtual Type[] getItemTypes();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getLockCount Method

Gets the number of source or target items that are currently locked on behalf of this session.

public virtual int getLockCount();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getMatchHint Method

public static Item getMatchHint(
Item source,
View target
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getMergePreview Method

Gets a preview of the merge results for this session. <p> The preview is a close approximation of what the target view would look like if the session were to be committed in its current state. <p> Since the preview is itself a view, it provides applications with a familiar way to browse and manipulate the difference information. For example, in order to manually resolve a file merge conflict, an application may use the ItemDifference directly: <pre> // Manually resolve a file merge conflict // through the ItemDifference. diff.setMergedFileContent(path); </pre> Alternatively, the application may choose to checkin the new content through the merge preview: <pre> // The merged item is accessible through the ItemDifference // and through the merge preview; they are physically the same. Item item = diff.getMergedItem(); // Checking in a new file revision also resolves the conflict. View preview = session.getMergePreview(); CheckinManager mgr = preview.createCheckinManager(); mgr.checkin((File)item, path); </pre>

public virtual View getMergePreview();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getMergeType Method

Gets the merge type of this session.

public virtual MergeType getMergeType();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getName Method

Gets the name of this session. The name is suitable, for example, as a file name.

public virtual string getName();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getOptions Method

Gets the current set of options that influence the behavior of compare or merge operations. <p> An application may change individual settings in the Options object, and they will affect this session.

public virtual Options getOptions();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getPostCommitRevisionLabelName Method

Gets the name of the post-commit revision label. This label is attached only to items that are added or changed during the commit. It is attached to the item revision that is current after making the change. <p> Creation of the post-commit revision label is optional, and is disabled by default. To enable creation of the label, use {@link #setPostCommitRevisionLabelEnabled setPostCommitRevisionLabelEnabled}.

public virtual string getPostCommitRevisionLabelName();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getPostCommitViewLabelName Method

Gets the name of the post-commit view label. This label shows the target view after the changes have been merged. The label is created at the start of the commit, and is updated as each change is merged to the target view. <p> Creation of the post-commit view label is optional, and is enabled by default. To disable creation of the label, use {@link #setPostCommitViewLabelEnabled setPostCommitViewLabelEnabled}.

public virtual string getPostCommitViewLabelName();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getPreCommitRevisionLabelName Method

Gets the name of the pre-commit revision label. This label is attached only to items that are changed or removed during the commit. It is attached to the item revision that is current prior to making the change. <p> Creation of the pre-commit revision label is optional, and is disabled by default. To enable creation of the label, use {@link #setPreCommitRevisionLabelEnabled setPreCommitRevisionLabelEnabled}.

public virtual string getPreCommitRevisionLabelName();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getPreCommitViewLabelName Method

Gets the name of the pre-commit view label. This label shows the target view just before any changes are merged. <p> Creation of the pre-commit view label is optional, and is disabled by default. To enable creation of the label, use {@link #setPreCommitViewLabelEnabled setPreCommitViewLabelEnabled}.

public virtual string getPreCommitViewLabelName();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getProcessTask Method

Gets the process task created in the target view when this session was committed. The process task contains the process links to each file and folder revision that was created or modified as a result of the commit.

public virtual Item getProcessTask();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getProgress Method

Gets a snapshot of the state of the current compare or commit operation. Used for progress monitoring.

public virtual Progress getProgress();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getRootDirectory Method

Gets the path to the temporary folder on disk used by this session.

public virtual string getRootDirectory();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getScope Method

Gets the current scope of this view compare/merge session.

public virtual Scope getScope();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getServer Method

Gets the server from which this session was constructed.

public virtual Server getServer();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getServerInfo Method

Gets the ServerInfo associated with this session. For a disconnected session, the ServerInfo would have been read from a serialized stream.

public virtual ServerInfo getServerInfo();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getSessionState Method

Gets the current state of this session.

public virtual SessionState getSessionState();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getSourceMatchesForTargetItems Method

public virtual Item[] getSourceMatchesForTargetItems(
Item[] targetItems
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getSourceMatchForTargetItem Method

Finds the source item that is the best match for the given target item. <p> The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchForTargetItem() may be used by an application that wants to define the scope starting with a target item. <p> To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.

public virtual Item getSourceMatchForTargetItem(
Item targetItem
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getSourceView Method

Gets the source view associated with this session.

public virtual View getSourceView();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getSourceViewForCompare Method

Gets the version of the source view used for comparison. This is not always the same view that was used to create the session; it is typically a time-based snapshot, and may be populated with both active and deleted items.

public virtual View getSourceViewForCompare();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getTargetView Method

Gets the target view associated with this session.

public virtual View getTargetView();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.getTargetViewForCompare Method

Gets the version of the target view used for comparison. This is not always the same view that was used to create the session; it is typically a time-based snapshot.

public virtual View getTargetViewForCompare();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.hasDifferences Method

Determines whether or not there were any differences detected when comparing the source and target views.

public virtual bool hasDifferences();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.hasLocks Method

Determines whether any source or target items are currently locked on behalf of this session.

public virtual bool hasLocks();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isCommitTransacted Method

Determines whether or not the commit operation is atomic. Commits are atomic by default when running against StarTeam Server 9.0 or later.

public virtual bool isCommitTransacted();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isDirty Method

Determines whether or not this session has been changed since it was last saved or restored.

public virtual bool isDirty();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isFullScope Method

Determines whether or not this session will perform a full-scope compare on the items of the given type.

public virtual bool isFullScope(
Type type
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


isIncluded Method

Borland StarTeam SDK for .NET

Session.isIncluded Method

Determines whether or not the given item is in scope for the current view compare/merge operation.

Overload List

Determines whether or not the given item is in scope for the current view compare/merge operation.

public virtual bool isIncluded(Item);

Determines whether or not the given item type is included in this view compare/merge session.

public virtual bool isIncluded(Type);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isIncluded Method (Item)

Determines whether or not the given item is in scope for the current view compare/merge operation.

public virtual bool isIncluded(
Item item
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace | Session.isIncluded Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isIncluded Method (Type)

Determines whether or not the given item type is included in this view compare/merge session.

public virtual bool isIncluded(
Type type
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace | Session.isIncluded Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isPartiallyCommitted Method

Determines whether or not this session was partially committed. <p> Partially committed sessions may occur when VCM commits are not transacted. If the commit fails in the middle (for example, due to insufficient access rights), then the session is left in a state where some of the differences have been merged to the target view and others have not. <p> A partially committed session may be saved, restored and re-committed. Previously committed differences will be skipped on subsequent commits.

public virtual bool isPartiallyCommitted();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isPostCommitRevisionLabelEnabled Method

Determines whether or not the post-commit revision label will be created. The post-commit revision label is disabled by default.

public virtual bool isPostCommitRevisionLabelEnabled();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isPostCommitViewLabelEnabled Method

Determines whether or not the post-commit view label will be created. The post-commit view label is enabled by default.

public virtual bool isPostCommitViewLabelEnabled();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isPreCommitRevisionLabelEnabled Method

Determines whether or not the pre-commit revision label will be created. The pre-commit revision label is disabled by default.

public virtual bool isPreCommitRevisionLabelEnabled();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isPreCommitViewLabelEnabled Method

Determines whether or not the pre-commit view label will be created. The pre-commit view label is disabled by default.

public virtual bool isPreCommitViewLabelEnabled();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isReadOnly Method

Determines whether this is a read-only session. <p> Compare-only sessions are read-only, as are sessions that have already been committed.

public virtual bool isReadOnly();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.isVerbosePreview Method

Determines whether or not verbose preview mode is enabled. <p> In verbose preview mode, every ItemDifference has a corresponding item in the MergePreview. In cases where the item will not actually appear in the target view after the merge, the preview item is marked deleted. <p> For example, in the case of an ItemDifference where the default action is "Delete", the item will be removed from the target view when the merge is commited. Thus, the merged item for this ItemDifference would normally be null. However, in verbose mode, the merged item for this ItemDifference would be a deleted item, and the deleted item would appear in the merge preview.

public virtual bool isVerbosePreview();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


remove Method

Borland StarTeam SDK for .NET

Session.remove Method

Removes this session and any associated temporary files on disk.

Overload List

Removes this session and any associated temporary files on disk.

public virtual void remove();

Remove the temporary folder tree associated with the specified session file.

public static void remove(File);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.remove Method ()

Removes this session and any associated temporary files on disk.

public virtual void remove();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace | Session.remove Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.remove Method (File)

Remove the temporary folder tree associated with the specified session file.

public static void remove(
File theSession
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace | Session.remove Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.removeLocks Method

Unlocks any source or target items that were locked on behalf of this session.

public virtual void removeLocks();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.resolve Method

public static Item[] resolve(
View target,
File file
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


restoreFrom Method

Borland StarTeam SDK for .NET

Session.restoreFrom Method

Restores a saved session from a file. <p> When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. <p> For example: <pre> Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . . </pre>

Overload List

Restores a saved session from a file. <p> When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. <p> For example: <pre> Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . . </pre>

public static Session restoreFrom(File);

public static Session restoreFrom(File,Boolean);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.restoreFrom Method (File)

Restores a saved session from a file. <p> When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. <p> For example: <pre> Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . . </pre>

public static Session restoreFrom(
File file
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace | Session.restoreFrom Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.restoreFrom Method (File, Boolean)

public static Session restoreFrom(
File file,
Boolean willPersist
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace | Session.restoreFrom Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.saveTo Method

public virtual void saveTo(
File file,
Boolean copyContent
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setApplicationObject Method

public virtual void setApplicationObject(
Object applicationObject
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setDefaultComment Method

public virtual void setDefaultComment(
String comment
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setMatch Method

public virtual void setMatch(
Item source,
Item target
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setMatchHint Method

public static void setMatchHint(
Item source,
Item target
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setOptions Method

Sets options that influence the behavior of compare or merge operations. <p> An application may also call {@link #getOptions getOptions}, and change individual settings in the Options instance that is returned.

public virtual void setOptions(
Options options
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setPostCommitRevisionLabelEnabled Method

public virtual void setPostCommitRevisionLabelEnabled(
Boolean isEnabled
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setPostCommitRevisionLabelName Method

public virtual void setPostCommitRevisionLabelName(
String name
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setPostCommitViewLabelEnabled Method

public virtual void setPostCommitViewLabelEnabled(
Boolean isEnabled
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setPostCommitViewLabelName Method

public virtual void setPostCommitViewLabelName(
String name
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setPreCommitRevisionLabelEnabled Method

public virtual void setPreCommitRevisionLabelEnabled(
Boolean isEnabled
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setPreCommitRevisionLabelName Method

public virtual void setPreCommitRevisionLabelName(
String name
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setPreCommitViewLabelEnabled Method

public virtual void setPreCommitViewLabelEnabled(
Boolean isEnabled
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setPreCommitViewLabelName Method

public virtual void setPreCommitViewLabelName(
String name
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setScope Method

Sets the scope of this view compare/merge session. <p> By default, all files and folders in the source view are compared against the corresponding target items. An application can change the scope so that specific items or types are included.

public virtual void setScope(
Scope s
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.setVerbosePreview Method

public virtual void setVerbosePreview(
Boolean verbose
);

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Session.ToString Method

public override string ToString();

See Also

Session Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState Class

For a list of all members of this type, see SessionState Members.

System.Object
SessionState

public class SessionState

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SessionState Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState Members

SessionState overview

Public Static Fields

CLOSED
COMMITTED
COMPARED
CONNECTED
DISCONNECTED

Public Instance Methods

equals | returns true if the two SessionStates represent the same state
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName | Returns the name of this session state as a string.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState Fields

The fields of the SessionState class are listed below. For a complete list of SessionState class members, see the SessionState Members topic.

Public Static Fields

CLOSED
COMMITTED
COMPARED
CONNECTED
DISCONNECTED

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState.CLOSED Field

public static readonly SessionState CLOSED;

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState.COMMITTED Field

public static readonly SessionState COMMITTED;

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState.COMPARED Field

public static readonly SessionState COMPARED;

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState.CONNECTED Field

public static readonly SessionState CONNECTED;

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState.DISCONNECTED Field

public static readonly SessionState DISCONNECTED;

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState Methods

The methods of the SessionState class are listed below. For a complete list of SessionState class members, see the SessionState Members topic.

Public Instance Methods

equals | returns true if the two SessionStates represent the same state
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getName | Returns the name of this session state as a string.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState.equals Method

returns true if the two SessionStates represent the same state

public virtual bool equals(
SessionState theOther
);

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState.getName Method

Returns the name of this session state as a string.

public virtual string getName();

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState.MemberwiseClone Method

public override object MemberwiseClone();

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SessionState.ToString Method

public override string ToString();

See Also

SessionState Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFileMergeAdapter Class

For a list of all members of this type, see StarTeamFileMergeAdapter Members.

System.Object
FileMergeAdapter
StarTeamFileMergeAdapter

public class StarTeamFileMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

StarTeamFileMergeAdapter Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFileMergeAdapter Members

StarTeamFileMergeAdapter overview

Public Instance Constructors

StarTeamFileMergeAdapter Constructor Constructs a VisMerge adapter for resolving a given file merge condition.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAutoMergeLinesWithNoConflicts | Determines whether or not changed lines with no conflicts will be merged automatically.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileMergeAdapter) |
merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. <p> If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. <p> Any temporary files created during the process are automatically removed.
setAutoMergeLinesWithNoConflicts |
ToString (inherited from FileMergeAdapter) |

See Also

StarTeamFileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFileMergeAdapter Constructor

Constructs a VisMerge adapter for resolving a given file merge condition.

public StarTeamFileMergeAdapter(
ItemDifference diff
);

See Also

StarTeamFileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFileMergeAdapter Methods

The methods of the StarTeamFileMergeAdapter class are listed below. For a complete list of StarTeamFileMergeAdapter class members, see the StarTeamFileMergeAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAutoMergeLinesWithNoConflicts | Determines whether or not changed lines with no conflicts will be merged automatically.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileMergeAdapter) |
merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. <p> If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. <p> Any temporary files created during the process are automatically removed.
setAutoMergeLinesWithNoConflicts |
ToString (inherited from FileMergeAdapter) |

See Also

StarTeamFileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFileMergeAdapter.getAutoMergeLinesWithNoConflicts Method

Determines whether or not changed lines with no conflicts will be merged automatically.

public virtual bool getAutoMergeLinesWithNoConflicts();

See Also

StarTeamFileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StarTeamFileMergeAdapter.setAutoMergeLinesWithNoConflicts Method

public virtual void setAutoMergeLinesWithNoConflicts(
Boolean bAutoMerge
);

See Also

StarTeamFileMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VCMFolder Class

For a list of all members of this type, see VCMFolder Members.

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Item
Folder
VCMFolder

public class VCMFolder : Folder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

VCMFolder Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VCMFolder Members

VCMFolder overview

Public Instance Methods

acquireOwnership (inherited from Item)
add (inherited from Folder) | Obsolete. Adds the specified item to this folder. The added item will still exist in its original folder as well as in this one.
addAttachment (inherited from Item)
addFolderListener (inherited from Folder)
addFolderUpdateListener (inherited from Folder)
addItemListener (inherited from Folder) | Overloaded.
addItemUpdateListener (inherited from Folder)
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy (inherited from Folder)
copyFolderTree (inherited from Folder) | Copies a folder tree. Does not populate any properties or copy any cached items.
countItems (inherited from Folder)
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
discardItems (inherited from Folder)
enumerateItems (inherited from Folder)
Equals (inherited from Folder)
get (inherited from Item)
getACL (inherited from Folder)
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAlternatePathFragment (inherited from Folder) | Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getCaseSensitiveFileNames (inherited from Folder) | Returns true if the names of files in this folder are case sensitive.
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getContainerLevelACL (inherited from Folder)
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDefaultPathFragment (inherited from Folder) | Returns this folder's specified default working path. This is the <code>FOLDER_WORKING_FOLDER</code> property associated with this folder. The folder's fully resolved location on disk may use this value along with the values for all of its parent folders.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDescription (inherited from Folder) | Returns the description of this folder.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Folder)
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getExcludeFlags (inherited from Folder) | Returns an <code>int</code> representing the method by which the exclude list is determined.
getExcludeList (inherited from Folder) | Returns the portion of the exclude list that this folder contributes. Use resolveExcludeList to get the full exclude list which may include specifications inherited from the parent folder.
getFileEOL (inherited from Folder) | Returns the end-of-line character sequence to be used for text files in this folder.
getFilePath (inherited from Folder)
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFolderHierarchy (inherited from Folder) | Gets the fully-qualified name of this folder. The names of this folder and all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getFolderTree (inherited from Folder)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode (inherited from Folder)
getHistory (inherited from Folder)
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getItems (inherited from Folder)
getList (inherited from Folder)
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getName (inherited from Folder) | Returns the name of the folder.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getNotInViewFiles (inherited from Folder) | Returns an array of "not in view" File objects in this Folder, applying exclusions as appropriate.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Folder)
getParentFolder (inherited from Folder)
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPath (inherited from Folder) | Returns the local working file path being used for this folder. This path is the concatenation of either the default path fragment or the alternate path fragment with the path of this folder's parent folder or the path of the view if this folder has no parent. A non-null alternate path fragment takes precedence over a default path fragment.
getPathFragment (inherited from Folder) | Return the path fragment to use for this folder. If an alternate path fragment is set then it will be used instead of the default path fragment.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPreviewState | Returns the preview state of this folder, which is an aggregate of the states of the constituent elements (items & sub-folders) of this folder
getPropertyNames (inherited from Item)
getQualifiedName (inherited from Folder) | Gets the fully-qualified name of this folder. The names of this folder and all parent folders up to the root are included, separated by the backslash character ("\") on all platforms. There is no terminating backslash.
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getString (inherited from Item)
getSubFolderCount (inherited from Folder) | Returns the number of sub folders for this folder.
getSubFolders (inherited from Folder) | Returns the subfolders of this folder. Will not return null but may return an empty array if the folder has no subfolders.
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getUserVisible (inherited from Folder) | Returns true if items in this folder should be visible to the user. Typically, a UI should not display the items in an invisible folder. The value for this folder may have been set upon opening a view based on client settings.
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasParentFolder (inherited from Folder) | Returns true if this folder has a parent folder.
hasPermission (inherited from Folder) | Overloaded.
hasPermission (inherited from Item) | Overloaded.
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Folder)
isExcluded (inherited from Folder)
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isPopulated (inherited from Folder)
isRefreshItemsRequired (inherited from Folder)
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move (inherited from Folder) | Obsolete.
moveTo (inherited from Folder)
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
populateAsNeeded (inherited from Folder) | Obsolete.
populateInBackground (inherited from Folder)
populateNow (inherited from Folder)
put (inherited from Folder)
putByPropertyID (inherited from Folder)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
refreshForeignFiles (inherited from Folder)
refreshItems (inherited from Folder)
remove (inherited from Folder)
removeAttachment (inherited from Item)
removeFolderListener (inherited from Folder)
removeFolderUpdateListener (inherited from Folder)
removeFromIntArray (inherited from TypedResource)
removeItemListener (inherited from Folder)
removeItemUpdateListener (inherited from Folder)
resolveExcludeList (inherited from Folder) | Returns the fully resolved exclude list. This may be the catenation of this folder's exclude list with its parent exclude list depending on the exclude list types.
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
resolveUserVisible (inherited from Folder) | Returns false if this folder or any parent is set to be not visible.
reverseShareTo (inherited from Folder) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
reverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Folder)
setAlternatePathFragment (inherited from Folder)
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setContainerLevelACL (inherited from Folder)
setDefaultPathFragment (inherited from Folder)
setDescription (inherited from Folder)
setExcludeFlags (inherited from Folder)
setExcludeList (inherited from Folder)
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setName (inherited from Folder)
setUserVisible (inherited from Folder)
shareTo (inherited from Folder) | Overloaded.
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString (inherited from Folder)
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update (inherited from Folder)
updateFolderTree (inherited from Folder)
updateRevisionComment (inherited from Item)

See Also

VCMFolder Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VCMFolder Methods

The methods of the VCMFolder class are listed below. For a complete list of VCMFolder class members, see the VCMFolder Members topic.

Public Instance Methods

acquireOwnership (inherited from Item)
add (inherited from Folder) | Obsolete. Adds the specified item to this folder. The added item will still exist in its original folder as well as in this one.
addAttachment (inherited from Item)
addFolderListener (inherited from Folder)
addFolderUpdateListener (inherited from Folder)
addItemListener (inherited from Folder) | Overloaded.
addItemUpdateListener (inherited from Folder)
addToIntArray (inherited from TypedResource)
Clone (inherited from CacheRef)
copy (inherited from Folder)
copyFolderTree (inherited from Folder) | Copies a folder tree. Does not populate any properties or copy any cached items.
countItems (inherited from Folder)
createAttachment (inherited from Item)
createAttachmentFromFile (inherited from Item)
deleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
discard (inherited from Item) | Discards all of the cached properties for this Item. They will be re-fetched from the server on demand (even when MPX is enabled). <p> If the properties of an Item are changed, and discard() is called without first calling update(), the changes will be lost.
discardItems (inherited from Folder)
enumerateItems (inherited from Folder)
Equals (inherited from Folder)
get (inherited from Item)
getACL (inherited from Folder)
getAllLabels (inherited from Item) | Returns all labels attached to any version of this item. This includes both view labels and revision labels.
getAlternatePathFragment (inherited from Folder) | Returns the alternate working file path to be used for this view. This is the value stored client-side as an override to the default path.
getAttachedLabels (inherited from Item) | Returns labels attached to any version of this item. This includes both view labels and revision labels but does not include any deleted labels. The getAllLabels method may return deleted labels. This method is generally to be prefered over getAllLabels.
getAttachment (inherited from Item)
getAttachmentIDs (inherited from Item) | Returns the attachment IDs for this item. If the item type does not support attachments (for example, File) then an exception will be thrown. To obtain the actual attachment you must call one of the getAttachment methods.
getAttachmentNames (inherited from Item) | Returns the attachment names for this item. If the item type does not support attachments (for example, File) then an exception will be thrown.
getAttachmentToFile (inherited from Item)
getBehavior (inherited from Item) | Returns ItemBehavior object associated with this Item.
getByProperty (inherited from Item) | Returns the value of the specified property. Retrieves value from persistent store if not already cached.
getByPropertyID (inherited from Item)
getByteArray (inherited from Item)
getCachedProperties (inherited from Item) | Returns an array of Properties whose values are cached locally, i.e either retrieved from persistent store or set by the client
getCaseSensitiveFileNames (inherited from Folder) | Returns true if the names of files in this folder are case sensitive.
getComment (inherited from Item) | Returns the comment describing this revision of the item.
getCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
getContainerLevelACL (inherited from Folder)
getCreatedBy (inherited from Item) | Returns the user ID of the user that created the first revision of the item.
getCreatedTime (inherited from Item) | Returns the time at which the first revision of the item was created.
getDefaultPathFragment (inherited from Folder) | Returns this folder's specified default working path. This is the <code>FOLDER_WORKING_FOLDER</code> property associated with this folder. The folder's fully resolved location on disk may use this value along with the values for all of its parent folders.
getDeletedTime (inherited from Item) | For deleted items, returns the time the item was deleted. For other items, returns DateTimeProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDeletedUserID (inherited from Item) | For deleted items, returns the UserID of the user who deleted the item. For other items, returns ObjectProperty.VALUE_NOT_SET. <p> Note that this method is supported for StarTeam Server 9.0 or later.
getDescription (inherited from Folder) | Returns the description of this folder.
getDisplayValue (inherited from Item) | Gets the value of a property in a form suitable for display.
getDotNotation (inherited from Folder)
getDouble (inherited from Item)
getEnumDisplayName (inherited from Item)
getExcludeFlags (inherited from Folder) | Returns an <code>int</code> representing the method by which the exclude list is determined.
getExcludeList (inherited from Folder) | Returns the portion of the exclude list that this folder contributes. Use resolveExcludeList to get the full exclude list which may include specifications inherited from the parent folder.
getFileEOL (inherited from Folder) | Returns the end-of-line character sequence to be used for text files in this folder.
getFilePath (inherited from Folder)
getFlag (inherited from Item) | Returns whether or not this item is "flagged" for the currently logged in user. You can consider a flag to be like a bookmark.
getFlagDisplayName (inherited from Item)
getFolderHierarchy (inherited from Folder) | Gets the fully-qualified name of this folder. The names of this folder and all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getFolderTree (inherited from Folder)
getFromHistoryByDate (inherited from Item) | Returns the most recent version of this item as of the specified date. Returns <code>null</code> if a version is not found that existed as of the given date.
getFromHistoryByLabelID (inherited from Item)
getFromHistoryByVersion (inherited from Item)
GetHashCode (inherited from Folder)
getHistory (inherited from Folder)
getID (inherited from Item)
getInt (inherited from Item)
getIntArray (inherited from Item)
getItemID (inherited from Item) | Returns an identifier representing this item, that is, the underlying entity represented by this item in this specific context. This ID is different for each instance of one entity shared in two locations. For instance, a file "foo" is shared between the "source" folder and the "include" folder. Calling this method on the item "foo" contained in folder "source" yields a different ID than calling it on the item "foo" contained in folder "include". Therefore, this ID is not appropriately used as an identifier of the entity itself, rather it identifies an occurence of the entity in a view.
getItemRevisions (inherited from Item) | Returns the Item revisions for this item. The revisions are based on the specific historical revisions identified by this item using getObjectID() and the ViewConfiguration of the view to which it belongs.
getItems (inherited from Folder)
getList (inherited from Folder)
getLocker (inherited from Item) | Returns the user ID of the user that has this item exclusively locked, or -1 if no one has it locked.
getMergeHistory (inherited from Item) | Returns the merge points for this item.
getModifiedBy (inherited from Item) | Returns the user ID of the user that created this revision of the item.
getModifiedTime (inherited from Item) | Returns the time at which this revision of the item was created.
getMyLock (inherited from Item) | Returns the lock status of this item for the currently logged in user. It will be one of exclusive, non-exclusive, or none.
getName (inherited from Folder) | Returns the name of the folder.
getNewRevisionComment (inherited from Item) | Returns the empty string. Added only because the property is used for the Win32 client and might show up in a query or filter definition.
getNotInViewFiles (inherited from Folder) | Returns an array of "not in view" File objects in this Folder, applying exclusions as appropriate.
getObjectID (inherited from Item) | Returns the object ID property for this item.
getOLEDate (inherited from Item)
getOwner (inherited from Item)
getParentContainer (inherited from Folder)
getParentFolder (inherited from Folder)
getParentFolderHierarchy (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by and terminated with the platform-specific path separator character.
getParentFolderName (inherited from Item) | Returns the name of the item's parent folder.
getParentFolderPath (inherited from Item) | Returns the working directory path for the item's parent folder.
getParentFolderQualifiedName (inherited from Item) | Gets the fully-qualified name of this item's parent folder. The names of all parent folders up to the root are included, separated by the backslash character on all platforms. There is no terminating backslash. This is the same format used for the "Folder Path" property.
getParentRevision (inherited from Item) | Returns the revision number at which this item was branched. For example, if this number is 8, then the item's revision number in the parent view was 8 at the time the item was branched. The history would then show that revision 9 was the first revision in the current view. The ParentRevision is zero if this item was not inherited from the parent view.
getPath (inherited from Folder) | Returns the local working file path being used for this folder. This path is the concatenation of either the default path fragment or the alternate path fragment with the path of this folder's parent folder or the path of the view if this folder has no parent. A non-null alternate path fragment takes precedence over a default path fragment.
getPathFragment (inherited from Folder) | Return the path fragment to use for this folder. If an alternate path fragment is set then it will be used instead of the default path fragment.
getPossibleFlag (inherited from Item) | Returns the possible enum codes that are valid values for the "Flag" property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleReadStatus (inherited from Item) | Returns the possible enum codes that are valid values for the ReadStatus property. This is really a convenience method for accessing Property.getEnumValues for this property.
getPossibleValues (inherited from Item)
getPreviewState | Returns the preview state of this folder, which is an aggregate of the states of the constituent elements (items & sub-folders) of this folder
getPropertyNames (inherited from Item)
getQualifiedName (inherited from Folder) | Gets the fully-qualified name of this folder. The names of this folder and all parent folders up to the root are included, separated by the backslash character ("\") on all platforms. There is no terminating backslash.
getReadStatus (inherited from Item) | A flag indicating whether or not the user has read this item before. It is not supported for File objects.
getReadStatusDisplayName (inherited from Item)
getReference (inherited from Item) | Returns the Item reference for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the ItemReference that is returned is "disembodied", containing no information about its parent or children.
getReferences (inherited from Item) | Returns the Item references for this item. The references are based on the specific historical revision identified by this item using getObjectID() and getRevisionNumber().
getRevisionNumber (inherited from Item) | Returns the branch revision number for this item revision. The first revision in a branch starts with 0 (not 1).
getRootObjectID (inherited from Item) | Returns the root object ID property for this item. All items with the same root object ID were all derived from the same original item object. Item revisions with the same object ID are all on the same branch.
getServer (inherited from Item) | Returns the server object to which this item belongs.
getString (inherited from Item)
getSubFolderCount (inherited from Folder) | Returns the number of sub folders for this folder.
getSubFolders (inherited from Folder) | Returns the subfolders of this folder. Will not return null but may return an empty array if the folder has no subfolders.
getType (inherited from Item)
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNames (inherited from Item)
getUserVisible (inherited from Folder) | Returns true if items in this folder should be visible to the user. Typically, a UI should not display the items in an invisible folder. The value for this folder may have been set upon opening a view based on client settings.
getView (inherited from Item) | Returns the <code>View</code> in which this item exists. For a disembodied item this will be the View from which the Item was obtained and may not be the actual view in which the item exists.
getViewVersion (inherited from Item) | The version number of this item calculated by counting direct ancestors of this item from this version to the initial version. The first revision will have a view version number of (1).
hasParentFolder (inherited from Folder) | Returns true if this folder has a parent folder.
hasPermission (inherited from Folder) | Overloaded.
hasPermission (inherited from Item) | Overloaded.
hasValues (inherited from Item)
isBranchable (inherited from Item) | Returns true if this item is a type that is branchable.
isDeleted (inherited from Item) | Determines whether or not this item has been deleted. <p> As of StarTeam 9.0, we can determine from an Item's properties whether or not it has been deleted. In older servers, we can only tell whether the remove() method was called on this Item.
isDirty (inherited from Item) | Returns <code>true</code> if any property has been modified from the original value (including properties set on new items). Modified properties are saved by a call to update().
isDisembodied (inherited from Item) | A disembodied Item is one which does not have its full View and Folder context. Consequently many Item operations are not supported. It is possible to get and set Item property values as well as get Item history for a disembodied item. The most common way to obtain a disembodied Item is through the Link APIs or the View methods getDisembodiedItem and getHistoryForItemID.
isEqualTo (inherited from Folder)
isExcluded (inherited from Folder)
isFromHistory (inherited from Item) | Determines whether or not this is a historical item obtained from the history.
isNew (inherited from Item) | Returns true if this item has not yet been stored in the server.
isPopulated (inherited from Folder)
isRefreshItemsRequired (inherited from Folder)
isRefreshRequired (inherited from Item) | Overloaded. Returns true if a refresh() operation might have resulted in any Item properties being updated; returns false if and only if it is known that the Item properties had not been changed since the last refresh. If MPX is not enabled, then isRefreshRequired() always returns true.
isReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
isRootShare (inherited from Item) | Determines whether or not this item is the root share of its share tree.
lock (inherited from Item) | Obtains an exclusive lock on this item without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
MemberwiseClone (inherited from CacheRef)
modifyFlagForUser (inherited from Item)
modifyReadStatusForUser (inherited from Item)
move (inherited from Folder) | Obsolete.
moveTo (inherited from Folder)
populate (inherited from Item) | Overloaded. Ensures that all item properties have been populated. Does not ensure that the properties are up-to-date with respect to the latest information on the server.
populateAsNeeded (inherited from Folder) | Obsolete.
populateInBackground (inherited from Folder)
populateNow (inherited from Folder)
put (inherited from Folder)
putByPropertyID (inherited from Folder)
putLock (inherited from Item)
recordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
refresh (inherited from Item) | Overloaded. Updates cached properties to reflect recent changes made on the server. All properties are refreshed. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
refreshForeignFiles (inherited from Folder)
refreshItems (inherited from Folder)
remove (inherited from Folder)
removeAttachment (inherited from Item)
removeFolderListener (inherited from Folder)
removeFolderUpdateListener (inherited from Folder)
removeFromIntArray (inherited from TypedResource)
removeItemListener (inherited from Folder)
removeItemUpdateListener (inherited from Folder)
resolveExcludeList (inherited from Folder) | Returns the fully resolved exclude list. This may be the catenation of this folder's exclude list with its parent exclude list depending on the exclude list types.
resolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same respoitory as this item.
resolveUserVisible (inherited from Folder) | Returns false if this folder or any parent is set to be not visible.
reverseShareTo (inherited from Folder) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
reverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. <p> In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. <p> When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. <p> Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
setACL (inherited from Folder)
setAlternatePathFragment (inherited from Folder)
setBehavior (inherited from Item) | Changes the behavior of this item. The change is saved to the repository immediately; no call to update() is required.
setBranchOnChange (inherited from Item)
setComment (inherited from Item)
setContainerLevelACL (inherited from Folder)
setDefaultPathFragment (inherited from Folder)
setDescription (inherited from Folder)
setExcludeFlags (inherited from Folder)
setExcludeList (inherited from Folder)
setFixedConfig (inherited from Item) | Changes the behavior of this item such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
setFloatingConfig (inherited from Item) | Changes the behavior of this item to "floating". The change is saved to the repository immediately; no call to update() is required.
setName (inherited from Folder)
setUserVisible (inherited from Folder)
shareTo (inherited from Folder) | Overloaded.
smartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
toDebugString (inherited from Item) | Returns a <code>String</code> that is potentially useful while debugging.
ToString (inherited from Folder)
unlock (inherited from Item) | Removes the current user's lock from this item. If another user has an exclusive lock on the item this method will not remove that lock.
update (inherited from Folder)
updateFolderTree (inherited from Folder)
updateRevisionComment (inherited from Item)

See Also

VCMFolder Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VCMFolder.getPreviewState Method

Returns the preview state of this folder, which is an aggregate of the states of the constituent elements (items & sub-folders) of this folder

public virtual PreviewState getPreviewState(
Type type
);

See Also

VCMFolder Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VisMergeAdapter Class

For a list of all members of this type, see VisMergeAdapter Members.

System.Object
FileMergeAdapter
VisMergeAdapter

public class VisMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

VisMergeAdapter Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VisMergeAdapter Members

VisMergeAdapter overview

Public Instance Constructors

VisMergeAdapter Constructor Constructs a VisMerge adapter for resolving a given file merge condition.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAutoMergeLinesWithNoConflicts | Determines whether or not changed lines with no conflicts will be merged automatically.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getIgnoreWhiteSpace | Determines whether or not changed lines with no conflicts will be merged automatically.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileMergeAdapter) |
merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. <p> If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. <p> Any temporary files created during the process are automatically removed.
setAutoMergeLinesWithNoConflicts |
setIgnoreWhiteSpace |
ToString (inherited from FileMergeAdapter) |

See Also

VisMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VisMergeAdapter Constructor

Constructs a VisMerge adapter for resolving a given file merge condition.

public VisMergeAdapter(
ItemDifference diff
);

See Also

VisMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VisMergeAdapter Methods

The methods of the VisMergeAdapter class are listed below. For a complete list of VisMergeAdapter class members, see the VisMergeAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getAutoMergeLinesWithNoConflicts | Determines whether or not changed lines with no conflicts will be merged automatically.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getIgnoreWhiteSpace | Determines whether or not changed lines with no conflicts will be merged automatically.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileMergeAdapter) |
merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. <p> If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. <p> Any temporary files created during the process are automatically removed.
setAutoMergeLinesWithNoConflicts |
setIgnoreWhiteSpace |
ToString (inherited from FileMergeAdapter) |

See Also

VisMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VisMergeAdapter.getAutoMergeLinesWithNoConflicts Method

Determines whether or not changed lines with no conflicts will be merged automatically.

public virtual bool getAutoMergeLinesWithNoConflicts();

See Also

VisMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VisMergeAdapter.getIgnoreWhiteSpace Method

Determines whether or not changed lines with no conflicts will be merged automatically.

public virtual bool getIgnoreWhiteSpace();

See Also

VisMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VisMergeAdapter.setAutoMergeLinesWithNoConflicts Method

public virtual void setAutoMergeLinesWithNoConflicts(
Boolean bAutoMerge
);

See Also

VisMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


VisMergeAdapter.setIgnoreWhiteSpace Method

public virtual void setIgnoreWhiteSpace(
Boolean bIgnore
);

See Also

VisMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkstationDefaultMergeAdapter Class

For a list of all members of this type, see WorkstationDefaultMergeAdapter Members.

System.Object
FileMergeAdapter
WorkstationDefaultMergeAdapter

public class WorkstationDefaultMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.viewcomparemerge

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

WorkstationDefaultMergeAdapter Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkstationDefaultMergeAdapter Members

WorkstationDefaultMergeAdapter overview

Public Instance Constructors

WorkstationDefaultMergeAdapter Constructor Constructs an adapter for resolving a given file merge condition.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileMergeAdapter) |
merge |
ToString (inherited from FileMergeAdapter) |

See Also

WorkstationDefaultMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkstationDefaultMergeAdapter Constructor

Constructs an adapter for resolving a given file merge condition.

public WorkstationDefaultMergeAdapter(
ItemDifference diff
);

See Also

WorkstationDefaultMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkstationDefaultMergeAdapter Methods

The methods of the WorkstationDefaultMergeAdapter class are listed below. For a complete list of WorkstationDefaultMergeAdapter class members, see the WorkstationDefaultMergeAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from FileMergeAdapter) |
merge |
ToString (inherited from FileMergeAdapter) |

See Also

WorkstationDefaultMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkstationDefaultMergeAdapter.merge Method

public override int merge();

See Also

WorkstationDefaultMergeAdapter Class | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


com.starbase.starteam.vts.comm

Borland StarTeam SDK for .NET

com.starbase.starteam.vts.comm Namespace

Namespace hierarchy

Classes

Class | Description
CommandException |
ConnectionException |
EncryptionAlgorithm |
NetMonitor |
ServerCommandAdapter |
ServerCommandEvent |
SystemRevisionNumbers |

Interfaces

Interface | Description
ServerCommandListener |


CommandException Class

For a list of all members of this type, see CommandException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
CommandException
ConnectionException

public class CommandException : RuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.vts.comm

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

CommandException Members | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandException Members

CommandException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getIOException |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString |
unwrap |

See Also

CommandException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandException Methods

The methods of the CommandException class are listed below. For a complete list of CommandException class members, see the CommandException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getIOException |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString |
unwrap |

See Also

CommandException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandException.Equals Method

public override bool Equals(
Object source
);

See Also

CommandException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandException.GetHashCode Method

public override int GetHashCode();

See Also

CommandException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandException.getIOException Method

public virtual IOException getIOException();

See Also

CommandException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandException.getMessage Method

public override string getMessage();

See Also

CommandException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

CommandException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandException.ToString Method

public override string ToString();

See Also

CommandException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandException.unwrap Method

public virtual CommandException unwrap();

See Also

CommandException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CommandException.wrap Method

public static CommandException wrap(
CommandException arg
);

See Also

CommandException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConnectionException Class

For a list of all members of this type, see ConnectionException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
CommandException
ConnectionException

public class ConnectionException : CommandException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.vts.comm

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ConnectionException Members | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConnectionException Members

ConnectionException overview

Public Static Methods

wrap

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

addReconnectException |
Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getIOException (inherited from CommandException) |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from CommandException) |
GetObjectData (inherited from java.lang.Throwable) |
getReconnectAttemptCount |
getReconnectExceptions |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone (inherited from CommandException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from CommandException) |
unwrap (inherited from CommandException) |

See Also

ConnectionException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConnectionException Methods

The methods of the ConnectionException class are listed below. For a complete list of ConnectionException class members, see the ConnectionException Members topic.

Public Static Methods

wrap

Public Instance Methods

addReconnectException |
Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getIOException (inherited from CommandException) |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from CommandException) |
GetObjectData (inherited from java.lang.Throwable) |
getReconnectAttemptCount |
getReconnectExceptions |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone (inherited from CommandException) |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from CommandException) |
unwrap (inherited from CommandException) |

See Also

ConnectionException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConnectionException.addReconnectException Method

public virtual void addReconnectException(
IOException e
);

See Also

ConnectionException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConnectionException.Equals Method

public override bool Equals(
Object source
);

See Also

ConnectionException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConnectionException.GetHashCode Method

public override int GetHashCode();

See Also

ConnectionException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConnectionException.getReconnectAttemptCount Method

public virtual int getReconnectAttemptCount();

See Also

ConnectionException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConnectionException.getReconnectExceptions Method

public virtual IOException[] getReconnectExceptions();

See Also

ConnectionException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ConnectionException.wrap Method

public static ConnectionException wrap(
ConnectionException arg
);

See Also

ConnectionException Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm Class

For a list of all members of this type, see EncryptionAlgorithm Members.

System.Object
EncryptionAlgorithm

public class EncryptionAlgorithm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.vts.comm

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

EncryptionAlgorithm Members | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm Members

EncryptionAlgorithm overview

Public Static Fields

NULL
RC2_CBC
RC2_CFB
RC2_ECB
RC4

Public Static Methods

maxSecurity

Public Instance Methods

Equals |
getDisplayName |
GetHashCode |
getName |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm Fields

The fields of the EncryptionAlgorithm class are listed below. For a complete list of EncryptionAlgorithm class members, see the EncryptionAlgorithm Members topic.

Public Static Fields

NULL
RC2_CBC
RC2_CFB
RC2_ECB
RC4

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.NULL Field

public static readonly EncryptionAlgorithm NULL;

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.RC2_CBC Field

public static readonly EncryptionAlgorithm RC2_CBC;

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.RC2_CFB Field

public static readonly EncryptionAlgorithm RC2_CFB;

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.RC2_ECB Field

public static readonly EncryptionAlgorithm RC2_ECB;

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.RC4 Field

public static readonly EncryptionAlgorithm RC4;

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm Methods

The methods of the EncryptionAlgorithm class are listed below. For a complete list of EncryptionAlgorithm class members, see the EncryptionAlgorithm Members topic.

Public Static Methods

maxSecurity

Public Instance Methods

Equals |
getDisplayName |
GetHashCode |
getName |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.Equals Method

public override bool Equals(
Object source
);

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.getDisplayName Method

public virtual string getDisplayName();

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.GetHashCode Method

public override int GetHashCode();

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.getName Method

public virtual string getName();

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.maxSecurity Method

public static EncryptionAlgorithm maxSecurity(
EncryptionAlgorithm algA,
EncryptionAlgorithm algB
);

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.MemberwiseClone Method

public override object MemberwiseClone();

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EncryptionAlgorithm.ToString Method

public override string ToString();

See Also

EncryptionAlgorithm Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor Class

For a list of all members of this type, see NetMonitor Members.

System.Object
NetMonitor

public class NetMonitor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.vts.comm

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

NetMonitor Members | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor Members

NetMonitor overview

Public Static Methods

addCacheAgentListener | Registers a listener for ServerCommand events. Event-handlers are triggered when server commands are executed.
addServerCommandListener | Registers a listener for ServerCommand events. Event-handlers are triggered when server commands are executed.
getRunningCommandCount | Gets the total number of server commands currently being executed. <p> Only one server command can be executed per connection at any given time. However, if there are multiple connections used by different threads, the total number of executing commands may be greater than 1.
kill | Turns off the NetMonitor.
on | Turns on the NetMonitor, sending output to the NetMonitor window.
onConsole | Turns on the NetMonitor, sending output to the system console.
onFile | Turns on the NetMonitor, sending output to the given file.
println |
removeCacheAgentListener | Removes a listener for ServerCommand events.
removeServerCommandListener | Removes a listener for ServerCommand events.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor Methods

The methods of the NetMonitor class are listed below. For a complete list of NetMonitor class members, see the NetMonitor Members topic.

Public Static Methods

addCacheAgentListener | Registers a listener for ServerCommand events. Event-handlers are triggered when server commands are executed.
addServerCommandListener | Registers a listener for ServerCommand events. Event-handlers are triggered when server commands are executed.
getRunningCommandCount | Gets the total number of server commands currently being executed. <p> Only one server command can be executed per connection at any given time. However, if there are multiple connections used by different threads, the total number of executing commands may be greater than 1.
kill | Turns off the NetMonitor.
on | Turns on the NetMonitor, sending output to the NetMonitor window.
onConsole | Turns on the NetMonitor, sending output to the system console.
onFile | Turns on the NetMonitor, sending output to the given file.
println |
removeCacheAgentListener | Removes a listener for ServerCommand events.
removeServerCommandListener | Removes a listener for ServerCommand events.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.addCacheAgentListener Method

Registers a listener for ServerCommand events. Event-handlers are triggered when server commands are executed.

public static void addCacheAgentListener(
CacheAgentListener listener
);

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.addServerCommandListener Method

Registers a listener for ServerCommand events. Event-handlers are triggered when server commands are executed.

public static void addServerCommandListener(
ServerCommandListener listener
);

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.getRunningCommandCount Method

Gets the total number of server commands currently being executed. <p> Only one server command can be executed per connection at any given time. However, if there are multiple connections used by different threads, the total number of executing commands may be greater than 1.

public static int getRunningCommandCount();

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.kill Method

Turns off the NetMonitor.

public static void kill();

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.MemberwiseClone Method

public override object MemberwiseClone();

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.on Method

Turns on the NetMonitor, sending output to the NetMonitor window.

public static void on();

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.onConsole Method

Turns on the NetMonitor, sending output to the system console.

public static void onConsole();

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.onFile Method

Turns on the NetMonitor, sending output to the given file.

public static void onFile(
File file
);

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.println Method

public static void println(
String info
);

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.removeCacheAgentListener Method

Removes a listener for ServerCommand events.

public static void removeCacheAgentListener(
CacheAgentListener listener
);

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.removeServerCommandListener Method

Removes a listener for ServerCommand events.

public static void removeServerCommandListener(
ServerCommandListener listener
);

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


NetMonitor.ToString Method

public override string ToString();

See Also

NetMonitor Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandAdapter Class

For a list of all members of this type, see ServerCommandAdapter Members.

System.Object
ServerCommandAdapter

public class ServerCommandAdapter : ServerCommandListener, EventListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.vts.comm

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerCommandAdapter Members | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandAdapter Members

ServerCommandAdapter overview

Public Instance Constructors

ServerCommandAdapter Constructor Initializes a new instance of the ServerCommandAdapter class.

Public Instance Methods

end |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
error |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
start |
ToString |

See Also

ServerCommandAdapter Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandAdapter Constructor

Initializes a new instance of the ServerCommandAdapter class.

public ServerCommandAdapter();

See Also

ServerCommandAdapter Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandAdapter Methods

The methods of the ServerCommandAdapter class are listed below. For a complete list of ServerCommandAdapter class members, see the ServerCommandAdapter Members topic.

Public Instance Methods

end |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
error |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
start |
ToString |

See Also

ServerCommandAdapter Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandAdapter.end Method

public override void end(
ServerCommandEvent e
);

Implements

ServerCommandListener.end

See Also

ServerCommandAdapter Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandAdapter.error Method

public override void error(
ServerCommandEvent e
);

Implements

ServerCommandListener.error

See Also

ServerCommandAdapter Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandAdapter.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ServerCommandAdapter Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandAdapter.start Method

public override void start(
ServerCommandEvent e
);

Implements

ServerCommandListener.start

See Also

ServerCommandAdapter Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandAdapter.ToString Method

public override string ToString();

See Also

ServerCommandAdapter Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent Class

For a list of all members of this type, see ServerCommandEvent Members.

System.Object
EventObject
ServerCommandEvent

public class ServerCommandEvent : EventObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.vts.comm

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerCommandEvent Members | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent Members

ServerCommandEvent overview

Public Instance Fields

source (inherited from java.util.EventObject)

Public Instance Methods

Equals |
getBytesReceived | Gets the total number of bytes returned by the server to the client.
getBytesSent | Gets the total number of bytes sent from the client to the server.
getCommandCount | Gets the number of commands executed in this command session. The command count is incremented at the start of the command. The session id and the command count together uniquely identify a command instance.
getCommandID | Gets the internal ID assigned to this command. Different IDs represent different server functions.
getCommandName | Gets a symbolic name that describes this command ID.
getCommandTime | Gets the total execution time of this command, in milliseconds.
getError |
GetHashCode |
getItemsExpected | For bulk commands that are executed in chunks, gets the total number of items to be processed.
getItemsSoFar | For bulk commands that are executed in chunks, gets the number of items that have been processed so far. <p> Note that isCommandFinished() may return true even if there are more items still to be processed. This occurs when each chunk is implemented as a separate server command. <p> Currently, PROJ_CMD_REFRESH_ITEMS is the only server command for which getItemsSoFar() returns non-zero. Note that isCommandFinished() may return true even if there are more items still to be processed. This is because each chunk is currently executed as a separate command.
GetObjectData (inherited from java.util.EventObject) |
getPendingCommandCount | Gets the total number of server commands currently in progress in this client application. Usually one (for a start event) or zero (for an end event), but may be greater than this if there are other command sessions executing in separate threads.
getPropertyNameBeingFetched | if a property fetch has been triggered, this method returns the name of the property that has triggered the fetch; otherwise it will return null
getServer | returns the server against which this command was issued
getSessionID | Gets a unique id assigned to this command session. The session id and the command count together uniquely identify a command instance.
getSource |
getType | returns the Type of Object associated with this Command, if any or null, if this command is not associated with any specific type
GetType (inherited from Object) | Gets the Type of the current instance.
isCommandFinished | Determines whether or not the execution of this command is starting (a start event) or finishing (an end or error event).
isPropertyFetchTriggered | Returns true if this command triggers a property fetch for a single item This is an indication that the application has not pre-populated the appropriate set of properties for the item(s) at the folder level Failure to do so implies significantly increased server round-trip processing. Applications should rely upon this information for performance improvement purposes only
isSuccessful | Determines whether or not the command terminated normally.
MemberwiseClone |
ToString |

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent Methods

The methods of the ServerCommandEvent class are listed below. For a complete list of ServerCommandEvent class members, see the ServerCommandEvent Members topic.

Public Instance Methods

Equals |
getBytesReceived | Gets the total number of bytes returned by the server to the client.
getBytesSent | Gets the total number of bytes sent from the client to the server.
getCommandCount | Gets the number of commands executed in this command session. The command count is incremented at the start of the command. The session id and the command count together uniquely identify a command instance.
getCommandID | Gets the internal ID assigned to this command. Different IDs represent different server functions.
getCommandName | Gets a symbolic name that describes this command ID.
getCommandTime | Gets the total execution time of this command, in milliseconds.
getError |
GetHashCode |
getItemsExpected | For bulk commands that are executed in chunks, gets the total number of items to be processed.
getItemsSoFar | For bulk commands that are executed in chunks, gets the number of items that have been processed so far. <p> Note that isCommandFinished() may return true even if there are more items still to be processed. This occurs when each chunk is implemented as a separate server command. <p> Currently, PROJ_CMD_REFRESH_ITEMS is the only server command for which getItemsSoFar() returns non-zero. Note that isCommandFinished() may return true even if there are more items still to be processed. This is because each chunk is currently executed as a separate command.
GetObjectData (inherited from java.util.EventObject) |
getPendingCommandCount | Gets the total number of server commands currently in progress in this client application. Usually one (for a start event) or zero (for an end event), but may be greater than this if there are other command sessions executing in separate threads.
getPropertyNameBeingFetched | if a property fetch has been triggered, this method returns the name of the property that has triggered the fetch; otherwise it will return null
getServer | returns the server against which this command was issued
getSessionID | Gets a unique id assigned to this command session. The session id and the command count together uniquely identify a command instance.
getSource |
getType | returns the Type of Object associated with this Command, if any or null, if this command is not associated with any specific type
GetType (inherited from Object) | Gets the Type of the current instance.
isCommandFinished | Determines whether or not the execution of this command is starting (a start event) or finishing (an end or error event).
isPropertyFetchTriggered | Returns true if this command triggers a property fetch for a single item This is an indication that the application has not pre-populated the appropriate set of properties for the item(s) at the folder level Failure to do so implies significantly increased server round-trip processing. Applications should rely upon this information for performance improvement purposes only
isSuccessful | Determines whether or not the command terminated normally.
MemberwiseClone |
ToString |

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.Equals Method

public override bool Equals(
Object source
);

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getBytesReceived Method

Gets the total number of bytes returned by the server to the client.

public virtual long getBytesReceived();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getBytesSent Method

Gets the total number of bytes sent from the client to the server.

public virtual long getBytesSent();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getCommandCount Method

Gets the number of commands executed in this command session. The command count is incremented at the start of the command. The session id and the command count together uniquely identify a command instance.

public virtual int getCommandCount();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getCommandID Method

Gets the internal ID assigned to this command. Different IDs represent different server functions.

public virtual int getCommandID();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getCommandName Method

Gets a symbolic name that describes this command ID.

public virtual string getCommandName();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getCommandTime Method

Gets the total execution time of this command, in milliseconds.

public virtual long getCommandTime();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getError Method

public virtual Throwable getError();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.GetHashCode Method

public override int GetHashCode();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getItemsExpected Method

For bulk commands that are executed in chunks, gets the total number of items to be processed.

public virtual int getItemsExpected();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getItemsSoFar Method

For bulk commands that are executed in chunks, gets the number of items that have been processed so far. <p> Note that isCommandFinished() may return true even if there are more items still to be processed. This occurs when each chunk is implemented as a separate server command. <p> Currently, PROJ_CMD_REFRESH_ITEMS is the only server command for which getItemsSoFar() returns non-zero. Note that isCommandFinished() may return true even if there are more items still to be processed. This is because each chunk is currently executed as a separate command.

public virtual int getItemsSoFar();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getPendingCommandCount Method

Gets the total number of server commands currently in progress in this client application. Usually one (for a start event) or zero (for an end event), but may be greater than this if there are other command sessions executing in separate threads.

public virtual int getPendingCommandCount();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getPropertyNameBeingFetched Method

if a property fetch has been triggered, this method returns the name of the property that has triggered the fetch; otherwise it will return null

public virtual string getPropertyNameBeingFetched();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getServer Method

returns the server against which this command was issued

public virtual Server getServer();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getSessionID Method

Gets a unique id assigned to this command session. The session id and the command count together uniquely identify a command instance.

public virtual int getSessionID();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getSource Method

public override object getSource();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.getType Method

returns the Type of Object associated with this Command, if any or null, if this command is not associated with any specific type

public virtual Type getType();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.isCommandFinished Method

Determines whether or not the execution of this command is starting (a start event) or finishing (an end or error event).

public virtual bool isCommandFinished();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.isPropertyFetchTriggered Method

Returns true if this command triggers a property fetch for a single item This is an indication that the application has not pre-populated the appropriate set of properties for the item(s) at the folder level Failure to do so implies significantly increased server round-trip processing. Applications should rely upon this information for performance improvement purposes only

public virtual bool isPropertyFetchTriggered();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.isSuccessful Method

Determines whether or not the command terminated normally.

public virtual bool isSuccessful();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandEvent.ToString Method

public override string ToString();

See Also

ServerCommandEvent Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandListener Interface

For a list of all members of this type, see ServerCommandListener Members.

public interface ServerCommandListener : EventListener

Types that implement ServerCommandListener

Type | Description
ServerCommandAdapter |

Requirements

Namespace: com.starbase.starteam.vts.comm

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ServerCommandListener Members | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandListener Members

ServerCommandListener overview

Public Instance Methods

end | Triggered whenever a command is issued to a StarTeam server, at the end of each command that terminates normally. <p> If an error occurs during execution of the command, then an error event is triggered instead of an end event.
error | Triggered whenever a command is issued to a StarTeam server, at the end of each command that terminates abnormally.
start | Triggered whenever a command is issued to a StarTeam server, at the start of the command.

See Also

ServerCommandListener Interface | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandListener Methods

The methods of the ServerCommandListener interface are listed below. For a complete list of ServerCommandListener interface members, see the ServerCommandListener Members topic.

Public Instance Methods

end | Triggered whenever a command is issued to a StarTeam server, at the end of each command that terminates normally. <p> If an error occurs during execution of the command, then an error event is triggered instead of an end event.
error | Triggered whenever a command is issued to a StarTeam server, at the end of each command that terminates abnormally.
start | Triggered whenever a command is issued to a StarTeam server, at the start of the command.

See Also

ServerCommandListener Interface | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandListener.end Method

Triggered whenever a command is issued to a StarTeam server, at the end of each command that terminates normally. <p> If an error occurs during execution of the command, then an error event is triggered instead of an end event.

void end(
ServerCommandEvent e
);

See Also

ServerCommandListener Interface | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandListener.error Method

Triggered whenever a command is issued to a StarTeam server, at the end of each command that terminates abnormally.

void error(
ServerCommandEvent e
);

See Also

ServerCommandListener Interface | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ServerCommandListener.start Method

Triggered whenever a command is issued to a StarTeam server, at the start of the command.

void start(
ServerCommandEvent e
);

See Also

ServerCommandListener Interface | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers Class

For a list of all members of this type, see SystemRevisionNumbers Members.

System.Object
SystemRevisionNumbers

public class SystemRevisionNumbers

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.starteam.vts.comm

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SystemRevisionNumbers Members | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers Members

SystemRevisionNumbers overview

Public Static Fields

REV_42 | Obsolete.
REV_CLIENT_STATUS | Obsolete.
REV_CONCURRENT_LICENSES_SUPPORTED | Obsolete.
REV_CORRECTED_REF_MODIFIED_TIME | Obsolete.
REV_FALCON_ADDED_CLIENT_PROPS | Obsolete.
REV_FIRST_5_2_BUILD | Obsolete.
REV_FORWARD_COMPATIBILITY |
REV_GET_SERVER_LOCK | Obsolete.
REV_IDARRAY_STREAMED_AS_INTARRAY | Obsolete.
REV_MODIFIED_CREATE_LINK | Obsolete.
REV_MOVE_FOLDER_DELETE_ABANDONS_VIEWS | Obsolete.
REV_PORTABLE_VTS | Obsolete.
REV_PROTOCOL_TCPIPXML_SUPPORTED | Obsolete.
REV_REPLICATION_SUPPORT | Obsolete.
REV_SECURE_COMMANDS | Obsolete.
REV_SERVER_LICENSE_INFO_SUPPORTED | Obsolete.
REV_SHARE_FLAGS_ADDED | Obsolete.
REV_SHUTDOWN_SUPPORTED | Obsolete.

Public Static Methods

equalOrGreater |
getRevisionName | Obsolete.
getSupportedRevs | Return an array of supported revision levels. index 0 is the most recent (highest) rev level.
isClientManagedStatus | Obsolete.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers Fields

The fields of the SystemRevisionNumbers class are listed below. For a complete list of SystemRevisionNumbers class members, see the SystemRevisionNumbers Members topic.

Public Static Fields

REV_42 | Obsolete.
REV_CLIENT_STATUS | Obsolete.
REV_CONCURRENT_LICENSES_SUPPORTED | Obsolete.
REV_CORRECTED_REF_MODIFIED_TIME | Obsolete.
REV_FALCON_ADDED_CLIENT_PROPS | Obsolete.
REV_FIRST_5_2_BUILD | Obsolete.
REV_FORWARD_COMPATIBILITY |
REV_GET_SERVER_LOCK | Obsolete.
REV_IDARRAY_STREAMED_AS_INTARRAY | Obsolete.
REV_MODIFIED_CREATE_LINK | Obsolete.
REV_MOVE_FOLDER_DELETE_ABANDONS_VIEWS | Obsolete.
REV_PORTABLE_VTS | Obsolete.
REV_PROTOCOL_TCPIPXML_SUPPORTED | Obsolete.
REV_REPLICATION_SUPPORT | Obsolete.
REV_SECURE_COMMANDS | Obsolete.
REV_SERVER_LICENSE_INFO_SUPPORTED | Obsolete.
REV_SHARE_FLAGS_ADDED | Obsolete.
REV_SHUTDOWN_SUPPORTED | Obsolete.

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_42 Field

NOTE: This field is now obsolete.

public const Int16 REV_42 = 63;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_CLIENT_STATUS Field

NOTE: This field is now obsolete.

public const Int16 REV_CLIENT_STATUS = 80;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_CONCURRENT_LICENSES_SUPPORTED Field

NOTE: This field is now obsolete.

public const Int16 REV_CONCURRENT_LICENSES_SUPPORTED = 84;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_CORRECTED_REF_MODIFIED_TIME Field

NOTE: This field is now obsolete.

public const Int16 REV_CORRECTED_REF_MODIFIED_TIME = 82;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_FALCON_ADDED_CLIENT_PROPS Field

NOTE: This field is now obsolete.

public const Int16 REV_FALCON_ADDED_CLIENT_PROPS = 72;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_FIRST_5_2_BUILD Field

NOTE: This field is now obsolete.

public const Int16 REV_FIRST_5_2_BUILD = 80;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_FORWARD_COMPATIBILITY Field

public const Int16 REV_FORWARD_COMPATIBILITY = 100;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_GET_SERVER_LOCK Field

NOTE: This field is now obsolete.

public const Int16 REV_GET_SERVER_LOCK = 76;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_IDARRAY_STREAMED_AS_INTARRAY Field

NOTE: This field is now obsolete.

public const Int16 REV_IDARRAY_STREAMED_AS_INTARRAY = 68;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_MODIFIED_CREATE_LINK Field

NOTE: This field is now obsolete.

public const Int16 REV_MODIFIED_CREATE_LINK = 83;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_MOVE_FOLDER_DELETE_ABANDONS_VIEWS Field

NOTE: This field is now obsolete.

public const Int16 REV_MOVE_FOLDER_DELETE_ABANDONS_VIEWS = 69;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_PORTABLE_VTS Field

NOTE: This field is now obsolete.

public const Int16 REV_PORTABLE_VTS = 67;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_PROTOCOL_TCPIPXML_SUPPORTED Field

NOTE: This field is now obsolete.

public const Int16 REV_PROTOCOL_TCPIPXML_SUPPORTED = 72;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_REPLICATION_SUPPORT Field

NOTE: This field is now obsolete.

public const Int16 REV_REPLICATION_SUPPORT = 79;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_SECURE_COMMANDS Field

NOTE: This field is now obsolete.

public const Int16 REV_SECURE_COMMANDS = 66;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_SERVER_LICENSE_INFO_SUPPORTED Field

NOTE: This field is now obsolete.

public const Int16 REV_SERVER_LICENSE_INFO_SUPPORTED = 73;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_SHARE_FLAGS_ADDED Field

NOTE: This field is now obsolete.

public const Int16 REV_SHARE_FLAGS_ADDED = 71;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.REV_SHUTDOWN_SUPPORTED Field

NOTE: This field is now obsolete.

public const Int16 REV_SHUTDOWN_SUPPORTED = 68;

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers Methods

The methods of the SystemRevisionNumbers class are listed below. For a complete list of SystemRevisionNumbers class members, see the SystemRevisionNumbers Members topic.

Public Static Methods

equalOrGreater |
getRevisionName | Obsolete.
getSupportedRevs | Return an array of supported revision levels. index 0 is the most recent (highest) rev level.
isClientManagedStatus | Obsolete.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.equalOrGreater Method

public static bool equalOrGreater(
Int16 serverRev,
String serverDot,
Int16 revisionLevel,
String dotRevision
);

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.getRevisionName Method

NOTE: This method is now obsolete.

public static string getRevisionName(
Int16 rev
);

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.getSupportedRevs Method

Return an array of supported revision levels. index 0 is the most recent (highest) rev level.

public static short[] getSupportedRevs();

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.isClientManagedStatus Method

NOTE: This method is now obsolete.

public static bool isClientManagedStatus(
Int16 nRevisionLevel
);

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.MemberwiseClone Method

public override object MemberwiseClone();

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SystemRevisionNumbers.ToString Method

public override string ToString();

See Also

SystemRevisionNumbers Class | com.starbase.starteam.vts.comm Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


com.starbase.util

Borland StarTeam SDK for .NET

com.starbase.util Namespace

Namespace hierarchy

Classes

Class | Description
Assert |
Base64 |
Diagnostics |
EOLReader |
FileUtils |
GUID |
ISO8601 |
LineProcessor |
LineReader |
MD5 |
OLEDate |
OLEDateFormat |
OSEnvironment |
Platform |
QuickSort |
Res |
ResIDs |
StreamUtils |
TextInputStream |
UTF8 |
UTF8InputStreamReader |
WorkStationException |
XMLUtils |

Interfaces

Interface | Description
Sortable |
SortCompare |
WorkStationOptions |


Assert Class

For a list of all members of this type, see Assert Members.

System.Object
Assert

public class Assert

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Assert Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert Members

Assert overview

Public Static Methods

argIsTrue |
argNotNull |
internalError | Overloaded.
isTrue |
notNull |
nullArgument | Overloaded.

Public Instance Constructors

Assert Constructor Initializes a new instance of the Assert class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Assert Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert Constructor

Initializes a new instance of the Assert class.

public Assert();

See Also

Assert Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert Methods

The methods of the Assert class are listed below. For a complete list of Assert class members, see the Assert Members topic.

Public Static Methods

argIsTrue |
argNotNull |
internalError | Overloaded.
isTrue |
notNull |
nullArgument | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Assert Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert.argIsTrue Method

public static void argIsTrue(
Boolean expr,
String message
);

See Also

Assert Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert.argNotNull Method

public static void argNotNull(
Object obj,
String message
);

See Also

Assert Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


internalError Method

Borland StarTeam SDK for .NET

Assert.internalError Method

Overload List

public static void internalError(String);

public static void internalError(String,Exception);

See Also

Assert Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert.internalError Method (String)

public static void internalError(
String strContext
);

See Also

Assert Class | com.starbase.util Namespace | Assert.internalError Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert.internalError Method (String, Exception)

public static void internalError(
String strContext,
Exception e
);

See Also

Assert Class | com.starbase.util Namespace | Assert.internalError Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert.isTrue Method

public static void isTrue(
Boolean expr,
String message
);

See Also

Assert Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Assert Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert.notNull Method

public static void notNull(
Object obj,
String message
);

See Also

Assert Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


nullArgument Method

Borland StarTeam SDK for .NET

Assert.nullArgument Method

Overload List

public static void nullArgument(String);

public static void nullArgument(String,String);

See Also

Assert Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert.nullArgument Method (String)

public static void nullArgument(
String strClassName
);

See Also

Assert Class | com.starbase.util Namespace | Assert.nullArgument Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert.nullArgument Method (String, String)

public static void nullArgument(
String strClassName,
String strArgName
);

See Also

Assert Class | com.starbase.util Namespace | Assert.nullArgument Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Assert.ToString Method

public override string ToString();

See Also

Assert Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Base64 Class

For a list of all members of this type, see Base64 Members.

System.Object
Base64

public class Base64

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Base64 Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Base64 Members

Base64 overview

Public Static Methods

decode
decodeAsString
decodeToFile
decodeToStream
encode
encodeBytes

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Base64 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Base64 Methods

The methods of the Base64 class are listed below. For a complete list of Base64 class members, see the Base64 Members topic.

Public Static Methods

decode
decodeAsString
decodeToFile
decodeToStream
encode
encodeBytes

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Base64 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Base64.decode Method

public static sbyte[] decode(
String data
);

See Also

Base64 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Base64.decodeAsString Method

public static string decodeAsString(
String data
);

See Also

Base64 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Base64.decodeToFile Method

public static void decodeToFile(
String data,
File outFile
);

See Also

Base64 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Base64.decodeToStream Method

public static void decodeToStream(
String data,
OutputStream out
);

See Also

Base64 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Base64.encode Method

public static string encode(
SByte[] data
);

See Also

Base64 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Base64.encodeBytes Method

public static sbyte[] encodeBytes(
SByte[] data,
Int32 pos,
Int32 len
);

See Also

Base64 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Base64.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Base64 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Base64.ToString Method

public override string ToString();

See Also

Base64 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Diagnostics Class

For a list of all members of this type, see Diagnostics Members.

System.Object
Diagnostics

public class Diagnostics

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Diagnostics Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Diagnostics Members

Diagnostics overview

Public Static Methods

createBugReport |
getSystemInfo | Returns a detailed string of the current runtime environment. This information includes, total and free memory, the current threads, the Java system properties and size, timestamp and MD5 details for any Java libraries on the classpath.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Diagnostics Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Diagnostics Methods

The methods of the Diagnostics class are listed below. For a complete list of Diagnostics class members, see the Diagnostics Members topic.

Public Static Methods

createBugReport |
getSystemInfo | Returns a detailed string of the current runtime environment. This information includes, total and free memory, the current threads, the Java system properties and size, timestamp and MD5 details for any Java libraries on the classpath.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Diagnostics Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Diagnostics.createBugReport Method

public static string createBugReport(
Throwable err
);

See Also

Diagnostics Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Diagnostics.getSystemInfo Method

Returns a detailed string of the current runtime environment. This information includes, total and free memory, the current threads, the Java system properties and size, timestamp and MD5 details for any Java libraries on the classpath.

public static string getSystemInfo();

See Also

Diagnostics Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Diagnostics.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Diagnostics Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Diagnostics.ToString Method

public override string ToString();

See Also

Diagnostics Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLReader Class

For a list of all members of this type, see EOLReader Members.

System.Object
Reader
LineProcessor
EOLReader

public class EOLReader : LineProcessor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

EOLReader Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLReader Members

EOLReader overview

Public Static Methods

wrap

Public Instance Constructors

EOLReader Constructor

Public Instance Fields

lock (inherited from java.io.Reader)

Public Instance Methods

close (inherited from LineProcessor) |
endofInput |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
mark (inherited from java.io.Reader) |
markSupported (inherited from java.io.Reader) |
MemberwiseClone (inherited from LineProcessor) |
processLine |
read (inherited from LineProcessor) | Overloaded.
read (inherited from java.io.Reader) | Overloaded.
ready (inherited from java.io.Reader) |
reset (inherited from java.io.Reader) |
skip (inherited from java.io.Reader) |
ToString (inherited from LineProcessor) |
unwrap (inherited from LineProcessor) |

See Also

EOLReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLReader Constructor

public EOLReader(
LineReader source,
String newEOL
);

See Also

EOLReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLReader Methods

The methods of the EOLReader class are listed below. For a complete list of EOLReader class members, see the EOLReader Members topic.

Public Static Methods

wrap

Public Instance Methods

close (inherited from LineProcessor) |
endofInput |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
mark (inherited from java.io.Reader) |
markSupported (inherited from java.io.Reader) |
MemberwiseClone (inherited from LineProcessor) |
processLine |
read (inherited from LineProcessor) | Overloaded.
read (inherited from java.io.Reader) | Overloaded.
ready (inherited from java.io.Reader) |
reset (inherited from java.io.Reader) |
skip (inherited from java.io.Reader) |
ToString (inherited from LineProcessor) |
unwrap (inherited from LineProcessor) |

See Also

EOLReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLReader.endofInput Method

public override Reader endofInput();

See Also

EOLReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLReader.Equals Method

public override bool Equals(
Object source
);

See Also

EOLReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLReader.GetHashCode Method

public override int GetHashCode();

See Also

EOLReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLReader.processLine Method

public override Reader processLine(
String line,
Int32 eol
);

See Also

EOLReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


EOLReader.wrap Method

public static EOLReader wrap(
EOLReader arg
);

See Also

EOLReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils Class

For a list of all members of this type, see FileUtils Members.

System.Object
FileUtils

public class FileUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

FileUtils Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils Members

FileUtils overview

Public Static Fields

MAX_FILE_LENGTH | Obsolete.
MAX_FILE_LENGTH_80 |

Public Static Methods

cmp |
condenseFilePaths |
condensePath | Obsolete.
fullyResolvedPath |
getAbsolutePath |
getCanonicalPathName |
getFileLength | Obsolete. Gets the length of the given file.
getFileLengthEx | Gets the length of the given file.
getName |
getParent |
isAbsolute |
isBinary | Returns true if the file is considered to be binary. The definition of binary is that the file has at least one null (0x0) character.
match |
matchesAnyPattern |
matchPatternList |
parsePatternList |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils Fields

The fields of the FileUtils class are listed below. For a complete list of FileUtils class members, see the FileUtils Members topic.

Public Static Fields

MAX_FILE_LENGTH | Obsolete.
MAX_FILE_LENGTH_80 |

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.MAX_FILE_LENGTH Field

NOTE: This field is now obsolete.

public const Int64 MAX_FILE_LENGTH = 2147483647;

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.MAX_FILE_LENGTH_80 Field

public const Int64 MAX_FILE_LENGTH_80 = 2147483647;

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils Methods

The methods of the FileUtils class are listed below. For a complete list of FileUtils class members, see the FileUtils Members topic.

Public Static Methods

cmp |
condenseFilePaths |
condensePath | Obsolete.
fullyResolvedPath |
getAbsolutePath |
getCanonicalPathName |
getFileLength | Obsolete. Gets the length of the given file.
getFileLengthEx | Gets the length of the given file.
getName |
getParent |
isAbsolute |
isBinary | Returns true if the file is considered to be binary. The definition of binary is that the file has at least one null (0x0) character.
match |
matchesAnyPattern |
matchPatternList |
parsePatternList |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.cmp Method

public static long cmp(
File f1,
File f2
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.condenseFilePaths Method

public static string condenseFilePaths(
String parentFolderPath,
String childFolderPath,
Boolean caseSensitive,
String delimiter
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.condensePath Method

NOTE: This method is now obsolete.

public static string condensePath(
String parentFolderPath,
String childFolderPath,
Boolean caseSensitive
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.fullyResolvedPath Method

public static string fullyResolvedPath(
String name,
String pathDelim
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.getAbsolutePath Method

public static string getAbsolutePath(
String path
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.getCanonicalPathName Method

public static string getCanonicalPathName(
String aPathName,
Boolean bCaseSensitive
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.getFileLength Method

NOTE: This method is now obsolete.

Gets the length of the given file.

public static int getFileLength(
File f
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.getFileLengthEx Method

Gets the length of the given file.

public static long getFileLengthEx(
File f
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.getName Method

public static string getName(
String path,
String pathDelim
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.getParent Method

public static string getParent(
String path,
String pathDelim
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.isAbsolute Method

public static bool isAbsolute(
String path
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.isBinary Method

Returns true if the file is considered to be binary. The definition of binary is that the file has at least one null (0x0) character.

public static bool isBinary(
File f
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.match Method

public static bool match(
String pattern,
String file,
Boolean caseSensitive
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.matchesAnyPattern Method

public static bool matchesAnyPattern(
String filename,
String[] patterns,
Boolean caseSensitive
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.matchPatternList Method

public static bool matchPatternList(
String filename,
String patternList,
Boolean caseSensitive
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.MemberwiseClone Method

public override object MemberwiseClone();

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.parsePatternList Method

public static string[] parsePatternList(
String patternList
);

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


FileUtils.ToString Method

public override string ToString();

See Also

FileUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID Class

For a list of all members of this type, see GUID Members.

System.Object
GUID

public class GUID

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

GUID Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID Members

GUID overview

Public Instance Constructors

GUID Overloaded. Initializes a new instance of the GUID class.

Public Instance Methods

byteString |
canonicalFormat | Returns the canonical string representation of this GUID. It will be of the form: 0201a8c0-dc96-68d9-97dc-d968e6000000 Note that this string representation is cached and may be called repeatedly without allocating a new String object for each call.
create |
debugDump |
Equals |
getData |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID Constructor

Initializes a new instance of the GUID class.

Overload List

Initializes a new instance of the GUID class.

public GUID();

public GUID(SByte[]);

public GUID(String);

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID Constructor ()

Initializes a new instance of the GUID class.

public GUID();

See Also

GUID Class | com.starbase.util Namespace | GUID Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID Constructor (SByte[])

public GUID(
SByte[] source
);

See Also

GUID Class | com.starbase.util Namespace | GUID Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID Constructor (String)

public GUID(
String spec
);

See Also

GUID Class | com.starbase.util Namespace | GUID Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID Methods

The methods of the GUID class are listed below. For a complete list of GUID class members, see the GUID Members topic.

Public Instance Methods

byteString |
canonicalFormat | Returns the canonical string representation of this GUID. It will be of the form: 0201a8c0-dc96-68d9-97dc-d968e6000000 Note that this string representation is cached and may be called repeatedly without allocating a new String object for each call.
create |
debugDump |
Equals |
getData |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID.byteString Method

public virtual string byteString();

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID.canonicalFormat Method

Returns the canonical string representation of this GUID. It will be of the form: 0201a8c0-dc96-68d9-97dc-d968e6000000 Note that this string representation is cached and may be called repeatedly without allocating a new String object for each call.

public virtual string canonicalFormat();

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID.create Method

public virtual void create();

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID.debugDump Method

public virtual string debugDump();

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID.Equals Method

public override bool Equals(
Object o
);

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID.getData Method

public virtual sbyte[] getData();

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID.GetHashCode Method

public override int GetHashCode();

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID.MemberwiseClone Method

public override object MemberwiseClone();

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


GUID.ToString Method

public override string ToString();

See Also

GUID Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISO8601 Class

For a list of all members of this type, see ISO8601 Members.

System.Object
ISO8601

public class ISO8601

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ISO8601 Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISO8601 Members

ISO8601 overview

Public Static Methods

parse
toGMTString
toLocalString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ISO8601 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISO8601 Methods

The methods of the ISO8601 class are listed below. For a complete list of ISO8601 class members, see the ISO8601 Members topic.

Public Static Methods

parse
toGMTString
toLocalString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ISO8601 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISO8601.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ISO8601 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISO8601.parse Method

public static long parse(
String spec
);

See Also

ISO8601 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISO8601.toGMTString Method

public static string toGMTString(
Int64 time
);

See Also

ISO8601 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISO8601.toLocalString Method

public static string toLocalString(
Int64 time
);

See Also

ISO8601 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ISO8601.ToString Method

public override string ToString();

See Also

ISO8601 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor Class

For a list of all members of this type, see LineProcessor Members.

System.Object
Reader
LineProcessor
KeywordReader
EOLReader

public class LineProcessor : Reader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LineProcessor Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor Members

LineProcessor overview

Public Instance Constructors

LineProcessor Constructor

Public Instance Fields

lock (inherited from java.io.Reader)

Public Instance Methods

close |
endofInput |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
mark (inherited from java.io.Reader) |
markSupported (inherited from java.io.Reader) |
MemberwiseClone |
processLine |
read | Overloaded.
read (inherited from java.io.Reader) | Overloaded.
ready (inherited from java.io.Reader) |
reset (inherited from java.io.Reader) |
skip (inherited from java.io.Reader) |
ToString |
unwrap |

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor Constructor

public LineProcessor(
LineReader source
);

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor Methods

The methods of the LineProcessor class are listed below. For a complete list of LineProcessor class members, see the LineProcessor Members topic.

Public Instance Methods

close |
endofInput |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
mark (inherited from java.io.Reader) |
markSupported (inherited from java.io.Reader) |
MemberwiseClone |
processLine |
read | Overloaded.
read (inherited from java.io.Reader) | Overloaded.
ready (inherited from java.io.Reader) |
reset (inherited from java.io.Reader) |
skip (inherited from java.io.Reader) |
ToString |
unwrap |

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor.close Method

public override void close();

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor.endofInput Method

public abstract Reader endofInput();

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor.Equals Method

public override bool Equals(
Object source
);

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor.GetHashCode Method

public override int GetHashCode();

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor.processLine Method

public abstract Reader processLine(
String line,
Int32 eol
);

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


read Method

Borland StarTeam SDK for .NET

LineProcessor.read Method

Overload List

Inherited from Reader.

public virtual int read();

Inherited from Reader.

public virtual int read(Char[]);

public override int read(Char[],Int32,Int32);

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor.read Method (Char[], Int32, Int32)

public override int read(
Char[] cbuf,
Int32 off,
Int32 len
);

See Also

LineProcessor Class | com.starbase.util Namespace | LineProcessor.read Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor.ToString Method

public override string ToString();

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineProcessor.unwrap Method

public virtual LineProcessor unwrap();

See Also

LineProcessor Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader Class

For a list of all members of this type, see LineReader Members.

System.Object
Reader
LineReader

public class LineReader : Reader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

LineReader Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader Members

LineReader overview

Public Static Fields

EOL_CR
EOL_CRLF
EOL_EOF
EOL_LF
EOL_UNKNOWN

Public Static Methods

wrap

Public Instance Constructors

LineReader Overloaded. Initializes a new instance of the LineReader class.

Public Instance Fields

lock (inherited from java.io.Reader)

Public Instance Methods

close |
Equals |
GetHashCode |
getLastEOL |
GetType (inherited from Object) | Gets the Type of the current instance.
mark |
markSupported |
MemberwiseClone |
read | Overloaded.
read (inherited from java.io.Reader) | Overloaded.
readLine |
ready |
reset |
skip |
ToString |
unwrap |

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader Constructor

Overload List

public LineReader(Reader);

public LineReader(Reader,Int32);

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader Constructor (Reader, Int32)

public LineReader(
Reader in,
Int32 sz
);

See Also

LineReader Class | com.starbase.util Namespace | LineReader Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader Constructor (Reader)

public LineReader(
Reader in
);

See Also

LineReader Class | com.starbase.util Namespace | LineReader Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader Fields

The fields of the LineReader class are listed below. For a complete list of LineReader class members, see the LineReader Members topic.

Public Static Fields

EOL_CR
EOL_CRLF
EOL_EOF
EOL_LF
EOL_UNKNOWN

Public Instance Fields

lock (inherited from java.io.Reader)

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.EOL_CR Field

public const Int32 EOL_CR = 0;

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.EOL_CRLF Field

public const Int32 EOL_CRLF = 2;

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.EOL_EOF Field

public const Int32 EOL_EOF = 3;

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.EOL_LF Field

public const Int32 EOL_LF = 1;

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.EOL_UNKNOWN Field

public const Int32 EOL_UNKNOWN = -1;

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader Methods

The methods of the LineReader class are listed below. For a complete list of LineReader class members, see the LineReader Members topic.

Public Static Methods

wrap

Public Instance Methods

close |
Equals |
GetHashCode |
getLastEOL |
GetType (inherited from Object) | Gets the Type of the current instance.
mark |
markSupported |
MemberwiseClone |
read | Overloaded.
read (inherited from java.io.Reader) | Overloaded.
readLine |
ready |
reset |
skip |
ToString |
unwrap |

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.close Method

public override void close();

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.Equals Method

public override bool Equals(
Object source
);

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.GetHashCode Method

public override int GetHashCode();

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.getLastEOL Method

public virtual int getLastEOL();

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.mark Method

public override void mark(
Int32 readAheadLimit
);

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.markSupported Method

public override bool markSupported();

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.MemberwiseClone Method

public override object MemberwiseClone();

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


read Method

Borland StarTeam SDK for .NET

LineReader.read Method

Overload List

public override int read();

Inherited from Reader.

public virtual int read(Char[]);

public override int read(Char[],Int32,Int32);

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.read Method ()

public override int read();

See Also

LineReader Class | com.starbase.util Namespace | LineReader.read Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.read Method (Char[], Int32, Int32)

public override int read(
Char[] cbuf,
Int32 off,
Int32 len
);

See Also

LineReader Class | com.starbase.util Namespace | LineReader.read Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.readLine Method

public virtual string readLine();

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.ready Method

public override bool ready();

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.reset Method

public override void reset();

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.skip Method

public override long skip(
Int64 n
);

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.ToString Method

public override string ToString();

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.unwrap Method

public virtual LineReader unwrap();

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


LineReader.wrap Method

public static LineReader wrap(
LineReader arg
);

See Also

LineReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5 Class

For a list of all members of this type, see MD5 Members.

System.Object
MD5

public class MD5

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

MD5 Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5 Members

MD5 overview

Public Instance Constructors

MD5 Overloaded. Initializes a new instance of the MD5 class.

Public Instance Methods

computeBufferMD5 |
computeFileMD5 | Obsolete. Computes the MD5 of the given file.
computeFileMD5Ex | Computes the MD5 of the given file.
computeStreamMD5 | Obsolete. Computes the MD5 of the given input stream.
computeStreamMD5Ex | Computes the MD5 of the given input stream.
Equals |
getData |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setData |
toHexString | Return the a 32-character String equal to the hex equivalent of this MD5 value.
ToString |

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5 Constructor

Overload List

Initializes a new instance of the MD5 class.

public MD5();

public MD5(MD5);

public MD5(SByte[]);

public MD5(String);

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5 Constructor (String)

public MD5(
String stringMD5
);

See Also

MD5 Class | com.starbase.util Namespace | MD5 Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5 Constructor ()

Initializes a new instance of the MD5 class.

public MD5();

See Also

MD5 Class | com.starbase.util Namespace | MD5 Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5 Constructor (SByte[])

public MD5(
SByte[] aSourceBytes
);

See Also

MD5 Class | com.starbase.util Namespace | MD5 Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5 Constructor (MD5)

public MD5(
MD5 aMD5
);

See Also

MD5 Class | com.starbase.util Namespace | MD5 Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5 Methods

The methods of the MD5 class are listed below. For a complete list of MD5 class members, see the MD5 Members topic.

Public Instance Methods

computeBufferMD5 |
computeFileMD5 | Obsolete. Computes the MD5 of the given file.
computeFileMD5Ex | Computes the MD5 of the given file.
computeStreamMD5 | Obsolete. Computes the MD5 of the given input stream.
computeStreamMD5Ex | Computes the MD5 of the given input stream.
Equals |
getData |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
setData |
toHexString | Return the a 32-character String equal to the hex equivalent of this MD5 value.
ToString |

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.computeBufferMD5 Method

public virtual void computeBufferMD5(
SByte[] data
);

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.computeFileMD5 Method

NOTE: This method is now obsolete.

Computes the MD5 of the given file.

public virtual int computeFileMD5(
File file
);

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.computeFileMD5Ex Method

Computes the MD5 of the given file.

public virtual long computeFileMD5Ex(
File file
);

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.computeStreamMD5 Method

NOTE: This method is now obsolete.

Computes the MD5 of the given input stream.

public virtual int computeStreamMD5(
InputStream in
);

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.computeStreamMD5Ex Method

Computes the MD5 of the given input stream.

public virtual long computeStreamMD5Ex(
InputStream in
);

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.Equals Method

public override bool Equals(
Object obj
);

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.getData Method

public virtual sbyte[] getData();

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.GetHashCode Method

public override int GetHashCode();

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.MemberwiseClone Method

public override object MemberwiseClone();

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.setData Method

public virtual void setData(
SByte[] aSource
);

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.toHexString Method

Return the a 32-character String equal to the hex equivalent of this MD5 value.

public virtual string toHexString();

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


MD5.ToString Method

public override string ToString();

See Also

MD5 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate Class

For a list of all members of this type, see OLEDate Members.

System.Object
OLEDate

public class OLEDate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

OLEDate Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate Members

OLEDate overview

Public Static Fields

CURRENT_SERVER_TIME

Public Static Methods

doubleFromLong
longFromDouble
wrap

Public Instance Constructors

OLEDate Overloaded. Initializes a new instance of the OLEDate class.

Public Instance Methods

createDate |
Equals |
getDoubleValue |
GetHashCode |
getLongValue |
GetType (inherited from Object) | Gets the Type of the current instance.
getUTCNoon |
localString |
MemberwiseClone |
toISO8601String |
ToString |
unwrap |

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate Constructor

Initializes a new instance of the OLEDate class.

Overload List

Initializes a new instance of the OLEDate class.

public OLEDate();

public OLEDate(OLEDate);

public OLEDate(Date);

public OLEDate(Double);

public OLEDate(Int64);

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate Constructor ()

Initializes a new instance of the OLEDate class.

public OLEDate();

See Also

OLEDate Class | com.starbase.util Namespace | OLEDate Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate Constructor (Double)

public OLEDate(
Double oletime
);

See Also

OLEDate Class | com.starbase.util Namespace | OLEDate Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate Constructor (Int64)

public OLEDate(
Int64 javatime
);

See Also

OLEDate Class | com.starbase.util Namespace | OLEDate Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate Constructor (Date)

public OLEDate(
Date date
);

See Also

OLEDate Class | com.starbase.util Namespace | OLEDate Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate Constructor (OLEDate)

public OLEDate(
OLEDate oledate
);

See Also

OLEDate Class | com.starbase.util Namespace | OLEDate Constructor Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate Fields

The fields of the OLEDate class are listed below. For a complete list of OLEDate class members, see the OLEDate Members topic.

Public Static Fields

CURRENT_SERVER_TIME

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.CURRENT_SERVER_TIME Field

public static readonly OLEDate CURRENT_SERVER_TIME;

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate Methods

The methods of the OLEDate class are listed below. For a complete list of OLEDate class members, see the OLEDate Members topic.

Public Static Methods

doubleFromLong
longFromDouble
wrap

Public Instance Methods

createDate |
Equals |
getDoubleValue |
GetHashCode |
getLongValue |
GetType (inherited from Object) | Gets the Type of the current instance.
getUTCNoon |
localString |
MemberwiseClone |
toISO8601String |
ToString |
unwrap |

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.createDate Method

public virtual Date createDate();

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.doubleFromLong Method

public static double doubleFromLong(
Int64 val
);

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.Equals Method

public override bool Equals(
Object obj
);

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.getDoubleValue Method

public virtual double getDoubleValue();

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.GetHashCode Method

public override int GetHashCode();

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.getLongValue Method

public virtual long getLongValue();

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.getUTCNoon Method

public virtual OLEDate getUTCNoon();

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.localString Method

public virtual string localString(
Int32 dateFormat,
Int32 timeFormat
);

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.longFromDouble Method

public static long longFromDouble(
Double dbl
);

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.MemberwiseClone Method

public override object MemberwiseClone();

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.toISO8601String Method

public virtual string toISO8601String();

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.ToString Method

public override string ToString();

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.unwrap Method

public virtual DateTime unwrap();

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDate.wrap Method

public static OLEDate wrap(
DateTime arg
);

See Also

OLEDate Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat Class

For a list of all members of this type, see OLEDateFormat Members.

System.Object
OLEDateFormat

public class OLEDateFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

OLEDateFormat Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat Members

OLEDateFormat overview

Public Static Fields

LONG
SHORT

Public Static Methods

getDateInstance |
getDateTimeInstance |
getLocalDateInstance | Returns a platform-dependent version of OLEDateFormat that can be used to create a date string formatted in the style typically found in item display tables.
getLocalDateTimeInstance | Returns a platform-dependent version of OLEDateFormat that can be used to create a date/time string formatted in the style typically found in item display tables.
getTimeInstance |

Public Instance Methods

Equals |
format | Returns a string formatted according to the style(s) passed to the getXxx() method that was used to create the OLEDateFormat.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat Fields

The fields of the OLEDateFormat class are listed below. For a complete list of OLEDateFormat class members, see the OLEDateFormat Members topic.

Public Static Fields

LONG
SHORT

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.LONG Field

public const Int32 LONG = 1;

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.SHORT Field

public const Int32 SHORT = 3;

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat Methods

The methods of the OLEDateFormat class are listed below. For a complete list of OLEDateFormat class members, see the OLEDateFormat Members topic.

Public Static Methods

getDateInstance |
getDateTimeInstance |
getLocalDateInstance | Returns a platform-dependent version of OLEDateFormat that can be used to create a date string formatted in the style typically found in item display tables.
getLocalDateTimeInstance | Returns a platform-dependent version of OLEDateFormat that can be used to create a date/time string formatted in the style typically found in item display tables.
getTimeInstance |

Public Instance Methods

Equals |
format | Returns a string formatted according to the style(s) passed to the getXxx() method that was used to create the OLEDateFormat.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.Equals Method

public override bool Equals(
Object source
);

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.format Method

Returns a string formatted according to the style(s) passed to the getXxx() method that was used to create the OLEDateFormat.

public abstract string format(
OLEDate date
);

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.getDateInstance Method

public static OLEDateFormat getDateInstance(
Int32 style
);

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.getDateTimeInstance Method

public static OLEDateFormat getDateTimeInstance(
Int32 dateStyle,
Int32 timeStyle
);

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.GetHashCode Method

public override int GetHashCode();

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.getLocalDateInstance Method

Returns a platform-dependent version of OLEDateFormat that can be used to create a date string formatted in the style typically found in item display tables.

public static OLEDateFormat getLocalDateInstance();

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.getLocalDateTimeInstance Method

Returns a platform-dependent version of OLEDateFormat that can be used to create a date/time string formatted in the style typically found in item display tables.

public static OLEDateFormat getLocalDateTimeInstance();

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.getTimeInstance Method

public static OLEDateFormat getTimeInstance(
Int32 style
);

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.MemberwiseClone Method

public override object MemberwiseClone();

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OLEDateFormat.ToString Method

public override string ToString();

See Also

OLEDateFormat Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OSEnvironment Class

For a list of all members of this type, see OSEnvironment Members.

System.Object
OSEnvironment

public class OSEnvironment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

OSEnvironment Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OSEnvironment Members

OSEnvironment overview

Public Static Methods

getEnvironmentVariable |
isAvailable | Determines if the needed support for environment variables is working.

Public Instance Constructors

OSEnvironment Constructor Initializes a new instance of the OSEnvironment class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

OSEnvironment Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OSEnvironment Constructor

NOTE: This constructor is now obsolete.

Initializes a new instance of the OSEnvironment class.

public OSEnvironment();

See Also

OSEnvironment Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OSEnvironment Methods

The methods of the OSEnvironment class are listed below. For a complete list of OSEnvironment class members, see the OSEnvironment Members topic.

Public Static Methods

getEnvironmentVariable |
isAvailable | Determines if the needed support for environment variables is working.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

OSEnvironment Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OSEnvironment.getEnvironmentVariable Method

public static string getEnvironmentVariable(
String varName
);

See Also

OSEnvironment Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OSEnvironment.isAvailable Method

Determines if the needed support for environment variables is working.

public static bool isAvailable();

See Also

OSEnvironment Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OSEnvironment.MemberwiseClone Method

public override object MemberwiseClone();

See Also

OSEnvironment Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


OSEnvironment.ToString Method

public override string ToString();

See Also

OSEnvironment Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform Class

For a list of all members of this type, see Platform Members.

System.Object
Platform

public class Platform

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Platform Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform Members

Platform overview

Public Static Fields

ONWINDOWSPROP

Public Static Methods

caseSensitiveFileNames | Returns true if file names are case sensitive.
getEOL | Return the end of line convention.
getFileExecutable |
getFileLastModified | Overloaded. returns the last modified time for the given file via a native platform call
getFilePathDelim | Return file name path delimiter.
getFileWritable |
getHostAddress | Return this machine's host IP Address
getLastModified | Overloaded. returns the last modified time for the given file via a native platform call
getMachineName | Return this machine's name
getOSName | Gets a descriptive name for the operating system.
getSetReadOnlyCmd |
getSetWritableCmd |
getTouchCmd |
getWorkStationID |
getWSOptions |
isDotNET | Determines whether or not we are running in a .NET environment.
isWin32 | Determines whether or not we are running on a Win32 computer. Currently, this is determined from the operating system name. To force the SDK to use Win32 behaviors, set the "onwin32" system property (e.g., -Donwin32=y).
printProps |
setFileExecutable |
setFileLastModified |
setFileWritable |

Public Instance Constructors

Platform Constructor Initializes a new instance of the Platform class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform Constructor

NOTE: This constructor is now obsolete.

Initializes a new instance of the Platform class.

public Platform();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform Fields

The fields of the Platform class are listed below. For a complete list of Platform class members, see the Platform Members topic.

Public Static Fields

ONWINDOWSPROP

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.ONWINDOWSPROP Field

public const String ONWINDOWSPROP = "onwin32";

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform Methods

The methods of the Platform class are listed below. For a complete list of Platform class members, see the Platform Members topic.

Public Static Methods

caseSensitiveFileNames | Returns true if file names are case sensitive.
getEOL | Return the end of line convention.
getFileExecutable |
getFileLastModified | Overloaded. returns the last modified time for the given file via a native platform call
getFilePathDelim | Return file name path delimiter.
getFileWritable |
getHostAddress | Return this machine's host IP Address
getLastModified | Overloaded. returns the last modified time for the given file via a native platform call
getMachineName | Return this machine's name
getOSName | Gets a descriptive name for the operating system.
getSetReadOnlyCmd |
getSetWritableCmd |
getTouchCmd |
getWorkStationID |
getWSOptions |
isDotNET | Determines whether or not we are running in a .NET environment.
isWin32 | Determines whether or not we are running on a Win32 computer. Currently, this is determined from the operating system name. To force the SDK to use Win32 behaviors, set the "onwin32" system property (e.g., -Donwin32=y).
printProps |
setFileExecutable |
setFileLastModified |
setFileWritable |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.caseSensitiveFileNames Method

Returns true if file names are case sensitive.

public static bool caseSensitiveFileNames();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getEOL Method

Return the end of line convention.

public static string getEOL();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getFileExecutable Method

public static bool getFileExecutable(
File file
);

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


getFileLastModified Method

Borland StarTeam SDK for .NET

Platform.getFileLastModified Method

returns the last modified time for the given file via a native platform call

Overload List

returns the last modified time for the given file via a native platform call

public static double getFileLastModified(File);

public static double getFileLastModified(String);

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getFileLastModified Method (File)

returns the last modified time for the given file via a native platform call

public static double getFileLastModified(
File file
);

See Also

Platform Class | com.starbase.util Namespace | Platform.getFileLastModified Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getFileLastModified Method (String)

public static double getFileLastModified(
String fileName
);

See Also

Platform Class | com.starbase.util Namespace | Platform.getFileLastModified Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getFilePathDelim Method

Return file name path delimiter.

public static string getFilePathDelim();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getFileWritable Method

public static bool getFileWritable(
File file
);

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getHostAddress Method

Return this machine's host IP Address

public static string getHostAddress();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


getLastModified Method

Borland StarTeam SDK for .NET

Platform.getLastModified Method

returns the last modified time for the given file via a native platform call

Overload List

returns the last modified time for the given file via a native platform call

public static long getLastModified(File);

public static long getLastModified(String);

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getLastModified Method (File)

returns the last modified time for the given file via a native platform call

public static long getLastModified(
File file
);

See Also

Platform Class | com.starbase.util Namespace | Platform.getLastModified Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getLastModified Method (String)

public static long getLastModified(
String fileName
);

See Also

Platform Class | com.starbase.util Namespace | Platform.getLastModified Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getMachineName Method

Return this machine's name

public static string getMachineName();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getOSName Method

Gets a descriptive name for the operating system.

public static string getOSName();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getSetReadOnlyCmd Method

public static string getSetReadOnlyCmd();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getSetWritableCmd Method

public static string getSetWritableCmd();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getTouchCmd Method

public static string getTouchCmd();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getWorkStationID Method

public static GUID getWorkStationID();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.getWSOptions Method

public static WorkStationOptions getWSOptions();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.isDotNET Method

Determines whether or not we are running in a .NET environment.

public static bool isDotNET();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.isWin32 Method

Determines whether or not we are running on a Win32 computer. Currently, this is determined from the operating system name. To force the SDK to use Win32 behaviors, set the "onwin32" system property (e.g., -Donwin32=y).

public static bool isWin32();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.MemberwiseClone Method

public override object MemberwiseClone();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.printProps Method

public static void printProps();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.setFileExecutable Method

public static void setFileExecutable(
File file,
Boolean executable
);

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.setFileLastModified Method

public static void setFileLastModified(
File file,
Double oletime
);

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.setFileWritable Method

public static void setFileWritable(
File file,
Boolean val
);

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Platform.ToString Method

public override string ToString();

See Also

Platform Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QuickSort Class

For a list of all members of this type, see QuickSort Members.

System.Object
QuickSort

public class QuickSort

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

QuickSort Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QuickSort Members

QuickSort overview

Public Static Methods

sort | This is an implementation of the Quick Sort algorithm.
sortArray |
sortInts |
sortStrings |

Public Instance Constructors

QuickSort Constructor Initializes a new instance of the QuickSort class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

QuickSort Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QuickSort Constructor

NOTE: This constructor is now obsolete.

Initializes a new instance of the QuickSort class.

public QuickSort();

See Also

QuickSort Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QuickSort Methods

The methods of the QuickSort class are listed below. For a complete list of QuickSort class members, see the QuickSort Members topic.

Public Static Methods

sort | This is an implementation of the Quick Sort algorithm.
sortArray |
sortInts |
sortStrings |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

QuickSort Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QuickSort.MemberwiseClone Method

public override object MemberwiseClone();

See Also

QuickSort Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QuickSort.sort Method

This is an implementation of the Quick Sort algorithm.

public static void sort(
Sortable s
);

See Also

QuickSort Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QuickSort.sortArray Method

public static void sortArray(
Object[] a,
SortCompare d
);

See Also

QuickSort Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QuickSort.sortInts Method

public static void sortInts(
Int32[] a
);

See Also

QuickSort Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QuickSort.sortStrings Method

public static void sortStrings(
String[] a
);

See Also

QuickSort Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


QuickSort.ToString Method

public override string ToString();

See Also

QuickSort Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Res Class

For a list of all members of this type, see Res Members.

System.Object
ResIDs
Res

public class Res : ResIDs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Res Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Res Members

Res overview

Public Static Methods

formatKey
getString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from ResIDs) |
ToString (inherited from ResIDs) |

See Also

Res Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Res Methods

The methods of the Res class are listed below. For a complete list of Res class members, see the Res Members topic.

Public Static Methods

formatKey
getString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone (inherited from ResIDs) |
ToString (inherited from ResIDs) |

See Also

Res Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Res.formatKey Method

public static string formatKey(
String key,
Object[] args
);

See Also

Res Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Res.getString Method

public static string getString(
String key
);

See Also

Res Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs Class

For a list of all members of this type, see ResIDs Members.

System.Object
ResIDs
Res

public class ResIDs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

ResIDs Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs Members

ResIDs overview

Public Static Fields

FILE_TOO_LARGE_FMT
LEVELS_LT_ZERO
UNABLE_TO_FIND_WRAP_FMT

Public Instance Constructors

ResIDs Constructor Initializes a new instance of the ResIDs class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ResIDs Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs Constructor

Initializes a new instance of the ResIDs class.

public ResIDs();

See Also

ResIDs Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs Fields

The fields of the ResIDs class are listed below. For a complete list of ResIDs class members, see the ResIDs Members topic.

Public Static Fields

FILE_TOO_LARGE_FMT
LEVELS_LT_ZERO
UNABLE_TO_FIND_WRAP_FMT

See Also

ResIDs Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.FILE_TOO_LARGE_FMT Field

public static readonly String FILE_TOO_LARGE_FMT;

See Also

ResIDs Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.LEVELS_LT_ZERO Field

public static readonly String LEVELS_LT_ZERO;

See Also

ResIDs Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.UNABLE_TO_FIND_WRAP_FMT Field

public static readonly String UNABLE_TO_FIND_WRAP_FMT;

See Also

ResIDs Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs Methods

The methods of the ResIDs class are listed below. For a complete list of ResIDs class members, see the ResIDs Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

ResIDs Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.MemberwiseClone Method

public override object MemberwiseClone();

See Also

ResIDs Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


ResIDs.ToString Method

public override string ToString();

See Also

ResIDs Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sortable Interface

For a list of all members of this type, see Sortable Members.

public interface Sortable

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

Sortable Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sortable Members

Sortable overview

Public Instance Methods

compare |
get |
set |
size | The size of the list.

See Also

Sortable Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sortable Methods

The methods of the Sortable interface are listed below. For a complete list of Sortable interface members, see the Sortable Members topic.

Public Instance Methods

compare |
get |
set |
size | The size of the list.

See Also

Sortable Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sortable.compare Method

int compare(
Object a,
Object b
);

See Also

Sortable Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sortable.get Method

object get(
Int32 index
);

See Also

Sortable Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sortable.set Method

void set(
Int32 index,
Object o
);

See Also

Sortable Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Sortable.size Method

The size of the list.

int size();

See Also

Sortable Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SortCompare Interface

For a list of all members of this type, see SortCompare Members.

public interface SortCompare

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

SortCompare Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SortCompare Members

SortCompare overview

Public Instance Methods

compare

See Also

SortCompare Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SortCompare Methods

The methods of the SortCompare interface are listed below. For a complete list of SortCompare interface members, see the SortCompare Members topic.

Public Instance Methods

compare

See Also

SortCompare Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SortCompare.compare Method

int compare(
Object a,
Object b
);

See Also

SortCompare Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StreamUtils Class

For a list of all members of this type, see StreamUtils Members.

System.Object
StreamUtils

public class StreamUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

StreamUtils Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StreamUtils Members

StreamUtils overview

Public Static Methods

bufferedTransfer | Overloaded.
eatStream | Overloaded.

Public Instance Constructors

StreamUtils Constructor Initializes a new instance of the StreamUtils class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

StreamUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StreamUtils Constructor

Initializes a new instance of the StreamUtils class.

public StreamUtils();

See Also

StreamUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StreamUtils Methods

The methods of the StreamUtils class are listed below. For a complete list of StreamUtils class members, see the StreamUtils Members topic.

Public Static Methods

bufferedTransfer | Overloaded.
eatStream | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

StreamUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


bufferedTransfer Method

Borland StarTeam SDK for .NET

StreamUtils.bufferedTransfer Method

Overload List

public static int bufferedTransfer(InputStream,OutputStream,Int32);

public static int bufferedTransfer(InputStream,OutputStream,Int32,MD5);

See Also

StreamUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StreamUtils.bufferedTransfer Method (InputStream, OutputStream, Int32)

public static int bufferedTransfer(
InputStream from,
OutputStream to,
Int32 buffSize
);

See Also

StreamUtils Class | com.starbase.util Namespace | StreamUtils.bufferedTransfer Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StreamUtils.bufferedTransfer Method (InputStream, OutputStream, Int32, MD5)

public static int bufferedTransfer(
InputStream from,
OutputStream to,
Int32 buffSize,
MD5 aMD5
);

See Also

StreamUtils Class | com.starbase.util Namespace | StreamUtils.bufferedTransfer Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


eatStream Method

Borland StarTeam SDK for .NET

StreamUtils.eatStream Method

Overload List

public static int eatStream(InputStream,Int32);

public static int eatStream(InputStream,Int32,MD5);

See Also

StreamUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StreamUtils.eatStream Method (InputStream, Int32)

public static int eatStream(
InputStream from,
Int32 buffSize
);

See Also

StreamUtils Class | com.starbase.util Namespace | StreamUtils.eatStream Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StreamUtils.eatStream Method (InputStream, Int32, MD5)

public static int eatStream(
InputStream from,
Int32 buffSize,
MD5 aMD5
);

See Also

StreamUtils Class | com.starbase.util Namespace | StreamUtils.eatStream Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StreamUtils.MemberwiseClone Method

public override object MemberwiseClone();

See Also

StreamUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


StreamUtils.ToString Method

public override string ToString();

See Also

StreamUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream Class

For a list of all members of this type, see TextInputStream Members.

System.Object
InputStream
TextInputStream

public class TextInputStream : InputStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

TextInputStream Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream Members

TextInputStream overview

Public Instance Constructors

TextInputStream Constructor

Public Instance Methods

available |
close |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
mark |
markSupported |
MemberwiseClone |
read | Overloaded.
read (inherited from java.io.InputStream) | Overloaded.
reset |
skip |
ToString |

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream Constructor

public TextInputStream(
Reader source
);

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream Methods

The methods of the TextInputStream class are listed below. For a complete list of TextInputStream class members, see the TextInputStream Members topic.

Public Instance Methods

available |
close |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
mark |
markSupported |
MemberwiseClone |
read | Overloaded.
read (inherited from java.io.InputStream) | Overloaded.
reset |
skip |
ToString |

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.available Method

public override int available();

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.close Method

public override void close();

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.Equals Method

public override bool Equals(
Object source
);

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.GetHashCode Method

public override int GetHashCode();

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.mark Method

public override void mark(
Int32 readlimit
);

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.markSupported Method

public override bool markSupported();

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.MemberwiseClone Method

public override object MemberwiseClone();

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


read Method

Borland StarTeam SDK for .NET

TextInputStream.read Method

Overload List

public override int read();

Inherited from InputStream.

public virtual int read(SByte[]);

public override int read(SByte[],Int32,Int32);

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.read Method ()

public override int read();

See Also

TextInputStream Class | com.starbase.util Namespace | TextInputStream.read Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.read Method (SByte[], Int32, Int32)

public override int read(
SByte[] b,
Int32 off,
Int32 len
);

See Also

TextInputStream Class | com.starbase.util Namespace | TextInputStream.read Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.reset Method

public override void reset();

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.skip Method

public override long skip(
Int64 n
);

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


TextInputStream.ToString Method

public override string ToString();

See Also

TextInputStream Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8 Class

For a list of all members of this type, see UTF8 Members.

System.Object
UTF8

public class UTF8

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

UTF8 Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8 Members

UTF8 overview

Public Static Methods

StringToUtf8 |
Utf16ToUtf8 |
Utf8ToString |
Utf8ToUtf16 |
Utf8ToUtf16Char | Returns a single UTF-16 character by reading as many characters as necessary from a given InputStream, which is a stream of UTF-8 bytes.

Public Instance Constructors

UTF8 Constructor Initializes a new instance of the UTF8 class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

UTF8 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8 Constructor

NOTE: This constructor is now obsolete.

Initializes a new instance of the UTF8 class.

public UTF8();

See Also

UTF8 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8 Methods

The methods of the UTF8 class are listed below. For a complete list of UTF8 class members, see the UTF8 Members topic.

Public Static Methods

StringToUtf8 |
Utf16ToUtf8 |
Utf8ToString |
Utf8ToUtf16 |
Utf8ToUtf16Char | Returns a single UTF-16 character by reading as many characters as necessary from a given InputStream, which is a stream of UTF-8 bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

UTF8 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8.MemberwiseClone Method

public override object MemberwiseClone();

See Also

UTF8 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8.StringToUtf8 Method

public static sbyte[] StringToUtf8(
String src
);

See Also

UTF8 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8.ToString Method

public override string ToString();

See Also

UTF8 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8.Utf16ToUtf8 Method

public static int Utf16ToUtf8(
Char[] src,
SByte[] dst
);

See Also

UTF8 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8.Utf8ToString Method

public static string Utf8ToString(
SByte[] src
);

See Also

UTF8 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8.Utf8ToUtf16 Method

public static int Utf8ToUtf16(
SByte[] src,
Char[] dst
);

See Also

UTF8 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8.Utf8ToUtf16Char Method

Returns a single UTF-16 character by reading as many characters as necessary from a given InputStream, which is a stream of UTF-8 bytes.

public static int Utf8ToUtf16Char(
InputStream src
);

See Also

UTF8 Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader Class

For a list of all members of this type, see UTF8InputStreamReader Members.

System.Object
Reader
UTF8InputStreamReader

public class UTF8InputStreamReader : Reader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

UTF8InputStreamReader Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader Members

UTF8InputStreamReader overview

Public Static Methods

wrap

Public Instance Constructors

UTF8InputStreamReader Constructor

Public Instance Fields

lock (inherited from java.io.Reader)

Public Instance Methods

close |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
mark (inherited from java.io.Reader) |
markSupported (inherited from java.io.Reader) |
MemberwiseClone |
read | Overloaded.
read (inherited from java.io.Reader) | Overloaded.
ready (inherited from java.io.Reader) |
reset (inherited from java.io.Reader) |
skip (inherited from java.io.Reader) |
ToString |
unwrap |

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader Constructor

public UTF8InputStreamReader(
InputStream utf8stream
);

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader Methods

The methods of the UTF8InputStreamReader class are listed below. For a complete list of UTF8InputStreamReader class members, see the UTF8InputStreamReader Members topic.

Public Static Methods

wrap

Public Instance Methods

close |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
mark (inherited from java.io.Reader) |
markSupported (inherited from java.io.Reader) |
MemberwiseClone |
read | Overloaded.
read (inherited from java.io.Reader) | Overloaded.
ready (inherited from java.io.Reader) |
reset (inherited from java.io.Reader) |
skip (inherited from java.io.Reader) |
ToString |
unwrap |

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader.close Method

public override void close();

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader.Equals Method

public override bool Equals(
Object source
);

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader.GetHashCode Method

public override int GetHashCode();

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader.MemberwiseClone Method

public override object MemberwiseClone();

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


read Method

Borland StarTeam SDK for .NET

UTF8InputStreamReader.read Method

Overload List

Inherited from Reader.

public virtual int read();

Inherited from Reader.

public virtual int read(Char[]);

public override int read(Char[],Int32,Int32);

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader.read Method (Char[], Int32, Int32)

public override int read(
Char[] cbuf,
Int32 off,
Int32 len
);

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace | UTF8InputStreamReader.read Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader.ToString Method

public override string ToString();

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader.unwrap Method

public virtual UTF8InputStreamReader unwrap();

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


UTF8InputStreamReader.wrap Method

public static UTF8InputStreamReader wrap(
UTF8InputStreamReader arg
);

See Also

UTF8InputStreamReader Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationException Class

For a list of all members of this type, see WorkStationException Members.

System.Object
Exception
Throwable
Exception
RuntimeException
WorkStationException

public class WorkStationException : RuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

WorkStationException Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationException Members

WorkStationException overview

Public Static Methods

wrap

Public Instance Constructors

WorkStationException Constructor

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from java.lang.Throwable) |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

WorkStationException Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationException Constructor

public WorkStationException(
String message
);

See Also

WorkStationException Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationException Methods

The methods of the WorkStationException class are listed below. For a complete list of WorkStationException class members, see the WorkStationException Members topic.

Public Static Methods

wrap

Public Instance Methods

Equals |
fillInStackTrace (inherited from java.lang.Throwable) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode |
getLocalizedMessage (inherited from java.lang.Throwable) |
getMessage (inherited from java.lang.Throwable) |
GetObjectData (inherited from java.lang.Throwable) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
MemberwiseClone |
printStackTrace (inherited from java.lang.Throwable) | Overloaded.
ToString (inherited from java.lang.Throwable) |
unwrap |

See Also

WorkStationException Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationException.Equals Method

public override bool Equals(
Object source
);

See Also

WorkStationException Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationException.GetHashCode Method

public override int GetHashCode();

See Also

WorkStationException Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationException.MemberwiseClone Method

public override object MemberwiseClone();

See Also

WorkStationException Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationException.unwrap Method

public virtual WorkStationException unwrap();

See Also

WorkStationException Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationException.wrap Method

public static WorkStationException wrap(
WorkStationException arg
);

See Also

WorkStationException Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationOptions Interface

For a list of all members of this type, see WorkStationOptions Members.

public interface WorkStationOptions

Types that implement WorkStationOptions

Type | Description
WorkStationOptionsAdapter |

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

WorkStationOptions Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationOptions Members

WorkStationOptions overview

Public Instance Methods

getOption
locationMsg
setOption

See Also

WorkStationOptions Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationOptions Methods

The methods of the WorkStationOptions interface are listed below. For a complete list of WorkStationOptions interface members, see the WorkStationOptions Members topic.

Public Instance Methods

getOption
locationMsg
setOption

See Also

WorkStationOptions Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationOptions.getOption Method

string getOption(
String option
);

See Also

WorkStationOptions Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationOptions.locationMsg Method

string locationMsg();

See Also

WorkStationOptions Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


WorkStationOptions.setOption Method

void setOption(
String option,
String value
);

See Also

WorkStationOptions Interface | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils Class

For a list of all members of this type, see XMLUtils Members.

System.Object
XMLUtils

public class XMLUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: com.starbase.util

Assembly: Borland.StarTeam.Core (in Borland.StarTeam.Core.dll)

See Also

XMLUtils Members | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils Members

XMLUtils overview

Public Static Methods

escape |
isXML | Test to see if a file could be an XML file. Not that the file might have a byte order mark. Supported byte order marks include UTF8, UTF16LE, and UTF16BE. Following the byte order mark the file must start with "<?xml" in order for this method to return true.
writeEscaped | Overloaded.
writeEscapedAttributeValue |

Public Instance Constructors

XMLUtils Constructor Initializes a new instance of the XMLUtils class.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

XMLUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils Constructor

NOTE: This constructor is now obsolete.

Initializes a new instance of the XMLUtils class.

public XMLUtils();

See Also

XMLUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils Methods

The methods of the XMLUtils class are listed below. For a complete list of XMLUtils class members, see the XMLUtils Members topic.

Public Static Methods

escape |
isXML | Test to see if a file could be an XML file. Not that the file might have a byte order mark. Supported byte order marks include UTF8, UTF16LE, and UTF16BE. Following the byte order mark the file must start with "<?xml" in order for this method to return true.
writeEscaped | Overloaded.
writeEscapedAttributeValue |

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MemberwiseClone |
ToString |

See Also

XMLUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils.Equals Method

public override bool Equals(
Object source
);

See Also

XMLUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils.escape Method

public static string escape(
String rawText
);

See Also

XMLUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils.GetHashCode Method

public override int GetHashCode();

See Also

XMLUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils.isXML Method

Test to see if a file could be an XML file. Not that the file might have a byte order mark. Supported byte order marks include UTF8, UTF16LE, and UTF16BE. Following the byte order mark the file must start with "<?xml" in order for this method to return true.

public static bool isXML(
File file
);

See Also

XMLUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils.MemberwiseClone Method

public override object MemberwiseClone();

See Also

XMLUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils.ToString Method

public override string ToString();

See Also

XMLUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


writeEscaped Method

Borland StarTeam SDK for .NET

XMLUtils.writeEscaped Method

NOTE: This method is now obsolete.

Overload List

Obsolete.

public static void writeEscaped(String,BufferedWriter);

public static void writeEscaped(String,Writer);

public static void writeEscaped(String,StringBuffer);

See Also

XMLUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils.writeEscaped Method (String, BufferedWriter)

NOTE: This method is now obsolete.

public static void writeEscaped(
String rawText,
BufferedWriter out
);

See Also

XMLUtils Class | com.starbase.util Namespace | XMLUtils.writeEscaped Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils.writeEscaped Method (String, Writer)

public static void writeEscaped(
String rawText,
Writer out
);

See Also

XMLUtils Class | com.starbase.util Namespace | XMLUtils.writeEscaped Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils.writeEscaped Method (String, StringBuffer)

public static void writeEscaped(
String rawText,
StringBuffer out
);

See Also

XMLUtils Class | com.starbase.util Namespace | XMLUtils.writeEscaped Overload List

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


XMLUtils.writeEscapedAttributeValue Method

public static void writeEscapedAttributeValue(
String rawText,
Writer out
);

See Also

XMLUtils Class | com.starbase.util Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


CacheRef Hierarchy

System.Object
CacheRef
Group
GroupAccount
Label
Property
User
UserAccount

See Also

CacheRef Class | CacheRef Members | Borland.StarTeam Namespace


Borland.StarTeam.DiffHierarchy

Borland StarTeam SDK for .NET

Borland.StarTeam.Diff Hierarchy

System.Object
Borland.StarTeam.Diff.BasicColumnMask ---- Borland.StarTeam.Diff.ColumnMask
Borland.StarTeam.Diff.BasicCompare ---- Borland.StarTeam.Diff.DiffCompare
Borland.StarTeam.Diff.BinaryCompare ---- Borland.StarTeam.Diff.DiffCompare
Borland.StarTeam.Diff.ByteSequence
Borland.StarTeam.Diff.ByteSequenceAdapter ---- Borland.StarTeam.Diff.ByteSequence, com.starbase.diff.ByteSequence
Borland.StarTeam.Diff.CharSequence
Borland.StarTeam.Diff.CharSequenceAdapter ---- Borland.StarTeam.Diff.CharSequence, com.starbase.diff.CharSequence
Borland.StarTeam.Diff.ColumnMask
Borland.StarTeam.Diff.ColumnMaskAdapter ---- Borland.StarTeam.Diff.ColumnMask, com.starbase.diff.ColumnMask
Borland.StarTeam.Diff.DiffCompare
Borland.StarTeam.Diff.DiffCompareAdapter ---- Borland.StarTeam.Diff.DiffCompare, com.starbase.diff.DiffCompare
Borland.StarTeam.Diff.Differ
Borland.StarTeam.Diff.DifferAdapter ---- Borland.StarTeam.Diff.Differ, com.starbase.diff.Differ
Borland.StarTeam.Diff.Edit ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Diff.EditList ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Diff.EditListWriter ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Diff.ConsoleWriter
Borland.StarTeam.Diff.HTMLDiffWriter
Borland.StarTeam.Diff.HTMLTableDiffWriter
Borland.StarTeam.Diff.HTMLInterleavedDiffWriter
Borland.StarTeam.Diff.HTMLStereoDiffWriter
Borland.StarTeam.Diff.IntralineSequence ---- Borland.StarTeam.Diff.Sequence
Borland.StarTeam.Diff.LineIterator ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Diff.ParsedCharSequence ---- Borland.StarTeam.Diff.Sequence
Borland.StarTeam.Diff.Sequence
Borland.StarTeam.Diff.SequenceAdapter ---- Borland.StarTeam.Diff.Sequence, com.starbase.diff.Sequence
Borland.StarTeam.Diff.SharedCharSequence ---- Borland.StarTeam.Diff.CharSequence
Borland.StarTeam.Diff.StarTeamDiff ---- Borland.StarTeam.Diff.Differ
Borland.StarTeam.Diff.StarTeamMerge ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Diff.StringCharSequence ---- Borland.StarTeam.Diff.CharSequence
Borland.StarTeam.Util.ArrayAdapter ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Borland.StarTeam.Diff.ColumnMaskCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Diff.EditCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
System.Exception ---- System.Runtime.Serialization.ISerializable
Borland.StarTeam.Diff.DiffException ---- Borland.StarTeam.Util.JSharp.IWrapper

See Also

Borland.StarTeam.Diff Namespace


SimpleTypedResource Hierarchy

System.Object
TypedResource
SimpleTypedResource
Item
ItemReference
ItemRevision
Project
PromotionModel
PromotionState
TaskDependency
View

See Also

SimpleTypedResource Class | SimpleTypedResource Members | Borland.StarTeam Namespace


ArrayAdapter Hierarchy

System.Object
ArrayAdapter
ACL
BLSLicenseInfoCollection
ChangeRequestCollection
CharacterSetCollection
ColumnInfoCollection
CultureInfoCollection
ColumnMaskCollection
EditCollection
EffectiveACL
EmailAttachmentCollection
EnumeratedValueCollection
EOLFormatCollection
FileCollection
FilterCollection
FolderCollection
GroupAccountCollection
GroupCollection
GroupNodeCollection
GroupSortInfoCollection
HiveInfoCollection
IOExceptionCollection
IPRangeCollection
ItemCollection
ItemReferenceCollection
ItemRevisionCollection
KeywordCollection
LabelCollection
LinkCollection
LogLineCollection
MatchedACECollection
MergePointCollection
NotificationItemCollection
ProjectCollection
PromotionStateCollection
PropertyCollection
PurgeStatusCollection
QueryCollection
QueryNodeCollection
QueryPartCollection
SecurityLogEntryCollection
ServerInfoCollection
TaskDependencyCollection
TypeCollection
UserAccountCollection
UserCollection
EncodingCollection
ViewCollection
ActionOverrideCollection
DifferenceTypeCollection
ItemDifferenceCollection
MergeActionCollection
MergeTypeCollection
ScopeCollection
WorkRecordCollection
XMLAttributeCollection
XMLElementCollection

See Also

ArrayAdapter Class | ArrayAdapter Members | Borland.StarTeam.Util Namespace | IEnumerable | ICollection | IList


Borland.StarTeam.Util.JSharpHierarchy

Borland StarTeam SDK for .NET

Borland.StarTeam.Util.JSharp Hierarchy

System.Object
Borland.StarTeam.Util.JSharp.DateAdapter
Borland.StarTeam.Util.JSharp.EnumerationAdapter ---- Borland.StarTeam.Util.JSharp.IWrapper, java.util.Enumeration, System.Collections.IEnumerator
Borland.StarTeam.Util.JSharp.FileAdapter
Borland.StarTeam.Util.JSharp.FileNotFoundExceptionAdapter
Borland.StarTeam.Util.JSharp.HashtableAdapter
Borland.StarTeam.Util.JSharp.InputStreamAdapter
Borland.StarTeam.Util.JSharp.IOExceptionAdapter
Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.JSharp.IWrapperFactory
Borland.StarTeam.Util.JSharp.LocaleAdapter
Borland.StarTeam.Util.JSharp.OutputStreamAdapter
Borland.StarTeam.Util.JSharp.ReaderAdapter
Borland.StarTeam.Util.JSharp.SByteArrayAdapter
Borland.StarTeam.Util.JSharp.StringBufferAdapter
Borland.StarTeam.Util.JSharp.StringTokenizerAdapter
Borland.StarTeam.Util.JSharp.ThrowableAdapter
Borland.StarTeam.Util.JSharp.Translation
Borland.StarTeam.Util.JSharp.Wrapper
Borland.StarTeam.Util.JSharp.WriterAdapter

See Also

Borland.StarTeam.Util.JSharp Namespace


Borland.StarTeam.UtilHierarchy

Borland StarTeam SDK for .NET

Borland.StarTeam.Util Hierarchy

System.Object
Borland.StarTeam.Util.ArrayAdapter ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Borland.StarTeam.Util.EncodingCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.Base64 ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.Diagnostics ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.Encoding ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.FileUtils ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.GUID ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.ISO8601 ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.LineProcessor ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.EOLReader
Borland.StarTeam.Util.LineReader ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.MD5 ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.OLEDateAdapter
Borland.StarTeam.Util.OSEnvironment ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.Platform ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.UTF8 ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.UTF8InputStreamReader ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.WorkStationOptions
Borland.StarTeam.Util.WorkStationOptionsAdapter ---- Borland.StarTeam.Util.WorkStationOptions, com.starbase.util.WorkStationOptions
Borland.StarTeam.Util.XMLUtils ---- Borland.StarTeam.Util.JSharp.IWrapper
System.Exception ---- System.Runtime.Serialization.ISerializable
Borland.StarTeam.Util.WorkStationException ---- Borland.StarTeam.Util.JSharp.IWrapper

See Also

Borland.StarTeam.Util Namespace


Scope Hierarchy

System.Object
Scope
AnyScope
EveryScope
FolderScope
ItemListScope
ItemTypeScope
ProcessItemScope
RevisionLabelScope

See Also

Scope Class | Scope Members | Borland.StarTeam.Viewcomparemerge Namespace


Borland.StarTeam.ViewcomparemergeHierarchy

Borland StarTeam SDK for .NET

Borland.StarTeam.Viewcomparemerge Hierarchy

System.Object
Borland.StarTeam.TypedResource ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.SimpleTypedResource
Borland.StarTeam.Item ---- Borland.StarTeam.ISecurable, Borland.StarTeam.ISecurableObject
Borland.StarTeam.Folder ---- Borland.StarTeam.ISecurableContainer
Borland.StarTeam.Viewcomparemerge.VCMFolder
Borland.StarTeam.View ---- Borland.StarTeam.ISecurable, Borland.StarTeam.ISecurableContainer, Borland.StarTeam.ISecurableObject
Borland.StarTeam.Viewcomparemerge.MergePreview
Borland.StarTeam.Util.ArrayAdapter ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Borland.StarTeam.Viewcomparemerge.ActionOverrideCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.DifferenceTypeCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.ItemDifferenceCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.MergeActionCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.MergeTypeCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.ScopeCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.ActionOverride ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.DifferenceIterator ---- System.Collections.IEnumerable
Borland.StarTeam.Viewcomparemerge.DifferenceIteratorAdapter ---- Borland.StarTeam.Viewcomparemerge.DifferenceIterator, com.starbase.starteam.viewcomparemerge.DifferenceIterator, System.Collections.IEnumerable
Borland.StarTeam.Viewcomparemerge.DifferenceType ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.FileMergeAdapter ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.Custom3WayMergeAdapter
Borland.StarTeam.Viewcomparemerge.StarTeamFileMergeAdapter
Borland.StarTeam.Viewcomparemerge.VisMergeAdapter
Borland.StarTeam.Viewcomparemerge.WorkstationDefaultMergeAdapter
Borland.StarTeam.Viewcomparemerge.ItemDifference ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.MatchState ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.MergeAction ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.MergeType ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.Options ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.PreviewState ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.Progress ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.Scope ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.AnyScope
Borland.StarTeam.Viewcomparemerge.EveryScope
Borland.StarTeam.Viewcomparemerge.FolderScope
Borland.StarTeam.Viewcomparemerge.ItemListScope
Borland.StarTeam.Viewcomparemerge.ItemTypeScope
Borland.StarTeam.Viewcomparemerge.ProcessItemScope
Borland.StarTeam.Viewcomparemerge.RevisionLabelScope
Borland.StarTeam.Viewcomparemerge.Session ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.SessionState ---- Borland.StarTeam.Util.JSharp.IWrapper
System.Exception ---- System.Runtime.Serialization.ISerializable
Borland.StarTeam.Viewcomparemerge.AmbiguousMatchException ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.FileMergeException ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Viewcomparemerge.PropertyMergeException ---- Borland.StarTeam.Util.JSharp.IWrapper

See Also

Borland.StarTeam.Viewcomparemerge Namespace


Borland.StarTeam.XmlHierarchy

Borland StarTeam SDK for .NET

Borland.StarTeam.Xml Hierarchy

System.Object
Borland.StarTeam.Util.ArrayAdapter ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Borland.StarTeam.Xml.XMLAttributeCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Xml.XMLElementCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Xml.XMLAttribute ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Xml.XMLDocument ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Xml.XMLElement ---- Borland.StarTeam.Util.JSharp.IWrapper
System.Exception ---- System.Runtime.Serialization.ISerializable
Borland.StarTeam.Xml.XMLException ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Xml.XMLParseException

See Also

Borland.StarTeam.Xml Namespace


Borland.StarTeamHierarchy

Borland StarTeam SDK for .NET

Borland.StarTeam Hierarchy

System.Object
Borland.StarTeam.AccessCheckSecLogID ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.AccessRightsManager ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.AccessTestResults ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ACE ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.EffectiveACE
Borland.StarTeam.BLSLicenseInfo ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.BuildNumber ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CacheAgent ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CacheAgentEventSource
Borland.StarTeam.CacheController ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CacheRef ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Group
Borland.StarTeam.GroupAccount
Borland.StarTeam.Label
Borland.StarTeam.Property
Borland.StarTeam.User
Borland.StarTeam.UserAccount
Borland.StarTeam.Catalog ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CheckinEventSource
Borland.StarTeam.CheckinManager ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CheckinOptions ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CheckinPhase ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CheckinProgress ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CheckoutEventSource
Borland.StarTeam.CheckoutManager ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CheckoutOptions ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CheckoutProgress ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ClientApplication ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ClientContext ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ColumnInfo ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ConfigFiles ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ContainerACLSecLogID ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ContentFilter
Borland.StarTeam.ContentFilterAdapter ---- Borland.StarTeam.ContentFilter, com.starbase.starteam.ContentFilter
Borland.StarTeam.DirectoryOverrides ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.EmailAttachment ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.EncryptionAlgorithm ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.EnumeratedValue ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CharacterSet
Borland.StarTeam.EOLFormat
Borland.StarTeam.ProcessItemUsage
Borland.StarTeam.EventHandlerInfo ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.EventHandlerProfile ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.FileBasedStatusManager ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.FileDigest
Borland.StarTeam.FileDigestAdapter ---- Borland.StarTeam.FileDigest, com.starbase.starteam.FileDigest
Borland.StarTeam.FileResult ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.AddResult
Borland.StarTeam.CheckInResult
Borland.StarTeam.CheckOutResult
Borland.StarTeam.FileStream ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.FileSyncInfo
Borland.StarTeam.FileSyncInfoAdapter ---- Borland.StarTeam.FileSyncInfo, com.starbase.starteam.FileSyncInfo
Borland.StarTeam.Filter ---- Borland.StarTeam.ISecurable
Borland.StarTeam.FilterEventSource
Borland.StarTeam.FolderEventSource
Borland.StarTeam.FolderListManager ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.FolderTreeEventSource
Borland.StarTeam.FolderUpdateEventSource
Borland.StarTeam.ForeignRefreshResult ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.GroupNode ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.GroupSortInfo ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.HiveInfo ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.HiveInfo.HiveType ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.HiveManager ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.IPRange ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ISecurable
Borland.StarTeam.ISecurableAdapter ---- Borland.StarTeam.ISecurable, com.starbase.starteam.ISecurable
Borland.StarTeam.ISecurableContainer
Borland.StarTeam.ISecurableContainerAdapter ---- Borland.StarTeam.ISecurableContainer, com.starbase.starteam.ISecurableContainer
Borland.StarTeam.ISecurableObject ---- Borland.StarTeam.ISecurable
Borland.StarTeam.ISecurableObjectAdapter ---- Borland.StarTeam.ISecurable, Borland.StarTeam.ISecurableObject, com.starbase.starteam.ISecurable, com.starbase.starteam.ISecurableObject
Borland.StarTeam.Item.LockType ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ItemBehavior ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ItemEventSource
Borland.StarTeam.ItemIDEventSource
Borland.StarTeam.ItemListAdapter
Borland.StarTeam.ItemListEventSource
Borland.StarTeam.ItemListManager ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ItemsAdapter ---- com.starbase.starteam.Items
Borland.StarTeam.ItemUpdateEventSource
Borland.StarTeam.Keyword
Borland.StarTeam.KeywordAdapter ---- Borland.StarTeam.Keyword, com.starbase.starteam.Keyword
Borland.StarTeam.LabelEventSource
Borland.StarTeam.LicenseUsage ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Link ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.LinkCache ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.LinkEndpoint ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.LinkFactory ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.LinkUpdateEventSource
Borland.StarTeam.LogLine ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.HistoryLine
Borland.StarTeam.MatchedACE ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.MergePoint ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.MPXStatusEventSource
Borland.StarTeam.MyUserAccount ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.NetMonitor ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.NotificationEventSource
Borland.StarTeam.NotificationItem ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ObjectACLSecLogID ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Permission ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ProcessItem ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ProductCodes ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ProjectEventSource
Borland.StarTeam.Property.Types ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.PropertyEnums ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.PropertyNames ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.PurgeControl ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.PurgeStatus ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Query ---- Borland.StarTeam.ISecurable
Borland.StarTeam.QueryEventSource
Borland.StarTeam.QueryNode ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.QueryPart ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.RevisionID ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.RevisionIdentifier
Borland.StarTeam.RevisionIdentifierAdapter ---- Borland.StarTeam.RevisionIdentifier, com.starbase.starteam.RevisionIdentifier
Borland.StarTeam.SecurableContainerAdapter ---- Borland.StarTeam.ISecurableContainer
Borland.StarTeam.SecurityLogEntry ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.SecurityLogEntry.SecurityEventType ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Server ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ServerAdministration ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ServerCommandEventSource
Borland.StarTeam.ServerConfiguration ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ServerControlEventSource
Borland.StarTeam.ServerInfo ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ServerLicenseInfo ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ServerList ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ServerSession
Borland.StarTeam.ServerSessionAdapter ---- Borland.StarTeam.ServerSession, com.starbase.starteam.ServerSession
Borland.StarTeam.SimpleKeyword ---- Borland.StarTeam.Keyword
Borland.StarTeam.HistoryKeyword
Borland.StarTeam.LogKeyword
Borland.StarTeam.NoKeywords
Borland.StarTeam.StarTeamClientOptions ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.StarTeamFinder ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.StarTeamURL ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Status ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.StatusMethod ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.SupportedFeatures ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.SystemPolicy ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.SystemRevisionNumbers ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Translations ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Type ---- Borland.StarTeam.ISecurableContainer
Borland.StarTeam.TypedResource ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.SimpleTypedResource
Borland.StarTeam.Item ---- Borland.StarTeam.ISecurable, Borland.StarTeam.ISecurableObject
Borland.StarTeam.Audit
Borland.StarTeam.ChangeRequest
Borland.StarTeam.File
Borland.StarTeam.Folder ---- Borland.StarTeam.ISecurableContainer
Borland.StarTeam.TreeItem
Borland.StarTeam.Task
Borland.StarTeam.Topic
Borland.StarTeam.ItemReference
Borland.StarTeam.ItemRevision
Borland.StarTeam.Project ---- Borland.StarTeam.ISecurable, Borland.StarTeam.ISecurableContainer, Borland.StarTeam.ISecurableObject
Borland.StarTeam.PromotionModel
Borland.StarTeam.PromotionState ---- Borland.StarTeam.ISecurable, Borland.StarTeam.ISecurableObject
Borland.StarTeam.TaskDependency
Borland.StarTeam.View ---- Borland.StarTeam.ISecurable, Borland.StarTeam.ISecurableContainer, Borland.StarTeam.ISecurableObject
Borland.StarTeam.RecycleBin
Borland.StarTeam.TypeEventSource
Borland.StarTeam.TypeNames ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.UserEventSource
Borland.StarTeam.UserGroupSecLogID ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.ArrayAdapter ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Borland.StarTeam.ACL ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.BLSLicenseInfoCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ChangeRequestCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CharacterSetCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ColumnInfoCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CultureInfoCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.EffectiveACL ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.EmailAttachmentCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.EnumeratedValueCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.EOLFormatCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.FileCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.FilterCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.FolderCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.GroupAccountCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.GroupCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.GroupNodeCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.GroupSortInfoCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.HiveInfoCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.IOExceptionCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.IPRangeCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ItemCollection
Borland.StarTeam.ItemReferenceCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ItemRevisionCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.KeywordCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.LabelCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.LinkCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.LogLineCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.MatchedACECollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.MergePointCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.NotificationItemCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ProjectCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.PromotionStateCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.PropertyCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.PurgeStatusCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.QueryCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.QueryNodeCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.QueryPartCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.SecurityLogEntryCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ServerInfoCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.TaskDependencyCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.TypeCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.UserAccountCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.UserCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ViewCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.WorkRecordCollection ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Util.JSharp.Wrapper
Borland.StarTeam.SDKWrapper
Borland.StarTeam.Util.LineProcessor ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.KeywordReader
Borland.StarTeam.ViewConfiguration ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ViewConfigurationDiffer ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ViewEventSource
Borland.StarTeam.ViewPollingAgent ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.WorkRecord ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.Workstation ---- Borland.StarTeam.Util.JSharp.IWrapper
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Borland.StarTeam.CacheAgentEventSource.Handler
Borland.StarTeam.CheckinEventSource.Handler
Borland.StarTeam.CheckoutEventSource.Handler
Borland.StarTeam.FilterEventSource.Handler
Borland.StarTeam.FolderEventSource.Handler
Borland.StarTeam.FolderTreeEventSource.Handler
Borland.StarTeam.FolderUpdateEventSource.Handler
Borland.StarTeam.ItemEventSource.Handler
Borland.StarTeam.ItemIDEventSource.Handler
Borland.StarTeam.ItemListEventSource.Handler
Borland.StarTeam.ItemUpdateEventSource.Handler
Borland.StarTeam.LabelEventSource.Handler
Borland.StarTeam.LinkUpdateEventSource.Handler
Borland.StarTeam.MPXStatusEventSource.Handler
Borland.StarTeam.NotificationEventSource.Handler
Borland.StarTeam.ProjectEventSource.Handler
Borland.StarTeam.QueryEventSource.Handler
Borland.StarTeam.ServerCommandEventSource.Handler
Borland.StarTeam.ServerControlEventSource.Handler
Borland.StarTeam.TypeEventSource.Handler
Borland.StarTeam.UserEventSource.Handler
Borland.StarTeam.ViewEventSource.Handler
System.EventArgs
Borland.StarTeam.CacheAgentEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CheckinEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CheckoutEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.FilterEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.FolderEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.FolderTreeEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.FolderUpdateEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ItemEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ItemIDEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ItemListEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ItemUpdateEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.LabelEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.LinkUpdateEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.MPXStatusEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.NotificationEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ProjectEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.QueryEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ServerCommandEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ServerControlEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.TypeEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.UserEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ViewEventArgs ---- Borland.StarTeam.Util.JSharp.IWrapper
System.Exception ---- System.Runtime.Serialization.ISerializable
Borland.StarTeam.CommandException ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ConnectionException
Borland.StarTeam.DisembodiedItemException ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.DuplicateServerListEntryException ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.MPXException ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.NoSuchPropertyException ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.PropertyNotWritableException ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.SDKRuntimeException ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.ServerException ---- Borland.StarTeam.Util.JSharp.IWrapper
Borland.StarTeam.CommandAbortedException
Borland.StarTeam.ForeignPasswordException
Borland.StarTeam.ItemNotFoundException
Borland.StarTeam.LogonException
Borland.StarTeam.PasswordExpiredException
Borland.StarTeam.ServerUnavailableException
Borland.StarTeam.TypeNotFoundException ---- Borland.StarTeam.Util.JSharp.IWrapper

See Also

Borland.StarTeam Namespace


com.borland.starteam.utilHierarchy

Borland StarTeam SDK for .NET

com.borland.starteam.util Hierarchy

System.Object
com.borland.starteam.util.Encoding

See Also

com.borland.starteam.util Namespace


com.borland.starteam.xmlHierarchy

Borland StarTeam SDK for .NET

com.borland.starteam.xml Hierarchy

System.Object
com.borland.starteam.xml.XMLAttribute
com.borland.starteam.xml.XMLDocument
com.borland.starteam.xml.XMLElement
System.Exception ---- System.Runtime.Serialization.ISerializable
java.lang.Throwable ---- java.io.Serializable
java.lang.Exception
com.borland.starteam.xml.XMLException
com.borland.starteam.xml.XMLParseException

See Also

com.borland.starteam.xml Namespace


com.starbase.diffHierarchy

Borland StarTeam SDK for .NET

com.starbase.diff Hierarchy

System.Object
com.starbase.diff.BasicColumnMask ---- com.starbase.diff.ColumnMask
com.starbase.diff.BasicCompare ---- com.starbase.diff.DiffCompare
com.starbase.diff.BinaryCompare ---- com.starbase.diff.DiffCompare
com.starbase.diff.ByteSequence
com.starbase.diff.CharSequence
com.starbase.diff.ColumnMask
com.starbase.diff.DiffCompare
com.starbase.diff.Differ
com.starbase.diff.Edit
com.starbase.diff.EditList
com.starbase.diff.EditListWriter
com.starbase.diff.ConsoleWriter
com.starbase.diff.HTMLDiffWriter
com.starbase.diff.HTMLTableDiffWriter
com.starbase.diff.HTMLInterleavedDiffWriter
com.starbase.diff.HTMLStereoDiffWriter
com.starbase.diff.IntralineSequence ---- com.starbase.diff.Sequence
com.starbase.diff.LineIterator
com.starbase.diff.ParsedCharSequence ---- com.starbase.diff.Sequence
com.starbase.diff.Sequence
com.starbase.diff.SharedCharSequence ---- com.starbase.diff.CharSequence
com.starbase.diff.StarTeamDiff ---- com.starbase.diff.Differ
com.starbase.diff.StarTeamMerge
com.starbase.diff.StringCharSequence ---- com.starbase.diff.CharSequence
System.Exception ---- System.Runtime.Serialization.ISerializable
java.lang.Throwable ---- java.io.Serializable
java.lang.Exception
com.starbase.diff.DiffException

See Also

com.starbase.diff Namespace


CacheRef Hierarchy

System.Object
CacheRef
Group
GroupAccount
Label
Property
User
UserAccount

See Also

CacheRef Class | CacheRef Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


SimpleTypedResource Hierarchy

System.Object
CacheRef
NamedCacheRef
TypedResource
SimpleTypedResource
Item
ItemReference
ItemRevision
Project
PromotionModel
PromotionState
TaskDependency
View

See Also

SimpleTypedResource Class | SimpleTypedResource Members | com.starbase.starteam Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


Scope Hierarchy

System.Object
Scope
AnyScope
EveryScope
FolderScope
ItemListScope
ItemTypeScope
ProcessItemScope
RevisionLabelScope

See Also

Scope Class | Scope Members | com.starbase.starteam.viewcomparemerge Namespace

Copyright 2004, Borland Corp.

Generated from assembly Borland.StarTeam.Core [11.0.0.35]


com.starbase.starteam.viewcomparemergeHierarchy

Borland StarTeam SDK for .NET

com.starbase.starteam.viewcomparemerge Hierarchy

System.Object
com.starbase.starteam.viewcomparemerge.ActionOverride
com.starbase.starteam.viewcomparemerge.DifferenceIterator
com.starbase.starteam.viewcomparemerge.DifferenceType
com.starbase.starteam.viewcomparemerge.FileMergeAdapter
com.starbase.starteam.viewcomparemerge.Custom3WayMergeAdapter
com.starbase.starteam.viewcomparemerge.StarTeamFileMergeAdapter
com.starbase.starteam.viewcomparemerge.VisMergeAdapter
com.starbase.starteam.viewcomparemerge.WorkstationDefaultMergeAdapter
com.starbase.starteam.viewcomparemerge.ItemDifference
com.starbase.starteam.viewcomparemerge.MatchState
com.starbase.starteam.viewcomparemerge.MergeAction
com.starbase.starteam.viewcomparemerge.MergeType
com.starbase.starteam.viewcomparemerge.Options
com.starbase.starteam.viewcomparemerge.PreviewState
com.starbase.starteam.viewcomparemerge.Progress
com.starbase.starteam.viewcomparemerge.Scope
com.starbase.starteam.viewcomparemerge.AnyScope
com.starbase.starteam.viewcomparemerge.EveryScope
com.starbase.starteam.viewcomparemerge.FolderScope
com.starbase.starteam.viewcomparemerge.ItemListScope
com.starbase.starteam.viewcomparemerge.ItemTypeScope
com.starbase.starteam.viewcomparemerge.ProcessItemScope
com.starbase.starteam.viewcomparemerge.RevisionLabelScope
com.starbase.starteam.viewcomparemerge.Session
com.starbase.starteam.viewcomparemerge.SessionState
System.Exception ---- System.Runtime.Serialization.ISerializable
java.lang.Throwable ---- java.io.Serializable
java.lang.Exception
java.lang.RuntimeException
com.starbase.starteam.viewcomparemerge.AmbiguousMatchException
com.starbase.starteam.viewcomparemerge.FileMergeException
com.starbase.starteam.viewcomparemerge.PropertyMergeException

See Also

com.starbase.starteam.viewcomparemerge Namespace


com.starbase.starteam.vts.commHierarchy

Borland StarTeam SDK for .NET

com.starbase.starteam.vts.comm Hierarchy

System.Object
com.starbase.starteam.vts.comm.EncryptionAlgorithm
com.starbase.starteam.vts.comm.NetMonitor
com.starbase.starteam.vts.comm.ServerCommandAdapter ---- com.starbase.starteam.vts.comm.ServerCommandListener, java.util.EventListener
com.starbase.starteam.vts.comm.ServerCommandListener ---- java.util.EventListener
com.starbase.starteam.vts.comm.SystemRevisionNumbers
java.util.EventObject ---- java.io.Serializable
com.starbase.starteam.vts.comm.ServerCommandEvent
System.Exception ---- System.Runtime.Serialization.ISerializable
java.lang.Throwable ---- java.io.Serializable
java.lang.Exception
java.lang.RuntimeException
com.starbase.starteam.vts.comm.CommandException
com.starbase.starteam.vts.comm.ConnectionException

See Also

com.starbase.starteam.vts.comm Namespace


com.starbase.starteamHierarchy

Borland StarTeam SDK for .NET

com.starbase.starteam Hierarchy

System.Object
com.starbase.starteam.AccessCheckSecLogID
com.starbase.starteam.AccessRightsManager
com.starbase.starteam.AccessTestResults
com.starbase.starteam.AclEntry
com.starbase.starteam.EffectiveACE
com.starbase.starteam.BLSLicenseInfo
com.starbase.starteam.BuildNumber
com.starbase.starteam.CacheAgent
com.starbase.starteam.CacheAgentAdapter ---- com.starbase.starteam.CacheAgentListener, java.util.EventListener
com.starbase.starteam.CacheAgentListener ---- java.util.EventListener
com.starbase.starteam.CacheController
com.starbase.starteam.CacheRef ---- System.ICloneable
com.starbase.starteam.Group
com.starbase.starteam.GroupAccount
com.starbase.starteam.Label
com.starbase.starteam.Property
com.starbase.starteam.User
com.starbase.starteam.UserAccount
com.starbase.starteam.CheckinListener ---- java.util.EventListener
com.starbase.starteam.CheckinManager
com.starbase.starteam.CheckinOptions
com.starbase.starteam.CheckinPhase
com.starbase.starteam.CheckinProgress
com.starbase.starteam.CheckoutListener ---- java.util.EventListener
com.starbase.starteam.CheckoutManager
com.starbase.starteam.CheckoutOptions
com.starbase.starteam.CheckoutProgress
com.starbase.starteam.ClientApplication
com.starbase.starteam.ClientContext
com.starbase.starteam.ColumnInfo
com.starbase.starteam.ConfigFiles
com.starbase.starteam.ContainerACLSecLogID
com.starbase.starteam.ContentFilter
com.starbase.starteam.DirectoryOverrides
com.starbase.starteam.EmailAttachment
com.starbase.starteam.EnumeratedValue
com.starbase.starteam.CharacterSet
com.starbase.starteam.EOLFormat
com.starbase.starteam.ProcessItemUsage
com.starbase.starteam.EventHandlerInfo
com.starbase.starteam.EventHandlerProfile
com.starbase.starteam.FileBasedStatusManager
com.starbase.starteam.FileDigest
com.starbase.starteam.FileResult
com.starbase.starteam.AddResult
com.starbase.starteam.CheckInResult
com.starbase.starteam.CheckOutResult
com.starbase.starteam.FileStream
com.starbase.starteam.FileSyncInfo
com.starbase.starteam.FilterAdapter ---- com.starbase.starteam.FilterListener, com.starbase.starteam.IFilterQueryListener, java.util.EventListener
com.starbase.starteam.FilterListener ---- com.starbase.starteam.IFilterQueryListener, java.util.EventListener
com.starbase.starteam.FilterQueryAdapter ---- com.starbase.starteam.FilterListener, com.starbase.starteam.IFilterQueryListener, com.starbase.starteam.QueryListener, java.util.EventListener
com.starbase.starteam.FolderAdapter ---- com.starbase.starteam.FolderListener, com.starbase.starteam.IFolderListener, java.util.EventListener
com.starbase.starteam.FolderListener ---- com.starbase.starteam.IFolderListener, java.util.EventListener
com.starbase.starteam.FolderListManager
com.starbase.starteam.FolderTreeAdapter ---- com.starbase.starteam.FolderTreeListener, com.starbase.starteam.IFolderListener, java.util.EventListener
com.starbase.starteam.FolderTreeListener ---- com.starbase.starteam.IFolderListener, java.util.EventListener
com.starbase.starteam.FolderUpdateAdapter ---- com.starbase.starteam.FolderUpdateListener, java.util.EventListener
com.starbase.starteam.FolderUpdateListener ---- java.util.EventListener
com.starbase.starteam.ForeignRefreshResult
com.starbase.starteam.GroupNode
com.starbase.starteam.GroupSortInfo
com.starbase.starteam.HiveInfo
com.starbase.starteam.HiveInfo.HiveType
com.starbase.starteam.HiveManager
com.starbase.starteam.IFilterQueryListener ---- java.util.EventListener
com.starbase.starteam.IFolderListener ---- java.util.EventListener
com.starbase.starteam.IItemListener ---- java.util.EventListener
com.starbase.starteam.ImportUtility
com.starbase.starteam.IPRange
com.starbase.starteam.ISecurable
com.starbase.starteam.ISecurableContainer
com.starbase.starteam.ISecurableObject ---- com.starbase.starteam.ISecurable
com.starbase.starteam.Item.LockType
com.starbase.starteam.ItemAdapter ---- com.starbase.starteam.IItemListener, com.starbase.starteam.ItemListener, java.util.EventListener
com.starbase.starteam.ItemBehavior
com.starbase.starteam.ItemIDAdapter ---- com.starbase.starteam.IItemListener, com.starbase.starteam.ItemIDListener, java.util.EventListener
com.starbase.starteam.ItemIDListener ---- com.starbase.starteam.IItemListener, java.util.EventListener
com.starbase.starteam.ItemList ---- com.starbase.starteam.Items, java.lang.Runnable
com.starbase.starteam.ItemListAdapter ---- com.starbase.starteam.IItemListener, com.starbase.starteam.ItemListListener, java.util.EventListener
com.starbase.starteam.ItemListener ---- com.starbase.starteam.IItemListener, java.util.EventListener
com.starbase.starteam.ItemListListener ---- com.starbase.starteam.IItemListener, java.util.EventListener
com.starbase.starteam.ItemListManager
com.starbase.starteam.Items
com.starbase.starteam.ItemUpdateAdapter ---- com.starbase.starteam.ItemUpdateListener, java.util.EventListener
com.starbase.starteam.ItemUpdateListener ---- java.util.EventListener
com.starbase.starteam.Keyword
com.starbase.starteam.LabelAdapter ---- com.starbase.starteam.LabelListener, java.util.EventListener
com.starbase.starteam.LabelListener ---- java.util.EventListener
com.starbase.starteam.LicenseUsage
com.starbase.starteam.Link
com.starbase.starteam.LinkCache
com.starbase.starteam.LinkEndpoint
com.starbase.starteam.LinkFactory
com.starbase.starteam.LinkUpdateAdapter ---- com.starbase.starteam.LinkUpdateListener, java.util.EventListener
com.starbase.starteam.LinkUpdateListener ---- java.util.EventListener
com.starbase.starteam.LogLine
com.starbase.starteam.HistoryLine
com.starbase.starteam.MatchedACE
com.starbase.starteam.MergePoint
com.starbase.starteam.MPXStatusAdapter ---- com.starbase.starteam.MPXStatusListener, java.util.EventListener
com.starbase.starteam.MPXStatusListener ---- java.util.EventListener
com.starbase.starteam.MyUserAccount
com.starbase.starteam.NotificationAdapter ---- com.starbase.starteam.IItemListener, com.starbase.starteam.NotificationListener, java.util.EventListener
com.starbase.starteam.NotificationItem
com.starbase.starteam.NotificationListener ---- com.starbase.starteam.IItemListener, java.util.EventListener
com.starbase.starteam.ObjectACLSecLogID
com.starbase.starteam.Permission
com.starbase.starteam.ProcessItem
com.starbase.starteam.ProductCodes
com.starbase.starteam.ProjectAdapter ---- com.starbase.starteam.ProjectListener, java.util.EventListener
com.starbase.starteam.ProjectListener ---- java.util.EventListener
com.starbase.starteam.Property.Types
com.starbase.starteam.PropertyEnums
com.starbase.starteam.PropertyNames
com.starbase.starteam.PurgeControl
com.starbase.starteam.PurgeStatus
com.starbase.starteam.QueryAdapter ---- com.starbase.starteam.IFilterQueryListener, com.starbase.starteam.QueryListener, java.util.EventListener
com.starbase.starteam.QueryListener ---- com.starbase.starteam.IFilterQueryListener, java.util.EventListener
com.starbase.starteam.QueryNode
com.starbase.starteam.QueryPart
com.starbase.starteam.ResIDs
com.starbase.starteam.Res
com.starbase.starteam.RevisionID
com.starbase.starteam.RevisionIdentifier
com.starbase.starteam.SecurableContainerAdapter ---- com.starbase.starteam.ISecurableContainer
com.starbase.starteam.SecurityLogEntry
com.starbase.starteam.SecurityLogEntry.SecurityEventType
com.starbase.starteam.Server
com.starbase.starteam.ServerAdministration
com.starbase.starteam.ServerConfiguration
com.starbase.starteam.ServerControlAdapter ---- com.starbase.starteam.ServerControlListener, java.util.EventListener
com.starbase.starteam.ServerControlListener ---- java.util.EventListener
com.starbase.starteam.ServerInfo
com.starbase.starteam.ServerLicenseInfo
com.starbase.starteam.ServerList
com.starbase.starteam.ServerSession
com.starbase.starteam.SimpleKeyword ---- com.starbase.starteam.Keyword
com.starbase.starteam.HistoryKeyword
com.starbase.starteam.LogKeyword
com.starbase.starteam.NoKeywords
com.starbase.starteam.StarTeamClientOptions
com.starbase.starteam.StarTeamFinder
com.starbase.starteam.StarTeamURL
com.starbase.starteam.Status
com.starbase.starteam.StatusMethod
com.starbase.starteam.SupportedFeatures
com.starbase.starteam.SystemPolicy
com.starbase.starteam.Translations
com.starbase.starteam.TypeAdapter ---- com.starbase.starteam.TypeListener, java.util.EventListener
com.starbase.starteam.TypeListener ---- java.util.EventListener
com.starbase.starteam.TypeNames
com.starbase.starteam.UserAdapter ---- com.starbase.starteam.UserListener, java.util.EventListener
com.starbase.starteam.UserGroupSecLogID
com.starbase.starteam.UserListener ---- java.util.EventListener
com.starbase.starteam.ViewAdapter ---- com.starbase.starteam.ViewListener, java.util.EventListener
com.starbase.starteam.ViewConfiguration
com.starbase.starteam.ViewConfigurationDiffer
com.starbase.starteam.ViewListener ---- java.util.EventListener
com.starbase.starteam.ViewPollingAgent
com.starbase.starteam.WorkRecord
com.starbase.starteam.Workstation
java.io.Reader
com.starbase.util.LineProcessor
com.starbase.starteam.KeywordReader
java.util.EventObject ---- java.io.Serializable
com.starbase.starteam.CacheAgentEvent
com.starbase.starteam.CheckinEvent
com.starbase.starteam.CheckoutEvent
com.starbase.starteam.FilterEvent
com.starbase.starteam.FolderEvent
com.starbase.starteam.FolderTreeEvent
com.starbase.starteam.FolderUpdateEvent
com.starbase.starteam.ItemEvent
com.starbase.starteam.ItemIDEvent
com.starbase.starteam.ItemListEvent
com.starbase.starteam.ItemUpdateEvent
com.starbase.starteam.LabelEvent
com.starbase.starteam.LinkUpdateEvent
com.starbase.starteam.MPXStatusEvent
com.starbase.starteam.NotificationEvent
com.starbase.starteam.ProjectEvent
com.starbase.starteam.QueryEvent
com.starbase.starteam.ServerControlEvent
com.starbase.starteam.TypeEvent
com.starbase.starteam.UserEvent
com.starbase.starteam.ViewEvent
System.Exception ---- System.Runtime.Serialization.ISerializable
java.lang.Throwable ---- java.io.Serializable
java.lang.Exception
com.starbase.starteam.DuplicateServerListEntryException
com.starbase.starteam.MPXException
java.lang.RuntimeException
com.starbase.starteam.DisembodiedItemException
com.starbase.starteam.NoSuchPropertyException
com.starbase.starteam.PropertyNotWritableException
com.starbase.starteam.SDKRuntimeException
com.starbase.starteam.ServerException
com.starbase.starteam.CommandAbortedException
com.starbase.starteam.ForeignPasswordException
com.starbase.starteam.ItemNotFoundException
com.starbase.starteam.LogonException
com.starbase.starteam.PasswordExpiredException
com.starbase.starteam.ServerUnavailableException
com.starbase.starteam.TypeNotFoundException

See Also

com.starbase.starteam Namespace


com.starbase.utilHierarchy

Borland StarTeam SDK for .NET

com.starbase.util Hierarchy

System.Object
com.starbase.util.Assert
com.starbase.util.Base64
com.starbase.util.Diagnostics
com.starbase.util.FileUtils
com.starbase.util.GUID
com.starbase.util.ISO8601
com.starbase.util.MD5
com.starbase.util.OLEDate
com.starbase.util.OLEDateFormat
com.starbase.util.OSEnvironment
com.starbase.util.Platform
com.starbase.util.QuickSort
com.starbase.util.ResIDs
com.starbase.util.Res
com.starbase.util.Sortable
com.starbase.util.SortCompare
com.starbase.util.StreamUtils
com.starbase.util.UTF8
com.starbase.util.WorkStationOptions
com.starbase.util.XMLUtils
java.io.InputStream
com.starbase.util.TextInputStream
java.io.Reader
com.starbase.util.LineProcessor
com.starbase.util.EOLReader
com.starbase.util.LineReader
com.starbase.util.UTF8InputStreamReader
System.Exception ---- System.Runtime.Serialization.ISerializable
java.lang.Throwable ---- java.io.Serializable
java.lang.Exception
java.lang.RuntimeException
com.starbase.util.WorkStationException

See Also

com.starbase.util Namespace